Server applicazioni

Il ruolo Server applicazioni nel sistema operativo Windows Server® 2008 consente di installare un server applicazioni che offre un ambiente integrato per la distribuzione e l'esecuzione di applicazioni business personalizzate create con Microsoft .NET Framework 3.0. Il server applicazioni include servizi che supportano applicazioni create per l'utilizzo di COM+, Accodamento messaggi, Servizi Web e Transazioni distribuite.

  • Panoramica del server applicazioni

  • Elenco di controllo: creare, distribuire e gestire siti Web dinamici e applicazioni basate sul Web

  • Elenco di controllo: hosting di applicazioni gestite

  • Elenco di controllo: sviluppare e integrare i servizi Web nell'ambiente esistente

  • Elenco di controllo: avviare i servizi Windows Communication Foundation alla ricezione di un messaggio

  • Elenco di controllo: utilizzare Condivisione porta TCP per consentire a più applicazioni WCF di utilizzare la stessa porta TCP

  • Elenco di controllo: controllare l'esposizione ad applicazioni Enterprise Services critiche

  • Elenco di controllo: Creare applicazioni connesse in un'architettura orientata ai servizi

  • Elenco di controllo: flussi di lavoro e processi aziendali modello

  • Elenco di controllo: attivare il servizio Transazioni distribuite per fornire supporto alle transazioni in tutta la rete

  • Installare e configurare il server applicazioni

  • Gestire il server applicazioni


Panoramica del server applicazioni

Il server applicazioni offre un ambiente integrato per la distribuzione e l'esecuzione di applicazioni business personalizzate create con Microsoft® .NET Framework 3.0. Durante l'installazione del ruolo Server applicazioni, è possibile scegliere servizi che supportano applicazioni create per l'utilizzo di COM+, Accodamento messaggi, Servizi Web e Transazioni distribuite.

Il server applicazioni garantisce ai professionisti IT e agli sviluppatori i vantaggi seguenti:

  • Runtime di base che consente di distribuire e gestire in modo efficace applicazioni business ad alte prestazioni.

  • Ambiente di sviluppo .NET Framework che offre un modello di programmazione semplificato e un modello di esecuzione ad alte prestazioni per applicazioni basate su server. .NET Framework abilita i servizi Web e integra le nuove applicazioni con l'infrastruttura e le applicazioni esistenti.

  • Installazione guidata semplice da usare in cui sono disponibili opzioni per i diversi servizi ruolo e le funzionalità necessarie per eseguire le applicazioni nell'organizzazione.

  • Funzionalità di installazione automatica delle funzionalità per un determinato servizio ruolo.

Opzioni di installazione

Durante l'installazione del ruolo Server applicazioni in un server, è possibile aggiungere il supporto per le opzioni seguenti:

  • Server Web

  • Accesso alla rete COM+

  • Servizio Attivazione processo Windows

  • Condivisione porta TCP

  • Transazioni distribuite

Server Web

Durante l'installazione del ruolo Server applicazioni è possibile aggiungere il servizio ruolo Supporto server Web. Questa opzione consente di installare Internet Information Services (IIS), il server Web incorporato in Windows Server 2008. IIS offre i vantaggi seguenti:

  • Consente al server applicazioni di ospitare servizi o siti Web interni o esterni con contenuto statico o dinamico.

  • Supporta le applicazioni ASP.NET accessibili da un Web browser.

  • Supporta i servizi Web incorporati in ASP.NET o Windows Communication Foundation (WCF).

Accesso alla rete COM+

Durante l'installazione del ruolo Server applicazioni è possibile aggiungere il servizio ruolo Accesso alla rete COM+, che consente di richiamare da postazione remota le applicazioni incorporate e ospitate in COM+ e nei componenti Enterprise Services. Accesso alla rete COM+ è una delle funzionalità di chiamata remota di Windows Server 2008. Nelle applicazioni più recenti la chiamata remota è supportata da WCF.

Servizio Attivazione processo Windows

Durante l'installazione del ruolo Server applicazioni è possibile aggiungere il Servizio Attivazione processo Windows, o WAS, che consente di avviare e arrestare le applicazioni in modo dinamico in base ai messaggi ricevuti in rete tramite protocollo HTTP (Hypertext Transfer Protocol), Accodamento messaggi, TCP e named pipe.

Condivisione porta TCP

Durante l'installazione del ruolo Server applicazioni è possibile aggiungere il servizio ruolo Condivisione porta TCP, che consente a più applicazioni HTTP di utilizzare un'unica porta TCP. Quando questa funzionalità è attivata, più applicazioni WCF possono condividere la stessa porta per ricevere i messaggi in ingresso dalla rete. Il servizio Condivisione porta Net.Tcp accetta le connessioni che utilizzano il protocollo net.tcp e inoltra automaticamente i messaggi in ingresso ai diversi servizi WCF sulla base del loro contenuto. Ciò semplifica la gestione dei server applicazioni nel caso in cui siano in esecuzione più istanze di un'applicazione.

Transazioni distribuite

Durante l'installazione del ruolo Server applicazioni è possibile aggiungere il servizio ruolo Transazioni distribuite, che consente di eseguire con successo transazioni complete che coinvolgono più database ospitati in più computer di una rete.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Elenco di controllo: creare, distribuire e gestire siti Web dinamici e applicazioni basate sul Web

Internet Information Services (IIS) in Windows Server 2008 è un server Web dotato di tutte le funzionalità e di un modello di processo a tolleranza d'errore che aumenta l'affidabilità dei siti e delle applicazioni Web. I servizi per le applicazioni Web sono assicurati da ASP.NET, che si integra direttamente con IIS.

ASP.NET espone un insieme di classi per mettere a disposizione funzionalità complete per la creazione e la distribuzione di applicazioni dinamiche basate sul Web. Grazie a controlli del server riutilizzabili, in ASP.NET è possibile adottare uno stile HTML (Hypertext Markup Language) di programmazione dichiarativa per la creazione di pagine Web complesse con una quantità di codice ridotta.

Attività | Riferimento
Esaminare le funzionalità e le funzioni di Supporto server Web (IIS) per il server applicazioni. Creare ed eseguire siti e servizi Web con HTML e ASP.NET. | Supporto server Web (IIS) per il server applicazioni
Installare il ruolo Server applicazioni nel server utilizzando l'Aggiunta guidata ruoli. Durante l'installazione del server applicazioni selezionare l'opzione Supporto server Web (IIS). | Installare il ruolo Server applicazioni nel server in uso

Ulteriori riferimenti

Installare e configurare il server applicazioni


Elenco di controllo: hosting di applicazioni gestite

In un ambiente caratterizzato da sistemi connessi basati su .NET Framework 3.0, la distribuzione di Application Server Foundation rende possibile l'integrazione semplificata dei sistemi, oltre a facilitare la distribuzione e l'esecuzione delle applicazioni gestite.

Attività | Riferimento
Esaminare le funzionalità e le funzioni di Application Server Foundation. | Panoramica di Application Server Foundation
Installare Application Server Foundation in un solo server tramite l'Aggiunta guidata ruoli. | Installare il ruolo Server applicazioni nel server in uso
Configurare il ruolo Server applicazioni in modo che le applicazioni da eseguire siano supportate. È consigliabile dapprima installare ed eseguire un'applicazione di prova, progettata in modo da utilizzare i servizi ruolo che devono essere configurati, quindi eseguire le applicazioni nell'ambiente di produzione vero e proprio. | Servizi ruolo Server applicazioni

Ulteriori riferimenti

Supporto server Web (IIS) per il server applicazioni

Accesso alla rete COM+ e server applicazioni

Condivisione porta TCP e server applicazioni

Supporto del servizio Attivazione processo Windows per il server applicazioni

Supporto delle transazioni distribuite per il server applicazioni


Elenco di controllo: sviluppare e integrare i servizi Web nell'ambiente esistente

È possibile sviluppare servizi Web scalabili e interoperabili con .NET Framework e successivamente integrare tali servizi Web nell'ambiente esistente con Internet Information Services (IIS). .NET Framework e IIS forniscono la tecnologia comune per sviluppo runtime e server applicazioni che è indispensabile per l'hosting di applicazioni Web.

Ulteriori componenti chiave includono Enterprise Services, ad esempio elaborazione delle transazioni e accodamento dei messaggi, servizi Web, gestione delle applicazioni, servizi di sicurezza, accesso a dati e directory e monitoraggio delle applicazioni.

Attività | Riferimento
Esaminare le funzionalità e le funzioni di Supporto server Web (IIS) per il server applicazioni. Creare servizi Web con .NET Framework e Windows Communication Foundation (WCF). | Supporto server Web (IIS) per il server applicazioni
Installare il ruolo Server applicazioni nel server utilizzando l'Aggiunta guidata ruoli. Durante l'installazione del server applicazioni selezionare l'opzione Supporto server Web (IIS). Quando questa opzione viene selezionata, il server applicazioni installa il supporto server Web preconfigurato con un insieme di impostazioni predefinite consigliate, che creano un ambiente di hosting idoneo alle applicazioni Web e ai servizi Web. | Installare il ruolo Server applicazioni nel server in uso
Se necessario, configurare i servizi ruolo Server applicazioni con il servizio Attivazione processo Windows, in modo da supportare i protocolli di rete elencati come opzioni del servizio Attivazione processo Windows e utilizzati dai servizi WCF nell'ambiente di hosting in uso, ovvero HTTP (Hypertext Transfer Protocol), TCP, named pipe e Accodamento messaggi. | Supporto del servizio Attivazione processo Windows per il server applicazioni

Ulteriori riferimenti

  • Per ulteriori informazioni su ASP.NET, vedere la pagina relativa a Microsoft ASP.NET all'indirizzo http://go.microsoft.com/fwlink/?LinkID=8785.

  • Per ulteriori informazioni su Enterprise Services, vedere la panoramica di Microsoft Enterprise Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81259.

  • Per ulteriori informazioni su WCF, vedere la pagina relativa a Windows Communication Foundation (http://go.microsoft.com/fwlink/?LinkId=81260).

  • Per ulteriori informazioni su WAS, vedere la pagina relativa all'hosting in WAS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81261.


Elenco di controllo: avviare i servizi Windows Communication Foundation alla ricezione di un messaggio

L'adattatore del listener per i diversi protocolli rimane in ascolto dei messaggi in ingresso e notifica il servizio Attivazione processo Windows (WAS) quando è opportuno attivare il processo in cui viene eseguito il processo Windows Communication Foundation (WCF).

Al termine dei servizi WCF, WAS può riciclare il processo e metterlo a disposizione di un altro servizio. In questo modo è possibile ridurre la quantità di risorse di processore e memoria utilizzate ed eseguire più servizi in un solo server.

Installare WAS con i protocolli utilizzati dai servizi WCF, che possono includere HTTP (Hypertext Transfer Protocol), Accodamento messaggi, TCP (Attivazione TCP) e named pipe.

Attività | Riferimento
Esaminare le funzionalità e le funzioni dei servizi ruolo WAS e quindi identificare i protocolli di rete utilizzati dalle applicazioni WCF in uso. I servizi ruolo WAS supportano i protocolli seguenti: HTTP, Accodamento messaggi, TCP (Attivazione TCP) e named pipe. | Supporto del servizio Attivazione processo Windows per il server applicazioni
Ogni applicazione sotto il controllo WAS dispone di un indirizzo URI (Uniform Resource Identifier) che identifica il protocollo di rete utilizzato da WAS per attivare l'applicazione. È necessario attivare i protocolli per ogni singola applicazione. Se il protocollo di rete di un'applicazione è supportato da WAS, installare il ruolo Server applicazioni nel server utilizzando l'Aggiunta guidata ruoli. Durante l'installazione del ruolo Server applicazioni, selezionare i servizi ruolo WAS per l'applicazione e quindi impostare i binding per il protocollo dell'applicazione a livello di sito. | Installare il ruolo Server applicazioni nel server in uso
Se viene selezionata l'opzione che attiva Attivazione TCP, verrà creata una regola delle eccezioni del firewall che aprirà la porta TCP 808. Affinché il Listener TCP possa mettersi in ascolto sulla porta 808, è necessario creare un sito Web predefinito che utilizzi net.tcp. | Classe NetTcpBinding (http://go.microsoft.com/fwlink/?LinkID=93610)
Importante

Se viene selezionata una qualsiasi delle opzioni di attivazione non HTTP, il server applicazioni creerà automaticamente una regola delle eccezioni del firewall che aprirà la porta 808. Dal momento che la regola delle eccezioni del firewall è obbligatoria solo per utilizzare Attivazione TCP, qualora non si intenda utilizzare Attivazione TCP è consigliabile disattivare manualmente la regola delle eccezioni del firewall per la porta 808.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Elenco di controllo: utilizzare Condivisione porta TCP per consentire a più applicazioni WCF di utilizzare la stessa porta TCP

Il servizio Condivisione porta Net.Tcp consente a più servizi Windows Communication Foundation (WCF) che utilizzano il protocollo net.tcp di rimanere in ascolto su una sola porta TCP. La condivisione della porta riduce il numero di eccezioni del firewall necessarie per ospitare i servizi WCF, grazie all'utilizzo comune di porte già aperte.

Attività | Riferimento
L'applicazione deve utilizzare la funzionalità Condivisione porta Net.Tcp. Lo sviluppatore deve scrivere l'applicazione impostando l'utilizzo del binding NetTcpBinding (una Classe .NET 3.0) per connettere le applicazioni WCF. WCF espone la condivisione della porta come opzione configurabile nel binding. | Procedure: Configurare un servizio WCF per la condivisione della porta (http://go.microsoft.com/fwlink/?LinkId=93846)
Esaminare le funzionalità e le funzioni del servizio Condivisione porta Net.Tcp. Quando la condivisione della porta è attivata, è possibile eseguire il servizio più volte senza il rischio di conflitti relativi al numero della porta. | Condivisione porta TCP e server applicazioni
Per attivare la condivisione della porta nel server applicazioni, installare il ruolo Server applicazioni tramite l'Aggiunta guidata ruoli e selezionare il servizio ruolo Condivisione porta TCP. | Installare il ruolo Server applicazioni nel server in uso

Ulteriori riferimenti

  • Installare e configurare il server applicazioni

  • Per ulteriori informazioni su WCF, vedere la pagina relativa a Windows Communication Foundation (http://go.microsoft.com/fwlink/?LinkId=81260).

  • Per ulteriori informazioni su Net.Tcp, vedere la pagina relativa alla Classe NetTcpBinding, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93610.


Elenco di controllo: controllare l'esposizione ad applicazioni Enterprise Services critiche

Le applicazioni Enterprise Services offrono in genere funzionalità critiche di livello intermedio. Se le applicazioni Enterprise Services risiedono nello stesso computer dei processi che le utilizzano, è possibile aggiungere un ulteriore livello di sicurezza, oltre a quello offerto dai controlli di accesso basati sui ruoli, disattivando Accesso alla rete COM+ e impedendo così l'accesso alla rete a tutte le applicazioni Enterprise Services.

Attività | Riferimento
Esaminare le funzionalità e le funzioni del servizio ruolo Accesso alla rete COM+. | Accesso alla rete COM+ e server applicazioni
Se il server applicazioni è stato installato con il servizio ruolo Accesso alla rete COM+ attivato, è possibile disattivare questo servizio ruolo eliminandolo tramite la procedura guidata Rimozione servizi ruolo. | Rimuovere servizi ruolo Server applicazioni

Ulteriori riferimenti

  • Per ulteriori informazioni su Accesso alla rete COM+, vedere la pagina relativa alle novità di COM+ 1.5 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81264.


Elenco di controllo: Creare applicazioni connesse in un'architettura orientata ai servizi

Windows Communication Foundation (WCF) fornisce un framework per la creazione di applicazioni distribuite sicure, affidabili, transazionali e interoperabili. WCF è un'infrastruttura per le comunicazioni basata sull'architettura dei servizi Web.

Il modello di programmazione orientato ai servizi di WCF si basa su Microsoft .NET Framework e unisce una vasta gamma di funzionalità di sistemi distribuiti in un'architettura estensibile e componibile che comprende trasporti, sistemi di sicurezza, modelli di messaggistica, codifiche, topologie di rete e modelli di hosting.

WCF riduce la quantità di codice personalizzato, semplificando lo sviluppo di sistemi connessi.

Attività | Riferimento
Esaminare le funzionalità e le funzioni dei servizi ruolo Server applicazioni che sono sviluppati per supportare le applicazioni connesse e semplificare la comunicazione tramite protocolli di rete. Tali servizi ruolo includono il servizio Attivazione processo di Windows (WAS), Condivisione porta TCP, Accesso alla rete COM+, Transazione distribuita e Supporto server Web (IIS). | Servizi ruolo Server applicazioni
Identificare l'infrastruttura necessaria per connettere le applicazioni e i servizi ruolo Server applicazioni che le supportano. Installare il ruolo Server applicazioni utilizzando l'Aggiunta guidata ruoli con i servizi ruoli appropriati in ogni server che supporta le applicazioni e le risorse partecipanti. | Installare il ruolo Server applicazioni nel server in uso

Ulteriori riferimenti

  • Per ulteriori informazioni su WCF, vedere la pagina relativa a Windows Communication Foundation (http://go.microsoft.com/fwlink/?LinkId=81260).

  • Per ulteriori informazioni su WAS, vedere la pagina relativa all'hosting in WAS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81261.

  • Per ulteriori informazioni sulla condivisione porta Tcp.net, vedere la pagina dedicata a questo argomento all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93614.


Elenco di controllo: flussi di lavoro e processi aziendali modello

Gli sviluppatori possono utilizzare Windows Workflow Foundation (WF) per descrivere processi aziendali e flussi di lavoro di risorse umane o del sistema con un modello semplice, analogo a un diagramma di flusso.

WF supporta un'ampia gamma di scenari, tra cui flusso di lavoro in applicazioni line-of-business, flusso di pagine dell'interfaccia utente, flusso di lavoro incentrato sui documenti, flusso di lavoro di risorse umane, flusso di lavoro composito per applicazioni orientate ai servizi, flusso di lavoro basato su regole business e flusso di lavoro per la gestione dei sistemi.

Dopo la compilazione, il modello può essere eseguito all'interno di qualsiasi processo Windows. In caso di variazione della regola business, sarà possibile applicare gli aggiornamenti al processo in modo dinamico.

Attività | Riferimento
Esaminare le informazioni più aggiornate su WF, modello di programmazione, motore e strumenti che consentono di creare rapidamente applicazioni che supportano il flusso di lavoro in Windows. WF è costituito da uno spazio dei nomi .NET Framework versione 3.0, un modulo dei flussi di lavoro in-process e finestre di progettazione per Microsoft Visual Studio® 2005. | Windows Workflow Foundation Developer Center (http://go.microsoft.com/fwlink/?LinkId=93622)
Imparare a ospitare i flussi di lavoro creati con WF nei servizi Windows Communication Foundation (WCF). | Integrare Windows Workflow Foundation e Windows Communication Foundation (http://go.microsoft.com/fwlink/?LinkId=93621)

Ulteriori riferimenti

  • Per ulteriori informazioni su Windows Workflow Foundation, vedere la pagina dedicata a questo argomento in .NET Framework Developer Center, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93624.


Elenco di controllo: attivare il servizio Transazioni distribuite per fornire supporto alle transazioni in tutta la rete

Un'applicazione che utilizza le transazioni può fornire servizi solidi e affidabili nonostante si verifichino errori a livello di sistema, di processo o di comunicazione. L'utilizzo delle transazioni garantisce che lo stato delle applicazioni e dei dati resterà coerente e che tutti gli aggiornamenti eseguiti sui dati saranno duraturi. Questa semantica delle transazioni viene mantenuta in ogni caso, sia che i dati siano archiviati localmente nell'applicazione, sia che vengano distribuiti in rete.

Per attivare il supporto delle transazioni per le applicazioni e le risorse della rete, è necessario attivare il servizio Transazioni distribuite nel ruolo Server applicazioni.

Attività | Riferimento
Esaminare le funzionalità e le funzioni del supporto delle transazioni distribuite per il server applicazioni. | Supporto delle transazioni distribuite per il server applicazioni
Installare il ruolo Server applicazioni in un server utilizzando l'Aggiunta guidata ruoli. Durante l'installazione del ruolo Server applicazioni, effettuare le selezioni appropriate per il servizio Transazioni distribuite. | Installare il ruolo Server applicazioni nel server in uso
Installare il ruolo Server applicazioni con l'opzione Transazioni distribuite attivata in ogni server che ospita un'applicazione o una risorsa che verrà coinvolta nella transazione distribuita. | Installare il ruolo Server applicazioni nel server in uso

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Installare e configurare il server applicazioni

  • Scegliere un certificato per la crittografia SSL

  • Panoramica di Application Server Foundation

  • Installare il ruolo Server applicazioni nel server in uso

  • Servizi ruolo Server applicazioni

  • Supporto server Web (IIS) per il server applicazioni

  • Accesso alla rete COM+ e server applicazioni

  • Condivisione porta TCP e server applicazioni

  • Supporto del servizio Attivazione processo Windows per il server applicazioni

  • Supporto delle transazioni distribuite per il server applicazioni


Scegliere un certificato per la crittografia SSL

La crittografia SSL (Secure Sockets Layer) assicura maggiore sicurezza per la comunicazione tra i computer client e il supporto del server Web che ospita le applicazioni distribuite, pertanto è consigliabile utilizzare SSL con il server applicazioni.

L'elenco di certificati viene filtrato in base all'utilizzo chiave e all'utilizzo chiave avanzato (EKU, Enhanced Key Usage) appropriato per il tipo di certificato richiesto dal ruolo. Se viene importato un certificato che non soddisfa i requisiti dell'utilizzo chiavi e dell'utilizzo chiavi avanzato, tale certificato non verrà visualizzato nell'elenco in quanto verrà filtrato prima. Per ulteriori informazioni sui certificati e sul loro funzionamento, vedere la pagina dedicata a questo argomento all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93630.

Importante

Se si utilizza la crittografia SSL, è necessario disporre di un certificato di autenticazione SSL. Non è necessario ottenere e installare un altro certificato di autenticazione se questa procedura è già stata completata per l'installazione del supporto server Web per le applicazioni distribuite. Per la procedura di configurazione di SSL in un server Web o un sito Web, vedere la pagina relativa alla configurazione di certificati server in IIS 7.0 (http://go.microsoft.com/fwlink/?LinkID=64327).

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Panoramica di Application Server Foundation

Application Server Foundation è il gruppo di tecnologie che vengono installate per impostazione predefinita quando si installa il ruolo Server applicazioni. In pratica, Application Server Foundation è Microsoft .NET Framework 3.0.

Windows Server 2008 include .NET Framework 2.0, indipendentemente dai ruoli server installati, .NET Framework 2.0 contiene Common Language Runtime (CLR), un ambiente di esecuzione del codice caratterizzato da un elevato grado di protezione, da un sistema di distribuzione dei codice semplificato e dal supporto dell'interoperabilità di più linguaggi. Installando Application Server Foundation si aggiungono le funzionalità di .NET Framework 3.0 alle funzionalità di base di .NET Framework 2.0. Per ulteriori informazioni su .NET Framework 3.0, vedere la pagina dedicata a questo argomento in .NET Framework Developer Center (http://go.microsoft.com/fwlink/?LinkId=81263).

Componenti di Application Server Foundation

I componenti chiave di Application Server Foundation sono i seguenti:

  • Windows Communication Foundation (WCF)

  • Windows Workflow Foundation (WF)

  • Windows Presentation Foundation (WPF)

Ogni componente viene installato come un insieme di librerie e di assembly .NET.

Per le applicazioni basate su server, i componenti più importanti di Application Server Foundation sono WCF e WF. WPF è utilizzato in prevalenza nelle applicazioni basate su client.

WCF

WCF è il modello di programmazione unificato Microsoft che consente di creare applicazioni che utilizzano i servizi Web per comunicare tra di loro, anche definite applicazioni orientate ai servizi. Gli sviluppatori possono utilizzare WCF per creare applicazioni sicure, affidabili, transazionali che si integrano tra più piattaforme e interagiscono con i sistemi e le applicazioni esistenti. Per ulteriori informazioni su WCF, vedere la pagina relativa a Windows Communication Foundation (http://go.microsoft.com/fwlink/?LinkId=81260).

WF

WF è il modulo e il modello di programmazione che consente di creare rapidamente applicazioni che supportano il flusso di lavoro in Windows Server 2008. WF include il supporto sia per il flusso di lavoro di risorse umane, sia per il flusso di lavoro del sistema in un'ampia gamma di scenari, tra cui:

  • Flusso di lavoro nell'ambito di applicazioni line-of-business

  • Flusso di pagine dell'interfaccia utente

  • Flusso di lavoro incentrato sui documenti

  • Flusso di lavoro di risorse umane

  • Flusso di lavoro composito per applicazioni orientate ai servizi

  • Flusso di lavoro basato su regole business

  • Flusso di lavoro per la gestione dei sistemi

WPF

WPF include un modello di programmazione unificato che consente di creare applicazioni Smart Client complesse per Windows. Poiché è un componente di .NET Framework 3.0, WPF viene installato insieme ad Application Server Foundation ma non trova spesso impiego nelle applicazioni basate su server.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Installare il ruolo Server applicazioni nel server in uso

Il server applicazioni offre ai professionisti e agli sviluppatori IT un ambiente integrato per la distribuzione e l'esecuzione di applicazioni business personalizzate, create con Microsoft® .NET Framework 3.0. È possibile scegliere servizi che supportano applicazioni create per l'utilizzo di COM+, Accodamento messaggi, servizi Web e transazioni distribuite.

Per installare il ruolo Server applicazioni

  1. Fare clic sul pulsante Start e quindi scegliere Server Manager.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Scegliere Aggiungi ruoli dal menu Azione.

  4. Verrà visualizzata l'Aggiunta guidata ruoli. Fare clic su Avanti.

  5. Verrà visualizzata la pagina Selezione ruoli server. Selezionare la casella di controllo Server applicazioni e quindi fare clic su Avanti.

  6. Verranno visualizzate alcune informazioni relative al ruolo Server applicazioni. Prendere visione di tali informazioni e quindi fare clic su Avanti.

  7. Nella pagina Selezione ruoli server selezionare i servizi ruolo che sono necessari per eseguire le applicazioni e quindi fare clic su Avanti. Il servizio ruolo predefinito, Application Server Foundation, viene sempre installato in quanto parte integrante del ruolo Server applicazioni.

    Nota

    Per alcuni servizi ruolo è necessario installare funzionalità di supporto o servizi ruolo di altri ruoli. In questo caso è possibile scegliere se installare o non installare le funzionalità o i servizi ruolo richiesti.

  8. Se è obbligatoria l'installazione di una funzionalità di supporto o di un servizio ruolo di un altro ruolo, nelle pagine successive vengono fornite informazioni utili sulla funzionalità o sull'insieme di funzionalità o sul servizio ruolo. Fare clic su Avanti per passare alla pagina Conferma opzioni di installazione.

  9. Fare clic su Installa per avviare l'installazione del ruolo Server applicazioni con le opzioni visualizzate nella pagina. Il processo di installazione può richiedere tempo, a seconda dei servizi ruolo selezionati. Dopo l'avvio del processo di installazione non è necessario alcun input da parte dell'operatore. Al termine del processo di installazione, lo stato dell'installazione verrà visualizzato nella pagina Risultati installazione.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Servizi ruolo Server applicazioni

È possibile che le applicazioni da distribuire richiedano un insieme di servizi di supporto, ad esempio Accodamento messaggi o Transazione distribuita. La sezione dell'Aggiunta guidata ruoli in cui viene aggiunto il ruolo Server applicazioni include una pagina che consente di selezionare i servizi ruolo necessari per eseguire le applicazioni.

Durante l'installazione del server applicazioni è possibile installare i servizi ruolo seguenti (o il supporto per tali servizi):

  • Supporto server Web (IIS): il server applicazioni utilizza il supporto per il server Web tramite IIS (Internet Information Services) per eseguire l'hosting di siti Web interni ed esterni e di servizi Web che comunicano tramite HTTP (Hypertext Transfer Protocol). Ciò include il supporto di applicazioni basate su Microsoft ASP.NET, alle quali è possibile accedere tramite un Web browser. nonché il supporto di servizi Web creati con Windows Communication Foundation (WCF). Per ulteriori informazioni, vedere Supporto server Web (IIS) per il server applicazioni.

  • Accesso alla rete COM+: il server applicazioni utilizza il servizio di accesso alla rete COM+ per eseguire l'hosting e consentire la chiamata remota di applicazioni create con COM+ e i componenti Enterprise Services. Per ulteriori informazioni, vedere Accesso alla rete COM+ e server applicazioni.

  • Condivisione porta TCP: grazie alla condivisione porta TCP, più processi che utilizzano WCF per comunicare possono condividere le stesse porte TCP. Per impostazione predefinita, viene condivisa la porta 808. Per ulteriori informazioni, vedere Condivisione porta TCP e server applicazioni.

  • Supporto servizio Attivazione processo Windows: il server applicazioni utilizza il servizio Attivazione processo Windows (WAS) per richiamare le applicazioni in remoto su una rete che utilizza protocolli quali HTTP, Accodamento messaggi, TCP e named pipe. Per ulteriori informazioni, vedere Supporto del servizio Attivazione processo Windows per il server applicazioni.

  • Transazioni distribuite: grazie alle transazioni distribuite, le transazioni che coinvolgono più database ospitati in più computer della rete possono essere eseguite con successo. Per ulteriori informazioni, vedere Supporto delle transazioni distribuite per il server applicazioni.

Nota

Per alcuni servizi ruolo è necessaria l'installazione di una funzionalità o di un insieme di funzionalità di supporto. In questo caso è possibile scegliere se installare o non installare le funzionalità o l'insieme di funzionalità.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Supporto server Web (IIS) per il server applicazioni

Il processo di installazione del server applicazioni include un'opzione che consente di aggiungere il supporto server Web. Questa opzione consente di installare Internet Information Services (IIS), il server Web incorporato in Windows Server 2008.

È consigliabile installare il supporto server Web se si intende ospitare applicazioni distribuite create in Microsoft ASP.NET, Enterprise Services o Windows Communication Foundation (WCF).

  • Per ulteriori informazioni su Microsoft ASP.NET, vedere la pagina dedicata a questo argomento all'indirizzo http://go.microsoft.com/fwlink/?LinkID=8785.

  • Per ulteriori informazioni su Enterprise Services, vedere la panoramica di Microsoft Enterprise Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81259.

  • Per ulteriori informazioni su WCF, vedere la pagina relativa a Windows Communication Foundation (http://go.microsoft.com/fwlink/?LinkId=81260).

Il server applicazioni consente di installare il supporto server Web preconfigurato con un insieme di impostazioni predefinite consigliate.

IIS 7.0 eseguito in Windows Server 2008 utilizza il servizio Attivazione processo Windows (WAS) per consentire l'attivazione e la comunicazione in rete tramite protocolli diversi da HTTP (Hypertext Transfer Protocol). Si tratta di un ambiente idoneo allo sviluppo e all'hosting dei servizi WCF che comunicano tramite qualsiasi protocollo di rete sia supportato da WCF, inclusi HTTP, TCP, named pipe e Accodamento messaggi. Per ulteriori informazioni su WAS, vedere la pagina relativa all'hosting in WAS (http://go.microsoft.com/fwlink/?LinkId=81261).

L'hosting dei servizi WCF in IIS offre i vantaggi seguenti:

  • Distribuzione e gestione familiari: i servizi WCF ospitati in IIS vengono distribuiti e gestiti come qualsiasi altro tipo di applicazione IIS, incluse applicazioni ASP.NET e servizi Web ASMX.

  • Gestione di integrità e affidabilità: IIS offre funzionalità di attivazione processi, gestione integrità e riciclo che aumentano l'affidabilità delle applicazioni in hosting.

  • Un modello di hosting condiviso: i servizi WCF ospitati in ASP.NET possono sfruttare i vantaggi del modello di hosting condiviso ASP.NET, che consente a più applicazioni di risiedere in un processo di lavoro comune per una migliore densità e scalabilità dei server.

Nota

WCF supporta l'hosting automatico delle applicazioni. Scegliere questa soluzione di hosting se è la più adatta all'ambiente dell'applicazione.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Accesso alla rete COM+ e server applicazioni

Il processo di installazione del ruolo Server applicazioni include un'opzione che consente di attivare Accesso alla rete COM+. Quando Accesso alla rete COM+ è attivato, viene creata una regola delle eccezioni del firewall che apre la porta 135. Nelle sezioni seguenti sono descritte le situazioni in cui è consigliabile attivare Accesso alla rete COM+ e le situazioni in cui non è consigliabile attivare Accesso alla rete COM+.

Attivare Accesso alla rete COM+

  • È consigliabile attivare Accesso alla rete COM+ quando una o alcune delle applicazioni COM+ nel server ricevono chiamate da client o applicazioni che risiedono in computer diversi.

  • Se il prodotto in uso raccoglie i dati delle prestazioni COM+ inviando chiamate remote a un oggetto che tiene traccia delle prestazioni, è necessario attivare Accesso alla rete COM+.

Nota

Attivando Accesso alla rete COM+ nel server applicazioni non si ottiene automaticamente l'accesso alle applicazioni COM+ in remoto. Per garantire che un'applicazione COM+ sia accessibile in remoto, è necessario configurare tale applicazione per l'utilizzo di un endpoint TCP statico.

Disattivare Accesso alla rete COM+

  • Non è consigliabile attivare Accesso alla rete COM+ se tutte le applicazioni che sono ospitate in COM+ nel computer locale ricevono chiamate da altre applicazioni che risiedono nel computer locale, ad esempio una pagina ASP.NET o un flusso di lavoro. In tal caso l'accesso alla rete COM+ non è indispensabile e, lasciando disattivata l'opzione Accesso alla rete COM+, è possibile circoscrivere la superficie di attacco.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni

  • Per ulteriori informazioni su Accesso alla rete COM+, vedere la pagina relativa alle novità di COM+ 1.5 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81264.

  • Per ulteriori informazioni sulla configurazione di un'applicazione COM+ per l'utilizzo di un endpoint TCP statico, vedere la pagina dedicata alla risoluzione dei problemi relativi all'impostazione di un endpoint fisso per un'applicazione COM+, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93633.

  • Per ulteriori informazioni su COM+, vedere la pagina relativa a COM+ (Servizi componenti) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93848.

  • Per ulteriori informazioni sulla sicurezza e le applicazioni Web, vedere la pagina relativa alla sicurezza del server applicazioni all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94263.


Condivisione porta TCP e server applicazioni

Il processo di installazione del ruolo Server applicazioni include un'opzione che consente di attivare Condivisione porta TCP. Il servizio Condivisione porta Net.Tcp, un nuovo componente del sistema che fa parte di Windows Communication Foundation (WCF), attiva Condivisione porta TCP.

Le applicazioni possono utilizzare il protocollo TCP per comunicare su reti private o pubbliche. Più applicazioni in uno stesso computer possono comunicare utilizzando il protocollo TCP. Grazie un numero a 16 bit, definito porta, il protocollo TCP/IP può differenziare le connessioni a più applicazioni della rete che sono eseguite nello stesso computer. Se un'applicazione è in ascolto su una porta, tutto il traffico TCP destinato a quella porta arriverà a quell'applicazione, mentre le altre applicazioni non potranno mettersi in ascolto sulla stessa porta nello stesso momento.

La funzionalità Condivisione porta Net.Tcp semplifica la condivisione delle porte TCP da parte di più processi che comunicano utilizzando WCF. Quando un servizio WCF che utilizza la condivisione della porta net.tcp:// si apre, l'infrastruttura di trasporto TCP del servizio WCF non apre direttamente un socket TCP nel processo dell'applicazione, bensì registra l'indirizzo URI (Uniform Resource Identifier) di base del servizio presso il servizio di condivisione porta Net.Tcp e attende che quest'ultimo rimanga in ascolto dei messaggi al suo posto. I messaggi indirizzati al servizio dell'applicazione vengono recapitati dal servizio di condivisione porta a mano a mano che arrivano.

Il servizio di condivisione porta Net.Tcp è trasparente per le applicazioni remote che inviano i messaggi, ovvero le applicazioni remote non sono necessariamente a conoscenza del fatto che la porta Net.Tcp è condivisa.

Come misura precauzionale, il servizio di condivisione porta Net.Tcp non è attivato per impostazione predefinita. Per attivarlo, selezionare la casella di controllo Condivisione porta TCP nella pagina Selezione servizi ruolo durante l'installazione del server applicazioni.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Supporto del servizio Attivazione processo Windows per il server applicazioni

Il processo di installazione del ruolo Server applicazioni include un'opzione per la selezione del servizio Attivazione processo Windows (WAS) per applicazioni create con Windows Communication Foundation (WCF). Installando WAS, viene installato anche il ruolo Server Web (IIS).

WAS è un nuovo meccanismo di attivazione del processo per il sistema operativo Windows Server 2008 che è disponibile anche nel sistema operativo Windows Vista®. Pur mantenendo il noto modello di processo di IIS (Internet Information Services) 6.0, ovvero i pool di applicazioni e l'attivazione dei processi basata sui messaggi, e funzionalità di hosting come la protezione rapida dagli errori, il monitoraggio dell'integrità e il riciclo, è stata rimossa la dipendenza dal protocollo HTTP (Hypertext Transfer Protocol) dall'architettura di attivazione. In IIS 7.0 WAS viene utilizzato per eseguire l'attivazione basata sui messaggi tramite HTTP. Oltre al protocollo HTTP, è possibile utilizzare anche protocolli non HTTP supportati dal servizio Attivazione processo Windows, ad esempio TCP, MSMQ e named pipe, per consentire l'attivazione basata sui messaggi in WCF. In questo modo le applicazioni che utilizzano i protocolli di comunicazione possono trarre vantaggio da funzionalità di IIS quali il riciclo dei processi, la protezione rapida dagli errori e il sistema di configurazione comune, che in precedenza erano disponibili solo per le applicazioni basate su HTTP.

Ogni applicazione posta sotto il controllo WAS dispone di un indirizzo URI (Uniform Resource Identifier) che identifica il protocollo di rete utilizzato da WAS per attivare l'applicazione.

Nota

Affinché l'attivazione WAS funzioni, è necessario che il protocollo di rete specificato nell'URI sia attivato nel server e sia autorizzato a superare gli eventuali firewall esistenti. Per ulteriori informazioni sulle eccezioni del firewall, vedere le pagine relative a Windows Firewall e Windows Firewall con sicurezza avanzata, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81757.

Se Attivazione TCP viene attivata, il server applicazioni crea una regola delle eccezioni del firewall che aprirà la porta TCP 808 (è possibile specificare una porta diversa digitando un numero diverso nell'URI). Affinché il TCP Listener possa mettersi in ascolto sulla porta 808, è inoltre necessario creare un sito Web predefinito che utilizzi net.tcp.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Supporto delle transazioni distribuite per il server applicazioni

Il processo di installazione del ruolo Server applicazioni include un'opzione che consente di attivare Distributed Transaction Coordinator (DTC). Quando questo servizio viene attivato, il server applicazioni configura automaticamente DTC per consentire le transazioni in rete e crea inoltre una regola del firewall che consente al traffico della rete di attraversare Distributed Transaction Coordinator.

Nell'ambito dell'elaborazione delle informazioni, la transazione è costituita da una serie di operazioni trattate come un'unità atomica singola: o si verificano tutte le operazioni o non se ne verifica nessuna. Ad esempio, è possibile effettuare il commit di una serie di operazioni di inserimento e aggiornamento eseguite su un database considerandole un'unica transazione. Quando una transazione coinvolge una sola risorsa, sarà il gestore stesso della risorsa (nell'esempio, il database) a gestire l'intera transazione. Quando invece le operazioni di una transazione comportano l'aggiornamento di dati in più computer di una rete, si ha a che fare con una transazione distribuita. In Windows Server 2008 è possibile utilizzare DTC per coordinare aggiornamenti che coinvolgono risorse distribuite in più computer della rete come se si trattasse di una transazione singola. Per ulteriori informazioni su Distributed Transaction Coordinator (DTC), vedere la pagina dedicata a questo argomento all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93847.

Nota

Per impostazione predefinita, il supporto delle transazioni distribuite non è attivato nel server applicazioni. Verificare che il ruolo Server applicazioni sia installato e che l'opzione DTC sia attivata in ogni server che ospita un'applicazione o una risorsa che verrà coinvolta nella transazione distribuita, tra cui, ad esempio, un'applicazione che creerà le transazioni distribuite e un'applicazione e una risorsa che parteciperanno alle transazioni distribuite (rispettivamente un componente COM+ transazionale e un database, ad esempio).

Durante l'installazione del ruolo Server applicazioni, è possibile installare il servizio Transazioni distribuite con le opzioni seguenti:

  • Transazioni remote in ingresso: in alcune situazioni, una transazione distribuita può essere avviata su un computer remoto, mentre un'operazione che fa parte di tale transazione può coinvolgere una risorsa nel computer locale. In questi casi si dice che la transazione "confluisce" nel computer locale e che la risorsa locale (ad esempio, un database) "si integra" nella transazione che è stata avviata sul computer remoto. L'attivazione di questa opzione garantisce il supporto delle transazioni distribuite per le applicazioni che si integrano nelle transazioni remote.

  • Transazioni remote in uscita: in alcune situazioni, un'applicazione locale può avviare una transazione ed eseguire operazioni di aggiornamento su risorse che risiedono in computer remoti. In questi casi si dice che la transazione "defluisce" dal computer locale e viene "propagata" a una risorsa nel computer remoto. L'attivazione di questa opzione garantisce il supporto delle transazioni distribuite per la propagazione esterna delle transazioni.

  • WS-Atomic Transactions: questa opzione fornisce il supporto delle transazioni distribuite per le applicazioni che utilizzano gli standard SOAP (Simple Object Access Protocol) e WS-Atomic Transaction per la comunicazione e il coordinamento delle transazioni.

Ulteriori riferimenti

  • Installare e configurare il server applicazioni


Gestire il server applicazioni

  • Configurazioni del server applicazioni

  • Aggiungere servizi ruolo Server applicazioni

  • Rimuovere servizi ruolo Server applicazioni

  • Rimuovere il ruolo Server applicazioni


Configurazioni del server applicazioni

  • Elenco di controllo: creare, distribuire e gestire siti Web dinamici e applicazioni basate sul Web

  • Elenco di controllo: hosting di applicazioni gestite

  • Elenco di controllo: sviluppare e integrare i servizi Web nell'ambiente esistente

  • Elenco di controllo: avviare i servizi Windows Communication Foundation alla ricezione di un messaggio

  • Elenco di controllo: utilizzare Condivisione porta TCP per consentire a più applicazioni WCF di utilizzare la stessa porta TCP

  • Elenco di controllo: controllare l'esposizione ad applicazioni Enterprise Services critiche

  • Elenco di controllo: Creare applicazioni connesse in un'architettura orientata ai servizi

  • Elenco di controllo: flussi di lavoro e processi aziendali modello

  • Elenco di controllo: attivare il servizio Transazioni distribuite per fornire supporto alle transazioni in tutta la rete


Aggiungere servizi ruolo Server applicazioni

È possibile aggiungere i servizi ruolo al ruolo Server applicazioni in qualsiasi momento.

Per aggiungere i servizi ruolo al ruolo Server applicazioni

  1. Fare clic sul pulsante Start e quindi scegliere Server Manager.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. In Riepilogo ruoli fare clic su Server applicazioni.

  4. In Riepilogo fare clic su Aggiungi servizi ruolo.

  5. Nella pagina Selezione ruoli server selezionare i servizi ruolo aggiuntivi che sono necessari per eseguire le applicazioni e quindi fare clic su Avanti.

    Nota

    Per alcuni servizi ruolo è necessario installare funzionalità di supporto o servizi ruolo di altri ruoli. In questo caso è possibile scegliere se installare o non installare le funzionalità o i servizi ruolo richiesti.

  6. Se è obbligatoria l'installazione di una funzionalità di supporto o di un servizio ruolo di un altro ruolo, nelle pagine successive vengono fornite informazioni sulla funzionalità o sul servizio ruolo in questione. Fare clic su Avanti per passare alla pagina Conferma opzioni di installazione.

  7. Fare clic su Installa per avviare l'installazione del ruolo Server applicazioni con i servizi ruolo visualizzati nella pagina.

    Il processo di installazione può richiedere tempo, a seconda dei servizi ruolo selezionati. Dopo l'avvio del processo di installazione non è necessario alcun input da parte dell'operatore. Al termine del processo di installazione, lo stato dell'installazione verrà visualizzato nella pagina Risultati installazione.

Ulteriori riferimenti

  • Gestire il server applicazioni


Rimuovere servizi ruolo Server applicazioni

È possibile rimuovere i servizi ruolo in qualsiasi momento senza dover eliminare il ruolo Server applicazioni.

Per rimuovere i servizi ruolo dal ruolo Server applicazioni

  1. Fare clic sul pulsante Start e quindi scegliere Server Manager.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. In Riepilogo ruoli fare clic su Server applicazioni.

  4. In Riepilogo fare clic su Rimuovi servizi ruolo.

  5. Nella pagina Selezione servizi ruolo deselezionare le caselle di controllo relative ai servizi ruolo che si desidera rimuovere e quindi fare clic su Avanti.

    Nota

    Per rimuovere alcuni servizi ruolo, è necessario rimuovere le funzionalità di supporto o i servizi ruolo da altri ruoli. In questo caso, per completare la rimozione del servizio ruolo è necessario rimuovere le funzionalità di supporto o i servizi ruolo dagli altri ruoli.

  6. Nella pagina Conferma opzioni di rimozione fare clic su Rimuovi per rimuovere i servizi ruolo visualizzati nella pagina. Al termine del processo di rimozione, lo stato della rimozione verrà visualizzato nella pagina Risultati rimozione.

Ulteriori riferimenti

  • Gestire il server applicazioni


Rimuovere il ruolo Server applicazioni

Se non si desidera più eseguire un server applicazioni, è possibile rimuovere il ruolo Server applicazioni dal server.

Per rimuovere il ruolo Server applicazioni dal server

  1. Fare clic sul pulsante Start e quindi scegliere Server Manager.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. In Riepilogo ruoli fare clic su Rimuovi ruoli.

  4. Verrà visualizzata la Rimozione guidata ruoli, con informazioni relative al processo di rimozione di un ruolo server. Acquisire familiarità con le informazioni disponibili e, se necessario, completare uno o alcuni dei passaggi consigliati prima di proseguire con il processo di rimozione del ruolo. Al termine, fare clic su Avanti.

  5. Nella pagina Rimozione ruoli server deselezionare la casella di controllo Server applicazioni e quindi fare clic su Avanti.

    Nota

    Per rimuovere un ruolo server potrebbe talvolta essere necessario rimuovere un servizio ruolo o una funzionalità di supporto. In questo caso, per rimuovere completamente il ruolo server è necessario rimuovere il servizio di supporto.

  6. Nella pagina Conferma opzioni di rimozione fare clic su Rimuovi per rimuovere il ruolo server dal server. Al termine del processo di rimozione, lo stato della rimozione verrà visualizzato nella pagina Risultati rimozione.

Ulteriori riferimenti

  • Gestire il server applicazioni