Windows Server Backup

Windows Server Backup è una funzionalità di Windows Server 2008 che implementa gruppi di procedure guidate e altri strumenti per l'esecuzione di attività di backup e ripristino di base per il server su cui è installata. Questa funzionalità è stata aggiornata in Windows Server 2008 R2. La precedente funzionalità di backup (Ntbackup.exe), disponibile in Windows Server 2003 e nelle versioni precedenti di Windows, è stata rimossa.

Per ulteriori informazioni sul backup e il ripristino dei server, vedere la raccolta di documentazione tecnica di Windows Server 2008 disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93012. Per informazioni sul comando Wbadmin, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216).

  • Panoramica di Windows Server Backup

  • Elenco di controllo: pianificare backup automatici

  • Elenco di controllo: eseguire un backup manuale

  • Elenco di controllo: ripristinare file, cartelle, applicazioni, volumi o il sistema operativo

  • Installare strumenti di Windows Server Backup

  • Eseguire il backup del server

  • Ripristinare il server

  • Ottimizzare le prestazioni dei backup e del server

  • Utilizzare i cmdlet per Windows Server Backup

  • Risolvere i problemi di backup e ripristino

  • Risorse per il backup e il ripristino

  • Interfaccia utente: Windows Server Backup


Panoramica di Windows Server Backup

Windows Server Backup è costituito da uno snap-in di Microsoft Management Console (MMC), strumenti da riga di comando e cmdlet Windows PowerShell che offrono una soluzione completa per le normali esigenze di backup e ripristino. È possibile utilizzare Windows Server Backup per eseguire il backup di un server completo (tutti i volumi), di volumi selezionati, dello stato del sistema o di cartelle e file specifici e per creare un backup da utilizzare per il ripristino bare metal. È possibile ripristinare volumi, cartelle, file, determinate applicazioni e lo stato del sistema. In caso di emergenze, ad esempio errori di dischi rigidi, è inoltre possibile eseguire un ripristino bare metal. A tale scopo, per ripristinare il sistema completo su quello precedente o in un nuovo disco rigido, è necessario disporre di un backup del server completo o dei soli volumi contenenti i file del sistema operativo e di Ambiente ripristino Windows.

È possibile utilizzare Windows Server Backup per creare e gestire backup per il computer locale o un computer remoto. Inoltre, è possibile pianificare i backup in modo che vengano eseguiti automaticamente.

Windows Server Backup è destinato a tutti coloro che necessitano di una soluzione di backup di base, da piccole aziende a grandi imprese, ma è adatto anche per piccole organizzazioni o singoli utenti che non sono professionisti IT.

Considerazioni

  • Per utilizzare Windows Server Backup, è necessario essere membri del gruppo Administrators o Backup Operators.

  • Alcune attività di backup o ripristino devono essere eseguite su due computer che eseguono la stessa versione di Windows Server 2008 o Windows Server 2008 R2, mentre altre possono essere eseguite con computer che eseguono una qualsiasi delle due versioni. Per ulteriori informazioni sulla compatibilità, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143709.

  • Per eseguire un ripristino dello stato del sistema o del sistema completo, è necessario utilizzare backup creati nella stessa versione di Windows che si desidera ripristinare. Non è ad esempio possibile utilizzare un backup creato in Windows Server 2008 per ripristinare lo stato del sistema di un computer che esegue Windows Server 2008 R2.

  • È possibile che sia abilitato il firewall. Di conseguenza, se si gestiscono i backup di un altro computer mediante lo snap-in Windows Server Backup, è possibile che la connettività al computer remoto sia limitata e, per risolvere questo problema, sia necessario modificare le regole del firewall. Se si lavora con il computer locale, questo problema non si verifica.

  • Windows Server Backup non supporta il backup di dati o l'archiviazione di backup in volumi condivisi del cluster. È tuttavia possibile eseguire il backup di macchine virtuali utilizzando Windows Server Backup dall'interno della macchina virtuale. Per ulteriori informazioni sulla gestione dei cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=92360. Per ulteriori informazioni sulla gestione di Hyper-V, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=93752. Per ulteriori informazioni su Hyper-V e i volumi condivisi del cluster, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=139667.

  • Se per archiviare i backup si utilizza un disco rigido virtuale che si trova in un disco fisico contenente volumi di sistema o volumi critici, gli elementi ripristinabili potrebbero essere soggetti a limitazioni. I file nei volumi virtuali verranno inoltre esclusi dal backup se i volumi virtuali sono online. Per ulteriori informazioni sull'utilizzo dei dischi rigidi virtuali, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143712.

  • Se attualmente si utilizza la precedente funzionalità di backup (Ntbackup.exe) e si prevede di passare al nuovo snap-in Windows Server Backup, tenere presenti i problemi e le modifiche seguenti:

    • Le impostazioni per la creazione di backup non vengono aggiornate quando si esegue l'aggiornamento a Windows Server 2008. È necessario configurare nuovamente le impostazioni.

    • Non è possibile utilizzare Windows Server Backup per eseguire il backup di file e cartelle in volumi che richiedono uno spazio superiore a 2040 GB o 2 TB. Se la dimensione dei dati è inferiore a 2 TB, è tuttavia possibile eseguire un backup di file o cartelle. È ad esempio possibile eseguire il backup di dati con una dimensione pari a 1,5 TB in un volume da 3 TB. Durante il ripristino di un volume o un server completo da tale backup, verrà tuttavia ricreato un volume da 2 TB anziché da 3 TB.

    • È possibile eseguire il backup solo di volumi formattati con NTFS in un disco collegato al computer locale. Per istruzioni sulla conversione di una partizione FAT in una partizione NTFS, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=70318.

    • Non è possibile archiviare backup su nastro. In Windows Server 2008 sono tuttavia ancora supportati i driver di archiviazione su nastro. Windows Server Backup supporta il backup in dischi esterni e interni, supporti ottici e rimovibili come DVD e cartelle condivise remote.

    • Non è possibile utilizzare Windows Server Backup per ripristinare i backup creati con Ntbackup.exe. Una versione di Ntbackup.exe è tuttavia disponibile come download per Windows Server 2008 per gli utenti che desiderano ripristinare dati da backup creati con Ntbackup.exe. La versione scaricabile di Ntbackup.exe serve esclusivamente per il ripristino di backup per versioni precedenti di Windows e non può essere utilizzata per creare nuovi backup in Windows Server 2008. Per scaricare Ntbackup.exe, vedere http://go.microsoft.com/fwlink/?LinkId=82917.

Nuove funzionalità

Windows Server Backup in Windows Server 2008 R2 offre i miglioramenti seguenti:

  • Maggiore flessibilità riguardo agli elementi da includere nel backup. Windows Server Backup consente di eseguire il backup di file selezionati anziché di volumi completi. È inoltre possibile escludere file in base al tipo di file e al percorso.

  • Gestione automatica di backup completi e incrementali. Non è più necessario gestire backup completi e incrementali. Per impostazione predefinita, Windows Server Backup crea un backup incrementale che si comporta come un backup completo. È possibile ripristinare qualsiasi elemento da un singolo backup, sebbene il backup occupi solo lo spazio necessario per un backup incrementale. Windows Server Backup non richiede inoltre l'intervento dell'utente per l'eliminazione periodica dei backup precedenti al fine di rendere disponibile spazio su disco per i nuovi backup, in quanto i backup precedenti vengono eliminati automaticamente.

  • Maggiori possibilità di scelta per l'archiviazione dei backup. È possibile archiviare i backup creati utilizzando una pianificazione in una cartella condivisa remota o un volume. Se si archiviano i backup in una cartella condivisa remota, verrà mantenuta una sola versione del backup. È inoltre possibile archiviare i backup in dischi rigidi virtuali.

  • Migliorate opzioni per i backup e i ripristini dello stato del sistema. È possibile utilizzare l'interfaccia utente dello snap-in Windows Server Backup per creare backup che consentano di eseguire ripristini dello stato del sistema. È inoltre possibile utilizzare un singolo backup per lo stato del sistema e altri dati presenti nel server. Questi backup dello stato del sistema sono più veloci e richiedono meno spazio per più versioni perché utilizzano copie shadow per le versioni, in modo simile ai backup basati su volume, anziché singole cartelle per ogni versione. Per ulteriori informazioni su come i backup dello stato del sistema sono archiviati in Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143713.

  • Espanso supporto per la riga di comando e Windows PowerShell. Il comando Wbadmin e la relativa documentazione consentono di eseguire dalla riga di comando le stesse attività eseguite tramite lo snap-in. Per ulteriori informazioni, vedere le pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216). È inoltre possibile automatizzare le attività di backup mediante script.

    Le modifiche apportate a questo comando equivalgono a quelle relative allo snap-in Windows Server Backup.

    In Windows Server 2008 R2 è inoltre disponibile un insieme aggiornato di cmdlet Windows PowerShell per Windows Server Backup che consente di scrivere script Windows PowerShell per l'esecuzione di backup. Per ulteriori informazioni, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140217.

Sistemi operativi supportati

Windows Server Backup è disponibile in tutte le edizioni di Windows Server 2008 e Windows Server 2008 R2. Windows Server Backup, come altri snap-in, non è tuttavia disponibile per l'opzione di installazione Server Core di Windows Server 2008 R2. Per eseguire backup per computer con un'installazione Server Core, è necessario utilizzare il comando Wbadmin, i cmdlet Windows PowerShell per Windows Server Backup oppure gestire i backup in remoto da un altro computer.

Risorse aggiuntive

  • Elenco di controllo: pianificare backup automatici

  • Elenco di controllo: eseguire un backup manuale

  • Elenco di controllo: ripristinare file, cartelle, applicazioni, volumi o il sistema operativo

  • Installare strumenti di Windows Server Backup

  • Eseguire il backup del server

  • Ripristinare il server

  • Risolvere i problemi di backup e ripristino

  • Risorse per il backup e il ripristino

  • Interfaccia utente: Windows Server Backup

  • Per ulteriori informazioni sul backup e il ripristino del server, vedere http://go.microsoft.com/fwlink/?LinkId=93012.


Elenco di controllo: pianificare backup automatici

È possibile utilizzare la Pianificazione guidata backup in Windows Server Backup per pianificare backup da eseguire automaticamente una o più volte al giorno.

Importante
  • I backup pianificati possono essere salvati in uno o più dischi collegati interni o esterni oppure, a partire da Windows Server 2008 R2, in un volume o una cartella condivisa remota. Se si utilizzano i dischi, devono essere disponibili e online affinché la pianificazione possa essere configurata e la procedura guidata possa essere completata. Quando successivamente si inizia a eseguire i backup pianificati, se si utilizzano più dischi, è comunque consigliabile collegarne solo uno alla volta, in modo che i backup vengano salvati sullo stesso disco. Se poi si desidera spostare tale set di backup in un altro luogo, collegare un altro disco della serie.
  • È possibile scegliere più volumi in cui archiviare i backup. È tuttavia consigliabile eseguire questa operazione solo se i dischi contenenti i volumi possono essere spostati in un altro luogo, come quando si utilizzano più dischi. È inoltre possibile scegliere di archiviare i backup in volumi se non si desidera formattare il disco prima che venga creato il primo backup. Se ad esempio il disco che si desidera utilizzare per archiviare i backup contiene anche altri dati o i backup di un altro server, è possibile archiviare i backup in un volume contenuto nel disco anziché riservare per i backup l'intero disco, in modo che quest'ultimo non venga formattato prima della creazione del primo backup.
  • Se si utilizza una cartella condivisa remota, verificare che la cartella sia disponibile e accessibile in scrittura e che l'utente corrente sia un membro del gruppo Administrators o Backup Operators nel computer in cui si trova la cartella. Ogni volta che si crea un backup, i backup precedenti vengono sovrascritti ed è quindi sempre disponibile un solo backup. Il backup erediterà le autorizzazioni dell'elenco di controllo di accesso (ACL) della cartella.

È inoltre possibile creare backup pianificati utilizzando il comando Wbadmin enable backup o i cmdlet Windows PowerShell per Windows Server Backup. Per esempi e informazioni sulla sintassi per il comando Wbadmin, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=93106). Per esempi e informazioni sulla sintassi per i cmdlet per Windows Server Backup, vedere la pagina di riferimento per Windows PowerShell (http://go.microsoft.com/fwlink/?LinkId=143721).

In questo elenco di controllo viene descritto come pianificare backup automatici utilizzando l'interfaccia utente di Windows Server Backup.

Attività Riferimenti

Prima di iniziare, esaminare i concetti e i requisiti, quindi determinare quanto segue:

  • Numero di backup da eseguire in un giorno e ora in cui eseguirli.

  • Se si desidera utilizzare un volume, un singolo disco, più dischi o una cartella condivisa remota per archiviare i backup.

    Nota

    Se si sceglie di utilizzare un volume per archiviare i backup, è possibile selezionare un solo volume per ogni disco fisico.

  • I file, le cartelle o i volumi di cui si desidera eseguire il backup e se i backup dovranno essere utilizzati per il ripristino bare metal, del server completo (tutti i volumi) o dello stato del sistema.

Windows Server Backup; Eseguire il backup del server; http://go.microsoft.com/fwlink/?LinkId=93012

Se questa operazione non è già stata eseguita, installare Windows Server Backup.

Installare strumenti di Windows Server Backup

Eseguire Pianificazione guidata backup e seguire le istruzioni della procedura guidata.

Configurare backup automatici; Pianificazione guidata backup

Se necessario, configurare il backup per il salvataggio su più dischi che possono essere spostati in un altro luogo.

Configurare una pianificazione di backup per più dischi di archiviazione

Dopo aver pianificato il backup e creato un primo backup, eseguire un ripristino di prova per verificare che sia possibile ripristinare gli elementi desiderati. A tale scopo, è possibile attendere l'esecuzione del primo backup pianificato o creare immediatamente un backup unico utilizzando la Creazione guidata backup unico o il comando Wbadmin start backup e le stesse impostazioni configurate per i backup pianificati.

Eseguire un backup manuale; Ripristinare il server

Esaminare periodicamente la pianificazione di backup per verificare che sia sempre conforme alle esigenze aziendali e valutare se modificarla dopo l'aggiunta o la rimozione di volumi, applicazioni, funzionalità o ruoli. Controllare inoltre lo stato dei backup utilizzando l'interfaccia utente di Windows Server Backup, il comando Wbadmin get status oppure i cmdlet Windows PowerShell per Windows Server Backup.

Modificare o interrompere una pianificazione di backup automatici

Ulteriori considerazioni

  • Per installare e utilizzare Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server, quando possibile assicurarsi che anche la posizione di archiviazione scelta sia protetta con Crittografia unità BitLocker. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkId=143722).

Risorse aggiuntive

  • Elenco di controllo: eseguire un backup manuale

  • Elenco di controllo: ripristinare file, cartelle, applicazioni, volumi o il sistema operativo


Elenco di controllo: eseguire un backup manuale

È possibile utilizzare la Creazione guidata backup unico in Windows Server Backup per creare singoli backup del computer.

È inoltre possibile creare backup unici utilizzando il comando Wbadmin start backup o Wbadmin start systemstatebackup oppure i cmdlet Windows PowerShell per Windows Server Backup. Per informazioni sulla sintassi ed esempi per Wbadmin, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216). Per esempi e informazioni sulla sintassi per i cmdlet per Windows Server Backup, vedere la pagina di riferimento per Windows PowerShell (http://go.microsoft.com/fwlink/?LinkID=143721).

In questo elenco di controllo viene descritto come eseguire un backup manuale utilizzando l'interfaccia utente di Windows Server Backup.

Attività Riferimenti

Prima di iniziare, esaminare i concetti e i requisiti, quindi determinare quanto segue:

  • Dove archiviare il backup.

  • I volumi di cui si desidera eseguire il backup e se i backup dovranno essere utilizzati per il ripristino del sistema operativo (solo i volumi critici), del server completo (tutti i volumi), dello stato del sistema o bare metal.

Windows Server Backup; Eseguire il backup del server; http://go.microsoft.com/fwlink/?LinkId=93012

Se questa operazione non è già stata eseguita, installare Windows Server Backup.

Installare strumenti di Windows Server Backup

Eseguire Creazione guidata backup unico e seguire le istruzioni della procedura guidata.

Eseguire un backup manuale; Creazione guidata backup unico

Dopo aver creato il backup, eseguire un ripristino di prova per verificare che sia possibile ripristinare gli elementi desiderati.

Ripristinare il server

Ulteriori considerazioni

  • Per installare e utilizzare Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server, quando possibile assicurarsi che anche la posizione di archiviazione scelta sia protetta con Crittografia unità BitLocker. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Risorse aggiuntive

  • Elenco di controllo: pianificare backup automatici

  • Elenco di controllo: ripristinare file, cartelle, applicazioni, volumi o il sistema operativo


Elenco di controllo: ripristinare file, cartelle, applicazioni, volumi o il sistema operativo

Per eseguire attività di ripristino, è possibile utilizzare gli strumenti seguenti:

  • Ripristino guidato in Windows Server Backup. Questa procedura guidata consente di ripristinare file, cartelle, applicazioni, volumi e lo stato del sistema.

  • Ripristino guidato catalogo in Windows Server Backup. Questa procedura guidata consente di ripristinare il catalogo di backup, ovvero un file in cui sono archiviati i dettagli relativi ai backup. È disponibile solo se il catalogo di backup è stato danneggiato.

  • Ambiente ripristino Windows e un backup creato con Windows Server Backup. Ambiente ripristino Windows è accessibile da un computer che esegue Windows Server 2008 R2 o un disco di installazione di Windows. Questo metodo consente di ripristinare il sistema operativo o il server completo.

È inoltre possibile eseguire ripristini utilizzando i comandi Wbadmin start recovery, Wbadmin start systemstaterecovery e Wbadmin restore catalog. Per informazioni sulla sintassi ed esempi, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216).

In questo elenco di controllo viene descritto come ripristinare i dati utilizzando l'interfaccia utente di Windows Server Backup.

Attività Riferimenti

Prima di iniziare, esaminare i concetti e i requisiti, quindi determinare quanto segue:

  • Quali elementi ripristinare.

  • Quale backup utilizzare per il ripristino.

  • Dove eseguire il ripristino.

Windows Server Backup; Ripristinare il server; Eseguire il backup del server; http://go.microsoft.com/fwlink/?LinkId=93012

Se questa operazione non è già stata eseguita, installare Windows Server Backup.

Installare strumenti di Windows Server Backup

Se necessario, collegare le unità o verificare che le cartelle condivise remote necessarie siano disponibili e accessibili. Accertarsi inoltre di aver compreso le limitazioni dei diversi tipi di archiviazione e ripristino.

Ripristinare il server; Eseguire il backup del server

Eseguire Ripristino guidato e seguire le istruzioni della procedura guidata specifiche per l'elemento da ripristinare.

Ripristinare file e cartelle; Ripristinare applicazioni e dati; Ripristinare i volumi; Ripristinare lo stato del sistema

In questo elenco di controllo viene descritto come ripristinare i dati mediante Ambiente ripristino Windows e un backup creato con Windows Server Backup.

Attività Riferimenti

Prima di iniziare accertarsi che sia disponibile un disco di installazione di Windows oppure che Ambiente ripristino Windows sia installato su una partizione separata del server, verificare i concetti e i requisiti e quindi stabilire quanto segue:

  • Quale backup utilizzare per il ripristino.

  • Dove eseguire il ripristino (nello stesso computer o in un altro) e se è disponibile lo spazio necessario per gli elementi da ripristinare.

  • Se si desidera ripristinare tutti i volumi critici contenenti i componenti del sistema operativo (durante il ripristino è possibile escludere i volumi non critici) oppure il server completo (tutti i volumi).

Windows Server Backup; Ripristinare il server; http://go.microsoft.com/fwlink/?LinkId=93012; http://go.microsoft.com/fwlink/?LinkId=94458; Ripristinare il sistema operativo o il server completo

Eseguire il ripristino e seguire le istruzioni visualizzate nell'interfaccia utente.

Ripristinare il sistema operativo o il server completo

In questo elenco di controllo viene descritto come ripristinare il catalogo di backup utilizzando l'interfaccia utente di Windows Server Backup.

Attività Riferimenti

Prima di iniziare, esaminare i concetti e i requisiti, quindi determinare quale backup utilizzare per il ripristino. In alternativa, se non si dispone di un backup da cui eseguire il ripristino, determinare se si desidera semplicemente eliminare il catalogo e riavviare i backup.

Windows Server Backup; Ripristinare il server; http://go.microsoft.com/fwlink/?LinkId=93012

Eseguire Ripristino guidato e seguire le istruzioni.

Nota

Ripristino guidato catalogo verrà visualizzato in Windows Server Backup solo se il catalogo è danneggiato.

Dopo aver eseguito la procedura guidata, chiudere e riavviare Windows Server Backup per aggiornare lo stato.

Ripristinare un catalogo di backup; Ripristino guidato catalogo

Ulteriori considerazioni

  • Per installare e utilizzare Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server ed è necessario eseguire un ripristino di sistema, assicurarsi di riapplicare Crittografia unità BitLocker. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Risorse aggiuntive

  • Elenco di controllo: pianificare backup automatici

  • Elenco di controllo: eseguire un backup manuale


Installare strumenti di Windows Server Backup

Per accedere agli strumenti di backup e ripristino, è necessario installare le Funzionalità di Windows Server Backup e gli elementi subordinati disponibili nell'Aggiunta guidata funzionalità di Server Manager. In questo modo verranno installati gli strumenti seguenti:

  • Snap-in Windows Server Backup di Microsoft Management Console (MMC)

  • Strumento da riga di comando Wbadmin

  • Cmdlet Windows PowerShell per Windows Server Backup

Per installare gli strumenti di backup e ripristino

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Server Manager, nel riquadro di sinistra fare clic su Funzionalità e nel riquadro di destra fare clic su Aggiungi funzionalità. Verrà visualizzata l'Aggiunta guidata funzionalità.

  2. Nella pagina Selezione funzionalità dell'Aggiunta guidata funzionalità espandere Funzionalità di Windows Server Backup e quindi selezionare le caselle di controllo relative a Windows Server Backup e Strumenti da riga di comando.

    Nota

    Se si desidera installare solo lo snap-in e lo strumento da riga di comando Wbadmin, espandere Funzionalità di Windows Server Backup e quindi selezionare solo la casella di controllo Windows Server Backup. Verificare che la casella di controllo Strumenti da riga di comando sia deselezionata.

  3. Nella pagina Conferma selezioni per l'installazione controllare le scelte effettuate e quindi fare clic su Installa. Eventuali errori verificatisi durante l'installazione verranno indicati nella pagina Risultati installazione.

  4. Per accedere a questi strumenti di backup e ripristino, eseguire le operazioni seguenti:

    • Per aprire lo snap-in Windows Server Backup, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Windows Server Backup.

    • Per accedere a Wbadmin e visualizzare la sintassi, fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore. Al prompt dei comandi digitare: wbadmin /?

    • Per istruzioni su come accedere alla Guida dei cmdlet Windows PowerShell per Windows Server Backup e visualizzarla, vedere Utilizzare i cmdlet per Windows Server Backup.

Ulteriori considerazioni

  • Per installare le funzionalità di Windows Server Backup in Server Manager, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Per installare Windows Server Backup in un'installazione Server Core, è possibile utilizzare la riga di comando per Server Manager. Per istruzioni, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143737. Per ulteriori istruzioni su come installare ruoli in installazioni Server Core, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=129805.

  • È inoltre possibile accedere a Windows Server Backup da Server Manager. A tale scopo, nel riquadro di sinistra fare doppio clic su Archiviazione e quindi su Windows Server Backup.

Ulteriori riferimenti

  • Windows Server Backup

  • Comando Wbadmin (http://go.microsoft.com/fwlink/?LinkId=140216)


Eseguire il backup del server

È possibile utilizzare Windows Server Backup per proteggere il sistema operativo, lo stato del sistema, volumi, file e dati di applicazioni. I backup possono essere salvati in uno o più dischi, uno o più volumi, DVD, supporti rimovibili o cartelle condivise remote e possono essere pianificati per l'esecuzione automatica o manuale.

Per eseguire i backup in base a una pianificazione regolare, creare il backup mediante Pianificazione guidata backup. Utilizzare Creazione guidata backup unico per l'esecuzione di backup singoli. Entrambe le procedure guidate sono disponibili nello snap-in Windows Server Backup di Microsoft Management Console (MMC). È inoltre possibile creare backup regolari o unici mediante il comando Wbadmin o i cmdlet Windows PowerShell per Windows Server Backup.

Windows Server Backup crea backup completi che consentono di eseguire ripristini del computer senza dover fare riferimento a un altro backup. Questi backup, tuttavia, sono ottimizzati come backup incrementali in modo da migliorare le prestazioni dei backup e limitare lo spazio utilizzato. Se si utilizza un disco o un volume per archiviare i backup, Windows Server Backup elimina inoltre automaticamente i backup meno recenti quando lo spazio nel percorso di archiviazione diventa insufficiente. Per ulteriori informazioni sui backup incrementali e completi, vedere Ottimizzare le prestazioni dei backup e del server.

Quando si crea un backup e lo si salva in un percorso di archiviazione, il backup creato verrà salvato in una cartella WindowsImageBackup\<ComputerBackedUp>. Oltre al backup, questa cartella include file catalogo, contenenti informazioni su tutti i backup presenti in tale percorso fino al backup corrente, e un file denominato MediaId, contenente l'identificatore del percorso di archiviazione dei backup. Queste informazioni sono necessarie per eseguire un ripristino.

Per istruzioni specifiche sul backup di Servizi di dominio Active Directory, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143748.

In questa sezione sono disponibili istruzioni per eseguire le operazioni seguenti:

  • Configurare backup automatici

  • Eseguire un backup manuale

  • Creare backup dello stato del sistema tramite riga di comando

  • Eseguire il backup di applicazioni e dati

Scegliere gli elementi di cui eseguire il backup

Durante la creazione di un backup, è necessario specificare i file, le cartelle o i volumi che si desidera includere. Gli elementi selezionati per il backup influenzano i dati che è possibile ripristinare.

Nota

Non è possibile utilizzare Windows Server Backup per eseguire il backup di file e cartelle in volumi che richiedono uno spazio superiore a 2040 GB o 2 TB. Se la dimensione dei dati è inferiore a 2 TB, è tuttavia possibile eseguire un backup di file o cartelle. È ad esempio possibile eseguire il backup di dati con una dimensione pari a 1,5 TB in un volume da 3 TB. Durante il ripristino di un volume o un server completo da tale backup, verrà tuttavia ricreato un volume da 2 TB anziché da 3 TB.

Sono disponibili le opzioni seguenti:

Elementi nel backup | Opzioni di ripristino risultanti
Server completo (tutti i volumi) | Eseguire un backup di tutti i volumi quando si desidera essere in grado di ripristinare il server completo. È possibile utilizzare un backup del server completo per eseguire tutti i tipi di ripristino, inclusi quelli dello stato del sistema e bare metal. Questa è l'opzione consigliata.
Volumi critici/ripristino bare metal | Scegliere di creare un backup per il ripristino bare metal quando si desidera eseguire il backup degli elementi necessari per ripristinare il sistema operativo (solo i volumi critici). Questa opzione è un sottoinsieme di un backup del server completo.
Stato del sistema | Scegliere di creare un backup dello stato del sistema quando si desidera eseguire il backup degli elementi necessari per eseguire un ripristino dello stato del sistema. Questa opzione è un sottoinsieme di un backup del server completo.
Singoli volumi | Eseguire il backup di singoli volumi quando si desidera essere in grado di ripristinare solo file, applicazioni o dati presenti in tali volumi.
Cartelle o file | Eseguire il backup di singole cartelle o singoli file quando si desidera essere in grado di ripristinare solo tali elementi.

Scegliere un percorso di archiviazione

È necessario specificare un percorso in cui archiviare i backup creati. Il tipo del percorso di archiviazione scelto influisce sugli elementi che è possibile ripristinare.

Nota
  • La dimensione del percorso in cui vengono archiviati i backup deve essere di almeno 1,5 volte superiore a quella dei backup per consentire di archiviare un paio di versioni del backup.

  • Come percorso di archiviazione dei backup per Windows Server Backup non è possibile utilizzare unità a nastro. In Windows Server 2008 e Windows Server 2008 R2 sono tuttavia ancora supportati i driver di archiviazione su nastro.

  • Non è possibile archiviare backup su dischi formattati con FAT32. I dischi devono essere formattati con NTFS perché Windows Server Backup utilizza copie shadow per gestire le versioni dei backup. È possibile utilizzare il comando Format per riformattare il disco oppure il comando Convert per modificarne il formato. Per informazioni sulla sintassi del comando Convert, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=143749).

  • Non è possibile archiviare backup in unità flash USB o chiavette USB.

Tipo di archiviazione Dettagli

Cartella condivisa remota

Nelle cartelle condivise remote è possibile archiviare sia backup unici (ad hoc) sia backup pianificati. La possibilità di archiviare backup pianificati in cartelle condivise remote è una novità di Windows Server 2008 R2. I backup archiviati in cartelle condivise remote possono essere utilizzati per ripristinare file, cartelle, lo stato del sistema, applicazioni e volumi completi oppure per eseguire ripristini bare metal.

Se si archivia il backup in una cartella condivisa remota, esso verrà sovrascritto ogni volta che si crea un nuovo backup. Non utilizzare questa opzione se si desidera archiviare più backup.

Se si crea un backup in una cartella condivisa che contiene già un backup e il processo di backup non riesce, potrebbe non essere più disponibile alcun backup.

DVD, altri supporti ottici o supporti rimovibili

Nei supporti ottici o rimovibili è possibile archiviare solo backup unici, non backup pianificati. I backup archiviati in supporti ottici o rimovibili possono essere utilizzati per eseguire ripristini bare metal o di volumi completi. Non è possibile ripristinare applicazioni, singoli file o lo stato del sistema dai backup archiviati in supporti ottici o rimovibili.

Se lo spazio disponibile nel supporto è superiore a 1 GB, il supporto rimovibile è formattato come NTFS e il supporto ottico è formattato come UDF, il supporto non verrà riformattato prima del salvataggio dei backup, in modo che possa essere utilizzato per archiviare altri dati. Questa è una novità di Windows Server 2008 R2. In Windows Server 2008 i DVD e i supporti rimovibili vengono sempre formattati prima dell'archiviazione dei backup.

I backup archiviati in DVD verranno compressi e occuperanno meno spazio rispetto a quelli salvati su disco rigido.

Disco rigido interno

In un disco formattato come NTFS o GPT (Tabella di partizione GUID, Guida Partition Table) è possibile archiviare sia backup unici sia backup pianificati. Se in un disco interno si archiviano backup pianificati, è possibile scegliere di configurare tale disco come dedicato per l'archiviazione. In tal caso, il disco scelto verrà dedicato all'archiviazione dei backup pianificati e non sarà visualizzato in Esplora risorse.

I backup archiviati in dischi interni possono essere utilizzati per:

  • Ripristinare file, cartelle, applicazioni e volumi.

  • Eseguire ripristini del sistema operativo (bare metal) se il backup utilizzato contiene tutti i volumi critici.

  • Eseguire ripristini dello stato del sistema se il backup utilizzato contiene lo stato del sistema.

Non è tuttavia possibile eseguire un ripristino completo del sistema o bare metal se il backup si trova nello stesso disco fisico di uno o più volumi critici. È possibile eseguire ripristini dello stato del sistema e ripristini di volumi senza partizionamento.

Infine, se per archiviare i backup si utilizza un volume in cui sono presenti anche altri dati, le prestazioni delle operazioni di scrittura nel volume potrebbero diminuire fino al 200%. Le operazioni di lettura non sono invece influenzate. È consigliabile non archiviare altri dati nel volume contenente i backup.

Disco rigido esterno

Se si archivia il backup in un disco rigido esterno formattato come NTFS o GPT, è possibile:

  • Ripristinare file, cartelle, applicazioni e volumi.

  • Eseguire ripristini dello stato del sistema e del sistema operativo (bare metal) se il backup utilizzato contiene gli elementi necessari.

  • Spostare facilmente i backup in un altro luogo per la protezione in caso di emergenza.

Come per i dischi interni, è possibile scegliere di configurare il disco come dedicato per l'archiviazione in modo che non venga visualizzato in Esplora risorse. Se per archiviare i backup si utilizza un volume in cui sono presenti anche altri dati, le prestazioni di I/O potrebbero diminuire nel volume. È consigliabile non archiviare altri dati nel volume contenente i backup.

Importante
  • Se per archiviare i backup si utilizza un disco rigido virtuale che si trova in un disco fisico contenente volumi di sistema o volumi critici, gli elementi ripristinabili potrebbero essere soggetti a limitazioni. I file nei volumi virtuali verranno inoltre esclusi dal backup se i volumi virtuali sono online. Per ulteriori informazioni sull'utilizzo dei dischi rigidi virtuali, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=143712.

  • Se per archiviare i backup si utilizza un disco dinamico anziché un disco di base, non sarà possibile eseguire ripristini bare metal tramite i backup archiviati nel disco dinamico. Sarà tuttavia possibile eseguire altri tipi di ripristini. Per ulteriori informazioni sull'utilizzo dei dischi dinamici, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143750.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server, quando possibile assicurarsi che anche la posizione di archiviazione scelta sia protetta con Crittografia unità BitLocker. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Ulteriori considerazioni

  • Per utilizzare Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

Ulteriori riferimenti

  • Windows Server Backup

  • Installare strumenti di Windows Server Backup

  • Ripristinare il server

  • Elenco di controllo: pianificare backup automatici

  • Elenco di controllo: eseguire un backup manuale

  • Utilizzare i cmdlet per Windows Server Backup

  • Comando Wbadmin nella pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216)


Configurare backup automatici

È possibile proteggere automaticamente il server che esegue Windows Server 2008 o Windows Server 2008 R2 e i relativi dati pianificando backup giornalieri. Per configurare i backup pianificati, è innanzitutto necessario:

  • Scegliere gli elementi da includere nei backup e i percorsi in cui archiviarli. Per ulteriori informazioni, vedere Eseguire il backup del server.

  • Decidere se eseguire i backup una volta al giorno o più spesso.

Nota

Non è possibile utilizzare Windows Server Backup per eseguire il backup di file e cartelle in volumi che richiedono uno spazio superiore a 2040 GB.

È quindi possibile creare backup pianificati nei modi seguenti:

  • È possibile utilizzare la Pianificazione guidata backup, a cui si accede dall'interfaccia utente di Windows Server Backup (Wbadmin.msc), per creare una pianificazione di backup.

  • È possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

  • È possibile utilizzare il comando Wbadmin enable backup per configurare direttamente i backup pianificati. Per esempi e informazioni sulla sintassi per questo comando, vedere http://go.microsoft.com/fwlink/?LinkId=93106.

  • È possibile utilizzare il comando Wbadmin start backup con l'Utilità di pianificazione per creare una serie di attività pianificate.

In questa sezione sono disponibili istruzioni per eseguire le operazioni seguenti:

  • Configurare backup automatici in un disco collegato

  • Configurare backup automatici in un volume

  • Configurare backup automatici in una cartella condivisa remota

  • Configurare backup automatici con l'Utilità di pianificazione

  • Modificare o interrompere una pianificazione di backup automatici

  • Configurare una pianificazione di backup per più dischi di archiviazione

Ulteriori considerazioni

  • Per configurare un backup pianificato, è necessario essere membri del gruppo Administrators o Backup Operators oppure avere ricevuto in delega l'autorità appropriata.

  • Quando l'esecuzione dei backup pianificati ha inizio, esaminare periodicamente la pianificazione per verificare che sia sempre conforme alle esigenze aziendali e valutare se modificarla dopo l'aggiunta o la rimozione di volumi, applicazioni, funzionalità o ruoli. Controllare inoltre lo stato dei backup utilizzando l'interfaccia utente di Windows Server Backup, il comando Wbadmin get status oppure i cmdlet Windows PowerShell per Windows Server Backup.

Ulteriori riferimenti

  • Eseguire il backup del server

  • Installare strumenti di Windows Server Backup


Configurare backup automatici in un disco collegato

È possibile proteggere automaticamente il server che esegue Windows Server 2008 o Windows Server 2008 R2 e i relativi dati pianificando backup giornalieri in dischi rigidi interni o esterni collegati. Per configurare i backup pianificati, è innanzitutto necessario:

  • Identificare un percorso per l'archiviazione dei backup. Per ulteriori informazioni sulla scelta di un percorso di archiviazione, vedere Eseguire il backup del server. Verificare che tutti i dischi rigidi per l'archiviazione dei backup siano collegati e online. Se si utilizza un disco rigido esterno, è consigliabile sceglierne uno che supporti la specifica USB 2.0 o IEEE 1394. Il disco dovrebbe avere una capacità di archiviazione pari almeno a 2,5 volte le dimensioni della serie di elementi di cui si desidera eseguire il backup. Se si utilizza un disco dedicato per l'archiviazione dei backup, tale disco deve essere vuoto o contenere dati che non è necessario mantenere perché verrà formattato e pulito da Windows Server Backup durante la preparazione per il backup.

  • Scegliere gli elementi da includere nel backup, ovvero il server completo o solo alcuni elementi. Per ulteriori informazioni sulla scelta degli elementi da includere nel backup, vedere Eseguire il backup del server.

Nota
  • È possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup per configurare i backup pianificati. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

  • Per configurare i backup pianificati, è inoltre possibile utilizzare il comando Wbadmin enable backup. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143762.

Per creare una pianificazione di backup mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Pianificazione backup in Windows Server Backup. Verrà avviata la Pianificazione guidata backup.

  3. Nella pagina Attività iniziali fare clic su Avanti.

  4. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server. Questa è l'opzione consigliata.

    • Fare clic su Personalizzato per eseguire il backup solo di alcuni elementi e quindi fare clic su Avanti.

      1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative agli elementi di cui si desidera eseguire il backup. Se si desidera eseguire il backup solo di alcune cartelle o alcuni file in un disco o un volume, espandere l'albero delle cartelle e selezionare gli elementi da includere. Fare clic su OK.

      2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Esclusioni, su Aggiungi esclusioni e infine espandere l'albero delle cartelle e selezionare gli elementi da escludere.

      3. Nella scheda Impostazioni servizio Copia Shadow del volume selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK e quindi su Avanti.

  5. Nella pagina Impostazione ora backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Una volta al giorno e quindi selezionare nell'elenco a discesa l'ora di inizio desiderata per il backup giornaliero.

    • Fare clic su Più di una volta al giorno. Per selezionare l'ora di inizio, in Orari disponibili fare clic sull'ora di inizio desiderata per il backup e quindi fare clic su Aggiungi per spostare l'ora impostata in Orari pianificati. Ripetere questa procedura per ogni ora di inizio da aggiungere.

  6. Nella pagina Impostazione tipo destinazione selezionare Backup su un disco rigido dedicato ai backup (scelta consigliata) e quindi fare clic su Avanti.

  7. Nella pagina Selezione disco di destinazione selezionare la casella di controllo relativa al disco collegato per questo scopo e quindi fare clic su Avanti.

    Per impostazione predefinita, nell'elenco vengono visualizzati il disco o i dischi più probabili. Si tratta dei dischi esterni che possono essere utilizzati per spostare i backup in un altro luogo per la protezione in caso di emergenza. Se l'elenco è vuoto oppure il disco che si desidera utilizzare non è presente nell'elenco, fare clic su Mostra tutti i dischi disponibili. In Mostra tutti i dischi disponibili selezionare la casella di controllo accanto al disco che si desidera utilizzare per archiviare i backup, fare clic su OK e quindi in Selezione disco di destinazione selezionare di nuovo la casella di controllo relativa al disco. Questo disco non verrà più visualizzato in Esplora risorse per impedire che nell'unità vengano inavvertitamente archiviati e successivamente sovrascritti dati ed evitare la perdita accidentale dei backup.

    Verrà visualizzato un messaggio per informare che il disco selezionato sarà formattato ed eventuali dati esistenti verranno eliminati. Fare clic su Sì. Non fare clic su Sì se il disco contiene dati necessari. Per utilizzare un disco diverso, fare clic su No e quindi selezionare il disco desiderato in Dischi disponibili.

    Importante

    È consigliabile annotare e quindi applicare fisicamente le informazioni dell'etichetta a tutti i dischi esterni utilizzati per l'archiviazione dei backup. Se si desidera ripristinare i dati dal backup archiviato nel disco, queste informazioni saranno necessarie per identificare il disco.

  8. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine. Se si utilizza un disco dedicato per l'archiviazione, tale disco verrà formattato automaticamente dalla procedura guidata. L'operazione potrebbe richiedere alcuni minuti in base alla dimensione del disco.

  9. Nella pagina Riepilogo fare clic su Chiudi.

Ulteriori considerazioni

  • Per configurare un backup pianificato, è necessario essere membri del gruppo Administrators o Backup Operators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

  • È possibile utilizzare più dischi esterni per archiviare i dati e spostarli tra sedi di archiviazione locali e remote. Per istruzioni, vedere Configurare una pianificazione di backup per più dischi di archiviazione.

  • Dopo aver creato una pianificazione di backup, è consigliabile ricontrollare periodicamente le impostazioni per verificare che la configurazione hardware non sia cambiata e che venga ancora eseguito il backup di tutti gli elementi desiderati. Per istruzioni, vedere Modificare o interrompere una pianificazione di backup automatici.

Ulteriori riferimenti

  • Configurare backup automatici

  • Installare strumenti di Windows Server Backup


Configurare backup automatici in un volume

È possibile proteggere automaticamente il server che esegue Windows Server 2008 R2 e i relativi dati pianificando backup giornalieri nei volumi. Per configurare i backup pianificati, è innanzitutto necessario:

  • Identificare un percorso per l'archiviazione dei backup. Per ulteriori informazioni sulla scelta di un percorso di archiviazione, vedere Eseguire il backup del server. Se si sceglie di archiviare i backup e altri dati in un volume anziché utilizzare un intero disco dedicato, è possibile che durante le operazioni di scrittura si verifichi un calo delle prestazioni di I/O fino al 200%.

  • Scegliere gli elementi da includere nel backup, ovvero il server completo o solo alcuni elementi. Per ulteriori informazioni sulla scelta degli elementi da includere nel backup, vedere Eseguire il backup del server.

Nota
  • È possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup per configurare i backup pianificati. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

  • Per configurare i backup pianificati, è inoltre possibile utilizzare il comando Wbadmin enable backup. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143762.

Per creare una pianificazione di backup mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Pianificazione backup in Windows Server Backup. Verrà avviata la Pianificazione guidata backup.

  3. Nella pagina Attività iniziali fare clic su Avanti.

  4. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server. Questa è l'opzione consigliata.

    • Fare clic su Personalizzato per eseguire il backup solo di alcuni elementi e quindi fare clic su Avanti.

      1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative agli elementi di cui si desidera eseguire il backup. Se si desidera eseguire il backup solo di alcune cartelle o alcuni file, espandere l'albero delle cartelle e selezionare gli elementi da includere. Fare clic su OK.

      2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Esclusioni, su Aggiungi esclusioni e infine espandere l'albero delle cartelle e selezionare gli elementi da escludere.

      3. Nella scheda Impostazioni servizio Copia Shadow del volume selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK.

  5. Nella pagina Impostazione ora backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Una volta al giorno e quindi selezionare nell'elenco a discesa l'ora di inizio desiderata per il backup giornaliero.

    • Fare clic su Più di una volta al giorno. Per selezionare l'ora di inizio, in Orari disponibili fare clic sull'ora di inizio desiderata per il backup e quindi fare clic su Aggiungi per spostare l'ora impostata in Orari pianificati. Ripetere questa procedura per ogni ora di inizio da aggiungere.

  6. Nella pagina Impostazione tipo destinazione selezionare Backup in un volume.

  7. Selezionare Backup in un volume. Nella pagina Selezione volume di destinazione fare clic su Aggiungi. In Aggiungi volumi fare clic sui volumi che si desidera utilizzare e quindi su OK.

    Nota

    Non è possibile selezionare più volumi dello stesso disco per l'archiviazione dei backup. È possibile aggiungere un solo volume per disco.

  8. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine. Se si utilizza un disco dedicato per l'archiviazione, tale disco verrà formattato automaticamente dalla procedura guidata. L'operazione potrebbe richiedere alcuni minuti in base alla dimensione del disco.

  9. Nella pagina Riepilogo fare clic su Chiudi.

Ulteriori considerazioni

  • Per configurare un backup pianificato, è necessario essere membri del gruppo Administrators o Backup Operators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

  • Dopo aver creato una pianificazione di backup, è consigliabile ricontrollare periodicamente le impostazioni per verificare che la configurazione hardware non sia cambiata e che venga ancora eseguito il backup di tutti gli elementi desiderati. Per istruzioni, vedere Modificare o interrompere una pianificazione di backup automatici.

Ulteriori riferimenti

  • Configurare backup automatici

  • Installare strumenti di Windows Server Backup


Configurare backup automatici in una cartella condivisa remota

È possibile proteggere automaticamente il server che esegue Windows Server 2008 R2 e i relativi dati pianificando backup giornalieri in una cartella condivisa remota. Per configurare i backup pianificati, è innanzitutto necessario:

  • Identificare un percorso per l'archiviazione dei backup. Per ulteriori informazioni sulla scelta di un percorso di archiviazione, vedere Eseguire il backup del server. Se i backup pianificati vengono archiviati in una cartella condivisa remota, verranno sovrascritti ogni volta che si crea un nuovo backup. Non utilizzare questa opzione se si desidera archiviare più backup.

  • Verificare di avere accesso a un account membro del gruppo Administrators o Backup Operators nel computer utilizzato per eseguire il backup e nel computer contenente la cartella condivisa remota. Verificare inoltre di avere accesso in scrittura alla cartella condivisa remota.

  • Scegliere gli elementi da includere nel backup, ovvero il server completo o solo alcuni elementi. Per ulteriori informazioni sulla scelta degli elementi da includere nel backup, vedere Eseguire il backup del server.

Importante

Se si crea un backup in una cartella condivisa remota che contiene già un backup e il processo di backup ha esito negativo, potrebbe non essere più disponibile alcun backup.

Nota
  • È possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup per configurare i backup pianificati. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

  • Per configurare i backup pianificati, è inoltre possibile utilizzare il comando Wbadmin enable backup. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143762.

Per creare una pianificazione di backup mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Pianificazione backup in Windows Server Backup. Verrà avviata la Pianificazione guidata backup.

  3. Nella pagina Attività iniziali fare clic su Avanti.

  4. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server. Questa è l'opzione consigliata.

    • Fare clic su Personalizzato per eseguire il backup solo di alcuni elementi e quindi fare clic su Avanti.

      1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative agli elementi di cui si desidera eseguire il backup. Se si desidera eseguire il backup solo di alcune cartelle o alcuni file, espandere l'albero delle cartelle e selezionare gli elementi da includere. Fare clic su OK.

      2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Esclusioni, su Aggiungi esclusioni e infine espandere l'albero delle cartelle e selezionare gli elementi da escludere.

      3. Nella scheda Impostazioni servizio Copia Shadow del volume selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK e quindi su Avanti.

  5. Nella pagina Impostazione ora backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Una volta al giorno e quindi selezionare nell'elenco a discesa l'ora di inizio desiderata per il backup giornaliero.

    • Fare clic su Più di una volta al giorno. Per selezionare l'ora di inizio, in Orari disponibili fare clic sull'ora di inizio desiderata per il backup e quindi fare clic su Aggiungi per spostare l'ora impostata in Orari pianificati. Ripetere questa procedura per ogni ora di inizio da aggiungere.

  6. Nella pagina Impostazione tipo destinazione selezionare Backup in una cartella di rete condivisa.

  7. Nella pagina Impostazione cartella condivisa remota digitare il percorso della cartella. All'interno di questa cartella ne verrà creata un'altra denominata WindowsImageBackup. Il backup creato verrà salvato in: \\<ServerRemoto>\<PercorsoCartellaCondivisa>\ WindowsImageBackup\<ComputerPerBackup>. Fare clic su Avanti.

  8. Verrà visualizzata la finestra di dialogo Registra pianificazione backup. Digitare il nome utente e la password di un account utente membro del gruppo Administrators o Backup Operators e con autorizzazioni di scrittura nel computer in cui si trova la cartella condivisa remota e quindi fare clic su OK.

  9. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine.

  10. Nella pagina Riepilogo fare clic su Chiudi.

Ulteriori considerazioni

  • Per configurare un backup pianificato, è necessario essere membri del gruppo Administrators o Backup Operators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

  • Dopo aver creato una pianificazione di backup, è consigliabile ricontrollare periodicamente le impostazioni per verificare che la configurazione hardware non sia cambiata e che venga ancora eseguito il backup di tutti gli elementi desiderati. Per istruzioni, vedere Modificare o interrompere una pianificazione di backup automatici.

Ulteriori riferimenti

  • Configurare backup automatici

  • Installare strumenti di Windows Server Backup


Configurare backup automatici con l'Utilità di pianificazione

Se si desidera creare una pianificazione per eseguire backup in orari e giorni diversi, è possibile utilizzare l'Utilità di pianificazione per creare una serie di attività che consentano di eseguire il comando Wbadmin start backup in base alla pianificazione desiderata oppure di avviare un file batch. Queste attività non verranno visualizzate nello snap-in Windows Server Backup di Microsoft Management Console (MMC). Se si utilizza questa utilità, è tuttavia necessario verificare che i backup eseguiti nell'ambito della pianificazione personalizzata non si sovrappongano a quelli eseguiti in base alla pianificazione regolare. In caso di conflitti, una delle operazioni di backup non verrà completata. Per l'attività seguente viene utilizzata la sintassi del comando per Windows Server 2008 R2.

Per utilizzare l'Utilità di pianificazione e il comando Wbadmin per creare una pianificazione di backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Utilità di pianificazione.

  2. Fare clic su Crea attività nel riquadro Azioni.

  3. Nella scheda Generale selezionare la casella di controllo Esegui con i privilegi più elevati.

  4. Nella scheda Azioni fare clic su Nuova e quindi eseguire le operazioni seguenti:

    1. Nell'elenco a discesa Azioni fare clic su Avvio programma.

    2. In Programma o script digitare:

      %windir%\System32\wbadmin.exe

    3. In Aggiungi argomenti digitare:

      start backup [-backupTarget:{<VolumeDestinazione> | <CondivisioneReteDestinazione>}] [-include:<ElemDaIncludere>] [-nonRecurseInclude:<ElemDaIncludere>] [-exclude:<ElemDaEscludere>] [-nonRecurseExclude:<ElemDaEscludere>] [-allCritical] [-systemState] [-noVerify] [-user:<NomeUtente>] [-password:<Password>] [-noInheritAcl] [-vssFull | -vssCopy] [-quiet]

    Per visualizzare la Guida per questo comando, nella riga di comando digitare:

    wbadmin start backup /?

  5. Ripetere il passaggio 4 per ogni backup da aggiungere.

  6. Per i restanti campi, seguire le istruzioni generali relative alla pianificazione di un'attività disponibili nella Guida dell'Utilità di pianificazione.

Ulteriori considerazioni

  • Per configurare un backup pianificato, è necessario essere membri del gruppo Administrators o Backup Operators oppure avere ricevuto in delega l'autorità appropriata.

  • Per eseguire questa attività direttamente, è inoltre possibile utilizzare il comando Schtasks. Per esempi, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143764. Per informazioni sulla sintassi del comando Schtasks, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkID=143763).

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di MMC. A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Configurare backup automatici con l'Utilità di pianificazione

  • Installare strumenti di Windows Server Backup


Modificare o interrompere una pianificazione di backup automatici

Dopo aver creato una pianificazione di backup mediante Windows Server Backup, è necessario controllare periodicamente la pianificazione per verificare che risponda ancora alle esigenze dell'azienda. È inoltre necessario controllare la configurazione dei backup pianificati ed eventualmente verificarla quando si aggiungono o rimuovono applicazioni, funzionalità, ruoli, volumi o dischi. Le selezioni eseguite durante la creazione della pianificazione dei backup vengono applicate alla Pianificazione guidata backup quando viene eseguita di nuovo per apportare modifiche.

Nota
  • È possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup per aggiornare i backup pianificati. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

  • Per aggiornare i backup pianificati, è inoltre possibile utilizzare il comando Wbadmin enable backup. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143762.

Per aggiornare una pianificazione di backup mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Pianificazione backup in Windows Server Backup. Verrà avviata la Pianificazione guidata backup.

  3. Nella pagina Modifica impostazioni backup pianificato fare clic su Modifica backup e quindi su Avanti.

  4. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server. Questa è l'opzione consigliata.

    • Fare clic su Personalizzato per eseguire il backup solo di volumi specifici e quindi fare clic su Avanti.

      1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative agli elementi di cui si desidera eseguire il backup. Se si desidera eseguire il backup solo di alcune cartelle o alcuni file in un disco o un volume, espandere l'albero delle cartelle e selezionare gli elementi da includere. Fare clic su OK.

      2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Esclusioni, su Aggiungi esclusioni e infine espandere l'albero delle cartelle e selezionare gli elementi da escludere.

      3. Nella scheda Impostazioni servizio Copia Shadow del volume selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK e quindi su Avanti.

  5. Nella pagina Impostazione ora backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Una volta al giorno e quindi immettere una nuova ora di inizio del backup giornaliero.

    • Fare clic su Più backup al giorno. Per selezionare l'ora di inizio, in Orari disponibili fare clic sull'ora di inizio desiderata per il backup e quindi fare clic su Aggiungi per spostare l'ora impostata in Orari pianificati. In Orario pianificato fare clic su Rimuovi per eliminare un orario. Ripetere l'operazione per ogni orario di inizio da aggiungere o rimuovere nella pianificazione.

  6. Nella pagina Impostazione tipo destinazione eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Selezionare Backup su un disco rigido dedicato ai backup (scelta consigliata). Nella pagina Mantieni o cambia destinazioni di backup selezionare una delle opzioni seguenti e quindi fare clic su Avanti:

      • Fare clic su Mantieni destinazioni di backup correnti.

      • Fare clic su Aggiungi altre destinazioni di backup e quindi su Avanti. Nella pagina Selezione disco di destinazione selezionare la casella di controllo relativa al disco che si desidera utilizzare e quindi fare clic su Avanti.

        Nota

        Per impostazione predefinita, il disco o i dischi più probabili vengono visualizzati nell'elenco. Si tratta dei dischi esterni che possono essere utilizzati per spostare i backup in un altro luogo per la protezione in caso di emergenza. Se il disco che si desidera utilizzare non è presente nell'elenco, fare clic su Mostra tutti i dischi disponibili. Selezionare quindi la casella di controllo accanto a ogni disco da utilizzare per archiviare i backup automatici.

      • Fare clic su Rimuovi destinazioni di backup correnti e quindi su Avanti. Nella pagina Rimuovi destinazioni correnti selezionare la casella di controllo relativa agli elementi che si desidera rimuovere e quindi fare clic su Avanti.

    • Selezionare Backup in un volume. Nella pagina Selezione volume di destinazione fare clic su Aggiungi. In Aggiungi volumi fare clic sul volume che si desidera utilizzare, quindi su OK e infine su Avanti.

    • Selezionare Backup in una cartella di rete condivisa. Nella pagina Impostazione cartella condivisa remota digitare il percorso della cartella. All'interno di questa cartella ne verrà creata un'altra denominata WindowsImageBackup. Il backup creato verrà salvato in: \\<ServerRemoto>\<PercorsoCartellaCondivisa>\ WindowsImageBackup\<ComputerPerBackup>. Fare clic su Avanti.

  7. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine. La pianificazione verrà modificata e tutti i dischi aggiunti verranno formattati.

  8. Nella pagina Riepilogo fare clic su Chiudi.

E' possibile, inoltre utilizzare questa procedura guidata per arrestare l'esecuzione di backup pianificati.

Per interrompere l'esecuzione di backup pianificati mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Pianificazione backup in Windows Server Backup. Verrà avviata la Pianificazione guidata backup.

  3. Nella pagina Modifica impostazioni backup pianificato fare clic su Interrompi backup per interrompere l'esecuzione dei backup pianificati e rendere disponibili il disco o i dischi in cui si stavano archiviando i backup, quindi fare clic su Avanti.

  4. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine. Verrà visualizzato un messaggio che richiede la conferma della modifica. Fare clic su Sì.

  5. Nella pagina Riepilogo fare clic su Chiudi.

Ulteriori considerazioni

  • Per modificare una pianificazione di backup utilizzando Windows Server Backup, è necessario essere membri del gruppo Administrators o Backup Operators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Eseguire il backup del server

  • Installare strumenti di Windows Server Backup

  • Configurare backup automatici


Configurare una pianificazione di backup per più dischi di archiviazione

È possibile utilizzare più dischi esterni per archiviare i backup, nonché passare tali dischi da sedi di archiviazione locali a sedi remote e viceversa. In questo modo è possibile migliorare la pianificazione per i casi di emergenza semplificando il ripristino dei dati qualora l'hardware locale subisca danni fisici.

Per ottimizzare la protezione è consigliabile seguire la procedura di rotazione del disco. Per questo scopo, recarsi presso la sede di archiviazione remota per consegnare i backup più recenti e recuperare i più datati. Al ritorno nella sede locale, inserire il disco prelevato dalla sede remota.

Per configurare una pianificazione di backup per più dischi

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Pianificazione backup in Windows Server Backup. Verrà avviata la Pianificazione guidata backup.

  3. Nella pagina Attività iniziali fare clic su Avanti.

  4. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server.

    • Fare clic su Personalizzato per eseguire il backup solo di alcuni elementi e quindi fare clic su Avanti.

      1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative agli elementi di cui si desidera eseguire il backup. Se si desidera eseguire il backup solo di alcune cartelle o alcuni file in un disco o un volume, espandere l'albero delle cartelle e selezionare gli elementi da includere. Fare clic su OK.

      2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Esclusioni, su Aggiungi esclusioni e infine espandere l'albero delle cartelle e selezionare gli elementi da escludere.

      3. Nella scheda Impostazioni servizio Copia Shadow del volume selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK e quindi su Avanti.

  5. Nella pagina Impostazione ora backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Una volta al giorno e quindi immettere l'ora di inizio del backup giornaliero.

    • Fare clic su Più backup al giorno. Per selezionare l'ora di inizio, in Orari disponibili fare clic sull'ora di inizio desiderata per il backup e quindi fare clic su Aggiungi per spostare l'ora impostata in Orari pianificati. Ripetere questa procedura per ogni ora di inizio da aggiungere.

  6. Nella pagina Impostazione tipo destinazione selezionare Backup su un disco rigido dedicato ai backup (scelta consigliata) e quindi fare clic su Avanti.

  7. Nella pagina Selezione disco di destinazione selezionare i dischi che si desidera utilizzare per archiviare i backup e quindi fare clic su Avanti.

    Per impostazione predefinita, nell'elenco vengono visualizzati il disco o i dischi più probabili. Si tratta dei dischi esterni che possono essere utilizzati per spostare i backup in un altro luogo per la protezione in caso di emergenza. Se l'elenco è vuoto oppure i dischi che si desidera utilizzare non sono presenti nell'elenco, fare clic su Mostra tutti i dischi disponibili. In Mostra tutti i dischi disponibili selezionare le caselle di controllo accanto ai dischi che si desidera utilizzare per archiviare i backup, fare clic su OK e quindi in Selezione disco di destinazione selezionare di nuovo le caselle di controllo relative ai dischi. Questi dischi non verranno più visualizzati in Esplora risorse per impedire che in essi vengano inavvertitamente archiviati e successivamente sovrascritti dati ed evitare la perdita accidentale dei backup.

  8. Verrà visualizzato un messaggio in cui si segnala che uno qualsiasi dei dischi selezionati potrà essere utilizzato per archiviare il primo backup. Fare clic su OK.

  9. Verrà visualizzato un messaggio nel quale si informa che i dischi selezionati verranno formattati ed eventuali dati esistenti verranno eliminati. Fare clic su Sì. Non fare clic su Sì se i dischi contengono dati necessari. Per utilizzare dischi diversi, fare clic su No e quindi selezionare i dischi desiderati in Dischi disponibili.

  10. Nella pagina Etichetta disco di destinazione sono elencati tutti i dischi selezionati. A ogni disco viene assegnata un'etichetta che include il nome del computer, la data corrente e il nome del disco. Fare clic su Avanti.

    Importante

    È consigliabile annotare e quindi applicare fisicamente le informazioni dell'etichetta su ogni disco esterno. Se si desidera ripristinare i dati dal backup archiviato nel disco, queste informazioni saranno necessarie per identificare il disco.

  11. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine. Il disco verrà formattato. Questa operazione può richiedere diversi minuti, a seconda delle dimensioni del disco.

  12. Nella pagina Riepilogo fare clic su Chiudi.

Ulteriori considerazioni

  • Per configurare una pianificazione di backup con Windows Server Backup, è necessario essere membri del gruppo Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

  • Per forzare il salvataggio di un backup in un disco specifico, scollegare o disabilitare tutti gli altri dischi della serie di backup.

Ulteriori riferimenti

  • Eseguire il backup del server

  • Installare strumenti di Windows Server Backup

  • Configurare backup automatici


Eseguire un backup manuale

È possibile creare un backup utilizzando la Creazione guidata backup unico, disponibile nello snap-in Windows Server Backup, oppure il comando Wbadmin start backup. La funzionalità per l'esecuzione di backup unici è stata progettata per consentire di creare backup che integrino quelli regolarmente pianificati. Non utilizzare i backup unici come unica soluzione di backup. Per informazioni, vedere Configurare backup automatici.

Per eseguire backup unici, è inoltre possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

Per integrare i backup regolari, è possibile utilizzare la Creazione guidata backup unico o il comando Wbadmin start backup allo scopo di:

  • Eseguire il backup di volumi non inclusi nei backup regolari.

  • Eseguire il backup di volumi contenenti elementi importanti prima di apportare modifiche quali l'installazione di aggiornamenti o di nuove funzionalità.

  • Creare un backup degli elementi inclusi nella pianificazione regolare in un percorso diverso rispetto a quello in cui vengono archiviati i backup pianificati.

Importante

È consigliabile, se possibile, archiviare in percorsi diversi i backup unici e i backup pianificati. Se i backup unici e i backup pianificati vengono salvati nello stesso percorso, è possibile che le operazioni di backup abbiano esito negativo a causa di conflitti o insufficienza di spazio, con una conseguente perdita delle versioni dei backup archiviate. Se è necessario utilizzare lo stesso percorso di archiviazione, verificare che lo spazio sia sufficiente per il salvataggio del backup prima di eseguire l'operazione. Non è inoltre possibile salvare backup nello stesso percorso se si utilizza la Creazione guidata backup unico e si scelgono impostazioni personalizzate. Se invece si utilizza il comando Wbadmin start backup per salvare backup unici nello stesso percorso dei backup pianificati, verrà visualizzato un avviso per informare che il backup pianificato verrà sovrascritto e che le versioni dei backup andranno perse.

Per creare un backup manuale mediante questa procedura guidata, utilizzare le procedure seguenti.

  • Eseguire un backup manuale in un disco collegato, un DVD o un supporto rimovibile

  • Eseguire un backup manuale in una cartella condivisa remota

Ulteriori considerazioni

  • Per utilizzare Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

Ulteriori riferimenti

  • Windows Server Backup

  • Installare strumenti di Windows Server Backup

  • Ripristinare il server


Eseguire un backup manuale in un disco collegato, un DVD o un supporto rimovibile

Se si esegue il backup in un disco collegato, sarà possibile ripristinare singoli file, cartelle, dati di applicazioni, volumi, lo stato del sistema e il sistema operativo.

Se si esegue il backup in un DVD, un altro supporto ottico o un supporto rimovibile, sarà possibile ripristinare solo interi volumi. Non è infatti possibile ripristinare singoli file e cartelle, lo stato del sistema o dati di applicazione direttamente da backup archiviati in questi tipi di supporto. I backup archiviati in un DVD o un supporto rimovibile vengono compressi, pertanto le dimensioni del backup nel DVD potrebbero risultare minori del volume sul server. È necessario tuttavia che nella destinazione del backup sia disponibile almeno 1 GB di spazio, altrimenti verrà bloccata nell'elenco delle destinazioni di backup disponibili. Se un backup su DVD contiene tutti i volumi critici (volumi con i componenti di sistema necessari per ripristinare il sistema operativo), è possibile utilizzare tale backup per ripristinare il sistema operativo del server mediante un ripristino del sistema.

Prima di tentare di eseguire il backup in un disco collegato, un DVD o un supporto rimovibile, è innanzitutto necessario:

  • Identificare un percorso per l'archiviazione dei backup. Per ulteriori informazioni sulla scelta di un percorso di archiviazione, vedere Eseguire il backup del server. Se si utilizza un disco locale, accertarsi che il disco supporti le specifiche USB 2.0 o IEEE 1394, sia interno o sia collegato al server. È inoltre consigliabile, se possibile, archiviare in percorsi diversi i backup unici e i backup pianificati. Se i backup unici e i backup pianificati vengono salvati nello stesso percorso, è possibile che le operazioni di backup abbiano esito negativo a causa di conflitti o insufficienza di spazio, con una conseguente perdita delle versioni dei backup archiviate. Se è necessario utilizzare lo stesso percorso di archiviazione, verificare che lo spazio sia sufficiente per il salvataggio del backup prima di eseguire l'operazione. Non è inoltre possibile salvare backup nello stesso percorso se si utilizza la Creazione guidata backup unico e si scelgono impostazioni personalizzate.

  • Se si utilizzano DVD, accertarsi che un masterizzatore DVD sia collegato al server e sia online e che sia disponibile un numero sufficiente di DVD vuoti per archiviare il contenuto di tutti i volumi di cui si intende eseguire il backup. Se il backup è troppo vasto per un DVD, è possibile che siano necessari vari DVD.

  • Scegliere gli elementi da includere nel backup, ovvero il server completo o solo alcuni elementi. Per ulteriori informazioni sulla scelta degli elementi da includere nel backup, vedere Eseguire il backup del server.

Per creare un backup manuale in un disco collegato, un DVD o un supporto rimovibile

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Backup unico in Windows Server Backup. Verrà avviata la Creazione guidata backup unico.

  3. Nella pagina Opzioni di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Opzioni backup pianificato.

    • Fare clic su Opzioni diverse.

      1. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

        1. Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server. Questa è l'opzione consigliata.

        2. Fare clic su Personalizzato per eseguire il backup solo di alcuni elementi e quindi fare clic su Avanti.

          1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative agli elementi di cui si desidera eseguire il backup. Se si desidera eseguire il backup solo di alcune cartelle o alcuni file, espandere l'albero delle cartelle e selezionare gli elementi da includere. Fare clic su OK.

          2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Esclusioni, su Aggiungi esclusioni e infine espandere l'albero delle cartelle e selezionare gli elementi da escludere.

          3. Nella scheda Impostazioni servizio Copia Shadow del volume selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK e quindi su Avanti.

      2. Nella pagina Impostazione tipo destinazione fare clic su Unità locali e quindi su Avanti.

      3. Nella pagina Selezione destinazione backup selezionare nell'elenco a discesa la destinazione che si desidera utilizzare per archiviare il backup. Se si sceglie un disco rigido, verificare che lo spazio libero nel disco sia sufficiente. Se si sceglie un'unità DVD o un altro supporto ottico, specificare se il contenuto deve essere verificato dopo che è stato scritto selezionando la casella di controllo Verifica dopo la scrittura.

  4. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Backup. Verrà preparato il set di backup e verrà controllato il supporto. Se il supporto è in formato UDF o NTFS e ha una capacità di archiviazione superiore a 1 GB, l'operazione di backup verrà eseguita. In caso contrario, verrà visualizzato un messaggio per informare che il supporto non dispone di spazio sufficiente oppure che il formato non è supportato. È possibile scegliere di riformattare il supporto o inserire un nuovo supporto.

  5. Nella pagina Stato backup è possibile visualizzare lo stato del backup. Se si esegue il backup su un DVD, all'avvio del backup verrà visualizzato un messaggio in cui si chiede di inserire il primo DVD nell'unità e quindi, se il backup è troppo vasto per un solo DVD, durante il corso del backup verranno richiesti i successivi DVD. Durante questo processo, è necessario scrivere fisicamente le informazioni presenti accanto a Etichetta disco nel messaggio sul DVD inserito. Queste informazioni saranno necessarie in seguito per eseguire un ripristino.

Ulteriori considerazioni

  • Per creare un backup con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Eseguire un backup manuale

  • Installare strumenti di Windows Server Backup

  • Eseguire un backup manuale in una cartella condivisa remota

  • Ripristinare il server


Eseguire un backup manuale in una cartella condivisa remota

Per eseguire il backup in una cartella condivisa remota, è innanzitutto necessario:

  • Verificare di avere accesso a un account membro del gruppo Administrators o Backup Operators nel computer utilizzato per eseguire il backup e nel computer contenente la cartella condivisa remota. Verificare inoltre di avere accesso in scrittura alla cartella condivisa remota.

  • Scegliere gli elementi da includere nel backup, ovvero il server completo o solo alcuni elementi. Per ulteriori informazioni sulla scelta degli elementi da includere nel backup, vedere Eseguire il backup del server.

  • Se nel dominio è stato abilitato IPsec e si desidera utilizzare una cartella condivisa remota per salvare il backup, è necessario salvarlo in una cartella condivisa all'interno di un computer che rientri nei limiti di IPsec. In caso contrario, quando si tenterà di eseguire un ripristino mediante Ambiente ripristino Windows non sarà possibile accedere alla cartella condivisa.

Importante

Se si salva un backup in una cartella condivisa remota, tale backup verrà sovrascritto se si utilizza la stessa cartella per eseguire un nuovo backup dello stesso computer. Inoltre, se il processo di backup non riesce, potrebbe non essere disponibile alcun backup poiché il precedente viene sovrascritto, mentre il nuovo backup è inutilizzabile.

Per creare un backup manuale e salvarlo in una cartella condivisa remota

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Backup unico in Windows Server Backup. Verrà avviata la Creazione guidata backup unico.

  3. Nella pagina Opzioni di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Opzioni backup pianificato.

    • Fare clic su Opzioni diverse.

      1. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

        1. Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server. Questa è l'opzione consigliata.

        2. Fare clic su Personalizzato per eseguire il backup solo di alcuni elementi e quindi fare clic su Avanti.

          1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative agli elementi di cui si desidera eseguire il backup. Se si desidera eseguire il backup solo di alcune cartelle o alcuni file, espandere l'albero delle cartelle e selezionare gli elementi da includere. Fare clic su OK.

          2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Esclusioni, su Aggiungi esclusioni e infine espandere l'albero delle cartelle e selezionare gli elementi da escludere.

          3. Nella scheda Impostazioni servizio Copia Shadow del volume selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK.

      2. Nella pagina Impostazione tipo destinazione fare clic su Cartella condivisa remota e quindi su Avanti.

      3. Nella pagina Impostazione cartella remota digitare il percorso della cartella. All'interno di questa cartella ne verrà creata un'altra denominata WindowsImageBackup. Il backup creato verrà salvato in: \\<RemoteServer>\<SharedFolderPath>\WindowsImageBackup\<ComputerBackedUp>.

      4. Nella pagina Impostazione cartella remota eseguire inoltre una delle operazioni seguenti:

        • Fare clic su Non ereditare se si desidera che il backup sia accessibile solo con le credenziali utente utilizzate per crearlo, quindi fare clic su Avanti. Immettere un nome utente e una password per un account utente con autorizzazioni di scrittura nel computer in cui si trova la cartella remota, quindi fare clic su OK.

        • Fare clic su Eredita se si desidera che il backup sia accessibile a chiunque abbia accesso alla cartella condivisa remota, quindi fare clic su Avanti.

        Nota

        Se in questo percorso è già stato archiviato un backup, verrà visualizzato un messaggio in cui si avvisa che il backup verrà sovrascritto. Per impedire questa operazione, fare clic su Annulla e quindi specificare una cartella condivisa diversa.

  4. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Backup. Verrà preparato il set di backup, verrà confermato l'accesso alla cartella condivisa remota e verrà creato il backup.

  5. Nella pagina Stato backup è possibile visualizzare lo stato del backup.

Ulteriori considerazioni

  • Per creare un backup singolo con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Eseguire un backup manuale

  • Installare strumenti di Windows Server Backup

  • Eseguire un backup manuale in un disco collegato, un DVD o un supporto rimovibile

  • Ripristinare il server


Creare backup dello stato del sistema tramite riga di comando

In Windows Server 2008 R2 è possibile utilizzare la Pianificazione guidata backup, la Creazione guidata backup unico, il comando Wbadmin start systemstatebackup, il comando Wbadmin enable backup oppure i cmdlet Windows PowerShell per Windows Server Backup per creare un backup dello stato del sistema di un server. Il backup dello stato del sistema può essere salvato in un disco collegato al computer locale (interno o esterno) o in una cartella condivisa remota. Non è possibile eseguire il salvataggio su DVD, supporti ottici o altri supporti di archiviazione rimovibili. Quando si crea un backup dello stato del sistema, è inoltre possibile aggiungere altri file, cartelle e volumi da ripristinare.

In questo argomento viene descritto come utilizzare il comando Wbadmin start systemstatebackup per creare un backup unico dello stato del sistema e il comando Wbadmin enable backup per creare un backup pianificato dello stato del sistema. Per informazioni su altri metodi, vedere le risorse seguenti:

  • Per istruzioni sull'utilizzo della Pianificazione guidata backup, vedere Configurare backup automatici.

  • Per istruzioni sull'utilizzo della Creazione guidata backup unico, vedere Eseguire un backup manuale.

  • Per ulteriori informazioni sui cmdlet Windows PowerShell per Windows Server Backup, vedere Utilizzare i cmdlet per Windows Server Backup.

Per creare un backup dello stato del sistema utilizzando il comando Wbadmin start systemstatebackup

  1. Per aprire un prompt dei comandi con privilegi elevati, fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    wbadmin start systemstatebackup -backupTarget:<NomeVolume> [-quiet]

    Per creare ad esempio un backup dello stato del sistema senza richiedere l'intervento dell'utente e salvarlo nel volume F, digitare:

    wbadmin start systemstatebackup -backupTarget:F: -quiet

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:

    Wbadmin start systemstatebackup /?

Per creare un backup pianificato dello stato del sistema utilizzando il comando Wbadmin enable backup

  1. Per aprire un prompt dei comandi con privilegi elevati, fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    wbadmin enable backup [-addtarget:<DestinazioneBackup>] [-removetarget:<DestinazioneBackup>] [-schedule:<OraEsecuzioneBackup>] [-include:<ElemDaIncludere> [-nonRecurseInclude:<ElemDaIncludere>] [-exclude:<ElemDaEscludere>] [-nonRecurseExclude:<ElemDaEscludere>] [-allCritical] [-systemState] [-vssFull | -vssCopy] [-user:<NomeUtente>] [-password:<Password>] [-quiet]

    Per creare ad esempio un backup dello stato del sistema ogni giorno alle 9.00 senza richiedere l'intervento dell'utente e salvarlo nel volume F, digitare:

    wbadmin enable backup -addtarget:F: -schedule:09:00 -systemState -quiet

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:

    Wbadmin enable backup /?

Ulteriori considerazioni

  • Per creare un backup dello stato del sistema utilizzando le funzionalità di Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Per creare un backup dello stato del sistema e al tempo stesso aggiungere altri elementi al backup, è possibile utilizzare il comando Wbadmin start backup con i parametri -systemState, -include e -nonRecurseInclude. Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:

    Wbadmin start backup /?

Ulteriori riferimenti

  • Eseguire il backup del server

  • Installare strumenti di Windows Server Backup


Eseguire il backup di applicazioni e dati

È possibile utilizzare Windows Server Backup per creare backup per il ripristino di applicazioni e dati di applicazioni. Per eseguire questa operazione, è necessario che l'applicazione contenga un writer del servizio Copia Shadow del volume (VSS) in modo che possa registrarsi in Windows Server Backup e che l'applicazione e il writer siano in esecuzione nel momento in cui viene creato il backup. Per istruzioni sulla registrazione di un'applicazione in Windows Server Backup, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93493. Per istruzioni sull'utilizzo di VSS, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=95935.

Per eseguire il backup di un'applicazione supportata, è innanzitutto necessario:

  • Identificare un percorso per l'archiviazione dei backup. I backup delle applicazioni devono essere archiviati in dischi collegati o cartelle condivise remote e non in supporti ottici o rimovibili. Per ulteriori informazioni sulla scelta di un percorso di archiviazione, vedere Eseguire il backup del server. Verificare che tutti i dischi rigidi per l'archiviazione dei backup siano collegati e online. Se si utilizza un disco rigido esterno, è consigliabile sceglierne uno che supporti la specifica USB 2.0 o IEEE 1394. Il disco dovrebbe avere una capacità di archiviazione pari almeno a 2,5 volte le dimensioni della serie di elementi di cui si desidera eseguire il backup. Se si utilizza un disco dedicato per l'archiviazione dei backup, tale disco deve essere vuoto o contenere dati che non è necessario mantenere perché verrà formattato da Windows Server Backup durante la preparazione per il backup. Se i backup pianificati vengono archiviati in una cartella condivisa remota, verranno sovrascritti ogni volta che si crea un nuovo backup. Non utilizzare questa opzione se si desidera archiviare più backup.

  • Scegliere i volumi da includere nel backup. Affinché un'applicazione possa essere ripristinata da un backup, è necessario che sia stato eseguito il backup del volume o dei volumi completi contenenti l'applicazione. Per ulteriori informazioni sulla scelta degli elementi da includere nel backup, vedere Eseguire il backup del server.

  • Se si desidera creare un backup pianificato, scegliere se eseguire i backup una o più volte al giorno.

  • Quando l'esecuzione dei backup ha inizio, monitorare lo stato utilizzando le sezioni Messaggi, Stato e Backup pianificato della pagina predefinita dello snap-in.

Nota
  • È possibile utilizzare la Creazione guidata backup unico per creare un backup unico per il ripristino dell'applicazione.

  • È possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup per creare backup unici o pianificati. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

  • È possibile utilizzare il comando Wbadmin enable backup o Wbadmin start backup per creare backup per il ripristino di applicazioni. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140216.

Per creare un backup pianificato da utilizzare per il ripristino di applicazioni

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Pianificazione backup in Windows Server Backup. Verrà avviata la Pianificazione guidata backup.

  3. Nella pagina Attività iniziali fare clic su Avanti.

  4. Nella pagina Selezione configurazione di backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Server completo (opzione consigliata) per eseguire il backup di tutti i volumi nel server, inclusi quelli contenenti l'applicazione. Questa è l'opzione consigliata.

    • Fare clic su Personalizzato per eseguire il backup solo di alcuni volumi e quindi fare clic su Avanti.

      1. Nella pagina Selezione elementi per backup fare clic su Aggiungi elementi. In Seleziona elementi selezionare le caselle di controllo relative ai volumi contenenti l'applicazione. Fare clic su OK.

      2. Nella pagina Selezione elementi per backup fare clic su Impostazioni avanzate, quindi fare clic sulla scheda Impostazioni servizio Copia Shadow del volume e infine selezionare Backup completo del servizio Copia Shadow del volume o Backup di copia del servizio Copia Shadow del volume. Fare clic su OK e quindi su Avanti.

  5. Nella pagina Impostazione ora backup eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Una volta al giorno e quindi selezionare nell'elenco a discesa l'ora di inizio desiderata per il backup giornaliero.

    • Fare clic su Più di una volta al giorno. Per selezionare l'ora di inizio, in Orari disponibili fare clic sull'ora di inizio desiderata per il backup e quindi fare clic su Aggiungi per spostare l'ora impostata in Orari pianificati. Ripetere questa procedura per ogni ora di inizio da aggiungere.

  6. Nella pagina Impostazione tipo destinazione eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Selezionare Backup su un disco rigido dedicato ai backup (scelta consigliata).

      1. Nella pagina Selezione disco di destinazione selezionare la casella di controllo relativa al disco collegato per questo scopo e quindi fare clic su Avanti.

      2. Per impostazione predefinita, nell'elenco vengono visualizzati il disco o i dischi più probabili. Si tratta dei dischi esterni che possono essere utilizzati per spostare i backup in un altro luogo per la protezione in caso di emergenza. Se l'elenco è vuoto oppure il disco che si desidera utilizzare non è presente nell'elenco, fare clic su Mostra tutti i dischi disponibili. In Mostra tutti i dischi disponibili selezionare la casella di controllo accanto al disco che si desidera utilizzare per archiviare i backup, fare clic su OK e quindi in Selezione disco di destinazione selezionare di nuovo la casella di controllo relativa al disco. Questo disco non verrà più visualizzato in Esplora risorse per impedire che nell'unità vengano inavvertitamente archiviati e successivamente sovrascritti dati ed evitare la perdita accidentale dei backup.

      3. Verrà visualizzato un messaggio per informare che il disco selezionato sarà formattato ed eventuali dati esistenti verranno eliminati. Fare clic su Sì. Non fare clic su Sì se il disco contiene dati necessari. Per utilizzare un disco diverso, fare clic su No e quindi selezionare il disco desiderato in Dischi disponibili.

      Importante

      È consigliabile annotare e quindi applicare fisicamente le informazioni dell'etichetta a tutti i dischi esterni utilizzati per l'archiviazione dei backup. Se si desidera ripristinare i dati dal backup archiviato nel disco, queste informazioni saranno necessarie per identificare il disco.

    • Selezionare Backup in una cartella di rete condivisa.

      1. Nella pagina Impostazione cartella condivisa remota digitare il percorso della cartella. All'interno di questa cartella ne verrà creata un'altra denominata WindowsImageBackup. Il backup creato verrà salvato in: \\<RemoteServer>\<SharedFolderPath>\WindowsImageBackup\<ComputerBackedUp>.

      2. Nella pagina Impostazione cartella condivisa remota fare clic su Non ereditare se si desidera che il backup sia accessibile solo se vengono specificate le stesse credenziali utente utilizzate per crearlo e quindi fare clic su Avanti. Verrà visualizzata la finestra di dialogo Registra pianificazione backup. Digitare il nome utente e la password di un account utente con autorizzazioni di scrittura nel computer in cui si trova la cartella remota e quindi fare clic su OK.

  7. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine. Se si utilizza un disco dedicato per l'archiviazione, tale disco verrà formattato automaticamente dalla procedura guidata. L'operazione potrebbe richiedere alcuni minuti in base alla dimensione del disco.

  8. Nella pagina Riepilogo fare clic su Chiudi.

Ulteriori considerazioni

  • Per creare backup unici, è necessario essere membri del gruppo Administrators o Backup Operators oppure avere ricevuto in delega l'autorità appropriata.

Ulteriori riferimenti

  • Configurare backup automatici

  • Installare strumenti di Windows Server Backup

  • Ripristinare applicazioni e dati


Ripristinare il server

È possibile utilizzare i backup creati con Windows Server Backup per ripristinare il sistema operativo, lo stato del sistema, volumi, applicazioni e dati di applicazioni, il catalogo di backup nonché file e cartelle locali. A tale scopo, utilizzare gli strumenti seguenti:

Strumento Elemento ripristinabile

Ripristino guidato (in Windows Server Backup)

File, cartelle, volumi, stato del sistema, applicazioni e dati di applicazioni

Disco Installazione di Windows oppure un'installazione separata di Ambiente ripristino Windows

Sistema operativo (volumi critici) e server completo (tutti i volumi)

Ripristino guidato catalogo (in Windows Server Backup)

Nota

Ripristino guidato catalogo è disponibile in Windows Server Backup solo se il catalogo di backup è danneggiato.

Catalogo di backup

Per eseguire queste attività, è inoltre possibile utilizzare il comando Wbadmin. Per informazioni sulla sintassi di questo comando, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216). Non è possibile eseguire ripristini utilizzando i cmdlet Windows PowerShell per Windows Server Backup.

Per istruzioni specifiche sul ripristino di Servizi di dominio Active Directory, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143754.

In questa sezione sono disponibili istruzioni per eseguire le operazioni seguenti:

  • Ripristinare file e cartelle

  • Ripristinare applicazioni e dati

  • Ripristinare i volumi

  • Ripristinare il sistema operativo o il server completo

  • Ripristinare lo stato del sistema

  • Ripristinare un catalogo di backup

Ulteriori considerazioni

  • Per eseguire i ripristini con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Non è possibile ripristinare i backup creati con Ntbackup.exe utilizzando Windows Server Backup (Wbadmin.exe). Tuttavia, gli utenti di Windows Server 2008 che desiderano ripristinare dati da backup creati con Ntbackup.exe possono scaricare una versione di Ntbackup.exe destinata esclusivamente al ripristino di backup legacy, che non può essere utilizzata per creare nuovi backup in Windows Server 2008. Per scaricare questa versione limitata di Ntbackup.exe, vedere http://go.microsoft.com/fwlink/?LinkId=82917.

  • Se si esegue il ripristino del sistema operativo su un nuovo disco rigido, verificare che il disco abbia almeno le dimensioni del disco che conteneva i volumi di cui è stato eseguito il backup, indipendentemente dalla dimensione dei volumi. Se ad esempio durante il backup era presente un solo volume con una capacità di 100 GB su un disco da 1 TB, è consigliabile utilizzare un disco di almeno 1 TB durante il ripristino.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server ed è necessario eseguire un ripristino, assicurarsi di riapplicare Crittografia unità BitLocker al server. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Risorse aggiuntive

  • Windows Server Backup

  • Installare strumenti di Windows Server Backup

  • Eseguire il backup del server


Ripristinare file e cartelle

È possibile utilizzare Ripristino guidato in Windows Server Backup per ripristinare file e cartelle da un backup. Prima di iniziare, è necessario:

  • Verificare che sia disponibile almeno un backup in un disco esterno o in una cartella di condivisione remota, poiché non è possibile ripristinare file e cartelle da backup salvati su DVD o supporti rimovibili. Se si desidera ripristinare un computer che esegue Windows Server 2008, verificare inoltre che non si tratti di un backup dello stato del sistema. Non è infatti possibile ripristinare file e cartelle da un backup dello stato del sistema. Per istruzioni sulla creazione di un backup per il ripristino di file e cartelle, vedere Configurare backup automatici ed Eseguire un backup manuale.

  • Verificare che il disco esterno o la cartella condivisa remota che contiene il backup sia online e disponibile per il server.

  • Determinare i file o le cartelle che si desidera ripristinare.

Nota

Per eseguire questa attività, è inoltre possibile utilizzare il comando Wbadmin start recovery. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143758.

Per ripristinare file e cartelle mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni nella pagina predefinita dello snap-in fare clic su Ripristino in Windows Server Backup. Verrà avviato il Ripristino guidato.

  3. Nella pagina Attività iniziali eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Questo server.

    • Fare clic su Altro server. Nella pagina Impostazione tipo di percorso eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

      • Fare clic su Unità locali. Nella pagina Selezione percorso di backup selezionare nell'elenco a discesa il volume o l'unità contenente il backup. In Selezione server selezionare il server di cui si desidera ripristinare i dati.

      • Fare clic su Cartella condivisa remota. Nella pagina Impostazione cartella remota digitare il percorso della cartella contenente il backup. In tale cartella il backup dovrebbe essere archiviato in \\<RemoteSharedFolder>\WindowsImageBackup\<ComputerName>\<YourBackup>.

  4. Nella pagina Selezione data backup selezionare la data nel calendario e l'ora nell'elenco a discesa relative al backup da cui si desidera eseguire il ripristino. Fare clic su Avanti.

  5. Nella pagina Selezione tipo di ripristino fare clic su File e cartelle e quindi su Avanti.

  6. Nella pagina Selezione elementi da ripristinare espandere l'elenco in Elementi disponibili fino a visualizzare la cartella desiderata. Fare clic su una cartella per visualizzarne il contenuto nel riquadro adiacente, quindi sui singoli elementi da ripristinare e infine su Avanti.

    Nota

    Utilizzando MAIUSC e CTRL è possibile selezionare un gruppo o una serie di elementi specifici.

  7. Nella pagina Impostazione opzioni di ripristino, in Percorso di ripristino, eseguire una delle operazioni seguenti:

    • Fare clic su Percorso originale.

    • Fare clic su Altro percorso. Digitare quindi il percorso oppure fare clic su Sfoglia per selezionarlo.

  8. In Se nel backup vengono trovati elementi già presenti nella destinazione di ripristino selezionare una delle opzioni seguenti e quindi fare clic su Avanti:

    1. Crea copie, in modo da mantenere entrambe le versioni

    2. Sovrascrivi le versioni esistenti con quelle ripristinate

    3. Non ripristinare gli elementi già presenti nella destinazione di ripristino

  9. In Impostazioni sicurezza selezionare se necessario la casella di controllo Ripristina autorizzazioni dell'elenco di controllo di accesso (ACL) per il file o la cartella da ripristinare e quindi fare clic su Avanti.

  10. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Ripristina per ripristinare gli elementi specificati.

  11. Nella pagina Stato ripristino è possibile visualizzare lo stato dell'operazione di ripristino e verificare la corretta esecuzione dell'operazione.

Ulteriori considerazioni

  • Per ripristinare file e cartelle da un backup con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Ripristinare il server

  • Ripristino guidato


Ripristinare applicazioni e dati

È possibile utilizzare Ripristino guidato in Windows Server Backup per ripristinare applicazioni e dati correlati da un backup. Per eseguire questa operazione, è necessario che l'applicazione contenga un writer del servizio Copia Shadow del volume (VSS) in modo che possa registrarsi in Windows Server Backup e che l'applicazione e il writer siano in esecuzione nel momento in cui viene creato il backup da utilizzare per il ripristino. Per istruzioni sulla registrazione di un'applicazione in Windows Server Backup, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93493. Per istruzioni sull'utilizzo di VSS, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=95935.

Prima di iniziare, verificare che esista almeno un backup dell'applicazione in un disco locale o una cartella condivisa remota e che il disco sia collegato e online oppure che la cartella condivisa remota sia disponibile. Per istruzioni sulla creazione di un backup per il ripristino di applicazioni, vedere Eseguire il backup di applicazioni e dati.

Nota

Per eseguire questa attività, è inoltre possibile utilizzare il comando Wbadmin start recovery. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143758.

Per ripristinare un'applicazione mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni nella pagina predefinita dello snap-in fare clic su Ripristino in Windows Server Backup. Verrà avviato il Ripristino guidato.

  3. Nella pagina Attività iniziali eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Questo server.

    • Fare clic su Altro server. Nella pagina Impostazione tipo di percorso eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

      • Fare clic su Unità locali. Nella pagina Selezione percorso di backup selezionare nell'elenco a discesa il volume o l'unità contenente il backup. In Selezione server selezionare il server di cui si desidera ripristinare i dati.

      • Fare clic su Cartella condivisa remota. Nella pagina Impostazione cartella remota digitare il percorso della cartella contenente il backup. In tale cartella il backup dovrebbe essere archiviato in \\<RemoteSharedFolder>\WindowsImageBackup\<ComputerName>\<YourBackup>.

  4. Nella pagina Selezione data backup selezionare la data nel calendario e l'ora nell'elenco a discesa relative al backup da cui si desidera eseguire il ripristino e quindi fare clic su Avanti.

  5. Nella pagina Selezione tipo di ripristino fare clic su Applicazioni e quindi su Avanti.

  6. Nella pagina Selezione applicazione, in Applicazioni, fare clic sull'applicazione da ripristinare. Se il backup in uso è il più recente e l'applicazione da ripristinare supporta il roll forward del database dell'applicazione, verrà visualizzata la casella di controllo Non eseguire ripristino roll forward dei database dell'applicazione. Selezionare questa casella di controllo per impedire a Windows Server Backup di eseguire il roll forward del database dell'applicazione presente sul server. Fare clic su Avanti.

  7. Nella pagina Impostazione opzioni di ripristino, in Percorso di ripristino, eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Ripristina nel percorso originale.

    • Fare clic su Ripristina in un percorso diverso. Digitare quindi il percorso oppure fare clic su Sfoglia per selezionarlo.

    Importante

    Sebbene sia possibile copiare un'applicazione in un percorso diverso, non è possibile ripristinare un'applicazione in un percorso diverso o in computer con un nome diverso.

  8. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Ripristina per ripristinare gli elementi elencati.

  9. Nella pagina Stato ripristino è possibile visualizzare lo stato dell'operazione di ripristino e verificare la corretta esecuzione dell'operazione.

Ulteriori considerazioni

  • Per ripristinare applicazioni da un backup con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Ripristinare il server


Ripristinare i volumi

È possibile utilizzare Ripristino guidato in Windows Server Backup per ripristinare un volume. Quando si ripristina un volume completo, viene ripristinato tutto il contenuto. Questa opzione non consente di ripristinare singoli file o cartelle. Se si desidera ripristinare solo alcuni file o cartelle anziché un intero volume, vedere Ripristinare file e cartelle.

Prima di iniziare, è necessario:

  • Verificare che il disco esterno o la cartella condivisa che contiene il backup sia online e disponibile per il server. In alternativa, se si utilizza un backup su DVD o supporti rimovibili, verificare che l'unità DVD o il dispositivo sia collegato al server locale e sia online e che tutti i DVD contenenti il backup siano etichettati e disponibili. Per istruzioni sulla creazione di un backup per il ripristino di volumi, vedere Configurare backup automatici ed Eseguire un backup manuale.

  • Identificare i volumi da ripristinare.

Nota

Per eseguire questa attività, è inoltre possibile utilizzare il comando Wbadmin start recovery. Per esempi e informazioni sulla sintassi per questo comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143758.

Per ripristinare volumi mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni nella pagina predefinita dello snap-in fare clic su Ripristino in Windows Server Backup. Verrà avviato il Ripristino guidato.

  3. Nella pagina Attività iniziali eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Questo server.

    • Fare clic su Altro server. Nella pagina Impostazione tipo di percorso eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

      • Fare clic su Unità locali. Nella pagina Selezione percorso di backup selezionare nell'elenco a discesa il volume o l'unità contenente il backup. In Selezione server selezionare il server di cui si desidera ripristinare i dati.

      • Fare clic su Cartella condivisa remota. Nella pagina Impostazione cartella remota digitare il percorso della cartella contenente il backup. In tale cartella il backup dovrebbe essere archiviato in \\<RemoteSharedFolder>\WindowsImageBackup\<ComputerName>\<YourBackup>.

  4. Nella pagina Selezione data backup selezionare la data nel calendario e l'ora nell'elenco a discesa relative al backup da cui si desidera eseguire il ripristino.

  5. Nella pagina Selezione tipo di ripristino fare clic su Volumi e quindi su Avanti.

  6. Nella pagina Selezione volumi selezionare le caselle di controllo associate ai volumi che si desidera ripristinare nella colonna Volume di origine. Nell'elenco a discesa associato nella colonna Volume di destinazione selezionare il percorso in cui ripristinare il volume. Fare clic su Avanti.

    Importante

    Verrà visualizzato un messaggio in cui si segnala che, eseguendo il ripristino, tutti i dati nel volume di destinazione andranno perduti. Verificare che il volume di destinazione sia vuoto o non contenga informazioni utili.

  7. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Ripristina per ripristinare i volumi specificati.

  8. Nella pagina Stato ripristino è possibile visualizzare lo stato dell'operazione di ripristino e verificare la corretta esecuzione dell'operazione.

Ulteriori considerazioni

  • Per ripristinare volumi da un backup con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server ed è necessario eseguire un ripristino, assicurarsi di riapplicare Crittografia unità BitLocker al server. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Ripristinare il server

  • Ripristino guidato


Ripristinare il sistema operativo o il server completo

È possibile ripristinare il sistema operativo del server oppure il server completo utilizzando Ambiente ripristino Windows e un backup creato in precedenza con Windows Server Backup.

Per accedere agli strumenti di ripristino e risoluzione dei problemi in Ambiente ripristino Windows, utilizzare la finestra di dialogo Opzioni ripristino di sistema della procedura guidata di installazione di Windows. Per avviare questa procedura guidata in Windows Server 2008 R2, utilizzare il disco di installazione di Windows o avviare/riavviare il computer, premere F8 e quindi selezionare Ripristina il computer nell'elenco delle opzioni di avvio.

È inoltre possibile configurare i server per il failover in Ambiente ripristino Windows in caso di problemi di avvio. Per istruzioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94458.

Per ripristinare il sistema operativo, è necessario eseguire un ripristino bare metal e scegliere le opzioni che consentono di ripristinare solo i dati presenti nei volumi critici, ovvero i volumi contenenti i file del sistema operativo.

Per eseguire il ripristino del sistema operativo o del server completo, è necessario specificare quanto segue:

  • Backup che verrà utilizzato

  • Tipo di ripristino, ovvero solo del sistema operativo o del server completo

  • Eventuale riformattazione e ripartizionamento dei dischi

Importante

In un ripristino del server completo se si sceglie di riformattare e ripartizionare tutti i dischi, i dati esistenti verranno eliminati, Lo stesso avviene per i volumi utilizzati dal server non inclusi nel backup. Questa opzione non è disponibile quando si accede ad Ambiente ripristino Windows premendo F8 anziché utilizzando un disco di installazione di Windows.

Per ripristinare il sistema operativo o un server completo, eseguire prima le operazioni seguenti:

  • Se si esegue il ripristino su un nuovo disco rigido, verificare che il disco abbia almeno le dimensioni del disco che conteneva i volumi di cui è stato eseguito il backup, indipendentemente dalla dimensione dei volumi. Se ad esempio durante il backup era presente un solo volume con una capacità di 100 GB su un disco da 1 TB, è consigliabile utilizzare un disco di almeno 1 TB durante il ripristino.

  • Se si ripristina solo il sistema operativo, accertarsi che sia disponibile un backup contenente almeno i volumi critici del server. Se si ripristina il server completo, accertarsi che sia disponibile un backup contenente tutti i volumi del server. Per eseguire un ripristino bare metal, verificare che sia abilitato un backup per questo tipo di ripristino o un ripristino del server completo. Per istruzioni sulla creazione dei backup, vedere Eseguire un backup manuale e Configurare backup automatici.

Importante

Se nel percorso in cui vengono archiviati i backup si utilizza Crittografia unità BitLocker, verificare che non sia bloccato. Per un ripristino a livello di volume, come quello descritto in questa procedura, non è tuttavia necessario sbloccare il percorso in cui si esegue il ripristino. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Per ripristinare il sistema operativo o il server completo utilizzando un backup creato in precedenza e un disco di installazione di Windows

  1. Inserire il disco di installazione di Windows con la stessa architettura del sistema che si sta tentando di ripristinare nell'unità CD o DVD e avviare o riavviare il computer. Se necessario, premere il tasto per l'avvio dal disco. Verrà visualizzata l'Installazione guidata Windows.

  2. In Installazione di Windows specificare le impostazioni della lingua e quindi fare clic su Avanti.

  3. Fare clic su Ripristina il computer.

  4. Verrà eseguita una ricerca di un'installazione di Windows esistente nelle unità disco rigido e i risultati verranno visualizzati in Opzioni ripristino di sistema. Se si esegue il ripristino del sistema operativo in un componente hardware separato, l'elenco risulterà vuoto (nessun sistema operativo nel computer). Fare clic su Avanti.

  5. Nella pagina Opzioni ripristino di sistema fare clic su Ripristino immagine del sistema. Verrà visualizzata la pagina Effettua re-imaging computer.

  6. Eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Usa l'immagine del sistema più recente (scelta consigliata).

    • Fare clic su Ripristina un backup diverso e quindi eseguire una delle operazioni seguenti:

      • Nella pagina Selezionare il percorso dell'immagine del sistema fare clic sul computer contenente il backup che si desidera utilizzare e quindi su Avanti.

        Importante

        Se il percorso di archiviazione contiene backup di più computer, fare clic sulla riga relativa ai backup del computer che si desidera utilizzare.

        Nella pagina Selezionare l'immagine del sistema da ripristinare fare clic sul backup che si desidera utilizzare e quindi su Avanti.

      • Fare clic su Avanzate per selezionare un backup in una cartella condivisa remota sulla rete e specificare il percorso UNC (Universal Naming Convention) del backup oppure, se il backup si trova in un dispositivo, per installare un driver di dispositivo. Per installare un'unità, il driver deve essere presente nel sistema locale. L'installazione di un driver non può essere eseguita dalla rete e richiede l'impostazione di un percorso locale per il file con estensione inf. Fare clic su Avanti.

        Importante
        • Se si utilizza un dominio nel proprio ambiente e il percorso di archiviazione dei backup si trova in un computer membro di tale dominio, il computer contenente il percorso di archiviazione deve trovarsi entro il limite IPsec affinché sia accessibile dai computer non appartenenti al dominio. Quando un computer viene avviato in Ambiente ripristino Windows, diventa un computer non di dominio e non è in grado di accedere alle normali condivisioni di rete. Per un percorso di archiviazione dei backup di questo tipo è quindi possibile utilizzare solo computer che consentono a computer non di dominio di accedere alla condivisione.
        • Per risolvere questo problema, è inoltre possibile aggiungere a un gruppo di lavoro il computer contenente il percorso di archiviazione dei backup e salvare il backup in una cartella condivisa. Un computer che esegue Ambiente ripristino Windows si comporta come se appartenesse a un gruppo di lavoro e consente di accedere alla cartella condivisa contenente il backup.

  7. Nella pagina Selezionare ulteriori opzioni di ripristino eseguire le attività facoltative seguenti e quindi fare clic su Avanti:

    • Selezionare la casella di controllo Formatta e partiziona i dischi per eliminare le partizioni esistenti e riformattare i dischi di destinazione in base al backup. In questo modo verrà abilitato il pulsante Escludi dischi. Fare clic su questo pulsante e quindi selezionare le caselle di controllo associate ai dischi da escludere dalla formattazione e partizione. Il disco contenente il backup in uso viene escluso automaticamente.

      Nota
      • Se un disco non viene escluso, i dati che contiene potrebbero andare persi, indipendentemente dal fatto che faccia parte del backup o includa volumi che verranno ripristinati.

      • Non escludere il disco di avvio, ovvero il primo disco in base all'ordine di avvio nel BIOS. Questo disco in genere è denominato disco 0, ma in alcune condizioni le utilità Diskmgmt.msc e Diskpart.exe potrebbero utilizzare un'etichetta diversa quale disco 1/2. Se il disco di avvio (disco 0) è escluso, Windows tenterà di eseguire il ripristino nel disco BIOS 1. Dopo il ripristino, il sistema non verrà tuttavia avviato e potrebbe essere visualizzato un errore per segnalare che Bootmgr non è presente. Il BIOS utilizzerà sempre il primo disco dell'ordine di avvio per cercare questo file e, se non è presente, il computer non verrà avviato.

      • Se in Escludi dischi non sono visualizzati tutti i dischi collegati al computer, può essere necessario installare i driver relativi ai dispositivi di archiviazione non visualizzati.

    • Selezionare la casella di controllo Ripristina solo le unità di sistema per eseguire un ripristino solo del sistema operativo.

    • Fare clic su Installa driver per installare i driver dei dispositivi per l'hardware in cui si esegue il ripristino.

    • Fare clic su Avanzate per specificare se si desidera riavviare il computer automaticamente ed eseguire una ricerca degli errori nei dischi immediatamente dopo il ripristino.

  8. Verificare i dettagli del ripristino e quindi fare clic su Fine. Il ripristino avrà esito positivo solo se verranno ripristinati tutti i volumi critici, ovvero contenenti i componenti del sistema operativo. Se non è possibile eseguire il ripristino di un qualsiasi volume di dati, al termine dell'operazione di ripristino verrà visualizzato un messaggio contenente i volumi non ripristinati, ad esempio i volumi presenti in dischi rigidi virtuali e dischi SCSI Internet (iSCSI).

Ulteriori considerazioni

  • Per creare un backup con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata. Il ripristino del sistema operativo viene eseguito da Ambiente ripristino Windows con l'account utente LocalSystem.

  • I driver di avvio verranno abilitati o installati nel sistema operativo ripristinato in modo da consentire l'avvio del sistema. Dopo il ripristino del sistema, potrebbero tuttavia verificarsi problemi in singole applicazioni basate su determinati componenti hardware, ad esempio schede di rete.

  • Ambiente ripristino Windows è disponibile in tutte le edizioni di Windows Server 2008. L'architettura del processore per una determinata istanza di Ambiente ripristino Windows e il computer di cui si desidera ripristinare il sistema devono tuttavia corrispondere. Ambiente ripristino Windows per una versione del sistema operativo basata su x64, ad esempio, può essere utilizzato solo in un computer basato su x64. Per Windows Server 2008, inoltre, è possibile che il produttore dell'hardware abbia installato Ambiente ripristino Windows in una partizione del server. In caso contrario, sarà necessario il disco di installazione per accedere a questo strumento.

    Per Windows Server 2008 R2, Ambiente ripristino Windows viene installato per impostazione predefinita, eccetto che per l'opzione di installazione Server Core.

  • Per eseguire questa procedura, è inoltre possibile utilizzare il comando Wbadmin start sysrecovery. Per informazioni sulla sintassi e istruzioni, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=143759).

  • Se si utilizza Crittografia unità BitLocker per proteggere il server ed è necessario eseguire un ripristino di sistema, assicurarsi di riapplicare Crittografia unità BitLocker. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Ulteriori riferimenti

  • Ripristinare il server

  • Ripristino guidato


Ripristinare lo stato del sistema

In Windows Server 2008 R2 è possibile utilizzare il Ripristino guidato disponibile in Windows Server Backup per ripristinare lo stato del sistema. Sia in Windows Server 2008 che in Windows Server 2008 R2 è inoltre possibile ripristinare lo stato del sistema utilizzando il comando Wbadmin. Per ulteriori informazioni sulla scelta degli elementi da includere in un backup, vedere Eseguire il backup del server.

Prima di iniziare, verificare che esista almeno un backup dello stato del sistema in un disco locale o una cartella condivisa remota e che il disco sia collegato e online oppure che la cartella condivisa remota sia disponibile. Per istruzioni sulla creazione di un backup per il ripristino dello stato del sistema, vedere Configurare backup automatici, Eseguire un backup manuale e Creare backup dello stato del sistema tramite riga di comando.

Per ripristinare lo stato del sistema mediante l'interfaccia utente di Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Ripristino in Windows Server Backup. Verrà avviato il Ripristino guidato.

  3. Nella pagina Attività iniziali eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Questo server.

    • Fare clic su Altro server. Nella pagina Impostazione tipo di percorso eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

      • Fare clic su Unità locali. Nella pagina Selezione percorso di backup selezionare nell'elenco a discesa il volume o l'unità contenente il backup. In Selezione server selezionare il server di cui si desidera ripristinare i dati.

      • Fare clic su Cartella condivisa remota. Nella pagina Impostazione cartella remota digitare il percorso della cartella contenente il backup. In tale cartella il backup dovrebbe essere archiviato in \\<RemoteSharedFolder>\WindowsImageBackup\<ComputerName>\<YourBackup>.

  4. Nella pagina Selezione data backup selezionare la data nel calendario e l'ora nell'elenco a discesa relative al backup da cui si desidera eseguire il ripristino e quindi fare clic su Avanti.

  5. Nella pagina Selezione tipo di ripristino fare clic su Stato sistema e quindi su Avanti.

  6. Nella pagina Selezione percorso per il ripristino dello stato del sistema eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Percorso originale.

    • Fare clic su Percorso alternativo. Digitare quindi il percorso oppure fare clic su Sfoglia per selezionarlo.

  7. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Ripristina per ripristinare gli elementi elencati.

  8. Nella pagina Stato ripristino è possibile visualizzare lo stato dell'operazione di ripristino e verificare la corretta esecuzione dell'operazione. Al termine dell'operazione, è necessario riavviare il computer.

    Attenzione

    Il ripristino dello stato del sistema non può essere interrotto dopo che è stato avviato e il sistema potrebbe non essere più avviabile.

È possibile utilizzare il comando Wbadmin start systemstaterecovery per ripristinare lo stato del sistema di un computer.

Per ripristinare lo stato del sistema tramite riga di comando

  1. Per aprire un prompt dei comandi con privilegi elevati, fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    wbadmin start systemstate recovery -version:<IdentificatoreVersione> -showsummary [-backupTarget:{<VolumeDestinazioneBackup> | <PercorsoCondivisioneRete>}] [-machine:<NomeComputerBackup>] [-recoveryTarget:<PercorsoDestinazioneRipristino>] [-authsysvol] [-autoReboot] [-quiet]

    Per ripristinare ad esempio lo stato del sistema dal backup del 30/04/2005 alle ore 9.00, archiviato nella cartella condivisa remota \\nomeserver\condivisione per il server01, digitare:

    wbadmin start systemstaterecovery -version:04/30/2005-09:00 -backupTarget:\\nomeserver\condivisione -machine:server01

Ulteriori considerazioni

  • Per ripristinare lo stato del sistema con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Ripristinare il server


Ripristinare un catalogo di backup

È possibile utilizzare Ripristino guidato catalogo per ripristinare un catalogo di backup locale danneggiato.

Windows Server Backup archivia i dettagli relativi ai backup (i volumi di cui viene eseguito il backup e il percorso in cui i backup vengono archiviati) in un file definito catalogo di backup. Il catalogo viene archiviato nello stesso percorso in cui vengono archiviati i backup, ovvero: <StorageLocation>\WindowsImageBackup\<ComputerBackedUp>\Catalog\. Windows Server Backup crea inoltre un catalogo master nel computer di cui viene eseguito il backup nel percorso seguente: <systemdrive>\System Volume Information\WindowsImageBackup\Catalog\. Se tale file viene danneggiato, verrà visualizzato un avviso e un evento verrà aggiunto al registro eventi (Evento 514). Per continuare a eseguire backup, sarà necessario ripristinare il catalogo mediante un backup disponibile o eliminare il catalogo.

Se non sono disponibili backup per il ripristino del catalogo ed è necessario eliminare il catalogo, le informazioni relative ai backup precedenti andranno perse e non sarà possibile accedere ai backup mediante lo snap-in Windows Server Backup. In questo caso, è necessario creare un nuovo backup dopo aver eliminato il catalogo.

Importante

Ripristino guidato catalogo viene visualizzato in Windows Server Backup solo se il catalogo è danneggiato.

Nota

Per eseguire queste attività, è inoltre possibile utilizzare i comandi Wbadmin restore catalog e Wbadmin delete catalog. Per informazioni sulla sintassi ed esempi per Wbadmin, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140216.

Per ripristinare un catalogo di backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni nella pagina predefinita dello snap-in, fare clic su Ripristina catalogo in Windows Server Backup. Verrà avviato Ripristino guidato catalogo.

  3. Nella pagina Impostazione tipo archivio eseguire una delle operazioni seguenti e quindi fare clic su Avanti:

    • Fare clic su Unità locali.

      1. Nella pagina Selezione percorso di backup selezionare nell'elenco a discesa l'unità contenente il backup che si desidera utilizzare. Se si utilizzano DVD o altri supporti, verificare che nell'unità sia presente l'ultimo DVD della serie. Fare clic su Avanti.

      2. Nella pagina Selezione server, se si utilizza un backup archiviato in un disco rigido interno o esterno, selezionare il server di cui si desidera utilizzare il backup.

    • Fare clic su Cartella condivisa remota.

      Nella pagina Impostazione cartella remota digitare il percorso della cartella contenente il backup che si desidera utilizzare.

    • Fare clic su Nessun backup utilizzabile se non è disponibile un backup da utilizzare per ripristinare il catalogo e si desidera semplicemente eliminare il catalogo.

  4. Nella pagina Conferma controllare i dettagli visualizzati e quindi fare clic su Fine per ripristinare il catalogo.

  5. Nella pagina Riepilogo fare clic su Chiudi.

  6. Dopo aver completato il ripristino del catalogo o averlo eliminato, è necessario chiudere e quindi riaprire Windows Server Backup per aggiornare la visualizzazione.

Ulteriori considerazioni

  • Per ripristinare un catalogo di backup con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • È inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di Microsoft Management Console (MMC). A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Ulteriori riferimenti

  • Ripristinare il server

  • Ripristino guidato catalogo


Ottimizzare le prestazioni dei backup e del server

È possibile utilizzare la finestra di dialogo Ottimizza prestazioni backup per migliorare le prestazioni dei backup per volumi completi, in modo da ottimizzare le prestazioni del server. Questa finestra di dialogo è accessibile dalla pagina predefinita dello snap-in Windows Server Backup. Le impostazioni relative alle prestazioni vengono tuttavia applicate solo quando nel backup si includono volumi completi. Se si esegue un backup di file o cartelle, queste impostazioni non verranno applicate e i backup verranno creati tramite il modulo di backup dei file.

Per modificare le impostazioni delle prestazioni per Windows Server Backup

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Windows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in fare clic su Configura impostazioni prestazioni in Windows Server Backup. Verrà visualizzata la finestra di dialogo Ottimizza prestazioni backup.

  3. Nella finestra di dialogo Ottimizza prestazioni backup eseguire una delle operazioni seguenti:

    • Fare clic su Prestazioni di backup normali. Selezionare questa opzione se si desidera creare backup completi. Durante un'operazione di backup, verrà trasferito tutto il contenuto del volume di cui si esegue il backup, ma nel percorso di archiviazione dei backup verrà utilizzato solo lo spazio necessario per i blocchi modificati dell'origine.

    • Fare clic su Prestazioni di backup superiori. Selezionare questa opzione se si desidera creare backup incrementali. Nel volume di origine verrà lasciata una copia shadow per tenere traccia delle modifiche. Durante la successiva operazione di backup, a differenza dell'opzione Prestazioni di backup normali in base a cui vengono trasferiti i dati dell'intero volume di origine, verranno trasferite solo le modifiche rispetto all'ultimo backup attraverso una lettura dell'area diff della copia shadow. Poiché vengono scritti solo i blocchi modificati, si ottiene un aumento delle prestazioni. Nel percorso di archiviazione dei backup verrà comunque utilizzato solo lo spazio necessario per i blocchi modificati rilevati nell'origine. Utilizzare questa opzione per i server con un numero ridotto di operazioni di I/O perché le copie shadow possono rallentare le prestazioni delle operazioni di scrittura per il volume in cui sono archiviate. Le operazioni di lettura non sono invece influenzate.

      Nota

      Anche se si seleziona l'opzione per la creazione di backup incrementali, ogni 14 giorni o dopo 14 operazioni di backup incrementale verrà creato un backup completo al fine di limitare i rischi di danneggiamento del disco.

    • Fare clic su Personalizzato, quindi per ogni elemento in Volume selezionare Backup completo o Backup incrementale nell'elenco a discesa adiacente.

Ulteriori considerazioni

  • Per utilizzare Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

Ulteriori riferimenti

  • Windows Server Backup

  • Installare strumenti di Windows Server Backup


Utilizzare i cmdlet per Windows Server Backup

È possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup per automatizzare e gestire i backup. Prima di iniziare, è necessario installare i cmdlet durante l'installazione di Windows Server Backup. Per istruzioni, vedere Installare strumenti di Windows Server Backup. Ogni volta che si utilizzano i cmdlet, è quindi necessario aggiungere lo snap-in dei cmdlet per Windows Server Backup all'istanza di Windows PowerShell aperta.

Per aggiungere lo snap-in dei cmdlet per Windows Server Backup a Windows PowerShell

  1. Per aggiungere lo snap-in, al prompt di Windows PowerShell digitare:

    add-pssnapin windows.serverbackup

  2. Per confermare l'aggiunta dello snap-in, al prompt di Windows PowerShell digitare:

    get-pssnapin

    Cercare quindi windows.serverbackup nell'output.
Per visualizzare un elenco dei cmdlet per Windows Server Backup

  • Al prompt di Windows PowerShell digitare:

    get-command *wb* -commandtype cmdlet
Per visualizzare la Guida relativa ai cmdlet per Windows Server Backup

  • Al prompt di Windows PowerShell eseguire le operazioni seguenti:

    • Per visualizzare informazioni di base, digitare: Get-Help <cmdlet_name>

    • Per visualizzare informazioni dettagliate, digitare: Get-Help <cmdlet_name> -detailed

    • Per visualizzare alcuni esempi relativi a un cmdlet, digitare: Get-Help <cmdlet_name> -examples

    • Per visualizzare tutte le informazioni della Guida relative a un cmdlet, digitare: Get-Help <cmdlet_name> -full

Ulteriori considerazioni

  • Per utilizzare i cmdlet Windows PowerShell per Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Per impostazione predefinita, i moduli e gli snap-in Windows PowerShell non vengono caricati in Windows PowerShell. Per avviare Windows PowerShell in modo che tutti i moduli e gli snap-in Windows PowerShell vengano caricati automaticamente, fare clic con il pulsante destro del mouse sull'icona di Windows PowerShell sulla barra delle applicazioni e quindi scegliere Importa tutti i moduli. In Windows Server 2008 R2 l'icona di Windows PowerShell viene aggiunta alla barra delle applicazioni per impostazione predefinita. È tuttavia necessaria avviare Windows PowerShell una volta affinché venga visualizzata l'attività Importa tutti i moduli.

Ulteriori riferimenti

  • Windows Server Backup

  • Per informazioni e istruzioni sui cmdlet Windows PowerShell per Windows Server Backup, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=143721.

  • Per accedere all'area dedicata agli script Windows PowerShell, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=93317.

  • Per accedere al blog su Windows PowerShell, visitare il sito Web all’indirizzo http://go.microsoft.com/fwlink/?LinkID=128557.


Risolvere i problemi di backup e ripristino

In questo argomento vengono elencati alcuni problemi comuni che possono verificarsi quando si utilizza Windows Server Backup in Windows Server 2008 R2. Per informazioni aggiornate sulla risoluzione dei problemi, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143745. Per informazioni più dettagliate sulla risoluzione dei problemi relativi agli eventi, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=140218.

Problema riscontrato

  • Non è possibile ripristinare dati da un file con estensione bkf creato mediante una versione precedente di Windows.

  • Durante il tentativo di creare un backup in un'unità nastro, non è stato possibile individuare l'unità tra i percorsi disponibili in cui archiviare i backup.

  • In Esplora risorse non viene visualizzato il disco utilizzato per archiviare i backup pianificati.

  • Elencando i comandi Wbadmin in un prompt dei comandi, non vengono visualizzati alcuni comandi descritti nella documentazione.

  • Durante l'esecuzione di un backup dello stato del sistema, il tempo impiegato è maggiore e le dimensioni del backup sono nettamente superiori rispetto alla versione precedente del sistema operativo.

  • Durante la creazione di un secondo backup su disco, il primo backup sembra essere scomparso.

  • I backup creati sembrano essere scomparsi.

  • Non è possibile gestire altri computer utilizzando l'opzione Connetti a un altro computer.
Non è possibile ripristinare dati da un file con estensione bkf creato mediante una versione precedente di Windows.
  • Causa: non è possibile utilizzare Windows Server Backup per ripristinare backup creati con la funzionalità di backup (Ntbackup.exe) in versioni di Windows precedenti a Windows Server 2008.

  • Soluzione: gli utenti di Windows Server 2008 che desiderano ripristinare dati da backup creati con Ntbackup.exe possono scaricare una versione di Ntbackup.exe destinata esclusivamente al ripristino di backup creati con versioni precedenti di Windows. Questa versione non può essere utilizzata per creare nuovi backup. Per scaricare questa versione di Ntbackup.exe, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=82917.

Durante il tentativo di creare un backup in un'unità nastro, non è stato possibile individuare l'unità tra i percorsi disponibili in cui archiviare i backup.
  • Causa: il backup in dispositivi di archiviazione su nastro non è supportato in Windows Server Backup. In Windows Server 2008 e Windows Server 2008 R2 sono tuttavia supportati i driver di archiviazione su nastro.

  • Soluzione: utilizzare un tipo di supporto o una soluzione di archiviazione supportati. In Windows Server Backup è supportato il backup su dischi esterni e interni, volumi, DVD, altri supporti ottici e rimovibili e cartelle condivise remote.

In Esplora risorse non viene visualizzato il disco utilizzato per archiviare i backup pianificati.
  • Causa: questa situazione corrisponde all'impostazione predefinita. Quando si specifica un disco da utilizzare per l'archiviazione dei backup pianificati, il disco viene allocato per tale scopo, pertanto non è associato a una lettera di unità e non è visibile in Esplora risorse. Questo comportamento viene adottato per i motivi seguenti:

    • Per proteggere il disco dall'inserimento di dati superflui. L'archiviazione di altri dati nel disco di backup può causare la perdita di spazio e di copie di backup.

    • Per proteggere i backup. Se il disco è nascosto, è improbabile che i dati vengano accidentalmente eliminati o danneggiati.

  • Soluzione: l'unità è visibile in Gestione disco (Diskmgr.msc). Per rilasciare l'unità, annullare i backup pianificati. Per istruzioni, vedere Modificare o interrompere una pianificazione di backup automatici.

Elencando i comandi Wbadmin in un prompt dei comandi, non vengono visualizzati alcuni comandi descritti nella documentazione.
  • Causa: questa situazione corrisponde all'impostazione predefinita. Alcuni comandi sono disponibili solo in Ambiente ripristino Windows oppure sono nascosti ma possono essere utilizzati.

  • Soluzione: per visualizzare un elenco completo dei comandi Wbadmin, con relativa sintassi ed esempi, vedere la pagina di riferimento per i comandi di Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=140216).

Durante l'esecuzione di un backup dello stato del sistema, il tempo impiegato è maggiore e le dimensioni del backup sono nettamente superiori rispetto alla versione precedente del sistema operativo.
  • Causa: questa situazione corrisponde all'impostazione predefinita. È aumentato il numero e la dimensione dei file dello stato del sistema. In Windows Server 2008 R2 sono presenti circa 78.752 file dello stato del sistema, che utilizzano circa 5,84 GB per l'installazione predefinita in un computer basato su x64.

Durante la creazione di un secondo backup su disco, il primo backup sembra essere scomparso.
  • Causa: i backup vengono archiviati mediante il servizio Copia Shadow del volume nel disco di archiviazione, pertanto sono disponibili nella copia Shadow creata del disco di archiviazione del backup.

  • Soluzione: i backup non sono andati persi. Per visualizzare tutte le versioni del backup disponibili, utilizzare il comando Wbadmin get versions oppure il Ripristino guidato. Se tuttavia si utilizza Esplora risorse, verrà visualizzato solo il contenuto del backup più recente sul disco.

I backup creati sembrano essere scomparsi.
  • Causa: Windows Server Backup elimina i dischi rigidi virtuali esistenti e ne crea di nuovi generando un intenso traffico di I/O e causando una possibile perdita dei backup nelle due situazioni seguenti:

    • Quando si crea un backup pianificato e si inizia a creare backup di volumi parziali, ad esempio file, e successivamente si modifica il backup pianificato in modo da eseguire un backup del volume completo (a livello di blocco). Un esempio potrebbe essere se si inizia con C:\cartella e poi si passa a C:\ oppure se si inizia con un backup dello stato del sistema e poi si passa a un backup per il ripristino bare metal.

    • Quando si diminuisce o si aumenta la dimensione di un volume di origine per il backup, Windows Server Backup elimina i dischi rigidi virtuali per i volumi il cui layout è stato modificato dopo l'ultimo backup.

  • Soluzione: i backup eliminati non possono essere ripristinati. Windows Server Backup inizierà a creare automaticamente nuovi backup quando verrà avviato.

Non è possibile gestire altri computer utilizzando l'opzione Connetti a un altro computer.
  • Causa: se non si riesce a utilizzare l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di MMC, è possibile che non si disponga delle autorizzazioni di sicurezza appropriate nel computer locale o nel computer remoto oppure che si stia tentando di gestire un computer che esegue una versione di Windows diversa rispetto al computer locale.

  • Soluzione: è inoltre possibile eseguire questa attività in remoto per un altro server utilizzando l'opzione Connetti a un altro computer disponibile nello snap-in Windows Server Backup di MMC. A tale scopo, è necessario essere un membro del gruppo Administrators o Backup Operators nel server remoto. Se l'utente è un membro del gruppo Backup Operators, verificare che le impostazioni di sicurezza DCOM (Distributed Component Object Model) nel computer remoto siano configurate in modo da consentire a tale gruppo di connettersi.

    Questa funzionalità può essere utilizzata solo se i server locale e remoto eseguono la stessa versione di Windows, ovvero entrambi Windows Server 2008 oppure entrambi Windows Server 2008 R2. Questa funzionalità non può inoltre essere utilizzata per gestire un computer che esegue una qualsiasi versione del sistema operativo client Windows.

Risorse aggiuntive

  • Windows Server Backup

  • Risorse per il backup e il ripristino


Risorse per il backup e il ripristino

Per ulteriori informazioni sul backup o il ripristino dei server, utilizzare le risorse seguenti, disponibili nel sito Web Microsoft:

  • Per informazioni tecniche, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93236.

  • Per informazioni sul comando Wbadmin, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216).

  • Per informazioni sul backup o il ripristino di computer che eseguono Servizi di dominio Active Directory, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143743.

  • Per informazioni sui comandi Windows PowerShell (cmdlet) per Windows Server Backup, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143721.

  • Per informazioni dettagliate sulla risoluzione dei problemi relativi agli eventi, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=140218.


Interfaccia utente: Windows Server Backup

Nello snap-in Windows Server Backup di Microsoft Management Console (MMC) sono disponibili le procedure guidate seguenti che consentono di pianificare e creare backup ed eseguire ripristini:

  • Pianificazione guidata backup

  • Creazione guidata backup unico

  • Ripristino guidato

  • Ripristino guidato catalogo

Nota

Alcune pagine e alcuni campi di queste procedure guidate sono stati aggiornati per Windows Server 2008 R2.

Ulteriori considerazioni

  • Per eseguire backup e ripristini con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Per eseguire le stesse attività di backup e ripristino supportate dalle procedure guidate dello snap-in Windows Server Backup, è possibile utilizzare il comando Wbadmin. Per informazioni su questo comando, vedere la pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216).

  • Per eseguire le attività di backup, è possibile utilizzare i cmdlet Windows PowerShell per Windows Server Backup. Per ulteriori informazioni, vedere Utilizzare i cmdlet per Windows Server Backup.

Ulteriori riferimenti

  • Windows Server Backup

  • Installare strumenti di Windows Server Backup


Pianificazione guidata backup

In questo argomento vengono fornite istruzioni per tutte le pagine della Pianificazione guidata backup disponibile nello snap-in Windows Server Backup di MMC.

Pagina Dettagli

Attività iniziali

Per informazioni sui prerequisiti e il processo globale, vedere Elenco di controllo: pianificare backup automatici.

Per istruzioni sull'utilizzo di questa procedura guidata, vedere:

  • Configurare backup automatici

  • Configurare una pianificazione di backup per più dischi di archiviazione

Modifica impostazioni backup pianificato

Se è già stata creata una pianificazione di backup, è possibile utilizzare questa pagina per modificare le impostazioni correnti o annullare i backup pianificati da questa pagina.

Selezione configurazione di backup

È possibile scegliere di eseguire il backup di tutti i volumi contenenti file, dati, applicazioni e lo stato del sistema operativo oppure solo di alcuni volumi o file specifici.

Selezione elementi per backup

Selezionare le caselle di controllo relative agli elementi che si desidera includere nel backup e abilitare il backup per il ripristino dello stato del sistema o il ripristino bare metal. È inoltre possibile fare clic su Impostazioni avanzate per accedere agli strumenti che consentono di escludere alcuni file o tipi di file e per specificare se si desidera eseguire un backup completo o di copia del servizio Copia Shadow del volume.

Impostazione ora backup

Specificare se si desidera eseguire i backup una sola volta o più volte al giorno.

Nota

Se si desidera creare una pianificazione per backup da eseguire in orari e giorni diversi, è possibile utilizzare l'Utilità di pianificazione e il comando Wbadmin start backup per eseguire una serie di attività per la creazione dei backup. Per istruzioni, vedere Configurare backup automatici con l'Utilità di pianificazione.

Impostazione tipo destinazione

Specificare se si desidera archiviare i backup in un disco rigido locale, un volume o una cartella condivisa remota. Per ulteriori informazioni sulla scelta del tipo di archiviazione, vedere Eseguire il backup del server.

Impostazione disco di destinazione

Questa pagina consente di selezionare uno o più dischi collegati da utilizzare per l'archiviazione dei backup. Se il disco che si desidera utilizzare non è visualizzato nell'elenco, fare clic su Mostra tutti i dischi disponibili e quindi selezionare le caselle di controllo dei dischi da utilizzare. Tali dischi verranno quindi visualizzati nell'elenco dei dischi disponibili. Per istruzioni sull'utilizzo di più dischi, vedere Configurare una pianificazione di backup per più dischi di archiviazione.

Importante

Se si utilizza Crittografia unità BitLocker per proteggere il server, quando possibile assicurarsi che anche la posizione di archiviazione scelta sia protetta con Crittografia unità BitLocker. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Selezione volume di destinazione

Se si desidera archiviare i backup in un volume, fare clic su Aggiungi per visualizzare e selezionare i volumi disponibili. Se si sceglie di archiviare i backup in un volume anziché utilizzare un intero disco dedicato, è possibile che si verifichi un calo delle prestazioni fino al 200%. Questo inconveniente è dovuto all'utilizzo delle copie shadow per la creazione dei backup e può causare un problema di prestazioni se gli utenti archiviano nel volume anche altri dati a cui hanno necessità di accedere.

Impostazione cartella condivisa remota

Se si archivia il backup in una cartella condivisa remota, digitare il percorso della cartella.

Nota

Durante la creazione del backup, alla cartella condivisa verranno aggiunte le cartelle \WindowsImageBackup\<ComputerName>. Il backup verrà salvato in <ComputerName>. Non è tuttavia necessario aggiungere tali cartelle al nome della cartella condivisa.

In questa pagina è inoltre possibile specificare se si desidera che il backup sia disponibile solo tramite le credenziali utilizzate per creare il backup oppure se consentire l'accesso al backup a chiunque possa accedere alla cartella remota.

Mantieni o cambia destinazioni di backup

Questa pagina consente di specificare se si desidera mantenere, aggiungere o rimuovere destinazioni di backup. Le opzioni disponibili dipendono dal tipo di archiviazione utilizzato per archiviare i backup.

Conferma

Verificare le scelte effettuate nella procedura guidata. Quando si seleziona Fine, il disco o i dischi selezionati verranno formattati e/o le modifiche apportate alla pianificazione corrente verranno implementate.

Riepilogo

Visualizzare lo stato e verificare se la pianificazione è stata creata o modificata in modo corretto.

Ulteriori considerazioni

  • Per configurare o modificare una pianificazione di backup con Windows Server Backup, è necessario essere membri del gruppo Administrators oppure avere ricevuto in delega l'autorità appropriata.

Risorse aggiuntive

  • Interfaccia utente: Windows Server Backup

  • Installare strumenti di Windows Server Backup


Creazione guidata backup unico

In questo argomento vengono fornite istruzioni per tutte le pagine della Creazione guidata backup unico disponibile nello snap-in Windows Server Backup di MMC.

Pagina Dettagli

Opzioni di backup

Per informazioni sui prerequisiti e il processo globale, vedere Elenco di controllo: eseguire un backup manuale.

Per istruzioni sull'utilizzo di questa procedura guidata, vedere:

  • Eseguire un backup manuale

  • Eseguire un backup manuale in un disco collegato, un DVD o un supporto rimovibile

  • Eseguire un backup manuale in una cartella condivisa remota

In questa pagina è inoltre possibile specificare se per il backup verranno utilizzate le stesse impostazioni o impostazioni diverse.

Selezione configurazione di backup

È possibile scegliere di eseguire il backup di tutti i volumi contenenti file, dati, applicazioni e lo stato del sistema operativo oppure solo di alcuni volumi o file specifici.

Selezione elementi per backup

Selezionare le caselle di controllo relative agli elementi che si desidera includere nel backup e abilitare il backup per il ripristino dello stato del sistema o il ripristino bare metal. È inoltre possibile fare clic su Impostazioni avanzate per accedere agli strumenti che consentono di escludere alcuni file o tipi di file e per specificare se si desidera eseguire un backup completo o di copia del servizio Copia Shadow del volume.

Impostazione tipo destinazione

Specificare se si desidera archiviare il backup in un'unità collegata o in una cartella condivisa remota.

Selezione destinazione backup

Se si desidera archiviare il backup in un disco o un DVD, selezionare l'unità disco o l'unità DVD da utilizzare.

Impostazione cartella remota

Se si archivia il backup in una cartella condivisa remota, immettere il percorso della cartella.

Nota

Durante la creazione del backup, alla cartella condivisa verranno aggiunte le cartelle \WindowsImageBackup\<ComputerName>. Il backup verrà salvato in <ComputerName>. Non è tuttavia necessario aggiungere tali cartelle al nome della cartella condivisa.

In questa pagina è inoltre possibile specificare se si desidera che il backup sia disponibile solo tramite le credenziali utilizzate per creare il backup oppure se consentire l'accesso al backup a chiunque possa accedere alla cartella remota.

Conferma

Verificare le scelte effettuate nella procedura guidata. Quando si seleziona Fine, il disco o i dischi selezionati verranno formattati e/o le modifiche apportate alla pianificazione corrente verranno implementate.

Stato backup

Visualizzare lo stato e verificare se la pianificazione è stata creata o modificata in modo corretto.

Ulteriori considerazioni

  • Per creare un backup singolo con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server, quando possibile assicurarsi che anche la posizione di archiviazione scelta sia protetta con Crittografia unità BitLocker. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Risorse aggiuntive

  • Interfaccia utente: Windows Server Backup

  • Installare strumenti di Windows Server Backup


Ripristino guidato

In questo argomento vengono fornite istruzioni per tutte le pagine del Ripristino guidato disponibile nello snap-in Windows Server Backup di MMC.

Pagina Dettagli

Attività iniziali

Per istruzioni sull'utilizzo di questa procedura guidata, vedere:

  • Ripristinare il server

  • Ripristinare file e cartelle

  • Ripristinare applicazioni e dati

  • Ripristinare i volumi

Questa pagina consente di specificare se si desidera ripristinare il backup archiviato nel computer locale o in un altro computer.

Impostazione tipo di percorso

Se si esegue il ripristino da un altro computer, specificare se il backup è archiviato in un'unità locale o una cartella condivisa remota.

Selezione percorso di backup

Se si ripristina un backup archiviato in un'unità locale, selezionare l'unità nell'elenco a discesa.

Impostazione cartella remota

Se si ripristina un backup archiviato in una cartella condivisa remota, immettere il percorso della cartella condivisa.

Nota

Durante la creazione del backup, alla cartella condivisa sono state aggiunte le cartelle \WindowsImageBackup\<ComputerName>. Il backup viene archiviato in <ComputerName>. Non è tuttavia necessario aggiungere tali cartelle al nome della cartella condivisa.

Selezione server

Se si utilizza un backup archiviato in un disco rigido, questa pagina consente di selezionare il server di cui si desidera utilizzare il backup per il ripristino.

Selezione data backup

Selezionare la data e l'ora del backup che verrà utilizzato per il ripristino.

Selezione tipo di ripristino

Specificare se si desidera eseguire il ripristino di file e cartelle, applicazioni e dati di applicazioni o volumi.

Selezione elementi da ripristinare

Se si ripristinano file e cartelle, in Elementi disponibili espandere l'elenco fino a rendere visibile la cartella desiderata. Fare clic su una cartella per visualizzarne il contenuto (file e cartelle) nel riquadro adiacente, quindi fare clic sui singoli elementi da ripristinare.

Selezione volumi

Se si ripristinano volumi, selezionare le caselle di controllo associate ai volumi da ripristinare nella colonna Volume di origine. Nell'elenco a discesa associato nella colonna Volume di destinazione selezionare il percorso in cui ripristinare il volume.

Se tutti i volumi sul server contengono componenti di sistema, non sarà possibile ripristinare un volume. Provare quindi a eseguire le operazioni seguenti:

  • Provare a ripristinare singoli file e cartelle. Per istruzioni, vedere Ripristinare file e cartelle.

  • Se si sta tentando di ripristinare lo stato del sistema, utilizzare il comando Wbadmin start systemstaterecovery. Per esempi e informazioni sulla sintassi, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143757.

  • Se si desidera ripristinare l'intero computer, utilizzare Ambiente ripristino Windows e un backup creato in precedenza. Per istruzioni, vedere Ripristinare il sistema operativo o il server completo.

Selezione applicazione

Se si ripristina un'applicazione, in Applicazioni fare clic sull'applicazione da ripristinare. Se il backup utilizzato è il più recente, verrà visualizzata la casella di controllo Non eseguire il ripristino roll forward dei database dell'applicazione. Selezionare questa casella di controllo per impedire a Windows Server Backup di eseguire il roll forward del database dell'applicazione presente sul server.

Selezione percorso per il ripristino dello stato del sistema

Questa pagina consente di specificare il percorso in cui si desidera eseguire il ripristino dello stato del sistema, ovvero il percorso originale in cui è stato creato il backup o un altro percorso.

Impostazione opzioni di ripristino

Specificare se si desidera ripristinare elementi nel percorso originale in cui è stato creato il backup o in un altro percorso, l'operazione da eseguire nel caso in cui alcuni elementi inclusi nel backup siano già presenti nel percorso di ripristino e se si desidera ripristinare le autorizzazioni dell'elenco di controllo di accesso (ACL).

Importante

Sebbene sia possibile copiare un'applicazione in un percorso diverso, non è possibile ripristinare un'applicazione in un percorso diverso o in computer con un nome diverso.

Conferma

Verificare le scelte effettuate nella procedura guidata. Quando si seleziona Fine, gli elementi vengono ripristinati.

Stato ripristino

Visualizzare lo stato e verificare se la pianificazione è stata creata o modificata in modo corretto.

Ulteriori considerazioni

  • Per eseguire i ripristini con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Se si utilizza Crittografia unità BitLocker per proteggere il server ed è necessario eseguire un ripristino, assicurarsi di riapplicare Crittografia unità BitLocker al server. La riattivazione non è automatica, ma deve essere eseguita in modo esplicito. Per istruzioni, vedere la Guida dettagliata a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=143722).

Risorse aggiuntive

  • Interfaccia utente: Windows Server Backup

  • Installare strumenti di Windows Server Backup


Ripristino guidato catalogo

In questo argomento vengono fornite istruzioni per tutte le pagine della Pianificazione guidata backup disponibile nello snap-in Windows Server Backup di MMC.

Pagina Dettagli

Impostazione tipo archivio

Per istruzioni relative all'utilizzo di questa procedura guidata, vedere Ripristinare un catalogo di backup.

Questa pagina consente di specificare il percorso da cui ripristinare il catalogo (un'unità locale o una cartella condivisa remota) o di eliminare il catalogo.

Selezione percorso di backup

Se si utilizza un backup archiviato in un'unità, questa pagina consente di scegliere il backup desiderato per il ripristino del catalogo. Selezionare il volume o l'unità nell'elenco a discesa.

Impostazione cartella remota

Utilizzare questa pagina se si ripristina il catalogo da un backup archiviato in una cartella condivisa remota. Digitare il percorso della cartella condivisa.

Nota

Durante la creazione del backup, alla cartella condivisa sono state aggiunte le cartelle \WindowsImageBackup\<ComputerName>. Il backup viene archiviato in <ComputerName>. Non è tuttavia necessario aggiungere tali cartelle al nome della cartella condivisa.

Selezione server

Se si utilizza un backup archiviato in un disco rigido, questa pagina consente di selezionare il server di cui si desidera utilizzare il backup per il ripristino.

Conferma

Verificare le scelte effettuate nella procedura guidata. Quando si seleziona Fine, il catalogo viene ripristinato o eliminato.

Riepilogo

Visualizzare lo stato e verificare se il catalogo è stato ripristinato o eliminato in modo corretto.

Ulteriori considerazioni

  • Per ripristinare un catalogo di backup con Windows Server Backup, è necessario essere membri del gruppo Backup Operators o Administrators oppure avere ricevuto in delega l'autorità appropriata.

  • Questa procedura guidata viene visualizzata in Windows Server Backup solo se il catalogo di backup è danneggiato.

Risorse aggiuntive

  • Interfaccia utente: Windows Server Backup

  • Installare strumenti di Windows Server Backup