BITS (Servizio trasferimento intelligente in background)

Il servizio BITS (Servizio trasferimento intelligente in background) include due servizi ruolo: Compact Server e l'estensione del server IIS. Compact Server è un file server HTTP o HTTPS autonomo, mentre l'estensione del server IIS è un plug-in di Internet Information Services (IIS) che richiede un server che esegue IIS.

Estensione del server IIS

L'estensione del server IIS BITS consente di configurare un server che esegue IIS in modo che i client BITS possano eseguire caricamenti di file in background e in modo ripristinabile in directory virtuali IIS. Al termine di un caricamento di file, il server BITS può notificare il nuovo file caricato a un'applicazione Web. In questo modo, l'applicazione può elaborare il file caricato. L'applicazione Web può facoltativamente rispondere al client responsabile del caricamento. Per informazioni, vedere la sezione Estensione del server IIS BITS.

Compact Server

BITS Compact Server è un file server HTTP o HTTPS autonomo tramite cui le applicazioni possono ospitare file per il download da parte di client BITS e che consente il trasferimento asincrono di un numero limitato di file di grandi dimensioni tra computer. Per informazioni, vedere la sezione BITS Compact Server.

Risorse aggiuntive

  • Pagina Web relativa al servizio BITS (Servizio trasferimento intelligente in background) http://go.microsoft.com/fwlink/?LinkId=140888

  • Documentazione di riferimento relativa al servizio BITS http://go.microsoft.com/fwlink/?LinkId=140985


Estensione del server IIS BITS

L'estensione del server IIS BITS (Servizio trasferimento intelligente in background) consente di configurare un server IIS (Internet Information Services) in modo che i client BITS possano eseguire caricamenti di file in background e in modo ripristinabile in directory virtuali IIS. Al termine di un caricamento di file, il server BITS può notificare il nuovo file a un'applicazione Web tramite l'estensione del protocollo di caricamento BITS per richieste POST HTTP. Facoltativamente, l'applicazione Web può quindi rispondere all'operazione di inserimento del client. Per informazioni sull'estensione del protocollo di caricamento BITS per richieste POST HTTP, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143105.

Per installare l'estensione del server IIS BITS

  1. Nella sezione Riepilogo funzionalità di Server Manager fare clic su Aggiungi funzionalità.

  2. Nell'Aggiunta guidata funzionalità selezionare Servizio trasferimento intelligente in background (BITS) e Estensione del server IIS.

  3. Seguire le istruzioni della procedura guidata, che includono l'installazione del software necessario (se indicato). Per ulteriori informazioni su come utilizzare l'Aggiunta guidata funzionalità, fare riferimento alla Guida di Server Manager.

Opzioni configurabili

Le opzioni configurabili per l'estensione del server IIS includono la limitazione della dimensione dei file caricati, l'eliminazione automatica dei file incompleti allo scadere del periodo di tempo predefinito e il supporto per server farm. Per ulteriori informazioni, vedere le sezioni seguenti:

  • Autorizzazioni per l'estensione del server IIS BITS

  • Attivare o disattivare l'estensione del server IIS BITS

  • Personalizzare le impostazioni dell'estensione del server IIS BITS

Per rimuovere l'estensione del server IIS BITS

  1. Nella sezione Riepilogo funzionalità di Server Manager fare clic su Rimuovi funzionalità.

  2. Nella Rimozione guidata funzionalità selezionare la casella di controllo Servizio trasferimento intelligente in background (BITS) e quindi fare clic su Avanti.

  3. Fare clic su Rimuovi e, quando richiesto, fare clic su Chiudi per uscire dalla Rimozione guidata funzionalità.

  4. Riavviare il server per completare il processo di rimozione delle funzionalità BITS. Per ulteriori informazioni su come utilizzare la Rimozione guidata funzionalità, fare riferimento alla Guida di Server Manager.


Attivare o disattivare l'estensione del server IIS BITS

L'estensione del server IIS BITS (Servizio trasferimento intelligente in background) consente di configurare un server IIS in modo che i client BITS possano eseguire o riprendere caricamenti di file in background in directory virtuali IIS. Al termine di un caricamento di file, il server BITS può inviare a un'applicazione Web una notifica relativa al nuovo file (tramite una richiesta POST a un URL configurabile), in modo da elaborare i file caricati. Facoltativamente, l'applicazione Web può quindi rispondere all'operazione di inserimento del client.

Dopo avere installato l'estensione del server IIS BITS, è necessario attivarla e personalizzare le impostazioni in base all'ambiente in uso. Per istruzioni di installazione, vedere Estensione del server IIS BITS È possibile disattivare l'estensione del server IIS BITS se necessario deselezionando la casella di controllo Consenti ai client di caricare file.

Per attivare l'estensione del server IIS BITS

  1. Passare alla directory virtuale in Gestione IIS.

  2. Nella visualizzazione delle funzionalità della directory virtuale fare doppio clic su Processi di caricamento BITS.

  3. Selezionare la casella di controllo Consenti ai client di caricare file e quindi fare clic su Applica.

Per impostazione predefinita, l'estensione del server IIS BITS utilizza le impostazioni del sito Web padre della directory virtuale. Se tali impostazioni non sono presenti, vengono utilizzate quelle predefinite del server BITS.

È possibile modificare il funzionamento del server BITS in relazione alla directory virtuale selezionando l'opzione Personalizza impostazioni. Per informazioni su queste impostazioni, vedere Personalizzare le impostazioni dell'estensione del server IIS BITS

Per disattivare l'estensione del server IIS BITS

  1. Passare alla directory virtuale in Gestione IIS.

  2. Nella visualizzazione delle funzionalità della directory virtuale fare doppio clic su Processi di caricamento BITS.

  3. Deselezionare la casella di controllo Consenti ai client di caricare file e quindi fare clic su Applica.

Vedere anche

  • Estensione del server IIS BITS


Personalizzare le impostazioni dell'estensione del server IIS BITS

Utilizzare la pagina Processi di caricamento BITS per personalizzare le impostazioni dell'estensione del server IIS BITS per una directory virtuale specifica. È possibile configurare le limitazioni di dimensione, le notifiche, la frequenza delle operazioni di pulizia e il supporto per server farm.

Impostazioni processi di caricamento

Le impostazioni incluse in questa sezione consentono di configurare la dimensione massima dei file caricati, determinare il momento in cui i processi incompleti vengono eliminati e definire la possibilità di sovrascrivere i file esistenti da parte di un processo di caricamento.

Elemento dell'interfaccia utente Descrizione

Dimensione max file

Definisce la dimensione massima di un file caricabile in un processo del server BITS. Per impostazione predefinita non è preconfigurata alcuna dimensione massima.

Elimina processi incompleti dopo

Definisce il periodo di attesa del server BITS prima di pulire i file caricati incompleti. Il timeout viene verificato ogni volta che è prevista l'esecuzione del processo di pulizia. Utilizzare le opzioni incluse nella sezione Pulizia per configurare la frequenza di esecuzione del processo di pulizia per la directory virtuale.

Consenti sovrascrittura dei file

Questa impostazione definisce se il server di caricamento BITS consente la sovrascrittura di file esistenti nella directory virtuale. Questa impostazione è disattivata per impostazione predefinita, in modo da impedire a utenti non autorizzati di sovrascrivere in modo legittimo i file caricati tramite il caricamento di un file con lo stesso nome. I tentativi di sovrascrivere un file causano errori nel secondo processo di caricamento. Se due processi di caricamento sono associati allo stesso nome di file di destinazione, il secondo processo di caricamento non viene eseguito, anche se il tentativo di sovrascrittura è accidentale. Se si attiva questa impostazione, si consente la sovrascrittura dei file.

Attivando questa impostazione, il server di caricamento BITS non è comunque in grado di eseguire la scrittura dei file all'esterno della directory virtuale e gli utenti non autorizzati non possono sovrascrivere i file del sistema tramite il server di caricamento BITS.

Notifiche

L'attivazione delle notifiche consente di configurare il server BITS per l'invio di una notifica tramite una richiesta POST HTTP a un URL specificato quando un file viene caricato nella directory virtuale.

Elemento dell'interfaccia utente Descrizione

Attiva notifiche

Abilita le notifiche per la directory virtuale. Le impostazioni Tipo di notifica e URL notifica sono necessarie qualora questa impostazione sia abilitata.

Tipo di notifica

Configura il tipo di notifica da eseguire al termine del processo.

  • Invia il nome del file: il server passa il percorso dell'intero file di caricamento all'URL specificato tramite l'impostazione URL notifica. Il server può restituire al client un file come risposta.

  • Invia il contenuto del file: il server passa l'intero file di caricamento all'URL specificato tramite l'impostazione URL notifica come corpo entità della richiesta POST HTTP. L'entità di risposta viene inviata al client.

URL notifica

Specifica l'URL a cui passare l'intero file di caricamento utilizzando una richiesta POST HTTP se l'opzione Tipo di notifica è impostata su Invia il contenuto del file o Invia il nome del file. L'URL può essere assoluto o relativo. Se l'URL è relativo, come base viene utilizzato l'URL originale della richiesta.

Pulizia

Il server BITS verifica ed elimina i processi di caricamento incompleti che sono scaduti. Se un caricamento supera l'impostazione predefinita di 12 ore o il valore specificato nell'impostazione Cerca processi non completati ogni, il server BITS annulla automaticamente il caricamento ed elimina tutti file con contenuto parziale. Questa impostazione non è interessata dall'ereditarietà delle proprietà IIS e viene applicata solo alla directory virtuale.

Elemento dell'interfaccia utente | Descrizione
Usa pianificazione di pulizia predefinita | Configura il server BITS per la ricerca di caricamenti incompleti la cui durata superi 12 ore. Se un caricamento supera il valore specificato per questa impostazione, il server BITS annulla automaticamente il caricamento ed elimina tutti file con contenuto parziale in base al valore specificato nell'impostazione Elimina processi incompleti dopo.
Usa pianificazione di pulizia personalizzata | Configura il server BITS per la ricerca e l'eliminazione in base a un intervallo specificato.
Cerca processi non completati ogni | Configura il server BITS per la ricerca di caricamenti incompleti che abbiano superato l'intervallo specificato. Se un caricamento supera il valore specificato per questa impostazione, il server BITS annulla automaticamente il caricamento ed elimina tutti file con contenuto parziale in base al valore specificato nell'impostazione Elimina processi incompleti dopo.
Abilita pulizia per limitare il numero di sessioni di caricamento per utente | Configura il server BITS per la rimozione di processi caricati da un utente che supera il valore specificato in Limita il numero di sessioni per utente.
Limita il numero di sessioni per utente | Specifica il numero di processi di caricamento attivi che possono essere inviati da un utente al server BITS.
Nota

È possibile eseguire manualmente un'operazione di pulizia facendo clic su Esegui pulizia nel riquadro delle azioni di Gestione IIS. Verrà immediatamente avviato un controllo dei file il cui stato non è cambiato dal periodo di timeout. Per rimuovere tutti i file incompleti per la directory virtuale, impostare Elimina processi incompleti dopo su 0 prima di eseguire la pulizia.

Supporto server farm

Se attivata, questa impostazione indica al client di tentare di riconnettersi allo stesso server anziché all'URL di caricamento originale utilizzato dal client. In questo modo, i client che eseguono un caricamento in server farm possono utilizzare lo stesso server utilizzato all'avvio del caricamento.

Le server farm possono essere configurate nei due modi seguenti:

  1. Mediante un volume condiviso per la directory virtuale di caricamento

  2. Mediante l'archiviazione locale sul server per i file caricati

Se si desidera utilizzare l'archiviazione locale, questa opzione consente al client di riconnettersi allo stesso computer server della server farm. È consigliabile attivare e quindi configurare questa funzionalità prima di eseguire il caricamento in server farm e utilizzare l'archiviazione locale.

Elemento dell'interfaccia utente Descrizione

Abilita supporto server farm

Abilita il supporto dei caricamenti del server BITS per le server farm.

Riconnetti al server

Specifica l'indirizzo IP pubblico da utilizzare per riconnettersi al server. In una configurazione normale per un server sono inclusi due indirizzi IP: uno verso l'esterno raggiungibile dai sistemi client e uno che fa parte della rete interna protetta. Specificare qui l'indirizzo IP verso l'esterno.

Nota

È possibile specificare un nome DNS solo se ogni computer della Web farm ha un nome DNS indipendente risolvibile dai computer client.

Utilizza server originario dopo

Se un client non è in grado di riconnettersi al server indicato in Riconnetti al server per il periodo di tempo specificato, torna a utilizzare il nome DNS originario specificato nell'URL di caricamento.

Vedere anche

  • Autorizzazioni per l'estensione del server IIS BITS


Autorizzazioni per l'estensione del server IIS BITS

IIS consente a un utente di impostare le autorizzazione di esecuzione e per gli script in una directory virtuale separatamente dalle autorizzazioni di scrittura. Gli amministratori che desiderano consentire l'esecuzione di script e programmi in una directory virtuale disattivano in genere la scrittura in tale directory virtuale, in modo da impedire ai client di caricare script o programmi eseguibili in una directory e di eseguirli. Se, tuttavia, una directory virtuale è abilitata per il server BITS, i client possono scrivere in tale directory tramite il server BITS anche se le autorizzazioni di scrittura per la directory virtuale sono state disattivate.

Per proteggere il server, vengono disattivate tutte le autorizzazioni di esecuzione e per gli script per una directory virtuale abilitata per il caricamento BITS. Per proteggere questa directory virtuale, il server BITS verifica che tali autorizzazioni siano disattivate prima di rispondere a qualsiasi richiesta client di caricamento di dati. Se le autorizzazioni sono attivate, il server BITS rifiuta tutte le richieste di caricamento fino a quando le autorizzazioni non vengono nuovamente disattivate. Ogni volta che il server BITS rifiuta una richiesta in un ambiente di questo tipo, viene creata una voce nei registri di IIS.

Vedere anche

  • Attivare o disattivare l'estensione del server IIS BITS
  • Estensione del server IIS BITS


BITS Compact Server

BITS Compact Server è un file server HTTP o HTTPS autonomo che consente il trasferimento asincrono tra computer di un numero limitato di file di grandi dimensioni.

BITS Compact Server è progettato per l'utilizzo da parte di utenti di piccole aziende e organizzazioni nei casi seguenti:

  • L'utilizzo previsto prevede un massimo di 25 connessioni simultanee e un massimo di 100 connessioni totali per server.

  • I trasferimenti di file vengono eseguiti tra computer nello stesso dominio o in domini reciprocamente trusted.

  • La funzionalità di trasferimento file non deve essere utilizzata in client connessi direttamente a Internet.

Se il volume di trasferimento file è maggiore o si desidera disporre di ulteriore controllo amministrativo e di funzionalità di trasferimento file aggiuntive, installare l'Estensione del server IIS BITS.

Per installare BITS Compact Server

  1. Nella sezione Riepilogo funzionalità di Server Manager fare clic su Aggiungi funzionalità.

  2. Nell'Aggiunta guidata funzionalità selezionare Servizio trasferimento intelligente in background (BITS) e Compact Server.

  3. Seguire le istruzioni della procedura guidata, che includono l'installazione del software necessario (se indicato). Per ulteriori informazioni su come utilizzare l'Aggiunta guidata funzionalità, fare riferimento alla Guida di Server Manager.

È eventualmente possibile installare BITS Compact Server utilizzando cmdlet di Windows PowerShell. Per informazioni su come utilizzare i cmdlet, vedere la guida per programmatori di Windows PowerShell all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143122.

Opzioni configurabili

BITS Compact Server utilizza l'API del server HTTP per creare URL, ricevere richieste HTTP e inviare risposte HTTP. L'API è costituita da due interfacce, ICompactServer and ICompactServerUrlGroup. La prima interfaccia consente di creare gruppi di URL, mentre la seconda consente di aggiungere URL ai gruppi di URL e di configurare alcune proprietà. È inoltre possibile utilizzare l'API per attivare l'autenticazione e definire il limite di larghezza di banda e i limiti di connessione nei gruppi di URL. Non è disponibile alcuna interfaccia utente.

Per ulteriori informazioni sulle opzioni configurabili di BITS Compact Server, vedere Personalizzare BITS Compact Server.

Per rimuovere BITS Compact Server

  1. Nella sezione Riepilogo funzionalità di Server Manager fare clic su Rimuovi funzionalità.

  2. Nella Rimozione guidata funzionalità selezionare la casella di controllo Servizio trasferimento intelligente in background (BITS) e quindi fare clic su Avanti.

  3. Fare clic su Rimuovi e, quando richiesto, fare clic su Chiudi per uscire dalla Rimozione guidata funzionalità.

  4. Riavviare il server per completare il processo di rimozione delle funzionalità BITS. Per ulteriori informazioni su come utilizzare la Rimozione guidata funzionalità, fare riferimento alla Guida di Server Manager.

Vedere anche

  • BITS (Servizio trasferimento intelligente in background)


Personalizzare BITS Compact Server

BITS Compact Server include le funzionalità personalizzabili seguenti:

  • Modalità a livello di codice per esporre file per il download

  • Download autenticati e crittografati

  • Funzionalità di gestione remota

Queste funzionalità consentono a Microsoft System Center Virtual Machine Manager di gestire gli host macchina virtuale senza un agente e offrono inoltre agli amministratori di sistema alcune opzioni per l'automazione del centro dati tramite altre applicazioni compatibili.

API di BITS Compact Server

L'API di BITS Compact Server è costituita da due interfacce, ICompactServerSession e ICompactServerUrlGroup. La prima interfaccia viene utilizzata per creare gruppi di URL. La seconda interfaccia consente di aggiungere URL al gruppo di URL e di configurare alcune proprietà. Non è disponibile alcuna interfaccia utente.

Tramite l'API di BITS Compact Server è possibile configurare l'applicazione di controllo per l'esecuzione delle attività seguenti:

  1. Eseguire CoCreate su ICompactServer.

  2. Chiamare ICompactServer::CreateUrlGroup.

  3. Chiamare ICompactServerUrlGroup::SetAuthentication.

  4. Chiamare ICompactServerUrlGroup::AddUrl.

Per informazioni dettagliate sull'API di BITS Compact Server, vedere la pagina Web relativa al servizio BITS (Servizio trasferimento intelligente in background) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140888 e la documentazione di riferimento relativa al servizio BITS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140985.

È inoltre possibile configurare BITS Compact Server utilizzando l'API del provider WMI e i cmdlet Powershell per WMI. Per informazioni, vedere la sezione Gestione remota di BITS Compact Server.

Registrazione

Se si contatta il supporto tecnico Microsoft, è possibile che l'addetto al supporto tecnico richieda l'invio di registri a Microsoft. Ai fini del debug, BITS Compact Server crea un file di registro in %windir%\System32\LogFiles\CompactServer. Per attivare la registrazione, impostare i valori seguenti come destinati al supporto tecnico nella chiave del Registro di sistema HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\CompactServer:

LogFileFlags

LogFileSize

LogFileMinMemory

Gestione remota di BITS Compact Server

Per informazioni sulla gestione remota dei trasferimenti di file nel server e nel client, vedere Gestione remota di BITS Compact Server.

Vedere anche

  • BITS Compact Server


Gestione remota di BITS Compact Server

BITS Compact Server con gestione remota consente di proteggere i trasferimenti di file remoti. Per la gestione remota di BITS Compact Server viene utilizzato il provider di Strumentazione gestione Windows (WMI) BITS per consentire a un amministratore di sistema o a un'applicazione del controller di creare in remoto processi BITS nei client e di pubblicare file per l'hosting in BITS Compact Server. I provider WMI BITS possono trasferire in remoto file da un computer remoto a un altro utilizzando il client BITS insieme a BITS Compact Server. Questa funzionalità è stata progettata in particolare per l'utilizzo con Microsoft System Center Virtual Machine Manager come applicazione del controller. Qualsiasi applicazione in grado di utilizzare il provider WMI BITS, tuttavia, può fungere da applicazione del controller.

Importante

Tutte le attività di gestione remota devono essere eseguite utilizzando un account appartenente al gruppo Administrators. Verrà negato l'accesso a qualsiasi richiesta proveniente da account non appartenenti al gruppo Administrators.

Panoramica dell'architettura

Nel diagramma seguente viene illustrato il modo in cui un'applicazione del controller in un computer remoto può gestire in modo sicuro trasferimenti di file in un client e in BITS Compact Server. In questo esempio l'applicazione del controller distribuisce un processo nel server e in un client tramite WS-Management. WS-Management è l'implementazione Microsoft del protocollo di gestione dei servizi Web. Le chiamate remote vengono ricevute dal servizio WS-Management nei computer server e client. Le chiamate vengono passate al servizio WMI che, a sua volta, richiama il provider WMI BITS per elaborare le richieste.

L'applicazione del controller può utilizzare WS-Management o WMI DCOM per distribuire un processo. In entrambi i casi, è necessario configurare il computer remoto per accettare le richieste in ingresso. Per informazioni su come connettersi a WMI in un computer remoto, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?linkid=122134. Per informazioni sulla configurazione per Gestione remota Windows, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?linkid=122026.

Per trasferire un file, l'applicazione del controller stabilisce connessioni ai provider WMI in esecuzione nel client e nei computer server e crea processi per l'avvio del trasferimento del file. Un processo in un server viene definito come URL ospitato per un file che risiede nel server. Un processo è identificato dagli elementi seguenti:

  • Gruppo di URL: un gruppo di URL ospita un URL per elaborare un file. Si tratta di una combinazione del gruppo di URL HTTP.SYS e della coda di richieste. È possibile, ad esempio, specificare un gruppo di URL come http://+:80/Carmine durante la creazione. Il protocollo da utilizzare e la porta nell'host vengono anch'essi specificati nel gruppo di URL. Si noti che non sono supportati i gruppi di URL a due livelli, ad esempio http://+:80/Carmine1/Carmine2.

  • File di origine: nome del file da ospitare nel server tramite il processo.

  • Suffisso URL: suffisso utilizzato da un client per identificare in modo univoco il processo.

  • L'URL specificato dal client per scaricare un processo è costituito dagli elementi seguenti:

    • Protocollo da utilizzare: HTTP o HTTPS

    • Nome host: nome del server

    • Gruppo di URL: spazio dei nomi utilizzato per ospitare un processo nel server

    • Suffisso URL: suffisso che identifica il processo creato nel server

Per ulteriori informazioni sulle stringhe di prefisso degli URL, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143141.

Nelle sezioni seguenti viene descritto come creare, monitorare ed eliminare processi.

Creazione di processi nel server

  1. L'applicazione del controller stabilisce una connessione allo spazio dei nomi root\Microsoft\Bits nel server BITS. Il provider server WMI autentica il token remoto per verificare i diritti amministrativi. L'applicazione del controller imposta i certificati SSL per la porta HTTPS in cui verranno elaborati i download.

  2. L'applicazione del controller richiede che il provider server WMI crei un gruppo di URL nel server in modo da consentire l'hosting degli URL nel server. Il meccanismo di autenticazione per il gruppo di URL può essere impostato a questo punto.

  3. L'applicazione del controller richiede che il provider server WMI crei un URL che consenta di rendere disponibile un file specifico che risiede nel server ai processi del computer client.

  4. Il provider crea un gruppo di URL utilizzando interfacce COM nel server e registra un suffisso URL univoco nel gruppo di URL. Per ogni URL univoco è possibile impostare l'autorizzazione SDDL e dei certificati.

  5. Tutti i nuovi processi aggiunti al gruppo di URL condivideranno lo stesso gruppo di URL e le relative impostazioni. A questo punto l'host è configurato ed è in ascolto di tutte le richieste dell'URL registrato provenienti dal client.

Creazione di processi nel client

  1. L'applicazione del controller stabilisce una connessione allo spazio dei nomi root\Microsoft\Bits nel computer client.

  2. Il provider client WMI autentica il token remoto per verificare le autorizzazioni amministrative. Si noti che in genere i provider WMI rappresentano anche le richieste client in ingresso prima di fornire dati. In questo caso, tuttavia, la gestione del client viene eseguita nel contesto in cui è stato aperto WMI (Sistema locale). In questo modo, le chiamate remote altrimenti bloccate possono essere elaborate dal servizio BITS.

  3. L'applicazione del controller richiede che il provider client WMI crei un processo che consenta di scaricare nel computer client un file specifico che risiede nel server utilizzando il servizio BITS.

  4. Il provider stabilisce una connessione al servizio BITS tramite le interfacce COM esposte.

  5. Il provider rappresenta l'account del servizio previsto dall'applicazione del controller per l'esecuzione del processo BITS.

  6. Viene creato il processo BITS per l'URL richiesto nel server.

  7. Il certificato di autenticazione può essere aggiunto al processo.

  8. È possibile impostare credenziali di autenticazione per il processo in scenari con domini non trusted.

  9. Il processo BITS viene ripreso immediatamente dopo la creazione e viene avviato il trasferimento del file.

Monitoraggio del processo

  1. L'applicazione del controller esegue il monitoraggio del processo BITS creato tramite la proprietà di stato resa disponibile dal provider client. Se nel processo si verifica un errore temporaneo, l'applicazione del controller può recuperare il codice di errore, annullare il processo BITS e procedere alla pulizia.

  2. Se il file è stato trasferito correttamente, l'applicazione del controller può eseguire la pulizia.

Pulizia del processo

  • La pulizia nel client viene eseguita quando l'applicazione del controller sposta il processo BITS a una fase di pulizia. Se lo stato del processo è BG_JOB_STATE_TRANSFERRED, può essere modificato in stato completato. In caso contrario, il processo può essere annullato.

  • La pulizia nel server viene eseguita dall'applicazione del controller che richiede al provider server di annullare l'URL ospitato. L'URL registrato con il gruppo viene eliminato. Il client può eliminare anche il gruppo di URL, eliminando in tal modo tutti gli URL elaborati dal gruppo di URL.

Risorse aggiuntive

Per informazioni dettagliate sulla sequenza di chiamate WMI BITS e i metodi, vedere la pagina Web relativa al servizio BITS (Servizio trasferimento intelligente in background) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140888 e la documentazione di riferimento relativa al servizio BITS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140985.

Per informazioni di carattere generale sull'utilizzo di WMI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?linkid=136379.

Vedere anche

  • Personalizzare BITS Compact Server