Cluster di failover

  • Panoramica dei cluster di failover

  • Elenco di controllo: creare un cluster di failover

  • Elenco di controllo: Creare un file server del cluster

  • Elenco di controllo: Creare un server di stampa del cluster

  • Elenco di controllo: creare una macchina virtuale del cluster

  • Installare la funzionalità Clustering di failover

  • Convalidare la configurazione di un cluster di failover

  • Creare un cluster di failover o aggiungere un nodo al cluster

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Migrare le impostazioni a un cluster di failover che esegue Windows Server 2008 R2

  • Modificare le impostazioni per un cluster di failover

  • Gestire un cluster di failover

  • Risorse per i cluster di failover

  • Interfaccia utente: snap-in Gestione cluster di failover


Panoramica dei cluster di failover

Un cluster è costituito da un insieme di computer indipendenti che funzionano insieme per aumentare la disponibilità di servizi e applicazioni. I server inclusi nel cluster (denominati nodi) sono connessi mediante cavi fisici e software. Se si verificano problemi in un nodo, i servizi verranno forniti da un altro nodo. Questo processo è noto come failover.

È possibile utilizzare lo snap-in Gestione cluster di failover di Microsoft® Management Console (MMC) per convalidare le configurazioni di cluster di failover, creare e gestire cluster di failover ed eseguire la migrazione di determinate impostazioni in un cluster che esegue il sistema operativo Windows Server® 2008 R2. È inoltre possibile configurare e gestire i cluster di failover con Windows PowerShell. In questi argomenti della Guida vengono descritti i metodi per l'utilizzo di Gestione cluster di failover. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare i siti Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

I miglioramenti introdotti in Windows Server 2008 e Windows Server 2008 R2 per i cluster di failover, noti in precedenza come cluster di server in Windows Server 2003, hanno lo scopo di semplificare i cluster, migliorarne la sicurezza e aumentarne la stabilità. La configurazione e la gestione del cluster sono più semplici. Sono state migliorate la sicurezza e la gestione della rete, nonché il modo in cui un cluster di failover comunica con i dispositivi di archiviazione.

Si noti che la funzionalità Clustering di failover è inclusa in prodotti server come Windows Server 2008 R2 Enterprise e Windows Server 2008 R2 Datacenter. La funzionalità Clustering di failover non è inclusa in Windows Server 2008 R2 Standard e Windows Web Server 2008 R2.

  • Elenco di controllo: creare un cluster di failover

  • Elenco di controllo: Creare un file server del cluster

  • Elenco di controllo: Creare un server di stampa del cluster

  • Elenco di controllo: creare una macchina virtuale del cluster

  • Installare la funzionalità Clustering di failover

  • Convalidare la configurazione di un cluster di failover

  • Creare un cluster di failover o aggiungere un nodo al cluster

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Migrare le impostazioni a un cluster di failover che esegue Windows Server 2008 R2

  • Modificare le impostazioni per un cluster di failover

  • Gestire un cluster di failover

  • Risorse per i cluster di failover

  • Interfaccia utente: snap-in Gestione cluster di failover

Ulteriori riferimenti

  • Per un elenco di collegamenti a numerosi argomenti dedicati ai cluster di failover, vedere http://go.microsoft.com/fwlink/?LinkId=68633.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.

  • Per informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.


Elenco di controllo: creare un cluster di failover

Se si desidera garantire una disponibilità elevata agli utenti di una o più condivisioni file, vedere un elenco di controllo più completo facendo clic su Elenco di controllo: Creare un file server del cluster.

Se si desidera garantire una disponibilità elevata agli utenti di uno o più server di stampa, vedere un elenco di controllo più completo facendo clic su Elenco di controllo: Creare un server di stampa del cluster.

 | Passaggio | Riferimento
Casella di controllo | Verificare i requisiti a livello di hardware e infrastruttura per un cluster di failover. | Informazioni sui requisiti per i cluster di failover
Casella di controllo | Installare la funzionalità Clustering di failover in ogni server che verrà incluso nel cluster. | Installare la funzionalità Clustering di failover
Casella di controllo | Connettere le reti e i dispositivi di archiviazione che verranno utilizzati dal cluster. | Preparare l'hardware prima della convalida di un cluster di failover
Casella di controllo | Eseguire la Convalida guidata configurazione in tutti i server che si desidera inserire nel cluster per verificare che l'hardware e le impostazioni hardware dei server, della rete e dei dispositivi di archiviazione siano compatibili con il clustering di failover. Se necessario, adeguare l'hardware o le impostazioni hardware e rieseguire la procedura guidata fino a quando non vengono superati tutti i test (condizione obbligatoria per poter usufruire dei servizi di supporto). | Convalidare un cluster di failover nuovo o esistente
Casella di controllo | Creare il cluster di failover. | Creare un nuovo cluster di failover

Dopo aver creato un cluster di failover, il passaggio successivo consiste in genere nel configurare il cluster per il supporto di un particolare servizio o applicazione. Per ulteriori informazioni, vedere Configurare un servizio o un'applicazione per la disponibilità elevata.

Ulteriori riferimenti

  • Panoramica dei cluster di failover

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Elenco di controllo: Creare un file server del cluster

 | Passaggio | Riferimento
Casella di controllo | In ogni server che verrà incluso nel cluster aprire Server Manager, fare clic su Aggiungi ruoli e quindi utilizzare l'Aggiunta guidata ruoli per aggiungere il ruolo Servizi file e gli eventuali servizi ruolo necessari. | Guida di Server Manager
Casella di controllo | Verificare i requisiti a livello di hardware e infrastruttura per un cluster di failover. | Informazioni sui requisiti per i cluster di failover
Casella di controllo | Installare la funzionalità Clustering di failover in ogni server che verrà incluso nel cluster. | Installare la funzionalità Clustering di failover
Casella di controllo | Connettere le reti e i dispositivi di archiviazione che verranno utilizzati dal cluster. | Preparare l'hardware prima della convalida di un cluster di failover
Casella di controllo | Eseguire la Convalida guidata configurazione in tutti i server che si desidera inserire nel cluster per verificare che l'hardware e le impostazioni hardware dei server, della rete e dei dispositivi di archiviazione siano compatibili con il clustering di failover. Se necessario, adeguare l'hardware o le impostazioni hardware e rieseguire la procedura guidata fino a quando non vengono superati tutti i test (condizione obbligatoria per poter usufruire dei servizi di supporto). | Convalidare un cluster di failover nuovo o esistente
Casella di controllo | Creare il cluster di failover. | Creare un nuovo cluster di failover
Casella di controllo | Se i server del cluster sono connessi a una rete che non deve essere utilizzata per la comunicazione di rete nel cluster, ad esempio una rete destinata solo all'archiviazione iSCSI o al backup, configurare tale rete in modo che non sia consentita la comunicazione di cluster. | Modificare le impostazioni di rete per un cluster di failover
Casella di controllo | Eseguire la Configurazione guidata disponibilità elevata e specificare il ruolo File server, un nome per il file server del cluster e le informazioni relative all'indirizzo IP che non vengono fornite automaticamente dalle impostazioni DHCP. Specificare inoltre il volume o i volumi di archiviazione. | Configurare un servizio o un'applicazione per la disponibilità elevata
Casella di controllo | Aggiungere cartelle condivise al file server del cluster in base alle necessità. | Creare una cartella condivisa in un file server del cluster
Casella di controllo | Eseguire il test di failover del file server del cluster. | Eseguire il test di failover di un servizio o un'applicazione in cluster

Ulteriori riferimenti

  • Panoramica dei cluster di failover

  • Modificare le impostazioni di failover per un servizio o un'applicazione in cluster

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Elenco di controllo: Creare un server di stampa del cluster

 | Passaggio | Riferimento
Casella di controllo | In ogni server che verrà incluso nel cluster aprire Server Manager, fare clic su Aggiungi ruoli e quindi utilizzare l'Aggiunta guidata ruoli per aggiungere il ruolo Servizi di stampa e digitalizzazione e gli eventuali servizi ruolo necessari. | Guida di Server Manager
Casella di controllo | Verificare i requisiti a livello di hardware e infrastruttura per un cluster di failover. | Informazioni sui requisiti per i cluster di failover
Casella di controllo | Installare la funzionalità Clustering di failover in ogni server che verrà incluso nel cluster. | Installare la funzionalità Clustering di failover
Casella di controllo | Connettere le reti e i dispositivi di archiviazione che verranno utilizzati dal cluster. | Preparare l'hardware prima della convalida di un cluster di failover
Casella di controllo | Eseguire la Convalida guidata configurazione in tutti i server che si desidera inserire nel cluster per verificare che l'hardware e le impostazioni hardware dei server, della rete e dei dispositivi di archiviazione siano compatibili con il clustering di failover. Se necessario, adeguare l'hardware o le impostazioni hardware e rieseguire la procedura guidata fino a quando non vengono superati tutti i test (condizione obbligatoria per poter usufruire dei servizi di supporto). | Convalidare un cluster di failover nuovo o esistente
Casella di controllo | Creare il cluster di failover. | Creare un nuovo cluster di failover
Casella di controllo | Se i server del cluster sono connessi a una rete che non deve essere utilizzata per la comunicazione di rete nel cluster, ad esempio una rete destinata solo all'archiviazione iSCSI o al backup, configurare tale rete in modo che non sia consentita la comunicazione di cluster. | Modificare le impostazioni di rete per un cluster di failover
Casella di controllo | Eseguire la Configurazione guidata disponibilità elevata e specificare il ruolo di server di stampa, un nome per il server di stampa del cluster e le informazioni relative all'indirizzo IP che non vengono fornite automaticamente dalle impostazioni DHCP. | Configurare un servizio o un'applicazione per la disponibilità elevata
Casella di controllo | Configurare le impostazioni di stampa, ad esempio l'impostazione che consente di specificare la stampante. | Configurare le impostazioni di stampa per un server di stampa del cluster
Casella di controllo | Eseguire il test di failover del server di stampa del cluster. | Eseguire il test di failover di un servizio o un'applicazione in cluster
Casella di controllo | Stampare una pagina di prova da un client sul server di stampa del cluster. | Guida del sistema operativo del client (per la specifica del percorso del server di stampa del cluster) Guida dell'applicazione utilizzata per la stampa della pagina di prova

Ulteriori riferimenti

  • Panoramica dei cluster di failover

  • Modificare le impostazioni di failover per un servizio o un'applicazione in cluster

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Elenco di controllo: creare una macchina virtuale del cluster

Passaggio Riferimento
Casella di controllo

Analizzare i requisiti a livello di hardware e infrastruttura per un cluster di failover.

Informazioni sui requisiti per i cluster di failover

Casella di controllo

Analizzare i requisiti hardware per Hyper-V.

Pagina relativa ai requisiti hardware per Hyper-V (http://go.microsoft.com/fwlink/?LinkId=137803)

Casella di controllo

Analizzare i concetti relativi a Hyper-V e alle macchine virtuali nel contesto di un cluster.

Se si desidera utilizzare i volumi condivisi del cluster per le macchine virtuali, analizzare i concetti relativi ai volumi condivisi del cluster.

Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster

Informazioni sui volumi condivisi del cluster in un cluster di failover

Casella di controllo

Installare il ruolo Hyper-V e la funzionalità Clustering di failover in ogni server del cluster.

Pagina relativa all'installazione di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=137803)

Installare la funzionalità Clustering di failover

Casella di controllo

Connettere le reti e i dispositivi di archiviazione che verranno utilizzati dal cluster. Nella console di gestione di Hyper-V creare reti virtuali che potranno essere utilizzate con le macchine virtuali.

Preparare l'hardware prima della convalida di un cluster di failover

Pagina relativa alla gestione di reti virtuali (http://go.microsoft.com/fwlink/?LinkId=139566)

Casella di controllo

Eseguire la Convalida guidata configurazione in tutti i server che si desidera inserire nel cluster per verificare che l'hardware e le impostazioni hardware dei server, della rete e dei dispositivi di archiviazione siano compatibili con il clustering di failover. Se necessario, adeguare l'hardware o le impostazioni hardware e rieseguire la procedura guidata fino a quando non vengono superati tutti i test (condizione obbligatoria per poter usufruire dei servizi di supporto).

Convalidare un cluster di failover nuovo o esistente

Casella di controllo

Creare il cluster di failover.

Creare un nuovo cluster di failover

Casella di controllo

Se i server del cluster sono connessi a una rete che non deve essere utilizzata per la comunicazione di rete nel cluster, ad esempio una rete destinata solo all'archiviazione iSCSI o al backup, configurare tale rete in modo che non sia consentita la comunicazione di cluster.

Modificare le impostazioni di rete per un cluster di failover

Casella di controllo

Se si desidera utilizzare i volumi condivisi del cluster, attivare questa funzionalità se non è ancora stata attivata.

Attivare i volumi condivisi del cluster in un cluster di failover

Casella di controllo

Creare una macchina virtuale e configurarla per la disponibilità elevata, assicurandosi di selezionare Archivia macchina virtuale in un percorso diverso e specificare l'archiviazione cluster appropriata. Se si dispone di volumi condivisi del cluster, per l'archiviazione, specificare uno di questi volumi, ovvero un volume che si trovi nell'unità di sistema del nodo, nella cartella \ClusterStorage. In caso contrario, creare la macchina virtuale nel nodo attualmente proprietario dell'archiviazione cluster per la macchina virtuale stessa e specificare la posizione di tale archiviazione.

Nessuno dei file utilizzati da una macchina virtuale del cluster può trovarsi in un disco locale. Tali file devono trovarsi tutti nell'archiviazione cluster.

Configurare una macchina virtuale per la disponibilità elevata

Casella di controllo

Installare il sistema operativo per la macchina virtuale, se non è ancora stato installato. Se sono disponibili servizi di integrazione Hyper-V per il sistema operativo, installarli nel sistema operativo in esecuzione nella macchina virtuale.

Pagina relativa all'installazione di un sistema operativo guest (http://go.microsoft.com/fwlink/?LinkId=137806)

Casella di controllo

Riconfigurare l'azione di avvio automatico per la macchina virtuale in modo che non venga eseguita alcuna operazione all'avvio del computer fisico.

Pagina relativa alla configurazione di macchine virtuali (http://go.microsoft.com/fwlink/?LinkId=137807)

Casella di controllo

Eseguire il test di failover della macchina virtuale del cluster.

Eseguire il test di failover di una macchina virtuale del cluster

Ulteriori riferimenti

  • Aggiornare la configurazione di una macchina virtuale

  • Panoramica dei cluster di failover

  • Modificare le impostazioni di failover per un servizio o un'applicazione in cluster

  • Configurare una macchina virtuale per la disponibilità elevata

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Installare la funzionalità Clustering di failover

Per creare un cluster di failover, è innanzitutto necessario installare la funzionalità Clustering di failover in tutti i server che si desidera includere nel cluster. In questa sezione vengono fornite le istruzioni per l'installazione di questa funzionalità.

Si noti che la funzionalità Clustering di failover è inclusa in prodotti server come Windows Server 2008 R2 Enterprise e Windows Server 2008 R2 Datacenter. La funzionalità Clustering di failover non è inclusa in Windows Server 2008 R2 Standard e Windows Web Server 2008 R2.

  • Installare la funzionalità Clustering di failover


Installare la funzionalità Clustering di failover

È possibile installare la funzionalità Clustering di failover utilizzando il comando Aggiungi funzionalità in Attività di configurazione iniziale o Server Manager.

Nota

La funzionalità Clustering di failover è inclusa in prodotti server come Windows Server 2008 R2 Enterprise e Windows Server 2008 R2 Datacenter. La funzionalità Clustering di failover non è inclusa in Windows Server 2008 R2 Standard e Windows Web Server 2008 R2.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare la funzionalità Clustering di failover

  1. Se è stato installato di recente Windows Server 2008 R2 nel server e l'interfaccia di Attività di configurazione iniziale è visualizzata, in Personalizzazione del server fare clic su Aggiungi funzionalità. Andare direttamente al passaggio 3.

  2. Se l'interfaccia di Attività di configurazione iniziale non è visualizzata, aggiungere la funzionalità utilizzando Server Manager:

    • Se Server Manager è già in esecuzione, fare clic su Funzionalità. In Riepilogo funzionalità fare quindi clic su Aggiungi funzionalità.

    • Se Server Manager non è in esecuzione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, fare clic su Server Manager e quindi, se viene richiesta l'autorizzazione dell'utente, fare clic su Continua. In Riepilogo funzionalità fare quindi clic su Aggiungi funzionalità.

  3. Nell'Aggiunta guidata funzionalità fare clic su Clustering di failover e quindi su Installa.

  4. Al termine dell'aggiunta, chiudere la procedura guidata.

  5. Ripetere il processo per ogni server che si desidera includere nel cluster.

Ulteriori riferimenti

  • Panoramica dei cluster di failover

  • Informazioni sui requisiti per i cluster di failover


Convalidare la configurazione di un cluster di failover

Prima di creare un cluster di failover, è consigliabile convalidare la configurazione, ovvero eseguire tutti i test disponibili nella Convalida guidata configurazione. Prima di eseguire i test, è possibile verificare che l'hardware e le impostazioni siano compatibili con il clustering di failover.

È possibile eseguire i test su un insieme di server e dispositivi di archiviazione prima o dopo averli configurati come cluster di failover.

Importante

Microsoft supporta una soluzione di cluster di failover solo se la configurazione completa, ovvero server, rete e memoria, supera tutti i test della Convalida guidata configurazione. È necessario inoltre che tutti i componenti hardware della soluzione siano contrassegnati con il logo "Certified for Windows Server 2008 R2".

Con la Convalida guidata configurazione, è possibile eseguire l'insieme completo di test di configurazione oppure un sottoinsieme. La procedura guidata genera un rapporto in cui vengono indicati i risultati di ogni test eseguito.

  • Informazioni sui requisiti per i cluster di failover

  • Informazioni sul supporto di Microsoft per le soluzioni cluster

  • Informazioni sui test di convalida del cluster

  • Preparare l'hardware prima della convalida di un cluster di failover

  • Convalidare un cluster di failover nuovo o esistente

Ulteriori riferimenti

  • Utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni sui requisiti per i cluster di failover

Un cluster di failover deve soddisfare determinati requisiti in termini di hardware, software e infrastruttura di rete ed è necessario che l'amministratore utilizzi un account con le autorizzazioni di dominio appropriate. Nelle sezioni seguenti vengono fornite informazioni sui requisiti necessari.

  • Requisiti hardware per un cluster di failover

    • Distribuzione di reti di archiviazione con cluster di failover

  • Requisiti software per un cluster di failover

  • Requisiti relativi all'infrastruttura di rete e all'account di dominio per un cluster di failover

Per ulteriori informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

Requisiti hardware per un cluster di failover

È necessario che un cluster di failover disponga dell'hardware seguente:

  • Server: è consigliabile utilizzare un insieme di computer che soddisfano i requisiti contenenti componenti identici o simili.

    Importante

    Microsoft supporta una soluzione di cluster di failover solo se tutti i componenti hardware sono contrassegnati con il logo "Certified for Windows Server 2008 R2". È necessario inoltre che la configurazione completa, ovvero server, rete e memoria, superi tutti i test della Convalida guidata configurazione, inclusa nello snap-in Gestione cluster di failover.

    Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

    Per informazioni sul numero massimo di server supportati in un cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139146.

  • Schede e cavi di rete (per la comunicazione di rete): analogamente agli altri componenti inclusi nella soluzione cluster di failover, l'hardware di rete deve essere contrassegnato come certificato per Windows Server 2008 R2. Se si utilizzano dispositivi iSCSI, le schede di rete devono essere dedicate alla comunicazione di rete o all'archiviazione iSCSI, ma non a entrambe.

    Evitare singoli punti di errore nell'infrastruttura di rete utilizzata per la connessione dei nodi del cluster. A tale scopo, è possibile procedere in più modi. È possibile connettere i nodi del cluster utilizzando più reti distinte oppure è possibile connettere i nodi del cluster utilizzando un'unica rete costruita con schede di rete in team, commutatori ridondanti, router ridondanti o componenti hardware simili che consentano di eliminare i singoli punti di errore.

    Nota

    Se i nodi del cluster vengono connessi mediante un'unica rete, il requisito di ridondanza verrà passato dalla rete nella Convalida guidata configurazione. Nel rapporto creato dalla procedura guidata verrà tuttavia incluso un avviso per informare che la rete non deve disporre di singoli punti di errore.

    Per ulteriori dettagli sulla configurazione di rete necessaria per un cluster di failover, vedere Requisiti relativi all'infrastruttura di rete e all'account di dominio per un cluster di failover più avanti in questo argomento.

  • Controller di dispositivi o schede appropriate per l'archiviazione:

    • Per SAS o Fibre Channel: se si utilizzano dispositivi SAS o Fibre Channel, è consigliabile che in tutti i server del cluster i controller dei dispositivi di archiviazione di massa dedicati per l'archivio del cluster siano identici. È inoltre consigliabile che utilizzino la stessa versione del firmware.

      Nota

      Con Windows Server 2008 R2 non è possibile utilizzare l'interfaccia SCSI parallela per connettere i dispositivi di archiviazione ai server del cluster. Questa restrizione è valida anche per Windows Server 2008.

    • Per iSCSI: se si utilizzano dispositivi iSCSI, ogni server del cluster deve disporre di una o più schede di rete o schede bus host dedicate per l'archivio del cluster. La rete utilizzata per i dispositivi iSCSI non deve essere utilizzata per la comunicazione di rete. È consigliabile che in tutti i server del cluster le schede di rete utilizzate per la connessione alla destinazione di archiviazione iSCSI siano identiche e che vengano utilizzate schede Ethernet Gigabit o con velocità superiori.

      Per iSCSI, non è possibile utilizzare schede di rete in team in quanto non sono supportate con l'archiviazione iSCSI.

      Per ulteriori informazioni sull'archiviazione iSCSI, vedere la pagina relativa alle domande frequenti su iSCSI nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=61375.

  • Archiviazione: è necessario utilizzare l'archiviazione condivisa compatibile con Windows Server 2008 R2.

    Nella maggior parte dei casi, l'archiviazione può essere costituita da più dischi o LUN separati configurati a livello hardware. Per alcuni cluster, un disco funziona come witness di disco, come descritto alla fine di questa sezione. Gli altri dischi contengono in file necessari per i servizi o le applicazioni del cluster. I requisiti di archiviazione includono:

    • Per utilizzare il supporto nativo per dischi fornito dal clustering di failover, utilizzare dischi di base anziché dinamici.

    • È consigliabile formattare le partizioni con NTFS. Per il witness di disco o per i volumi condivisi del cluster, è necessario utilizzare partizioni NTFS.

      Per i volumi condivisi del cluster non sono previsti requisiti specifici oltre a quello di NTFS. Per ulteriori informazioni sui volumi condivisi del cluster, vedere Informazioni sui volumi condivisi del cluster in un cluster di failover.

    • Per lo stile di partizione del disco, è possibile utilizzare sia MBR (Record di avvio principale, Master Boot Record) sia GPT (Tabella di partizione GUID, GUID Partition Table).

    Un witness di disco è un disco dell'archivio del cluster progettato per contenere una copia del database di configurazione del cluster. Un cluster di failover dispone di un witness di disco solo se tale funzionalità è stata specificata durante la configurazione quorum. Per ulteriori informazioni, vedere Informazioni sulle configurazioni quorum in un cluster di failover.

Distribuzione di reti di archiviazione con cluster di failover

Per la distribuzione di una rete di archiviazione (SAN) con un cluster di failover, attenersi alle linee guida seguenti:

  • Verificare la compatibilità dei dispositivi di archiviazione: rivolgersi a produttori e fornitori per verificare che i dispositivi di archiviazione, inclusi driver, firmware e software per l'archiviazione, siano compatibili con i cluster di failover di Windows Server 2008 R2.

    Importante

    I dispositivi di archiviazione compatibili con i cluster di server di Windows Server 2003 potrebbero non essere compatibili con i cluster di failover di Windows Server 2008 R2. Contattare il fornitore per verificare che il dispositivo di archiviazione utilizzato sia compatibile con i cluster di failover di Windows Server 2008 R2.

    Per i cluster di failover sono previsti i nuovi requisiti per l'archiviazione seguenti:

    • I miglioramenti introdotti nei cluster di failover, rispetto ai cluster di server di Windows Server 2003, richiedono che il dispositivo di archiviazione risponda correttamente a comandi SCSI specifici. Per verificare se il dispositivo di archiviazione utilizzato è compatibile, eseguire la Convalida guidata configurazione. È inoltre possibile contattare il fornitore del dispositivo di archiviazione.

    • Il driver della miniport utilizzato per il dispositivo di archiviazione deve funzionare con il driver di archiviazione Microsoft Storport.

  • Isolare i dispositivi di archiviazione, un cluster per dispositivo: server inclusi in cluster diversi non devono essere in grado di accedere agli stessi dispositivi di archiviazione. Nella maggior parte dei casi, è consigliabile isolare un LUN utilizzato da un insieme di server del cluster da tutti gli altri server mediante il mascheramento dei LUN o la suddivisione in zone.

  • Considerare la possibilità di utilizzare software di I/O a percorsi multipli: nelle infrastrutture di archiviazione a disponibilità elevata è possibile distribuire cluster di failover con più schede bus host mediante software di I/O a percorsi multipli. Questa operazione garantisce il livello di ridondanza e disponibilità più elevato. La soluzione a percorsi multipli per Windows Server 2008 R2 deve essere basata su Microsoft Multipath I/O (MPIO). Con l'hardware viene in genere fornito un modulo specifico di dispositivo (DSM, Device Specific Module) MPIO, sebbene in Windows Server 2008 R2 siano inclusi uno o più DSM come parte del sistema operativo.

    Importante

    Le schede bus host e il software di I/O a percorsi multipli possono applicare una distinzione tra le diverse versioni. Se si sta implementando una soluzione a percorsi multipli per il cluster in uso, è consigliabile lavorare in stretta collaborazione con il fornitore dell'hardware per individuare le schede, il firmware e il software adatti per Windows Server 2008 R2.

Requisiti software per un cluster di failover

Tutti i server di un cluster di failover devono eseguire la versione di Windows Server 2008 R2 basata su architettura Itanium o x64. Nei nodi con un singolo cluster di failover non possono essere in esecuzione versioni diverse.

È inoltre necessario che tutti i server dispongano degli stessi aggiornamenti software (patch) e Service Pack.

La funzionalità Clustering di failover è inclusa in prodotti server come Windows Server 2008 R2 Enterprise e Windows Server 2008 R2 Datacenter. La funzionalità Clustering di failover non è inclusa in Windows Server 2008 R2 Standard e Windows Web Server 2008 R2.

Requisiti relativi all'infrastruttura di rete e all'account di dominio per un cluster di failover

Sarà necessario disporre dell'infrastruttura di rete per un cluster di failover descritta di seguito e di un account amministrativo con le autorizzazioni di dominio seguenti:

  • Impostazioni di rete e indirizzi IP: quando si utilizzano schede di rete identiche per una rete, è necessario utilizzare impostazioni di comunicazione identiche per tali schede, ad esempio Velocità, Modalità Duplex, Controllo di flusso e Tipo di supporto. Confrontare inoltre le impostazioni della scheda di rete e del commutatore al quale è connessa e verificare che non vi siano impostazioni in conflitto.

    Se si dispone di reti private non indirizzate alla restante parte dell'infrastruttura di rete, verificare che ogni rete privata utilizzi una subnet univoca. Questa operazione è necessaria anche se si assegna un indirizzo IP univoco a ogni scheda di rete. Se, ad esempio, si dispone di due nodi del cluster in un ufficio centrale che utilizza un'unica rete fisica e di due ulteriori nodi in una succursale di ufficio che utilizza una rete fisica separata, non specificare 10.0.0.0/24 per entrambe le reti, anche se si assegna un indirizzo IP univoco a ogni scheda.

    Per ulteriori informazioni sulle schede di rete, vedere Requisiti hardware per un cluster di failover nelle sezioni precedenti di questo argomento.

  • DNS: i server inclusi nel cluster devono utilizzare DNS per la risoluzione dei nomi. È possibile utilizzare il protocollo di aggiornamento dinamico del DNS.

  • Ruolo di dominio: tutti i server inclusi nel cluster devono trovarsi nello stesso dominio Active Directory. In base alle procedure consigliate, è opportuno che tutti i server del cluster dispongano dello stesso ruolo di dominio, ovvero server membro o controller di dominio. Il ruolo consigliato è server membro.

  • Controller di dominio: è consigliabile che i server del cluster siano server membro. In tal caso, altri server saranno controller di dominio nel dominio che contiene il cluster di failover.

  • Client: non esistono requisiti specifici per i client, tranne i normali requisiti relativi a connettività e compatibilità: i client devono essere in grado di connettersi ai server del cluster e devono eseguire software compatibile con i servizi offerti dai server del cluster.

  • Account per l'amministrazione del cluster: per creare un cluster o aggiungervi server, è necessario accedere al dominio con un account che disponga dei diritti di amministratore e delle autorizzazioni in tutti i server del cluster. L'account non deve necessariamente essere un account Domain Admins, ma può essere un account di utenti di dominio incluso nel gruppo Administrators in ogni server del cluster. Se non è un account Domain Admins, all'account o al gruppo del quale è membro dovrà inoltre essere assegnata l'autorizzazione Crea oggetti computer nel dominio. Per ulteriori informazioni, vedere l'argomento relativo alla configurazione di account in Active Directory della Guida dettagliata ai cluster di failover all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139147.

    Nota

    È stata apportata una modifica al modo in cui il Servizio cluster viene eseguito in Windows Server 2008 R2 rispetto a Windows Server 2003. In Windows Server 2008 R2 non esiste l'account del Servizio cluster. Il Servizio cluster viene invece eseguito automaticamente in un contesto speciale che fornisce le autorizzazioni e i privilegi specifici necessari per il servizio, in modo analogo al contesto di sistema locale, ma con privilegi ridotti.

Ulteriori riferimenti

  • Convalidare la configurazione di un cluster di failover

  • Panoramica dei cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni sul supporto di Microsoft per le soluzioni cluster

Microsoft supporta le soluzioni cluster di failover che soddisfano i requisiti seguenti:

  • Tutti i componenti hardware inclusi nella soluzione cluster di failover devono essere contrassegnati come certificati per Windows Server 2008 R2.

  • Tutti i componenti della soluzione cluster, ovvero server, rete e dispositivi di archiviazione, devono superare i test disponibili nella Convalida guidata configurazione.

  • Devono essere stati seguiti i consigli del produttore dell'hardware relativi agli aggiornamenti del firmware e del software (patch), ovvero devono essere stati applicati gli aggiornamenti del firmware e del software più recenti. È tuttavia possibile che un produttore consigli l'installazione di aggiornamenti specifici anziché di quelli più recenti.

Ulteriori riferimenti

  • Informazioni sui requisiti per i cluster di failover

  • Convalidare la configurazione di un cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni sui test di convalida del cluster

È possibile utilizzare la Convalida guidata configurazione per eseguire i test che consentono di verificare se l'hardware e le relative impostazioni sono compatibili con il clustering di failover. È possibile eseguire l'insieme completo o un sottoinsieme dei test di configurazione.

È consigliabile eseguire i test su tutti i server e dispositivi di archiviazione prima di configurarli come cluster di failover e di creare quindi un cluster. È inoltre possibile eseguire i test dopo aver creato un cluster.

Si noti che è necessario installare la funzionalità Clustering di failover in tutti i server che si desidera includere nei test.

Importante

Microsoft supporta una soluzione di cluster di failover solo se la configurazione completa, ovvero server, rete e memoria, supera tutti i test della Convalida guidata configurazione. È necessario inoltre che tutti i componenti hardware della soluzione siano contrassegnati con il logo "Certified for Windows Server 2008 R2".

La Convalida guidata configurazione include cinque tipi di test:

  • Test Configurazione cluster. Consentono di analizzare in modo semplice le impostazioni di un cluster esistente e determinare se sono configurate correttamente. Questi test possono essere eseguiti solo per cluster esistenti. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Configurazione cluster.

  • Test Inventario. Consentono di ottenere un inventario dell'hardware, del software e delle impostazioni dei server, ad esempio le impostazioni di rete, nonché informazioni sull'archiviazione. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Inventario.

  • Test Rete. Consentono di verificare che le reti siano configurate correttamente per il clustering. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Rete.

  • Test Archiviazione. Consentono di verificare che i dispositivi di archiviazione da cui dipende il cluster di failover funzionino correttamente e che supportino le funzioni necessarie del cluster. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Archiviazione.

  • Test Configurazione sistema. Consentono di verificare che le impostazioni di configurazione e del software di sistema siano compatibili tra i server. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Configurazione sistema.

Nel rapporto creato tramite la Convalida guidata configurazione sono inclusi messaggi simili ai seguenti relativi a ogni test:

  • L'elemento testato soddisfa i requisiti per un cluster di failover.

  • L'elemento testato potrebbe soddisfare i requisiti, ma è stato generato un avviso per informare che è consigliabile eseguire una verifica.

  • L'elemento testato non soddisfa i requisiti.

  • Non è possibile eseguire il test. Se, ad esempio, si sta testando un singolo nodo dal nodo stesso, è possibile che alcuni test non vengano eseguiti.

Ulteriori riferimenti

  • Convalidare la configurazione di un cluster di failover

  • Utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Informazioni sui test di convalida del cluster: Configurazione cluster

I test di configurazione dei cluster semplificano l'analisi delle impostazioni dei cluster e consentono di determinare se sono configurati correttamente. I test di configurazione dei cluster possono essere eseguiti solo in cluster esistenti e non in server per i quali è pianificato un cluster. I test includono i seguenti:

  • Elenco gruppi di base cluster: questo test consente di elencare le informazioni sull'archiviazione disponibile e sul gruppo di risorse utilizzato dal cluster.

  • Elenco informazioni reti cluster: questo test consente di elencare le impostazioni di rete specifiche del cluster archiviate nella configurazione del cluster. Vengono ad esempio elencate le impostazioni che influiscono sulla frequenza di invio di segnali heartbeat tra i server nella stessa subnet e tra i server di subnet diverse.

  • Elenco risorse cluster: questo test consente di elencare informazioni dettagliate per tutte le risorse configurate nel cluster.

  • Elenco volumi cluster: questo test consente di elencare le informazioni sui volumi nell'archivio cluster.

  • Elenco servizi e applicazioni del cluster: questo test consente di elencare le applicazioni e i servizi configurati per l'esecuzione nel cluster.

  • Convalida configurazione quorum: questo test consente di verificare se la configurazione quorum è ottimale per il cluster. Per ulteriori informazioni sulle configurazioni quorum, vedere Informazioni sulle configurazioni quorum in un cluster di failover.

  • Convalida stato risorse: questo test consente di verificare che le risorse siano online e di elencare le risorse del cluster in esecuzione in istanze di Monitoraggio risorse separate. Se una risorsa è in esecuzione in un'istanza distinta di Monitoraggio risorse, in genere significa che si è verificato un errore nella risorsa e che l'esecuzione del Servizio cluster è stata avviata in un'istanza di Monitoraggio risorse distinta, per ridurre al minimo l'effetto sulle altre risorse in caso di nuovo errore.

  • Convalida nome principale di servizio: questo test consente di verificare che sia disponibile un nome principale di servizio per tutte le risorse per cui è abilitato il protocollo Kerberos.

  • Convalida coerenza volume: questo test consente di verificare la presenza di volumi contrassegnati come incoerenti, ovvero "dirty", e, qualora siano presenti, di visualizzare un promemoria per segnalare che è consigliabile eseguire chkdsk.

Ulteriori riferimenti

  • Informazioni sui test di convalida del cluster

  • Convalidare la configurazione di un cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.


Informazioni sui test di convalida del cluster: Inventario

I test di inventario consentono di ottenere elenchi di informazioni relative all'hardware, al software e alle impostazioni di ogni server testato. È possibile utilizzare solo i test di inventario, senza eseguire gli altri test disponibili nella Convalida guidata configurazione, per rivedere o registrare la configurazione dell'hardware, ad esempio per verificare che gli aggiornamenti software siano identici in ogni server dopo aver eseguito la manutenzione pianificata.

È possibile utilizzare la Convalida guidata configurazione per eseguire i test di inventario seguenti:

  • Elenca informazioni BIOS

  • Elenca variabili di ambiente: esempi di variabili di ambiente sono rappresentati dal numero di processori, dal percorso del sistema operativo e dalla posizione di cartelle temporanee.

  • Elenca schede bus host Fibre Channel

  • Elenca scheda bus host iSCSI

  • Elenca informazioni memoria

  • Elenca informazioni sistema operativo

  • Elenca dispositivi Plug and Play

  • Elenca processi in esecuzione

  • Elenca schede bus host SAS: questo test consente di elencare le scheda bus host per SAS.

  • Elenca informazioni servizi: in base alle procedure consigliate per i server, in particolare per i nodi del cluster, è consigliabile eseguire solo i servizi necessari.

  • Elenca aggiornamenti software: è possibile utilizzare questo test per correggere i problemi che non vengono rilevati dal test Convalida livelli aggiornamenti software incluso nei test Configurazione sistema. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Configurazione sistema.

  • Elenca driver di sistema

  • Elenca informazioni sistema: le informazioni di sistema includono:

    • Nome computer

    • Produttore, modello e tipo

    • Nome account della persona che ha eseguito i test di convalida

    • Dominio in cui è incluso il computer

    • Impostazioni relative a fuso orario e ora legale, che consentono di determinare se l'orologio è stato modificato per l'ora legale

    • Numero di processori

  • Elenca driver non firmati: è possibile utilizzare questo test per correggere i problemi che non vengono rilevati dal test Convalida solo driver firmati incluso nei test Configurazione sistema. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Configurazione sistema.

Ulteriori riferimenti

  • Informazioni sui test di convalida del cluster

  • Convalidare la configurazione di un cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.


Informazioni sui test di convalida del cluster: Rete

I test di rete consentono di verificare di disporre dell'infrastruttura di rete corretta per un cluster di failover.

Correzione dei problemi non rilevabili dai test di rete

Per ulteriori informazioni sulla correzione dei problemi rilevati dai test di rete, vedere:

  • Preparare l'hardware prima della convalida di un cluster di failover

  • Informazioni sui requisiti per i cluster di failover

Per ulteriori informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

Test di rete disponibili nella Convalida guidata configurazione

Mediante la Convalida guidata configurazione è possibile eseguire i test di rete seguenti:

  • Elenco ordine di binding rete: questo test consente di elencare l'ordine di binding delle reti alle schede in ogni nodo.

  • Convalida configurazione reti di cluster include le attività seguenti:

    • Elenco delle reti di cluster, ovvero la topologia di rete vista dalla prospettiva del cluster.

    • Verifica che, per una determinata rete di cluster, gli indirizzi IP di tutte le schede di rete siano stati configurati nello stesso modo, ovvero che tutte utilizzino indirizzi IP statici o che tutte utilizzino DHCP.

    • Verifica che, per una determinata rete di cluster, tutte le schede di rete utilizzino la stessa versione di protocollo IP, ovvero che tutte utilizzino IPv4, che tutte utilizzino IPv6 o che tutte utilizzino sia IPv4 sia IPv6.

  • Convalida configurazione IP include le attività seguenti:

    • Elenco dei dettagli di configurazione IP.

    • Verifica che gli indirizzi IP siano univoci nel cluster, ovvero che non vi siano duplicati.

    • Controllo del numero di schede di rete in ogni server testato. Se viene individuata solo una scheda, nel rapporto verrà incluso un avviso per informare che è consigliabile evitare singoli punti di errore nell'infrastruttura di rete utilizzata per la connessione dei server del cluster.

      È possibile evitare singoli punti di errore in più modi. È possibile connettere i nodi del cluster utilizzando più reti distinte oppure è possibile connettere i nodi del cluster utilizzando un'unica rete costruita con schede di rete in team, commutatori ridondanti, router ridondanti o componenti hardware simili che consentano di eliminare i singoli punti di errore.

    • Verifica dell'assenza in tutti i server testati di più schede di rete nella stessa subnet IP.

    • Verifica che in tutti i server testati venga utilizzata la stessa versione di protocollo IP, ovvero che tutti utilizzino IPv4, che tutti utilizzino IPv6 o che tutti utilizzino sia IPv4 sia IPv6.

  • Convalida proprietà cluster con più subnet: questo testo consente di verificare che le impostazioni relative a DNS siano configurate in modo appropriato per i cluster che utilizzano più subnet per estendersi in più siti.

  • Convalida comunicazione di rete: questo test consente di verificare che i server testati possano comunicare con una latenza accettabile su tutte le reti. Questo test consente inoltre di rilevare l'esistenza di percorsi di comunicazione ridondanti tra tutti i server. La comunicazione tra i nodi di un cluster consente al cluster di rilevare errori ai nodi e modifiche dello stato e di gestire il cluster come una sola entità.

  • Convalida configurazione Windows Firewall: questo test consente di verificare che Windows Firewall sia configurato correttamente per il clustering di failover nei server testati.

Ulteriori riferimenti

  • Informazioni sui test di convalida del cluster

  • Informazioni sui requisiti per i cluster di failover

  • Preparare l'hardware prima della convalida di un cluster di failover

  • Convalidare la configurazione di un cluster di failover

  • Per ulteriori informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.


Informazioni sui test di convalida del cluster: Archiviazione

I test di archiviazione consentono di analizzare i dispositivi di archiviazione per determinare se funzioneranno correttamente con un cluster di failover che esegue Windows Server 2008 R2.

Correzione dei problemi non rilevabili dai test di archiviazione

Se un test di archiviazione indica che il dispositivo di archiviazione o la configurazione di archiviazione non supporterà un cluster di failover, tenere presenti i suggerimenti seguenti:

  • Contattare il fornitore del dispositivo di archiviazione e utilizzare le utilità fornite con l'archiviazione cluster per ottenere informazioni sulla configurazione. In casi rari, il fornitore del dispositivo di archiviazione potrebbe indicare che la soluzione cluster è supportata anche se i test di archiviazione non lo confermano. È ad esempio possibile che la soluzione cluster sia stata specificatamente progettata per essere utilizzata senza archiviazione condivisa.

  • Esaminare i risultati dei diversi eseguiti nella Convalida guidata configurazione, ad esempio i test del tipo Elenca schede bus host (vedere l'argomento Informazioni sui test di convalida del cluster: Inventario) e i due test descritti in questo argomento, ovvero Elenca tutti i dischi e Elenca potenziali dischi cluster.

  • Individuare un test di convalida dell'archiviazione correlato a quello che non ha rilevato il problema. Se, ad esempio, il test Convalida arbitraggio multiplo non ha rilevato un problema, il testo correlato Convalida arbitraggio dischi potrebbe fornire informazioni utili.

  • Esaminare i requisiti relativi all'archiviazione in Informazioni sui requisiti per i cluster di failover.

    Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Consultare la documentazione del dispositivo di archiviazione oppure contattare il produttore.

Test di archiviazione disponibili nella Convalida guidata configurazione

Mediante la Convalida guidata configurazione è possibile eseguire i test di archiviazione seguenti:

  • Elenca tutti i dischi

  • Elenca potenziali dischi cluster

  • Convalida latenza di accesso al disco

  • Convalida arbitraggio dischi

  • Convalida failover dei dischi

  • Convalida file system

  • Convalida dischi basati su Microsoft MPIO

  • Convalida arbitraggio multiplo

  • Convalida VPD (Vital Product Data) dispositivi SCSI

  • Convalida prenotazione permanente SCSI-3

  • Convalida failover simultaneo

Elenca tutti i dischi

Questo test consente di elencare tutti i dischi visibili per uno o più server testati. Vengono elencati:

  • Dischi che supportano il clustering e ai quali è possibile accedere da tutti i server.

  • Dischi in un singolo server.

Per ogni disco vengono elencate le informazioni seguenti:

  • Numero disco

  • Identificatore univoco

  • Tipo di bus

  • Tipo di stack

  • Indirizzo del disco, se applicabile, inclusi la porta, il percorso, l'identificatore di destinazione (TID, Target Identifier) e il numero di unità logica (LUN, Logical Unit Number)

  • Descrizione scheda

  • Caratteristiche del disco, ad esempio lo stile di partizione e il tipo di partizione

È possibile utilizzare questo test per diagnosticare problemi non rilevati da altri test di archiviazione descritti in questo argomento.

Elenca potenziali dischi cluster

Questo test consente di elencare i dischi che sono in grado di supportare il clustering e che sono visibili per tutti i server testati. Per supportare il clustering, è necessario che il disco sia connesso mediante schede SAS, iSCSI o Fibre Channel. Il test consente inoltre di convalidare il funzionamento corretto dell'I/O a percorsi multipli, a indicare che ogni disco viene visto come un singolo disco anziché due.
Tipi di dischi non elencati dal test

Questo test consente di elencare solo i dischi che possono essere utilizzati per il clustering. I dischi elencati devono:

  • Essere connessi mediante schede SAS, iSCSI o Fibre Channel.

  • Essere visibili per tutti i server del cluster.

  • Essere accessibili tramite una scheda bus host che supporti il clustering.

  • Non essere volumi di avvio o di sistema.

  • Non essere utilizzati per file di paging, file ibernazione o file di dettagli. Nei file di dettagli viene registrato il contenuto della memoria quando il sistema si arresta in modo imprevisto.

Convalida latenza di accesso al disco

Questo test consente di verificare che la latenza per le operazioni di lettura e scrittura su disco sia compresa entro un limite accettabile per un cluster di failover. Se le operazioni di lettura e scrittura richiedono troppo tempo, potrebbero venire attivati i timeout del cluster. L'applicazione che sta tentando di accedere al disco potrebbe inoltre apparire in errore e il cluster potrebbe avviare un failover non necessario.

Convalida arbitraggio dischi

Questo test consente di verificare che:

  • Ogni server del cluster sia in grado di utilizzare il processo di arbitraggio per diventare il proprietario di tutti i dischi del cluster.

  • Quando un determinato server è proprietario di un disco, se in uno o più altri server viene eseguito l'arbitraggio di tale disco, il proprietario originale mantiene la proprietà.

Se un server del cluster non può diventare il proprietario di un disco o non è in grado di mantenerne la proprietà quando in altri server del cluster viene eseguito l'arbitraggio del disco, potrebbero determinarsi i problemi seguenti:

  • Il disco potrebbe non avere proprietari ed essere pertanto non disponibile.

  • Due proprietari potrebbero scrivere nel disco in modo non coordinato, causandone il danneggiamento.

    I server di cluster di failover sono progettati per coordinare tutte le operazioni di scrittura in modo da evitare il danneggiamento del disco.

  • Il proprietario del disco potrebbe cambiare a ogni arbitraggio, determinando un'interferenza nella disponibilità del disco.

Convalida failover dei dischi

Questo test consente di verificare che il failover dei dischi funzioni correttamente nel cluster. Nello specifico, il test consente di verificare che quando viene eseguito il failover di un disco di un server del cluster, il server che diventa proprietario del disco sia in grado di leggerlo. Il test consente inoltre di verificare che le informazioni scritte nel disco prima del failover rimangano le stesse anche dopo il failover.

Se si verifica il failover dei dischi e il server che diventa proprietario di un disco non è in grado di leggerlo, il cluster non potrà gestire la disponibilità del disco. Se le informazioni scritte nel disco vengono modificate durante il processo di failover, potrebbero verificarsi problemi per gli utenti o per il software che necessitano di tali informazioni. In entrambi i casi, se il disco interessato è un witness di disco, ovvero un disco in cui vengono archiviati i dati di configurazione del cluster e che fa parte del quorum, questi problemi potrebbero causare la perdita del quorum e l'arresto del cluster.

Se questo test indica che il failover dei dischi non funziona correttamente, i risultati dei test seguenti potrebbero contribuire a identificare la causa del problema:

  • Convalida prenotazione permanente SCSI-3

  • Convalida arbitraggio dischi

  • Convalida arbitraggio multiplo

Convalida file system

Questo test consente di verificare che il file system nei dischi dell'archiviazione condivisa sia supportato dai cluster di failover.

Convalida dischi basati su Microsoft MPIO

Questo test consente di verificare che i dischi a percorsi multipli, ovvero dischi basati su Microsoft MPIO, siano stati configurati correttamente per il cluster di failover.

Convalida arbitraggio multiplo

Questo test consente di verificare che quando più server del cluster eseguono l'arbitraggio di un disco del cluster, solo un server ne diventi il proprietario. Il processo di arbitraggio del disco consente di garantire che i server del cluster eseguano tutte le operazioni di scrittura in modo coordinato, evitando il danneggiamento del disco.

Se il test indica che più server del cluster sono in grado di diventare proprietari di un disco del cluster mediante l'arbitraggio del disco, i risultati del test seguente potrebbero contribuire a identificare la causa del problema:

  • Convalida prenotazione permanente SCSI-3

Convalida VPD (Vital Product Data) dispositivi SCSI

Questo test consente di verificare che l'archiviazione supporti i dati di interrogazione SCSI necessari (descrittori VPD) e che questi siano univoci.

Convalida prenotazione permanente SCSI-3

Questo test consente di verificare che l'archiviazione del cluster utilizzi i comandi di prenotazione permanente più recenti (standard SCSI-3), i quali sono diversi dai comandi di prenotazione/rilascio dello standard SCSI-2 precedente. I comandi di prenotazione permanente consentono di evitare i ripristini del bus SCSI causati dai comandi di prenotazione/rilascio meno recenti. La velocità di risposta di un cluster di failover risulta quindi più elevata in numerose situazioni rispetto a un cluster che esegue una versione precedente del sistema operativo. I dischi non vengono inoltre mai lasciati in uno stato non protetto, riducendo in tal modo i rischi di danneggiamento dei volumi.

Convalida failover simultaneo

Questo test consente di verificare che il failover dei dischi simultaneo funzioni correttamente nel cluster. Nello specifico, questo test consente di verificare che anche quando si verifica il failover di più dischi contemporaneamente, i server del cluster che diventano proprietari di un disco siano in grado di leggerlo. Il test consente inoltre di verificare che le informazioni scritte in ogni disco prima del failover rimangano le stesse anche dopo il failover.

Se si verifica il failover dei dischi e il server che diventa proprietario di un disco non è in grado di leggerlo, il cluster non potrà gestire la disponibilità del disco. Se le informazioni scritte nel disco vengono modificate durante il processo di failover, potrebbero verificarsi problemi per il software o per gli utenti che necessitano di tali informazioni. In entrambi i casi, se il disco interessato è un witness di disco, ovvero un disco in cui vengono archiviati i dati di configurazione del cluster e che fa parte del quorum, questi problemi potrebbero causare la perdita del quorum e l'arresto del cluster.

Se questo test indica che il failover dei dischi non funziona correttamente, i risultati dei test seguenti potrebbero contribuire a identificare la causa del problema:

  • Convalida failover dei dischi

  • Convalida arbitraggio dischi

  • Convalida arbitraggio multiplo

Ulteriori riferimenti

  • Informazioni sui test di convalida del cluster

  • Informazioni sui requisiti per i cluster di failover

  • Preparare l'hardware prima della convalida di un cluster di failover

  • Convalidare la configurazione di un cluster di failover

  • Per ulteriori informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.


Informazioni sui test di convalida del cluster: Configurazione sistema

I test Configurazione sistema consentono di analizzare i server selezionati per stabilire se sono stati configurati correttamente per l'interazione in un cluster di failover. I test Configurazione sistema includono:

  • Convalida configurazione di Active Directory: questo test consente di verificare che ogni server testato appartenga allo stesso dominio e alla stessa unità organizzativa. Consente inoltre di verificare che tutti i server testati siano controller di dominio o server membri. Per modificare il ruolo di dominio di un server, utilizzare l'Installazione guidata Servizi di dominio Active Directory®.

  • Convalida solo driver firmati: questo test consente di verificare che tutti i server testati contengano solo driver firmati. L'eventuale presenza di un driver non firmato non verrà considerata un errore, ma determinerà la visualizzazione di un avviso.

    Lo scopo dei driver firmati è garantire che i driver presenti nel sistema siano file originali inalterati forniti con il sistema operativo o da un fornitore.

    È possibile visualizzare un elenco di driver di sistema e un elenco di driver non firmati eseguendo l'attività Inventario corrispondente. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Inventario.

  • Convalida impostazioni Servizio cluster e driver: questo test consente di verificare le impostazioni di avvio utilizzate da servizi e driver, inclusi il Servizio cluster, NetFT.sys e Clusdisk.sys.

  • Convalida impostazioni file di dettagli della memoria: questo test consente di verificare che non siano presenti nodi che richiedono un riavvio nell'ambito di un aggiornamento del software e che ogni nodo sia configurato in modo da acquisire un file di dettagli della memoria se l'esecuzione viene interrotta.

  • Convalida opzione di installazione sistema operativo: questo test consente di verificare che per tutti i sistemi operativi dei server venga utilizzata la stessa opzione di installazione (installazione completa o dei componenti di base del server).

  • Convalida servizi necessari: questo test consente verificare che i servizi necessari per il clustering di failover siano in esecuzione in ogni server testato e siano stati configurati per l'avvio automatico ogni volta che il server viene riavviato.

  • Convalida stessa architettura di processore: questo test consente di verificare che tutti i server testati abbiano la stessa architettura. Un cluster di failover è supportato solo se i sistemi in esso contenuti sono tutti sistemi basati su architettura Itanium o x64.

  • Convalida livelli di Service Pack: questo test consente di verificare che tutti i server testati dispongano degli stessi Service Pack. È possibile eseguire un cluster di failover anche se alcuni server dispongono di Service Pack diversi rispetto agli altri. È tuttavia possibile che server con Service Pack diversi producano risultati imprevisti diversi tra loro. È consigliabile che tutti i server inclusi nel cluster di failover dispongano degli stessi Service Pack.

  • Convalida livelli aggiornamenti software: questo test consente di verificare che tutti i server testati dispongano degli stessi aggiornamenti software. È possibile eseguire un cluster di failover anche se alcuni server dispongono di aggiornamenti software diversi rispetto agli altri. È tuttavia possibile che server con aggiornamenti software diversi producano risultati imprevisti diversi tra loro. È consigliabile che tutti i server inclusi nel cluster di failover dispongano degli stessi livelli di aggiornamento del software.

  • Convalida variabile unità di sistema: questo test consente di verificare che in tutti i nodi venga utilizzata la stessa lettera per la variabile di ambiente dell'unità di sistema.

Ulteriori riferimenti

  • Informazioni sui test di convalida del cluster

  • Convalidare la configurazione di un cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.


Preparare l'hardware prima della convalida di un cluster di failover

Prima di eseguire la Convalida guidata configurazione per un cluster di failover, è consigliabile eseguire alcune attività di preparazione, ad esempio la connessione delle reti e dei dispositivi di archiviazione necessari per il cluster. In questo argomento vengono illustrate brevemente queste attività di preparazione. Per un elenco completo dei requisiti per un cluster di failover, vedere Informazioni sui requisiti per i cluster di failover.

Per eseguire questa procedura, è in genere necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente, poiché i passaggi illustrati prevedono la configurazione delle reti e dei dispositivi di archiviazione. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per preparare l'hardware prima della convalida di un cluster di failover

  1. Verificare che l'intera soluzione cluster, inclusi i driver, sia compatibile con Windows Server 2008 R2 controllando le informazioni sulla compatibilità hardware disponibili nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

    Importante

    Microsoft supporta una soluzione di cluster di failover solo se tutti i componenti hardware sono contrassegnati con il logo "Certified for Windows Server 2008 R2". È necessario inoltre che la configurazione completa, ovvero server, rete e memoria, superi tutti i test della Convalida guidata configurazione, inclusa nello snap-in Gestione cluster di failover.

    È consigliabile utilizzare un insieme di computer contenenti componenti identici o simili.

  2. Per le reti del cluster:

    1. Esaminare i dettagli sulle reti in Informazioni sui requisiti per i cluster di failover.

    2. Connettere e configurare le reti che verranno utilizzate dai server nel cluster.

      Nota

      Per configurare le reti del cluster, è possibile creare una configurazione di rete preliminare, quindi eseguire la Convalida guidata configurazione selezionando i test Rete senza selezionare i test Archiviazione. Quando si selezionano solo i test Rete, il processo richiede meno tempo. Utilizzando il rapporto di convalida, è possibile apportare le correzioni necessarie alla configurazione di rete. Dopo aver configurato l'archiviazione, si eseguirà la procedura guidata con tutti i test.

  3. Per l'archiviazione:

    1. Esaminare i dettagli sull'archiviazione in Informazioni sui requisiti per i cluster di failover.

    2. Per la connessione fisica dei server ai dispositivi di archiviazione, seguire le istruzioni fornite dal produttore.

  4. Verificare che i dischi o i LUN che si desidera utilizzare nel cluster siano esposti ai server che verranno configurati in cluster e solo a tali server. Per esporre i dischi o i LUN, è possibile utilizzare una delle interfacce seguenti:

    • Gestione archivi SAN, un componente del sistema operativo Windows Server 2008 R2. Per utilizzare questa interfaccia, è necessario rivolgersi al produttore del dispositivo di archiviazione per ottenere un pacchetto del provider Servizio dischi virtuali (VDS) specifico per il dispositivo di archiviazione in uso.

    • Se si utilizzano dispositivi iSCSI, utilizzare un'interfaccia iSCSI appropriata.

    • Interfaccia fornita dal produttore del dispositivo di archiviazione.

  5. Se è stato acquistato un software per il controllo del formato o della funzione del disco, richiedere istruzioni al fornitore sull'utilizzo di tale software con Windows Server 2008 R2.

  6. In uno dei server che si desidera inserire in un cluster fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Gestione computer e quindi fare clic su Gestione disco. (Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.) In Gestione disco verificare che i dischi del cluster siano visibili.

  7. Se si desidera disporre di un volume di archiviazione di dimensioni maggiori di 2 TB e si utilizza l'interfaccia di Windows per controllare il formato del disco, convertire il disco nello stile di partizione denominato tabella di partizione GUID (GPT, GUID Partition Table). A tale scopo, eseguire il backup di tutti i dati presenti nel disco, eliminare tutti i volumi nel disco e quindi in Gestione disco fare clic con il pulsante destro del mouse sul disco, non sulla partizione, e scegliere Converti in disco GPT.

    Per i volumi di dimensioni inferiori a 2 TB, anziché utilizzare lo stile di partizione GPT, è possibile utilizzare lo stile di partizione denominato record di avvio principale (MBR, Master Boot Record).

    Importante

    Per un disco utilizzato da un cluster di failover, è possibile utilizzare lo stile di partizione MBR o GPT, ma non è possibile utilizzare un disco convertito in dinamico mediante Gestione disco.

  8. Controllare il formato dei volumi o dei LUN esposti. È consigliabile utilizzare NTFS per il formato. Per il witness di disco o per i volumi condivisi del cluster è necessario utilizzare NTFS.

  9. Verificare che sia stabilita la connessione tra i server da inserire in un cluster e gli eventuali controller di dominio non cluster. La connessione ai client non è necessaria per la convalida e potrà essere stabilita successivamente.

Ulteriori riferimenti

  • Informazioni sul supporto di Microsoft per le soluzioni cluster

  • Informazioni sui requisiti per i cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Convalidare un cluster di failover nuovo o esistente

Prima di creare un cluster di failover, è consigliabile convalidare l'hardware, ovvero server, reti e dispositivi di archiviazione, eseguendo la Convalida guidata configurazione. È possibile convalidare un cluster esistente oppure uno o più server non ancora configurati in cluster.

Importante

Microsoft supporta una soluzione di cluster di failover solo se la configurazione completa, ovvero server, rete e memoria, supera tutti i test della Convalida guidata configurazione. È necessario inoltre che tutti i componenti hardware della soluzione siano contrassegnati con il logo "Certified for Windows Server 2008 R2".

Nota

Se si desidera eseguire test in un cluster con volumi condivisi del cluster attualmente online, attenersi alle istruzioni in Utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per convalidare un cluster di failover nuovo o esistente

  1. Identificare il server o i server che si desidera testare e verificare che la funzionalità Clustering di failover sia installata:

    • Se il cluster non esiste ancora, scegliere i server che si desidera includere nel cluster e verificare di aver installato la funzionalità Clustering di failover in tali server. Per ulteriori informazioni, vedere Installare la funzionalità Clustering di failover.

      Si noti che quando si esegue la Convalida guidata configurazione su server non appartenenti a un cluster, è necessario immettere i nomi di tutti i server che si desidera testare anziché quello di un solo server.

    • Se il cluster esiste già, verificare di conoscere il nome del cluster o di uno dei relativi nodi.

  2. Verificare che l'hardware di rete e di archiviazione che si desidera convalidare sia connesso ai server. Per informazioni dettagliate, vedere Preparare l'hardware prima della convalida di un cluster di failover e Informazioni sui requisiti per i cluster di failover.

  3. Scegliere se si desidera eseguire tutti i test di convalida disponibili o solo una parte di essi. Per informazioni dettagliate sui test, vedere agli argomenti elencati in Informazioni sui test di convalida del cluster.

    Per decidere se eseguire o meno tutti i test, attenersi alle linee guida seguenti:

    • Per un cluster pianificato con tutti i componenti hardware connessi: eseguire tutti i test.

    • Per un cluster pianificato con alcuni componenti hardware connessi: eseguire i test Configurazione sistema, i test Inventario e i test che si applicano all'hardware connesso, ovvero i test Rete se la rete è connessa o i test Archiviazione se i dispositivi di archiviazione sono connessi.

    • Per un cluster al quale si prevede di aggiungere un server: eseguire tutti i test, verificando al momento dell'esecuzione di includere tutti i server che si prevede di inserire nel cluster.

    • Per la risoluzione dei problemi relativi a un cluster esistente: per risolvere i problemi relativi a un cluster esistente, è consigliabile eseguire tutti i test, sebbene sia possibile eseguire solo i test correlati al problema riscontrato.

      Nota

      Se si stanno risolvendo i problemi in un cluster esistente che utilizza i volumi condivisi del cluster, vedere Utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover.

  4. Nello snap-in Gestione cluster di failover, nell'albero della console verificare che l'opzione Gestione cluster di failover sia selezionata e quindi fare clic su Convalida configurazione in Gestione.

  5. Per specificare i server e i test, eseguire i test e visualizzare i risultati, seguire le istruzioni visualizzate nella procedura guidata.

    Si noti che quando si esegue la Convalida guidata configurazione su server non appartenenti a un cluster, è necessario immettere i nomi di tutti i server che si desidera testare anziché quello di un solo server.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Per visualizzare i risultati dei test dopo aver chiuso la procedura guidata, eseguire una delle procedure seguenti:

    • Aprire la cartella systemroot\Cluster\Reports in un server del cluster.

    • Se i server testati sono ora inclusi in un cluster, nell'albero della console fare clic con il pulsante destro del mouse sul cluster e quindi scegliere Visualizza rapporto di convalida. Verrà visualizzato il rapporto di convalida più recente per il cluster specifico.

Ulteriori riferimenti

  • Installare la funzionalità Clustering di failover

  • Informazioni sul processo di migrazione a un cluster che esegue Windows Server 2008 R2

  • Preparare l'hardware prima della convalida di un cluster di failover

  • Informazioni sui test di convalida del cluster

  • Utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Creare un cluster di failover o aggiungere un nodo al cluster

Prima di poter configurare il cluster per la prima volta o di aggiungere un server (nodo) a un cluster di failover esistente, è necessario eseguire la procedura preparatoria seguente:

  • Installare la funzionalità Clustering di failover: è necessario installare la funzionalità Clustering di failover in tutti i server che verranno configurati come server (nodi) nel cluster. Per ulteriori informazioni, vedere Installare la funzionalità Clustering di failover.

  • Connettere reti e dispositivi di archiviazione: è necessario connettere le reti e i dispositivi di archiviazione che verranno utilizzati dati nodi. Per informazioni dettagliate, vedere:

    • Preparare l'hardware prima della convalida di un cluster di failover

    • Informazioni sui requisiti per i cluster di failover.

  • Convalidare la configurazione hardware : è consigliabile convalidare la configurazione hardware, costituita da server, rete e dispositivi di archiviazione, prima di creare un cluster o di aggiungere un nodo a un cluster. Per eseguire la convalida, avviare la procedura guidata. Per ulteriori informazioni, vedere Convalidare un cluster di failover nuovo o esistente.

    Importante

    Microsoft supporta una soluzione di cluster di failover solo se la configurazione completa, ovvero server, rete e memoria, supera tutti i test della Convalida guidata configurazione. È necessario inoltre che tutti i componenti hardware della soluzione siano contrassegnati con il logo "Certified for Windows Server 2008 R2".

Per visualizzare la procedura precedente nel contesto di un elenco di controllo, vedere Elenco di controllo: creare un cluster di failover.

Negli argomenti seguenti viene descritto come creare un cluster di failover o aggiungere un server (nodo) a un cluster di failover:

  • Informazioni sui punti di accesso (nomi e indirizzi IP) in un cluster di failover

  • Creare un nuovo cluster di failover

  • Aggiungere un server a un cluster di failover

Ulteriori riferimenti

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Migrare le impostazioni a un cluster di failover che esegue Windows Server 2008 R2

  • Per informazioni sul numero massimo di server supportati in un cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139146.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni sui punti di accesso (nomi e indirizzi IP) in un cluster di failover

Un punto di accesso è costituito da un nome e da un indirizzo IP associato. È possibile utilizzare un punto di accesso per amministrare un cluster di failover oppure per comunicare con un servizio o un'applicazione nel cluster. Un punto di accesso può includere uno o più indirizzi IP, i quali possono essere indirizzi IPv6, indirizzi IPv4 forniti tramite DHCP oppure indirizzi IPv4 statici.

Quando si seleziona una rete da utilizzare come punto di accesso, evitare le reti utilizzate per l'archiviazione iSCSI. Configurare le reti utilizzate per l'archiviazione iSCSI in modo che non vengano utilizzate per la comunicazione di rete nel cluster.

Ulteriori riferimenti

  • Informazioni sui test di convalida del cluster: Rete

  • Modificare le impostazioni di rete per un cluster di failover

  • Informazioni sui requisiti per i cluster di failover


Creare un nuovo cluster di failover

Prima di creare un cluster, è necessario eseguire attività quali la connessione dell'hardware e la convalida della configurazione hardware. Per un elenco di queste attività, vedere Elenco di controllo: creare un cluster di failover.

Per informazioni sul numero massimo di server supportati in un cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139146.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Se l'account in uso non è un account Domain Admins, all'account o al gruppo di cui l'account è membro sarà inoltre necessario assegnare l'autorizzazione Crea oggetti computer nel dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare un nuovo cluster di failover

  1. Verificare che l'hardware sia stato connesso e la configurazione hardware sia stata convalidata, come descritto negli argomenti seguenti:

    • Preparare l'hardware prima della convalida di un cluster di failover

    • Convalidare un cluster di failover nuovo o esistente.

    Importante

    Microsoft supporta una soluzione di cluster di failover solo se la configurazione completa, ovvero server, rete e memoria, supera tutti i test della Convalida guidata configurazione. È necessario inoltre che tutti i componenti hardware della soluzione siano contrassegnati con il logo "Certified for Windows Server 2008 R2".

  2. Nello snap-in Gestione cluster di failover verificare che l'opzione Gestione cluster di failover sia selezionata e quindi fare clic su Crea un cluster in Gestione.

  3. Seguire le istruzioni della procedura guidata per specificare:

    • I server da includere nel cluster.

    • Il nome del cluster.

    • Le informazioni sugli indirizzi IP che non vengono fornite automaticamente dalle impostazioni DHCP.

  4. Quando viene visualizzata la pagina Riepilogo al termine dell'esecuzione della procedura guidata, fare clic su Visualizza rapporto se si desidera visualizzare un rapporto delle attività eseguite dalla procedura guidata.

    Per visualizzare il rapporto dopo aver chiuso la procedura guidata, vedere la cartella indicata di seguito, dove SystemRoot è la posizione del sistema operativo, ad esempio C:\Windows:

    SystemRoot\Cluster\Reports\

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Creare un cluster di failover o aggiungere un nodo al cluster

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Aggiungere un server a un cluster di failover

Prima di aggiungere un server (nodo) a un cluster di failover, è consigliabile eseguire la Convalida guidata configurazione per i nodi del cluster esistenti e per i nuovi nodi. La Convalida guidata configurazione consente di verificare aspetti importanti relativi alla configurazione, ad esempio che il server da aggiungere sia connesso correttamente alle reti e ai dispositivi di archiviazione e che disponga degli stessi aggiornamenti software.

Importante

Microsoft supporta una soluzione di cluster di failover solo se la configurazione completa, ovvero server, rete e memoria, supera tutti i test della Convalida guidata configurazione. È necessario inoltre che tutti i componenti hardware della soluzione siano contrassegnati con il logo "Certified for Windows Server 2008 R2".

Per informazioni sul numero massimo di server supportati in un cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139146.

Per ulteriori informazioni sulla convalida, vedere Convalidare un cluster di failover nuovo o esistente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere un server a un cluster di failover

  1. Verificare di aver connesso le reti e i dispositivi di archiviazione al server che si desidera aggiungere. Per informazioni dettagliate sui requisiti di rete e archiviazione, vedere Preparare l'hardware prima della convalida di un cluster di failover.

  2. Verificare la configurazione hardware, sia dei nodi del cluster esistenti sia del nuovo nodo proposto. Per informazioni sulla convalida, vedere Convalidare un cluster di failover nuovo o esistente.

    Importante

    Microsoft supporta una soluzione di cluster di failover solo se la configurazione completa, ovvero server, rete e memoria, supera tutti i test della Convalida guidata configurazione. È necessario inoltre che tutti i componenti hardware della soluzione siano contrassegnati con il logo "Certified for Windows Server 2008 R2".

  3. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  4. Selezionare il cluster e quindi fare clic su Aggiungi nodo nel riquadro Azioni.

  5. Per specificare il server da aggiungere al cluster, seguire le istruzioni della procedura guidata.

  6. Quando viene visualizzata la pagina Riepilogo al termine dell'esecuzione della procedura guidata, fare clic su Visualizza rapporto se si desidera visualizzare un rapporto delle attività eseguite dalla procedura guidata.

    Per visualizzare il rapporto dopo aver chiuso la procedura guidata, vedere la cartella indicata di seguito, dove SystemRoot è la posizione del sistema operativo, ad esempio C:\Windows:

    SystemRoot\Cluster\Reports\

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Creare un cluster di failover o aggiungere un nodo al cluster


Configurare un servizio o un'applicazione per la disponibilità elevata

In questo argomento vengono fornite informazioni generali sull'attività di configurazione di servizi o applicazioni specifici per il clustering di failover mediante la Configurazione guidata disponibilità elevata. Le istruzioni per l'esecuzione della procedura guidata vengono fornite in Configurare un servizio o un'applicazione per la disponibilità elevata.

Importante

Se si desidera configurare in cluster un'applicazione di server di posta o server di database, vedere la documentazione dell'applicazione per ottenere informazioni sulla modalità di installazione corretta in un ambiente cluster. Server di posta e server di database sono applicazioni complesse per le quali potrebbe essere necessario eseguire procedure che non rientrano nell'ambito di questa Guida relativa al clustering di failover.

In questo argomento sono incluse le sezioni seguenti:

  • Applicazioni e servizi elencati nella Configurazione guidata disponibilità elevata

  • Elenco di argomenti relativi alla configurazione di un servizio o di un'applicazione per la disponibilità elevata

Applicazioni e servizi elencati nella Configurazione guidata disponibilità elevata

Come applicazioni abilitate per i cluster è possibile utilizzare un'ampia gamma di servizi e applicazioni il cui funzionamento è coordinato con i componenti del cluster.

Nota

Quando si configura un servizio o un'applicazione non abilitato per i cluster, è possibile utilizzare le opzioni generiche disponibili nella Configurazione guidata disponibilità elevata, ovvero Servizio generico, Applicazione generica o Script generico. Per informazioni sull'utilizzo di queste opzioni, vedere Informazioni su servizi e applicazioni generici configurabili in un cluster di failover.

Nella Configurazione guidata disponibilità elevata è possibile scegliere tra le diverse opzioni generiche incluse nella nota precedente oppure è possibile scegliere i servizi e le applicazioni seguenti:

  • Server dello spazio dei nomi DFS: offre una visualizzazione virtuale delle cartelle condivise all'interno di un'organizzazione. Quando un utente visualizza lo spazio dei nomi, le cartelle sembrano risiedere in un unico disco rigido. Gli utenti possono esplorare lo spazio dei nomi senza conoscere i nomi dei server o delle cartelle condivise che ospitano i dati.

  • Server DHCP: consente di fornire automaticamente indirizzi IP validi a computer client e altri dispositivi di rete basati su TCP/IP.

  • Distributed Transaction Coordinator (DTC): consente il supporto di applicazioni distribuite che eseguono transazioni. Una transazione è un insieme di attività correlate, ad esempio aggiornamenti di database, che hanno esito positivo o negativo come unità.

  • File server: offre una posizione centrale in rete in cui è possibile archiviare i file e condividerli con altri utenti.

  • Server iSNS (Internet Storage Name Service): fornisce una directory di destinazioni iSCSI.

  • Accodamento messaggi: consente alle applicazioni distribuite che vengono eseguite in momenti diversi di comunicare attraverso reti eterogenee e con computer che potrebbero essere offline.

  • Altro server: fornisce soltanto un punto di accesso client e l'archiviazione. Consente di aggiungere un'applicazione dopo il completamento della procedura guidata.

  • Server di stampa: consente di gestire una coda di processi di stampa per una stampante condivisa.

  • Gestore connessione Desktop remoto (in precedenza Broker di sessione di Servizi terminal): supporta il bilanciamento del carico di sessione e la riconnessione delle sessioni in una server farm con carico bilanciato. Gestore connessione Desktop remoto viene inoltre utilizzato per fornire agli utenti l'accesso ai desktop virtuali e ai programmi RemoteApp tramite Connessione RemoteApp e desktop.

  • Macchina virtuale: eseguita in un computer fisico come sistema virtualizzato. In un computer è possibile eseguire più macchine virtuali.

  • Server WINS: consente agli utenti di accedere alle risorse tramite il nome NetBIOS anziché richiedere l'utilizzo di indirizzi IP difficili da riconoscere e ricordare.

Elenco di argomenti relativi alla configurazione di un servizio o di un'applicazione per la disponibilità elevata

Negli argomenti seguenti viene descritto il processo di configurazione di un servizio o di un'applicazione per la disponibilità elevata in un cluster di failover:

  • Informazioni su servizi e applicazioni generici configurabili in un cluster di failover

  • Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Configurare una macchina virtuale per la disponibilità elevata

  • Eseguire il test di failover di un servizio o un'applicazione in cluster

  • Eseguire il test di failover di una macchina virtuale del cluster

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

Ulteriori riferimenti

  • Elenco di controllo: creare un cluster di failover

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni su servizi e applicazioni generici configurabili in un cluster di failover

In un cluster di failover è possibile configurare per la disponibilità elevata un'ampia gamma di servizi o applicazioni. Per un elenco dei servizi o delle applicazioni più comunemente configurati per la disponibilità elevata, vedere Configurare un servizio o un'applicazione per la disponibilità elevata.

Questo argomento include le sezioni seguenti:

  • Servizi o applicazioni che possono essere eseguiti come Applicazione generica, Script generico o Servizio generico

  • Requisiti di base per un servizio o un'applicazione in un ambiente cluster di failover

Servizi o applicazioni che possono essere eseguiti come Applicazione generica, Script generico o Servizio generico

Nei cluster di failover è possibile utilizzare le opzioni Applicazione generica, Script generico e Servizio generico per configurare la disponibilità elevata per alcuni servizi e applicazioni non abilitati per i cluster, ovvero non progettati in origine per essere eseguiti in un cluster.

Applicazione generica

Se si esegue un'applicazione come applicazione generica, il software di cluster avvierà l'applicazione e quindi interrogherà periodicamente il sistema operativo per verificare se l'applicazione è in esecuzione. In caso affermativo, presumendo che sia online, l'applicazione non verrà riavviata o non ne verrà eseguito il failover.

Si noti che rispetto a un'applicazione abilitata per i cluster, un'applicazione generica dispone di un numero ridotto di possibilità per comunicare con precisione il proprio stato al software di cluster. Se un'applicazione generica, apparentemente in esecuzione, entra in stato di errore, il software di cluster non avrà modo di individuare il problema e di intraprendere un'azione, ad esempio il riavvio o il failover dell'applicazione.

Prima di eseguire la Configurazione guidata disponibilità elevata per un'applicazione generica, verificare di conoscere il percorso dell'applicazione e i nomi delle eventuali chiavi indicati nel Registro di sistema in HKEY_LOCAL _MACHINE necessari per l'applicazione.

Script generico

È possibile creare uno script che viene eseguito in Windows Script Host per monitorare e controllare l'applicazione. È quindi possibile configurare lo script come script generico nel cluster. Lo script consente di fornire al software di cluster informazioni sullo stato corrente dell'applicazione. In base alle necessità, il software di cluster riavvierà o eseguirà il failover dello script causando il riavvio o il failover dell'applicazione.

Quando si configura uno script generico in un cluster di failover, la capacità del software di cluster di rispondere con precisione allo stato dell'applicazione è determinata dallo script. Più sono precise le informazioni sullo stato dell'applicazione fornite dallo script, più il software di cluster sarà in grado di rispondere con precisione a tali informazioni.

Prima di eseguire la Configurazione guidata disponibilità elevata per configurare la disponibilità elevata per uno script generico, verificare di conoscere il percorso dello script.

Servizio generico

Il software di cluster avvierà il servizio e quindi interrogherà periodicamente il controller del servizio, una funzionalità del sistema operativo, per determinare se il servizio risulta in esecuzione. In caso affermativo, presumendo che sia online, il servizio non verrà riavviato o non ne verrà eseguito il failover.

Si noti che rispetto a un servizio abilitato per i cluster, un servizio generico dispone di un numero ridotto di possibilità per comunicare con precisione il proprio stato al software di cluster. Se un servizio generico, apparentemente in esecuzione, entra in stato di errore, il software di cluster non avrà modo di individuare il problema e di intraprendere un'azione, ad esempio il riavvio o il failover del servizio.

Prima di eseguire la Configurazione guidata disponibilità elevata per configurare la disponibilità elevata per un servizio generico, verificare di conoscere il nome del servizio indicato nel Registro di sistema in HKEY_LOCAL _MACHINE\System\CurrentControlSet\Services.

Requisiti di base per un servizio o un'applicazione in un ambiente cluster di failover

Per essere adatto a un cluster di failover, è necessario che un servizio o un'applicazione disponga di determinate caratteristiche. Quelle più importanti includono:

  • Il servizio o l'applicazione deve essere dotato di uno stato. Il servizio o l'applicazione deve disporre della caratteristica di stato in memoria di lunga durata o di stati dei dati di grandi dimensioni aggiornati di frequente. Un esempio è rappresentato da un'applicazione di database. Per un'applicazione senza stato, ad esempio un server Web front-end, il bilanciamento del carico di rete risulterà più appropriato rispetto al clustering di failover.

  • Il servizio o l'applicazione deve utilizzare un componente client che riesegua la connessione automatica quando si verificano interruzioni di rete temporanee. In caso contrario, se il componente server dell'applicazione esegue il failover da un server del cluster a un altro, l'inevitabile, seppur breve, interruzione che si verificherà determinerà l'arresto dei client anziché il tentativo di riconnessione.

  • Il servizio o l'applicazione deve essere in grado di identificare il disco o i dischi utilizzati. Il servizio o l'applicazione sarà in questo modo in grado di comunicare con i dischi inclusi nell'archivio del cluster e di individuare in modo affidabile il disco corretto anche dopo il failover.

  • Il servizio o l'applicazione deve utilizzare protocolli basati su indirizzi IP. Ad esempio TCP, UDP, DCOM, named pipe e RPC su TCP/IP.

Ulteriori riferimenti

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster

In questo argomento vengono fornite informazioni sugli aspetti seguenti:

  • Panoramica di Hyper-V nel contesto di un cluster di failover

  • Utilizzo di volumi condivisi del cluster con Hyper-V

  • Operazioni Live Migration, migrazione rapida e spostamento di macchine virtuali

  • Coordinamento dell'utilizzo della console di gestione di Hyper-V con Gestione cluster di failover

Panoramica di Hyper-V nel contesto di un cluster di failover

Il ruolo Hyper-V in Server Manager consente di creare un ambiente di elaborazione server virtualizzato in cui è possibile creare e gestire macchine virtuali che eseguono sistemi operativi, applicazioni e servizi. I cluster di failover vengono utilizzati per aumentare la disponibilità di tali applicazioni e servizi. È possibile utilizzare Hyper-V e la funzionalità Clustering di failover in combinazione per creare una macchina virtuale con disponibilità elevata, riducendo pertanto al minimo i tempi di interruzione per i client.

È possibile configurare in cluster una macchina virtuale, nonché un servizio o un'applicazione in esecuzione in una macchina virtuale. Se si configura in cluster una macchina virtuale, il cluster esegue il monitoraggio dell'integrità della macchina virtuale stessa e risponde agli errori tramite riavvio della macchina virtuale o esecuzione del failover. Se si configura in cluster un servizio o un'applicazione in esecuzione in una macchina virtuale, il cluster esegue il monitoraggio dell'integrità del servizio o dell'applicazione e risponde agli errori tramite riavvio dell'applicazione o esecuzione del failover.

Una funzionalità dei cluster di failover denominata Volumi condivisi cluster è progettata appositamente per migliorare la disponibilità e la semplicità di gestione delle macchine virtuali.

Utilizzo di volumi condivisi del cluster con Hyper-V

I volumi condivisi del cluster sono volumi di un cluster di failover che possono essere letti e scritti contemporaneamente da più nodi. In questo modo, più nodi possono accedere contemporaneamente a un unico volume condiviso. La funzionalità per i volumi condivisi del cluster può essere utilizzata solo con Hyper-V (un ruolo del server in Windows Server 2008 R2) e altre tecnologie specificate da Microsoft. Per informazioni sui ruoli e le funzionalità supportati per l'utilizzo con Volumi condivisi cluster, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137158.

L'utilizzo dei volumi condivisi del cluster consente di semplificare la gestione di un numero elevato di macchine virtuali del cluster. Per ulteriori informazioni sui volumi condivisi del cluster, vedere Informazioni sui volumi condivisi del cluster in un cluster di failover.

Operazioni Live Migration, migrazione rapida e spostamento di macchine virtuali

I cluster di failover consentono di spostare le macchine virtuali da un nodo del cluster a un altro in diversi modi: operazioni Live Migration, migrazione rapida e spostamento. In questa sezione vengono descritte tali azioni. Per informazioni su come eseguire le azioni, vedere Eseguire operazioni Live Migration, di migrazione rapida o di spostamento di una macchina virtuale da un nodo a un altro.

Nota

Se si desidera configurare in cluster le macchine virtuali e utilizzare operazioni Live Migration o di migrazione rapida, è consigliabile impostare nel modo più simile possibile la configurazione hardware e di sistema dei nodi, per ridurre al minimo i potenziali problemi.

Nell'elenco seguente sono descritte le opzioni disponibili:

Live Migration: quando si avvia un'operazione Live Migration, il cluster copia la memoria utilizzata dalla macchina virtuale dal nodo corrente a un altro nodo, così che quando avviene effettivamente la transizione all'altro nodo, le informazioni sullo stato e sulla memoria sono già disponibili per la macchina virtuale. La transizione avviene in genere in modo sufficientemente rapido affinché un client che utilizza la macchina virtuale non perda la connessione di rete. Se si utilizzano i volumi condivisi del cluster, le operazioni Live Migration sono quasi istantanee, in quanto non è necessario il trasferimento della proprietà dei dischi. È possibile utilizzare Live Migration per la manutenzione pianificata ma non per un failover non pianificato.

Nota

Non è possibile utilizzare Live Migration per spostare contemporaneamente più macchine virtuali. In un particolare server che esegue Hyper-V, è possibile eseguire una sola operazione Live Migration (al o dal server) in un determinato momento.

Migrazione rapida: quando si avvia un'operazione di migrazione rapida, il cluster copia la memoria utilizzata dalla macchina virtuale in un disco nell'archivio, così che quando avviene effettivamente la transizione a un altro nodo, le informazioni sullo stato e sulla memoria necessarie per la macchina virtuale possono essere lette in modo rapido dal disco da parte del nodo che acquisisce la proprietà. È possibile eseguire la migrazione rapida per la manutenzione pianificata ma non per un failover non pianificato.

Non è possibile eseguire la migrazione rapida per spostare contemporaneamente più macchine virtuali.

Spostamento: quando si avvia un'operazione di spostamento, il cluster prepara la disconnessione della macchina virtuale eseguendo un'azione specificata nella configurazione del cluster per la risorsa macchina virtuale: Salva, Arresta, Arresta (in modo forzato) o Spegni. Salva (impostazione predefinita) consente di salvare lo stato della macchina virtuale in modo che sia possibile ripristinarlo quando la macchina virtuale viene di nuovo connessa. Arresta consente di eseguire un arresto ordinato del sistema operativo, attendendo la chiusura di tutti i processi, nella macchina virtuale prima di disconnetterla. Arresta (in modo forzato) consente di arrestare il sistema operativo nella macchina virtuale senza attendere il completamento dei processi e quindi disconnette la macchina virtuale. Spegni consente di eseguire un'operazione simile all'interruzione dell'alimentazione della macchina virtuale e può pertanto comportare la perdita di dati.

L'impostazione specificata per l'azione di disconnessione non influisce su operazioni Live Migration, sulla migrazione rapida o sul failover non pianificato, ma solo sullo spostamento o sulla disconnessione della risorsa tramite l'azione di Windows PowerShell o un'applicazione. Per informazioni su come eseguire le azioni, vedere la sezione "Ulteriori considerazioni" in Eseguire operazioni Live Migration, di migrazione rapida o di spostamento di una macchina virtuale da un nodo a un altro.

Coordinamento dell'utilizzo della console di gestione di Hyper-V con Gestione cluster di failover

Dopo aver configurato le macchine virtuali del cluster, è possibile modificare le impostazioni di tali macchine utilizzando la console di gestione di Hyper-V o Gestione cluster di failover. È consigliabile utilizzare Gestione cluster di failover per modificare queste impostazioni, come descritto in Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster. Se si decide di utilizzare la console di gestione di Hyper-V per modificare le impostazioni delle macchine virtuali, aprire Gestione cluster di failover e aggiornare la configurazione delle macchine virtuali, come descritto in Aggiornare la configurazione di una macchina virtuale.

Ulteriori riferimenti

  • Informazioni sui volumi condivisi del cluster in un cluster di failover

  • Elenco di controllo: creare una macchina virtuale del cluster

  • Eseguire operazioni Live Migration, di migrazione rapida o di spostamento di una macchina virtuale da un nodo a un altro

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.

  • Per informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Configurare un servizio o un'applicazione per la disponibilità elevata

È possibile configurare un servizio o un'applicazione per la disponibilità elevata eseguendo una procedura guidata che consente di creare le impostazioni appropriate in un cluster di failover. Per informazioni sui servizi e le applicazioni che è possibile configurare in un cluster di failover, vedere:

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Informazioni su servizi e applicazioni generici configurabili in un cluster di failover.

Se si sta configurando un file server del cluster o un server di stampa del cluster, rivedere uno degli elenchi di controllo seguenti:

  • Elenco di controllo: Creare un file server del cluster

  • Elenco di controllo: Creare un server di stampa del cluster.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Se l'account in uso non è un account Domain Admins, all'account o al gruppo di cui l'account è membro sarà inoltre necessario assegnare l'autorizzazione Crea oggetti computer nel dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare un servizio o un'applicazione per la disponibilità elevata

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Fare clic su Servizi e applicazioni e quindi su Configura servizio o applicazione sul lato destro di Azioni.

  4. Seguire le istruzioni della procedura guidata per specificare il servizio o l'applicazione che si desidera configurare per la disponibilità elevata e i dettagli seguenti:

    • Nome per il servizio o l'applicazione del cluster. Questo nome verrà registrato nel DNS e associato all'indirizzo IP del servizio o dell'applicazione del cluster specifico.

    • Informazioni sull'indirizzo IP non fornite automaticamente dalle impostazioni DHCP, ad esempio un indirizzo IPv4 statico per il servizio o l'applicazione del cluster specifico.

    • Volume o volumi di archiviazione che dovranno essere utilizzati dal servizio o dall'applicazione del cluster.

    • Informazioni specifiche per il servizio o l'applicazione che si sta configurando. Per un'applicazione generica, sarà ad esempio necessario specificare il percorso dell'applicazione e le eventuali chiavi del Registro di sistema richieste dall'applicazione, in modo che possano essere replicate in tutti i nodi del cluster.

  5. Quando viene visualizzata la pagina Riepilogo al termine dell'esecuzione della procedura guidata, fare clic su Visualizza rapporto se si desidera visualizzare un rapporto delle attività eseguite dalla procedura guidata.

    Se si sta configurando un file server del cluster o un server di stampa del cluster, vedere la sezione "Ulteriori considerazioni" seguente.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Se si tratta del primo servizio o applicazione che viene configurato per la disponibilità elevata, potrebbe essere utile rivedere adesso le impostazioni relative alla rete di cluster. Se i server del cluster sono connessi a una rete che non deve essere utilizzata per la comunicazione di rete nel cluster, ad esempio una rete destinata solo all'archiviazione iSCSI o al backup, in Reti fare clic con il pulsante destro del mouse su tale rete, scegliere Proprietà e quindi selezionare Non consentire al cluster di utilizzare questa rete.

  • Se si sta configurando un file server del cluster, rivedere Elenco di controllo: Creare un file server del cluster.

  • Se si sta configurando un server di stampa del cluster, rivedere Elenco di controllo: Creare un server di stampa del cluster.

  • Per informazioni sulla modifica delle impostazioni per il servizio o l'applicazione specifico dopo il completamento della procedura guidata, vedere Modificare le impostazioni per un servizio o un'applicazione in cluster.

Ulteriori riferimenti

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Informazioni su servizi e applicazioni generici configurabili in un cluster di failover

  • Modificare le impostazioni per un servizio o un'applicazione in cluster


Configurare una macchina virtuale per la disponibilità elevata

In un cluster di failover è possibile configurare una macchina virtuale per la disponibilità elevata eseguendo una procedura guidata che consente di creare le impostazioni appropriate.

Per informazioni sull'utilizzo delle macchine virtuali, vedere il contenuto della Guida relativo allo snap-in Console di gestione di Hyper-V. A tale scopo, installare il ruolo Hyper-V, tramite Server Manager e l'Aggiunta guidata ruoli, aprire la console di gestione di Hyper-V, tramite Server Manager o in una console snap-in distinta, e premere F1. È inoltre possibile ottenere informazioni su Hyper-V nel Web, ad esempio per quanto riguarda la creazione di una macchina virtuale (http://go.microsoft.com/fwlink/?LinkId=137805).

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare una macchina virtuale per la disponibilità elevata

  1. Assicurarsi di avere installato il ruolo Hyper-V e analizzato i passaggi descritti in Elenco di controllo: creare una macchina virtuale del cluster. Questa procedura corrisponde a un passaggio di tale elenco di controllo.

  2. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  3. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  4. Fare clic su Servizi e applicazioni.

  5. Se è già stata creata la macchina virtuale, andare al passaggio 6. In caso contrario, utilizzare la Creazione guidata macchina virtuale per creare una macchina virtuale e configurarla per la disponibilità elevata:

    1. Nel riquadro Azione fare clic su Macchine virtuali, scegliere Macchina virtuale e quindi fare clic su un nodo.

      La macchina virtuale verrà inizialmente creata in tale nodo e verrà quindi configurata in cluster per consentirne lo spostamento in uno o più altri nodi, in base a quanto necessario.

    2. Se viene visualizzata la pagina Prima di iniziare della Creazione guidata macchina virtuale, fare clic su Avanti.

    3. Specificare un nome per la macchina virtuale e quindi selezionare Archivia macchina virtuale in un percorso diverso e specificare un disco in un dispositivo di archiviazione condiviso oppure, se sono attivati i volumi condivisi del cluster, specificare un volume condiviso del cluster, ovvero un volume che si trovi nell'unità di sistema del nodo, nella cartella \ClusterStorage.

    4. Seguire le istruzioni visualizzate nella procedura guidata. È possibile specificare dettagli, quali la quantità di memoria, la rete e il file del disco rigido virtuale, nonché aggiungere o modificare i dettagli di configurazione in un secondo momento.

    5. Quando si fa clic su Fine, tramite la procedura guidata viene creata la macchina virtuale, che viene configurata per la disponibilità elevata. Ignorare i passaggi rimanenti di questa procedura.

  6. Se la macchina virtuale è già stata creata e si desidera solo configurarla per la disponibilità elevata, verificare innanzitutto che non sia in esecuzione. Utilizzare quindi la Configurazione guidata disponibilità elevata per configurare la macchina virtuale per la disponibilità elevata.

    1. Nel riquadro Azione fare clic su Configura servizio o applicazione.

    2. Se viene visualizzata la pagina Prima di iniziare della Configurazione guidata disponibilità elevata, fare clic su Avanti.

    3. Nella pagina Selezione servizio o applicazione fare clic su Macchina virtuale e quindi su Avanti.

    4. Selezionare la macchina virtuale che si desidera configurare per la disponibilità elevata e completare la procedura guidata.

    5. Quando viene visualizzata la pagina Riepilogo al termine dell'esecuzione della Configurazione guidata disponibilità elevata, fare clic su Visualizza rapporto se si desidera visualizzare un rapporto delle attività eseguite dalla procedura guidata.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Se si decide di modificare le impostazioni di una macchina virtuale del cluster, assicurarsi di consultare l'argomento Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster.

  • Per ogni macchina virtuale del cluster è inoltre possibile specificare l'azione eseguita dal cluster prima della disconnessione della macchina virtuale. È necessario disconnettere la macchina virtuale quando la si sposta, mentre non è necessario farlo in caso di operazione Live Migration o migrazione rapida. Per specificare l'impostazione, dopo aver selezionato la macchina virtuale del cluster nell'albero della console (sulla sinistra), assicurarsi di fare clic con il pulsante destro del mouse sulla risorsa macchina virtuale visualizzata nel riquadro centrale (e non a sinistra) e quindi scegliere Proprietà. Fare clic sulla scheda Impostazioni e selezionare un'opzione. Le azioni sono descritte nella sezione relativa a operazioni Live Migration, migrazione rapida e spostamento di macchine virtuali di Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster, nella parte in cui viene descritto lo spostamento di macchine virtuali.

  • Se si tratta della prima macchina virtuale che viene configurata per la disponibilità elevata, potrebbe essere utile rivedere le impostazioni relative alla rete di cluster. Se i server del cluster sono connessi a una rete che non deve essere utilizzata per la comunicazione di rete nel cluster, ad esempio una rete destinata solo all'archiviazione iSCSI o al backup, in Reti fare clic con il pulsante destro del mouse su tale rete, scegliere Proprietà e quindi selezionare Non consentire al cluster di utilizzare questa rete.

Ulteriori riferimenti

  • Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster

  • Elenco di controllo: creare una macchina virtuale del cluster

  • Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster

  • Configurare un servizio o un'applicazione per la disponibilità elevata


Eseguire il test di failover di un servizio o un'applicazione in cluster

È possibile eseguire un test di base per verificare che sia possibile eseguire correttamente il failover di un servizio o di un'applicazione del cluster in un altro nodo. Per ulteriori informazioni sull'esecuzione di un test simile per una macchina virtuale del cluster, vedere Eseguire il test di failover di una macchina virtuale del cluster.

Questa procedura corrisponde ai passaggi illustrati negli elenchi di controllo seguenti:

  • Elenco di controllo: Creare un file server del cluster

  • Elenco di controllo: Creare un server di stampa del cluster

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per eseguire il test di failover di un servizio o un'applicazione in cluster

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Servizi e applicazioni e quindi fare clic sul servizio o l'applicazione di cui si desidera eseguire il test di failover.

  4. Sul lato destro di Azioni fare clic su Sposta servizio o applicazione in un altro nodo.

    Mentre il servizio o l'applicazione viene spostato, lo stato viene visualizzato nella parte centrale del riquadro dei risultati.

  5. È possibile ripetere il passaggio 4 per spostare il servizio o l'applicazione in un nodo aggiuntivo o spostarlo di nuovo nel nodo originale.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Elenco di controllo: Creare un file server del cluster

  • Elenco di controllo: Creare un server di stampa del cluster

  • Modificare le impostazioni per un servizio o un'applicazione in cluster


Eseguire il test di failover di una macchina virtuale del cluster

È possibile eseguire un test di base per verificare che sia possibile eseguire correttamente il failover di una macchina virtuale del cluster in un altro nodo. Per informazioni sull'esecuzione di un test simile per un servizio o un'applicazione in cluster, vedere Eseguire il test di failover di un servizio o un'applicazione in cluster.

Questa procedura corrisponde a uno dei passaggi illustrati nell'elenco di controllo seguente:

  • Elenco di controllo: creare una macchina virtuale del cluster

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per eseguire il test di failover di una macchina virtuale del cluster

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Macchina virtuale e quindi fare clic sulla macchina virtuale di cui si desidera eseguire il test di failover.

  4. In Azioni, a destra, fare clic su Sposta macchine virtuali in un altro nodo.

    Mentre la macchina virtuale viene spostata, lo stato viene visualizzato nella parte centrale del riquadro dei risultati.

  5. Facoltativamente, ripetere il passaggio 4 per spostare la macchina virtuale in un nodo aggiuntivo o spostarla di nuovo nel nodo originale.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Se si decide di modificare le impostazioni di una macchina virtuale del cluster, assicurarsi di consultare l'argomento Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster.

Ulteriori riferimenti

  • Configurare una macchina virtuale per la disponibilità elevata

  • Elenco di controllo: creare una macchina virtuale del cluster

  • Configurare un servizio o un'applicazione per la disponibilità elevata


Modificare le impostazioni per un servizio o un'applicazione in cluster

In questo argomento vengono descritte le impostazioni di failover e failback per un servizio o un'applicazione del cluster. Sono inoltre disponibili collegamenti alle informazioni relative alle altre impostazioni che è possibile modificare per un servizio o un'applicazione del cluster.

  • Modifica delle impostazioni di failover e failback, inclusi i proprietari preferiti

  • Elenco di argomenti relativi alla modifica delle impostazioni

Modifica delle impostazioni di failover e failback, inclusi i proprietari preferiti

È possibile modificare le impostazioni di failover, inclusi i proprietari preferiti e le impostazioni di failback, per controllare la modalità di risposta del cluster a errori dell'applicazione o del servizio. È possibile configurare queste impostazioni nella finestra delle proprietà relativa al servizio o all'applicazione del cluster disponibile nella scheda Generale o nella scheda Failover. Nella tabella seguente vengono descritti esempi che illustrano gli effetti di tali impostazioni.

Impostazioni Effetto

Esempio 1:

Scheda Generale, Proprietari preferiti: Nodo1

Scheda Failover, Impostazione di failback: Consenti failback (immediatamente)

Se viene eseguito il failover del servizio o dell'applicazione dal Nodo 1 nel Nodo2, quando il Nodo1 sarà di nuovo disponibile, verrà eseguito il failback del servizio o dell'applicazione nel Nodo1.

Esempio 2:

Scheda Failover, Numero massimo di errori nel periodo specificato: 2

Scheda Failover, Periodo (ore): 6

Se in un periodo di 6 ore si verificano errori all'applicazione o al servizio per un numero di volte minore o uguale a due, l'applicazione o il servizio verrà riavviato o ne verrà eseguito il failover ogni volta. Se nel periodo di 6 ore si verificano errori all'applicazione o al servizio per una terza volta, l'applicazione o il servizio verrà lasciato in stato di errore.

Il valore predefinito per il numero massimo di errori corrisponde a n-1, dove n è il numero dei nodi. È possibile modificare questo valore, ma è consigliabile scegliere un valore relativamente piccolo in modo che, in caso di errori di più nodi, l'applicazione o il servizio non verrà spostato tra i nodi per un tempo indeterminato.

Elenco di argomenti relativi alla modifica delle impostazioni

Negli argomenti seguenti vengono fornite informazioni dettagliate sulle impostazioni che è possibile modificare per un servizio o un'applicazione del cluster:

  • Aggiungere archiviazione per un servizio o un'applicazione del cluster (Per informazioni sull'aggiunta di un disco al cluster, in modo che il disco sia disponibile per l'aggiunta a un servizio o a un'applicazione del cluster, vedere Aggiungere archiviazione a un cluster di failover).

  • Aggiungere una risorsa a un servizio o un'applicazione del cluster

  • Modificare le impostazioni di failover per un servizio o un'applicazione in cluster

  • Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster

  • Creare una cartella condivisa in un file server del cluster

  • Configurare le impostazioni di stampa per un server di stampa del cluster

Ulteriori riferimenti

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Aggiungere archiviazione per un servizio o un'applicazione del cluster

È possibile aggiungere archiviazione a un servizio o un'applicazione del cluster esistente. Tuttavia, se l'archiviazione non è stata ancora aggiunta al cluster di failover, sarà innanzitutto necessario aggiungerla al cluster prima di poterla aggiungere al servizio o all'applicazione all'interno del cluster. Per informazioni sull'aggiunta di archiviazione al cluster, vedere Aggiungere archiviazione a un cluster di failover.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere archiviazione a un servizio o un'applicazione del cluster

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Servizi e applicazioni e quindi fare clic sul servizio o l'applicazione a cui si desidera aggiungere archiviazione.

  4. Sul lato destro di Azioni fare clic su Aggiungi archiviazione.

  5. Selezionare il disco o i dischi che si desidera aggiungere.

    Se il disco non viene visualizzato nell'elenco, è possibile che non sia stato ancora aggiunto al cluster. Per ulteriori informazioni, vedere Aggiungere archiviazione a un cluster di failover.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Aggiungere archiviazione a un cluster di failover

  • Informazioni sui requisiti per i cluster di failover

  • Informazioni sui test di convalida del cluster: Archiviazione


Aggiungere una risorsa a un servizio o un'applicazione del cluster

Per personalizzare il funzionamento di un servizio o un'applicazione del cluster, è possibile aggiungere una risorsa.

Importante
  • Questa procedura è progettata per essere utilizzata da amministratori che hanno familiarità con la configurazione di risorse cluster e gruppi di risorse in Windows Server 2003. Se non si dispone di questo livello di familiarità, non utilizzare questa procedura, ma eseguire la procedura illustrata in Configurare un servizio o un'applicazione per la disponibilità elevata che consente di utilizzare la Configurazione guidata disponibilità elevata. Quando si esegue la procedura guidata e si sceglie un ruolo o un servizio, ad esempio File server o Server di stampa, vengono create le risorse appropriate per un'istanza in cluster del ruolo o servizio.
  • Se si desidera configurare in cluster un'applicazione di server di posta o server di database, vedere la documentazione dell'applicazione per informazioni sulla modalità di installazione corretta in un ambiente cluster. Server di posta e server di database sono applicazioni complesse per le quali potrebbe essere necessario eseguire procedure che non rientrano nell'ambito di questa Guida relativa al clustering di failover.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere una risorsa a un servizio o un'applicazione del cluster

  1. Verificare che il software o la funzionalità necessario per la risorsa sia installato in tutti i nodi del cluster.

  2. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  3. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  4. Espandere Servizi e applicazioni e quindi fare clic sul servizio o l'applicazione a cui si desidera aggiungere una risorsa.

  5. Sul lato destro di Azioni fare clic su Aggiungi una risorsa.

  6. Fare clic sulla risorsa che si desidera aggiungere oppure fare clic su Altre risorse e quindi sulla risorsa che si desidera aggiungere. Se viene visualizzata una procedura guidata per la risorsa scelta, specificare le informazioni necessarie per la procedura guidata.

  7. Nel riquadro centrale fare clic con il pulsante destro del mouse sulla risorsa aggiunta e scegliere Proprietà.

  8. Se la finestra delle proprietà contiene una scheda Parametri, fare clic sulla scheda e quindi configurare i parametri necessari per la risorsa.

  9. Fare clic sulla scheda Relazioni di dipendenza e quindi configurare le dipendenze per la risorsa. Fare clic su OK.

  10. Nell'albero della console selezionare il servizio o l'applicazione, non la singola risorsa, e quindi sul lato destro di Azioni fare clic su Visualizza rapporto dipendenze.

  11. Esaminare le dipendenze tra le risorse. Per molte risorse, sarà necessario configurare le dipendenze corrette prima che sia possibile connettere la risorsa. Se è necessario modificare le dipendenze, chiudere il rapporto sulle dipendenze e quindi ripetere il passaggio 9.

  12. Fare clic con il pulsante destro del mouse sulla risorsa appena aggiunta e quindi scegliere Connetti risorsa.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Modificare le impostazioni di failover per un servizio o un'applicazione in cluster

È possibile modificare le impostazioni di failover, di failback o del proprietario preferito per controllare il modo in cui il cluster risponde quando si verifica un errore a un determinato servizio o applicazione. Per esempi che illustrano l'utilizzo delle impostazioni, vedere Modificare le impostazioni per un servizio o un'applicazione in cluster.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per modificare le impostazioni di failover per un servizio o un'applicazione in cluster

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Servizi e applicazioni.

  4. Fare clic con il pulsante destro del mouse sul servizio o sull'applicazione per cui si desidera modificare le impostazioni di failover e quindi scegliere Proprietà.

  5. Per configurare il failback, nella scheda Generale modificare le impostazioni per i proprietari preferiti, quindi fare clic sulla scheda Failover e scegliere le opzioni disponibili in Failback.

    È necessario configurare un proprietario preferito se si desidera che venga eseguito il failback, ovvero se si desidera che venga eseguito il failback di un determinato servizio o applicazione in un particolare nodo quando possibile.

  6. Per configurare il numero di tentativi di riavvio o failover del servizio o dell'applicazione eseguiti in un determinato periodo di tempo dal Servizio cluster, fare clic sulla scheda Failover e specificare i valori in Failover.

    Per ulteriori informazioni sulle impostazioni di failover per un servizio o un'applicazione in cluster, vedere Modificare le impostazioni per un servizio o un'applicazione in cluster.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Configurare un servizio o un'applicazione per la disponibilità elevata

  • Modificare le impostazioni per un servizio o un'applicazione in cluster


Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster

Quando si modificano le impostazioni di una macchina virtuale del cluster, è consigliabile utilizzare Gestione cluster di failover anziché la console di gestione di Hyper-V, come descritto in questa procedura.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Servizi e applicazioni.

  4. Nell'albero della console fare clic sulla macchina virtuale di cui si desidera modificare le impostazioni.

  5. Nel riquadro centrale fare clic con il pulsante destro del mouse sulla risorsa macchina virtuale e quindi scegliere Impostazioni. Se la voce di menu Impostazioni non è visualizzata, comprimere la risorsa macchina virtuale e quindi fare clic con il pulsante destro del mouse su di essa.

    Verrà visualizzata l'interfaccia Impostazioni. Si tratta della stessa interfaccia visualizzata nella console di gestione di Hyper-V.

  6. Configurare le impostazioni per la macchina virtuale.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Se si utilizza la console di gestione di Hyper-V anziché Gestione cluster di failover per configurare le impostazioni per una macchina virtuale, attenersi alla procedura descritta in Aggiornare la configurazione di una macchina virtuale.

Ulteriori riferimenti

  • Aggiornare la configurazione di una macchina virtuale

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster


Creare una cartella condivisa in un file server del cluster

Prima di eseguire questa procedura, rivedere i passaggi illustrati in Elenco di controllo: Creare un file server del cluster. In questa procedura viene descritto un passaggio illustrato in tale elenco di controllo.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare una cartella condivisa in un file server del cluster

  1. Nel Pannello di controllo aprire Windows Firewall, fare clic su Consenti programma o funzionalità con Windows Firewall e quindi su Modifica impostazioni, selezionare un'eccezione per Gestione volumi remota e quindi fare clic su OK.

  2. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  3. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  4. Espandere Servizi e applicazioni e quindi selezionare il file server cluster.

  5. In Azioni fare clic su Aggiungi cartella condivisa.

    Verrà visualizzata la Creazione guidata cartella condivisa. Questa procedura guidata è uguale a quella che viene normalmente utilizzata per condividere una cartella in un server non cluster.

  6. Per specificare le impostazioni per la cartella condivisa, inclusi il percorso, il nome, le impostazioni per la modalità offline e le autorizzazioni, seguire le istruzioni della procedura guidata.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Quando si connette o disconnette la risorsa File server associata in un file server del cluster, vengono connesse o disconnesse contemporaneamente tutte le cartelle condivise in tale risorsa. Non è possibile modificare lo stato online o offline di una cartella condivisa senza che ciò influisca su tutte le cartelle condivise.

Ulteriori riferimenti

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Elenco di controllo: Creare un file server del cluster

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Configurare le impostazioni di stampa per un server di stampa del cluster

Prima di eseguire questa procedura, rivedere i passaggi illustrati in Elenco di controllo: Creare un server di stampa del cluster. In questa procedura viene descritto l'ultimo passaggio illustrato in tale elenco di controllo.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni di stampa per un server di stampa del cluster

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Servizi e applicazioni.

  4. Fare clic con il pulsante destro del mouse sul server di stampa del cluster per il quale si desidera configurare le impostazioni di stampa e quindi scegliere Gestione stampanti.

    Nell'albero della console verrà visualizzata un'istanza dell'interfaccia di Gestione cluster di failover con Gestione stampa.

  5. In Gestione stampa fare clic su Server di stampa e individuare il server di stampa del cluster che si desidera configurare.

    Eseguire sempre le attività di gestione sul server di stampa del cluster. Non gestire i singoli nodi del cluster come server di stampa.

  6. Fare clic con il pulsante destro del mouse sul server di stampa del cluster e quindi scegliere Aggiungi stampante. Seguire le istruzioni della procedura guidata per aggiungere una stampante.

    Questa procedura guidata è la stessa che viene normalmente utilizzata per aggiungere una stampante in un server non cluster.

  7. Dopo aver completato la configurazione delle impostazioni per il server di stampa del cluster, per chiudere l'istanza dell'interfaccia di Gestione cluster di failover con Gestione stampa, nell'albero della console fare clic su File e quindi su Esci.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Il software del cluster di failover esegue automaticamente la replica dei file importanti, ad esempio i driver di stampa, in ogni nodo del cluster. Il processo di replica viene eseguito utilizzando una risorsa disco dell'archiviazione del cluster come posizione per l'archiviazione dei file. Tale risorsa disco viene configurata automaticamente dalla Configurazione guidata disponibilità elevata come parte del nuovo server di stampa del cluster. Non eliminare la risorsa disco che fa parte del server di stampa del cluster.

Ulteriori riferimenti

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Elenco di controllo: Creare un server di stampa del cluster

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Migrare le impostazioni a un cluster di failover che esegue Windows Server 2008 R2

Negli argomenti seguenti vengono fornite informazioni sulla migrazione delle impostazioni in un cluster di failover che esegue Windows Server 2008 R2:

  • Informazioni sul processo di migrazione a un cluster che esegue Windows Server 2008 R2

  • Migrare gruppi di risorse a un cluster di failover che esegue Windows Server 2008 R2

Ulteriori riferimenti

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni sul processo di migrazione a un cluster che esegue Windows Server 2008 R2

È possibile utilizzare una procedura guidata per eseguire la migrazione delle impostazioni di numerosi tipi di risorse in un cluster che esegue Windows Server 2008 R2. Nella terza pagina della procedura guidata è possibile visualizzare un rapporto pre-migrazione in cui viene indicato se una risorsa è idonea per la migrazione e in cui vengono illustrate le operazioni aggiuntive da eseguire dopo il completamento della procedura guidata. Al termine della procedura guidata, è disponibile un rapporto in cui vengono descritte le operazioni aggiuntive necessarie per completare la migrazione. La procedura guidata supporta la migrazione delle impostazioni in un cluster che esegue Windows Server 2008 R2 da un cluster che esegue uno dei sistemi operativi seguenti:

  • Windows Server 2003

  • Windows Server 2008

  • Windows Server 2008 R2

Per ulteriori informazioni sulla procedura specifica per l'esecuzione della Migrazione guidata cluster, vedere Migrare gruppi di risorse a un cluster di failover che esegue Windows Server 2008 R2.

Attenzione

Se vengono utilizzati nuovi archivi, è necessario gestire la copia o lo spostamento di dati o cartelle nei volumi condivisi durante una migrazione. La procedura guidata per la migrazione di gruppi di risorse cluster non consente di copiare i dati da una posizione in un'altra.

In questo argomento sono incluse le sottosezioni seguenti:

  • Identificare i servizi o le applicazioni del cluster che è possibile migrare da un cluster che esegue Windows Server 2003

  • Scenario di migrazione A: Migrare un cluster a più nodi in un cluster con nuovo hardware

    Fare riferimento a questo scenario se è possibile creare un cluster a più nodi che esegue Windows Server 2008 R2 e quindi migrare le impostazioni nel cluster da un cluster a più nodi che esegue Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2. Con questo scenario, per il nuovo cluster è possibile utilizzare hardware e server fisici diversi rispetto a quelli utilizzati per il cluster precedente.

  • Scenario di migrazione B: Migrare un cluster a due nodi in un cluster con lo stesso hardware

    Fare riferimento a questo scenario per una migrazione sul posto di un cluster a due nodi che esegue Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2 a un cluster a due nodi che esegue Windows Server 2008 R2. Con questo scenario, per un cluster a due nodi è possibile utilizzare hardware e server fisici uguali a quelli utilizzati per il cluster precedente. Questo scenario non prevede l'aggiornamento in sequenza, ovvero un aggiornamento in cui due nodi dello stesso cluster eseguono temporaneamente sistemi operativi diversi. Non è possibile eseguire aggiornamenti in sequenza a un cluster di failover che esegue Windows Server 2008 R2.

    Si noti che l'hardware del nuovo cluster deve soddisfare i requisiti per un cluster che esegue Windows Server 2008 R2. Per ulteriori informazioni, vedere Informazioni sui requisiti per i cluster di failover.

Identificare i servizi o le applicazioni del cluster che è possibile migrare da un cluster che esegue Windows Server 2008 R2

In questa sezione vengono elencati i servizi o le applicazioni del cluster (risorse cluster) che è possibile migrare in un cluster che esegue Windows Server 2008 R2.

Importante

Non è possibile utilizzare la Migrazione guidata cluster per migrare le impostazioni di server virtualizzati, server di posta, server database e server di stampa o eventuali altre risorse non elencate nelle sottosezioni seguenti. Per alcune di queste applicazioni sono disponibili altri strumenti di migrazione. Per ulteriori informazioni sulla migrazione di applicazioni di server di posta, vedere http://go.microsoft.com/fwlink/?LinkId=91732 e http://go.microsoft.com/fwlink/?LinkId=91733.

Risorse per le quali la Migrazione guidata cluster consente di eseguire l'intera procedura di migrazione o parte di essa

Dopo aver utilizzato la Migrazione guidata cluster per migrare le impostazioni delle risorse descritte di seguito in un cluster di failover che esegue Windows Server 2008 R2, per connettere le risorse sarà necessario eseguire poche operazioni aggiuntive o nessuna operazione.

Attenzione

Se vengono utilizzati nuovi archivi, è necessario gestire la copia o lo spostamento di dati o cartelle durante una migrazione dai volumi condivisi. La procedura guidata per la migrazione delle impostazioni di gruppi di risorse cluster non consente di copiare i dati da una posizione in un'altra.

  • Risorse file server o condivisione file: è possibile migrare le impostazioni per un file server del cluster (oppure da un cluster Windows Server 2003, un gruppo di risorse condivisione file) e per le risorse disco fisico, indirizzo IP e nome di rete associate.

    Quando si esegue la migrazione da un cluster che esegue Windows Server 2003, tramite la Migrazione guidata cluster tutti i gruppi di risorse condivisione file vengono spostati automaticamente in un singolo file server del cluster, che contiene più risorse condivisione file, in Windows Server 2008 R2. L'aspetto di alcune risorse potrebbe pertanto essere diverso dopo la migrazione. Nella tabella seguente vengono forniti i dettagli:

    Risorsa così come appare in un cluster di server che esegue Windows Server 2003 Risorsa migrata così come appare in un cluster di failover che esegue Windows Server 2008 R2

    Singola risorsa Condivisione file

    Singola risorsa File server

    Più risorse Condivisione file

    Più risorse condivisione file in un singolo file server del cluster (gruppo di risorse)

    Risorsa Condivisione file con radice DFS

    Risorsa file system distribuito e risorsa condivisione file (entrambe in un server DFS del cluster)

  • Disco fisico: è possibile migrare le impostazioni per le risorse Disco fisico diverse dalla risorsa quorum.

    Non è necessario migrare la risorsa quorum. Quando si esegue la Creazione guidata cluster, la configurazione quorum che offrirà la disponibilità più elevata per il nuovo cluster di failover verrà scelta automaticamente dal software di cluster. È possibile modificare le impostazioni della configurazione quorum in base alle necessità dell'ambiente specifico. Per informazioni sulla modifica delle impostazioni, incluse quelle relative alla configurazione quorum, per un cluster di failover, vedere Modificare le impostazioni per un cluster di failover.

  • Indirizzo IP: è possibile migrare le impostazioni delle risorse Indirizzo IP diverse dall'indirizzo IP del cluster. Gli indirizzi IP sono idonei per la migrazione solo se sono compresi nella stessa subnet.

  • Nome di rete: è possibile migrare le impostazioni delle risorse Nome di rete diverse dal nome del cluster. Se è abilitata l'autenticazione Kerberos per la risorsa Nome di rete, verrà richiesta la password dell'account del Servizio cluster utilizzato dal cluster precedente.

Risorse per le quali la Migrazione guidata cluster non consente di eseguire l'intera procedura di migrazione

Dopo aver utilizzato la Migrazione guidata cluster per migrare le impostazioni dei gruppi di risorse seguenti in un cluster di failover che esegue Windows Server 2008 R2, prima di poter connettere le risorse potrebbe essere necessario eseguire alcune operazioni aggiuntive, a seconda della configurazione originale. Nel rapporto di migrazione vengono indicati gli eventuali passaggi necessari per i gruppi di risorse seguenti:

  • Servizio DHCP

  • Spazio dei nomi del file system distribuito (DFS-N)

  • Distributed Transaction Coordinator (DTC)

  • Internet Storage Name Service (iSNS)

  • Accodamento messaggi

  • Servizio NFS

  • Servizio WINS

  • Applicazione generica

  • Script generico

  • Servizio generico

Questa procedura guidata genera un rapporto in cui vengono descritte le operazioni aggiuntive che è necessario eseguire. Tali operazioni includono in genere:

  • Installazione di funzionalità o ruoli server necessari in tutti i nodi del nuovo cluster.

  • Copia o installazione di applicazioni, servizi o script associati in tutti i nodi del nuovo cluster.

  • Verifica che i dati siano stati copiati.

  • Configurazione di indirizzi IP statici se il nuovo cluster si trova in una subnet diversa.

  • Aggiornamento dei percorsi delle unità per le applicazioni se il nuovo cluster utilizza una lettera di volume diversa.

Le impostazioni delle risorse vengono migrate, così come le impostazioni delle risorse Indirizzo IP e Nome di rete incluse nel gruppo di risorse. Se il gruppo di risorse include una risorsa Disco fisico, verranno migrate anche le impostazioni di tale risorsa.

Scenario di migrazione A: Migrare un cluster a più nodi in un cluster con nuovo hardware

Per questo scenario di migrazione, sono previste tre fasi:

  1. Installare due o più nuovi server, eseguire la convalida e creare un nuovo cluster. Per questa fase, mentre il cluster precedente è ancora in esecuzione, installare Windows Server 2008 R2 e la funzionalità Clustering di failover in almeno due server. Creare le reti che verranno utilizzate dai server e connettere gli archivi. Eseguire quindi tutti i test di convalida del cluster per verificare che l'hardware e le relative impostazioni siano in grado di supportare un cluster di failover. Creare infine il nuovo cluster. A questo punto, si disporrà di due cluster.

    Informazioni aggiuntive sulla connessione degli archivi: se il nuovo cluster è connesso agli archivi precedenti, rendere accessibili ai server almeno due numeri di unità logica (LUN) o dischi e non rendere accessibili questi LUN o dischi a eventuali altri server. Questi LUN o dischi sono necessari per la convalida e per il witness di disco, la cui funzione è simile, ma non identica, a quella della risorsa quorum in Windows Server 2003. Se il nuovo cluster è connesso a nuovi archivi, rendere disponibili per il cluster il numero di dischi o LUN che si ritiene sia necessario

    Le operazioni che consentono di creare un cluster sono elencate in Elenco di controllo: creare un cluster di failover.

  2. Migrare le impostazioni nel nuovo cluster e determinare il modo in cui gli eventuali dati esistenti verranno resi disponibili per il nuovo cluster. Al termine della Migrazione guidata cluster, tutte le risorse migrate verranno disconnesse. In questa fase lasciarle disconnesse. Il nuovo cluster rimarrà connesso e continuerà a soddisfare le richieste dei client. Se il nuovo cluster riutilizzerà gli archivi precedenti, pianificare il modo in cui questi verranno resi disponibili per il cluster, ma lasciare il cluster precedente connesso agli archivi fino a quando non si è pronti per eseguire la transizione. Se il nuovo cluster utilizzerà nuovi archivi, copiare le cartelle e i dati appropriati negli archivi.

  3. Eseguire la transizione dal cluster precedente al nuovo. Il primo passaggio della transizione consiste nel disconnettere le applicazioni e i servizi del cluster precedente. Se il nuovo cluster utilizza gli archivi precedenti, seguire il piano predisposto per rendere i LUN o i dischi inaccessibili al cluster precedente e accessibili al nuovo cluster. Indipendentemente dagli archivi utilizzati dal nuovo cluster, connettere quindi i servizi e le applicazioni nel nuovo cluster.

Scenario di migrazione B: Migrare un cluster a due nodi in un cluster con lo stesso hardware

Per questo scenario di migrazione, sono previste quattro fasi:

  1. Installare un nuovo server ed eseguire i test di convalida selezionati. Per questa fase, consentire l'esecuzione di Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2 e del Servizio cluster in un server esistente mentre si avvia il processo di migrazione. Rimuovere l'altro server dal cluster precedente e quindi installare Windows Server 2008 R2 e la funzionalità Clustering di failover nel server stesso. In tale server eseguire tutti i test previsti dalla Convalida guidata configurazione. La procedura guidata riconoscerà che si tratta di un singolo nodo senza archivio ed eseguirà un numero di test limitato. I test per i quali sono necessari due nodi, ad esempio quelli che eseguono il confronto dei nodi o che simulano il failover, non verranno eseguiti.

    Si noti che i test eseguiti in questa fase non forniscono informazioni complete sul funzionamento degli archivi in un cluster che esegue Windows Server 2008 R2. Come descritto più avanti in questa sezione, sarà necessario eseguire la Convalida guidata configurazione con tutti i test disponibili.

  2. Inserire il nuovo server in un cluster a nodo singolo e migrarvi le impostazioni. Creare un nuovo cluster a nodo singolo e utilizzare la Migrazione guidata per migrarvi le impostazioni, mantenendo comunque disconnesse le risorse nel nuovo cluster.

  3. Connettere il nuovo cluster e rendere disponibili i dati esistenti. Disconnettere i servizi e le applicazioni nel cluster precedente. Se il nuovo cluster utilizzerà gli archivi precedenti, lasciare i dati negli archivi precedenti e rendere accessibili i dischi o i LUN al nuovo cluster. Se il nuovo cluster utilizzerà nuovi archivi, copiare le cartelle e i dati nei dischi o LUN appropriati nel nuovo archivio e verificare che tali LUN o dischi siano visibili per il nuovo cluster e non visibili per qualsiasi altro server. Verificare che le impostazioni per i servizi o le applicazioni di cui è stata eseguita la migrazione siano corrette. Connettere i servizi e le applicazioni nel nuovo cluster e verificare che le risorse funzionino e siano in grado di accedere agli archivi.

  4. Inserire il secondo nodo nel nuovo cluster. Eliminare il cluster precedente e nel server installare Windows Server 2008 R2 e la funzionalità Clustering di failover. Connettere il server alle reti e agli archivi utilizzati dal nuovo cluster. Se i dischi o i LUN appropriati non sono già accessibili a entrambi i server, renderli accessibili. Eseguire la Convalida guidata configurazione specificando entrambi i server e verificare che vengano superati tutti i test. Aggiungere infine il secondo server al nuovo cluster.

Ulteriori riferimenti

  • Migrare le impostazioni a un cluster di failover che esegue Windows Server 2008 R2

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione, incluse le informazioni sulla migrazione, di cluster di failover, vedere http://go.microsoft.com/fwlink/?LinkId=137832.


Migrare gruppi di risorse a un cluster di failover che esegue Windows Server 2008 R2

È possibile utilizzare una procedura guidata per eseguire la migrazione delle impostazioni di numerosi tipi di gruppi di risorse in un cluster che esegue Windows Server 2008 R2. È possibile eseguire la migrazione di queste impostazioni da un cluster che esegue Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2. Dopo aver eseguito la migrazione delle impostazioni, tramite la procedura guidata viene inoltre creato un rapporto in cui vengono descritte le operazioni aggiuntive che potrebbero essere necessarie per completare la migrazione.

Attenzione

Se vengono utilizzati nuovi archivi, è necessario gestire tutte le operazioni di copia o spostamento di dati o cartelle nei volumi condivisi durante una migrazione. La procedura guidata per la migrazione di gruppi di risorse cluster non consente di copiare i dati da una posizione in un'altra.

Prima di avviare la procedura guidata, verificare di conoscere il nome o l'indirizzo IP del cluster o del nodo del cluster dal quale si desidera eseguire la migrazione dei gruppi di risorse.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per eseguire la migrazione di gruppi di risorse a un cluster di failover che esegue Windows Server 2008 R2

  1. Nel cluster che esegue Windows Server 2008 R2 aprire lo snap-in del cluster di failover.

  2. Se il cluster in cui si desidera migrare le impostazioni non è visualizzato, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  3. In Configura fare clic su Esegui migrazione di servizi e applicazioni.

  4. Leggere la prima pagina della Migrazione guidata cluster e quindi fare clic su Avanti.

  5. Specificare il nome o l'indirizzo IP del cluster o del nodo del cluster dal quale si desidera eseguire la migrazione dei gruppi di risorse e quindi fare clic su Avanti.

  6. Fare clic su Visualizza rapporto. Leggere il rapporto in cui viene indicato se ogni risorsa è idonea per la migrazione.

    Al termine della procedura guidata viene inoltre creato un rapporto in cui vengono descritte le operazioni aggiuntive che è necessario eseguire prima di connettere i gruppi di risorse di cui è stata eseguita la migrazione.

  7. Seguire le istruzioni della procedura guidata per completare le operazioni seguenti:

    • Scegliere il gruppo o i gruppi di risorse dei quali si desidera eseguire la migrazione delle impostazioni.

      Alcuni tipi di gruppi di risorse sono idonei per la migrazione, altri no. Per ulteriori informazioni, vedere Informazioni sul processo di migrazione a un cluster che esegue Windows Server 2008 R2.

    • Specificare se i gruppi di risorse da migrare utilizzeranno nuovi archivi o gli stessi archivi utilizzati nel cluster precedente. Se i gruppi di risorse utilizzeranno nuovi archivi, sarà possibile specificare il disco che ogni gruppo di risorse dovrà utilizzare dopo la migrazione. Si noti che se vengono utilizzati nuovi archivi, è necessario gestire tutte le operazioni di copia o spostamento di dati o cartelle, in quanto tramite la procedura guidata i dati non vengono copiati da una posizione a un'altra.

  8. Dopo aver eseguito la procedura guidata, con la pagina Riepilogo visualizzata fare clic su Visualizza rapporto. In questo rapporto sono incluse informazioni importanti sulle operazioni aggiuntive che è necessario eseguire prima di connettere i gruppi di risorse di cui è stata eseguita la migrazione.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Per informazioni sulla modifica delle impostazioni di un servizio o un'applicazione dopo la migrazione, vedere Modificare le impostazioni per un servizio o un'applicazione in cluster.

Ulteriori riferimenti

  • Informazioni sul processo di migrazione a un cluster che esegue Windows Server 2008 R2

  • Migrare le impostazioni a un cluster di failover che esegue Windows Server 2008 R2

  • Modificare le impostazioni per un servizio o un'applicazione in cluster


Modificare le impostazioni per un cluster di failover

Le impostazioni predefinite create dalle procedure guidate per il clustering di failover sono adatte alla maggior parte dei cluster. È tuttavia possibile modificare le impostazioni di un cluster, ad esempio aggiungendo risorse di archiviazione, modificando le impostazioni di rete o attivando i volumi condivisi del cluster. Negli argomenti seguenti vengono fornite informazioni sulla modifica delle impostazioni generali del cluster:

  • Informazioni sui volumi condivisi del cluster in un cluster di failover

  • Informazioni sulle configurazioni quorum in un cluster di failover

  • Aggiungere archiviazione a un cluster di failover

  • Modificare le impostazioni di rete per un cluster di failover

  • Attivare i volumi condivisi del cluster in un cluster di failover

  • Selezionare le opzioni relative al quorum per un cluster di failover

Ulteriori riferimenti

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Informazioni sui volumi condivisi del cluster in un cluster di failover

In un cluster di failover in cui vengono utilizzati i volumi condivisi del cluster, più macchine virtuali del cluster distribuite in più nodi del cluster possono accedere contemporaneamente ai file del relativo disco rigido virtuale (VHD, Virtual Hard Disk) anche se tali file si trovano in un unico disco (LUN) nell'archivio. Questo significa che il failover delle macchine virtuali del cluster può essere eseguito in modo indipendente, anche se le macchine utilizzano un unico LUN.

In un cluster di failover in cui i volumi condivisi del cluster non sono attivati, invece, un solo nodo per volta può accedere a un singolo disco (LUN) in un determinato momento. Questo significa che il failover delle macchine virtuali del cluster può essere eseguito in modo indipendente solo se ogni macchina virtuale dispone di un proprio LUN e pertanto la gestione di LUN e macchine virtuali del cluster risulta più difficoltosa.

In questo argomento sono incluse le sezioni seguenti:

  • Vantaggi dell'utilizzo dei volumi condivisi del cluster in un cluster di failover

  • Restrizioni per l'utilizzo dei volumi condivisi del cluster in un cluster di failover

Vantaggi dell'utilizzo dei volumi condivisi del cluster in un cluster di failover

I volumi condivisi del cluster offrono i vantaggi seguenti in un cluster di failover:

  • La configurazione delle macchine virtuali del cluster risulta molto più semplice di prima.

  • È possibile ridurre il numero di LUN (dischi) necessari per le macchine virtuali e non è necessario dover gestire un LUN per ogni macchina virtuale, come previsto in precedenza dalla configurazione consigliata, in cui il LUN corrisponde all'unità di failover. Numerose macchine virtuali consentono di utilizzare un unico LUN ed eseguire il failover senza comportare il failover anche delle altre macchine virtuali nello stesso LUN.

  • È possibile utilizzare in modo migliore lo spazio su disco, in quanto non è necessario inserire ogni file del disco rigido virtuale (VHD, Virtual Hard Disk) in un disco distinto con spazio aggiuntivo riservato solo per tale file VHD. Lo spazio libero di un volume condiviso del cluster può invece essere utilizzato da qualsiasi file VHD in tale volume.

  • È possibile tenere traccia in modo più semplice dei percorsi dei file VHD e di altri file utilizzati dalle macchine virtuali. È possibile specificare i nomi dei percorsi, anziché identificare i dischi tramite lettere di unità (con le limitazioni legate al numero di lettere dell'alfabeto) o tramite identificatori detti GUID (difficili da utilizzare e ricordare). Con i volumi condivisi del cluster, il percorso risulta nell'unità di sistema del nodo, nella cartella \ClusterStorage. Questo percorso è tuttavia lo stesso quando viene visualizzato da qualsiasi nodo nel cluster.

  • Se si utilizzano i volumi condivisi del cluster per creare una configurazione che supporta numerose macchine virtuali del cluster, è possibile eseguire la convalida più rapidamente di quanto sia possibile fare utilizzando una configurazione in cui sono presenti numerosi LUN per supportare numerose macchine virtuali del cluster. Con un numero minore di LUN, la convalida viene eseguita più rapidamente. È possibile eseguire la convalida tramite la Convalida guidata configurazione nello snap-in per i cluster di failover.

  • Non sono previsti requisiti hardware speciali oltre a quelli già necessari per l'archiviazione in un cluster di failover, sebbene i volumi condivisi del cluster richiedano NTFS.

  • La resilienza è maggiore in quanto il cluster può rispondere correttamente anche in caso di interruzione della connettività tra un nodo e la rete SAN o di mancato funzionamento della rete. Il cluster esegue di nuovo il routing della comunicazione dei volumi condivisi del cluster tramite una parte intatta della SAN o della rete.

Restrizioni per l'utilizzo dei volumi condivisi del cluster in un cluster di failover

Le restrizioni seguenti si applicano all'utilizzo dei volumi condivisi del cluster in un cluster di failover:
  • La funzionalità per i volumi condivisi del cluster può essere utilizzata solo con Hyper-V (un ruolo del server in Windows Server 2008 R2) e altre tecnologie specificate da Microsoft. Per informazioni sui ruoli e le funzionalità supportati per l'utilizzo con Volumi condivisi cluster, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137158.

  • Un amministratore, un utente o un'applicazione non può creare o copiare file in un volume condiviso del cluster a meno che questi non verranno utilizzati dal ruolo Hyper-V o da altre tecnologie specificate da Microsoft. Se queste istruzioni non vengono rispettate, i dati nei volumi condivisi potrebbero venire persi o danneggiati. Queste istruzioni riguardano anche i file creati o copiati nella cartella \ClusterStorage, o nelle relative sottocartelle, nei nodi.

  • Per consentire il corretto funzionamento di Hyper-V, l'unità (%SystemDrive%) del sistema operativo di ogni server del cluster deve essere impostata in modo da essere avviata dalla stessa lettera di unità di tutti gli altri server nel cluster. In altre parole, se un server viene avviato dalla lettera di unità C, tutti i server del cluster devono essere avviati dalla lettera di unità C.

  • Il file system NTFS è necessario per tutti i volumi attivati come volumi condivisi del cluster.

Ulteriori riferimenti

  • Modificare le impostazioni di rete per un cluster di failover

  • Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster


Informazioni sulle configurazioni quorum in un cluster di failover

In questo argomento sono incluse le sezioni seguenti:

  • In che modo la configurazione quorum ha effetto sul cluster

  • Scelte relative alla configurazione quorum

  • Illustrazioni di configurazioni quorum

  • Perché è necessario il quorum

Per informazioni sulla configurazione delle opzioni relative al quorum, vedere Selezionare le opzioni relative al quorum per un cluster di failover.

In che modo la configurazione quorum ha effetto sul cluster

La configurazione quorum in un cluster di failover consente di determinare il numero di errori che il cluster è in grado di supportare. Se si verifica un errore aggiuntivo, l'esecuzione del cluster dovrà essere arrestata. Gli errori rilevanti in questo contesto sono quelli che si verificano nei nodi oppure, in alcuni casi, in un witness di disco, che contiene una copia della configurazione del cluster, o in un witness di condivisione file. È fondamentale che l'esecuzione del cluster venga arrestata quando si verificano troppi errori o quando si verifica un problema di comunicazione tra i nodi del cluster. Per una descrizione più dettagliata, vedere Perché è necessario il quorum più avanti in questo argomento.

Importante

Nella maggior parte delle situazioni, è possibile utilizzare la configurazione quorum identificata come appropriata per il cluster dal software di cluster. Modificare la configurazione quorum solo se la modifica è appropriata per il cluster.

Si noti che la funzionalità completa di un cluster non dipende solo dal quorum, ma dalla capacità di ogni nodo di supportare i servizi e le applicazioni di cui viene eseguito il failover in tale nodo. Un cluster con cinque nodi potrebbe ad esempio raggiungere comunque il quorum in caso di errore in due nodi, ma il livello di servizio offerto da ogni restante nodo del cluster dipenderebbe dalla capacità di tale nodo di supportare i servizi e le applicazioni di cui viene eseguito il failover.

Scelte relative alla configurazione quorum

È possibile scegliere tra le quattro possibili configurazioni quorum seguenti:

  • Maggioranza dei nodi (scelta consigliata per i cluster con un numero dispari di nodi)

    Consente il supporto in caso di errore nella metà dei nodi (valore arrotondato per eccesso) meno uno. Ad esempio, un cluster costituito da sette nodi può supportare errori in tre nodi.

  • Maggioranza dei nodi e dei dischi (scelta consigliata per i cluster con un numero pari di nodi)

    Consente il supporto in caso di errore nella metà dei nodi (valore arrotondato per eccesso) se il witness di disco rimane online. Un cluster costituito da sei nodi in cui il witness di disco è online può ad esempio supportare errori in tre nodi.

    Consente il supporto in caso di errore nella metà dei nodi (valore arrotondato per eccesso) meno uno se si verifica un errore nel witness di disco o il witness di disco viene disconnesso. Un cluster costituito da sei nodi in cui si è verificato un errore nel witness di disco può ad esempio supportare errori in due (3-1=2) nodi.

  • Maggioranza dei nodi e delle condivisioni file (per cluster con configurazioni speciali)

    Il funzionamento è simile a quello dell'opzione Maggioranza dei nodi e dei dischi, ma anziché un witness di disco, il cluster utilizza un witness di condivisione file.

    Si noti che se si utilizza l'opzione Maggioranza dei nodi e delle condivisioni file, prima di poter avviare il cluster sarà necessario che almeno uno dei nodi del cluster disponibili contenga una copia corrente della configurazione del cluster. In caso contrario, sarà necessario forzare l'avvio del cluster tramite un nodo specifico. Per ulteriori informazioni, vedere la sezione "Ulteriori considerazioni" in Avviare o arrestare il Servizio cluster in un nodo di cluster.

  • Nessuna maggioranza: solo disco (scelta non consigliata)

    Consente il supporto in caso di errore in tutti i nodi tranne uno, se il disco è online. Questa configurazione non è tuttavia consigliata, poiché il disco potrebbe rappresentare un singolo punto di errore.

Illustrazioni di configurazioni quorum

Nelle illustrazioni seguenti viene mostrato il funzionamento delle configurazioni quorum. Una quarta configurazione viene descritta mediante testo, poiché è simile alla configurazione Maggioranza dei nodi e dei dischi mostrata nell'illustrazione.

Nota

In tutte le configurazioni diverse da Nessuna maggioranza: solo disco descritte nelle illustrazioni, osservare se una maggioranza degli elementi rilevanti sono in comunicazione, indipendentemente dal loro numero. In caso affermativo, il cluster continuerà a funzionare. In caso negativo, il funzionamento del cluster verrà arrestato.

Cluster con configurazione del quorum della maggioranza dei nodi

Come mostrato nell'illustrazione precedente, in un cluster con la configurazione Maggioranza dei nodi, per il calcolo della maggioranza vengono considerati solo i nodi.

Cluster con quorum della maggioranza dei dischi e dei nodi

Come mostrato nell'illustrazione precedente, in un cluster con la configurazione Maggioranza dei nodi e dei dischi, per il calcolo della maggioranza vengono considerati i nodi e il witness di disco.

Configurazione quorum Maggioranza dei nodi e delle condivisioni file

In un cluster con la configurazione Maggioranza dei nodi e delle condivisioni file, per il calcolo della maggioranza vengono considerati i nodi e il witness di condivisione file. Questa configurazione è simile alla configurazione quorum Maggioranza dei nodi e dei dischi mostrata nell'illustrazione precedente, tranne per il fatto che il cluster utilizza una condivisione file witness alla quale possono accedere tutti i nodi del cluster anziché un disco nell'archiviazione cluster.

Cluster con configurazione del solo quorum disco

In un cluster con la configurazione Nessuna maggioranza (solo disco), il numero dei nodi non influenza la modalità di calcolo del quorum. Il disco rappresenta il quorum. Se la comunicazione con il disco si interrompe, il cluster diventerà tuttavia non disponibile.

Perché è necessario il quorum

I problemi che si verificano sulla rete possono interferire con la comunicazione tra i nodi del cluster. Un piccolo insieme di nodi potrebbe essere in grado di comunicare attraverso la parte funzionante di una rete, ma non essere in grado di comunicare con un insieme di nodi diverso in un'altra parte della rete, causando in tal modo gravi problemi. In questa situazione di suddivisione, è necessario che venga arrestata l'esecuzione come cluster di almeno un insieme di nodi.

Per evitare che si verifichino i problemi causati da una suddivisione del cluster, il software di cluster richiede che un insieme di nodi in esecuzione come cluster utilizzi un algoritmo di voto per determinare se, in un determinato momento, tale insieme raggiunge il quorum. Poiché un determinato cluster dispone di un insieme di nodi specifico e di una configurazione quorum specifica, il cluster determinerà la quantità di voti che costituisce la maggioranza, ovvero il quorum. Se il numero è inferiore alla maggioranza, l'esecuzione del cluster verrà interrotta. I nodi rimarranno comunque in ascolto degli altri nodi, nel caso in cui un altro nodo risulti di nuovo visibile sulla rete, ma i nodi non inizieranno a funzionare come cluster fino a quando non verrà di nuovo raggiunto il quorum.

Ad esempio, in un cluster con cinque nodi che utilizza un quorum di maggioranza dei nodi, valutare che cosa succede se i nodi 1, 2 e 3 possono comunicare tra loro ma non con i nodi 4 e 5. I nodi 1, 2 e 3 costituiscono la maggioranza e continuano ad essere eseguiti come cluster. I nodi 4 e 5, essendo minoranza, smettono di essere eseguiti come cluster. Se il nodo 3 perde la comunicazione con gli altri nodi, tutti i nodi smetteranno di essere eseguiti come cluster. Tutti i nodi funzionanti continueranno tuttavia a rimanere in ascolto della comunicazione, in modo che quando il funzionamento della rete verrà ripristinato, il cluster potrà essere ricostituito ed eseguito.

Ulteriori riferimenti

  • Modificare le impostazioni per un cluster di failover

  • Selezionare le opzioni relative al quorum per un cluster di failover

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.


Aggiungere archiviazione a un cluster di failover

È possibile aggiungere archiviazione a un cluster di failover dopo aver esposto tale archiviazione a tutti i nodi del cluster mediante la modifica del mascheramento LUN o della suddivisione in zone. Non sarà necessario aggiungere l'archiviazione al cluster se questa è già elencata per il cluster in Archiviazione nello snap-in Gestione cluster di failover.

Se si sta aggiungendo archiviazione solo a un particolare servizio o applicazione del cluster anziché un'archiviazione completamente nuova al cluster di failover nel suo insieme, vedere Aggiungere archiviazione per un servizio o un'applicazione del cluster.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere archiviazione a un cluster di failover

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Fare clic con il pulsante destro del mouse su Archiviazione e quindi scegliere Aggiungi un disco.

  4. Selezionare il disco o i dischi che si desidera aggiungere.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Dopo aver scelto Aggiungi un disco, se non viene visualizzato il disco previsto, verificare quanto segue:

    • Elenco dei dischi visualizzati quando si fa clic su Archiviazione nello snap-in Gestione cluster di failover. Se il disco è già incluso in tale elenco, non sarà necessario aggiungerlo al cluster.

    • Configurazione delle interfacce di archiviazione, incluse quelle che vengono eseguite nei nodi del cluster. Prima di poterlo aggiungere all'insieme di archivi del cluster, è necessario che il disco sia disponibile per tutti i nodi del cluster.

    • Dischi visualizzati in Gestione disco (verificare ogni nodo del cluster).

      Se il disco che si desidera aggiungere non viene visualizzato in Gestione disco in qualsiasi nodo, è possibile che esista un problema con la configurazione di archiviazione che impedisce al sistema operativo di riconoscere o caricare il disco. Si noti che i dischi attualmente utilizzati dal cluster verranno visualizzati in Gestione disco in un solo nodo, ovvero nel nodo attualmente proprietario del disco.

      Se il disco che si desidera aggiungere viene visualizzato in Gestione disco ma non dopo aver fatto clic su Aggiungi un disco, verificare che il disco sia configurato come disco di base anziché come disco dinamico. In un cluster di failover possono essere utilizzati solo dischi di base.

      Per aprire Gestione disco, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Gestione computer e quindi fare clic su Gestione disco. (Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.)

Ulteriori riferimenti

  • Modificare le impostazioni per un cluster di failover

  • Aggiungere archiviazione per un servizio o un'applicazione del cluster


Modificare le impostazioni di rete per un cluster di failover

Per ogni rete connessa fisicamente ai server (nodi) in un cluster di failover, è possibile specificare se la rete verrà utilizzata dal cluster e, in tal caso, se verrà utilizzata solo dai nodi o anche dai client. Si noti che in questo contesto il termine client si riferisce non solo ai computer client che accedono ai servizi o alle applicazioni del cluster, ma anche ai computer remoti che vengono utilizzati per amministrare il cluster.

Se si utilizza una rete per l'archiviazione iSCSI, non utilizzarla per la comunicazione di rete nel cluster.

Per informazioni generali sui requisiti di rete per un cluster di failover, vedere Informazioni sui requisiti per i cluster di failover.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per modificare le impostazioni di rete per un cluster di failover

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Reti.

  4. Fare clic con il pulsante destro del mouse sulla rete della quale si desidera modificare le impostazioni e quindi scegliere Proprietà.

  5. Se necessario, modificare il nome della rete.

  6. Selezionare una delle opzioni seguenti:

    • Consenti comunicazioni di rete del cluster su questa rete

      Se si seleziona questa opzione e si desidera che la rete venga utilizzata solo dai nodi e non dai client, deselezionare Consenti ai client di connettersi tramite questa rete. In caso contrario, verificare che sia selezionata.

    • Non consentire comunicazioni di rete del cluster su questa rete

      Selezionare questa opzione se si utilizza una rete solo per l'archiviazione iSCSI, per la comunicazione con i dispositivi di archiviazione o solo per backup. Questi sono i motivi più comuni per cui si seleziona questa opzione.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Gli indirizzi IP e i nomi di rete associati utilizzati per il cluster oppure per i servizi o le applicazioni del cluster sono detti punti di accesso. Per una breve descrizione dei punti di accesso, vedere Informazioni sui punti di accesso (nomi e indirizzi IP) in un cluster di failover.

Ulteriori riferimenti

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Informazioni sui requisiti per i cluster di failover

  • Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster


Attivare i volumi condivisi del cluster in un cluster di failover

È possibile attivare i volumi condivisi del cluster per un cluster di failover utilizzando lo snap-in Gestione cluster di failover. Attivando i volumi condivisi del cluster per un cluster di failover, viene consentito l'utilizzo dei volumi condivisi per tutti i nodi del cluster.

Importante

La funzionalità per i volumi condivisi del cluster presenta restrizioni specifiche che è necessario rispettare. Per un elenco di tutti i vantaggi e le restrizioni, vedere Informazioni sui volumi condivisi del cluster in un cluster di failover.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare i volumi condivisi del cluster in un cluster di failover

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. In Configura, nel riquadro centrale, fare clic su Abilita volumi condivisi cluster.

  3. Nella finestra di dialogo selezionare la casella di controllo.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • È possibile attivare i volumi condivisi del cluster una sola volta per ogni cluster.

Ulteriori riferimenti

  • Modificare le impostazioni per un cluster di failover

  • Informazioni sui volumi condivisi del cluster in un cluster di failover


Selezionare le opzioni relative al quorum per un cluster di failover

Se si dispone di particolare requisiti o si apportano modifiche al cluster, è possibile che si desideri modificare le opzioni relative al quorum per il cluster.

Importante

Nella maggior parte dei casi, è possibile utilizzare la configurazione quorum identificata come appropriata per il cluster dal software di cluster. Modificare la configurazione quorum solo se la modifica è appropriata per il cluster.

Per importanti informazioni concettuali sulle configurazioni quorum, vedere Informazioni sulle configurazioni quorum in un cluster di failover.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per selezionare le opzioni relative al quorum per un cluster

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Con il cluster selezionato, nel riquadro Azioni fare clic su Altre azioni e quindi su Configura impostazioni quorum del cluster.

  3. Per selezionare la configurazione quorum per il cluster, seguire le istruzioni della procedura guidata. Se si sceglie una configurazione che include un witness di disco o di condivisione file, seguire le istruzioni per specificare il witness.

  4. Quando viene visualizzata la pagina Riepilogo al termine dell'esecuzione della procedura guidata, fare clic su Visualizza rapporto se si desidera visualizzare un rapporto delle attività eseguite dalla procedura guidata.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Modificare le impostazioni per un cluster di failover

  • Informazioni sulle configurazioni quorum in un cluster di failover


Gestire un cluster di failover

Negli argomenti seguenti sono incluse informazioni sulla gestione e la risoluzione dei problemi di un cluster di failover.

  • Informazioni sul backup e sul ripristino per un cluster di failover

  • Connettere o disconnettere un servizio o un'applicazione del cluster

  • Eseguire operazioni Live Migration, di migrazione rapida o di spostamento di una macchina virtuale da un nodo a un altro

  • Aggiornare la configurazione di una macchina virtuale

  • Sospendere o riprendere un nodo in un cluster di failover

  • Eseguire uno strumento di manutenzione del disco quale Chkdsk su un disco di tipo cluster

  • Avviare o arrestare il Servizio cluster in un nodo di cluster

  • Utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover

  • Visualizzare eventi e registri per un cluster di failover

  • Visualizzare i rapporti delle azioni eseguite dalle procedure guidate per cluster di failover

Ulteriori riferimenti

  • Panoramica dei cluster di failover

  • Per informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Informazioni sul backup e sul ripristino per un cluster di failover

In questo argomento vengono illustrate le linee guida di base per il backup e il ripristino di un cluster di failover. Per ulteriori informazioni sul backup e il ripristino di un cluster di failover, vedere http://go.microsoft.com/fwlink/?LinkId=92360.

Backup di un cluster di failover

Quando si esegue il backup di un cluster di failover, è possibile eseguirlo della configurazione del cluster, dei dati presenti sui dischi del cluster o di entrambi.

Backup della configurazione del cluster

Quando si esegue il backup della configurazione del cluster, considerare quanto segue:

  • Per la riuscita del backup in un cluster di failover, è necessario che il cluster sia in esecuzione e che disponga del quorum. In altre parole, è necessario che un numero sufficiente di nodi sia in esecuzione e che tali nodi comunichino, mediante un witness di disco o di condivisione file a seconda della configurazione quorum, che il cluster ha raggiunto il quorum.

    Per ulteriori informazioni sul quorum in un cluster di failover, vedere Informazioni sulle configurazioni quorum in un cluster di failover.

  • Prima di eseguire un cluster nell'ambiente di produzione, verificare il processo di backup e ripristino.

  • Se si sceglie di utilizzare la funzionalità Windows Server Backup inclusa in Windows Server 2008 R2, è innanzitutto necessario aggiungerla utilizzando la finestra Attività di configurazione iniziale oppure l'Aggiunta guidata funzionalità in Server Manager.

  • Quando si esegue un backup utilizzando Windows Server Backup o un altro software di backup, scegliere le opzioni che consentiranno di eseguire il ripristino del sistema dal backup. Per ulteriori informazioni, vedere la Guida o la documentazione del software di backup.

Backup dei dati presenti sui dischi del cluster

Quando si esegue il backup da un nodo del cluster, prestare attenzione ai dischi Online in tale nodo in quel momento. Verrà eseguito il backup solo dei dischi Online e di proprietà del nodo del cluster al momento del backup.

Ripristino da backup in un cluster di failover

Quando si esegue il ripristino da backup in un cluster di failover, è possibile ripristinare la configurazione del cluster, i dati presenti sui dischi del cluster o entrambi.

Ripristino da backup della configurazione del client

Il Servizio cluster tiene traccia della configurazione del cluster più recente e la replica in tutti i nodi del cluster. Se il cluster dispone di un witness di disco, il Servizio cluster eseguirà inoltre la replica della configurazione nel witness di disco. Quando si esegue il ripristino da backup di un singolo nodo del cluster, esistono pertanto due possibilità:

  • Ripristino della funzione normale del nodo, senza che venga eseguito il rollback della configurazione del cluster: questa modalità è nota come ripristino non autorevole. In questo scenario, il backup viene eseguito al solo scopo di ripristinare la normale funzione di un nodo danneggiato. Quando il nodo ripristinato inizia a funzionare e viene aggiunto al cluster, la configurazione del cluster più recente viene replicata automaticamente in tale nodo.

  • Rollback della configurazione del cluster nella configurazione archiviata nel backup: questa modalità è nota come ripristino autorevole. In questo scenario, è stato stabilito che si desidera utilizzare la configurazione del cluster archiviata nel backup e non la configurazione attualmente presente nei nodi del cluster. Specificando le opzioni appropriate durante il ripristino del backup, è possibile fare in modo che la configurazione ripristinata venga considerata dal cluster come la più recente. In questo caso, il Servizio cluster non sovrascriverà la configurazione ripristinata ma la replicherà in tutti i nodi. Per informazioni dettagliate sull'esecuzione di un ripristino autorevole, vedere la Guida o la documentazione del software di backup.

Ripristino da backup dei dati nei dischi del cluster

Quando si esegue il ripristino di dati di cui è stato eseguito il backup da un nodo del cluster di failover, prestare attenzione ai dischi Online in tale nodo in quel momento. I dati possono essere scritti solo sui dischi Online e di proprietà del nodo del cluster nel momento in cui il backup viene ripristinato.

Ulteriori riferimenti

  • Gestire un cluster di failover

  • Per ulteriori informazioni sul backup e il ripristino dei cluster di failover, vedere http://go.microsoft.com/fwlink/?LinkId=92360.

  • Per ulteriori informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Connettere o disconnettere un servizio o un'applicazione del cluster

Durante l'esecuzione di operazioni diagnostiche o di manutenzione che riguardano un servizio o un'applicazione di un cluster di failover, potrebbe talvolta essere necessario connettere o disconnettere il servizio o l'applicazione specifico. La connessione o disconnessione di un'applicazione non determina l'attivazione del failover, sebbene il Servizio cluster gestisca il processo in base a un determinato ordine. Se, ad esempio, un determinato disco viene richiesto da una particolare applicazione del cluster, il Servizio cluster garantirà la disponibilità del disco prima dell'avvio dell'applicazione.

Per informazioni sulle azioni correlate, ad esempio la sospensione di un nodo del cluster, vedere Gestire un cluster di failover.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per connettere o disconnettere un servizio o un'applicazione del cluster

  1. Nello snap-in Gestione cluster di failover, se il cluster che si desidera gestire non è visualizzato, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo nel cluster che si desidera gestire.

  3. In Servizi e applicazioni espandere l'albero della console.

  4. Controllare lo stato del servizio o dell'applicazione che si desidera connettere o disconnettere facendo clic sul servizio o sull'applicazione e osservando la colonna Stato nel riquadro centrale.

  5. Fare clic con il pulsante destro del mouse sul servizio o sull'applicazione che si desidera connettere o disconnettere.

  6. Fare clic sul comando appropriato, ovvero: Connetti servizio o applicazione oppure Disconnetti servizio o applicazione.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Si noti che in un file server del cluster le cartelle condivise sono associate a una risorsa File server. Quando si connette o disconnette tale risorsa, vengono connesse o disconnesse contemporaneamente tutte le cartelle condivise incluse nella risorsa. Non è possibile modificare lo stato online o offline di una cartella condivisa senza che ciò influisca su tutte le cartelle condivise incluse nella risorsa File server.

Ulteriori riferimenti

  • Gestire un cluster di failover

  • Per ulteriori informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Eseguire operazioni Live Migration, di migrazione rapida o di spostamento di una macchina virtuale da un nodo a un altro

I cluster di failover di Windows Server 2008 R2 consentono di spostare le macchine virtuali da un nodo del cluster a un altro in diversi modi. È possibile eseguire operazioni Live Migration, di migrazione rapida o di spostamento di una macchina virtuale in un altro nodo.

Per eseguire operazioni Live Migration, di migrazione rapida o di spostamento di una macchina virtuale in un altro nodo

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Servizi e applicazioni e quindi fare clic sull'istanza del cluster contenente la macchina virtuale di cui si desidera eseguire la migrazione o lo spostamento.

  4. In Azioni (a destra) fare clic su una delle opzioni seguenti:

    • Esegui migrazione della macchina virtuale in un altro nodo utilizzando Live Migration

    • Esegui migrazione rapida delle macchine virtuali in un altro nodo

    • Sposta macchine virtuali in un altro nodo

    Per ulteriori informazioni su queste opzioni, vedere Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Non è possibile utilizzare Live Migration per spostare contemporaneamente più macchine virtuali. In un particolare server che esegue Hyper-V, è possibile eseguire una sola operazione Live Migration (al o dal server) in un determinato momento.

  • Se si decide di modificare le impostazioni di una macchina virtuale del cluster, assicurarsi di consultare l'argomento Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster.

  • Per le operazioni Live Migration e di migrazione rapida, è consigliabile impostare nel modo più simile possibile la configurazione hardware e di sistema dei nodi, per ridurre al minimo i potenziali problemi.

  • Per ogni macchina virtuale del cluster è inoltre possibile specificare l'azione eseguita dal cluster prima della disconnessione della macchina virtuale. Questa impostazione non influisce su operazioni Live Migration, sulla migrazione rapida o sul failover non pianificato, ma solo sullo spostamento o sulla disconnessione della risorsa tramite l'azione di Windows PowerShell o un'applicazione. Per specificare l'impostazione, dopo aver selezionato la macchina virtuale del cluster nell'albero della console (sulla sinistra), assicurarsi di fare clic con il pulsante destro del mouse sulla risorsa macchina virtuale visualizzata nel riquadro centrale (e non a sinistra) e quindi scegliere Proprietà. Fare clic sulla scheda Impostazioni e selezionare un'opzione. Le azioni sono descritte nella sezione relativa a operazioni Live Migration, migrazione rapida e spostamento di macchine virtuali di Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster, nella parte in cui viene descritto lo spostamento di macchine virtuali.

Ulteriori riferimenti

  • Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster

  • Gestire un cluster di failover


Aggiornare la configurazione di una macchina virtuale

Importante
  • Se si configurano in cluster le macchine virtuali e quindi si utilizza la console di gestione di Hyper-V per modificare la configurazione di una di queste macchine virtuali, eseguire la procedura descritta in questo argomento. In caso contrario, le impostazioni della macchina virtuale potrebbero non essere aggiornate nel cluster di failover e, di conseguenza, potrebbero verificarsi problemi durante il successivo spostamento, migrazione o failover della macchina virtuale del cluster.
  • Quando si modificano le impostazioni di una macchina virtuale del cluster, è consigliabile utilizzare Gestione cluster di failover anziché la console di gestione di Hyper-V. Per ulteriori informazioni, vedere Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster.
Per aggiornare la configurazione di una macchina virtuale

  1. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo in corrispondenza del cluster da configurare.

  3. Espandere Servizi e applicazioni e quindi fare clic sulla macchina virtuale di cui si desidera aggiornare la configurazione.

  4. Nel riquadro Azioni scorrere verso il basso, fare clic su Altre azioni e quindi su Aggiorna configurazione macchina virtuale.

  5. Fare clic su Sì per visualizzare i dettagli di questa azione.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Modificare le impostazioni della macchina virtuale per una macchina virtuale del cluster

  • Gestire un cluster di failover

  • Modificare le impostazioni per un servizio o un'applicazione in cluster


Sospendere o riprendere un nodo in un cluster di failover

Quando si sospende un nodo, i gruppi e le risorse esistenti rimangono online, ma non è possibile connettere gruppi e risorse aggiuntivi. La sospensione di un nodo viene in genere utilizzata durante l'applicazione di aggiornamenti software al nodo, quando la sequenza consigliata consiste nello spostare dal nodo tutti i servizi e le applicazioni, sospendere il nodo e quindi applicarvi gli aggiornamenti software.

Se è necessario eseguire operazioni diagnostiche e di manutenzione estensive in un nodo del cluster, potrebbe non essere sufficiente sospendere il nodo. In tal caso, è possibile interrompere il Servizio cluster in tale nodo. Per ulteriori informazioni, vedere Avviare o arrestare il Servizio cluster in un nodo di cluster.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per sospendere o riprendere un nodo in un cluster di failover tramite l'interfaccia di Windows

  1. Nello snap-in Gestione cluster di failover, se il cluster che si desidera gestire non è visualizzato, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo nel cluster che si desidera gestire.

  3. Espandere l'albero della console in Nodi.

  4. Fare clic con il pulsante destro del mouse sul nodo che si desidera sospendere o riprendere e quindi scegliere Sospendi o Riprendi.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Gestire un cluster di failover

  • Per ulteriori informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Eseguire uno strumento di manutenzione del disco quale Chkdsk su un disco di tipo cluster

Per eseguire uno strumento di manutenzione del disco come Chkdsk in un disco o in un volume configurato come parte di una macchina virtuale, un servizio o un'applicazione in cluster, è necessario utilizzare la modalità di manutenzione. Quando la modalità di manutenzione è attiva, l'esecuzione dello strumento di manutenzione del disco può essere completata senza che venga attivato un failover. Se si utilizza un witness di disco, non è possibile utilizzare la modalità di manutenzione per tale disco.

La modalità di manutenzione funziona per alcuni aspetti in modo diverso in un volume incluso in Volumi condivisi cluster rispetto a quanto avvenga in altri dischi dell'archivio cluster, come descritto nella sezione Ulteriori considerazioni, più avanti in questo argomento.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per eseguire uno strumento di manutenzione del disco come Chkdsk in un disco di tipo cluster

  1. Nello snap-in Gestione cluster di failover, se il cluster non è visualizzato, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo nel cluster che utilizza il disco sul quale si desidera eseguire lo strumento di manutenzione del disco.

  3. Nell'albero della console fare clic su Archiviazione.

  4. Nel riquadro centrale fare clic sul disco sul quale si desidera eseguire lo strumento di manutenzione del disco.

  5. In Azioni fare clic su Altre azioni e quindi sul comando appropriato:

    • Se il disco selezionato è incluso in Volumi condivisi cluster e contiene più volumi, fare clic su Manutenzione e quindi fare clic sul comando per il volume appropriato. Se richiesto, confermare l'azione.

    • Se il disco selezionato è incluso in Volumi condivisi cluster e contiene un volume, fare clic su Manutenzione e quindi su Attiva modalità manutenzione per questo disco. Se richiesto, confermare l'azione.

    • Se il disco selezionato è incluso in Volumi condivisi cluster, fare clic su Attiva modalità manutenzione per questo disco.

  6. Eseguire lo strumento di manutenzione del disco nel disco o nel volume.

    Quando la modalità di manutenzione è attiva, l'esecuzione dello strumento di manutenzione del disco può essere completata senza che venga attivato un failover.

  7. Al termine dell'esecuzione dello strumento di manutenzione del disco, con il disco ancora selezionato, in Azioni fare clic su Altre azioni e quindi sul comando appropriato:

    • Se il disco selezionato è incluso in Volumi condivisi cluster e contiene più volumi, fare clic su Manutenzione e quindi fare clic sul comando per il volume appropriato.

    • Se il disco selezionato è incluso in Volumi condivisi cluster e contiene un volume, fare clic su Manutenzione e quindi su Disattiva modalità manutenzione per questo disco.

    • Se il disco selezionato è incluso in Volumi condivisi cluster, fare clic su Disattiva modalità manutenzione per questo disco.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • La modalità di manutenzione funziona per alcuni aspetti in modo diverso in un volume incluso in Volumi condivisi cluster rispetto a quanto avvenga in altri dischi dell'archivio cluster:

    Per i volumi condivisi del cluster Per i dischi non inclusi nei volumi condivisi del cluster

    Modifica lo stato di un volume.

    Modifica lo stato di un disco (LUN).

    Disconnette le risorse dipendenti, interrompendo l'accesso client.

    Lascia connesse le risorse dipendenti.

    Rimuove l'accesso tramite il percorso \ClusterStorage\volume, consentendo comunque al nodo del proprietario di accedere al volume tramite il relativo identificatore (GUID). Sospende inoltre l'accesso diretto da altri nodi, consentendo di accedere solo tramite il nodo del proprietario.

    Non modifica l'accesso al disco.

  • La modalità di manutenzione rimarrà attiva fino a quando non si verifica una delle condizioni seguenti:

    • L'utente la disattiva.

    • Il nodo in cui la risorsa è in esecuzione viene riavviato o perde la comunicazione con gli altri nodi, determinando il failover di tutte le risorse in quel nodo.

    • Per un disco non incluso nei volumi condivisi del cluster, la risorsa disco viene disconnessa oppure si verifica un errore in tale risorsa.

  • È possibile sapere se è attiva la modalità di manutenzione per un disco osservando lo stato riportato nel riquadro centrale quando nell'albero della console è selezionato Archiviazione.

Ulteriori riferimenti

  • Gestire un cluster di failover

  • Per ulteriori informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Avviare o arrestare il Servizio cluster in un nodo di cluster

Potrebbe essere necessario avviare o arrestare il Servizio cluster in un nodo del cluster durante la risoluzione dei problemi o l'esecuzione di operazioni di manutenzione. Quando si arresta il Servizio cluster in un nodo, viene eseguito il failover dei servizi o delle applicazioni in tale nodo e il funzionamento del nodo nel cluster si interrompe fino a quando il Servizio cluster non viene riavviato.

Se si desidera mantenere in funzione un determinato nodo in modo che supporti i servizi o le applicazioni di cui è proprietario e contemporaneamente impedire che venga eseguito il failover di servizi e applicazioni aggiuntivi in tale nodo, sospendere il nodo senza arrestare il Servizio cluster. Per ulteriori informazioni, vedere Sospendere o riprendere un nodo in un cluster di failover.

L'appartenenza al gruppo locale Administrators su ogni server in cluster, o equivalente, è il minimo indispensabile per completare questa procedura. Inoltre, l'account utilizzato deve essere un account di dominio. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per avviare o interrompere il Servizio cluster in un nodo del cluster tramite l'interfaccia di Windows

  1. Nello snap-in Gestione cluster di failover, se il cluster che si desidera gestire non è visualizzato, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo nel cluster che si desidera gestire.

  3. Per ridurre al minimo i tempi di interruzione per i client, prima di arrestare il Servizio cluster in un nodo, spostare in un altro nodo le applicazioni di cui il nodo è attualmente proprietario. A tale scopo, espandere l'albero della console nel cluster che si desidera gestire e quindi espandere Servizi e applicazioni. Fare clic su ogni servizio o applicazione in modo da visualizzare il Proprietario corrente nel riquadro centrale. Se il proprietario corrisponde al nodo in cui si desidera arrestare il Servizio cluster, fare clic con il pulsante destro del mouse sul servizio o sull'applicazione, scegliere Sposta servizio o applicazione in un altro nodo e quindi scegliere il nodo. Per una descrizione dell'opzione di comando Migliore possibile, vedere la sezione "Ulteriori considerazioni" in questo argomento.

  4. Espandere l'albero della console in Nodi.

  5. Fare clic con il pulsante destro del mouse sul nodo che si desidera avviare o arrestare e quindi scegliere Altre azioni.

  6. Fare clic sul comando appropriato:

    • Per avviare il servizio, fare clic su Avvia Servizio cluster.

    • Per arrestare il servizio, fare clic su Arresta Servizio cluster.

Ulteriori considerazioni

  • Per eseguire l'attività descritta in questa procedura è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di failover, visitare il sito Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=135119 e http://go.microsoft.com/fwlink/?LinkId=135120.

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • In un cluster con più nodi è possibile scegliere l'opzione Migliore possibile tra le opzioni disponibili accanto a Sposta servizio o applicazione in un altro nodo. Questa opzione non avrà effetto se non è stato configurato un elenco di Proprietari preferiti per il servizio o l'applicazione che si sta spostando. In tal caso, il nodo verrà scelto in modo casuale. Se è stato configurato un elenco Proprietari preferiti, la scelta dell'opzione Migliore possibile consentirà di spostare il servizio o l'applicazione nel primo nodo disponibile dell'elenco.

  • Nel riquadro centrale dello snap-in Gestione cluster di failover vengono visualizzate le informazioni sullo stato di un nodo. Per controllare se il Servizio cluster è in esecuzione in un nodo specifico, fare clic con il pulsante destro sul nodo e scegliere Altre azioni. Se un nodo è stato avviato, l'opzione Avvia Servizio cluster verrà visualizzata in grigio, mentre se un nodo è stato arrestato, l'opzione Arresta Servizio cluster verrà visualizzata in grigio.

  • Se si utilizza l'opzione relativa al quorum Maggioranza dei nodi e delle condivisioni file, prima di poter avviare il cluster sarà necessario che almeno uno dei nodi del cluster disponibili contenga una copia corrente della configurazione del cluster. In caso contrario, sarà necessario forzare l'avvio del cluster tramite un nodo specifico. Il cluster utilizzerà quindi la copia della configurazione del cluster presente in tale nodo e la replicherà in tutti gli altri nodi. Per forzare l'avvio del cluster, nel nodo che contiene una copia della configurazione del cluster che si desidera utilizzare aprire lo snap-in Gestione cluster di failover, fare clic sul cluster e quindi in Azioni, a destra, fare clic su Forza avvio del cluster. In alcuni casi, questo pulsante non è disponibile nell'interfaccia di Windows.

    Nota

    Quando si utilizza questo comando in un determinato nodo, la copia della configurazione del cluster presente in tale nodo viene considerata una copia autorevole della configurazione e quindi replicata in tutti gli altri nodi.

  • Il Servizio cluster esegue le funzioni essenziali in ogni nodo del cluster, inclusi la gestione della configurazione del cluster, il coordinamento con le istanze del Servizio cluster in esecuzione in altri nodi e l'esecuzione delle operazioni di failover.

Ulteriori riferimenti

  • Gestire un cluster di failover

  • Per ulteriori informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover

È possibile utilizzare la Convalida guidata configurazione per la risoluzione dei problemi di un cluster di failover. Mediante l'esecuzione dei test correlati ai sintomi manifestati, è possibile ottenere ulteriori informazioni per la correzione del problema.

Importante
  • Se un servizio o un'applicazione del cluster sta utilizzando un disco mentre viene avviata la procedura guidata, verrà richiesto se si desidera disconnettere il servizio o l'applicazione del cluster per eseguire i test. Se si sceglie di disconnettere un servizio o un'applicazione del cluster, il servizio o l'applicazione rimarrà disconnesso per tutta la durata dei test.
  • Se inoltre si desidera eseguire il test dei dischi configurati come volumi condivisi del cluster, è necessario disconnettere esplicitamente tali dischi, come descritto nella procedura seguente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per utilizzare i test di convalida per la risoluzione dei problemi di un cluster di failover

  1. Scegliere se si desidera eseguire tutti i test di convalida disponibili o solo una parte di essi. È possibile selezionare o deselezionare i test seguenti singolarmente o per categoria:

    • Test Configurazione cluster: consentono di verificare impostazioni importanti di configurazione del cluster. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Configurazione cluster.

    • Test Inventario: consentono di ottenere un inventario dell'hardware, del software e delle impostazioni dei server, ad esempio le impostazioni di rete, nonché informazioni sull'archiviazione. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Inventario.

    • Test Rete: consentono di verificare che le reti siano configurate correttamente per il clustering. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Rete.

    • Test Archiviazione: consentono di verificare che i dispositivi di archiviazione da cui dipende il cluster di failover funzionino correttamente e che supportino le funzioni necessarie del cluster. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Archiviazione.

    • Test Configurazione sistema: consentono di verificare che le impostazioni di configurazione e del software di sistema siano compatibili tra i server. Per ulteriori informazioni, vedere Informazioni sui test di convalida del cluster: Configurazione sistema.

  2. Nello snap-in Gestione cluster di failover, se il cluster per il quale si desidera risolvere i problemi non è visualizzato, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  3. Se si desidera eseguire il test dei dischi configurati come volumi condivisi del cluster, eseguire la procedura seguente:

    1. Espandere l'albero della console e fare clic su Volumi condivisi cluster.

    2. Nel riquadro centrale fare clic con il pulsante destro del mouse su un disco per il quale si desidera eseguire il test e quindi scegliere Disconnetti risorsa.

    3. Ripetere il passaggio precedente per tutti i dischi per i quali si desidera eseguire il test.

  4. Fare clic con il pulsante destro del mouse sul cluster per il quale si desidera risolvere i problemi e quindi scegliere Convalida cluster.

  5. Seguire le istruzioni visualizzate nella procedura guidata per specificare ed eseguire i test e per visualizzare i risultati.

  6. Se i volumi condivisi del cluster sono stati disconnessi in un passaggio precedente, eseguire la procedura seguente:

    1. Fare clic su Volumi condivisi cluster.

    2. Nel riquadro centrale fare clic con il pulsante destro del mouse su un disco disconnesso e quindi scegliere Connetti risorsa.

    3. Ripetere il passaggio precedente per tutti i dischi precedentemente disconnessi.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Per visualizzare i risultati dei test dopo aver chiuso la procedura guidata, eseguire una delle procedure seguenti:

    • Aprire la cartella systemroot\Cluster\Reports in un server del cluster.

    • Nell'albero della console fare clic con il pulsante destro del mouse sul cluster e quindi scegliere Visualizza rapporto di convalida. Verrà visualizzato il rapporto di convalida più recente per il cluster specifico.

Ulteriori riferimenti

  • Informazioni sui test di convalida del cluster

  • Gestire un cluster di failover

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Visualizzare eventi e registri per un cluster di failover

Quando si visualizzano eventi mediante lo snap-in Gestione cluster di failover, è possibile visualizzare gli eventi per tutti i nodi del cluster anziché per un solo nodo alla volta.

Per informazioni sulla visualizzazione dei rapporti generati dalle procedure guidate per i cluster di failover, vedere Visualizzare i rapporti delle azioni eseguite dalle procedure guidate per cluster di failover.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare eventi e registri per un cluster di failover tramite l'interfaccia di Windows

  1. Nello snap-in Gestione cluster di failover, se il cluster non è visualizzato, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  2. Se l'albero della console è compresso, espanderlo nel cluster per il quale si desidera visualizzare gli eventi.

  3. Nell'albero della console fare clic con il pulsante destro del mouse su Eventi cluster e quindi scegliere Query.

  4. Nella finestra di dialogo Filtro eventi cluster selezionare i criteri per gli eventi che si desidera visualizzare.

    Per ripristinare i criteri predefiniti, fare clic sul pulsante Reimposta.

  5. Fare clic su OK.

  6. Per ordinare gli eventi, fare clic su un'intestazione, ad esempio Livello o Data e ora.

  7. Per visualizzare un evento specifico, fare clic sull'evento per visualizzare i dettagli nel riquadro Dettagli evento.

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  • Per aprire un registro correlato al clustering di failover, è inoltre possibile utilizzare Visualizzatore eventi. Per individuare un registro, in Visualizzatore eventi espandere Registri applicazioni e servizi, espandere Microsoft, espandere Windows e quindi espandere FailoverClustering. Il file di registro viene archiviato in systemroot\system32\winevt\Logs.

Ulteriori riferimenti

  • Gestire un cluster di failover

  • Visualizzare i rapporti delle azioni eseguite dalle procedure guidate per cluster di failover

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Visualizzare i rapporti delle azioni eseguite dalle procedure guidate per cluster di failover

Per ogni procedura guidata per i cluster di failover eseguita in Windows Server 2008 R2 viene creato un rapporto delle relative azioni. In questo argomento viene descritto come visualizzare il rapporto di una determinata procedura guidata facendo clic su un pulsante nell'ultima pagina di tale procedura guidata oppure aprendo un rapporto da una cartella specifica in Windows Server 2008 R2.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare un rapporto delle azioni di una procedura guidata per cluster di failover

  • Scegliere una delle opzioni seguenti:

    • Se la procedura guidata della quale si desidera visualizzare un rapporto è aperta, procedere nella procedura guidata fino alla pagina Riepilogo e quindi fare clic su Visualizza rapporto.

    • Se la procedura guidata è stata eseguita ma non è attualmente visualizzata, utilizzare Esplora risorse o un altro metodo per spostarsi nella posizione seguente e aprire il rapporto desiderato:

      systemroot\Cluster\Reports

Ulteriori considerazioni

  • Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

Ulteriori riferimenti

  • Gestire un cluster di failover

  • Visualizzare eventi e registri per un cluster di failover

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Risorse per i cluster di failover

Per ulteriori informazioni sui cluster di failover, vedere le risorse seguenti sul sito Web Microsoft:

  • Per un elenco di collegamenti a numerosi argomenti dedicati ai cluster di failover, vedere http://go.microsoft.com/fwlink/?LinkId=68633.

  • Per informazioni sulla compatibilità hardware per Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139145.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.

  • Per informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Interfaccia utente: snap-in Gestione cluster di failover

In questa sezione vengono descritti gli elementi seguenti dello snap-in Gestione cluster di failover per Windows Server 2008 R2:

  • Finestra di dialogo Aggiungi tipo di risorsa

  • Proprietà <IstanzaInCluster>: scheda Generale

  • Proprietà <risorsa>: scheda Criteri avanzati

  • Proprietà <risorsa>: scheda Relazioni di dipendenza

  • Proprietà <risorsa>: scheda Generale

  • Proprietà <risorsa>: scheda Criteri

  • Proprietà <nome risorsa> macchina virtuale: scheda Impostazioni

Ulteriori riferimenti

Panoramica dei cluster di failover


Finestra di dialogo Aggiungi tipo di risorsa

Elemento | Dettagli
Percorso e nome file della DLL della risorsa | Specificare il percorso e il nome file della DLL della risorsa che il Servizio cluster dovrà utilizzare per comunicare con il servizio o l'applicazione. In risposta ai comandi e alle richieste inviati dal Servizio cluster e dai componenti software associati, una DLL della risorsa esegue il monitoraggio e il controllo del servizio o dell'applicazione associato. La DLL della risorsa, ad esempio, salva e recupera le proprietà del servizio o dell'applicazione nel database del cluster, connette e disconnette la risorsa e controlla lo stato della risorsa.
Nome tipo di risorsa | Specificare il nome utilizzato dal Servizio per il tipo di risorsa. Questo nome rimane invariato indipendentemente dalle opzioni internazionali e della lingua attualmente selezionate.
Nome visualizzato del tipo di risorsa | Specificare il nome che viene visualizzato per il tipo di risorsa. Il nome potrebbe variare se si apportano modifiche alle opzioni internazionali e della lingua.

Ulteriori riferimenti

  • Interfaccia utente: snap-in Gestione cluster di failover


Proprietà <IstanzaInCluster>: scheda Generale

Elemento Dettagli

Proprietari preferiti

Selezionare i nodi nell'elenco e quindi utilizzare i pulsanti per elencarli in ordine.

Se si desidera spostare il servizio o l'applicazione in un nodo specifico ogni volta che tale nodo è disponibile:

  • Selezionare la casella di controllo per un nodo e utilizzare i pulsanti per spostare il nodo nella parte superiore dell'elenco.

  • Nella scheda Failover verificare che il failback sia consentito per il servizio o l'applicazione specifico.

Si noti che anche se si deseleziona la casella di controllo per un nodo nell'elenco Proprietari preferiti, è possibile che venga eseguito il failover del servizio o dell'applicazione in tale nodo per uno dei motivi seguenti:

  • Non sono stati specificati proprietari preferiti.

  • Nessun nodo corrispondente a un proprietario preferito è attualmente connesso.

Per assicurarsi che non venga mai eseguito il failover di un servizio o un'applicazione del cluster in un particolare nodo:

  1. Selezionare una singola risorsa nel servizio o nell'applicazione.

  2. Aprire la finestra delle proprietà per tale risorsa.

  3. Selezionare la scheda Criteri avanzati.

  4. Configurare l'elenco Possibili proprietari.

Ulteriori riferimenti

  • Modificare le impostazioni per un servizio o un'applicazione in cluster

  • Interfaccia utente: snap-in Gestione cluster di failover


Proprietà <risorsa>: scheda Criteri avanzati

Elemento Dettagli

Proprietari possibili

Deselezionare la casella di controllo per un nodo solo se si desidera impedire che venga eseguito il failover in tale nodo della risorsa, nonché del servizio o dell'applicazione del cluster che contiene la risorsa. In caso contrario, lasciare selezionate le caselle per tutti i nodi.

Si noti che se si lascia selezionata la casella per un solo nodo, non sarà possibile eseguire il failover della risorsa, nonché del servizio o dell'applicazione che contiene la risorsa.

Intervallo di verifica di base dello stato della risorsa

Consente di specificare la frequenza con cui si desidera che il cluster esegua una verifica di base per stabilire se la risorsa è online. È consigliabile utilizzare il periodo di tempo standard per il tipo di risorsa, a meno che non esista un motivo specifico per modificarlo.

Questa verifica è nota anche come polling "Looks Alive".

Intervallo di verifica completa dello stato della risorsa

Consente di specificare la frequenza con cui si desidera che il cluster esegua una verifica più approfondita per stabilire se la risorsa è online e funziona correttamente. È consigliabile utilizzare il periodo di tempo standard per il tipo di risorsa, a meno che non esista un motivo specifico per modificarlo.

Questa verifica è nota anche come polling "Is Alive".

Ulteriori riferimenti

  • Interfaccia utente: snap-in Gestione cluster di failover


Proprietà <risorsa>: scheda Relazioni di dipendenza

Quando si specificano le dipendenze delle risorse, è possibile controllare l'ordine in cui il Servizio cluster connette e disconnette le risorse. Una risorsa dipendente viene:

  • Connessa dopo la risorsa o le risorse da cui dipende.

  • Disconnessa prima della risorsa o delle risorse da cui dipende.

Nota

Dopo aver specificato le dipendenze, per visualizzare un rapporto, fare clic con il pulsante destro del mouse sul servizio o l'applicazione del cluster, non sulla risorsa, e quindi scegliere Visualizza rapporto dipendenze.

In questa scheda sono disponibili i controlli seguenti:

Elemento Dettagli

Risorsa

Selezionare la casella e quindi selezionare una risorsa nell'elenco. Nell'elenco sono incluse le altre risorse del servizio o dell'applicazione del cluster che non sono state già selezionate.

AND/OR

Per la seconda riga o le righe successive:

  • Specificare AND se è necessario che entrambe le risorse in tale riga e una o più risorse elencate in precedenza siano online prima che la risorsa dipendente venga connessa.

  • Specificare OR se è necessario che una delle risorse in tale riga o un'altra risorsa elencata in precedenza sia online prima che la risorsa dipendente venga connessa. È inoltre possibile che la risorsa dipendente venga connessa se entrambe sono online.

Si noti che vengono visualizzate parentesi grigie per indicare la modalità di raggruppamento degli elenchi, in base alle impostazioni AND/OR.

Inserisci

Quando si seleziona una riga nell'elenco e si fa clic su Inserisci, viene aggiunta una riga all'elenco prima della riga selezionata.

Elimina

Quando si seleziona una riga nell'elenco e si fa clic su Elimina, la riga viene eliminata.

Ulteriori riferimenti

  • Interfaccia utente: snap-in Gestione cluster di failover


Proprietà <risorsa>: scheda Generale

Se si verifica un errore a un disco utilizzato in un cluster di failover, sarà possibile utilizzare il comando Ripristina nella scheda Generale della finestra delle proprietà per assegnare un disco diverso.

Elemento Dettagli

Pulsante Ripristina (per un disco)

Quando si fa clic su questo pulsante, è possibile interrompere l'utilizzo di un disco danneggiato e assegnare un disco diverso al servizio o all'applicazione specifico. Il disco assegnato deve poter essere utilizzato per il clustering, ma non deve essere stato già configurato in cluster.

Per ulteriori informazioni sui dischi utilizzabili per il clustering, vedere "Elenca potenziali dischi cluster" in Informazioni sui test di convalida del cluster: Archiviazione.

Attenzione

Il pulsante Ripristina non consente di ripristinare i dati.

Prima di utilizzare il pulsante Ripristina, esporre un LUN a ogni nodo del cluster, senza aggiungere il LUN al cluster, mediante lo snap-in Gestione cluster di failover.

È possibile ripristinare i dati sul disco prima o dopo l'utilizzo del pulsante Ripristina.


Proprietà <risorsa>: scheda Criteri

Elemento Dettagli

Numero massimo di riavvii nel periodo specificato

Specificare il numero di volte per cui si desidera che il Servizio cluster tenti di riavviare la risorsa durante il periodo specificato. Se non è possibile riavviare la risorsa dopo questo numeri di tentativi durante il periodo specificato, verranno intraprese azioni dal Servizio cluster in base a quanto specificato in altri campi di questa scheda.

Se, ad esempio, si specifica 3 per Numero massimo di riavvii nel periodo specificato e 15.00 per il periodo, il Servizio cluster tenterà di riavviare la risorsa tre volte in un periodo di 15 minuti. Se non è ancora possibile eseguire la risorsa, anziché eseguire un quarto tentativo di riavvio, verranno intraprese azioni da parte del Servizio cluster in base a quanto specificato negli altri campi di questa scheda.

Periodo per i riavvii (mm:ss)

Specificare il periodo di tempo in minuti e secondi durante il quale il Servizio cluster conteggerà il numero di volte in cui una risorsa è stata riavviata. Per un esempio dell'utilizzo del periodo con il numero massimo di riavvii, vedere la cella precedente in questa tabella.

Se il riavvio ha esito negativo, esegui il failover di tutte le risorse nel servizio o nell'applicazione

Utilizzare questa casella per controllare la modalità di risposta del Servizio cluster quando il numero massimo di riavvii ha esito negativo:

  • Selezionare questa casella se si desidera che il Servizio cluster risponda eseguendo il failover del servizio o dell'applicazione del cluster in un altro nodo.

  • Deselezionare questa casella se si desidera che il Servizio cluster risponda lasciando il servizio o l'applicazione del cluster in esecuzione nel nodo corrente, anche se la risorsa è in stato di errore.

Se tutti i tentativi di riavvio hanno esito negativo, ripeti il tentativo di riavvio dopo un'attesa pari al periodo indicato (hh:mm)

Selezionare questa casella se si desidera che il Servizio cluster rimanga in attesa per un periodo di tempo prolungato dopo aver tentato il numero massimo di riavvii della risorsa. Si noti che questo periodo di attesa prolungato viene misurato in ore e minuti. Al termine del periodo di attesa, il Servizio cluster eseguirà un'altra serie di riavvii, indipendentemente da qual è il nodo proprietario del servizio o dell'applicazione del cluster in quel momento.

Ulteriori riferimenti

  • Interfaccia utente: snap-in Gestione cluster di failover


Proprietà <nome risorsa> macchina virtuale: scheda Impostazioni

In questa scheda è possibile specificare l'azione eseguita dal cluster quando la macchina virtuale viene disconnessa. Questa impostazione non influisce su operazioni Live Migration, sulla migrazione rapida o sul failover non pianificato, ma solo sullo spostamento o sulla disconnessione della risorsa tramite l'azione di Windows PowerShell o un'applicazione.

Opzione | Dettagli
Salva | Il cluster salva lo stato della macchina virtuale prima di disconnetterla, in modo che lo stato possa essere ripristinato quando la macchina virtuale viene di nuovo connessa. Questa è l'impostazione predefinita.
Arresta | Il cluster esegue un arresto ordinato del sistema operativo, attendendo la chiusura di tutti i processi, nella macchina virtuale prima di disconnetterla.
Arresta (in modo forzato) | Il cluster arresta il sistema operativo nella macchina virtuale senza attendere il completamento dei processi e quindi disconnette la macchina virtuale.
Spegni | Il cluster spegne la macchina virtuale senza arrestare il sistema operativo quando la macchina virtuale viene disconnessa. Questa operazione corrisponde all'interruzione dell'alimentazione e può pertanto comportare la perdita di dati.

Opzione | Dettagli
Abilita controllo dell'heartbeat sulla macchina virtuale | Quando questa opzione è selezionata, vengono inviati heartbeat dal sistema operativo in esecuzione nella macchina virtuale a quello che esegue il ruolo Hyper-V. In caso di arresto degli heartbeat, a indicare che la macchina virtuale non risponde, il cluster riceve una notifica e può tentare di riavviare la macchina virtuale del cluster o di eseguirne il failover.

Ulteriori riferimenti

  • Interfaccia utente: snap-in Gestione cluster di failover

  • Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster