Connection Manager Administration Kit

Connection Manager è uno strumento per connessioni di rete client che consente a un utente di connettersi a una rete remota, ad esempio un provider di servizi Internet (ISP, Internet Service Provider), o a una rete aziendale protetta da un server di rete privata virtuale (VPN, Virtual Private Network).

Connection Manager Administration Kit (CMAK) è uno strumento che può essere utilizzato per personalizzare la modalità di esecuzione delle connessioni remote per gli utenti in rete creando connessioni predefinite a reti e server remoti. Per creare e personalizzare una connessione per gli utenti, utilizzare la Configurazione guidata Microsoft Connection Manager Administration Kit.

Installare CMAK

CMAK è un componente facoltativo non installato per impostazione predefinita. È necessario installare CMAK per creare profili di connessione installabili dagli utenti per l'accesso a reti remote. Per ulteriori informazioni su come installare CMAK, vedere Installare CMAK.

Prima di eseguire la Configurazione guidata Microsoft Connection Manager Administration Kit

Prima di eseguire questa procedura guidata, leggere la documentazione relativa a CMAK disponibile on line all'indirizzo http://go.microsoft.com/fwlink/?linkid=55986. Dopo aver acquisito familiarità con il processo e aver raccolto i dati necessari, è possibile eseguire la procedura guidata. Per ulteriori informazioni sui singoli passaggi per la creazione del profilo di connessione, vedere Eseguire la Configurazione guidata Microsoft Connection Manager Administration Kit per creare un profilo di connessione.

Distribuire il profilo di connessione completato

Eseguendo la Configurazione guidata Microsoft Connection Manager Administration Kit viene creato un profilo di connessione che viene archiviato in un file eseguibile. Eseguendo tale file in un computer client si configura il computer per la connessione di rete desiderata. Per ulteriori informazioni sul testing e la distribuzione del profilo di connessione, vedere Distribuire il profilo di connessione agli utenti.

Ulteriori riferimenti

  • Risorse aggiuntive per CMAK


Installare CMAK

CMAK è un componente facoltativo non installato per impostazione predefinita. È necessario installare CMAK per creare profili di connessione installabili dagli utenti per l'accesso a reti remote.

Importante

È necessario utilizzare un computer che esegue una versione di Windows con la stessa architettura del processore utilizzata dai client su cui si desidera installare il profilo. È possibile creare e installare un profilo di connessione a 32 bit solo su una versione a 32 bit di Windows. È possibile creare e installare un profilo di connessione a 64 bit solo su una versione a 64 bit di Windows.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Utilizzare la procedura seguente per installare CMAK su un computer che esegue una versione a 64 bit di Windows Server 2008 R2. È possibile utilizzare i profili creati con questa versione di CMAK solo su computer che eseguono una versione a 64 bit di Windows. Non è possibile installare CMAK su un computer che esegue una versione a 64 bit di Windows 7.

Per installare CMAK su una versione a 64 bit di Windows Server 2008 R2

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  2. Nel riquadro di spostamento fare clic con il pulsante destro del mouse su Funzionalità e quindi scegliere Aggiungi funzionalità.

  3. Nell'elenco Funzionalità selezionare Connection Manager Administration Kit e quindi fare clic su Successivo.

  4. Nella pagina Conferma selezioni per l'installazione fare clic su Installa.

  5. Nella pagina Risultati installazione fare clic su Chiudi.

Utilizzare la procedura seguente per installare CMAK su un computer che esegue una versione a 32 bit di Windows 7. È possibile utilizzare i profili creati con questa versione di CMAK solo su computer che eseguono una versione a 32 bit di Windows.

Per installare CMAK su una versione a 32 bit di Windows 7

  1. Fare clic sul pulsante Start, scegliere Pannello di controllo, Programmi e quindi Attivazione o disattivazione delle funzionalità Windows.

  2. Nell'elenco delle funzionalità selezionare Connection Manager Administration Kit (CMAK) RAS e quindi fare clic su OK.

Ulteriori riferimenti

  • Risorse aggiuntive per CMAK


Eseguire la Configurazione guidata Microsoft Connection Manager Administration Kit per creare un profilo di connessione

Utilizzare la Configurazione guidata Microsoft Connection Manager Administration Kit per configurare un profilo di connessione nuovo o già esistente.

Per avviare la Configurazione guidata Microsoft Connection Manager Administration Kit

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Connection Manager Administration Kit. Se tale voce non è disponibile nel menu, Connection Manager Administration Kit (CMAK) non è installato. Vedere Installare CMAK.

  2. Nella pagina iniziale fare clic su Avanti.

    Ogni pagina della procedura guidata include un passaggio di creazione di un profilo di connessione.

In questa sezione sono contenute informazioni di base sulle opzioni visualizzate nelle pagine della Configurazione guidata Microsoft Connection Manager Administration Kit:

  • Selezionare il sistema operativo di destinazione

  • Creare o modificare un profilo di connessione

  • Specificare il nome del servizio e il nome del file

  • Specificare il nome di un'area di autenticazione

  • Unire informazioni di altri profili di connessione

  • Aggiungere supporto per le connessioni VPN

  • Aggiungere una Rubrica telefonica personalizzata

  • Configurare le voci di connessione remota

  • Specificare gli aggiornamenti delle tabelle di routing

  • Configurare le impostazioni del proxy per Internet Explorer

  • Aggiungere operazioni personalizzate

  • Visualizzare bitmap e icone personalizzate

  • Personalizzare il menu di scelta rapida dell'area di notifica

  • Includere un file della Guida personalizzato

  • Visualizzare informazioni personalizzate relative al supporto

  • Includere il software di Connection Manager nel profilo di connessione

  • Visualizzare un contratto di licenza personalizzato

  • Installare file aggiuntivi con il profilo di connessione

  • Generare il profilo di connessione e il relativo programma di installazione

  • Effettuare personalizzazioni avanzate

  • Profilo di connessione creato e pronto per la distribuzione

  • Risolvere i problemi relativi al processo di creazione di un profilo di connessione

Per ulteriori informazioni sulla creazione di un profilo di connessione, vedere la pagina relativa alla guida operativa di CMAK nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=57535.

Ulteriori riferimenti

  • Installare CMAK

  • Distribuire il profilo di connessione agli utenti

  • Risorse aggiuntive per CMAK


Selezionare il sistema operativo di destinazione

Quando si crea un profilo di connessione, è necessario specificare i sistemi operativi supportati. Connection Manager 1.4 e il relativo Administration Kit (CMAK) in Windows Server® 2008 R2 aggiungono il supporto per funzionalità che richiedono Windows Vista®, Windows Server® 2008, Windows® 7 o Windows Server 2008 R2 sul computer client. Selezionando il gruppo di sistemi operativi di destinazione corretto si garantisce agli utenti del profilo la disponibilità delle funzionalità più appropriate.

Importante
  • È possibile installare ed eseguire un profilo di Connection Manager creato su una versione a 64 bit di Windows solo su computer che eseguano una versione a 64 bit di Windows, tra cui Windows XP x64 Edition, Windows Server 2003 x64 Edition e le versioni a 64 bit di Microsoft Windows Vista, Windows Server 2008 R2 e Windows 7.
  • Per creare un profilo di Connection Manager per un computer che esegue una versione a 32 bit di Windows, è necessario eseguire CMAK su un computer che esegue una versione a 32 bit di Windows. Poiché Windows Server 2008 R2 è disponibile solo come sistema operativo a 64 bit, è possibile utilizzare la versione a 32 bit di Windows 7. Per installare CMAK su una versione a 32 bit di Windows 7, nel Pannello di controllo, fare clic su Programmi e quindi Attivazione o disattivazione delle funzionalità Windows, selezionare la funzionalità Connection Manager Administration Kit (CMAK) RAS e quindi fare clic su OK.

Impostazione | Descrizione
Windows 7 o Windows Vista | Consente di specificare che nel profilo sono incluse funzionalità che possono essere utilizzate solo in un computer che esegue Microsoft Windows Vista, Windows Server 2008, Windows 7 o Windows Server 2008 R2.
Windows Server 2003, Windows XP o Windows 2000 (visualizzato su computer a 32 bit) o Windows Server 2003 o Windows XP (visualizzato su computer a 64 bit) | Consente di specificare che nel profilo sono incluse solo funzionalità che possono essere utilizzate in uno qualsiasi dei sistemi operativi supportati.

Per ulteriori informazioni sul supporto nei sistemi operativi del client, vedere la pagina relativa ai componenti di Connection Manager e ai requisiti di sistema nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80948.

Ulteriori riferimenti

  • Eseguire la Configurazione guidata Microsoft Connection Manager Administration Kit per creare un profilo di connessione


Creare o modificare un profilo di connessione

Ogni volta che si esegue la Configurazione guidata Microsoft Connection Manager Administration Kit, si crea o si modifica un profilo di connessione. È possibile creare un numero illimitato di profili di connessione per supportare gruppi di utenti in rete remoti.

Impostazione | Descrizione
Nuovo profilo | Consente di specificare che si desidera creare un nuovo profilo di connessione.
Profilo esistente | Consente di specificare che si desidera modificare un profilo di connessione esistente. In CMAK vengono visualizzati i profili di connessione precedentemente creati nel computer.
Nota

Per creare un profilo di connessione per un'altra lingua, utilizzare la versione del sistema operativo e della Configurazione guidata Microsoft Connection Manager Administration Kit appropriate per tale lingua.

Per ulteriori informazioni sul percorso di archiviazione e sul funzionamento dei profili, vedere la pagina relativa all'impostazione dei profili del servizio nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80949.

Ulteriori riferimenti


Specificare il nome del servizio e il nome del file

Per ogni profilo di connessione che viene creato, è necessario specificare un nome di servizio e un nome di file.

Importante

Verificare che i nomi di servizio e di file utilizzati siano diversi da tutti gli altri nomi di servizio e file specificati per gli utenti in rete remoti. Se due profili di connessione nello stesso computer hanno lo stesso nome di servizio o di file, le icone di connessione associate non funzioneranno correttamente.

Impostazione Descrizione

Nome servizio

Consente di specificare il nome che viene visualizzato agli utenti nell'elenco dei profili di connessione installati nei computer di tali utenti.

Nome file

Consente di specificare il nome di file utilizzato per archiviare il profilo di connessione creato. Quando si modifica un profilo di connessione esistente, se non si desidera sovrascriverlo, sarà necessario cambiare il nome di file.

Nota

Il nome di un file non può superare 8 caratteri e non può contenere spazi né alcun simbolo.

Per ulteriori informazioni sull'assegnazione di nomi di servizio e di file a un nuovo profilo, vedere la pagina relativa all'impostazione dei nomi di servizio e di file nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=141932.

Ulteriori riferimenti


Specificare il nome di un'area di autenticazione

I nomi delle aree di autenticazione vengono utilizzati per l'autenticazione e il routing in rete. Forniscono infatti l'identificazione necessaria per inoltrare richieste di autenticazione al server in cui sono contenute le credenziali dell'utente. In Windows spesso si tratta di un nome di dominio di Servizi di dominio Active Directory®. Le informazioni relative all'area di autenticazione vengono utilizzate solo per le connessioni remote.

Impostazione | Descrizione
Non aggiungere un nome area autenticazione al nome utente | Consente di specificare che il profilo di connessione deve inviare il nome utente al server remoto esattamente così come viene digitato.
Aggiungi nome area autenticazione al nome utente | Consente di specificare che il profilo di connessione deve aggiungere il nome dell'area di autenticazione immesso in questa pagina a ogni nome utente prima che venga inviato al server remoto per l'autenticazione.
Nome area autenticazione (inclusi separatori) | Consente di specificare il testo da aggiungere al nome utente prima dell'invio al server remoto per l'autenticazione. Include il carattere separatore da utilizzare per separare il nome delle aree di autenticazione dal nome utente.
Prima del nome utente | Consente di specificare che il nome dell'area di autenticazione deve essere anteposto al nome utente. Formato utilizzato in genere quando il separatore tra il nome dell'area di autenticazione e il nome utente è il carattere '\'. Se si seleziona questa opzione, il Nome area autenticazione deve essere strutturato come il seguente: Microsoft\
Dopo il nome utente | Consente di specificare che il nome dell'area di autenticazione deve essere posposto al nome utente. Formato utilizzato in genere quando il separatore tra il nome utente e il nome dell'area di autenticazione è il carattere '@'. Se si seleziona questa opzione, il Nome area autenticazione deve essere strutturato come il seguente: @microsoft\.com

Per ulteriori informazioni sull'utilizzo delle aree di autenticazione, vedere la pagina relativa nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80950.

Ulteriori riferimenti


Unire informazioni di altri profili di connessione

Se in alcuni profili di connessione già esistenti sono contenute informazioni necessarie per il profilo di connessione che si desidera creare, è possibile utilizzare la Configurazione guidata Microsoft Connection Manager Administration Kit per unire nel profilo da creare gran parte delle informazioni incluse in tali profili di connessione esistenti. Un profilo contenente informazioni provenienti da altri profili di connessione viene indicato come profilo di primo livello. Un profilo di connessione le cui informazioni vengono unite in un altro profilo di connessione viene indicato come profilo componente.

Impostazione | Descrizione
Profili esistenti | Consente di visualizzare l'elenco di tutti i profili di connessione disponibili contenenti impostazioni che possono essere unite nel profilo corrente.
Profili da unire | Consente di visualizzare l'elenco di tutti i profili di connessione le cui impostazioni sono state selezionate per essere incluse nel profilo corrente.
Aggiungi | Consente di spostare il profilo di connessione selezionato dall'elenco Profili esistenti all'elenco Profili da unire.
Rimuovi | Consente di rimuovere dall'elenco Profili da unire il profilo di connessione selezionato.

Selezionare i profili di connessione desiderati nell'elenco di sinistra e quindi fare clic su Aggiungi per spostarli nell'elenco di destra. I profili di connessione contenuti nell'elenco di destra verranno uniti nel profilo corrente quando quest'ultimo verrà compilato.

Per ulteriori informazioni sull'unione di informazioni di più profili, vedere la pagina relativa all'unione di rubriche telefoniche e altre funzionalità dei profili del servizio esistenti nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80951.

Ulteriori riferimenti


Aggiungere supporto per le connessioni VPN

Una rete privata virtuale (VPN, Virtual Private Network) è una sessione crittografata tra il client e il server remoto a cui è connesso. Il server remoto può funzionare come router, inviando i pacchetti ricevuti dal client sulla relativa scheda di rete pubblica a una rete protetta separata collegata a una seconda scheda di rete privata. Per specificare che la connessione deve essere di tipo VPN con un server remoto, selezionare la casella di controllo appropriata nella parte superiore della finestra di dialogo. Immettere quindi il nome o l'indirizzo IP del server VPN oppure specificare un file di testo con un elenco di indirizzi o nomi di server VPN selezionabili dall'utente.

Impostazione | Descrizione
Rubrica del profilo | Consente di specificare che la connessione VPN può essere completata utilizzando le impostazione di connessione remota archiviate nella Rubrica telefonica associata al profilo di connessione.
Rubriche dei profili uniti | Consente di specificare che la connessione VPN può essere completata utilizzando le impostazioni di connessione remota archiviate nelle Rubriche telefoniche associate ai profili di connessione uniti.
Utilizza sempre lo stesso server VPN | Se selezionata, consente di specificare il nome DNS o l'indirizzo IP della VPN a cui deve connettersi il client.
Consenti all'utente di scegliere il server VPN prima della connessione | Se selezionata, consente di specificare un file di testo in cui sono elencati i server VPN che possono essere scelti dall'utente. Per ulteriori informazioni sulla formattazione dei file di testo, vedere la sezione relativa all'attivazione delle scelte utente del server VPN nella pagina sull'implementazione del supporto VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80962.
Utilizza lo stesso nome utente e password per le connessioni remote e VPN | Consente di specificare che, se l'utente stabilisce la connessione VPN tramite una connessione remota, per accedere al server VPN devono essere utilizzati gli stessi nome utente e password che consentono di accedere alla connessione remota.

Se si seleziona la casella di controllo Rubrica del profilo o Rubriche dei profili uniti per indicare che si desidera il supporto VPN nel profilo di connessione, dopo questa pagina verrà visualizzata la pagina Creazione o modifica di una voce VPN nella Configurazione guidata Microsoft Connection Manager Administration Kit. Se invece non viene selezionata alcuna delle due caselle di controllo superiori, le pagine per la configurazione delle voci VPN non verranno visualizzate.

Per ulteriori informazioni sulla configurazione del profilo per il supporto VPN, vedere la pagina relativa all'implementazione del supporto VPN nel sito Web Microsoft http://go.microsoft.com/fwlink/?LinkId=80962.

Ulteriori riferimenti

  • Creare o modificare una voce VPN

  • Voce VPN - Scheda Generale

  • Voce VPN - Scheda IPv4

  • Voce VPN - Scheda IPv6

  • Voce VPN - Scheda Sicurezza

  • Voce VPN - Scheda Avanzate


Creare o modificare una voce VPN

Utilizzare questa pagina per configurare le impostazioni di connessione e sicurezza necessarie per comunicare con uno o più server VPN che supportano il profilo di connessione.

Nota

Questa pagina viene visualizzata solo se nella pagina Aggiunta del supporto per le connessioni VPN, è stato specificato che si desidera il supporto VPN per il profilo di connessione.

Personalizzando queste impostazioni, è possibile far fronte in modo più adeguato a requisiti di autenticazione o routing in rete di determinati server VPN. Per la connessione ai server VPN viene creata e utilizzata una voce predefinita, a meno che non venga creata un'altra voce per un server specifico:

  • Se nella pagina precedente della procedura guidata è stata selezionata l'opzione Utilizza sempre lo stesso server VPN, nella voce predefinita devono essere contenute le impostazioni di configurazione utilizzate per la connessione al server VPN.

  • Se nella pagina precedente della procedura guidata è stato specificato un file di testo contenente un elenco di server VPN, la voce VPN predefinita viene utilizzata per i server a cui non è associata una voce VPN con nome corrispondente in questa pagina. Se ad esempio nell'elenco è contenuto un server VPN denominato Server-NY, verrà utilizzata la voce VPN predefinita, a meno che non sia stata creata una voce VPN denominata Server-NY.

Impostazione | Descrizione
Nuova | Consente di creare una nuova voce VPN. Se nella pagina precedente della procedura guidata è stato utilizzato un file di testo contenente un elenco di server VPN, sarà necessario creare una voce per ogni server VPN definito nel file di testo per cui la voce predefinita non è appropriata.
Modifica | Consente di modificare la voce VPN selezionata.
Elimina | Consente di eliminare la voce VPN selezionata. Non è possibile eliminare la voce contrassegnata come <Predefinita>.

Per ulteriori informazioni sulle impostazioni delle voci VPN, vedere la pagina relativa all'inserimento delle voci VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=80953. Per ulteriori informazioni sulla creazione dei file di testo contenenti elenchi di server VPN, vedere la sezione dedicata all'attivazione delle scelte utente del server VPN nella pagina relativa all'implementazione del supporto VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80962.

Ulteriori riferimenti

  • Aggiungere supporto per le connessioni VPN


Voce VPN - Scheda Generale

Utilizzare questa scheda per specificare se si desidera consentire la condivisione di file e stampanti tramite la connessione, nonché le versioni di IP che si desidera supportare.

Impostazione Descrizione

Nome

Specifica il nome della voce VPN. Se si sta modificando una voce esistente, il nome è già stato impostato e non sarà possibile modificarlo da questa posizione.

Disabilita condivisione file e stampanti

Selezionando questa casella di controllo è possibile specificare che i protocolli per la condivisione di file e stampanti non possono essere utilizzati da una connessione basata su questa voce VPN.

Consenti ai client di stabilire i tipi di connessioni seguenti

Le opzioni disponibili sono le seguenti:

  • Solo indirizzo IPv4. Specifica che il client riceve solo un indirizzo IPv4 e non può comunicare tramite IPv6.

  • Solo indirizzo IPv6. Specifica che il client riceve solo un indirizzo IPv6 e non può comunicare tramite IPv4.

  • Sia indirizzi IPv4 che IPv6. Opzione predefinita che indica che il client riceve sia indirizzi IPv4 che IPv6 e che può comunicare tramite entrambi i protocolli.

Le opzioni di configurazione per i protocolli IPv4 e IPv6 vengono impostate nelle schede IPv4 e IPv6 della finestra di dialogo Nuova voce VPN/Modifica voce VPN.

Per ulteriori informazioni sulla configurazione del supporto VPN, vedere la pagina relativa all'inserimento delle voci VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=80953.

Ulteriori riferimenti

  • Aggiungere supporto per le connessioni VPN


Voce VPN - Scheda IPv4

Utilizzare questa scheda per specificare la configurazione IP che si desidera applicare ai client che si connettono a un server VPN remoto tramite il profilo di connessione.

Impostazione Descrizione

Il server assegna gli indirizzi

Specifica che il client viene configurato in modo dinamico dal server al momento della connessione. Se gli indirizzi dei server DNS e WINS nella rete accessibile tramite VPN cambiano, sarà sufficiente modificare la configurazione nel server che fornisce tali informazioni ai client. Alla successiva connessione, tutti i client riceveranno le informazioni aggiornate.

Tutti i client utilizzano i seguenti indirizzi

Specifica che il client utilizza gli indirizzi IP immessi nelle caselle di testo sottostanti. È possibile specificare qualsiasi indirizzo o tutti gli indirizzi server supportati, inclusi gli indirizzi dei server DNS primario e secondario, nonché dei server WINS primario e secondario. Se è necessario un solo server di un tipo specifico, è necessario immetterlo nella casella di testo relativa all'indirizzo del server primario.

Se si utilizza questa opzione e in seguito si modificano gli indirizzi dei server DNS e WINS, è necessario modificare il profilo, ricompilarlo e quindi ridistribuirlo a tutti i client.

Rendi questa connessione il gateway predefinito del client

Specifica che, ogni volta che con questo profilo si esegue la connessione al server VPN remoto, l'indirizzo del gateway predefinito del client viene sostituito da quello del server VPN. Dopo questa modifica, il client indirizzerà tutto il traffico della subnet non locale tramite VPN.

Utilizza compressione intestazione IP

Specifica che nella connessione VPN viene utilizzata la compressione dell'intestazione IP per ottimizzare l'utilizzo della larghezza di banda di rete.

Per ulteriori informazioni sulla configurazione di voci VPN, vedere la pagina relativa all'inserimento delle voci VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=80953.

Ulteriori riferimenti

  • Aggiungere supporto per le connessioni VPN


Voce VPN - Scheda IPv6

Utilizzare questa scheda per specificare la configurazione del protocollo Internet versione 6 (IPv6) che si desidera applicare ai client che si connettono a un server VPN remoto tramite il profilo di connessione.

Impostazione Descrizione

Il server assegna gli indirizzi

Specifica che il client viene configurato in modo dinamico dal server al momento della connessione. Se gli indirizzi dei server DNS nella rete accessibile tramite VPN cambiano, sarà sufficiente modificare la configurazione nel server che fornisce tali informazioni ai client. Alla successiva connessione, tutti i client ricevono le informazioni aggiornate.

Tutti i client utilizzano i seguenti indirizzi

Specifica che il client viene configurato con gli indirizzi IP dei server DNS immessi nelle caselle di testo sottostanti. È possibile specificare sia un server DNS primario che uno secondario.

Se si utilizza questa opzione e in seguito si modificano gli indirizzi dei server DNS, sarà necessario modificare il profilo, ricompilarlo e quindi ridistribuirlo a tutti i client.

Rendi questa connessione il gateway predefinito del client

Specifica che l'indirizzo IP del gateway predefinito del client viene sostituito da quello del server VPN ogni volta che si esegue la connessione con questo profilo. Dopo questa modifica, il client indirizzerà tutto il traffico della subnet non locale tramite VPN.

Per ulteriori informazioni sulla configurazione di voci VPN, vedere la pagina relativa all'inserimento delle voci VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=80953.

Ulteriori riferimenti

  • Aggiungere supporto per le connessioni VPN


Voce VPN - Scheda Sicurezza

Le impostazioni di sicurezza assegnate a una voce VPN devono essere uguali alle impostazioni del server VPN a cui corrisponde la voce. Le impostazioni sono determinate dalla configurazione del server VPN. È possibile specificare se è richiesta la crittografia, quale protocollo di autorizzazione viene utilizzato, con quali protocolli VPN tentare di eseguire la connessione e secondo quale ordine di priorità.

Impostazione Descrizione

Strategia VPN

Specifica i protocolli VPN con cui tentare di eseguire la connessione e il relativo ordine di priorità. È possibile scegliere il protocollo PPTP (Point-to-Point Tunneling Protocol), L2TP (Layer Two Tunneling Protocol), SSTP (Secure Socket Tunneling Protocol) o IKEv2 (Internet Key Exchange versione 2), singolarmente oppure insieme al protocollo selezionato provato per primo. Se si specifica un singolo protocollo e tale protocollo non è supportato dal server remoto, la connessione avrà esito negativo.

Se si seleziona una delle opzioni relative al protocollo da provare per primo, l'ordine di utilizzo dei protocolli sarà il seguente:

  • PPTP: PPTP, IKEv2, SSTP e quindi L2TP

  • L2TP: PPTP, IKEv2, SSTP e quindi SSTP

  • SSTP: SSTP, IKEv2, PPTP e quindi L2TP

  • IKEv2: IKEv2, PPTP, SSTP e quindi L2TP

Note
  • IKEv2 non è supportato in sistemi operativi precedenti a Windows 7. Se si seleziona Usa solo IKEv2 e il profilo viene eseguito su un computer che esegue una versione precedente di Windows, viene invece utilizzata una delle strategie VPN seguenti:
    • Per i client che eseguono Microsoft Windows Vista con Service Pack 1 (SP1) o versione successiva, viene utilizzato solo il protocollo SSTP.

    • Per i client che eseguono Microsoft Windows Vista con nessun Service Pack installato, viene utilizzato il protocollo PPTP.

Avanzate

Questa opzione è disponibile se si seleziona una strategia VPN che include IKEv2 o L2TP.

  • Se si seleziona un'opzione che include IKEv2, è possibile attivare la funzionalità di mobilità che consente alla connessione VPN di rimanere attiva per un periodo di tempo, anche se l'indirizzo IP o la scheda di rete tramite la quale il computer si connette a Internet vengono modificati. Fare clic su Avanzate. Nella finestra di dialogo Opzioni avanzate fare clic sulla scheda IKEv2. Selezionare Mobilità e quindi la quantità di tempo che la connessione VPN può rimanere attiva prima di essere interrotta. Se il client non è in grado di ristabilire la connessione con il server VPN prima che sia trascorso l'intervallo configurato, la connessione viene interrotta. L'opzione Mobilità è attivata per impostazione predefinita.

  • Se si seleziona un'opzione che include L2TP, è possibile includere nel profilo di connessione una chiave già condivisa. Fare clic su Avanzate, e nella finestra di dialogo Impostazioni avanzate fare clic sulla scheda L2TP e quindi su Utilizza una chiave già condivisa. Utilizzare questa opzione solo se non è possibile utilizzare i certificati del computer come metodo di autenticazione. Per ulteriori informazioni sull'inserimento di una chiave già condivisa, vedere Configurare una chiave già condivisa.

Crittografia dati

Specifica il tipo di crittografia da utilizzare per il flusso di dati trasmesso o ricevuto dal server VPN remoto. Le opzioni disponibili sono le seguenti:

  • Senza crittografia. I dati vengono inviati come testo normale. La connessione non riesce se il server VPN richiede la crittografia dei dati.

    Nota

    Non è possibile utilizzare questa opzione per IKEv2 in quanto questo protocollo richiede la crittografia. Se si seleziona questa opzione e si tenta di utilizzare IKEv2, la connessione avrà esito negativo.

  • Crittografia facoltativa. I dati vengono crittografati solo se richiesto dal server VPN.

  • Richiedi crittografia. I dati vengono crittografati. La connessione non riesce se il server VPN non supporta dati crittografati.

  • Massimo livello di crittografia. I dati verranno crittografati utilizzando la tecnologia di crittografia più avanzata supportata da entrambi i computer.

L'opzione selezionata deve essere compatibile con i requisiti di crittografia del server remoto. In caso contrario, la connessione avrà esito negativo.

Utilizza EAP (Extensible Authentication Protocol)

Specifica che per l'autenticazione di accesso deve essere utilizzato il protocollo EAP (Extensible Authentication Protocol), con la possibilità di utilizzare smart card o altri certificati. Se si seleziona questa impostazione, è necessario fare clic su Proprietà per configurare le opzioni relative a EAP o ai certificati. Per ulteriori informazioni sulla pagina Proprietà PEAP o Proprietà smart card o altro certificato, premere F1 dopo aver visualizzato la pagina.

Metodi di autenticazione

Specifica altri metodi per la trasmissione delle informazioni di autenticazione al server. Si tratta di protocolli di autenticazione meno recenti che possono essere utilizzati solo se richiesto dal server VPN.

Sicurezza Nota

È consigliabile evitare l'utilizzo del protocollo PAP (Password Authentication Protocol), poiché trasmette in rete il nome utente e la password come testo normale.

Per ulteriori informazioni sulla configurazione di voci VPN, vedere la pagina relativa all'inserimento delle voci VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=80953.

Ulteriori riferimenti

  • Aggiungere supporto per le connessioni VPN


Configurare una chiave già condivisa

È possibile utilizzare una chiave già condivisa anziché un certificato digitale per l'autenticazione L2TP/IPsec dei client VPN. Le chiavi già condivise non richiedono un'infrastruttura a chiave pubblica (PKI, Public Key Infrastructure) per la distribuzione, ma sono un metodo di autenticazione vulnerabile. È possibile migliorare la sicurezza della distribuzione delle chiavi già condivise crittografandole con un PIN che gli utenti devono immettere prima di poter installare il profilo di connessione.

Sicurezza Nota

È consigliabile non utilizzare chiavi già condivise perché non considerate sicure.

Nota

La pagina Configurazione di una chiave già condivisa è disponibile nella procedura guidata solo se è stato specificato di utilizzarne una nella voce VPN della pagina Creazione o modifica di una voce VPN. Per utilizzare una chiave già condivisa, modificare la voce nella pagina della procedura guidata e nella scheda Sicurezza, fare clic su Avanzate. Nella scheda L2TP, selezionare Utilizza una chiave già condivisa.

Impostazione | Descrizione
Digitare una chiave già condivisa | Consente di specificare la chiave di crittografia utilizzata sia dal server che dal client per avviare la sessione L2TP/IPsec. La stringa deve essere costituita da un minimo di 8 e da un massimo di 256 caratteri. È necessario richiedere la chiave all'amministratore del server VPN. È consigliabile utilizzare una chiave molto lunga e crittografarla utilizzando un PIN, come descritto di seguito.
Crittografa la chiave già condivisa utilizzando un PIN | Consente di specificare che la chiave già condivisa è crittografata nel profilo di connessione e che tale profilo può essere installato solo immettendo il PIN fornito. Il PIN può essere costituito da un minimo di 4 e da un massimo di 15 caratteri alfanumerici. Digitare gli stessi caratteri in entrambe le caselle di testo.

Se dopo aver inserito una chiave nel profilo di connessione si passa a un'altra pagina, la chiave non sarà più visualizzabile. Per cambiare la chiave utilizzata in un profilo, fare clic su Sostituisci chiave e quindi immettere la nuova chiave nella casella di testo Digitare una chiave già condivisa.

Per ulteriori informazioni sull'utilizzo di chiavi già condivise, vedere la pagina relativa all'inserimento di chiavi già condivise nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80954.

Ulteriori riferimenti

  • Voce VPN - Scheda Sicurezza


Voce VPN - Scheda Avanzate

Quando il computer è connesso a una rete remota accessibile tramite VPN, è possibile specificare se si desidera che il computer client faccia parte dello spazio dei nomi DNS della rete remota e indicare il suffisso DNS che deve far parte del nome DNS registrato del client.

Impostazione | Descrizione
Suffisso DNS per questa impostazione di connessione | Specifica il nome di dominio DNS che viene aggiunto al nome del computer client per consentire l'identificazione completa del computer nella rete remota. Digitare il nome senza il punto iniziale. Se ad esempio il computer deve essere indicato come client1.esempio.com, digitare esempio.com nella casella di testo.
Registra l'indirizzo della connessione nel DNS | Selezionare questa casella di controllo se si desidera che il client registri il proprio nome e indirizzo nel server DNS nella rete remota. Il server DNS deve supportare il protocollo di aggiornamento dinamico DNS. Il nome da associare all'indirizzo e da fornire al server DNS viene determinato dall'impostazione seguente.
Utilizza il suffisso DNS di questa connessione nella registrazione DNS | Selezionare questa casella di controllo se si desidera che il client fornisca il suffisso DNS specificato al server DNS nella rete remota da associare all'indirizzo IP del computer client. Se questa casella di controllo non è selezionata, al server DNS remoto verrà fornito il suffisso DNS predefinito del computer client specificato nella scheda Nome computer della finestra di dialogo Proprietà del sistema.

Per ulteriori informazioni sulla configurazione di voci VPN, vedere la pagina relativa all'inserimento delle voci VPN nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=80953.

Ulteriori riferimenti

  • Aggiungere supporto per le connessioni VPN


Aggiungere una Rubrica telefonica personalizzata

Utilizzando Phone Book Administrator, incluso in Connection Point Services (CPS), è possibile creare un file della Rubrica telefonica contenente un elenco di più numeri di accesso per la connessione a una rete di accesso remoto. Tale rubrica telefonica può essere inclusa nel profilo di connessione utilizzando la pagina Aggiunta di una rubrica telefonica personalizzata della procedura guidata. Se si consente l'accesso al file della Rubrica telefonica tramite Internet, sarà possibile configurare il profilo in modo da scaricare automaticamente le nuove versioni del file ogni volta che il client si connette utilizzando il profilo di connessione.

Nota

Non inserendo il nome del file della Rubrica telefonica in questa pagina, si specifica che si desidera che gli utenti scarichino la Rubrica telefonica la prima volta che si connettono utilizzando il profilo. Selezionare la casella di controllo Scarica automaticamente aggiornamenti Rubrica telefonica e quindi digitare il nome della Rubrica telefonica e il percorso per il download nella pagina successiva della procedura guidata. Vedere Specificare un server per l'aggiornamento automatico della Rubrica telefonica.

Impostazione | Descrizione
File Rubrica telefonica | Consente di specificare il percorso del file della Rubrica telefonica che si desidera includere nel profilo di connessione. Se già si conosce il percorso del file, è possibile immetterlo direttamente nella casella di testo, altrimenti fare clic su Sfoglia e quindi selezionare il file.
Scarica automaticamente aggiornamenti Rubrica telefonica | Selezionare questa casella di controllo se si desidera che il client verifichi se sono disponibili versioni più recenti del file della Rubrica telefonica e aggiorni il file ogni volta che si connette alla rete tramite il profilo di connessione. Se si seleziona questa casella di controllo, subito dopo nella procedura guidata verrà visualizzata la pagina Impostazione del server per l'aggiornamento della Rubrica telefonica.
Testo relativo a Altri numeri di accesso | Consente di specificare il testo riportato nell'etichetta accanto all'elenco dei numeri di telefono visualizzati nel client.

Per ulteriori informazioni sulle Rubriche telefoniche personalizzate, incluso come scaricare e utilizzare Connection Point Services e Phone Book Administrator, vedere la pagina relativa al supporto per le rubriche telefoniche nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80955.

Ulteriori riferimenti


Specificare un server per l'aggiornamento automatico della Rubrica telefonica

I numeri di telefono forniti in una Rubrica telefonica personalizzata sono spesso soggetti a modifiche. Connection Point Services (CPS) offre un servizio per la manutenzione automatica delle Rubriche telefoniche nei profili di connessione.

Utilizzare questa pagina per specificare il percorso di download del file aggiornato. Ogni volta che un utente si connette utilizzando tale profilo, Connection Manager controlla sul server specificato se il file della Rubrica telefonica è stato modificato. Se il file sul server è più recente, Connection Manager lo scarica e aggiorna la Rubrica telefonica nel profilo di connessione.

Nota

Questa pagina è disponibile solo se si seleziona Scarica automaticamente aggiornamenti Rubrica telefonica nella pagina Aggiunta di una Rubrica telefonica personalizzata.

Impostazione | Descrizione
Nome Rubrica telefonica | Se nella pagina Aggiunta di una Rubrica telefonica personalizzata è stato specificato il nome di una rubrica telefonica, non sarà possibile modificarlo da questa posizione. Se invece non è stato specificato in quella pagina ed è stata selezionata la casella di controllo Scarica automaticamente aggiornamenti Rubrica telefonica, sarà necessario digitare il nome del file della Rubrica telefonica in questa casella. Il nome del file deve essere pubblicato nel server CPS specificato nella casella di testo Server Connection Point Services.
Server Connection Point Services | URL del server CPS in cui verranno inserite le copie aggiornate della Rubrica telefonica.

Per ulteriori informazioni sull'inserimento nel Web di file della Rubrica telefonica nuovi o aggiornati accessibili ai client, vedere la pagina relativa al supporto delle rubriche telefoniche nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80955. Per ulteriori informazioni sull'impostazione di un server Connection Point Services, vedere la pagina relativa a Connection Point Services nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=141964.

Ulteriori riferimenti

  • Aggiungere una Rubrica telefonica personalizzata


Configurare le voci di connessione remota

Un numero di telefono per la connesione remota nella rubrica telefonica personalizzata specificata nella pagina Aggiunta di una Rubrica telefonica personalizzata viene indicato come POP (Point of Presence). Per ogni POP creato tramite lo strumento Phone Book Administrator è possibile specificare una Voce di connessione remota nella relativa scheda Impostazioni. Se questa impostazione corrisponde a una voce specificata nella pagina Configurazione delle voci di connessione remota della Configurazione guidata Microsoft Connection Manager Administration Kit, tale voce di connessione remota verrà utilizzata per configurare un client con un indirizzo IP, server DNS e WINS e impostazioni di sicurezza. Se l'impostazione nella Rubrica telefonica non corrisponde a una delle voci di connessione remota specificate nella Configurazione guidata Microsoft Connection Manager Administration Kit, per la connessione verrà utilizzata la voce contrassegnata come <Predefinita>.

Impostazione | Descrizione
Nuova | Consente di creare una nuova voce di connessione remota. Il nome deve corrispondere alla Voce di connessione remota della rubrica personalizzata specificata nella pagina precedente della Configurazione guidata Microsoft Connection Manager Administration Kit.
Modifica | Consente di modificare la voce di connessione remota attualmente selezionata.
Elimina | Consente di eliminare la voce di connessione remota attualmente selezionata. Non è possibile eliminare la voce contrassegnata come <Predefinita>.

La finestra di dialogo visualizzata quando si fa clic su Nuovo o Modifica include le schede seguenti:

  • Voce di connessione remota - Scheda Generale

  • Voce di connessione remota - Scheda IPv4

  • Voce di connessione remota - Scheda IPv6

  • Voce di connessione remota - Scheda Sicurezza

  • Voce di connessione remota - Scheda Avanzate

Per ulteriori informazioni sulla configurazione delle voci di connessione remota vedere la pagina relativa all'inserimento delle voci di connessione remota personalizzate nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80957.

Ulteriori riferimenti


Voce di connessione remota - Scheda Generale

Utilizzare questa scheda per specificare se si desidera consentire la condivisione di file e stampanti tramite la connessione, nonché le versioni di IP che si desidera supportare.

Impostazione Descrizione

Nome

Specifica il nome della voce di connessione remota. Se si sta modificando una voce esistente, il nome è già stato impostato e non sarà possibile modificarlo da questa posizione.

Disabilita condivisione file e stampanti

Selezionare questa casella di controllo per specificare che i protocolli utilizzati per la condivisione di file e stampanti non possono essere utilizzati dalla connessione.

Consenti ai client di stabilire i tipi di connessioni seguenti

Le opzioni disponibili sono le seguenti:

  • Solo indirizzo IPv4. Specifica che il client riceve solo un indirizzo IPv4 e non può comunicare tramite IPv6.

  • Solo indirizzo IPv6. Specifica che il client riceve solo un indirizzo IPv6 e non può comunicare tramite IPv4.

  • Sia indirizzi IPv4 che IPv6. Opzione predefinita che indica che il client riceve sia indirizzi IPv4 che IPv6 e che può comunicare tramite entrambi i protocolli.

Le opzioni di configurazione per i protocolli IPv4 e IPv6 vengono impostate nelle schede IPv4 e IPv6 di questa finestra di dialogo.

Script di connessione remota

Se richiesto, specifica un file script che viene eseguito come parte del processo di connessione per personalizzare ulteriormente l'ambiente di connessione remota.

Per ulteriori informazioni sulla configurazione di voci di connessione remota, vedere la pagina relativa all'inserimento delle voci di connessione remota nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80957.

Ulteriori riferimenti

  • Configurare le voci di connessione remota


Voce di connessione remota - Scheda IPv4

Utilizzare questa scheda per specificare la configurazione del protocollo Internet versione 6 (IPv6) che si desidera applicare ai client che si connettono a un server di connessione remota tramite il profilo di connessione.

Impostazione Descrizione

Il server assegna gli indirizzi

Specifica che il client viene configurato in modo dinamico dal server al momento della connessione. Se gli indirizzi dei server DNS e WINS nella rete remota cambiano, sarà sufficiente modificare la configurazione nel server che fornisce tali informazioni al client. Alla successiva connessione, tutti i client riceveranno le informazioni aggiornate.

Tutti i client utilizzano i seguenti indirizzi

Specifica che il client utilizza gli indirizzi IP immessi nelle caselle di testo sottostanti. È possibile specificare qualsiasi indirizzo o tutti gli indirizzi server supportati, inclusi gli indirizzi dei server DNS primario e secondario, nonché dei server WINS primario e secondario. Se è necessario un solo server di un tipo specifico, è necessario immetterlo nella casella di testo relativa all'indirizzo del server primario.

Se si utilizza questa opzione e in seguito si modificano gli indirizzi dei server DNS e WINS, è necessario modificare il profilo, ricompilarlo e quindi ridistribuirlo a tutti i client.

Rendi questa connessione il gateway predefinito del client

Specifica che ogni volta che si esegue la connessione con questo profilo, l'indirizzo IP del gateway predefinito del client viene sostituito con l'indirizzo IP del server di connessione remota. Dopo questa modifica, il client indirizzerà tutto il traffico della subnet non locale tramite la connessione remota.

Utilizza compressione intestazione IP

Specifica che nella connessione remota viene utilizzata la compressione dell'intestazione IP per ottimizzare l'utilizzo della larghezza di banda di rete.

Per ulteriori informazioni sulla configurazione di voci di connessione remota, vedere la pagina relativa all'inserimento delle voci di connessione remota personalizzate nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80957.

Ulteriori riferimenti

  • Configurare le voci di connessione remota


Voce di connessione remota - Scheda IPv6

Utilizzare questa scheda per specificare la configurazione del protocollo Internet versione 6 (IPv6) che si desidera applicare ai client che si connettono a un server di connessione remota tramite il profilo di connessione.

Impostazione Descrizione

Il server assegna gli indirizzi

Specifica che il client viene configurato in modo dinamico dal server al momento della connessione. Se gli indirizzi dei server DNS cambiano, sarà sufficiente modificarli nel server che li fornisce al client. Alla successiva connessione, tutti i client riceveranno le informazioni aggiornate.

Tutti i client utilizzano i seguenti indirizzi

Specifica che il client viene configurato con gli indirizzi IP dei server DNS immessi nelle caselle di testo sottostanti. È possibile specificare sia un server DNS primario che uno secondario.

Se si utilizza questa opzione e in seguito si modificano gli indirizzi dei server DNS, sarà necessario modificare il profilo, ricompilarlo e quindi ridistribuirlo a tutti i client.

Rendi questa connessione il gateway predefinito del client

Specifica che ogni volta che si esegue la connessione con questo profilo, l'indirizzo IP del gateway predefinito del client viene sostituito con l'indirizzo IP del server di connessione remota. Dopo questa modifica, il client indirizzerà tutto il traffico della subnet non locale tramite la connessione remota.

Per ulteriori informazioni sulla configurazione di voci di connessione remota, vedere la pagina relativa all'inserimento delle voci di connessione remota personalizzate nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80957.

Ulteriori riferimenti

  • Configurare le voci di connessione remota


Voce di connessione remota - Scheda Sicurezza

Utilizzare questa scheda per specificare se è necessaria la crittografia e il protocollo di autenticazione utilizzato per scambiare le credenziali. Le impostazioni di sicurezza assegnate a una voce di connessione remota devono essere uguali alle impostazioni del server di accesso remoto a cui corrisponde la voce. Se le impostazioni non corrispondono, il tentativo di connessione avrà esito negativo.

Impostazione Descrizione

Crittografia dati

Specifica il tipo di crittografia da utilizzare per il flusso di dati trasmesso o ricevuto dal server remoto. Le opzioni disponibili sono le seguenti:

  • Senza crittografia. I dati vengono inviati come testo normale. La connessione non riesce se il server remoto richiede la crittografia dei dati.

  • Crittografia facoltativa. I dati vengono crittografati solo se richiesto dal server remoto.

  • Richiedi crittografia. I dati vengono crittografati. La connessione non riesce se il server remoto non supporta dati crittografati.

  • Massimo livello di crittografia. I dati vengono crittografati utilizzando la tecnologia di crittografia più avanzata supportata da entrambi i computer.

L'opzione selezionata deve essere compatibile con i requisiti di crittografia del server remoto. In caso contrario, la connessione avrà esito negativo.

Utilizza EAP (Extensible Authentication Protocol)

Specifica che per l'autenticazione di accesso deve essere utilizzato il protocollo EAP, con la possibilità di utilizzare smart card o altri certificati. Se si seleziona questa impostazione, è necessario fare clic su Proprietà per configurare le opzioni relative a EAP o ai certificati. Per ulteriori informazioni sulla pagina Proprietà PEAP o Proprietà smart card o altro certificato, premere F1 dopo aver visualizzato la pagina.

Metodi di autenticazione

Specifica altri metodi per la trasmissione delle informazioni di autenticazione al server. Si tratta di protocolli di autenticazione meno recenti che possono essere utilizzati solo se il server di connessione remota lo richiede.

Sicurezza Nota

È consigliabile evitare l'utilizzo del protocollo PAP (Password Authentication Protocol), poiché trasmette in rete il nome utente e la password come testo normale.

Per ulteriori informazioni sulla configurazione di voci di connessione remota, vedere la pagina relativa all'inserimento delle voci di connessione remota personalizzate nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80957.

Ulteriori riferimenti

  • Configurare le voci di connessione remota


Voce di connessione remota - Scheda Avanzate

Utilizzare questa scheda per specificare che il computer client faccia parte dello spazio dei nomi DNS della rete remota e indicare il suffisso DNS che deve far parte del nome DNS registrato del client.

Impostazione | Descrizione
Suffisso DNS per questa impostazione di connessione | Specifica il nome di dominio DNS che viene aggiunto al nome del computer client per consentire l'identificazione completa del computer nella rete remota. Digitare il nome senza il punto iniziale. Se ad esempio il computer deve essere indicato come client1.example.com, digitare example.com nella casella di testo.
Registra l'indirizzo della connessione nel DNS | Selezionare questa casella di controllo se si desidera che il client registri il proprio nome e indirizzo nel server DNS nella rete remota. Il server DNS deve supportare il protocollo di aggiornamento dinamico DNS. Il nome da associare all'indirizzo e da fornire al server DNS viene determinato dall'impostazione seguente.
Utilizza il suffisso DNS di questa connessione nella registrazione DNS | Selezionare questa casella di controllo se si desidera che il client fornisca il suffisso DNS specificato al server DNS nella rete remota da associare all'indirizzo IP del computer client. Se questa casella di controllo non è selezionata, al server DNS remoto verrà fornito il suffisso DNS predefinito del computer client specificato nella scheda Nome computer della finestra di dialogo Proprietà del sistema.

Per ulteriori informazioni sulla configurazione di voci di connessione remota, vedere la pagina relativa all'inserimento delle voci di connessione remota personalizzate nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80957.

Ulteriori riferimenti

  • Configurare le voci di connessione remota


Specificare gli aggiornamenti delle tabelle di routing

Utilizzare questa pagina per modificare le tabelle di routing del client in base alle impostazioni specificate in un profilo di connessione in modo da migliorare la gestione della sicurezza e del traffico di rete. È possibile includere un file di aggiornamento delle tabelle di routing nel profilo di connessione, specificare l'URL di un server in cui cercare gli eventuali aggiornamenti disponibili o eseguire entrambe le operazioni.

Impostazione | Descrizione
Non modificare le tabelle di routing | Consente di specificare che le tabelle di routing del client non devono essere modificate quando si utilizza il profilo di connessione. Il computer client ha accesso sia all'insieme di reti originale che alla rete remota fornita dal profilo di connessione. Qualsiasi rete aggiuntiva disponibile tramite router connessi alla rete remota è accessibile solo se il gateway predefinito per il client viene modificato nel server di accesso remoto. Per modificare il gateway predefinito, vedere le tabelle IPv4 e IPv6 nelle pagine della procedura guidata Aggiungi/Modifica voce VPN e Aggiungi/Modifica voce di connessione remota.
Definisci aggiornamento tabella di routing | Consente di specificare che le tabelle di ruoting devono essere aggiornate durante il processo di connessione, come indicato dalle due opzioni successive.
File di route da includere | Consente di specificare il file di aggiornamento delle tabelle di routing che viene compilato nel profilo di connessione e installato nei computer client con tale profilo.
URL per il file di route | Consente di specificare che il file di aggiornamento delle tabelle di routing è ospitato sul server Web all'URL specificato. Il file viene scaricato automaticamente e applicato ogni volta che il profilo si connette.
Se l'indirizzo URL non è disponibile, disconnetti il client | Se selezionata, consente di specificare che la connessione verrà interrotta se il file di aggiornamento delle tabelle di routing non può essere scaricato.

Per ulteriori informazioni su come creare il file di aggiornamento delle tabelle di routing, vedere la pagina relativa all'inserimento degli aggiornamenti delle tabelle di routing nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80963.

Ulteriori riferimenti


Configurare le impostazioni del proxy per Internet Explorer

Utilizzare questa pagina della procedura guidata per specificare le informazioni che definiscono la modalità di individuazione e utilizzo dei server proxy da parte del client. Un server proxy garantisce all'utente l'accesso alle risorse di rete interne ed esterne appropriate tramite il profilo di connessione.

Impostazione | Descrizione
Non configurare le impostazioni del proxy | Consente di specificare che le impostazioni del proxy nel computer client non devono essere modificate dopo la connessione tramite il profilo di connessione.
Copia automaticamente nell'interfaccia tunnel le impostazioni proxy di Internet Explorer per l'utente corrente. | Consente di specificare che se il computer client ha Internet Explorer installato, le impostazioni del proxy già configurate in Internet Explorer corrispondono alle impostazioni utilizzate per la connessione alla rete remota.
Configura automaticamente le impostazioni del proxy | Consente di specificare che le impostazioni del proxy in File impostazioni proxy devono essere applicate al computer dopo che è stata stabilita la connessione.
File impostazioni proxy | Consente di specificare il file contenente la configurazione del proxy da applicare al computer client.
Ripristina le impostazioni originali del proxy dopo la disconnessione | Se si seleziona questa opzione, le impostazioni originali dell'utente vengono salvate prima dell'applicazione del file di impostazioni del proxy. Tali impostazioni verranno ripristinate al termine della connessione alla rete remota.

Per ulteriori informazioni sulla creazione di un file di impostazioni del proxy, vedere la pagina relativa all'utilizzo della configurazione automatica del proxy nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80964.

Ulteriori riferimenti


Aggiungere operazioni personalizzate

Utilizzare questa pagina per includere nei profili di connessione operazioni personalizzate da eseguire quando gli utenti si connettono al servizio. È possibile utilizzare queste operazioni per migliorare la modalità di esecuzione delle connessioni per gli utenti fornendo programmi aggiuntivi che si avviano automaticamente durante la connessione al servizio. Queste operazioni personalizzate possono avviarsi automaticamente e utilizzare programmi già installati nei computer degli utenti oppure è possibile includerli nel profilo del servizio.

Impostazione | Descrizione
Tipo operazione | Consente di filtrare l'elenco Operazioni personalizzate in modo da includere solo le operazioni del tipo selezionato.
Operazioni personalizzate | Visualizza l'elenco delle operazioni personalizzate attualmente definite nel profilo di connessione. Alcune potrebbero essere già presenti a seguito di selezioni effettuate nelle pagine precedenti della procedura guidata. Quando il profilo viene utilizzato sul computer client, le operazioni vengono eseguite nell'ordine visualizzato. È possibile modificare l'ordine selezionando un'operazione e facendo clic sul pulsante freccia SU o freccia GIÙ accanto all'elenco.
Nuova | Consente di aggiungere una nuova operazione personalizzata al profilo di connessione. Vedere la sezione Finestra di dialogo Nuova operazione personalizzata/Modifica operazione personalizzata in questo argomento.
Modifica | Consente di modificare un'operazione personalizzata esistente. Vedere la sezione Finestra di dialogo Nuova operazione personalizzata/Modifica operazione personalizzata in questo argomento.
Elimina | Consente di rimuovere dall'elenco l'operazione personalizzata selezionata.

Finestra di dialogo Nuova operazione personalizzata/Modifica operazione personalizzata

Quando si sceglie di aggiungere o modificare un'operazione personalizzata, questa finestra di dialogo consente di configurare l'operazione.

Impostazione Descrizione

Descrizione

Consente di specificare il nome dell'operazione personalizzata.

Programma da eseguire

Consente di specificare il comando, il programma eseguibile, la DLL (libreria di collegamento dinamico) o il file batch da eseguire per effettuare l'operazione personalizzata. Se il file è già presente nei computer client, specificarne il percorso. È possibile utilizzare variabili di ambiente come ad esempio %SystemRoot%.

Parametri

Consente di specificare le opzioni della riga di comando necessarie per l'operazione personalizzata. Se il programma è una DLL, il primo parametro è in genere il nome della funzione nella DLL da richiamare.

Tipo operazione

Consente di specificare quando deve essere richiamata l'operazione durante il processo di connessione. Sono disponibili le opzioni seguenti:

  • Pre-inizializzazione

  • Preconnessione

  • Pre-composizione (solo per connessioni remote)

  • Pre-tunnel (solo per connessioni VPN)

  • Post-connessione

  • Controllato

  • Disconnessione

  • Su annullamento

  • Su errore

Esegui questa operazione personalizzata per

Consente di specificare la condizione in cui viene eseguita l'operazione personalizzata. Sono disponibili le opzioni seguenti:

  • Tutte le connessioni

  • Tutte le connessioni remote

  • Tutte le connessioni che implicano un tunnel

  • Connessioni che utilizzano solo un tunnel

  • Connessioni solo remote

Includi il programma per l'operazione personalizzata nel profilo del servizio

Se il programma eseguibile dell'operazione non fa parte della distribuzione standard per i computer client, è possibile includere il file nel profilo in modo che venga installato quando l'utente installa il profilo di connessione. Il file verrà installato nella cartella contenente il profilo di connessione.

Il programma interagisce con l'utente

Consente di specificare che l'operazione personalizzata deve essere eseguita solo se Connection Manager è in uno stato interattivo. Se questa casella di controllo non è selezionata e Connection Manager è in uno stato non interattivo, un programma chiamato dall'operazione personalizzata che tenti di interagire con l'utente interromperà il processo di connessione a tempo indeterminato in attesa di una risposta da parte dell'utente.

Richiedi elevazione dei privilegi

Consente di specificare che per l'esecuzione dell'operazione personalizzata devono essere utilizzati privilegi amministrativi. Se l'opzione Controllo dell'account utente è attivata, selezionando questa casella di controllo Connection Manager chiederà all'utente l'autorizzazione per continuare, se l'utente è membro del gruppo Administrators, altrimenti chiederà di specificare credenziali di amministratore.

Per ulteriori informazioni sulle operazioni personalizzate, i tipi di operazione e i parametri sostituibili nelle variabili, vedere la pagina relativa all'inserimento di operazioni personalizzate nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80965.

Ulteriori riferimenti


Visualizzare bitmap e icone personalizzate

In Connection Manager è incluso un insieme predefinito di immagini e icone che vengono visualizzate quando l'utente esegue il profilo di connessione. È tuttavia possibile specificare immagini e icone alternative nelle pagine Visualizzazione di una bitmap di accesso personalizzata, Visualizzazione di una bitmap personalizzata per la Rubrica telefonica e Visualizzazione di icone personalizzate della Configurazione guidata Microsoft Connection Manager Administration Kit.

Per bitmap di accesso e bitmap della Rubrica telefonica personalizzate

Impostazione | Descrizione
Immagine predefinita | Consente di specificare che per il profilo di connessione deve essere visualizzata la bitmap predefinita di Connection Manager.
Immagine personalizzata | Consente di specificare il percorso e il nome del file di una bitmap da utilizzare per il profilo di connessione.

Per icone personalizzate

Impostazione | Descrizione
Icone predefinite | Consente di specificare che per il profilo di connessione devono essere visualizzate le tre icone predefinite di Connection Manager.
Icone personalizzate | Consente di specificare il percorso e i nomi dei file di due icone di dimensioni diverse utilizzate per il profilo di connessione.

Per ulteriori informazioni su come creare e configurare immagini personalizzate per il profilo di connessione vedere la pagina relativa all'inserimento di immagini personalizzate nel sito Web Microsoft all'indizzo http://go.microsoft.com/fwlink/?LinkId=80966 e la pagina relativa all'inserimento di icone personalizzate nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=142059.

Ulteriori riferimenti


Personalizzare il menu di scelta rapida dell'area di notifica

Nei sistemi operativi Windows XP, Windows Server 2003 e Windows 2000 viene visualizzata un'icona nell'area di notifica della barra delle applicazioni quando l'utente è connesso al servizio. Se l'utente fa clic con il pulsante destro del mouse su tale icona, viene visualizzato un menu di scelta rapida. In questo menu sono disponibili collegamenti a programmi specifici. I comandi predefiniti del menu sono Stato, Disconnetti e Apri connessione di rete. Mediante la Configurazione guidata Microsoft Connection Manager Administration Kit è possibile personalizzare questo menu di scelta rapida specificando gli eventuali altri comandi che si desidera vengano visualizzati.

Nota

Questa icona è disponibile solo in Windows XP, Windows Server 2003 e Windows 2000. È per questo che la pagina della procedura guidata è disponibile solo quando si crea un profilo che utilizza l'opzione Windows Server 2003, Windows XP o Windows 2000 nella pagina della procedura guidata Selezione del sistema operativo di destinazione.

Impostazione | Descrizione
Nuova | Consente di aggiungere una nuova voce del menu di scelta rapida all'icona nell'area di notifica della barra delle applicazioni.
Modifica | Consente di modificare una voce del menu di scelta rapida precedentemente creata.
Elimina | Consente di eliminare dal menu la voce selezionata.

Quando si crea o si modifica una voce di menu, viene visualizzata la finestra di dialogo Nuovo comando di scelta rapida o Modifica comando di scelta rapida rispettivamente. Questa finestra di dialogo consente di personalizzare le impostazioni descritte nella tabella seguente.

Impostazione | Descrizione
Nome comando | Consente di specificare il testo che viene visualizzato nel menu di scelta rapida quando l'utente fa clic con il pulsante destro del mouse sull'icona. Utilizzare & prima del carattere che deve essere utilizzato come tasto di scelta rapida per l'opzione di menu. Ad esempio, se si desidera che il testo Comando venga visualizzato con la C sottolineata e utilizzato come tasto di scelta rapida, digitare la stringa &Comando. Per includere una e commerciale nel testo, utilizzare &&.
Programma da eseguire | Consente di specificare il file da eseguire quando l'utente sceglie la voce di menu. Se il file non è incluso nella variabile di ambiente %PATH% dell'utente, sarà necessario specificare il percorso completo in modo che il file possa essere individuato da Connection Manager quando viene scelta l'opzione di menu.
Parametri | Consente di specificare gli eventuali parametri aggiuntivi della riga di comando da passare al programma per il contesto.
Includi il programma nel profilo del servizio | Se il file eseguibile non è già presente nel computer client, è possibile includerlo nel profilo di connessione. Verrà così installato nella stessa cartella degli altri file dei profili di connessione nel computer client.

Per ulteriori informazioni sulla modifica del menu di scelta rapida, vedere la pagina relativa alla personalizzazione del menu di scelta rapida dell'area di notifica nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80958.

Ulteriori riferimenti


Includere un file della Guida personalizzato

Utilizzare questa pagina per fornire una Guida di Connection Manager personalizzata agli utenti che si connettono alla rete.

Il file della Guida che è possibile includere dipende dal sistema operativo selezionato nella pagina Selezione del sistema operativo di destinazione della Configurazione guidata Microsoft Connection Manager Administration Kit:

  • Se è stata selezionata l'opzione Windows 7 o Windows Vista, è possibile includere un file con estensione chm nel profilo di connessione. Per ulteriori informazioni su come creare un file chm personalizzato, vedere la pagina relativa alla guida di Connection Manager per i file chm nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80959

  • Se è stata selezionata l'opzione Windows Server 2003, Windows XP o Windows 2000, è possibile includere un file con estensione hlp nel profilo di connessione. Per ulteriori informazioni su come creare un file con estensione hlp personalizzato, vedere la pagina relativa alla guida di Windows per i file hlp nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80970.

Impostazione | Descrizione
File della Guida predefinito | Consente di specificare che deve essere visualizzata la Guida predefinita di Connection Manager inclusa in Windows quando gli utenti premono F1 o fanno clic su ? durante l'esecuzione del profilo di connessione.
File della Guida personalizzato | Consente di specificare che deve essere visualizzato il file della Guida personalizzato quando gli utenti premono F1 o fanno clic su ? durante l'esecuzione del profilo di connessione. Digitare il percorso e il nome del file personalizzato o fare clic su Sfoglia per selezionare il file.

Nella tabella seguente vengono riepilogati i file della Guida che vengono visualizzati agli utenti. Con “recente” si fa riferimento all'opzione Windows 7 o Windows Vista nella pagina Selezione del sistema operativo di destinazione della procedura guidata. Con “precedente" si fa riferimento all'opzione Windows XP, Windows Server 2003 o Windows 2000 nella pagina Selezione del sistema operativo di destinazione della procedura guidata.

Opzione selezionata per il profilo | Sistema operativo installato | File incluso dall'amministratore di CMAK | Guida visualizzata all'utente
Precedente | Precedente | File con estensione hlp personalizzato | File con estensione hlp personalizzato
Precedente | Precedente | Nessun file della Guida personalizzato | File con estensione hlp predefinito nel sistema operativo
Recente | Recente | File con estensione chm personalizzato | File con estensione chm personalizzato
Recente | Recente | Nessun file della Guida personalizzato | File con estensione chm predefinito nel sistema operativo
Precedente | Recente | - | File con estensione chm predefinito nel sistema operativo
Recente | Precedente | - | Non funziona (il profilo non è installato)

Ulteriori riferimenti


Visualizzare informazioni personalizzate relative al supporto

Utilizzare questa pagina per specificare le informazioni da visualizzare nella finestra di dialogo di accesso, direttamente al di sopra di Stato connessione. Nella riga di testo in genere viene fornito agli utenti un numero da chiamare per ottenere supporto tecnico, ad esempio "Chiamare 800-xxx-xxxx per l'assistenza tecnica". Per questa opzione non è previsto un testo predefinito. Se non si specifica una riga di testo, quest'area della finestra di dialogo di accesso rimarrà vuota.

Impostazione | Descrizione
Informazioni sul supporto | Consente di specificare una stringa di testo di circa 50 caratteri da visualizzare agli utenti nella finestra di dialogo di accesso.

È consigliabile inserire le stesse informazioni sui contatti anche nel file Leggimi o in altre istruzioni per l'installazione fornite agli utenti, in modo che questi possano consultarle anche qualora la finestra di dialogo di accesso non venga visualizzata.

Se le informazioni sui contatti variano a seconda del luogo da cui viene eseguita la chiamata, è possibile personalizzare la Guida in modo da elencare tutti i numeri del supporto tecnico, garantendo così l'accesso al servizio anche agli utenti remoti che si spostano al di fuori della consueta zona di assistenza. Nella riga di testo della finestra di dialogo di accesso è quindi possibile includere un riferimento alla Guida, ad esempio "Per i numeri di telefono del supporto tecnico, fare clic su ?.". In questo caso, aggiungere un collegamento all'argomento contenente i numeri del supporto tecnico. Per ulteriori informazioni sulla personalizzazione della Guida, vedere Includere un file della Guida personalizzato.

Ulteriori riferimenti


Includere il software di Connection Manager nel profilo di connessione

Per poter eseguire un profilo di connessione creato per Connection Manager 1.4, gli utenti devono avere installato Connection Manager 1.4 nel proprio computer. Se questo componente non è già installato, è necessario includere il software nel profilo del servizio. Utilizzare questa pagina per specificare che si desidera includere tale software nel profilo del servizio da creare, in modo che il software venga installato quando l'utente installa il profilo del servizio.

Nota

Questa pagina è disponibile solo quando CMAK viene eseguito su una versione a 32 bit di Windows selezionando l'opzione Windows XP, Windows Server 2003 e Windows 2000 nella pagina Selezione del sistema operativo di destinazione della procedura guidata. Tutte le versioni successive di Windows e tutte le versioni a 64 bit di Windows supportate hanno già installato Connection Manager 1.4.

Impostazione | Descrizione
Installa Connection Manager 1.4 con il profilo di Connection Manager | Se selezionata, consente di specificare che la versione 1.4 del software di Connection Manager deve essere inclusa nel profilo e installata nel computer client qualora sia presente una versione di Connection Manager meno recente o non sia installata alcuna versione di tale software.

Se si include Connection Manager 1.4 nel profilo del servizio e un utente ha installata una versione precedente di Connection Manager, il software verrà aggiornato automaticamente al momento dell'installazione. Connection Manager non verrà invece installato se nel computer dell'utente è installata la versione corrente o una versione successiva del software. Ad esempio, poiché Connection Manager 1.4 è un componente del sistema operativo Microsoft Windows Vista, non verrà installato da tale profilo su computer che eseguono Microsoft Windows Vista. Il profilo di connessione invece verrà installato comunque, anche se il software di Connection Manager in esso incluso non è richiesto.

Ulteriori riferimenti


Visualizzare un contratto di licenza personalizzato

Utilizzare questa pagina per includere il proprio contratto di licenza nel profilo di connessione. Tale contratto di licenza verrà visualizzato quando l'utente fa clic su OK per avviare l'installazione iniziale del profilo di connessione. Se l'utente accetta il contratto di licenza, l'installazione continua. In caso contrario, l'installazione viene annullata.

Utilizzare un editor di testo normale, ad esempio il Blocco note, per creare il contratto di licenza come file di testo con estensione txt. Per evitare problemi di formattazione, non utilizzare ritorni a capo, ovvero interruzioni di riga forzate, alla fine delle righe per forzare il ritorno a capo. Il ritorno a capo viene applicato automaticamente quando il contratto di licenza viene visualizzato durante l'installazione del profilo.

Impostazione | Descrizione
Nome file | Consente di specificare il nome di un file di testo che viene visualizzato agli utenti durante l'installazione del profilo di connessione.

Ulteriori riferimenti


Installare file aggiuntivi con il profilo di connessione

Utilizzare questa pagina per includere nel profilo di connessione file aggiuntivi contenenti informazioni utili agli utenti per implementare il servizio. Tutti i file necessari per il servizio non specificati in altre pagine della Configurazione guidata Microsoft Connection Manager Administration Kit devono essere specificati nella pagina Installazione di file aggiuntivi con il profilo di Connection Manager.

Impostazione | Descrizione
File aggiuntivi | Consente di visualizzare l'elenco dei file attualmente selezionati per essere installati con il profilo di connessione nel computer client.
Aggiungi | Consente di individuare e selezionare un file aggiuntivo da includere nel profilo di connessione.
Rimuovi | Consente di eliminare il file selezionato dall'elenco dei file da includere nel profilo di connessione.

Per ulteriori informazioni sull'inserimento di file aggiuntivi nel profilo di connessione, vedere la pagina relativa nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80960.

Ulteriori riferimenti


Generare il profilo di connessione e il relativo programma di installazione

Quando la Configurazione guidata Microsoft Connection Manager Administration Kit è pronta per generare un profilo di connessione, fare clic su Avanti. Dopo che il profilo di connessione è stato generato, viene visualizzata una finestra di dialogo con il percorso e il nome di file utilizzati dalla procedura guidata per salvarlo.

Attenzione

Dopo aver fatto clic su Avanti nella pagina Generazione del profilo di Connection Manager e del relativo programma di installazione, il pulsante Indietro non sarà più disponibile. Per modificare il profilo, sarà pertanto necessario eseguire di nuovo la Configurazione guidata Microsoft Connection Manager Administration Kit.

Impostazione | Descrizione
Personalizzazione avanzata | Consente di specificare che si desidera configurare manualmente le impostazioni avanzate nei file di configurazione del profilo di connessione prima di compilare il profilo per creare un file del programma di installazione. Per ulteriori informazioni, vedere Effettuare personalizzazioni avanzate.

Al termine della compilazione del profilo di connessione, è possibile continuare con la personalizzazione avanzata manuale, inclusa la modifica dei file con estensione chm e di altri file del profilo del servizio. Dopo aver completato la personalizzazione avanzata, ricordarsi di eseguire di nuovo la Configurazione guidata Microsoft Connection Manager Administration Kit in modo da includere i file personalizzati nel programma di installazione del profilo di connessione.

Ulteriori riferimenti


Effettuare personalizzazioni avanzate

La Configurazione guidata Microsoft Connection Manager Administration Kit è in grado di supportare la maggior parte delle funzionalità di personalizzazione necessarie agli amministratori per creare un profilo di Connection Manager personalizzato. È comunque possibile personalizzare ulteriori funzionalità modificando i file del profilo di connessione e quindi modificando la modalità di gestione di alcune funzioni da parte di Connection Manager.

Impostazione | Descrizione
Nome file | Specifica il nome del file da modificare. Le opzioni disponibili in Nome sezione variano in base al file selezionato. È possibile modificare il file con estensione cms o cmp associato al profilo di connessione.
Nome sezione | Consente di specificare il nome della sezione contenente un'impostazione che si desidera modificare. Le opzioni disponibili in Nome chiave variano in base al nome di sezione selezionato.
Nome chiave | Consente di specificare la singola impostazione che si desidera modificare. Quando si seleziona un nome di chiave, il valore corrente assegnato nel file viene visualizzato nella casella di testo Valore.
Valore | Consente di specificare il valore che si desidera assegnare all'impostazione di configurazione.
Applica | Consente di modificare il valore assegnato al nome della chiave nella sezione e nel file indicati.

Per ulteriori informazioni sui file, le sezioni, i nomi di chiavi e i valori che è possibile configurare, vedere la pagina relativa alla personalizzazione avanzata nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80967.

Ulteriori riferimenti


Profilo di connessione creato e pronto per la distribuzione

Il profilo del servizio è stato compilato in un file eseguibile che può essere distribuito agli utenti. I passaggi successivi possono essere costituiti da una combinazione qualsiasi delle operazioni seguenti:

  • Firmare l'eseguibile del profilo del servizio.

  • Testare il profilo del servizio.

  • Includere Connection Manager in applicazioni personalizzate.

  • Distribuire il profilo del servizio.

  • Risolvere i problemi relativi al profilo del servizio.

Per informazioni sui passaggi necessari per distribuire il profilo di connessione, vedere la pagina relativa alla fase 4 sulla preparazione per l'integrazione, la distribuzione e l'installazione nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80961.

Per informazioni sui test dei profili, vedere la la pagina relativa alla fase 5 sui test dei risultati finali nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=142065.

Per informazioni sulla risoluzione dei problemi dei profili, vedere la pagina relativa alla fase 6 sull'assistenza agli utenti nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=142066.

Ulteriori riferimenti


Risolvere i problemi relativi al processo di creazione di un profilo di connessione

Il processo di generazione di un profilo di connessione a volte può avere esito negativo. Di seguito vengono descritte alcune delle cause più comuni di errori durante tale processo:

  • Durante l'esecuzione della Configurazione guidata Microsoft Connection Manager Administration Kit non vengono trovati uno o più file specificati.

    È sempre consigliabile ricercare e selezionare il file anziché digitarne manualmente il percorso e il nome. Mediante la ricerca e la selezione il percorso e il nome del file vengono infatti inseriti automaticamente.

  • La Configurazione guidata Microsoft Connection Manager Administration Kit non è in grado di creare una cartella o un file necessario durante il processo di creazione.

    La Configurazione guidata Microsoft Connection Manager Administration Kit viene eseguita nel contesto di sicurezza dell'utente attualmente connesso. Se l'utente non dispone delle autorizzazioni necessarie per creare un file o una cartella, non sarà possibile creare il file o la cartella durante l'esecuzione della Configurazione guidata Microsoft Connection Manager Administration Kit. Tale procedura guidata crea i relativi profili all'interno della cartella %PROGRAMFILES%\CMAK\Profiles, nella sottocartella Vista and above o Downlevel, a seconda dell'opzione selezionata nella pagina Selezione del sistema operativo di destinazione. Se il proprio account utente non dispone delle autorizzazioni di lettura o scrittura per queste cartelle, il processo di generazione avrà esito negativo.

Per informazioni sulla risoluzione dei problemi di connessione e relativi al client CMAK, vedere la pagina relativa alla fase 6 sull'assistenza agli utenti nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=142066.

Ulteriori riferimenti


Distribuire il profilo di connessione agli utenti

La Configurazione guidata Microsoft Connection Manager Administration Kit compila il profilo di connessione in un unico file eseguibile con estensione exe. Per fornire tale file agli utenti è possibile ricorrere a qualsiasi metodo a disposizione. Di seguito vengono indicati alcuni metodi che è possibile utilizzare:

  • Includere il profilo di connessione come parte dell'immagine fornita con i nuovi computer.

    È possibile installare il profilo di connessione come parte delle immagini di computer client installate in un nuovo computer dell'organizzazione.

  • Archiviare il profilo di connessione in un sito Web o in una condivisione di rete a cui gli utenti possano accedere.

    Un collegamento Web rende il profilo facilmente accessibile a client di accesso remoto esterni e interni. Una condivisione di rete è in genere accessibile solo ai client interni.

  • Fornire il profilo di connessione su supporti rimovibili in modo che l'utente possa installarlo manualmente.

    È possibile fornire il programma di installazione del profilo di connessione su disco floppy, CD-ROM, unità memoria flash USB o qualsiasi altro supporto rimovibile a cui possono accedere gli utenti. Per alcuni supporti rimovibili è supportata la funzionalità di esecuzione automatica, che consente di avviare l'installazione non appena il supporto viene inserito nel computer client.

  • Fornire il profilo di connessione con strumenti di distribuzione software automatici.

    Molte organizzazioni utilizzano uno strumento di gestione desktop e distribuzione software come Microsoft® System Center Configuration Manager, che consente di comprimere e distribuire il software richiesto dai computer client. L'installazione può essere eseguita senza che gli utenti se ne accorgano e l'esito positivo o negativo della procedura può essere segnalato alla console di gestione.

Ulteriori riferimenti

  • Risorse aggiuntive per CMAK


Risorse aggiuntive per CMAK

Per ulteriori informazioni, vedere la pagina relativa a Connection Manager Administration Kit (CMAK) nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=55986.

Per informazioni sulle tecnologie correlate a CMAK, vedere la:

  • pagina relativa a Connection Point Services nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=141964

  • pagina relativa a IPv6 nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80971

  • pagina relativa a Domain Name System nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=141619

  • pagina relativa alle informazioni sulla firma codice nel sito Web Microsoft all'indirzzo http://go.microsoft.com/fwlink/?LinkId=59273

  • pagina relativa a System Center Configuration Manager nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80968


Supporti non corrispondenti

Causa

Questo problema si verifica se, dopo aver creato il profilo di connessione in un computer che esegue Windows in una determinata lingua, si tenta di modificare il profilo in un computer che esegue Windows in un'altra lingua.

Questo problema può verificarsi inoltre se, dopo aver creato un profilo di connessione, si installa un supporto nel sistema operativo e quindi si tenta di modificare il profilo di connessione.

Soluzione

I profili creati con Connection Manager Administration Kit (CMAK) devono essere modificati in un computer che esegue lo stesso supporto del computer in cui sono stati creati.

Se si passa a un supporto diverso, è necessario ricreare il profilo di connessione.