Amministrazione di Servizi componenti

È possibile utilizzare lo snap-in Servizi componenti in Microsoft Management Console (MMC) per configurare e amministrare i componenti COM (Component Object Model), le applicazioni COM+ e il gestore DTC (Distributed Transaction Coordinator).

Servizi componenti è progettato per amministratori di sistema e sviluppatori di applicazioni. Gli amministratori possono ad esempio gestire componenti, mentre gli sviluppatori possono configurare il funzionamento di applicazioni e componenti di routine, ad esempio la partecipazione a transazioni e pool di oggetti. Per informazioni di carattere concettuale e sulla procedura non incluse in questo argomento, vedere la pagina relativa a COM+ (Servizi componenti) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=67385.

  • Panoramica dell'amministrazione di Servizi componenti

  • Elenco di controllo: Configurare il sistema per Servizi componenti

  • Elenco di controllo: Gestire le applicazioni COM+

  • Elenco di controllo: Gestire le applicazioni DCOM

  • Elenco di controllo: Gestire le transazioni distribuite

  • Configurare il sistema per Servizi componenti

  • Gestire le applicazioni COM+

  • Gestire le applicazioni DCOM

  • Gestire le transazioni distribuite

  • Interfaccia utente: Servizi componenti


Panoramica dell'amministrazione di Servizi componenti

Servizi componenti è incentrato sull'amministrazione di applicazioni COM+. Gli sviluppatori utilizzano COM+ per sviluppare applicazioni distribuite. Gli amministratori utilizzano Servizi componenti per gestire tali applicazioni. Un amministratore riceve un file di applicazione COM+ da uno sviluppatore e quindi utilizza Servizi componenti per distribuire l'applicazione su un computer server. L'amministratore configura quindi le autorizzazioni per l'applicazione, nonché altre impostazioni.

In qualità di amministratore, è possibile distribuire e amministrare le applicazioni COM+ in due modi principali. È possibile utilizzare lo snap-in MMC (Microsoft Management Console) Servizi componenti oppure scrivere script per automatizzare la distribuzione e l'amministrazione. In alternativa allo snap-in MMC Servizi componenti, è possibile automatizzare le attività scrivendo codice che utilizza oggetti di amministrazione disponibili tramite la libreria di collegamento dinamico (DLL) COMAdmin Library. Per una descrizione relativa all'utilizzo di tali oggetti, vedere la pagina relativa all'automazione dell'amministrazione COM+ nell'ambito delle attività generali correlate a COM+ all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66607.

Risorse complete su Servizi componenti per gli sviluppatori sono disponibili alla pagina relativa a COM+ all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66575.

In questo argomento viene illustrata una panoramica delle attività più comuni eseguite tramite Servizi componenti e dei concetti ad esse correlati.

Tipi di applicazioni di Servizi componenti

La maggior parte delle attività amministrative di Servizi componenti prevede la distribuzione di applicazioni e componenti sulla rete e la verifica del livello di prestazioni e sicurezza di questi. Le attività da eseguire dipendono dal tipo di applicazione e dai servizi utilizzati da quest'ultima.

Nota

Negli argomenti inclusi in questo documento viene trattata solo una parte delle impostazioni configurabili con lo snap-in Servizi componenti. È consigliabile che le impostazioni non descritte in tali argomenti vengano configurate solo da utenti in possesso di approfondite conoscenze relative all'implementazione del componente o dell'applicazione. Tali impostazioni, illustrate nella pagina relativa a COM+ (Servizi componenti) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66575, vengono in genere configurate dallo sviluppatore dell'applicazione prima che quest'ultima venga fornita per l'installazione e la distribuzione.

Le applicazioni amministrate tramite Servizi componenti possono appartenere a una delle due categorie seguenti, ovvero applicazioni COM e applicazioni COM+. Questi termini vengono utilizzati negli argomenti laddove le impostazioni possono differire a seconda del tipo di applicazione.

Applicazioni COM

Il concetto di applicazione COM (Component Object Model) non rappresenta una novità. "COM" è semplicemente il termine utilizzato per fare riferimento a gruppi di componenti COM sviluppati affinché funzioni insieme. Un esempio di applicazione COM è Microsoft® Office Excel®, che consiste di un file eseguibile principale e DLL di estensione dell'applicazione per il controllo ortografico, le funzionalità di Microsoft Visual Basic® e così via.

Applicazioni COM+

Le applicazioni COM+ sono gruppi di componenti COM sviluppati e configurati insieme allo scopo di utilizzare servizi COM+, quali le transazioni, l'accodamento, la sicurezza basata su ruoli e così via. Alcuni degli elementi di distinzione di un'applicazione COM+ sono scritti nel codice del componente, mentre altre differenze vengono definite tramite lo snap-in Servizi componenti.

Le applicazioni COM+ possono essere di due tipi, ognuno dei quali con esigenze amministrative distinte. I due tipi di applicazioni sono le applicazioni server COM+ e le applicazioni libreria COM+. Le applicazioni server COM+ vengono eseguite nel proprio spazio di processo. Un'applicazione server potrebbe ad esempio essere costituita da un gruppo di DLL che incapsulano l'elaborazione dei rendiconti retribuzioni. Le applicazioni libreria COM+ sono costituite da componenti sviluppati per l'esecuzione nel processo di un'applicazione host. In un'applicazione libreria potrebbe ad esempio raggruppare DLL che offrono servizi ad altri componenti e DLL di applicazione che condividono caratteristiche di sicurezza di tali componenti.

Panoramica delle attività amministrative

Le attività amministrative da eseguire in Servizi componenti possono appartenere a quattro categorie generali:

  • Configurare il sistema per Servizi componenti

  • Configurare le impostazioni iniziali dei servizi

  • Installare e configurare le applicazioni COM+

  • Monitorare e ottimizzare i servizi componenti

Nota

In questo argomento vengono esaminate le attività necessarie o comuni. Esistono tuttavia altre attività che possono essere eseguite a seconda delle esigenze. Per informazioni più complete su tutte le attività, vedere la documentazione relativa alle aree di attività della cui amministrazione si è responsabili.

Configurare il sistema per Servizi componenti

Quando si inizia a gestire COM+, è necessario eseguire alcune attività di personalizzazione che consentano di utilizzare i servizi in rete. È ad esempio necessario iniziare impostando la sicurezza amministrativa tramite l'assegnazione di un utente o un gruppo al ruolo Administrator dell'applicazione di sistema con Servizi componenti. Per ulteriori informazioni, vedere Configurare il sistema per Servizi componenti.

Configurare le impostazioni iniziali dei servizi

Dopo aver completato la configurazione di base di Servizi componenti per le caratteristiche della rete, potrebbe essere necessario modificare le impostazioni specifiche per i tipi di applicazioni e servizi che si desidera utilizzare nella rete.

Esempi dei tipi di impostazioni configurabili sono i seguenti:

  • Per garantire la sicurezza dei componenti non configurati nelle applicazioni COM+, ovvero le applicazioni o i componenti COM distribuiti in modo indipendente, potrebbe essere necessario configurare impostazioni di sicurezza COM specifiche per tali computer. Le applicazioni COM+, d'altra parte, possono essere progettate per utilizzare la sicurezza basata su ruoli. Per ulteriori informazioni, vedere Gestire le applicazioni DCOM.

  • Se le applicazioni utilizzano transazioni distribuite, specificare se il servizio Microsoft Distributed Transaction Coordinator (DTC) deve essere eseguito manualmente o automaticamente su ogni computer. Se le transazioni vengono utilizzate con il Servizio cluster di Windows, è necessario configurare la rete in modo appropriato. Per ulteriori informazioni, vedere Gestire le transazioni distribuite.

Installare e configurare le applicazioni COM+

Le applicazioni COM+ devono essere configurate con impostazioni specifiche dei servizi che esse devono utilizzare. Dopo aver configurato le impostazioni per l'applicazione, è possibile installare le relative parti lato client e lato server nei computer in rete. Negli esempi seguenti vengono illustrati tipi di attività che potrebbero essere eseguite per installare e configurare le applicazioni COM+:

  • Per poter configurare le impostazioni che controllano il funzionamento dell'applicazione COM+ sulla rete, installare l'applicazione in un computer di gestione temporanea in cui sia possibile configurarla. Per ulteriori informazioni, vedere Informazioni sull'installazione di applicazioni COM+.

  • Per verificare che l'applicazione COM+ partecipi in modo appropriato allo schema di sicurezza della rete, ovvero che l'accesso all'applicazione e alle altre risorse sia adeguato alle esigenze della rete, potrebbe essere necessario aggiungere utenti ai ruoli dell'applicazione e impostare l'identità di sicurezza di quest'ultima. Per ulteriori informazioni, vedere Impostare la configurazione della sicurezza COM specifica di un'applicazione.

  • Dopo aver configurato l'applicazione COM+ in modo appropriato per quanto concerne la sicurezza e i servizi utilizzati, è necessario distribuire le parti lato client e lato server in computer di produzione attraverso la rete. Per ulteriori informazioni, vedere Gestire le applicazioni COM+.

Monitorare e ottimizzare i servizi componenti

Dopo aver distribuito i componenti che utilizzano Servizi componenti, è possibile tenere traccia delle prestazioni dei servizi in modo da migliorarle e gestire gli errori. In alcuni casi, le modifiche apportate a tali impostazioni, in particolare per ottenere un monitoraggio più dettagliato, possono determinare in effetti una riduzione delle prestazioni.

Negli esempi seguenti vengono illustrati tipi di attività che è possibile eseguire per monitorare e ottimizzare i componenti e le applicazioni:

  • Installare aggiornamenti disponibili.

  • Per migliorare il controllo della sicurezza, ad esempio per impedire che gli oggetti vengano rilasciati accidentalmente o in seguito all'attacco di un utente malintenzionato, è possibile utilizzare la registrazione dei riferimenti per effettuare ulteriori controlli della sicurezza e tenere traccia di altre informazioni.

  • Se le applicazioni partecipano a transazioni distribuite, è possibile monitorare le prestazioni visualizzato statistiche, messaggi e stato delle transazioni. Potrebbe inoltre essere possibile migliorare le prestazioni del sistema modificando le dimensioni o il percorso del file di registro in cui vengono archiviate le statistiche relative alle transazioni.

Per attività correlate al monitoraggio e all'ottimizzazione non incluse qui, vedere la pagina relativa alle attività generali di COM+ all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66607


Elenco di controllo: Configurare il sistema per Servizi componenti

Attività | Informazioni di riferimento
Esaminare le nozioni di base relative alla configurazione del sistema per Servizi componenti. | Configurare il sistema per Servizi componenti Informazioni sulla configurazione del sistema
Impostare la sicurezza per l'amministrazione assegnando un utente o un gruppo al ruolo Administrator dell'applicazione di sistema | Impostare la sicurezza per l'amministrazione
Rendere visibili i computer a Servizi componenti per gestire le applicazioni COM+ e monitorare le transazioni. | Rendere i computer visibili a Servizi componenti
Abilitare DCOM per la comunicazione con i componenti COM (Component Object Model) in altri computer. | Attivare o disattivare DCOM


Elenco di controllo: Gestire le applicazioni COM+

Attività | Informazioni di riferimento
Creare una nuova applicazione COM+ | Informazioni sull'installazione di applicazioni COM+ Creare una nuova applicazione COM+
Installare applicazioni server COM+ | Informazioni sull'installazione di applicazioni COM+ Installare applicazioni server COM+
Installare proxy di applicazioni COM+ | Installare proxy di applicazioni COM+
Rimuovere applicazioni COM+ | Rimuovere applicazioni COM+


Elenco di controllo: Gestire le applicazioni DCOM

Attività | Informazioni di riferimento
Impostare la sicurezza COM (Component Object Model) a livello di computer. | Impostare le autorizzazioni di accesso a livello di computer Impostare le autorizzazioni di esecuzione e attivazione a livello di computer
Impostare la sicurezza COM specifica di un'applicazione | Impostare le autorizzazioni di accesso specifiche di un'applicazione Impostare le autorizzazioni di esecuzione e attivazione specifiche di un'applicazione


Elenco di controllo: Gestire le transazioni distribuite

Attività | Informazioni di riferimento
Esaminare i concetti relativi alla gestione delle transazioni distribuite. | Gestire le transazioni distribuite Configurare il servizio DTC (Distributed Transaction Coordinator) predefinito
Configurare il gestore delle transazioni DTC (Distributed Transaction Coordinator) di un sistema remoto (non il computer locale). | Configurare il servizio DTC (Distributed Transaction Coordinator) predefinito
Controllare la traccia in background selezionando opzioni di output e di registrazione. | Configurare la traccia di DTC
Modificare le dimensioni o il percorso del file di registro di DTC. | Configurare la registrazione di DTC
Configurare la sicurezza DTC per consentire solo le transazioni locali oppure utilizzare il DTC di un sistema remoto. | Configurare la sicurezza di DTC
Coordinare le transazioni remote. | Configurare la sicurezza di DTC


Configurare il sistema per Servizi componenti

Dopo aver installato il sistema operativo, è necessario configurarlo per abilitare l'amministrazione di Servizi componenti in rete, ovvero abilitare il controllo dell'applicazione di sistema da parte dell'amministratore. Servizi componenti viene inoltre configurato per riconoscere la rete rendendo visibili i computer allo snap-in e abilitando la comunicazione dei componenti tra i computer mediante la configurazione di DCOM. Questi requisiti di configurazione sono di importanza fondamentale ai fini dell'amministrazione di Servizi componenti.

Nota

A seconda delle esigenze del sistema in uso, potrebbe essere necessario eseguire ulteriori attività di configurazione non descritte negli argomenti di questa sezione. Sebbene sia possibile configurare le proprietà seguenti successivamente, è importante esserne subito a conoscenza:

  • Lo snap-in Servizi componenti richiede che il servizio DTC (Distributed Transaction Coordinator) sia in esecuzione. È pertanto necessario configurarlo. Per ulteriori informazioni, vedere Gestire le transazioni distribuite.

  • Se si desidera ottimizzare la scalabilità del sistema, è possibile configurare Servizi componenti affinché arresti i processi delle applicazioni non utilizzati. Per ulteriori informazioni, vedere la pagina relativa alle attività generali di COM+ all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66607.

  • Informazioni sulla configurazione del sistema

  • Impostare la sicurezza per l'amministrazione

  • Rendere i computer visibili a Servizi componenti

  • Attivare o disattivare DCOM


Informazioni sulla configurazione del sistema

In questo argomento è inclusa una panoramica generale delle attività di configurazione iniziale del sistema da eseguire con Servizi componenti dopo l'installazione del sistema operativo.

Nota

Lo snap-in Servizi componenti richiede che il servizio DTC (Microsoft Distributed Transaction Coordinator) sia in esecuzione. Se il servizio DTC viene arrestato e si tenta di modificare le impostazioni mediante lo snap-in Servizi componenti, il servizio DTC verrà riavviato. Se vengono visualizzati messaggi di errore quando si tenta di utilizzare lo snap-in Servizi componenti, verificare che il servizio DTC sia in esecuzione. In caso contrario, riavviarlo nello snap-in MMC Servizi. Per aprire lo snap-in Servizi, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi.

Impostare il controllo per l'applicazione di sistema

L'applicazione di sistema si trova nella cartella Applicazioni COM+ dello snap-in Servizi componenti. L'applicazione di sistema gestisce la configurazione e la distribuzione in Servizi componenti. Per controllare l'accesso a questa importante applicazione, è necessario definire chi è autorizzato ad amministrare l'ambiente. Questa operazione è necessaria per apportare qualsiasi modifica alla configurazione di Servizi componenti, incluse l'installazione di un'applicazione o l'aggiunta di un computer.

L'applicazione di sistema utilizza la sicurezza basata su ruoli con ruoli quali Administrator, Lettore, Applicazione server, Qualsiasi applicazione e Utente trusted QC. I membri del ruolo Administrator dispongono di accesso in lettura e scrittura all'applicazione di sistema. Gli amministratori possono modificare o eliminare qualsiasi impostazione nello snap-in Servizi componenti. Solo ai membri del ruolo Administrator è consentito installare le applicazioni COM+ nel sistema. Per impostazione predefinita, il gruppo Administrators locale è l'unico membro di questo ruolo. Solo gli utenti appartenenti al gruppo Administrators locale possono essere aggiunti al ruolo Administrator.

Nota

È necessario assegnare almeno un utente o un gruppo al ruolo Administrator. In caso contrario, nessun utente potrà amministrare Servizi componenti.

I membri del ruolo Lettore dispongono dell'accesso di sola lettura all'applicazione di sistema. Tali membri possono visualizzare le impostazioni nello snap-in Servizi componenti, ma non possono modificarle, aggiungerle o eliminarle. Per impostazione predefinita, il gruppo Everyone appartiene a tale ruolo, il che significa che chiunque abbia accesso al computer può visualizzare le impostazioni di Servizi componenti.

Nota

Per motivi di sicurezza, potrebbe essere opportuno impedire ai membri del gruppo Everyone di visualizzare le impostazioni di Servizi componenti. In questo caso, è consigliabile eliminare il gruppo Everyone dal ruolo Lettore e aggiungere solo gli utenti a cui si desidera concedere l'accesso in lettura alle impostazioni di Servizi componenti. Affinché le modifiche diventino effettive, è necessario riavviare il computer.

Ai membri del ruolo Applicazione server è consentito eseguire le applicazioni server COM+, mentre i membri del ruolo Qualsiasi applicazione sono autorizzati ad eseguire le applicazioni server e libreria COM+. Per impostazione predefinita, il gruppo Everyone appartiene a ogni ruolo.

I membri del ruolo Utente trusted QC sono autorizzati a trasmettere i messaggi per i componenti accodati per conto di altri utenti. Per impostazione predefinita, a questo ruolo non appartiene alcun membro.

Nota

I membri del ruolo Utente trusted QC sono autorizzati a specificare un'identità arbitraria, il che significa che un membro malintenzionato potrebbe eseguire una chiamata a un componente accodato con privilegi elevati. È pertanto consigliabile ridurre al minimo il numero di tali utenti.

Per impostare la sicurezza per l'amministrazione dell'applicazione di sistema, vedere Impostare la sicurezza per l'amministrazione.

Rendere i computer visibili a Servizi componenti

È possibile gestire le applicazioni COM+ e le relative transazioni in remoto. A tale scopo, è innanzitutto necessario rendere il computer visibile in Servizi componenti. Aggiungere qualsiasi computer che si desidera amministrare all'albero della console dello snap-in Servizi componenti. Per aggiungere computer a Servizi componenti, vedere Rendere i computer visibili a Servizi componenti.

Configurare DCOM

Il protocollo wire DCOM gestisce tutte le comunicazioni di rete tra i componenti COM (Component Object Model) in esecuzione su computer separati. È necessario abilitare DCOM per ogni computer con componenti COM che comunicano con altri componenti nella rete. Sebbene la disabilitazione di DCOM non influisca sulle comunicazioni tra i componenti nello stesso computer, tutte le comunicazioni tra i componenti di computer separati vengono disabilitate. Per abilitare le comunicazioni di componenti tra computer, vedere Attivare o disattivare DCOM.

Ulteriori riferimenti

  • Configurare il sistema per Servizi componenti


Impostare la sicurezza per l'amministrazione

L'applicazione di sistema si trova nella cartella Applicazioni COM+ dello snap-in Servizi componenti. L'applicazione di sistema gestisce la configurazione e la distribuzione in Servizi componenti. Il livello di autenticazione predefinito utilizzato dall'applicazione di sistema per le chiamate è Riservatezza pacchetto, il quale offre il livello di sicurezza più elevato.

Nota

Per motivi di sicurezza, è consigliabile non modificare il livello di autenticazione predefinito dell'applicazione di sistema.

Affinché sia possibile apportare modifiche al sistema, ad esempio l'installazione di un'applicazione COM+ o l'aggiunta di un computer, è necessario configurare la sicurezza per determinare gli utenti a cui è consentito amministrare l'ambiente. È possibile utilizzare la procedura seguente per abilitare la sicurezza per l'applicazione di sistema definendo le appartenenze al ruolo Administrator. A tale ruolo dell'applicazione di sistema possono appartenere solo i membri del gruppo Administrators del computer in uso.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Esaminare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Per impostare la sicurezza per l'amministrazione assegnando un utente o un gruppo al ruolo Administrator dell'applicazione di sistema

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare doppio clic su Computer e Risorse del computer.

  3. Fare doppio clic su Applicazioni COM+, Applicazione di sistema, Ruoli e Administrator.

  4. In Administrator fare clic con il pulsante destro del mouse sulla cartella Utenti, scegliere Nuovo e quindi Utente.

  5. Nella finestra di dialogo Seleziona Utenti o Gruppi, in Immettere i nomi degli oggetti da selezionare digitare il nome completo dell'utente o del gruppo che si desidera aggiungere. Se non si conosce il nome dell'utente o del gruppo da aggiungere, eseguire la procedura seguente:

    1. Fare clic su Percorsi, selezionare il dominio appropriato e quindi fare clic su OK.

    2. Nella finestra di dialogo Seleziona Utenti o Gruppi fare clic su Avanzate.

    3. Per visualizzare un elenco di utenti e gruppi nel dominio selezionato, nella finestra di dialogo Seleziona Utenti o Gruppi fare clic su Trova.

    4. Selezionare un utente o un gruppo e quindi fare clic su OK.

  6. Per aggiungere altri account utente o gruppi, ripetere i passaggi fino a punto d.

  7. Riavviare il computer.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Per abilitare la sicurezza per l'amministrazione per l'applicazione di sistema, è necessario assegnare almeno un utente o gruppo al ruolo Administrator. In caso contrario, nessun utente potrà amministrare Servizi componenti.

  • Gli utenti del ruolo Administrator per l'applicazione di sistema devono essere membri del gruppo Administrators locale.

Ulteriori riferimenti

  • Configurare il sistema per Servizi componenti


Rendere i computer visibili a Servizi componenti

Se si dispone di privilegi sufficienti su un computer remoto, è possibile gestirne le applicazioni COM+ e monitorarne le transazioni mediante Servizi componenti su un altro computer, tuttavia è innanzitutto necessario rendere il computer remoto visibile a Servizi componenti. Utilizzare la procedura seguente per aggiungere qualsiasi computer che si desidera amministrare all'albero della console dello snap-in Servizi componenti.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Esaminare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Per aggiungere un computer remoto allo snap-in Servizi componenti

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Computer, scegliere Nuovo e quindi fare clic su Computer.

  3. Nella finestra di dialogo Aggiungi computer digitare il nome del computer che si desidera aggiungere. Se non si conosce il nome del computer, eseguire la procedura seguente:

    1. Fare clic su Sfoglia e quindi fare clic su Avanzate nella finestra di dialogo Selezione computer.

    2. Per limitare la ricerca del computer, in Query comuni compilare il maggior numero di campi possibile. Per visualizzare un elenco di computer che soddisfano i criteri specificati, fare clic su Trova.

    3. Selezionare un computer e quindi fare clic su OK.

  4. Fare clic su OK due volte.

    Il computer verrà visualizzato nella cartella Computer. Sarà quindi possibile utilizzare lo snap-in Servizi componenti per gestire gli oggetti nel computer remoto come se si trovassero nel computer locale.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella Cerca digitare dcomcnfg e quindi premere INVIO.

  • Per visualizzare i processi in esecuzione nel computer remoto, aggiungere la porta TCP 135 e Dllhost.exe all'elenco delle eccezioni di Windows Firewall nel computer remoto da amministrare. Aggiungere la porta TCP 135 e Microsoft Management Console (MMC) all'elenco delle eccezioni di Windows Firewall nel computer locale.

È inoltre possibile utilizzare la procedura seguente per rimuovere un computer remoto dallo snap-in Servizi componenti.

Per rimuovere un computer remoto dallo snap-in Servizi componenti

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare clic su Computer.

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul computer da rimuovere e quindi scegliere Elimina.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Ulteriori riferimenti

  • Configurare il sistema per Servizi componenti


Attivare o disattivare DCOM

Se il computer che utilizza Servizi componenti fa parte di una rete, è necessario attivare il protocollo wire DCOM affinché lo snap-in possa comunicare con i componenti COM in altri computer. Nei computer di rete con sistema basato su Windows DCOM è inizialmente attivato per impostazione predefinita. È possibile disattivare DCOM, tuttavia in questo modo non sarà possibile comunicare con i componenti in altri computer.

È possibile utilizzare la procedura seguente per attivare o disattivare DCOM.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per attivare o disattivare DCOM

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare clic sulla cartella Computer, fare clic con il pulsante destro del mouse sul computer in cui si desidera attivare o disattivare DCOM e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Proprietà predefinite.

  4. Per attivare DCOM, selezionare la casella di controllo Abilita DCOM in questo computer. Per disattivare DCOM, deselezionare la casella di controllo.

  5. Fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Se si abilita il servizio DCOM, è inoltre necessario configurare il firewall sia sul computer che esegue il componente sia in quello che esegue Servizi componenti. Per informazioni dettagliate sulla configurazione del firewall per DCOM vedere la pagina relativa all'utilizzo di DCOM con i firewall all'indirizzo http://go.microsoft.com/fwlink/?LinkId=38001.

  • Se si disabilita DCOM in un computer remoto, non sarà possibile accedere in remoto a tale computer per abilitare nuovamente DCOM. Per abilitare nuovamente DCOM, è necessario poter accedere fisicamente al computer.

Ulteriori riferimenti

  • Configurare il sistema per Servizi componenti


Gestire le applicazioni COM+

COM+ rappresenta un'estensione del modello di programmazione dei componenti. È possibile utilizzare COM+ per aggiungere funzionalità utili a un componente configurato. Le funzionalità aggiunte includono la sicurezza basata sui ruoli, l'accodamento, il riciclo dei processi e l'accessibilità tramite SOAP (Simple Object Access Protocol).

Molte delle attività eseguite dagli amministratori di sistema sono correlate a:

  • Installazione delle applicazioni server in computer di gestione temporanea e computer di produzione.

  • Installazione di proxy di applicazioni su computer client.

  • Rimozione o aggiornamento di applicazioni.

Gli amministratori possono eseguire tali attività mediante lo snap-in Servizi componenti, nonché automatizzarle tramite Windows Script Host (WSH). L'installazione di un'applicazione COM+ prevede in genere l'utilizzo di componenti e applicazioni COM+ create in precedenza su un computer di gestione temporanea utilizzato per sviluppare e testare l'applicazione. Per ulteriori informazioni sui computer di gestione temporanea, vedere Informazioni sull'installazione di applicazioni COM+.

Prima di iniziare il processo di installazione, assegnare utenti o gruppi al ruolo Administrator. Per ulteriori informazioni, vedere Impostare la sicurezza per l'amministrazione.

Per informazioni sulle attività correlate alla gestione di applicazioni COM+ non incluse in questa sezione, vedere la pagina relativa a COM+ (Servizi componenti) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66575.

Negli argomenti seguenti vengono illustrati concetti e procedure relativi alle attività di installazione delle applicazioni COM+ che potrebbe essere necessario eseguire.

  • Informazioni sull'installazione di applicazioni COM+

  • Creare una nuova applicazione COM+

  • Installare applicazioni server COM+

  • Installare proxy di applicazioni COM+

  • Rimuovere applicazioni COM+


Informazioni sull'installazione di applicazioni COM+

Panoramica dell'installazione di applicazioni COM+

È possibile sviluppare applicazioni COM+ nell'organizzazione, a condizione che lo sviluppatore conosca perfettamente l'ambiente di destinazione: account utente, gruppi di utenti, nomi server e così via. Lo sviluppatore configura ed esporta l'applicazione. L'amministratore installa semplicemente l'applicazione nel sistema di destinazione.

È inoltre possibile acquistare le applicazioni COM+ da produttori di applicazioni non Microsoft. Se il fornitore dell'applicazione non offre un programma di installazione standard che consenta di eseguire in modo semplificato i passaggi necessari per eseguirla, è necessario installare e configurare l'applicazione COM+ manualmente.

La configurazione delle applicazioni COM+ viene spesso eseguita su un computer di gestione temporanea anziché su uno di produzione. Se si utilizza un computer di gestione temporanea, è necessario esportare l'applicazione COM+ configurata e un proxy di applicazione COM+ dal computer di gestione temporanea e installarli nei computer di produzione.

L'installazione manuale di un'applicazione COM+ include i passaggi principali seguenti. A seconda del modo in cui l'applicazione viene fornita dal produttore o dallo sviluppatore, non tutti i passaggi possono risultare necessari. Per ulteriori informazioni, vedere l'eventuale documentazione disponibile con l'applicazione.

  1. Nel computer di gestione temporanea, configurare l'applicazione COM+ per un ambiente di destinazione specifico.

  2. Esportare i file di installazione lato client e lato server specifici dell'ambiente dal computer di gestione temporanea.

  3. Installare l'applicazione COM+ o il proxy di applicazione COM+ nei computer di produzione.

Per informazioni sulle procedure necessarie per completare questi passaggi, vedere Gestire le applicazioni COM+.

Computer di gestione temporanea e di produzione

È utile installare e testare le applicazioni in un ambiente di gestione temporanea utilizzabile per simulare scenari che potrebbero potenzialmente verificarsi dopo la distribuzione delle applicazioni sui computer di produzione utilizzati dagli utenti della rete.

È inoltre possibile utilizzare ambienti di gestione temporanea per gestire il controllo delle versioni e l'aggiornamento dei componenti. Anziché modificare le configurazioni o aggiornare singoli componenti di un'applicazione nei computer di produzione, è possibile modificare l'applicazione, testarla nell'ambiente di gestione temporanea e quindi esportarla come unità da installare nei computer di produzione.

In alcuni casi, la configurazione nel sistema di gestione di produzione è identica a quella dell'ambiente di produzione con l'unica differenze che il primo non è pubblicamente accessibile. In tali casi, è sufficiente replicare l'applicazione configurata e convalidata nell'ambiente di gestione temporanea in quello di produzione.

Aggiornare le versioni delle applicazioni COM+

Quando le applicazioni COM+ diventano obsolete oppure se non vengono più utilizzate, è necessario aggiornarle oppure rimuoverle. Se si desidera aggiornare un'applicazione COM+, è innanzitutto necessario eliminare la versione precedentemente installata e quindi installare quella aggiornata.

Per rimuovere e quindi installare le applicazioni, vedere Rimuovere applicazioni COM+ e Installare applicazioni server COM+.

Installazione lato server per le applicazioni COM+

Tutte le informazioni necessarie relative a un'applicazione server COM+ sono contenute in un file di applicazione server con estensione msi. È possibile utilizzare lo snap-in Servizi componenti o Windows Installer per installare l'applicazione COM+ dal file con estensione msi.

Per impedire le modifiche non autorizzate alle applicazioni esportate, archiviare i file dell'applicazione server solo in directory con autorizzazioni di scrittura limitate. Per migliorare ulteriormente la sicurezza, firmare i file dell'applicazione server mediante Authenticode™. Per ulteriori informazioni su Authenticode, vedere la pagina relativa a Authenticode all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66679.

Se un componente di un'applicazione COM+ richiede l'installazione o la configurazione di altre risorse, ad esempio connessioni a database, file di testo o dati, configurazione di radice virtuale di Internet Information Services (IIS) e così via, tali risorse devono essere installate mediante utilità o strumenti diversi da Servizi componenti.

Per installare un'applicazione COM+, vedere Installare applicazioni server COM+.

Installazione lato client per le applicazioni COM+

Dopo aver installato un'applicazione server COM+ in un computer, potrebbe essere necessario accedere all'applicazione in remoto mediante DCOM o Accodamento messaggi.

Se si accedere a un'applicazione in remoto, è possibile utilizzare lo snap-in Servizi componenti per esportare un proxy di applicazione COM+. Il file del proxy dell'applicazione (con estensione msi) contiene le informazioni necessarie per accedere in remoto alle classi incluse in un'applicazione server COM+ da un computer client tramite DCOM. Se si utilizza il file del proxy dell'applicazione con lo snap-in Servizi componenti, è possibile installare il proxy dell'applicazione COM+ nei computer client del sito.

È possibile creare un proxy di applicazione in grado di accedere a un server diverso rispetto al computer da cui è stato esportato. Ciò risulta utile se il proxy dell'applicazione per un computer di produzione deve essere esportato da un computer di gestione temporanea. Per modificare il nome server, fare clic sulla scheda Opzioni nella finestra delle proprietà relativa al computer nello snap-in Servizi componenti e quindi immettere il nome del server remoto corretto del proxy dell'applicazione

Per installare proxy di applicazione COM+, vedere Installare proxy di applicazioni COM+.


Creare una nuova applicazione COM+

Le attività principali nell'ambito dello sviluppo di applicazioni COM+ includono la progettazione di componenti COM (Component Object Model) in cui incapsulare la logica dell'applicazione e l'integrazione dei componenti in un'applicazione COM+. È possibile integrare i componenti in un'applicazione COM+ esistente oppure creare un'applicazione nuova (vuota) per i componenti. È possibile utilizzare lo snap-in Servizi componenti per creare applicazioni COM+ nuove (vuote).

Importante

Non è possibile installare un'applicazione server COM+ in computer che eseguono sistemi operativi precedenti a Microsoft Windows® 2000. Le applicazioni server richiedono una piattaforma che supporti Servizi componenti.

La configurazione minima per un'applicazione non richiede la sicurezza. Se è necessaria la sicurezza per l'applicazione, utilizzare lo snap-in Servizi componenti per impostare la sicurezza a livello di processo oppure aggiungere utenti ai ruoli predefiniti dopo aver creato l'applicazione.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Esaminare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Per creare una nuova applicazione COM+

  1. Aprire Servizi componenti.

  2. Nell'albero della console individuare la cartella Applicazioni COM+ associata al computer in cui si desidera creare l'applicazione.

  3. Fare clic con il pulsante destro del mouse sulla cartella Applicazioni COM+, scegliere Nuovo e quindi Applicazione.

  4. Nell'Installazione guidata applicazioni COM+ fare clic su Avanti.

  5. Nella pagina Installa o crea una nuova applicazione fare clic su Crea un'applicazione vuota.

  6. Nella pagina Crea applicazione vuota digitare un nome per la nuova applicazione. In Tipo di attivazione fare clic su Applicazione libreria o Applicazione server e quindi fare clic su Avanti.

  7. Nella pagina Imposta identità applicazione, in Account fare clic sull'account su cui impostare l'identità dell'applicazione e quindi su Avanti.

    Nota

    L'impostazione predefinita è Utente interattivo. L'utente interattivo corrisponde all'utente che ha effettuato l'accesso all'account di Windows per il computer che esegue l'applicazione. Per scegliere un altro utente, fare clic su Utente seguente e quindi specificare i dettagli di un utente o gruppo specifico.

  8. Nella pagina Aggiungi ruoli applicazione fare clic su Aggiungi ruolo per specificare i ruoli che si desidera creare per l'applicazione. Per impostazione predefinita, viene creato un singolo ruolo denominato CreatorOwner.

  9. Fare clic su Avanti.

  10. Per aggiungere gli utenti desiderati ai ruoli creati, nella pagina Aggiungi utenti a ruoli fare doppio clic sul nome di un ruolo, sulla cartella Utenti e quindi su Aggiungi. Per impostazione predefinita, l'account utente viene aggiunto al ruolo CreatorOwner.

  11. Fare clic su Avanti e quindi su Fine.

    La nuova applicazione verrà quindi visualizzata nell'albero della console.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Per poter eseguire questa procedura, è necessario essere membri del ruolo Administrator nell'applicazione di sistema del computer di destinazione. Nella configurazione predefinita vengono assegnati a questo ruolo solo gli amministratori del computer locale. Per ulteriori informazioni, vedere Impostare la sicurezza per l'amministrazione.

  • Se si desidera consentire agli utenti di rete non autenticati di eseguire un'applicazione COM+, i ruoli di quest'ultima devono includere l'utente Anonimo. Per impostazione predefinita, in Microsoft Windows Vista® l'utente Anonimo non è incluso nel gruppo Everyone. È possibile aggiungere questo tipo di utente nell'Installazione guidata applicazioni COM+ quando si installa o si crea una nuova applicazione. Nella pagina Aggiungi ruoli applicazione della procedura guidata fare clic su Aggiungi ruolo, digitare ACCESSO ANONIMO e quindi fare clic su OK.

Ulteriori riferimenti

  • Gestire le applicazioni COM+


Installare applicazioni server COM+

È possibile utilizzare lo snap-in Servizi componenti per installare applicazioni server COM+.

Importante

Non è possibile installare un'applicazione server COM+ in computer che eseguono sistemi operativi precedenti a Windows 2000. Le applicazioni server richiedono una piattaforma che supporti Servizi componenti.

La configurazione minima per un'applicazione non richiede la sicurezza. Se è necessaria la sicurezza per l'applicazione, utilizzare lo snap-in Servizi componenti per impostare la sicurezza a livello di processo oppure aggiungere utenti ai ruoli predefiniti dopo aver installato l'applicazione. Per ulteriori informazioni su come configurare la sicurezza per l'applicazione, vedere la pagina relativa alla sicurezza COM+ all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66688.

Importante

Se si desidera consentire agli utenti di rete non autenticati di eseguire un'applicazione COM+, i ruoli di quest'ultima devono includere l'utente Anonimo. Per impostazione predefinita, in Microsoft Windows Vista l'utente Anonimo non è incluso nel gruppo Everyone. È possibile aggiungere il ruolo ACCESSO ANONIMO nell'Installazione guidata applicazioni COM+ quando si installa o si crea una nuova applicazione.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Esaminare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Installare applicazioni server COM+

  • Utilizzare lo snap-in Servizi componenti

  • Utilizzare Esplora risorse

  • Utilizzare una riga di comando
Per installare un'applicazione server COM+ mediante lo snap-in Servizi componenti

  1. Aprire Servizi componenti.

  2. Nell'albero della console individuare la cartella Applicazioni COM+ associata al computer in cui si desidera installare l'applicazione.

  3. Fare clic con il pulsante destro del mouse sulla cartella Applicazioni COM+, scegliere Nuovo e quindi Applicazione.

  4. Nell'Installazione guidata applicazioni COM+ fare clic su Avanti.

  5. Nella pagina Installa o crea una nuova applicazione fare clic su Installa un'applicazione esistente.

  6. Nella finestra di dialogo Installa da file dell'applicazione individuare e selezionare il file con estensione msi dell'applicazione che si desidera installare e fare clic su Apri.

  7. Nella finestra di dialogo Selezione file dell'applicazione fare clic su Aggiungi per individuare eventuali altre applicazioni da installare e quindi fare clic su Avanti.

  8. Nella pagina Imposta identità applicazione fare clic sull'identità dell'applicazione e quindi su Avanti.

    Nota

    L'impostazione predefinita è Utente interattivo. L'utente interattivo corrisponde all'utente che ha effettuato l'accesso all'account di Windows per il computer che esegue l'applicazione. Per selezionare un altro utente, fare clic su Utente seguente e quindi specificare i dettagli di un utente o gruppo specifico.

  9. Nella pagina Opzioni di installazione dell'applicazione specificare la directory in cui installare l'applicazione COM+ e quindi fare clic su Avanti.

    I file dei componenti dell'applicazione verranno copiati dal file con estensione msi nella directory di installazione. La directory di installazione predefinita è:

    %Program Files%\COMPlus Applications\idapplicazione

    È possibile accettare la directory predefinita oppure fare clic su Directory specifica e quindi individuare un altro percorso.

    Nota

    Per eseguire questa procedura, l'identità dell'applicazione specificata nel passaggio precedente deve disporre almeno dell'accesso in lettura alla directory di installazione e l'utente che esegue l'installazione deve disporre dell'accesso in scrittura a tale directory.

  10. Fare clic su Fine. Nell'albero della console Servizi componenti verrà quindi visualizzata la nuova applicazione. Se si installano più applicazioni, le opzioni scelte al passaggio 9 verranno applicate a tutte le applicazioni.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Per poter eseguire questa procedura, è necessario essere membri del ruolo Administrator nell'applicazione di sistema del computer di destinazione. Nella configurazione predefinita vengono assegnati a questo ruolo solo gli amministratori del computer locale. Per ulteriori informazioni, vedere Impostare la sicurezza per l'amministrazione.

È inoltre possibile installare un'applicazione COM+ trascinando un file di applicazione da Esplora risorse nella cartella Applicazioni COM+ di un computer all'interno del riquadro dei dettagli dello snap-in Servizi componenti.

Per installare un'applicazione server COM+ mediante Esplora risorse

  1. Nel computer in cui si desidera installare l'applicazione COM+, utilizzare Esplora risorse per individuare il file dell'applicazione server (con estensione msi). Il file può trovarsi nel computer locale oppure su una risorsa condivisa di rete.

  2. Fare doppio clic sul file dell'applicazione server. È inoltre possibile fare clic con il pulsante destro del mouse sul nome del file e quindi scegliere Installa. L'applicazione server verrà automaticamente installata nel computer di destinazione da Microsoft Windows Installer.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessario essere membri del ruolo Administrator nell'applicazione di sistema del computer di destinazione. Nella configurazione predefinita vengono assegnati a questo ruolo solo gli amministratori del computer locale. Per ulteriori informazioni, vedere Impostare la sicurezza per l'amministrazione.

Per installare un'applicazione server COM+ mediante una riga di comando

  • Al prompt dei comandi digitare quanto segue e quindi premere INVIO:

    msiexec -i [<property overrides>] <application name>.msi

    Valore Descrizione

    override di proprietà

    Oltre agli override di proprietà standard di Windows Installer, è possibile specificare l'opzione seguente per cambiare la directory di installazione dell'applicazione COM+:

    TARGETDIR = <target installation directory>

    nome applicazione

    Il nome dell'applicazione da installare.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessario essere membri del ruolo Administrator nell'applicazione di sistema del computer di destinazione. Nella configurazione predefinita vengono assegnati a questo ruolo solo gli amministratori del computer locale. Per ulteriori informazioni, vedere Impostare la sicurezza per l'amministrazione.

Ulteriori riferimenti

  • Gestire le applicazioni COM+

  • Notazione di sintassi della riga di comando


Installare proxy di applicazioni COM+

Dopo aver creato il proxy dell'applicazione come file di Windows Installare (con estensione msi), è possibile installarlo nel computer client. L'installazione del proxy di applicazione offre le informazioni di registrazione necessarie alle applicazioni client per accedere all'applicazione COM+ in remoto dal computer client.

Importante

È possibile installare un proxy di applicazione COM+ in qualsiasi computer che esegue Windows Installer. Windows Installer viene installato in tutti i computer che eseguono Windows 2000, Microsoft Windows Server™ 2003 o Windows Server 2008 ed è inoltre disponibile per i computer che eseguono versioni precedenti di Windows. Se un proxy di applicazione richiede tuttavia il servizio componenti in coda COM+, il proxy può essere installato solo su un computer che esegue Windows 2000, Windows Server 2003 o Windows Server 2008. Il servizio componenti in coda è disponibile solo su piattaforme che supportano Servizi componenti.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Esaminare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Installare proxy di applicazioni COM+

  • Utilizzare lo snap-in Servizi componenti

  • Utilizzare Esplora risorse

  • Utilizzare una riga di comando
Per installare un proxy di applicazione COM+ mediante lo snap-in Servizi componenti

  1. Aprire Servizi componenti.

  2. Nell'albero della console individuare la cartella Applicazioni COM+ associata al computer in cui si desidera installare l'applicazione.

  3. Fare clic con il pulsante destro del mouse sulla cartella Applicazioni COM+, scegliere Nuovo e quindi Applicazione.

  4. Nell'Installazione guidata applicazioni COM+ fare clic su Avanti.

  5. Nella pagina Installa o crea una nuova applicazione fare clic su Installa un'applicazione esistente.

  6. Nella finestra di dialogo Installa da file dell'applicazione individuare e selezionare il file con estensione msi del proxy di applicazione che si desidera installare e fare clic su Apri.

  7. Nella pagina Selezione file dell'applicazione fare clic su Aggiungi per individuare eventuali altri proxy di applicazioni da installare e quindi fare clic su Avanti.

  8. Nella pagina Opzioni di installazione dell'applicazione specificare la directory in cui installare l'applicazione COM+ e quindi fare clic su Avanti.

    I file dei componenti dell'applicazione verranno copiati dal file con estensione msi nella directory di installazione. La directory di installazione predefinita è:

    %Program Files%\COMPlus Applications\idapplicazione

    È possibile accettare la directory predefinita oppure fare clic su Directory specifica e individuare un altro percorso.

  9. Fare clic su Fine. Nell'albero della console Servizi componenti verrà quindi visualizzata la nuova applicazione. Se si installano più applicazioni, la directory scelta al passaggio 8 verrà utilizzata per tutte le applicazioni.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Per poter installare un proxy di applicazione COM+, è necessario disporre dell'accesso in scrittura alla directory di installazione.

Per installare un proxy di applicazione COM+ mediante Esplora risorse

  1. Nel computer client, individuare il file del proxy di applicazioni (con estensione msi) mediante Esplora risorse. Il file può trovarsi nel computer locale oppure su una risorsa condivisa di rete.

  2. Fare doppio clic sul file del proxy di applicazione. È inoltre possibile fare clic con il pulsante destro del mouse sul nome del file e quindi scegliere Installa.

    Il proxy di applicazione verrà automaticamente installato nel computer client da Windows Installer.

Ulteriori considerazioni

  • Per poter installare un proxy di applicazione COM+, è necessario disporre dell'accesso in scrittura alla directory di installazione.

Per installare un proxy di applicazione COM+ mediante una riga di comando

  • Al prompt dei comandi digitare quanto segue e quindi premere INVIO:

    msiexec -i [<property overrides>] <application_name>.msi

    Valore Descrizione

    override di proprietà

    Oltre agli override di proprietà standard di Windows Installer, è possibile specificare l'opzione seguente per cambiare la directory di installazione dell'applicazione COM+:

    TARGETDIR = <target installation directory>

    nome applicazione

    Il nome dell'applicazione da installare.

Oltre agli override di proprietà standard di Windows Installer, è possibile specificare le opzioni di installazione descritte nella tabella seguente.

Opzione di installazione Descrizione
REMOTESERVERNAME = <new target server>

Consente di cambiare il server a cui si connette il computer client sostituendo quello predefinito di esportazione con il nuovo server di destinazione specificato.

ALLUSERS = 0

Consente di installare il proxy di applicazione solo per l'utente corrente. Per impostazione predefinita, il proxy di applicazione viene installato a livello di computer.

TARGETDIR = <target installation directory>

Consente di cambiare la directory di installazione predefinita dell'applicazione COM+ con quella specificata.

Ulteriori considerazioni

  • Per poter installare un proxy di applicazione COM+, è necessario disporre dell'accesso in scrittura alla directory di installazione.

Ulteriori riferimenti

  • Gestire le applicazioni COM+

  • Notazione di sintassi della riga di comando


Rimuovere applicazioni COM+

Le applicazioni esistenti obsolete o non più utilizzate possono essere rimosse. L'eliminazione di un'applicazione determina inoltre l'eliminazione di tutti i componenti in essa contenuti. Se tali componenti dipendono da ulteriori risorse, ad esempio connessioni a database, file di testo o dati, configurazione di radice virtuale di Internet Information Services (IIS) e così via, tali risorse devono essere rimosse mediante strumenti o utilità diverse dallo snap-in Servizi componenti.

Nota

Se si elimina un'applicazione server COM+ mentre è in esecuzione, questa viene chiusa senza che vengano visualizzati avvisi prima dell'eliminazione.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Rimuovere applicazioni COM+

  • Utilizzare lo snap-in Servizi componenti

  • Utilizzare Esplora risorse

  • Utilizzare una riga di comando
Per eliminare un'applicazione COM+ mediante lo snap-in Servizi componenti

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare doppio clic su Computer e quindi fare doppio clic sul computer per il quale si desidera eliminare l'applicazione.

  3. Fare doppio clic sulla cartella Applicazioni COM+ relativa al computer specificato per visualizzare tutte le applicazioni.

  4. Fare clic sull'applicazione che si desidera rimuovere.

  5. Se si seleziona un'applicazione server, chiuderla. A tale scopo, fare clic con il pulsante destro del mouse sull'applicazione e quindi scegliere Arresta. Se si seleziona un'applicazione libreria, verificare che tutti i processi che la utilizzano siano arrestati.

  6. Fare clic con il pulsante destro del mouse sull'applicazione. Se l'opzione Elimina non è disponibile quando si fa clic con il pulsante destro del mouse sull'applicazione, è necessario abilitarla nel modo seguente:

    1. Fare clic con il pulsante destro del mouse sull'applicazione e quindi scegliere Proprietà.

    2. Nella pagina delle proprietà dell'applicazione, selezionare la scheda Avanzate.

    3. In Protezione deselezionare la casella di controllo Disabilita eliminazione.

    4. Fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sull'applicazione e quindi scegliere Elimina.

  8. Nella finestra di dialogo Conferma eliminazione elemento fare clic su Sì per eliminare l'applicazione.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Le procedure seguenti risultano particolarmente utili per l'eliminazione di applicazioni COM+ in computer client che non eseguono lo snap-in Servizi componenti.

Per eliminare un'applicazione COM+ mediante Esplora risorse

  1. Nel computer in cui si desidera eliminare l'applicazione COM+, utilizzare Esplora risorse per individuare il file dell'applicazione server o del proxy di applicazione (in entrambi i casi con estensione msi).

  2. Fare clic con il pulsante destro del mouse sul file con estensione msi e quindi scegliere Disinstalla. L'applicazione verrà automaticamente eliminata da Windows Installer.
Per eliminare un'applicazione COM+ mediante una riga di comando

  • Al prompt dei comandi digitare quanto segue e quindi premere INVIO:

    msiexec -x <application_name>.msi

    Valore Descrizione

    nome applicazione

    Il nome dell'applicazione da eliminare.

Ulteriori riferimenti

  • Gestire le applicazioni COM+

  • Notazione di sintassi della riga di comando


Gestire le applicazioni DCOM

COM (Component Object Model) consente di incapsulare funzionalità in un'applicazione COM riutilizzabile da diverse applicazioni. La tecnologia DCOM consente di accedere alle applicazioni COM da diversi computer in rete.

I componenti COM e COM+ si trovano in genere in librerie DLL o file eseguibili (con estensione exe). È possibile installare questi componenti in un computer client o un computer remoto. Quando si installano questi componenti in un computer remoto, la chiamata viene effettuata da DCOM, il quale si basa su una chiamata di procedura remota (RPC).

Per informazioni sulle attività correlate all'amministrazione delle applicazioni DCOM non incluse in questa sezione, vedere la pagina relativa a DCOM all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66689.

  • Impostare la configurazione della sicurezza COM a livello di computer

  • Impostare la configurazione della sicurezza COM specifica di un'applicazione


Impostare la configurazione della sicurezza COM a livello di computer

Le attività iniziali eseguite dall'utente per la gestione delle applicazioni DCOM sono principalmente relative alle impostazioni di sicurezza. Lo snap-in Servizi componenti consente di impostare le proprietà di sicurezza COM (Component Object Model) a livello di computer utilizzate per le applicazioni COM.

Per ulteriori informazioni sulle impostazioni di sicurezza COM, vedere la pagina relativa alla sicurezza in COM all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66690.

  • Impostare le autorizzazioni di accesso a livello di computer

  • Impostare le autorizzazioni di esecuzione e attivazione a livello di computer


Impostare le autorizzazioni di accesso a livello di computer

Le autorizzazioni di accesso a livello di computer specificano gli utenti a cui è assegnato o negato l'accesso alle applicazioni COM. Lo snap-in Servizi componenti consente di modificare le autorizzazioni di accesso predefinite oppure i criteri di restrizione a livello di computer. In questo argomento viene illustrata la procedura per impostare le autorizzazioni di accesso a livello di computer. Per ulteriori informazioni sui criteri di restrizione a livello di computer, vedere la pagina relativa alle restrizioni a livello di computer all'indirizzo http://go.microsoft.com/fwlink/?LinkID=66013.

Importante

La modifica delle autorizzazioni di accesso può influire sulla possibilità di avviare, connettere, utilizzare ed eseguire in modo sicuro le applicazioni. È pertanto consigliabile modificare le autorizzazioni specifiche dell'applicazione piuttosto che modificare le autorizzazioni di accesso predefinite.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per impostare le autorizzazioni di accesso a livello di computer

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare clic con il pulsante destro del mouse sul computer per il quale si desidera modificare le autorizzazioni di accesso e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Sicurezza COM.

  4. In Autorizzazioni di accesso fare clic su Modifica limiti o Modifica predefinite a seconda che si desideri modificare i criteri di limitazione o le impostazioni predefinite a livello di computer. Verrà visualizzata la finestra di dialogo Autorizzazioni di accesso.

  5. Per rimuovere un account utente o un gruppo, selezionare il gruppo o l'utente nell'elenco Utenti e gruppi e quindi fare clic su Rimuovi. L'account utente o il gruppo selezionato non sarà più visualizzato nell'elenco.

  6. Per aggiungere un account utente o un gruppo, fare clic su Aggiungi. Nella finestra di dialogo Seleziona utenti, computer o gruppi digitare il nome completo dell'utente o del gruppo da aggiungere.

    Se non si conosce il nome dell'utente o del gruppo da aggiungere, fare clic su Avanzate e quindi su Trova per visualizzare un elenco di utenti e gruppi nel dominio selezionato. Selezionare un utente o un gruppo nell'elenco e quindi fare clic su OK. L'account utente o il gruppo aggiunto verrà visualizzato nell'elenco Utenti e gruppi.

  7. Nell'elenco Utenti e gruppi selezionare il gruppo o l'utente di cui si desidera modificare le autorizzazioni di accesso.

  8. Nell'elenco Autorizzazioni selezionare le caselle di controllo Consenti o Nega per consentire o negare le autorizzazioni di accesso locale e remoto per il gruppo o l'utente selezionato.

  9. Fare clic su OK per tornare alla scheda Sicurezza COM.

  10. Fare clic su OK. Le nuove impostazioni di accesso a livello di computer verranno applicate al successivo avvio di un'applicazione nel computer. Le applicazioni attualmente in esecuzione non saranno interessate fino al successivo riavvio.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Ulteriori riferimenti

  • Impostare la configurazione della sicurezza COM a livello di computer


Impostare le autorizzazioni di esecuzione e attivazione a livello di computer

Le autorizzazioni di attivazione e di esecuzione a livello di computer determinano a quali utenti è assegnata in modo esplicito l'autorizzazione di eseguire e attivare le applicazioni COM. Lo snap-in Servizi componenti consente di modificare le autorizzazioni di esecuzione e attivazione predefinite oppure i criteri di restrizione a livello di computer.

Importante

La modifica delle autorizzazioni di esecuzione e attivazione può influire sulla possibilità di avviare, connettere, utilizzare ed eseguire in modo sicuro le applicazioni. È pertanto consigliabile modificare le autorizzazioni specifiche dell'applicazione piuttosto che modificare le autorizzazioni di esecuzione e attivazione predefinite.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per impostare le autorizzazioni di esecuzione e attivazione a livello di computer

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare clic con il pulsante destro del mouse sul computer per il quale si desidera modificare le autorizzazioni di esecuzione e quindi scegliere Proprietà.

  3. Selezionare la scheda Sicurezza COM.

  4. In Autorizzazione di esecuzione e attivazione fare clic su Modifica limiti o Modifica predefinite a seconda che si desideri modificare i criteri di limitazione o le impostazioni predefinite a livello di computer. Verrà visualizzata la finestra di dialogo Autorizzazione di esecuzione e attivazione.

  5. Per rimuovere un account utente o un gruppo, selezionare il gruppo o l'utente nell'elenco Utenti e gruppi e quindi fare clic su Rimuovi. L'account utente o il gruppo selezionato non sarà più visualizzato nell'elenco.

  6. Per aggiungere un account utente o un gruppo, fare clic su Aggiungi. Nella finestra di dialogo Seleziona utenti, computer o gruppi digitare il nome completo dell'utente o del gruppo da aggiungere. Se non si conosce il nome dell'utente o del gruppo desiderato, fare clic su Avanzate e quindi su Trova per visualizzare un elenco di utenti e gruppi nel dominio selezionato. Selezionare un utente o un gruppo nell'elenco e quindi fare clic su OK. L'account utente o il gruppo aggiunto verrà visualizzato nell'elenco Utenti e gruppi.

  7. Nell'elenco Utenti e gruppi selezionare il gruppo o l'utente di cui si desidera modificare le autorizzazioni di esecuzione e attivazione a livello di computer.

  8. Nell'elenco Autorizzazioni selezionare le caselle di controllo Consenti o Nega per consentire o negare le autorizzazioni di esecuzione locale, le autorizzazioni di attivazione locale, le autorizzazioni di esecuzione remota e le autorizzazioni di attivazione remota per il gruppo o l'utente selezionato.

  9. Fare clic su OK per tornare alla scheda Sicurezza COM.

  10. Fare clic su OK. Le nuove impostazioni di esecuzione e attivazione a livello di computer verranno applicate al successivo avvio di un'applicazione nel computer. Le applicazioni attualmente in esecuzione non saranno interessate fino al successivo riavvio.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Se si impostano le autorizzazioni, è necessario accertarsi che SYSTEM sia incluso nell'elenco Utenti o gruppi nella finestra di dialogo Autorizzazione di esecuzione e attivazione e che a tale account sia assegnata l'autorizzazione di esecuzione. SYSTEM è implicitamente incluso nel gruppo Everyone. Per motivi di sicurezza, è tuttavia consigliabile non concedere l'autorizzazione di esecuzione al gruppo Everyone.

Ulteriori riferimenti

  • Impostare la configurazione della sicurezza COM a livello di computer


Impostare la configurazione della sicurezza COM specifica di un'applicazione

Lo snap-in Servizi componenti consente di impostare le proprietà di sicurezza COM (Component Object Model) per un'applicazione COM specifica.

Per ulteriori informazioni sul funzionamento di tali funzionalità di sicurezza, vedere la pagina relativa alla sicurezza in COM all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66690.

  • Impostare le autorizzazioni di accesso specifiche di un'applicazione

  • Impostare le autorizzazioni di esecuzione e attivazione specifiche di un'applicazione


Impostare le autorizzazioni di accesso specifiche di un'applicazione

Le autorizzazioni di accesso specifiche di un'applicazione specificano gli utenti a cui è assegnato o negato l'accesso all'applicazione COM.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per impostare le autorizzazioni di accesso specifiche di un'applicazione

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sull'applicazione DCOM per la quale si desidera modificare le autorizzazioni di accesso e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Sicurezza.

  4. In Autorizzazioni di accesso fare clic sul pulsante Personalizza e quindi su Modifica.

  5. Per rimuovere un account utente o un gruppo, selezionare il gruppo o l'utente nell'elenco Utenti e gruppi e quindi fare clic su Rimuovi. L'account utente o il gruppo selezionato non sarà più visualizzato nell'elenco.

  6. Per aggiungere un account utente o un gruppo, fare clic su Aggiungi. Nella finestra di dialogo Seleziona utenti, computer o gruppi digitare il nome completo dell'utente o del gruppo da aggiungere. Se non si conosce il nome dell'utente o del gruppo desiderato, fare clic su Avanzate e quindi su Trova per visualizzare un elenco di utenti e gruppi nel dominio selezionato. Selezionare un utente o un gruppo nell'elenco e quindi fare clic su OK. L'account utente o il gruppo aggiunto verrà visualizzato nell'elenco Utenti e gruppi.

  7. Nell'elenco Utenti e gruppi selezionare il gruppo o l'utente di cui si desidera modificare le autorizzazioni di accesso predefinite.

  8. Nell'elenco Autorizzazioni selezionare le caselle di controllo Consenti o Nega per consentire o negare le autorizzazioni di accesso locale e remoto per il gruppo o l'utente selezionato.

  9. Fare clic su OK due volte. Le nuove impostazioni di accesso specifiche dell'applicazione verranno applicate al successivo avvio dell'applicazione nel computer.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Ulteriori riferimenti

  • Impostare la configurazione della sicurezza COM specifica di un'applicazione


Impostare le autorizzazioni di esecuzione e attivazione specifiche di un'applicazione

Le autorizzazioni di esecuzione e attivazione specifiche di un'applicazione determinano gli utenti a cui è consentito o meno di avviare o attivare un'applicazione COM.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per impostare le autorizzazioni di esecuzione e attivazione specifiche di un'applicazione

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare clic con il pulsante destro del mouse sull'applicazione DCOM per il quale si desidera modificare le autorizzazioni di accesso e quindi scegliere Proprietà.

  3. Selezionare la scheda Sicurezza.

  4. In Autorizzazione di esecuzione e attivazione fare clic sul pulsante Personalizza e quindi su Modifica.

  5. Per rimuovere un account utente o un gruppo, selezionare il gruppo o l'utente nell'elenco Utenti e gruppi e quindi fare clic su Rimuovi. L'account utente o il gruppo selezionato non sarà più visualizzato nell'elenco.

  6. Per aggiungere un account utente o un gruppo, fare clic su Aggiungi. Nel riquadro inferiore della finestra di dialogo Seleziona utenti, computer o gruppi digitare il nome completo dell'utente o del gruppo da aggiungere. Se non si conosce il nome dell'utente o del gruppo desiderato, fare clic su Avanzate e quindi su Trova per visualizzare un elenco di utenti e gruppi nel dominio selezionato. Selezionare un utente o un gruppo nell'elenco e quindi fare clic su OK. L'account utente o il gruppo aggiunto verrà visualizzato nell'elenco Utenti e gruppi.

  7. Nell'elenco Utenti e gruppi selezionare il gruppo o l'utente di cui si desidera modificare le autorizzazioni di accesso predefinite.

  8. Nell'elenco Autorizzazioni selezionare le caselle di controllo Consenti o Nega per consentire o negare le autorizzazioni di esecuzione locale, le autorizzazioni di attivazione locale, le autorizzazioni di esecuzione remota e le autorizzazioni di attivazione remota per il gruppo o l'utente selezionato.

  9. Fare clic su OK due volte. Le nuove impostazioni di esecuzione e attivazione specifiche dell'applicazione verranno applicate al successivo avvio di un'applicazione nel computer.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Ulteriori riferimenti

  • Impostare la configurazione della sicurezza COM specifica di un'applicazione


Gestire le transazioni distribuite

Il servizio Distributed Transaction Coordinator (DTC) coordina le transazioni utilizzate per l'aggiornamento di due o più risorse protette tramite transazioni, come i database, le code di messaggi, i file system e così via. Queste risorse protette tramite transazioni possono trovarsi in un singolo sistema oppure essere distribuite su numerosi sistemi in rete.

Lo snap-in Servizi componenti consente di configurare i computer affinché supportino transazioni locali, remote e distribuite. In Servizi componenti è inoltre possibile monitorare e gestire tutte le transazioni.

Gestione delle transazioni

Servizi componenti offre diverse funzionalità che possono essere utilizzate dagli amministratori per eseguire attività di amministrazione di base del gestore di transazioni DTC nel computer locale e in sistemi remoti.

Quando si amministrano le transazioni, configurare innanzitutto il DTC che le coordinerà per le applicazioni in esecuzione nel computer. Per impostazione predefinita, tutte le transazioni in un computer vengono coordinate dal gestore di transazioni DTC locale del computer. È inoltre possibile configurare il computer per indirizzare tutto il traffico di coordinamento delle transazioni al gestore di transazioni DTC di un computer remoto.

L'attività principale successive per l'amministrazione delle transazioni consiste nel configurare il gestore DTC responsabile del coordinamento delle transazioni. È possibile utilizzare Servizi componenti per amministrare il gestore di transazioni DTC locale oppure il gestore di un computer remoto. È possibile accedere alla finestra delle proprietà del DTC locale nell'albero della console di Servizi componenti, nel modo seguente:

Servizi componenti\Computer\Nome computer\Distributed Transaction Coordinator

Le attività di configurazione disponibili includono l'avvio e l'arresto della registrazione, la modifica delle dimensioni e del percorso del registro e la modifica di varie impostazioni di sicurezza per il gestore delle transazioni DTC.

Servizi componenti include inoltre le utilità Elenco transazioni e Statistiche transazioni per il gestore delle transazioni DTC. È possibile utilizzare tali utilità per visualizzare o modificare lo stato delle transazioni controllate dal gestore DTC.

Per informazioni sulle attività di DTC non incluse qui, vedere la Guida all'amministrazione di DTC all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66713.

  • Configurare il servizio DTC (Distributed Transaction Coordinator) predefinito

  • Configurare la traccia di DTC

  • Configurare la registrazione di DTC

  • Configurare la sicurezza di DTC

  • Utilizzare le funzionalità di backup e ripristino di Windows con DTC


Configurare il servizio DTC (Distributed Transaction Coordinator) predefinito

Per impostazione predefinita, ogni sistema utilizza un gestore di transazioni DTC per avviare e coordinare le transazioni. È tuttavia possibile configurare il computer affinché utilizzi il gestore di transazioni DTC di un altro sistema per impostazione predefinita. Il gestore di transazioni DTC in un sistema specificato viene utilizzato per coordinare le transazioni ogni volta che un client nel sistema locale inizia una transazione DTC e non specifica in modo esplicito un gestore DTC. Il gestore DTC coordina tutte le transazioni iniziate da COM+ o da qualsiasi altro client che utilizza le transazioni. Il gestore DTC predefinito coordina inoltre le transazioni relative a tutti i gestori di risorse nel sistema locale integrati in qualsiasi transazione DTC.

Il sistema selezionato come DTC deve essere affidabile, così come la connessione di rete a esso. In caso contrario, l'impostazione di un DTC potrebbe ridurne la disponibilità nel sistema locale.

Se si decide di utilizzare un DTC remoto, sia quest'ultimo sia il computer devono essere configurati per consentire l'accesso DTC di rete. A questo scopo, vedere Configurare la sicurezza di DTC.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Esaminare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Per designare un sistema remoto come DTC

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare clic con il pulsante destro del mouse sul computer per il quale si desidera modificare le impostazioni DTC (ad esempio Risorse del computer) e quindi scegliere Proprietà.

  3. Nelle finestra di dialogo delle proprietà del computer, fare clic sulla scheda MSDTC.

  4. Deselezionare la casella di controllo Usa coordinatore locale.

  5. In Nome host coordinatore remoto digitare il nome del sistema remoto. Se non si è certi del nome esatto, fare clic su Seleziona per visualizzare un elenco di tutti i computer nella rete e quindi selezionare quello desiderato nell'elenco.

  6. Fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Per configurare il sistema DTC, è necessario disporre di credenziali amministrative sia sul sistema locale sia su quello da impostare come coordinatore predefinito. In questo modo il sistema DTC locale può recuperare le informazioni appropriate dal Registro di sistema nel sistema DTC.

Per designare il sistema locale come sistema DTC

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul computer che si desidera designare come DTC e quindi scegliere Proprietà.

  3. Nella finestra di dialogo delle proprietà del computer fare clic sulla scheda MSDTC.

  4. Selezionare la casella di controllo Usa coordinatore locale.

  5. Fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

  • Per configurare il coordinatore di transazione predefinito, è necessario disporre di credenziali di amministratore sia nel sistema locale sia in quello da impostare come coordinatore predefinito. In questo modo il sistema DTC locale può recuperare le informazioni appropriate dal Registro di sistema nel coordinatore di transazione predefinito.

Ulteriori riferimenti

  • Gestire le transazioni distribuite


Configurare la traccia di DTC

È possibile configurare la traccia in background nella finestra delle proprietà di DTC locale nello snap-in Servizi componenti. È possibile utilizzare questa interfaccia per configurare esclusivamente la traccia in background. Non è possibile utilizzarlo per controllare la traccia di transazioni singole o per controllare le impostazioni di traccia in remoto. Per configurare la traccia di DTC (Distributed Transaction Coordinator), è possibile selezionare le opzioni di output e le opzioni di registrazione. È possibile utilizzare le opzioni di registrazione per controllare il file di registro dei dati di traccia.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per configurare la traccia di DTC

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare doppio clic su Computer, Nome computer e Distributed Transaction Coordinator.

  3. Fare clic con il pulsante destro del mouse su DTC locale e quindi scegliere Proprietà.

  4. Nella scheda Analisi in Opzioni di output selezionare o deselezionare le caselle di controllo corrispondenti alle opzioni di output desiderate.

  5. In Opzioni di registrazione fare clic su Nuova sessione, Arresta sessione o Cancella dati a seconda delle esigenze.

    È inoltre possibile specificare un valore in Numero max. buffer di memoria (dimensioni PageSize).

  6. Fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Ulteriori riferimenti

  • Gestire le transazioni distribuite


Configurare la registrazione di DTC

È possibile configurare il percorso e le dimensioni del file di registro di DTC (Distributed Transaction Coordinator).

Attenzione

Se si modificano le dimensioni del file di registro di DTC, il file di registro corrente viene eliminato e sostituito con un nuovo file. Prima di modificare il file di registro verificare che il file di registro esistente possa essere eliminato con sicurezza verificando che non siano presenti transazioni nello stato In dubbio, Impossibile notificare abbandono oppure Impossibile notificare commit. Per ulteriori informazioni sulla gestione dei file di registro di DTC, vedere la pagina relativa alla gestione dei file di registro di DTC all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66753.

Importante

Prima di configurare il file di registro, arrestare DTC nello snap-in Servizi. Se non si arresta DTC, il tentativo di reimpostare il file di registro genererà un messaggio della console DTC indicante che il servizio deve essere arrestato e riavviato per poter eseguire l'azione richiesta.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per configurare la registrazione di DTC

  1. Aprire Servizi componenti.

  2. Nell'albero della console fare doppio clic su Computer, Nome computer e Distributed Transaction Coordinator.

  3. Fare clic con il pulsante destro del mouse su DTC locale e quindi scegliere Proprietà.

  4. Per modificare il percorso del file di registro, fare clic sulla scheda Registrazione. In Percorso digitare il nuovo percorso del file di registro. Se non si conosce il percorso completo, fare clic su Sfoglia per selezionarlo.

  5. Per modificare le dimensioni del file di registro, in Capacità digitare il nuovo valore delle dimensioni espresse in megabyte (MB).

  6. Fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Ulteriori riferimenti

  • Gestire le transazioni distribuite


Configurare la sicurezza di DTC

È possibile configurare i requisiti di sicurezza per le transazioni distribuite a cui partecipa il computer. Le impostazioni di sicurezza predefinite non consentono al computer di partecipare a transazioni distribuite remote.

Importante
  • Per impostazione predefinita, Distributed Transaction Coordinator (DTC) viene eseguito con l'account Servizio di rete. Questo account è progettato specificatamente per consentire a servizi quali DTC (Distributed Transaction Coordinator) di essere eseguiti con l'insieme di privilegi appropriato. Per ridurre il rischio che si verifichino problemi di sicurezza e assicurare che il servizio DTC venga eseguito, è consigliabile utilizzare l'account Servizio di rete predefinito. In alternativa, è possibile utilizzare un account utente di dominio.

  • Se si abilitano le transazioni di rete di DTC in un computer in cui è attivato Windows Firewall, è inoltre necessario configurare il computer affinché sia consentito il traffico DTC attraverso il firewall. Per ulteriori informazioni su Windows Firewall, vedere la pagina relativa alla gestione di eccezioni per servizi di sistema, porte e programmi all'indirizzo http://go.microsoft.com/fwlink/?LinkId=67467.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per configurare la sicurezza DTC in modo da consentire solo transazioni locali

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare doppio clic su Computer, Nome computer e Distributed Transaction Coordinator.

  3. Fare clic con il pulsante destro del mouse su DTC locale, scegliere Proprietà e quindi fare clic sulla scheda Sicurezza.

  4. In Impostazioni sicurezza deselezionare la casella di controllo Accesso di rete DTC.

  5. Proseguire con la configurazione delle impostazioni della sicurezza oppure fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Per configurare la sicurezza DTC in modo da utilizzare un servizio DTC remoto

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare doppio clic su Computer, Nome computer e Distributed Transaction Coordinator.

  3. Fare clic con il pulsante destro del mouse su DTC locale, scegliere Proprietà e quindi fare clic sulla scheda Sicurezza.

  4. In Impostazioni sicurezza selezionare la casella di controllo Accesso di rete DTC.

  5. In Comunicazione gestore transazioni selezionare le caselle di controllo Consenti connessioni in ingresso e Consenti connessioni in uscita.

  6. Selezionare un livello di autenticazione per le comunicazioni DTC. Necessaria autenticazione reciproca rappresenta il livello con la maggiore sicurezza.

  7. Proseguire con la configurazione delle impostazioni di sicurezza oppure fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Per coordinare le transazioni remote

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare doppio clic su Computer, Nome computer e Distributed Transaction Coordinator.

  3. Fare clic con il pulsante destro del mouse su DTC locale, scegliere Proprietà e quindi fare clic sulla scheda Sicurezza.

  4. In Impostazioni sicurezza selezionare la casella di controllo Accesso di rete DTC.

  5. In Client e amministrazione selezionare la casella di controllo Consenti client remoti.

  6. In Comunicazione gestore transazioni selezionare le caselle di controllo Consenti connessioni in ingresso e Consenti connessioni in uscita.

  7. Selezionare un livello di autenticazione per le comunicazioni DTC. Il livello Necessaria autenticazione reciproca è quello che offre maggiore sicurezza.

  8. Proseguire con la configurazione delle impostazioni di sicurezza oppure fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Per modificare l'account di accesso DTC

  1. Aprire Servizi componenti.

  2. Nello snap-in Servizi componenti fare doppio clic su Computer, Nome computer e Distributed Transaction Coordinator.

  3. Fare clic con il pulsante destro del mouse su DTC locale, scegliere Proprietà e quindi fare clic sulla scheda Sicurezza.

  4. In Account di accesso DTC specificare l'account con cui eseguire DTC oppure fare clic su Sfoglia per individuare il nome dell'account. Digitare e quindi confermare la password per l'account.

  5. Fare clic su OK.

Ulteriori considerazioni

  • Servizi componenti non è più disponibile in Strumenti di amministrazione. Per aprire Servizi componenti, fare clic sul pulsante Start. Nella casella di ricerca digitare dcomcnfg e quindi premere INVIO.

Ulteriori riferimenti

  • Gestire le transazioni distribuite


Utilizzare le funzionalità di backup e ripristino di Windows con DTC

Distributed Transaction Coordinator (DTC) è perfettamente compatibile con le funzionalità di backup e ripristino di Windows.

Le operazioni di backup e ripristino, tuttavia, possono essere eseguite soltanto sulle risorse del computer locale. Pertanto, in presenza di transazioni attive che interessano più computer, la coerenza delle transazioni non potrà essere garantita.

Per evitare l'insorgere di problemi, durante le operazioni di backup o ripristino verificare che non siano presenti transazioni incomplete nelle condizioni seguenti:

  • Un computer è in esecuzione come coordinatore DTC remoto

    Eseguire la procedura "Per determinare se un computer utilizza un coordinatore remoto" per stabilire se il computer utilizza un coordinatore remoto. Per risolvere le eventuali transazioni incomplete, eseguire la procedura "Per visualizzare e risolvere le transazioni esistenti".

  • In un computer è in esecuzione un'applicazione coinvolta in transazioni che interessano più computer

    Eseguire la procedura "Per determinare se un computer utilizza un coordinatore remoto" nel computer in cui è in esecuzione l'applicazione per individuare il coordinatore delle transazioni di tale computer. Per risolvere le eventuali transazioni incomplete, eseguire la procedura "Per visualizzare e risolvere le transazioni esistenti" nel computer in cui è in esecuzione il coordinatore.

Per determinare se un computer utilizza un coordinatore remoto

  1. Aprire lo snap-in Servizi componenti.

  2. Fare clic con il pulsante destro del mouse sul computer per il quale si desidera modificare le impostazioni DTC (ad esempio Risorse del computer) e quindi scegliere Proprietà.

  3. Nella finestra di dialogo delle proprietà del computer fare clic sulla scheda MSDTC.

  4. Se la casella di controllo Usa coordinatore locale è deselezionata, il nome computer visualizzato in Nome host coordinatore remoto indica il coordinatore remoto utilizzato dal computer.

  5. Fare clic su OK.
Per visualizzare e risolvere le transazioni esistenti

  1. Aprire lo snap-in Servizi componenti nel computer che svolge il ruolo di coordinatore delle transazioni.

  2. Fare doppio clic su Computer, Risorse del computer, Distributed Transaction Coordinator e DTC locale, quindi fare clic su Elenco transazioni.

    Verrà visualizzato un elenco di tutte le transazioni incomplete.

  3. Per risolvere una transazione incompleta, fare clic con il pulsante destro del mouse sulla transazione, quindi scegliere Risolvi. Scegliere Esegui commit, Interrompi o Ignora in base alle esigenze.

Ulteriori riferimenti

  • Gestire le transazioni distribuite


Interfaccia utente: Servizi componenti

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Attivazione

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Avanzate

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Dump

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Generale

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Identità

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Pool e riciclo

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Accodamento

  • Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Sicurezza

  • Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Endpoint

  • Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Generale

  • Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Identità

  • Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Percorso

  • Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Sicurezza

  • Finestra delle proprietà di Risorse del computer: scheda Sicurezza COM

  • Finestra delle proprietà di Risorse del computer: scheda Proprietà predefinite

  • Finestra delle proprietà di Risorse del computer: scheda Protocolli predefiniti

  • Finestra delle proprietà di Risorse del computer: scheda Generale

  • Finestra delle proprietà di Risorse del computer: scheda MSDTC

  • Finestra delle proprietà di Risorse del computer: scheda Opzioni

  • Finestra delle proprietà di DTC locale: scheda Registrazione

  • Finestra delle proprietà di DTC locale: scheda Sicurezza

  • Finestra delle proprietà di DTC locale: scheda Analisi


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Attivazione

Elemento Dettagli

Tipo di attivazione

Fare clic su Applicazione libreria per un'applicazione che viene eseguita nel processo del client che l'ha creata. Può essere chiamata solo dai client che si trovano nello stesso computer.

Fare clic su Applicazione server per un'applicazione che viene eseguita nel proprio processo server dedicato.

Se si modifica il tipo di attivazione di un'applicazione, altre proprietà dell'applicazione potrebbero risultare reimpostate.

SOAP

Se si seleziona la casella di controllo Usa SOAP:

  • In VRoot SOAP specificare la directory radice virtuale di Internet Information Services (IIS) in cui i componenti dell'applicazione devono essere resi disponibili come servizio Web XML.

  • Protezione SOAP indica se la sicurezza basata sui ruoli COM+ viene implementata per le attivazioni tramite SOAP (Simple Object Access Protocol).

Nome server remoto

Digitare il nome del server remoto utilizzato dal proxy di applicazione. I proxy di applicazione indirizzano le chiamate client a un'applicazione server COM+ installata in un computer remoto.

Directory radice applicazione

Digitare il percorso completo della directory contenente un file di manifesto dell'assembly affiancato valido utilizzato per creare un contesto di attivazione per l'applicazione. Le applicazioni utilizzano i contesti per caricare una determinata versione di DLL, istanza dell'oggetto COM oppure versione di finestra personalizzata.


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Avanzate

Elemento Dettagli

Arresto processi server

È possibile configurare un processo server in modo che venga arrestato dopo un determinato periodo di inattività. Si tratta di un modo utile per liberare automaticamente risorse non più necessarie. Selezionare una delle opzioni seguenti:

  • Fare clic su Continua l'esecuzione anche in caso di inattività del sistema per specificare che il processo server associato all'applicazione COM+ deve rimanere in esecuzione in assenza di chiamate client in corso. L'applicazione rimarrà in esecuzione finché non viene chiusa manualmente.

  • Fare clic su Abilita chiusura per inattività per specificare che il processo server associato all'applicazione COM+ deve essere arrestato automaticamente dopo un determinato periodo di inattività corrispondente al numero di minuti indicato nella casella di testo.

Protezione

Selezionare una o entrambe le caselle di controllo seguenti per impedire l'eliminazione o la modifica dell'applicazione:

  • Disabilita eliminazione

  • Disabilita modifiche

Debug

Selezionare la casella di controllo Avvia nel debugger per specificare che un'applicazione server deve essere avviata nel debugger mediante la riga di comando specificata in Percorso debugger.

Digitare il percorso e la riga di comando utilizzata per richiamare il debugger quando l'opzione Avvia nel debugger è abilitata. Per cercare il debugger, fare clic su Sfoglia. Eventuali opzioni della riga di comando per il debugger devono essere digitate nella casella di testo dopo aver individuato il debugger.

Abilita gestori delle risorse di compensazione

Selezionare questa casella di controllo per abilitare l'utilizzo di un gestore delle risorse di compensazione da parte dell'applicazione server. I componenti del gestore delle risorse di compensazione sono disponibili per l'applicazione soltanto se questa casella di controllo è selezionata.

Abilita supporto 3 GB

Selezionare questa casella di controllo per specificare che l'applicazione può accedere a un massimo di 3 GB di memoria se il sistema operativo è stato configurato per consentire l'accesso a più di 2 GB di memoria.


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Dump

Elemento | Dettagli
Directory dump immagini | Digitare il percorso completo del file di dump. Non includere il nome file. Il percorso predefinito è %SystemRoot%\system32\com\dmp.
Numero max. immagini di dump | Selezionare il numero massimo di file da generare nella directory dump immagini al raggiungimento del quale i file verranno sovrascritti. Il numero deve essere compreso tra 1 e 200. Il numero predefinito è 5.
Abilitazione dump immagini processo | Selezionare la casella di controllo Abilita dump immagini in caso di errore dell'applicazione per effettuare il dump di un'immagine statica dell'applicazione se si verifica un'eccezione o un errore.


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Generale

Elemento | Dettagli
Descrizione | È possibile digitare una descrizione di massimo 500 caratteri che consenta di identificare e gestire l'elemento selezionato.
ID applicazione | Identificatore univoco globale (GUID) della partizione di applicazione COM+ selezionata. Il GUID viene generato automaticamente quando viene creata la partizione COM+. È possibile utilizzarlo per identificare versioni particolari della partizione in un computer.


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Identità

Elemento Dettagli

Pulsanti di opzione Account sistema

Fare clic sul pulsante di opzione corrispondente all'account con cui eseguire l'applicazione:

  • Utente interattivo: fare clic su questo pulsante per specificare che l'applicazione viene eseguita con l'identità dell'utente attualmente connesso al computer. Le credenziali di sicurezza dell'utente verranno utilizzate quando l'applicazione viene autenticata per l'accesso alle risorse.

  • Servizio locale: fare clic su questo pulsante per specificare che l'applicazione viene eseguita con l'account Servizio locale.

  • Servizio di rete: fare clic su questo pulsante per specificare che l'applicazione viene eseguita con l'account Servizio di rete.

  • Local System: fare clic su questo pulsante per specificare che l'applicazione viene eseguita con l'account Local System. Questo account garantisce all'applicazione l'accesso completo al computer locale.

Pulsante di opzione Per questo utente

Fare clic su Per questo utente per specificare che l'applicazione viene eseguita con l'identità di un account utente specifico. Le credenziali di sicurezza dell'utente verranno utilizzate quando l'applicazione viene autenticata per l'accesso alle risorse. Digitare il nome e la password dell'utente.


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Pool e riciclo

Elemento Dettagli

Pool di applicazioni

In Dimensioni pool digitare il numero massimo di processi server di applicazione che possono essere eseguiti contemporaneamente. Il numero predefinito è 1, il quale indica che il servizio di Pool di applicazioni COM+ è disabilitato.

Riciclo applicazioni

È possibile selezionare i valori per le opzioni seguenti:

  • Limite durata: numero massimo di minuti di esecuzione di un processo prima che venga riciclato. L'intervallo valido è compreso tra 0 e 30.240 minuti (21 giorni).

  • Limite memoria: quantità massima di memoria, in kilobyte (KB), che può essere utilizzata dal processo prima che quest'ultimo venga riciclato. Se l'utilizzo di memoria da parte del processo supera il numero specificato per più di un minuto, il processo viene riciclato. L'intervallo valido è compreso tra 0 e 1.048.576 KB. Il valore predefinito è 0 KB.

  • Timeout scadenza: numero di minuti di attesa del rilascio di tutti i riferimenti esterni a oggetti inclusi nel processo, prima che quest'ultimo venga forzatamente arrestato. L'intervallo valido è compreso tra 1 e 1440 minuti (24 giorni). Il valore predefinito è 15 minuti. Questo valore viene utilizzato solo se si è già determinato che il processo verrà riciclato in base ad altri criteri.

  • Limite chiamate: numero massimo di chiamate accettabili da parte degli oggetti dell'applicazione prima del riciclo del processo. L'intervallo valido è compreso tra 0 e 1.048.576 chiamate.

  • Limite attivazione: numero massimo di attivazioni di oggetti dell'applicazione da accettare prima del riciclo del processo. L'intervallo valido è compreso tra 0 e 1.048.576 attivazioni.


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Accodamento

Elemento | Dettagli
Casella di gruppo Autenticazione messaggi MSMQ | Fare clic su Autentica i messaggi se l'opzione Livello di autenticazione per le chiamate (nella pagina delle proprietà Sicurezza) non è impostata su Nessuno per autenticare i messaggi del client che richiedono i servizi dell'applicazione solo se Accodamento messaggi verifica l'integrità delle richieste. Se Livello di autenticazione per le chiamate nella scheda Sicurezza della finestra delle proprietà dell'applicazione è impostato su Nessuno, i messaggi non vengono autenticati.
Max. riproduttori simultanei | Digitare il numero massimo di thread simultanei in attesa della coda. Se il numero massimo viene superato, i messaggi restano nella coda in attesa del thread disponibile successivo.


Finestra delle proprietà - <Applicazione> di Applicazioni COM+: scheda Sicurezza

Elementi Dettagli

Autorizzazione

Selezionare la casella di controllo Applica controlli di accesso per questa applicazione per applicare controlli di accesso basati sui ruoli per l'applicazione. Se per un'applicazione sono definiti ruoli, verrà controllata l'appartenenza a un ruolo del chiamante a ogni chiamata nell'applicazione.

Livello di sicurezza

Fare clic su Esegui i controlli di accesso solo a livello di processo per abilitare i controlli di accesso solo a livello di applicazione. In questo modo non verrà eseguito alcun controllo dei ruoli a livello di componente, interfaccia o metodo. Se la casella di controllo Applica controlli di accesso per questa applicazione non è selezionata, questa impostazione verrà ignorata.

Fare clic su Esegui i controlli di accesso a livello di processo e componente per abilitare i controlli di accesso a ogni livello per le chiamate nell'applicazione. Il controllo dei ruoli viene eseguito a livello di applicazione, nonché a livello di componente, interfaccia e metodo per ogni componente per il quale l'opzione Applica controlli di accesso a livello di componente è selezionata nella scheda Sicurezza delle proprietà. Se la casella di controllo Applica controlli di accesso per questa applicazione non è selezionata, questa impostazione verrà ignorata.

Criteri di restrizione software

Selezionare la casella di controllo Applica criteri di restrizione software per configurare il livello di attendibilità dei criteri di restrizione software per l'applicazione nella casella a discesa Livello di restrizione. Se la casella di controllo non è selezionata, viene utilizzata la configurazione dei criteri di restrizione software a livello di sistema.

Livello di autenticazione per le chiamate

L'impostazione di un livello di autenticazione per un'applicazione consente di determinare il livello di autenticazione eseguito quando il client esegue una chiamata nell'applicazione. Livelli di autenticazione elevati garantiscono maggiore sicurezza e integrità. Il livello di autenticazione selezionato viene applicato al successivo avvio dell'applicazione.

Selezionare il livello di autenticazione appropriato. I livelli di autenticazione seguenti sono ordinati dal più basso al più alto:

  • Nessuno: l'autenticazione non viene eseguita.

  • Connessione: l'autenticazione delle credenziali viene eseguita solo se viene stabilita la connessione.

  • Chiamata: l'autenticazione delle credenziali viene eseguita all'inizio di ogni chiamata.

  • Pacchetto: l'autenticazione delle credenziali viene eseguita e viene verificata la ricezione di tutti i dati di chiamata. Si tratta dell'impostazione predefinita per le applicazioni server COM+.

  • Integrità pacch.: l'autenticazione delle credenziali viene eseguita e viene verificato che i dati di chiamata non siano stati modificati durante il trasferimento.

  • Riservatezza pacch., vengono eseguite l'autenticazione delle credenziali e la crittografia del pacchetto, incluse la firma e l'identità del mittente e dei dati.

Livello rappresentazione

Quando si imposta un livello di rappresentazione per un'applicazione, si determina il livello di autorità concesso dall'applicazione ad altre applicazioni per utilizzarne l'identità al momento della chiamata. È possibile impostare il livello di rappresentazione solo per le applicazioni server COM+. Le applicazioni libreria vengono eseguite con l'identità del processo host e utilizzano il livello di rappresentazione da esso specificato.

Selezionare il livello di rappresentazione appropriato. I livelli di rappresentazione seguenti sono ordinati dal quello con autorità minima a quello con autorità massima:

  • Anonimo: il client è anonimo per il server. Il server può rappresentare il client, ma il token di rappresentazione (una credenziale locale) non contiene alcuna informazioni sul client.

  • Identifica: il server può ottenere l'identità del client e rappresentarlo per determinare i livelli di controllo di accesso.

  • Rappresenta: si tratta dell'impostazione predefinita per le applicazioni server COM+. Il server può rappresentare il client quando agisce per conto di quest'ultimo, sebbene con restrizioni. Il server può accedere a risorse sullo stesso computer del client. Se il server si trova sullo stesso computer del client, potrà accedere alle risorse di rete nello stesso modo del client. Se il server si trova su un altro computer, potrà accedere solo alle risorse disponibile sullo stesso computer del server.

  • Delega: il server può rappresentare il client quando agisce per conto di quest'ultimo, indipendentemente dal fatto che si trovi sullo stesso computer del client. Durante la rappresentazione, le credenziali del client, sia quelle con validità locale sia quelle con validità di rete, possono essere passate a un numero qualsiasi di computer.


Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Endpoint

Elemento Dettagli

Protocolli ed endpoint DCOM

In Protocolli ed endpoint DCOM fare clic sulla voce per specificare il protocollo di rete utilizzato per comunicare con un coordinatore di commit remoto:

  • Fare clic su Aggiungi per selezionare la sequenza di protocolli di rete DCOM da aggiungere.

  • Fare clic su Rimuovi per rimuovere la voce evidenziata.

  • Fare clic su Proprietà per modificare le proprietà degli endpoint DCOM relative al protocollo specificato.

  • Fare clic su Cancella per cancellare l'elenco di protocolli ed endpoint DCOM.


Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Generale

Elemento Dettagli

Nome applicazione

Nome dell'applicazione DCOM.

ID applicazione

Si tratta dell'ID applicazione univoco generato automaticamente al momento della creazione di un'applicazione. È possibile utilizzarlo per identificare versioni particolari dell'applicazione in un computer.

Tipo applicazione

Tipo dell'applicazione, inclusa la posizione nel computer locale o in un altro computer nella rete.

Livello autenticazione

Nella casella a discesa, selezionare la sicurezza a livello di pacchetto utilizzata dall'applicazione ai fini delle comunicazioni. Le impostazioni di sicurezza seguenti sono ordinate da quella con il livello di sicurezza più basso a quella con il livello di sicurezza più alto:

  • Nessuno. l'autenticazione non viene eseguita.

  • Connessione: l'autenticazione delle credenziali viene eseguita solo se viene stabilita la connessione.

  • Chiamata: l'autenticazione delle credenziali viene eseguita all'inizio di ogni chiamata.

  • Pacchetto: l'autenticazione delle credenziali viene eseguita e viene verificata la ricezione di tutti i dati di chiamata. Si tratta dell'impostazione predefinita per le applicazioni server COM+.

  • Integrità pacch.: l'autenticazione delle credenziali viene eseguita e viene verificato che i dati di chiamata non siano stati modificati durante il trasferimento.

  • Riservatezza pacch., vengono eseguite l'autenticazione delle credenziali e la crittografia del pacchetto, incluse la firma e l'identità del mittente e dei dati.

Percorso locale o Nome servizio

Se il Tipo applicazione è Server locale, in Percorso locale viene indicato il percorso completo dell'applicazione. Se il Tipo applicazione è Servizio locale, viene visualizzato il Nome servizio.


Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Identità

Elemento | Dettagli
Pulsante di opzione Utente interattivo | Fare clic per specificare che l'applicazione viene eseguita con l'identità dell'utente attualmente connesso al computer. Le credenziali di sicurezza dell'utente verranno utilizzate quando l'applicazione viene autenticata per l'accesso alle risorse.
Pulsante di opzione Utente che esegue l'avvio | Fare clic per specificare che l'applicazione viene eseguita mediante il contesto di sicurezza dell'utente che l'ha avviata, in modo che l'applicazione possa essere autenticata nel dominio. L'utente che esegue l'avvio può coincidere con l'utente interattivo.
Pulsante di opzione Per questo utente | Fare clic per specificare che l'applicazione viene eseguita mediante il contesto di sicurezza dell'utente specificato, in modo che possa essere autenticata nel dominio. Digitare il nome utente e la password.
Pulsante di opzione Account di sistema | Fare clic per specificare che l'applicazione server viene eseguita mediante il contesto di sicurezza dell'account di sistema predefinito. Questa opzione è disponibile solo per applicazioni installate come servizi.


Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Percorso

Elemento | Dettagli
Casella di controllo Esegui l'applicazione nel computer in cui sono memorizzati i dati | Selezionare questa casella di controllo per specificare che l'applicazione viene eseguita nel computer in cui si trovano i dati. Si tratta di un'opzione utile solo se l'applicazione client include un file di dati per l'applicazione server.
Casella di controllo Esegui l'applicazione in questo computer | Selezionare questa casella di controllo per specificare che l'applicazione viene eseguita nel computer locale.
Casella di controllo Esegui l'applicazione nel computer seguente | Selezionare questa casella di controllo per specificare che l'applicazione viene eseguita nel computer specificato dall'utente.


Finestra delle proprietà - <Applicazione> di configurazione DCOM: scheda Sicurezza

Elemento Dettagli

Autorizzazione di esecuzione e attivazione

Fare clic su uno dei pulsanti di opzione seguenti:

  • Usa predefinite: fare clic su questo pulsante per specificare che l'applicazione utilizza le autorizzazioni predefinite impostate nella scheda Sicurezza COM delle pagine delle proprietà del computer.

  • Personalizza: fare clic su questo pulsante per specificare che l'applicazione utilizza le autorizzazioni impostate dall'utente. Per cambiare le autorizzazioni, fare clic su Modifica.

Autorizzazioni di accesso

Fare clic su uno dei pulsanti di opzione seguenti:

  • Usa predefinite: fare clic su questo pulsante per specificare che l'applicazione utilizza le autorizzazioni predefinite impostate nella scheda Sicurezza COM delle pagine delle proprietà del computer.

  • Personalizza: fare clic su questo pulsante per specificare che l'applicazione utilizza le autorizzazioni impostate dall'utente. Per cambiare le autorizzazioni, fare clic su Modifica.

Autorizzazioni di configurazione

Fare clic su uno dei pulsanti di opzione seguenti:

  • Usa predefinite: fare clic su questo pulsante per specificare che l'applicazione utilizza le autorizzazioni di configurazione del Registro di sistema predefinite.

  • Personalizza: fare clic su questo pulsante per specificare che l'applicazione utilizza le autorizzazioni di configurazione del Registro di sistema impostate dall'utente. Per cambiare le autorizzazioni, fare clic su Modifica.


Finestra delle proprietà di Risorse del computer: scheda Sicurezza COM

Elementi Dettagli

Autorizzazioni di accesso

Fare clic sul pulsante Modifica limiti per impostare i limiti delle autorizzazioni di accesso per le applicazioni.

Fare clic sul pulsante Modifica predefinite per selezionare gli account e i gruppi di utenti a cui sono assegnate o negate per impostazione predefinita, le autorizzazioni di accesso alle applicazioni in questo computer. Questa impostazione non influisce sulle applicazioni COM+.

Autorizzazione di esecuzione e attivazione

Fare clic sul pulsante Modifica limiti per impostare i limiti assoluti per le autorizzazioni di esecuzione e attivazione dei componenti.

Fare clic sul pulsante Modifica predefinite per selezionare gli account e i gruppi di utenti a cui sono assegnate o negate per impostazione predefinita, le autorizzazioni di esecuzione delle applicazioni in questo computer. Questa impostazione non influisce sulle applicazioni COM+.


Finestra delle proprietà di Risorse del computer: scheda Proprietà predefinite

Elemento Dettagli

Casella di controllo Abilita DCOM in questo computer

Selezionare questa casella di controllo per specificare che DCOM è disponibile per tutte le applicazioni COM (Component Object Model) installate nel computer. In questo modo il computer potrà scambiare chiamate con applicazioni in altri computer.

Casella di controllo Abilita servizi Internet COM in questo computer

Selezionare questa casella di controllo per specificare che le comunicazioni DCOM sono disponibili tramite Internet per tutte le applicazioni COM installate nel computer. Ciò consente ai server DCOM nel computer di ricevere chiamate in ingresso da parte di client che utilizzano il tunneling TCP.

Proprietà predefinite comunicazione DCOM

Livello di autenticazione predefinito: selezionare un livello di autenticazione a livello di sistema utilizzabile dalle applicazioni server e client COM per verificare le rispettive identità durante le chiamate. I livelli sono ordinati in base al livello di sicurezza crescente.

Livello di rappresentazione predefinito: selezionare il livello predefinito di autorità a livello di sistema che un client COM nel computer può concedere a un'applicazione server per l'esecuzione di attività di elaborazione per suo conto. I livelli sono ordinati in base al livello di autorità crescente.

Sicurezza aggiuntiva rilevamento dei riferimenti: selezionare questa casella di controllo per abilitare l'autenticazione di chiamate di conteggio dei riferimenti distribuiti nel computer. Se questa opzione è abilitata, la traccia dei riferimenti impedisce ai client COM di rilasciare oggetti in anticipo, tuttavia può determinarsi una riduzione delle prestazioni.


Finestra delle proprietà di Risorse del computer: scheda Protocolli predefiniti

Elemento | Dettagli
Protocolli DCOM | Elenca il gruppo di protocolli di rete disponibili per DCOM nel computer. Utilizzare questa finestra di dialogo per aggiungere o rimuovere protocolli di rete, modificare la priorità di utilizzo e configurarne le proprietà.
Aggiungi | Fare clic su questo pulsante per aggiungere un protocollo di rete che si desidera rendere disponibile per DCOM nel computer.
Rimuovi | Fare clic su questo pulsante per rimuovere il protocollo di rete selezionato dall'elenco di protocolli disponibili per DCOM nel computer.
Sposta su, Sposta giù | Fare clic su questi pulsanti per spostare il protocollo di rete selezionato più in alto o più in basso nell'elenco. L'ordine dei protocolli ne riflette la priorità di utilizzo. Il protocollo elencato per primo ha la priorità più alta.
Proprietà | Fare clic su questo pulsante per configurare le proprietà del protocollo selezionato. Questa opzione potrebbe non essere disponibile per tutti i protocolli.


Finestra delle proprietà di Risorse del computer: scheda Generale

Elemento | Dettagli
Descrizione | Digitare una descrizione di massimo 500 caratteri che consenta di identificare e gestire l'elemento selezionato.


Finestra delle proprietà di Risorse del computer: scheda MSDTC

Controllo Dettagli

Coordinatore predefinito

Usa coordinatore locale: selezionare questa casella di controllo per designare il sistema locale come coordinatore predefinito.

Nome host coordinatore remoto: se si deseleziona la casella di controllo Usa coordinatore locale, digitare il nome del computer da utilizzare come host remoto. Per visualizzare un elenco di computer nella rete e selezionarne uno, fare clic su Seleziona.


Finestra delle proprietà di Risorse del computer: scheda Opzioni

Elemento | Dettagli
Timeout transazioni | È possibile specificare il tempo massimo (in secondi) di attività delle transazioni prima che se ne verifichi il timeout. Le transazioni che rimangono attive oltre il periodo di timeout vengono automaticamente interrotte dal sistema. Se Timeout transazioni è impostato su 0, non si verifica mai alcun timeout.
Esporta | In RSN proxy applicazione digitare il nome del server remoto utilizzato per i proxy di applicazione esportati dal server in uso. Se la casella è vuota, viene utilizzato il nome di rete del computer.
Casella di controllo Attiva partizioni | Selezionare la casella di controllo Attiva partizioni per abilitare le partizioni COM+ nel computer. Selezionare la casella di controllo Controlla archivio locale per la selezione della partizione per l'utente per controllare verificare la presenza di partizioni COM+ nell'archivio locale prima di controllare i Servizi di dominio Active Directory.


Finestra delle proprietà di DTC locale: scheda Registrazione

Elemento Dettagli

Informazioni registro

Percorso: per modificare il percorso del file di registro, digitare il percorso completo oppure fare clic su Sfoglia per selezionarlo. Per poter modificare il percorso del file di registro, interrompere il servizio DTC nello snap-in Servizi. Al termine, riavviare il servizio.

Capacità: specificare le dimensioni, in megabyte (MB), del file di registro di DTC. Per poter modificare le dimensioni del file di registro, interrompere il servizio DTC nello snap-in Servizi. Al termine, riavviare il servizio.


Finestra delle proprietà di DTC locale: scheda Sicurezza

Elemento Dettagli

Casella di controllo Impostazioni sicurezza - Accesso di rete DTC

Selezionare questa casella di controllo se si desidera consentire qualsiasi traffico di rete per il servizio DTC (Distributed Transaction Coordinator).

Se la casella di controllo non è selezionata, il DTC non trasmetterà alcuna transazione alla rete, né accetterà traffico in ingresso. L'amministrazione remota del DTC risulterà inoltre disabilitata.

Casella di controllo Impostazioni sicurezza - Client e amministrazione

Consenti client remoti: selezionare questa casella di controllo se si desidera che il DTC coordini le transazioni per client remoti.

Consenti amministrazione remota: selezionare questa casella di controllo se si desidera consentire l'amministrazione del DTC da computer remoti.

Impostazioni sicurezza - Comunicazione gestore transazioni

Consenti connessioni in ingresso: selezionare questa casella di controllo per consentire il flusso di transizioni dal computer remoto al computer locale. Questa opzione è in genere necessaria nei computer che ospitano il DTC per un gestore di risorse quale Microsoft SQL Server.

Consenti connessioni in uscita: selezionare questa casella di controllo per consentire il flusso di transizioni dal computer locale al computer remoto. Questa opzione è in genere necessaria nel computer client in cui viene avviata la transazione.

Necessaria autenticazione reciproca: se questa opzione è selezionata, il DTC locale (proxy or servizio) comunica con un servizio DTC remoto esclusivamente mediante messaggi crittografati e autenticazione reciproca (autenticazione di dominio Windows). Se non è possibile stabilire una comunicazione sicura con il sistema remoto, la comunicazione viene negata. Questa opzione può essere utilizzata solo per la comunicazione con computer che eseguono Windows Server 2003, Windows XP SP2, Microsoft Windows Vista o Windows Server® 2008.

Necessaria autenticazione del chiamante in ingresso: se questa opzione è selezionata e non è possibile stabilire l'autenticazione reciproca ma il chiamante in ingresso è stato autenticato, la comunicazione è consentita. Questa opzione può essere utilizzata solo per la comunicazione con computer che eseguono Windows Server 2003 o Windows XP SP2.

Nessuna autenticazione: se questa opzione è selezionata, la comunicazione DTC nella rete può eseguire il fallback a una comunicazione non autenticata e non crittografata se i tentativi di avviare una comunicazione sicura hanno esito negativo. Questa opzione viene utilizzata soprattutto per consentire la comunicazione del DTC con computer che eseguono Windows 2000, Windows XP SP1 e versioni precedenti. Questa impostazione può inoltre essere utilizzata se in uno dei sistemi è disattivata la sicurezza di chiamata di procedura remota (RPC).

Casella di controllo Impostazioni sicurezza - Abilita transazioni XA

Selezionare questa casella di controllo per consentire l'utilizzo dello standard XA nelle transazioni. I gestori di risorse eseguiti su sistemi operativi diversi possono comunicare con un gestore delle transazioni DTC mediante lo standard XA.

Le interfacce XA costituiscono un gruppo standard di interfacce di programmazione che consentono agli sviluppatori di applicazioni COM+ di accedere a database compatibili con XA e creare gestori di risorse che funzionano con database relazionali, accodamento di messaggi, file transazionali e database orientati agli oggetti. Sebbene il protocollo XA non sia direttamente supportato da Microsoft, sono invece supportate le infrastrutture di conversione tra transazioni OLE e XA.

Account di accesso DTC

Consente di specificare l'account con cui viene eseguito il servizio DTC.

Per impostazione predefinita, DTC viene eseguito con l'account Servizio di rete. Questo account è progettato specificatamente per consentire a servizi quali DTC (Distributed Transaction Coordinator) di essere eseguiti con l'insieme di privilegi appropriato. Per ridurre il rischio che si verifichino problemi di sicurezza, è consigliabile utilizzare l'account Servizio di rete predefinito.

Se si sceglie di modificare l'account di accesso DTC, digitare il nome di un altro account in Account oppure fare clic su Sfoglia. Digitare e confermare quindi una password.


Finestra delle proprietà di DTC locale: scheda Analisi

Elemento Dettagli

Opzioni di output
  • Output di traccia, Traccia transazioni: selezionare entrambe le caselle di controllo per abilitare la traccia.

  • Tutte le transazioni: selezionare la casella di controllo per tracciare tutte le transazioni. L'attivazione di questa posizione può influire sulle prestazioni del sistema. Per impostazione predefinita, l'opzione è disabilitata.

  • Transazioni abbandonate: selezionare questa casella di controllo per tenere traccia solo delle transazioni abbandonate. Questa opzione è selezionata per impostazione predefinita.

  • Transazioni di lunga durata: se si seleziona questa casella di controllo, verrà tenuta traccia delle transazioni di durata superiore a un determinato intervallo di tempo, indicando che tali transazioni potrebbero non essere risolte. L'intervallo di timeout definito dal sistema è pari a un minuto più il periodo di timeout per la transazione (se specificato).

Opzioni di registrazione
  • Nuova sessione: fare clic su questo pulsante per avviare una nuova sessione di registrazione. Qualsiasi sessione di registrazione attualmente in esecuzione deve essere interrotta per poter creare una nuova sessione. Quando si avvia una nuova sessione di registrazione, il DTC esegue un backup dell'eventuale file di registro esistente.

  • Arresta sessione: fare clic su questo pulsante per arrestare la sessione di registrazione corrente. L'arresto di una sessione di registrazione determina lo sblocco del file di registro in modo che possa essere eliminato, se necessario. Per verificare che eventuali dati nei buffer di memoria vengano scritti nel registro, fare clic su Cancella dati prima di arrestare una sessione di registrazione.

  • Cancella dati: fare clic su questo pulsante per spostare tutti i dati dai rispettivi buffer di memoria nel file di registro su disco. Fare clic sul pulsante prima di visualizzare i dati di registrazione per accertarsi che tutti i dati in memoria siano scritti su disco. In caso contrario, alcuni dati di registrazione potrebbero non essere presenti nel file di registro quando lo si visualizza. Se si fa clic su questo pulsante, le prestazioni del sistema potrebbero subire una riduzione. Se la sessione di registrazione è arrestata, il pulsante è disabilitato.

  • Numero max. buffer di memoria: modificare questo valore se si desidera modificare il numero massimo di buffer di memoria consentiti. Il valore massimo predefinito è 25. Se si aumenta questo limita, il DTC scrive un messaggio nel Visualizzatore eventi. Tale memoria viene estratta dal buffer non paginabile. Se la quantità di memoria disponibile nel buffer non paginabile non è sufficiente, potrebbe pertanto non essere possibile impostare questo valore su un numero più alto. In questo caso, verrà visualizzato un messaggio di avviso. In questo caso, fare clic su OK.


Notazione di sintassi della riga di comando

Nella tabella seguente viene descritta la notazione utilizzata per indicare la sintassi della riga di comando.

Notazione | Descrizione
Testo senza parentesi quadre o graffe | Elementi da digitare come indicato
<Testo tra parentesi acute> | Segnaposto per il quale è necessario fornire un valore
[Testo tra parentesi quadre] | Elementi facoltativi
{Testo tra parentesi graffe} | Serie di elementi richiesti: effettuare una selezione
Barra verticale (|) | Separatore per elementi che si escludono a vicenda: effettuare una selezione
Puntini di sospensione (...) | Elementi che possono essere ripetuti