Gestione dispositivi

Gestione dispositivi consente di installare e aggiornare i driver dei dispositivi hardware, modificare le impostazioni hardware per tali dispositivi e risolvere eventuali problemi.

Un driver di dispositivo è un componente software che consente a Windows di comunicare con uno specifico dispositivo hardware. Affinché Windows sia in grado di utilizzare un nuovo componente hardware, è necessario che sia installato il relativo driver.

  • Panoramica di Gestione dispositivi

  • Aprire Gestione dispositivi

  • Visualizzare le informazioni relative ai dispositivi

  • Installare i dispositivi e i relativi driver

  • Configurare le proprietà dei dispositivi

  • Disinstallare e reinstallare dispositivi

  • Ulteriori risorse relative a Gestione dispositivi

  • Glossario di Gestione dispositivi


Panoramica di Gestione dispositivi

Gestione dispositivi offre una visualizzazione grafica dell'hardware installato nel computer. Tutti i dispositivi comunicano con Windows attraverso un componente software denominato driver di dispositivo. È possibile utilizzare Gestione dispositivi per installare e aggiornare i driver dei dispositivi hardware, modificare le impostazioni hardware per tali dispositivi e risolvere i problemi.

Utilizzi di Gestione dispositivi

Gestione dispositivi consente di:

  • Stabilire se l'hardware nel computer funziona correttamente.

  • Cambiare le impostazioni della configurazione hardware.

  • Identificare i driver di dispositivo caricati per ogni dispositivo e ottenere informazioni su ognuno di tali driver.

  • Modificare le impostazioni avanzate e le proprietà per i dispositivi. Installare driver di dispositivo aggiornati.

  • Attivare, disattivare e disinstallare i dispositivi.

  • Ripristinare la versione precedente di un driver.

  • Visualizzare i dispositivi in base al tipo, alla connessione al computer o alle risorse utilizzate.

  • Visualizzare o nascondere i dispositivi nascosti che non è essenziale visualizzare ma che potrebbero essere necessari per le procedure avanzate di risoluzione dei problemi.

Gestione periferiche in genere viene utilizzato per controllare lo stato dell'hardware e per aggiornare i driver di dispositivo nel computer. Gli utenti esperti che hanno una conoscenza approfondita dell'hardware del computer possono inoltre utilizzare le funzionalità di diagnostica di Gestione dispositivi per risolvere i conflitti tra i dispositivi e per modificare le impostazioni delle risorse.

In genere non è necessario utilizzare Gestione dispositivi per modificare le impostazioni delle risorse in quanto le risorse vengono allocate in modo automatico dal sistema durante l'installazione dell'hardware.

È possibile utilizzare Gestione dispositivi per gestire dispositivi solo in un computer locale. In un computer remoto Gestione dispositivi funziona solo in modalità di sola lettura, che consente di visualizzare ma non di modificare la configurazione hardware del computer.
Ulteriori riferimenti

Aprire Gestione dispositivi

Visualizzare le informazioni relative ai dispositivi

Installare i dispositivi e i relativi driver

Configurare le proprietà dei dispositivi

Disinstallare e reinstallare dispositivi

Ulteriori risorse relative a Gestione dispositivi

Glossario di Gestione dispositivi


Aprire Gestione dispositivi

Gestione dispositivi può essere avviato in diversi modi. In questo argomento vengono illustrate due procedure per l'avvio di Gestione dispositivi in Windows Vista® e Windows Server® 2008, sia dall'interfaccia di Windows che dalla riga di comando.

È possibile utilizzare qualsiasi account utente per completare questa procedura. I dispositivi, tuttavia, possono essere modificati solo dai membri del gruppo Administrators.

Aprire Gestione dispositivi

Gestione dispositivi può essere aperto nei modi seguenti:

  • Tramite l'interfaccia di Windows

  • Tramite una riga di comando

  • Tramite Gestione computer

  • Da un computer remoto

Tramite l'interfaccia di Windows

La procedura riportata di seguito consente di aprire Gestione dispositivi utilizzando l'interfaccia utente di Windows.

Per aprire Gestione dispositivi utilizzando l'interfaccia di Windows

  1. Fare clic sul pulsante Start e quindi fare clic su Pannello di controllo.

  2. Fare clic su Hardware e suoni.

  3. Fare clic su Gestione dispositivi. Si verificherà una delle situazioni seguenti:

    • Se è stato effettuato l'accesso con l'account Administrator predefinito, verrà aperto Gestione dispositivi.

    • Se è stato effettuato l'accesso con un account utente membro del gruppo Administrators, verrà visualizzata la finestra di dialogo Controllo account utente e sarà necessario fare clic su Continua per aprire Gestione dispositivi.

    • Se è stato effettuato l'accesso con un account utente standard, verrà visualizzato un messaggio che indica che non è possibile apportare modifiche ai dispositivi. Fare clic su OK per aprire Gestione dispositivi in modalità di sola lettura.

Tramite la riga di comando

La procedura riportata di seguito consente di aprire Gestione dispositivi dal prompt dei comandi.

Per aprire Gestione dispositivi dalla riga di comando

  • Al prompt dei comandi, nella casella Inizia ricerca o nella casella Esegui digitare il comando seguente:

    mmc devmgmt.msc

    Si verificherà una delle situazioni seguenti:

    • Se è stato effettuato l'accesso con l'account Administrator predefinito, verrà aperto Gestione dispositivi.

    • Se è stato effettuato l'accesso con un account utente membro del gruppo Administrators, verrà visualizzata la finestra di dialogo Controllo account utente e sarà necessario fare clic su Continua per aprire Gestione dispositivi.

    • Se è stato effettuato l'accesso con un account utente standard, verrà visualizzato un messaggio che indica che non è possibile apportare modifiche ai dispositivi. Fare clic su OK per aprire Gestione dispositivi in modalità di sola lettura.

Tramite Gestione computer

Le procedure riportate di seguito consentono di aprire Gestione computer, che include Gestione dispositivi come componente.

Nota

Questa procedura funziona solo in Microsoft Windows Vista. In Windows Server 2008 questa procedura avvia il programma Server Manager. Per avviare Gestione computer in Windows Server 2008, utilizzare la procedura successiva utilizzando il prompt dei comandi.

Per aprire Gestione computer utilizzando l'interfaccia di Windows

  1. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Computer e quindi scegliere Gestione.

    Si verificherà una delle situazioni seguenti:

    • Se è stato effettuato l'accesso con l'account Administrator predefinito, verrà aperto Gestione computer.

    • Se è stato effettuato l'accesso con un account utente membro del gruppo Administrators, verrà visualizzata la finestra di dialogo Controllo account utente e sarà necessario fare clic su Continua per aprire Gestione computer.

    • Se è stato effettuato l'accesso con un account utente standard, verrà aperto Gestione computer.

  2. Fare clic su Gestione dispositivi nel riquadro di spostamento.

    Si verificherà una delle situazioni seguenti:

    • Nel caso degli amministratori, verrà visualizzato Gestione dispositivi nel riquadro dei dettagli.

    • Nel caso degli utenti standard, verrà visualizzato un messaggio che indica che non è possibile apportare modifiche ai dispositivi. Fare clic su OK per aprire Gestione dispositivi in modalità di sola lettura nel riquadro dei dettagli.
Per aprire Gestione computer dalla riga di comando

  1. Al prompt dei comandi, nella casella Inizia ricerca o nella casella Esegui digitare il comando:

    mmc compmgmt.msc

    Si verificherà una delle situazioni seguenti:

    • Se è stato effettuato l'accesso con l'account Administrator predefinito, verrà aperto Gestione computer.

    • Se è stato effettuato l'accesso con un account utente membro del gruppo Administrators, verrà visualizzata la finestra di dialogo Controllo account utente e sarà necessario fare clic su Continua per aprire Gestione computer.

    • Se è stato effettuato l'accesso con un account utente standard, verrà aperto Gestione computer.

  2. Fare clic su Gestione computer nel riquadro di spostamento.

    Si verificherà una delle situazioni seguenti:

    • Se l'utente è un amministratore, verrà visualizzato Gestione dispositivi nel riquadro dei dettagli.

    • Se l'utente è un utente standard, verrà visualizzato un messaggio che indica che non è possibile apportare modifiche ai dispositivi. Fare clic su OK per aprire Gestione dispositivi in modalità di sola lettura nel riquadro dei dettagli.

Da un computer remoto

Per aprire Gestione dispositivi su un computer remoto

  1. Aprire Gestione computer eseguendo una delle procedure riportate nella sezione precedente.

  2. Scegliere Connetti a un altro computer dal menu Azione.

  3. Nella finestra di dialogo Seleziona computer eseguire una delle operazioni seguenti:

    • Nella casella di testo Altro computer, digitare il nome del computer a cui accedere e quindi fare clic su OK.

    • Fare clic su Sfoglia e quindi su Avanzate per individuare il computer desiderato. Fare clic su OK dopo aver selezionato il computer corretto.

    Se la connessione ha esito positivo, il nome del computer verrà visualizzato tra parentesi accanto all'etichetta Gestione computer in alto a sinistra.

    Nota

    Questo tipo di accesso a Gestione dispositivi in un computer remoto è di "sola lettura". Non è possibile apportare alcuna modifica ai dispositivi o alle relative impostazioni.
Ulteriori riferimenti

Gestione dispositivi

Ulteriori risorse relative a Gestione dispositivi

Glossario di Gestione dispositivi


Visualizzare le informazioni relative ai dispositivi

Con Gestione dispositivi è possibile visualizzare i dettagli della configurazione hardware, compresi lo stato e i driver in uso, nonché altre informazioni.

In questa sezione vengono illustrate le procedure seguenti per la visualizzazione delle informazioni fornite da Gestione dispositivi:

  • Visualizzare i dettagli e lo stato di un dispositivo

  • Visualizzare le allocazioni di alimentazione e larghezza di banda USB per un dispositivo

  • Visualizzare le informazioni relative a un driver di dispositivo


Visualizzare i dettagli e lo stato di un dispositivo

In questo argomento vengono illustrate alcune procedure che consentono di visualizzare le informazioni relative a un dispositivo.

  • Visualizzare lo stato di un dispositivo

  • Visualizzare i dispositivi in base al tipo, alla connessione e alle risorse che utilizzano

  • Visualizzare i dispositivi nascosti

È possibile utilizzare qualsiasi account utente per completare questa procedura. Solo i membri del gruppo Administrators possono tuttavia apportare modifiche ai dispositivi o ai relativi driver.

Visualizzare lo stato di un dispositivo

Lo stato di un dispositivo indica se sono installati i relativi driver e se Windows è in grado di comunicare con esso.

Per visualizzare lo stato di un dispositivo

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic sul tipo di dispositivo che si desidera visualizzare.

  3. Fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Proprietà.

  4. Nell'area Stato dispositivo della scheda Generale è riportata una descrizione dello stato corrente.

    Nota

    Quando nel dispositivo si verifica un problema, verrà indicato il tipo di problema riscontrato. È possibile che vengano indicati anche un codice e un numero per il problema e una soluzione suggerita. È inoltre possibile inviare una segnalazione errore di Windows a Microsoft facendo clic sul pulsante Cerca soluzioni, se è presente.

Visualizzare i dispositivi in base al tipo, alla connessione e alle risorse che utilizzano

Per impostazione predefinita, i dispositivi sono raggruppati per tipo. In alternativa, è possibile visualizzarli in base alla modalità di connessione al computer, ad esempio il bus a cui sono collegati, oppure in base alle risorse che utilizzano.

Per visualizzare i dispositivi in base al tipo, alla connessione e alle risorse che utilizzano

  1. Aprire Gestione dispositivi.

  2. Dal menu Visualizza scegliere una delle opzioni elencate nella tabella seguente:

    Opzione Descrizione

    Dispositivi per tipo

    I dispositivi vengono raggruppati per tipo, ad esempio monitor o mouse. Questa è la visualizzazione predefinita. Quando si fa doppio clic sul tipo di dispositivo, tutti i nomi delle connessioni verranno elencati sotto il tipo.

    Dispositivi per connessione

    Visualizza i dispositivi in base al modo in cui sono connessi al computer. Ogni dispositivo è elencato sotto l'hardware a cui è connesso. Ad esempio, se è presente una scheda SCSI (Small Computer System Interface), i dispositivi collegati alla scheda SCSI saranno elencati al di sotto di questa.

    Risorse per tipo

    Visualizza tutte le risorse allocate in base al tipo di dispositivo che utilizza tali risorse. I tipi di risorsa sono:

    • Canali di accesso diretto alla memoria (DMA)

    • Porte in input/output (porte I/O)

    • Richiesta di interrupt (IRQ)

    • Indirizzi di memoria

    Risorse per connessione

    Visualizza tutte le risorse allocate in base al tipo di connessione.

Per ulteriori informazioni sulla visualizzazione dei dispositivi in base alla relativa classe di installazione, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

Visualizzare i dispositivi nascosti

Nella maggior parte dei casi, i dispositivi sono nascosti quando il relativo driver è installato ma il dispositivo non è collegato. Eseguire la procedura seguente per visualizzare i dispositivi nascosti nel computer.

Per visualizzare i dispositivi nascosti

  1. Aprire Gestione dispositivi.

  2. Scegliere Mostra dispositivi nascosti dal menu Visualizza.
Ulteriori riferimenti

Visualizzare le informazioni relative ai dispositivi

Visualizzare le allocazioni di alimentazione e larghezza di banda USB per un dispositivo

Visualizzare le informazioni relative a un driver di dispositivo


Visualizzare le allocazioni di alimentazione e larghezza di banda USB per un dispositivo

In questo argomento vengono illustrate alcune procedure che consentono di visualizzare le allocazioni di alimentazione o larghezza di banda per hub e controller USB.

  • Visualizzare le allocazioni di alimentazione per un hub USB

  • Visualizzare le allocazioni di larghezza di banda per un controller host USB

È possibile utilizzare qualsiasi account utente per completare questa procedura. Solo i membri del gruppo Administrators possono tuttavia apportare modifiche ai dispositivi o ai relativi driver.

Visualizzare le allocazioni di alimentazione per un hub USB

Gli hub per dispositivi USB possono essere autoalimentati o alimentati dal bus. Un hub autoalimentato dispone di un proprio alimentatore e fornisce l'alimentazione massima al dispositivo. Un hub alimentato dal bus trae la propria alimentazione dal bus USB a cui è collegato e fornisce l'alimentazione minima. I dispositivi che richiedono un'alimentazione notevole, ad esempio le fotocamere, devono essere collegati a hub autoalimentati.

È possibile verificare le allocazioni di alimentazione per un hub USB per individuare situazioni in cui l'hub è utilizzato da un numero eccessivo di dispositivi.

Per visualizzare le allocazioni di alimentazione per un hub USB

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Controller USB (Universal Serial Bus).

  3. Fare clic con il pulsante destro del mouse su Hub radice USB, di cui possono essere presenti più istanze, e quindi scegliere Proprietà.

  4. Nella scheda Alimentazione visualizzare l'alimentazione richiesta da ogni dispositivo nell'elenco Dispositivi collegati.

    Note
    • L'opzione Controller USB (Universal Serial Bus) viene visualizzata solo se il computer è dotato di una porta USB.
    • La scheda Alimentazione viene visualizzata solo per gli hub USB.

Visualizzare le allocazioni di larghezza di banda per un controller host USB

È possibile visualizzare la larghezza di banda solo per un controller USB (Universal Serial Bus). Alcuni dispositivi USB, ad esempio i modem, potrebbero non essere indicati perché non segnalano al sistema operativo i requisiti di larghezza di banda.

A ogni controller USB è assegnata una quantità fissa di larghezza di banda, che deve essere condivisa da tutti i dispositivi collegati. Se si ritiene che la larghezza di banda a disposizione di un controller USB sia insufficiente, è possibile visualizzare le allocazioni di larghezza di banda attualmente in uso per ogni dispositivo.

Per visualizzare le allocazioni di larghezza di banda per un controller host USB

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Controller USB (Universal Serial Bus).

  3. Fare clic con il pulsante destro del mouse su Controller host [Marca] per il sistema e quindi scegliere Proprietà.

  4. Nell'elenco Dispositivi che utilizzano molta larghezza di banda nella scheda Avanzate visualizzare la larghezza di banda utilizzata da ogni dispositivo.

    Nota

    L'opzione Controller USB (Universal Serial Bus) viene visualizzata solo se il computer è dotato di una porta USB.
Ulteriori riferimenti

Visualizzare le informazioni relative ai dispositivi

Visualizzare i dettagli e lo stato di un dispositivo

Visualizzare le informazioni relative a un driver di dispositivo


Visualizzare le informazioni relative a un driver di dispositivo

In questo argomento viene illustrata una procedura che consente di visualizzare i dettagli relativi ai driver di dispositivo in esecuzione nel computer.

È possibile utilizzare qualsiasi account utente per completare questa procedura. Solo i membri del gruppo Administrators possono tuttavia apportare modifiche ai dispositivi o ai relativi driver.

Per visualizzare le informazioni relative a un driver di dispositivo

  1. Aprire Gestione dispositivi.

  2. Individuare e fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Proprietà.

  3. Nella scheda Driver vengono visualizzate le informazioni relative al driver attualmente installato.

  4. Fare clic sul pulsante Dettagli.

    Verrà visualizzata la pagina Dettagli file del driver con un elenco dei file che compongono il driver.

Ulteriori riferimenti

Visualizzare le informazioni relative ai dispositivi

Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

Aggiornare o cambiare un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo


Installare i dispositivi e i relativi driver

In questa sezione vengono illustrate alcune procedure che consentono di installare dispositivi Plug and Play e non Plug and Play e gestire i driver dei dispositivi.

  • Informazioni sull'installazione dei dispositivi e dei driver

  • Installare un dispositivo Plug and Play

  • Installare un dispositivo non Plug and Play

  • Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici

  • Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

  • Configurare Windows per ricercare i driver di dispositivo in altre cartelle

  • Configurare Windows per ricercare i driver di dispositivo in Windows Update

  • Aggiornare o cambiare un driver di dispositivo

  • Ripristinare la versione precedente di un driver di dispositivo

  • Attivare o disattivare un dispositivo Plug and Play

  • Avviare o arrestare un driver di dispositivo non Plug and Play

  • Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Informazioni sull'installazione dei dispositivi e dei driver

Windows supporta la specifica Plug and Play che definisce il modo in cui un computer può rilevare e configurare i nuovi componenti hardware aggiunti e installare automaticamente il driver di dispositivo. Prima dell'avvento della tecnologia Plug and Play, gli utenti dovevano configurare manualmente i dispositivi prima di collegarli al computer.

Con l'hardware Plug and Play e un sistema operativo compatibile Plug and Play, ad esempio Windows Vista® e Windows Server® 2008, quando un utente collega il componente hardware al computer, tramite Windows viene eseguita la ricerca di un pacchetto driver appropriato e il componente viene configurato automaticamente per consentirne il funzionamento senza interferire con altri dispositivi.

Dato che i driver di dispositivo vengono eseguiti come se facessero parte del sistema operativo, con accesso illimitato all'intero computer, è essenziale che vengano installati solo driver di dispositivo conosciuti e autorizzati. A supporto di questo requisito di sicurezza, Microsoft Windows Vista e Windows Server 2008 suddividono il processo di installazione in due passaggi:

Installazione di dispositivi in Windows

L'installazione di dispositivi e di driver di dispositivo in Microsoft Windows Vista e Windows Server 2008 si svolge come illustrato nella figura seguente. "PnP" nella figura si riferisce al servizio Plug and Play in esecuzione in Windows. Se uno dei controlli di sicurezza descritti ha esito negativo o se non viene individuato un pacchetto driver di dispositivo appropriato, il processo si interrompe.

Diagramma di flusso - Installazione del driver di periferica Windows
  1. Quando un utente inserisce un dispositivo, Windows rileva il nuovo hardware e segnala al servizio Plug and Play di rendere operativo il dispositivo.

  2. Il dispositivo viene identificato.

  3. Viene cercato un pacchetto driver per il dispositivo nell'archivio driver. Se non viene individuato un pacchetto corrispondente, passare al punto 4. Se viene individuato un pacchetto corrispondente, passare al punto 8.

  4. Per trovare un pacchetto driver corrispondente, Windows eseguirà una ricerca nelle posizioni seguenti, fermandosi non appena individua un pacchetto corrispondente:

    • Ricerca nelle cartelle specificate nella voce del Registro di sistema DevicePath. Per ulteriori informazioni, vedere Configurare Windows per ricercare i driver di dispositivo in altre cartelle.

    • Ricerca in Windows Update. Per ulteriori informazioni, vedere Configurare Windows per ricercare i driver di dispositivo in Windows Update.

    • Richiesta all'utente di inserire l'apposito supporto.

  5. Windows verifica che l'utente disponga dei privilegi necessari per inserire il pacchetto driver nell'archivio driver. È necessario che l'utente disponga di credenziali amministrative o che sia configurato il criterio computer che consente agli utenti standard di installare dispositivi con questo identificatore. Per ulteriori informazioni su questo criterio, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

  6. Windows verifica che il pacchetto driver contenga una firma digitale valida. Se il pacchetto driver è firmato con un certificato valido ma non reperibile nell'archivio Autori attendibili, verrà visualizzata una richiesta di conferma.

  7. Viene inserita una copia del pacchetto driver nell'archivio driver.

  8. Il servizio Plug and Play copia i file del driver dall'archivio driver nei percorsi operativi, in genere %systemroot%\windows32\drivers.

  9. Il servizio Plug and Play configura il Registro di sistema in modo da indicare a Windows come utilizzare il nuovi driver installati.

  10. Il servizio Plug and Play avvia i nuovi driver installati. Questo passaggio viene ripetuto a ogni riavvio del computer per ricaricare i driver.

In Microsoft Windows Vista e Windows Server 2008 il processo descritto nei passaggi 3-7 è definito installazione di appoggio. Durante questo processo, Windows esegue i controlli di sicurezza e quindi inserisce il pacchetto driver in un percorso sicuro affinché il servizio Plug and Play possa accedervi. In Microsoft Windows Vista e Windows Server 2008 l'installazione di appoggio può essere eseguita da un amministratore in un passaggio separato. Per ulteriori informazioni, vedere Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver.

L'installazione di appoggio dei pacchetti driver di dispositivo per gli utenti può risultare particolarmente vantaggiosa per gli amministratori con più computer. Windows esegue tutti i controlli di sicurezza necessari, comprese la verifica dei diritti amministrativi e la convalida delle firme digitali. Dopo l'installazione di appoggio di un pacchetto driver, tutti gli utenti che eseguono l'accesso a tale computer possono installare i driver nell'archivio driver semplicemente collegando il dispositivo al computer. Non vengono visualizzati prompt e non vengono richieste autorizzazioni speciali. È sufficiente che l'utente colleghi il dispositivo per farlo funzionare, senza l'intervento dell'amministratore o dell'helpdesk.
Ulteriori riferimenti

Per ulteriori informazioni sull'archivio driver e sul processo di installazione di appoggio, vedere l'argomento relativo a firma e installazione di appoggio di driver di dispositivo nella Guida dettagliata all'installazione e alla gestione di dispositivi (http://go.microsoft.com/fwlink/?LinkId=140049)

Installare i dispositivi e i relativi driver

Installare un dispositivo Plug and Play

Installare un dispositivo non Plug and Play

Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici

Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

Configurare Windows per ricercare i driver di dispositivo in altre cartelle

Configurare Windows per ricercare i driver di dispositivo in Windows Update

Aggiornare o cambiare un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo

Attivare o disattivare un dispositivo Plug and Play

Avviare o arrestare un driver di dispositivo non Plug and Play

Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Installare un dispositivo Plug and Play

In questo argomento viene illustrata una procedura che consente di installare un dispositivo compatibile Plug and Play.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni, vedere "Considerazioni aggiuntive" in questo argomento.

Per installare un dispositivo Plug and Play

  1. Collegare il nuovo dispositivo al computer.

  2. Nella finestra di dialogo Trovato nuovo hardware scegliere una delle opzioni seguenti:

    • Individuare e installare il driver. Se si seleziona questa opzione, inizierà il processo di installazione. Analizzare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

    • Visualizza questo messaggio in seguito. Il dispositivo non è installato e non è stata apportata alcuna modifica di configurazione nel computer. Se il dispositivo è ancora collegato al successivo accesso al computer, questa finestra di dialogo verrà visualizzata nuovamente.

    • Non visualizzare più questo messaggio. Se si seleziona questa opzione, il servizio Plug and Play verrà configurato in modo da non installare il driver del dispositivo e il dispositivo non sarà funzionante. Per completare l'installazione del driver, è necessario scollegare e ricollegare il dispositivo. Per ulteriori informazioni, vedere Disinstallare o reinstallare un dispositivo.

Se si seleziona Individuare e installare il driver, l'esito dell'installazione dipenderà dai fattori seguenti:

  • Il dispositivo è supportato da un pacchetto driver incluso in Windows. I pacchetti driver inclusi in Windows possono essere installati dagli utenti standard.

  • L'amministratore del computer ha effettuato un'installazione di appoggio del pacchetto driver nell'archivio driver. Per ulteriori informazioni, vedere Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver. I pacchetti driver presenti nell'archivio driver possono essere installati dagli utenti standard.

  • L'utente ha ricevuto un supporto con il pacchetto driver dal fornitore. Per ulteriori informazioni, vedere la sezione "Ulteriori considerazioni" in questo argomento.
Ulteriori considerazioni

Per impostazione predefinita, per installare un nuovo dispositivo il cui driver non è presente nell'archivio dati, è necessaria almeno l'appartenenza al gruppo Administrators o equivalente. Se il pacchetto driver non è presente nell'archivio driver, gli utenti standard possono installare il dispositivo solo se sono soddisfatte le condizioni seguenti:

  • Il pacchetto driver è firmato con un certificato digitale valido. Per ulteriori informazioni, vedere la documentazione sulla firma di driver di dispositivo disponibile nel sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=62923).

  • La classe di installazione dispositivi per il driver è archiviata nel criterio computer Consenti agli utenti con privilegi limitati di installare driver per queste classi di dispositivo. Per ulteriori informazioni, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

Ulteriori riferimenti

Installare i dispositivi e i relativi driver

Installare un dispositivo non Plug and Play

Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici

Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

Configurare Windows per ricercare i driver di dispositivo in altre cartelle

Configurare Windows per ricercare i driver di dispositivo in Windows Update

Aggiornare o cambiare un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo

Avviare o arrestare un driver di dispositivo non Plug and Play

Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Installare un dispositivo non Plug and Play

In questo argomento viene illustrata una procedura che consente di installare un dispositivo non compatibile Plug and Play.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per installare un dispositivo non Plug and Play

  1. Aprire Gestione dispositivi.

  2. Fare clic con il pulsante destro del mouse sul nodo di primo livello nel riquadro dei dettagli.

  3. Fare clic su Aggiungi hardware legacy.

  4. Nell'Installazione guidata hardware fare clic su Avanti e quindi seguire le istruzioni visualizzate.
Ulteriori riferimenti

Installare i dispositivi e i relativi driver

Installare un dispositivo Plug and Play

Aggiornare o cambiare un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo

Avviare o arrestare un driver di dispositivo non Plug and Play

Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici

Per impostazione predefinita, solo i membri del gruppo di amministratori di un computer possono installare dispositivi in quando solo un amministratore può inserire un pacchetto driver nell'archivio driver, un passaggio necessario del processo di installazione. Con Windows Vista® e Windows Server® 2008 è possibile configurare criteri del computer per consentire agli utenti con limitazioni di installare dispositivi da classi di installazione dispositivi specifiche.

In questo argomento vengono illustrate alcune procedure che consentono di determinare la classe di installazione dispositivi per un dispositivo hardware e quindi di aggiungere tale classe al criterio per permettere a un utente con privilegi limitati di installare driver per tale dispositivo senza necessità di privilegi elevati.

  • Determinare la classe di installazione dispositivi per uno specifico dispositivo hardware

  • Configurare un criterio per consentire a un utente con privilegi limitati di effettuare un'installazione di appoggio di dispositivi per una specifica classe di installazione dispositivi

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Determinare la classe di installazione dispositivi per un dispositivo hardware specifico

Prima di concedere l'autorizzazione per installare un particolare dispositivo, è necessario determinare la classe di installazione dispositivi utilizzata da Windows per identificare in modo univoco il dispositivo. A questo scopo è possibile visualizzare i file con estensione inf del pacchetto driver dispositivo oppure visualizzare le proprietà di un dispositivo installato.

Per determinare la classe di installazione dispositivi visualizzando il file con estensione inf di un pacchetto driver di dispositivo

  1. Aprire in Blocco note il file con estensione inf del pacchetto driver di dispositivo.

  2. Individuare la sezione che inizia con il testo [Versione].

  3. Individuare la riga di tale sezione che con il testo ClassGuid=.

  4. Copiare negli Appunti il valore alla destra del segno di uguale e quindi incollarlo dove necessario.
Per determinare la classe di installazione dispositivi visualizzando le proprietà di un dispositivo installato

  1. Installare il dispositivo in un computer di test.

  2. Aprire Gestione dispositivi in tale computer.

  3. Individuare il dispositivo nell'albero Gestione dispositivi.

  4. Fare doppio clic sul dispositivo per visualizzare la pagina Proprietà.

  5. Fare clic sulla scheda Dettagli.

  6. Nell'elenco Proprietà selezionare GUID classe periferica.

  7. Fare clic con il pulsante destro del mouse sul GUID, scegliere Copia e quindi incollare il valore dove necessario.

Configurare un criterio per consentire a un utente con limitazioni di effettuare un'installazione di appoggio di dispositivi per una classe di installazione dispositivi specifica

Windows supporta i criteri che possono essere utilizzati da un amministratore per controllare l'installazione dei dispositivi da parte degli utenti con privilegi limitati. Per impostazione predefinita, solo gli amministratori possono installare dispositivi. Questo criterio viene imposto durante l'installazione di appoggio di un driver di dispositivo nell'archivio driver. Per ulteriori informazioni sull'installazione di appoggio, vedere Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver.

Nota

Questa procedura è appropriata per un numero ridotto di computer. Per applicare il criterio a un numero elevato di computer, utilizzare uno strumento quale Criteri di gruppo. Per informazioni su Criteri di gruppo, vedere il sito Web TechCenter di Windows Server sui Criteri di gruppo all'indirizzo http://go.microsoft.com/fwlink/?linkid=55625.

Per configurare un criterio computer per consentire a un utente con privilegi limitati di effettuare un'installazione di appoggio di driver per una specifica classe di installazione dispositivi

  1. Eseguire una delle procedure precedenti per determinare il GUID della classe di installazione per il dispositivo.

  2. Fare clic sul pulsante Start, digitare mmc gpedit.msc nella casella Inizia ricerca e quindi premere Enter per eseguire Editor oggetti Criteri di gruppo locali.

  3. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  4. In Editor oggetti Criteri di gruppo locale, in Criteri del computer locale, fare doppio clic su Configurazione computer, Modelli amministrativi, Sistema e quindi Installazione driver.

  5. Nel riquadro dei dettagli fare doppio clic su Consenti agli utenti non amministratori di installare driver per queste classi di dispositivo.

  6. Selezionare Abilitato per attivare il criterio computer.

  7. Fare clic su Mostra per visualizzare l'elenco corrente di classi di installazione dispositivi approvate.

  8. Nella finestra di dialogo Mostra contenuti fare clic su Aggiungi.

  9. Nella finestra di dialogo Aggiungi elemento immettere il GUID della classe di installazione dispositivi, comprese le parentesi graffe {}, e quindi fare clic su OK.

  10. Fare clic su OK per chiudere la finestra di dialogo Mostra contenuti.

  11. Fare clic su OK per chiudere il criterio computer.

    Nella colonna Stato il criterio sarà segnalato come Abilitato.

A questo punto, gli utenti con privilegi limitati sul computer o su qualsiasi computer a cui viene applicato il criterio potranno installare dispositivi per questa classe di installazione dispositivi senza necessità di privilegi elevati.

Importante

Il pacchetto driver di dispositivo deve essere comunque firmato in conformità con il criterio computer. Se il certificato per l'autore del driver non è presente nell'archivio di certificati Autori attendibili, verrà visualizzata la richiesta di accettare il certificato non verificato durante il processo di installazione.
Ulteriori riferimenti

Installare i dispositivi e i relativi driver

Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

Configurare Windows per ricercare i driver di dispositivo in altre cartelle

Configurare Windows per ricercare i driver di dispositivo in Windows Update


Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

L'archivio driver è un'area protetta di un computer che contiene i pacchetti driver di dispositivo di cui è stata approvata l'installazione nel computer. Quando un pacchetto driver di dispositivo è presente nell'archivio driver, un utente standard del computer può installare i relativi driver senza necessità di privilegi elevati.

In questo argomento viene illustrata una procedura che consente a un amministratore di effettuare un'installazione di appoggio di un pacchetto di installazione di driver di periferica nell'archivio driver.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni, vedere "Considerazioni aggiuntive" in questo argomento.

Per effettuare un'installazione di appoggio di un pacchetto driver nell'archivio driver

  1. Aprire il prompt dei comandi con privilegi di amministratore. Fare clic sul pulsante Start, fare clic su Tutti i programmi e Accessori, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

    Nota

    Lo strumento della riga di comando PnPUtil funziona solo se il prompt dei comandi viene eseguito con privilegi di amministratore.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Al prompt dei comandi digitare:

    pnputil.exe -a <PathToDriver>/<Driver>.inf

    Parametro Descrizione

    -a

    Specifica il pacchetto driver da aggiungere all'archivio driver.

    PathToDriver

    Specifica il percorso della cartella in cui si trova attualmente il driver.

    Driver.inf

    Specifica il nome del file con estensione inf che descrive il pacchetto driver.

    Nota

    Per visualizzare tutti i parametri della riga di comando per il comando PnPUtil, al prompt dei comandi digitare: pnputil -?

  4. Se il pacchetto driver non è firmato o è firmato con un certificato non presente nell'archivio certificati Autori attendibili, verrà visualizzata la finestra di dialogo Sicurezza di Windows in cui viene chiesto di confermare se il driver deve essere installato. Visualizzare i dettagli del messaggio per individuare il problema relativo alla firma del driver. Se si è certi che il pacchetto driver sia valido e sicuro, fare clic su Installa per completare l'installazione di appoggio.

  5. Al termine dell'installazione di appoggio lo strumento PnPUtil indicherà il Nome pubblicato assegnato al pacchetto nell'archivio driver. Questo è il nome che dovrà essere utilizzato per eliminare il pacchetto driver dall'archivio in un secondo momento. Per determinare il nome pubblicato di un pacchetto driver, utilizzare il comando pnputil.exe -e e cercare il driver desiderato nel risultato.
Ulteriori considerazioni
  • Per impostazione predefinita, per installare un pacchetto driver di periferica nell'archivio driver è richiesta almeno l'appartenenza al gruppo Administrators o equivalente. Un utente standard può installare un pacchetto driver solo se sono soddisfatte le condizioni seguenti:

    • Il pacchetto driver di dispositivo è firmato con un certificato digitale valido. Per ulteriori informazioni, vedere la documentazione sulla firma e l'esecuzione di un'installazione di appoggio di driver di dispositivo, disponibile nel sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=62923 e http://go.microsoft.com/fwlink/?LinkID=140049).

    • La classe di installazione dispositivi per il driver si trova nel criterio computer Consenti agli utenti con privilegi limitati di installare driver per queste classi di dispositivo. Per ulteriori informazioni, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

Ulteriori riferimenti

Installare i dispositivi e i relativi driver

Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici

Configurare Windows per ricercare i driver di dispositivo in altre cartelle

Configurare Windows per ricercare i driver di dispositivo in Windows Update

Notazione di sintassi della riga di comando


Configurare Windows per ricercare i driver di dispositivo in altre cartelle

Quando viene rilevato un nuovo dispositivo, Windows verifica se nell'archivio driver è stata effettuata un'installazione di appoggio di un pacchetto driver appropriato. In caso contrario, esegue una ricerca in diverse posizioni per individuare un pacchetto driver da inserire nell'archivio driver. Queste posizioni sono, nell'ordine:

  1. Le cartelle specificate nell'impostazione del Registro di sistema DevicePath, come descritto in questo argomento.

  2. Windows Update sul Web. Per ulteriori informazioni, vedere Configurare Windows per ricercare i driver di dispositivo in Windows Update.

  3. Un percorso di file o un supporto fornito dall'utente.

Dopo aver individuato il pacchetto driver, Windows lo copia nell'archivio driver e lo installa da quella posizione.

In questo argomento viene illustrata una procedura che consente di modificare l'elenco di cartelle in cui Gestione dispositivi ricerca un pacchetto driver.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per configurare Windows per ricercare i driver di dispositivo in altre cartelle

  1. Aprire l'editor del Registro di sistema. Fare clic sul pulsante Start e digitare regedit nella casella Inizia ricerca.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Passare alla chiave del Registro di sistema seguente:

    HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Current Version

  4. Nel riquadro dei dettagli fare doppio clic su DevicePath.

  5. Aggiungere altri percorsi di cartelle all'impostazione, separati da un punto e virgola (;). Assicurarsi che sia presente %systemroot%\inf tra le cartelle incluse nel valore.
Attenzione

Non rimuovere %systemroot%\inf dalla voce del Registro di sistema DevicePath. La rimozione di tale cartella può compromettere l'installazione del driver di dispositivo.
Ulteriori considerazioni
  • È possibile includere percorsi utilizzando:

    • Lettere di unità e cartelle, ad esempio c:\nomecartella

    • Variabili d'ambiente, ad esempio %systemdrive%\nomecartella

    • Percorsi di rete, ad esempio \\server\condivisione

    L'elenco specificato deve essere su una riga e le cartelle devono essere separate da un punto e virgola (;)..

  • Se le cartelle elencate nella voce del Registro di sistema DevicePath contengono altre sottocartelle, anche queste ultime verranno incluse nella ricerca. Ad esempio, se si include c:\ come percorso, Windows eseguirà la ricerca nell'intera unità.

  • L'inclusione di un pacchetto driver in una cartella riportata nella voce del Registro di sistema DevicePath non comporta la rimozione dei prompt creati dalla firma sul pacchetto. Se il pacchetto non è firmato o è firmato da un autore sconosciuto o non attendibile, verranno comunque visualizzate le finestre di dialogo per l'accettazione dell'autore. Se si include il certificato utilizzato per firmare il driver nell'archivio certificati Autori attendibili, questo prompt aggiuntivo verrà rimosso. Per ulteriori informazioni, vedere la documentazione sulla firma di driver di dispositivo disponibile nel sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=62923).

Ulteriori riferimenti

Installare un dispositivo Plug and Play

Installare un dispositivo non Plug and Play

Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici

Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

Configurare Windows per ricercare i driver di dispositivo in Windows Update


Configurare Windows per ricercare i driver di dispositivo in Windows Update

Quando viene rilevato un nuovo dispositivo, Windows verifica se nell'archivio driver è stata effettuata un'installazione di appoggio di un pacchetto driver appropriato. In caso contrario, esegue una ricerca in diverse posizioni per individuare un pacchetto driver. Queste posizioni sono, nell'ordine:

  1. Le cartelle specificate nell'impostazione del Registro di sistema DevicePath. Per ulteriori informazioni, vedere Configurare Windows per ricercare i driver di dispositivo in altre cartelle.

  2. Windows Update sul Web, come descritto in questo argomento.

  3. Un percorso di file o un supporto fornito dall'utente.

Dopo aver individuato il pacchetto driver, Windows lo copia nell'archivio driver e lo installa da quella posizione.

Per impostazione predefinita, Windows esegue una ricerca nell'archivio driver di Windows Update su Internet qualora il driver non venga individuato automaticamente nel computer locale. Per gli amministratori in ambienti gestiti può risultare utile esercitare un controllo maggiore sui propri sistemi gestiti e disattivare la ricerca automatica in Windows Update.

In questo argomento viene illustrata una procedura che consente di attivare o disattivare la ricerca dei driver di dispositivo in Windows Update.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per configurare Windows per ricercare i driver di dispositivo in altre cartelle

  1. Avviare Editor oggetti Criteri di gruppo locale. Fare clic sul pulsante Start e quindi digitare mmc gpedit.msc nella casella Inizia ricerca.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Aprire Criteri del computer locale, Configurazione computer, Modelli amministrativi, Sistema, Gestione comunicazioni Internet e quindi Impostazioni di comunicazione Internet.

  4. Nel riquadro di destra fare doppio clic su Disattiva ricerca driver dispositivi in Windows Update.

  5. Selezionare una delle opzioni seguenti:

    • Selezionare Attivato per impedire a Windows di eseguire la ricerca in Windows Update.

    • Selezionare Disattivato per eseguire sempre la ricerca automatica in Windows Update quando non viene rilevato localmente un driver.

    • Selezionare Non configurato per utilizzare l'impostazione predefinita, che prevede la ricerca automatica in Windows Update.

  6. Se si seleziona Disattivato o Non configurato, verrà applicato il criterio in Configurazione computer, Modelli amministrativi, Sistema, Installazione driver, Disattiva richiesta ricerca driver dispositivi in Windows Update. Questo criterio specifica se viene visualizzata la richiesta di consenso prima di eseguire la ricerca in Windows Update. Se questo criterio è attivato, la ricerca in Windows Update verrà eseguita in modo invisibile all'utente senza richiesta di consenso.

Nella tabella seguente viene illustrato l'effetto di varie combinazioni delle due impostazioni. I risultati indicano se viene visualizzato un messaggio di richiesta e se viene eseguita la ricerca in Windows Update.

Criterio: Disattiva ricerca driver dispositivi in Windows Update | Criterio: Disattiva richiesta ricerca driver dispositivi in Windows Update | Comportamento risultante
Attivato | Attivato | Nessun messaggio di richiesta e nessuna ricerca in Windows Update.
Attivato | Disattivato | Nessun messaggio di richiesta e nessuna ricerca in Windows Update.
Attivato | Non configurato | Nessun messaggio di richiesta e nessuna ricerca in Windows Update.
Disattivato | Attivato | Nessun messaggio di richiesta. Ricerca automatica in Windows Update.
Disattivato | Disattivato | Viene visualizzato un messaggio di richiesta e, se l'utente accetta, viene eseguita la ricerca in Windows Update.
Disattivato | Non configurato | Viene visualizzato un messaggio di richiesta e, se l'utente accetta, viene eseguita la ricerca in Windows Update.
Non configurato | Attivato | Nessun messaggio di richiesta. Ricerca automatica in Windows Update.
Non configurato | Disattivato | Viene visualizzato un messaggio di richiesta e, se l'utente accetta, viene eseguita la ricerca in Windows Update.
Non configurato | Non configurato | Viene visualizzato un messaggio di richiesta e, se l'utente accetta, viene eseguita la ricerca in Windows Update.
Ulteriori riferimenti

Installare i dispositivi e i relativi driver

Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici

Configurare Windows per ricercare i driver di dispositivo in altre cartelle


Aggiornare o cambiare un driver di dispositivo

In questo argomento viene illustrata una procedura che consente di aggiornare o cambiare il driver utilizzato per un dispositivo.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni, vedere "Considerazioni aggiuntive" in questo argomento.

Per aggiornare o cambiare il driver utilizzato per un dispositivo

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic sul tipo di dispositivo che si desidera aggiornare o cambiare.

  3. Fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Aggiorna driver.

  4. Seguire le istruzioni della procedura guidata Aggiornamento software driver.
Ulteriori considerazioni
  • Quando si aggiorna un driver o si installa un nuovo hardware, il computer tenta automaticamente di individuare un driver di dispositivo appropriato nel sito Windows Update e nelle cartelle specificate nella voce del Registro di sistema registro DevicePath. Per ulteriori informazioni, vedere Configurare Windows per ricercare i driver di dispositivo in Windows Update e Configurare Windows per ricercare i driver di dispositivo in altre cartelle.

  • Per impostazione predefinita, è necessario almeno appartenere al gruppo Administrators per installare un dispositivo il cui pacchetto driver non sia ancora presente nell'archivio driver. Un utente standard può installare un pacchetto driver solo se sono soddisfatte le condizioni seguenti:

    • Il pacchetto driver è firmato con un certificato presente nell'archivio certificati Autori attendibili nel computer. Per ulteriori informazioni, vedere la documentazione sulla firma di driver di dispositivo disponibile nel sito Web Microsoft (http://go.microsoft.com/fwlink/?linkid=62923).

    • La classe di installazione dispositivi per il driver si trova nel criterio Consenti agli utenti con privilegi limitati di installare driver per queste classi di dispositivo. Per ulteriori informazioni, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

Ulteriori riferimenti

Visualizzare le informazioni relative a un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo

Avviare o arrestare un driver di dispositivo non Plug and Play

Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Ripristinare la versione precedente di un driver di dispositivo

In questo argomento viene illustrata una procedura che consente di ripristinare una versione precedente di un driver di dispositivo.

Nelle versioni più recenti di un driver di dispositivo spesso sono presenti nuove funzionalità e vengono risolti i problemi riscontrati nelle versioni precedenti. Il ripristino di una versione precedente di un driver può causare la perdita delle nuove funzionalità e reintrodurre i problemi risolti dalla versione più recente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni, vedere "Considerazioni aggiuntive" in questo argomento.

Per ripristinare una versione precedente di un driver

  1. Aprire Gestione dispositivi.

  2. Fare clic con il pulsante destro del mouse sul dispositivo per il quale si desidera ripristinare la versione precedente del driver e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Driver.

  4. Fare clic su Ripristina driver.

  5. Nella finestra di dialogo Rollback pacchetto driver fare clic su Sì.
Ulteriori considerazioni
  • Per impostazione predefinita, per modificare i driver di dispositivo nel computer è richiesta almeno l'appartenenza al gruppo Administrators o equivalente. Un utente standard può modificare un pacchetto driver solo se la classe di installazione dispositivi per i driver è presente nel criterio computer Consenti agli utenti non amministratori di installare driver per queste classi di dispositivo. Per ulteriori informazioni, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

  • Il pulsante Ripristina driver è disponibile solo se era stata installata una versione precedente del driver. Se invece è stato installato solo il driver corrente per il dispositivo, il pulsante Ripristina driver non sarà disponibile.

Ulteriori riferimenti

Visualizzare le informazioni relative a un driver di dispositivo

Aggiornare o cambiare un driver di dispositivo

Avviare o arrestare un driver di dispositivo non Plug and Play

Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Attivare o disattivare un dispositivo Plug and Play

In questo argomento viene illustrata una procedura che consente di avviare o arrestare il driver di un dispositivo Plug and Play. Queste procedure non sono valide per i dispositivi non conformi alla specifica Plug and Play. Per i dispositivi non Plug and Play, vedere Avviare o arrestare un driver di dispositivo non Plug and Play.

  • Attivare un dispositivo

  • Disattivare un dispositivo

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Attivare un dispositivo

Per attivare un dispositivo Plug and Play

  1. Aprire Gestione dispositivi.

  2. Fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Attiva.

    L'opzione Attiva sarà presente solo se il dispositivo è disattivato.

Per attivare un dispositivo è possibile utilizzare anche la pagina Proprietà del dispositivo. Nella parte inferiore della scheda Generale fare clic su Cambia impostazioni, se presente. Nella scheda Driver fare clic su Attiva.

Se viene richiesto di riavviare il computer, il dispositivo verrà attivato solo dopo il riavvio del computer.

Disattivare un dispositivo

Quando si disattiva un dispositivo, il dispositivo fisico rimane collegato al computer ma il relativo driver viene disattivato. I driver saranno nuovamente disponibili quando si attiva il dispositivo. La disabilitazione dei dispositivi può risultare utile se si desidera utilizzare più configurazioni hardware per il computer o se si dispone di un computer portatile da inserire in un alloggiamento di espansione.

Se viene chiesto di riavviare il computer, il dispositivo non verrà disattivato e continuerà a funzionare fino al successivo riavvio del computer.

Dopo la disattivazione di un dispositivo e il riavvio del computer, se necessario, le risorse allocate al dispositivo vengono liberate e possono essere allocate a un altro dispositivo.

Alcuni dispositivi, ad esempio i dispositivi per le unità disco e i processori, non possono essere disattivati.

Per disattivare un dispositivo Plug and Play

  1. Aprire Gestione dispositivi.

  2. Fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Disattiva.

    Importante

    Se si disattiva un dispositivo necessario per l'avvio del sistema, ad esempio l'unità disco rigido, è possibile che il sistema non venga avviato.

Per disattivare un dispositivo è possibile utilizzare anche la pagina Proprietà del dispositivo. Nella parte inferiore della scheda Generale fare clic su Cambia impostazioni, se presente. Nella scheda Driver fare clic su Disattiva.
Ulteriori riferimenti

Installare i dispositivi e i relativi driver

Visualizzare le informazioni relative a un driver di dispositivo

Aggiornare o cambiare un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo

Avviare o arrestare un driver di dispositivo non Plug and Play

Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Avviare o arrestare un driver di dispositivo non Plug and Play

In questo argomento viene illustrata una procedura che consente di avviare o arrestare i driver dei dispositivi non conformi alla specifica Plug and Play. Per un dispositivo Plug and Play, vedere Attivare o disattivare un dispositivo Plug and Play.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per avviare o arrestare un driver di dispositivo non Plug and Play

  1. Aprire Gestione dispositivi.

  2. Scegliere Mostra dispositivi nascosti dal menu Visualizza.

  3. Nell'elenco dei dispositivi fare doppio clic su Driver non Plug and Play, fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Proprietà.

  4. Nella scheda Driver fare clic su Avvia o Arresta e quindi fare clic su OK.

    Nota

    Se il pulsante Avvia nella scheda Driver non è disponibile, il driver è già caricato.
Ulteriori riferimenti

Installare i dispositivi e i relativi driver

Visualizzare le informazioni relative a un driver di dispositivo

Aggiornare o cambiare un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo

Configurare il tipo di avvio per un driver di dispositivo non Plug and Play


Configurare il tipo di avvio per un driver di dispositivo non Plug and Play

In questo argomento viene illustrata una procedura che consente di configurare la modalità di avvio di un driver di dispositivo non Plug and Play all'avvio del computer.

Attenzione

La modifica impropria del tipo di avvio di un dispositivo di avvio o di una periferica di sistema può causare l'instabilità o il mancato avvio del computer oppure il mancato funzionamento del dispositivo. È importante comprendere appieno le istruzioni prima di modificare questa impostazione.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per modificare il tipo di avvio per un driver di dispositivo non Plug and Play

  1. Aprire Gestione dispositivi.

  2. Scegliere Mostra dispositivi nascosti dal menu Visualizza.

  3. Fare doppio clic su Driver non Plug and Play, fare clic con il pulsante destro del mouse su un dispositivo e quindi scegliere Proprietà.

  4. Nella scheda Driver, in Avvio, selezionare un Tipo e quindi fare clic su OK.

Quando si installa il driver per la prima volta, in Tipo di avvio viene impostato automaticamente il tipo richiesto dal driver. È possibile utilizzare le opzioni illustrate nella tabella riportata di seguito per modificare l'impostazione predefinita. Prestare attenzione quando si modifica il tipo di avvio. È importante comprendere appieno le istruzioni prima di modificare questa impostazione.

Tipo di avvio | Descrizione
Automatico | Il dispositivo viene avviato a ogni avvio del sistema, dopo i dispositivi di avvio e le periferiche di sistema. Fare clic su questa opzione per i dispositivi non essenziali per il funzionamento di base del sistema.
Avvio | Il dispositivo viene avviato a ogni avvio del sistema, prima degli altri dispositivi. Fare clic su questa opzione per i dispositivi essenziali per il funzionamento del sistema.
Richiesta | Il dispositivo viene avviato quando viene rilevato o se è necessario per un particolare evento. Fare clic su questa opzione per i dispositivi non essenziali per il funzionamento di base del sistema o non richiesti per il rilevamento di dispositivi.
Sistema | Il dispositivo viene avviato a ogni avvio del sistema, dopo i dispositivi di avvio. Fare clic su questa opzione per i dispositivi essenziali per il funzionamento del sistema.
Ulteriori riferimenti

Visualizzare le informazioni relative a un driver di dispositivo

Aggiornare o cambiare un driver di dispositivo

Ripristinare la versione precedente di un driver di dispositivo

Avviare o arrestare un driver di dispositivo non Plug and Play


Configurare le proprietà dei dispositivi

In questa sezione vengono illustrate alcune procedure che consentono di modificare la configurazione dei dispositivi hardware.

  • Informazioni sulla configurazione dei dispositivi

  • Modificare le impostazioni delle risorse di un dispositivo

  • Modificare le impostazioni di un tipo di dispositivo specifico

  • Modificare le opzioni di risparmio energia per un dispositivo

  • Eseguire l'aggiornamento da un computer monoprocessore a un computer multiprocessore


Informazioni sulla configurazione dei dispositivi

Quando si installa un dispositivo Plug and Play, Windows configura automaticamente il dispositivo in modo che funzioni correttamente con gli altri dispositivi installati nel computer. Durante tale processo di configurazione, Windows assegna un insieme univoco di risorse di sistema al dispositivo in corso di installazione. Tali risorse possono includere uno o più dei seguenti elementi:

  • Numero di riga IRQ

  • Canali DMA (Direct Memory Access)

  • Indirizzi di porta I/O (Input/output)

  • Intervalli di indirizzi di memoria

Per le definizioni di questi termini, vedere il Glossario di Gestione dispositivi.

Ogni risorsa assegnata al dispositivo deve essere univoca, altrimenti il dispositivo non potrà funzionare correttamente. Per i dispositivi Plug and Play, queste risorse vengono configurate automaticamente in modo corretto da Windows. È possibile tuttavia configurare manualmente le periferiche utilizzando Gestione dispositivi.

In generale è preferibile evitare di modificare manualmente le risorse poiché in questo modo le modifiche diventano fisse e Windows avrà una flessibilità minore nell'allocazione delle risorse ad altri dispositivi. Se troppe risorse diventano fisse, potrebbe risultare impossibile installare nuovi dispositivi Plug and Play.

Può accadere che due dispositivi richiedano le stesse risorse, con conseguente conflitto di periferica. In questo caso, è possibile modificare manualmente le impostazioni delle risorse per assicurarsi che ogni impostazione sia univoca. Alcune risorse come gli interrupt su dispositivi PCI, tuttavia, possono essere condivise, a seconda dei driver e dei computer.

In base al tipo di dispositivo che si sta installando, può essere necessario configurare manualmente queste impostazioni. Quando si installa un dispositivo non Plug and Play, Windows non è in grado di configurare automaticamente le impostazioni delle risorse per il dispositivo. Per istruzioni a questo riguardo, consultare il manuale fornito con il dispositivo.

Attenzione

La modifica impropria delle impostazioni delle risorse può causare la disattivazione dell'hardware e rendere malfunzionante o inutilizzabile il computer. Modificare le impostazioni delle risorse solo se si è certi che le nuove impostazioni non siano in conflitto con altri componenti hardware o se un produttore di hardware ha fornito specifiche impostazioni delle risorse per un dispositivo.
Ulteriori riferimenti

Configurare le proprietà dei dispositivi

Modificare le impostazioni delle risorse di un dispositivo

Modificare le impostazioni di un tipo di dispositivo specifico

Modificare le opzioni di risparmio energia per un dispositivo

Eseguire l'aggiornamento da un computer monoprocessore a un computer multiprocessore


Modificare le impostazioni delle risorse di un dispositivo

In questo argomento viene illustrata una procedura che consente di modificare le risorse utilizzate da un dispositivo.

Attenzione

La modifica impropria delle impostazioni delle risorse può causare la disattivazione dell'hardware e rendere malfunzionante o inutilizzabile il computer. È consigliabile che le modifiche alle impostazioni delle risorse vengano eseguite solo da utenti con una solida esperienza in fatto di hardware del computer e di impostazioni della configurazione hardware.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per modificare le impostazioni delle risorse per un dispositivo

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic sul tipo di dispositivo che si desidera modificare.

  3. Fare doppio clic sul dispositivo specifico che si desidera modificare. Se le impostazioni delle risorse del dispositivo sono modificabili, nella finestra di dialogo verrà visualizzata la scheda Risorse.

  4. Fare clic sulla scheda Risorse e quindi deselezionare la casella di controllo Impostazioni automatiche. Questa casella di controllo potrebbe non essere disponibile se non è possibile assegnare una risorsa specifica al dispositivo.

  5. In Impostazione basata su fare clic sulla configurazione hardware che si desidera modificare.

  6. In Impostazione risorse, in Tipo di risorsa, fare clic sul tipo di risorsa che si desidera modificare. Sono disponibili le opzioni seguenti:

    • Accesso diretto alla memoria (DMA)

    • Richiesta di interrupt (IRQ)

    • Porta I/O

    • Indirizzo memoria

  7. Fare clic su Cambia impostazione e quindi digitare un nuovo valore per il tipo di risorsa.

  8. Se necessario, ripetere i passaggi da 2 a 7.
Ulteriori considerazioni
Importante

Verificare che le nuove impostazioni non siano in conflitto con altri dispositivi. Gli eventuali conflitti tra dispositivi vengono visualizzati nella scheda Risorse in Elenco dispositivi in conflitto.

  • L'opzione Impostazioni automatiche non è abilitata per i dispositivi di cui non è possibile configurare altre impostazioni, né per i dispositivi controllati da risorse Plug and Play e che è consigliabile che non vengano modificati dall'utente.

  • L'assegnazione manuale delle risorse dovrebbe essere necessaria solo per alcune periferiche basilari di input/output di sistema (BIOS) di tipo ISA (Industry Standard Architecture) e Plug and Play obsolete. In genere non è necessario modificare manualmente le impostazioni delle risorse poiché le risorse vengono allocate automaticamente dal sistema al momento dell'installazione dell'hardware.

Ulteriori riferimenti

Configurare le proprietà dei dispositivi


Modificare le impostazioni di un tipo di dispositivo specifico

In questo argomento vengono illustrate alcune procedure che consentono di modificare le impostazioni specifiche di determinati tipi di dispositivo.

  • Modificare le impostazioni per una scheda di rete

  • Modificare le impostazioni per una porta COM o LPT

  • Modificare le impostazioni per un mouse PS/2

  • Modificare le impostazioni per un controller IDE

  • Modificare l'impostazione della regione per un'unità DVD

  • Modificare le impostazioni per un adattatore ISDN

  • Modificare le impostazioni per un dispositivo multimediale

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Modificare le impostazioni per una scheda di rete

Le proprietà dispositivo per le schede di rete sono dipendenti dal dispositivo. Consultare il manuale di istruzioni fornito dal produttore del dispositivo per determinare quali impostazioni devono essere modificate.

Per modificare le impostazioni per una scheda di rete

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Schede di rete.

  3. Fare clic con il pulsante destro del mouse sulla scheda di rete desiderata e quindi scegliere Proprietà.

  4. Nella scheda Avanzate apportare le modifiche desiderate.

Modificare le impostazioni per una porta COM o LPT

Per modificare le impostazioni per una porta COM o LPT

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Porte (COM e LPT).

  3. Fare clic con il pulsante destro del mouse sulla porta desiderata e quindi scegliere Proprietà.

  4. Nella scheda Impostazioni della porta apportare le modifiche desiderate.

    Nota

    La maggior parte dei dispositivi hardware che utilizza le porte ne imposta la velocità in modo automatico. Le impostazioni predefinite della velocità della porta del modem sono specificate in Opzioni modem e telefono nel Pannello di controllo, nella sezione Hardware e suoni.

Modificare le impostazioni per un mouse PS/2

Per modificare le impostazioni per un mouse PS/2

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Mouse e altre periferiche di puntamento.

  3. Fare clic con il pulsante destro del mouse su Mouse compatibile PS/2 e quindi scegliere Proprietà.

  4. Nella scheda Impostazioni avanzate apportare le modifiche desiderate.

Modificare le impostazioni per un controller IDE

Alcune impostazioni avanzate per i controlli IDE sono dipendenti dal dispositivo. Consultare il manuale di istruzioni fornito dal produttore del dispositivo per determinare quali impostazioni è possibile modificare.

Se è già stato rilevato un dispositivo IDE su un canale IDE, non sarà possibile modificare l'impostazione in Tipo di dispositivo. Questo impedisce di selezionare l'opzione Nessuno che disabiliterebbe il dispositivo IDE.

Per modificare le impostazioni per un controller IDE

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Controller IDE ATA/ATAPI, fare clic con il pulsante destro del mouse sul dispositivo IDE desiderato e quindi scegliere Proprietà.

  3. Nella scheda Impostazioni avanzate apportare le modifiche desiderate e quindi fare clic su OK.

    Nota

    La scheda Impostazioni avanzate potrebbe non essere visualizzata per tutti i controller IDE.

Modificare le impostazioni della regione per un'unità DVD

Per il funzionamento di molti software di decodificazione è necessario l'accesso diretto alla memoria (DMA). Verificare le impostazioni dei controller IDE (Integrated Device Electronics) ATA/ATAPI per assicurarsi che sia selezionata l'opzione DMA se disponibile in Modalità di trasferimento. Se del caso, verificare questa impostazione anche per il canale IDE secondario.

Per modificare l'impostazione della regione per un'unità DVD

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Unità DVD/CD-ROM, fare clic con il pulsante destro del mouse sull'unità DVD desiderata e quindi scegliere Proprietà.

  3. Nella scheda Regione DVD apportare le modifiche desiderate.

    Nota

    La scheda Regione DVD potrebbe non essere disponibile per tutte le unità DVD.

Per configurare l'unità DVD per la riproduzione di dischi di altre regioni, selezionare un'area geografica dall'elenco di regioni. In genere viene selezionata la regione in cui si risiede e non è necessario modificare ulteriormente questa impostazione.

Le impostazioni della regione possono essere modificate solo un numero limitato di volte. Quando Modifiche rimanenti indica 1 e si seleziona una nuova regione, verrà visualizzato un avviso per informare che dopo questa modifica sarà possibile riprodurre esclusivamente DVD di tale regione. Si tenga presente che l'impostazione della regione potrebbe non essere modificabile per alcuni decoder hardware e software di decodificazione per DVD.

Modificare le impostazioni per un adattatore ISDN

Per modificare le impostazioni per un adattatore ISDN

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Schede di rete, fare clic con il pulsante destro del mouse sull'adattatore ISDN (Integrated Services Digital Network) desiderato e quindi scegliere Proprietà.

  3. Nell'elenco Tipo commutatore o protocollo canale D della scheda ISDN fare clic su un tipo di commutatore o su un protocollo del canale D e quindi scegliere Configura.

    Apportare le modifiche desiderate.

Per informazioni sulla configurazione delle impostazioni per un adattatore ISDN, consultare la documentazione fornita dalla società telefonica o dal produttore dell'hardware.

Modificare le impostazioni per un dispositivo multimediale

I dispositivi multimediali possono includere dispositivi per flussi audio o video, codec audio o video o dispositivi MIDI.

Per modificare le impostazioni per un dispositivo multimediale

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Controller audio, video e giochi.

  3. Fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Proprietà.

  4. Modificare le configurazioni desiderate.

    Nota

    Il pulsante Proprietà è disponibile solo se nel computer sono presenti driver non WDM (Windows Driver Model). Se il pulsante Proprietà non è disponibile, utilizzare la scheda Risorse per configurare il dispositivo.
Ulteriori riferimenti

Configurare le proprietà dei dispositivi


Modificare le opzioni di risparmio energia per un dispositivo

In questo argomento viene illustrata una procedura che consente di configurare l'interazione tra il dispositivo e le opzioni di risparmio di energia di Windows, incluse le impostazioni che controllano il consumo di energia del dispositivo in varie condizioni e la risposta di Windows agli eventi del dispositivo, quando nel computer sono attivi diversi stati di risparmio energia.

Le opzioni di risparmio energia consentono di configurare un dispositivo per l'attivazione da uno stato di basso consumo al verificarsi di un evento. Ad esempio, una chiamata modem in ingresso indurrà il sistema a rispondere alla chiamata anche se è attivo lo stato di ibernazione. È inoltre possibile specificare se il sistema operativo deve spegnere un particolare dispositivo quando questo non è occupato, ad esempio per la risposta a una chiamata.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per modificare le opzioni di risparmio energia per un dispositivo

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic sul tipo di dispositivo per cui si desidera modificare le opzioni di risparmio energia.

  3. Fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Proprietà.

  4. Nella scheda Risparmio energia modificare le impostazioni desiderate.
Nota

La scheda Risparmio energia viene visualizzata solo per i driver di dispositivo che supportano gli standard relativi alle opzioni di risparmio energia.
Ulteriori riferimenti

Configurare le proprietà dei dispositivi


Eseguire l'aggiornamento da un computer monoprocessore a un computer multiprocessore

In questo argomento viene illustrata una procedura che consente di configurare specifici dispositivi quando si esegue l'aggiornamento da un sistema monoprocessore a un sistema multiprocessore.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Attenzione

L'aggiornamento da un computer monoprocessore a un computer multiprocessore può causare la disattivazione dell'hardware e rendere malfunzionante o inutilizzabile il computer. È consigliabile che l'aggiornamento venga effettuato solo da utenti con una solida esperienza in fatto di hardware del computer e di impostazioni della configurazione hardware.

Per eseguire l'aggiornamento da un computer monoprocessore a un computer multiprocessore

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic su Computer.

  3. Fare clic con il pulsante destro del mouse sul modello di computer e quindi scegliere Proprietà.

  4. Nella scheda Driver fare clic su Aggiorna driver. Verrà avviato l'Aggiornamento guidato hardware.

  5. Selezionare Cerca driver nel computer.

  6. Selezionare l'opzione Selezionare da un elenco di driver di dispositivo nel computer.

  7. Nella pagina Aggiornamento software driver fare clic sul tipo di computer appropriato nell'elenco Modello e quindi fare clic su Avanti.

  8. Al termine dell'installazione del driver, fare clic su Chiudi per chiudere la procedura guidata.

  9. Se viene richiesto di riavviare il computer, fare clic su Riavvia.
Ulteriori riferimenti

Configurare le proprietà dei dispositivi


Disinstallare e reinstallare dispositivi

In questa sezione vengono illustrate alcune procedure che consentono di disinstallare e reinstallare i dispositivi hardware.

  • Informazioni sul processo di disinstallazione dei dispositivi

  • Disinstallare o reinstallare un dispositivo

  • Rimuovere un pacchetto driver dall'archivio driver

  • Rimuovere o scollegare un dispositivo

  • Disinserire un computer portatile dall'alloggiamento di espansione


Informazioni sul processo di disinstallazione dei dispositivi

Disinstallare un dispositivo Plug and Play

In genere non è necessario disinstallare un dispositivo Plug and Play. È sufficiente scollegarlo dal computer e Windows non caricherà o non utilizzerà il driver. In alcuni casi può essere necessario spegnere il computer prima di scollegare il dispositivo. Per eseguire questa operazione in modo corretto, consultare il manuale di istruzioni fornito dal produttore del dispositivo.

Disinstallare un dispositivo non Plug and Play

La disinstallazione di un dispositivo non Plug and Play in genere prevede due passaggi:

  1. Utilizzo di Gestione dispositivi per disinstallare il dispositivo.

  2. Rimozione del dispositivo dal computer.

Utilizzare Gestione dispositivi per disinstallare un dispositivo non Plug and Play. Dopo aver disinstallato un dispositivo, è necessario scollegarlo o rimuoverlo fisicamente dal computer. Se ad esempio il dispositivo è collegato a una porta nella parte esterna del computer, spegnere il computer, scollegare il dispositivo dalla porta e quindi scollegare il cavo di alimentazione del dispositivo.

Differenza tra abilitare e disabilitare e installare e disinstallare

Anziché disinstallare un dispositivo Plug and Play che può essere necessario ricollegare successivamente, ad esempio un modem, è possibile decidere di disabilitarlo. Quando si disabilita un dispositivo, quest'ultimo rimane collegato fisicamente al computer, ma viene aggiornato il Registro di sistema in modo che i driver di tale dispositivo non vengano caricati all'avvio del computer. I driver saranno nuovamente disponibili quando si abilita il dispositivo. La disabilitazione risulta utile se si desidera utilizzare più configurazioni hardware per il computer o se si dispone di un computer portatile da inserire in un alloggiamento di espansione.

Per le procedure relative alla disinstallazione, alla reinstallazione e al ripristino dello stato precedente dei dispositivi e dei relativi driver, vedere Disinstallare o reinstallare un dispositivo e Ripristinare la versione precedente di un driver di dispositivo.

Per ulteriori informazioni sull'hardware e le procedure per l'installazione dei dispositivi, vedere Installare i dispositivi e i relativi driver e Configurare le proprietà dei dispositivi.

Ulteriori riferimenti

Disinstallare e reinstallare dispositivi


Disinstallare o reinstallare un dispositivo

In questo argomento vengono illustrate alcune procedure che consentono di disinstallare e reinstallare i dispositivi hardware.

  • Disinstallare un dispositivo

  • Reinstallare un dispositivo Plug and Play

  • Reinstallare un dispositivo non Plug and Play

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni, vedere "Considerazioni aggiuntive" in questo argomento.

Disinstallare un dispositivo

In generale non è necessario utilizzare Gestione dispositivi per disinstallare un dispositivo Plug and Play. È sufficiente scollegare il dispositivo Plug and Play dal computer. A seconda del tipo di dispositivo, tuttavia, può essere necessario riavviare il computer. Per ulteriori informazioni, vedere le istruzioni fornite dal produttore del dispositivo.

Per installare un dispositivo

  1. Aprire Gestione dispositivi.

  2. Fare doppio clic sul tipo di dispositivo che si desidera disinstallare.

  3. Fare clic con il pulsante destro del mouse sul dispositivo desiderato e quindi scegliere Disinstalla. In alternativa, è possibile fare doppio clic sul dispositivo e fare clic su Disinstalla nella scheda Driver.

  4. Nella pagina Conferma rimozione dispositivo selezionare Elimina il driver per il dispositivo se si desidera anche rimuovere il pacchetto driver di dispositivo dall'archivio driver.

    L'opzione Elimina il driver per il dispositivo consente di rimuovere il pacchetto dall'archivio driver ma non il driver installato per gli altri dispositivi operativi che utilizzano lo stesso driver. Se si rimuove il driver dall'archivio e il dispositivo viene nuovamente collegato al computer, Windows dovrà cercare una copia del pacchetto driver nei percorsi di ricerca standard, chiedendo all'utente di inserire l'apposito supporto, se necessario. Questa opzione equivale all'esecuzione del comando: pnputil -d -f <package.inf>. Per ulteriori informazioni, vedere Rimuovere un pacchetto driver dall'archivio driver.

  5. Fare clic su OK per completare il processo di disinstallazione.

  6. Al termine del processo di disinstallazione, scollegare il dispositivo dal computer.

    Se viene chiesto di riavviare il computer, la rimozione non è stata completata ed è possibile che il dispositivo continui a funzionare fino al successivo riavvio del computer.

Reinstallare un dispositivo Plug and Play

Reinstallare un dispositivo solo in caso di problemi di funzionamento o di mancato funzionamento. Prima di reinstallare un dispositivo, provare a riavviare il computer e verificare il dispositivo per stabilire se funziona correttamente. Se non funziona, procedere con la reinstallazione.

Per reinstallare un dispositivo Plug and Play

  1. Aprire Gestione dispositivi.

  2. Seguire le istruzioni riportate nella procedura precedente per disinstallare il dispositivo.

  3. Se viene richiesto di riavviare il computer, eseguire la procedura seguente:

    • Collegare il dispositivo e quindi riavviare il computer. Il dispositivo verrà rilevato e reinstallato dopo il riavvio di Windows.

    • Seguire le istruzioni visualizzate sullo schermo per completare l'installazione.

  4. Se non viene richiesto di riavviare il computer, eseguire la procedura seguente:

    • Scegliere Rileva modifiche hardware dal menu Azione di Gestione dispositivi.

    • Seguire le istruzioni visualizzate.

    Nota

    Tramite l'opzione Rileva modifiche hardware non viene reinstallato un dispositivo Plug and Play se nel computer è già installato un driver. Se il dispositivo non è stato disinstallato, tramite l'opzione Rileva modifiche hardware il collegamento del dispositivo non viene rilevato come modifica. È necessario disinstallare un dispositivo Plug and Play se si desidera che in Windows venga avviata l'installazione quando si collega di nuovo tale dispositivo.

Reinstallare un dispositivo non Plug and Play

Reinstallare un dispositivo solo in caso di problemi di funzionamento o di mancato funzionamento. Prima di reinstallare un dispositivo, provare a riavviare il computer e verificare il dispositivo per stabilire se funziona correttamente. Se non funziona, procedere con la reinstallazione.

Per reinstallare un dispositivo non Plug and Play

  1. Aprire Gestione dispositivi.

  2. Seguire le istruzioni riportate nella prima procedura per disinstallare il dispositivo.

  3. Fare clic con il pulsante destro del mouse sul nodo di primo livello nel riquadro dei dettagli.

  4. Fare clic su Aggiungi hardware legacy.

  5. Nell'Installazione guidata hardware fare clic su Avanti e quindi seguire le istruzioni visualizzate.
Ulteriori considerazioni
  • Per impostazione predefinita, per modificare i driver di dispositivo è richiesta almeno l'appartenenza al gruppo Administrators o equivalente. Un utente standard può modificare un driver solo se la classe di installazione dispositivi per i driver è presente nel criterio computer Consenti agli utenti non amministratori di installare driver per queste classi di dispositivo. Per ulteriori informazioni, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

Ulteriori riferimenti

Informazioni sul processo di disinstallazione dei dispositivi

Rimuovere un pacchetto driver dall'archivio driver

Rimuovere o scollegare un dispositivo

Disinserire un computer portatile dall'alloggiamento di espansione

Notazione di sintassi della riga di comando


Rimuovere un pacchetto driver dall'archivio driver

L'archivio driver è un'area protetta del computer che contiene i pacchetti driver di dispositivo di cui è stata approvata l'installazione nel computer. Per ulteriori informazioni sull'archivio driver, vedere Informazioni sull'installazione dei dispositivi e dei driver.

Con la rimozione di un pacchetto driver di dispositivo dall'archivio non vengono disinstallati i dispositivi attualmente funzionanti che utilizzano il driver. Le copie installate dei file del driver rimarranno inalterate. Verrà eliminata solo la copia del pacchetto driver presente nell'archivio. Dopo la rimozione del pacchetto dall'archivio, se viene collegato un nuovo dispositivo che utilizza il driver, Windows dovrà cercare il pacchetto driver utilizzando le posizioni standard, compresa la richiesta all'utente di inserire l'apposito supporto.

In questo argomento vengono illustrate alcune procedure che consentono di rimuovere un pacchetto driver di dispositivo dall'archivio driver.

  • Determinare il nome del pacchetto driver nell'archivio driver

  • Rimuovere dall'archivio driver un pacchetto driver di cui è stata effettuata un'installazione di appoggio

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni, vedere "Considerazioni aggiuntive" in questo argomento.

Determinare il nome del pacchetto driver nell'archivio driver

Prima di rimuovere il pacchetto driver, è necessario conoscerne il nome nell'archivio driver. Il nome del file con estensione inf viene cambiato in OEM#.inf, dove # è un numero univoco.

Per determinare il nome del pacchetto driver nell'archivio driver

  1. Aprire il prompt dei comandi con privilegi di amministratore. Fare clic sul pulsante Start, fare clic su Tutti i programmi e Accessori, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

    Nota

    Lo strumento della riga di comando PnPUtil funziona solo se il prompt dei comandi viene eseguito con privilegi di amministratore.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Al prompt dei comandi digitare:

    pnputil.exe -e

  4. Leggere le voci nel risultato per individuare la descrizione e il nome file del pacchetto.

Rimuovere dall'archivio driver un pacchetto driver di cui è stata effettuata un'installazione di appoggio

Quando si conosce il nome del file con estensione inf del pacchetto nell'archivio driver, è possibile rimuovere il pacchetto driver di dispositivo.

Per rimuovere dall'archivio driver un pacchetto driver di cui è stata effettuata un'installazione di appoggio

  1. Aprire il prompt dei comandi con privilegi amministrativi. Fare clic sul pulsante Start, fare clic su Tutti i programmi e Accessori, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

    Nota

    Lo strumento PnPUtil non funziona se non si esegue il prompt dei comandi come amministratore.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Al prompt dei comandi digitare:

    pnputil.exe -d Oem#.inf

    Sostituire # con il numero del file con estensione inf che si desidera rimuovere.

    Nota

    Per visualizzare tutti i parametri della riga di comando per lo strumento PnPUtil, al prompt dei comandi digitare: pnputil -?

  4. Se viene segnalato che il pacchetto driver è utilizzato da un dispositivo attualmente installato, sarà necessario disinstallare prima il dispositivo oppure utilizzare l'opzione -f nel comando pnputil per imporre l'eliminazione del pacchetto.

Ulteriori considerazioni
  • Per impostazione predefinita, per modificare i driver di dispositivo nell'archivio driver è richiesta almeno l'appartenenza al gruppo Administrators o equivalente. A un utente standard è possibile delegare l'autorizzazione per l'installazione o la disinstallazione di un pacchetto driver. Per delegare questo diritto, inserire la classe di installazione dispositivo per il driver nel criterio Consenti agli utenti non amministratori di installare driver per queste classi di dispositivo. Per ulteriori informazioni, vedere Configurare un criterio computer per consentire agli utenti non amministratori di installare dispositivi specifici.

Ulteriori riferimenti

Disinstallare e reinstallare dispositivi

Informazioni sull'installazione dei dispositivi e dei driver

Effettuare un'installazione di appoggio di un driver di dispositivo nell'archivio driver

Informazioni sul processo di disinstallazione dei dispositivi

Disinstallare o reinstallare un dispositivo

Notazione di sintassi della riga di comando


Rimuovere o scollegare un dispositivo

In questo argomento viene illustrata una procedura che consente di rimuovere o scollegare in modo sicuro un dispositivo rimovibile.

Attenzione

Se si scollega o si rimuove un dispositivo che supporta la rimozione sicura senza prima utilizzare l'applicazione Rimozione sicura per avvisare il sistema, è possibile che si verifichi una perdita di dati o che il sistema diventi instabile. Se ad esempio si scollega un dispositivo durante un trasferimento di dati, è probabile che si verifichi una perdita di dati. Se invece si utilizza Rimozione sicura, è possibile avvisare il sistema prima di scollegare o rimuovere un dispositivo, evitando la perdita di dati.

È possibile utilizzare qualsiasi account utente per completare questa procedura.

Per rimuovere o scollegare un dispositivo

  1. Nell'area di notifica della barra delle applicazioni fare clic sull'icona Rimozione sicura (

    Icona Rimozione sicura dell'hardware).

    Verrà visualizzato un menu di scelta rapida con un elenco di dispositivi Plug and Play che supportano la rimozione sicura e che sono attualmente collegati al sistema.

    Se nel menu non viene visualizzato il dispositivo desiderato, tale dispositivo non supporta la rimozione sicura e non può essere scollegato o rimosso utilizzando Rimozione sicura.

  2. Nell'elenco di dispositivi selezionare il dispositivo che si desidera scollegare o rimuovere.

    Verrà visualizzata una notifica che indica che è possibile scollegare o rimuovere il dispositivo.

    Nota

    Per i dispositivi di archiviazione rimovibili che possono essere rimossi in modo sicuro quando il computer è acceso, per impostazione predefinita è disattivata la cache in scrittura. Questo consente di rimuovere i dispositivi senza perdita di dati.
Ulteriori riferimenti

Disinstallare e reinstallare dispositivi

Informazioni sul processo di disinstallazione dei dispositivi

Disinserire un computer portatile dall'alloggiamento di espansione


Disinserire un computer portatile dall'alloggiamento di espansione

In questo argomento viene illustrata una procedura che consente di rimuovere in modo sicuro un computer portatile da un alloggiamento di espansione.

Attenzione

La rimozione di un computer portatile senza utilizzare l'opzione Disinserisci può provocare l'instabilità del computer, la perdita di dati o persino danni ai componenti hardware. Per evitare perdite o danni, utilizzare l'opzione Disinserisci per disinserire il computer dall'alloggiamento di espansione oppure spegnere il sistema e disinserire il computer portatile quando il sistema è spento. Se un computer portatile viene disinserito dall'alloggiamento di espansione quando è in modalità standby o di ibernazione, è possibile che si verifichino perdite di dati e instabilità del sistema.

È possibile utilizzare qualsiasi account utente per completare questa procedura.

Per disinserire un computer portatile dall'alloggiamento di espansione

  1. Fare clic sul pulsante Start.

  2. Nel menu Start, sulla destra dei pulsanti di spegnimento e blocco , fare clic sul pulsante freccia per visualizzare il menu Opzioni di arresto.

    Se il computer viene riconosciuto come computer portatile che supporta il disinserimento dall'alloggiamento di espansione, in questo menu sarà presente l'opzione Disinserisci. In caso contrario, l'opzione Disinserisci non sarà presente.

  3. Fare clic su Disinserisci.

  4. Se viene visualizzato un messaggio che indica che è sicuro procedere, disinserire il computer portatile dall'alloggiamento di espansione. Se si dispone di un alloggiamento di espansione motorizzato, il computer portatile verrà disinserito automaticamente.
Ulteriori considerazioni
  • L'opzione Disinserisci viene visualizzato nel menu Opzioni di arresto solo se il computer è abilitato per ACPI (Advanced Configuration and Power Interface) e viene riconosciuto come computer portatile in un alloggiamento di espansione. Se l'opzione Disinserisci non viene visualizzata nel menu Opzioni di arresto, il computer non è abilitato per ACPI o potrebbe non supportare il disinserimento dall'alloggiamento di espansione.

  • Alcuni computer dispongono di un pulsante di espulsione nell'alloggiamento di espansione. Se viene premuto questo pulsante, il computer portatile viene disinserito dall'alloggiamento di espansione anche senza eseguire questa procedura. Per ulteriori informazioni, consultare la documentazione fornita con l'alloggiamento di espansione.

  • Per assicurare prestazioni ottimali del computer portatile, modificare la combinazione per il risparmio di energia nel Pannello di controllo. Questa opzione è disponibile nella categoria PC portatile come Gestisci alimentazione a batteria oppure Opzioni risparmio energia in Visualizzazione classica.

Ulteriori riferimenti

Disinstallare e reinstallare dispositivi

Rimuovere o scollegare un dispositivo


Ulteriori risorse relative a Gestione dispositivi

Per ulteriori informazioni su Gestione dispositivi, vedere le risorse seguenti nel sito Web Microsoft:

  • Guida dettagliata all'installazione e alla gestione di dispositivi: firma e installazione di appoggio di driver di dispositivo (http://go.microsoft.com/fwlink/?LinkId=140049)

  • Pagina relativa a prestazioni e compatibilità hardware (http://go.microsoft.com/fwlink/?LinkId=63117)

  • Pagina relativa alla risoluzione dei problemi di installazione e gestione di dispositivi (http://go.microsoft.com/fwlink/?LinkId=63116)

  • Sito Web relativo agli sviluppatori hardware di Windows (http://go.microsoft.com/fwlink/?LinkId=3788)


Glossario di Gestione dispositivi

I termini indicati di seguito sono utilizzati nella documentazione relativa all'installazione e alla gestione di dispositivi. Nell'ambito della gestione di dispositivi, tali termini possono avere un significato specifico.

dispositivo
Qualunque dispositivo collegabile a una rete o a un computer, ad esempio una stampante, un joystick, un adattatore o una scheda modem, oppure qualsiasi altra periferica. Un dispositivo richiede un driver di dispositivo per funzionare con Windows.

conflitto di dispositivo
Si verifica quando le stesse risorse sono state allocate a due o più dispositivi. Le risorse di sistema includono le linee IRQ, i canali di accesso diretto alla memoria (DMA), le porte di input/output (I/O) e gli indirizzi di memoria.

driver di dispositivo
Software che consente a Windows di comunicare con uno specifico dispositivo hardware. Affinché Windows sia in grado di utilizzare un nuovo componente hardware, è necessario che sia installato il relativo driver.

pacchetto driver di dispositivo
File necessari per installare e configurare il driver di dispositivo. Un pacchetto driver di dispositivo può includere un programma di installazione, un file con estensione inf e un file catalogo di sicurezza, oltre ai file del driver di dispositivo veri e propri.

disabilitare
Disattivare il funzionamento di un dispositivo. Se ad esempio si disabilita un dispositivo in una configurazione hardware, non sarà possibile utilizzare il dispositivo quando viene utilizzata tale configurazione hardware. Con la disabilitazione di un dispositivo vengono liberate le risorse precedentemente allocate a tale dispositivo.

accesso diretto alla memoria (DMA)
Accesso alla memoria che non coinvolge il microprocessore. Questo tipo di accesso viene utilizzato di frequente per il trasferimento diretto di dati tra la memoria e una periferica, ad esempio un'unità disco.

inserire nell'alloggiamento di espansione
Collegare un computer portatile a un alloggiamento di espansione.

archivio driver (o archivio driver protetto)
Area sicura del computer in cui vengono inseriti i pacchetti di installazione dei driver di dispositivo prima che siano attivati. Per tutti i pacchetti driver è prevista un'installazione di appoggio nell'archivio durante il processo di installazione.

abilitare
Attivare il funzionamento di un dispositivo. Se ad esempio si abilita un dispositivo nelle impostazioni della configurazione hardware, il dispositivo sarà disponibile quando viene utilizzata tale configurazione hardware.

configurazione hardware
Impostazioni delle risorse allocate per un dispositivo specifico. A ogni dispositivo nel computer è associata una configurazione hardware, che può essere costituita da linee IRQ, DMA, una porta I/O o impostazioni relative all'indirizzo di memoria.

porta di input/output (I/O)
Canale attraverso il quale vengono trasferiti i dati tra un dispositivo e il microprocessore. Per il microprocessore la porta è rappresentata da uno o più indirizzi di memoria utilizzabili per l'invio o la ricezione di dati.

installare
Con riferimento all'hardware, collegare fisicamente un dispositivo al computer, caricare i driver di dispositivo nel computer e configurare le impostazioni e le proprietà del dispositivo.

interrupt
Richiesta di attenzione dal microprocessore. Quando il processore riceve un interrupt, sospende le operazioni in corso, salva lo stato del lavoro e trasferisce il controllo a una particolare routine denominata gestore di interrupt, che contiene le istruzioni per la gestione della situazione specifica all'origine dell'interrupt.

richiesta di interrupt (IRQ)
Segnale inviato da un dispositivo per ottenere l'attenzione da parte del processore quando il dispositivo è pronto a ricevere o inviare informazioni. Ogni dispositivo invia le richieste di interrupt su una specifica linea hardware. È pertanto necessario assegnare un numero IRQ univoco a ogni dispositivo.

computer locale
Computer al quale si è ottenuto l'accesso come utente. In termini più generali, un computer locale è un computer al quale è possibile accedere direttamente senza dover utilizzare una linea di comunicazione o un dispositivo di comunicazione, ad esempio una scheda di rete o un modem.

indirizzo di memoria
Parte della memoria del computer che è possibile allocare a un dispositivo o che può essere utilizzata da un'applicazione o dal sistema operativo. Ai dispositivi è generalmente assegnato un intervallo di indirizzi di memoria.

non Plug and Play
Dispositivo, quale una stampante, un modem o una periferica di gioco, che richiede la configurazione manuale delle impostazioni hardware prima dell'utilizzo. I dispositivi non Plug and Play sono sempre più rari in quanto l'industria ha orientato la produzione in favore dei dispositivi Plug and Play. Il termine non Plug and Play in genere si riferisce ad apparecchiature obsolete.

PCI (Peripheral Connection Interface)
Specifica introdotta da Intel Corporation che definisce un sistema di bus locale che consente di installare fino a 10 schede di espansione compatibili PCI.

Plug and Play
Insieme di specifiche sviluppate da Intel Corporation che consente al computer di rilevare e configurare automaticamente un dispositivo e di installare i driver di dispositivo appropriati.

porta
Punto di collegamento disponibile nel computer al quale è possibile collegare dispositivi per lo scambio di dati in uscita e in ingresso.

computer remoto
Computer al quale è possibile accedere solo tramite una linea di comunicazione o un dispositivo di comunicazione, quale una scheda di rete o un modem.

risorse
In linea generale, qualsiasi parte di un sistema o di una rete, ad esempio un'unità disco, una stampante o la memoria, che può essere allocata a un programma in esecuzione o a un processo.

Nell'ambito della gestione di dispositivi, uno dei quattro componenti di sistema che controllano la modalità di funzionamento di dispositivi in un computer. Queste quattro risorse di sistema sono le linee di richiesta di interrupt (IRQ), i canali di accesso diretto alla memoria (DMA), le porte di input/output (I/O) e gli indirizzi di memoria.

installazione di appoggio
Processo di inserimento di un driver di dispositivo nell'archivio driver per consentirne l'installazione. Per tutti i pacchetti driver è necessaria un'installazione di appoggio nell'archivio dati prima dell'installazione. Per inserire un driver di dispositivo nell'archivio driver è necessario utilizzare un account di amministratore o un account utente con le autorizzazioni delegate appropriate. Durante l'installazione di appoggio Windows verifica che nel driver di dispositivo sia presente una firma valida.

disinserire dall'alloggiamento di espansione
Scollegare un computer portatile da un alloggiamento di espansione.

disinstallare
In riferimento al software, rimuovere i file di programma e le cartelle da disco rigido e i dati correlati dal Registro di sistema affinché il programma non sia più disponibile.

In riferimento a un dispositivo, rimuovere i driver di dispositivo corrispondenti dal disco rigido e rimuovere fisicamente il dispositivo dal computer.


Notazione di sintassi della riga di comando

Nella tabella seguente viene descritta la notazione utilizzata per indicare la sintassi della riga di comando.

Notazione | Descrizione
Testo senza parentesi quadre o graffe | Elementi da digitare come indicato
<Testo tra parentesi acute> | Segnaposto per il quale è necessario fornire un valore
[Testo tra parentesi quadre] | Elementi facoltativi
{Testo tra parentesi graffe} | Serie di elementi richiesti: effettuare una selezione
Barra verticale (|) | Separatore per elementi che si escludono a vicenda: effettuare una selezione
Puntini di sospensione (...) | Elementi che possono essere ripetuti