Gestione DFS

File system distribuito viene implementato come servizio ruolo del ruolo Servizi file. File system distribuito è costituito da due servizi ruolo:

  • Spazi dei nomi DFS

  • Replica DFS

Per gestire Spazi dei nomi DFS e Replica DFS è possibile utilizzare lo snap-in Gestione DFS ospitato da Server Manager oppure incluso nella cartella Strumenti di amministrazione. In alternativa, è possibile utilizzare gli strumenti del prompt dei comandi, come illustrato più avanti in questo argomento.

Importante

Per visualizzare o gestire gruppi di replica contenenti cartelle replicate di sola lettura o membri che rappresentano cluster di failover, è necessario utilizzare la versione di Gestione DFS inclusa con Windows Server 2008 R2.

Per ulteriori informazioni su Spazi dei nomi DFS e Replica DFS, vedere gli argomenti seguenti:

  • Installare DFS

  • Spazi dei nomi

  • Replica

  • Risorse su Gestione DFS

Gestire DFS dal prompt dei comandi

Per gestire File system distribuito dal prompt dei comandi, è possibile utilizzare i comandi elencati nella tabella seguente oppure creare script in cui viene utilizzato Strumentazione gestione Windows (WMI).

Comando | Descrizione
DfsUtil | Gestisce gli spazi dei nomi, i computer server e i computer client DFS.
DfsCmd | Configura cartelle e destinazioni di cartelle DFS in uno spazio dei nomi DFS.
DfsDiag | Esegue test di diagnostica di Spazi dei nomi DFS.
DfsrAdmin | Gestisce le cartelle replicate di Replica DFS.
DfsrDiag | Esegue test di diagnostica di Replica DFS.

Ulteriori riferimenti

  • Novità di File system distribuito in Windows Server® 2008 R2

    (http://go.microsoft.com/fwlink/?LinkId=139569)

  • Guida alla migrazione della replica SYSVOL: da Replica file a Replica DFS

    (http://go.microsoft.com/fwlink/?LinkId=139569

  • Guida comandi di Windows Server 2008

    (http://go.microsoft.com/fwlink/?LinkId=140139)


Installare DFS

Per gestire Spazi dei nomi DFS e Replica DFS, è necessario installare lo snap-in Gestione DFS. Utilizzare una delle procedure riportate di seguito per installare lo snap-in Gestione DFS.

Importante

Per visualizzare o gestire gruppi di replica contenenti cartelle replicate di sola lettura o membri che rappresentano cluster di failover, è necessario utilizzare la versione di Gestione DFS inclusa con Windows Server 2008 R2.

Installare Gestione DFS

  • Tramite l'interfaccia di Windows

  • Tramite riga di comando
Per installare Gestione DFS tramite l'interfaccia di Windows

  • Per installare Gestione DFS e i servizi correlati, in Server Manager utilizzare l'Aggiunta guidata ruoli per selezionare il ruolo Servizi file e quindi selezionare il servizio ruolo File system distribuito. In tal modo il server verrà configurato come file server, verrà installato lo snap-in Gestione DFS e verranno installati e avviati i servizi Spazi dei nomi DFS e Replica DFS.

  • Per installare solo Gestione DFS e gli strumenti da riga di comando, in Server Manager utilizzare l'Aggiunta guidata funzionalità per installare la funzionalità Strumenti di amministrazione remota del server, selezionare Strumenti di amministrazione ruoli e quindi la funzionalità Strumenti per Servizi file con l'opzione Strumenti per File system distribuito (DFS). Questa opzione consente di installare lo snap-in Gestione DFS e gli strumenti da riga di comando, senza installare tuttavia i servizi DFS nel server.

Per installare Gestione DFS tramite riga di comando

  • Aprire una finestra del prompt dei comandi e digitare il comando seguente, dove <nome> è il ruolo, il servizio ruolo o la funzionalità che si desidera installare. Per un breve elenco dei parametri pertinenti, vedere la tabella riportata di seguito.

    ServerManagerCmd -install <nome>

    Per installare ad esempio il componente Strumenti per File system distribuito (DFS) della funzionalità Strumenti di amministrazione remota del server, digitare:

    ServerManagerCmd -install RSAT-DFS-Mgmt-Con

    Descrizione Parametro

    Ruolo server Servizi file

    File-Services

    Ruolo server File system distribuito

    FS-DFS

    Ruolo server Spazi dei nomi DFS

    FS-DFS-Namespace

    Ruolo server Replica DFS

    FS-DFS-Replication

    Funzionalità Strumenti per File system distribuito (DFS)

    RSAT-DFS-Mgmt-Con
    Nota

    Per installare Replica DFS in Windows Web Server 2008 R2, è necessario utilizzare il comando OCSetup DFSR-Infrastructure-ServerEdition.

Ulteriori riferimenti

  • Spazi dei nomi

  • Replica


Spazi dei nomi

La tecnologia Spazi dei nomi DFS consente di raggruppare in uno o più spazi dei nomi cartelle condivise che risiedono su server diversi. Ogni spazio dei nomi viene visualizzato agli utenti come un'unica cartella condivisa con una serie di sottocartelle. La struttura sottostante dello spazio dei nomi può tuttavia consistere in numerose cartelle condivise che risiedono in server diversi e in più siti.

Tale struttura consente di incrementare la disponibilità e di connettere automaticamente gli utenti a eventuali cartelle condivise disponibili nello stesso sito Servizi di dominio Active Directory, anziché eseguirne il routing tramite connessioni WAN (Wide Area Network).

  • Panoramica di Spazi dei nomi DFS

  • Elenco di controllo: distribuire Spazi dei nomi DFS

  • Elenco di controllo: ottimizzare uno spazio dei nomi DFS

  • Distribuire Spazi dei nomi DFS

  • Ottimizzare Spazi dei nomi DFS

  • Risorse su Gestione DFS

Nota

Per eseguire la maggior parte delle attività, è necessario essere membri del gruppo Domain Admins in Servizi di dominio Active Directory, a meno che non si sia stati delegati dall'autorità appropriata. Per gestire un server remoto, potrebbe inoltre essere necessario essere membri del gruppo Administrators locale del server che si desidera gestire. Per ulteriori informazioni, vedere Delegare le autorizzazioni di gestione per Spazi dei nomi DFS.


Panoramica di Spazi dei nomi DFS

Uno spazio dei nomi è una visualizzazione virtuale delle cartelle condivise di un'organizzazione. Il percorso di uno spazio dei nomi è simile a un percorso UNC (Universal Naming Convention) di una cartella condivisa, ad esempio \\Server1\Pubblico\Software\Strumenti. In questo esempio la cartella condivisa Pubblico e le relative sottocartelle Software e Strumenti sono tutte ospitate su Server1.

Se si desidera consentire agli utenti di individuare i dati in un unico percorso ospitando tuttavia i dati su server diversi, ai fini delle prestazioni e della disponibilità, è possibile distribuire uno spazio dei nomi simile a quello illustrato nella figura seguente. Di seguito sono descritti gli elementi di questo spazio dei nomi.

Elementi della tecnologia degli spazi dei nomi DFS
  • Server degli spazi dei nomi. Un server dello spazio dei nomi ospita uno spazio dei nomi e può essere un server membro o un controller di dominio.

  • Directory radice dello spazio dei nomi. La directory radice dello spazio dei nomi è il punto di partenza dello spazio dei nomi. Nella figura precedente il nome della directory radice è Public e il percorso dello spazio dei nomi è \\Contoso\Public. Questo tipo di spazio dei nomi è uno spazio dei nomi basato su dominio, poiché inizia con un nome di dominio, ad esempio Contoso, e i relativi metadati vengono archiviati in Servizi di dominio Active Directory. Nonostante nella figura precedente sia illustrato un singolo server dello spazio dei nomi, è possibile incrementare la disponibilità di uno spazio dei nomi basato su dominio eseguendone l'hosting su più server dello spazio dei nomi.

  • Cartella. Le cartelle senza destinazioni cartella costituiscono la struttura e la gerarchia dello spazio dei nomi, mentre quelle con destinazioni cartella offrono agli utenti l'effettivo contenuto. Quando gli utenti esplorano una cartella con destinazioni cartella nello spazio dei nomi, il computer client riceve un riferimento da cui viene reindirizzato in modo trasparente a una delle destinazioni cartella.

  • Destinazioni cartella. Una destinazione cartella è il percorso UNC (Universal Naming Convention) di una cartella condivisa o un altro spazio dei nomi associato a una cartella in uno spazio dei nomi. La destinazione cartella viene utilizzata per l'archiviazione di dati e contenuto. Nella figura precedente la cartella denominata Tools dispone di due destinazioni cartella, una a Londra e una a New York, mentre la cartella denominata Training Guides dispone di una singola destinazione cartella a New York. Gli utenti che selezionano \\Contoso\Public\Software\Tools vengono reindirizzati in modo trasparente alla cartella condivisa \\LDN-SVR-01\Tools o \\NYC-SVR-01\Tools, a seconda del sito in cui si trova attualmente l'utente.

Nota

Le cartelle possono contenere destinazioni cartella o altre cartelle DFS, ma non entrambi, nello stesso livello della gerarchia di cartelle.

Per amministrare gli spazi dei nomi, è possibile utilizzare Gestione DFS, il comando DfsUtil o script che chiamano WMI.

Ulteriori riferimenti

  • Gestione DFS


Elenco di controllo: distribuire Spazi dei nomi DFS

È possibile utilizzare Spazi dei nomi DFS e Replica DFS per pubblicare documenti, software e dati line-of-business tra gli utenti di un'organizzazione. Sebbene il solo servizio Replica DFS sia sufficiente per distribuire i dati, è possibile utilizzare Spazi dei nomi DFS per configurare lo spazio dei nomi in modo che una cartella venga ospitata da più server contenenti ognuno una copia aggiornata della cartella. In tal modo è possibile aumentare la disponibilità dei dati e distribuire il carico di lavoro tra i server.

Gli utenti che esplorano una cartella inclusa nello spazio dei nomi non sono in grado di rilevare che questa è ospitata da più server. Quando un utente apre la cartella, il computer viene automaticamente indirizzato a un server dello stesso sito. Se nel sito non sono disponibili server dello stesso sito, è possibile configurare lo spazio dei nomi in modo che indirizzi il client a un server con la connessione di costo inferiore in base a quanto definito in Servizi di dominio Active Directory.

Per distribuire Spazi dei nomi DFS, eseguire le attività seguenti:

Attività | Riferimento
Esaminare i concetti fondamentali relativi a Spazi dei nomi DFS | Panoramica di Spazi dei nomi DFS
Esaminare i requisiti ed eseguire le operazioni di preparazione alla distribuzione di Spazi dei nomi DFS | Preparare la distribuzione di Spazi dei nomi DFS
Installare Gestione DFS | Installare DFS
Creare uno spazio dei nomi DFS | Creare uno spazio dei nomi DFS
Eseguire la migrazione di spazi dei nomi basati su dominio a spazi dei nomi basati su dominio in modalità Windows Server 2008 | Eseguire la migrazione di uno spazio dei nomi basato su dominio alla modalità Windows Server 2008
Garantire una maggior disponibilità aggiungendo server dello spazio dei nomi a uno spazio dei nomi basato su dominio | Aggiungere server dello spazio dei nomi a uno spazio dei nomi DFS basato su dominio
Aggiungere cartelle a uno spazio dei nomi | Creare una cartella in uno spazio dei nomi DFS
Aggiungere destinazioni cartella a cartelle in uno spazio dei nomi | Aggiungere destinazioni cartella
Replicare contenuto tra destinazioni cartella mediante Replica DFS (facoltativo) | Replicare destinazioni cartella mediante Replica DFS

Ulteriori riferimenti

  • Spazi dei nomi

  • Elenco di controllo: ottimizzare uno spazio dei nomi DFS

  • Replica


Elenco di controllo: ottimizzare uno spazio dei nomi DFS

Dopo aver creato uno spazio dei nomi e aver aggiunto cartelle e destinazioni, utilizzare gli elenchi di controllo seguenti per ottimizzare il modo in cui Spazio dei nomi DFS gestisce i riferimenti ed esegue il polling a Servizi di dominio Active Directory per ottenere dati aggiornati sullo spazio dei nomi.

Il miglioramento del servizio Spazi dei nomi DFS noto come priorità della destinazione consente inoltre di impostare la priorità dei server in modo che un determinato server risulti sempre il primo o l'ultimo nell'elenco dei server (noto come riferimento) ricevuto dal client all'accesso alla cartella con destinazioni nello spazio dei nomi.

Attività | Riferimento
Impedire agli utenti di visualizzare cartelle in uno spazio dei nomi per cui non dispongono delle autorizzazioni di accesso | Attivare l'enumerazione basata sull'accesso in uno spazio dei nomi
Consentire o evitare che gli utenti siano indirizzati a uno spazio dei nomi o una destinazione di cartella quando accedono a una cartella nello spazio dei nomi | Attivare o disattivare i riferimenti e il failback dei client
Modificare l'intervallo di tempo di memorizzazione nella cache di un riferimento da parte dei client prima che questi ultimi ne richiedano uno nuovo | Modificare l'intervallo di tempo di memorizzazione nella cache dei riferimenti da parte dei client
Specificare l'ordine con cui gli utenti devono essere indirizzati a destinazioni cartella | Impostare il metodo di ordinamento delle destinazioni nei riferimenti
Ignorare l'ordinamento dei riferimenti per un server dello spazio dei nomi o una destinazione di cartella specifica | Impostare la priorità della destinazione per ignorare l'ordinamento dei riferimenti
Ottimizzare il polling dei server dello spazio dei nomi a Servizi di dominio Active Directory in modo da ottenere i dati dello spazio dei nomi più recenti | Ottimizzare il polling dello spazio dei nomi
Utilizzare autorizzazioni ereditate per specificare gli utenti che possono visualizzare le cartelle in uno spazio dei nomi per cui è attivata l'enumerazione basata sull'accesso | Utilizzare autorizzazioni ereditate con enumerazione basata sull'accesso

Ulteriori riferimenti

  • Spazi dei nomi

  • Elenco di controllo: distribuire Spazi dei nomi DFS

  • Ottimizzare Spazi dei nomi DFS


Distribuire Spazi dei nomi DFS

Per distribuire Spazi dei nomi DFS, fare riferimento agli argomenti seguenti:

  • Preparare la distribuzione di Spazi dei nomi DFS

  • Creare uno spazio dei nomi DFS

  • Eseguire la migrazione di uno spazio dei nomi basato su dominio alla modalità Windows Server 2008

  • Aggiungere server dello spazio dei nomi a uno spazio dei nomi DFS basato su dominio

  • Creare una cartella in uno spazio dei nomi DFS

  • Aggiungere destinazioni cartella

  • Replicare destinazioni cartella mediante Replica DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Preparare la distribuzione di Spazi dei nomi DFS

Nelle sezioni seguenti vengono fornite informazioni sulle operazioni da eseguire per distribuire Spazi dei nomi DFS:

  • Esaminare i requisiti del client di Spazi dei nomi DFS

  • Esaminare i requisiti del server di Spazi dei nomi DFS

  • Scegliere un tipo di spazio dei nomi


Esaminare i requisiti del client di Spazi dei nomi DFS

I sistemi operativi seguenti includono il supporto completo per Spazi dei nomi DFS, incluso quello per il failback dei client sulla destinazione cartella preferita:

  • Windows 7

  • Windows Server 2008 R2

  • Windows Server 2008

  • Windows Vista Business, Windows Vista Enterprise, Windows Vista Ultimate

  • Windows Server 2003 R2

  • Windows Storage Server 2003 R2

  • Windows Server 2003 con SP2 o SP1 e l'aggiornamento rapido per il failback dei client Windows Server 2003

  • Windows XP Professional con SP3 o SP2 e l'aggiornamento rapido per il failback dei client Windows XP

Per una descrizione di questi aggiornamenti rapidi, vedere l'articolo 898900 della Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=53202).

Gli utenti che utilizzano i sistemi operativi seguenti possono accedere agli spazi dei nomi, tuttavia se una destinazione cartella diventa indisponibile e viene riattivata in un secondo momento, il computer non eseguirà il failback, ovvero il ripristino, della destinazione cartella preferita.

  • Windows Storage Server 2003

  • Windows XP Professional

  • Ambiente preinstallazione di Windows (Windows PE)

    Windows PE consente di accedere a spazi dei nomi autonomi ma non a quelli basati su dominio.

  • Windows 2000 Server

  • Windows 2000 Professional

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Attivare o disattivare i riferimenti e il failback dei client


Esaminare i requisiti del server di Spazi dei nomi DFS

Un server dello spazio dei nomi è un controller di dominio o un server membro che ospita uno spazio dei nomi. Il numero di spazi dei nomi che possono essere ospitati in un server dipende dal sistema operativo utilizzato.

I server seguenti possono ospitare più spazi dei nomi autonomi e basati su dominio:

  • Windows Server 2008 R2 Enterprise

  • Windows Server 2008 R2 Datacenter

  • Windows Server 2008 Enterprise

  • Windows Server 2008 Datacenter

  • Windows Server 2003 R2, Enterprise Edition

  • Windows Server 2003 R2, Datacenter Edition

  • Windows Server 2003, Enterprise Edition

  • Windows Server 2003, Datacenter Edition

I server che eseguono i sistemi operativi seguenti possono ospitare più spazi dei nomi basati su dominio oltre a un singolo spazio dei nomi autonomo:

  • Windows Server 2008 R2 Standard

  • Windows Server 2008 Standard

  • Windows Server 2003 R2, Standard Edition con Service Pack 2 o versioni successive

  • Windows Server 2003, Standard Edition con Service Pack 2 o versioni successive

I server che eseguono i sistemi operativi seguenti possono ospitare solo un singolo spazio dei nomi di qualsiasi tipo:

  • Windows Server 2003 R2, Standard Edition

  • Windows Server 2003, Standard Edition

  • Qualsiasi versione di Windows 2000 Server

Nota

Windows Server 2003, Web Edition non può ospitare spazi dei nomi. Può essere configurato come destinazione di cartella, ma non sono consentite più di 10 connessioni SMB (Server Message Block) in ingresso simultanee.

Nella tabella seguente vengono descritti gli ulteriori fattori da considerare nella scelta dei server in cui ospitare uno spazio dei nomi.

Indicazioni relative ai server che ospitano spazi dei nomi

Server che ospitano spazi dei nomi autonomi Server che ospitano spazi dei nomi basati su dominio
  • Solo i server che eseguono Windows Server 2008 supportano l'enumerazione basata sull'accesso per spazi dei nomi autonomi o basati su dominio (modalità Windows Server 2008).

  • Devono contenere un volume NTFS in cui ospitare lo spazio dei nomi.

  • Possono essere server membri o controller di dominio.

  • Possono essere ospitati da un cluster di failover per garantire una maggior disponibilità dello spazio dei nomi.
  • Solo i server che eseguono Windows Server 2008 possono ospitare spazi dei nomi basati su dominio in modalità Windows Server 2008.

  • Devono contenere un volume NTFS in cui ospitare lo spazio dei nomi.

  • Devono essere server membri o controller di dominio nel dominio in cui viene configurato lo spazio dei nomi. Questo requisito si applica a ogni server che ospita uno spazio dei nomi basato su dominio.

  • Possono utilizzare più server dello spazio dei nomi per garantire una maggior disponibilità dello spazio dei nomi.

  • Lo spazio dei nomi non può essere una risorsa di cluster in un cluster di failover. È tuttavia possibile ospitare lo spazio dei nomi in un server utilizzato anche come nodo in un cluster di failover se configurato in modo da utilizzare solo le risorse locali disponibili nel server in cui si trova.

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Scegliere un tipo di spazio dei nomi


Scegliere un tipo di spazio dei nomi

Quando si crea uno spazio dei nomi, è necessario scegliere uno dei due tipi disponibili, ovvero spazio dei nomi autonomo oppure basato su dominio. Se inoltre si sceglie uno spazio dei nomi basato su dominio, sarà necessario scegliere una modalità, tra Windows 2000 Server e Windows Server 2008.

Scegliere un tipo di spazio dei nomi

Scegliere uno spazio dei nomi autonomo se all'ambiente si applica una qualsiasi delle condizioni seguenti:

  • Nell'organizzazione non viene utilizzato Servizi di dominio Active Directory.

  • Si desidera garantire una maggior disponibilità dello spazio dei nomi utilizzando un cluster di failover.

  • È necessario creare un singolo spazio dei nomi contenente più di 5.000 cartelle DFS in un dominio non conforme ai requisiti di uno spazio dei nomi basato su dominio (modalità Windows Server 2008), come descritto più avanti in questo argomento.

    Nota

    Per verificare le dimensioni di uno spazio dei nomi, fare clic con il pulsante destro del mouse sullo spazio dei nomi nell'albero della console Gestione DFS, scegliere Proprietà e quindi visualizzare le dimensioni nella finestra di dialogo relativa alle proprietà dello spazio dei nomi. Per ulteriori informazioni sulla scalabilità dello spazio dei nomi DFS, visitare il sito Web Microsoft (http://go.microsoft.com/fwlink/?LinkId=92838).

Scegliere uno spazio dei nomi basato su dominio se all'ambiente si applica una qualsiasi delle condizioni seguenti:

  • Si desidera garantire la disponibilità dello spazio dei nomi utilizzando più server dello spazio dei nomi.

  • Si desidera evitare che il nome del server dello spazio dei nomi sia visibile agli utenti. In tal modo sarà più semplice sostituire il server dello spazio dei nomi o eseguire la migrazione dello spazio dei nomi su un altro server.

Scegliere una modalità per lo spazio dei nomi basato su dominio

Se si sceglie uno spazio dei nomi basato su dominio, è inoltre necessario scegliere se utilizzare la modalità Windows 2000 Server o Windows Server 2008. La modalità Windows Server 2008 include il supporto per l'enumerazione basata sull'accesso e una maggior scalabilità. Allo spazio dei nomi basato su dominio introdotto in Windows 2000 Server viene ora fatto riferimento come "spazio dei nomi basato su dominio (modalità Windows 2000 Server)."

Per utilizzare la modalità Windows Server 2008, il dominio e lo spazio dei nomi devono soddisfare i requisiti minimi seguenti:

  • La foresta deve utilizzare il livello di funzionalità della foresta Windows Server 2003 o superiore.

  • Il dominio deve utilizzare il livello di funzionalità Windows Server 2008.

  • In tutti i server dello spazio dei nomi deve essere in esecuzione Windows Server 2008.

Se supportata dall'ambiente, scegliere la modalità Windows Server 2008 quando si creano nuovi spazi dei nomi basati su dominio. Tale modalità consente di disporre di ulteriori funzionalità, nonché di una maggior scalabilità, eliminando inoltre la necessità di eseguire la migrazione di uno spazio dei nomi dalla modalità Windows 2000 Server.

Per informazioni sulla migrazione di uno spazio dei nomi alla modalità Windows Server 2008, vedere Eseguire la migrazione di uno spazio dei nomi basato su dominio alla modalità Windows Server 2008.

Se l'ambiente non supporta gli spazi dei nomi basati su dominio in modalità Windows Server 2008, utilizzare la modalità Windows 2000 Server esistente per lo spazio dei nomi.

Confrontare tipi e modalità di spazio dei nomi

Nella tabella seguente vengono descritte le caratteristiche di ogni tipo e modalità di spazio dei nomi.

Caratteristica | Spazio dei nomi autonomo | Spazio dei nomi basato su dominio (modalità Windows 2000 Server) | Spazio dei nomi basato su dominio (modalità Windows Server 2008)
Percorso dello spazio dei nomi | \\NomeServer\NomeDirRadice | \\NomeDominioNetBIOS\NomeDirRadice \\NomeDominioDNS\NomeDirRadice | \\NomeDominioNetBIOS\NomeDirRadice \\NomeDominioDNS\NomeDirRadice
Percorso di archiviazione delle informazioni sullo spazio dei nomi | Nel Registro di sistema e in una cache in memoria nel server dello spazio dei nomi | In Servizi di dominio Active Directory e in una cache in memoria in ogni server dello spazio dei nomi | In Servizi di dominio Active Directory e in una cache in memoria in ogni server dello spazio dei nomi
Dimensioni consigliate per lo spazio dei nomi | Lo spazio dei nomi può contenere più di 5.000 cartelle con destinazioni | Le dimensioni dell'oggetto spazio dei nomi in Servizi di dominio Active Directory devono essere inferiori a 5 MB per garantire la compatibilità con controller di dominio che non eseguono Windows Server 2008. Ciò equivale a non più di circa 5.000 cartelle con destinazioni. | Lo spazio dei nomi può contenere più di 5.000 cartelle con destinazioni
Livello minimo di funzionalità della foresta di Servizi di dominio Active Directory | Servizi di dominio Active Directory non necessario | Windows 2000 | Windows Server 2003
Livello minimo di funzionalità del dominio di Servizi di dominio Active Directory | Servizi di dominio Active Directory non necessario | Windows 2000 in modalità mista | Windows Server 2008
Numero minimo di server dello spazio dei nomi supportati | Windows 2000 Server | Windows 2000 Server | Windows Server 2008
Supporto per enumerazione basata sull'accesso (se abilitata) | Sì. È necessario il server dello spazio dei nomi Windows Server 2008 | No | Sì
Metodi supportati per garantire la disponibilità dello spazio dei nomi | Creare uno spazio dei nomi autonomo in un cluster di failover. | Ospitare lo spazio dei nomi in più server dello spazio dei nomi. I server dello spazio dei nomi devono appartenere allo stesso dominio. | Ospitare lo spazio dei nomi in più server dello spazio dei nomi. I server dello spazio dei nomi devono appartenere allo stesso dominio.
Supporto dell'utilizzo di Replica DFS per la replica di destinazioni cartella | Supportato se fa parte del dominio di Servizi di dominio Active Directory | Supportato | Supportato

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Eseguire la migrazione di uno spazio dei nomi basato su dominio alla modalità Windows Server 2008


Creare uno spazio dei nomi DFS

È possibile creare un nuovo spazio dei nomi quando si installa il servizio ruolo Spazi dei nomi utilizzando l'Aggiunta guidata ruoli o la procedura guidata Aggiunta servizi ruolo di Server Manager. È inoltre possibile utilizzare la procedura seguente per creare uno spazio dei nomi dopo l'installazione del servizio ruolo.

Per creare uno spazio dei nomi

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul nodo Spazi dei nomi e quindi scegliere Nuovo spazio dei nomi.

  3. Seguire le istruzioni della Creazione guidata nuovo spazio dei nomi.

    Per creare uno spazio dei nomi autonomo in un cluster di failover, specificare il nome di un'istanza del file server in cluster nella pagina Server dello spazio dei nomi della Creazione guidata nuovo spazio dei nomi.

    Importante

    Non tentare di creare uno spazio dei nomi basato su dominio utilizzando la modalità Windows Server 2008, a meno che il livello di funzionalità della foresta non sia Windows Server 2003 o superiore. In caso contrario, è possibile che venga creato uno spazio dei nomi che non consente di eliminare le cartelle DFS e che venga generato il messaggio di errore seguente: "Impossibile eliminare la cartella. Impossibile completare la funzione".

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Scegliere un tipo di spazio dei nomi

  • Aggiungere server dello spazio dei nomi a uno spazio dei nomi DFS basato su dominio

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Eseguire la migrazione di uno spazio dei nomi basato su dominio alla modalità Windows Server 2008

La modalità Windows Server 2008 per gli spazi dei nomi basati su dominio include il supporto per l'enumerazione basata sull'accesso e una maggiore scalabilità.

Per eseguire la migrazione di uno spazio dei nomi basato su dominio dalla modalità Windows 2000 Server alla modalità Windows Server 2008, è necessario esportare lo spazio dei nomi in un file, eliminare lo spazio dei nomi, ricrearlo in modalità Windows Server 2008 e quindi importarne le impostazioni. A tale scopo, eseguire la procedura seguente.

Per eseguire la migrazione di uno spazio dei nomi basato su dominio alla modalità Windows Server 2008

  1. Aprire una finestra del prompt dei comandi e digitare il comando seguente per esportare lo spazio dei nomi in un file, dove \\dominio\spaziodeinomi è il nome del dominio e dello spazio dei nomi appropriati e percorso\nomefile è il percorso e il nome del file di esportazione:

    Dfsutil root export \\dominio\spaziodeinomi percorso\nomefile.xml

  2. Annotare il percorso (\\server\condivisione) di ogni server dello spazio dei nomi. I server dello spazio dei nomi devono essere aggiunti manualmente allo spazio dei nomi ricreato perché non possono essere importati da Dfsutil.

  3. In Gestione DFS fare clic con il pulsante destro del mouse sullo spazio dei nomi e quindi scegliere Elimina, oppure al prompt dei comandi digitare il comando seguente, dove \\dominio\spaziodeinomi è il nome del dominio e dello spazio dei nomi appropriato:

    Dfsutil root remove \\dominio\spaziodeinomi

  4. In Gestione DFS ricreare lo spazio dei nomi specificando lo stesso nome, ma utilizzare la modalità Windows Server 2008, oppure al prompt dei comandi digitare il comando seguente, dove \\server\spaziodeinomi è il nome del server e della condivisione appropriati per la radice dello spazio dei nomi:

    Dfsutil root adddom \\server\spaziodeinomi v2

  5. Per importare lo spazio dei nomi dal file di esportazione, al prompt dei comandi digitare il comando seguente, dove \\dominio\spaziodeinomi è il nome del dominio e dello spazio dei nomi appropriato e percorso\nomefile è il percorso e il nome del file di esportazione:

    Dfsutil root import merge percorso\nomefile.xml \\dominio\spaziodeinomi
    Nota

    Per ridurre al minimo il tempo necessario per importare uno spazio dei nomi esteso, eseguire il comando Dfsutil root import in modalità locale in un server dello spazio dei nomi.

  6. Aggiungere gli eventuali server dello spazio dei nomi restanti allo spazio dei nomi ricreato facendo clic con il pulsante destro del mouse sullo spazio dei nomi in Gestione DFS e quindi scegliendo Aggiungi server dello spazio dei nomi oppure digitando il comando seguente al prompt dei comandi, dove \\server\condivisione è il nome del server e della condivisione appropriati per la radice dello spazio dei nomi:

    Dfsutil target add \\server\condivisione
    Nota

    È possibile aggiungere server dello spazio dei nomi prima di importare lo spazio dei nomi, ma in questo modo i server dello spazio dei nomi scaricheranno in modo incrementale i metadati dello spazio dei nomi anziché scaricare immediatamente l'intero spazio dei nomi dopo l'aggiunta come server dello spazio dei nomi.

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Scegliere un tipo di spazio dei nomi


Aggiungere server dello spazio dei nomi a uno spazio dei nomi DFS basato su dominio

È possibile aumentare la disponibilità di uno spazio dei nomi basato su dominio specificando altri server in cui ospitarlo.

Per aggiungere un server dello spazio dei nomi a uno spazio dei nomi basato su dominio

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su uno spazio dei nomi basato su dominio nel nodo Spazi dei nomi e quindi scegliere Aggiungi server dello spazio dei nomi.

  3. Digitare il percorso di un altro server o fare clic su Sfoglia per selezionarlo.
Nota

Questa procedura non è applicabile agli spazi dei nomi autonomi poiché questi ultimi supportano solo un unico server. Per aumentare la disponibilità di uno spazio dei nomi autonomo, specificare un cluster di failover come server dello spazio dei nomi nella Creazione guidata nuovo spazio dei nomi.

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Esaminare i requisiti del server di Spazi dei nomi DFS

  • Creare uno spazio dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Creare una cartella in uno spazio dei nomi DFS

È possibile utilizzare le cartelle per creare ulteriori livelli di gerarchia in uno spazio dei nomi. È inoltre possibile creare cartelle con destinazioni cartella per aggiungere cartelle condivise allo spazio dei nomi. Le cartelle DFS con destinazioni cartella non possono contenere altre cartelle DFS, pertanto se si desidera aggiungere un livello di gerarchia allo spazio dei nomi, non aggiungere destinazioni cartella alla cartella. Eseguire la procedura seguente per creare una cartella in uno spazio dei nomi.

Per creare una cartella in uno spazio dei nomi

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su uno spazio dei nomi o una cartella in uno spazio dei nomi nel nodo Spazi dei nomi e quindi scegliere Nuova cartella.

  3. Digitare il nome della nuova cartella nella casella di testo Nome.

  4. Per aggiungere una o più destinazioni cartella alla cartella, fare clic su Aggiungi, specificare il percorso UNC (Universal Naming Convention) della destinazione cartella e quindi fare clic su OK.

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Aggiungere destinazioni cartella

Per destinazione cartella si intende il percorso UNC (Universal Naming Convention) di una cartella condivisa o di un altro spazio dei nomi associato a una cartella inclusa in uno spazio dei nomi. L'aggiunta di più destinazioni cartella consente di aumentare la disponibilità della cartella nello spazio dei nomi.

Per aggiungere una destinazione cartella

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su una cartella nel nodo Spazi dei nomi e quindi scegliere Aggiungi destinazione cartella.

  3. Digitare il percorso della destinazione cartella o fare clic su Sfoglia per selezionarlo.

  4. Se la cartella è replicata mediante Replica DFS, è possibile specificare se aggiungere la nuova destinazione cartella al gruppo di replica.
Nota

Le cartelle possono contenere destinazioni cartella o altre cartelle DFS, ma non entrambi, nello stesso livello della gerarchia di cartelle.

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS

  • Replicare destinazioni cartella mediante Replica DFS


Replicare destinazioni cartella mediante Replica DFS

È possibile utilizzare Replica DFS per mantenere sincronizzati i contenuti delle destinazioni cartella in modo che gli utenti possano visualizzare gli stessi file indipendentemente dalla destinazione cartella a cui viene indirizzato il computer client.

Per replicare destinazioni cartella mediante Replica DFS

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su una cartella con due o più destinazioni cartella nel nodo Spazi dei nomi e quindi scegliere Replica cartella.

  3. Seguire le istruzioni della Replica guidata cartella.

Nota

Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

Ulteriori riferimenti

  • Distribuire Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS

  • Replica


Delegare le autorizzazioni di gestione per Spazi dei nomi DFS

Nella tabella seguente vengono descritti i gruppi che per impostazione predefinita possono eseguire operazioni di base relative agli spazi dei nomi, nonché il metodo per delegare la possibilità di eseguire tali operazioni.

Attività | Gruppi in grado di eseguire l'attività per impostazione predefinita | Metodo di delega
Creare uno spazio dei nomi basato su dominio | Gruppo Domain Admins del dominio in cui è configurato lo spazio dei nomi | Fare clic con il pulsante destro del mouse sul nodo Spazi dei nomi nell'albero della console e quindi scegliere Delega autorizzazioni di gestione. È inoltre necessario aggiungere l'utente al gruppo Administrators locale del server dello spazio dei nomi.
Aggiungere un server dello spazio dei nomi a uno spazio dei nomi basato su dominio | Gruppo Domain Admins del dominio in cui è configurato lo spazio dei nomi | Fare clic con il pulsante destro del mouse sullo spazio dei nomi basato su dominio nell'albero della console e quindi scegliere Delega autorizzazioni di gestione. È inoltre necessario aggiungere l'utente al gruppo Administrators locale del server dello spazio dei nomi da aggiungere.
Gestire uno spazio dei nomi basato su dominio | Gruppo Administrators locale di ogni server dello spazio dei nomi | Fare clic con il pulsante destro del mouse sullo spazio dei nomi basato su dominio nell'albero della console e quindi scegliere Delega autorizzazioni di gestione.
Creare uno spazio dei nomi autonomo | Gruppo Administrators locale del server dello spazio dei nomi | Aggiungere l'utente al gruppo Administrators locale del server dello spazio dei nomi.
Gestire uno spazio dei nomi autonomo* | Gruppo Administrators locale del server dello spazio dei nomi | Fare clic con il pulsante destro del mouse sullo spazio dei nomi autonomo nell'albero della console e quindi scegliere Delega autorizzazioni di gestione.
Creare un gruppo di replica o abilitare Replica DFS in una cartella | Gruppo Domain Admins del dominio in cui è configurato lo spazio dei nomi | Fare clic con il pulsante destro del mouse sul nodo Replica nell'albero della console e quindi scegliere Delega autorizzazioni di gestione.

* La delega delle autorizzazioni di gestione per gestire uno spazio dei nomi autonomo non concede all'utente la possibilità di visualizzare e gestire la sicurezza tramite la scheda Delega, a meno che l'utente non appartenga al gruppo Administrators locale nel server dello spazio dei nomi, poiché lo snap-in Gestione DFS non è in grado di recuperare gli elenchi di controllo di accesso discrezionale (DACL) per lo spazio dei nomi autonomo dal Registro di sistema. Per abilitare la visualizzazione delle informazioni relative alla delega nello snap-in, è necessario eseguire la procedura descritta nell'articolo 314837 della Microsoft Knowledge Base (http://go.microsoft.com/fwlink?linkid=46803).


Ottimizzare Spazi dei nomi DFS

Dopo aver creato uno spazio dei nomi e aver aggiunto cartelle e destinazioni, fare riferimento alle sezioni seguenti per ottimizzare il modo in cui Spazi dei nomi DFS gestisce i riferimenti ed esegue il polling a Servizi di dominio Active Directory per ottenere dati aggiornati sullo spazio dei nomi:

  • Attivare l'enumerazione basata sull'accesso in uno spazio dei nomi

  • Attivare o disattivare i riferimenti e il failback dei client

  • Modificare l'intervallo di tempo di memorizzazione nella cache dei riferimenti da parte dei client

  • Impostare il metodo di ordinamento delle destinazioni nei riferimenti

  • Impostare la priorità della destinazione per ignorare l'ordinamento dei riferimenti

  • Ottimizzare il polling dello spazio dei nomi

  • Utilizzare autorizzazioni ereditate con enumerazione basata sull'accesso

Nota

Per cercare cartelle o destinazioni cartella, selezionare uno spazio dei nomi, fare clic sulla scheda Cerca, digitare la stringa di ricerca nella casella di testo e quindi fare clic su Cerca.


Attivare l'enumerazione basata sull'accesso in uno spazio dei nomi

L'enumerazione basata sull'accesso nasconde i file e le cartelle per cui gli utenti non dispongono di autorizzazioni di accesso. Per impostazione predefinita, questa funzionalità è disattivata per gli spazi dei nomi DFS. È possibile attivare l'enumerazione basata sull'accesso delle cartelle DFS tramite Gestione DFS. Per controllare l'enumerazione basata sull'accesso di file e cartelle nelle destinazioni cartella, è necessario attivare l'enumerazione basata sull'accesso per ogni cartella condivisa mediante Gestione condivisione e archiviazione.

Per attivare l'enumerazione basata sull'accesso in uno spazio dei nomi, è necessario che tutti i server dello spazio de nomi eseguano Windows Server 2008 o versioni successive. Negli spazi dei nomi basati su dominio inoltre deve essere attiva la modalità Windows Server 2008. Per informazioni sui requisiti per la modalità Windows Server 2008, vedere Scegliere un tipo di spazio dei nomi.

In alcuni ambienti l'attivazione dell'enumerazione basata sull'accesso può comportare un utilizzo elevato della CPU nel server con un conseguente rallentamento dei tempi di risposta per gli utenti. Per ulteriori informazioni, visitare il sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140356.

Nota

Se si esegue l'aggiornamento del livello di funzionalità del dominio a Windows Server 2008 in presenza di spazi dei nomi basati su dominio, Gestione DFS consentirà di attivare l'enumerazione basata sull'accesso in tali spazi dei nomi. Non sarà possibile tuttavia modificare le autorizzazioni per nascondere le cartelle a gruppi o utenti a meno che non si esegua la migrazione degli spazi dei nomi alla modalità Windows Server 2008. Per ulteriori informazioni, vedere Eseguire la migrazione di uno spazio dei nomi basato su dominio alla modalità Windows Server 2008.

Per utilizzare l'enumerazione basata sull'accesso con Spazi dei nomi DFS per definire i gruppi o gli utenti che possono visualizzare determinate cartelle DFS, è necessario eseguire la procedura seguente.

  • Attivare l'enumerazione basata sull'accesso in uno spazio dei nomi

  • Definire gli utenti e i gruppi che possono visualizzare singole cartelle DFS

Attenzione

L'enumerazione basata sull'accesso non impedisce agli utenti di ottenere un riferimento a una destinazione di cartella se conoscono già il percorso DFS. Solo le autorizzazioni di condivisione o le autorizzazioni del file system NTFS della destinazione di cartella (cartella condivisa) stessa possono impedire agli utenti di accedere a una destinazione di cartella. Le autorizzazioni per le cartelle DFS vengono utilizzate solo per visualizzare o nascondere le cartelle DFS e non per controllarne l'accesso, rendendo in tal modo l'accesso in lettura la sola autorizzazione rilevante a livello della cartella DFS. Per ulteriori informazioni, vedere Utilizzare autorizzazioni ereditate con enumerazione basata sull'accesso.

Attivare l'enumerazione basata sull'accesso in uno spazio dei nomi

  • Tramite l'interfaccia di Windows

  • Tramite riga di comando
Per attivare l'enumerazione basata sull'accesso tramite l'interfaccia di Windows

  1. Nell'albero della console fare clic con il pulsante destro del mouse sullo spazio dei nomi appropriato nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  2. Fare clic sulla scheda Avanzate e quindi selezionare la casella di controllo Abilita enumerazione basata sull'accesso per questo spazio dei nomi.

Per attivare l'enumerazione basata sull'accesso tramite riga di comando

  1. Aprire una finestra del prompt dei comandi in un server in cui è installato il servizio ruolo File system distribuito o la funzionalità Strumenti per File system distribuito (DFS).

  2. Digitare il comando seguente, dove <namespace_root> è la radice dello spazio dei nomi:

    dfsutil property abe enable \\<namespace_root>

Definire gli utenti e i gruppi che possono visualizzare singole cartelle DFS

  • Tramite l'interfaccia di Windows

  • Tramite riga di comando
Per definire la visibilità di una cartella tramite l'interfaccia di Windows

  1. Nell'albero della console individuare al di sotto del nodo Spazi dei nomi la cartella con destinazioni di cui si desidera controllare la visibilità, fare clic su di essa con il pulsante destro del mouse e quindi scegliere Proprietà.

  2. Fare clic sulla scheda Avanzate.

  3. Fare clic su Imposta autorizzazioni di visualizzazione esplicite per la cartella DFS e quindi su Configura autorizzazioni visualizzazione.

  4. Aggiungere o rimuovere gruppi o utenti facendo clic su Aggiungi o Rimuovi.

  5. Per consentire agli utenti di visualizzare la cartella DFS, selezionare il gruppo o l'utente e quindi selezionare la casella di controllo Consenti.

    Per nascondere la cartella a un gruppo o a un utente, selezionarlo e quindi selezionare la casella di controllo Nega.

Per definire la visibilità di una cartella tramite riga di comando

  1. Aprire una finestra del prompt dei comandi in un server in cui è installato il servizio ruolo File system distribuito o la funzionalità Strumenti per File system distribuito (DFS).

  2. Digitare il comando seguente, dove <DFSPath> è il percorso della cartella DFS (collegamento), <DOMAIN\Account> è il nome dell'account di gruppo o utente e (…) viene sostituito con ulteriori voci di controllo di accesso:

    dfsutil property sd grant <DFSPath> DOMAIN\Account:R (…) Protect Replace

    Per sostituire ad esempio le autorizzazioni esistenti con autorizzazioni che consentono ai gruppi Domain Admins e CONTOSO\Trainers l'accesso in lettura (R) alla cartella \\contoso.office\public\training, digitare il comando seguente:

    dfsutil property sd grant \\contoso.office\public\training ”CONTOSO\Domain Admins”:R CONTOSO\Trainers:R Protect Replace

  3. Per eseguire ulteriori attività dal prompt dei comandi, utilizzare i comandi seguenti:

    Comando Descrizione

    Dfsutil property sd deny

    Nega a un gruppo o a un utente la possibilità di visualizzare la cartella.

    Dfsutil property sd reset

    Rimuove tutte le autorizzazioni dalla cartella.

    Dfsutil property sd revoke

    Rimuove dalla cartella la voce di controllo di accesso di un gruppo o di un utente.

Ulteriori riferimenti

  • Creare uno spazio dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS

  • Installare DFS

  • Utilizzare autorizzazioni ereditate con enumerazione basata sull'accesso


Attivare o disattivare i riferimenti e il failback dei client

Un riferimento è un elenco ordinato di server che un computer client riceve da un controller di dominio o un server dello spazio dei nomi quando l'utente accede a una radice dello spazio dei nomi o una cartella DFS con destinazioni. Dopo aver ricevuto il riferimento, il computer tenta di accedere al primo server dell'elenco. Se il server non è disponibile, il computer client tenta di accedere al server successivo. Se un server non è più disponibile, è possibile configurare i client in modo che eseguano il failback sul server preferito nel momento in cui diventa disponibile.

Nelle sezioni seguenti vengono fornite informazioni su come abilitare o disabilitare i riferimenti oppure abilitare il failback dei client.

Abilitare o disabilitare i riferimenti

Disattivando il riferimento di un server dello spazio dei nomi o di una destinazione di cartella, è possibile evitare che gli utenti vengano reindirizzati a tale server dello spazio dei nomi o destinazione di cartella. Tale accorgimento risulta utile se è necessario disconnettere temporaneamente un server per eseguire interventi di manutenzione.

Per attivare o disattivare riferimenti

  • Per attivare o disattivare riferimenti a una destinazione di cartella, eseguire la procedura seguente:

    1. Nell'albero della console Gestione DFS fare clic su una cartella con destinazioni nel nodo Spazi dei nomi e quindi sulla scheda Destinazioni cartella nel riquadro dei dettagli.

    2. Fare clic con il pulsante destro del mouse sulla destinazione di cartella e quindi scegliere Disabilita destinazione cartella o Abilita destinazione cartella.

  • Per attivare o disattivare riferimenti a un server dello spazio dei nomi, eseguire la procedura seguente:

    1. Nell'albero della console Gestione DFS selezionare lo spazio dei nomi appropriato e quindi fare clic sulla scheda Server dello spazio dei nomi.

    2. Fare clic con il pulsante destro del mouse sul server dello spazio dei nomi appropriato e quindi scegliere Disabilita server dello spazio dei nomi o Abilita server dello spazio dei nomi.

Abilitare il failback dei client

Se una destinazione non è più disponibile, è possibile configurare i client in modo che eseguano il failback sulla destinazione dopo che quest'ultima viene ripristinata. Per il corretto funzionamento del failback è necessario che i computer client soddisfino i requisiti elencati nell'argomento seguente: Esaminare i requisiti del client di Spazi dei nomi DFS.

Per abilitare il failback dei client per la directory radice di uno spazio dei nomi

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su uno spazio dei nomi nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  3. Nella scheda Riferimenti selezionare la casella di controllo Failback dei client sulle destinazioni preferite.

Le cartelle con destinazioni ereditano le impostazioni relative al failback dei client dalla directory radice dello spazio dei nomi. Se il failback dei client è disabilitato sulla directory radice dello spazio dei nomi, è possibile eseguire la procedura seguente per abilitarlo su una cartella con destinazioni.

Per abilitare il failback dei client per una cartella con destinazioni

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su una cartella con destinazioni nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  3. Nella scheda Riferimenti selezionare la casella di controllo Failback dei client sulle destinazioni preferite.

Ulteriori riferimenti

  • Ottimizzare Spazi dei nomi DFS

  • Esaminare i requisiti del client di Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Modificare l'intervallo di tempo di memorizzazione nella cache dei riferimenti da parte dei client

Un riferimento è un elenco ordinato di destinazioni che un computer client riceve da un controller di dominio o un server dello spazio dei nomi quando l'utente accede a una directory radice dello spazio dei nomi o una cartella con destinazioni nello spazio dei nomi. È possibile modificare l'intervallo di tempo di memorizzazione nella cache di un riferimento da parte dei client prima che questi ultimi ne richiedano uno nuovo.

Per modificare l'intervallo di tempo di memorizzazione nella cache dei riferimenti a directory radice dello spazio dei nomi da parte dei client

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su uno spazio dei nomi nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  3. Nella scheda Riferimenti digitare nella casella di testo Durata cache (in secondi) il tempo di memorizzazione nella cache (in secondi) dei riferimenti a directory radice dello spazio dei nomi. L'impostazione predefinita corrisponde a 300 secondi (cinque minuti).
Per modificare l'intervallo di memorizzazione nella cache dei riferimenti a cartelle da parte dei client

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su una cartella con destinazioni nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  3. Nella scheda Riferimenti digitare nella casella di testo Durata cache (in secondi) il tempo di memorizzazione nella cache (in secondi) dei riferimenti a cartelle. L'impostazione predefinita corrisponde a 1800 secondi (30 minuti).

Ulteriori riferimenti

  • Ottimizzare Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Impostare il metodo di ordinamento delle destinazioni nei riferimenti

Un riferimento è un elenco ordinato di destinazioni che un computer client riceve da un controller di dominio o un server dello spazio dei nomi quando l'utente accede a una directory radice dello spazio dei nomi o una cartella con destinazioni. Dopo aver ricevuto il riferimento, il client tenta di accedere alla prima destinazione dell'elenco. Se tale destinazione non è disponibile, tenta di accedere alla destinazione successiva.

Le destinazioni presenti nel sito del client sono sempre elencate per prime. Quelle esterne vengono elencate in base al metodo di ordinamento.

Utilizzare le sezioni seguenti per specificare l'ordine con cui le destinazioni devono essere indirizzate ai client e per comprendere i diversi metodi di ordinamento dei riferimenti a destinazioni.

Impostare il metodo di ordinamento

Eseguire la procedura seguente per impostare il metodo di ordinamento nella directory radice dello spazio dei nomi.

Per impostare il metodo di ordinamento delle destinazioni nei riferimenti alla directory radice dello spazio dei nomi

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su uno spazio dei nomi nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  3. Nella scheda Riferimenti selezionare un metodo di ordinamento.

Le cartelle con destinazioni ereditano il metodo di ordinamento dalla directory radice dello spazio dei nomi. È possibile ignorare il metodo di ordinamento eseguendo la procedura seguente.

Per impostare il metodo di ordinamento delle destinazioni nei riferimenti alle cartelle

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su una cartella con destinazioni nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  3. Nella scheda Riferimenti selezionare la casella di controllo Escludi destinazioni esterne al sito del client.

Metodo di ordinamento dei riferimenti a destinazioni

Sono disponibili i tre metodi di ordinamento descritti di seguito.

  • Ordine casuale

  • Costo minimo

  • Escludi destinazioni esterne al sito del client

Ordine casuale

Con questo metodo le destinazioni vengono ordinate come segue:

  1. Le destinazioni nello stesso sito Servizi di dominio Active Directory del client vengono elencate in ordine casuale all'inizio del riferimento.

  2. Le destinazioni esterne al sito del client sono elencate in ordine casuale.

Se non sono disponibili server di destinazione nello stesso sito, il computer client viene indirizzato a un server di destinazione casuale, indipendentemente dal costo della connessione o dalla distanza della destinazione.

Costo minimo

Con questo metodo le destinazioni vengono ordinate come segue:

  1. Le destinazioni nello stesso sito del client vengono elencate in ordine casuale all'inizio del riferimento.

  2. Successivamente vengono elencate le destinazioni esterne al sito del client, in ordine crescente di costo a partire dal costo minimo. I riferimenti con lo stesso costo vengono raggruppati e, all'interno di ogni gruppo, le destinazioni sono elencate in ordine casuale.

Nota

I costi dei collegamenti di sito non vengono visualizzati nello snap-in Gestione DFS. Per visualizzare i costi dei collegamenti di sito, utilizzare lo snap-in Siti e servizi di Active Directory.

Escludi destinazioni esterne al sito del client

Con questo metodo il riferimento contiene soltanto le destinazioni nello stesso sito del client, che vengono ordinate in ordine casuale. Se non esistono destinazioni nello stesso sito, il client non riceve un riferimento e non può accedere a tale parte dello spazio dei nomi.

Nota

Le destinazioni con priorità della destinazione impostata su "Prima tra tutte le destinazioni" o "Ultima tra tutte le destinazioni" vengono comunque elencate nel riferimento anche se il metodo di ordinamento è impostato su Escludi destinazioni esterne al sito del client.

Ulteriori riferimenti

  • Ottimizzare Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Impostare la priorità della destinazione per ignorare l'ordinamento dei riferimenti

Un riferimento è un elenco ordinato di destinazioni che un computer client riceve da un controller di dominio o un server dello spazio dei nomi quando l'utente accede a una directory radice dello spazio dei nomi o una cartella con destinazioni nello spazio dei nomi. Tutte le destinazioni in un riferimento vengono ordinate in base al metodo impostato per la cartella o la directory radice dello spazio dei nomi. Per ridefinire l'ordinamento, è possibile impostare la priorità delle singole destinazioni. È ad esempio possibile impostare una destinazione in modo che venga inserita prima o dopo tutte le altre oppure prima o dopo tutte quelle di costo uguale.

Per impostare la priorità di una destinazione directory radice di uno spazio dei nomi basato su dominio, eseguire la procedura seguente.

Per impostare la priorità di una destinazione directory radice di uno spazio dei nomi basato su dominio

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sullo spazio dei nomi basato su dominio delle destinazioni directory radice di cui si desidera impostare la priorità nel nodo Spazi dei nomi.

  3. Nella scheda Server dello spazio dei nomi del riquadro dei dettagli fare clic con il pulsante destro del mouse sulla destinazione directory radice di cui si desidera modificare la priorità e quindi scegliere Proprietà.

  4. Nella scheda Avanzate fare clic su Ignora ordinamento riferimenti e quindi selezionare la priorità desiderata.

    • Prima tra tutte le destinazioni Indica che gli utenti devono sempre fare riferimento a questa destinazione, se disponibile.

    • Ultima tra tutte le destinazioni Indica che gli utenti devono fare riferimento a questa destinazione solo nel caso in cui non sia disponibile alcuna altra destinazione.

    • Prima tra le destinazioni con uguale costo Indica che gli utenti devono fare riferimento a questa destinazione prima di altre destinazioni con costo uguale, che in genere sono altre destinazioni dello stesso sito.

    • Ultima tra le destinazioni con uguale costo Indica che gli utenti non devono mai fare riferimento a questa destinazione se sono disponibili altre destinazioni con costo uguale, che in genere sono altre destinazioni dello stesso sito.

Per impostare la priorità di una destinazione cartella, eseguire la procedura seguente.

Per impostare la priorità di una destinazione cartella

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sulla cartella delle destinazioni di cui si desidera impostare la priorità nel nodo Spazio dei nomi.

  3. Nella scheda Destinazioni cartella del riquadro dei dettagli fare clic con il pulsante destro del mouse sulla destinazione cartella di cui si desidera modificare la priorità e quindi scegliere Proprietà.

  4. Nella scheda Avanzate fare clic su Ignora ordinamento riferimenti e quindi selezionare la priorità desiderata.

Ulteriori riferimenti

  • Ottimizzare Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Ottimizzare il polling dello spazio dei nomi

Per mantenere la coerenza di uno spazio dei nomi basato su dominio tra server dello spazio dei nomi, è necessario che i server eseguano periodicamente il polling a Servizi di dominio Active Directory in modo da ottenere i dati dello spazio dei nomi più recenti. È possibile utilizzare questa procedura per ottimizzare la modalità di esecuzione del polling.

Per ottimizzare il polling dello spazio dei nomi

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su uno spazio dei nomi basato su dominio nel nodo Spazi dei nomi e quindi scegliere Proprietà.

  3. Nella scheda Avanzate scegliere se l'ottimizzazione dello spazio dei nomi deve essere eseguita ai fini della coerenza o della scalabilità.

    • Scegliere Ottimizza per la coerenza se il numero di server dello spazio dei nomi che ospitano lo spazio dei nomi è minore o uguale a 16.

    • Scegliere Ottimizza per la scalabilità se il numero di server dello spazio dei nomi maggiore di 16. In tal modo il carico sull'emulatore PDC risulterà ridotto, ma aumenterà il tempo necessario per replicare le modifiche apportate allo spazio dei nomi in tutti i server dello spazio dei nomi. Fino a quando le modifiche non vengono replicate in tutti i server, è possibile che lo spazio dei nomi visualizzato non sia coerente.

    Nota

    Anche se si attiva Ottimizza per la scalabilità nello spazio dei nomi, per impostazione predefinita i server dello spazio dei nomi che eseguono Windows 2000 Server continueranno a eseguire il polling all'emulatore PDC ogni ora.

Ulteriori riferimenti

  • Ottimizzare Spazi dei nomi DFS

  • Delegare le autorizzazioni di gestione per Spazi dei nomi DFS


Utilizzare autorizzazioni ereditate con enumerazione basata sull'accesso

Per impostazione predefinita, le autorizzazioni utilizzate per una cartella DFS vengono ereditate a partire dal file system locale del server dello spazio dei nomi. Le autorizzazioni vengono ereditate a partire dalla directory radice dell'unità di sistema e concedono autorizzazioni di lettura al gruppo DOMAIN\Users. In questo modo, anche dopo l'attivazione dell'enumerazione basata sull'accesso, tutte le cartelle dello spazio dei nomi rimarranno visibili per tutti gli utenti del dominio.

Vantaggi e limitazioni derivanti dall'utilizzo delle autorizzazioni ereditate

L'utilizzo delle autorizzazioni ereditate per specificare gli utenti che possono visualizzare le cartelle in uno spazio dei nomi DFS comporta due vantaggi principali:

  • Le autorizzazioni ereditate possono essere applicate rapidamente a molte cartelle senza dover utilizzare script.

  • È possibile applicarle a cartelle senza destinazioni e radici dello spazio dei nomi.

Nonostante questi vantaggi, in Spazi dei nomi DFS le autorizzazioni ereditate comportano numerose limitazioni che le rendono inadatte per la maggior parte degli ambienti:

  • Le modifiche apportate alle autorizzazioni ereditate non vengono replicate ad altri server dello spazio dei nomi. È consigliabile pertanto utilizzare le autorizzazioni ereditate solo in spazi dei nomi autonomi o in ambienti in cui è possibile implementare un sistema di replica di terze parti per la sincronizzazione degli elenchi di controllo di accesso (ACL, Access Control List) in tutti i server dello spazio dei nomi.

  • Gestione DFS e Dfsutil non consentono di visualizzare o modificare le autorizzazioni ereditate. È necessario pertanto utilizzare Esplora risorse o il comando Icacls insieme a Gestione DFS o a Dfsutil per gestire lo spazio dei nomi.

  • Se si utilizzano autorizzazioni ereditate, non è possibile modificare le autorizzazioni di una cartella con destinazioni, se non utilizzando il comando Dfsutil. Spazi dei nomi DFS rimuove automaticamente le autorizzazioni dalle cartelle con destinazioni impostate utilizzando altri strumenti o metodi.

  • Se si impostano autorizzazioni in una cartella con destinazioni mentre si utilizzano autorizzazioni ereditate, l'elenco ACL impostato per la cartella con destinazioni si combinerà con le autorizzazioni ereditate provenienti dall'elemento padre della cartella nel file system. Sarà necessario esaminare entrambi gli insiemi di autorizzazioni per determinare quali autorizzazioni verranno effettivamente applicate.

Suggerimento

Se si utilizzano autorizzazioni ereditate, è più semplice impostare le autorizzazioni per le cartelle senza destinazioni e le radici dello spazio dei nomi. Utilizzare quindi le autorizzazioni ereditate nelle cartelle con destinazioni in modo che ereditino tutte le autorizzazioni dai relativi elementi padre.

Utilizzare le autorizzazioni ereditate

Per limitare la visualizzazione di una cartella DFS a utenti specifici, è necessario eseguire una delle attività seguenti:

  • Impostare autorizzazioni esplicite per la cartella, disattivando l'eredità. Per impostare autorizzazioni esplicite per una cartella con destinazioni (collegamento) utilizzando Gestione DFS o il comando Dfsutil, vedere Attivare l'enumerazione basata sull'accesso in uno spazio dei nomi.

  • Modificare nell'elemento padre nel file system locale le autorizzazioni ereditate. Per modificare le autorizzazioni ereditate da una cartella con destinazioni, se sono state già impostate autorizzazioni esplicite per la cartella passare dalle autorizzazioni esplicite alle autorizzazioni ereditate, come illustrato nella procedura precedente. Utilizzare quindi Esplora risorse o il comando Icacls per modificare le autorizzazioni della cartella dalla quale la cartella con destinazioni eredita le autorizzazioni, come descritto nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140259.

Nota

L'enumerazione basata sull'accesso non impedisce agli utenti di ottenere un riferimento a una destinazione di cartella se conoscono già il percorso DFS della cartella con destinazioni. Le autorizzazioni impostate utilizzando Esplora risorse o il comando Icacls nelle cartelle senza destinazioni o nelle radici dello spazio dei nomi controllano se gli utenti possono accedere alla cartella DFS o alla radice dello spazio dei nomi. Non impediscono tuttavia agli utenti di accedere direttamente a una cartella con destinazioni. Solo le autorizzazioni di condivisione o le autorizzazioni del file system NTFS della cartella condivisa stessa possono impedire agli utenti di accedere alle destinazioni delle cartelle.

Per passare da autorizzazioni esplicite ad autorizzazioni ereditate

  1. Nell'albero della console individuare al di sotto del nodo Spazi dei nomi la cartella con destinazioni di cui si desidera controllare la visibilità, fare clic su di essa con il pulsante destro del mouse e quindi scegliere Proprietà.

  2. Fare clic sulla scheda Avanzate.

  3. Fare clic su Usa autorizzazioni ereditate dal file system locale e quindi su OK nella finestra di dialogo Conferma utilizzo di autorizzazioni ereditate.

    In questo modo verranno rimosse tutte le autorizzazioni impostate in modo esplicito per la cartella e verranno ripristinate le autorizzazioni NTFS ereditate a partire dal file system locale del server dello spazio dei nomi.

  4. Per modificare le autorizzazioni ereditate per cartelle o radici dello spazio dei nomi in uno spazio dei nomi DFS, utilizzare Esplora risorse o il comando ICacls, come descritto nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140259.

Per modificare la modalità di applicazione delle autorizzazioni tramite prompt dei comandi oppure ripristinare l'eredità delle autorizzazioni NTFS dal file system locale e mantenere le autorizzazioni impostate utilizzando Gestione DFS, visitare il sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140259.

Ulteriori riferimenti

  • Creare uno spazio dei nomi DFS


Replica

Replica DFS è un motore di replica multimaster in grado di replicare dati tra più server attraverso connessioni di rete con larghezza di banda limitata. Negli argomenti seguenti vengono fornite informazioni sull'utilizzo di Replica DFS:

  • Panoramica di Replica DFS

  • Panoramica di FRS

  • Elenco di controllo: distribuire Replica DFS

  • Elenco di controllo: gestire Replica DFS

  • Distribuire Replica DFS

  • Gestire Replica DFS

  • Risolvere i problemi relativi a Replica DFS

Nota

Per eseguire la maggior parte delle attività, è necessario essere membri del gruppo Domain Admins in Servizi di dominio Active Directory, a meno che non si disponga della delega per gestire Replica DFS. Per gestire un server remoto, potrebbe inoltre essere necessario essere membri del gruppo Administrators locale del server che si desidera gestire. L'autore del gruppo di replica può eseguire la maggior parte delle procedure correlate a tale gruppo. Per ulteriori informazioni, vedere Delegare la possibilità di gestire Replica DFS.

Ulteriori riferimenti

  • Guida alla migrazione della replica SYSVOL: da Replica file a Replica DFS

    (http://go.microsoft.com/fwlink/?LinkId=139749)


Panoramica di Replica DFS

Replica DFS è un motore di replica multimaster efficace utilizzabile per mantenere sincronizzate le cartelle tra più server attraverso connessioni di rete con larghezza di banda limitata. Sostituisce il servizio Replica file come motore di replica di Spazi dei nomi DFS, nonché per la replica della cartella SYSVOL di Servizi di dominio Active Directory in domini che utilizzano il livello di funzionalità di dominio Windows Server 2008. Per ulteriori informazioni sulla replica di SYSVOL con Replica DFS, visitare il sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139749.

Replica DFS utilizza un algoritmo di compressione noto come RDC (Remote Differential Compression). La tecnologia RDC è in grado di rilevare le modifiche apportate ai dati di un file e consente a Replica DFS di replicare solo i blocchi di file modificati anziché l'intero file.

Per utilizzare Replica DFS, è necessario creare gruppi di replica e aggiungere cartelle replicate ai gruppi. Nella figura seguente sono illustrati gruppi di replica, cartelle replicate e membri.

Gruppi e cartelle di Replica DFS

Come illustrato in figura, un gruppo di replica rappresenta un insieme di server, noti come membri, che partecipano alla replica di una o più cartelle replicate. Una cartella replicata è una cartella sempre sincronizzata in tutti i membri. Nella figura vengono illustrate due cartelle replicate, Projects e Proposals. Quando i dati in tali cartelle vengono modificati, le modifiche vengono replicate tramite connessioni tra i membri del gruppo di replica. Le connessioni tra tutti i membri costituiscono la topologia di replica.

La creazione di più cartelle replicate in un singolo gruppo di replica consente di semplificare il processo di distribuzione delle cartelle stesse poiché la topologia, la pianificazione e la limitazione della larghezza di banda per il gruppo vengono applicate a ogni cartelle replicata. Per distribuire altre cartelle replicate, è possibile utilizzare Dfsradmin.exe oppure attenersi alle istruzioni di una procedura guidata che consente di definire il percorso locale e le autorizzazioni relative alla nuova cartella replicata.

A ogni cartella replicata vengono assegnate impostazioni univoche, ad esempio filtri sottocartelle e file, in modo che sia possibile escludere sottocartelle e file diversi per ogni cartella replicata.

Le cartelle replicate archiviate in ogni membro possono trovarsi in volumi diversi e non è necessario che siano condivise o facciano parte di uno spazio dei nomi. Lo snap-in Gestione DFS consente tuttavia di condividere ed eventualmente pubblicare le cartelle replicate in uno spazio dei nomi esistente in modo estremamente semplice.

Per amministrare Replica DFS è possibile utilizzare Gestione DFS, i comandi DfsrAdmin e Dfsrdiag oppure script che chiamano WMI.

Ulteriori riferimenti

  • Replica

  • Gestione DFS


Panoramica di FRS

Il servizio Replica file è una tecnologia originariamente introdotta in Windows 2000 Server per replicare le cartelle DFS (Distributed File System, File system distribuito) e la cartella SYSVOL in controller di dominio. Questo servizio è stato sostituito in Windows Server 2008 R2 da Replica DFS per la replica delle cartelle DFS e della cartella SYSVOL.

Per gestire uno spazio dei nomi di File system distribuito che utilizza FRS per la replica del contenuto, aprire lo snap-in File system distribuito in un computer che esegue Windows Server 2003 o Windows 2000 Server.

Importante

In Windows Server 2008 R2 il servizio Replica file può essere utilizzato solo per replicare la cartella SYSVOL in controller di dominio di domini che utilizzano livelli di funzionalità di dominio di Windows Server 2003 o Windows 2000. Tutte le altre attività di replica precedentemente eseguite da Replica file vengono ora effettuate da Replica DFS. Le repliche di Replica file sono disattivate nei server che sono stati aggiornati a Windows Server 2008 R2. Per ulteriori informazioni, visitare il sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140224.

Ulteriori riferimenti

  • Guida alla migrazione della replica SYSVOL: da Replica file a Replica DFS

    (http://go.microsoft.com/fwlink/?LinkId=139749)

  • Documentazione tecnica su Replica file

    (all'indirizzo http://go.microsoft.com/fwlink/?LinkID=27595)

  • Replica


Elenco di controllo: distribuire Replica DFS

Per raccogliere dati a scopo di backup o di altro tipo, utilizzare la Creazione guidata nuovo gruppo di replica per configurare un gruppo di replica per la raccolta di dati. Questa opzione consente di configurare una replica bidirezionale tra due server, ad esempio un server di succursale e un server di hub. Gli amministratori della sede centrale possono utilizzare software di backup per eseguire il backup dei dati del server di succursale da un server di hub, eliminando così il processo soggetto a errori con cui gli utenti finali eseguono backup presso succursali non dotate di personale IT qualificato.

Importante

La topologia di raccolta dei dati consente la replica dei dati dal server di hub al server di succursale. Se non si desidera che le modifiche apportate al server di hub vengano replicate nel server di succursale, impostare la cartella replicata come di sola lettura nel server di hub.

Utilizzare le attività seguenti per distribuire Replica dati per la raccolta di dati o per altri scopi:

Attività | Riferimento
Esaminare i concetti relativi a Replica DFS. | Panoramica di Replica DFS
Esaminare i requisiti relativi a Replica DFS. | Esaminare i requisiti per Replica DFS
Installare la versione più recente di Gestione DFS. | Installare DFS
Creare un gruppo di replica. | Creare un gruppo di replica
Aggiungere cartelle replicate al gruppo di replica. | Aggiungere una cartella replicata a un gruppo di replica
Aggiungere server membro al gruppo di replica. | Aggiungere un membro a un gruppo di replica
Aggiungere un cluster di failover come membro di un gruppo di replica. | Aggiungere un cluster di failover a un gruppo di replica
Impostare una cartella replicata come di sola lettura. | Impostare una cartella replicata in sola lettura in un membro specifico
Creare una connessione tra server membro. | Creare una connessione
Delegare la possibilità di gestire Replica DFS. | Delegare la possibilità di gestire Replica DFS
Importante

Per visualizzare o gestire gruppi di replica contenenti cartelle replicate di sola lettura o membri che rappresentano cluster di failover, è necessario utilizzare la versione di Gestione DFS inclusa con Windows Server 2008 R2.

Ulteriori riferimenti

  • Condividere o pubblicare una cartella replicata


Elenco di controllo: gestire Replica DFS

Per gestire Replica DFS, eseguire le attività seguenti:

Attività | Riferimento
Modificare le pianificazioni della replica o imporre manualmente la replica. | Modificare le pianificazioni e la larghezza di banda di replica
Abilitare o disabilitare la replica. | Abilitare o disabilitare la replica
Abilitare o disabilitare la replica di un gruppo di replica in un membro specifico. | Abilitare o disabilitare la replica in un membro specifico
Modificare le dimensioni delle cartelle di gestione temporanea o delle cartelle dei file eliminati e con conflitti. | Modificare le dimensioni della quota della cartella di gestione temporanea e della cartella dei file eliminati e con conflitti
Controllare i tipi di file da replicare. | Modificare i filtri di replica per una cartella replicata
Condividere una cartella replicata in rete oppure aggiungere la cartella a uno spazio dei nomi DFS. | Condividere o pubblicare una cartella replicata
Modificare la topologia di un gruppo di replica. | Modificare la topologia di replica
Nota

Per visualizzare o gestire gruppi di replica contenenti cartelle replicate di sola lettura o membri che rappresentano cluster di failover, è necessario utilizzare la versione di Gestione DFS inclusa con Windows Server 2008 R2.


Distribuire Replica DFS

Negli argomenti seguenti vengono fornite informazioni sulla distribuzione di Replica DFS:

  • Esaminare i requisiti per Replica DFS

  • Creare un gruppo di replica

  • Aggiungere una cartella replicata a un gruppo di replica

  • Aggiungere un membro a un gruppo di replica

  • Aggiungere un cluster di failover a un gruppo di replica

  • Impostare una cartella replicata in sola lettura in un membro specifico

  • Creare una connessione

  • Delegare la possibilità di gestire Replica DFS


Esaminare i requisiti per Replica DFS

Per poter distribuire Replica DFS, è necessario configurare i server nel modo seguente:

  • Estendere (o aggiornare) lo schema di Servizi di dominio Active Directory in modo da includere le aggiunte agli schemi di Windows Server 2003 R2, Windows Server 2008 o Windows Server 2008 R2. Per utilizzare cartelle replicate di sola lettura, lo schema deve includere le aggiunte agli schemi di Windows Server 2008 o versione successiva. Per informazioni sull'estensione dello schema di Servizi di dominio Active Directory, vedere il sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93051.

  • Verificare che tutti i server inclusi in un gruppo di replica si trovino nella stessa foresta. Non è possibile attivare la replica tra server in foreste diverse.

  • Verificare che tutti i membri del gruppo di replica eseguano Windows Server 2008 R2, Windows Server 2008 o Windows Server 2003 R2. Il servizio Replica DFS è supportato in tutte le edizioni x64 di Windows Server 2008 R2 e in tutte le edizioni x64 e x86 di Windows Server 2008. Non è disponibile invece per Itanium-Based Systems.

  • Installare Replica DFS in tutti i server che funzioneranno come membri di un gruppo di replica.

  • Installare lo snap-in Gestione DFS in un server per la gestione della replica Tale server non può eseguire un'installazione Server Core del sistema operativo Windows Server 2008.

  • Contattare il fornitore del software antivirus per verificare la compatibilità del software antivirus con Replica DFS.

  • Archiviare le cartelle replicate in volumi NTFS.

  • Per includere un cluster di failover in un gruppo di replica, è necessario che il cluster di failover esegua Windows Server 2008 R2. Installare e configurare la funzionalità cluster di failover e quindi utilizzare la Configurazione guidata disponibilità elevata per creare un'istanza di File Server in cluster prima di aggiungere l'istanza come membro del gruppo di replica. Per ulteriori informazioni, vedere Aggiungere un cluster di failover a un gruppo di replica.

    In un server che esegue una versione di Windows precedente a Windows Server 2008 R2 individuare le cartelle replicate per i cluster di failover nello spazio di archiviazione locale di un nodo. Le versioni del servizio Replica DFS precedenti a Windows Server 2008 R2 non prevedono il coordinamento con componenti cluster e pertanto non eseguono il failover su un altro nodo.

Ulteriori riferimenti

  • Distribuire Replica DFS

  • Gestione DFS

  • Installare DFS

  • Aggiungere un cluster di failover a un gruppo di replica


Creare un gruppo di replica

Eseguire la procedura seguente per creare un gruppo di replica.

Per creare un gruppo di replica

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul nodo Replica e quindi scegliere Nuovo gruppo di replica.

  3. Seguire le istruzioni della Creazione guidata nuovo gruppo di replica.

    Prima di impostare un membro di un gruppo di replica in sola lettura, vedere le informazioni nella sezione relativa alle considerazioni sulle prestazioni in Impostare una cartella replicata in sola lettura in un membro specifico.

    Per includere un cluster di failover in un gruppo di replica, vedere Aggiungere un cluster di failover a un gruppo di replica.

Operazioni eseguite durante la replica iniziale

Durante la configurazione iniziale della replica è necessario scegliere un membro primario. Selezionare il membro contenente i file più aggiornati che si desidera replicare in tutti gli altri membri del gruppo di replica, poiché il contenuto del membro primario viene considerato "autorevole" durante la replica iniziale. Durante la replica iniziale i file del membro primario avranno pertanto sempre la precedenza nella risoluzione dei conflitti che si verificano quando i membri di destinazione dispongono di file più recenti o precedenti rispetto ai file associati nel membro primario.

I concetti illustrati di seguito consentono una migliore comprensione del processo di replica iniziale.

  • La replica iniziale non viene avviata immediatamente. Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

  • La replica iniziale viene sempre eseguita tra il membro primario e i partner di replica di destinazione del membro primario. La replica iniziale è completata dopo che un membro ha ricevuto tutti i file dal membro primario e ha completato la creazione del database. Il membro procederà quindi a replicare gli eventuali file locali non ancora contenuti nel membro primario. La replica per una nuova cartella replicata viene così avviata dal membro primario e prosegue quindi verso gli altri membri del gruppo di replica.

  • Quando si ricevono i file dal membro primario durante la replica iniziale, se un membro di destinazione contiene file non presenti nel membro primario, tali file vengono spostati nella rispettiva cartella DfsrPrivate\PreExisting. Un file identico a un file nel membro primario non viene replicato. Se la versione di un file nel membro di destinazione è diversa dalla versione del membro primario, la versione del membro di destinazione viene spostata nella cartella dei file eliminati e con conflitti ed è possibile utilizzare la tecnologia RDC (Remote Differential Compression) per scaricare soltanto i blocchi modificati. Per evitare conflitti, non apportare modifiche ai file nella cartella replicata in membri non primari finché non è stata completata la replica iniziale.

  • Per determinare se i file nel membro primario e nel membro di destinazione sono identici, i file vengono confrontati da Replica DFS mediante un algoritmo hash. Se i file sono identici, vengono trasferiti soltanto metadati minimi.

  • Dopo l'inizializzazione della cartella replicata, quando tutti i file esistenti nella cartella replicata vengono aggiunti al database di Replica DFS, la designazione di membro primario viene rimossa. Il membro viene quindi gestito come qualsiasi altro membro e i relativi file non vengono più considerati autorevoli rispetto agli altri membri in cui è stata completata la replica iniziale. Qualsiasi membro in cui è stata completata la replica iniziale viene considerato autorevole rispetto ai membri in cui la replica non è stata completata.

Ulteriori riferimenti

  • Distribuire Replica DFS

  • Creare un rapporto di diagnostica per Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Aggiungere una cartella replicata a un gruppo di replica

Eseguire la procedura seguente per creare una cartella replicata.

Per creare una cartella replicata

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su un gruppo di replica nel nodo Replica e quindi scegliere Nuove cartelle replicate.

  3. Seguire le istruzioni contenute nella Creazione guidata nuove cartelle replicate.
Nota

Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

Ulteriori riferimenti

  • Distribuire Replica DFS

  • Creare un rapporto di diagnostica per Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Aggiungere un membro a un gruppo di replica

Eseguire la procedura seguente per aggiungere un membro a un gruppo di replica.

Per aggiungere un membro a un gruppo di replica

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su un gruppo di replica nel nodo Replica e quindi scegliere Nuovo membro.

  3. Seguire le istruzioni della Creazione guidata nuovo membro.

    Prima di impostare un membro di un gruppo di replica in sola lettura, vedere le informazioni nella sezione relativa alle considerazioni sulle prestazioni in Impostare una cartella replicata in sola lettura in un membro specifico.

    Per includere un cluster di failover in un gruppo di replica, vedere Aggiungere un cluster di failover a un gruppo di replica.
Nota

Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

Ulteriori riferimenti

  • Distribuire Replica DFS

  • Creare un rapporto di diagnostica per Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Aggiungere un cluster di failover a un gruppo di replica

Replica DFS in Windows Server 2008 R2 consente ora di aggiungere un cluster di failover come membro di un gruppo di replica. Per aggiungere un cluster di failover come membro di un gruppo di replica, eseguire la procedura seguente.

Importante

Per includere un cluster di failover in un gruppo di replica, è necessario che il cluster di failover esegua Windows Server 2008 R2. Per visualizzare o gestire gruppi di replica contenenti cartelle replicate di sola lettura o membri che rappresentano cluster di failover, è necessario utilizzare la versione di Gestione DFS inclusa con Windows Server 2008 R2.

Aggiungere un cluster di failover a un gruppo di replica

  1. Installare e configurare la funzionalità Gestione cluster di failover. Per ulteriori informazioni, vedere la Guida di Gestione cluster di failover.

  2. Se nello snap-in Gestione cluster di failover non è visibile il cluster che si desidera configurare, nell'albero della console fare clic con il pulsante destro del mouse su Gestione cluster di failover, scegliere Gestisci un cluster e quindi selezionare o specificare il cluster desiderato.

  3. Fare clic su Servizi e applicazioni e quindi su Configura servizio o applicazione sul lato destro di Azioni.

  4. Seguire le istruzioni della Configurazione guidata disponibilità elevata per specificare il servizio o l'applicazione che si desidera configurare per la disponibilità elevata, insieme ai dettagli seguenti:

    • Nella pagina Selezione servizio o applicazione della Configurazione guidata disponibilità elevata fare clic su File server.

    • Nella pagina Punto di accesso client della Configurazione guidata disponibilità elevata digitare il nome dell'istanza del file server in cluster. Questo nome verrà registrato nel server DNS (Domain Name System) e in Servizi di dominio Active Directory come account computer del file server in cluster.

  5. In Gestione DFS avviare la Creazione guidata nuovo gruppo di replica o la Creazione guidata nuovo membro e quindi digitare il nome dell'istanza del file server in cluster che si desidera aggiungere al gruppo di replica. Archiviare la cartella replicata e la cartella di gestione temporanea nell'archiviazione condivisa.
Nota

Se si desidera spostare da un nodo a un altro la cartella replicata, creare una cartella condivisa per la cartella replicata o eseguire altre attività di amministrazione di cluster, utilizzare lo snap-in Gestione cluster di failover. Gestione DFS infatti non consente di eseguire direttamente queste attività in un cluster di failover.

Ulteriori riferimenti

  • Distribuire Replica DFS

  • Gestione DFS


Impostare una cartella replicata in sola lettura in un membro specifico

Una cartella replicata di sola lettura è una cartella replicata di un membro specifico in cui gli utenti non possono aggiungere o modificare file. Questa funzionalità è utile per le cartelle di sola lettura che si desidera mantenere aggiornate con uno o più server centrali, ad esempio le cartelle di installazione di software o le cartelle contenenti documenti o rapporti pubblicati. Le cartelle replicate di sola lettura vengono utilizzate inoltre da controller di dominio di sola lettura per mantenere aggiornata la cartella condivisa SYSVOL impedendo modifiche locali.

Le cartelle replicate di sola lettura possono essere aggiornate solo con contenuto di un membro di lettura-scrittura del gruppo di replica. Qualsiasi tentativo di scrivere nella cartella avrà esito negativo, inclusa l'esecuzione di un'operazione di ripristino autorevole tramite un programma di backup.

Avvertenza

Quando si imposta una cartella replicata come di sola lettura, Replica DFS sovrascrive l'eventuale contenuto del membro di sola lettura non ancora replicato in un membro di lettura-scrittura. Per questo motivo è consigliabile eseguire il backup della cartella, creare un rapporto di diagnostica di replica e controllare il backlog di replica prima di impostare come di sola lettura una cartella replicata con contenuto esistente.

Impostare come di sola lettura o scrivibile una cartella replicata

  • Tramite l'interfaccia di Windows

  • Tramite riga di comando
Per utilizzare l'interfaccia di Windows per impostare come di sola lettura o scrivibile una cartella replicata

  1. Aprire Gestione DFS e quindi selezionare il gruppo di replica appropriato nell'albero della console.

    Importante

    Per utilizzare cartelle replicate di sola lettura, lo schema deve includere le aggiunte agli schemi di Windows Server 2008 o versione successiva. Per visualizzare o gestire gruppi di replica contenenti cartelle replicate di sola lettura o membri che rappresentano cluster di failover, è necessario utilizzare la versione di Gestione DFS inclusa con Windows Server 2008 R2.

  2. Nella scheda Appartenenze fare clic con il pulsante destro del mouse sulla cartella replicata e membro e quindi scegliere Imposta come sola lettura o Imposta come lettura/scrittura.
Per utilizzare la riga di comando per impostare come di sola lettura o scrivibile una cartella replicata

  • Aprire una finestra del prompt dei comandi e quindi digitare il comando seguente. Per ripristinare la cartella di sola lettura come scrivibile, sostituire /RO:true con /RO:false:

    Dfsradmin membership set /RGName:<replication_group> /RFName:<replicated_folder> /MemName:<DOMAIN\Server>/RO:true

Considerazioni sulle prestazioni

Le cartelle replicate di sola lettura possono influire sulle prestazioni di un file server se una cartella esistente è impostata come sola lettura o se la cartella replicata è archiviata nello stesso volume del sistema operativo Windows.

  • Se si modifica lo stato di sola lettura o di lettura-scrittura di una cartella replicata, Replica DFS eseguirà una replica iniziale e ricreerà il database di Replica DFS per la cartella. Nelle cartelle replicate contenenti un numero elevato di file ciò può comportare un rallentamento della replica e un utilizzo intensivo delle risorse del sistema finché non viene completata l'operazione.

  • L'archiviazione di una cartella replicata di sola lettura nello stesso volume dell'installazione di Windows comporterà un rallentamento delle prestazioni nel volume corrispondente. Il rallentamento delle prestazioni si verificherà principalmente al caricamento del primo driver minifiltro. Se sono installati altri driver minifiltro, ad esempio un programma antivirus o di backup, l'ulteriore rallentamento delle prestazioni per l'utilizzo di una cartella replicata di sola lettura sarà minimo.

    Il driver minifiltro di Replica DFS intercetta tutte le operazioni di creazione e apertura (IRP_MJ_CREATE) per il volume in cui è presente la cartella di replica di sola lettura e quindi controlla se la destinazione è in una cartella di replica di sola lettura. Se la destinazione è in una cartella replicata di sola lettura, la richiesta viene rifiutata dal driver affinché la cartella resti di sola lettura. Il controllo di ogni operazione di creazione e apertura in un volume può influire sulle prestazioni se la cartella replicata di sola lettura è contenuta nel volume di sistema o in un altro volume per il quale si verificano frequenti richieste di creazione o apertura per molti file diversi.

Ulteriori riferimenti

  • Distribuire Replica DFS

  • Creare un rapporto di diagnostica per Replica DFS

  • IRP_MJ_CREATE

  • Panoramica di Replica DFS


Creare una connessione

Eseguire la procedura seguente per creare una connessione.

Per creare una connessione

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul gruppo di replica in cui si desidera creare una nuova connessione nel nodo Replica e quindi scegliere Nuova connessione.

  3. Specificare i membri di origine e di destinazione e la pianificazione da utilizzare per la connessione. A questo punto la replica è unidirezionale.

  4. Per creare una seconda connessione per la replica bidirezionale tra i membri di origine e di destinazione, selezionare Crea una seconda connessione nella direzione opposta. Tutti i membri devono disporre di connessioni bidirezionali.

    Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

    Avvertenza

    Microsoft non supporta connessioni unidirezionali per Replica DFS. La creazione di una connessione di replica unidirezionale può causare numerosi problemi, tra cui errori di topologia del controllo di integrità, problemi di gestione temporanea, nonché problemi relativi al database di Replica DFS. Per creare una connessione unidirezionale è invece consigliabile impostare la cartella replicata in sola lettura nel membro appropriato.

Ulteriori riferimenti

  • Distribuire Replica DFS

  • Delegare la possibilità di gestire Replica DFS

  • Impostare una cartella replicata in sola lettura in un membro specifico


Delegare la possibilità di gestire Replica DFS

Nella tabella seguente vengono descritti i gruppi autorizzati, per impostazione predefinita, a eseguire attività di Replica DFS di base e il metodo per delegare tali attività.

Per visualizzare l'elenco di delega relativo a un gruppo di replica nell'albero della console, selezionare il gruppo e quindi fare clic sulla scheda Delega nel riquadro dei dettagli.

Attività Utenti o gruppi autorizzati all'esecuzione dell'attività per impostazione predefinita Metodo di delega

Creare un gruppo di replica o abilitare Replica DFS su una cartella con destinazioni cartella.

Gruppo Domain Admins nel dominio in cui verrà creato il gruppo di replica.

Nell'albero della console fare clic con il pulsante destro del mouse sul nodo Replica e quindi scegliere Delega autorizzazioni di gestione.

Amministrare un gruppo di replica.

Gruppo Domain Admins nel dominio in cui viene configurato il gruppo di replica oppure l'autore del gruppo di replica.

Nell'albero della console fare clic con il pulsante destro del mouse sul gruppo di replica e quindi scegliere Delega autorizzazioni di gestione.

Aggiungere un server a un gruppo di replica.

Il server da aggiungere deve essere online e all'utente deve essere stata delegata l'amministrazione del gruppo di replica.

Nel caso di un server membro l'utente deve appartenere al gruppo Administrators locale nel server da aggiungere.

Nel caso di un controller di dominio l'utente deve essere membro del gruppo Domain Admins nel dominio in cui si trova il server.

Aggiungere l'utente al gruppo Administrators locale nel server membro da aggiungere oppure al gruppo Domain Admins nel controller di dominio.

Se si prevede di delegare la creazione e l'amministrazione di gruppi di replica, tenere presente quanto segue:

  • Se si delega a un utente o a un gruppo la creazione di gruppi di replica e successivamente tale utente o gruppo viene rimosso dall'elenco di delega, non viene apportata alcuna modifica alle impostazioni di sicurezza dei gruppi di replica esistenti.

  • Se si delega a un utente o a un gruppo l'amministrazione di un gruppo di replica specifico e successivamente tale utente o gruppo viene rimosso dall'elenco di delega, non viene apportata alcuna modifica alle impostazioni di sicurezza dei dati di configurazione esistenti. Se ad esempio l'utente rimosso ha creato in precedenza una connessione nel gruppo di replica, manterrà le autorizzazioni per la modifica della connessione in quanto è il proprietario dell'oggetto Servizi di dominio Active Directory contenente i dati di configurazione relativi a tale connessione.

Ulteriori riferimenti

  • Delega avanzata di autorizzazioni di Replica DFS

    (http://go.microsoft.com/fwlink/?LinkId=140355)

  • Distribuire Replica DFS


Gestire Replica DFS

Negli argomenti seguenti vengono fornite informazioni sulla gestione di Replica DFS:

  • Modificare le pianificazioni e la larghezza di banda di replica

  • Abilitare o disabilitare la replica

  • Abilitare o disabilitare la replica in un membro specifico

  • Modificare le dimensioni della quota della cartella di gestione temporanea e della cartella dei file eliminati e con conflitti

  • Modificare i filtri di replica per una cartella replicata

  • Condividere o pubblicare una cartella replicata

  • Modificare la topologia di replica


Modificare le pianificazioni e la larghezza di banda di replica

Per modificare la larghezza di banda o la pianificazione di replica per un gruppo o una connessione di replica o per imporre la replica con un membro specifico di un gruppo di replica, eseguire le procedure seguenti.

Per modificare la larghezza di banda e la pianificazione di replica

  • Per modificare la pianificazione e la larghezza di banda per un gruppo di replica, eseguire la procedura seguente:

    1. Nell'albero della console fare clic con il pulsante destro del mouse sul gruppo di replica di cui si desidera modificare la pianificazione nel nodo Replica e quindi scegliere Modifica pianificazione gruppo di replica.

    2. Utilizzare la finestra di dialogo Modifica pianificazione per stabilire quando eseguire la replica e impostare la quantità massima di larghezza di banda utilizzabile per la replica.

  • Per modificare la pianificazione e la larghezza di banda per una connessione specifica, eseguire la procedura seguente:

    1. Nell'albero della console selezionare il gruppo di replica appropriato nel nodo Replica.

    2. Fare clic sulla scheda Connessioni, fare clic con il pulsante destro del mouse sulla connessione che si desidera modificare e quindi scegliere Proprietà.

    3. Fare clic sulla scheda Pianificazione, selezionare Pianificazione personalizzata connessione e quindi fare clic su Modifica pianificazione.

    4. Utilizzare la finestra di dialogo Modifica pianificazione per stabilire quando eseguire la replica e impostare la quantità massima di larghezza di banda utilizzabile per la replica.
Nota

Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

Per imporre l'esecuzione immediata della replica

  1. Nell'albero della console selezionare il gruppo di replica appropriato nel nodo Replica.

  2. Fare clic sulla scheda Connessioni.

  3. Fare clic con il pulsante destro del mouse sul membro si desidera replicare e quindi scegliere Replica ora.

Ulteriori riferimenti

  • Gestire Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Abilitare o disabilitare la replica

Eseguire la procedura seguente per abilitare o disabilitare la replica.

Per abilitare o disabilitare la replica per una connessione specifica

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sul gruppo di replica contenente la connessione che si desidera modificare nel nodo Replica.

  3. Nel riquadro dei dettagli fare clic sulla scheda Connessioni.

  4. Eseguire una delle operazioni seguenti:

    • Per disabilitare una connessione, fare clic con il pulsante destro del mouse sulla connessione e quindi scegliere Disabilita.

    • Per abilitare una connessione, fare clic con il pulsante destro del mouse sulla connessione e quindi scegliere Abilita.

Ulteriori considerazioni

  • Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

  • Microsoft non supporta connessioni unidirezionali per Replica DFS. La creazione di una connessione di replica unidirezionale può causare numerosi problemi, tra cui errori di topologia del controllo di integrità, problemi di gestione temporanea, nonché problemi relativi al database di Replica DFS. Per creare una connessione unidirezionale è invece consigliabile impostare la cartella replicata in sola lettura nel membro appropriato.

Ulteriori riferimenti

  • Gestire Replica DFS

  • Delegare la possibilità di gestire Replica DFS

  • Impostare una cartella replicata in sola lettura in un membro specifico


Abilitare o disabilitare la replica in un membro specifico

È possibile abilitare o disabilitare la replica con membri specifici di un gruppo di replica. È tuttavia importante comprendere le implicazioni di una tale scelta. Dopo aver abilitato un membro disabilitato, nel membro deve essere eseguita una replica iniziale della cartella replicata. Questa operazione determina il trasferimento di circa 1 KB di dati per ogni file o cartella nella cartella replicata. Qualsiasi file nuovo o aggiornato presente nel membro verrà inoltre spostato nella cartella DfsrPrivate\PreExisting del membro e sostituito con un file autorevole proveniente da un altro membro.

Se vengono disabilitati tutti i membri relativi a una cartella replicata, il primo membro successivamente abilitato verrà impostato come primario. Se l'elenco di controllo di accesso discrezionale (DACL) nel percorso locale del membro contiene voci di controllo di accesso (ACE) ereditate, queste ultime verranno convertite in voci ACE esplicite con le medesime autorizzazioni in modo che tutti i membri disporranno dello stesso elenco DACL nella directory radice della cartella replicata.

Eseguire la procedura seguente per abilitare o disabilitare la replica di una cartella replicata in un membro specifico.

Per abilitare o disabilitare la replica di una cartella replicata in un membro specifico

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sul gruppo di replica contenente l'appartenenza che si desidera abilitare o disabilitare nel nodo Replica.

  3. Nel riquadro dei dettagli fare clic sulla scheda Appartenenze.

  4. Selezionare la cartella replicata nel membro specifico e quindi eseguire una delle operazioni seguenti:

    • Per disabilitare la cartella replicata nel membro, fare clic con il pulsante destro del mouse sulla cartella replicata e quindi scegliere Disabilita.

    • Per abilitare la cartella replicata nel membro, fare clic con il pulsante destro del mouse sulla cartella replicata e quindi scegliere Abilita.
Nota

Le modifiche apportate alle appartenenze non vengono applicate immediatamente. Le modifiche devono infatti essere replicate in tutti i controller di dominio e ogni membro deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling breve, ovvero 5 minuti, di ogni membro.

Ulteriori riferimenti

  • Gestire Replica DFS

  • Delegare la possibilità di gestire Replica DFS

  • Creare un gruppo di replica


Modificare le dimensioni della quota della cartella di gestione temporanea e della cartella dei file eliminati e con conflitti

Il servizio Replica DFS utilizza per ogni cartella replicata le cartelle di gestione temporanea come cache per file nuovi e modificati pronti per essere replicati dai membri di origine in quelli di destinazione. Tali file sono archiviati nel percorso locale della cartella replicata della cartella DfsrPrivate\Staging.

Quando un file viene modificato in due o più membri prima di poter replicare le modifiche, il file aggiornato più di recente viene considerato vincente in caso di conflitto e Replica DFS sposta il file o i file perdenti nella cartella dei file eliminati e con conflitti. Il file o i file perdenti vengono archiviati nella cartella DfsrPrivate\ConflictandDeleted nel percorso locale della cartella replicata nel membro utilizzato per la risoluzione del conflitto. La cartella dei file eliminati e con conflitti viene inoltre utilizzata per archiviare file eliminati dalle cartelle replicate.

Per impostazione predefinita, la dimensioni della quota di ogni cartella di gestione temporanea sono pari a 4.096 MB, mentre quelle di ogni cartella dei file eliminati e con conflitti a 660 MB. Le dimensioni di ogni cartella in un membro sono cumulative per volume, pertanto se in un membro sono presenti più cartelle replicate, Replica DFS creerà più cartelle di gestione temporanea e dei file eliminati e con conflitti, ognuna con la propria quota.

Nelle sottosezioni seguenti vengono fornite informazioni su come modificare la quota della cartella di gestione temporanea e della cartella dei file eliminati e con conflitti e su come ottimizzare le dimensioni delle cartelle di gestione temporanea.

Nota

I file nella cartella dei file eliminati e con conflitti vengono ridenominati e sono accessibili solo ai membri del gruppo Administrators locale. Gli elenchi di controllo di accesso (ACL) dei file in conflitto vengono mantenuti per garantire la sicurezza. È possibile visualizzare un registro di file in conflitto e i relativi nomi file originali aprendo il file ConflictandDeletedManifest.xml disponibile nella cartella DfsrPrivate.

Modificare le dimensioni della quota o il percorso della cartella di gestione temporanea e della cartella dei file eliminati e con conflitti

È possibile modificare la quota della cartella di gestione temporanea e della cartella dei file eliminati e con conflitti per cartella replicata, in base al membro. È inoltre possibile modificare il percorso della cartella di gestione temporanea.

Per modificare le dimensioni della quota o il percorso della cartella di gestione temporanea e della cartella dei file eliminati e con conflitti

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sul gruppo di replica contenente la cartella replicata di cui si desidera modificare le quote nel nodo Replica.

  3. Nella scheda Appartenenze del riquadro dei dettagli fare clic con il pulsante destro del mouse sulla cartella replicata nel membro di cui si desidera modificare la quota e quindi scegliere Proprietà.

  4. Nella scheda Gestione temporanea modificare la quota e il percorso della cartella di gestione temporanea a seconda delle esigenze.

  5. Nella scheda Avanzate modificare la quota della cartella dei file eliminati e con conflitti a seconda delle esigenze.
Nota

Le modifiche non vengono applicate immediatamente. Gli aggiornamenti devono essere replicati in tutti i controller di dominio e il membro deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling breve, ovvero 5 minuti, di ogni membro.

Ottimizzare le dimensioni delle cartelle di gestione temporanea

Sebbene sia possibile modificare la dimensione di ogni cartella di gestione temporanea, è necessario considerare i fattori seguenti:

  • Aumentare la quota della cartella di gestione temporanea quando è necessario replicare più file di grandi dimensioni modificati di frequente.

  • Se possibile, aumentare la quota delle cartelle di gestione temporanea nei membri hub con numerosi partner di replica.

  • Se la quota configurata per una cartella di gestione temporanea è eccessivamente ridotta, potrebbe verificarsi un ulteriore consumo delle risorse di CPU e disco da parte di Replica DFS ai fini della rigenerazione dei file di gestione temporanea. Le prestazioni di replica potrebbero inoltre risultare ridotte poiché l'insufficienza dello spazio di gestione temporanea può limitare notevolmente il numero di trasferimenti simultanei con i partner.

  • Per la replica iniziale di dati esistenti nel membro primario, è importante che la quota della cartella di gestione temporanea sia tale che, se file di grandi dimensioni vengono bloccati in gestione temporanea a causa di problemi di download nei partner, sia possibile continuare la replica dei file rimanenti. Per definire la dimensione adeguata della cartella di gestione temporanea ai fini della replica iniziale, è necessario considerare le dimensioni dei file da replicare. La quota della cartella deve essere pari ad almeno il doppio delle dimensioni del file di dimensioni maggiori presente nella cartella replicata. Per migliorare le prestazioni, è consigliabile aumentare la quota della cartella di gestione temporanea in modo che corrisponda alle dimensioni dei quattro file di dimensioni maggiori presenti nella cartella replicata nei membri spoke e a quelle dei 16 file di dimensioni maggiori nella cartella replicata nei membri hub.

  • Se si dispone di una quantità di spazio su disco limitata, potrebbe essere necessario configurare la quota di gestione temporanea in modo che sia inferiore a quella predefinita quando più cartelle replicate condividono lo spazio nel medesimo volume.

  • Se nel corso del normale funzionamento in un'ora viene registrato più volte l'evento che indica il superamento della quota di gestione temporanea (ID evento 4208 nel registro eventi di Replica DFS), aumentare la quota del 20%.

  • Per migliorare la velocità effettiva di input/output (I/O), posizionare le cartelle di gestione temporanea e le cartelle replicate in dischi fisici diversi. Questa operazione può essere eseguita modificando il percorso della cartella di gestione temporanea.

Nota

La quota di gestione temporanea per Replica DFS non è un limite rigido e può aumentare oltre le dimensioni configurate, a differenza di quella per FRS. Quando la quota viene raggiunta, Replica DFS elimina i file obsoleti dalla cartella di gestione temporanea in modo da ridurre l'utilizzo del disco a un valore inferiore a quello previsto dalla quota. La cartella di gestione temporanea non riserva spazio sul disco rigido e occupa solo la quantità di spazio attualmente necessaria.

Ulteriori riferimenti

  • Gestire Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Modificare i filtri di replica per una cartella replicata

È possibile configurare filtri file e sottocartella per impedire la replica di file e sottocartelle. Entrambi i tipi di filtri vengono impostati per cartella replicata. Le sottocartelle vengono escluse specificandone il nome oppure utilizzando l'asterisco (*) come carattere jolly. I file vengono esclusi specificandone il nome oppure utilizzando l'asterisco (*) come carattere jolly per estensioni e nomi file.

Per impostazione predefinita, non viene esclusa alcuna sottocartella. I filtri file predefiniti escludono dalla replica i file seguenti:

  • Nomi file che iniziano con un carattere tilde (~)

  • File con estensione bak o tmp

Indipendentemente dai filtri impostati, i tipi di file seguenti sono sempre esclusi dalla replica:

  • Punti di montaggio di volumi NTFS

  • File crittografati mediante EFS (Encrypting File System)

  • Qualsiasi reparse point, tranne quelli associati a Spazi dei nomi DFS

    Se un file dispone di un reparse point utilizzato per Hierarchical Storage Management (HSM) o Single Instance Store (SIS), Replica DFS replicherà il file sottostante ma non il reparse point.

  • File per cui è stato impostato l'attributo temporaneo

Per modificare i filtri di replica per una cartella replicata

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sul gruppo di replica contenente la cartella replicata di cui si desidera modificare i filtri nel nodo Replica.

  3. Nella scheda Cartelle replicate del riquadro dei dettagli fare clic con il pulsante destro del mouse su una cartella replicata e quindi scegliere Proprietà.

  4. Nella scheda Generale modificare i filtri esistenti o aggiungere nuovi filtri prestando attenzione alle restrizioni seguenti:

    • Non è possibile creare filtri file o sottocartella specificando un percorso completo, ad esempio C:\Cartellareplicata\Temp o C:\Cartellareplicata\file.dat.

    • Non è possibile specificare una virgola in un filtro, poiché le virgole vengono utilizzate come delimitatori.

In seguito al rilevamento di un nuovo filtro, un membro analizza il relativo database e rimuove qualsiasi record di file corrispondente al filtro. Poiché i file non sono più inclusi nel database, le modifiche future apportate ai file verranno ignorate.

In seguito al rilevamento della rimozione di un filtro, un membro analizza il file system, aggiunge record per tutti i file corrispondenti al filtro rimosso e replica i file.

Nota

Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

Ulteriori riferimenti

  • Gestire Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Condividere o pubblicare una cartella replicata

Per abilitare la condivisione dei file in una cartella replicata e facoltativamente aggiungere la cartella a uno spazio dei nomi DFS, utilizzare le procedure seguenti:

Per condividere una cartella replicata senza pubblicarla in uno spazio dei nomi DFS

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sul gruppo di replica contenente la cartella replicata che si desidera condividere nel nodo Replica.

  3. Nella scheda Cartelle replicate del riquadro dei dettagli fare clic con il pulsante destro del mouse sulla cartella replicata che si desidera condividere e quindi scegliere Condividi e pubblica nello spazio dei nomi.

  4. Nella Condivisione e pubblicazione guidata cartella replicata fare clic su Condividi cartella replicata e quindi eseguire i passaggi della procedura guidata.
Per condividere una cartella replicata e pubblicarla in uno spazio dei nomi DFS

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic nel nodo Replica sul gruppo di replica contenente la cartella replicata che si desidera condividere.

  3. Nella scheda Cartelle replicate del riquadro dei dettagli fare clic con il pulsante destro del mouse sulla cartella replicata che si desidera condividere e quindi scegliere Condividi e pubblica nello spazio dei nomi.

  4. Nella Condivisione e pubblicazione guidata cartella replicata fare clic su Condividi e pubblica la cartella replicata in uno spazio dei nomi e quindi eseguire i passaggi della procedura guidata.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessario che i requisiti di sicurezza relativi alla gestione di Replica DFS e degli spazi dei nomi vengano soddisfatti. Se la condivisione delle cartelle verrà impostata durante la Condivisione e pubblicazione guidata cartella replicata, è inoltre necessario essere membri del gruppo Administrators locale nei server in cui ogni cartella viene condivisa.

  • Se non è disponibile alcuno spazio dei nomi esistente, è possibile crearne uno nella pagina Percorso dello spazio dei nomi della Condivisione e pubblicazione guidata cartella replicata. Per creare lo spazio dei nomi, fare clic su Sfoglia nella pagina Percorso dello spazio dei nomi e quindi su Nuovo spazio dei nomi.

Ulteriori riferimenti

  • Gestire Replica DFS

  • Spazi dei nomi


Modificare la topologia di replica

La topologia di replica è costituita dalle connessioni logiche utilizzate da Replica DFS per la replica di file tra i server. Quando si sceglie una topologia, tenere presente che tra i membri selezionati vengono create due connessioni unidirezionali. Queste due connessioni consentono il flusso dei dati in entrambe le direzioni.

Per creare una topologia di replica

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul gruppo di replica per il quale creare la nuova topologia nel nodo Replica e quindi scegliere Nuova topologia.

  3. Seguire le istruzioni contenute nella Creazione guidata nuova topologia per selezionare una delle topologie seguenti:

    • Hub e spoke. Per questa topologia sono necessari tre o più membri. Per ogni membro spoke scegliere un membro hub obbligatorio e un secondo membro hub facoltativo a scopo di ridondanza. Questo hub facoltativo garantisce la possibilità di replica di un membro spoke anche in caso di indisponibilità di uno dei membri hub. Se si specificano due membri hub, tra i membri hub verrà stabilita una topologia a maglia completa.

    • A maglia completa. In questa topologia ogni membro esegue la replica con tutti gli altri membri del gruppo di replica. Questa topologia si rivela efficiente se nel gruppo di replica sono presenti fino a dieci membri.

Nota

Le modifiche apportate alla configurazione non vengono applicate immediatamente a tutti i membri. La nuova configurazione deve essere replicata in tutti i controller di dominio e ogni membro del gruppo di replica deve eseguire il polling del controller di dominio più vicino per ottenere le modifiche. Il tempo richiesto dipende dalla latenza di replica di Servizi di dominio Active Directory e dall'intervallo di polling per ogni membro, in genere 60 minuti. Per eseguire immediatamente il polling per le modifiche della configurazione, aprire una finestra del prompt dei comandi e quindi digitare il comando seguente una volta per ogni membro del gruppo di replica: dfsrdiag.exe PollAD /Member:DOMAIN\Server1.

Ulteriori riferimenti

  • Gestire Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Risolvere i problemi relativi a Replica DFS

Negli argomenti seguenti vengono fornite informazioni sulla risoluzione dei problemi relativi a Replica DFS:

  • Creare un rapporto di diagnostica per Replica DFS

  • Ripristinare una topologia disconnessa

Ulteriori riferimenti

  • Risorse su Gestione DFS

  • Sezione relativa alla risoluzione dei problemi della Raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=83365)

  • Gruppo di discussione su file system distribuiti e Replica file (http://go.microsoft.com/fwlink/?LinkId=93050)

  • Forum TechNet su archiviazione e Servizi file di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=93045)


Creare un rapporto di diagnostica per Replica DFS

Gestione DFS disponibile in Windows Server 2008 consente di eseguire una prova di propagazione e di generare due tipi di rapporti di diagnostica, ovvero un rapporto di propagazione e un rapporto di stato di carattere generale.

  • Prova di propagazione Consente di eseguire una prova relativa allo stato di avanzamento della replica mediante la creazione di un file di prova in una cartella replicata.

  • Rapporto di propagazione Consente di generare un rapporto in cui viene registrato lo stato di avanzamento della replica per il file di prova creato durante una prova di propagazione.

  • Rapporto di stato Consente di generare un rapporto in cui è indicato lo stato della replica e il livello di efficienza della replica.

Eseguire la procedura seguente per creare un rapporto di diagnostica per Replica DFS.

Per creare un rapporto di diagnostica per Replica DFS

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul gruppo di replica per cui si desidera creare un rapporto di diagnostica nel nodo Replica e quindi scegliere Crea rapporto di diagnostica.

  3. Seguire le istruzioni della Creazione guidata rapporto di diagnostica.

Ulteriori considerazioni

  • Per creare un rapporto di diagnostica, è necessario essere membri del gruppo Administrators locale di ogni server per cui si prepara un rapporto.

  • La quantità di tempo necessaria per generare un rapporto di diagnostica può variare in base a numerosi fattori, tra cui lo stato di Replica DFS, il numero di cartelle replicate, le risorse del server disponibili (ad esempio CPU e memoria), la disponibilità della rete WAN (connettività, larghezza di banda e latenza) e le opzioni selezionate per la creazione del rapporto. A causa del potenziale ritardo nella creazione di rapporti di diagnostica, è consigliabile creare rapporti di diagnostica per un massimo di 50 server per volta.

Ulteriori riferimenti

  • Risolvere i problemi relativi a Replica DFS


Ripristinare una topologia disconnessa

Eseguire la procedura seguente per ripristinare una topologia disconnessa.

Per ripristinare una topologia disconnessa

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione DFS.

  2. Nell'albero della console fare clic sul gruppo di replica contenente la topologia disconnessa nel nodo Replica.

  3. Nella scheda Connessioni del riquadro dei risultati fare clic sul messaggio di errore nella parte superiore della scheda per aprire la finestra di dialogo Topologia disconnessa.

  4. Per visualizzare i membri disconnessi, selezionare una cartella replicata nell'elenco Cartella replicata e quindi espandere Membri disconnessi.

  5. Fare clic su Chiudi.

  6. Ripristinare la topologia eseguendo una delle procedure seguenti, in base alle esigenze:

    • Creare una connessione

    • Modificare le pianificazioni e la larghezza di banda di replica

    • Abilitare o disabilitare la replica

    • Abilitare o disabilitare la replica in un membro specifico

    Suggerimento

    In alcune istanze potrebbe essere necessario rimuovere membri disconnessi e quindi riaggiungerli al gruppo di replica per ripristinare una topologia disconnessa.

Ulteriori riferimenti

  • Creare un rapporto di diagnostica per Replica DFS

  • Risolvere i problemi relativi a Replica DFS

  • Delegare la possibilità di gestire Replica DFS


Risorse su Gestione DFS

Per ulteriori informazioni su File system distribuito (DFS) e Gestione DFS, vedere le risorse seguenti sul sito Web Microsoft:

  • Sezione relativa a Servizi file della Raccolta di documentazione tecnica di Windows Server 2008

    (http://go.microsoft.com/fwlink/?LinkID=85622)

  • Sezione relativa alla risoluzione dei problemi della Raccolta di documentazione tecnica di Windows Server 2008

    (http://go.microsoft.com/fwlink/?LinkID=83365)

  • Forum TechNet su archiviazione e Servizi file di Windows Server 2008

    (http://go.microsoft.com/fwlink/?LinkId=93045)

  • Novità di File system distribuito in Windows Server 2008 R2

    (http://go.microsoft.com/fwlink/?LinkId=139569)

  • Domande frequenti su Replica DFS

    (http://go.microsoft.com/fwlink/?LinkId=140270)

  • Guida alla migrazione della replica SYSVOL: da Replica file a Replica DFS

    (http://go.microsoft.com/fwlink/?LinkId=139749)

  • Aggiornamenti rapidi attualmente disponibili per tecnologie di file system distribuito (DFS) in Windows Server 2008 e Windows Server 2008 R2

    (http://go.microsoft.com/fwlink/?LinkId=140177)

  • Blog Microsoft Filecab del team specializzato in archiviazione

    (http://go.microsoft.com/fwlink/?LinkId=139751)

  • Domande per il blog del team specializzato in servizi directory

    (http://go.microsoft.com/fwlink/?LinkId=139752)

  • Amministrazione di DFS dal prompt dei comandi

    (http://go.microsoft.com/fwlink/?LinkID=92840)