Protocollo DHCP

DHCP (Dynamic Host Configuration Protocol) è uno standard IP progettato per semplificare l'amministrazione delle configurazioni di indirizzi attraverso l'impiego di un computer server che gestisce centralmente gli indirizzi IP e altre informazioni di configurazione correlate utilizzate nella rete. Il servizio DHCP consente al computer server di fungere da server DHCP e configurare computer client abilitati per DHCP nella rete.

DHCP include Multicast Address Dynamic Client Allocation Protocol (MADCAP) che viene utilizzato per l'assegnazione di indirizzi multicast. I client registrati cui vengono assegnati in modo dinamico indirizzi IP mediante MADCAP possono essere inclusi efficacemente nel processo del flusso di dati, ad esempio in trasmissioni di rete di dati audio o video in tempo reale.

In questo file della Guida:

  • Panoramica di DHCP

  • Installare il ruolo Server DHCP

  • Configurare le impostazioni del ruolo Server DHCP

  • Attività consigliate per il ruolo server DHCP

Ulteriori informazioni

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Panoramica di DHCP

Con la distribuzione di server DHCP (Dynamic Host Configuration Protocol) in rete, i computer client e gli altri dispositivi della rete basati su TCP/IP potranno usufruire automaticamente di indirizzi IP validi, nonché dei parametri di configurazione aggiuntivi, o opzioni DHCP, necessari per la connessione ad altre risorse di rete, ad esempio server DNS, server WINS e router.

Funzionalità offerte da un server DHCP

DHCP è una tecnologia client-server che consente ai server DHCP di assegnare indirizzi IP, o eseguirne il lease, a computer e altri dispositivi abilitati come client DHCP. DHCP consente di eseguire le operazioni seguenti:

  • Lease di indirizzi IP a client DHCP per un periodo di tempo specifico e rinnovo automatico di tali indirizzi su richiesta del client.

  • Aggiornamento automatico dei parametri dei client DHCP mediante la modifica di un'opzione relativa al server o all'ambito nel server DHCP, invece che singolarmente in tutti i client DHCP.

  • Prenotazione di indirizzi IP per computer specifici o altri dispositivi, in modo che dispongano sempre dello stesso indirizzo IP e ricevano le opzioni DHCP più aggiornate.

  • Esclusione di indirizzi IP o intervalli di indirizzi IP dalla distribuzione da parte del server DHCP, in modo che sia possibile utilizzarli per la configurazione statica di server, router e altri dispositivi che richiedono indirizzi IP statici.

  • Offerta di servizi DHCP a molte subnet, se tutti i router tra il server DHCP e la subnet per cui si desidera fornire servizi sono configurati per l'inoltro di messaggi DHCP.

  • Configurazione del server DHCP per l'esecuzione di servizi di registrazione dei nomi DNS per i client DHCP.

  • Implementazione dell'assegnazione di indirizzi multicast per client DHCP basati su IP.

Componenti di un server DHCP

I componenti principali di DHCP consentono di distribuire un server DHCP e un server Multicast Address Dynamic Client Allocation Protocol (MADCAP).

Nota

MADCAP è supportato solo in IPv4. Il server DHCPv6 non supporta MADCAP.

Server DHCP

Per il funzionamento corretto della rete, è necessario assegnare un indirizzo IP a tutti i computer e i dispositivi della rete TCP/IP. È possibile configurare manualmente gli indirizzi IP in ogni computer, oppure distribuire un server DHCP che assegna automaticamente lease di indirizzi IP a tutti i client DHCP della rete.

La maggior parte dei sistemi operativi ricerca il lease di un indirizzo IP per impostazione predefinita, pertanto per implementare una rete abilitata per DHCP non è necessario eseguire alcuna configurazione nei computer client. Il primo passaggio consiste nella distribuzione di un server DHCP.

Prima che il server DHCP possa fornire lease di indirizzi IP ai client tuttavia, è necessario definire un intervallo di indirizzi IP nel server DHCP. Tale intervallo, noto come ambito, definisce una singola subnet fisica nella rete in cui vengono offerti i servizi DHCP. Se ad esempio si dispone di due subnet, il server DHCP deve essere connesso a entrambe le subnet ed è necessario definire un ambito per ogni subnet. Gli ambiti costituiscono inoltre la modalità principale utilizzata dal server per gestire la distribuzione e l'assegnazione di indirizzi IP e di qualsiasi parametro di configurazione correlato ai client in rete.

Server MADCAP

Quando si distribuisce DHCP come server MADCAP, il server DHCP può assegnare dinamicamente indirizzi IP multicast ai client che desiderano aggiungersi al gruppo di client che riceve le informazioni inviate nei messaggi multicast.

Il multicasting è utile per il recapito di informazioni point-to-multipoint in un sistema di reti, ad esempio di informazioni audio o video. Mediante il multicasting un punto, ad esempio un server multimediale, può inviare le informazioni in un unico pacchetto a più destinatari utilizzando un indirizzo multicast.

I vantaggi di questo metodo sono l'utilizzo di un unico pacchetto e l'eliminazione della possibilità di sovraccarico per mantenere gli elenchi di destinatari. A differenza dei pacchetti di broadcast, il traffico multicast non disturba i nodi che non ascoltano questo tipo di traffico. I router possono essere abilitati per il multicast e inoltrare il pacchetto multicast a tutte le reti in cui esiste almeno un nodo in ascolto.

Gestire un server DHCP

Gli strumenti principali per la gestione dei server DHCP sono i comandi Netsh per DHCP e la console DHCP.

Comandi Netsh per DHCP

È possibile digitare i comandi Netsh per DHCP in una finestra del prompt dei comandi al prompt dei comandi netsh dhcp>, oppure eseguirli in file batch e altri script. Tutte le funzionalità disponibili nella console DHCP sono disponibili al prompt dei comandi netsh dhcp>. Questo può risultare utile nelle situazioni seguenti:

  • Quando si gestiscono server DHCP in reti WAN (Wide Area Networks), è possibile utilizzare i comandi in modo interattivo al prompt dei comandi netsh> per una gestione migliore nei collegamenti di rete a bassa velocità.

  • Quando si gestisce un numero elevato di server DHCP, è possibile utilizzare i comandi in modalità batch per creare script per automatizzare le attività amministrative ricorrenti che è necessario eseguire per tutti i server DHCP.

Console DHCP

La console DHCP viene aggiunta alla cartella Strumenti di amministrazione del Pannello di controllo quando si installa il ruolo di server DHCP. La console DHCP viene visualizzata come snap-in di Microsoft Management Console (MMC).

La console DHCP contiene inoltre alcune migliorie suggerite da amministratori di rete. Tali migliorie comprendono monitoraggio migliorato delle prestazioni del server, un numero maggiore di tipi di opzioni DHCP predefinite, supporto dell'aggiornamento dinamico per i client che eseguono versioni precedenti di Windows, nonché rilevamento dei server DHCP non autorizzati all'interno della rete.

Attività amministrative comuni per DHCP

Dopo aver installato un server DHCP, è possibile utilizzare la console DHCP oppure i comandi Netsh per DHCP per eseguire le attività amministrative di base per i server descritte di seguito:

  1. Creazione di ambiti.

  2. Aggiunta e configurazione di ambiti estesi e ambiti multicast.

  3. Visualizzazione e modifica delle proprietà degli ambiti, ad esempio impostazione di intervalli di esclusione aggiuntivi.

  4. Attivazione di ambiti, ambiti multicast o ambiti estesi.

  5. Monitoraggio dell'attività di assegnazione lease degli ambiti mediante l'analisi dei lease attivi per ogni ambito.

  6. Creazione di prenotazioni all'interno degli ambiti per i client DHCP che richiedono un indirizzo IP permanente per l'utilizzo in lease.

È inoltre possibile utilizzare la console DHCP oppure i comandi Netsh per DHCP per eseguire le attività di configurazione facoltative o avanzate seguenti:

  • Aggiunta di nuovi tipi di opzioni predefinite personalizzate.

  • Aggiunta e configurazione di qualsiasi classe di opzione definita dal venditore o dall'utente.

  • Configurazione di altre proprietà del server, ad esempio registrazione dei controlli oppure tabelle del protocollo d'avvio (BOOTP).

Nota

Gli ambiti estesi sono supportati solo in IPv4. Il server DHCPv6 non supporta gli ambiti estesi.

Ulteriori informazioni

Per informazioni aggiornate e dettagliate su DHCP per i professionisti IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Installare il ruolo Server DHCP

Ruolo server DHCP: configurazione di un server DHCP

I server DHCP consentono di gestire da una posizione centrale gli indirizzi IP e le informazioni a essi correlate e di fornirli ai client automaticamente. In questo modo è possibile configurare le impostazioni di rete dei client in un unico server anziché in ogni singolo computer client. Se si desidera utilizzare il computer per distribuire indirizzi IP ai client, configurarlo come server DHCP.

In questo argomento vengono descritte le operazioni di base da eseguire per configurare un server DHCP. Dopo aver configurato un server DHCP di base, è possibile eseguire altre attività di configurazione in base agli utilizzi previsti per il server DHCP.

Requisiti preliminari

Prima di configurare il computer come server DHCP, verificare che:

  • I concetti inerenti DHCP, ad esempio gli ambiti, i lease e le opzioni, siano tutti noti.

  • Il sistema operativo sia configurato in modo corretto. In Windows Server® 2008 DHCP dipende dalla configurazione appropriata del sistema operativo stesso e dei rispettivi servizi.

  • Il computer in uso disponga di un indirizzo IP statico (vedere Configurare un indirizzo IP statico per il server DHCP).

  • Tutti i volumi di disco esistenti utilizzino il file system NTFS. I volumi FAT32 non sono sicuri e non supportano la compressione di file e cartelle, le quote del disco, la crittografia di file o autorizzazioni per singoli file.

Quando si aggiunge il ruolo server DHCP, si crea un ambito che definisce l'intervallo di indirizzi IP allocati dal server DHCP ai client di una subnet. È necessario creare un ambito per ogni subnet in cui sono presenti client da gestire mediante DHCP. Nella tabella seguente sono elencate le informazioni da raccogliere prima di aggiungere il ruolo server DHCP per la creazione del primo ambito. Le informazioni da raccogliere sono le stesse per ogni ambito aggiuntivo.

Prima di aggiungere un ruolo server DHCP | Commenti
Esaminare i problemi inerenti la sicurezza di DHCP. | I problemi inerenti la sicurezza possono influire sulle modalità di distribuzione dei server DHCP. Verificare di avere compreso come DHCP utilizza i gruppi di sicurezza. Per ulteriori informazioni, vedere Ulteriori informazioni sui gruppi di sicurezza DHCP.
Identificare l'intervallo di indirizzi IP che il server DHCP dovrà allocare ai client. | Utilizzare l'intero intervallo di indirizzi IP consecutivi che costituiscono la subnet IP locale. In molti casi la scelta ottimale è un intervallo di indirizzi privati. Per ulteriori informazioni e per un elenco di tutti gli intervalli di indirizzi IP approvati per l'utilizzo in reti private, vedere il documento RFC 1918 relativo all'allocazione degli indirizzi per reti internet private (informazioni in lingua inglese), disponibile nel sito Web Internet Engineering Task Force.
Determinare la subnet mask corretta per i client. | Quando il server DHCP concede in lease un indirizzo IP a un client, può specificare ulteriori informazioni di configurazione, tra cui la subnet mask.
Identificare tutti gli indirizzi IP che il server DHCP non dovrà allocare ai client. | Un server o una stampante connessa alla rete, ad esempio, spesso utilizza un indirizzo IP statico che il server DHCP non deve allocare ai client.
Stabilire la durata del lease degli indirizzi IP. | L'impostazione predefinita è otto giorni. La durata del lease deve in generale coincidere con il tempo medio in cui i client della subnet rimangono attivi. La durata ideale può ad esempio essere superiore agli otto giorni se i client sono computer desktop che vengono spenti di rado oppure inferiore agli otto giorni se i client sono dispositivi mobili spesso disconnessi dalla rete o spostati tra subnet.
(Facoltativo) Identificare l'indirizzo IP del router (il gateway predefinito) che dovrà essere utilizzato dai client per comunicare con client di altre subnet. | Quando il server DHCP concede in lease un indirizzo IP a un client, può specificare ulteriori informazioni di configurazione, tra cui l'indirizzo IP del router.
(Facoltativo) Identificare il nome del dominio DNS dei client. | Quando il server DHCP concede in lease un indirizzo IP a un client, può specificare ulteriori informazioni di configurazione, tra cui il nome del dominio DNS a cui appartengono i client.
(Facoltativo) Identificare l'indirizzo IP del server DNS che dovrà essere utilizzato dai client. | Quando il server DHCP concede in lease un indirizzo IP a un client, può specificare ulteriori informazioni di configurazione, tra cui l'indirizzo IP del server DNS che dovrà essere contattato dai client per la risoluzione del nome di un altro computer.
(Facoltativo) Identificare l'indirizzo IP del server WINS che dovrà essere utilizzato dai client. | Quando il server DHCP concede in lease un indirizzo IP a un client, può specificare ulteriori informazioni di configurazione, tra cui l'indirizzo IP del server WINS che dovrà essere contattato dai client per la risoluzione del nome NetBIOS di un altro computer.

Installare il server DHCP

Per installare un server DHCP

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, fare clic su Server Manager e quindi confermare Controllo account utente.

  2. In Riepilogo ruoli fare clic su Aggiungi ruoli, scegliere Avanti, selezionare Server DHCP e quindi scegliere Avanti.

Risorse aggiuntive

Per informazioni aggiornate e dettagliate su DHCP e sui ruoli server destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Configurare le impostazioni del ruolo Server DHCP

Per configurare il ruolo Server DHCP in Server Manager, vengono utilizzate sette schermate. I titoli delle schermate sono riportate in grassetto di seguito e sotto ogni titolo sono elencati i collegamenti agli argomenti della Guida disponibili nella schermata di Server Manager.

Schermata 1: Server DHCP

Panoramica di DHCP

Ulteriori informazioni sull'aggiunta di ambiti

Integrare DHCP con DNS

Schermata 2: Impostazioni DNS IPv4

Ulteriori informazioni sulle impostazioni del server DNS ->Integrare DHCP con DNS

Schermata 3: Impostazioni IPv4 server WINS

Ulteriori informazioni sulle impostazioni del server WINS

Schermata 4: Ambiti DHCP

Ulteriori informazioni sull'aggiunta di ambiti

Schermata 5: Configurazione della modalità senza stato di DHCPv6

Ulteriori informazioni sulla modalità senza stato di DHCPv6

Schermata 6: Impostazioni server DNS IPv6

Integrare DHCP con DNS

Schermata 7: Autorizzazione server DHCP

Ulteriori informazioni sull'autorizzazione di server DHCP in Servizi di dominio Active Directory

Risorse aggiuntive

Per ulteriori informazioni sui requisiti e la configurazione dei gruppi di sicurezza, vedere Ulteriori informazioni sui gruppi di sicurezza DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Configurare un indirizzo IP statico per il server DHCP

Per alcuni tipi di server è necessario assegnare un indirizzo IP statico e una subnet mask durante o dopo l'installazione. Tali server comprendono i server DHCP, DNS e WINS, oltre a qualsiasi server che fornisce agli utenti l'accesso in Internet. È inoltre consigliabile assegnare un indirizzo IP statico e una subnet mask a ogni controller di dominio. Se un computer dispone di più schede di rete, sarà necessario assegnare un indirizzo IP a ognuna di esse.

Per configurare IPv4 per l'indirizzamento statico

  1. Fare clic sul pulsante Start, scegliere Pannello di controllo, Rete e connessioni Internet, Centro connessioni di rete e condivisione e quindi Modifica impostazioni scheda.

  2. Fare clic con il pulsante destro del mouse sulla connessione per la quale si desidera aggiungere un indirizzo IP statico e quindi scegliere Proprietà.

  3. Confermare la finestra di dialogo di controllo dell'account utente e quindi fare doppio clic su Protocollo Internet versione 4 (TCP/IPv4).

  4. Fare clic su Utilizza il seguente indirizzo IP e quindi eseguire una delle operazioni seguenti:

    • Per una connessione alla rete locale, digitare l'indirizzo IP, la subnet mask e gli indirizzi del gateway predefinito in Indirizzo IP, Subnet mask e Gateway predefinito.

    • Per tutte le altre connessioni, digitare l'indirizzo IP in Indirizzo IP.

  5. Fare clic su Utilizza i seguenti indirizzi server DNS.

  6. In Server DNS preferito e Server DNS alternativo digitare gli indirizzi del server DNS primario e secondario.

Per configurare impostazioni avanzate per gli indirizzi IPv4 statici per una connessione alla rete locale, fare clic su Avanzate.

Per configurare IPv6 per l'indirizzamento statico

  1. Fare clic sul pulsante Start, scegliere Pannello di controllo, Rete e connessioni Internet, Centro connessioni di rete e condivisione e quindi Modifica impostazioni scheda.

  2. Fare clic con il pulsante destro del mouse sulla connessione per la quale si desidera aggiungere un indirizzo IP statico e quindi scegliere Proprietà.

  3. Confermare la finestra di dialogo di controllo dell'account utente e quindi fare doppio clic su Protocollo Internet versione 4 (TCP/IPv6).

  4. Fare clic su Usa l'indirizzo IPv6 seguente e quindi eseguire una delle operazioni seguenti:

    • Per una connessione alla rete locale, digitare l'indirizzo IP, la lunghezza di prefisso della subnet e l'indirizzo del gateway predefinito in Indirizzo IPv6, Lunghezza prefisso subnet e Gateway predefinito.

    • Per tutte le altre connessioni, digitare l'indirizzo IP in Indirizzo IPv6.

  5. Fare clic su Utilizza i seguenti indirizzi server DNS.

  6. In Server DNS preferito e Server DNS alternativo digitare gli indirizzi del server DNS primario e secondario.

Per configurare impostazioni avanzate per gli indirizzi IPv6 statici per una connessione alla rete locale, fare clic su Avanzate.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP e TCP/IP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Ulteriori informazioni sulle impostazioni del server WINS

Quando si aggiunge il ruolo Server DHCP in Server Manager, è possibile specificare se WINS è o meno necessario per le applicazioni disponibili in rete. WINS supporta principalmente i client che eseguono versioni meno recenti di Windows e le applicazioni che utilizzano NetBIOS. Windows 2000, Windows XP, Windows Vista®, Windows Server 2003 e Windows Server® 2008 utilizzano nomi DNS oltre a quelli NetBIOS. Gli ambienti in cui sono presenti alcuni computer che utilizzano nomi NetBIOS e altri computer che utilizzano nomi di dominio devono includere sia server WINS che server DNS.

Se tutti i computer della rete eseguono Windows 2000, Windows XP, Microsoft Windows Vista, Windows Server 2003 e Windows Server 2008 e non si intende supportare applicazioni che richiedono nomi NetBIOS, è necessario impostare DNS come unico metodo per la risoluzione dei nomi. Prima di decidere se rimuovere o non installare i server WINS, identificare eventuali computer o applicazioni che si basano su NetBIOS per valutare l'impatto della rimozione di NetBIOS. Se ad esempio viene individuata un'applicazione critica che si basa su NetBIOS e per la quale non è attualmente disponibile nessuna alternativa, sarà necessario continuare a utilizzare WINS. La denominazione NetBIOS può essere richiesta con le versioni meno recenti di alcune applicazioni, ad esempio Microsoft® Systems Management Server (SMS) e configurazioni di posta client/server Microsoft® BackOffice® che utilizzano Exchange Server.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP e WINS destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Integrare DHCP con DNS

I server DNS forniscono la risoluzione dei nomi di dominio per le risorse di rete. In particolare associano l'indirizzo TCP/IP assegnato da DHCP a un client in base al nome di dominio completo. Tale associazione, o mapping, di un indirizzo IP a un nome di dominio implica che, in caso di modifica dell'indirizzo o del nome, è necessario aggiornare le informazioni presenti in DNS. Il protocollo DHCP non aggiorna automaticamente DNS quando il server DHCP modifica l'indirizzo IP di un client. Per facilitare questa interazione, i server che eseguono Windows Server® 2008 con DHCP e i client che eseguono DHCP possono eseguire la registrazione con DNS, in modo da consentire la cooperazione tra i due. Quando DHCP modifica le informazioni sull'indirizzo IP, gli aggiornamenti DNS corrispondenti sincronizzano le associazioni nome-indirizzo relative al computer.

Quando un server DHCP registra e aggiorna i record di risorse relativi al puntatore DNS (PTR) e all'indirizzo (A) per conto dei relativi client DHCP, utilizza le informazioni contenute in un'opzione DHCP aggiuntiva, quella relativa all'FQDN del client (opzione 81), che consente a un client di fornire l'FQDN ed eventuali istruzioni al server DHCP utilizzato per elaborare aggiornamenti dinamici di DNS per proprio conto.

I motivi o gli eventi seguenti possono attivare un aggiornamento dinamico:

  • Aggiunta, rimozione o modifica degli indirizzi IP nella configurazione delle proprietà TCP/IP relativa a una qualsiasi delle connessioni di rete installate.

  • Lease dell'indirizzo IP che modifica o rinnova una qualsiasi delle connessioni di rete installate con il server DHCP, ad esempio quando si avvia un computer o dopo l'utilizzo del comando ipconfig /renew.

  • Utilizzo del comando ipconfig /registerdns, che impone manualmente un aggiornamento della registrazione del nome del client in DNS.

Quando uno di questi eventi attiva un aggiornamento dinamico, il servizio Client DHCP (e non quello Client DNS) invia gli aggiornamenti. Il servizio Client DHCP esegue questa funzione per tutte le connessioni di rete disponibili nel client, incluse quelle non configurate per l'utilizzo di DHCP.

Quando un client DHCP qualificato invia un aggiornamento, ad esempio un computer DHCP che esegue Windows XP Professional o Windows Vista®, i server che eseguono Windows Server 2008 e DHCP elaborano l'aggiornamento per determinare in quale dei tre modi disponibili il server avvierà gli aggiornamenti per conto del client.

  • Il server DHCP registra sempre il client DHCP sia per la ricerca diretta (record di risorse A) che per la ricerca inversa o il puntatore (record di risorse PTR) con DNS.

  • Il server DHCP non registra mai l'associazione nome-indirizzo (record di risorse A) per i client DHCP.

  • Il server DHCP registra il client DHCP sia per la ricerca diretta (record di risorse A) che per la ricerca inversa o il puntatore (record di risorse PTR) quando viene richiesto dal client.

La possibilità di registrare record di risorse sia A che PTR consente a un server DHCP di fungere da proxy per i client che eseguono altri sistemi operativi, ad esempio Microsoft Windows Millennium Edition o Windows 98, ai fini della registrazione degli aggiornamenti dinamici DNS. Il server DHCP è in grado di distinguere automaticamente tra client Windows 2000, Windows XP Professional, Microsoft Windows Vista e di altro tipo.

Per mantenere sincronizzate le informazioni relative al mapping nome-indirizzo, in DHCP è necessario utilizzare gli aggiornamenti dinamici DNS. L'utilizzo combinato di DHCP e DNS in una rete può causare problemi quando si utilizzano server DNS statici meno recenti che non sono in grado di interagire dinamicamente in caso di modifica delle configurazioni dei client DHCP. Per evitare errori di ricerca di client registrati DHCP quando si utilizza il servizio DNS statico, eseguire le operazioni seguenti:

  • Se si utilizzano server WINS (Windows Internet Name Service) in una rete, abilitare la ricerca WINS di client DHCP basati su NetBIOS.

  • Assegnare prenotazioni di indirizzi IP specificando una durata del lease infinita per i client DHCP che utilizzano solo DNS e non supportano NetBIOS.

  • Laddove possibile, aggiornare o sostituire server DNS statici meno recenti con server DNS che supportano gli aggiornamenti dinamici DNS.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP e DNS destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Ulteriori informazioni sull'aggiunta di ambiti

Configurare gli ambiti

Un ambito è un raggruppamento amministrativo di indirizzi IP per i computer di una subnet che utilizzano il servizio DHCP. L'amministratore crea dapprima un ambito per ogni subnet fisica e quindi utilizza l'ambito per definire i parametri utilizzati dai client. Un ambito presenta le proprietà seguenti:

  • Un intervallo di indirizzi IP da cui includere o escludere indirizzi utilizzati per le offerte di lease del servizio DHCP.

  • Una subnet mask, che determina la subnet per un determinato indirizzo IP.

  • Un nome di ambito assegnato al momento della creazione.

  • Valori di durata del lease, che vengono assegnati ai client DHCP che ricevono indirizzi IP allocati in modo dinamico.

  • Eventuali opzioni dell'ambito DHCP configurate per l'assegnazione a client DHCP, ad esempio il server DNS, l'indirizzo IP del router e l'indirizzo del server WINS.

  • Prenotazioni, utilizzate facoltativamente per garantire che un client DHCP riceva sempre lo stesso indirizzo IP.

Operazioni preliminari all'aggiunta di ambiti

Un ambito DHCP è costituito da un pool di indirizzi IP in una data subnet, ad esempio da 192.168.0.1 a 192.168.0.254, che un server DHCP può concedere in lease ai client.

Per ogni subnet può esistere solo un singolo ambito DHCP con un intervallo continuo di indirizzi IP. Per utilizzare più intervalli di indirizzi in un singolo ambito o una singola subnet per il servizio DHCP, è necessario definire prima l'ambito e quindi impostare eventuali intervalli di esclusione necessari.

  • Definire l'ambito

    Utilizzare l'intero intervallo di indirizzi IP consecutivi che costituiscono la subnet IP locale per la quale abilitare il servizio DHCP.

  • Impostare gli intervalli di esclusione

    È necessario impostare intervalli di esclusione per tutti gli indirizzi IP compresi nell'ambito che non si desidera vengano offerti o utilizzati dal server DHCP per l'assegnazione DHCP. È ad esempio possibile escludere i primi 10 indirizzi nell'ambito di esempio precedente per creare un'esclusione per gli indirizzi compresi tra 192.168.0.1 e 192.168.0.10.

    L'impostazione di un'esclusione per questi indirizzi consente di specificare che tali indirizzi non vengono mai offerti ai client DHCP quando richiedono la configurazione di lease dal server. Gli indirizzi IP esclusi possono essere attivi nella rete, tuttavia solo se vengono configurati manualmente negli host che non utilizzano DHCP per ottenere un indirizzo.

Creare ambiti

Quando si crea un ambito DHCP, viene utilizzata la console DHCP per immettere le informazioni obbligatorie seguenti:

  • Un nome di ambito, assegnato dall'amministratore che ha creato l'ambito.

  • Una subnet mask utilizzata per identificare la subnet cui appartiene un indirizzo IP.

  • Un intervallo di indirizzi IP contenuti nell'ambito.

  • Un intervallo di tempo (noto come durata lease) che specifica il tempo in cui un client DHCP può utilizzare un indirizzo IP assegnato prima che debba rinnovare la configurazione con il server DHCP.

Utilizzare la regola 80/20 per gli ambiti

Per bilanciare l'utilizzo del server DHCP, è consigliabile utilizzare la regola "80/20" per dividere gli indirizzi dell'ambito tra i due server DHCP. Se il server 1 è configurato per rendere disponibili la maggior parte, ovvero circa l'80%, degli indirizzi, è possibile configurare il server 2 per rendere disponibili ai client gli altri indirizzi, ovvero circa il 20%. Nella figura seguente è illustrato un esempio relativo all'applicazione della regola 80/20.

Operazioni successive all'aggiunta di ambiti

Dopo aver definito un ambito, è possibile configurare ulteriormente l'ambito eseguendo le attività seguenti:

  • Impostare intervalli di esclusione aggiuntivi.

    È possibile escludere tutti gli altri indirizzi IP che non devono essere concessi in lease ai client. È necessario utilizzare le esclusioni per tutti i dispositivi da configurare in modo statico. Gli intervalli esclusi devono includere tutti gli indirizzi IP assegnati manualmente ad altri server DHCP, client non DHCP, workstation prive di dischi o client Routing e Accesso remoto e PPP.

  • Creare prenotazioni.

    È possibile scegliere di prenotare alcuni indirizzi IP per l'assegnazione di lease permanenti a computer o dispositivi specificati della rete. È necessario effettuare prenotazioni solo per dispositivi abilitati per DHCP e che devono essere prenotati per scopi specifici nella rete, ad esempio server di stampa.

  • Regolare le durate del lease.

    È possibile modificare la durata del lease da utilizzare per l'assegnazione di lease di indirizzi IP. La durata predefinita è otto giorni.

    Il valore predefinito è accettabile per la maggior parte delle reti LAN ma può essere aumentato ulteriormente se i computer non sono soggetti a spostamenti frequenti. È inoltre possibile impostare una durata infinita per i lease, anche se è necessario prestare particolare attenzione.

  • Configurare le opzioni e le classi da utilizzare con l'ambito.

    Per offrire la configurazione completa per i client, è necessario configurare e abilitare le opzioni DHCP per l'ambito.

    Per una gestione discreta più avanzata dei client dell'ambito è possibile aggiungere o abilitare classi di opzioni definite dall'utente o dal fornitore.

Nota

  • Dopo aver definito e configurato un ambito, è necessario attivarlo per consentire al server DHCP di offrire servizi ai client. Non è tuttavia consigliabile attivare un nuovo ambito finché non sono state specificate le relative opzioni DHCP.

  • Dopo aver attivato un ambito, è opportuno non modificare l'intervallo di indirizzi dell'ambito.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP, ambiti e attivazione destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Ulteriori informazioni sull'autorizzazione di server DHCP in Servizi di dominio Active Directory

In Windows Server® 2008 il servizio Server DHCP è integrato in Active Directory per fornire l'autorizzazione per i server DHCP. Un server DHCP non autorizzato in una rete può causare il blocco delle operazioni di rete in seguito all'allocazione di opzioni di configurazione o indirizzi non corretti. Un server DHCP che è controller di dominio o membro di un dominio di Active Directory esegue una query per richiedere ad Active Directory l'elenco dei server autorizzati, identificati mediante l'indirizzo IP. Se il proprio indirizzo IP non è incluso nell'elenco di server DHCP autorizzati, il servizio Server DHCP non completa la sequenza di avvio e viene arrestato automaticamente.

Si tratta di un problema comunemente riscontrato dagli amministratori di rete che tentano di installare e configurare un server DHCP in un ambiente Active Directory senza prima autorizzare il server.

Nel caso di un server DHCP che non appartiene al dominio di Active Directory, il servizio Server DHCP invia un messaggio trasmesso DHCPInform per richiedere informazioni sul dominio radice di Active Directory in cui sono installati e configurati altri server DHCP. Altri server DHCP della rete rispondono con un messaggio DHCPAck che contiene le informazioni utilizzate dal server DHCP oggetto della query per individuare il dominio radice di Active Directory. Il server DHCP in fase di avvio esegue quindi una query per richiedere ad Active Directory un elenco dei server DHCP autorizzati e avvia il servizio Server DHCP solo se il proprio indirizzo è incluso nell'elenco.

Funzionamento del processo di autorizzazione

Il processo di autorizzazione per i computer server DHCP dipende dal ruolo installato del server nella rete. Sono disponibili tre ruoli o tipi di server in base ai quali è possibile installare ogni computer server:

  • Controller di dominio: il computer mantiene e gestisce una copia del database di Active Directory ed offre la gestione sicura degli account per utenti e computer appartenenti al dominio.

  • Server membro: il computer non funge da controller di dominio ma è stato aggiunto a un dominio in cui dispone di un account di appartenenza nel database di Active Directory.

  • Server autonomo: il computer non funge da controller di dominio o server membro in un dominio. Viene invece reso noto alla rete tramite un nome di gruppo di lavoro specificato, che può essere condiviso da altri computer ma utilizzato solo per la ricerca di computer e non per l'accesso protetto a risorse di dominio condivise.

Se si distribuisce Active Directory, tutti i computer che fungono da server DHCP devono essere controller di dominio o server membri di dominio prima che possano essere autorizzati e possano offrire servizi DHCP ai client.

Sebbene non sia consigliato, è possibile utilizzare un server autonomo come server DHCP purché non si trovi in una subnet che include server DHCP autorizzati. Quando un server DHCP autonomo rileva un server autorizzato nella stessa subnet, interrompe automaticamente il lease di indirizzi IP ai client DHCP.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Ulteriori informazioni sulla modalità senza stato di DHCPv6

Windows Server® 2008 supporta la funzionalità server DHCPv6 senza stato e con stato. I client in modalità senza stato di DHCPv6 utilizzano DHCPv6 per ottenere parametri di configurazione di rete diversi dall'indirizzo IPv6, ad esempio gli indirizzi del server DNS. I client configurano un indirizzo IPv6 mediante un meccanismo non basato su DHCPv6, ad esempio la configurazione automatica degli indirizzi IPv6 (basata sui prefissi IPv6 inclusi negli annunci dei router) oppure la configurazione degli indirizzi IP statici.

Nella modalità con stato di DHCPv6 i client acquisiscono sia l'indirizzo IPv6 che altri parametri di configurazione di rete mediante DHCPv6.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP e DHCPv6 destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Binding a una scheda di interfaccia di rete DHCP

Un server DHCP multihomed è un computer che esegue un sistema operativo Windows Server® 2008 in cui il servizio DHCP viene utilizzato per più di una singola connessione di rete. Affinché un computer server sia multihomed, ogni connessione di rete deve associare il computer a più di una singola rete fisica. A tale scopo è necessario installare nel computer hardware aggiuntivo, nel caso specifico più schede di rete.

Un computer che esegue un sistema operativo Windows Server 2008 può fungere da server DHCP multihomed. Per i server multihomed il servizio DHCP esegue il binding al primo indirizzo IP configurato in modo statico per ogni connessione di rete in uso.

Per impostazione predefinita, i binding del servizio variano a seconda che la prima connessione di rete sia configurata in modo dinamico o statico per TCP/IP. In base al metodo di configurazione utilizzato, indicato dalle impostazioni correnti nelle proprietà di Protocollo IP (TCP/IP), il servizio Server DHCP esegue i binding predefiniti nel modo seguente.

  • Se la prima connessione di rete utilizza un indirizzo IP specificato manualmente, la connessione verrà abilitata nei binding del server. A tale scopo, è necessario configurare un valore per l'indirizzo IP e selezionare l'opzione Utilizza il seguente indirizzo IP nelle proprietà di Protocollo IP (TCP/IP). In questo modo il server DHCP è in ascolto dei client DHCP e assicura loro il servizio.

  • Se la prima connessione di rete utilizza un indirizzo IP configurato in modo dinamico, la connessione verrà disabilitata nei binding del server. Tale situazione si verifica quando l'opzione Ottieni automaticamente un indirizzo IP è selezionata nelle proprietà di Protocollo IP (TCP/IP). Per i computer che eseguono Windows Server 2008 si tratta dell'impostazione predefinita. In questo modo il server DHCP non è in ascolto dei client DHCP e non assicura loro il servizio finché non viene configurato un indirizzo IP statico.

  • Il server DHCP eseguirà il binding al primo indirizzo IP statico configurato in ogni scheda.

Nota

  • Per impostazione predefinita, i binding del server DHCP vengono abilitati e disabilitati per singole connessioni e non per singoli indirizzi. Tutti i binding si basano sul primo indirizzo IP configurato per ogni connessione presente nella cartella Connessioni di rete. Se per la connessione applicabile vengono configurati ulteriori indirizzi IP statici, ad esempio quelli specificati nelle proprietà di Impostazioni avanzate TCP/IP, tali indirizzi non verranno mai utilizzati da server DHCP che eseguono Windows Server 2008 e saranno ininfluenti ai fini dei binding del server.

  • I server DHCP che eseguono Windows Server 2008 non eseguono mai il binding a nessuna delle interfacce abilitate per NDISWAN o DHCP utilizzate nel server. Tali interfacce non vengono visualizzate nella console DHCP nell'elenco dei binding del server perché non vengono mai utilizzate per il servizio DHCP. Solo le connessioni di rete aggiuntive per le quali è stato configurato un indirizzo IP statico primario possono essere incluse nell'elenco dei binding del server oppure abilitate o disabilitate tramite tale elenco.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP e sull'abilitazione o la disabilitazione selettiva dei binding del server DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Configurare la divisione degli ambiti

È possibile utilizzare questa procedura per dividere un ambito IPv4 DHCP.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators.

Per dividere un ambito DHCP

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare.

  3. Fare clic con il pulsante destro del mouse su IPv4 e quindi fare clic con il pulsante destro del mouse sull'ambito che si desidera dividere.

  4. Fare clic su Avanzate e quindi su Divisione ambiti.

  5. Seguire le istruzioni della Configurazione guidata divisione ambiti DHCP.

    Nota

    La Configurazione guidata divisione ambiti DHCP è disponibile solo per gli ambiti IPv4.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP e sull'abilitazione o la disabilitazione selettiva dei binding del server DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Configurare la protezione dei nomi

L'appropriazione indebita del nome o name squatting si verifica quando un computer non Windows viene registrato nel DNS (Domain Name System) con un nome già registrato per un computer Windows. L'utilizzo della protezione dei nomi in Windows Server impedisce il name squatting da parte dei computer non Windows. Il name squatting non rappresenta un problema per le reti Windows omogenee in cui è possibile utilizzare Servizi di dominio Active Directory per assegnare nomi riservati a utenti o computer.

La protezione dei nomi si basa sul DHCID (Dynamic Host Configuration Identifier) nel server DHCP (Dynamic Host Configuration Protocol) e sul supporto del nuovo record di risorse DHCID nel DNS. Il record di risorse DHCID è descritto da Internet Engineering Task Force (IETF) nelle RFC 4701 e 4703.

Il DHCID è un record di risorse (RR) archiviato nel DNS che esegue il mapping dei nomi per impedire la registrazione di nomi duplicati. Tale RR viene utilizzato da DHCP per archiviare un identificatore per un computer, insieme ad altre informazioni relative al nome quali i record A/AAAA del computer. La sua posizione unica nel processo di registrazione dei nomi consente a DHCP di richiedere tale corrispondenza e quindi di rifiutare la registrazione di un computer con un indirizzo diverso che tenti di registrare un nome con un record DHCID esistente.

Il DHCID previene le situazioni di name squatting seguenti:

  • Name squatting di un server da parte di un client

  • Name squatting di un server da parte di un altro server

  • Name squatting di un client da parte di un altro client

  • Name squatting di un client da parte di un server

Verrà inoltre aggiunto il supporto per DUID (DHCP Unique Identifier) alla registrazione IPv4 nel client DHCP. Il DUID è descritto da Internet Engineering Task Force (IETF) nella RFC 4361.

La protezione dei nomi può essere configurata per IPv4 e IPv6 a livello di scheda di rete o a livello di ambito. Le impostazioni di protezione dei nomi configurate a livello di ambito hanno la precedenza sulle impostazioni configurate a livello di IPv4 o IPv6. Se la protezione dei nomi a livello di ambito non è configurata, l'impostazione a livello della scheda di rete IPv4 o IPv6 avrà la precedenza. Il DHCID protegge i nomi in base all'ordine cronologico con cui li riceve.

Per attivare la protezione dei nomi a livello di nodo IPv4 o IPv6

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare clic con il pulsante destro del mouse su IPv4 o IPv6 e quindi scegliere Proprietà.

  3. Fare clic su DNS, su Avanzate e quindi selezionare Attiva protezione dei nomi.
Per attivare la protezione dei nomi a livello di ambito

  1. Aprire la console DHCP.

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare doppio clic su IPv4 o IPv6, fare clic con il pulsante destro del mouse sull'ambito desiderato e quindi scegliere Proprietà.

  3. Fare clic su DNS, su Configura e quindi selezionare Attiva protezione dei nomi.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Configurare la funzionalità di filtro del livello di collegamento

La funzionalità di filtro del livello di collegamento consente il controllo dell'accesso alla rete per il rilascio o rifiuto di lease DHCP di indirizzi IP basati su un indirizzo MAC (Media Access Control). Tale funzionalità può essere configurata a livello di nodo IPv4 per tutti i client in tutti gli ambiti IPv4. È attualmente disponibile solo per le reti IPv4.

Per abilitare il filtro degli indirizzi MAC

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare clic con il pulsante destro del mouse su IPv4 e quindi scegliere Proprietà.

  3. Fare clic su Filtri e quindi selezionare la casella di controllo Attiva elenco indirizzi consentiti o Attiva elenco indirizzi non consentiti.
Per configurare un nuovo filtro

  1. Aprire lo snap-in DHCP.

  2. Nell'albero della console fare doppio clic sul server DHCP appropriato, su IPv4, su Filtri e quindi fare clic con il pulsante destro del mouse su Consenti o su Nega.

  3. Fare clic su Nuovo filtro e quindi digitare le informazioni appropriate nelle caselle Indirizzo MAC e Descrizione. Descrizione è un campo facoltativo.
Note
  • L'indirizzo MAC può essere l'indirizzo completo o una sequenza di indirizzi MAC (caratteri jolly). Di seguito sono elencati i caratteri jolly validi per gli indirizzi MAC:
    • 00-1C-23-*-*-*

    • 00-1C-23-20-AF-*

    • 00-1C-23-20-*-*

    • 001C2320AF4E

    • 001C*

Nota

Il filtro degli indirizzi non consentiti ha la precedenza sul filtro degli indirizzi consentiti.

Per modificare il tipo di hardware con esenzione dall'elenco di filtro

  1. Aprire lo snap-in DHCP.

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare clic con il pulsante destro del mouse su IPv4 e quindi scegliere Proprietà.

  3. Fare clic su Filtri, su Avanzate e quindi selezionare o deselezionare le caselle di controllo relative ai tipi di hardware che si desidera modificare.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Configurare un ambito DHCP

Un ambito è un raggruppamento amministrativo di indirizzi IP per i computer di una subnet che utilizzano il servizio DHCP (Dynamic Host Configuration Protocol). L'amministratore crea innanzitutto un ambito per ogni subnet fisica e quindi utilizza l'ambito per definire i parametri utilizzati dai client. Un ambito presenta le proprietà seguenti:

  • Un intervallo di indirizzi IP da cui includere o escludere indirizzi utilizzati per le offerte di lease del servizio DHCP.

  • Una subnet mask, che determina la subnet per un indirizzo IP specifico.

  • Un nome di ambito.

  • Valori di durata del lease, che vengono assegnati ai client DHCP che ricevono indirizzi IP allocati in modo dinamico.

  • Eventuali opzioni dell'ambito DHCP configurate per l'assegnazione a client DHCP, ad esempio il server DNS (Domain Name System), l'indirizzo IP del router e l'indirizzo del server WINS (Windows Internet Name Service).

  • Prenotazioni, utilizzate facoltativamente per garantire che un client DHCP riceva sempre lo stesso indirizzo IP.

Operazioni preliminari all'aggiunta di ambiti

Un ambito DHCP è costituito da un pool di indirizzi IP in una subnet specifica, ad esempio da 192.168.0.1 a 192.168.0.254, che il server DHCP può concedere in lease ai client.

Per ogni subnet può esistere solo un singolo ambito DHCP con un intervallo continuo di indirizzi IP. Per utilizzare più intervalli di indirizzi in un singolo ambito o una singola subnet per il servizio DHCP, è necessario definire prima l'ambito e quindi impostare eventuali intervalli di esclusione necessari:

  • Definire l'ambito

    Utilizzare l'intero intervallo di indirizzi IP consecutivi che costituiscono la subnet IP locale per la quale abilitare il servizio DHCP.

  • Impostare gli intervalli di esclusione

    Impostare intervalli di esclusione per tutti gli indirizzi IP compresi nell'ambito che non si desidera vengano offerti o utilizzati dal server DHCP per l'assegnazione DHCP. È ad esempio possibile escludere i primi 10 indirizzi nell'ambito di esempio precedente per creare un'esclusione per gli indirizzi compresi tra 192.168.0.1 e 192.168.0.10.

    L'impostazione di un intervallo di esclusione per questi indirizzi consente di specificare che tali indirizzi non vengano mai offerti ai client DHCP quando richiedono un indirizzo IP dal server. Gli indirizzi IP esclusi possono essere attivi nella rete, tuttavia solo se vengono configurati manualmente negli host che non utilizzano DHCP per ottenere un indirizzo.

Creare ambiti

Per creare un nuovo ambito DHCP, è possibile utilizzare la procedura seguente.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators.

Per creare un nuovo ambito DHCP

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare.

  3. Fare clic con il pulsante destro del mouse su IPv4 o IPv6 e quindi scegliere Nuovo ambito.

  4. Seguire le istruzioni della Creazione guidata ambito.

Ulteriori considerazioni

Prima di creare l'ambito, determinare gli indirizzi IP iniziale e finale da utilizzare all'interno dell'ambito.

In base a tali indirizzi, la console DHCP suggerisce una subnet mask predefinita utile per la maggior parte delle reti. Se si è certi che per la rete è necessaria una subnet mask diversa, è possibile modificare il valore secondo necessità.

Al termine della creazione di un nuovo ambito, potrebbe essere necessario completare ulteriori attività, ad esempio l'attivazione dell'ambito per l'utilizzo o l'assegnazione di opzioni di ambito.

Utilizzare la regola 80/20 per gli ambiti

Per bilanciare l'utilizzo del server DHCP, è consigliabile utilizzare la regola "80/20" per dividere gli indirizzi dell'ambito tra i due server DHCP. Se il server 1 è configurato per rendere disponibili la maggior parte, ovvero circa l'80%, degli indirizzi, è possibile configurare il server 2 per rendere disponibili ai client gli altri indirizzi, ovvero circa il 20%. Per ulteriori informazioni, vedere Bilanciare il carico sui server DHCP mediante l'utilizzo della regola 80/20 per gli ambiti nel sito Web Microsoft TechNet all'indirizzo http://go.microsoft.com/fwlink/?LinkId=125700.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito WebMicrosoft TechNet.


Configurare un ambito multicast DHCP

Il multicasting è il processo che consente l'invio del traffico di rete a un gruppo di host di endpoint di destinazione. Solo i membri del gruppo di host di endpoint in ascolto del traffico multicast (il gruppo multicast) elaborano il traffico multicast. Tutti gli altri host di nodi ignorano il traffico multicast.

Gli ambiti multicast vengono supportati tramite MADCAP (Multicast Address Dynamic Client Allocation Protocol), un protocollo utilizzato per l'assegnazione di indirizzi multicast. Il protocollo MADCAP descrive come l'allocazione di indirizzi multicast o i server MADCAP consentano di assegnare in modo dinamico indirizzi IP ad altri computer (client MADCAP) della rete.

Un server MADCAP è in genere anche un server multicast (MCS) utilizzato per supportare il multicasting IP. Un server MCS gestisce l'utilizzo condiviso o di gruppo dell'indirizzo IP multicast assegnato e trasmette il traffico di dati ai membri che condividono l'utilizzo dell'indirizzo di gruppo specificato.

Dopo che un server MCS è stato configurato e ha assegnato un indirizzo di gruppo da utilizzare, tutti i client multicast che hanno registrato la propria appartenenza al server MCS possono ricevere i flussi inviati a questo indirizzo. Registrandosi con il server MCS, i client possono essere inclusi efficacemente nel processo del flusso, ad esempio in trasmissioni di rete di dati audio o video in tempo reale. Il server MCS gestisce inoltre l'elenco di gruppi multicast, aggiornando la propria appartenenza e il proprio stato in modo che il traffico multicast venga ricevuto da tutti i membri correnti.

È possibile utilizzare questa procedura per creare un ambito multicast.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators.

Per creare un ambito multicast

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare clic sul server DHCP che si desidera configurare.

  3. Scegliere Nuovo ambito multicast dal menu Azione.

  4. Seguire le istruzioni della Creazione guidata ambito multicast.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Configurare un ambito esteso DHCP

Un ambito esteso è una funzionalità amministrativa dei server DHCP (Dynamic Host Configuration Protocol) che eseguono Windows Server 2008, che è possibile creare e gestire utilizzando lo snap-in MMC (Microsoft Management Console) DHCP. Un ambito esteso consente di raggruppare più ambiti come singola entità amministrativa. Tramite questa funzionalità un server DHCP è in grado di:

  • Supportare client DHCP su un singolo segmento della rete fisica, ad esempio un segmento di una LAN Ethernet, dove vengono utilizzate più reti IP logiche. Le configurazioni per le quali in ogni subnet o rete fisica viene utilizzata più di una rete IP logica sono spesso dette multinet o configurazioni multiple di rete.

  • Supportare client DHCP remoti situati sul lato opposto degli agenti di inoltro DHCP e BOOTP, dove la rete sul lato opposto dell'agente di inoltro utilizza configurazioni multiple di rete.

Nelle configurazioni multiple di rete è possibile utilizzare gli ambiti estesi DHCP per raggruppare e attivare singoli intervalli di ambito degli indirizzi IP utilizzati in rete. In questo modo, il server DHCP può attivare e fornire i lease da più di un ambito ai client in una singola rete fisica.

Gli ambiti estesi consentono di risolvere tipi specifici di problemi di distribuzione DHCP per multinet, incluse le situazioni in cui:

  • Il pool di indirizzi disponibili per un ambito attualmente attivo è quasi esaurito ed è necessario aggiungere altri computer alla rete. L'ambito originale include l'intervallo indirizzabile completo per una sola rete IP di una classe di indirizzi specificata. È necessario utilizzare un altro intervallo di indirizzi IP per estendere lo spazio degli indirizzi per lo stesso segmento della rete fisica.

  • È necessario eseguire nel tempo la migrazione dei client a un nuovo ambito, ad esempio per rinumerare la rete IP corrente da un intervallo di indirizzi utilizzato in un ambito attivo esistente in nuovo ambito contenente un altro intervallo di indirizzi IP.

  • Si desidera utilizzare due server DHCP nello stesso segmento della rete fisica per gestire reti IP logiche separate.

Configurazioni di ambiti estesi per multinet

Nella sezione seguente viene illustrato come una semplice rete DHCP costituita in origine da un segmento di rete fisica e da un server DHCP possa essere estesa per utilizzare ambiti estesi per il supporto delle configurazioni multiple di rete.

Esempio 1: server DHCP senza routing (prima dell'ambito esteso)

In questo esempio una rete locale (LAN) di piccole dimensioni con un server DHCP supporta una sola subnet fisica, denominata Subnet A. In questa configurazione il server DHCP è limitato al lease degli indirizzi ai client in questa stessa subnet fisica.

Nella figura seguente viene illustrata questa rete di esempio nello stato originale. Attualmente nessun ambito esteso è stato aggiunto ed è utilizzato un solo ambito, Ambito 1, per soddisfare le richieste di tutti i client DHCP nella Subnet A.

Subnet singola e server DHCP (prima dell'ambito esteso)

Esempio 2: ambito esteso per il server DHCP senza routing che supporta multinet locali

Per includere le multinet implementate per i computer client nella Subnet A, ovvero lo stesso segmento di rete in cui si trova il server DHCP, è possibile configurare un ambito esteso che include come membri l'ambito originale (Ambito 1) e gli ambiti aggiuntivi per le multinet logiche per cui è necessario aggiungere il supporto (Ambito 2 e Ambito 3).

In questa figura viene illustrata la configurazione dell'ambito e dell'ambito esteso per il supporto delle configurazioni multiple di rete nella stessa rete fisica (Subnet A) del server DHCP.

Ambito esteso per un server DHCP non indirizzato

Esempio 3: ambito esteso per il server DHCP con routing con l'agente di inoltro che supporta le configurazioni multiple di rete

Per includere le multinet implementate per i computer client nella Subnet B, ovvero il segmento di rete remota posto dal server DHCP nella Subnet A attraverso un router, è possibile configurare un ambito esteso che include come membri gli ambiti aggiuntivi per le multinet logiche per cui è necessario aggiungere il supporto remoto (Ambito 2 e Ambito 3).

Poiché le multinet sono relative alla rete remota (Subnet B), non è necessario che l'ambito originale (Ambito 1) faccia parte dell'ambito esteso aggiunto.

In questa figura viene illustrata la configurazione dell'ambito e dell'ambito esteso per il supporto delle multinet nella rete fisica remota (Subnet B) lontano dal server DHCP. Un agente di inoltro DHCP viene utilizzato per i server DHCP per supportare i client nelle subnet remote.

Ambito esteso per il server DHCP indirizzato

Creare un ambito esteso

Per creare un ambito esteso DHCP, è possibile utilizzare la procedura seguente.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators.

Per creare un ambito esteso

  1. Aprire lo snap-in DHCP.

  2. Nell'albero della console fare clic sul server DHCP che si desidera configurare.

  3. Scegliere Nuovo ambito esteso dal menu Azione.

    Questa voce di menu viene visualizzata solo se nel server DHCP è stato creato almeno un ambito che attualmente non fa parte di un ambito esteso.

  4. Seguire le istruzioni della Creazione guidata ambito esteso.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito WebMicrosoft TechNet.


Ulteriori informazioni sulle opzioni DHCP predefinite

Le classi di opzione DHCP (Dynamic Host Configuration Protocol) offrono un metodo aggiuntivo per raggruppare i dettagli della configurazione per i client DHCP all'interno di un ambito. Esistono due tipi di classi di opzione DHCP:

  • Classi utente, per l'assegnazione di opzioni ai client che necessitano di un'analoga configurazione delle opzioni DHCP.

  • Classi fornitore, per l'assegnazione di opzioni specifiche dei fornitori ai client che condividono un tipo di fornitore comunemente definito.

Gestire le classi utente

Le classi utente consentono ai client DHCP di differenziarsi specificando un'opzione Classe utente. Se disponibile per l'utilizzo client, questa opzione include un ID classe determinato dall'utente che consente di raggruppare i client con analoghe esigenze di configurazione all'interno di un ambito. È possibile, ad esempio, supportare utenti e computer con esigenze di mobilità configurando una classe utente nel server DHCP e impostando il relativo ID di classe nei computer client.

Una classe utente è utile quando è necessario tenere separate le opzioni relative a esigenze specifiche di identificazione dei computer client, ad esempio quella di garantire una durata del lease più breve per i computer portatili che vengono spostati di frequente o utilizzano spesso l'accesso remoto. In questo esempio è possibile configurare il server DHCP per la distribuzione di opzioni specifiche per le esigenze di tali client.

La funzionalità della classe utente offre una maggiore flessibilità nella configurazione dei client DHCP in rete, ma non è necessaria per l'utilizzo standard di DHCP. Se le classi di opzione definite dall'utente non sono configurate, le opzioni vengono invece implementate attraverso le impostazioni delle opzioni server, di ambito o client standard.

I server DHCP che eseguono Windows Server® 2008, che supporta il riconoscimento degli ID di classe utente, eseguono i passaggi aggiuntivi seguenti quando i client richiedono un indirizzo IP:

  1. Il server determina se la classe utente identificata dal client nella richiesta di lease è una classe riconosciuta, definita in precedenza sul server.

    Se nel server esiste ed è configurata una classe utente predefinita, viene abilitata l'assegnazione basata su classe. Le altre classi utente devono innanzitutto essere aggiunte e configurate nel server prima che siano disponibili per l'utilizzo.

  2. Se la classe utente è riconosciuta, il server determina se per questa classe sono configurate altre opzioni DHCP nel contesto di lease attivo (l'ambito o una prenotazione client) in cui il server assegna il lease al client.

  3. Se il contesto dell'ambito o della prenotazione è configurato per implementare le opzioni per la classe definita dall'utente del client, il server restituisce le opzioni al client nel messaggio di riconoscimento DHCP (DHCPACK), inviato per confermare il lease.

    Nota

    Oltre a configurare o aggiungere le classi utente nel server DHCP, è possibile impostare un identificatore di classe client DHCP con il comando ipconfig /setclassid.

Altri esempi di classe utente

È possibile definire identificatori di classe utente per trasmettere informazioni sulla configurazione del software client, sull'ubicazione fisica o sulle preferenze utente. Un identificatore, ad esempio, può specificare che i client DHCP sono membri di una classe definita dall'utente denominata "secondo piano, ovest," che necessita di un insieme speciale di impostazioni per router, DNS (Domain Name System) e server WINS (Windows Internet Name Service).

È inoltre possibile utilizzare le classi utente predefinite di Microsoft per isolare i dettagli della configurazione specifici dei client con esigenze particolari, ad esempio BOOTP (Bootstrap Protocol) o il servizio Routing e accesso remoto.

Note
  • Quando si configurano le classi utente nel server DHCP, verificare che i dati degli ID delle classi utente impostati sia nel server DHCP che nei computer client membri corrispondano esattamente ai dati ASCII o binari.
  • L'opzione della classe utente consente di utilizzare un solo ID di classe per identificare i client. Ogni computer client può essere identificato solo come membro di una singola classe utente nel server DHCP. È possibile utilizzare ulteriori classi utente e creare ibridi dalle altre classi utente, in base alle necessità.

Gestire le classi fornitore

Le classi di opzione definite dal fornitore possono essere utilizzate dai client DHCP che si identificano al server DHCP in base al tipo di fornitore quando ottengono un lease. Per identificare la propria appartenenza a una classe fornitore, un client specifica un valore nell'opzione Vendor class identifier quando richiede o seleziona un lease dal server.

Le informazioni dell'identificatore della classe fornitore sono costituite da una stringa di dati di tipo carattere interpretati da un server DHCP. Microsoft supporta l'identificazione della classe fornitore per i client DHCP che eseguono Windows 7Microsoft Windows Vista e Windows XP.

Altri fornitori potrebbero scegliere di definire i propri ID di classe fornitore specifici per trasmettere informazioni specifiche dei fornitori o gestire particolari esigenze per i client DHCP.

I server DHCP che eseguono Windows Server 2008, che supporta il riconoscimento degli ID di classe fornitore, eseguono i passaggi aggiuntivi seguenti quando i client richiedono un indirizzo IP:

  1. Il server determina se la classe fornitore identificata dal client nella richiesta di lease è una classe riconosciuta, definita in precedenza sul server.

    Solo le classi fornitore di Microsoft sono predefinite nel server. Per le altre classi fornitore, è necessario aggiungere e configurare manualmente queste opzioni nei server DHCP che eseguono Windows Server 2008 prima che siano disponibili per l'utilizzo.

  2. Se la classe fornitore è riconosciuta, il server determina se per questa classe sono configurate altre opzioni DHCP nel contesto di lease attivo (l'ambito o una prenotazione client) in cui il server assegna il lease al client.

  3. Se il contesto dell'ambito o della prenotazione è configurato per implementare le opzioni per la classe del client definita dal fornitore, il server restituisce le opzioni utilizzando l'opzione Vendor specific information nel messaggio di riconoscimento DHCP (DHCPACK), inviato per confermare il lease.

Le classi fornitore consentono ad altri fornitori di sistemi di supportare applicazioni personalizzate per DHCP in ambienti con fornitori misti. Le opzioni specifiche dei fornitori, se implementate, vengono utilizzate in aggiunta alle opzioni DHCP standard assegnate o necessarie per DHCP.

Note
  • La classe fornitore predefinita, che corrisponde alle opzioni standard DHCP, può essere utile per raggruppare eventuali client DHCP che non specificano gli ID di classe fornitore.
  • Quando si aggiungono nuove classi fornitore nel server DHCP, verificare che i dati degli ID di classe fornitore impostati nel server corrispondano all'ID di classe fornitore utilizzato dai client per il fornitore. Per ulteriori informazioni, rivolgersi al fornitore appropriato.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito WebMicrosoft TechNet.


Attività consigliate per il ruolo server DHCP

Le attività seguenti consentono di garantire una maggior sicurezza, affidabilità e gestibilità del ruolo Server DHCP. Molte di tali attività implicano la configurazione di DHCP unitamente a un'altra tecnologia o funzionalità di Windows Server® 2008, ad esempio Active Directory o Protezione accesso alla rete, mentre in altre viene descritto come progettare l'infrastruttura DHCP per garantire la massima efficienza.

  • Migliorare la tolleranza di errore mediante la divisione degli ambiti DHCP

  • Eliminare la necessità di aggiornamenti manuali di record DNS mediante la configurazione di aggiornamenti dinamici e aggiornamenti dinamici sicuri

  • Consentire l'amministrazione remota di server DHCP mediante la configurazione di porte di Windows Firewall

  • Prevenire server DHCP non autorizzati in rete mediante l'autorizzazione dei server DHCP in Servizi di dominio Active Directory

  • Imporre criteri di accesso alla rete in base all'integrità dei client mediante la configurazione di DHCP con Protezione accesso alla rete

  • Automatizzare la gestione di dispositivi con indirizzi IP statici mediante la creazione di prenotazioni DHCP

  • Supportare più subnet con un unico server DHCP mediante la configurazione di agenti di inoltro DHCP

  • Evitare di riconfigurare DHCP in un nuovo server mediante la migrazione di un'infrastruttura DHCP esistente

  • Bilanciare il carico sui server DHCP mediante l'utilizzo della regola 80/20 per gli ambiti

  • Centralizzare la gestione di due o più server DHCP come un unico sistema mediante l'inserimento dei server DHCP in un cluster

Informazioni aggiuntive

Per informazioni aggiornate e dettagliate su DHCP e sui ruoli server destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Migliorare la tolleranza di errore mediante la divisione degli ambiti DHCP

È consigliabile dividere un ambito tra due o tre server in modo che uno dei server possa gestire più facilmente il traffico DHCP e impedire che l'eventuale malfunzionamento di un server influisca sulla rete. Una divisione 80/20 sembra essere quella ottimale.

Si consideri ad esempio un ambito di classe B 132.255.0.0 il cui intervallo di indirizzi è compreso tra 132.255.0.1 e132.255.255.255 e la cui subnet mask è 255.255.0.0. Una configurazione può prevedere la distribuzione del carico tra due server (SRV1 e SRV2). L'ambito di SRV1 è compreso tra 132.255.0.1 e132.255.255.255, mentre la mask è 255.255.0.0. L'intervallo di esclusione per questo ambito è compreso tra 132.255.128.0 e 132.255.255.255. L'ambito di SRV2 è invece compreso tra 132.255.0.1 e132.255.255.255, mentre la mask è 255.255.0.0. L'intervallo di esclusione per questo ambito è compreso tra 132.255.0.1 e 132.127.255.255. È inoltre possibile dividere un ambito tra tre server in modo simile.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Eliminare la necessità di aggiornamenti manuali di record DNS mediante la configurazione di aggiornamenti dinamici e aggiornamenti dinamici sicuri

Con Windows Server 2008 un server DHCP può abilitare gli aggiornamenti dinamici nello spazio dei nomi DNS per uno qualsiasi dei client che supportano tali aggiornamenti. I client dell'ambito possono utilizzare il protocollo di aggiornamento dinamico DNS per aggiornare le informazioni relative al mapping nome-indirizzo dell'host in caso di modifiche all'indirizzo assegnato da DHCP. Le informazioni sul mapping sono archiviate in zone del server DNS. Un server DHCP basato su Windows Server 2008 può eseguire aggiornamenti su qualsiasi server DNS per conto dei relativi client DHCP.

Funzionamento dell'interazione tra aggiornamenti DHCP/DNS

È possibile utilizzare il server DHCP per registrare e aggiornare i record di risorse PTR e A per conto dei client DHCP del server. In tal caso è necessario utilizzare un'opzione DHCP aggiuntiva, ovvero quella relativa all'FQDN del client (opzione 81). Questa opzione consente al client di inviare il proprio FQDN al server DHCP nel pacchetto DHCPREQUEST. In questo modo il client può notificare al server DHCP informazioni in merito al livello di servizio richiesto.

L'opzione FQDN include i sei campi seguenti:

  1. Codice: specifica il codice relativo a questa opzione (81).

  2. Lunghezza: specifica la lunghezza di questa opzione. È necessario specificare almeno 4.

  3. Flag: specifica il tipo di servizio.

    • 0: il client registrerà il record "A" (Host).

    • 1: il client desidera che il record "A" (Host) venga registrato da DHCP.

    • 3: DHCP registrerà il record "A" (Host) indipendentemente dalla richiesta del client.

  4. RCODE1: specifica un codice di risposta che il server invia al client.

  5. RCODE2: specifica un'ulteriore descrizione di RCODE1.

  6. Nome dominio: specifica l'FQDN del client.

Se il client richiede di eseguire la registrazione dei record di risorse con DNS, dovrà generare la richiesta UPDATE dinamica secondo quanto previsto dalla Request for Comments (RFC) 2136. Il server DHCP registrerà quindi il relativo record PTR (puntatore).

Si presupponga che questa opzione sia stata inviata da un client DHCP qualificato, ad esempio un computer abilitato per DHCP che esegue Microsoft Windows Vista, Windows 2000 o Windows XP. In questo caso l'opzione verrà elaborata e interpretata da server DHCP basati su Windows Server 2008 per determinare in che modo il server inizializzerà gli aggiornamenti per conto del client.

Proteggere gli aggiornamenti dinamici

In Windows Server 2008 la sicurezza degli aggiornamenti DNS è disponibile solo per le zone integrate in Active Directory. Dopo aver integrato una zona, è possibile utilizzare le funzionalità di modifica degli elenchi di controllo di accesso disponibili nello snap-in DNS per aggiungere o rimuovere utenti o gruppi dall'elenco di controllo di accesso per una zona specifica o per un record di risorse.

Per impostazione predefinita, la sicurezza degli aggiornamenti dinamici per client e server DNS basati su Windows Server 2008 viene gestita nel modo seguente:

  1. I client DNS basati su Windows Server 2008 tentano di utilizzare prima gli aggiornamenti dinamici non sicuri. Se l'aggiornamento non sicuro viene rifiutato, i client tentano di utilizzare un aggiornamento sicuro.

    I client utilizzano inoltre criteri di aggiornamento predefiniti in base ai quali possono tentare di sovrascrivere un record di risorse registrato in precedenza a meno che non siano bloccati in modo specifico dalla sicurezza degli aggiornamenti.

  2. Per impostazione predefinita, dopo che una zona è diventata integrata in Active Directory, i server DNS basati su Windows Server 2008 consentono solo aggiornamenti dinamici sicuri.

    Per impostazione predefinita, quando si utilizza l'archiviazione standard delle zone, il servizio Server DNS non consente gli aggiornamenti dinamici nelle relative zone. Per le zone integrate in Active Directory o che utilizzano l'archiviazione standard basata su file, è possibile modificare la zona in modo da consentire tutti gli aggiornamenti dinamici. In tal modo, consentendo l'utilizzo di aggiornamenti sicuri, tutti gli aggiornamenti verranno accettati.

Se si utilizzano più server DHCP basati su Windows Server 2008 nella rete e si configurano le zone per consentire solo gli aggiornamenti dinamici sicuri, utilizzare lo snap-in Utenti e computer di Active Directory per aggiungere i computer server DHCP al gruppo DnsUpdateProxy predefinito. Tutti i server DHCP disporranno pertanto dei diritti di sicurezza per eseguire gli aggiornamenti del proxy per uno qualsiasi dei client DHCP.

Attenzione
  • La funzionalità degli aggiornamenti dinamici sicuri può risultare compromessa in presenza delle condizioni seguenti:
  • Si esegue un server DHCP in un controller di dominio basato su Windows Server 2008.
  • Il server DHCP è configurato in modo da eseguire la registrazione dei record DNS per conto dei relativi client.
  • Per evitare questo problema, distribuire i server DHCP e i controller di dominio in computer diversi oppure configurare il server DHCP in modo che utilizzi un account utente dedicato per gli aggiornamenti dinamici.
Nota

La funzionalità degli aggiornamenti dinamici sicuri è supportata solo per le zone integrate in Active Directory. Se si configura un tipo di zona diverso, sarà necessario modificarlo e integrare la zona prima di poterla proteggere per gli aggiornamenti DNS. La funzionalità di aggiornamento dinamico è un'estensione dello standard DNS conforme a RFC. Il processo di aggiornamento in DNS è definito nel documento RFC 2136 relativo agli aggiornamenti dinamici in DNS (DNS UPDATE).

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito WebMicrosoft TechNet.


Consentire l'amministrazione remota di server DHCP mediante la configurazione di porte di Windows Firewall

Windows Firewall è un firewall host con stato che blocca tutto il traffico TCP/IP in ingresso indesiderato, incluso quello IPv4 (Internet Protocol versione 4) e IPv6 (Internet Protocol versione 6). Se si abilita Windows Firewall in un server e si desidera gestire il server con uno strumento di amministrazione remota, è in genere necessario configurare le impostazioni di Windows Firewall nel server in modo che possa ricevere traffico indesiderato dallo strumento di amministrazione remota. Può inoltre essere necessario configurare le impostazioni di Windows Firewall nel computer che esegue lo strumento di amministrazione remota se Windows Firewall è abilitato anche in tale computer. Sebbene sia possibile configurare manualmente le impostazioni di Windows Firewall, è consigliabile utilizzare la Configurazione guidata impostazioni di sicurezza.

Per utilizzare uno strumento di amministrazione remota con Windows Firewall, è in genere necessario aggiungere un programma o una porta all'elenco di eccezioni di Windows Firewall. Quando si aggiunge un programma o una porta all'elenco di eccezioni, si indica a Windows Firewall di consentire al traffico in ingresso indesiderato di raggiungere il programma specificato o di passare attraverso la porta specificata. In alcuni casi può essere necessario configurare un'impostazione del Registro di sistema o abilitare una delle eccezioni preconfigurate di Windows Firewall, ad esempio quella relativa a Condivisione file e stampanti o all'amministrazione remota.

Attenzione

L'eccezione relativa all'amministrazione remota consente il passaggio del traffico attraverso numerose porte, rendendo il computer più esposto a possibili attacchi. Vedere la documentazione di Windows Firewall per informazioni dettagliate sui rischi connessi all'utilizzo di tale eccezione. La modifica non corretta del Registro di sistema può danneggiare gravemente il sistema. Prima di apportare modifiche al Registro di sistema, eseguire il backup di tutti i dati rilevanti presenti nel computer.

Per amministrare un server DHCP in remoto da un altro server DHCP oppure per utilizzare il pacchetto degli strumenti di amministrazione per amministrare un server DHCP in remoto, aggiungere Tcpsvcs.exe e le porte UDP 67 e 2535 all'elenco di eccezioni di Windows Firewall nel server di destinazione.

Le regole di eccezione in ingresso del firewall elencate di seguito vengono abilitate durante e dopo l'installazione del ruolo Server DHCP per consentire l'amministrazione remota del server DHCP:

  • Server DHCP (RPC-In)

  • Server DHCP (RPCCS-In)

Quando il ruolo Server DHCP viene disinstallato, le regole di eccezione in ingresso del firewall verranno rimosse, impedendo l'amministrazione remota.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP e Windows Firewall destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Prevenire server DHCP non autorizzati in rete mediante l'autorizzazione dei server DHCP in Servizi di dominio Active Directory

In Windows Server® 2008 il servizio Server DHCP è integrato in Active Directory per fornire l'autorizzazione per i server DHCP. Un server DHCP non autorizzato in una rete può causare il blocco delle operazioni di rete in seguito all'allocazione di opzioni di configurazione o indirizzi non corretti. Un server DHCP che è controller di dominio o membro di un dominio di Active Directory esegue una query per richiedere ad Active Directory l'elenco dei server autorizzati, identificati mediante l'indirizzo IP. Se il proprio indirizzo IP non è incluso nell'elenco di server DHCP autorizzati, il servizio Server DHCP non completa la sequenza di avvio e viene arrestato automaticamente.

Si tratta di un problema comunemente riscontrato dagli amministratori di rete che tentano di installare e configurare un server DHCP in un ambiente Active Directory senza prima autorizzare il server.

Nel caso di un server DHCP che non appartiene al dominio di Active Directory, il servizio Server DHCP invia un messaggio trasmesso DHCPInform per richiedere informazioni sul dominio radice di Active Directory in cui sono installati e configurati altri server DHCP. Altri server DHCP della rete rispondono con un messaggio DHCPAck che contiene le informazioni utilizzate dal server DHCP oggetto della query per individuare il dominio radice di Active Directory. Il server DHCP in fase di avvio esegue quindi una query per richiedere ad Active Directory un elenco dei server DHCP autorizzati e avvia il servizio Server DHCP solo se il proprio indirizzo è incluso nell'elenco.

Funzionamento del processo di autorizzazione

Il processo di autorizzazione per i computer server DHCP dipende dal ruolo installato del server nella rete. Sono disponibili tre ruoli o tipi di server in base ai quali è possibile installare ogni computer server:

  • Controller di dominio: il computer mantiene e gestisce una copia del database di Active Directory ed offre la gestione sicura degli account per utenti e computer appartenenti al dominio.

  • Server membro: il computer non funge da controller di dominio ma è stato aggiunto a un dominio in cui dispone di un account di appartenenza nel database di Active Directory.

  • Server autonomo: il computer non funge da controller di dominio o server membro in un dominio. Viene invece reso noto alla rete tramite un nome di gruppo di lavoro specificato, che può essere condiviso da altri computer ma utilizzato solo per la ricerca di computer e non per l'accesso protetto a risorse di dominio condivise.

Se si distribuisce Active Directory, tutti i computer che fungono da server DHCP devono essere controller di dominio o server membri di dominio prima che possano essere autorizzati e possano offrire servizi DHCP ai client.

Sebbene non sia consigliato, è possibile utilizzare un server autonomo come server DHCP purché non si trovi in una subnet che include server DHCP autorizzati. Quando un server DHCP autonomo rileva un server autorizzato nella stessa subnet, interrompe automaticamente il lease di indirizzi IP ai client DHCP.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Imporre criteri di accesso alla rete in base all'integrità dei client mediante la configurazione di DHCP con Protezione accesso alla rete

La piattaforma Protezione accesso alla rete fornisce i componenti per l'imposizione di criteri mediante i quali i computer che si connettono a una rete o comunicano con essa devono soddisfare i requisiti di integrità del sistema definiti dall'amministratore. Utilizzando Protezione accesso alla rete di DHCP è possibile scegliere di limitare l'accesso a una rete con restrizioni ai computer che non soddisfano i requisiti. La rete con restrizioni contiene le risorse necessarie per aggiornare i computer in modo che siano conformi ai requisiti di integrità per l'accesso illimitato alla rete e le normali comunicazioni.

Con l'imposizione DHCP solo un computer conforme ai requisiti può ottenere da un server DHCP una configurazione di indirizzi IP per l'accesso illimitato. Per i computer non conformi l'accesso di rete è limitato da una configurazione di indirizzi IP che consente l'accesso solo alla rete con restrizioni. Con l'imposizione DHCP i requisiti dei criteri di integrità vengono imposti ogni volta che un client DHCP tenta di eseguire il lease o di rinnovare una configurazione di indirizzi IP. L'imposizione DHCP consente inoltre di monitorare attivamente lo stato di integrità del client Protezione accesso alla rete e di rinnovare la configurazione dell'indirizzo IPv4 per l'accesso solo alla rete con restrizioni qualora il client diventi non conforme.

Funzionamento dell'imposizione DHCP

Il processo seguente descrive il funzionamento dell'imposizione DHCP per un client Protezione accesso alla rete che tenta di utilizzare una configurazione DHCP iniziale.

  1. Il client Protezione accesso alla rete invia al server DHCP un messaggio di richiesta DHCP contenente informazioni sullo stato di integrità.

  2. Il server DHCP invia al server dei criteri di integrità Protezione accesso alla rete le informazioni sullo stato di integrità del client Protezione accesso alla rete.

  3. Il server dei criteri di integrità Protezione accesso alla rete valuta tali informazioni, determina se il client Protezione accesso alla rete è conforme e invia i risultati al client Protezione accesso alla rete e al server DHCP. Se il client Protezione accesso alla rete non è conforme, i risultati includono una configurazione per l'accesso limitato per il server DHCP e istruzioni per il monitoraggio e l'aggiornamento dell'integrità per il client NAP.

  4. Se lo stato di integrità è conforme, il server DHCP assegna al client Protezione accesso alla rete una configurazione di indirizzi IP per l'accesso illimitato e completa lo scambio di messaggi DHCP.

  5. Se lo stato di integrità non è conforme, il server DHCP assegna al client Protezione accesso alla rete una configurazione di indirizzi IPv4 per l'accesso limitato alla rete con restrizioni e completa lo scambio di messaggi DHCP. Il client Protezione accesso alla rete può inviare traffico solo ai server di monitoraggio e aggiornamento della rete con restrizioni.

  6. Il client Protezione accesso alla rete invia richieste di aggiornamento ai server di monitoraggio e aggiornamento.

  7. I server di monitoraggio e aggiornamento inviano al client Protezione accesso alla rete gli aggiornamenti necessari per garantire la conformità con i criteri di integrità. Il client Protezione accesso alla rete aggiorna le informazioni sullo stato di integrità.

  8. Il client Protezione accesso alla rete invia al server DHCP un nuovo messaggio di richiesta DHCP contenente informazioni aggiornate sullo stato di integrità.

  9. Il server DHCP invia al server dei criteri di integrità Protezione accesso alla rete le informazioni aggiornate sullo stato di integrità del client Protezione accesso alla rete.

  10. Presupponendo che siano stati eseguiti tutti gli aggiornamenti necessari, il server dei criteri di integrità Protezione accesso alla rete determina che il client Protezione accesso alla rete sia conforme e indica al server DHCP di assegnare una configurazione di indirizzi IPv4 per l'accesso illimitato alla Intranet.

  11. Il server DHCP assegna al client Protezione accesso alla rete una configurazione di indirizzi IP per l'accesso illimitato e completa lo scambio di messaggi DHCP.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Automatizzare la gestione di dispositivi con indirizzi IP statici mediante la creazione di prenotazioni DHCP

È possibile utilizzare una prenotazione client per garantire che un computer client DHCP riceva sempre lo stesso lease degli indirizzi IP all'avvio. Se si dispone di più server DHCP raggiungibili da un client prenotato, aggiungere la prenotazione per ognuno degli altri server DHCP. Questa pratica consente agli altri server DHCP di accettare la prenotazione degli indirizzi IP effettuata per il client prenotato. Sebbene il server DHCP eseguirà le azioni previste dalla prenotazione client quando l'indirizzo prenotato fa parte del pool di indirizzi disponibili, l'utilizzo della stessa prenotazione per lo stesso client in più server in genere non causa problemi.

Se si intende prenotare un indirizzo IP per un nuovo client oppure un indirizzo diverso da quello corrente, è necessario verificare che l'indirizzo non sia già stato concesso in lease dal server DHCP. La prenotazione di un indirizzo IP in un ambito non impone automaticamente a un client che utilizza attualmente tale indirizzo di non utilizzarlo più.

Se l'indirizzo è già in uso, il client che utilizza l'indirizzo dovrà prima rilasciarlo mediante l'invio di un messaggio di rilascio DHCP (DHCPRELEASE). A tale scopo, al prompt dei comandi di un computer client digitare ipconfig /release.

La prenotazione di un indirizzo IP nel server DHCP non impone inoltre al nuovo client per il quale è stata effettuata la prenotazione di passare immediatamente a tale indirizzo. Anche in questo caso, il client deve prima inviare un messaggio di richiesta DHCP (DHCPREQUEST). A tale scopo, al prompt dei comandi di un computer client digitare ipconfig /renew.

Per eseguire il rilascio o il rinnovo degli indirizzi IP prenotati in DHCP in client che utilizzano Windows 95 o Windows 98, è possibile utilizzare il programma Winipcfg.exe. Per i client che utilizzano MS-DOS e alcuni client che utilizzano altri sistemi operativi è necessario riavviare il computer per rendere effettiva la modifica.

Dopo aver effettuato queste modifiche, al client prenotato viene concesso in lease l'indirizzo IP prenotato per l'utilizzo permanente ogni volta che viene rinnovato il lease con il server DHCP.

Nota

I client prenotati possono disporre di opzioni DHCP appositamente configurate. Quando per un client prenotato sono disponibili opzioni configurate, questi valori sostituiscono eventuali parametri di tipo di opzioni distribuiti tramite l'assegnazione di opzioni basate su server, ambito o classe.

Nota

È possibile creare prenotazioni utilizzando qualsiasi indirizzo IP compreso nell'intervallo di indirizzi dell'ambito anche se è incluso in un intervallo di esclusione. In virtù di questo comportamento, quando si implementa la regola 80/20 e tutti gli indirizzi nell'ambito vengono esclusi (80% su un server, 20% sull'altro), le prenotazioni funzioneranno comunque correttamente.

Per aggiungere una prenotazione client, è possibile utilizzare la procedura seguente.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Domain Admins oppure a un gruppo equivalente.

Per aggiungere una prenotazione client

  1. Aprire DHCP.

  2. Nell'albero della console fare clic su Prenotazioni.

  3. Scegliere Nuova prenotazione dal menu Azione.

  4. In Nuova prenotazione digitare le informazioni necessarie per completare la prenotazione client.

  5. Per aggiungere la prenotazione client all'ambito, fare clic su Aggiungi.

  6. Ripetere i due passaggi precedenti per qualsiasi altra prenotazione client si desideri aggiungere e quindi fare clic su Chiudi.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito WebMicrosoft TechNet.


Supportare più subnet con un unico server DHCP mediante la configurazione di agenti di inoltro DHCP

Un agente di inoltro è un piccolo programma che consente l'inoltro di messaggi DHCP/BOOTP tra client e server in subnet diverse. Gli agenti di inoltro DHCP/BOOTP fanno parte degli standard DHCP e BOOTP e il relativo funzionamento è conforme a quanto previsto dalle Request for Comments (RFC), documenti standard in cui viene descritta la struttura e il comportamento dei protocolli.

Nelle connessioni di rete TCP/IP i router vengono utilizzati per connettere tra loro i componenti hardware e software utilizzati in segmenti diversi della rete fisica, denominati subnet, nonché per inoltrare pacchetti IP tra ognuna delle subnet. Per supportare e utilizzare il servizio DHCP tra più subnet, i router che connettono le singole subnet devono essere conformi alle funzionalità degli agenti di inoltro DHCP/BOOTP descritte nel documento RFC 1542.

Per essere conforme con il documento RFC 1542 e offrire il supporto per gli agenti di inoltro, ogni router deve poter riconoscere i messaggi dei protocolli BOOTP e DHCP ed elaborarli, ovvero inoltrarli, in modo appropriato. Poiché i router interpretano i messaggi DHCP come messaggi BOOTP, ad esempio un messaggio UDP inviato tramite lo stesso numero di porta UDP e contenente la struttura di messaggio condivisa, un router con funzionalità di agente di inoltro BOOTP inoltra in genere i pacchetti DHCP e tutti i pacchetti BOOTP inviati in rete.

Se un router non può essere utilizzato come agente di inoltro DHCP/BOOTP, ogni subnet deve disporre di un proprio server DHCP o di un altro computer utilizzabile come agente di inoltro in tale subnet. Nei casi in cui risulti poco pratico o impossibile configurare i router per supportare l'inoltro DHCP/BOOTP, è possibile configurare come agente di inoltro un computer che esegue Windows Server® 2008 installando il servizio Agente di inoltro DHCP.

Nella maggior parte dei casi i router supportano l'inoltro DHCP/BOOTP. Se l'inoltro non è supportato nei router in uso, contattare il produttore o il fornitore del router per verificare la disponibilità di un aggiornamento software o firmware in cui tale funzionalità sia supportata.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Evitare di riconfigurare DHCP in un nuovo server mediante la migrazione di un'infrastruttura DHCP esistente

È possibile spostare un database DHCP da un computer server (server di origine) a un altro computer server (server di destinazione). Prima di procedere con la migrazione del database DHCP, eseguire il backup del database di origine e quindi ripristinare il database nel server DHCP di destinazione.

Per ulteriori informazioni, vedere Ulteriori informazioni sulle funzionalità di backup e ripristino DHCP e Ulteriori informazioni sull'esportazione e l'importazione del database DHCP

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Bilanciare il carico sui server DHCP mediante l'utilizzo della regola 80/20 per gli ambiti

È possibile utilizzare la regola di progettazione 80/20 per bilanciare la distribuzione degli indirizzi dell'ambito quando si distribuiscono più server DHCP per offrire servizi allo stesso ambito.

L'utilizzo di più server DHCP nella stessa subnet offre una maggior tolleranza di errore per servire i client DHCP in essa presenti. Con due server DHCP, se un server non è disponibile, l'altro server può assumere il controllo e continuare a concedere in lease nuovi indirizzi o a rinnovare client esistenti.

Quando si bilancia tra due server DHCP un intervallo di indirizzi relativi a un unico ambito e a un'unica rete, l'80% degli indirizzi viene solitamente distribuito da un server DHCP e il rimanente 20% dall'altro server.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server® 2008 nel sito Web Microsoft TechNet.


Centralizzare la gestione di due o più server DHCP come un unico sistema mediante l'inserimento dei server DHCP in un cluster

Il servizio Server DHCP è un'applicazione compatibile con Cluster API. È possibile implementare un ulteriore livello di affidabilità del server DHCP (o MADCAP) distribuendo un cluster di server DHCP mediante il servizio Cluster.

Il supporto cluster per DHCP consente di implementare un metodo locale di failover del server DHCP e quindi di ottenere una maggior tolleranza di errore. È inoltre possibile migliorare la tolleranza di errore combinando il cluster di server DHCP con una configurazione di failover remota, ad esempio utilizzando una configurazione basata sulla divisione degli ambiti.

Requisiti per la configurazione di una risorsa di tipo cluster DHCP

Quando viene utilizzato in un cluster di server, il servizio Server DHCP richiede i tipi di risorsa seguenti:

  • Disco

  • Indirizzo IP

  • Nome

In questo tipo di configurazione per la risorsa dell'indirizzo IP viene definito un indirizzo IP virtuale utilizzando lo strumento Amministrazione cluster. Tale indirizzo deve essere un indirizzo IP statico e non uno ottenuto da un altro server DHCP.

Il servizio Server DHCP esegue quindi il binding a questo indirizzo IP virtuale. Sarà pertanto necessario utilizzare l'indirizzo IP per autorizzare il servizio Server DHCP in Active Directory in modo che possa funzionare correttamente e servire i client della rete.

Dopo aver configurato l'indirizzo IP virtuale utilizzando la configurazione cluster, sarà necessario specificare una configurazione degli indirizzi IP per ogni scheda di rete installata nei singoli nodi, ovvero un server del cluster. Poiché il servizio Server DHCP non esegue il binding a indirizzi IP di scheda, è possibile specificarli mediante DHCP o configurarli in modo statico. Se si utilizza la configurazione statica, gli indirizzi per ogni coppia di schede di rete collegata (da nodo a nodo) devono trovarsi nella stessa subnet.

È inoltre possibile visualizzare gli indirizzi configurati in modo statico utilizzando le proprietà di TCP/IP in Centro connessioni di rete mediante le proprietà dei binding del server nella console DHCP. Per un cluster di server DHCP le informazioni sui binding visualizzate in queste schermate non corrispondono tuttavia all'indirizzo IP utilizzato per il cluster di server. Tali impostazioni non sono pertanto valide.

Quando si crea un ambito per un server di tipo cluster DHCP, gli indirizzi IP virtuali utilizzati nel contesto del server devono essere esclusi in modo che non vengano distribuiti ai client. È inoltre necessario configurare il percorso del database, il percorso del file del registro di controllo e il percorso di backup del database utilizzando lo strumento Amministrazione cluster sul disco condiviso.

Nota

Il database Jet su cui si basa il servizio Server DHCP non è compatibile con Cluster API. Se il database DHCP di tipo cluster diventa inaccessibile al servizio Server DHCP, il servizio segnalerà migliaia di errori ESENT del registro applicazioni e il servizio DHCP in prossimità del cluster verrà interrotto.

Nota

Se è necessario solo gestire in remoto cluster di server DHCP distribuiti in computer remoti, è possibile utilizzare Amministrazione cluster.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Ulteriori informazioni sulle funzionalità di backup e ripristino DHCP

L'esecuzione del backup del database DHCP (Dynamic Host Configuration Protocol) consente di evitare la perdita dei dati qualora il database DHCP venga perso, ad esempio a causa di un errore del disco rigido, o danneggiato. Il servizio Server DHCP supporta tre metodi di backup:

  • Backup sincroni eseguiti automaticamente. L'intervallo di backup predefinito è 60 minuti. È possibile cambiare tale valore modificando la voce seguente del Registro di sistema:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DHCPServer\Parameters\BackupInterval

    Attenzione

    La modifica incorretta del Registro di sistema potrebbe danneggiare gravemente il sistema. Prima di apportare modifiche al Registro di sistema, si consiglia di effettuare il backup di qualsiasi dati importanti sul computer.

  • Backup asincroni (manuali) eseguiti tramite il comando backup nella console DHCP.

Quando viene eseguito un backup sincrono o asincrono, viene salvato l'intero database DHCP, inclusi gli elementi seguenti:

  • Tutti gli ambiti, inclusi ambiti multicast e ambiti estesi.

  • Prenotazioni

  • Lease

  • Tutte le opzioni, incluse le opzioni relative a server, ambito, prenotazione e classe

  • Tutte le chiavi del Registro di sistema e altre impostazioni di configurazione (ad esempio le impostazioni del registro di controllo e dei percorsi delle cartelle) impostate nelle proprietà del server DHCP. Tali impostazioni sono archiviate nella sottochiave seguente del Registro di sistema:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DHCPServer\Parameters

Nota

Il backup delle credenziali (nome utente, dominio e password) per l'aggiornamento dinamico DNS (Domain Name System), utilizzate dal server DHCP quando si registrano i computer client DHCP, non viene eseguito con nessun metodo di backup.

Percorsi di backup

In questo argomento si presume che il database DHCP e le directory di backup si trovino nell'unità e nei percorsi predefiniti. Il percorso di backup predefinito del database DHCP è %systemroot%\System32\Dhcp\Backup. È possibile cambiare la cartella di backup del database selezionando una cartella locale diversa durante un backup manuale o modificando il percorso della cartella di backup nelle proprietà del server DHCP.

Quando si pianifica la strategia di backup, tenere presente quanto segue:

  • I backup sincroni vengono eseguiti mentre il servizio DHCP è in esecuzione. Analogamente, quando si eseguono backup asincroni (manuali), non è necessario arrestare il servizio DHCP a meno che non si stia spostando il database in un nuovo server.

  • La posizione della cartella di backup del database DHCP deve essere un percorso locale.

  • Non archiviare i backup del server DHCP nello stesso disco rigido in cui è installato il servizio DHCP e verificare che l'elenco di controllo di accesso (ACL) per la cartella di backup contenga solo il gruppo Administrators e il gruppo DHCP Administrators come membri. Oltre a eseguire i backup manuali, eseguire i backup in altri percorsi, ad esempio un'unità nastro, e verificare che persone non autorizzate non abbiano accesso alle copie di backup. A tale scopo, è possibile utilizzare Windows Backup.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators nel server DHCP.

Per eseguire il backup del database DHCP

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare clic sul server DHCP che si desidera configurare.

  3. Scegliere Backup dal menu Azione.

  4. Nella finestra di dialogo Sfoglia per cartelle selezionare la cartella in cui si desidera archiviare il database DHCP di backup e quindi fare clic su OK.

Ulteriori considerazioni

Quando si archivia un backup del database DHCP creato manualmente nello stesso percorso del backup sincrono creato ogni 60 minuti dal server DHCP, il backup manuale viene sovrascritto quando viene eseguito il backup automatico.

Ripristinare il database DHCP

Il ripristino del database del server DHCP è utile qualora il database venga danneggiato o perso. Per ripristinare correttamente il database, è necessario eseguire il backup del database periodicamente. Per impostazione predefinita, DHCP esegue i backup sincroni a intervalli di 60 minuti nella cartella %systemroot%\System32\Dhcp\Backup, ma è anche possibile eseguire backup manuali o utilizzare il software di backup per copiare il database in altri percorsi.

È possibile ripristinare il database DHCP da una copia di backup del file di database, Dhcp.mdb, scegliendo Ripristina dal menu Azione nello snap-in DHCP. Quando si ripristina il database DHCP da una copia di backup di Dhcp.mdb, nel server vengono configurate le informazioni seguenti:

  • Tutti gli ambiti, inclusi ambiti multicast e ambiti estesi.

  • Prenotazioni

  • Lease

  • Tutte le opzioni, incluse le opzioni relative a server, ambito, prenotazione e classe

  • Tutte le chiavi del Registro di sistema e altre impostazioni di configurazione (ad esempio le impostazioni del registro di controllo e dei percorsi delle cartelle) impostate nelle proprietà del server DHCP.

Nota

Poiché il backup delle credenziali (nome utente, dominio e password) per l'aggiornamento dinamico DNS, utilizzate dal server DHCP quando si registrano i computer client DHCP, non viene eseguito con nessun metodo di backup, tali credenziali non vengono ripristinate durante la procedura di ripristino. Dopo il ripristino del database DHCP, configurare le credenziali per il server e impostare inoltre lo stato del server.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators nel server DHCP.

Per ripristinare il database DHCP

  1. Aprire lo snap-in DHCP.

  2. Nell'albero della console fare clic sul server DHCP che si desidera configurare.

  3. Scegliere Ripristina dal menu Azione.

  4. Nella finestra di dialogo Sfoglia per cartelle selezionare la cartella che contiene il database DHCP di backup e quindi fare clic su OK.
Note
  • Per consentire il ripristino del database DHCP, il servizio DHCP viene temporaneamente arrestato. Quando il servizio è arrestato, i client DHCP non sono in grado di contattare il server DHCP e ottenere indirizzi IP.
  • È possibile ripristinare solo database DHCP in una determinata lingua. Non è ad esempio possibile ripristinare un database DHCP di un server DHCP che esegue la versione inglese del sistema operativo in un server DHCP che esegue la versione giapponese del sistema operativo.

È inoltre possibile utilizzare questa procedura per spostare un database DHCP da un computer server (server di origine) a un altro computer server (server di destinazione).

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito WebMicrosoft TechNet.


Ulteriori informazioni sull'esportazione e l'importazione del database DHCP

È possibile utilizzare questa procedura per spostare un database DHCP da un computer server (server di origine) a un altro computer server (server di destinazione).

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators nei server DHCP di origine e di destinazione.

Per spostare un database DHCP e la configurazione da un server che esegue Windows Server 2003 a un altro server che esegue Windows Server 2008 R2

  1. Accedere al server DHCP di origine.

  2. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd nella casella Apri e quindi fare clic su OK.

  3. Scegliere Backup dal menu Azione.

  4. Digitare netsh dhcp server export C:\dhcp.txt all e quindi premere INVIO.

  5. Installare il servizio server DHCP nel server DHCP di destinazione. Per ulteriori informazioni sull'installazione di DHCP, vedere Installare il ruolo Server DHCP.

  6. Accedere al server DHCP di destinazione.

  7. Copiare il file del database DHCP esportato nel disco rigido locale del server DHCP di destinazione.

  8. Verificare che il servizio DHCP sia avviato nel server DHCP di destinazione.

  9. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd nella casella Apri e quindi fare clic su OK.

  10. Aprire DHCP.

  11. Nell'albero della console fare clic su DHCP.

  12. Scegliere Autorizza dal menu Azione.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Ulteriori informazioni sui gruppi di sicurezza DHCP

Quando si installa il servizio Server DHCP, vengono creati due gruppi locali di dominio: DHCP Users e DHCP Administrators.

Nelle versioni di Windows precedenti a Windows Server 2008 R2, il servizio DHCP (Dynamic Host Configuration Protocol) viene eseguito nell'account di sistema locale e dispone dei privilegi per creare i gruppi nel database del sistema di gestione degli account di sicurezza (SAM). Il servizio Server DHCP in Windows Server 2008 R2 è stato spostato nell'account Servizio di rete, che dispone di privilegi ridotti e non è in grado di creare gli account di sicurezza. Per facilitare l'aggiunta di gruppi di sicurezza e l'impostazione degli elenchi di controllo accesso (ACL), DHCP utilizza un'API (Application Programming Interface) denominata DhcpAddSecurityGroups. Questa API è implementata in Dhcpsapi.dll e viene avviata dallo strumento di gestione del ruolo al termine dell'installazione del ruolo Server DHCP.

Gruppo DHCP Users

I membri del gruppo DHCP Users dispongono dell'accesso in sola lettura al server tramite lo snap-in MMC (Microsoft Management Console) DHCP, che consente di visualizzare, ma non di modificare i dati del server, inclusi la configurazione del server DHCP, le chiavi del Registro di sistema, i file di registro DHCP e il database DHCP. DHCP Users non può creare ambiti, modificare i valori delle opzioni, creare prenotazioni o intervalli di esclusione né modificare in qualsiasi altro modo la configurazione del server DHCP.

Gruppo DHCP Administrators

I membri del gruppo DHCP Administrators possono visualizzare e modificare qualsiasi impostazione sul server DHCP. DHCP Administrators può creare ed eliminare ambiti, aggiungere prenotazioni, modificare i valori delle opzioni, creare ambiti estesi o eseguire qualsiasi altra attività richiesta per amministrare il server DHCP, inclusa l'esportazione o l'importazione della configurazione e del database del server DHCP.

I membri del gruppo DHCP Administrators non dispongono di diritti amministrativi illimitati. Se, ad esempio, un server DHCP è configurato anche come server DNS (Domain Name System), un membro del gruppo DHCP Administrators può visualizzare e modificare la configurazione DHCP, ma non può modificare la configurazione del server DNS nello stesso computer.

Poiché i membri del gruppo DHCP Administrators dispongono dei diritti solo per il computer locale, DHCP Administrators non può autorizzare o annullare l'autorizzazione dei server DHCP in Servizi di dominio Active Directory. Solo i membri del gruppo Domain Admins possono eseguire questa attività. Se si desidera autorizzare o annullare l'autorizzazione di un server DHCP in un dominio figlio, è necessario disporre delle credenziali di amministratore dell'organizzazione per il dominio padre.

Nota

Per accedere come amministratore dell'organizzazione, è necessario utilizzare un account membro del gruppo Enterprise Admins. È possibile aggiungersi a questo gruppo eseguendo l'accesso come amministratore locale nel primo controller di dominio creato nell'organizzazione.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Distribuire lease DHCP basati sull'indirizzo MAC

La funzionalità di filtro del livello di collegamento consente il controllo dell'accesso alla rete per il rilascio o rifiuto di lease DHCP di indirizzi IP basati su un indirizzo MAC (Media Access Control). Tale funzionalità può essere configurata a livello di nodo IPv4 per tutti i client in tutti gli ambiti IPv4. È attualmente disponibile solo per le reti IPv4.

Per abilitare il filtro degli indirizzi MAC

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare clic con il pulsante destro del mouse su IPv4 e quindi scegliere Proprietà.

  3. Fare clic su Filtri e quindi selezionare la casella di controllo Attiva elenco indirizzi consentiti o Attiva elenco indirizzi non consentiti.
Per configurare un nuovo filtro

  1. Aprire lo snap-in DHCP.

  2. Nell'albero della console fare doppio clic sul server DHCP appropriato, su IPv4, su Filtri e quindi fare clic con il pulsante destro del mouse su Consenti o su Nega.

  3. Fare clic su Nuovo filtro e quindi digitare le informazioni appropriate nelle caselle Indirizzo MAC e Descrizione. Descrizione è un campo facoltativo.
Note
  • L'indirizzo MAC può essere l'indirizzo completo o una sequenza di indirizzi MAC (caratteri jolly). Di seguito sono elencati i caratteri jolly validi per gli indirizzi MAC:
    • 00-1C-23-*-*-*

    • 00-1C-23-20-AF-*

    • 00-1C-23-20-*-*

    • 001C2320AF4E

    • 001C*

Nota

Il filtro degli indirizzi non consentiti ha la precedenza sul filtro degli indirizzi consentiti.

Per modificare il tipo di hardware con esenzione dall'elenco di filtro

  1. Aprire lo snap-in DHCP.

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare clic con il pulsante destro del mouse su IPv4 e quindi scegliere Proprietà.

  3. Fare clic su Filtri, su Avanzate e quindi selezionare o deselezionare le caselle di controllo relative ai tipi di hardware che si desidera modificare.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Configurare le impostazioni del ruolo Server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Impedire il name squatting con la protezione dei nomi

L'appropriazione indebita del nome o name squatting si verifica quando un computer non Windows viene registrato nel DNS (Domain Name System) con un nome già registrato per un computer Windows. L'utilizzo della protezione dei nomi in Windows Server impedisce il name squatting da parte dei computer non Windows. Il name squatting non rappresenta un problema per le reti Windows omogenee in cui è possibile utilizzare Servizi di dominio Active Directory per assegnare nomi riservati a utenti o computer.

La protezione dei nomi si basa sul DHCID (Dynamic Host Configuration Identifier) nel server DHCP (Dynamic Host Configuration Protocol) e sul supporto del nuovo record di risorse DHCID nel DNS. Il record di risorse DHCID è descritto da Internet Engineering Task Force (IETF) nelle RFC 4701 e 4703.

Il DHCID è un record di risorse (RR) archiviato nel DNS che esegue il mapping dei nomi per impedire la registrazione di nomi duplicati. Tale RR viene utilizzato da DHCP per archiviare un identificatore per un computer, insieme ad altre informazioni relative al nome quali i record A/AAAA del computer. La sua posizione unica nel processo di registrazione dei nomi consente a DHCP di richiedere tale corrispondenza e quindi di rifiutare la registrazione di un computer con un indirizzo diverso che tenti di registrare un nome con un record DHCID esistente.

Il DHCID previene le situazioni di name squatting seguenti:

  • Name squatting di un server da parte di un client

  • Name squatting di un server da parte di un altro server

  • Name squatting di un client da parte di un altro client

  • Name squatting di un client da parte di un server

Verrà inoltre aggiunto il supporto per DUID (DHCP Unique Identifier) alla registrazione IPv4 nel client DHCP. Il DUID è descritto da Internet Engineering Task Force (IETF) nella RFC 4361.

La protezione dei nomi può essere configurata per IPv4 e IPv6 a livello di scheda di rete o a livello di ambito. Le impostazioni di protezione dei nomi configurate a livello di ambito hanno la precedenza sulle impostazioni configurate a livello di IPv4 o IPv6. Se la protezione dei nomi a livello di ambito non è configurata, l'impostazione a livello della scheda di rete IPv4 o IPv6 avrà la precedenza. Il DHCID protegge i nomi in base all'ordine cronologico con cui li riceve.

Per attivare la protezione dei nomi a livello di nodo IPv4 o IPv6

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare clic con il pulsante destro del mouse su IPv4 o IPv6 e quindi scegliere Proprietà.

  3. Fare clic su DNS, su Avanzate e quindi selezionare Attiva protezione dei nomi.
Per attivare la protezione dei nomi a livello di ambito

  1. Aprire la console DHCP.

  2. Nell'albero della console fare doppio clic sul server DHCP che si desidera configurare, fare doppio clic su IPv4 o IPv6, fare clic con il pulsante destro del mouse sull'ambito desiderato e quindi scegliere Proprietà.

  3. Fare clic su DNS, su Configura e quindi selezionare Attiva protezione dei nomi.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito Web Microsoft TechNet.


Ulteriori informazioni sulla registrazione di eventi e controlli DHCP

Per abilitare la registrazione server DHCP (Dynamic Host Configuration Protocol), è possibile utilizzare la procedura seguente.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o DHCP Administrators.

Per abilitare la registrazione server DHCP

  1. Aprire lo snap-in DHCP di Microsoft Management Console (MMC).

  2. Nell'albero della console fare clic sul server DHCP che si desidera configurare.

  3. Scegliere Proprietà dal menu Azione.

  4. Nella scheda Generale selezionare l'opzione Attiva registrazione controlli DHCP e quindi fare clic su OK.

Analizzare i file di registro del server

In Windows Server 2008 i file di registro del server DHCP sono configurati per impostazione predefinita per gestire la relativa crescita e conservare le risorse disco. I file di registro dei controlli DHCP si trovano per impostazione predefinita in %windir%\System32\Dhcp.

Nella sezione seguente viene illustrato il formato di questi file di registro e viene descritto come utilizzarli per raccogliere ulteriori informazioni sulle operazioni del servizio Server DHCP in rete.

Formato dei file di registro del server DHCP

I file di registro del server DHCP sono file di testo delimitato da virgole in cui ogni voce di registro rappresenta una singola riga di testo. Di seguito sono indicati i campi e l'ordine in cui vengono visualizzati in una voce di file di registro:

ID, Date, Time, Description, IP Address, Host Name, MAC Address

I singoli campi sono descritti in dettaglio nella tabella seguente:

Campo | Descrizione
ID | Codice ID dell'evento server DHCP.
Date | Data di registrazione della voce nel server DHCP.
Time | Ora di registrazione della voce nel server DHCP.
Description | Descrizione dell'evento server DHCP.
IP Address | Indirizzo IP del client DHCP.
Host Name | Nome host del client DHCP.
MAC Address | Indirizzo MAC (Media Access Control) utilizzato dalla scheda di rete del client.

Registro server DHCP: codici di eventi comuni

I file di registro dei controlli del server DHCP utilizzano codici di ID evento riservati per fornire informazioni sul tipo di attività o di evento server registrato. Nella tabella seguente vengono descritti in modo più dettagliato questi codici di ID evento.

ID evento | Descrizione
00 | Registro avviato.
01 | Registro arrestato.
02 | Registro temporaneamente sospeso a causa di spazio su disco insufficiente.
10 | Un nuovo indirizzo IP è stato assegnato in lease a un client.
11 | Lease rinnovato da un client.
12 | Lease rilasciato da un client.
13 | È stato rilevato un indirizzo IP in uso nella rete.
14 | Impossibile soddisfare una richiesta di lease perché il pool di indirizzi dell'ambito è esaurito.
15 | Lease negato.
20 | Indirizzo BOOTP assegnato in lease a un client.

Eventi di aggiornamento dinamico DNS

Quando il server DHCP è configurato per l'esecuzione di aggiornamenti dinamici DNS (Domain Name System) per conto di client DHCP, è possibile utilizzare i file di registro dei controlli DHCP per monitorare le richieste di aggiornamento da parte del server DHCP al server DNS, gli aggiornamenti dei record DNS completati e gli aggiornamenti dei record DNS non riusciti. Gli ID evento seguenti vengono utilizzati per eventi di aggiornamento dinamico DNS:

ID evento | Descrizione
30 | Richiesta di aggiornamento dinamico DNS
31 | Aggiornamento dinamico DNS non riuscito
32 | Aggiornamento dinamico DNS completato

L'indirizzo IP del computer client DHCP è incluso nel file di registro dei controlli DHCP in modo da poter tenere traccia dell'origine in caso di attacco Denial of Service.

Registri server DHCP: eventi di autorizzazione server

Di seguito sono indicati ulteriori codici di ID evento dei file di registro del server e le relative descrizioni. Questi eventi possono essere visualizzati nei registri creati dai server DHCP che eseguono Windows Server 2008. Si riferiscono al server DHCP specifico e al relativo stato di autorizzazione al momento della distribuzione in ambienti Servizi di dominio Active Directory.

ID evento Descrizione

50

Dominio non raggiungibile

Il server DHCP non ha individuato il dominio specifico per l'installazione di Active Directory configurata.

51

Autorizzazione riuscita

Il server DHCP è stato autorizzato a essere avviato in rete.

52

Aggiornato a un sistema operativo Windows Server 2008

Il server DHCP è stato aggiornato di recente a un sistema operativo Windows Server 2008 e pertanto la funzionalità di individuazione dei server DHCP non autorizzati, utilizzata per determinare se il server è stato autorizzato in Servizi di dominio Active Directory, è stata disabilitata.

53

Autorizzazione in cache

Il server DHCP è stato autorizzato a essere avviato tramite le informazioni memorizzate in precedenza nella cache. Servizi di dominio Active Directory non è stato trovato al momento dell'avvio del server in rete.

54

Autorizzazione non riuscita

Il server DHCP non è stato autorizzato a essere avviato in rete. Quando si verifica questo evento, è probabile che venga seguito dall'arresto del server.

55

Autorizzato (servizio)

Il server DHCP è stato correttamente autorizzato a essere avviato in rete.

56

Errore di autorizzazione, servizio interrotto

Il server DHCP non è stato autorizzato a essere avviato in rete ed è stato arrestato dal sistema operativo. È innanzitutto necessario autorizzare il server in Servizi di dominio Active Directory prima di avviarlo nuovamente.

57

Server trovato nel dominio

Un altro server DHCP esiste ed è autorizzato per il servizio nello stesso dominio.

58

Dominio non trovato dal server

Il server DHCP non ha individuato il dominio specificato.

59

Errore di rete

Un errore relativo alla rete ha impedito di determinare se il server è autorizzato.

60

Nessun controller di dominio abilitato per Servizi di dominio Active Directory

Non è stato individuato alcun controller di dominio che esegue Windows Server 2008. Per rilevare se il server è autorizzato, è necessario un controller di dominio abilitato per Servizi di dominio Active Directory.

61

Server appartenente al dominio DS

È stato trovato in rete un altro server DHCP appartenente al dominio Active Directory.

62

Trovato altro server

Un altro server DHCP è stato trovato in rete.

63

Riavvio rilevamento rogue

Il server DHCP sta nuovamente cercando di determinare se è autorizzato a essere avviato e a fornire servizi in rete.

64

Nessuna interfaccia DHCP abilitata

I binding del servizio o le connessioni di rete del server DHCP sono configurate in modo che non sia abilitato a fornire servizi. La causa è in genere una delle seguenti:

  • Le connessioni di rete del server non sono installate o non sono attivamente connesse a una rete.

  • Il server non è stato configurato con almeno un indirizzo IP statico per una delle connessioni di rete installate e attive.

  • Tutte le connessioni di rete configurate in modo statico per il server sono disabilitate.

Esempio: estratto da un file di registro dei controlli del server DHCP di esempio

Di seguito è riportato un breve estratto di attività di un registro di controllo di esempio generato dal servizio Server DHCP:

ID Date,Time,Description,IP Address,Host Name,MAC Address
00,04/19/99,12:43:06,Started,,,
60,04/19/99,12:43:21,No DC is DS Enabled,,MYDOMAIN,
63,04/19/99,12:43:28,Restarting rogue detection,,,
01,04/19/99,13:11:13,Stopped,,,
00,04/19/99,12:43:06,Started,,,
55,04/19/99,12:43:54,Authorized(servicing),,MYDOMAIN,

In questo esempio, il server DHCP non è stato autorizzato al momento dell'avvio iniziale ed è stato quindi arrestato. Dopo l'autorizzazione, il server potrà essere riavviato e soddisfare le richieste dei client.

Risorse aggiuntive

Per un elenco degli argomenti della Guida in cui sono disponibili informazioni correlate, vedere Attività consigliate per il ruolo server DHCP.

Per informazioni aggiornate e dettagliate su DHCP destinate ai responsabili IT, vedere la documentazione relativa a Windows Server 2008 nel sito WebMicrosoft TechNet.