Siti e servizi di Active Directory

Siti e servizi di Active Directory® è uno snap-in di Microsoft Management Console (MMC) del sistema operativo Windows Server® 2008 R2 che è possibile utilizzare per amministrare la replica dei dati di directory tra tutti i siti di una foresta di Servizi di dominio Active Directory. Questo snap-in consente inoltre di visualizzare gli oggetti specifici dei servizi pubblicati in Servizi di dominio Active Directory.

Nota

È inoltre possibile utilizzare Siti e servizi di Active Directory per amministrare la replica dei dati di directory tra tutti i siti in un set di configurazione Active Directory Lightweight Directory Services.

Gli amministratori responsabili dell'amministrazione dei servizi a livello di foresta possono utilizzare Siti e servizi di Active Directory per gestire la topologia di replica tra siti per la foresta. Agli amministratori responsabili dei servizi delle applicazioni può essere delegata la responsabilità dei contenitori dei servizi in cui vengono pubblicati gli oggetti specifici delle applicazioni.

Quando si aggiunge il ruolo server di Servizi di dominio Active Directory a un server, Siti e servizi di Active Directory viene aggiunto al menu Strumenti di amministrazione.

  • Panoramica di Siti e servizi di Active Directory

  • Elenco di controllo: configurare un sito aggiuntivo

  • Elenco di controllo: configurare la pianificazione di replica tra siti

  • Elenco di controllo: aggiungere un server di catalogo globale

  • Aggiungere un sito alla foresta

  • Pianificare la replica tra siti

  • Aggiungere il catalogo globale a un sito

  • Risolvere i problemi relativi alla replica di Servizi di dominio Active Directory

  • Risorse per Siti e servizi di Active Directory

  • Interfaccia utente: Siti e servizi di Active Directory


Panoramica di Siti e servizi di Active Directory

È possibile utilizzare lo snap-in Siti e servizi di Active Directory per gestire gli oggetti specifici dei siti che implementano la topologia di replica tra siti. Tali oggetti vengono archiviati nel contenitore Siti di Servizi di dominio Active Directory.

Nota

È inoltre possibile utilizzare Siti e servizi di Active Directory per amministrare la replica dei dati di directory tra tutti i siti in un set di configurazione Active Directory Lightweight Directory Services.

In Siti e servizi di Active Directory è inoltre disponibile il contenitore Servizi, che può essere utilizzato per visualizzare gli oggetti correlati ai servizi pubblicati in Servizi di dominio Active Directory.

Nelle sezioni seguenti vengono fornite informazioni dettagliate sulla gestione dei siti e sulla pubblicazione dei servizi con Siti e servizi di Active Directory:

  • Gestione dei siti

  • Pubblicazione dei servizi

  • Ulteriori riferimenti

Gestione dei siti

Nella rete fisica, un sito rappresenta un insieme di computer connessi da una rete ad alta velocità, ad esempio una rete locale (LAN). Tutti i computer dello stesso sito fisico risiedono in genere nella rete dello stesso edificio o ad esempio dello stesso campus.

In Servizi di dominio Active Directory, un oggetto sito rappresenta gli aspetti del sito fisico che possono essere gestiti, in particolare la replica dei dati di directory tra controller di dominio. È possibile utilizzare Siti e servizi di Active Directory per gestire gli oggetti che rappresentano i siti e i server che risiedono in tali siti.

Gli oggetti sito e i rispettivi oggetti correlati vengono replicati in tutti i controller di dominio di una foresta di Active Directory. In Siti e servizi di Active Directory è possibile gestire gli oggetti seguenti:

  • Siti

  • Subnet

  • Server

  • Impostazioni NTDS

  • Connessioni

  • Collegamenti di sito

  • Trasporti tra siti IP e SMTP

Siti

Gli oggetti sito si trovano nel contenitore Sito e possono essere utilizzati per eseguire le attività seguenti:

  • Creare nuovi siti

  • Delegare il controllo sui siti utilizzando Criteri di gruppo e autorizzazioni

In ogni sito è presente un oggetto Impostazioni sito NTDS che identifica il generatore della topologia tra siti (ISTG). Il generatore della topologia tra siti è il controller di dominio del sito che genera oggetti connessione dai controller di dominio di siti diversi. Esegue inoltre attività avanzate di gestione della replica.

Per ulteriori informazioni sui siti e sull'oggetto Impostazioni sito NTDS, vedere Informazioni su siti, subnet e collegamenti di sito.

Subnet

Gli oggetti subnet identificano gli intervalli di indirizzi IP all'interno di un sito e possono essere utilizzati per eseguire le attività seguenti:

  • Creare nuove subnet

  • Associare subnet a siti

  • Specificare un percorso di un sito utilizzabile dalla funzionalità di rilevamento del percorso della stampante in Criteri di gruppo

Per ulteriori informazioni sulle subnet, vedere Informazioni su siti, subnet e collegamenti di sito.

Server

Gli oggetti server vengono creati automaticamente quando si aggiunge il ruolo server di Servizi di dominio Active Directory. I server rappresentano i controller di dominio nella topologia di replica.

È possibile utilizzare oggetti server per eseguire le attività seguenti:

  • Identificare i controller di dominio che fungeranno da server testa di ponte preferiti. È possibile utilizzare i server testa di ponte preferiti per controllare la replica tra siti affinché venga eseguita soltanto tra i controller di dominio specificati e non tra controller di dominio che potrebbero gestire il traffico di replica tra siti in modo meno efficiente.

  • Spostare i server da un sito a un altro. Se si crea un nuovo sito e sono già stati installati controller di dominio con indirizzi IP mappati al nuovo sito, è possibile spostare i controller di dominio nel nuovo sito.

Impostazioni NTDS

Ogni oggetto server contiene un oggetto Impostazioni NTDS che rappresenta il controller di dominio nel sistema di replica. Nell'oggetto Impostazioni NTDS sono archiviati gli oggetti connessione che consentono la replica tra due o più controller di dominio.

È possibile utilizzare oggetti Impostazioni NTDS per eseguire le attività seguenti:

  • Generare la topologia di replica. Il comando Check Replication Topology per l'oggetto Impostazioni NTDS segnala a ISTG di eseguire un controllo di tutte le connessioni tra i controller di dominio e di aggiungere o rimuovere le connessioni necessarie.

  • Abilitare o disabilitare il catalogo globale in un server. Quando si abilita il catalogo globale, il controller di dominio replica le partizioni di directory di sola lettura che costituiscono il catalogo globale nella foresta.

Per ulteriori informazioni sul catalogo globale, vedere Informazioni sul catalogo globale.

Connessioni

I partner di replica dei server di un sito sono identificati da oggetti connessione. La replica viene eseguita in una direzione. Un oggetto connessione per un server contiene informazioni sull'altro server (server "mittente") che invia la replica al primo server. Negli oggetti connessione sono archiviate le pianificazioni che controllano la replica all'interno di un sito. Per impostazione predefinita, il polling di un partner di replica per ottenere le modifiche viene eseguito automaticamente ogni ora. Nella replica tra siti, la pianificazione per gli oggetti connessione è derivata dall'oggetto collegamento di sito. Non è necessario gestire le pianificazioni per gli oggetti connessione. Gli oggetti connessione vengono creati automaticamente dal sistema di replica.

È possibile utilizzare oggetti connessione per eseguire le attività seguenti:

  • Identificare i partner di replica dei server del sito

  • Forzare la replica su una connessione, quando non si desidera attendere la replica pianificata oppure per testare la replica su una connessione

Collegamenti di sito

I collegamenti di sito rappresentano il flusso di replica tra i siti. È possibile gestire la replica tra siti configurando le proprietà dei siti: i periodi di tempo in cui può essere eseguita la replica, la frequenza con cui la replica viene eseguita in un determinato periodo di tempo e le route preferite tra due siti.

È possibile utilizzare oggetti collegamento di sito per eseguire le attività seguenti:

  • Aggiungere e rimuovere siti che utilizzano il collegamento di sito

  • Impostare il costo della replica sul collegamento di sito, che determina le probabilità che la replica venga eseguita su tale collegamento di sito quando sono disponibili più route utilizzabili dalla replica per raggiungere un sito di destinazione

  • Impostare la pianificazione del collegamento di sito, che determina i giorni e le ore in cui la replica è disponibile, ovvero può essere eseguita, sul collegamento di sito

  • Impostare l'intervallo di replica, che determina la frequenza con cui la replica viene eseguita sul collegamento di sito quando la replica è disponibile

Per ulteriori informazioni sull'utilizzo di collegamenti di sito, vedere Pianificare la replica tra siti.

Trasporti tra siti IP e SMTP

La replica utilizza RPC (Remote Procedure Call) su trasporto IP oppure su trasporto SMTP (Simple Mail Transfer Protocol). È possibile utilizzare SMTP per inviare la replica in messaggi di posta negli ambienti in cui non sono disponibili collegamenti di rete WAN (Wide Area Network). In questo caso, la replica viene eseguita in base alla pianificazione della messaggistica e non alla pianificazione del collegamento di sito. Per impostazione predefinita, per il recapito dei pacchetti nella replica tra siti viene utilizzato il protocollo di trasporto IP. È possibile utilizzare i contenitori Trasporto tra siti IP e SMTP per eseguire le attività seguenti:

  • Creare collegamenti di sito. È possibile aggiungere collegamenti di sito alla topologia di replica in base alle esigenze per implementare nuovi siti.

  • Creare bridge di collegamenti di sito. In Servizi di dominio Active Directory, i collegamenti di sito sono collegati tramite bridge per impostazione predefinita e non sono necessari nella maggior parte delle distribuzioni.

Per ulteriori informazioni sui trasporti tra siti, vedere Pianificare la replica tra siti.

Pubblicazione dei servizi

Alcuni servizi, ad esempio Servizi certificati, Accodamento messaggi ed Exchange Server, pubblicano automaticamente informazioni nel contenitore Siti di Servizi di dominio Active Directory al momento della relativa installazione. Altri servizi possono essere pubblicati nella directory con interfacce di programmazione.

Siti e servizi di Active Directory espone gli oggetti correlati ai servizi pubblicati nel nodo Servizi. Per impostazione predefinita, questo nodo non è visibile. Per visualizzare il nodo, aprire Siti e servizi di Active Directory e quindi scegliere Mostra nodo servizi dal menu Visualizza.

Gli oggetti nel nodo Servizi di Siti e servizi di Active Directory vengono pubblicati per essere utilizzati dagli amministratori delle rispettive applicazioni. Per questo motivo, le informazioni su tali oggetti sono disponibili nella documentazione del servizio o dell'applicazione.

Per ulteriori informazioni sulla pubblicazione dei servizi in Servizi di dominio Active Directory, vedere la pagina relativa alla pubblicazione dei servizi all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86230.

Ulteriori riferimenti

  • Aggiungere un sito alla foresta

  • Pianificare la replica tra siti

  • Aggiungere il catalogo globale a un sito


Elenco di controllo: configurare un sito aggiuntivo

Le attività per la configurazione di un nuovo sito includono:

  • Creazione del sito

  • Mapping degli indirizzi IP corretti al sito mediante la creazione di una subnet

  • Collegamento del sito a uno o più siti mediante la creazione di un collegamento di sito e l'aggiunta a esso del nuovo sito

Attività | Riferimento
(Facoltativo) Esaminare i concetti relativi ai siti e alla replica. | Informazioni su siti, subnet e collegamenti di sito
Creare un nuovo oggetto sito per rappresentare i controller di dominio in una posizione geografica. | Creare un sito
Identificare l'intervallo degli indirizzi IP che vengono utilizzati dai controller di dominio del sito e che identificano i controller di dominio come membri del sito, creando un oggetto subnet e associandolo al nuovo sito. | Creare una subnet
Creare un oggetto collegamento di sito che connette il nuovo sito a un sito esistente in modo da consentire la replica tra i due siti. L'oggetto collegamento di sito può essere utilizzato per gestire la pianificazione di replica. | Creare un collegamento di sito
Modificare l'associazione del collegamento di sito per il nuovo sito passando dal collegamento di sito esistente al nuovo collegamento di sito in modo da avviare la replica con il nuovo collegamento di sito. | Aggiungere o rimuovere un sito in un collegamento di sito


Elenco di controllo: configurare la pianificazione di replica tra siti

È possibile utilizzare oggetti collegamento di sito per controllare i periodi di tempo durante i quali può essere eseguita la replica tra i siti connessi da un collegamento di sito. In questi periodi di tempo è inoltre possibile controllare la frequenza con cui i partner di replica richiedono le modifiche ai rispettivi partner. Dopo aver configurato un nuovo collegamento di sito, è possibile verificare se la replica tra i siti ha esito positivo forzando la replica in ingresso sulle connessioni di entrambi i partner di replica.

Attività | Riferimento
(Facoltativo) Esaminare i concetti relativi alla replica tra siti. | Informazioni sulla replica tra siti Pianificare la replica tra siti
Configurare i periodi di tempo durante i quali è possibile la replica tra siti in modo da garantirne l'esecuzione solo quando la larghezza di banda della rete è maggiormente disponibile oppure uno scenario aziendale richiede i dati di directory più recenti. | Configurare la disponibilità della replica tra siti
Configurare la frequenza con cui viene eseguita la replica tra siti nei periodi di tempo durante i quali la replica è disponibile su un collegamento di sito. | Configurare la frequenza di replica tra siti


Elenco di controllo: aggiungere un server di catalogo globale

Se una foresta include più domini e in un sito è presente un elevato numero di utenti, è possibile ottimizzare la velocità e l'efficienza degli accessi al dominio e delle ricerche nelle directory aggiungendo un server di catalogo globale al sito.

In una foresta con dominio singolo non sono necessari server di catalogo globale per gli accessi, ma le ricerche nelle directory vengono indirizzate al catalogo globale. In questo caso, è possibile abilitare il catalogo globale in tutti i controller di dominio per velocizzare le ricerche nelle directory.

Attività | Riferimento
(Facoltativo) Esaminare i concetti relativi al catalogo globale. | Informazioni sul catalogo globale
Aggiungere o rimuovere le partizioni di directory di sola lettura del catalogo globale in un controller di dominio del sito. | Aggiungere o rimuovere il catalogo globale
Verificare che tutte le partizioni di directory di sola lettura siano state replicate nel nuovo server di catalogo globale. | Verificare la disponibilità del catalogo globale
Verificare che il server di catalogo globale venga annunciato nel DNS (Domain Name System). | Verificare le registrazioni DNS del catalogo globale


Aggiungere un sito alla foresta

Se si desidera distribuire controller di dominio in un'area di rete remota rispetto al sito hub, è possibile creare un oggetto sito in Servizi di dominio Active Directory per rappresentare la rete locale (LAN) nell'area remota. È necessario configurare il sito in modo da includere gli indirizzi di subnet assegnati alla rete LAN remota. Quando si crea un nuovo oggetto sito, è necessario inserire il sito in un collegamento di sito esistente. Se si dispone già di più siti, potrebbe essere necessario creare un collegamento di sito aggiuntivo per connettere il nuovo sito a un sito esistente.

Dopo la creazione di un nuovo sito, quando si aggiunge il ruolo server di Servizi di dominio Active Directory a un server dotato di un indirizzo IP mappato a tale sito è possibile specificare che l'oggetto server per il nuovo controller di dominio deve essere creato nel sito in base al relativo indirizzo IP. In alternativa, è possibile selezionare il sito per il nuovo controller di dominio e quindi configurarne l'indirizzo IP con un indirizzo mappato a una subnet di tale sito.

Requisiti per le procedure

Per le procedure di questa sezione sono previsti i requisiti seguenti:

  • Uno o più indirizzi di rete, nel formato indirizzo/prefisso. Tali indirizzi formano i nomi degli oggetti subnet quando si creano subnet.

  • Un collegamento di sito. Per creare un sito, è necessario aggiungere il nuovo sito a un collegamento di sito esistente. Se non esistono altri collegamenti di sito, è possibile utilizzare il collegamento di sito predefinito (DEFAULTIPSITELINK). Se sono presenti più di due siti esistenti e si aggiunge un sito, è possibile aggiungere il sito a un collegamento di sito esistente e quindi creare un nuovo collegamento di sito e associarvi il nuovo sito. Nella maggior parte dei casi, il nuovo sito verrà quindi rimosso dal collegamento di sito precedente.

  • Protocollo di trasporto disponibile per la replica sul collegamento di sito. Se tra i siti è disponibile un collegamento di rete WAN (Wide Area Network), utilizzare il trasporto IP. Se la connettività è intermittente o la connettività IP end-to-end non è disponibile, è possibile utilizzare SMTP (Simple Mail Transfer Protocol) per la replica nel sito. Per la replica SMTP, tuttavia, sono previste restrizioni. Per ulteriori informazioni sulla replica SMTP, vedere Informazioni sulla replica tra siti.

Per aggiungere un sito a una foresta, eseguire le procedure seguenti:

  • Creare un sito

  • Creare una subnet

  • Creare un collegamento di sito

  • Aggiungere o rimuovere un sito in un collegamento di sito

Ulteriori riferimenti

  • Informazioni su siti, subnet e collegamenti di sito


Informazioni su siti, subnet e collegamenti di sito

La conoscenza dei siti, delle subnet e dei collegamenti di sito consente di gestire in modo efficiente i siti e la relativa implementazione in Servizi di dominio Active Directory.

Panoramica dei siti

I siti di Servizi di dominio Active Directory rappresentano la struttura fisica, o topologia, della rete. Servizi di dominio Active Directory utilizza le informazioni sulla topologia di rete, archiviate nella directory come oggetti sito, subnet e collegamento di sito, per creare la topologia di replica più efficiente. La topologia di replica è costituita dall'insieme degli oggetti connessione che consentono la replica in ingresso da un controller di dominio di origine al controller di dominio di destinazione in cui è archiviato l'oggetto connessione. Tali oggetti connessione vengono creati automaticamente da Controllo di coerenza informazioni (KCC) in ogni controller di dominio.

Nota

Non è necessario gestire gli oggetti connessione. Le modifiche apportate agli oggetti connessione creati automaticamente da Controllo di coerenza informazioni vengono infatti ignorate.

È possibile utilizzare lo snap-in Siti e servizi di Active Directory per gestire gli oggetti sito, subnet e collegamento di sito la cui combinazione determina la topologia di replica.

Nota

È inoltre possibile utilizzare Siti e servizi di Active Directory per gestire i siti in un set di configurazione Active Directory Lightweight Directory Services (AD LDS).

È importante distinguere tra siti e domini. I siti rappresentano la struttura fisica della rete, mentre i domini rappresentano la struttura logica dell'organizzazione. Gli oggetti sito e il relativo contenuto vengono replicati in tutti i controller di dominio della foresta, indipendentemente dal dominio o dal sito.

Utilizzare i siti

I controller di dominio e gli altri server che utilizzano i siti pubblicano oggetti server in Servizi di dominio Active Directory per sfruttare la connettività di rete efficiente offerta dai siti. I controller di dominio vengono inseriti nei siti in base alla posizione in cui sono necessari i dati di dominio. Se nessun utente di un dominio è fisicamente incluso in un sito, ad esempio, non è necessario inserire un controller per tale dominio nel sito.

I siti consentono di facilitare diverse attività:

  • Replica. Servizi di dominio Active Directory consente di bilanciare l'esigenza di informazioni della directory aggiornate con l'esigenza di un'ottimizzazione della larghezza di banda replicando le informazioni all'interno di un sito ogni volta che vengono aggiornati i dati e tra i siti in base a una pianificazione configurabile.

  • Autenticazione. Le informazioni sul sito consentono un'autenticazione più rapida ed efficiente. Quando accede a un dominio, un client richiede innanzitutto un controller di dominio del sito locale ai fini dell'autenticazione. Con la creazione di siti, è possibile garantire che i client utilizzino i controller di dominio più vicini per l'autenticazione, riducendo così la latenza di autenticazione e il traffico sulle connessioni di rete WAN.

  • Posizione dei servizi. Altri servizi, ad esempio Servizi certificati Active Directory, Exchange Server e Accodamento messaggi, utilizzano Servizi di dominio Active Directory per archiviare oggetti in grado di utilizzare le informazioni su siti e subnet che consentono ai client di individuare più facilmente i provider di servizi più vicini.

Associare siti e subnet

Un oggetto subnet di Servizi di dominio Active Directory raggruppa computer adiacenti nello stesso modo in cui i codici postali raggruppano indirizzi postali adiacenti. Associando un sito a una o più subnet, si assegna al sito un insieme di indirizzi IP.

Nota

Al termine "subnet" in Servizi di dominio Active Directory non corrisponde la rigida definizione di rete dell'insieme di tutti gli indirizzi dietro un singolo router. L'unico requisito per una subnet di Servizi di dominio Active Directory è la conformità del prefisso di indirizzo al formato IP versione 4 (IPv4) o IP versione 6 (IPv6).

Quando si aggiungere il ruolo server di Servizi di dominio Active Directory per creare il primo controller di dominio di una foresta, in Servizi di dominio Active Directory viene creato un sito predefinito (Nome-predefinito-primo-sito). Se tale sito costituisce l'unico sito nella directory, tutti i controller di dominio aggiunti alla foresta vengono assegnati a questo sito. Se la foresta include più siti, invece, è necessario creare subnet per assegnare indirizzi IP sia a Nome-predefinito-primo-sito che a tutti i siti aggiuntivi.

Assegnare computer ai siti

Gli oggetti server vengono creati in Servizi di dominio Active Directory da applicazioni e servizi e inseriti in un sito in base all'indirizzo IP. Quando si aggiunge il ruolo server di Servizi di dominio Active Directory a un server, viene creato un oggetto server nel sito di Servizi di dominio Active Directory contenente la subnet a cui è mappato l'indirizzo IP del server. Se l'indirizzo IP del controller di dominio non è mappato ad alcun sito della foresta, l'oggetto server del controller di dominio viene creato nel sito del controller di dominio che fornisce l'origine di replica per Servizi di dominio Active Directory.

Nota

Gli oggetti server non vengono creati per impostazione predefinita in Nome-predefinito-primo-sito a meno che nella foresta non siano presenti altri siti.

Per un client, l'assegnazione del sito è determinata in modo dinamico dal relativo indirizzo IP e dalla relativa subnet mask durante l'accesso.

Individuazione dei controller di dominio in base al sito

I controller di dominio registrano record di risorse servizi (SRV) del DNS (Domain Name System) che ne identificano i nomi dei siti. I controller di dominio registrano inoltre record di risorse host (A) del DNS che ne identificano gli indirizzi IP. Quando un client richiede un controller di dominio, ne fornisce il nome del sito al DNS. Il nome del sito viene utilizzato dal DNS per individuare un controller di dominio in tale sito o nel successivo sito più vicino al client. Il DNS passa quindi l'indirizzo IP del controller di dominio al client per la connessione al controller di dominio. Per questo motivo, è importante verificare che l'indirizzo IP assegnato a un controller di dominio sia mappato a una subnet associata al sito del rispettivo oggetto server. In caso contrario, quando un client richiede un controller di dominio l'indirizzo IP restituito potrebbe corrispondere all'indirizzo IP di un controller di dominio di un sito distante. La connessione di un client a un sito distante può determinare prestazioni ridotte e traffico superfluo su costosi collegamenti WAN.

Connettere i siti con collegamenti di sito

Le reti sono in genere costituite da un insieme di reti locali (LAN) connesse tramite WAN. In Servizi di dominio Active Directory, gli oggetti collegamento di sito rappresentano le connessioni WAN tra i siti. Mentre la replica all'interno di un sito viene attivata automaticamente quando si verifica un aggiornamento della directory, la replica tra siti (su collegamenti WAN più lenti e costosi) è pianificata in modo da essere eseguita ogni 3 ore. È possibile modificare la pianificazione predefinita affinché venga eseguita durante i periodi e agli intervalli specificati, in modo da controllare il traffico sui collegamenti WAN.

Ulteriori riferimenti

  • Informazioni sulla replica tra siti

  • Aggiungere un sito alla foresta


Creare un sito

È possibile utilizzare lo snap-in Siti e servizi di Active Directory per creare nuovi siti nell'ambiente in uso.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare un sito

  1. Aprire Siti e servizi di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Siti e servizi di Active Directory.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Siti e quindi scegliere Nuovo sito.

  3. In Nome digitare il nome del nuovo sito.

  4. In Nome collegamento fare clic su un oggetto collegamento di sito e quindi fare clic su OK.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Aggiungere un sito alla foresta


Creare una subnet

È possibile utilizzare lo snap-in Siti e servizi di Active Directory per creare nuove subnet.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare una subnet

  1. Aprire Siti e servizi di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Siti e servizi di Active Directory.

  2. Nell'albero della console fare doppio clic su Siti, fare clic con il pulsante destro del mouse su Subnet e quindi scegliere Nuova subnet.

  3. In Prefisso digitare il prefisso di subnet IP versione 4 (IPv4) o IP versione 6 (IPv6).

  4. In Selezionare un oggetto sito per il prefisso fare clic sul sito associato alla subnet e quindi fare clic su OK.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Aggiungere un sito alla foresta


Creare un collegamento di sito

È possibile utilizzare lo snap-in Siti e servizi di Active Directory per creare nuovi collegamenti di sito.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare un collegamento di sito

  1. Aprire Siti e servizi di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Siti e servizi di Active Directory.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul protocollo di trasporto tra siti che si desidera venga utilizzato sul collegamento di sito.

    Percorso

    • Active Directory Sites and Services\Sites\Inter-Site Transports\IP o SMTP

  3. Scegliere Nuovo collegamento di sito.

  4. In Nome digitare il nome del collegamento di sito.

  5. In Siti non presenti nel collegamento di sito fare clic su un sito da aggiungere al collegamento di sito e quindi fare clic su Aggiungi. Ripetere questa operazione per aggiungere ulteriori siti al collegamento di sito. Per rimuovere un sito dal collegamento di sito, fare clic sul sito in Siti presenti nel collegamento di sito e quindi su Rimuovi.

  6. Dopo aver aggiunto i siti che si desidera siano connessi dal collegamento di sito, fare clic su OK.
Importante

Utilizzare il trasporto tra siti IP a meno che la rete in uso non disponga di siti remoti in cui la connettività di rete è intermittente o la connettività IP end-to-end non è disponibile. Per la replica SMTP (Simple Mail Transfer Protocol) sono previste restrizioni che non sono valide per la replica IP. Per ulteriori informazioni sull'utilizzo del trasporto SMTP, vedere Informazioni sulla replica tra siti.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Aggiungere un sito alla foresta


Aggiungere o rimuovere un sito in un collegamento di sito

Quando si aggiungono siti e collegamenti di sito alla foresta, è possibile creare una condizione in cui lo stesso sito viene aggiunto a due collegamenti di sito, nonché creare una condizione in cui un collegamento di sito non contiene tutti i siti per cui è necessaria la replica sul collegamento di sito. Per aggiungere e rimuovere siti nei collegamenti di sito, è possibile utilizzare lo snap-in Siti e servizi di Active Directory.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere o rimuovere un sito in un collegamento di sito

  1. Aprire Siti e servizi di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Siti e servizi di Active Directory.

  2. Nell'albero della console fare clic sulla cartella del trasporto tra siti contenente il collegamento di sito in cui si sta aggiungendo o rimuovendo un sito.

    Percorso

    • Active Directory Sites and Services\Sites\Inter-Site Transports\IP o SMTP

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul collegamento di sito in cui si desidera aggiungere o rimuovere un sito e quindi scegliere Proprietà.

  4. Nell'elenco appropriato fare clic sul sito che si desidera aggiungere o rimuovere nel collegamento di sito e quindi fare clic rispettivamente su Aggiungi o Rimuovi.
Importante

Utilizzare il trasporto tra siti IP a meno che la rete in uso non disponga di siti remoti in cui la connettività di rete è intermittente o la connettività IP end-to-end non è disponibile. Per la replica SMTP (Simple Mail Transfer Protocol) sono previste restrizioni che non sono valide per la replica IP. Per ulteriori informazioni sull'utilizzo del trasporto SMTP, vedere Informazioni sulla replica tra siti.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Aggiungere un sito alla foresta


Pianificare la replica tra siti

Per controllare la replica tra due siti, è possibile utilizzare lo snap-in Siti e servizi di Active Directory per configurare le impostazioni per l'oggetto collegamento di sito a cui vengono aggiunti i siti. Configurando le impostazioni per un collegamento di sito, è possibile controllare quando viene eseguita la replica tra due o più siti e la frequenza di esecuzione. Al momento della configurazione delle impostazioni per un collegamento di sito, considerare il traffico di rete generato dalle applicazioni line-of-business, le ore in cui vengono eseguite le operazioni aziendali e i periodi di massima attività durante la giornata lavorativa. Valutare queste considerazioni rispetto all'esigenza di aggiornamenti di directory nei siti remoti. Si potrebbe ad esempio decidere che una replica al giorno, dopo l'orario di ufficio durante un periodo di scarso traffico, è sufficiente per consentire agli utenti dei siti remoti di svolgere le proprie attività.

Requisiti per le procedure

Per le procedure di questa sezione sono previsti i requisiti seguenti:

  • Un oggetto collegamento di sito che rappresenta un collegamento di rete WAN (Wide Area Network) fisico tra due o più siti

  • Informazioni sul traffico di rete WAN tra i siti e sui requisiti di aggiornamento degli utenti e delle applicazioni dei siti remoti

Per pianificare la replica tra i siti, eseguire le procedure seguenti:

  • Configurare la disponibilità della replica tra siti

  • Configurare la frequenza di replica tra siti

Ulteriori riferimenti

  • Informazioni sulla replica tra siti


Informazioni sulla replica tra siti

La replica tra siti viene gestita da Servizi di dominio Active Directory in modo diverso rispetto alla replica all'interno di siti, poiché la larghezza di banda tra siti è in genere limitata. La topologia di replica tra siti viene creata da Controllo di coerenza informazioni (KCC) di Active Directory utilizzando una progettazione ad albero di spanning basata sul costo minimo. La replica tra siti è ottimizzata per un utilizzo efficiente della larghezza di banda. Gli aggiornamenti di directory tra i siti vengono eseguiti automaticamente in base a una pianificazione configurabile. Gli aggiornamenti di directory replicati tra i siti vengono compressi per risparmiare larghezza di banda.

Creare la topologia di replica tra siti

Servizi di dominio Active Directory utilizza le informazioni specificate (tramite lo snap-in Siti e servizi di Active Directory) relativamente ai siti e ai collegamenti di sito per creare automaticamente la topologia di replica tra siti più efficiente. La topologia di replica viene archiviata nella directory sotto forma di oggetti connessione, creati automaticamente dal sistema per realizzare la topologia di replica sia all'interno dei siti che tra siti. Gli oggetti connessione identificano i partner di replica sia per la replica all'interno di un sito che per la replica tra siti. Questi oggetti rappresentano sempre la replica unidirezionale in ingresso verso il server contenente l'oggetto. La topologia di replica tra siti viene aggiornata regolarmente per riflettere le modifiche che si verificano all'interno della rete. Non è necessario creare o gestire oggetti connessione. È tuttavia possibile controllare i tempi della replica tra siti tramite le informazioni specificate al momento della configurazione degli oggetti collegamento di sito.

Nota

È possibile utilizzare Siti e servizi di Active Directory per amministrare la replica dei dati di directory tra tutti i siti in un set di configurazione Active Directory Lightweight Directory Services.

Determinare quando deve essere eseguita la replica tra siti

Servizi di dominio Active Directory risparmia larghezza di banda tra i siti riducendo al minimo la frequenza di replica e consentendo di pianificare la disponibilità dei collegamenti di sito per la replica. Per impostazione predefinita, la replica tra siti su ogni collegamento di sito viene eseguita ogni 180 minuti (3 ore). Tale frequenza può essere regolata in base alle specifiche esigenze, tenendo tuttavia presente che l'aumento della frequenza determina l'utilizzo di una maggiore quantità di larghezza di banda per la replica. Oltre alla frequenza di replica, è possibile pianificare la disponibilità dei collegamenti di sito per la replica. Per impostazione predefinita, un collegamento di sito è disponibile per il traffico di replica 24 ore su 24, 7 giorni su 7. È possibile limitare la pianificazione a determinati giorni della settimana e specifiche ore del giorno. È possibile, ad esempio, pianificare la replica tra siti affinché venga eseguita soltanto dopo il normale orario di lavoro, cinque giorni alla settimana.

Se sono stati configurati più collegamenti di sito e tra due siti sono pertanto disponibili più route, è possibile configurare il costo della replica sul collegamento di sito in modo da identificare una preferenza per una route rispetto all'altra. Per ulteriori informazioni sull'impatto del costo sulle route della replica tra siti, vedere la pagina relativa al funzionamento della topologia di replica di Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93526. Per ulteriori informazioni sulla configurazione del costo dei collegamenti di sito, vedere la pagina relativa all'amministrazione della replica tra siti all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93527.

Utilizzare i tipi di trasporto di replica

Il tipo di trasporto predefinito per la replica di Servizi di dominio Active Directory all'interno dei siti è RPC (Remote Procedure Call) su IP. Il trasporto RPC su IP viene inoltre utilizzato per la replica tra siti. Il contenitore IP di Siti e servizi di Active Directory contiene oggetti che rappresentano collegamenti di sito che utilizzano RPC su IP per la creazione di pacchetti e il trasferimento dei dati di replica. Per mantenere i dati sicuri durante la trasmissione tra i siti, la replica RPC su IP utilizza sia l'autenticazione, con il protocollo di autenticazione Kerberos versione 5 (V5), che la crittografia dei dati.

Quando non è disponibile una connessione IP diretta o affidabile, è possibile configurare la replica tra i siti in modo da utilizzare SMTP (Simple Mail Transfer Protocol). Le funzionalità della replica SMTP sono tuttavia limitate alla replica non di dominio (aggiornamenti dello schema, della configurazione e del catalogo globale). In caso di utilizzo su collegamenti di sito, è inoltre necessaria un'autorità di certificazione dell'organizzazione (enterprise). In Windows Server 2008 R2 il componente SMTP della messaggistica tra siti è facoltativo e deve essere aggiunto per poter utilizzare SMTP per la replica. Per ulteriori informazioni sulla replica SMTP, vedere la pagina relativa al funzionamento della topologia di replica di Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93526.

Nota

La replica tra siti attraverso un firewall o una rete privata virtuale (VPN) richiede alcune considerazioni speciali. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Active Directory in reti segmentate tramite firewall all'indirizzo http://go.microsoft.com/fwlink?linkid=45087.

Ulteriori riferimenti

  • Informazioni su siti, subnet e collegamenti di sito

  • Pianificare la replica tra siti


Configurare la disponibilità della replica tra siti

Per controllare i periodi di tempo durante i quali può essere eseguita la replica tra siti su un collegamento di sito, è possibile utilizzare lo snap-in Siti e servizi di Active Directory per configurare le impostazioni relative alla disponibilità nella pianificazione del collegamento di sito.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare la disponibilità della replica tra siti

  1. Aprire Siti e servizi di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Siti e servizi di Active Directory.

  2. Nell'albero della console fare clic sulla cartella del trasporto tra siti contenente il collegamento di sito per cui si sta configurando la disponibilità della replica tra siti.

    Percorso

    • Active Directory Sites and Services\Sites\Inter-Site Transports\IP o SMTP

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul collegamento di sito da configurare e quindi scegliere Proprietà.

  4. Fare clic su Cambia pianificazione.

    Nota

    Quando si accede con un account che non dispone di credenziali sufficienti per modificare la pianificazione, l'opzione disponibile è Visualizza pianificazione.

  5. Selezionare il periodo di tempo durante il quale si desidera che la replica sia disponibile o non disponibile e quindi fare clic rispettivamente su Replica disponibile o su Replica non disponibile.
Importante

Utilizzare il trasporto tra siti IP a meno che la rete in uso non disponga di siti remoti in cui la connettività di rete è intermittente o la connettività IP end-to-end non è disponibile. Per la replica SMTP (Simple Mail Transfer Protocol) sono previste restrizioni che non sono valide per la replica IP. Per ulteriori informazioni sull'utilizzo del trasporto SMTP, vedere Informazioni sulla replica tra siti.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Pianificare la replica tra siti


Configurare la frequenza di replica tra siti

Per specificare la frequenza con cui la replica può essere eseguita durante qualsiasi periodo di disponibilità nella pianificazione della replica tra siti, è possibile utilizzare lo snap-in Siti e servizi di Active Directory per configurare l'impostazione relativa alla frequenza nelle proprietà dell'oggetto collegamento di sito. All'intervallo specificato, ad esempio una volta ogni 60 minuti, un controller di dominio che funge da server testa di ponte in un sito richiede le modifiche al partner di replica di origine in un diverso sito.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare la frequenza di replica tra siti

  1. Aprire Siti e servizi di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Siti e servizi di Active Directory.

  2. Nell'albero della console fare clic sulla cartella del trasporto tra siti contenente il collegamento di sito per cui si sta configurando la disponibilità della replica tra siti.

    Percorso

    • Active Directory Sites and Services\Sites\Inter-Site Transports\IP o SMTP

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul collegamento di sito da configurare e quindi scegliere Proprietà.

  4. In Replica ogni digitare o selezionare il numero di minuti tra le repliche.
Importante

Utilizzare il trasporto tra siti IP a meno che la rete in uso non disponga di siti remoti in cui la connettività di rete è intermittente o la connettività IP end-to-end non è disponibile. Per la replica SMTP (Simple Mail Transfer Protocol) sono previste restrizioni che non sono valide per la replica IP. Per ulteriori informazioni sull'utilizzo del trasporto SMTP, vedere Informazioni sulla replica tra siti.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Domain Admins nel dominio radice della foresta o al gruppo Enterprise Admins nella foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

  • La frequenza di replica predefinita per i collegamenti di sito è 180 minuti.

  • Il valore di Replica ogni verrà elaborato come il multiplo più vicino di 15 minuti, da un minimo di 15 minuti a un massimo di 10.080 minuti (1 settimana).

Ulteriori riferimenti

  • Pianificare la replica tra siti


Aggiungere il catalogo globale a un sito

Un server di catalogo globale consente di eseguire ricerche nell'intera foresta di Servizi di dominio Active Directory senza riferimenti a un controller del dominio contenente la destinazione dell'operazione di ricerca. Quando si aggiunge il catalogo globale a un controller di dominio, nel controller di dominio viene eseguita una replica parziale di sola lettura di ogni dominio della foresta (ad eccezione del dominio archiviato nel nuovo server di catalogo globale). I server di catalogo globale sono necessari per la ricerca e per l'elaborazione degli accessi al dominio nelle foreste in cui sono disponibili gruppi universali.

Server di catalogo globale e domini

I server di catalogo globale rispondono alle query LDAP (Lightweight Directory Access Protocol) a livello di foresta sulla porta 3268. Il catalogo globale elimina l'esigenza di inviare una query a più controller di dominio finché non viene individuato il dominio contenente l'oggetto richiesto.

Quando una foresta contiene un solo dominio, tutti i controller di dominio dispongono di tutti gli oggetti su cui possono essere eseguite ricerche e non è necessario un server di catalogo globale per eliminare i riferimenti ad altri domini. Poiché la porta del catalogo globale è diversa dalla porta LDAP predefinita (389), tuttavia, le query sul catalogo globale devono individuare un server di catalogo globale. In una foresta con dominio singolo, la configurazione di tutti i controller di dominio come server di catalogo globale consente di garantire il bilanciamento uniforme del carico delle query sul catalogo globale tra tutti i controller del dominio. Poiché non è necessaria un'ulteriore replica o elaborazione di altri dati di dominio, il server di catalogo globale con dominio singolo non necessita di speciali vantaggi a livello di hardware rispetto agli altri controller di dominio.

Se una foresta contiene più domini, invece, un server di catalogo globale deve archiviare e replicare dati di dominio per tutti i domini della foresta. In questo caso, determinare l'inserimento di server di catalogo globale nella foresta in base alle esigenze dei siti, come descritto nella sezione seguente.

Server di catalogo globale e siti

Per ottimizzare le prestazioni di rete in un ambiente con più siti, è possibile aggiungere server di catalogo globale nei siti in base alle relative esigenze in termini di rapidità di risposta alle ricerche e accessi al dominio. In un ambiente con più domini e un singolo sito, per gestire gli accessi e le query comuni di Active Directory è in genere sufficiente un singolo server di catalogo globale. Utilizzare le informazioni disponibili nella tabella seguente per determinare se un ambiente con più domini e più siti può trarre vantaggio da server di catalogo globale aggiuntivi.

Casi in cui utilizzare un catalogo globale Vantaggio Svantaggio

Un'applicazione comunemente utilizzata del sito utilizza la porta 3268 per risolvere le query sul catalogo globale.

Prestazioni migliori

Traffico di rete aggiuntivo causato dalla replica del catalogo globale

Per connettersi ad altri siti viene utilizzata una connessione di rete WAN lenta o inaffidabile. Utilizzare le stesse regole di errore e di distribuzione del carico utilizzate per i singoli controller di dominio per determinare se sono necessari server di catalogo globale in ogni sito.

Tolleranza di errore

Traffico di rete aggiuntivo causato dalla replica del catalogo globale

Nel sito sono presenti utenti che appartengono a un dominio Windows 2000 con livello di funzionalità del dominio impostato su Windows 2000 originale. In questo caso, tutti gli utenti devono ottenere informazioni sull'appartenenza a gruppi universali da un server di catalogo globale. Se nello stesso sito non è incluso un server di catalogo globale, tutte le richieste di accesso devono essere indirizzate su una connessione WAN a un server di catalogo globale di un altro sito.

È possibile utilizzare la memorizzazione nella cache dell'appartenenza a gruppi universali, una funzionalità disponibile nei controller di dominio che eseguono Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2, per eliminare l'esigenza di contattare un server di catalogo globale di un sito diverso durante gli accessi al dominio.

Rapidità di accesso degli utenti

Traffico di rete aggiuntivo causato dalla replica del catalogo globale

Ulteriori riferimenti

  • Informazioni sul catalogo globale

  • Aggiungere o rimuovere il catalogo globale

  • Verificare la disponibilità del catalogo globale

  • Verificare le registrazioni DNS del catalogo globale


Informazioni sul catalogo globale

Il catalogo globale è l'insieme di tutti gli oggetti di una foresta di Servizi di dominio Active Directory. Un server di catalogo globale è un controller di dominio in cui viene archiviata una copia completa di tutti gli oggetti della directory per il dominio host e una copia parziale di sola lettura di tutti gli oggetti per tutti gli altri domini della foresta. I server di catalogo globale rispondono alle query sul catalogo globale.

Attributi replicati nel catalogo globale

Le copie parziali di sola lettura contenute nel catalogo globale vengono definite "parziali" poiché includono un set limitato di attributi, costituito dagli attributi necessari per lo schema e dagli attributi più comunemente utilizzati nelle operazioni di ricerca degli utenti. Tali attributi vengono contrassegnati per l'inclusione nel set di attributi parziali (PAS) nell'ambito delle relative definizioni dello schema. L'archiviazione degli attributi su cui vengono più comunemente eseguite ricerche per tutti gli oggetti dominio nel catalogo globale garantisce ricerche più efficienti per gli utenti senza influire sulle prestazioni di rete con riferimenti superflui a controller di dominio e senza richiedere l'archiviazione di ingenti quantità di dati non necessari in un server di catalogo globale.

Funzionalità del catalogo globale

Quando si installa Servizi di dominio Active Directory, il catalogo globale per una nuova foresta viene creato automaticamente nel primo controller di dominio della foresta. È possibile aggiungere funzionalità di catalogo globale a ulteriori controller di dominio, nonché rimuovere il catalogo globale da un controller di dominio.

Un server di catalogo globale esegue le operazioni seguenti.

  • Individuazione di oggetti.

    Il catalogo globale supporta ricerche degli utenti relative alle informazioni della directory in tutti i domini di una foresta, indipendentemente dalla posizione in cui i dati sono archiviati. Le ricerche in una foresta vengono eseguite con la massima velocità e un traffico di rete minimo.

    Quando un utente cerca utenti o stampanti dal menu Start oppure seleziona l'opzione Directory completa in una query, la ricerca dell'utente viene eseguita nel catalogo globale. Dopo che è stata immessa dall'utente, una richiesta di ricerca viene indirizzata alla porta predefinita del catalogo globale 3268 e viene inviata a un server di catalogo globale per la risoluzione.

  • Autenticazione del nome dell'entità utente.

    Un server di catalogo globale risolve un nome dell'entità utente (UPN) quando il controller di dominio che esegue l'autenticazione non è in grado di determinare l'account utente. Ad esempio, se l'account di un utente è incluso in vendite1.cohovineyard.com e l'utente accede con l'UPN luigi@vendite1.cohovineyard.com da un computer in vendite2.cohovineyard.com, il controller di dominio di vendite2.cohovineyard.com non è in grado di individuare l'account dell'utente e deve contattare un server di catalogo globale per completare il processo di accesso.

  • Convalida dei riferimenti a oggetti in una foresta.

    I controller di dominio utilizzano il catalogo globale per convalidare i riferimenti a oggetti di altri domini della foresta. Quando un controller di dominio include un oggetto directory con un attributo contenente un riferimento a un oggetto di un altro dominio, il controller di dominio convalida il riferimento contattando il server di catalogo globale.

  • Passaggio di informazioni sull'appartenenza a gruppi universali in un ambiente con più domini.

    Un controller di dominio è sempre in grado di individuare le appartenenze a gruppi globali e gruppi locali di dominio per qualsiasi utente del proprio dominio e l'appartenenza a tali gruppi non viene replicata nel catalogo globale. In una foresta con dominio singolo, un controller di dominio può sempre individuare inoltre l'appartenenza a gruppi universali. I gruppi universali possono tuttavia includere membri di domini diversi. Per questo motivo, l'attributo member dei gruppi universali, contenente l'elenco dei membri del gruppo, viene replicato nel catalogo globale. Quando un utente di una foresta con più domini accede a un dominio in cui sono consentiti gruppi universali, il controller di dominio deve contattare un server di catalogo globale per recuperare qualsiasi appartenenza a gruppi universali di cui l'utente potrebbe disporre in altri domini.

    Se non è disponibile un server di catalogo globale al momento dell'accesso dell'utente a un dominio in cui sono disponibili gruppi universali, il computer client dell'utente può accedere utilizzando le credenziali memorizzate nella cache, a condizione che l'utente abbia in precedenza eseguito l'accesso al dominio. In caso contrario, l'utente può accedere soltanto al computer locale.

    Nota

    L'amministratore del dominio (account Administrator predefinito) può sempre accedere al dominio, anche quando non è disponibile un server di catalogo globale.

Memorizzazione nella cache dell'appartenenza a gruppi universali

Nei controller di dominio che eseguono Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2 in un sito che non dispone di un server di catalogo globale, è possibile utilizzare la memorizzazione nella cache dell'appartenenza a gruppi universali per ridurre l'esigenza di contattare un server di catalogo globale di un sito diverso. Quando questa funzionalità è attivata, al primo accesso di un utente a un dominio in cui sono disponibili gruppi universali vengono memorizzate nella cache del controller di dominio informazioni sull'appartenenza dell'utente a gruppi universali. Successivamente, il controller di dominio utilizza le informazioni sull'appartenenza memorizzate nella cache per elaborare l'accesso, anziché contattare un server di catalogo globale.

Ulteriori riferimenti

  • Aggiungere il catalogo globale a un sito

  • Aggiungere o rimuovere il catalogo globale


Aggiungere o rimuovere il catalogo globale

È possibile utilizzare la stessa interfaccia utente dello snap-in Siti e servizi di Active Directory per aggiungere o rimuovere il catalogo globale. L'abilitazione del catalogo globale può causare traffico di replica aggiuntivo. La rimozione del catalogo globale viene invece eseguita gradualmente in background e non influisce sulla replica o sulle prestazioni.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere o rimuovere il catalogo globale

  1. Aprire Siti e servizi di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Siti e servizi di Active Directory.

  2. Nell'albero della console fare clic sull'oggetto server a cui si desidera aggiungere il catalogo globale o da cui si desidera rimuoverlo.

    Percorso

    • Siti e servizi di Active Directory\Siti\NomeSito\Server

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su Impostazioni NTDS per l'oggetto server selezionato e quindi scegliere Proprietà.

  4. Selezionare la casella di controllo Catalogo globale per aggiungere il catalogo globale oppure deselezionare la casella di controllo per rimuoverlo.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Domain Admins nel dominio del controller di dominio selezionato o al gruppo Enterprise Admins nella foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

  • Il controller di dominio non viene annunciato nel DNS (Domain Name System) come server di catalogo globale finché non sono state ricevute tutte le partizioni parziali di directory del dominio.

  • Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare il modulo Active Directory per Windows PowerShell™. Per aprire Modulo di Active Directory, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Modulo Active Directory per Windows PowerShell. Per ulteriori informazioni, vedere la pagina relativa all'aggiunta o alla rimozione del catalogo globale (http://go.microsoft.com/fwlink/?LinkId=138333). Per ulteriori informazioni su Windows PowerShell, vedere la pagina relativa a Windows PowerShell (http://go.microsoft.com/fwlink/?LinkID=102372).

Ulteriori riferimenti

  • Aggiungere il catalogo globale a un sito


Verificare la disponibilità del catalogo globale

Quando un server di catalogo globale soddisfa i requisiti della replica, l'attributo rootDSE isGlobalCatalogReady è impostato su TRUE e il catalogo globale è disponibile per i computer client. Per verificare questa impostazione, è possibile utilizzare le procedure seguenti nello snap-in LDP o alla riga di comando.

Per eseguire queste procedure, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Verificare la disponibilità del catalogo globale

  • Tramite l'interfaccia di Windows

  • Tramite un prompt dei comandi
Per verificare la disponibilità del catalogo globale tramite l'interfaccia di Windows

  1. Aprire lo snap-in LDP. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare ldp e quindi fare clic su OK.

  2. Scegliere Connetti dal menu Connessione.

  3. In Connetti digitare il nome del server per il quale si desidera verificare la disponibilità del catalogo globale.

  4. In Porta digitare 389, se non è già visualizzato.

  5. Deselezionare la casella di controllo Senza connessione, se selezionata, e quindi fare clic su OK.

  6. Nel riquadro dei dettagli verificare che il valore dell'attributo isGlobalCatalogReady sia TRUE.

  7. Scegliere Disconnetti dal menu Connessione e quindi chiudere LDP.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Domain Admins nel dominio del controller di dominio selezionato o al gruppo Enterprise Admins nella foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Aggiungere il catalogo globale a un sito

  • Panoramica di LDP (http://go.microsoft.com/fwlink/?LinkId=93561)

Per verificare la disponibilità del catalogo globale tramite riga di comando

  1. Aprire un prompt dei comandi. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare cmd e quindi fare clic su OK.

  2. Digitare il comando seguente e quindi premere INVIO:

    nltest /server:<servername> /dsgetdc:<domainname>

    Valore Descrizione

    nltest

    Esegue attività amministrative di rete.

    /server:<ServerName>

    Specifica il nome del controller di dominio designato come server di catalogo globale.

    /dsgetsdc:<nomedominio>

    Specifica il nome del dominio a cui appartiene il server.

    Se nella riga Flags dell'output viene visualizzato GC, il server di catalogo globale ha soddisfatto i requisiti della replica.

Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:

nltest /?

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Domain Admins nel dominio del controller di dominio selezionato o al gruppo Enterprise Admins nella foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Aggiungere il catalogo globale a un sito

  • Panoramica di nltest (http://go.microsoft.com/fwlink/?LinkId=93567)


Verificare le registrazioni DNS del catalogo globale

Per verificare l'annuncio di un server come server di catalogo globale, è possibile utilizzare lo snap-in Gestore DNS per verificare la presenza di record di risorse Posizione servizio (SRV) del DNS (Domain Name System) per il server di catalogo globale.

Per eseguire queste procedure, è necessaria almeno l'appartenenza al gruppo Enterprise Admins nella foresta o al gruppo Domain Admins nel dominio radice della foresta oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per verificare le registrazioni DNS del catalogo globale

  1. Riavviare il server di catalogo globale di cui si desidera verificare le registrazioni DNS.

  2. Aprire Gestore DNS. Per aprire Gestore DNS, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su DNS.

  3. Per connettersi a un controller del dominio radice della foresta per cui si desidera verificare le registrazioni DNS, fare clic con il pulsante destro del mouse su DNS e quindi scegliere Connetti al server DNS.

  4. Nell'albero della console fare clic sul contenitore _tcp per il dominio radice della foresta.

    Percorso

    • DNS\ServerDNS\Zone di ricerca diretta\DominioRadiceForesta\

  5. Nella colonna Nome del riquadro dei dettagli cercare _gc e nella colonna Dati cercare il nome del server. I record che iniziano con _gc sono record di risorse Posizione servizio (SRV) del catalogo globale.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Domain Admins nel dominio del controller di dominio selezionato o al gruppo Enterprise Admins nella foresta o, in alternativa, la delega dell'autorità appropriata. Per assicurare un livello di sicurezza ottimale, utilizzare Esegui come amministratore per eseguire questa procedura. Per gestire Servizi di dominio Active Directory, accedere con l'account utente di livello più basso e utilizzare credenziali amministrative.

Ulteriori riferimenti

  • Aggiungere il catalogo globale a un sito


Risolvere i problemi relativi alla replica di Servizi di dominio Active Directory

Problema riscontrato

  • È necessario individuare i problemi di replica.

  • La replica tra siti è lenta.

È necessario individuare i problemi di replica.

  • Causa: monitorare regolarmente la replica per identificare e risolvere i problemi prima che si espandano.

  • Soluzione: un monitoraggio regolare è essenziale per una manutenzione efficiente della replica. Come strumenti principali per il monitoraggio della replica è possibile utilizzare Repadmin.exe, Dcdiag.exe e il registro eventi del servizio directory (nel Visualizzatore eventi).

    Repadmin è uno strumento da riga di comando che segnala gli errori tra due partner di replica. Nell'esempio relativo a repadmin seguente vengono visualizzati i partner di replica e tutti gli errori di replica per server1 nel dominio adatum.com:

    repadmin /showrepl server1.adatum.com

    Per un elenco completo delle opzioni di repadmin, utilizzare l'opzione ?:

    repadmin /?

    Dcdiag è uno strumento da riga di comando in grado di controllare la registrazione DNS (Domain Name System) di un controller di dominio, verificare che gli ID di sicurezza (SID) nei vertici dei contesti dei nomi dispongano delle autorizzazioni appropriate per la replica, analizzare lo stato dei controller di dominio di una foresta o un'organizzazione e altro ancora. Nell'esempio relativo a dcdiag seguente viene verificata l'eventuale presenza di errori tra i controller di dominio:

    dcdiag /test:replications

    Per un elenco completo delle opzioni di dcdiag, utilizzare l'opzione ?:

    dcdiag /?

    Il registro del servizio directory, disponibile nel Visualizzatore eventi in Registri applicazioni, segnala gli errori di replica che si verificano dopo che è stato stabilito un collegamento di replica.

La replica tra siti è lenta.

  • Causa: il tempo necessario per replicare dati di directory tra controller di dominio è denominato latenza di replica. La latenza di replica può variare notevolmente a seconda del numero di controller di dominio, del numero di siti, della larghezza di banda disponibile tra i siti, della frequenza di replica e altro ancora.

  • Soluzione:

    • il monitoraggio regolare della replica consente di determinare la normale latenza di replica sulla rete. Con queste informazioni, è possibile determinare più facilmente se si è verificato un problema.

    • Esaminare il registro del servizio directory per individuare eventuali errori di replica recenti. Eseguire inoltre il comando repadmin /showrepl ed esaminare gli eventuali errori risultanti.

    • Ai fini dell'efficienza della replica è importante una corretta progettazione della topologia dei siti. Per le linee guida sulla progettazione della topologia dei siti, vedere la pagina relativa alla progettazione della topologia dei siti per Servizi di dominio Active Directory in Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93576).


Risorse per Siti e servizi di Active Directory

Per ulteriori informazioni su Siti e servizi di Active Directory, vedere le risorse seguenti sul sito Web Microsoft:

  • Per informazioni sulla gestione della replica di Servizi di dominio Active Directory, vedere la pagina relativa all'amministrazione della replica tra siti all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93527.

  • Per informazioni sulla gestione della replica in presenza di firewall, vedere la pagina relativa all'utilizzo di Active Directory in reti segmentate tramite firewall all'indirizzo http://go.microsoft.com/fwlink?linkid=45087.

  • Per informazioni generali di carattere tecnico sulla topologia di replica, vedere la documentazione tecnica sulla topologia di replica di Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93578.

  • Per informazioni sulla gestione del catalogo globale, vedere la pagina relativa all'amministrazione del catalogo globale all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93580.

  • Per informazioni generali di carattere tecnico sul catalogo globale, vedere la relativa documentazione tecnica all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93581.

  • Per informazioni sulla risoluzione dei problemi relativi alla replica di Servizi di dominio Active Directory, vedere la pagina relativa alla risoluzione dei problemi di replica di Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=92818.

  • Per informazioni sui criteri query LDAP (Lightweight Directory Access Protocol), vedere l'articolo 315071 della Microsoft Knowledge Base all'indirizzo http://go.microsoft.com/fwlink/?LinkId=65383.


Interfaccia utente: Siti e servizi di Active Directory

  • Finestra delle proprietà di <NomeCollegamentoSito> - Scheda Generale

  • Finestra delle proprietà di <NomeOggettoConnessione> - Scheda Generale

  • Finestra delle proprietà Impostazioni NTDS - Scheda Generale

  • Finestra delle proprietà Impostazioni sito NTDS - Scheda Impostazioni sito

  • Finestra delle proprietà di <NomeServer> - Scheda Generale

  • Proprietà IP o SMTP - Scheda Generale

  • Finestra di dialogo Nuovo oggetto - Subnet

  • Finestra di dialogo Nuovo oggetto - Bridge di collegamenti di sito

  • Immettere prefissi di indirizzo


Finestra delle proprietà di <NomeCollegamentoSito> - Scheda Generale

Elemento Dettagli

Costo

Specifica un valore di costo per impostare la preferenza in modo da utilizzare questo collegamento di sito anziché un altro collegamento di sito in grado di indirizzare la replica allo stesso sito.

Quando tra due siti sono disponibili più route, la replica tra siti viene eseguita sulla ruote con il costo più basso. Se al momento della creazione della topologia di replica non è disponibile un controller di dominio e la replica attraverso il sito è pertanto impossibile, viene utilizzata la successiva route con il costo più basso. Questo reindirizzamento è automatico in caso di collegamenti di sito con bridge (transitivi), che rappresentano l'impostazione predefinita.

Replica ogni ___ minuti

Specifica la durata, in minuti, tra gli eventi di replica sul collegamento di sito. La replica viene eseguita con questa frequenza nei periodi di tempo in cui è stata pianificata la disponibilità della replica sul collegamento di sito.

L'intervallo di replica minimo è 15 minuti.

Cambia pianificazione o Visualizza pianificazione

Per controllare o modificare la pianificazione del collegamento, fare clic su Cambia pianificazione.

Quando si accede con un account che non dispone di credenziali sufficienti per modificare la pianificazione, l'opzione disponibile è Visualizza pianificazione.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Finestra delle proprietà di <NomeOggettoConnessione> - Scheda Generale

Le modifiche alle proprietà dell'oggetto connessione diverranno effettive solo se apportate dal proprietario dell'oggetto connessione. La proprietà di un oggetto connessione viene stabilita quando si crea manualmente un oggetto connessione oppure si diventa proprietari di un oggetto connessione generato automaticamente. Non è necessario gestire oggetti connessione a meno che non si crei manualmente una topologia di replica.

Elemento Dettagli

Trasporto

Offre l'elenco dei protocolli di rete disponibili che possono essere utilizzati dalla connessione.

Utilizzare IP per la maggior parte degli scenari di replica. Simple Mail Transfer Protocol (SMTP) è disponibile solo per topologie non comuni in cui non è supportata la replica IP.

Cambia pianificazione o Visualizza pianificazione

La pianificazione si applica agli oggetti connessione all'interno di un sito e agli oggetti connessione tra siti creati manualmente.

Per un oggetto connessione tra siti creato manualmente, fare clic per visualizzare o specificare la frequenza con cui viene eseguita la replica sulla connessione. La pianificazione per gli oggetti connessione tra siti generati manualmente è derivata dall'oggetto collegamento di sito.

Per un oggetto connessione all'interno di un sito, la replica viene eseguita in risposta alle modifiche. Gli oggetti connessione all'interno di un sito generati automaticamente, tuttavia, dispongono inoltre di una pianificazione predefinita di 1 ora per garantire l'esecuzione della replica in caso di errore nei meccanismi di notifica. La pianificazione per gli oggetti connessione all'interno di un sito generati automaticamente è derivata dalla pianificazione dell'oggetto Impostazioni sito NTDS.

Cambia

Fare clic per selezionare un controller di dominio alternativo come partner di replica di origine dal quale le informazioni della directory verranno replicate sulla connessione.

Contesti dei nomi replicati

Partizioni di directory in comune tra il controller di dominio e il relativo partner di replica di origine in Server, per le quali il controller di dominio riceve aggiornamenti.

Contesti dei nomi parzialmente replicati

Se il server è un server di catalogo globale, gli aggiornamenti a queste partizioni di directory di sola lettura vengono replicati sulla connessione.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Finestra delle proprietà Impostazioni NTDS - Scheda Generale

Elemento | Dettagli
Criteri query | Specifica i limiti operativi per diverse operazioni LDAP (Lightweight Directory Access Protocol) per garantire il supporto delle garanzie a livello di servizio da parte dei controller di dominio.
Alias DNS | Visualizza il nome del record di risorse alias (CNAME) nel DNS (Domain Name System) che viene utilizzato dai partner di replica per individuare i controller di dominio per la replica. Il record di risorse alias (CNAME) utilizza l'identificatore univoco globale (GUID) dell'oggetto DSA (Directory System Agent).
Casella di controllo Catalogo globale | Quando si seleziona questa casella di controllo, il catalogo globale viene aggiunto al controller di dominio. Quando si deseleziona questa casella di controllo, il catalogo globale viene rimosso dal controller di dominio. Poiché i server di catalogo globale sono necessari per controllare l'appartenenza ai gruppi durante il processo di accesso, l'aggiunta del catalogo globale a un controller di dominio in ogni sito riduce il traffico tra siti causato dagli accessi.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Finestra delle proprietà Impostazioni sito NTDS - Scheda Impostazioni sito

Elemento Dettagli

Cambia pianificazione o Visualizza pianificazione

Pianificazione predefinita per la replica all'interno di un sito. È consigliabile non modificare questa pianificazione. Nonostante la replica all'interno di un sito venga eseguita automaticamente quando si verifica un aggiornamento, i partner di replica vengono inoltre contattati ogni ora per garantire la replica delle modifiche eventualmente non rilevate.

Quando si accede con un account che non dispone di credenziali sufficienti per modificare la pianificazione, l'opzione disponibile è Visualizza pianificazione.

Generatore della topologia tra siti

Nome del singolo controller di dominio del sito responsabile della creazione di connessioni dai controller di dominio di altri siti. La combinazione di tutte le connessioni create dai generatori della topologia tra siti di tutti i siti costituisce la topologia di replica tra siti per la foresta.

Caching appartenenza a gruppo universale

Abilita caching appartenenza a gruppo universale: elimina l'esigenza per un controller di dominio del sito di contattare un server di catalogo globale di un diverso sito per verificare l'appartenenza a gruppi universali durante gli accessi al dominio.

Aggiorna cache da: elenca i siti disponibili nella foresta. Utilizzare questo elenco per specificare un sito per la memorizzazione nella cache dell'appartenenza a gruppi universali. Con <Predefinito> viene utilizzata la route più efficiente verso un sito che dispone di un server di catalogo globale. Se si specifica un sito, verificare che contenga un server di catalogo globale funzionante.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Finestra delle proprietà di <NomeServer> - Scheda Generale

Elemento Dettagli

Tipi di trasporto disponibili per il trasferimento tra siti

Elenca i tipi di trasporto di replica che possono essere utilizzati dal server per la replica.

  • IP: il trasporto IP è il trasporto di replica predefinito per la replica all'interno di un sito e tra siti.

  • SMTP: il trasporto SMTP (Simple Mail Transfer Protocol) utilizza messaggi di posta elettronica per il trasferimento dei dati di replica. Questo tipo di trasporto necessita di configurazione aggiuntiva nelle proprietà di rete e presenta limitazioni significative.

Questo server è un server testa di ponte preferito per i seguenti tipi di trasporto

Contiene i tipi di trasporto aggiunti per designare il server come server testa di ponte preferito. Aggiungendo un tipo di trasporto all'elenco, si designa il server come server testa di ponte preferito per la replica che utilizza tale tipo di trasporto. Rimuovendo un tipo di trasporto, viene ripristinato lo stato del server come server non testa di ponte.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Proprietà IP o SMTP - Scheda Generale

Elemento Dettagli

Ignora pianificazioni

Questa opzione equivale alla costante disponibilità della replica. Se l'opzione Ignora pianificazioni è selezionata, la replica viene eseguita agli intervalli designati ignorando tuttavia i giorni e le ore pianificati. I collegamenti di sito che utilizzano il trasporto SMTP (Simple Mail Transfer Protocol) ignorano sempre le pianificazioni dei collegamenti di sito.

Collega tramite bridge i collegamenti di sito

Specifica se è possibile eseguire la replica in modo transitivo tra siti non connessi direttamente da un collegamento di sito. Per impostazione predefinita, questa opzione è attivata. I controller di dominio di siti diversi possono eseguire la replica in modo transitivo in presenza delle condizioni seguenti:

  • Sono connessi a un sito comune su collegamenti di sito diversi.

  • Le pianificazioni per i due collegamenti di sito si sovrappongono, ovvero la replica è disponibile in periodi di tempo comuni.

  • Nel sito intermedio non è disponibile un controller per il dominio.

Se si disattiva questa opzione, potrebbe essere necessario creare bridge di collegamenti di sito per consentire la comunicazione tra determinati controller di dominio.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Finestra di dialogo Nuovo oggetto - Subnet

Elemento | Dettagli
Prefisso | Indirizzo di rete che identifica l'intervallo di indirizzi IP della subnet.
Nome prefisso in Servizi di dominio Active Directory | Valore utilizzato per il nome dell'oggetto subnet in Servizi di dominio Active Directory.
Selezionare un oggetto sito per il prefisso | Sito associato all'indirizzo di subnet. Quando un server DNS (Domain Name System) riceve una richiesta per un controller di dominio di questo sito, vengono restituiti soltanto i controller di dominio i cui indirizzi IP sono inclusi in questo intervallo di subnet. I controller di dominio vengono così individuati in base al sito.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Finestra di dialogo Nuovo oggetto - Bridge di collegamenti di sito

Per impostazione predefinita, i collegamenti di sito sono collegati tramite bridge e la replica pertanto utilizza automaticamente la route con il costo più basso tra i siti. Non è necessario collegare manualmente tramite bridge i collegamenti di sito, a meno che non si desideri garantire che determinate route verso un sito non vengano mai utilizzate.

Elemento | Dettagli
Collegamenti di sito non presenti nel bridge di collegamenti di sito | Questo elenco non contiene originariamente alcun collegamento di sito, poiché per impostazione predefinita tutti i collegamenti di sito sono collegati tramite bridge. Se si disattiva il bridging del collegamento di sito, questo elenco non verrà modificato. Quando si crea manualmente il primo bridge di collegamenti di sito, è necessario rimuovere i siti dell'elenco dei collegamenti di sito con bridge che non si desidera includere nel bridge di collegamenti di sito.
Collegamenti di sito presenti nel bridge di collegamenti di sito | Questo elenco contiene originariamente tutti i collegamenti di sito, poiché per impostazione predefinita tutti i collegamenti di sito sono collegati tramite bridge. Se si disattiva il bridging del collegamento di sito, questo elenco non verrà modificato. Per selezionare i collegamenti di sito da includere nel bridge di collegamenti di sito, rimuovere i collegamenti di sito che non si desidera includere nel bridge di collegamenti di sito. Se è già stato implementato un bridge di collegamenti di sito, potrebbe essere necessario aggiungere uno o più collegamenti di sito al bridge.

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory


Immettere prefissi di indirizzo

La suddivisione tra subnet include un insieme di tecniche che possono essere utilizzate per allocare in modo efficiente lo spazio di indirizzi di uno o più prefissi di indirizzo unicast tra le subnet della rete di un'organizzazione.

Per determinare il prefisso di subnet di una configurazione di indirizzi IP versione 4 (IPv4) nella notazione della lunghezza del prefisso (w.x.y.z/n), mantenere gli n bit di ordine superiore, impostare tutti i restanti bit su 0 e quindi convertire il risultato nella notazione decimale puntata. Per determinare il prefisso di subnet di una configurazione di indirizzi IPv4 nella notazione per le subnet mask, eseguire un'operazione AND logica bit per bit tra l'indirizzo IPv4 e la relativa subnet mask.

Oltre agli indirizzi IPv4, Windows Server 2008 R2 supporta prefissi di subnet IP versione 6 (IPv6). Per creare una subnet nello spazio degli indirizzi IPv6, utilizzare metodi esadecimali o decimali per enumerare i prefissi di indirizzo della subnet.

Per ulteriori informazioni, vedere la pagina contenente le nozioni fondamentali su TCP/IP per Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=83553).

Ulteriori riferimenti

  • Interfaccia utente: Siti e servizi di Active Directory