Visualizzatore eventi

Il Visualizzatore eventi è uno snap-in di MMC (Microsoft Management Console) che consente all'utente di esplorare e gestire i registri eventi. È uno strumento indispensabile per il monitoraggio dell'integrità dei sistemi e la risoluzione dei problemi al loro sorgere. Per le informazioni più recenti sul Visualizzatore eventi, vedere l'argomento online relativo al Visualizzatore eventi.

Il Visualizzatore eventi consente all'utente di eseguire le attività seguenti:

  • Visualizzare eventi da più registri eventi

  • Salvare utili filtri di eventi come visualizzazioni personalizzate che possono essere riutilizzate

  • Pianificare un'attività da eseguire in risposta a un evento

  • Creare e gestire sottoscrizioni di eventi

Visualizzare eventi da più registri

Quando si utilizza il Visualizzatore eventi per la risoluzione di un problema, è necessario individuare gli eventi correlati al problema, indipendentemente dal registro eventi in cui si trovano. Il Visualizzatore eventi consente all'utente di filtrare eventi specifici su più registri. Questo semplifica la visualizzazione di tutti gli eventi potenzialmente correlati al problema analizzato. Per specificare un filtro che si estende su più registri, è necessario creare una visualizzazione personalizzata.

Per informazioni dettagliate sulla creazione di visualizzazioni personalizzate, vedere l'argomento seguente:

  • Creare una visualizzazione personalizzata

Visualizzazioni personalizzate riutilizzabili

Quando si utilizzano i registri eventi, la maggiore difficoltà è rappresentata dalla necessità di ridurre il gruppo di eventi, limitandosi a quelli desiderati. Talvolta questo è semplice. In altri casi, implica un grande sforzo, che rischia di essere vanificato se non si trova il modo di salvare la visualizzazione dei registri ottenuta con tanta fatica. Il Visualizzatore eventi supporta il concetto di visualizzazioni personalizzate. Dopo aver eseguito interrogazioni e ordinamenti per poter analizzare solo gli eventi desiderati, è possibile salvare questo lavoro come visualizzazione denominata, che potrà essere riutilizzata in futuro. È persino possibile esportare la visualizzazione e utilizzarla in altri computer o condividerla con altre persone.

Per informazioni dettagliate sulle attività correlate alle visualizzazioni, vedere gli argomenti seguenti:

  • Visualizzazioni personalizzate

  • Creare una visualizzazione personalizzata

  • Esportare una visualizzazione personalizzata

  • Importare una visualizzazione personalizzata

Integrazione con l'Utilità di pianificazione

Utilizzando il Visualizzatore eventi, è possibile automatizzare facilmente le risposte agli eventi. Il Visualizzatore eventi è integrato nell'Utilità di pianificazione, consentendo all'utente di fare clic col pulsante destro del mouse sulla maggior parte degli eventi per avviare la pianificazione di un'attività da eseguire quando tale evento verrà registrato in futuro.

Per informazioni dettagliate sulle attività associate agli eventi, vedere:

  • Eseguire un'attività in risposta a un evento specifico

Sottoscrizioni di eventi

È possibile raccogliere eventi da computer remoti e archiviarli localmente specificando le sottoscrizioni di eventi.

Per informazioni dettagliate sulle sottoscrizioni di eventi, vedere l'argomento seguente:

  • Sottoscrizioni di eventi

Risorse aggiuntive

  • Registri eventi

  • Proprietà evento

  • Informazioni sugli eventi online

  • Procedure relative al Visualizzatore eventi

  • Risolvere i problemi relativi al Visualizzatore eventi


Registri eventi

In Windows Vista sono presenti due categorie di registri eventi: I registri di Windows e i registri applicazioni e servizi. È possibile utilizzare il Visualizzatore eventi o lo strumento da riga di comando wevtutil per gestire i registri eventi in un computer remoto. Quando si utilizza wevtutil per gestire i registri eventi, i messaggi ricevuti da wevtutil possono fare riferimento a registri eventi come a canali. Nella maggioranza dei casi, registri eventi e canali sono equivalenti. Per ulteriori informazioni sui registri eventi e sui canali, vedere l'argomento relativo ai registri eventi e ai canali nel Registro eventi di Windows del Software Development Kit (SDK) del Registro eventi di Windows (informazioni in lingua inglese).

Registri di Windows

La categoria dei registri di Windows include i registri disponibili in versioni precedenti di Windows: i registri applicazione, sicurezza e il registro eventi di sistema. Sono inoltre inclusi due nuovi registri, ovvero il registro installazione e il registro ForwardedEvents. I registri di Windows sono progettati per l'archiviazione di eventi da applicazioni legacy ed eventi che si applicano all'intero sistema.

Registro applicazione

Il registro applicazioni contiene gli eventi registrati dalle applicazioni o dai programmi. Ad esempio potrebbe venire registrato un errore file di un programma di database Gli eventi da registrare sono stabiliti dagli sviluppatori del programma.

Registro sicurezza

Il registro sicurezza contiene eventi quali i tentativi di accesso validi e non validi, nonché gli eventi relativi all'utilizzo delle risorse, ad esempio la creazione, l'apertura o l'eliminazione di file o altri oggetti. Gli amministratori possono specificare i tipi di evento che vengono registrati nel registro sicurezza. Vi vengono ad esempio annotati i tentativi di connettersi al sistema quando è attivato il controllo degli accessi.

Registro installazione

Il registro installazione contiene eventi correlati all'installazione delle applicazioni.

Registro eventi di sistema

Il registro eventi di sistema contiene tutti gli eventi registrati dai componenti di sistema di Windows. In questo registro viene ad esempio annotato il mancato caricamento di un driver o di un altro componente di sistema all'avvio del computer. I tipi di evento registrati dai componenti di sistema sono predeterminati da Windows.

Registro ForwardedEvents

Il registro ForwardedEvents viene utilizzato per archiviare eventi raccolti da computer remoti. Per raccogliere eventi di computer remoti, è necessario creare una sottoscrizione di eventi. Per informazioni sulle sottoscrizioni di eventi, vedere Sottoscrizioni di eventi.

Registri applicazioni e servizi

I registri applicazioni e servizi sono una nuova categoria di registri eventi. Questi registri archiviano gli eventi provenienti da una singola applicazione o da un singolo componente, piuttosto che eventi che potrebbero avere un impatto su tutto il sistema.

Questa categoria di registri include quattro sottotipi: amministrativo, operativo, analitico e di debug. Gli eventi contenuti nei registri amministrativi sono particolarmente interessanti per i responsabili IT che utilizzano il Visualizzatore eventi per la risoluzione dei problemi. Gli eventi presenti in questo tipo di registro forniscono indicazioni su come reagire a tali problemi. Gli eventi del registro operativo sono a loro volta utili per i responsabili IT ma richiedono una maggiore interpretazione.

I registri amministrativi e di debug non sono di facile utilizzo. I registri analitici archiviano gli eventi che tracciano un problema e spesso viene registrato un elevato volume di eventi. I log di debug vengono utilizzati dagli sviluppatori durante il debug delle applicazioni. Per impostazione predefinita, i registri analitici e di debug sono nascosti e disabilitati. Per renderli visibili, eseguire la procedura in Visualizzare o nascondere registri analitici e di debug. Per abilitare questi registri, eseguire la procedura in Attivare i registri analitici e di debug.

Amministrativi

Questi eventi sono principalmente mirati agli utenti finali, agli amministratori e al personale di supporto. Gli eventi che vengono trovati nei canali Admin indicano un problema e una soluzione ben definita che può essere adottata da un amministratore. Un esempio di evento amministrativo è un evento che si verifica quando un'applicazione non riesce a connettersi a una stampante. Questi eventi sono ben documentati o presentano un messaggio associato che fornisce al lettore istruzioni dirette su cosa fare per risolvere il problema.

Operativi

Gli eventi operativi vengono utilizzati per l'analisi e la diagnosi di un problema o di ricorrenze. Possono essere utilizzati per avviare strumenti o attività basati su problemi o ricorrenze. Un esempio di evento operativo è un evento che si verifica quando una stampante viene aggiunta o rimossa da un sistema.

Analitici

Gli eventi analitici vengono pubblicati in grandi quantità. Questi eventi descrivono il funzionamento dei programmi e indicano problemi che non possono essere gestiti dall'intervento dell'utente.

Debug

Gli eventi di debug vengono utilizzati dagli sviluppatori per la risoluzione di problemi dei programmi.

Infrastruttura basata su XML

L'infrastruttura alla base della registrazione di eventi è stata completamente rinnovata in Windows Vista. Le informazioni relative ai singoli eventi sono conformi a uno schema XML ed è possibile accedere all'XML che rappresenta un evento specifico. È inoltre possibile creare query basate su XML rispetto ai registri eventi. Non è necessario che l'utente conosca il linguaggio XML per utilizzare le nuove funzioni disponibili. Il Visualizzatore eventi consente all'utente di accedere la funzionalità in un formato grafico di facile utilizzo.

Risorse aggiuntive

  • Visualizzare una visualizzazione personalizzata in formato XML

  • Attivare i registri analitici e di debug

  • Visualizzare o nascondere registri analitici e di debug


Proprietà evento

Nella tabella seguente sono elencante le proprietà evento più comuni. Per ulteriori informazioni sulle proprietà evento e sullo schema XML sottostante, vedere l'argomento onlinerelativo alla rappresentazione per il consumo di eventi del Software Development Kit (SDK) del Registro eventi di Windows.

Nome proprietà Descrizione

Origine

Il software che ha registrato l'evento. Può essere un nome di programma, ad esempio SQL Server, oppure un componente del sistema o di un programma di grandi dimensioni, ad esempio un nome di driver. "Elnkii" indica ad esempio un driver EtherLink II.

Event ID

Un numero che identifica il particolare tipo di evento. La prima riga della descrizione in genere include il nome del tipo di evento. Ad esempio, 6005 è l'ID dell'evento che si verifica quando viene avviato il servizio Registro eventi. La prima riga della descrizione di un evento di questo tipo è "Il servizio Registro eventi è stato avviato". L'ID evento e l'origine possono essere utilizzati dai rappresentanti del supporto tecnico per risolvere problemi relativi al sistema.

Livello

Una classificazione della gravità dell'evento. Nel sistema e nei registri applicazioni possono verificarsi i seguenti livelli di gravità degli eventi:

  • Informazioni Indica una modifica in un'applicazione o in un componente, ad esempio il corretto completamento di un'operazione, la creazione di una risorsa o l'avvio di un servizio.

  • Avviso Indica un problema che può influire sul servizio o causare un problema più grave se non si intraprende alcuna azione.

  • Errore Indica un problema che potrebbe influire sulle funzionalità esterne all'applicazione o al componente che ha attivato l'evento.

  • Critico Indica un errore che non consente il ripristino automatico dell'applicazione o del componente che ha attivato l'evento.

Nel registro sicurezza possono verificarsi i seguenti livelli di gravità degli eventi:

  • Operazioni riuscite. Indica che l'esercizio di un diritto utente è riuscito.

  • Controllo operazioni non riuscite. Indica che l'esercizio di un diritto utente non è riuscito.

Nella normale visualizzazione elenco del Visualizzatore eventi queste classificazioni sono rappresentate da un simbolo.

Utente

Il nome dell'utente per conto del quale si è verificato l'evento. Questo nome corrisponde all'ID client se l'evento è stato effettivamente causato da un processo server o all'ID primario se non c'è rappresentazione. Dove possibile, una voce del registro sicurezza include sia gli ID primari, sia gli ID di rappresentazione. La rappresentazione ha luogo quando il server consente a un processo di assumere gli attributi di sicurezza di un altro processo.

Codice operativo

Contiene un valore numerico che identifica l'attività o il punto all'interno di un'attività eseguito dall'applicazione al momento dell'evento. Ad esempio, l'inizializzazione o la chiusura.

Registro

Il nome del file di registro dove l'evento è stato registrato.

Categoria attività

Utilizzato per rappresentare un sottocomponente o un'attività dell'autore di eventi.

Parole chiave

Un gruppo di categorie o tag che possono essere utilizzati per filtrare o eseguire una ricerca sugli eventi. Ad esempio "Rete", "Sicurezza" o "Impossibile trovare la risorsa".

Computer

Il nome del computer in cui si è verificato l'evento. Il nome del computer è in genere il nome del computer locale, ma può essere il nome di un computer che ha inoltrato l'evento o anche il nome del computer locale prima che il suo nome sia stato modificato.

Data e ora

La data e l'ora in cui l'evento è stato registrato.

La tabella seguente mostra le proprietà che possono essere visualizzate aggiungendo colonne alla visualizzazione del Visualizzatore eventi. Per ulteriori informazioni sull'aggiunta di colonne alla visualizzazione, vedere Visualizzare o nascondere le proprietà evento.

Nome proprietà | Descrizione
ID processo | Il numero di identificazione per il processo che ha generato l'evento.
ID thread | Il numero di identificazione per il thread che ha generato l'evento.
ID processore | Il numero di identificazione per il processore che ha elaborato l'evento.
ID sessione | Il numero di identificazione per la sessione di terminal server nella quale si è verificato l'evento.
Tempo kernel | Tempo di esecuzione trascorso per le istruzioni in modalità kernel, in unità di tempo CPU.
Tempo utente | Il tempo di esecuzione trascorso per le istruzioni in modalità utente, in unità di tempo CPU.
Tempo processore | Il tempo di esecuzione trascorso per le istruzioni in modalità utente, in tick CPU.
ID di correlazione | Identifica l'attività in corso nella quale l'evento è coinvolto. Questo identificato è utilizzato per specificare relazioni semplici tra eventi.
ID di correlazione relativo | Identifica un'attività correlata in un processo nel quale l'evento è coinvolto.


Visualizzazioni personalizzate

Nelle versioni precedenti del Visualizzatore eventi è possibile filtrare gli eventi in un registro eventi. Per creare un filtro, si specifica un gruppo di regole che vengono utilizzate per determinare quali eventi del registro sono visibili e quali sono nascosti. È ad esempio possibile specificare la visualizzazione solo per gli eventi con livello di errore o di avviso.

La possibilità di filtrare gli eventi è cruciale. È necessario concentrare l'attenzione solo sugli eventi che sono applicabili al problema analizzato. La versione più recente del Visualizzatore eventi estende il concetto di filtro oltre il singolo registro eventi. Questa versione consente la creazione di un gruppo di regole che selezionano gli eventi dalle origini specificate dall'utente e mostrano solo gli eventi di queste origini i cui valori di proprietà rispondono alle regole.

La creazione di un filtro che consente di visualizzare solo gli eventi desiderati per un particolare problema può richiedere molto tempo. Le visualizzazioni personalizzate rappresentano un modo per salvare questo lavoro. Dopo aver creato un filtro che consente di visualizzare solo i record desiderati, è possibile denominare questo filtro e salvarlo per un utilizzo successivo. Questo filtro salvato è una visualizzazione personalizzata.

Risorse aggiuntive

  • Creare e gestire visualizzazioni personalizzate


Sottoscrizioni di eventi

Il Visualizzatore eventi consente all'utente di visualizzare eventi in un singolo computer remoto. La risoluzione di un problema potrebbe tuttavia richiedere l'esame di una serie di eventi archiviati in più registri in diversi computer.

In Windows Vista è possibile raccogliere copie di eventi da più computer remoti e archiviarle localmente. Per specificare gli eventi da raccogliere creare una sottoscrizione di eventi. Tra gli altri dettagli, la sottoscrizione specifica con precisione quali eventi verranno raccolti e in quale registro verranno archiviati a livello locale. Dopo aver attivato la sottoscrizione e la raccolta di eventi, è possibile visualizzare e modificare gli eventi inoltrati come per qualsiasi altro evento archiviato localmente.

L'utilizzo della funzione di raccolta degli eventi richiede la configurazione di entrambi i computer, quello per l'inoltro e quello per la raccolta. Questa funzionalità dipende dai servizi Gestione remota Windows e Raccolta eventi Windows. Entrambi questi servizi devono essere in esecuzione sui computer che prendono parte al processo di inoltro e raccolta. Per ulteriori informazioni sulla procedura per configurare i computer per la raccolta e l'inoltro degli eventi, vedere Configurare i computer per l'inoltro e la raccolta di eventi.

Ulteriori considerazioni

  • È possibile sottoscrivere la ricezione di eventi da una sottoscrizione esistente in un computer remoto.

Risorse aggiuntive

  • Configurare i computer per l'inoltro e la raccolta di eventi

  • Creare una nuova sottoscrizione


Informazioni sugli eventi online

Gli eventi registrati includono un collegamento URL (Uniform Resource Locator) a un sito Web Microsoft o a un sito Web definito dall'utente. Quando si visualizza un evento, è possibile fare clic su Guida registro eventi per inviare una richiesta, sotto forma di query, per ottenere informazioni aggiuntive sull'evento. I dati inviati si limitano alle informazioni strettamente necessarie per recuperare maggiori informazioni sull'evento. Per ulteriori informazioni, leggere l'informativa sulla privacy online.

Se si desidera definire l'URL associato al collegamento Guida registro eventi per fare riferimento a un sito Web diverso dal sito Web Microsoft, è possibile definire l'URL nel Registro di sistema oppure definire l'URL in un manifesto di strumentazione per un autore. Se si definisce l'URL nel Registro di sistema, il collegamento utilizzato sarà lo stesso per tutti gli eventi che sono pubblicati sul computer in cui si trova il Registro di sistema. Un URL definito nel Registro di sistema avrà la priorità su tutti gli URL definiti in manifesti di strumentazione per autori.

Quando si fa clic su Guida registro eventi, i parametri seguenti sono inclusi nell'URL e vengono passati al sito Web:

Parametro | Descrizione
Product Name | Il nome del prodotto associato all'autore dell'evento.
Product Version | La versione del prodotto definito nel parametro Product Name.
Event ID | Il numero di identificazione assegnato all'evento.
Event Source | Il nome del file di registro dove l'evento è stato pubblicato.
Locale ID | Il numero di identificazione per le impostazioni locali del computer in cui l'evento ha avuto origine.

Definire l'URL nel Registro di sistema

È possibile modificare sia l'indirizzo URL associato al collegamento Guida registro eventi, sia il programma utilizzato per visualizzare i risultati restituiti dal sito Web definito nell'URL. Le impostazioni di configurazione sono archiviate nel Registro di sistema nella chiave HKLM\Software\Microsoft\Windows NT\CurrentVersion\EventViewer\.

L'elenco seguente descrive le voci del Registro di sistema visualizzate in quella chiave e il modo in cui consentono di configurare il comportamento della Guida registro eventi.

Voce del Registro di sistema | Descrizione
MicrosoftRedirectionProgram | Specifica il programma utilizzato per visualizzare le informazioni restituite dal sito Web associato con il collegamento Guida registro eventi.
MicrosoftRedirectionProgramCommandLineParameters | Specifica i parametri passati al programma specificato nella voce MicrosoftRedirectionProgram.
MicrosoftRedirectionURL | Specifica l'URL associato al collegamento Guida registro eventi. Il valore predefinito di questa voce è: http://go.microsoft.com/fwlink/events.asp.

Definire l'URL in un manifesto di strumentazione

È possibile definire l'URL per il collegamento Guida registro eventi in un manifesto di strumentazione. Per definire un URL in un manifesto di strumentazione è necessario aggiungere l'attributo helpLink all'elemento provider. Nell'esempio viene visualizzato un attributo helpLink definito per un provider.

<provider name="Microsoft-Windows-EventLogSamplePublisher"
guid="{1db28f2e-8f80-4027-8c5a-a11f7f10f62d}"
symbol="MICROSOFT_SAMPLE_PUBLISHER"
resourceFileName="C:\temp\Publisher.exe"
messageFileName="C:\temp\Publisher.exe"
helpLink="http://www.contoso.com">

Per ulteriori informazioni sui manifesti di strumentazione, vedere la pagina relativa ai Manifesti di strumentazione per gli autori di eventi.


Procedure relative al Visualizzatore eventi

Gli argomenti dell'elenco seguente includono informazioni e procedure passo passo per spiegare come utilizzare l'interfaccia utente del Visualizzatore eventi e lo strumento da riga di comando wevtutil per la gestione di eventi e di registri eventi.

  • Avviare il Visualizzatore eventi

  • Creare e gestire visualizzazioni personalizzate

  • Organizzare una presentazione di eventi

  • Gestire i registri eventi

  • Gestire sottoscrizioni

  • Utilizzare i registri eventi in un computer remoto

  • Eseguire un'attività in risposta a un evento specifico


Avviare il Visualizzatore eventi

Il Visualizzatore eventi è uno snap-in di MMC (Microsoft Management Console). È possibile avviare il Visualizzatore eventi aggiungendo lo snap-in a MMC o facendo doppio clic sul file dello snap-in, Eventvwr.msc, che si trova nella cartella %SYSTEMROOT%\system32. Inoltre è possibile avviare il Visualizzatore eventi dall'interfaccia di Windows o dalla riga di comando utilizzando le procedure seguenti.

Per avviare il Visualizzatore eventi con l'interfaccia di Windows

  1. Fare clic sul pulsante Start.

  2. Scegliere Pannello di controllo.

  3. Fare clic su Sistema e manutenzione.

  4. Scegliere Strumenti di amministrazione.

  5. Fare doppio clic su Visualizzatore eventi.
Per avviare il Visualizzatore eventi con una riga di comando

  1. Aprire un prompt dei comandi. Per aprire un prompt dei comandi, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Prompt dei comandi.

  2. Digitare eventvwr.

Lo strumento da riga di comando eventvwr.exe supporta le opzioni che determinano il computer al quale si connetterà lo snap-in e i registri evento che verranno visualizzati. Quando ci si connette a un computer che esegue una versione precedente di Windows, lo strumento potrebbe essere utilizzato per avviare lo snap-in e connettersi al computer remoto ma le opzioni della riga di comando aggiuntive vengono ignorate.

Per visualizzare informazioni aggiuntive sullo strumento da riga di comando eventvwr, al prompt dei comandi digitare il comando seguente: eventvwr /?

Risorse aggiuntive

  • Utilizzare i registri eventi in un computer remoto


Creare e gestire visualizzazioni personalizzate

Le visualizzazioni personalizzate sono come filtri che sono stati denominati e salvati. Dopo aver creato e salvato una visualizzazione personalizzata, l'utente potrà riutilizzarla senza la necessità di creare il filtro sottostante. Per riutilizzare una visualizzazione personalizzata, passare alla categoria Visualizzazioni personalizzate nell'albero della console e selezionare il nome della visualizzazione personalizzata. Selezionando la visualizzazione personalizzata, è possibile applicare il filtro sottostante e visualizzare i risultati. È possibile importare ed esportare visualizzazioni personalizzate che consentono all'utente la loro condivisione tra utenti e computer.

Negli argomenti seguenti viene descritta la procedura per la creazione e la gestione delle visualizzazioni personalizzate:

  • Creare una visualizzazione personalizzata

  • Esportare una visualizzazione personalizzata

  • Importare una visualizzazione personalizzata

  • Visualizzare una visualizzazione personalizzata in formato XML

  • Salvare il filtro come visualizzazione personalizzata


Creare una visualizzazione personalizzata

È possibile creare un filtro che include eventi provenienti da più registri eventi che soddisfano i criteri specificati. È quindi possibile denominare e salvare questo filtro come visualizzazione personalizzata. Per applicare il filtro associato a una visualizzazione personalizzata salvata, passare alla visualizzazione personalizzata nell'albero della console e fare clic sul suo nome.

Per creare una visualizzazione personalizzata

  1. Avviare il Visualizzatore eventi.

  2. Scegliere Crea visualizzazione personalizzata dal menu Azione.

  3. Per filtrare gli eventi sulla base del momento in cui sono verificati, selezionare il periodo di tempo corrispondente dall'elenco a discesa Accesso.

    Nota

    Se nessuna delle opzioni è accettabile, selezionare Intervallo personalizzato. Nella finestra di dialogo Intervallo personalizzato specificare la data e l'ora di inizio e di fine degli eventi. Fare clic su OK.

  4. In Livello evento selezionare le caselle di controllo vicine ai livelli degli eventi che si desidera includere nella visualizzazione personalizzata.

  5. È possibile specificare i registri eventi o le origini degli eventi visualizzati nella visualizzazione personalizzata.

    • Per specificare i registri eventi: Selezionare l'opzione Registro eventi e nell'elenco a discesa Registro eventi selezionare le caselle di controllo vicine ai registri eventi di cui si desidera includere gli eventi.

    • Per specificare le origini degli eventi: Selezionare l'opzione Origine evento e nell'elenco a discesa Origine evento selezionare le caselle di controllo vicine alle origini degli eventi che si desidera includere nella visualizzazione personalizzata.

  6. In ID evento, digitare l'ID dell'evento che si desidera visualizzare nella visualizzazione personalizzata. I diversi ID degli eventi vanno separati da virgole. Se si desidera includere un intervallo di ID, ad esempio da 4624 a 4634 incluso, digitare 4624-4634. Se si desidera che il filtro visualizzi gli eventi con tutti gli ID ad eccezione di alcuni, digitare gli ID delle eccezioni, preceduti dal segno meno. Ad esempio, per includere tutti gli ID tra 4624 e 4634 ad eccezione di 4630, digitare 4624-4634,-4630.

  7. In Categoria attività selezionare le caselle di controllo vicine alle categorie di attività dell'elenco a discesa che si desidera includere nella visualizzazione personalizzata.

  8. In Parole chiave selezionare le caselle di controllo vicine alle parole chiave nell'elenco a discesa che si desidera includere nella visualizzazione personalizzata.

  9. In Utente immettere il nome degli account utente che si desidera visualizzare. È possibile immettere più utenti separati da una virgola (,).

  10. In Computer(s) immettere il nome dei computer che si desidera visualizzare nella visualizzazione personalizzata. È possibile immettere più computer separati da una virgola (,).

  11. Fare clic su OK.

  12. In Nome nella finestra di dialogo Salva filtro in una visualizzazione personalizzata digitare un nome per la visualizzazione personalizzata.

  13. In Descrizione digitare una descrizione facoltativa della visualizzazione personalizzata.

  14. Selezionare la cartella in cui si desidera archiviare la visualizzazione personalizzata.

    Nota

    È possibile archiviare le visualizzazioni personalizzate nella cartella Visualizzazioni personalizzate o in una sua sottocartella. Per creare nuove sottocartelle, selezionare la cartella Visualizzazioni personalizzate e fare clic su Nuova cartella.

  15. È possibile rendere la visualizzazione personalizzata accessibile a tutti gli utenti del computer o solo agli utenti connessi all'account corrente.

    • Per salvare la visualizzazione personalizzata e renderla accessibile a tutti gli utenti del computer: Verificare che la casella di controllo Tutti gli utenti sia selezionata e fare clic su OK.

    • Per salvare la visualizzazione personalizzata e renderla accessibile solo agli utenti connessi con l'account corrente: Verificare che la casella di controllo Tutti gli utenti non sia selezionata e fare clic su OK.

Ulteriori considerazioni

  • Se si lascia vuoto un campo della finestra di dialogo Crea visualizzazione personalizzata, questo significa che si desidera che il filtro visualizzi le voci indipendentemente dal valore della proprietà corrispondente.

Risorse aggiuntive

Visualizzazioni personalizzate


Esportare una visualizzazione personalizzata

È possibile esportare le visualizzazioni personalizzate come file XML con un'estensione xml. È possibile importare i file XML risultanti con il Visualizzatore eventi. Questo consente la condivisione delle visualizzazioni personalizzate tra utenti e computer.

Per esportare la visualizzazione personalizzata

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console selezionare la visualizzazione personalizzata che si desidera esportare.

  3. Fare clic su Esporta visualizzazione personalizzare nel riquadro Azioni.

  4. Nella finestra di dialogo Salva con nome selezionare una cartella, immettere un Nome file per il file esportato e quindi fare clic su Salva.

Ulteriori riferimenti

Creare e gestire visualizzazioni personalizzate


Importare una visualizzazione personalizzata

È possibile esportare le visualizzazioni personalizzate come file XML con un'estensione xml. È possibile importare i file XML risultanti con il Visualizzatore eventi. Questo consente la condivisione delle visualizzazioni personalizzate tra utenti e computer.

Per importare una visualizzazione personalizzata

  1. Avviare il Visualizzatore eventi.

  2. Scegliere Importa visualizzazione personalizzata dal menu Azione.

  3. Passare alla posizione della visualizzazione esportata, selezionare il file con estensione xml corrispondente e fare clic su Apri.

  4. In Nome nella finestra di dialogo Importa file di visualizzazione personalizzata immettere un nome per la visualizzazione personalizzata importata.

  5. Nella casella di testo Descrizione immettere una descrizione della visualizzazione personalizzata.

  6. Selezionare la cartella in cui si desidera archiviare la visualizzazione personalizzata.

    Nota

    È possibile archiviare le visualizzazioni personalizzate nella cartella Visualizzazioni personalizzate o in una sua sottocartella. Per creare nuove sottocartelle, selezionare la cartella Visualizzazioni personalizzate e fare clic su Nuova cartella.

  7. Se si desidera che la visualizzazione personalizzata sia accessibile a tutti gli utenti del computer, verificare che la casella di controllo Tutti gli utenti sia selezionata e fare clic su OK. Se si desidera che la visualizzazione personalizzata sia accessibile solo agli utenti che hanno accesso con l'account corrente, verificare che la casella di controllo Tutti gli utenti sia deselezionata e fare clic su OK.

Ulteriori riferimenti

Creare e gestire visualizzazioni personalizzate


Visualizzare una visualizzazione personalizzata in formato XML

Le visualizzazioni personalizzate sono filtri denominati che possono essere riutilizzati tra una sessione e l'altra del Visualizzatore eventi. Come per altri filtri del registro eventi, una visualizzazione personalizzata presenta una rappresentazione basata su XML. Dopo aver creato una visualizzazione personalizzata utilizzando l'interfaccia utente del Visualizzatore eventi, è possibile visualizzare ed esaminare il file XML che rappresenta la query sottostante. Si tratta di un modo pratico per ottenere informazioni sulla sintassi XML.

Per visualizzare il formato XML sottostante di una visualizzazione personalizzata

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare alla visualizzazione personalizzata e selezionarla.

  3. Scegliere Proprietà dal menu Azione.

  4. Nella finestra di dialogo delle proprietà fare clic su Modifica filtro.

  5. Nella finestra di dialogo Proprietà visualizzazione personalizzata fare clic sulla scheda XML. La query XML per la visualizzazione personalizzata viene visualizzata nella casella di testo.

Risorse aggiuntive

Visualizzazioni personalizzate


Salvare il filtro come visualizzazione personalizzata

È possibile salvare un filtro come visualizzazione personalizzata per poterlo utilizzare nuovamente senza la necessità di ricrearlo.

Per salvare un filtro per un utilizzo successivo

  1. Avviare il Visualizzatore eventi.

  2. Eseguire la procedura indicata in Filtrare gli eventi visualizzati.

  3. Scegliere Salva filtro come visualizzazione personalizzata dal menu Azione.

  4. In Nome digitare il nome che si desidera utilizzare per accedere alla visualizzazione personalizzata in futuro.

  5. In Descrizione digitare una descrizione della visualizzazione personalizzata.

  6. Nell'albero della console selezionare il percorso in cui si desidera archiviare il filtro salvato.

  7. Per consentire a tutti gli utenti di accedere alla visualizzazione, verificare che la casella di controllo Tutti gli utenti sia selezionata. Per consentire l'accesso alla visualizzazione solo agli utenti attualmente connessi al computer, verificare che la casella di controllo Tutti gli utenti sia deselezionata.

  8. Fare clic su OK.

Risorse aggiuntive

  • Creare una visualizzazione personalizzata

  • Filtrare gli eventi visualizzati


Organizzare una presentazione di eventi

Dopo aver selezionato il gruppo di eventi desiderato, l'utente può utilizzare il Visualizzatore eventi per personalizzare il modo in cui vengono presentati gli eventi. È possibile ordinare e raggruppare gli eventi e le relative proprietà in diversi modi, come descritto negli argomenti seguenti:

  • Filtrare gli eventi visualizzati

  • Raggruppare gli eventi in base a una proprietà specifica

  • Ordinare gli eventi in base a una proprietà specifica

  • Visualizzare o nascondere le proprietà evento

  • Visualizzare o nascondere registri analitici e di debug

  • Modificare l'ordine delle proprietà evento


Filtrare gli eventi visualizzati

Quando si visualizza un registro eventi, è possibile filtrare gli eventi che vengono visualizzati. Il filtraggio degli eventi è progettato per essere un filtro temporaneo e applicato di facile rimozione. Se tuttavia si crea un filtro utile che si desidera riutilizzare, è possibile salvarlo come visualizzazione personalizzata.

Per filtrare gli eventi visualizzati

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console selezionare il registro eventi che si desidera filtrare.

  3. Scegliere Filtro registro corrente dal menu Azione.

  4. Per filtrare gli eventi sulla base del momento in cui sono verificati, selezionare il periodo di tempo corrispondente dall'elenco a discesa Accesso.

    Nota

    Se nessuna delle opzioni è accettabile, selezionare Intervallo personalizzato. Nella finestra di dialogo Intervallo personalizzato specificare la data e l'ora di inizio e di fine degli eventi. Fare clic su OK.

  5. In Livello evento selezionare le caselle di controllo vicine ai livelli di evento che si desidera filtrare per la visualizzazione.

  6. Nell'elenco a discesa Origine evento selezionare le caselle di controllo vicine alle origini degli eventi che si desidera filtrare per la visualizzazione.

  7. In ID evento digitare l'ID dell'evento che si desidera filtrare per la visualizzazione. I diversi ID degli eventi vanno separati da virgole. Se si desidera includere un intervallo di ID, ad esempio da 4624 a 4634 incluso, digitare 4624-4634. Se si desidera che il filtro visualizzi gli eventi con tutti gli ID ad eccezione di alcuni, digitare gli ID delle eccezioni, preceduti dal segno meno. Ad esempio, per includere tutti gli ID tra 4624 e 4634 ad eccezione di 4630, digitare 4624-4634,-4630.

  8. In Categoria attività selezionare le caselle di controllo vicine alle categorie di attività dell'elenco a discesa che si desidera filtrare per la visualizzazione.

  9. Nell'elenco a discesa Parole chiave selezionare le caselle di controllo vicine alle parole chiave che si desidera filtrare per la visualizzazione.

  10. In Utente immettere il nome degli account utente che si desidera filtrare per la visualizzazione. Per immettere più account utenti, separarli con una virgola (,).

  11. In Computer immettere il nome dei computer che si desidera filtrare per la visualizzazione. Questo campo si riferisce al computer di origine dell'evento. È possibile immettere più computer separati da una virgola (,).

  12. Per applicare il filtro fare clic su OK.

Ulteriori considerazioni

  • Per rimuovere un filtro attualmente applicato, scegliere Cancella filtro dal menu Azione.

  • Se si lascia vuoto un campo della finestra di dialogo Filtro registro corrente, questo significa che si desidera che il filtro visualizzi le voci indipendentemente dal valore della proprietà corrispondente.

  • Non è possibile applicare il filtro a un'origine evento, a una categoria di attività o a una parola chiave che non sia già presente nel registro che si sta filtrando.

  • I filtri si applicano a un singolo registro eventi. Se si desidera applicare il filtro a più registri, è necessario creare una visualizzazione personalizzata.

Risorse aggiuntive

Salvare il filtro come visualizzazione personalizzata


Raggruppare gli eventi in base a una proprietà specifica

È possibile visualizzare in modo pratico tutti gli eventi che condividono lo stesso valore per una proprietà specifica. Ad esempio è possibile visualizzare tutti gli eventi che hanno avuto la stessa origine o tutti gli eventi con livello di avviso.

Gli eventi possono essere ordinati in base alla proprietà, tuttavia i raggruppamenti risultanti potrebbero risultare di grandi dimensioni e difficili da esplorare. Se si rileva questo limite relativo all'ordinamento, è possibile utilizzare in alternativa la funzionalità di raggruppamento del Visualizzatore eventi. Quando si raggruppano gli eventi, nel controllo elenco su ogni gruppo viene visualizzata un'intestazione descrittiva. Anche se tutti i membri di ogni gruppo sono visibili per impostazione predefinita, è possibile comprimere ed espandere ogni singolo gruppo facendo doppio clic sull'intestazione del gruppo corrispondente.

Per raggruppare gli eventi in base a una proprietà specifica

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare a un registro eventi, a una visualizzazione personalizzata o a un registro salvato.

  3. Nell'intestazione dell'elenco eventi fare clic con il pulsante destro del mouse sull'intestazione della colonna che rappresenta la proprietà in base alla quale si desidera effettuare il raggruppamento, quindi scegliere Raggruppa gli eventi in base a questa colonna.

Ulteriori considerazioni

  • Per rimuovere un raggruppamento, fare clic con il pulsante destro del mouse in un punto qualsiasi dell'intestazione di una colonna e scegliere Separa eventi.

  • Il Visualizzatore eventi supporta solo un livello di raggruppamento. Dopo aver raggruppato un gruppo di eventi è tuttavia possibile ordinare i gruppi risultanti in base alla colonna.

  • La funzionalità di raggruppamento funziona indipendentemente dall'origine dei record dell'evento. È possibile raggruppare un gruppo di eventi purché ne sia consentito il caricamento.

Risorse aggiuntive

  • Ordinare gli eventi in base a una proprietà specifica


Ordinare gli eventi in base a una proprietà specifica

È possibile ordinare ogni gruppo di eventi attualmente visualizzato in base a una singola proprietà evento.

Per ordinare gli eventi in base a una proprietà specifica

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console fare clic sul registro eventi, sulla visualizzazione personalizzata o sul registro salvato che si desidera ordinare.

  3. Fare clic sull'intestazione di colonna in base a cui si desidera eseguire l'ordinamento.

Ulteriori considerazioni

  • Per invertire l'ordinamento, fare di nuovo clic sull'intestazione della colonna.

  • Quando si archivia un registro, l'ordinamento non viene salvato.

Risorse aggiuntive

  • Raggruppare gli eventi in base a una proprietà specifica

  • Archiviare un registro eventi


Visualizzare o nascondere le proprietà evento

È possibile personalizzare l'aspetto degli eventi visualizzati dal Visualizzatore eventi selezionando solo le proprietà desiderate.

Per visualizzare o nascondere le proprietà evento

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console, selezionare un registro eventi, una visualizzazione personalizzata o un registro salvato.

  3. Scegliere Aggiungi/Rimuovi colonne dal menu Visualizza.

  4. Nella finestra di dialogo Aggiungi/rimuovi colonne selezionare le proprietà evento da visualizzare nella casella di riepilogo Colonne disponibili e quindi fare clic su Aggiungi. Nella casella di riepilogo Colonne visualizzate selezionare le proprietà evento che si desidera nascondere e quindi fare clic su Rimuovi.

  5. Fare clic su OK.

Ulteriori considerazioni

  • La visibilità delle proprietà viene mantenuta tra una sessione e l'altra.

  • Non è possibile nascondere la proprietà evento Level.

Risorse aggiuntive

  • Proprietà evento

  • Modificare l'ordine delle proprietà evento


Visualizzare o nascondere registri analitici e di debug

I registri analitici e di debug sono disattivati e nascosti per impostazione predefinita. Per utilizzarli, è necessario innanzitutto renderli visibili nell'interfaccia utente.

Per visualizzare o nascondere i registri analitici o di debug

  1. Avviare il Visualizzatore eventi.

  2. Fare clic sul menu Visualizza. Se l'opzione Visualizza registri analitici e di debug è selezionata, questi tipi di registri sono già visibili. Non sono necessarie altre operazioni. Per rendere visibili questi registri, selezionare l'opzione Visualizza registri analitici e di debug. Si noti che alla sinistra dell'opzione del menu deve essere visualizzato un segno di spunta.

Risorse aggiuntive

  • Attivare i registri analitici e di debug

  • Registri eventi


Modificare l'ordine delle proprietà evento

È possibile personalizzare il modo di visualizzazione degli eventi del Visualizzatore eventi configurando l'ordine di visualizzazione delle proprietà nel riquadro dei dettagli.

Per modificare l'ordine delle proprietà evento

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare a un registro eventi, a una visualizzazione personalizzata o a un registro salvato.

  3. Scegliere Aggiungi/Rimuovi colonne dal menu Visualizza.

  4. Nella finestra di dialogo Aggiungi/Rimuovi colonne, in Colonne visualizzate, fare clic sulla proprietà evento che si desidera riordinare.

  5. Per posizionare la proprietà, utilizzare i pulsanti Sposta su e Sposta giù.

  6. Fare clic su OK.

Ulteriori considerazioni

  • Le proprietà nella parte superiore dell'elenco Colonne visualizzate vengono visualizzate nella parte sinistra del riquadro dei dettagli.

  • L'ordine delle proprietà viene mantenuto tra una sessione e l'altra.

Risorse aggiuntive

  • Proprietà evento

  • Visualizzare o nascondere le proprietà evento


Gestire i registri eventi

È possibile utilizzare il Visualizzatore eventi per gestire diversi aspetti del registro eventi. A tale scopo, in genere è possibile: passare al registro eventi da gestire e selezionarlo, fare clic col pulsante destro del mouse e scegliere Proprietà per accedere alla corrispondente finestra di dialogo delle proprietà e quindi aggiornare i valori appropriati.

È possibile eseguire le attività seguenti di gestione dei registri con il Visualizzatore eventi:

  • Cancellare un registro eventi

  • Impostare le dimensioni massime di registro

  • Impostare il criterio di conservazione del registro

  • Attivare i registri analitici e di debug

  • Archiviare un registro eventi

  • Aprire o chiudere un registro salvato

È inoltre possibile utilizzare lo strumento da riga di comando wevtutil.exe per la gestione dei registri eventi. Quando applicabile, gli argomenti precedenti includono informazioni sulla procedura per il completamento dell'attività dalla riga di comando. Per ulteriori informazioni sullo strumento da riga di comando wevtutil.exe, al prompt dei comandi digitare wevtutil /?.


Cancellare un registro eventi

È possibile cancellare gli eventi di un registro eventi utilizzando il Visualizzatore eventi o il comando wevtutil su una riga di comando.

Per cancellare un registro eventi utilizzando il Visualizzatore eventi

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare al registro eventi che si desidera cancellare.

  3. Scegliere Cancella registro dal menu Azione.

  4. È possibile cancellare il registro eventi o salvarne una copia e quindi cancellarlo.

    • Per cancellare il registro eventi senza salvarlo: Fare clic su Cancella.

    • Per cancellare il registro eventi dopo averlo salvato: Fare clic su Salva e cancella, digitare un nome per il file salvato in Nome file nella finestra di dialogo Salva con nome e quindi fare clic su Salva.
Per cancellare un registro eventi con una riga di comando

  1. Per aprire una finestra di prompt dei comandi, fare clic sul pulsante Start, digitare cmd nella casella di testo Inizia ricerca e quindi premere Invio.

  2. Digitare il comando seguente:

    wevtutil cl <LogName> [/bu: <backup_file_name>]

Per ulteriori informazioni sulle opzioni di cancellazione del registro con lo strumento da riga di comando wevtutil, al prompt dei comandi digitare il comando seguente:

wevtutil cl -?

Ulteriori considerazioni

  • Per eseguire questa operazione, è necessario disporre dell'autorizzazione di cancellazione sul registro. Per impostazione predefinita, gli amministratori dispongono dell'autorizzazione per cancellare i registri eventi. Per impostare l'autorizzazione di cancellazione del registro per altri gruppi, al prompt dei comandi digitare il comando seguente:

    wevtutil sl <LogName> /ca:<SecurityDescriptor>
    Il Descrittore di sicurezza per ogni registro è specificato utilizzando la sintassi di Security Descriptor Definition Language (SDDL). Per ulteriori informazioni sulla sintassi SDDL, vedere l'argomento relativo alla sintassi Security Descriptor Definition Language nel sito Web MSDN.

    Per creare una stringa SDDL, si noti che sono presenti tre diritti distinti relativi ai registri eventi: lettura, scrittura e cancellazione Questi diritti corrispondono ai bit seguenti nel campo dei diritti di accesso della stringa ACE:

    • 1= Lettura

    • 2 = Scrittura

    • 4 = Cancellazione

    Per visualizzare la stringa SDLL per un registro, al prompt dei comandi digitare il comando seguente:

    wevtutil gl <LogName>
    Nell'esempio seguente viene illustrato come aggiungere l'autorizzazione di cancellazione al registro applicazione per il gruppo Backup Operators (A;;0x4;;;BO):

    wevtutil sl Application /ca:O:BAG:SYD:(A;;0xf0007;;;SY)(A;;0x7;;;BA)(A;;0x7;;;SO)(A;;0x3;;;IU)(A;;0x3;;;SU)(A;;0x3;;;S-1-5-3)(A;;0x3;;;S-1-5-33)(A;;0x1;;;S-1-5-32-573)(A;;0x4;;;BO)

Ulteriori riferimenti

  • Archiviare un registro eventi

  • Notazione di sintassi della riga di comando


Impostare le dimensioni massime di registro

I registri eventi sono archiviati in file. Questi file presentano una dimensione massima predefinita che può essere modificata. Questa procedura può essere eseguita utilizzando l'interfaccia di Windows o una riga di comando.

Per impostare la dimensione massima di registro con l'interfaccia di Windows

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare al registro eventi che si desidera modificare e selezionarlo.

  3. Scegliere Proprietà dal menu Azione.

  4. In Dimensioni massime registro (KB) utilizzare il controllo della casella di selezione per impostare il valore desiderato e quindi fare clic su OK.
Nota

La dimensione del registro deve essere un multiplo di 64 KB e non può essere inferiore a 1024 KB. Se si digita una dimensione di registro invece di utilizzare il controllo della casella di selezione, il valore verrà arrotondato al multiplo di 64 KB più vicino.
Per impostare le dimensioni massime di registro con una riga di comando

  1. Per aprire un prompt dei comandi, fare clic sul pulsante Start, scegliere Esegui, digitare cmd e fare clic su OK.

  2. Digitare il comando seguente:

    wevtutil sl <LogName> /ms:<MaxSizeInBytes>

Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:

wevtutil sl -?

Ulteriori considerazioni

  • È necessario essere membri del gruppo Administrators per impostare dimensioni massime di registro.

  • Se si impostano dimensioni massime di registro inferiori alle dimensioni attuali del registro, queste dimensioni massime verranno applicate solo dopo la cancellazione del registro.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Impostare il criterio di conservazione del registro

Gli eventi vengono archiviati in un file di registro che può crescere solo fino a raggiungere una dimensione massima configurabile. La destinazione degli eventi in ingresso dopo il raggiungimento delle dimensioni massime del file viene determinata dai criteri di conservazione del registro. I criteri di conservazione del registro sono i seguenti:

Criterio di conservazione | Descrizione
Sovrascrivi eventi se necessario | I nuovi eventi continuano a essere archiviati quando il file di registro è pieno. Ogni evento in ingresso sostituirà l'evento più vecchio nel registro.
Archivia il registro quando è pieno, non sovrascrivere gli eventi | Il registro viene archiviato automaticamente se necessario. Non sovrascrivere gli eventi
Non sovrascrivere eventi (pulizia manuale del registro). | Consente di cancellare il registro manualmente invece di automaticamente.

È possibile impostare i criteri di conservazione del registro mediante l'interfaccia di Windows oppure l'utilità da riga di comando Wevtutil.

Per impostare il criterio di conservazione del registro con l'interfaccia di Windows

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare al registro eventi che si desidera gestire e selezionarlo.

  3. Scegliere Proprietà dal menu Azione.

  4. Nella sezione Abilita registrazione della scheda Generale selezionare l'opzione corrispondente al criterio di conservazione che si desidera impostare.

  5. Fare clic su OK.
Per impostare il criterio di conservazione con una riga di comando

  1. Per aprire un prompt dei comandi, fare clic sul pulsante Start, scegliere Esegui, digitare cmd e fare clic su OK.

  2. Digitare il comando seguente:

    wevtutil sl <LogName> /r:{true | false} /ab:{true | false}

Il parametro 'r' specifica se conservare il registro e il parametro 'ab' se eseguirne automaticamente il backup. Nell'elenco seguente vengono illustrati i valori dei parametri dell'utilità da riga di comando Wevtutil corrispondenti a ognuno dei criteri di conservazione precedentemente descritti.

  • Sovrascrivi eventi se necessario: r = false, ab = false

  • Archivia il registro quando è pieno, non sovrascrivere gli eventi: r = true, ab = true

  • Non sovrascrivere eventi (pulizia manuale del registro): r = true, ab = false

Per visualizzare la sintassi completa di questo comando, digitare il comando seguente:

wevtutil sl -?

Ulteriori considerazioni

  • È necessario essere membro del gruppo di amministratori per poter impostare il criterio di conservazione del registro.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Attivare i registri analitici e di debug

I registri analitici e di debug sono disattivati per impostazione predefinita. Quando sono attivati, possono riempirsi velocemente di un numero di voci elevato. Per questo motivo, è probabile che l'utente desideri attivarli solo per un periodo specifico per raccogliere determinati dati per la risoluzione di problemi e quindi disattivarli di nuovo. È possibile eseguire questa procedura utilizzando l'interfaccia di Windows o una riga di comando.

Per attivare i registri analitici e di debug con l'interfaccia di Windows

  1. Avviare il Visualizzatore eventi.

  2. Verificare che i registri analitici e di debug siano visibili mediante la procedura descritta in Visualizzare o nascondere registri analitici e di debug.

  3. Nell'albero della console passare al registro analitico o di debug che si desidera abilitare e selezionarlo.

  4. Scegliere Proprietà dal menu Azione.

  5. Nella finestra di dialogo delle proprietà selezionare Abilita registrazione e fare clic su OK.
Per attivare i registri analitici e di debug con una riga di comando

  1. Per aprire un prompt dei comandi, fare clic sul pulsante Start, scegliere Esegui, digitare cmd e fare clic su OK.

  2. Digitare il testo seguente:

    wevtutil sl <logname> /e:true

Ulteriori riferimenti

  • Visualizzare o nascondere registri analitici e di debug

  • Notazione di sintassi della riga di comando


Archiviare un registro eventi

È possibile salvare manualmente gli eventi in un registro eventi utilizzando la procedura seguente. Alcuni criteri di conservazione del registro inoltre possono consentire il salvataggio automatico degli eventi. Quando si salvano gli eventi, è possibile includere informazioni di visualizzazione che consentiranno la visualizzazione degli eventi salvati su un altro computer ed è possibile includere informazioni consentiranno la visualizzazione degli eventi salvati in una diversa lingua.

Per esportare e archiviare un registro eventi

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare al registro che si desidera archiviare.

  3. Scegliere Salva eventi con nome dal menu Azione.

  4. In Nome file immettere il nome che si desidera assegnare al file di registro archiviato.

  5. In Salva come selezionare un formato di file e quindi scegliere Salva.

  6. (Facoltativo) Nella finestra di dialogo Informazioni di visualizzazione se le informazioni del Registro eventi non devono essere visualizzate su un altro computer, accettare l'impostazione predefinita Nessuna informazione di visualizzazione.

  7. (Facoltativo) Nella finestra di dialogo Informazioni di visualizzazione se le informazioni del Registro eventi devono essere visualizzate su un altro computer, fare clic su Informazioni di visualizzazione per queste lingue.

  8. (Facoltativo) Se le informazioni del Registro devono essere visualizzate in una diversa lingua, selezionare la casella di controllo Visualizza tutte le lingue disponibili.

  9. (Facoltativo) Selezionare le caselle di controllo relative alle lingue per le quali includere informazioni sulla lingua.

  10. Fare clic su OK.
Per esportare e archiviare un registro eventi con una riga di comando

  1. Per aprire una finestra di prompt dei comandi, fare clic sul pulsante Start, digitare cmd nella casella di testo Inizia ricerca e quindi premere Invio.

  2. Per esportare il registro in un file, digitare il comando seguente:

    wevtutil epl <LogName> <FileName.evtx>

  3. Per archiviare il registro con le informazioni di visualizzazione, digitare il comando seguente:

    wevtutil al <FileName.evtx> [/l:<LocaleString>]

Per visualizzare la sintassi completa del comando wevutil con l'opzione epl, al prompt dei comandi digitare:

wevtutil epl /?

Per visualizzare la sintassi completa del comando wevutil con l'opzione epl, al prompt dei comandi digitare:

wevtutil al /?

Ulteriori considerazioni

  • Se si archivia un registro con estensione evtx, è possibile riaprirlo nel Visualizzatore eventi.

  • L'archiviazione non cancella il contenuto del registro.

  • Quando i registri vengono salvati, l'ordinamento non viene mantenuto.

  • Se si archivia un registro filtrato, verranno salvati solo i record che soddisfano il filtro.

  • Per risolvere i problemi relativi agli eventi registrati su un computer remoto, è necessario esportare e archiviare il registro con le informazioni di visualizzazione. Le informazioni di visualizzazione per gli eventi salvati sono archiviare nella cartella LocaleMetaData ed è consigliabile spostarle insieme alle informazioni del registro quando sono visualizzate su un altro computer.

Risorse aggiuntive

  • Impostare il criterio di conservazione del registro


Aprire o chiudere un registro salvato

È possibile aprire e visualizzare un file di registro archiviato utilizzando Visualizzatore eventi. È possibile aprire più file di log salvati e accedere a essi in qualsiasi momento dall'albero della console. Un file di registro che è stato aperto nel Visualizzatore eventi può essere chiuso senza eliminare le informazioni nel file.

Per aprire un registro eventi salvato

  1. Avviare il Visualizzatore eventi.

  2. Scegliere Apri registro salvato dal menu Azioni.

  3. Nella casella Cerca in selezionare la cartella in cui si trova il file di registro.

  4. Selezionare il file di registro e quindi scegliere Apri.

  5. (Facoltativo) Nella casella Nome immettere un nuovo nome che sarà utilizzato per il file di registro nell'albero della console oppure utilizzare il nome esistente del file di registro.

    Nota

    Se si immette un nome diverso dal nome del file di registro, esso viene utilizzato solo per rappresentare il file di registro nell'albero della console e non modifica il nome del file di registro.

  6. (Facoltativo) Nella casella Descrizione immettere una descrizione del file di registro. La descrizione sarà visualizzata nel riquadro centrale quando si fa clic sulla cartella padre del file di registro nell'albero della console.

  7. (Facoltativo) Fare clic su Nuova cartella, immettere il nome per la cartella in cui si troverà il file di registro aperto e quindi scegliere OK. Se non si seleziona una cartella padre, la nuova cartella sarà contenuta in Saved Logs.

  8. (Facoltativo) Gli amministratori del computer possono fare clic per eliminare il contenuto del punto di controllo Tutti gli utenti se non si desidera che il file di registro aperto sia disponibile agli altri utenti quando il Visualizzatore eventi è avviato. Se non si elimina il contenuto del punto di controllo, il file di registro aperto sarà disponibile a tutti gli utenti, che non potranno rimuoverlo dall'albero della console a meno di non disporre di diritti amministrativi.

  9. Selezionare la posizione in cui si desidera inserire il file di registro nell'albero della console. È necessario posizionare il file di registro nella cartella Saved Logs o in una nuova cartella nella cartella Saved Logs.

  10. Fare clic su OK.

È possibile chiudere un file di registro eliminandolo dall'albero della console.

Importante

In questo modo il file di registro viene eliminato solo dall'albero della console, non dal sistema.

Per rimuovere un file di registro aperto dall'albero della console

  1. Avviare il Visualizzatore eventi se non è già in esecuzione.

  2. Selezionare il file di registro che si desidera rimuovere dall'albero della console.

  3. Scegliere Elimina dal menu Azioni. È inoltre possibile fare clic con il pulsante destro del mouse sul file di registro nell'albero della console e quindi scegliere Elimina oppure fare clic sul file di registro nell'albero della console e premere il tasto Canc.

  4. Fare clic su Sì.

Risorse aggiuntive

Gestire i registri eventi


Gestire sottoscrizioni

È possibile raccogliere eventi da computer remoti e archiviarli in registri in un computer locale. Per creare una sottoscrizione è sufficiente specificare gli eventi da raccogliere. Negli argomenti seguenti viene descritta la procedura per utilizzare sottoscrizioni di eventi.

  • Configurare i computer per l'inoltro e la raccolta di eventi

  • Creare una nuova sottoscrizione

  • Configurare impostazioni di sottoscrizione avanzate


Configurare i computer per l'inoltro e la raccolta di eventi

Per poter creare una sottoscrizione per la raccolta di eventi in un computer, è necessario configurare sia il computer di raccolta sia tutti i computer di origine da cui verranno raccolti tali eventi. Le informazioni aggiornate sulle sottoscrizioni di eventi sono disponibili online alla pagina relativa alle sottoscrizioni di eventi.

Per configurare i computer in un dominio per l'inoltro e la raccolta di eventi

  1. Accedere a tutti i computer di raccolta e di origine. È consigliabile utilizzare un account di dominio con privilegi amministrativi.

  2. In ciascun computer di origine, digitare quanto segue a un prompt dei comandi con privilegi elevati:

    winrm quickconfig
    Nota

    Se si desidera specificare un'ottimizzazione recapito eventi di Riduci larghezza di banda o Riduci latenza, è inoltre necessario eseguire il comando riportato sopra nel computer di raccolta.

  3. Nel computer di raccolta, digitare quanto segue a un prompt dei comandi con privilegi elevati:

    wecutil qc

  4. Aggiungere l'account computer del computer di raccolta al gruppo di amministratori locali in tutti i computer di origine.

    Nota

    Per impostazione predefinita, lo snap-in di MMC Utenti e gruppi locali non consente di aggiungere account computer. Nella finestra di dialogo Seleziona utenti, computer o gruppi fare clic sul pulsante Tipi di oggetto e selezionare la casella di controllo Computer. A questo punto sarà possibile aggiungere gli account computer.

  5. I computer sono ora configurati per l'inoltro e la raccolta di eventi. Seguire i passaggi in Creare una nuova sottoscrizione per specificare gli eventi che si desidera inoltrare al computer di raccolta.

Ulteriori considerazioni

  • In un ambiente di gruppo di lavoro, è possibile seguire la stessa procedura di base descritta sopra per configurare i computer per l'inoltro e la raccolta di eventi. Vi sono tuttavia alcune considerazioni e passaggi aggiuntivi per i gruppi di lavoro:

    • È possibile utilizzare solo le sottoscrizioni Modalità normale (Pull).

    • È necessario aggiungere un'eccezione di Windows Firewall per la Gestione remota registro eventi in ogni computer di origine.

    • È necessario aggiungere un account con privilegi di amministratore al gruppo Lettori registri eventi in ogni computer di origine. È necessario specificare questo account nella finestra di dialogo Configurare impostazioni di sottoscrizione avanzate durante la creazione di una sottoscrizione in un computer di raccolta.

    • Digitare winrm set winrm/config/client @{TrustedHosts="<sources>"} al prompt dei comandi nel computer di raccolta per consentire a tutti i computer di origine di utilizzare l'autenticazione NTLM per comunicare con WinRM nel computer di raccolta. Eseguire questo comando solo una volta. Sostituire <sources> nel comando con un elenco dei nomi di tutti computer di origine appartenenti al gruppo di lavoro. Separare i nomi utilizzando le virgole. In alternativa, è possibile utilizzare i caratteri jolly per eseguire la corrispondenza con i nomi di tutti i computer di origine. Ad esempio, se si desidera configurare un insieme di computer di origine, ciascuno con un nome che inizia con "msft", è possibile digitare questo comando winrm set winrm/config/client @{TrustedHosts="msft*"} nel computer di raccolta. Digitare winrm help config. per ulteriori informazioni su questo comando.

  • Se si seleziona l'opzione HTTPS in Impostazioni di sottoscrizione avanzate per configurare una sottoscrizione per l'utilizzo del protocollo HTTPS, è inoltre necessario impostare le relative eccezioni di Windows Firewall per la porta 443. Per una sottoscrizione che utilizza l'ottimizzazione di recapito Normale (modalità PULL), è necessario impostare l'eccezione solo nei computer di origine. Per una sottoscrizione che utilizza l'ottimizzazione di recapito Riduci larghezza di banda o Riduci latenza (modalità PUSH), è necessario impostare l'eccezione sia nei computer di origine che di raccolta.

  • Se durante la creazione di una sottoscrizione si desidera specificare un account utente selezionando l'opzione Utente specifico in Impostazioni di sottoscrizione avanzate, è necessario verificare al passaggio 4 che l'account appartenga al gruppo di amministratori locali in tutti i computer di origine anziché aggiungere l'account computer del computer di raccolta. In alternativa, è possibile utilizzare l'utilità da riga di comando Registro eventi di Windows per concedere a un account l'accesso ai singoli registri. Per ulteriori informazioni su questa utilità da riga di comando, digitare wevtutil sl -? al prompt dei comandi.


Creare una nuova sottoscrizione

Per ricevere nel computer gli eventi inoltrati è necessario impostare una o più sottoscrizioni di eventi. Prima di impostare una sottoscrizione, è necessario configurare sia il computer di inoltro, sia quello di raccolta degli eventi. Per informazioni sulla procedura di configurazione dei computer, vedere Configurare i computer per l'inoltro e la raccolta di eventi.

Dopo aver configurato i computer, è possibile creare una sottoscrizione per specificare gli eventi da raccogliere.

Per creare una nuova sottoscrizione

  1. Nel computer di raccolta eseguire il Visualizzatore eventi come amministratore.

  2. Nell'albero della console fare clic su Sottoscrizioni.

    Nota

    Se il servizio Raccolta eventi Windows non è stato avviato, verrà richiesta la conferma dell'utente per l'avvio. È necessario avviare questo servizio per la creazione di sottoscrizioni e la raccolta di eventi. Per avviare questo servizio, è necessario essere membri del gruppo Administrators.

  3. Scegliere Crea sottoscrizione dal menu Azioni.

  4. Nella casella Nome sottoscrizione digitare un nome per la sottoscrizione.

  5. Nella casella Descrizione digitare una descrizione facoltativa.

  6. Nella casella Registro di destinazione selezionare il file di registro in cui archiviare gli eventi raccolti. Per impostazione predefinita, gli eventi raccolti vengono archiviati nel registro ForwardedEvents.

  7. Fare clic su Aggiungi e selezionare i computer da cui raccogliere gli eventi.

    Nota

    Dopo aver aggiunto un computer, è possibile testare la connettività e il computer locale selezionando il computer e facendo clic su Test.

  8. Per visualizzare la finestra di dialogo Filtro query fare clic su Seleziona eventi. Utilizzare i controlli della finestra di dialogo Filtro query per specificare i criteri che devono essere rispettati dagli eventi da raccogliere.

  9. Nella finestra di dialogo Proprietà sottoscrizione fare clic su OK. La sottoscrizione verrà aggiunta al riquadro Sottoscrizioni e al completamento dell'operazione lo stato della sottoscrizione sarà attivo.

Gli eventi generati sui computer di inoltro che rispondono ai criteri della sottoscrizione verranno copiati nel registro del computer di raccolta descritto al passaggio 6.

Ulteriori considerazioni

  • Non è possibile utilizzare il Visualizzatore eventi per creare una sottoscrizione durante la connessione a un computer remoto.

  • È possibile utilizzare il filtro di una visualizzazione predefinita precedente selezionando Copia da visualizzazione personalizzata esistente. È inoltre possibile incollare una query XPATH nella casella di testo nella scheda XML della finestra di dialogo Filtro query.

  • Se la nuova sottoscrizione non viene attivata, è possibile aprire la finestra di dialogo Proprietà sottoscrizione e selezionare i singoli computer di origine per visualizzare lo stato di ognuno di essi.

Risorse aggiuntive

  • Configurare i computer per l'inoltro e la raccolta di eventi

  • Configurare impostazioni di sottoscrizione avanzate


Configurare impostazioni di sottoscrizione avanzate

È possibile configurare la modalità di recapito degli eventi raccolti e specificare l'account utilizzato la gestione del processo di raccolta degli eventi. Il Visualizzatore eventi offre tre opzioni per l'ottimizzazione del recapito degli eventi: Normale, Riduci larghezza di banda e Riduci latenza. Nella tabella seguente vengono elencate tutte le opzioni con una descrizione di quando questa scelta è appropriata.

Opzioni di ottimizzazione del recapito degli eventi | Descrizione
Normale | Questa opzione assicura un recapito degli eventi affidabile senza conservare la larghezza di banda. Si tratta della scelta più idonea se non si ha la necessità di avere uno stretto controllo dell'utilizzo della larghezza di banda o quando è necessario recapitare gli eventi inoltrati al più presto. Questa opzione utilizza la modalità di recapito pull, gestisce batch di 5 elementi alla volta e imposta un timeout di batch di 15 minuti.
Riduci larghezza di banda | Questa opzione garantisce un severo controllo dell'utilizzo della larghezza di banda di rete per il recapito degli eventi. Si tratta di una scelta idonea se si desidera limitare la frequenza delle connessioni di rete effettuate per il recapito degli eventi. Utilizza la modalità di recapito push e imposta un timeout di batch di 6 ore. Utilizza inoltre un intervallo di heartbeat di 6 ore.
Riduci latenza | Questa opzione garantisce un recapito degli eventi con ritardi minimi. Si tratta della scelta giusta quando si raccolgono avvisi o eventi critici. Utilizza la modalità di recapito push e imposta un timeout di batch di 30 secondi.

L'opzione di recapito degli eventi Personalizzata non viene mai utilizzata quando si gestiscono sottoscrizioni create utilizzando lo snap-in del Visualizzatore eventi. Il Visualizzatore eventi può creare sottoscrizioni solo con impostazioni di recapito degli eventi corrispondenti alle opzioni Normale, Riduci larghezza di banda o Riduci latenza. È tuttavia possibile utilizzare il Visualizzatore eventi per gestire una sottoscrizione creata o aggiornata utilizzando un metodo diverso, come lo strumento da riga di comando wecutil. In questo caso, l'opzione Personalizzata viene selezionata per indicare che il gruppo di impostazioni di recapito della sottoscrizione non corrisponde a nessuno di quelli supportati dal Visualizzatore eventi.

Per configurare impostazioni di sottoscrizione avanzate

  1. Eseguire i passaggi da 1 a 6 della procedura Creare una nuova sottoscrizione.

  2. Fare clic su Avanzate.

  3. Nella finestra di dialogo Impostazioni di sottoscrizione avanzate è possibile specificare l'opzione di ottimizzazione del recapito degli eventi o specificare l'account utilizzato per gestire il processo di raccolta degli eventi.

    • Per specificare l'ottimizzazione di recapito degli eventi: Selezionare l'opzione Ottimizzazione recapito eventi desiderata e fare clic su OK.

    • Per specificare l'account utilizzato per gestire il processo di raccolta degli eventi, selezionare l'opzione Utente specifico e quindi scegliere Utente e password e immettere il nome utente e la password dell'account e quindi scegliere OK. Nella finestra di dialogo Impostazioni di sottoscrizione avanzate fare clic su OK.

Ulteriori considerazioni

Entrambe le opzioni Riduci larghezza di banda e Riduci latenza gestiscono batch di un numero di elementi predefinito. È possibile determinare il valore di questa impostazione predefinita digitando il comando seguente al prompt dei comandi:

winrm get winrm/config.

È possibile modificare il numero predefinito di elementi in un batch digitando il comando seguente al prompt dei comandi:

winrm set winrm/config @{MaxBatchItems=<NumberOfItems>}

Nell'esempio seguente viene illustrato come modificare il numero predefinito di elementi in batch impostandolo su cinque:

winrm set winrm/config @{MaxBatchItems="5"}

Risorse aggiuntive

  • Sottoscrizioni di eventi

  • Configurare i computer per l'inoltro e la raccolta di eventi

  • Creare una nuova sottoscrizione


Utilizzare i registri eventi in un computer remoto

È possibile utilizzare il Visualizzatore eventi o il comando wevtutil sulla riga di comando per gestire i registri eventi in un computer remoto.

È possibile utilizzare il Visualizzatore eventi per gestire i registri eventi in un computer remoto.

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console fare clic sul nodo radice, per esempio Visualizzatore eventi (locale).

  3. Scegliere Connetti a un altro computer dal menu Azione.

  4. Nella casella Altro computer digitare il nome o l'indirizzo IP del computer remoto.

  5. (Facoltativo) Selezionare Connetti come altro utente, fare clic su Imposta utente, digitare Nome utente e Password e quindi fare clic su OK.

  6. Fare clic su OK.
È possibile utilizzare wevtutil per gestire i registri eventi in un computer remoto.

  1. Per aprire la finestra del prompt dei comandi, fare clic su Start, nella casella Inizia ricerca digitare cmd e quindi premere INVIO.

  2. Nella finestra del prompt dei comandi digitare il comando seguente:

    wevtutil <command> /r:<remote_computer_name>

  3. (Facoltativo) Per gestire i registri eventi su un computer remoto come un diverso utente, digitare il comando seguente nella finestra del prompt dei comandi:

    wevtutil <command> /r:<remote_computer_name> /u:<user_name> /p:<password>

Ulteriori considerazioni

  • È necessario abilitare l'eccezione Gestione remota registro eventi nelle Impostazioni Windows Firewall sul computer remoto al quale si desidera connettersi.

  • È possibile digitare eventvwr <remote_computer_name> in una finestra del prompt dei comandi per avviare il Visualizzatore eventi e connettersi a un computer remoto. È inoltre possibile includere opzioni che consentono l'avvio del Visualizzatore eventi con una visualizzazione personalizzata specificata oppure con un determinato registro selezionato. Per ulteriori informazioni sul comando eventvwr, in una finestra del prompt dei comandi digitare eventvwr /?. Sebbene sia possibile utilizzare il comando eventvwr per avviare il Visualizzatore eventi e connettersi a computer che eseguono versioni precedenti di Windows, le eventuali opzioni specificate verranno ignorate.

  • Quando ci si connette a un computer remoto, il Visualizzatore eventi visualizza le visualizzazioni personalizzate archiviate nel computer locale. Facendo clic su una di queste visualizzazioni personalizzate locali, la query sottostante verrà eseguita per i registri eventi del computer remoto.

  • Quando ci si connette a un computer remoto, i registri esterni visualizzati dal Visualizzatore eventi sono quelli a cui si fa riferimento nel computer locale.

  • È possibile riscontrare errori se, durante la connessione a un computer remoto, si cerca di visualizzare le visualizzazioni personalizzate che fanno riferimento a registri eventi esterni. Questo avviene poiché il Visualizzatore eventi cerca di aprire questi registri esterni nel computer remoto invece che nel computer locale. Questo problema non si presenta se si utilizzano nomi percorso UNC per il riferimento a registri esterni.

  • Per visualizzare gli evento salvati da un computer remoto, è necessario salvare gli eventi sul computer remoto con le informazioni di visualizzazione. Per ulteriori informazioni sull'archiviazione degli eventi con le informazioni di visualizzazione, vedere Archiviare un registro eventi.

Ulteriori riferimenti

  • Avviare il Visualizzatore eventi

  • Notazione di sintassi della riga di comando


Eseguire un'attività in risposta a un evento specifico

È possibile configurare un'attività da eseguire quando viene registrato un evento che risponde a criteri specifici.

Per eseguire un'attività in risposta a un evento specifico

  1. Avviare il Visualizzatore eventi.

  2. Nell'albero della console passare al registro che contiene l'evento che si desidera associare a un'attività.

  3. Fare clic con il pulsante destro del mouse sull'evento e selezionare Associa attività all'evento.

  4. Eseguire ogni passaggio della procedura della Creazione guidata attività di base.

Ulteriori considerazioni

  • Non è possibile assegnare un'attività a un evento in un registro salvato.

  • Non è possibile assegnare un'attività a un evento in un registro analitico o di debug.

Risorse aggiuntive

Procedure relative al Visualizzatore eventi


Risolvere i problemi relativi al Visualizzatore eventi

In questa sezione vengono elencati alcuni problemi comuni riscontrabili durante l'utilizzo del Visualizzatore eventi. Per informazioni più aggiornate sulla risoluzione dei problemi vedere l'argomento online sulla risoluzione dei problemi relativi al Visualizzatore eventi.

Quale problema si è verificato?

  • Non vi sono eventi nel registro eventi

  • Non è possibile individuare registri analitici o di debug

  • Il Visualizzatore eventi non riesce a connettersi a un computer remoto

  • Non è possibile vedere la descrizione associata a un evento

  • L'utente ha associato un'attività a un evento ma l'attività non è stata eseguita in risposta all'evento

  • Una visualizzazione personalizzata importata non restituisce eventi

Nota

Se si verificano problemi con una o più funzionalità del Visualizzatore eventi, verificare innanzitutto che il servizio registrazione eventi di Windows sia in esecuzione. Se si lavora con sottoscrizioni eventi, verificare che il servizio Raccolta eventi Windows sia in esecuzione.
Non vi sono eventi nel registro eventi.

Se non ci sono eventi nel registro eventi, è possibile che la registrazione sia disabilitata per quel registro specifico o che gli eventi siano stati cancellati da un altro utente. Per verificare se un registro è abilitato, fare clic col pulsante destro del mouse sul registro, scegliere Proprietà e selezionare l'opzione Abilita registrazione. Per verificare se il registro è stato cancellato, nel registro eventi del sistema cercare un evento con un valore di ID di 104. Questo evento viene generato quando si cancella un registro.

Non è possibile trovare registri analitici o di debug.

I registri analitici e di debug sono nascosti per impostazione predefinita. Per informazioni su come rendere questi registri visibili, vedere Visualizzare o nascondere registri analitici e di debug.

Il Visualizzatore eventi non riesce a connettersi a un computer remoto.

Se il Visualizzatore eventi non riesce a connettersi a un computer remoto, verificare che il computer remoto sia disponibile in rete. Verificare quindi che nel computer remoto sia stata impostata l'eccezione Gestione remota registro eventi di Windows Firewall. Verificare infine che l'account utente disponga dell'autorizzazione per accedere al computer remoto.

Non è possibile visualizzare la descrizione associata a un evento.

Se non è possibile visualizzare la descrizione associata a un evento, l'applicazione di origine potrebbe non essere installata nel computer su cui si cerca di visualizzare l'evento. È possibile salvare l'evento in un file e visualizzarlo nel computer dove è installata questa applicazione oppure è possibile procedere all'installazione dell'applicazione nel computer locale.

L'utente ha associato un'attività a un evento ma l'attività non viene eseguita in risposta all'evento.

È necessario utilizzare l'Utilità di pianificazione per il debug dei problemi relativi alle attività associate agli eventi. Aprire l'Utilità di pianificazione e cercare l'attività. È necessario verificare l'esistenza dell'attività e la sua configurazione per l'avvio in corrispondenza dell'evento corretto.

Una visualizzazione personalizzata importata non restituisce eventi.

La visualizzazione personalizzata importata potrebbe includere riferimenti a registri che non sono disponibili nel computer attualmente utilizzato. Per verificare i registri cui si fa riferimento nella visualizzazione personalizzata, fare clic col tasto destro del mouse sulla visualizzazione personalizzata e scegliere Proprietà e quindi Modifica filtro e selezionare l'elenco a discesa Registro eventi.


Notazione di sintassi della riga di comando

Nella tabella seguente viene descritta la notazione utilizzata per indicare la sintassi della riga di comando.

Notazione | Descrizione
Testo senza parentesi quadre o graffe | Elementi da digitare come indicato
<Testo tra parentesi acute> | Segnaposto per il quale è necessario fornire un valore
[Testo tra parentesi quadre] | Elementi facoltativi
{Testo tra parentesi graffe} | Serie di elementi richiesti: effettuare una selezione
Barra verticale (|) | Separatore per elementi che si escludono a vicenda: effettuare una selezione
Puntini di sospensione (...) | Elementi che possono essere ripetuti