Servizi file

Servizi file fornisce tecnologie per la gestione degli archivi, la replica di file, la gestione delle cartelle condivise, la ricerca rapida di file e l'accesso da parte di computer client UNIX.

Con Servizi file le organizzazioni possono archiviare i file in una posizione centrale, quindi condividerli con gli utenti di tutta la rete aziendale. Per aiutare gli utenti a trovare rapidamente i file, è possibile indicizzarli. È inoltre possibile sincronizzare le cartelle presenti in più server per assicurare accesso a tolleranza di errore alle risorse condivise. Servizi file consente inoltre di effettuare il provisioning dell'archiviazione in sottosistemi di archiviazione disco iSCSI e Fibre Channel

  • Per ulteriori informazioni sui servizi e i componenti di Servizi file, vedere Panoramica di Servizi file.

  • Per ottenere la documentazione di Servizi file, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94208.


Panoramica di Servizi file

Un file server rappresenta una posizione centrale sulla rete in cui è possibile archiviare e condividere file con utenti della rete. Quando gli utenti hanno necessità di utilizzare un file importante creato affinché possano accedervi più utenti, ad esempio la pianificazione di un progetto, possono accedere al file nel file server in remoto anziché trasferire il file tra computer separati.

Se gli utenti della rete accedono agli stessi file e applicazioni oppure nel caso in cui la centralizzazione del backup e della gestione dei file sia importante nell'organizzazione, è consigliabile configurare il computer come file server aggiungendo il ruolo Servizi file.

Il ruolo Servizi file include i servizi ruolo seguenti:

  • Gestione condivisione e archiviazione

  • File system distribuito (DFS)

  • Gestione risorse file server

  • Servizi per NFS (Network File System)

  • Servizio Ricerca di Windows

  • Servizi file di Windows Server 2003

  • BranchCache per file di rete

Oltre ai servizi ruolo elencati sopra, è possibile installare le funzionalità facoltative seguenti:

  • Windows Server Backup

  • Gestione archivi SAN

  • Clustering di failover

  • Multipath I/O

Servizi ruolo nel ruolo Servizi file

Gestione condivisione e archiviazione

La console Gestione condivisione e archiviazione consente la gestione integrata e semplificata di cartelle condivise e risorse di archiviazione. È possibile utilizzare Gestione condivisione e archiviazione per condividere il contenuto delle cartelle e gestire l'utilizzo delle cartelle condivise.

È inoltre possibile utilizzare Gestione condivisione e archiviazione per creare e configurare numeri di unità logiche per allocare spazio nei sottosistemi di archiviazione sulla rete di archiviazione (SAN, Storage Area Network).

Per ulteriori informazioni, vedere la Guida di Gestione condivisione e archiviazione. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh storagemgmt.chm.

File system distribuito (DFS)

File system distribuito è costituito da due tecnologie che possono essere utilizzate congiuntamente o singolarmente per garantire servizi di replica e condivisione file flessibili e a tolleranza di errore in una rete basata su Windows.

Spazi dei nomi DFS

Spazi dei nomi DFS consente di raggruppare cartelle condivise situate in server diversi in uno o più spazi dei nomi strutturati logicamente. Gli utenti vedono ogni spazio dei nomi come una singola cartella condivisa con una serie di sottocartelle. La struttura sottostante dello spazio dei nomi può essere tuttavia costituita da numerose cartelle condivise situate in server diversi e in più siti. Poiché la struttura sottostante delle cartelle condivise non è visibile agli utenti, una singola cartella in uno spazio dei nomi DFS può corrispondere a più cartelle condivise in più server. Questa struttura offre la tolleranza di errore e la possibilità di connettere automaticamente gli utenti a cartelle condivise locali, se disponibili, invece di instradarli su connessioni di rete WAN.

Per ulteriori informazioni, vedere la Guida relativa alla gestione degli spazi dei nomi in DFS. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh dfs2.chm.

Replica DFS

Replica DFS è un motore di replica multimaster che consente di sincronizzare cartelle in più server tramite connessioni di rete LAN o WAN. Utilizza il protocollo RDC (Remote Differential Compression) per aggiornare solo le parti dei file che sono state modificate dopo l'ultima replica. È possibile utilizzare Replica DFS autonomamente o insieme a Spazi dei nomi DFS.

Per ulteriori informazioni, vedere la Guida relativa alla gestione della replica in DFS. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh dfs2.chm.

Gestione risorse file server

Gestione risorse file server include diversi strumenti che consentono agli amministratori di esaminare, controllare e gestire la quantità e il tipo di dati archiviati nei server di competenza. Con Gestione risorse file server, gli amministratori possono impostare quote per cartelle e volumi, eseguire screening dei file, classificare automaticamente i file, applicare scadenze e attività personalizzate ai file in base alla classificazione, nonché generare rapporti archiviazione completi.

Per ulteriori informazioni, vedere la Guida di Gestione risorse file server. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh fsrm.chm.

Servizi per NFS (Network File System)

Servizi per NFS rappresenta una soluzione di condivisione file per le organizzazioni che dispongono di ambienti misti Windows e UNIX. Servizi per NFS consente di trasferire file tra computer che eseguono sistemi operativi Windows Server 2008 o Windows Server 2008 R2 e UNIX mediante il protocollo NFS.

Per ulteriori informazioni, vedere la Guida di Servizi per NFS. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh nfs__lh.chm.

Servizio Ricerca di Windows

Servizio Ricerca di Windows consente di eseguire ricerche rapide di file in un server da computer client compatibili con Ricerca di Windows.

Per ulteriori informazioni, vedere Servizio Ricerca di Windows e Servizio di indicizzazione.

Nota

Non è possibile installare nello stesso computer servizio Ricerca di Windows e il Servizio di indicizzazione.

Servizi file di Windows Server 2003

Il ruolo Servizi file in Windows Server 2008 R2 include i servizi ruolo seguenti, compatibili con Windows Server 2003.

Servizio di indicizzazione

Servizio di indicizzazione consente di catalogare il contenuto e le proprietà dei file disponibili in computer locali e remoti, oltre che di trovare rapidamente i file tramite un linguaggio di query flessibile.

Per ulteriori informazioni, vedere Servizio Ricerca di Windows e Servizio di indicizzazione.

Nota

Non è possibile installare nello stesso computer il Servizio di indicizzazione e Servizio Ricerca di Windows.

BranchCache per file di rete

BranchCache per file di rete consente ai computer delle succursali di memorizzare nella cache i file scaricati comunemente dalle cartelle condivise nelle quali è attivato BranchCache e quindi di rendere tali file disponibili per altri computer nella succursale. Ciò consente di ridurre l'utilizzo della larghezza di banda della rete nonché di offrire un accesso più rapido ai file.

Per ulteriori informazioni, vedere l'argomento contenente la panoramica di Windows BranchCache nella Guida delle funzionalità dei ruoli server. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh features.chm.

Funzionalità facoltative

Per integrare i servizi ruolo del ruolo Servizi file, è possibile installare le funzionalità aggiuntive seguenti.

Windows Server Backup

Windows Server Backup consente il backup e il ripristino affidabili del sistema operativo, di determinate applicazioni e di file e cartelle archiviati nel server. Questa funzionalità introduce una nuova tecnologia di backup e ripristino e sostituisce la funzionalità di backup disponibile nelle versioni precedenti di Windows.

Per ulteriori informazioni, vedere la Guida di Windows Server Backup. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh backup.chm.

Gestione archivi SAN

Gestione archivi SAN consente di utilizzare spazio di archiviazione in uno o più sottosistemi di archiviazione Fibre Channel o iSCSI in una rete di archiviazione (SAN).

Per ulteriori informazioni, vedere la Guida di Gestione archivi SAN. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh sanmgr.chm.

Clustering di failover

La funzionalità Clustering di failover consente a più server di funzionare insieme per aumentare la disponibilità di servizi e applicazioni. I server inclusi nel cluster (denominati nodi) sono connessi mediante cavi fisici e software. Se si verificano problemi in uno dei nodi, i servizi verranno forniti da un altro nodo. Tale processo è noto come failover.

Per ulteriori informazioni, vedere la documentazione relativa al clustering di failover disponibile sul Web (http://go.microsoft.com/fwlink/?LinkId=62911).

Multipath I/O

Multipath I/O garantisce il supporto per più percorsi di dati da un file server a un dispositivo di archiviazione. Con Multipath I/O è possibile aumentare la disponibilità dei dati offrendo connessioni ridondanti ai sottosistemi di archiviazione. Questa soluzione consente inoltre il bilanciamento del carico del traffico I/O migliorando così le prestazioni di sistema e applicazioni.

Per ulteriori informazioni, vedere la documentazione di Multipath I/O disponibile sul Web (http://go.microsoft.com/fwlink/?LinkId=81020).

Considerazioni relative ai requisiti hardware e software

Nota

È disponibile un insieme limitato di ruoli server per l'opzione di installazione di Server Core di Windows Server 2008 e per Windows Server 2008 per sistemi basati su Itanium.

Risorse aggiuntive

Per ottenere la documentazione di Servizi file, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94208.


Servizio Ricerca di Windows e Servizio di indicizzazione

Servizio Ricerca di Windows è una nuova soluzione di indicizzazione inclusa in Windows Server® 2008 come servizio ruolo nel ruolo Servizi file. Crea un indice dei file e dei tipi di dati diversi da file più comuni disponibili nel server, ad esempio posta elettronica, contatti, appuntamenti del calendario, documenti, foto, materiale multimediale e altri formati estesi da file non Microsoft. L'indicizzazione di file e tipi di dati consente di eseguire ricerche rapide dei file nel server da computer che eseguono Windows Vista o da computer che eseguono Windows XP o Windows Server 2003 in cui è installato Windows Desktop Search.

Servizio di indicizzazione è una soluzione di indicizzazione inclusa in Windows Server 2008 e in versioni precedenti di Windows.

Quale soluzione di indicizzazione è consigliabile installare?

È consigliabile installare servizio Ricerca di Windows, a meno che non si disponga di un'applicazione personalizzata o non Microsoft per cui sia necessaria l'esecuzione del Servizio di indicizzazione legacy nel server. A servizio Ricerca di Windows sono stati apportati diversi miglioramenti rispetto al Servizio di indicizzazione, principalmente nelle aree relative all'estendibilità, all'utilizzabilità e alle prestazioni.

Se si dispone di applicazioni per cui è necessario il Servizio di indicizzazione, è consigliabile aggiornarle in modo che siano compatibili con servizio Ricerca di Windows.

È possibile installare entrambe le soluzioni di indicizzazione?

Non è possibile installare nello stesso computer servizio Ricerca di Windows e il Servizio di indicizzazione. Poiché entrambe le soluzioni di indicizzazione si avvalgono delle risorse di sistema durante l'indicizzazione attiva di volumi e cartelle, le prestazioni del sistema potrebbero risultare compromesse.

Selezionare volumi e cartelle da indicizzare con servizio Ricerca di Windows

Se si installa servizio Ricerca di Windows mediante l'Aggiunta guidata ruoli o la procedura guidata Aggiunta servizi ruolo in Server Manager, sarà possibile selezionare i volumi da indicizzare. È consigliabile selezionare solo i volumi utilizzati esclusivamente per ospitare cartelle condivise. L'indicizzazione di file e tipi di dati in cartelle non condivise sulla rete non è utile per i computer client che si connettono al server e prevede un utilizzo intensivo delle risorse di sistema.

Se si desidera indicizzare singole cartelle condivise, è possibile aggiungerle in un secondo tempo all'elenco dei percorsi di indicizzazione mediante Opzioni di indicizzazione nel Pannello di controllo.

Nota

Quando si installa servizio Ricerca di Windows, vengono selezionati percorsi di indicizzazione predefiniti, anche se non si seleziona un volume da indicizzare. È possibile controllare i percorsi di indicizzazione mediante Opzioni di indicizzazione.

Modificare i percorsi di indicizzazione

Dopo aver installato servizio Ricerca di Windows, è possibile utilizzare Opzioni di indicizzazione nel Pannello di controllo per aggiungere o rimuovere cartelle e volumi dall'elenco dei percorsi di indicizzazione. Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per modificare i percorsi di indicizzazione

  1. Dopo aver installato servizio Ricerca di Windows, fare doppio clic su Opzioni di indicizzazione nel Pannello di controllo.

  2. Fare clic su Modifica.

  3. Se nell'elenco non è visualizzato alcun percorso di indicizzazione, fare clic su Mostra tutti i percorsi. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  4. Per rimuovere una cartella o un volume dall'elenco dei percorsi di indicizzazione, selezionarlo innanzitutto nell'elenco Riepilogo percorsi selezionati e quindi deselezionare la casella di controllo corrispondente nell'elenco Modifica percorsi selezionati.

  5. Per aggiungere una cartella o un volume all'elenco, selezionare la casella di controllo corrispondente nell'elenco Modifica percorsi selezionati.

  6. Dopo aver apportato tutte le modifiche, fare clic su OK.

  7. Fare clic su Chiudi per uscire da Opzioni di indicizzazione.

Informazioni correlate

  • Windows Desktop Search per Windows XP, Windows 2000 e Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=93384)

  • Documentazione Microsoft Developer Network per Ricerca di Windows 3.x (http://go.microsoft.com/fwlink/?LinkId=93386).