Console Gestione Criteri di gruppo

Console Gestione Criteri di gruppo è uno snap-in di MMC (Microsoft Management Console) configurabile tramite script che consente di gestire Criteri di gruppo all'interno dell'organizzazione tramite un singolo strumento di amministrazione. Gestione Criteri di gruppo è lo strumento standard per la gestione di Criteri di gruppo.

Per informazioni su operazioni specifiche, vedere:

  • Iniziare a utilizzare Console Gestione Criteri di gruppo

  • Modificare, filtrare e commentare le impostazioni dei criteri

  • Configurare e commentare elementi preferenza e definirne la destinazione

  • Ripristinare, importare, copiare oggetti Criteri di gruppo ed eseguirne il backup

  • Controllare l'ambito degli oggetti Criteri di gruppo

  • Utilizzare Gruppo di criteri risultante per gestire Criteri di gruppo

  • Delegare le autorizzazioni per Criteri di gruppo

  • Utilizzare Windows PowerShell per gestire Criteri di gruppo

Per informazioni sulla risoluzione dei problemi e risorse aggiuntive, vedere:

  • Risorse per Console Gestione Criteri di gruppo


Iniziare a utilizzare Console Gestione Criteri di gruppo

In questa sezione sono inclusi gli argomenti seguenti:

  • Aprire Console Gestione Criteri di gruppo

  • Personalizzare l'interfaccia utente di Console Gestione Criteri di gruppo

  • Utilizzare oggetti Criteri di gruppo

  • Impostare domini, foreste e siti

  • Visualizzare, stampare e salvare un rapporto contenente le impostazioni di un oggetto Criteri di gruppo

Ulteriori riferimenti

TechCenter di Windows Server


Installare Console Gestione Criteri di gruppo

Console Gestione Criteri di gruppo è disponibile in Windows Server® 2008 e versioni successive. Questa funzionalità, tuttavia, non viene installata con il sistema operativo. Per installare Console Gestione Criteri di gruppo, utilizzare Server Manager.

Installare Console Gestione Criteri di gruppo tramite l'interfaccia utente

Installare Console Gestione Criteri di gruppo tramite la riga di comando

Installare Console Gestione Criteri di gruppo tramite l'interfaccia utente

Per installare Console Gestione Criteri di gruppo utilizzando l'interfaccia utente di Server Manager

  1. Per aprire Server Manager fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Server Manager.

  2. Nell'albero della console fare clic su Funzionalità. Nel riquadro Funzionalità fare clic su Aggiungi funzionalità.

  3. Nella finestra di dialogo Aggiunta guidata funzionalità selezionare Console Gestione Criteri di gruppo nell'elenco delle funzionalità disponibili. Fare clic su Installa.

  4. Al termine dell'installazione, chiudere Server Manager.

Installare Console Gestione Criteri di gruppo tramite la riga di comando

Per installare Console Gestione Criteri di gruppo utilizzando la riga di comando

  1. Aprire il prompt dei comandi come amministratore.

  2. Al prompt dei comandi digitare ServerManagerCmd -install gpmc.

  3. Al termine dell'installazione, chiudere il prompt dei comandi.

Ulteriori riferimenti

  • Aprire Console Gestione Criteri di gruppo

  • Personalizzare l'interfaccia utente di Console Gestione Criteri di gruppo

  • Utilizzare oggetti Criteri di gruppo

  • Utilizzare oggetti Criteri di gruppo Starter

  • Impostare domini, foreste e siti


Aprire Console Gestione Criteri di gruppo

È possibile avviare Console Gestione Criteri di gruppo in uno dei due modi seguenti.

Per avviare Console Gestione Criteri di gruppo

  • Eseguire una delle operazioni seguenti:

    • Premere il tasto logo Windows+R per aprire la finestra di dialogo Esegui. Digitare gpmc.msc nella casella di testo e quindi fare clic su OK o premere INVIO.

    • Fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Esegui. Digitare gpmc.msc nella casella di testo e quindi fare clic su OK o premere INVIO.

Ulteriori riferimenti

Iniziare a utilizzare Console Gestione Criteri di gruppo


Personalizzare l'interfaccia utente di Console Gestione Criteri di gruppo

È possibile personalizzare l'interfaccia utente di Console Gestione Criteri di gruppo eseguendo le procedure indicate in questo argomento.

Per impostare le opzioni dell'interfaccia utente

  1. Aprire Console Gestione Criteri di gruppo.

  2. Scegliere Opzioni dal menu Visualizza.

  3. Fare clic su una o più delle schede seguenti per personalizzare l'interfaccia utente di Console Gestione Criteri di gruppo:

    Nella scheda Colonne:

    1. Selezionare una tabella nell'elenco Percorso tabella.

    2. In Ordine di visualizzazione colonne selezionare ogni colonna che si desidera visualizzare.

    3. Selezionare una colonna e fare clic sui pulsanti Sposta su e Sposta giù per modificare l'ordine delle colonne.

    4. Ripetere i passaggi 2 e 3 per ogni tabella inclusa nell'elenco Percorso tabella che si desidera modificare e quindi fare clic su OK.

    5. L'opzione Salva valori personalizzati per dimensioni e ordine colonne, attivata per impostazione predefinita, consente di rendere permanenti le scelte relative all'ordine e alle dimensioni delle colonne. Deselezionare questa casella di controllo se non si desidera rendere permanenti tali valori.

    Nella scheda Rapporti selezionare una delle opzioni seguenti:

    • Per specificare che in Console Gestione Criteri di gruppo è necessario utilizzare i file con estensione adm locali, selezionare Predefinito. Se non viene trovato in locale alcun file con estensione adm, la ricerca verrà eseguita nella cartella degli oggetti Criteri di gruppo all'interno della cartella SYSVOL.

    • Per specificare un percorso personalizzato che abbia precedenza su quelli predefiniti, selezionare Personalizzato e quindi immettere il percorso in cui sono archiviati i file con estensione adm.

      Importante

      Questa procedura è valida solo per i file con estensione adm e non per i file ADMX di Windows® 7 o Windows Vista®. Il percorso dei file ADMX non è configurabile. Console Gestione Criteri di gruppo legge automaticamente i file ADMX dall'archivio locale o dall'archivio centrale basato sul dominio.

    Nella scheda Generale selezionare una delle opzioni seguenti:

    • Per visualizzare solo le foreste o i domini con trust bidirezionali verso il dominio dell'utente, selezionare Abilita rilevamento trust. Questa opzione è selezionata per impostazione predefinita.

    • Per visualizzare i nomi dei controller di dominio tra parentesi dopo ogni dominio in Console Gestione Criteri di gruppo, selezionare Visualizza i controller di dominio dopo i nomi di dominio.

    • Per visualizzare una finestra di dialogo di conferma che consenta di distinguere tra oggetti Criteri di gruppo e collegamenti a oggetti Criteri di gruppo ogni volta che un oggetto o un collegamento viene selezionato in Console Gestione Criteri di gruppo, selezionare Visualizza finestra di dialogo di conferma per distinguere tra gli oggetti Criteri di gruppo e i relativi collegamenti. Questa opzione è selezionata per impostazione predefinita.

Ulteriori considerazioni

  • Console Gestione Criteri di gruppo vengono utilizza i file con estensioni adm, admx e adml per visualizzare i nomi descrittivi delle impostazioni relative ai criteri durante la generazione di rapporti HTML per oggetti Criteri di gruppo, Modellazione Criteri di gruppo e Rapporti Criteri di gruppo. Queste opzioni consentono di controllare il percorso da cui i soli file con estensione adm vengono letti da Console Gestione Criteri di gruppo.

  • Se si aggiunge o modifica un file con estensione adm o un file ADMX in un percorso esistente, è necessario riavviare Console Gestione Criteri di gruppo affinché venga visualizzata la modifica apportata durante la visualizzazione dei rapporti HTML.

  • Console Gestione Criteri di gruppo non copia mai i file con estensione adm o i file ADMX nella cartella SYSVOL.

Ulteriori riferimenti

Iniziare a utilizzare Console Gestione Criteri di gruppo


Utilizzare oggetti Criteri di gruppo

  • Creare e modificare un oggetto Criteri di gruppo

  • Cercare un oggetto Criteri di gruppo

  • Eliminare un oggetto Criteri di gruppo

  • Aggiungere commenti a un oggetto Criteri di gruppo

Ulteriori riferimenti

Iniziare a utilizzare Console Gestione Criteri di gruppo


Creare e modificare un oggetto Criteri di gruppo

È possibile utilizzare Console Gestione Criteri di gruppo per creare e modificare Oggetti Criteri di gruppo.

Creare e modificare un oggetto Criteri di gruppo

  • Creare un oggetto Criteri di gruppo

  • Modificare un oggetto Criteri di gruppo

Nota

È possibile creare un oggetto Criteri di gruppo anche da un oggetto Criteri di gruppo Starter. Per ulteriori informazioni, vedere Creare un nuovo un oggetto Criteri di gruppo da un oggetto Criteri di gruppo Starter.
Per creare un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo nella foresta e nel dominio in cui si desidera creare un oggetto Criteri di gruppo.

  2. Fare clic su Nuovo.

  3. Nella finestra di dialogo Nuovo oggetto Criteri di gruppo specificare un nome per il nuovo oggetto Criteri di gruppo e quindi fare clic su OK.

Per modificare un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic su Oggetti Criteri di gruppo nella foresta e nel dominio contenenti l'oggetto Criteri di gruppo che si desidera modificare.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo e quindi scegliere Modifica.

  3. Nell'albero della console modificare le impostazioni in base alle esigenze.

    Importante

    Gli oggetti Criteri di gruppo Criterio dominio predefinito e Criterio controller di dominio predefiniti sono estremamente importanti per il corretto funzionamento di qualsiasi dominio. È consigliabile non modificare l'oggetto Criteri di gruppo Criterio controller di dominio predefiniti o Criterio dominio predefinito, ad eccezione dei casi seguenti:

    • È necessario configurare impostazioni dei criteri degli account nell'oggetto Criteri di gruppo Criterio dominio predefinito.

    • Se si installano applicazioni nei controller di dominio che richiedono modifiche alle impostazioni Diritti utente o Criteri controllo, è necessario modificare le impostazioni dei criteri nell'oggetto Criteri di gruppo Criterio controller di dominio predefiniti.

Ulteriori considerazioni

  • Quando si crea un oggetto Criteri di gruppo, questo non sarà effettivo fino al collegamento a un sito, un dominio o un'unità organizzativa.

  • Per impostazione predefinita, solo gli amministratori di dominio, gli amministratori dell'organizzazione e i membri del gruppo Proprietari autori criteri di gruppo possono creare e modificare oggetti Criteri di gruppo.

  • Per modificare le impostazioni dei criteri IPSec all'interno di un oggetto Criteri di gruppo, è necessario essere un membro del gruppo degli amministratori di dominio.

  • Per modificare un oggetto Criteri di gruppo, è inoltre possibile fare clic con il pulsante destro del mouse sul nome dell'oggetto in qualsiasi contenitore in cui sia collegato e quindi scegliere Modifica.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo


Cercare un oggetto Criteri di gruppo

Per cercare un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta contenente il dominio in cui si desidera cercare un oggetto Criteri di gruppo. Fare doppio clic su Domini, fare clic con il pulsante destro del mouse sul dominio e quindi scegliere Cerca.

  2. Nella casella Selezionare il dominio in cui cercare della finestra di dialogo Cerca oggetti Criteri di gruppo selezionare un dominio oppure l'opzione Tutti i domini visualizzati in questa foresta.

  3. Nella casella Elemento da cercare selezionare il tipo di oggetto su cui si desidera basare la ricerca.

    Se si seleziona Gruppo di sicurezza, verrà visualizzata la finestra di dialogo Selezione Utente, Computer o Gruppo. Specificare il tipo di oggetto appropriato, il percorso e il nome dell'oggetto e quindi fare clic su OK.

    È possibile selezionare Collegamenti a oggetti Criteri di gruppo nel menu a discesa Elemento da cercare per trovare gli oggetti Criteri di gruppo non collegati e quelli collegati tra domini.

  4. Nella casella Condizione selezionare la condizione che si desidera utilizzare nella ricerca.

  5. Nella casella Valore selezionare o specificare il valore che si desidera utilizzare per filtrare la ricerca e quindi fare clic su Aggiungi.

  6. Ripetere i passaggi 4 e 5 per completare la definizione di tutti i criteri di ricerca e quindi fare clic su Cerca.

  7. Quando vengono visualizzati i risultati della ricerca, eseguire una delle operazioni seguenti:

    • Per salvare i risultati della ricerca, fare clic su Salva risultati. Nella finestra di dialogo Salva i risultati della ricerca di oggetti Criteri di gruppo specificare il nome del file per i risultati salvati e quindi fare clic su Salva.

    • Per accedere a uno degli oggetti Criteri di gruppo individuati, fare doppio clic sull'oggetto Criteri di gruppo desiderato nell'elenco dei risultati della ricerca.

    • Per cancellare i risultati della ricerca, fare clic su Cancella.

Ulteriori considerazioni

  • È inoltre possibile aprire la finestra di dialogo di ricerca facendo clic con il pulsante destro del mouse su una foresta e quindi scegliendo Cerca. In questo caso, la casella Selezionare il dominio in cui cercare verrà automaticamente impostata su Tutti i domini visualizzati in questa foresta.

  • Se è attivata un'impostazione dei criteri e nell'estensione vengono quindi rimosse tutte le impostazioni dei criteri, è possibile che la ricerca restituisca risultati errati per alcuni tipi di impostazioni. Questo comportamento si verifica in quanto l'estensione viene elencata come attivata per l'oggetto Criteri di gruppo. Le estensioni con questo comportamento sono Impostazioni sicurezza, Installazione software, Reindirizzamento cartelle, Manutenzione di Internet Explorer ed EFS (Encrypting File System).

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo


Eliminare un oggetto Criteri di gruppo

Per eliminare un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic su Oggetti Criteri di gruppo nella foresta e nel dominio contenenti l'oggetto Criteri di gruppo che si desidera eliminare.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo e quindi scegliere Elimina.

  3. Quando viene richiesto di confermare l'eliminazione, fare clic su OK.

Ulteriori considerazioni

  • Per eliminare un oggetto Criteri di gruppo, è necessario disporre delle autorizzazioni Modifica impostazioni, elimina, modifica sicurezza per tale oggetto.

  • Quando si elimina un oggetto Criteri di gruppo, in Console Gestione Criteri di gruppo viene eseguito il tentativo di eliminare tutti i collegamenti all'oggetto Criteri di gruppo inclusi nel dominio dell'oggetto. Se non si dispone dei diritti necessari per eliminare un collegamento, l'oggetto Criteri di gruppo verrà eliminato, ma il collegamento verrà mantenuto. I collegamenti da altri domini e siti non verranno eliminati. Il collegamento a un oggetto Criteri di gruppo viene visualizzato in Console Gestione Criteri di gruppo come Non trovato. Per eliminare i collegamenti Non trovato, è necessario disporre dell'autorizzazione per il sito, il dominio o l'unità organizzativa contenente il collegamento.

  • Non è possibile eliminare l'oggetto Criteri di gruppo Criterio controller di dominio predefiniti o Criterio dominio predefinito.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo


Aggiungere commenti a un oggetto Criteri di gruppo

È possibile includere commenti per ogni oggetto Criteri di gruppo. Lo spazio dei commenti può essere utilizzato per documentare l'oggetto Criteri di gruppo e il motivo per cui la relativa implementazione è importante per l'ambiente di utilizzo. L'aggiunta di commenti agli oggetti Criteri di gruppo consentirà in seguito di utilizzare filtri in base a parole chiave per trovare rapidamente gli oggetti Criteri di gruppo corrispondenti alle parole chiave.

Aggiungere commenti a un oggetto Criteri di gruppo

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo al quale si desidera aggiungere un commento e quindi scegliere Modifica.

  3. Nell'albero della console fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Commento.

  5. Digitare i commenti nella casella Commenti.

  6. Fare clic su OK.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo


Utilizzare oggetti Criteri di gruppo Starter

Gli oggetti Criteri di gruppo Starter derivano da un Oggetto Criteri di gruppo e consentono di archiviare in un unico oggetto un insieme di impostazioni dei criteri dei modelli amministrativi. Gli oggetti Criteri di gruppo Starter possono essere importati ed esportati, sono pertanto molto semplici da distribuire in altri ambienti. Quando si crea un oggetto Criteri di gruppo da un oggetto Criteri di gruppo Starter, il nuovo oggetto Criteri di gruppo contiene tutte le impostazioni dei criteri dei modelli amministrativi e i relativi valori, in base a quanto definito nell'oggetto Criteri di gruppo Starter.

In questa sezione vengono descritti gli argomenti seguenti:

  • Creare e modificare un oggetto Criteri di gruppo Starter

  • Eliminare un oggetto Criteri di gruppo Starter

  • Creare un nuovo un oggetto Criteri di gruppo da un oggetto Criteri di gruppo Starter

  • Eseguire il backup e il ripristino di un oggetto Criteri di gruppo Starter

  • Visualizzare, stampare e salvare un rapporto contenente le impostazioni di un oggetto Criteri di gruppo Starter

  • Importare ed esportare oggetti Criteri di gruppo Starter

  • Aggiungere commenti a un oggetto Criteri di gruppo Starter


Creare e modificare un oggetto Criteri di gruppo Starter

Console Gestione Criteri di gruppo consente di archiviare oggetti Criteri di gruppo Starter in una cartella denominata StarterGPOs che si trova nella cartella SYSVOL, disponibile nei controller di dominio.

Nota

Console Gestione Criteri di gruppo cerca la cartella quando si fa clic su Oggetti Criteri di gruppo Starter nell'interfaccia utente. Se la cartella non esiste, in Console Gestione Criteri di gruppo viene visualizzato il pulsante Crea cartella di oggetti Criteri di gruppo Starter. Fare clic su Crea cartella di oggetti Criteri di gruppo Starter per creare il percorso di archiviazione Oggetti Criteri di gruppo Starter.

Creare e modificare un oggetto Criteri di gruppo Starter

  • Creare un oggetto Criteri di gruppo Starter

  • Modificare un oggetto Criteri di gruppo Starter
Creare un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo.

  2. Fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo Starter e quindi scegliere Nuovo.

  3. Nella finestra di dialogo Nuovo oggetto Criteri di gruppo Starter immettere il nome dell'oggetto Criteri di gruppo Starter nella casella Nome. Se lo si desidera, è possibile aggiungere commenti nella casella Commenti.

  4. Fare clic su OK.
Modificare un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo Starter che si desidera modificare e quindi scegliere Modifica.

  3. Nell'albero della console fare clic sulla cartella in Modelli amministrativi contenente le impostazioni dei criteri che si desidera configurare.

  4. Nella colonna Impostazione fare clic sul nome di un'impostazione dei criteri per visualizzare la relativa descrizione.

  5. Per modificare un'impostazione dei criteri, fare doppio clic sul nome dell'impostazione.

  6. Nella finestra di dialogo delle impostazioni del criterio fare clic su una delle opzioni seguenti:

    • Non configurata: il Registro di sistema non verrà modificato.

    • Attivata: nel Registro di sistema verrà indicato che l'impostazione dei criteri è selezionata.

    • Disattivata: nel Registro di sistema verrà indicato che l'impostazione dei criteri non è selezionata.

  7. Selezionare tutte le altre opzioni disponibili e quindi fare clic su OK.

Ulteriori considerazioni

  • Gli oggetti Criteri di gruppo Starter di sistema sono di sola lettura. Per ulteriori informazioni, vedere Oggetti Criteri di gruppo Starter di sistema.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Copiare un oggetto Criteri di gruppo Starter

Copiare un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo Starter che si desidera copiare e quindi scegliere Copia.

  3. Fare clic con il pulsante destro del mouse sul nodo Oggetti Criteri di gruppo Starter e quindi scegliere Incolla.

  4. Fare clic su OK.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Eliminare un oggetto Criteri di gruppo Starter

Eliminare un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo Starter che si desidera eliminare e quindi scegliere Elimina.

  3. Fare clic su Ok per confermare l'eliminazione.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Creare un nuovo un oggetto Criteri di gruppo da un oggetto Criteri di gruppo Starter

Esistono due modi per creare un nuovo un oggetto Criteri di gruppo a partire da un oggetto Criteri di gruppo Starter. È possibile eseguire l'operazione nel nodo Oggetti Criteri di gruppo Starter oppure nel nodo Oggetti Criteri di gruppo.

Creare un nuovo un oggetto Criteri di gruppo da un oggetto Criteri di gruppo Starter nel nodo Oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo Starter che si desidera utilizzare per creare un nuovo oggetto Criteri di gruppo e quindi scegliere Nuovo oggetto Criteri di gruppo dall'oggetto Criteri di gruppo Starter.

  3. Nella finestra di dialogo Nuovo oggetto Criteri di gruppo immettere il nome del nuovo oggetto Criteri di gruppo nella casella Nome.

  4. Fare clic su OK.

Creare un nuovo un oggetto Criteri di gruppo da un oggetto Criteri di gruppo Starter nel nodo Oggetti Criteri di gruppo

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sul nodo Oggetti Criteri di gruppo.

  2. Nella finestra di dialogo Nuovo oggetto Criteri di gruppo digitare il nome del nuovo oggetto Criteri di gruppo nella casella Nome.

  3. Selezionare nell'elenco Oggetto Criteri di gruppo Starter di origine l'oggetto Criteri di gruppo Starter che si desidera utilizzare per creare un nuovo oggetto Criteri di gruppo.

  4. Fare clic su OK.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Eseguire il backup e il ripristino di un oggetto Criteri di gruppo Starter

Eseguire il backup di un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Per eseguire il backup di un singolo oggetto Criteri di gruppo Starter, fare clic con il pulsante destro del mouse sull'oggetto e quindi scegliere Backup. Per eseguire il backup di tutti gli oggetti Criteri di gruppo Starter presenti nel dominio, fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo Starter e quindi scegliere Esegui backup di tutto.

  3. Nella casella Percorso della finestra di dialogo Backup oggetto Criteri di gruppo Starter immettere il percorso in cui si desidera archiviare i backup dell'oggetto Criteri di gruppo Starter. In alternativa, fare clic su Sfoglia, individuare la cartella in cui si desidera archiviare i backup dell'oggetto Criteri di gruppo Starter e quindi fare clic su OK.

  4. Nella casella Descrizione digitare una descrizione per gli oggetti Criteri di gruppo Starter di cui si desidera eseguire il backup e quindi fare clic su Backup. Se si esegue il backup di più oggetti Criteri di gruppo Starter, la descrizione verrà applicata a tutte le copie di backup.

  5. Al termine dell'operazione, fare clic su OK.

    Importante

    Per proteggere gli oggetti Criteri di gruppo Starter di cui è stato eseguito il backup, assicurarsi che solo gli amministratori autorizzati possano accedere alla cartella in cui verranno salvati i backup.
Ripristinare un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo Starter e quindi scegliere Gestione backup.

  3. Nella casella Percorso backup della finestra di dialogo Gestione backup digitare il percorso della cartella di backup. È inoltre possibile utilizzare il pulsante Sfoglia per individuare la cartella di backup.

  4. Nella casella Oggetti Criteri di gruppo Starter sottoposti a backup selezionare l'oggetto Criteri di gruppo Starter che si desidera ripristinare nell'elenco contenente le copie di backup disponibili e quindi fare clic su Ripristina.

  5. Quando viene richiesto di confermare l'operazione di ripristino, fare clic su OK.

  6. Al termine dell'operazione, fare clic su OK e quindi su Chiudi.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Visualizzare, stampare e salvare un rapporto contenente le impostazioni di un oggetto Criteri di gruppo Starter

Per visualizzare, stampare e salvare un rapporto contenente le impostazioni di un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic sull'oggetto Criteri di gruppo Starter di cui si desidera visualizzare le impostazioni.

  3. Fare clic sulla scheda Impostazioni per visualizzare i rapporti in Console Gestione Criteri di gruppo.

  4. Se si desidera stampare o salvare il rapporto, fare clic con il pulsante destro del mouse sul rapporto sulle impostazione nel riquadro risultati e quindi eseguire una delle operazioni seguenti:

    • Scegliere Stampa per stampare il rapporto.

    • Scegliere Salva rapporto per salvare il rapporto.

      Nota

      Per personalizzare le informazioni visualizzate o stampate in un rapporto, fare clic su Mostra o Nascondi.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Importare ed esportare oggetti Criteri di gruppo Starter

La funzionalità di importazione ed esportazione degli oggetti Criteri di gruppo Starter consente di condividere in modo estremamente semplice oggetti Criteri di gruppo Starter con altri ambienti.

Importare un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Fare clic sul nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic su Carica file CAB e quindi su Cerca file CAB.

  3. Utilizzare la finestra di dialogo Carica oggetto Criteri di gruppo Starter per individuare il file CAB oggetto Criteri di gruppo Starter da caricare. Fare clic sul nome del file e quindi su Apri.

  4. Fare clic su OK per completare l'importazione.

Esportare un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Fare clic sul nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic su Salva come file CAB.

  3. Nella finestra di dialogo Salva oggetto Criteri di gruppo Starter come file CAB digitare il nome del file nella casella Nome file. Se si desidera modificare il percorso di salvataggio del file CAB, fare clic su Sfoglia cartelle.

  4. Fare clic su Salva.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Aggiungere commenti a un oggetto Criteri di gruppo Starter

È possibile includere commenti per ogni oggetto Criteri di gruppo Starter. Questa casella di testo può essere utilizzata per documentare l'utilizzo progettato per l'oggetto Criteri di gruppo Starter, oppure il nome dell'ultimo utente che ha aggiornato l'oggetto. L'aggiunta di commenti agli oggetti Criteri di gruppo Starter consentirà in seguito di utilizzare filtri in base a parole chiave per trovare rapidamente gli oggetti Criteri di gruppo Starter corrispondenti alle parole chiave.

Aggiungere un commento a un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo Starter al quale si desidera aggiungere commenti e quindi scegliere Modifica.

  3. Nell'albero della console fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo Starter e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Commento.

  5. Digitare i commenti nella casella Commenti.

  6. Fare clic su OK.

Ulteriori considerazioni

  • Gli oggetti Criteri di gruppo Starter di sistema sono di sola lettura. Per ulteriori informazioni, vedere Oggetti Criteri di gruppo Starter di sistema.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Oggetti Criteri di gruppo Starter di sistema

Gli oggetti Criteri di gruppo Starter di sistema sono oggetti Criteri di gruppo Starter di sola lettura che forniscono impostazioni di base per uno scenario specifico. Analogamente agli oggetti Criteri di gruppo Starter, derivano da un oggetto Criteri di gruppo, consentono di archiviare in un singolo oggetto un insieme di impostazioni relative ai criteri dei modelli amministrativi e possono essere importati. È possibile determinare se un oggetto Criteri di gruppo Starter sia un oggetto Criteri di gruppo Starter di sistema controllando l'opzione Tipo oggetto Criteri di gruppo Starter nella scheda Dettagli dell'oggetto Criteri di gruppo Starter.

In Windows Server® 2008 R2 è inclusa un'ampia gamma di oggetti Criteri di gruppo Starter di sistema. Per informazioni sull'utilizzo consigliato di ogni oggetto Criteri di gruppo Starter di sistema, vedere la sezione Commento nella scheda Dettagli per l'oggetto Criteri di gruppo Starter specifico.

Ulteriori riferimenti

Utilizzare oggetti Criteri di gruppo Starter


Impostare domini, foreste e siti

  • Aggiungere un dominio

  • Specificare un controller di dominio

  • Aggiungere una foresta

  • Aggiungere un sito

Ulteriori riferimenti

Iniziare a utilizzare Console Gestione Criteri di gruppo


Aggiungere un dominio

Al termine di questa procedura, è possibile visualizzare e gestire un dominio Active Directory esistente tramite Console Gestione Criteri di gruppo.

Per aggiungere un dominio in Console Gestione Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta in cui si desidera aggiungere il dominio, fare clic con il pulsante destro del mouse su Domini e quindi scegliere Mostra domini.

  2. Nella finestra di dialogo Mostra domini selezionare la casella di controllo visualizzata accanto a ogni dominio che si desidera aggiungere al Console Gestione Criteri di gruppo e quindi fare clic su OK.

Ulteriori considerazioni

  • L'aggiunta di un dominio a Console Gestione Criteri di gruppo non comporta la creazione di un nuovo dominio in Active Directory.

  • I domini vengono sempre visualizzati come peer uno dell'altro, indipendentemente dalle relazioni effettive.

  • Per aggiungere domini trusted esterni, è possibile utilizzare la funzione Aggiungi foresta.

Ulteriori riferimenti

  • Impostare domini, foreste e siti

  • Aggiungere una foresta


Specificare un controller di dominio

Per specificare un controller di dominio

  1. Nell'albero di Console Gestione Criteri di gruppo eseguire una delle operazioni seguenti:

    • Se si desidera specificare il controller di dominio per un dominio, fare doppio clic sulla foresta contenente tale dominio, fare doppio clic su Domini, fare clic con il pulsante destro del mouse sul dominio di interesse e quindi scegliere Cambia controller di dominio.

    • Se si desidera specificare il controller di dominio per un sito, fare doppio clic sulla foresta contenente i siti di interesse, fare clic con il pulsante destro del mouse su Siti e quindi scegliere Cambia controller di dominio. Nell'elenco a discesa Specificare il dominio in cui eseguire la ricerca della finestra di dialogo Cambia controller di dominio selezionare il dominio in cui risiede il controller di dominio.

  2. Selezionare l'opzione del controller di dominio nella finestra di dialogo Cambia controller di dominio e fare clic su OK.

Ulteriori considerazioni

  • Per tutte le operazioni eseguite negli oggetti Criteri di gruppo, nei gruppi di sicurezza e nelle unità organizzative di un dominio verrà utilizzato il controller di dominio specificato per tale dominio.

  • Per tutte le operazioni eseguite nei collegamenti ai siti verrà utilizzato il controller di dominio specificato per tali siti.

Ulteriori riferimenti

  • Impostare domini, foreste e siti


Aggiungere una foresta

Per aggiungere una foresta

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su Gestione Criteri di gruppo e quindi scegliere Aggiungi foresta.

  2. Nella finestra di dialogo Aggiungi foresta digitare il nome DNS o NetBIOS di un dominio incluso nella foresta e quindi fare clic su OK.

Per il nome del dominio incluso nella foresta è possibile utilizzare il formato DNS o NetBIOS. Se si specifica un nome NetBIOS, è necessario verificare che corrisponda al nome DNS del dominio.

Ulteriori considerazioni

  • L'aggiunta di una foresta in Console Gestione Criteri di gruppo non comporta la creazione di una nuova foresta in Active Directory.

  • Gli oggetti Criteri di gruppo non possono essere collegati esternamente alla foresta.

  • Console Gestione Criteri di gruppo consente la gestione di più foreste direttamente dalla console se è presente un trust tra la foresta di destinazione e quella dell'oggetto utente.

  • È possibile utilizzare la funzione Aggiungi foresta per aggiungere domini trusted esterni, anche se non si dispone di un trust tra foreste con l'intera foresta. È tuttavia necessario disporre di trust tra il dominio che si desidera aggiungere e quello dell'oggetto utente.

Ulteriori riferimenti

  • Impostare domini, foreste e siti


Aggiungere un sito

Per aggiungere un sito

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta in cui si desidera aggiungere il sito, fare clic con il pulsante destro del mouse su Siti e quindi scegliere Mostra siti.

  2. Nella finestra di dialogo Mostra siti selezionare la casella di controllo accanto a ogni sito che si desidera visualizzare nell'albero della console e quindi fare clic su OK.

Ulteriori considerazioni

  • I siti vengono visualizzati nell'albero della console solo se vengono aggiunti esplicitamente.

Ulteriori riferimenti

  • Impostare domini, foreste e siti


Visualizzare, stampare e salvare un rapporto contenente le impostazioni di un oggetto Criteri di gruppo

Per visualizzare, stampare e salvare un rapporto contenente le impostazioni di un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta contenente il dominio o l'unità organizzativa in cui è incluso l'oggetto Criteri di gruppo che si desidera utilizzare e quindi selezionare tale oggetto.

  2. Fare clic sulla scheda Impostazioni per visualizzare i rapporti in Console Gestione Criteri di gruppo.

  3. Se si desidera stampare o salvare il rapporto, fare clic con il pulsante destro del mouse sul rapporto nel riquadro risultati e quindi eseguire una delle operazioni seguenti:

    • Scegliere Stampa per stampare il rapporto.

    • Scegliere Salva rapporto per salvare il rapporto.

      Nota

      Per personalizzare le informazioni visualizzate o stampate in un rapporto, fare clic su Mostra o Nascondi.

Ulteriori considerazioni

  • Per visualizzare la descrizione di un'impostazione inclusa in Modelli amministrativi, fare clic sul nome dell'impostazione nel rapporto.

  • In Console Gestione Criteri di gruppo non è possibile utilizzare la tastiera per spostarsi all'interno di un rapporto HTML. Per spostarsi all'interno del rapporto HTML, salvarlo su file e quindi utilizzare Microsoft Internet Explorer per visualizzarlo.

Ulteriori riferimenti

  • Iniziare a utilizzare Console Gestione Criteri di gruppo


Modificare, filtrare e commentare le impostazioni dei criteri

  • Impostazioni dei criteri di Modelli amministrativi

  • Modelli amministrativi classici

  • Modificare le impostazioni software

  • Utilizzare script di avvio, arresto, accesso e disconnessione

  • Utilizzare il reindirizzamento cartelle


Impostazioni dei criteri di Modelli amministrativi

I Modelli amministrativi sono impostazioni dei criteri basate sul Registro di sistema, visualizzate nel nodo Modelli amministrativi dei nodi Configurazione computer e Configurazione utente. Questa gerarchia viene creata quando Console Gestione Criteri di gruppo legge i file dei modelli amministrativi basati su XML (con estensione admx).

In questa sezione vengono descritti gli argomenti seguenti:

  • Modificare le impostazioni dei criteri di Modelli amministrativi

  • Filtrare le impostazioni dei criteri di Modelli amministrativi

  • Aggiungere commenti alle impostazioni dei criteri di Modelli amministrativi


Modificare le impostazioni dei criteri di Modelli amministrativi

Per modificare le impostazioni dei criteri dei modelli amministrativi

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Nell'albero della console fare clic sulla cartella in Modelli amministrativi contenente le impostazioni dei criteri che si desidera configurare.

  3. Nella colonna Impostazione fare clic sul nome di un'impostazione dei criteri per visualizzare la relativa descrizione.

  4. Per modificare un'impostazione dei criteri, fare doppio clic sul nome dell'impostazione.

  5. Nella finestra di dialogo delle impostazioni del criterio fare clic su una delle opzioni seguenti:

    • Non configurata: il Registro di sistema non verrà modificato.

    • Attivata: nel Registro di sistema verrà indicato che l'impostazione dei criteri è selezionata.

    • Disattivata: nel Registro di sistema verrà indicato che l'impostazione dei criteri non è selezionata.

  6. Selezionare tutte le altre opzioni e quindi fare clic su OK.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Le impostazioni per HKEY_LOCAL_MACHINE si trovano in Configurazione computer, mentre le impostazioni per HKEY_CURRENT_USER si trovano in Configurazione utente.

  • In caso di conflitti, in genere i criteri del computer hanno priorità rispetto a quelli dell'utente. Se gli autori delle applicazioni ignorano questa convenzione, tuttavia, gli oggetti Criteri di gruppo non potranno applicarla.

  • Le impostazioni dei criteri di Modelli amministrativi sono anche note come impostazioni dei criteri basate sul Registro di sistema.


Filtrare le impostazioni dei criteri di Modelli amministrativi

Console Gestione Criteri di gruppo consente di filtrare le impostazioni dei criteri di Modelli amministrativi in base a:

  • Impostazioni dei criteri Gestite, Configurate o Con commento.

  • Parole chiave all'interno del titolo, testo della Guida o commento delle impostazioni dei criteri.

  • Requisito per la piattaforma o l'applicazione delle impostazioni dei criteri.

Applicare filtri alle impostazioni dei criteri di Modelli amministrativi quando si desidera individuare una specifica impostazione dei criteri, oppure si desidera limitare il numero di impostazioni dei criteri visualizzate in Console Gestione Criteri di gruppo.

In questa sezione vengono descritti gli argomenti seguenti:

  • Applicare filtri di proprietà

  • Applicare filtri in base a parole chiave

  • Applicare filtri in base ai requisiti


Applicare filtri di proprietà

Console Gestione Criteri di gruppo consente di modificare i criteri per la visualizzazione delle impostazioni dei criteri di Modelli amministrativi. Per impostazione predefinita, nell'editor vengono visualizzate tutte le impostazioni dei criteri, comprese quelle non gestite. È tuttavia possibile modificare le modalità di visualizzazione delle impostazioni dei criteri di Modelli amministrativi in Console Gestione Criteri di gruppo mediante l'utilizzo di filtri di proprietà.

Per filtrare i Modelli amministrativi sono disponibili i tre filtri di proprietà seguenti:

  • Gestite

  • Configurate

  • Con commento

Gestite

Le impostazioni dei criteri di Modelli amministrativi possono essere di due tipi: Gestite e Non gestite. Il servizio Criteri di gruppo governa le impostazioni dei criteri Gestite e rimuove le impostazioni dei criteri che non si trovano più nell'ambito dell'utente o del computer.

Il servizio Criteri di gruppo non governa le impostazioni dei criteri non gestite, che sono permanenti, né le rimuove, anche se non si trovano nell'ambito dell'utente o del computer. Le impostazioni dei criteri di questo tipo vengono in genere utilizzate per impostare le preferenze relative a componenti del sistema operativo non abilitati per l'utilizzo di criteri. È inoltre possibile utilizzare le impostazioni dei criteri non gestite per le impostazioni relative alle applicazioni.

Il filtro della proprietà Gestite dispone di tre stati: Qualsiasi, Sì e No. Impostando questo filtro di proprietà su Qualsiasi, in Console Gestione Criteri di gruppo verranno visualizzate tutte le impostazioni dei criteri di Modelli amministrativi. Impostandolo su Sì, nell'editor verranno visualizzate solo le impostazioni dei criteri di Modelli amministrativi gestite e verranno nascoste tutte quelle non gestite. Impostandolo su No, nell'editor verranno visualizzate solo le impostazioni dei criteri di Modelli amministrativi non gestite e verranno nascoste tutte quelle gestite.

Per impostare il filtro della proprietà Gestite in Modelli amministrativi

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Fare clic con il pulsante destro del mouse su Modelli amministrativi in Configurazione computer\Criteri o Configurazione utente\Criteri. Fare clic su Opzioni filtro.

  3. Nell'elenco Gestite fare clic sul filtro appropriato.

  4. Fare clic su OK per applicare le nuove impostazioni del filtro e chiudere la finestra di dialogo Opzioni filtro.

Configurate

È possibile configurare le impostazioni dei criteri di Modelli amministrativi su tre stati: Non configurata, Attivata e Disattivata. Non configurata è lo stato predefinito di tutte le impostazioni dei criteri. Le impostazioni dei criteri impostate su Non configurata non hanno effetto su utenti o computer. Attivando un'impostazione dei criteri di Modelli amministrativi, l'impostazione viene abilitata. Se è Attivata, all'utente o al computer viene applicata l'azione descritta nel titolo dell'impostazione del criterio. Se è Disattivata, all'utente o al computer viene applicata l'azione opposta a quella descritta nel titolo dell'impostazione del criterio. In genere le impostazioni dei criteri con stato Non configurata e Disattivata producono gli stessi risultati. La differenza sta nel fatto che le impostazioni dei criteri con stato Non configurata non vengono applicate all'utente, mentre quelle con stato Disattivata vengono applicate a un utente.

Per tutte le impostazioni dei criteri di Modelli amministrativi sono disponibili informazioni dettagliate relative agli stati Attivata, Disattivata e Non configurata. È possibile visualizzare tali informazioni nella scheda Guida di tutte le impostazioni dei criteri dei Modelli amministrativi. In alternativa, è possibile visualizzare queste informazioni per l'impostazione dei criteri selezionata nella visualizzazione estesa dell'editor.

Il filtro della proprietà Configurate dispone di tre stati: Qualsiasi, Sì e No. Impostando questo filtro di proprietà su Qualsiasi, in Console Gestione Criteri di gruppo verranno visualizzate tutte le impostazioni dei criteri di Modelli amministrativi. Si tratta dell'impostazione predefinita del filtro. Impostandolo su Sì, nell'editor verranno visualizzate solo le impostazioni dei criteri di Modelli amministrativi configurate e verranno nascoste tutte quelle non configurate. Impostandolo su Sì, nell'editor verranno visualizzate solo le impostazioni dei criteri di Modelli amministrativi non configurate e verranno nascoste tutte quelle configurate.

Per impostare il filtro della proprietà Configurate in Modelli amministrativi

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Fare clic con il pulsante destro del mouse su Modelli amministrativi in Configurazione computer\Criteri o Configurazione utente\Criteri. Scegliere Opzioni filtro.

  3. Nell'elenco Configurate fare clic sul filtro appropriato.

  4. Fare clic su OK per applicare le nuove impostazioni del filtro e chiudere la finestra di dialogo Opzioni filtro.

Con commento

Tutte le impostazioni dei criteri di Modelli amministrativi dispongono di una proprietà di commento. La proprietà Con commento consente l'inserimento di testo associato a una specifica impostazione dei criteri.

Il filtro della proprietà Con commento dispone di tre stati: Qualsiasi, Sì e No. Impostando questo filtro di proprietà su Qualsiasi, in Editor Gestione Criteri di gruppo verranno visualizzate tutte le impostazioni dei criteri di Modelli amministrativi. Si tratta dell'impostazione predefinita del filtro. Impostandolo su Sì, nell'editor verranno visualizzate solo le impostazioni dei criteri di Modelli amministrativi con commenti e verranno nascoste tutte quelle senza commenti. Impostandolo su Sì, nell'editor verranno visualizzate solo le impostazioni dei criteri di Modelli amministrativi senza commenti e verranno nascoste tutte quelle con commenti.

Per impostare il filtro della proprietà Con commenti in Modelli amministrativi

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Fare clic con il pulsante destro del mouse su Modelli amministrativi in Configurazione computer\Criteri o Configurazione utente\Criteri. Scegliere Opzioni filtro.

  3. Nell'elenco Con commenti fare clic sul filtro appropriato.

  4. Fare clic su OK per applicare le nuove impostazioni del filtro e chiudere la finestra di dialogo Opzioni filtro.

Ulteriori considerazioni

  • Poiché i filtri sono inclusivi, selezionare gli elementi che si desidera visualizzare invece degli elementi che si desidera rimuovere.

  • I filtri non funzionano con i Modelli amministrativi classici.


Applicare filtri in base a parole chiave

Console Gestione Criteri di gruppo consente di modificare i criteri per la visualizzazione delle impostazioni dei criteri di Modelli amministrativi. Per impostazione predefinita, nell'editor vengono visualizzate tutte le impostazioni dei criteri, incluse le impostazioni delle preferenze (note in precedenza come impostazioni di criteri non gestite). È tuttavia possibile modificare le modalità di visualizzazione delle impostazioni dei criteri di Modelli amministrativi in Console Gestione Criteri di gruppo mediante l'utilizzo di filtri in base a parole chiave.

Per impostare il filtro in base a parole chiave dei modelli amministrativi

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Fare clic con il pulsante destro del mouse su Modelli amministrativi in Configurazione computer o Configurazione utente. Fare clic su Opzioni filtro.

  3. Selezionare la casella di controllo Abilita filtri in base a parole chiave.

  4. Digitare una o più parole chiave nella casella Filtra in base alla/e parola/e.

  5. Nell'elenco Criteri di ricerca fare clic sul filtro appropriato.

    • Qualsiasi parola: il filtro include qualsiasi parola digitata nella casella Filtra in base alla/e parola/e.

    • Tutte le parole: il filtro include tutte le parole digitate nella casella Filtra in base alla/e parola/e.

    • Corrispondenza esatta: il filtro include le corrispondenze esatte delle parole digitate nella casella Filtra in base alla/e parola/e.

  6. Selezionare le caselle di controllo appropriate accanto a In.

    • Titolo impostazione criterio: il filtro include la ricerca nel titolo dell'impostazione del criterio.

    • Testo di istruzioni: il filtro include la ricerca nel testo della Guida dell'impostazione del criterio.

    • Commento: il filtro include la ricerca nel commento dell'impostazione del criterio.

  7. Fare clic su OK per applicare le nuove impostazioni del filtro e chiudere la finestra di dialogo Opzioni filtro.

Ulteriori considerazioni

  • Poiché i filtri sono inclusivi, selezionare gli elementi che si desidera visualizzare invece degli elementi che si desidera rimuovere.

  • I filtri non funzionano con i Modelli amministrativi classici.


Applicare filtri in base ai requisiti

Console Gestione Criteri di gruppo consente di modificare i criteri per la visualizzazione delle impostazioni dei criteri di Modelli amministrativi. Per impostazione predefinita, nell'editor vengono visualizzate tutte le impostazioni dei criteri, incluse le impostazioni delle preferenze (note in precedenza come impostazioni di criteri non gestite). È tuttavia possibile modificare le modalità di visualizzazione delle impostazioni dei criteri di Modelli amministrativi in Console Gestione Criteri di gruppo mediante l'utilizzo di filtri in base ai requisiti.

Per impostare il filtro in base ai requisiti dei Modelli amministrativi

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Fare clic con il pulsante destro del mouse su Modelli amministrativi in Configurazione computer o Configurazione utente. Fare clic su Opzioni filtro.

  3. Selezionare la casella di controllo Abilita filtri in base ai requisiti.

  4. Digitare una o più parole chiave nella casella Filtra in base alla/e parola/e.

  5. Nell'elenco Selezionare il filtro o i filtri desiderati per la piattaforma e l'applicazione fare clic sul filtro appropriato:

    • Includi impostazioni che corrispondono a una qualsiasi delle piattaforme selezionate.

    • Includi impostazioni che corrispondono a tutte le piattaforme selezionate.

      Nota

      È possibile fare clic su Seleziona tutto per selezionare tutti gli elementi dell'elenco, oppure su Deseleziona tutto per deselezionarli.

  6. Fare clic su OK per applicare le nuove impostazioni del filtro e chiudere la finestra di dialogo Opzioni filtro.

Ulteriori considerazioni

  • Poiché i filtri sono inclusivi, selezionare gli elementi che si desidera visualizzare invece degli elementi che si desidera rimuovere.

  • I filtri non funzionano con i Modelli amministrativi classici.


Aggiungere commenti alle impostazioni dei criteri di Modelli amministrativi

È possibile includere commenti in tutte le impostazioni dei criteri per i modelli amministrativi. Questo spazio può essere utilizzato per documentare ulteriormente l'impostazione dei criteri e il motivo per cui la relativa implementazione è importante per l'ambiente di utilizzo. L'aggiunta di commenti consentirà in seguito di utilizzare filtri in base a parole chiave per trovare rapidamente le impostazioni dei criteri corrispondenti alle parole chiave.

Per aggiungere commenti a un'impostazione dei criteri per i modelli amministrativi

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Nell'albero della console fare clic sulla cartella in Modelli amministrativi contenente le impostazioni dei criteri che si desidera configurare.

  3. Nella colonna Impostazione fare doppio clic sul nome dell'impostazione dei criteri.

  4. Digitare i commenti nella casella Commenti.

  5. Fare clic su OK.


Modelli amministrativi classici

I file dei modelli amministrativi classici, noti anche come file ADM, non utilizzano un formato XML. Nelle versioni precedenti dello strumento Gestione criteri di gruppo (precedentemente denominato Editor oggetti Criteri di gruppo), queste impostazioni vengono visualizzate nel nodo Modelli amministrativi.

La versione corrente dei file dei modelli amministrativi (noti come file ADMX) utilizza il formato XML. Console Gestione Criteri di gruppo visualizza queste impostazioni nel nodo Modelli amministrativi. Console Gestione Criteri di gruppo tuttavia, riconosce ancora i file ADM e visualizza tali impostazioni nel nodo Modelli amministrativi classici, che è un nodo figlio di Modelli amministrativi.

In questa sezione sono inclusi gli argomenti seguenti:

Aggiungere o rimuovere modelli amministrativi classici

Applicare filtri ai modelli amministrativi classici


Aggiungere o rimuovere modelli amministrativi classici

Per aggiungere o rimuovere Modelli amministrativi classici (file con estensione adm)

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente, fare clic con il pulsante destro del mouse su Modelli amministrativi.

  3. Scegliere Aggiunta/Rimozione modelli.

  4. Eseguire una delle operazioni seguenti:

    • Per aggiungere un modello, fare clic su Aggiungi. Nella finestra di dialogo Modelli criteri fare clic sul modello che si desidera aggiungere e quindi su Apri.

    • Per rimuovere un modello, nell'elenco Modelli criteri correnti fare clic sul modello desiderato e quindi su Rimuovi.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.


Applicare filtri ai modelli amministrativi classici

In Console Gestione Criteri di gruppo le impostazioni dei criteri per i modelli amministrativi classici vengono visualizzate nel nodo Modelli amministrativi classici, una sottocartella di Modelli amministrativi. La visualizzazione include sia le impostazioni dei criteri gestite che le impostazioni relative alle preferenze incluse in tutti i modelli amministrativi classici (noti anche come file ADM). Le opzioni di filtro incluse in Console Gestione Criteri di gruppo si applicano solo ai modelli amministrativi (file ADMX) e non ai modelli amministrativi classici.


Modificare le impostazioni software

Criteri di gruppo Installazione software consente di implementare l'installazione di software su richiesta e il ripristino automatico delle applicazioni. Con l'utilizzo di Criteri di gruppo la distribuzione del software risulta estremamente semplice, in particolare se si utilizza già Criteri di gruppo per altri scopi, ad esempio per la sicurezza dei computer client e server.

In questa sezione vengono descritti gli argomenti seguenti:

  • Aprire Criteri di gruppo Installazione software

  • Impostare le opzioni per Criteri di gruppo Installazione software

  • Utilizzare applicazioni

  • Impostare le proprietà delle applicazioni

  • Aggiungere o rimuovere modifiche per un pacchetto applicazioni


Aprire Criteri di gruppo Installazione software

Per aprire Criteri di gruppo Installazione software

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Per assegnare applicazioni software a computer, nell'albero della console espandere Configurazione computer\Criteri. Per pubblicare o assegnare applicazioni software a utenti, nell'albero della console espandere Configurazione utente\Criteri.

  3. Espandere Impostazioni del software e quindi fare clic su Installazione software.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.


Impostare le opzioni per Criteri di gruppo Installazione software

In questa sezione sono inclusi gli argomenti seguenti:

  • Configurare le impostazioni predefinite di Criteri di gruppo Installazione software

  • Specificare opzioni di installazione automatica in base all'estensione di file

  • Specificare le categorie per la gestione delle applicazioni


Configurare le impostazioni predefinite di Criteri di gruppo Installazione software

Per aggiungere pacchetti di installazione software alle impostazioni dell'utente, è possibile pubblicarli o assegnarli. I pacchetti pubblicati possono essere installati dagli utenti dell'unità organizzativa, del sito o del dominio selezionato tramite Installazione applicazioni nel Pannello di controllo o l'attivazione del file. I pacchetti assegnati vengono ricevuti dagli utenti dell'unità organizzativa, del sito o del dominio selezionato al successivo accesso, in caso di assegnazione a utenti, o al successivo riavvio del computer, in caso di assegnazione a computer.

Per configurare le impostazioni predefinite di Criteri di gruppo Installazione software

  1. Aprire Criteri di gruppo Installazione software. Nell'albero della console fare clic con il pulsante destro del mouse su Installazione software.

  2. Scegliere Proprietà e nella scheda Generale specificare le opzioni seguenti:

    • In Posizione predefinita pacchetti specificare il punto di distribuzione software predefinito.

    • In Nuovi pacchetti specificare la modalità di aggiunta dei nuovi pacchetti alle impostazioni dell'utente. Per impostazione predefinita, i pacchetti possono essere pubblicati o assegnati. Nel caso dei computer è possibile solo assegnarli. Se si desidera selezionare queste opzioni per ogni pacchetto, fare clic su Mostra la finestra di dialogo Distribuisci applicazione. Per un maggiore controllo sulle impostazioni dei singoli pacchetti, fare clic su Avanzate.

    • In Opzioni interfaccia utente dell'installazione fare clic su Minima o Completa in base alle informazioni che si desidera rendere visibili agli utenti durante il processo di installazione.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.


Specificare opzioni di installazione automatica in base all'estensione di file

Per specificare le opzioni di installazione automatica basate sull'estensione di file

  1. Aprire Criteri di gruppo Installazione software. Nell'albero della console fare clic con il pulsante destro del mouse su Installazione software.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Installazione software.

  3. Scegliere Proprietà e quindi fare clic sulla scheda Estensioni file.

  4. Nella scheda Estensioni file specificare le opzioni seguenti:

    • Selezionare l'estensione del file: visualizza l'elenco di tutte le estensioni di file disponibili per il software gestito. Quando si seleziona un'estensione, tutte le applicazioni in Active Directory associate all'estensione di file selezionata vengono visualizzate nella casella di riepilogo Precedenza applicazione. È ad esempio possibile che all'estensione di file htm siano associate varie applicazioni, tra cui Microsoft Word, Microsoft Internet Explorer e Netscape Communicator.

    • Precedenza applicazione: visualizza l'elenco di tutte le applicazioni associate all'estensione di file selezionata. È possibile determinare la precedenza utilizzando i pulsanti Su e Giù per impostare l'ordine delle applicazioni.

    • Su: sposta l'applicazione selezionata di una posizione verso l'alto nell'elenco delle precedenze. L'applicazione posizionata in cima all'elenco verrà installata automaticamente se si richiama un documento con l'estensione di file selezionata prima che l'applicazione sia stata installata. Il pulsante Su non è disponibile quando l'applicazione selezionata si trova in cima all'elenco delle precedenze.

    • Giù: sposta l'applicazione selezionata di una posizione verso il basso nell'elenco delle precedenze. Il pulsante Giù non è disponibile quando l'applicazione selezionata si trova in fondo all'elenco delle precedenze.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Quando si aggiorna un'applicazione, disattivare l'installazione automatica per la versione precedente.


Specificare le categorie per la gestione delle applicazioni

Per specificare le categorie per la gestione delle applicazioni

  1. Aprire Criteri di gruppo Installazione software.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Installazione software.

  3. Scegliere Proprietà e quindi fare clic sulla scheda Categorie.

  4. Per creare o modificare l'elenco delle categorie in base a cui vengono raggruppati i programmi in Installazione applicazioni nel Pannello di controllo, eseguire una o più delle operazioni seguenti:

    • Per creare una nuova categoria, fare clic su Aggiungi e quindi digitare il nome della nuova categoria. Se non si dispone dell'autorizzazione per l'aggiunta di categorie, il pulsante Aggiungi non risulta disponibile.

    • Per modificare una categoria esistente, selezionare la categoria desiderata, fare clic su Modifica e quindi modificare il testo della categoria selezionata. Se non si dispone dell'autorizzazione per la modifica di categorie, il pulsante Modifica non risulta disponibile.

    • Per rimuovere una categoria dall'elenco Categorie, selezionare il relativo nome e quindi fare clic su Rimuovi. Se non si dispone dell'autorizzazione per la modifica di categorie, il pulsante Rimuovi non risulta disponibile.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Le modifiche apportate alle categorie delle applicazioni verranno applicate all'intero dominio in cui è archiviato l'oggetto Criteri di gruppo.


Utilizzare applicazioni

In questa sezione sono inclusi gli argomenti seguenti:

  • Assegnare un'applicazione

  • Pubblicare un'applicazione

  • Aggiornare un'applicazione

  • Rimuovere un'applicazione gestita

Per ulteriori informazioni su Criteri di gruppo Installazione software, vedere Installare Console Gestione Criteri di gruppo.


Assegnare un'applicazione

Per assegnare un'applicazione

  1. Aprire Criteri di gruppo Installazione software.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Installazione software, scegliere Nuovo e quindi fare clic su Pacchetto.

  3. Nella finestra di dialogo Apri utilizzare le caselle di ricerca per individuare l'applicazione che si desidera distribuire, fare clic sul pacchetto di Windows Installer e quindi su Apri.

  4. Nella finestra di dialogo Distribuisci applicazione fare clic su Assegnata e quindi su OK.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Nella finestra di dialogo Apri vengono visualizzati i pacchetti disponibili nel punto di distribuzione software impostato come predefinito.

  • Se il pacchetto di Windows Installer si trova in una directory di rete condivisa diversa, passare al punto di distribuzione software corretto nella finestra di dialogo Apri, fare clic sul pacchetto e quindi su Apri.

  • È responsabilità degli amministratori proteggere tale percorso mediante tecnologie come IPSEC e mediante l'utilizzo di file server con autenticazione reciproca, ad esempio Kerberos, al fine di evitare attacchi di tipo spoofing o alterazioni durante il trasferimento dei file.


Pubblicare un'applicazione

Per pubblicare un'applicazione

  1. Aprire Criteri di gruppo Installazione software.

  2. Fare clic con il pulsante destro del mouse nel riquadro dei risultati, scegliere Nuovo e Pacchetto.

  3. Nella finestra di dialogo Apri utilizzare le caselle di ricerca per individuare il pacchetto che si desidera pubblicare, fare clic sul pacchetto di Windows Installer da pubblicare e quindi su Apri.

  4. Nella finestra di dialogo Distribuisci applicazione fare clic su Pubblicata.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • I pacchetti possono essere pubblicati solo per gli utenti e non per i computer.

  • Nella finestra di dialogo Apri vengono visualizzati i pacchetti disponibili nel punto di distribuzione software impostato come predefinito.

  • Se il pacchetto di Windows Installer si trova in una directory di rete condivisa diversa, passare al punto di distribuzione software corretto nella finestra di dialogo Apri, fare clic sul pacchetto e quindi su Apri.

  • È responsabilità degli amministratori proteggere tale percorso mediante tecnologie come IPSEC e mediante l'utilizzo di file server con autenticazione reciproca, ad esempio Kerberos, al fine di evitare attacchi di tipo spoofing o alterazioni durante il trasferimento dei file.

  • Gli utenti potranno installare l'applicazione utilizzando Installazione applicazioni nel Pannello di controllo oppure aprendo un file con l'estensione di file associata all'applicazione.


Aggiornare un'applicazione

Per aggiornare un'applicazione

  1. Aprire Criteri di gruppo Installazione software.

  2. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sul nuovo pacchetto di aggiornamento di Windows Installer, ovvero non il pacchetto da aggiornare.

  3. Scegliere Proprietà e quindi fare clic sulla scheda Aggiornamenti.

  4. Fare clic su Aggiungi per creare un elenco dei pacchetti che si desidera aggiornare con il nuovo pacchetto di aggiornamento oppure per aggiungere un pacchetto all'elenco.

  5. Nella finestra di dialogo Aggiungi pacchetto di aggiornamento, in Scegliere un pacchetto da, eseguire una delle operazioni seguenti:

    • Fare clic su Oggetto Criteri di gruppo corrente.

    • Fare clic su Oggetto Criteri di gruppo specifico, su Sfoglia e quindi sull'oggetto Criteri di gruppo che si desidera aggiornare.

  6. Esaminare l'elenco dei pacchetti in Pacchetto da aggiornare, contenente tutti gli altri pacchetti assegnati o pubblicati all'interno dell'oggetto Criteri di gruppo selezionato.

  7. Fare clic sul pacchetto che si desidera aggiornare e quindi eseguire una delle operazioni seguenti:

    • Per sostituire un'applicazione con una completamente diversa, ad esempio un'applicazione di un altro fornitore, fare clic su Disinstalla il pacchetto esistente, quindi installa il pacchetto di aggiornamento.

    • Per installare una versione più recente dello stesso prodotto mantenendo le preferenze dell'applicazione impostate dall'utente, le associazioni al tipo di documento e così via, fare clic su Aggiorna il pacchetto esistente.

  8. (Facoltativo) Per rendere obbligatorio l'aggiornamento, selezionare la casella di controllo Aggiornamento richiesto per pacchetti esistenti nella scheda Aggiornamenti.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Prima di eseguire questa procedura, è necessario assegnare o pubblicare il pacchetto di aggiornamento.

  • In base all'oggetto Criteri di gruppo, l'elenco dei pacchetti in Pacchetto da aggiornare può essere vuoto oppure può contenere più voci. Se si tratta di un aggiornamento in Configurazione computer nell'albero di Console Criteri di gruppo, la casella di controllo Aggiornamento richiesto per pacchetti esistenti sarà selezionata e non disponibile perché è possibile solo assegnare i pacchetti ai computer, ma non pubblicarli.


Rimuovere un'applicazione gestita

Per rimuovere un'applicazione gestita

  1. Aprire Criteri di gruppo Installazione software.

  2. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sull'applicazione che si desidera rimuovere, scegliere Tutte le attività e quindi Rimuovi.

  3. Nella finestra di dialogo Rimozione software fare clic su uno dei metodi di rimozione seguenti:

    • Per specificare che l'applicazione deve essere rimossa al successivo accesso da parte di un utente o riavvio del computer, fare clic su Disinstalla immediatamente il software per utenti e computer.

    • Per specificare che gli utenti possono continuare a utilizzare l'applicazione se l'hanno già installata, fare clic su Consenti agli utenti di continuare ad utilizzare il software, ma impedisci nuove installazioni. Se l'applicazione è stata rimossa dagli utenti o non è mai stata installata, non sarà possibile installarla.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.


Impostare le proprietà delle applicazioni

In questa sezione sono inclusi gli argomenti seguenti:

  • Modificare le opzioni di installazione delle applicazioni

  • Specificare le categorie delle applicazioni per Installazione applicazioni nel Pannello di controllo

  • Impostare l'opzione di installazione automatica per un'applicazione

  • Impostare le autorizzazioni per Criteri di gruppo Installazione software

Risorse aggiuntive

Modificare le impostazioni software


Modificare le opzioni di installazione delle applicazioni

Per modificare le opzioni di installazione delle applicazioni

  1. Aprire Criteri di gruppo Installazione software.

  2. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sull'applicazione per cui si desidera modificare le opzioni di installazione e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà dell'applicazione fare clic sulla scheda Distribuzione.

  4. Nella scheda Distribuzione fare clic su una delle opzioni seguenti in Tipo di distribuzione:

    • Pubblicata: gli utenti nell'unità organizzativa, nel dominio o nel sito selezionato possono installare l'applicazione tramite Installazione applicazioni nel Pannello di controllo o l'attivazione di file.

    • Assegnata: gli utenti nell'unità organizzativa, nel dominio o nel sito selezionato ricevono l'applicazione al successivo accesso, in caso di assegnazione a utenti, o al riavvio del computer, in caso di assegnazione a computer.

  5. In Opzioni di distribuzione selezionare le caselle di controllo relative alle opzioni desiderate:

    • Installa automaticamente questa applicazione tramite l'attivazione dell'estensione del file: selezionare questa opzione se si desidera utilizzare la precedenza applicazione per l'estensione del file in base a quanto specificato nella scheda Estensioni file della finestra di dialogo delle proprietà di installazione software. Se l'applicazione non è già installata, la selezione di questa opzione provoca l'installazione dell'applicazione quando l'utente apre un file con questa associazione, ad esempio facendo doppio clic sul file.

    • Disinstalla questa applicazione quando non rientra più nell'ambito di gestione: selezionare questa opzione se si desidera che l'applicazione venga rimossa all'accesso degli utenti o al riavvio dei computer, se questi sono stati spostati in un sito, un dominio o un'unità organizzativa per cui l'applicazione non è distribuita.

    • Non mostrare il pacchetto in Installazione applicazioni nel Pannello di controllo: questa opzione consente di rimuovere il metodo di disinstallazione dell'applicazione più ovvio per gli utenti. Questa opzione può essere utile di quando in quando durante il ciclo di vita del software.

    • Installa l'applicazione all'accesso: questa opzione consente di installare l'applicazione utilizzando le impostazioni predefinite del pacchetto. Si noti che tali impostazioni predefinite possono a loro volta comportare l'installazione di tutte le funzionalità o solo di alcune.

  6. In Opzioni interfaccia utente dell'installazione fare clic su una delle opzioni seguenti:

    • Minima: vengono visualizzati solo gli errori e le barre di stato.

    • Completa: viene visualizzata l'intera interfaccia utente supportata dal pacchetto.

  7. Se si desidera impostare le opzioni avanzate seguenti, fare clic su Avanzate:

    • Ignora la lingua per la distribuzione di questo pacchetto: selezionare questa casella di controllo se si desidera installare un'applicazione che utilizza una lingua diversa da quella del sistema operativo.

    • Rimuovi le installazioni precedenti del prodotto per gli utenti, se il prodotto non è stato installato mediante un programma di installazione software basato sui criteri di gruppo: questa opzione può essere utile, ad esempio, se i criteri della società non consentono agli utenti di installare applicazioni da CD personali.

    • Rendi disponibile questa applicazione a 32 bit per piattaforme X86 anche per i computer Win64: specifica se l'applicazione a 32 bit deve essere assegnata o pubblicata a computer a 64 bit.

    • Includi informazioni sulla classe OLE e sul prodotto: specifica se distribuire informazioni sui componenti COM con il pacchetto in modo che il software nel client possa installarli da Active Directory, analogamente all'attivazione in base all'estensione del file.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Nella finestra di dialogo Opzioni avanzate distribuzione, visualizzata quando si fa clic su Avanzate, sono disponibili informazioni avanzate di diagnostica che possono risultare utili per la risoluzione dei problemi. Queste informazioni vengono elencate e descritte nella tabella seguente.

Campo | Dati
Codice prodotto | Identificatore univoco globale (GUID) che rappresenta il prodotto
Conteggio distribuzioni | Numero di distribuzioni del pacchetto in questo oggetto Criteri di gruppo
Nome script | Percorso di rete completo dello script di assegnazione applicazioni, ovvero del file con estensione aas, inclusi i GUID


Specificare le categorie delle applicazioni per Installazione applicazioni nel Pannello di controllo

Per specificare le categorie delle applicazioni per Installazione applicazioni nel Pannello di controllo

  1. Aprire Criteri di gruppo Installazione software.

  2. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sull'applicazione gestita per cui si desidera impostare categorie e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà dell'applicazione fare clic sulla scheda Categorie.

  4. Nella scheda Categorie eseguire una delle operazioni seguenti:

    • Per associare all'applicazione una categoria di applicazioni definita per l'organizzazione, fare clic su una categoria nell'elenco Categorie disponibili e quindi fare clic su Seleziona.

    • Per rimuovere una categoria associata all'applicazione, fare clic su una categoria nell'elenco Categorie selezionate e quindi fare clic su Rimuovi.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Poiché le applicazioni assegnate non vengono visualizzate in Installazione applicazioni nel Pannello di controllo, le categorie impostate in questa finestra di dialogo in genere si riferiscono solo alle applicazioni pubblicate. L'applicazione viene visualizzata nelle categorie selezionate in Installazione applicazioni, che può essere utilizzato dall'utente per installare l'applicazione.

  • Utilizzare questa procedura per associare applicazioni a categorie esistenti e non per creare o rimuovere categorie.


Impostare l'opzione di installazione automatica per un'applicazione

Per impostare l'opzione di installazione automatica per un'applicazione

  1. Aprire Criteri di gruppo Installazione software.

  2. Nell'albero della console fare clic su Installazione software.

  3. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sull'applicazione che si desidera installare automaticamente quando l'utente tenta di aprire un file con l'estensione associata.

  4. Scegliere Proprietà e quindi fare clic sulla scheda Distribuzione.

  5. In Opzioni di distribuzione selezionare la casella di controllo Installa automaticamente questa applicazione tramite l'attivazione dell'estensione del file e quindi fare clic su OK. È consigliabile lasciare attivata questa opzione, che è selezionata per impostazione predefinita.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • L'opzione di installazione automatica verrà applicata solo se non è attualmente installata un'applicazione per l'estensione associata.


Impostare le autorizzazioni per Criteri di gruppo Installazione software

Per impostare le autorizzazioni per Criteri di gruppo Installazione software

  1. Aprire l'oggetto Criteri di gruppo che si desidera modificare.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sull'icona o sul nome dell'oggetto Criteri di gruppo e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Sicurezza e nella casella Utenti e gruppi fare clic sul gruppo di sicurezza per il quale si desidera impostare le autorizzazioni.

  4. Eseguire una delle operazioni seguenti:

    • Per modificare l'insieme di gruppi di sicurezza ai quali sono assegnate le autorizzazioni per l'oggetto Criteri di gruppo, fare clic su Aggiungi o Rimuovi per aggiungere o rimuovere gruppi di sicurezza.

    • Se il gruppo di sicurezza rappresenta amministratori che gestiscono il software per utenti e computer dell'organizzazione, nella casella Autorizzazioni relativa al gruppo di sicurezza selezionare la casella di controllo Consenti per l'autorizzazione Controllo completo e quindi fare clic su OK.

    • Se il gruppo di sicurezza rappresenta utenti che utilizzano il software assegnato o pubblicato da un amministratore, nella casella Autorizzazioni relativa al gruppo di sicurezza selezionare la casella di controllo Consenti per entrambe le autorizzazioni Applica Criteri di gruppo e Lettura e quindi fare clic su OK.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Le autorizzazioni impostate in questa procedura si riferiscono solo all'oggetto Criteri di gruppo. È inoltre necessario che nella rete sia presente una cartella condivisa, ovvero un punto di distribuzione software, contenente i pacchetti da installare. Gli amministratori e gli utenti devono disporre rispettivamente delle autorizzazioni Controllo completo e Lettura per il punto di distribuzione software.


Aggiungere o rimuovere modifiche per un pacchetto applicazioni

Per aggiungere o rimuovere modifiche per un pacchetto applicazioni

  1. Aprire Criteri di gruppo Installazione software.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Installazione software, scegliere Nuovo e quindi fare clic su Pacchetto.

  3. Nella finestra di dialogo Apri fare clic sul pacchetto di Windows Installer e quindi su Apri.

  4. Nella finestra di dialogo Distribuisci applicazione fare clic su Avanzate e quindi su OK.

  5. Nella finestra di dialogo Proprietà del pacchetto fare clic sulla scheda Modifiche.

  6. Eseguire una delle operazioni seguenti:

    • Per aggiungere modifiche, fare clic su Aggiungi. Nella finestra di dialogo Apri selezionare il file di trasformazione, con estensione mst, e quindi fare clic su Apri.

    • Per rimuovere modifiche, selezionare la modifica che si desidera rimuovere nella scheda Modifiche e quindi fare clic su Rimuovi. Ripetere questo passaggio per rimuovere tutte le modifiche che non si desidera applicare.

  7. Dopo avere configurato le modifiche nel modo desiderato, fare clic su OK.

    Importante

    Fare clic su OK solo al termine della configurazione delle modifiche. Quando si fa clic su OK, il pacchetto viene assegnato o pubblicato immediatamente. Se le modifiche non sono configurate in modo appropriato, sarà necessario disinstallare il pacchetto o aggiornarlo con una versione configurata correttamente.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Nella finestra di dialogo Apri vengono visualizzati i pacchetti disponibili nel punto di distribuzione software impostato come predefinito.

  • Se il pacchetto di Windows Installer si trova in una directory di rete condivisa diversa, passare al punto di distribuzione software corretto nella finestra di dialogo Apri, fare clic sul pacchetto e quindi su Apri.

  • Le modifiche, ovvero i file con estensione mst, vengono applicate ai pacchetti di Windows Installer, con estensione msi, in base all'ordine specificato dall'utente. Determinare questo ordine prima di procedere con l'assegnazione o la pubblicazione dell'applicazione.

  • È possibile aggiungere più modifiche o trasformazioni. Le trasformazioni verranno applicate in base all'ordine specificato dall'utente nell'elenco Modifiche, dall'alto verso il basso. Per modificare l'ordine delle voci, selezionare una trasformazione nell'elenco e quindi fare clic su Sposta su o Sposta giù.


Utilizzare script di avvio, arresto, accesso e disconnessione

Criteri di gruppo consente di associare uno o più file script a quattro eventi attivati:

  • Avvio del computer

  • Arresto del computer

  • Accesso dell'utente

  • Disconnessione dell'utente

  • È possibile utilizzare script di Windows PowerShell o script sviluppati in qualsiasi altro linguaggio supportato dal computer client. Vengono inoltre utilizzati i linguaggi e i file di comando supportati da Windows Script Host, inclusi VBScript e Jscript.

  • In questa sezione vengono descritti gli argomenti seguenti:

    Impostare script nel controller di dominio

    Assegnare script di avvio del computer

    Assegnare script di arresto del computer

    Assegnare script di accesso dell'utente

    Assegnare script di disconnessione dell'utente

Ulteriori considerazioni

Per ulteriori informazioni sugli script, visitare l'area dedicata agli script per i Criteri di gruppo all'indirizzo http://go.microsoft.com/fwlink/?LinkID=66013.


Impostare script nel controller di dominio

Per impostare script nel controller di dominio

  • Copiare lo script e i file dipendenti nella cartella condivisa Netlogon sul controller di dominio.

Ulteriori considerazioni

Per configurare script in un controller di dominio, è necessario appartenere al gruppo di sicurezza Domain Admins.


Assegnare script di avvio del computer

Per assegnare script di avvio del computer

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'Oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Nell'albero della console fare clic su Script (Avvio/Arresto). Il percorso è Configurazione computer\Criteri\Impostazioni di Windows\Script (Avvia/Arresta).

  3. Nel riquadro risultati fare doppio clic su Avvio.

  4. Nella finestra di dialogo Proprietà - avvio fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiunta script eseguire le operazioni seguenti:

    • In Nome script digitare il percorso dello script oppure fare clic su Sfoglia per cercare il file script nella cartella condivisa Netlogon nel controller di dominio.

    • In Parametri script digitare i parametri desiderati esattamente come verrebbero digitati nella riga di comando. Se ad esempio nello script si desidera includere i parametri //logo (visualizzazione intestazione) e //I (modalità interattiva), digitare //logo //I.

  6. Nella finestra di dialogo Proprietà - avvio specificare le opzioni desiderate:

    • Script di avvio per <oggetto Criteri di gruppo>: contiene l'elenco di tutti gli script attualmente assegnati all'oggetto Criteri di gruppo selezionato. Se si assegnano più script, questi verranno elaborati in base all'ordine specificato. Per spostare uno script verso l'alto nell'elenco, selezionarlo e quindi fare clic su Su. Per spostare uno script verso il basso nell'elenco, selezionarlo e quindi fare clic su Giù.

    • Aggiungi: visualizza la finestra di dialogo Aggiunta script in cui è possibile specificare script aggiuntivi da utilizzare.

    • Modifica: apre la finestra di dialogo Modifica script in cui è possibile modificare le informazioni sullo script, ad esempio il nome e i parametri.

    • Rimuovi: rimuove lo script selezionato dall'elenco Script di avvio.

    • Visualizza file: visualizza i file script archiviati nell'oggetto Criteri di gruppo selezionato.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Gli script di avvio vengono eseguiti con l'account di sistema locale e dispongono dei diritti completi associati all'esecuzione con tale account.

  • Per impostazione predefinita, in Windows® 7 e Windows Vista® gli script di avvio vengono eseguiti in modalità asincrona. Questo comportamento è diverso rispetto ai sistemi operativi precedenti.

  • Se si impostano gli script di avvio in modo che vengano eseguiti in modalità sincrona, è possibile che si verifichi un rallentamento del processo di avvio.

  • In Windows 7 e Microsoft Windows Vista gli script di avvio eseguiti in modalità asincrona non sono visibili. L'attivazione dell'impostazione dei Criteri di gruppo Rendi visibili gli script di avvio durante l'esecuzione non ha alcun effetto durante l'esecuzione degli script di avvio in modalità asincrona.


Assegnare script di arresto del computer

Per assegnare script di arresto del computer

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Nell'albero della console fare clic su Script (Avvio/Arresto). Il percorso è Configurazione computer\Criteri\Impostazioni di Windows\Script (Avvio/Arresto).

  3. Nel riquadro dei risultati espandere Arresto.

  4. Nella finestra di dialogo Proprietà - arresto fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiunta script eseguire le operazioni seguenti:

    • In Nome script digitare il percorso dello script oppure fare clic su Sfoglia per cercare il file script nella cartella condivisa Netlogon nel controller di dominio.

    • In Parametri script digitare i parametri desiderati esattamente come verrebbero digitati nella riga di comando. Se ad esempio nello script si desidera includere i parametri //logo (visualizzazione intestazione) e //I (modalità interattiva), digitare //logo //I.

  6. Nella finestra di dialogo Proprietà - arresto specificare le opzioni desiderate:

    • Script di arresto per <oggetto Criteri di gruppo>: elenca tutti gli script attualmente assegnati all'oggetto Criteri di gruppo selezionato. Se si assegnano più script, questi verranno elaborati in base all'ordine specificato. Per spostare uno script verso l'alto nell'elenco, selezionarlo e quindi fare clic su Su. Per spostare uno script verso il basso nell'elenco, selezionarlo e quindi fare clic su Giù.

    • Aggiungi: visualizza la finestra di dialogo Aggiunta script in cui è possibile specificare script aggiuntivi da utilizzare.

    • Modifica: apre la finestra di dialogo Modifica script in cui è possibile modificare le informazioni sullo script, ad esempio il nome e i parametri.

    • Rimuovi: rimuove lo script selezionato dall'elenco Script di arresto.

    • Visualizza file: visualizza i file script archiviati nell'oggetto Criteri di gruppo selezionato.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Gli script di arresto vengono eseguiti con l'account di sistema locale e dispongono dei diritti completi associati all'esecuzione con tale account.

  • Se si impostano gli script di arresto in modo che vengano eseguiti in modalità sincrona, è possibile che si verifichi un rallentamento del processo di arresto.


Assegnare script di accesso dell'utente

Per assegnare script di accesso dell'utente

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Nell'albero della console fare clic su Script (Accesso/Fine sessione). Il percorso è Configurazione utente\Criteri\Impostazioni di Windows\Script (Accesso/Fine sessione).

  3. Nel riquadro dei risultati espandere Accesso.

  4. Nella finestra di dialogo Proprietà - accesso fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiunta script eseguire le operazioni seguenti:

    • In Nome script digitare il percorso dello script oppure fare clic su Sfoglia per cercare il file script nella cartella condivisa Netlogon nel controller di dominio.

    • In Parametri script digitare i parametri desiderati esattamente come verrebbero digitati nella riga di comando. Se ad esempio nello script si desidera includere i parametri //logo (visualizzazione intestazione) e //I (modalità interattiva), digitare //logo //I.

  6. Nella finestra di dialogo Proprietà - accesso specificare le opzioni desiderate:

    • Script di accesso per <oggetto Criteri di gruppo>: elenca tutti gli script attualmente assegnati all'oggetto Criteri di gruppo selezionato. Se si assegnano più script, questi verranno elaborati in base all'ordine specificato. Per spostare uno script verso l'alto nell'elenco, selezionarlo e quindi fare clic su Su. Per spostare uno script verso il basso nell'elenco, selezionarlo e quindi fare clic su Giù.

    • Aggiungi: visualizza la finestra di dialogo Aggiunta script in cui è possibile specificare script aggiuntivi da utilizzare.

    • Modifica: apre la finestra di dialogo Modifica script in cui è possibile modificare le informazioni sullo script, ad esempio il nome e i parametri.

    • Rimuovi: rimuove lo script selezionato dall'elenco Script di accesso.

    • Visualizza file: visualizza i file script archiviati nell'oggetto Criteri di gruppo selezionato.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Se si impostano gli script di accesso in modo che vengano eseguiti in modalità sincrona, è possibile che si verifichi un rallentamento del processo di accesso.

  • Gli script di accesso vengono eseguiti con l'account utente, non con l'account amministratore, e i relativi diritti sono soggetti alle limitazioni di tale account.


Assegnare script di disconnessione dell'utente

Per assegnare script di disconnessione dell'utente

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo che si desidera modificare e quindi scegliere Modifica.

  2. Nell'albero della console fare clic su Script (Accesso/Fine sessione). Il percorso è Configurazione utente\Criteri\Impostazioni di Windows\Script (Accesso/Fine sessione).

  3. Nel riquadro dei risultati espandere Fine sessione.

  4. Nella finestra di dialogo Proprietà - fine sessione fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiunta script eseguire le operazioni seguenti:

    • In Nome script digitare il percorso dello script oppure fare clic su Sfoglia per cercare il file script nella cartella condivisa Netlogon nel controller di dominio.

    • In Parametri script digitare i parametri desiderati esattamente come verrebbero digitati nella riga di comando. Se ad esempio nello script si desidera includere i parametri //logo (visualizzazione intestazione) e //I (modalità interattiva), digitare //logo //I.

  6. Nella finestra di dialogo Proprietà - fine sessione specificare le opzioni desiderate:

    • Script di disconnessione per <oggetto Criteri di gruppo>: elenca tutti gli script attualmente assegnati all'oggetto Criteri di gruppo selezionato. Se si assegnano più script, questi verranno elaborati in base all'ordine specificato. Per spostare uno script verso l'alto nell'elenco, selezionarlo e quindi fare clic su Su. Per spostare uno script verso il basso nell'elenco, selezionarlo e quindi fare clic su Giù.

    • Aggiungi: visualizza la finestra di dialogo Aggiunta script in cui è possibile specificare script aggiuntivi da utilizzare.

    • Modifica: apre la finestra di dialogo Modifica script in cui è possibile modificare le informazioni sullo script, ad esempio il nome e i parametri.

    • Rimuovi: rimuove lo script selezionato dall'elenco Script di disconnessione.

    • Visualizza file: visualizza i file script archiviati nell'oggetto Criteri di gruppo selezionato.

Ulteriori considerazioni

  • Per completare la procedura è necessario avere autorizzazioni di modifica per modificare un oggetto Criteri di gruppo. Per impostazione predefinita, i membri dei gruppi di sicurezza Domain Admins, Amministratori dell'organizzazione o Proprietari autori criteri di gruppo hanno autorizzazioni di modifica per modificare un oggetto Criteri di gruppo.

  • Gli script di disconnessione vengono eseguiti con l'account utente, non con l'account amministratore, e i relativi diritti sono soggetti alle limitazioni di tale account.

  • Se si impostano gli script di disconnessione in modo che vengano eseguiti in modalità sincrona, è possibile che si verifichi un rallentamento del processo di disconnessione.


Utilizzare il reindirizzamento cartelle

Utilizzare il reindirizzamento delle cartelle

Il reindirizzamento delle cartelle consente di reindirizzare il percorso di cartelle specifiche all'interno dei profili utente a una nuova posizione, ad esempio un percorso di rete condiviso. Il reindirizzamento delle cartelle viene utilizzato durante il processo di amministrazione dei profili utente e dei profili utente mobili. È possibile configurare il reindirizzamento delle cartelle utilizzando Console Gestione Criteri di gruppo per reindirizzare cartelle specifiche dei profili utente e per modificare le impostazioni dei criteri di reindirizzamento delle cartelle.

In questa sezione vengono descritti gli argomenti seguenti:

  • Panoramica del reindirizzamento delle cartelle

  • Specificare il percorso delle cartelle in un profilo utente

Ulteriori considerazioni

  • Per ulteriori informazioni sui profili utente e il reindirizzamento delle cartelle, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=66003.


Panoramica del reindirizzamento delle cartelle

Reindirizzamento delle cartelle

Le impostazioni utente e i file utente vengono in genere archiviati nel profilo utente locale, all'interno della cartella Utenti. Poiché è possibile accedere ai file archiviati nei profili utente locali solo dal computer corrente, gli utenti che utilizzano più computer hanno difficoltà a gestire i dati e a sincronizzare le impostazioni tra più computer. Per risolvere questo problema, sono disponibili due tecnologie, ovvero i profili mobili e il reindirizzamento delle cartelle. Entrambe le tecnologie presentano vantaggi specifici e possono essere utilizzate separatamente oppure insieme per creare un'esperienza utente uniforme durante l'utilizzo di computer diversi. Queste tecnologie offrono inoltre alcune opzioni aggiuntive agli amministratori per la gestione dei dati dell'utente.

Il reindirizzamento delle cartelle consente agli amministratori di reindirizzare il percorso di una cartella a una nuova posizione. La nuova posizione può essere rappresentata da una cartella nel computer locale o da una directory in una condivisione file di rete. Gli utenti possono utilizzare documenti presenti in un server come se fossero archiviati in un'unità locale. I documenti presenti nella cartella saranno disponibili all'utente da qualsiasi computer della rete. Il reindirizzamento delle cartelle è disponibile in Impostazioni di Windows nell'albero della console quando si modificano Criteri di gruppo basati sul dominio tramite Console Gestione Criteri di gruppo. Il percorso è [Nome oggetto Criteri di gruppo]\Configurazione utente\Criteri\Impostazioni di Windows\Reindirizzamento cartelle.

Modifiche recenti apportate al reindirizzamento delle cartelle

Il reindirizzamento delle cartelle include le funzionalità seguenti:

  • La possibilità di reindirizzare più cartelle nelle cartelle dei profili utente rispetto ai sistemi operativi Windows precedenti, incluse le cartelle Contatti, Download, Preferiti, Collegamenti, Musica, Partite salvate, Ricerche e Video.

  • La possibilità di applicare impostazioni relative alle cartelle reindirizzate a computer Windows® 2000, Windows 2000 Server®, Windows XP e Windows Server 2003. È possibile scegliere se applicare le impostazioni configurate in Windows Server® 2008 R2, Windows® 7, Windows Server 2008 o Windows Vista® solo ai computer che eseguono questi sistemi operativi oppure anche ai computer che eseguono versioni precedenti dei sistemi operativi Windows. Per questi sistemi operativi Windows precedenti, è possibile applicare le impostazioni a cartelle che possono essere reindirizzate, ovvero alle cartelle Dati applicazioni, Desktop, Documenti, Immagini e Menu Avvio. Questa opzione è disponibile nella scheda Impostazioni della finestra di dialogo Proprietà della cartella, in Selezionare le impostazioni di reindirizzamento per [NomeCartella].

  • L'opzione che consente di impostare le cartelle Musica, Immagini e Video in modo che seguano la cartella Documenti. Nei sistemi operativi Windows precedenti a Microsoft Windows Vista queste cartelle sono sottocartelle della cartella Documenti. Configurando questa opzione, è possibile risolvere i problemi correlati alle differenze tra i sistemi operativi Windows precedenti e quelli più recenti in termini di denominazione e struttura delle cartelle. Questa opzione è disponibile nella scheda Destinazione della finestra di dialogo Proprietà della cartella, in Impostazioni.

  • La possibilità di reindirizzare la cartella Menu Start a un percorso specifico per tutti gli utenti. In Windows XP la cartella Menu Avvio può essere reindirizzata solo a una cartella di destinazione condivisa.

Nota

Questa funzionalità è nuova solo per la cartella Menu Start. Anche tutte le altre cartelle reindirizzabili in Microsoft Windows Vista e versioni successive possono essere reindirizzate a un percorso specifico per tutti gli utenti.

Cartelle che è possibile reindirizzare

È possibile utilizzare Console Gestione Criteri di gruppo per reindirizzare le cartelle seguenti.

Cartella in Windows 7 e Microsoft Windows Vista | Cartella equivalente nei sistemi operativi Windows precedenti
AppData/Profilo mobile | Application Data
Contatti | Non applicabile
Desktop | Desktop
Documenti | Documenti
Download | Non applicabile
Preferiti | Non applicabile
Collegamenti | Non applicabile
Musica | Non applicabile
Immagini | Immagini
Partite salvate | Non applicabile
Ricerche | Non applicabile
Menu Start | Menu Avvio
Video | Non applicabile

Vantaggi del reindirizzamento delle cartelle

  • I dati di un utente saranno sempre disponibili, anche se l'utente accede a computer diversi della rete.

  • La tecnologia per i file offline, che è attivata per impostazione predefinita, consente agli utenti di accedere alla cartella anche quando non sono connessi alla rete. Questa funzionalità è particolarmente utile per gli utenti di computer portatili.

  • È possibile eseguire il backup dei dati archiviati in una cartella di rete durante la normale procedura di amministrazione del sistema. Si tratta di una scelta più sicura, in quanto non comporta alcun intervento da parte dell'utente.

  • Se si utilizzano profili utente mobili, è possibile scegliere il reindirizzamento delle cartelle per ridurre le dimensioni totali del profilo mobile e rendere il processo di accesso e disconnessione più efficiente per l'utente finale. Quando si distribuisce il reindirizzamento delle cartelle con profili utente mobili, i dati sincronizzati tramite il reindirizzamento delle cartelle non fanno parte del profilo mobile e vengono sincronizzati in background tramite la funzionalità File offline in seguito all'accesso dell'utente. L'utente, pertanto, non deve attendere che i dati vengano sincronizzati in fase di accesso o disconnessione, come nel caso dei profili utente mobili.

  • I dati specifici di un utente possono essere reindirizzati dal disco rigido contenente i file del sistema operativo a un disco rigido diverso del computer locale dell'utente. In questo modo, i dati dell'utente sono più sicuri qualora sia necessario reinstallare il sistema operativo.

  • Gli amministratori possono utilizzare Criteri di gruppo per impostare quote del disco, che consentono di limitare la quantità di spazio utilizzato dalle cartelle dei profili utente.

Selezionare una destinazione per il reindirizzamento delle cartelle

Nella scheda Destinazione della finestra di dialogo Proprietà della cartella è possibile selezionare il percorso della cartella reindirizzata su una rete o nel profilo utente locale. È possibile scegliere tra le impostazioni seguenti:

  • Base - Reindirizza la cartella comune nello stesso percorso. Questa impostazione consente di reindirizzare allo stesso percorso le cartelle di tutti gli utenti e viene applicata a tutti gli utenti inclusi nell'Oggetto Criteri di gruppo. Per questa impostazione, sono disponibili le opzioni seguenti per la scelta del percorso della cartella di destinazione:

    • Crea una cartella per ogni utente nel percorso directory radice. Tramite questa opzione viene creata una cartella con il formato \\server\condivisione\Nome account utente\Nome cartella. Ogni utente disporrà di un percorso univoco per la cartella reindirizzata.

Nota

Se si seleziona l'opzione Applica criterio di reindirizzamento anche ai sistemi operativi Windows 2000, Windows 2000 Server, Windows XP e Windows Server 2003 nella scheda Impostazioni, questa opzione non sarà disponibile per la cartella Menu Start.

  • Reindirizza al seguente percorso. Questa opzione consente di utilizzare un percorso esplicito per la posizione di reindirizzamento. Di conseguenza, è possibile che più utenti condividano lo stesso percorso per la cartella reindirizzata.

  • Reindirizza nel percorso del profilo utente locale. Questa opzione consente di spostare il percorso della cartella nel profilo utente locale all'interno della cartella Utenti.

  • Avanzata - Specifica i percorsi per i vari gruppi di utenti. Questa impostazione consente di specificare il comportamento del reindirizzamento per la cartella in base alle appartenenze al gruppo di sicurezza dell'oggetto Criteri di gruppo.

  • Segui la cartella Documenti. Questa opzione è disponibile solo per le cartelle Musica, Immagini e Video e consente di risolvere i problemi correlati alle differenze tra Windows 7 e Microsoft Windows Vista e i sistemi operativi Windows precedenti in termini di denominazione e struttura delle cartelle. Se si seleziona questa opzione, non sarà possibile configurare altre opzioni di reindirizzamento o di rimozione dei criteri per queste cartelle e le impostazioni verranno ereditate dalla cartella Documenti.

Nota

Questo comportamento viene applicato per impostazione predefinita anche quando si seleziona l'opzione Applica criterio di reindirizzamento anche ai sistemi operativi Windows 2000, Windows 2000 Server, Windows XP e Windows Server 2003 nella scheda Impostazioni durante la configurazione delle impostazioni di reindirizzamento per la cartella Documenti.

  • Non configurato. Questa è l'impostazione predefinita. Questa impostazione specifica che il reindirizzamento delle cartelle basato sui criteri è stato rimosso per l'oggetto Criteri di gruppo e le cartelle verranno reindirizzate nel percorso del profilo utente locale oppure verranno mantenute nella posizione corrente a seconda delle opzioni di reindirizzamento selezionate se sono stati impostati criteri di reindirizzamento esistenti. Il percorso corrente della cartella non subisce alcuna modifica.

Configurare impostazioni aggiuntive per la cartella reindirizzata

Nella scheda Impostazioni della finestra di dialogo Proprietà di una cartella è possibile attivare le impostazioni seguenti:

  • Concedi all'utente i diritti esclusivi. È consigliabile lasciare attivata questa impostazione, che è selezionata per impostazione predefinita. Questa impostazione specifica che l'amministratore e gli altri utenti non dispongono delle autorizzazioni necessarie per accedere alla cartella.

  • Sposta il contenuto di [NomeCartella] nella nuova posizione. Questa impostazione consente di spostare nella cartella condivisa sulla rete tutti i dati dell'utente presenti nella cartella locale.

  • Applica criterio di reindirizzamento ai sistemi operativi Windows 2000, Windows 2000 Server, Windows XP e Windows Server 2003. Questa impostazione consente l'utilizzo del reindirizzamento delle cartelle in Windows 7, Microsoft Windows Vista e nei sistemi operativi Windows precedenti e ha effetto solo sulle cartelle reindirizzabili dei sistemi operativi Windows precedenti, ovvero Application Data, Desktop, Documenti, Immagini e Menu Avvio.

Nota

La cartella AppData/Roaming di Windows Vista, denominata Dati applicazioni nei sistemi operativi Windows precedenti, contiene diverse cartelle in precedenza disponibili nella cartella radice della cartella Profilo utente nei sistemi operativi Windows precedenti. Nei sistemi operativi Windows precedenti, ad esempio, la cartella Menu Avvio non è una sottocartella della cartella Application Data. Potrebbe quindi non essere consigliabile reindirizzare tutte le cartelle incluse in Dati applicazioni quando si attiva l'impostazione Applica criterio di reindirizzamento ai sistemi operativi Windows 2000, Windows 2000 Server, Windows XP e Windows Server 2003. Se, pertanto, si seleziona questa impostazione, in Windows 7 e Microsoft Windows Vista le cartelle seguenti non verranno reindirizzate automaticamente: Menu Start, Collegamenti rete, Collegamenti stampanti, Modelli, Cookies, Inviato a. Se non si seleziona questa impostazione, tutte le sottocartelle della cartella Dati applicazioni verranno automaticamente reindirizzate in Windows 7 e Microsoft Windows Vista.

  • Rimozione criteri. Nella tabella seguente viene riepilogato il comportamento delle cartelle reindirizzate e del relativo contenuto quando l'oggetto Criteri di gruppo non è più applicabile in base alle selezioni eseguite per la rimozione dei criteri. Le seguenti opzioni per la rimozione dei criteri sono disponibili nella scheda Impostazioni, in Rimozione criteri.

Opzione di rimozione dei criteri Impostazione selezionata Risultato

Reindirizza la cartella nel percorso del profilo utente locale quando i criteri sono rimossi

Attivata

  • Reindirizza la cartella nel percorso del profilo utente.

  • Il contenuto viene copiato, non spostato, nel percorso del profilo utente.

  • Il contenuto non viene eliminato dal percorso reindirizzato.

  • L'utente continua ad avere accesso al contenuto, ma solo nel computer locale.

Reindirizza la cartella nel percorso del profilo utente locale quando i criteri vengono rimossi

Disattivata

  • Consente di reindirizzare la cartella nel percorso del profilo utente.

  • Il contenuto non viene copiato né spostato nel percorso del profilo utente.

Nota

Se il contenuto di una cartella non viene copiato nel percorso del profilo utente, l'utente non sarà in grado di visualizzarlo.

Lascia la cartella nel nuovo percorso quando i criteri sono rimossi

Attivata o Disattivata
  • La cartella rimane nel percorso reindirizzato.

  • Il contenuto viene lasciato nel percorso reindirizzato.

  • L'utente continua ad avere accesso al contenuto nella cartella reindirizzata.

Ulteriori considerazioni

  • Per informazioni dettagliate sull'utilizzo del reindirizzamento delle cartelle, vedere Specificare il percorso delle cartelle in un profilo utente.


Specificare il percorso delle cartelle in un profilo utente

È possibile utilizzare Criteri di gruppo per specificare un percorso diverso per le cartelle, ovvero reindirizzarne il percorso, all'interno dei profili utente. Le cartelle possono essere reindirizzate a un unico percorso per tutti gli utenti o a percorsi diversi in base al gruppo di sicurezza di appartenenza degli utenti. È inoltre possibile configurare impostazioni aggiuntive per la cartella reindirizzata. Le impostazioni che è possibile configurare includono la concessione di diritti utente esclusivi per la cartella, lo spostamento del contenuto della cartella nella nuova posizione, l'applicazione del criterio di reindirizzamento ai sistemi operativi Windows precedenti e la definizione del comportamento di sistema da applicare in caso di rimozione dei criteri.

Per specificare il percorso delle cartelle in un profilo utente

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse sull'Oggetto Criteri di gruppo collegato al sito, al dominio o all'unità organizzativa contenente gli utenti di cui si desidera reindirizzare le cartelle dei profili utente e quindi scegliere Modifica.

  2. Nella finestra Editor Gestione Criteri di gruppo fare clic con il pulsante destro del mouse sulla cartella dei profili utente che si desidera reindirizzare. Il percorso della cartella dei profili utente è Configurazione utente\Criteri\Impostazioni di Windows\Reindirizzamento cartelle\NomeCartellaProfiliUtente

  3. Nella scheda Destinazione, in Impostazioni, scegliere una delle impostazioni seguenti, eseguire la procedura relativa a tale impostazione e quindi fare clic su OK:

    Base - Reindirizza la cartella comune nello stesso percorso

    1. In Percorso cartella di destinazione selezionare un percorso.

    2. Se si desidera reindirizzare la cartella a un percorso specifico, selezionare Crea una cartella per ogni utente nel percorso directory radice o Reindirizza al seguente percorso e quindi fare clic su Sfoglia per specificare il percorso.

    3. Se si desidera specificare impostazioni di reindirizzamento aggiuntive per la cartella, fare clic sulla scheda Impostazioni per configurare una o più delle impostazioni seguenti e quindi fare clic su OK:

    • Concedi all'utente i diritti esclusivi per [NomeCartella] (selezionata per impostazione predefinita).

    • Sposta il contenuto di [NomeCartella] nella nuova posizione (selezionata per impostazione predefinita).

    • Applica criterio di reindirizzamento da Windows® 7 o Windows Vista® a sistemi operativi Windows precedenti.

    • Specificare le impostazioni per la rimozione dei criteri (per impostazione predefinita è selezionata l'opzione Lascia la cartella nel nuovo percorso quando i criteri sono rimossi).

    Avanzata - Specifica i percorsi per i vari gruppi di utenti

    1. In Appartenenza al gruppo di sicurezza fare clic su Aggiungi.

    2. In Appartenenza al gruppo di sicurezza fare clic su Sfoglia per selezionare il gruppo di sicurezza.

    3. In Percorso cartella di destinazione selezionare un percorso.

    4. Se si desidera reindirizzare la cartella a un percorso specifico, selezionare Crea una cartella per ogni utente nel percorso directory radice o Reindirizza al seguente percorso e quindi fare clic su Sfoglia per specificare il percorso.

    5. Se si desidera specificare impostazioni di reindirizzamento aggiuntive per la cartella, fare clic sulla scheda Impostazioni per configurare una o più delle impostazioni seguenti e quindi fare clic su OK:

    • Concedi all'utente i diritti esclusivi per [NomeCartella] (selezionata per impostazione predefinita).

    • Sposta il contenuto di [NomeCartella] nella nuova posizione (selezionata per impostazione predefinita).

    • Applica criterio di reindirizzamento ai sistemi operativi Windows 2000, Windows 2000 Server, Windows XP e Windows Server 2003.

    • Specificare le impostazioni di Rimozione criteri (per impostazione predefinita è selezionata l'opzione Lascia la cartella nel nuovo percorso quando i criteri sono rimossi).

    Segui la cartella Documenti

    Questa opzione è disponibile solo per le cartelle Musica, Immagini e Video Questa selezione consente di seguire tutte le impostazioni configurate per la cartella Documenti e di risolvere i problemi correlati alle differenze di denominazione e di struttura delle cartelle tra Windows 7 e Microsoft Windows Vista e i sistemi operativi Windows precedenti. Se si seleziona questa opzione, non sarà possibile configurare altre opzioni di reindirizzamento o di rimozione dei criteri per queste cartelle e le impostazioni verranno ereditate dalla cartella Documenti.

    Non configurato

    Questa è l'impostazione predefinita. Al percorso corrente della cartella non viene apportata alcuna modifica.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario accedere come membri del gruppo di sicurezza Domain Admins, Enterprise Admins o Proprietari autori criteri di gruppo.

  • Per ulteriori informazioni sulle impostazioni e le opzioni di configurazione per il reindirizzamento delle cartelle, vedere Panoramica del reindirizzamento delle cartelle.

  • È inoltre possibile utilizzare Console Gestione Criteri di gruppo per configurare le impostazioni dei criteri seguenti per il reindirizzamento delle cartelle:

    • Utilizzare i nomi delle sottocartelle localizzati durante il reindirizzamento di Start e Documenti, disponibile nei percorsi seguenti: Configurazione computer\Criteri\Modelli amministrativi\Sistema\Reindirizzamento cartelle o Configurazione utente\Criteri\Modelli amministrativi\Sistema\Reindirizzamento cartelle.

    • Non rendere automaticamente disponibili non in linea le cartelle reindirizzate, disponibile nel percorso seguente: Configurazione utente\Criteri\Modelli amministrativi\Sistema\Reindirizzamento cartelle.

  • Per ulteriori informazioni sui profili utente e il reindirizzamento delle cartelle, vedere http://go.microsoft.com/fwlink/?LinkId=66003.


Configurare e commentare elementi preferenza e definirne la destinazione

La Console Gestione criteri di gruppo consente di configurare elementi preferenza quando si modifica un oggetto Criteri di gruppo basato su dominio. Il nodo Preferenze viene visualizzato sotto Configurazione computer e Configurazione utente. Nell'editor le estensioni delle preferenze sono visualizzate in due categorie: Impostazioni di Windows e Impostazioni del Pannello di controllo.

Le estensioni relative alle preferenze disponibili in Impostazioni di Windows includono:

  • Estensione Applicazioni: consente di configurare le impostazioni per le applicazioni.

  • Estensione Mapping unità: consente di creare, modificare o eliminare unità mappate, nonché di configurare la visibilità di tutte le unità.

  • Estensione Ambiente: consente di creare, modificare o eliminare variabili di ambiente.

  • Estensione File: consente di copiare, sostituire o eliminare file, nonché di modificarne gli attributi.

  • Estensione Cartelle: consente di creare, modificare o eliminare cartelle.

  • Estensione File INI: consente di aggiungere, sostituire o eliminare sezioni o proprietà nei file delle impostazioni di configurazione (estensione ini) o delle informazioni di installazione (estensione inf).

  • Estensione Condivisioni di rete: consente di creare, modificare o eliminare, ovvero rimuovere, condivisioni.

  • Estensione Registro di sistema: consente di copiare impostazioni del Registro di sistema e di applicarle ad altri computer, nonché di creare, sostituire o eliminare impostazioni del Registro di sistema.

  • Estensione Collegamenti: consente di creare, modificare o eliminare collegamenti.

Le estensioni relative alle preferenze disponibili in Impostazioni del Pannello di controllo includono:

  • Estensione Origini dati: consente di creare, modificare o eliminare nomi di origini dati ODBC (Open Database Connectivity).

  • Estensione Dispositivi: consente di abilitare o disabilitare dispositivi hardware o classi di dispositivi.

  • Estensione Opzioni cartella: Consente di configurare le opzioni cartella, di creare, modificare o eliminare le associazioni Apri con per le estensioni di file, nonché di creare, modificare o eliminare le estensioni di file associato a un tipo di file.

  • Estensione Impostazioni Internet: consente di modificare le impostazioni Internet configurabili dall'utente.

  • Estensione Utenti e gruppi locali: consente di creare, modificare o eliminare utenti e gruppi locali.

  • Estensione Opzioni rete: consente di creare, modificare o eliminare connessioni VPN o connessioni remote.

  • Estensione Opzioni risparmio energia: consente di modificare le opzioni risparmio energia e di creare, modificare o eliminare combinazioni per il risparmio di energia.

  • Estensione Stampanti: consente di creare, modificare o eliminare connessioni a stampanti TCP/IP, condivise e locali.

  • Estensione Opzioni internazionali: consente di modificare le opzioni internazionali.

  • Estensione Attività pianificate: consente di creare, modificare o eliminare attività pianificate o immediate.

  • Estensione Servizi: consente di modificare i servizi.

  • Estensione Menu Start: consente di modificare le opzioni del menu Start.


Panoramica di Preferenze

Preferenze di Criteri di gruppo, introdotto in Windows Server® 2008, include oltre venti estensioni di Criteri di gruppo che ampliano la gamma di impostazioni relative alle preferenze configurabili in un Oggetto Criteri di gruppo. Criteri di gruppo consente di gestire mapping di unità, impostazioni del Registro di sistema, utenti e gruppi locali, servizi, file e cartelle senza dover apprendere un linguaggio di script.

Le preferenze consentono di gestire tutte queste impostazioni aggiuntive utilizzando la nota interfaccia Console Gestione Criteri di gruppo. Nella maggior parte degli elementi preferenza viene simulata l'interfaccia utente finale pertinente per la configurazione di queste impostazioni, rendendo la configurazione più intuitiva.

In ogni oggetto Criteri di gruppo è possibile creare più elementi preferenza con ogni estensione della preferenza. Le opzioni di destinazione offrono un controllo più preciso sulle modalità di applicazione delle impostazioni delle preferenze in Windows. Utilizzando destinazioni a livello di elemento, è possibile configurare ogni oggetto Criteri di gruppo perché sia adatto per più utenti e computer.

Console Gestione Criteri di gruppo consente di configurare preferenze quando si modifica un oggetto Criteri di gruppo basato su dominio. Il nodo Preferenze viene visualizzato all'interno di Configurazione computer e Configurazione utente.

Ulteriori riferimenti

  • Configurare e commentare elementi preferenza e definirne la destinazione


Impostazioni di Windows

Console Gestione criteri di gruppo consente di configurare elementi preferenza quando si modifica un oggetto Criteri di gruppo basato su dominio. Il nodo Preferenze viene visualizzato in Configurazione computer e Configurazione utente. Nell'editor le estensioni delle preferenze sono visualizzate in due categorie: Impostazioni di Windows e Impostazioni del Pannello di controllo.

Le estensioni preferenza in Impostazioni di Windows includono:

  • Estensione Applicazioni: consente di configurare le impostazioni per le applicazioni.

  • Estensione Mapping unità: consente di creare, modificare o eliminare unità mappate, nonché configurare la visibilità di tutte le unità.

  • Estensione Ambiente: consente di creare, modificare o eliminare variabili di ambiente.

  • Estensione File: consente di copiare, sostituire o eliminare file, nonché modificarne gli attributi.

  • Estensione Cartelle: consente di creare, modificare o eliminare cartelle.

  • Estensione File INI: consente di aggiungere, sostituire o eliminare sezioni o proprietà nei file delle impostazioni di configurazione (con estensione ini) e nei file di informazioni per l'installazione (con estensione inf).

  • Estensione Condivisioni di rete: consente di creare, modificare o eliminare condivisioni, ovvero rimuoverle.

  • Estensione Registro di sistema: consente di copiare le impostazioni del Registro di sistema e applicarle ad altri computer, nonché creare, sostituire o eliminare le impostazioni del Registro di sistema.

  • Estensione Collegamenti: consente di creare, modificare o eliminare collegamenti.

Ulteriori riferimenti

  • Configurare e commentare elementi preferenza e definirne la destinazione


Estensione Applicazioni

Criteri di gruppo include l'estensione di preferenza Applicazioni. Per gli utenti questa estensione consente di configurare le impostazioni per una versione specifica di un'applicazione per la quale è stato installato un plug-in di preferenza. Le impostazioni variano a seconda dell'applicazione e della versione.

Gli sviluppatori di software possono creare plug-in per altre applicazioni tramite il Software Development Kit per Criteri di gruppo disponibile all'indirizzohttp://go.microsoft.com/fwlink/?LinkId=144.

Informazioni introduttive

È possibile creare e configurare gli elementi di preferenza Applicazione per tutti gli oggetti Criteri di gruppo basati su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ Applicazioni

Importante

È necessario installare un plug-in di preferenza prima di creare e configurare gli elementi di preferenza Applicazione.

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento applicazione

  • Configurare opzioni comuni


Configurare un elemento applicazione

Gli elementi preferenza Applicazione consentono di configurare le impostazioni per una versione specifica di un'applicazione per la quale è stato installato un plug-in di preferenza.

Gli sviluppatori di software possono creare plug-in per altre applicazioni tramite il Software Development Kit di Criteri di gruppo disponibile all'indirizzohttp://go.microsoft.com/fwlink/?LinkId=144.

Creare un elemento Applicazione

Per creare un nuovo elemento preferenza Applicazione

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Applicazioni, scegliere Nuovo e selezionare un'applicazione.

  4. Nella finestra di dialogo Proprietà immettere le impostazioni dell'applicazione da configurare per Criteri di gruppo.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Applicazioni


Estensione Mapping unità

In Criteri di gruppo è inclusa l'estensione della preferenza Mapping unità. Per gli utenti, questa estensione consente di:

  • Creare mapping dinamici di unità a condivisioni di rete.

  • Creare mapping dinamici di unità a condivisioni di rete utilizzando credenziali utente alternative.

  • Modificare le unità mappate e le rispettive proprietà.

  • Eliminare un'unità mappata.

  • Eliminare tutte le unità mappate oppure tutte le unità mappate a partire da una specifica lettera.

  • Nascondere o mostrare un'unità o tutte le unità, sia mappate che fisiche.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Unità mappata per qualsiasi oggetto Criteri di gruppo (GPO) basato sul dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ Mapping unità

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Unità mappata

  • Configurare opzioni comuni


Configurare un elemento Unità mappata

Gli elementi preferenza Mapping unità consentono di creare, sostituire, aggiornare ed eliminare unità mappate, nonché le proprietà associate a tali unità. Prima di creare un elemento preferenza Mapping unità, è necessario verificare il comportamento di ogni tipo di azione possibile con questa estensione.

Creare un elemento Unità mappata

Per creare un nuovo elemento preferenza Unità mappata

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Mapping unità, scegliere Nuovo e fare clic su Unità mappata.

  4. Nella finestra di dialogo Proprietà nuovo elemento Unità mappata selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni del mapping dell'unità da configurare o rimuovere per Criteri di gruppo. Per ulteriori informazioni, vedere la sezione "Impostazioni mapping unità" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista già o meno una lettera di unità.

Crea | Consente di creare una nuova unità mappata per gli utenti.
Elimina | Consente di rimuovere un'unità mappata per gli utenti.
Sostituisci | Consente di eliminare e ricreare unità mappate per gli utenti. Il risultato dell'azione Sostituisci consiste nel sovrascrivere tutte le impostazioni esistenti associate all'unità mappata. Se il mapping dell'unità non esiste, l'azione Sostituisci consente di crearne uno nuovo.
Aggiorna | Consente di modificare le impostazioni di un'unità mappata per gli utenti esistente. Questa azione è diversa da Sostituisci, in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. Tutte le altre impostazioni rimangono configurate come specificato nell'unità mappata. Se il mapping dell'unità non esiste l'azione Aggiorna consente di crearne uno nuovo.

Impostazioni mapping unità

Percorso

Per configurare un nuovo mapping di unità o ricrearne uno, digitare un percorso UNC completo per la condivisione di rete, ad esempio \\server\nomecondivisione, \\server\condivisionenascosta$ oppure \\server\nomecondivisione\nomecartella

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Per modificare un mapping di unità esistente, identificato dalla lettera di unità, lasciare vuoto questo campo.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Riconnetti

Per salvare questa unità mappata nelle impostazioni dell'utente e tentare di ripristinarla a ogni accesso successivo, selezionare questa casella di controllo. In caso contrario, l'unità viene mappata ma non viene salvata nelle impostazioni dell'utente.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Etichetta come

Per specificare un'etichetta descrittiva da visualizzare accanto alla lettera di unità, digitare l'etichetta in questo campo.

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Lettera di unità

Selezionare le unità mappate da configurare identificate dalla lettera di unità:

  • Per assegnare la prima lettera di unità disponibile all'unità mappata, selezionare Usa prima lettera disponibile a partire da e quindi selezionare una lettera di unità da cui iniziare a verificare la disponibilità. Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

  • Per assegnare un lettera di unità specifica all'unità mappata, selezionare Usae quindi scegliere una lettera di unità. Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna e se è stato immesso un percorso.

  • Per modificare un mapping di unità esistente, identificato dalla lettera di unità, selezionare Esistentee quindi selezionare una lettera di unità. Questa opzione è disponibile solo se il campo Percorso è vuoto e l'azione selezionata è Aggiorna.

  • Per eliminare tutti i mapping di unità a partire da una determinata lettera di unità, selezionare Elimina tutto a partire da e quindi selezionare una lettera di unità dalla quale iniziare l'eliminazione dei mapping di unità. Le unità fisiche vengono ignorate senza errore. Questa opzione è disponibile solo se l'azione selezionata è Elimina.

  • Per eliminare un'unità mappata specifica, selezionare Elimina e quindi la lettera di unità. Questa opzione è disponibile solo se l'azione selezionata è Elimina.

Connetti come

Per implementare un mapping di unità tramite credenziali diverse da quelle dell'utente attualmente connesso, digitare le credenziali da utilizzare. Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Nascondi/Mostra unità

Consente di configurare la visibilità dell'unità mappata:

  • Per non apportare alcuna modifica alla visibilità dell'unità mappata, selezionare Nessun cambiamento. Questa opzione non ha la precedenza sull'impostazione Nascondi/Mostra tutte le unità.

  • Per impedire la visualizzazione dell'unità in Esplora risorse, selezionare Nascondi unità. Questa opzione ha la precedenza sull'impostazione Nascondi/Mostra tutte le unità.

  • Per consentire la visualizzazione di questa unità in Esplora risorse, selezionare Mostra unità. Questa opzione ha la precedenza sull'impostazione Nascondi/Mostra tutte le unità.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Nascondi/Mostra tutte le unità

Consente di configurare la visibilità di tutte le unità mappate e fisiche in Esplora risorse. Le opzioni sono paragonabili a quelle di Nascondi/Mostra unità, ma si applicano globalmente a tutte le unità.

Ulteriori considerazioni

  • Le opzioni Nascondi/Mostra unità hanno la precedenza su Nascondi/Mostra tutte le unità. Ad esempio, se in un elemento preferenza Mapping unità l'opzione Nascondi/Mostra unità è impostata su Nascondi unità e l'opzione Nascondi/Mostra tutte le unità è impostata su Mostra tutte le unità, sono visibili tutte le unità tranne quella designata come nascosta.

  • È possibile utilizzare un elemento preferenza Mapping unità per configurare la visibilità di un'unità fisica anziché di un'unità mappata. A tale scopo, selezionare l'azione Aggiorna, lasciare vuoto il campo Percorso, selezionare la lettera di unità dell'unità fisica e quindi configurare le opzioni Nascondi/Mostra unità e Nascondi/Mostra tutte le unità.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Mapping unità

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Ambiente

Criteri di gruppo include l'estensione di preferenza Ambiente. Per i computer o gli utenti, questa estensione consente di:

  • Creare variabili di ambiente di sistema o di utente permanenti.

  • Modificare variabili di ambiente. ad esempio:

    • Modificare il prompt dei comandi, modificando la variabile di sistema PROMPT.

    • Modificare il percorso della cartella TEMP, modificando la variabile di sistema TEMP.

    • Sostituire il valore dell'intera variabile PATH.

    • Aggiungere segmenti delimitati da punto e virgola alla variabile PATH.

    • Eliminare segmenti delimitati da punto e virgola dalla variabile PATH.

    • Cambiare le maiuscole/minuscole di segmenti delimitati da punto e virgola della variabile PATH.

  • Eliminare variabili di ambiente.

Nota

È possibile applicare un elemento destinazione Variabile di ambiente ad altri elementi preferenza per limitarne l'applicazione in base al valore della variabile.

Informazioni introduttive

È possibile creare e configurare gli elementi di preferenza Variabile di ambiente per tutti gli oggetti Criteri di gruppo basati su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ Ambiente

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Variabile di ambiente

  • Configurare opzioni comuni


Configurare un elemento Variabile di ambiente

Gli elementi preferenza Variabile di ambiente consentono di creare, aggiornare, sostituire ed eliminare variabili di ambiente relative all'utente e al sistema o segmenti delimitati da punti e virgola della variabile PATH. Prima di creare un elemento preferenza Variabile di ambiente, è necessario rivedere il comportamento di ogni tipo di azione associata all'estensione.

Creare un elemento Variabile di ambiente

Per creare un nuovo elemento preferenza Variabile di ambiente

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Ambiente, scegliere Nuovo e selezionare Variabile di ambiente.

  4. Nella finestra di dialogo Proprietà nuovo elemento Variabile di ambiente selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni variabile di ambiente per Criteri di gruppo da configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni variabile di ambiente" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una variabile di ambiente.

Crea | Consente di creare una nuova variabile di ambiente o aggiungere un segmento delimitato da punti e virgola alla variabile PATH per computer o utenti.
Elimina | Consente di rimuovere una nuova variabile di ambiente o di eliminare un segmento delimitato da punti e virgola dalla variabile PATH per computer o utenti.
Sostituisci | Consente di eliminare o ricreare una variabile di ambiente. L'azione Sostituisci ha come effetto quello di sovrascrivere tutte le impostazioni esistenti associate alla variabile di ambiente. L'applicazione di questa azione a un segmento della variabile PATH non ha un effetto pratico se non eventualmente modificare l'impostazione maiuscole/minuscole nel segmento. Se la variabile di ambiente non esiste l'azione Sostituisci ne creerà una nuova.
Aggiorna | Consente di modificare le impostazioni di una variabile di ambiente esistente. Questa azione è diversa da Sostituisci in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. La configurazione di tutti gli altri segmenti non viene modificata rispetto a quella della variabile di ambiente. L'applicazione di questa azione a un segmento della variabile PATH non ha un effetto pratico se non eventualmente modificare l'impostazione maiuscole/minuscole nel segmento. Se la variabile di ambiente non esiste l'azione Aggiorna consente di crearne una nuova.

Impostazioni variabile di ambiente

Variabile utente

Per fare in modo che la variabile di ambiente influenzi ogni utente in modo indipendente, selezionare questa impostazione per un elemento preferenza Ambiente in Configurazione utente. La variabile di ambiente viene archiviata nel Registro di sistema in HKEY_CURRENT_USER.

Per fare in modo che la variabile di ambiente influenzi solo l'utente predefinito del computer, selezionare questa impostazione per un elemento preferenza Ambiente in Configurazione computer.

Variabile di sistema

Selezionare questa impostazione per fare in modo che la variabile di ambiente influenzi tutti gli utenti del computer. La variabile di ambiente viene archiviata nel Registro di sistema in HKEY_LOCAL_MACHINE.

Nome

Digitare un nome per la variabile di ambiente a cui viene applicata l'azione. Per selezionare la variabile PATH, lasciare il campo vuoto.

PATH

Selezionare questa casella di controllo per creare o sostituire il valore della variabile PATH oppure aggiungere o eliminare un segmento delimitato da punti e virgola del valore della variabile PATH. Questa opzione è disponibile solo se è selezionata l'opzione Variabile di sistema.

Parziale

Selezionare questa casella di controllo per aggiungere o eliminare un segmento delimitato da punti e virgola del valore della variabile PATH. Questa opzione è disponibile solo se sono selezionate le opzioni Variabile di sistema e PATH.

Valore

Digitare il valore della variabile di ambiente. Questo campo accetta variabili.

Se è selezionata l'opzione PATH, digitare un elenco delimitato da punti e virgola dei percorsi cartella Windows da utilizzare per individuare i file.

Se si seleziona l'opzione Parziale, digitare un solo segmento della variabile PATH, omettendo il delimitatore del punto e virgola.

Ulteriori considerazioni

  • Se si desidera limitare l'ambito di più elementi preferenza con un insieme complesso di elementi destinazione, è possibile semplificare la configurazione utilizzando una variabile di ambiente. Ad esempio, creare un elemento preferenza Variabile di ambiente che genera una nuova variabile di ambiente con valore pari a 1 e applicarvi gli elementi destinazione. Per applicare la stessa destinazione ad altri elementi preferenza, aggiungere un elemento destinazione Variabile di ambiente a tali elementi preferenza e configurarlo per richiedere un valore pari a 1 per la variabile creata utilizzando un elemento preferenza Variabile di ambiente.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Ambiente

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione File

Criteri di gruppo include l'estensione di preferenza File. Per i computer o gli utenti, questa estensione consente di:

  • Copiare un file, o più file di un'unica cartella, in una nuova posizione e quindi configurare gli attributi di tali file. Se necessario, vengono create nuove sottocartelle.

  • Eliminare un file, o più file di un'unica cartella, e sostituirlo con una copia di un file disponibile in una cartella di origine.

  • Modificare gli attributi di un file o di più file di un'unica cartella.

  • Eliminare un file o più file di un'unica cartella

  • Sostituire o eliminare tutti i file con una determinata estensione presenti in una cartella oppure modificare gli attributi di tali file.

  • Sostituire o eliminare tutti i file presenti in una determinata cartella oppure modificare gli attributi di tali file.

Nota

Per configurare cartelle anziché singoli file, vedere Estensione Cartelle.

Informazioni introduttive

È possibile creare e configurare gli elementi di preferenza File per tutti gli oggetti Criteri di gruppo basati su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ File

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento File

  • Configurare opzioni comuni


Configurare un elemento File

Gli elementi preferenza File consentono di copiare, modificare gli attributi, sostituire ed eliminare i file. Per configurare cartelle anziché singoli file, vedere Estensione Cartelle.) Prima di creare un elemento preferenza File, è necessario rivedere il comportamento di ogni tipo di azione associata all'estensione.

Creare un elemento File

Per creare un nuovo elemento preferenza File

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo File, scegliere Nuovo e quindi File.

  4. Nella finestra di dialogo Proprietà nuovo elemento File selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni file per Criteri di gruppo da configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni file" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e se il file esiste già.

Crea | Consente di copiare un file (o più file in un'unica cartella) da un percorso di origine in un percorso di destinazione se non esiste già nella destinazione e quindi di configurare gli attributi dei file per i computer o gli utenti.
Elimina | Consente di rimuovere un file (o più file in un'unica cartella) relativo a computer o utenti.
Sostituisci | Consente di eliminare un file (o più file in un'unica cartella), sostituirlo con un altro file e configurare gli attributi relativi ai computer o utenti. L'azione Sostituisci ha come effetto quello di sovrascrivere i file nel percorso di destinazione. Se il file non esiste nella destinazione, l'azione Sostituisci copia il file dal percorso di origine nella destinazione.
Aggiorna | Consente di modificare le impostazioni di un file esistente (o più file in un'unica cartella) relativo a computer o utenti. Questa azione è diversa da Sostituisci in quanto aggiorna solo gli attributi file definiti nell'elemento preferenza. La configurazione di tutti gli altri attributi file non viene modificata. Se il file non esiste, l'azione Aggiorna copierà il file dal percorso di origine nella destinazione.

Impostazioni file

File di origine

Digitare il percorso da cui copiare il o i File di origine. Il percorso può essere un percorso UNC completo o un percorso di un'unità locale o mappata dal punto di vista del client. Questo campo può contenere variabili.

Il campo può anche contenere caratteri jolly singoli (?) e multipli (*), per consentire di copiare o modificare più file.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

File di destinazione

Digitare il percorso in cui copiare un file o il percorso del file da modificare. Il percorso può essere un percorso UNC completo o un percorso di un'unità locale o mappata dal punto di vista del client. Se necessario, verranno create cartelle padre. È necessario includere il nome file, che può essere modificato fornendo un nome diverso da quello specificato nel campo File di origine.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna e il campo File di origine non contiene caratteri jolly.

Cartella di destinazione

Digitare il percorso della cartella in cui copiare i file o il percorso dei file da modificare. Il percorso può essere un percorso UNC completo o un percorso di un'unità locale o mappata dal punto di vista del client. Se necessario, verranno create cartelle padre.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna e il campo File di origine comprende caratteri jolly.

Elimina file

Per eliminare un file, digitare il percorso del file dal punto di vista del client.

Per eliminare più file all'interno di una cartella, includere caratteri jolly singoli (?) e multipli (*) nel nome file.

Questa opzione è disponibile solo se l'azione selezionata è Elimina.

Elimina errori relativi ad azioni su singoli file

Selezionare questa casella di controllo per consentire il trasferimento di più file anche se uno o più file singoli non possono essere trasferiti. Verranno eliminati solo gli errori dovuti al tentativo di sostituire, eliminare o configurare gli attributi di un file. La causa di questi errori può essere il file utilizzato oppure l'impossibilità di accedere o trovare il file. Se si seleziona questa opzione, questi errori possono essere rilevati solo nel file di traccia. Questa opzione è diversa dall'eliminazione degli errori della preferenza predefinita che può essere ignorata nella scheda Comuni.

Attributi

Per configurare gli attributi file system per i file in trasferimento, selezionare le caselle di controllo appropriate nella casella Attributi. Gli attributi deselezionati verranno rimossi dal file a livello di destinazione.

Ulteriori considerazioni

  • Numerosi sistemi di backup incrementale utilizzano l'attributo Archivia per determinare se un file o una cartella è stata creata o modificata e per eseguirne il backup. Per questo motivo, l'opzione Archivia è configurata per impostazione predefinita per selezionare l'attributo Archivia in qualsiasi cartella modificata.

  • Se si seleziona l'opzione Rimuovi elemento quando non viene più applicato della scheda Comuni, il file di destinazione verrà eliminato se si tratta di un file singolo. In un'operazione a più file, non verrà eliminato nessun file.

  • Per impostazione predefinita, un elemento preferenza File ha accesso a tutti gli oggetti con Voce di controllo di accesso SYSTEM. Per modificare questo elemento per l'esecuzione con autorizzazioni utente finale (se in Configurazione utente), modificare il contesto di sicurezza nella scheda Comuni.

  • Un elemento preferenza File ripristina l'attributo Sola lettura di qualsiasi file destinazione se necessario per eseguire l'attività specificata.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione File


Estensione Cartelle

Criteri di gruppo include l'estensione di preferenza Cartelle. Per i computer o gli utenti, questa estensione consente di:

  • Creare una cartella e configurarne gli attributi.

  • Modificare una cartella e configurarne gli attributi.

  • Eliminare una cartella e il relativo contenuto.

  • Eliminare una cartella solo se è vuota.

  • Eliminare tutti i file all'interno di una cartella, ad esempio una cartella di file temporanei, senza eliminare la cartella.

  • Eliminare tutti i file all'interno di una cartella senza eliminare le sottocartelle.

Nota

Per configurare singoli file anziché cartelle, vedere Estensione File.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Cartella per tutti gli oggetti Criteri di gruppo basati su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ Cartelle

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Cartella

  • Configurare opzioni comuni


Configurare un elemento Cartella

Gli elementi preferenza Cartella consentono di creare, aggiornare ed eliminare cartelle e il relativo contenuto. Per configurare singoli file anziché cartelle, vedere Estensione File. Prima di creare un elemento preferenza Cartella, è opportuno esaminare il comportamento di ogni tipo di azione possibile rispetto all'estensione.

Creare un elemento Cartella

Per creare un nuovo elemento preferenza Cartella

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Cartelle, scegliere Nuovo e quindi Cartella.

  4. Nella finestra di dialogo Proprietà nuovo elemento Cartella selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni relative alla cartella da configurare o rimuovere per Criteri di gruppo. Per ulteriori informazioni, vedere "Impostazioni della cartella" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una cartella.

Crea | Consente di creare una nuova cartella per computer o utenti.
Elimina | Consente di rimuovere una cartella per computer o utenti.
Sostituisci | Consente di eliminare e creare nuovamente una cartella per computer o utenti. L'esecuzione dell'azione Sostituisci implica l'eliminazione del contenuto di una cartella esistente e la sovrascrittura di tutte le impostazioni esistenti associate alla cartella. Se la cartella non esiste, l'azione Sostituisci consente di crearne una nuova.
Aggiorna | Consente di modificare una cartella esistente per computer o utenti. Questa azione è diversa da Sostituisci, in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se la cartella non esiste, l'azione Aggiorna consente di crearne una nuova.

Impostazioni della cartella

Percorso

Digitare il percorso della cartella dal punto di vista del client. Non inserire virgole o una barra finale. Il campo può contenere variabili.

Attributi

Per configurare gli attributi del file system per la cartella, selezionare le caselle di controllo appropriate.

Queste opzioni sono disponibili solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Opzioni disponibili per le azioni Elimina o Sostituisci

Selezionare una combinazione di opzioni per controllare i file e le cartelle da eliminare. Se viene selezionata l'azione Sostituisci, la cartella verrà nuovamente creata dopo l'elaborazione di queste opzioni a meno che non venga impedita l'eliminazione. L'effetto di queste opzioni varia a seconda della combinazione di opzioni selezionate. Per ulteriori informazioni, vedere "Ulteriori considerazioni".

Queste opzioni sono disponibili solo se l'azione selezionata è Sostituisci o Elimina.

Sono disponibili le opzioni seguenti:

  • Ignora errori relativi a file/cartelle non eliminabili: se si deseleziona questa opzione, verrà restituito un errore quando l'elemento Cartella tenta di eliminare una cartella non vuota, un file aperto, file o cartelle per le quali l'utente non dispone di autorizzazione o qualsiasi altro file o cartella non eliminabile. Se è selezionata, questa opzione consente di eliminare tutti i messaggi di errore visualizzati a causa di file o cartelle non eliminabili.

  • Consenti eliminazione di file/cartelle di sola lettura: se questa opzione è deselezionata, all'elemento Cartella viene impedito di eliminare file e cartelle di sola lettura. Se è selezionata, questa opzione consente di cancellare l'attributo di sola lettura da file e cartelle che l'elemento Cartella tenta di eliminare.

  • Elimina tutti i file nelle cartelle: se questa opzione è deselezionata, l'elemento Cartella non può eliminare file all'interno di cartelle. Se è selezionata, questa opzione consente di eliminare tutti i file della cartella corrente che è consentito eliminare. Se è selezionata anche l'opzione Elimina tutte le sottocartelle in modo ricorsivo, verranno eliminati anche tutti i file che è consentito eliminare all'interno di tutte le sottocartelle.

  • Elimina tutte le sottocartelle in modo ricorsivo (se vuote): se questa opzione è deselezionata, all'elemento Cartella viene impedito di eliminare le sottocartelle all'interno della cartella. Se questa opzione è selezionata, verrà eliminato il livello più basso delle sottocartelle se vuote e l'operazione verrà ripetuta per ogni cartella padre fino a raggiungere la cartella specificata nel campo Percorso. La presenza di elementi nelle sottocartelle viene valutata dopo l'elaborazione dell'opzione Elimina tutti i file nelle cartelle.

  • Elimina cartella (se vuota): se questa opzione è deselezionata, all'elemento Cartella viene impedito di eliminare la cartella specificata nel campo Percorso. Se questa opzione è selezionata, la cartella specificata nel campo Percorso verrà eliminata se è vuota. La presenza di elementi in questa cartella viene valutata dopo l'elaborazione delle opzioni Elimina tutti i file nelle cartelle e Elimina tutte le sottocartelle in modo ricorsivo.

Ulteriori considerazioni

  • Per le azioni Elimina o Sostituisci sono disponibili le combinazioni comuni di opzioni seguenti:

    • Eliminazione della cartella solo se è vuota: selezionare Elimina questa cartella e Consenti eliminazione di file/cartelle di sola lettura. Per evitare la visualizzazione di un errore se la cartella include file e non può essere eliminata, selezionare Ignora errori.

    • Eliminazione della cartella e di tutti i file e le sottocartelle in essa presenti: selezionare Elimina questa cartella, Elimina tutte le sottocartelle in modo ricorsivo, Elimina tutti i file nelle cartelle e Consenti eliminazione di file/cartelle di sola lettura.

    • Eliminazione di tutte le sottocartelle vuote presenti nella cartella: selezionare Elimina tutte le sottocartelle in modo ricorsivo e Consenti eliminazione di file/cartelle di sola lettura. Per evitare la visualizzazione di un errore se la cartella include file e non può essere eliminata, selezionare Ignora errori.

    • Eliminazione di tutti i file presenti nella cartella ma non delle sottocartelle o dei file presenti nelle sottocartelle: selezionare Elimina tutti i file nelle cartelle e Consenti eliminazione di file/cartelle di sola lettura.

    • Eliminazione di tutti i file e di tutte le sottocartelle presenti nella cartella: selezionare Elimina tutte le sottocartelle in modo ricorsivo, Elimina tutti i file nelle cartelle e Consenti eliminazione di file/cartelle di sola lettura.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Cartelle


Estensione File INI

Criteri di gruppo comprende l'estensione della preferenza File INI. Nel caso di computer e gruppi di computer o utenti e gruppi di utenti, questa estensione consente di:

  • Aggiungere una proprietà a un file delle impostazioni di configurazione (INI) o di informazioni per l'installazione (INF).

  • Sostituire una proprietà in un file INI o INF.

  • Eliminare una proprietà da un file INI o INF.

  • Eliminare una sezione da un file INI o INF.

  • Eliminare un file INI o INF.

Nota

Per copiare qualsiasi tipo di file in un nuovo percorso o modificarne gli attributi, vedere Estensione File.

Informazioni introduttive

È possibile creare e configurare elementi preferenza File INI per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ File INI

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento File INI

  • Configurare opzioni comuni


Configurare un elemento File INI

Gli elementi preferenza File INI consentono di aggiungere o sostituire una proprietà in un file di impostazioni di configurazione (INI) o in un file di informazioni di installazione (INF) oppure di eliminare una proprietà, una sezione o un intero file INI o INF. Per copiare un tipo qualsiasi di file in una nuova posizione o per modificarne gli attributi, vedere Estensione File.

In ogni sezione di un file INI o INF viene utilizzato il formato seguente:

[SectionName]
PropertyName1=PropertyValue1
PropertyName2=PropertyValue2

Prima di creare un elemento preferenza File INI, è opportuno esaminare il comportamento di ogni azione possibile con questa estensione.

Creare un elemento File INI

Per creare un nuovo elemento preferenza File INI

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo File INI, scegliere Nuovo e selezionare File INI.

  4. Nella finestra di dialogo Proprietà nuovo elemento File INI selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni di configurazione (INI) o le impostazioni di file di informazioni di installazione (INF) che Criteri di gruppo deve configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni di File INI" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una proprietà.

Crea | Aggiunge o configura una proprietà in un file INI o INF per computer o utenti. Se il file non esiste, viene creato.
Elimina | Rimuove una proprietà o una sezione da un file INI o INF oppure elimina un file INI o INF per computer o utenti.
Sostituisci | Elimina e ricrea una proprietà in un file INI o INF per computer o utenti. Il risultato finale dell'azione Sostituisci è la sovrascrittura della proprietà. Se la proprietà non esiste, l'azione Sostituisci la crea.
Aggiorna | Questa azione ha lo stesso effetto dell'azione Sostituisci.

Impostazioni di File INI

Percorso file

Immettere il percorso di un file INI o INF dal punto di vista del client. Non includere le virgolette. Se il file e le cartelle padre non esistono, vengono creati.

Nome sezione

Digitare il nome della sezione del file in cui configurare una proprietà o da cui eliminare una proprietà. Per eliminare l'intero file INI o INF, lasciare vuoto questo campo.

Nome proprietà

Digitare il nome della proprietà da configurare o eliminare. Per eliminare l'intera sezione del file o l'intero file, lasciare vuoto questo campo.

Valore proprietà

Digitare un valore per la proprietà. I valori possono includere le virgolette, che di solito vengono tuttavia rimosse quando i valori vengono letti da un'applicazione o dal sistema operativo. Tutti i valori vengono interpretati come testo.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Importante
  • Se il campo viene lasciato vuoto, la proprietà viene configurata come valore vuoto, che verrà interpretato come se la proprietà non esistesse.
  • Questo campo è disabilitato fino a quando non viene specificata la proprietà.

Ulteriori considerazioni

  • I campi Nome sezione, Nome proprietà e Valore proprietà sono disabilitati fino a quando non si digita del testo nel campo precedente.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione File INI

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Condivisioni di rete

Criteri di gruppo include l'estensione della preferenza Condivisioni di rete. Per i computer, questa estensione consente di:

  • Creare una condivisione e configurarne le proprietà.

  • Modificare il percorso della cartella di una condivisione sostituendo quest'ultima.

  • Eliminare (annullare la condivisione) oppure modificare il limite di utenti, Enumerazione basata sull'accesso, e aggiungere un commento per:

    • Una condivisione.

    • Tutte le condivisioni ad eccezione di quelle nascoste.

    • Tutte le condivisioni nascoste ad eccezione di quelle amministrative con lettera di unità.

    • Tutte le condivisioni amministrative con lettera di unità.

    • Tutte le condivisioni.

Note
  • Gli elementi condivisione di rete consentono di creare, modificare o eliminare i punti di condivisione, ma non di creare o eliminare le cartelle a cui essi fanno riferimento. Per i punti di condivisione da creare, le cartelle da condividere devono esistere già nei computer a cui viene applicato l'oggetto Criteri di gruppo. Quando si elimina una condivisione, il punto di condivisione per la cartella viene rimosso, tuttavia quest'ultima e i relativi contenuti non vengono eliminati.
  • Per informazioni su come utilizzare l'elemento preferenza Cartella per creare o eliminare cartelle mediante Criteri di gruppo, vedere Estensione Cartelle.

Informazioni introduttive

È possibile creare e configurare gli elementi preferenza condivisione di rete per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer

└ Preferenze

└ Impostazioni di Windows

└ Condivisioni di rete

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Condivisione di rete

  • Configurare opzioni comuni


Configurare un elemento Condivisione di rete

Gli elementi preferenza Condivisione di rete consentono di creare, aggiornare, sostituire ed eliminare condivisioni. Prima di creare un elemento preferenza Condivisione di rete, è opportuno esaminare il comportamento di ogni tipo di azione possibile con questa estensione.

Creare un elemento Condivisione di rete

Per creare un nuovo elemento preferenza Condivisione di rete

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console in Configurazione computer espandere la cartella Preferenze e quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Condivisioni di rete, scegliere Nuovo e selezionare Condivisione di rete.

  4. Nella finestra di dialogo Proprietà nuovo elemento Condivisione di rete selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni della condivisione di rete che Criteri di gruppo deve configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni della condivisione di rete" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una condivisione.

Crea | Crea una nuova condivisione per i computer.
Elimina | Rimuove una condivisione dai computer.
Sostituisci | Consente di eliminare e ricreare una condivisione. Il risultato finale dell'azione Sostituisci è costituito dalla sovrascrittura di tutte le impostazioni esistenti associate alla condivisione. Se la condivisione non esiste, l'azione Sostituisci ne crea una nuova.
Aggiorna | Modifica le impostazioni di una condivisione. Questa azione è diversa da Sostituisci in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni della condivisione rimane invariata. Se la condivisione non esiste, l'azione Aggiorna ne crea una nuova.

Impostazione della condivisione di rete

Nome condivisione

Immettere il nome della condivisione.

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile se si è selezionato Modificatori di azione e l'azione è Elimina o Aggiorna.

Percorso cartella

Immettere il percorso di una cartella esistente a cui punterà la condivisione.

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile se si è selezionato Modificatori di azione e l'azione è Elimina o Aggiorna.

Commento

Digitare il testo da visualizzare nel campo Commento della condivisione. Se l'azione selezionata è Aggiorna, la condivisione esiste già e questo campo è lasciato vuoto, il commento esistente rimane invariato.

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Modificatori di azione

È possibile modificare o eliminare tutte le condivisioni di un tipo specifico anziché una singola condivisione. Queste opzioni sono disponibili solo se l'azione selezionata è Aggiorna o Elimina.

  • Per modificare o eliminare tutte le condivisioni non nascoste (il cui nome finisce con $) o speciali (SYSVOL e NETLOGON), selezionare Aggiorna o Elimina tutte le condivisioni normali.

  • Per modificare o eliminare tutte le condivisioni nascoste tranne le condivisioni amministrative con lettera di unità, ADMIN$, FAX$, IPC$ e PRINT$, selezionare Aggiorna o Elimina tutte le condivisioni non amministrative nascoste.

  • Per modificare o eliminare tutte le condivisioni amministrative con lettera di unità seguita da $, selezionare Aggiorna o Elimina tutte le condivisioni amministrative con lettera di unità.

Nota

Le condivisioni speciali (SYSVOL e NETLOGON) e le condivisioni amministrative diverse dalle condivisioni con lettera di unità (ADMIN$, FAX$, IPC$ e PRINT$) possono essere modificate singolarmente selezionando l'azione Aggiorna e specificando il nome della condivisione.

Limite utenti

Configura il numero di utenti che possono connettersi simultaneamente alla condivisione.

  • Per limitare il numero di utenti, selezionare Numero consentito e immettere il numero massimo consentito.

  • Per non porre alcuna restrizione al numero di utenti, selezionare Massimo consentito.

  • Per lasciare invariato il numero consentito di utenti quando si aggiorna una condivisione, selezionare Nessun cambiamento.

    Nota

    Se si crea o si sostituisce una condivisione, la selezione di Nessun cambiamento configura il numero di utenti senza alcuna restrizione.

Queste opzioni sono disponibili solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Enumerazione basata sull'accesso

Configura la visibilità delle cartelle contenute nella condivisione.

  • Per rendere le cartelle della condivisione visibili solo a chi ha l'accesso in lettura, selezionare Abilita.

  • Per rendere le cartelle della condivisione visibili a tutti gli utenti, selezionare Disabilita.

  • Per lasciare invariata la visibilità delle cartelle all'interno della condivisione quando si aggiorna la condivisione, selezionare Nessuna modifica.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Ulteriori considerazioni

  • Gli elementi Condivisione di rete creano, modificano o eliminano i punti di condivisione ma non le cartelle a cui essi fanno riferimento. Per creare un punto di condivisione, la cartella da condividere deve esistere già nei computer a cui viene applicato l'oggetto Criteri di gruppo. Quando si elimina una condivisione, il punto di condivisione che fa riferimento alla cartella viene rimosso ma la cartella e il relativo contenuto non vengono eliminati.

  • Per informazioni su come utilizzare un elemento preferenza Cartella per creare o eliminare le cartelle mediante Criteri di gruppo, vedere Estensione Cartelle.

  • L'opzione Enumerazione basata sull'accesso è valida solo se nei computer che ospitano le cartelle condivise è installato il sistema operativo Windows Server® 2003 Service Pack 1 o versione successiva oppure Windows Server® 2008 R2 o Windows Server 2008.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Condivisioni di rete

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Registro di sistema

In Criteri di gruppo è inclusa l'estensione della preferenza Registro di sistema. Per i computer o gli utenti, questa estensione consente di:

  • Copiare più impostazioni del Registro di sistema da un computer e di applicarle ad altri computer.

  • Creare, sostituire o eliminare un singolo valore del Registro di sistema.

  • Creare una chiave vuota, eliminare una chiave o eliminare tutti i valori e le sottochiavi di una chiave.

  • Creare raccolte (cartelle) per organizzare gli elementi preferenza Registro di sistema nella Console Gestione Criteri di gruppo per poter applicare la stessa destinazione a più elementi Registro di sistema.

  • Creare raccolte nella Console Gestione Criteri di gruppo che riflettono specularmente la struttura delle chiavi del Registro di sistema in un computer selezionato.

Informazioni ntroduttive

È possibile creare e configurare elementi preferenza Registro di sistema per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ Registro di sistema

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Creare più elementi Registro di sistema con Creazione guidata Registro di sistema

  • Configurare un elemento Registro di sistema

  • Configurare opzioni comuni

  • Organizzare elementi Registro di sistema


Creare più elementi Registro di sistema con Creazione guidata Registro di sistema

La Creazione guidata Registro di sistema consente di creare più elementi preferenza Registro di sistema in base alle impostazioni del Registro di sistema selezionate in un computer. Gli elementi preferenza Registro di sistema contengono chiavi e valori del Registro di sistema analoghi a quelli selezionati. Tali elementi preferenza possono comunque essere modificati dopo la creazione. La procedura guidata consente di organizzare gli elementi Registro di sistema in una struttura di raccolta (cartella) analoga alla struttura del Registro di sistema. Ogni elemento Registro di sistema generato dalla procedura guidata consente di configurare una chiave o un valore del Registro di sistema di Windows.

Per creare più elementi preferenza Registro di sistema

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Registro di sistema, scegliere Nuovo e selezionare Creazione guidata Registro di sistema.

  4. Selezionare il computer in cui si trovano le impostazioni del Registro di sistema desiderate oppure il computer in cui si trovano impostazioni simili da modificare, quindi fare clic su Avanti.

  5. Individuare e selezionare la casella di controllo di ogni chiave o valore da cui si desidera creare un elemento preferenza Registro di sistema. Selezionare la casella di controllo di una chiave solo se si desidera creare un elemento Registro di sistema per la chiave anziché per un valore all'interno della chiave.

  6. Fare clic su Fine. Le impostazioni selezionate vengono visualizzate come elementi preferenza nella raccolta Valori Creazione guidata Registro di sistema.

  7. Fare clic con il pulsante destro del mouse sulla raccolta Valori Creazione guidata Registro di sistema nell'albero della console, scegliere Rinomina e digitare un nome descrittivo per la raccolta.

Ulteriori considerazioni

  • È possibile modificare le impostazioni nei singoli elementi preferenza Registro di sistema creati dalla Creazione guidata Registro di sistema. Per ulteriori informazioni, vedere Configurare un elemento Registro di sistema.

  • È possibile riorganizzare elementi preferenza e raccolte Registro di sistema trascinandoli nelle raccolte create. La struttura delle raccolte di elementi preferenza del Registro di sistema non ha alcun effetto sulla posizione delle chiavi e dei valori del Registro di sistema di Windows. Per ulteriori informazioni, vedere Organizzare elementi Registro di sistema.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Registro di sistema

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Registro di sistema

Gli elementi preferenza Registro di sistema consentono di creare, aggiornare, sostituire ed eliminare chiavi e valori (inclusi nome, tipo e dati) del Registro di sistema di Windows. Prima di creare un elemento preferenza Registro di sistema, è necessario verificare il comportamento di ogni tipo di azione possibile con questa estensione.

Creare un elemento Registro di sistema

Per creare un nuovo elemento preferenza Registro di sistema

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Registro di sistema scegliere Nuovo e fare clic su Elemento Registro di sistema.

  4. Nella finestra di dialogo Nuovo elemento Registro di sistema selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni del Registro di sistema da configurare o rimuovere per Criteri di gruppo. Per ulteriori informazioni, vedere la sezione "Impostazioni del Registro di sistema" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che la chiave o il valore del Registro di sistema esista già.

Crea | Consente di creare un nuovo valore o una nuova chiave del Registro di sistema per i computer o gli utenti.
Elimina | Consente di rimuovere un valore o una chiave del Registro di sistema e tutti i relativi valori e sottochiavi per i computer o gli utenti.
Sostituisci | Consente di eliminare e ricreare un nuovo valore o una nuova chiave del Registro di sistema per i computer o gli utenti. Se la destinazione è un valore del Registro di sistema, il risultato dell'azione Sostituisci consiste nel sovrascrivere tutte le impostazioni esistenti associate al valore del Registro di sistema. Se la destinazione è una chiave del Registro di sistema, il risultato consiste nell'eliminare tutti i valori e le sottochiavi della chiave, lasciando solo un nome di valore predefinito senza dati. Se il valore o la chiave del Registro di sistema non esiste, l'azione Sostituisci consente di creare un nuovo valore o una nuova chiave.
Aggiorna | Consente di modificare le impostazioni di un valore o di una chiave del Registro di sistema esistente per i computer o gli utenti. Questa azione è diversa da Sostituisci, in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. Tutte le altre impostazioni rimangono configurate come specificato nel valore o nella chiave del Registro di sistema. Se il valore o la chiave del Registro di sistema non esiste l'azione Aggiorna consente di creare un nuovo valore o una nuova chiave.

Impostazioni del Registro di sistema

È possibile fare clic sul pulsante Sfoglia accanto al campo Percorso chiave per passare al valore o alla chiave del Registro di sistema da configurare.

…

Se il valore o la chiave del Registro di sistema da configurare è disponibile nel computer in uso, fare clic su … per visualizzare il valore o la chiave. I restanti campi della finestra di dialogo Proprietà vengono compilati in base alla selezione effettuata. I valori di tali campi possono tuttavia essere modificati.

Per selezionare una chiave senza specificare un valore, oppure se il valore non esiste ancora, fare clic sulla chiave nell'albero disponibile nella parte superiore della finestra e quindi fare clic su Seleziona.

Hive

Se si è visualizzato un valore o una chiave, selezionare l'hive della chiave del Registro di sistema.

  • HKEY_CLASSES_ROOT è un alias per HKEY_LOCAL_MACHINE\Software\Classes.

  • HKEY_CURRENT_USER è un alias per HKEY_USERS\hive utente connesso. HKEY_USERS\.Default viene utilizzato quando il valore di HKEY_CURRENT_USER è impostato in Configurazione computer.

  • HKEY_LOCAL_MACHINE è l'opzione predefinita per i criteri del computer. Queste impostazioni influiscono su tutti gli utenti del computer.

  • HKEY_LOCAL_MACHINE è l'opzione predefinita per i criteri utente. Queste impostazioni influiscono sui singoli utenti.

  • HEKY_CURRENT_CONFIG è un alias per HEKY_LOCAL_MACHINE\System\CurrentControlSet\Hardware Profiles\Current.

Percorso chiave

Se non si è visualizzato un valore o una chiave, digitare il percorso della chiave. Non includere l'hive oppure una barra iniziale o finale.

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nome valore

Per configurare un valore, selezionare la casella di controllo Predefinito per configurare il valore predefinito della chiave oppure digitare il nome del valore da configurare. Per configurare solo una chiave, lasciare vuoto il campo.

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Tipo valore

Per configurare un valore, selezionare il tipo di valore. Per configurare solo una chiave, lasciare vuoto il campo.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna e se è stato immesso un Nome valore.

Dati valore

Per configurare i dati del valore, digitare i dati per il valore del Registro di sistema. Per configurare solo una chiave, lasciare vuoto il campo.

Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna e se è stato selezionato un Tipo valore.

Ulteriori considerazioni

  • Tramite la Creazione guidata Registro di sistema è possibile creare più elementi preferenza Registro di sistema in base alle impostazioni del Registro di sistema selezionate. Per ulteriori informazioni, vedere Creare più elementi Registro di sistema con Creazione guidata Registro di sistema.

  • È possibile organizzare gli elementi preferenza Registro di sistema trascinandoli nelle raccolte create. La struttura delle raccolte di elementi preferenza del Registro di sistema non ha alcun effetto sulla posizione delle chiavi e dei valori del Registro di sistema di Windows. Per ulteriori informazioni, vedere Organizzare elementi Registro di sistema.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Registro di sistema

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Organizzare elementi Registro di sistema

È possibile organizzare gli elementi preferenza Registro di sistema in cartelle denominate raccolte in modo da applicare la stessa destinazione a tutti gli elementi Registro di sistema della raccolta oppure per riprodurre la struttura delle impostazioni del Registro di sistema. La struttura delle raccolte di elementi preferenza Registro di sistema non ha alcun effetto sulla posizione delle chiavi e dei valori del Registro di sistema di Windows.

Per creare una nuova raccolta di elementi preferenza Registro di sistema

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Registro di sistema oppure su una cartella raccolte al di sotto del nodo, selezionare Nuovo e fare clic su Elemento raccolta.

  4. Digitare un nome per la cartella raccolte.

  5. La nuova cartella raccolte verrà visualizzata nell'albero della console.

  6. Fare clic con il pulsante destro del mouse sulla cartella raccolte, selezionare Nuovo e fare clic su Elemento Registro di sistema o su Elemento raccolta per creare un elemento Registro di sistema o una sottocartella all'interno di questa cartella raccolte oppure trascinare nella cartella raccolte elementi o raccolte Registro di sistema esistenti.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Registro di sistema

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Collegamenti

Criteri di gruppo include l'estensione della preferenza Collegamenti. Per i computer o gli utenti, questa estensione consente di:

  • Creare un collegamento.

  • Modificare le proprietà di un collegamento.

  • Eliminare un collegamento.

Informazioni introduttive

È possibile creare e configurare gli elementi preferenza Collegamento per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni di Windows

└ Collegamenti

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Collegamento

  • Configurare opzioni comuni


Configurare un elemento Collegamento

Gli elementi preferenza Collegamento consentono di configurare un collegamento a un oggetto del file system (ad esempio un file, una cartella, un'unità, una condivisione o un computer), a un oggetto della shell (ad esempio una stampante, un elemento del desktop o un elemento del Pannello di controllo) oppure a un URL (ad esempio una pagina Web o un sito FTP): Prima di creare un elemento preferenza Collegamento, è consigliabile esaminare il comportamento di ogni tipo di azione possibile con questa estensione.

Creare un elemento Collegamento

Per creare un nuovo elemento preferenza Collegamento

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Collegamenti, scegliere Nuovo e quindi Collegamento.

  4. Nella finestra di dialogo Proprietà nuovo elemento Collegamento selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Specificare le impostazioni del collegamento da configurare o rimuovere in Criteri di gruppo. Per ulteriori informazioni, vedere "Impostazioni del collegamento" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che il collegamento esista già o meno.

Crea | Consente di creare un nuovo collegamento per computer o utenti.
Elimina | Consente di rimuovere un collegamento per computer o utenti.
Sostituisci | Consente di eliminare e ricreare un collegamento per computer o utenti. L'azione Sostituisci determina sostanzialmente la sovrascrittura del collegamento esistente. Se il collegamento non esiste, l'opzione Sostituisci consente di creare un nuovo collegamento.
Aggiorna | Consente di modificare le impostazioni di un collegamento esistente per computer o utenti. Questa azione è diversa da Sostituisci in quanto consente di aggiornare solo le impostazioni del collegamento definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane immutata nel collegamento. Se il collegamento non esiste, l'azione Aggiorna consente di creare un nuovo collegamento.

Impostazioni del collegamento

Nome

Digitare un nome visualizzato per il collegamento. Se si modifica o si elimina un collegamento, il nome immesso deve corrispondere a quello del collegamento esistente.

Tipo di destinazione

Selezionare il tipo di destinazione a cui deve puntare il collegamento. Se si modifica o si elimina un collegamento, il tipo di destinazione selezionato deve corrispondere a quello del collegamento esistente.

Se è possibile impostare la destinazione del collegamento:

  • Con un percorso di Windows (ad esempio un file, una cartella, un'unità, una condivisione o un computer), fare clic su Oggetto file system.

  • Con un URL (ad esempio una pagina Web, un sito Web o un sito FTP), fare clic su URL.

  • Come un oggetto all'interno della shell di Windows (ad esempio una stampante, un elemento del desktop o del Pannello di controllo, un file, una cartella, una condivisione, un computer o una risorsa di rete), fare clic su Oggetto shell.

Percorso

Selezionare il percorso in cui inserire il collegamento nei computer di destinazione dell'elemento preferenza. I percorsi diversi da All Users sono relativi all'utente connesso. Se si modifica un collegamento esistente, il percorso selezionato deve corrispondere a quello del collegamento esistente. Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Per inserire il collegamento in una sottocartella nel percorso, immettere il percorso della sottocartella nel campo Nome seguito dal nome visualizzato. Ad esempio, per inserire un collegamento con nome visualizzato Collegamento personale nella sottocartella Azienda della cartella Preferiti, digitare Azienda\Collegamento personale nel campo Nome e selezionare Preferiti come Percorso.

Se si seleziona <Impostazione percorso completo>, digitare il percorso completo seguito dal nome visualizzato nel campo Nome. Ad esempio, per inserire un collegamento con nome visualizzato Collegamento personale nella sottocartella Azienda della cartella Programmi, digitare %ProgramFilesDir%\Azienda\Collegamento personale nel campo Nome e selezionare <Impostazione percorso completo> come Percorso.

Percorso di destinazione

Immettere un percorso locale, un percorso UNC o una lettera di unità a cui condurrà il collegamento. Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile solo se per Tipo di destinazione è selezionato Oggetto file system e l'azione è Crea, Sostituisci o Aggiorna.

URL di destinazione

Immettere un URL a cui condurrà il collegamento. Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile solo se per Tipo di destinazione è selezionato URL e l'azione è Crea, Sostituisci o Aggiorna.

Oggetto di destinazione

Selezionare l'oggetto della shell (ad esempio una stampante, un elemento del desktop o del Pannello di controllo, un file, una cartella, una condivisione, un computer o una risorsa di rete) a cui condurrà il collegamento.

Questa opzione è disponibile solo se per Tipo di destinazione è selezionato Oggetto shell e l'azione è Crea, Sostituisci o Aggiorna.

Argomenti

Digitare uno o più argomenti da utilizzare per l'apertura del file o della cartella di destinazione.

Questa opzione è disponibile solo se per Tipo di destinazione è selezionato Oggetto file system e l'azione è Crea, Sostituisci o Aggiorna.

Da

Per specificare una directory di lavoro contenente i file necessari per la destinazione, digitare il percorso della cartella. Non includere virgolette o barre finali. Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile solo se per Tipo di destinazione è selezionato Oggetto file system e l'azione è Crea, Sostituisci o Aggiorna.

Tasti di scelta rapida

Per specificare una combinazione di tasti di scelta rapida che consentano di avviare il collegamento, fare clic nel campo Tasti di scelta rapida e premere la combinazione di tasti desiderata. Per rimuovere i tasti di scelta rapida, premere CANC o BACKSPACE.

Questa opzione è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Esegui

Selezionare la dimensione della finestra in cui aprire la destinazione del collegamento.

Questa opzione è disponibile solo se per Tipo di destinazione è selezionato Oggetto file system o Oggetto shell e l'azione è Crea, Sostituisci o Aggiorna.

Commento

Per visualizzare una descrizione comando quando si ferma il puntatore del mouse sul collegamento, digitarne il testo. Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Questa opzione è disponibile solo se per Tipo di destinazione è selezionato Oggetto file system o Oggetto shell e l'azione è Crea, Sostituisci o Aggiorna.

Percorso file icona e Indice icone

Per specificare un'icona per il collegamento diversa da quella predefinita per il relativo tipo, selezionare un file icona o un'icona. È inoltre possibile digitare il percorso completo di un'icona e quindi un indice di icone. Non includere virgolette. Il campo Percorso file icona accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Queste opzioni sono disponibili solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Ulteriori considerazioni

  • Poiché le unità mappate esistono solo per gli utenti, qualora uno o più percorsi nella configurazione del collegamento includessero un'unità mappata, l'elemento preferenza Collegamento dovrà trovarsi in Configurazione utente, la lettera di unità dovrà esistere già al momento dell'elaborazione del collegamento e l'opzione Esegui nel contesto di sicurezza dell'utente connesso dovrà essere selezionata nella scheda Comuni.

  • Per impostazione predefinita, le variabili in Percorso di destinazione vengono risolte da Criteri di gruppo prima della creazione o della modifica del collegamento. Per includere la variabile invece del relativo valore risolto nel collegamento, in modo che la variabile venga risolta nell'ambiente del computer in cui il collegamento viene applicato, utilizzare la sintassi della variabile non risolta, ad esempio %<ProgramFiles>% invece di %ProgramFiles%.

    Poiché questo tipo di sintassi viene risolto nell'ambiente dei computer a cui viene applicato il collegamento, utilizzare solo variabili di ambiente e non variabili di elaborazione delle preferenze.

  • I percorsi specifici dell'utente vengono risolti in .default quando si applica un collegamento al computer.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Collegamenti

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Impostazioni del Pannello di controllo

Console Gestione criteri di gruppo consente di configurare preferenze quando si modifica un oggetto Criteri di gruppo basato su dominio. Il nodo Preferenze viene visualizzato in Configurazione computer e Configurazione utente. Nell'editor le estensioni delle preferenze sono visualizzate in due categorie: Impostazioni di Windows e Impostazioni del Pannello di controllo.

Le estensioni preferenza in Impostazioni del Pannello di controllo includono:

  • Estensione Origini dati: consente di creare, modificare o eliminare i nomi di origini dati ODBC (Open Database Connectivity).

  • Estensione Dispositivi: consente di attivare o disattivare dispositivi hardware o classi di dispositivi.

  • Estensione Opzioni cartella: consente di configurare opzioni cartella, creare, modificare o eliminare associazioni Apri con per le estensioni dei nomi di file, nonché creare, modificare o eliminare le estensioni dei nomi di file associate a un tipo di file.

  • Estensione Impostazioni Internet: consente di modificare le impostazioni Internet configurabili dall'utente.

  • Estensione Utenti e gruppi locali: consente di creare, modificare o eliminare utenti e gruppi locali.

  • Estensione Opzioni rete: consente di creare, modificare o eliminare connessioni VPN o connessioni remote.

  • Estensione Opzioni risparmio energia: consente di modificare le opzioni di risparmio energia e creare, modificare o eliminare le combinazioni risparmio energia.

  • Estensione Stampanti: consente di creare, modificare o eliminare connessioni a stampanti TCP/IP, condivise e locali.

  • Estensione Opzioni internazionali: consente di modificare le opzioni internazionali.

  • Estensione Attività pianificate: consente di creare, modificare o eliminare attività immediate o pianificate.

  • Estensione Servizi: consente di modificare i servizi.

  • Estensione Menu Start: consente di modificare le opzioni del menu Start.

Ulteriori riferimenti

  • Configurare e commentare elementi preferenza e definirne la destinazione


Estensione Origini dati

In Criteri di gruppo è inclusa l'estensione della preferenza Origini dati. Tale estensione consente di configurare in modo centralizzato i nomi di origini dati ODBC (Open Database Connectivity) per utenti o computer.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Origini dati per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Origini dati

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Origine dati

  • Configurare opzioni comuni


Configurare un elemento Origine dati

Gli elementi preferenza Origine dati consentono di creare, aggiornare, sostituire ed eliminare origini dati di sistema e dell'utente. Le origini dati contengono informazioni sulla modalità di connessione a un provider di dati. Prima di creare un elemento preferenza Origine dati, è necessario verificare il comportamento di ogni tipo di azione possibile con questa estensione.

Creare un elemento Origine dati

Per creare un nuovo elemento preferenza Origine dati

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Origini dati, scegliere Nuovo e fare clic su Origine dati.

  4. Nella finestra di dialogo Proprietà nuovo elemento Origine dati selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni dell'origine dati da configurare o rimuovere per Criteri di gruppo. Per ulteriori informazioni, vedere la sezione "Impostazioni di origini dati" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia in base all'azione selezionata e all'esistenza o meno di un'origine dati con lo stesso nome.

Crea | Consente di creare un nuovo nome di origine dati per l'utente o il computer. Se l'origine dati esiste, non deve essere modificata.
Elimina | Consente di rimuovere un nome di origine dati dall'utente o dal computer. L'estensione non esegue alcuna azione se l'origine dati non esiste.
Sostituisci | Consente di eliminare e ricreare un nome di origine dati per l'utente o il computer. Il risultato dell'azione Sostituisci consiste nel sovrascrivere tutte le impostazioni esistenti associate al nome dell'origine dati. Se il nome dell'origine dati non esiste, l'azione Sostituisci crea il nuovo nome dell'origine dati.
Aggiorna | Consente di modificare le impostazioni di un nome di origine dati esistente. Questa azione è diversa da Sostituisci, in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se il nome dell'origine dati non esiste, l'azione Aggiorna crea un nuovo nome dell'origine dati.

Impostazioni di origini dati

Origine dati utente oppure Origine dati di sistema

Selezionare la visibilità del nome dell'origine dati. Le origini dati utente sono disponibili per gli utenti che ricevono l'elemento preferenza. Le origini dati di sistema sono disponibili per tutti gli utenti del computer, incluso il sistema locale.

Nome origine dati

Digitare il nome utilizzato per identificare l'origine dati. Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare. È possibile importare un nome di origine dati locale nell'elemento preferenza origine dati. Fare clic su Sfoglia (…) per visualizzare un elenco dei nomi delle origini dati disponibili nel computer in uso.

Importante

Gli attributi vengono popolati automaticamente durante l'importazione di un nome di origine dati esistente in un elemento preferenza origine dati.

Driver

Digitare il nome del driver ODBC utilizzato per connettersi al provider di dati. Fare clic su Sfoglia (…) per selezionare il driver in un elenco di driver ODBC.

Descrizione

Immettere un testo utilizzato per descrivere l'origine dati. Questo campo accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nome utente

Digitare il nome utente utilizzato per connettersi al provider di dati indicato.

Password

Digitare la password utilizzata per connettersi al provider di dati indicato. Digitare la stessa password nella casella Conferma Password.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Attributi

Gli attributi dell'elemento Origine dati consentono di fornire informazioni aggiuntive per il provider di dati. Ogni attributo è costituito da un nome di attributo e dal relativo valore associato.

  • Fare clic su Aggiungi per creare nuovi attributi nell'elemento Origine dati.

  • Fare clic su Rimuovi per eliminare attributi esistenti.

  • Fare clic su Modifica per modificare il nome o il valore dell'attributo.

Importante

Gli attributi vengono popolati automaticamente durante l'importazione di un nome di origine dati esistente in un elemento preferenza Origine dati.

Ulteriori considerazioni

  • Utilizzare l'azione Aggiorna per aggiungere o sovrascrivere gli attributi di nomi di origini dati esistenti.

  • Utilizzare l'azione Sostituisci per rimuovere attributi da nomi di origini dati esistenti.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Origini dati

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Dispositivi

In Criteri di gruppo è inclusa l'estensione della preferenza Dispositivi. Questa estensione consente di abilitare o disabilitare centralmente classi o tipi specifici di dispositivi hardware per utenti o computer.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Dispositivo per qualsiasi oggetto Criteri di gruppo (GPO) basato sul dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Dispositivi

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Dispositivo

  • Configurare opzioni comuni


Configurare un elemento Dispositivo

Gli elementi preferenza Dispositivo consentono di attivare o disattivare classi o tipi di dispositivi hardware. Le classi di dispositivi consentono di attivare o disattivare una gamma più vasta di tipi di dispositivi, mentre i tipi di dispositivi consentono di attivare o disattivare un tipo specifico di dispositivo hardware. Se ad esempio si disattiva la classe di dispositivi Unità DVD/CD-ROM, verranno disattivati tutti i dispositivi hardware inclusi nella classe selezionata. Se invece si disattiva il tipo di dispositivo Dispositivo MS ATA CD/DVD-ROM, verranno disattivati solo i dispositivi hardware di tale tipo e non l'intera classe. Prima di creare un elemento preferenza Dispositivo, è opportuno esaminare il comportamento di ogni tipo di azione possibile rispetto all'estensione.

Importante

Assicurarsi di provare gli elementi preferenza Dispositivo prima di distribuirli in un ambiente di produzione. La disattivazione dei dispositivi potrebbe impedire il corretto funzionamento di Windows.

Creare un elemento Dispositivo

Per creare un nuovo elemento preferenza Dispositivo

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Dispositivi, scegliere Nuovo e quindi Dispositivo.

  4. Nella finestra di dialogo Proprietà nuovo elemento Dispositivo selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni relative al dispositivo da configurare o rimuovere per Criteri di gruppo. Per ulteriori informazioni, vedere "Impostazioni del dispositivo" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Utilizza questo dispositivo (attiva) | Consente di attivare una classe o un tipo di dispositivo corrispondente.
Non utilizzare questo dispositivo (disattiva) | Consente di disattivare una classe o un tipo di dispositivo corrispondente.

Impostazioni del dispositivo

Classe dispositivo | Questa impostazione contiene il nome della classe di dispositivo attivata o disattivata. Unità DVD/CD-ROM rappresenta un esempio di classe di dispositivo. Fare clic su Sfoglia (…) per selezionare una classe nell'elenco delle classi di dispositivo disponibili nel computer.
Tipo di dispositivo | Questa impostazione contiene il nome del tipo di dispositivo attivato o disattivato. Dispositivo MS ATA CD/DVD-ROM rappresenta un esempio di tipo di dispositivo. Per selezionare un tipo di dispositivo, fare clic su Sfoglia (…) accanto alla casella Classe dispositivo. Espandere una classe di dispositivo per visualizzare l'elenco dei tipi di dispositivo disponibili nel computer.

Ulteriori considerazioni

  • Gli elementi preferenza Dispositivo applicati ai computer influiscono su tutti gli utenti del computer di destinazione. Applicare gli elementi preferenza agli utenti se si desidera controllare gli utenti per i quali sono attivati o disattivati tipi e classi di dispositivo.

  • Non è possibile disattivare alcuni dispositivi visualizzati in Gestione dispositivi.

  • La disattivazione di un dispositivo ha effetto immediato. È tuttavia possibile che in Gestione dispositivi l'elemento o la classe di dispositivo venga visualizzato come disattivato con un leggero ritardo. Per informazioni sullo stato corrente, controllare le proprietà del dispositivo.

  • L'opzione Rimuovi elemento quando non viene più applicato è disponibile solo se l'azione elemento è impostata su Non utilizzare questo dispositivo (disattiva). La rimozione dell'elemento preferenza implica l'attivazione del dispositivo.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Dispositivi

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Opzioni cartella

In Criteri di gruppo è inclusa l'estensione della preferenza Opzioni cartella. Questa estensione consente di configurare diverse impostazioni di Esplora risorse, ad esempio le associazioni di tipo di file e avvio dell'applicazione, nonché le opzioni di visualizzazione delle cartelle.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Tipo di file, Apri con e Opzioni cartella per qualsiasi oggetto Criteri di gruppo (GPO) basato sul dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Opzioni cartella

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Opzioni cartella (Windows Vista e versioni successive)

  • Configurare un elemento Apri con

  • Configurare un elemento Tipo di file

  • Configurare un elemento Opzioni cartella (Windows XP)

  • Configurare opzioni comuni


Configurare un elemento Opzioni cartella (Windows Vista e versioni successive)

L'elemento preferenza Opzioni cartella (Windows Vista® e versioni successive) consente di configurare impostazioni diverse per la visualizzazione delle cartelle di Esplora risorse. L'estensione della preferenza Opzioni cartella consente di utilizzare l'azione Aggiorna per elaborare gli elementi Opzioni cartella.

Creare un elemento preferenza Opzioni cartella (Windows Vista e versioni successive)

Per creare un nuovo elemento preferenza Opzioni cartella

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni cartella, scegliere Nuovo e quindi Opzioni cartella (Windows Vista e versioni successive).

  4. Nella finestra di dialogo Proprietà nuovo elemento Opzioni cartella immettere le impostazioni relative alle opzioni cartella da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Gli elementi Opzioni cartella (Microsoft Windows Vista e versioni successive) si applicano a computer che eseguono Windows Server® 2008 R2, Windows® 7, Windows Server 2008 o Microsoft Windows Vista. Utilizzare l'elemento preferenza Opzioni cartella (Windows XP) per configurare le impostazioni delle opzioni cartella per computer che eseguono Windows Server 2003 e Windows XP.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni cartella

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Apri con

L'elemento preferenza Apri con consente di creare, configurare ed eliminare un'associazione Apri con a un' estensione di file specifica. Prima di creare un elemento preferenza Apri con, è opportuno esaminare il comportamento di ogni tipo di azione possibile con l'estensione.

Creare un elemento Apri con

Per creare un nuovo elemento preferenza Apri con

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni cartella, scegliere Nuovo e selezionare Apri con.

  4. Nella finestra di dialogo Proprietà nuovo elemento Apri con selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni di Apri con che Criteri di gruppo deve configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni di Apri con" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno un'associazione Apri con.

Crea | Crea una nuova associazione Apri con. Se nel profilo utente è presente un'estensione di file nell'elemento Apri con, la nuova associazione non viene creata.
Elimina | Rimuove un'associazione esistente Apri con. Un'associazione esiste se l'estensione di file nell'elemento Apri con è presente nel profilo utente. Non viene eseguita alcuna azione se l'associazione non esiste.
Sostituisci | Elimina e ricrea un'associazione Apri con. Il risultato finale dell'azione Sostituisci è costituito dalla sovrascrittura di tutte le impostazioni esistenti associate all'associazione Apri con. Se l'associazione Apri con non esiste, l'azione Sostituisci ne crea una nuova.
Aggiorna | Modifica un'associazione Apri con. Questa azione è diversa da Sostituisci, in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se l'associazione Apri con non esiste, l'azione Aggiorna ne crea una nuova.

Impostazioni di Apri con

Estensione di file

Digitare l'estensione del file da associare all'applicazione specificata. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nota

Non è necessario inserire il punto prima dell'estensione del nome di file.

Programma associato

Digitare il percorso e il nome dell'applicazione che si desidera associare all'estensione di file. In alternativa è possibile fare clic su Sfoglia (…) e selezionare l'applicazione. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Predefinita

Selezionare questa casella di controllo per far sì che l'applicazione associata sia quella predefinita utilizzata da Windows per aprire l'estensione di file.

Ulteriori considerazioni

  • Apri con viene visualizzato nel menu di scelta rapida di Esplora risorse se esistono più associazioni Apri con.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni cartella

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Tipo di file

L'elemento preferenza Tipo di file consente di creare, configurare ed eliminare estensioni di file associate a una determinata classe di file, ad esempio documenti di testo. Consente inoltre di associare a tipi di file specifici applicazioni per l'apertura, la modifica o l'esecuzione di altre azioni, nonché icone. Prima di creare un elemento preferenza Tipo di file, è opportuno esaminare il comportamento di ogni tipo di azione possibile rispetto all'elemento.

Creare un elemento Tipo di file

Per creare un nuovo elemento preferenza Tipo di file

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni cartella, scegliere Nuovo e quindi Tipo di file.

  4. Nella finestra di dialogo Proprietà nuovo elemento Tipo di file selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni relative al tipo di file da configurare o rimuovere per Criteri di gruppo. Per ulteriori informazioni, vedere "Impostazioni del tipo di file" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno un'associazione per il tipo di file.

Crea | Consente di creare una nuova associazione per il tipo di file. Se l'estensione di file nell'elemento Tipo di file è registrata nel computer, la nuova associazione per il tipo di file non verrà creata.
Elimina | Consente di rimuovere un'associazione esistente per il tipo di file. Un'associazione esiste quando l'estensione di file nell'elemento Tipo di file è registrata nel computer. Se l'associazione non esiste, non viene eseguita nessuna azione.
Sostituisci | Consente di eliminare e creare nuovamente l'associazione per il tipo di file. L'esecuzione dell'azione Sostituisci implica la sovrascrittura di tutte le impostazioni esistenti associate all'associazione per il tipo di file. Se l'associazione non esiste, l'azione Sostituisci consente di crearne una nuova.
Aggiorna | Consente di modificare un'associazione per il tipo di file. Questa azione è diversa da Sostituisci, in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se l'associazione non esiste, l'azione Aggiorna consente di crearne una nuova.

Impostazioni del tipo di file

Estensione file

Digitare l'estensione del file da associare all'applicazione specificata. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nota

Non è necessario inserire il punto prima dell'estensione del nome di file.

Classe associata

Scegliere nell'elenco delle classi registrate quella che si desidera associare al tipo di file. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Configurare le impostazioni delle classi

Selezionare Configura impostazioni classi per configurare le impostazioni avanzate delle classi.

  • Per associare un'icona di file all'estensione di file, digitare il percorso completo nella casella Percorso file icona. In alternativa, è possibile utilizzare il pulsante (…) per individuare e selezionare il percorso del file. In tal caso la casella Indice icone verrà popolata automaticamente.

  • Per associare le applicazioni per l'apertura, la modifica e l'esecuzione di altre azioni su questo tipo di file specifico, fare clic su Nuovo. Digitare il nome del comando visualizzato da Windows nel menu di scelta rapida e il programma che verrà avviato unitamente a eventuali specifiche obbligatorie. Fare clic su OK.

Ulteriori considerazioni

  • Ogni sottoazione configurata sostituisce in pieno eventuali sottoazioni con lo stesso nome registrate in precedenza sotto la classe associata. Oltre a sovrascrivere una sottoazione, l'elemento non supporta la rimozione di sottoazioni o altri elementi nell'elenco Azioni.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni cartella

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Opzioni cartella (Windows XP)

L'elemento preferenza Opzioni cartella (Windows XP) consente di configurare diverse impostazioni per la visualizzazione delle cartelle di Esplora risorse. L'estensione della preferenza Opzioni cartella consente di utilizzare l'azione Aggiorna per elaborare gli elementi Opzioni cartella.

Creare un elemento Opzioni cartella (Windows XP)

Per creare un nuovo elemento preferenza Opzioni cartella

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni cartella, scegliere Nuovo e fare clic su Opzioni cartella (XP).

  4. Nella finestra di dialogo Proprietà nuovo elemento Opzioni cartella immettere le opzioni di cartella da configurare per Criteri di gruppo. (Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.)

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Gli elementi Opzioni cartella (Windows XP) si applicano a computer che eseguono Windows Server 2003 e Windows XP. Utilizzare l'elemento preferenza Opzioni cartella (Windows Vista® e versioni successive) per configurare impostazioni relative alle opzioni cartella per computer che eseguono Windows Server® 2008 R2, Windows® 7, Windows Server 2008 o Microsoft Windows Vista.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni cartella

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Impostazioni Internet

In Criteri di gruppo è inclusa l'estensione della preferenza Impostazioni Internet. Per gli utenti, questa estensione consente di:

  • Richiedere una configurazione specifica delle impostazioni Internet.

  • Definire una configurazione iniziale delle impostazioni Internet, consentendo comunque agli utenti finali di apportare modifiche.

  • Configurare alcune impostazioni Internet consentendo ai singoli utenti finali di modificare le altre a propria discrezione. È ad esempio possibile specificare le impostazioni del server proxy consentendo agli utenti di modificare le opzioni relative all'accessibilità.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Internet Explorer per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Impostazioni Internet

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Internet Explorer 8

  • Configurare un elemento Internet Explorer 7

  • Configurare un elemento Internet Explorer 5 e 6

  • Configurare opzioni comuni


Configurare un elemento Internet Explorer 8

Gli elementi preferenza Internet Explorer 8 consentono di aggiornare le opzioni Internet per Internet Explorer 8, ma non offrono una selezione di azioni, in quanto l'unica azione possibile è Aggiorna.

Creare un elemento Internet Explorer

Per creare un nuovo elemento Internet Explorer

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Impostazioni Internet, scegliere Nuovo e quindi Internet Explorer 8.

  4. Nella finestra di dialogo Nuove proprietà Internet Explorer 8 immettere le opzioni Internet da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Le impostazioni che non possono essere attivate o disattivate non sono disponibili. Non è possibile configurare queste impostazioni tramite un elemento preferenza Internet Explorer.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Impostazioni Internet

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Internet Explorer 7

Gli elementi preferenza Internet Explorer 7 consentono di aggiornare le opzioni Internet per Internet Explorer 7, ma non forniscono una selezione di azioni in quanto l'unica azione possibile è Aggiorna.

Creare un elemento Internet Explorer

Per creare un nuovo elemento Internet Explorer

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Impostazioni Internet, scegliere Nuovo e fare clic su Internet Explorer 7.

  4. Nella finestra di dialogo Proprietà nuovo elemento Internet Explorer 7 immettere le opzioni Internet da configurare per Criteri di gruppo. (Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.)

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Le impostazioni che non possono essere attivate o disattivate non sono disponibili. Non è possibile configurare queste impostazioni tramite un elemento preferenza Internet Explorer.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Impostazioni Internet

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Internet Explorer 5 e 6

Gli elementi preferenza Internet Explorer 5 e 6 consentono di aggiornare le opzioni Internet per Internet Explorer 5 e 6, ma non forniscono una selezione di azioni, in quanto l'unica azione possibile è Aggiorna.

Creare un elemento Internet Explorer

Per creare un nuovo elemento Internet Explorer

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo impostazioni Internet, scegliere Nuovo e quindi fare clic su Internet Explorer 5 e 6.

  4. Nella finestra di dialogo Nuove proprietà Internet Explorer 5 e 6 immettere le opzioni Internet da configurare per Criteri di gruppo. (Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.)

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Le impostazioni che non possono essere attivate o disattivate non sono disponibili. Non è possibile configurare queste impostazioni tramite un elemento preferenza Internet Explorer.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Impostazioni Internet

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Utenti e gruppi locali

In Criteri di gruppo è inclusa l'estensione della preferenza Utenti e gruppi locali. Questa estensione consente di gestire centralmente gli utenti e i gruppi locali nei computer membri del dominio.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Utente locale e Gruppo locale per qualsiasi oggetto Criteri di gruppo (GPO) basato sul dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Utenti e gruppi locali

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Gruppo locale

  • Configurare un elemento Utente locale

  • Configurare opzioni comuni


Configurare un elemento Gruppo locale

Gli elementi preferenza Gruppo locale consentono di creare, eliminare e rinominare centralmente i gruppi locali. È inoltre possibile utilizzare questi elementi preferenza per modificare l'appartenenza ai gruppi locali. Prima di creare un elemento preferenza Gruppo locale, è opportuno esaminare il comportamento di ogni tipo di azione possibile con l'estensione.

Creare un elemento Gruppo locale

Per creare un nuovo elemento preferenza Gruppo locale

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Gruppi e utenti locali, scegliere Nuovo e selezionare Gruppo locale.

  4. Nella finestra di dialogo Proprietà nuovo elemento Gruppo locale selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni del gruppo locale che Criteri di gruppo deve configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni del gruppo locale" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno un gruppo con lo stesso nome.

Crea

Crea un nuovo gruppo locale nel computer locale. Se il gruppo locale esiste già, non viene modificato.

Elimina

Rimuove un gruppo locale con lo stesso nome dal computer locale. L'estensione non esegue alcuna azione se il gruppo non esiste.

Sostituisci

Elimina e ricrea un gruppo locale con lo stesso nome per il computer locale. Il risultato finale dell'azione Sostituisci è costituito dalla sovrascrittura di tutte le impostazioni esistenti associate al gruppo locale. Se il gruppo locale non esiste, l'azione Sostituisci ne crea uno nuovo.

Importante

Windows assegna a ogni gruppo un ID di sicurezza (SID) e utilizza questa informazione per stabilire se a un gruppo è consentito l'accesso a una determinata risorsa. Utilizzare con cautela l'azione Sostituisci in quanto al nuovo gruppo creato viene assegnato un nuovo ID di sicurezza, impedendo in tal modo al gruppo di accedere alle risorse.

Aggiorna

Rinomina o modifica le impostazioni, inclusa l'appartenenza, di un gruppo esistente. Questa azione è diversa da Sostituisci, in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se il gruppo locale non esiste, l'azione Aggiorna ne crea uno nuovo.

Importante

L'azione Aggiorna non modifica l'ID di sicurezza del gruppo.

Impostazioni del gruppo locale

Nome gruppo

Digitare il nome del gruppo locale di destinazione. L'estensione della preferenza crea un nuovo gruppo con questo nome se il gruppo non esiste. Se il gruppo esiste, l'estensione della preferenza utilizza il gruppo con questo nome come destinazione dell'azione richiesta.

Rinomina con:

Digitare il nuovo nome del gruppo locale. Questa opzione è disponibile solo se si utilizza l'azione Aggiorna. L'estensione della preferenza rinomina il gruppo sostituendo il nome nella casella Nome gruppo con il nome fornito nella casella Rinomina con.

Descrizione

Testo utilizzato per descrivere lo scopo o l'utilizzo del gruppo locale. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Aggiungi utente corrente

Utilizzare questa impostazione per includere come membro del gruppo locale l'utente attualmente connesso.

Nota

Questa impostazione è disponibile solo quando si modifica l'elemento preferenza in Configurazione utente.

Rimuovi utente corrente

Utilizzare questa impostazione per eliminare l'appartenenza al gruppo locale dell'utente attualmente connesso.

Nota

Questa impostazione è disponibile solo quando si modifica l'elemento preferenza in Configurazione utente.

Non configurare per l'utente corrente

Utilizzare questa impostazione se non si desidera aggiungere o rimuovere dal gruppo locale l'utente attualmente connesso.

Nota

Questa impostazione è disponibile solo quando si modifica l'elemento preferenza in Configurazione utente.

Elimina tutti gli utenti membri

Utilizzare questa impostazione per rimuovere tutti gli account utente membri del gruppo locale. L'estensione della preferenza esegue questa operazione prima di elaborare l'elenco dei membri definito nell'elemento preferenza.

Elimina tutti i gruppi membri

Utilizzare questa impostazione per rimuovere tutti gli account di gruppo membri del gruppo locale. L'estensione della preferenza esegue questa operazione prima di elaborare l'elenco dei membri definito nell'elemento preferenza.

Aggiungi

Fare clic su Aggiungi per immettere un nuovo membro nell'elenco dei membri.

  • Digitare il nome dell'utente o del gruppo che si desidera includere nell'elenco dei membri oppure fare clic su Sfoglia (…) per selezionare l'utente o il gruppo.

  • Scegliere l'azione desiderata per il membro nell'elenco Azione:

    • Aggiungi a questo gruppo: aggiunge il membro in questione al gruppo locale.

    • Rimuovi da questo gruppo: rimuove il membro in questione dal gruppo locale.

Rimuovi

Fare clic su Rimuovi per eliminare il membro attualmente selezionato dall'elenco dei membri.

Cambia

Fare clic su Cambia per modificare il membro attualmente selezionato.

  • Digitare il nome dell'utente o del gruppo che si desidera includere nell'elenco dei membri oppure fare clic su Sfoglia (…) per selezionare l'utente o il gruppo.

  • Scegliere l'azione desiderata per il membro nell'elenco Azione:

    • Aggiungi a questo gruppo: consente di aggiungere il membro specificato al gruppo locale.

    • Rimuovi da questo gruppo: consente di rimuovere il membro specificato dal gruppo locale.

Ulteriori considerazioni

  • Le appartenenze ai gruppi relative all'utente corrente hanno effetto a partire dal successivo accesso utente.

  • L'azione Sostituisci dell'elemento Gruppo locale elimina il gruppo locale esistente e crea un nuovo gruppo locale, che include un nuovo ID di sicurezza.

  • L'azione Aggiorna dell'elemento Gruppo locale modifica le impostazioni di un gruppo locale ma non ne cambia l'ID di sicurezza.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Utenti e gruppi locali

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Utente locale

Gli elementi preferenza Utente locale consentono di creare, eliminare e rinominare utenti locali in modo centralizzato. È inoltre possibile utilizzare questo elemento preferenza per cambiare la password degli utenti locali. Prima di creare un elemento preferenza Utente locale, è opportuno esaminare il comportamento di ogni tipo di azione possibile rispetto all'estensione.

Creare un elemento Utente locale

Per creare un nuovo elemento preferenza Utente locale

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Utenti e gruppi locali, scegliere Nuovo e quindi Utente locale.

  4. Nella finestra di dialogo Proprietà nuovo elemento Utente locale selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni relative all'utente locale da configurare o rimuovere per Criteri di gruppo. Per ulteriori informazioni, vedere "Impostazioni dell'utente locale" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno un utente con lo stesso nome oppure per gli account predefiniti un ID di sicurezza (SID).

Crea

Consente di creare un nuovo utente locale nel computer locale. Se l'utente locale esiste, non modificarlo.

Elimina

Consente di rimuovere dal computer locale un utente locale con il nome corrispondente. Se l'utente locale non esiste, l'estensione non esegue nessuna azione.

Sostituisci

Consente di eliminare dal computer locale un utente locale con il nome corrispondente e di crearlo nuovamente. L'esecuzione dell'azione Sostituisci implica la sovrascrittura di tutte le impostazioni esistenti associate all'utente locale. Se l'utente locale non esiste, l'azione Sostituisci consente di crearne uno nuovo.

Importante

Windows assegna un SID a ogni utente. Tali informazioni vengono utilizzate per determinare se a un utente è consentito accedere a una determinata risorsa. Prestare attenzione quando si utilizza l'azione Sostituisci poiché al nuovo utente creato viene associato un nuovo SID che potrebbe impedire agli utenti di accedere alle risorse.

Aggiorna

Consente di rinominare un utente o di modificare le impostazioni utente. Questa azione è diversa da Sostituisci, in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se l'utente locale non esiste, l'azione Aggiorna consente di crearne uno nuovo.

Importante

L'azione Aggiorna non comporta la modifica del SID dell'utente.

Impostazioni dell'utente locale

Nome utente

Digitare il nome dell'utente locale di destinazione. Se l'utente non esiste, l'estensione della preferenza ne creerà uno nuovo con questo nome. Se l'utente esiste, l'estensione della preferenza utilizzerà l'utente con tale nome come destinazione dell'azione richiesta.

Rinomina con

Digitare il nuovo nome dell'utente locale. Questa opzione è disponibile solo quando si utilizza l'azione Aggiorna. L'estensione della preferenza rinominerà l'utente il cui nome corrisponde a quello indicato nella casella Nome utente utilizzando il nome specificato nella casella Rinomina con.

Nome completo

Testo utilizzato per visualizzare il nome completo dell'utente locale. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Descrizione

Testo utilizzato per descrivere lo scopo o l'utilizzo dell'utente locale. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Password

Digitare la password utilizzata durante la creazione, la sostituzione o l'aggiornamento di un utente locale. Digitare la stessa password nella casella Conferma password.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Cambiamento obbligatorio password all'accesso successivo

Utilizzare questa impostazione se si desidera che l'utente locale appena creato o aggiornato modifichi la propria password all'accesso successivo.

Account disabilitato

Utilizzare questa impostazione se si desidera disattivare l'utente locale appena creato o aggiornato.

Nessuna scadenza account

Utilizzare questa impostazione se non si desidera che l'account dell'utente locale appena creato o aggiornato scada. Deselezionarla se si desidera forzare la scadenza dell'account dell'utente locale appena creato o aggiornato e quindi scegliere una data di scadenza nell'elenco Scadenza account.

Ulteriori considerazioni

  • L'azione Sostituisci dell'elemento Utente locale implica l'eliminazione dell'utente locale esistente e la creazione di nuovo utente locale che include un nuovo ID di sicurezza.

  • L'azione Aggiorna dell'elemento Utente locale implica la modifica delle impostazioni di un utente locale ma non dell'ID di sicurezza dell'utente locale.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Utenti e gruppi locali

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Opzioni rete

In Criteri di gruppo è inclusa l'estensione della preferenza Opzioni rete. Tale estensione consente di configurare connessioni VPN o remote.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Connessione VPN e Connessione remota per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Opzioni rete

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Connessione remota

  • Configurare un elemento Connessione VPN

  • Configurare opzioni comuni


Configurare un elemento Connessione remota

L'estensione Opzioni rete consente di creare, modificare ed eliminare connessioni remote e a reti private virtuali. Prima di creare un elemento preferenza opzione rete, è necessario rivedere il comportamento di ogni tipo di azione associata all'estensione.

Creare un elemento Connessione remota

Per creare un nuovo elemento preferenza Connessione remota

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni rete, scegliere Nuovo e quindi Connessione remota.

  4. In Azione nella scheda Connessione remota selezionare un azione da eseguire per Criteri di gruppo. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni connessione remota per Criteri di gruppo da configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni connessione remota" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una connessione remota.

Crea | Consente di creare una nuova connessione di rete. Se esiste una connessione con lo stesso nome, questa non verrà modificata.
Elimina | Consente di rimuovere una connessione di rete con lo stesso nome. L'estensione non esegue nessuna azione se la connessione non esiste.
Sostituisci | Consente di eliminare o ricreare la connessione di rete. L'azione Sostituisci ha come effetto quello di sovrascrivere tutte le impostazioni esistenti associate alla connessione. Se la connessione non esiste l'azione Sostituisci ne creerà una nuova.
Aggiorna | Consente di rinominare o modificare una connessione di rete. Questa azione è diversa da Sostituisci in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se la connessione non esiste l'azione Aggiorna ne creerà una nuova.

Impostazioni connessione remota

Connessione utente | Utilizzare questa impostazione per rendere visibile la nuova connessione creata o aggiornata solo all'utente a cui viene applicata.
Connessione per tutti gli utenti | Utilizzare questa impostazione per rendere visibile la nuova connessione creata o aggiornata a tutti gli utenti del computer.
Nome connessione | Testo utilizzato per assegnare un nome alla connessione. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare. È possibile importare una connessione remota in un elemento preferenza Connessione remota. Fare clic su Sfoglia (…) per visualizzare un elenco delle connessioni remote per il computer corrente.
Numero di telefono | Testo utilizzato per indicare il numero di telefono utilizzato dalla connessione. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Ulteriori considerazioni

  • Gli elementi preferenza Connessione remota e gli elementi preferenza Connessione VPN non sono supportati in un'installazione Server Core dei sistemi operativi Windows Server® 2008 R2 o Windows Server 2008.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni rete

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Connessione VPN

L'estensione Opzioni rete consente di creare, modificare ed eliminare connessioni remote e a reti private virtuali. Prima di creare un elemento preferenza opzione rete, è necessario rivedere il comportamento di ogni tipo di azione associata all'estensione.

Creare un elemento Connessione VPN

Per creare un nuovo elemento preferenza Connessione VPN

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni rete, scegliere Nuovo e quindi Connessione VPN.

  4. Nella finestra di dialogo Proprietà nuovo elemento Connessione VPN selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni connessione VPN per Criteri di gruppo da configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni connessione VPN" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una connessione VPN.

Crea | Consente di creare una nuova connessione di rete. Se esiste una connessione con lo stesso nome, questa non verrà modificata.
Elimina | Consente di rimuovere una connessione di rete con lo stesso nome. L'estensione non esegue nessuna azione se la connessione non esiste.
Sostituisci | Consente di eliminare o ricreare la connessione di rete. L'azione Sostituisci ha come effetto quello di sovrascrivere tutte le impostazioni esistenti associate alla connessione. Se la connessione non esiste l'azione Sostituisci ne creerà una nuova.
Aggiorna | Consente di rinominare o modificare una connessione di rete. Questa azione è diversa da Sostituisci poiché aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se la connessione non esiste l'azione Aggiorna ne creerà una nuova.

Impostazioni connessione VPN

Connessione utente

Utilizzare questa impostazione per rendere visibile la nuova connessione creata o aggiornata solo all'utente a cui viene applicata.

Connessione per tutti gli utenti

Utilizzare questa impostazione per rendere visibile la nuova connessione creata o aggiornata a tutti gli utenti del computer.

Nome connessione

Testo utilizzato per assegnare un nome alla connessione. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare. È possibile importare una connessione VPN in un elemento preferenza rete privata virtuale. Fare clic su Sfoglia (…) per visualizzare un elenco delle connessioni VPN dal computer attuale.

Indirizzo IP o Nome DNS

Digitare l'indirizzo IP del computer remoto. Oppure, selezionare la casella Usa nome DNS e digitare il nome di dominio completo del computer remoto.

Nota

Gli indirizzi IPv6 non sono supportati.

Effettua prima un'altra connessione

Digitare il nome della connessione remota che è stata stabilita prima di connettersi alla rete privata virtuale.

Mostra un'icona nell'area di notifica quando connesso

Visualizza un'icona animata nell'area di notifica quando connesso.

Scheda Opzioni

Utilizzare la scheda Opzioni per scegliere le opzioni di composizione e ricomposizione per l'elemento preferenza Connessione VPN.

Scheda Sicurezza

La scheda Sicurezza contiene le impostazioni di sicurezza Tipica e Avanzate associate all'elemento preferenza Connessione VPN. Utilizzare queste impostazioni per determinare sicurezza password, crittografia dati e protocolli di autenticazione.

Scheda Rete

Utilizzare la scheda Rete per scegliere il tipo di connessione VPN per l'elemento preferenza.

Ulteriori considerazioni

  • Gli elementi preferenza Connessione remota e gli elementi preferenza Connessione VPN non sono supportati in un'installazione Server Core dei sistemi operativi Windows Server® 2008 R2 o Windows Server 2008.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni rete

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Opzioni risparmio energia

In Criteri di gruppo è inclusa l'estensione della preferenza Opzioni risparmio energia. Questa estensione consente di configurare le opzioni di risparmio di energia per utenti o computer.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Combinazione per il risparmio di energia, Opzioni risparmio energia e Combinazione risparmio energia per qualsiasi oggetto Criteri di gruppo (GPO) basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Opzioni risparmio energia

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Combinazione per il risparmio di energia (Windows Vista e versioni successive)

  • Configurare un elemento Opzioni risparmio energia (Windows XP)

  • Configurare un elemento Combinazione risparmio energia (Windows XP)

  • Configurare opzioni comuni


Configurare un elemento Combinazione per il risparmio di energia (Windows Vista e versioni successive)

Gli elementi preferenza Combinazione per il risparmio di energia (Windows Vista® e versioni successive) consentono di configurare le opzioni di sospensione e visualizzazione per la gestione del consumo di energia per Windows Server® 2008 R2, Windows® 7, Windows Server 2008 e Microsoft Windows Vista.

La procedura di configurazione degli elementi Combinazione per il risparmio di energia è simile a quella utilizzata in Opzioni risparmio energia nel Pannello di controllo.

Creare un elemento preferenza Combinazione per il risparmio di energia (Windows Vista e versioni successive)

Per creare un nuovo elemento preferenza Combinazione per il risparmio di energia

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni risparmio energia, scegliere Nuovo e quindi Opzioni risparmio energia (Windows Vista e versioni successive).

  4. Nella finestra di dialogo Nuove proprietà combinazione per il risparmio di energia (Windows Vista e versioni successive) immettere le impostazioni relative alle opzioni per il risparmio di energia da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che sia già presente o meno una combinazione per il risparmio di energia.

Crea | Consente di creare una combinazione per il risparmio di energia appena configurata. Se è già presente una combinazione per il risparmio di energia con lo stesso nome dell'elemento Combinazione per il risparmio di energia, la combinazione esistente non verrà modificata.
Elimina | Consente di rimuovere una combinazione per il risparmio di energia il cui nome è identico a quello dell'elemento preferenza Combinazione per il risparmio di energia. Se la combinazione per il risparmio di energia non è presente, l'estensione non esegue alcuna azione. Non è possibile eliminare combinazioni per il risparmio di energia predefinite.
Sostituisci | Consente di eliminare e ricreare la combinazione per il risparmio di energia specificata. L'esecuzione dell'azione Sostituisci implica la sovrascrittura di tutte le impostazioni esistenti associate alla combinazione per il risparmio di energia. Se la combinazione non è presente, l'azione Sostituisci consente di crearne una nuova. Non è possibile sostituire combinazioni per il risparmio di energia predefinite.
Aggiorna | Consente di modificare una combinazione per il risparmio di energia. Questa azione è diversa da Sostituisci in quanto consente di aggiornare le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se la combinazione per il risparmio di energia non è presente, l'azione Aggiorna consente di crearne una nuova.

Ulteriori considerazioni

  • Se un elemento Combinazione per il risparmio di energia utente viene elaborato dopo un elemento Combinazione per il risparmio di energia computer, le impostazioni utente sostituiscono quelle attive, che potrebbero essere state attivate in precedenza da un elemento Combinazione per il risparmio di energia computer o utente.

  • L'amministratore locale e il gruppo amministrativo Power Users possono modificare manualmente le relative impostazioni per il risparmio di energia tramite il Pannello di controllo. Tale operazione non è invece consentita ad altri utenti. Le impostazioni configurate per gli utenti diventano comunque attive quando questi accedono e rimangono tali anche dopo la disconnessione.

  • Le impostazioni applicate al computer diventano attive quando il computer viene avviato senza un utente connesso. Gli elementi preferenza Combinazione per il risparmio di energia, che supportano gli aggiornamenti in background di Criteri di Gruppo, possono tuttavia reimpostare le impostazioni relative al risparmio di energia quando i criteri del computer vengono applicati senza un utente connesso.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni risparmio energia

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Opzioni risparmio energia (Windows XP)

L'elemento preferenza Opzioni risparmio energia consente di configurare la risposta di Windows Server® 2003 e Windows® XP a eventi di alimentazione, ad esempio la pressione del pulsante di alimentazione o sospensione, la chiusura del coperchio di computer portatili o la riattivazione dallo standby.

Gli elementi preferenza Opzione risparmio energia consentono di configurare le opzioni per il risparmio di energia solo per Windows Server 2003 o Windows XP. Per configurare le opzioni per il risparmio di energia per Windows Server® 2008 R2, Windows Server 2008, Windows 7 e Windows Vista®, utilizzare le impostazioni del modello amministrativo Risparmio energia disponibili nelle posizioni seguenti:

Configurazione computer

└ Criteri

└ Modelli amministrativi

└ Sistema

└ Risparmio energia

La procedura di configurazione degli elementi Opzioni risparmio energia è simile a quella utilizzata per Opzioni risparmio energia nel Pannello di controllo. Un elemento Opzioni risparmio energia non include un'azione elemento.

Creare un elemento Opzioni risparmio energia (Windows XP)

Per creare un nuovo elemento preferenza Opzioni risparmio energia

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni risparmio energia, scegliere Nuovo e quindi Opzioni risparmio energia (Windows XP).

  4. Nella finestra di dialogo Proprietà nuovo elemento Opzioni risparmio energia immettere le impostazioni relative alle opzioni per il risparmio di energia da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Se un elemento Opzioni risparmio energia utente viene elaborato dopo un elemento Opzioni risparmio energia computer, le impostazioni utente sostituiscono quelle attive, che potrebbero essere state attivate in precedenza da un elemento Opzioni risparmio energia computer o utente.

  • L'amministratore locale e il gruppo amministrativo Power Users possono modificare manualmente le proprie impostazioni per il risparmio di energia tramite il Pannello di controllo. Tale operazione non è invece consentita ad altri utenti. Le impostazioni configurate per gli utenti diventano tuttavia attive quando questi eseguono l'accesso e rimangono tali anche dopo la disconnessione.

  • Le impostazioni applicate al computer diventano attive quando il computer viene avviato senza un utente che esegue l'accesso. Gli elementi preferenza Opzioni risparmio energia, che supportano gli aggiornamenti in background di Criteri di Gruppo, possono tuttavia reimpostare le impostazioni relative al risparmio di energia quando i criteri del computer vengono applicati senza un utente che ha eseguito l'accesso.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni risparmio energia

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Combinazione risparmio energia (Windows XP)

L'elemento preferenza Combinazione risparmio energia consente di configurare le impostazioni di una combinazione per il risparmio di energia di Windows Server® 2003 o Windows® XP, ovvero un gruppo di impostazioni di risparmio energia combinate con un unico nome. Le combinazioni per il risparmio di energia consentono di controllare la gestione del consumo di energia dell'hardware in seguito a un periodo di inattività. Prima di creare una combinazione per il risparmio di energia, è consigliabile esaminare il comportamento di ogni tipo di azione possibile rispetto all'estensione. La procedura di configurazione degli elementi relativi alle combinazioni per il risparmio di energia è simile a quella utilizzata per Opzioni risparmio energia nel Pannello di controllo.

Nota

Utilizzare gli elementi preferenza Opzione risparmio energia per configurare il comportamento di Windows Server 2003 o Windows XP in risposta a eventi di alimentazione.

Creare un elemento Combinazione risparmio energia Windows XP

Per creare un nuovo elemento preferenza Combinazione risparmio energia per Windows XP

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni risparmio energia, scegliere Nuovo e quindi Combinazione risparmio energia (Windows XP).

  4. Nella finestra di dialogo Proprietà nuovo elemento Combinazione risparmio energia selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni relative alla combinazione per il risparmio di energia da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una combinazione per il risparmio di energia.

Crea | Consente di creare una combinazione per il risparmio di energia appena configurata. Se è già presente una combinazione per il risparmio di energia con lo stesso nome dell'elemento Combinazione risparmio energia, la combinazione esistente non verrà modificata.
Elimina | Consente di rimuovere una combinazione per il risparmio di energia il cui nome è identico a quello dell'elemento preferenza Combinazione risparmio energia. Se la combinazione per il risparmio di energia non esiste, l'estensione non esegue nessuna azione.
Sostituisci | Consente di eliminare e creare nuovamente la combinazione per il risparmio di energia specificata. L'esecuzione dell'azione Sostituisci implica la sovrascrittura di tutte le impostazioni esistenti associate alla combinazione per il risparmio di energia. Se la combinazione non esiste, l'azione Sostituisci consente di crearne una appena configurata.
Aggiorna | Consente di modificare una combinazione per il risparmio di energia. Questa azione è diversa da Sostituisci, in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se la combinazione per il risparmio di energia non esiste, l'azione Aggiorna consente di crearne una nuova.

Ulteriori considerazioni

  • Se un elemento Combinazione risparmio energia utente viene elaborato dopo un elemento Combinazione risparmio energia computer, le impostazioni della combinazione utente sostituiscono quelle attive, che potrebbero essere state attivate in precedenza da un elemento Combinazione risparmio energia computer o utente.

  • L'amministratore locale e il gruppo amministrativo Power Users possono modificare manualmente le proprie impostazioni per la combinazione per il risparmio di energia tramite il Pannello di controllo. Tale operazione non è invece consentita ad altri utenti. Le impostazioni configurate per gli utenti diventano tuttavia attive quando questi eseguono l'accesso e rimangono tali anche dopo la disconnessione.

  • Le impostazioni applicate al computer diventano attive quando il computer viene avviato senza un utente che esegue l'accesso. Gli elementi preferenza Combinazione risparmio energia, che supportano gli aggiornamenti in background di Criteri di Gruppo, possono tuttavia reimpostare le impostazioni relative alla combinazione per il risparmio di energia quando i criteri del computer vengono applicati senza un utente che ha eseguito l'accesso.

  • Le impostazioni della combinazione per il risparmio di energia consentono di controllare i valori contenuti nella combinazione specificata. Durante la creazione di nuove combinazioni i valori disabilitati vengono estratti dalla combinazione per il risparmio di energia predefinita per il computer o l'utente. Nella finestra di dialogo Proprietà nuovo elemento Combinazione risparmio energia vengono selezionate le impostazioni standard per qualsiasi combinazione per il risparmio di energia selezionata nell'elenco Combinazioni risparmio energia.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni risparmio energia

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Stampanti

In Criteri di gruppo è inclusa l'estensione della preferenza Stampanti. Questa estensione consente di creare, configurare ed eliminare stampanti locali, condivise e TCP/IP.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Stampante per qualsiasi oggetto Criteri di gruppo (GPO) basato sul dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Stampanti

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Stampante locale

  • Configurare un elemento Stampante condivisa

  • Configurare un elemento Stampante TCP/IP

  • Configurare opzioni comuni


Configurare un elemento Stampante locale

L'estensione della preferenza Stampanti consente di creare, configurare ed eliminare stampanti locali utilizzando l'elemento preferenza Stampante locale Prima di creare un elemento preferenza Stampante locale, è necessario rivedere il comportamento di ogni tipo di azione associata all'estensione.

Creare un elemento Stampante locale

Per creare un nuovo elemento preferenza Stampante locale

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Stampanti, scegliere Nuovo e quindi Stampante locale.

  4. Nella finestra di dialogo Proprietà nuovo elemento Stampante locale selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni stampante locale per Criteri di gruppo da configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni stampante locale" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una connessione alla stampante.

Crea

Consente di creare una nuova stampante locale. Se una stampante locale con lo stesso nome esiste già, questa non verrà modificata.

Elimina

Consente di rimuovere una stampante locale con lo stesso nome. L'estensione non esegue alcuna azione se la stampante locale non esiste.

Importante

Questa azione non rimuove il driver della stampante ma solo la stampante locale.

Sostituisci

Consente di eliminare e ricreare la stampante locale. L'azione Sostituisci ha come effetto quello di sovrascrivere tutte le impostazioni esistenti associate al computer locale. Se la stampante locale non esiste, l'azione Sostituisci ne crea una nuova.

Aggiorna

Consente di rinominare o modificare una stampante locale. Questa azione è diversa da Sostituisci in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se la stampante locale non esiste, l'azione Aggiorna ne crea una nuova.

Impostazioni stampante locale

Nome connessione | Digitare il nome della stampante locale di destinazione. Se la stampante locale non esiste, l'estensione della preferenza ne creerà una con questo nome. Se la stampante esiste, l'estensione della preferenza utilizzerà la stampante locale con questo nome come destinazione dell'azione richiesta. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.
Porta | Scegliere una porta locale dall'elenco fornito o digitare il nome della porta locale.
Percorso stampante | Digitare o fare clic su Sfoglia (…) per scegliere un percorso UNC completo per una connessione stampante condivisa. L'estensione della preferenza utilizza questa connessione condivisa come origine di installazione per il driver della stampante. La stampante reale deve essere fisicamente collegata alla workstation.
Imposta come stampante predefinita | Selezionare questa casella di controllo per impostare la stampante locale come la stampante Windows predefinita per l'utente corrente.
Percorso | Digitare il testo che descrive l'ubicazione della stampante. Questa informazione viene visualizzata nella casella Percorso della stampante. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.
Commento | Digitare il testo che fornisce commenti aggiuntivi sulla stampante. Questa informazione viene visualizzata nella casella Commenti della stampante. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Stampanti

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Stampante condivisa

L'estensione della preferenza Stampanti consente di creare, configurare ed eliminare connessioni a stampanti condivise mediante l'elemento preferenza Stampante condivisa. Prima di creare un elemento preferenza Stampante condivisa, è opportuno esaminare il comportamento di ogni azione possibile con l'estensione.

Creare un elemento Stampante condivisa

Per creare un nuovo elemento preferenza Stampante condivisa

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Stampanti, scegliere Nuovo e selezionare Stampante condivisa.

  4. Nella finestra di dialogo Proprietà nuovo elemento Stampante condivisa selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni della stampante condivisa che Criteri di gruppo deve configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni di Stampante condivisa" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una connessione alla stampante.

Crea

Crea una nuova connessione alla stampante condivisa. Se esiste già una stampante locale con lo stesso nome, non viene modificato.

Elimina

Rimuove una connessione a una stampante condivisa con lo stesso percorso di condivisione. L'estensione non esegue alcuna azione se la connessione alla stampante condivisa non esiste.

Importante

Questa azione non rimuove il driver della stampante, ma solo la connessione alla stampante condivisa.

Sostituisci

Elimina e ricrea la connessione alla stampante condivisa. Il risultato finale dell'azione Sostituisci è costituito dalla sovrascrittura di tutte le impostazioni esistenti associate alla connessione alla stampante condivisa. Se la connessione alla stampante condivisa non esiste, l'azione Sostituisci crea una nuova connessione alla stampante condivisa.

Aggiorna

Modifica una connessione alla stampante condivisa. Questa azione è diversa da Sostituisci, in quanto aggiorna le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se la connessione alla stampante condivisa non esiste, l'azione Aggiorna crea una nuova connessione alla stampante condivisa.

Impostazioni di Stampante condivisa

Percorso condivisione

Digitare il percorso UNC completo di una stampante condivisa o fare clic su Sfoglia (…) per sceglierlo.

Imposta come stampante predefinita

Selezionare questa casella di controllo per fare in modo che la connessione alla stampante condivisa sia la stampante predefinita di Windows per l'utente corrente.

Solo se non è presente una stampante locale

Selezionare questa casella di controllo per ignorare la modifica della stampante predefinita qualora vi sia una stampante locale configurata nel computer. Questa impostazione non è disponibile se non si seleziona la casella di controllo Imposta come stampante predefinita.

Importante

Per stampante locale si intende una stampante non connessa a una stampante di rete condivisa. Sono incluse le stampanti fisiche connesse alle porte parallele, seriali e USB, le stampanti TCP/IP e le stampanti virtuali installate mediante software.

Elimina tutte le connessioni alla stampante condivisa

Selezionare questa casella di controllo se si desidera eliminare tutte le connessioni alla stampante condivisa per l'utente corrente. Questa impostazione è disponibile solo se l'azione dell'elemento preferenza è impostata su Elimina.

Porta locale

Scegliere la porta locale a cui eseguire il mapping della connessione condivisa. Questa impostazione è facoltativa.

Importante

Se nella casella Porta locale è contenuto un valore e l'azione dell'elemento preferenza è impostato su Elimina, l'estensione della preferenza elimina la connessione alla stampante condivisa associata a tale porta locale.

Riconnetti

Selezionare questa casella di controllo se si desidera rendere permanente la connessione alla stampante condivisa. Questa opzione non è disponibile se non si sceglie un valore nell'elenco Porta locale.

Annulla mapping di tutte le porte locali

Selezionare questa casella di controllo se si desidera annullare il mapping delle connessioni alla stampante condivisa a tutte le porte locali. Questa impostazione è disponibile solo se l'azione dell'elemento preferenza è impostata su Elimina.

Ulteriori considerazioni

  • Quando elabora gli elementi Stampante condivisa, l'estensione Stampanti installa sempre il driver della stampante nel contesto di sicurezza specificato nella scheda Comune.

  • Gli elementi Stampante condivisa utilizzano sempre il contesto di sicurezza dell'utente corrente per eseguire il mapping delle connessioni alla stampante e impostare lo stato della stampante predefinita.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Stampanti

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Stampante TCP/IP

L'estensione della preferenza Stampanti consente di creare, configurare ed eliminare stampanti TCP/IP mediante l'apposito elemento preferenza. Prima di creare un elemento preferenza Stampante TCP/IP, è consigliabile esaminare il comportamento di ogni tipo di azione possibile con questa estensione.

Creare un elemento Stampante TCP/IP

Per creare un nuovo elemento preferenza Stampante TCP/IP

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Stampanti, scegliere Nuovo e quindi Stampante TCP/IP.

  4. Nella finestra di dialogo Proprietà nuovo elemento Stampante TCP/IP selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Specificare le impostazioni della stampante TCP/IP da configurare o rimuovere in Criteri di gruppo. Per ulteriori informazioni, vedere "Impostazioni della stampante TCP/IP" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista o meno una connessione stampante.

Crea

Consente di creare una nuova connessione a una stampante TCP/IP. Se esiste già una connessione a una stampante TCP/IP con lo stesso indirizzo IP, questa non viene modificata.

Elimina

Consente di rimuovere la connessione alla stampante TCP/IP con lo stesso indirizzo IP. L'estensione non esegue alcuna azione se la connessione alla stampante TCP/IP non esiste.

Importante

Questa azione non determina la rimozione del driver o della porta della stampante. Rimuove solo la connessione alla stampante TCP/IP.

Sostituisci

Consente di eliminare e ricreare la connessione alla stampante TCP/IP . L'azione Sostituisci determina sostanzialmente la sovrascrittura di tutte le impostazioni associate alla connessione alla stampante TCP/IP esistente. Se tale connessione non esiste, l'azione Sostituisci consente di creare una nuova connessione alla stampante TCP/IP.

Aggiorna

Consente di modificare una connessione a una stampante TCP/IP. Questa azione è diversa da Sostituisci in quanto consente di aggiornare le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata. Se tale connessione non esiste, l'azione Aggiorna consente di creare una nuova connessione alla stampante TCP/IP.

Impostazioni della stampante TCP/IP

Indirizzo IP o Nome DNS

Digitare l'indirizzo IP della stampante remota. In alternativa, selezionare la casella di controllo Usa nome DNS e digitare il nome di dominio completo della stampante remota.

Importante

L'estensione della preferenza Stampanti utilizza l'indirizzo TCP/IP o il nome DNS per determinare se una stampante TCP/IP esiste quando non viene specificato un nome locale.

Nota

Gli indirizzi IPv6 non sono supportati.

Nome locale

Digitare il nome locale della connessione alla stampante TCP/IP in questione. L'estensione della preferenza crea una nuova connessione alla stampante TCP/IP con tale nome, se non ne esiste già una. Se esiste già una connessione con questo nome, quest'ultima verrà utilizzata come destinazione dell'azione richiesta. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Importante

L'estensione della preferenza Stampanti utilizza il nome locale per determinare se una stampante TCP/IP esiste quando viene specificato un nome locale. In caso contrario, per determinare se una connessione esiste viene utilizzato l'indirizzo TCP/IP o il nome DNS.

Percorso stampante

Digitare un percorso UNC completo oppure fare clic su Sfoglia (…) per selezionare un percorso UNC completo di una connessione a una stampante condivisa. L'estensione della preferenza utilizza questa connessione condivisa come origine dell'installazione per il driver della stampante.

Imposta come stampante predefinita

Selezionare questa casella di controllo per impostare la stampante locale come stampante predefinita di Windows per l'utente corrente.

Solo se non è presente una stampante locale

Selezionare questa casella di controllo per ignorare le modifiche di impostazione della stampante predefinita se è presente una stampante locale configurata nel computer. Questa impostazione non è disponibile se non si seleziona la casella di controllo Imposta come stampante predefinita.

Importante

Una stampante locale è una qualsiasi stampante non connessa a una stampante di rete condivisa. Può trattarsi di stampanti fisiche collegate alle porte parallela, seriale e USB, di stampanti TCP/IP e di stampanti virtuali installate tramite software.

Elimina tutte le connessioni IP con stampanti

Selezionare questa casella di controllo se si desidera eliminare tutte le connessioni TCP/IP con stampanti per l'utente corrente.. Questa impostazione è disponibile solo se l'azione dell'elemento preferenza è impostata su Elimina.

Posizione

Digitare una descrizione che indichi dove si trova la stampante. Queste informazioni vengono visualizzate nella casella Posizione della stampante. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Commento

Digitare ulteriori commenti sulla stampante. Queste informazioni vengono visualizzate nella casella Commenti della stampante. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Impostazioni della porta

Utilizzare Impostazioni della porta per configurare ulteriori impostazioni della porta, oltre a quelle predefinite. Le impostazioni disponibili includono Protocollo, Impostazioni Raw, Impostazioni LPR e Stato SNMP.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Stampanti

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Opzioni internazionali

In Criteri di gruppo è inclusa l'estensione della preferenza Opzioni internazionali. Tale estensione consente di configurare il formato di numeri, valute, date e orari per la maggior parte delle applicazioni.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Opzioni internazionali per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Opzioni internazionali

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Opzioni internazionali

  • Configurare opzioni comuni


Configurare un elemento Opzioni internazionali

La configurazione di Opzioni internazionali è analoga a quella di Opzioni internazionali e della lingua nel Pannello di controllo. Selezionare Impostazioni locali utente nella scheda Opzioni internazionali. In questo modo i valori nelle schede rimanenti verranno reimpostati. È tuttavia possibile modificare i valori rimanenti.

Nota

A differenza delle altre estensioni delle preferenze, è possibile aggiornare solo gli elementi preferenza Opzioni internazionali. Non è pertanto disponibile alcuna scelta di azioni per l'elemento preferenza.

Creare un elemento Opzioni internazionali

Per creare un nuovo elemento preferenza Opzioni internazionali

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Opzioni internazionali, scegliere Nuovo e quindi Opzioni internazionali.

  4. Nella finestra di dialogo Proprietà nuovo elemento Opzioni internazionali immettere le impostazioni di Criteri di gruppo da configurare o rimuovere. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Non è possibile attivare o disattivare impostazioni non disponibili. Non è possibile configurare queste impostazioni mediante un elemento preferenza Opzioni internazionali.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Opzioni internazionali

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Attività pianificate

Criteri di gruppo include l'estensione di preferenza Attività pianificate. Per i computer e gli utenti, questa estensione consente di:

  • Creare, modificare o eliminare un'attività pianificata.

  • Eseguire un comando immediatamente al successivo aggiornamento di Criteri di gruppo oppure a ogni aggiornamento di Criteri di gruppo.

  • Automatizzare la manutenzione periodica, ad esempio ricerche di virus, backup, sincronizzazione e pulizia del disco.

  • Riattivare i computer dallo stato di standby e aggiornare Criteri di gruppo per aggiornare le impostazioni.

  • Avviare un processo all'accesso dell'utente senza eseguirlo da uno script di accesso.

Informazioni introduttive

È possibile creare e configurare gli elementi di preferenza Attività pianificata o Attività immediata per tutti gli oggetti Criteri di gruppo basati su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer o Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Attività pianificate

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Attività pianificata (Windows Vista e versioni successive)

  • Configurare un elemento Attività immediata (Windows Vista e versioni successive)

  • Configurare un elemento Attività pianificata

  • Configurare un elemento Attività immediata (Windows XP)

  • Configurare opzioni comuni


Configurare un elemento Attività pianificata (Windows Vista e versioni successive)

Per i computer che eseguono Windows Server® 2008 R2, Windows® 7, Windows Server 2008 o Windows Vista®, gli elementi preferenza Attività pianificata (Microsoft Windows Vista e versioni successive) consentono di creare, sostituire, aggiornare ed eliminare attività e le rispettive proprietà associate. Prima di creare un elemento preferenza Attività pianificata, è consigliabile controllare il comportamento di ogni tipo di azione possibile con questa estensione.

Configurare un elemento Attività pianificata (Windows Vista e versioni successive)

Per creare un nuovo elemento preferenza Attività pianificata

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Attività pianificate, scegliere Nuovo e quindi Attività pianificata (Windows Vista e versioni successive).

  4. Nella finestra di dialogo Proprietà nuova attività (Windows Vista e versioni successive) selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. In Nome immettere il nome dell'attività da configurare o eliminare. Per ulteriori informazioni, vedere la sezione "Impostazioni generali per l'attività" in questo argomento.

  6. Se si crea, si aggiorna o si sostituisce un'attività:

    1. Nella scheda Generale configurare le opzioni di sicurezza per l'attività. Per ulteriori informazioni, vedere la sezione "Impostazioni generali per l'attività" in questo argomento.

    2. Fare clic sulla scheda Attivazione e configurare il momento di inizio dell'attività e la frequenza di esecuzione. Per ulteriori informazioni, vedere la sezione "Attivazione" in questo argomento.

    3. Fare clic sulla scheda Azioni e configurare una o più azioni per l'attività da eseguire, ad esempio l'avvio di un programma, l'invio di un messaggio di posta elettronica o la visualizzazione di un messaggio. Per ulteriori informazioni, vedere "Azioni dell'attività" in questo argomento.

    4. Fare clic sulla scheda Condizioni e configurare altre condizioni necessarie per l'esecuzione dell'attività rispetto a quelle configurate nella scheda Attivazione. Per ulteriori informazioni, vedere la sezione "Altre impostazioni per l'attività" in questo argomento.

    5. Fare clic sulla scheda Impostazioni e immettere eventuali impostazioni aggiuntive dell'attività da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere la sezione "Altre impostazioni per l'attività" in questo argomento.

  7. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  8. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e a seconda che l'attività sia o meno già presente.

Crea | Consente di creare una nuova attività pianificata per utenti o computer.
Elimina | Consente di rimuovere un'attività pianificata per utenti o computer.
Sostituisci | Consente di eliminare e ricreare attività pianificate per utenti o computer. Il risultato finale dell'azione Sostituisci consiste nella sovrascrittura di tutte le impostazioni esistenti associate all'attività. Se l'attività pianificata non esiste, l'azione Sostituisci consente di crearne una nuova.
Aggiorna | Consente di modificare le impostazioni di un'attività pianificata esistente per utenti o computer. Questa azione è diversa da Sostituisci in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. La configurazione di tutte le altre impostazioni rimane invariata nell'attività. Se l'attività pianificata non esiste, l'azione Aggiorna consente di crearne una nuova.

Impostazioni generali per l'attività

Nota

Tutti i campi di testo accettano variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nome

Digitare un nome per l'attività. Il nome verrà visualizzato nell'elenco delle attività in Utilità di pianificazione in Strumenti di amministrazione. Per modificare o eliminare un'attività, il nome deve corrispondere al nome dell'attività esistente visualizzato in Utilità di pianificazione. Gli elementi preferenza che configurano attività con lo stesso nome possono generare conflitti.

Descrizione

Digitare una descrizione dell'attività. Questa descrizione sarà visibile per gli utenti o i computer a cui è applicato l'elemento preferenza.

Opzioni di sicurezza

Configurare il contesto di sicurezza in cui viene eseguita l'attività.

  • Se l'elemento preferenza fa parte di Configurazione computer, l'attività verrà eseguita nel contesto di sicurezza dell'account SYSTEM per impostazione predefinita.

  • Se l'elemento preferenza fa parte di Configurazione utente, l'attività verrà eseguita nel contesto di sicurezza dell'utente connesso per impostazione predefinita. Se non si specificano credenziali, l'attività viene eseguita solo se l'utente è connesso al computer, ma può continuare dopo la disconnessione dell'utente.

  • Per eseguire un'attività nel contesto di sicurezza di un account specificato, indipendentemente dal fatto che l'account sia connesso o meno, fare clic su Cambia utente o gruppo, immettere le credenziali per l'account e quindi fare clic su Esegui indipendentemente dalla connessione degli utenti.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Nascosta

Specificare se l'attività è nascosta per impostazione predefinita. In Utilità di pianificazione gli utenti finali possono fare clic su Visualizza e su Visualizza attività nascoste per visualizzare le attività nascoste.

Configura per

Per i computer che eseguono Windows Server 2008 R2, Windows 7, Windows Server 2008 o Microsoft Windows Vista, è possibile limitare le opzioni visualizzate in base a quelle disponibili anche nei sistemi operativi precedenti. La scelta di questa opzione non comporta la configurazione dell'attività o dell'elemento preferenza per l'esecuzione nei sistemi operativi precedenti.

Attivazione

Se si crea, aggiorna o sostituisce un'attività, configurare il momento di inizio dell'attività e la frequenza di esecuzione dell'attività nella scheda Attivazione. Per un'attività pianificata per l'esecuzione giornaliera, settimanale, mensile o per una singola esecuzione, selezionare l'ora di inizio dell'attività.

Configurare tutte le impostazioni di pianificazione facoltative desiderate:

  • Per configurare l'esecuzione giornaliera, settimanale o mensile di un'attività solo durante un intervallo di date specifico, fare clic sul pulsante Nuovo, specificare la frequenza, immettere una data in Inizio, selezionare la casella di controllo Scadenza e quindi immettere una data in Fine.

  • Per eseguire l'attività con una frequenza maggiore rispetto a quella giornaliera, fare clic sul pulsante Nuovo, selezionare Ripeti l'attività ogni e configurare la frequenza e l'ora di fine oppure la durata.

  • Selezionare la casella di controllo Attivato per consentire l'esecuzione dell'attività. Per configurare un'attivazione senza che l'attività venga eseguita, deselezionare questa casella di controllo.

Azioni dell'attività

Nota

Tutti i campi di testo accettano variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

È possibile configurare un'attività per avviare un programma, inviare un messaggio di posta elettronica o visualizzare un messaggio. Se si configura un'attività per l'avvio di un programma, nella scheda Azioni fare clic su Nuovo, selezionare Avvio programma e quindi configurare le opzioni seguenti:

Programma/script | Immettere il comando da eseguire senza includere alcun argomento.
Aggiungi argomenti (facoltativo) | Digitare eventuali argomenti della riga di comando necessari.
Inizio (facoltativo) | Per specificare la directory di lavoro per il comando in esecuzione (di solito per garantire la corretta risoluzione di tutti i nomi di file relativi) digitare il nome della directory di lavoro utilizzata al momento dell'esecuzione dell'attività. Non includere virgolette o barre finali.

Altre impostazioni dell'attività

La configurazione delle opzioni nella scheda Condizioni consente di limitare le situazioni nelle quali un'attività può essere eseguita o è possibile riattivare il computer per eseguire un'attività. Nella scheda Impostazioni è possibile configurare le opzioni per gestire il comportamento dell'attività al completamento, se si verifica un problema o se un'istanza dell'attività è già in esecuzione.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Attività pianificate

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Attività immediata (Windows Vista e versioni successive)

Per i computer che eseguono Windows Server® 2008 R2, Windows® 7, Windows Server 2008 o Windows Vista®, gli elementi preferenza Attività immediata (Microsoft Windows Vista e versioni successive) consentono di creare attività da eseguire immediatamente all'aggiornamento di Criteri di gruppo, attività che vengono quindi rimosse. Per gli elementi preferenza Attività immediata non è possibile selezionare azioni o attivazioni, in quanto tali elementi creano sempre un'attività che viene eliminata al termine dell'esecuzione.

Configurare un elemento Attività immediata (Windows Vista e versioni successive)

Per creare un nuovo elemento preferenza Attività immediata

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Attività pianificate, scegliere Nuovo e quindi Attività immediata (Windows Vista e versioni successive).

  4. Nella finestra di dialogo Proprietà nuova attività (Windows Vista e versioni successive) selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Immettere le impostazioni dell'attività da configurare per Criteri di gruppo.

    1. Nella scheda Generale immettere un nome per l'attività da configurare in Nome e configurare le opzioni di sicurezza per l'attività. Per ulteriori informazioni, vedere la sezione "Impostazioni generali per l'attività" in questo argomento.

    2. Fare clic sulla scheda Condizioni e configurare le condizioni necessarie per l'esecuzione dell'attività. Per ulteriori informazioni, vedere la sezione "Altre impostazioni per l'attività" in questo argomento.

    3. Fare clic sulla scheda Impostazioni e immettere eventuali impostazioni aggiuntive dell'attività da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere la sezione "Altre impostazioni per l'attività" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Impostazioni generali per l'attività

Nota

Tutti i campi di testo accettano variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nome

Digitare un nome per l'attività. Il nome verrà visualizzato nell'elenco delle attività in Utilità di pianificazione in Strumenti di amministrazione. Per modificare o eliminare un'attività, il nome deve corrispondere al nome dell'attività esistente visualizzato in Utilità di pianificazione. Gli elementi preferenza che configurano attività con lo stesso nome possono generare conflitti.

Descrizione

Digitare una descrizione dell'attività. Questa descrizione sarà visibile per gli utenti o i computer a cui è applicato l'elemento preferenza.

Opzioni di sicurezza

Configurare il contesto di sicurezza in cui viene eseguita l'attività.

  • Se l'elemento preferenza fa parte di Configurazione computer, l'attività verrà eseguita nel contesto di sicurezza dell'account SYSTEM per impostazione predefinita.

  • Se l'elemento preferenza fa parte di Configurazione utente, l'attività verrà eseguita nel contesto di sicurezza dell'utente connesso per impostazione predefinita. Se non si specificano credenziali, l'attività viene eseguita solo se l'utente è connesso al computer, ma può continuare dopo la disconnessione dell'utente.

  • Per eseguire un'attività nel contesto di sicurezza di un account specificato, indipendentemente dal fatto che l'account sia connesso o meno, fare clic su Cambia utente o gruppo, immettere le credenziali per l'account e quindi fare clic su Esegui indipendentemente dalla connessione degli utenti.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Nascosta

Specificare se l'attività è nascosta per impostazione predefinita. In Utilità di pianificazione gli utenti finali possono fare clic su Visualizza e su Visualizza attività nascoste per visualizzare le attività nascoste.

Configura per

Per i computer che eseguono Windows Server 2008 R2, Windows 7, Windows Server 2008 o Microsoft Windows Vista, è possibile limitare le opzioni visualizzate in base a quelle disponibili anche nei sistemi operativi precedenti. La scelta di questa opzione, tuttavia, non comporta la configurazione dell'attività o dell'elemento preferenza per l'esecuzione nei sistemi operativi precedenti.

Azioni dell'attività

Nota

Tutti i campi di testo accettano variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

È possibile configurare un'attività per avviare un programma, inviare un messaggio di posta elettronica o visualizzare un messaggio. Se si configura un'attività per l'avvio di un programma, nella scheda Azioni fare clic su Nuovo, selezionare Avvio programma e quindi configurare le opzioni seguenti:

Programma/script | Immettere il comando da eseguire senza includere alcun argomento.
Aggiungi argomenti (facoltativo) | Digitare eventuali argomenti della riga di comando necessari.
Inizio (facoltativo) | Per specificare la directory di lavoro per il comando in esecuzione (di solito per garantire la corretta risoluzione di tutti i nomi di file relativi) digitare il nome della directory di lavoro utilizzata al momento dell'esecuzione dell'attività. Non includere virgolette o barre finali.

Altre impostazioni dell'attività

La configurazione delle opzioni nella scheda Condizioni consente di limitare le situazioni nelle quali un'attività può essere eseguita o è possibile riattivare il computer per eseguire un'attività. Nella scheda Impostazioni è possibile configurare le opzioni per gestire il comportamento dell'attività al completamento, se si verifica un problema o se un'istanza dell'attività è già in esecuzione.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Attività pianificate

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Attività pianificata

Per i computer che eseguono Windows Server® 2008 R2, Windows® 7, Windows Server 2008, Windows Vista®, Windows Server 2003, o Windows XP, gli elementi preferenza Attività pianificata consentono di creare, sostituire, aggiornare ed eliminare attività pianificate e le rispettive proprietà associate. Prima di creare un elemento preferenza Attività pianificata, è necessario verificare il comportamento di ogni tipo di azione possibile con questa estensione.

Configurare un elemento Attività pianificata

Per creare un nuovo elemento preferenza Attività pianificata

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Attività pianificate, scegliere Nuovo e fare clic su Attività pianificata.

  4. Nella finestra di dialogo Proprietà nuovo elemento Attività pianificata selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni" in questo argomento.

  5. Nella scheda Attività immettere le impostazioni dell'attività che Criteri di gruppo deve configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni di attività" in questo argomento.

  6. Se si crea, si aggiorna o si sostituisce un'attività:

    1. Fare clic sulla scheda Pianificazione e configurare una o più pianificazioni per l'attività. Per ulteriori informazioni, vedere la sezione "Impostazioni di pianificazione" in questo argomento.

    2. Fare clic sulla scheda Impostazioni e immettere altre impostazioni relative alle attività da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere la sezione "Altre impostazioni di attività pianificate" in questo argomento.

  7. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. (Per ulteriori informazioni, vedere Configurare opzioni comuni.)

  8. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni

Il tipo di elemento preferenza consente di scegliere tra quattro azioni: Crea, Sostituisci, Aggiorna ed Elimina. Il comportamento dell'elemento preferenza varia a seconda dell'azione selezionata e del fatto che esista già o meno l'attività pianificata.

Crea | Consente di creare una nuova attività pianificata per utenti o computer.
Elimina | Consente di rimuovere un'attività pianificata per utenti o computer.
Sostituisci | Consente di eliminare e ricreare attività pianificate per utenti o computer. Il risultato dell'azione Sostituisci consiste nel sovrascrivere tutte le impostazioni esistenti associate all'attività pianificata. Se l'attività pianificata non esiste, l'azione Sostituisci consente di crearne una nuova.
Aggiorna | Consente di modificare le impostazioni di un'attività pianificata esistente per utenti o computer. Questa azione è diversa da Sostituisci in quanto aggiorna solo le impostazioni definite nell'elemento preferenza. Tutte le altre impostazioni rimangono configurate come specificato nell'attività pianificata. Se l'attività pianificata non esiste l'azione Aggiorna consente di crearne una nuova.

Impostazioni di attività

Nota

Tutti i campi di testo accettano le variabili di elaborazione preferenza. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nome

Digitare un nome per l'attività pianificata. Il nome verrà visualizzato nell'elenco di attività pianificate del Pannello di controllo per gli utenti o i computer. Per modificare o eliminare un'attività, il nome deve corrispondere al nome dell'attività esistente visualizzato nel Pannello di controllo per i computer o gli utenti. Attività di configurazione degli elementi preferenza con nome identico possono essere in conflitto.

Esegui

Digitare il comando da eseguire senza includere alcun argomento.

Questo campo è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Argomenti

Digitare tutti gli argomenti della riga di comando necessari.

Questo campo è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Avvia in

Per specificare la directory di lavoro per il comando in esecuzione (di solito per garantire la corretta risoluzione di tutti i nomi di file relativi) digitare il nome della directory di lavoro utilizzata al momento dell'esecuzione dell'attività. Non includere virgolette o una barra finale.

Questo campo è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Commenti

Digitare una descrizione dell'attività. Questa descrizione è visibile per utenti o computer a cui viene applicato l'elemento preferenza.

Questo campo è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Esegui come

Configurare il contesto di sicurezza in cui l'attività viene eseguita.

  • Se l'elemento preferenza fa parte di Configurazione computer, per impostazione predefinita l'attività viene eseguita nel contesto di sicurezza dell'account SYSTEM.

  • Se l'elemento preferenza fa parte di Configurazione utente, per impostazione predefinita l'attività viene eseguita nel contesto di sicurezza dell'utente connesso. L'attività viene eseguita solo se l'utente è connesso al computer, ma può continuare dopo la disconnessione dell'utente.

  • Per eseguire un'attività nel contesto di sicurezza di un account specificato consentendo l'esecuzione dell'attività indipendentemente dal fatto che l'account sia connesso o meno, selezionare la casella di controllo Esegui come e immettere le credenziali per l'account.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Questi campi sono disponibili solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Attivata

Selezionare questa casella di controllo per consentire l'esecuzione dell'attività. Per configurare l'attività per gli utenti o i computer senza consentirne l'esecuzione, deselezionare questa casella di controllo.

Questa casella di controllo è disponibile solo se l'azione selezionata è Crea, Sostituisci o Aggiorna.

Impostazioni di pianificazione

Se si crea, aggiorna o sostituisce un'attività, configurare la frequenza di esecuzione dell'attività nella scheda Pianificazione. Per un'attività pianificata per l'esecuzione giornaliera, settimanale, mensile o per una singola esecuzione selezionare l'ora di inizio dell'attività.

Configurare tutte le impostazioni di pianificazione facoltative desiderate:

  • Per fare in modo che un'attività giornaliera, settimanale o mensile venga eseguita solo in un intervallo di date specifico, fare clic sul pulsante Avanzate e selezionare Data di inizio e Data di fine.

  • Per fare in modo che l'attività venga eseguita ripetutamente, fare clic sul pulsante Avanzate, selezionare Ripeti attività e configurare la frequenza e l'ora di fine oppure la durata.

  • È possibile configurare più pianificazioni. A tale scopo, selezionare la casella di controllo Mostra pianificazioni multiple. Per la prima pianificazione che si desidera creare selezionare una frequenza, l'ora di inizio ed eventuali opzioni avanzate per l'attività. Fare clic su Nuova per aggiungere un'altra pianificazione all'elenco e quindi configurarne le impostazioni. Eventuali modifiche della pianificazione vengono applicate alla pianificazione attualmente visualizzata, ma vengono eseguite tutte le attività.

    Nota

    Per tornare alla visualizzazione di una singola pianificazione, eliminare tutte le pianificazioni eccetto una dell'elenco e quindi deselezionare la casella di controllo Mostra pianificazioni multiple.

Altre impostazioni di attività pianificate

Se si crea, aggiorna o sostituisce un'attività, nella scheda Impostazioni configurare le impostazioni per la gestione del comportamento dell'attività al completamento, se il computer è in uso oppure in condizioni di alimentazione specifiche.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Attività pianificate

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Attività immediata (Windows XP)

Per i computer che eseguono Windows Server® 2003 o Windows® XP, gli elementi preferenza Attività immediata consentono di creare attività da eseguire immediatamente all'aggiornamento di Criteri di gruppo, che vengono quindi rimosse. Per gli elementi preferenza Attività immediata non è possibile selezionare azioni poiché essi creano sempre un'attività la quale viene rimossa subito dopo essere stata eseguita.

Configurare un elemento Attività immediata (Windows XP)

Per creare un nuovo elemento preferenza Attività immediata

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer o Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni di Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Attività pianificate, scegliere Nuovo e quindi Attività immediata (Windows XP).

  4. Nella finestra di dialogo Proprietà nuovo elemento Attività immediata immettere le impostazioni di Criteri di gruppo da configurare o rimuovere. Per ulteriori informazioni, vedere "Impostazioni dell'attività" in questo argomento.

  5. Fare clic sulla scheda Impostazioni e immettere eventuali ulteriori impostazioni dell'attività da configurare in Criteri di gruppo. Per ulteriori informazioni, vedere "Altre impostazioni dell'attività immediata" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Impostazioni dell'attività

Nota

Tutti i campi di testo accettano variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nome

Digitare un nome per l'attività immediata. Questo nome verrà visualizzato nell'elenco delle attività immediate nel Pannello di controllo per utenti o computer. Gli elementi preferenza che configurano attività con lo stesso nome possono generare conflitti.

Esegui

Digitare il comando da eseguire senza includere argomenti.

Argomenti

Digitare eventuali argomenti della riga di comando necessari.

Da

Per specificare la directory di lavoro per il comando in esecuzione (in genere per assicurare la risoluzione corretta di eventuali nomi di file relativi), indicare la directory utilizzata per l'avvio dell'attività. Non includere virgolette o barre finali.

Commenti

Digitare una descrizione dell'attività. Questa descrizione è visibile per utenti o computer a cui è applicato l'elemento preferenza.

Esegui come

Configurare il contesto di sicurezza in cui viene eseguita l'attività.

  • Se l'elemento fa parte di Configurazione computer, l'attività verrà eseguita nel contesto di sicurezza dell'account SYSTEM per impostazione predefinita.

  • Se l'elemento fa parte di Configurazione utente, l'attività verrà eseguita nel contesto di sicurezza dell'utente connesso. L'attività viene eseguita solo se l'utente ha effettuato l'accesso al computer, ma può continuare anche dopo la disconnessione dell'utente.

  • Per eseguire un'attività nel contesto di sicurezza di un account specificato, in modo che venga eseguita indipendentemente dall'account connesso, selezionare la casella di controllo Esegui come e immettere le credenziali dell'account.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Altre impostazioni dell'attività immediata

Nella scheda Impostazioni configurare le impostazioni per gestire il comportamento dell'attività dopo il suo completamento, se il computer è in uso o in specifiche condizioni di alimentazione.

Ulteriori considerazioni

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Attività pianificate

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Servizi

Criteri di gruppo comprende l'estensione della preferenza Servizi che consente di configurare i servizi attualmente installati sui computer.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Servizio in qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione computer

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Servizi

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Servizio

  • Configurare opzioni comuni


Configurare un elemento Servizio

L'estensione della preferenza Servizi consente di configurare i servizi esistenti nei computer utilizzando un elemento preferenza Servizio. Prima di creare un elemento preferenza Servizio, è opportuno esaminare il comportamento di ogni tipo di azione possibile con l'estensione.

Creare un elemento Servizio

Per creare un nuovo elemento preferenza Servizio

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione computer espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Servizi, scegliere Nuovo e selezionare Servizio.

  4. Nella finestra di dialogo Proprietà nuovo elemento Servizio selezionare un'azione da eseguire per Criteri di gruppo in Azione. Per ulteriori informazioni, vedere la sezione "Azioni servizio" in questo argomento.

  5. Immettere le impostazioni del servizio che Criteri di gruppo deve configurare o rimuovere. Per ulteriori informazioni, vedere la sezione "Impostazioni servizio" in questo argomento.

  6. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  7. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Azioni servizio

Nessuna modifica | L'utilizzo di questa azione non modifica lo stato attuale del servizio in questione.
Avvia servizio | Utilizzare questa azione per avviare il servizio in questione. Questa azione non ha effetto se il servizio in questione è già avviato.
Arresta servizio | Utilizzare questa azione per arrestare il servizio in questione. Questa azione non ha effetto se il servizio in questione è già arrestato.
Riavvia servizio | Utilizzare questa azione per arrestare e riavviare il servizio in questione.
Riavvia servizio se necessario | Utilizzare questa azione per arrestare il servizio in questione qualora vi sia un'azione di configurazione che richiede il riavvio.
Nota

L'avvio e l'arresto di un servizio hanno luogo dopo che l'estensione della preferenza ha elaborato tutte le altre impostazioni di configurazione. Questo è il motivo per il quale i servizi non possono essere avviati o riavviati qualora la modalità di avvio sia impostata su disabilitato.

Impostazioni servizio

Avvio

Scegliere il tipo di avvio per il servizio

  • Nessun cambiamento: Utilizzare questa impostazione se non si desidera modificare il tipo di avvio.

  • Automatico: Utilizzare questa impostazione per configurare l'avvio automatico del servizio durante il processo di avvio e accesso.

  • Disabilitato: Utilizzare questa impostazione per disabilitare il servizio. La disabilitazione del servizio ne impedisce l'avvio.

  • Automatico (avvio ritardato): Utilizzare questa impostazione per configurare l'avvio automatico del servizio durante il processo di avvio e accesso. L'avvio del servizio viene leggermente ritardato durante il processo di avvio e accesso così da incrementare le prestazioni dell'accesso.

Nome servizio

Digitare il nome univoco del servizio oppure fare clic su Sfoglia (…) per selezionare un servizio nell'elenco dei servizi installati sul computer corrente.

Importante

Il nome univoco di un servizio non sempre corrisponde al nome visualizzato. Ad esempio, il nome univoco del servizio Server è LanmanServer.

Timeout di attesa se il servizio è bloccato

Digitare un valore di timeout, espresso in secondi, che l'estensione della preferenza deve attendere prima di scrivere i dati di configurazione qualora il servizio sia bloccato o stia passando da uno stato a un altro tra avvio, arresto o riavvio.

Connessione: Nessuna modifica

Utilizzare questa impostazione per conservare le credenziali di accesso del servizio configurate in precedenza.

Connessione: Account di sistema locale

Utilizzare questa impostazione per modificare le credenziali di accesso del servizio impostandole sull'account di sistema locale.

Consenti al servizio di interagire col desktop

Selezionare questa casella di controllo per consentire al servizio di interagire con il desktop. Questa impostazione non è disponibile se non si fa clic sull'opzione Account di sistema locale.

Connessione: Il seguente account

Utilizzare questa impostazione per modificare le credenziali di accesso del servizio impostandole su uno specifico utente locale o del dominio. Le impostazioni Il seguente account e Password diventano disponibili dopo che si è fatto clic su questa opzione.

Il seguente account

Digitare il nome utente che si utilizza per le credenziali di accesso del servizio oppure fare clic su Sfoglia (…) per selezionarlo.

Password

Digitare la password utilizzata per autenticare l'utente. Digitare la stessa password nella casella Conferma password.

Sicurezza Nota

Questa password utilizza la crittografia AES (Advanced Encryption Standard) a 256 bit e viene archiviata come parte dell'oggetto Criteri di gruppo in SYSVOL. È consigliabile cambiare tale password a scadenze regolari e non utilizzarla come unico mezzo per proteggere i dati riservati.

Azioni di ripristino

Configura il modo in cui il computer deve rispondere se il servizio non funziona dopo uno, due o più tentativi.

Nessun cambiamento | Utilizzare questa impostazione se non si desidera modificare l'azione di ripristino nel caso di un errore del servizio. L'estensione della preferenza non modifica l'azione di ripristino se è selezionata questa impostazione.
Nessuna azione | Utilizzare questa impostare per configurare il servizio affinché non risponda a una condizione di errore.
Riavvia il servizio | Utilizzare questa impostazione per configurare il servizio affinché si riavvii in caso di errore.
Riavvia il computer | Utilizzare questa impostazione per configurare il servizio affinché riavvii il computer in caso di errore.

Impostazioni di ripristino

Riavvia conteggio errori dopo | Digitare il numero di giorni che devono trascorrere prima che il conteggio degli errori del servizio venga reimpostato. Questa impostazione è disponibile se almeno una delle azioni di ripristino è impostata su un valore diverso da Nessun cambiamento.
Avvia servizio dopo | Digitare il numero di minuti che devono trascorrere prima che il servizio con errori venga riavviato. Questa impostazione è disponibile solo se almeno una delle azioni di ripristino è impostata su Riavvia il servizio.
Programma | Digitare il percorso completo del programma da avviare in risposta all'azione di ripristino Esegui un programma. In alternativa è possibile fare clic su Sfoglia (…) per selezionare l'applicazione. Utilizzare la casella Parametri riga di comando per fornire ulteriori argomenti della riga di comando per il programma. Questa impostazione è disponibile solo se almeno una delle azioni di ripristino è impostata su Esegui un programma.
Opzioni riavvio computer | Fare clic su Opzioni riavvio computer per impostare il tempo di attesa prima del riavvio di un servizio. È inoltre possibile includere un messaggio da trasmettere ai computer della rete per avvisare gli utenti dell'imminente riavvio del computer.

Ulteriori considerazioni

  • Utilizzare il formato .\nomeutente per specificare l'account di un utente locale in più computer.

  • Utilizzare il formato dominio\nomeutente per specificare un account di dominio.

  • Per tutti gli account utente, ad eccezione degli account per i quali la parte del dominio delle credenziali utente inizia con NT AUTHORITY, è necessario indicare la password.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Servizi

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Estensione Menu Start

In Criteri di gruppo è inclusa l'estensione della preferenza Menu Start. Per gli utenti, questa estensione consente di:

  • Richiedere una configurazione specifica del menu Start.

  • Definire una configurazione iniziale del menu Start, consentendo comunque agli utenti finali di apportare modifiche.

  • Configurare alcune impostazioni del menu Start consentendo ai singoli utenti finali di modificare le altre a propria discrezione.

Nota

Per aggiungere, modificare o rimuovere un collegamento nel menu Start, utilizzare un elemento preferenza Collegamento. Per ulteriori informazioni, vedere Estensione Collegamenti.

Informazioni introduttive

È possibile creare e configurare elementi preferenza Menu Start per qualsiasi oggetto Criteri di gruppo basato su dominio. È possibile configurare le impostazioni modificando un oggetto Criteri di gruppo tramite Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, è possibile trovare tale estensione delle preferenze nel percorso seguente:

Configurazione utente

└ Preferenze

└ Impostazioni del Pannello di controllo

└ Menu Start

Per informazioni su come utilizzare tale estensione per creare e configurare un elemento preferenza, vedere gli argomenti seguenti:

  • Configurare un elemento Menu Start (Windows Vista e versioni successive)

  • Configurare un elemento Menu Start (Windows XP)

  • Configurare opzioni comuni


Configurare un elemento Menu Start (Windows Vista e versioni successive)

Gli elementi preferenza Menu Start (Windows Vista® e versioni successive) consentono di aggiornare il menu Start per i computer che eseguono i sistemi operativi Windows Server® 2008 R2, Windows® 7, Windows Server 2008 e Microsoft Windows Vista. Gli elementi preferenza Menu Start non consentono di selezionare azioni in quanto la sola azione possibile è Aggiorna.

Creare un elemento Menu Start (Windows Vista e versioni successive)

Per creare un nuovo elemento preferenza Menu Start

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Menu Start, scegliere Nuovo e quindi Menu Start (Windows Vista e versioni successive).

  4. Nella finestra di dialogo Nuove proprietà menu Start (Windows Vista e versioni successive) immettere le opzioni del menu Start da configurare per Criteri di gruppo. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Non è possibile attivare o disattivare impostazioni non disponibili. Non è possibile configurare queste impostazioni utilizzando un elemento preferenza Menu Start.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Menu Start

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Configurare un elemento Menu Start (Windows XP)

Gli elementi preferenza Menu Start (Windows XP) consentono di aggiornare il menu Start dei computer che eseguono il sistema operativo Windows Server® 2003 o Windows XP. Gli elementi preferenza Menu Start non consentono di selezionare azioni in quanto la sola azione possibile è Aggiorna.

Creare un elemento Menu Start (Windows XP)

Per creare un nuovo elemento preferenza Menu Start

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console, in Configurazione utente espandere la cartella Preferenze, quindi la cartella Impostazioni del Pannello di controllo.

  3. Fare clic con il pulsante destro del mouse sul nodo Menu Start, scegliere Nuovo e selezionare Menu Start (Windows XP).

  4. Nella finestra di dialogo Proprietà nuovo elemento Menu Start (Windows XP) immettere le opzioni del menu Start che Criteri di gruppo deve configurare. Per ulteriori informazioni, vedere Attivare e disattivare impostazioni in un elemento preferenza.

  5. Fare clic sulla scheda Comune, configurare le opzioni desiderate e quindi digitare i propri commenti nella casella Descrizione. Per ulteriori informazioni, vedere Configurare opzioni comuni.

  6. Fare clic su OK. Nel riquadro Dettagli viene visualizzato il nuovo elemento preferenza.

Ulteriori considerazioni

  • Non è possibile attivare o disattivare impostazioni non disponibili. Non è possibile configurare queste impostazioni utilizzando un elemento preferenza Menu Start.

  • È possibile utilizzare la destinazione a livello di elemento per modificare l'ambito degli elementi preferenza.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Estensione Menu Start

  • Per ulteriori informazioni sulle impostazioni di configurazione in Windows, visitare il sito Web TechCenter di Windows Server 2008 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91710.


Destinazione a livello di elemento preferenza

Utilizzare la destinazione a livello di elemento per modificare l'ambito di singoli elementi preferenza in modo che siano validi solo per utenti o computer selezionati. All'interno di un singolo oggetto Criteri di gruppo, è possibile includere più elementi preferenza, ognuno personalizzato per utenti o computer selezionati e ognuno finalizzato ad applicare le impostazioni solo a utenti o computer correlati.

Ogni elemento destinazione fornisce un valore vero o falso. È possibile applicare più elementi destinazione a un elemento preferenza e selezionare l'operatore logico (AND o OR) con il quale unire ogni elemento destinazione a quello precedente. Se il valore combinato di tutti gli elementi destinazione per un elemento preferenza è falso, allora le impostazioni nell'elemento preferenza non verranno applicate all'utente o al computer. Utilizzando gruppi destinazione è inoltre possibile creare espressioni parentetiche.

Configurare un elemento destinazione

Per selezionare un elemento preferenza esistente in modo che sia valido solo per utenti o computer specifici

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo in cui dovrebbe essere contenuto il nuovo elemento preferenza, quindi fare clic su Modifica.

  2. Nell'albero della console in Configurazione computer o Configurazione utente espandere la cartella Preferenze e quindi selezionare l'estensione della preferenza.

  3. Fare doppio clic sul nodo relativo all'estensione della preferenza, fare clic con il pulsante destro del mouse sull'elemento preferenza e scegliere Proprietà.

  4. Nella finestra di dialogo Proprietà fare clic sulla scheda Comuni.

  5. Selezionare Destinazione a livello di elemento e quindi fare clic su Destinazione.

    1. Fare clic su Nuovo elemento, scegliere il tipo di elemento destinazione da applicare all'elemento preferenza e quindi configurare le impostazioni per l'elemento destinazione.

      Note
      • Per modificare il valore dell'elemento destinazione nel suo opposto, scegliere Non è dal menu Opzioni elemento.
      • I campi di testo accettano variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.
      • Per assegnare un nome personalizzato all'elemento destinazione, scegliere Etichetta dal menu Opzioni elemento e quindi digitare un nome.
      • Per assegnare un commento all'elemento destinazione, scegliere Etichetta dal menu Opzioni elemento e quindi digitare un commento.
    2. Se si configurano più elementi destinazione, dal menu Opzioni elemento scegliere l'operatore logico (And o Or) da utilizzare per combinare i risultati dell'elemento preferenza con l'elemento precedente.

      Nota

      Per creare un'espressione parentetica fare clic su Aggiungi gruppo. Per ulteriori informazioni, vedere Gruppo di destinazioni.

    3. Ripetere ogni elemento destinazione da applicare.

  6. Fare clic su OK e quindi di nuovo su OK nella finestra di dialogo Proprietà.

Tipi di elementi destinazione

È possibile configurare i tipi di elementi destinazione seguenti:

  • Destinazione Batteria presente

  • Destinazione Nome computer

  • Destinazione Velocità CPU

  • Destinazione Corrispondenza data

  • Destinazione Spazio su disco

  • Destinazione Dominio

  • Destinazione Variabile di ambiente

  • Destinazione Corrispondenza file

  • Destinazione Intervallo indirizzi IP

  • Destinazione Lingua

  • Destinazione Query LDAP

  • Destinazione Intervallo indirizzi MAC

  • Destinazione Query MSI

  • Destinazione Connessione di rete
  • Destinazione Sistema operativo

  • Destinazione Unità organizzativa

  • Destinazione PCMCIA presente

  • Destinazione Computer portatile

  • Destinazione Modalità di elaborazione

  • Destinazione RAM

  • Destinazione Corrispondenza Registro di sistema

  • Destinazione Gruppo di sicurezza

  • Destinazione Sito

  • Destinazione Sessione terminal

  • Destinazione Intervallo di tempo

  • Destinazione Utente

  • Destinazione Query WMI

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Se si desidera limitare l'ambito di più elementi preferenza con un insieme complesso di elementi destinazione, è possibile semplificare la configurazione utilizzando una variabile di ambiente. Ad esempio, creare un elemento preferenza Variabile di ambiente che genera una nuova variabile di ambiente con valore pari a 1 e applicarvi gli elementi destinazione. Per applicare la stessa destinazione ad altri elementi preferenza, aggiungere un elemento destinazione Variabile di ambiente a tali elementi preferenza e configurarlo per richiedere un valore pari a 1 per la variabile creata utilizzando un elemento preferenza Variabile di ambiente.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Configurare e commentare elementi preferenza e definirne la destinazione

  • Configurare opzioni comuni


Destinazione Batteria presente

Un elemento destinazione Batteria presente consente l'applicazione di un elemento preferenza a computer o utenti solo se nel computer sono presenti una o più batterie. Se si seleziona Non è, l'elemento preferenza verrà applicato solo se nel computer non sono presenti una o più batterie.

Ulteriori considerazioni

  • Se al computer è collegato un gruppo di continuità, l'elemento destinazione Batteria presente può rilevarlo e identificarlo come se fosse una batteria.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Questo elemento destinazione può essere utile per il rilevamento di computer portatili.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza

  • Destinazione PCMCIA presente

  • Destinazione Computer portatile


Destinazione Nome computer

Un elemento destinazione Nome computer consente di applicare un elemento preferenza ai computer o agli utenti solo se il nome del computer corrisponde a quello specificato nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il nome del computer non corrisponde a quello specificato nell'elemento destinazione.

Nome computer

Il nome computer con cui viene confrontato il nome del computer. Non viene applicata alcuna distinzione tra maiuscole e minuscole.

Nota

La casella Nome computer accetta variabili per l'elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

NetBIOS

Se questa opzione è selezionata, l'elemento destinazione confronta il nome specificato con il nome NetBIOS del computer (come specificato nella variabile %ComputerName%).

DNS

Se questa opzione è selezionata, l'elemento destinazione risolve il nome specificato in uno o più indirizzi IP utilizzando il comportamento risoluzione dei nomi di Windows attivo nel computer. L'elemento destinazione confronta quindi l'elenco di indirizzi IP ottenuto con tutti gli indirizzi IP associati a tutte le schede di rete del computer. Se esiste un'unica corrispondenza, l'elemento destinazione restituisce un valore true.

Note
  • È necessario scegliere NetBIOS oppure DNS.
  • Non è richiesto un formato specifico per il nome del computer, ad eccezione del fatto che deve essere possibile risolverlo in un indirizzo IP.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Se non vengono trovate corrispondenze in base al SID per gli elementi destinazione Nome computer (solo NetBIOS), Dominio, Sito, Sessione terminal e Utente, nelle relative caselle è possibile specificare uno (?) o più (*) caratteri jolly.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Velocità CPU

Un elemento destinazione Velocità CPU consente l'applicazione di un elemento preferenza a computer o utenti solo se la velocità della CPU del computer è maggiore o uguale al valore specificato nell'elemento destinazione. Se si seleziona Non è, l'elemento preferenza verrà applicato solo se la velocità della CPU del computer è inferiore o uguale al valore specificato nell'elemento destinazione.

MHz

La velocità espressa in megahertz (MHz) con la quale confrontare la CPU del computer.

Nota

Nella casella MHz è possibile immettere variabili di elaborazione di preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Corrispondenza data

Un elemento destinazione Corrispondenza data consente di applicare un elemento preferenza a computer o utenti solo se il giorno o la data corrisponde a quella specificata nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il giorno o la data non corrisponde a quella specificata nell'elemento destinazione.

Settimanale | Se si seleziona questa opzione, l'elemento preferenza verrà applicato solo il giorno della settimana specificato nell'elemento destinazione.
Mensile | Se si seleziona questa opzione, l'elemento preferenza verrà applicato solo il giorno specificato nell'elemento destinazione.
In data | Se si seleziona questa opzione, l'elemento preferenza verrà applicato nella data specificata nell'elemento destinazione. Se si seleziona Ogni anno, l'elemento preferenza verrà applicato ogni anno solo nel mese e nel giorno specificati.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Spazio su disco

Un elemento destinazione Spazio su disco consente di applicare un elemento preferenza ai computer o agli utenti solo se lo spazio su disco disponibile nel computer di elaborazione è maggiore o uguale alla quantità specificata nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se lo spazio su disco disponibile nel computer è minore o uguale alla quantità specificata nell'elemento destinazione.

Spazio disponibile su disco

La quantità di spazio, espressa in gigabyte (GB), con cui viene confrontato lo spazio disponibile dell'unità specificata. Sono consentiti i valori decimali, ad esempio ,5.

Nota

La casella Spazio disponibile su disco accetta variabili per l'elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Lettera unità

La lettera dell'unità di sistema o di un'unità specifica. Se si tratta dell'opzione relativa all'unità di sistema, l'elemento destinazione utilizzerà la variabile di ambiente SYSTEMDRIVE per determinare la lettera di unità. La lettera di unità specificata può essere mappata a un'unità di rete.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Dominio

Un elemento destinazione Dominio consente di applicare un elemento preferenza ai computer o agli utenti solo se l'utente è connesso al dominio o al gruppo di lavoro specificato nell'elemento destinazione oppure il computer è membro del dominio o del gruppo di lavoro. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se l'utente non è connesso al dominio o al gruppo di lavoro specificato nell'elemento destinazione oppure il computer non è membro del dominio o del gruppo di lavoro.

Nome dominio

Il nome NetBIOS con cui confrontare l'appartenenza al dominio.

Nota

La casella Nome dominio accetta variabili per l'elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Dominio a cui l'utente è connesso

Se questa opzione è selezionata, l'elemento destinazione confronta il nome di dominio specificato con il dominio a cui l'utente finale è connesso. Si tratta inoltre del dominio di cui l'utente è membro e viene utilizzata la variabile %LogonDomain% per il confronto.

Nota

Questa opzione è disponibile solo per gli elementi preferenza in Configurazione utente.

Dominio del computer

Se questa opzione è selezionata, l'elemento destinazione confronta il nome di dominio specificato con il dominio a cui appartiene il computer. Utilizza la varabile %DomainName% per il confronto.

Nota

È necessario selezionare Dominio a cui l'utente è connesso oppure Dominio del computer.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Se non vengono trovate corrispondenze in base al SID per gli elementi destinazione Nome computer (solo NetBIOS), Dominio, Sito, Sessione terminal e Utente, nelle relative caselle è possibile specificare uno (?) o più (*) caratteri jolly.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Variabile di ambiente

Un elemento destinazione Variabile di ambiente consente l'applicazione di un elemento preferenza a computer o utenti solo se la variabile di ambiente e il valore specificato nell'elemento destinazione sono uguali. Se si seleziona Non è, l'elemento preferenza verrà applicato solo se la variabile di ambiente e il valore specificato nell'elemento destinazione non sono uguali o se la variabile di ambiente non esiste.

Nome

Il nome della variabile di ambiente con cui confrontare il valore. Nel confronto dei nomi di variabile non viene fatta distinzione tra maiuscole e minuscole.

Nota

Il nome di variabile non può essere una variabile.

Valore

Il valore da confrontare con la variabile di ambiente specificata.

Nota

Nella casella Valore è possibile immettere variabili di elaborazione di preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Ulteriori considerazioni

  • Se si desidera limitare l'ambito di più elementi preferenza con un insieme complesso di elementi destinazione, è possibile semplificare la configurazione utilizzando una variabile di ambiente. Ad esempio, creare un elemento preferenza Variabile di ambiente che genera una nuova variabile di ambiente con valore pari a 1 e applicarvi gli elementi destinazione. Per applicare la stessa destinazione ad altri elementi preferenza, aggiungere un elemento destinazione Variabile di ambiente a tali elementi preferenza e configurarlo per richiedere un valore pari a 1 per la variabile creata utilizzando un elemento preferenza Variabile di ambiente.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Corrispondenza file

Un elemento destinazione Corrispondenza file consente di applicare un elemento preferenza a computer o utenti solo se il file o la cartella specificata nell'elemento destinazione esiste oppure se il file esiste e corrisponde a una versione compresa nell'intervallo specificato nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il file o la cartella specificata nell'elemento destinazione non esiste oppure solo se la versione del file non è compresa nell'intervallo specificato nell'elemento destinazione.

Tipo corrispondenza

Criteri in base ai quali valutare un file o una cartella:

  • File esistente o Cartella esistente: Se questa opzione è selezionata, l'elemento destinazione restituirà true se il file o la cartella specificata nella casella Percorso è esistente.

  • Corrispondenza versione file: se questa opzione è selezionata, l'elemento destinazione restituirà true se il file specificato nella casella Percorso esiste, dispone di una risorsa di versione e la versione è compresa nell'intervallo di versioni specificato.

Percorso

Percorso di un file o di una cartella. Se si seleziona Corrispondenza versione file, è necessario digitare il percorso di un file.

Nota

La casella Percorso accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Intervallo versione

Se si seleziona Corrispondenza versione file, immettere un intervallo di versioni per la corrispondenza. Ogni segmento del numero di versione deve essere maggiore o uguale a zero e minore o uguale a 65535.

Ad esempio, per specificare una versione maggiore o uguale a 1.0 ma minore di 8.5.1, selezionare >=, digitare 1 nella casella a sinistra (sostituendo il primo 0), selezionare < e sostituire i primi tre zero nella casella a destra con 8, 5 e 1.

Nota

La casella Intervallo versione viene visualizzata solo se si seleziona Corrispondenza versione file.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Intervallo indirizzi IP

Un elemento destinazione Intervallo indirizzi IP consente l'applicazione di un elemento preferenza a computer o utenti solo se l'indirizzo IP del computer fa parte dell'intervallo specificato nell'elemento destinazione. Se si seleziona Non è, l'elemento preferenza verrà apllicato solo se l'indirizzo IP del computer non fa parte dell'intervallo specificato nell'elemento destinazione.

Intervallo indirizzi IP

L'intervallo con il quale viene confrontato l'indirizzo IP del computer. I punti di inizio e di fine dell'intervallo sono inclusi. È possibile specificare un singolo indirizzo digitando lo stesso valore in entrambe le caselle.

Ulteriori considerazioni

  • Gli indirizzi IPv6 non sono supportati.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Lingua

Un elemento destinazione Lingua consente di applicare un elemento preferenza a computer o utenti solo le impostazioni locali specificate nell'elemento destinazione sono installate sul computer che esegue l'elaborazione. Opzioni aggiuntive consentono di limitare la destinazione alle impostazioni locali dell'utente o del computer. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se le impostazioni locali del computer che esegue l'elaborazione non corrispondono a quelle specificate nell'elemento destinazione.

Nota

Le impostazioni locali comprendono una lingua e, in alcuni casi, un'area geografica in cui la lingua viene parlata o l'alfabeto utilizzato. Ad esempio, Francese (Canada) sono le impostazioni locali della lingua francese e dell'area geografica Canada.

Lingua

Le impostazioni locali confrontate dall'elemento destinazione con quelle del computer che esegue l'elaborazione.

Nota

Se la casella di controllo Utente o Sistema è deselezionata, l'elemento destinazione consente di applicare l'elemento criteri associato se le impostazioni locali specificate sono installate sul computer che esegue l'elaborazione. Utilizzare Opzioni internazionali e della lingua nel Pannello di controllo per visualizzare l'elenco delle impostazioni locali installate.

Utente

Se si seleziona questa casella di controllo, la destinazione dell'elemento viene limitata per includere le impostazioni locali.

Importante

Questa opzione viene disabilitata negli elementi preferenza in Configurazione computer.

Sistema

Se si seleziona questa casella di controllo, la destinazione dell'elemento viene limitata per includere le impostazioni locali del sistema operativo.

Nativo

Se si seleziona questa casella di controllo, la destinazione dell'elemento viene limitata per includere le impostazioni locali specificate per il file NTDLL.DLL.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Query LDAP

Un elemento destinazione Query LDAP consente l'applicazione di un elemento preferenza a computer o utenti solo se la query LDAP restituisce un valore per l'attributo specificato nell'elemento destinazione. Se si seleziona Non è, l'elemento preferenza viene applicato solo se la query LDAP non restituisce un valore per l'attributo specificato nell'elemento destinazione.

Filtro

Ricerca LDAP utilizzata dall'elemento destinazione. Vengono cercati tutti i sottocontenitori. Se si desidera cercare un oggetto non contenitore, lasciare vuota questa casella e specificare il percorso completo dell'oggetto non contenitore nella casella Binding. Specificare questo valore nell'elemento di destinazione è facoltativo.

Esempio:

Questo filtro LDAP individua tutti gli utenti con cognomi che iniziano con la lettera A.
(&(objectClass=user)(sn= A*))

Binding

Percorso di un contenitore in cui viene eseguita la ricerca. Se si specifica un valore in Filtro, l'oggetto deve essere un contenitore. In caso contrario, si verifica un errore. Se non è possibile soddisfare il percorso specificato in Binding, si verifica un errore.

Nota

Nei prefissi di binding viene fatta distinzione tra maiuscole e minuscole. Tali prefissi devono essere in maiuscolo (LDAP).

Esempio:

  • Questo esempio consente di eseguire il binding alla radice dello spazio dei nomi.
    LDAP:

  • Questo esempio consente di eseguire il binding alla radice del catalogo globale.
    GC:

  • Questo esempio consente di eseguire il binding a un server specifico.
    LDAP://servername

  • Questo esempio consente di eseguire il binding a un contenitore specifico trame il nome distinto.
    LDAP://CN=LabUser1,OU=LAB,DC=contoso,DC=com

Attributo

Valore di attributo specificato restituito dalla ricerca. Specificare questo valore nell'elemento di destinazione è facoltativo.

Esempio:

In questo esempio viene mostrato come specificare l'attributo del nome canonico.
cn

Nome variabile di ambiente

Nome della variabile di ambiente in base al quale l'elemento destinazione imposta il valore di Attributo, nel caso ne venga individuato uno. Specificare questo valore nell'elemento di destinazione è facoltativo.

Importante

Questa opzione supporta solo i tipi di dati di Active Directory seguenti. Altri tipi di dati possono avere esito positivo ma restituiscono valori vuoti.
ADSTYPE_DN_STRING
ADSTYPE_CASE_EXACT_STRING
ADSTYPE_CASE_IGNORE_STRING
ADSTYPE_PRINTABLE_STRING
ADSTYPE_NUMERIC_STRING
ADSTYPE_OBJECT_CLASS
ADSTYPE_BOOLEAN

Nota

Se il valore dell'attributo restituito è un attributo multivalore, il primo elemento dell'elenco di valori viene assegnato alla variabile di ambiente.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

  • Gli elementi destinazione Query LDAP utilizzano l'opzione di ricerca del sottoalbero.

  • Gli elementi destinazione Query LDAP non cercano i riferimenti.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Intervallo indirizzi MAC

Un elemento destinazione Intervallo indirizzi MAC consente l'applicazione di un elemento preferenza a computer o utenti solo se uno degli indirizzi MAC del computer fa parte dell'intervallo specificato nell'elemento destinazione. Se si seleziona Non è, l'elemento preferenza verrà applicato solo se nessuno degli indirizzi MAC del computer fa parte dell'intervallo specificato nell'elemento destinazione.

Intervallo indirizzi MAC

L'intervallo con il quale vengono confrontati gli indirizzi MAC del computer. I punti di inizio e di fine dell'intervallo sono inclusi. È possibile specificare un singolo indirizzo digitando lo stesso valore in entrambe le caselle.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Query MSI

Un elemento destinazione Query MSI consente l'applicazione di un elemento preferenza a computer o utenti solo se determinati aspetti di un prodotto, un aggiornamento o un componente installato tramite Windows Installer nel computer di elaborazione corrispondono ai criteri specificati nell'elemento destinazione. Se è selezionata l'opzione Diverso da, l'elemento preferenza verrà applicato solo se determinati aspetti di un prodotto, un aggiornamento o un componente installato tramite Windows Installer nel computer non corrispondono ai criteri specificati nell'elemento destinazione.

Tipo di query

L'elemento destinazione consente di elaborare l'elemento preferenza associato nei casi seguenti:

  • Destinazione esistente

    • Prodotto: il prodotto con il valore specificato in Codice prodotto è installato.

    • Patch: l'aggiornamento con il valore specificato in Codice patch è installato.

    • Componente: il file chiave di un componente con il valore specificato in Codice componente è installato.

  • Corrispondenza versione

    • Prodotto: il prodotto con il valore specificato in Codice prodotto è compreso nell'intervallo di versioni specificato.

    • Componente: il file chiave di un componente con il valore specificato in Codice componente è compreso nell'intervallo di versioni specificato.

  • Recupero proprietà o Recupero informazioni

    • Prodotto: viene installato il prodotto con il valore Codice prodotto specificato.

    • Componente: viene installato il file chiave di un componente con il valore Codice componente specificato.

    L'elemento proprietà o informazioni è archiviato nella variabile specificata.

  • Corrispondenza proprietà o Corrispondenza informazioni

    L'elemento proprietà o informazioni corrisponde al valore specificato nell'elemento destinazione e:

    • Prodotto: viene installato il prodotto con il valore Codice prodotto specificato.

    • Componente: viene installato il file chiave di un componente con il valore Codice componente specificato.

    Nota

    L'elemento destinazione non consente di elaborare l'elemento preferenza se all'elemento proprietà o informazioni non è associato nessun valore.

Tipo di destinazione

Consente di definire la destinazione della query Windows Installer come prodotto installato, aggiornamento installato o componente.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Connessione di rete

Un elemento destinazione Connessione di rete consente di applicare un elemento preferenza agli utenti solo se è attiva una connessione di rete del tipo specificato nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se non è attiva nessuna connessione di rete del tipo specificato nell'elemento destinazione.

Nota

Gli elementi destinazione Connessione di rete rilevano se è presente un tipo di connessione di rete, non se l'utente ha eseguito l'accesso tramite un connessione di tale tipo.

Tipo di connessione

Il tipo di connessione di rete rilevata dall'elemento destinazione:

  • Qualsiasi (comprende solo i tipi di connessione di rete elencati di seguito)

  • Modem telefonico con accesso tramite porta COM

  • Scheda ISDN con driver NDISWAN corrispondente installato

  • Scheda X.25 con driver NDISWAN corrispondente installato

  • Rete privata virtuale (VPN)

  • Modalità di trasferimento asincrono

  • Frame Relay

  • Sonet

  • Accesso 56K commutato

  • Dispositivo IRDA (Infrared Data Association)

  • Connessione diretta porta seriale

  • Connessione diretta porta parallela

  • Generico

  • Assembler/disassembler pacchetti

  • PPPoE (PPP over Ethernet)

Se si seleziona l'opzione Qualsiasi, l'elemento destinazione consente di applicare un elemento preferenza a utenti se è attivo almeno uno dei tipi di connessione di rete disponibili nell'elenco Tipo di connessione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se nessuno dei tipi di connessione di rete elencati in precedenza è attivo.

Ulteriori considerazioni

  • La destinazione Connessione di rete è disponibile solo per gli elementi preferenza in Configurazione utente.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Sistema operativo

Un elemento destinazione Sistema operativo consente di applicare un elemento preferenza ai computer o agli utenti solo se il nome prodotto, la versione, l'edizione o il ruolo del computer del sistema operativo del computer di elaborazione corrisponde a quanto specificato nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il nome prodotto, la versione, l'edizione o il ruolo del computer del sistema operativo non corrisponde a quanto specificato nell'elemento destinazione.

Prodotto

Nome prodotto del sistema operativo.

Edizione

Edizione del prodotto, ad esempio Enterprise, Standard o Web.

Versione

Versione del prodotto. Se il Service Pack desiderato non è presente nell'elenco, digitarne il nome completo nella casella, ad esempio Service Pack 3.

Ruolo del computer

Ruolo del computer. Un computer che esegue Windows può essere associato a uno dei tre ruoli seguenti:

  • Workstation: un computer connesso a un dominio che esegue una versione qualsiasi di Windows® 7, Windows Vista® o Windows XP.

  • Server membro: un computer connesso a un dominio che esegue una versione qualsiasi di Windows Server® 2008 R2, Windows Server 2008 o Windows Server 2003.

  • Controller di dominio: un computer che esegue una versione qualsiasi di Windows Server 2008 R2, Windows Server 2008 o Windows Server 2003 e che ospita il servizio directory Active Directory® per il dominio.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Unità organizzativa

Un elemento destinazione Unità organizzativa consente di applicare un elemento preferenza a computer o utenti solo se sono membri dell'unità organizzativa specificata nell'elemento destinazione. Se si seleziona Non è, l'elemento preferenza viene applicato solo se l'utente o il computer non è membro dell'unità organizzativa specificata nell'elemento destinazione.

Unità organizzativa

L'unità organizzativa per cui individuare l'appartenenza. Non viene applicata alcuna distinzione tra maiuscole e minuscole. È possibile specificare un'unità organizzativa non qualificata (MySubUnit), parzialmente qualificata (OU=MyOrgUnit,OU=MySubUnit) oppure completa (OU=MyOrgUnit,OU=MySubUnit,DC=MyDC,DC=MyCompany,DC=com).

Nota

Nella casella Unità organizzativa è possibile immettere variabili di elaborazione preferenza. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Solo membro diretto

Se questa casella di controllo è selezionata, l'elemento destinazione restituisce true solo se l'utente o il computer è un membro diretto dell'unità organizzativa specificata. Se l'utente o il computer ha ereditato l'appartenenza, l'elemento destinazione restituisce false.

Utente nell'utente organizzativa

Se si seleziona questa opzione, l'elemento destinazione confronta l'unità organizzativa specificata con l'unità organizzativa di cui l'utente è membro.

Nota

Questa opzione è disponibile solo per elementi preferenza in Configurazione utente.

Computer nell'unità organizzativa

Se si seleziona questa opzione, l'elemento destinazione confronta l'unità organizzativa specificata con l'unità organizzativa di cui il computer è membro.

Nota

È necessario selezionare Utente nell'unità organizzativa oppure Computer nell'unità organizzativa.

Ulteriori considerazioni

  • Se un utente o un computer non è membro di un'unità organizzativa ma di un gruppo di sicurezza membro dell'unità organizzativa, l'utente o il computer non è membro dell'unità organizzativa.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione PCMCIA presente

Un elemento destinazione PCMCIA presente consente di applicare un elemento preferenza ai computer o agli utenti solo se il computer di elaborazione dispone di almeno uno slot PCMCIA. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il computer non dispone di alcuno slot PCMCIA.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Uno slot PCMCIA è considerato presente se i relativi driver sono installati e lo slot funziona correttamente.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza

  • Destinazione Batteria presente

  • Destinazione Computer portatile


Destinazione Computer portatile

Un elemento destinazione Computer portatile consente di applicare un elemento preferenza a computer o utenti solo se il computer utilizzato per l'elaborazione viene identificato come computer portatile nel profilo hardware corrente o come computer portatile con lo stato dell'alloggiamento di espansione specificato nell'elemento destinazione. Quando si seleziona l'opzione Non è, l'elemento destinazione consente di applicare l'elemento preferenza solo se il computer utilizzato per l'elaborazione non viene identificato come computer portatile nel profilo hardware corrente o se lo stato dell'alloggiamento di espansione di tale computer è diverso da quello specificato nell'elemento destinazione.

Stato alloggiamento di espansione

Per consentire l'applicazione dell'elemento preferenza solo se il computer utilizzato per l'elaborazione è portatile ed è stato specificato uno stato dell'alloggiamento di espansione, selezionare uno stato dell'alloggiamento di espansione. È possibile selezionare una qualsiasi combinazione di stati:

  • Inserito

  • Non inserito

  • Sconosciuto

Nota

Selezionare uno stato dell'alloggiamento di espansione nell'elemento di destinazione è facoltativo. Se non viene selezionato nessuno stato o vengono selezionati tutti, l'elemento destinazione rileverà solo se il computer utilizzato per l'elaborazione è un computer portatile.

Ulteriori considerazioni

  • Per definire la destinazione di computer portatili, possono essere utili anche le destinazioni Batteria presente e PCMCIA presente.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Modalità di elaborazione

Un elemento destinazione Modalità di elaborazione consente di applicare un elemento preferenza ai computer o agli utenti solo se la modalità di elaborazione o le condizioni di Criteri di gruppo nel computer di elaborazione corrispondono ad almeno una di quelle specificate nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se la modalità di elaborazione e le condizioni di Criteri di gruppo nel computer di elaborazione non corrispondono ad alcuna di quelle specificate nell'elemento destinazione.

Sincrona

Se questa casella di controllo è selezionata, l'elemento destinazione determina se Criteri di gruppo viene elaborato in modo sincrono. L'elaborazione sincrona garantisce il completamento dell'elaborazione di Criteri di gruppo per l'avvio del computer e l'accesso dell'utente prima che a quest'ultimo venga concesso di accedere o che venga visualizzato il desktop.

Asincrona

Se questa casella di controllo è selezionata, l'elemento destinazione determina se Criteri di gruppo viene elaborato in modo asincrono. L'elaborazione asincrona consente all'utente di accedere mentre è in corso l'elaborazione di Criteri di gruppo del computer. Consente inoltre il caricamento del desktop dell'utente (dopo l'accesso) durante l'elaborazione di Criteri di gruppo dell'utente.

Background

Se questa casella di controllo è selezionata, l'elemento destinazione determina se Criteri di gruppo viene elaborato in background. L'elaborazione di Criteri di gruppo in background, nota anche come "aggiornamento in background", viene eseguita regolarmente ogni 90-120 minuti per applicare nuove impostazioni di Criteri di gruppo all'utente o al computer.

Condizioni di elaborazione

Per ogni casella di controllo selezionata tra quelle indicate di seguito, l'elemento destinazione determina se la condizione di elaborazione corrispondente è attiva:

  • Aggiornamento forzato: l'aggiornamento in background è stato forzato.

  • Transizione collegamento: si è verificata una modifica nella velocità di collegamento tra l'applicazione corrente e un'applicazione precedente di Criteri di gruppo.

  • Nessuna modifica: nessuna nuova impostazione di Criteri di gruppo è applicata al computer o all'utente.

  • Transizione Gruppo di criteri risultante: si è verificata una modifica nella registrazione di Gruppo di criteri risultante tra l'applicazione corrente e un'applicazione precedente di Criteri di gruppo.

  • Collegamento lento: l'applicazione di Criteri di gruppo viene eseguita su una connessione di rete lenta.

  • Modalità provvisoria: Windows funziona in modalità provvisoria.

  • Registrazione dettaglia: è attivata la registrazione dettagliata.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione RAM

Un elemento Destinazione RAM consente l'applicazione di un elemento preferenza a computer o utenti solo se la quantità totale di memoria fisica del computer è maggiore o uguale alla quantità specificata nell'elemento destinazione. Se si seleziona Non è, l'elemento preferenza verrà applicato solo se la quantità totale di memoria fisica del computer è inferiore alla quantità specificata nell'elemento destinazione

MB

La quantità totale di memoria fisica espressa in megabyte (MB). Un gigabyte (GB) di memoria fisica viene espresso con 1024. Quattro gigabyte di memoria fisica vengono espressi con 4096.

Nota

Nella casella MB è possibile immettere variabili di elaborazione di preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Corrispondenza Registro di sistema

Un elemento destinazione Corrispondenza Registro di sistema consente di applicare un elemento preferenza a computer o utenti solo se la chiave o il valore del Registro di sistema specificato nell'elemento destinazione esiste, se il valore del Registro di sistema contiene i dati specificati nell'elemento destinazione o se il numero di versione nel valore del Registro di sistema è compreso nell'intervallo specificato nell'elemento destinazione. Se l'elemento destinazione consente l'elemento preferenza e se la casella di controllo Ottieni dati valore è selezionata nell'elemento destinazione, i dati valore del valore del Registro di sistema specificato verranno salvati nella variabile di ambiente specificata nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se la chiave o il valore del Registro di sistema specificato nell'elemento destinazione non esiste, se il valore del Registro di sistema non contiene i dati specificati nell'elemento destinazione o se il numero di versione nel valore del Registro di sistema non è compreso nell'intervallo specificato nell'elemento destinazione.

Tipo corrispondenza

Criteri in base ai quali valutare una chiave o un valore del Registro di sistema:

  • Chiave esistente: consente di applicare l'elemento preferenza se è presente la chiave del Registro di sistema specificata.

  • Valore esistente: consente di applicare l'elemento preferenza se è presente il valore del Registro di sistema specificato.

  • Corrispondenza dati valore: consente di applicare l'elemento preferenza se il valore del Registro di sistema specificato è presente e corrisponde al valore specificato.

    Tipo corrispondenza dati valore: consente di applicare l'elemento preferenza nei casi seguenti:

    • Qualsiasi: il valore del Registro di sistema esiste e corrisponde al valore specificato.

    • Corrispondenza sottostringa: il valore del Registro di sistema è presente e contiene la sottostringa specificata.

    • Corrispondenza versione: il numero di versione della stringa trovato nel valore del Registro di sistema specificato è compreso nell'intervallo configurato.

  • Ottieni dati valore: consente di applicare l'elemento preferenza se il valore del Registro di sistema specificato è presente e corrisponde al tipo di valore specificato. Inoltre, consente di salvare i dati valore per quel valore del Registro di sistema nella variabile di ambiente specificata.

Hive

L'hive del Registro di sistema per il valore o la chiave da associare.

Nota

È possibile fare clic sul pulsante Sfoglia nell'elemento destinazione per selezionare un hive del Registro di sistema esistente, percorso chiave e valore.

Percorso chiave

La chiave del Registro di sistema da associare, omettendo il nome hive.

Nota

La casella Percorso chiave accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Nome valore

Il nome del valore da associare. Per specificare il valore predefinito per la chiave, selezionare la casella di controllo Nome predefinito.

Note
  • La casella Nome valore accetta variabili di elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.
  • Questa opzione è disponibile solo se il tipo di corrispondenza è Valore esistente, Corrispondenza dati valore, Formato decimale, Corrispondenza sottostringa, Corrispondenza versione o Ottieni dati valore.

Tipo valore

Il tipo del valore da associare. Per ignorare il tipo di valore, selezionare Qualsiasi.

Nota

Questa opzione è disponibile solo se il tipo di corrispondenza è Valore esistente, Corrispondenza dati valore, Formato decimale, Corrispondenza sottostringa, Corrispondenza versione o Ottieni dati valore.

Dati valore

I dati valore da associare.

Nota

Questa opzione è disponibile solo se il tipo di corrispondenza è Corrispondenza dati valore, Formato decimale o Corrispondenza sottostringa.

Nome variabile

Il nome della variabile di ambiente in cui vengono salvati i dati del valore del Registro di sistema se l'elemento destinazione consente l'applicazione dell'elemento preferenza.

Nota

Questa opzione è disponibile solo se il tipo di corrispondenza è Ottieni dati valore.

Intervallo versione

Un intervallo versione da confrontare con la stringa di versione separata da punti o separata da virgole nei dati valore per il valore del Registro di sistema specificato. Ogni segmento versione deve essere maggiore o uguale a zero e inferiore o uguale a 65535.

Per specificare, ad esempio, una versione maggiore o uguale a 1.0 ma inferiore a 8.5.1, selezionare >=, digitare 1 nella casella a sinistra (sostituendo il primo 0), selezionare < e sostituire i primi tre zeri nella casella a destra con 8, 5 e 1.

Nota

Questa opzione è disponibile solo se il tipo di corrispondenza è Corrispondenza versione.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Gruppo di sicurezza

Un elemento destinazione Gruppo di sicurezza consente di applicare un elemento preferenza a computer e utenti solo se il computer o l'utente che esegue l'elaborazione è un membro del gruppo specificato nell'elemento destinazione e, facoltativamente, solo se il gruppo specificato è un gruppo primario per il computer o l'utente che esegue l'elaborazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il computer o l'utente che esegue l'elaborazione non è un membro del gruppo specificato nell'elemento destinazione e, facoltativamente, solo se il gruppo specificato non è un gruppo primario per il computer o l'utente che esegue l'elaborazione.

Gruppo

Questa casella contiene il nome del gruppo di sicurezza selezionato. Fare clic su Sfoglia per selezionare il gruppo di sicurezza. Non è possibile digitare direttamente nella casella di testo.

Importante

Il nome del gruppo viene visualizzato per scopi di riferimento ma non viene utilizzato per determinarne l'appartenenza. Se si modifica un nome gruppo, il nome gruppo originale rimane nell'elemento destinazione.

Gruppo primario

Se si seleziona questa casella di controllo, l'elemento destinazione elabora l'elemento preferenza associato solo se il gruppo specificato è il gruppo primario dell'utente che esegue l'elaborazione.

Nota

Questa opzione è disabilitata quando è selezionata l'opzione Computer nel gruppo.

Utente nel gruppo

Se selezionata, l'elemento destinazione elabora l'elemento preferenza associato quando l'utente che esegue l'elaborazione è un membro del gruppo specificato in Gruppo.

Nota

Questa opzione è disabilitata negli elementi preferenza computer.

Computer nel gruppo

Se selezionata, l'elemento destinazione elabora l'elemento preferenza associato quando il computer che esegue l'elaborazione è un membro del gruppo specificato in Gruppo.

Gruppi supportati

Gruppi di dominio:

  • Gruppi globali

  • Gruppi universali

Gruppi locali:

  • Gruppi locali (compresi i gruppi predefiniti)

  • Locale di dominio

  • Conosciuti

Ulteriori considerazioni

  • Gli elementi destinazione Gruppo di sicurezza utilizzano l'ID di sicurezza del gruppo per determinare l'appartenenza al gruppo e non il nome visualizzato per il gruppo.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Sito

Un elemento destinazione Sito consente l'applicazione di un elemento preferenza a computer o utenti solo se il computer si trova nel sito di Active Directory specificato nell'elemento destinazione. Se si seleziona Non è, l'elemento preferenza verrà applicato solo se il computer non si trova nel sito di Active Directory specificato nell'elemento destinazione.

Sito

Il nome di sito con il quale confrontare il sito in cui risiede il computer. Non viene applicata alcuna distinzione tra maiuscole e minuscole.

Nota

Nella casella Sito è possibile immettere variabili di elaborazione di preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Se non vengono trovate corrispondenze in base al SID per gli elementi destinazione Nome computer (solo NetBIOS), Dominio, Sito, Sessione terminal e Utente, nelle relative caselle è possibile specificare uno (?) o più (*) caratteri jolly.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Gruppo di destinazioni

Gli elementi destinazione applicati a un elemento preferenza vengono valutati come un'espressione logica. Un gruppo di destinazioni consente di creare un raggruppamento parentetico all'interno dell'espressione. È possibile nidificare un gruppo di destinazioni in un altro per creare espressioni logiche più complesse.

Un gruppo di destinazioni consente di applicare un elemento preferenza a computer o utenti solo se il gruppo di elementi destinazione specificato produce un valore true. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il gruppo di elementi destinazione specificato restituisce un valore false.

Ulteriori considerazioni

  • Se si desidera limitare l'ambito di più elementi preferenza con un insieme complesso di elementi destinazione, è possibile semplificare la configurazione utilizzando una variabile di ambiente. Ad esempio, creare un elemento preferenza Variabile di ambiente che genera una nuova variabile di ambiente con valore pari a 1 e applicarvi gli elementi destinazione. Per applicare la stessa destinazione ad altri elementi preferenza, aggiungere un elemento destinazione Variabile di ambiente a tali elementi preferenza e configurarlo per richiedere un valore pari a 1 per la variabile creata utilizzando un elemento preferenza Variabile di ambiente.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Sessione terminal

Un elemento destinazione Sessione terminal consente di applicare un elemento preferenza agli utenti solo se l'utente che esegue l'elaborazione è connesso a una sessione terminal con le impostazioni specificate nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se l'utente non è connesso a una sessione terminal o se l'utente è connesso a una sessione terminal senza le impostazioni specificate nell'elemento destinazione.

Tipo o protocollo
  • Qualsiasi: qualsiasi tipo di sessione terminal.

  • Servizi Desktop remoto: una sessione di Servizi Desktop remoto basata su Remote Desktop Protocol (RDP), incluso Desktop remoto.

Nota

La destinazione Sessione terminal non è disponibile durante la configurazione delle impostazioni di Criteri di gruppo per computer.

Parametro
  • Qualsiasi: la destinazione non è limitata da parametri.

  • Nome applicazione: il nome pubblicato dell'applicazione.

  • Nome client: il nome del computer utilizzato per connettersi alla sessione terminal.

  • Programma iniziale: il percorso e il nome del programma iniziale.

  • Nome sessione: il nome della sessione terminal utilizzato dall'utente. Un tipico nome di sessione di Servizi Desktop remoto inizia con "RDP_tpc", seguito da un valore numerico.

  • Directory di lavoro: la directory di lavoro della sessione, situata sul server.

  • Indirizzo TCP/IP client: l'intervallo degli indirizzi TCP/IP del computer client.

    Nota

    Gli indirizzi IPv6 non sono supportati.

Valore del parametro

Il valore necessario per il Parametro. Se il Parametro è impostato su Qualsiasi, questa opzione non è disponibile.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Se non vengono trovate corrispondenze in base al SID per gli elementi destinazione Nome computer (solo NetBIOS), Dominio, Sito, Sessione terminal e Utente, nelle relative caselle è possibile specificare uno (?) o più (*) caratteri jolly.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Intervallo di tempo

Un elemento destinazione Intervallo di tempo consente di applicare un elemento preferenza a computer o utenti solo se l'ora attuale sul computer dell'utente finale è compresa nell'intervallo di tempo specificato nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se l'ora attuale sul computer dell'utente finale non è compresa nell'intervallo specificato nell'elemento destinazione.

Intervallo di tempo

L'intervallo di tempo rispetto al quale viene confrontata l'ora attuale. Se l'orario specificato nella casella a sinistra è posteriore a quello specificato nella casella a destra, quest'ultimo è considerato come relativo al giorno successivo.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Utente

Un elemento destinazione Utente consente di applicare un elemento preferenza agli utenti solo se l'utente in questione è quello specificato nell'elemento destinazione. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se l'utente non corrisponde a quello specificato nell'elemento destinazione.

Utente

Il nome utente o l'ID di sicurezza (SID) con cui viene confrontato l'utente. Non viene applicata alcuna distinzione tra maiuscole e minuscole.

  • Se è selezionata l'opzione Confronta ID di sicurezza, è necessario cercare e selezionare l'utente. Sebbene il dominio e il nome dell'utente siano visualizzati al momento della selezione, l'elemento destinazione salva il SID dell'utente per il confronto con quello dell'utente di elaborazione.

  • Se l'opzione Confronta ID di sicurezza è deselezionata, è possibile selezionare oppure digitare un nome utente. Non includere il nome del dominio. L'elemento destinazione confronta il nome utente specificato con quello dell'utente di elaborazione.

    Nota

    La casella Utente accetta variabili per l'elaborazione delle preferenze. Premere F3 per visualizzare l'elenco delle variabili da cui è possibile selezionare.

Ulteriori considerazioni

  • La definizione della destinazione Utente è disponibile solo per gli elementi preferenza in Configurazione utente.

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Se non vengono trovate corrispondenze in base al SID per gli elementi destinazione Nome computer (solo NetBIOS), Dominio, Sito, Sessione terminal e Utente, nelle relative caselle è possibile specificare uno (?) o più (*) caratteri jolly.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Destinazione Query WMI

Un elemento destinazione Query WMI consente di applicare un elemento preferenza a computer o utenti solo se il computer utilizzato per l'elaborazione valuta la query WMI come true. Se si seleziona l'opzione Non è, l'elemento preferenza verrà applicato solo se il computer utilizzato per l'elaborazione valuta la query WMI come false.

Query | Testo della query WMI. Esempio L'elemento destinazione consente di elaborare l'elemento preferenza associato se il fuso orario del computer è impostato su Fuso orientale. Select * from win32_timezone where bias = -300
Spazio dei nomi | Spazio dei nomi WMI in cui eseguire la query. Il valore predefinito è Root\cimv2.
Proprietà | Nome di una proprietà specifica da assegnare a una variabile. Specificare questo valore nell'elemento di destinazione è facoltativo.
Nome variabile | Nome della variabile di ambiente su cui l'elemento destinazione imposta il valore di Proprietà, se ne viene trovata una. Specificare questo valore nell'elemento di destinazione è facoltativo.

Ulteriori considerazioni

  • Per riposizionare l'elemento destinazione all'interno dell'elenco degli elementi destinazione applicati a un elemento preferenza, trascinare l'elemento destinazione in una nuova posizione oppure selezionare l'elemento destinazione e fare clic sulla freccia Sposta su o Sposta giù.

  • Gli elementi preferenza sono disponibili solo negli oggetti Criteri di gruppo basati su domini.

Ulteriori riferimenti

  • Destinazione a livello di elemento preferenza


Configurare opzioni comuni

Numerosi elementi preferenza Criteri di gruppo condividono opzioni comuni. Ogni elemento preferenza visualizza queste opzioni nella scheda Comuni. Le opzioni comuni sono coerenti tra le estensioni della preferenza e consentono di controllare la gestione degli errori per una particolare estensione, il contesto di sicurezza utilizzato dall'estensione durante l'elaborazione delle impostazioni configurazione utente, l'ambito e l'applicazione degli elementi preferenza, nonché la destinazione a livello di elemento, che offre opzioni di filtro a livello di elemento preferenza in aggiunta al filtro Criteri di gruppo.

Configurare opzioni comuni

Le opzioni comuni comprendono:

  • Arrestare elaborazione elementi dell'estensione se si verifica un errore in questo elemento

  • Esegui nel contesto di sicurezza dell'utente connesso (opzione criterio utente)

  • Rimuovere elemento quando non viene più applicato

  • Applicare una sola volta e non riapplicare

  • Destinazione a livello di elemento

Arresta elaborazione elementi dell'estensione se si verifica un errore

Ogni estensione della preferenza può contenere uno o più elementi preferenza.

  • Per impostazione predefinita, un elemento preferenza che causa un errore non impedisce l'elaborazione di altri elementi preferenza nella stessa estensione.

  • Se si seleziona l'opzione Arresta elaborazione elementi dell'estensione se si verifica un errore in questo elemento, un elemento preferenza che causa un errore impedisce l'elaborazione degli elementi preferenza rimanenti nell'estensione. Questa modifica del comportamento è limitata all'oggetto Criteri di gruppo host e non è estesa ad altri oggetti Criteri di gruppo.

    Importante

    Le estensioni della preferenza avviano l'elaborazione degli elementi preferenza dalla parte inferiore dell'elenco e proseguono verso la parte superiore. Verranno applicati gli elementi preferenza precedenti a quello che causa un errore. L'estensione della preferenza arresta solo l'elaborazione degli elementi preferenza che seguono quello che causa un errore.

Esegui nel contesto di sicurezza dell'utente connesso (opzione criterio utente)

Esistono due contesti di sicurezza in cui Criteri di gruppo applica preferenze utente: l'account SYSTEM e l'utente connesso.

  • Per impostazione predefinita, Criteri di gruppo elabora le preferenze utente utilizzando il contesto di sicurezza dell'account SYSTEM. In questo contesto di sicurezza l'estensione della preferenza è limitata alle variabili di ambiente e alle risorse di sistema disponibili solo per il computer.

  • Se si seleziona l'opzione Esegui nel contesto di sicurezza dell'utente connesso (opzione criterio utente), verrà modificato il contesto di sicurezza in cui l'elemento preferenza viene elaborato. L'estensione della preferenza elabora gli elementi preferenza nel contesto di sicurezza dell'utente connesso. Questo consente di accedere alle risorse come utente anziché come computer ed è particolarmente importante quando si utilizzano mappe unità o altre preferenze in cui è possibile che il computer non disponga delle autorizzazioni di accesso alle risorse o quando si utilizzano variabili di ambiente. Il valore di numerose variabili di ambiente è diverso quando viene valutato in un ambiente di sicurezza diverso dall'utente connesso.

Rimuovi elemento quando non viene più applicato

Criteri di gruppo applica impostazioni criterio ed elementi preferenza a utenti e computer. Per determinare quali utenti e computer ricevono questi elementi, collegare uno o più oggetti Criteri di gruppo a siti, domini o unità organizzative Active Directory. Gli oggetti utente e computer che risiedono in questi contenitori riceveranno impostazioni criterio ed elementi preferenza definiti nell'oggetto Criteri di gruppo collegato poiché si trovano nell'ambito di questo oggetto.

  • A differenza delle impostazioni criterio, per impostazione predefinita gli elementi preferenza non vengono rimossi quando l'oggetto Criteri di gruppo diventa esterno all'ambito per l'utente o il computer.

  • Se si seleziona l'opzione Rimuovi elemento quando non viene più applicato, il comportamento verrà modificato. Dopo che l'opzione è stata selezionata, l'estensione della preferenza determina se l'elemento preferenza non deve essere applicato a utenti e computer di destinazione (esterni all'ambito). Se l'estensione della preferenza determina che l'elemento preferenza è esterno all'ambito, le impostazioni associate all'elemento preferenza verranno rimosse.

    Importante

    La selezione di questa opzione modifica l'azione in Sostituisci. Durante l'applicazione di Criteri di gruppo, l'estensione della preferenza ricrea (elimina e crea) i risultati dell'elemento preferenza. Se l'elemento preferenza è esterno all'ambito per l'utente o il computer, i risultati dell'elemento preferenza verranno eliminati ma non creati. Gli elementi preferenza possono diventare esterni all'ambito se si utilizza la destinazione a livello di elemento o filtri Criteri di gruppo di livello più elevato, ad esempio WMI e filtri di gruppo di sicurezza.

    Nota

    L'opzione Rimuovi elemento quando non viene più applicato non è disponibile se l'azione dell'elemento preferenza è impostata su Elimina.

Applica una sola volta e non riapplicare

Gli elementi preferenza vengono applicati quando Criteri di gruppo viene aggiornato.

  • Per impostazione predefinita, i risultati degli elementi preferenza vengono riscritti ogni volta che si aggiorna Criteri di gruppo. Questo assicura che i risultati degli elementi preferenza siano coerenti con quanto progettato dall'amministratore nell'oggetto Criteri di gruppo.

  • Se si seleziona l'opzione Applica una sola volta e non riapplicare, questo comportamento verrà modificato in modo da applicare i risultati dell'elemento preferenza all'utente o al computer una sola volta. Questa opzione è utile quando non si desidera riapplicare i risultati di un elemento preferenza.

Destinazione a livello di elemento

Criteri di gruppo dispone di filtri per controllare quali impostazioni criterio ed elementi preferenza applicare a utenti e computer. Le preferenze forniscono un livello di filtro aggiuntivo denominato destinazione. La destinazione a livello di elemento consente di controllare la validità di un elemento preferenza per un gruppo di utenti o computer. Per ulteriori informazioni, vedere Destinazione a livello di elemento preferenza.

Ulteriori riferimenti

  • Impostazioni di Windows

  • Impostazioni del Pannello di controllo


Attivare e disattivare impostazioni in un elemento preferenza

Oltre ad attivare e disattivare elementi preferenza in un oggetto Criteri di gruppo, è possibile attivare e disattivare singolarmente impostazioni con sottolineatura o precedute da un cerchio in un elemento preferenza.

La sottolineatura o il cerchio indica se l'impostazione è attualmente attivata o disattivata:

Impostazione attivata | Impostazione attivata | Un'impostazione con una sottolineatura continua di colore verde o un cerchio verde è attivata. L'estensione della preferenza applicherà il valore di questa impostazione all'utente o al computer.
Impostazione disattivata | Impostazione disattivata | Un'impostazione con una sottolineatura tratteggiata di colore rosso o un cerchio rosso con una barra è disattivata. L'estensione della preferenza non applicherà il valore di questa impostazione all'utente o al computer.

Per attivare o disattivare queste impostazioni in un elemento preferenza, è possibile utilizzare i tasti funzione.

F5 | Consente di attivare tutte le impostazioni presenti nella scheda corrente.
F6 | Consente di attivare l'impostazione attualmente selezionata.
F7 | Consente di disattivare l'impostazione attualmente selezionata.
F8 | Consente di disattivare tutte le impostazioni presenti nella scheda corrente.

Ulteriori riferimenti

  • Estensione Opzioni cartella

  • Estensione Impostazioni Internet

  • Estensione Opzioni risparmio energia

  • Estensione Opzioni internazionali

  • Estensione Menu Start


Variabili negli elementi preferenza

Le estensioni delle preferenze supportano le variabili di ambiente di Windows e generano numerose variabili di ambiente di elaborazione aggiuntive. Per il valore di un parametro di configurazione può essere utilizzata una qualsiasi variabile. In ogni documento della Guida viene indicato se le variabili sono supportate nei diversi campi.

Nota

Se si utilizzano gli elementi destinazione Destinazione Corrispondenza Registro di sistema, è possibile definire variabili in fase di esecuzione del client e fare in modo che queste controllino il comportamento mediante gli elementi destinazione Destinazione Variabile di ambiente o come valori in un'impostazione dell'elemento preferenza.

Variabili di ambiente di Windows

L'ambiente di Windows è costituito da un elenco di variabili salvate sotto forma di coppie nome/valore. Per visualizzare l'elenco di variabili corrente, digitare SET al prompt dei comandi. Ogni processo, incluso il desktop, dispone di un elenco di variabili univoco. Quando un processo ne avvia un altro, in genere una copia dell'ambiente del processo di avvio viene passata al processo avviato. In genere, i nomi delle variabili di ambiente sono racchiusi tra due segni di percentuale, ad esempio %ProgramFiles%. Windows risolve la variabile di ambiente quando un'applicazione richiede il valore associato al nome.

Variabili di elaborazione delle preferenze

Le estensioni delle preferenze implementano le variabili di elaborazione seguenti.

Nota

Per le variabili non viene fatta distinzione tra maiuscole e minuscole.

%AppDataDir% | La directory Dati applicazioni dell'utente corrente.
%BinaryComputerSid% | L'ID di sicurezza (SID) del computer in formato esadecimale.
%BinaryUserSid% | L'ID di sicurezza (SID) dell'utente corrente in formato esadecimale.
%CommonAppdataDir% | La directory Dati applicazioni di "All Users".
%CommonDesktopDir% | La directory Desktop di "All Users".
%CommonFavoritesDir% | La directory Preferiti di "All Users".
%CommonProgramsDir% | La directory Programmi di "All Users".
%CommonStartMenuDir% | La directory Menu Start di "All Users".
%CommonStartUpDir% | La directory Avvio di "All Users".
%ComputerName% | Il nome NetBIOS del computer.
%CurrentProcessId% | L'ID numerico del processo client principale.
%CurrentThreadId% | L'ID numerico del thread client principale.
%DateTime% | Data e ora correnti (UTC).
%DateTimeEx% | Data e ora correnti (UTC) con millisecondi.
%DesktopDir% | La directory Desktop dell'utente corrente.
%DomainName% | Il nome del dominio o del gruppo di lavoro del computer.
%FavoritesDir% | La directory Preferiti dell'utente corrente.
%LastError% | L'ultimo codice di errore generato durante la configurazione.
%LastErrorText% | Il testo della descrizione dell'ultimo codice di errore.
%LdapComputerSid% | L'ID di sicurezza (SID) del computer nel formato binario con caratteri di escape di LDAP.
%LdapUserSid% | L'ID di sicurezza (SID) dell'utente corrente nel formato binario con caratteri di escape di LDAP.
%LocalTime% | L'ora locale corrente.
%LocalTimeEx% | L'ora locale corrente con millisecondi.
%LogonDomain% | Il dominio dell'utente corrente.
%LogonServer% | Il controller di dominio che ha autenticato l'utente corrente.
%LogonUser% | Il nome dell'utente corrente.
%LogonUserSid% | L'ID di sicurezza (SID) dell'utente corrente.
%MacAddress% | Il primo indirizzo MAC rilevato nel computer.
%NetPlacesDir% | La directory Risorse di rete dell'utente corrente.
%OsVersion% | Il sistema operativo: Windows Server® 2008 R2, Windows® 7, Windows Server® 2008, Windows Vista®, Windows Server 2003, Windows XP o Sconosciuto.
%ProgramFilesDir% | La directory Programmi di Windows.
%ProgramsDir% | La directory Programmi dell'utente corrente.
%RecentDocumentsDir% | La directory Documenti recenti dell'utente corrente.
%ResultCode% | Il codice di uscita del client.
%ResultText% | Il testo della descrizione del codice di uscita del client.
%ReversedComputerSid% | Il SID del computer in formato esadecimale in ordine di byte inverso.
%ReversedUserSid% | Il SID dell'utente corrente in formato esadecimale in ordine di byte inverso.
%SendToDir% | La directory Invia a dell'utente corrente.
%StartMenuDir% | La directory Menu Start dell'utente corrente.
%StartUpDir% | La directory Avvio dell'utente corrente.
%SystemDir% | La directory system di Windows.
%SystemDrive% | Il nome dell'unità da cui viene eseguito il sistema operativo.
%TempDir% | La directory Temp dell'utente corrente come determinata dall'API Windows.
%TimeStamp% | Il timestamp delle configurazioni implementate.
%TraceFile% | Il percorso/nome del file di traccia.
%WindowsDir% | La directory Windows.

Le estensioni delle preferenze includono un elenco di variabili che è possibile scegliere di inserire nelle caselle di testo. È possibile aprire la finestra di dialogo da qualsiasi casella di testo:

  • Non disattivata.

  • Non di sola lettura.

  • Non limitata a valori numerici.

Per immettere una variabile

  1. Aprire Console Gestione Criteri di gruppo. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo contenente l'elemento preferenza che si desidera configurare e quindi scegliere Modifica.

  2. Posizionare il cursore nella casella desiderata.

    • Per immettere una variabile di elaborazione delle preferenze, premere F3, selezionare una variabile dall'elenco e quindi fare clic su Seleziona per inserire la variabile nella casella.

    • Per immettere una variabile di ambiente di Windows esistente, digitarla nella casella.

      Nota

      È possibile impedire che una variabile venga risolta prima dell'applicazione al computer client, in modo che nell'impostazione della preferenza nei computer client venga visualizzata la variabile invece del relativo valore risolto. A tale scopo, per una variabile di elaborazione delle preferenze, deselezionare la casella di controllo Risolvi variabile. In questo modo verranno inseriti i caratteri <> tra i delimitatori % % e il nome della variabile (ad esempio, %<ProgramFiles>%). Le estensioni delle preferenze rimuovono i caratteri < > dal testo e lasciano la variabile non risolta. È inoltre possibile utilizzare questa sintassi con le variabili di ambiente di Windows.

Ulteriori riferimenti

  • Configurare e commentare elementi preferenza e definirne la destinazione


Ripristinare, importare, copiare oggetti Criteri di gruppo ed eseguirne il backup

  • Eseguire il backup di un oggetto Criteri di gruppo

  • Ripristinare la versione precedente o eliminata di un oggetto Criteri di gruppo esistente

  • Copiare un oggetto Criteri di gruppo

  • Importare le impostazioni da un oggetto Criteri di gruppo

  • Utilizzare tabelle di migrazione


Eseguire il backup di un oggetto Criteri di gruppo

Per eseguire il backup di un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo aprire Oggetti Criteri di gruppo nella foresta e nel dominio contenenti l'oggetto Criteri di gruppo di cui eseguire il backup.

  2. Per eseguire il backup di un singolo oggetto Criteri di gruppo, fare clic con il pulsante destro del mouse sull'oggetto e quindi scegliere Backup. Per eseguire il backup di tutti gli oggetti Criteri di gruppo presenti nel dominio, fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo e quindi scegliere Esegui backup di tutto.

  3. Nella casella Percorso della finestra di dialogo Backup oggetto Criteri di gruppo immettere il percorso della cartella in cui si desidera archiviare le copie di backup degli oggetti Criteri di gruppo oppure fare clic su Sfoglia, individuare la cartella desiderata e quindi fare clic su OK.

  4. Nella casella Descrizione digitare una descrizione per gli oggetti Criteri di gruppo di cui si desidera eseguire il backup e quindi fare clic su Backup. Se si esegue il backup di più oggetti Criteri di gruppo, la descrizione verrà applicata a tutte le copie di backup.

  5. Al termine dell'operazione, fare clic su OK.

    Importante

    Per proteggere gli oggetti Criteri di gruppo di cui è stato eseguito il backup, assicurarsi che solo gli amministratori autorizzati possano accedere alla cartella in cui verranno esportati gli oggetti.

Ulteriori considerazioni

  • Per eseguire questa procedura è necessario disporre delle autorizzazioni di lettura per l'oggetto Criteri di gruppo e di scrittura per la cartella contenente la copia di backup dell'oggetto Criteri di gruppo.

  • La funzione di backup può inoltre essere utilizzata come caratteristica di esportazione per gli oggetti Criteri di gruppo.

Ulteriori riferimenti

  • Ripristinare, importare, copiare oggetti Criteri di gruppo ed eseguirne il backup


Ripristinare la versione precedente o eliminata di un oggetto Criteri di gruppo esistente

Per ripristinare la versione precedente o eliminata di un oggetto Criteri di gruppo esistente

  1. Nell'albero di Console Gestione Criteri di gruppo individuare l'opzione Oggetti Criteri di gruppo nella foresta e nel dominio contenenti l'oggetto Criteri di gruppo che si desidera ripristinare.

  2. Fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo e quindi scegliere Gestione backup.

  3. Nella casella Percorso backup della finestra di dialogo Gestione backup digitare il percorso della cartella di backup. È inoltre possibile utilizzare il pulsante Sfoglia per individuare la cartella di backup.

  4. Nella casella Oggetti Criteri di gruppo sottoposti a backup selezionare l'oggetto Criteri di gruppo che si desidera ripristinare nell'elenco contenente le copie di backup disponibili e quindi fare clic su Ripristina.

  5. Quando viene richiesto di confermare l'operazione di ripristino, fare clic su OK.

  6. Al termine dell'operazione, fare clic su OK e quindi su Chiudi.

Ulteriori considerazioni

  • Per ripristinare un oggetto Criteri di gruppo eliminato, è necessario disporre dei privilegi necessari per creare oggetti Criteri di gruppo nel dominio e autorizzazioni di lettura nel percorso del file system dell'oggetto Criteri di gruppo di backup.

  • È inoltre possibile ripristinare un oggetto Criteri di gruppo esistente o eliminato tramite la funzione Gestione backup facendo clic con il pulsante destro del mouse su Domini.

Ulteriori riferimenti

  • Ripristinare, importare, copiare oggetti Criteri di gruppo ed eseguirne il backup


Copiare un oggetto Criteri di gruppo

È possibile copiare un oggetto Criteri di gruppo tramite il metodo di trascinamento della selezione o facendo clic con il pulsante destro del mouse. In questo argomento vengono descritti entrambi i metodi.

Per copiare un oggetto Criteri di gruppo (metodo di trascinamento della selezione)

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic sull'oggetto Criteri di gruppo che si desidera copiare.

  2. Eseguire una delle operazioni seguenti:

    • Per creare una copia dell'oggetto Criteri di gruppo nello stesso dominio dell'oggetto di origine, trascinare l'oggetto da copiare in Oggetti Criteri di gruppo, selezionare un'opzione di autorizzazione in Specificare le autorizzazioni per il nuovo oggetto Criteri di gruppo e quindi fare clic su OK.

    • Per creare una copia dell'oggetto Criteri di gruppo in un dominio diverso, fare doppio clic sul dominio di destinazione e quindi trascinare l'oggetto Criteri di gruppo che si desidera copiare in Oggetti Criteri di gruppo. Rispondere a tutte le domande visualizzate nella Copia guidata tra domini e quindi fare clic su Fine.

Per copiare un oggetto Criteri di gruppo (metodo del clic con il pulsante destro del mouse)

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse sull'oggetto da copiare e quindi scegliere Copia.

  2. Eseguire una delle operazioni seguenti:

    • Per creare una copia dell'oggetto Criteri di gruppo nello stesso dominio dell'oggetto di origine, fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo, scegliere Incolla, specificare le autorizzazioni per il nuovo oggetto Criteri di gruppo nella casella Copia oggetto Criteri di gruppo e quindi fare clic su OK.

    • Per creare una copia dell'oggetto Criteri di gruppo in un dominio diverso, fare doppio clic sul dominio di destinazione, fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo e quindi scegliere Incolla. Rispondere a tutte le domande visualizzate nella Copia guidata tra domini e quindi fare clic su Fine.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario disporre dei privilegi necessari per creare oggetti Criteri di gruppo nel dominio di destinazione.

  • Per le operazioni di copia in un dominio diverso, potrebbe essere necessario specificare una tabella di migrazione.

Ulteriori riferimenti

  • Ripristinare, importare, copiare oggetti Criteri di gruppo ed eseguirne il backup

  • Utilizzare tabelle di migrazione


Importare le impostazioni da un oggetto Criteri di gruppo

Per importare le impostazioni da un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo espandere il nodo Oggetti Criteri di gruppo nella foresta e nel dominio contenenti l'oggetto Criteri di gruppo da cui importare le impostazioni.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo e quindi scegliere Importa impostazioni.

  3. Seguire le istruzioni visualizzate nell'Importazione guidata impostazioni.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario disporre delle autorizzazioni di modifica per l'oggetto Criteri di gruppo in cui si desidera importare le impostazioni.

  • Per le operazioni di importazione in una foresta o un dominio diverso, potrebbe essere necessario specificare una tabella di migrazione.

Ulteriori riferimenti

  • Ripristinare, importare, copiare oggetti Criteri di gruppo ed eseguirne il backup

  • Utilizzare tabelle di migrazione


Utilizzare tabelle di migrazione

Le tabelle di migrazione vengono utilizzate quando si copia o si importa un oggetto Criteri di gruppo da una foresta all'altra o da un dominio all'altro. L'aspetto più impegnativo durante la migrazione di oggetti Criteri di gruppo da una foresta o da un dominio a un altro è rappresentato dal fatto che alcune informazioni contenute nell'oggetto Criteri di gruppo sono specifiche della foresta o del dominio in cui è stato definito l'oggetto stesso. Durante il trasferimento dell'oggetto Criteri di gruppo in un nuovo dominio o in una nuova foresta, non è talvolta consigliabile, né persino possibile, utilizzare le stesse impostazioni. È possibile utilizzare una tabella di migrazione per associare utenti, gruppi, computer e percorsi UNC inclusi nell'oggetto Criteri di gruppo di origine ai nuovi valori inclusi nell'oggetto Criteri di gruppo di destinazione.

È possibile creare tabelle di migrazione tramite Editor tabelle di migrazione.

In questa sezione vengono descritti gli argomenti seguenti:

  • Popolare automaticamente una tabella di migrazione da un oggetto Criteri di gruppo

  • Creare una tabella di migrazione

Ulteriori riferimenti

  • Ripristinare, importare, copiare oggetti Criteri di gruppo ed eseguirne il backup

  • Per ulteriori informazioni sulle tabelle di migrazione di Console Gestione Criteri di gruppo, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=63300.


Popolare automaticamente una tabella di migrazione da un oggetto Criteri di gruppo

È possibile utilizzare l'Editor tabelle di migrazione per analizzare uno o più oggetti Criteri di gruppo o oggetti Criteri di gruppo di backup per estrarre tutti i riferimenti alle entità di sicurezza e ai percorsi UNC e quindi immettere automaticamente tali elementi nella tabella di migrazione come voci per i nomi di origine.

Per popolare automaticamente una tabella di migrazione da un oggetto Criteri di gruppo

  1. Aprire l'Editor tabelle di migrazione.

  2. Scegliere Popola da oggetto Criteri di gruppo dal menu Strumenti.

  3. Nell'elenco a discesa Specificare il dominio in cui eseguire la ricerca selezionare il dominio contenente l'oggetto Criteri di gruppo.

  4. Nell'elenco Oggetti Criteri di gruppo fare clic sull'oggetto o sugli oggetti Criteri di gruppo da cui si desidera eseguire il popolamento della tabella di migrazione, se necessario selezionare Durante l'analisi includi entità di sicurezza DACL nell'oggetto Criteri di gruppo e quindi fare clic su OK.
Per popolare automaticamente una tabella di migrazione da un oggetto Criteri di gruppo di backup

  1. Aprire l'Editor delle tabelle di migrazione.

  2. Scegliere Popola da backup dal menu Strumenti.

  3. Nell'elenco a discesa Percorso backup digitare il percorso della cartella contenente l'oggetto Criteri di gruppo di backup oppure fare clic su Sfoglia per individuare la cartella.

  4. Nell'elenco Oggetti Criteri di gruppo sottoposti a backup selezionare uno o più oggetti Criteri di gruppo di backup, se necessario selezionare Mostra solo l'ultima versione di ogni oggetto o Durante l'analisi includi entità di sicurezza DACL nell'oggetto Criteri di gruppo e quindi fare clic su OK.

Ulteriori considerazioni

  • Per completare la tabella di migrazione per entrambe le procedure, è necessario regolare solo i valori relativi alla destinazione. Per impostazione predefinita, quando si utilizza una delle opzioni di popolamento, il nome della destinazione per ogni voce viene impostato su Uguale all'origine.

Ulteriori riferimenti

  • Utilizzare tabelle di migrazione


Creare una tabella di migrazione

Per creare una tabella di migrazione

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta da cui si desidera creare una tabella di migrazione.

  2. Eseguire una delle operazioni seguenti:

    • Fare clic con il pulsante destro del mouse su Domini e quindi scegliere Apri Editor tabelle di migrazione.

    • Fare clic con il pulsante destro del mouse su Oggetti Criteri di gruppo e quindi scegliere Apri Editor tabelle di migrazione.

  3. Specificare l'origine che si desidera includere nella tabella di migrazione eseguendo le operazioni seguenti:

    1. In Nome origine digitare il nome dell'origine oppure fare clic con il pulsante destro del mouse sulla cella e scegliere Sfoglia per trovare e quindi specificare il tipo di oggetto, il percorso e il nome.

      Se si immette il nome dell'origine manualmente, è necessario digitare il nome esatto dell'utente, del computer, del gruppo o del percorso UNC utilizzato come riferimento nell'oggetto Criteri di gruppo di origine (ad esempio, DominioTest\AmministratoriCriteri o \\server1\condivisionepubblica). Il tipo di nome di origine deve corrispondere al tipo di origine specificato nella tabella di migrazione.

      Le entità di sicurezza possono essere specificate utilizzando uno dei formati seguenti:

      UPN: ad esempio prova@contoso.com.

      SAM: ad esempio contoso\prova.

      DNS: ad esempio contoso.com\prova.

      Testo libero: ad esempio prova. È necessario specificare il tipo come testo libero o SID.

      SID: ad esempio S-1-11-111111111-111111111-1111111111-1112. È necessario specificare il tipo come testo libero o SID.

    2. In Tipo di origine selezionare il tipo di origine appropriato nell'elenco a discesa della cella adiacente a quella del nome di origine. Se è stato utilizzato Sfoglia per individuare il nome di origine, il tipo di origine verrà immesso automaticamente per impostazione predefinita.

    3. In Nome destinazione digitare il nome di destinazione oppure fare clic con il pulsante destro del mouse sulla cella adiacente a quelle del nome e del tipo di origine e quindi eseguire una delle operazioni seguenti:

      Scegliere Sfoglia per cercare un utente, un computer o un gruppo.

      Scegliere Imposta destinazione e quindi fare clic sull'opzione appropriata. Non è possibile utilizzare l'opzione Nessuna destinazione per i percorsi UNC.

  4. Ripetere il passaggio 3 per ogni origine che si desidera includere nella tabella di migrazione.

  5. Scegliere Salva dal menu File.

  6. Specificare il percorso in cui si desidera salvare la tabella di migrazione e quindi fare clic su Salva.

Ulteriori considerazioni

  • È possibile utilizzare l'Editor tabelle di migrazione per verificare che sia possibile risolvere le voci di destinazione. Se le voci di destinazione non vengono risolte nella tabella di migrazione, è possibile che l'operazione di copia o di importazione non riesca. Per convalidare la tabella di migrazione, scegliere Convalida dal menu Strumenti.

Ulteriori riferimenti

  • Utilizzare tabelle di migrazione


Controllare l'ambito degli oggetti Criteri di gruppo

  • Collegare un oggetto Criteri di gruppo

  • Applicare un filtro tramite i gruppi di sicurezza

  • Imporre un collegamento a un oggetto Criteri di gruppo

  • Disattivare le impostazioni utente o del computer in un oggetto Criteri di gruppo

  • Disabilitare un collegamento a un oggetto Criteri di gruppo

  • Utilizzare filtri WMI

  • Bloccare l'eredità

Ulteriori riferimenti

  • Sito Web TechCenter relativo a Criteri di gruppo


Collegare un oggetto Criteri di gruppo

Per collegare un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo individuare il sito, il dominio o l'unità organizzativa a cui si desidera collegare un oggetto Criteri di gruppo.

  2. Eseguire una delle operazioni seguenti:

    • Per collegare un oggetto Criteri di gruppo esistente, fare clic con il pulsante destro del mouse sul dominio o l'unità organizzativa all'interno del dominio e quindi scegliere Collega oggetto Criteri di gruppo esistente. Nella finestra di dialogo Seleziona oggetto Criteri di gruppo fare clic sull'oggetto Criteri di gruppo che si desidera collegate e quindi fare clic su OK.

    • Per collegare un nuovo oggetto Criteri di gruppo, fare clic con il pulsante destro del mouse sul dominio o l'unità organizzativa all'interno del dominio e quindi scegliere Crea un oggetto Criteri di gruppo in questo dominio e crea qui un collegamento. Nella casella Nome digitare un nome per il nuovo oggetto Criteri di gruppo e quindi fare clic su OK.

Ulteriori considerazioni

  • Per collegare un oggetto Criteri di gruppo a un sito, un dominio o un'unità organizzativa, è necessario disporre dell'autorizzazione Collega oggetti Criteri di gruppo per tale sito, dominio o unità organizzativa. Per impostazione predefinita, solo gli amministratori di dominio e gli amministratori dell'organizzazione dispongono di questo privilegio per i domini e le unità organizzative. Gli amministratori di dominio e gli amministratori dell'organizzazione per il dominio radice della foresta dispongono di questo privilegio per i siti.

  • Per creare e collegare un oggetto Criteri di gruppo, è necessario disporre delle autorizzazioni Collega oggetti Criteri di gruppo per l'unità organizzativa o il dominio desiderato, nonché dell'autorizzazione necessaria per creare oggetti Criteri di gruppo nel dominio. Per impostazione predefinita, solo gli amministratori di dominio, gli amministratori dell'organizzazione e i membri del gruppo Proprietari autori criteri di gruppo dispongono delle autorizzazioni necessarie per creare oggetti Criteri di gruppo.

  • L'opzione Crea un oggetto Criteri di gruppo in questo dominio e crea qui un collegamento non è disponibile per i siti. L'amministratore può creare un oggetto Criteri di gruppo in qualsiasi dominio della foresta e quindi utilizzare l'opzione Collega oggetto Criteri di gruppo esistente per collegarlo al sito.

Ulteriori riferimenti

  • Controllare l'ambito degli oggetti Criteri di gruppo


Applicare un filtro tramite i gruppi di sicurezza

Per applicare un filtro tramite i gruppi di sicurezza

  1. Nell'albero di Console Gestione Criteri di gruppo espandere Oggetti Criteri di gruppo e fare clic sull'oggetto Criteri di gruppo a cui si desidera applicare i filtri di sicurezza.

  2. Nella scheda Ambito all'interno del riquadro risultati fare clic su Aggiungi.

  3. Nella casella Immettere il nome dell'oggetto da selezionare digitare il nome del gruppo, dell'utente o del computer a cui si desidera aggiungere il filtro di sicurezza. Fare clic su OK.

Ulteriori considerazioni

  • Per assicurare che solo i membri del gruppo o dei gruppi aggiunti nel passaggio 3 possano ricevere le impostazioni incluse nell'oggetto Criteri di gruppo, è necessario rimuovere il gruppo Authenticated Users se questo è visualizzato nella scheda Ambito. Fare clic sulla scheda Ambito, selezionare il gruppo e quindi fare clic su Rimuovi.

  • Per eseguire queste procedure è necessario disporre delle autorizzazioni Modifica impostazioni, elimina, modifica sicurezza per l'oggetto Criteri di gruppo.

  • Le impostazioni contenute in un oggetto Criteri di gruppo verranno applicate solo agli utenti e ai computer inclusi nel dominio, nell'unità organizzativa o nelle unità organizzative a cui è collegato l'oggetto Criteri di gruppo e che sono specificati in Filtri di sicurezza o appartengono a un gruppo specificato in Filtri di sicurezza.

Ulteriori riferimenti

  • Controllare l'ambito degli oggetti Criteri di gruppo


Imporre un collegamento a un oggetto Criteri di gruppo

Per imporre un collegamento a un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta contenente il dominio, il sito o l'unità organizzativa in cui è incluso il collegamento che si desidera imporre e quindi eseguire una delle operazioni seguenti:

    • Per imporre un collegamento a un oggetto Criteri di gruppo a livello di dominio, fare doppio clic su Domini e quindi sul dominio contenente il collegamento all'oggetto Criteri di gruppo.

    • Per imporre un collegamento a un oggetto Criteri di gruppo a livello di unità organizzativa, fare doppio clic su Domini, sul dominio contenente l'unità organizzativa e quindi sull'unità organizzativa contenente il collegamento all'oggetto Criteri di gruppo.

    • Per imporre un collegamento a un oggetto Criteri di gruppo a livello di sito, fare doppio clic su Siti e quindi sul sito contenente il collegamento all'oggetto Criteri di gruppo.

  2. Fare clic con il pulsante destro del mouse sul collegamento all'oggetto Criteri di gruppo e quindi scegliere Imposto per attivare o disattivare l'imposizione del collegamento. Un segno di spunta visualizzato accanto all'opzione Imposto indica che il collegamento è stato imposto.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario disporre dell'autorizzazione Collega oggetti Criteri di gruppo per il dominio, il sito o l'unità organizzativa contenente il collegamento all'oggetto Criteri di gruppo.

  • Per determinare se un collegamento a un oggetto Criteri di gruppo è stato imposto, è inoltre possibile fare clic sul collegamento e quindi esaminare le informazioni visualizzate nella sezione Collegamenti della scheda Ambito.

Ulteriori riferimenti

  • Controllare l'ambito degli oggetti Criteri di gruppo


Disattivare le impostazioni utente o del computer in un oggetto Criteri di gruppo

Per disattivare le impostazioni utente o del computer in un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta contenente il dominio o l'unità organizzativa in cui è incluso l'oggetto Criteri di gruppo.

  2. Fare doppio clic sul dominio o sull'unità organizzativa.

  3. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo contenente le impostazioni utente o del computer che si desidera disattivare, scegliere Stato oggetto Criteri di gruppo e quindi eseguire una delle operazioni seguenti:

    • Fare clic su Impostazioni utente disattivate per disattivare le impostazioni utente per l'oggetto Criteri di gruppo.

    • Fare clic su Impostazioni computer disattivate per disattivare le impostazioni del computer per l'oggetto Criteri di gruppo.

  4. Un segno di spunta accanto all'opzione Impostazioni utente disattivate o Impostazioni computer disattivate indica che le impostazioni corrispondenti sono disattivate.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario disporre dell'autorizzazione Modifica per l'oggetto Criteri di gruppo.

  • È inoltre possibile modificare l'impostazione di Stato oggetto Criteri di gruppo nella scheda Dettagli di un oggetto Criteri di gruppo.

Ulteriori riferimenti

  • Controllare l'ambito degli oggetti Criteri di gruppo


Disabilitare un collegamento a un oggetto Criteri di gruppo

Per disabilitare un collegamento a un oggetto Criteri di gruppo

  • Nell'albero di Console Gestione Criteri di gruppo fare doppio clic per espandere la foresta contenente il dominio, il sito o l'unità organizzativa in cui è incluso il collegamento che si desidera disabilitare e quindi eseguire una delle operazioni seguenti:

    Fare clic con il pulsante destro del mouse sul collegamento all'oggetto Criteri di gruppo. Un segno di spunta visualizzato accanto all'opzione Collegamento abilitato indica che il collegamento è abilitato.

    Fare clic su Collegamento abilitato per disabilitare il collegamento. Se il collegamento è disabilitato, il segno di spunta non viene visualizzato.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario disporre dell'autorizzazione Collega oggetti Criteri di gruppo per il dominio, il sito o l'unità organizzativa.

  • Per determinare se il collegamento a un oggetto Criteri di gruppo è abilitato, è inoltre possibile fare clic sul collegamento e quindi esaminare le informazioni visualizzate nella sezione Collegamenti della scheda Ambito.

Ulteriori riferimenti

  • Controllare l'ambito degli oggetti Criteri di gruppo


Utilizzare filtri WMI

I filtri di Strumentazione gestione Windows (WMI) consentono di determinare in modo dinamico l'ambito degli oggetti Criteri di gruppo in base agli attributi del computer di destinazione.

Quando un oggetto Criteri di gruppo collegato a un filtro WMI viene applicato nel computer di destinazione, il filtro viene valutato nel computer di destinazione stesso. Se il risultato del filtro WMI è False, l'oggetto Criteri di gruppo non viene applicato, a meno che il computer client non esegua Windows 2000, nel qual caso il filtro viene ignorato e l'oggetto Criteri di gruppo viene sempre applicato. Se il risultato del filtro WMI è True, l'oggetto Criteri di gruppo viene applicato.

In questa sezione vengono descritti gli argomenti seguenti:

  • Creare un filtro WMI

  • Importare un filtro WMI

  • Esportare un filtro WMI

  • Copiare un filtro WMI

  • Collegare un filtro WMI a un oggetto Criteri di gruppo

Ulteriori riferimenti

  • Controllare l'ambito degli oggetti Criteri di gruppo


Creare un filtro WMI

Per creare un filtro WMI, eseguire la procedura seguente.

Per creare un filtro WMI

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su Filtri WMI nella foresta e nel dominio in cui si desidera creare un filtro WMI.

  2. Fare clic su Nuovo.

  3. Nella finestra di dialogo Nuovo filtro WMI digitare un nome per il nuovo filtro WMI nella casella Nome e quindi digitare una descrizione del filtro nella casella Descrizione.

  4. Fare clic su Aggiungi.

  5. Nella finestra di dialogo Query WMI lasciare lo spazio dei nomi predefinito (root\CIMv2) oppure immetterne uno nuovo eseguendo una delle operazioni seguenti:

    • Nella casella Spazio dei nomi digitare il nome dello spazio dei nomi che si desidera utilizzare per la query WMI.

    • Fare clic su Sfoglia, selezionare uno spazio dei nomi nell'elenco e quindi fare clic su OK.

  6. Digitare una query WMI nella casella Query e quindi fare clic su OK.

  7. Per aggiungere altre query, ripetere i passaggi da 4 a 6 per ogni query.

  8. Dopo avere aggiunto tutte le query, fare clic su Salva.

Ulteriori considerazioni

  • È necessario disporre dei privilegi per creare i filtri WMI nel dominio in cui si desidera creare il filtro. Per impostazione predefinita, gli amministratori di dominio, gli amministratori dell'organizzazione e i membri del gruppo Proprietari autori criteri di gruppo dispongono di queste autorizzazioni.

  • L'opzione Filtri WMI è disponibile solo se almeno un controller di dominio presente nel dominio esegue Microsoft Windows Server™ 2003. Lo stesso vale per l'opzione Filtri WMI della scheda Ambito per Oggetti Criteri di gruppo.

  • Per eliminare un filtro WMI, nell'albero della console fare clic con il pulsante destro del mouse sul filtro WMI e quindi scegliere Elimina. Quando viene richiesto di confermare l'eliminazione del filtro WMI, fare clic su Sì.

  • I filtri WMI non vengono valutati in Microsoft Windows® 2000. Un oggetto Criteri di gruppo destinato a un computer che esegue Windows 2000 verrà sempre applicato, indipendentemente dalla query associata al filtro WMI. Il filtro verrà pertanto ignorato.

Ulteriori riferimenti

  • Utilizzare filtri WMI


Importare un filtro WMI

Importare un filtro WMI

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su Filtri WMI nella foresta e nel dominio in cui si desidera importare un filtro WMI.

  2. Fare clic su Importa.

  3. Nella finestra di dialogo Importa filtro WMI immettere il file con estensione mof contenente il filtro WMI che si desidera importare e quindi fare clic su Apri.

  4. Nella finestra di dialogo Importa filtro WMI specificare le informazioni appropriate nelle caselle Nome e Descrizione e quindi eseguire una delle operazioni seguenti:

    • Per importare il filtro WMI senza modificarlo, fare clic su Importa.

    • Per modificare il filtro WMI e quindi importarlo, fare clic su Modifica, apportare le modifiche desiderate allo spazio dei nomi o alla query, fare clic su OK e quindi su Importa.

Ulteriori considerazioni

  • Per poter completare questa procedura, è necessario disporre dei privilegi per creare i filtri WMI nel dominio in cui si desidera creare il filtro. Per impostazione predefinita, gli amministratori di dominio, gli amministratori dell'organizzazione e i membri del gruppo Proprietari autori criteri di gruppo dispongono di queste autorizzazioni.

  • L'opzione Filtri WMI è disponibile solo se almeno un controller di dominio presente nel dominio esegue Microsoft Windows Server 2003. Lo stesso vale per l'opzione Filtri WMI della scheda Ambito per Oggetti Criteri di gruppo.

  • L'importazione di un filtro WMI comporta la creazione di un nuovo filtro anziché la modifica di un filtro esistente.

Ulteriori riferimenti

  • Utilizzare filtri WMI


Esportare un filtro WMI

Esportare un filtro WMI

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse sul filtro WMI che si desidera esportare e quindi scegliere Esporta.

  2. Nella finestra di dialogo Esporta filtro WMI selezionare un percorso del file system sicuro nell'elenco a discesa Salva in, digitare un nome per il filtro che si desidera esportare e quindi fare clic su Salva.

Importante

Per proteggere i filtri WMI esportati, assicurarsi che solo gli amministratori autorizzati possano accedere alla cartella in cui verranno esportati i filtri.

Ulteriori considerazioni

  • I Filtri WMI sono disponibili solo se almeno un controller di dominio presente nel dominio esegue Microsoft Windows Server 2003. Lo stesso vale per l'opzione Filtri WMI della scheda Ambito per Oggetti Criteri di gruppo.

  • È inoltre possibile esportare un filtro WMI facendo clic su Filtri WMI, selezionando la scheda Contenuto nel riquadro risultati, facendo clic con il pulsante destro del mouse sul nome del filtro e quindi scegliendo Esporta.

  • Tramite Console Gestione Criteri di gruppo è possibile importare solo file con estensione mof contenenti un unico filtro WMI.

Ulteriori riferimenti

  • Utilizzare filtri WMI


Copiare un filtro WMI

Per copiare un filtro WMI

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic sul filtro WMI presente nella foresta e nel dominio contenenti il filtro WMI che si desidera copiare.

  2. Fare clic con il pulsante destro del mouse sul filtro WMI che si desidera copiare e quindi scegliere Copia.

  3. Nel dominio di destinazione fare clic con il pulsante destro del mouse su Filtri WMI e quindi scegliere Incolla.

Ulteriori considerazioni

  • Per poter completare questa procedura, è necessario disporre dei privilegi per creare i filtri WMI nel dominio in cui si desidera creare il filtro. Per impostazione predefinita, gli amministratori di dominio, gli amministratori dell'organizzazione e i membri del gruppo Proprietari autori criteri di gruppo dispongono di queste autorizzazioni.

  • L'opzione Filtri WMI è disponibile solo se almeno un controller di dominio presente nel dominio esegue Microsoft Windows Server 2003. Lo stesso vale per l'opzione Filtri WMI della scheda Ambito per Oggetti Criteri di gruppo.

Ulteriori riferimenti

  • Utilizzare filtri WMI


Collegare un filtro WMI a un oggetto Criteri di gruppo

Per collegare un filtro WMI a un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic su Oggetti Criteri di gruppo nella foresta e nel dominio contenenti l'oggetto Criteri di gruppo a cui si desidera collegare un filtro WMI.

  2. Fare clic sull'oggetto Criteri di gruppo.

  3. Nella scheda Ambito del riquadro risultati selezionare un filtro WMI nell'elenco a discesa Filtri WMI.

  4. Quando viene richiesto di confermare la selezione, fare clic su Sì.

Ulteriori considerazioni

  • Per collegare un filtro WMI a un oggetto Criteri di gruppo, è necessario disporre delle autorizzazioni di modifica per l'oggetto.

  • È possibile collegare un solo filtro WMI a un oggetto Criteri di gruppo ed è necessario che l'oggetto si trovi nello stesso dominio.

  • L'opzione Filtri WMI e l'opzione Filtri WMI della scheda Ambito per gli oggetti Criteri di gruppo sono disponibili solo se almeno un controller di dominio presente nel dominio esegue Microsoft Windows Server 2003.

Ulteriori riferimenti

  • Utilizzare filtri WMI


Bloccare l'eredità

È possibile bloccare l'eredità per un dominio o un'unità organizzativa. Tramite il blocco dell'eredità è possibile impedire che gli oggetti Criteri di gruppo collegati a siti, domini o unità organizzative di livello superiore vengano ereditati automaticamente dal livello figlio.

Per bloccare l'eredità

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta contenente il dominio o l'unità organizzativa per cui si desidera bloccare l'eredità per i collegamenti agli oggetti Criteri di gruppo e quindi eseguire una delle operazioni seguenti:

    • Per bloccare l'eredità dei collegamenti agli oggetti Criteri di gruppo per un intero dominio, fare doppio clic su Domini e quindi fare clic con il pulsante destro del mouse sul dominio.

    • Per bloccare l'eredità per un'unità organizzativa, fare doppio clic su Domini, sul dominio contenente l'unità organizzativa e quindi fare clic con il pulsante destro del mouse sull'unità organizzativa.

  2. Scegliere Blocca eredità.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario disporre dell'autorizzazione Collega oggetti Criteri di gruppo per il dominio o l'unità organizzativa.

  • Un dominio o un'unità organizzativa per cui è impostato il blocco dell'eredità viene visualizzato con un punto esclamativo blu nell'albero della console.

  • Se si impongono collegamenti a un oggetto Criteri di gruppo, questi non possono essere bloccati dal contenitore padre.

Ulteriore riferimento

  • Controllare l'ambito degli oggetti Criteri di gruppo


Utilizzare Gruppo di criteri risultante per gestire Criteri di gruppo

  • Determinare Gruppo di criteri risultante

  • Simulare Gruppo di criteri risultante tramite Modellazione Criteri di gruppo


Determinare Gruppo di criteri risultante

Per determinare Gruppo di criteri risultante

  1. Nell'albero di Console Gestione Criteri di gruppo fare doppio clic sulla foresta in cui si desidera creare una query rapporti Criteri di gruppo, fare clic con il pulsante destro del mouse su Rapporti Criteri di gruppo e quindi scegliere Creazione guidata rapporti Criteri di gruppo.

  2. In Creazione guidata rapporti Criteri di gruppo fare clic su Avanti e quindi immettere le informazioni appropriate.

  3. Al termine della procedura guidata, fare clic su Fine.

  4. Se si desidera stampare o salvare il rapporto sulle impostazioni, fare clic con il pulsante destro del mouse sul rapporto nel riquadro dei dettagli e quindi eseguire una delle operazioni seguenti:

    • Scegliere Stampa per stampare il rapporto.

    • Scegliere Salva rapporto per salvare il rapporto.

Ulteriori considerazioni

  • Per accedere ai dati dei rapporti Criteri di gruppo per un utente o un computer, è necessario disporre dell'autorizzazione Lettura dei dati dei rapporti Criteri di gruppo per il dominio o l'unità organizzativa contenente l'utente o il computer oppure appartenere al gruppo di amministratori locali del computer di destinazione.

  • Se si esegue Rapporti Criteri di gruppo in un computer che non supporta Preferenze di Criteri di gruppo e si seleziona un computer di destinazione che non supporta Preferenze di Criteri di gruppo, le impostazioni di Preferenze Criteri di gruppo nel computer di destinazione non saranno incluse nei risultati dei rapporti.

  • Per personalizzare le informazioni visualizzate o stampate in un rapporto, fare clic su Mostra o Nascondi.

  • In Console Gestione Criteri di gruppo non è possibile utilizzare la tastiera per spostarsi all'interno di un rapporto HTML. Per spostarsi all'interno del rapporto HTML, salvarlo in un file e quindi utilizzare Internet Explorer per visualizzarlo.

  • Se si apre una console salvata in precedenza e si desidera salvare in formato XML un rapporto relativo a Modellazione Criteri di gruppo o Rapporti Criteri di gruppo, rieseguire il rapporto utilizzando l'opzione Riesegui query.

  • Per visualizzare un rapporto salvato in un Web browser, è necessario utilizzare Internet Explorer® 6 o versione successiva.

  • Rapporti Criteri di gruppo è supportati solo nei computer che eseguono Microsoft Windows XP e versioni successive.

Ulteriori riferimenti

  • Utilizzare Gruppo di criteri risultante per gestire Criteri di gruppo


Simulare Gruppo di criteri risultante tramite Modellazione Criteri di gruppo

Per simulare Gruppo di criteri risultante tramite Modellazione Criteri di gruppo

  1. Aprire Console Gestione Criteri di gruppo. Nell'albero della console fare doppio clic sulla foresta in cui si desidera creare una query di Modellazione Criteri di gruppo, fare clic con il pulsante destro del mouse su Modellazione Criteri di gruppo e quindi scegliere Modellazione guidata Criteri di gruppo.

  2. In Modellazione guidata Criteri di gruppo fare clic su Avanti e quindi digitare le informazioni appropriate.

  3. Al termine, fare clic su Fine.

  4. Se si desidera stampare o salvare il rapporto sulle impostazioni, fare clic con il pulsante destro del mouse sul rapporto nel riquadro dei dettagli e quindi eseguire una delle operazioni seguenti:

    • Scegliere Stampa per stampare il rapporto.

    • Scegliere Salva rapporto per salvare il rapporto.

Ulteriori considerazioni

  • Per creare una query di Modellazione Criteri di gruppo, è necessario disporre dell'autorizzazione Esegui analisi di Modellazione Criteri di gruppo per il dominio o l'unità organizzativa contenente l'oggetto su cui si desidera eseguire la query.

  • L'opzione Modellazione Criteri di gruppo è disponibile solo se almeno un controller di dominio nella foresta esegue Microsoft Windows Server 2003.

  • Se si esegue Modellazione Criteri di gruppo in un ambiente che supporta Preferenze di Criteri di gruppo, è necessario che vengano soddisfatti i requisiti seguenti per visualizzare le impostazioni di Preferenze di Criteri di gruppo nei risultati dei rapporti:

    • Il computer da cui si esegue Modellazione Criteri di gruppo deve eseguire Windows Server® 2008 R2 o Windows Server® 2008.

    • Se in ambienti misti che utilizzano controller di dominio che eseguono Windows Server 2008 R2 o Windows Server 2008 e controller di dominio che eseguono Windows Server 2003 si seleziona un controller di dominio che esegue Windows Server 2003 durante l'esecuzione di Modellazione Criteri di gruppo, verificare che le estensioni lato client per Preferenze di Criteri di gruppo siano installate nel controller di dominio. Per scaricare le estensioni lato client per Preferenze di Criteri di gruppo per Windows Server 2003 (x86), visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=111852. Per scaricare le estensioni lato client per Windows Server 2003 (x64), visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=111863.

  • Per personalizzare le informazioni visualizzate in un rapporto in modo da visualizzare o stampare solo i dati desiderati, fare clic su Mostra o Nascondi.

  • In Console Gestione Criteri di gruppo non è possibile utilizzare la tastiera per spostarsi all'interno di un rapporto HTML. Per spostarsi all'interno del rapporto HTML, salvarlo in un file e quindi utilizzare Internet Explorer per visualizzarlo.

  • Se si apre una console salvata in precedenza e si desidera salvare in formato XML un rapporto relativo a Modellazione Criteri di gruppo oppure rapporti Criteri di gruppo, rieseguire il rapporto utilizzando l'opzione Riesegui query.

  • Per visualizzare un rapporto salvato in un Web browser, è necessario utilizzare Internet Explorer® 6 o versione successiva.

Ulteriori riferimenti

  • Utilizzare Gruppo di criteri risultante per gestire Criteri di gruppo


Delegare le autorizzazioni per Criteri di gruppo

  • Delegare le autorizzazioni per un gruppo o un utente in un oggetto Criteri di gruppo

  • Delegare le autorizzazioni necessarie per collegare oggetti Criteri di gruppo

  • Delegare le autorizzazioni per la generazione di dati di Modellazione Criteri di gruppo

  • Delegare le le autorizzazioni per la generazione di rapporti Criteri di gruppo

  • Delegare le autorizzazioni per un gruppo o un utente in un filtro WMI


Delegare le autorizzazioni per un gruppo o un utente in un oggetto Criteri di gruppo

Per delegare le autorizzazioni per un gruppo o un utente in un oggetto Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo espandere il nodo Oggetti Criteri di gruppo nella foresta e nel dominio contenenti l'oggetto Criteri di gruppo per cui si desidera aggiungere o rimuovere autorizzazioni.

  2. Fare clic sull'oggetto Criteri di gruppo.

  3. Nel riquadro risultati fare clic sulla scheda Delega.

  4. Fare clic su Aggiungi.

  5. Nella finestra di dialogo Seleziona utente, computer o gruppo fare clic su Tipi di oggetto, selezionare i tipi di oggetti per cui si desidera aggiungere autorizzazioni per gli oggetti Criteri di gruppo e quindi fare clic su OK.

  6. Fare clic su Percorsi, selezionare Directory completa oppure il dominio o l'unità organizzativa contenente l'oggetto per cui si desidera aggiungere autorizzazioni per gli oggetti Criteri di gruppo e quindi fare clic su OK.

  7. Nella casella Immettere il nome dell'oggetto da selezionare digitare il nome dell'oggetto per cui si desidera aggiungere autorizzazioni per gli oggetti Criteri di gruppo eseguendo una delle operazioni seguenti:

    • Se lo si conosce, digitare il nome dell'oggetto e quindi fare clic su OK.

    • Per cercare il nome, fare clic su Avanzate, digitare i criteri di ricerca, fare clic su Trova, selezionare il nome desiderato nella casella di riepilogo, fare clic su OK e quindi di nuovo su OK.

    • Nella casella Autorizzazioni della finestra di dialogo Aggiungi gruppo o utente selezionare le autorizzazioni appropriate nell'elenco a discesa e quindi fare clic su OK.

Ulteriori considerazioni

  • Per eseguire questa procedura è necessario disporre delle autorizzazioni Modifica impostazioni, elimina, modifica sicurezza per l'oggetto Criteri di gruppo.

  • I gruppi e gli utenti per cui è impostato Personalizzato nella colonna Autorizzazioni concesse nella casella di riepilogo Gruppi e utenti della scheda Delega disporranno di autorizzazioni che non corrispondono a uno dei tre livelli standard. Per visualizzare le autorizzazioni per i gruppi dotati di autorizzazioni personalizzate o per impostare autorizzazioni personalizzate, fare clic su Avanzate.

  • È inoltre possibile fare clic sulla scheda Delega per modificare o rimuovere le autorizzazioni per un gruppo o un utente in un oggetto Criteri di gruppo.

Ulteriori riferimenti

  • Delegare le autorizzazioni per Criteri di gruppo


Delegare le autorizzazioni necessarie per collegare oggetti Criteri di gruppo

Per delegare le autorizzazioni necessarie per collegare oggetti Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo eseguire una delle operazioni seguenti:

    • Per delegare l'autorizzazione necessaria per collegare oggetti Criteri di gruppo al dominio o a un'unità organizzativa, fare clic sul dominio o sull'unità organizzativa.

    • Per delegare l'autorizzazione necessaria per collegare oggetti Criteri di gruppo a un sito, fare clic sul sito.

  2. Nel riquadro risultati fare clic sulla scheda Delega.

  3. Nell'elenco a discesa Autorizzazione selezionare Collega oggetti Criteri di gruppo. Fare clic su Aggiungi.

  4. Nella finestra di dialogo Seleziona utente, computer o gruppo fare clic su Tipi di oggetto, selezionare i tipi di oggetti a cui si desidera delegare le autorizzazioni per il dominio, il sito o l'unità organizzativa e quindi fare clic su OK.

  5. Fare clic su Percorsi, selezionare Directory completa oppure il dominio o l'unità organizzativa contenente l'oggetto a cui si desidera delegare le autorizzazioni e quindi fare clic su OK.

  6. Nella casella Immettere il nome dell'oggetto da selezionare immettere il nome dell'oggetto a cui si desidera delegare le autorizzazioni eseguendo una delle operazioni seguenti:

    • Se lo si conosce, digitare il nome dell'oggetto e quindi fare clic su OK.

    • Per cercare il nome, fare clic su Avanzate, immettere i criteri di ricerca, fare clic su Trova, selezionare il nome desiderato nella casella di riepilogo, fare clic su OK e quindi di nuovo su OK.

  7. Nell'elenco a discesa Autorizzazioni della finestra di dialogo Aggiungi gruppo o utente selezionare il livello a cui si desidera applicare le autorizzazioni per il gruppo o l'utente e quindi fare clic su OK.

Ulteriori considerazioni

  • Per delegare le autorizzazioni necessarie per collegare oggetti Criteri di gruppo a un sito, un dominio o un'unità organizzativa, è necessario disporre del diritto Autorizzazioni di modifica per tale sito, dominio o unità organizzativa. Per impostazione predefinita, solo i membri dei gruppi Domain Admins ed Enterprise Admins dispongono di questa autorizzazione.

  • Gli utenti e i gruppi che dispongono dell'autorizzazione per collegare oggetti Criteri di gruppo a un sito, un'unità organizzativa o un dominio specifico possono collegare oggetti Criteri di gruppo, modificare l'ordine dei collegamenti e impostare il blocco dell'eredità nel sito, nell'unità organizzativa o nel dominio specifico.

  • Non è possibile rimuovere gruppi e utenti che ereditano le autorizzazioni da un contenitore padre.

  • Ad alcune voci visualizzate nell'elenco a discesa Gruppi e utenti, ad esempio Sistema, non è associata alcuna finestra di dialogo delle proprietà e pertanto la finestra di dialogo Proprietà non è disponibile per tali voci.

Ulteriori riferimenti

  • Delegare le autorizzazioni per Criteri di gruppo


Delegare le autorizzazioni per la generazione di dati di Modellazione Criteri di gruppo

Per delegare le autorizzazioni per la generazione dei dati di Modellazione Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic sul dominio o sull'unità organizzativa per cui si desidera delegare le autorizzazioni per Modellazione Criteri di gruppo.

  2. Nel riquadro risultati fare clic sulla scheda Delega.

  3. Nella casella Autorizzazione selezionare Esegui analisi di Modellazione Criteri di gruppo per aggiungere un nuovo gruppo o utente all'elenco delle autorizzazioni.

  4. Nella scheda Delega fare clic su Aggiungi.

  5. Nella finestra di dialogo Selezione Utente, Computer o Gruppo fare clic su Tipi di oggetto, selezionare i tipi di oggetti a cui si desidera delegare le autorizzazioni per il dominio, il sito o l'unità organizzativa e quindi fare clic su OK.

  6. Fare clic su Percorsi, selezionare Directory completa oppure il dominio o l'unità organizzativa contenente l'oggetto a cui si desidera delegare le autorizzazioni e quindi fare clic su OK.

  7. Nella casella Immettere il nome dell'oggetto da selezionare individuare il nome dell'oggetto a cui si desidera delegare le autorizzazioni eseguendo una delle operazioni seguenti:

    • Se lo si conosce, digitare il nome dell'oggetto e quindi fare di nuovo clic su OK.

    • Per cercare il nome, fare clic su Avanzate, immettere i criteri di ricerca, fare clic su Trova, selezionare il nome desiderato nell'elenco a discesa, fare clic su OK e quindi di nuovo su OK.

  8. Nell'elenco a discesa Autorizzazioni della finestra di dialogo Aggiungi gruppo o utente selezionare il livello a cui si desidera applicare le autorizzazioni per il gruppo o l'utente e quindi fare clic su OK.

Ulteriori considerazioni

  • Per delegare le autorizzazioni necessarie per eseguire analisi di Modellazione Criteri di gruppo per oggetti inclusi in un dominio o un'unità organizzativa, è necessario disporre del diritto Autorizzazioni di modifica per tale dominio o unità organizzativa. Per impostazione predefinita, solo gli amministratori di dominio e gli amministratori dell'organizzazione dispongono di questa autorizzazione.

  • Non è possibile delegare l'autorizzazione per eseguire analisi di Modellazione Criteri di gruppo per i siti.

  • È inoltre possibile utilizzare la scheda Delega per modificare o rimuovere le autorizzazioni per un gruppo o un utente per i dati di Modellazione Criteri di gruppo.

Ulteriori riferimenti

  • Delegare le autorizzazioni per Criteri di gruppo


Delegare le le autorizzazioni per la generazione di rapporti Criteri di gruppo

Per delegare le autorizzazioni necessarie per generare rapporti Criteri di gruppo

  1. Nell'albero di Console Gestione Criteri di gruppo fare clic sul dominio o sull'unità organizzativa per cui si desidera delegare le autorizzazioni per generare rapporti Criteri di gruppo.

  2. Nel riquadro risultati fare clic sulla scheda Delega.

  3. Nell'elenco a discesa Autorizzazioni selezionare Leggi dati dei rapporti Criteri di gruppo per aggiungere un nuovo gruppo o utente all'elenco delle autorizzazioni.

  4. Nella scheda Delega fare clic su Aggiungi.

  5. Nella finestra di dialogo Seleziona utente, computer o gruppo fare clic su Tipi di oggetto, selezionare i tipi di oggetti a cui si desidera delegare le autorizzazioni per il dominio, il sito o l'unità organizzativa e quindi fare clic su OK.

  6. Selezionare l'utente o il gruppo a cui si desidera delegare l'autorizzazione.

  7. Nell'elenco a discesa Autorizzazioni della finestra di dialogo Aggiungi gruppo o utente selezionare il livello a cui si desidera applicare le autorizzazioni per il gruppo o l'utente e quindi fare clic su OK.

Ulteriori considerazioni

  • Per delegare le autorizzazioni necessarie per generare rapporti Criteri di gruppo per gli oggetti di un dominio o di un'unità organizzativa, è necessario disporre del diritto Autorizzazioni di modifica per tale dominio o unità organizzativa. Per impostazione predefinita, solo gli amministratori di dominio e gli amministratori dell'organizzazione dispongono di questa autorizzazione.

  • Non è possibile delegare l'autorizzazione per generare rapporti Criteri di gruppo per i siti.

  • È inoltre possibile utilizzare la scheda Delega per modificare o rimuovere le autorizzazioni per un gruppo o un utente per i dati dei rapporti Criteri di gruppo.

Ulteriori riferimenti

  • Delegare le autorizzazioni per Criteri di gruppo


Delegare le autorizzazioni per un gruppo o un utente in un filtro WMI

Per delegare le autorizzazioni per un gruppo o un utente in un filtro WMI

  1. Nell'albero della console Gestione Criteri di gruppo fare clic sul filtro WMI per cui si desidera delegare le autorizzazioni.

  2. Nel riquadro risultati fare clic sulla scheda Delega.

  3. Fare clic su Aggiungi.

  4. Nella finestra di dialogo Selezione Utente, Computer o Gruppo fare clic su Tipi di oggetto, selezionare i tipi di oggetti a cui si desidera delegare le autorizzazioni per il filtro WMI e quindi fare clic su OK.

  5. Fare clic su Posizioni, selezionare Directory completa oppure il dominio o l'unità organizzativa contenente l'oggetto a cui si desidera delegare le autorizzazioni e quindi fare clic su OK.

  6. Nella casella Immettere il nome dell'oggetto da selezionare digitare il nome dell'oggetto a cui si desidera delegare le autorizzazioni eseguendo una delle operazioni seguenti:

    • Se lo si conosce, digitare il nome dell'oggetto e quindi fare clic su OK.

    • Per cercare il nome, fare clic su Avanzate, digitare i criteri di ricerca, fare clic su Trova, selezionare il nome desiderato nella casella di riepilogo, fare clic su OK e quindi di nuovo su OK.

  7. Nella casella Autorizzazioni della finestra di dialogo Aggiungi gruppo o utente selezionare il livello di autorizzazione che si desidera assegnare al gruppo o all'utente e quindi fare clic su OK.

Ulteriori considerazioni

  • Per modificare le autorizzazioni relative a un filtro WMI è necessario disporre delle autorizzazioni di controllo completo per il filtro.

  • Non è possibile rimuovere o modificare autorizzazioni ereditate per i filtri WMI.

  • Tutti gli utenti devono disporre dell'accesso in lettura a tutti i filtri WMI. In caso contrario, quando viene rilevato un filtro WMI che non può essere letto, l'elaborazione tramite Criteri di gruppo viene interrotta.

  • Non è possibile utilizzare Console Gestione Criteri di gruppo per rimuovere le autorizzazioni di lettura dai filtri WMI.

  • I filtri WMI sono disponibili se almeno un controller di dominio presente nel dominio esegue Microsoft Windows Server 2003 o versione successiva.

  • È inoltre possibile utilizzare la scheda Delega per modificare o rimuovere le autorizzazioni per un gruppo o un utente per i filtri WMI.

Ulteriori riferimenti

  • Delegare le autorizzazioni per Criteri di gruppo


Delegare le autorizzazioni per un gruppo o un utente in un oggetto Criteri di gruppo Starter

Delegare le autorizzazioni per un gruppo o un utente in un oggetto Criteri di gruppo Starter

  1. Aprire Console Gestione Criteri di gruppo. Espandere il nodo Oggetti Criteri di gruppo Starter.

  2. Fare clic sull'oggetto Criteri di gruppo Starter per cui si desidera delegare le autorizzazioni.

  3. Nel riquadro risultati fare clic sulla scheda Delega.

  4. Fare clic su Aggiungi.

  5. Nella finestra di dialogo Selezione Utente, Computer o Gruppo fare clic su Tipi di oggetto, selezionare i tipi di oggetti per cui si desidera aggiungere autorizzazioni per gli oggetti Criteri di gruppo Starter e quindi fare clic su OK.

  6. Fare clic su Percorsi, selezionare Directory completa oppure il dominio o l'unità organizzativa contenente l'oggetto per cui si desidera aggiungere autorizzazioni per gli oggetti Criteri di gruppo Starter e quindi fare clic su OK.

  7. Nella casella Immettere il nome dell'oggetto da selezionare digitare il nome dell'oggetto per cui si desidera aggiungere autorizzazioni per gli oggetti Criteri di gruppo Starter eseguendo una delle operazioni seguenti:

    • Se lo si conosce, digitare il nome dell'oggetto e quindi fare clic su OK.

    • Per cercare il nome, fare clic su Avanzate, digitare i criteri di ricerca, fare clic su Trova, selezionare il nome desiderato nella casella di riepilogo, fare clic su OK e quindi di nuovo su OK.

  8. Nella casella Autorizzazioni della finestra di dialogo Aggiungi gruppo o utente selezionare le autorizzazioni appropriate nell'elenco a discesa e quindi fare clic su OK.


Utilizzare Windows PowerShell per gestire Criteri di gruppo

Criteri di gruppo in Windows Server® 2008 R2 offre il supporto per Windows PowerShell, una shell da riga di comando Windows, nonché un linguaggio di script. È possibile utilizzare i cmdlet Windows PowerShell per Criteri di gruppo per automatizzare molte delle attività per oggetti Criteri di gruppo basati su dominio eseguite nell'interfaccia utente tramite Console Gestione Criteri di gruppo.

Attività che è possibile eseguire

  • Gestione di oggetti Criteri di gruppo: creazione, rimozione, backup e importazione di oggetti Criteri di gruppo

  • Associazione di Oggetti Criteri di gruppo a contenitori del servizio directory di Active Directory®: creazione, aggiornamento e rimozione di collegamenti a oggetti Criteri di gruppo

  • Impostare le autorizzazioni in oggetti Criteri di gruppo

  • Modificare i flag di eredità in unità organizzative e domini di Active Directory

  • Configurazione di impostazioni dei criteri basate sul Registro di sistema e di impostazioni del Registro di sistema per le preferenze di Criteri di gruppo: aggiornamento, recupero e rimozione

  • Creare oggetti Criteri di gruppo Starter

Per semplificare il completamento di queste attività, in Windows Server 2008 R2 sono disponibili oltre 20 cmdlet per Criteri di gruppo. Ciascun cmdlet è un semplice strumento da riga di comando che esegue una singola funzione. Utilizzando combinazioni di cmdlet, è possibile automatizzare attività più complesse. È inoltre possibile combinare azioni con attività pianificate per fare in modo che attività di gestione di Criteri di gruppo specifiche si verifichino nel momento desiderato. È possibile, ad esempio, eseguire il backup di un oggetto Criteri di gruppo, restituire l'output del risultato in un file e aggiungere il file ogni volta che si esegue un backup. In questo modo, viene generato un rapporto per ogni backup pianificato.

Utilizzare i cmdlet per Criteri di gruppo

Importante
  • Per utilizzare i cmdlet Windows PowerShell per Criteri di gruppo, è necessario eseguire Windows Server 2008 R2 in un controller di dominio o in un server membro in cui sia installato Console Gestione Criteri di gruppo oppure Windows® 7 con Strumenti di amministrazione remota del server. Strumenti di amministrazione remota del server include Console Gestione Criteri di gruppo.
  • È inoltre necessario importare il modulo Criteri di gruppo prima di utilizzare i cmdlet, all'inizio di ogni script che li utilizza e all'inizio di ogni sessione di Windows PowerShell.
Per importare il modulo Criteri di gruppo

  1. Aprire Windows PowerShell. Per aprire Windows PowerShell, scegliere Tutti i programmi, Accessori, Windows PowerShell e quindi fare clic su Windows PowerShell V2.

  2. Al prompt di Windows PowerShell digitare Import-Module GroupPolicy –verbose

    Importante

    È necessario eseguire queste operazioni quando si apre una sessione di Windows PowerShell e si desidera utilizzare i cmdlet per Criteri di gruppo.
Per visualizzare un elenco di cmdlet per Criteri di gruppo

  • Al prompt di Windows PowerShell digitare Get-Command *GP* -commandtype cmdlet
Per visualizzare informazioni relative ai cmdlet per Criteri di gruppo

  • Al prompt di Windows PowerShell eseguire le operazioni seguenti:

    • Per visualizzare informazioni di base, digitare Get-Help <cmdlet_name>

    • Per visualizzare informazioni di base, digitare Get-Help <cmdlet_name> -detailed

    • Per visualizzare informazioni tecniche, digitare Get-Help <cmdlet_name> -full

Ulteriori considerazioni

È possibile utilizzare i cmdlet GPRegistryValue per modificare le impostazioni dei criteri basate sul Registro di sistema e i cmdlet GPPrefRegistryValue per modificare gli elementi preferenza del Registro di sistema. Per informazioni sulle chiavi del Registro di sistema associate alle impostazioni dei criteri basate sul Registro di sistema, vedere le informazioni di riferimento sulle impostazioni di Criteri di gruppo all'indirizzo http://go.microsoft.com/fwlink/?LinkId=131389. Queste informazioni vengono fornite in un foglio di calcolo scaricabile.

Ulteriori riferimenti

  • Console Gestione Criteri di gruppo

  • Per informazioni sulla tecnologia Windows PowerShell, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=102372. Il sito Web costituisce un punto di ingresso per accedere alla documentazione di PowerShell, incluse le informazioni su distribuzione, operazioni, formazione, supporto e community.

  • Il blog di Windows PowerShell è disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkID=128557: Questo sito Web rappresenta un punto di ingresso ai blog su Windows PowerShell, che includono informazioni sulle distribuzioni, le procedure consigliate, la formazione e altre risorse correnti relative a Windows PowerShell.

  • Per informazioni sulla tecnologia Criteri di gruppo, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=116313. Questo sito Web rappresenta un punto di ingresso per accedere alla documentazione di Criteri di gruppo, incluse informazioni su distribuzione, operazioni, formazione, supporto e community.

  • Per visualizzare le informazioni di riferimento sulle impostazioni di Criteri di gruppo, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=131389. In questo documento sono elencate le impostazioni di Criteri di gruppo descritte nei file dei modelli amministrativi (con estensione admx) e nelle impostazioni di sicurezza. Il foglio di calcolo include tutte le impostazioni dei criteri dei modelli amministrativi per Windows Server 2008 R2 e Windows 7.


Risorse per Console Gestione Criteri di gruppo

In questo argomento vengono forniti i collegamenti a ulteriori informazioni relative a Criteri di gruppo e alle tecnologie correlate.

  • Per accedere al TechCenter di Criteri di gruppo, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?linkid=66015. Questo sito Web rappresenta un punto di ingresso per accedere alla documentazione di Criteri di gruppo, incluse informazioni su distribuzione, operazioni, formazione, supporto e community.

  • Per visualizzare le informazioni di riferimento sulle impostazioni di Criteri di gruppo, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=131389. In questo documento sono elencate le impostazioni di Criteri di gruppo descritte nei file dei modelli amministrativi (con estensione admx) e nelle impostazioni di sicurezza. Il foglio di calcolo include tutte le impostazioni dei criteri dei modelli amministrativi per Windows® 7.

  • Per informazioni sulle interfacce COM di Console Gestione Criteri di gruppo, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139089. In questo articolo di Microsoft Developer Network (MSDN) sono elencate le interfacce COM che supportano la creazione di script per molte attività che è possibile eseguire tramite Console Gestione Criteri di gruppo.

  • Per visualizzare gli script di esempio di Console Gestione Criteri di gruppo, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=65841. In questo insieme di script di esempio viene illustrato come utilizzare le interfacce per affrontare una serie di problemi e scenari amministrativi reali. Gli scenari sono disponibili come pacchetto scaricabile.