Creare e utilizzare i criteri IPSec

IPSec è un'infrastruttura di standard aperti che assicurano comunicazioni private sicure su reti IP tramite servizi di sicurezza con crittografia. L'implementazione di IPSec di Microsoft Windows si basa su standard sviluppati dal gruppo di lavoro su IPSec della Internet Engineering Task Force (IETF).

IPSec stabilisce attendibilità e sicurezza tra un indirizzo IP di origine e un indirizzo IP di destinazione. Gli unici computer che devono essere consapevoli del traffico che viene protetto sono il computer che invia i dati e quello che li riceve. Ogni computer gestisce la sicurezza nel proprio lato basandosi sul presupposto che il supporto utilizzato per la comunicazione non sia sicuro. Per i computer che eseguono solo il routing dei dati dall'origine alla destinazione non è richiesto il supporto di IPSec, a meno che tra i due computer non vengano applicati filtri dei pacchetti di tipo firewall o non venga eseguita la conversione degli indirizzi di rete (NAT, Network Address Translation).

Lo snap-in Criteri di sicurezza IP consente di creare, modificare e assegnare i criteri IPSec nel computer locale e nei computer remoti.

Nota

Con la presente documentazione si intende offrire le informazioni necessarie alla comprensione e all'utilizzo dello snap-in Criteri di sicurezza IP. Non verranno invece fornite informazioni sulla progettazione e sulla distribuzione dei criteri.

Informazioni sui criteri IPSec

I criteri IPSec vengono utilizzati per configurare i servizi di sicurezza IPSec. Tali criteri offrono livelli di protezione diversi per la maggior parte dei tipi di traffico in quasi tutte le reti esistenti. È possibile configurare i criteri IPSec in modo da soddisfare i requisiti di sicurezza di un singolo computer, un'unità organizzativa (OU, Organizational Unit), un dominio, un sito o un'intera organizzazione. Lo snap-in Criteri di sicurezza IP disponibile in questa versione di Windows può essere utilizzato per definire i criteri IPSec per i computer tramite oggetti Criteri di gruppo (per i membri di un dominio) o nel computer locale oppure per i computer remoti.

Importante

Lo snap-in Criteri di sicurezza IP consente la creazione di criteri IPSec che possono essere applicati a computer che eseguono Microsoft Windows Vista e versioni successive di Windows, ma non utilizza i nuovi algoritmi di sicurezza e altre nuove funzionalità disponibili in Microsoft Windows Vista e nelle versioni successive di Windows. Per creare criteri IPsec per questi computer, utilizzare lo snap-in Windows Firewall con sicurezza avanzata. I criteri creati con lo snap-in Windows Firewall con sicurezza avanzata non possono essere applicati alle versioni precedenti di Windows.

Un criterio IPSec è costituito da impostazioni generali e regole. Le impostazioni generali dei criteri IPSec vengono applicate indipendentemente dalle regole configurate e determinano il nome del criterio, la relativa descrizione ai fini amministrativi, le impostazioni e i metodi di scambio chiave. Una o più regole IPSec determinano i tipi di traffico che devono essere controllati da IPSec, il modo in cui viene considerato il traffico, la modalità di autenticazione di un peer IPSec e altre impostazioni.

Dopo che i criteri sono stati creati, è possibile applicarli a livello locale e a livello di dominio, sito e unità organizzativa. In un computer può essere attivo un solo criterio alla volta. I criteri distribuiti e applicati tramite oggetti Criteri di gruppo hanno priorità sui criteri locali.

Attività relative allo snap-in IPSec

In questa sezione vengono illustrate alcune delle attività più comuni che è possibile eseguire con lo snap-in Criteri di sicurezza IP.

Creare un criterio

A meno che non si stiano creando criteri su un solo computer e sul relativo peer IPSec, sarà in genere necessario creare un set di criteri IPSec adatti al proprio ambiente IT. La complessità della progettazione, della creazione e della distribuzione dei criteri dipende dalle dimensioni del dominio, dall'omogeneità dei computer del dominio e da altri fattori.

Viene in genere adottata la procedura seguente:

  1. Creazione di elenchi di filtri IP corrispondenti ai computer, alle subnet e alle condizioni dell'ambiente.

  2. Creazione di operazioni filtro corrispondenti al modo in cui si desidera autenticare le connessioni, applicare l'integrità dei dati e crittografare i dati. L'operazione filtro può anche essere Blocco o Autorizza, indipendentemente da altri criteri. L'operazione Blocco ha priorità su altre operazioni.

  3. Creazione di un set di criteri corrispondenti ai requisiti di filtro e operazioni filtro (sicurezza) desiderati.

  4. Distribuzione dei criteri che utilizzano le operazioni filtro Autorizza e Blocco, quindi monitoraggio dell'ambiente IPSec per individuare eventuali problemi che potrebbero richiedere la modifica di tali criteri.

  5. Distribuzione dei criteri tramite l'operazione filtro Negozia sicurezza, con la possibilità di utilizzare le comunicazioni non crittografate, in modo da consentire la verifica del funzionamento di IPSec nell'ambiente senza interrompere le comunicazioni.

  6. Dopo avere apportato le eventuali modifiche ai criteri, rimozione del consenso alle comunicazioni non crittografate, dove appropriato. In tal modo non sarà possibile creare una connessione senza autenticazione e sicurezza.

  7. Monitoraggio dell'ambiente per individuare l'eventuale assenza di comunicazioni, che potrebbero essere indicate da un aumento inaspettato delle statistiche delle negoziazioni non riuscite in modalità principale.

Per creare un nuovo criterio IPSec

  1. Fare clic con il pulsante destro del mouse sul nodo Criteri di sicurezza IP e quindi scegliere Crea criterio di sicurezza IP.

  2. Nella Creazione guidata criteri di sicurezza IP fare clic su Avanti.

  3. Digitare il nome e l'eventuale descrizione del criterio e quindi fare clic su Avanti.

  4. Scegliere se selezionare o meno la casella di controllo Attiva la regola di risposta predefinita e quindi fare clic su Avanti.

    Nota

    La regola di risposta predefinita può essere utilizzata solo per i criteri applicati a Windows XP e a Windows Server 2003 e versioni precedenti. Nelle versioni successive di Windows non è possibile utilizzare la regola di risposta predefinita.

  5. Se si utilizza la regola di risposta predefinita, selezionare un metodo di autenticazione e quindi fare clic su Avanti.

    Per ulteriori informazioni sulla regola di risposta predefinita, vedere Regole IPSec.

  6. Lasciare selezionata la casella di controllo Modifica proprietà e quindi fare clic su Avanti. È inoltre possibile aggiungere le regole desiderate al criterio, in base alle necessità.

Aggiungere o modificare una regola in un criterio

Per aggiungere una regola a un criterio

  1. Fare clic con il pulsante destro del mouse sulla regola IPSec e quindi scegliere Proprietà.

  2. Se si desidera creare la regola nella finestra di dialogo delle proprietà, deselezionare la casella di controllo Utilizza Aggiunta guidata. Per utilizzare la procedura guidata, lasciare la casella di controllo selezionata. Fare clic su Aggiungi. Nelle istruzioni seguenti viene indicato come creare una regola utilizzando la finestra di dialogo.

  3. Nella scheda Elenco filtri IP della finestra di dialogo Proprietà nuova regola selezionare l'elenco di filtri appropriato o fare clic su Aggiungi per aggiungerne uno nuovo. Se sono già stati creati elenchi di filtri, questi verranno visualizzati in Elenchi filtri IP. Per ulteriori informazioni sulla creazione e l'utilizzo degli elenchi di filtri, vedere Elenchi di filtri.

    Nota

    È possibile utilizzare un solo elenco di filtri per regola.

  4. Nella scheda Operazione filtro selezionare l'operazione filtro appropriata o fare clic su Aggiungi per aggiungerne una nuova. Per ulteriori informazioni sulla creazione e l'utilizzo delle operazioni filtro, vedere Operazioni filtro.

    Nota

    È possibile utilizzare una sola operazione filtro per regola.

  5. Nella scheda Metodi di autenticazione selezionare il metodo appropriato o fare clic su Aggiungi per aggiungere un nuovo metodo. Per ulteriori informazioni sulla creazione e l'utilizzo dei metodi di autenticazione, vedere Autenticazione IPSec.

    Nota

    È possibile utilizzare diversi metodi per regola. Tali metodi vengono tentati nell'ordine in cui appaiono nell'elenco. Se si specifica l'utilizzo di certificati, inserirli nell'elenco nell'ordine in cui si desidera che vengano utilizzati.

  6. Nella scheda Tipo di connessione selezionare il tipo di connessione a cui si applica la regola. Per ulteriori informazioni sui tipi di connessione, vedere Tipo di connessione IPSec

  7. Se si utilizza un tunnel, specificare gli endpoint nella scheda Impostazioni tunnel. Per impostazione predefinita, non viene utilizzato alcun tunnel. Per ulteriori informazioni sull'utilizzo dei tunnel, vedere Impostazioni del tunnel IPSec. Non è possibile eseguire il mirroring delle regole di tunneling.

  8. Al termine delle impostazioni, fare clic su OK.
Per modificare una regola di un criterio

  1. Fare clic con il pulsante destro del mouse sul criterio IPsec e quindi scegliere Proprietà.

  2. Nella finestra di dialogo Proprietà criterio selezionare la regola e quindi fare clic su Modifica.

  3. Nella scheda Elenco filtri IP della finestra di dialogo Modifica proprietà regola selezionare l'elenco di filtri appropriato o fare clic su Aggiungi per aggiungerne uno nuovo. Per ulteriori informazioni sulla creazione e l'utilizzo degli elenchi di filtri, vedere Elenchi di filtri.

    Nota

    È possibile utilizzare un solo elenco di filtri per regola.

  4. Nella scheda Operazione filtro selezionare l'operazione filtro appropriata o fare clic su Aggiungi per aggiungerne una nuova. Per ulteriori informazioni sulla creazione e l'utilizzo delle operazioni filtro, vedere Operazioni filtro.

    Nota

    È possibile utilizzare una sola operazione filtro per regola.

  5. Nella scheda Metodi di autenticazione selezionare il metodo appropriato o fare clic su Aggiungi per aggiungere un nuovo metodo. Per ulteriori informazioni sulla creazione e l'utilizzo dei metodi di autenticazione, vedere Autenticazione IPSec.

    Nota

    È possibile utilizzare diversi metodi per regola. Tali metodi vengono tentati nell'ordine in cui appaiono nell'elenco.

  6. Nella scheda Tipo di connessione selezionare il tipo di connessione a cui si applica la regola. Per ulteriori informazioni sui tipi di connessione, vedere Tipo di connessione IPSec.

  7. Se si utilizza un tunnel, specificare gli endpoint nella scheda Impostazioni tunnel. Per impostazione predefinita, non viene utilizzato alcun tunnel. Per ulteriori informazioni sull'utilizzo dei tunnel, vedere Impostazioni del tunnel IPSec.

  8. Dopo aver definito tutte le impostazioni, fare clic su OK.

Assegnare un criterio

Per assegnare un criterio al computer in uso

  • Fare clic con il pulsante destro del mouse sul criterio e quindi scegliere Assegna.

    Note
    • A un computer può essere assegnato un solo criterio alla volta. L'assegnazione di un nuovo criterio comporta la sostituzione automatica del criterio corrente. I criteri di gruppo impostati nel dominio potrebbero assegnare al computer un criterio diverso che sostituirebbe quello locale.
    • Per utilizzare un criterio IPSec in una connessione da computer a computer, è necessario creare un criterio con mirroring sull'altro computer e quindi assegnare il criterio a tale computer.
    • Per assegnare questo criterio a diversi computer, utilizzare Criteri di gruppo.

Vedere anche

  • Autenticazione IPSec
  • Tipo di connessione IPSec
  • Impostazioni del tunnel IPSec
  • Operazioni filtro
  • Elenchi di filtri
  • Regole IPSec


Elenchi di filtri

Ad eccezione del caso di una regola di blocco o di autorizzazione, un elenco di filtri IP attiva negoziazioni di sicurezza basate sulla corrispondenza con l'origine, la destinazione e il tipo di traffico IP. Questo tipo di filtro dei pacchetti IP consente all'amministratore di rete di definire precisamente il traffico IP che verrà protetto. Ogni elenco di filtri IP contiene uno o più filtri che definiscono tipi di traffico e indirizzi IP. È possibile utilizzare un singolo elenco di filtri IP per più scenari di comunicazione.

IPSec richiede sia un filtro in ingresso che un filtro in uscita tra i computer specificati nell'elenco di filtri, tranne che per le regole di blocco o di autorizzazione. I filtri in ingresso vengono applicati al traffico in arrivo, consentendo al computer ricevente di rispondere alle richieste di comunicazione sicura oppure di verificare la corrispondenza del traffico con l'elenco di filtri IP. I filtri in uscita vengono applicati al traffico in uscita e prevedono una negoziazione della sicurezza prima dell'invio del traffico.

Tramite la casella di controllo Con mirroring è possibile creare automaticamente due filtri: uno per il traffico diretto verso la destinazione e l'altro per il traffico proveniente dalla destinazione. In tal modo è possibile stabilire comunicazioni bidirezionali con altri computer.

Impostazioni degli elenchi di filtri

Gli elenchi di filtri (e le operazioni filtro) possono essere definiti prima o durante la creazione di un criterio. Gli elenchi di filtri sono disponibili per qualsiasi criterio. Per definire un elenco di filtri, fare clic con il pulsante destro del mouse sul nodo Criteri di sicurezza IP e scegliere Gestisci elenchi filtri IP e operazioni filtro.

Ogni filtro individua un sottoinsieme del traffico di rete in ingresso o in uscita e vi interviene proteggendolo (tramite autenticazione, integrità dei dati o crittografia), bloccandolo interamente o autorizzandolo (senza autenticazione, integrità dei dati o crittografia). È necessario definire un filtro per ogni tipo di traffico a cui si applica la regola associata. Un filtro contiene le seguenti impostazioni:

  • Gli indirizzi IP di origine e di destinazione del pacchetto IP. È possibile configurare qualsiasi indirizzo IP assegnato al peer IPSec, un indirizzo IP specifico, indirizzi IP individuati tramite nome DNS o gruppi di indirizzi che specificano subnet IP.

  • Il protocollo utilizzato per trasferire il pacchetto. Sono previsti tutti i protocolli del gruppo TCP/IP. Per soddisfare esigenze particolari, è tuttavia possibile configurare questa impostazione su un singolo protocollo, inclusi i protocolli personalizzati.

  • La porta di origine e di destinazione del protocollo per TCP e UDP. Per impostazione predefinita, sono previste tutte le porte TCP e UDP, ma è possibile configurare questa impostazione in modo che venga applicata solo a una porta TCP o UDP specifica.

Importante

La risoluzione dei nomi DNS avviene solo quando l'elenco di filtri viene creato e non viene ripetuta successivamente. Pertanto, se l'indirizzo IP viene modificato, il criterio non verrà aggiornato. Per aggiornare l'indirizzo IP è necessario modificare il criterio.

Per creare un elenco di filtri utilizzando la finestra di dialogo Proprietà nuova regola

  1. Nella finestra di dialogo Proprietà criterio di sicurezza IP selezionare la regola di sicurezza IP desiderata e fare clic su Modifica oppure creare una nuova regola facendo clic su Aggiungi.

  2. Se si desidera creare l'elenco di filtri utilizzando la finestra di dialogo delle proprietà, nella scheda Elenco filtri IP deselezionare la casella di controllo Utilizza Aggiunta guidata. Se si desidera utilizzare la procedura guidata, lasciare selezionata la casella di controllo. Fare clic su Aggiungi. Le istruzioni seguenti si riferiscono alla creazione di un elenco di filtri tramite la finestra di dialogo.

  3. Nella scheda Indirizzi della finestra di dialogo Proprietà filtro IP selezionare un indirizzo IP di origine (locale) e un indirizzo IP di destinazione (che individua un peer IPSec).

  4. Nella scheda Protocollo selezionare il tipo di protocollo su cui il filtro agirà.

  5. (Facoltativo) Nella scheda Descrizione digitare una descrizione del filtro. Tale descrizione faciliterà l'ordinamento dei filtri e ne consentirà l'identificazione rapida senza che sia necessario esaminarne le proprietà.

  6. Fare clic su OK.

  7. Ripetere i passaggi da 4 a 8 per aggiungere altri filtri all'elenco.

  8. Nella finestra di dialogo Elenco filtri IP digitare un nome descrittivo per l'elenco di filtri. Fare clic su OK per aggiungere l'elenco di filtri alla regola.

  9. Nella finestra di dialogo Proprietà nuova regola selezionare l'elenco di filtri.
Per creare un elenco di filtri utilizzando la finestra di dialogo Gestisci elenchi filtri IP e operazioni filtro

  1. Fare clic con il pulsante destro del mouse sul nodo Criteri di sicurezza IP e scegliere Gestisci elenchi filtri IP e operazioni filtro.

  2. Nella scheda Gestione elenchi filtri IP fare clic su Aggiungi.

  3. Se si desidera creare l'elenco di filtri utilizzando la finestra di dialogo delle proprietà, nella scheda Elenco filtri IP deselezionare la casella di controllo Utilizza Aggiunta guidata. Se si desidera utilizzare la procedura guidata, lasciare selezionata la casella di controllo. Fare clic su Aggiungi. Le istruzioni seguenti si riferiscono alla creazione di un elenco di filtri tramite la finestra di dialogo.

  4. Nella scheda Indirizzi della finestra di dialogo Proprietà - Filtro IP selezionare un indirizzo IP di origine (locale) e un indirizzo IP di destinazione, ovvero un peer IPSec.

  5. Nella scheda Protocollo selezionare il tipo di protocollo su cui agirà il filtro.

  6. (Facoltativo) Nella scheda Descrizione digitare una descrizione del filtro. Tale descrizione faciliterà l'individuazione dei filtri e ne consentirà l'identificazione rapida senza che sia necessario esaminarne le proprietà.

  7. Fare clic su OK.

  8. Ripetere i passaggi da 4 a 8 per aggiungere altri filtri all'elenco.

  9. Nella finestra di dialogo Elenco filtri IP digitare un nome descrittivo per l'elenco di filtri. Fare clic su OK per aggiungere l'elenco di filtri alla regola.

Vedere anche

  • Operazioni filtro


Operazioni filtro

Un'operazione filtro definisce i requisiti di sicurezza per la trasmissione dei dati. Le operazioni filtro possono essere definite prima o durante la creazione di un criterio. Gli elenchi di filtri sono disponibili per qualsiasi criterio. Per definire un elenco di filtri, fare clic con il pulsante destro del mouse sul nodo Criteri di sicurezza IP e scegliere Gestisci elenchi filtri IP e operazioni filtro.

Le operazioni filtro possono essere configurate in modo da:

Autorizzare il traffico

IPSec passa il traffico inviato o ricevuto dal driver TCP/IP senza modifiche o senza requisiti di sicurezza. Questo tipo di funzionamento è appropriato per il traffico proveniente da computer che non supportano IPSec. Quando si utilizza questo tipo di operazione filtro è importante limitare al massimo l'ambito dell'elenco di filtri IP, in modo da evitare il passaggio di traffico che dovrebbe essere protetto.

Prendere in considerazione la possibilità di autorizzare il traffico ICMP per la risoluzione dei problemi. Potrebbe inoltre essere necessario consentire a un computer non incluso nel dominio, ad esempio il computer di un consulente, l'accesso a un altro computer del dominio. Per consentire tale accesso è possibile utilizzare l'operazione filtro di autorizzazione.

Importante

L'operazione filtro di autorizzazione consente l'accesso senza autenticazione, integrità dei dati o crittografia. Chiunque utilizzi un computer con l'indirizzo IP specificato nell'elenco di filtri è autorizzato all'accesso. Tutto il traffico tra i computer si svolge senza protezione e non viene eseguita alcuna verifica di integrità.

Bloccare il traffico

IPSec elimina il traffico in modo invisibile all'utente. Quando si utilizza un'operazione filtro di blocco, assicurarsi di utilizzare un elenco di filtri IP che definisca l'ambito di indirizzi IP corretto. L'utilizzo di ambiti più ampi può comportare il blocco del traffico tra computer validi.

Negoziare la sicurezza

Se si attiva l'opzione Accetta comunicazioni non sicure, ma rispondi sempre usando IPSec, IPSec tenterà di negoziare le associazioni di sicurezza (SA, Security Association) e l'invio o la ricezione di traffico protetto tramite IPSec. Se tuttavia il computer peer non può utilizzare IPSec, verranno consentite le comunicazioni senza protezione IPSec. Se si è scelta questa operazione filtro, sarà inoltre possibile eseguire le configurazioni seguenti:

  • Metodi di sicurezza e relativo ordinamento. L'elenco di metodi definisce l'ordine in cui i metodi verranno tentati. Verrà utilizzato il primo metodo che ha esito positivo e i metodi restanti non verranno tentati. I metodi vengono in genere ordinati dal più sicuro al meno sicuro, in modo che venga utilizzato il più sicuro.

  • Autorizzazione del traffico non protetto in ingresso iniziale (Accetta comunicazioni non protette, ma rispondi sempre usando IPSec). IPSec consente l'ingresso di pacchetti non protetti da IPSec quando questi siano corrispondenti all'elenco di filtri configurato. La risposta in uscita al pacchetto in ingresso deve tuttavia essere protetta. Questa impostazione risulta utile se si utilizza per i client la regola di risposta predefinita. Se un gruppo di server è configurato con una regola che assicura la sicurezza delle comunicazioni con qualsiasi indirizzo IP e accetta la comunicazione non protetta rispondendo solo con comunicazioni protette, l'attivazione della regola di risposta predefinita sui client garantisce che i client risponderanno alle richieste del server per la negoziazione della sicurezza. È consigliabile disattivare questa opzione per i computer sicuri connessi a Internet, allo scopo di evitare attacchi Denial of Service.

  • Attivazione della comunicazione con computer non abilitati per IPSec (Consenti comunicazioni non sicure se non è possibile stabilire una connessione sicura). IPSec consente la comunicazione non protetta, se necessario. Anche in questo caso è opportuno limitare l'elenco di filtri IP a un ambito minimo. In caso contrario, infatti, nelle comunicazioni su cui ha effetto la regola in cui risiede questa operazione filtro potrebbe verificarsi l'invio di dati senza sicurezza se la negoziazione avesse esito negativo per qualsiasi motivo. Se si desidera evitare la comunicazione non protetta, è possibile disattivare queste impostazioni. In questo caso, tuttavia, è possibile che venga bloccata la comunicazione con i computer che non possono avviare IPSec, ad esempio i sistemi legacy. È consigliabile disattivare questa opzione per i computer sicuri connessi a Internet, allo scopo di evitare attacchi Denial of Service.

  • Generazione di chiavi di sessione in modalità rapida da nuovo materiale per le chiavi in modalità principale (chiave di sessione PFS). L'attivazione della chiave di sessione PFS (Perfect Forward Secrecy) garantisce che il materiale per le chiavi master in modalità principale non possa essere utilizzato per generare più di una chiave di sessione in modalità rapida. Se è attivato PFS in modalità rapida, prima di creare la nuova chiave in modalità rapida viene eseguito un altro scambio di chiavi Diffie-Hellman per generare nuovo materiale per le chiavi master in modalità principale. La chiave di sessione PFS in modalità rapida non richiede la riautenticazione in modalità principale e comporta un utilizzo di risorse inferiore rispetto alla chiave master PFS in modalità principale.

Metodi di sicurezza IPSec

Ogni metodo di sicurezza definisce i requisiti di sicurezza di tutte le comunicazioni a cui viene applicata la regola associata. La creazione di più metodi di sicurezza aumenta la possibilità di trovare un metodo comune tra due computer. Il componente IKE (Internet Key Exchange) legge l'elenco dei metodi di sicurezza in ordine decrescente e invia un elenco dei metodi di sicurezza consentiti all'altro peer. Verrà selezionato il primo metodo comune. I metodi più sicuri vengono in genere posizionati all'inizio dell'elenco e i metodi meno sicuri nella parte inferiore.

Metodi di sicurezza predefiniti

Di seguito sono elencati i metodi di sicurezza predefiniti:

Crittografia e integrità

Utilizza il protocollo ESP per garantire la riservatezza (crittografia) dei dati mediante l'algoritmo 3DES (Triple Data Encryption Standard), l'integrità e l'autenticazione dei dati mediante l'algoritmo SHA1 (Secure Hash Algorithm 1) e la durata predefinita delle chiavi (100 MB, 1 ora). Se è necessaria sia la protezione dei dati che quella dell'indirizzamento (intestazione IP), è possibile creare un metodo di sicurezza personalizzato. Se non è necessaria la crittografia, utilizzare Solo integrità.

Solo integrità

Utilizza il protocollo ESP per assicurare l'integrità e l'autenticazione dei dati mediante l'algoritmo di integrità SHA1 e la durata standard delle chiavi (100 MB, 1 ora). In questa configurazione il protocollo ESP non assicura la riservatezza (crittografia) dei dati.

Metodi di sicurezza personalizzati

Se i metodi predefiniti Crittografia e integrità o Solo integrità non soddisfano i requisiti di sicurezza, è possibile specificare metodi di sicurezza personalizzati. I metodi personalizzati possono essere utilizzati, ad esempio, quando è necessario specificare la crittografia e l'integrità degli indirizzi, algoritmi di livello più elevato o le durate delle chiavi. Per un metodo di sicurezza personalizzato è possibile configurare gli elementi seguenti:
Protocolli di sicurezza

Se sono richieste l'integrità dell'intestazione IP e la crittografia dei dati, in un metodo di sicurezza personalizzato possono essere attivati sia AH (integrità dati e indirizzi senza crittografia) che ESP (integrità dati con crittografia). Se si sceglie di attivare entrambi, non è necessario specificare un algoritmo di integrità per ESP.

Nota

Non è possibile utilizzare il protocollo AH su dispositivi NAT (Network Address Translation), perché utilizza un hash dell'intestazione. Poiché i dispositivi NAT modificano l'intestazione, il pacchetto non verrebbe autenticato correttamente.

Algoritmo di integrità

MD5 (Message Digest 5), che utilizza una chiave a 128 bit. Questo algoritmo non è più considerato sicuro e deve essere utilizzato solo per esigenze di interoperabilità.

SHA1, che utilizza una chiave a 160 bit. SHA1 produce un hash di livello più elevato rispetto a MD5 ed è compatibile con lo standard FIPS (Federal Information Processing Standard).

Algoritmo di crittografia

3DES è la combinazione DES che offre maggiore sicurezza e, di conseguenza, prestazioni leggermente minori in termini di velocità. 3DES elabora ogni blocco tre volte, utilizzando tre chiavi univoche a 56 bit.

DES impiega una sola chiave a 56 bit e viene utilizzato quando la maggiore sicurezza e il relativo sovraccarico che caratterizzano 3DES non sono richiesti. Questo algoritmo non è più considerato sicuro e deve essere utilizzato solo per esigenze di interoperabilità.

Le impostazioni delle chiavi di sessione in modalità rapida determinano il momento e non il modo in cui viene generata una nuova chiave. È possibile specificare una durata in kilobyte (KB), secondi o entrambi. Se ad esempio la comunicazione richiede 10.000 secondi e si specifica una durata della chiave di 1.000 secondi, per completare il trasferimento verranno generate 10 chiavi. Ciò garantisce che un eventuale utente non autorizzato che riuscisse a ottenere una chiave della sessione, potrebbe decifrare una parte della comunicazione, ma non tutta. Per impostazione predefinita, vengono generate nuove chiavi in modalità rapida ogni ora oppure ogni 100 MB di dati. Ogni volta che scade una chiave, oltre all'aggiornamento o alla rigenerazione della chiave viene anche rinegoziata l'associazione di sicurezza (SA).

Per creare un'operazione filtro utilizzando la finestra di dialogo Proprietà nuova regola

  1. Se si desidera creare l'operazione filtro nella finestra di dialogo delle proprietà, nella scheda Regole della finestra di dialogo Proprietà criterio di sicurezza IP deselezionare la casella di controllo Utilizza Aggiunta guidata. Se si desidera utilizzare la procedura guidata, lasciare selezionata la casella di controllo. Fare clic su Aggiungi. Le istruzioni seguenti si riferiscono alla creazione di un elenco di filtri tramite la finestra di dialogo.

  2. Nella scheda Operazione filtro della finestra di dialogo Proprietà regola deselezionare la casella di controllo Utilizza Aggiunta guidata e fare clic su Aggiungi.

  3. Nella scheda Metodi di sicurezza selezionare il metodo (operazione) che verrà utilizzato dalla regola.

  4. (Facoltativo) Nella scheda Descrizione digitare una descrizione dell'operazione filtro. Tale descrizione faciliterà l'ordinamento delle operazioni filtro e ne consentirà l'identificazione rapida senza che sia necessario esaminarne le proprietà.

  5. Fare clic su OK.

  6. Ripetere i passaggi da 4 a 8 per aggiungere ulteriori operazioni filtro all'elenco.

    Nota

    Benché in ogni regola sia possibile elencare diverse operazioni filtro, ne verrà utilizzata solo una.

  7. Nella scheda Operazione filtro selezionare l'operazione filtro appropriata per la regola e fare clic su OK.
Per creare un'operazione filtro utilizzando la finestra di dialogo Gestisci elenchi filtri IP e operazioni filtro

  1. Fare clic con il pulsante destro del mouse sul nodo Criteri di sicurezza IP e scegliere Gestisci elenchi filtri IP e operazioni filtro.

  2. Se si desidera creare l'operazione filtro utilizzando la finestra di dialogo delle proprietà, nella scheda Gestione operazioni filtro deselezionare la casella di controllo Utilizza Aggiunta guidata. Se si desidera utilizzare la procedura guidata, lasciare selezionata la casella di controllo. Fare clic su Aggiungi. Le istruzioni seguenti si riferiscono alla creazione di un elenco di filtri tramite la finestra di dialogo. In queste istruzioni non viene utilizzata la procedura guidata.

  3. Nella scheda Metodi di sicurezza selezionare il metodo e fare clic su OK.

  4. Se è stata selezionata l'opzione Negozia sicurezza, sarà possibile aggiungere più metodi e specificare l'ordine in cui questi verranno tentati. A tale scopo, fare clic su Aggiungi.

  5. (Facoltativo) Nella scheda Descrizione digitare una descrizione del filtro. Tale descrizione faciliterà l'ordinamento dei filtri e ne consentirà l'identificazione rapida senza che sia necessario esaminarne le proprietà.

  6. Fare clic su OK.

  7. Ripetere i passaggi da 4 a 8 per aggiungere operazioni filtro all'elenco.

Vedere anche

  • Elenchi di filtri
  • Autenticazione IPSec


Autenticazione IPSec

Ogni regola definisce un elenco di metodi di autenticazione. Ogni metodo di autenticazione definisce i requisiti in base ai quali verranno verificate le identità nelle comunicazioni a cui si applica la regola associata. Tali metodi vengono tentati da ogni peer nell'ordine in cui appaiono nell'elenco. Perché la comunicazione venga effettuata correttamente, i due peer devono avere almeno un metodo di autenticazione comune. Se si creano più metodi di autenticazione, si aumenta la possibilità che i due computer dispongano di un metodo comune.

Nota

Anche l'ordine di tali metodi è importante, perché viene tentato solo il primo metodo comune. Se con questo l'autenticazione non riesce, gli altri metodi in elenco non verranno tentati, anche se potenzialmente validi.

Metodi di autenticazione

Indipendentemente dal numero di metodi configurati, è possibile specificare un solo metodo di autenticazione tra due computer. Se esistono più regole applicabili a una stessa coppia di computer, è necessario configurare l'elenco dei metodi di autenticazione in tali regole per consentire alla coppia di utilizzare lo stesso metodo. Se ad esempio una regola tra due computer specifica solo il protocollo Kerberos per l'autenticazione e filtra solo i dati TCP, mentre l'altra regola specifica solo i certificati per l'autenticazione e filtra solo i dati UDP, l'autenticazione non verrà eseguita. È possibile configurare i metodi di autenticazione nella scheda Metodi di autenticazione delle finestre delle proprietà Modifica proprietà regola o Aggiungi proprietà regola.

  • Il protocollo di autenticazione Kerberos versione 5 è la tecnologia di autenticazione predefinita. È possibile utilizzare questo metodo per tutti i computer che eseguono il protocollo di autenticazione Kerberos V5 e che sono membri di uno stesso dominio oppure di domini trusted. Questo metodo è utile per l'isolamento dei domini con IPSec (Internet Protocol Security).

  • È consigliabile utilizzare un certificato di chiave pubblica in situazioni che prevedono l'accesso a Internet, l'accesso remoto a risorse aziendali, comunicazioni esterne con distributori o computer su cui non viene eseguito il protocollo di autenticazione Kerberos V5. In questi casi è necessario configurare almeno un'Autorità di certificazione (CA) attendibile. Questa versione di Windows supporta i certificati X.509 versione 3, inclusi i certificati CA generati da Autorità di certificazione commerciali.

  • È possibile specificare una chiave già condivisa. Si tratta di una chiave segreta condivisa, stabilita in precedenza di comune accordo tra due utenti. I vantaggi di questo tipo di chiave sono la facilità di utilizzo e il fatto che non richiede che nel client sia in esecuzione il protocollo di autenticazione Kerberos V5 o sia presente un certificato di chiave pubblica. Entrambe le parti devono configurare manualmente IPSec per utilizzare questa chiave già condivisa. Questo metodo consente di autenticare facilmente computer autonomi o computer che non utilizzano il protocollo di autenticazione Kerberos V5. Le chiavi già condivise vengono utilizzate solo per la protezione dell'autenticazione e non per l'integrità e la crittografia dei dati.

Importante

La chiave già condivisa viene archiviata in forma non crittografata e non è considerata un metodo sicuro. Le chiavi già condivise dovrebbero essere utilizzate solo a scopo di testing.

Vedere anche

  • Operazioni filtro
  • Regole IPSec


Impostazioni del tunnel IPSec

IPSec consente il tunneling di livello 3 per gli scenari in cui non è possibile utilizzare L2TP (Layer Two Tunneling Protocol). Se si utilizza L2TP per le comunicazioni remote, non sarà necessaria alcuna configurazione del tunnel perché i componenti VPN client e server di Windows creano automaticamente le regole per la sicurezza del traffico L2TP.

Per creare un tunnel di livello 3 con IPSec, utilizzare lo snap-in Criteri di sicurezza IP o Criteri di gruppo per configurare e attivare le due regole seguenti:

  1. Una regola per il traffico in uscita per il tunnel. Per configurare la regola per il traffico in uscita, si utilizzano un elenco di filtri che descrive il traffico che verrà inviato tramite il tunnel e un endpoint del tunnel con un indirizzo IP configurato nel peer del tunnel IPSec (computer o router dall'altro lato del tunnel).

  2. Una regola per il traffico in ingresso per il tunnel. Per configurare la regola per il traffico in ingresso, si utilizzano un elenco di filtri che descrive il traffico che verrà ricevuto tramite il tunnel e un endpoint del tunnel con un indirizzo IP locale (computer o router da questo lato del tunnel).

Nota

Per ogni connessione tramite tunnel è necessario creare sia la regola per il traffico in ingresso che quella per il traffico in uscita. Se viene creato un filtro in una sola direzione, la regola non verrà applicata.

Quando si crea un criterio per un computer Microsoft Windows Vista o una versione successiva di Windows, è possibile specificare un indirizzo IPv4 o IPv6. È necessario specificare un endpoint per ogni lato del tunnel utilizzando la stessa versione del protocollo per indirizzi per entrambi i lati. Se si specifica un indirizzo IPv6 per il lato di origine del tunnel, si dovrà pertanto utilizzare un indirizzo IPv6 anche per il lato remoto.

Per ogni regola è inoltre necessario specificare le operazioni filtro, i metodi di autenticazione e altre impostazioni.

Vedere anche

  • Regole IPSec


Tipo di connessione IPSec

Per ogni regola IPSec (Internet Protocol Security) è necessario specificare i tipi di connessione a cui la regola verrà applicata. È ad esempio possibile specificare che una regola verrà applicata solo alle connessioni di accesso remoto.

A ogni regola corrisponde un'impostazione del tipo di connessione:

  • Tutte le connessioni di rete. La regola verrà applicata alle comunicazioni inviate tramite qualsiasi connessione di rete configurata nel computer.

  • Rete locale (LAN). La regola verrà applicata solo alle comunicazioni inviate tramite le connessioni LAN configurate nel computer.

    Nota

    Quando i criteri vengono creati utilizzando lo snap-in Criteri di sicurezza IP, le connessioni wireless vengono gestite come connessioni di rete locale (LAN). Per specificare che una regola dovrà essere applicata solo a una connessione wireless, è necessario creare un criterio utilizzando il nuovo snap-in Windows Firewall con sicurezza avanzata.

  • Accesso remoto. La regola verrà applicata solo alle comunicazioni inviate tramite le connessioni di accesso remoto, VPN o remote configurate nel computer.


Regole IPSec

Un criterio IPSec (Internet Protocol Security) è rappresentato da una o più regole che definiscono il funzionamento di IPSec. Le regole IPSec possono essere configurate nella scheda Regole delle proprietà di un criterio IPSec. Ogni regola IPSec contiene gli elementi di configurazione seguenti:

Elenco di filtri

Un singolo elenco di filtri contenente uno o più filtri di pacchetto predefiniti che descrivono i tipi di traffico ai quali è applicata l'operazione filtro configurata per la regola. È possibile configurare l'elenco di filtri nella scheda Elenco filtri IP delle proprietà di una regola IPSec di un criterio IPSec. Per ulteriori informazioni sugli elenchi di filtri, vedere Elenchi di filtri.

Operazione filtro

Una singola operazione filtro contenente il tipo di operazione richiesta (Autorizza, Blocco o Negozia sicurezza) per i pacchetti corrispondenti all'elenco di filtri. I dati di negoziazione per l'operazione filtro Negozia sicurezza contengono uno o più metodi di sicurezza utilizzati, in ordine di preferenza, durante le negoziazioni IKE e altre impostazioni relative a IPSec. Ogni metodo di sicurezza stabilisce il protocollo di sicurezza, ad esempio AH o ESP, gli algoritmi di crittografia e le impostazioni utilizzate per la rigenerazione delle chiavi di sessione. È possibile configurare i dati di negoziazione nella scheda Operazione filtro delle proprietà di una regola IPSec di un criterio IPSec. Per ulteriori informazioni, vedere Operazioni filtro.

Metodi di autenticazione

Vengono configurati uno o più metodi di autenticazione in ordine di preferenza, che vengono quindi utilizzati per l'autenticazione dei peer IPSec durante le negoziazioni in modalità principale. I metodi di autenticazione disponibili sono il protocollo Kerberos V5, l'utilizzo di un certificato emesso da un'Autorità di certificazione (CA) specificata o una chiave già condivisa. È possibile configurare i dati di autenticazione nella scheda Metodi autenticazione delle proprietà di una regola IPSec di un criterio IPSec. Per ulteriori informazioni, vedere Autenticazione IPSec.

Endpoint tunnel

Specifica se per il traffico viene eseguito il tunneling e l'eventuale indirizzo IP dell'endpoint del tunnel. Per il traffico in uscita, l'endpoint del tunnel corrisponde all'indirizzo IP del peer del tunnel IPSec, mentre per il traffico in ingresso corrisponde a un indirizzo IP locale. È possibile configurare l'endpoint del tunnel nella scheda Impostazioni tunnel delle proprietà di una regola IPSec di un criterio IPSec. È necessario creare due regole di tunneling, una per ogni direzione del traffico. Per ulteriori informazioni, vedere Impostazioni del tunnel IPSec.

Tipo di connessione

Specifica se la regola è valida per le connessioni LAN, per le connessioni remote o per entrambe. È possibile configurare il tipo di connessione nella scheda Tipo di connessione delle proprietà di una regola IPSec di un criterio IPSec. Per ulteriori informazioni, vedere Tipo di connessione IPSec.

Regola di risposta predefinita

La regola di risposta predefinita consente di assicurare la risposta del computer alle richieste di comunicazione sicura. Se in un criterio attivo non è stata definita una regola che richiede la comunicazione sicura, verrà applicata la regola di risposta predefinita (se attivata) e verrà negoziata la sicurezza. Verrà ad esempio utilizzata la regola di risposta predefinita se Computer A comunica in modo sicuro con Computer B e in Computer B non è stato definito alcun filtro in ingresso per Computer A.

La regola di risposta predefinita può essere utilizzata per tutti i criteri e non può essere eliminata, ma può essere disattivata. È possibile attivarla quando si creano nuovi criteri IPSec con la Creazione guidata criteri di sicurezza IP.

Nota

La regola di risposta predefinita verrà ignorata in un criterio assegnato a un computer che esegue Windows Vista® o una versione successiva di Windows.

È possibile configurare i metodi di autenticazione e i metodi di sicurezza per la regola di risposta predefinita. L'elenco di filtri <Dinamico> indica che l'elenco non è stato configurato, ma che i filtri vengono creati automaticamente in base alla ricezione dei pacchetti di negoziazione IKE. L'operazione filtro Risposta predefinita indica che non è possibile configurare l'operazione del filtro (Autorizza, Blocco o Negozia sicurezza).


Scambio chiave IPSec

Prima che sia possibile effettuare uno scambio di dati protetto, è necessario stabilire un accordo tra i due computer. In tale accordo, denominato associazione di sicurezza (SA, Security Association), le parti concordano le modalità di scambio e protezione delle informazioni.

Una chiave è un codice o un numero segreto necessario per la lettura, la modifica o il controllo delle informazioni protette. Le chiavi vengono utilizzate insieme agli algoritmi (processi matematici) per proteggere i dati. In IPSec le chiavi vengono utilizzate in due fasi o modalità. La modalità principale viene adottata per prima e prevede la generazione di una chiave master condivisa che le parti utilizzeranno per scambiarsi informazioni sulla generazione delle chiavi in modo sicuro. La modalità rapida prevede l'utilizzo della chiave master per proteggere la definizione di una o più chiavi di sessione che vengono utilizzate per la crittografia o l'integrità dei dati.

Windows gestisce la generazione delle chiavi in modo automatico e ottimizza la protezione implementando le proprietà delle chiavi seguenti:

Importante

Lo snap-in Criteri di sicurezza IP consente la creazione di criteri IPSec che possono essere applicati a computer che eseguono Microsoft Windows Vista e versioni successive di Windows, ma non utilizza i nuovi algoritmi di sicurezza e altre nuove funzionalità disponibili in computer che eseguono le versioni successive di Windows. Per creare criteri IPsec per questi computer, utilizzare lo snap-in Windows Firewall con sicurezza avanzata. I criteri creati con lo snap-in Windows Firewall con sicurezza avanzata non possono essere applicati alle versioni precedenti di Windows.

Generazione dinamica di nuove chiavi

IPSec utilizza un metodo denominato generazione dinamica di nuove chiavi per controllare la frequenza di generazione di nuove chiavi durante la comunicazione. La comunicazione prevede l'invio di blocchi di dati, ognuno dei quali è protetto da una chiave diversa. In questo modo, un eventuale utente non autorizzato che è riuscito a ottenere una parte della comunicazione e le chiavi di sessione corrispondenti non riuscirà a ottenere anche la parte rimanente della comunicazione. Questo servizio di negoziazione della sicurezza a richiesta e di gestione automatica delle chiavi è reso disponibile tramite IKE (Internet Key Exchange), come definito nell'RFC 2409.

IPSec consente di gestire la frequenza con cui vengono generate le nuove chiavi. Se non viene configurato alcun valore, le chiavi verranno rigenerate in modo automatico agli intervalli di tempo predefiniti.

Lunghezza delle chiavi

Ogni volta che la lunghezza di una chiave aumenta di un bit, il numero di chiavi possibili raddoppia, con un incremento esponenziale della difficoltà di individuazione della chiave. IPSec offre la possibilità di utilizzare numerosi algoritmi per la definizione di chiavi lunghe o brevi.

Generazione del materiale per le chiavi: algoritmo Diffie-Hellman

Per consentire una comunicazione sicura, due computer devono essere in grado di ottenere la stessa chiave condivisa (modalità rapida o chiave di sessione) senza che la chiave venga inviata attraverso una rete compromettendone la segretezza.

L'algoritmo Diffie-Hellman (DH) è uno degli algoritmi più vecchi e più sicuri per lo scambio di chiave. Le due parti si scambiano pubblicamente le informazioni sulla generazione delle chiavi, che vengono ulteriormente protette da Windows con la firma di una funzione hash. Le parti non si scambiano la chiave effettiva, ma dopo lo scambio del materiale per le chiavi ognuna di esse è in grado di generare la stessa chiave condivisa.

Il materiale per le chiavi DH scambiato dalle due parti può essere basato su 768, 1024 o 2048 bit, denominati anche gruppi DH. L'affidabilità del gruppo DH è proporzionale all'affidabilità della chiave calcolata a seguito dello scambio di DH. Se si combina un livello elevato di affidabilità dei gruppi DH con lunghezze delle chiavi maggiori, la difficoltà di individuazione della chiave sarà maggiore.

Nota

Nella finestra di dialogo Algoritmi di sicurezza IKE 768 bit corrisponde all'impostazione Min (1) e 1024 bit all'impostazione Media (2).

IPSec si avvale dell'algoritmo DH per fornire il materiale per la generazione di tutte le altre chiavi di crittografia. DH non assicura tuttavia l'autenticazione. Nell'implementazione di IPSec di Microsoft Windows, le identità vengono autenticate dopo lo scambio di DH e pertanto viene assicurata anche la protezione dagli attacchi man-in-the-middle.

Protezione delle chiavi

Di seguito sono illustrate le funzionalità che migliorano l'efficacia dei numeri primi di base (materiale per le chiavi) e l'affidabilità delle chiavi master e delle chiavi di sessione.

Durata delle chiavi

La durata delle chiavi determina il momento in cui viene generata una nuova chiave, piuttosto che la modalità di generazione. È conosciuta anche come rigenerazione dinamica delle chiavi e consente di imporre una rigenerazione delle chiavi dopo un intervallo specificato. Se ad esempio una comunicazione dura 10.000 secondi e si specifica una durata della chiave di 1.000 secondi, per completare la comunicazione verranno generate 10 chiavi. In questo modo si garantisce che, anche se un utente non autorizzato riesce a decifrare una parte della comunicazione, la parte rimanente rimarrà protetta. È possibile specificare una durata sia per le chiavi master che per le chiavi di sessione. Ogni volta che scade la durata di una chiave, viene rinegoziata anche l'associazione di sicurezza. La chiave viene inoltre aggiornata o rigenerata. La quantità di dati elaborata da una singola chiave non dovrebbe essere superiore ai 100 MB.

Limite di aggiornamento delle chiavi di sessione

Il limite di aggiornamento delle chiavi di sessione in modalità rapida viene utilizzato perché la ripetuta reimpostazione di chiavi sulla base di una chiave di sessione in modalità rapida può compromettere il segreto condiviso Diffie-Hellman.

Se, ad esempio, Alice sul Computer A invia un messaggio a Roberto sul Computer B e pochi minuti dopo invia un nuovo messaggio a Roberto, è possibile riutilizzare lo stesso materiale della chiave di sessione perché è stata stabilita di recente un'associazione di sicurezza con quel computer. Se si desidera limitare il numero di riutilizzi del materiale, specificare un valore basso come limite di aggiornamento delle chiavi di sessione.

Se è stata attivata l'opzione PFS (Perfect Forward Secrecy) chiave master, il limite di aggiornamento per la chiave di sessione in modalità rapida non verrà utilizzato. L'impostazione del limite di aggiornamento su 1 equivale all'attivazione dell'opzione PFS chiave master. Se si specificano sia la durata della chiave master in modalità principale che un limite di aggiornamento per la chiave di sessione in modalità rapida, verrà eseguita la reimpostazione della chiave indipendentemente da quale dei due limiti venga raggiunto per primo. Per impostazione predefinita, nei criteri IPSec non viene specificato un limite di aggiornamento per la chiave di sessione.

Gruppi Diffie-Hellman

I gruppi Diffie-Hellman (DH) consentono di determinare la lunghezza dei numeri primi di base (materiale per le chiavi) utilizzati per lo scambio di DH. L'affidabilità di una chiave che deriva da uno scambio di DH dipende in parte dall'affidabilità del gruppo DH su cui si basano i numeri primi.

In ogni gruppo DH viene utilizzata una diversa lunghezza del materiale per le chiavi. Il gruppo 1 protegge 768 bit di materiale per le chiavi, il gruppo 2 protegge 1024 bit e il gruppo 3 protegge 2048 bit. Se viene utilizzato un gruppo più grande, la chiave risultante da uno scambio di DH sarà più grande e più difficile da individuare da parte di un utente non autorizzato.

IKE negozia il gruppo da utilizzare in base alla configurazione stabilita nella finestra di dialogo Algoritmi di sicurezza IKE e garantisce che non vi siano errori di negoziazione dovuti alla mancata corrispondenza del gruppo DH tra i due peer.

Se l'opzione PFS chiave di sessione è attivata, alla prima negoziazione dell'associazione di sicurezza in modalità rapida verrà negoziata una nuova chiave DH. La nuova chiave DH elimina la dipendenza della chiave di sessione dallo scambio di DH eseguito per la chiave master.

Se l'iniziatore attiva l'opzione PFS chiave di sessione, non è necessario che anche il risponditore la attivi. Se invece l'iniziatore non utilizza tale opzione e il risponditore la utilizza, la negoziazione avrà esito negativo.

Il gruppo DH per le negoziazioni delle associazioni di sicurezza in modalità principale è uguale a quello per le negoziazioni delle associazioni di sicurezza in modalità rapida. Se l'opzione chiave di sessione PFS è attivata, influirà su qualsiasi reimpostazione delle chiavi durante la definizione della chiave di sessione in modalità rapida, anche se il gruppo DH è impostato ai fini della negoziazione delle associazioni di sicurezza in modalità principale.

PFS (Perfect Forward Secrecy)

Diversamente dalla durata delle chiavi, l'opzione PFS determina la modalità di generazione di una nuova chiave, piuttosto che il momento in cui questa viene generata. Più specificamente, garantisce che l'eventuale manomissione di una singola chiave consentirà unicamente l'accesso ai dati da essa protetti e non necessariamente all'intera comunicazione. A tale scopo, PFS assicura che una chiave utilizzata per proteggere una trasmissione, in qualsiasi modalità, non possa essere utilizzata per generare altre chiavi. Inoltre, se la chiave è stata creata con materiale specifico, tale materiale non può essere utilizzato per generare altre chiavi.

L'opzione PFS chiave master in modalità principale richiede una riautenticazione e comporta un utilizzo elevato di risorse. Se è attivata, il protocollo IKE deve riautenticare le identità e ciò determina un incremento del sovraccarico per i controller di dominio in caso di autenticazione tramite Kerberos V5, poiché richiede una nuova negoziazione in modalità principale per ogni negoziazione in modalità rapida.

L'opzione chiave di sessione PFS in modalità rapida può essere utilizzata senza riautenticazione e comporta un minor dispendio di risorse. Prevede inoltre uno scambio di DH per la generazione di nuovo materiale per le chiavi. A tale scopo vengono utilizzati quattro messaggi e nessun processo di autenticazione.

Non è necessario attivare PFS in entrambi i peer perché non fa parte della negoziazione delle associazioni di sicurezza. Se il risponditore richiede PFS e l'associazione di sicurezza in modalità rapida dell'iniziatore scade, il messaggio di quest'ultimo verrà rifiutato e verrà richiesta una nuova negoziazione. L'iniziatore farà scadere l'associazione di sicurezza in modalità principale ed eseguirà la rinegoziazione. L'opzione PFS può essere impostata singolarmente sia per le chiavi master in modalità principale che per le chiavi di sessione in modalità rapida.

Scambio di chiave

Prima che sia possibile effettuare uno scambio di dati protetto, è necessario stabilire un accordo tra i due computer. In tale accordo, denominato associazione di sicurezza (SA, Security Association), le parti concordano le modalità di scambio e protezione delle informazioni.

L'accordo tra i due computer viene stabilito in base a un metodo standard per le associazioni di sicurezza e per la risoluzione degli scambi di chiave definito dalla Internet Engineering Task Force (IETF) e denominato IKE, che prevede quanto segue:

  • Gestione centralizzata delle associazioni di sicurezza, che consente di ridurre la durata della connessione.

  • Generazione e gestione di chiavi segrete condivise utilizzate per proteggere le informazioni.

Questo processo non solo assicura la protezione della comunicazione tra i due computer, ma anche la protezione dei computer remoti che richiedono un accesso sicuro a una rete aziendale. Il processo viene inoltre eseguito ogni volta che un gateway di sicurezza esegue la negoziazione per il computer di destinazione finale (endpoint).

Definizione di associazione di sicurezza

Un'associazione di sicurezza è rappresentata dalla combinazione di una chiave negoziata, di un protocollo di sicurezza e dell'indice dei parametri di sicurezza (SPI, Security Parameters Index), che contribuiscono a definire la sicurezza utilizzata per proteggere la comunicazione tra il mittente e il ricevente. L'indice SPI è un valore di identificazione univoco presente nell'associazione di sicurezza, che consente di distinguere tra più associazioni di sicurezza esistenti nel computer di destinazione. Possono ad esempio esistere più associazioni se un computer intrattiene comunicazioni sicure contemporaneamente con più computer. Questa situazione si verifica spesso nel caso di computer che fungono da file server o da server di accesso remoto utilizzati da più client. In questi casi, il computer di destinazione utilizza l'indice SPI per determinare l'associazione di sicurezza che verrà utilizzata per elaborare i pacchetti in ingresso.

Associazione di sicurezza in modalità principale

Per garantire il corretto svolgimento di una comunicazione sicura, IKE esegue un'operazione suddivisa in due fasi. In entrambe le fasi, la riservatezza e l'autenticazione sono garantite dall'utilizzo di algoritmi di crittografia e di autenticazione che vengono concordati dai due computer durante le negoziazioni della sicurezza. La suddivisione delle attività nelle due fasi consente di creare le chiavi in modo rapido.

Nella prima fase, i due computer stabiliscono un canale sicuro autenticato. Tale operazione viene definita associazione di sicurezza in modalità principale. Durante lo scambio, IKE fornisce automaticamente la protezione di identità necessaria.

Nei passaggi seguenti viene descritta una negoziazione in modalità principale.

  1. Negoziazione dei criteri. L'associazione di sicurezza in modalità principale prevede la negoziazione dei quattro parametri obbligatori elencati di seguito:

    • Algoritmo di crittografia (DES o 3DES).

    • Algoritmo hash (MD5 o SHA1).

    • Metodo di autenticazione (Kerberos V5, basata su certificati o con chiave già condivisa).

    • Gruppo Diffie-Hellman (DH) da utilizzare per il materiale di base per le chiavi: Gruppo 1 (Min, 768 bit), Gruppo 2 (Medio, 1024 bit) o Gruppo 3 (Max, 2048 bit).

    • Se per l'autenticazione vengono utilizzati i certificati o le chiavi già condivise, l'identità del computer è protetta. Se invece viene utilizzato il protocollo di autenticazione Kerberos V5, l'identità del computer non è crittografata fino a quando non viene eseguita la crittografia dell'intero payload dell'identità durante l'autenticazione.

  2. Scambio DH (di valori pubblici). Lo scambio delle chiavi effettive non viene mai eseguito. Vengono infatti scambiate solo le informazioni richieste dall'algoritmo di definizione della chiave DH per generare la chiave segreta condivisa. Dopo lo scambio, il servizio IKE di ogni computer genera la chiave master utilizzata per proteggere l'autenticazione.

  3. Autenticazione. I computer tentano di autenticare lo scambio della chiave DH. Se non si esegue l'autenticazione dello scambio della chiave DH, la comunicazione è esposta agli attacchi man-in-the-middle. Se l'autenticazione non riesce, la comunicazione non può procedere. Per autenticare le identità viene utilizzata la chiave master insieme agli algoritmi e ai metodi di negoziazione. Per l'intero payload dell'identità (incluso il tipo di identità, la porta e il protocollo) vengono eseguiti l'hashing e la crittografia tramite le chiavi generate dallo scambio di DH nel secondo passaggio. Il payload dell'identità viene protetto dalle modifiche e dall'interpretazione, indipendentemente dal metodo di autenticazione utilizzato.

    Il mittente presenta un'offerta per un'associazione di sicurezza al destinatario, che non ha facoltà di modificare l'offerta. Se l'offerta viene modificata, l'iniziatore rifiuta il messaggio del risponditore. Il risponditore invia una risposta di accettazione dell'offerta o propone delle alternative.

    I messaggi inviati in questa fase vengono inseriti in un ciclo di ripetizione dei tentativi automatico che viene eseguito per cinque volte. Se prima del completamento del ciclo viene ricevuta una risposta, ha inizio la negoziazione dell'associazione di sicurezza standard. Se consentite dai criteri IPSec, dopo un breve periodo di tempo avranno inizio comunicazioni non protette, in cui viene utilizzato testo non crittografato. Anche in questo caso, i tentativi di negoziazione della comunicazione sicura verranno ripetuti ogni cinque minuti.

    Non esiste alcuna limitazione al numero di scambi che possono essere eseguiti, poiché il numero delle associazioni di sicurezza stabilite è limitato esclusivamente dalle risorse del sistema.

Associazione di sicurezza in modalità rapida

In questa fase, le associazioni di sicurezza vengono negoziate per conto del driver di sicurezza IP.

Nei passaggi seguenti viene descritta una negoziazione in modalità rapida.

  1. Viene eseguita la negoziazione dei criteri. I computer IPSec si scambiano i requisiti seguenti per la protezione del trasferimento di dati:

    • Protocollo IPSec (AH o ESP)

    • Algoritmo hash per l'integrità e l'autenticazione (MD5 o SHA1)

    • Algoritmo di crittografia, se necessario (DES o 3DES)

    Viene raggiunto un accordo comune e vengono stabilite due associazioni di sicurezza, una per le comunicazioni in ingresso e l'altra per le comunicazioni in uscita.

  2. Viene aggiornato o scambiato il materiale della chiave di sessione. IKE aggiorna il materiale per le chiavi e vengono generate nuove chiavi condivise per l'integrità, l'autenticazione e la crittografia dei pacchetti (se negoziate). Se è necessaria la reimpostazione delle chiavi, viene eseguito un secondo scambio DH come descritto per la negoziazione in modalità principale oppure viene aggiornata la chiave DH originale.

  3. Le associazioni di sicurezza e le chiavi vengono passate al driver di sicurezza IP insieme all'indice SPI. La negoziazione in modalità rapida delle impostazioni di sicurezza e del materiale per le chiavi, finalizzata alla protezione dei dati, è protetta dall'associazione di sicurezza in modalità principale. Mentre la prima fase assicura la protezione dell'identità, la seconda, in modalità rapida, assicura la protezione tramite l'aggiornamento del materiale per le chiavi prima dell'invio dei dati. IKE è in grado di gestire un payload di scambio chiave per un ulteriore scambio di DH se è necessaria una rigenerazione della chiave, ovvero la funzionalità PFS chiave master è attivata. In caso contrario, il protocollo IKE aggiorna il materiale per le chiavi dallo scambio DH eseguito in modalità principale.

    La modalità rapida crea una coppia di associazioni di sicurezza, ognuna delle quali dispone di un indice SPI e di una chiave. Un'associazione viene utilizzata per le comunicazioni in ingresso e l'altra per le comunicazioni in uscita.

    L'algoritmo di ripetizione dei tentativi per un messaggio è simile al processo illustrato per la negoziazione in modalità principale. Se tuttavia per un qualsiasi motivo si verifica un timeout durante la seconda negoziazione o una negoziazione successiva della stessa associazione di sicurezza in modalità principale, verrà tentata una rinegoziazione di quest'ultima. Gli eventuali messaggi ricevuti in questa fase senza un'associazione di sicurezza nella modalità principale definita verranno rifiutati.

    Se si utilizza una singola associazione di sicurezza in modalità principale per più negoziazioni di associazione di sicurezza in modalità rapida, il processo risulterà più veloce. Fino allo scadere dell'associazione di sicurezza in modalità principale, non sono necessarie rinegoziazioni e riautenticazioni. Il numero di negoziazioni dell'associazione di sicurezza in modalità rapida eseguibili è determinato dalle impostazioni dei criteri IPSec.

    Nota

    Una eccessiva reimpostazione delle chiavi dalla stessa associazione di sicurezza in modalità principale può rendere la chiave segreta condivisa più esposta a un attacco basato su testo normale noto. Questo tipo di attacco è un attacco tramite sniffer nel quale l'utente non autorizzato tenta di individuare la chiave di crittografia dai dati crittografati basandosi su testo noto.

Durata delle associazioni di sicurezza

L'associazione di sicurezza in modalità principale viene memorizzata nella cache per consentire più negoziazioni dell'associazione di sicurezza in modalità rapida, a meno che non sia attivata la funzionalità PFS chiave master. Alla scadenza della durata della chiave master o della chiave di sessione, l'associazione di sicurezza viene rinegoziata. La chiave viene inoltre aggiornata o rigenerata.

Allo scadere del timeout predefinito per l'associazione di sicurezza in modalità principale o della durata della chiave master o della chiave di sessione, al risponditore verrà inviato un messaggio di eliminazione. Il messaggio di eliminazione di IKE comunica al risponditore di far scadere l'associazione di sicurezza in modalità principale. In questo modo si evita che dall'associazione di sicurezza in modalità principale scaduta vengano create nuove associazioni di sicurezza in modalità rapida. Il protocollo IKE non fa scadere l'associazione di sicurezza in modalità rapida perché solo il driver IPSec contiene il numero dei secondi o dei byte che sono stati passati fino allo scadere della durata della chiave.

È necessario prestare particolare attenzione quando si imposta una durata nettamente diversa per le chiavi master e le chiavi di sessione. Se ad esempio si imposta una durata di otto ore per la chiave master in modalità principale e una durata di due ore per la chiave di sessione in modalità rapida, può accadere che un'associazione di sicurezza in modalità rapida rimanga attiva per quasi due ore dopo che l'associazione di sicurezza in modalità principale è già scaduta. Questo si verifica quando l'associazione di sicurezza in modalità rapida viene generata subito prima della scadenza dell'associazione di sicurezza in modalità principale.