Guide e Strumenti di migrazione per Windows Server

La documentazione e gli strumenti per la migrazione semplificano la migrazione di ruoli server, impostazioni del sistema operativo e dati da un server esistente che esegue Windows Server® 2003, Windows Server 2008 o Windows Server 2008 R2 a un computer che esegue Windows Server 2008 R2.

Utilizzando le guide relative alla migrazione a cui è collegato questo argomento, e dove appropriato Strumenti di migrazione per Windows Server, per eseguire la migrazione dei ruoli, è possibile semplificare la distribuzione di nuovi server (inclusi quelli che utilizzano l'opzione di installazione dei soli componenti di base del server di Windows Server 2008 R2, o Server Core, e i server virtuali), ridurre il tempo di inattività dovuto alla migrazione, aumentare l'accuratezza del processo di migrazione e facilitare l'eliminazione dei conflitti che potrebbero verificarsi durante il processo di migrazione.

La maggior parte della documentazione e degli strumenti per la migrazione presentati nel portale dedicato alla migrazione a Windows Server supporta migrazioni tra architetture diverse (da piattaforme di elaborazione basate su x86 a piattaforme di elaborazione basate su x64), migrazioni tra ambienti fisici e virtuali e migrazioni tra installazioni complete e Server Core del sistema operativo Windows Server, se disponibili.

Guida alla migrazione a Windows Server 2008 R2

Guide dettagliate sulla migrazione per ruoli del server supportati, funzionalità, impostazioni del sistema operativo e dati sono disponibili nel TechCenter di Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkID=128554).

Strumenti di migrazione per Windows Server

Strumenti di migrazione per Windows Server è una funzionalità disponibile per l'installazione nei computer che eseguono Windows Server 2008 R2 utilizzando l'Aggiunta guidata funzionalità in Server Manager. Per rimuovere Strumenti di migrazione per Windows Server da Windows Server 2008 R2, è possibile utilizzare la Rimozione guidata funzionalità.

Per eseguire la migrazione di ruoli, funzionalità e altri dati utilizzando Strumenti di migrazione per Windows Server, è inoltre necessario distribuire Strumenti di migrazione per Windows Server nei server di origine dai quali si desidera eseguire la migrazione dei dati. Strumenti di migrazione per Windows Server viene distribuito nei server di origine creando una cartella di distribuzione in un computer che esegue Windows Server 2008 R2, quindi copiandola nei sistemi operativi dei computer di origine in cui è presente una versione precedente a Windows Server 2008 R2 indicati nella tabella in questo argomento.

È necessario essere membri del gruppo Administrators nel computer in cui si desidera installare, registrare o utilizzare Strumenti di migrazione per Windows Server. Inoltre, se si esegue Strumenti di migrazione per Windows Server in server che eseguono Windows Server 2008 o Windows Server 2008 R2, è necessario eseguire Strumenti di migrazione per Windows Server con diritti utente elevati. A tale scopo, fare clic su Start, scegliere Strumenti di amministrazione, fare clic con il pulsante destro del mouse su Strumenti di migrazione per Windows Server e quindi scegliere Esegui come amministratore.

Istruzioni complete su installazione, configurazione e rimozione di Strumenti di migrazione per Windows Server sono disponibili nella guida dettagliata relativa a installazione, accesso e rimozione di Strumenti di migrazione per Windows Server (http://go.microsoft.com/fwlink/?LinkId=134763) nel sito Web TechCenter di Windows Server 2008 R2.

Sistemi operativi supportati

Nella tabella seguente sono indicati i sistemi operativi per i quali è supportata la migrazione tramite Strumenti di migrazione per Windows Server.

Processore del server di origine | Sistemi operativi dei server di origine | Sistemi operativi dei server di destinazione | Processore di destinazione
Basato su x86 o su x64 | Windows Server 2003 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x86 o su x64 | Windows Server 2003 R2 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x86 o su x64 | Windows Server 2008 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x64 | Windows Server 2008 R2 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x64 | Windows Server 2008 R2 Server Core | Windows Server 2008 R2 e Server Core | Basato su x64
Note
  • Per le edizioni Foundation, Standard, Enterprise e Datacenter di Windows Server è supportata sia l'opzione per l'installazione completa che quella per l'installazione Server Core, sia nei server di origine che di destinazione.
  • Sono supportate le migrazioni tra sistemi operativi fisici e sistemi operativi virtuali.
  • Non è supportata la migrazione da un server di origine a un server di destinazione che esegue un sistema operativo con una lingua dell'interfaccia utente (ovvero la lingua installata) diversa da quella del server di origine. Non è ad esempio possibile utilizzare Strumenti di migrazione per Windows Server per eseguire la migrazione di ruoli, impostazioni del sistema operativo o dati da un computer che esegue Windows Server 2008 con interfaccia utente del sistema in lingua francese a un computer che esegue Windows Server 2008 R2 con interfaccia utente del sistema in lingua tedesca.
  • La lingua dell'interfaccia utente del sistema è la lingua del pacchetto di installazione localizzato utilizzato per installare il sistema operativo Windows.
  • Per Windows Server 2003 e Windows Server 2008 sono supportate sia le migrazioni basate su x86 che quelle basate su x64. Tutte le edizioni di Windows Server 2008 R2 sono a 64 bit.
  • Non è possibile eseguire la migrazione dei ruoli nelle installazioni Server Core di Windows Server 2008 in quanto Windows Server 2008 Server Core non include .NET Framework.


Panoramica dei cmdlet per la migrazione

Strumenti di migrazione per Windows Server include cinque cmdlet di Windows PowerShell che consentono di eseguire la migrazione di alcuni ruoli server, funzionalità, impostazioni del sistema operativo, condivisioni e altri dati da computer che eseguono Windows Server 2003, Windows Server 2003 R2, Windows Server 2008 o Windows Server® 2008 R2 o in computer che eseguono Windows Server 2008 R2. In questo argomento vengono identificati e descritti i cmdlet di Windows PowerShell che fanno parte di Strumenti di migrazione per Windows Server.

Per un elenco completo dei sistemi operativi supportati da Strumenti di migrazione per Windows Server, vedere Guide e Strumenti di migrazione per Windows Server in questa Guida.

Windows PowerShell

I cmdlet (pronuncia command-lets) sono comandi incorporati inclusi in Windows PowerShell 2.0 che vengono installati per impostazione predefinita come parte di Windows Server 2008 R2. Per ulteriori informazioni su Windows PowerShell e sul funzionamento dei cmdlet, vedere la guida introduttiva a Windows PowerShell. Per aprire la guida introduttiva, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell 2.0, Documenti, aprire la cartella delle impostazioni locali e quindi fare doppio clic su GettingStarted.rtf.

Eseguire Windows PowerShell come amministratore

Sebbene i cmdlet di Strumenti di migrazione per Windows Server funzionino sui server che eseguono Windows Server 2008 R2, Windows Server 2003 o Windows Server 2008, dato che in Windows Server 2008 e Windows Server 2008 R2 è inclusa la funzionalità di sicurezza Controllo dell'account utente, è necessario eseguire Windows PowerShell con diritti utente elevati in tali sistemi operativi, anche se è già stato eseguito l'accesso al computer come amministratore.

  • Nei computer che eseguono Windows Server 2003, aprire una sessione di Windows PowerShell. A tale scopo fare clic sul pulsante Start, scegliere Tutti i programmi, Windows PowerShell e quindi fare clic sul collegamento Windows PowerShell.

  • Nei computer che eseguono Windows Server 2008 aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, aprire la cartella Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento Windows PowerShell e quindi scegliere Esegui come amministratore.

  • Nei computer che eseguono Windows Server 2008 R2 aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Windows PowerShell, fare clic con il pulsante destro del mouse su Windows PowerShell e quindi scegliere Esegui come amministratore.

Avviare Strumenti di migrazione per Windows Server

Per avviare Strumenti di migrazione per Windows Server è possibile utilizzare una delle due procedure seguenti.

Per avviare Strumenti di migrazione per Windows Server dal menu Start

  1. In un computer che esegue Windows Server 2008 R2 fare clic sul pulsante Start, scegliere Strumenti di amministrazione, fare clic con il pulsante destro del mouse su Strumenti di migrazione per Windows Server e quindi scegliere Esegui come amministratore.
Per avviare Strumenti di migrazione per Windows Server da una sessione di Windows PowerShell

  1. Effettuare una delle operazioni seguenti.

    • Nei computer che eseguono Windows Server 2003 aprire una sessione di Windows PowerShell. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, aprire la cartella Windows PowerShell e fare clic sul collegamento Windows PowerShell.

    • Nei computer che eseguono Windows Server 2008 aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, aprire la cartella Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento Windows PowerShell e quindi scegliere Esegui come amministratore.

    • Nei computer che eseguono Windows Server 2008 R2 aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, aprire la cartella Windows PowerShell, fare clic con il pulsante destro del mouse su Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Caricare Strumenti di migrazione per Windows Server nella sessione di Windows PowerShell aperta. Per caricare Strumenti di migrazione per Windows Server, digitare il comando seguente e quindi premere INVIO.

    Add-PSSnapin Microsoft.Windows.ServerManager.Migration

Cmdlet di Strumenti di migrazione per Windows Server

Nella tabella seguente sono descritti i cmdlet disponibili con Strumenti di migrazione per Windows Server. Dopo avere installato Strumenti di migrazione per Windows Server seguendo le istruzioni fornite nella guida dettagliata relativa a installazione, accesso e rimozione di Strumenti di migrazione per Windows Server (http://go.microsoft.com/fwlink/?LinkId=134763), è possibile ottenere specifiche indicazioni dettagliate su sintassi, parametri e utilizzo per i cmdlet di Strumenti di migrazione per Windows Server in qualsiasi momento. Per informazioni dettagliate, digitare Get-Help cmdlet_name -full in una sessione di Windows PowerShell, dove cmdlet_name rappresenta il nome del cmdlet di Strumenti di migrazione per Windows Server su cui si desidera ottenere informazioni..

Nome del cmdlet | Descrizione
Export-SmigServerSetting | Questo cmdlet consente di esportare determinate funzionalità di Windows e impostazioni del sistema operativo da computer che eseguono Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2 e le memorizza in un archivio delle migrazioni specificato dagli utenti nel parametro -Path. Eseguire il cmdlet Import-SmigServerSetting per importare funzionalità di Windows e impostazioni del sistema operativo in un computer di destinazione che esegue Windows Server 2008 R2 utilizzando l'archivio delle migrazioni popolato dal cmdlet Export-SmigServerSetting.
Import-SmigServerSetting | Questo cmdlet consente di importare determinate funzionalità di Windows e impostazioni del sistema operativo da un archivio delle migrazioni identificato nel parametro -Path e di applicarle nel computer locale. Se le funzionalità di Windows di cui si desidera eseguire la migrazione non sono installate, tali funzionalità e le relative dipendenze verranno installate automaticamente.
Get-SmigServerFeature | Questo cmdlet fornisce un elenco di tutte le funzionalità di Windows che possono essere esportate da un server o importate da un archivio delle migrazioni specificato nel parametro -Path.
Send-SmigServerData | Questo cmdlet consente di eseguire la migrazione di cartelle, file, autorizzazioni associate e proprietà di condivisione dal server locale a un server di destinazione. Send-SmigServerData deve essere eseguito sul server di origine nel momento in cui il cmdlet Receive-SmigServerData viene eseguito sul server di destinazione.
Receive-SmigServerData | Questo cmdlet consente a un server di destinazione di ricevere le condivisioni, le cartelle, i file e le autorizzazioni associate e le proprietà di condivisione di cui viene eseguita la migrazione da un server di origine. Receive-SmigServerData deve essere eseguito sul server di destinazione nel momento in cui il cmdlet Send-SmigServerData viene eseguito sul server di origine.


Risolvere i problemi relativi alla migrazione basata su cmdlet

Le informazioni contenute in questa sezione consentono di determinare se la migrazione tramite i cmdlet di Strumenti di migrazione per Windows Server ha avuto esito positivo o negativo. In caso di esito negativo, è possibile utilizzare le informazioni in questa sezione per identificare le cause degli errori.

Risolvere i problemi relativi alla migrazione

Il file di registro della distribuzione di Strumenti di migrazione per Windows Server è incluso in %windir%\Logs\SmigDeploy.log. Vengono inoltre creati file di registro aggiuntivi di Strumenti di migrazione per Windows Server nelle posizioni seguenti.

  • %windir%\Logs\ServerMigration.log

  • In Windows Server 2008 e Windows Server 2008 R2: %localappdata%\SvrMig\Log

  • In Windows Server 2003: %userprofile%\Impostazioni locali\Dati applicazioni\SvrMig\Log

Se non è possibile creare i file di registro della migrazione in queste posizioni, i file ServerMigration.log e SmigDeploy.log vengono creati in %temp%, mentre altri file di registro vengono creati in %windir%\System32.

Visualizzare il contenuto degli oggetti risultato di Strumenti di migrazione per Windows Server

Tutti i cmdlet di Strumenti di migrazione per Windows Server restituiscono i risultati come oggetti. È possibile salvare gli oggetti risultato ed eseguire query su di essi per ottenere ulteriori informazioni sulle impostazioni e i dati migrati. È inoltre possibile utilizzare gli oggetti risultato come input per altri comandi e script di Windows PowerShell.

Descrizioni degli oggetti risultato

I risultati restituiti dai cmdlet di Strumenti di migrazione per Windows Server Import-SmigServerSetting e Export-SmigServerSetting sono costituiti da un elenco di oggetti MigrationResult. Ogni oggetto MigrationResult contiene informazioni sui dati o le impostazioni elaborate dal cmdlet, il risultato dell'operazione e tutti i messaggi di errore o avviso correlati. Le proprietà di un oggetto MigrationResult sono illustrate nella tabella seguente.

Nome proprietà | Tipo | Definizione
ItemType | Enum | Tipo di elemento migrato. I valori supportati includono File, Folder, RegistryKey, Share e EncryptedFile.
ID | Stringa | ID dell'elemento migrato. I valori supportati includono ad esempio Local User, Local Group e DHCP.
Success | Booleano | Se la migrazione viene completata correttamente verrà visualizzato il valore True, in caso contrario verrà visualizzato il valore False.
DetailsList | Elenco <MigrationResultDetails> | Elenco di oggetti MigrationResultDetails.

I risultati restituiti dai cmdlet Send-SmigServerData e Receive-SmigServerData sono costituiti da un elenco di oggetti MigrationDataResult. Ogni oggetto MigrationDataResult contiene informazioni sui dati o le condivisioni elaborate dal cmdlet, il risultato dell'operazione e tutti i messaggi di errore o avviso e altre informazioni correlate. Le proprietà di un oggetto MigrationDataResult sono illustrate nella tabella seguente.

Nome proprietà | Tipo | Definizione
ItemType | Enum | Tipo di elemento migrato. I valori supportati includono File, Folder, Share e Encrypted File.
SourceLocation | Stringa | Percorso di origine dell'elemento, visualizzato come nome di percorso.
DestinationLocation | Stringa | Percorso di destinazione dell'elemento, visualizzato come nome di percorso.
Success | Booleano | Se la migrazione viene completata correttamente verrà visualizzato il valore True, in caso contrario verrà visualizzato il valore False.
Size | Intero | Dimensione dell'elemento in byte.
ErrorDetails | Elenco <MigrationResultDetails> | Un unico oggetto MigrationResultDetails.
Error | Enum | Enumerazione degli errori generati.
WarningMessageList | Elenco di oggetti <stringa> | Elenco di messaggi di avviso.

Nella tabella seguente sono illustrate le proprietà degli oggetti contenuti nell'oggetto MigrationResultDetails e disponibili anche per gli oggetti MigrationResult e MigrationDataResult.

Nome proprietà | Tipo | Definizione
Id | Stringa | Nome dell'impostazione di migrazione correlata all'elemento. I valori supportati includono ad esempio IPConfig e DNS. Per la migrazione dei dati questa proprietà è vuota.
Messages | Elenco di oggetti <stringa> | Elenco di messaggi di evento dettagliati.
DetailCode | Intero | Codice di errore o avviso associato a ogni messaggio di evento.
Severity | Enum | Gravità di un evento, se si è verificato un evento. I valori supportati includono ad esempio Information, Error e Warning.
Title | Stringa | Titolo dell'oggetto risultato. I valori supportati includono ad esempio l'indirizzo fisico della NIC per la configurazione IP o il nome utente per la migrazione dell'utente locale.

Esempi

Negli esempi seguenti viene illustrato come archiviare l'elenco degli oggetti risultato in una variabile e quindi utilizzare tale variabile in una query per restituire il contenuto degli oggetti risultato al termine della migrazione.

Per archiviare un elenco di oggetti risultato come variabile per le query

  1. Per eseguire un cmdlet e salvare il risultato in una variabile, digitare un comando nel formato seguente e quindi premere INVIO.

    $VariableName = $(Cmdlet)

    Di seguito viene riportato un esempio.

    $ImportResult = $(Import-SmigServerSetting -FeatureId DHCP -User all -Group -Path D:\rmt\DemoStore -force –Verbose)

    Questo comando esegue il cmdlet con numerosi parametri Import-SmigServerSetting e quindi salva gli oggetti risultato nella variabile ImportResult.

  2. Dopo il completamento delle operazioni del cmdlet Import-SmigServerSetting, per restituire le informazioni contenute nell'oggetto risultato digitare un comando nel formato seguente e quindi premere INVIO.

    $VariableName

    Nell'esempio seguente la variabile è denominata ImportResult.

    $ImportResult

    Questo comando restituisce informazioni contenute negli oggetti risultato restituiti da Import-SmigServerSetting nell'esempio illustrato nel passaggio 1. Di seguito viene riportato un esempio dell'output visualizzato quando si chiama la variabile ImportResult.

               ItemType  ID                              Success  DetailsList
           --------  --                              -------  -----------
          OSSetting  Local User                         True  {Local User, Loc...
          OSSetting  Local Group                        True  {Local Group, Lo...
     WindowsFeature  DHCP                               True  {}

    Ogni riga dell'esempio precedente è un risultato della migrazione di un elemento migrato tramite il cmdlet Import-SmigServerSetting. I nomi delle intestazioni di colonna sono proprietà degli oggetti MigrationResult. È possibile incorporare tali proprietà in un altro comando per restituire informazioni più dettagliate sugli oggetti risultato, come illustrato negli esempi riportati nel passaggio 3 e successivi.

  3. Per visualizzare una proprietà specifica per tutti gli oggetti risultato nell'elenco, digitare un comando nel formato seguente e quindi premere INVIO.

    $<NomeVariabile>| Select-Object -ExpandProperty <NomeProprietà>

    Di seguito viene riportato un esempio.

    $importResult | Select-Object -ExpandProperty DetailsList

  4. È possibile eseguire query più avanzate per analizzare gli oggetti risultato utilizzando i cmdlet di Windows PowerShell. Di seguito vengono riportati alcuni esempi.

    • Il comando seguente restituisce solo i dettagli relativi agli oggetti risultato con ID Local User.

      $ImportResult | Where-Object { $_.ID -eq "Local User" } | Select-Object -ExpandProperty DetailsList
    • Il comando seguente restituisce solo i dettagli relativi agli oggetti risultato con ID Local User e livello di gravità del messaggio Warning.

      $ImportResult | Where-Object { $_.ID -eq "Local User" } | Select-Object -ExpandProperty DetailsList | ForEach-Object { if ($_.Severity -eq "Warning") {$_} }
    • Il comando seguente restituisce solo i dettagli relativi agli oggetti risultato con ID Local User e titolo Remote Desktop Users.

      $ImportResult | Where-Object { $_.ID -eq "Local Group" } | Select-Object -ExpandProperty DetailsList | ForEach-Object { if ($_.Title -eq "Remote Desktop Users") {$_} }

Ulteriori informazioni sull'esecuzione di query sui risultati

Per ulteriori informazioni sui cmdlet utilizzati negli esempi precedenti, vedere le risorse aggiuntive seguenti.

  • Where-Object nell'area dedicata agli script sul sito Web Microsoft TechNet (http://go.microsoft.com/fwlink/?LinkId=134853).

  • Select-Object nell'area dedicata agli script sul sito Web Microsoft TechNet (http://go.microsoft.com/fwlink/?LinkId=134858).

  • ForEach-Object nell'area dedicata agli script sul sito Web Microsoft TechNet (http://go.microsoft.com/fwlink/?LinkId=134860).

Per ulteriori informazioni sulle tecniche di script di Windows PowerShell, vedere l'articolo relativo alle tecniche di script di Windows PowerShell nell'area dedicata agli script sul sito Web Microsoft TechNet (http://go.microsoft.com/fwlink/?LinkId=134862).