Scheda Avanzate

Utilizzare la scheda Avanzate per visualizzare e impostare proprietà di inizializzazione aggiuntive per i dati.

La scheda Avanzate della finestra di dialogo Proprietà di Data Link è specifica del provider e consente di visualizzare solo le proprietà di inizializzazione richieste dal provider OLE DB selezionato. Per ulteriori informazioni sulle proprietà di inizializzazione avanzate, vedere la documentazione fornita con ogni provider OLE DB specifico.

Nella tabella seguente viene descritta la maggior parte delle opzioni di inizializzazione.

Opzione Descrizione

Livello di rappresentazione

Livello di rappresentazione che il server è autorizzato a utilizzare quando rappresenta il client. La proprietà si applica solo alle connessioni di rete diverse dalle connessioni RPC (Remote Procedure Call); questi livelli di rappresentazione sono simili a quelli delle connessioni RPC. I valori di questa proprietà corrispondono direttamente ai livelli di rappresentazione specificabili per le connessioni RPC autenticate, ma possono essere applicati a connessioni diverse. È possibile eseguire la selezione tra i livelli seguenti:

  • Anonimo: il client è anonimo al server. Il processo del server non è in grado di ottenere informazioni di identificazione sul client e non può rappresentare il client.

  • Delega: il processo può rappresentare il contesto di sicurezza del client mentre agisce per suo conto. Il processo del server può inoltre eseguire chiamate in uscita verso altri server mentre agisce per conto del client.

  • Identifica: il server è in grado di ottenere l'identità del client. Il server può rappresentare il client per il controllo ACL (Access Control List, elenco di controllo di accesso), ma non può accedere agli oggetti di sistema come il client.

  • Rappresenta: il processo del server può rappresentare il contesto di sicurezza del client mentre agisce per suo conto. Queste informazioni vengono ottenute quando viene stabilita la connessione, non a ogni chiamata.

Livello di protezione

Livello di protezione dei dati inviati tra client e server. La proprietà si applica solo alle connessioni di rete diverse dalle connessioni RPC; questi livelli di protezione sono simili a quelli delle connessioni RPC. I valori di questa proprietà corrispondono direttamente ai livelli di protezione specificabili per le connessioni RPC autenticate, ma possono essere applicati a connessioni diverse. È possibile eseguire la selezione tra i livelli seguenti:

  • Chiamata: autentica l'origine dei dati all'inizio di ogni richiesta client al server.

  • Connessione: effettua l'autenticazione solo quando il client stabilisce la connessione con il server.

  • Nessuna: non effettua alcuna autenticazione dei dati inviati al server.

  • .Pacchetto: autentica che tutti i dati ricevuti provengono dal client.

  • Integrità pacchetto: autentica che tutti i dati ricevuti provengono dal client e che non sono stati modificati durante il transito.

  • Privacy pacchetto: autentica che tutti i dati ricevuti provengono dal client e che non sono stati modificati durante il transito; protegge, inoltre, la privacy dei dati mediante crittografia.

Timeout di connessione

Specifica il numero di secondi di attesa del provider OLE DB per il completamento dell'inizializzazione. In caso di timeout dell'inizializzazione, viene restituito un errore e la connessione non viene creata.

Autorizzazioni di accesso

Selezionare una o più delle autorizzazioni seguenti:

  • Lettura: sola lettura.

  • Lettura/Scrittura: lettura e scrittura.

  • Condividi senza negare: impossibile negare ad altri utenti l'accesso in lettura e in scrittura.

  • Condividi senza lettura: impedisce ad altri utenti l'apertura in modalità di lettura.

  • Condividi senza scrittura: impedisce ad altri utenti l'apertura in modalità di scrittura.

  • Condividi esclusivo: impedisce ad altri utenti l'apertura in modalità di lettura e scrittura.

  • Scrittura: sola scrittura.

Osservazioni

Nota:
Per ulteriori informazioni sull'inizializzazione di Data Link, vedere Data Link API Overview in MSDN.


Scheda Tutte le proprietà

Utilizzare la scheda Tutte le proprietà per visualizzare e modificare tutte le proprietà di inizializzazione OLE DB disponibili per il provider OLE DB. Le proprietà possono variare a seconda del provider OLE DB utilizzato. Per ulteriori informazioni sulle proprietà di inizializzazione, fare riferimento alla documentazione fornita con ogni provider OLE DB specifico.

Opzione | Descrizione
Modifica valore | Apre la finestra di dialogo Modifica valore proprietà per la proprietà selezionata.

Osservazioni

Nota:
È possibile aprire la finestra di dialogo Modifica valore proprietà facendo doppio clic sulla proprietà desiderata. Per ulteriori informazioni sull'inizializzazione di Data Link, vedere Data Link API Overview in MSDN.


Scheda Connessione

Utilizzare la scheda Connessione per specificare come connettersi ai dati utilizzando un provider OLE DB.

La scheda Connessione della finestra di dialogo Proprietà di Data Link è specifica del provider e consente di visualizzare solo le proprietà di connessione richieste dal provider OLE DB selezionato. Le proprietà di connessione consentono di specificare la posizione dei dati e la modalità di connessione agli stessi. Per ulteriori informazioni, fare riferimento alla documentazione relativa a ogni provider OLE DB specifico.

Nella tabella seguente viene descritta la maggior parte delle opzioni di connessione.

Opzione Descrizione

Origine dati

Digitare il nome dell'origine dati cui si desidera accedere, in genere il nome di un server.

Percorso

Digitare il percorso dell'origine dati cui si desidera accedere, in genere il nome di un database.

Utilizza sicurezza integrata di Windows NT

Selezionare per utilizzare un servizio di autenticazione per la propria identificazione.

Per utilizzare questa funzionalità, è necessario che il provider OLE DB supporti un servizio di autenticazione. Un esempio è il provider OLE DB per SQL Server. È inoltre necessario disporre delle autorizzazioni per l'utilizzo del servizio di autenticazione nell'origine dati.

Utilizza password e nome utente specifici

Selezionare per utilizzare un nome utente e una password specifici per autenticare le informazioni di accesso per l'origine dati.

Nome utente

Digitare l'ID utente da utilizzare per l'autenticazione quando si accede all'origine dati.

Password

Digitare la password da utilizzare per l'autenticazione quando si accede all'origine dati.

Nessuna password

Consente al provider specificato di non restituire alcuna password nella stringa di connessione.

Consenti salvataggio password

Consente che la password venga salvata con la stringa di connessione. L'eventuale inclusione della password nella stringa di connessione dipende dalle funzionalità dell'applicazione chiamante.

Nota:
Se salvata, la password viene restituita e salvata non mascherata e non crittografata.

Inserire il catalogo iniziale da utilizzare

Digitare il catalogo cui si desidera accedere durante la connessione.

Verifica connessione

Fare clic per tentare una connessione all'origine dati specificata. Se la connessione non riesce, verificare che le impostazioni siano corrette. Ad esempio, è possibile che le connessioni non vengano eseguite correttamente se sono presenti errori ortografici o non viene rispettata la distinzione tra maiuscole e minuscole.

Osservazioni

Nota:
Per ulteriori informazioni sulla connessione di Data Link, vedere Data Link API Overview in MSDN.


Scheda Connessione per Jet

Utilizzare la scheda Connessione per specificare come connettersi ai dati di Microsoft Access.

Nella scheda Connessione, specifica del provider, vengono visualizzate solo le proprietà di connessione richieste dal provider OLE DB per Microsoft Jet.

Opzione Descrizione

Nome database

Digitare il nome file del database di Microsoft Access (.mdb) cui si desidera accedere.

Nome utente

Digitare l'ID utente da utilizzare per l'autenticazione quando si accede all'origine dati.

Password

Digitare la password da utilizzare per l'autenticazione quando si accede all'origine dati.

Nessuna password

Consente al provider specificato di non restituire alcuna password nella stringa di connessione.

Consenti salvataggio password

Consente che la password venga salvata con la stringa di connessione. L'eventuale inclusione della password nella stringa di connessione dipende dalle funzionalità dell'applicazione chiamante.

Nota:
Se salvata, la password viene restituita e salvata non mascherata e non crittografata.

Verifica connessione

Fare clic per tentare una connessione all'origine dati specificata. Se la connessione non riesce, verificare che le impostazioni siano corrette. Ad esempio, è possibile che le connessioni non vengano eseguite correttamente se sono presenti errori ortografici o non viene rispettata la distinzione tra maiuscole e minuscole.

Osservazioni

Nota:
Per ulteriori informazioni sulla connessione di Data Link, vedere Data Link API Overview in MSDN.


Scheda Connessione per ODBC

Utilizzare la scheda Connessione per specificare come effettuare la connessione a dati ODBC.

Nella scheda Connessione, specifica del provider, vengono visualizzate solo le proprietà di connessione richieste dal provider Microsoft OLE DB per ODBC.

Opzione Descrizione

Utilizza nome origine dati

Consente di selezionare dall'elenco o digitare il nome dell'origine dati ODBC (DSN) cui si desidera accedere. È possibile aggiungere altre origini tramite Amministrazione origine dati ODBC. Aggiornare l'elenco facendo clic su Aggiorna.

Utilizza stringa di connessione

Consente di digitare o generare una stringa di connessione ODBC invece di utilizzare un DSN esistente.

Genera

Consente di visualizzare la finestra di dialogo Selezione origine dati. Dopo aver selezionato un'origine dati, la stringa di connessione nell'origine dati verrà visualizzata nella scheda Connessione della finestra di dialogo Proprietà di Data Link.

Se si seleziona un DSN su file, la stringa di connessione ODBC risultante non sarà basata su un DSN. La stringa di connessione ODBC viene definita come permanente nel file di collegamento dati (.udl) e non si basa sul DSN su file selezionato.

Se si seleziona un nome dell'origine dati per un computer, la stringa di connessione ODBC risultante sarà basata su un DSN. La stringa di connessione ODBC fa riferimento al DSN sul computer selezionato. Per accedere al file di collegamento dati (.udl), un utente di un sistema diverso deve disporre anche del DSN su computer installato.

Nome utente

Digitare l'ID utente da utilizzare per l'autenticazione quando si accede all'origine dati.

Password

Digitare la password da utilizzare per l'autenticazione quando si accede all'origine dati.

Nessuna password

Consente al provider specificato di non restituire alcuna password nella stringa di connessione.

Consenti salvataggio password

Consente che la password venga salvata con la stringa di connessione. L'eventuale inclusione della password nella stringa di connessione dipende dalle funzionalità dell'applicazione chiamante.

Nota:
Se salvata, la password viene restituita e salvata non mascherata e non crittografata.

Inserire il catalogo iniziale da utilizzare

Digitare il nome del catalogo o del database oppure selezionare una voce dall'elenco a discesa.

Verifica connessione

Fare clic per tentare una connessione all'origine dati specificata. Se la connessione non riesce, verificare che le impostazioni siano corrette. Ad esempio, è possibile che le connessioni non vengano eseguite correttamente se sono presenti errori ortografici o non viene rispettata la distinzione tra maiuscole e minuscole.

Osservazioni

Nota:
Per ulteriori informazioni sulla connessione di Data Link, vedere Data Link API Overview in MSDN.


Scheda Connessione per Oracle

Utilizzare la scheda Connessione per specificare come effettuare la connessione ai dati Oracle.

Nella scheda Connessione, specifica del provider, vengono visualizzate solo le proprietà di connessione richieste dal provider Microsoft OLE DB per Oracle.

Opzione Descrizione

Nome server

Digitare il server in cui si trova il database cui si desidera accedere.

Nome utente

Digitare l'ID utente da utilizzare per l'autenticazione quando si accede all'origine dati.

Password

Digitare la password da utilizzare per l'autenticazione quando si accede all'origine dati.

Nessuna password

Consente al provider specificato di non restituire alcuna password nella stringa di connessione.

Consenti salvataggio password

Consente che la password venga salvata con la stringa di connessione. L'eventuale inclusione della password nella stringa di connessione dipende dalle funzionalità dell'applicazione chiamante.

Nota:
Se salvata, la password viene restituita e salvata non mascherata e non crittografata.

Verifica connessione

Fare clic per tentare una connessione all'origine dati specificata. Se la connessione non riesce, verificare che le impostazioni siano corrette. Ad esempio, è possibile che le connessioni non vengano eseguite correttamente se sono presenti errori ortografici o non viene rispettata la distinzione tra maiuscole e minuscole.

Osservazioni

Nota:
Per ulteriori informazioni sulla connessione di Data Link, vedere Data Link API Overview in MSDN.


Scheda Connessione per SQL Server

Utilizzare la scheda Connessione per specificare come connettersi ai dati di Microsoft® SQL Server®.

Nella scheda Connessione, specifica del provider, vengono visualizzate solo le proprietà di connessione richieste dal provider OLE DB per Microsoft SQL Server.

Opzione Descrizione

Nome server

Selezionare un nome di server dall'elenco a discesa oppure digitare il percorso del server in cui si trova il database cui si desidera accedere. La selezione del database nel server è un'azione distinta. Aggiornare l'elenco facendo clic su Aggiorna.

Utilizza sicurezza integrata di Windows NT

Selezionare per specificare che il provider richiede una connessione protetta (o trusted) a un'istanza di SQL Server in esecuzione su Microsoft Windows NT. Se si seleziona questa opzione, in SQL Server verrà utilizzata la sicurezza di account di accesso integrata per stabilire connessioni con questa origine dati, indipendentemente dalla modalità di sicurezza degli accessi corrente nel server. Qualsiasi password o ID di accesso specificato viene ignorato. L'amministratore di sistema di SQL Server deve associare l'ID di rete di Microsoft Windows a un ID di accesso di SQL Server.

Utilizza password e nome utente specifici

Selezionare per utilizzare un nome utente e una password specifici per autenticare le informazioni di accesso per l'origine dati.

Nome utente

Digitare l'ID utente da utilizzare per l'autenticazione quando si accede all'origine dati.

Password

Digitare la password da utilizzare per l'autenticazione quando si accede all'origine dati.

Nessuna password

Consente al provider specificato di non restituire alcuna password nella stringa di connessione.

Consenti salvataggio password

Consente che la password venga salvata con la stringa di connessione. L'eventuale inclusione della password nella stringa di connessione dipende dalle funzionalità dell'applicazione chiamante.

Nota:
Se salvata, la password viene restituita e salvata non mascherata e non crittografata.

Selezione database

Utilizzare uno dei metodi seguenti:

  • Digitare il nome del database cui si desidera accedere.

  • Associare un file di database SQL come nome del database. Digitare il nome del database da utilizzare per il file del database SQL associato.

  • Per SQL Server 6.5 e versioni precedenti, digitare il nome file del database da associare. Digitare, quindi, il nome del file di database a file singolo. Per cercare il file, fare clic sul pulsante.

Verifica connessione

Fare clic per tentare una connessione all'origine dati specificata. Se la connessione non riesce, verificare che le impostazioni siano corrette. Ad esempio, è possibile che le connessioni non vengano eseguite correttamente se sono presenti errori ortografici o non viene rispettata la distinzione tra maiuscole e minuscole.

Osservazioni

Nota:
Per ulteriori informazioni sulla connessione di Data Link, vedere Data Link API Overview in MSDN.


Finestra di dialogo Modifica valore proprietà

Utilizzare la finestra di dialogo Modifica valore proprietà per modificare la proprietà di inizializzazione OLE DB attualmente selezionata nella scheda Tutte le proprietà. Le proprietà possono variare a seconda del provider OLE DB.

Nota:
Per ulteriori informazioni sulle proprietà specifiche del provider, vedere la documentazione fornita con ogni provider OLE DB specifico.

Opzione | Descrizione
Descrizione proprietà | Visualizza la descrizione della proprietà selezionata.
Valore proprietà | Consente di selezionare un valore valido.
Reimposta valore | Imposta il valore della proprietà selezionata sul valore predefinito del provider OLE DB.


Scheda Provider

Utilizzare la scheda Provider per selezionare il provider OLE DB adatto per il tipo di dati cui si desidera accedere. Non tutte le applicazioni consentono di specificare un provider oppure di modificare la selezione corrente; questa scheda viene visualizzata solo se l'applicazione consente di modificare la selezione del provider OLE DB. È possibile salvare un collegamento dati con l'applicazione stessa o come file separato.

Opzione | Descrizione
Provider OLE DB | Elenca tutti i provider OLE DB rilevati nel computer. Per ulteriori informazioni sui provider, vedere Microsoft OLE DB Providers Overview in MSDN.
Avanti | Apre la scheda Connessione per il provider OLE DB selezionato.

Osservazioni

Nota:
È possibile passare direttamente alla scheda Connessione facendo doppio clic sul provider desiderato. Per ulteriori informazioni sui collegamenti dati, vedere Data Link API Overview in MSDN.


Copyright e informazioni legali

Le informazioni contenute nel presente documento, inclusi URL e altri riferimenti a siti Web, sono soggette a modifiche senza preavviso. Se non specificato diversamente, ogni riferimento a società, organizzazioni, prodotti, nomi di dominio, indirizzi di posta elettronica, logo, persone, luoghi ed eventi utilizzati negli esempi è puramente casuale e ha il solo scopo di illustrare l'uso del prodotto Microsoft. Nessuna associazione con nessuna società, organizzazione, prodotto, nome di dominio, indirizzo di posta elettronica, logo, persona, luogo o evento è intenzionale o può essere presupposta. Il rispetto di tutte le leggi applicabili in materia di copyright è esclusivamente a carico dell'utente. Fermi restando tutti i diritti coperti da copyright, nessuna parte del presente documento potrà comunque essere riprodotta, archiviata o inserita in un sistema di riproduzione o trasmessa in qualsiasi forma e con qualsiasi mezzo (in formato elettronico, meccanico, fotocopia, tramite registrazione o altro) per qualsiasi scopo, senza il permesso scritto di Microsoft Corporation.

Microsoft può essere titolare di brevetti, domande di brevetto, marchi, copyright o altri diritti di proprietà intellettuale relativi all'oggetto del presente documento. Salvo quanto espressamente previsto in un contratto scritto di licenza Microsoft, la consegna del presente documento non implica la concessione di alcuna licenza su tali brevetti, marchi, copyright o altra proprietà intellettuale.

© 2009 Microsoft Corporation. Tutti i diritti riservati.

Microsoft, Active Directory, ActiveX, JScript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SQL Server, Visual Basic, Visual C++, Visual Studio, Win32, Windows e Windows NT sono marchi di Microsoft Corporation.

Altri nomi di prodotti e società citati nel presente documento possono essere marchi dei rispettivi proprietari.