Amministrare Client per NFS

Client per NFS consente ai computer Windows di accedere ai file presenti nei server NFS (Network File System) basati su UNIX.

  • Informazioni sul componente Client per NFS

  • Procedure consigliate relative a Client per NFS

  • Utilizzare Client per NFS

  • Configurare Client per NFS

  • Risolvere i problemi relativi a Client per NFS


Informazioni sul componente Client per NFS

Client per NFS consente a un computer Windows di operare come client di un server NFS (Network File System). Con Client per NFS è possibile accedere ai file in un ambiente misto di computer, sistemi operativi e reti.

L'accesso ai file su server NFS richiede inoltre a ogni utente Windows di disporre di identità di tipo UNIX. Per consentire agli utenti di accedere alle risorse condivise NFS utilizzando Client per NFS, è possibile includere gli attributi relativi alle identità di tipo UNIX in Active Directory.

I controller di dominio Windows Server 2003 R2 includono gli attributi relativi alle identità di tipo UNIX appropriati contenuti nelle specifiche RFC (Request for Comments) 2307 di Internet Engineering Task Force (IETF) nello schema di Active Directory. Visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70027. I controller di dominio includono inoltre il componente aggiuntivo Identity Management for UNIX, che semplifica la gestione delle identità di tipo UNIX in Active Directory.

Oltre a recuperare i dati relativi alle identità di tipo UNIX da Active Directory, Client per NFS è anche in grado di recuperare i dati relativi alle identità di tipo UNIX da un server Mapping nomi utente. Mapping nomi utente è un componente facoltativo di Windows Server 2003 R2, Server Appliance Kit e Services for UNIX e potrebbe già essere disponibile nella rete in uso. Non è consigliabile utilizzare Mapping nomi utente per nuove distribuzioni di Client per NFS.

Dopo aver installato e configurato Client per NFS, per accedere ai file disponibili nel server NFS è possibile montarli nel proprio computer utilizzando il formato UNIX server:/esportazione o il formato Windows \\server\condivisione. È inoltre possibile esplorare le cartelle condivise utilizzando il formato \\server\condivisione in Esplora risorse.

Ulteriori riferimenti

Amministrare Client per NFS


Procedure consigliate relative a Client per NFS

Utilizzare il prompt dei comandi corretto.

Se si esegue Client per NFS e si utilizza il prompt dei comandi, utilizzare la versione a 32 bit (Cmd.exe) disponibile dal menu Start. Non utilizzare la versione a 16 bit (Command.com). Per modificare le impostazioni di configurazione di Client per NFS, è necessario eseguire Nfsadmin.exe da una finestra del prompt dei comandi con privilegi elevati.

Evitare di utilizzare hard mount.

Indipendentemente dal tipo di montaggio, Client per NFS non tenterà di eseguire all'infinito il montaggio di una risorsa NFS condivisa. Al termine del montaggio della risorsa condivisa, se il montaggio è di tipo hard mount e il server NFS (Network File System) non è disponibile, Client per NFS continuerà a tentare l'accesso alla risorsa condivisa fino a quando il server NFS non sarà di nuovo disponibile. Di conseguenza, le applicazioni Windows che tentano di accedere alla risorsa condivisa sembreranno bloccate.

Nota

Il comando umount consentirà di disconnettere un hard mount, anche se il server non è disponibile.

Ulteriori riferimenti

Amministrare Client per NFS


Utilizzare Client per NFS

  • Avviare Client per NFS

  • Arrestare Client per NFS

  • Montare una risorsa condivisa NFS su una lettera di unità

  • Smontare una risorsa condivisa NFS da una lettera di unità

  • Configurare le autorizzazioni NFS per un file o una cartella

  • Visualizzare le opzioni di montaggio e le proprietà NFS

  • Visualizzare le proprietà del server NFS

Ulteriori riferimenti

Amministrare Client per NFS


Avviare Client per NFS

Per avviare Client per NFS dall'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, quindi Strumenti di amministrazione e infine Servizi per NFS (Network File System).

  2. Se necessario, stabilire una connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Client per NFS e quindi scegliere Avvia servizio.

Per avviare Client per NFS dalla riga di comando

  1. Aprire una finestra del prompt dei comandi con privilegi elevati.

  2. Al prompt dei comandi digitare:

    nfsadmin client [NomeComputer] start

    Argomento Descrizione

    NomeComputer

    Nome del computer in cui si desidera avviare il servizio Client per NFS.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin client /?

Ulteriori riferimenti

Utilizzare Client per NFS


Arrestare Client per NFS

Per arrestare Client per NFS dall'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, quindi Strumenti di amministrazione e infine Servizi per NFS (Network File System).

  2. Se necessario, stabilire una connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Client per NFS e quindi scegliere Interrompi.

Per arrestare Client per NFS dalla riga di comando

  1. Aprire il prompt dei comandi con privilegi elevati.

  2. Al prompt dei comandi digitare:

    nfsadmin client [NomeComputer] stop

    Argomento Descrizione

    NomeComputer

    Nome del computer nel quale si desidera arrestare Client per NFS.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin client /?

Ulteriori riferimenti

Utilizzare Client per NFS


Montare una risorsa condivisa NFS su una lettera di unità

Per montare una risorsa condivisa NFS su una lettera di unità tramite la riga di comando

  1. Aprire una finestra del prompt dei comandi (non necessariamente con privilegi elevati).

  2. Al prompt dei comandi digitare quanto segue:

    mount [–o Opzioni] NomeComputer:\NomeCondivisione {NomeDispositivo | *}

    oppure

    mount [–o Opzioni] \\NomeComputer\NomeCondivisione {NomeDispositivo | *}

    Argomento Descrizione

    -o rsize=n

    Dimensione del buffer di lettura, in kilobyte. I valori accettabili sono 1, 2, 4, 8, 16 e 32. Il valore predefinito è 32 KB.

    -o wsize=n

    Dimensione del buffer di scrittura, in kilobyte. I valori accettabili sono 1, 2, 4, 8, 16 e 32. Il valore predefinito è 32 KB.

    -o timeout=n

    Timeout per una chiamata di procedura remota (RPC, Remote Procedure Call), in secondi. I valori accettabili sono 0,8, 0,9 e qualsiasi numero intero compreso tra 1 e 60. Il valore predefinito è 0,8.

    -o retry=n

    Numero di tentativi di esecuzione di un soft mount. I valori accettabili sono i numeri interi compresi tra 1 e 10. Il valore predefinito è 1.

    -o mtype={soft | hard}

    Soft mount o hard mount. Indipendentemente dal tipo di montaggio, l'operazione di montaggio avrà esito negativo se non è possibile montare immediatamente la risorsa condivisa. Se tuttavia al termine del montaggio della risorsa condivisa il montaggio è di tipo hard mount e il server NFS (Network File System) non è disponibile, Client per NFS tenterà nuovamente l'accesso alla risorsa condivisa fino a quando il server NFS non sarà di nuovo disponibile. Di conseguenza, le applicazioni Windows che tentano di accedere alla risorsa condivisa sembreranno bloccate.

    -o anon

    Il montaggio viene eseguito come utente anonimo.

    -o nolock

    Disattiva il blocco. Questa opzione consente di migliorare le prestazioni se è necessario solo leggere i file.

    -o lang={euc-jp | euc-tw | euc-kr | shift-jis | big5 | ksc5601 | gb2312-80 | ansi}

    Specifica la codifica predefinita utilizzata per i nomi di file e directory. Se utilizzata, questa opzione deve essere impostata su uno dei valori seguenti:

    • ansi

    • big5 (cinese)

    • euc-jp (giapponese)

    • euc-kr (coreano)

    • euc-tw (cinese)

    • gb2312-80 (cinese semplificato)

    • ksc5601 (coreano)

    • shift-jis (giapponese)

    Se questa opzione viene impostata su ANSI nei sistemi configurati per impostazioni locali non inglesi, lo schema di codifica verrà impostato sullo schema di codifica predefinito delle impostazioni locali. Gli schemi di codifica predefiniti per le impostazioni locali indicate sono i seguenti:

    Giapponese: SHIFT-JIS

    Coreano: KS_C_5601-1987

    Cinese semplificato: GB2312-80

    Cinese tradizionale: BIG5

    -o fileaccess=modalità

    Specifica la modalità di autorizzazione predefinita dei nuovi file creati nella risorsa condivisa NFS. La modalità di autorizzazione deve essere specificata con un numero di tre cifre nel formato pgt, dove p, g e t rappresentano l'accesso concesso rispettivamente al proprietario, al gruppo e a tutti. Ogni numero deve essere compreso tra 0 e 7, con i valori che corrispondono ai livelli di accesso seguenti:

    • 0: nessun accesso

    • 1: x (accesso in esecuzione)

    • 2: w (accesso in scrittura)

    • 3: wx (accesso in scrittura ed esecuzione)

    • 4: r (accesso in lettura)

    • 5: rx (accesso in lettura ed esecuzione)

    • 6: rw (acceso in lettura e scrittura)

    • 7: rwx (accesso in lettura, scrittura ed esecuzione)

    -o casesensitive

    Impone la ricerca dei file con distinzione tra maiuscole e minuscole, simile alla ricerca dei client NFS basati su UNIX.

    NomeComputer

    Nome del server con la risorsa condivisa da montare.

    NomeCondivisione

    Nome della directory condivisa da montare.

    NomeDispositivo | *

    Lettera di unità da assegnare alla risorsa condivisa montata. L'asterisco (*) indica di utilizzare la successiva lettera disponibile.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: mount /?
    • Quando una risorsa condivisa NFS viene montata su una lettera di unità, è consigliabile utilizzare il formato NomeComputer:/ NomeCondivisione.
    • Per montare una risorsa condivisa NFS su una lettera di unità, è inoltre possibile utilizzare il comando net use. Per ulteriori informazioni sull'utilizzo del comando net use, vedere la Guida di Windows oppure al prompt dei comandi digitare net use /?

Ulteriori riferimenti

Utilizzare Client per NFS


Smontare una risorsa condivisa NFS da una lettera di unità

Per smontare una risorsa condivisa NFS da una lettera di unità tramite la riga di comando

  1. Aprire una finestra del prompt dei comandi (non necessariamente con privilegi elevati).

  2. Al prompt dei comandi digitare:

    umount [-f] {-a | Unità}

    Argomento Descrizione

    -f

    Forza lo smontaggio di un'unità di rete NFS (Network File System).

    -a

    Smonta tutte le unità di rete NFS.

    Unità

    Lettera di unità mappata a una risorsa condivisa NFS.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: umount /?

Ulteriori riferimenti

Utilizzare Client per NFS


Configurare le autorizzazioni NFS per un file o una cartella

Per configurare le autorizzazioni NFS tramite Esplora risorse

  1. Aprire Esplora risorse. A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, Accessori e quindi Esplora risorse.

  2. Fare clic con il pulsante destro del mouse sul nome del file o della directory.

  3. Scegliere Proprietà e quindi fare clic sulla scheda Attributi NFS.

  4. In Autorizzazioni file (modalità) selezionare o deselezionare le caselle di controllo corrispondenti ai bit di modalità che si desidera utilizzare, fare clic su Applica e quindi su OK. Per chiudere la finestra di dialogo senza apportare modifiche, fare clic su Annulla.

    Note
    • Solo il proprietario di un file o un utente con le autorizzazioni appropriate può cambiare la modalità di un file.
    • Questa procedura non può essere eseguita dalla riga di comando.

Ulteriori riferimenti

Utilizzare Client per NFS


Visualizzare le opzioni di montaggio e le proprietà NFS

Per visualizzare le opzioni di montaggio NFS tramite Esplora risorse

  1. Aprire Esplora risorse. A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, Accessori e quindi Esplora risorse.

  2. Fare clic con il pulsante destro del mouse sul nome del file o della directory, fare clic con il pulsante destro del mouse sull'unità assegnata a un montaggio NFS (Network File System) e quindi scegliere Proprietà.

  3. Per visualizzare le opzioni di montaggio NFS per l'unità, fare clic su Opzioni montaggio NFS.

  4. Per visualizzare le proprietà NFS per la directory montata, fare clic su Attributi NFS.

    Nota

    Se l'accesso è stato eseguito con un account mappato a un account UNIX nel server NFS con credenziali amministrative appropriate, quando si visualizzano le proprietà NFS è possibile cambiare le autorizzazioni per la modalità file UNIX della directory montata.
Per visualizzare le opzioni di montaggio NFS tramite la riga di comando

  1. Aprire una finestra del prompt dei comandi (non necessariamente con privilegi elevati).

  2. Al prompt dei comandi digitare:

    mount

    Note
    • Se utilizzato senza opzioni della riga di comando, il comando mount consente di visualizzare tutti i volumi montati e le relative opzioni.
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: mount /?

Ulteriori riferimenti

Utilizzare Client per NFS


Visualizzare le proprietà del server NFS

Per visualizzare le proprietà del server NFS tramite la riga di comando

  1. Aprire una finestra del prompt dei comandi (non necessariamente con privilegi elevati).

  2. Al prompt dei comandi digitare:

    showmount -e Server

    Argomento Descrizione

    Server

    Nome del computer di cui si desidera visualizzare le proprietà.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: showmount /?

Ulteriori riferimenti

Utilizzare Client per NFS


Configurare Client per NFS

  • Specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX

  • Selezionare il protocollo di rete

  • Impostare il tipo di montaggio predefinito

  • Specificare le autorizzazioni UNIX predefinite per i nuovi file

Ulteriori riferimenti

Amministrare Client per NFS


Specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX

L'accesso ai file server NFS (Network File System) richiede identità utente e identità di gruppo di tipo UNIX, diverse dalle identità di Windows. Per consentire agli utenti di accedere alle risorse NFS condivise, Client per NFS consente di recuperare i dati relativi alle identità di tipo UNIX da Active Directory, se lo schema include gli attributi appropriati, oppure da un server Mapping nomi utente. Se Active Directory non include gli attributi relativi alle identità di tipo UNIX e la rete non dispone di un server Mapping nomi utente, Client per NFS tenterà di accedere alle risorse NFS in modo anonimo.

I server NFS spesso limitano l'accesso anonimo a operazioni di sola lettura oppure non consentono l'accesso anonimo.

Per specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, quindi Strumenti di amministrazione e infine Servizi per NFS (Network File System).

  2. Se necessario, stabilire una connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Servizi per NFS e quindi scegliere Proprietà.

  4. Specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX:

    • Per utilizzare Active Directory, selezionare la casella di controllo Nome dominio Active Directory, digitare il nome del dominio e quindi fare clic su Applica.

    • Per utilizzare Mapping nomi utente, selezionare la casella di controllo Mapping nomi utenti, digitare il nome del server mapping e quindi fare clic su Applica.

    Nota

    Per utilizzare Mapping nomi utente, è necessario che il computer che esegue Client per NFS sia elencato nel file con estensione maphosts nel computer che esegue Mapping nomi utente.

Per specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX tramite la riga di comando

  1. Aprire il prompt dei comandi con privilegi elevati.

  2. Specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX:

    • Per utilizzare Active Directory, digitare:

      nfsadmin mapping [NomeComputer] config adlookup=yes addomain=NomeDominio

    • Per utilizzare Mapping nomi utente, digitare:

      nfsadmin mapping [NomeComputer] config maplookup=yes mapsvr=NomeServer

    Argomento Descrizione

    NomeDominio

    Nome del controller di dominio che si desidera utilizzare.

    NomeComputer

    Nome del computer che si desidera gestire.

    NomeServer

    Nome del server mapping che si desidera utilizzare.

    Nota

    Per utilizzare Mapping nomi utente, è necessario che il computer che esegue Client per NFS sia elencato nel file con estensione maphosts nel computer che esegue Mapping nomi utente.

Ulteriori riferimenti

Configurare Client per NFS


Selezionare il protocollo di rete

Per impostare il protocollo di rete tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, quindi Strumenti di amministrazione e infine Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Client per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Impostazioni client.

  5. Nella casella di riepilogo Protocollo di trasporto selezionare il tipo di protocollo utilizzato da Client per NFS.

  6. Per salvare questa impostazione, fare clic su Applica.

Per impostare il protocollo di rete tramite la riga di comando

  1. Aprire il prompt dei comandi con privilegi elevati.

  2. Al prompt dei comandi digitare:

    nfsadmin client [NomeComputer] config protocol={TCP | UDP | TCP+UDP}

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    protocol={TCP | UDP | TCP+UDP}

    Impostare TCP per Transmission Control Protocol (TCP), UDP per User Datagram Protocol (UDP) o TCP+UDP per entrambi.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin client /?

Ulteriori riferimenti

Configurare Client per NFS


Impostare il tipo di montaggio predefinito

Per impostare il tipo di montaggio tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, quindi Strumenti di amministrazione e infine Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Client per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Impostazioni client.

  5. Per utilizzare soft mount, selezionare Usa soft mount e in Numero di tentativi specificare il numero di tentativi consentiti a Client per NFS per stabilire una connessione. Per utilizzare hard mount, selezionare Usa hard mount.

  6. Specificare l'intervallo di tempo tra i tentativi di connessione in Intervallo tentativi.

  7. Per salvare queste impostazioni, fare clic su Applica.

Per impostare il tipo di montaggio tramite la riga di comando

  1. Aprire il prompt dei comandi con privilegi elevati.

  2. Al prompt dei comandi specificare il tipo di montaggio digitando quanto segue:

    nfsadmin client [NomeComputer] config mtype={hard | soft}

  3. Specificare il numero di tentativi di soft mount digitando quanto segue:

    nfsadmin client [NomeComputer] config retry=n

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    mtype={hard | soft}

    Tipo di montaggio.

    retry=n

    Numero di tentativi che Client per NFS può effettuare per stabilire una connessione per un soft mount. Questo valore deve essere compreso tra 1 e 10. Il valore predefinito è 1.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin client /?

Ulteriori riferimenti

Configurare Client per NFS


Specificare le autorizzazioni UNIX predefinite per i nuovi file

Quando viene creato un file in un server NFS (Network File System), viene applicato un insieme predefinito di autorizzazioni per controllare l'accesso al file. Client per NFS utilizza le autorizzazioni predefinite seguenti per i nuovi file creati su risorse condivise NFS:

  • Utente: rwx (lettura, scrittura ed esecuzione)

  • Gruppo: r-x (lettura ed esecuzione)

  • Altri: r-x (lettura ed esecuzione)

Per specificare le autorizzazioni predefinite per i file tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, quindi Strumenti di amministrazione e infine Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Client per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Autorizzazioni file e quindi selezionare le autorizzazioni da utilizzare come impostazioni predefinite.

  5. Per salvare queste impostazioni, fare clic su Applica.
Per specificare le autorizzazioni predefinite per i file tramite la riga di comando

  1. Aprire il prompt dei comandi con privilegi elevati.

  2. Al prompt dei comandi digitare quanto segue:

    nfsadmin client [ NomeComputer] fileaccess= pgt

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    pgt

    p = codice per le autorizzazioni del proprietario
    g = codice per le autorizzazioni del gruppo
    t = codice per le autorizzazioni degli altri

    I codici delle autorizzazioni sono riportati nella tabella seguente.

    Codice Descrizione

    0

    Nessuno

    1

    Esecuzione

    2

    Scrittura

    3

    Esecuzione e scrittura

    4

    Lettura

    5

    Lettura ed esecuzione

    6

    Lettura e scrittura

    7

    Lettura, scrittura ed esecuzione

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare nfsadmin client /?

Ulteriori riferimenti

Configurare Client per NFS


Risolvere i problemi relativi a Client per NFS

Problema riscontrato

  • È necessario Client per NFS per utilizzare solo porte "privilegiate".

  • Si è verificato un errore durante il tentativo di comunicare con il servizio Client per NFS.

  • Errore di sistema 1722. Server RPC non disponibile.

  • Un tentativo di montare una directory condivisa genera l'errore di rete 67. Il nome della rete non è stato trovato.

  • È stato visualizzato il messaggio RPC seguente: RPC: errore portmapper. RPC: timeout.

  • Un file creato personalmente in una risorsa condivisa NFS (Network File System) risulta creato da nobody:nogroup o da –2:–1 oppure l'identificativo utente (UID, User Identifier) è un numero molto alto (2**32-2).

  • Non è possibile accedere ai file in una risorsa condivisa NFS (Network File System).

  • Non è possibile accedere ai file in un'unità di rete mappata.

  • Non è possibile accedere a un'esportazione in più parti utilizzando un percorso UNC (Universal Naming Convention).

  • Non è possibile montare una directory radice condivisa (/) in un computer UNIX.

  • È stato visualizzato un messaggio di errore di scrittura rimandata.

  • Il tentativo di montaggio con il comando net use genera il messaggio di errore seguente: 1788: La relazione di trust tra il dominio primario e il dominio trusted non è riuscita.

  • Anche dopo aver cambiato le autorizzazioni predefinite per i nuovi file, i nuovi file di un montaggio vengono comunque creati con le autorizzazioni precedenti.

  • Dopo il riavvio del computer, i parametri di un montaggio permanente risultano cambiati.

  • Gli utenti autenticati non riescono ad accedere alle risorse NFS oppure per tutte le risorse condivise NFS risulta che l'accesso è anonimo.

È necessario Client per NFS per utilizzare solo porte "privilegiate".

Causa

Per alcuni server NFS (Network File System) esiste il concetto di porte "privilegiate", ovvero di porte con numerazione inferiore a 1024. Tali server non accetteranno connessioni client da porte con numerazione superiore.

Soluzione

Accedere ai computer che eseguono Client per NFS, impostare su 1 la chiave del Registro di sistema seguente e quindi riavviare Client per NFS:

HKLM\Software\Microsoft\Client for NFS\CurrentVersion\default

DWORD "UseReservedPorts"

Si è verificato un errore durante il tentativo di comunicare con il servizio Client per NFS.

Causa

Il servizio Client per NFS non è stato avviato, non può contattare Active Directory o il server Mapping nomi utente oppure è in esecuzione con credenziali non mappate correttamente.

Soluzione

In Servizi per NFS (Network File System) di Microsoft Management Console (MMC) è possibile accertarsi che il servizio sia stato avviato facendo clic con il pulsante destro del mouse su Client per NFS e quindi scegliendo Avvia servizio. Nella console verificare che il nome del dominio Active Directory o del server Mapping nomi utente specificato sia corretto. Verificare con l'amministratore di Active Directory o del server Mapping nomi utente che la propria identità utente Windows sia mappata correttamente alla propria identità utente UNIX.

Errore di sistema 1722. Il server RPC (Remote Procedure Call, Chiamata di procedura remota) non è disponibile.

Causa

Il servizio Client per NFS non è stato avviato.

Soluzione

In Servizi per NFS (Network File System) fare clic con il pulsante destro del mouse su Client per NFS e quindi scegliere Avvia servizio.

Un tentativo di montare una directory condivisa genera l'errore di rete 67. Il nome della rete non è stato trovato.

Causa

La directory non è condivisa oppure il server non è in grado di risolvere il nome del client.

Soluzione

Utilizzare showmount –e server per visualizzare i nomi delle directory condivise nel server. Se si verifica un errore con timeout della chiamata di procedura remota (RPC, Remote Procedure Call), rivolgersi all'amministratore del server NFS per verificare che i servizi NFS e Portmap siano stati avviati nel server. Verificare inoltre che il server NFS sia in grado di accettare connessioni da questo computer.

È stato visualizzato il messaggio RPC seguente: errore portmapper. RPC: timeout.

Causa

Il servizio Portmap o NFS non è in esecuzione nel server oppure è necessario regolare le impostazioni relative alle prestazioni di Client per NFS.

Soluzione

Verificare che i servizi siano stati avviati. Se i servizi Portmap e NFS sono in esecuzione nel server, in Servizi per NFS (Network File System) fare clic con il pulsante destro del mouse su Client per NFS, scegliere Proprietà e quindi aumentare i valori relativi al numero massimo di tentativi consentiti e all'intervallo che deve trascorrere tra un tentativo e l'altro.

Un file creato personalmente in una risorsa condivisa NFS risulta creato da nobody:nogroup o da -2:-1 oppure l'ID utente (UID, User Identifier) è un numero molto alto (2**32-2).

Causa

La propria identità utente Windows non è mappata correttamente in Active Directory o in Mapping nomi utente.

Soluzione

Nello snap-in Servizi per NFS (Network File System) verificare che il nome del dominio Active Directory o del server Mapping nomi utente specificato sia corretto. Verificare con l'amministratore di Active Directory o di Mapping nomi utente che la propria identità utente Windows sia mappata correttamente alla propria identità utente UNIX.

Non è possibile accedere ai file in una risorsa condivisa NFS.

Causa

Non è stato designato un dominio Active Directory o un server Mapping nomi utente per l'utilizzo da parte di Servizi per NFS (Network File System).

Soluzione

Specificare il dominio Active Directory o il server Mapping nomi utente corretto. Per ulteriori informazioni, vedere Specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX.

Non è possibile accedere ai file in un'unità di rete mappata.

Causa

Servizi per NFS (Network File System) non ha designato un dominio Active Directory o un server Mapping nomi utente per l'utilizzo.

Soluzione

Specificare il dominio Active Directory o il server Mapping nomi utente corretto. Per ulteriori informazioni, vedere Specificare la modalità con cui Client per NFS recupera i dati relativi alle identità di tipo UNIX.

Non è possibile accedere a un'esportazione in più parti utilizzando un percorso UNC (Universal Naming Convention).

Causa

Client per NFS può accedere a un'esportazione in più parti, ad esempio server:/d1/d2/d3, solo quando la risorsa condivisa è montata in una lettera di unità.

Soluzione

Montare l'esportazione in più parti in una lettera di unità:

mount server:/d1/d2/d3 *

Non è possibile montare una directory radice condivisa (/) in un computer UNIX.

Causa

Quando una directory radice (/) di un computer UNIX è condivisa, Client per NFS non può montarla utilizzando la sintassi di percorso standard, ovvero net use * \\server\ oppure net use server:/.

Soluzione

Per montare la directory radice, digitare il comando seguente:

net use * \\server\!

Il nome della condivisione deve essere un punto esclamativo (!).

È stato visualizzato un messaggio di errore di scrittura rimandata.

Causa

Il server NFS non risponde o le opzioni relative alle prestazioni di Client per NFS non sono state regolate correttamente.

Soluzione

Utilizzare il comando showmount –e server per determinare se il server NFS viene eseguito correttamente.

Il tentativo di montaggio con il comando net use genera il messaggio di errore seguente: 1788: La relazione di trust tra il dominio primario e il dominio trusted non è riuscita.

Causa

Si sta tentando di accedere a un computer in un dominio non attendibile e nel computer non è stato avviato Client per NFS oppure nel server NFS non è disponibile la risorsa condivisa.

Soluzione

Nello snap-in Servizi per NFS (Network File System) fare clic con il pulsante destro del mouse su Client per NFS e quindi scegliere Avvia servizio. Al prompt dei comandi digitare showmount –e server per visualizzare i nomi delle directory condivise nel server. Se si verifica un errore con timeout RPC, rivolgersi all'amministratore del server NFS per verificare che i servizi NFS e Portmap siano stati avviati nel server e che la risorsa condivisa sia disponibile.

Anche dopo aver cambiato le autorizzazioni predefinite per i nuovi file, i nuovi file di un montaggio vengono comunque creati con le autorizzazioni precedenti.

Causa

Questo è il comportamento normale. Le nuove autorizzazioni predefinite vengono applicate solo ai nuovi montaggi.

Soluzione

Smontare e quindi rimontare la directory condivisa.

Dopo il riavvio del computer, i parametri di un montaggio permanente risultano cambiati.

Causa

È stato utilizzato il comando net use per montare la directory.

Soluzione

Utilizzare l'utilità mount per montare la directory.

Gli utenti autenticati non possono accedere alle risorse NFS oppure per tutte le risorse condivise NFS risulta che l'accesso è anonimo.

Causa

Servizi per NFS (Network File System) non è configurato per recuperare i dati relativi alle identità di tipo UNIX da Active Directory o da Mapping nomi utente.

Soluzione

In Servizi per NFS (Network File System) di Microsoft Management Console (MMC) fare clic con il pulsante destro del mouse su Servizi per NFS (Network File System), scegliere Proprietà e verificare che sia impostato il nome del dominio Active Directory o del server Mapping nomi utente appropriato.

Se si utilizza Mapping nomi utente, accertarsi che nel file con estensione maphosts nel computer che esegue Mapping nomi utente sia specificato il nome o l'indirizzo IP del computer.

Ulteriori riferimenti

Amministrare Client per NFS