Servizi per NFS (Network File System)

Servizi per NFS (Network File System) rappresenta una soluzione di condivisione file che consente di trasferire file tra computer che eseguono sistemi operativi Windows Server 2008 e UNIX mediante il protocollo NFS.

Per ulteriori informazioni su Servizi per NFS, vedere TechCenter di Windows Server (http://go.microsoft.com/fwlink/?LinkId=92798).

  • Panoramica di Servizi per NFS (Network File System)

  • Elenco di controllo: operazioni preliminari con Servizi per NFS (Network File System)

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Installare e disinstallare Servizi per NFS (Network File System)

  • Configurare Server per NFS

  • Proteggere Server per NFS

  • Gestire Server per NFS

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)


Panoramica di Servizi per NFS (Network File System)

Servizi per NFS (Network File System) rappresenta una soluzione di condivisione file per le organizzazioni che dispongono di ambienti misti Windows e UNIX. Servizi per NFS consente di trasferire file tra computer che eseguono sistemi operativi Windows Server 2008 e UNIX mediante il protocollo NFS.

Per ulteriori informazioni su Servizi per NFS, vedere TechCenter di Windows Server (http://go.microsoft.com/fwlink/?LinkId=92798).

Nuove funzionalità introdotte in Windows Server 2008 R2

In Servizi per NFS sono stati apportati i miglioramenti seguenti tra Windows Server 2008 e Windows Server 2008 R2:

  • Supporto per netgroup. Servizi per NFS supporta i netgroup, che vengono utilizzati per creare gruppi di host denominati a livello di rete. I netgroup semplificano il controllo della connessione di utenti e gruppi e dell'accesso shell ai computer remoti e consentono agli amministratori di sistema di gestire più facilmente gli elenchi di controllo di accesso NFS.

  • Supporto per RPCSEC_GSS. Servizi per NFS offre il supporto nativo per RPCSEC_GSS, che consente alle applicazioni di utilizzare le funzionalità di sicurezza GSS-API.

    Nota

    Il supporto per RPCSEC_GSS include autenticazione e integrità. La privacy non è inclusa.

  • Utilizzo di WMI per la gestione di Server per NFS. WMI consente la gestione remota di NFS mediante l'abilitazione delle comunicazioni tra le applicazioni WBEM (Web-Based Enterprise Management) e i provider WMI nei computer locali o remoti per la gestione degli oggetti WMI.

  • Accesso utenti UNIX non mappati. Per le condivisioni NFS è ora disponibile un'opzione Utente UNIX non mappato. È possibile utilizzare i server Windows per archiviare dati NFS senza creare mapping di account da UNIX a Windows. Gli account utente mappati utilizzeranno ID di sicurezza (SID) di Windows standard, mentre gli utenti non mappati utilizzeranno SID NFS personalizzati.

Nota

Anche se non è disponibile la funzionalità server Mapping nomi utente per Windows Server 2008 R2, è comunque presente la funzionalità client Mapping nomi utente. Servizi per NFS è comunque in grado di recuperare i mapping dai server Mapping nomi utente precedenti in uso.

Ulteriori riferimenti

  • Elenco di controllo: operazioni preliminari con Servizi per NFS (Network File System)

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Installare e disinstallare Servizi per NFS (Network File System)

  • Configurare Server per NFS

  • Proteggere Server per NFS

  • Gestire Server per NFS


Elenco di controllo: operazioni preliminari con Servizi per NFS (Network File System)

L'elenco di controllo seguente consente di iniziare rapidamente a utilizzare Servizi per NFS (Network File System). Per ulteriori informazioni, visitare il TechCenter di Windows Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=92798.

 | Attività | Riferimento
Casella di controllo | Esaminare le informazioni generali e le procedure consigliate per Servizi per NFS. | Panoramica di Servizi per NFS (Network File System) Procedure consigliate per Servizi per NFS (Network File System)
Casella di controllo | Installare Servizi per NFS | Installare e disinstallare Servizi per NFS (Network File System)
Casella di controllo | Configurare Server per NFS | Configurare Server per NFS
Casella di controllo | Proteggere Server per NFS | Proteggere Server per NFS
Casella di controllo | Gestire Server per NFS. | Gestire Server per NFS
Casella di controllo | Risolvere i problemi relativi a Servizi per NFS | Risolvere i problemi relativi a Servizi per NFS (Network File System)


Procedure consigliate per Servizi per NFS (Network File System)

In questo argomento vengono riepilogate le procedure consigliate relative all'utilizzo di Servizi per NFS (Network File System) in un ambiente Windows Server 2008. Le aree trattate includono procedure consigliate e suggerimenti di carattere generale per l'utilizzo di Server per NFS in un cluster di server. Per ulteriori informazioni su Servizi per NFS, vedere TechCenter di Windows Server (http://go.microsoft.com/fwlink/?LinkId=92798).

Procedure consigliate generali

Utilizzare le utilità corrette per l'amministrazione di Servizi per NFS.

Non è possibile utilizzare Servizi per NFS o le utilità da riga di comando per l'amministrazione di versioni precedenti di Servizi per NFS. Non è inoltre possibile utilizzare versioni precedenti di Servizi per NFS o di utilità da riga di comando per l'amministrazione di versioni più recenti di Servizi per NFS.

È possibile utilizzare Servizi per NFS per l'amministrazione dei componenti di Servizi per NFS presenti su un computer remoto se entrambi i computer eseguono Windows Server 2008.

Aprire le porte del firewall.

Servizi per NFS richiede l'apertura di diverse porte in Windows Firewall e altri firewall. Quando richiesto, assicurarsi di consentire l'accesso ai componenti di Servizi per NFS.

Implementare la sicurezza a livello di utente

Con Server per NFS è possibile controllare l'accesso di utenti e gruppi alle risorse di Servizi per NFS. È necessario configurare e popolare Servizi di dominio Active Directory con informazioni sull'ID utente (UID) e l'identificatore di gruppo (GID) o installare Mapping nomi utente in un computer della rete per associare gli account utente Windows con account utente UNIX. In alcuni casi, può essere necessario installare Autenticazione Server per NFS.

Proteggere i file

Server per NFS supporta solo volumi di archiviazione formattati per il file system NTFS. Con i volumi NTFS è possibile garantire sicurezza a livello di file consentendo e negando l'accesso ai file a utenti e gruppi specifici. Se si desidera consentire agli utenti anonimi di accedere ai file, verificare che le autorizzazioni su file e directory garantiscano accesso appropriato agli utenti anonimi. Quando si condivide la directory, inoltre, utilizzare il controllo di accesso NFS a livello di host durante la creazione della risorsa NFS condivisa allo scopo di garantire un livello di sicurezza maggiore per i file della directory.

Proteggere le nuove unità

Quando si aggiunge una nuova unità a un computer in cui è in esecuzione Server per NFS, modificare le autorizzazioni proteggendo la directory radice dell'unità affinché gli utenti considerati non attendibili, inclusi gli utenti del gruppo Everyone, non possano scrivere nella directory. Grazie alla protezione delle directory condivise nell'unità, gli utenti non attendibili non saranno in grado di compromettere la sicurezza di Server per NFS.

Consentire agli utenti di disconnettersi prima di arrestare il servizio Server per NFS.

Prima di arrestare o di disinstallare Server per NFS, informare gli utenti connessi alle risorse condivise di Servizi per NFS che il servizio verrà arrestato. Quando gli utenti avranno avuto la possibilità di chiudere i file aperti e disconnettersi dalle directory condivise, sarà quindi possibile arrestare il servizio.

Utilizzare le convenzioni di denominazione per identificare le condivisioni con codifica EUC.

Se una directory è condivisa con un tipo di codifica EUC (Extended UNIX Code), ad esempio EUC-JP e un client configurato per utilizzare una codifica EUC diversa, ad esempio EUC-TW, tenta di connettersi alla directory condivisa, si possono verificare risultati imprevisti. Per impedire che si verifichi questa situazione, stabilire una convenzione di denominazione da utilizzare per la condivisione di directory con codifica EUC affinché gli utenti dei computer client possano conoscere la codifica utilizzata per le directory condivise.

Proteggere i file di configurazione

Se si creano file di configurazione, ad esempio un file per la conversione dei caratteri o un file di registro di controllo, proteggerli con un elenco di controllo di accesso discrezionale (DACL) che garantisca controllo completo all'account System predefinito e al gruppo Administrators. Nell'elenco DACL non devono essere incluse altre voci.

Procedure consigliate per l'esecuzione di Server per NFS in un cluster di server

Arrestare Server per NFS prima di arrestare il cluster di server

Per assicurare il funzionamento corretto di Server per NFS in un cluster di server, arrestare Server per NFS prima del cluster di server.

Garantire la disponibilità delle risorse condivise in caso di errore di un nodo

Per garantire la disponibilità di una risorsa cluster in una directory condivisa nel caso si verifichino errori nel nodo che contiene la risorsa, rendere la risorsa cluster dipendente dalla risorsa disco fisico appropriata.

Utilizzare lo strumento apposito per gestire le risorse cluster delle condivisioni NFS.

Sebbene sia possibile utilizzare Esplora risorse per visualizzare le proprietà di una risorsa cluster di una condivisione NFS, è consigliabile non utilizzarlo per la modifica delle proprietà. Per creare e amministrare le directory NFS condivise in un cluster di server, utilizzare solo Amministrazione cluster o il comando cluster.

Evitare conflitti tra i nomi delle condivisioni

Accertarsi che il nome di condivisione di ogni directory condivisa nel cluster di server sia univoco. In caso contrario, se si verifica il failover di un nodo del cluster in un nodo diverso e se le directory condivise dei due nodi hanno lo stesso nome, sarà disponibile solo una delle directory condivise.

Garantire la disponibilità dei registri di controllo

Non impostare una risorsa disco condivisa come percorso del registro di controllo di Server per NFS. Solo un nodo del cluster può essere proprietario del file di registro. Di conseguenza, se la proprietà di un gruppo viene spostata a un altro nodo, gli eventi di controllo delle risorse condivise rimanenti nel nodo originale non potranno essere registrati nel file. Per garantire la disponibilità dei registri di controllo di Server per NFS, registrare gli eventi nel registro eventi di Visualizzatore eventi.

Spostare le risorse condivise o disconnetterle prima di arrestare Server per NFS.

Quando Server per NFS viene arrestato in un nodo del cluster che ospita risorse NFS condivise attive, il servizio cluster risponderà come se si fosse verificato un errore delle relative risorse gestite e, di conseguenza, tenterà di riavviare il servizio per garantire la disponibilità della risorsa. Prima di tentare di arrestare Server per NFS in un nodo di un cluster di server, spostare tutti i gruppi che contengono risorse NFS condivise in un altro nodo del cluster oppure disconnettere tutte le risorse NFS condivise nel nodo.

Disconnettere le risorse prima di apportare modifiche.

Disconnettere sempre una directory NFS condivisa prima di modificarne le proprietà. In caso contrario si potrebbero verificare risultati imprevisti.

Amministrare Server per NFS solo da computer di un dominio trusted

Per garantire la replica corretta delle modifiche alla configurazione di Server per NFS, amministrare sempre Server per NFS in esecuzione in un cluster utilizzando un computer appartenente a un dominio trusted. Le modifiche alla configurazione di Server per NFS infatti non vengono replicate correttamente nei nodi di un cluster se si esegue Amministrazione Servizi per NFS o nfsadmin in un computer appartenente a un dominio non considerato trusted dal dominio del cluster.

Riavviare il servizio Server per NFS dopo il riavvio del servizio cluster

Se il servizio cluster deve essere riavviato in un nodo del cluster, arrestare e riavviare il servizio Server per NFS nello stesso nodo per garantire che le modifiche alla configurazione di Server per NFS vengano replicate correttamente nei nodi del cluster.

Scegliere la modalità di condivisione appropriata

Quando si crea una risorsa directory NFS condivisa, è possibile condividere la directory radice o tutte le sottodirectory della directory. Prima di scegliere l'opzione, determinare prima se è necessario controllare l'accesso alle sottodirectory o modificarne i nomi di condivisione. In caso affermativo, condividere le sottodirectory separatamente perché quando si crea una risorsa directory NFS condivisa per condividere le sottodirectory, non è possibile impostare le autorizzazioni di accesso, consentire o negare l'accesso anonimo o modificare il nome di condivisione delle sottodirectory separatamente.

Se si sceglie di condividere tutte le sottodirectory della directory, verificare che le autorizzazioni che proteggono la directory non consentano ad utenti non attendibili di creare sottodirectory. In caso contrario, un utente malintenzionato potrebbe sovraccaricare il servizio cluster creando un numero molto elevato di sottodirectory che verrebbero automaticamente condivise come risorsa del cluster.

Utilizzare la riga di comando correttamente per la creazione o la modifica di risorse cluster di una condivisione NFS.

Se si utilizza il comando cluster per creare e modificare le risorse cluster di una condivisione NFS, sono valide le considerazioni seguenti:

  • Quando si crea la risorsa cluster utilizzando il comando cluster, è possibile impostare alcune proprietà non private, ma non tutte.

  • Quando si utilizza il comando cluster per impostare le proprietà, non accettare automaticamente i valori predefiniti perché potrebbero non essere validi per una risorsa cluster di una condivisione NFS. Impostare sempre i valori delle proprietà in modo esplicito.

  • Utilizzare Amministrazione cluster per impostare o visualizzare le autorizzazioni di una risorsa cluster di una condivisione NFS. È inoltre possibile utilizzare il comando nfsshare per visualizzare le autorizzazioni, ma non per impostarle.

Utilizzare hard mount.

Indicare agli utenti dei computer client di utilizzare l'hard mount per il montaggio di directory NFS condivise nel cluster di server per garantire che, in caso di errore del nodo che condivide la directory, non si verifichi un timeout del computer client prima del completamento del failover a un nodo diverso.

Utilizzare il nome del server virtuale corretto.

Indicare agli utenti dei computer client di montare le directory NFS condivise nel cluster di server utilizzando il nome del server virtuale dello stesso gruppo della directory condivisa. Utilizzando un nome di server virtuale di un gruppo diverso o il nome del nodo, il computer client potrà montare la directory, ma il montaggio potrebbe essere perso in caso di failover.

Ulteriori riferimenti

  • Panoramica di Servizi per NFS (Network File System)

  • Elenco di controllo: operazioni preliminari con Servizi per NFS (Network File System)

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Installare e disinstallare Servizi per NFS (Network File System)

  • Configurare Server per NFS

  • Proteggere Server per NFS

  • Gestire Server per NFS


Installare e disinstallare Servizi per NFS (Network File System)

In questa sezione vengono descritte le procedure seguenti per l'installazione e la disinstallazione di Servizi per NFS (Network File System), nonché informazioni sull'aggiornamento:

  • Informazioni sugli aggiornamenti in Servizi per NFS

  • Installare e disinstallare Servizi per NFS (Network File System) tramite l'interfaccia di Windows

  • Installare e disinstallare Servizi per NFS (Network File System) mediante OCSetup.exe


Informazioni sugli aggiornamenti in Servizi per NFS

Elementi da considerare per un aggiornamento

  • A differenza di Windows Server 2003 R2, Windows Server 2008 non include Mapping nomi utente. Se si esegue l'aggiornamento a Windows Server 2008, Mapping nomi utente verrà rimosso.

Nota

Windows Server 2008 è comunque in grado di recuperare i dati relativi alle identità di tipo UNIX da server Mapping nomi utente remoti oppure da Servizi di dominio Active Directory. Gli utenti possono configurare un server di Mapping nomi utente remoto centralizzato oppure integrare i dati relativi alle identità di tipo UNIX in Servizi di dominio Active Directory.

  • La gestione dell'accesso anonimo in Windows Server 2008 è diversa. È necessario impostare il criterio di sicurezza Network Access: Let Everyone permissions apply to anonymous users in modo da consentire l'accesso anonimo.

  • Dopo la migrazione, è necessario verificare che le impostazioni del firewall di Windows Server 2008 siano ancora valide.

    Nota

    Servizi per NFS (Network File System) in Windows Server 2003 R2 richiede la configurazione manuale di Windows Firewall. Ciò non è necessario in Windows Server 2008.

Ulteriori riferimenti

  • Panoramica di Servizi per NFS (Network File System)

  • Installare e disinstallare Servizi per NFS (Network File System)


Installare e disinstallare Servizi per NFS (Network File System) tramite l'interfaccia di Windows

È necessario installare i componenti di Servizi per NFS (Network File System ) in un computer che esegue Windows Server 2008. Ai fini delle istruzioni descritte in questa sezione, si presuppone che tutti i componenti vengano installati in un unico computer.

Installare e disinstallare i componenti di Servizi per NFS

  • Installare i componenti di Servizi per NFS

  • Disinstallare i componenti di Servizi per NFS
Per installare i componenti NFS

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  2. Nel riquadro sinistro fare clic su Ruoli.

  3. Fare clic su Aggiungi ruoli. Verrà visualizzata l'Aggiunta guidata ruoli.

  4. Fare clic su Avanti. Verranno visualizzate le opzioni di Selezione ruoli server.

  5. Selezionare la casella di controllo File server e quindi fare clic su Avanti.

  6. Verrà visualizzata la pagina File server. Fare clic su Avanti per visualizzare le opzioni di Servizi ruolo.

  7. Selezionare la casella di controllo Servizi per NFS (Network File System) e quindi fare clic su Avanti.

  8. Confermare le selezioni effettuate e fare clic su Installa.

  9. Al termine del processo, verranno visualizzati i risultati dell'installazione. Fare clic su Chiudi.

Ulteriori riferimenti

  • Installare e disinstallare Servizi per NFS (Network File System)

Per disinstallare i componenti di Servizi per NFS

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  2. Nel riquadro sinistro fare clic su Ruoli.

  3. Eseguire le operazioni seguenti a seconda della situazione:

    • Se il servizio NFS è l'unico servizio installato, sarà necessario rimuovere l'intero ruolo Servizi file.

      1. Nel riquadro a destra, nella sezione Riepilogo ruoli fare clic su Rimuovi ruoli. Verrà visualizzata la Rimozione guidata ruoli.

      2. Verrà visualizzata la pagina Prima di iniziare. Fare clic su Avanti.

      3. Nella pagina Rimozione ruoli server deselezionare la casella di controllo Servizi file e quindi fare clic su Avanti.

      4. Confermare le selezioni effettuate e fare clic su Rimuovi.

      5. Quando viene visualizzata la finestra Risultati rimozione, riavviare per completare la procedura.

    • Se il servizio NFS non è l'unico servizio installato, sarà necessario rimuovere solo tale servizio ruolo.

      1. Nel riquadro a destra, nella sezione Servizi ruolo fare clic su Rimuovi servizi ruolo.

      2. Nella pagina Selezione servizi ruolo deselezionare la casella di controllo Servizi per NFS (Network File System) e quindi fare clic su Avanti.

      3. Verificare le selezioni effettuate e fare clic su Rimuovi.

      4. Quando viene visualizzata la finestra Risultati rimozione, riavviare per completare la procedura.

Ulteriori riferimenti

  • Installare e disinstallare Servizi per NFS (Network File System)


Installare e disinstallare Servizi per NFS (Network File System) mediante OCSetup.exe

Prima di eseguire OCSetup.exe al prompt dei comandi, impostare quest'ultimo per l'esecuzione come amministratore, anche se si è eseguito l'accesso al computer come amministratore.

  1. Fare clic sul pulsante Start e scegliere Tutti i programmi.

  2. Scegliere Accessori.

  3. Fare clic con il pulsante destro del mouse sul prompt dei comandi e scegliere Esegui come amministratore.

Esempi

Nella tabella seguente vengono illustrati esempi di utilizzo del comando OCSetup per l'installazione dei diversi componenti di Servizi per NFS.

Componente Comando

Server per NFS, Client per NFS, Amministrazione Servizi per NFS

Ocsetup ServicesForNFS-ServerAndClient;ServerForNFS-Infrastructure;NFS-Administration;ClientForNFS-Infrastructure

Server per NFS, Amministrazione Servizi per NFS

Ocsetup ServicesForNFS-ServerAndClient;ServerForNFS-Infrastructure;NFS-Administration

Client per NFS, Amministrazione Servizi per NFS

Ocsetup ServicesForNFS-ServerAndClient;ClientForNFS-Infrastructure;NFS-Administration
Nota

Per disinstallare i componenti di Servizi per NFS, aggiungere l'opzione /uninstall ai comandi indicati sopra.

Ulteriori riferimenti

  • Panoramica di Servizi per NFS (Network File System)

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Installare e disinstallare Servizi per NFS (Network File System)


Configurare Server per NFS

In questa sezione vengono descritte le procedure seguenti per la configurazione di Server per NFS:

  • Avviare e arrestare Server per NFS

  • Specificare la modalità di ricezione delle informazioni sugli utenti e i gruppi di Windows da parte di Server per NFS

  • Impostare il periodo di prova del blocco

  • Rilasciare i blocchi

  • Impostare la registrazione delle attività

  • Specificare le impostazioni TCP e UDP di Server per NFS

  • Abilitare la versione NFS

  • Configurare la conversione caratteri dei nomi di file

  • Configurare il periodo di rinnovo dell'autenticazione

  • Configurare la distinzione tra maiuscole e minuscole per i nomi di file e cartelle

  • Modificare le impostazioni della memoria cache delle directory


Avviare e arrestare Server per NFS

Avviare Server per NFS

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per avviare il servizio Server per NFS tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Avvia servizio.

Ulteriori riferimenti

  • Configurare Server per NFS

Per avviare il servizio Server per NFS tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [NomeComputer] start

    Argomento Descrizione

    NomeComputer

    Nome del computer in cui si desidera avviare il servizio Server per NFS.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

Arrestare Server per NFS

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per arrestare Server per NFS tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Arresta servizio.

Nota

Prima di arrestare Server per NFS in esecuzione in un nodo di un cluster di server, spostare tutti i gruppi contenenti risorse NFS condivise in un altro nodo o disconnettere tutte le risorse NFS condivise.

Ulteriori riferimenti

  • Configurare Server per NFS

Per arrestare il servizio Server per NFS tramite la riga di comando

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [NomeComputer] stop

    Argomento Descrizione

    NomeComputer

    Nome del computer nel quale si desidera arrestare Server per NFS.

    Note
    • Prima di arrestare Server per NFS in esecuzione in un nodo di un cluster di server, spostare in un altro nodo tutti i gruppi contenenti risorse NFS condivise o disconnettere tutte le risorse NFS condivise.
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS


Specificare la modalità di ricezione delle informazioni sugli utenti e i gruppi di Windows da parte di Server per NFS

Quando un utente esegue l'accesso a un computer host UNIX, la password e il nome utente specificati vengono confrontati con quelli presenti in un file password. Se corrispondono a una password e a un nome utente presenti nel file, il server restituisce UID (User Identifier, ID utente) e GID (Group Identifier, identificatore di gruppo) corrispondenti. UID e GID consentono l'identificazione dell'utente per le operazioni di selezione e montaggio in NFS.

Server per NFS consente l'accesso alle risorse NFS ai client senza un'ulteriore procedura di accesso a Server per NFS. La prima volta che si accede a una risorsa NFS, Server per NFS cerca UID e GID UNIX relativi all'utente in Servizi di dominio Active Directory o in Mapping nomi utente. Se le informazioni UID e GID UNIX sono mappate ad account utente e di gruppo di Windows, verranno restituiti i nomi Windows a Server per NFS, che concederà l'accesso ai file in base ai nomi utente e di gruppo di Windows. Se le informazioni UID e GID UNIX non sono mappate, l'accesso ai file viene negato.

Nota

La funzionalità Mapping nomi utente è stata modificata. La funzionalità server non è più presente, tuttavia è disponibile la funzionalità client. Servizi per NFS è comunque in grado di recuperare i mapping dai server Mapping nomi utente precedenti in uso.

Specificare la modalità di ricezione delle informazioni sugli utenti e i gruppi di Windows da parte di Server per NFS

È possibile eseguire questa procedura in uno dei modi seguenti:

  • Tramite l'interfaccia di Windows

  • Tramite una riga di comando

Per specificare la modalità di ricezione delle informazioni UID e GID da parte di Server per NFS tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Servizi per NFS e quindi scegliere Proprietà.

  4. Specificare il modo in cui Server per NFS ottiene informazioni UID e GID relative agli utenti:

    • Per utilizzare Ricerca con Active Directory, selezionare la casella di controllo Nome dominio Active Directory, digitare il nome del dominio e quindi fare clic su Applica.

    • Per utilizzare Mapping nomi utente, selezionare la casella di controllo Mapping nomi utente, digitare il nome del server mapping che si desidera utilizzare per l'autenticazione e quindi fare clic su Applica.

    Note
    • Per utilizzare Ricerca con Active Directory, è necessario installare e popolare l'estensione dello schema di Active Directory Identity Management for UNIX, inclusa in Windows Server 2008, oppure utilizzare uno schema equivalente che includa i campi UID e GID di UNIX. Identity Management for UNIX semplifica in modo significativo questo aspetto della gestione degli account utente da Windows a UNIX in Servizi di dominio Active Directory.
    • È possibile specificare l'indirizzo IP del server Mapping nomi utente anziché il nome del server.
    • Per utilizzare Mapping nomi utente, è necessario inserire il computer che esegue Server per NFS nel file con estensione maphosts nel computer che esegue Mapping nomi utente.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per specificare la modalità di ricezione delle informazioni UID e GID da parte di Server per NFS tramite la riga di comando

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Specificare il modo in cui Server per NFS ottiene informazioni UID e GID relative agli utenti:

    • Per utilizzare Ricerca con Active Directory, digitare:

      nfsadmin mapping [NomeComputer] config adlookup=yes addomain=NomeDominio

    Argomento Descrizione

    NomeDominio

    Nome del controller di dominio che si desidera utilizzare.

    NomeComputer

    Nome del computer che si desidera gestire.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin mapping /?
    • Per utilizzare Ricerca con Active Directory, è necessario installare e popolare l'estensione dello schema di Active Directory Identity Management for UNIX, inclusa in Windows Server 2008, oppure utilizzare uno schema equivalente che includa i campi UID e GID di UNIX. Identity Management for UNIX semplifica questo aspetto della gestione degli account utente da Windows a UNIX in Servizi di dominio Active Directory.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Impostare il periodo di prova del blocco

Impostare il periodo di prova del blocco

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per impostare il periodo di prova del blocco tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Blocco.

  5. In Tempo di attesa digitare il numero di secondi entro cui i client di Server per NFS possono ristabilire i blocchi file dopo un'interruzione di rete o del servizio server.

  6. Per salvare questa impostazione, fare clic su Applica.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per impostare il periodo di prova del blocco tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [Nome Computer] config lockperiod=PeriodoProvaBlocco

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    PeriodoProvaBlocco

    Periodo di tempo (espresso in secondi) entro cui gli utenti possono ristabilire i blocchi dopo il riavvio del server.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Rilasciare i blocchi

Rilasciare i blocchi

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per rilasciare i blocchi tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Blocco.

  5. Nell'elenco dei client fare clic sul client per cui si desidera rilasciare i blocchi, fare clic su Rilascia blocco e quindi su Applica.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per rilasciare i blocchi tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Per elencare tutti i blocchi, digitare:

    nfsadmin server [NomeComputer] –l

  3. Per rilasciare i blocchi, digitare:

    nfsadmin server [NomeComputer] –r [Client | all]

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    Client

    Il client per cui si desidera rilasciare i blocchi.

    All

    Rilascia tutti i blocchi.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
    • nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Impostare la registrazione delle attività

Impostare la registrazione attività

Nella procedura seguente viene descritto come impostare la registrazione attività per Server per NFS.

Per impostare la registrazione tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Registrazione attività.

  5. In Eventi Server per NFS selezionare gli eventi da registrare dalle opzioni seguenti:

    • Richieste di montaggio e smontaggio

    • Richieste di blocco e sblocco

    • Richieste di lettura e scrittura

    • Richieste di creazione ed eliminazione

  6. Per salvare le impostazioni, fare clic su Applica.

    Note
    • Per impostazione predefinita, gli eventi non vengono registrati. Se la registrazione viene eseguita in un file di testo, il file di registro deve trovarsi nel computer locale. Per interrompere la registrazione di un evento, deselezionare la relativa casella di controllo.
    • Se si sceglie di registrare le attività di Server per NFS nel registro eventi, la stringa corrispondente al nome del file potrebbe risultare troncata a causa di una limitazione del sistema. Per risolvere il problema, è possibile registrare le attività in un file di testo. In un cluster di server è consigliabile registrare le attività nel Visualizzatore eventi perché i dati vengono replicati in tutti i nodi del cluster. In questo scenario la registrazione delle attività in un file di testo oltre che in un registro eventi può consentire di associare nomi di file completi a una determinata voce del registro attività.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Specificare le impostazioni TCP e UDP di Server per NFS

Specificare le impostazioni TCP e UDP

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per specificare le impostazioni TCP e UDP di Server per NFS tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Impostazioni server.

  5. Selezionare l'impostazione desiderata per il protocollo di trasporto nell'elenco a discesa Protocollo di trasporto e quindi fare clic su Applica.

    Importante

    Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per specificare le impostazioni TCP e UDP di Server per NFS tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [NomeComputer] config [Protocollo]= [Trasporto]

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    Protocollo

    Nome del protocollo NFS che si desidera configurare.

    Termine

    Definizione

    PortmapProtocol

    Specifica il protocollo di Portmap.

    MountProtocol

    Specifica il protocollo di montaggio.

    NLMProtocol

    Specifica il protocollo NLM.

    NSMProtocol

    Specifica il protocollo NSM.

    Trasporto

    Trasporto o combinazione di trasporti da abilitare per il protocollo NFS selezionato.

    Termine

    Definizione

    TCP

    Abilita solo il trasporto TCP (Transmission Control Protocol).

    UDP

    Abilita solo il trasporto UDP (User Data Protocol).

    TCP+UDP

    Abilita entrambi i trasporti TCP e UDP.

    Importante

    Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Abilitare la versione NFS

Abilitare NFS versione 3

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per abilitare NFS versione 3 tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Impostazioni server.

  5. Selezionare la casella di controllo Attiva supporto per NFS versione 3 e quindi fare clic su Applica.
Importante

Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per abilitare NFS versione 3 tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

nfsadmin server [\\NomeComputerRemoto] config enablev3={yes | no}

Argomento | Descrizione
NomeComputerRemoto | Nome del computer che si desidera configurare.
Importante

Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.

Note
  • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
  • nfsadmin server /?
  • Il supporto per NFS versione 3 è attivato per impostazione predefinita.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Configurare la conversione caratteri dei nomi di file

Configurare la conversione caratteri dei nomi di file

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per configurare la conversione caratteri dei nomi di file tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Gestione nomi file.

  5. Selezionare la casella di controllo Converti nomi file.

  6. Nella casella File di conversione caratteri digitare il percorso completo del file contenente il mapping per la conversione dei caratteri oppure fare clic su Sfoglia per trovare il file e quindi su Applica.

    Importante

    Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.

    Importante

    Per impedire la manomissione del file di conversione caratteri per i nomi di file da parte di utenti non autorizzati e quindi errori di Server per NFS, accertarsi che il file sia protetto con un elenco di controllo di accesso discrezionale (DACL) che conceda diritti di controllo completo all'account predefinito System e al gruppo Administrators. Nell'elenco DACL non devono essere incluse altre voci.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per configurare la conversione caratteri dei nomi di file tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati:

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [NomeComputerRemoto] config translationfile=file

    Argomento Descrizione

    NomeComputerRemoto

    Nome del computer che si desidera configurare.

    file

    Percorso completo e nome del file contenente l'elenco dei mapping per la conversione dei caratteri. Se non viene specificato alcun file, la conversione dei caratteri sarà disabilitata.

    Importante

    Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.
Importante

Per evitare che utenti non autorizzati possano manomettere il file di conversione caratteri dei nomi di file e causare un errore di Server per NFS, è possibile proteggere il file utilizzando un elenco di controllo di accesso discrezionale (DACL, Discretionary Access Control List) che conceda il controllo completo all'account di sistema incorporato e al gruppo Administrators. L'elenco DACL non deve includere altre voci.

Note
  • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
  • nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Configurare il periodo di rinnovo dell'autenticazione

Configurare il periodo di rinnovo dell'autenticazione

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per configurare la frequenza del rinnovo dell'autenticazione tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Impostazioni server.

  5. Scegliere una delle opzioni seguenti:

    • Per impedire che Server per NFS rinnovi periodicamente l'autenticazione, fare clic su Non rinnovare autenticazione.

    • Per fare in modo che Server per NFS rinnovi periodicamente l'autenticazione, fare clic su Rinnova autenticazione ogni e digitare il numero di secondi da attendere prima di procedere al rinnovo dell'autenticazione. Il valore predefinito è 600 secondi.

  6. Fare clic su Applica.

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per configurare la frequenza del rinnovo dell'autenticazione tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Scegliere una delle opzioni seguenti:

    • Per evitare che Server per NFS rinnovi periodicamente l'autenticazione, digitare:

      nfsadmin server [NomeComputer] config renewauth=no

    • Per configurare Server per NFS in modo da rinnovare periodicamente l'autenticazione, digitare:

      nfsadmin server [NomeComputer] config renewauth=yes

      nfsadmin server [NomeComputer] config renewauthinterval=secondi

      Argomento Descrizione

      NomeComputer

      Nome del computer che si desidera configurare.

      secondi

      Il numero di secondi di attesa prima del rinnovo dell'autenticazione. Il valore predefinito è 600.

      Nota

      Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Configurare la distinzione tra maiuscole e minuscole per i nomi di file e cartelle

Configurare la distinzione tra maiuscole e minuscole

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per configurare la distinzione tra maiuscole e minuscole per i nomi di file e cartelle tramite l'interfaccia di Windows

  1. Aprire Servizi per NFS (Network File System). A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi per NFS (Network File System).

  2. Se necessario, eseguire la connessione al computer che si desidera gestire.

  3. Fare clic con il pulsante destro del mouse su Server per NFS e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Gestione nomi file.

  5. Eseguire una delle operazioni seguenti:

    • Per attivare le ricerche di nomi di file e directory con distinzione tra maiuscole e minuscole, selezionare la casella di controllo Distinzione maiuscole/minuscole nei nomi file in Server per NFS.

    • Per disattivare le ricerche di nomi di file e directory con distinzione tra maiuscole e minuscole, deselezionare la casella di controllo Distinzione maiuscole/minuscole nei nomi file in Server per NFS.

  6. Fare clic su Applica.

    Importante
    • Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.
    • È inoltre necessario disattivare la non distinzione tra maiuscole e minuscole del kernel di Windows affinché Server per NFS supporti i nomi di file con distinzione tra maiuscole e minuscole. È possibile disattivare la non distinzione tra maiuscole e minuscole del kernel di Windows impostando il valore della chiave del Registro di sistema seguente su 0:
    • HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\kernel
    • DWORD “obcaseinsensitive”

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per configurare la distinzione tra maiuscole e minuscole per i nomi di file e cartelle utilizzando il prompt dei comandi

  1. Aprire una finestra del prompt dei comandi.

  2. Per attivare la distinzione tra maiuscole e minuscole digitare:

    nfsadmin server [NomeComputer] config casesensitivelookups=yes

  3. Per disattivare la distinzione tra maiuscole e minuscole e specificare facoltativamente l'utilizzo delle maiuscole/minuscole per i nomi di file restituiti da Server per NFS, digitare:

    nfsadmin server [NomeComputer] config casesensitivelookups=no [ntfscase={upper | lower | preserve}]

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera configurare.

    Importante

    Le modifiche non avranno effetto finché Server per NFS non verrà riavviato.

    Note
    • L'opzione ntfscase imposta la distinzione tra maiuscole e minuscole per il file system NTFS. L'impostazione predefinita è quella di mantenere la distinzione tra maiuscole e minuscole originali, ovvero preserve.
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
    • nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Modificare le impostazioni della memoria cache delle directory

Server per NFS cerca le informazioni sulle directory in un'apposita cache invece che nelle directory stesse sul disco fisico. Per impostazione predefinita, questa cache è configurata per utilizzare 128 KB di memoria per ogni directory di cui Server per NFS memorizza le informazioni nella cache. È possibile modificare la quantità di memoria utilizzata dalla cache di directory configurando le dimensioni della cache di cartella dal prompt dei comandi.

Modificare l'impostazione della memoria cache delle directory

Nella procedura seguente viene descritto come modificare la quantità di memoria utilizzata per la cache delle directory.

Per configurare le dimensioni della cache delle cartelle tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Digitare il comando seguente:

    nfsadmin server [\\NomeComputerRemoto] config dircache=dimensioni

    Valore Descrizione

    NomeComputerRemoto

    Nome del computer che si desidera configurare.

    dimensioni

    Le dimensioni, espresse in kilobyte (KB), che si desidera impostare per la cache della directory. L'impostazione predefinita è 128 KB.
Note
  • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
  • nfsadmin server /?

Ulteriori riferimenti

  • Configurare Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Proteggere Server per NFS

In questa sezione vengono descritte le procedure seguenti per proteggere Server per NFS:

  • Informazioni sui descrittori di sicurezza di Windows in Server per NFS

  • Informazioni sui DACL in Server per NFS

  • Consentire l'accesso alla radice e l'accesso anonimo alle risorse da parte dei client NFS

  • Utilizzare i bit setuid, setgid e sticky con Server per NFS

  • Aggiungere client e gruppi all'elenco delle autorizzazioni della condivisione NFS


Informazioni sui descrittori di sicurezza di Windows in Server per NFS

Il servizio Server per NFS prevede l'utilizzo del descrittore di sicurezza di Windows per l'implementazione delle autorizzazioni di accesso NFS (Network File System). Il descrittore di sicurezza è la struttura che controlla le assegnazioni di sicurezza per Windows. Il descrittore di sicurezza contiene i componenti seguenti:

  • Proprietario del file

  • Gruppo di file

  • Elenco di controllo di accesso discrezionale (DACL)

  • Elenco di controllo di accesso di sistema (SACL)

Nota

L'elenco di controllo di accesso di sistema viene utilizzato per il controllo e non influisce sulle autorizzazioni file.

All'interno del descrittore di sicurezza il proprietario del file e il gruppo di file fanno riferimento a ID di sicurezza (SID). Un SID può essere considerato come la rappresentazione interna di un singolo utente o gruppo. I SID vengono principalmente utilizzati per consentire la distinzione tra account di diversi domini che condividono lo stesso nome. Sebbene i nomi siano uguali, essi rappresentano account diversi e possono disporre di autorizzazioni diverse per lo stesso file.

Ulteriori riferimenti

  • Proteggere Server per NFS

  • Informazioni sui DACL in Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Informazioni sui DACL in Server per NFS

L'elenco di controllo di accesso discrezionale (DACL) contenuto nel descrittore di sicurezza costituisce un elemento importante della sicurezza di Windows. L'elenco DACL contiene le voci che concedono o negano determinati diritti a utenti o gruppi specifici. Tali voci sono denominate voci di controllo di accesso (ACE). Ogni ACE è costituita dagli elementi seguenti:

  • Un ID di sicurezza (SID) per identificare un determinato utente o gruppo.

  • Un elenco degli accessi in cui sono specificate le autorizzazioni concesse o negate all'utente o al gruppo.

Di seguito è disponibile un esempio di elenco DACL:

  • DACL: Utente1 Full Control (All)

  • ToolGroup:Read(RX)

  • Everyone:Read (RX)

In questo elenco DACL l'utente Utente1 dispone di autorizzazioni di accesso al file in lettura, scrittura ed esecuzione. I membri del gruppo ToolGroup dispongono delle autorizzazioni di accesso in lettura ed esecuzione. I membri del gruppo Everyone (tutti gli utenti) dispongono delle autorizzazioni di accesso in lettura ed esecuzione.

L'accesso ai file è stabilito dalle regole seguenti:

  • Se non è presente alcun elenco DACL, a tutti sarà concesso l'accesso completo.

  • Se è presente un elenco DACL, ma non contiene alcuna voce, l'accesso non sarà concesso a nessuno.

  • Il proprietario del file ha sempre la capacità di modificare l'elenco DACL.

Le regole seguenti, invece, sono relative all'elenco DACL:

  • Le voci dell'elenco DACL vengono ricercate in ordine sequenziale.

  • Tutte le autorizzazioni vengono negate in modo implicito.

  • Dopo che è stata negata, un'autorizzazione non può più essere concessa.

  • Dopo che è stata concessa, un'autorizzazione non può più essere negata.

Ulteriori riferimenti

  • Proteggere Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Consentire l'accesso alla radice e l'accesso anonimo alle risorse da parte dei client NFS

Consentire l'accesso alla radice

È possibile consentire agli utenti UNIX l'accesso come utente ROOT alle risorse. A tale scopo è possibile utilizzare le modalità seguenti:

  • Assegnare l'accesso come utente ROOT ai computer client al momento dell'esportazione della risorsa condivisa.

  • Eseguire il mapping (tramite Ricerca con Active Directory o Mapping nomi utente) dell'utente ROOT UNIX (UID 0) all'utente Administrator di Windows, nonché del gruppo a cui appartiene l'utente ROOT al gruppo Administrators di Windows.

Si consideri ad esempio la directory Dirtest, appartenente ad Administrators. La directory è stata creata da un account membro del gruppo Administrators di Windows. Le autorizzazioni elencate sono state impostate dopo la creazione della directory. Nel client UNIX le autorizzazioni sono visualizzate nel modo seguente:

ls ld /testdir
drwxrwxr-x 2 root root 64 Nov 3 12:11 /testdir/

Se la directory appartiene al gruppo Administrators, Server per NFS indica una coppia ID utente (UID)-identificatore gruppo (GID) uguale a 0,0.

Consentire l'accesso anonimo

Per impostazione predefinita, Server per NFS non consente l'accesso alle directory condivise da parte di utenti anonimi. Al momento della condivisione di una directory è possibile consentire l'accesso anonimo a quest'ultima utilizzando i valori UID e GID validi degli account utente e gruppo UNIX desiderati anziché i valori UID e GID anonimi predefiniti. Se si sostituiscono i valori UID e GID anonimi per una risorsa condivisa, l'utente corrispondente ai valori utilizzati verrà indicato come proprietario dei file appartenenti a un utente Windows non mappato a un utente UNIX, anche quando l'accesso anonimo non è consentito.

Nota

Per consentire l'accesso anonimo, attivare il criterio Network Access: Let Everyone permissions apply to anonymous users.

Per consentire l'accesso anonimo a una condivisione NFS tramite l'interfaccia di Windows

  1. Aprire Esplora risorse: fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, Accessori e quindi Esplora risorse.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sulla directory condivisa che si desidera gestire.

  3. Fare clic su Condivisione.

  4. Scegliere Condivisione NFS.

  5. Selezionare Consenti accesso anonimo.

  6. Per specificare un valore non predefinito per l'ID utente (UID) anonimo o l'identificatore di gruppo (GID) anonimo, digitare il valore nella casella UID anonimo o GID anonimo.

  7. Fare clic su Applica.

Ulteriori riferimenti

  • Proteggere Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per consentire l'accesso anonimo a una condivisione NFS tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsshare -o opzione=valore...nomecondivisione

    Argomento Descrizione

    nomecondivisione

    Il nome della directory condivisa.

    -o

    Specifica una o più opzioni da impostare e deve essere impostata almeno su uno dei valori seguenti:

    anon={yes | no}

    Specifica se gli utenti anonimi, ovvero non mappati, possono accedere alla directory condivisa. Il valore predefinito è no.

    anonuid=uid

    Specifica che gli utenti anonimi, ovvero non mappati, potranno accedere alla directory della condivisione utilizzando uid come ID utente (UID). Il valore predefinito è -2. L'UID anonimo verrà utilizzato per segnalare al proprietario un file di proprietà di un utente non mappato, anche se è disabilitato l'accesso anonimo.

    anongid=gid

    Specifica che gli utenti anonimi, ovvero non mappati, potranno accedere alla directory della condivisione utilizzando gid come identificatore di gruppo (GID). Il valore predefinito è -2. Il GID anonimo verrà utilizzato per segnalare al proprietario un file di proprietà di un utente non mappato, anche se è disabilitato l'accesso anonimo.

    Nota

    Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: nfsshare /?

Ulteriori riferimenti

  • Proteggere Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Utilizzare i bit setuid, setgid e sticky con Server per NFS

Gli utenti di computer client possono utilizzare l'utilità chmod per impostare i bit di modalità file setuid (set-user-identifier-on-execution), setgid (set-group-identifier-on-execution) e sticky in directory o file archiviati in una partizione del file system NTFS e condivisi tramite Server per NFS. Quando successivamente viene eseguito l'accesso al file o alla directory da parte di un client basato su UNIX, viene applicata la semantica standard per questi bit. Un file eseguibile con il bit setuid impostato verrà ad esempio eseguito con l'ID utente del proprietario del file e non dell'utente che sta eseguendo il file.

In genere, quando in un file viene impostato il bit setuid o setgid, il proprietario o il gruppo del file viene modificato nel proprietario o nel gruppo con l'ID del quale verrà eseguito il file. A meno che un utente disponga del diritto di ripristinare file o directory, la sicurezza di Windows consente all'utente di diventare proprietario di un file, se le autorizzazioni del file lo consentono, ma non di trasferire la proprietà a un altro utente. Di conseguenza, per utilizzare i comandi chown o chgrp per cambiare il proprietario o il gruppo di un file assegnando un diverso utente o gruppo, è necessario disporre del privilegio di ripristino di file e directory. Per impostazione predefinita, questo privilegio viene assegnato ai membri dei gruppi Administrators e Backup Operators, sebbene possa essere assegnato ad altri gruppi o a singoli utenti. È inoltre necessario che per l'account utente che esegue il comando chown o chgrp e per l'utente o il gruppo a cui viene trasferita la proprietà venga eseguito il mapping appropriato tramite la funzionalità Ricerca con Active Directory o il servizio Mapping nomi utente.

In alcuni server NFS (Network File System) basati su UNIX vengono applicate interpretazioni o restrizioni speciali per i bit setuid, setgid e sticky. In alcune versioni di UNIX, ad esempio, viene applicato il blocco obbligatorio a una directory con il bit setgid impostato ma senza autorizzazioni di esecuzione. Tramite il servizio Server per NFS non vengono implementate interpretazioni o restrizioni speciali per l'utilizzo di questi bit.

Problema di sicurezza

Il comportamento tipico dei bit setuid e setgid UNIX presenta un problema di sicurezza noto in UNIX. Un intruso può sfruttare il comportamento dei bit setuid e setgid sovrascrivendo un file eseguibile con un trojan horse e quindi eseguendo il file. Il file eseguibile viene eseguito con i diritti di proprietario anziché come intruso.

Per impedire questo problema di sicurezza noto, per impostazione predefinita i bit setuid e setgid sono disabilitati e non influiscono sulle impostazioni di UID o GID se il file o la directory presenta entrambe le caratteristiche seguenti:

  • Uno o entrambi i bit seguenti sono impostati: setuid o setgid

  • Il file o la directory può essere scritto o eseguito da un gruppo o da tutti.

Per alcuni utenti questa misura di sicurezza potrebbe risultare problematica in quanto si differenzia dal comportamento tipico di UNIX, sebbene il comportamento tipico dei bit setuid e setgid UNIX non sia specificato come parte del protocollo NFS.

Modificare il comportamento dei bit setuid e setgid

Per modificare il comportamento dei bit setuid e setgid, eseguire la procedura seguente.

Per modificare il comportamento dei bit setuid e setgid

  1. Aprire l'editor del Registro di sistema.

  2. Impostare la chiave del Registro di sistema seguente:

    HKEY_Local_Machine\System\CurrentControlSet\Services\NfsSvr\Parameters\SafeSetUidGidBits = (DWORD)

    • Un valore pari a 1 consente di impostare il comportamento più protetto dei bit setuid e setgid.

    • Un valore pari a 0 consente di impostare il comportamento standard di UNIX.

Ulteriori riferimenti

  • Proteggere Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Aggiungere client e gruppi all'elenco delle autorizzazioni della condivisione NFS

Aggiungere client e gruppi all'elenco delle autorizzazioni della condivisione NFS

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per aggiungere client e gruppi all'elenco delle autorizzazioni della condivisione NFS tramite l'interfaccia di Windows

  1. Aprire Esplora risorse: fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, Accessori e quindi Esplora risorse.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sulla directory condivisa che si desidera gestire.

  3. Fare clic su Condivisione.

  4. Scegliere Condivisione NFS.

  5. Se la directory non è già condivisa, fare clic su Condividi questa cartella e quindi digitare un nome per la condivisione nella casella Nome condivisione.

  6. Fare clic su Autorizzazioni, quindi su Aggiungi e infine scegliere una delle azioni seguenti:

    • Nell'elenco Nomi fare clic sui client e sui gruppi che si desidera aggiungere, quindi fare clic su Aggiungi.

    • Nella casella Aggiungi nomi digitare i nomi dei client o dei gruppi che si desidera aggiungere, separando i nomi nell'elenco con un punto e virgola (;).

  7. Per visualizzare un elenco dei membri di un gruppo, fare clic su un gruppo nell'elenco Nomi e quindi su Membri.

  8. Nell'elenco Tipo di accesso fare clic sul tipo di accesso che si desidera concedere ai client e ai gruppi selezionati.

  9. Selezionare Consenti accesso alla radice se si desidera assegnare un tipo di accesso diverso da quello come utente anonimo a un utente identificato come ROOT. Per impostazione predefinita, l'ID utente (UID) ROOT viene assegnato all'UID anonimo.

  10. Nell'elenco Codifica fare clic sul tipo di codifica dei nomi di file e directory da impostare per i client e i gruppi selezionati. Oltre alla codifica predefinita ANSI (American National Standards Institute), sono disponibili le codifiche seguenti:

    • BIG5 (cinese)

    • EUC-JP (giapponese)

    • EUC-KR (coreano)

    • EUC-TW (cinese)

    • GB2312-80 (cinese semplificato)

    • KSC5601 (coreano)

    • SHIFT-JIS (giapponese)

    Nota

    Se questa opzione viene impostata su ANSI nei sistemi configurati per impostazioni locali non inglesi, lo schema di codifica verrà impostato sullo schema di codifica predefinito delle impostazioni locali. Gli schemi di codifica predefiniti per le impostazioni locali indicate sono i seguenti:

    • Giapponese: SHIFT-JIS

    • Coreano: KS_C_5601-1987

    • Cinese semplificato: GB

    • Cinese tradizionale: BIG5

  11. Per chiudere la finestra di dialogo, fare clic su OK.

Ulteriori riferimenti

  • Proteggere Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per aggiungere client e gruppi all'elenco delle autorizzazioni della condivisione NFS tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e scegliere Tutti i programmi.

    2. Scegliere Accessori.

    3. Fare clic con il pulsante destro del mouse sul prompt dei comandi e scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsshare -o opzione [=host[:host]...] nomecondivisione

    Argomento Descrizione

    nomecondivisione

    Il nome della directory condivisa.

    -o opzione

    Consente di specificare una o più opzioni da impostare. È necessario impostare almeno una delle seguenti:

    • big5 (cinese)

    • euc-jp (giapponese)

    • euc-kr (coreano)

    • euc-tw (cinese)

    • gb2312-80 (cinese semplificato)

    • ksc5601 (coreano)

    • shift-jis (giapponese)

    Se questa opzione non viene impostata, verrà utilizzato lo schema di codifica predefinito.

    noroot[=host[:host]...]

    Consente di negare l'accesso come utente ROOT alla directory condivisa da parte di gruppi o client specificati dall'host. Separare i nomi dei gruppi e dei client con i due punti (:). Se non si specifica un host, l'accesso alla directory radice viene negato a tutti i client e i gruppi ad esclusione di quelli a cui è stato concesso esplicitamente.

    ro[=host[:host]...]

    Consente l'accesso di sola lettura alla directory condivisa da parte di gruppi o client specificati dall'host. Separare i nomi dei gruppi e dei client con i due punti (:). Se non si specifica un host, l'accesso in sola lettura viene concesso a tutti i client e i gruppi ai quali l'accesso non è stato concesso o negato esplicitamente.

    root[=host[:host]...]

    Consente l'accesso come utente ROOT alla directory condivisa da parte di gruppi o client specificati dall'host. Separare i nomi dei gruppi e dei client con i due punti (:). Se non si specifica un host, l'accesso alla directory radice viene concesso a tutti i client e i gruppi ad esclusione di quelli a cui è stato negato esplicitamente.

    rw[=host[:host]...]

    Consente l'accesso in lettura/scrittura alla directory condivisa da parte di gruppi o client specificati dall'host. Separare i nomi dei gruppi e dei client con i due punti (:). Se non si specifica un host, l'accesso in lettura/scrittura viene concesso a tutti i client e i gruppi ai quali l'accesso non è stato concesso o negato esplicitamente.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
    • nfsshare /?
    • Per impostazione predefinita, quando una directory viene condivisa, a tutti i computer client viene consentito l'accesso di sola lettura mentre viene negato l'accesso anonimo.

Ulteriori riferimenti

  • Proteggere Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Gestire Server per NFS

In questa sezione vengono descritte le procedure seguenti per la gestione di Server per NFS:

  • Creare una risorsa di rete NFS condivisa

  • Configurare le risorse condivise DFS per NFS

  • Gestire gruppi client NFS


Creare una risorsa di rete NFS condivisa

Creare una risorsa di rete NFS condivisa

  • Tramite l'interfaccia di Windows

  • Tramite il prompt dei comandi
Per creare una risorsa condivisa tramite l'interfaccia di Windows

  1. Aprire Esplora risorse: fare clic sul pulsante Start, scegliere Programmi o Tutti i programmi, Accessori e quindi Esplora risorse.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sulla directory condivisa che si desidera gestire.

  3. Scegliere Condivisione NFS.

  4. Selezionare Condividi la cartella.

  5. Digitare un nome per la risorsa condivisa nella casella di testo Nome condivisione.

  6. Fare clic su Applica.

Ulteriori riferimenti

  • Gestire Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)

  • Risolvere i problemi relativi a Servizi per NFS (Network File System)

Per creare una risorsa condivisa tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsshare ShareName=unità:percorso

    Argomento Descrizione

    nomecondivisione

    Nome della directory da condividere.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
    • nfsshare /?

Ulteriori riferimenti

  • Gestire Server per NFS

  • Procedure consigliate per Servizi per NFS (Network File System)


Configurare le risorse condivise DFS per NFS

Configurare le risorse condivise DFS per NFS

Per configurare le risorse condivise DFS per NFS

  1. Configurare un server NFS e creare una risorsa NFS condivisa.

  2. Installare il servizio Client per NFS nel computer in cui è in esecuzione il file system DFS.

  3. Nel server DFS aggiungere un collegamento nel file system DFS che punti alla risorsa condivisa nel server NFS.

  4. Per accedere alla risorsa NFS condivisa da qualsiasi computer, connettersi al server DFS come se si trattasse di un qualsiasi file server Windows.

  5. Passare al collegamento creato.

Ulteriori riferimenti

  • Gestire Server per NFS


Gestire gruppi client NFS

Gestire gruppi client NFS

  • Creare un gruppo client NFS

  • Rinominare un gruppo client NFS

  • Eliminare un gruppo client NFS
Per creare un gruppo client NFS tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [NomeComputer] creategroup NomeGruppo

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    NomeGruppo

    Nome del gruppo da creare.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
    • nfsadmin server /?
    • Non è possibile assegnare a un gruppo lo stesso nome di un client di quel gruppo.

Ulteriori riferimenti

  • Gestire Server per NFS

Per rinominare un gruppo client NFS tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [NomeComputer] renamegroup VecchioNome NuovoNome

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    VecchioNome

    Nome corrente del gruppo che si desidera modificare.

    NuovoNome

    Nuovo nome per il gruppo.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
    • nfsadmin server /?
    • Non è possibile assegnare a un gruppo lo stesso nome di un client di quel gruppo.

Ulteriori riferimenti

  • Gestire Server per NFS

Per eliminare un gruppo client NFS tramite il prompt dei comandi

  1. Aprire il prompt dei comandi con privilegi elevati.

    1. Fare clic sul pulsante Start e quindi scegliere Tutti i programmi.

    2. Fare clic su Accessori, fare clic con il pulsante destro del mouse sull'icona di Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare:

    nfsadmin server [NomeComputer] deletegroup NomeGruppo

    Argomento Descrizione

    NomeComputer

    Nome del computer che si desidera gestire.

    NomeGruppo

    Nome del gruppo da eliminare.

    Note
    • Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare:
    • nfsadmin server /?

Ulteriori riferimenti

  • Gestire Server per NFS


Risolvere i problemi relativi a Servizi per NFS (Network File System)

In questa sezione vengono illustrati alcuni problemi comuni che possono verificarsi durante l'utilizzo di Servizi per NFS (Network File System).

Per ulteriori informazioni su Servizi per NFS, vedere TechCenter di Windows Server (http://go.microsoft.com/fwlink/?LinkId=92798).

  • Nonostante le autorizzazioni assegnate sembrino corrette, l'utente non può accedere a una cartella o un file

  • Gli utenti autenticati non possono accedere alle risorse NFS (Network File System)

  • Gli utenti, inclusi quelli mappati in modo corretto, non possono passare dalla directory corrente a una directory condivisa o creare file nella directory, anche se è consentito l'accesso anonimo alla directory

  • Tutti i file creati in Server per NFS sono di proprietà di un utente anonimo

  • I file creati da un nuovo utente sono di proprietà di un utente anonimo

  • Un utente non può scrivere in un file

  • Gli utenti dei sistemi UNIX in lingua giapponese non possono visualizzare i nomi di file in giapponese

  • Le impostazioni di configurazione di Server per NFS non vengono replicate nei nodi di un cluster di server

  • Server per NFS non si arresta in un cluster di server

  • Non è possibile connettere una risorsa di rete NFS condivisa in un nodo di cluster di server

  • La creazione o la modifica di una risorsa NFS condivisa non riesce e viene generato l'errore seguente: Il percorso della condivisione specificato non esiste oppure si tenta di modificare le proprietà di una condivisione online

  • Mapping nomi utente è configurato correttamente, ma gli utenti non sono mappati correttamente

  • Non è possibile connettere un gruppo contenente una risorsa NFS condivisa in un determinato nodo di server cluster

  • Il comando showmount –e per un server virtuale elenca tutte le risorse condivise nel nodo anziché quelle che si trovano nello stesso gruppo del server virtuale

  • Non sono state concesse autorizzazioni appropriate all'utente ROOT

  • L'accesso anonimo non riesce

Problema riscontrato

Nonostante le autorizzazioni assegnate sembrino corrette, l'utente non può accedere a una cartella o a un file

Causa

L'utente appartiene a uno o più gruppi non mappati in modo coerente, Servizi di dominio Active Directory non è accessibile oppure Mapping nomi utente non è in esecuzione.

Soluzione

Per garantire un accesso corretto ai file, accertarsi che i gruppi Windows e UNIX siano mappati tra loro in Servizi di dominio Active Directory o Mapping nomi utente, che contengano gli stessi utenti e che i membri dei gruppi Windows e UNIX siano mappati correttamente tra loro. Verificare inoltre che Servizi di dominio Active Directory sia accessibile o che il servizio Mapping nomi utente sia in esecuzione nel server designato.

Gli utenti autenticati non possono accedere alle risorse NFS (Network File System)

Causa

Ricerca con Active Directory o Mapping nomi utente non è configurato correttamente per l'interazione con il computer in uso.

Soluzione

Se si utilizza Ricerca con Active Directory, verificare che Servizi per NFS (Network File System) punti al dominio Active Directory corretto.

Se si utilizza Mapping nomi utente, verificare che nel file con estensione maphosts presente nel computer con Mapping nomi utente siano specificati i nomi o gli indirizzi IP dei computer che possono eseguire il mapping di account utente tramite Mapping nomi utente. Se gli utenti non riescono ad accedere saltuariamente alle risorse NFS e la configurazione del file con estensione maphosts non ha risolto il problema, è possibile che troppi computer client tentino di accedere contemporaneamente a Mapping nomi utente.

Gli utenti, inclusi quelli mappati in modo corretto, non possono passare dalla directory corrente a una directory condivisa o creare file nella directory, anche se è consentito l'accesso anonimo alla directory

Causa

Il client NFS non supporta NFS versione 3 oppure Server per NFS non è configurato per supportare NFS 3. L'elenco di controllo di accesso discrezionale (DACL) che protegge la directory condivisa, inoltre, non contiene alcuna voce per Everyone, pertanto il bit della modalità di accesso per Altro è segnalato come 0. Poiché i client NFS 2 si basano sulle impostazioni della modalità della directory e non eseguono un controllo di accesso separato per la directory condivisa, il tentativo del client non riesce.

Soluzione

Eseguire una delle operazioni seguenti:

  • Aggiungere una voce all'elenco di controllo di accesso discrezionale (DACL) che protegge la directory condivisa in modo da garantire accesso in lettura/scrittura a tutti gli utenti (Everyone), come necessario.

  • Verificare che il client NFS supporti NFS 3 e abilitare il supporto NFS 3 da parte di Server per NFS.

La directory condivisa non è accessibile sebbene sia elencata come disponibile.

Causa

La directory è stata spostata dopo essere stata condivisa.

Soluzione

Riportare la directory al percorso originale oppure interrompere la condivisione della directory e quindi condividerla nuovamente.

Tutti i file creati in Server per NFS sono di proprietà di un utente anonimo

Causa

L'autenticazione non è stata configurata correttamente.

Soluzione

Verificare che i mapping siano impostati correttamente in Servizi di dominio Active Directory o in Mapping nomi utente e che Server per NFS sia configurato correttamente per utilizzare Ricerca con Active Directory o Mapping nomi utente. Verificare inoltre che tutti i controller di dominio siano configurati correttamente.

I file creati da un nuovo utente sono di proprietà di un utente anonimo

Causa

Se si utilizza Mapping nomi utente, questo servizio e Server per NFS non hanno ancora eseguito l'aggiornamento dei dati dal server NIS (Network Information Service). In genere, Mapping nomi utente aggiorna i dati da NIS una volta all'ora e Server per NFS li aggiorna a sua volta da Mapping nomi utente una volta all'ora.

Soluzione

Il nuovo utente dovrà attendere almeno due ore prima di tentare di accedere a file o creare file in Server per NFS. In alternativa l'amministratore del computer con Mapping nomi utente può aggiornare il database di mapping.

Un utente non può scrivere in un file

Causa

Le autorizzazioni o gli attributi del file non consentono l'accesso in scrittura al file o alla relativa directory.

Soluzione

Se la directory è di proprietà del gruppo Administrators, impostare un account utente singolo come proprietario della directory. Controllare che l'account UNIX dell'utente sia mappato a un account Windows valido e che le autorizzazioni del file system NTFS sulla directory e sul file consentano l'accesso in scrittura all'account utente Windows. Verificare che sul file o sulla directory non sia impostato l'attributo di sola lettura.

Gli utenti dei sistemi UNIX in lingua giapponese non possono visualizzare i nomi di file in giapponese

Causa

EUC (Extended UNIX Character) non è abilitato.

Soluzione

Configurare la risorsa condivisa affinché venga utilizzata la codifica dei caratteri corretta.

Le impostazioni di configurazione di Server per NFS non vengono replicate nei nodi di un cluster di server

Causa

Il servizio cluster non è in esecuzione, non era in esecuzione quando è stato avviato Server per NFS oppure si è verificato un errore dopo l'avvio di Server per NFS.

Soluzione

Disconnettere tutte le risorse NFS condivise di proprietà del nodo oppure spostare i gruppi di cluster contenenti le risorse NFS condivise in un altro nodo. Arrestare Server per NFS, avviare il servizio cluster se necessario e quindi riavviare Server per NFS. Riconnettere le risorse NFS condivise o spostare i gruppi di cluster nuovamente nel nodo.

Server per NFS non si arresta in un cluster di server

Causa

Si tratta del comportamento normale. Quando una risorsa NFS condivisa è online in un nodo di cluster, il servizio cluster riavvia automaticamente Server per NFS per mantenere online le risorse condivise.

Soluzione

Prima di arrestare Server per NFS in un nodo di cluster di server, disconnettere tutte le risorse NFS condivise di proprietà del nodo oppure spostare i gruppi di cluster contenenti le risorse NFS condivise in un altro nodo.

Non è possibile connettere una risorsa NFS condivisa in un nodo di cluster di server

Causa

Nel nodo esiste già una risorsa NFS condivisa con lo stesso alias o percorso.

Soluzione

Controllare che il percorso condiviso e l'alias siano univoci nel cluster. Evitare inoltre risorse NFS condivise non cluster in un nodo di cluster di server.

Causa

L'utente che ha installato il servizio cluster non dispone di autorizzazioni di lettura sulla directory condivisa, pertanto il percorso non può essere convalidato.

Soluzione

Concedere accesso in lettura alla directory all'utente che ha installato il servizio cluster.

Causa

La risorsa disco contenente la directory condivisa è offline, pertanto il servizio cluster non può verificare il percorso della condivisione.

Soluzione

Connettere la risorsa disco e quindi la risorsa NFS condivisa. È consigliabile che la risorsa NFS condivisa venga resa dipendente dalla risorsa disco che contiene la cartella condivisa.

Causa

Il disco è inaccessibile a causa di un errore hardware.

Soluzione

Disconnettere le risorse NFS condivise sul disco. Verificare che il disco sia accessibile da tutti i nodi del cluster e quindi connettere le risorse NFS condivise.

Causa

È presente un numero elevato di sottodirectory in una condivisione di sole sottodirectory e si verifica un timeout della risorsa prima della creazione di tutte le risorse condivise quando la risorsa viene connessa.

Soluzione

Aumentare l'intervallo di timeout per la risorsa.

La creazione o la modifica di una risorsa NFS condivisa non riesce e viene generato l'errore seguente: Il percorso della condivisione specificato non esiste oppure si tenta di modificare le proprietà di una condivisione online

Causa

La directory specificata non esiste.

Soluzione

Controllare che la directory esista e che il percorso sia corretto.

Causa

La risorsa condivisa è online.

Soluzione

Disconnettere la risorsa condivisa, apportare le modifiche necessarie e quindi riconnetterla.

Causa

La risorsa disco contenente la directory condivisa è offline, pertanto il servizio cluster non può verificare il percorso della condivisione.

Soluzione

Connettere il disco, apportare le modifiche necessarie alla risorsa NFS condivisa e quindi connettere la risorsa NFS condivisa.

Mapping nomi utente è configurato in modo appropriato, ma gli utenti non vengono mappati correttamente

Causa

Server per NFS non è impostato per utilizzare il server Mapping nomi utente corretto.

Soluzione

Verificare che il server Mapping nomi utente specificato sia valido. Se il server Mapping nomi utente si trova in un cluster di server, verificare che sussistano le condizioni seguenti:

  • Mapping nomi utente è installato in tutti i nodi del cluster

  • I dati di Mapping nomi utente vengono replicati in tutti i nodi del cluster

  • Server per NFS utilizza il nome di una risorsa cluster Nome di rete come server Mapping nomi utente. Non utilizza localhost, né il nome di un nodo del cluster

Causa

Server per NFS non ha ricevuto mapping aggiornati dal server di mapping. Se Server per NFS e Mapping nomi utente si trovano in computer diversi, questa operazione viene eseguita ogni 30 minuti.

Soluzione

Forzare Server per NFS affinché aggiorni i mapping eseguendo una delle operazioni seguenti:

  • Utilizzare il comando nfsadmin server per eseguire un'operazione, ad esempio per impostare un valore sul valore corrente.

  • Riavviare Server per NFS.

Causa

Le modifiche agli account nel controller di dominio Windows o nel server NIS (Network Information Service) non sono state ricevute da Mapping nomi utente.

Soluzione

Forzare Server per NFS in modo da aggiornare i mapping eseguendo una delle operazioni seguenti:

  • In Servizi per NFS fare clic su Server per NFS e quindi su Applica.

  • Utilizzare il comando nfsadmin server per eseguire un'operazione, ad esempio per impostare un valore sul valore corrente.

  • Riavviare Server per NFS.

Causa

Gli account locali in un nodo di cluster sono stati mappati ad account utente UNIX. Gli account locali sono validi in tutti i nodi di un cluster.

Soluzione

Verificare che tutti gli account Windows mappati ad account UNIX in Mapping nomi utente in esecuzione in un cluster siano account di dominio Windows.

Causa

I file dei gruppi e delle password non si trovano nello stesso percorso in tutti i nodi del cluster o in un'unità di rete.

Soluzione

Verificare che i file dei gruppi e delle password siano identici e si trovino negli stessi percorsi sui dischi locali di tutti i nodi.

Causa

Il server Server per NFS non si trova nell'elenco dei client Mapping nomi utente consentiti.

Soluzione

Verificare che i file con estensione maphosts in tutti i nodi di cluster di server Mapping nomi utente siano identici per consentire al nodo in cui viene eseguito Server per NFS di ottenere mapping dal server Mapping nomi utente.

Causa

Si è verificato un errore del server in cui viene eseguito Mapping nomi utente.

Soluzione

Correggere la causa dell'errore e riavviare Mapping nomi utente nel server.

Causa

Un account Windows mappato a un account UNIX è disabilitato o non esiste più.

Soluzione

Se l'account Windows esiste, ma è disabilitato, abilitarlo. Se l'account non esiste, creare un nuovo account e, se necessario, ricreare il mapping avanzato corrispondente.

Causa

Un account utente Windows non è stato associato alle credenziali necessarie per accedere alla rete.

Soluzione

Concedere le credenziali necessarie all'account utente di Windows e quindi forzare Server per NFS affinché aggiorni i mapping eseguendo una delle operazioni seguenti:

  • Utilizzare il comando nfsadmin server per eseguire un'operazione, ad esempio per impostare un valore sul valore corrente.

  • Riavviare Server per NFS.

Causa

I gruppi Windows e UNIX mappati tra di loro non contengono gli stessi membri.

Soluzione

Verificare che tutti gli utenti Windows di un gruppo siano mappati a utenti UNIX nel gruppo UNIX corrispondente e che tutti gli utenti UNIX di un gruppo siano mappati a utenti nel gruppo Windows corrispondente.

Causa

Le impostazioni di Mapping nomi utente non sono replicate in modo corretto in tutti i nodi di un cluster di server.

Soluzione

Verificare che Mapping nomi utente in un cluster di server sia configurato in modo corretto per consentire la replica in tutti i nodi.

Non è possibile connettere in un determinato nodo di server cluster un gruppo contenente una risorsa NFS condivisa

Causa

Server per NFS non è installato nel nodo.

Soluzione

Installare Server per NFS nel nodo.

Causa

Il nodo non è configurato come proprietario preferito del gruppo.

Soluzione

Configurare le proprietà del gruppo per rendere il nodo il proprietario preferito del gruppo.

Causa

Per una delle risorse del gruppo il nodo non è elencato come possibile proprietario anche se è specificato come proprietario preferito del gruppo.

Soluzione

Configurare le proprietà della risorsa per specificare il nodo come possibile proprietario.

Il comando showmount -e per un server virtuale elenca tutte le risorse condivise nel nodo anziché quelle che si trovano nello stesso gruppo del server virtuale

Causa

Si tratta del comportamento normale. È presente una sola istanza di Server per NFS in esecuzione in un nodo che enumererà tutte le risorse condivise del nodo. Non viene fatta distinzione tra le risorse condivise in gruppi di cluster diversi.

Soluzione

Gestire gruppi diversi in nodi diversi.

Non sono state concesse autorizzazioni appropriate all'utente ROOT

Causa

Per la risorsa condivisa non è stato abilitato l'accesso alla directory radice.

Soluzione

Fare clic con il pulsante destro del mouse sulla directory condivisa, fare clic su Proprietà, Condivisione NFS, Autorizzazioni e quindi Consenti accesso alla radice.

Causa

Al computer da cui l'utente ROOT accede alla risorsa condivisa non è consentito l'accesso alla directory radice.

Soluzione

Fare clic con il pulsante destro del mouse sulla directory condivisa, fare clic su Proprietà, Autorizzazioni e quindi eseguire una delle operazioni seguenti:

  • Concedere accesso alla directory radice a Tutti i computer.

  • Concedere accesso alla directory radice a un gruppo di client contenente il computer.

  • Concedere accesso alla directory radice al computer.

Causa

L'utente ROOT non dispone di autorizzazione in lettura/scrittura.

Soluzione

Concedere le autorizzazioni appropriate all'utente Windows mappato all'utente ROOT. Fare clic con il pulsante destro del mouse sulla directory condivisa, fare clic su Proprietà, Autorizzazioni e quindi su Accesso alla radice consentito.

Causa

L'account dell'utente ROOT non è mappato correttamente a un account utente di Windows.

Soluzione

Eseguire il mapping dell'utente ROOT a un account Windows del gruppo Administrators o Domain Admins e quindi del gruppo dell'utente ROOT allo stesso gruppo di Windows.

Causa

Server per NFS non ha ricevuto mapping aggiornati da Mapping nomi utente.

Soluzione

Forzare Server per NFS in modo da aggiornare i mapping eseguendo una delle operazioni seguenti:

  • Utilizzare il comando nfsadmin server per eseguire un'operazione, ad esempio per impostare un valore sul valore corrente.

  • Riavviare Server per NFS.

Causa

L'ID utente (UID) dell'utente ROOT non è 0. Server per NFS concede l'accesso alla directory radice solo a un utente UNIX con UID 0.

Soluzione

Impostare l'UID dell'utente ROOT su 0.

L'accesso anonimo non riesce

Causa

I criteri di sicurezza locali non sono impostati per consentire che le autorizzazioni del gruppo Everyone vengano applicate agli utenti anonimi (impostazione predefinita).

Soluzione

Utilizzare lo strumento di gestione dei criteri di sicurezza locali per abilitare Accesso alla rete: applica autorizzazioni account Everyone agli utenti anonimi in Opzioni di sicurezza di Criteri locali.


Proprietà di Server per NFS - Gestione nomi file

La scheda Gestione nomi file consente di determinare il livello di supporto della conversione dei nomi di file garantito da Server per NFS. Per i client UNIX è necessario mantenere la distinzione tra maiuscole e minuscole nei nomi di file. Per impostazione predefinita, con il sistema operativo Windows Server la distinzione tra maiuscole e minuscole non è obbligatoria. Il file system NTFS tuttavia mantiene tale distinzione nei nomi di file. Server per NFS può essere configurato in modo da fornire funzionalità di ricerca con distinzione tra maiuscole e minuscole, nonché il supporto per la conversione di caratteri non consentiti nei file system di client o server.

I mapping di conversione dei caratteri vengono archiviati in un file di testo. I nomi di file contenenti un carattere non supportato verranno convertiti mediante i mapping di caratteri contenuti nel file di conversione.

La distinzione tra maiuscole e minuscole nelle ricerche dei nomi di file è attivata per impostazione predefinita in Server per NFS. È tuttavia possibile ignorare tale impostazione predefinita allo scopo di restituire nomi di file in lettere maiuscole o minuscole. È inoltre possibile configurare i nomi di file preceduti da un punto (.) in modo che il file venga contrassegnato automaticamente come file nascosto in NTFS per garantire l'interoperabilità per l'accesso locale o in rete da client Windows.

Informazioni sul file di conversione caratteri

Nei file system di Windows e UNIX non è consentito l'utilizzo di alcuni caratteri nei nomi di file. I caratteri non consentiti tuttavia non sono gli stessi per entrambi i sistemi operativi. Un nome di file UNIX valido ad esempio può contenere i due punti (:), mentre per un nome di file Windows non è consentito. Se un utente UNIX tenta di creare un file con un nome contenente i due punti in una cartella NFS condivisa di un computer che esegue Windows Server con Server per NFS, l'operazione avrà esito negativo poiché il nome di file contiene un carattere non valido.

È possibile ovviare a questo problema abilitando l'utilizzo di un file di conversione caratteri, come descritto nella sezione precedente. Ogni voce del file esegue il mapping tra un carattere di UNIX e il carattere corrispondente riconosciuto in Windows. Per eseguire il mapping ad esempio tra i due punti (:) in UNIX e il trattino (-) in Windows, il file di conversione dovrà includere la riga seguente:

0x00 0x3a : 0x00 0x2d ; replace client : with - on server

Se questa voce è presente nel file di conversione caratteri dei nomi di file in un computer Server per NFS, quando un client NFS crea un file re:salesquotas in una risorsa condivisa Server per NFS, il file verrà denominato re-salesquotas. Questo è il nome che sarà visibile in Esplora risorse quando gli utenti Windows locali o remoti visualizzeranno il contenuto della cartella condivisa. I client NFS che elencano il contenuto della directory condivisa visualizzeranno il nome di file come re:salesquotas. La conversione dei caratteri viene eseguita per tutti i file condivisi tramite NFS dal server, anche se non sono stati creati da un client NFS.

Il file di conversione caratteri è un semplice file di testo contenente uno o più mapping nel formato:

0xnn 0xnn : 0xnn 0xnn [ ; comment]

Nn (nn) è il valore esadecimale di un byte di un carattere Unicode a due byte e comment è un commento facoltativo, preceduto da un punto e virgola (;). Il testo racchiuso tra il punto e virgola e la fine della riga verrà ignorato. Il primo gruppo di valori esadecimali della voce rappresenta il carattere nel computer client (UNIX), mentre il secondo gruppo rappresenta il carattere utilizzato nel computer Windows che esegue Server per NFS.

Ulteriori considerazioni

  • Non eseguire il mapping tra un punto (.) e un carattere diverso, poiché il punto viene utilizzato nella sintassi dei nomi di file nei file system sia di Windows che di UNIX.

  • Per evitare che utenti non autorizzati possano manomettere il file di conversione caratteri dei nomi di file e causare un errore di Server per NFS, è possibile proteggere il file utilizzando un elenco di controllo di accesso discrezionale (DACL, Discretionary Access Control List) che conceda il controllo completo all'account di sistema incorporato e al gruppo Administrators. L'elenco DACL non deve includere altre voci.


Proprietà di Server per NFS

Proprietà Server NFS consente di configurare il comportamento generale di Server per NFS.


Proprietà di Server per NFS - Blocco

La scheda Blocco di Proprietà Server NFS determina la modalità di gestione delle richieste di blocco dei file da parte di Server per NFS. Se un client NFS (Network File System) richiede il blocco di un file, Server per NFS fornisce il blocco del file per conto del client. Se la sessione viene interrotta prima del completamento dell'operazione, Server per NFS può essere configurato in modo da attendere per un determinato numero di secondi affinché il client si riconnetta e richieda il recupero del blocco prima che venga rimosso.

La scheda Blocco consente inoltre di rimuovere manualmente gli eventuali blocchi di file in attesa.


Proprietà di Server per NFS - Registrazione

Server per NFS supporta la registrazione completa degli eventi nel Visualizzatore eventi, in un file di testo o in entrambi. Utilizzando la scheda Registrazione è possibile stabilire il percorso e il livello di registrazione di Server per NFS.