Bilanciamento carico di rete

È possibile utilizzare Bilanciamento carico di rete in Windows Server 2008 per migliorare la scalabilità e la disponibilità delle applicazioni server. Bilanciamento carico di rete consente inoltre di migliorare le prestazioni del server per essere in grado di gestire le crescenti richieste dei client basati su Internet. In questo argomento vengono fornite informazioni su:

Panoramica di Bilanciamento carico di rete

Elenco di controllo: guida introduttiva a Bilanciamento carico di rete

Installare Bilanciamento carico di rete

Creare cluster di Bilanciamento carico di rete

Gestire cluster di Bilanciamento carico di rete

Impostare i parametri di Bilanciamento carico di rete

Controllare gli host in cluster di Bilanciamento carico di rete

Rimuovere Bilanciamento carico di rete

Risolvere i problemi relativi ai cluster di Bilanciamento carico di rete

Risorse per Bilanciamento carico di rete

Interfaccia utente: Gestione Bilanciamento carico di rete


Panoramica di Bilanciamento carico di rete

La funzionalità Bilanciamento carico di rete di Windows Server 2008 R2 consente di migliorare la disponibilità e la scalabilità di applicazioni server Internet come quelle utilizzate in server Web, FTP, firewall, proxy e di rete privata virtuale (VPN), nonché in altri server di importanza strategica. Un singolo computer che esegue Windows Server 2008 R2 offre un livello limitato di scalabilità delle prestazioni e affidabilità del server. Combinando invece le risorse di due o più computer che eseguono uno dei prodotti di Windows Server 2008 R2 in un unico cluster virtuale, Bilanciamento carico di rete può garantire i livelli di affidabilità e prestazioni necessari per i server Web e altri server di importanza strategica.

Cluster del bilanciamento carico di rete con 4 host

Nel diagramma precedente sono illustrati due cluster di Bilanciamento carico di rete connessi. Il primo cluster è costituito da due host e il secondo cluster include quattro host. Si tratta di un esempio di come può essere utilizzato Bilanciamento carico di rete.

Ogni host esegue una copia separata delle applicazioni server desiderate (ad esempio, applicazioni per server Web, FTP e Telnet). Le richieste client in ingresso vengono distribuite da Bilanciamento carico di rete tra gli host del cluster. Il peso del carico che deve essere gestito da ogni host può essere configurato in base alle esigenze. È inoltre possibile aggiungere host al cluster in modo dinamico per gestire un incremento del carico. Bilanciamento carico di rete può inoltre indirizzare tutto il traffico a un unico host designato, denominato host predefinito.

Bilanciamento carico di rete consente di associare a tutti i computer del cluster lo stesso insieme di indirizzi IP del cluster, mantenendo un insieme di indirizzi IP dedicati univoci per ogni host. Per le applicazioni con carico bilanciato, in caso di errore o disconnessione di un host il carico viene automaticamente ridistribuito tra i computer ancora operativi. In caso di disconnessione o errore imprevisto di un computer, le connessioni attive al server in errore o offline vengono perse. Se invece un host viene disattivato intenzionalmente, è possibile utilizzare il comando drainstop per gestire tutte le connessioni attive prima di disconnettere il computer. In qualsiasi caso, quando il computer offline è pronto, può essere aggiunto nuovamente al cluster in modo trasparente e riottenere la propria parte del carico di lavoro, consentendo agli altri computer del cluster di gestire una minore quantità di traffico.

Gli host di un cluster di Bilanciamento carico di rete scambiano messaggi di tipo heartbeat per mantenere dati coerenti sull'appartenenza al cluster. Per impostazione predefinita, se un host non invia messaggi di tipo heartbeat entro cinque secondi, si è verificato un errore nell'host. In caso di errore in un host, si verifica la convergenza degli host restanti, che eseguono le operazioni seguenti:

  • Stabiliscono quali host sono ancora membri attivi del cluster.

  • Identificano l'host con la priorità massima come nuovo host predefinito.

  • Garantiscono che tutte le nuove richieste client vengano gestite dagli host ancora funzionanti.

Durante una convergenza, gli host ancora funzionanti cercano heartbeat coerenti. Se l'host che non aveva inviato heartbeat fornisce heartbeat in modo coerente, viene aggiunto nuovamente al cluster nel corso della convergenza. Durante un tentativo di aggiunta di un nuovo host al cluster, l'host invia messaggi di tipo heartbeat che attivano una convergenza. Quando tutti i cluster host concordano sull'appartenenza corrente al cluster, il carico di lavoro viene ridistribuito tra gli host restanti e viene completata la convergenza.

La convergenza richiede in genere pochi secondi, pertanto l'interruzione del servizio ai client da parte del cluster risulta minima. Durante la convergenza, gli host ancora attivi continuano a gestire le richieste client senza alcun impatto sulle connessioni esistenti. La convergenza termina quando tutti gli host segnalano una visualizzazione coerente dell'appartenenza al cluster e della mappa di distribuzione per diversi periodi di heartbeat.

Novità di Bilanciamento carico di rete

Bilanciamento carico di rete include in Windows Server 2008 R2 i miglioramenti seguenti:

  • Affinità estesa. L'opzione di affinità estesa garantisce l'affinità dei client quando viene modificata la configurazione di un cluster di Bilanciamento carico di rete. Questa opzione consente inoltre ai client di mantenere l'affinità con un cluster host anche se non sono presenti connessioni esistenti attive dal client all'host.

  • Windows PowerShell per cluster di Bilanciamento carico di rete. Windows PowerShell è una nuova shell da riga di comando e un linguaggio di scripting. Consente di accelerare l'automazione delle attività di amministrazione del sistema. È possibile utilizzare Windows PowerShell per gestire cluster di Bilanciamento carico di rete. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

  • Supporto di aggiornamenti in sequenza. Bilanciamento carico di rete supporta gli aggiornamenti in sequenza da Windows Server 2003 a Windows Server 2008 R2 e da Windows Server 2008 a Windows Server 2008 R2. Per informazioni sulla distribuzione di Bilanciamento carico di rete e sugli aggiornamenti in sequenza, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87253.

Configurazione di Bilanciamento carico di rete

Bilanciamento carico di rete viene eseguito come driver di rete di Windows, con operazioni trasparenti per lo stack di rete TCP/IP.

Relazione tra NLB e altri componenti

Nel diagramma precedente è illustrata la relazione tra Bilanciamento carico di rete e altri componenti software in una configurazione tipica di un host di Bilanciamento carico di rete.

Funzionalità di Bilanciamento carico di rete

Bilanciamento carico di rete include le funzionalità seguenti.

Scalabilità

La scalabilità indica la possibilità di espansione di un computer, un servizio o un'applicazione allo scopo di soddisfare crescenti esigenze in termini di prestazioni. Per i cluster di Bilanciamento carico di rete, la scalabilità rappresenta la possibilità di aggiungere in modo incrementale uno o più sistemi a un cluster esistente quando il carico complessivo del cluster ne supera le capacità. Per supportare la scalabilità, Bilanciamento carico di rete può eseguire le operazioni seguenti:

  • Bilanciamento delle richieste di carico nel cluster di Bilanciamento carico di rete per i singoli servizi TCP/IP.

  • Supporto di un massimo di 32 computer in un singolo cluster.

  • Bilanciamento di più richieste di carico del server (dallo stesso client o da diversi client) tra più host del cluster.

  • Supporto della possibilità di aggiungere host al cluster di Bilanciamento carico di rete in caso di aumento del carico senza arrestare il cluster

  • Supporto della possibilità di rimuovere host dal cluster in caso di riduzione del carico

  • Prestazioni elevate e sovraccarico ridotto grazie a un'implementazione interamente in pipeline. L'utilizzo di una pipeline consente di inviare richieste al cluster di Bilanciamento carico di rete senza attendere la risposta alla richiesta precedentemente inviata.

Disponibilità elevata

Un sistema a disponibilità elevata offre un livello accettabile e affidabile di servizio con tempo di inattività minimo. Per garantire una disponibilità elevata, Bilanciamento carico di rete include funzionalità incorporate in grado di eseguire automaticamente le operazioni seguenti:

  • Rilevamento e ripristino da un cluster host in caso di errore o disconnessione.

  • Bilanciamento del carico di rete in caso di aggiunta o rimozione di host.

  • Ripristino e ridistribuzione del carico di lavoro entro dieci secondi.

Gestibilità

Relativamente alla gestibilità, Bilanciamento carico di rete offre le funzionalità seguenti.

  • È possibile gestire e configurare più cluster di Bilanciamento carico di rete e i cluster host da un unico computer, utilizzando Gestione bilanciamento carico di rete.

  • È possibile specificare il comportamento di bilanciamento del carico per una singola porta IP o un gruppo di porte utilizzando regole di gestione delle porte.

  • È possibile definire regole di porta diverse per ogni sito Web. Se si utilizza lo stesso insieme di server con carico bilanciato per più applicazioni o siti Web, le regole di porta sono basate sull'indirizzo IP virtuale di destinazione (utilizzando cluster virtuali).

  • È possibile indirizzare tutte le richieste client a un unico host mediante regole in host singolo facoltative. Le richieste client vengono indirizzate da Bilanciamento carico di rete a un determinato host che esegue applicazioni specifiche.

  • È possibile bloccare l'accesso di rete indesiderato a determinate porte IP.

  • È possibile abilitare il supporto IGMP (Internet Group Management Protocol) nei cluster host per controllare la quantità di commutatori (in caso di funzionamento in modalità multicast).

  • È possibile avviare, arrestare e controllare le azioni di Bilanciamento carico di rete in remoto da qualsiasi computer in rete che esegue Windows, tramite script o comandi della shell.

  • È possibile visualizzare il registro eventi di Windows per controllare gli eventi di Bilanciamento carico di rete. Tutte le azioni e le modifiche al cluster vengono registrate da Bilanciamento carico di rete nel registro eventi.

Facilità di utilizzo

Bilanciamento carico di rete offre numerose funzionalità che ne semplificano l'utilizzo:

  • Bilanciamento carico di rete viene installato come un componente driver di rete standard di Windows.

  • L'attivazione e l'esecuzione di Bilanciamento carico di rete non richiedono modifiche hardware.

  • Gestione bilanciamento carico di rete consente di creare nuovi cluster di Bilanciamento carico di rete.

  • Gestione bilanciamento carico di rete consente di configurare e gestire più cluster e tutti i cluster host da un unico computer locale o remoto.

  • Bilanciamento carico di rete consente ai client di accedere al cluster utilizzando un unico nome Internet logico e un indirizzo IP virtuale denominato indirizzo IP del cluster, che mantiene i singoli nomi di ogni computer. Bilanciamento carico di rete supporta più indirizzi IP virtuali per server multihomed.

    Nota

    In caso di cluster virtuali, non è necessario che i server siano multihomed per disporre di più indirizzi IP virtuali.

  • Bilanciamento carico di rete può essere associato a più schede di rete. È così possibile configurare più cluster indipendenti in ogni host. Il supporto per più schede di rete è diverso rispetto ai cluster virtuali, poiché i cluster virtuali consentono di configurare più cluster in un'unica scheda di rete.

  • Non è necessario modificare le applicazioni server per l'esecuzione in un cluster di Bilanciamento carico di rete.

  • In caso di errore e successiva riconnessione di un cluster host, Bilanciamento carico di rete può essere configurato in modo da aggiungere automaticamente tale host al cluster. L'host aggiunto potrà quindi iniziare a gestire nuove richieste al server dai client.

  • È possibile disconnettere i computer a scopo di manutenzione preventiva senza influenzare le operazioni cluster negli altri host.

Ulteriori riferimenti

Installare Bilanciamento carico di rete

Elenco di controllo: guida introduttiva a Bilanciamento carico di rete

Creare cluster di Bilanciamento carico di rete

Gestire cluster di Bilanciamento carico di rete

Impostare i parametri di Bilanciamento carico di rete

Controllare gli host in cluster di Bilanciamento carico di rete

Risolvere i problemi relativi ai cluster di Bilanciamento carico di rete

Interfaccia utente: Gestione Bilanciamento carico di rete


Elenco di controllo: guida introduttiva a Bilanciamento carico di rete

Utilizzare l'elenco di controllo seguente come guida introduttiva a Bilanciamento carico di rete.

Attività | Riferimenti
Installare Bilanciamento carico di rete. | Installare Bilanciamento carico di rete
Utilizzare Gestione bilanciamento carico di rete per creare cluster di Bilanciamento carico di rete. | Creare un nuovo cluster di Bilanciamento carico di rete
Configurare parametri degli host, parametri del cluster e regole di porta. | Creare un nuovo cluster di Bilanciamento carico di rete Proprietà di Gestione bilanciamento carico di rete Impostare i parametri di Bilanciamento carico di rete
Aggiungere host al cluster di Bilanciamento carico di rete. | Aggiungere un host al cluster di Bilanciamento carico di rete
Mantenere il corretto controllo degli host nei cluster di Bilanciamento carico di rete. | Arrestare o avviare la gestione del traffico dei cluster di Bilanciamento carico di rete Sospendere o riprendere Bilanciamento carico di rete Disabilitare o abilitare la gestione di tutto il traffico di Bilanciamento carico di rete per porte specifiche Disabilitare la gestione di nuovo traffico di Bilanciamento carico di rete per porte specifiche

Ulteriori considerazioni

  • Quando si utilizza Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure avere ricevuto in delega l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non appartenente al cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Ulteriori riferimenti

  • Panoramica di Bilanciamento carico di rete

  • Risolvere i problemi relativi ai cluster di Bilanciamento carico di rete

  • Risorse per Bilanciamento carico di rete


Installare Bilanciamento carico di rete

Per utilizzare Bilanciamento carico di rete, è necessario che nella scheda del computer in cui è installato Bilanciamento carico di rete sia presente solo TCP/IP. Non aggiungere altri protocolli (ad esempio, IPX) a questa scheda. Bilanciamento carico di rete può bilanciare il carico di qualsiasi applicazione o servizio che utilizza TCP/IP come protocollo di rete ed è associato a una porta TCP (Transmission Control Protocol) o UDP (User Datagram Protocol) specifica.

Per installare e configurare Bilanciamento carico di rete, è necessario utilizzare un account incluso nel gruppo Administrators in ogni host. Se durante l'installazione e la configurazione di ogni host non si utilizza un account del gruppo Administrators, verrà richiesto di specificare le credenziali di accesso di un account di questo tipo. Per impostare un account che verrà utilizzato per impostazione predefinita da Gestione bilanciamento carico di rete, in Gestione bilanciamento carico di rete scegliere Credenziali dal menu Opzioni. È consigliabile non utilizzare questo account per altri scopi.

Per aprire l'Aggiunta guidata funzionalità e installare Bilanciamento carico di rete

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  2. Nell'area Riepilogo funzionalità della finestra principale di Server Manager fare clic su Aggiungi funzionalità.

    oppure

    Nell'area Personalizza server in uso della finestra Attività di configurazione iniziale fare clic su Aggiungi funzionalità.

  3. Nell'Aggiunta guidata funzionalità selezionare la casella di controllo Bilanciamento carico di rete.

  4. Fare clic su Installa.

  5. In alternativa, è possibile installare Bilanciamento carico di rete digitando il comando seguente:

    servermanagercmd.exe -install nlb

  6. Al termine dell'installazione di Bilanciamento carico di rete, è possibile configurare un cluster di Bilanciamento carico di rete mediante Gestione bilanciamento carico di rete.

    Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

Ulteriori riferimenti

Panoramica di Bilanciamento carico di rete

Creare cluster di Bilanciamento carico di rete

Rimuovere Bilanciamento carico di rete


Creare cluster di Bilanciamento carico di rete

Per informazioni su come utilizzare Bilanciamento carico di rete per creare cluster di Bilanciamento carico di rete, vedere gli argomenti seguenti:

Creare un nuovo cluster di Bilanciamento carico di rete

Aggiungere un host al cluster di Bilanciamento carico di rete


Creare un nuovo cluster di Bilanciamento carico di rete

Per configurare il cluster di Bilanciamento carico di rete, è necessario configurare tre tipi di parametri:

  • Parametri degli host, specifici di ogni host di un cluster di Bilanciamento carico di rete.

  • Parametri del cluster, applicati a un intero cluster di Bilanciamento carico di rete.

  • Regole di porta, che controllano il funzionamento del cluster. Per impostazione predefinita, una regola di porta bilancia equamente tutto il traffico TCP/IP tra tutti i server. Per il corretto funzionamento di alcune applicazioni possono essere necessarie regole di porta diverse o aggiuntive. Queste regole predefinite devono essere modificate ad esempio quando si utilizza Bilanciamento carico di rete in un ambiente di Servizi Desktop remoto.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per creare un nuovo cluster di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Fare clic con il pulsante destro del mouse su Cluster Bilanciamento carico di rete e quindi scegliere Nuovo cluster.

  3. Per connettersi all'host da includere nel nuovo cluster, digitare il nome dell'host nella casella di testo Host e quindi fare clic su Connetti.

  4. Selezionare l'interfaccia che si desidera utilizzare con il cluster e quindi fare clic su Avanti. L'interfaccia ospita l'indirizzo IP virtuale e riceve il traffico client per cui deve essere eseguito il bilanciamento del carico.

  5. In Parametri host selezionare un valore in Priorità (identificatore host univoco). Questo parametro specifica un ID univoco per ogni host. L'host con la priorità numerica inferiore tra i membri correnti del cluster gestisce tutto il traffico di rete del cluster non coperto da alcuna regola di porta.

    È possibile ignorare queste priorità oppure impostare il bilanciamento del carico per determinati intervalli di porte specificando regole nella scheda Regole porta della finestra di dialogo Proprietà del bilanciamento carico di rete.

    In Parametri host è inoltre possibile aggiungere indirizzi IP dedicati, se necessario.

  6. Fare clic su Avanti per continuare.

  7. In Indirizzi IP cluster fare clic su Aggiungi e digitare l'indirizzo IP del cluster condiviso da ogni host del cluster. Questo indirizzo IP viene aggiunto da Bilanciamento carico di rete allo stack TCP/IP dell'interfaccia selezionata di tutti gli host che verranno inclusi nel cluster.

    Nota

    Bilanciamento carico di rete non supporta Dynamic Host Configuration Protocol (DHCP). Bilanciamento carico di rete disabilita DHCP in ogni interfaccia configurata, pertanto gli indirizzi IP devono essere statici.

  8. Fare clic su Avanti per continuare.

  9. In Parametri cluster selezionare i valori in Indirizzo IP e subnet mask. Per gli indirizzi IPv6 non è necessario un valore della subnet mask. Digitare il nome Internet completo che verrà utilizzato dagli utenti per accedere al cluster di Bilanciamento carico di rete.

  10. In Modalità operativa del cluster fare clic su Unicast per specificare che per le operazioni cluster dovrà essere utilizzato un indirizzo MAC (Media Access Control) unicast. In modalità unicast, alla scheda di rete del computer viene assegnato l'indirizzo MAC del cluster e l'indirizzo MAC predefinito della scheda di rete non viene utilizzato. È consigliabile accettare le impostazioni predefinite della modalità unicast.

  11. Fare clic su Avanti per continuare.

  12. Se necessario, in Regole porta fare clic su Modifica per modificare le regole di porta predefinite.

  13. Per aggiungere ulteriori host al cluster, fare clic con il pulsante destro del mouse sul nuovo cluster e quindi scegliere Aggiungi host al cluster. Configurare i parametri degli host aggiuntivi, come priorità host, indirizzi IP dedicati e peso del carico, seguendo le stesse istruzioni utilizzate per configurare l'host iniziale. Poiché si aggiungono host a un cluster già configurato, tutti i parametri a livello di cluster rimangono invariati.

Ulteriori considerazioni

  • Per ulteriori informazioni sui parametri degli host, gli indirizzi IP del cluster, i parametri del cluster e le regole di porta, vedere Proprietà di Gestione bilanciamento carico di rete.

Ulteriori riferimenti

Panoramica di Bilanciamento carico di rete

Aggiungere un host al cluster di Bilanciamento carico di rete

Gestire cluster di Bilanciamento carico di rete

Impostare i parametri di Bilanciamento carico di rete

Proprietà di Gestione bilanciamento carico di rete


Aggiungere un host al cluster di Bilanciamento carico di rete

Per aggiungere host a un cluster di Bilanciamento carico di rete, eseguire la procedura seguente.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per assicurarsi che in Gestione bilanciamento carico di rete vengano visualizzate le informazioni più recenti sull'host, fare clic con il pulsante destro del mouse sul cluster e scegliere Aggiorna. Questa operazione è necessaria perché le proprietà dell'host visualizzate in Gestione bilanciamento carico di rete sono una copia delle proprietà dell'host configurate durante l'ultima connessione di Gestione bilanciamento carico di rete a tale host. Quando si sceglie Aggiorna, Gestione bilanciamento carico di rete si connette nuovamente al cluster e visualizza le informazioni aggiornate.

Per aggiungere un host al cluster di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Fare clic con il pulsante destro del mouse nel punto in cui si desidera aggiungere l'host e quindi scegliere Aggiungi host al cluster. Se il cluster non è elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Digitare il nome dell'host e fare clic su Connetti. Le schede di rete disponibili nell'host verranno elencate nella parte inferiore della finestra di dialogo.

  4. Fare clic sulla scheda di rete che si desidera utilizzare per Bilanciamento carico di rete e quindi su Avanti. L'indirizzo IP configurato per questa scheda di rete costituirà l'indirizzo IP dedicato dell'host.

  5. Configurare i restanti parametri dell'host nel modo appropriato e quindi fare clic su Fine.

    Per ulteriori informazioni sull'impostazione dei parametri degli host, vedere Proprietà di Gestione bilanciamento carico di rete.

Ulteriori considerazioni

  • Quando si crea un cluster di Bilanciamento carico di rete, Bilanciamento carico di rete viene associato automaticamente a ogni scheda di rete del cluster.

  • Gli ulteriori host aggiunti dopo il primo host erediteranno automaticamente le regole di porta del cluster dall'host iniziale.

  • Il nuovo cluster host non sarà immediatamente in stato di esecuzione nel cluster. È innanzitutto necessario che le impostazioni del nuovo host circolino in tutti i cluster host.

Ulteriori riferimenti

Proprietà di Gestione bilanciamento carico di rete

Panoramica di Bilanciamento carico di rete

Gestire cluster di Bilanciamento carico di rete

Installare Bilanciamento carico di rete


Gestire cluster di Bilanciamento carico di rete

Per gestire i cluster di Bilanciamento carico di rete, è possibile utilizzare Gestione bilanciamento carico di rete.

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un unico host

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un elenco di host

Configurare le impostazioni del registro di Gestione bilanciamento carico di rete

Rimuovere un host da un cluster di Bilanciamento carico di rete

Eliminare un cluster di Bilanciamento carico di rete


Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un unico host

Per connettersi a un cluster di Bilanciamento carico di rete digitando il nome di un unico host, eseguire la procedura seguente. Quando si seleziona un determinato cluster, tale cluster e tutti gli host in esso inclusi vengono visualizzati in Gestione bilanciamento carico di rete.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un unico host

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Fare clic con il pulsante destro del mouse su Cluster Bilanciamento carico di rete e quindi scegliere Connessione a cluster esistente.

  3. Digitare il nome di un cluster host e quindi fare clic su Connetti. I cluster di Bilanciamento carico di rete esistenti nell'host verranno elencati nella parte inferiore della finestra di dialogo.

  4. Fare clic sul nome del cluster che si desidera gestire in Gestione bilanciamento carico di rete e quindi fare clic su Fine.

Ulteriori considerazioni

Quando si esegue questa procedura, alcuni problemi di rete possono impedire la connessione di Gestione bilanciamento carico di rete a uno o più degli altri host del cluster. Analogamente, in caso di configurazione non corretta del cluster con valori di priorità duplicati in più host, Gestione bilanciamento carico di rete non sarà in grado di connettersi agli host non configurati correttamente. In questi casi, alcuni host non verranno visualizzati in Gestione bilanciamento carico di rete.

Se tutti gli host non vengono visualizzati in Gestione bilanciamento carico di rete, provare a utilizzare un elenco di host. Vedere Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un elenco di host. Per la diagnosi del problema in uno o più cluster host, sono inoltre disponibili informazioni nel registro eventi di Windows.

Ulteriori riferimenti

Gestire cluster di Bilanciamento carico di rete

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un elenco di host


Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un elenco di host

Per connettersi a più host e a tutti i cluster di Bilanciamento carico di rete in tali host, eseguire la procedura seguente. I cluster e gli host verranno quindi visualizzati in Gestione bilanciamento carico di rete. Ciò risulta particolarmente utile quando si verificano problemi di connettività nella scheda di rete di Bilanciamento carico di rete di un host, ma in tale host è disponibile un'altra scheda di rete. È inoltre possibile eseguire questa procedura per il rilevamento e la diagnosi di problemi come la convergenza separata dei cluster host.

L'elenco degli host è un file di testo che può essere creato nei modi seguenti:

  • Digitando un elenco in Blocco note o un'applicazione simile.

  • Esportando un elenco precedentemente aperto con Gestione bilanciamento carico di rete.

Nel file dovrà essere elencato il nome di ogni host, separato da un'interruzione di riga. Nell'elenco degli host è possibile includere commenti anteponendo un punto e virgola (;) al commento.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Se nel registro di Gestione bilanciamento carico di rete viene visualizzato Accesso negato. Errore durante la connessione a "host", è necessario riconnettersi al cluster utilizzando un nome di accesso corrispondente a un membro del gruppo Administrators in tutti gli host. A tale scopo, è possibile accedere con un diverso nome di accesso utilizzando Esegui come oppure specificare un nome di accesso alternativo da utilizzare in Gestione bilanciamento carico di rete scegliendo Credenziali dal menu Opzioni di Gestione bilanciamento carico di rete.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un elenco di host

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Scegliere Carica elenco host dal menu File.

  3. Individuare e selezionare il file di testo dell'elenco degli host e quindi fare clic su Apri.

Ulteriori riferimenti

Gestire cluster di Bilanciamento carico di rete

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un unico host


Configurare le impostazioni del registro di Gestione bilanciamento carico di rete

La registrazione degli eventi in Gestione bilanciamento carico di rete differisce dalla registrazione degli eventi generati dal driver di Bilanciamento carico di rete. In Gestione bilanciamento carico di rete vengono registrati soltanto gli eventi correlati all'utilizzo di Gestione bilanciamento carico di rete. Per visualizzare gli eventi relativi al driver di Bilanciamento carico di rete, è necessario utilizzare il Visualizzatore eventi.

È consigliabile gestire sempre un cluster di Bilanciamento carico di rete da un computer sicuro e attendibile, soprattutto quando è attivata la registrazione eventi. Il file di registro di Gestione bilanciamento carico di rete contiene informazioni potenzialmente riservate sul cluster e sugli host di Bilanciamento carico di rete e deve pertanto essere protetto in modo appropriato. Per impostazione predefinita, il file di registro eredita le impostazioni di sicurezza della directory in cui viene creato. Può essere utile modificare le autorizzazioni esplicite per il file in Limita accesso in lettura e in scrittura per singoli utenti che non necessitano di controllo completo. Un utente che utilizza Gestione bilanciamento carico di rete non necessita di controllo completo sul file di registro.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per configurare le impostazioni del registro di Gestione bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Scegliere Impostazioni registro dal menu Opzioni.

  3. Selezionare Abilita registrazione e specificare un nome e un percorso per il file di registro.

Ulteriori riferimenti

Gestire cluster di Bilanciamento carico di rete

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un unico host

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un elenco di host


Rimuovere un host da un cluster di Bilanciamento carico di rete

Per rimuovere un singolo host da un cluster di Bilanciamento carico di rete, eseguire la procedura seguente. Prima di rimuovere un host dal cluster di Bilanciamento carico di rete, può essere opportuno utilizzare il comando drainstop per disattivare la gestione di nuovo traffico e arrestare Bilanciamento carico di rete. Per ulteriori informazioni, vedere Disabilitare la gestione di nuovo traffico di Bilanciamento carico di rete per porte specifiche.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per rimuovere un host o tutti gli host da un cluster di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Per rimuovere un singolo host, fare clic con il pulsante destro del mouse sull'host in cui si desidera disabilitare Bilanciamento carico di rete e quindi scegliere Elimina host.

Ulteriori riferimenti

Eliminare un cluster di Bilanciamento carico di rete

Gestire cluster di Bilanciamento carico di rete

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un unico host


Eliminare un cluster di Bilanciamento carico di rete

Per eliminare un cluster di Bilanciamento carico di rete, eseguire la procedura seguente.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per eliminare un cluster di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Per eliminare il cluster, fare clic con il pulsante destro del mouse sul cluster in cui si desidera disabilitare Bilanciamento carico di rete e quindi scegliere Elimina cluster. Tutte le connessioni esistenti agli host del cluster verranno perse e il cluster non esisterà più.

Ulteriori riferimenti

Rimuovere un host da un cluster di Bilanciamento carico di rete

Gestire cluster di Bilanciamento carico di rete

Connettersi a cluster di Bilanciamento carico di rete esistenti utilizzando un unico host


Impostare i parametri di Bilanciamento carico di rete

Per impostare i parametri di Bilanciamento carico di rete, è possibile utilizzare Gestione bilanciamento carico di rete.

Configurare i parametri dei cluster di Bilanciamento carico di rete

Configurare la modalità operativa dei cluster di Bilanciamento carico di rete

Configurare i parametri degli host di Bilanciamento carico di rete

Creare una nuova regola di porta di Bilanciamento carico di rete

Modificare una regola di porta di Bilanciamento carico di rete

Rimuovere una regola di porta di Bilanciamento carico di rete


Configurare i parametri dei cluster di Bilanciamento carico di rete

Per configurare i parametri dei cluster di Bilanciamento carico di rete, eseguire la procedura seguente. Questa procedura viene eseguita in un unico host. Tutti gli host erediteranno automaticamente la configurazione del cluster dall'host iniziale. I parametri impostati nella finestra di dialogo Proprietà vengono memorizzati nel Registro di sistema di ogni host.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per assicurarsi che in Gestione bilanciamento carico di rete vengano visualizzate le informazioni più recenti sull'host, fare clic con il pulsante destro del mouse sul cluster e scegliere Aggiorna. Questa operazione è necessaria perché le proprietà dell'host visualizzate in Gestione bilanciamento carico di rete sono una copia delle proprietà dell'host configurate durante l'ultima connessione di Gestione bilanciamento carico di rete a tale host. Quando si sceglie Aggiorna, Gestione bilanciamento carico di rete si connette nuovamente al cluster e visualizza le informazioni aggiornate.

Per configurare i parametri dei cluster di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Fare clic con il pulsante destro del mouse sul cluster e quindi scegliere Proprietà cluster.

  4. Nella scheda Parametri cluster specificare i valori di Indirizzo IP, Subnet mask, Nome Internet completo e Modalità operativa del cluster.
Nota

Le modifiche ai parametri di Bilanciamento carico di rete vengono applicate quando si fa clic su OK nella finestra di dialogo Proprietà. Se si fa clic su OK, Bilanciamento carico di rete verrà arrestato (se in esecuzione), i parametri verranno ricaricati e quindi verranno riavviate le operazioni cluster.

Ulteriori riferimenti

Proprietà di Gestione bilanciamento carico di rete

Configurare i parametri degli host di Bilanciamento carico di rete

Creare una nuova regola di porta di Bilanciamento carico di rete


Configurare la modalità operativa dei cluster di Bilanciamento carico di rete

Per configurare la modalità operativa dei cluster di Bilanciamento carico di rete, eseguire la procedura seguente.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per configurare la modalità operativa dei cluster di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è già elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Fare clic con il pulsante destro del mouse sul cluster e quindi scegliere Proprietà cluster.

  4. Nella scheda Parametri cluster selezionare Unicast o Multicast in Modalità operativa del cluster. Se appropriato, è inoltre possibile abilitare il supporto IGMP (Internet Group Management Protocol) selezionando la casella di controllo Multicast IGMP.

Ulteriori considerazioni

  • I parametri relativi alla modalità operativa del cluster specificano se per le operazioni cluster dovrà essere utilizzato un indirizzo MAC (Media Access Control) multicast. Se è abilitato il multicast, l'indirizzo MAC del cluster per la scheda del cluster viene convertito da Bilanciamento carico di rete in un indirizzo multicast. Viene inoltre verificato che l'indirizzo IP primario del cluster venga risolto in questo indirizzo multicast nell'ambito del protocollo ARP (Address Resolution Protocol). La scheda può ora utilizzare il proprio indirizzo MAC predefinito originale, che era stato disabilitato in modalità unicast.

  • Prima di abilitare il supporto IGMP (Internet Group Management Protocol), è innanzitutto necessario abilitare il supporto multicast. È inoltre possibile abilitare il supporto IGMP nella scheda di rete.

  • La casella di controllo Multicast IGMP abilita il supporto IGMP allo scopo di ridurre la quantità di commutatori limitando il traffico alle sole porte di Bilanciamento carico di rete. Abilitando il supporto IGMP è pertanto possibile garantire che il traffico diretto a un cluster di Bilanciamento carico di rete passi soltanto attraverso le porte collegate ai cluster host e non attraverso tutte le porte di commutazione.

Ulteriori riferimenti

Configurare i parametri dei cluster di Bilanciamento carico di rete

Impostare i parametri di Bilanciamento carico di rete


Configurare i parametri degli host di Bilanciamento carico di rete

Per configurare i parametri degli host di Bilanciamento carico di rete, eseguire la procedura seguente. I parametri impostati nella finestra di dialogo Proprietà vengono memorizzati nel Registro di sistema su ogni host.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per assicurarsi che in Gestione bilanciamento carico di rete vengano visualizzate le informazioni più recenti sull'host, fare clic con il pulsante destro del mouse sul cluster e scegliere Aggiorna. Questa operazione è necessaria perché le proprietà dell'host visualizzate in Gestione bilanciamento carico di rete sono una copia delle proprietà dell'host configurate durante l'ultima connessione di Gestione bilanciamento carico di rete a tale host. Quando si sceglie Aggiorna, Gestione bilanciamento carico di rete si connette nuovamente al cluster e visualizza le informazioni aggiornate.

Per configurare i parametri degli host di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Fare clic con il pulsante destro del mouse sull'host che si desidera configurare e quindi scegliere Proprietà host.

  4. Nella scheda Parametri host specificare i valori di Priorità (identificatore host univoco), Indirizzo IP e Subnet mask e selezionare uno stato iniziale dell'host.
Nota

Le modifiche ai parametri di Bilanciamento carico di rete vengono applicate quando si fa clic su OK nella finestra di dialogo Proprietà. Se si fa clic su OK, Bilanciamento carico di rete verrà arrestato (se in esecuzione), i parametri verranno ricaricati e quindi verranno riavviate le operazioni cluster.

Ulteriori riferimenti

Proprietà di Gestione bilanciamento carico di rete

Impostare i parametri di Bilanciamento carico di rete


Creare una nuova regola di porta di Bilanciamento carico di rete

Le regole di porta controllano il funzionamento di un cluster di Bilanciamento carico di rete. Per ottimizzare il controllo dei diversi tipi di traffico TCP/IP, è possibile impostare regole di porta per controllare come verrà gestito il traffico di rete del cluster in ogni porta. Il metodo con cui viene gestito il traffico di rete di una porta è denominato modalità di filtro. Sono disponibili tre modalità di filtro: Host multipli, Host singolo e Disabilitato.

È inoltre possibile specificare che una modalità di filtro deve essere applicata a un intervallo numerico di porte. A tale scopo, si crea una regola di porta con un insieme di parametri di configurazione che definiscono la modalità di filtro. Ogni regola è costituita dai parametri di configurazione seguenti:

  • Indirizzo IP virtuale a cui la regola dovrà essere applicata

  • Intervallo di porte TCP o UDP a cui la regola dovrà essere applicata

  • Protocolli a cui la regola dovrà essere applicata, ovvero TCP, UDP o entrambi

  • Modalità di filtro che specifica come il cluster gestisce il traffico, come descritto dall'intervallo di porte e dai protocolli

È inoltre possibile selezionare una di tre opzioni per l'affinità del client: Nessuna, Singola o Rete. Le opzioni Singola e Rete vengono utilizzate per garantire che tutto il traffico di rete da un determinato client venga indirizzato allo stesso cluster host. Per consentire la gestione corretta dei frammenti IP da parte di Bilanciamento carico di rete, è consigliabile evitare di utilizzare Nessuna quando si seleziona UDP o Entrambi per l'impostazione del protocollo. Come estensione delle opzioni Singola e Rete è possibile configurare un'impostazione di timeout per mantenere l'affinità client in caso di modifica della configurazione di un cluster di Bilanciamento carico di rete. Questa estensione consente inoltre ai client di mantenere l'affinità con un cluster host anche se non sono presenti connessioni esistenti attive dal client all'host.

Nota

Per impostazione predefinita, tutto il traffico di rete del cluster a cui non vengono applicate regole di porta viene gestito dall'host con la massima priorità host tra i membri correnti del cluster. Questo singolo host gestisce tutto il traffico di rete del cluster, mentre un altro host gestisce il traffico in caso di errore o disconnessione dell'host con priorità massima. Grazie a questo comportamento predefinito, Bilanciamento carico di rete non influisce sul traffico di rete del cluster per le porte che non vengono specificamente gestite con i meccanismi di bilanciamento del carico di Bilanciamento carico di rete. Viene inoltre garantita disponibilità elevata nella gestione del traffico di rete del cluster.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per assicurarsi che in Gestione bilanciamento carico di rete vengano visualizzate le informazioni più recenti sull'host, fare clic con il pulsante destro del mouse sul cluster e scegliere Aggiorna. Questa operazione è necessaria perché le proprietà dell'host visualizzate in Gestione bilanciamento carico di rete sono una copia delle proprietà dell'host configurate durante l'ultima connessione di Gestione bilanciamento carico di rete a tale host. Quando si sceglie Aggiorna, Gestione bilanciamento carico di rete si connette nuovamente al cluster e visualizza le informazioni aggiornate.

Per creare una nuova regola di porta di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Fare clic con il pulsante destro del mouse sul cluster e quindi scegliere Proprietà cluster.

  4. Fare clic sulla scheda Regole porta e quindi su Aggiungi. Utilizzando le informazioni dell'elenco di controllo per la configurazione di Bilanciamento carico di rete, specificare i valori per i parametri seguenti:

    • Indirizzo IP del cluster, ovvero l'indirizzo IP virtuale a cui si desidera applicare la regola. Immettere un indirizzo IP virtuale specifico per creare un cluster virtuale oppure fare clic su Tutti per applicare la regola a tutti gli indirizzi IP virtuali.

    • Intervallo porte

    • Protocolli

    • Modalità filtro

    • Affinità e Peso del carico (in base alle esigenze)

  5. In Timeout impostare il valore con cui si desidera estendere l'opzione di affinità Singola o Rete. In questo modo viene garantita l'affinità dei client quando viene modificata la configurazione di un cluster di Bilanciamento carico di rete. Le impostazioni di timeout sono disponibili solo per le opzioni Singola e Rete.

  6. Fare clic su OK. Verranno applicate le modifiche ai parametri di Bilanciamento carico di rete, Bilanciamento carico di rete verrà arrestato (se in esecuzione), i parametri verranno ricaricati e quindi verranno riavviate le operazioni cluster.

Ulteriori considerazioni

  • Il numero e il tipo di regole devono essere esattamente gli stessi per ogni host nel cluster. Il push delle regole di porta negli host del cluster viene eseguito da Gestione bilanciamento carico di rete.

  • Se si tenta di aggiungere al cluster un host con un numero di regole diverso da quello degli altri host, tale host non viene accettato come parte del cluster e il resto del cluster continua a gestire il traffico come in precedenza. Al tempo stesso viene inserito un messaggio nel registro eventi di Windows. In questo caso, consultare il registro eventi per determinare l'host con un numero di regole in conflitto, risolvere il conflitto e riavviare Bilanciamento carico di rete su tale host.

  • Le regole immesse in ogni host del cluster devono includere indirizzi IP del cluster, intervalli di porte, tipi di protocollo e modalità di filtro corrispondenti.

    Se rileva una regola incoerente tra gli host del cluster, Bilanciamento carico di rete memorizza un messaggio nel registro eventi di Windows. Consultare il registro eventi per determinare l'host interessato e la regola che ha causato il problema. Correggere la regola e riavviare Bilanciamento carico di rete su tale host. Per ulteriori informazioni sulla registrazione degli errori e le operazioni cluster, vedere Ulteriori riferimenti.

  • Quando si utilizza Bilanciamento carico di rete per bilanciare il carico del traffico di una rete privata virtuale (ad esempio PPTP/GRE e IPSEC/L2TP), è necessario configurare le regole di porta applicate alle porte che gestiscono il traffico VPN (porta TCP 1723 per PPTP e porta UDP 500 per IPSEC) in modo da utilizzare l'affinità Singola o Rete.

  • Per consentire la gestione corretta dei frammenti IP da parte di Bilanciamento carico di rete, è consigliabile evitare di utilizzare il valore di affinità Nessuna quando si seleziona UDP o Entrambi per l'impostazione del protocollo. Impostare invece l'affinità su Singola.

  • L'elenco di tutte le regole di porta attualmente installate è ordinato per intervallo di porte.

  • I parametri impostati nella finestra di dialogo Proprietà vengono memorizzati nel Registro di sistema su ogni host.

Ulteriori riferimenti

Impostare i parametri di Bilanciamento carico di rete

Modificare una regola di porta di Bilanciamento carico di rete

Rimuovere una regola di porta di Bilanciamento carico di rete

Configurare le impostazioni del registro di Gestione bilanciamento carico di rete

Proprietà di Gestione bilanciamento carico di rete


Modificare una regola di porta di Bilanciamento carico di rete

Per modificare una regola di porta di Bilanciamento carico di rete esistente, eseguire la procedura seguente.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per assicurarsi che in Gestione bilanciamento carico di rete vengano visualizzate le informazioni più recenti sull'host, fare clic con il pulsante destro del mouse sul cluster e scegliere Aggiorna. Questa operazione è necessaria perché le proprietà dell'host visualizzate in Gestione bilanciamento carico di rete sono una copia delle proprietà dell'host configurate durante l'ultima connessione di Gestione bilanciamento carico di rete a tale host. Quando si sceglie Aggiorna, Gestione bilanciamento carico di rete si connette nuovamente al cluster e visualizza le informazioni aggiornate.

Per modificare una regola di porta di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Fare clic con il pulsante destro del mouse sul cluster e quindi scegliere Proprietà cluster.

  3. Fare clic sulla scheda Regole porta.

  4. Fare clic su una regola nell'elenco Regole porta definite e quindi su Modifica.

  5. Modificare l'indirizzo IP del cluster a cui si desidera applicare la regola e i parametri relativi a intervallo di porte, protocolli e modalità di filtro in base alle esigenze, quindi fare clic su OK.

  6. Nella finestra di dialogo Proprietà fare clic su OK. Verranno applicate le modifiche ai parametri di Bilanciamento carico di rete, Bilanciamento carico di rete verrà arrestato (se in esecuzione), i parametri verranno ricaricati e quindi verranno riavviate le operazioni cluster.

Ulteriori considerazioni

  • Il numero e il tipo di regole devono essere esattamente gli stessi per ogni host nel cluster. A tale scopo, è preferibile utilizzare Gestione bilanciamento carico di rete per configurare le regole relative alle porte. Gli ulteriori host aggiunti tramite Gestione bilanciamento carico di rete ereditano automaticamente le regole di porta del cluster dall'host iniziale.

    Se si tenta di aggiungere al cluster un host con numero o tipo di regole diverso da quello degli altri host, tale host non verrà accettato come parte del cluster. Il resto del cluster continua a gestire il traffico. Al tempo stesso viene inserito un messaggio nel registro eventi di Windows. Consultare il registro eventi per determinare l'host in conflitto con gli altri host del cluster, risolvere il conflitto e quindi riavviare Bilanciamento carico di rete su tale host.

  • L'elenco di tutte le regole di porta attualmente installate è ordinato per intervallo di porte.

  • I parametri impostati nella finestra di dialogo Proprietà vengono memorizzati nel Registro di sistema su ogni host.

Ulteriori riferimenti

Impostare i parametri di Bilanciamento carico di rete

Creare una nuova regola di porta di Bilanciamento carico di rete

Rimuovere una regola di porta di Bilanciamento carico di rete

Configurare le impostazioni del registro di Gestione bilanciamento carico di rete

Proprietà di Gestione bilanciamento carico di rete


Rimuovere una regola di porta di Bilanciamento carico di rete

Per rimuovere una regola di porta di Bilanciamento carico di rete esistente, eseguire la procedura seguente.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

Per assicurarsi che in Gestione bilanciamento carico di rete vengano visualizzate le informazioni più recenti sull'host, fare clic con il pulsante destro del mouse sul cluster e scegliere Aggiorna. Questa operazione è necessaria perché le proprietà dell'host visualizzate in Gestione bilanciamento carico di rete sono una copia delle proprietà dell'host configurate durante l'ultima connessione di Gestione bilanciamento carico di rete a tale host. Quando si sceglie Aggiorna, Gestione bilanciamento carico di rete si connette nuovamente al cluster e visualizza le informazioni aggiornate.

Per rimuovere una regola di porta di Bilanciamento carico di rete

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Fare clic con il pulsante destro del mouse sul nome del cluster e quindi scegliere Proprietà cluster.

  3. Fare clic sulla scheda Regole porta.

  4. Fare clic sulla regola che si desidera rimuovere e quindi su Rimuovi.

  5. Nella finestra di dialogo Proprietà fare clic su OK. Verranno applicate le modifiche ai parametri di Bilanciamento carico di rete, Bilanciamento carico di rete verrà arrestato (se in esecuzione), i parametri verranno ricaricati e quindi verranno riavviate le operazioni cluster.

Ulteriori considerazioni

  • Il numero e il tipo di regole devono essere esattamente gli stessi per ogni host nel cluster. A tale scopo, è preferibile utilizzare Gestione bilanciamento carico di rete per configurare le regole relative alle porte. Gli ulteriori host aggiunti tramite Gestione bilanciamento carico di rete ereditano automaticamente le regole di porta del cluster dall'host iniziale.

    Se si tenta di aggiungere al cluster un host con numero o tipo di regole diverso da quello degli altri host, tale host non verrà accettato come parte del cluster. Il resto del cluster continua a gestire il traffico. Al tempo stesso viene inserito un messaggio nel registro eventi di Windows. Consultare il registro eventi per determinare l'host in conflitto con gli altri host del cluster, risolvere il conflitto e quindi riavviare Bilanciamento carico di rete su tale host.

  • L'elenco di tutte le regole di porta attualmente installate è ordinato per intervallo di porte.

  • I parametri impostati nella finestra di dialogo Proprietà vengono memorizzati nel Registro di sistema su ogni host.

Ulteriori riferimenti

Impostare i parametri di Bilanciamento carico di rete

Creare una nuova regola di porta di Bilanciamento carico di rete

Modificare una regola di porta di Bilanciamento carico di rete

Configurare le impostazioni del registro di Gestione bilanciamento carico di rete

Proprietà di Gestione bilanciamento carico di rete


Controllare gli host in cluster di Bilanciamento carico di rete

Negli argomenti seguenti vengono fornite informazioni sul controllo degli host nei cluster di Bilanciamento carico di rete.

Arrestare o avviare la gestione del traffico dei cluster di Bilanciamento carico di rete

Sospendere o riprendere Bilanciamento carico di rete

Disabilitare o abilitare la gestione di tutto il traffico di Bilanciamento carico di rete per porte specifiche

Disabilitare la gestione di nuovo traffico di Bilanciamento carico di rete per porte specifiche


Arrestare o avviare la gestione del traffico dei cluster di Bilanciamento carico di rete

Per arrestare o avviare la gestione del traffico dei cluster di Bilanciamento carico di rete, eseguire la procedura seguente. Potrebbe essere necessario arrestare e riavviare il traffico dei cluster di Bilanciamento carico di rete nei casi seguenti:

  • Operazioni di risoluzione dei problemi o manutenzione.

  • Risoluzione di problemi delle applicazioni in uno o più host del cluster.

  • Riduzione delle dimensioni del cluster poiché il traffico non richiede più il numero corrente di host.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per arrestare o avviare la gestione del traffico dei cluster di Bilanciamento carico di rete tramite l'interfaccia di Windows

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Se si desidera arrestare le operazioni cluster in tutti i cluster host, fare clic con il pulsante destro del mouse sul cluster, scegliere Controlla host e quindi fare clic su Arresta.

    Se si desidera arrestare il Servizio cluster solo in un determinato host, fare clic con il pulsante destro del mouse sull'host, scegliere Controlla host e quindi fare clic su Arresta.

  4. Se si desidera avviare le operazioni cluster in tutti i cluster host, fare clic con il pulsante destro del mouse sul cluster, scegliere Controlla host e quindi fare clic su Avvia.

    Se si desidera avviare il Servizio cluster solo in un determinato host, fare clic con il pulsante destro del mouse sull'host, scegliere Controlla host e quindi fare clic su Avvia.

Ulteriori considerazioni

  • Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

  • Quando si arresta la gestione del traffico dei cluster di Bilanciamento carico di rete, le connessioni client già in corso vengono interrotte. Per evitare di interrompere le connessioni attive, invece del comando stop è consigliabile utilizzare il comando di controllo del cluster drainstop, che consente all'host di continuare a gestire le connessioni attive ma disabilita tutto il traffico nuovo verso tale host.

  • È possibile riavviare le operazioni cluster arrestate o sospese. Facendo clic su Avvia per il cluster o l'host che si desidera riavviare vengono riavviate le operazioni cluster, ma non viene abilitato l'utilizzo dei comandi di controllo del cluster che sono stati disabilitati tramite un precedente comando di sospensione.

Ulteriori riferimenti

Disabilitare o abilitare la gestione di tutto il traffico di Bilanciamento carico di rete per porte specifiche

Sospendere o riprendere Bilanciamento carico di rete

Controllare gli host in cluster di Bilanciamento carico di rete


Sospendere o riprendere Bilanciamento carico di rete

Può essere necessario sospendere e riprendere Bilanciamento carico di rete per ignorare eventuali comandi di controllo remoto eseguiti. Verranno ignorati tutti i successivi comandi di controllo del cluster, ad eccezione di resume e query. La procedura seguente può essere eseguita sull'intero cluster di Bilanciamento carico di rete o su un singolo host.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per sospendere o riprendere Bilanciamento carico di rete tramite l'interfaccia di Windows

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è già elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Se si desidera sospendere le operazioni cluster in tutti i cluster host, fare clic con il pulsante destro del mouse sul cluster, scegliere Controlla host e quindi fare clic su Sospendi.

    Se si desidera sospendere il Servizio cluster solo in un determinato host, fare clic con il pulsante destro del mouse sull'host, scegliere Controlla host e quindi fare clic su Sospendi.

  4. Se si desidera riprendere le operazioni cluster in tutti i cluster host, fare clic con il pulsante destro del mouse sul cluster, scegliere Controlla host e quindi fare clic su Riprendi.

    Se si desidera avviare il Servizio cluster solo in un determinato host, fare clic con il pulsante destro del mouse sull'host, scegliere Controlla host e quindi fare clic su Riprendi.

Ulteriori considerazioni

  • Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

  • La sospensione di Bilanciamento carico di rete si differenzia dall'arresto della gestione del traffico del cluster di Bilanciamento carico di rete poiché sospendendo Bilanciamento carico di rete viene arrestato Bilanciamento carico di rete sull'host e vengono sospesi tutti i comandi di controllo del cluster sull'host, ad eccezione dei comandi resume e query. L'arresto della gestione del traffico del cluster di Bilanciamento carico di rete sull'host determina l'arresto di Bilanciamento carico di rete sull'host ma non influisce sugli altri comandi di controllo del cluster. Per ulteriori informazioni sul comando stop, vedere Ulteriori riferimenti.

Ulteriori riferimenti

Arrestare o avviare la gestione del traffico dei cluster di Bilanciamento carico di rete

Controllare gli host in cluster di Bilanciamento carico di rete


Disabilitare o abilitare la gestione di tutto il traffico di Bilanciamento carico di rete per porte specifiche

Nella procedura seguente viene descritto come disattivare e bloccare immediatamente la gestione di tutto il traffico di Bilanciamento carico di rete. La disabilitazione della gestione di tutto il traffico influisce su tutte le porte specificate nella regola di porta. Dopo che è stata disabilitata, la gestione del traffico di Bilanciamento carico di rete può essere abilitata in qualsiasi momento.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per disabilitare o abilitare la gestione di tutto il traffico di Bilanciamento carico di rete per porte specifiche tramite l'interfaccia di Windows

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è già elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Fare clic con il pulsante destro del mouse su un host o un cluster e quindi scegliere Controlla porte.

  4. Per disabilitare porte specifiche, selezionare la regola di porta contenente le porte che si desidera disabilitare e quindi fare clic su Disabilita.

    Per abilitare la gestione di tutto il traffico, selezionare la regola di porta contenente le porte che si desidera abilitare e quindi fare clic su Abilita.

Ulteriori considerazioni

  • Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

  • Questa procedura non ha effetto se gli host specificati non hanno avviato operazioni cluster.

Ulteriori riferimenti

Disabilitare la gestione di nuovo traffico di Bilanciamento carico di rete per porte specifiche

Sospendere o riprendere Bilanciamento carico di rete

Controllare gli host in cluster di Bilanciamento carico di rete


Disabilitare la gestione di nuovo traffico di Bilanciamento carico di rete per porte specifiche

Nella procedura seguente viene illustrato come disattivare la gestione di nuovo traffico di Bilanciamento carico di rete per porte specifiche.

Per eseguire l'attività descritta in questa procedura, è inoltre possibile utilizzare Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

Per disabilitare la gestione di nuovo traffico di Bilanciamento carico di rete per porte specifiche tramite l'interfaccia di Windows

  1. Per aprire Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione Bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

  2. Se il cluster non è già elencato in Gestione bilanciamento carico di rete, connettersi al cluster.

  3. Fare clic con il pulsante destro del mouse su un host o un cluster e quindi scegliere Controlla porte.

  4. Per disabilitare la gestione di nuovo traffico, fare clic su Svuota.

    Per disabilitare la gestione di nuovo traffico e arrestare Bilanciamento carico di rete, fare clic su Svuota e arresta.

Ulteriori considerazioni

  • Per utilizzare Gestione bilanciamento carico di rete, è necessario essere membri del gruppo Administrators nell'host che si sta configurando oppure disporre della delega per l'autorità appropriata. Se si configura un cluster o un host eseguendo Gestione bilanciamento carico di rete da un computer non incluso nel cluster, non è necessario essere membri del gruppo Administrators in tale computer.

  • Questa procedura non ha effetto se gli host specificati non hanno avviato operazioni cluster.

  • Svuota disabilita la gestione del nuovo traffico per la regola che contiene la porta specificata nell'intervallo di porte. Non sono consentite nuove connessioni agli host specificati, ma tutte le connessioni attive vengono mantenute. Per disabilitare le connessioni attive, utilizzare il comando Disabilita.

  • Se si esegue il comando Svuota a livello di cluster, verranno svuotate le porte specificate su tutti gli host all'interno del cluster. Se si esegue il comando Svuota a livello di host, le porte verranno svuotate solo sull'host specificato.

Ulteriori riferimenti

Disabilitare o abilitare la gestione di tutto il traffico di Bilanciamento carico di rete per porte specifiche

Sospendere o riprendere Bilanciamento carico di rete

Controllare gli host in cluster di Bilanciamento carico di rete


Rimuovere Bilanciamento carico di rete

In Windows Server 2008 è possibile rimuovere funzionalità installate nel server utilizzando la Rimozione guidata funzionalità.

Per rimuovere Bilanciamento carico di rete, eseguire la procedura seguente.

Per rimuovere Bilanciamento carico di rete

  • Nell'area Riepilogo funzionalità della finestra principale di Server Manager fare clic su Rimuovi funzionalità e quindi su Bilanciamento carico di rete.

    oppure

  • Nell'area Personalizza server in uso della finestra Attività di configurazione iniziale fare clic su Rimuovi funzionalità e quindi su Bilanciamento carico di rete.

    oppure

  • È possibile rimuovere Bilanciamento carico di rete digitando il comando seguente:

    servermanagercmd.exe -remove nlb
Nota

La finestra Attività di configurazione iniziale viene visualizzata per impostazione predefinita quando un membro del gruppo Administrators esegue l'accesso al computer. Server Manager viene visualizzato quando viene chiusa la finestra Attività di configurazione iniziale. È inoltre possibile aprire Server Manager utilizzando i collegamenti disponibili nel menu Start o in Strumenti di amministrazione.

Ulteriori riferimenti

Installare Bilanciamento carico di rete

Panoramica di Bilanciamento carico di rete


Risolvere i problemi relativi ai cluster di Bilanciamento carico di rete

In questa sezione sono elencati alcuni problemi comuni riscontrabili durante l'utilizzo dei cluster di Bilanciamento carico di rete.

Problema riscontrato

  • Dopo l'installazione di Bilanciamento carico di rete e il riavvio di un cluster host, viene visualizzato il messaggio: "È stato rilevato dal sistema un conflitto di indirizzi IP con un altro sistema della rete".

  • Nessuna risposta quando si utilizza il ping per accedere all'indirizzo IP del cluster da una rete esterna.

  • Nessuna risposta quando si utilizza il ping per accedere agli indirizzi IP dedicati di un host da un altro cluster host.

  • Quando si tenta di utilizzare Gestione bilanciamento carico di rete per la connessione a un host del cluster, viene visualizzato l'errore "Host non raggiungibile".

  • Nessuna risposta quando si utilizza Telnet o si tenta di esplorare un computer all'esterno del cluster da un cluster host.

  • Nessuna risposta da uno o più cluster host quando si richiamano i comandi di controllo remoto di Bilanciamento carico di rete da un computer all'esterno del cluster.

  • Nessuna risposta quando si utilizza l'indirizzo IP dedicato di un host per specificare l'host come destinazione di un comando di controllo remoto. Si ottiene invece il risultato desiderato specificando l'host tramite la relativa priorità (ID).

  • La connettività al cluster viene negata ad alcuni utenti, ma non a tutti.

  • Non è possibile visualizzare o modificare le proprietà di Bilanciamento carico di rete utilizzando net config e Strumentazione gestione Windows (WMI).

  • Il server o il client reimposta un numero insolito di connessioni TCP all'indirizzo IP del cluster.

  • Quando si apporta una modifica che causa la convergenza, come l'aggiunta, la rimozione o lo svuotamento di un host, le chiamate di reti private virtuali (VPN) hanno esito negativo.

  • Dopo l'avvio dei cluster host, la relativa convergenza viene avviata ma non viene completata.

  • Nel cluster viene attivato e disattivato lo stato di convergenza.

  • Dopo l'avvio dei cluster host, Bilanciamento carico di rete segnala il completamento della convergenza ma più host sono impostati come host predefinito.

  • Bilanciamento carico di rete non esegue il bilanciamento del carico delle applicazioni e l'host predefinito gestisce tutto il traffico di rete.

  • Il traffico viene alternato in modo imprevisto tra i cluster host e interrompe le connessioni TCP.

  • Il bilanciamento del carico del traffico di rete non viene eseguito uniformemente tra i cluster host.

  • Quando si utilizza Bilanciamento carico di rete con Microsoft Internet Security and Acceleration (ISA) Server, un cluster host registra i pacchetti bloccati diretti all'indirizzo IP (Internet Protocol) di un altro host.

  • È impossibile creare un cluster di Bilanciamento carico di rete in un ambiente con versione a 64 bit.
Dopo l'installazione di Bilanciamento carico di rete e il riavvio di un cluster host, viene visualizzato il messaggio: "È stato rilevato dal sistema un conflitto di indirizzi IP con un altro sistema della rete".
  • Causa: nella rete esiste già lo stesso indirizzo IP.

  • Soluzione: scegliere un nuovo indirizzo IP o rimuovere l'indirizzo duplicato.

  • Causa: negli host sono state configurate modalità operative del cluster diverse (Unicast o Multicast), di conseguenza viene eseguito il mapping di due indirizzi MAC diversi allo stesso indirizzo IP.

  • Soluzione: verificare che per tutti gli host sia stata configurata la stessa modalità operativa del cluster.

  • Causa: l'indirizzo IP del cluster è stato configurato prima dell'associazione di Bilanciamento carico di rete alla scheda di rete.

  • Soluzione: rimuovere l'indirizzo IP del cluster dalle proprietà TCP/IP, abilitare Bilanciamento carico di rete nella scheda appropriata e quindi configurare l'indirizzo IP del cluster.

  • Causa: l'indirizzo IP del cluster è stata aggiunto a una scheda di rete non abilitata per Bilanciamento carico di rete.

  • Soluzione: rimuovere l'indirizzo IP del cluster dalle proprietà TCP/IP della scheda non corretta, abilitare Bilanciamento carico di rete nella scheda appropriata e quindi configurare l'indirizzo IP del cluster.

Per ulteriori informazioni su come abilitare Bilanciamento carico di rete, vedere Installare Bilanciamento carico di rete

Nessuna risposta quando si utilizza il comando ping per accedere all'indirizzo IP del cluster da una rete esterna.

Verificare di poter utilizzare ping per accedere agli indirizzi IP dedicati dei cluster host da un computer all'esterno del router. Se il test ha esito negativo e si utilizzano più schede di rete, il problema non riguarda Bilanciamento carico di rete. Se si utilizza un'unica scheda di rete per gli indirizzi IP dedicati e del cluster, considerare le cause seguenti.

  • Causa: se si utilizza il supporto multicast, è possibile che il router riscontri difficoltà nella risoluzione dell'indirizzo IP primario in un indirizzo MAC (Media Access Control) multicast mediante il protocollo ARP (Address Resolution Protocol).

  • Soluzione: verificare di poter utilizzare il comando ping per accedere al cluster da un client nella subnet del cluster e per accedere agli indirizzi IP dedicati dei cluster host da un computer all'esterno del router. In caso di funzionamento non corretto di questi test, è probabile che il problema sia causato dal router. Per aggirare il problema, dovrebbe essere possibile aggiungere una voce ARP statica al router. È inoltre possibile disabilitare il supporto multicast di Bilanciamento carico di rete e utilizzare un indirizzo di rete unicast senza hub.

  • Causa: quando si utilizza Bilanciamento carico di rete in modalità multicast o unicast, i router devono accettare le risposte ARP dei proxy (mapping da indirizzi IP a indirizzi di rete ricevuti con un indirizzo di origine di rete diverso nel frame Ethernet).

  • Soluzione: verificare che nel router sia attivato il supporto ARP proxy. È inoltre possibile impostare una voce ARP statica per mantenere disabilitato il supporto ARP proxy nel router.

  • Causa: il traffico ICMP (Internet Control Message Protocol) verso il cluster è bloccato da un router o da un firewall.

  • Soluzione: consentire il traffico ICMP attraverso il router o il firewall. Ciò potrebbe esporre il sistema a ulteriori rischi per la sicurezza.

Nessuna risposta quando si utilizza il ping per accedere agli indirizzi IP dedicati di un host da un altro cluster host.
  • Causa: quando si utilizza Bilanciamento carico di rete in modalità multicast o unicast, i router devono accettare le risposte ARP dei proxy (mapping da indirizzi IP a indirizzi di rete ricevuti con un indirizzo di origine di rete diverso nel frame Ethernet).

  • Soluzione: verificare che nel router sia attivato il supporto ARP proxy. È inoltre possibile impostare una voce ARP statica per mantenere disabilitato il supporto ARP proxy nel router.

  • Causa: il traffico ICMP (Internet Control Message Protocol) verso il cluster è bloccato da un router o da un firewall.

  • Soluzione: consentire il traffico ICMP attraverso il firewall o il router. Ciò potrebbe esporre il sistema a ulteriori rischi per la sicurezza.

Quando si tenta di utilizzare Gestione Bilanciamento carico di rete per la connessione a un host del cluster, viene visualizzato l'errore "Host non raggiungibile".
  • Causa: il traffico ICMP (Internet Control Message Protocol) verso l'host è bloccato da un router o da un firewall oppure è disabilitato nella scheda di rete dell'host.

  • Soluzione: abilitare ICMP nella scheda di rete dell'host oppure consentire il traffico ICMP attraverso il firewall o il router. Ciò potrebbe esporre il sistema a ulteriori rischi per la sicurezza. È inoltre possibile utilizzare l'opzione /noping di Gestione Bilanciamento carico di rete.

Nessuna risposta quando si utilizza Telnet o si tenta di esplorare il contenuto di un computer all'esterno del cluster da un cluster host.
  • Causa: verificare di poter utilizzare il comando ping per accedere al computer all'esterno del cluster. Se questo test ha esito positivo, è possibile che l'indirizzo IP dedicato dell'host non sia stato inserito per primo nelle proprietà TCP/IP.

  • Soluzione: se l'accesso al computer all'esterno del cluster tramite il ping ha esito negativo, vedere i problemi seguenti, precedentemente descritti in questo argomento per la risoluzione dei problemi:

    • Nessuna risposta quando si utilizza il ping per accedere all'indirizzo IP del cluster da una rete esterna.

    • Nessuna risposta quando si utilizza il comando ping per accedere agli indirizzi IP dedicati di un host da un altro cluster host.

Nessuna risposta da uno o più cluster host quando si richiamano i comandi di controllo remoto di Bilanciamento carico di rete da un computer all'esterno del cluster.
  • Causa: i comandi di controllo remoto non vengono inviati all'indirizzo IP del cluster.

  • Soluzione: i comandi devono essere inviati all'indirizzo IP primario del cluster, assegnato nella finestra di dialogo Proprietà del bilanciamento carico di rete. Verificare che i comandi remoti vengano inviati all'indirizzo IP corretto.

  • Causa: il traffico di controllo remoto viene crittografato tramite IPSec (Internet Protocol Security). I comandi di controllo remoto di Bilanciamento carico di rete non funzionano correttamente se inviati da un computer in cui la configurazione di IPSec determina la crittografia del traffico di controllo remoto tramite IPSec.

  • Soluzione: disabilitare IPSec.

    Per ulteriori informazioni, vedere il contenuto della Guida relativo a IPSec (Internet Protocol Security).

  • Causa: le porte di controllo UDP di Bilanciamento carico di rete sono protette in modo non corretto da un firewall. Per impostazione predefinita, i comandi di controllo remoto vengono inviati alle porte UDP 1717 e 2504 dell'indirizzo IP del cluster.

  • Soluzione: verificare che queste porte non siano state bloccate in modo non corretto da un router o da un firewall. È inoltre possibile modificare il numero di porta modificando il parametro corrispondente di Bilanciamento carico di rete.

Nessuna risposta quando si utilizza l'indirizzo IP dedicato di un host per specificare l'host come destinazione di un comando di controllo remoto. Si ottiene invece il risultato desiderato specificando l'host tramite la relativa priorità (ID).
  • Causa: nessun host dispone di un indirizzo IP dedicato.

  • Soluzione: assegnare un indirizzo IP dedicato a ogni host. Per ulteriori informazioni, vedere Configurare i parametri degli host di Bilanciamento carico di rete.

La connettività al cluster viene negata ad alcuni utenti, ma non a tutti.
  • Causa: un'applicazione con carico bilanciato non risponde.

  • Soluzione: si tratta di un problema specifico dell'applicazione non correlato a Bilanciamento carico di rete. Per risolvere il problema, vedere la documentazione dell'applicazione. Potrebbe essere necessario arrestare e riavviare l'applicazione.

  • Causa: se il cluster è configurato per la modalità unicast, è possibile che l'indirizzo MAC della scheda di rete sottoposta a bilanciamento del carico di rete sia stato memorizzato in un commutatore.

  • Soluzione: cancellare il mapping da porta a indirizzo MAC nel commutatore.

  • Causa: l'indirizzo IP del cluster non è stato aggiunto a TCP/IP in uno o più host.

  • Soluzione: se non si utilizza Gestione bilanciamento carico di rete per configurare il cluster, è necessario configurare manualmente l'indirizzo IP del cluster in TCP/IP.

  • Causa: un host sta abbandonando il cluster a causa di un comando drainstop o stop, ma la convergenza non è stata completata correttamente.

  • Soluzione: attendere il completamento della convergenza. Se la convergenza non viene completata, vedere il problema seguente più avanti in questo argomento per la risoluzione dei problemi:

    Dopo l'avvio dei cluster host, la relativa convergenza viene avviata ma non viene completata

Non è possibile visualizzare o modificare le proprietà di Bilanciamento carico di rete utilizzando net config e Strumentazione gestione Windows (WMI).
  • Causa: per visualizzare o modificare le proprietà di Bilanciamento carico di rete, è necessario essere membri del gruppo Administrators.

  • Soluzione: accedere come utente incluso nel gruppo Administrators locale del computer che esegue Bilanciamento carico di rete.

Il server o il client reimposta un numero insolito di connessioni TCP all'indirizzo IP del cluster.
  • Causa: negli host di Bilanciamento carico di rete sono abilitati i valori keep-alive HTTP e client abilitati all'uso di valori keep-alive stanno eseguendo la connessione al cluster.

  • Soluzione: disabilitare i valori keep-alive HTTP. Per ulteriori informazioni sui valori keep-alive HTTP e Internet Information Services (IIS), vedere l'insieme della documentazione di IIS.

    Per visualizzare l'insieme della documentazione di IIS dal desktop, installare IIS, quindi fare clic sul pulsante Start, scegliere Esegui e digitare il comando seguente nella casella di testo Apri:

    %windir%\help\iisrv.chm

  • Causa: le connessioni vengono rifiutate da TCP a causa di risorse di sistema insufficienti nel server.

  • Soluzione: liberare risorse di sistema, ad esempio aggiungendo memoria di sistema aggiuntiva oppure chiudendo le applicazioni non necessarie.

  • Causa: a seguito della divisione del cluster in due cluster con convergenza separata, più nodi richiedono la proprietà di ogni connessione.

  • Soluzione: rimuovere i due cluster e quindi ricreare un unico cluster.

Quando si apporta una modifica che causa la convergenza, come l'aggiunta, la rimozione o lo svuotamento di un host, le chiamate di reti private virtuali (VPN) hanno esito negativo.
  • Causa: quando si utilizza Bilanciamento carico di rete per bilanciare il carico del traffico VPN, è necessario configurare le regole di porta applicate alle porte che gestiscono il traffico VPN (porta TCP 1723 per PPTP/GRE e porta UDP 500 per IPSEC/L2TP) in modo da utilizzare l'affinità Singola o Rete.

  • Soluzione: configurare le regole di porta applicate alle porte 500 e 1723 in modo da utilizzare l'affinità Singola o Rete. Per ulteriori informazioni, vedere Proprietà di Gestione bilanciamento carico di rete.

Dopo l'avvio dei cluster host, la relativa convergenza viene avviata ma non viene completata.
  • Causa: in cluster host diversi è stato immesso un numero di regole di porta diverso oppure sono state specificate regole di porta incompatibili. Ciò impedisce la convergenza.

  • Soluzione: aprire la finestra di dialogo Proprietà del bilanciamento carico di rete in ogni cluster host e verificare che tutti gli host dispongano di regole di porta identiche.

  • Causa: una scheda o un cavo di rete non funziona.

  • Soluzione: utilizzare il comando ping per testare la connettività. Immettere il nome di dominio completo dell'host. È inoltre possibile ottenere ulteriori informazioni sul problema utilizzando il comando ping per eseguire ricerche nel controller di dominio in base all'indirizzo IP e negli altri server di rete in base a nome e indirizzo IP.

  • Causa: in un commutatore o un hub sono presenti impostazioni duplex non corrispondenti.

  • Soluzione: verificare la corretta configurazione delle impostazioni duplex di ogni commutatore o hub.

  • Causa: l'indirizzo IP dedicato che è stato utilizzato per un host è già presente in rete.

  • Soluzione: scegliere un nuovo indirizzo IP o rimuovere l'indirizzo duplicato.

  • Causa: il cluster contiene host che eseguono Windows 2000.

  • Soluzione: in tutti gli host del cluster deve essere eseguito Windows Server 2008. Un ambiente cluster di Bilanciamento carico di rete che include host con Windows Server 2003 e Windows Server 2008 è supportato solo per l'esecuzione di un aggiornamento in sequenza a Windows Server 2008. La combinazione di Windows Server 2003 e Windows Server 2008 nello stesso cluster non è supportata per periodi di tempo prolungati.

  • Causa: negli host sono state configurate modalità operative del cluster diverse (unicast e multicast).

  • Soluzione: utilizzare Gestione bilanciamento carico di rete per verificare che per tutti gli host sia stata configurata la stessa modalità operativa del cluster.

Nota

È inoltre possibile visualizzare i registri eventi di Windows per verificare l'eventuale presenza di errori e avvisi. Per ulteriori informazioni, vedere Installare Bilanciamento carico di rete.

Nel cluster viene attivato e disattivato lo stato di convergenza.
  • Causa: gli heartbeat vanno perduti a causa di una connettività di rete intermittente determinata da una scheda o un cavo di rete non funzionante o da altri problemi di rete.

  • Soluzione: utilizzare il comando ping per testare la connettività. Immettere il nome di dominio completo dell'host. È inoltre possibile ottenere ulteriori informazioni sul problema utilizzando il comando ping per eseguire ricerche nel controller di dominio in base all'indirizzo IP e negli altri server di rete in base a nome e indirizzo IP.

Dopo l'avvio dei cluster host, Bilanciamento carico di rete segnala il completamento della convergenza ma più host sono impostati come host predefinito.
  • Causa: i cluster host sono stati inclusi in subnet diverse e non è pertanto possibile accedere a tutti gli host nella stessa rete.

  • Soluzione: verificare che tutti i cluster host siano in grado di comunicare tra loro.

  • Causa: viene utilizzato un commutatore di livello 3.

  • Soluzione: inserire un commutatore di livello 2 tra gli host e il commutatore di livello 3.

  • Causa: un guasto in un commutatore ridondante ha determinato la separazione del cluster in due cluster e sono stati pertanto creati due host predefiniti.

  • Soluzione: rimuovere i due cluster e quindi creare un unico cluster.

  • Causa: il commutatore è configurato in modo da rifiutare i pacchetti di broadcast.

  • Soluzione: configurare il commutatore in modo da accettare i pacchetti di broadcast (ciò potrebbe causare rischi per la sicurezza) oppure configurare il cluster di Bilanciamento carico di rete in modo da utilizzare la modalità multicast.

  • Causa: un host non è in grado di inviare o ricevere heartbeat.

  • Soluzione: utilizzare il comando ping per testare la connettività con ognuno degli host. Immettere il nome di dominio completo dell'host.

  • Causa: un host è collegato alla porta errata del commutatore.

  • Soluzione: utilizzare la porta corretta del commutatore.

Bilanciamento carico di rete non esegue il bilanciamento del carico delle applicazioni e l'host predefinito gestisce tutto il traffico di rete.
  • Causa: manca una regola di porta. Per impostazione predefinita, Bilanciamento carico di rete indirizza tutto il traffico di rete in ingresso a cui non vengono applicate regole di porta all'host predefinito, in modo da garantire il funzionamento corretto delle applicazioni di cui non si desidera bilanciare il carico.

  • Soluzione: per bilanciare il carico di un'applicazione nel cluster, in ogni cluster host creare una regola di porta per le porte TCP/IP gestite dall'applicazione.

  • Causa: è stato aggiunto un secondo host a un cluster con host singolo, ma il secondo host non è configurato correttamente. Non viene eseguita la convergenza del cluster e l'host originale continua a gestire tutto il traffico.

  • Soluzione: esaminare attentamente e correggere (se necessario) ogni impostazione del secondo host, ad esempio l'indirizzo IP del cluster, l'indirizzo IP dedicato e le regole di porta.

  • Causa: se il cluster è configurato per la modalità unicast, è possibile che l'indirizzo MAC della scheda di rete sottoposta a bilanciamento del carico di rete sia stato memorizzato in un commutatore.

  • Soluzione: cancellare il mapping tra la porta e l'indirizzo MAC nel commutatore.

  • Causa: un server proxy invia tutte le connessioni che utilizzano un unico indirizzo IP al cluster in modalità affinità singola.

  • Soluzione: configurare il server proxy in modo da utilizzare più indirizzi IP.

Il traffico viene alternato in modo imprevisto tra i cluster host e interrompe le connessioni TCP.
  • Causa: gli indirizzi di rete unicast causano problemi con l'hub di commutazione. Se si utilizza un hub di commutazione per l'interconnessione dei cluster host, è necessario utilizzare il supporto multicast di Bilanciamento carico di rete. In caso contrario, il commutatore può presentare un funzionamento non corretto quando la stessa rete unicast viene utilizzata in più porte di commutazione.

  • Soluzione: verificare che nella finestra di dialogo Proprietà del bilanciamento carico di rete sia stato selezionato il supporto multicast. Se non si desidera utilizzare il supporto multicast, per l'interconnessione dei cluster host è possibile utilizzare un hub o un cavo coassiale, anziché un commutatore.

Il bilanciamento del carico del traffico di rete non viene eseguito uniformemente tra i cluster host.
  • Causa: il traffico di rete proviene da un numero limitato di indirizzi IP, probabilmente a causa dell'impostazione in un server proxy.

  • Soluzione: configurare il server proxy in modo da utilizzare più indirizzi IP.

Quando si utilizza Bilanciamento carico di rete con Microsoft Internet Security and Acceleration (ISA) Server, un cluster host registra i pacchetti bloccati diretti all'indirizzo IP (Internet Protocol) dedicato di un altro host.
  • Causa: un cluster host è configurato con identificatore della priorità host uguale a 1.

  • Soluzione: non configurare alcun cluster host con un identificatore della priorità host 1. Utilizzare numeri maggiori di 1. Per ulteriori informazioni, vedere Configurare i parametri degli host di Bilanciamento carico di rete.

È impossibile creare un cluster di Bilanciamento carico di rete in un ambiente con versione a 64 bit.
  • Causa: è possibile che non venga eseguita la versione di Bilanciamento carico di rete appropriata per l'ambiente. Bilanciamento carico di rete non supporta la creazione di un cluster in caso di utilizzo della versione a 32 bit di Bilanciamento carico di rete in un computer con versione a 64 bit. È possibile che questo problema non sia stato rilevato poiché i componenti di Bilanciamento carico di rete a 32 bit (nlb.exe, wlbs.exe e nlbmgr.exe) risultano eseguiti correttamente nell'ambiente con versione a 64 bit.

  • Soluzione: se si intende utilizzare un ambiente di computer con versione a 64 bit, è necessario utilizzare la versione di Bilanciamento carico di rete a 64 bit.

Note
  • Negli argomenti seguenti vengono illustrati diversi problemi comuni riscontrabili durante l'installazione e l'utilizzo iniziale di Bilanciamento carico di rete. Vengono descritte le probabili cause di ogni problema e una o più soluzioni. Questi argomenti presuppongono che il sistema e le applicazioni in uso soddisfino i requisiti minimi per Bilanciamento carico di rete. Per ulteriori informazioni, vedere Panoramica di Bilanciamento carico di rete e Installare Bilanciamento carico di rete.
  • Prima di installare Bilanciamento carico di rete, è consigliabile testare il corretto funzionamento della rete e di tutte le schede di rete. Eseguire l'intera procedura di installazione e verificare che i parametri del cluster e le regole di porta siano stati impostati in modo identico per tutti i cluster host. In caso di problemi, verificare sempre l'eventuale presenza di un messaggio del driver di Bilanciamento carico di rete nel registro eventi di Windows. Per ulteriori informazioni, vedere le sezioni relative ai parametri del cluster, ai parametri degli host e alle regole di porta in Proprietà di Gestione bilanciamento carico di rete.


Risorse per Bilanciamento carico di rete

Per ulteriori informazioni su Bilanciamento carico di rete, vedere le risorse seguenti nel sito Web Microsoft:

  • Per ulteriori informazioni sull'utilizzo di Windows PowerShell per i cluster di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140180.

  • Per informazioni sulla distribuzione di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87253.

  • Per istruzioni sulla configurazione di Bilanciamento carico di rete con Servizi Desktop remoto, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80406.

  • Per informazioni sulla risoluzione dei problemi relativi a Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87255.

  • Per informazioni sulla progettazione di Windows Server 2003 in relazione a Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87250.

  • Per informazioni di riferimento tecnico su Windows Server 2003 in relazione a Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87249.

  • Per informazioni sulla distribuzione di Windows Server 2003 in relazione a Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87251.


Interfaccia utente: Gestione Bilanciamento carico di rete

In questa sezione vengono descritte le proprietà di Gestione bilanciamento carico di rete.

Proprietà di Gestione bilanciamento carico di rete


Proprietà di Gestione bilanciamento carico di rete

Nella tabella seguente sono descritte le proprietà relative a Bilanciamento carico di rete.

Proprietà di Bilanciamento carico di rete

Scheda Descrizione

Indirizzi IP cluster

Il parametro Indirizzo IP specifica l'indirizzo IP primario del cluster. Negli indirizzi IPv4 viene utilizzata la notazione puntata standard di Internet, ad esempio w.x.y.z. Gli indirizzi IPv6 sono costituiti da indirizzi di 16 byte, in genere espressi nella notazione esadecimale con due punti. Nella notazione esadecimale con due punti vengono utilizzati otto numeri esadecimali di quattro cifre, con blocchi di 16 bit (i numeri di 4 cifre) separati da due punti.

Per semplificare la gestione degli indirizzi, in IPv6 vengono eliminati gli zeri iniziali e un singolo blocco contiguo di 16 bit costituito interamente da zeri viene compresso e rappresentato con due segni di due punti (::). Questa procedura è denominata compressione con doppio segno di due punti. Di seguito è riportato un esempio di indirizzo IPv6 con gli zeri iniziali eliminati:

FEC0:0:0:0:2AA:FF:FE3F:2A1C

L'indirizzo è un indirizzo IP virtuale e deve essere impostato in modo identico per tutti gli host del cluster. Questo indirizzo IP viene utilizzato per l'intero cluster e dovrà corrispondere all'indirizzo IP mappato al nome Internet completo specificato per il cluster.

Se si desidera aggiungere più indirizzi IP al cluster, fare clic su Aggiungi per immettere gli indirizzi IP aggiuntivi. In caso di configurazione di un cluster di bilanciamento del carico in una rete privata virtuale (VPN), non è consigliabile configurare l'indirizzo IP dedicato. In una VPN è necessario che su ognuno dei cluster host sia presente solo l'indirizzo IP del cluster.

Parametri cluster
  • Il parametro Indirizzo IP specifica l'indirizzo IP primario del cluster nella notazione puntata standard di Internet, ad esempio w.x.y.z. È possibile selezionare un diverso indirizzo IP per il cluster facendo clic sull'elenco a discesa.

  • Il parametro Subnet mask indica la subnet mask per l'indirizzo IP specificato. La subnet mask viene espressa nella notazione puntata standard di Internet, ad esempio 255.255.255.0. Ciò può essere riscontrato solo quando l'indirizzo IP del cluster è costituito da un indirizzo IPv4.

  • Il parametro Nome Internet completo specifica un nome Internet completo per il cluster di Bilanciamento carico di rete, ad esempio cluster.microsoft.com. Questo nome verrà utilizzato per l'intero cluster e dovrà risultare uguale per tutti gli host del cluster. Se per il cluster sono presenti diversi nomi con alias, immettere il nome primario (principale), che dovrà essere risolvibile nell'indirizzo IP primario del cluster tramite il server DNS o il file hosts.

  • Il parametro Indirizzo di rete specifica l'indirizzo MAC (Media Access Control) per la scheda di rete da utilizzare per la gestione del traffico da client a cluster. Se il supporto multicast viene disabilitato, nell'host viene ripristinata la modalità unicast. Bilanciamento carico di rete indica automaticamente al driver appartenente alla scheda del cluster di ignorare l'indirizzo di rete univoco predefinito della scheda e di sostituire il relativo indirizzo MAC con l'indirizzo MAC del cluster. Questo è l'indirizzo utilizzato su tutti i cluster host. Non è necessario configurare manualmente la scheda di rete per riconoscere tale indirizzo.

    Se in una subnet locale sono presenti altri cluster di Bilanciamento carico di rete, ogni cluster deve utilizzare un indirizzo di rete diverso. Quando si seleziona un diverso indirizzo IP primario per ogni cluster, Bilanciamento carico di rete verifica automaticamente che i cluster utilizzino indirizzi di rete univoci. Alcune schede di rete potrebbero non consentire la modifica dell'indirizzo di rete predefinito. Se si riscontra questo problema, è necessario ottenere e installare una diversa scheda di rete che supporti questa funzionalità.

  • I parametri Modalità operativa del cluster specificano se per le operazioni cluster dovrà essere utilizzato un indirizzo MAC multicast. Se è abilitato il multicast, l'indirizzo MAC del cluster appartenente alla scheda del cluster viene convertito da Bilanciamento carico di rete in un indirizzo multicast. Viene inoltre verificato che l'indirizzo IP primario del cluster venga risolto in questo indirizzo multicast nell'ambito del protocollo ARP. La scheda può quindi utilizzare il proprio indirizzo MAC predefinito originale, che era stato disabilitato in modalità unicast.

    In modalità multicast è inoltre possibile abilitare il supporto IGMP (Internet Group Management Protocol), che riduce la quantità di commutatori limitando il traffico alle sole porte di Bilanciamento carico di rete. Abilitando il supporto IGMP è pertanto possibile garantire che il traffico diretto a un cluster di Bilanciamento carico di rete passi soltanto attraverso le porte collegate ai cluster host e non attraverso tutte le porte di commutazione.

    Se si seleziona il supporto unicast, Bilanciamento carico di rete indica automaticamente al driver appartenente alla scheda del cluster di ignorare l'indirizzo di rete univoco predefinito della scheda e di sostituire il relativo indirizzo MAC con l'indirizzo MAC del cluster. Questo è l'indirizzo utilizzato su tutti i cluster host. Non è necessario configurare manualmente la scheda di rete per riconoscere tale indirizzo. Si noti che alcune schede di rete non supportano la modifica dei propri indirizzi MAC. Se si riscontra questo problema, è necessario installare una scheda di rete che supporti tale modifica.

Importante

Bilanciamento carico di rete non supporta un ambiente misto di unicast e multicast in un singolo cluster. Tutte le schede di rete di ogni cluster devono essere multicast o unicast. In caso contrario, il cluster non funzionerà correttamente. Non esistono restrizioni per il numero di schede e host diversi possono disporre di un diverso numero di schede.

Regole porta

Nella scheda Regole porta viene visualizzato soltanto il riepilogo delle regole di porta esistenti. Facendo clic su Aggiungi o Modifica saranno disponibili i parametri elencati di seguito.

  • Il parametro Indirizzo IP del cluster specifica l'indirizzo IP del cluster a cui dovrà essere applicata la regola di porta. Se non si specifica un valore per questo parametro e si seleziona Tutti, la regola di porta è una regola di porta globale che verrà applicata a tutti gli indirizzi IP di cluster associati allo specifico cluster di Bilanciamento carico di rete. Se viene specificato un indirizzo IP del cluster, la regola di porta ha la precedenza su qualsiasi regola di porta globale in conflitto per tale specifico indirizzo IP del cluster.

  • Il parametro Intervallo porte specifica l'intervallo di porte TCP/UDP a cui dovrà essere applicata una regola di porta. L'intervallo di porte predefinito è 0-65.535. Le regole per una singola porta vengono codificate utilizzando un intervallo con numeri di porta iniziale e finale uguali.

  • Il parametro Protocolli consente di scegliere il protocollo TCP/IP specifico a cui dovrà essere applicata una regola: TCP, UDP o entrambi. La regola influisce soltanto sul traffico di rete per il protocollo specificato. Il traffico non interessato dalla regola di porta viene gestito dall'host predefinito.

  • Per Modalità filtro, configurare i parametri seguenti:

    • Il parametro Host multipli specifica che il traffico di rete per la regola di porta associata verrà gestito da più host del cluster. Questa modalità di filtro garantisce prestazioni scalabili e tolleranza di errore distribuendo il carico di rete tra più host. È possibile specificare che il carico deve essere equamente distribuito tra gli host oppure che ogni host gestirà un peso del carico specificato.

    • Il parametro Host singolo specifica che il traffico di rete per la regola di porta associata verrà gestito da un singolo host del cluster, in base alla priorità di gestione specificata. Questa modalità di filtro garantisce tolleranza di errore specifica per la gestione del traffico di rete.

    • Il parametro Disabilita intervallo di porte specifica che tutto il traffico di rete per la regola di porta associata verrà bloccato. In questo caso, il driver di Bilanciamento carico di rete filtra tutti i datagrammi o i pacchetti di rete corrispondenti. Questa modalità di filtro consente di bloccare il traffico di rete indirizzato a un intervallo di porte specifico.

  • Il parametro Affinità è applicabile soltanto alla modalità di filtro Host multipli.

    • L'opzione Nessuna specifica che più connessioni dallo stesso indirizzo IP client possono essere gestite da cluster host diversi, senza affinità del client. Per consentire la gestione corretta dei frammenti IP da parte di Bilanciamento carico di rete, è consigliabile evitare di utilizzare Nessuna quando si seleziona UDP o Entrambi per l'impostazione del protocollo.

    • L'opzione Singola specifica che Bilanciamento carico di rete dovrà indirizzare più richieste dello stesso indirizzo IP client allo stesso cluster host. Questa è l'impostazione predefinita per Affinità. Facoltativamente, è possibile modificare l'affinità del client di Bilanciamento carico di rete in modo da indirizzare tutte le richieste client da un intervallo di indirizzi di classe C TCP/IP (anziché da un unico indirizzo IP) a un singolo cluster host, abilitando l'opzione Rete anziché l'opzione Singola. Questa funzionalità garantisce ai client che utilizzano più server proxy per accedere al cluster la possibilità di indirizzare le connessioni TCP allo stesso cluster host.

    • L'opzione Rete specifica che Bilanciamento carico di rete indirizzerà più richieste dallo stesso intervallo di indirizzi di classe C TCP/IP allo stesso cluster host. Abilitando l'affinità Rete anziché Singola è possibile garantire che le connessioni TCP dei client che utilizzano più server proxy per accedere al cluster vengano indirizzate allo stesso cluster host.

      In caso di utilizzo di più server proxy nel sito del client, le richieste di un singolo client risultano provenienti da computer diversi. Presupponendo che tutti i server proxy del client siano inclusi nello stesso intervallo di indirizzi, l'affinità Rete garantisce la gestione corretta delle sessioni client. Se questa funzionalità non è necessaria, utilizzare l'affinità Singola per usufruire di prestazioni scalabili ottimizzate.

    Come estensione delle opzioni Singola e Rete è possibile configurare un'impostazione di timeout per mantenere l'affinità client in caso di modifica della configurazione di un cluster di Bilanciamento carico di rete. Questa estensione consente inoltre ai client di mantenere l'affinità con un cluster host anche se non sono presenti connessioni esistenti attive dal client all'host.

    Abilitando l'affinità Singola o Rete è possibile garantire che tutte le connessioni appartenenti alla stessa sessione client vengano gestite da un unico cluster host. Ciò è importante se l'applicazione server in esecuzione nel cluster host mantiene lo stato della sessione (ad esempio, cookie server) tra le diverse connessioni.

    Non viene invece mantenuto lo stato della sessione con database back-end in cui vengono eseguite molte transazioni diverse che coinvolgono molti computer diversi. Quando la connessione viene terminata, termina anche lo stato della sessione.

    Disabilitando il parametro Affinità è possibile migliorare il bilanciamento del carico, poiché più connessioni dallo stesso client possono essere gestite contemporaneamente da cluster host diversi. Per usufruire di prestazioni scalabili ottimizzate, disabilitare l'affinità del client quando non necessaria, utilizzando l'opzione Nessuna. Per consentire la gestione corretta dei frammenti IP da parte di Bilanciamento carico di rete, è tuttavia consigliabile evitare di utilizzare Nessuna quando si seleziona UDP o Entrambi per l'impostazione del protocollo.

Importante

Quando si utilizza Bilanciamento carico di rete per bilanciare il carico del traffico VPN, è necessario configurare le regole di porta applicate alle porte che gestiscono il traffico VPN (porta TCP 1723 per PPTP/GRE e porta UDP 500 per IPSEC/L2TP) in modo da utilizzare l'affinità Singola o Rete.

  • Il parametro Peso del carico è applicabile soltanto alla modalità di filtro Host multipli. È possibile configurare questo parametro solo se la finestra di dialogo per le regole di porta viene aperta tramite Proprietà host. Il parametro non è configurabile se la finestra di dialogo per le regole di porta viene aperta tramite Proprietà cluster.

    Quando si utilizza la modalità di filtro Host multipli, questo parametro specifica la quantità relativa del traffico di rete con carico bilanciato che dovrà essere gestita da questo host per la regola di porta associata. I valori consentiti sono compresi tra 0 (zero) e 100. Per impedire a un host di gestire traffico di rete, impostare il peso del carico su 0 (zero). L'effettiva frazione del traffico gestita da ogni host viene calcolata dividendo il peso del carico locale per la somma di tutti i pesi del carico nel cluster.

    Mediante il parametro Peso del carico è possibile specificare pesi del carico diversi per ogni host del cluster. Per specificare una distribuzione equa del carico di rete in tutti gli host, utilizzare il parametro di distribuzione Carico equo anziché il parametro Peso del carico.

  • Il parametro Priorità di gestione è applicabile soltanto alla modalità di filtro Host singolo. È possibile configurare questo parametro solo se la finestra di dialogo per le regole di porta viene aperta tramite Proprietà host. Il parametro non è disponibile se la finestra di dialogo per le regole di porta viene aperta tramite Proprietà cluster.

    Quando viene utilizzata la modalità di filtro Host singolo, il parametro Priorità di gestione specifica la priorità dell'host locale per la gestione del traffico di rete per la regola di porta associata. L'host con la priorità di gestione massima (valore numerico inferiore) per una regola tra i membri correnti del cluster gestirà tutto il traffico per la regola. I valori consentiti sono compresi tra 1, corrispondente alla priorità massima, e il numero massimo di host consentito (32). Questo valore deve essere univoco per tutti gli host del cluster. Nonostante venga visualizzato nell'elenco Regole porta definite, questo parametro viene configurato nella scheda Parametri host.

Parametri host
  • Il parametro Priorità (ID host univoco) specifica un ID univoco per ogni host. L'host con la priorità numerica inferiore tra i membri correnti del cluster gestisce tutto il traffico di rete del cluster non coperto da alcuna regola di porta. È possibile ignorare queste priorità oppure impostare il bilanciamento del carico per determinati intervalli di porte specificando regole nella scheda Regole porta.

    In caso di aggiunta al cluster di un nuovo host con priorità in conflitto con un altro host del cluster, l'host non viene accettato come parte del cluster. Il resto del cluster continuerà a gestire il traffico. Nel registro eventi di Windows viene inserito un messaggio che descrive il problema.

  • Il parametro Indirizzo IP specifica l'indirizzo IP univoco dell'host che viene utilizzato per il traffico di rete non associato al cluster (ad esempio, specificando l'accesso Telnet a un determinato host all'interno del cluster). L'indirizzo dovrà essere espresso nella notazione puntata standard di Internet, ad esempio w.x.y.z. Questo indirizzo IP viene utilizzato per il singolo host del cluster e dovrà essere univoco per ogni host. L'indirizzo IP dedicato dovrà sempre essere immesso per primo nelle proprietà TCP/IP.

    Bilanciamento carico di rete fa riferimento all'indirizzo IP dedicato soltanto quando viene utilizzata un'unica scheda di rete per gestire sia il traffico da client a cluster che altro traffico di rete diretto specificamente all'indirizzo IP dedicato. Bilanciamento carico di rete garantisce che tutto il traffico verso l'indirizzo IP dedicato non sia interessato dalla configurazione corrente di Bilanciamento carico di rete, anche quando l'host è in esecuzione come parte del cluster e quando Bilanciamento carico di rete viene disabilitato a causa di errori nei parametri nel Registro di sistema.

Importante

Sia l'indirizzo IP dedicato che l'indirizzo IP del cluster devono inoltre essere immessi in genere nella finestra di dialogo Proprietà TCP/IP. Verificare che gli indirizzi corrispondano in entrambe le posizioni. In caso di configurazione di un cluster di bilanciamento del carico in una rete privata virtuale (VPN), tuttavia, non è consigliabile configurare l'indirizzo IP dedicato. In una VPN è necessario che su ognuno dei cluster host sia presente solo l'indirizzo IP del cluster. L'indirizzo IP dedicato deve essere un indirizzo IP statico e non può essere costituito da un indirizzo DHCP.

  • Il parametro Subnet mask indica la subnet mask per l'indirizzo IP specificato. La subnet mask viene espressa nella notazione puntata standard di Internet, ad esempio 255.255.255.0.

  • Il parametro Stato iniziale host specifica se verrà avviato Bilanciamento carico di rete e se l'host verrà aggiunto immediatamente al cluster all'avvio del sistema operativo. Ad esempio, potrebbe essere opportuno avviare altri servizi manualmente e in un ordine specifico prima di avviare Bilanciamento carico di rete. È possibile aggiungere e rimuovere gli host nel cluster in modo dinamico utilizzando i comandi Start e Stop nel controllo della riga di comando di Bilanciamento carico di rete. Se la casella di controllo Mantieni lo stato sospeso dopo il riavvio del computer è selezionata, un host che si trova nello stato sospeso al momento dell'arresto risulterà ancora sospeso all'avvio di Windows.

Ulteriori riferimenti

Panoramica di Bilanciamento carico di rete

Installare Bilanciamento carico di rete

Creare cluster di Bilanciamento carico di rete

Gestire cluster di Bilanciamento carico di rete