Performance Monitor di Windows

È possibile utilizzare Performance Monitor di Windows per esaminare l'effetto prodotto dall'esecuzione dei programmi sulle prestazioni del computer sia in tempo reale che raccogliendo i dati di registro per un'analisi successiva.

Performance Monitor di Windows utilizza i contatori delle prestazioni, i dati di traccia eventi e le informazioni sulla configurazione, che possono essere combinati in insiemi agenti di raccolta dati.

I contatori delle prestazioni sono misure dello stato o dell'attività del sistema. È possibile includerli nel sistema operativo o possono far parte delle singole applicazioni. Performance Monitor di Windows richiede il valore corrente dei contatori delle prestazioni a intervalli di tempo specifici.

I dati di analisi degli eventi vengono raccolti dai provider di analisi che sono componenti del sistema operativo o di singole applicazioni che segnalano azioni o eventi. L'output di più provider di traccia può essere combinato in una sessione di traccia.

Le informazioni sulla configurazione vengono raccolte dai valori chiave del Registro di sistema di Windows. È possibile registrare il valore di una chiave del Registro di sistema in un orario o un intervallo di tempo specifico come parte di un file di registro.

  • Panoramica di Performance Monitor di Windows

  • Utilizzare Monitoraggio prestazioni

  • Creare insiemi agenti di raccolta dati

  • Pianificare e gestire i dati in Performance Monitor di Windows

  • Interfaccia utente: Performance Monitor di Windows

Ulteriori riferimenti

  • Per ulteriori informazioni sull'utilizzo di Performance Monitor di Windows, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70270.


Panoramica di Performance Monitor di Windows

Performance Monitor di Windows è uno snap-in MMC (Microsoft Management Console) che offre strumenti per l'analisi delle prestazioni del sistema. Da una sola console è possibile monitorare le prestazioni dell'applicazione e dell'hardware in tempo reale, personalizzare i dati che si desiderano raccogliere nei registri, definire le soglie degli avvisi e le azioni automatiche, generare rapporti e visualizzare i dati delle performance precedenti in diversi modi.

In Performance Monitor di Windows sono riunite le funzionalità di strumenti autonomi precedenti, tra cui Avvisi e registri di prestazioni, Server Performance Advisor (SPA) e Monitor di sistema. Offre un'interfaccia grafica per la personalizzazione di Insiemi agenti di raccolta dati e Sessioni di analisi eventi.

Performance Monitor di Windows esegue la raccolta e la registrazione dei dati utilizzando Insiemi agenti di raccolta dati.

Per avviare Performance Monitor di Windows

  • Fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e premere INVIO.

Monitoraggio prestazioni

Monitoraggio prestazioni consente di visualizzare i contatori delle prestazioni incorporati di Windows in tempo reale o in modo da verificare i dati cronologici. È possibile aggiungere contatori delle prestazioni a Monitoraggio prestazioni tramite trascinamento della selezione oppure creando Insiemi agenti di raccolta dati personalizzati. Offre una funzionalità che consente di visualizzare più grafici per la verifica visiva dei dati di registro delle prestazioni. In Monitoraggio prestazioni è possibile creare visualizzazioni personalizzate che possono essere esportate come Insiemi agenti di raccolta dati da utilizzare con le funzionalità relative alle prestazioni e alle registrazioni.

Accedere alle funzionalità di Performance Monitor di Windows

I membri del gruppo locale Administrators o di un gruppo equivalente possono utilizzare tutte le funzionalità di Performance Monitor di Windows. Nell'elenco sottostante vengono riepilogate le funzionalità accessibili ai membri degli altri gruppi:

Membri del gruppo Users

  • Possono aprire i file di registro per la visualizzazione in Monitoraggio prestazioni e modificare le proprietà della schermata di Monitoraggio prestazioni durante la visualizzazione dei dati cronologici.

  • Non possono creare o modificare Insiemi agenti di raccolta dati né visualizzare i dati delle prestazioni in tempo reale in Performance Monitor.

    Nota

    Non possono configurare un insieme agenti di raccolta dati per eseguirlo come membri del gruppo Users.

Membri del gruppo Performance Monitor Users

  • Possono utilizzare tutte le funzionalità disponibili per il gruppo Users.

  • Possono visualizzare i dati delle prestazioni in tempo reale in Monitoraggio prestazioni e modificare le proprietà della schermata di Monitoraggio prestazioni durante la visualizzazione dei dati.

  • Non possono creare né modificare Insiemi agenti di raccolta dati.

    Nota

    Non possono configurare un insieme agenti di raccolta dati per eseguirlo come membri del gruppo Performance Monitor Users.

Membri del gruppo Performance Log Users

  • Possono utilizzare tutte le funzionalità disponibili per il gruppo Performance Monitor Users.

  • Possono creare e modificare Insiemi agenti di raccolta dati dopo l'assegnazione al gruppo del diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

    Nota

    Se si è membri del gruppo Performance Log Users, è necessario configurare Insiemi agenti di raccolta dati creati per l'esecuzione con le proprie credenziali.

  • Non possono utilizzare il provider di traccia del kernel di Windows in Insiemi agenti di raccolta dati.

Ulteriori riferimenti

  • Utilizzare Monitoraggio prestazioni

  • Creare insiemi agenti di raccolta dati

  • Pianificare e gestire i dati in Performance Monitor di Windows

  • Interfaccia utente: Performance Monitor di Windows


Utilizzare Monitoraggio prestazioni

Monitoraggio prestazioni è uno strumento di visualizzazione semplice ma potente per la visualizzazione dei dati delle prestazioni in tempo reale e dai file di registro. Questo strumento consente di esaminare i dati delle prestazioni sotto forma di grafico, istogramma o rapporto.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Performance Log Users locale o a un gruppo equivalente.

Per avviare Monitoraggio prestazioni

  1. Fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e premere INVIO.

  2. Nell'albero di spostamento espandere Strumenti di monitoraggio e quindi fare clic su Monitoraggio prestazioni.

È inoltre possibile utilizzare Monitoraggio prestazioni per visualizzare dati delle prestazioni in tempo reale in un computer remoto.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Performance Log Users del computer di destinazione o a un gruppo equivalente.

Per connettersi a un computer remoto con Monitoraggio prestazioni

  1. Avviare Monitoraggio prestazioni.

  2. Nell'albero di spostamento fare clic con il pulsante destro del mouse su Affidabilità e prestazioni e quindi scegliere Connetti a un altro computer.

  3. Nella finestra di dialogo Seleziona computer digitare il nome del computer che si desidera monitorare oppure fare clic su Sfoglia per selezionarlo in un elenco.

  4. Fare clic su OK.

Ulteriori considerazioni

  • Per visualizzare contatori delle prestazioni da un computer remoto, è necessario attivare l'eccezione del firewall Avvisi e registri di prestazioni nel computer remoto. I membri del gruppo Performance Log Users devono inoltre appartenere al gruppo Lettori registri eventi nel computer remoto.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Configurare la schermata di Monitoraggio prestazioni

  • Utilizzare i registri di prestazioni

  • Finestra di dialogo Aggiungi contatori

  • Per ulteriori informazioni sull'utilizzo di Performance Monitor di Windows, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70270.


Configurare la schermata di Monitoraggio prestazioni

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Per configurare la schermata di Monitoraggio prestazioni

  1. Fare clic con il pulsante destro del mouse sulla schermata di Monitoraggio prestazioni e scegliere Proprietà.

  2. Apportare le modifiche della configurazioni desiderate.

  3. Per visualizzare gli effetti delle modifiche senza aprire di nuovo la finestra di dialogo Proprietà, è possibile fare clic su Applica dopo l'eventuale modifica.

  4. Al termine, fare clic su OK.

È possibile salvare le informazioni nella schermata corrente di Monitoraggio prestazioni come pagina Web o immagine.

Per salvare la schermata corrente di Monitoraggio prestazioni come pagina Web

  1. Fare clic con il pulsante destro del mouse sulla schermata di Monitoraggio prestazioni e scegliere Salva impostazioni con nome.

  2. Scegliere una directory in cui si desidera salvare il file.

  3. Digitare il nome del file della schermata salvato e quindi fare clic su OK.
Per salvare la schermata corrente di Monitoraggio prestazioni come immagine

  1. Fare clic con il pulsante destro del mouse sulla schermata di Monitoraggio prestazioni e scegliere Salva immagine con nome.

  2. Scegliere una directory in cui si desidera salvare il file.

  3. Digitare il nome del file della schermata salvato e quindi fare clic su OK.

Ulteriori considerazioni

  • È inoltre possibile accedere alle proprietà di Monitoraggio prestazioni premendo CTRL+Q oppure facendo clic sul pulsante Proprietà sulla barra degli strumenti.

  • Se non sono presenti contatori nella schermata corrente, è possibile aprire la finestra di dialogo Aggiungi contatori scegliendo la scheda Dati e facendo clic su Aggiungi.

  • È possibile aprire i file di registro o i database del registro dalle proprietà di Monitoraggio prestazioni nella scheda Origine. È possibile aprire contemporaneamente più file di registro. Per ulteriori informazioni sui dati di registro, vedere Utilizzare i registri di prestazioni.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Utilizzare Monitoraggio prestazioni

  • Finestra di dialogo Aggiungi contatori


Utilizzare i registri di prestazioni

I file o i dati di registro forniti da un database possono essere visualizzati in Monitoraggio prestazioni mediante una rappresentazione grafica dei dati delle prestazioni raccolti tramite Insieme agenti di raccolta dati.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

  • Aprire i file di registro in Monitoraggio prestazioni

  • Accedere a un'origine di dati di registro in Monitoraggio prestazioni

  • Confrontare più file di registro in Monitoraggio prestazioni


Aprire i file di registro in Monitoraggio prestazioni

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Users o a un gruppo equivalente.

Aprire i file di registro in Monitoraggio prestazioni

  1. Nel riquadro di spostamento di Performance Monitor di Windows espandere Strumenti di monitoraggio e quindi fare clic su Performance Monitor.

  2. Sulla barra degli strumenti del riquadro della console fare clic sul pulsante Aggiungi dati registro. Verrà aperta la pagina delle proprietà di Monitoraggio prestazioni alla scheda Origine.

  3. Nella sezione Origine dati, scegliere File registro e fare clic su Aggiungi.

  4. Individuare il file di registro che si desidera visualizzare e fare clic su Apri. Per aggiungere più file di registro alla schermata di Monitoraggio prestazioni, scegliere di nuovo Aggiungi.

  5. Fare clic su Intervallo di tempo per visualizzare i tempi inclusi nel registro o registri selezionati.

    • Per un singolo file di registro è possibile spostare i dispositivi di scorrimento di inizio e di fine per visualizzare soltanto una parte del file di registro in Monitoraggio prestazioni.

    • Per più file di registro è possibile spostare i dispositivi di scorrimento di inizio e di fine per scegliere il periodo di tempo, per tutti i file di registro selezionati, da visualizzare in Monitoraggio prestazioni. Se in un registro sono presenti dati del periodo di tempo selezionato, questi verranno visualizzati nella schermata.

  6. Al termine della selezione dei file di registro, fare clic su OK.

  7. Fare clic con il pulsante destro del mouse nella schermata di Monitoraggio prestazioni e scegliere Aggiungi contatori. Verrà aperta la finestra di dialogo Aggiungi contatori. Saranno disponibili soltanto i contatori inclusi nel file o nei file di registro selezionati nel passaggio 4.

  8. Selezionare i contatori che si desidera visualizzare nel grafico di Monitoraggio prestazioni e fare clic su OK. Per informazioni sull'aggiunta dei contatori, vedere Finestra di dialogo Aggiungi contatori.

    Nota

    Per selezionare contemporaneamente più gruppi di contatori o contatori premere il tasto CTRL e scegliere i nomi dei gruppi o dei contatori, quindi fare clic su OK.

Ulteriori considerazioni

  • Per avviare Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

  • È inoltre possibile aprire Performance Monitor nella relativa finestra specifica. A tale scopo, digitare perfmon /sys e premere INVIO nella casella Inizia ricerca o al prompt dei comandi.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Utilizzare i registri di prestazioni


Accedere a un'origine di dati di registro in Monitoraggio prestazioni

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Users o a un gruppo equivalente.

Nota

È necessario disporre delle autorizzazioni per accedere all'origine di dati di registro per visualizzarli in Monitoraggio prestazioni.

Per accedere a un'origine di dati di registro in Monitoraggio prestazioni

  1. Nel riquadro di spostamento di Performance Monitor di Windows espandere Strumenti di monitoraggio e quindi fare clic su Performance Monitor.

  2. Sulla barra degli strumenti del riquadro della console fare clic sul pulsante Aggiungi dati registro. Verrà aperta la pagina Proprietà di Monitoraggio prestazioni alla scheda Origine.

  3. Nella sezione Origine dati, scegliere Database.

  4. Scegliere un nome di origine dati di sistema (DSN) e un set di registri negli elenchi a discesa.

  5. Fare clic su Intervallo di tempo per visualizzare i tempi inclusi nel registro selezionato. È possibile spostare i dispositivi di scorrimento di inizio e di fine per visualizzare soltanto una parte del file di registro in Monitoraggio prestazioni.

  6. Al termine, fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sulla schermata di Monitoraggio prestazioni e scegliere Aggiungi contatori. Verrà aperta la finestra di dialogo Aggiungi contatori. Saranno disponibili soltanto i contatori inclusi nell'origine di dati di registro selezionati nel passaggio 4.

  8. Selezionare i contatori che si desidera visualizzare nel grafico di Monitoraggio prestazioni e fare clic su OK. Per informazioni sull'aggiunta dei contatori, vedere Finestra di dialogo Aggiungi contatori.

    Nota

    Per selezionare contemporaneamente più gruppi di contatori o contatori premere il tasto CTRL e scegliere i nomi dei gruppi o dei contatori, quindi fare clic su OK.

Ulteriori considerazioni

  • Per avviare Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

  • È inoltre possibile aprire Performance Monitor nella relativa finestra specifica. A tale scopo, digitare perfmon /sys e premere INVIO nella casella Inizia ricerca o al prompt dei comandi.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Utilizzare i registri di prestazioni


Confrontare più file di registro in Monitoraggio prestazioni

È possibile visualizzare i file di registro in finestre separate di Monitoraggio prestazioni e poi confrontarli con una sovrapposizione trasparente.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Users o a un gruppo equivalente.

Per confrontare più file di registro in Monitoraggio prestazioni

  1. Fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon /sys /comp e premere INVIO. Monitoraggio prestazioni verrà aperto in modalità autonoma con il confronto abilitato.

    Nota

    È possibile utilizzare la sovrapposizione solo quando Monitoraggio prestazioni è in esecuzione in modalità autonoma con il confronto abilitato.

  2. Per creare una visualizzazione da utilizzare come base per il confronto, aprire i registri o un'origine dati e aggiungere i contatori dai registri o dall'origine dati alla schermata di Monitoraggio prestazioni.

  3. Al termine della creazione della visualizzazione di base, ripetere il passaggio 1 per aprire un'altra istanza di Monitoraggio prestazioni in modalità autonoma con il confronto abilitato.

  4. Per creare una visualizzazione da utilizzare come base per il confronto, aprire i registri o un'origine dati e aggiungere i contatori dai registri o dall'origine dati alla seconda schermata di Monitoraggio prestazioni.

  5. Nel menu Confronto della finestra di Monitoraggio prestazioni che si desidera utilizzare come base per il confronto scegliere Imposta trasparenza e selezionare Trasparenza 70% o Trasparenza 40%.

  6. Nel menu Confronto della finestra di Monitoraggio prestazioni che si desidera utilizzare come base per il confronto scegliere Confronto per sovrapposizione. La finestra attiva di Monitoraggio prestazioni verrà automaticamente allineata all'altra finestra.

Ulteriori considerazioni

  • La funzione di sovrapposizione per il confronto dei file di registro funziona meglio se più registri vengono visualizzati in base allo stesso Insieme agenti di raccolta dati poiché le proporzioni dei grafici di Monitoraggio prestazioni vengono modificate per una visualizzazione più efficace dell'intervallo di dati del file di registro.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Utilizzare i registri di prestazioni


Creare insiemi agenti di raccolta dati

Un insieme agenti di raccolta dati è un componente di monitoraggio e segnalazione delle prestazioni in Performance Monitor di Windows. Vengono organizzati più punti di raccolta di dati in un solo componente che possono essere utilizzati per esaminare o registrare le prestazioni. Un insieme agenti di raccolta dati può essere creato e quindi registrato singolarmente, raggruppato con un altro insieme agenti di raccolta dati e incorporato nei registri, visualizzato in Monitoraggio prestazioni, configurato per generare avvisi quando vengono raggiunte le soglie oppure utilizzato da altre applicazioni non Microsoft. Può essere associato alle regole di pianificazione per la raccolta di dati in periodi di tempo specifici. È possibile configurare l'esecuzione delle attività di Windows Management Interface (WMI) al completamento della raccolta dell'insieme agenti di raccolta dati.

In Insiemi agenti di raccolta dati sono contenuti i tipi seguenti di agenti di raccolta dati:

  • Contatori prestazioni

  • Dati di analisi eventi

  • Informazioni relative alla configurazione del sistema (valori chiave del Registro di sistema)

È possibile creare un insieme agenti di raccolta dati da un modello, da un insieme esistente di agenti di raccolta dati in una schermata di Monitoraggio prestazioni o selezionando singoli agenti di raccolta dati e impostando ogni singola opzione nelle proprietà dell'insieme agenti di raccolta dati.

  • Creare un insieme agenti di raccolta dati da Monitoraggio prestazioni

  • Creare un insieme agenti di raccolta dati da un modello

  • Creare un insieme agenti di raccolta dati manualmente

  • Creare un insieme agenti di raccolta dati per monitorare i contatori delle prestazioni

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Pianificare e gestire i dati in Performance Monitor di Windows

  • Per ulteriori informazioni sull'utilizzo di Performance Monitor di Windows, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70270.


Creare un insieme agenti di raccolta dati da Monitoraggio prestazioni

È possibile creare un insieme agenti di raccolta dati dai contatori della schermata corrente di Monitoraggio prestazioni.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Nota

È necessario assegnare al gruppo Performance Log Users il diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

Per creare un insieme agenti di raccolta dati da Monitoraggio prestazioni

  1. Avviare Monitoraggio prestazioni e aggiungere i contatori per creare una visualizzazione personalizzata che si desidera salvare come insieme agenti di raccolta dati.

  2. Fare clic con il pulsante destro del mouse in un punto qualsiasi nel riquadro della schermata di Monitoraggio prestazioni, scegliere Nuovo e quindi fare clic su Insieme agenti di raccolta dati. Viene avviata la Creazione guidata Nuovo insieme agenti di raccolta dati. Nell'insieme agenti di raccolta dati saranno contenuti tutti gli agenti di raccolta dati selezionati nella schermata corrente di Monitoraggio prestazioni.

  3. Immettere un nome per l'insieme agenti di raccolta dati e fare clic su Avanti.

  4. I dati raccolti dall'insieme agenti di raccolta dati saranno contenuti nella Directory radice. Modificare questa impostazione se si desidera archiviare i dati dell'insieme agenti di raccolta dati in una posizione diversa da quella predefinita. Individuare e scegliere la directory o digitare il nome della directory.

    Nota

    Se il nome della directory viene immesso manualmente, non è necessario immettere una barra rovesciata alla fine del nome della directory.

  5. Fare clic su Avanti per definire un utente che esegue l'insieme agenti di raccolta dati oppure fare clic su Fine per salvare le impostazioni correnti e uscire.

  6. Dopo aver scelto Avanti è possibile configurare l'insieme agenti di raccolta dati da eseguire come utente specifico. Fare clic sul pulsante Cambia per immettere il nome utente e la password per un utente diverso da quello presente nell'elenco predefinito.

    Nota

    Se si è membri del gruppo Performance Log Users, è necessario configurare Insiemi agenti di raccolta dati creati per l'esecuzione con le proprie credenziali.

  7. Fare clic su Fine per tornare a Performance Monitor di Windows.

    • Per visualizzare le proprietà dell'insieme agenti di raccolta dati o per eseguire modifiche aggiuntive per questo insieme agenti di raccolta dati selezionare Visualizza proprietà dell'insieme agenti di raccolta dati. Per ulteriori informazioni sulle proprietà dell'insieme agenti di raccolta dati, vedere Proprietà dell'Insieme agenti di raccolta dati.

    • Per avviare immediatamente l'insieme agenti di raccolta dati e salvare i dati nella posizione specificata nel passaggio 4, scegliere Avvia l'insieme agenti di raccolta dati.

    • Per salvare l'insieme agenti di raccolta dati senza avviare la raccolta, scegliere Salva e chiudi.

Ulteriori considerazioni

  • Per aprire Performance Monitor, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO. In Performance Monitor di Windows espandere Strumenti di monitoraggio e fare clic su Performance Monitor.

  • Insiemi agenti di raccolta dati viene eseguito dall'utente del sistema predefinito. Per una sicurezza ottimale, è consigliabile accettare questo valore predefinito fino a quando non si hanno motivi validi per modificarlo.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Creare insiemi agenti di raccolta dati

  • Pianificare e gestire i dati in Performance Monitor di Windows

  • Utilizzare Monitoraggio prestazioni


Creare un insieme agenti di raccolta dati da un modello

Il modo più semplice per creare un nuovo insieme agenti di raccolta dati consiste nell'utilizzare la procedura guidata in Performance Monitor di Windows. In Microsoft Windows Vista sono disponibili diversi modelli basati sulle informazioni generali relative alla diagnostica del sistema o che raccolgono i dati delle prestazioni specifici dei ruoli server o delle applicazioni. È inoltre possibile importare i modelli creati su altri computer e salvare l'insieme agenti di raccolta dati creato per l'utilizzo in altra posizione.

Importazione di modelli

I modelli dell'insieme agenti di raccolta dati sono archiviati come file XML e possono essere importati direttamente dall'unità disco rigido locale o dalle unità rimovibili o di rete disponibili.

Per importare un modello dell'insieme agenti di raccolta dati, eseguire la Creazione guidata Nuovo insieme agenti di raccolta dati e fare clic su Sfoglia nella schermata del Modello insieme agenti di raccolta dati. Individuare il file XML che si desidera utilizzare e scegliere il nome di file quindi fare clic su OK.

Esportare i modelli

Per esportare un insieme agenti di raccolta dati creato come modello da utilizzare in altri computer, aprire Performance Monitor di Windows, espandere Insiemi agenti di raccolta dati, fare clic con il pulsante destro del mouse sull'insieme agenti di raccolta dati che si desidera esportare e quindi scegliere Salva modello. Scegliere una directory in cui memorizzare il file XML e fare clic su Salva.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Nota

È necessario assegnare al gruppo Performance Log Users il diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

Nota

Per utilizzare modelli che raccolgono dati utilizzando il provider di analisi del kernel di Windows, è necessario appartenere al gruppo locale Administrators.

Per creare un insieme agenti di raccolta dati da un modello

  1. Nel riquadro di spostamento di Performance Monitor di Windows espandere Insiemi agenti di raccolta dati, fare clic con il pulsante destro del mouse su Definiti dall'utente, scegliere Nuovo e quindi fare clic su Insieme agenti di raccolta dati. Viene avviata la Creazione guidata Nuovo insieme agenti di raccolta dati.

  2. Immettere un nome per l'insieme agenti di raccolta dati.

  3. Scegliere Crea da modello e quindi fare clic su Avanti.

  4. Scegliere il modello che si desidera utilizzare per creare l'insieme agenti di raccolta dati dal menu.

    Nota

    Quando viene evidenziato un modello disponibile, viene visualizzata la descrizione a destra dell'elenco.

  5. Fare clic su Avanti per scegliere una posizione personalizzata per i dati da salvare o per definire più opzioni oppure fare clic su Fine per salvare le impostazioni correnti e uscire.

  6. I dati raccolti dall'insieme agenti di raccolta dati saranno contenuti nella Directory radice. Modificare questa impostazione se si desidera archiviare i dati dell'insieme agenti di raccolta dati in una posizione diversa da quella predefinita. Individuare e scegliere la directory o digitare il nome della directory.

    Nota

    Se il nome della directory viene immesso manualmente, non è necessario immettere una barra rovesciata alla fine del nome della directory.

  7. Fare clic su Avanti per definire un utente che esegue l'insieme agenti di raccolta dati oppure fare clic su Fine per salvare le impostazioni correnti e uscire.

  8. Dopo aver scelto Avanti è possibile configurare l'insieme agenti di raccolta dati da eseguire come utente specifico. Fare clic sul pulsante Cambia per immettere il nome utente e la password per un utente diverso da quello presente nell'elenco predefinito.

    Nota

    Se si è membri del gruppo Performance Log Users, è necessario configurare Insiemi agenti di raccolta dati creati per l'esecuzione con le proprie credenziali.

  9. Fare clic su Fine per tornare a Performance Monitor di Windows.

    • Per visualizzare le proprietà dell'insieme agenti di raccolta dati o per eseguire modifiche aggiuntive per questo insieme agenti di raccolta dati selezionare Visualizza proprietà dell'insieme agenti di raccolta dati. Per ulteriori informazioni sulle proprietà dell'insieme agenti di raccolta dati, vedere Proprietà dell'Insieme agenti di raccolta dati.

    • Per avviare immediatamente l'insieme agenti di raccolta dati e salvare i dati nella posizione specificata nel passaggio 6, scegliere Avvia l'insieme agenti di raccolta dati.

    • Per salvare l'insieme agenti di raccolta dati senza avviare la raccolta, scegliere Salva e chiudi.

Ulteriori considerazioni

  • Per aprire Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

  • Insiemi agenti di raccolta dati viene eseguito dall'utente del sistema predefinito. Per una sicurezza ottimale, è consigliabile accettare questo valore predefinito fino a quando non si hanno motivi validi per modificarlo.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Creare insiemi agenti di raccolta dati

  • Pianificare e gestire i dati in Performance Monitor di Windows


Creare un insieme agenti di raccolta dati manualmente

È possibile creare un insieme agenti di raccolta dati da una combinazione personalizzata di agenti di raccolta dati. Negli agenti di raccolta dati possono essere inclusi i contatori delle prestazioni, i dati di configurazione o di dati dei provider di analisi.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Nota

È necessario assegnare al gruppo Performance Log Users il diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

Per creare un insieme agenti di raccolta dati manualmente

  1. Nel riquadro di spostamento di Performance Monitor di Windows espandere Insiemi agenti di raccolta dati, fare clic con il pulsante destro del mouse su Definiti dall'utente, scegliere Nuovo e quindi fare clic su Insieme agenti di raccolta dati. Viene avviata la Creazione guidata Nuovo insieme agenti di raccolta dati.

  2. Immettere un nome per l'insieme agenti di raccolta dati.

  3. Scegliere Crea manualmente e quindi fare clic su Avanti.

  4. Scegliere Crea registri dati.

  5. Selezionare le caselle accanto a tipi di agenti di raccolta dati che si desidera utilizzare e fare clic su Avanti.

    • In Contatori prestazioni sono disponibili i dati metrici relativi alle prestazioni del sistema.

    • In Dati di analisi eventi sono disponibili le informazioni relative alle attività e agli eventi di sistema.

    • L'opzione Informazioni sulla configurazione del sistema consente di registrare lo stato e le modifiche delle chiavi del Registro di sistema.

  6. In base ai tipi degli agenti di raccolta dati selezionati, verranno visualizzate finestre di dialogo che consentono di aggiungere agenti di raccolta dati al proprio insieme agenti di raccolta dati.

    • Fare clic su Aggiungi. Verrà visualizzata la finestra di dialogo Aggiungi contatori. Dopo aver terminato di aggiungere i contatori delle prestazioni, fare clic su Avvia per continuare la configurazione oppure su Fine per uscire e salvare la configurazione corrente.

    • È possibile installare i provider di analisi degli eventi con il sistema operativo o come parte di un'applicazione non Microsoft. Fare clic su Aggiungi per scegliere nell'elenco dei provider di analisi degli eventi disponibili. Per selezionare più provider, premere il tasto CTRL ed eseguire l'evidenziazione. Dopo aver terminato di aggiungere i provider di analisi degli eventi, fare clic su Avvia per continuare la configurazione oppure su Fine per uscire e salvare la configurazione corrente.

    • Registrare le informazioni sulla configurazione del sistema immettendo le chiavi del Registro di sistema delle quali si desidera tenere traccia. È necessario conoscere la chiave esatta che si desidera includere nell'insieme agenti di raccolta dati. Dopo aver terminato di aggiungere le chiavi del Registro di sistema, fare clic su Avvia per continuare la configurazione oppure su Fine per uscire e salvare la configurazione corrente.

      Nota

      Se non sono stati selezionati tutti i tipi di agenti di raccolta dati, non tutte le finestre di dialogo per l'immissione dei dati descritte in questo documento verranno incluse nelle fasi della creazione guidata.

  7. I dati raccolti dall'insieme agenti di raccolta dati saranno contenuti nella Directory radice. Modificare questa impostazione se si desidera archiviare i dati dell'insieme agenti di raccolta dati in una posizione diversa da quella predefinita. Individuare e scegliere la directory o digitare il nome della directory.

    Nota

    Se il nome della directory viene immesso manualmente, non è necessario immettere una barra rovesciata alla fine del nome della directory.

  8. Dopo aver scelto Avanti è possibile configurare l'insieme agenti di raccolta dati da eseguire come utente specifico. Fare clic sul pulsante Cambia per immettere il nome utente e la password per un utente diverso da quello presente nell'elenco predefinito.

    Nota

    Se si è membri del gruppo Performance Log Users, è necessario configurare Insiemi agenti di raccolta dati creati per l'esecuzione con le proprie credenziali.

  9. Scegliere Fine per tornare a Console diagnostica prestazioni Windows.

    • Per visualizzare le proprietà dell'insieme agenti di raccolta dati o per eseguire modifiche aggiuntive per questo insieme agenti di raccolta dati selezionare Visualizza proprietà dell'insieme agenti di raccolta dati. Per ulteriori informazioni sulle proprietà dell'insieme agenti di raccolta dati, vedere Proprietà dell'Insieme agenti di raccolta dati.

    • Per avviare immediatamente l'insieme agenti di raccolta dati e salvare i dati nella posizione specificata nel passaggio 8, scegliere Avvia l'insieme agenti di raccolta dati.

    • Per salvare l'insieme agenti di raccolta dati senza avviare la raccolta, scegliere Salva e chiudi.

Ulteriori considerazioni

  • Per aprire Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

  • Insiemi agenti di raccolta dati viene eseguito dall'utente del sistema predefinito. Per una sicurezza ottimale, è consigliabile accettare questo valore predefinito fino a quando non si hanno motivi validi per modificarlo.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Proprietà dell'Insieme agenti di raccolta dati

  • Pianificare e gestire i dati in Performance Monitor di Windows


Creare un insieme agenti di raccolta dati per monitorare i contatori delle prestazioni

È possibile creare un insieme agenti di raccolta dati personalizzato che contiene i contatori delle prestazioni e configurare le attività di avviso in base ai limiti definiti dall'utente, se vengono superati o non vengono raggiunti, dei contatori delle prestazioni.

Dopo la creazione dell'insieme agenti di raccolta dati, è necessario configurare le azioni che verranno eseguite dal sistema quando vengono soddisfatti i criteri di avviso.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Nota

È necessario assegnare al gruppo Performance Log Users il diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

  • Creare un insieme agenti di raccolta dati per monitorare i contatori delle prestazioni

  • Configurare le azioni di avviso
Per creare un insieme agenti di raccolta dati per monitorare i contatori delle prestazioni

  1. Nel riquadro di spostamento di Performance Monitor di Windows espandere Insiemi agenti di raccolta dati, fare clic con il pulsante destro del mouse su Definiti dall'utente, scegliere Nuovo e quindi fare clic su Insieme agenti di raccolta dati. Viene avviata la Creazione guidata Nuovo insieme agenti di raccolta dati.

  2. Immettere un nome per l'insieme agenti di raccolta dati.

  3. Scegliere l'opzione Crea manualmente e quindi fare clic su Avanti.

  4. Scegliere l'opzione Avviso contatore di prestazioni e quindi fare clic su Avanti.

  5. Fare clic su Aggiungi. Verrà visualizzata la finestra di dialogo Aggiungi contatori. Dopo aver completato l'aggiunta dei contatori, fare clic su OK per tornare alla procedura guidata.

  6. Definire gli avvisi in base ai valori dei contatori di prestazioni selezionati.

    1. Dall'elenco dei contatori delle prestazioni, scegliere il contatore per monitorare e avviare un avviso.

    2. Nell'elenco a discesa Avvisa quando, scegliere se avviare l'avviso quando il valore del contatore delle prestazioni è superiore o inferiore al limite.

    3. Nella casella Limite digitare un valore di soglia.

  7. Al termine fare clic su Avvia per continuare la configurazione oppure su Fine per uscire e salvare la configurazione corrente.

  8. Dopo aver scelto Avanti è possibile configurare l'insieme agenti di raccolta dati da eseguire come utente specifico. Fare clic sul pulsante Cambia per immettere il nome utente e la password per un utente diverso da quello presente nell'elenco predefinito.

    Nota

    Se si è membri del gruppo Performance Log Users, è necessario configurare Insiemi agenti di raccolta dati creati per l'esecuzione con le proprie credenziali.

  9. Fare clic su Fine per tornare a Performance Monitor di Windows.

    • Per visualizzare le proprietà dell'insieme agenti di raccolta dati o per eseguire modifiche aggiuntive per questo insieme agenti di raccolta dati selezionare Visualizza proprietà dell'insieme agenti di raccolta dati. Per ulteriori informazioni sulle proprietà dell'insieme agenti di raccolta dati, vedere Proprietà dell'Insieme agenti di raccolta dati.

    • Per avviare immediatamente l'insieme agenti di raccolta dati e salvare i dati nella posizione specificata nel passaggio 8, scegliere Avvia l'insieme agenti di raccolta dati.

    • Per salvare l'insieme agenti di raccolta dati senza avviare la raccolta, scegliere Salva e chiudi.

Ulteriori considerazioni

  • Per aprire Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

  • Insiemi agenti di raccolta dati viene eseguito dall'utente del sistema predefinito. Per una sicurezza ottimale, è consigliabile accettare questo valore predefinito fino a quando non si hanno motivi validi per modificarlo.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Pianificare e gestire i dati in Performance Monitor di Windows

Per configurare le azioni di avviso

  1. Nel riquadro di spostamento espandere Affidabilità e prestazioni.

  2. Espandere Insiemi agenti di raccolta dati quindi Definita dall'utente e scegliere il nome dall'insieme agenti di raccolta dati con gli avvisi dei contatori delle prestazioni.

  3. Nel riquadro della console, fare clic con il pulsante destro del mouse su un agente di raccolta dati con il tipo Avviso e fare clic su Proprietà.

  4. Nella pagina Proprietà dell'agente di raccolta dati, fare clic sulla scheda Avvisi. Verranno visualizzati gli agenti di raccolta dati e gli avvisi già configurati.

  5. Fare clic sulla scheda Azione avviso per scegliere se scrivere una voce nel registro eventi Registri applicazioni e servizi/Microsoft/Windows/Diagnosis-PLA/Operativo quando vengono soddisfatti i criteri di avviso. È inoltre possibile avviare un insieme agenti di raccolta dati quando vengono soddisfatti i criteri di avviso.

  6. Fare clic sulla scheda Attività di avviso per scegliere un'attività e gli argomenti di Windows Management Interface (WMI) da eseguire quando vengono soddisfatti i criteri di avviso.

Ulteriori considerazioni

  • Per aprire Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Pianificare e gestire i dati in Performance Monitor di Windows


Pianificare e gestire i dati in Performance Monitor di Windows

Per pianificare la raccolta dei dati e gestire l'archiviazione dei dati di registro sulla base di Insieme agenti di raccolta dati viene utilizzato Performance Monitor di Windows. È possibile archiviare i rapporti dopo l'eliminazione dei dati di registro e accedere alle statistiche sulle prestazioni senza archiviare i singoli valori dei contatori.

  • Pianificare la raccolta dei dati in Performance Monitor di Windows

  • Gestire i dati in Performance Monitor di Windows

  • Visualizzare rapporti in Performance Monitor di Windows

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Per ulteriori informazioni sull'utilizzo di Performance Monitor di Windows, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70270.


Pianificare la raccolta dei dati in Performance Monitor di Windows

In Performance Monitor di Windows viene utilizzato un metodo di pianificazione coerente per l'intera raccolta dati.

  • Durante la creazione dell'insieme agenti di raccolta dati, è possibile configurare la pianificazione scegliendo Visualizza proprietà dell'insieme agenti di raccolta dati al termine della Creazione guidata Nuovo insieme agenti di raccolta dati.

  • Dopo la creazione di un insieme agenti di raccolta dati, è possibile accedere alle opzioni di pianificazione facendo clic con il pulsante destro del mouse nel riquadro di spostamento di Microsoft Management Console (MMC) e scegliendo Proprietà.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Nota

È necessario assegnare al gruppo Performance Log Users il diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

Nota

Se Insieme agenti di raccolta dati è stato configurato per l'esecuzione con un altro utente, verrà richiesto di digitare il nome utente e la password ogni volta che vengono modificate le proprietà dell'Insieme agenti di raccolta dati.

  • Pianificare la condizione di avvio per un insieme agenti di raccolta dati

  • Pianificare la condizione di interruzione per un insieme agenti di raccolta dati

Per pianificare la condizione di avvio per un insieme agenti di raccolta dati

  1. In Performance Monitor di Windows espandere Insiemi agenti di raccolta dati e fare clic su Definiti dall'utente.

  2. Nel riquadro della console, fare clic con il pulsante destro del mouse sul nome dell'insieme agenti di raccolta dati che si desidera pianificare e fare clic su Proprietà.

  3. Fare clic sulla scheda Pianificazione.

  4. Fare clic su Aggiungi per creare una data, un'ora o un giorno di avvio della raccolta di dati. Durante la configurazione di un nuovo insieme agenti di raccolta dati, verificare che la data sia posteriore alla data e ora correnti.

  5. Se non si desidera raccogliere nuovi dati dopo un data specifica, selezionare Data scadenza e scegliere una data dal calendario.

    Nota

    La selezione di una data di scadenza non interrompe la raccolta di dati in corso in quella data, ma impedisce nuove istanze di raccolta di dati a partire dalla data di scadenza. È necessario utilizzare la scheda Condizione di interruzione per configurare le modalità di interruzione della raccolta di dati.

  6. Al termine, fare clic su OK.
Per pianificare la condizione di interruzione per un insieme agenti di raccolta dati

  1. In Performance Monitor di Windows espandere Insiemi agenti di raccolta dati e fare clic su Definiti dall'utente.

  2. Nel riquadro della console fare clic con il pulsante destro del mouse sul nome dell'insieme agenti di raccolta dati che si desidera pianificare e scegliere Proprietà.

  3. Fare clic sulla scheda Condizione di interruzione.

  4. Per interrompere la raccolta di dati dopo un periodo di tempo, selezionare la durata complessiva e scegliere la quantità e le unità. Si noti che, per visualizzare tutti i dati nel rapporto, è necessario che la durata complessiva sia più lunga dell'intervallo in cui i dati vengono raccolti. Non selezionare una durata complessiva se si desidera raccogliere i dati per un periodo di tempo indeterminato.

  5. Utilizzare i limiti per segmentare la raccolta di dati in registri separati selezionando Al raggiungimento di un limite, riavvia l'insieme agenti di raccolta dati. Se sono selezionati entrambi i tipi di limiti, la raccolta di dati verrà interrotta o riavviata quando viene raggiunto il primo limite.

    • Selezionare Durata per configurare un periodo di tempo per la raccolta di dati da scrivere in un singolo file di registro.

    • Scegliere Dimensione massima per avviare di nuovo l'insieme agenti di raccolta dati o interrompere la raccolta di dati quando il file di registro raggiunge il limite.

      Nota

      Se è configurata una durata complessiva, i limiti verranno sovrascritti.

  6. Se è stata configurata una durata complessiva, è possibile scegliere Interrompi al termine dell'esecuzione di tutti gli agenti di raccolta dati per consentire a tutti gli agenti di raccolta dati di terminare la registrazione dei valori più recenti prima che l'insieme agenti di raccolta dati venga interrotto.

  7. Al termine, fare clic su OK.

    Importante

    Maggiori sono le dimensioni dei file di registro più lunghi saranno i tempi per la generazione del rapporto. Se i registri vengono esaminati con frequenza per visualizzare i dati recenti, è consigliabile utilizzare limiti per la segmentazione automatica dei registri. È possibile utilizzare il comando relog per segmentare i file di registro lunghi o riunire più file di registro brevi.

Ulteriori considerazioni

  • Per aprire Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

  • Per ulteriori informazioni sul comando relog, al prompt dei comandi digitare relog /? e quindi premere INVIO.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Pianificare e gestire i dati in Performance Monitor di Windows

  • Proprietà dell'Insieme agenti di raccolta dati


Gestire i dati in Performance Monitor di Windows

Insiemi agenti di raccolta consente di creare una file dei dati di registro non elaborati oltre ai file di rapporto facoltativi. Data Management consente di configurare come archiviare i dati di registro, i rapporti e i dati compressi per ogni insieme agenti di raccolta dati.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Nota

È necessario assegnare al gruppo Performance Log Users il diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

Nota

Se Insieme agenti di raccolta dati è stato configurato per l'esecuzione con un altro utente, verrà richiesto di digitare il nome utente e la password ogni volta che vengono modificate le proprietà dell'Insieme agenti di raccolta dati.

Per configurare la gestione di dati per un insieme agenti di raccolta dati

  1. In Performance Monitor di Windows espandere Insiemi agenti di raccolta dati e fare clic su Definiti dall'utente.

  2. Nel riquadro della console, fare clic con il pulsante destro del mouse sul nome dell'insieme agenti di raccolta dati che si desidera configurare e fare clic su Gestore dati.

  3. Nella scheda Gestore dati è possibile accettare i valori predefiniti o apportare le modifiche in base al proprio criterio di mantenimento dei dati. Vedere la tabella seguente per i dettagli su ogni opzione.

    • Quando è selezionata l'opzione Spazio minimo disponibile su disco o Numero max cartelle, i dati precedenti verranno eliminati in base ai Criteri risorse selezionati (Elimina i più grandi o Elimina i meno recenti) quando viene raggiunto il limite.

    • Quando è selezionata l'opzione Applica criteri prima dell'avvio dell'insieme agenti di raccolta dati, i dati precedenti verranno eliminati in base alle selezioni eseguite prima della creazione del file di registro successivo.

    • Quando è selezionata l'opzione Dimensione massima percorso directory radice, i dati precedenti verranno eliminati in base alle selezioni eseguite quando viene raggiunto il limite delle dimensioni della cartella di registro radice.

  4. Selezionare la scheda Azioni. È possibile accettare i valori predefiniti o apportare modifiche. Vedere la tabella seguente per i dettagli su ogni opzione.

    Nota

    Le azioni della cartella consentono di scegliere come archiviare i dati prima di eliminarli in modo permanente. È possibile decidere di disattivare i limiti di Gestore dati a favore della gestione di tutti i dati in base alla regole di azione della cartella.

  5. Al termine delle modifiche, fare clic su OK.
Proprietà di Gestore dati

Opzione | Definizione
Spazio minimo disponibile su disco | La quantità di spazio su disco che deve essere disponibile sull'unità dove sono archiviati i dati di registro. Se l'opzione è selezionata, i dati precedenti verranno eliminati in base ai Criteri risorse scelti quando viene raggiunto il limite.
Numero max cartelle | Il numero di sottocartelle disponibili nella directory dei dati Insieme agenti di raccolta dati. Se l'opzione è selezionata, i dati precedenti verranno eliminati in base ai Criteri risorse scelti quando viene raggiunto il limite.
Criteri risorse | Specifica se eliminare il file di registro o directory meno recenti o più grandi quando vengono raggiunti i limiti.
Dimensione massima percorso directory radice | La dimensione massima della directory dei dati per l'Insieme agenti di raccolta dati comprese tutte le sotto cartelle. Se l'opzione è selezionata, la dimensione massima del percorso sovrascriverà i limiti di Spazio minimo disponibile su disco e Numero max cartelle e i dati precedenti verranno eliminati in base ai Criteri risorse scelti quando viene raggiunto il limite.
Proprietà di Azioni

Opzione | Definizione
Età | L'età in giorni e settimane del file di dati. Se il valore è 0, il criterio non viene utilizzato.
Dimensioni | La dimensione in megabyte (MB) della cartella in cui sono archiviati i dati di registro. Se il valore è 0, il criterio non viene utilizzato.
CAB | Un file CAB in un formato file di archivio. È possibile creare file CAB da dati di registro non elaborati ed estratti in un secondo momento quando è necessario. Scegliere di crearli o eliminarli per eseguire un'operazione in base all'età o ai criteri relativi alle dimensioni.
Dati | Dati di registro non elaborati raccolti dall'Insieme agenti di raccolta dati. È possibile eliminare i dati di registro dopo la creazione di un file CAB per risparmiare spazio su disco mantenendo un backup dei dati originali.
Rapporto | File di rapporto generato da Performance Monitor di Windows da dati di registro non elaborati. È possibile mantenere i file di rapporto anche dopo l'eliminazione dei dati non elaborati o del file CAB.

Ulteriori considerazioni

  • Per aprire Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Pianificare e gestire i dati in Performance Monitor di Windows


Visualizzare rapporti in Performance Monitor di Windows

I modelli di Insieme agenti di raccolta dati possono includere anche i modelli dei rapporti che consentono di interpretare le informazioni sulle prestazioni raccolte durante l'esecuzione.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

Nota

È necessario assegnare al gruppo Performance Log Users il diritto utente Accedi come utente batch come descritto in Abilitare la registrazione per i membri del gruppo Performance Log Users.

Per visualizzare il rapporto di Insieme agenti di raccolta dati

  1. In Performance Monitor di Windows espandere Rapporti e fare clic su Definiti dall'utente o Sistema.

  2. Nel riquadro di spostamento, espandere l'Insieme agenti di raccolta dati che si desidera visualizzare come rapporto.

  3. Fare clic sul rapporto che si desidera visualizzare nell'elenco dei rapporti disponibili. Verrà visualizzato il rapporto nel riquadro della console.

Ulteriori considerazioni

  • Per aprire Performance Monitor di Windows, fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare perfmon e quindi premere INVIO.

  • In alternativa, per visualizzare il rapporto più recente per un'insieme agenti di raccolta dati espandere Insiemi agenti di raccolta dati, espandere Definita dall'utente o Sistema, scegliere il nome dell'Insieme agenti di raccolta dati nel riquadro di spostamento e fare clic sull'icona Visualizza l'ultimo rapporto sulla barra degli strumenti.

  • È inoltre possibile creare un nuovo rapporto per un insieme agenti di raccolta dati digitando perfmon /report "Nome_insieme_agenti_raccolta_dati" al prompt dei comandi. Se si digita perfmon /report senza altri parametri, verrà generato il rapporto Diagnostica di sistema.

  • Se Insieme agenti di raccolta dati non è stato eseguito, non sarà disponibile nessun rapporto.

  • Se Insieme agenti di raccolta dati è in esecuzione, nel riquadro della console verranno visualizzate le informazioni sulla durata configurata per l'esecuzione.

  • Al termine della raccolta dei dati, si verificherà un ritardo fino alla generazione del rapporto. Durante questo periodo di tempo, nel riquadro della console verrà visualizzata un'icona attiva.

  • Maggiori sono le dimensioni dei file di registro più lunghi saranno i tempi per la generazione del rapporto. Se i registri vengono esaminati con frequenza per visualizzare i dati recenti, è consigliabile utilizzare limiti per la segmentazione automatica dei registri. È possibile utilizzare il comando relog per segmentare i file di registro lunghi o riunire più file di registro brevi.

  • Per ulteriori informazioni sul comando relog, digitare relog /? al prompt dei comandi.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Pianificare e gestire i dati in Performance Monitor di Windows


Abilitare la registrazione per i membri del gruppo Performance Log Users

Affinché i membri del gruppo Performance Log Users possano avviare la registrazione dei dati o modificare gli insiemi agenti di raccolta dati, è innanzitutto necessario assegnare al gruppo il diritto utente Accesso come processo batch. Per assegnare questo diritto, utilizzare lo snap-in Criteri di sicurezza locali in Microsoft Management Console.

Per completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente.

Per assegnare il diritto utente "Accesso come processo batch" al gruppo Performance Log Users

  1. Fare clic sul pulsante Start, fare clic nella casella di ricerca, digitare secpol.msc e premere INVIO. Lo snap-in Criteri di sicurezza locali verrà aperto in Microsoft Management Console.

  2. Nel riquadro di spostamento espandere Criteri locali e fare clic su Assegnazione diritti utente.

  3. Nel riquadro della console fare clic con il pulsante destro del mouse su Accesso come processo batch e scegliere Proprietà.

  4. Nella pagina Proprietà fare clic su Aggiungi utente o gruppo.

  5. Nella finestra di dialogo per la selezione di utenti o gruppi fare clic su Tipi di oggetto. Selezionare Gruppi nella finestra di dialogo Tipi di oggetto e fare clic su OK.

  6. Digitare Performance Log Users nella finestra di dialogo per la selezione di utenti o gruppi e quindi fare clic su OK.

  7. Nella pagina Proprietà fare clic su OK.

Ulteriori riferimenti

  • Performance Monitor di Windows

  • Panoramica di Performance Monitor di Windows


Interfaccia utente: Performance Monitor di Windows

  • Finestra di dialogo Aggiungi contatori

  • Proprietà dell'Insieme agenti di raccolta dati


Finestra di dialogo Aggiungi contatori

È possibile aggiungere i contatori delle prestazioni inclusi nel sistema operativo o installati come parte di un'applicazione a un insieme agenti di raccolta dati o a una sessione di Monitoraggio prestazioni. Nella finestra di dialogo Aggiungi contatori è possibile accedere all'elenco completo dei contatori disponibili.

Per aprire la finestra di dialogo Aggiungi contatori è possibile:

  • Creare un insieme agenti di raccolta dati e scegliere di includere i contatori delle prestazioni (la procedura guidata aprirà la finestra di dialogo Aggiungi contatori).

  • Fare clic sul pulsante Aggiungi (+) in Monitoraggio prestazioni per aggiungere un contatore alla schermata corrente di Monitoraggio prestazioni.

  • Fare clic con il pulsante destro del mouse sulla schermata di Monitoraggio prestazioni e scegliere Aggiungi contatori.

Attività comuni nella finestra di dialogo Aggiungi contatori

Attività Procedura

Scegliere il computer di origine per i contatori

Scegliere un computer nell'elenco a discesa o fare clic su Sfoglia per trovare altri computer. È possibile aggiungere i contatori dal computer locale o da un altro computer della rete al quale si ha accesso.

Nota

Nell'elenco sottostante l'elenco a discesa per la scelta del computer vengono visualizzati i contatori disponibili divisi in gruppi. È possibile aggiungere tutti i contatori di un gruppo o scegliere soltanto quelli desiderati.

Visualizzare una descrizione del gruppo di contatori selezionati

Scegliere Mostra descrizione nell'angolo inferiore della pagina. La descrizione verrà aggiornata quando verranno selezionati altri gruppi.

Aggiungere un gruppo di contatori

Evidenziare il nome del gruppo e fare clic su Aggiungi.

Nota

Dopo l'evidenziazione del nome del gruppo, è possibile fare clic sulla Freccia Giù per visualizzare i contatori inclusi. Se viene selezionato un solo contatore nell'elenco prima di fare clic su Aggiungi, verrà aggiunto soltanto quel contatore.

Aggiungere contatori singoli

Espandere il gruppo facendo clic sulla Freccia Giù, evidenziare il contatore e fare clic su Aggiungi.

Nota

È possibile selezionare più contatori da un gruppo premendo il tasto CTRL e facendo clic sui nomi nell'elenco. Dopo aver selezionato tutti i contatori che si desidera aggiungere da quel gruppo, fare clic su Aggiungi.

Cercare istanze di un contatore

Evidenziare il gruppo di contatori o espandere il gruppo ed evidenziare il contatore che si desidera aggiungere, digitare il nome del processo nell'elenco a discesa sottostante la casella Istanze dell'oggetto selezionato e fare clic su Cerca. Il nome del processo digitato sarà disponibile nell'elenco a discesa per ripetere la ricerca con altri contatori.

Se non viene restituito nessun risultato e si desidera cancellare la ricerca, è necessario evidenziare un altro gruppo. Se non vi sono più istanze di un gruppo di contatori o di un contatore, la funzione di ricerca non sarà disponibile.

Aggiungere soltanto determinate istante di un contatore

Evidenziare un gruppo di contatori o un contatore nell'elenco, scegliere il processo nell'elenco che si desidera visualizzare nella casella Istanze dell'oggetto selezionato e fare clic su Aggiungi.

Più processi possono creare lo stesso contatore, ma scegliendo un'istanza verranno selezionati soltanto i contatori prodotti dal processo indicato.

Nota

A meno che non venga scelta un'istanza specifica, verranno selezionate tutte le istanze di un contatore.

Ulteriori considerazioni

  • Per eseguire queste procedure, è necessaria almeno l'appartenenza al gruppo Performance Log Users o Administrators locale o a un gruppo equivalente.

  • Se vengono aggiunti contatori a un insieme agenti di raccolta dati esistente che è stato configurato per l'esecuzione con un altro utente, verrà richiesto di digitare il nome utente e la password ogni volta che vengono modificate le proprietà dell'Insieme agenti di raccolta dati.

  • Per aggiungere contatori delle prestazioni da un computer remoto, è necessario attivare l'eccezione Avvisi e registri di prestazioni del firewall nel computer remoto. I membri del gruppo Performance Log Users devono inoltre appartenere al gruppo Lettori registri eventi nel computer remoto.

Ulteriori riferimenti

  • Performance Monitor di Windows


Proprietà dell'Insieme agenti di raccolta dati

Per visualizzare o modificare le proprietà di un insieme agenti di raccolta dati dopo la creazione, è possibile:

  • Selezionare la casella di controllo Visualizza proprietà dell'insieme agenti di raccolta dati al termine della Creazione guidata Insieme agenti di raccolta dati.

  • Fare clic con il pulsante destro del mouse sul nome di un insieme agenti di raccolta dati nell'albero dell'ambito di MMC o nella finestra della console e quindi scegliere Proprietà dal menu di scelta rapida.

Scheda Dettagli

Generale

Nella scheda Generale è inclusa la descrizione e le parole chiave associate all'insieme agenti di raccolta dati. Se l'insieme agenti di raccolta dati è stato creato da un modello con descrizione e parole chiave, questi saranno inclusi qui. Se è stato creato un insieme agenti di raccolta dati personalizzato, è possibile aggiungere i dati qui per identificarli in un secondo momento o per fornire maggiori informazioni ad altri in caso di esportazione come modello.

Per modificare l'utente che eseguirà l'insieme agenti di raccolta dati con il comando Esegui come fare clic su Cambia… e immettere un nome utente e una password.

Importante

È necessario eseguire l'insieme agenti di raccolta dati come utente con credenziali amministrative o come membro del gruppo Performance Log Users.

Nota

Se l'insieme agenti di raccolta dati è configurato per l'esecuzione con credenziali di livello superiore rispetto a quelle dell'utente attualmente connesso, verrà richiesto di immettere il nome utente e la password dell'account con il quale è configurata l'esecuzione quando vengono cambiate le proprietà.

Directory

Oltre a definire una directory radice per l'archiviazione dei dati dell'insieme agenti di raccolta dati, è possibile specificare una sola Sottodirectory o creare un Formato nome sottodirectory facendo clic sulla freccia a destra del campo di immissione testo. Nella Directory di esempio nella parte inferiore della pagina è disponibile un esempio in tempo reale della directory e/o della sottodirectory in cui sono stati archiviati i dati dell'insieme agenti di raccolta dati.

Sicurezza

È possibile modificare le autorizzazioni dei gruppi o degli utenti per l'insieme agenti di raccolta dati scegliendo il nome del gruppo o dell'utente e selezionando le caselle di controllo Consenti o Nega per ogni tipo di autorizzazione. Per aggiungere, rimuovere o modificare i tipi di autorizzazioni, fare clic sul pulsante Avanzate.

Nota

Le modifiche delle autorizzazioni, comprese le modifiche implementate nella sezione Avanzate, si applicano soltanto all'insieme agenti di raccolta dati.

Pianificazione

Nella scheda Pianificazione sono incluse le opzioni di configurazione quando viene avviata la raccolta di dati. Per ulteriori informazioni, vedere Pianificare e gestire i dati in Performance Monitor di Windows. Utilizzare la scheda Condizione di interruzione per configurare l'interruzione della raccolta di dati.

Condizione di interruzione

È possibile utilizzare una sola condizione di interruzione o una combinazione di più criteri per bloccare o riavviare la raccolta di dati da un insieme agenti di raccolta dati.

Selezionare le caselle di controllo per scegliere una o tutte le condizioni di interruzione che si desidera applicare all'insieme agenti di raccolta dati. Se non viene selezionata nessuna condizione di interruzione in questa scheda, verranno raccolti dati dall'ora di avvio, manuale o automatico, fino all'interruzione manuale.

L'opzione Durata complessiva determina l'interruzione della raccolta di dati quando l'ora configurata è trascorsa. L'impostazione della durata complessiva ha la precedenza su tutte le impostazioni definite come limiti.

È possibile utilizzare l'opzione Limiti anziché o in aggiunta alla condizione di interruzione della durata complessiva.

Selezionare questa casella di controllo per il riavvio automatico della raccolta dell'insieme agenti di raccolta dati quando vengono raggiunti i limiti per la durata, la dimensione, o entrambi. Quando viene utilizzata insieme alla condizione di interruzione della durata complessiva, la configurazione dei riavvii automatici determinerà la raccolta di dati in file di registro separati per ogni periodo di tempo o dimensione specificati fino a quando viene soddisfatta la condizione di interruzione della durata complessiva.

Attività

È possibile eseguire un'attività di Strumentazione gestione Windows (WMI) al completamento della raccolta dell'insieme agenti di raccolta dati digitando il comando nella casella Esegui l'operazione dopo l'interruzione dell'insieme agenti di raccolta dati. Per le opzioni fare riferimento alla documentazione relativa alle attività di WMI.