Infrastruttura a chiave pubblica dell'organizzazione

Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione consente di monitorare e gestire una o più infrastrutture a chiave pubblica (PKI) e Autorità di certificazione (CA) in un'organizzazione.

  • Panoramica di Infrastruttura a chiave pubblica dell'organizzazione

  • Usare Infrastruttura a chiave pubblica dell'organizzazione

  • Risolvere i problemi relativi a Infrastruttura a chiave pubblica dell'organizzazione


Panoramica di Infrastruttura a chiave pubblica dell'organizzazione

Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione consente di visualizzare lo stato di tutte le Autorità di certificazione (CA) in una o più infrastrutture a chiave pubblica (PKI) presenti nella rete. Tramite la visualizzazione di più CA e del relativo stato, gli amministratori sono in grado di gestire le gerarchie di CA e di risolvere eventuali errori relativi alle CA in modo più semplice ed efficace.

  • Concetti relativi a Infrastruttura a chiave pubblica dell'organizzazione

  • Codici di stato di Infrastruttura a chiave pubblica dell'organizzazione


Concetti relativi a Infrastruttura a chiave pubblica dell'organizzazione

Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione consente di verificare che tutti gli elementi seguenti in un'infrastruttura a chiave pubblica (PKI) siano funzionanti, disponibili e validi:

  • Autorità di certificazione (CA). Una CA accetta una richiesta di certificato, verifica le informazioni del richiedente in base al criterio della CA e infine utilizza la propria chiave privata per firmare il certificato. La CA rilascia quindi il certificato al soggetto richiedente, che potrà utilizzarlo come credenziale di sicurezza nell'ambito di una PKI. Una CA ha inoltre il compito di revocare i certificati e di pubblicare un elenco di revoche dei certificati (CRL).

  • Certificati CA. Un certificato CA è un certificato rilasciato da una CA a se stessa o a una seconda CA allo scopo di creare una relazione definita tra le due CA. Un certificato che viene rilasciato da una CA a se stessa è definito un certificato radice attendibile. I certificati CA sono fondamentali per poter definire il percorso di un certificato e le restrizioni relative all'utilizzo di tutti i certificati finali che sono stati rilasciati per essere utilizzati nella PKI.

  • Percorsi AIA. I percorsi AIA sono URL che vengono aggiunti a un certificato nella relativa estensione Accesso alle informazioni dell'autorità (AIA). Tali URL possono essere utilizzati da un'applicazione o da un servizio per recuperare il certificato della CA di emissione. Tali certificati CA vengono quindi utilizzati per convalidare la firma del certificato e per costruire il percorso di un certificato attendibile.

  • Elenchi CRL. Gli elenchi CRL sono elenchi completi, firmati digitalmente, di certificati non scaduti che sono stati revocati. I client possono recuperare un elenco CRL, memorizzarlo nella cache (in base alla durata configurata per l'elenco CRL) e utilizzarlo per verificare i certificati che vengono presentati.

  • Punti di distribuzione CRL. I punti di distribuzione CRL sono percorsi, in genere URL, che vengono aggiunti a un certificato nella relativa estensione Punti di distribuzione CRL. I punti di distribuzione CRL possono essere utilizzati da un'applicazione o da un servizio per recuperare un elenco CRL e vengono contattati quando un'applicazione o un servizio devono verificare se un certificato è stato revocato prima della scadenza del periodo di validità.

Lo snap-in Autorità di certificazione consente a un amministratore di monitorare e gestire questi elementi della PKI per una singola CA. In presenza di più di una CA, tuttavia, è necessario utilizzare istanze separate dello snap-in per monitorare e gestire una PKI. Lo snap-in Autorità di certificazione non può inoltre essere utilizzato per integrare CA non Microsoft nell'infrastruttura o per gestire in modo efficace i percorsi AIA e gli archivi dei punti di distribuzione CRL. Per risolvere questi problemi utilizzando un solo snap-in è pertanto possibile utilizzare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione.

Per ulteriori informazioni sul modo in cui le Autorità di certificazione (CA), i certificati CA, i percorsi di Accesso alle informazioni dell'autorità (AIA), i punti di distribuzione CRL e gli elenchi CRL concorrono alla creazione di una gerarchia di trust a chiave pubblica, vedere la pagina relativa al funzionamento di Servizi certificati all'indirizzo http://go.microsoft.com/fwlink/?LinkID=88045

Ulteriori riferimenti

  • Panoramica di Infrastruttura a chiave pubblica dell'organizzazione

  • Pagina relativa a Servizi certificati Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkID=48545


Codici di stato di Infrastruttura a chiave pubblica dell'organizzazione

Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione consente di visualizzare lo stato delle Autorità di certificazione (CA) e dei risponditori online in una o più infrastrutture a chiave pubblica (PKI). Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione consente inoltre di verificare la validità e l'accessibilità dei percorsi di Accesso alle informazioni dell'autorità (AIA) e dei punti di distribuzione degli elenchi di revoche dei certificati (CRL).

Per ogni CA selezionata, lo snap-in Infrastruttura a chiave pubblica dell'organizzazione indica uno degli stati di integrità delle CA elencati nella tabella seguente.

Indicatore | Stato CA
Punto interrogativo | Valutazione stato integrità CA
Indicatore verde | Nessun problema per la CA
Indicatore giallo | Uno o più problemi non critici per la CA
Indicatore rosso | Uno o più problemi critici per la CA
Croce rossa su icona di CA | CA offline

Se l'ambiente include uno o più risponditori online, è possibile utilizzare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione per monitorare lo stato di tali componenti. Gli indicatori e gli stati di integrità nella tabella seguente si riferiscono ai risponditori online.

Indicatore | Stato risponditore online
Punto interrogativo | Valutazione stato integrità risponditore online
Indicatore verde | Nessun problema per il risponditore online
Indicatore giallo | Uno o più problemi non critici per il risponditore online
Indicatore rosso | Uno o più problemi critici per il risponditore online
Croce rossa su icona di CA | Il risponditore online è offline

I codici di stato seguenti si riferiscono ai punti di distribuzione CRL, ai punti di distribuzione Delta CRL e ai percorsi AIA.

Indicatore | Stato punto di distribuzione CRL o percorso AIA
Punto interrogativo | Valutazione stato integrità percorso
Indicatore verde | I dati sono disponibili e non presentano problemi
Indicatore giallo | I dati sono disponibili e presentano uno o più problemi non critici
Indicatore rosso | I dati sono disponibili ma presentano uno o più problemi critici
Croce rossa su icona di CA | I dati non sono disponibili

Per problemi riguardanti il risponditore online, utilizzare lo snap-in Risponditore in linea per un'ulteriore diagnosi e risoluzione del problema. Per problemi riguardanti CA, punti di distribuzione CRL e percorsi AIA, utilizzare lo snap-in Autorità di certificazione per un'ulteriore diagnosi e risoluzione del problema. Verificare inoltre il registro eventi dei computer che ospitano i servizi ruolo di Servizi certificati Active Directory per ulteriori informazioni utili per l'identificazione e la risoluzione dei problemi. Per ulteriori informazioni sulla risoluzione dei problemi relativi alle Autorità di certificazione (CA), a Risponditore in linea, alla convalida dei certificati e alla verifica delle revoche, vedere la pagina relativa a Servizi certificati Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89215.

Ulteriori riferimenti

  • Panoramica di Infrastruttura a chiave pubblica dell'organizzazione


Usare Infrastruttura a chiave pubblica dell'organizzazione

Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione è principalmente uno strumento di monitoraggio. Molti dei problemi identificabili tramite questo strumento possono essere risolti utilizzando gli snap-in Modelli di certificato, Autorità di certificazione o Risponditore in linea. Tuttavia lo snap-in Infrastruttura a chiave pubblica dell'organizzazione consente di eseguire direttamente una serie di attività riguardanti i contenitori di Servizi certificati Active Directory.

  • Installare la Console di Infrastruttura a chiave pubblica dell'organizzazione

  • Configurare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione

  • Gestire le Autorità di certificazione con Infrastruttura a chiave pubblica dell'organizzazione

  • Gestire i contenitori di Active Directory con Infrastruttura a chiave pubblica dell'organizzazione


Installare la Console di Infrastruttura a chiave pubblica dell'organizzazione

Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione non viene visualizzato nell'elenco degli snap-in predefiniti di Microsoft Management Console (MMC). Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione viene visualizzato nell'elenco Aggiungi/Rimuovi snap-in soltanto dopo avere installato nel computer uno o più servizi ruolo di Servizi certificati Active Directory o dopo avere installato Strumenti di amministrazione remota del server per Servizi certificati Active Directory da Server Manager.

Per poter completare questa procedura, è necessario essere un amministratore del server.

Per installare Strumenti di amministrazione remota del server per Servizi certificati Active Directory

  1. In Server Manager fare clic su Aggiungi funzionalità per avviare l'Aggiunta guidata funzionalità.

  2. Nella finestra Selezione funzionalità fare clic sul segno più (+) a sinistra della casella di controllo Strumenti di amministrazione remota del server e quindi sul segno più (+) a sinistra della casella di controllo Strumenti di amministrazione ruoli.

  3. Selezionare la casella di controllo Servizi certificati Active Directory, fare clic su Avanti e quindi su Installa.

  4. Al termine dell'installazione, fare clic su Chiudi.

Se il computer dal quale si desidera svolgere attività di amministrazione remota esegue Windows Vista, è possibile ottenere il pacchetto Strumenti di amministrazione remota del server dall'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89361.

Dopo avere installato Strumenti di amministrazione remota del server di Servizi certificati Active Directory o uno o più servizi ruolo di Servizi certificati Active Directory, è possibile utilizzare la procedura seguente per installare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione.

Per poter completare questa procedura, è necessario essere un amministratore locale.

Per installare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare mmc e quindi premere INVIO.

  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

  3. Aggiungere lo snap-in Infrastruttura a chiave pubblica dell'organizzazione all'elenco a destra.

  4. Fare clic su OK.

Ulteriori riferimenti

  • Usare Infrastruttura a chiave pubblica dell'organizzazione


Configurare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione

Nel riquadro sinistro, o albero della console, dello snap-in Infrastruttura a chiave pubblica dell'organizzazione è disponibile una visualizzazione albero delle infrastrutture a chiave pubblica (PKI) e delle Autorità di certificazione (CA) dell'organizzazione (enterprise) presenti in un'organizzazione.

Se si seleziona una PKI specifica nell'albero della console, nel riquadro dei dettagli verrà visualizzato lo stato dell'intera PKI: OK se tutto è configurato e funziona in modo corretto o Errore se sono presenti problemi che richiedono un intervento.

Se si seleziona una CA specifica nell'albero della console, verranno visualizzate ulteriori informazioni utili per identificare l'origine di una condizione di errore, come la disponibilità, la scadenza o l'indisponibilità degli elementi seguenti:

  • Certificato CA

  • Percorsi AIA

  • Punti di distribuzione CRL

  • Punti di distribuzione Delta CRL

Facendo clic con il pulsante destro del mouse sul nome della PKI nell'albero della console, è possibile configurare la visualizzazione degli eventuali avvisi relativi ai componenti seguenti delle CA nella gerarchia in questione.

Componente | Descrizione
Imposta lo stato del certificato su In scadenza se la scadenza è tra: | Quanti giorni prima della scadenza di un certificato CA verrà visualizzato un avviso
Imposta lo stato CRL su In scadenza se la scadenza è tra: | Quante ore o quanti giorni prima della scadenza di un elenco CRL verrà visualizzato un avviso
Imposta lo stato Delta CRL su In scadenza se la scadenza è tra: | Quante ore o quanti giorni prima della scadenza di un elenco Delta CRL verrà visualizzato un avviso

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per modificare le opzioni relative agli avvisi per una PKI

  1. Aprire lo snap-in Infrastruttura a chiave pubblica dell'organizzazione.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Infrastruttura a chiave pubblica dell'organizzazione.

  3. Scegliere Opzioni.

  4. Esaminare e modificare il numero di giorni o di ore selezionato per i certificati CA e gli elenchi CRL e Delta CRL.

  5. Fare clic su OK.

  6. Scegliere Aggiorna dal menu Azione.

Ulteriori riferimenti

  • Usare Infrastruttura a chiave pubblica dell'organizzazione


Gestire le Autorità di certificazione con Infrastruttura a chiave pubblica dell'organizzazione

Le Autorità di certificazione (CA) sono elencate in base al nome e al percorso loro assegnato nell'infrastruttura a chiave pubblica (PKI), con le CA radice al vertice della gerarchia e le CA subordinate a seguire. Le CA vengono visualizzate nell'albero della console oppure nel riquadro dei dettagli, a seconda che nell'albero della console sia selezionata la PKI o una CA. Quando si fa doppio clic su una CA nel riquadro dei dettagli, questa viene espansa e selezionata nell'albero della console.

Lo stato della CA verrà indicato dai messaggi OK, Avviso, Errore o Impossibile scaricare. Tali messaggi di stato segnalano l'eventuale presenza di un problema, relativo ad esempio al certificato CA, ai percorsi dei punti di distribuzione CRL o ai percorsi di accesso alle informazioni dell'autorità (AIA), oppure che non è stata ottenuta nessuna informazione sullo stato. Per i messaggi di stato specifici e il relativo significato, vedere Codici di stato di Infrastruttura a chiave pubblica dell'organizzazione.

Se un problema o un avviso riguarda solo una CA subordinata, l'indicatore di errore verrà visualizzato soltanto sull'icona di tale CA.

Quando si fa clic con il pulsante destro del mouse su una CA o si fa clic sul menu Azione, vengono visualizzate le due opzioni seguenti:

  • Gestisci CA, che consente di aprire lo snap-in Autorità di certificazione. Se l'utente dispone delle autorizzazioni necessarie, lo snap-in Autorità di certificazione potrà essere utilizzato per eseguire diverse attività di gestione per la CA.

  • Aggiorna, che consente di avviare un aggiornamento di tutte le informazioni disponibili sullo stato della CA.

Per ulteriori informazioni sulla personalizzazione della visualizzazione di diversi codici di avviso, vedere Configurare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione.

Ulteriori riferimenti

  • Usare Infrastruttura a chiave pubblica dell'organizzazione


Gestire i contenitori di Active Directory con Infrastruttura a chiave pubblica dell'organizzazione

Le Autorità di certificazione o CA globali (enterprise) pubblicano certificati, elenchi di revoche di certificati (CRL) e altri dati nei contenitori di Active Directory. Lo snap-in Infrastruttura a chiave pubblica dell'organizzazione consente di esplorare e gestire gli oggetti in tali contenitori.

I contenitori di Active Directory che è possibile gestire con lo snap-in Infrastruttura a chiave pubblica dell'organizzazione sono:

  • NTAuthCertificates. Contiene tutti i certificati CA nella foresta corrente. I certificati vengono aggiunti automaticamente quando un membro del gruppo Enterprise Admins installa una nuova CA. È inoltre possibile aggiungere manualmente i certificati tramite la finestra di dialogo Gestisci contenitori AD .

  • Contenitore AIA. Contiene i certificati CA che possono essere recuperati dai client tramite l'estensione dei certificati Accesso alle informazioni dell'autorità (AIA) per creare una catena di certificati validi e recuperare tutti i certificati incrociati rilasciati dalla CA.

  • Contenitore CDP. Contiene tutti gli elenchi Base CRL e Delta CRL pubblicati nella foresta.

  • Contenitore agente di recupero chiavi. Contiene i certificati per gli agenti di recupero chiavi relativi alla foresta. È necessario configurare gli agenti di recupero chiavi per consentire l'archiviazione e il recupero delle chiavi. È possibile aggiungere automaticamente i certificati degli agenti di recupero chiavi a questo contenitore eseguendo una registrazione con una CA globale (enterprise). Non è possibile aggiungere manualmente i certificati degli agenti di recupero chiavi tramite la finestra di dialogo Gestisci contenitori AD .

  • Contenitore Autorità di certificazione. Contiene i certificati delle CA radice attendibili presenti nella foresta. I certificati delle CA radice vengono aggiunti automaticamente quando un membro del gruppo Enterprise Admins configura una CA radice dell'organizzazione (enterprise) o una CA radice autonoma che fa parte del dominio. È inoltre possibile aggiungere manualmente i certificati CA radice al prompt dei comandi, ma non tramite la finestra di dialogo Gestisci contenitori AD.

  • Contenitore servizi di registrazione. Contiene i certificati per le CA globali (enterprise) che sono disponibili per il rilascio di certificati a utenti, computer o servizi nella foresta. Per poter aggiungere i certificati delle CA globali (enterprise) a questo contenitore, è necessario appartenere al gruppo Enterprise Admins e installare una CA globale (enterprise). Non è possibile aggiungere manualmente i certificati tramite la finestra di dialogo Gestisci contenitori AD .

Ulteriori riferimenti

  • Usare Infrastruttura a chiave pubblica dell'organizzazione

  • Aggiungere i certificati pubblicati ai contenitori di Active Directory

  • Eliminare gli oggetti inutilizzati dai contenitori di Active Directory


Aggiungere i certificati pubblicati ai contenitori di Active Directory

Tutti i certificati delle Autorità di certificazione (CA) presenti nel dominio Active Directory della foresta corrente vengono archiviati nel contenitore NTAuthCertificates. I certificati delle CA globali (enterprise) vengono aggiunti automaticamente quando viene installata una nuova CA.

Se un certificato CA non viene aggiunto automaticamente durante la creazione della nuova CA, ad esempio una CA autonoma creata da un utente che non appartiene al gruppo Enterprise Admins, è comunque possibile aggiungere manualmente il certificato CA al contenitore NTAuthCertificates. Lo stesso processo consente inoltre di aggiungere il certificato CA di una CA non Microsoft utilizzato per il rilascio dell'accesso con smart card o per il rilascio di certificati del controller di dominio. Pubblicando tali certificati CA nell'archivio NTAuth dell'organizzazione, l'amministratore attesta l'attendibilità della CA per il rilascio di certificati di questo tipo.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins oppure a un gruppo equivalente.

Per aggiungere un certificato al contenitore NTAuthCertificates tramite l'interfaccia di Windows

  1. Esportare il certificato della CA in un file con estensione cer che supporti il formato binario codificato DER (Distinguished Encoding Rules) o il formato X.509 codificato in base 64.

  2. Aprire lo snap-in Infrastruttura a chiave pubblica dell'organizzazione, fare clic con il pulsante destro del mouse su Infrastruttura a chiave pubblica dell'organizzazione nell'albero della console e quindi scegliere Gestisci contenitori AD.

  3. Fare clic sul contenitore NTAuthCertificates.

  4. Scegliere Aggiungi e selezionare il file con estensione cer relativo al certificato da aggiungere. Fare clic su OK.

È inoltre possibile aggiungere un certificato al contenitore NTAuthCertificates tramite lo strumento della riga di comando Certutil.

Per aggiungere un certificato al contenitore NTAuthCertificates tramite una riga di comando

  1. Esportare il certificato della CA in un file con estensione cer che supporti il formato binario codificato DER o il formato X.509 codificato in base 64.

  2. Aprire una finestra del prompt dei comandi, digitare il comando seguente e premere INVIO:

    certutil -dspublish -f filename NTAuthCA

Ulteriori riferimenti

  • Eliminare gli oggetti inutilizzati dai contenitori di Active Directory


Eliminare gli oggetti inutilizzati dai contenitori di Active Directory

In alcune situazioni potrebbe essere necessario disinstallare una Autorità di certificazione (CA). Tuttavia i client non saranno in grado di inviare richieste a tale CA e alcune applicazioni che dipendono dall'Infrastruttura a chiave pubblica interessata potrebbero non funzionare correttamente dopo la disinstallazione di una CA necessaria per verificare la validità e lo stato della revoca di un certificato.

Se si rimuove definitivamente la CA prima della data di scadenza prevista, è necessario che il certificato CA venga revocato dalla CA padre e che il motivo della revoca del certificato sia "Termine operazione". Se si tratta di una CA radice autofirmata, è necessario che vengano revocati tutti i certificati non ancora scaduti e che venga generato un elenco di revoche di certificati (CRL) con lo stesso motivo. Viene in tal modo indicato che i certificati non sono più validi perché la CA è stata rimossa.

Quando si disinstalla un'Autorità di certificazione dell'organizzazione (enterprise), è importante che la disinstallazione avvenga in modo corretto affinché l'oggetto di registrazione CA venga rimosso da Servizi di dominio Active Directory. In caso contrario, i client di Servizi di dominio Active Directory continueranno a effettuare tentativi di registrazione presso tale CA. Se un'Autorità di certificazione dell'organizzazione (enterprise) non può essere disinstallata normalmente, è possibile utilizzare lo snap-in Infrastruttura a chiave pubblica dell'organizzazione per rimuovere manualmente gli oggetti CA da Servizi di dominio Active Directory.

Nota

È consigliabile eseguire il backup dell'intero server prima di disinstallare la CA.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Enterprise Admins oppure a un gruppo equivalente.

Per rimuovere gli oggetti inutilizzati correlati ai certificati dai contenitori di Active Directory

  1. Aprire lo snap-in Infrastruttura a chiave pubblica dell'organizzazione.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Infrastruttura a chiave pubblica dell'organizzazione e quindi scegliere Gestisci contenitori AD.

  3. Selezionare uno dei contenitori e quindi selezionare uno o più oggetti al suo interno.

  4. Fare clic su Visualizza per esaminare il contenuto dei singoli oggetti se non si è certi che si riferiscano effettivamente alla CA da disinstallare.

  5. Fare clic su Rimuovi.

  6. Selezionare un diverso contenitore e ripetere i passaggi da 3 a 5 per rimuovere tutti gli oggetti non più necessari.

Ulteriori riferimenti

  • Aggiungere i certificati pubblicati ai contenitori di Active Directory


Risolvere i problemi relativi a Infrastruttura a chiave pubblica dell'organizzazione

Infrastruttura a chiave pubblica dell'organizzazione è principalmente uno strumento di monitoraggio. In quanto tale, spesso è il primo strumento con cui un amministratore rileva un problema o un potenziale problema relativo all'infrastruttura a chiave pubblica (PKI). È pertanto importante conoscere le modalità per reperire ulteriori informazioni per la diagnosi e la risoluzione dei problemi prima che questi diventino potenzialmente più seri.

Se viene rilevato un errore grave su un server che ospita una Autorità di certificazione (CA) o Risponditore in linea, è necessario esaminare gli eventi registrati nel Visualizzatore eventi in tale computer per ottenere ulteriori informazioni che consentano di diagnosticare e risolvere il problema.

Per problemi relativi alle CA, ad esempio difficoltà di connessione a un elenco di revoche dei certificati (CRL) corrente, è possibile correggere il problema utilizzando lo snap-in Autorità di certificazione.

Per problemi relativi a Risponditore in linea, è possibile utilizzare lo snap-in Risponditore in linea per eseguire attività come la correzione dei problemi di configurazione delle revoche.

Se Infrastruttura a chiave pubblica dell'organizzazione indica che uno o più certificati CA sono prossimi alla scadenza, è possibile utilizzare lo snap-in Certificati per rilasciare di nuovo o rinnovare tali certificati.

È possibile attivare la diagnostica CryptoAPI 2.0 per ottenere ulteriori informazioni su numerosi problemi correlati alla PKI.

Per poter completare questa procedura, è necessario essere un amministratore locale.

Per attivare la diagnostica CryptoAPI 2.0 avanzata

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Strumenti di amministrazione e quindi Visualizzatore eventi.

  2. Espandere le cartelle Registri applicazioni e servizi, Microsoft e Windows.

  3. Aprire la cartella CAPI2, fare clic con il pulsante destro del mouse su Operativo e scegliere Attiva registro.

  4. Se il registro contiene dati prima che un problema venga riprodotto, fare clic con il pulsante destro del mouse su Operativo e scegliere Cancella registro. In tal modo verranno raccolti nel registro salvato soltanto i dati attinenti allo scenario del problema.

  5. Aprire lo snap-in Servizi, fare clic con il pulsante destro del mouse su Servizi certificati Active Directory e scegliere Riavvia.

  6. Dopo aver raccolto i dati relativi all'evento, fare clic con il pulsante destro del mouse su Operativo, scegliere Salva eventi con nome e infine digitare un nome per il file dell'evento per salvare il file di registro. È possibile salvare il file di registro con estensione evtx (per aprirlo in Visualizzatore eventi) o con estensione xml.
Nota

La dimensione massima predefinita per il registro eventi è di 1 MB. Nel caso della diagnostica CryptoAPI 2.0, la dimensione del registro può aumentare rapidamente ed è pertanto consigliabile aumentare la dimensione massima del registro ad almeno 4 MB per acquisire gli eventi da analizzare. Per aumentare la dimensione massima del registro, fare clic con il pulsante destro del mouse su Operativo e quindi scegliere Proprietà. Nelle proprietà del registro aumentare la dimensione massima del registro.

Per ulteriori informazioni sulla diagnostica CryptoAPI 2.0, vedere la pagina relativa alla risoluzione dei problemi PKI in Windows Vista all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89570

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle Autorità di certificazione (CA), agli elenchi CRL, all'accesso ai certificati e ai risponditori online, vedere la pagina relativa a Servizi certificati Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89215.