Gestione stampa

Gestione stampa consente di condividere stampanti nella rete e gestire le attività del server di stampa e delle stampanti di rete in modo centralizzato.

  • Panoramica di Servizi di stampa e digitalizzazione

  • Panoramica di Gestione stampa

  • Elenco di controllo: distribuire server di stampa

  • Distribuire stampanti e server di stampa

  • Gestire stampanti e server di stampa

  • Risorse su Gestione stampa

  • Interfaccia utente: Gestione stampa


Panoramica di Servizi di stampa e digitalizzazione

Servizi di stampa e digitalizzazione è un ruolo server di Windows Server 2008 R2 che consente di condividere stampanti e scanner di una rete, impostare server di stampa e server di digitalizzazione e centralizzare le attività di gestione della stampante e dello scanner di rete. È possibile eseguire queste attività tramite gli snap-in Gestione Stampa e Gestione digitalizzazione di Microsoft Management Console. È possibile utilizzare tali snap-in per monitorare stampanti e scanner di rete e gestire server di stampa e server di digitalizzazione Windows in un'organizzazione.

Gestire risorse di stampa e di digitalizzazione

Per la gestione di server di stampa e server di digitalizzazione sono disponibili tre strumenti principali:

  • Server Manager

  • Gestione stampa

  • Gestione digitalizzazione

In Windows Server 2008 R2 è possibile utilizzare Server Manager per installare il ruolo server e i servizi ruolo Servizi di stampa e digitalizzazione. I servizi ruolo installano anche gli snap-in Gestione stampa e Gestione digitalizzazione.

Gli snap-in Gestione stampa e Gestione digitalizzazione sono inoltre disponibili in computer che eseguono Windows 7.

Gestione stampa consente di monitorare le code di stampa e ricevere notifiche quando queste interrompono l'elaborazione dei processi di stampa. Consente inoltre di eseguire la migrazione di server di stampa e distribuire connessioni con stampanti tramite Criteri di gruppo.

Gestione digitalizzazione consente di monitorare scanner di rete e server di digitalizzazione, elaborare documenti digitalizzati e quindi inviarli a cartelle di rete, siti Web Windows SharePoint e a destinatari di posta elettronica.

Servizi ruolo Servizi di stampa e digitalizzazione

Il ruolo Servizi di stampa e digitalizzazione in Windows Server 2008 R2 include quattro servizi ruolo importanti per la gestione di risorse di stampa e digitalizzazione. I primi tre servizi ruolo offrono la funzionalità per un server di stampa, mentre Server Digitalizzazione distribuita offre la funzionalità per un server di digitalizzazione. È possibile aggiungere i servizi ruolo durante l'installazione del ruolo Servizi di stampa e digitalizzazione, utilizzando l'Aggiunta guidata ruolo di Server Manager oppure installarli in un momento successivo, sempre utilizzando l'Aggiunta guidata ruoli di Server Manager.

Nota

Poiché Windows 7 è un sistema operativo client, non include i servizi ruolo. Include invece gli snap-in di MMC Gestione stampa e Gestione digitalizzazione. Windows 7 include inoltre il servizio ruolo del Servizio di stampa LPD (Line Printer Daemon) come funzionalità facoltativa di Windows. Windows 7 non include i servizi ruolo Stampa Internet o Server Digitalizzazione distribuita.

Servizio ruolo Server di stampa

Server di stampa è un servizio ruolo del ruolo Servizi di stampa e digitalizzazione che installa lo snap-in Gestione stampa. È possibile utilizzare Gestione stampa per gestire più stampanti di rete o server di stampa e per eseguire la migrazione di stampanti da e verso altri server di stampa Windows.

Servizio ruolo servizio LPD

Il servizio ruolo servizio LPD (Line Printer Daemon) installa e avvia il servizio Server di stampa TCP/IP (LPDSVC), che consente ai computer basati su UNIX o ad altri computer che utilizzano il servizio LPR (Line Printer Remote) di stampare sulle stampanti condivise presenti nel server.

Servizio ruolo Stampa Internet

Il servizio ruolo Stampa Internet di Windows Server 2008 R2 crea un sito Web ospitato da Internet Information Services (IIS). Questo sito Web consente agli utenti di gestire processi di stampa nel server e di utilizzare un Web browser per connettersi e stampare sulle stampanti condivise presenti sul server utilizzando il protocollo IPP (Internet Printing Protocol). È necessario che gli utenti abbiano installato Client di stampa Internet.

Servizi ruolo Server Digitalizzazione distribuita

Server Digitalizzazione distribuita è un servizio ruolo che installa lo snap-in Gestione digitalizzazione. È possibile utilizzare Gestione digitalizzazione per monitorare più scanner di rete, configurare server di digitalizzazione, elaborare documenti digitalizzati e quindi inviarli in tutta la rete.

Ulteriori riferimenti

Per ulteriori informazioni sul ruolo Servizi di stampa e digitalizzazione, vedere http://go.microsoft.com/fwlink/?LinkID=127821.


Panoramica di Gestione stampa

In computer che eseguono Windows® 7 e Windows Server® 2008 R2, è possibile condividere stampanti di una rete e centralizzare le attività di gestione del server di stampa e delle stampanti di rete tramite lo snap-in Gestione Stampa di Microsoft Management Console. È possibile monitorare le code di stampa e ricevere notifiche quando queste interrompono l'elaborazione dei processi di stampa. Servizi di stampa consente inoltre di eseguire la migrazione di server di stampa e distribuire connessioni con stampanti tramite Criteri di gruppo.

Strumenti per la gestione di un server di stampa

Per l'amministrazione di un server di stampa Windows sono disponibili due strumenti principali:

  • Server Manager

  • Print Management

In Windows Server 2008 R2 è possibile utilizzare Server Manager per installare il ruolo server e servizi ruolo Servizi di stampa e digitalizzazione. Server Manager include inoltre un'instanza dello snap-in Gestione stampa per amministrare il server locale.

In Gestione stampa vengono visualizzati dettagli aggiornati relativi allo stato delle stampanti e dei server di stampa nella rete. È possibile utilizzare Gestione stampa per installare connessioni con stampanti in un gruppo di computer client contemporaneamente e per monitorare le code di stampa da postazioni remote. Gestione stampa consente di individuare tramite appositi filtri le stampanti in cui si sono verificate condizioni di errore. È inoltre possibile inviare notifiche tramite posta elettronica oppure eseguire script quando è necessario intervenire su una stampante o un server di stampa. Nelle stampanti con un'interfaccia di gestione basata sul Web, con Gestione stampa è possibile visualizzare un numero maggiore di dati, ad esempio il livello del toner e della carta.

Nota

Per gestire un un server di stampa remoto è necessaria l'appartenenza al gruppo Print Operators o Server Operators, oppure al gruppo Administrators locale nel server di stampa remoto. Per il monitoraggio dei server di stampa remoti queste autorizzazioni non sono necessarie, tuttavia alcune funzionalità non saranno disponibili.

Servizi per server di stampa e stampanti di rete

Il ruolo Servizi di stampa e digitalizzazione in Windows Server 2008 R2 include i tre servizi ruolo seguenti, importanti per la gestione di server di stampa e stampanti di rete. È possibile aggiungere i servizi ruolo durante l'installazione del ruolo Servizi di stampa, oppure installarli in un momento successivo, sempre utilizzando l'Aggiunta guidata ruoli di Server Manager.

Nota

Poiché Windows 7 è un sistema operativo client, non include i servizi ruolo. Include invece lo snap-in Gestione di stampa. Windows 7 include inoltre Servizio di stampa LPD come funzionalità facoltativa di Windows. È possibile installare Servizio di stampa LPD utilizzando Programmi e funzionalità nel Pannello di controllo. Windows 7 non include la funzionalità Stampa Internet né il servizio ruolo Server Digitalizzazione distribuita.

Server di stampa

Server di stampa è un servizio ruolo che installa lo snap-in Gestione stampa. Gestione stampa viene utilizzato per gestire più stampanti o server di stampa e per eseguire la migrazione di stampanti da e verso altri server di stampa Windows. Quando si condivide una stampante, Windows abilita l'eccezione Condivisione file e stampanti di Windows Firewall con sicurezza avanzata.

Servizio LPD

Il Servizio LPD (Line Printer Daemon) installa e avvia il servizio di stampa TCP/IP (LPDSVC), che consente ai computer basati su UNIX o ad altri computer che utilizzano il servizio LPR (Line Printer Remote) di stampare sulle stampanti condivise presenti nel server. Crea inoltre un'eccezione in entrata per la porta 515 in Windows Firewall con sicurezza avanzata.

Il servizio non richiede alcuna configurazione. Se tuttavia si arresta o riavvia il servizio spooler di stampa, viene arrestato anche il servizio di stampa TCP/IP, che non viene riavviato automaticamente.

Per stampare su una stampante o un server di stampa che utilizza il protocollo LPD, è possibile utilizzare l'Installazione guidata stampante di rete e una porta stampante TCP/IP standard. Per stampare su un server di stampa UNIX è invece necessario installare la funzionalità Monitor porta LPR (Line Printer Remote). A tale scopo, utilizzare una una delle modalità seguenti:

  • Nel Pannello di controllo fare clic su Programmi e funzionalità, fare clic su Attivazione o disattivazione delle funzionalità Windows, espandere Servizi di stampa, selezionare la casella di controllo Monitor porta LPR e quindi fare clic su OK.

  • In Server Manager fare clic su Aggiungi funzionalità, selezionare la casella di controllo Monitor porta LPR e quindi fare clic su OK.

Stampa Internet

Il servizio ruolo Stampa Internet di Windows Server 2008 R2 crea un sito Web ospitato da Internet Information Services (IIS). Questo sito Web consente agli utenti di:

  • Gestire i processi di stampa nel server.

  • Utilizzare un browser per creare una connessione a una stampante condivisa nel server e stampare su di essa utilizzando il protocollo IPP (Internet Printing Protocol). È necessario che gli utenti abbiano installato Client di stampa Internet.

Per gestire un server utilizzando il sito Web creato da Stampa Internet, aprire un browser e accedere all'indirizzo http://servername/printers, dove servername è il percorso UNC del server di stampa.

Per installare Client di stampa Internet, utilizzare una una delle modalità seguenti:

  • In Windows 7: nel Pannello di controllo fare clic su Programmi e funzionalità, fare clic su Attivazione o disattivazione delle funzionalità Windows, espandere Servizi di stampa e digitalizzazione, selezionare la casella di controllo Client di stampa Internet e quindi fare clic su OK.

  • In Windows Server 2008 R2: In Server Manager fare clic su Aggiungi funzionalità, selezionare la casella di controllo Client di stampa Internet e quindi fare clic su OK.

Ulteriori riferimenti

  • Gestione stampa

  • Installare componenti di stampa


Elenco di controllo: distribuire server di stampa

Attività | Riferimento
Esaminare i concetti fondamentali secondo necessità. | Panoramica di Gestione stampa
Installare il ruolo Servizi di stampa e digitalizzazione e i servizi ruolo di stampa desiderati e aprire lo snap-in Gestione stampa. | Installare componenti di stampa
Aggiungere o rimuovere server di stampa tramite lo snap-in Gestione stampa. | Aggiungere o rimuovere server di stampa
Eseguire la migrazione di server di stampa se necessario. | Eseguire la migrazione di server di stampa
Aggiungere automaticamente stampanti di rete al server di stampa. | Aggiungere stampanti di rete automaticamente
Distribuire connessioni con stampanti a utenti o computer secondo necessità. | Distribuire stampanti tramite Criteri di gruppo
Elencare o rimuovere stampanti da Servizi di dominio Active Directory. | Elencare o rimuovere stampanti da Servizi di dominio Active Directory
Installare driver delle stampanti aggiornati nel server, inclusi driver a 32 o a 64 bit. | Aggiornare e gestire i driver delle stampanti
Controllare il modo in cui gli utenti non membri del gruppo Administrators locale possono installare i driver delle stampanti. | Controllare la sicurezza per l'installazione dei driver delle stampanti

Ulteriori riferimenti

Gestione stampa


Distribuire stampanti e server di stampa

Nelle sezioni seguenti sono disponibili informazioni sulla distribuzione di stampanti e server di stampa:

  • Installare componenti di stampa

  • Aggiungere o rimuovere server di stampa

  • Eseguire la migrazione di server di stampa

  • Aggiungere stampanti di rete automaticamente

  • Distribuire stampanti tramite Criteri di gruppo

  • Elencare o rimuovere stampanti da Servizi di dominio Active Directory

Ulteriori riferimenti

Gestione stampa


Installare componenti di stampa

Lo snap-in Gestione stampa viene installato per impostazione predefinita nei computer che eseguono Windows 7, ma non nei computer che eseguono Windows Server 2008 R2. Per installare lo snap-in Gestione stampa in un computer che esegue Windows Server 2008 R2, utilizzare una delle modalità seguenti:

  • Per installare lo snap-in Gestione stampa e configurare il server come server di stampa - Da Server Manager, utilizzare l'Aggiunta guidata ruoli per installare il ruolo Servizi di stampa e digitalizzazione e il servizio ruolo Server di stampa.

  • Per installare lo snap-in Gestione stampa senza configurare il server come server di stampa - Da Server Manager, utilizzare l'Aggiunta guidata funzionalità per installare l'opzione Strumenti per Servizi di stampa della funzionalità Strumenti di amministrazione remota del server.

Per aprire Gestione stampa in un computer che esegue Windows 7 o Windows Server 2008 R2, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

Nota

È possibile che Gestione stampa non visualizzi in modo preciso lo stato dei computer remoti quando sta monitorando più di 10 server di stampa in un computer che esegue Microsoft Windows Vista. Questo accade perché i computer che eseguono Microsoft Windows Vista supportano un massimo di 10 connessioni di rete simultanee. Per il monitoraggio remoto di un numero elevato di server di stampa, utilizzare Desktop remoto per accedere a un computer in cui è installato Gestione stampa e che esegue Windows Server 2008 R2.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Distribuire stampanti e server di stampa


Aggiungere o rimuovere server di stampa

Per impostazione predefinita, lo snap-in Gestione stampa consente di gestire il computer locale. È tuttavia possibile gestire o monitorare un numero illimitato di server di stampa che eseguono Windows 2000, Windows XP, Windows Server 2003, Microsoft Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2 aggiungendo i server di stampa a Gestione stampa.

Nota

È possibile che Gestione stampa non visualizzi in modo preciso lo stato dei computer remoti quando sta monitorando più di 10 server di stampa in un computer che esegue Microsoft Windows Vista. Questo accade perché i computer che eseguono Microsoft Windows Vista supportano un massimo di 10 connessioni di rete simultanee. Per il monitoraggio remoto di un numero elevato di server di stampa, utilizzare Desktop remoto per accedere a un computer in cui è installato Gestione stampa e che esegue Windows Server 2008 R2.

Per aggiungere server di stampa a Gestione stampa

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Gestione stampa e quindi scegliere Aggiungi/Rimuovi server.

  3. Nella casella di gruppo Server di stampa della finestra di dialogo Aggiungi/Rimuovi server, in Aggiungi server, eseguire una delle operazioni seguenti:

    • Digitare o incollare i nomi dei server di stampa, separando i nomi computer con virgole.

    • Fare clic su Sfoglia per individuare e selezionare il server di stampa.

  4. Fare clic su Aggiungi a elenco.

  5. Aggiungere tutti i server di stampa desiderati e quindi fare clic su OK.

    Nota

    È possibile aggiungere il server locale su cui si lavora facendo clic su Aggiungi server locale. Non è possibile aggiungere server remoti a Gestione stampa da Server Manager.
Per rimuovere server di stampa da Gestione stampa

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Gestione stampa e quindi scegliere Aggiungi/Rimuovi server.

  3. Nella finestra di dialogo Aggiungi/Rimuovi server, in Server di stampa, selezionare uno o più server e fare clic su Rimuovi.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Distribuire stampanti e server di stampa


Eseguire la migrazione di server di stampa

È possibile esportare code di stampa, impostazioni e porte di stampanti e monitor del linguaggio e quindi importarli in un altro server di stampa con sistema operativo Microsoft Windows. È così possibile consolidare più server di stampa o sostituire un server di stampa obsoleto con la massima efficienza.

Strumenti per la migrazione del server di stampa

Lo strumento utilizzato per eseguire la migrazione di server di stampa dipende dai fattori seguenti:

  • Sistema operativo di origine da cui si desidera eseguire la migrazione.

  • Sistema operativo di destinazione in cui si desidera eseguire la migrazione.

  • Coinvolgimento nella migrazione di driver e sistemi operativi a 64 bit.

Scenari di migrazione supportati

Nella tabella seguente vengono descritti gli scenari di migrazione supportati e non supportati per Migrazione stampanti e Print Migrator 3.1, se sono supportati sistemi e driver basati su x64 e come accedere a ogni strumento:

Strumento | Scenari di migrazione supportati | Scenari di migrazione non supportati | Supporto di sistemi e driver basati su x64? | Disponibilità
Migrazione stampanti, strumento da riga di comando Printbrm.exe | Windows Vista - Supporta tutte le migrazioni a Windows Vista. Windows Server 2008 R2 - Non è possibile eseguire la migrazione direttamente da sistemi operativi precedenti (Windows NT Server 4.0, Windows 2000 Server) a Windows Server 2008 R2. È invece necessario eseguire la migrazione dal sistema operativo precedente a un computer che esegue Windows Vista, quindi da Windows Vista a Windows Server 2008 R2. | Non supporta migrazioni da Windows 2000 Server e sistemi precedenti. | Sì. Migrazione stampanti è l'unico strumento di migrazione supportato da Microsoft utilizzabile con sistemi e driver a 64 bit. | Disponibile dallo snap-in Gestione stampa o dalla riga di comando mediante Printbrm.exe in computer che eseguono Windows 7 Enterprise, Windows 7 Ultimate e Windows Server 2008 R2.
Print Migrator 3.1 | Supporta la migrazione a Windows Server 2003 da tutti i sistemi operativi Windows precedenti. | Non supporta la migrazione da Windows Vista e sistemi operativi successivi. | No. I driver e i sistemi a 64 bit non sono supportati. | Disponibile online. Print Migrator 3.1 era inoltre incluso nei Resource Kit per Windows 2000 Server e Windows Server 2003.

Eseguire la migrazione a computer che eseguono Windows Server 2003

Se si esegue la migrazione da Windows NT Server 4 o Windows 2000 Server a Windows Server 2003, è necessario utilizzare Print Migrator 3.1. Print Migrator 3.1 non funziona con Windows Vista o sistemi operativi successivi e non è utilizzabile con i driver di sistema. Per eseguire la migrazione tra sistemi Windows Server 2003 x64, utilizzare Migrazione stampanti.

Nota

Print Migrator 3.1 non è più supportato da Microsoft. Migrazione stampanti e lo strumento da riga di comando Printbrm.exe sono stati introdotti in Windows 7 per sostituirlo.

Eseguire la migrazione a computer che eseguono Windows Server 2008 R2

Utilizzare Migrazione stampanti o lo strumenti da riga di comando Printbrm.exe per eseguire la migrazione a un computer che esegue Windows Server 2008 R2. Utilizzare lo strumento da riga di comando Printbrm.exe in computer che eseguono Windows Vista e Windows Server 2008. In Windows Server 2003, è possibile utilizzarlo solo per la gestione remota di server di stampa.

Nota
  • Non è possibile eseguire la migrazione direttamente da sistemi operativi precedenti (Windows NT Server 4.0, Windows 2000 Server) a Windows Server 2008 R2. È invece necessario eseguire la migrazione dal sistema operativo precedente a un computer che esegue Windows Vista, quindi da Windows Vista a Windows Server 2008 R2.

  • Per l'aggiornamento sul posto (reinstallazione) dei server di stampa, utilizzare Migrazione stampanti per eseguire il backup e ripristinare la configurazione del server di stampa. La migrazione standard del sistema non mantiene le informazioni del server di stampa e può comportare la perdita dei dati di configurazione di stampa se non ne è stato eseguito il backup corretto prima dell'installazione del nuovo sistema operativo.

Eseguire la migrazione di server di stampa

  • Tramite l'interfaccia Windows

  • Tramite un prompt dei comandi
Per eseguire la migrazione di server di stampa tramite Gestione stampa

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, fare clic sul pulsante destro del mouse sul server di stampa contenente le code di stampa che si desidera esportare e quindi scegliere Esporta stampanti in un file. Verrà avviata la procedura guidata Migrazione stampanti.

  3. Nella pagina Selezionare il percorso del file specificare il percorso in cui salvare le impostazioni delle stampanti e quindi fare clic su Avanti per salvare le stampanti.

  4. Fare clic con il pulsante destro del mouse sul computer di destinazione in cui si desidera importare le stampanti e quindi scegliere Importa stampanti da un file. Verrà avviata la procedura guidata Migrazione stampanti.

  5. Nella pagina Selezionare il percorso del file specificare il percorso del file delle impostazioni delle stampanti e quindi fare clic su Avanti.

  6. Nella pagina Selezionare le opzioni di importazione specificare le opzioni seguenti:

    • Modalità importazione. Specifica le operazioni da eseguire se nel computer di destinazione esiste già una determinata coda di stampa.

    • Pubblica nell'elenco online. Specifica se pubblicare le code di stampa importate in Servizi di dominio Active Directory.

    • Converti porte LPR in monitor di porta standard. Specifica se convertire le porte stampanti LPR (Line Printer Remote) del file delle impostazioni delle stampanti nel più rapido monitor di porta standard quando si importano le stampanti.

  7. Fare clic su Avanti per importare le stampanti.
Per eseguire la migrazione di server di stampa tramite un prompt dei comandi

  1. Per aprire una finestra del prompt dei comandi, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Digitare:

    CD %WINDIR%\System32\Spool\Tools Printbrm -s \\<sourcecomputername> -b -f <nomefile>.printerExport

  3. Digitare il comando seguente:

    Printbrm -s \\<destinationcomputername> -r -f <filename>.printerExport

Valore | Descrizione
<sourcecomputername> | Nome UNC (Universal Naming Convention) del computer di origine o di destinazione.
<destinationcomputername> | Nome UNC (Universal Naming Convention) del computer di destinazione.
<filename> | Nome del file delle impostazioni delle stampanti. Utilizzare le estensioni di file printerExport o cab.
Nota

Per visualizzare la sintassi completa del comando, al prompt dei comandi digitare: Printbrm /?

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

  • La procedura guidata Migrazione stampanti e lo strumento Printbrm.exe consentono di importare profili colori o moduli personalizzati solo nel computer locale e non supportano le impostazioni delle stampanti esportate utilizzando lo strumento Print Migrator.

  • È possibile utilizzare la funzionalità Utilità di pianificazione di Windows per pianificare lo strumento Printbrm.exe in modo da esportare o importare le stampanti a intervalli regolari. Tale funzionalità può essere utilizzata come integrazione dei backup di sistema.

Ulteriori riferimenti

  • Distribuire stampanti e server di stampa

  • Notazione di sintassi della riga di comando


Aggiungere stampanti di rete automaticamente

È possibile utilizzare Gestione stampa per rilevare automaticamente tutte le stampanti presenti nella stessa subnet del computer nel quale viene eseguito Gestione stampa, installare i driver della stampante appropriati, impostare le code e condividere le stampanti.

Per aggiungere una stampante per indirizzo IP o nome host, è necessario essere membri del gruppo Administrators locale o disporre dell'autorizzazione Gestione server.

Per aggiungere automaticamente stampanti di rete a un server di stampa

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato, fare clic con il pulsante destro del mouse su Stampanti e quindi scegliere Aggiungi stampante.

  3. Nella pagina Installazione stampante dell'Installazione guidata stampante di rete fare clic su Cerca stampanti in rete e quindi su Avanti. Se richiesto, specificare i driver da installare per la stampante.
Nota

Per aggiungere le stampanti presenti nella stessa subnet di un server di stampa remoto, utilizzare Desktop remoto per accedere al server di stampa, aprire Gestione stampa e quindi aggiungere la stampante.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Se si è membri del gruppo Administrators locale, è possibile concedere l'autorizzazione Gestisci Server ad altri utenti per poter aggiungere una stampante per indirizzo IP o nome host. A tale scopo, aprire Gestione stampa, fare doppio clic su Server di stampa, fare clic con il pulsante destro del mouse sul server di stampa desiderato e scegliere Proprietà. Nella finestra di dialogo Proprietà server di stampa, selezionare la scheda Sicurezza, selezionare l'utente dall'elenco, in Consenti fare clic sulla casella di controllo Gestisci server e quindi fare clic su OK.

  • Se lo snap-in Gestione stampa non è disponibile perché il servizio ruolo Server di stampa non è installato nel server, è necessario disporre dei privilegi amministrativi per poter aggiungere una stampante per indirizzo IP o nome host. Nell'Installazione guidata stampante, selezionare Aggiungi una stampante locale o di rete come amministratore e seguire le istruzioni nell'Installazione guidata stampante per aggiungere una stampante con privilegi amministrativi.

  • Per aggiungere stampanti WSD per la condivisione e visualizzarle nella rete, è necessario attivare l'individuazione delle reti ed eseguire il servizio Enumeratore bus IP PnP-X. Per aggiungere una stampante WSD, è necessario essere membri del gruppo Administrators.

    Per attivare l'individuazione delle reti, fare clic sul pulsante Start, scegliere Pannello di controllo e quindi fare clic su Rete e Internet. Nella pagina Rete e Internet fare clic su Centro connessioni di rete e condivisione. Nella pagina Centro connessioni di rete e condivisione fare clic su Modifica impostazioni di condivisione avanzate. Nella pagina Impostazioni di condivisione avanzate fare clic sulla freccia accanto a Dominio, fare clic su Attiva individuazione rete e quindi su Salva modifiche.

    Per avviare il servizio Enumeratore bus IP PnP-X, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Servizi. Nel pannello centrale fare clic con il pulsante destro del mouse su Enumeratore bus IP PnP-X e scegliere Avvia.

Ulteriori riferimenti

  • Distribuire stampanti e server di stampa


Distribuire stampanti tramite Criteri di gruppo

È possibile utilizzare Gestione stampa per distribuire automaticamente connessioni con stampanti a utenti o computer e installare i driver delle stampanti appropriati. Questa modalità di installazione delle stampanti si rivela utile in laboratori, aule o succursali in cui la maggior parte dei computer o degli utenti presenti devono accedere alle stesse stampanti. È inoltre utile per la distribuzione di driver delle stampanti a utenti non appartenenti al gruppo Administrators locale e che eseguono Windows 7.

Per distribuire connessioni con stampanti tramite Criteri di gruppo è necessario che l'ambiente soddisfi i requisiti seguenti:

  • Lo schema di Servizi di dominio Active Directory deve utilizzare una versione per Windows Server 2008 o Windows Server 2008 R2.

  • I computer client che non eseguono Windows 7 o Windows Server 2008 R2 devono utilizzare lo strumento PushPrinterConnections.exe in uno script di avvio, nel caso delle connessioni per computer, oppure in uno script di accesso, nel caso delle connessioni per utente.

Negli argomenti seguenti sono disponibili informazioni su come distribuire connessioni con stampanti tramite Criteri di gruppo:

  • Distribuire connessioni con stampanti

  • Distribuire l'utilità PushPrinterConnections.exe

  • Modificare la sicurezza per l'installazione di driver di stampanti distribuite utilizzando Criteri di gruppo

Importante

Per eseguire queste procedure è necessario appartenere al gruppo Administrators locale e disporre di accesso in scrittura agli oggetti Criteri di gruppo nel dominio di Servizi di dominio Active Directory o nell'unità organizzativa alla quale si desidera distribuire le connessioni con stampanti.

Ulteriori riferimenti

  • Distribuire stampanti e server di stampa

  • Raccolta di documentazione tecnica di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=92735


Distribuire connessioni con stampanti

Per distribuire connessioni con stampanti a utenti o computer tramite Criteri di gruppo, è necessario aggiungere le connessioni stampante a un oggetto Criteri di gruppo come descritto nella procedura.

Per distribuire connessioni con stampanti a utenti o computer utilizzando Criteri di gruppo

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Stampanti.

  3. Nel riquadro centrale fare clic con il pulsante destro del mouse sulla stampante desiderata e quindi scegliere Distribuisci con Criteri di gruppo.

  4. Nella finestra di dialogo Distribuisci con Criteri di gruppo fare clic su Sfoglia e quindi selezionare o creare un nuovo oggetto Criteri di gruppo per l'archiviazione delle connessioni con stampanti.

  5. Fare clic su OK.

  6. Specificare se si desidera distribuire le connessioni con stampanti a utenti o a computer:

    • Per la distribuzione a gruppi di computer, in modo che tutti gli utenti dei computer possano accedere alle stampanti, selezionare la casella di controllo Computer a cui viene applicato questo oggetto Criteri di gruppo (per computer).

    • Per la distribuzione a gruppi di utenti, in modo che gli utenti possano accedere alle stampanti da qualsiasi computer al quale accedono, selezionare la casella di controllo Utenti a cui viene applicato questo oggetto Criteri di gruppo (per utente).

    Nota

    I computer client che eseguono Windows 2000 non supportano le connessioni per computer.

  7. Fare clic su Aggiungi.

  8. Ripetere i passaggi da 3 a 6 per aggiungere le impostazioni di connessione alle stampanti a un altro oggetto Criteri di gruppo, se necessario.

  9. Fare clic su OK.

Nota

Nel caso delle connessioni per computer, le connessioni con stampanti vengono aggiunte quando l'utente esegue l'accesso, oppure quando il computer viene riavviato, se si sta utilizzando l'utilità PushPrinterConnections.exe. Nel caso delle connessioni per utente, le connessioni con stampanti vengono aggiunte durante l'aggiornamento dei criteri in background, oppure quando l'utente esegue l'accesso, se si sta utilizzando l'utilità PushPrinterConnections.exe. Se si rimuovono le impostazione di connessione con stampanti dall'oggetto Criteri di gruppo, le stampanti corrispondenti verranno rimosse dal computer client al successivo aggiornamento dei criteri in background o accesso dell'utente, oppure al successivo riavvio o accesso dell'utente se si sta utilizzando l'utilità PushPrinterConnections.exe.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

Ulteriori riferimenti

  • Distribuire stampanti tramite Criteri di gruppo

  • Distribuire l'utilità PushPrinterConnections.exe


Distribuire l'utilità PushPrinterConnections.exe

Per distribuire connessioni con stampanti tramite Criteri di gruppo in computer che eseguono versioni di Windows precedenti a Windows 7 è necessario aggiungere l'utilità PushPrinterConnections.exe a uno script di avvio del computer oppure a uno script di accesso utente. L'utilità PushPrinterConnections.exe legge le impostazioni di connessione stampante da Criteri di gruppo e aggiunge le connessioni stampante appropriate al computer o all'account utente, oppure aggiorna le connessioni esistenti.

Il file PushPrinterConnections.exe rileva automaticamente i computer che eseguono Windows 7 o Windows Server 2008 R2 ed esce. Tali computer dispongono di supporto integrato per le connessioni con stampanti distribuite utilizzando Criteri di gruppo, pertanto è possibile distribuire in modo sicuro questo file a tutti i computer client dell'organizzazione.

Nota

Nella procedura seguente si presuppone che sia in uso la versione di Console Gestione Criteri di gruppo fornita con Windows Server 2008 R2. Per installare Console Gestione Criteri di gruppo in Windows Server 2008 R2, utilizzare l'Aggiunta guidata funzionalità di Server Manager. Se si utilizza un'altra versione della Console, i passaggi potrebbero essere leggermente diversi.

Per aggiungere il file PushPrinterConnections.exe a script di avvio o di accesso utente

  1. Aprire la console Gestione Criteri di gruppo.

  2. Nell'albero della Console Gestione Criteri di gruppo passare al dominio o all'unità organizzativa in cui sono archiviati gli account computer o utente in cui si desidera distribuire il file PushPrinterConnections.exe.

  3. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo contenente le connessioni con stampanti che si desidera distribuire e quindi scegliere Modifica.

  4. Passare a una delle posizioni seguenti:

    • Se le connessioni con stampanti sono distribuite per computer, passare a Configurazione computer, Criteri, Impostazioni di Windows, Script (Avvio/Arresto).

    • Se le connessioni con stampanti sono distribuite per utente, passare a Configurazione utente, Criteri, Impostazioni di Windows, Script (Accesso/Fine sessione).

    Nota

    I computer client che eseguono Windows 2000 non supportano le connessioni per computer.

  5. Fare clic con il pulsante destro del mouse su Avvio o Accesso e quindi scegliere Proprietà.

  6. Nella finestra di dialogo Proprietà - accesso o Proprietà - avvio fare clic su Visualizza file. Verrà visualizzata la finestra di dialogo Avvio o Accesso.

  7. Copiare il file PushPrinterConnections.exe dalla cartella %WINDIR%\System32 alla finestra Avvio o Accesso. In questo modo l'utilità verrà aggiunta all'oggetto Criteri di gruppo, in cui verrà replicata agli altri controller di dominio con le impostazioni di Criteri di gruppo.

  8. Nella finestra di dialogo Proprietà - avvio o Proprietà - accesso fare clic su Aggiungi. Verrà visualizzata la finestra di dialogo Aggiunta script.

  9. Nella casella Nome script digitare: PushPrinterConnections.exe

  10. Per abilitare la registrazione nei computer client che eseguono Windows Server 2003, Windows XP o Windows 2000, nella casella Parametri script digitare: –log

    I file di registro vengono scritti in %WINDIR%\temp\ppcMachine.log (nel caso delle connessioni per computer) e in %temp%\ppcUser.log (nel caso delle connessioni per utente) nel computer in cui vengono applicati i criteri.

  11. Nella finestra di dialogo Aggiunta script fare clic su OK.

  12. Nella finestra di dialogo Proprietà - avvio o Proprietà - accesso fare clic su OK.

  13. Utilizzare la console Gestione Criteri di gruppo per collegare l'oggetto Criteri di gruppo ad altre unità organizzative o domini ai quali si desidera distribuire l'utilità PushPrinterConnections.exe.

Ulteriori considerazioni

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Distribuire stampanti tramite Criteri di gruppo


Modificare la sicurezza per l'installazione di driver di stampanti distribuite utilizzando Criteri di gruppo

Ad eccezione per Windows 7 e Windows Server 2008 R2, le impostazioni di sicurezza predefinite per i sistemi operativi Windows legacy consentono a un utente che non è membro del gruppo Administrators locale di installare solo driver delle stampanti attendibili, ad esempio quelli forniti con il sistema operativo Windows oppure contenuti in pacchetti driver della stampante con firma digitale.

Per consentire agli utenti non membri del gruppo Administrators locale di installare connessioni con stampanti distribuite utilizzando Criteri di gruppo e includere i driver delle stampanti senza firma digitale, è necessario configurare le impostazioni dei Criteri di gruppo per le Restrizioni di selezione e stampa. Se non si configurano queste impostazioni di Criteri di gruppo, gli utenti potrebbero dover fornire le credenziali del gruppo Administrators locale.

Nota

Nella procedura seguente si presuppone che sia in uso la versione di Console Gestione Criteri di gruppo fornita con Windows Server 2008 R2. Per installare Console Gestione Criteri di gruppo in Windows Server 2008 R2, utilizzare l'Aggiunta guidata funzionalità di Server Manager. Se si utilizza un'altra versione della Console, i passaggi potrebbero essere leggermente diversi.

Per modificare le impostazioni di sicurezza per l'installazione dei driver distribuiti utilizzando Criteri di gruppo

  1. Aprire la console Gestione Criteri di gruppo.

  2. Aprire la console Gestione Criteri di gruppo in cui sono distribuite le connessioni con stampanti e passare a Configurazione utente, Criteri, Modelli amministrativi, Pannello di controllo e quindi Stampanti.

  3. Fare clic con il pulsante destro del mouse su Restrizioni di selezione e stampa e quindi scegliere Proprietà.

  4. Fare clic su Attivata.

  5. Deselezionare le caselle di controllo seguenti:

    • Gli utenti possono selezionare e stampare soltanto su questi server

    • Gli utenti possono selezionare e stampare soltanto sui computer della foresta

  6. Nella casella Quando si installano i driver per una nuova connessione selezionare Non mostrare avvisi o richieste di elevazione dei privilegi.

  7. Scorrere verso il basso e nella casella Quando si aggiornano i driver per una connessione esistente selezionare Mostra solo avvisi.

  8. Fare clic su OK.

Dopo aver configurato queste impostazioni, tutti gli utenti saranno in grado di ricevere connessioni con stampanti e driver nei propri account utente utilizzando Criteri di gruppo senza che vengano visualizzate richieste o avvisi. Gli utenti riceveranno un avviso prima dell'installazione dei driver aggiornati provenienti dal server di stampa, ma per l'installazione non sarà necessaria l'appartenenza al gruppo Administrators locale.

Ulteriori riferimenti

  • Distribuire stampanti tramite Criteri di gruppo

  • Raccolta di documentazione tecnica di Windows Server 2008 con Criteri di gruppo all'indirizzo http://go.microsoft.com/fwlink/?LinkID=92735.


Elencare o rimuovere stampanti da Servizi di dominio Active Directory

Elencando le stampanti in Servizi di dominio Active Directory si consente agli utenti di individuarle e installarle più facilmente. Dopo aver installato le stampanti in un server di stampa, è possibile utilizzare Gestione stampa per elencarle in Servizi di dominio Active Directory.

È possibile elencare più stampanti contemporaneamente, nonché impostare un filtro per visualizzare tutte le stampanti da elencare o rimuovere, in modo da poter selezionare senza difficoltà tutte le stampanti contemporaneamente.

Per elencare o rimuovere stampanti in Servizi di dominio Active Directory

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Stampanti.

  3. Nel riquadro centrale fare clic con il pulsante destro del mouse sulla stampante che si desidera elencare o rimuovere e quindi scegliere Elenca in Active Directory o Rimuovi da Active Directory.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Distribuire stampanti e server di stampa


Gestire stampanti e server di stampa

Negli argomenti seguenti sono disponibili informazioni sulla gestione di stampanti e server di stampa mediante Gestione stampa:

  • Aggiornare e gestire i driver delle stampanti

  • Controllare la sicurezza per l'installazione dei driver delle stampanti

  • Creare un nuovo filtro stampanti

  • Creare un nuovo filtro driver

  • Visualizzare funzionalità estese per la stampante

  • Aggiungere e gestire porte

  • Gestire moduli

  • Impostare le autorizzazioni per i server di stampa

È possibile eseguire operazioni di massa su tutte le stampanti in un determinato server o su tutte le stampanti restituite da un filtro. Le azioni seguenti possono essere eseguite contemporaneamente su più stampanti:

  • Interruzione o ripresa della stampa

  • Annullamento di tutti i processi

  • Elencare o rimuovere stampanti da Servizi di dominio Active Directory.

  • Eliminazione di stampanti

È inoltre possibile esportare un elenco di stampanti, moduli, porte o stampanti facendo clic su Altre azioni nel riquadro Azioni e quindi facendo clic su Esporta elenco.

Ulteriori riferimenti

Gestione stampa


Aggiornare e gestire i driver delle stampanti

Nelle sezioni seguenti sono disponibili informazioni su come utilizzare lo snap-in Gestione stampa per gestire i driver delle stampanti in un server di stampa:

  • Aggiungere driver per computer client che eseguono versioni di Windows a 32 bit o a 64 bit.

  • Aggiornare o modificare driver delle stampanti

  • Rimuovere driver delle stampanti

Aggiungere driver per computer client che eseguono versioni di Windows a 32 bit o a 64 bit.

Per il supporto di computer client che utilizzano architetture del processore diverse rispetto al server di stampa è necessaria l'installazione di driver aggiuntivi. Se ad esempio il server di stampa esegue una versione di Windows a 64 bit e si desidera implementare il supporto dei computer client che eseguono versioni di Windows a 32 bit, è necessario aggiungere driver basati su x86 per ogni stampante.

Nota

È possibile aggiungere driver di stampanti fino a 2GB di dimensioni. Non sarà possibile eseguire il backup di driver di stampanti di dimensioni superiori a 2GB.

Per aggiungere driver delle stampanti client al server di stampa

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Stampanti.

  3. Nel pannello centrale fare clic con il pulsante destro del mouse sulla stampante alla quale si desidera aggiungere driver della stampante aggiuntivi e quindi scegliere Gestisci condivisione.

  4. Fare clic su Driver aggiuntivi. Verrà visualizzata la finestra di dialogo Driver aggiuntivi.

  5. Selezionare la casella di controllo relativa all'architettura del processore per cui si desidera aggiungere i driver.

    Se ad esempio il server di stampa esegue una versione di Windows basata su x64, selezionare la casella di controllo x86 per installare la versione a 32 bit dei driver della stampante per i computer client che eseguono versioni a 32 bit di Windows.

  6. Se nell'archivio driver del server di stampa non sono già presenti i driver della stampante appropriati, verrà richiesto di specificare la posizione dei file del driver. Scaricare ed estrarre i file del driver appropriati e quindi specificare il percorso del file con estensione inf del driver nella finestra di dialogo visualizzata.

    Nota

    Potrebbe non essere possibile estrarre alcuni driver delle stampanti senza installarli. In questo caso, accedere a un computer client che utilizza la stessa architettura del processore utilizzata dai driver della stampante che si desidera aggiungere al server di stampa e quindi installare i driver. Utilizzare quindi Gestione stampa dal computer client per eseguire la connessione al server di stampa e aggiungere i driver nella finestra di dialogo Driver aggiuntivi. I driver verranno caricati automaticamente dal computer client al server di stampa.

Aggiornare o modificare driver delle stampanti

Per aggiornare o modificare i driver per una stampante, eseguire la procedura seguente. I computer client scaricheranno e installeranno automaticamente i driver della stampante aggiornati al successivo tentativo di stampa sulla stampante.

Nota

Durante l'installazione di driver della stampante forniti dal produttore del dispositivo, attenersi alle istruzioni fornite con il driver invece di utilizzare questa procedura.

Per aggiornare o modificare i driver per una stampante

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Stampanti.

  3. Nel riquadro centrale fare clic con il pulsante destro del mouse sulla stampante di cui si desidera aggiornare o modificare il driver e quindi scegliere Proprietà.

  4. Fare clic sulla scheda Avanzate.

  5. Selezionare un nuovo driver nella casella Driver, oppure fare clic su Nuovo driver per installare un nuovo driver della stampante.

Rimuovere driver delle stampanti

Quando si installa un driver della stampante in un computer che esegue Windows 7 o Windows Server 2008 R2, il driver della stampante viene innanzitutto installato nell'archivio driver locale e quindi viene installato da tale archivio.

Quando si rimuovono driver delle stampanti, è possibile scegliere di eliminare solo il driver della stampante oppure di rimuovere l'intero pacchetto driver della stampante. Se si elimina il driver della stampante, il driver viene disinstallato, ma il pacchetto driver della stampante resta nell'archivio driver per consentirne la reinstallazione in qualsiasi momento. Se si rimuove il pacchetto driver della stampante, il pacchetto viene rimosso dall'archivio driver, pertanto il driver della stampante viene completamente rimosso dal computer.

Per rimuovere driver delle stampanti da un server, eseguire la procedura seguente:

Per rimuovere driver delle stampanti

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Stampanti.

  3. Nel riquadro centrale fare clic con il pulsante destro del mouse sulle stampanti che utilizzano il driver da eliminare, oppure modificare il driver utilizzato da tali stampanti impostando un driver diverso.

  4. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Driver.

  5. Nel riquadro centrale fare clic con il pulsante destro del mouse sul driver e quindi eseguire una delle operazioni seguenti:

    • Per eliminare solo i file dei driver installati, fare clic su Elimina.

    • Per rimuovere il pacchetto driver dall'archivio driver, rimuovendo così completamente il driver dal computer, fare clic su Rimuovi pacchetto driver.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa

  • Pagina relativa all'architettura di stampa e al supporto dei driver all'indirizzo http://go.microsoft.com/fwlink/?LinkID=92657


Controllare la sicurezza per l'installazione dei driver delle stampanti

Le impostazioni di sicurezza predefinite per Windows 7 e Windows Server 2008 R2 consentono agli utenti che non appartengono al gruppo Administrators locale di installare solo driver delle stampanti attendibili, ad esempio quelli forniti con il sistema operativo Windows oppure contenuti in pacchetti driver della stampante con firma digitale. In questo modo è possibile garantire che gli utenti non installino driver non testati o non affidabili, oppure driver modificati con l'inserimento di codice dannoso (malware). A volte tuttavia provocano l'impossibilità da parte degli utenti di installare il driver appropriato per una stampante condivisa, anche se il driver è stato testato e approvato per l'utilizzo nell'ambiente in uso.

Nelle sezioni seguenti sono disponibili informazioni su come consentire agli utenti non appartenenti al gruppo Administrators locale di connettersi a un server di stampa e installare i driver delle stampanti ospitati dal server:

  • Installare pacchetti driver della stampante nel server di stampa

  • Utilizzare Criteri di gruppo per distribuire connessioni con stampanti a utenti o computer

  • Utilizzare Criteri di gruppo per modificare le impostazioni di sicurezza per i driver delle stampanti

Installare pacchetti driver della stampante nel server di stampa

I pacchetti driver della stampante sono driver con firma digitale che installano tutti i componenti del driver nell'archivio driver dei computer client, se il server e i computer client eseguono Windows 7 oWindows Server 2008 R2. L'utilizzo di pacchetti driver della stampante in un server di stampa che esegue Windows 7 o Windows Server 2008 R2 consente inoltre agli utenti non appartenenti al gruppo Administrators locale di connettersi al server di stampa e installare o ricevere driver delle stampanti aggiornati.

Per utilizzare pacchetti driver della stampante in un server di stampa che esegue Windows Server 2008 R2 o Windows 7, scaricare e installare i pacchetti driver della stampante appropriati dal sito Web del fornitore della stampante.

Nota

È inoltre possibile scaricare e installare i pacchetti driver della stampante da un server di stampa ai computer client che eseguono Windows Server 2003, Windows XP e Windows 2000. I computer client tuttavia, non controllano la firma digitale dei driver, né installano tutti i componenti del driver nell'archivio driver, poiché il sistema operativo client non supporta tali funzionalità.

Utilizzare Criteri di gruppo per distribuire connessioni con stampanti a utenti o computer

È possibile utilizzare Gestione stampa in combinazione con Criteri di gruppo per aggiungere automaticamente connessioni con stampanti alla cartella Stampanti senza che l'utente debba disporre di privilegi di amministratore locale. Per ulteriori informazioni, vedere Distribuire stampanti tramite Criteri di gruppo.

Utilizzare Criteri di gruppo per modificare le impostazioni di sicurezza per i driver delle stampanti

È possibile utilizzare l'impostazione di Criteri di gruppo Restrizioni di selezione e stampa per controllare il modo in cui gli utenti possono installare i driver delle stampanti dai server di stampa. Questa impostazione consente di permettere agli utenti di connettersi solo a server di stampa specifici considerati attendibili. Poiché tale impostazione impedisce agli utenti di connettersi ad altri server di stampa che potrebbero potenzialmente ospitare driver della stampante dannosi o non testati, è possibile disattivare i messaggi di avviso relativi all'installazione dei driver della stampante senza per questo compromettere la sicurezza.

È consigliabile valutare attentamente le esigenze di stampa degli utenti prima di limitare i server di stampa ai quali sono autorizzati a connettersi. Se gli utenti hanno occasionalmente l'esigenza di connettersi a stampanti condivise in una succursale o in un altro reparto, verificare che tali server di stampa siano inclusi nell'elenco, sempre se si considerano attendibili i driver delle stampanti installati in tali server.

È inoltre possibile utilizzare l'impostazione Restrizioni di selezione e stampa per disabilitare completamente i messaggi di avviso, sebbene in questo modo venga disabilitata la sicurezza avanzata per l'installazione dei driver delle stampanti di Windows 7 e Windows Server 2008 R2 per tali utenti.

Nota

Nella procedura seguente si presuppone che sia in uso la versione di Console Gestione Criteri di gruppo fornita con Windows Server 2008 R2. Per installare Console Gestione Criteri di gruppo in Windows Server 2008 R2, utilizzare l'Aggiunta guidata funzionalità di Server Manager. Se si utilizza un'altra versione della Console, i passaggi potrebbero essere leggermente diversi.

Per modificare l'impostazione Restrizioni di selezione e stampa

  1. Aprire la Console Gestione Criteri di gruppo.

  2. Nell'albero della Console Gestione Criteri di gruppo passare al dominio o all'unità organizzativa in cui sono archiviati gli account utente per cui si desidera modificare le impostazioni di sicurezza per i driver delle stampanti.

  3. Fare clic con il pulsante destro del mouse sul dominio o sull'unità organizzativa appropriata, scegliere Crea un oggetto Criteri di gruppo in questo dominio e crea qui un collegamento, digitare un nome per il nuovo oggetto Criteri di gruppo e quindi fare clic su OK.

  4. Fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo creato e quindi scegliere Modifica.

  5. Nell'albero di Editor Gestione Criteri di gruppo fare clic su Configurazione utente, Criteri, Modelli amministrativi, Pannello di controllo e quindi su Stampanti.

  6. Fare clic con il pulsante destro del mouse su Restrizioni di selezione e stampa e quindi scegliere Proprietà.

Per consentire agli utenti di connettersi solo a server di stampa specifici considerati attendibili:

  1. Nella finestra di dialogo Restrizioni di selezione e stampa fare clic su Abilitato.

  2. Selezionare la casella di controllo Gli utenti possono selezionare e stampare soltanto su questi server, se non è già selezionata.

  3. Nella casella di testo digitare i nomi completi dei server ai quali si desidera consentire la connessione da parte degli utenti. Separare i nomi con un punto e virgola.

  4. Nella casella Quando si installano i driver per una nuova connessione selezionare Non mostrare avvisi o richieste di elevazione dei privilegi.

  5. Nella casella Quando si aggiornano i driver per una connessione esistente selezionare Mostra solo avvisi.

  6. Fare clic su OK.

    Nota

    Per disabilitare la visualizzazione di messaggi di avviso e richieste di elevazione dei privilegi nei computer che eseguono Windows 7 e Windows Server 2008 R2, nella finestra di dialogo Restrizioni di selezione e stampa fare clic su Disabilitato e quindi fare clic su OK. In questo modo la sicurezza avanzata per l'installazione dei driver delle stampanti di Windows 7 e Windows Server 2008 R2 verrà disabilitata.

Ulteriori considerazioni

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa

  • Pagina relativa all'architettura di stampa e al supporto dei driver all'indirizzo http://go.microsoft.com/fwlink/?LinkID=92657


Creare un nuovo filtro stampanti

I filtri stampanti vengono utilizzati per visualizzare solo le stampanti che soddisfano un determinato insieme di criteri. Può essere utile ad esempio filtrare le stampanti in modo da visualizzare solo quelle con particolari condizioni di errore o quelle installate in un gruppo di edifici indipendentemente dal server di stampa utilizzato.

Con Gestione stampa vengono forniti due filtri predefiniti. Per ogni filtro creato, è possibile impostare l'invio di una notifica per posta elettronica o l'esecuzione di uno a script quando le condizioni del filtro vengono soddisfatte.

Nota

Per poter eseguire questa attività, è necessario che sia installato il ruolo server di stampa ed essere membri del gruppo Administrators.

Per impostare e salvare una visualizzazione filtrata

  1. Aprire Gestione stampa.

  2. Fare clic con il pulsante destro del mouse sulla cartella Filtri personalizzati e quindi scegliere Aggiungi nuovo filtro stampanti. Verrà avviata la Creazione guidata nuovo filtro stampanti.

  3. Nella pagina Nome e descrizione filtro stampanti della procedura guidata digitare un nome per il filtro stampanti. Tale nome verrà visualizzato nella cartella Filtri stampanti personalizzati nell'albero di Gestione stampa.

  4. In Descrizione digitare una descrizione facoltativa.

  5. Per visualizzare il numero di stampanti che soddisfano le condizioni di un filtro, selezionare la casella di controllo Mostra il numero totale di stampanti accanto al nome del filtro stampanti.

  6. Fare clic su Avanti.

  7. Nella pagina Definizione di un filtro stampanti della procedura guidata eseguire le operazioni seguenti:

    1. Nell'elenco Campo fare clic sulla caratteristica della coda di stampa o dello stato della stampante.

    2. Nell'elenco Condizione fare clic sulla condizione.

    3. Nella casella Valore digitare un valore.

    4. Continuare ad aggiungere criteri fino a completare il filtro come desiderato e quindi fare clic su Avanti.

  8. Nella pagina Impostazione notifiche (facoltativo) della procedura guidata eseguire una o entrambe le operazioni seguenti:

    • Per impostare una notifica per posta elettronica, selezionare la casella di controllo Invia notifica per posta elettronica e digitare uno o più indirizzi di posta elettronica di destinatari e mittenti. È inoltre necessario specificare un server SMTP per il routing del messaggio. Utilizzare il formato account@domain e il punto e virgola per separare più account.

    • Per impostare uno script da eseguire, selezionare la casella di controllo Esegui script e quindi digitare il percorso in cui si trova il file script. Per aggiungere ulteriori argomenti, digitarli in Argomenti aggiuntivi.

  9. Fare clic su Fine.

    Nota

    Per impostare le notifiche per filtri stampanti esistenti, fare clic con il pulsante destro del mouse su una visualizzazione filtrata e quindi scegliere Imposta notifiche.

Impostare notifiche facoltative

Quando si crea o si modifica un filtro, è possibile scegliere di inviare una notifica automatica per posta elettronica a un determinato destinatario o di eseguire uno script quando le condizioni del filtro vengono soddisfatte. Ciò è utile per risolvere gli eventuali problemi relativi alle stampanti, in modo particolare in un'organizzazione con più edifici e numerosi amministratori.

È possibile ad esempio impostare una visualizzazione di tutte le stampanti gestite da un server di stampa specifico il cui stato sia diverso da Pronta. Se quindi una stampante passa da Pronta a un altro stato, l'amministratore può ricevere una notifica per posta elettronica da Gestione stampa.

Oltre a impostare le notifiche per un insieme personalizzato di stampanti, è possibile impostarle per gli oggetti server di stampa. È possibile ad esempio configurare l'invio di una notifica per posta elettronica quando il server è offline o lo spooler si disattiva.

Le notifiche tramite script sono utili per individuare e risolvere i problemi relativi alle stampanti. È possibile ad esempio decidere di eseguire automaticamente uno script per riavviare uno spooler quando le stampanti passano alla modalità offline. È inoltre possibile eseguire automaticamente uno script per la stampa di una pagina di prova.

Gli script possono essere scritti in Visual Basic Script (vbs) o in qualsiasi altro linguaggio di script disponibile nel computer. Lo script deve trovarsi nello stesso computer di Gestione stampa. Deve inoltre essere eseguito con le proprie credenziali ed è necessario disporre delle autorizzazioni per l'esecuzione delle operazioni previste dallo script.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa


Creare un nuovo filtro driver

È possibile utilizzare lo snap-in Gestione stampa per creare filtri personalizzati dei driver della stampante. I filtri consentono di visualizzare solo i driver della stampante che soddisfano un determinato insieme di criteri.

Nota

Per poter eseguire queste procedure, è necessario che sia installato il servizio ruolo server di stampa ed essere membri del gruppo Administrators.

Per creare un nuovo filtro driver

  1. Aprire Gestione stampa.

  2. Fare clic con il pulsante destro del mouse sulla cartella Filtri personalizzati e quindi scegliere Aggiungi nuovo filtro driver. Verrà avviata la Creazione guidata nuovo filtro driver.

  3. Nella pagina Nome e descrizione filtro della procedura guidata digitare un nome per il filtro del driver. Tale nome verrà visualizzato nella cartella Filtri driver personalizzati nell'albero di Gestione stampa.

  4. In Descrizione digitare una descrizione facoltativa.

  5. Per visualizzare il numero di driver della stampante che soddisfano le condizioni di un filtro, selezionare la casella di controllo Mostra il numero totale di elementi accanto al nome del filtro.

  6. Fare clic su Avanti.

  7. Nella pagina Definizione filtro della procedura guidata eseguire le operazioni seguenti:

    1. Nell'elenco Campo fare clic sulla caratteristica del driver.

    2. Nell'elenco Condizione fare clic sulla condizione.

    3. Nella casella Valore digitare un valore.

    4. Continuare ad aggiungere criteri fino a completare il filtro come desiderato e quindi fare clic su Avanti.

  8. Nella pagina Impostazione notifiche (facoltativo) della procedura guidata eseguire una o entrambe le operazioni seguenti:

    • Per impostare una notifica per posta elettronica, selezionare la casella di controllo Invia notifica per posta elettronica e digitare uno o più indirizzi di posta elettronica di destinatari e mittenti. È inoltre necessario specificare un server SMTP per il routing del messaggio. Utilizzare il formato account@domain e il punto e virgola per separare più account.

    • Per impostare uno script da eseguire, selezionare la casella di controllo Esegui script e quindi digitare il percorso in cui si trova il file script. Per aggiungere ulteriori argomenti, digitarli in Argomenti aggiuntivi.

  9. Fare clic su Fine.

    Nota

    Per impostare le notifiche per filtri driver esistenti, fare clic con il pulsante destro del mouse su una visualizzazione filtrata e quindi scegliere Imposta notifiche.

Impostare notifiche facoltative

Quando si crea o si modifica un filtro, è possibile scegliere di inviare una notifica automatica per posta elettronica a un determinato destinatario o di eseguire uno script quando le condizioni del filtro vengono soddisfatte. Ciò è utile per risolvere gli eventuali problemi relativi ai driver.

Le notifiche tramite script sono utili per individuare e risolvere i problemi relativi ai driver.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa


Visualizzare funzionalità estese per la stampante

È possibile utilizzare lo snap-in Gestione stampa per visualizzare funzionalità estese per la stampante. Consente di ottenere ulteriori informazioni sullo stato di un processo di stampa, il relativo proprietario, il numero di pagine, le dimensioni, la data e l'ora di invio, la porta, la priorità e altre proprietà avanzate del processo. Nello snap-in Gestione stampa la visualizzazione estesa è visibile al di sotto delle colonne del riquadro destro.

Per visualizzare funzionalità estese per la stampante

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato, fare clic con il pulsante destro del mouse su Stampanti e quindi scegliere Mostra visualizzazione estesa.

    Nota

    Per visualizzare o nascondere le colonne nella visualizzazione estesa, selezionare una stampante. Nella scheda Processi fare clic con il pulsante destro del mouse sulla riga dell'intestazione della colonna e scegliere il nome della colonna che si desidera visualizzare o nascondere.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • In un dominio con IPsec attivato, le stampanti WSD devono supportare ed essere configurate per IPsec affinché gli eventi della stampante siano registrati. IPsec non consente alle stampanti WSD non compatibili IPsec di inviare dati a un server di stampa incluso in un dominio con IPsec attivato.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa


Aggiungere e gestire porte

È possibile utilizzare Gestione stampa per aggiungere, eliminare e configurare porte stampanti per un server di stampa.

Per aggiungere e gestire le porte

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Porte.

  3. Per aggiungere una nuova porta, fare clic su Aggiungi porta. Nella finestra di dialogo Porte stampanti, selezionare un tipo di porta disponibile, fare clic su Nuova porta, digitare un nome per la porta e quindi fare clic su OK.

  4. Per aggiungere un nuovo tipo di porta, fare clic su Aggiungi porta. Nella finestra di dialogo Porte stampanti, digitare il percorso della cartella in cui si trova il file INF dei driver della stampante e quindi fare clic su OK.

  5. Per gestire una porta esistente, fare clic su Gestisci porte. Nella finestra di dialogo Proprietà server di stampa selezionare la porta ed eseguire le operazioni seguenti:

    1. Per eliminare una porta, selezionare la porta, fare clic su Elimina porta e quindi su OK.

    2. Per configurare una porta, fare clic su Configura porta, immettere un valore in secondi per l'intervallo tra tentativi di trasmissione e quindi fare clic su OK.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa


Gestire moduli

È possibile utilizzare Gestione stampa per gestire moduli della stampante.

Per gestire i moduli

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato, fare clic con il pulsante destro del mouse su Moduli e quindi scegliere Gestisci moduli.

  3. Nella finestra di dialogo Proprietà server di stampa eseguire le operazioni seguenti:

    1. Per creare un nuovo modulo, selezionare un modulo esistente, selezionare la casella di controllo Crea un nuovo modulo, modificare le unità di misura, il formato della carta e i margini dell'area di stampa in base alle esigenze, fare clic su Salva modulo e quindi su OK.

    2. Per eliminare un modulo, selezionare il modulo, fare clic su Elimina e quindi su OK.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per eseguire questa attività è necessario disporre di credenziali amministrative.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa


Impostare le autorizzazioni per i server di stampa

Per proteggere un server di stampa, è necessario valutare i diritti di cui disporranno gli utenti e i gruppi. È possibile proteggere un server di stampa assegnando specifici diritti a utenti o gruppi di utenti. Per ogni utente o gruppo di utenti, è possibile concedere o negare l'autorizzazione a:

  • Stampare documenti

  • Gestire stampanti

  • Gestire documenti

  • Visualizzare i dettagli relativi a un server di stampa

  • Gestire il server di stampa

  • Utilizzare autorizzazioni speciali o impostazioni avanzate

Impostare le autorizzazioni per i server di stampa

  1. Aprire Gestione stampa.

  2. Nel riquadro sinistro fare clic su Server di stampa, scegliere il server di stampa desiderato e quindi fare clic su Proprietà.

  3. Nella scheda Sicurezza, in Utenti e gruppi, fare clic su un utente o su un gruppo per il quale si desidera impostare le autorizzazioni.

  4. In Autorizzazioni per <user or group name>, selezionare la casella di controllo Consenti o Nega relativa alle autorizzazioni elencate in base alle esigenze.

  5. Per modificare Autorizzazioni speciali, fare clic su Avanzate.

  6. Nella scheda Autorizzazioni fare clic su un gruppo di utenti e quindi su Modifica.

  7. Nella finestra di dialogo Voce autorizzazione selezionare la casella di controllo Consenti o Nega relativa alle autorizzazioni che si desidera modificare.

Ulteriori considerazioni

  • Per aprire Gestione stampa, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione stampa.

  • Per modificare le autorizzazioni per utenti e gruppi è necessario disporre di autorizzazioni amministrative.

Ulteriori riferimenti

  • Gestire stampanti e server di stampa


Risorse su Gestione stampa

Per ulteriori informazioni su Gestione stampa, vedere le risorse seguenti nel sito Web Microsoft:

  • Per informazioni su Servizi di stampa e digitalizzazione nel TechCenter di Windows Server 2008, vedere http://go.microsoft.com/fwlink/?LinkId=92654.

  • Per informazioni sulla risoluzione di problemi di Server di stampa, vedere http://go.microsoft.com/fwlink/?LinkId=92656.

  • Per informazioni sull'architettura di stampa e il supporto di driver, vedere http://go.microsoft.com/fwlink/?LinkId=92657.

  • Per informazioni sul forum TechNet relativo alla stampa e ai fax in Windows Server 2008, vedere http://go.microsoft.com/fwlink/?LinkId=92658.

  • Per informazioni sul forum TechNet relativo alla stampa in Microsoft Windows Vista, vedere http://go.microsoft.com/fwlink/?LinkId=92659.

Ulteriori riferimenti

Gestione stampa


Interfaccia utente: Gestione stampa

Negli argomenti riportati di seguito vengono descritti gli elementi dell'interfaccia utente di Gestione stampa:

  • Finestra di dialogo Aggiungi/Rimuovi server

  • Finestra di dialogo Proprietà filtro

  • Finestra di dialogo Distribuisci con Criteri di gruppo

  • Finestra di dialogo Imposta notifiche

Ulteriori riferimenti

Gestione stampa


Finestra di dialogo Aggiungi/Rimuovi server

Nella tabella riportata di seguito vengono descritti gli elementi dell'interfaccia utente della finestra di dialogo Aggiungi/Rimuovi server.

Elemento | Descrizione
Aggiungi server | Aggiunge il nome del server di stampa che deve essere gestito da Gestione stampa.
Aggiungi a elenco | Aggiunge il server di stampa all'elenco nella parte inferiore della pagina e cancella il contenuto della casella Aggiungi server.
Aggiungi server locale | Aggiunge il computer a cui si è connessi all'elenco dei server di stampa gestiti.
Rimuovi | Elimina la selezione.
Rimuovi tutto | Cancella il contenuto dell'intero elenco.

Ulteriori riferimenti

  • Interfaccia utente: Gestione stampa


Finestra di dialogo Proprietà filtro

Nella tabella riportata di seguito vengono descritti gli elementi dell'interfaccia utente della finestra di dialogo Proprietà filtro.

Scheda | Elemento | Descrizione
Generale | Nome | Casella in cui digitare un nome per il filtro stampanti.
Generale | Descrizione | Casella in cui digitare una descrizione del filtro stampanti che consenta di differenziarlo dagli altri.
Criteri filtro | Campo | Elenca la caratteristica della coda di stampa o dello stato della stampante disponibile.
Criteri filtro | Condizione | Elenca le condizioni disponibili.
Criteri filtro | Valore | Elenca i valori disponibili.
Criteri filtro | Cancella tutto | Cancella il contenuto di tutti i campi dei criteri.

Ulteriori riferimenti

  • Interfaccia utente: Gestione stampa


Finestra di dialogo Distribuisci con Criteri di gruppo

Nella tabella riportata di seguito vengono descritti gli elementi dell'interfaccia utente della finestra di dialogo Distribuisci con Criteri di gruppo.

Elemento | Descrizione
Utenti a cui viene applicato questo oggetto Criteri di gruppo (per utente) | Specifica se assegnare l'impostazione della connessione stampante all'oggetto Criteri di gruppo per utente.
Computer a cui viene applicato questo oggetto Criteri di gruppo (per computer) | Specifica se assegnare l'impostazione della connessione stampante all'oggetto Criteri di gruppo per computer.
Sfoglia | Specifica l'oggetto Criteri di gruppo che distribuisce la connessione stampante.
Aggiungi | Aggiunge l'impostazione della connessione stampante.
Rimuovi | Elimina la selezione.
Rimuovi tutto | Cancella il contenuto dell'intero elenco.

Ulteriori riferimenti

  • Interfaccia utente: Gestione stampa


Finestra di dialogo Imposta notifiche

Nella tabella riportata di seguito vengono descritti gli elementi dell'interfaccia utente della finestra di dialogo Imposta notifiche.

Elemento | Descrizione
Invia notifica per posta elettronica | Attiva o disattiva l'invio di una notifica automatica per posta elettronica a un destinatario quando vengono soddisfatte le condizioni di un filtro.
Posta elettronica destinatari | Casella in cui digitare l'indirizzo di posta elettronica del destinatario.
Posta elettronica mittente | Casella in cui digitare l'indirizzo di posta elettronica del mittente.
Server SMTP | Casella in cui digitare il nome host del server SMTP che inoltrerà le notifiche per posta elettronica.
Messaggio | Casella in cui digitare un messaggio di testo che descriva le condizioni del problema relativo alla stampante.
Esegui script | Attiva o disattiva l'esecuzione di uno script quando vengono soddisfatte le condizioni di un filtro.
Percorso | Casella in cui digitare il percorso del file script.
Argomenti aggiuntivi | Casella in cui aggiungere ulteriori argomenti.
Test | Prova le impostazioni di notifica per posta elettronica o script.

Ulteriori riferimenti

  • Interfaccia utente: Gestione stampa


Notazione di sintassi della riga di comando

Nella tabella seguente viene descritta la notazione utilizzata per indicare la sintassi della riga di comando.

Notazione | Descrizione
Testo senza parentesi quadre o graffe | Elementi da digitare come indicato
<Testo tra parentesi acute> | Segnaposto per il quale è necessario fornire un valore
[Testo tra parentesi quadre] | Elementi facoltativi
{Testo tra parentesi graffe} | Serie di elementi richiesti: effettuare una selezione
Barra verticale (|) | Separatore per elementi che si escludono a vicenda: effettuare una selezione
Puntini di sospensione (...) | Elementi che possono essere ripetuti