Panoramica di QoS basata su criteri

La funzionalità QoS (Quality of Service) per le reti è costituita da un insieme di standard e meccanismi di settore in grado di garantire prestazioni di qualità elevata per applicazioni critiche. Gli amministratori di rete possono utilizzare i meccanismi QoS per classificare in ordine di priorità il traffico di rete in uscita e gestirne la velocità di invio. L'applicazione di questi meccanismi garantisce un utilizzo efficiente delle risorse in modo da offrire il livello di servizio richiesto.

In Windows Server® 2008 R2 e Windows 7® la funzionalità QoS basata su criteri combina la funzionalità degli standard QoS con la gestibilità di Criteri di gruppo per una più facile applicazione dei criteri QoS ai computer e alle sessioni di accesso utente.

Informazioni sui criteri QoS

Una procedura guidata per i criteri QoS in Console Gestione Criteri di gruppo consente di configurare criteri QoS in un oggetto Criteri di gruppo. Collegando l'oggetto Criteri di gruppo a contenitori Active Directory quali siti, domini e unità organizzative, è possibile applicare il criterio QoS per gestire il traffico in uscita per i computer o le sessioni di accesso utente definite. È ad esempio possibile creare criteri QoS per assegnare una priorità alta a tutto il traffico proveniente da un gruppo di server che eseguono un'applicazione di pianificazione delle risorse aziendali critica.

Le impostazioni di QoS basata su criteri in Windows Server 2008 R2 e Windows 7 consentono di classificare in ordine di priorità del traffico in uscita o di gestirne la velocità di invio sulla base degli elementi seguenti:

  • Applicazione di invio.

  • URL. Questa è una nuova funzionalità in Windows Server 2008 R2 e Windows 7.

  • Indirizzi o prefissi di indirizzi protocollo Internet versione 4 (IPv4) o versione 6 (IPv6) di origine o di destinazione.

  • Porte o intervalli di porte TCP (Transmission Control Protocol) o UDP (User Datagram Protocol).

  • Protocollo (TCP o UDP).

È possibile utilizzare un valore DSCP (Differentiated Services Code Point) per specificare la priorità del traffico. I valori DSCP sono definiti nella RFC 2474. Viene utilizzato un valore di velocità per specificare la velocità di invio del traffico. La velocità e il contrassegno DSCP possono essere utilizzati insieme. È ad esempio possibile creare un criterio QoS per contrassegnare tutto il traffico che risponde alle richieste da http://www.contoso.com con un valore DSCP pari a 44 e limitare tale traffico a una velocità in uscita totale di 500 kilobyte per secondo (KBps).

Nell'intestazione IPv4 il valore DSCP viene archiviato nel parametro TOS. Nell'intestazione IPv6 questo valore viene archiviato nel campo della classe di traffico. I router che supportano DSCP leggono il valore DSCP e inseriscono un pacchetto da inoltrare in una coda. Configurando le code e i valori DSCP per i router sulla rete, è possibile ottenere livelli differenziati di servizio per traffico contrassegnato con DSCP sulla rete. Per ulteriori informazioni, vedere la RFC 2474 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139654.

Oltre alle impostazioni dei criteri QoS standard che consentono di specificare un valore DSCP e una velocità, è possibile utilizzare impostazioni QoS avanzate per gestire il livello della velocità effettiva del traffico TCP in entrata e per specificare se le richieste di contrassegno DSCP delle applicazioni sono consentite o ignorate, in contrapposizione alle richieste di contrassegno dei criteri QoS.

Ulteriori riferimenti

  • Utilizzare criteri QoS

  • Impostazioni QoS avanzate

  • Sito Web TechCenter per QoS su Microsoft TechNet


Utilizzare criteri QoS

Utilizzare Console Gestione Criteri di gruppo per configurare o modificare le impostazioni di QoS (Quality of Service) basata su criteri. Se si modificano le impostazioni dei criteri sul computer locale, si modificano le impostazioni solo di quel computer. Se si configurano le impostazioni si un oggetto Criteri di gruppo ospitato in un dominio Active Directory, le impostazioni vengono applicate a tutti i computer che sono soggetti a quei Criteri di gruppo. Per ulteriori informazioni sui Criteri di gruppo in un dominio Active Directory vedere Criteri di gruppo (http://go.microsoft.com/fwlink/?LinkId=55625. La pagina potrebbe essere in inglese).

Per eseguire queste procedure, è necessaria almeno l'appartenenza al gruppo Domain Admins oppure a un gruppo equivalente.

Per creare un criterio QoS per computer o utenti

  1. In Oggetti Criteri di gruppo in Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su un oggetto Criteri di gruppo nella foresta e nel dominio in cui si desidera creare un criterio e quindi scegliere Modifica.

    • Per creare un criterio QoS per i computer, in Configurazione computer\Criteri\Impostazioni di Windows fare clic con il pulsante destro del mouse su QoS basata su criteri e quindi scegliere Crea nuovo criterio.

    • Per creare un criterio QoS per gli utenti, in Configurazione utente\Criteri\Impostazioni di Windows fare clic con il pulsante destro del mouse su QoS basata su criteri e quindi scegliere Crea nuovo criterio.

  2. Nella procedura guidata QoS basata su criteri selezionare Proprietà criterio QoS. Per ulteriori informazioni, vedere Creare e modificare un criterio QoS.
Per configurare impostazioni di criteri QoS avanzate per i computer

  1. In Oggetti Criteri di gruppo in Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su un oggetto Criteri di gruppo nella foresta e nel dominio in cui si desidera configurare impostazioni di criteri QoS avanzate e quindi scegliere Modifica.

  2. In Configurazione computer\Criteri\Impostazioni di Windows fare clic con il pulsante destro del mouse su QoS basata su criteri e quindi scegliere Impostazioni QoS avanzate.

  3. Fare clic su Proprietà QoS avanzate. Per ulteriori informazioni, vedere Impostazioni QoS avanzate.
Per visualizzare o modificare le impostazioni dei criteri QoS

  1. In Oggetti Criteri di gruppo in Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su un oggetto Criteri di gruppo nella foresta e nel dominio in cui si desidera visualizzare o modificare le impostazioni dei criteri e quindi scegliere Modifica.

  2. In Configurazione computer\Criteri\Impostazioni di Windows oppure in Configurazione utente\Criteri\Impostazioni di Windows fare clic con il pulsante destro del mouse sul criterio di cui si desidera visualizzare o modificare le impostazioni e quindi scegliere Modifica criterio esistente.
Per eliminare un criterio QoS

  1. In Oggetti Criteri di gruppo in Console Gestione Criteri di gruppo fare clic con il pulsante destro del mouse su un oggetto Criteri di gruppo nella foresta e nel dominio in cui si desidera eliminare un criterio QoS e quindi scegliere Modifica.

  2. In Configurazione computer\Criteri\Impostazioni di Windows oppure in Configurazione utente\Criteri\Impostazioni di Windows fare clic con il pulsante destro del mouse sul criterio che si desidera eliminare e quindi scegliere Elimina criterio.

Ulteriori riferimenti

  • Sito Web TechCenter per QoS su Microsoft TechNet


Interfaccia utente: QoS basata su criteri

  • Creare e modificare un criterio QoS

  • Impostazioni QoS avanzate


Creare e modificare un criterio QoS

Per creare o modificare un criterio QoS, utilizzare Console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo, i criteri QoS sono disponibili in Configurazione computer\Criteri\Impostazioni di Windows oppure in Configurazione utente\Criteri\Impostazioni di Windows nell'Editor Gestione Criteri di gruppo. I criteri QoS creati in Configurazione computer si applicano ai computer indipendentemente dall'utente connesso. I criteri QoS creati in Configurazione utente si applicano a una sessione utente indipendentemente dal computer utilizzato. Per ulteriori informazioni, vedere la pagina relativa ai criteri di gruppo di Windows Server all'indirizzo http://go.microsoft.com/fwlink/?LinkID=116313.

Quando si crea un nuovo criterio QoS, le pagine della procedura guidata consentono di definire la configurazione del criterio. Quando si modifica un criterio QoS, le schede corrispondenti alle pagine della procedura guidata consentono di modificare le impostazioni.

  • Scheda Profilo criterio (prima pagina della procedura guidata)

  • Scheda Nome o URL applicazione (seconda pagina della procedura guidata)

  • Scheda Indirizzi IP (terza pagina della procedura guidata)

  • Scheda Protocollo e porte (quarta pagina della procedura guidata)

Scheda Profilo criterio (prima pagina della procedura guidata)

Elemento | Dettagli
Nome criterio | Digitare un nome che identifichi in modo univoco il criterio QoS.
Specifica valore DSCP | Selezionare la casella di controllo per attivare il contrassegno DSCP e quindi digitare un valore DSCP compreso tra 0 e 63.
Specifica velocità | Selezionare questa casella di controllo per attivare la limitazione per il traffico in uscita e quindi specificare un valore maggiore di 1 in kilobyte per secondo (KBps) o in megabyte per secondo (Mbps).

Scheda Nome o URL applicazione (seconda pagina della procedura guidata)

Elemento | Dettagli
Tutte le applicazioni. | Impostazione predefinita. Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita indipendentemente dall'applicazione.
Solo le applicazioni con questo nome di eseguibile | Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita solo per l'applicazione specificata. Il nome del file eseguibile deve terminare con l'estensione exe. È possibile includere il percorso con il nome dell'applicazione. Il percorso inoltre può includere variabili di ambiente, ad esempio %ProgramFiles%\Percorso applicazione\App.exe oppure c:\programmi\percorso applicazione\app.exe. Il percorso dell'applicazione non può includere un collegamento simbolico.
Solo le applicazioni server HTTP che rispondono a richieste per l'URL seguente | Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita che risponde a un URL specificato. Sono supportati URL HTTP e HTTPS. L'URL può includere caratteri jolly e può specificare un nome host e un numero di porta. Selezionare la casella di controllo Includi sottodirectory e file per applicare le impostazioni di gestione del traffico a tutte le sottodirectory e a tutti i file dell'URL.

Scheda Indirizzi IP (terza pagina della procedura guidata)

Elemento Dettagli

Qualsiasi indirizzo IP di origine

Impostazione predefinita. Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita indipendentemente dall'indirizzo IP di origine del traffico.

Solo per il prefisso o l'indirizzo IP di origine seguente

Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita da un indirizzo IP di origine specificato. È possibile specificare l'indirizzo IP in uno dei formati seguenti:

  • Indirizzo protocollo Internet versione 4 (IPv4), ad esempio 1.2.3.4. Se l'indirizzo è locale rispetto al collegamento o è definito dalla RFC 1918, è necessario utilizzare la notazione della lunghezza del prefisso.

  • Prefisso di indirizzo IPv4 con notazione della lunghezza del prefisso di rete, ad esempio 192.168.1.0/24.

  • Indirizzo protocollo Internet versione 6 (IPv6), ad esempio 3ffe:ffff::1. Se l'indirizzo è locale rispetto al collegamento o al sito, è necessario utilizzare la notazione della lunghezza del prefisso.

  • Prefisso di indirizzo IPv6, ad esempio fe80::1234/48.

Qualsiasi indirizzo IP di destinazione

Impostazione predefinita. Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita indipendentemente dall'indirizzo IP di origine del traffico.

Solo per il prefisso o l'indirizzo IP di destinazione seguente

Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita per un indirizzo IP di destinazione specificato. È possibile specificare l'indirizzo IP in uno dei formati seguenti:

  • Indirizzo IPv4, ad esempio 1.2.3.4. Se l'indirizzo è locale rispetto al collegamento o è definito dalla RFC 1918, è necessario utilizzare la notazione della lunghezza del prefisso.

  • Prefisso di indirizzo IPv4 con notazione della lunghezza del prefisso di rete, ad esempio 192.168.1.0/24.

  • Indirizzo IPv6, ad esempio 3ffe:ffff::1. Se l'indirizzo è locale rispetto al collegamento o al sito, è necessario utilizzare la notazione della lunghezza del prefisso.

  • Prefisso di indirizzo IPv6, ad esempio fe80::1234/48.

Scheda Protocollo e porte (quarta pagina della procedura guidata)

Elemento | Dettaglio
Seleziona il protocollo a cui si applica questo criterio QoS: | È possibile scegliere di applicare il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita TPC, UDP o a entrambi.
Da qualsiasi porta di origine | Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita indipendentemente dal numero della porta di origine del traffico.
Da questo numero di porta o intervallo di porte di origine | Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) solo al traffico con il numero di porta o intervallo di porte di origine specificato. È possibile digitare un numero di porta compreso tra 1 e 65535 oppure un intervallo di porte nel formato "Minimo:Massimo", dove Minimo e Massimo rappresentano i limiti inferiore e superiore dell'intervallo di porte. Sia Minimo che Massimo devono corrispondere a un numero da 1 a 65535. Tra il carattere di due punti (:) e i numeri non sono consentiti spazi.
Verso qualsiasi porta di destinazione | Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) al traffico in uscita indipendentemente dal numero della porta di destinazione del traffico.
Verso questo numero di porta o intervallo di porte di destinazione | Applica il valore DSCP e la velocità specificati nella scheda Profilo criterio (prima pagina della procedura guidata) solo al traffico con il numero di porta o intervallo di porte di destinazione specificato. È possibile digitare un numero di porta compreso tra 1 e 65535 oppure un intervallo di porte nel formato "Minimo:Massimo", dove Minimo e Massimo rappresentano i limiti inferiore e superiore dell'intervallo di porte. Sia Minimo che Massimo devono corrispondere a un numero compreso tra 1 e 65535. Tra i due punti (:) e i numeri non sono consentiti spazi.

Ulteriori riferimenti

  • Panoramica di QoS basata su criteri

  • Utilizzare criteri QoS

  • Sito Web TechCenter per QoS su Microsoft TechNet


Impostazioni QoS avanzate

Le impostazioni QoS (Quality of Service) avanzate consentono di gestire l'utilizzo della larghezza di banda e la modalità con cui il computer gestisce i contrassegni DSCP impostati da applicazioni e servizi, in contrapposizione a quelli impostati da Criteri di rete. Le impostazioni QoS avanzate si applicano solo a livello di computer, mentre i criteri QoS possono essere applicati sia a livello di computer che a livello utente.

Traffico TCP in entrata

Il valore di Velocità nelle impostazioni di QoS basata su criteri consente di gestire la velocità di invio per il traffico di rete in uscita, mentre le impostazioni nella scheda Traffico TCP in entrata consentono di definire l'utilizzo della larghezza di banda per il traffico TCP ricevuto dal computer. Se si imposta un livello di velocità effettiva basso nella scheda Traffico TCP in entrata, TCP limita la dimensione della finestra di ricezione TCP annunciata. L'effetto prodotto da questa impostazione è un aumento delle velocità effettive e dell'utilizzo dei collegamenti per le connessioni TCP con larghezze di banda superiori o latenze, ovvero il prodotto del ritardo della larghezza di banda. Per impostazione predefinita è configurato il livello massimo di velocità effettiva, ovvero Livello 3.

Per modificare il livello di velocità effettiva, selezionare la casella di controllo Specifica il livello di velocità effettiva TCP in entrata e quindi selezionare un livello di velocità effettiva in base alla tabella seguente. Il livello di velocità effettiva può essere uguale o minore del livello massimo, a seconda delle condizioni della rete.

Impostazione | Livello massimo di velocità effettiva
Livello 0 (velocità effettiva minima) | 64 kilobyte (KB)
Livello 1 | 256 KB
Livello 2 | 1 megabyte (MB)
Livello 3 (velocità effettiva massima) | 16 MB

Override contrassegno DSCP

Override contrassegno DSCP impedisce alle applicazioni di specificare o contrassegnare valori DSCP diversi da zero. Per impostazione predefinita, le applicazioni e i servizi possono impostare valori DSCP diversi da zero.

Per ignorare le richieste di contrassegno DSCP di applicazioni e servizi, selezionare la casella di controllo Controlla le richieste di contrassegno DSCP di applicazioni e servizi e quindi selezionare Ignorato. I valori DSCP delle applicazioni e dei servizi che utilizzano API (Application Programming Interface) QoS verranno impostati su zero. Potranno impostare valori DSCP solo i criteri QoS.

Ulteriori riferimenti

  • Sito Web TechCenter per QoS su Microsoft TechNet