Individuazione evento di arresto

Individuazione evento di arresto è uno strumento che richiede agli utenti di registrare un motivo per il riavvio o l'arresto del computer. Questa informazione può essere esaminata nel registro eventi. Se un computer che esegue Windows 7 è connesso a un dominio che utilizza strumenti di monitoraggio, è possibile raccogliere queste informazioni nel rapporto di rete.

Quando Individuazione evento di arresto è attivato, non è possibile arrestare o riavviare il computer senza fornire un motivo. Se il computer viene arrestato o riavviato in modo imprevisto, in seguito a un'interruzione di corrente o a un errore hardware, viene richiesto di immettere un motivo in Individuazione evento di arresto al riavvio del computer.

Per ulteriori informazioni sull'utilizzo di Individuazione evento di arresto, vedere gli argomenti seguenti.

  • Panoramica di Individuazione evento di arresto

  • Utilizzare Individuazione evento di arresto


Panoramica di Individuazione evento di arresto

Individuazione evento di arresto costituisce uno strumento che consente ai professionisti IT di registrare in maniera coerente i motivi che spingono gli utenti a riavviare o arrestare i computer. Non consente, tuttavia, di specificare le motivazioni della scelta di altre opzioni, ad esempio Disconnetti o Ibernazione. I motivi forniti dagli utenti per i riavvii o gli arresti vengono raccolti per creare una panoramica completa dell'ambiente di sistema di un'organizzazione. Individuazione evento di arresto è disattivato per impostazione predefinita nei computer che eseguono Windows 7.

Riavvii e arresti "previsti" e "imprevisti"

Se Individuazione evento di arresto è attivato, viene visualizzata la finestra di dialogo relativa all'arresto previsto quando si fa clic sul pulsante Start e si sceglie Chiudi sessione, quando si preme ALT+F4 sul desktop oppure CTRL+ALT+CANC e quindi si sceglie Arresta il sistema o Riavvia il sistema. Questa operazione introduce un passaggio nel processo di arresto che richiede di fornire un motivo e un commento per spiegare l'azione. Il riavvio o l'arresto previsto lascia comunque al sistema operativo il tempo necessario per completare la normale routine di arresto. Per contro, il computer non è in grado di prevedere un riavvio o arresto "imprevisto". Se Individuazione evento di arresto è attivato, la finestra di dialogo per l'arresto imprevisto verrà mostrata al primo utente appartenente al gruppo locale Users che accederà al computer dopo il riavvio o l'arresto. Analogamente alla finestra di dialogo di arresto previsto, viene richiesto all'utente di fornire un motivo e un commento.

Riavvii e arresti pianificati e non pianificati

Un riavvio o un arresto previsto può essere pianificato o non pianificato. Quando si ha il controllo dei tempi di un riavvio o di un arresto, l'operazione è pianificata. Il reparto IT, ad esempio, può specificare un determinato momento per l'installazione di nuove applicazioni. Per contro, un riavvio o arresto non pianificato forza l'utente a eseguire immediatamente l'attività. L'applicazione che non risponde, ad esempio, impone all'utente di riavviare il computer in uso.

Anche i riavvii o gli arresti imprevisti possono essere pianificati o non pianificati. A volte gli utenti possono, ad esempio, arrestare i computer premendo il pulsante di spegnimento anziché facendo clic sul pulsante Start e scegliendo Chiudi sessione oppure premendo CTRL+ALT+CANC e scegliendo Arresta il sistema. In questo caso, l'arresto risulta imprevisto per il computer e pianificato per l'utente. Tuttavia, se il cavo di alimentazione del computer viene scollegato accidentalmente, l'arresto sarà imprevisto e non pianificato. In ogni caso, la finestra di dialogo dell'arresto imprevisto verrà mostrata al primo utente con diritti di arresto che accederà al computer dopo l'evento.

Riavvii e arresti in locale e in remoto

Individuazione evento di arresto e lo strumento da riga di comando Shutdown.exe consentono di riavviare o arrestare un computer e uno o più computer remoti. I professionisti IT possono, inoltre, eseguire annotazioni in blocco in remoto degli arresti imprevisti come alternativa alla dispendiosa attività che prevede l'accesso a ogni computer per registrare il motivo di un arresto imprevisto.

Analisi delle cause radice di riavvii e arresti

Individuazione evento di arresto registra il motivo di ogni riavvio o arresto mediante il servizio Registro eventi. Utilizzando il Visualizzatore eventi è possibile aprire il registro eventi sistema e cercare gli eventi che consentono di individuare la causa di riavvii o arresti frequenti. Per ulteriori informazioni sull'utilizzo di Visualizzatore eventi, vedere http://go.microsoft.com/fwlink/?LinkId=144403.

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto


Utilizzare Individuazione evento di arresto

I dati forniti da Individuazione evento di arresto possono essere utilizzati per ottenere un'immagine più completa dell'ambiente di sistema in uso. Per identificare l'andamento dei riavvii e degli arresti del computer, esaminare con regolarità i registri eventi nel Visualizzatore eventi. Questo tipo di informazioni costituisce il punto di partenza per isolare i problemi del sistema. Per ulteriori informazioni su Visualizzatore eventi, vedere http://go.microsoft.com/fwlink/?LinkId=144403.

  • Configurare Individuazione evento di arresto nel computer locale

  • Eseguire il riavvio o l'arresto di un computer locale e specificare il motivo

  • Eseguire il riavvio o l'arresto di un computer remoto e specificare il motivo

  • Annullare un riavvio o un arresto

  • Documentare il motivo di un riavvio o di un arresto imprevisto del computer locale

  • Documentare il motivo di un riavvio o di un arresto imprevisto del computer remoto

  • Attivare il servizio Registro di sistema remoto


Configurare Individuazione evento di arresto nel computer locale

Quando Individuazione evento di arresto è attivato, non è possibile arrestare o riavviare il computer senza fornire un motivo. Se il computer viene arrestato o riavviato in modo imprevisto, in seguito a un'interruzione di corrente o a un errore hardware, al primo membro del gruppo locale Users che accede dopo il riavvio verrà richiesto di immettere un motivo in Individuazione evento di arresto.

Individuazione evento di arresto può essere attivato sul computer locale modificando le impostazioni dei criteri di gruppo del computer locale.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente.

Per attivare Individuazione evento di arresto in Criteri di gruppo

  1. Fare clic sul pulsante Start, fare clic nella casella di ricerca e digitare gpedit.msc.

    Verrà visualizzata la finestra di dialogo Editor oggetti Criteri di gruppo.

  2. Nel riquadro di spostamento Criteri del computer locale espandere Configurazione computer, Modelli amministrativie quindi fare clic su Sistema.

  3. Nel riquadro della console, scorrere l'elenco degli oggetti, fare clic con il pulsante destro del mouse su Visualizza Individuazione evento di arresto e quindi fare clic su Proprietà.

  4. Nella scheda Impostazioni fare clic su Attivata.

  5. Nella casella a discesa selezionare Sempre e quindi fare clic su OK.

    Nota

    Le impostazioni Solo server e Solo workstation devono essere utilizzate dall'amministratore di dominio.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessario appartenere al gruppo locale Administrators o a un gruppo equivalente.

  • Se più utenti utilizzano il computer nel quale è attivato Individuazione evento di arresto, è consigliabile definire regole generali per specificare i motivi, ad esempio l'immissione del nome dell'applicazione nel campo del commento ogni volta che è necessario il riavvio in seguito all'installazione di un nuovo programma.

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto


Eseguire il riavvio o l'arresto di un computer locale e specificare il motivo

Quando Individuazione evento di arresto è attivato, verrà richiesto di fornire un motivo per il riavvio o l'arresto del computer.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo locale Users o a un gruppo equivalente.

Per eseguire il riavvio o l'arresto del computer locale e specificare il motivo

  1. Fare clic sul pulsante Start, fare clic sulla freccia a destra dell'icona Lucchetto e fare clic su Riavvia il sistema o Arresta il sistema.

  2. Se non si prevede di dover riavviare o arrestare il computer in questa occasione, deselezionare la casella di controllo Pianificato.

  3. Nell'elenco a discesa, selezionare il motivo appropriato per il riavvio o l'arresto e fare clic su OK.

    Nota

    Se l'immissione di un commento è obbligatoria, il pulsante OK non sarà disponibile finché non viene digitato almeno un carattere nella casella di testo.
Importante

Se il computer non viene spento automaticamente, non spegnerlo finché non verrà visualizzato un messaggio che indica che è possibile farlo. Il sistema operativo archivia dati importanti nella memoria mentre il sistema è in esecuzione ed è necessario che tali dati vengano salvati sul disco rigido prima di spegnere il computer. Dopo il salvataggio dei dati, il sistema operativo spegne il computer o visualizza un messaggio per indicare all'utente che è possibile farlo.

Ulteriori considerazioni

  • È inoltre possibile eseguire il riavvio o l'arresto del computer e specificare il motivo dalla riga di comando. Per informazioni sull'utilizzo del comando shutdown, digitare shutdown /? al prompt dei comandi.

  • È inoltre possibile eseguire il riavvio o l'arresto del computer e specificare il motivo premendo ALT+F4 quando è selezionato il desktop.

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto


Eseguire il riavvio o l'arresto di un computer remoto e specificare il motivo

Per utilizzare questa funzionalità, è necessario attivare il servizio Registro di sistema remoto sul computer remoto. Per ulteriori informazioni, vedere Attivare il servizio Registro di sistema remoto.

L'accesso al Registro di sistema remoto o l'appartenenza al gruppo Administrators del computer remoto è il requisito minimo necessario per completare questa procedura.

  • Tramite l'interfaccia di Windows

  • Tramite una riga di comando

Tramite l'interfaccia di Windows

Per eseguire il riavvio o l'arresto di un computer remoto e specificare il motivo utilizzando l'interfaccia Windows

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi fare clic su Prompt dei comandi.

  2. Digitare shutdown /i per visualizzare la finestra di dialogo Arresto remoto (Shutdown.exe).

  3. In Computer scegliere Aggiungi per immettere i nomi dei computer o Sfoglia per aprire la finestra di dialogo Trova computer.

  4. In Scegliere una delle seguenti opzioni fare clic su Arresta il sistema o Riavvia il sistema.

  5. Selezionare dall'elenco il motivo appropriato per il riavvio o l'arresto.

    Nota

    Se l'immissione di un commento è obbligatoria, il pulsante OK non sarà disponibile finché non viene digitato almeno un carattere nella casella di testo.

Ulteriori considerazioni

  • È inoltre possibile aprire il prompt dei comandi facendo clic sul pulsante Start, facendo clic nella casella di ricerca, digitando cmd e quindi premendo INVIO.

  • È necessario attivare il servizio Registro di sistema remoto sul computer remoto in modo che Individuazione evento di arresto registri le informazioni.

  • Per spegnere o riavviare un computer remoto, è necessario che nel computer remoto siano attivate le eccezioni del firewall per Amministrazione remota e Strumentazione gestione Windows (WMI).

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto

  • Attivare il servizio Registro di sistema remoto

Tramite una riga di comando

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente nel computer remoto.

Per eseguire il riavvio o l'arresto di un computer remoto e specificare il motivo utilizzando la riga di comando

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Prompt dei comandi.

  2. Digitare shutdown /[r|s] /m \\NomeComputer /c "Commento" /d [u|p] <xx>:<yy> e quindi premere INVIO.

Valore Descrizione

/r

Riavvia il computer remoto.

/s

Spegne il computer remoto.

/m \\NomeComputer

Specifica il computer di destinazione.

/c "Commento"

Consente di immettere un commento dettagliato sul motivo dell'arresto. È possibile utilizzare un massimo di 511 caratteri. I commenti vanno racchiusi tra virgolette.

/d [u|p] xx:yy

Specifica il motivo del riavvio o dell'arresto del sistema, dove xx è un numero di motivo principale compreso tra 0 e 255 e yy è un numero di motivo secondario compreso tra 0 e 65.535.

/force

Forza lo spegnimento del computer se sono connessi altri utenti. Se non si utilizza questa opzione e altri utenti sono connessi al computer remoto, il computer non verrà spento o riavviato.

Importante

Se si forza lo spegnimento o il riavvio del computer, gli utenti connessi non avranno la possibilità di salvare il lavoro.

/t xxx

Imposta il periodo di timeout prima dello spegnimento o del riavvio del sistema su xxx secondi. L'intervallo valido è 0-600, con un valore predefinito di 30. Se si specifica il contrassegno /t, verrà utilizzata l'opzione /force.

Per informazioni più dettagliate sul comando shutdown e altre opzioni, digitare shutdown /? al prompt dei comandi.

Ulteriori considerazioni

  • È inoltre possibile aprire il prompt dei comandi facendo clic sul pulsante Start, facendo clic nella casella Inizia ricerca, digitando cmd e premendo INVIO.

  • È necessario attivare il servizio Registro di sistema remoto sul computer remoto in modo che Individuazione evento di arresto registri le informazioni.

  • Per arrestare o riavviare un computer remoto, è necessario che nel computer remoto siano attivate le eccezioni del firewall per Amministrazione remota e Strumentazione gestione Windows (WMI).

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto

  • Attivare il servizio Registro di sistema remoto

  • Notazione di sintassi della riga di comando


Annullare un riavvio o un arresto

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Users o a un gruppo equivalente.

Per annullare un riavvio o un arresto

  1. Aprire una finestra del prompt dei comandi.

  2. Digitare shutdown /a entro il periodo di timeout.

Ulteriori considerazioni

  • Per avviare un prompt dei comandi, fare clic sul pulsante Start, scegliere Tutti i programmi, espandere Accessori e quindi fare clic su Prompt dei comandi.

  • È inoltre possibile aprire il prompt dei comandi facendo clic sul pulsante Start, facendo clic nella casella di ricerca, digitando cmd e quindi premendo INVIO.

  • Per ulteriori informazioni sul comando shutdown, digitare shutdown /? al prompt dei comandi.

  • Non è possibile annullare un riavvio o un arresto tramite l'interfaccia Windows Individuazione evento di arresto. Questa operazione può essere eseguita solo dalla riga di comando.

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto

  • Notazione di sintassi della riga di comando


Documentare il motivo di un riavvio o di un arresto imprevisto del computer locale

Se Individuazione evento di arresto è disattivato e il computer viene riavviato o arrestato senza l'immissione di un motivo, al primo membro del gruppo locale Users che accede dopo il riavvio verrà richiesto di immettere un motivo dell'evento.

Per poter completare questa procedura, è richiesta almeno l'appartenenza al gruppo Users o a un gruppo equivalente.

Documentare il motivo di un riavvio o di un arresto imprevisto del computer locale

  1. Selezionare il motivo nell'elenco a discesa Motivo dell'arresto imprevisto del computer.

  2. Se nell'organizzazione è disponibile un sistema di registrazione dei problemi, è possibile immettere un ID problema per consentire all'amministratore di sistema di tenere traccia del problema.

  3. Se è richiesto un commento del motivo selezionato nel passaggio 1, è necessario immettere un testo nella casella prima di fare clic su OK.

  4. Dopo aver immesso le informazioni, fare clic su OK.

Ulteriori considerazioni

  • È consigliabile utilizzare motivi standard quando vengono registrate le informazioni in Individuazione evento di arresto. Viene così facilitata la verifica delle tendenze cronologiche.

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto


Documentare il motivo di un riavvio o di un arresto imprevisto del computer remoto

È possibile documentare il motivo di un riavvio o di un arresto imprevisto del computer remoto senza accedere localmente al computer. Per utilizzare questa funzionalità, è necessario attivare il servizio Registro di sistema remoto sul computer remoto. Per ulteriori informazioni, vedere Attivare il servizio Registro di sistema remoto.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente nel computer remoto.

  • Tramite l'interfaccia di Windows

  • Tramite una riga di comando

Tramite l'interfaccia di Windows

Per specificare il motivo di un riavvio o un arresto imprevisto di un computer remoto utilizzando l'interfaccia Windows

  1. Aprire una finestra del prompt dei comandi.

  2. Digitare shutdown /i per visualizzare la finestra di dialogo Arresto remoto (Shutdown.exe).

  3. In Computer scegliere Aggiungi per immettere i nomi dei computer o Sfoglia per aprire la finestra di dialogo Trova computer.

  4. In Scegliere una delle seguenti opzioni fare clic su Commenta arresto inatteso.

  5. Selezionare dall'elenco il motivo appropriato per l'arresto imprevisto.

    Nota

    Se l'immissione di un commento è obbligatoria, il pulsante OK non sarà disponibile finché non viene digitato almeno un carattere nella casella di testo.

Ulteriori considerazioni

  • Per avviare il prompt dei comandi, fare clic sul pulsante Start, scegliere Tutti i programmi, fare clic su Accessori e quindi su Prompt dei comandi.

  • È inoltre possibile aprire il prompt dei comandi facendo clic sul pulsante Start, facendo clic nella casella Inizia ricerca, digitando cmd e premendo INVIO.

  • È necessario attivare il servizio Registro di sistema remoto sul computer remoto in modo che Individuazione evento di arresto registri le informazioni.

  • Per spegnere o riavviare un computer remoto, è necessario che nel computer remoto siano attivate le eccezioni del firewall per Amministrazione remota e Strumentazione gestione Windows (WMI).

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto

  • Attivare il servizio Registro di sistema remoto

Tramite una riga di comando

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente nel computer remoto.

Per specificare il motivo di un riavvio o un arresto imprevisto di un computer remoto utilizzando la riga di comando

  1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi fare clic su Prompt dei comandi.

  2. Digitare shutdown /e /m \\NomeComputer /c "Commento" /d [u|p] <xx>:<yy> e quindi premere INVIO.

Valore Descrizione

/e

Consente di specificare il motivo dell'arresto imprevisto del computer remoto.

/m \\NomeComputer

Specifica il computer di destinazione.

/c

Consente di immettere un commento dettagliato sul motivo dell'arresto. È possibile utilizzare un massimo di 511 caratteri. I commenti vanno racchiusi tra virgolette.

/d [u|p] xx:yy

Specifica il motivo del riavvio o dell'arresto del sistema, dove xx è un numero di motivo principale compreso tra 0 e 255 e yy è un numero di motivo secondario compreso tra 0 e 65.535.

/force

Forza lo spegnimento del computer se sono connessi altri utenti. Se non si utilizza questa opzione e altri utenti sono connessi al computer remoto, il computer non verrà spento o riavviato.

Importante

Se si forza lo spegnimento o il riavvio del computer, gli utenti connessi non avranno la possibilità di salvare il lavoro.

/t xxx

Imposta il periodo di timeout prima dello spegnimento o del riavvio del sistema su xxx secondi. L'intervallo valido è 0-600, con un valore predefinito di 30. Se si specifica il contrassegno /t, verrà utilizzata l'opzione /force.

Per informazioni più dettagliate sul comando shutdown e altre opzioni, digitare shutdown /? al prompt dei comandi.

Ulteriori considerazioni

  • È necessario attivare il servizio Registro di sistema remoto sul computer remoto in modo che Individuazione evento di arresto registri le informazioni.

  • Per arrestare o riavviare un computer remoto, è necessario che nel computer remoto siano attivate le eccezioni del firewall per Amministrazione remota e Strumentazione gestione Windows (WMI).

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto

  • Attivare il servizio Registro di sistema remoto

  • Notazione di sintassi della riga di comando


Attivare il servizio Registro di sistema remoto

Un valore chiave del Registro di sistema indica a Individuazione evento di arresto quando richiedere all'utente le informazioni sul riavvio o arresto imprevisto. Senza l'accesso al Registro di sistema remoto, Individuazione evento di arresto non può reimpostare in remoto il valore chiave del Registro di sistema dopo che è stato fornito il motivo.

Per poter completare questa procedura sul computer remoto, è richiesta almeno l'appartenenza al gruppo Administrator o a un gruppo equivalente.

Attivare il servizio Registro di sistema remoto

  1. Nel computer in cui si desidera registrare i dati di Individuazione evento di arresto fare clic sul pulsante Start, fare clic nella casella Inizia ricerca, digitare services.msc e quindi premere INVIO. Microsoft Management Console verrà avviato con lo snap-in Servizi aperto.

  2. Nella riquadro della console fare clic con il pulsante destro del mouse su Registro di sistema remoto e fare clic su Start.

Ulteriori considerazioni

  • Per completare questa procedura, è necessario appartenere al gruppo Administrators locale o a un gruppo equivalente sul computer remoto.

Ulteriori riferimenti

  • Utilizzare Individuazione evento di arresto

  • Panoramica di Individuazione evento di arresto

Per ulteriori informazioni sull'utilizzo di Microsoft Management Console, vedere http://go.microsoft.com/fwlink/?linkid=70036.


Notazione di sintassi della riga di comando

Nella tabella seguente viene descritta la notazione utilizzata per indicare la sintassi della riga di comando.

Notazione | Descrizione
Testo senza parentesi quadre o graffe | Elementi da digitare come indicato
<Testo tra parentesi acute> | Segnaposto per il quale è necessario fornire un valore
[Testo tra parentesi quadre] | Elementi facoltativi
{Testo tra parentesi graffe} | Serie di elementi richiesti: effettuare una selezione
Barra verticale (|) | Separatore per elementi che si escludono a vicenda: effettuare una selezione
Puntini di sospensione (...) | Elementi che possono essere ripetuti