Monitoraggio risorse di Windows

Monitoraggio risorse di Windows è un'utilità di sistema che consente di visualizzare informazioni sull'utilizzo di risorse hardware (CPU, memoria, disco e rete) e software (handle di file e moduli) in tempo reale. È possibile filtrare i risultati in base a processi o servizi specifici che si desidera monitorare. È inoltre possibile utilizzare Monitoraggio risorse per avviare, arrestare, sospendere e riprendere processi e servizi e per risolvere problemi quando un'applicazione non risponde nel modo previsto.

Per avviare Monitoraggio risorse

  • Fare clic sul pulsante Start, fare clic nella casella Avvia ricerca, digitare resmon.exe e quindi premere INVIO.
  • Panoramica di Monitoraggio risorse di Windows

  • Utilizzare Monitoraggio risorse per identificare i consumer di risorse

  • Filtrare i dati di Monitoraggio risorse

  • Utilizzare Monitoraggio risorse per controllare processi e servizi

  • Utilizzare Monitoraggio risorse per risolvere i problemi relativi ad applicazioni che non rispondono

  • Utilizzare Monitoraggio risorse per visualizzare handle e moduli

Ulteriori riferimenti

Per ulteriori informazioni, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70270.


Utilizzare Monitoraggio risorse per controllare processi e servizi

Monitoraggio risorse di Windows consente di terminare o sospendere processi e di avviare, arrestare o riavviare servizi.

Nota

Se non si è in grado di determinare con certezza la criticità o la funzione di un processo o di un servizio, è possibile fare clic con il pulsante destro del mouse sul nome del processo o del servizio nella tabella e quindi scegliere Cerca online per cercare ulteriori informazioni sul Web utilizzando il nome del processo o del servizio.

Per avviare Monitoraggio risorse

  • Fare clic sul pulsante Start, fare clic nella casella Avvia ricerca, digitare resmon.exe e quindi premere INVIO.

Controllare processi tramite Monitoraggio risorse

Attenzione

È consigliabile utilizzare Monitoraggio risorse per terminare un processo solo se non è possibile chiudere il programma normalmente. Se al processo è associato un programma aperto, il programma verrà chiuso immediatamente e i dati non salvati andranno perduti. Se si termina un processo di sistema, è possibile provocare instabilità del sistema e perdita dei dati.

Nota

Se si utilizza Monitoraggio risorse per sospendere un processo, non sarà possibile utilizzare il programma sospeso fino a quando non viene ripreso. La sospensione di un processo può provocare perdita dei dati se dal processo dipendono altri programmi.

Per terminare un processo tramite Monitoraggio risorse

  1. Nella colonna Immagine della tabella principale di qualsiasi scheda di Monitoraggio risorse fare clic con il pulsante destro del mouse sul nome dell'eseguibile del processo che si desidera terminare e quindi scegliere Termina processo.

    Nota

    Per terminare tutti i processi dipendenti dal processo selezionato, fare clic su Termina albero processi.

  2. Nella finestra di dialogo confermare che si desidera terminare il processo.
Per sospendere un processo tramite Monitoraggio risorse

  1. Nella colonna Immagine della tabella principale di qualsiasi scheda di Monitoraggio risorse fare clic con il pulsante destro del mouse sul nome dell'eseguibile del processo che si desidera sospendere e quindi scegliere Sospendi processo.

  2. Nella finestra di dialogo confermare che si desidera sospendere il processo.

    Nota

    I processi sospesi vengono visualizzati come voci di colore blu nella tabella.
Per riprendere un processo tramite Monitoraggio risorse

  1. Nella colonna Immagine della tabella principale di qualsiasi scheda di Monitoraggio risorse fare clic con il pulsante destro del mouse sul nome dell'eseguibile del processo che si desidera riprendere e quindi scegliere Riprendi processo.

  2. Nella finestra di dialogo confermare che si desidera riprendere il processo.

Controllare servizi tramite Monitoraggio risorse

Attenzione

Altri servizi e applicazioni possono dipendere dai servizi in esecuzione. L'arresto o il riavvio di un servizio necessario per il corretto funzionamento di altri servizi e applicazioni può provocare instabilità del sistema e perdita di dati. Potrebbe non essere possibile arrestare un servizio critico tramite Monitoraggio risorse.

Per avviare, arrestare o riavviare un servizio tramite Monitoraggio risorse

  1. Nella scheda CPU fare clic sulla barra del titolo di Servizi per espandere la tabella.

  2. In Nome fare clic con il pulsante destro del mouse sul nome del servizio che si desidera modificare e quindi scegliere Arresta servizio, Avvia servizio, o Riavvia servizio.

    Nota

    Per ordinare i servizi in base a quelli in esecuzione o arrestati, fare clic sull'etichetta della colonna Stato.

Ulteriori riferimenti

  • Panoramica di Monitoraggio risorse di Windows

  • Utilizzare Monitoraggio risorse per risolvere i problemi relativi ad applicazioni che non rispondono

  • Utilizzare Monitoraggio risorse per visualizzare handle e moduli


Filtrare i dati di Monitoraggio risorse

Monitoraggio risorse consente di visualizzare informazioni in tempo reale su tutti i processi in esecuzione nel sistema. Se si desidera visualizzare solo i dati correlati a processi selezionati, è possibile filtrare i risultati dettagliati.

Per filtrare i dati in base a uno o più processi

  1. Per avviare Monitoraggio risorse, fare clic sul pulsante Start, fare clic nella casella Avvia ricerca digitare resmon.exe e quindi premere INVIO.

  2. Nella colonna Immagine della tabella principale di qualsiasi scheda di Monitoraggio risorse selezionare la casella di controllo accanto al nome di ogni processo che si desidera monitorare. I processi selezionati verranno spostati all'inizio della colonna.

  3. Se i risultati dettagliati non sono visibili, fare clic sulla barra del titolo della tabella dei dettagli per espandere la tabella.

    Nota

    Dopo avere selezionato almeno un processo in base a cui filtrare i dati, le tabelle Handle associati e Moduli associati della scheda CPU includeranno i dati correlati alla selezione.

  4. Il filtro verrà applicato a tutte le schede. Per visualizzare ulteriori dati di utilizzo delle risorse per la selezione, è possibile fare clic su un'altra scheda. Le tabelle che contengono solo risultati filtrati includono una barra delle informazioni di colore arancione al di sotto della barra del titolo della tabella.

    Nota

    Se il processo selezionato non utilizza alcuna delle risorse visualizzate nella scheda corrente, il nome del processo non verrà visualizzato nella tabella principale. Per apportare modifiche alla selezione, tornare alla scheda originale.

  5. Per rimuovere il filtro per un singolo processo o servizio, deselezionare la casella di controllo relativa. Per non filtrare più i risultati, nella tabella principale deselezionare la casella di controllo accanto a Immagine.

Ulteriori riferimenti

  • Panoramica di Monitoraggio risorse di Windows

  • Utilizzare Monitoraggio risorse per identificare i consumer di risorse

  • Utilizzare Monitoraggio risorse per controllare processi e servizi

  • Utilizzare Monitoraggio risorse per risolvere i problemi relativi ad applicazioni che non rispondono


Panoramica di Monitoraggio risorse di Windows

Monitoraggio risorse di Windows è un potente strumento in cui viene indicato l'utilizzo delle risorse di sistema da parte di processi e servizi. Oltre a monitorare l'utilizzo delle risorse in tempo reale, Monitoraggio risorse consente di analizzare i processi che non rispondono, identificare le applicazioni che utilizzano determinati file e controllare processi e servizi.

Per avviare Monitoraggio risorse

  • Fare clic sul pulsante Start, fare clic nella casella Avvia ricerca, digitare resmon.exe e quindi premere INVIO.
Per sospendere o riprendere il monitoraggio

  • Per sospendere la raccolta dati ed esaminare i dati correnti, fare clic su Monitor e quindi su Interrompi monitoraggio. Per riavviare la raccolta dati, fare clic su Monitor e quindi su Avvia monitoraggio.

Monitoraggio risorse viene avviato sempre nella stessa posizione e con le stesse opzioni di visualizzazione della sessione precedente. In qualsiasi momento, tuttavia, è possibile salvare lo stato di visualizzazione, incluse le dimensioni della finestra, la larghezza delle colonne, le colonne facoltative, le tabelle espanse e la scheda attiva. È quindi possibile aprire il file di configurazione per utilizzare le impostazioni salvate.

Per salvare o caricare le impostazioni di configurazione di Monitoraggio risorse

  • Per salvare le impostazioni di visualizzazione correnti, scegliere Salva impostazioni con nome dal menu File, digitare un nome nella casella Nome file e quindi fare clic su Salva.

    Nota

    Le opzioni relative ai filtri non vengono salvate come parte delle impostazioni di configurazione.

  • Per caricare una configurazione salvata, scegliere Carica impostazioni dal menu File, selezionare il file di configurazione nell'elenco e quindi fare clic su Apri.

Panoramica di Monitoraggio risorse

Monitoraggio risorse di Windows include gli elementi e le funzionalità seguenti.

Schede

Monitoraggio risorse include cinque schede: Panoramica, CPU, Memoria, Disco e Rete. Nella scheda Panoramica vengono visualizzate informazioni di base sull'utilizzo delle risorse di sistema, mentre nelle altre schede vengono visualizzate le informazioni su ogni risorsa specifica.

  • Per passare da una scheda all'altra, fare clic sui rispettivi titoli.

  • Se sono stati filtrati i risultati in una scheda, nelle altre schede verranno visualizzate solo le risorse utilizzate dai processi o i servizi selezionati. I risultati filtrati sono indicati da una barra arancione al di sotto della barra del titolo di ogni scheda. Per non filtrare più i risultati durante la visualizzazione della scheda corrente, nella tabella principale deselezionare la casella di controllo accanto a Immagine.

Tabelle

Ogni scheda di Monitoraggio risorse include più tabelle, che contengono informazioni dettagliate sulla risorsa descritta nella scheda.

  • Per espandere o comprimere una tabella, fare clic sulla freccia a destra della barra del titolo della tabella. Non tutte le tabelle sono espanse per impostazione predefinita.

  • Per aggiungere o nascondere colonne di dati in una tabella, fare clic con il pulsante destro del mouse sull'etichetta di una tabella e quindi scegliere Seleziona colonne. Selezionare o deselezionare le caselle di controllo per le colonne che si desidera visualizzare. Non tutte le colonne vengono visualizzate per impostazione predefinita.

  • La prima tabella visualizzata è sempre la tabella principale, che contiene sempre un elenco completo dei processi che utilizzano la risorsa inclusa nella scheda. La tabella principale nella scheda Panoramica contiene un elenco completo dei processi in esecuzione nel sistema.

  • Per ordinare i dati della tabella, fare clic sull'etichetta della colonna in base alla quale si desidera ordinare i dati. Per invertire l'ordinamento, fare di nuovo clic sull'etichetta della colonna.

  • È possibile filtrare i dati dettagliati in tabelle diverse da quella principale in base a uno o più processi o servizi. Per filtrare i dati, nella tabella principale selezionare la casella di controllo accanto a ogni processo o servizio che si desidera evidenziare. Per rimuovere il filtro per un singolo processo o servizio, deselezionare la relativa casella di controllo. Per non filtrare più i risultati, nella tabella principale deselezionare la casella di controllo accanto a Immagine.

  • Se sono stati filtrati i risultati, nelle tabelle diverse da quella principale verranno visualizzati solo i dati per i processi o i servizi selezionati.

  • Per visualizzare definizioni dei dati visualizzati nelle tabelle, spostare il puntatore del mouse sul titolo della colonna su cui si desidera visualizzare ulteriori informazioni.

  • Un processo non più in esecuzione ma incluso nei dati visualizzati correnti verrà visualizzato come voce in grigio in una tabella fino allo scadere dei dati.

Riquadro dei grafici

Ogni scheda di Monitoraggio risorse include un riquadro dei grafici nel lato destro della finestra, in cui vengono visualizzati i grafici delle risorse contenute nella scheda.

  • È possibile modificare le dimensioni dei grafici facendo clic sul pulsante Visualizzazioni e quindi selezionando una dimensione diversa.

  • È possibile nascondere il riquadro dei grafici facendo clic sulla freccia nella parte superiore del riquadro.

  • Se sono stati filtrati i risultati, le risorse utilizzate dai processi o i servizi selezionati verranno visualizzate nei grafici come righe arancioni.

  • Se sono presenti più processori logici, è possibile scegliere quelli visualizzati nel riquadro dei grafici. Nella scheda CPU fare clic su Monitor e quindi su Seleziona processori. Nella finestra di dialogo Seleziona processori deselezionare la casella di controllo Tutte le CPU e quindi selezionare le caselle di controllo relative ai processori logici che si desidera visualizzare.

    Nota

    In Monitoraggio risorse viene visualizzato un grafico per ogni processore logico. A un computer con un singolo processore dotato di due core, ad esempio, corrisponderanno due grafici dei processori nel riquadro dei grafici della scheda CPU. Per i computer con più processori organizzati in nodi NUMA, è possibile utilizzare l'opzione di menu Seleziona nodi NUMA per configurare Monitoraggio risorse per la visualizzazione di tutti i processori logici in un nodo NUMA selezionato.

Ulteriori riferimenti

  • Utilizzare Monitoraggio risorse per identificare i consumer di risorse

  • Filtrare i dati di Monitoraggio risorse

  • Utilizzare Monitoraggio risorse per controllare processi e servizi

  • Utilizzare Monitoraggio risorse per risolvere i problemi relativi ad applicazioni che non rispondono

  • Utilizzare Monitoraggio risorse per visualizzare handle e moduli


Utilizzare Monitoraggio risorse per risolvere i problemi relativi ad applicazioni che non rispondono

Le applicazioni che non rispondono potrebbero essere in attesa del completamento di altri processi o della disponibilità di risorse di sistema prima di poter continuare. Monitoraggio risorse di Windows consente di visualizzare una catena di attesa dei processi e di terminare i processi che impediscono il corretto funzionamento di un programma.

Un processo che non risponde verrà visualizzato come voce di colore rosso nella tabella CPU della scheda Panoramica e nella tabella Processi della scheda CPU.

Attenzione

È consigliabile utilizzare Monitoraggio risorse per terminare un processo solo se non è possibile chiudere il programma normalmente. Se al processo è associato un programma aperto, il programma verrà chiuso immediatamente e i dati non salvati andranno perduti. Se si termina un processo di sistema, è possibile provocare instabilità del sistema e perdita dei dati.

Per analizzare un processo tramite Monitoraggio risorse

  1. Per avviare Monitoraggio risorse, fare clic sul pulsante Start, fare clic nella casella Avvia ricerca digitare resmon.exe e quindi premere INVIO.

  2. Nella colonna Immagine della tabella principale di qualsiasi scheda di Monitoraggio risorse fare clic con il pulsante destro del mouse sul nome del processo che si desidera analizzare e quindi scegliere Analizza catena di attesa.

  3. Se il processo è in esecuzione normalmente e non è in attesa di altri processi, non verrà visualizzata alcuna informazione sulla catena di attesa.

    Se il processo è in attesa di un altro processo, verrà visualizzato un albero organizzato in base alla dipendenza da altri processi.

    Nota

    Il normale funzionamento di molti processi di sistema dipende da altri processi e servizi. In Monitoraggio risorse vengono visualizzate le informazioni sulla catena di attesa per ogni processo. Se la voce di un processo non è visualizzata in rosso nella tabella, se lo stato del processo viene indicato come In esecuzione e il programma funziona normalmente, non sarà necessaria alcuna azione da parte dell'utente.

  4. Se viene visualizzato l'albero di una catena di attesa, è possibile terminare uno o più processi nell'albero selezionando le caselle di controllo accanto ai nomi dei processi e quindi facendo clic su Termina processo.

Ulteriori riferimenti

  • Panoramica di Monitoraggio risorse di Windows

  • Utilizzare Monitoraggio risorse per visualizzare handle e moduli


Utilizzare Monitoraggio risorse per visualizzare handle e moduli

In Monitoraggio risorse di Windows è possibile visualizzare gli handle e i moduli utilizzati da un processo selezionato.

  • Gli handle sono puntatori che fanno riferimento a elementi di sistema, inclusi, tra gli altri, file, chiavi del Registro di sistema, eventi o directory.

  • I moduli sono file di supporto o programmi, inclusi, tra gli altri, i file DLL (Dynamic-Link Library).

Per avviare Monitoraggio risorse

  • Fare clic sul pulsante Start, fare clic nella casella Avvia ricerca, digitare resmon.exe e quindi premere INVIO.

Per visualizzare tutti gli handle e i moduli associati a un processo

  1. Nella colonna Immagine della tabella Processi nella scheda CPU selezionare la casella di controllo accanto al nome del processo per cui si desidera visualizzare gli handle e i moduli associati. I processi selezionati verranno spostati all'inizio della colonna.

  2. Fare clic sulle barre del titolo delle tabelle Handle associati e Moduli associati per espanderle. Una barra arancione al di sotto della barra del titolo di ogni tabella indicherà i processi selezionati.

  3. Esaminare i risultati nelle tabelle dei dettagli. Per ottimizzare ulteriormente i risultati, è possibile utilizzare la procedura seguente, che consente di cercare handle specifici nella tabella Handle associati.
Per identificare le applicazioni che utilizzano un handle specifico

  • Nella barra del titolo della tabella Handle associati fare clic nella casella Cerca handle, digitare il nome dell'handle che si desidera cercare e quindi fare clic sul pulsante di ricerca.

    Nota

    Nella stringa di ricerca non viene effettuata alcuna distinzione tra maiuscole e minuscole e i caratteri jolly non sono supportati. È possibile digitare tutta o parte di una stringa per cercare gli handle. La ricerca di c:\windows, ad esempio, restituirà tutti gli handle il cui nome contiene c:\windows.

  • Per ottimizzare ulteriormente i risultati della ricerca, nella tabella Processi è possibile selezionare la casella di controllo accanto al nome di un processo al termine della ricerca. I risultati verranno quindi filtrati in base al processo o ai processi selezionati.

    Nota

    La tabella dei risultati non viene aggiornata dinamicamente. Se si ritiene che lo stato del sistema sia cambiato, fare nuovamente clic sul pulsante di ricerca per aggiornare i risultati.

Ulteriori riferimenti

  • Panoramica di Monitoraggio risorse di Windows

  • Utilizzare Monitoraggio risorse per risolvere i problemi relativi ad applicazioni che non rispondono


Utilizzare Monitoraggio risorse per identificare i consumer di risorse

In Monitoraggio risorse di Windows è possibile ordinare i dati delle tabelle in base a qualsiasi colonna per semplificare l'identificazione delle risorse utilizzate da determinati processi. Nelle sezioni seguenti viene descritto come completare alcune attività di risoluzione dei problemi comuni utilizzando Monitoraggio risorse.

Nota

Per visualizzare definizioni dei dati visualizzati nelle tabelle, spostare il puntatore del mouse sul titolo della colonna su cui si desidera visualizzare ulteriori informazioni.

Per avviare Monitoraggio risorse

  • Fare clic sul pulsante Start, fare clic nella casella Avvia ricerca, digitare resmon.exe e quindi premere INVIO.
Per identificare il processo con l'utilizzo di CPU corrente più elevato

  1. Fare clic sulla scheda CPU.

  2. In Processi fare clic su CPU per ordinare i processi in base all'utilizzo di risorse della CPU corrente.

    Nota

    Quando si chiude Monitoraggio risorse, le impostazioni di visualizzazione specificate vengono salvate. Se in precedenza sono stati ordinati i risultati in ordine decrescente, è necessario fare nuovamente clic sull'etichetta della colonna per invertire l'ordine e visualizzare i consumer di risorse più elevati all'inizio dell'elenco.

  3. Il primo nome di processo in Immagine, che corrisponde anche al valore più elevato in CPU, è il processo che utilizza la maggior parte della CPU.
Per visualizzare l'utilizzo della CPU da parte dei servizi in base al processo

  1. Fare clic sulla scheda CPU.

  2. Nella colonna Immagine in Processi selezionare la casella di controllo accanto al nome del servizio per cui si desidera visualizzare i dettagli sull'utilizzo. È possibile selezionare più servizi. I servizi selezionati verranno spostati all'inizio della colonna.

  3. Fare clic sulla barra del titolo di Servizi per espandere la tabella.

  4. Esaminare i dati in Servizi per visualizzare l'elenco dei processi ospitati dai servizi selezionati e il relativo utilizzo della CPU.
Per identificare il processo che utilizza un file specifico

  1. Fare clic sulla scheda CPU e quindi fare clic sulla barra del titolo di Handle associati per espandere la tabella.

  2. Fare clic nella casella Cerca handle digitare il nome del file che si desidera cercare e quindi fare clic sul pulsante di ricerca.

    Nota

    Nella stringa di ricerca non viene effettuata alcuna distinzione tra maiuscole e minuscole e i caratteri jolly non sono supportati. Nella casella di ricerca è possibile digitare tutto o parte del nome del file o del percorso. La ricerca di c:\windows, ad esempio, restituirà tutti i file il cui percorso contiene c:\windows.

  3. Esaminare i risultati per identificare il processo che utilizza il file.
Per identificare l'indirizzo di rete a cui è connesso un processo

  1. Fare clic sulla scheda Rete e quindi fare clic sulla barra del titolo di Connessioni TCP per espandere la tabella.

  2. Individuare il processo di cui si desidera identificare la connessione di rete. Se la tabella include un numero elevato di voci, è possibile fare clic su Immagine per ordinare le voci in base al nome del file eseguibile.

  3. Esaminare le colonne Indirizzo remoto e Porta remota per visualizzare l'indirizzo di rete e la porta a cui è connesso il processo.
Per visualizzare lo spazio disponibile in tutti i dispositivi di archiviazione.

  • Fare clic sulla scheda Disco e quindi fare clic sulla barra del titolo di Archiviazione per espandere la tabella. Nella colonna Spazio disponibile verrà visualizzata la quantità di spazio disponibile in megabyte (MB) per ogni disco fisico del sistema.
Per visualizzare la quantità di memoria disponibile per i programmi

  1. Fare clic sulla scheda Memoria.

  2. In Memoria fisica controllare il valore indicato per Disponibile. La memoria disponibile è la combinazione totale di memoria standby e memoria libera. La memoria libera include la memoria assegnata alle pagine azzerate.

Ulteriori riferimenti

  • Panoramica di Monitoraggio risorse di Windows

  • Filtrare i dati di Monitoraggio risorse

  • Utilizzare Monitoraggio risorse per controllare processi e servizi

  • Utilizzare Monitoraggio risorse per risolvere i problemi relativi ad applicazioni che non rispondono