Server Manager

Windows Server® 2008 R2 semplifica la gestione e la protezione di più ruoli del server in un'organizzazione grazie alla console di Server Manager. Server Manager in Windows Server 2008 R2 consente infatti di gestire le informazioni di sistema e di identità di un server, di visualizzare lo stato di un server, di individuare i problemi relativi alla configurazione dei ruoli del server e di gestire tutti i ruoli installati nel server in modo centralizzato.

Come semplificare l'amministrazione del server tramite Server Manager

Server Manager consente di amministrare il server in modo più efficiente. Gli amministratori possono infatti utilizzare un unico strumento per eseguire le operazioni seguenti:

  • Visualizzare e modificare le funzionalità e i ruoli del server installati nel server.

  • Eseguire attività di gestione associate al ciclo di vita operativo del server, ad esempio l'avvio o l'arresto di servizi e la gestione di account utente locali.

  • Eseguire attività di gestione associate al ciclo di vita operativo dei ruoli installati nel server, tra cui l'analisi di determinati ruoli per verificarne la conformità alle procedure consigliate

  • Determinare lo stato del server, identificare eventi critici, nonché analizzare e risolvere problemi o errori di configurazione.

In questa sezione

Ruoli, servizi ruolo e funzionalità

Aggiungere ruoli del server e funzionalità

Rimuovere ruoli del server e funzionalità

Finestra principale di Server Manager

Home page relative ai ruoli

Strumenti da riga di comando di Server Manager

Gestione remota tramite Server Manager

Funzionalità di accessibilità in Server Manager


Ruoli, servizi ruolo e funzionalità

In Windows Server® 2008 R2 Server Manager sostituisce console di gestione precedenti quali Configurazione server e Amministrazione server. Tramite Server Manager è possibile preparare il server per la distribuzione installando pacchetti software logici noti come ruoli, servizi ruolo e funzionalità.

In questo argomento vengono fornite le definizioni di ruolo, servizio ruolo e funzionalità e viene illustrata l'integrazione di tali elementi nell'organizzazione.

Che cosa sono i ruoli del server, i servizi ruolo e le funzionalità?

In questa sezione viene fornita una definizione dei termini role, role service e feature così come vengono utilizzati in Windows Server 2008 R2.

Ruoli

Un ruolo del server è un insieme di programmi software che, se installati e configurati correttamente, consentono a un computer di eseguire una funzione specifica per più utenti o altri computer di una rete. I ruoli hanno in genere le caratteristiche seguenti.

  • Descrivono la funzione, lo scopo o l'utilizzo principale di un computer. Un determinato computer può ad esempio essere dedicato a un unico ruolo diffusamente utilizzato all'interno dell'organizzazione o svolgere più ruoli utilizzati in modo meno esteso nell'organizzazione.

  • I ruoli consentono agli utenti di un'organizzazione di accedere alle risorse gestite da altri computer, ad esempio siti Web, stampanti o file archiviati in altri computer.

  • Un ruolo include in genere un database proprio, in grado di accodare le richieste degli utenti o dei computer oppure di registrare informazioni sugli utenti e i computer di rete correlati a tale ruolo. Servizi dei domini Active Directory include ad esempio un database per l'archiviazione dei nomi e delle relazioni gerarchiche di tutti i computer di una rete.

  • Dopo essere stati installati e configurati in modo appropriato, i ruoli funzionano automaticamente, consentendo ai computer in cui sono installati di eseguire le attività previste con un intervento minimo da parte degli utenti.

Servizi ruolo

I servizi ruolo sono programmi software che offrono la funzionalità di un ruolo. Quando si installa un ruolo, è possibile scegliere quali servizi ruolo esso fornirà agli altri utenti e computer dell'organizzazione. Alcuni ruoli, ad esempio Server DNS, hanno un'unica funzione e non dispongono pertanto di servizi ruolo. Altri ruoli, come ad esempio Servizi Desktop remoto, dispongono invece di numerosi servizi ruolo installabili in base alle esigenze dell'organizzazione in termini di attività da postazioni remote.

Un ruolo può essere considerato come un raggruppamento di servizi ruolo complementari strettamente correlati. L'installazione del ruolo significa nella maggior parte dei casi l'installazione di uno o più dei relativi servizi ruolo.

Funzionalità

Le funzionalità sono programmi software che possono supportare o potenziare la funzionalità di uno o più ruoli, pur non facendone direttamente parte, oppure estendere la funzionalità dell'intero server, indipendentemente dai ruoli installati. La funzionalità Clustering di failover, ad esempio, potenzia la funzionalità di altri ruoli quali Servizi file e Server DHCP, consentendone l'aggiunta a cluster di server al fine di ottenere una maggiore ridondanza e un miglioramento delle prestazioni. Un'altra funzionalità, Client Telnet, consente di comunicare da postazione remota con un server Telnet tramite una connessione di rete, migliorando le possibilità di comunicazione del server.


Dipendenze di ruoli, servizi ruolo e funzionalità in Server Manager

In questo argomento vengono identificate le dipendenze di ruoli, ruoli server e funzionalità del server da altri ruoli, ruoli server e funzionalità in Windows Server® 2008 R2.

Dipendenze in Server Manager

Quando si installano i ruoli e si prepara la distribuzione nel server, Server Manager richiede di installare eventuali altri ruoli, ruoli server o funzionalità necessari per un ruolo da installare. Molti ruoli, ad esempio Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD), richiedono l'esecuzione di Web Server (IIS).

Per installare ed eseguire un programma, è necessario che siano installati anche tutti i programmi da cui esso dipende. Alcuni sono semplicemente elementi figlio del ruolo, servizio ruolo o funzionalità dipendente. Funzionalità di .NET Framework 3.5.1 rappresenta ad esempio la funzionalità padre, e Attivazione di Windows Communication Foundation (WCF) una sua funzionalità secondaria.

Analogamente, se si desidera rimuovere ruoli, servizi ruolo o funzionalità dal computer, tramite messaggi di Server Manager viene indicato se il software che si sta rimuovendo è necessario per altri programmi. Se ad esempio si desidera rimuovere Web Server (IIS), verrà visualizzato un avviso di Server Manager qualora nel computer rimangano altri ruoli che dipendono da Web Server (IIS). Questa complessa disposizione di dipendenze viene gestita da Server Manager e impedisce la rimozione accidentale di software necessario al server per l'esecuzione delle relative attività assegnate. Non è necessario che gli utenti conoscano i software da cui dipendono i ruoli che desiderano installare.

Visualizzare le dipendenze di ruoli, servizi ruolo e funzionalità utilizzando Windows PowerShell

Nella procedura in questa sezione viene descritto come utilizzare il cmdlet Add-WindowsFeature Server Manager in una sessione di Windows PowerShell per visualizzare il software necessario per ruoli, ruoli server o funzionalità disponibili in Windows Server 2008 R2. Utilizzando il parametro -whatIf, è possibile visualizzare le dipendenze software senza eseguire un'installazione effettiva.

Nota

Per i cmdlet di Windows PowerShell non viene fatta distinzione tra maiuscole e minuscole.

Per visualizzare le dipendenze di ruoli, servizi ruolo e funzionalità

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Digitare il comando seguente per caricare il modulo Server Manager e quindi premere INVIO.

    Import-Module ServerManager

  3. Se non si conosce il nome del comando per il ruolo, servizio ruolo o funzionalità per cui si desidera visualizzare le dipendenze, digitare il comando seguente e quindi premere INVIO. In caso contrario, continuare con il passaggio successivo.

    Get-WindowsFeature

    I nomi dei comandi per ruoli, ruoli server e funzionalità sono visualizzati nella colonna Nome dei risultati.

  4. Digitare il comando seguente e quindi premere INVIO per eseguire il cmdlet Add-WindowsFeature in modalità -whatIf.

    Add-WindowsFeature name -whatIf

    In modalità -whatIf, l'installazione non viene eseguita ma ruoli, ruoli server o funzionalità da cui dipende il ruolo, servizio ruolo o funzionalità specificato vengono visualizzati come output.

    È possibile visualizzare le dipendenze per più ruoli, ruoli server e funzionalità separando i nomi dei comandi di ruoli, ruoli server e funzionalità con virgole, come illustrato nell'esempio seguente.

    Add-WindowsFeature Application-Server,Hyper-V -whatIf

    I ruoli, ruoli server e funzionalità da cui dipendono le funzionalità specificate per l'esecuzione sono visualizzati nei risultati del cmdlet.

Vedere anche

  • Ruoli, servizi ruolo e funzionalità


Aggiungere ruoli del server e funzionalità

Windows Server® 2008 R2 semplifica la gestione e la protezione di più ruoli del server in un'organizzazione grazie alla console di Server Manager. Server Manager in Windows Server 2008 R2 consente infatti di gestire le informazioni di sistema e di identità di un server, di visualizzare lo stato di un server, di individuare i problemi relativi alla configurazione dei ruoli del server e di gestire tutti i ruoli installati nel server in modo centralizzato.

Come semplificare l'amministrazione del server tramite Server Manager

Server Manager consente di amministrare il server in modo più efficiente. Gli amministratori possono infatti utilizzare un unico strumento per eseguire le operazioni seguenti:

  • Visualizzare e modificare le funzionalità e i ruoli del server installati nel server.

  • Eseguire attività di gestione associate al ciclo di vita operativo del server, ad esempio l'avvio o l'arresto di servizi e la gestione di account utente locali.

  • Eseguire attività di gestione associate al ciclo di vita operativo dei ruoli installati nel server, tra cui l'analisi dei ruoli per verificarne la conformità alle procedure consigliate.

  • Determinare lo stato del server, identificare eventi critici, nonché analizzare e risolvere problemi o errori di configurazione.

Aggiunta guidata ruoli

L'Aggiunta guidata ruoli consente di semplificare la modalità di installazione dei ruoli nel server, nonché di installare più ruoli contemporaneamente. Nelle versioni precedenti del sistema operativo Windows gli amministratori devono eseguire più volte Installazione componenti di Windows per installare tutti i ruoli, i servizi ruolo e le funzionalità necessari in un server. Server Manager sostituisce Installazione componenti di Windows e consente di completare la configurazione del server tramite un'unica sessione dell'Aggiunta guidata ruoli.

L'Aggiunta guidata ruoli consente di verificare che insieme a ogni ruolo selezionato nella procedura guidata vengano installati anche tutti i componenti software necessari per tale ruolo. Se necessario, verrà richiesto all'utente di approvare l'installazione di altri ruoli, servizi ruolo o componenti software necessari per i ruoli selezionati.

Durante il processo di installazione della maggior parte dei ruoli e servizi ruolo disponibili, all'utente viene richiesto di prendere decisioni che determinano la modalità di utilizzo del ruolo all'interno dell'organizzazione. Active Directory® Federation Services (ADFS) richiede, ad esempio, l'installazione di un certificato, mentre Domain Name System (DNS) richiede di specificare un nome di dominio completo (FQDN).

Prima di installare un ruolo nel server, è consigliabile leggere la documentazione specifica relativa a pianificazione, distribuzione e funzionamento di un ruolo, disponibile in TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkID=122006).

Come aggiungere ruoli e funzionalità al server

In Windows Server 2008 R2 è possibile aggiungere ruoli o funzionalità al server utilizzando una delle tre procedure seguenti.

  • Per aggiungere ruoli o funzionalità utilizzando l'interfaccia di Windows

  • Per aggiungere ruoli o funzionalità utilizzando Windows PowerShell

  • Per aggiungere ruoli o funzionalità utilizzando una riga di comando

Per aggiungere ruoli o funzionalità utilizzando l'interfaccia di Windows

  • Nell'area Riepilogo ruoli o Riepilogo funzionalità della finestra principale di Server Manager fare clic su Aggiungi ruoli o su Aggiungi funzionalità, in base al software che si desidera installare.

    oppure

    Nell'area Personalizzazione del server della finestra Attività di configurazione iniziale fare clic su Aggiungi ruoli o su Aggiungi funzionalità.

    Note
    • La finestra Attività di configurazione iniziale viene visualizzata per impostazione predefinita ogni volta che un membro del gruppo Administrators effettua l'accesso al computer.
    • Server Manager si apre quando viene chiusa la finestra Attività di configurazione iniziale. È inoltre possibile aprire Server Manager utilizzando i collegamenti disponibili nel menu Start, sulla barra delle applicazioni di Windows o in Strumenti di amministrazione.
Per aggiungere ruoli o funzionalità utilizzando Windows PowerShell

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Per poter utilizzare i cmdlet di Server Manager, caricare il modulo Server Manager nella sessione di Windows PowerShell. Digitare il comando seguente e quindi premere INVIO.

    Import-Module Servermanager

    Nota

    Per i cmdlet di Windows PowerShell non viene fatta distinzione tra maiuscole e minuscole.

  3. Se non si conosce il nome di comando del ruolo, servizio ruolo o funzionalità che si desidera installare, digitare il comando seguente e quindi premere INVIO per visualizzare un elenco di tutti i nomi di comando nella colonna Nome. Il nome di comando è necessario per il passaggio successivo.

    Get-WindowsFeature

  4. Digitare il comando seguente, dove name rappresenta il nome di comando del ruolo, servizio ruolo o funzionalità ottenuto nel passaggio precedente, e quindi premere INVIO per installare un ruolo o una funzionalità. Il parametro -restart consente di riavviare il computer automaticamente al termine dell'operazione di installazione, qualora il riavvio sia richiesto dal ruolo o dalla funzionalità.

    Add-WindowsFeature name -restart

    È possibile installare più ruoli, ruoli server e funzionalità separando i nomi di comando con virgole, come illustrato nell'esempio seguente.

    Add-WindowsFeature Application-Server,Hyper-V,WAS

Nota

Per informazioni dettagliate sugli altri parametri che è possibile utilizzare con il cmdlet Add-WindowsFeature, immettere Get-Help Add-WindowsFeature -full oppure vedere Panoramica dei comandi di Server Manager.

Per aggiungere ruoli o funzionalità utilizzando una riga di comando

  1. Aprire una finestra del prompt dei comandi con diritti utente elevati. Per aprire una finestra del prompt dei comandi con privilegi elevati, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, quindi fare clic con il pulsante destro del mouse su Prompt dei comandi e infine scegliere Esegui come amministratore.

  2. Se non si conosce il nome di comando del ruolo, servizio ruolo o funzionalità che si desidera installare, digitare il comando seguente e quindi premere INVIO per visualizzare un elenco di tutti i ruoli, ruoli server e funzionalità disponibili nel computer per l'installazione.

    ServerManagerCmd.exe -query

    Nota

    Per i comandi nel prompt dei comandi di Windows non viene fatta distinzione tra maiuscole e minuscole.

  3. Digitare il comando seguente, dove name rappresenta il nome di comando del ruolo, servizio ruolo o funzionalità che si desidera installare e quindi premere INVIO.

    ServerManagerCmd.exe -install name -restart

    È possibile installare più ruoli, ruoli server e funzionalità separando i nomi di comando con virgole, come illustrato nell'esempio seguente.

    ServerManagerCmd.exe -install Application-Server Hyper-V WAS -restart

  4. Al termine dell'installazione, verificare che i ruoli, ruoli server e funzionalità siano stati installati digitando il comando seguente e quindi premendo INVIO. I ruoli, ruoli server e funzionalità installati sono evidenziati nei risultati della query.

    ServerManagerCmd.exe -query

Ruoli e funzionalità disponibili per l'installazione

I ruoli e le funzionalità seguenti sono disponibili per l'installazione in computer che eseguono Windows Server 2008 R2.

Nota

I ruoli e le funzionalità descritti in questo argomento potrebbero essere stati aggiornati dopo la pubblicazione di questo contenuto. Per verificare la presenza di aggiornamenti o ottenere ulteriori informazioni sulla gestione dei ruoli e delle funzionalità descritti in questo argomento, vedere TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=122006). Alcuni ruoli e funzionalità potrebbero non essere disponibili in edizioni speciali di Windows Server 2008 R2.

  • Ruoli

  • Funzionalità

Ruoli

Nome ruolo Descrizione

Servizi certificati Active Directory

Servizi certificati Active Directory offre servizi personalizzabili per il rilascio e la gestione di certificati in sistemi di sicurezza software che utilizzano tecnologie a chiave pubblica. È possibile utilizzare Servizi certificati Active Directory per creare una o più Autorità di certificazione (CA) con il compito di ricevere le richieste di certificati, verificare le informazioni contenute nelle richieste e l'identità del richiedente, rilasciare certificati, revocare certificati e pubblicare i dati di revoca dei certificati.

Le applicazioni supportate da Servizi certificati Active Directory includono le estensioni S/MIME (Secure/Multipurpose Internet Mail Extensions), le reti wireless sicure, le reti private virtuali (VPN, Virtual Private Network), IPSec (Internet Protocol Security), EFS (Encrypting File System), Accesso smart card, SSL/TLS (Secure Socket Layer/Transport Layer Security) e le firme digitali.

Servizi dei domini Active Directory

Servizi dei domini Active Directory (AD DS) archivia le informazioni su utenti, computer e altri dispositivi di rete. AD DS aiuta gli amministratori a gestire in modo sicuro le informazioni e semplifica la condivisione delle risorse e la collaborazione tra utenti. AD DS è inoltre necessario per le applicazioni abilitate all'uso di directory, ad esempio Microsoft Exchange Server, nonché per altre tecnologie di Windows Server come Criteri di gruppo.

Active Directory Federation Services

Active Directory Federation Services (ADFS) offre tecnologie Web Single Sign-On (SSO) per autenticare un utente per più applicazioni Web che utilizzano un unico account utente. Ciò avviene mediante la federazione, o condivisione, sicura delle autorizzazioni e delle identità utente, sotto forma di attestazioni digitali, tra organizzazioni partner.

Active Directory Lightweight Directory Services

Le organizzazioni con applicazioni che richiedono una directory per l'archiviazione dei dati delle applicazioni possono utilizzare Active Directory Lightweight Directory Services (AD LDS) come archivio dati. AD LDS viene eseguito come servizio non di sistema operativo. Per questo motivo, non è necessaria la distribuzione in un controller di dominio. L'esecuzione come servizio non di sistema operativo consente l'esecuzione simultanea di più istanze di AD LDS in un solo server. Ogni istanza può essere configurata in modo indipendente per più applicazioni.

Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD)

Active Directory Rights Management Services è una tecnologia per la protezione delle informazioni che interagisce con le applicazioni abilitate per RMS di AD per contribuire a proteggere le informazioni digitali dall'utilizzo non autorizzato. I proprietari dei contenuti possono definire esattamente come le informazioni potranno essere utilizzate dal destinatario, ad esempio chi potrà aprire, modificare, stampare o inoltrare le informazioni oppure eseguire altre operazioni su di esse. Le organizzazioni possono creare modelli di diritti di utilizzo personalizzati, ad esempio "Riservato - Sola lettura" che possono essere applicati direttamente alle informazioni, quali relazioni finanziarie, specifiche di prodotto, dati di clienti e messaggi di posta elettronica.

Server applicazioni

Il server applicazioni offre una soluzione completa per ospitare e gestire applicazioni aziendali distribuite ad alte prestazioni. Servizi integrati come .NET Framework, Supporto server Web, Accodamento messaggi, COM+, Windows Communication Foundation e il supporto per Clustering di failover consentono di incrementare la produttività per l'intera durata del ciclo di vita dell'applicazione, dalle fasi di progettazione e sviluppo fino alla distribuzione e all'utilizzo.

Server DHCP (Dynamic Host Configuration Protocol)

DHCP (Dynamic Host Configuration Protocol) consente ai server di assegnare indirizzi IP, o eseguirne il lease, a computer e altri dispositivi abilitati come client DHCP. Con la distribuzione di server DHCP in rete, i computer e gli altri dispositivi di rete basati su TCP/IP potranno usufruire automaticamente di indirizzi IP validi e dei parametri di configurazione aggiuntivi, o opzioni DHCP, che consentono la connessione ad altre risorse di rete, ad esempio server DNS, server WINS e router.

Server DNS

DNS (Domain Name System) rappresenta un metodo standard per associare nomi a indirizzi Internet numerici e consentire agli utenti di fare riferimento ai computer di rete tramite nomi facili da ricordare anziché tramite una lunga serie di numeri. I servizi DNS di Windows possono essere integrati con i servizi DHCP, eliminando così la necessità di aggiungere record DNS quando si aggiungono computer alla rete.

Server fax

Server fax consente di inviare e ricevere fax, nonché di gestire risorse fax, quali processi, impostazioni, rapporti e dispositivi fax, disponibili nel computer o in rete.

Servizi file

Servizi file offre tecnologie per la gestione degli archivi, la replica dei file, la gestione di spazi dei nomi distribuiti, la ricerca rapida dei file e la semplificazione dell'accesso client ai file, come nel caso di computer client basati su UNIX.

Hyper-V™

Hyper-V offre i servizi da utilizzare per creare e gestire ambienti di elaborazione virtuali le relative risorse. I computer virtuali funzionano in un sistema operativo isolato. In questo modo, è possibile eseguire più sistemi operativi contemporaneamente. È possibile utilizzare un ambiente di elaborazione virtualizzato per migliorare l'efficienza delle risorse di elaborazione con un numero maggiore di risorse hardware.

Servizi di accesso e criteri di rete

Servizi di accesso e criteri di rete offre diversi metodi per fornire agli utenti la connettività di rete locale e remota, connettere segmenti di rete e consentire agli amministratori di rete di gestire in modo centralizzato l'accesso alla rete e i criteri di integrità dei client. Con Servizi di accesso e criteri di rete è possibile distribuire server VPN, server di connessione remota, router e accesso wireless protetto 802.11. È inoltre possibile distribuire proxy e server RADIUS, nonché utilizzare Connection Manager Administration Kit per creare profili di accesso remoto che consentano ai computer client di connettersi alla rete.

Servizi di stampa e digitalizzazione

Servizi di stampa e digitalizzazione consente di centralizzare le attività di gestione del server di stampa e delle stampanti di rete. Con questo ruolo è inoltre possibile ricevere documenti digitalizzati da scanner di rete e inoltrare i documenti a una risorsa di rete condivisa, un sito di Windows SharePoint Services o indirizzi di posta elettronica.

Servizi Desktop remoto

Servizi Desktop remoto offre tecnologie che consentono agli utenti di accedere ai programmi basati su Windows installati in un server desktop remoto oppure di accedere al desktop di Windows praticamente da qualsiasi computer. Gli utenti possono connettersi a un server desktop remoto per eseguire programmi e utilizzare le risorse di rete disponibili in tale server.

Web Server (IIS)

Il ruolo Web Server (IIS) in Windows Server 2008 R2 consente di condividere le informazioni con altri utenti in Internet, in una rete Intranet o in una rete Extranet. Windows Server 2008 R2 include IIS 7.5, una piattaforma Web unificata che integra IIS, ASP.NET e Windows Communication Foundation.

Servizi di distribuzione Windows

È possibile utilizzare Servizi di distribuzione Windows per installare e configurare da postazione remota sistemi operativi Windows in computer con ROM di avvio PXE (Pre-Boot eXecution Environment). Il sovraccarico amministrativo è minore grazie all'implementazione di WdsMgmt, uno snap-in di Microsoft Management Console (MMC) in grado di gestire tutti gli aspetti di Servizi di distribuzione Windows. Servizi di distribuzione Windows offre agli utenti finali un ambiente analogo a quello di Installazione di Windows.

Windows Server Update Services

Windows Server Update Services consente agli amministratori di rete di specificare gli aggiornamenti Microsoft da installare, di creare gruppi distinti di computer per set diversi di aggiornamenti e di ottenere rapporti sui livelli di conformità dei computer e sugli aggiornamenti da installare.

Funzionalità

Funzionalità | Descrizione
.NET Framework 3.5.1 | .NET Framework 3.5.1 estende le funzionalità aggiunte in .NET Framework 3.0, ad esempio con miglioramenti a Windows Workflow Foundation (WF), Windows Communication Foundation (WCF), Windows Presentation Foundation (WPF) e Windows CardSpace.
BITS (Servizio trasferimento intelligente in background) | BITS (Servizio trasferimento intelligente in background) consente di eseguire il trasferimento asincrono di file in primo piano o in background, regolare la velocità dei trasferimenti per mantenere la velocità di risposta di altre applicazioni di rete e riprendere automaticamente il trasferimento dei file dopo la disconnessione della rete e il riavvio del computer.
Crittografia unità BitLocker | Crittografia unità BitLocker consente di proteggere i dati presenti nel computer anche in caso di smarrimento, furto o rimozione inappropriata delle autorizzazioni, tramite la crittografia dell'intero volume e il controllo dell'integrità dei componenti di avvio. I dati vengono decrittografati esclusivamente se è possibile verificare tali componenti e se l'unità crittografata si trova nel computer originale. Per il controllo dell'integrità è necessario un Trusted Platform Module (TPM) compatibile.
BranchCache | BranchCache, disponibile sia in Windows Server 2008 R2 che in Windows 7, consente ai computer client di una succursale di recuperare il contenuto in modo sicuro e localmente, anziché da server dell'ufficio centrale. Poiché le succursali sono in genere connesse con collegamenti WAN più lenti, BranchCache consente la riduzione del traffico WAN e e il miglioramento della velocità di risposta delle applicazioni nel computer client.
Connection Manager Administration Kit | Connection Manager Administration Kit (CMAK) consente di generare profili di Connection Manager.
Esperienza desktop | Esperienza desktop include funzionalità di Windows® 7 quali Windows Media Player, i temi del desktop e la gestione delle fotografie. Tramite Esperienza desktop non vengono abilitate per impostazione predefinita le funzionalità di Windows 7, ma è necessario abilitarle manualmente.
Console di gestione Accesso diretto | La console di gestione Accesso diretto consente di monitorare e impostare l'accesso diretto.
Clustering di failover | Clustering di failover consente a più server di interagire per garantire un'elevata disponibilità dei servizi e delle applicazioni. Questa funzionalità viene spesso utilizzata per i servizi di file e di stampa, nonché per le applicazioni di database e di posta.
Gestione Criteri di gruppo | Gestione Criteri di gruppo consente di semplificare la distribuzione, la gestione e la risoluzione dei problemi relativi alle implementazioni di Criteri di gruppo. Lo strumento standard è Console Gestione Criteri di gruppo, uno snap-in di Microsoft Management Console (MMC) configurabile tramite script che consente di gestire tutti i Criteri di gruppo di un'organizzazione tramite un singolo strumento di amministrazione.
Servizi di riconoscimento della grafia | Servizi di riconoscimento della grafia, una nuova funzionalità di Windows Server 2008 R2, offre supporto per il riconoscimento della grafia in più lingue, nonché per l'utilizzo di una penna o di uno stilo con un'interfaccia di elaborazione sensibile alla pressione, come un Tablet PC.
Client di stampa Internet | Client di stampa Internet consente agli utenti di utilizzare il protocollo IPP (Internet Printing Protocol) per connettersi alle stampanti attraverso la rete locale o Internet e utilizzarle per la stampa. Per utilizzare Client di stampa Internet e il protocollo IPP per connettersi alla stampante condivisa è possibile utilizzare un Web browser, se nel server di stampa è installato il ruolo Stampa Internet, oppure l'Installazione guidata stampante di rete.
Internet Storage Name Server | Internet Storage Name Server (iSNS) fornisce servizi di individuazione per reti di archiviazione (SAN) iSCSI. Il protocollo iSNS elabora le richieste di registrazione o annullamento della registrazione e le query inviate dai client iSNS.
Monitor porta LPR | Monitor porta LPR (Line Printer Remote) consente agli utenti in grado di accedere a computer UNIX di stampare tramite dispositivi collegati a tali computer.
Accodamento messaggi | Accodamento messaggi gestisce i messaggi scambiati tra più applicazioni garantendo il recapito dei messaggi, un routing efficiente, sicurezza e messaggistica basata sulla priorità. Accodamento messaggi consente inoltre il recapito di messaggi tra applicazioni che vengono eseguite in sistemi operativi diversi, utilizzano infrastrutture di rete diverse, sono temporaneamente offline o vengono eseguite in momenti diversi.
Multipath I/O | Utilizzato insieme a DSM (Device Specific Module, Modulo specifico dispositivo) Microsoft o di terze parti, Multipath I/O (MPIO) offre il supporto necessario per utilizzare più percorsi dati per un determinato dispositivo di archiviazione in Windows.
Bilanciamento carico di rete | Bilanciamento carico di rete distribuisce il traffico tra più server, utilizzando il protocollo di rete TCP/IP. È utile soprattutto per garantire la scalabilità delle applicazioni senza stato, ad esempio un server Web che esegue IIS, attraverso l'aggiunta di ulteriori server a mano a mano che il carico aumenta.
Peer Name Resolution Protocol | Peer Name Resolution Protocol (PNRP) consente alle applicazioni di effettuare la registrazione e risolvere i nomi nel computer in uso in modo che altri computer possano comunicare con tali applicazioni.
Servizio audio/video Windows di qualità (qWave) | Servizio audio/video Windows di qualità (qWave) è una piattaforma di rete per applicazioni che utilizzano il flusso di dati audio/video (AV) in reti domestiche IP. Tale piattaforma migliora le prestazioni e l'affidabilità del flusso AV garantendo la qualità del servizio (QoS, Quality of Service) in rete per le applicazioni AV. Offre meccanismi per il controllo dell'ammissione, il monitoraggio e l'imposizione in fase di esecuzione, il feedback dell'applicazione, nonché l'impostazione della priorità del traffico. Nelle piattaforme Windows Server qWave offre solo servizi di velocità di flusso e impostazione delle priorità.
Assistenza remota | Assistenza remota consente all'utente o al personale di supporto tecnico di offrire assistenza a utenti con domande o problemi relativi al computer. Assistenza remota consente di visualizzare il desktop dell'utente e di condividerne il controllo al fine di identificare e risolvere i problemi. Gli utenti possono inoltre richiedere assistenza ad amici o colleghi.
RDC (Remote Differential Compression) | La funzionalità RDC (Remote Differential Compression) è un insieme di API utilizzate dalle applicazioni per determinare se un insieme di file è stato modificato e, in caso affermativo, per rilevare quali sezioni dei file contengono le modifiche.
Strumenti di amministrazione server remoto | Strumenti di amministrazione server remoto consente la gestione remota di Windows Server 2008 e Windows Server 2008 R2 da un computer che esegue Windows Server 2008 R2, permettendo l'esecuzione di alcuni snap-in e strumenti di gestione per ruoli, ruoli server e funzionalità in un computer remoto.
Proxy RPC su HTTP | Proxy RPC su HTTP è un proxy utilizzato dagli oggetti che ricevono chiamate a procedure remote (RPC) tramite HTTP. Il proxy consente ai client di individuare tali oggetti anche se questi ultimi vengono spostati da un server all'altro o si trovano in aree distinte della rete, in genere per motivi di sicurezza.
Servizi per NFS (Network File System) | Servizi per NFS (Network File System) è un protocollo che agisce come file system distribuito, consentendo a un computer di accedere agevolmente a file in rete come se si trovassero in dischi locali. Questa funzionalità è disponibile per l'installazione solo in Windows Server 2008 R2 for Itanium-based Systems. Nelle altre versioni di Windows Server 2008 R2 Servizi per NFS è disponibile come servizio ruolo per il ruolo Servizi file.
Servizi TCP/IP semplificati | Servizi TCP/IP semplificati supporta i servizi TCP/IP seguenti: Character Generator, Daytime Discard, Echo e Quote of the Day. Servizi TCP/IP semplificati è disponibile per compatibilità con le versioni precedenti e deve essere installato solo se necessario.
Server SMTP | Il server SMTP supporta il trasferimento di messaggi di posta elettronica tra sistemi di posta elettronica.
Servizi SNMP | Simple Network Management Protocol (SNMP) è il protocollo standard Internet per lo scambio di informazioni di gestione tra applicazioni di console, ad esempio HP Openview, Novell NMS, IBM NetView o Sun Net Manager, ed entità gestite. Le entità gestite possono includere host, router, bridge e hub.
Gestione archivi SAN | Gestione archivi SAN consente di creare e gestire numeri di unità logica (LUN) nei sottosistemi delle unità disco Fibre Channel e iSCSI che supportano il Servizio dischi virtuali (VDS) nella rete SAN.
Subsystem for UNIX-based Applications | Subsystem for UNIX-based Applications (SUA), insieme a un pacchetto di utilità di supporto disponibile per il download nel sito Web Microsoft (http://go.microsoft.com/fwlink/?LinkID=139521), consente di eseguire programmi basati su UNIX, nonché di compilare ed eseguire applicazioni basate su UNIX personalizzate in ambiente Windows.
Client Telnet | Client Telnet si basa sul protocollo Telnet per connettersi a un server Telnet remoto ed eseguire le applicazioni in tale server.
Server Telnet | Server Telnet consente agli utenti remoti, ad esempio quelli che utilizzano sistemi operativi basati su UNIX, di svolgere attività di amministrazione dalla riga di comando ed eseguire programmi utilizzando un client Telnet.
Protocollo TFTP (Trivial File Transfer Protocol) | Client TFTP (Trivial File Transfer Protocol) consente di leggere o scrivere file in un server TFTP remoto. TFTP viene utilizzato principalmente da sistemi o dispositivi incorporati che recuperano informazioni di configurazione, firmware o un'immagine di sistema durante il processo di avvio da un server TFTP.
Windows Biometric Framework | Windows Biometric Framework (WBF) consente l'utilizzo di dispositivi per impronte digitali per identificare e verificare le identità e accedere a Windows. WBF include funzionalità secondarie necessarie per l'utilizzo di dispositivi per impronte digitali.
Database interno di Windows | Database interno di Windows è un archivio dati relazionale che può essere utilizzato solo da ruoli e funzionalità di Windows, ad esempio RMS di AD, Windows Server Update Services e Gestione risorse di sistema Windows.
Servizio Attivazione processo Windows | Il servizio Attivazione processo Windows consente di generalizzare il modello di processo di IIS, eliminando la dipendenza da HTTP. Tutte le funzionalità di IIS che in precedenza erano disponibili solo per le applicazioni HTTP sono ora disponibili per le applicazioni che ospitano i servizi WCF (Windows Communication Foundation) tramite protocolli non HTTP. In IIS 7.5 il servizio Attivazione processo Windows viene inoltre utilizzato per l'attivazione basata su messaggi su HTTP.
Funzionalità di Windows Server Backup | Funzionalità di Windows Server Backup consente di eseguire il backup e il ripristino del sistema operativo, delle applicazioni e dei dati. È possibile pianificare i backup in modo che vengano eseguiti una o più volte al giorno, nonché proteggere l'intero server o volumi specifici.
Strumenti di migrazione per Windows Server | Strumenti di migrazione per Windows Server consente agli amministratori di eseguire la migrazione di alcuni ruoli del server, funzionalità, impostazioni del sistema operativo, condivisioni e altri dati dai computer che eseguono determinate edizioni di Windows Server 2003, Windows Server 2008 o Windows Server 2008 R2 nei computer che eseguono Windows Server 2008 R2. Per ulteriori informazioni su Strumenti di migrazione per Windows Server e sulla migrazione di ruoli, funzionalità e altri dati in Windows Server 2008 R2, vedere il portale sulla migrazione in Windows Server (http://go.microsoft.com/fwlink/?LinkID=128554).
Gestione risorse di sistema Windows | Gestione risorse di sistema Windows è uno strumento di amministrazione di Windows Server che consente di controllare la modalità di allocazione delle risorse di CPU e di memoria. Attraverso la gestione dell'allocazione delle risorse è possibile migliorare le prestazioni del sistema e limitare le possibili interferenze tra applicazioni, servizi o processi, che determinerebbero una riduzione dell'efficienza del server e della velocità di risposta del sistema.
Estensione IIS di Gestione remota Windows | Estensione IIS di Gestione remota Windows consente a un server di ricevere una richiesta di gestione da un computer client tramite il protocollo WS-Management. Gestione remota Windows è l'implementazione Microsoft del protocollo WS-Management. In questo modo, è possibile garantire comunicazioni sicure tra computer locali e remoti utilizzando servizi basati sul Web.
Server WINS (Windows Internet Name Service) | Server Windows Internet Name Service (WINS) fornisce un database distribuito per la registrazione e il recupero dei mapping dinamici dei nomi NetBIOS per i computer e i gruppi utilizzati nella rete. WINS esegue il mapping dei nomi NetBIOS a indirizzi IP e risolve i problemi derivanti dalla risoluzione dei nomi NetBIOS negli ambienti con routing.
Database interno di Windows | Database interno di Windows è un archivio dati relazionale che può essere utilizzato solo da ruoli e funzionalità di Windows, ad esempio Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD), Windows Server Update Services e Gestione risorse di sistema Windows.
Windows PowerShell Integrated Scripting Environment (ISE) | Windows PowerShell ISE è un'applicazione host grafica per Windows PowerShell. Windows PowerShell ISE consente di eseguire comandi, nonché scrivere, modificare, eseguire, testare ed effettuare il debug di script in un ambiente in cui la sintassi viene visualizzata tramite colori ed è disponibile il supporto per Unicode.
IFilter TIFF di Windows | IFilter TIFF (Tagged Image File Format) di Windows utilizza riconoscimento ottico dei caratteri (OCR) per consentire agli utenti di eseguire ricerche in documenti TIFF in base a testo contenuto nelle immagini.
Servizio LAN wireless | Il servizio LAN wireless (WLAN) consente di configurare e avviare il servizio Configurazione automatica WLAN, indipendentemente dalla presenza di schede wireless nel computer. Il servizio Configurazione automatica WLAN consente di enumerare le schede wireless e gestire sia le connessioni che i profili wireless contenenti le impostazioni necessarie per configurare un client wireless per la connessione a una rete wireless.
XPS Viewer | Un documento XPS (XML Paper Specification) rappresenta un formato che è possibile utilizzare per visualizzare, salvare, condividere, firmare in modo digitale e proteggere il contenuto dei documenti. È possibile utilizzare XPS Viewer per visualizzare documenti XPS, nonché eseguire ricerche, impostare autorizzazioni e apporre una firma digitale per tali documenti.

Vedere anche

  • Panoramica dei comandi di Server Manager


Rimuovere ruoli del server e funzionalità

Gli strumenti di Windows Server® 2008 R2 consentono di rimuovere facilmente ruoli del server e funzionalità. È possibile rimuovere ruoli o funzionalità utilizzando la Rimozione guidata ruoli o la Rimozione guidata funzionalità, Windows PowerShell oppure una riga di comando.

Come rimuovere ruoli o funzionalità dal server

In Windows Server 2008 R2 è possibile rimuovere ruoli o funzionalità dal server utilizzando una delle tre procedure seguenti.

  • Per rimuovere ruoli o funzionalità utilizzando l'interfaccia di Windows

  • Per rimuovere ruoli o funzionalità utilizzando Windows PowerShell

  • Per rimuovere ruoli o funzionalità utilizzando una riga di comando

Per rimuovere ruoli o funzionalità utilizzando l'interfaccia di Windows

  • Nell'area Riepilogo ruoli o Riepilogo funzionalità della finestra principale di Server Manager fare clic su Rimuovi ruoli o su Rimuovi funzionalità, in base al software che si desidera rimuovere. Seguire le istruzioni indicate nella procedura guidata per procedere con la rimozione.
Per rimuovere ruoli o funzionalità utilizzando Windows PowerShell

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Per poter utilizzare i cmdlet di Server Manager, caricare il modulo Server Manager nella sessione di Windows PowerShell. Digitare il comando seguente e quindi premere INVIO.

    Import-Module Servermanager

    Nota

    Per i cmdlet di Windows PowerShell non viene fatta distinzione tra maiuscole e minuscole.

  3. Se non si conosce il nome di comando del ruolo, servizio ruolo o funzionalità che si desidera rimuovere, digitare il comando seguente e quindi premere INVIO per visualizzare un elenco di tutti i nomi di comando nella colonna Nome. Il nome di comando è necessario per il passaggio successivo.

    Get-WindowsFeature

  4. Digitare il comando seguente, dove name rappresenta il nome di comando del ruolo, servizio ruolo o funzionalità ottenuto nel passaggio precedente, e quindi premere INVIO per rimuovere un ruolo o una funzionalità. Il parametro -restart consente di riavviare il computer automaticamente al termine dell'operazione di rimozione, qualora il riavvio sia necessario.

    Remove-WindowsFeature name -restart

    È possibile rimuovere più ruoli, ruoli server e funzionalità separando i nomi di comando con virgole, come illustrato nell'esempio seguente.

    Remove-WindowsFeature Application-Server,Hyper-V,WAS

Nota

Per informazioni dettagliate sugli altri parametri che è possibile utilizzare con il cmdlet Remove-WindowsFeature, immettere Get-Help Remove-WindowsFeature -full oppure vedere Panoramica dei comandi di Server Manager.
Per rimuovere ruoli o funzionalità utilizzando una riga di comando

  1. Aprire una finestra del prompt dei comandi con diritti utente elevati. Per aprire una finestra del prompt dei comandi con privilegi elevati, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, quindi fare clic con il pulsante destro del mouse su Prompt dei comandi e infine scegliere Esegui come amministratore.

  2. Se non si conosce il nome di comando del ruolo, servizio ruolo o funzionalità che si desidera rimuovere, digitare il comando seguente e quindi premere INVIO per visualizzare un elenco di tutti i ruoli, ruoli server e funzionalità disponibili nel computer.

    ServerManagerCmd.exe -query

    Nota

    Per i comandi nel prompt dei comandi di Windows non viene fatta distinzione tra maiuscole e minuscole.

  3. Digitare il comando seguente, dove name rappresenta il nome di comando del ruolo, servizio ruolo o funzionalità che si desidera rimuovere e quindi premere INVIO. Il parametro -restart consente di riavviare il computer automaticamente al termine dell'operazione di rimozione, qualora il riavvio sia necessario.

    ServerManagerCmd.exe -remove name -restart

    È possibile rimuovere più ruoli, ruoli server e funzionalità separando i nomi di comando con spazi, come illustrato nell'esempio seguente.

    ServerManagerCmd.exe -install Application-Server Hyper-V WAS -restart

  4. Al termine della rimozione, verificare che i ruoli, ruoli server e funzionalità siano stati rimossi dal computer digitando il comando seguente e quindi premendo INVIO. I ruoli, ruoli server e funzionalità installati sono evidenziati nei risultati della query.

    ServerManagerCmd.exe -query

Rimozione guidata ruoli

La Rimozione guidata ruoli consente di semplificare il processo di rimozione dei ruoli dal server, nonché di rimuovere più ruoli contemporaneamente. Non è più necessario aprire più volte Installazione componenti di Windows per rimuovere più ruoli, servizi ruolo o funzionalità installati nel server. La Rimozione guidata ruoli consente di completare la configurazione del server in un'unica sessione.

Prima di rimuovere i ruoli, tramite la Rimozione guidata ruoli viene verificato che i componenti software necessari per i ruoli rimanenti non vengano rimossi accidentalmente. Se necessario, verrà richiesto all'utente di approvare la rimozione di altri ruoli, servizi ruolo o programmi software necessari per i ruoli che rimangono installati. In questo modo viene praticamente eliminato il rischio di rimozione di software da cui dipendono altri ruoli.

Vedere anche

  • Panoramica dei comandi di Server Manager


Finestra principale di Server Manager

La finestra principale di Server Manager consente di visualizzare uno snapshot dettagliato delle informazioni relative all'identità del server, delle opzioni di configurazione della sicurezza selezionate, nonché dei ruoli e delle funzionalità installati.

L'area Risorse e supporto della finestra principale di Server Manager contiene collegamenti che agevolano la connessione alla documentazione e ai download più aggiornati e consentono di partecipare ai programmi di feedback per migliorare le versioni future di Windows Server.

Area Riepilogo server

Nell'area Riepilogo server vengono visualizzati dettagli sul server che sono particolarmente utili durante la risoluzione dei problemi, ad esempio il nome e gli indirizzi di rete del computer e l'ID prodotto del sistema operativo in esecuzione nel computer.

Da quest'area è possibile attivare la copia di Windows, visualizzare e modificare le connessioni di rete, modificare le proprietà di sistema, nonché attivare e configurare Desktop remoto.

L'area Riepilogo server contiene le sottosezioni comprimibili seguenti:

  • Informazioni computer

  • Informazioni sicurezza

Informazioni computer

Nella tabella seguente vengono descritte le informazioni visualizzate nella sezione Informazioni computer.

Testo del campo | Descrizione dei dati
Nome completo computer: | Nome di dominio completo (FQDN) del server di destinazione.
Domino (o Gruppo di lavoro se il computer non appartiene a un dominio): | Suffisso DNS (Domain Name System) primario.
<nome connessione di rete 1>: | Indirizzo IP
<nome connessione di rete 2>: | Indirizzo IP
<nome connessione di rete 3>: | Indirizzo IP
Stato Desktop remoto | Indica se le connessioni Desktop remoto sono attivate o disattivate ovvero se i computer remoti che eseguono Desktop remoto possono connettersi a questo computer.
Gestione remota di Server Manager | Indica se altri computer che eseguono Windows Server 2008 R2 possono essere utilizzati per gestire questo computer tramite Server Manager.
ID prodotto (se attivato): | Indica lo stato di attivazione per la copia di Windows. Viene visualizzato Non attivato se l'amministratore non ha fornito il codice "Product Key" associato alla copia di Windows oppure se ha fornito un codice "Product Key" ma non ha ancora attivato Windows online o telefonicamente. Viene visualizzato Attivato insieme all'ID prodotto di Windows se l'amministratore ha fornito il codice "Product Key" corretto e ha attivato il sistema operativo. Per attivare Windows, fare clic su Attiva Windows nell'elenco Azioni sul lato destro dell'area Informazioni computer.

La casella di controllo Non visualizzare questa console all'accesso al sistema nella sezione Informazioni computer consente agli amministratori di impedire l'apertura automatica di Server Manager quando viene effettuato l'accesso al computer, qualora non sia necessario visualizzare Server Manager a ogni accesso. Questo comportamento può essere controllato anche tramite l'impostazione di Criteri di gruppo Criteri del computer locale/Configurazione computer/Modelli amministrativi/Sistema/Server Manager/Non visualizzare Server Manager automaticamente all'accesso.

Informazioni sicurezza

Nella tabella seguente vengono descritte le informazioni visualizzate nella sezione Informazioni sicurezza.

Testo del campo | Descrizione dei dati
Stato Windows Firewall | Indica se Windows Firewall è attivato nel server.
Stato Windows Update | Indica se il server è configurato per scaricare e installare automaticamente gli aggiornamenti software di Windows.
Ultima verifica disponibilità aggiornamenti | Visualizza il giorno e l'ora dell'ultima verifica della disponibilità degli aggiornamenti software eseguita dal server.
Ultimi aggiornamenti installati | Visualizza il giorno e l'ora dell'ultima installazione di aggiornamenti software automatici.
Sicurezza avanzata di Internet Explorer | Indica se la Sicurezza avanzata di Internet Explorer è attivata sia per i membri del gruppo Administrators che per altri utenti.

I comandi di questa sezione consentono di modificare le impostazioni di Windows Firewall, Aggiornamenti automatici Windows e Sicurezza avanzata di Internet Explorer. È inoltre possibile eseguire in Windows Update una ricerca di nuovi ruoli da scaricare e installare facendo clic su Controlla nuovi ruoli.

Dall'area Informazioni sicurezza è inoltre possibile avviare la Configurazione guidata impostazioni di sicurezza, che consente di creare un criterio di sicurezza applicabile a qualsiasi server della rete. Per ulteriori informazioni sull'esecuzione della Configurazione guidata impostazioni di sicurezza, consultare la documentazione della procedura guidata disponibile in TechCenter per Windows Server (http://go.microsoft.com/fwlink/?LinkId=91742).

Area Riepilogo ruoli

Nell'area Riepilogo ruoli della finestra principale di Server Manager viene visualizzato un elenco di tutti i ruoli installati nel computer. I nomi dei ruoli installati nel computer vengono visualizzati sotto forma di ipertesto. Se si fa clic sul nome di un ruolo, verrà aperta la home page di Server Manager per la gestione del ruolo.

Per installare ulteriori ruoli o rimuovere ruoli esistenti, fare clic sul comando appropriato sul lato destro dell'area Riepilogo ruoli.

Il comando Vai a Gestisci ruoli contenuto in questa sezione apre la home page Ruoli in cui è possibile trovare ulteriori dettagli sui ruoli installati, ad esempio i servizi ruolo installati per il ruolo, lo stato operativo del ruolo ed eventuali messaggi di eventi disponibili relativi al ruolo.

Per ulteriori informazioni sulla home page Ruoli, vedere Home page relative ai ruoli.

Area Riepilogo funzionalità

Nell'area Riepilogo funzionalità dell'intestazione della home page di Server Manager viene visualizzato un elenco di tutte le funzionalità installate nel computer.

Per installare ulteriori funzionalità o rimuovere funzionalità esistenti, fare clic sul comando appropriato sul lato destro dell'area Riepilogo funzionalità.

Aggiungere e rimuovere ruoli e funzionalità

Per informazioni sull'aggiunta e sulla rimozione di ruoli, servizi ruolo e funzionalità, vedere Aggiungere ruoli del server e funzionalità e Rimuovere ruoli del server e funzionalità.


Server Manager e la Configurazione guidata impostazioni di sicurezza

Sebbene le installazioni di ruoli, servizi ruolo e funzionalità completate in Server Manager siano sicure per impostazione predefinita, è possibile utilizzare la Configurazione guidata impostazioni di sicurezza per personalizzare la sicurezza di ruoli, ruoli server e funzionalità nell'organizzazione.

Come Server Manager interagisce con la Configurazione guidata impostazioni di sicurezza

Server Manager e la Configurazione guidata impostazioni di sicurezza sono simili in quanto entrambi utilizzano gli stessi processi per eseguire le attività seguenti.

  • Server Manager e la Configurazione guidata impostazioni di sicurezza utilizzano entrambi lo stesso processo di Windows per determinare ruoli, ruoli server e funzionalità installati su un computer o disponibili per l'installazione.

  • Server Manager e la Configurazione guidata impostazioni di sicurezza utilizzano entrambi gli stessi criteri predefiniti per servizi ed eccezioni del firewall.

  • Server Manager e la Configurazione guidata impostazioni di sicurezza utilizzano entrambi gli stessi strumenti per determinare in che modo l'esecuzione di ruoli, ruoli server e funzionalità dipende da altri ruoli, ruoli server e funzionalità.

Server Manager e la Configurazione guidata impostazioni di sicurezza sono tecnologie complementari in diversi modi, come descritto nelle sezioni seguenti. Server Manager viene utilizzato al fine di ridurre il tempo necessario per distribuire e reimpiegare i server, consentendo inoltre agli amministratori di gestire le operazioni quotidiane tipiche di ruoli, ruoli server e funzionalità. La Configurazione guidata impostazioni di sicurezza contribuisce invece alla prevenzione a lungo termine di eventi, comportamenti degli utenti e vulnerabilità che possono causare errori di sicurezza, come ad esempio l'accesso non autorizzato ai dati.

Creazione dei criteri

La Configurazione guidata impostazioni di sicurezza consente agli amministratori di definire criteri di sicurezza basati su ruoli applicabili ai computer remoti di un'intera organizzazione. Server Manager protegge i ruoli per impostazione predefinita ed esegue operazioni per garantire la sicurezza di ruoli, ruoli server e funzionalità rimanenti dopo la rimozione di un ruolo, servizio ruolo o funzionalità dal computer, ma gli amministratori non possono utilizzare Server Manager direttamente per apportare modifiche della sicurezza personalizzate.

Controllo

La Configurazione guidata impostazioni di sicurezza consente agli amministratori di confrontare lo stato corrente della sicurezza di un computer con i criteri di sicurezza esistenti per garantire la conformità a tali criteri.

Sebbene Server Manager sia in grado di visualizzare i registri di sicurezza di Windows interagendo con il Visualizzatore eventi e di mostrare le opzioni di sicurezza selezionate dagli amministratori (indicando ad esempio se Windows Firewall e Windows Update sono attivati), Server Manager non verifica tuttavia la sicurezza di ruoli, ruoli server e funzionalità dopo la relativa installazione.

Protezione avanzata

La Configurazione guidata impostazioni di sicurezza consente un controllo dettagliato sulla superficie di attacco di un computer e offre agli amministratori la scalabilità necessaria per implementare in un computer la protezione avanzata contro gli attacchi in base alle esigenze di sicurezza dell'organizzazione. Server Manager consente agli amministratori di installare ruoli, ruoli server e funzionalità sicuri per impostazione predefinita e disponibili per la distribuzione. Nella maggior parte dei casi, non è necessario che gli amministratori eseguano la Configurazione guidata impostazioni di sicurezza per iniziare a utilizzare ruoli, ruoli server e funzionalità.

Ruoli, servizi ruolo e funzionalità esterni

È possibile utilizzare Server Manager per gestire solo ruoli, ruoli server e funzionalità inclusi nel disco del prodotto Windows Server 2008. La Configurazione guidata impostazioni di sicurezza consente di proteggere sia ruoli, ruoli server e funzionalità inclusi in Windows Server 2008 che ruoli, ruoli server e funzionalità non disponibili per l'installazione nel disco del prodotto, ad esempio Microsoft SQL Server e Microsoft Exchange Server.

Estendibilità

Non è possibile utilizzare Server Manager per installare o creare ruoli, ruoli server e funzionalità di terze parti. La Configurazione guidata impostazioni di sicurezza offre uno schema pubblico per consentire ai produttori di software di terze parti di definire nuovi ruoli, ruoli server e funzionalità che possono essere protetti tramite la configurazione guidata stessa.

Ulteriori riferimenti

Per ulteriori informazioni sulla Configurazione guidata impostazioni di sicurezza, vedere la relativa Guida scwhelp.chm.


Riepilogo ruoli

Sezione Riepilogo ruoli

Nella sezione Riepilogo ruoli sono elencati in ordine alfabetico i ruoli installati nel computer. A sinistra di ogni ruolo è presente un'icona che indica lo stato operativo generale corrente del ruolo.

Se si fa clic sul nome del ruolo nella sezione Riepilogo ruoli, viene visualizzata la home page relativa a tale ruolo.

I comandi sul margine della sezione Riepilogo ruoli consentono di aprire la pagina Ruoli, aggiungere più ruoli o rimuovere ruoli installati.

Aggiungere e rimuovere ruoli

Per informazioni sull'aggiunta e sulla rimozione di ruoli, vedere Aggiungere ruoli del server e funzionalità e Rimuovere ruoli del server e funzionalità.


Risorse e supporto

Sezione Risorse e supporto

La sezione Risorse e supporto della finestra principale di Server Manager contiene i comandi che è possibile utilizzare per modificare lo stato della partecipazione ai programmi di feedback di Windows Server® 2008, ovvero Analisi utilizzo software e Segnalazione errori Windows.

Per ulteriori informazioni sulla partecipazione a questi programmi, vedere Programma Analisi utilizzo software e Segnalazione errori Windows.

Per ulteriori informazioni sulla gestione e sulla distribuzione del server, visitare il sito Web TechCenter per Windows Server® 2008 utilizzando il relativo collegamento disponibile nella sezione Risorse e supporto.


Riepilogo funzionalità

L'area Riepilogo funzionalità di Windows Server® 2008 include una tabella in cui sono elencate le funzionalità installate e contiene collegamenti ai comandi per l'aggiunta e la rimozione di funzionalità.

Area Riepilogo funzionalità

Nell'area Riepilogo funzionalità dell'intestazione della home page di Server Manager viene visualizzato un elenco di tutte le funzionalità installate nel computer.

Per installare ulteriori funzionalità o rimuovere funzionalità esistenti, fare clic sul comando appropriato sul lato destro dell'area Riepilogo funzionalità.

Aggiungere e rimuovere funzionalità

Per informazioni sull'aggiunta e sulla rimozione di funzionalità, vedere Aggiungere ruoli del server e funzionalità e Rimuovere ruoli del server e funzionalità.


Programma Analisi utilizzo software

Programma Analisi utilizzo software

È possibile partecipare al programma Analisi utilizzo software, che consente di migliorare la qualità, l'affidabilità e le prestazioni dei sistemi operativi Microsoft.

Se si accetta, Microsoft Corporation raccoglierà informazioni statistiche sulla configurazione del sistema dell'utente, sulle prestazioni di alcuni componenti di Windows e su determinati tipi di eventi. A Microsoft viene pertanto inviato periodicamente un file di piccole dimensioni contenente un riepilogo delle informazioni raccolte. Il file viene trasmesso tramite Internet.

I dati caricati non contengono informazioni che consentono di identificare l'utente o la relativa azienda. Non è necessario compilare sondaggi e la raccolta delle informazioni viene eseguita automaticamente, senza mai interrompere le operazioni dell'utente. Di norma non si verifica alcuna riduzione delle prestazioni. Se il computer non è connesso a Internet, i dati verranno eliminati. Microsoft non condivide tali informazioni con altre aziende. Le informazioni vengono utilizzate esclusivamente da Microsoft in formato aggregato allo scopo di migliorare il software degli utenti.

Per partecipare, seguire la procedura indicata nella sezione Per attivare il programma Analisi utilizzo software.

Se non si desidera partecipare, seguire la procedura indicata nella sezione Per disattivare il programma Analisi utilizzo software.

Per attivare il programma Analisi utilizzo software

È possibile attivare il programma Analisi utilizzo software tramite Server Manager o Attività di configurazione iniziali.

Per attivare il programma Analisi utilizzo software tramite Server Manager

Per attivare il programma Analisi utilizzo software tramite Attività di configurazione iniziale

Per attivare il programma Analisi utilizzo software tramite Server Manager

Per partecipare al programma Analisi utilizzo software con Server Manager, eseguire la procedura seguente.

Per attivare il programma Analisi utilizzo software tramite Server Manager

  1. Fare clic sul pulsante Start.

  2. Scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  3. Nella home page di Server Manager espandere l'area Risorse e supporto, qualora non sia già aperta.

  4. Per aprire la finestra di dialogo Configurazione programma Analisi utilizzo software, fare clic su Configura Analisi utilizzo software.

  5. Selezionare Sì, desidero partecipare al programma Analisi utilizzo software di Windows Server. Fare clic su OK.

Per attivare il programma Analisi utilizzo software tramite Attività di configurazione iniziale

Per partecipare al programma Analisi utilizzo software con Attività di configurazione iniziali, eseguire la procedura seguente.

Per attivare il programma Analisi utilizzo software tramite Attività di configurazione iniziale

  1. Nella sezione Aggiorna server in uso della finestra Attività di configurazione iniziale fare clic su Consenti aggiornamenti automatici e feedback.

  2. Nella finestra di dialogo Attiva Aggiornamenti automatici Windows e il feedback eseguire una delle operazioni seguenti.

    • Per partecipare sia al programma Analisi utilizzo software che a Segnalazione errori Windows, fare clic su Attiva Aggiornamenti automatici Windows e il feedback. Fare clic su Chiudi. La procedura è completata.

    • Per partecipare solo al programma Analisi utilizzo software o modificare le impostazioni, fare clic su Configura le impostazioni manualmente.

  3. Se nel passaggio precedente è stato selezionato Configura le impostazioni manualmente, fare clic su Cambia impostazione nell'area Programma Analisi utilizzo software della finestra di dialogo Configura le impostazioni manualmente.

  4. Nella finestra di dialogo Configurazione programma Analisi utilizzo software selezionare Sì, desidero partecipare al programma Analisi utilizzo software di Windows Server. Fare clic su OK.

Per disattivare il programma Analisi utilizzo software

È possibile disattivare la partecipazione al programma Analisi utilizzo software tramite Server Manager o Attività di configurazione iniziali.

Per disattivare il programma Analisi utilizzo software tramite Server Manager

Per disattivare il programma Analisi utilizzo software tramite Attività di configurazione iniziale

Per disattivare il programma Analisi utilizzo software tramite Server Manager

Eseguire la procedura seguente in Server Manager se non si desidera partecipare al programma Analisi utilizzo software.

Per disattivare il programma Analisi utilizzo software tramite Server Manager

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  2. Nella home page di Server Manager espandere l'area Risorse e supporto, qualora non sia già aperta.

  3. Per aprire la finestra di dialogo Configurazione programma Analisi utilizzo software, fare clic su Configura Analisi utilizzo software.

  4. Selezionare No, non desidero partecipare. Fare clic su OK.

Per disattivare il programma Analisi utilizzo software tramite Attività di configurazione iniziale

Eseguire la procedura seguente in Attività di configurazione iniziali se non si desidera partecipare al programma Analisi utilizzo software.

Per disattivare il programma Analisi utilizzo software tramite Attività di configurazione iniziale

  1. Nella sezione Aggiornamento del server della finestra Attività di configurazione iniziale fare clic su Consenti aggiornamenti automatici e feedback.

  2. Nella finestra di dialogo Attiva Aggiornamenti automatici Windows e il feedback fare clic su Configura le impostazioni manualmente.

  3. Fare clic su Cambia impostazione nell'area Programma Analisi utilizzo software della finestra di dialogo Configura le impostazioni manualmente.

  4. Nella finestra di dialogo Configurazione programma Analisi utilizzo software selezionare No, non desidero partecipare. Fare clic su OK.

Profilo per il programma Analisi utilizzo software

Se si partecipa al programma Analisi utilizzo software, è possibile aggiungere un profilo per fornire a Microsoft ulteriori dettagli sul tipo di organizzazione in cui è distribuito il server. L'aggiunta di un profilo è facoltativa, ma fornisce dati più completi che consentono a Microsoft di creare soluzioni migliori per il tipo specifico di organizzazione.

Se si desidera aggiungere un profilo, eseguire la procedura seguente.

Per aggiungere un profilo per il programma Analisi utilizzo software

  1. Nella finestra di dialogo Configurazione programma Analisi utilizzo software selezionare l'opzione Sì, desidero partecipare al programma Analisi utilizzo software di Windows Server.

  2. Per selezionare i valori che rappresentano meglio l'organizzazione, utilizzare i menu a discesa e quindi fare clic su OK.

    • Numero di server dell'organizzazione in tutto il mondo: Selezionare l'intervallo numerico che rappresenta in modo più preciso il numero dei server dell'organizzazione.

    • Numero di PC desktop e portatili dell'organizzazione in tutto il mondo: Selezionare l'intervallo numerico che rappresenta in modo più preciso il numero dei computer desktop e portatili dell'organizzazione.

    • Settore di appartenenza dell'organizzazione: Se il settore dell'organizzazione non è rappresentato adeguatamente nelle opzioni, selezionare Altri servizi.

Vedere anche

  • Segnalazione errori Windows
  • Finestra principale di Server Manager


Segnalazione errori Windows

Segnalazione errori Windows

Tramite Segnalazione errori Windows, Windows è in grado di inviare a Microsoft le descrizioni dei problemi che si verificano sul server e cercare le procedure per risolverli. Il servizio Segnalazione errori Windows è attivato per impostazione predefinita.

Se si sceglie di inviare automaticamente informazioni generiche su un problema, Microsoft comunicherà la soluzione più aggiornata o ne elaborerà una in base a tali informazioni.

Per ulteriori informazioni sulla tutela delle informazioni degli utenti mediante l'informativa sulla privacy, visitare il sito Web Microsoft Online Crash Analysis.

Opzioni avanzate di Segnalazioni errori Windows

Le due opzioni seguenti nella finestra di dialogo Configurazione di Segnalazioni errori Windows Server comportano la disattivazione di Segnalazione errori Windows:

  • Non desidero partecipare. Non visualizzare più questo messaggio

    Se si seleziona questa opzione, la funzionalità Segnalazione errori Windows viene disattivata e il messaggio in cui viene chiesto se si desidera inviare a Microsoft le informazioni relative agli errori dell'applicazione non viene più visualizzato.

  • Chiedi conferma prima di inviare rapporti quando si verifica un errore

    Se si seleziona questa opzione, la funzionalità Segnalazione errori Windows viene disattivata, ma il messaggio in cui viene chiesto se si desidera inviare a Microsoft le informazioni relative agli errori dell'applicazione viene visualizzato ogni volta che si verifica un errore.

Le due opzioni seguenti comportano l'attivazione di Segnalazione errori Windows. Ogni opzione offre un livello di dettaglio diverso nelle informazioni inviate a Microsoft quando si verificano errori.

  • Sì, invia automaticamente rapporti dettagliati. Avvisa se sono disponibili possibili soluzioni del problema.

    Quando questa opzione è selezionata, in caso di errore di un'applicazione vengono inviati automaticamente a Microsoft rapporti dettagliati. È possibile includere in questi rapporti sezioni dei documenti sui cui si stava lavorando nel momento in cui si è verificato un errore in un programma oppure i dati inviati dall'utente a moduli o siti Web. È inoltre possibile inviare a Microsoft il contenuto dei file di registro e parti del Registro di sistema.

  • Sì, invia automaticamente rapporti brevi. Avvisa se sono disponibili possibili soluzioni del problema.

    Quando questa opzione è selezionata, in caso di errore di un'applicazione vengono inviati a Microsoft solo dati non a carattere personale, ad esempio dati sulla configurazione del computer, il programma utilizzato ed eventuali operazioni che hanno attivato l'errore.

Come attivare Segnalazione errori Windows

In Windows Server® 2008 R2 è possibile attivare Segnalazione errori Windows nei modi seguenti:

Per attivare Segnalazione errori Windows utilizzando la finestra Attività di configurazione iniziale

Per attivare Segnalazione errori Windows utilizzando Server Manager

Per attivare Segnalazione errori Windows utilizzando Attività di configurazione iniziale

  1. Se la finestra Attività di configurazione iniziale non è già aperta, è possibile visualizzarla facendo clic sul pulsante Start, scegliendo Esegui, digitando oobe nella casella di testo e quindi facendo clic su OK.

  2. Fare clic su Consenti aggiornamenti automatici e feedback nell'area Aggiornamento del server.

  3. Fare clic su Configura le impostazioni manualmente.

  4. Nell'area Segnalazione errori Windows della finestra di dialogo Configura le impostazioni manualmente fare clic su Cambia impostazione.

  5. Nella finestra di dialogo Configurazione di Segnalazione errori Windows selezionare una delle opzioni seguenti, descritte nella sezione precedente, e quindi fare clic su OK:

    • Sì, invia automaticamente rapporti dettagliati

    • Sì, invia automaticamente rapporti brevi

  6. Nella finestra di dialogo Configura le impostazioni manualmente fare clic su Chiudi.
Per attivare Segnalazione errori Windows utilizzando Server Manager

  1. Aprire Server Manager facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione e quindi facendo clic su Server Manager.

  2. Nella home page di Server Manager espandere l'area Risorse e supporto, qualora non sia già aperta.

  3. Fare clic su Configura Segnalazione errori Windows.

  4. Nella finestra di dialogo Configurazione di Segnalazione errori Windows selezionare una delle opzioni seguenti, descritte nella sezione precedente, e quindi fare clic su OK:

    • Sì, invia automaticamente rapporti dettagliati

    • Sì, invia automaticamente rapporti brevi

Come disattivare Segnalazione errori Windows

In Windows Server 2008 R2 è possibile disattivare Segnalazione errori Windows in uno dei modi seguenti:

Per disattivare Segnalazione errori Windows utilizzando la finestra Attività di configurazione iniziale

Per disattivare Segnalazione errori Windows utilizzando Server Manager

È inoltre possibile attivare o disattivare Segnalazione errori Windows configurandone il comportamento tramite Criteri di gruppo. Utilizzare l'Editor Criteri di gruppo locali per la modifica di oggetti Criteri di gruppo locali oppure utilizzare Console Gestione Criteri di gruppo per la modifica di oggetti Criteri di gruppo basati sul dominio. È possibile individuare le impostazioni di questi Criteri di gruppo in Modelli amministrativi/Componenti di Windows/Segnalazione errori Windows.

Per disattivare Segnalazione errori Windows utilizzando Attività di configurazione iniziale

  1. Se la finestra Attività di configurazione iniziale non è già aperta, è possibile visualizzarla facendo clic sul pulsante Start, scegliendo Esegui, digitando oobe nella casella di testo e quindi facendo clic su OK.

  2. Fare clic su Consenti aggiornamenti automatici e feedback nell'area Aggiornamento del server.

  3. Nella finestra di dialogo Attiva Aggiornamenti automatici Windows e il feedback fare clic su Configura le impostazioni manualmente.

  4. Nell'area Segnalazione errori Windows della finestra di dialogo Configura le impostazioni manualmente fare clic su Cambia impostazione.

  5. Nella finestra di dialogo Configurazione di Segnalazione errori Windows selezionare una delle opzioni seguenti e quindi fare clic su OK:

    • Non desidero partecipare. Non visualizzare più questo messaggio

      Se si seleziona questa opzione, la funzionalità Segnalazione errori Windows viene disattivata e il messaggio in cui viene chiesto se si desidera inviare a Microsoft le informazioni relative agli errori dell'applicazione non viene più visualizzato.

    • Chiedi conferma prima di inviare segnalazioni quando si verifica un errore

      Se si seleziona questa opzione, la funzionalità Segnalazione errori Windows viene disattivata, ma il messaggio in cui viene chiesto se si desidera inviare a Microsoft le informazioni relative agli errori dell'applicazione viene visualizzato ogni volta che si verifica un errore.

  6. Nella finestra di dialogo Configura le impostazioni manualmente fare clic su Chiudi.
Per disattivare Segnalazione errori Windows utilizzando Server Manager

  1. Aprire Server Manager facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione e quindi facendo clic su Server Manager.

  2. Nella home page di Server Manager espandere l'area Risorse e supporto, qualora non sia già aperta.

  3. Fare clic su Configura Segnalazione errori Windows.

  4. Nella finestra di dialogo Configurazione di Segnalazione errori Windows selezionare una delle opzioni seguenti e quindi fare clic su OK:

    • Non desidero partecipare. Non visualizzare più questo messaggio

      Se si seleziona questa opzione, la funzionalità Segnalazione errori Windows viene disattivata e il messaggio in cui viene chiesto se si desidera inviare a Microsoft le informazioni relative agli errori dell'applicazione non viene più visualizzato.

    • Chiedi conferma prima di inviare segnalazioni quando si verifica un errore

      Se si seleziona questa opzione, la funzionalità Segnalazione errori Windows viene disattivata, ma il messaggio in cui viene chiesto se si desidera inviare a Microsoft le informazioni relative agli errori dell'applicazione viene visualizzato ogni volta che si verifica un errore.

Vedere anche

  • Programma Analisi utilizzo software
  • Finestra principale di Server Manager


Home page relative ai ruoli

Pagina Ruoli di Server Manager

La pagina Ruoli della console Server Manager contiene la sezione Riepilogo ruoli, seguita da sezioni comprimibili aggiunte per ogni ruolo installato nel computer.

Sezione Riepilogo ruoli

Nella sezione Riepilogo ruoli sono elencati in ordine alfabetico i ruoli installati nel computer. A sinistra di ogni ruolo è presente un'icona che indica lo stato operativo generale corrente del ruolo.

Se si fa clic sul nome del ruolo nella sezione Riepilogo ruoli, viene visualizzata la home page relativa a tale ruolo.

Sezioni specifiche del ruolo

Le sezioni specifiche del ruolo nella pagina Ruoli contengono le sottosezioni seguenti.

Nome della sottosezione | Descrizione
Stato ruoli | Nella sottosezione Stato ruoli è indicato se sono stati registrati messaggi di errore e di evento recenti per il ruolo o per eventuali servizi da cui il ruolo dipende. Se si fa clic sui collegamenti della sezione Stato ruoli, viene aperta la home page specifica del ruolo.
Servizi ruolo | Nella sottosezione Servizi ruolo sono elencati tutti i servizi ruolo disponibili, con una breve descrizione corrispondente, e vengono visualizzati i servizi ruolo installati nel server. È possibile aggiungere o rimuovere servizi ruolo tramite i comandi disponibili sul lato destro della sottosezione Servizi ruolo.

Home page specifiche del ruolo

Le home page specifiche del ruolo contengono dettagli completi sullo stato operativo di un ruolo e consentono di avviare attività di gestione specifiche del ruolo da Server Manager.

Tali pagine includono le sezioni seguenti.

Sezione Riepilogo

La sezione Riepilogo della home page di un ruolo contiene le sottosezioni seguenti.

Nome sezione | Descrizione
Eventi | Nella sezione Eventi vengono visualizzati i messaggi di evento e di errore registrati per il ruolo nelle ultime 24 ore. È possibile aprire, visualizzare e filtrare i messaggi di evento in questa sezione senza aprire il Visualizzatore eventi separatamente. È tuttavia anche possibile utilizzare il comando Vai a Visualizzatore eventi sul lato destro della sezione per aprire il Visualizzatore eventi, se necessario.
Servizi di sistema | Nella sezione Servizi di sistema sono elencati i servizi di sistema da cui dipende l'esecuzione del ruolo e vengono visualizzati lo stato e la descrizione di ogni servizio. I comandi disponibili nella sezione Servizi sistema consentono di aprire lo snap-in Servizi, nonché di interrompere e riavviare i servizi.
Best Practice Analyzer | Best Practice Analyzer (BPA) può aiutare gli amministratori a gestire i ruoli del server in modo conforme alle linee guida relative alle procedure consigliate consentendo loro di analizzare uno o più ruoli installati in Windows Server® 2008 R2 per verificare la presenza di violazioni delle procedure consigliate e visualizzare informazioni sulla risoluzione dei problemi e risultati dettagliati. Per ulteriori informazioni su Best Practice Analyzer, vedere Best Practice Analyzer.
Servizi ruolo | Nella sezione Servizi ruolo sono elencati tutti i servizi ruolo disponibili, con una breve descrizione corrispondente, e vengono visualizzati i servizi ruolo installati nel server. È possibile aggiungere o rimuovere servizi ruolo tramite i comandi disponibili sul lato destro della sottosezione Role Services.

Finestra di dialogo Filtro eventi

Il comando Filtra eventi, disponibile nel margine della sezione Eventi, consente di aprire la finestra di dialogo Filtro eventi. Sebbene la finestra di dialogo Filtro eventi consenta di filtrare gli eventi con modalità analoghe a quelle degli strumenti filtro nel Visualizzatore eventi, questa finestra è disponibile esclusivamente nelle home page specifiche del ruolo di Server Manager. I filtri del Visualizzatore eventi offrono un maggior numero di opzioni e criteri di filtro. Nella finestra di dialogo Filtro eventi in Server Manager è disponibile un sottoinsieme delle funzionalità di filtro del Visualizzatore eventi.

La finestra di dialogo Filtro eventi consente di visualizzare gli eventi selezionati nella sezione Eventi della home page di un ruolo in base alle tre proprietà evento seguenti.

  • Livelli Agli eventi vengono aggiunti tag con i livelli seguenti, in base alla gravità dell'azione o della condizione che ha attivato il messaggio di evento. Quando sono selezionati tutti i livelli, nella sezione Eventi della home page del ruolo vengono visualizzati eventi di tutti i livelli. Per impostazione predefinita, sono selezionati tutti i livelli degli eventi in modo che vengano visualizzati nell'area Eventi.

    • Informazioni Indica una modifica in un'applicazione o in un componente, ad esempio il corretto completamento di un'operazione, la creazione di una risorsa o l'avvio di un servizio.

    • Avviso Indica un problema che può influire sul servizio o causare un problema più grave se non si intraprende alcuna azione.

    • Errore Indica un problema che potrebbe influire su funzionalità esterne all'applicazione o al componente che ha attivato l'evento.

    • Critico Indica un errore che non consente il ripristino automatico dell'applicazione o del componente che ha attivato l'evento.

    La selezione del livello Dettagliato consente di ottenere la massima quantità di dati nei messaggi di eventi.

  • ID evento È possibile filtrare gli eventi in base ai numeri di ID separati da virgola o a un intervallo di numeri separati da un trattino. Per escludere un numero di evento in un intervallo, inserire un trattino o un segno meno (-) davanti al numero che si desidera escludere.

    Nota

    La proprietà Livelli ha la precedenza sulle altre proprietà della finestra di dialogo Filtro eventi. Se ad esempio si desidera filtrare gli eventi relativi a un messaggio di errore del livello Errore con ID evento 620 ma il livello Errore non è selezionato nell'area Livelli, l'ID evento 620 non verrà visualizzato. Analogamente, se è stato applicato un filtro in cui sono stati selezionati gli eventi del livello Informazioni e quindi è stato specificato un periodo di dodici ore, ma per il ruolo non sono stati registrati eventi del livello Informazioni nelle ultime dodici ore, nella sezione Eventi non verrà visualizzato alcun evento.

  • Periodo Questa proprietà consente di filtrare gli eventi che si sono verificati solo nell'ultimo periodo specificato. Per impostazione predefinita, il periodo viene impostato su 24 ore.

Quando si modifica una qualsiasi delle impostazioni predefinite nella finestra di dialogo Filtro eventi e quindi si fa clic su OK, nella parte inferiore dell'elenco di eventi dell'area Eventi viene visualizzato il messaggio Filtro attivato. Se le impostazioni predefinite nella finestra di dialogo Filtro eventi vengono ripristinate (tutti i livelli selezionati, nessun ID evento specificato, periodo di 24 ore specificato), il filtro viene disattivato e il messaggio Filtro attivato viene cancellato.

Preferenze relative ai servizi di sistema

Analogamente alla finestra di dialogo Filtro eventi, la finestra di dialogo Preferenze relativa ai servizi di sistema in Server Manager include un sottoinsieme di informazioni e impostazioni disponibili nella finestra di dialogo Proprietà aperta dallo snap-in Servizi. Esattamente come quando si utilizza la finestra di dialogo Proprietà per servizi specifici nello snap-in Servizi, è possibile avviare, arrestare, sospendere e riavviare i servizi associati all'esecuzione di un ruolo tramite i comandi disponibili nel margine dell'area Servizi di sistema.

L'implementazione di Server Manager nella finestra di dialogo Preferenze relativa ai servizi consente di monitorare lo stato dei servizi necessari per un ruolo nella home page di tale ruolo. I servizi associati all'esecuzione del ruolo sono elencati nella finestra di dialogo Preferenze ed è possibile attivare o disattivare il monitoraggio di ogni servizio in modo indipendente.

Importante

I servizi di sistema predefiniti vengono selezionati per il monitoraggio nella finestra di dialogo Preferenze al fine di garantire la continuità ottimale dell'esecuzione del ruolo. La modifica delle impostazioni di monitoraggio predefinite, in particolare la disattivazione del monitoraggio relativo ai servizi controllati per impostazione predefinita, può causare condizioni di errore o modifiche dello stato durante l'esecuzione del ruolo.

Sezione Risorse e supporto

La sezione Risorse e supporto offre indicazioni per la gestione del ruolo e la relativa configurazione al fine di eseguire attività comuni e consigliate nell'organizzazione.

Nella sezione Risorse e supporto sono elencate le configurazioni consigliate per il ruolo. Se si seleziona una configurazione, viene visualizzata la relativa descrizione, incluso un collegamento a un elenco di controllo che guida l'utente attraverso le attività da eseguire per completare la configurazione.

Per ulteriori informazioni sulla gestione e sulla distribuzione di altri aspetti del ruolo, nel margine della sezione Risorse e supporto fare clic sui relativi collegamenti alla Guida e al sito Web TechCenter per Windows Server 2008 R2 per tale ruolo.


Best Practice Analyzer

In ambito di gestione di Windows, con best practices si fa riferimento a linee guida considerate ideali, in circostanze tipiche, per configurare un server in base al parere degli esperti. Per la maggior parte delle tecnologie server, ad esempio, le procedure consigliate prevedono l'apertura solo delle porte necessarie per la comunicazione delle tecnologie con altri computer di rete e il blocco delle porte non utilizzate. Sebbene il mancato rispetto delle procedure consigliate, anche di quelle più importanti, non sia necessariamente problematico, potrebbero verificarsi cali nelle prestazioni, scarsa affidabilità, conflitti imprevisti, aumento dei rischi per la sicurezza e altri problemi potenziali.

Best Practice Analyzer (BPA) è uno strumento di gestione dei server disponile in Windows Server® 2008 R2. BPA può aiutare gli amministratori a ridurre le violazioni delle procedure consigliate tramite l'analisi di uno o più ruoli installati in Windows Server 2008 R2 e la segnalazione di tali violazioni all'amministratore. Gli amministratori possono filtrare o escludere i risultati dei rapporti BPA che non è necessario visualizzare. Gli amministratori possono inoltre svolgere attività di Best Practice Analyzer utilizzando l'interfaccia utente grafica di Server Manager o i cmdlet di Windows PowerShell.

È inoltre possibile utilizzare BPA in server remoti che eseguono Windows Server 2008 R2, utilizzando Server Manager per un server remoto. Per ulteriori informazioni su come eseguire Server Manager per un server remoto, vedere Gestione remota tramite Server Manager.

Best Practice Analyzer

BPA viene installato per impostazione predefinita in tutte le edizioni di Windows Server 2008 R2, ad eccezione dell'opzione di installazione Server Core.

Nota

Le istruzioni per l'installazione di Windows PowerShell e i moduli per Server Manager e Best Practice Analyzer con l'opzione di installazione Server Core di Windows Server 2008 R2 sono disponibili nella pagina relativa a installazione, accesso e rimozione di Strumenti di migrazione per Windows Server (http://go.microsoft.com/fwlink/?LinkId=134763).

Poiché le unità analizzate da BPA sono ruoli del server, l'interfaccia per BPA si trova nelle home page dei ruoli nella console di Server Manager. Per ulteriori informazioni sui ruoli, vedere Ruoli, servizi ruolo e funzionalità. Best Practice Analyzer è una delle aree della sezione Riepilogo della home page di un ruolo.

Come funziona BPA

BPA funziona misurando la conformità di un ruolo alle regole per le procedure consigliate in otto categorie diverse relative a efficacia, attendibilità e affidabilità. I risultati delle analisi sono rappresentati da tre livelli di gravità descritti nella tabella seguente.

Livello di gravità | Descrizione
Non conforme | I risultati di tipo Non conforme vengono restituiti quando un ruolo non soddisfa le condizioni di una regola.
Conforme | I risultati di tipo Conforme vengono restituiti quando un ruolo soddisfa le condizioni di una regola.
Avviso | I risultati di tipo Avviso vengono restituiti quando un ruolo in base al funzionamento attuale è conforme ma potrebbe non soddisfare le condizioni di una regola qualora non vengano apportate modifiche alle impostazioni di configurazione o dei criteri. Da un'analisi di Servizi Desktop remoto potrebbe ad esempio risultare un avviso qualora per il ruolo non sia disponibile un server licenze in quanto, anche se al momento dell'analisi non vi sono connessioni remote attive, la mancanza di un server licenze impedisce alle nuove connessioni remote di ottenere licenze CAL (Client Access License) valide.

Categorie regole BPA

Nella tabella seguente sono descritte le categorie delle regole relative alle procedure consigliate in base a cui vengono valutati i ruoli durante un'analisi BPA.

Nome categoria | Descrizione
Sicurezza | Le regole relative alla sicurezza vengono applicate per valutare il rischio relativo di un ruolo per quanto riguarda l'esposizione a minacce come utenti non autorizzati o malintenzionati oppure perdita o furto di dati riservati o proprietari.
Prestazioni | Le regole relative alle prestazioni vengono applicate per valutare la capacità di un ruolo di elaborare le richieste e svolgere i compiti previsti in un'organizzazione, entro il periodo di tempo previsto in base al carico di lavoro.
Configurazione | Le regole relative alla configurazione vengono applicate per identificare le impostazioni dei ruoli per le quali potrebbero essere necessarie modifiche per garantire il funzionamento ottimale del ruolo. Le regole relative alla configurazione possono aiutare a evitare conflitti tra impostazioni che possono comportare la visualizzazione di messaggi di errore o impedire a un ruolo di svolgere i compiti previsti in un'organizzazione.
Criterio | Le regole relative ai criteri vengono applicate per identificare le impostazioni di Criteri di gruppo o del Registro di sistema di Windows per le quali potrebbero essere necessarie modifiche per garantire il funzionamento ottimale e sicuro del ruolo.
Operazione | Le regole relative alle operazioni vengono applicate per identificare i possibili casi in cui un ruolo non è in grado di svolgere i compiti previsti nell'organizzazione.
Pre-distribuzione | Le regole relative alla pre-distribuzione vengono applicate prima della distribuzione di un ruolo nell'organizzazione, per consentire agli amministratori di stabilire se le procedure consigliate vengono rispettate, prima di utilizzare il ruolo in un ambiente di produzione.
Post-distribuzione | Le regole relative alla post-distribuzione vengono applicate dopo che tutti i servizi necessari sono stati avviati per un ruolo e il ruolo è in esecuzione nell'organizzazione.
Prerequisiti BPA | Le regole relative ai prerequisiti di BPA illustrano le impostazioni di configurazione, le impostazioni dei criteri e le funzionalità necessarie per il ruolo affinché tramite BPA possano essere applicate regole specifiche di altre categorie. Un prerequisito nei risultati di un'analisi indica che un'impostazione non corretta, un ruolo, servizio ruolo o funzionalità non presente, un criterio abilitato o disabilitato in modo non corretto, un'impostazione di una chiave del Registro di sistema o un'altra configurazione ha impedito a BPA di applicare una o più regole durante un'analisi. Un risultato relativo a un prerequisito non implica la conformità o la non conformità, bensì indica che non è stato possibile applicare una regola che pertanto non è inclusa nei risultati dell'analisi.

Come aprire BPA

È possibile aprire BPA nella console di Server Manager aprendo la home page di un ruolo del server che supporta BPA.

Per aprire BPA in Server Manager

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro dell'albero aprire Ruoli e quindi selezionare il ruolo per il quale si desidera aprire BPA.

  3. Nel riquadro dei dettagli aprire la sezione Riepilogo e quindi l'area Best Practice Analyzer.

Eseguire BPA

Per ulteriori informazioni su come eseguire analisi BPA, vedere Eseguire e filtrare analisi in Best Practice Analyzer in questa Guida.


Eseguire e filtrare analisi in Best Practice Analyzer

È possibile eseguire analisi di Best Practice Analyzer (BPA) da Server Manager, utilizzando l'interfaccia utente grafica (GUI) di BPA o utilizzando i cmdlet in Windows PowerShell. I cmdlet di BPA in Windows PowerShell consentono di analizzare uno o più ruoli contemporaneamente, mentre l'interfaccia utente grafica consente di analizzare un singolo ruolo per volta. È inoltre possibile impostare BPA in modo da escludere o ignorare i risultati dell'analisi che non è necessario visualizzare.

In questo argomento

  • Eseguire analisi di Best Practice Analyzer sui ruoli

  • Analizzare ruoli in esecuzione in computer remoti

  • Escludere risultati dell'analisi

  • Includere risultati dell'analisi

  • Archiviare risultati dell'analisi

Eseguire analisi di Best Practice Analyzer sui ruoli

È possibile eseguire analisi BPA sui ruoli utilizzando l'interfaccia utente grafica (GUI) di BPA in Server Manager o utilizzando i cmdlet in Windows PowerShell.

  • Analizzare i ruoli utilizzando l'interfaccia utente grafica (GUI) di BPA

  • Analizzare i ruoli utilizzando i cmdlet di Windows PowerShell

Analizzare i ruoli utilizzando l'interfaccia utente grafica (GUI) di BPA

Per analizzare un singolo ruolo utilizzando l'interfaccia utente grafica (GUI) di BPA, eseguire la procedura seguente.

Per analizzare un ruolo utilizzando l'interfaccia utente grafica (GUI) di BPA

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro dell'albero aprire Ruoli e quindi selezionare il ruolo per il quale si desidera aprire BPA.

  3. Nel riquadro dei dettagli aprire la sezione Riepilogo e quindi l'area Best Practice Analyzer.

  4. Fare clic su Analizza ruolo per avviare un'analisi.

Analizzare i ruoli utilizzando i cmdlet di Windows PowerShell

Utilizzare le procedure seguenti per analizzare uno o più ruoli utilizzando i cmdlet di Windows PowerShell. Per completare questa procedura, è necessario accedere al computer come membro del gruppo Administrators.

Nota

Nelle procedure descritte in questa sezione non sono mostrati tutti i parametri e i cmdlet di BPA. Per ulteriori informazioni sulle operazioni di BPA in Windows PowerShell, nella sessione di Windows PowerShell immettere Get-Help BPACmdlet -full, dove BPACmdlet può avere uno dei valori seguenti.

  • Get-BPAModel

  • Get-BPAResult

  • Invoke-BPAModel

  • Set-BPAResult

Per analizzare un singolo ruolo utilizzando i cmdlet di Windows PowerShell

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Importare il modulo Server Manager nella sessione di Windows PowerShell. Per importare il modulo Server Manager, digitare il comando seguente e quindi premere INVIO.

    Import-Module ServerManager

  3. Importare il modulo BPA. Digitare il comando seguente e quindi premere INVIO.

    Import-Module BestPractices

  4. Individuare gli ID modello per tutti i ruoli per i quali possono essere eseguite analisi BPA immettendo il cmdlet Get-WindowsFeature con il qualificatore BestPracticesModelId diverso da "null", come illustrato nell'esempio seguente.

    Get-WindowsFeature | Where {$_.BestPracticesModelId -ne $null}

  5. Nei risultati del passaggio 4 individuare l'ID modello del ruolo per il quale si desidera eseguire un'analisi BPA.

  6. Immettere il comando seguente per avviare l'analisi BPA per tale ruolo.

    Invoke-BPAModel -BestPracticesModelId ModelID_from_Step4

    Se è possibile eseguire un'analisi BPA su un ruolo specifico, è anche possibile avviare l'analisi eseguendo il piping dei risultati del cmdlet Get-WindowsFeature nel cmdlet Invoke-BPAModel, come illustrato nell'esempio seguente.

    Get-WindowsFeature Model_Name | Invoke-BPAModel
Per analizzare tutti i ruoli utilizzando i cmdlet di Windows PowerShell

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Importare il modulo Server Manager nella sessione di Windows PowerShell. Per importare il modulo Server Manager, digitare il comando seguente e quindi premere INVIO.

    Import-Module ServerManager

  3. Importare il modulo BPA. Digitare il comando seguente e quindi premere INVIO.

    Import-Module BestPractices

  4. Eseguire il piping di tutti i ruoli per i quali possono essere eseguite analisi BPA nel cmdlet Invoke-BPAModel per avviare le analisi.

    Get-WindowsFeature | Where {$_.BestPracticesModelId -ne $null} | Invoke-BPAModel

Analizzare ruoli in esecuzione in computer remoti

Nelle procedure di questa sezione viene descritto come eseguire analisi BPA sui ruoli installati in computer remoti che eseguono Windows Server® 2008 R2.

Importante

È necessario essere membri del gruppo Administrators in tutti i computer remoti in cui si desidera eseguire analisi BPA.

Per analizzare un ruolo remoto utilizzando l'interfaccia utente grafica (GUI) di Server Manager

  1. Per poter gestire un computer remoto utilizzando Server Manager, è innanzitutto necessario preparare il computer remoto eseguendo le procedure descritte in Gestione remota tramite Server Manager.

  2. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  3. Nel riquadro dell'albero di Server Manager fare clic con il pulsante destro del mouse sul nodo Server Manager e quindi scegliere Connetti a un altro computer.

  4. Nella finestra di dialogo Connetti a un altro computer selezionare Altro computer e quindi cercare o immettere il nome o l'indirizzo IP di un altro server che esegue Windows Server 2008 R2. Fare clic su OK.

  5. Nel riquadro dell'albero di Server Manager per il computer remoto aprire Ruoli.

  6. Selezionare la home page del ruolo sul quale si desidera eseguire un'analisi BPA.

  7. Nel riquadro dei dettagli aprire la sezione Riepilogo e quindi espandere l'area Best Practice Analyzer.

  8. Nell'area Best Practice Analyzer fare clic su Analizza ruolo.

  9. Al termine dell'analisi, visualizzare i risultati facendo doppio clic su una voce nella scheda Non conforme, Conforme o Tutti.
Per analizzare un ruolo remoto utilizzando i cmdlet di Windows PowerShell

  1. Per poter gestire un computer remoto utilizzando Server Manager, è innanzitutto necessario preparare il computer remoto eseguendo le procedure descritte in Gestione remota tramite Server Manager.

  2. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  3. Digitare il comando seguente, dove ComputerName è il nome del computer remoto che esegue Windows Server 2008 R2 e UserName è il nome di un utente membro del gruppo Administrators nel computer remoto, e quindi premere INVIO.

    Enter-PSSession <ComputerName> -credential <UserName>

  4. Verrà chiesto di immettere la password in una finestra di dialogo sicura. Digitare la password e quindi premere INVIO.

  5. Importare il modulo Server Manager nella sessione di Windows PowerShell. Per importare il modulo Server Manager, digitare il comando seguente e quindi premere INVIO.

    Import-Module ServerManager

  6. Importare il modulo BPA. Digitare il comando seguente e quindi premere INVIO.

    Import-Module BestPractices

  7. Avviare un'analisi BPA eseguendo il piping del modello del ruolo nel cmdlet Invoke-BPAModel. Digitare il comando seguente e quindi premere INVIO.

    Get-WindowsFeature [Role Name] | Invoke-BpaModel

  8. Digitare il comando seguente e quindi premere INVIO.

    configure-wsman.ps1

  9. Digitare il comando seguente e quindi premere INVIO.

    New-RunSpace

  10. Digitare il comando seguente e quindi premere INVIO.

    Start-PSSession

  11. Avviare un'analisi BPA sul ruolo in esecuzione nel computer remoto eseguendo il piping del modello del ruolo nel cmdlet per l'avvio delle analisi BPA, Invoke-BpaModel. Digitare il comando seguente e quindi premere INVIO.

    Get-WindowsFeature [Role Name] | Invoke-BpaModel

  12. Ottenere i risultati dell'analisi BPA. Digitare uno dei comandi seguenti e quindi premere INVIO.

    • Get-BpaResult [BestPracticeModelID]

    • Get-WindowsFeature [Role Name] | Get-BpaResult

Escludere risultati dell'analisi

Poiché potrebbe non essere necessario visualizzare alcuni risultati delle analisi, in particolare se si eseguono analisi frequenti, è possibile escludere i risultati che non si desidera visualizzare o che non sono rilevanti per l'analisi. I risultati delle analisi esclusi vengono spostati nella scheda Escluso dell'interfaccia utente grafica (GUI) di BPA e possono essere inclusi di nuovo in qualsiasi momento.

  • Escludere risultati dell'analisi utilizzando l'interfaccia utente grafica (GUI) di BPA

  • Escludere risultati dell'analisi utilizzando i cmdlet di Windows PowerShell

Escludere risultati dell'analisi utilizzando l'interfaccia utente grafica (GUI) di BPA

Per escludere i risultati dell'analisi utilizzando l'interfaccia utente grafica (GUI) di BPA, eseguire la procedura seguente.

Nota

Per poter utilizzare questa procedura, è prima necessario eseguire almeno un'analisi BPA su un ruolo.

Per escludere risultati dell'analisi utilizzando l'interfaccia utente grafica (GUI) di BPA

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro dell'albero aprire Ruoli e quindi selezionare il ruolo per il quale si desidera aprire BPA.

  3. Nel riquadro dei dettagli aprire la sezione Riepilogo e quindi l'area Best Practice Analyzer.

  4. Selezionare un risultato nella scheda Non conforme, Conforme o Tutti e quindi fare clic su Escludi.

  5. Per escludere più risultati contemporaneamente, tenere premuto CTRL quando si selezionano i risultati.

Escludere risultati dell'analisi utilizzando i cmdlet di Windows PowerShell

È possibile escludere i risultati dell'analisi utilizzando il cmdlet Set-BPAResult con il parametro -Exclude. Come nell'interfaccia utente grafica (GUI) di BPA, è possibile escludere oggetti risultato singoli oppure un insieme di risultati i cui campi, ad esempio relativi a categoria, titolo e gravità, equivalgono a o contengono valori specifici. È ad esempio possibile escludere tutti i risultati Prestazioni da un insieme di risultati dell'analisi per un ruolo.

Nota

Per poter utilizzare questa procedura, è prima necessario eseguire almeno un'analisi BPA su un ruolo.

Per escludere risultati dell'analisi utilizzando i cmdlet di Windows PowerShell

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Importare il modulo Server Manager nella sessione di Windows PowerShell. Per importare il modulo Server Manager, digitare il comando seguente e quindi premere INVIO.

    Import-Module ServerManager

  3. Importare il modulo BPA. Digitare il comando seguente e quindi premere INVIO.

    Import-Module BestPractices

  4. Escludere risultati specifici dall'analisi di un ruolo immettendo il cmdlet seguente.

    Get-BPAResult -BestPracticesModelId Specified Model Id | Where { $_ Field_Name -eq "Value" } | Set-BPAResult -Id Specified Model Id -Exclude $true

    Il cmdlet precedente consente di recuperare le voci dei risultati dell'analisi BPA per l'ID modello rappresentato da Specified Model Id. La seconda sezione del comando consente di filtrare i risultati del cmdlet Get-BPAResult per recuperare solo quelli il cui valore di un campo corrisponde al testo tra virgolette. La sezione finale del cmdlet, dopo la seconda barra verticale, consente di escludere i risultati filtrati dalla sezione precedente del cmdlet.

Includere risultati dell'analisi

Quando si desidera visualizzare risultati dell'analisi esclusi in precedenza, è possibile includere tali risultati.

  • Per includere risultati dell'analisi utilizzando l'interfaccia utente grafica (GUI) di BPA

  • Per includere risultati dell'analisi utilizzando i cmdlet di Windows PowerShell

Includere risultati dell'analisi utilizzando l'interfaccia utente grafica (GUI) di BPA

Nell'interfaccia utente grafica (GUI) di BPA è possibile includere qualsiasi risultato escluso selezionando uno o più risultati nella scheda Escluso e quindi facendo clic su Includi.

Per includere risultati dell'analisi utilizzando l'interfaccia utente grafica (GUI) di BPA

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro dell'albero aprire Ruoli e quindi selezionare il ruolo per il quale si desidera aprire BPA.

  3. Nel riquadro dei dettagli aprire la sezione Riepilogo e quindi l'area Best Practice Analyzer.

  4. Selezionare un risultato nella scheda Escluso e quindi fare clic su Includi.

  5. Per includere più risultati contemporaneamente, tenere premuto CTRL quando si selezionano i risultati.

Includere risultati dell'analisi utilizzando i cmdlet di Windows PowerShell

È possibile includere i risultati dell'analisi utilizzando il cmdlet Set-BPAResult con il parametro -Exclude. È possibile includere oggetti risultato singoli, come nell'interfaccia utente grafica (GUI) di BPA, oppure un insieme di risultati i cui campi, ad esempio relativi a categoria, titolo e gravità, equivalgono a o contengono valori specifici. È ad esempio possibile includere tutti i risultati Prestazioni esclusi in precedenza da un insieme di risultati dell'analisi per un ruolo.

Per includere risultati dell'analisi utilizzando i cmdlet di Windows PowerShell

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Importare il modulo Server Manager nella sessione di Windows PowerShell. Per importare il modulo Server Manager, digitare il comando seguente e quindi premere INVIO.

    Import-Module ServerManager

  3. Importare il modulo BPA. Digitare il comando seguente e quindi premere INVIO.

    Import-Module BestPractices

  4. Includere risultati specifici dell'analisi di un ruolo digitando il cmdlet seguente e quindi premendo INVIO.

    Get-BPAResult -BestPracticesModelId Specified Model Id | Where { $_Field_Name-eq "Value" } | Set-BPAResult -Id Specified Model Id -Exclude $false

    Il cmdlet precedente consente di recuperare le voci dei risultati dell'analisi BPA per il modello rappresentato da Specified Model Id. La seconda parte del cmdlet, dopo la prima barra verticale (|) consente di filtrare i risultati del cmdlet Get-BPAResult per recuperare solo quelli il cui valore di un campo corrisponde al testo tra virgolette. La parte finale del cmdlet, dopo la seconda barra verticale, consente di includere i risultati filtrati dalla seconda parte del cmdlet, impostando il valore del parametro –Exclude su false.

Archiviare risultati dell'analisi

È possibile archiviare i risultati di un'analisi BPA in un rapporto basato su HTML.

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Importare il modulo Server Manager nella sessione di Windows PowerShell. Per importare il modulo Server Manager, digitare il comando seguente e quindi premere INVIO.

    Import-Module ServerManager

  3. Importare il modulo BPA. Digitare il comando seguente e quindi premere INVIO.

    Import-Module BestPractices

  4. Digitare il comando seguente e premere INVIO per archiviare i risultati di un'analisi.

    Get-BPAResult –BestPracticesModelId Specified Model Id | ConvertTo-Html –As List –CssUri $env:windir\system32\WindowsPowerShell\v1.0\Modules\BestPractices\BestPracticesReportFormat.css > <path to HTML report file>

    Il cmdlet precedente consente di recuperare i risultati dell'analisi BPA più recente per il modello specificato e di salvarli in formato HTML, applicando i fogli di stile CSS standard archiviati nel percorso windir\system32\WindowsPowerShell\v1.0\Modules\BestPractices\BestPracticesReportFormat.css. Se si desidera sostituire i fogli di stile CSS, fornire il percorso di fogli di stile CSS diversi.

  5. Per visualizzare i risultati HTML archiviati dell'analisi, aprire un browser Internet e quindi aprire i risultati archiviati nel passaggio precedente.

Vedere anche

  • Best Practice Analyzer


Strumenti da riga di comando di Server Manager

Server Manager offre sia un insieme di cmdlet di Windows PowerShell che uno strumento da riga di comando, ServerManagerCmd.exe, per automatizzare la distribuzione di ruoli e funzionalità in computer che eseguono Windows Server® 2008 R2.

È possibile utilizzare i cmdlet di Windows PowerShell o ServerManagerCmd.exe per installare e rimuovere ruoli, ruoli server e funzionalità. Sia i cmdlet di Server Manager che ServerManagerCmd.exe consentono di visualizzare un elenco di tutti i ruoli, ruoli server e funzionalità, sia installati che disponibili per l'installazione nel computer.

Nota

Servermanagercmd.exe è obsoleto e il supporto non è garantito nelle versioni future di Windows. È consigliabile utilizzare i cmdlet di Windows PowerShell disponibili per Server Manager.

Windows PowerShell e Server Manager

I cmdlet (pronuncia command-lets) sono strumenti da riga di comando incorporati inclusi in Windows PowerShell 2.0, installati per impostazione predefinita come parte di Windows Server 2008 R2. Per ulteriori informazioni su Windows PowerShell e sul funzionamento dei cmdlet, vedere la guida introduttiva a Windows PowerShell. Per aprire tale guida introduttiva, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell 2.0, Documenti, aprire la cartella delle impostazioni locali e quindi fare doppio clic su GettingStarted.rtf.

Per eseguire qualsiasi cmdlet di Windows PowerShell correlato a Server Manager, è necessario eseguire Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore. Per poter utilizzare i cmdlet di Server Manager è inoltre necessario caricare il modulo Server Manager in ogni sessione nuova di Windows PowerShell. A tale scopo, in una sessione di Windows PowerShell aperta con diritti utente elevati, digitare Import-Module Servermanager e quindi premere INVIO.

Nota

Per ulteriori informazioni su come avviare una sessione di Windows PowerShell con tutti i moduli e gli snap-in installati caricati automaticamente, vedere Avviare Windows PowerShell con tutti i moduli caricati.

I tre cmdlet seguenti consentono di installare, rimuovere o visualizzare informazioni sui ruoli disponibili utilizzando Windows PowerShell. Per ulteriori informazioni sull'utilizzo di tali cmdlet, in una sessione di Windows PowerShell immettere Get-Help cmdlet_name -full, dove cmdlet_name rappresenta uno dei valori seguenti.

  • Add-WindowsFeature

  • Get-WindowsFeature

  • Remove-WindowsFeature

In questa sezione

In questa sezione vengono descritti gli argomenti seguenti:

Panoramica dei comandi di Server Manager

Creare un file di risposta per comandi di Server Manager

Interpretare l'output dei comandi di Server Manager

Avviare Windows PowerShell con tutti i moduli caricati


Panoramica dei comandi di Server Manager

Server Manager in Windows Server® 2008 R2 offre un insieme di cmdlet di Windows PowerShell per l'installazione e la rimozione di ruoli, ruoli server e funzionalità, nonché l'esecuzione di query su di essi, nonché uno strumento da riga di comando, ServerManagerCmd.exe, che consente agli utenti di eseguire in modo automatico l'installazione o la rimozione di ruoli, ruoli server e funzionalità. Entrambe le opzioni della riga di comando consentono agli utenti di visualizzare i registri delle operazioni ed eseguire query per visualizzare elenchi di ruoli, ruoli server e funzionalità sia installati che disponibili per l'installazione in un computer.

È possibile utilizzare ServerManagerCmd.exe con un file di risposta XML per velocizzare installazioni o rimozioni automatiche ripetitive di ruoli o funzionalità. Per ulteriori informazioni sul file di risposta che è possibile utilizzare con ServerManagerCmd.exe, vedere Creare un file di risposta per comandi di Server Manager.

Nota

Servermanagercmd.exe è obsoleto e il supporto non è garantito nelle versioni future di Windows. È consigliabile utilizzare i cmdlet di Windows PowerShell disponibili per Server Manager.

In questo argomento

  • Strumenti da riga di comando di Server Manager, dism, pkgmgr e ocsetup

  • Cmdlet di Windows PowerShell per Server Manager

  • Comando di ServerManagerCmd.exe

  • Identificatori di comando per ruoli, servizi ruolo o funzionalità

Strumenti da riga di comando di Server Manager, dism, pkgmgr e ocsetup

Gli strumenti da riga di comando di Server Manager sono diversi dagli altri strumenti da riga di comando, ad esempio dism, pkgmgr e ocsetup, utilizzati per installare e rimuovere pacchetti software di Windows. È consigliabile utilizzare i cmdlet di Windows PowerShell per Server Manager o l'utilità da riga di comando ServerManagerCmd.exe per installare e rimuovere ruoli, ruoli server e funzionalità in un computer che esegue Windows Server 2008 R2.

Nell'elenco seguente vengono illustrate le differenze tra l'insieme di cmdlet e l'utilità da riga di comando di Server Manager e gli strumenti dism, pkgmgr e ocsetup, nonché i vantaggi degli strumenti da riga di comando di Server Manager per gli amministratori che desiderano distribuire un server con la maggiore efficienza possibile.

  • La riga di comando di Server Manager è coerente, per quanto riguarda funzionamento e terminologia, con le funzionalità di gestione e distribuzione della console di Server Manager nell'interfaccia utente di Windows Server 2008 R2.

  • I tipi di pacchetti o file in cui è incluso un ruolo, servizio ruolo o funzionalità non devono essere necessariamente noti agli utenti. Per la riga di comando di Server Manager è necessario solo il nome del ruolo, servizio ruolo o funzionalità che l'amministratore desidera installare o rimuovere. Non è necessario che gli amministratori forniscano percorsi o nomi di file dei pacchetti del ruolo, servizio ruolo o funzionalità.

  • Se gli amministratori utilizzano la riga di comando di Server Manager, non è necessario che specifichino le dipendenze tra ruoli, ruoli server e funzionalità. L'utilità da riga di comando di Server Manager consente di installare automaticamente tutti gli altri pacchetti software necessari per l'utilizzo del ruolo, servizio ruolo o funzionalità specificato nel comando.

  • Se si verificano problemi relativi a un'installazione o a una rimozione, la gestione degli errori di ServerManagercmd.exe semplifica la risoluzione dei problemi e offre azioni chiare all'utente.

  • Il parametro -whatIf di ServerManagercmd.exe consente agli utenti di verificare le azioni che verranno eseguite dai comandi prima dell'avvio dei comandi con la conseguente modifica del sistema. In dism, pkgmgr, and ocsetup non è disponibile un parametro di comando analogo.

  • Il cmdlet Get-WindowsFeature e il parametro -query di ServerManagerCmd.exe offrono agli utenti informazioni complete sui ruoli, ruoli server e funzionalità disponibili per l'installazione nel computer e su quelli attualmente installati. In dism, pkgmgr, and ocsetup non è disponibile un parametro analogo.

  • Sia l'input che output della riga di comando di Server Manager sono basati su XML. ServerManagercmd.exe accetta un file di risposta XML contenente le voci di ruoli, ruoli server e funzionalità da installare o rimuovere. È possibile esportare in file XML sia i risultati delle operazioni di installazione e rimozione sia i risultati del parametro -query, consentendo in tal modo scenari di automazione in cui altri software possono generare e interpretare i file XML utilizzati con l'utilità da riga di comando di Server Manager.

Cmdlet di Windows PowerShell per Server Manager

I cmdlet di Windows PowerShell per Server Manager accettano parametri per l'installazione o la rimozione di uno o più ruoli, ruoli server e funzionalità separati da virgole.

I tre cmdlet seguenti consentono di installare, rimuovere o visualizzare informazioni sui ruoli disponibili utilizzando Windows PowerShell. Per ulteriori informazioni ed esempi per l'utilizzo di tali cmdlet, in una sessione di Windows PowerShell in cui è caricato il modulo Server Manager immettere Get-Help cmdlet_name -full, dove cmdlet_name rappresenta uno dei valori seguenti.

  • Add-WindowsFeature Installa i ruoli, ruoli server e funzionalità specificati nel computer. Per ulteriori informazioni su come aggiungere ruoli, ruoli server e funzionalità utilizzando questo cmdlet, vedere Aggiungere ruoli del server e funzionalità.

  • Get-WindowsFeature Restituisce un elenco di tutti i ruoli, ruoli server e funzionalità disponibili per l'installazione nel computer e visualizza tramite caselle di controllo ([X]) quelli installati. Il cmdlet Get-WindowsFeature restituisce inoltre un elenco dei nomi di comando forniti nei cmdlet Add-WindowsFeature e Remove-WindowsFeature quando si desidera aggiungere o rimuovere ruoli, ruoli server e funzionalità. È possibile eseguire il piping dei risultati del cmdlet Get-WindowsFeature in uno degli altri due cmdlet di Server Manager o in cmdlet per l'esecuzione di analisi di Best Practice Analyzer, ad esempio.

  • Remove-WindowsFeature Rimuove i ruoli, ruoli server e funzionalità specificati dal computer. Per ulteriori informazioni su come rimuovere ruoli, ruoli server e funzionalità utilizzando questo cmdlet, vedere Rimuovere ruoli del server e funzionalità.

Vantaggi dei cmdlet di Windows PowerShell per Server Manager

I cmdlet di Windows PowerShell per Server Manager offrono alcuni vantaggi significativi rispetto al comando di ServerManagerCmd.exe.

  • Dopo l'installazione di Windows PowerShell e dell'insieme di cmdlet di Server Manager tramite dism, pkgmgr o ocsetup, Windows PowerShell, è possibile eseguire i cmdlet in un computer che esegue l'opzione di installazione Server Core di Windows Server 2008 R2. Le istruzioni per l'installazione di Windows PowerShell e dell'insieme di cmdlet di Server Manager con l'opzione di installazione Server Core di Windows Server 2008 R2 sono disponibili nella pagina relativa a installazione, accesso e rimozione di Strumenti di migrazione per Windows Server (http://go.microsoft.com/fwlink/?LinkId=134763).

  • I cmdlet e gli strumenti di Windows PowerShell sono disponibili per l'esecuzione di attività di gestione dopo l'installazione di un ruolo, servizio ruolo o funzionalità. Per ulteriori informazioni sui ruoli, ruoli server e funzionalità che è possibile gestire utilizzando gli strumenti di Windows PowerShell, vedere la pagina relativa ai moduli di Windows PowerShell (http://go.microsoft.com/fwlink/?LinkId=141216).

Requisiti per l'utilizzo dei cmdlet di Server Manager

Per eseguire qualsiasi cmdlet di Windows PowerShell correlato a Server Manager, è necessario eseguire Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

Per poter utilizzare i cmdlet di Server Manager è inoltre necessario caricare il modulo Server Manager in ogni sessione nuova di Windows PowerShell. A tale scopo, in una sessione di Windows PowerShell aperta con diritti utente elevati, digitare Import-Module Servermanager e quindi premere INVIO.

Nota

Per ulteriori informazioni su come avviare una sessione di Windows PowerShell con tutti i moduli e gli snap-in installati caricati automaticamente, vedere Avviare Windows PowerShell con tutti i moduli caricati.

Sintassi dei cmdlet di Server Manager

Add-WindowsFeature [-Name] <string[]> [-IncludeAllSubFeature] [-logPath <string>] [-WhatIf] [-Restart] [-Concurrent] [<CommonParameters>]

Get-WindowsFeature [[-Name] <string[]>] [-logPath <string>] [<CommonParameters>]

Remove-WindowsFeature [-Name] <string[]> [-logPath <string>] [-WhatIf] [-Restart] [-Concurrent] [<CommonParameters>]

Parametri

In questa sezione vengono descritti i parametri dei cmdlet Add-WindowsFeature, Get-WindowsFeature e Remove-WindowsFeature.

  • Add-WindowsFeature

  • Get-WindowsFeature

  • Remove-WindowsFeature

Add-WindowsFeature

Parametro Descrizione

-name <string[]>

Specifica l'ID di comando di ruoli, servizi ruolo o funzionalità che si desidera installare utilizzando il cmdlet Add-WindowsFeature. In alternativa, è accettata anche una matrice di oggetti Feature.

Un elenco di ID di comando di tutti i ruoli, servizi ruolo e funzionalità è disponibile in questo argomento oppure eseguendo il cmdlet Get-WindowsFeature.

-IncludeAllSubFeature

Specifica l'installazione di tutti i servizi e le funzionalità subordinati, insieme al ruolo, al servizio ruolo o alla funzionalità padre nominato nel parametro Name.

-logPath <string>

Specifica un nome e un percorso per il file di registro diversi da quelli predefiniti, ovvero %windir%\logs\ServerManager.log.

-WhatIf

Visualizza le operazioni specificate per il cmdlet Add-WindowsFeature, ad esempio le funzionalità di Windows che vengono installate in quanto il ruolo, il servizio ruolo o la funzionalità che si desidera installare dipende da esse. Aggiungendo il parametro -WhatIf al cmdlet Add-WindowsFeature è possibile eseguire il cmdlet senza eseguire un'installazione effettiva. Viene solo indicato cosa verrebbe installato e quali sarebbero i risultati dell'esecuzione del cmdlet.

-Restart

Riavvia il computer automaticamente al termine dell'installazione nel caso in cui il riavvio sia richiesto dalle funzionalità o dai ruoli installati.

-Concurrent

Consente l'esecuzione di istanze simultanee del cmdlet di Server Manager Add-WindowsFeature o Remove-WindowsFeature.

Importante

Non aggiungere questo parametro a meno che non si stiano installando ruoli, servizi ruolo o funzionalità scaricati separatamente da Windows Server 2008 R2 e non si desideri installare contemporaneamente funzionalità di Windows da cui dipende la tecnologia scaricata.

<CommonParameters>

Questo cmdlet supporta i parametri comuni -Verbose, -Debug, -ErrorAction, -ErrorVariable, -WarningAction, -WarningVariable, -OutBuffer e -OutVariable. Per ulteriori informazioni sui parametri comuni, nella sessione di Windows PowerShell digitare get-help about_commonparameters e quindi premere INVIO.

Get-WindowsFeature

Parametro Descrizione

-name <string[]>

Specifica l'ID di comando di ruoli, servizi ruolo o funzionalità per i quali si desidera visualizzare informazioni.

Un elenco di ID di comando di tutti i ruoli, servizi ruolo e funzionalità è disponibile in questo argomento oppure eseguendo il cmdlet Get-WindowsFeature senza parametri.

-logPath <string>

Specifica un nome e un percorso per il file di registro diversi da quelli predefiniti, ovvero %windir%\logs\ServerManager.log. Aggiungere questo parametro se si desidera che i risultati del cmdlet Get-WindowsFeature vengano archiviati in un registro.

<CommonParameters>

Questo cmdlet supporta i parametri comuni -Verbose, -Debug, -ErrorAction, -ErrorVariable, -WarningAction, -WarningVariable, -OutBuffer e -OutVariable. Per ulteriori informazioni sui parametri comuni, nella sessione di Windows PowerShell digitare get-help about_commonparameters e quindi premere INVIO.

Remove-WindowsFeature

Parametro Descrizione

-name <string[]>

Specifica l'ID di comando di ruoli, servizi ruolo o funzionalità che si desidera rimuovere utilizzando il cmdlet Remove-WindowsFeature. In alternativa, è accettata anche una matrice di oggetti Feature.

Un elenco di ID di comando di tutti i ruoli, servizi ruolo e funzionalità è disponibile in questo argomento oppure eseguendo il cmdlet Get-WindowsFeature.

-logPath <string>

Specifica un nome e un percorso per il file di registro diversi da quelli predefiniti, ovvero %windir%\logs\ServerManager.log.

-WhatIf

Visualizza le operazioni specificate per il cmdlet Remove-WindowsFeature. Aggiungendo il parametro -WhatIf al cmdlet Remove-WindowsFeature è possibile eseguire il cmdlet senza eseguire una rimozione effettiva. Viene solo indicato cosa verrebbe rimosso e quali sarebbero i risultati dell'esecuzione del cmdlet.

-Restart

Riavvia il computer automaticamente al termine della rimozione nel caso in cui il riavvio sia necessario.

-Concurrent

Consente l'esecuzione di istanze simultanee del cmdlet di Server Manager Add-WindowsFeature o Remove-WindowsFeature.

<CommonParameters>

Questo cmdlet supporta i parametri comuni -Verbose, -Debug, -ErrorAction, -ErrorVariable, -WarningAction, -WarningVariable, -OutBuffer e -OutVariable. Per ulteriori informazioni sui parametri comuni, nella sessione di Windows PowerShell digitare get-help about_commonparameters e quindi premere INVIO.

Comando di ServerManagerCmd.exe

L'installazione dalla riga di comando di Server Manager accetta i parametri per installare o rimuovere uno o più ruoli, ruoli server e funzionalità separati da spazi. Per installare o rimuovere più ruoli, servizi ruolo o funzionalità in un server tramite una singola istanza di comando, è inoltre possibile utilizzare un file di risposta XML, soprattutto se si desidera configurare più server nello stesso modo. Per ulteriori informazioni sul file di risposta che è possibile utilizzare con ServerManagerCmd.exe, vedere Creare un file di risposta per comandi di Server Manager.

Nota

È possibile eseguire ServerManagerCmd.exe da qualsiasi directory nelle unità locali del server. È necessario essere membri del gruppo Administrators nel server in cui si desidera installare o rimuovere software.

Importante

A causa delle restrizioni di sicurezza imposte dalla funzionalità Controllo dell'account utente in Windows Server 2008 R2, è necessario eseguire ServerManagerCmd.exe in una finestra del prompt dei comandi aperta con autorizzazioni elevate. A tale scopo, fare clic con il pulsante destro del mouse sull'eseguibile di Prompt dei comandi oppure sull'oggetto Command Prompt nel menu Start e quindi scegliere Run as administrator.

Sintassi di ServerManagerCmd.exe

ServerManagerCmd.exe -query [<query.xml>] [-logPath <log.txt>]

ServerManagerCmd.exe -inputPath <answer.xml> [-resultPath <result.xml> [-restart] | -whatIf] [-logPath <log.txt>]

ServerManagerCmd.exe -install <command-Id> [-setting <setting-name>=<setting value>]* [-allSubFeatures] [-resultPath <result.xml> [-restart] | -whatIf] [-logPath <log.txt>]

ServerManagerCmd.exe -remove <command-Id> [-resultPath <result.xml> [-restart] | -whatIf] [-logPath <log.txt>]

ServerManagerCmd.exe [-help | -?]

ServerManagerCmd.exe -version

Parametri

Parametro Descrizione

-query [<query.xml>]

Visualizza un elenco di tutti i ruoli, ruoli server e funzionalità installati e disponibili per l'installazione nel server. È inoltre possibile utilizzare il formato breve del parametro, ovvero -q.

Se si desidera che i risultati della query vengano salvati in un file XML, specificare un file XML per sostituire query.xml.

Nota

I risultati del parametro -query non possono essere utilizzati come file di risposta con il parametro -inputPath. Il codice XML utilizzato dai risultati di -query e quello necessario in un file di risposta di Servermanagercmd.exe non vengono convalidati nello stesso schema.

-inputPath <answer.xml>

Installa o rimuove i ruoli, ruoli server e funzionalità specificati in un file di risposta, un file XML rappresentato da answer.xml. È inoltre possibile utilizzare il formato breve del parametro, ovvero -p.

Per ulteriori informazioni sulla creazione di un file di risposta da utilizzare con questo parametro, vedere Creare un file di risposta per comandi di Server Manager.

-install <Id>

Installa il ruolo, servizio ruolo o funzionalità specificato da Id. Per un elenco completo degli identificatori di ruolo, servizio ruolo o funzionalità tra cui è possibile scegliere per specificare l'Id, vedere Identificatori di comando per ruoli, servizi ruolo o funzionalità in questo argomento. Per gli identificatori non viene fatta distinzione tra maiuscole e minuscole. Se si immettono più ruoli, ruoli server e funzionalità, sarà necessario separarli con spazi.

Con il parametro -install vengono utilizzati i parametri facoltativi seguenti.

  • -setting <setting name>=<setting value> - Specifica le impostazioni necessarie per l'installazione. Per un elenco completo delle impostazioni disponibili, vedere Identificatori di comando per ruoli, servizi ruolo o funzionalità in questo argomento.

  • -allSubFeatures - Specifica l'installazione di tutti i servizi e le funzionalità subordinati insieme al ruolo, servizio ruolo o funzionalità padre indicato nel parametro Id del comando -install. Si noti che alcuni contenitori di ruoli non dispongono di un identificatore della riga di comando per consentire l'installazione di tutti i servizi ruolo. In questo caso non è possibile installare i servizi ruolo nella stessa istanza del comando di Server Manager. Ad esempio, il servizio ruolo Servizio federativo di Active Directory Federation Services e il servizio ruolo Proxy servizio federativo non possono essere installati utilizzando la stessa istanza del comando di Server Manager.

  • -resultPath <result.xml> - Salva i risultati dell'installazione in un file XML rappresentato da result.xml. È inoltre possibile utilizzare il formato breve del parametro, ovvero -w. Non è possibile utilizzare il parametro -resultPath e il parametro -whatIf nella stessa istanza di ServerManagerCmd.exe.

  • -restart - Se si aggiunge il parametro -restart al comando -install, riavvia il computer automaticamente al termine dell'installazione nel caso in cui il riavvio sia richiesto dalle funzionalità o dai ruoli installati.

  • -whatIf - È possibile utilizzare -whatIf per visualizzare le operazioni specificate per il comando -install. È inoltre possibile utilizzare il formato breve del parametro -whatIf, ovvero -w. Non è possibile utilizzare il parametro -resultPath e il parametro -whatIf nella stessa istanza di ServerManagerCmd.exe.

  • -logPath <log.txt> - Utilizzare -logPath per specificare un nome e un percorso per il file di registro diversi da quelli predefiniti, ovvero %windir%\temp\servermanager.log.

-remove <Id>

Rimuove il ruolo, servizio ruolo o funzionalità specificato da Id. Per un elenco completo degli identificatori di ruolo, servizio ruolo o funzionalità tra cui è possibile scegliere per specificare l'Id, vedere Identificatori di comando per ruoli, servizi ruolo o funzionalità in questo argomento. Per gli identificatori non viene fatta distinzione tra maiuscole e minuscole. Se si immettono più ruoli, ruoli server e funzionalità, è necessario separarli con spazi.

Con il parametro -remove vengono utilizzati i parametri facoltativi seguenti.

  • -resultPath <result.xml> - Salva i risultati della rimozione in un file XML rappresentato da result.xml. È inoltre possibile utilizzare il formato breve del parametro, ovvero -r. Non è possibile utilizzare il parametro -resultPath e il parametro -whatIf nella stessa istanza di ServerManagerCmd.exe.

  • -restart - Se si aggiunge il parametro -restart al comando -remove, riavvia il computer automaticamente al termine della rimozione nel caso in cui il riavvio sia richiesto dalle funzionalità o dai ruoli rimanenti.

  • -whatIf - È possibile utilizzare -whatIf per visualizzare le operazioni specificate per il comando -remove. È inoltre possibile utilizzare il formato breve del parametro -whatIf, ovvero -w. Non è possibile utilizzare il parametro -resultPath e il parametro -whatIf nella stessa istanza di ServerManagerCmd.exe.

  • -logPath <log.txt> - Utilizzare -logPath per specificare un nome e un percorso per il file di registro diversi da quelli predefiniti, ovvero %windir%\temp\servermanager.log.

-help

Visualizza la Guida di ServerManagerCmd.exe nella finestra del prompt dei comandi. È inoltre possibile utilizzare il formato breve, ovvero -?.

-version

Visualizza il numero di versione di Server Manager. È inoltre possibile utilizzare il formato breve, ovvero -v.

Osservazioni su ServerManagerCmd.exe

ServerManagerCmd.exe non supporta la configurazione o la gestione di ruoli e funzionalità dopo la relativa installazione. Per le installazioni di ruoli e funzionalità completate tramite ServerManagerCmd.exe vengono utilizzate le impostazioni predefinite. Per modificare impostazioni di ruoli o funzionalità, eseguire attività di amministrazione dei ruoli oppure visualizzare stati o eventi relativi a ruoli e funzionalità, è consigliabile utilizzare la console di Server Manager basata sull'interfaccia utente grafica di Windows. Potrebbe essere necessario aprire altri snap-in di gestione per il ruolo, oppure utilizzare strumenti da riga di comando specifici del ruolo e della funzionalità per la gestione e la configurazione di determinati ruoli, ruoli server e funzionalità.

Nota

Sebbene le installazioni di ruoli e funzionalità siano sicure per impostazione predefinita, è consigliabile utilizzare la console di Server Manager per modificare le impostazioni predefinite in modo che siano conformi ai criteri di sicurezza dell'organizzazione. Non è possibile utilizzare ServerManagerCmd.exe per installare e configurare applicazioni diverse da ruoli, ruoli server e funzionalità di Windows Server 2008 R2. ServerManagerCmd.exe non è supportato nei computer che eseguono un'installazione Server Core di Windows Server 2008 R2. Non è possibile utilizzare ServerManagerCmd.exe per l'installazione o la rimozione di ruoli, ruoli server e funzionalità in computer remoti.

Esempi relativi a ServerManagerCmd.exe

Di seguito vengono riportati alcuni esempi di utilizzo dei comandi di Server Manager.

Eseguire query relative a ruoli e funzionalità installati nel computer

Nell'esempio seguente viene illustrata la sintassi di ServerManagerCmd.exe per l'esecuzione di una query che consente di determinare i ruoli, ruoli server e funzionalità installati in un computer e quelli disponibili per l'installazione. In questo esempio, l'amministratore specifica in Server Manager l'istruzione per salvare i risultati della query nel file C:\queryResults.xml.

ServerManagerCmd.exe -query C:\queryResults.xml

Installare un ruolo senza un file di risposta

Nell'esempio seguente viene illustrata la sintassi di ServerManagerCmd.exe per l'installazione di Web Server (IIS) e di tutti i relativi servizi ruolo. L'amministratore esporta i risultati dell'installazione in un file XML denominato ServerWeb.xml e specifica in Server Manager l'istruzione per riavviare automaticamente il computer al termine dell'installazione, se richiesto dal ruolo.

ServerManagerCmd.exe -install Web-Server -allSubFeatures -resultPath C:\Admin\WebServer.xml -restart

Rimuovere funzionalità utilizzando un file di risposta e il comando di ServerManagerCmd.exe

Per reimpiegare diversi server rimuovendo alcuni ruoli, un amministratore utilizza il comando seguente. I comandi per i ruoli da rimuovere vengono specificati in un file di risposta denominato RemoveFilePrint.xml. L'amministratore ha aggiunto l'opzione -whatIf al comando per visualizzarne le operazioni specificate nel file di risposta removalresults.xml e indicare se è stato rimosso anche software che dipende dagli elementi specificati per la rimozione nel file di risposta.

ServerManagerCmd.exe -inputPath C:\AdminFiles\RemoveFilePrint.xml -resultPath C:\AdminFiles\removalresults.xml -whatIf

Identificatori di comando per ruoli, servizi ruolo o funzionalità

Nella tabella contenuta in questa sezione viene indicata la corrispondenza tra ruoli, ruoli server e funzionalità disponibili in Windows Server 2008 R2 e gli identificatori di comando che è necessario utilizzare con ServerManagerCmd.exe per installarli o rimuoverli.

  • Identificatori di comando per ruoli e servizi ruolo

  • Identificatori di comando per funzionalità

Identificatori di comando per ruoli e servizi ruolo

Identificatori di comando di Servizi certificati Active Directory | Valore del comando | Note
Servizi certificati Active Directory | AD-Certificate | L'Autorità di certificazione e il Protocollo di stato del certificato online possono essere installati tramite l'interfaccia della riga di comando di Server Manager. Gli altri servizi ruolo per Servizi certificati Active Directory non possono essere installati tramite la riga di comando di Server Manager.
Autorità di certificazione | ADCS-Cert-Authority
Registrazione Web Autorità di certificazione (non installabile tramite la riga di comando) | ADCS-Web-Enrollment
Risponditore in linea | ADCS-Online-Cert
Servizio Registrazione dispositivi di rete | ADCS-Device-Enrollment
Servizio Web di registrazione certificati | ADCS-Enroll-Web-Svc
Servizio Web di informazioni sulle registrazioni di certificati | ADCS-Enroll-Web-Pol

Identificatori di comando di Servizi dei domini Active Directory Valore del comando Note

Servizi dei domini Active Directory

AD-Domain-Services

Dopo avere installato Servizi dei domini Active Directory (AD DS), è necessario eseguire il comando dcpromo.

Non è possibile rimuovere il ruolo AD DS mentre il computer svolge la funzione di controller di dominio. È innanzitutto necessario rimuovere Servizi di dominio Active Directory dal controller di dominio.

Controller di dominio Active Directory

ADDS-Domain-Controller

Identity Management for UNIX

ADDS-Identity-Mgmt

Server per Network Information Services

ADDS-NIS

Sincronizzazione password

ADDS-Password-Sync

Strumenti di amministrazione per Identity Management for UNIX

ADDS-IDMU-Tools

Identificatori di comando di Active Directory Federation Services | Valore del comando | Note
Active Directory Federation Services | AD-Federation-Services | È consigliabile installare Active Directory Federation Services con le impostazioni predefinite.
Servizio federativo | ADFS-Federation
Proxy servizio federativo | ADFS-Proxy
Agenti Web | ADFS-Web-Agents
Agente in grado di riconoscere attestazioni | ADFS-Claims
Agente basato su token Windows | ADFS-Windows-Token

Identificatori di comando di Active Directory Lightweight Directory Services | Valore del comando | Note
Active Directory Lightweight Directory Services | ADLDS | Nessuna

Identificatori di comando di Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD) | Valore del comando | Note
Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD) | ADRMS | Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD) non può essere installato tramite la riga di comando di Server Manager.
Server AD RMS (Active Directory Rights Management Services) | ADRMS-Server
Supporto federazione identità | ADRMS-Identity

Identificatori di comando del server applicazioni | Valore del comando | Note
Server applicazioni | Application-Server | Se si installa il servizio ruolo WS-Atomic Transactions tramite la riga di comando di Server Manager, WS-Atomic Transactions verrà configurato per impostazione predefinita per l'utilizzo di un certificato autofirmato.
Application Server Foundation | AS-AppServer-Foundation
Supporto server Web (IIS) | AS-Web-Support
Accesso alla rete COM+ | AS-Ent-Services
Condivisione porta TCP | AS-TCP-Port-Sharing
Supporto per il servizio Attivazione processo Windows | AS-WAS-Support
Attivazione HTTP | AS-HTTP-Activation
Attivazione Accodamento messaggi | AS-MSMQ-Activation
Attivazione TCP | AS-TCP-Activation
Attivazione tramite named pipe | AS-Named-Pipes
Transazioni distribuite | AS-Dist-Transaction
Transazioni remote in ingresso | AS-Incoming-Trans
Transazioni remote in uscita | AS-Outgoing-Trans
WS-Atomic Transactions | AS-WS-Atomic

Identificatori di comando del server DHCP | Valore del comando | Note
Server DHCP | DHCP | È consigliabile installare il ruolo di server DHCP con le impostazioni predefinite.

Identificatori di comando del server DNS | Valore del comando | Note
Server DNS | DNS | Nessuna

Identificatori di comando di Server fax | Valore del comando | Note
Server fax | Fax | È consigliabile installare Server fax con le impostazioni predefinite.

Identificatori di comando di Servizi file Valore del comando Note

Servizi file

Servizi file

Non è possibile installare o rimuovere il contenitore Servizi file tramite la riga di comando di Server Manager. È possibile installare o rimuovere il contenitore Servizi file esclusivamente tramite l'interfaccia utente di Server Manager. Si noti che, per tale motivo, non è disponibile alcun ID di comando per rappresentare il contenitore Servizi file.

Poiché è possibile configurare le impostazioni di Servizi file dopo aver installato il ruolo, non è necessario specificare le impostazioni di Servizi file nel file di risposta della riga di comando di Server Manager.

File server

FS-Fileserver

File system distribuito (DFS)

FS-DFS

Spazio dei nomi DFS

FS-DFS-Namespace

Replica DFS

FS-DFS-Replication

Gestione risorse file server

FS-Resource-Manager

Servizi per NFS (Network File System)

FS-NFS-Services

Servizio Ricerca di Windows

FS-Search-Service

Servizi file di Windows Server 2003

FS-Win2003-Services

BranchCache per file remoti

FS-BranchCache

Servizio di indicizzazione

FS-Indexing-Service

Identificatori di comando di Hyper-V™ | Valore del comando | Note
Hyper-V™ | Hyper-V |

Identificatori di comando di Servizi di accesso e criteri di rete | Valore del comando | Note
Servizi di accesso e criteri di rete | NPAS | Poiché le impostazioni di Servizi di accesso e criteri di rete possono essere configurate dopo l'installazione del ruolo, non è necessario specificare tali impostazioni nel file di risposta della riga di comando.
Server dei criteri di rete | NPAS-Policy-Server
Servizio Routing e Accesso remoto NPAS | NPAS-RRAS-Services
Servizio di accesso remoto | NPAS-RRAS
Routing | NPAS-Routing
Autorità registrazione integrità | NPAS-Health
Host Credential Authorization Protocol | NPAS-Host-Cred

Identificatori di comando di Servizi di stampa e digitalizzazione | Valore del comando | Note
Servizi di stampa e digitalizzazione | Print-Services | Durante la rimozione di questo ruolo nell'interfaccia utente di Server Manager, viene richiesto di eliminare le istanze delle stampanti configurate nel server. Per impostazione predefinita, tali istanze vengono mantenute, come avviene in base al comportamento predefinito della rimozione da riga di comando del ruolo Servizi di stampa e digitalizzazione.
Server di stampa | Print-Server
Stampa Internet | Print-Internet
Servizio LPD | Print-LPD-Service
Server Digitalizzazione distribuita | Print-Scan-Server

Identificatori di comando di Servizi Desktop remoto | Valore del comando | Note
Servizi Desktop remoto | Remote-Desktop-Services | Poiché le impostazioni di Servizi Desktop remoto possono essere configurate dopo l'installazione del ruolo, non è necessario specificare tali impostazioni nel file di risposta della riga di comando.
Server Desktop remoto | RDS-RD-Server
Servizio licenze Desktop remoto | RDS-Licensing
Gateway Desktop remoto | RDS-Gateway
Accesso Web RemoteApp e desktop | RDS-Web-Access
Gestore connessione Desktop remoto | RDS-Connection-Broker
Virtualizzazione Desktop remoto | RDS-Virtualization

Identificatori di comando di Web Server (IIS) | Valore del comando | Note
Web Server (IIS) | Web-Server | Nessuna
Internet Information Services (Server Web) | Web-WebServer |
Funzionalità HTTP comuni | Web-Common-Http |
Contenuto statico | Web-Static-Content |
Documento predefinito | Web-Default-Doc |
Esplorazione directory | Web-Dir-Browsing |
Errori HTTP | Web-Http-Errors |
Reindirizzamento HTTP | Web-Http-Redirect |
Pubblicazione WebDAV | Web-DAV-Publishing |
Sviluppo applicazioni | Web-App-Dev |
ASP.NET | Web-Asp-Net |
Estendibilità .NET | Web-Net-Ext |
ASP | Web-ASP |
CGI | Web-CGI |
Estensioni ISAPI | Web-ISAPI-Ext |
Filtri ISAPI | Web-ISAPI-Filter |
Server Side Includes | Web-Includes |
Integrità e diagnostica | Web-Health |
Registrazione HTTP | Web-Http-Logging |
Strumenti di registrazione | Web-Log-Libraries |
Monitor richieste | Web-Request-Monitor |
Traccia | Web-Http-Tracing |
Registrazioni personalizzate | Web-Custom-Logging |
Registrazione ODBC | Web-ODBC-Logging |
Sicurezza | Web-Security |
Autenticazione di base | Web-Basic-Auth |
Autenticazione di Windows | Web-Windows-Auth |
Autenticazione del digest | Web-Digest-Auth |
Autenticazione mapping certificati client | Web-Client-Auth |
Autenticazione mapping certificati client IIS | Web-Cert-Auth |
Autorizzazione URL | Web-Url-Auth |
Filtro richieste | Web-Filtering |
Restrizioni per IP e domini | Web-IP-Security |
Prestazioni | Web-Performance |
Compressione contenuto statico | Web-Stat-Compression |
Compressione dinamica del contenuto | Web-Dyn-Compression |
Strumenti di gestione | Web-Mgmt-Tools |
Console di gestione IIS | Web-Mgmt-Console |
Strumenti e script di gestione IIS | Web-Scripting-Tools |
Servizio di gestione | Web-Mgmt-Service |
Compatibilità gestione IIS 6 | Web-Mgmt-Compat |
Compatibilità metabase IIS 6 | Web-Metabase |
Compatibilità WMI con IIS 6 | Web-WMI |
Strumenti di scripting di IIS 6 | Web-Lgcy-Scripting |
Console di gestione IIS 6 | Web-Lgcy-Mgmt-Console |
Server FTP | Web-Ftp-Server |
Servizio FTP | Web-Ftp-Service |
Estendibilità FTP | Web-Ftp-Ext |

Identificatori di comando di Servizi di distribuzione Windows | Valore del comando | Note
Servizi di distribuzione Windows | WDS | Nessuna
Server di distribuzione | WDS-Deployment
Server di trasporto | WDS-Transport

Identificatori di comando di Windows Server Update Services | Valore del comando | Note
Windows Server Update Services | OOB-WSUS |

Identificatori di comando delle funzionalità

Funzionalità Valore del comando Note

BITS (Servizio trasferimento intelligente in background)

BITS

  • BITS Compact Server

BITS-LWDLServer

  • Estensione del server IIS

BITS-IIS-Ext

Crittografia unità BitLocker

BitLocker

Windows BranchCache

BranchCache

Connection Manager Administration Kit

CMAK

Esperienza desktop

Desktop-Experience

Console di gestione Accesso diretto

DAMC

Clustering di failover

Failover-Clustering

Gestione Criteri di gruppo

GPMC

Servizi di riconoscimento della grafia

Ink-Handwriting

  • Supporto input penna

IH-Ink-Support

  • Riconoscimento grafia

IH-Handwriting

Client di stampa Internet

Internet-Print-Client

Internet Storage Name Server

ISNS

Monitor porta LPR

LPR-Port-Monitor

Accodamento messaggi

MSMQ
  • Servizi Accodamento messaggi

MSMQ-Services

  • Server di Accodamento messaggi

MSMQ-Server

  • Integrazione servizio directory

MSMQ-Directory

  • Trigger Accodamento messaggi

MSMQ-Triggers

  • Supporto HTTP

MSMQ-HTTP-Support

  • Supporto multicast

MSMQ-Multicasting

  • Servizio di routing

MSMQ-Routing

  • Proxy DCOM di Accodamento messaggi

MSMQ-DCOM

Multipath I/O

Multipath-IO

Bilanciamento carico di rete

NLB

Funzionalità di .NET Framework 3.5.1

NET-Framework

Si noti che la sintassi della riga di comando per Funzionalità di .NET Framework 3.5.1 non contiene il carattere "." prima di NET.

  • .NET Framework 3.5.1

NET-Framework-Core

  • Attivazione di Windows Communication Foundation (WCF)

NET-Win-CFAC

  • Attivazione HTTP

NET-HTTP-Activation

  • Attivazione non HTTP

NET-Non-HTTP-Activ

Peer Name Resolution Protocol

PNRP

Servizio audio/video Windows di qualità

Qwave

Assistenza remota

Remote-Assistance

Remote Differential Compression

RDC

Strumenti di amministrazione server remoto

RSAT

  • Strumenti di amministrazione ruoli

RSAT-Role-Tools

  • Strumenti Servizi certificati Active Directory

RSAT-ADCS

  • Strumenti per Autorità di certificazione

RSAT-ADCS-Mgmt

  • Strumenti per Risponditore in linea

RSAT-Online-Responder

  • Strumenti per Servizi di dominio Active Directory e AD LDS

RSAT-AD-Tools

  • Strumenti di Servizi di dominio Active Directory

RSAT-ADDS

  • Snap-in e strumenti da riga di comando di Servizi di dominio Active Directory

RSAT-ADDS-Tools

  • Centro di amministrazione di Active Directory

RSAT-AD-AdminCenter

  • Strumenti per Server per NIS

RSAT-SNIS

  • Strumenti Active Directory Lightweight Directory Services

RSAT-ADLDS

  • Snap-in Active Directory PowerShell

RSAT-AD-PowerShell

  • Strumenti Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD)

RSAT-RMS

  • Strumenti server DHCP

RSAT-DHCP

  • Strumenti server DNS

RSAT-DNS
  • Server fax Strumenti

RSAT-Fax

  • Strumenti per Servizi file

RSAT-File-Services

  • Strumenti per File system distribuito

RSAT-DFS-Mgmt-Con
  • Strumenti per Gestione risorse file server

RSAT-FSRM-Mgmt
  • Strumenti per Servizi per NFS (Network File System)

RSAT-NFS-Admin
  • Strumenti Hyper-V

RSAT-Hyper-V
  • Strumenti Servizi di accesso e criteri di rete

RSAT-NPAS
  • Strumenti per Servizi di stampa e digitalizzazione

RSAT-Print-Services
  • Strumenti per Servizi Desktop remoto

RSAT-RDS
  • Strumenti per server desktop remoto

RSAT-RDS-RemoteApp

  • Strumenti per Gateway Desktop remoto

RSAT-RDS-Gateway
  • Strumenti per Servizio licenze Desktop remoto

RSAT-RDS-Licensing
  • Strumenti per Gestore connessione Desktop remoto

RSAT-TS-Session-Broker
  • Web Server (IIS) Strumenti

RSAT-Web-Server
  • Strumenti Servizi di distribuzione Windows

RSAT-WDS

Strumenti di amministrazione delle funzionalità di Strumenti di amministrazione server remoto

RSAT-Feature-Tools
  • Strumenti di amministrazione per Crittografia unità BitLocker

RSAT-BitLocker
  • Strumenti Crittografia unità BitLocker

RSAT-Bitlocker-DriveEnc
  • Visualizzatore password di ripristino BitLocker

RSAT-Bitlocker-RecPwd
  • Strumenti Estensioni del server BITS

RSAT-BITS-Server
  • Strumenti Clustering di failover

RSAT-Clustering
  • Strumenti Bilanciamento carico di rete

RSAT-NLB
  • Strumenti Server SMTP

RSAT-SMTP
  • Strumenti Server WINS

RSAT-WINS

Proxy RPC su HTTP

RPC-over-HTTP-Proxy

Servizi TCP/IP semplificati

Simple-TCPIP

Server SMTP

SMTP-Server

Servizi SNMP

SNMP-Services
  • Servizio SNMP

SNMP-Service

  • Provider WMI per SNMP

SNMP-WMI-Provider

Gestione archivi SAN

Storage-Mgr-SANS

Subsystem for UNIX-based Applications

Subsystem-UNIX-Apps

Client Telnet

Telnet-Client

Server Telnet

Telnet-Server

Client TFTP

TFTP-Client

Windows Biometric Framework

Biometric-Framework

Database interno di Windows

Windows-Internal-DB

Windows PowerShell ISE

PowerShell-ISE

Servizio Attivazione processo Windows

WAS
  • Modello di processo

WAS-Process-Model

  • Ambiente .NET

WAS-NET-Environment

  • API di configurazione

WAS-Config-APIs

Funzionalità di Windows Server Backup

Funzionalità di backup
  • Windows Server Backup

Backup

  • Strumenti della riga di comando

Strumenti di backup

  • Cmdlet per Windows Server Backup

Cmdlet di backup

Strumenti di migrazione per Windows Server

Migration

Gestione risorse di sistema Windows

WSRM

IFilter TIFF di Windows

TIFF-iFilter

Estensione IIS di Gestione remota Windows

WinRM-IIS-Ext

Server WINS

WINS-Server

Servizio LAN wireless

Wireless-Networking

Visualizzatore XPS

XPS-Viewer

Vedere anche

  • Interpretare l'output dei comandi di Server Manager
  • Aggiungere ruoli del server e funzionalità
  • Rimuovere ruoli del server e funzionalità
  • Area dedicata agli script Windows


Creare un file di risposta per comandi di Server Manager

Nota

Servermanagercmd.exe è obsoleto e il supporto non è garantito nelle versioni future di Windows. È consigliabile utilizzare i cmdlet di Windows PowerShell disponibili per Server Manager.

L'installazione dalla riga di comando di Server Manager in Windows Server® 2008 R2 accetta parametri per installare o rimuovere un singolo ruolo, servizio ruolo o funzionalità per ogni istanza di comando. Per installare o rimuovere più ruoli, servizi ruolo o funzionalità in un server tramite una singola istanza di comando, utilizzare un file di risposta XML.

In Windows Server 2008 R2 gli utenti creano file di risposta da zero. Il file di risposta offre le informazioni seguenti all'interfaccia della riga di comando di Server Manager:

  • ruoli, ruoli server e funzionalità che gli utenti desiderano installare o rimuovere da un server

  • Impostazioni di configurazione necessarie per completare l'installazione di ruoli, ruoli server o funzionalità

Dipendenze di ruoli, servizi ruolo e funzionalità

Quando si installano o si rimuovono ruoli, servizi ruolo o funzionalità tramite l'interfaccia grafica di Server Manager, l'Aggiunta guidata ruoli verifica che tutto il software necessario per un ruolo venga installato insieme al ruolo selezionato nella procedura guidata. Se necessario, la procedura guidata richiede all'utente di approvare l'installazione di altri ruoli, ruoli server o funzionalità necessari per i ruoli selezionati.

Lo stesso processo di verifica viene eseguito quando si utilizza la riga di comando di Server Manager. Per installare o rimuovere solo componenti specifici di ruoli o funzionalità, è necessario specificare solo tali componenti. Non è necessario specificare tutti i ruoli e i servizi ruolo necessari per i servizi ruolo da installare, in quanto Server Manager installa o rimuove automaticamente il software da cui dipende il servizio ruolo desiderato.

Importante

Quando si rimuovono i ruoli utilizzando un file di risposta, Server Manager rimuove automaticamente tutti i ruoli e i servizi ruolo che dipendono da un ruolo o un servizio ruolo specificato nel file di risposta. Se si aggiunge il parametro -whatIf al comando di Server Manager, verrà visualizzato un elenco di tutti i ruoli e i servizi ruolo che sono stati rimossi in seguito alla rimozione di un ruolo o servizio ruolo specificato nel file di risposta.

Se ad esempio si desidera installare Stampa Internet, un servizio ruolo di Servizi di stampa e digitalizzazione, nel file di risposta è necessario specificare solo Stampa Internet e non Web Server (IIS) né servizi ruolo specifici di Web Server (IIS). Per impostazione predefinita, Server Manager installa i componenti di Web Server (IIS) (un altro ruolo) necessari per l'esecuzione di Stampa Internet. Si supponga di voler rimuovere il servizio ruolo Gateway Desktop remoto di Servizi Desktop remoto dallo stesso server utilizzando lo stesso file di risposta. Anche per l'esecuzione di Gateway Desktop remoto sono richiesti componenti di Web Server (IIS). Tramite Server Manager vengono rimossi solo i servizi ruolo di Web Server (IIS) non necessari né per l'esecuzione di Gateway Desktop remoto né per l'esecuzione di Stampa Internet, mentre vengono mantenuti i servizi ruolo di Web Server (IIS) ancora necessari per Stampa Internet.

Come vengono gestiti servizi ruolo padre e figlio dal file di risposta

Alcuni ruoli, ruoli server e funzionalità sono contenitori di elementi figlio installati per impostazione predefinita da Server Manager. Nelle procedure guidate che fanno parte dell'interfaccia grafica di Server Manager, quando si seleziona un nodo contenitore da installare o rimuovere, gli elementi figlio necessari vengono selezionati automaticamente. Sebbene sia possibile deselezionare manualmente le caselle di controllo relative ad alcuni elementi figlio, le impostazioni predefinite consigliate sono gli elementi figlio selezionati.

Quando un contenitore viene specificato in un'installazione dalla riga di comando, gli elementi figlio predefiniti vengono inclusi automaticamente. Quando un contenitore viene specificato in una rimozione dalla riga di comando, tutti gli elementi figlio vengono rimossi. Se ad esempio il ruolo Servizi di stampa e digitalizzazione viene specificato nel file di risposta insieme al comando -install, verrà installato anche il servizio ruolo Server di stampa. Se tuttavia si specifica la rimozione del contenitore di Servizi di stampa e digitalizzazione, verrà rimosso l'intero ruolo.

Nel caso in cui gli elementi figlio predefiniti non debbano essere installati, non specificare il contenitore nel file di risposta. Specificare solo gli elementi figlio che si desidera installare o rimuovere.

Se ad esempio si desidera installare Stampa Internet, un servizio ruolo di Servizi di stampa e digitalizzazione, nel file di risposta è necessario specificare solo Stampa Internet e non Servizi di stampa e digitalizzazione o altri servizi ruolo di Servizi di stampa e digitalizzazione. Server Manager installa solo Stampa Internet e il servizio ruolo Server di stampa necessario, ma non Servizio LPD, un altro servizio ruolo subordinato a Servizi di stampa e digitalizzazione.

Creare un file di risposta per comandi di Server Manager

È possibile creare il file di risposta da utilizzare con la riga di comando di Server Manager in un editor XML o in un editor di testo quale Blocco note. È consigliabile utilizzare un editor XML in grado di convalidare i dati in uno schema XML esistente, in quanto è importante convalidare il file di risposta nella definizione dello schema della riga di comando di Server Manager. Per ulteriori informazioni, vedere Schema della riga di comando di Server Manager in questo argomento.

Nota

I risultati del parametro -query non possono essere utilizzati come file di risposta con il parametro -inputPath. Il codice XML utilizzato dai risultati di -query e quello necessario in un file di risposta di Servermanagercmd.exe non vengono convalidati nello stesso schema.

Specificare gli identificatori di ruoli, servizi ruolo e funzionalità

La riga di comando di Server Manager e il file di risposta riconoscono gli identificatori di ruoli, servizi ruolo e funzionalità indicati in Panoramica dei comandi di Server Manager. Per gli identificatori di ruoli, servizi ruolo e funzionalità nel file di risposta e nella riga di comando di Server Manager non viene effettuata alcuna distinzione tra maiuscole e minuscole. L'utilizzo di lettere maiuscole negli identificatori, pertanto, non è essenziale.

file di risposta di esempio

Di seguito vengono illustrati file di risposta di esempio. Si noti che l'elemento intestazione seguente deve essere presente in tutti i file di risposta e, al fine di creare un file XML dal formato corretto, deve essere chiuso alla fine del file di risposta. Il segnaposto action deve essere sostituito con Install o Remove.

<ServerManagerConfiguration
Action="action"
xmlns="http://schemas.microsoft.com/sdm/Windows/ServerManager/Configuration/2007/1">
…answer file content…
</ServerManagerConfiguration>

Installare Server DNS, Server Web, Gateway Desktop remoto, Server di Accodamento messaggi e Funzionalità di .NET Framework 3.0

Nell'esempio seguente l'amministratore desidera installare Server DNS, Web Server (IIS), Gateway Desktop remoto (un servizio ruolo di Servizi Desktop remoto), Server di Accodamento messaggi (componente della funzionalità Accodamento messaggi) e tutti i componenti di Funzionalità di .NET Framework 3.5.1.

<ServerManagerConfiguration
Action="Install"
xmlns="http://schemas.microsoft.com/sdm/Windows/ServerManager/Configuration/2007/1">
<Role Id="DNS"/>
<Role Id="Web-Server"/>
<RoleService Id="RDS-Gateway"/>
<Feature Id="MSMQ-Server"/>
<Feature Id="Net-Framework" InstallAllSubFeatures="true"/>
</ServerManagerConfiguration>

I risultati dell'operazione sono i seguenti.

  • Server DNS: installato.

  • Web Server (IIS): include vari servizi ruolo predefiniti e una dipendenza dalla funzionalità Servizio Attivazione processo Windows. Tutti i servizi di ruolo predefiniti e il servizio Attivazione processo Windows sono installati.

  • Servizi Desktop remoto: il servizio ruolo Gateway Desktop remoto è installato, a indicare pertanto che il ruolo Servizi Desktop remoto è installato. Gateway Desktop remoto dipende da diversi servizi ruolo di Web Server (IIS) e da Servizi di accesso e criteri di rete, anch'esso installato.

  • Accodamento messaggi: è installato solo l'elemento della funzionalità Server di Accodamento messaggi. Gli altri elementi di Accodamento messaggi non sono installati.

  • Funzionalità di .NET Framework 3.5.1: vengono installate tutte le funzionalità secondarie di Funzionalità di .NET Framework 3.5.1.

Rimuovere Server DNS, Gateway Desktop remoto e Funzionalità di .NET Framework 3.5.1

Nell'esempio seguente l'amministratore desidera rimuovere Server DNS, Gateway Desktop remoto e Funzionalità di .NET Framework 3.5.1.

<ServerManagerConfiguration
Action="Remove"
xmlns="http://schemas.microsoft.com/sdm/Windows/ServerManager/Configuration/2007/1">
<Role Id="DNS"/>
<RoleService Id="RDS-Gateway"/>
<Feature Id="Net-Framework"/>
</ServerManagerConfiguration>

I risultati dell'operazione sono i seguenti.

  • Server DNS: rimosso.

  • Servizi Desktop remoto: il servizio ruolo Gateway Desktop remoto viene rimosso. Gli altri servizi ruolo di Gateway Desktop remoto installati non vengono rimossi.. Server Web (IIS), da cui dipende Gateway Desktop remoto, non viene rimosso.

  • Funzionalità di .NET Framework 3.5.1: tutte le funzionalità secondarie di .NET Framework 3.5.1 vengono rimosse. Le eventuali funzionalità secondarie non installate in precedenza vengono ignorate.

Schema della riga di comando di Server Manager

I file di risposta XML utilizzati con la riga di comando di Server Manager devono essere convalidati nella definizione dello schema della riga di comando di Server Manager. Una copia di questo schema è disponibile nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81203.


Interpretare l'output dei comandi di Server Manager

Nota

Servermanagercmd.exe è obsoleto e il supporto non è garantito nelle versioni future di Windows. È consigliabile utilizzare i cmdlet di Windows PowerShell disponibili per Server Manager.

Il comando di Server Manager, ServerManagerCmd.exe, genera output relativo alle operazioni e ne visualizza i punti di maggiore interesse sullo schermo. Server Manager scrive inoltre un output più dettagliato in un file di registro di solo testo. È inoltre possibile configurare Server Manager per scrivere i risultati delle operazioni della riga di comando in un file dei risultati basato su XML.

In questa sezione vengono identificati e descritti i codici e i messaggi trovati nei file di output dei comandi di Server Manager.

Risultati delle operazioni della riga di comando di Server Manager

Per impostazione predefinita, Server Manager scrive l'output dei comandi in un file di registro di solo testo denominato logname.txt, che si trova in %windir%\logs\ServerManager.log.

Nota

Sebbene l'output relativo alle operazioni del comando di Server Manager venga archiviato in questo registro, tale output è estremamente dettagliato e in formato complesso. Il file di registro risulta utile se è necessario contattare il Servizio supporto tecnico Microsoft per le operazioni di Server Manager.

È possibile modificare il nome e il percorso predefiniti del file di registro aggiungendo il parametro -logPath alla riga di comando di Server Manager, ServerManagerCmd.exe. Per ulteriori informazioni sul parametro -logPath e sulla sintassi di ServerManagerCmd.exe, vedere Panoramica dei comandi di Server Manager.

Oltre al file di registro di solo testo creato per impostazione predefinita da Server Manager, è possibile utilizzare un comando di Server Manager per archiviare i risultati delle relative operazioni in un file XML con un nome e un percorso specificati dall'utente. Il parametro per specificare il nome e il percorso di un file dei risultati XML è -resultPath.

I parametri -logPath e -resultPath vengono utilizzati al prompt dei comandi, indipendentemente dal fatto che venga specificato un elenco di ruoli o funzionalità da rimuovere utilizzando un file di risposta con il comando di Server Manager oppure venga installato o rimosso un singolo elemento direttamente dalla riga di comando. Per ulteriori informazioni sul file di risposta della riga di comando di Server Manager, vedere Creare un file di risposta per comandi di Server Manager.

Esempi

Negli esempi seguenti viene illustrato come specificare il nome e il percorso di un file dei risultati XML nel comando di Server Manager.

Esempio di specifica del file dei risultati in un comando con un file di risposta

ServerManagerCmd.exe -inputPath C:\CmdLine\Remove_roles.xml -resultPath C:\CmdLine\010107.xml

Nell'esempio precedente, un amministratore ha creato un file di risposta denominato Remove_roles.xml, contenente comandi per rimuovere diversi ruoli da un server. L'amministratore ha specificato il nome e il percorso di un file dei risultati, C:\CmdLine\010107.xml.

Esempio di specifica del file dei risultati in un comando senza un file di risposta

ServerManagerCmd.exe -install npas -allSubFeatures -r C:\CmdLine\Results\010107.xml -restart

Nell'esempio precedente un amministratore ha specificato un'istruzione per indicare a Server Manager di installare Servizi di accesso e criteri di rete. Si noti che per il nome del comando per il ruolo, ovvero npas, non viene effettuata distinzione tra maiuscole e minuscole.

In questo esempio vengono installati tutti i servizi ruolo di Servizi di accesso e criteri di rete, come richiesto dal parametro -allSubFeatures. L'amministratore utilizza il formato breve del parametro -resultPath, ovvero -r, per specificare il nome e il percorso di un file dei risultati. Utilizza infine il parametro -restart per specificare l'istruzione che indica a Server Manager di riavviare il computer, se necessario, al termine dell'installazione del ruolo Servizi di accesso e criteri di rete.

Descrizioni dei messaggi di output

In questa sezione vengono descritti l'output e i risultati restituiti da Server Manager in un file dei risultati basato su XML.

Messaggi di output

Nella tabella seguente vengono identificati e descritti i messaggi che il comando di Server Manager scrive nella finestra della console e nei file dei risultati.

Messaggio Codice di uscita Stringa di testo Note

Operazione riuscita. Non è necessario riavviare.

0

Operazione riuscita: installazione completata.

Operazione riuscita: rimozione completata.

Questi due messaggi possono essere leggermente diversi, a seconda che l'utente abbia specificato ruoli o funzionalità nel comando.

Operazione riuscita. È necessario riavviare.

3010

Operazione riuscita: installazione completata. È necessario riavviare.

Operazione riuscita: rimozione completata. È necessario riavviare.

Questo codice viene restituito quando è necessario riavviare. Dopo aver riavviato il computer, potrebbe essere necessario eseguire Server Manager nell'interfaccia utente di Windows Server 2008 R2 al fine di completare la configurazione necessaria per ruoli o funzionalità.

Argomento non valido

4

ArgumentNotValid: argomento non valido {argomento}

ArgumentNotValid: percorso del file di risposta mancante

ArgumentNotValid: percorso del file di registro mancante

ArgumentNotValid: funzionalità non valida: '{nome}'. Nome della funzionalità non trovato.

ArgumentNotValid: ruolo non valido: '{nome}'. Nome del ruolo non trovato.

ArgumentNotValid: il nome seguente è stato già specificato nel percorso di input: {nome}.

ArgumentNotValid: l'impostazione seguente è stata già specificata nel percorso di input: {impostazione}.

ArgumentNotValid: funzionalità non valida. '{nome}' è un ruolo.

ArgumentNotValid: funzionalità non valida. '{nome}' è un servizio ruolo.

ArgumentNotValid: ruolo non valido. '{nome}' è una funzionalità.

ArgumentNotValid: ruolo non valido. '{nome}' è un servizio ruolo.

ArgumentNotValid: servizio ruolo non valido. '{nome}' è una funzionalità.

ArgumentNotValid: servizio ruolo non valido. '{nome}' è un ruolo.

Viene visualizzato quando un utente specifica un argomento inesistente oppure omette una parte obbligatoria di un argomento specificato nella riga di comando di Server Manager.

Vengono visualizzati messaggi diversi a seconda dell'argomento che richiede attenzione.

{argomento} rappresenta l'argomento non corretto specificato dall'utente.

{nome} rappresenta il nome del ruolo, del servizio ruolo o della funzionalità specificato in modo non corretto.

{impostazione} rappresenta il nome di un riferimento specificato in modo non corretto o duplicato relativo a un'impostazione per un ruolo, un servizio ruolo o una funzionalità.

Errore durante l'apertura o la lettura di un file di input

110

ReadError: il file di risposta non esiste: {0}

ReadError: impossibile leggere il file di risposta: {0}

ReadError: impossibile caricare il file di risposta: {0}. {1}

Viene visualizzato se l'interfaccia della riga di comando di Server Manager non può leggere o individuare il file di risposta specificato da un utente. Vengono visualizzati messaggi diversi per lo stesso codice di errore (110) a seconda del motivo per cui non è stato possibile caricare il file di risposta.

{0} rappresenta il percorso e il nome specificati dall'utente.

{1} rappresenta l'eccezione rilevata da Server Manager.

Se viene visualizzato questo messaggio di errore, la procedura di risoluzione dei problemi consigliata è verificare di aver specificato il nome e il percorso corretti del file di risposta XML, nonché di verificare che il file di risposta venga convalidato nello schema del file di risposta di Server Manager e utilizzi la struttura di elementi corretta. Per ulteriori informazioni sulla corretta impostazione e sull'aspetto di un file di risposta della riga di comando di Server Manager, vedere Creare un file di risposta per comandi di Server Manager.

Autorizzazioni o credenziali insufficienti

5

Errore: Server Manager può essere eseguito solo da un membro del gruppo Administrators predefinito nel computer locale. I ruoli e le funzionalità possono essere installati e rimossi solo con autorizzazioni elevate.

Questo errore si verifica se le credenziali utente specificate non dispongono di diritti amministrativi locali sul server o se un utente non ha aperto la finestra del prompt dei comandi con autorizzazioni elevate. Per eseguire tale operazione, fare clic con il pulsante destro del mouse sull'eseguibile di Prompt dei comandi oppure fare clic con il pulsante destro del mouse su Prompt dei comandi nel menu Start e quindi scegliere Esegui come amministratore.

Nessuna modifica necessaria

1003

NoChange: non sono state apportate modifiche perché i ruoli e le funzionalità specificati nel file di risposta sono già installati o sono stati già rimossi dal computer locale.

Viene visualizzato se i ruoli, i servizi ruolo o le funzionalità specificati nel file di risposta per essere installati sono già installati nel computer oppure se il file di risposta ne richiede la rimozione e Server Manager ha rilevato che non esistono nel computer oppure sono stati già rimossi. In altre parole, questo messaggio viene visualizzato se le azioni specificate nel comando restituiscono un'operazione Null.

Un'istanza di una procedura guidata di Server Manager è già in esecuzione nel computer

1004

Errore: un altro utente sta eseguendo una procedura guidata nell'interfaccia utente di Server Manager.

Se una delle procedure guidate di Server Manager (Aggiunta guidata ruoli, Aggiunta guidata funzionalità, Aggiunta servizi ruolo, Rimozione guidata ruoli, Rimozione guidata funzionalità, Rimozione servizi ruolo) è già in esecuzione, il tentativo di eseguire la riga di comando di Server Manager per installare o rimuovere ruoli, servizi ruolo o funzionalità avrà esito negativo. Eseguendo un unico strumento alla volta, Server Manager impedisce che gli utenti apportino modifiche in conflitto ai pacchetti software installati nel server. È possibile eseguire gli strumenti da riga di comando o una procedura guidata di Server Manager, ma non entrambi contemporaneamente.

Si è verificato un errore durante la raccolta dell'elenco di ruoli o funzionalità installati oppure durante l'installazione o la rimozione degli elementi specificati dall'utente.

1000

Errore: impossibile installare uno o più ruoli, servizi ruolo o funzionalità. Per ulteriori informazioni, controllare il registro di Server Manager e riprovare.

Errore: impossibile rimuovere uno o più ruoli, ruoli server o funzionalità. Per ulteriori informazioni, controllare il registro di Server Manager e riprovare.

Questi due messaggi possono essere leggermente diversi, a seconda che l'utente abbia specificato ruoli o funzionalità nel comando.

Si tratta di un errore identico all'errore 1000, tranne per il fatto che in questo caso è necessario riavviare per annullare le eventuali modifiche apportate al computer.

1001

Errore: impossibile installare uno o più ruoli, ruoli server o funzionalità. È necessario riavviare per annullare le eventuali modifiche apportate al computer. Per ulteriori informazioni, controllare il registro di Server Manager e riprovare.

Errore: impossibile rimuovere uno o più ruoli, ruoli server o funzionalità. È necessario riavviare per annullare le eventuali modifiche apportate al computer. Per ulteriori informazioni, controllare il registro di Server Manager e riprovare.

Errore: installazione del ruolo, servizio ruolo o funzionalità non riuscita perché è necessario riavviare il computer per completare un'altra installazione o rimozione. Dopo aver riavviato il computer, riprovare a installare il ruolo, servizio ruolo o funzionalità.

Errore: rimozione del ruolo, servizio ruolo o funzionalità non riuscita perché è necessario riavviare il computer per completare un'altra installazione o rimozione. Dopo aver riavviato il computer, riprovare a rimuovere il ruolo, servizio ruolo o funzionalità.

Questi messaggi possono essere leggermente diversi, a seconda che l'utente abbia specificato ruoli o funzionalità nel comando.

Errore generico

1002

Errore: Errore generico. {0}

Si tratta di un errore generico per il quale non sono disponibili informazioni sulla risoluzione del problema. Se viene restituito questo errore, è consigliabile verificare la sintassi del comando, controllare di aver eseguito l'accesso al computer locale come membro del gruppo Administrators e riprovare a eseguire il comando.

{0} rappresenta l'eccezione rilevata da Server Manager.

File dei risultati XML

Di seguito viene illustrato un esempio del file dei risultati XML creato da Server Manager quando viene aggiunto il parametro -resultPath o -r alla riga di comando di Server Manager e nel parametro vengono specificati un percorso e un nome.

< ServerManagerConfigurationResult
Action="Install"
Time="2006-11-29T14:26:39"
Language="en-US"
Success="true"
RequiresReboot="false"
xmlns="http://schemas.microsoft.com/sdm/Windows/ServerManager/Configuration/2007/1">
<Message Level="Information">Start Installing...</Message>
<Role DisplayName="DHCP Server"
Id="DHCP"
Success="true"
RequiresReboot="false"
RequestedBy="UserSpecified">
<Message Level="Information">Succeeded: [DHCP Server] </Message>
</Role>
<Message Level="Information">Install succeeded.</Message>
</ServerManagerConfigurationResult>

Nella tabella seguente vengono identificati e descritti gli elementi trovati nel file dei risultati.

Elemento o attributo Descrizione

ServerManagerCommandLineResult

Elemento intestazione, rappresenta il contenitore per l'intero file.

Action

Identifica se i risultati visualizzati si riferiscono a un'operazione di installazione o di rimozione.

Time

Visualizza la data e l'ora in cui è stata completata l'operazione.

Language

Visualizza il codice della lingua (in questo esempio, l'inglese degli Stati Uniti) per i messaggi localizzati inclusi nei risultati.

Operazione riuscita

Visualizza il valore "true" se l'azione è riuscita per tutti i ruoli, ruoli server e funzionalità specificati nel comando e il valore "false" se l'azione non è riuscita per uno o più ruoli, ruoli server o funzionalità.

RequiresReboot

Visualizza il valore "true" se è necessario riavviare il computer a causa dell'operazione di installazione o di rimozione riuscita e il valore "false" se non è necessario riavviare.

Xmlns

Questo attributo fa riferimento alla definizione dello schema XML della riga di comando di Server Manager.

Messaggio

Tutti i messaggi informativi, di avviso e di errore sono inclusi nel corpo del file XML. Al livello superiore si trova un messaggio generale relativo all'intera operazione. Se tuttavia un messaggio riguarda uno specifico ruolo, servizio ruolo o funzionalità, il messaggio è contenuto all'interno dell'elemento specifico corrispondente. I messaggi vengono localizzati nella lingua specificata dall'attributo Language.

  • Level Descrive se il messaggio è informativo, di avviso o di errore..

  • Code Se applicabile, visualizza un codice di messaggio o di errore numerico. I codici di errore e di messaggio di Server Manager sono descritti in questo argomento nella sezione File di registro di solo testo.

Role, Role Service o Feature

Gli elementi Role, Role Service o Feature possono ricorrere più volte nel file dei risultati, in base agli oggetti per cui il file di risposta della riga di comando di Server Manager richiede l'installazione o la rimozione.

  • DisplayName Nome localizzato del ruolo, servizio ruolo o funzionalità.

  • Id Nome del comando per il ruolo, servizio ruolo o funzionalità. Un elenco dei nomi di comando per ruoli, ruoli server o funzionalità è disponibile in Panoramica dei comandi di Server Manager.

  • RootParent Nome dell'oggetto padre per il valore specificato nell'attributo DisplayName. Ad esempio, l'oggetto padre del servizio ruolo Filtro richieste è Server Web.

  • Success Visualizza il valore "true" se l'azione specificata nell'attributo Action è riuscita sull'oggetto specificato in DisplayName e il valore "false" se l'azione non è riuscita.

  • RequiresReboot Visualizza il valore "true" se per l'installazione o la rimozione dell'oggetto specificato nell'attributo DisplayName è necessario riavviare il computer e il valore "false" se non è necessario riavviarlo.

  • Skipped Visualizza il valore "true" se i ruoli, ruoli server o funzionalità specificati nel file di risposta per essere installati sono già installati nel computer o se il file di risposta ne richiede la rimozione e Server Manager ha rilevato che non esistono nel computer oppure sono stati già rimossi. In altre parole, questo visualizza il valore "true" solo se le azioni specificate nel comando restituiscono un'operazione Null e visualizza il valore "false" se Server Manager ha completato le azioni specificate nel comando.

  • RequestedBy Visualizza il motivo per cui è stata eseguita l'installazione o la rimozione di un ruolo, servizio ruolo o funzionalità. I motivi possibili sono quattro.

    • Richiesta diretta di un utente

    • Richiesta effettuata in base alla dipendenza di un altro ruolo, servizio ruolo o funzionalità

    • È stato installato o rimosso un oggetto contenitore selezionato per impostazione predefinita

    • Sono stati selezionati tutti gli oggetti figlio di un ruolo, servizio ruolo o funzionalità contenitore (ad esempio, l'utente ha aggiunto il parametro -allSubFeatures al comando Server Manager)

  • Message Vedere la descrizione di Message nella riga precedente. I messaggi nidificati negli elementi Role, Role Service o Feature sono specifici solo di tale oggetto.


Avviare Windows PowerShell con tutti i moduli caricati

Per impostazione predefinita, gli snap-in e i moduli di Windows PowerShell non vengono caricati nelle sessioni di Windows PowerShell. In questo argomento viene descritto come avviare Windows PowerShell in modo che tutti gli snap-in e i moduli installati vengano caricati automaticamente.

Avviare Windows PowerShell con tutti gli snap-in e i moduli caricati

Nella procedura seguente viene descritto come avviare una sessione di Windows PowerShell con tutti gli snap-in e i moduli caricati per impostazione predefinita.

Per avviare Windows PowerShell in modo che vengano caricati tutti i relativi snap-in e moduli

  • Fare clic con il pulsante destro del mouse sull'icona di Windows PowerShell sulla barra delle applicazioni e quindi scegliere Importa tutti i moduli.

    Nota

    In Windows Server® 2008 R2 l'icona di Windows PowerShell viene aggiunta alla barra delle applicazioni per impostazione predefinita. È tuttavia necessario avviare Windows PowerShell una volta per visualizzare Importa tutti i moduli.


Gestione remota tramite Server Manager

In Windows Server® 2008 R2 è possibile utilizzare Server Manager per eseguire alcune attività di gestione in computer remoti. Per gestire un computer da postazione remota utilizzando Server Manager, è necessario connettere Server Manager a un computer remoto così come si connette Microsoft Management Console (MMC) per altre tecnologie.

Scenari di gestione remota supportati

Gli scenari di gestione remota seguenti sono supportati da Server Manager in Windows Server 2008 R2.

  • Da server a server È possibile utilizzare Server Manager in un'installazione completa di Windows Server 2008 R2 per gestire ruoli e funzionalità installati in un altro server che esegue Windows Server 2008 R2.

  • Da server a Server Core È possibile utilizzare Server Manager in un'installazione completa di Windows Server 2008 R2 per gestire ruoli e funzionalità installati in un'installazione Server Core di Windows Server 2008 R2.

  • Da client a server Server Manager è installato come parte di Strumenti di amministrazione server remoto in un computer che esegue Windows® 7. Questo scenario può essere utilizzato per gestire ruoli e funzionalità in un computer che esegue installazioni complete o Server Core di Windows Server 2008 R2.

Computer di origine |  | A computer remoto |  |  | Dominio C (aggiunto come host attendibile)
 |  | Dominio A | Dominio B | Gruppo di lavoro |
 | Dominio A | √ |  |  |
 | Dominio B |  | √ |  |
 | Gruppo di lavoro |  |  | √ | √
Note
  • Se si gestisce un computer remoto da un computer che esegue Windows 7, avviare il servizio Gestione remota Windows (WinRM) per consentire l'aggiunta di host attendibili. Aprire una sessione del prompt dei comandi con diritti utente elevati facendo clic sul pulsante Start, scegliendo Tutti i programmi, Accessori, facendo clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliendo Esegui come amministratore. Digitare il comando seguente e quindi premere INVIO: net start winrm
  • Per le connessioni remote in uno scenario da gruppo di lavoro a gruppo di lavoro/dominio, il computer remoto deve essere aggiunto all'elenco di host attendibili nel computer di origine. A tale scopo, eseguire il comando seguente nel computer di origine in una finestra del prompt dei comandi aperta con diritti utente elevati.
  • winrm set winrm/config/client @{TrustedHosts="NomeComputerRemoto"}
  • Per le connessioni remote in uno scenario da gruppo di lavoro a gruppo di lavoro/dominio, se un utente non ha effettuato l'accesso utilizzando l'account predefinito Administrator del computer, è necessario impostare la chiave del Registro di sistema di WinRM seguente per consentire l'accesso remoto dal computer di origine. Questa modifica è necessaria a causa delle restrizioni imposte da Controllo account utente per gli account non di tipo Administrator membri del gruppo Administrators. Per modificare la chiave del Registro di sistema, eseguire il comando seguente nel computer di origine da un prompt dei comandi aperto con diritti utente elevati.
  • reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f
  • Per impostazione predefinita, WinRM consente un massimo di cinque connessioni attive a un computer remoto per ogni utente. Per aumentare il limite, eseguire il comando seguente nel computer di origine, dove X rappresenta il numero di connessioni che si desidera consentire, da un prompt dei comandi aperto con diritti utente elevati.
  • winrm s winrm/config/winrs @{MaxShellsPerUser="X"}

Considerazioni sulla sicurezza per la gestione remota con Server Manager

Importante

È necessario essere membri del gruppo Administrators nei computer che si desidera gestire utilizzando Server Manager.

Poiché la funzionalità di gestione remota di Server Manager viene fornita utilizzando la tecnologia Windows PowerShell, la gestione remota di Server Manager eredita le considerazioni relative alla sicurezza da Windows PowerShell. Un utente malintenzionato può provare a sottrarre le credenziali di accesso fornite da un amministratore tramite una connessione remota, ma in genere si tratta di un rischio minimo. Altre minacce potenziali per le quali il rischio è minimo includono la modifica di librerie di collegamenti dinamico (DLL) da parte di utenti malintenzionati o i tentativi di ottenere dati sensibili o personali nel file di registro di Server Manager. Gli utenti che dispongono dei diritti di accesso al computer locale possono leggere i file di registro di Server Manager, ma tali file non contengono informazioni sull'account o personali riservate come ad esempio password.

Attività che è possibile eseguire in un server remoto utilizzando Server Manager

Server Manager consente di eseguire le attività seguenti in un computer remoto.

  • Verificare lo stato degli aggiornamenti automatici di Windows

  • Eseguire analisi di Best Practice Analyzer sui ruoli. Per ulteriori informazioni, vedere Eseguire e filtrare analisi in Best Practice Analyzer.

  • Visualizzare o modificare lo stato di Analisi utilizzo software Windows

  • Configurare Segnalazione errori Windows

  • Visualizzare o modificare le informazioni su Windows Firewall

  • Visualizzare e gestire i ruoli dalle relative home page

    Nota

    Per utilizzare strumenti o snap-in specifici delle funzionalità o dei ruoli in una console di Server Manager connessa a un server remoto, è necessario che tali strumenti siano installati nel computer di origine utilizzando Strumenti di amministrazione server remoto.

  • Visualizzare le impostazioni di configurazione di Sicurezza avanzata di Internet Explorer

  • Gestire servizi dalla home page di un ruolo

Attività che non è possibile eseguire da postazione remota utilizzando Server Manager

Allo scopo di ridurre al minimo i rischi di sicurezza per i server, le attività seguenti non possono essere eseguite in una sessione di Server Manager remota

  • Aggiungere o rimuovere ruoli, ruoli server e funzionalità

  • Configurare le impostazioni di Desktop remoto

  • Configurare le proprietà di sistema

  • Verificare la presenza di nuovi ruoli

  • Modificare le impostazioni di aggiornamento automatico di Windows

  • Cambiare le impostazioni di rete

  • Cambiare il nome del computer o l'appartenenza al dominio

  • Cambiare le impostazioni di configurazione di Sicurezza avanzata di Internet Explorer

  • Eseguire la Configurazione guidata impostazioni di sicurezza, se il computer di origine è un server che esegue Windows Server 2008 R2

Attivare o disattivare la gestione remota in Windows Server 2008 R2

Per proteggere i server dall'accesso non autorizzato, e affinché gli amministratori possano connettersi a un computer che esegue Windows Server 2008 R2 da postazione remota utilizzando Server Manager, è necessario attivare la gestione remota di Server Manager nel computer di destinazione.

Prima di configurare un server per la gestione remota utilizzando Server Manager, è necessario attivare diverse impostazioni di Criteri di gruppo per il controllo delle eccezioni di Windows Firewall. Eseguire la procedura descritta in Per impostare Criteri di gruppo per la gestione remota di Server Manager per verificare che non vi siano impostazioni di Criteri di gruppo che sostituiscono la configurazione del server per la gestione remota.

Nota

Le procedure descritte in questa sezione possono essere completate solo in un computer che esegue Windows Server 2008 R2. Non è possibile attivare o disattivare la gestione remota in un computer che esegue Windows 7 in quanto non è possibile gestire Windows 7 utilizzando Server Manager.

  • Per impostare Criteri di gruppo per la gestione remota di Server Manager

  • Per configurare la gestione remota di Server Manager utilizzando l'interfaccia di Windows

  • Per configurare la gestione remota di Server Manager utilizzando Windows PowerShell

Per impostare Criteri di gruppo per la gestione remota di Server Manager

  1. Nel computer che si desidera gestire da postazione remota aprire Editor Criteri di gruppo locali. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare gpedit.msc nella casella Apri e quindi premere INVIO.

  2. Espandere Configurazione computer, Modelli amministrativi, Componenti di Windows, Gestione remota Windows e quindi selezionare Servizio Gestione remota Windows.

  3. Nel riquadro dei dettagli fare doppio clic su Consenti configurazione automatica dei listener.

  4. Selezionare Attivata e quindi fare clic su OK.

  5. Nel riquadro dell'albero espandere Impostazioni di Windows, Impostazioni sicurezza, Windows Firewall con sicurezza avanzata e quindi Windows Firewall con sicurezza avanzata.

  6. Fare clic con il pulsante destro del mouse su Regole connessioni in entrata e quindi scegliere Nuova regola.

  7. Nella pagina Tipo di regola della Creazione guidata nuova regola connessioni in entrata selezionare Predefinita.

  8. Nel menu a discesa Predefinita selezionare Gestione remota registro eventi. Fare clic su Avanti.

  9. Nella pagina Regole predefinite fare clic su Avanti per accettare le nuove regole.

  10. Nella pagina Operazione selezionare Consenti la connessione e quindi fare clic su Fine. L'opzione Consenti la connessione è selezionata per impostazione predefinita.

  11. Ripetere i passaggi da 5 a 10 per creare nuove regole in entrata per i due tipi aggiuntivi di regole predefinite seguenti.

    • Gestione remota servizi

    • Gestione remota firewall Windows

  12. Chiudere Editor Criteri di gruppo locali.
Per configurare la gestione remota di Server Manager utilizzando l'interfaccia di Windows

  1. Nel computer che si desidera gestire da postazione remota aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nell'area Riepilogo server della home page di Server Manager fare clic su Configura gestione remota di Server Manager.

  3. Effettuare una delle operazioni seguenti.

    • Per consentire la gestione remota del computer tramite Server Manager, selezionare Consenti gestione remota del server da altri computer.

    • Per impedire la gestione remota del computer tramite Server Manager, deselezionare la casella di controllo Consenti gestione remota del server da altri computer.

    • Se si desidera attivare la gestione remota, ma non è possibile modificare questa impostazione, eseguire la procedura descritta in Per impostare Criteri di gruppo per la gestione remota di Server Manager e quindi continuare con il passaggio successivo.

  4. Fare clic su OK.

  5. Verificare che le eccezioni alle regole firewall seguenti siano attivate e non siano disattivate dalle impostazioni di Criteri di gruppo.

    • Gestione controllo servizi (NP-In)

    • Gestione remota servizi (RPC)

    • Gestione servizi remoti (RPC-EPMAP)

    • Gestione remota registro eventi (NP-In)

    • Gestione remota registro eventi (RPC)

    • Gestione remota registro eventi (RPC-EPMAP)

    • Gestione remota Windows Firewall (RPC)

    • Gestione remota Windows Firewall (RPC-EPMAP)

    A tale scopo, eseguire la procedura seguente.

    1. Aprire lo snap-in Windows Firewall con sicurezza avanzata eseguendo una delle operazioni seguenti:

      • Nell'area Informazioni sicurezza della finestra principale di Server Manager fare clic su Vai a Windows Firewall.

      • Nel riquadro dell'albero di Server Manager espandere Configurazione e quindi fare clic su Windows Firewall con sicurezza avanzata.

      • Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Windows Firewall con sicurezza avanzata.

    2. Nell'area Operazioni preliminari del riquadro dei dettagli di Windows Firewall con sicurezza avanzata fare clic su Regole connessioni in entrata.

    3. Nell'elenco di regole individuare le regole specificate in questo passaggio.

    4. Se nella colonna Abilitata di una delle regole specificate è indicato No, fare doppio clic sulla regola per aprire la relativa finestra di dialogo Proprietà.

    5. Nella scheda Generale della finestra di dialogo Proprietà della regola selezionare Abilitato. Fare clic su OK.

      Nota

      Sebbene la gestione remota tramite Server Manager sia possibile anche se sono disabilitate le eccezioni alle regole firewall Gestione remota registro eventi, i tempi necessari per la connessione remota possono risultare molto lunghi, in base al numero di ruoli e funzionalità in esecuzione nel computer che si desidera gestire, a meno che non vengano abilitate le eccezioni a queste regole firewall. È consigliabile abilitare le regole firewall Gestione remota registro eventi per impedire ritardi nella connessione.

Per configurare la gestione remota di Server Manager utilizzando Windows PowerShell

  1. Nel computer che si desidera gestire da postazione remota aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Nella sessione di Windows PowerShell digitare il comando seguente e quindi premere INVIO.

    Set-ExecutionPolicy -ExecutionPolicy RemoteSigned

  3. Digitare il comando seguente e premere INVIO per abilitare tutte le eccezioni alle regole firewall necessarie.

    Configure-SMRemoting.ps1 -force -enable

Per configurare la gestione remota con l'opzione di installazione Server Core di Windows Server 2008 R2

  1. Nel computer che si desidera gestire da postazione remota, al prompt dei comandi visualizzato per impostazione predefinita quando un membro del gruppo Administrators accede al computer che esegue l'opzione di installazione Server Core di Windows Server 2008 R2 digitare il comando seguente e quindi premere INVIO.

    Dism.exe /Online /Enable-Feature /FeatureName:NetFx2-ServerCore /FeatureName:MicrosoftWindowsPowerShell /FeatureName:ServerManager-PSH-Cmdlets /FeatureName:BestPractices-PSH-Cmdlets

  2. Al termine dell'installazione, chiudere tutte le applicazioni e quindi riavviare il computer.

    Per verificare che Windows PowerShell e i cmdlet per Server Manager e Best Practice Analyzer siano installati, provare a immettere il comando oclist, che restituisce un elenco di tutte le funzionalità di Windows installate nel computer.

  3. Al termine del caricamento del sistema operativo, accedere al computer almeno come membro del gruppo Administrators locale.

  4. Nella finestra del prompt dei comandi visualizzata dopo l'accesso al computer digitare il comando seguente per aprire una sessione di Windows PowerShell e quindi premere INVIO.

    powershell

  5. Nella sessione di Windows PowerShell digitare il comando seguente e quindi premere INVIO.

    Set-ExecutionPolicy -ExecutionPolicy RemoteSigned

  6. Digitare il comando seguente e premere INVIO per abilitare tutte le eccezioni alle regole firewall necessarie.

    Configure-SMRemoting.ps1 -force -enable

Eseguire la connessione a computer remoti utilizzando Server Manager

Per gestire un server remoto utilizzando Server Manager, eseguire la procedura seguente

Per connettersi a un altro computer utilizzando Server Manager

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro dell'albero fare clic con il pulsante destro del mouse su Server Manager e quindi scegliere Connetti a un altro computer.

  3. Nella finestra di dialogo Connetti a un altro computer immettere il nome o l'indirizzo IP di un altro computer che esegue Windows Server 2008 R2 nella casella di testo Altro computer oppure cercare un altro server nella rete. Fare clic su OK.

    Nella casella di testo Altro computer è possibile specificare un nome NetBIOS, un nome di dominio completo (FQDN) o un indirizzo IPv4 o IPv6. Se non viene specificato alcun numero di porta, verrà utilizzato il numero di porta predefinito. Di seguito sono riportati alcuni esempi di formati che è possibile specificare nella casella di testo Altro computer.

    • ComputerName

    • ComputerName:PortNumber

    • Indirizzo IP: n.n.n.n

    • Indirizzo IPv6: [n:n:n:n]

    • Indirizzo IPv4 con numero di porta: n.n.n.n:PortNumber

    • Indirizzo IPv6 con numero di porta: [n:n:n:n]:PortNumber

    Nota

    Se il numero di porta predefinito è stato modificato da un amministratore, la porta non predefinita deve essere aperta in Windows Firewall per consentire le connessioni in ingresso. La porta 5985 è aperta per impostazione predefinita quando si configura Gestione remota Windows come descritto in Per impostare Criteri di gruppo per la gestione remota di Server Manager in questo argomento. Le porte non predefinite rimangono bloccate fino a quando non vengono aperte. Per ulteriori informazioni su come sbloccare una porta in Windows Firewall, vedere l'argomento della Guida relativo a Windows Firewall. Per ulteriori informazioni su come configurare Gestione remota Windows, in una sessione del prompt dei comandi digitare winrm help e quindi premere INVIO.

    Dopo aver stabilito la connessione a un computer remoto, si noti che il nome del computer cambia nella console di Server Manager. Il nome del computer nel nodo Server Manager del riquadro dell'albero, il campo Nome completo computer nell'area Riepilogo server di Server Manager e il nome del computer nell'intestazione della console cambiano tutti in base al nome del computer remoto a cui si è connessi. Poiché Server Manager risolve gli indirizzi IP in nomi di dominio completi, se si effettua la connessione a un computer remoto utilizzando un indirizzo IP, nella console di Server Manager viene visualizzato il nome di dominio completo del computer remoto.

    Nota

    Se si sta effettuando la connessione a un computer in un dominio diverso utilizzando un indirizzo IP, la connessione remota potrebbe non riuscire a causa delle restrizioni previste per i server DNS che possono impedire la risoluzione dell'indirizzo IP in un nome host. In questo caso, provare a effettuare la connessione specificando un nome di dominio completo.

Per eseguire il cmdlet Get-WindowsFeature di Server Manager in un computer remoto da una sessione di Windows PowerShell

  1. Aprire una sessione di Windows PowerShell con diritti utente elevati. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori, Windows PowerShell, fare clic con il pulsante destro del mouse sul collegamento a Windows PowerShell e quindi scegliere Esegui come amministratore.

  2. Digitare il comando seguente, dove ComputerName è il nome del computer remoto che esegue Windows Server 2008 R2 e UserName è il nome di un utente membro del gruppo Administrators nel computer remoto, e quindi premere INVIO.

    Enter-PSSession <ComputerName> –credential <UserName>

  3. Verrà chiesto di immettere la password in una finestra di dialogo sicura. Digitare la password e quindi premere INVIO.

  4. Nella sessione di Windows PowerShell digitare il comando seguente per caricare lo snap-in Server Manager e quindi premere INVIO.

    Import-Module ServerManager

  5. Digitare il comando seguente e quindi premere INVIO.

    Get-WindowsFeature

  6. Dopo che i risultati del cmdlet Get-WindowsFeature sono stati visualizzati nella sessione di Windows PowerShell, digitare il comando seguente per chiudere la sessione di Windows PowerShell e quindi premere INVIO.

    Exit-PSSession

Gestire più computer utilizzando Server Manager e MMC

È inoltre possibile creare una console MMC (Microsoft Management Console) personalizzata contenente più snap-in di Server Manager, ognuno destinato alla gestione di un computer remoto diverso.

Per gestire più computer utilizzando Server Manager e MMC

  1. Per aprire Microsoft Management Console, fare clic sul pulsante Start, scegliere Esegui, digitare mmc e quindi fare clic su OK.

  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

  3. Nell'elenco Snap-in disponibili selezionare Server Manager.

  4. Fare clic su Aggiungi per aggiungere Server Manager all'elenco Snap-in selezionati.

  5. Ripetere il passaggio precedente il numero di volte necessario per aggiungere gli snap-in Server Manager a MMC. Fare clic su OK.

  6. Nel riquadro dell'albero della nuova console MMC fare clic con il pulsante destro del mouse sul nodo di primo livello di uno snap-in Server Manager e quindi scegliere Connetti a un altro computer.

  7. Nella finestra di dialogo Connetti a un altro computer immettere il nome o l'indirizzo IP di un altro computer nella casella di testo Altro computer oppure cercare un altro server nella rete. Fare clic su OK.

    Dopo aver stabilito la connessione a un computer remoto, si noti che il nome del computer cambia nel nodo Server Manager del riquadro dell'albero.

  8. Se in MMC sono presenti ulteriori snap-in Server Manager, ripetere questa procedura a partire dal passaggio 6 per connettere ulteriori snap-in Server Manager ad altri computer remoti.

  9. Scegliere Salva dal menu File per salvare la console MMC personalizzata.

Gestione remota da Windows 7

Sebbene i computer che eseguono Windows 7 non possano essere gestiti utilizzando Server Manager, è possibile installare Server Manager in un computer che esegue Windows 7 installando Strumenti di amministrazione server remoto. È possibile scaricare Strumenti di amministrazione server remoto per Windows 7 dal sito Web Microsoft (http://go.microsoft.com/fwlink/?LinkId=131280). Dopo l'installazione di Strumenti di amministrazione server remoto, è possibile connettere una console di Server Manager a un computer remoto che esegue Windows Server 2008 R2 e svolgere nel server di destinazione le attività di gestione descritte in Attività che è possibile eseguire in un server remoto utilizzando Server Manager in questo argomento.

Dopo l'installazione di Strumenti di amministrazione server remoto in un computer che esegue Windows 7, analogamente a quanto accade in un computer che esegue Windows Server 2008 R2, è possibile creare una console MMC di Server Manager per gestire più computer remoti che eseguono Windows Server 2008 R2. Per creare una console MMC di Server Manager personalizzata in un computer che esegue Windows 7 e Strumenti di amministrazione server remoto, vedere Gestire più computer utilizzando Server Manager e MMC in questo argomento.

Per eseguire la gestione remota da un computer che esegue Windows 7

  1. Installare Strumenti di amministrazione server remoto nel computer che esegue Windows 7.

    Scaricare il pacchetto relativo a Strumenti di amministrazione server remoto dal sito Web Microsoft e quindi attenersi alle istruzioni specificate nell'Area download per installare Strumenti di amministrazione server remoto.

    Per utilizzare strumenti o snap-in specifici delle funzionalità o dei ruoli in una console di Server Manager connessa a un server remoto, è necessario che tali strumenti siano installati nel computer di origine utilizzando Strumenti di amministrazione server remoto.

  2. Dopo l'installazione di Strumenti di amministrazione server remoto, aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  3. Nel riquadro dell'albero fare clic con il pulsante destro del mouse su Server Manager e quindi scegliere Connetti a un altro computer.

  4. Nella finestra di dialogo Connetti a un altro computer immettere il nome o l'indirizzo IP di un computer che esegue Windows Server 2008 R2 nella casella di testo Altro computer oppure cercare un altro server nella rete. Fare clic su OK.

    Dopo aver stabilito la connessione a un computer remoto, si noti che il nome del computer viene visualizzato nella console di Server Manager. È possibile visualizzare il nome del computer remoto a cui si è connessi nel nodo Server Manager del riquadro dell'albero, nel campo Nome completo computer nell'area Riepilogo server di Server Manager e nell'intestazione della console.


Funzionalità di accessibilità in Server Manager

In questo argomento vengono descritti due tipi di tasti di scelta rapida: quelli per la home page di Server Manager e quelli per la finestra attiva.

Tasti di scelta rapida per la home page di Server Manager

Nella tabella seguente sono elencati i tasti di scelta rapida per i comandi di menu che agiscono sull'intera console Server Manager o sulla home page di Server Manager.

Azione | Risultato
F5 | Aggiorna il contenuto della home page di Server Manager.
ALT+BARRA SPAZIATRICE | Visualizza il menu della finestra.
ALT+F4 | Chiude Server Manager.
ALT+A | Visualizza il menu Azione.
ALT+V | Visualizza il menu Visualizza.
ALT+F | Visualizza il menu File.
ALT+H | Visualizza il menu ?.

Tasti di scelta rapida per la finestra o l'oggetto attivo di Server Manager

Nella tabella seguente sono elencati i tasti di scelta rapida per i comandi di menu che agiscono sulla finestra o sull'oggetto attivo (ad esempio un nodo nel riquadro di gerarchia) in Server Manager.

Azione | Risultato
ALT+SEGNO MENO | Visualizza il menu della finestra per qualsiasi pagina di Server Manager.
MAIUSC+F10 | Visualizza il menu di scelta rapida Azione per l'elemento selezionato.
F1 | Apre l'argomento della Guida relativo all'elemento selezionato, se disponibile.
F5 | Aggiorna il contenuto visualizzato da Server Manager.
CTRL+F10 | Ingrandisce la pagina attiva in Server Manager.
CTRL+F5 | Ripristina la pagina attiva in Server Manager.
ALT+INVIO | Visualizza la finestra di dialogo Proprietà per l'elemento selezionato, se disponibile.
F2 | Rinomina l'elemento selezionato, se possibile.

Spostamento in Server Manager tramite la tastiera

Nella tabella seguente sono elencati i tasti e le combinazioni di tasti che è possibile utilizzare per spostarsi all'interno di riquadri e aree raggruppate e passare dall'uno all'altro in qualsiasi pagina di Server Manager.

Tasto o combinazione di tasti | Risultato
TAB o F6 | Consente di spostarsi in avanti tra i riquadri della finestra attiva.
MAIUSC+TAB o MAIUSC+F6 | Consente di spostarsi all'indietro tra i riquadri della finestra attiva.
CTRL+TAB o CTRL+F6 | Consente di spostarsi in avanti tra le finestre.
CTRL+MAIUSC+TAB o CTRL+MAIUSC+F6 | Consente di spostarsi all'indietro tra le finestre.
SEGNO PIÙ (+) sul tastierino numerico | Espande l'elemento selezionato.
SEGNO MENO (-) sul tastierino numerico | Comprime l'elemento selezionato.
Asterisco (*) sul tastierino numerico | Espande l'intero albero al di sotto dell'elemento radice nella finestra attiva.
FRECCIA SU | Sposta la selezione di un elemento verso l'alto in un riquadro.
FRECCIA GIÙ | Sposta la selezione di un elemento verso il basso in un riquadro.
PGSU | Sposta la selezione sul primo elemento visibile in un riquadro.
PGGIÙ | Sposta la selezione sull'ultimo elemento visibile in un riquadro.
HOME | Sposta la selezione sul primo elemento in un riquadro.
FINE | Sposta la selezione sull'ultimo elemento in un riquadro.
FRECCIA DESTRA | Espande l'elemento selezionato. Se l'elemento selezionato non contiene elementi nascosti, ha la stessa funzione di FRECCIA GIÙ.
FRECCIA SINISTRA | Comprime l'elemento selezionato. Se l'elemento selezionato non contiene elementi esposti, ha la stessa funzione di FRECCIA SU.
ALT+FRECCIA DESTRA | Sposta la selezione sull'elemento successivo. Ha la stessa funzione della freccia Avanti sulla barra degli strumenti.
ALT+FRECCIA SINISTRA | Sposta la selezione sull'elemento precedente. Ha la stessa funzione della freccia Indietro sulla barra degli strumenti.