Schema di Active Directory

Lo strumento Schema di Active Directory® è uno snap-in di Microsoft Management Console (MMC) che consente di visualizzare e gestire lo schema di Servizi di dominio Active Directory.

Nota

E' possibile, inoltre, utilizzare lo snap-in Schema di Active Directory per visualizzare e gestire gli oggetti schema di Active Directory Lightweight Directory Services (AD LDS).

Definizioni dello schema

Lo schema contiene le definizioni formali di tutte le classi di oggetti che è possibile creare nella foresta Active Directory. Lo schema contiene inoltre le definizioni formali di tutti gli attributi che possono o che devono esistere in un oggetto Active Directory.

Contenitori dello schema

Lo snap-in Schema di Active Directory include due contenitori: il contenitore Classi e il contenitore Attributi. In tali contenitori sono archiviate le definizioni delle classi e degli attributi. Tali definizioni assumono la forma di oggetti classSchema, che è possibile visualizzare nel contenitore Classi, e di oggetti attributeSchema, che è possibile visualizzare nel contenitore Attributi.

Modificare lo schema

Modificare lo schema di Servizi di dominio Active Directory è raramente consigliabile. Se si commettono errori durante la modifica dello schema, le conseguenze possono essere la perdita o il danneggiamento dei dati. Per tale motivo, prima di accingersi a manipolare gli oggetti dello schema in qualsiasi modo è consigliabile conoscere gli effetti che le modifiche avranno osservando i test eseguiti preliminarmente su una foresta di prova.

Prima di apportare qualsiasi modifica allo schema, leggere la Documentazione tecnica sullo schema di Active Directory disponibile sul sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=65961 Per ulteriori informazioni su come modificare lo schema, vedere la pagina dedicata allo schema di Active Directory sul sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80809.

  • Panoramica dello snap-in Schema di Active Directory

  • Installare, proteggere e visualizzare lo schema

  • Risoluzione dei problemi relativi a Schema di Active Directory

  • Risorse per Schema di Active Directory

  • Interfaccia utente: Schema di Active Directory


Panoramica dello snap-in Schema di Active Directory

Lo snap-in Schema di Active Directory di Microsoft Management Console (MMC) consente di visualizzare e gestire lo schema di Servizi di dominio Active Directory. I requisiti per l'installazione e l'utilizzo dello snap-in Schema di Active Directory sono meno flessibili rispetto ad altri strumenti amministrativi. Per apportare modifiche tramite lo snap-in Schema di Active Directory, è necessaria l'appartenenza al gruppo di sicurezza Schema Admins nello stesso dominio radice della foresta di Active Directory. Per impostazione predefinita, il solo membro del gruppo Schema Admins è l'account Administrator per il dominio radice della foresta.

Lo snap-in Schema di Active Directory consente di visualizzare le definizioni di classi e oggetti, concedere l'accesso amministrativo allo schema e modificare classi e attributi dello schema. Tuttavia la modifica dello schema è un'operazione complessa e avanzata, pertanto è preferibile che venga eseguita da programmatori e amministratori esperti. Per tale motivo, le informazioni sulla modifica dello schema sono disponibili prevalentemente nella documentazione per la programmazione. Per ulteriori informazioni su come modificare lo schema, vedere la pagina dedicata allo schema di Active Directory sul sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80809.

Nota

E' possibile, inoltre, utilizzare lo snap-in Schema di Active Directory per visualizzare e gestire gli oggetti schema di Active Directory Lightweight Directory Services (AD LDS).

Ulteriori riferimenti

Installare, proteggere e visualizzare lo schema


Installare, proteggere e visualizzare lo schema

In gran parte delle foreste di Active Directory non è necessario gestire gli oggetti dello schema o le relative proprietà in alcun modo, se non a scopo di sicurezza e per assicurare che l'accesso allo schema sia consentito soltanto agli amministratori autorizzati. L'accesso predefinito agli oggetti dello schema e alle rispettive proprietà è limitato all'account Administrator nel dominio radice della foresta. In alcune circostanze potrebbe essere tuttavia necessario concedere ad altri amministratori le autorizzazioni per l'accesso allo schema, ad esempio se uno sviluppatore di applicazioni ha la necessità di modificare un oggetto dello schema o di risolvere un problema di compatiblità tra un'applicazione e lo schema.

Potrebbe inoltre essere necessario installare lo snap-in Schema di Active Directory in altri controller di dominio. È possibile utilizzare lo snap-in Schema di Active Directory per visualizzare gli oggetti classe e attributo dello schema e le relative proprietà.

Installare lo snap-in Schema di Active Directory

Dal momento che la gestione dello schema non rientra tra gli obiettivi tradizionali dell'amministratore e le modifiche dello schema hanno conseguenze potenzialmente deleterie sull'intera foresta, lo snap-in Schema di Active Directory non viene installato per impostazione predefinita quando si aggiunge il ruolo Servizi di dominio Active Directory. Per poter aggiungere lo snap-in Schema di Active Directory a Microsoft Management Console (MMC), è dapprima necessario registrare il file Schmmgmt.dll in Servizi di dominio Active Directory. Questo passaggio preliminare ha la funzione di scoraggiare l'utilizzo improprio dello strumento. Dopo aver registrato Schmmgmt.dll, è possibile aggiungere lo snap-in Schema di Active Directory a MMC.

Installare lo snap-in Schema di Active Directory

Concedere l'accesso amministrativo allo schema

I membri del gruppo Schema Admins dispongono delle autorizzazioni necessarie per apportare tutte le modifiche allo schema, tranne Elimina tutti gli oggetti figlio. Per impostazione predefinita, il solo membro del gruppo Schema Admins è l'account Administrator nel dominio radice della foresta.

Concedere le autorizzazioni a un amministratore

È possibile utilizzare lo snap-in Utenti e computer di Active Directory per aggiungere un ulteriore utente al gruppo Schema Admins. È consigliabile aggiungere al gruppo un solo utente alla volta. Nel caso in cui sia necessario modificare lo schema, è consigliabile aggiungere un utente amministrativo al gruppo Schema Admins affinché esegua la modifica e, al termine dell'operazione, rimuovere l'utente amministrativo dal gruppo.

Specificare singole autorizzazioni

È possibile concedere le autorizzazioni per svolgere specifiche operazioni di gestione dello schema senza concedere le autorizzazioni per tutti i tipi di modifica. Utilizzare l'opzione Autorizzazioni per concedere l'accesso specifico a un utente o un gruppo. Anche in questo caso è consigliabile rimuovere le autorizzazioni dall'utente o dal gruppo quando l'accesso non è più necessario.

Applicare le autorizzazioni amministrative per lo schema di Active Directory

Visualizzare le definizioni di classi e attributi

Lo snap-in Schema di Active Directory consente di visualizzare gli oggetti classSchema e attributeSchema.

Visualizzare le definizioni di classi e attributi dello schema


Installare lo snap-in Schema di Active Directory

È possibile utilizzare questa procedura innanzitutto per registrare la libreria di collegamento dinamico (DLL) necessaria per lo snap-in Schema di Active Directory. A quel punto, sarà possibile aggiungere lo snap-in a Microsoft Management Console (MMC).

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Domain Admins oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare lo snap-in Schema di Active Directory

  1. Aprire il prompt dei comandi, digitare il comando seguente e quindi premere INVIO:

    regsvr32 schmmgmt.dll

  2. Fare clic sul pulsante Start, scegliere Esegui, digitare mmc e quindi fare clic su OK.

  3. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

  4. In Snap-in disponibili fare clic su Schema di Active Directory, scegliere Aggiungi e quindi fare clic su OK.

  5. Per salvare la console, scegliere Salva dal menu File.

  6. Nella finestra di dialogo Salva con nome eseguire una delle operazioni seguenti:

    • Per aggiungere lo snap-in nella cartella Strumenti di amministrazione, in Nome file digitare un nome per lo snap-in e quindi fare clic su Salva.

    • Per salvare lo snap-in in un percorso diverso dalla cartella Strumenti di amministrazione, in Salva in selezionare un percorso per lo snap-in. In Nome file digitare un nome per lo snap-in e quindi fare clic su Salva.
Attenzione

La modifica dello schema è un'operazione avanzata ed è preferibile che venga eseguita da programmatori e amministratori di sistema esperti. Per informazioni dettagliate su come modificare lo schema, vedere la pagina relativa allo schema di Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80809.

Ulteriori considerazioni

  • Per eseguire il passaggio della procedura relativo alla registrazione del file Schmmgmt.dll, è necessario appartenere al gruppo Domain Admins nel dominio o al gruppo Enterprise Admins nella foresta o, in alternativa, avere ricevuto in delega l'autorità appropriata. Per poter aggiungere lo snap-in Schema di Active Directory a MMC, è sufficiente appartenere al gruppo Domain Users. Per poter apportare modifiche allo schema, è tuttavia necessario appartenere al gruppo Schema Admins.

  • Non è possibile installare gli Strumenti di amministrazione di Windows Server 2008 in computer che eseguono Windows XP Professional o Windows Server 2003.

Ulteriori riferimenti

  • Installare, proteggere e visualizzare lo schema


Applicare le autorizzazioni amministrative per lo schema di Active Directory

È possibile impostare le autorizzazioni per l'esecuzione delle attività nello snap-in Schema di Active Directory.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Schema Admins oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per applicare le autorizzazioni per l'esecuzione di un'attività dello schema

  1. Aprire lo snap-in Schema di Active Directory.

  2. Nell'albero della console fare clic su Schema di Active Directory per connettersi al dominio.

  3. Nell'albero della console fare clic con il pulsante destro del mouse su Schema di Active Directory e quindi scegliere Autorizzazioni.

  4. In Utenti e gruppi selezionare un utente o un gruppo oppure scegliere Aggiungi per aggiungere un utente o un gruppo.

  5. In Autorizzazioni per <nome_utente> selezionare o deselezionare l'autorizzazione che si desidera concedere o negare e quindi fare clic su OK.

Ulteriori considerazioni

  • Per eseguire questa procedura è necessario disporre delle credenziali di amministratore dello schema, che vengono assegnate soltanto al gruppo Schema Admins. Per impostazione predefinita, il solo membro del gruppo Schema Admins è l'account Administrator per il dominio radice della foresta. Sebbene sia possibile concedere a diversi amministratori le autorizzazioni per la gestione delle operazioni relative allo schema, è consigliabile limitare il numero di amministratori dello schema impostando nella foresta un unico amministratore di elevata affidabilità.

  • Se lo snap-in Schema di Active Directory non è installato, vedere Installare lo snap-in Schema di Active Directory.

Ulteriori riferimenti

Installare, proteggere e visualizzare lo schema


Visualizzare le definizioni di classi e attributi dello schema

Lo snap-in Schema di Active Directory di Microsoft Management Console (MMC) consente di visualizzare le definizioni dello schema nelle proprietà degli oggetti attributeSchema e classSchema.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Domain Users oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare la definizione di una classe o un attributo dello schema

  1. Aprire lo snap-in Schema di Active Directory.

  2. Nell'albero della console fare doppio clic su Schema di Active Directory.

  3. Eseguire una delle operazioni seguenti:

    • Per visualizzare la definizione di una classe, nell'albero della console fare clic su Classi per espandere la visualizzazione. Fare clic con il pulsante destro del mouse sulla classe di cui si desidera visualizzare la definizione e quindi scegliere Proprietà.

    • Per visualizzare la definizione di un attributo, nell'albero della console fare clic su Attributi. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sull'attributo di cui si desidera visualizzare la definizione e quindi scegliere Proprietà.

Ulteriori considerazioni

  • Per l'esecuzione di questa attività non è necessario disporre di credenziali amministrative. Per una sicurezza ottimale, è pertanto consigliabile eseguire questa attività con un account utente senza credenziali amministrative.

  • Se lo snap-in Schema di Active Directory non è installato, vedere Installare lo snap-in Schema di Active Directory.

Ulteriori riferimenti

Installare, proteggere e visualizzare lo schema


Risoluzione dei problemi relativi a Schema di Active Directory

Problema riscontrato

  • Non è possibile aggiungere lo snap-in Schema di Active Directory a Microsoft Management Console (MMC).

  • Non è possibile trovare lo snap-in Schema di Active Directory.
Non è possibile aggiungere lo snap-in Schema di Active Directory a Microsoft Management Console (MMC).
  • Causa: il file Schmmgmt.dll non è stato registrato.

  • Soluzione. Aprire il prompt dei comandi, digitare il comando regsvr32 schmmgmt.dll e quindi premere INVIO.

Non è possibile trovare lo snap-in Schema di Active Directory.
  • Causa: lo snap-in di MMC è stato salvato, ma non si conosce il percorso.

  • Soluzione. Aprire MMC (fare clic sul pulsante Start, scegliere Esegui, digitare mmc e quindi fare clic su OK) e quindi scegliere File. Nel menu sono visualizzati gli ultimi quattro percorsi utilizzati per salvare gli snap-in. Verificare se nell'elenco sono presenti Schema di Active Directory o Schmmgmt.msc, quindi seguire il percorso di tale file. Dopo avere individuato il file .msc, trascinarlo sul menu Start per creare un collegamento allo snap-in.


Risorse per Schema di Active Directory

Per ulteriori informazioni sullo snap-in Schema di Active Directory e sugli oggetti che possono essere gestiti, vedere le risorse seguenti:

  • Per ulteriori informazioni sullo schema di Active Directory, vedere la Documentazione tecnica di Schema di Active Directory, disponibile sul sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=90646.

  • Per ulteriori informazioni su come modificare lo schema di Active Directory, vedere la pagina dedicata allo schema di Active Directory sul sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80809.


Interfaccia utente: Schema di Active Directory

  • Proprietà di <NomeClasse> - Scheda Generale

  • Proprietà di <NomeClasse> - Scheda Relazione

  • Proprietà di <NomeClasse> - Scheda Attributi

  • Finestra delle proprietà di <NomeAttributo>

  • Finestra di dialogo Crea nuova classe di schema - Layout 1

  • Finestra di dialogo Crea nuova classe di schema - Layout 2

  • Finestra di dialogo Crea nuovo attributo

  • Finestra di dialogo Cambia master schema


Proprietà di <NomeClasse> - Scheda Generale

Elemento Dettagli

Nome comune

Il nome distinto relativo dell'istanza della classe.

ID oggetto X.500

L'identificatore di oggetto (noto anche come OID), rilasciato dall'organizzazione ISO e univoco per tutte le reti in tutto il mondo. Gli identificatori di oggetto assicurano che le classi o gli attributi che sono definiti da entità diverse non entrino in conflitto quando diversi servizi directory, ad esempio Servizi di domino Active Directory, vengono raggruppati in una directory globale.

Tipo classe

La classe selezionata può essere di tre tipi:

  • Strutturale: è possibile creare un'istanza della classe nella directory.

  • Astratta: la classe fornisce una definizione di base di una classe che è possibile utilizzare per creare classi strutturali.

  • Ausiliare: è possibile utilizzare la classe per estendere la definizione di una classe da cui eredita, tuttavia non può essere utilizzata per creare una classe da sola.

Categoria

Il nome di questa classe che viene utilizzato dall'agente LDAP per Servizi di dominio Active Directory. I client LDAP devono necessariamente utilizzare questo nome per accedere agli oggetti di questa classe.

Modifica

Fare clic per modificare la objectCategory predefinita della classe selezionata. Questo pulsante è disattivato per gli oggetti contrassegnati come “schema di base”.

Mostra oggetti di questa classe durante la selezione

Selezionare per controllare l'attributo defaultHidingValue sulla classe. Questo attributo controlla il valore predefinito dell'attributo showInAdvancedViewOnly per quanto riguarda gli oggetti di nuova creazione della classe.

La classe è attiva

Fare clic per disattivare la classe se è attiva.

Per recuperare la classe è possibile utilizzare la disattivazione, mentre l'eliminazione è un'operazione permanente. Quando una classe è disattivata, non è più possibile creare oggetti che siano istanze di tale classe. Anche se disattivata, la classe esiste ancora nella directory. Non è pertanto possibile creare nuove classi con lo stesso nome.

Se questa casella di controllo non è disponibile, significa che la classe è nello schema di base e deve rimanere attiva per Servizi di dominio Active Directory. Non è possibile disattivare la classe.

Ulteriori riferimenti


Proprietà di <NomeClasse> - Scheda Relazione

Elemento | Dettagli
Classe padre | La classe di cui è una sottoclasse la classe corrente. La classe corrente eredita gli attributi obbligatori e facoltativi dalla classe padre specificata.
Classi ausiliarie | Le classi o sottoclassi ausiliarie della classe padre. Una classe può avere una classe padre e molte classi ausiliarie. Gli attributi delle classi ausiliarie possono essere ereditati totalmente dalle sottoclassi.
Aggiungi classe | Fare clic per aggiungere nuove classi ausiliarie per questa classe.
Rimuovi | Fare clic per rimuovere le classi ausiliarie da questa classe.
Superiore possibile | Le strutture ad albero possibili per la directory sono specificate dalle classi che possono essere padre di una determinata classe.
Aggiungi superiore | Fare clic per aggiungere una nuova classe superiore per la classe selezionata.
Rimuovi | Fare clic per rimuovere una classe superiore dalla classe selezionata.

Ulteriori riferimenti


Proprietà di <NomeClasse> - Scheda Attributi

Elemento | Dettagli
Obbligatori | Visualizza un elenco degli attributi che non possono essere rimossi dalla classe selezionata.
Facoltativi | Visualizza un elenco degli attributi che possono essere aggiunti e rimossi dalla classe selezionata.
Aggiungi | Fare clic per aggiungere un nuovo attributo facoltativo alla classe selezionata.
Rimuovi | Fare clic per rimuovere un attributo facoltativo dalla classe selezionata.

Ulteriori riferimenti


Finestra delle proprietà di <NomeAttributo>

Scheda Dettagli

Nome comune

Il nome distinto relativo dell'istanza della classe.

ID oggetto X.500

L'identificatore di oggetto (noto anche come OID), rilasciato dall'organizzazione ISO e univoco per tutte le reti in tutto il mondo. Gli identificatori di oggetto assicurano che le classi o gli attributi che sono definiti da entità diverse non entrino in conflitto quando diversi servizi directory, ad esempio Servizi di domino Active Directory, vengono raggruppati in una directory globale.

Sintassi e intervallo di validità
  • Sintassi: un tipo di dati che è possibile utilizzare per un particolare attributo, ad esempio un numero intero, una stringa o una data. Ogni attributo di ogni oggetto è associato esattamente a una sintassi.

  • Valore minimo: i caratteri validi sono compresi tra 0 e 9. Il valore minimo accettabile è determinato dalla sintassi dell'attributo. Le sintassi Numero intero, Numero intero grande ed Enumerazione accettano numeri negativi. Per queste sintassi, il valore più piccolo che è possibile immettere è -2.147.483.648. Per tutte le altre sintassi, il valore più piccolo che è possibile immettere è 0 (zero).

  • Valore massimo: i caratteri validi sono compresi tra 0 e 9. Il valore massimo accettabile è determinato dalla sintassi dell'attributo. Se si definiscono i valori minimo e massimo, il valore massimo deve essere maggiore o uguale al valore minimo.

  • L'attributo specificato è a valore singolo: in Lightweight Directory Access Protocol (LDAP) gli attributi possono essere a valore singolo (associati a un solo valore) o multivalore (associati a molteplici valori). Un esempio di attributo a valore singolo è "manager", poiché un utente può avere un solo manager. Un esempio di attributo multivalore è "member", poiché un gruppo può avere molti membri.

L'attributo è attivo

Deselezionare questa casella di controllo per disattivare l'attributo se è attivo. È possibile utilizzare la disattivazione per poter recuperare l'attributo. L'eliminazione è un'operazione permanente.

In Servizi di dominio Active Directory non è consentito eliminare classi o attributi. Quando un attributo è disattivato, non può essere utilizzato nelle definizioni di nuove classi, né aggiunto alle definizioni di classi esistenti.

Indicizza questo attributo

L'indicizzazione di un attributo migliora l'efficienza della ricerca, tuttavia aumenta anche i requisiti di archiviazione. Indicizzare solo gli attributi che verranno ricercati con maggiore probabilità.

Risoluzione nome ambiguo (ANR)

Aggiunge l'attributo al set di attributi che è possibile ricercare con un filtro ANR nella forma (ANR=stringa). Quando viene rilevato da Servizi di dominio Active Directory, il filtro (ANR=stringa) viene espanso in modo da includere una ricerca di tutti gli attributi nel set ANR. Ad esempio, viene implementata una ricerca ANR quando si utilizza l'opzione Controlla nomi in Microsoft Outlook per eseguire una ricerca in un server di posta Microsoft Exchange. Dal momento che physicalDeliveryOfficeName appartiene al set di attributi ANR predefinito, è possibile digitare nella riga A di un messaggio di posta il numero civico e l'interno esattamente come appaiono nel valore dell'attributo, quindi scegliere Crontrolla nomi. La Rubrica visualizzerà il nome utente di tutti gli account che contengono tale valore nell'attributo physicalDeliveryOfficeName di un oggetto utente. Questa opzione è disponibile solo per gli attributi a valore singolo.

Replica questo attributo nel catalogo globale

Aggiunge l'attributo al set di attributi parziali (PAS) che viene replicato per tutti i controller di dominio nella foresta. Mentre tutti gli oggetti vengono replicati nel catalogo globale, solo gli attributi inclusi nel set PAS vengono replicati. È consigliabile includere nel set PAS gli attributi che verranno utilizzati con maggiore probabilità per la ricerca dell'oggetto.

Copia attributo quando un utente viene duplicato

Si riferisce solo agli attributi che sono presenti nella classe utente. Quando viene eseguita una copia di un oggetto utente per creare una nuova istanza dell'utente, tali attributi vengono inclusi.

Indicizza questo attributo per ricerche nei contenitori

Consente di definire la ricerca di un attributo che si trova in un contenitore specifico.

Ulteriori riferimenti


Finestra di dialogo Crea nuova classe di schema - Layout 1

Elemento Dettagli

Nome comune

Il nome che rappresenta un oggetto e che è utilizzato per eseguire le ricerche.

Nome LDAP

Il nome che verrà utilizzato dai client LDAP (Lightweight Directory Access Protocol), ad esempio dal provider LDAP di Active Directory Service Interfaces (ADSI), per la lettura e scrittura dell'attributo tramite il protocollo LDAP.

ID oggetto X500 univoco

Il valore per l'attributo governsID in un oggetto classSchema. La notazione dell'identificatore di oggetto è una stringa puntata di numeri non negativi, ad esempio 1.2.840.113556.1.5.4.

Eredità e tipo

Classe padre: un nuovo oggetto viene definito come sottoclasse dell'oggetto padre. La sottoclasse eredita le regole relative a struttura e contenuto dalla classe padre. L'oggetto padre diventa una superclasse del nuovo oggetto.

Tipo classe: Uno dei valori seguenti:

  • Strutturale: le sole classi che possono disporre di istanze nella directory.

  • Astratta: i modelli utilizzati per generare nuove classi strutturali. Nessun oggetto può appartenere soltanto a una classe astratta. Ogni oggetto di una classe astratta appartiene anche a una sottoclasse strutturale di tale classe.

  • Ausiliare: contiene un elenco di attributi. Quando si aggiunge una classe ausiliare alla definizione di una classe strutturale o di una classe astratta, gli attributi della classe ausiliare vengono aggiunti alla definizione.

Ulteriori riferimenti


Finestra di dialogo Crea nuova classe di schema - Layout 2

Elemento | Dettagli
Obbligatori | Elenca gli attributi di oggetto per i quali è obbligatorio specificare un valore. Se non è specificato un valore per un attributo obbligatorio, viene assegnato un valore predefinito all'attributo oppure l'oggetto non verrà creato finché non verrà specificato un valore per l'attributo.
Aggiungi | Fare clic per aggiungere gli attributi obbligatori alla classe che viene creata.
Rimuovi | Fare clic per rimuovere gli attributi obbligatori dalla classe che viene creata.
Facoltativi | Elenca gli attributi di oggetto per i quali non è necessario un valore.
Aggiungi | Fare clic per aggiungere gli attributi facoltativi alla classe che viene creata.
Rimuovi | Fare clic per rimuovere gli attributi facoltativi dalla classe che viene creata.

Ulteriori riferimenti


Finestra di dialogo Crea nuovo attributo

Elemento Dettagli

Nome comune

Il nome che rappresenta un oggetto e che è utilizzato per eseguire le ricerche.

Nome LDAP

Il nome che verrà utilizzato dai client LDAP (Lightweight Directory Access Protocol), ad esempio dal provider LDAP di Active Directory Service Interfaces (ADSI), per la lettura e scrittura dell'attributo tramite il protocollo LDAP.

ID oggetto X.500 univoco

L'identificatore di oggetto (noto anche come OID) che rappresenta il valore per l'attributo attributeID dell'oggetto attributeSchema. È necessario rivolgersi all'organizzazione ISO (International Standards Organization) o a Microsoft per ottenere un identificatore di oggetto X.500 univoco.

Sintassi e intervallo di validità
  • Sintassi: consente di specificare un elenco delle sintassi disponibili, ovvero i tipi di dati che è possibile assegnare a un nuovo attributo, ad esempio numero intero, stringa o data. Ogni attributo di ogni oggetto è associato esattamente a una sintassi.

  • Valore minimo: casella in cui è possibile specificare il valore minimo per il nuovo attributo. I caratteri validi sono compresi tra 0 e 9. Il valore minimo accettabile è determinato dalla sintassi dell'attributo. Le sintassi Numero intero, Numero intero grande ed Enumerazione accettano numeri negativi. Per queste sintassi, il valore più piccolo che è possibile immettere è -2.147.483.648. Per tutte le altre sintassi, il valore più piccolo che è possibile immettere è 0 (zero).

  • Valore massimo: casella in cui è possibile specificare il valore massimo per il nuovo attributo. I caratteri validi sono compresi tra 0 e 9. Il valore massimo accettabile è determinato dalla sintassi dell'attributo. Se si definiscono i valori minimo e massimo, il valore massimo deve essere maggiore o uguale al valore minimo.

Multivalore

Fare clic se il nuovo attributo dovrà essere multivalore. In LDAP gli attributi possono essere a valore singolo (associati a un solo valore) o multivalore (associati a molteplici valori). Un esempio di attributo a valore singolo è "manager", poiché un utente può avere un solo manager. Un esempio di attributo multivalore è "member", poiché un gruppo può avere molti membri.

Ulteriori riferimenti


Finestra di dialogo Cambia master schema

Elemento | Dettagli
Master schema corrente (online) | Se il master schema non è online, il contenuto di questo elemento è "Master schema corrente (offline)" e il valore è ERRORE. Se si cambia il proprietario del ruolo di master operazioni schema (noto anche come Operazioni FSMO, Flexible Single Master Operations) mentre il master schema è offline, è necessario seguire le istruzioni per la requisizione del ruolo di master schema, che è un'operazione diversa dal trasferimento del ruolo. La requisizione del ruolo di master schema è un intervento delicato ed è pertanto consigliabile ricorrervi solo se il trasferimento del ruolo non è possibile. Prima di requisire il ruolo di master schema, approfondire le implicazioni di tale operazione nella documentazione tecnica dedicata a Master operazioni, disponibile sul sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80873. Quindi seguire le istruzioni fornite per la requisizione del ruolo di master schema sul sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80874.
Proprietario FSMO dello schema indicato | Il controller di dominio in questa casella deve essere diverso dal master schema corrente. Se il nome di tale controller di dominio è identico al nome specificato in Master schema corrente (online), è necessario utilizzare il comando Cambia controller di dominio Active Directory per indicare allo snap-in il controller di dominio che dovrà diventare il master schema.
Modifica | Fare clic per eseguire il trasferimento dal master schema corrente al controller di dominio di destinazione.

Ulteriori riferimenti