Scheda Agente di SNMP

SNMP (Simple Network Management Protocol) è un protocollo di rete utilizzato per la gestione delle reti TCP/IP. In Windows il Servizio SNMP, conosciuto anche come agente SNMP, viene utilizzato per fornire informazioni di stato relative a un host SNMP su una rete TCP/IP.

I sistemi di gestione SNMP possono richiedere il nome del contatto, la posizione del sistema e i servizi di rete per il computer inviando una richiesta SNMP.

Controlli dell'agente SNMP

Contatto: casella in cui digitare il nome della persona che amministra il computer.

Percorso: casella in cui digitare la posizione fisica del computer, ad esempio l'edificio e il numero dell'ufficio.

Servizio: sono disponibili cinque opzioni basate sul servizio. Gli agenti SNMP forniscono informazioni sull'host SNMP al sistema di gestione SNMP:

  • Fisico: specifica se il computer gestisce dispositivi fisici, ad esempio un disco rigido.

  • Applicazioni: specifica se il computer utilizza applicazioni che inviano dati tramite TCP/IP.

  • Collegamento dati e subnet: specifica se il computer gestisce un bridge.

  • Internet: specifica se il computer è un gateway IP (router).

  • End-to-end: specifica se il computer è un host IP.

Ulteriori riferimenti

Per ulteriori informazioni su SNMP, vedere la pagina relativa a Simple Network Management Protocol nelle nozioni fondamentali sul protocollo TCP/IP per Windows nella Libreria Technet Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66006.


Scheda Sicurezza di SNMP

SNMP (Simple Network Management Protocol) è un protocollo di rete utilizzato per la gestione delle reti TCP/IP. In Windows il Servizio SNMP, conosciuto anche come agente SNMP, viene utilizzato per fornire informazioni di stato relative a un host SNMP su una rete TCP/IP.

SNMP assicura la sicurezza utilizzando nomi di community e trap di autenticazione SNMP. Una trap SNMP è un messaggio di notifica eventi inviato dal servizio Trap SNMP in esecuzione su un host SNMP. La trap SNMP viene inviata agli altri SNMP o a un sistema di gestione SNMP, conosciuti come destinazioni trap.

È possibile limitare le comunicazioni SNMP per l'agente SNMP, consentendogli di comunicare solo con uno specifico elenco di community.

Controlli della sicurezza SNMP

Invia trap di autenticazione: Specifica se deve essere inviato un messaggio trap SNMP a tutte le destinazioni trap quando l'host SNMP riceve una richiesta SNMP da un host o da una community SNMP non presente nella scheda Sicurezza. L'autenticazione è il processo di verifica della validità di un nome host o di un indirizzo. Quando l'agente SNMP riceve una richiesta che non contiene un nome di community conosciuto o che non proviene da un membro dell'elenco di host accettabili, l'agente SNMP invia un messaggio trap di autenticazione a una o più destinazioni trap per segnalare la mancata autenticazione. Questa casella di controllo è selezionata per impostazione predefinita.

Nomi community accettati: elenca i nomi delle community i cui host SNMP sono autenticati per l'invio di richieste SNMP a questo computer. Un nome di community svolge la funzione di password condivisa da uno o più host SNMP.

I nomi di community accettati vengono utilizzati solo per autenticare i messaggi in ingresso. Per controllare i messaggi in uscita, aggiungere l'host SNMP come destinazione trap nella scheda Trap.

Per il servizio Trap SNMP è necessario almeno un nome di community. Pubblico è il nome di community predefinito che viene accettato in tutte le implementazioni di SNMP. È possibile aggiungere più nomi di community, nonché eliminare o modificare il nome di community predefinito. Se viene ricevuta una richiesta SNMP da una community non presente in questo elenco, verrà generata una trap di autenticazione.

Attenzione

Se vengono rimossi tutti i nomi di community, compreso il nome Pubblico predefinito, il Servizio SNMP non risponderà più ad alcun nome di community.

  • Aggiungi: aggiunge un nome di community e le relative autorizzazioni all'elenco di community che possono inviare richieste SNMP a questo host SNMP. Utilizzare i livelli di autorizzazione seguenti per specificare la modalità di elaborazione delle richieste SNMP provenienti da una community selezionata da parte dell'host SNMP:

    • Nessuno: impedisce all'host di elaborare le richieste SNMP.

    • Notifica: consente all'host di inviare solo trap SNMP alla community.

    • Sola lettura: impedisce all'host di elaborare le richieste SET SNMP. Gli oggetti gestiti SNMP hanno valori predefiniti specificati dall'agente. È possibile che alcune applicazioni richiedano la modifica di questi valori con il comando SET SNMP.

    • Lettura/Scrittura: consente all'host di elaborare le richieste SET SNMP.

    • Lettura/Creazione: consente all'host di creare nuove voci nelle tabelle SNMP.

  • Modifica: visualizza una finestra di dialogo che consente di modificare il nome di community selezionato e le relative autorizzazioni.

  • Rimuovi: rimuove il nome di community selezionato dall'elenco.

Accetta pacchetti SNMP da qualsiasi host: specifica che vengono elaborati tutti i pacchetti SNMP provenienti da tutti gli host SNMP appartenenti a una delle community elencate in Nomi community accettati. Nessun pacchetto SNMP verrà rifiutato sulla base del nome host o dell'indirizzo IP dell'host di origine o dell'elenco di host accettabili. Questa casella di controllo è selezionata per impostazione predefinita.

Accetta pacchetti SNMP da questi host: elenca gli host SNMP e i sistemi di gestione SNMP che possono inviare richieste SNMP a questo host SNMP. Questa impostazione assicura un livello di sicurezza più elevato rispetto all'utilizzo di un nome di community, che può contenere un ampio gruppo di host. È possibile aggiungere il nome di qualunque host SNMP o sistema di gestione SNMP appartenente a una delle community elencate in Nomi community accettati. Verranno accettati solo i pacchetti SNMP ricevuti dagli host presenti nell'elenco. Tutti gli altri messaggi SNMP verranno rifiutati e quindi verranno inviate trap di autenticazione.

  • Aggiungi: aggiunge uno specifico nome host SNMP o sistema di gestione SNMP all'elenco di origini accettabili.

  • Modifica: visualizza una finestra di dialogo che consente di modificare il nome computer o l'indirizzo IP dell'host SNMP selezionato.

  • Rimuovi: rimuove dall'elenco l'host SNMP o il sistema di gestione SNMP selezionato.

Ulteriori riferimenti

Per ulteriori informazioni su SNMP, vedere la pagina relativa a Simple Network Management Protocol nelle nozioni fondamentali sul protocollo TCP/IP per Windows nella Libreria Technet Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66006.


Scheda Trap di SNMP

SNMP (Simple Network Management Protocol) è un protocollo di rete utilizzato per la gestione delle reti TCP/IP. In Windows il Servizio SNMP, conosciuto anche come agente SNMP, viene utilizzato per fornire informazioni di stato relative a un host SNMP su una rete TCP/IP.

Una trap SNMP è un messaggio di notifica eventi inviato dal servizio Trap SNMP in esecuzione su un host SNMP. La trap SNMP viene inviata agli altri SNMP o a un sistema di gestione SNMP, conosciuti come destinazioni trap.

Quando sono richieste le trap, devono essere specificati uno o più nomi di community. Le destinazioni trap possono esse specificate come nomi di host o indirizzi IP.

Controlli delle trap SNMP

Nome community: casella in cui digitare o selezionare un nome di community che si desidera venga utilizzato dalle destinazioni trap. Un nome di community svolge la funzione di password condivisa da uno o più host SNMP. L'agente SNMP può inviare messaggi trap SNMP solo agli host SNMP che utilizzano un nome di community noto. I nomi di community elencati nella scheda Trap sono utilizzati solo per l'autenticazione dei messaggi trap SNMP in uscita. Per autenticare tutti i messaggi trap SNMP in ingresso, configurare questo host SNMP nella scheda Sicurezza.

Aggiungi all'elenco: aggiunge un nome di community all'elenco Nome community.

Rimuovi dall'elenco: rimuove il nome di community selezionato dall'elenco Nome community.

Destinazioni trap: elenca le destinazioni trap, ovvero i sistemi di gestione SNMP che ricevono messaggi trap SNMP da qualsiasi host SNMP nella community selezionata.

Aggiungi: aggiunge un sistema di gestione SNMP all'elenco di destinazioni trap per la community selezionata.

Modifica: visualizza una finestra di dialogo che consente di modificare il nome host o l'indirizzo IP della destinazione trap selezionata.

Rimuovi: rimuove il sistema di gestione SNMP selezionato dall'elenco di destinazioni trap per la community selezionata.

Ulteriori riferimenti

Per ulteriori informazioni su SNMP, vedere la pagina relativa a Simple Network Management Protocol nelle nozioni fondamentali sul protocollo TCP/IP per Windows nella Libreria Technet Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66006.