Creazione guidata origine dati - Schermata 1

Nella prima schermata della procedura guidata, è possibile specificare il nome e la descrizione dell'origine dati, nonché il nome del server che esegue Microsoft SQL Server al quale si connetterà l'origine dati.

Casella Nome

Nome dell'origine dati utilizzato da un'applicazione ODBC quando richiede una connessione all'origine dati, ad esempio "Personale". Il nome dell'origine dati viene visualizzato nella finestra di dialogo Amministrazione origine dati ODBC.

Casella Descrizione

Descrizione facoltativa dell'origine dati, ad esempio "Data assunzione, cronologia stipendi e situazione corrente di tutti i dipendenti".

Casella Server

Nome di un'istanza SQL Server in rete. Se il nome del server viene selezionato dall'elenco, non sono necessarie ulteriori configurazioni. Se si immette il nome di un server che non esiste come voce nell'utilità Configurazione client SQL Server, è possibile creare un alias del server per il nuovo nome nella successiva schermata della procedura guidata.

Nella casella Server è possibile specificare "(locale)" quando si utilizza lo stesso computer in cui è installato SQL Server. In questo modo sarà possibile connettersi alla copia locale di SQL Server, anche in caso di esecuzione di una versione non in rete di SQL Server. Sono supportate più istanze di SQL Server in esecuzione nello stesso computer. Per specificare un'istanza denominata di SQL Server, il nome del server deve essere specificato come NomeServer\NomeIstanza.

Per ulteriori informazioni sui nomi dei server per tipi diversi di reti, vedere la documentazione di installazione di SQL Server online.

Se le informazioni specificate in questa schermata sono tutto ciò che occorre per connettersi a SQL Server, è possibile fare clic su Fine. Per tutti gli attributi specificati nelle altre schermate della procedura guidata verranno utilizzate le impostazioni predefinite.


Creazione guidata origine dati - Schermata 2

Nella seconda schermata della procedura guidata, è possibile specificare il metodo di autenticazione. È inoltre possibile configurare le voci del client avanzato di Microsoft SQL Server e specificare l'account di accesso e la password che il driver ODBC di SQL Server utilizzerà per connettersi a SQL Server durante la configurazione dell'origine dati.

Autenticazione Windows NT tramite ID di accesso alla rete

Il pulsante di opzione Autenticazione Windows NT tramite ID di accesso alla rete specifica che il driver ODBC di SQL Server richiederà una connessione protetta (o trusted) a un'istanza di SQL Server. Se si seleziona questa opzione, in SQL Server verrà utilizzata la sicurezza di account di accesso integrata per stabilire connessioni con questa origine dati, indipendentemente dalla modalità di sicurezza degli accessi corrente nel server. Qualsiasi password o ID di accesso specificato viene ignorato. L'amministratore di sistema di SQL Server deve associare l'account di accesso di Windows a un ID di accesso di SQL Server.

Autenticazione SQL Server tramite ID e password di accesso immessi dall'utente

Il pulsante di opzione Autenticazione SQL Server tramite ID e password di accesso immessi dall'utente specifica che il driver ODBC di SQL Server non richiederà una connessione protetta (o trusted) a un'istanza di SQL Server. Quando questa opzione è selezionata, in SQL Server viene utilizzata la sicurezza degli accessi standard per stabilire connessioni utilizzando l'origine dati. È necessario specificare un ID di accesso e una password di SQL Server per tutte le richieste di connessione.

Configurazione client

Il pulsante Configurazione client consente di aprire la finestra di dialogo Aggiungi configurazione libreria di rete.

Se nella casella Server della prima schermata della procedura guidata è stato specificato un nuovo nome, potrebbe essere necessario utilizzare questa finestra di dialogo per aggiungere una voce di configurazione dell'alias del server il cui nome corrisponda al nome specificato nella casella Server nella prima schermata della procedura guidata ODBC. Il nome dell'alias deve corrispondere al nome specificato nella casella Server. Per SQL Server una configurazione dell'alias del server generalmente non è necessaria. Nella maggior parte dei casi il driver ODBC di SQL Server può connettersi utilizzando il valore predefinito nell'elenco Librerie di rete e il nome di rete specificato nella casella Server nella prima schermata della procedura guidata.

Fare clic su Configurazione client se per la connessione si desidera utilizzare una libreria di rete diversa dalla libreria di rete predefinita del client. Scegliere inoltre Configurazione client se per stabilire una connessione è necessario specificare l'indirizzo di rete effettivo del server. Se, ad esempio, si utilizza la libreria di rete TCP/IP, potrebbe essere necessario specificare la porta e l'indirizzo socket del server. Se un'istanza di SQL Server è in attesa su una named pipe alternativa, è necessario specificare il nome della pipe nella voce avanzata.

Per ulteriori informazioni sulla configurazione dei client, vedere la documentazione di SQL Server online.

Connettersi al server SQL per ottenere le impostazioni predefinite per ulteriori opzioni di configurazione

Quando si seleziona la casella di controllo Connettersi al server SQL per ottenere le impostazioni predefinite per ulteriori opzioni di configurazione, il driver SQL Server ottiene dall'istanza di SQL Server le impostazioni iniziali per le opzioni delle schermate successive della procedura guidata. Il driver SQL Server si connette all'istanza di SQL Server specificata nella casella Server della prima schermata.

Quando questa casella di controllo è deselezionata, il driver utilizza le impostazioni predefinite standard come impostazioni iniziali per le opzioni delle schermate successive della procedura guidata.

Casella ID accesso

La casella ID accesso specifica l'ID di accesso utilizzato dal driver SQL Server durante la connessione a SQL Server se il pulsante di opzione Autenticazione SQL Server tramite ID e password di accesso immessi dall'utente è selezionato. Si applica solo alla connessione effettuata per determinare le impostazioni predefinite del server. Non si applica alle connessioni successive effettuate utilizzando l'origine dati dopo la relativa creazione.

Casella Password

La casella Password specifica la password utilizzata dall'istanza di SQL Server durante la connessione a SQL Server se il pulsante di opzione Autenticazione SQL Server tramite ID e password di accesso immessi dall'utente è selezionato. Si applica solo alla connessione effettuata per determinare le impostazioni predefinite del server. Non si applica alle connessioni successive effettuate utilizzando la nuova origine dati.

Le caselle ID accesso e Password sono disattivate se è selezionato il pulsante di opzione Autenticazione Windows NT tramite ID di accesso alla rete o se è deselezionata la casella di controllo Connettersi al server SQL per ottenere le impostazioni predefinite per ulteriori opzioni di configurazione.


Creazione guidata origine dati - Schermata 3

Nella terza schermata della procedura guidata è possibile specificare il database predefinito, la modalità di utilizzo delle stored procedure da parte del driver per il supporto di SQLPrepare, diverse opzioni ANSI utilizzate dal driver e l'eventuale utilizzo di un server secondario.

Casella Usa il seguente database predefinito

La casella Usa il seguente database predefinito specifica il nome del database predefinito per qualsiasi connessione stabilita utilizzando questa origine dati. Se questa casella viene deselezionata, le connessioni utilizzeranno il database predefinito indicato per l'ID di accesso nel server. Se questa casella viene selezionata, il database specificato sostituirà il database predefinito indicato per l'ID di accesso. Se la casella Associa file di database contiene il nome di un file primario, il database descritto dal file primario viene associato utilizzando il nome del database specificato nella casella Usa il seguente database predefinito.

L'utilizzo del database predefinito per l'ID di accesso è più efficiente rispetto all'impostazione di un database predefinito nell'origine dati ODBC.

Casella Associa file di database

La casella Associa file di database specifica il nome del file primario di un database associabile. Tale database viene associato e utilizzato come database predefinito per l'origine dati. Specificare il percorso completo e il nome del file primario. Il nome del database specificato nella casella Usa il seguente database predefinito viene utilizzato come nome del database associato.

Casella di controllo Crea stored procedure temporanee per istruzioni SQL preparate ed elimina le stored procedure

Se la casella di controllo Crea stored procedure temporanee per istruzioni SQL preparate ed elimina le stored procedure è deselezionata, il driver Microsoft SQL Server non crea stored procedure per supportare la funzione ODBC SQLPrepare. Se la casella è selezionata, il driver SQL Server crea stored procedure temporanee per supportare la funzione ODBC SQLPrepare.

Pulsante di opzione Solo alla chiusura della connessione

Il pulsante di opzione Solo alla chiusura della connessione specifica che le stored procedure temporanee create per SQLPrepare saranno eliminate quando viene chiamata la funzione ODBC SQLDisconnect. In questo modo il driver può riutilizzare le stored procedure se la stessa istruzione SQL viene preparata più volte, riducendo così il sovraccarico dovuto alla rimozione delle stored procedure durante l'esecuzione dell'applicazione. La selezione di questa opzione per un'applicazione eseguita per molto tempo senza disconnessione o per un'applicazione che genera molte chiamate SQLPrepare può provocare la creazione di stored procedure temporanee.

Pulsante di opzione Alla chiusura della connessione e quando necessario durante la connessione

Il pulsante di opzione Alla chiusura della connessione e quando necessario durante la connessione specifica che le stored procedure temporanee create per SQLPrepare saranno eliminate quando viene chiamata una delle seguenti funzioni: SQLDisconnect, SQLFreeHandle per l'handle di istruzione, SQLPrepare o SQLExecDirect per elaborare una nuova istruzione SQL sullo stesso handle di istruzione o una funzione di catalogo. In questo modo si genera del sovraccarico a causa della rimozione delle stored procedure temporanee durante l'esecuzione dell'applicazione, ma si impedisce la creazione di stored procedure temporanee in caso di applicazioni a lunga esecuzione.

Casella di controllo Usa identificatori ANSI tra virgolette

La casella di controllo Usa identificatori ANSI tra virgolette specifica che QUOTED_IDENTIFIERS deve essere impostato al momento della connessione del driver ODBC di SQL Server. Se la casella è selezionata, in SQL Server vengono applicate le regole ANSI relative alle virgolette. Le virgolette doppie possono essere utilizzate solo per gli identificatori, ad esempio i nomi di colonna e tabella. Le stringhe di caratteri devono essere racchiuse tra virgolette singole:

Copia codice
SELECT "au_id"
FROM "authors"
WHERE "au_lname" = 'O''Brien'

Se questa casella di controllo è deselezionata, le applicazioni che utilizzano gli identificatori tra virgolette, ad esempio l'utilità Microsoft Query distribuita con Microsoft Excel, provocano errori quando generano istruzioni SQL con identificatori tra virgolette.

Casella di controllo Usa avvisi, padding e caratteri nulli ANSI

La casella di controllo Usa avvisi, padding e caratteri nulli ANSI specifica che le opzioni ANSI_NULLS, ANSI_WARNINGS e ANSI_PADDINGS devono essere impostate al momento della connessione del driver SQL Server.

Se ANSI_NULLS è impostato, il server applica le regole ANSI relative al confronto delle colonne per individuare i valori NULL. La sintassi ANSI "IS NULL" o "IS NOT NULL" deve essere utilizzata per tutti i confronti di valori NULL. La sintassi Transact-SQL "= NULL" non è supportata.

Se ANSI_WARNINGS è impostato, in SQL Server vengono generati messaggi di avviso per le condizioni che violano le regole ANSI ma non le regole Transact-SQL. Sono esempi di tali errori il troncamento dei dati durante l'esecuzione di un'istruzione INSERT o UPDATE e il rilevamento di un valore Null durante una funzione di aggregazione.

Se ANSI_PADDING è impostato, gli spazi vuoti finali nei valori varchar e gli zeri finali nei valori varbinary non vengono rimossi automaticamente.

Casella di controllo Usa il server SQL secondario se il server SQL principale non è disponibile

La casella di controllo Usa il server SQL secondario se il server SQL principale non è disponibile specifica che quando viene definito un server secondario per il server SQL specificato nell'origine dati, il driver SQL Server raccoglie le informazioni di connessione relative al server secondario quando si connette al server principale specificato. Se la connessione al server SQL principale viene persa, l'applicazione rimuove la transazione corrente e cerca di riconnettersi al server SQL principale. Se il driver rileva che il server principale non è disponibile, si connette automaticamente al server secondario. Questa opzione è disattivata se il server non supporta operazioni di failover.


Creazione guidata origine dati - Schermata 4

Nella quarta schermata della procedura guidata, è possibile specificare gli elementi seguenti: la lingua da utilizzare per i messaggi di Microsoft SQL Server, la conversione del set di caratteri e l'eventuale utilizzo delle impostazioni internazionali da parte del driver SQL Server. È inoltre possibile controllare la registrazione di query a lunga esecuzione e le impostazioni delle statistiche del driver.

Casella Visualizza i messaggi di sistema di SQL Server in

Ogni istanza di SQL Server può disporre di più set di messaggi di sistema e per ogni set è possibile impostare una lingua diversa (italiano, inglese, francese e così via). Se viene definita un'origine dati per un server che dispone di più set di messaggi di sistema, è possibile specificare la lingua da utilizzare per i messaggi di sistema. Selezionare la lingua desiderata nell'elenco. L'opzione Visualizza i messaggi di sistema di SQL Server in non è disponibile se nell'istanza di SQL Server viene installata un'unica lingua.

Casella di controllo Converti dati caratteri

Quando viene selezionata la casella di controllo Converti dati caratteri, il driver ODBC di SQL Server converte stringhe ANSI inviate tra il computer client e SQL Server utilizzando Unicode. Il driver ODBC di SQL Server in alcuni casi esegue la conversione tra la tabella codici di SQL Server e Unicode nel computer client. Per questa operazione è necessario che la tabella codici utilizzata da SQL Server sia una delle tabelle codici disponibili nel computer client.

Se questa casella di controllo è deselezionata, i caratteri estesi non vengono convertiti in stringhe di caratteri ANSI quando tali caratteri vengono inviati tra l'applicazione client e il server. Se nel computer client viene utilizzata una tabella codici ANSI diversa dalla tabella codici di SQL Server, i caratteri estesi nelle stringhe di caratteri ANSI possono essere interpretati in modo non corretto. Se nel computer client viene utilizzata come tabella codici ANSI la stessa tabella codici utilizzata da SQL Server, i caratteri estesi vengono interpretati correttamente.

Casella di controllo Usa le impostazioni internazionali del sistema per visualizzare simboli di valuta, numeri, data e ora

La casella di controllo Usa le impostazioni internazionali del sistema per visualizzare simboli di valuta, numeri, data e ora specifica che il driver utilizza le impostazioni internazionali del computer client per la formattazione di valuta, numeri, date e ore nelle stringhe di caratteri di output. Vengono utilizzate le impostazioni internazionali predefinite per l'account di accesso dell'utente che si connette tramite l'origine dati. Selezionare questa opzione per le applicazioni che effettuano solo la visualizzazione dei dati, non per quelle che consentono di elaborare i dati.

Casella Salva query a lunga esecuzione nel seguente file registro

La casella Salva query a lunga esecuzione nel seguente file registro specifica che il driver registra tutte le query con una durata superiore al valore impostato in Durata query lunghe. Le query a lunga esecuzione vengono registrate nel file specificato. Per specificare un file di registro, digitare il percorso completo e il nome file nella casella oppure fare clic su Sfoglia per selezionare un file di registro spostandosi tra le directory esistenti.

Casella Durata query lunghe (millisecondi)

La casella Durata query lunghe (millisecondi) specifica un valore di soglia, in millisecondi, per la registrazione delle query a lunga esecuzione. Qualsiasi query con una durata superiore al numero di millisecondi impostato viene registrata.

Casella Salva statistiche del driver ODBC nel seguente file registro

La casella Salva statistiche del driver ODBC nel seguente file registro specifica che le statistiche verranno registrate nel file specificato. Per specificare un file di registro, digitare il percorso completo e il nome file nella casella oppure fare clic su Sfoglia per selezionare un file di registro spostandosi tra le directory esistenti.

Il file registro delle statistiche è un file delimitato da tabulazioni che può essere analizzato in Microsoft Excel o in qualsiasi altra applicazione in grado di supportare i file delimitati da tabulazioni.


Finestra di dialogo Connessione SQL Server (ODBC)

Quando si cerca di stabilire una connessione ODBC senza fornire al driver informazioni sufficienti per la connessione a un'istanza di SQL Server, il driver ODBC di Microsoft SQL Server visualizza la finestra di dialogo Connessione SQL Server.

Alla prima visualizzazione, la finestra di dialogo Connessione SQL Server contiene solo gli elementi seguenti:

  • Casella Server o nome dell'origine dati

  • Casella di controllo Usa connessione trusted

  • Casella ID accesso

  • Casella Password

  • Pulsanti OK, Annulla, ? e Opzioni

Facendo clic sul pulsante Opzioni, la finestra di dialogo si espande per contenere anche il gruppo Opzioni:

  • Casella Database

  • Casella Lingua

  • Casella Nome applicazione

  • Casella ID workstation

Casella Server

Nome di un server SQL in rete. Se il nome del server viene selezionato dall'elenco, non sono necessarie ulteriori configurazioni. Se il nome del server viene digitato, deve essere una voce avanzata nell'utilità Configurazione client SQL Server o il nome di rete di un server che esegue SQL Server. Questa casella viene sostituita dal nome origine dati (DSN, Data Source Name) se è stato specificato un nome DSN per la connessione.

Nella casella Server è possibile specificare "(locale)" se si utilizza lo stesso computer in cui è installato SQL Server. In questo modo sarà possibile connettersi a una copia locale di SQL Server, anche in caso di esecuzione di una versione non in rete di SQL Server.

Per ulteriori informazioni sui nomi dei server per tipi diversi di reti, vedere la documentazione di installazione di SQL Server online.

Casella di controllo Usa connessione trusted

Se selezionata, specifica che il driver ODBC di SQL Server richiederà una connessione protetta (o trusted) a SQL Server. Se si seleziona questa opzione, in SQL Server verrà utilizzata la sicurezza di account di accesso integrata, Autenticazione di Windows, per stabilire connessioni con questa origine dati, indipendentemente dalla modalità di sicurezza degli accessi corrente nel server. Qualsiasi password o ID di accesso specificato viene ignorato. L'amministratore di sistema di SQL Server deve associare l'ID di rete di Windows a un ID di accesso di SQL Server.

Quando questa casella è deselezionata, in SQL Server viene utilizzata la sicurezza degli accessi standard, Autenticazione di SQL Server, per stabilire connessioni utilizzando l'origine dati. È necessario specificare un ID di accesso e una password per tutte le richieste di connessione.

Casella ID accesso

Specifica l'ID di accesso di SQL Server da utilizzare per la connessione se l'opzione Usa connessione trusted è deselezionata. Se Usa connessione trusted è selezionata, la casella ID accesso è disattivata.

Casella Password

Specifica la password per l'ID di accesso di SQL Server utilizzato per la connessione se l'opzione Usa connessione trusted è deselezionata. Se Usa connessione trusted è selezionata, la casella Password è disattivata.

Casella Database

Specifica il database predefinito da utilizzare per la connessione. Questa impostazione è prioritaria rispetto al database predefinito specificato per l'accesso nel server. Se non viene specificato alcun database, viene utilizzato il database predefinito specificato per l'accesso nel server.

Casella Lingua

Specifica la lingua da utilizzare per i messaggi di sistema di SQL Server. Tale lingua deve essere installata nell'istanza di SQL Server. Questa impostazione è prioritaria rispetto alla lingua predefinita specificata per l'accesso nel server. Se non viene specificata alcuna lingua, viene utilizzata la lingua predefinita indicata per l'account di accesso nel server.

Casella Nome applicazione

Facoltativa. Specifica il nome dell'applicazione da archiviare nella colonna program_name nella riga relativa alla connessione corrente in master.dbo.sysprocesses.

Casella ID workstation

Facoltativa. Specifica l'ID della workstation da archiviare nella colonna hostname nella riga relativa alla connessione corrente in master.dbo.sysprocesses.


Copyright e informazioni legali

Le informazioni contenute nel presente documento, inclusi URL e altri riferimenti a siti Web, sono soggette a modifiche senza preavviso. Se non specificato diversamente, ogni riferimento a società, organizzazioni, prodotti, nomi di dominio, indirizzi di posta elettronica, logo, persone, luoghi ed eventi utilizzati negli esempi è puramente casuale e ha il solo scopo di illustrare l'uso del prodotto Microsoft. Nessuna associazione con nessuna società, organizzazione, prodotto, nome di dominio, indirizzo di posta elettronica, logo, persona, luogo o evento è intenzionale o può essere presupposta. Il rispetto di tutte le leggi applicabili in materia di copyright è esclusivamente a carico dell'utente. Fermi restando tutti i diritti coperti da copyright, nessuna parte del presente documento potrà comunque essere riprodotta, archiviata o inserita in un sistema di riproduzione o trasmessa in qualsiasi forma e con qualsiasi mezzo (in formato elettronico, meccanico, fotocopia, tramite registrazione o altro) per qualsiasi scopo, senza il permesso scritto di Microsoft Corporation.

Microsoft può essere titolare di brevetti, domande di brevetto, marchi, copyright o altri diritti di proprietà intellettuale relativi all'oggetto del presente documento. Salvo quanto espressamente previsto in un contratto scritto di licenza Microsoft, la consegna del presente documento non implica la concessione di alcuna licenza su tali brevetti, marchi, copyright o altra proprietà intellettuale.

© 2009 Microsoft Corporation. Tutti i diritti riservati.

Microsoft, Active Directory, ActiveX, JScript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SQL Server, Visual Basic, Visual C++, Visual Studio, Win32, Windows e Windows NT sono marchi di Microsoft Corporation.

Altri nomi di prodotti e società citati nel presente documento possono essere marchi dei rispettivi proprietari.