Gestione condivisione e archiviazione

Gestione condivisione e archiviazione consente di utilizzare una posizione centralizzata per la gestione delle risorse condivise, quali cartelle e volumi, e delle risorse di archiviazione.

  • Panoramica di Gestione condivisione e archiviazione

  • Eseguire il provisioning di risorse condivise

  • Eseguire il provisioning di un'archiviazione

  • Gestire una risorsa condivisa esistente

  • Gestire le autorizzazioni per le cartelle condivise

  • Gestione di un volume esistente

  • Gestire risorse condivise e archiviazione in un computer remoto

  • Risolvere i problemi relativi a Gestione condivisione e archiviazione


Panoramica di Gestione condivisione e archiviazione

Con Gestione condivisione e archiviazione è possibile utilizzare una posizione centralizzata per la gestione di due importanti risorse del server:

  • Cartelle e volumi condivisi in rete

  • Volumi in sottosistemi di archiviazione e dischi

Gestione delle risorse condivise

È possibile condividere in rete il contenuto delle cartelle e dei volumi del server utilizzando Preparazione guidata cartella condivisa, che è disponibile in Gestione condivisione e archiviazione. Questa procedura consente di eseguire in modo semplificato i passaggi necessari a condividere una cartella o un volume e ad assegnare a tale cartella o volume tutte le proprietà applicabili. Con la procedura è possibile:

  • Specificare la cartella o il volume che si desidera condividere o creare una nuova cartella da condividere.

  • Specificare il protocollo di condivisione di rete utilizzato per accedere alla risorsa condivisa.

  • Modificare le autorizzazioni NTFS locali per la cartella o il volume che si intende condividere.

  • Specificare le autorizzazioni di accesso alla condivisione, i limiti per gli utenti e l'accesso in modalità offline per i file della risorsa condivisa.

  • Pubblicare la risorsa condivisa in uno spazio dei nomi DFS.

  • Se si è installato Servizi per NFS (Network File System), specificare le autorizzazioni di accesso basate su NFS per la risorsa condivisa.

  • Se sul server si è installato Gestione risorse file server, applicare quote di archiviazione alla nuova risorsa condivisa e creare screening dei file per limitare il tipo di file che è possibile archiviarvi.

Utilizzando Gestione condivisione e archiviazione è possibile anche controllare e modificare aspetti importanti delle risorse condivise, nuove ed esistenti. È possibile:

  • Terminare la condivisione di una cartella o di un volume.

  • Modificare le autorizzazioni NTFS locali per una cartella o un volume.

  • Modificare le autorizzazioni di accesso alle condivisioni, la disponibilità in modalità offline e altre proprietà di una risorsa condivisa.

  • Verificare quali utenti hanno correntemente eseguito l'accesso a una cartella o a un file e se necessario disconnettere un utente.

  • Se si è installato Servizi per NFS (Network File System), modificare le autorizzazioni di accesso basate su NFS per una risorsa condivisa.

Per ulteriori informazioni su come utilizzare Gestione condivisione e archiviazione per gestire risorse condivise, vedere Eseguire il provisioning di risorse condivise.

Gestione dell'archiviazione

Con Gestione condivisione e archiviazione è possibile utilizzare spazio di archiviazione sui dischi che sono disponibili sul server oppure su sottosistemi di archiviazione che supportano Servizio dischi virtuali. In Provisioning guidato archiviazione vengono illustrate le procedure necessarie per creare un volume in un disco esistente o in un sottosistema di archiviazione collegato al server. Se il volume verrà creato in un sottosistema di archiviazione, verranno fornite anche le istruzioni necessarie per creare un numero di unità logica (LUN) per ospitare tale volume. È inoltre possibile creare solo il LUN e utilizzare Gestione disco per creare il volume in seguito.

Gestione condivisione e archiviazione consente anche di controllare e gestire i volumi creati, così come gli altri volumi disponibili sul server. Utilizzando Gestione condivisione e archiviazione è possibile:

  • Aumentare le dimensioni di un volume.

  • Formattare un volume.

  • Eliminare un volume.

  • Modificare le proprietà di un volume, ad esempio compressione, sicurezza, disponibilità in modalità offline e indicizzazione.

  • Accedere agli strumenti del disco che consentono di eseguire la verifica degli errori, la deframmentazione e il backup.

Per ulteriori informazioni su come utilizzare Gestione condivisione e archiviazione per gestire risorse di archiviazione, vedere Eseguire il provisioning di un'archiviazione.

Ulteriori riferimenti

  • Gestione condivisione e archiviazione

  • Eseguire il provisioning di risorse condivise

  • Eseguire il provisioning di un'archiviazione

  • Gestire una risorsa condivisa esistente

  • Gestire le autorizzazioni per le cartelle condivise

  • Gestione di un volume esistente

  • Gestire risorse condivise e archiviazione in un computer remoto

  • Risolvere i problemi relativi a Gestione condivisione e archiviazione


Eseguire il provisioning di risorse condivise

È possibile utilizzare Gestione condivisione e risorse per configurare risorse condivise sul server, ad esempio cartelle e volumi. Con Preparazione guidata cartella condivisa è possibile iniziare a condividere un volume o una cartella, configurare le autorizzazioni di accesso e assegnare quote e screening di file.

In questa sezione viene descritto l'argomento seguente:

  • Condividere una risorsa

Ulteriori riferimenti

  • Gestione condivisione e archiviazione


Condividere una risorsa

È possibile condividere in rete il contenuto delle cartelle e dei volumi del server utilizzando Preparazione guidata cartella condivisa, che è disponibile in Gestione condivisione e archiviazione. Con questa procedura è possibile:

  • Specificare la cartella o il volume che si desidera condividere o creare una nuova cartella da condividere.

  • Specificare il protocollo di condivisione di rete che si intende utilizzare per accedere alla risorsa condivisa.

  • Modificare le autorizzazioni NTFS locali per la cartella o il volume che si intende condividere.

  • Specificare le autorizzazioni di accesso alla condivisione, i limiti per gli utenti e l'accesso in modalità offline per i file della risorsa condivisa.

  • Pubblicare la risorsa condivisa in uno spazio dei nomi DFS.

  • Se si è installato Servizi per NFS (Network File System), specificare le autorizzazioni di accesso basate su NFS per la risorsa condivisa.

  • Se si è installato Gestione risorse file server, applicare quote di archiviazione alla nuova risorsa condivisa e creare screening dei file per limitare il tipo di file che è possibile archiviarvi.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per condividere una cartella o un volume

  1. Fare clic su Provisioning condivisione nel riquadro Azioni.

  2. Eseguire i passaggi di Preparazione guidata cartella condivisa per creare e configurare una risorsa condivisa.

Ulteriori considerazioni

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestire una risorsa condivisa esistente

  • Eseguire il provisioning di risorse condivise


Eseguire il provisioning di un'archiviazione

È possibile utilizzare Gestione condivisione e risorse per configurare e gestire tutte le risorse di archiviazione sul server. Con Provisioning guidato archiviazione è possibile creare volumi sui dischi disponibili sul server oppure su sottosistemi di archiviazione che supportano Servizio dischi virtuali. È possibile utilizzare Provisioning guidato archiviazione per creare LUN su sottosistemi di archiviazione.

In questa sezione vengono descritti gli argomenti seguenti:

  • Eseguire il provisioning di un volume

  • Eseguire il provisioning di un LUN

  • Supporto per Multipath I/O (MPIO)

Ulteriori riferimenti

  • Gestione condivisione e archiviazione


Eseguire il provisioning di un volume

È possibile utilizzare Provisioning guidato archiviazione in Gestione condivisione e archiviazione per creare un volume su uno o più dischi disponibili sul server, se lo spazio non allocato è sufficiente. Con questa procedura è possibile:

  • Scegliere il disco su cui creare il volume.

  • Specificare le dimensioni del volume.

  • Assegnare una lettera di unità o un punto di montaggio al volume.

  • Formattare il volume.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per eseguire il provisioning di un volume

  1. Fare clic su Provisioning archiviazione nel riquadro Azioni.

  2. Nella pagina Origine archiviazione selezionare l'opzione In uno o più dischi disponibili nel server e quindi fare clic su Avanti.

  3. Eseguire i passaggi della procedura guidata per creare e configurare il volume.

Ulteriori considerazioni

  • Se in nessuno dei dischi disponibili sul server vi è spazio non allocato, l'opzione In uno o più dischi disponibili nel server in Provisioning guidato archiviazione non sarà disponibile.

  • È possibile creare un volume solo in dischi in modalità online.

  • Per creare un volume in un sottosistema di archiviazione, è innanzitutto necessario creare un LUN su tale sottosistema e quindi renderlo disponibile al server. Per ulteriori informazioni, vedere Eseguire il provisioning di un LUN.

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestione di un volume esistente

  • Eseguire il provisioning di un'archiviazione


Eseguire il provisioning di un LUN

È possibile utilizzare Provisioning guidato archiviazione e Gestione condivisione e archiviazione per creare numeri di unità logica (LUN) in sottosistemi di unità disco Fibre Channel e iSCSI che supportano Servizio dischi virtuali (VDS). È quindi possibile assegnare il LUN al server o ad altri server in rete. Durante la creazione del LUN, è anche possibile creare un volume sul LUN e formattarlo.

Un LUN è un riferimento logico a una parte di un sottosistema di archiviazione. Un LUN può essere costituito da un disco, una sezione di un disco, un intero array di dischi o una sezione di un array di dischi nel sottosistema. L'utilizzo di LUN semplifica la gestione delle risorse di archiviazione perché consente di disporre di identificatori logici tramite i quali è possibile assegnare privilegi di accesso e controllo.

Per eseguire il provisioning di un LUN su un sottosistema di archiviazione su disco, è innanzitutto necessario verificare che tutti i requisiti seguenti siano soddisfatti:

  • Il sottosistema di archiviazione supporta Servizio dischi virtuali (VDS).

  • Il provider hardware VDS per il sottosistema di archiviazione è installato sul server.

  • Nel sottosistema si trova spazio di archiviazione disponibile.

  • Il sottosistema di archiviazione è collegato direttamente al server oppure è accessibile in rete.

  • Se si desidera assegnare il LUN a un server o a un cluster diverso dal server su cui si esegue la procedura guidata, le connessioni del server sono state configurate utilizzando Gestione archivi SAN. Per ulteriori informazioni, vedere la pagina relativa alla gestione delle connessioni server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94431.

    Nota

    Gestione archivi SAN è una funzionalità facoltativa e non viene installata per impostazione predefinita. Se non è già installata, è possibile installarla utilizzando Server Manager (nel nodo Funzionalità fare clic su Aggiungi funzionalità).

  • Se il LUN che si sta creando si trova in un sottosistema iSCSI, gli iniziatori e le destinazioni iSCSI nel SAN sono stati configurati. Per ulteriori informazioni su iSCSI, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93543.

  • Se il server a cui si assegnerà il LUN eseguirà l'accesso al LUN utilizzando più iniziatori iSCSI o porte Fibre Channel, Multipath I/O è stato installato ed è in esecuzione sul server.

    Attenzione

    Se si assegna il LUN a un server su cui non è installato Multipath I/O e che eseguirà l'accesso al LUN utilizzando più porte Fibre Channel o iniziatori iSCSI, è possibile che si verifichi una perdita di dati. Per ulteriori informazioni, vedere Supporto per Multipath I/O (MPIO).

  • Se si desidera assegnare il LUN a un cluster, il cluster è stato configurato completamente tramite l'installazione di Clustering di failover.

    Attenzione

    Per impedire la perdita di dati, verificare che ogni server sia membro di un solo cluster e che Clustering di failover sia stato installato su tutti i server del cluster. Per ulteriori informazioni sull'installazione di Clustering di failover, vedere http://go.microsoft.com/fwlink/?LinkId=86168.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per eseguire il provisioning di archiviazione

  1. Fare clic su Provisioning archiviazione nel riquadro Azioni.

  2. Nella pagina Origine archiviazione selezionare l'opzione In un sottosistema di archiviazione e quindi fare clic su Avanti.

  3. Eseguire i passaggi della procedura guidata per creare e configurare il LUN.

Ulteriori considerazioni

  • Se nessun sottosistema di archiviazione su disco è collegato al server, se i provider hardware VDS non sono installati oppure non vi è spazio di archiviazione disponibile in nessun sottosistema, l'opzione In un sottosistema di archiviazione in Provisioning guidato archiviazione non sarà disponibile.

  • Se si crea un LUN ma non si crea un volume su di esso, è possibile utilizzare Gestione disco per creare il volume in un secondo momento.

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestione di un volume esistente

  • Eseguire il provisioning di un'archiviazione


Supporto per Multipath I/O (MPIO)

Multipath I/O (MPIO) è una funzionalità che offre il supporto per l'utilizzo di più percorsi di dati per un dispositivo di archiviazione. I percorsi multipli aumentano la disponibilità delle risorse di archiviazione offrendo failover di percorso da un server o da un cluster a un sottosistema di archiviazione.

È necessario installare MPIO in un server se questo avrà accesso a un numero di unità logica (LUN, Logical Unit Number) tramite più porte Fibre Channel o più schede degli iniziatori iSCSI. Per installare MPIO, seguire i passaggi descritti nella procedura seguente.

Attenzione

Per evitare la perdita di dati, verificare che il server supporti MPIO prima di attivare più porte Fibre Channel o schede degli iniziatori iSCSI per l'accesso ai LUN. Se il server non supporta MPIO o in caso di dubbi, attivare soltanto una porta Fibre Channel o una scheda dell'iniziatore iSCSI nel server.

Attenzione

Se si desidera attivare l'accesso a un LUN da un cluster, verificare che in ogni server del cluster sia stato installato correttamente Clustering di failover, altrimenti si verificherà una perdita di dati. Per ulteriori informazioni sull'installazione di Clustering di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86168.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare MPIO

  1. Nell'albero della console di Server Manager fare clic sul nodo Funzionalità.

  2. Nel riquadro Funzionalità, in Riepilogo funzionalità, fare clic su Aggiungi funzionalità.

  3. Nell'Aggiunta guidata funzionalità selezionare la casella di controllo Multipath I/O e quindi fare clic su Avanti.

  4. Eseguire i passaggi dell'Aggiunta guidata funzionalità.

Ulteriori riferimenti

  • Per ulteriori informazioni su MPIO, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81020.


Gestire una risorsa condivisa esistente

È possibile utilizzare Gestione condivisione e risorse per gestire tutti i volumi e le cartelle condivise disponibili sul server. Nella scheda Condivisioni è disponibile un elenco di tutte le risorse condivise che è possibile gestire.

È inoltre possibile verificare quali utenti hanno correntemente eseguito l'accesso a una cartella o a un file e se necessario disconnettere un utente.

In questa sezione vengono descritti gli argomenti seguenti:

  • Visualizzare e modificare le proprietà di una cartella condivisa

  • Terminare la condivisione di una risorsa

  • Configurare la disponibilità in modalità offline di una cartella condivisa

  • Gestire sessioni e aprire file

Ulteriori riferimenti

  • Eseguire il provisioning di risorse condivise


Visualizzare e modificare le proprietà di una cartella condivisa

È possibile utilizzare Gestione condivisione e archiviazione per visualizzare e modificare le proprietà di una cartella o un volume condiviso, incluse le autorizzazioni NTFS locali e le autorizzazioni di accesso alla rete per tale risorsa condivisa.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per visualizzare o modificare le proprietà di un volume o di una cartella condivisa

  1. Nella scheda Condivisioni fare clic sul volume o sulla cartella condivisa di SMB o NFS per cui si desidera visualizzare o modificare le proprietà.

  2. Fare clic su Proprietà nel riquadro Azioni.

  3. Modificare le impostazioni come desiderato e quindi fare clic su OK.

Ulteriori considerazioni

  • Per informazioni sulle autorizzazioni di accesso per le risorse condivise, vedere Gestire le autorizzazioni per le cartelle condivise.

  • Non è possibile modificare le autorizzazioni di accesso di cartelle o volumi condivisi per scopi amministrativi, ad esempio C$ e ADMIN$.

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestire una risorsa condivisa esistente

  • Eseguire il provisioning di risorse condivise


Terminare la condivisione di una risorsa

È possibile terminare la condivisione di una cartella o di un volume incluso nell'elenco della scheda Condivisioni in Gestione condivisione e archiviazione. Se l'accesso a una cartella o a un volume è condiviso da protocolli NFS (Network File System) e SMB (Server Message Block), è necessario terminare la condivisione separatamente per ogni protocollo.

Attenzione

Se si termina la condivisione di una cartella o di un volume in uso, i dati potrebbero essere danneggiati. Prima di iniziare l'operazione, verificare che la risorsa condivisa non sia in uso e che non vi siano utenti collegati. Per ulteriori informazioni su come stabilire quali utenti di rete hanno correntemente eseguito l'accesso a cartelle o file sul server, vedere Gestire sessioni e aprire file.

Per poter completare queste procedure, è necessaria almeno l'appartenenza al gruppo Administrators oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per terminare la condivisione di una cartella o di un volume

  1. Nella scheda Condivisioni fare clic sulla cartella o sul volume condiviso SMB o NFS per cui si desidera terminare la condivisione.

  2. Fare clic su Interruzione condivisione nel riquadro Azioni.

  3. Alla richiesta di confermare l'azione, esaminare l'avviso e, se si desidera continuare, fare clic su Sì.

Ulteriori considerazioni

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestire una risorsa condivisa esistente

  • Eseguire il provisioning di risorse condivise


Configurare la disponibilità in modalità offline di una cartella condivisa

Utilizzando Gestione condivisione e archiviazione è possibile configurare se e come i file e i programmi contenuti in una cartella o in un volume condiviso saranno disponibili in modalità offline. Gli utenti possono utilizzare la funzionalità File non in linea sul computer client per accedere alle cartelle condivise archiviate su un server anche quando queste non sono connesse alla rete. Per rendere le cartelle di rete condivise disponibili in modalità offline, una versione di tali cartelle viene archiviata da File non in linea in una parte riservata del disco sul computer dell'utente (una cache locale).

È inoltre possibile utilizzare Gestione condivisione e archiviazione per attivare BranchCache in cartelle condivise. La funzionalità BranchCache in Windows® 7 o Windows Server 2008 R2 consente ai computer di una succursale di memorizzare nella cache i file scaricati dalla cartella condivisa e quindi restituire in modo sicuro i file ad altri computer della succursale.

Importante

Quando si crea una cartella condivisa, la disponibilità offline è consentita per impostazione predefinita ed è quindi possibile che cartelle condivise sicure vengano archiviate offline su computer potenzialmente non sicuri. Per ottimizzare la sicurezza, non consentire agli utenti di archiviare file offline. In tal caso, è opportuno crittografare il volume del sistema operativo mediante Windows® Crittografia unità BitLocker™. Per ulteriori informazioni, vedere la pagina relativa a Crittografia unità BitLocker nel sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=141534.

Configurare le impostazioni per la modalità offline

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per configurare impostazioni per la modalità offline per una cartella condivisa

  1. Nella scheda Condivisioni in Protocollo: SMB, fare clic con il pulsante destro del mouse sulla cartella condivisa per cui si desidera configurare le impostazioni relative alla modalità offline e quindi fare clic su Proprietà.

  2. Nella scheda Condivisione fare clic su Avanzate.

  3. Nella scheda Memorizzazione nella cache configurare la disponibilità offline in modo appropriato e quindi fare clic su OK.

Opzioni della disponibilità offline

Per ogni cartella condivisa, è possibile scegliere una delle seguenti opzioni di disponibilità offline:

  • Solo i file e i programmi specificati dall'utente saranno disponibili in modalità offline. Questa è l'opzione predefinita per la configurazione di una cartella condivisa. Se si utilizza questa opzione, per impostazione predefinita nessun file o programma sarà disponibile in modalità offline e gli utenti potranno stabilire per quali file e programmi desiderano disporre dell'accesso quando non sono connessi alla rete.

    • Abilita BranchCache consente ai computer di una succursale di memorizzare nella cache i file scaricati dalla cartella condivisa e quindi restituire in modo sicuro i file ad altri computer della succursale.

  • Nessun file o programma nella condivisione è disponibile in modalità offline. Questa opzione impedisce a File non in linea nei computer client di creare copie dei file e dei programmi nella cartella condivisa.

  • Tutti i file e i programmi aperti dagli utenti nella condivisione sono automaticamente disponibili in modalità offline. Quando un utente accede alla cartella o al volume condiviso o a un programma in essi contenuto, tale file o programma verrà automaticamente reso disponibile in modalità offline a tale utente. I file e i programmi automaticamente disponibili offline rimangono nella cache di File non in linea e si sincronizzano con la versione nel server finché la cache non è piena o l'utente non cancella i file. I file e i programmi che non vengono aperti non sono disponibili in modalità offline.

    Se si seleziona la casella di controllo Ottimizza prestazioni, i file eseguibili (file con estensione exe o dll) che vengono eseguiti dalla cartella condivisa da un computer client vengono automaticamente memorizzati nella cache di tale computer client. Quando il computer client dovrà eseguire gli stessi file la volta successiva, accederà alla cache locale invece che alla cartella condivisa sul server. Questa opzione è particolarmente utile per i file server che ospitano applicazioni, perché riduce il traffico di rete e migliora la scalabilità dei server.

    Nota

    Perché i file e i programmi vengano memorizzati automaticamente nella cache, la funzionalità File non in linea deve essere attivata sul computer client. L'opzione Ottimizza prestazioni non ha inoltre effetto sui computer client che eseguono Microsoft Windows Vista.

Ulteriori considerazioni

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Guida alla distribuzione di BranchCache

  • Gestire le autorizzazioni per le cartelle condivise

  • Gestire una risorsa condivisa esistente


Gestire sessioni e aprire file

Quando un utente accede a una cartella o a un file archiviato sul server in rete, viene aperta una sessione per tale utente. È possibile monitorare e gestire separatamente ogni cartella o file a cui viene eseguito l'accesso durante una sessione.

Con Gestione condivisione e archiviazione è possibile stabilire quali utenti di rete hanno correntemente eseguito l'accesso a cartelle o file sul server e, se necessario, disconnettere un utente. È anche possibile chiudere cartelle o file specifici a cui ha eseguito l'accesso un utente di rete, senza chiudere altri file a cui lo stesso utente ha eseguito l'accesso.

Attenzione

Se la disconnessione viene eseguita senza preavviso, è possibile che si verifichi una perdita di dati. Se possibile, inviare agli utenti una notifica prima di eseguire la disconnessione o di chiudere una cartella o un file.

Per poter completare queste procedure, è necessaria almeno l'appartenenza al gruppo Administrators oppure a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per visualizzare e chiudere sessioni aperte

  1. Fare clic su Gestisci sessioni nel riquadro Azioni.

  2. Per chiudere una sessione specifica, selezionare la sessione e fare clic su Chiudi selezionati.

    Oppure

    Per chiudere tutte le sessioni, fare clic su Chiudi tutto.
Per visualizzare e chiudere file aperti

  1. Fare clic su Gestisci file aperti nel riquadro Azioni.

  2. Per chiudere un file specifico, selezionare il file e fare clic su Chiudi selezionati.

    -Or-

    Per chiudere tutti i file, fare clic su Chiudi tutto.

Ulteriori considerazioni

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestire una risorsa condivisa esistente

  • Eseguire il provisioning di risorse condivise


Gestire le autorizzazioni per le cartelle condivise

Le autorizzazioni per una risorsa condivisa, ad esempio una cartella o un volume, sono determinate dalle autorizzazioni NTFS locali per tale risorsa e dal protocollo utilizzato per accedere alla risorsa condivisa:

  • Protocollo SMB (Server Message Block)

    Il controllo dell'accesso basato su SMB (per file system basati su Windows) viene implementato tramite la concessione di autorizzazioni a singoli utenti e gruppi.

  • Protocollo NFS (Network File System)

    Il controllo dell'accesso basato su NFS (per file system basati su UNIX) viene implementato tramite la concessione di autorizzazioni a gruppi e computer client specifici, utilizzando nomi di rete.

Le autorizzazioni di accesso finali per una risorsa condivisa vengono determinate valutando sia le autorizzazioni NTFS sia le autorizzazioni del protocollo di condivisione e applicando quindi le autorizzazioni più restrittive. Se si abilita l'enumerazione basata sull'accesso in una cartella condivisa basata su SMB, vengono nascosti i file e le cartelle per cui gli utenti non dispongono di autorizzazioni di lettura.

È possibile configurare autorizzazioni e abilitare l'enumerazione basata sull'accesso per una risorsa condivisa quando si crea un nuovo volume o una nuova cartella condivisa utilizzando Preparazione guidata cartella condivisa oppure selezionando una risorsa condivisa esistente e facendo clic su Proprietà nel riquadro Azioni.

In questo argomento vengono descritti gli argomenti seguenti:

  • Autorizzazioni NTFS

  • Autorizzazioni SMB

  • Autorizzazioni NFS

  • Enumerazione basata sull'accesso

Per informazioni sull'utilizzo di Preparazione guidata cartella condivisa, vedere Condividere una risorsa. Per informazioni sulla configurazione di proprietà per una risorsa condivisa esistente, vedere Visualizzare e modificare le proprietà di una cartella condivisa.

Autorizzazioni NTFS

È possibile configurare le autorizzazioni NTFS locali per una cartella o un volume condiviso utilizzando Gestione condivisione e archiviazione nei modi seguenti:

  • Nuove risorse condivise. In Preparazione guidata cartella condivisa prima di selezionare un protocollo di condivisione di rete è possibile modificare le autorizzazioni NTFS per la cartella o il volume che si intende condividere. Queste autorizzazioni NTFS si applicano sia a livello locale che all'accesso alla risorsa dalla rete Per modificare le autorizzazioni NTFS, nella pagina Autorizzazioni NTFS selezionare Sì, modifica le autorizzazioni NTFS e quindi fare clic su Modifica autorizzazioni.

  • Risorse condivise esistenti. È possibile modificare le autorizzazioni NTFS di una cartella o un volume condiviso presente nella scheda Condivisioni. Per modificare le autorizzazioni NTFS, selezionare la cartella o il volume, fare clic su Proprietà nel riquadro Azioni e quindi fare clic su Autorizzazioni NTFS nella scheda Autorizzazioni.

Nota

Per ulteriori informazioni sulle autorizzazioni NTFS, fare clic su Informazioni su controllo di accesso e autorizzazioni nella pagina delle proprietà che viene visualizzata quando si fa clic su Autorizzazioni NTFS.

Autorizzazioni SMB

Il controllo dell'accesso basato su SMB per una risorsa condivisa viene determinato attraverso due tipi di autorizzazioni: le autorizzazioni NTFS e le autorizzazioni di condivisione. Le autorizzazioni di condivisione vengono spesso utilizzate solo per controllare l'accesso a computer che non utilizzano il file system NTFS.

Le autorizzazioni NTFS e le autorizzazioni di condivisione sono indipendenti, in quanto non si modificano a vicenda, e alla risorsa condivisa viene applicata l'autorizzazione più restrittiva.

Utilizzando Gestione condivisione e archiviazione è possibile specificare autorizzazioni di condivisione per risorse condivise basate su SMB nei modi seguenti:

  • Nuove risorse condivise. Se in Preparazione guidata cartella condivisa si seleziona SMB come protocollo di condivisione, è possibile specificare le seguenti autorizzazioni di accesso basate su SMB nella pagina Autorizzazioni SMB:

    • Tutti gli utenti e i gruppi dispongono solo dell'accesso in lettura. L'autorizzazione risultante sarà Lettura per il gruppo Everyone.

    • Gli amministratori dispongono del controllo completo; tutti gli altri utenti e gruppi dispongono solo dell'accesso in lettura. Il gruppo Administrators avrà autorizzazioni di tipo Controllo completo, mentre il gruppo Everyone disporrà della sola autorizzazione di lettura.

    • Gli amministratori dispongono del controllo completo; tutti gli altri utenti e gruppi dispongono solo dell'accesso in scrittura. Il gruppo Administrators avrà autorizzazioni di tipo Controllo completo, mentre il gruppo Everyone disporrà delle autorizzazioni di lettura e scrittura.

    • Utenti e gruppi dispongono di autorizzazioni di condivisione personalizzate. Per utilizzare questa opzione, è necessario specificare ogni gruppo e ogni utente a cui si desidera assegnare l'accesso di condivisione, oltre alle autorizzazioni di condivisione specifiche (Controllo completo, Cambia, Lettura) da concedere o negare.

  • Risorse condivise esistenti. È possibile modificare le autorizzazioni di condivisione di una cartella o di un volume condiviso presente in Protocollo: SMB nella scheda Condivisioni. Per modificare le autorizzazioni di condivisione, selezionare la cartella o il volume, fare clic su Proprietà nel riquadro Azioni e quindi fare clic su Autorizzazioni condivisione nella scheda Autorizzazioni.

Nota

Per ulteriori informazioni sulle autorizzazioni di accesso di condivisione, fare clic su Informazioni su controllo di accesso e autorizzazioni nella pagina delle proprietà che viene visualizzata quando si fa clic su Autorizzazioni condivisione.

Autorizzazioni NFS

Il controllo dell'accesso basato su NFS per una risorsa condivisa viene determinato sulla base dei gruppi e dei nomi di rete. Per utilizzare le autorizzazioni NFS, è innanzitutto necessario installare il servizio ruolo Servizi per NFS (Network File System) utilizzando Server Manager. Dopo aver installato Servizi per NFS, utilizzare NFSAdmin.exe per creare gruppi di client e aggiungere computer client a tali gruppi prima di configurare le autorizzazioni di condivisione NFS.

Nota

Per informazioni sulle opzioni di autenticazione Kerberos, vedere http://go.microsoft.com/fwlink/?LinkId=143906. Per ulteriori informazioni su Servizi per NFS e NFSAdmin.exe, visualizzare il contenuto della Guida locale relativo a questo servizio ruolo digitando il comando seguente al prompt dei comandi: hh nfs__lh.chm (con due caratteri di sottolineatura).

Utilizzando Gestione condivisione e archiviazione è possibile specificare autorizzazioni di condivisione per risorse condivise basate su NFS nei modi seguenti:

  • Nuove risorse condivise. Se in Preparazione guidata cartella condivisa si seleziona NFS come protocollo di condivisione, la pagina Autorizzazioni NFS è disponibile. È necessario specificare se l'accesso deve essere controllato da un computer client (host) specifico o da un gruppo di client. Per configurare le autorizzazioni NFS in una risorsa condivisa, è possibile eseguire le operazioni seguenti:

    • Aggiungere, modificare o rimuovere autorizzazioni per host e gruppi di client. Per impostazione predefinita, il gruppo TUTTI I COMPUTER dispone di un accesso di sola lettura. È possibile aggiungere qualsiasi host o gruppo di client creato in precedenza (utilizzando NFSAdmin.exe) e concedere a ognuno le autorizzazioni appropriate (nessun accesso, solo lettura, lettura e scrittura).

      È inoltre possibile selezionare l'opzione Consenti accesso alla directory radice per ogni host e gruppo di client. Questa operazione non è tuttavia consigliabile in quanto comporta rischi di sicurezza.

    • Specificare se consentire l'accesso anonimo alla risorsa condivisa. Per impostazione predefinita, per motivi di sicurezza l'accesso anonimo non è attivato. Anche se può essere utile per eseguire la risoluzione dei problemi o eseguire test degli ambienti, in genere non è consigliabile utilizzarlo.

      Per consentire l'accesso anonimo, Preparazione guidata cartella condivisa modifica le autorizzazioni NTFS per la cartella o il volume in modo da consentire l'accesso al gruppo di sicurezza Everyone.

      Quando si attiva l'accesso anonimo viene attivato anche il criterio di sicurezza Applica autorizzazioni account Everyone agli utenti anonimi, che aggiunge il principio Accesso anonimo al gruppo di sicurezza Everyone. Gli utenti anonimi possono quindi passare attraverso cartelle a cui non avrebbero altrimenti accesso quando si spostano in un percorso di oggetto nella cartella condivisa (anche se non possono elencare i contenuti delle cartelle per cui non dispongono dell'accesso).

      Nota

      Quando si disattiva l'accesso anonimo il criterio di sicurezza Applica autorizzazioni account Everyone agli utenti anonimi non viene disattivato.

  • Risorse condivise esistenti. È possibile modificare le autorizzazioni NFS di un volume o di una cartella condivisa presente in Protocollo: NFS nella scheda Condivisioni. Per modificare le autorizzazioni di condivisione, selezionare la cartella o il volume, fare clic su Proprietà nel riquadro Azioni e quindi fare clic su Autorizzazioni NFS nella scheda Autorizzazioni. Per configurare le autorizzazioni, è possibile aggiungere, modificare o rimuovere le autorizzazioni per ogni singolo host o gruppo di client per cui si desidera configurare l'accesso.

Enumerazione basata sull'accesso

L'enumerazione basata sull'accesso consente agli utenti di visualizzare solo i file e le cartelle contenuti in una cartella condivisa basata su SMB per cui dispongono delle autorizzazioni di accesso. Se un utente non dispone delle autorizzazioni di lettura per una cartella, la cartella viene nascosta dalla visualizzazione dell'utente. Ciò è utile, ad esempio, per le cartelle condivise che contengono numerose home directory degli utenti.

Per abilitare l'enumerazione basata sull'accesso in una cartella condivisa

  1. In Gestione condivisione e archiviazione, fare clic con il pulsante destro del mouse sulla cartella condivisa appropriata e quindi scegliere Proprietà.

  2. Nella scheda Condivisione fare clic su Avanzate.

  3. Selezionare la casella di controllo Abilita enumerazione basata sull'accesso e quindi fare clic su OK.

Ulteriori considerazioni

  • La concessione di un'autorizzazione NTFS per il controllo completo su una risorsa condivisa consente all'utente di assumere la proprietà della cartella o del volume, a meno che non sia stato limitato in qualche altro modo. Si consiglia quindi di essere cauti nel concedere il controllo completo.

  • Se si desidera gestire l'accesso alle cartelle e ai volumi utilizzando esclusivamente le autorizzazioni NTFS, impostare le autorizzazioni di condivisione per il gruppo Everyone su Controllo completo. In tal modo la gestione delle autorizzazioni di condivisione sarà più semplice, anche se le autorizzazioni NTFS sono più complesse.

  • Le autorizzazioni NTFS hanno effetto sia sull'accesso locale che su quello remoto e vengono applicate indipendentemente dal protocollo. Le autorizzazioni di condivisione, al contrario, vengono applicate solo alle risorse di rete condivise. Le autorizzazioni di condivisione non limitano l'accesso degli utenti locali o degli utenti di Terminal Server. Le autorizzazioni di condivisione quindi non proteggono la privacy dell'utente su un computer utilizzato da più utenti.

  • Per impostazione predefinita, il gruppo Everyone non include il gruppo Anonymous pertanto le autorizzazioni applicate al gruppo Everyone non hanno effetto sui membri del gruppo Anonymous.

  • Non è possibile modificare le autorizzazioni di accesso di cartelle o volumi condivisi per scopi amministrativi, ad esempio C$ e ADMIN$.

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Visualizzare e modificare le proprietà di una cartella condivisa

  • Condividere una risorsa


Gestione di un volume esistente

È possibile utilizzare Gestione condivisione e risorse per gestire tutti i volumi disponibili sul server. Nella scheda Volumi è disponibile un elenco di tutti i volumi che è possibile gestire.

In questa sezione vengono descritti gli argomenti seguenti:

  • Visualizzare e modificare le proprietà di un volume

  • Formattare un volume

  • Estendere un volume

  • Eliminare un volume

Ulteriori riferimenti

  • Eseguire il provisioning di un'archiviazione


Visualizzare e modificare le proprietà di un volume

È possibile utilizzare Gestione condivisione e archiviazione per visualizzare e modificare le impostazioni del volume e per eseguire attività di manutenzione, ad esempio deframmentazione, verifica degli errori e backup di un volume.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per visualizzare o modificare le proprietà di un volume

  1. Nella scheda Volumi fare clic sul volume per cui si desidera visualizzare o modificare le proprietà.

  2. Fare clic su Proprietà nel riquadro Azioni.

  3. Modificare le impostazioni come desiderato e quindi fare clic su OK.

    Oppure

    Nella scheda Strumenti selezionare l'azione di manutenzione del volume che si desidera eseguire.

Ulteriori considerazioni

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestione di un volume esistente

  • Eseguire il provisioning di un'archiviazione


Formattare un volume

È possibile formattare tutti i volumi inclusi nell'elenco della scheda Volumi in Gestione condivisione e archiviazione, ad eccezione dei seguenti:

  • Un volume di sistema, di avvio o di sola lettura

  • Un volume a cui non è stata assegnata nessuna lettera di unità

Attenzione

La formattazione di un volume elimina tutti i dati in esso contenuti. Se il volume contiene dati, assicurarsi che sia stato eseguito il necessario backup prima della formattazione.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per formattare un volume

  1. Nella scheda Volumi fare clic sul volume che si desidera formattare.

  2. Fare clic su Formatta nel riquadro Azioni.

  3. Specificare le impostazioni appropriate nella finestra di dialogo Formatta e quindi fare clic su Avvia.

  4. Quando viene richiesto di confermare l'operazione, fare clic su OK.

Ulteriori considerazioni

  • Per assegnare una lettera di unità a un volume, utilizzare Gestione disco.

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestione di un volume esistente

  • Eseguire il provisioning di un'archiviazione


Estendere un volume

È possibile utilizzare Gestione condivisione e archiviazione per allocare più spazio di archiviazione per un volume esistente estendendolo.

Per estendere un volume è necessario:

  • Se il volume è stato creato su un disco locale:

    • Sul disco che ospita il volume vi deve essere spazio disponibile.

    • Sul disco non devono esserci volumi situati immediatamente dopo il volume che si desidera estendere (ovvero, il volume da estendere deve essere l'ultimo volume del disco).

  • Se il volume è stato creato su un sottosistema di archiviazione:

    • Se il LUN su cui risiede il volume deve essere esteso, è necessario che nel sottosistema vi sia spazio disponibile.

    • Il volume deve essere l'ultima partizione del LUN oppure il LUN immediatamente successivo al volume da estendere deve includere spazio disponibile non allocato.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per estendere un volume

  1. Nella scheda Volumi fare clic sul volume che si desidera estendere.

  2. Fare clic su Estendi nel riquadro Azioni.

  3. Nella finestra di dialogo Estendi volume specificare le nuove dimensioni e quindi fare clic su OK.

Ulteriori considerazioni

  • Se il volume è stato creato su un sottosistema di archiviazione, estendendo il volume si estende automaticamente il LUN associato ad esso, se necessario.

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestione di un volume esistente

  • Eseguire il provisioning di un'archiviazione


Eliminare un volume

È possibile eliminare qualsiasi volume incluso nell'elenco della scheda Volumi in Gestione condivisione e archiviazione, ad eccezione dei volumi di sistema o di avvio.

Attenzione

Quando si elimina un volume, vengono eliminati anche tutti i dati e le informazioni di configurazione del volume, incluse tutte le cartelle condivise. Se il volume contiene dati, assicurarsi che sia stato eseguito il necessario backup prima dell'eliminazione.

Per poter completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators o a un gruppo equivalente. Per ulteriori informazioni sull'utilizzo degli account appropriati e sull'appartenenza a gruppi, vedere http://go.microsoft.com/fwlink/?LinkId=83477.

Per eliminare un volume

  1. Nella scheda Volumi fare clic sul volume che si desidera eliminare.

  2. Fare clic su Elimina nel riquadro Azioni.

  3. Nella finestra di dialogo Elimina volume verificare l'avviso e, se si desidera proseguire, fare clic su Sì e quindi su OK.

Ulteriori considerazioni

  • Se il volume che si intede eliminare è l'ultimo volume di un LUN, lo spazio del LUN verrà liberato e reso disponibile per la creazione di nuovi LUN.

  • Se il volume eliminato non è l'ultimo volume di un LUN, è possibile creare Gestione disco per creare un nuovo volume nello spazio in precedenza allocato al volume eliminato.

  • Per aprire Gestione condivisione e archiviazione, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione condivisione e archiviazione.

Ulteriori riferimenti

  • Gestione di un volume esistente

  • Eseguire il provisioning di un'archiviazione


Gestire risorse condivise e archiviazione in un computer remoto

Per gestire le risorse condivise e l'archiviazione in un computer remoto è possibile connettersi al computer da Gestione condivisione e archiviazione.

Nota

Utilizzando Gestione condivisione e archiviazione è possibile gestire le risorse tramite il computer locale o il computer remoto, ma non tramite entrambi contemporaneamente.

Per connettersi a un computer remoto da Gestione condivisione e archiviazione

  1. In Strumenti di amministrazione fare clic su Gestione condivisione e archiviazione.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Gestione condivisione e archiviazione e quindi scegliere Connetti a un altro computer.

  3. Nella finestra di dialogo Connetti a un altro computer fare clic su Altro computer. Digitare il nome del server al quale si desidera eseguire la connessione o fare clic su Sfoglia per cercare un computer remoto.

  4. Fare clic su OK.
Importante

L'opzione Connetti a un altro computer è disponibile solo quando si apre Gestione condivisione e archiviazione da Strumenti di amministrazione. Quando si esegue l'accesso a Gestione condivisione e archiviazione da Server Manager, questa opzione non è disponibile.

Ulteriori considerazioni

  • È necessario aver eseguito l'accesso al computer locale con un account di dominio che è membro del gruppo Administrators sul computer remoto.

  • Il computer remoto deve eseguire Windows Server 2008 o versione successiva.

  • L'eccezione Gestione volumi remota deve essere attivata sia sul computer locale che sul computer remoto. Attivare questa eccezione utilizzando Windows Firewall nel Pannello di controllo.

  • Non è possibile creare, visualizzare o modificare risorse condivise basate su NFS su un computer remoto.

  • Se si esegue una connessione remota a un'istanza del file server a disponibilità elevata, sarà possibile gestire solo l'archiviazione in cluster e le risorse condivise disponibili a tale istanza del file server a disponibilità elevata.

  • Se si esegue una connessione remota a un server in un cluster di failover (un nodo), sarà possibile gestire le risorse condivise e l'archiviazione che sono disponibili localmente a tale server, oltre all'archiviazione in cluster e alle risorse condivise che sono correntemente di proprietà di tale server nel cluster.

Ulteriori riferimenti

  • Gestione condivisione e archiviazione


Risolvere i problemi relativi a Gestione condivisione e archiviazione

In questo argomento vengono elencati alcuni problemi comuni che possono verificarsi quando si utilizza Gestione condivisione e archiviazione. Per ulteriori informazioni sulla risoluzione dei problemi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94430.

Problema riscontrato

  • L'opzione "In uno o più dischi disponibili nel server" in Provisioning guidato archiviazione non è disponibile.

  • L'opzione "In un sottosistema di archiviazione" in Provisioning guidato archiviazione non è disponibile.

  • Non è possibile modificare le autorizzazioni di accesso per una cartella condivisa.

  • Non è possibile formattare un volume, anche se non si tratta di un volume di sistema o di avvio.

  • Non vi sono server elencati nella pagina Accesso server di Provisioning guidato archiviazione.

  • Non è possibile connettersi a un computer remoto utilizzando Gestione condivisione e archiviazione.

  • Non è possibile estendere un volume, anche se sul disco vi è spazio non allocato disponibile.

  • Quando si crea un nuovo volume condiviso utilizzando Preparazione guidata cartella condivisa, non è possibile selezionare il protocollo NFS nella pagina Protocolli condivisione.
L'opzione "In uno o più dischi disponibili nel server" in Provisioning guidato archiviazione non è disponibile.
  • Causa: non vi è spazio non allocato in nessuno dei dischi disponibili sul server.

  • Soluzione: utilizzare Gestione disco per rendere disponibile spazio su uno dei dischi del server oppure installare un nuovo disco.

L'opzione "In un sottosistema di archiviazione" in Provisioning guidato archiviazione non è disponibile.
  • Causa: di seguito sono riportate le possibili cause.

    • Non vi sono sottosistemi di archiviazione su disco che supportano Servizio dischi virtuali collegati al server oppure i provider hardware VDS dei sottosistemi di archiviazione non sono stati disinstallati.

    • Non vi è spazio di archiviazione disponibile su nessun sottosistema collegato al server.

  • Soluzione: contattare il produttore dei sottosistemi di archiviazione su disco e verificare che il sistema in uso supporti Servizio dischi virtuali. In caso affermativo, installare il provider hardware VDS per il sottosistema. Verificare infine che vi sia spazio di archiviazione disponibile su almeno uno dei sottosistemi collegati al server.

Non è possibile modificare le autorizzazioni di accesso per una cartella condivisa.
  • Causa: si sta cercando di modificare le autorizzazioni di accesso di una cartella o di un volume condiviso per scopi amministrativi, ad esempio C$ e ADMIN$.

  • Soluzione: utilizzare Preparazione guidata cartella condivisa per creare una nuova risorsa condivisa per la stessa cartella o lo stesso volume e assegnare le relative autorizzazioni.

Non è possibile formattare un volume, anche se non si tratta di un volume di sistema o di avvio.
  • Causa: al volume non è stata assegnata nessuna lettera di unità.

  • Soluzione: per assegnare una lettera di unità a un volume, utilizzare Gestione disco.

Non vi sono server elencati nella pagina Accesso server di Provisioning guidato archiviazione.
  • Causa: le connessioni del server necessarie non sono state configurate utilizzando Gestione archivi SAN.

  • Soluzione: utilizzare Gestione archivi SAN per configurare le connessioni del server. Per ulteriori informazioni, vedere la pagina relativa alla gestione delle connessioni server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94431.

    Nota

    Gestione archivi SAN è una funzionalità facoltativa e non viene installata per impostazione predefinita. Se non è già installata, è possibile installarla utilizzando Server Manager (nel nodo Funzionalità fare clic su Aggiungi funzionalità).

Non è possibile connettersi a un computer remoto utilizzando Gestione condivisione e archiviazione.
  • Causa: l'eccezione Gestione volumi remota non è attivata sul computer locale o sul computer remoto.

  • Soluzione: utilizzare Windows Firewall nel Pannello di controllo per attivare l'eccezione Gestione volumi remota in entrambi i computer.

Non è possibile estendere un volume, anche se sul disco vi è spazio non allocato disponibile.
  • Causa: lo spazio su disco non allocato non si trova immediatamente dopo il volume che si desidera estendere.

  • Soluzione: utilizzare Gestione disco per estendere il volume su un altro disco.

Quando si crea un nuovo volume condiviso utilizzando Preparazione guidata cartella condivisa, non è possibile selezionare il protocollo NFS nella pagina Protocolli condivisione.
  • Causa: Servizi per NFS (Network File System) non è stato installato.

  • Soluzione: installare il servizio ruolo Servizi per NFS (Network File System) utilizzando Server Manager.

Ulteriori riferimenti

  • Gestione condivisione e archiviazione