Servizi

È possibile utilizzare lo snap-in Servizi di Microsoft Management Console (MMC) per gestire servizi in esecuzione in computer locali o remoti, ad esempio per arrestare o avviare un servizio. È inoltre possibile gestire servizi utilizzando il comando sc config.

Che cos'è un servizio?

Un servizio è un tipo di applicazione che viene eseguito in background senza un'interfaccia utente ed è simile a un processo daemon di UNIX. I servizi consentono di eseguire funzionalità di base del sistema operativo, ad esempio funzionalità di server Web e di file server, registrazione eventi, stampa, crittografia e segnalazione errori.

Quali operazioni è possibile eseguire utilizzando lo snap-in Servizi?

Relativamente ai servizi in esecuzione in computer locali o remoti (questi ultimi devono eseguire Microsoft Windows NT 4.0, Windows 2000, Windows XP, Windows Server 2003, Microsoft Windows Vista, Windows Server 2008, Windows® 7 o Windows Server® 2008 R2) è possibile eseguire le operazioni seguenti:

  • Avvio, arresto, sospensione, ripresa o disattivazione di un servizio.

  • Impostazione di operazioni di ripristino da eseguire se un servizio non funziona, ad esempio riavvio automatico del servizio o riavvio del computer.

  • Esecuzione di servizi nel contesto di sicurezza di un account utente diverso dall'utente connesso o dall'account computer predefinito.

  • Attivazione o disattivazione di servizi per un profilo hardware specifico.

  • Esportazione e salvataggio di informazioni relative al servizio in un file con estensione csv o txt.

  • Visualizzazione dello stato e della descrizione di ogni servizio.

  • Visualizzare le dipendenze del servizio.
Per aprire lo snap-in Servizi

  • Fare clic sul pulsante Start, nella casella Inizia ricerca digitare services.msc e quindi premere INVIO.

    Nota

    Per utilizzare lo snap-in Servizi, è necessaria l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente.

Ulteriori riferimenti

  • Impostare operazioni di ripristino da eseguire quando un servizio non funziona

  • Configurare le modalità di avvio di un servizio

  • Utilizzare i profili hardware per risolvere i problemi relativi ai servizi

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi a eventi ed errori relativi ai servizi, vedere http://go.microsoft.com/fwlink/?linkid=68107.

  • Per informazioni sullo sviluppo e sull'utilizzo di servizi, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=88931.


Impostare operazioni di ripristino da eseguire quando un servizio non funziona

Se un servizio non funziona, è possibile utilizzare lo snap-in Servizi per specificare l'operazione da eseguire, ad esempio l'esecuzione di un programma o uno script, dopo il primo o il secondo errore del servizio o dopo gli errori successivi.

Per completare questa procedura, è necessario appartenere almeno al gruppo Account Operators, Domain Admins, Enterprise Admins oppure a un gruppo equivalente. Analizzare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Per impostare operazioni di ripristino quando un servizio non funziona

  1. Fare clic sul pulsante Start, nella casella Inizia Ricerca digitare services.msc e quindi premere INVIO.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul servizio per cui si desidera impostare le operazioni di ripristino e quindi scegliere Proprietà.

  3. Nella scheda Ripristino fare clic sull'operazione desiderata in Primo tentativo, Secondo tentativo e Tentativi successivi e quindi fare clic su OK.

    • Se si fa clic su Esegui un programma, in Esegui digitare il percorso completo relativo al computer specifico. I nomi UNC (Universal Naming Convention) non sono supportati. Digitare ad esempio C:\scripts\handlefailure.cmd anziché \\computername\c$\scripts\handlefailure.cmd. Per i programmi o gli script specificati non deve essere necessario l'input dell'utente.

    • Se si fa clic su Riavvia il computer, fare clic su Opzioni riavvio computer per specificare il tempo di attesa prima del riavvio del computer. È inoltre possibile creare un messaggio da inviare automaticamente agli utenti remoti prima del riavvio del computer.

    • Selezionare Consenti azioni per interruzioni con errori per attivare le azioni di ripristino che il servizio ha interrotto con un errore.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessario essere membri del gruppo Account Operators, Domain Admins, Enterprise Admins oppure disporre della delega per l'autorità appropriata. Per garantire un livello di sicurezza ottimale, è consigliabile utilizzare la funzione Run as.

  • Le operazioni di ripristino sono disponibili solo in computer che eseguono Windows 2000 o versione successiva.

Ulteriori riferimenti

  • Servizi


Configurare le modalità di avvio di un servizio

I servizi vengono eseguiti spesso con impostazioni predefinite, ad esempio la disattivazione automatica all'avvio. Per modificare le impostazioni predefinite di un servizio, è possibile utilizzare lo snap-in Servizi, che risulta particolarmente utile per la risoluzione di problemi relativi a errori di un servizio o in situazioni in cui sia necessario modificare l'account di sicurezza utilizzato per l'esecuzione del servizio.

Per completare questa procedura, è necessario appartenere almeno al gruppo Account Operators, Domain Admins, Enterprise Admins oppure a un gruppo equivalente. Analizzare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Configurare le modalità di avvio di un servizio

  • Utilizzo dell'interfaccia di Windows

  • Utilizzo della riga di comando
Per configurare le modalità di avvio di un servizio mediante l'interfaccia di Windows

  1. Fare clic sul pulsante Start, nella casella Inizia Ricerca digitare services.msc e quindi premere INVIO.

  2. Se si desidera, esportare e salvare un elenco delle impostazioni esistenti. A tale scopo, fare clic con il pulsante destro del mouse su Servizi, scegliere Esporta elenco e quindi salvare l'elenco delle impostazioni.

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul servizio da configurare e quindi scegliere Proprietà.

  4. Nella scheda Generale fare clic su Automatico, Manuale Disattivato o Automatico (avvio ritardato) in Tipo di avvio.

  5. Per specificare l'account utente che il servizio può utilizzare per eseguire l'accesso, fare clic sulla scheda Connessione e quindi eseguire una delle operazioni seguenti:

    • Per specificare l'utilizzo dell'account di sistema locale, fare clic su Account di sistema locale.

    • Per specificare l'utilizzo dell'account Servizio locale, fare clic su Account e quindi digitare NT AUTHORITY\LocalService.

    • Per specificare l'utilizzo dell'account Servizio di rete, fare clic su Account e quindi digitare NT AUTHORITY\NetworkService.

    • Per specificare un account diverso, fare clic su Account, su Sfoglia e quindi specificare un account utente nella finestra di dialogo Seleziona utente. Al termine, fare clic su OK.

  6. Digitare la password per l'account utente in Password e in Conferma password e quindi fare clic su OK. Se si seleziona l'account Servizio locale o Servizio di rete, non digitare una password.

Per configurare le modalità di avvio di un servizio mediante la riga di comando

  • È inoltre possibile gestire servizi utilizzando il comando sc config. Per ulteriori informazioni sulle opzioni disponibili, aprire una finestra del prompt dei comandi e digitare sc config /?. Per esempi e descrizioni dettagliate delle opzioni della riga di comando, vedere i riferimenti relativi alla riga di comando nel sito Web all'indirizzo http://go.microsoft.com/fwlink/?linkid=53528.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessario essere membri del gruppo Account Operators, Domain Admins o Enterprise Admins oppure disporre della delega per l'autorità appropriata. Per garantire un livello di sicurezza ottimale, è consigliabile utilizzare la funzione Run as.

  • La modifica delle impostazioni predefinite di un servizio potrebbe impedire il corretto funzionamento di servizi chiave. È consigliabile pertanto prestare particolare attenzione quando si modificano le impostazioni Tipo di avvio e Connessione di servizi configurati per l'avvio automatico.

  • Nella maggior parte dei casi è consigliabile lasciare invariata l'impostazione Consenti al servizio di interagire col desktop. Se si consente al servizio di interagire con il desktop, tutte le informazioni visualizzate dal servizio sul desktop verranno visualizzate anche su un desktop interattivo dell'utente. In una situazione di questo tipo, un utente malintenzionato potrebbe assumere il controllo del servizio o attaccarlo direttamente dal desktop interattivo.

  • L'account Servizio locale e Servizio di rete sono configurati con una password vuota. Le informazioni relative alla password indicate, pertanto, vengono ignorate.

  • È consigliabile che la casella di controllo Nessuna scadenza password nella finestra di dialogo Proprietà relativa ad account utente utilizzati per accedere a un servizio sia selezionata e che le password relative a tali account siano complesse.

  • Se il criterio di blocco account è attivato e l'account risulta bloccato, il servizio non verrà avviato.

  • Se si attiva o disattiva un servizio e si verifica un problema durante l'avvio del computer, è possibile eseguire l'avvio in modalità provvisoria. In tale modalità i servizi di base necessari per l'avvio del sistema operativo vengono avviati in base a uno schema predefinito, indipendentemente dalle modifiche apportate alle impostazioni dei servizi stessi. Dopo avere avviato il computer in modalità provvisoria, è possibile modificare la configurazione dei servizi o ripristinare quella predefinita.

  • Se si specifica un account che non dispone dell'autorizzazione per accedere come servizio, lo snap-in Servizi concede automaticamente le autorizzazioni appropriate all'account specifico sul computer attualmente gestito.

Ulteriori riferimenti

Per informazioni sulla configurazione del servizio Ora di Windows, vedere W32tm all'indirizzo http://go.microsoft.com/fwlink/?linkid=69453.

Per ulteriori informazioni sugli account utente utilizzati da un servizio per eseguire l'accesso, vedere le impostazioni predefinite dei servizi all'indirizzo http://go.microsoft.com/fwlink/?linkid=68107.


Utilizzare i profili hardware per risolvere i problemi relativi ai servizi

Per risolvere i problemi relativi ai nuovi servizi installati, è possibile utilizzare lo snap-in Servizi in combinazione con profili hardware predefiniti. Se ad esempio si associa un servizio a due profili hardware diversi, uno in cui il servizio è attivato e l'altro in cui il servizio è disattivato, è possibile risolvere in modo più semplice i problemi hardware che si possono verificare in relazione a un nuovo servizio installato, ad esempio il caricamento non corretto di un driver.

Per completare questa procedura, è necessario appartenere almeno al gruppo Account Operators, Domain Admins, Enterprise Admins oppure a un gruppo equivalente. Analizzare i dettagli nella sezione "Ulteriori considerazioni" in questo argomento.

Per attivare o disattivare un servizio per un profilo hardware

  1. Fare clic sul pulsante Start, nella casella Inizia Ricerca digitare services.msc e quindi premere INVIO.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul servizio da attivare o disattivare e quindi scegliere Proprietà.

  3. Nella scheda Connessione fare clic sul profilo hardware da configurare.

  4. Fare clic su Attiva o Disattiva e quindi su OK.

Ulteriori considerazioni

  • Per eseguire questa procedura, è necessario essere membri del gruppo Account Operators, Domain Admins o Enterprise Admins oppure disporre della delega per l'autorità appropriata. Per garantire un livello di sicurezza ottimale, è consigliabile utilizzare la funzione Run as.

  • Se questa procedura viene utilizzata per disattivare servizi, è necessario prestare particolare attenzione. Se si disattiva un servizio per un profilo hardware specifico, infatti, le impostazioni definite in Profilo hardware hanno la priorità rispetto all'impostazione Tipo di avvio relativa al servizio stesso.

  • Nella maggior parte dei casi è consigliabile lasciare invariata l'impostazione Consenti al servizio di interagire col desktop. Se si consente al servizio di interagire con il desktop, tutte le informazioni visualizzate dal servizio sul desktop verranno visualizzate anche su un desktop interattivo dell'utente. In una situazione di questo tipo, un utente malintenzionato potrebbe assumere il controllo del servizio o attaccarlo direttamente dal desktop interattivo.

  • Se all'apertura della finestra di dialogo Proprietà relativa a un servizio viene visualizzato un messaggio di errore di Connection Manager, verificare che il servizio Registro di sistema remoto sia in esecuzione sul computer specificato. Se il servizio Registro di sistema remoto non è in esecuzione o se sul computer specificato è in esecuzione Windows NT 4.0, non è possibile visualizzare o modificare le impostazioni dei profili hardware, ma è possibile eseguire qualsiasi altra operazione.

Ulteriori riferimenti

  • Servizi