Gestione Gateway Desktop remoto

Gateway Desktop remoto

Gateway Desktop remoto è un servizio ruolo che consente agli utenti remoti autorizzati di connettersi alle risorse di una rete privata o aziendale interna da qualunque dispositivo connesso a Internet in grado di eseguire il client di Connessione desktop remoto. Le risorse di rete possono essere server Host sessione Desktop remoto, server Host sessione Desktop remoto che eseguono Programmi RemoteApp o computer in cui è attivato Desktop remoto.

Gateway Desktop remoto utilizza Remote Desktop Protocol (RDP) su HTTPS per stabilire una connessione sicura e crittografata tra utenti remoti su Internet e le risorse di rete interne in cui vengono eseguite le applicazioni per la produttività.

Sono inclusi gli argomenti seguenti:

  • Panoramica di Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Prerequisiti per l'installazione di Gateway Desktop remoto

  • Configurare il server Gateway Desktop remoto

  • Configurare il client di Servizi Desktop remoto per Gateway Desktop remoto

  • Utilizzare Criteri di gruppo per gestire le connessioni client tramite Gateway Desktop remoto

  • Monitorare un server Gateway Desktop remoto per verificare lo stato della connessione e segnalare gli errori

  • Attivare o disattivare la condivisione di credenziali per le connessioni tramite Gateway Desktop remoto


Panoramica di Gateway Desktop remoto

Che cos'è Gateway Desktop remoto?

Gateway Desktop remoto è un servizio ruolo che consente agli utenti remoti autorizzati di connettersi alle risorse di una rete privata o aziendale interna da qualunque dispositivo connesso a Internet in grado di eseguire il client di Connessione desktop remoto. Le risorse di rete possono essere server Host sessione Desktop remoto, server Host sessione Desktop remoto che eseguono Programmi RemoteApp o computer in cui è attivato Desktop remoto.

Gateway Desktop remoto utilizza Remote Desktop Protocol (RDP) su HTTPS per stabilire una connessione sicura e crittografata tra utenti remoti su Internet e le risorse di rete interne in cui vengono eseguite le applicazioni per la produttività.

Perché utilizzare Gateway Desktop remoto?

Gateway Desktop remoto offre numerosi vantaggi, tra cui i seguenti:

  • Gateway Desktop remoto consente agli utenti remoti di connettersi alle risorse di rete interne tramite Internet, utilizzando una connessione crittografata, senza dovere configurare connessioni a reti private virtuali (VPN).

  • Gateway Desktop remoto offre un modello di configurazione della sicurezza completo per il controllo dell'accesso a risorse di rete interne specifiche. Gateway Desktop remoto fornisce inoltre una connessione RDP point-to-point che impedisce l'accesso indiscriminato a tutte le risorse di rete interne da parte degli utenti remoti.

  • Gateway Desktop remoto consente alla maggior parte degli utenti remoti di effettuare connessioni a risorse di rete interne che sono ospitate in reti private protette da firewall e NAT (Network Address Translator). Con Gateway Desktop remoto non è necessario eseguire ulteriori operazioni di configurazione per il server o i client di Gateway Desktop remoto per questo scenario.

    Nelle versioni precedenti di Windows Server, le misure di sicurezza impediscono agli utenti remoti di connettersi alle risorse di rete interne attraverso firewall e NAT perché la porta 3389, utilizzata per le connessioni RDP, è in genere bloccata per garantire la sicurezza della rete. Gateway Desktop remoto trasmette invece il traffico RDP alla porta 443, utilizzando un tunnel TLS/SSL (Transport Layer Security/Secure Sockets Layer) HTTP. Poiché la maggior parte delle aziende apre la porta 443 per consentire la connettività Internet, Gateway Desktop remoto sfrutta questa struttura della rete per offrire connettività di accesso remoto attraverso più firewall.

  • Gestione Gateway Desktop remoto consente di configurare i criteri di autorizzazione per definire le condizioni che gli utenti remoti devono rispettare per connettersi alle risorse di rete interne. È possibile, ad esempio, specificare le informazioni seguenti:

    • Utenti autorizzati a connettersi alle risorse di rete interne, ovvero i gruppi di utenti che possono connettersi.

    • Risorse di rete, o gruppi di computer, a cui possono connettersi gli utenti.

    • Se i computer client debbano o meno essere membri di gruppi di sicurezza di Active Directory.

    • Se il reindirizzamento dei dispositivi è consentito.

    • Se i client debbano utilizzare l'autenticazione tramite smart card o password o se possano utilizzare entrambi i metodi.

  • È possibile configurare i server Gateway Desktop remoto e i client di Servizi Desktop remoto per l'utilizzo di Protezione accesso alla rete per aumentare ulteriormente la sicurezza. Protezione accesso alla rete è una tecnologia di creazione, applicazione, monitoraggio e aggiornamento dei criteri di integrità inclusa in Windows Server® 2008 R2, Windows Server® 2008, Windows® 7, Windows Vista® e Windows® XP Service Pack 3. Con Protezione accesso alla rete gli amministratori di sistema possono imporre requisiti di integrità che possono includere requisiti software, requisiti relativi agli aggiornamenti per la sicurezza, configurazioni obbligatorie per il computer e altre impostazioni.

    Nota

    I computer che eseguono Windows Server 2008 R2 o Windows Server 2008 non possono essere utilizzati come client di Protezione accesso alla rete quando Gateway Desktop remoto impone Protezione accesso alla rete. Solo i computer che eseguono Windows 7, Microsoft Windows Vista o Windows XP SP3 possono essere utilizzati come client di Protezione accesso alla rete quando Gateway Desktop remoto impone Protezione accesso alla rete.

    Per informazioni sulla configurazione di Gateway Desktop remoto per l'utilizzo di Protezione accesso alla rete per imporre criteri di integrità per client di Servizi Desktop remoto che si connettono a server Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto in TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?linkid=140433).

  • È possibile utilizzare il server Gateway Desktop remoto con Microsoft Internet Security and Acceleration (ISA) Server per migliorare la sicurezza. In questo scenario è possibile ospitare server Gateway Desktop remoto in una rete privata anziché una rete perimetrale e ospitare ISA Server nella rete perimetrale. La connessione SSL (Secure Sockets Layer) tra il client di Servizi Desktop remoto e ISA Server può essere terminata da ISA Server, che opera con Internet.

    Per informazioni sulla configurazione di ISA Server come dispositivo di terminazione SSL per scenari con server Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto in TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?linkid=140433).

  • Gestione Gateway Desktop remoto offre strumenti che consentono il monitoraggio degli eventi e dello stato del server Gateway Desktop remoto. Utilizzando Gestione Gateway Desktop remoto, è possibile specificare eventi, ad esempio tentativi di connessione non riusciti al server Gateway Desktop remoto, che si desidera monitorare per motivi di controllo.

Ulteriori riferimenti

  • Gestione Gateway Desktop remoto


Elenco di controllo: configurare Gateway Desktop remoto

In questo elenco di controllo sono indicate le attività che è necessario completare per una corretta configurazione di Gateway Desktop remoto per lo scenario di base di Gateway Desktop remoto. In tale scenario è possibile configurare un server Gateway Desktop remoto in modo che un utente remoto abbia accesso tramite Internet a una risorsa della rete aziendale o privata interna utilizzando il server Gateway Desktop remoto. La risorsa di rete interna in tale scenario potrebbe essere un server Host sessione Desktop remoto, un server Host sessione Desktop remoto che esegue Programmi RemoteApp o un computer con Desktop remoto attivato.

Attività | Riferimento
Installare il servizio ruolo Gateway Desktop remoto. | Installare il servizio ruolo Gateway Desktop remoto
Ottenere un certificato per il server Gateway Desktop remoto. | Ottenere un certificato per il server Gateway Desktop remoto
Creare Criteri di autorizzazione connessioni Desktop remoto. | Creare criteri di autorizzazione connessioni Desktop remoto
Creare Criteri di autorizzazione risorse Desktop remoto. | Creare criteri di autorizzazione risorse Desktop remoto
Configurare il client di Servizi Desktop remoto per Gateway Desktop remoto. | Configurare il client di Servizi Desktop remoto per Gateway Desktop remoto

Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.


Prerequisiti per l'installazione di Gateway Desktop remoto

Per un corretto funzionamento di Gateway Desktop remoto, è necessario che siano soddisfatti i requisiti seguenti:

  • Avere a disposizione un server con Windows Server 2008 R2 installato.

  • Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

  • Ottenere un certificato SSL (Secure Sockets Layer) per il server Gateway Desktop remoto, se non è già disponibile. Per impostazione predefinita, nel server Gateway Desktop remoto il servizio Internet Information Services (IIS) utilizza Transport Layer Security (TLS) 1.0 per crittografare le comunicazioni tramite Internet tra i client e i server Gateway Desktop remoto. Per un corretto funzionamento del protocollo TLS, è necessario che nel server Gateway Desktop remoto sia installato un certificato SSL.

    Nota

    Non è necessario che l'organizzazione disponga di un'infrastruttura CA (autorità di certificazione) se è possibile ottenere con un altro metodo un certificato ritenuto attendibile all'esterno e che soddisfi i requisiti di Gateway Desktop remoto. Se la propria società non dispone né di un'autorità di certificazione dell'organizzazione (enterprise) o autonoma (standalone), né di un certificato compatibile rilasciato da una CA pubblica attendibile, è possibile creare e importare un certificato autofirmato per il proprio server Gateway Desktop remoto, da utilizzare solo per le valutazioni tecniche e i test. Per ulteriori informazioni, vedere Creare un certificato autofirmato per il server Gateway Desktop remoto.

    Per informazioni sui requisiti dei certificati per Gateway Desktop remoto e su come ottenerne e installarne uno, vedere Ottenere un certificato per il server Gateway Desktop remoto.

  • Se si configura un criterio di autorizzazione di Gateway Desktop remoto che richiede che gli utenti dei computer client appartengano a un gruppo di sicurezza Active Directory per potersi connettere ai server Gateway Desktop remoto, anche i server Gateway Desktop remoto dovranno appartenere un dominio di Active Directory.

Dipendenze di ruoli, servizi ruolo e funzionalità

Per un corretto funzionamento di Gateway Desktop remoto, è necessario che vengano installati ed eseguiti molteplici funzionalità e servizi ruolo. Quando si utilizza Server Manager per installare il servizio ruolo Gateway Desktop remoto, verranno installati e avviati automaticamente (se non sono già presenti) i ruoli, i servizi ruolo e le funzionalità seguenti:

  • Proxy RPC su HTTP

  • Server Web (Internet Information Services)

    Per consentire il corretto funzionamento di Proxy RPC su HTTP è necessario installare ed eseguire IIS.

  • Servizi di accesso e criteri di rete

    È inoltre possibile configurare Gateway Desktop remoto in modo da utilizzare i Criteri di autorizzazione connessioni Desktop remoto archiviati in un altro server che esegue il servizio Server dei criteri di rete. In questo modo si utilizza il server che esegue il Server dei criteri di rete, in precedenza denominato server RADIUS (Remote Authentication Dial-In User Service), per centralizzare l'archiviazione, la gestione e la convalida dei Criteri di autorizzazione connessioni Desktop remoto. Se è già stato distribuito un server che esegue il Server dei criteri di rete per gli scenari di accesso remoto, ad esempio per le connessioni VPN e remote, l'utilizzo del server che esegue il Server dei criteri di rete esistente per gli scenari di Gateway Desktop remoto potrebbe migliorare la distribuzione.

Ulteriori riferimenti

  • Gestione Gateway Desktop remoto


Configurare il server Gateway Desktop remoto

In questa sezione vengono illustrate le procedure per installare Gateway Desktop remoto e configurare i criteri di autorizzazione con cui è possibile definire le condizioni che gli utenti devono soddisfare per connettersi alle risorse di rete interne (computer) tramite Gateway Desktop remoto. Vengono inoltre descritte le procedure per specificare gli utenti che hanno accesso ai computer della rete interna e i computer ai quali possono accedere. Sono inclusi gli argomenti seguenti:

  • Installare il servizio ruolo Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto

  • Configurare un certificato per il server Gateway Desktop remoto

  • Specificare un server Gateway Desktop remoto da gestire

  • Creare una server farm Gateway Desktop remoto

  • Rimuovere i membri di una server farm Gateway Desktop remoto

  • Disattivare la gestione per un server Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Gestire i criteri di autorizzazione risorse Desktop remoto

  • Attivare il bridging SSL nel server Gateway Desktop remoto

  • Attivare la verifica dei criteri di integrità Protezione accesso alla rete nel server Gateway Desktop remoto

  • Limitare il numero massimo di connessioni simultanee consentite tramite un server Gateway Desktop remoto

  • Importare o esportare le impostazioni per un server Gateway Desktop remoto

  • Configurare la messaggistica per un server Gateway Desktop remoto


Installare il servizio ruolo Gateway Desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare il servizio ruolo Gateway Desktop remoto

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Se il ruolo Servizi Desktop remoto non è già installato:

    1. In Server Manager, in Riepilogo ruoli fare clic su Aggiungi ruoli.

    2. Nell'Aggiunta guidata ruoli fare clic su Avanti se viene visualizzata la pagina Prima di iniziare. Questa pagina non verrà visualizzata se sono già stati installati altri ruoli ed è stata selezionata la casella di controllo Ignora questa pagina per impostazione predefinita.

    3. Nella pagina Selezione ruoli server selezionare Servizi Desktop remoto in Ruoli e quindi fare clic su Avanti.

    4. Nella pagina Servizi Desktop remoto fare clic su Avanti.

    5. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Gateway Desktop remoto.

    6. Se viene chiesto di specificare se si desidera installare i servizi ruolo aggiuntivi necessari per Gateway Desktop remoto, fare clic su Aggiungi servizi ruolo necessari.

    7. Nella pagina Selezione servizi ruolo fare clic su Avanti.

    Se il ruolo Servizi Desktop remoto è già installato:

    1. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    2. In Servizi ruolo fare clic su Aggiungi servizi ruolo.

    3. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Gateway Desktop remoto e quindi fare clic su Avanti.

    4. Se viene chiesto di specificare se si desidera installare i servizi ruolo aggiuntivi necessari per Gateway Desktop remoto, fare clic su Aggiungi servizi ruolo necessari.

    5. Nella pagina Selezione servizi ruolo fare clic su Avanti.

  3. Nella pagina Scelta di un certificato di autenticazione server per crittografia SSL specificare se si desidera scegliere un certificato esistente per la crittografia SSL (opzione consigliata), creare un certificato autofirmato per la crittografia SSL o scegliere un certificato per la crittografia SSL in seguito. Se si esegue l'installazione per un nuovo server che non dispone ancora di certificati, vedere Ottenere un certificato per il server Gateway Desktop remoto per ulteriori informazioni sui requisiti dei certificati e su come ottenerne e installarne uno.

    L'opzione Scegli un certificato esistente per crittografia SSL (scelta consigliata) consente di visualizzare un elenco contenente soltanto i certificati con lo scopo previsto (autenticazione server) e l'utilizzo chiavi avanzato (EKU, Enhanced Key Usage) [Autenticazione server (1.3.6.1.5.5.7.3.1)] che sono appropriati per il servizio ruolo Gateway Desktop remoto. Se si seleziona questa opzione, fare clic su Importa e quindi importare un nuovo certificato. Un certificato che non soddisfa questi requisiti non verrà visualizzato nell'elenco.

  4. Nella pagina Creazione di criteri di autorizzazione per Gateway Desktop remoto specificare se si desidera creare criteri di autorizzazione (Criteri di autorizzazione connessioni Desktop remoto e Criteri di autorizzazione risorse Desktop remoto) durante l'installazione del servizio ruolo Gateway Desktop remoto o in seguito. Se si seleziona In seguito, seguire le procedure descritte in Creare criteri di autorizzazione connessioni Desktop remoto per creare questi criteri. Se si seleziona Adesso, eseguire le operazioni seguenti:

    1. Nella pagina Selezione dei gruppi di utenti che possono connettersi tramite Gateway Desktop remoto fare clic su Aggiungi per specificare ulteriori gruppi di utenti. Nella finestra di dialogo Seleziona gruppi specificare il percorso e il nome del gruppo di utenti e quindi fare clic su OK secondo le esigenze per controllare il nome e chiudere la finestra di dialogo Seleziona gruppi.

      Per specificare più gruppi di utenti, eseguire una delle operazioni seguenti: Digitare il nome di ogni gruppo di utenti e separarlo con un punto e virgola, oppure aggiungere altri gruppi da domini diversi ripetendo la prima parte di questo passaggio per ogni gruppo.

    2. Dopo avere specificato i gruppi di utenti aggiuntivi, nella pagina Selezione dei gruppi di utenti che possono connettersi tramite Gateway Desktop remoto fare clic su Avanti.

    3. Nella pagina Creazione di criteri di autorizzazione connessioni Desktop remoto per Gateway Desktop remoto accettare il nome predefinito per i criteri di autorizzazione connessioni Desktop remoto (RD_CAP_01) oppure specificare un nome diverso, selezionare uno o più metodi di autenticazione di Windows supportati e infine fare clic su Avanti.

    4. Nella pagina Creazione di criteri di autorizzazione risorse Desktop remoto per Gateway Desktop remoto accettare il nome predefinito per i criteri di autorizzazione risorse Desktop remoto (RD_RAP_01) oppure specificare un nome diverso e quindi eseguire una delle operazioni seguenti: Specificare se consentire agli utenti di connettersi soltanto ai computer appartenenti a uno o più gruppi di computer e quindi specificare il gruppo di computer in questione, oppure specificare che gli utenti potranno connettersi a qualsiasi computer della rete. Fare clic su Avanti.

  5. Nella pagina Servizi di accesso e criteri di rete, che viene visualizzata solo se il servizio ruolo non è già installato, controllare le informazioni di riepilogo e quindi fare clic su Avanti.

  6. Nella pagina Selezione servizi ruolo verificare che la casella di controllo Server dei criteri di rete sia selezionata e quindi fare clic su Avanti.

  7. Nella pagina Server Web (IIS), che viene visualizzata solo se il servizio ruolo non è già installato, controllare le informazioni di riepilogo e quindi fare clic su Avanti.

  8. Nella pagina Selezione servizi ruolo accettare le selezioni predefinite per Server Web (IIS) e quindi fare clic su Avanti.

  9. Nella pagina Conferma selezioni per l'installazione verificare che vengano installati i servizi ruolo seguenti:

    • Servizi Desktop remoto\Gateway Desktop remoto

    • Servizi di accesso e criteri di rete\Server dei criteri di rete

    • Server Web (IIS)

    • Proxy RPC su HTTP

  10. Fare clic su Installa.

  11. Nella pagina Stato installazione verrà indicato lo stato di avanzamento dell'installazione.

    Verrà indicato solo lo stato di avanzamento dell'installazione di nuovi ruoli, servizi ruolo e funzionalità e non di eventuali ruoli, servizi ruolo e funzionalità già installati.

  12. Nella pagina Risultati installazione confermare che l'installazione di tali ruoli, servizi ruolo e funzionalità è stata completata, quindi fare clic su Chiudi.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Aprire Gestione Gateway Desktop remoto

Per aprire Gestione Gateway Desktop remoto dal menu Start

  • Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  • Fare clic sul pulsante Start, scegliere Esegui, digitare tsgateway.msc e quindi premere INVIO.

Per aprire Gestione Gateway Desktop remoto da Server Manager

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  2. Nel riquadro sinistro espandere Ruoli.

  3. Espandere Servizi Desktop remoto e quindi fare clic su Gestione Gateway Desktop remoto.

Per eseguire Gestione Gateway Desktop remoto da Microsoft Management Console

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare mmc e quindi premere INVIO.

  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

  3. In Snap-in disponibili fare clic su Gestione Gateway Desktop remoto e quindi su Aggiungi.

  4. Fare clic su OK.
Ulteriori riferimenti
  • Configurare il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Configurare un certificato per il server Gateway Desktop remoto

Per impostazione predefinita, Transport Layer Security (TLS) 1.0 viene utilizzato per crittografare le comunicazioni tra i client di Servizi Desktop remoto e i server Gateway Desktop remoto in Internet. Per un corretto funzionamento del protocollo TLS, è necessario che nel server Gateway Desktop remoto sia installato un certificato X.509 compatibile con SSL (Secure Sockets Layer).

È possibile ottenere un certificato in uno dei modi seguenti.

  • È possibile generare e inviare una richiesta di certificato per ottenere un certificato da una CA dell'organizzazione (enterprise) o autonoma (standalone).

  • È possibile acquistare un certificato, o ottenerne uno a costo zero per un periodo di prova, da una delle CA pubbliche attendibili che partecipano al programma Microsoft Root Certificate (vedere l'elenco nell'articolo 931125 della Microsoft Knowledge Base, all'indirizzo http://go.microsoft.com/fwlink/?LinkID=59547).

  • È possibile utilizzare l'Aggiunta guidata ruoli per creare un certificato autofirmato durante l'installazione del servizio ruolo Gateway Desktop remoto oppure è possibile utilizzare Gestione Gateway Desktop remoto per eseguire questa operazione dopo avere installato Gateway Desktop remoto.

Nota

È consigliabile utilizzare un certificato autofirmato solo a scopo di valutazione e per eseguire test.

Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

In questa sezione vengono descritti i requisiti dei certificati per il server Gateway Desktop remoto e vengono fornite ulteriori informazioni sui diversi metodi disponibili per ottenerne uno. Sono inclusi gli argomenti seguenti:

  • Ottenere un certificato per il server Gateway Desktop remoto

  • Creare un certificato autofirmato per il server Gateway Desktop remoto

  • Selezionare un certificato esistente da Gateway Desktop remoto

  • Importare un certificato nel server Gateway Desktop remoto

  • Visualizzare o modificare le proprietà dei certificati


Ottenere un certificato per il server Gateway Desktop remoto

Questo argomento presuppone la conoscenza delle nozioni fondamentali relative alla catena di certificati, alla firma dei certificati, nonché alla configurazione dell'infrastruttura a chiave pubblica e dei certificati. Per informazioni sulla configurazione dell'infrastruttura a chiave pubblica (PKI) in Windows Server 2008, vedere l'articolo ITPROADD-204 relativo ai miglioramenti di PKI in Microsoft Windows Vista e Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93995). Per informazioni sulla configurazione dell'infrastruttura a chiave pubblica (PKI) in Windows Server 2003, vedere l'articolo relativo all'infrastruttura a chiave pubblica (http://go.microsoft.com/fwlink/?LinkID=54917).

Per impostazione predefinita, Transport Layer Security (TLS) 1.0 viene utilizzato per crittografare le comunicazioni tra i client di Servizi Desktop remoto e i server Gateway Desktop remoto in Internet. TLS è un protocollo standard che consente di proteggere le comunicazioni Web che si svolgono su Internet o nelle reti Intranet ed è la versione più recente e sicura del protocollo Secure Sockets Layer (SSL). Per ulteriori informazioni su TLS vedere:

  • Pagina relativa a SSL/TLS in Windows Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?LinkID=19646.

  • Pagina relativa a RFC 2246, il protocollo TLS versione 1.0, all'indirizzo http://go.microsoft.com/fwlink/?LinkID=40979.

Per un corretto funzionamento del protocollo TLS, è necessario che nel server Gateway Desktop remoto sia installato un certificato X.509 compatibile con SSL.

Panoramica dell'installazione del certificato e del processo di configurazione

Per ottenere, installare e configurare un certificato per il server Gateway Desktop remoto, eseguire la procedura seguente:

Passaggio 1: ottenere un certificato per il server Gateway Desktop remoto

È possibile ottenere un certificato per il server Gateway Desktop remoto utilizzando uno dei metodi seguenti:

  • Se la propria società dispone di un'autorità di certificazione dell'organizzazione (enterprise) o autonoma (standalone) configurata per il rilascio di certificati X.509 compatibili con SSL conformi ai requisiti di Gateway Desktop remoto, è possibile generare e inviare una richiesta di certificato in più modi, in base ai criteri e alla configurazione della CA dell'organizzazione. È possibile ottenere un certificato:

    • Avviando la registrazione automatica dallo snap-in certificati.

    • Richiedendo i certificati mediante la Richiesta guidata certificato.

    • Richiedendo un certificato sul Web.

      Nota

      Se si dispone di una CA di Windows Server 2003, tenere presente che la funzionalità di registrazione Web di Servizi certificati di Windows Server 2003 si basa su un controllo ActiveX denominato Xenroll, che è disponibile in Microsoft Windows Server 2003, Windows 2000 e Windows XP, ma è obsoleto in Windows Server 2008 e Microsoft Windows Vista. Le pagine Web di esempio per la registrazione dei certificati che sono incluse nella versione originale di Windows Server 2003, Windows Server 2003 Service Pack 1 (SP1) e Windows Server 2003 Service Pack 2 (SP2) non sono adatte alla diversa modalità con cui Windows Server 2008 e Microsoft Windows Vista gestiscono le operazioni di registrazione dei certificati basate sul Web. Per informazioni sulla procedura da seguire per risolvere il problema, vedere l'articolo 922706 nella Microsoft Knowledge Base, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94472.

    • Utilizzando lo strumento da riga di comando Certreq.

    Per ulteriori informazioni su come utilizzare uno di questi metodi per ottenere i certificati per Windows Server 2008 R2, vedere l'argomento "Ottenere un certificato" nella Guida dello snap-in certificati e l'argomento "Certreq" nella pagina di riferimento per i comandi di Windows Server 2008 R2. Per esaminare gli argomenti della Guida dello snap-in certificati, fare clic sul pulsante Start, scegliere Esegui, digitare hh certmgr.chm e quindi fare clic su OK. Per informazioni su come richiedere i certificati per Windows Server 2003, vedere la pagina relativa alla richiesta di certificati, all'indirizzo http://go.microsoft.com/fwlink/?LinkID=19638.

    Un certificato rilasciato da una CA dell'organizzazione (enterprise) o da una CA autonoma (standalone) deve essere firmato contestualmente da una CA pubblica attendibile che partecipi al programma Microsoft Root Certification (http://go.microsoft.com/fwlink/?LinkID=59547). In caso contrario, gli utenti che si connettono da computer di casa o chioschi multimediali potrebbero non essere in grado di connettersi ai server TS Gateway o Gateway Desktop remoto. Tali connessioni potrebbero non avvenire perché il certificato radice rilasciato dalla CA potrebbe non essere considerato attendibile dai computer che non sono membri di domini, ad esempio i computer di casa o i chioschi multimediali.

  • Se la propria società non dispone di una CA dell'organizzazione (enterprise) o di una CA autonoma (standalone) configurata per il rilascio di certificati X.509 conformi a SSL, è possibile acquistare un certificato da una CA pubblica attendibile che partecipi al programma Microsoft Root Certificate (http://go.microsoft.com/fwlink/?LinkID=59547). Alcune di questa CA pubbliche potrebbero offrire certificati a costo zero per un periodo di prova.

  • In alternativa, se la propria società non dispone di né un'autorità di certificazione dell'organizzazione (enterprise) o autonoma (standalone), né di un certificato compatibile rilasciato da una CA pubblica attendibile, è possibile creare e importare un certificato autofirmato per il proprio server Gateway Desktop remoto, da utilizzare solo per le valutazioni tecniche e i test. Per ulteriori informazioni, vedere Creare un certificato autofirmato per il server Gateway Desktop remoto.

    Importante

    Se si utilizza uno dei primi due metodi per ottenere un certificato, in altre parole se si ottiene un certificato da un'autorità di certificazione dell'organizzazione (enterprise) o autonoma (standalone) oppure da una CA pubblica attendibile, è inoltre necessario Importare un certificato nel server Gateway Desktop remoto e Selezionare un certificato esistente da Gateway Desktop remoto. Se invece si crea un certificato autofirmato utilizzando l'Aggiunta guidata ruoli durante l'installazione del servizio ruolo Gateway Desktop remoto oppure utilizzando Gestione Gateway Desktop remoto dopo l'installazione, come descritto in Creare un certificato autofirmato per il server Gateway Desktop remoto, non è necessario installare o mappare il certificato al server Gateway Desktop remoto. In tal caso, il certificato verrà automaticamente creato, installato nel percorso corretto del server Gateway Desktop remoto e mappato sul server Gateway Desktop remoto.

    Si noti che il certificato della CA che ha rilasciato il certificato del server deve essere presente nell'archivio Autorità di certificazione radice attendibili dei client di Servizi Desktop remoto. Per istruzioni dettagliate sull'installazione del certificato nel client, vedere Installare il certificato radice del server Gateway Desktop remoto nel client di Servizi Desktop remoto.

    Se è stato utilizzato uno dei primi due metodi per ottenere un certificato e il computer client di Servizi Desktop remoto considera attendibile la CA che lo ha rilasciato, non è necessario installare il certificato della CA che ha rilasciato il certificato del server nell'archivio certificati del computer client. Non è ad esempio necessario installare il certificato della CA di rilascio nell'archivio certificati del computer client se nel server Gateway Desktop remoto è installato un certificato VeriSign o un altro certificato rilasciato da una CA pubblica attendibile. Se si utilizza il terzo metodo e si crea un certificato autofirmato, è invece necessario che il certificato della CA che ha rilasciato il certificato del server venga installato nell'archivio Autorità di certificazione radice attendibili nel computer client. Per ulteriori informazioni, vedere Installare il certificato radice del server Gateway Desktop remoto nel client di Servizi Desktop remoto.

Passaggio 2: importare un certificato

Dopo aver ottenuto un certificato, è possibile importarlo nel server Gateway Desktop remoto utilizzando uno dei metodi seguenti:

  • Per installare il certificato nell'archivio certificati e importarlo nel server Gateway Desktop remoto, vedere Importare un certificato nel server Gateway Desktop remoto.

  • Per importare un certificato esistente dall'archivio certificati nel server Gateway Desktop remoto, vedere Selezionare un certificato esistente da Gateway Desktop remoto.

Ulteriori riferimenti

  • Configurare un certificato per il server Gateway Desktop remoto


Creare un certificato autofirmato per il server Gateway Desktop remoto

In questa procedura viene descritto come utilizzare Gestione Gateway Desktop remoto per creare un certificato autofirmato, nel caso non sia già stato creato tramite l'Aggiunta guidata ruoli durante l'installazione del servizio ruolo Gateway Desktop remoto.

Importante

È consigliabile utilizzare i certificati autofirmati solo a scopo di valutazione e per eseguire test.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare un certificato autofirmato per il server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione e quindi scegliere Proprietà.

  3. Nel riquadro dei risultati fare clic su Visualizza o modifica proprietà certificato in Stato configurazione.

  4. Nella scheda Certificato SSL fare clic su Crea un certificato autofirmato e quindi su Crea e importa certificato.

  5. Nella finestra di dialogo Crea certificato autofirmato eseguire le operazioni seguenti:

    • Nella casella Nome certificato verificare che sia specificato il nome di dominio completo (FQDN) corretto per il certificato autofirmato oppure specificare un nuovo nome. Il nome di dominio completo deve corrispondere esattamente al nome DNS utilizzato dal client per connettersi al server Gateway Desktop remoto, a meno che non si utilizzino i certificati jolly o gli attributi SAN dei certificati.

    • Per archiviare il certificato radice in un percorso specifico e in seguito distribuirlo manualmente ai client, verificare che la casella di controllo Archivia certificato radice sia selezionata e quindi specificare il percorso in cui si desidera archiviare il certificato. Per impostazione predefinita, questa casella di controllo è selezionata e il certificato viene archiviato nella cartella %Windir%\Utenti\<NomeUtente>\Documenti.

    • Fare clic su OK.

  6. Se è stata selezionata la casella di controllo Archivia certificato radice ed è stato specificato un percorso per il certificato, verrà visualizzato un messaggio per informare che Gateway Desktop remoto ha completato la creazione del certificato autofirmato e confermare il percorso in cui il certificato è stato archiviato. Fare clic su OK per chiudere la finestra del messaggio.

  7. Fare clic su OK di nuovo per chiudere la finestra di dialogo Proprietà del server Gateway Desktop remoto.

Ulteriori considerazioni

  • Per informazioni sugli altri metodi per ottenere un certificato e sui requisiti dei certificati per Gateway Desktop remoto, vedere Ottenere un certificato per il server Gateway Desktop remoto.

Ulteriori riferimenti

  • Configurare un certificato per il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Ottenere un certificato per il server Gateway Desktop remoto


Selezionare un certificato esistente da Gateway Desktop remoto

Dopo avere ottenuto e installato un certificato per il server Gateway Desktop remoto, è necessario mappare (associare) tale certificato sul server Gateway Desktop remoto utilizzando Gestione Gateway Desktop remoto. Se il certificato del server Gateway Desktop remoto viene mappato con qualsiasi altro metodo, Gateway Desktop remoto non funzionerà correttamente.

Nota

Questa procedura non è necessaria se è stato creato un certificato autofirmato per Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per importare il certificato di Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà del server Gateway Desktop remoto, nella scheda Certificato SSL, fare clic su Seleziona un certificato esistente dal Gateway Desktop remoto <RD Gateway Server Name> Certificati (computer locale)/archivio personale, dove <RD Gateway Server Name> è il nome del computer in cui il server Gateway Desktop remoto è in esecuzione.

  4. Fare clic su Importa certificato.

  5. Nella finestra di dialogo Importa certificato fare clic sul certificato che si desidera utilizzare e quindi su Importa.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server Gateway Desktop remoto.

    Se il certificato di Gateway Desktop remoto viene mappato per la prima volta, al termine della procedura è possibile verificare se l'operazione è stata eseguita correttamente visualizzando l'area Stato del server Gateway Desktop remoto in Gestione Gateway Desktop remoto. In Stato configurazione e Attività di configurazione non dovrebbero essere più visualizzati l'avviso relativo alla mancata selezione o installazione di un certificato del server e il collegamento ipertestuale Visualizza o modifica proprietà certificato.

Ulteriori riferimenti

  • Configurare un certificato per il server Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto

  • Ottenere un certificato per il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Importare un certificato nel server Gateway Desktop remoto

Dopo avere ottenuto un certificato, utilizzare la procedura seguente per installarlo nell'archivio corretto del server Gateway Desktop remoto, qualora non sia già installato. La procedura descritta consente di installare il certificato nell'archivio certificati appropriato e di importarlo per il server Gateway Desktop remoto.

Nota

Questa procedura non è necessaria se è stato creato un certificato autofirmato per Gateway Desktop remoto selezionando l'opzione Crea certificato autofirmato per crittografia SSL durante l'installazione di Gateway Desktop remoto tramite la procedura guidata di aggiunta o rimozione di ruoli o, in alternativa, selezionando l'opzione Crea un certificato autofirmato come descritto in Creare un certificato autofirmato per il server Gateway Desktop remoto dopo l'installazione di Gateway Desktop remoto. In entrambi i casi, il certificato verrà automaticamente creato, installato nel percorso corretto del server Gateway Desktop remoto e mappato sul server Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare un certificato nel server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà del server Gateway Desktop remoto, nella scheda Certificato SSL, fare clic su Importa un certificato in Gateway Desktop remoto<RD Gateway Server Name> Certificati (computer locale)/archivio personale, dove <RD Gateway Server Name> è il nome del computer in cui il server Gateway Desktop remoto è in esecuzione.

  4. Fare clic su Cerca e importa certificato.

  5. Nella finestra di dialogo Apri fare clic sul certificato che si desidera utilizzare e quindi su Apri.

  6. Nella finestra di dialogo Immissione password chiave privata immettere nella casella Password chiave privata la password per il certificato e quindi fare clic su OK.

  7. Nella finestra di dialogo Importazione certificati fare clic su OK.

  8. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server Gateway Desktop remoto.

    Se il certificato di Gateway Desktop remoto viene mappato per la prima volta, al termine della procedura è possibile verificare se l'operazione è stata eseguita correttamente visualizzando l'area Stato del server Gateway Desktop remoto in Gestione Gateway Desktop remoto. In Stato configurazione e Attività di configurazione non dovrebbero essere più visualizzati l'avviso relativo alla mancata selezione o installazione di un certificato del server e il collegamento ipertestuale Visualizza o modifica proprietà certificato.

Ulteriori riferimenti

  • Configurare un certificato per il server Gateway Desktop remoto

  • Ottenere un certificato per il server Gateway Desktop remoto

  • Creare un certificato autofirmato per il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Visualizzare o modificare le proprietà dei certificati

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare o modificare le proprietà dei certificati

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà del server Gateway Desktop remoto, nella scheda Certificato SSL, fare clic su Seleziona un certificato esistente dal Gateway Desktop remoto <RD Gateway Server Name> Certificati (computer locale)/archivio personale, dove <RD Gateway Server Name> è il nome del computer in cui il server Gateway Desktop remoto è in esecuzione.

  4. Fare clic su Importa certificato e quindi eseguire una delle operazioni seguenti nella finestra di dialogo Importa certificato:

    • Per mappare un certificato diverso sul server Gateway Desktop remoto, selezionare il certificato che si desidera venga utilizzato da tale server Gateway Desktop remoto e quindi fare clic su Importa. Nella scheda Certificato SSL esaminare i campi Rilasciato a, Rilasciato da e Data scadenza per verificare che il certificato mappato sul server Gateway Desktop remoto sia quello corretto.

    • Per visualizzare le proprietà di un certificato installato nel server Gateway Desktop remoto, selezionare il certificato che si desidera visualizzare e quindi fare clic su Visualizza certificato. Dopo avere esaminato le proprietà del certificato nella finestra di dialogo Certificato, fare clic su OK per chiudere la finestra di dialogo Certificato e quindi fare clic su Annulla per chiudere la finestra di dialogo Installa certificato.

  5. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server Gateway Desktop remoto.

Ulteriori riferimenti

  • Configurare un certificato per il server Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Specificare un server Gateway Desktop remoto da gestire

Dopo l'installazione del servizio ruolo Gateway Desktop remoto e l'apertura di Gestione Gateway Desktop remoto nel server, per impostazione predefinita Gestione Gateway Desktop remoto visualizza i dettagli relativi al server.

Se si intende gestire un server remoto Gateway Desktop remoto, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende gestire in remoto. In particolare, è necessario accedere al computer locale utilizzando un account di dominio appartenente al gruppo Administrators o a un gruppo equivalente nel server Gateway Desktop remoto che si intende gestire in remoto. In alternativa, è possibile aprire Gestione Gateway Desktop remoto dopo avere effettuato l'accesso con un account di questo tipo. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per gestire un server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse su Gestione Gateway Desktop remoto e quindi scegliere Connetti a server Gateway Desktop remoto.

  3. Nella finestra di dialogo Aggiungi server Gateway Desktop remoto da gestire specificare se si desidera connettersi a un server locale o a un server remoto eseguendo una delle operazioni seguenti:

    • Per connettersi a un server locale Gateway Desktop remoto, fare clic su Server locale (il server su cui viene eseguita questa console snap-in).

    • Per connettersi a un server remoto Gateway Desktop remoto, immettere il nome del server Gateway Desktop remoto al quale si desidera connettersi nella casella Server remoto. In alternativa, fare clic su Cerca per selezionare il server Gateway Desktop remoto e, nella finestra Seleziona computer, specificare il dominio in cui si trova il server, quindi immettere il nome del server o parte di esso e infine fare clic su OK per chiudere la finestra di dialogo Seleziona computer.

  4. Fare clic su OK.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Installare il servizio ruolo Gateway Desktop remoto

  • Ottenere un certificato per il server Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Creare una server farm Gateway Desktop remoto

Gateway Desktop remoto utilizza due connessioni per ogni sessione client: una per il traffico in entrata e una per il traffico in uscita. Tale procedura serve ad assicurare che, se il carico viene bilanciato distribuendo ogni connessione a un diverso server Gateway Desktop remoto, il traffico da entrambe le connessioni possa essere reindirizzato verso lo stesso server Gateway Desktop remoto.

Importante

Prima di completare questa procedura, è necessario avere già configurato il bilanciamento del carico, in quanto Gateway Desktop remoto non lo esegue direttamente. Questa procedura serve solo ad assicurare che Gateway Desktop remoto funzioni correttamente con una soluzione di bilanciamento del carico preesistente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Importante

I server Gateway Desktop remoto aggiunti alla server farm Gateway Desktop remoto devono essere membri del dominio e avere Criteri di autorizzazione connessioni Desktop remoto e Criteri di autorizzazione risorse Desktop remoto identici.

Per creare una server farm Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto selezionare il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nel riquadro dei risultati fare clic su Aggiungi membri server farm del Gateway Desktop remoto in Stato configurazione. Se sono già stati aggiunti uno o più server Gateway Desktop remoto alla server farm, il titolo del collegamento ipertestuale visualizzato sarà Visualizza membri della server farm di Gateway Desktop remoto.

  4. Nella finestra di dialogo Proprietà del server Gateway Desktop remoto, nella casella Membri server farm Gateway Desktop remoto della scheda Server farm digitare il nome del server Gateway Desktop remoto che si desidera aggiungere alla farm e quindi fare clic su Aggiungi.

    Nota

    È possibile specificare un nome NetBIOS, un nome di dominio completo o un indirizzo IP per ogni server Gateway Desktop remoto che viene aggiunto alla farm, tuttavia tale nome deve corrispondere esattamente al nome del server Gateway Desktop remoto utilizzato in Servizi di dominio Active Directory.

    Dopo avere fatto clic su Aggiungi, il nome del server Gateway Desktop remoto verrà visualizzato in Stato server farm di Gateway Desktop remoto.

  5. Ripetere il passaggio 4 il numero di volte necessario, assicurandosi di aggiungere i nomi di tutti gli altri membri della server farm Gateway Desktop remoto e di includere il nome del server Gateway Desktop remoto locale. L'elenco dei membri della server farm Gateway Desktop remoto deve essere identico in ogni server Gateway Desktop remoto della farm.

  6. Fare clic su OK.

Ulteriori considerazioni

  • Gateway Desktop remoto interagisce con Bilanciamento carico di rete o con i dispositivi non Microsoft per il bilanciamento del carico.

  • In un ambiente con bilanciamento del carico, i server Gateway Desktop remoto sono raggruppati in farm, ognuna delle quali è rappresentata ai client di Servizi Desktop remoto con un solo nome di computer e un solo indirizzo IP.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Rimuovere i membri di una server farm Gateway Desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per rimuovere i membri di una server farm Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto selezionare il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nel riquadro dei risultati fare clic su Visualizza membri della server farm di Gateway Desktop remoto in Stato configurazione.

  4. Nella finestra di dialogo Proprietà del server Gateway Desktop remoto, in Stato server farm di Gateway Desktop remoto, nella scheda Server farm, fare clic sul server Gateway Desktop remoto che si desidera rimuovere e quindi fare clic su Rimuovi.

  5. Nella finestra di dialogo Gateway Desktop remoto fare clic su Sì.

  6. Per rimuovere ulteriori server Gateway Desktop remoto, ripetere i passaggi 4 e 5 il numero di volte necessario. Assicurarsi di ripetere questi passaggi per ogni server nella farm, in modo che l'elenco di membri sia identico per ogni server nella farm.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Creare una server farm Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Disattivare la gestione per un server Gateway Desktop remoto

È possibile utilizzare questa procedura per interrompere la gestione di un server Gateway Desktop remoto. Per specificare un server Gateway Desktop remoto diverso da gestire o per gestire di nuovo lo stesso server Gateway Desktop remoto in seguito, vedere Specificare un server Gateway Desktop remoto da gestire.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per disattivare la gestione per un server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per selezionare il nodo che rappresenta il server Gateway Desktop remoto per il quale si desidera disattivare la gestione.

  3. Fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto e quindi scegliere Non gestire questo server.

  4. Verrà visualizzato un messaggio in cui viene richiesto di confermare l'interruzione della gestione per il server Gateway Desktop remoto specificato. Per confermare, fare clic su Sì.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

Dopo avere installato il servizio ruolo Gateway Desktop remoto e aver configurato un certificato per il server Gateway Desktop remoto, è necessario creare Criteri di autorizzazione connessioni Desktop remoto, gruppi di computer e Criteri di autorizzazione risorse Desktop remoto.

In questo argomento viene descritto il modo in cui i Criteri di autorizzazione connessioni Desktop remoto, i gruppi di computer e i Criteri di autorizzazione risorse Desktop remoto consentono di controllare l'accesso remoto degli utenti alle risorse di rete interne (computer) quando tali utenti si connettono alla rete interna tramite Internet utilizzando Gateway Desktop remoto.

Criteri di autorizzazione connessioni Desktop remoto

I Criteri di autorizzazione connessioni Desktop remoto consentono di specificare gli utenti autorizzati a connettersi a un server Gateway Desktop remoto. È possibile specificare un gruppo di utenti esistente nel server Gateway Desktop remoto locale o in Servizi di dominio Active Directory. È inoltre possibile specificare altre condizioni che gli utenti devono soddisfare per accedere a un server Gateway Desktop remoto. È possibile elencare condizioni specifiche per ognuno dei Criteri di autorizzazione connessioni Desktop remoto. È ad esempio possibile richiedere che un gruppo di utenti utilizzi una smart card per connettersi tramite Gateway Desktop remoto.

Importante

Gli utenti sono autorizzati ad accedere a un server Gateway Desktop remoto se soddisfano le condizioni specificate nei Criteri di autorizzazione connessioni Desktop remoto. È inoltre necessario creare Criteri di autorizzazione risorse Desktop remoto. I Criteri di autorizzazione risorse Desktop remoto consentono di specificare le risorse di rete (computer) alle quali gli utenti possono connettersi tramite Gateway Desktop remoto. Fino a quando non vengono creati sia i Criteri di autorizzazione connessioni Desktop remoto che i Criteri di autorizzazione risorse Desktop remoto, gli utenti non possono connettersi alle risorse di rete tramite questo server Gateway Desktop remoto.

Per informazioni sulla creazione di Criteri di autorizzazione connessioni Desktop remoto, vedere Gestire i criteri di autorizzazione connessioni Desktop remoto.

Criteri di autorizzazione risorse Desktop remoto

I Criteri di autorizzazione risorse Desktop remoto consentono di specificare le risorse di rete interne alle quali gli utenti remoti possono connettersi tramite un server Gateway Desktop remoto. Quando si creano Criteri di autorizzazione risorse Desktop remoto, è possibile creare un gruppo di computer (un elenco di computer della rete interna ai quali gli utenti remoti possono connettersi) e associare tale gruppo ai Criteri di autorizzazione risorse Desktop remoto.

Gli utenti remoti che si connettono a una rete interna tramite un server Gateway Desktop remoto sono autorizzati ad accedere ai computer della rete se soddisfano le condizioni specificate in almeno uno dei Criteri di autorizzazione connessioni Desktop remoto e uno dei Criteri di autorizzazione risorse Desktop remoto.

Nota

Quando si associa un gruppo di computer gestito da Gateway Desktop remoto a Criteri di autorizzazione risorse Desktop remoto, è possibile supportare sia i nomi di dominio completi sia i nomi NetBIOS aggiungendo entrambi i nomi separatamente al gruppo di computer gestito da Gateway Desktop remoto. Quando si associa un gruppo di sicurezza di Active Directory a Criteri di autorizzazione risorse Desktop remoto, i nomi di dominio completi e i nomi NetBIOS sono entrambi supportati automaticamente se il computer della rete interna a cui il client si connette appartiene allo stesso dominio del server Gateway Desktop remoto. Se il computer della rete interna appartiene a un dominio diverso rispetto al server Gateway Desktop remoto, gli utenti devono specificare il nome di dominio completo del computer della rete interna.

Per informazioni sulla creazione di Criteri di autorizzazione risorse Desktop remoto, vedere Gestire i criteri di autorizzazione risorse Desktop remoto.

L'utilizzo di Criteri di autorizzazione connessioni Desktop remoto in combinazione con i Criteri di autorizzazione risorse Desktop remoto garantisce due livelli diversi di autorizzazione e offre la possibilità di configurare un più specifico livello di controllo dell'accesso ai computer della rete interna.

Gruppi di risorse di rete e gruppi di computer gestiti da Gateway Desktop remoto associati con criteri di autorizzazione risorse Desktop remoto

Tramite Gateway Desktop remoto gli utenti remoti possono connettersi alle risorse di rete interne in un gruppo di sicurezza o in un gruppo di computer gestito da Gateway Desktop remoto. Il gruppo può essere uno qualsiasi dei seguenti:

  • Selezionare un gruppo di risorse di Servizi di dominio Active Directory. Il gruppo di risorse di rete è già presente in Servizi di dominio Active Directory.

  • Selezionare un gruppo gestito da Gateway Desktop remoto o crearne uno nuovo. È possibile configurare un gruppo di computer gestito da Gateway Desktop remoto o selezionare un gruppo esistente utilizzando Gestione Gateway Desktop remoto dopo l'installazione.

    Un gruppo di computer gestito da Gateway Desktop remoto non verrà visualizzato in Utenti e gruppi locali nel server Gateway Desktop remoto, né potrà essere configurato utilizzando Utenti e gruppi locali.

  • Consentire agli utenti di connettersi a qualsiasi risorsa di rete. In questo caso, gli utenti possono connettersi a tutti i computer della rete interna ai quali possono connettersi quando utilizzano Connessione desktop remoto.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto


Gestire i criteri di autorizzazione connessioni Desktop remoto

In questa sezione vengono illustrate le procedure per configurare i Criteri di autorizzazione connessioni Desktop remoto, che consentono ai client di Servizi Desktop remoto di connettersi a un server Gateway Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Informazioni sui requisiti per la connessione a un server Gateway Desktop remoto

  • Creare criteri di autorizzazione connessioni Desktop remoto

  • Attivare o disattivare criteri di autorizzazione connessioni Desktop remoto

  • Visualizzare i dettagli sui criteri di autorizzazione connessioni Desktop remoto

  • Modificare o rimuovere criteri di autorizzazione connessioni Desktop remoto locali

  • Specificare un nuovo archivio centrale per i criteri di autorizzazione connessioni Desktop remoto

  • Specificare un archivio locale o centrale esistente per i criteri di autorizzazione connessioni Desktop remoto

  • Rimuovere un server che esegue il Server dei criteri di rete o modificare un segreto condiviso del server per i criteri di autorizzazione connessioni Desktop remoto archiviati centralmente


Informazioni sui requisiti per la connessione a un server Gateway Desktop remoto

Per potersi connettere a Gateway Desktop remoto, è necessario che gli utenti dei client di Servizi Desktop remoto soddisfino alcuni requisiti specifici, tra cui i seguenti:

  • Metodo di autenticazione di Windows supportato (obbligatorio). È possibile configurare i metodi di autenticazione che saranno riconosciuti dal server Gateway Desktop remoto utilizzando Gestione Gateway Desktop remoto. Nei client è possibile configurare il metodo di autenticazione che dovrà essere utilizzato per la connessione al server Gateway Desktop remoto utilizzando Criteri di gruppo.

    Importante

    È necessario che il client e il server Gateway Desktop remoto al quale il client si connette abbiano almeno un metodo di autenticazione in comune, altrimenti il tentativo di connessione del client al server Gateway Desktop remoto avrà esito negativo.

    Nota

    Se si configura il metodo di autenticazione nel client tramite Criteri di gruppo, tenere presente che le impostazioni di Criteri di gruppo per le connessioni dei client di Servizi Desktop remoto possono essere applicate in due modi: le impostazioni possono essere consigliate, ovvero attivate ma non imposte, oppure possono essere attivate e imposte. Per ulteriori informazioni, vedere Utilizzare Criteri di gruppo per gestire le connessioni client tramite Gateway Desktop remoto.

  • Appartenenza a un gruppo di utenti (obbligatorio). È possibile configurare il requisito relativo all'appartenenza a un gruppo di utenti utilizzando Gestione Gateway Desktop remoto.

  • Appartenenza a un gruppo di computer client (facoltativo). È possibile configurare il requisito relativo all'appartenenza a un gruppo di computer client utilizzando Gestione Gateway Desktop remoto.

  • In Gestione Gateway Desktop remoto è possibile configurare questi requisiti nella scheda Requisiti di Criteri di autorizzazione connessioni Desktop remoto. Per ulteriori informazioni, vedere Creare criteri di autorizzazione connessioni Desktop remoto.

Metodi di autenticazione di Windows supportati

Se il metodo di autenticazione di Windows supportato viene configurato tramite Gestione Gateway Desktop remoto, è possibile specificare che l'utente dovrà utilizzare una password o una smart card oppure entrambe. Se si selezionano entrambi i metodi, l'utente potrà utilizzarne uno a scelta per connettersi.

Se il metodo di autenticazione di Windows supportato viene configurato tramite Criteri di gruppo, sono disponibili le opzioni seguenti:

  • Richiedi credenziali, usa protocollo NTLM (un protocollo challenge/response di Windows NT). Per informazioni sul protocollo NTLM, vedere la pagina relativa ad accesso e autenticazione (http://go.microsoft.com/fwlink/?LinkId=94215) e la pagina relativa a Microsoft NTLM (http://go.microsoft.com/fwlink/?LinkId=94216).

  • Richiedi credenziali, usa protocollo di base. Il metodo di autenticazione di base è un metodo standard ampiamente utilizzato per la raccolta di informazioni relative a nome utente e password, tuttavia è meno sicuro perché le password vengono trasmesse nel formato codificato Base64 e non crittografate. Per ulteriori informazioni, vedere la pagina dedicata all'autenticazione di base all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94217.

  • Usa credenziali dell'utente connesso localmente. In questo caso, per la connessione al server Gateway Desktop remoto verranno utilizzate le stesse credenziali fornite dagli utenti per eseguire l'accesso al computer locale. Se tuttavia si seleziona questa opzione, ma gli utenti si sono già connessi in precedenza allo stesso server Gateway Desktop remoto e hanno selezionato la casella di controllo Memorizza credenziali nella finestra di dialogo Impostazioni server Gateway Desktop remoto nel proprio computer client, per la connessione al server Gateway Desktop remoto verranno utilizzate le credenziali salvate.

  • Utilizza smart card. Le smart card contengono un microcomputer e una piccola quantità di memoria e costituiscono un archivio sicuro e inalterabile per le chiavi private e i certificati di sicurezza X.509. Le smart card sono una forma di autenticazione a due fattori, in quanto l'utente deve avere a disposizione una smart card e conoscere il PIN per avere accesso alle risorse di rete. Per ulteriori informazioni, vedere la Guida alla pianificazione dell'accesso sicuro tramite smart card all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94218.

  • Se gli utenti dispongono di tutte le credenziali descritte e hanno già salvato le proprie credenziali durante la connessione al server Gateway Desktop remoto, le credenziali verranno utilizzate nell'ordine seguente:

  1. Credenziali salvate

  2. Credenziali dell'utente connesso localmente

  3. Altre credenziali basate su password o smart card fornite dall'utente

Ulteriori riferimenti

  • Per informazioni su come utilizzare Criteri di gruppo per configurare i metodi di autenticazione di Windows supportati per Gateway Desktop remoto, vedere Impostare il metodo di autenticazione del server Gateway Desktop remoto.

  • Per informazioni su come utilizzare Gestione Gateway Desktop remoto per configurare i metodi di autenticazione di Windows supportati, vedere Creare criteri di autorizzazione connessioni Desktop remoto.

  • Per informazioni su come utilizzare Gestione Gateway Desktop remoto per configurare i requisiti di appartenenza a un gruppo di utenti o a un gruppo di computer, vedere Creare criteri di autorizzazione connessioni Desktop remoto.

  • Gestire i criteri di autorizzazione connessioni Desktop remoto


Creare criteri di autorizzazione connessioni Desktop remoto

I Criteri di autorizzazione connessioni Desktop remoto consentono di specificare gli utenti autorizzati a connettersi a un server Gateway Desktop remoto. In questa procedura viene descritto come creare nuovi Criteri di autorizzazione connessioni Desktop remoto locali. In alternativa, è possibile specificare un archivio centrale dei Criteri di autorizzazione connessioni Desktop remoto. Per ulteriori informazioni, vedere Specificare un nuovo archivio centrale per i criteri di autorizzazione connessioni Desktop remoto o Specificare un archivio locale o centrale esistente per i criteri di autorizzazione connessioni Desktop remoto.

Importante

È inoltre necessario creare Criteri di autorizzazione risorse Desktop remoto, qualora non siano già stati creati. Fino a quando non vengono creati sia i Criteri di autorizzazione connessioni Desktop remoto che i Criteri di autorizzazione risorse Desktop remoto, gli utenti non possono connettersi alle risorse di rete tramite questo server Gateway Desktop remoto.

In questa procedura viene descritto come utilizzare Gestione Gateway Desktop remoto per creare Criteri di autorizzazione connessioni Desktop remoto personalizzati. In alternativa, è possibile utilizzare la Configurazione guidata criteri di autorizzazione per creare rapidamente Criteri di autorizzazione connessioni Desktop remoto e Criteri di autorizzazione risorse Desktop remoto per Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare criteri di autorizzazione connessioni Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle connessioni.

  4. Fare clic con il pulsante destro del mouse sulla cartella Criteri di autorizzazione delle connessioni, scegliere Crea nuovo criterio e quindi fare clic su personalizzate.

  5. Nella scheda Generale della finestra di dialogo Nuovo criterio di autorizzazione connessioni Desktop remoto immettere nella casella Nome criterio un nome per il criterio e quindi verificare che la casella di controllo Attiva criterio sia selezionata.

  6. Nella scheda Requisiti, in Metodi di autenticazione di Windows supportati, selezionare una o entrambe le caselle di controllo seguenti:

    • Password

    • Smart card

    Se entrambe le opzioni sono selezionate, i client che utilizzano uno di questi metodi di autenticazione saranno autorizzati a connettersi.

  7. In Appartenenza a un gruppo di utenti (obbligatorio) fare clic su Aggiungi gruppo e quindi specificare un gruppo di utenti i cui membri siano autorizzati a connettersi al server Gateway Desktop remoto. È necessario specificare almeno un gruppo di utenti.

  8. Nella finestra di dialogo Seleziona gruppi specificare il percorso e il nome del gruppo di utenti e quindi fare clic su OK secondo le esigenze per selezionare il nome e chiudere la finestra di dialogo Seleziona gruppi. Per specificare più gruppi di utenti, eseguire una delle operazioni seguenti:

    • Digitare il nome di ogni gruppo di utenti, separandolo dagli altri nomi con un punto e virgola.

    • Per aggiungere altri gruppi da domini diversi, ripetere questo passaggio per ogni gruppo.

  9. È possibile specificare criteri aggiuntivi facoltativi di appartenenza a un dominio di computer che devono essere soddisfatti dai computer client facendo clic su Aggiungi gruppo in Appartenenza a un gruppo di computer client (facoltativo) nella scheda Requisiti e quindi specificando i gruppi di computer.

    Per specificare i gruppi di computer, è possibile eseguire gli stessi passaggi utilizzati per specificare i gruppi di utenti.

  10. Per attivare o disattivare il reindirizzamento dei dispositivi client remoti, nella scheda Reindirizzamento dispositivi selezionare una delle opzioni seguenti:

    • Per consentire il reindirizzamento di tutti i dispositivi client quando effettuano la connessione tramite il server Gateway Desktop remoto, fare clic su Attiva reindirizzamento dispositivi per tutti i dispositivi client. Questa opzione è selezionata per impostazione predefinita.

    • Per disattivare il reindirizzamento dei dispositivi solo per alcuni tipi di dispositivo quando effettuano la connessione tramite il server Gateway Desktop remoto, fare clic su Disattiva reindirizzamento dispositivi per i tipi di dispositivi client seguenti e quindi selezionare le caselle di controllo corrispondenti ai tipi di dispositivo per i quali si desidera disattivare il reindirizzamento dei dispositivi.

  11. Per consentire solo la connessione client ai server che impongono il reindirizzamento sicuro dei dispositivi, nella scheda Reindirizzamento dispositivi fare clic su Consenti connessioni client solo ai server host sessione Desktop remoto in cui è applicato il reindirizzamento dei dispositivi del Gateway Desktop remoto.

    Attenzione

    Se si seleziona Consenti connessioni client solo ai server host sessione Desktop remoto in cui è applicato il reindirizzamento dei dispositivi del Gateway Desktop remoto, gli utenti che eseguono versioni precedenti a Connessione desktop remoto 7.0 non possono effettuare la connessione e viene imposto il reindirizzamento sicuro dei dispositivi.

  12. Nella scheda Timeout selezionare le opzioni seguenti per attivare o disattivare i timeout:

    • Per specificare le impostazioni di timeout per la disconnessione per una sessione remota inattiva quando ci si connette tramite il server Gateway Desktop remoto, selezionare la casella di controllo Attiva timeout di inattività. Nella casella Disconnetti sessione se inattiva per immettere il tempo massimo, in minuti, durante il quale una sessione remota può rimanere inattiva prima che venga disconnessa.

    • Per specificare le impostazioni di timeout per la sessione per una sessione remota inattiva quando ci si connette tramite il server Gateway Desktop remoto, selezionare la casella di controllo Attiva timeout della sessione. Nella casella Timeout della sessione immettere il tempo, in minuti, per l'attivazione del timeout della sessione. Selezionare l'azione da eseguire dopo il timeout della sessione utente:

      • Per disconnettere la sessione remota, fare clic su Disconnetti sessione.

      • Per consentire alla sessione di continuare senza interruzioni, a meno che non siano state apportate modifiche al profilo utente, fare clic su Ripeti automaticamente l'autenticazione/autorizzazione della sessione.

  13. Fare clic su OK.

    I nuovi Criteri di autorizzazione connessioni Desktop remoto appena creati verranno visualizzati nel riquadro dei risultati di Gestione Gateway Desktop remoto. Quando si fa clic sul nome dei Criteri di autorizzazione connessioni Desktop remoto, i relativi dettagli vengono visualizzati nel riquadro inferiore.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Attivare o disattivare criteri di autorizzazione connessioni Desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare o disattivare i criteri di autorizzazione connessioni Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle connessioni.

  4. Nell'elenco dei Criteri di autorizzazione connessioni Desktop remoto nel riquadro dei risultati fare clic con il pulsante destro del mouse sui Criteri di autorizzazione connessioni Desktop remoto che si desidera attivare o disattivare e quindi fare clic su Attiva o Disattiva.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Visualizzare i dettagli sui criteri di autorizzazione connessioni Desktop remoto

È possibile utilizzare Gestione Gateway Desktop remoto per visualizzare i dettagli relativi ai Criteri di autorizzazione connessioni Desktop remoto locali, inclusi i requisiti che gli utenti devono soddisfare per connettersi a un server Gateway Desktop remoto e un'indicazione del fatto che i Criteri di autorizzazione connessioni Desktop remoto siano attivati o disattivati.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare i dettagli sui criteri di autorizzazione connessioni Desktop remoto locali

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle connessioni.

  4. Nel riquadro dei risultati selezionare nell'elenco di Criteri di autorizzazione connessioni Desktop remoto locali i Criteri di autorizzazione connessioni Desktop remoto locali per i quali si desidera visualizzare i dettagli. I dettagli relativi ai Criteri di autorizzazione connessioni Desktop remoto locali selezionati verranno visualizzati nella sezione inferiore del riquadro dei risultati.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Modificare o rimuovere criteri di autorizzazione connessioni Desktop remoto locali

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per modificare o rimuovere criteri di autorizzazione connessioni Desktop remoto locali

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle connessioni.

  4. Eseguire una delle operazioni seguenti:

    • Per modificare i Criteri di autorizzazione connessioni Desktop remoto, nell'elenco disponibile nel riquadro dei risultati dei Criteri di autorizzazione connessioni Desktop remoto fare clic con il pulsante destro del mouse sui Criteri di autorizzazione connessioni Desktop remoto desiderati, scegliere Proprietà, modificare le impostazioni secondo le esigenze e quindi fare clic su OK.

    • Per rimuovere i Criteri di autorizzazione connessioni Desktop remoto, nell'elenco disponibile nel riquadro dei risultati dei Criteri di autorizzazione connessioni Desktop remoto fare clic con il pulsante destro del mouse sui Criteri di autorizzazione connessioni Desktop remoto desiderati e quindi scegliere Elimina.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Specificare un nuovo archivio centrale per i criteri di autorizzazione connessioni Desktop remoto

I Criteri di autorizzazione connessioni Desktop remoto consentono di specificare gli utenti autorizzati a connettersi a un server Gateway Desktop remoto. È possibile specificare un archivio locale per i Criteri di autorizzazione connessioni Desktop remoto, e in tal caso i Criteri di autorizzazione connessioni Desktop remoto sono archiviati nel server Gateway Desktop remoto, oppure un archivio centrale per i Criteri di autorizzazione connessioni Desktop remoto, e in tal caso i Criteri di autorizzazione connessioni Desktop remoto sono archiviati in un server centrale che esegue un Server dei criteri di rete, in precedenza noto come server RADIUS (Remote Authentication Dial-In User Service).

L'utilizzo di un server centrale che esegue un Server dei criteri di rete per Gateway Desktop remoto consente di centralizzare l'archiviazione, la gestione e la convalida dei Criteri di autorizzazione connessioni Desktop remoto.

Se si utilizza un archivio centrale per i Criteri di autorizzazione connessioni Desktop remoto, è necessario stabilire una connessione di rete dal server Gateway Desktop remoto al server che esegue il Server dei criteri di rete. A tale scopo, è necessario specificare un segreto condiviso.

Quando si crea e si utilizza un segreto condiviso, è necessario rispettare la stessa distinzione tra maiuscole e minuscole utilizzata per il segreto condiviso durante la configurazione del server Gateway Desktop remoto come client RADIUS nel server che esegue il Server dei criteri di rete.

È inoltre consigliabile eseguire le operazioni seguenti:

  • Generare segreti condivisi lunghi, formati da più di 22 caratteri, composti da una sequenza casuale di lettere, numeri e segni di punteggiatura.

  • Modificare spesso il segreto condiviso.

Importante

È inoltre necessario creare Criteri di autorizzazione risorse Desktop remoto, qualora non siano già stati creati.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare un nuovo archivio centrale per i criteri di autorizzazione connessioni Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle connessioni.

  4. Fare clic con il pulsante destro del mouse sulla cartella Criteri di autorizzazione delle connessioni e quindi scegliere Configura criteri di autorizzazione connessioni Desktop remoto archiviati centralmente.

  5. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto, fare clic su Server dei criteri di rete centrale nella scheda Archivio criteri di autorizzazione connessioni Desktop remoto, immettere il nome o l'indirizzo IP del server che esegue il Server dei criteri di rete che si desidera aggiungere e quindi fare clic su Aggiungi.

  6. Nella finestra di dialogo Segreto condiviso digitare il segreto desiderato nella casella Immettere un nuovo segreto condiviso.

  7. Fare clic su OK per chiudere la finestra di dialogo Segreto condiviso e quindi di nuovo su OK per chiudere la finestra di dialogo Proprietà per il server Gateway Desktop remoto.

    Il nuovo archivio centrale dei Criteri di autorizzazione connessioni Desktop remoto specificato verrà visualizzato nel riquadro dei risultati di Gestione Gateway Desktop remoto.

    Dopo avere specificato il nuovo archivio centrale dei Criteri di autorizzazione connessioni Desktop remoto, è inoltre necessario configurare le impostazioni e i criteri opportuni nel server centrale che esegue il Server dei criteri di rete. Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Specificare un archivio locale o centrale esistente per i criteri di autorizzazione connessioni Desktop remoto

I Criteri di autorizzazione connessioni Desktop remoto consentono di specificare gli utenti autorizzati a connettersi a un server Gateway Desktop remoto. È possibile specificare un archivio locale per i Criteri di autorizzazione connessioni Desktop remoto, e in tal caso i Criteri di autorizzazione connessioni Desktop remoto sono archiviati nel server Gateway Desktop remoto, oppure un archivio centrale per i Criteri di autorizzazione connessioni Desktop remoto, e in tal caso i Criteri di autorizzazione connessioni Desktop remoto sono archiviati in un server centrale che esegue un Server dei criteri di rete, in precedenza noto come server RADIUS (Remote Authentication Dial-In User Service).

In questa procedura viene descritto come specificare un archivio esistente, locale o centrale, per i Criteri di autorizzazione connessioni Desktop remoto. In alternativa, è possibile creare un nuovo archivio locale dei Criteri di autorizzazione connessioni Desktop remoto o specificare un nuovo archivio centrale dei Criteri di autorizzazione connessioni Desktop remoto. Per ulteriori informazioni, vedere Creare criteri di autorizzazione connessioni Desktop remoto o Specificare un nuovo archivio centrale per i criteri di autorizzazione connessioni Desktop remoto. I Criteri di autorizzazione connessioni Desktop remoto archiviati centralmente vengono archiviati in server che eseguono un Server dei criteri di rete.

Importante

È inoltre necessario creare Criteri di autorizzazione risorse Desktop remoto, qualora non siano già stati creati.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare un archivio esistente, locale o centrale, per i criteri di autorizzazione connessioni Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto, nella scheda Archivio criteri di autorizzazione connessioni Desktop remoto eseguire una delle operazioni seguenti:

    • Per specificare un archivio locale per i Criteri di autorizzazione connessioni Desktop remoto, fare clic su Server dei criteri di rete locale e quindi su OK.

    • Per specificare un archivio centrale per i Criteri di autorizzazione connessioni Desktop remoto, fare clic su Server dei criteri di rete centrale, specificare il nome del server che esegue il Server dei criteri di rete desiderato e quindi fare clic su OK.

      Dopo avere specificato un archivio centrale per i Criteri di autorizzazione connessioni Desktop remoto, è inoltre necessario configurare le impostazioni e i criteri necessari nel server centrale che esegue il Server dei criteri di rete. Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Ulteriori considerazioni

È possibile rimuovere o modificare il segreto condiviso per un archivio centrale dei Criteri di autorizzazione connessioni Desktop remoto. Per informazioni, vedere Rimuovere un server che esegue il Server dei criteri di rete o modificare un segreto condiviso del server per i criteri di autorizzazione connessioni Desktop remoto archiviati centralmente.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Rimuovere un server che esegue il Server dei criteri di rete o modificare un segreto condiviso del server per i criteri di autorizzazione connessioni Desktop remoto archiviati centralmente

Se si modifica il segreto condiviso per un server che esegue il Server dei criteri di rete in cui sono archiviati centralmente i Criteri di autorizzazione connessioni Desktop remoto, tenere presente che è necessario rispettare la stessa distinzione tra maiuscole e minuscole che è stata utilizzata per il segreto condiviso specificato durante la configurazione del server Gateway Desktop remoto come client RADIUS nel server centrale che esegue il Server dei criteri di rete.

È inoltre consigliabile eseguire le operazioni seguenti:

  • Generare segreti condivisi lunghi, formati da più di 22 caratteri, composti da una sequenza casuale di lettere, numeri e segni di punteggiatura.

  • Modificare spesso il segreto condiviso.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per rimuovere un server che esegue il Server dei criteri di rete o modificare il segreto condiviso per un server che esegue il Server dei criteri di rete per i criteri di autorizzazione connessioni Desktop remoto archiviati centralmente

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Server dei criteri di rete centrale.

  4. Nell'elenco di Server dei criteri di rete centrali disponibile nel riquadro dei risultati fare clic sul nome del server che esegue il Server dei criteri di rete che si desidera rimuovere o per il quale si desidera modificare il segreto condiviso.

  5. Scegliere Configura criteri di autorizzazione connessioni Desktop remoto archiviati centralmente dal menu Azione.

  6. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto, nella scheda Archivio criteri di autorizzazione connessioni Desktop remoto eseguire una delle operazioni seguenti:

    • Per rimuovere un server che esegue il Server dei criteri di rete, fare clic sul nome del server da rimuovere e quindi scegliere Rimuovi Server dei criteri di rete.

      Se è specificato un solo server che esegue il Server dei criteri di rete e lo si rimuove dall'elenco, è necessario aggiungerne un altro all'elenco se si intende utilizzare Criteri di autorizzazione connessioni Desktop remoto archiviati centralmente.

    • Per modificare il segreto condiviso per un server che esegue il Server dei criteri di rete, fare clic sul nome del server per il quale si desidera modificare il segreto condiviso e quindi su Modifica segreto condiviso. Nella finestra di dialogo Segreto condiviso digitare un nuovo segreto condiviso nella casella Immettere un nuovo segreto condiviso e quindi fare clic su OK.

  7. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server Gateway Desktop remoto.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Gestire i criteri di autorizzazione risorse Desktop remoto

In questa sezione vengono illustrate le procedure per la gestione dei Criteri di autorizzazione risorse Desktop remoto che consentono di specificare le risorse di rete interne (computer) a cui gli utenti remoti possono connettersi tramite un server Gateway Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Creare criteri di autorizzazione risorse Desktop remoto

  • Specificare i computer ai quali gli utenti possono connettersi tramite Gateway Desktop remoto

  • Attivare o disattivare criteri di autorizzazione risorse Desktop remoto

  • Visualizzare i dettagli sui criteri di autorizzazione risorse Desktop remoto

  • Modificare o rimuovere un gruppo di computer gestito da Gateway Desktop remoto

  • Modificare o rimuovere criteri di autorizzazione risorse Desktop remoto


Creare criteri di autorizzazione risorse Desktop remoto

I Criteri di autorizzazione risorse Desktop remoto consentono di specificare le risorse di rete interne (computer) alle quali gli utenti remoti possono connettersi tramite un server Gateway Desktop remoto.

Gli utenti remoti che si connettono alla rete tramite un server Gateway Desktop remoto sono autorizzati ad accedere ai computer della rete interna se soddisfano le condizioni specificate in almeno uno dei Criteri di autorizzazione connessioni Desktop remoto e uno dei Criteri di autorizzazione risorse Desktop remoto.

Nota

Quando si associa un gruppo di computer gestito da Gateway Desktop remoto a Criteri di autorizzazione risorse Desktop remoto, è possibile supportare sia i nomi di dominio completi sia i nomi NetBIOS aggiungendo entrambi i nomi separatamente al gruppo di computer gestito da Gateway Desktop remoto. Quando si associa un gruppo di sicurezza di Active Directory o una server farm Host sessione Desktop remoto a Criteri di autorizzazione risorse Desktop remoto, i nomi di dominio completi e i nomi NetBIOS sono entrambi supportati automaticamente se il computer della rete interna a cui il client si connette appartiene allo stesso dominio del server Gateway Desktop remoto. Se il computer della rete interna appartiene a un dominio diverso rispetto al server Gateway Desktop remoto, gli utenti devono specificare il nome di dominio completo del computer della rete interna.

In questa procedura viene descritto come utilizzare Gestione Gateway Desktop remoto per creare Criteri di autorizzazione risorse Desktop remoto personalizzati. In alternativa, è possibile utilizzare la Configurazione guidata criteri di autorizzazione per creare rapidamente Criteri di autorizzazione connessioni Desktop remoto e Criteri di autorizzazione risorse Desktop remoto per Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare criteri di autorizzazione risorse Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle risorse.

  4. Nell'albero della console fare clic con il pulsante destro del mouse sulla cartella Criteri di autorizzazione delle risorse, scegliere Crea nuovo criterio e quindi fare clic su Personalizzato.

  5. Nella scheda Generale della finestra di dialogo Nuovo criterio di autorizzazione risorse Desktop remoto immettere un nome non più lungo di 64 caratteri nella casella Nome criterio.

  6. Nella scheda Descrizione immettere una descrizione per i nuovi Criteri di autorizzazione risorse Desktop remoto e quindi verificare che la casella di controllo Attiva criterio sia selezionata.

  7. Nella scheda Gruppi di utenti fare clic su Aggiungi per selezionare i gruppi di utenti a cui si desidera applicare i Criteri di autorizzazione risorse Desktop remoto.

  8. Nella finestra di dialogo Seleziona gruppi specificare il nome e il percorso del gruppo di utenti e quindi fare clic su OK. Per specificare più gruppi di utenti, eseguire una delle operazioni seguenti:

    • Digitare il nome di ogni gruppo di utenti, separandolo dagli altri nomi con un punto e virgola.

    • Per aggiungere altri gruppi da domini diversi, ripetere il passaggio 7 per ogni gruppo.

  9. Nella scheda Risorsa di rete specificare il gruppo di computer al quale gli utenti possono connettersi tramite Gateway Desktop remoto. Per informazioni su come creare gruppi di computer per Gateway Desktop remoto, vedere Specificare i computer ai quali gli utenti possono connettersi tramite Gateway Desktop remoto.

  10. Nella scheda Porte consentite specificare la porta che i client di Servizi Desktop remoto potranno utilizzare per connettersi ai computer tramite Gateway Desktop remoto eseguendo una delle operazioni seguenti:

    • Per consentire ai client di utilizzare solo la porta TCP 3389, fare clic su Consenti connessioni solo tramite la porta TCP 3389. Questa è l'opzione predefinita.

    • Per specificare più porte a disposizione dei client per la connessione, fare clic su Consenti connessioni tramite le porte seguenti e quindi digitare il numero di porta. Se si specificano più porte, digitare il numero di ogni porta separandolo dagli altri con un punto e virgola.

    • Per consentire ai client di connettersi tramite tutte le porte, fare clic su Consenti connessioni tramite qualsiasi porta.

  11. Fare clic su OK per chiudere la finestra di dialogo Nuovo criterio di autorizzazione risorse Desktop remoto.

    I nuovi Criteri di autorizzazione risorse Desktop remoto appena creati verranno visualizzati nel riquadro dei risultati di Gestione Gateway Desktop remoto. Quando si fa clic sul nome dei Criteri di autorizzazione risorse Desktop remoto, i relativi dettagli vengono visualizzati nel riquadro inferiore.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione risorse Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Specificare i computer ai quali gli utenti possono connettersi tramite Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Specificare i computer ai quali gli utenti possono connettersi tramite Gateway Desktop remoto

Tramite Gateway Desktop remoto gli utenti remoti possono connettersi alle risorse di rete interne in un gruppo di sicurezza esistente, in un gruppo di computer gestito da Gateway Desktop remoto o in una farm di server Host sessione Desktop remoto.

I gruppi possono essere i seguenti:

  • Un gruppo di risorse di rete di Servizi di dominio Active Directory esistente.

  • Un gruppo di computer esistente gestito da Gateway Desktop remoto o un nuovo gruppo di computer gestito da Gateway Desktop remoto.

    Importante

    Se gli utenti si connettono ai membri di una server farm utilizzando Broker di sessione di Servizi terminal in esecuzione in Windows Server 2008, è necessario selezionare questa opzione. È necessario specificare nel gruppo di computer il nome della farm e il nome di ogni membro.

  • Qualunque risorsa di rete.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare i computer ai quali gli utenti possono connettersi tramite Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle risorse.

  4. Con la cartella Criteri di autorizzazione delle risorse selezionata, fare clic con il pulsante destro del mouse sui Criteri di autorizzazione risorse Desktop remoto per i quali si desidera specificare un gruppo di computer e quindi scegliere Proprietà.

  5. Nella scheda Risorsa di rete specificare il gruppo di computer a cui gli utenti possono connettersi tramite Gateway Desktop remoto, eseguendo una delle operazioni seguenti:

    • Per specificare un gruppo di risorse di rete di Servizi di dominio Active Directory esistente, fare clic su Seleziona un gruppo di risorse di rete di Servizi di dominio Active Directory. Questa è l'opzione predefinita.

      1. Fare clic su Sfoglia.

      2. Nella finestra di dialogo Seleziona gruppo specificare il nome e il percorso del gruppo di utenti e quindi fare clic su OK.

    • Per specificare un gruppo di computer gestito da Gateway Desktop remoto, fare clic su Seleziona un gruppo gestito da Gateway Desktop remoto esistente oppure creane uno nuovo e quindi scegliere Sfoglia. Nella finestra di dialogo Seleziona gruppo di computer gestito da Gateway Desktop remoto eseguire una delle operazioni seguenti:

      • Selezionare un gruppo di computer esistente gestito da Gateway Desktop remoto facendo clic sul nome del gruppo che si desidera utilizzare e quindi su OK.

      • Creare un nuovo gruppo di computer gestito da Gateway Desktop remoto facendo clic su Crea nuovo gruppo.

        1. Nella finestra di dialogo Nuovo gruppo di computer gestito dal Gateway Desktop remoto immettere nella casella Nome della scheda Generale un nome per il nuovo gruppo di computer gestito da Gateway Desktop remoto. Nella casella Descrizione digitare una descrizione.

        2. Nella scheda Risorse di rete digitare il nome o l'indirizzo IP del computer o della farm Desktop remoto che si desidera aggiungere e quindi scegliere Aggiungi. Ripetere questo passaggio il numero di volte necessario per specificare ulteriori computer e quindi fare clic su OK per chiudere la finestra di dialogo Nuovo gruppo di computer gestito dal Gateway Desktop remoto.

        3. Nella finestra di dialogo Seleziona gruppo di computer gestito da Gateway Desktop remoto fare clic sul nome del nuovo gruppo di computer e quindi su OK.

        Importante

        Quando si aggiunge un computer della rete aziendale interna all'elenco dei computer gestiti da Gateway Desktop remoto, tenere presente che per consentire agli utenti remoti di connettersi al computer specificando il nome o l'indirizzo IP del computer, è necessario aggiungere tale computer al gruppo di computer due volte: prima specificando il nome del computer e aggiungendolo al gruppo di computer e quindi specificando l'indirizzo IP del computer e aggiungendolo di nuovo al gruppo di computer. Se si specifica solo l'indirizzo IP quando si aggiunge un computer a un gruppo di computer, anche gli utenti dovranno specificare l'indirizzo IP di tale computer per potersi connettere a tale risorsa tramite Gateway Desktop remoto. Per assicurarsi che gli utenti remoti possano connettersi ai computer della rete aziendale interna desiderati, non è consigliabile specificare gli indirizzi IP dei computer se non sono configurati indirizzi IP statici. Ad esempio, non è consigliabile specificare gli indirizzi IP se nella propria organizzazione viene utilizzato il protocollo DHCP per la riconfigurazione dinamica degli indirizzi IP dei computer.

    • Per specificare qualunque risorsa di rete, selezionare Consenti agli utenti di connettersi a qualsiasi risorsa di rete e quindi fare clic su OK.

Ulteriori riferimenti

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Creare criteri di autorizzazione risorse Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Attivare o disattivare criteri di autorizzazione risorse Desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare o disattivare i criteri di autorizzazione risorse Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle risorse.

  4. Nell'elenco dei Criteri di autorizzazione risorse Desktop remoto nel riquadro dei risultati fare clic con il pulsante destro del mouse sui Criteri di autorizzazione risorse Desktop remoto che si desidera attivare o disattivare e quindi fare clic su Attiva o Disattiva.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione risorse Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Visualizzare i dettagli sui criteri di autorizzazione risorse Desktop remoto

È possibile utilizzare Gestione Gateway Desktop remoto per visualizzare i dettagli sui Criteri di autorizzazione risorse Desktop remoto, inclusi i nomi dei gruppi di sicurezza o dei gruppi di computer e di utenti gestiti da Gateway Desktop remoto associati ai Criteri di autorizzazione risorse Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare i dettagli sui criteri di autorizzazione risorse Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle risorse.

  4. Nel riquadro dei risultati selezionare nell'elenco di Criteri di autorizzazione risorse Desktop remoto i Criteri di autorizzazione risorse Desktop remoto per i quali si desidera visualizzare i dettagli. I dettagli relativi ai Criteri di autorizzazione risorse Desktop remoto selezionati verranno visualizzati nella sezione inferiore del riquadro dei risultati.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione risorse Desktop remoto


Modificare o rimuovere un gruppo di computer gestito da Gateway Desktop remoto

È possibile utilizzare Gestione Gateway Desktop remoto per rimuovere un gruppo di computer gestito da Gateway Desktop remoto.

Se si associa un gruppo di computer gestito da Gateway Desktop remoto a più Criteri di autorizzazione risorse Desktop remoto e successivamente si modifica o si elimina tale gruppo di computer gestito da Gateway Desktop remoto, tutti i Criteri di autorizzazione risorse Desktop remoto associati al gruppo saranno interessati dall'operazione.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per modificare o rimuovere un gruppo di computer gestito da Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console selezionare il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle risorse.

  4. Fare clic con il pulsante destro del mouse sulla cartella Criteri di autorizzazione delle risorse e quindi scegliere Gestisci gruppi di computer locali.

  5. Nella finestra di dialogo Gestisci gruppi di computer archiviati localmente eseguire una delle operazioni seguenti:

    • Per modificare un gruppo di computer gestito da Gateway Desktop remoto, fare clic sul gruppo da modificare nell'elenco, quindi su Proprietà e quindi modificare le impostazioni desiderate.

    • Per eliminare un gruppo di computer gestito da Gateway Desktop remoto, fare clic sul gruppo da eliminare e quindi su Rimuovi.

    • Per specificare un nuovo gruppo di computer gestito da Gateway Desktop remoto, fare clic su Crea gruppo e quindi seguire la procedura descritta in Specificare i computer ai quali gli utenti possono connettersi tramite Gateway Desktop remoto.

  6. Fare clic su OK.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione risorse Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Specificare i computer ai quali gli utenti possono connettersi tramite Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Modificare o rimuovere criteri di autorizzazione risorse Desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per modificare o rimuovere criteri di autorizzazione risorse Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle risorse.

  4. Nel riquadro dei risultati selezionare nell'elenco di Criteri di autorizzazione risorse Desktop remoto i Criteri di autorizzazione risorse Desktop remoto che si desidera modificare o rimuovere.

  5. Con il nome dei Criteri di autorizzazione risorse Desktop remoto selezionato, eseguire una delle operazioni seguenti:

    • Per modificare i Criteri di autorizzazione risorse Desktop remoto, fare clic con il pulsante destro del mouse sui Criteri di autorizzazione risorse Desktop remoto, scegliere Proprietà, modificare le impostazioni secondo le esigenze e quindi fare clic su OK.

    • Per rimuovere i Criteri di autorizzazione risorse Desktop remoto, fare clic con il pulsante destro del mouse sui Criteri di autorizzazione risorse Desktop remoto e quindi fare clic su Elimina. Quando viene richiesto di confermare l'eliminazione dei Criteri di autorizzazione risorse Desktop remoto, fare clic su Sì.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione risorse Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Attivare il bridging SSL nel server Gateway Desktop remoto

Per migliorare la sicurezza per un server Gateway Desktop remoto, è possibile configurare Microsoft Internet Security and Acceleration (ISA) Server o un prodotto non Microsoft in modo che funzioni come dispositivo di bridging SSL (Secure Sockets Layer). Il dispositivo di bridging SSL può migliorare la sicurezza chiudendo le sessioni SSL, ispezionando i pacchetti e ristabilendo le sessioni SSL.

È possibile configurare la comunicazione di ISA Server con il server Gateway Desktop remoto in uno dei due modi seguenti:

  • Bridging HTTPS-HTTPS. In questa configurazione il client Gateway Desktop remoto invia una richiesta SSL (HTTPS) al dispositivo di bridging SSL. Il dispositivo di bridging SSL invia una nuova richiesta HTTPS al server Gateway Desktop remoto per una sicurezza massima.

  • Bridging HTTPS-HTTP. In questa configurazione il client Gateway Desktop remoto invia una richiesta SSL (HTTPS) al dispositivo di bridging SSL. Il dispositivo di bridging SSL invia una nuova richiesta HTTP al server Gateway Desktop remoto.

Per utilizzare il bridging HTTPS-HTTPS o HTTPS-HTTP, è necessario attivare l'impostazione Usa bridging SSL nel server Gateway Desktop remoto, come descritto in questa procedura.

Importante

Per utilizzare un dispositivo di bridging SSL con Gateway Desktop remoto, è inoltre necessario attivare la terminazione SSL esterna sul dispositivo di bridging SSL che si intende utilizzare, nonché configurarlo per la connessione al server Gateway Desktop remoto. Per istruzioni dettagliate sulla configurazione di ISA Server per l'utilizzo come dispositivo di bridging SSL esterno per Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto in TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=140433).

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare il bridging HTTPS-HTTP nel server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto, nella scheda Bridging SSL selezionare la casella di controllo Usa bridging SSL, fare clic su Usa bridging HTTPS-HTTP (termina richieste SSL e avvia nuove richieste HTTP) e quindi su OK.

  4. Nella finestra di dialogo Gateway Desktop remoto selezionare una delle opzioni seguenti:

    • Per duplicare il pool di applicazione predefinito subito, fare clic su Sì.

      Attenzione

      Per applicare le impostazioni di bridging SSL, è necessario riciclare il pool di applicazioni di IIS predefinito. Se si sceglie di riciclare il pool di applicazioni di IIS che include Gateway Desktop remoto, verranno disconnesse tutte le connessioni attive di tutte le applicazioni incluse in questo pool.

    • Per duplicare il pool di applicazione predefinito in seguito, fare clic su No.

    Se si utilizza ISA Server come dispositivo di bridging SSL esterno per Gateway Desktop remoto, per ulteriori informazioni vedere la pagina relativa a Servizi Desktop remoto in TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=140433).
Per attivare il bridging HTTPS-HTTPS nel server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto, nella scheda Bridging SSL selezionare la casella di controllo Usa bridging SSL, fare clic su Usa bridging HTTPS-HTTPS (termina richieste SSL e avvia nuove richieste HTTPS) e quindi su OK.

  4. Nella finestra di dialogo Gateway Desktop remoto selezionare una delle opzioni seguenti:

    • Per riciclare il pool di applicazioni predefinito subito, fare clic su Sì.

      Attenzione

      Per applicare le impostazioni di bridging SSL, è necessario riciclare il pool di applicazioni di IIS predefinito. Se si sceglie di riciclare il pool di applicazioni di IIS che include Gateway Desktop remoto, verranno disconnesse tutte le connessioni attive di tutte le applicazioni incluse in questo pool.

    • Per riciclare il pool di applicazioni predefinito in seguito, fare clic su No.

    Se si utilizza ISA Server come dispositivo di bridging SSL esterno per Gateway Desktop remoto, per ulteriori informazioni vedere la pagina relativa a Servizi Desktop remoto in TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=140433).

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Attivare la verifica dei criteri di integrità Protezione accesso alla rete nel server Gateway Desktop remoto

Per migliorare la sicurezza, è possibile configurare Protezione accesso alla rete nei server e nei client di Gateway Desktop remoto. Protezione accesso alla rete è una tecnologia di creazione, applicazione, monitoraggio e aggiornamento dei criteri di integrità inclusa in Windows Server 2008 R2, Windows Server 2008, Windows 7, Microsoft Windows Vista e Windows XP Service Pack 3. Con Protezione accesso alla rete gli amministratori di sistema possono imporre requisiti di integrità nei client di Servizi Desktop remoto che si connettono al server Gateway Desktop remoto, che possono includere l'attivazione di firewall, requisiti relativi agli aggiornamenti per la sicurezza, configurazioni obbligatorie per il computer e altre impostazioni.

Protezione accesso alla rete consente inoltre di verificare se i client di Servizi Desktop remoto soddisfano i requisiti dei criteri di integrità dell'organizzazione prima di autorizzare tali client a connettersi ai computer della rete aziendale tramite i server Gateway Desktop remoto.

Nota

I computer che eseguono Windows Server 2008 R2 e Windows Server 2008 non possono essere utilizzati come client di Protezione accesso alla rete. Solo i computer che eseguono Windows 7, Microsoft Windows Vista e Windows XP Service Pack 3 possono essere utilizzati come client di Protezione accesso alla rete.

Per attivare la verifica dei criteri di integrità di Protezione accesso alla rete nel server Gateway Desktop remoto, è necessario attivare un'impostazione nel server per richiedere al client di Servizi Desktop remoto di inviare un rapporto di integrità.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare la verifica dei criteri di integrità di Protezione accesso alla rete nel server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto verificare, nella scheda Archivio criteri di autorizzazione connessioni Desktop remoto, che la casella di controllo Richiedi ai client di inviare un rapporto di integrità sia selezionata e quindi fare clic su OK.

    Verificare di aver configurato correttamente i client di Servizi Desktop remoto, il server Gateway Desktop remoto e il server che esegue il Server dei criteri di rete. Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Limitare il numero massimo di connessioni simultanee consentite tramite un server Gateway Desktop remoto

Con la sola eccezione dei server Gateway Desktop remoto eseguiti in Windows Server 2008 R2 Standard, per impostazione predefinita non viene fissato nessun limite al numero di connessioni simultanee che i client di Servizi Desktop remoto possono effettuare alle risorse di rete interne (computer) tramite un server Gateway Desktop remoto. È tuttavia possibile ottimizzare le prestazioni del server Gateway Desktop remoto impostando un limite per il numero di connessioni simultanee alle risorse di rete interne che i client possono effettuare tramite un server Gateway Desktop remoto.

Nota

Per i server Gateway Desktop remoto eseguiti in Windows Server 2008 R2 Standard, il numero massimo di connessioni simultanee supportate è 250.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per limitare il numero massimo di connessioni simultanee consentite tramite un server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto, in Numero massimo connessioni nella scheda Generale eseguire una delle operazioni seguenti:

    • Per impostare un limite per il numero massimo di connessioni simultanee alle risorse interne che i client di Servizi Desktop remoto possono effettuare tramite Gateway Desktop remoto, fare clic su Limita numero massimo di connessioni simultanee a e quindi specificare il numero di connessioni consentite.

    • Per non impostare nessun limite per il numero di connessioni consentite tra i client e le risorse di rete interne tramite Gateway Desktop remoto, fare clic su Consenti massimo numero di connessioni simultanee supportato. Questa è l'opzione predefinita.

      Nota

      Per i server Gateway Desktop remoto eseguiti in Windows Server 2008 R2 Standard, il numero massimo di connessioni simultanee supportate è 250.

    • Per impedire che vengano stabilite nuove connessioni tra i client e le risorse di rete tramite Gateway Desktop remoto, fare clic su Non consentire nuove connessioni. Se si seleziona questa opzione, saranno respinti soltanto i nuovi tentativi di connessione, mentre le connessioni in corso non saranno interrotte da Gateway Desktop remoto.

  4. Fare clic su OK.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Importare o esportare le impostazioni per un server Gateway Desktop remoto

Per semplificare l'amministrazione e la configurazione di più server Gateway Desktop remoto, è possibile utilizzare Gestione Gateway Desktop remoto per importare o esportare i criteri e le impostazioni di configurazione per un server Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per importare o esportare le impostazioni per un server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi eseguire una delle operazioni seguenti:

    • Per esportare le impostazioni per il server Gateway Desktop remoto, fare clic su Esporta criteri e impostazioni di configurazione.

      1. Nella finestra di dialogo Esporta criteri e impostazioni di configurazione immettere nella casella Specificare il nome del file un nome per il file e nella casella Percorso un percorso per il file.

      2. Fare clic su OK.

        Nota

        Se la directory specificata non esiste ancora o se esiste un altro file con lo stesso nome, verranno visualizzati i messaggi appropriati per confermare che si intende creare la directory o sovrascrivere il file esistente.

      3. Nella finestra di dialogo Gateway Desktop remoto fare clic su OK.

    • Per importare le impostazioni per un server Gateway Desktop remoto, fare clic su Importa criteri e impostazioni di configurazione.

      1. Nella finestra di dialogo Importa criteri e impostazioni di configurazione immettere nella casella Specificare il file da importare un nome e un percorso per il file che si desidera importare.

      2. Fare clic su OK.

        Avvertenza

        Importando il file, i criteri e le impostazioni di configurazione esistenti per il server Gateway Desktop remoto verranno sovrascritte.

      3. Nella finestra di dialogo Gateway Desktop remoto fare clic su Sì. Un messaggio di Gateway Desktop remoto indicherà che è in corso l'importazione.

      4. Nella finestra di dialogo Gateway Desktop remoto fare clic su OK.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Configurare la messaggistica per un server Gateway Desktop remoto

In questa procedura viene descritto come creare e attivare un messaggio di sistema o di accesso per un server Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare la messaggistica in Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà per il server Gateway Desktop remoto, nella scheda Messaggistica specificare le impostazioni seguenti per i messaggi:

    • Per impostare un messaggio di sistema:

      1. Selezionare la casella di controllo Attiva messaggio di sistema.

      2. Nella casella sotto Attiva messaggio di sistema digitare il messaggio amministrativo che si desidera venga visualizzato dagli utenti.

      3. Selezionare data e ora per il messaggio amministrativo da visualizzare utilizzando gli elenchi Ora di inizio e Ora di fine.

      4. Per visualizzare il messaggio prima di attivarlo, fare clic su Anteprima. Verificare il messaggio e quindi fare clic su OK.

    • Per impostare un messaggio di accesso:

      1. Per visualizzare un messaggio di accesso per gli utenti, è innanzitutto necessario creare e salvare il testo da visualizzare in un file di testo distinto.

      2. Selezionare la casella di controllo Attiva messaggio di accesso.

      3. In Attiva messaggio di accesso fare clic su Sfoglia. Nella finestra di dialogo Apri selezionare il file che si desidera venga visualizzato dagli utenti e quindi fare clic su Apri.

      4. Per visualizzare il messaggio prima di attivarlo, fare clic su Anteprima. Verificare il messaggio e quindi fare clic su OK.

  4. Per limitare le connessioni al client di Connessione desktop remoto 7.0, selezionare la casella di controllo Consenti solo connessioni da client di Servizi Desktop remoto che supportano la messaggistica Gateway Desktop remoto.

  5. Fare clic su OK.

Ulteriori riferimenti

  • Configurare il server Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Configurare il client di Servizi Desktop remoto per Gateway Desktop remoto

In questa sezione vengono illustrate le procedure per configurare i client di Servizi Desktop remoto in modo che possano connettersi alle risorse di rete interne (computer) tramite Gateway Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Installare il certificato radice del server Gateway Desktop remoto nel client di Servizi Desktop remoto

  • Configurare le impostazioni di Connessione desktop remoto per Gateway Desktop remoto


Installare il certificato radice del server Gateway Desktop remoto nel client di Servizi Desktop remoto

Il computer client di Servizi Desktop remoto deve verificare l'identità del server Gateway Desktop remoto e ritenerla attendibile affinché il client possa inviare in modo protetto le credenziali di accesso e la password dell'utente e completare il processo di autenticazione. Per stabilire una relazione di trust, è necessario che i client ritengano attendibile la radice del certificato del server. In altre parole, è necessario che il certificato dell'Autorità di certificazione (CA) che ha rilasciato il certificato del server sia installato nell'archivio Autorità di certificazione radice attendibili dei client. È possibile visualizzare tale archivio utilizzando lo snap-in Certificati.

Come anticipato, questa procedura non è necessaria se:

  • Nel server Gateway Desktop remoto è installato un certificato rilasciato da una delle autorità di certificazione (CA) pubbliche attendibili che partecipano al programma Microsoft Root Certificate (vedere l'elenco nell'articolo 931125 della Microsoft Knowledge Base, all'indirizzo http://go.microsoft.com/fwlink?LinkID=59547).

  • Il computer client di Servizi Desktop remoto ha già stabilito una relazione di trust con l'Autorità di certificazione (CA) di rilascio.

Per ulteriori informazioni, vedere Ottenere un certificato per il server Gateway Desktop remoto.

Se il server Gateway Desktop remoto utilizza un certificato che è stato rilasciato da una delle CA pubbliche attendibili e il certificato è riconosciuto e ritenuto attendibile dal computer client, completare la procedura descritta in Configurare le impostazioni di Connessione desktop remoto per Gateway Desktop remoto.

Note
  • Se il client di Servizi Desktop remoto viene configurato per l'utilizzo con Protezione accesso alla rete, è necessario installare il certificato radice del server Gateway Desktop remoto utilizzando l'account computer. In caso contrario, è possibile installare il certificato radice del server Gateway Desktop remoto utilizzando l'account utente.
  • Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Users o al gruppo Administrators locale oppure a un gruppo equivalente. Per aprire lo snap-in Certificati per un account computer, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel client di Servizi Desktop remoto in cui si intende installare il certificato. Per aprire lo snap-in Certificati per un account utente, è sufficiente l'appartenenza al gruppo Users nel client. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare il certificato radice del server Gateway Desktop remoto nel client di Servizi Desktop remoto

  1. Aprire la console snap-in Certificati. Se la console snap-in Certificati non è stata ancora aggiunta, è possibile farlo eseguendo le operazioni seguenti:

    1. Fare clic sul pulsante Start, scegliere Esegui, digitare mmc e quindi fare clic su OK.

    2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

    3. Nella finestra di dialogo Aggiungi o rimuovi snap-in, nell'elenco Snap-in disponibili, selezionare Certificati e quindi fare clic su Aggiungi.

    4. Nella finestra di dialogo Snap-in certificati eseguire una delle operazioni seguenti:

      • Per aprire lo snap-in per un account computer, fare clic su Computer account e quindi su Avanti. Nella finestra di dialogo Seleziona computer fare clic su Computer locale (il computer su cui è in esecuzione questa console) e quindi su Fine.

      • Per aprire lo snap-in per un account utente, fare clic su Account dell'utente e quindi su Fine.

    5. Nella finestra di dialogo Aggiungi o rimuovi snap-in fare clic su OK.

  2. Nell'albero della console snap-in Certificati espandere Certificati (computer locale) e quindi Autorità di certificazione radice attendibili, fare clic con il pulsante destro del mouse su Certificati, scegliere Tutte le attività e infine fare clic su Importa.

  3. Nella pagina iniziale dell'Importazione guidata certificati fare clic su Avanti.

  4. Nella pagina File da importare specificare il nome del certificato radice del server Gateway Desktop remoto nella casella Nome file e quindi fare clic su Avanti.

  5. Nella pagina Archivio certificati accettare l'opzione predefinita Colloca tutti i certificati nel seguente archivio (nell'archivio certificati Autorità di certificazione radice attendibili) e quindi fare clic su Avanti.

  6. Nella pagina Completamento dell'Importazione guidata certificati verificare che vengano visualizzate le impostazioni seguenti per il certificato:

    • Archivio certificati scelto dall'utente: Autorità di certificazione radice attendibili

    • Contenuto: Certificato

    • Nome file: PercorsoFile\<Root_Certificate_Name.cer>, dove <Root_Certificate_Name> è il nome del certificato radice del server Gateway Desktop remoto.

  7. Fare clic su Fine.

  8. Nella finestra di dialogo Importazione guidata certificati fare clic su OK.

  9. Dopo avere selezionato Certificati (computer locale)\Autorità di certificazione radice attendibili\Certificati nell'albero della console, verificare nel riquadro dei dettagli che il certificato radice del server Gateway Desktop remoto sia visualizzato nell'elenco dei certificati disponibili nel client.

Ulteriori riferimenti

  • Configurare il client di Servizi Desktop remoto per Gateway Desktop remoto

  • Ottenere un certificato per il server Gateway Desktop remoto


Configurare le impostazioni di Connessione desktop remoto per Gateway Desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni di Connessione desktop remoto per Gateway Desktop remoto

  1. Aprire il client di Connessione desktop remoto. Per aprire il client di Connessione desktop remoto, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Connessione desktop remoto.

  2. Nella finestra di dialogo Connessione desktop remoto fare clic su Opzioni per espandere la finestra di dialogo e visualizzare le impostazioni.

  3. Nella scheda Avanzate fare clic su Impostazioni in Connessione da postazioni remote.

  4. Nella finestra di dialogo Impostazioni server Gateway Desktop remoto selezionare le opzioni appropriate:

    • Rileva automaticamente impostazioni del server Gateway Desktop remoto(opzione predefinita). Se si seleziona questa opzione, il client di Servizi Desktop remoto tenterà di utilizzare le impostazioni di Criteri di gruppo che determinano il comportamento delle connessioni dei client ai server Gateway Desktop remoto o alle server farm Gateway Desktop remoto, purché tali impostazioni siano state configurate e attivate. Per ulteriori informazioni, vedere Utilizzare Criteri di gruppo per gestire le connessioni client tramite Gateway Desktop remoto.

    • Usa le seguenti impostazioni del server Gateway Desktop remoto. Se tramite Criteri di gruppo non sono già stati attivati e imposti il nome del server Gateway Desktop remoto o della server farm Gateway Desktop remoto e un metodo di accesso, è possibile selezionare questa opzione e specificare il nome del server Gateway Desktop remoto o della server farm Gateway Desktop remoto a cui connettersi, nonché il metodo di accesso da utilizzare per la connessione.

      Avvertenza

      Quando si specifica un nome per il server Gateway Desktop remoto o la server farm Gateway Desktop remoto, è necessario utilizzare un nome di dominio completo (FQDN).

      Ignora server Gateway Desktop remoto per indirizzi locali. Questa opzione è selezionata per impostazione predefinita.

      Se si desidera che il client di Servizi Desktop remoto rilevi automaticamente quando è richiesto l'utilizzo di Gateway Desktop remoto, selezionare questa casella di controllo. Se si utilizza un computer portatile, questa opzione consente di ottimizzare le prestazioni di connettività del client e ridurre al minimo la latenza, in quanto Gateway Desktop remoto verrà utilizzato solo quando necessario. Se il computer è sempre connesso alla rete locale (LAN) o se si trova all'interno di una rete protetta da firewall, Gateway Desktop remoto non verrà utilizzato. Se il computer è all'esterno e si connette alla rete interna tramite Internet, verrà utilizzato Gateway Desktop remoto.

      Nota

      Se il sistema si trova in una rete LAN ma si desidera verificare la connettività tramite un server Gateway Desktop remoto o una server farm Gateway Desktop remoto, deselezionare questa casella di controllo. Se questa casella di controllo è selezionata, il client si connetterà direttamente al server Host sessione Desktop remoto e non tramite il server Gateway Desktop remoto o la server farm Gateway Desktop remoto.

    • Non usare un server Gateway Desktop remoto. Selezionare questa opzione se il computer è sempre connesso alla rete LAN o se è all'interno di una rete protetta da firewall. Questa opzione deve essere selezionata solo se si è certi di non dover utilizzare Gateway Desktop remoto per attraversare un firewall.

  5. Eseguire una delle operazioni seguenti:

    • Per salvare le impostazioni e chiudere la finestra di dialogo Connessione desktop remoto, fare clic su Salva e quindi su Annulla. Le impostazioni verranno salvate come file RDP in un percorso predefinito. Per impostazione predefinita il file viene salvato in Unità:\<Username>\Documenti.

    • Per salvare il file RDP in un percorso specifico, in modo da poterlo personalizzare e distribuire a più client in seguito secondo le esigenze, fare clic su Salva con nome. Nella finestra di dialogo Salva con nome immettere il nome del file e il percorso in Nome file e quindi fare clic su Salva.

  6. Per proseguire con una connessione a una risorsa di rete interna, fare clic su Connetti e quindi immettere le credenziali quando richiesto.

Ulteriori riferimenti

  • Configurare il client di Servizi Desktop remoto per Gateway Desktop remoto


Utilizzare Criteri di gruppo per gestire le connessioni client tramite Gateway Desktop remoto

È possibile utilizzare Criteri di gruppo e Servizi di dominio Active Directory per centralizzare e semplificare l'amministrazione delle impostazioni dei criteri di Gateway Desktop remoto. È possibile utilizzare l'Editor Criteri di gruppo locali per configurare queste impostazioni, contenute negli oggetti Criteri di gruppo. La console Gestione Criteri di gruppo consente di collegare gli oggetti Criteri di gruppo a siti, domini o unità organizzative (OU) nei Servizi di dominio Active Directory.

L'Editor Criteri di gruppo locali funziona come un'estensione della console Gestione Criteri di gruppo. Quando si modifica un oggetto Criteri di gruppo dalla console Gestione Criteri di gruppo, viene visualizzato l'Editor Criteri di gruppo locali con le impostazioni dell'oggetto Criteri di gruppo selezionato. Per aprire un oggetto Criteri di gruppo nell'Editor Criteri di gruppo locali, è necessario disporre dei diritti di modifica su tale oggetto.

Gli oggetti Criteri di gruppo Criterio dominio predefinito e Criterio controller di dominio predefinito sono estremamente importanti per l'integrità di qualsiasi dominio. È consigliabile non modificare l'oggetto Criteri di gruppo Criterio controller di dominio predefinito o Criterio dominio predefinito, ad eccezione dei casi seguenti:

  • È necessario che le impostazioni dei criteri di account siano configurate nell'oggetto Criteri di gruppo Criterio dominio predefinito.

  • Se si installano applicazioni nei controller di dominio che richiedono modifiche alle impostazioni Diritti utente o Controllo, è necessario modificare le impostazioni nell'oggetto Criteri di gruppo Criterio controller di dominio predefinito.

È possibile applicare le impostazioni di Criteri di gruppo per le connessioni client di Servizi Desktop remoto tramite Gateway Desktop remoto in due modi: le impostazioni possono essere consigliate, ovvero attivate ma non imposte, oppure possono essere attivate e imposte.

Se si desidera suggerire l'impostazione di un criterio per Gateway Desktop remoto, attivare tale impostazione in Criteri di gruppo, ma non deselezionare la casella di controllo Consenti agli utenti di modificare questa impostazione. In questo modo, gli utenti del client potranno specificare impostazioni di connessione di Gateway Desktop remoto alternative. Per specificare impostazioni dei criteri alternative, gli utenti potranno selezionare l'opzione Usa le seguenti impostazioni del server Gateway Desktop remoto nella finestra di dialogo Impostazioni server Gateway Desktop remoto nel client e quindi dovranno specificare le impostazioni di connessione di Gateway Desktop remoto alternative.

Se si desidera imporre un'impostazione del criterio per Gateway Desktop remoto, attivare tale impostazione in Criteri di gruppo deselezionando la casella di controllo Consenti agli utenti di modificare questa impostazione. In questo modo, gli utenti non potranno modificare l'impostazione di connessione di Gateway Desktop remoto, neppure selezionando l'opzione Usa le seguenti impostazioni del server Gateway Desktop remoto nel client. Per informazioni su come configurare le impostazioni dei client di Servizi Desktop remoto, vedere Configurare il client di Servizi Desktop remoto per Gateway Desktop remoto.

In questa sezione vengono illustrate le procedure per l'utilizzo di Criteri di gruppo ai fini della gestione delle connessioni client di Servizi Desktop remoto alla rete tramite Gateway Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Impostare il metodo di autenticazione del server Gateway Desktop remoto

  • Attivare le connessioni tramite Gateway Desktop remoto

  • Impostare l'indirizzo del server Gateway Desktop remoto


Impostare il metodo di autenticazione del server Gateway Desktop remoto

In questa procedura viene descritto come utilizzare Console Gestione Criteri di gruppo per impostare un metodo di autenticazione per i client di Servizi Desktop remoto che si connettono alle risorse di rete interne (computer) tramite un server Gateway Desktop remoto.

Nota

Per gestire Criteri di gruppo in un controller di dominio basato su Windows Server 2008 R2, è innanzitutto necessario aggiungere la funzionalità Console Gestione Criteri di gruppo. A tale scopo, avviare Server Manager e quindi in Riepilogo funzionalità fare clic su Aggiungi funzionalità. Nella pagina Selezione funzionalità selezionare la casella di controllo Gestione Criteri di gruppo. Seguire le istruzioni visualizzate per completare l'installazione.

Per modificare le impostazioni dei Criteri di gruppo per un dominio o un'unità organizzativa (OU), è necessario accedere come membro del gruppo Domain Admins, Enterprise Admins o Proprietari autori criteri di gruppo oppure disporre della delega per il controllo appropriato dei Criteri di gruppo.

Per impostare il metodo di autenticazione del server Gateway Desktop remoto

  1. Avviare Console Gestione Criteri di gruppo. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione Criteri di gruppo.

  2. Nel riquadro sinistro individuare l'unità organizzativa che si desidera modificare.

    • Per modificare un oggetto Criteri di gruppo esistente per l'unità organizzativa, espandere l'unità organizzativa e quindi fare clic sull'oggetto.

    • Per creare un nuovo oggetto Criteri di gruppo, eseguire la procedura seguente:

      1. Fare clic con il pulsante destro del mouse sull'unità organizzativa e quindi scegliere Crea un oggetto Criteri di gruppo in questo dominio e crea qui un collegamento.

      2. Nella casella Nome digitare un nome per l'oggetto Criteri di gruppo e quindi fare clic su OK.

      3. Nel riquadro sinistro fare clic sul nuovo oggetto Criteri di gruppo.

  3. Nel riquadro destro fare clic sulla scheda Impostazioni.

  4. Fare clic con il pulsante destro del mouse su Configurazione utente e quindi scegliere Modifica.

  5. Nel riquadro sinistro, in Configurazione utente, espandere Criteri, Modelli amministrativi, Componenti di Windows, Servizi Desktop remoto e quindi fare clic su Gateway Desktop remoto.

  6. Nell'elenco delle impostazioni disponibile nel riquadro destro fare clic con il pulsante destro del mouse su Imposta metodo di autenticazione Gateway Desktop remoto e quindi scegliere Modifica.

  7. Nella finestra di dialogo Imposta metodo di autenticazione Gateway Desktop remoto eseguire una delle operazioni seguenti:

    • Fare clic su Non configurata. Verrà utilizzato il metodo di autenticazione specificato dall'utente. Se non viene specificato un metodo di autenticazione, sarà possibile utilizzare il protocollo NTLM attivato nel client oppure una smart card per l'autenticazione.

    • Fare clic su Attivata e quindi selezionare il metodo di autenticazione. La casella di controllo Consenti agli utenti di modificare questa impostazione non è selezionata per impostazione predefinita, pertanto l'impostazione per il metodo di autenticazione viene suggerita e gli utenti del client di Servizi Desktop remoto non potranno specificare un metodo di autenticazione diverso. Per consentire agli utenti del client di modificare il metodo di autenticazione, selezionare la casella di controllo. Per informazioni sui metodi di autenticazione di Windows supportati per Gateway Desktop remoto, vedere Informazioni sui requisiti per la connessione a un server Gateway Desktop remoto.

    • Fare clic su Disattivata. Verrà utilizzato il metodo di autenticazione specificato dall'utente. Se non viene specificato un metodo di autenticazione, per l'autenticazione sarà possibile utilizzare il protocollo NTLM attivato nel client di Servizi Desktop remoto oppure una smart card.

  8. Fare clic su OK.
Nota

Per configurare le impostazioni di Gateway Desktop remoto utilizzando i criteri del computer locale, utilizzare l'Editor Criteri di gruppo locali. Per avviare l'Editor Criteri di gruppo locali, fare clic sul pulsante Start, scegliere Esegui, digitare gpedit.msc e quindi fare clic su OK. Per configurare le impostazioni dei Criteri di gruppo locali, è necessario essere un membro del gruppo Administrators nel computer locale oppure disporre della delega per l'autorità appropriata.

Ulteriori riferimenti

  • Utilizzare Criteri di gruppo per gestire le connessioni client tramite Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Attivare le connessioni tramite Gateway Desktop remoto

In questa procedura viene descritto come utilizzare Console Gestione Criteri di gruppo per attivare le connessioni tramite Gateway Desktop remoto. Quando questa impostazione è attivata, nel caso in cui i client di Servizi Desktop remoto non possano connettersi direttamente a una risorsa di rete interna (computer), verrà effettuato un tentativo di connessione al computer tramite il server Gateway Desktop remoto specificato nell'impostazione Imposta indirizzo server Gateway Desktop remoto.

Nota

Per gestire Criteri di gruppo in un controller di dominio basato su Windows Server 2008 R2, è innanzitutto necessario aggiungere la funzionalità Console Gestione Criteri di gruppo. A tale scopo, avviare Server Manager e quindi in Riepilogo funzionalità fare clic su Aggiungi funzionalità. Nella pagina Selezione funzionalità selezionare la casella di controllo Gestione Criteri di gruppo. Seguire le istruzioni visualizzate per completare l'installazione.

Per modificare le impostazioni dei Criteri di gruppo per un dominio o un'unità organizzativa (OU), è necessario accedere come membro del gruppo Domain Admins, Enterprise Admins o Proprietari autori criteri di gruppo oppure disporre della delega per il controllo appropriato dei Criteri di gruppo.

Per attivare le connessioni tramite Gateway Desktop remoto

  1. Avviare Console Gestione Criteri di gruppo. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione Criteri di gruppo.

  2. Nel riquadro sinistro individuare l'unità organizzativa che si desidera modificare.

    • Per modificare un oggetto Criteri di gruppo esistente per l'unità organizzativa, espandere l'unità organizzativa e quindi fare clic sull'oggetto.

    • Per creare un nuovo oggetto Criteri di gruppo, eseguire la procedura seguente:

      1. Fare clic con il pulsante destro del mouse sull'unità organizzativa e quindi scegliere Crea un oggetto Criteri di gruppo in questo dominio e crea qui un collegamento.

      2. Nella casella Nome digitare un nome per l'oggetto Criteri di gruppo e quindi fare clic su OK.

      3. Nel riquadro sinistro fare clic sul nuovo oggetto Criteri di gruppo.

  3. Nel riquadro destro fare clic sulla scheda Impostazioni.

  4. Fare clic con il pulsante destro del mouse su Configurazione utente e quindi scegliere Modifica.

  5. Nel riquadro sinistro, in Configurazione utente, espandere Modelli amministrativi, Componenti di Windows, Servizi Desktop remoto e quindi fare clic su Gateway Desktop remoto.

  6. Nell'elenco delle impostazioni disponibile nel riquadro destro fare clic con il pulsante destro del mouse su Attiva connessione tramite Gateway Desktop remoto e quindi scegliere Modifica.

  7. Nella scheda Impostazioni eseguire una delle operazioni seguenti:

    • Fare clic su Non configurata. I client di Servizi Desktop remoto non utilizzeranno l'indirizzo del server Gateway Desktop remoto specificato nell'impostazione Imposta indirizzo server Gateway Desktop remoto. Se l'utente specifica un server Gateway Desktop remoto, verrà effettuato un tentativo di connessione client tramite il server Gateway Desktop remoto.

    • Fare clic su Attivata. Quando i client di Servizi Desktop remoto non possono connettersi direttamente a una risorsa di rete interna, verrà effettuato un tentativo di connessione alla risorsa tramite il server Gateway Desktop remoto specificato nell'impostazione Imposta indirizzo server Gateway Desktop remoto.

    • Fare clic su Disattivata. I client di Servizi Desktop remoto non utilizzeranno l'indirizzo del server Gateway Desktop remoto specificato nell'impostazione Imposta indirizzo server Gateway Desktop remoto. Se l'utente specifica un server Gateway Desktop remoto, verrà effettuato un tentativo di connessione client tramite il server Gateway Desktop remoto.

  8. Fare clic su OK.
Nota

Per configurare le impostazioni di Gateway Desktop remoto utilizzando i criteri del computer locale, utilizzare l'Editor Criteri di gruppo locali. Per avviare l'Editor Criteri di gruppo locali, fare clic sul pulsante Start, scegliere Esegui, digitare gpedit.msc e quindi fare clic su OK. Per configurare le impostazioni dei Criteri di gruppo locali, è necessario essere un membro del gruppo Administrators nel computer locale oppure disporre della delega per l'autorità appropriata.

Ulteriori riferimenti

  • Utilizzare Criteri di gruppo per gestire le connessioni client tramite Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Impostare l'indirizzo del server Gateway Desktop remoto

In questa procedura viene descritto come utilizzare Console Gestione Criteri di gruppo per specificare il server Gateway Desktop remoto utilizzato dai client di Servizi Desktop remoto durante la connessione alle risorse di rete interne (computer) tramite un server Gateway Desktop remoto.

Per impostazione predefinita, i client di Servizi Desktop remoto rilevano automaticamente quando Gateway Desktop remoto è necessario.

Nota

Per gestire Criteri di gruppo in un controller di dominio basato su Windows Server 2008 R2, è innanzitutto necessario aggiungere la funzionalità Console Gestione Criteri di gruppo. A tale scopo, avviare Server Manager e quindi in Riepilogo funzionalità fare clic su Aggiungi funzionalità. Nella pagina Selezione funzionalità selezionare la casella di controllo Gestione Criteri di gruppo. Seguire le istruzioni visualizzate per completare l'installazione.

Per modificare le impostazioni dei Criteri di gruppo per un dominio o un'unità organizzativa (OU), è necessario accedere come membro del gruppo Domain Admins, Enterprise Admins o Proprietari autori criteri di gruppo oppure disporre della delega per il controllo appropriato dei Criteri di gruppo.

Per impostare l'indirizzo del server Gateway Desktop remoto

  1. Avviare Console Gestione Criteri di gruppo. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione Criteri di gruppo.

  2. Nel riquadro sinistro individuare l'unità organizzativa che si desidera modificare.

    • Per modificare un oggetto Criteri di gruppo esistente per l'unità organizzativa, espandere l'unità organizzativa e quindi fare clic sull'oggetto.

    • Per creare un nuovo oggetto Criteri di gruppo, eseguire la procedura seguente:

      1. Fare clic con il pulsante destro del mouse sull'unità organizzativa e quindi scegliere Crea un oggetto Criteri di gruppo in questo dominio e crea qui un collegamento.

      2. Nella casella Nome digitare un nome per l'oggetto Criteri di gruppo e quindi fare clic su OK.

      3. Nel riquadro sinistro fare clic sul nuovo oggetto Criteri di gruppo.

  3. Nel riquadro destro fare clic sulla scheda Impostazioni.

  4. Fare clic con il pulsante destro del mouse su Configurazione utente e quindi scegliere Modifica.

  5. Nel riquadro sinistro, in Configurazione utente, espandere Modelli amministrativi, Componenti di Windows, Servizi Desktop remoto e quindi fare clic su Gateway Desktop remoto.

  6. Nell'elenco delle impostazioni disponibile nel riquadro destro fare clic con il pulsante destro del mouse su Imposta indirizzo server Gateway Desktop remoto e quindi scegliere Proprietà.

  7. Nella scheda Impostazioni eseguire una delle operazioni seguenti:

    • Fare clic su Non configurata. I client di Servizi Desktop remoto rileveranno automaticamente quando Gateway Desktop remoto è necessario. Quando è necessaria una connessione tramite Gateway Desktop remoto, vengono utilizzati la server farm Gateway Desktop remoto o il server Gateway Desktop remoto specificato dall'utente.

    • Fare clic su Attivata e quindi specificare un nome di dominio completo (FQDN) valido per il server Gateway Desktop remoto o per la server farm Gateway Desktop remoto. I client dovranno utilizzare tale nome per connettersi alle risorse di rete interne. Il nome deve corrispondere esattamente al nome visualizzato nel certificato SSL (Secure Sockets Layer) per il server Gateway Desktop remoto.

      Per impostazione predefinita, la casella di controllo Consenti agli utenti di modificare questa impostazione è selezionata e pertanto questa impostazione è consigliata, in modo che gli utenti possano specificare una server farm Gateway Desktop remoto o un server Gateway Desktop remoto alternativo. Per imporre questa impostazione in modo che gli utenti non possano specificare una server farm Gateway Desktop remoto o un server Gateway Desktop remoto alternativo, deselezionare questa casella di controllo.

    • Fare clic su Disattivata. I client di Servizi Desktop remoto rileveranno automaticamente quando Gateway Desktop remoto è necessario.

      Importante

      Se si disattiva o non si configura questa impostazione, ma si attiva l'impostazione Attiva connessione tramite Gateway Desktop remoto, i tentativi di connessione client a qualunque risorsa di rete interna avranno esito negativo se il client non potrà connettersi direttamente alla risorsa.

  8. Fare clic su OK.
Nota

Per configurare le impostazioni di Gateway Desktop remoto utilizzando i criteri del computer locale, utilizzare l'Editor Criteri di gruppo locali. Per avviare l'Editor Criteri di gruppo locali, fare clic sul pulsante Start, scegliere Esegui, digitare gpedit.msc e quindi fare clic su OK. Per configurare le impostazioni dei Criteri di gruppo locali, è necessario essere un membro del gruppo Administrators nel computer locale oppure disporre della delega per l'autorità appropriata.

Ulteriori riferimenti

  • Utilizzare Criteri di gruppo per gestire le connessioni client tramite Gateway Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto


Monitorare un server Gateway Desktop remoto per verificare lo stato della connessione e segnalare gli errori

In questa sezione vengono descritte le procedure che consentono di monitorare le connessioni attive dai client di Servizi Desktop remoto alle risorse di rete interne (computer) tramite un server Gateway Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Specificare gli eventi di Gateway Desktop remoto da registrare

  • Visualizzare i dettagli sulle connessioni attive tramite un server Gateway Desktop remoto

  • Informazioni sui dettagli sulle connessioni attive tramite un server Gateway Desktop remoto

  • Modificare l'intervallo di aggiornamento della visualizzazione delle informazioni di connessione di Gateway Desktop remoto


Specificare gli eventi di Gateway Desktop remoto da registrare

Utilizzando Gestione Gateway Desktop remoto è possibile specificare i tipi di evento che si desidera monitorare, ad esempio i tentativi di connessione riusciti o non riusciti alle risorse di rete interne (computer) tramite un server Gateway Desktop remoto.

Quando si verificano questi eventi, è possibile monitorarli utilizzando il Visualizzatore eventi di Windows. Gli eventi del server Gateway Desktop remoto sono archiviati nel Visualizzatore eventi, nel percorso Registri applicazioni e servizi\Microsoft\Windows\Servizi terminal-Gateway\.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare gli eventi di Gateway Desktop remoto da registrare

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic con il pulsante destro del mouse sul server Gateway Desktop remoto locale e quindi scegliere Proprietà.

  3. Nella scheda Controllo selezionare o deselezionare le caselle di controllo appropriate per specificare quali eventi si desidera monitorare per Gateway Desktop remoto.

  4. Fare clic su OK.

Ulteriori riferimenti

  • Monitorare un server Gateway Desktop remoto per verificare lo stato della connessione e segnalare gli errori

  • Aprire Gestione Gateway Desktop remoto


Visualizzare i dettagli sulle connessioni attive tramite un server Gateway Desktop remoto

Gestione Gateway Desktop remoto consente di visualizzare informazioni relative alle connessioni attive dai client di Servizi Desktop remoto alle risorse di rete interne (computer) tramite Gateway Desktop remoto. Per ulteriori informazioni sui dettagli che vengono visualizzati per le connessioni attive, vedere Informazioni sui dettagli sulle connessioni attive tramite un server Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare i dettagli sulle connessioni attive tramite un server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console fare clic su Monitoraggio.

    Nel riquadro dei risultati di Gestione Gateway Desktop remoto viene visualizzato un riepilogo del numero di connessioni tra gli utenti remoti e i computer della rete interna. Se sono presenti connessioni specifiche, queste saranno elencate sotto il riepilogo.

    Quando si fa clic su una connessione, nel riquadro inferiore vengono visualizzati i dettagli corrispondenti. Se necessario, è possibile disconnettere una connessione specifica o tutte le connessioni a Gateway Desktop remoto per un utente.

  4. Per aggiornare la visualizzazione dello stato delle connessioni, nel riquadro Azioni fare clic su Aggiorna.

Ulteriori riferimenti

  • Monitorare un server Gateway Desktop remoto per verificare lo stato della connessione e segnalare gli errori

  • Aprire Gestione Gateway Desktop remoto


Informazioni sui dettagli sulle connessioni attive tramite un server Gateway Desktop remoto

Gestione Gateway Desktop remoto consente di visualizzare informazioni relative alle connessioni attive dai client di Servizi Desktop remoto alle risorse di rete interne (computer) tramite un server Gateway Desktop remoto. Queste informazioni vengono visualizzate nel riquadro dei dettagli Monitoraggio.

Nella tabella seguente vengono elencate e descritte le informazioni relative alle connessioni attive visualizzate.

Nome evento Descrizione

ID connessione

Nel formato <a:b>, dove "a" è l'ID del tunnel che identifica in modo univoco una connessione specifica al server Gateway Desktop remoto e "b" è l'ID del canale. L'ID del tunnel rappresenta il numero di connessioni che il server Gateway Desktop remoto ha ricevuto da quando il servizio Gateway di Servizi Desktop remoto è in esecuzione. Ogni volta che il server Gateway Desktop remoto riceve una nuova connessione, l'ID del tunnel viene incrementato di 1.

ID utente

L'ID utente e il dominio dell'utente che ha eseguito l'accesso al client, nel formato <dominio\IDutente>.

Nome utente

Il nome completo dell'utente che ha eseguito l'accesso al client.

Connesso su

La data e l'ora in cui la connessione è stata avviata.

Durata connessione

L'intervallo di tempo in cui la connessione è rimasta attiva.

Tempo di inattività

L'intervallo di tempo in cui la connessione è rimasta inattiva, se pertinente.

Computer di destinazione

Il nome del computer della rete interna al quale è connesso il client.

Indirizzo IP client

L'indirizzo IP del client.

Nota

Se nella configurazione di rete sono inclusi server proxy, l'indirizzo IP visualizzato in questa colonna rifletterà l'indirizzo IP del server proxy e non l'indirizzo IP del client di Servizi Desktop remoto.

Porta di destinazione

La porta del computer della rete interna alla quale è connesso il client.

Ulteriori riferimenti

  • Monitorare un server Gateway Desktop remoto per verificare lo stato della connessione e segnalare gli errori

  • Visualizzare i dettagli sulle connessioni attive tramite un server Gateway Desktop remoto


Modificare l'intervallo di aggiornamento della visualizzazione delle informazioni di connessione di Gateway Desktop remoto

Per impostazione predefinita, lo stato della connessione di Gateway Desktop remoto viene aggiornato automaticamente ogni 30 minuti. È possibile modificare l'intervallo di aggiornamento oppure specificare che la visualizzazione di queste informazioni non venga aggiornata automaticamente.

Importante

Se si imposta l'intervallo di aggiornamento su un valore inferiore a 10 minuti, le prestazioni del server Gateway Desktop remoto potrebbero risentirne.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per modificare l'intervallo di aggiornamento della visualizzazione delle informazioni di connessione di Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console fare clic con il pulsante destro del mouse sulla cartella Monitoraggio e quindi scegliere Imposta opzioni aggiornamento automatico.

  4. Nella finestra di dialogo Imposta opzioni aggiornamento automatico eseguire una delle operazioni seguenti:

    • Per specificare che la visualizzazione delle informazioni di connessione di Gateway Desktop remoto non venga aggiornata automaticamente, fare clic su Non aggiornare automaticamente.

    • Per specificare che la visualizzazione delle informazioni di connessione di Gateway Desktop remoto venga aggiornata automaticamente, fare clic su Aggiorna automaticamente e quindi specificare il valore desiderato.

  5. Fare clic su OK.

Ulteriori riferimenti

  • Monitorare un server Gateway Desktop remoto per verificare lo stato della connessione e segnalare gli errori

  • Aprire Gestione Gateway Desktop remoto


Attivare o disattivare la condivisione di credenziali per le connessioni tramite Gateway Desktop remoto

Per consentire agli utenti di connettersi alle risorse di rete interne (computer) tramite Gateway Desktop remoto, sono necessari due livelli di autenticazione. Superando il primo di livello di autenticazione, gli utenti possono connettersi al server Gateway Desktop remoto. Superando il secondo livello di autenticazione, gli utenti possono connettersi ai computer remoti (computer della rete interna). Per ogni livello di autenticazione viene richiesto agli utenti di specificare le credenziali, a meno che essi non dispongano delle credenziali seguenti:

  • Credenziali dell'utente connesso localmente

  • Credenziali salvate

  • Credenziali condivise

Nota

La condivisione delle credenziali è disponibile con il client di Connessione desktop remoto 6.1. Connessione Desktop remoto 6.1 supporta Remote Desktop Protocol 6.1

Quando è attivata la condivisione delle credenziali, gli utenti possono immettere lo stesso insieme di credenziali per eseguire l'autenticazione sia per il server Gateway Desktop remoto, sia per il computer remoto. In tal caso, all'utente viene richiesto di fornire le credenziali una sola volta.

Per impostazione predefinita, la condivisione delle credenziali è attivata per Gateway Desktop remoto, tuttavia è possibile disattivarla qualora i criteri di sicurezza adottati dall'organizzazione lo richiedano. Per attivare o disattivare la condivisione delle credenziali, procedere in uno dei due modi seguenti:

  • Modificare le impostazioni relative alla connessione nel client di Servizi Desktop remoto (Connessione desktop remoto). Nel client è possibile configurare l'impostazione relativa alla condivisione delle credenziali selezionando o deselezionando la casella di controllo Usa credenziali di Gateway Desktop remoto per il computer remoto, come descritto più avanti in questo argomento.

  • Modificare le impostazioni del file RDP. Nel file RDP è possibile configurare l'impostazione relativa alla condivisione delle credenziali aggiungendo o modificando la riga PromptCredentialOnce:i, come descritto più avanti in questo argomento.

Se la condivisione delle credenziali è attivata, quando gli utenti tenteranno di connettersi a un computer tramite Gateway Desktop remoto verrà visualizzata una finestra di dialogo Sicurezza di Windows in cui viene richiesto agli utenti di immettere le credenziali una sola volta e viene indicato che tali credenziali verranno utilizzate sia per la connessione al server Gateway Desktop remoto, sia per la connessione al computer remoto (il computer della rete interna). Nella finestra di dialogo Sicurezza di Windows sono indicati i nomi di entrambi i computer.

Nella finestra di dialogo Sicurezza di Windows è inoltre inclusa la casella di controllo Memorizza credenziali. Se gli utenti selezionano questa casella di controllo dopo avere fornito le credenziali, queste verranno salvate sia per il server Gateway Desktop remoto, sia per il computer remoto. Le stesse credenziali verranno utilizzate nelle connessioni successive allo stesso server Gateway Desktop remoto e allo stesso computer remoto.

Importante
  • L'impostazione Memorizza credenziali viene ignorata nei due casi seguenti: se gli utenti hanno già salvato le loro credenziali o se è attivata l'impostazione di Criteri di gruppo per consentire che vengano specificate le credenziali dell'utente connesso localmente per Gateway Desktop remoto.
  • Dopo avere salvato le credenziali, se gli utenti tentano di connettersi al server Gateway Desktop remoto e al computer remoto verrà visualizzato un messaggio nella finestra di dialogo Impostazioni server Gateway Desktop remoto nel client. Tale messaggio informa gli utenti che le credenziali salvate verranno utilizzate per la connessione al server Gateway Desktop remoto. Gli utenti possono modificare o eliminare tali credenziali. Per aprire la finestra di dialogo Impostazioni server Gateway Desktop remoto, nella finestra di dialogo Connessione desktop remoto del computer client fare clic su Opzioni e nell'area Connessione da postazioni remote della scheda Avanzate scegliere Impostazioni.
  • Se è stata attivata l'impostazione di Criteri di gruppo per consentire che vengano specificate le credenziali dell'utente connesso localmente per Gateway Desktop remoto, quando l'utente tenterà di connettersi verrà visualizzato un messaggio nella finestra di dialogo Impostazioni server Gateway Desktop remoto per informarlo che le credenziali dell'utente connesso localmente verranno utilizzate per la connessione al server Gateway Desktop remoto. Per informazioni su come attivare l'impostazione di Criteri di gruppo e consentire l'utilizzo delle credenziali dell'utente connesso localmente per Gateway Desktop remoto, vedere Impostare il metodo di autenticazione del server Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare.

Per modificare le impostazioni del client in modo da attivare o disattivare la condivisione delle credenziali

  1. Aprire il client di Connessione desktop remoto. Per aprire il client di Connessione desktop remoto, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Connessione desktop remoto.

  2. Nella finestra di dialogo Connessione desktop remoto fare clic su Opzioni per espandere la finestra di dialogo e visualizzare le impostazioni.

  3. Nella scheda Avanzate fare clic su Impostazioni nell'area Connessione da postazioni remote.

  4. Nella finestra di dialogo Impostazioni server Gateway Desktop remoto selezionare la casella di controllo Usa credenziali di Gateway Desktop remoto per il computer remoto nell'area Impostazioni di accesso.

  5. Verificare e configurare ulteriori impostazioni relative alla connessione client per Gateway Desktop remoto secondo le esigenze e quindi fare clic su OK per chiudere la finestra di dialogo. Per informazioni su come configurare le altre impostazioni del client, vedere Configurare le impostazioni di Connessione desktop remoto per Gateway Desktop remoto.

  6. Eseguire una delle operazioni seguenti:

    • Per salvare le impostazioni e chiudere la finestra di dialogo Connessione desktop remoto, nella scheda Generale fare clic su Salva e quindi su Annulla. Le impostazioni verranno salvate come file RDP in un percorso predefinito. Per impostazione predefinita il file viene salvato in Unità:\<Username>\Documenti.

    • Per salvare il file RDP in un percorso specifico, in modo da poterlo personalizzare e distribuire a più client in seguito secondo le esigenze, fare clic su Salva con nome. Nella finestra di dialogo Salva con nome immettere il nome del file e il percorso in Nome file, quindi fare clic su Salva.

  7. Per procedere con una connessione a una risorsa di rete interna, nella scheda Generale configurare le impostazioni in Impostazioni di accesso secondo le esigenze, fare clic su Salva, quindi su Connetti e immettere le credenziali quando richiesto.

In alternativa, come anticipato è possibile modificare le impostazioni direttamente nel file RDP.

Per modificare un file RDP in modo da attivare o disattivare la condivisione delle credenziali

  1. Aprire il file RDP che si desidera modificare utilizzando un editor di testo, ad esempio Blocco note.

  2. Eseguire una delle operazioni seguenti:

    • Per disattivare la condivisione delle credenziali, aggiungere la riga seguente o assicurarsi che le eventuali righe PromptCredentialOnce:i esistenti abbiano il seguente formato: PromptCredentialOnce:i:0

    • Per riattivare la condivisione delle credenziali, modificare la riga PromptCredentialOnce:i nel modo seguente: PromptCredentialOnce:i:1

  3. Salvare e chiudere il file.

Ulteriori riferimenti

  • Configurare le impostazioni di Connessione desktop remoto per Gateway Desktop remoto


Specificare le condizioni che gli utenti devono soddisfare per connettersi a un server Gateway Desktop remoto

I Criteri di autorizzazione connessioni Desktop remoto consentono di specificare gli utenti autorizzati a connettersi a un server Gateway Desktop remoto.

Importante

È inoltre necessario creare Criteri di autorizzazione risorse Desktop remoto, qualora non siano già stati creati. Fino a quando non vengono creati sia i Criteri di autorizzazione connessioni Desktop remoto che i Criteri di autorizzazione risorse Desktop remoto, gli utenti non possono connettersi alle risorse di rete tramite questo server Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare le condizioni che gli utenti devono soddisfare per connettersi a un server Gateway Desktop remoto

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto selezionare il nodo che rappresenta il server Gateway Desktop remoto locale, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle connessioni.

  4. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sui Criteri di autorizzazione connessioni Desktop remoto per i quali si desidera specificare le condizioni e quindi scegliere Proprietà.

  5. Nella scheda Requisiti, in Metodi di autenticazione di Windows supportati, selezionare una o entrambe le caselle di controllo seguenti:

    • Password

    • Smart card

    Se entrambe le opzioni sono selezionate, i client che utilizzano uno di questi metodi di autenticazione saranno autorizzati a connettersi. Per ulteriori informazioni sui metodi di autenticazione di Windows supportati per Gateway Desktop remoto, vedere Informazioni sui requisiti per la connessione a un server Gateway Desktop remoto.

  6. In Appartenenza a un gruppo di utenti (obbligatorio) fare clic su Aggiungi gruppo e quindi specificare un gruppo di utenti i cui membri siano autorizzati a connettersi al server Gateway Desktop remoto. È necessario specificare almeno un gruppo di utenti.

  7. Nella finestra di dialogo Seleziona gruppi specificare il percorso e il nome del gruppo di utenti e quindi fare clic su OK secondo le esigenze per selezionare il nome e chiudere la finestra di dialogo Seleziona gruppi. Per specificare più gruppi di utenti, eseguire una delle operazioni seguenti:

    • Digitare il nome di ogni gruppo di utenti, separandolo dagli altri nomi con un punto e virgola.

    • Per aggiungere altri gruppi da domini diversi, ripetere il passaggio 7 per ogni gruppo.

  8. È possibile specificare facoltativamente i criteri di appartenenza al dominio del computer che devono essere soddisfatti dai computer client facendo clic su Aggiungi gruppo in Appartenenza a un gruppo di computer client (facoltativo) nella scheda Requisiti e quindi specificando i gruppi di computer.

    Per specificare i gruppi di computer, è possibile eseguire gli stessi passaggi utilizzati per specificare i gruppi di utenti.

  9. Fare clic su OK le volte necessarie per chiudere la finestra di dialogo Proprietà per i Criteri di autorizzazione connessioni Desktop remoto.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Informazioni sulle impostazioni di timeout e riconnessione per per le sessioni remote

È possibile impostare timeout nel server Gateway Desktop remoto per i client di Servizi Desktop remoto. I timeout possono essere utilizzati per recuperare risorse dalle sessioni utente inattive o applicare periodicamente i criteri per le connessioni utente attive per i client di Servizi Desktop remoto che si connettono utilizzando un server Gateway Desktop remoto.

Timeout di Gateway Desktop remoto

È possibile impostare i timeout seguenti nella scheda Timeout della finestra Proprietà per i Criteri di autorizzazione connessioni Desktop remoto per il server Gateway Desktop remoto.

  1. Attiva timeout di inattività consente di recuperare risorse da sessioni utente inattive senza alcun impatto sui dati e sulla sessione dell'utente. Al raggiungimento del timeout di inattività, la sessione viene disconnessa e le relative risorse vengono recuperate dal server Gateway Desktop remoto.

  2. Attiva timeout della sessione consente di applicare periodicamente i criteri per le connessioni utente attive. Al raggiungimento del timeout della sessione, la sessione può essere disconnessa oppure può essere autenticata e autorizzata di nuovo senza alcun impatto sull'utente e sulla relativa sessione, se non sono state apportate modifiche ai criteri.

Ulteriori riferimenti

  • Creare criteri di autorizzazione connessioni Desktop remoto

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto


Che cos'è Reindirizzamento dispositivi?

Servizi Desktop remoto consente agli utenti dei client di accedere alle risorse e ai dispositivi locali in sessioni remote. Gli utenti possono accedere a risorse quali unità locali, stampanti, gli Appunti e dispositivi Plug and Play supportati. Tale tipo di accesso viene in genere definito reindirizzamento dei dispositivi.

In Windows Server 2008 R2 il reindirizzamento dei dispositivi è stato migliorato e ampliato. È ora possibile reindirizzare i dispositivi portatili Windows, in particolare i lettori multimediali MTP (Media Transfer Protocol) e le fotocamere digitali PTP (Picture Transfer Protocol).

Per Gateway Desktop remoto, quando si seleziona l'opzione che disattiva il reindirizzamento solo per tipi di dispositivi specifici, il server Gateway Desktop remoto restituisce la richiesta al client con un elenco dei tipi di dispositivi da disattivare. Questo elenco è solo un suggerimento. Al client è consentito modificare le impostazioni di reindirizzamento del dispositivo incluse nell'elenco. È possibile imporre le impostazioni di reindirizzamento dei dispositivi suggerite solo per i client di Connessione desktop remoto.

Attenzione

Se si seleziona la casella di controllo Consenti connessioni client solo ai server host sessione Desktop remoto in cui è applicato il reindirizzamento dei dispositivi del Gateway Desktop remoto, gli utenti che eseguono versioni precedenti a Connessione desktop remoto 7.0 non possono effettuare la connessione e viene imposto il reindirizzamento sicuro dei dispositivi.

Nota

Gateway Desktop remoto non consente di gestire il reindirizzamento dei dispositivi per smart card e audio.

Per ulteriori informazioni sul reindirizzamento dei dispositivi in Windows Server 2008 R2, vedere la pagina relativa a Servizi Desktop remoto in TechCenter per Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=140433).

Ulteriori riferimenti

  • Attivare o disattivare il reindirizzamento dei dispositivi client


Attivare o disattivare il reindirizzamento dei dispositivi client

I Criteri di autorizzazione connessioni Desktop remoto consentono di specificare gli utenti autorizzati a connettersi a un server Gateway Desktop remoto. È possibile specificare un gruppo di utenti esistente nel server Gateway Desktop remoto locale o in Servizi di dominio Active Directory. Gli utenti sono autorizzati ad accedere a un server Gateway Desktop remoto se soddisfano le condizioni specificate nei Criteri di autorizzazione connessioni Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gateway Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare o disattivare il reindirizzamento dei dispositivi client

  1. Nel server Gateway Desktop remoto aprire Gestione Gateway Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Gestione Gateway Desktop remoto.

  2. Nell'albero della console di Gestione Gateway Desktop remoto fare clic per espandere il nodo che rappresenta il server Gateway Desktop remoto, denominato in base al computer in cui il server Gateway Desktop remoto è in esecuzione.

  3. Nell'albero della console espandere Criteri e quindi fare clic su Criteri di autorizzazione delle connessioni.

  4. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sui Criteri di autorizzazione connessioni Desktop remoto per i quali si desidera attivare o disattivare il reindirizzamento dei dispositivi client, quindi scegliere Proprietà.

  5. Per attivare o disattivare il reindirizzamento dei dispositivi client remoti, nella scheda Reindirizzamento dispositivi selezionare una delle opzioni seguenti:

    • Per consentire il reindirizzamento di tutti i dispositivi client quando effettuano la connessione tramite il server Gateway Desktop remoto, fare clic su Attiva reindirizzamento dispositivi per tutti i dispositivi client. Questa opzione è selezionata per impostazione predefinita.

    • Per disattivare il reindirizzamento dei dispositivi solo per alcuni tipi di dispositivo quando effettuano la connessione tramite il server Gateway Desktop remoto, fare clic su Disattiva reindirizzamento dispositivi per i tipi di dispositivi client seguenti e quindi selezionare le caselle di controllo corrispondenti ai tipi di dispositivo per i quali si desidera disattivare il reindirizzamento dei dispositivi.

  6. Per consentire solo la connessione client ai server che impongono il reindirizzamento sicuro dei dispositivi, nella scheda Reindirizzamento dispositivi selezionare la casella di controllo Consenti connessioni client solo ai server host sessione Desktop remoto in cui è applicato il reindirizzamento dei dispositivi del Gateway Desktop remoto.

  7. Fare clic su OK.

Ulteriori riferimenti

  • Gestire i criteri di autorizzazione connessioni Desktop remoto

  • Elenco di controllo: configurare Gateway Desktop remoto

  • Informazioni sui criteri di autorizzazione per Gateway Desktop remoto

  • Aprire Gestione Gateway Desktop remoto