Desktop remoti

Che cos'è lo snap-in Desktop remoti?

Lo snap-in Desktop remoti consente di gestire connessioni a server Host sessione Desktop remoto e a computer che eseguono una versione di Windows Server® 2008 R2, Windows Server 2008, Windows Server 2003, Windows® 7, Windows Vista® o Windows XP.

Perché utilizzare lo snap-in Desktop remoti?

Lo snap-in Desktop remoti consente di amministrare più computer da un'unica posizione remota. È possibile connettersi a più computer contemporaneamente e quindi passare con facilità da una connessione all'altra.

Ulteriori riferimenti

Panoramica dello snap-in Desktop remoti

Avviare lo snap-in Desktop remoti

Aggiungere una nuova connessione

Avviare una sessione

Disconnettersi da una sessione

Modificare una connessione esistente

Specificare l'avvio di un programma alla connessione

Eliminare una connessione


Panoramica dello snap-in Desktop remoti

Lo snap-in Desktop remoti consente di gestire connessioni a server Host sessione Desktop remoto e ad altri computer. Tramite lo snap-in Desktop remoti è possibile amministrare più computer da un'unica posizione remota.

Per impostazione predefinita, quando si aggiunge una connessione, viene eseguita una connessione a una sessione nel computer remoto che viene utilizzato a scopo amministrativo. In questo caso la connessione desktop remoto viene avviata con l'opzione /admin. Questa opzione non utilizza una licenza CAL (Client Access License) se ci si connette a un computer in cui è installato il servizio ruolo Host sessione Desktop remoto. Per eseguire un determinato programma alla connessione, è possibile modificare quest'ultima specificando il nome del programma.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Utenti desktop remoto nel computer remoto. Se ci si connette a una sessione mediante l'opzione /admin, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale nel computer remoto.

Nota

Se il computer è connesso alla rete, è possibile che le impostazioni dei criteri di rete impediscano il completamento di una determinata procedura.

Ulteriori riferimenti

Avviare lo snap-in Desktop remoti

Aggiungere una nuova connessione

Avviare una sessione

Disconnettersi da una sessione

Modificare una connessione esistente

Specificare l'avvio di un programma alla connessione

Eliminare una connessione


Avviare lo snap-in Desktop remoti

È possibile aprire lo snap-in Desktop remoti dal menu Start oppure tramite Microsoft Management Console (MMC).

Per eseguire le procedure illustrate in questo argomento, è possibile utilizzare qualsiasi account utente.

Per aprire Desktop remoti dal menu Start

  • Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Desktop remoti.
Per aprire Desktop remoti da MMC

  1. Fare clic sul pulsante Start, digitare mmc e quindi premere INVIO.

  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

  3. Nell'elenco Snap-in disponibili selezionare Desktop remoti e quindi fare clic su Aggiungi.

  4. Fare clic su OK.

Ulteriori riferimenti

Aggiungere una nuova connessione


Aggiungere una nuova connessione

Per potersi connettere in remoto a un computer nello snap-in Desktop remoti, è innanzitutto necessario aggiungere una connessione al computer.

Per completare questa procedura, è possibile utilizzare qualsiasi account utente.

Per aggiungere una nuova connessione

  1. Avviare lo snap-in Desktop remoti. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Desktop remoti.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Desktop remoti e quindi scegliere Aggiungi nuova connessione.

  3. In Connessione eseguire le operazioni seguenti:

    1. Nella casella Nome o indirizzo IP del computer digitare il nome o l'indirizzo IP del computer a cui si desidera connettersi. Se si ha necessità di individuare il computer, fare clic su Sfoglia, selezionare il nome del computer e quindi fare clic su OK.

    2. Nella casella Nome connessione digitare un nome descrittivo per la connessione. Per impostazione predefinita, il nome della connessione corrisponde a quello digitato nella casella Nome computer o indirizzo IP.

    3. Per impostazione predefinita, la casella di controllo Connetti con l'opzione /admin è selezionata. Se ci si connette a una sessione tramite l'opzione /admin, è necessaria almeno l'appartenenza al gruppo Administrators locale nel computer remoto.

      Importante

      Se si configura un programma affinché venga avviato alla connessione in un computer che esegue Windows Server 2003 o Windows XP, è necessario deselezionare la casella di controllo Connetti con l'opzione /admin nella scheda Generale. Se il computer host esegue Windows Server 2008 o Windows Server 2008 R2, per avviare un programma alla connessione non è necessario deselezionare l'opzione /admin. Se il computer host esegue Microsoft Windows Vista o Windows 7, non è possibile configurare un programma affinché venga eseguito alla connessione.

      Se non si desidera connettersi a una sessione tramite l'opzione /admin, deselezionare la casella di controllo Connetti con l'opzione /admin.

      Importante

      In Windows Server 2003 e Windows XP quando ci si connette a una sessione tramite l'opzione /admin, viene sempre aperta una sessione in modalità a schermo intero, come avviene quando l'accesso al computer viene eseguito localmente. Se si desidera avviare un determinato programma alla connessione, è necessario deselezionare la casella di controllo Connetti con l'opzione /admin e specificare il percorso e il nome del file del programma nella scheda Altro, a cui si accede facendo clic con il pulsante destro del mouse sulla connessione e scegliendo Proprietà.

  4. In Informazioni di accesso eseguire le operazioni seguenti:

    1. Nella casella Nome utente digitare il nome utente dell'account che si desidera utilizzare per l'accesso. Se si lascia vuota la casella Nome utente, è possibile immettere il proprio nome utente al momento della connessione.

    2. Se si desidera salvare le credenziali in modo da accedere automaticamente al computer remoto, selezionare la casella di controllo Consenti il salvataggio delle credenziali. Se si seleziona questa casella di controllo, le credenziali verranno salvate alla successiva connessione al computer remoto eseguita tramite lo snap-in Desktop remoti.

  5. Al termine, fare clic su OK.

Ulteriori riferimenti

Avviare una sessione

Modificare una connessione esistente

Eliminare una connessione


Avviare una sessione

Tramite lo snap-in Desktop remoti è possibile avviare una nuova sessione o connettersi a una sessione esistente.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Utenti desktop remoto locale nel computer remoto. Se ci si connette a una sessione mediante l'opzione /admin, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale nel computer remoto.

Importante

Se ci si sta connettendo a un controller di dominio, assicurarsi che l'account utente disponga del diritto utente Consenti accesso tramite Servizi Desktop remoto.

Per avviare o connettersi a una sessione

  1. Aprire lo snap-in Desktop remoti facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione, Servizi Desktop remoto e quindi Desktop remoti.

  2. Nell'albero della console espandere Desktop remoti.

  3. In Desktop remoti fare clic sul nome del computer a cui si desidera connettersi.

    Se la connessione non viene avviata entro pochi istanti, fare clic con il pulsante destro del mouse sul nome del computer e scegliere Connetti.

  4. Se richiesto, immettere le proprie credenziali di accesso e quindi fare clic su OK.

    Nota

    È possibile configurare il comportamento per le credenziali salvate nella scheda Generale, quando si visualizzano le proprietà della connessione. Per ulteriori informazioni, vedere Modificare una connessione esistente.

Ulteriori riferimenti

Disconnettersi da una sessione

Modificare una connessione esistente

Specificare l'avvio di un programma alla connessione


Disconnettersi da una sessione

Quando ci si disconnette da una sessione, i programmi continuano a essere in esecuzione in uno stato disconnesso. Quando ci si connette nuovamente, si viene riconnessi alla stessa sessione fino a che questa rimane in esecuzione nel computer remoto. È possibile disconnettersi da una sessione utilizzando lo snap-in Desktop remoti.

Per completare questa procedura, è possibile utilizzare qualsiasi account utente. Per disconnettere una sessione, è tuttavia necessario essere membri del gruppo Utenti desktop remoto locale nel computer remoto.

Per disconnettersi da una sessione

  1. Aprire lo snap-in Desktop remoti facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione, Servizi Desktop remoto e quindi Desktop remoti.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sul nome della connessione che si desidera disconnettere e quindi scegliere Disconnetti.
Nota

Per disconnettere il computer remoto, è necessario chiudere la sessione di desktop remoto.

Ulteriori riferimenti

Avviare una sessione


Modificare una connessione esistente

È possibile modificare le proprietà di una connessione esistente nello snap-in Desktop remoti, ad esempio il nome del computer, le informazioni di accesso, le dimensioni del desktop e le opzioni di autenticazione.

Per completare questa procedura, è possibile utilizzare qualsiasi account utente.

Per modificare una connessione esistente

  1. Aprire lo snap-in Desktop remoti facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione, Servizi Desktop remoto e quindi Desktop remoti.

  2. Nell'albero della console espandere Desktop remoti.

  3. Fare clic con il pulsante destro del mouse sulla connessione che si desidera modificare e quindi scegliere Proprietà.

  4. Apportare le modifiche desiderate.

    • Nella scheda Generale è possibile modificare il nome del computer o della connessione, indicare se ci si connette a una sessione tramite l'opzione /admin oppure modificare le proprie informazioni di accesso.

      Importante

      Se si configura un programma affinché venga avviato alla connessione in un computer che esegue Windows Server 2003 o Windows XP, è necessario deselezionare la casella di controllo Connetti con l'opzione /admin nella scheda Generale. Se il computer host esegue Windows Server 2008 o Windows Server 2008 R2, per avviare un programma alla connessione non è necessario deselezionare l'opzione /admin. Se il computer host esegue Microsoft Windows Vista o Windows 7, non è possibile configurare un programma affinché venga eseguito alla connessione.

      Se le credenziali di accesso non sono state salvate, in Informazioni di accesso è possibile selezionare la casella di controllo Consenti il salvataggio delle credenziali. Le credenziali verranno salvate alla successiva connessione al computer remoto eseguita tramite lo snap-in Desktop remoti.

      Se le credenziali di accesso sono state salvate in precedenza, è possibile modificarle o rimuoverle facendo clic rispettivamente su Modifica o Elimina.

      Se le credenziali sono state salvate, ma si desidera accedere temporaneamente con un utente diverso, è possibile selezionare la casella di controllo Richiedi sempre credenziali. Per utilizzare nuovamente le credenziali salvate, deselezionare la casella di controllo.

    • Nella scheda Opzioni schermo è possibile modificare le dimensioni del desktop.

    • Nella scheda Altro è possibile configurare o modificare un programma che viene avviato alla connessione, modificare il metodo di autenticazione o modificare le impostazioni di reindirizzamento delle unità.

  5. Al termine, fare clic su OK.

Ulteriori riferimenti

Specificare l'avvio di un programma alla connessione


Specificare l'avvio di un programma alla connessione

Quando si configura una connessione nello snap-in Desktop remoti, è possibile specificare l'avvio di un programma alla connessione.

Per completare questa procedura, è possibile utilizzare qualsiasi account utente.

Per specificare l'avvio di un programma alla connessione

  1. Aprire lo snap-in Desktop remoti facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione, Servizi Desktop remoto e quindi Desktop remoti.

  2. Se non è già stato fatto, aggiungere la connessione. Per ulteriori informazioni, vedere Aggiungere una nuova connessione.

  3. Nell'albero della console espandere Desktop remoti.

  4. Fare clic con il pulsante destro del mouse sulla connessione che si desidera configurare e quindi scegliere Proprietà.

  5. Per connettersi a un computer che esegue Windows Server 2003 o Windows XP, deselezionare la casella di controllo Connetti con l'opzione /admin nella scheda Generale.

  6. Nella scheda Altro in Avvio programma selezionare la casella di controllo Avvia il seguente programma alla connessione.

  7. Nella casella Percorso e nome file del programma digitare il percorso completo del programma da avviare. Nella casella Directory di lavoro digitare la cartella predefinita che deve essere utilizzata dalla connessione.

    Nota

    Se non viene specificato un programma da avviare, la connessione verrà avviata sul desktop di Windows.

  8. Per consentire al computer remoto di accedere alle unità del computer locale, selezionare la casella di controllo Reindirizza unità locali quando connesso al computer remoto.

  9. Al termine, fare clic su OK.

Ulteriori riferimenti

Modificare una connessione esistente


Eliminare una connessione

È possibile eliminare una connessione utilizzando lo snap-in Desktop remoti.

Per completare questa procedura, è possibile utilizzare qualsiasi account utente.

Per eliminare una connessione

  1. Aprire lo snap-in Desktop remoti facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione, Servizi Desktop remoto e quindi Desktop remoti.

  2. Nell'albero della console espandere Desktop remoti.

  3. Fare clic con il pulsante destro del mouse sulla connessione che si desidera eliminare e quindi scegliere Elimina.

Ulteriori riferimenti

Aggiungere una nuova connessione