Configurazione host sessione Desktop remoto

Configurazione host sessione Desktop remoto, precedentemente noto come Configurazione Servizi terminal, consente di configurare le impostazioni relative a nuove connessioni, modificare le impostazioni delle connessioni esistenti ed eliminare connessioni. È possibile configurare le impostazioni per singole connessioni o per l'intero server.

Sono inclusi gli argomenti seguenti:

  • Panoramica di Configurazione host sessione Desktop remoto

  • Configurare le connessioni di Servizi Desktop remoto

  • Configurare le impostazioni di un server Host sessione Desktop remoto

  • Gestire le connessioni di Servizi Desktop remoto

Per ulteriori informazioni sull'installazione, sulla configurazione e sulla gestione del servizio ruolo Gestore connessione Desktop remoto, vedere Gestore connessione Desktop remoto.

Ulteriori riferimenti

  • Per ulteriori informazioni su Servizi Desktop remoto, vedere la pagina corrispondente nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.


Panoramica di Configurazione host sessione Desktop remoto

Configurazione host sessione Desktop remoto consente di configurare le impostazioni relative a nuove connessioni, modificare le impostazioni delle connessioni esistenti ed eliminare connessioni. È possibile configurare le impostazioni per singole connessioni o per l'intero server.

Importante

È possibile utilizzare Configurazione host sessione Desktop remoto in Windows Server 2008 R2 solo per configurare un server Host sessione Desktop remoto che esegue Windows Server 2008 o Windows Server 2008 R2.

Nota

Host sessione Desktop remoto era precedentemente noto come servizio ruolo Terminal Server e il server Host sessione Desktop remoto come Terminal Server.

Negli argomenti seguenti sono incluse informazioni sulle impostazioni relative all'intero server:

  • Limitare gli utenti a una singola sessione

  • Configurare cartelle temporanee per un server Host sessione Desktop remoto

  • Negare nuovi accessi utente a un server Host sessione Desktop remoto

  • Configurare le impostazioni relative alle licenze per un server Host sessione Desktop remoto

  • Configurare Virtualizzazione IP di Desktop remoto

  • Configurare il supporto per la stampante

  • Configurare le impostazioni di Gestore connessione Desktop remoto per un server Host sessione Desktop remoto

Negli argomenti seguenti sono incluse informazioni sulle impostazioni relative alle connessioni:

  • Gestire le connessioni di Servizi Desktop remoto

  • Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto

  • Configurare le impostazioni client per le connessioni di Servizi Desktop remoto

  • Configurare le impostazioni di sessione per le connessioni di Servizi Desktop remoto

Sono inoltre inclusi gli argomenti seguenti:

  • Eseguire Configurazione host sessione Desktop remoto

  • Connettersi a un altro server Host sessione Desktop remoto mediante Configurazione host sessione Desktop remoto

  • Desktop remoto per amministrazione


Eseguire Configurazione host sessione Desktop remoto

È possibile eseguire Configurazione host sessione Desktop remoto da una delle posizioni seguenti:

  • Menu Start

  • Server Manager

  • Microsoft Management Console

Nota

Configurazione host sessione Desktop remoto è disponibile in Server Manager solo se nel computer è installato il ruolo Servizi Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per eseguire Configurazione host sessione Desktop remoto dal menu Start

  • Fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  • Fare clic sul pulsante Start, scegliere Esegui, digitare tsconfig.msc e quindi premere INVIO.
Per eseguire Configurazione host sessione Desktop remoto da Server Manager

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

  2. Nel riquadro sinistro espandere Ruoli.

  3. Espandere Servizi Desktop remoto e quindi fare clic su Configurazione host sessione Desktop remoto.
Per eseguire Configurazione host sessione Desktop remoto da Microsoft Management Console

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare mmc e quindi premere INVIO.

  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

  3. In Snap-in disponibili fare clic su Configurazione host sessione Desktop remoto e quindi su Aggiungi.

  4. Nella finestra di dialogo Seleziona computer selezionare se si desidera connettersi al computer locale o a un altro computer. Se si seleziona Altro computer, digitare il nome del computer oppure utilizzare Sfoglia per cercare il computer.

  5. Fare clic su OK.

  6. Nella finestra di dialogo Aggiungi o rimuovi snap-in fare clic su OK.

Ulteriori riferimenti

  • Panoramica di Configurazione host sessione Desktop remoto

  • Connettersi a un altro server Host sessione Desktop remoto mediante Configurazione host sessione Desktop remoto


Connettersi a un altro server Host sessione Desktop remoto mediante Configurazione host sessione Desktop remoto

In Windows Server 2008 R2 è possibile utilizzare Configurazione host sessione Desktop remoto per configurare le impostazioni nel server Host sessione Desktop remoto locale oppure connettersi a un altro server Host sessione Desktop remoto e configurare le impostazioni del server Host sessione Desktop remoto in remoto.

Importante

È possibile utilizzare Configurazione host sessione Desktop remoto in Windows Server 2008 R2 solo per configurare un server Host sessione Desktop remoto che esegue Windows Server 2008 o Windows Server 2008 R2.

Per connettersi a un altro server Host sessione Desktop remoto mediante Configurazione host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Scegliere Connetti al server Host sessione Desktop remoto dal menu Azione.

  3. Nella finestra di dialogo Selezione computer selezionare Altro computer, digitare il nome del computer nella casella o fare clic su Sfoglia per individuare il computer e quindi fare clic su OK.

Ulteriori riferimenti

  • Panoramica di Configurazione host sessione Desktop remoto

  • Eseguire Configurazione host sessione Desktop remoto


Desktop remoto per amministrazione

È possibile utilizzare Configurazione host sessione Desktop remoto anche in un computer in cui non è installato il servizio ruolo Host sessione Desktop remoto. Se il servizio ruolo Host sessione Desktop remoto non è installato, in Il computer è configurato per Desktop remoto per amministrazione verrà visualizzato il riquadro dei risultati di Configurazione host sessione Desktop remoto.

Di seguito sono illustrati i limiti di Desktop remoto per amministrazione:

  • La connessione predefinita (RDP-Tcp) consente solo due connessioni remote simultanee.

  • Le impostazioni di gestione licenze non possono essere configurate.

  • Le impostazioni di Gestore connessione Desktop remoto non possono essere configurate.

  • La modalità di accesso utente non può essere configurata.

Per rimuovere questi limiti, è necessario installare il servizio ruolo Host sessione Desktop remoto nel computer. Per ulteriori informazioni sull'installazione del servizio ruolo Host sessione Desktop remoto, vedere Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto.

Ulteriori riferimenti

  • Panoramica di Configurazione host sessione Desktop remoto

  • Configurare il numero di connessioni remote simultanee consentite per una connessione

  • Configurare le impostazioni relative alle licenze per un server Host sessione Desktop remoto

  • Configurare le impostazioni di Gestore connessione Desktop remoto per un server Host sessione Desktop remoto

  • Negare nuovi accessi utente a un server Host sessione Desktop remoto


Configurare le connessioni di Servizi Desktop remoto

In questa sezione vengono descritte le procedure per la configurazione delle connessioni di Servizi Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto

  • Configurare le impostazioni client per le connessioni di Servizi Desktop remoto

  • Configurare le impostazioni di sessione per le connessioni di Servizi Desktop remoto

Ulteriori riferimenti

  • Gestire le connessioni di Servizi Desktop remoto


Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto

In questa sezione vengono descritte le procedure per la configurazione delle impostazioni di sicurezza relative alle connessioni di Servizi Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Configurare i livelli di crittografia e autenticazione del server

  • Configurare Autenticazione a livello di rete per le connessioni di Servizi Desktop remoto

  • Configurare le informazioni di accesso client per le connessioni di Servizi Desktop remoto

  • Configurare le autorizzazioni per le connessioni di Servizi Desktop remoto

Ulteriori riferimenti

  • Configurare le connessioni di Servizi Desktop remoto

  • Gestire le connessioni di Servizi Desktop remoto


Configurare i livelli di crittografia e autenticazione del server

Per impostazione predefinita, Servizi Desktop remoto le sessioni vengono configurate per la negoziazione del livello di crittografia dal client al server Host sessione Desktop remoto. È possibile migliorare la sicurezza delle sessioni Servizi Desktop remoto richiedendo l'utilizzo di Transport Layer Security (TLS) 1.0. TLS 1.0 verifica l'identità del server Host sessione Desktop remoto e crittografa tutte le comunicazioni tra il server Host sessione Desktop remoto e il computer client. Per migliorare la sicurezza è necessario configurare correttamente il server Host sessione Desktop remoto e il computer client per TLS.

Nota

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.

Sono disponibili tre livelli di sicurezza.

Livello di sicurezza | Descrizione
SSL (TLS 1.0) | SSL (TLS 1.0) viene utilizzato per l'autenticazione del server e la crittografia di tutti i dati trasferiti tra il server e il client.
Con negoziazione | Questa è l'impostazione predefinita. Viene utilizzato il livello più sicuro supportato dal client. Se supportato, viene utilizzato SSL (TLS 1.0). Se il client non supporta SSL (TLS 1.0), verrà utilizzato il livello di sicurezza RDP.
Livello di sicurezza RDP | Per le comunicazioni tra server e client viene utilizzata la crittografia nativa RDP. Se si seleziona il livello di sicurezza RDP, non sarà possibile utilizzare Autenticazione a livello di rete.

Per utilizzare il livello di sicurezza TLS 1.0 è necessario un certificato, che consente di verificare l'identità del server Host sessione Desktop remoto e di crittografare la comunicazione tra il server Host sessione Desktop remoto e il client. È possibile selezionare un certificato installato nel server Host sessione Desktop remoto oppure utilizzare un certificato autofirmato.

Attenzione

È consigliabile ottenere e installare un certificato emesso da un'Autorità di certificazione pubblica attendibile che partecipa al programma Microsoft Root Certificate.

Per impostazione predefinita, le connessioni di Servizi Desktop remoto vengono crittografate al massimo livello di sicurezza disponibile. Alcune versioni precedenti del client di Connessione Desktop remoto non supportano tuttavia questo livello elevato di crittografia. Se la rete in uso include client legacy, è possibile impostare il livello di crittografia della connessione per l'invio e la ricezione dei dati al livello di crittografia massimo supportato dal client.

Sono disponibili quattro livelli di crittografia.

Livello di crittografia | Descrizione
FIPS compatibile | Questo livello crittografa e decrittografa i dati inviati dal client al server e viceversa utilizzando metodi di crittografia convalidati dal Federal Information Process Standard (FIPS) 140-1. I client che non supportano questo livello di crittografia non possono connettersi.
Alta | Questo livello crittografa i dati inviati dal client al server e viceversa utilizzando la crittografia a 128 bit. Utilizzare questo livello quando il server Host sessione Desktop remoto viene eseguito in un ambiente che include solo client a 128 bit, ad esempio client di Connessione desktop remoto. I client che non supportano questo livello di crittografia non possono connettersi.
Compatibile con client | Questa è l'impostazione predefinita. Questo livello crittografa i dati inviati dal client al server e viceversa alla forza massima della chiave supportata dal client. Utilizzare questo livello quando il server Host sessione Desktop remoto viene eseguito in un ambiente che include client misti o legacy.
Bassa | Questo livello crittografa i dati inviati dal client al server utilizzando la crittografia a 56 bit. I dati inviati dal server al client non vengono crittografati.

Per configurare le impostazioni di autenticazione e crittografia del server per una connessione nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni di crittografia e autenticazione del server per una connessione

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella scheda Generale della finestra di dialogo Proprietà relativa alla connessione selezionare le impostazioni di autenticazione e crittografia del server appropriate per l'ambiente in uso in base ai requisiti e al livello di sicurezza supportati dai computer client.

  4. Se si seleziona SSL (TLS 1.0), selezionare un certificato installato nel server Host sessione Desktop remoto o fare clic su Predefinito per generare un certificato autofirmato. Se si utilizza un certificato autofirmato, il nome del certificato verrà visualizzato come Generato automaticamente.

  5. Fare clic su OK.

È inoltre possibile configurare le impostazioni di crittografia e autenticazione del server applicando le impostazioni di Criteri di gruppo seguenti:

  • Imposta livello di crittografia connessione client

  • Richiedi l'utilizzo di un livello di protezione specificato per le connessioni remote (RDP)

  • Modello di certificato di autenticazione Server

  • Richiedi autenticazione utente per le connessioni remote tramite Autenticazione a livello di rete

Queste impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e possono essere configurate mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che queste impostazioni di Criteri di gruppo avranno la priorità sulle impostazioni configurate in Configurazione host sessione Desktop remoto, ad eccezione dell'impostazione Modello di certificato di autenticazione Server.

È possibile configurare il server Host sessione Desktop remoto per l'utilizzo del livello di crittografia FIPS applicando l'impostazione di Criteri di gruppo Crittografia di sistema: utilizza algoritmi FIPS compatibili per crittografia, hash e firma. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Criteri\Impostazioni di Windows\Impostazioni di protezione\Criteri locali\Opzioni di protezione e può essere configurata utilizzando l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che questa impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto e sull'impostazione Imposta livello di crittografia connessione client.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto

  • Configurare Autenticazione a livello di rete per le connessioni di Servizi Desktop remoto


Configurare Autenticazione a livello di rete per le connessioni di Servizi Desktop remoto

Autenticazione a livello di rete è un metodo di autenticazione che può essere utilizzato per migliorare la sicurezza del server Host sessione Desktop remoto richiedendo l'autenticazione dell'utente nel server Host sessione Desktop remoto prima della creazione di una sessione.

Questo metodo consente di completare l'autenticazione dell'utente prima che venga stabilita una connessione desktop remoto e che venga visualizzata la schermata di accesso. Si tratta di un metodo di autenticazione più sicuro che contribuisce a proteggere il computer remoto da utenti malintenzionati e software dannoso. Autenticazione a livello di rete offre i vantaggi seguenti:

  • Richiede un minore dispendio iniziale di risorse per il computer remoto. Il computer remoto utilizza una quantità limitata di risorse prima di eseguire l'autenticazione dell'utente, anziché avviare una connessione desktop remoto completa come accade nelle versioni precedenti.

  • Offre un migliore livello di sicurezza, riducendo il rischio di attacchi Denial of Service.

Per poter utilizzare Autenticazione a livello di rete, devono essere soddisfatti i requisiti seguenti:

  • Il computer client deve utilizzare almeno Connessione desktop remoto 6.0.

  • Il computer client deve utilizzare un sistema operativo, ad esempio Windows 7, Microsoft Windows Vista o Windows XP con Service Pack 3, che supporta il protocollo CredSSP (Credential Security Support Provider).

  • È necessario che il server Host sessione Desktop remoto esegua Windows Server 2008 R2 o Windows Server 2008.

Per configurare Autenticazione a livello di rete per una connessione, eseguire la procedura seguente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare Autenticazione a livello di rete per una connessione

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella scheda Generale selezionare la casella di controllo Consenti connessioni solo da computer che eseguono Desktop remoto con Autenticazione a livello di rete.

    Se la casella di controllo Consenti connessioni solo da computer che eseguono Desktop remoto con Autenticazione a livello di rete è selezionata e non è attivata, l'impostazione di Criteri di gruppo Richiedi autenticazione utente tramite Autenticazione a livello di rete per le connessioni remote è stata attivata e applicata al server Host sessione Desktop remoto.

  4. Fare clic su OK.

L'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto può inoltre essere configurata nei modi seguenti:

  • Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto dell'Aggiunta guidata ruoli.

  • Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto.

    Se l'opzione Consenti connessioni dai computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro) non è selezionata e non è attivata, l'impostazione di Criteri di gruppo Richiedi autenticazione utente tramite Autenticazione a livello di rete per le connessioni remote è stata attivata e applicata al server Host sessione Desktop remoto.

    Per configurare l'impostazione Autenticazione a livello di rete tramite la scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto, vedere Modificare le impostazioni di connessione remota.

  • Applicando l'impostazione di Criteri di gruppo Richiedi autenticazione utente tramite Autenticazione a livello di rete per le connessioni remote.

    Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto o nella scheda Connessione remota.

Per determinare se un computer esegue una versione di Connessione desktop remoto che supporta Autenticazione a livello di rete, avviare Connessione desktop remoto, fare clic sull'icona nell'angolo superiore sinistro della finestra di dialogo Connessione desktop remoto e quindi su Informazioni su. Cercare la frase Autenticazione a livello di rete supportata nella finestra di dialogo Informazioni su Connessione desktop remoto.

Per ulteriori informazioni su Servizi Desktop remoto, vedere la pagina corrispondente nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto


Configurare le informazioni di accesso client per le connessioni di Servizi Desktop remoto

Per connettersi in remoto a un server Host sessione Desktop remoto, l'utente deve specificare le credenziali necessarie per l'autenticazione e per consentire al server Host sessione Desktop remoto di determinare le azioni che l'utente è autorizzato a eseguire.

Per impostazione predefinita, una connessione utilizzerà le informazioni di accesso specificate dall'utente quando quest'ultimo utilizza Connessione desktop remoto per la connessione in remoto al server Host sessione Desktop remoto.

Invece di utilizzare le informazioni di accesso fornite dal client, è possibile specificare le informazioni di accesso da utilizzare per la connessione nella scheda Impostazioni di accesso della finestra di dialogo Proprietà della connessione.

È inoltre possibile specificare di richiedere sempre all'utente l'immissione di una password quando si connette al server Host sessione Desktop remoto, anche se Connessione desktop remoto è stato configurato per l'utilizzo delle credenziali salvate durante la connessione al server Host sessione Desktop remoto.

Per configurare le impostazioni di accesso di una connessione, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni di accesso di una connessione

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà della connessione fare clic sulla scheda Impostazioni di accesso, configurare le impostazioni di accesso appropriate per l'ambiente in uso e quindi fare clic su OK.

    Nota

    Se la casella di controllo Richiedi sempre password è selezionata e visualizzata in grigio, l'impostazione di Criteri di gruppo Richiedi sempre password alla connessione è stata attivata e applicata al server Host sessione Desktop remoto.

È inoltre possibile specificare di richiedere sempre all'utente l'immissione di una password quando si connette in remoto a un server Host sessione Desktop remoto applicando l'impostazione di Criteri di gruppo Richiedi sempre password alla connessione. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per ulteriori informazioni su Servizi Desktop remoto, vedere la pagina corrispondente nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Ulteriori riferimenti

  • Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto


Configurare le autorizzazioni per le connessioni di Servizi Desktop remoto

Le autorizzazioni di Servizi Desktop remoto vengono utilizzate per controllare gli utenti o i gruppi che possono eseguire attività specifiche nel server Host sessione Desktop remoto, ad esempio accedere al server Host sessione Desktop remoto o controllare in remoto una sessione utente. È possibile gestire le autorizzazioni per singole connessioni in Configurazione host sessione Desktop remoto.

Nota

Per controllare gli utenti che possono connettersi in remoto al server Host sessione Desktop remoto, è consigliabile modificare il gruppo Utenti desktop remoto. Per ulteriori informazioni sulla modifica del gruppo Utenti desktop remoto, vedere Configurare il gruppo Utenti desktop remoto.

Le autorizzazioni di connessione impostate in Configurazione host sessione Desktop remoto determinano inoltre le azioni che possono essere eseguite da un utente specifico in Gestione Servizi Desktop remoto. Ad esempio, un utente deve disporre almeno dell'autorizzazione di accesso speciale Controllo remoto per controllare in remoto una sessione utente tramite Gestione Servizi Desktop remoto.

Di seguito vengono elencate le autorizzazioni che possono essere impostate in Configurazione host sessione Desktop remoto e vengono descritte le funzionalità offerte da ogni autorizzazione.

Autorizzazione | Funzionalità
Ricerca di informazioni | Esecuzione di query per informazioni su sessioni e server Host sessione Desktop remoto
Imposta informazioni | Configurazione delle proprietà della connessione
Controllo remoto | Visualizzazione o controllo attivo della sessione di un altro utente
Accesso | Accesso a una sessione nel server Host sessione Desktop remoto
Disconnessione | Chiusura della sessione di un utente
Messaggio | Invio di un messaggio a una sessione utente
Connetti | Connessione alla sessione di un altro utente
Disconnetti | Disconnessione di una sessione utente
Canali virtuali | Utilizzo di un canale virtuale in una sessione per il reindirizzamento di un dispositivo e una risorsa locali

Per impostazione predefinita il gruppo Utenti desktop remoto dispone delle autorizzazioni seguenti: Ricerca di informazioni, Accesso e Connetti.

Sono disponibili tre set di autorizzazioni standard preconfigurate:

  • Controllo completo

  • Accesso utente

  • Accesso guest

Di seguito vengono elencate le autorizzazioni associate a ogni set di autorizzazioni standard preconfigurate.

Set di autorizzazioni | Autorizzazioni assegnate
Controllo completo | Richiesta di informazioni, Imposta informazioni, Controllo remoto, Accesso, Disconnessione, Messaggio, Connetti, Disconnetti, Canali virtuali
Accesso utente | Richiesta di informazioni, Accesso, Connetti
Accesso guest | Accesso

Per configurare le autorizzazioni di una connessione, eseguire la procedura seguente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le autorizzazioni di una connessione

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà della connessione fare clic sulla scheda Sicurezza, configurare le autorizzazioni appropriate per l'ambiente in uso e quindi fare clic su OK.

È possibile impedire agli amministratori di modificare le autorizzazioni per una connessione applicando l'impostazione di Criteri di gruppo Non consentire agli amministratori locali di personalizzare le autorizzazioni. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per ulteriori informazioni su Servizi Desktop remoto, vedere la pagina corrispondente nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Ulteriori riferimenti

  • Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto


Configurare le impostazioni client per le connessioni di Servizi Desktop remoto

In questa sezione vengono descritte le procedure per la configurazione delle impostazioni client relative alle connessioni di Servizi Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Rendere disponibili dispositivi e risorse locali in una sessione remota

  • Specificare l'avvio automatico di un programma quando l'utente esegue l'accesso

  • Configurare l'intensità del colore massima per una sessione remota

  • Configurare le impostazioni del monitor per una sessione remota

Ulteriori riferimenti

  • Configurare le connessioni di Servizi Desktop remoto

  • Gestire le connessioni di Servizi Desktop remoto


Rendere disponibili dispositivi e risorse locali in una sessione remota

Servizi Desktop remoto consente agli utenti di accedere ai dispositivi e alle risorse locali in sessioni remote. Gli utenti possono accedere a risorse quali unità locali, stampanti, gli Appunti e dispositivi Plug and Play supportati. Ciò viene in genere definito reindirizzamento.

In Windows Server 2008 e in Windows Server 2008 R2 il reindirizzamento è stato migliorato e ampliato. È ora possibile reindirizzare i dispositivi portatili Windows, in particolare i lettori multimediali basati sul protocollo MTP (Media Transfer Protocol) e le fotocamere digitali basate sul protocollo PTP (Picture Transfer Protocol).

Gli utenti possono specificare i tipi di dispositivi e risorse che desiderano reindirizzare al computer remoto nella scheda Risorse locali di Connessione desktop remoto.

È possibile specificare i dispositivi e le risorse locali che saranno disponibili agli utenti di sessioni remote utilizzando una connessione nel server Host sessione Desktop remoto. È possibile attivare o disattivare il reindirizzamento degli elementi seguenti:

  • Unità

  • Stampanti

  • Porta LPT

  • Porta COM

  • Appunti

  • Audio

  • Dispositivi Plug and Play supportati

Nota

Servizi Desktop remoto in Windows Server 2008 R2 supporta il reindirizzamento di alcuni dispositivi Plug and Play supportati aggiuntivi. Tra questi dispositivi non sono inclusi i diversi tipi di dispositivi Plug and Play già supportati in altre categorie, ad esempio Unità, Stampanti o Smart card. Una chiavetta USB installata come lettera di unità nel computer client verrà ad esempio elencata per il reindirizzamento nella categoria Unità e una stampante Plug and Play USB connessa al computer client verrà reindirizzata nella categoria Stampanti.

Se si disattiva il reindirizzamento degli Appunti, ad esempio, gli utenti che si connettono in remoto al server Host sessione Desktop remoto mediante questa connessione non saranno in grado di reindirizzare gli Appunti nella sessione remota, anche se selezionano la casella di controllo Appunti in Opzioni nella scheda Risorse locali di Connessione desktop remoto. Se si attiva il reindirizzamento di un dispositivo o una risorsa locale nel server Host sessione Desktop remoto, gli utenti dovranno comunque specificare che desiderano reindirizzare tale tipo di dispositivo o risorsa locale effettuando la selezione appropriata in Opzioni nella scheda Risorse locali di Connessione desktop remoto.

Per attivare o disattivare il reindirizzamento di dispositivi e risorse locali per la connessione nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare o disattivare il reindirizzamento di dispositivi e risorse locali

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà della connessione fare clic sulla scheda Impostazioni client.

  4. In Reindirizzamento eseguire una delle operazioni seguenti per una determinata categoria di dispositivi o risorse locali:

    • Selezionare la casella di controllo per disattivare il reindirizzamento di quel tipo di dispositivo o risorsa locale.

    • Deselezionare la casella di controllo per attivare il reindirizzamento di quel tipo di dispositivo o risorsa locale.

  5. Fare clic su OK.

È inoltre possibile configurare quali dispositivi e risorse locali sono disponibili agli utenti nelle sessioni remote applicando le impostazioni di Criteri di gruppo.

Nell'elenco seguente sono indicate alcune impostazioni di Criteri di gruppo specifiche per Servizi Desktop remoto correlate al reindirizzamento di dispositivi e risorse locali.

Nome dell'impostazione di Criteri di gruppo Percorso dell'impostazione di Criteri di gruppo

Consenti reindirizzamento riproduzione audio e video

Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse

Non consentire il reindirizzamento degli Appunti

Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse

Configurazione utente\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse

Non consentire il reindirizzamento della porta COM

Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse

Non consentire il reindirizzamento delle unità

Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse

Non consentire il reindirizzamento della porta LPT

Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse

Non consentire il reindirizzamento dei dispositivi Plug and Play supportati

Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse

Non consentire il reindirizzamento della stampante client

Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento stampante

Queste impostazioni di Criteri di gruppo possono essere configurate utilizzando l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo.

Nota

Tali impostazioni avranno la priorità sulle impostazioni configurate in Configurazione host sessione Desktop remoto e sulle impostazioni specificate dall'utente in Connessione desktop remoto. Se sono configurate sia le impostazioni del criterio Configurazione computer che quelle del criterio Configurazione utente, avranno la priorità le impostazioni del criterio Configurazione computer.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per ulteriori informazioni su Servizi Desktop remoto, vedere la pagina corrispondente nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Ulteriori riferimenti

  • Configurare le impostazioni client per le connessioni di Servizi Desktop remoto

  • Configurare il supporto per la stampante


Specificare l'avvio automatico di un programma quando l'utente esegue l'accesso

Per impostazione predefinita, le sessioni di Servizi Desktop remoto consentono di accedere all'intero desktop di Windows, a meno che non sia stato specificato l'avvio di un programma quando l'utente accede alla sessione remota.

Se si specifica l'avvio di un programma iniziale, l'utente potrà utilizzare solo tale programma nella sessione di Servizi Desktop remoto. Quando l'utente accede alla sessione remota il menu Start e il desktop di Windows non vengono visualizzati e quando l'utente chiude il programma la sessione viene disconnessa automaticamente.

Nota

L'impostazione dell'esecuzione di un programma iniziale non è applicabile alle sessioni di RemoteApp. Per ulteriori informazioni su RemoteApp, vedere l'argomento relativo alla panoramica di RemoteApp nella Guida di Gestione RemoteApp in Windows Server 2008 R2.

La configurazione dell'avvio di un programma iniziale per singole connessioni ha effetto su tutti gli utenti che utilizzano la connessione.

È possibile configurare l'avvio di un programma iniziale per singoli utenti utilizzando l'estensione di Servizi Desktop remoto allo snap-in Utenti e gruppi locali o allo snap-in Utenti e computer di Active Directory.

Le impostazioni di avvio di un programma iniziale configurate mediante Configurazione host sessione Desktop remoto avranno la priorità sulle impostazioni di avvio configurate per un account utente specifico o su quelle specificate dall'utente in Connessione desktop remoto.

Per specificare l'avvio di un programma quando l'utente accede a una sessione remota, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare l'avvio di un programma quando l'utente accede a una sessione remota

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella scheda Ambiente della finestra di dialogo Proprietà relativa alla connessione configurare le impostazioni di avvio del programma iniziale appropriate per l'ambiente in uso.

    Se si seleziona All'accesso utente avvia questo programma, eseguire le operazioni seguenti:

    1. Nella casella Percorso e nome file del programma immettere il percorso completo e il nome del file eseguibile da eseguire all'accesso dell'utente.

    2. Se necessario, nella casella Avvia in immettere il percorso completo della directory di avvio del programma.

      Nota

      Se la casella Avvia in è vuota, il programma viene eseguito dalla relativa directory di lavoro predefinita. Se il percorso, il nome file o la directory di lavoro del programma specificati non corrispondono al nome di una directory valida, la connessione server Host sessione Desktop remoto ha esito negativo e viene visualizzato un messaggio di errore.

  4. Fare clic su OK. Le modifiche apportate nella scheda Ambiente non vengono applicate alle sessioni connesse al momento della modifica. Le modifiche avranno effetto alla successiva connessione dell'utente al server Host sessione Desktop remoto.

È inoltre possibile configurare l'avvio di un programma o la visualizzazione del desktop all'accesso dell'utente a una sessione remota applicando le impostazioni di Criteri di gruppo seguenti:

  • Avvia un programma alla connessione

  • Mostra sempre desktop alla connessione

Queste impostazioni sono disponibili nei percorsi seguenti:

  • Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota

  • Configurazione utente\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota

Queste impostazioni di Criteri di gruppo possono essere configurate utilizzando l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo.

Nota

Le impostazioni di Criteri di gruppo avranno la priorità sulle impostazioni configurate in Configurazione host sessione Desktop remoto. Se sono configurate sia le impostazioni del criterio Configurazione computer che quelle del criterio Configurazione utente, avranno la priorità le impostazioni del criterio Configurazione computer. L'impostazione Mostra sempre desktop alla connessione avrà inoltre la priorità sull'impostazione Avvia un programma alla connessione.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per informazioni sull'avvio di un programma per singoli utenti, vedere l'argomento relativo alla scheda Ambiente delle proprietà <AccountUtente> nella Guida delle proprietà utente di Servizi Desktop remoto in Windows Server 2008 R2.

Ulteriori riferimenti

  • Configurare le impostazioni client per le connessioni di Servizi Desktop remoto

  • Configurare le impostazioni di sicurezza per le connessioni di Servizi Desktop remoto


Configurare l'intensità del colore massima per una sessione remota

È possibile specificare la risoluzione colore massima (intensità del colore) per una sessione remota. Limitando l'intensità del colore è possibile migliorare le prestazioni della connessione, soprattutto in presenza di collegamenti lenti, e ridurre il carico del server.

L'intensità del colore effettiva per la connessione è determinata dal supporto per i colori disponibile nel computer client. L'utente può inoltre specificare l'intensità di colore per la connessione nella scheda Schermo in Colori in Connessione desktop remoto, ma tale valore non può essere superiore al valore configurato nel server Host sessione Desktop remoto.

Per specificare l'intensità del colore massima per una sessione remota, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare l'intensità del colore massima per una sessione remota

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella scheda Impostazioni client della finestra di dialogo Proprietà selezionare la casella di controllo Limite intensità di colore massima e quindi selezionare il valore appropriato per l'ambiente in uso.

    Il valore predefinito è 32 bit per pixel. Un'intensità del colore pari a 24 bit per pixel è supportata solo in Windows XP Professional e Windows Server 2003.

  4. Fare clic su OK. Quando si apporta una modifica alle impostazioni dell'intensità del colore, questa non verrà applicata alle sessioni connesse al momento della modifica. Le modifiche avranno effetto alla successiva connessione dell'utente al server Host sessione Desktop remoto.
Nota

È inoltre possibile impostare l'intensità di colore massima per una sessione remota applicando l'impostazione di Criteri di gruppo Limita intensità colore massima. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare le impostazioni client per le connessioni di Servizi Desktop remoto


Configurare le impostazioni del monitor per una sessione remota

È possibile specificare le impostazioni del monitor o il numero di monitor disponibili per una sessione remota. Limitando il numero di monitor è possibile migliorare le prestazioni della connessione, soprattutto in presenza di collegamenti lenti, e ridurre il carico del server.

Il numero effettivo di monitor disponibili per la connessione è determinato dal numero di monitor disponibili nel computer client. L'utente può inoltre specificare che desidera utilizzare tutti i monitor per la connessione nella scheda Schermo in Configurazione schermo in Connessione desktop remoto, ma il numero di monitor specificato non può essere superiore al valore configurato nel server Host sessione Desktop remoto.

Per specificare il numero di monitor per una sessione remota, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare il numero di monitor per una sessione remota

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà della connessione fare clic sulla scheda Impostazioni client.

  4. In Impostazioni monitor, nella casella Limita numero massimo di monitor per sessione, immettere il numero di monitor disponibili per il client.

    Nota

    Composizione desktop o Aero Glass non verranno attivati nel client Desktop remoto se quest'ultimo utilizza più monitor. Composizione desktop viene attivato solo se il client Desktop remoto utilizza un singolo monitor.

  5. Fare clic su OK. Quando si apportano modifiche alle impostazioni del monitor, queste non vengono applicate alle sessioni connesse al momento della modifica. Le modifiche avranno effetto alla successiva connessione dell'utente al server Host sessione Desktop remoto.
Nota

È inoltre possibile specificare il numero di monitor per una sessione remota applicando l'impostazione di Criteri di gruppo Limita numero massimo di monitor per sessione. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare le impostazioni client per le connessioni di Servizi Desktop remoto


Configurare le impostazioni di sessione per le connessioni di Servizi Desktop remoto

In questa sezione vengono descritte procedure per la configurazione delle impostazioni di sessione relative alle connessioni di Servizi Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Configurare le impostazioni di timeout e riconnessione per le sessioni di Servizi Desktop remoto

  • Configurare le impostazioni di controllo remoto per le sessioni di Servizi Desktop remoto

Ulteriori riferimenti

  • Configurare le connessioni di Servizi Desktop remoto

  • Gestire le connessioni di Servizi Desktop remoto


Configurare le impostazioni di timeout e riconnessione per le sessioni di Servizi Desktop remoto

Per impostazione predefinita, Servizi Desktop remoto consente agli utenti di disconnettersi da una sessione remota senza terminare la sessione. Quando una sessione è in stato disconnesso, i programmi in esecuzione rimangono attivi anche quando l'utente non è più connesso attivamente.

È possibile limitare il tempo in cui sessioni attive, disconnesse e inattive (senza input da parte dell'utente) rimangono nel server. Questa operazione è utile perché le sessioni che rimangono in esecuzione a tempo indeterminato nel server Host sessione Desktop remoto continuano a utilizzare le risorse di sistema.

La configurazione delle impostazioni di timeout e riconnessione per singole connessioni ha effetto su tutte le sessioni che utilizzano la connessione.

È possibile configurare le impostazioni di timeout e riconnessione per singoli utenti utilizzando l'estensione di Servizi Desktop remoto allo snap-in Utenti e gruppi locali o allo snap-in Utenti e computer di Active Directory.

Le impostazioni di timeout e riconnessione configurate tramite Configurazione host sessione Desktop remoto avranno la priorità sulle impostazioni di timeout e riconnessione configurate per un account utente specifico.

È possibile configurare le impostazioni di timeout e riconnessione seguenti in Configurazione host sessione Desktop remoto.

Impostazione Dettagli

Termina sessione disconnessa

Specificare il periodo di tempo massimo durante il quale una sessione utente disconnessa rimane attiva nel server Host sessione Desktop remoto. Se si specifica "Mai", la sessione disconnessa dell'utente viene mantenuta per un periodo di tempo illimitato.

Quando una sessione è in stato disconnesso, i programmi in esecuzione rimangono attivi anche quando l'utente non è più connesso attivamente.

Limite sessione attiva

Specificare il periodo di tempo massimo durante il quale la sessione di Servizi Desktop remoto dell'utente può essere attiva prima di venire disconnessa o terminata automaticamente.

Due minuti prima della disconnessione o dell'interruzione della sessione di Servizi Desktop remoto viene visualizzato un avviso, in modo da consentire all'utente di salvare i file aperti e chiudere i programmi in esecuzione.

Limite sessione inattiva

Specificare il periodo di tempo massimo durante il quale una sessione attiva di Servizi Desktop remoto può essere inattiva (senza input da parte dell'utente) prima di venire disconnessa o terminata automaticamente.

Due minuti prima della disconnessione o dell'interruzione della sessione viene visualizzato un avviso, in modo da consentire all'utente di premere un tasto o di muovere il mouse per mantenere attiva la sessione.

Quando si raggiunge un limite di sessione o la connessione è interrotta

Specificare se si desidera disconnettere o terminare la sessione di Servizi Desktop remoto dell'utente quando viene raggiunto il limite di sessione attiva o inattiva.

Se la sessione viene disconnessa, i programmi in esecuzione rimangono attivi anche se l'utente non è più connesso attivamente.

Se la sessione viene terminata, l'utente dovrà stabilire una nuova sessione di Servizi Desktop remoto con un server Host sessione Desktop remoto.

Per specificare le impostazioni di timeout e riconnessione per una sessione remota, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare le impostazioni di timeout e riconnessione per una sessione remota

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella scheda Sessioni della finestra di dialogo Proprietà relativa alla connessione selezionare le opzioni seguenti in base alle proprie esigenze:

    • Selezionare la casella di controllo Ignora impostazioni utente e quindi configurare le impostazioni di timeout per Termina sessione disconnessa, Limite sessione attiva e Limite sessione inattiva.

    • Selezionare la casella di controllo Ignora impostazioni utente e quindi una delle impostazioni di riconnessione seguenti: Disconnetti dalla sessione o Termina sessione.

  4. Fare clic su OK. Quando si apportano modifiche alle impostazioni di timeout e riconnessione, queste non verranno applicate alle sessioni connesse al momento della modifica. Le modifiche avranno effetto alla successiva connessione dell'utente al server Host sessione Desktop remoto.

È inoltre possibile configurare le impostazioni di timeout e riconnessione applicando le impostazioni di Criteri di gruppo seguenti:

  • Imposta limite di tempo per le sessioni disconnesse

  • Imposta limite di tempo per le sessioni di Servizi Desktop remoto attive ma in attesa

  • Imposta limite di tempo per le sessioni di Servizi Desktop remoto attive

  • Termina la sessione quando si raggiungono i limiti di tempo

Queste impostazioni sono disponibili nei percorsi seguenti:

  • Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Limiti di tempo sessioni

  • Configurazione utente\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Limiti di tempo sessioni

Queste impostazioni di Criteri di gruppo possono essere configurate utilizzando l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo.

Nota

Le impostazioni di Criteri di gruppo avranno la priorità sulle impostazioni configurate in Configurazione host sessione Desktop remoto. Se sono configurate sia le impostazioni del criterio Configurazione computer che quelle del criterio Configurazione utente, avranno la priorità le impostazioni del criterio Configurazione computer.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per informazioni sulla configurazione delle impostazioni di timeout e riconnessione per singoli utenti, vedere l'argomento relativo alla scheda Sessioni delle proprietà <AccountUtente> nella Guida delle proprietà utente di Servizi Desktop remoto in Windows Server 2008 R2..

Ulteriori riferimenti

  • Configurare le impostazioni di sessione per le connessioni di Servizi Desktop remoto


Configurare le impostazioni di controllo remoto per le sessioni di Servizi Desktop remoto

È possibile monitorare le azioni di un client connesso a un server Host sessione Desktop remoto mediante il controllo remoto da un'altra sessione. Grazie al controllo remoto è possibile osservare o controllare attivamente una sessione client. Se si sceglie di controllare attivamente una sessione client, sarà possibile specificare azioni da eseguire tramite tastiera e mouse nella sessione. È possibile informare un client che si desidera controllare in remoto la relativa sessione scegliendo di visualizzare un messaggio nel client che richiede l'autorizzazione per visualizzare la sessione o parteciparvi.

La configurazione del controllo remoto per singole connessioni ha effetto su tutte le sessioni che utilizzano la connessione. Per impostazione predefinita il controllo remoto non è consentito.

È possibile configurare il controllo remoto per singoli utenti utilizzando l'estensione di Servizi Desktop remoto allo snap-in Utenti e gruppi locali o allo snap-in Utenti e computer di Active Directory.

Le impostazioni di controllo remoto configurate tramite Configurazione host sessione Desktop remoto avranno la priorità sulle impostazioni configurate per un account utente specifico.

Per specificare le impostazioni di controllo remoto per una sessione remota, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare le impostazioni di controllo remoto per una sessione remota

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella scheda Controllo remoto della finestra di dialogo Proprietà relativa alla connessione selezionare una delle opzioni seguenti:

    • Per utilizzare le impostazioni di controllo remoto specificate per l'account utente, selezionare Usa controllo remoto con impostazioni predefinite utente. L'impostazione predefinita per un account utente prevede che gli utenti che esercitano il controllo remoto abbiano il controllo completo della sessione se l'utente concede l'autorizzazione.

    • Per disattivare le sessioni di controllo remoto, selezionare Non consentire controllo remoto.

    • Per specificare le impostazioni di controllo remoto relative alla connessione, selezionare Usa il controllo remoto con le seguenti impostazioni. Per richiedere l'autorizzazione utente prima che la sessione di controllo remoto venga attivata, selezionare la casella di controllo Autorizzazione utente necessaria e quindi selezionare una delle opzioni seguenti:

      • Per consentire alla sessione di controllo remoto solo di visualizzare la sessione remota, fare clic su Visualizza sessione.

      • Per consentire alla sessione di controllo remoto di interagire con la sessione remota, fare clic su Interazione con la sessione.

  4. Fare clic su OK. Quando si apporta una modifica alle impostazioni di controllo remoto, questa non verrà applicata alle sessioni connesse al momento della modifica. Le modifiche avranno effetto alla successiva connessione dell'utente al server Host sessione Desktop remoto.

È inoltre possibile configurare le impostazioni di controllo remoto applicando l'impostazione di Criteri di gruppo Imposta regole per il controllo remoto delle sessioni del server Host sessione Desktop remoto. Questa impostazione è disponibile nei percorsi seguenti:

  • Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Connessioni

  • Configurazione utente\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Connessioni

Questa impostazione di Criteri di gruppo può essere configurata utilizzando l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo.

Nota

L'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto. Se sono configurate sia le impostazioni del criterio Configurazione computer che quelle del criterio Configurazione utente, avrà la priorità l'impostazione del criterio Configurazione computer.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per informazioni su come controllare in remoto una sessione utente, vedere l'argomento relativo al controllo remoto di una sessione utente nella Guida di Gestione Servizi Desktop remoto in Windows Server 2008 R2.

Per informazioni sulla configurazione delle impostazioni di controllo remoto per singoli utenti, vedere l'argomento relativo alla scheda Controllo remoto delle proprietà <AccountUtente> nella Guida delle proprietà utente di Servizi Desktop remoto in Windows Server 2008 R2.

Ulteriori riferimenti

  • Configurare le impostazioni di sessione per le connessioni di Servizi Desktop remoto


Configurare le impostazioni di un server Host sessione Desktop remoto

In questa sezione vengono descritte le procedure per la configurazione delle impostazioni del server Host sessione Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Limitare gli utenti a una singola sessione

  • Configurare cartelle temporanee per un server Host sessione Desktop remoto

  • Negare nuovi accessi utente a un server Host sessione Desktop remoto

  • Configurare le impostazioni relative alle licenze per un server Host sessione Desktop remoto

  • Configurare Virtualizzazione IP di Desktop remoto

  • Configurare il supporto per la stampante

  • Configurare le impostazioni di Gestore connessione Desktop remoto per un server Host sessione Desktop remoto


Limitare gli utenti a una singola sessione

Per migliorare le prestazioni del server Host sessione Desktop remoto, è possibile limitare gli utenti a una singola sessione attiva o disconnessa. In questo modo si riduce il numero di sessioni remote create nel server Host sessione Desktop remoto e si risparmiano risorse di sistema sul server Host sessione Desktop remoto, consentendo a più utenti di connettersi al server Host sessione Desktop remoto.

Se un server Host sessione Desktop remoto è configurato per limitare gli utenti a una singola sessione e l'utente si disconnette dalla sessione, l'utente verrà riconnesso automaticamente a tale sessione la volta successiva che si connette al server Host sessione Desktop remoto.

Per impostazione predefinita, un server Host sessione Desktop remoto è configurato per limitare gli utenti a una singola sessione.

Per configurare l'impostazione Limita ogni utente a una singola sessione nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare l'impostazione Limita ogni utente a una singola sessione nel server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Nell'area Modifica impostazioni, in Generale, fare doppio clic su Limita ogni utente a una singola sessione.

  3. Nella scheda Generale della finestra di dialogo Proprietà selezionare o deselezionare la casella di controllo Limita ogni utente a una singola sessione in base all'impostazione più appropriata per l'ambiente in uso e quindi fare clic su OK.

È inoltre possibile limitare gli utenti a una singola sessione nel server Host sessione Desktop remoto attivando l'impostazione di Criteri di gruppo Limita gli utenti di Servizi Desktop remoto a una sola sessione remota. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Connessioni e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Se un utente specifica l'avvio di un programma diverso alla connessione al server Host sessione Desktop remoto, verrà creata una nuova sessione per l'utente nel server Host sessione Desktop remoto anche se il server Host sessione Desktop remoto è configurato per limitare gli utenti a una singola sessione. Un utente può specificare l'avvio di un programma alla connessione nella scheda Programmi in Opzioni di Connessione desktop remoto. È tuttavia possibile impedire agli utenti di avviare un programma alla connessione. Per ulteriori informazioni in proposito, vedere Specificare l'avvio automatico di un programma quando l'utente esegue l'accesso.

Ulteriori riferimenti

  • Configurare le impostazioni di un server Host sessione Desktop remoto


Configurare cartelle temporanee per un server Host sessione Desktop remoto

Per impostazione predefinita, Servizi Desktop remoto crea una cartella temporanea separata nel server Host sessione Desktop remoto per ogni sessione attiva gestita da un utente nel server Host sessione Desktop remoto. La cartella temporanea viene creata nel server Host sessione Desktop remoto in una cartella Temp all'interno della cartella del profilo dell'utente ed è denominata con l'ID sessione. In questa cartella temporanea vengono archiviati singoli file temporanei.

Per liberare spazio su disco, la cartella temporanea viene eliminata quando l'utente si disconnette da una sessione.

Per configurare cartelle temporanee nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare cartelle temporanee nel server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Nell'area Modifica impostazioni, in Generale, fare doppio clic su Rimuovi cartelle temporanee alla chiusura del programma o su Usa cartelle temporanee per sessione.

  3. Nella scheda Generale della finestra di dialogo Proprietà selezionare o deselezionare le caselle di controllo Rimuovi cartelle temporanee alla chiusura del programma e Usa cartelle temporanee per sessione in base all'impostazione appropriata per l'ambiente in uso e quindi fare clic su OK.

    Se si deseleziona la casella di controllo Usa cartelle temporanee per sessione, i file temporanei di un utente per tutte le sessioni nel Host sessione Desktop remoto vengono archiviati in una cartella Temp comune all'interno delle cartella del profilo dell'utente nel server Host sessione Desktop remoto.

È inoltre possibile configurare cartelle temporanee nel server Host sessione Desktop remoto utilizzando le impostazioni di Criteri di gruppo Non eliminare la cartella Temp all'uscita e Non utilizzare cartelle temporanee per sessione. Queste impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Cartelle temporanee e possono essere configurate mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare le impostazioni di un server Host sessione Desktop remoto


Negare nuovi accessi utente a un server Host sessione Desktop remoto

È possibile configurare la modalità di accesso utente nel server Host sessione Desktop remoto per impedire la creazione di nuove sessioni utente nel server Host sessione Desktop remoto. Tale funzionalità è stata rilasciata con Windows Server 2008.

Se si intende disconnettere il server Host sessione Desktop remoto per interventi di manutenzione o l'installazione di nuove applicazioni, è possibile impedire la creazione di nuove sessioni utente nel server Host sessione Desktop remoto.

È possibile specificare una delle impostazioni seguenti per la modalità di accesso utente:

  • Consenti tutte le connessioni. Per impostazione predefinita, questa impostazione è selezionata e rappresenta l'impostazione consigliata. In questo modo, gli utenti possono connettersi in remoto al server Host sessione Desktop remoto per stabilire una sessione remota.

  • Consenti le riconnessioni ma non i nuovi accessi. Se si seleziona questa impostazione, un utente con una sessione remota già esistente nel server Host sessione Desktop remoto può riconnettersi a tale sessione. Un nuovo utente, ovvero un utente senza una sessione remota nel server Host sessione Desktop remoto, non potrà invece connettersi al server Host sessione Desktop remoto. Se il server Host sessione Desktop remoto viene riavviato, nessun utente potrà connettersi al server Host sessione Desktop remoto.

  • Consenti le riconnessioni ma non i nuovi accessi fino al riavvio del server. Se si seleziona questa impostazione, un utente con una sessione remota già esistente nel server Host sessione Desktop remoto può riconnettersi a tale sessione. Un nuovo utente, ovvero un utente senza una sessione remota nel server Host sessione Desktop remoto, non potrà invece connettersi al server Host sessione Desktop remoto. Se il server Host sessione Desktop remoto viene riavviato, la modalità di accesso utente verrà impostata su Consenti tutte le connessioni e gli utenti potranno connettersi al server Host sessione Desktop remoto.

Per configurare la modalità di accesso utente nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare la modalità di accesso utente nel server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Nell'area Modifica impostazioni, in Generale, fare doppio clic su Modalità accesso utente.

  3. Nella scheda Generale della finestra di dialogo Proprietà selezionare l'impostazione della modalità di accesso utente più appropriata per l'ambiente in uso e quindi fare clic su OK.

È inoltre possibile digitare il comando change logon al prompt dei comandi per configurare la modalità di accesso utente nel server Host sessione Desktop remoto. Per ulteriori informazioni sugli strumenti da riga di comando per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138135.

Per impedire a tutti gli utenti, anche a quelli con sessioni remote nel server Host sessione Desktop remoto, di connettersi in remoto al server Host sessione Desktop remoto mediante una determinata connessione, è possibile disattivare la connessione. Per ulteriori informazioni sulla disattivazione di una connessione, vedere Disattivare una connessione di Servizi Desktop remoto.

Ulteriori riferimenti

  • Configurare le impostazioni di un server Host sessione Desktop remoto


Configurare le impostazioni relative alle licenze per un server Host sessione Desktop remoto

Ogni utente o dispositivo di elaborazione che si connette a un server Host sessione Desktop remoto deve disporre di una licenza CAL Servizi Desktop remoto valida rilasciata da un server licenze Desktop remoto.

Per garantire che un server Host sessione Desktop remoto possa contattare un server licenze Desktop remoto per richiedere le licenze CAL Servizi Desktop remoto relative ai client, nel server Host sessione Desktop remoto è necessario eseguire le operazioni seguenti:

  • Specificare la modalità di gestione licenze per un server Host sessione Desktop remoto

  • Specificare il server licenze che deve essere utilizzato da un server Host sessione Desktop remoto

Per essere informati di eventuali problemi di configurazione della gestione licenze, utilizzare Diagnosi gestione licenze in Configurazione host sessione Desktop remoto. Per ulteriori informazioni su Diagnosi gestione licenze, vedere Identificare possibili problemi di gestione licenze per il server Host sessione Desktop remoto.

Ulteriori riferimenti

  • Configurare le impostazioni di un server Host sessione Desktop remoto


Specificare la modalità di gestione licenze per un server Host sessione Desktop remoto

La modalità di gestione licenze di Desktop remoto determina il tipo di licenze CAL Servizi Desktop remoto richiesto da un server Host sessione Desktop remoto a un server licenze per conto di un client che si connette al server Host sessione Desktop remoto.

Importante

La modalità di gestione licenze di Desktop remoto configurata in un server Host sessione Desktop remoto deve corrispondere al tipo di licenze CAL Servizi Desktop remoto disponibile nel server licenze.

Esistono due tipi di licenze CAL Servizi Desktop remoto:

  • Licenza CAL Per dispositivo di Servizi Desktop remoto: consente a un dispositivo, utilizzato da qualsiasi utente, di connettersi a un server Host sessione Desktop remoto.

  • Licenza CAL Per utente di Servizi Desktop remoto: concede a un utente il diritto di accedere a server Host sessione Desktop remoto da un numero illimitato di dispositivi o computer client.

Per specificare la modalità di gestione licenze di Desktop remoto per il server Host sessione Desktop remoto utilizzando Configurazione host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare la modalità di gestione licenze di Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nell'area Modifica impostazioni, in Gestione licenze, fare doppio clic su Modalità di gestione licenze di Desktop remoto.

  4. Nella scheda Gestione licenze della finestra di dialogo Proprietà fare clic su Per dispositivo o su Per utente, a seconda dell'opzione che risulta più appropriata per l'ambiente in uso.

    Se le impostazioni di Modalità di gestione licenze di Desktop remoto sono visualizzate in grigio e non possono essere selezionate, l'impostazione di Criteri di gruppo Imposta la modalità Licenze Desktop remoto è stata attivata e applicata al server Host sessione Desktop remoto.

  5. Dopo aver specificato una modalità di gestione licenze di Desktop remoto, è necessario specificare un server licenze che deve essere utilizzato dal server Host sessione Desktop remoto. Per ulteriori informazioni, vedere Specificare il server licenze che deve essere utilizzato da un server Host sessione Desktop remoto.

  6. Fare clic su OK per salvare le modifiche alle impostazioni di gestione licenze.

La modalità di gestione licenze di Desktop remoto per il server Host sessione Desktop remoto può inoltre essere impostata nei modi seguenti:

  • Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, nella pagina Impostazione modalità di gestione licenze dell'Aggiunta guidata ruoli.

    Nella pagina Impostazione modalità di gestione licenze è possibile selezionare Configura in seguito se durante l'installazione si è indecisi tra l'impostazione Per Dispositivo o Per Utente. Se si seleziona Configura in seguito, ogni volta che si accede al server Host sessione Desktop remoto verrà visualizzato un messaggio nell'angolo inferiore destro del desktop per ricordare che è necessario configurare la modalità di gestione licenze per il server Host sessione Desktop remoto.

  • Applicando l'impostazione di Criteri di gruppo Imposta la modalità Licenze Desktop remoto.

    Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Gestione licenze e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

    Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

  • Utilizzando il modulo Servizi Desktop remoto per Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell con Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139898.

Per essere informati di eventuali problemi di configurazione della gestione licenze, utilizzare Diagnosi gestione licenze in Configurazione host sessione Desktop remoto. Per ulteriori informazioni su Diagnosi gestione licenze, vedere Identificare possibili problemi di gestione licenze per il server Host sessione Desktop remoto.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Ulteriori riferimenti

  • Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto


Specificare il server licenze che deve essere utilizzato da un server Host sessione Desktop remoto

Un server Host sessione Desktop remoto deve essere in grado di contattare un server licenze Desktop remoto al fine di richiedere licenze CAL Servizi Desktop remoto per gli utenti o i dispositivi di elaborazione che si connettono al server Host sessione Desktop remoto.

In Windows Server 2008 R2 è necessario specificare un server licenze che deve essere utilizzato dal server Host sessione Desktop remoto. L'individuazione automatica del server licenze non è più supportata per un server Host sessione Desktop remoto che esegue Windows Server 2008 R2.

Un server Host sessione Desktop remoto che esegue Windows Server 2008 R2 può contattare un server licenze che esegue Windows Server 2008 R2 o Windows Server 2008 per richiedere licenze CAL Servizi Desktop remoto.

Nota

Prima di specificare un server licenze che deve essere utilizzato dal server Host sessione Desktop remoto, è necessario specificare una modalità di gestione licenze di Desktop remoto. Per ulteriori informazioni, vedere Specificare la modalità di gestione licenze per un server Host sessione Desktop remoto.

Per specificare un server licenze che deve essere utilizzato dal server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare un server licenze che deve essere utilizzato dal server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nell'area Modifica impostazioni, in Gestione licenze, fare doppio clic su Server licenze Desktop remoto.

  4. Nella scheda Gestione licenze della finestra di dialogo Proprietà fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiungi server licenze selezionare un server licenze nell'elenco dei server di questo tipo noti e quindi fare clic su Aggiungi. Se il server licenze che si desidera aggiungere non è incluso nell'elenco, nella casella Nome o indirizzo IP del server licenze digitare il nome o l'indirizzo IP del server licenze da aggiungere e quindi fare clic su Aggiungi.

    È possibile aggiungere più server licenze che devono essere utilizzati dal server Host sessione Desktop remoto. Il server Host sessione Desktop remoto contatterà i server licenze nell'ordine in cui sono visualizzati nella casella Server licenze specificati.

  6. Fare clic su OK per chiudere la finestra di dialogo Aggiungi server licenze e quindi di nuovo su OK per salvare le modifiche relative alle impostazioni di gestione delle licenze.

È inoltre possibile specificare un server licenze che deve essere utilizzato dal server Host sessione Desktop remoto applicando l'impostazione di Criteri di gruppo Usa server licenze Desktop remoto specificati. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Gestione licenze e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sui server licenze configurati in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per configurare le impostazioni relative a Servizio licenze Desktop remoto è inoltre possibile utilizzare il modulo Servizi Desktop remoto per Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell con Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139898.

Per essere informati di eventuali problemi di configurazione della gestione licenze, utilizzare Diagnosi gestione licenze in Configurazione host sessione Desktop remoto. Per ulteriori informazioni su Diagnosi gestione licenze, vedere Identificare possibili problemi di gestione licenze per il server Host sessione Desktop remoto.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Ulteriori riferimenti

  • Configurare le impostazioni relative alle licenze per un server Host sessione Desktop remoto


Identificare possibili problemi di gestione licenze per il server Host sessione Desktop remoto

Configurazione host sessione Desktop remoto include lo strumento Diagnosi gestione licenze, che offre informazioni utili per identificare possibili problemi di gestione licenze relativi al server Host sessione Desktop remoto.

Ogni utente o dispositivo di elaborazione che si connette a un server Host sessione Desktop remoto deve disporre di una licenza CAL Servizi Desktop remoto valida rilasciata da un server licenze Desktop remoto.

Un server Host sessione Desktop remoto deve essere in grado di contattare un server licenze Desktop remoto al fine di richiedere una licenza CAL Servizi Desktop remoto per gli utenti e i computer che si connettono al server Host sessione Desktop remoto.

Lo scopo principale di Diagnosi gestione licenze è determinare i server licenze per cui è configurato il server Host sessione Desktop remoto e stabilire se tali server licenze dispongono di licenze CAL Servizi Desktop remoto da rilasciare agli utenti e ai computer che si connettono al server Host sessione Desktop remoto. Diagnosi gestione licenze tenta inoltre di identificare i possibili problemi di gestione licenze e fornire le risoluzioni più appropriate.

Per eseguire lo strumento Diagnosi gestione licenze, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per eseguire lo strumento Diagnosi gestione licenze

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Nel riquadro sinistro fare clic su Diagnosi gestione licenze. Tale strumento verrà eseguito automaticamente e tenterà di contattare i server licenze per cui è configurato il server Host sessione Desktop remoto, identificare i problemi di configurazione delle licenze e quindi visualizzare i risultati.

Diagnosi gestione licenze è costituito da quattro sezioni principali:

  • Dettagli configurazione server host sessione Desktop remoto in cui vengono visualizzate le informazioni di configurazione relative al server Host sessione Desktop remoto, inclusa la modalità di gestione licenze specificata per il server Host sessione Desktop remoto.

  • Informazioni Diagnosi gestione licenze in cui vengono visualizzati i problemi di gestione licenze identificati e le relative risoluzioni.

  • Informazioni server licenze Servizi Desktop remoto in cui vengono visualizzati i server licenze per cui è configurato il server Host sessione Desktop remoto.

  • Dettagli configurazione server licenze in cui vengono visualizzate le informazioni di configurazione relative a un server licenze, inclusi il tipo e la versione delle licenze CAL Servizi Desktop remoto installate e disponibili in tale server.

Per visualizzare i dettagli di configurazione di un server licenze selezionato, l'account utilizzato per l'accesso deve disporre di privilegi di amministratore nel server licenze. Se l'account in uso non dispone di privilegi di amministratore nel server licenze, è possibile utilizzare Specifica credenziali nello strumento Diagnosi gestione licenze per specificare credenziali con privilegi amministrativi nel server licenze.

Importante

Per visualizzare i dettagli di configurazione di un server licenze Windows 2000 o Windows Server 2003, è necessario specificare le credenziali dell'account predefinito Administrator locale in tale server. Le credenziali di qualsiasi altro account, anche se questo dispone dei privilegi di amministratore nel server licenze, non consentiranno di visualizzare i dettagli di configurazione.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Ulteriori riferimenti

  • Configurare le impostazioni relative alle licenze per un server Host sessione Desktop remoto

  • Specificare la modalità di gestione licenze per un server Host sessione Desktop remoto

  • Specificare il server licenze che deve essere utilizzato da un server Host sessione Desktop remoto


Configurare Virtualizzazione IP di Desktop remoto

Virtualizzazione IP di Desktop remoto consente l'assegnazione degli indirizzi IP alle connessioni Desktop remoto per singole sessioni o singoli programmi, che può risultare utile se un programma comunica con un server che consente un'unica connessione per ogni indirizzo IP. Nelle versioni precedenti a Windows Server 2008 R2, a ogni sessione in un server Host sessione Desktop remoto viene assegnato lo stesso indirizzo IP. Con Windows Server 2008 R2 è possibile utilizzare Virtualizzazione IP di Desktop remoto al fine di assegnare indirizzi IP per singole sessioni o per singoli programmi. Se si assegnano indirizzi IP per più programmi, questi ultimi condivideranno un indirizzo IP per ogni singola sessione. Se nel server sono disponibili più schede di rete, è inoltre necessario sceglierne una per Virtualizzazione IP di Desktop remoto.

La funzionalità Virtualizzazione IP di Desktop remoto viene configurata mediante lo strumento Configurazione host sessione Desktop remoto. Nella scheda Virtualizzazione IP di Desktop remoto di Configurazione host sessione Desktop remoto è possibile eseguire le operazioni seguenti:

  • Attivare o disattivare Virtualizzazione IP di Desktop remoto.

  • Selezionare la scheda di rete da utilizzare per Virtualizzazione IP di Desktop remoto.

  • Configurare la modalità per sessione o per programma di Virtualizzazione IP di Desktop remoto .

  • Se la funzionalità Virtualizzazione IP di Desktop remoto viene configurata in modalità per programma, è possibile aggiungere un elenco dei programmi utilizzabili da Virtualizzazione IP di Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni di Virtualizzazione IP di Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Nell'area Modifica impostazioni, in Virtualizzazione IP di Desktop remoto, fare doppio clic su Virtualizzazione IP.

  3. Nella finestra di dialogo Proprietà fare clic sulla scheda Virtualizzazione IP di Desktop remoto.

  4. Per attivare o disattivare Virtualizzazione IP di Desktop remoto, eseguire una delle operazioni seguenti:

    • Selezionare la casella di controllo Attiva virtualizzazione IP per attivare Virtualizzazione IP di Desktop remoto.

    • Deselezionare la casella di controllo Attiva virtualizzazione IP per disattivare Virtualizzazione IP di Desktop remoto.

  5. Selezionare la scheda di rete appropriata da utilizzare per Virtualizzazione IP di Desktop remoto nell'elenco Selezionare la scheda di rete da utilizzare per la virtualizzazione IP.

  6. Per selezionare la modalità di Virtualizzazione IP di Desktop remoto, in Modalità virtualizzazione IP:

    • Fare clic su Per sessione per configurare l'esecuzione di Virtualizzazione IP di Desktop remoto in modalità per sessione.

    • Fare clic su Per programma per configurare l'esecuzione di Virtualizzazione IP di Desktop remoto in modalità per programma.

  7. Per assegnare i programmi che utilizzano Virtualizzazione IP di Desktop remoto, in Assegna indirizzi IP virtuali ai programmi seguenti fare clic su Aggiungi programma.

Ulteriori riferimenti

  • Configurare le impostazioni di un server Host sessione Desktop remoto


Configurare il supporto per la stampante

Servizi Desktop remoto supporta il reindirizzamento della stampante, con cui i processi di stampa vengono indirizzati da un server a una stampante collegata a un computer client o a una stampante condivisa disponibile per il computer client. In un server Host sessione Desktop remoto è possibile utilizzare il driver della stampante Easy Print di Desktop remoto per semplificare la configurazione della stampante. Il driver Easy Print di Desktop remoto è utile se in un server Host sessione Desktop remoto non è installato un driver della stampante corrispondente al driver della stampante di un computer client.

Per impostazione predefinita, il server Host sessione Desktop remoto tenta innanzitutto di utilizzare il driver Easy Print di Desktop remoto. Se il computer client non supporta questo driver, il server cerca un driver della stampante corrispondente nel server. È possibile installare un driver della stampante corrispondente nel server Host sessione Desktop remoto oppure creare un file di mapping della stampante personalizzato.

Nota

Il driver della stampante di fallback per un server Host sessione Desktop remoto non è supportato in Windows Server 2008 o in Windows Server 2008 R2.

Requisiti client

Per utilizzare Easy Print di Desktop remoto, è necessario che nel computer client siano installati i componenti seguenti:

  • Connessione desktop remoto 6.1

    Nota

    Il client Connessione desktop remoto 6.1 supporta Remote Desktop Protocol 6.1.

  • Almeno Microsoft .NET Framework 3.0 Service Pack 1

    Nota

    La versione di Microsoft .NET Framework inclusa in Windows Server 2008 e in Microsoft Windows Vista con Service Pack 1 supporta Easy Print di Desktop remoto. Microsoft .NET Framework non è necessario per i client remoti che eseguono Windows 7 o Windows Server 2008 R2.

Configurare il comportamento del driver della stampante

Per modificare il comportamento predefinito del driver della stampante, è possibile utilizzare Criteri di gruppo per modificare l'impostazione Utilizza prima il driver della stampante Easy Print di Servizi Desktop remoto. Questa impostazione è disponibile nel nodo seguente della Console Gestione Criteri di gruppo:

Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento stampante

Nota

Se si utilizza l'Editor Criteri di gruppo locali, "Criteri" non fa parte del percorso del nodo.

Mediante questa impostazione è possibile configurare il server Host sessione Desktop remoto per l'esecuzione di una delle operazioni seguenti:

  • Utilizzare innanzitutto il driver Easy Print di Desktop remoto. Se questa operazione ha esito negativo, cercare un driver della stampante corrispondente. (Questo è il comportamento se si attiva o non si configura l'impostazione).

  • Cercare prima un driver della stampante corrispondente. Se questa operazione ha esito negativo, utilizzare il driver Easy Print di Desktop remoto. (Questo è il comportamento se si disattiva l'impostazione).

Le altre impostazioni per il reindirizzamento della stampante disponibili in questo nodo nell'Editor Criteri di gruppo locali sono:

  • Non consentire il reindirizzamento della stampante client

  • Non impostare stampante predefinita del client come stampante predefinita per una sessione

  • Reindirizza solo la stampante predefinita del client

Per ulteriori informazioni su queste impostazioni, vedere le descrizioni delle impostazioni nella Console Gestione Criteri di gruppo o nell'Editor Criteri di gruppo locali.

Ulteriori riferimenti

  • Configurare le impostazioni di un server Host sessione Desktop remoto

  • Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.


Configurare le impostazioni di Gestore connessione Desktop remoto per un server Host sessione Desktop remoto

Per informazioni sulla configurazione delle impostazioni di Gestore connessione Desktop remoto per un server Host sessione Desktop remoto, vedere Configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto.


Gestire le connessioni di Servizi Desktop remoto

In questa sezione vengono descritte le procedure per la gestione delle connessioni di Servizi Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Creare una connessione di Servizi Desktop remoto

  • Configurare il numero di connessioni remote simultanee consentite per una connessione

  • Attivare una connessione di Servizi Desktop remoto

  • Disattivare una connessione di Servizi Desktop remoto

  • Rinominare una connessione di Servizi Desktop remoto

  • Eliminare una connessione di Servizi Desktop remoto


Creare una connessione di Servizi Desktop remoto

Per impostazione predefinita, in un computer che esegue Windows Server 2008 e Windows Server 2008 R2 viene creata e attivata automaticamente una connessione anche se il servizio ruolo Host sessione Desktop remoto non è installato nel computer. Questa connessione è denominata RDP-Tcp e consente solo due connessioni remote simultanee al computer.

Quando si installa il servizio ruolo Host sessione Desktop remoto nel computer, la connessione RDP-Tcp viene modificata per consentire un numero illimitato di connessioni remote simultanee. Per ulteriori informazioni sulla configurazione del numero di connessioni remote simultanee consentite da una connessione, vedere Configurare il numero di connessioni remote simultanee consentite per una connessione.

Per ogni scheda di rete installata nel server Host sessione Desktop remoto è possibile configurare una sola connessione RDP (Remote Desktop Protocol). La connessione predefinita RDP-Tcp è in genere l'unica connessione necessaria per il supporto dell'amministrazione remota del server o del servizio ruolo Host sessione Desktop remoto. Per configurare connessioni aggiuntive che utilizzano RDP, è necessario installare un'ulteriore scheda di rete per ogni connessione RDP che si desidera creare.

Per creare una nuova connessione, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare una nuova connessione

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Scegliere Crea nuova connessione dal menu Azione.

  3. Nella pagina iniziale della Connessione guidata Servizi Desktop remoto fare clic su Avanti.

  4. Nella pagina Protocollo di connessione digitare il nome della connessione. Non è possibile disporre di due connessioni con lo stesso nome nel computer.

  5. Se nel computer sono disponibili più tipi di connessione, selezionare il tipo appropriato per l'ambiente in uso in Tipo di connessione.

    A una scheda di rete non è possibile assegnare più connessioni dello stesso tipo.

  6. Fare clic su Avanti.

  7. Nella pagina Scheda di rete eseguire le operazioni seguenti:

    • Selezionare la scheda di rete utilizzata dalla connessione. Se si desidera che la connessione utilizzi tutte le schede di rete disponibili nel computer, selezionare Tutte le schede configurate con questo protocollo.

    • Selezionare il numero di connessioni remote simultanee supportate dalla connessione.

  8. Fare clic su Avanti e quindi su Fine nella pagina Riepilogo. La nuova connessione verrà visualizzata in Connessioni nella pagina principale di Configurazione host sessione Desktop remoto.

Ulteriori riferimenti

  • Gestire le connessioni di Servizi Desktop remoto


Configurare il numero di connessioni remote simultanee consentite per una connessione

È possibile configurare il numero di connessioni remote simultanee consentite per una connessione. Limitando il numero di connessioni remote simultanee si migliorano le prestazioni del computer in quanto ci sono meno sessioni che richiedono risorse di sistema.

Se il servizio ruolo Host sessione Desktop remoto non è installato nel computer, per una connessione sono consentite solo due connessioni remote simultanee al computer.

Per configurare il numero di connessioni remote simultanee consentite per una connessione, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare il numero di connessioni remote simultanee consentite per una connessione

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sul nome della connessione e quindi scegliere Proprietà.

  3. Nella scheda Scheda di rete della finestra di dialogo Proprietà relativa alla connessione fare clic su Numero massimo connessioni, immettere il numero di connessioni remote simultanee che si desidera consentire per la connessione e quindi fare clic su OK.

    Se l'opzione Numero massimo connessioni è selezionata e visualizzata in grigio, l'impostazione di Criteri di gruppo Limita il numero di connessioni è stata attivata e applicata al server Host sessione Desktop remoto.

È inoltre possibile impostare il numero massimo di connessioni simultanee consentite per un server Host sessione Desktop remoto applicando l'impostazione di Criteri di gruppo Limita il numero di connessioni. Questa impostazione di Criteri di gruppo è disponibile in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Connessioni e può essere configurata mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Gestire le connessioni di Servizi Desktop remoto


Attivare una connessione di Servizi Desktop remoto

È necessario attivare una connessione nel server Host sessione Desktop remoto in modo che gli utenti possano accedere al server Host sessione Desktop remoto mediante tale connessione.

Per attivare una connessione nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per attivare una connessione nel server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic sul nome della connessione che si desidera attivare, ad esempio RDP-Tcp.

  3. Scegliere Abilita connessione dal menu Attiva. Una freccia GIÙ di colore verde sull'icona associata al nome della connessione indica che la connessione è attivata.

Ulteriori riferimenti

  • Gestire le connessioni di Servizi Desktop remoto

  • Disattivare una connessione di Servizi Desktop remoto


Disattivare una connessione di Servizi Desktop remoto

È possibile disattivare una connessione nel server Host sessione Desktop remoto in modo che nessun utente possa accedere al server Host sessione Desktop remoto mediante tale connessione. Se si intende disconnettere il server Host sessione Desktop remoto per interventi di manutenzione o l'installazione di nuove applicazioni, è possibile disattivare tutte le connessioni al server Host sessione Desktop remoto.

Importante

Quando si disattiva una connessione nel server Host sessione Desktop remoto, tutti gli utenti che utilizzano tale connessione per accedere al server Host sessione Desktop remoto verranno immediatamente disconnessi dal server Host sessione Desktop remoto. Prima di disattivare la connessione, è consigliabile inviare un messaggio agli utenti connessi al server Host sessione Desktop remoto per avvisarli che verranno disconnessi dal server Host sessione Desktop remoto.

Per ulteriori informazioni sull'invio di un messaggio agli utenti connessi a un server Host sessione Desktop remoto, vedere l'argomento relativo all'invio di un messaggio agli utenti nella Guida di Gestione Servizi Desktop remoto in Windows Server 2008 R2.

Per disattivare una connessione nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per disattivare una connessione nel server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic sul nome della connessione che si desidera disattivare, ad esempio RDP-Tcp.

  3. Scegliere Disabilita connessione dal menu Azione. La connessione verrà disattivata immediatamente e tutti gli utenti che la utilizzano verranno subito disconnessi dal server Host sessione Desktop remoto. Una freccia GIÙ di colore rosso sull'icona associata al nome della connessione indica che la connessione è disattivata.

È inoltre possibile negare nuovi accessi al server Host sessione Desktop remoto. Per ulteriori informazioni, vedere Negare nuovi accessi utente a un server Host sessione Desktop remoto.

Ulteriori riferimenti

  • Gestire le connessioni di Servizi Desktop remoto

  • Attivare una connessione di Servizi Desktop remoto


Rinominare una connessione di Servizi Desktop remoto

È possibile rinominare una connessione nel server Host sessione Desktop remoto. È possibile rinominare una connessione per renderne il nome più descrittivo.

Il nome della connessione viene visualizzato insieme alle informazioni sulle sessioni in Gestione Servizi Desktop remoto. Per ulteriori informazioni sulla visualizzazione delle informazioni sulle sessioni in Gestione Servizi Desktop remoto, vedere l'argomento relativo alla visualizzazione delle sessioni in esecuzione in un server Host sessione Desktop remoto nella Guida di Gestione Servizi Desktop remoto in Windows Server 2008 R2.

Non è possibile disporre di due connessioni con lo stesso nome in un server Host sessione Desktop remoto.

Per rinominare una connessione nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per rinominare una connessione nel server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic sul nome della connessione che si desidera rinominare, ad esempio RDP-Tcp.

  3. Scegliere Rinomina connessione dal menu Azione.

  4. Nella finestra di dialogo Rinomina connessione digitare un nuovo nome per la connessione e quindi fare clic su OK.

Ulteriori riferimenti

  • Gestire le connessioni di Servizi Desktop remoto


Eliminare una connessione di Servizi Desktop remoto

È possibile eliminare una connessione nel server Host sessione Desktop remoto.

Importante

Se si elimina una connessione nel server Host sessione Desktop remoto, tutti gli utenti che utilizzano tale connessione per accedere al server Host sessione Desktop remoto verranno immediatamente disconnessi dal server Host sessione Desktop remoto. Prima di eliminare la connessione, è consigliabile inviare un messaggio agli utenti connessi al server Host sessione Desktop remoto per avvisarli che verranno disconnessi dal server Host sessione Desktop remoto.

Per ulteriori informazioni sull'invio di un messaggio agli utenti connessi a un server Host sessione Desktop remoto, vedere l'argomento relativo all'invio di un messaggio agli utenti nella Guida di Gestione Servizi Desktop remoto in Windows Server 2008 R2.

Per eliminare una connessione nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per eliminare una connessione nel server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic sul nome della connessione che si desidera eliminare, ad esempio RDP-Tcp.

  3. Scegliere Elimina dal menu Azione e quindi fare clic su Sì. La connessione verrà disattivata immediatamente e tutti gli utenti che la utilizzano verranno subito disconnessi dal server Host sessione Desktop remoto.

    Gli utenti non potranno riconnettersi alle proprie sessioni finché non si crea una nuova connessione che utilizza lo stesso protocollo di connessione e la stessa scheda di rete della connessione eliminata. Per ulteriori informazioni sulla creazione di una nuova connessione, vedere Creare una connessione di Servizi Desktop remoto.

È possibile impedire temporaneamente agli utenti di connettersi al server Host sessione Desktop remoto eseguendo una delle operazioni seguenti:

  • Disattivare una connessione nel server Host sessione Desktop remoto. Per ulteriori informazioni, vedere Disattivare una connessione di Servizi Desktop remoto.

  • Negare nuovi accessi al server Host sessione Desktop remoto. Per ulteriori informazioni, vedere Negare nuovi accessi utente a un server Host sessione Desktop remoto.

Ulteriori riferimenti

  • Gestire le connessioni di Servizi Desktop remoto


Gestore connessione Desktop remoto

Gestore connessione Desktop remoto, in precedenza denominato Broker di sessione di Servizi terminal, è un servizio ruolo che offre le funzionalità seguenti:

  • Consente a un utente di riconnettersi a una sessione esistente in una server farm Host sessione Desktop remoto con carico bilanciato. In questo modo, l'utente con una sessione disconnessa non potrà connettersi a un server Host sessione Desktop remoto diverso della farm e avviare una nuova sessione.

  • Consente di distribuire in modo uniforme il carico di sessioni tra i server Host sessione Desktop remoto di una server farm Host sessione Desktop remoto con carico bilanciato.

  • Consente agli utenti di accedere ai desktop virtuali ospitati nei server Host di virtualizzazione Desktop remoto e ai Programmi RemoteApp ospitati nei server Host sessione Desktop remoto tramite Connessione RemoteApp e desktop.

Per un'introduzione a Gestore connessione Desktop remoto, vedere Panoramica di Gestore connessione Desktop remoto.

Per ulteriori informazioni su Gestore connessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140432.

Sono inclusi gli argomenti seguenti:

  • Panoramica di Gestore connessione Desktop remoto

  • Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto

  • Installare il servizio ruolo Gestore connessione Desktop remoto

  • Aggiungere i server Host sessione Desktop remoto della farm al gruppo locale Computer broker di sessione

  • Configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto

  • Configurare DNS per il bilanciamento del carico di Gestore connessione Desktop remoto

  • Informazioni sul reindirizzamento dell'indirizzo IP e del token

  • Informazioni sul reindirizzamento dedicato a una farm e sul reindirizzamento a una macchina virtuale


Panoramica di Gestore connessione Desktop remoto

Gestore connessione Desktop remoto, in precedenza denominato Broker di sessione di Servizi terminal, è un servizio ruolo che offre le funzionalità seguenti:

  • Consente a un utente di riconnettersi a una sessione esistente in una server farm Host sessione Desktop remoto con carico bilanciato. In questo modo, l'utente con una sessione disconnessa non potrà connettersi a un server Host sessione Desktop remoto diverso della farm e avviare una nuova sessione.

  • Consente di distribuire in modo uniforme il carico di sessioni tra i server Host sessione Desktop remoto di una server farm Host sessione Desktop remoto con carico bilanciato.

  • Consente agli utenti di accedere ai desktop virtuali ospitati nei server Host di virtualizzazione Desktop remoto e ai Programmi RemoteApp ospitati nei server Host sessione Desktop remoto tramite Connessione RemoteApp e desktop.

Gestore connessione Desktop remoto tiene traccia delle sessioni utente in una server farm Host sessione Desktop remoto con carico bilanciato. Nel database di Gestore connessione Desktop remoto vengono archiviate le informazioni sulle sessioni, inclusi il nome del server Host sessione Desktop remoto in cui risiede ogni sessione, lo stato, l'ID e il nome utente associato a ogni sessione. Gestore connessione Desktop remoto utilizza queste informazioni per reindirizzare un utente che dispone di una sessione esistente al server Host sessione Desktop remoto in cui risiede tale sessione.

Se un utente si disconnette da una sessione, intenzionalmente o a causa di un errore di rete, le applicazioni utilizzate dall'utente continueranno a essere eseguite. Quando l'utente si riconnette, viene eseguita una query in Gestore connessione Desktop remoto per determinare se l'utente dispone di una sessione esistente e, in caso affermativo, il server Host sessione Desktop remoto della farm in cui risiede tale sessione. Se è disponibile una sessione esistente, Gestore connessione Desktop remoto reindirizza il client al server Host sessione Desktop remoto in cui risiede la sessione.

Grazie alla funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto, quando un utente senza una sessione esistente si connette a un server Host sessione Desktop remoto nella server farm Host sessione Desktop remoto con carico bilanciato, viene reindirizzato al server Host sessione Desktop remoto con il minor numero di sessioni. Se un utente con una sessione esistente si riconnette, viene reindirizzato al server Host sessione Desktop remoto in cui risiede tale sessione. Per distribuire il carico di sessioni tra server più potenti e meno potenti della farm, è possibile assegnare un valore di peso relativo a un server.

Gestore connessione Desktop remoto viene inoltre utilizzato per fornire agli utenti l'accesso a Connessione RemoteApp e desktop. Connessione RemoteApp e desktop offre agli utenti una visualizzazione personalizzata dei Programmi RemoteApp e dei desktop virtuali. Gestore connessione Desktop remoto supporta il bilanciamento del carico e la riconnessione a sessioni esistenti nei desktop virtuali a cui si accede tramite Connessione RemoteApp e desktop. Per configurare il server Gestore connessione Desktop remoto in modo che supporti Connessione RemoteApp e desktop, utilizzare lo strumento Gestione connessione Desktop remoto. Per ulteriori informazioni, vedere la Guida di Gestione connessione Desktop remoto in Windows Server 2008 R2.

Componenti di Gestore connessione Desktop remoto

In una server farm Host sessione Desktop remoto con carico bilanciato è necessario considerare due componenti di Gestore connessione Desktop remoto.

  • Server Gestore connessione Desktop remoto. Si tratta del server che esegue il servizio Gestore connessione Desktop remoto e tiene traccia delle sessioni utente per una o più server farm Host sessione Desktop remoto con carico bilanciato. Gestore connessione Desktop remoto utilizza un nome di farm per determinare i server inclusi nella stessa server farm Host sessione Desktop remoto.

  • Server Host sessione Desktop remoto che utilizzano Gestore connessione Desktop remoto. Si tratta di server Host sessione Desktop remoto che sono membri di una farm in Gestore connessione Desktop remoto. Per partecipare a Gestore connessione Desktop remoto, un server deve soddisfare i criteri seguenti:

    • Nel server deve essere installato il servizio ruolo Host sessione Desktop remoto.

    • Il server deve essere membro di un dominio Active Directory.

    • Il server deve essere membro del gruppo locale Computer broker di sessione nel server Gestore connessione Desktop remoto.

    • Il server deve essere membro di una server farm Host sessione Desktop remoto con carico bilanciato.

      Se si utilizza la funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto, è possibile configurare le impostazioni di bilanciamento del carico insieme ad altre impostazioni di Gestore connessione Desktop remoto. Per ulteriori informazioni, vedere Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto

      Importante

      Per essere membri di una farm che utilizza Gestore connessione Desktop remoto in Windows Server 2008 R2, è necessario che un server Host sessione Desktop remoto esegua Windows Server 2008 R2 o Windows Server 2008.

Per ulteriori informazioni su Gestore connessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140432.

Ulteriori riferimenti

  • Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto

  • Installare il servizio ruolo Gestore connessione Desktop remoto

  • Aggiungere i server Host sessione Desktop remoto della farm al gruppo locale Computer broker di sessione

  • Configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto

  • Configurare DNS per il bilanciamento del carico di Gestore connessione Desktop remoto


Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto

In una server farm Host sessione Desktop remoto con carico bilanciato è possibile migliorare le prestazioni di un singolo server Host sessione Desktop remoto distribuendo le sessioni di Servizi Desktop remoto tra più server. È possibile configurare una farm con carico bilanciato mediante la funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto, denominata Bilanciamento carico di rete, o una soluzione di terze parti. Gestore connessione Desktop remoto consente inoltre agli utenti di riconnettersi alla sessione esistente in una server farm Host sessione Desktop remoto con carico bilanciato.

In questo elenco di controllo viene illustrata la procedura per creare e configurare una server farm Host sessione Desktop remoto con carico bilanciato utilizzando la funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto.

Importante

Per essere membri di una farm che utilizza Gestore connessione Desktop remoto in Windows Server 2008 R2, è necessario che un server Host sessione Desktop remoto esegua Windows Server 2008 R2 o Windows Server 2008.

Attività | Riferimento
Installare il servizio ruolo Gestore connessione Desktop remoto nel server che si desidera utilizzare per tenere traccia delle sessioni utente di una farm. | Installare il servizio ruolo Gestore connessione Desktop remoto
Aggiungere i server Host sessione Desktop remoto della farm al gruppo locale Computer broker di sessione nel server Gestore connessione Desktop remoto. | Aggiungere i server Host sessione Desktop remoto della farm al gruppo locale Computer broker di sessione
Configurare i server Host sessione Desktop remoto della farm per aggiungerli a una farm in Gestore connessione Desktop remoto e utilizzare la funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto. | Configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto
Configurare le voci round robin DNS per i server Host sessione Desktop remoto della farm. | Configurare DNS per il bilanciamento del carico di Gestore connessione Desktop remoto

Per ulteriori informazioni su Gestore connessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140432.

Ulteriori riferimenti

  • Panoramica di Gestore connessione Desktop remoto


Installare il servizio ruolo Gestore connessione Desktop remoto

È necessario installare il servizio ruolo Gestore connessione Desktop remoto nel server che si desidera utilizzare per tenere traccia delle informazioni relative alle sessioni utente in una server farm Host sessione Desktop remoto con carico bilanciato. Il server in cui si installa il servizio ruolo Gestore connessione Desktop remoto non deve essere un server Host sessione Desktop remoto o disporre di Desktop remoto attivato.

È possibile utilizzare un singolo server Gestore connessione Desktop remoto per tenere traccia delle sessioni utente in più farm, poiché il sovraccarico a livello di prestazioni è minimo.

Quando si installa il servizio ruolo Gestore connessione Desktop remoto, nel computer locale vengono apportate le modifiche seguenti:

  • Viene installato il servizio Gestore connessione Desktop remoto. Per impostazione predefinita il servizio viene impostato su Avviato e Automatico.

  • Viene creato il gruppo locale Computer broker di sessione.

  • Viene installato lo strumento Gestione connessione Desktop remoto.

Prerequisiti per l'installazione

Il server in cui si installa Gestore connessione Desktop remoto deve essere membro di un dominio.

Nota

Se si installa il servizio ruolo Gestore connessione Desktop remoto in un controller di dominio, il gruppo Computer broker di sessione sarà un gruppo locale di dominio disponibile in tutti i controller di dominio.

Procedura di installazione

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gestore connessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare il servizio ruolo Gestore connessione Desktop remoto

  1. Nel server in cui si desidera installare il servizio ruolo Gestore connessione Desktop remoto aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Se il ruolo Servizi Desktop remoto non è già installato:

    1. In Riepilogo ruoli fare clic su Aggiungi ruoli.

    2. Nella pagina Prima di iniziare dell'Aggiunta guidata ruoli fare clic su Avanti.

    3. Nella pagina Selezione ruoli server selezionare la casella di controllo Servizi Desktop remoto e quindi fare clic su Avanti.

    4. Nella pagina Servizi Desktop remoto fare clic su Avanti.

    5. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Gestore connessione Desktop remoto e quindi fare clic su Avanti.

    Se il ruolo Servizi Desktop remoto è già installato:

    1. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    2. In Servizi ruolo fare clic su Aggiungi servizi ruolo.

    3. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Gestore connessione Desktop remoto e quindi fare clic su Avanti.

  3. Nella pagina Conferma selezioni per l'installazione verificare che Gestore connessione Desktop remoto sia elencato e quindi fare clic su Installa.

  4. Nella pagina Stato installazione verrà indicato lo stato dell'installazione.

  5. Nella pagina Risultati installazione verificare che l'installazione del servizio ruolo Gestore connessione Desktop remoto sia stata completata e quindi fare clic su Chiudi.

Ulteriori riferimenti

  • Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto


Aggiungere i server Host sessione Desktop remoto della farm al gruppo locale Computer broker di sessione

Affinché un server Host sessione Desktop remoto possa utilizzare Gestore connessione Desktop remoto, è necessario aggiungere l'account computer per il server Host sessione Desktop remoto al gruppo locale Computer broker di sessione nel server Gestore connessione Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Gestore connessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Importante

È necessario eseguire questa procedura nel server in cui è installato il servizio ruolo Gestore connessione Desktop remoto.

Per aggiungere un server Host sessione Desktop remoto al gruppo locale Computer broker di sessione

  1. Nel server Gestore connessione Desktop remoto fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione computer.

  2. Nel riquadro sinistro espandere Utenti e gruppi locali e quindi fare clic su Gruppi.

  3. Nel riquadro centrale fare clic con il pulsante destro del mouse sul gruppo Computer broker di sessione e quindi scegliere Proprietà.

  4. Nella scheda Generale fare clic su Aggiungi.

  5. Nella finestra di dialogo Seleziona utenti, computer o gruppi fare clic su Tipi di oggetto.

  6. Selezionare la casella di controllo Computer e quindi fare clic su OK.

  7. Individuare e quindi aggiungere l'account computer per ogni server Host sessione Desktop remoto che si desidera aggiungere.

  8. Al termine fare clic su OK.

Ulteriori riferimenti

  • Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto


Configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto

È possibile configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto e utilizzare la funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto mediante lo strumento Configurazione host sessione Desktop remoto.

Nota

Prima di configurare il server Host sessione Desktop remoto per aggiungerlo a una farm, è necessario che l'account computer per il server Host sessione Desktop remoto sia membro del gruppo Computer broker di sessione nel server Gestore connessione Desktop remoto. Per ulteriori informazioni, vedere Aggiungere i server Host sessione Desktop remoto della farm al gruppo locale Computer broker di sessione.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni di Gestore connessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Nell'area Modifica impostazioni, in Gestore connessione Desktop remoto, fare doppio clic su Membro della farm in Gestore connessione desktop remoto.

  3. Nella scheda Gestore connessione Desktop remoto della finestra di dialogo Proprietà fare clic su Modifica impostazioni.

  4. Nella finestra di dialogo Impostazioni di Gestore connessione Desktop remoto fare clic su Membro farm.

  5. Nella casella Nome server Gestore connessione Desktop remoto digitare il nome del server Gestore connessione Desktop remoto.

    Nota

    Il server Gestore connessione Desktop remoto è il server in cui è installato il servizio ruolo Gestore connessione Desktop remoto.

  6. Nella casella Nome farm digitare il nome della farm a cui si desidera aggiungere il server in Gestore connessione Desktop remoto.

    Importante
    • Gestore connessione Desktop remoto utilizza un nome di farm per determinare i server inclusi nella stessa server farm Host sessione Desktop remoto. È necessario utilizzare lo stesso nome di farm per tutti i server inclusi nella stessa server farm Host sessione Desktop remoto con carico bilanciato. Se si digita un nuovo nome di farm, in Gestore connessione Desktop remoto verrà creata una nuova farm e il server verrà aggiunto alla farm. Se si specifica un nome di farm esistente, il server verrà aggiunto a tale farm in Gestore connessione Desktop remoto.
    • Sebbene non sia necessario registrare il nome della farm Gestore connessione Desktop remoto in Servizi di dominio Active Directory, è consigliabile utilizzare lo stesso nome che verrà utilizzato in DNS per la server farm Host sessione Desktop remoto. Il nome della server farm Host sessione Desktop remoto in DNS rappresenta il nome virtuale utilizzato dai client per connettersi alla server farm Host sessione Desktop remoto. Per ulteriori informazioni, vedere Configurare DNS per il bilanciamento del carico di Gestore connessione Desktop remoto.

  7. Fare clic su OK per chiudere la finestra di dialogo Impostazioni di Gestore connessione Desktop remoto.

  8. Per utilizzare il bilanciamento del carico di Gestore connessione Desktop remoto, selezionare la casella di controllo Partecipa a bilanciamento del carico di Gestore di connessione.

  9. Facoltativamente, modificare il peso del server nella casella Peso relativo del server nella farm. Il valore predefinito è 100. Il peso del server è relativo. Pertanto, se si assegna a un server un valore di 50 e a un altro server un valore di 100, il server con peso 50 riceverà la metà del numero di connessioni.

  10. Verificare se si desidera utilizzare il reindirizzamento indirizzo IP. Per impostazione predefinita la casella di controllo Utilizza reindirizzamento indirizzo IP è selezionata. Se si desidera utilizzare la modalità di reindirizzamento del token, selezionare Utilizza reindirizzamento token. Per ulteriori informazioni, vedere Informazioni sul reindirizzamento dell'indirizzo IP e del token.

  11. Nella casella Seleziona indirizzi IP da utilizzare per la riconnessione selezionare le caselle di controllo corrispondenti agli indirizzi IP che si desidera utilizzare.

    Nota

    Solo il primo indirizzo IPv4 selezionato viene utilizzato dai client che eseguono Connessione desktop remoto versione 5.2 e precedenti.

  12. Al termine fare clic su OK.

È possibile utilizzare Criteri di gruppo per configurare alcune impostazioni di Gestore connessione Desktop remoto. Le impostazioni di Criteri di gruppo rilevanti sono:

  • Aggiungi a Gestore connessione Desktop remoto

  • Configura nome farm Gestore connessione Desktop remoto

  • Configura nome server Gestore connessione Desktop remoto

  • Usa bilanciamento del carico di Gestore connessione Desktop remoto

  • Utilizza reindirizzamento indirizzo IP

Queste impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Gestore connessione Desktop remoto e possono essere configurate mediante l'Editor Criteri di gruppo locali o la Console Gestione Criteri di gruppo. Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per visualizzare e configurare alcune impostazioni di Gestore connessione Desktop remoto è inoltre possibile utilizzare il modulo Servizi Desktop remoto per Windows PowerShell. Per ulteriori informazioni sull'utilizzo di Windows PowerShell con Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139898.

Ulteriori riferimenti

  • Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto


Configurare DNS per il bilanciamento del carico di Gestore connessione Desktop remoto

Per bilanciare il carico delle sessioni in una server farm Host sessione Desktop remoto, è possibile utilizzare la funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto insieme al round robin DNS (Domain Name System). Per configurare DNS, è necessario creare un record di risorse host DNS per ogni server Host sessione Desktop remoto della farm che esegue il mapping dell'indirizzo IP del server Host sessione Desktop remoto al nome della server farm Host sessione Desktop remoto in DNS.

Per configurare DNS in un controller di dominio basato su Windows Server 2008 R2, eseguire la procedura seguente.

Per eseguire questa procedura, è necessaria l'appartenenza al gruppo Domain Admins, Enterprise Admins o DnsAdmins.

Per aggiungere voci DNS per ogni server Host sessione Desktop remoto della farm

  1. Aprire lo snap-in DNS. A tale scopo, accedere a un computer in cui è installato questo snap-in, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi DNS.

  2. Espandere il nome del server, Zone di ricerca diretta e quindi il nome del dominio.

  3. Fare clic con il pulsante destro del mouse sulla zona appropriata e quindi scegliere Nuovo host (A o AAAA).

  4. Nella casella Nome (se vuoto, utilizza il nome del dominio padre) digitare il nome della server farm Host sessione Desktop remoto.

    Il nome della farm è il nome virtuale utilizzato dai client per connettersi alla server farm Host sessione Desktop remoto. Non utilizzare il nome di un server esistente. Ai fini della gestione, è consigliabile utilizzare lo stesso nome di farm specificato durante la configurazione dei server Host sessione Desktop remoto da aggiungere a una farm in Gestore connessione Desktop remoto.

  5. Nella casella Indirizzo IP digitare l'indirizzo IP di un server Host sessione Desktop remoto della farm.

  6. Fare clic su Aggiungi host.

  7. Ripetere i passaggi da 3 a 6 per ogni server Host sessione Desktop remoto della farm.

    Importante

    È necessario specificare lo stesso nome di farm nella casella Nome (se vuoto, utilizza il nome del dominio padre) per ogni voce DNS.

    Se ad esempio una farm denominata FARM1 include tre server Host sessione Desktop remoto con indirizzi IP 192.168.1.20, 192.168.1.21 e 192.168.1.22, le voci saranno simili alle seguenti:

    Farm1     Host(A)     192.168.1.20
Farm1     Host(A)     192.168.1.21
Farm1     Host(A)     192.168.1.22

  8. Al termine fare clic su Fine.
Nota

Per impostazione predefinita, il round robin DNS viene attivato quando si utilizza DNS in un controller di dominio basato su Windows Server 2008 R2. L'impostazione Attiva round robin è disponibile nella scheda Avanzate quando si visualizzano le proprietà del server in DNS.

Ulteriori riferimenti

  • Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto


Informazioni sul reindirizzamento dell'indirizzo IP e del token

Modalità di reindirizzamento di Gestore connessione Desktop remoto

Gestore connessione Desktop remoto può utilizzare il reindirizzamento dell'indirizzo IP o il reindirizzamento del token di routing per reindirizzare un client al server Host sessione Desktop remoto in cui sono attive le relative sessioni. Quando si configurano le impostazioni di Gestore connessione Desktop remoto nello strumento Configurazione host sessione Desktop remoto, è possibile scegliere la modalità di reindirizzamento del client.

Reindirizzamento dell'indirizzo IP

Per impostazione predefinita, un server Host sessione Desktop remoto utilizza il reindirizzamento dell'indirizzo IP, con cui il client esegue una query in Gestore connessione Desktop remoto e viene reindirizzato alla relativa sessione esistente tramite l'indirizzo IP del server. Per utilizzare questo metodo di reindirizzamento, i computer client devono essere in grado di connettersi direttamente tramite l'indirizzo IP ai server Host sessione Desktop remoto della farm. Se i client possono connettersi direttamente ai server Host sessione Desktop remoto, è consigliabile accettare il comportamento predefinito. È ad esempio necessario utilizzare il reindirizzamento dell'indirizzo IP se si utilizza una delle opzioni seguenti come soluzione di bilanciamento del carico:

  • Funzionalità di bilanciamento del carico di Gestore connessione Desktop remoto con round robin DNS

  • Bilanciamento carico di rete

  • Un servizio di bilanciamento del carico hardware che non supporta i token di routing di Gestore connessione Desktop remoto

Reindirizzamento del token di routing di Gestore connessione Desktop remoto

È possibile configurare un server Host sessione Desktop remoto in modo che utilizzi il reindirizzamento del token di routing di Gestore connessione Desktop remoto anziché il reindirizzamento dell'indirizzo IP. Utilizzare tuttavia questa modalità solo quando la soluzione di bilanciamento del carico in uso supporta l'utilizzo dei token di routing di Gestore connessione Desktop remoto.

Se si configura un server Host sessione Desktop remoto per l'utilizzo dei token di routing di Gestore connessione Desktop remoto come metodo di reindirizzamento, l'indirizzo IP del server Host sessione Desktop remoto non viene inviato al client ma integrato in un token. Quando un client si riconnette a un servizio di bilanciamento del carico, il token di routing viene utilizzato per reindirizzare il client alla relativa sessione esistente nel server Host sessione Desktop remoto corretto della farm.

Se si passa alla modalità di reindirizzamento del token, è possibile selezionare un solo indirizzo IP per la riconnessione. L'indirizzo selezionato deve soddisfare i criteri seguenti:

  • Deve essere l'indirizzo IP della scheda di rete collegata al servizio di bilanciamento del carico.

  • Deve essere l'indirizzo configurato nel servizio di bilanciamento del carico come indirizzo IP del server Host sessione Desktop remoto.

Nota

Selezionare un indirizzo IPv6 solo se la soluzione di bilanciamento del carico utilizzata supporta IPv6.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto


Informazioni sul reindirizzamento dedicato a una farm e sul reindirizzamento a una macchina virtuale

È possibile configurare un server Host sessione Desktop remoto per l'utilizzo con Gestore connessione Desktop remoto in modo da consentire due tipi di reindirizzamento:

  • Reindirizzamento dedicato farm

  • Reindirizzamento macchine virtuali

Reindirizzamento dedicato farm

Quando si registra l'indirizzo IP di ogni server Host sessione Desktop remoto della farm per un singolo nome di server farm Host sessione Desktop remoto in DNS, i client di Servizi Desktop remoto in ingresso tentano di connettersi al primo indirizzo IP per il nome di farm restituito da DNS. Il server Host sessione Desktop remoto che riceve la richiesta di connessione iniziale viene utilizzato come redirector.

Per aumentare le prestazioni del reindirizzamento di sessione in una server farm Host sessione Desktop remoto di grandi dimensioni, è possibile configurare un server Host sessione Desktop remoto in modo che consenta il reindirizzamento dedicato per la farm. Questo server Host sessione Desktop remoto elabora le richieste in ingresso ma non accetta le sessioni utente. Per configurare il reindirizzamento dedicato a una farm, è necessario eseguire le operazioni seguenti:

  1. Configurare tutti i server Host sessione Desktop remoto della farm per l'utilizzo della stessa farm in Gestore connessione Desktop remoto. Per ulteriori informazioni, vedere Configurare un server Host sessione Desktop remoto per aggiungerlo a una farm in Gestore connessione Desktop remoto.

  2. Configurare un altro server Host sessione Desktop remoto in modo che consenta il reindirizzamento dedicato per la farm. È necessario configurare questo server Host sessione Desktop remoto con lo stesso nome di farm e lo stesso server Gestore connessione Desktop remoto degli altri server Host sessione Desktop remoto. L'unica differenza consiste nel fatto che per questo server Host sessione Desktop remoto è necessario selezionare Reindirizzamento dedicato farm (anziché Membro farm) nella finestra di dialogo Impostazioni di Gestore connessione Desktop remoto in Configurazione host sessione Desktop remoto.

    Importante

    Quando si configura un server Host sessione Desktop remoto per il rendirizzamento dedicato a una farm, la modalità di accesso utente del server Host sessione Desktop remoto viene impostata su Consenti le riconnessioni ma non i nuovi accessi. Per connettersi in remoto al fine di amministrare un server Host sessione Desktop remoto configurato per il reindirizzamento dedicato a una farm, utilizzare mstsc /admin.

  3. Creare una voce round robin DNS per il server Host sessione Desktop remoto che consente il rendirizzamento dedicato per la farm. Durante tale operazione è necessario eseguire il mapping dell'indirizzo IP di questo server Host sessione Desktop remoto al nome della farm in DNS. Per informazioni sull'aggiunta di una voce DNS per un nome di farm, vedere Configurare DNS per il bilanciamento del carico di Gestore connessione Desktop remoto.

È possibile configurare più server Host sessione Desktop remoto in modo che consentano il reindirizzamento dedicato per la farm. Per configurare a tale scopo un altro server Host sessione Desktop remoto, ripetere i passaggi 2 e 3.

Reindirizzamento macchine virtuali

Per consentire l'accesso degli utenti a un desktop virtuale personale o a macchine virtuali in un pool di desktop virtuali tramite Connessione RemoteApp e desktop, è necessario configurare un server Host sessione Desktop remoto per il reindirizzamento a una macchina virtuale.

Per configurare a tale scopo un server Host sessione Desktop remoto, selezionare Reindirizzamento macchine virtuali nella finestra di dialogo Impostazioni di Gestore connessione Desktop remoto in Configurazione host sessione Desktop remoto.

Quando si configura un server Host sessione Desktop remoto per il reindirizzamento a una macchina virtuale, al server Host sessione Desktop remoto vengono apportate le modifiche seguenti:

  • La modalità di accesso utente viene impostata su Consenti le riconnessioni ma non i nuovi accessi.

  • Tutti i programmi vengono rimossi dall'elenco Programmi RemoteApp in Gestione RemoteApp.

  • Il gruppo Authenticated Users viene aggiunto al gruppo Utenti desktop remoto.

Nota

Per connettersi in remoto al fine di amministrare un server Host sessione Desktop remoto configurato per il reindirizzamento a una macchina virtuale, utilizzare mstsc /admin.

Per ulteriori informazioni su come consentire l'accesso degli utenti a un desktop virtuale personale o a macchine virtuali in un pool di desktop virtuali tramite Connessione RemoteApp e desktop, vedere la Guida di Gestione connessione Desktop remoto in Windows Server 2008 R2.

Ulteriori riferimenti

Elenco di controllo: creare una server farm host sessione Desktop remoto con carico bilanciato mediante Gestore connessione Desktop remoto


Host sessione Desktop remoto

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto tramite Connessione Desktop remoto o RemoteApp.

Sono inclusi gli argomenti seguenti:

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

  • Elenco di controllo: configurare un server Host sessione Desktop remoto

  • Configurare un server Host sessione Desktop remoto

  • Gestire un server Host sessione Desktop remoto

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.


Panoramica di Host sessione Desktop remoto

Il ruolo server Servizi Desktop remoto in Windows Server 2008 R2 è costituito da diversi servizi ruolo, tra cui Host sessione Desktop remoto.

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto da una rete aziendale o da Internet utilizzando Connessione Desktop remoto o RemoteApp.

Per ulteriori informazioni su RemoteApp, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140439.

Quando un utente accede a un programma in un server Host sessione Desktop remoto, l'esecuzione del programma viene eseguita nel server. Ogni utente visualizza solo la propria sessione individuale. Tale sessione viene gestita in modo trasparente dal sistema operativo server ed è indipendente da qualsiasi altra sessione client.

Se si distribuisce un programma in un server Host sessione Desktop remoto anziché in ogni dispositivo, si ottengono numerosi vantaggi, tra cui i seguenti:

  • È possibile distribuire rapidamente programmi basati su Windows nei computer di un'organizzazione. Ciò è particolarmente utile quando si dispone di programmi aggiornati di frequente, utilizzati raramente o difficili da gestire.

  • Gli utenti possono accedere ai programmi in esecuzione in un server Host sessione Desktop remoto da dispositivi quali computer di casa, chioschi multimediali, componenti hardware che potrebbero non soddisfare i requisiti del sistema operativo o dell'applicazione e sistemi operativi diversi da Windows.

  • I dipendenti di succursali che devono accedere ad archivi dati centralizzati possono ottenere migliori prestazioni dei programmi accedendo a un programma in remoto in un Host sessione Desktop remoto. I programmi che richiedono un utilizzo intensivo di dati non dispongono in genere di protocolli client/server ottimizzati per connessioni a bassa velocità. I programmi di questo tipo offrono in genere prestazioni migliori se si utilizza una connessione di Servizi Desktop remoto anziché una normale Wide Area Network.

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.


Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto tramite Connessione Desktop remoto o RemoteApp.

In questo elenco di controllo sono incluse le attività che un amministratore deve eseguire prima di installare e configurare un server Host sessione Desktop remoto.

Nota

Non è consigliabile installare il servizio ruolo Host sessione Desktop remoto in un controller di dominio Active Directory®. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

Attività Riferimento

Determinare se è necessario un server Host sessione Desktop remoto.

Per consentire connessioni remote esclusivamente a scopo amministrativo, non è necessario installare un server Host sessione Desktop remoto.

Per ulteriori informazioni sulle connessioni remote per scopo amministrativo, vedere Utilizzare Desktop remoto.

Analizzare i requisiti relativi alle licenze per un server Host sessione Desktop remoto.

Ogni utente o dispositivo di elaborazione che si connette a un server Host sessione Desktop remoto deve disporre di una licenza CAL (Client Access License) Servizi Desktop remoto valida.

Un server Host sessione Desktop remoto che esegue Windows Server 2008 R2 deve essere configurato per l'utilizzo di almeno un server licenze che esegue Windows Server 2008 e in tale server devono essere installate licenze CAL Servizi Desktop remoto valide.

Per ulteriori informazioni sui requisiti di gestione delle licenze per Servizi Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Determinare i programmi che si desidera ospitare nel server Host sessione Desktop remoto.

È consigliabile installare il servizio ruolo Host sessione Desktop remoto nel computer prima di installare qualsiasi programma che si desidera rendere disponibile per gli utenti. Se si installa il servizio ruolo Host sessione Desktop remoto in un computer in cui sono già installati programmi, alcuni dei programmi esistenti potrebbero non funzionare correttamente in un ambiente multiutente. È possibile che tali problemi vengano risolti disinstallando e quindi reinstallando i programmi interessati.

Per ulteriori informazioni, vedere Installare programmi in un server Host sessione Desktop remoto.

Analizzare le informazioni relative a:

  • Requisiti hardware

  • Capacità e scalabilità

Vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Determinare se è necessario distribuire una server farm Host sessione Desktop remoto con carico bilanciato.

Per ulteriori informazioni su Gestore connessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140432.

Determinare la modalità gestione licenze Desktop remoto che verrà utilizzata dal server Host sessione Desktop remoto.

La modalità gestione licenze Desktop remoto configurata in un server Host sessione Desktop remoto deve corrispondere al tipo delle licenze CAL Servizi Desktop remoto disponibile nel server licenze Desktop remoto.

Per ulteriori informazioni, vedere Specificare la modalità di gestione licenze Desktop remoto.

Determinare il server licenze Desktop remoto a cui il server Host sessione Desktop remoto richiederà licenze CAL Servizi Desktop remoto.

Un server Host sessione Desktop remoto deve essere configurato per specificare un server licenze Desktop remoto a cui richiedere licenze CAL Servizi Desktop remoto per gli utenti o i dispositivi di elaborazione che si connettono al server Host sessione Desktop remoto.

Per ulteriori informazioni, vedere Specificare un server licenze per il server Host sessione Desktop remoto.

Determinare gli utenti autorizzati a connettersi in remoto al server Host sessione Desktop remoto.

Il gruppo Utenti desktop remoto in un server Host sessione Desktop remoto consente di concedere a utenti e gruppi l'autorizzazione necessaria per accedere in remoto al server Host sessione Desktop remoto.

Per ulteriori informazioni, vedere Configurare il gruppo Utenti desktop remoto.

Stabilire se è necessario distribuire un server Gateway Desktop remoto.

Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Determinare se per il server Host sessione Desktop remoto è necessario configurare l'impostazione Autenticazione a livello di rete.

È possibile migliorare la protezione del server Host sessione Desktop remoto consentendo l'autenticazione utente in una fase precedente del processo di connessione, ovvero quando un client si connette a un server Host sessione Desktop remoto. Questo metodo di autenticazione anticipata dell'utente viene definito Autenticazione a livello di rete.

Per ulteriori informazioni, vedere Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto.

Analizzare le informazioni su Windows Firewall.

L'installazione del ruolo Servizi Desktop remoto comporta la modifica della configurazione di Windows Firewall.

Per ulteriori informazioni, vedere Servizi Desktop remoto e Windows Firewall.


Utilizzare Desktop remoto

Per consentire connessioni remote esclusivamente a scopo amministrativo, non è necessario installare il servizio ruolo Host sessione Desktop remoto. Attivare invece la funzionalità Desktop remoto nel computer che si desidera amministrare in modo remoto.

Nota

Desktop remoto supporta solo due connessioni remote simultanee al computer. Per queste connessioni, non sono necessarie licenze CAL (Client Access License) Servizi Desktop remoto.

Per attivare Desktop remoto in un computer Windows Server 2008 R2, eseguire la procedura seguente.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel computer che si intende configurare.

Per attivare Desktop remoto

  1. Avviare lo strumento Sistema. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare control system e quindi fare clic su OK.

  2. In Attività fare clic su Impostazioni di connessione remota.

  3. Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema fare clic su una delle opzioni seguenti, in base all'ambiente:

    • Consenti connessioni da computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro)

    • Consenti connessioni solo dai computer che eseguono Desktop remoto con Autenticazione a livello di rete (più sicuro)

    Per ulteriori informazioni sulle due opzioni, fare clic sul collegamento Suggerimenti per la scelta nella scheda Connessione remota.

  4. Fare clic su Seleziona utenti per aggiungere utenti e gruppi che devono connettersi al computer tramite Desktop remoto. Gli utenti e i gruppi aggiunti verranno inseriti nel gruppo Utenti desktop remoto.

    Nota

    I membri del gruppo Administrators locale possono connettersi anche se non sono presenti nell'elenco.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

  • Configurare il gruppo Utenti desktop remoto

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Installare Host sessione Desktop remoto in un controller di dominio

Non è consigliabile installare il servizio ruolo Host sessione Desktop remoto in un controller di dominio Active Directory. Consentendo agli utenti di eseguire programmi in un controller di dominio, si potrebbero provocare rischi per la sicurezza e problemi relativi alle prestazioni.

Se il servizio ruolo Host sessione Desktop remoto viene installato in un controller di dominio, sarà necessario modificare le impostazioni di sicurezza del controller di dominio per consentire agli utenti di accedere in remoto al server. Questo accesso remoto è controllato dall'assegnazione dei diritti utente Consenti accesso tramite Servizi Desktop remoto, che è possibile configurare utilizzando Console Gestione Criteri di gruppo.

Per impostazione predefinita, in un controller di dominio il diritto utente Consenti accesso tramite Servizi Desktop remoto è concesso solo al gruppo Administrators. Per consentire l'accesso remoto al server Host sessione Desktop remoto agli utenti che non sono membri del gruppo Administrators, è necessario concedere il diritto utente Consenti accesso tramite Servizi Desktop remoto al gruppo Utenti desktop remoto.

Per ulteriori informazioni sull'utilizzo di Console Gestione Criteri di gruppo per configurare le assegnazioni dei diritti utente, vedere la Guida di Console Gestione Criteri di gruppo in Windows Server 2008 R2.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Ulteriori riferimenti

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Servizi Desktop remoto e Windows Firewall

In Windows Server 2008 e Windows Server 2008 R2 Windows Firewall è attivato per impostazione predefinita. Windows Firewall consente di controllare i programmi o le porte che è possibile utilizzare per la comunicazione tra il server Windows Server 2008 o Windows Server 2008 R2 e altri computer nella rete o in Internet. Per consentire a un programma o a una porta di comunicare attraverso Windows Firewall, è necessario attivare un'eccezione.

Se si attiva Desktop remoto, in Windows Firewall viene automaticamente attivata la relativa eccezione.

Quando è installato il servizio ruolo Host sessione Desktop remoto, in Windows Firewall vengono automaticamente attivate le eccezioni seguenti:

  • Desktop remoto

  • Servizi Desktop remoto

Se si installano altri servizi ruolo di Servizi Desktop remoto, in Windows Firewall verranno automaticamente attivate altre eccezioni. Quando ad esempio si installa il servizio ruolo Servizio licenze Desktop remoto, in Windows Firewall viene attivata l'eccezione Server licenze Desktop remoto.

Quando si disinstalla, o si rimuove, un servizio ruolo dal computer, in Windows Firewall viene automaticamente rimossa la relativa eccezione.

Importante

Quando il servizio ruolo Host sessione Desktop remoto viene disinstallato, ovvero rimosso, viene rimossa solo l'eccezione Servizi Desktop remoto, non l'eccezione Desktop remoto.

Per visualizzare le eccezioni di Windows Firewall, eseguire la procedura seguente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per visualizzare le eccezioni di Windows Firewall

  1. Fare clic sul pulsante Start e quindi scegliere Pannello di controllo.

  2. Fare clic su Sistema e sicurezza e quindi su Windows Firewall.

  3. Fare clic su Consenti programma o funzionalità con Windows Firewall.

  4. Se la casella di controllo associata al programma o alla porta nell'elenco è selezionata, l'eccezione di Windows Firewall per tale programma o porta è attivata.

    Alcuni programmi vengono visualizzati nell'elenco solo dopo l'installazione del servizio ruolo. L'eccezione Server licenze Desktop remoto viene ad esempio visualizzata nell'elenco solo quando il servizio ruolo Servizio licenze Desktop remoto è installato nel computer.

Per visualizzare informazioni più dettagliate sulle impostazioni di Windows Firewall, utilizzare lo snap-in Windows Firewall con sicurezza avanzata.

Per utilizzare Windows Firewall con sicurezza avanzata, eseguire la procedura seguente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per utilizzare lo snap-in Windows Firewall con sicurezza avanzata

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Windows Firewall con sicurezza avanzata.

  2. Per visualizzare informazioni dettagliate sulle impostazioni di Windows Firewall, fare clic su uno dei nodi seguenti nel riquadro di sinistra:

    • Regole connessioni in entrata

    • Regole connessioni in uscita

Per ulteriori informazioni sulla configurazione di Windows Firewall, vedere la Guida di Windows Firewall con sicurezza avanzata in Windows Server 2008 R2.

Per ulteriori informazioni sulle eccezioni di Windows Firewall specifiche di Servizi Desktop remoto, vedere la pagina relativa alla documentazione tecnica di Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?Linkid=138056.

Ulteriori riferimenti

  • Utilizzare Desktop remoto

  • Installare il servizio ruolo Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Elenco di controllo: configurare un server Host sessione Desktop remoto

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto tramite Connessione Desktop remoto o RemoteApp.

In questo elenco di controllo sono incluse le attività che gli amministratori devono eseguire per installare e configurare un server Host sessione Desktop remoto.

Tenere presente quanto segue:

  • L'installazione del servizio ruolo Host sessione Desktop remoto richiede il riavvio del computer.

  • Non è consigliabile installare il servizio ruolo Host sessione Desktop remoto in un controller di dominio Active Directory. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

  • È consigliabile installare il servizio ruolo Host sessione Desktop remoto nel computer prima di installare qualsiasi programma che si desidera rendere disponibile per gli utenti. Per ulteriori informazioni, vedere Installare programmi in un server Host sessione Desktop remoto.

Attività | Riferimento
Analizzare i prerequisiti per l'installazione del servizio ruolo Host sessione Desktop remoto. | Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto
Installare il servizio ruolo Host sessione Desktop remoto. | Installare il servizio ruolo Host sessione Desktop remoto
Configurare le impostazioni relative alle licenze nel server Host sessione Desktop remoto. | Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto
Configurare l'impostazione Autenticazione a livello di rete per il server Host sessione Desktop remoto. | Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto
Installare programmi nel server Host sessione Desktop remoto. | Installare programmi in un server Host sessione Desktop remoto
Configurare gli utenti autorizzati a connettersi in remoto al server Host sessione Desktop remoto. | Configurare il gruppo Utenti desktop remoto

Ulteriori riferimenti

  • Panoramica di Host sessione Desktop remoto


Configurare un server Host sessione Desktop remoto

In questa sezione sono incluse le procedure per la configurazione di un server Host sessione Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Installare il servizio ruolo Host sessione Desktop remoto

  • Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto

  • Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

  • Installare programmi in un server Host sessione Desktop remoto

  • Configurare il gruppo Utenti desktop remoto

  • Configurare l'esperienza client in un server Host sessione Desktop remoto

Ulteriori riferimenti

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

  • Elenco di controllo: configurare un server Host sessione Desktop remoto


Installare il servizio ruolo Host sessione Desktop remoto

In Windows Server 2008 R2 è possibile utilizzare Server Manager per installare il servizio ruolo Host sessione Desktop remoto. Per ulteriori informazioni su altri modi per installare il servizio ruolo Host sessione Desktop remoto, incluso l'utilizzo dello strumento da riga di comando servermanagercmd.exe, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?linkid=138055.

Per installare il servizio ruolo Host sessione Desktop remoto tramite Server Manager se Servizi Desktop remoto non è già installato nel server, eseguire la procedura seguente. Se Servizi Desktop remoto è già installato nel server, vedere Installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Importante

L'installazione del servizio ruolo Host sessione Desktop remoto richiede il ravvio del computer.

Per installare il servizio ruolo Host sessione Desktop remoto

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro sinistro fare clic con il pulsante destro del mouse su Ruoli e quindi scegliere Aggiungi ruoli.

  3. Nella pagina Prima di iniziare dell'Aggiunta guidata ruoli fare clic su Avanti.

  4. Nella pagina Selezione ruoli server selezionare la casella di controllo Servizi Desktop remoto in Ruoli.

    Nota

    Se Servizi Desktop remoto è già installato nel server, la casella di controllo Servizi Desktop remoto risulterà selezionata, in grigio e seguita dalla dicitura "(Installata)".

  5. Fare clic su Avanti.

  6. Nella pagina Servizi Desktop remoto fare clic su Avanti.

  7. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

    Nota

    Se si installa il servizio ruolo Host sessione Desktop remoto in un controller di dominio, verrà visualizzato un messaggio di avviso in quanto l'installazione del servizio ruolo Host sessione Desktop remoto in un controller di dominio non è consigliata. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

  8. Nella pagina Disinstallazione e reinstallazione di applicazioni per la compatibilità fare clic su Avanti.

  9. Nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto selezionare il metodo di autenticazione appropriato per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sui metodi di autenticazione, vedere Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto.

  10. Nella pagina Impostazione modalità di gestione licenze selezionare la modalità di gestione licenze appropriata per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sulle modalità di gestione licenze, vedere Specificare la modalità di gestione licenze Desktop remoto.

  11. Nella pagina Selezione dei gruppi di utenti autorizzati ad accedere al server Host sessione Desktop remoto aggiungere gli utenti o i gruppi di utenti a cui si desidera consentire la connessione remota al server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare il gruppo Utenti desktop remoto.

  12. Nella pagina Configura esperienza client selezionare le funzionalità che si desidera rendere disponibili ai client remoti connessi mediante il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare l'esperienza client in un server Host sessione Desktop remoto.

  13. Nella pagina Conferma selezioni per l'installazione verificare che il servizio ruolo Host sessione Desktop remoto venga installato e quindi fare clic su Installa.

  14. Nella pagina Stato installazione verrà indicato lo stato di avanzamento dell'installazione.

  15. Nella pagina Risultati installazione verrà richiesto di riavviare il server per completare il processo di installazione. Fare clic su Chiudi e quindi su Sì nella finestra Aggiunta servizi ruolo per riavviare il server.

  16. Se viene segnalato che altri programmi sono ancora in esecuzione, eseguire una delle operazioni seguenti:

    • Per chiudere i programmi manualmente e riavviare il server in un secondo momento, fare clic su Annulla.

    • Per chiudere i programmi automaticamente e riavviare il server, fare clic su Riavvia.

  17. Dopo aver riavviato il server e aver eseguito l'accesso al computer, verranno completati gli altri passaggi dell'installazione. Quando viene visualizzata la pagina Risultati installazione, verificare che l'installazione di Host sessione Desktop remoto sia stata eseguita correttamente.

    Per verificare che Host sessione Desktop remoto sia stato installato è inoltre possibile eseguire la procedura seguente:

    1. Avviare Server Manager.

    2. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    3. In Servizi di sistema verificare che lo stato di Servizi Desktop remoto sia In esecuzione.

    4. In Servizi ruolo verificare che lo stato di Host sessione Desktop remoto sia Installato.

Installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato

Per installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato nel server, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Importante

L'installazione del servizio ruolo Host sessione Desktop remoto richiede il ravvio del computer.

Per installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro sinistro espandere Ruoli.

  3. Fare clic con il pulsante destro del mouse su Servizi Desktop remoto e quindi scegliere Aggiungi servizi ruolo.

  4. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

    Nota

    Se si installa il servizio ruolo Host sessione Desktop remoto in un controller di dominio, verrà visualizzato un messaggio di avviso in quanto l'installazione del servio ruolo Host sessione Desktop remoto in un controllo di dominio non è consigliata. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

  5. Nella pagina Disinstallazione e reinstallazione di applicazioni per la compatibilità fare clic su Avanti.

  6. Nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto selezionare il metodo di autenticazione appropriato per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sui metodi di autenticazione, vedere Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto.

  7. Nella pagina Impostazione modalità di gestione licenze selezionare la modalità di gestione licenze appropriata per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sulle modalità di gestione licenze, vedere Specificare la modalità di gestione licenze Desktop remoto.

  8. Nella pagina Selezione dei gruppi di utenti autorizzati ad accedere al server Host sessione Desktop remoto aggiungere gli utenti o i gruppi di utenti a cui si desidera consentire la connessione remota al server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare il gruppo Utenti desktop remoto.

  9. Nella pagina Configura esperienza client selezionare le funzionalità che si desidera rendere disponibili ai client remoti connessi mediante il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare l'esperienza client in un server Host sessione Desktop remoto.

  10. Nella pagina Conferma selezioni per l'installazione verificare che il servizio ruolo Host sessione Desktop remoto venga installato e quindi fare clic su Installa.

  11. Nella pagina Stato installazione verrà indicato lo stato dell'installazione.

  12. Nella pagina Risultati installazione verrà richiesto di riavviare il server per completare il processo di installazione. Fare clic su Chiudi e quindi su Sì nella finestra Aggiunta servizi ruolo per riavviare il server.

  13. Se viene segnalato che altri programmi sono ancora in esecuzione, eseguire una delle operazioni seguenti:

    • Per chiudere manualmente i programmi e riavviare il server in un secondo momento, fare clic su Annulla.

    • Per chiudere automaticamente i programmi e riavviare il server, fare clic su Riavvia.

  14. Dopo aver riavviato il server ed eseguito l'accesso al computer, verranno completati gli altri passaggi dell'installazione. Quando viene visualizzata la pagina Risultati installazione, verificare che l'installazione di Host sessione Desktop remoto sia stata eseguita correttamente.

    Per verificare che Host sessione Desktop remoto sia stato installato è inoltre possibile eseguire la procedura seguente:

    1. Avviare Server Manager.

    2. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    3. In Servizi di sistema verificare che lo stato di Servizi Desktop remoto sia In esecuzione.

    4. In Servizi ruolo verificare che lo stato di Host sessione Desktop remoto sia Installato.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

  • Elenco di controllo: configurare un server Host sessione Desktop remoto


Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto

Ogni utente o dispositivo di elaborazione che si connette a un server Host sessione Desktop remoto deve disporre di una licenza CAL (Client Access License) Servizi Desktop remoto valida rilasciata da un server licenze Desktop remoto.

Per garantire che un server Host sessione Desktop remoto possa contattare un server licenze Desktop remoto per richiedere licenze CAL Servizi Desktop remoto per i client, è necessario eseguire le operazioni seguenti nel server Host sessione Desktop remoto:

  • Specificare la modalità di gestione licenze Desktop remoto

  • Specificare un server licenze per il server Host sessione Desktop remoto

Per essere informati di eventuali problemi di configurazione della gestione licenze, utilizzare Diagnosi gestione licenze in Configurazione host sessione Desktop remoto. Per informazioni su Diagnosi gestione licenze, vedere l'argomento relativo all'identificazione di possibili problemi relativi alla gestione delle licenze per il server Host sessione Desktop remoto nella Guida di Configurazione host sessione Desktop remoto in Windows Server 2008 R2.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Specificare la modalità di gestione licenze Desktop remoto

La modalità gestione licenze Desktop remoto determina il tipo di licenze CAL (Client Access License) Servizi Desktop remoto richiesto da un server Host sessione Desktop remoto a un server licenze per conto di un client che si connette al server Host sessione Desktop remoto.

Importante

La modalità gestione licenze Desktop remoto configurata in un server Host sessione Desktop remoto deve corrispondere al tipo delle licenze CAL Servizi Desktop remoto disponibile nel server licenze.

Esistono due tipi di licenze CAL Servizi Desktop remoto:

  • Licenza CAL Per dispositivo di Servizi Desktop remoto: consente a un dispositivo, utilizzato da qualsiasi utente, di connettersi a un server Host sessione Desktop remoto.

  • Licenza CAL Per utente di Servizi Desktop remoto: concede a un utente il diritto di accedere a server Host sessione Desktop remoto da un numero illimitato di dispositivi o computer client.

La modalità gestione licenze Desktop remoto per il server Host sessione Desktop remoto può essere impostata nei modi seguenti:

  • Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, nella pagina Impostazione modalità di gestione licenze nell'Aggiunta guidata ruoli.

    Nella pagina Impostazione modalità di gestione licenze è possibile selezionare Configura in seguito se durante l'installazione non si è certi se selezionare Per dispositivo o Per utente. Se si seleziona Configura in seguito, ogni volta che si accede al server Host sessione Desktop remoto nell'angolo in basso a destra del desktop verrà visualizzato un messaggio indicante che è necessario configurare la modalità gestione licenze per il server Host sessione Desktop remoto.

  • Configurando l'opzione Modalità di gestione licenze di Desktop remoto per il server Host sessione Desktop remoto tramite lo strumento Configurazione host sessione Desktop remoto.

    Se le impostazioni di Modalità di gestione licenze di Desktop remoto sono visualizzate in grigio e non possono essere selezionate, l'impostazione di Criteri di gruppo Imposta modalità gestione licenze Desktop remoto è stata attivata e applicata al server Host sessione Desktop remoto.

  • Applicando l'impostazione di Criteri di gruppo Imposta la modalità Licenze Desktop remoto.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Gestione licenze e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto


Specificare un server licenze per il server Host sessione Desktop remoto

Un server Host sessione Desktop remoto deve essere in grado di contattare un server licenze Desktop remoto per richiedere licenze CAL (Client Access License) Servizi Desktop remoto per gli utenti o i dispositivi di elaborazione che si connettono al server Host sessione Desktop remoto.

In Windows Server 2008 R2 è necessario specificare un server licenze per l'utilizzo da parte del server Host sessione Desktop remoto. L'individuazione automatica del server licenze non è più supportata per un server Host sessione Desktop remoto che esegue Windows Server 2008 R2.

Eseguire la procedura seguente per specificare un server licenze per l'utilizzo da parte del server Host sessione Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare un server licenze per il server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nella sezione Modifica impostazioni fare doppio clic su Server licenze Desktop remoto in Gestione licenze.

  4. Fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiungi server licenze selezionare un server licenze nell'elenco dei server di questo tipo noti e quindi fare clic su Aggiungi. Se il server licenze che si desidera aggiungere non è incluso nell'elenco, nella casella Nome o indirizzo IP del server licenze digitare il nome o l'indirizzo IP del server licenze da aggiungere e quindi fare clic su Aggiungi.

    È possibile aggiungere più server licenze per l'utilizzo da parte del server Host sessione Desktop remoto. Il server Host sessione Desktop remoto contatterà i server licenze nell'ordine in cui sono visualizzati nella casella Server licenze specificati.

  6. Fare clic su OK per chiudere la finestra di dialogo Aggiungi server licenze e quindi di nuovo su OK per salvare le modifiche relative alle impostazioni di gestione delle licenze.

È inoltre possibile specificare un server licenze per l'utilizzo da parte del server Host sessione Desktop remoto applicando l'impostazione di Criteri di gruppo Usa server licenze Desktop remoto specificati. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Gestione licenze e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sui server licenze configurati in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto


Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

Autenticazione a livello di rete consente di migliorare la sicurezza di un server Host sessione Desktop remoto richiedendo che l'utente venga autenticato in un server Host sessione Desktop remoto prima della creazione di una sessione.

Autenticazione a livello di rete è un metodo di autenticazione che consente di completare l'autenticazione dell'utente prima che venga stabilita una connessione desktop remoto e che venga visualizzata la schermata di accesso. Si tratta di un metodo di autenticazione più sicuro che contribuisce a proteggere il computer remoto da utenti malintenzionati e software dannoso. Autenticazione a livello di rete offre i vantaggi seguenti:

  • Richiede un minore dispendio iniziale di risorse per il computer remoto. Il computer remoto utilizza una quantità limitata di risorse prima di eseguire l'autenticazione dell'utente, anziché avviare una connessione desktop remoto completa come accade nelle versioni precedenti.

  • Offre un migliore livello di sicurezza, riducendo il rischio di attacchi Denial of Service.

Per poter utilizzare Autenticazione a livello di rete, devono essere soddisfatti i requisiti seguenti:

  • Il computer client deve utilizzare almeno Connessione desktop remoto 6.0.

  • Il computer client deve utilizzare un sistema operativo, ad esempio Windows® 7 o Windows Vista®, che supporti il protocollo CredSSP (Credential Security Support Provider).

  • Il server Host sessione Desktop remoto deve utilizzare Windows Server 2008 R2 o Windows Server 2008.

È possibile configurare un server Host sessione Desktop remoto per supportare solo le connessioni da client che eseguono Autenticazione a livello di rete. È possibile configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto nei modi seguenti:

  • Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto dell'Aggiunta guidata ruoli.

  • Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto.

    Se l'opzione Consenti connessioni dai computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro) non è selezionata né attivata, l'impostazione di Criteri di gruppo Richiedi autenticazione utente tramite Autenticazione a livello di rete per le connessioni remote è stata attivata e applicata al server Host sessione Desktop remoto.

    Per configurare l'impostazione Autenticazione a livello di rete tramite la scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto, vedere Modificare le impostazioni di connessione remota.

  • Nella scheda Generale della finestra di dialogo Proprietà di una connessione nello strumento Configurazione host sessione Desktop remoto, selezionando la casella di controllo Consenti connessioni solo da computer che eseguono Desktop remoto con Autenticazione a livello di rete.

    Se la casella di controllo Consenti connessioni solo da computer che eseguono Desktop remoto con Autenticazione a livello di rete è selezionata e visualizzata in grigio, l'impostazione di Criteri di gruppo Richiedi autenticazione utente per le connessioni remote tramite Autenticazione a livello di rete è stata attivata e applicata al server Host sessione Desktop remoto.

  • Applicando l'impostazione di Criteri di gruppo Richiedi autenticazione utente tramite Autenticazione a livello di rete per le connessioni remote.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto o nella scheda Connessione remota.

Per determinare se un computer esegue una versione di Connessione desktop remoto che supporta il metodo Autenticazione a livello di rete, avviare Connessione desktop remoto, fare clic sull'icona nell'angolo in alto a sinistra della finestra di dialogo Connessione desktop remoto e quindi fare clic su Informazioni su. Nella finestra di dialogo Informazioni su Connessione desktop remoto ricercare la frase Autenticazione a livello di rete supportata.

Per ulteriori informazioni su Autenticazione a livello di rete e Servizi Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=138055.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Installare il servizio ruolo Host sessione Desktop remoto


Installare programmi in un server Host sessione Desktop remoto

È consigliabile installare il servizio ruolo Host sessione Desktop remoto nel computer prima di installare qualsiasi programma che si desidera rendere disponibile per gli utenti. Se si installa il servizio ruolo Host sessione Desktop remoto in un computer in cui sono già installati programmi, alcuni dei programmi esistenti potrebbero non funzionare correttamente in un ambiente multiutente. È possibile che tali problemi vengano risolti disinstallando e quindi reinstallando i programmi interessati.

Per garantire la corretta installazione di un'applicazione e il relativo funzionamento in un ambiente multiutente, è necessario attivare una speciale modalità di installazione nel server Host sessione Desktop remoto prima di installare l'applicazione nel server Host sessione Desktop remoto. Questa speciale modalità di installazione fa sì che durante il processo di installazione vengano creati le voci del Registro di sistema e i file con estensione ini corretti necessari per supportare l'esecuzione dell'applicazione in un ambiente multiutente.

È possibile attivare questa speciale modalità di installazione in un server Host sessione Desktop remoto utilizzando uno dei metodi seguenti:

  • Strumento Installa applicazione nel server desktop remoto in Programmi nel Pannello di controllo. Questo strumento esegue una procedura guidata per semplificare l'installazione dell'applicazione.

  • Comando Change user /install al prompt dei comandi. Sarà necessario avviare manualmente l'installazione dell'applicazione.

Al termine dell'installazione dell'applicazione, è necessario attivare la modalità di esecuzione nel server Host sessione Desktop remoto prima che gli utenti remoti inizino a utilizzare l'applicazione. Tramite lo strumento Installa applicazione nel server desktop remoto la modalità di esecuzione verrà automaticamente attivata nel server Host sessione Desktop remoto al termine dell'esecuzione. Per attivare la modalità di esecuzione nel server Host sessione Desktop remoto dal prompt dei comandi, utilizzare il comando change user /execute.

Ulteriori considerazioni

  • Per la corretta esecuzione in un server Host sessione Desktop remoto, alcuni programmi potrebbero richiedere modifiche minime a livello di configurazione.

  • Se sono presenti programmi con relazioni di correlazione o di dipendenza reciproca, è consigliabile installarli nello stesso server Host sessione Desktop remoto. È consigliabile, ad esempio, installare Microsoft Office come famiglia di prodotti nello stesso server Host sessione Desktop remoto anziché installare singoli programmi di Office in server Host sessione Desktop remoto distinti.

  • È consigliabile installare singoli programmi in server Host sessione Desktop remoto distinti nei casi seguenti:

    • Possono verificarsi problemi di compatibilità tra il programma e altri programmi.

    • Un singolo programma e il numero di utenti associati rischiano di esaurire la capacità del server.

  • Per ulteriori informazioni sugli strumenti da riga di comando per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138135.

  • Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto


Configurare il gruppo Utenti desktop remoto

Il gruppo Utenti desktop remoto in un server Host sessione Desktop remoto consente di concedere a utenti e gruppi l'autorizzazione necessaria per connettersi in remoto al server Host sessione Desktop remoto.

È possibile aggiungere utenti e gruppi al gruppo Utenti desktop remoto tramite i metodi seguenti:

  • Snap-in Utenti e gruppi locali

  • Snap-in Utenti e computer di Active Directory se il server Host sessione Desktop remoto è installato in un controller di dominio

  • Nella scheda Connessione remota della finestra di dialogo Proprietà sistema in un server Host sessione Desktop remoto

Per aggiungere utenti e gruppi al gruppo Utenti desktop remoto tramite la scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Per aggiungere utenti e gruppi al gruppo Utenti desktop remoto tramite la scheda Connessione remota

  1. Avviare lo strumento Sistema. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare control system e quindi fare clic su OK.

  2. In Attività fare clic su Impostazioni di connessione remota.

  3. Nella scheda Connessione remota nella finestra di dialogo Proprietà del sistema fare clic su Seleziona utenti. Aggiungere gli utenti o i gruppi che devono connettersi al server Host sessione Desktop remoto tramite Desktop remoto. Gli utenti e i gruppi aggiunti verranno inseriti nel gruppo Utenti desktop remoto.

    Nota

    I membri del gruppo Administrators locale possono connettersi anche se non sono presenti nell'elenco.

    Se nella scheda Connessione remota si seleziona Non consentire connessioni al computer, nessun utente potrà connettersi in remoto a questo computer, anche se è membro del gruppo Utenti desktop remoto.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto


Configurare l'esperienza client in un server Host sessione Desktop remoto

È possibile configurare un server Host sessione Desktop remoto in modo che gli utenti che si connettono a una sessione desktop remoto possano utilizzare una funzionalità simile a quella disponibile in Windows 7.

Importante

Per poter garantire questa funzionalità, sono necessarie ulteriori risorse di sistema e di larghezza di banda, che possono influire sulla scalabilità del server Host sessione Desktop remoto.

Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, è possibile configurare automaticamente le funzionalità seguenti nella pagina Configura esperienza client dell'Aggiunta guidata ruoli:

  • Reindirizzamento riproduzione audio e video

  • Reindirizzamento registrazione audio

  • Composizione desktop

Se si configura il server Host sessione Desktop remoto in modo da consentire la riproduzione audio e video o la composizione desktop, nel server Host sessione Desktop remoto verrà installata la funzionalità Esperienza desktop. Per ulteriori informazioni su Esperienza desktop, vedere Funzionalità Esperienza desktop.

Per configurare manualmente tale funzionalità, vedere gli argomenti seguenti:

  • Configurare la riproduzione audio e video in un server Host sessione Desktop remoto

  • Configurare il reindirizzamento della registrazione audio in un server Host sessione Desktop remoto

  • Configurare la composizione desktop in un server Host sessione Desktop remoto


Funzionalità Esperienza desktop

La funzionalità Esperienza desktop consente di installare una vasta gamma di componenti e funzionalità offerti dal sistema operativo Windows 7 in un computer che esegue il sistema operativo Windows Server 2008 R2. Dopo avere installato Esperienza desktop, i componenti e le funzionalità di Windows 7, ad esempio Windows Media Player, verranno visualizzati in Tutti i programmi nel menu Start.

Nota

L'installazione di Esperienza desktop non comporta l'attivazione automatica dei relativi componenti o funzionalità. Dopo aver installato Esperienza desktop, sarà infatti necessario attivare o configurare manualmente le funzionalità o i componenti desiderati.

Per informazioni sull'installazione di Esperienza desktop, vedere Installare Esperienza desktop in un server Host sessione Desktop remoto.

Componenti e funzionalità di Esperienza desktop

Esperienza desktop include i componenti e le funzionalità di Windows 7 seguenti:

  • Calendario di Windows

  • Windows Mail

  • Windows Media Player

  • Temi del desktop

  • Video per Windows (supporto AVI)

  • Raccolta foto di Windows

  • Windows SideShow

  • Windows Defender

  • Pulizia disco

  • Centro sincronizzazione

  • Registratore di suoni

  • Mappa caratteri

  • Strumento di cattura

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Installare Esperienza desktop in un server Host sessione Desktop remoto

Quando un utente utilizza Connessione Desktop remoto per connettersi a un server Host sessione Desktop remoto, per impostazione predefinita viene riprodotto il desktop presente nel server Host sessione Desktop remoto nella sessione remota. Per conferire alla sessione remota lo stesso aspetto dell'esperienza desktop di Windows 7 locale dell'utente, installare la funzionalità Esperienza desktop in un server Host sessione Desktop remoto che esegue Windows Server 2008 R2.

Esperienza desktop consente di installare componenti e funzionalità di Windows 7, ad esempio Windows Media Player, Windows Defender e il Calendario di Windows. Per ulteriori informazioni su Esperienza desktop, vedere Funzionalità Esperienza desktop.

Installare Esperienza desktop

Per installare Esperienza desktop nel server, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Importante

L'installazione di Esperienza desktop richiede il riavvio del computer.

Per installare Esperienza desktop

  1. Aprire Gestione server. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Gestione server.

  2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità fare clic su Aggiungi funzionalità.

  3. Nella pagina Selezione funzionalità selezionare la casella di controllo Esperienza desktop.

  4. Verificare le informazioni relative alle funzionalità necessarie da installare con Esperienza desktop e quindi fare clic su Aggiungi funzionalità necessarie.

  5. Fare clic su Avanti.

  6. Nella pagina Conferma selezioni per l'installazione verificare che la funzionalità Esperienza desktop verrà installata e quindi fare clic su Installa.

  7. Nella pagina Stato installazione verrà indicato lo stato di avanzamento dell'installazione.

  8. Nella pagina Risultati installazione verrà richiesto di riavviare il server per completare il processo di installazione. Fare clic su Chiudi e quindi su Sì per riavviare il server.

  9. Dopo aver riavviato il server e aver eseguito l'accesso al computer con lo stesso account utente, verranno completati gli altri passaggi dell'installazione. Quando viene visualizzata la pagina Risultati installazione, verificare che l'installazione di Esperienza desktop sia stata eseguita correttamente e quindi fare clic su Chiudi.

    È inoltre possibile verificare che la funzionalità Esperienza desktop sia installata eseguendo la procedura seguente:

    1. Avviare Server Manager.

    2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità verificare che Esperienza desktop sia elencata come installata.

Dopo avere installato Esperienza desktop, i componenti e le funzionalità di Windows 7, ad esempio Windows Media Player, verranno visualizzati in Tutti i programmi nel menu Start.

Disinstallare (rimuovere) Esperienza desktop

Per disinstallare, ovvero rimuovere, Esperienza desktop dal server, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Importante

La rimozione di Esperienza desktop dal server richiede il riavvio del computer.

Per disinstallare (rimuovere) Esperienza desktop

  1. Aprire Gestione server. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Gestione server.

  2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità fare clic su Rimuovi funzionalità.

  3. Nella pagina Selezione delle funzionalità deselezionare la casella di controllo Esperienza desktop e quindi fare clic su Avanti.

  4. Nella pagina Conferma selezioni per la rimozione verificare che la funzionalità Esperienza desktop verrà rimossa e quindi fare clic su Rimuovi.

  5. Nella pagina Stato rimozione verrà indicato lo stato di avanzamento della rimozione.

  6. Nella pagina Risultati rimozione verrà richiesto di riavviare il server per completare il processo di rimozione. Fare clic su Chiudi e quindi su Sì per riavviare il server.

  7. Dopo aver riavviato il server e aver eseguito l'accesso al computer con lo stesso account utente, verranno completati gli altri passaggi della rimozione. Quando viene visualizzata la pagina Risultati rimozione, verificare che la rimozione di Esperienza desktop sia stata eseguita correttamente e quindi fare clic su Chiudi.

    È inoltre possibile verificare che la funzionalità Esperienza desktop sia stata rimossa eseguendo la procedura seguente:

    1. Avviare Server Manager.

    2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità verificare che Esperienza desktop non sia più elencata come installata.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Configurare la riproduzione audio e video in un server Host sessione Desktop remoto

La riproduzione audio e video consente agli utenti di reindirizzare l'audio del computer remoto in una sessione remota, garantendo una migliore esperienza di riproduzione video nelle sessioni remote. Per impostazione predefinita, la riproduzione audio e video non è consentita quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2.

Nota

Gli utenti possono specificare dove riprodurre l'output audio del computer remoto configurando le impostazioni per l'audio remoto nella scheda Risorse locali di Connessione desktop remoto. La riproduzione video può essere configurata utilizzando l'impostazione videoplayback in un file Remote Desktop Protocol (con estensione rdp). La riproduzione video è attivata per impostazione predefinita.

Configurare manualmente la riproduzione audio e video

Per configurare manualmente la riproduzione audio e video in un server Host sessione Desktop remoto, è necessario eseguire le operazioni seguenti:

  • Installare la funzionalità Esperienza desktop.

  • Avviare il servizio Audio di Windows.

  • Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video.

  • Impostare l'intensità di colore massima su 32 bit per pixel.

Installare la funzionalità Esperienza desktop

Per informazioni sull'installazione di Esperienza desktop, vedere Installare Esperienza desktop in un server Host sessione Desktop remoto.

Avviare il servizio Audio di Windows

Per avviare il servizio Audio Windows nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per avviare il servizio Audio di Windows

  1. Nel server Host sessione Desktop remoto aprire lo snap-in Servizi. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nel riquadro Servizi fare clic con il pulsante destro del mouse su Audio di Windows e quindi scegliere Proprietà.

  4. Nella casella Tipo di avvio nella scheda Generale selezionare Automatico e quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà - Audio di Windows.

  7. Verificare che nella colonna Stato relativa al servizio Audio di Windows sia visualizzato Avviato.

Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video.

Per consentire la riproduzione audio e video quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2, è necessario attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video. L'impostazione Consenti reindirizzamento riproduzione audio e video è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Impostare l'intensità di colore massima su 32 bit per pixel

Per impostare l'intensità di colore massima su 32 bit per pixel nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per impostare l'intensità di colore massima su 32 bit per pixel

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. In Connessioni fare clic con il pulsante destro del mouse sulla connessione da configurare, ad esempio RDP-Tcp, e quindi scegliere Proprietà.

  4. Nella casella Limita intensità colore massima nella scheda Impostazioni client selezionare 32 bit per pixel.

  5. Fare clic su OK. Quando si apporta una modifica alle impostazioni dell'intensità del colore, questa non verrà applicata alle sessioni connesse al momento della modifica. Le modifiche diventeranno effettive alla successiva connessione dell'utente al server Host sessione Desktop remoto.

È inoltre possibile impostare l'intensità del colore massima applicando l'impostazione di Criteri di gruppo Limita intensità colore massima. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Configurare il reindirizzamento della registrazione audio in un server Host sessione Desktop remoto

Il reindirizzamento della registrazione audio consente agli utenti di effettuare registrazioni audio nel computer remoto in una sessione remota. Per impostazione predefinita, il reindirizzamento della registrazione audio non è consentito quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2.

Nota

Gli utenti possono specificare se registrare l'audio nel computer remoto configurando le impostazioni per l'audio remoto nella scheda Risorse locali di Connessione desktop remoto. Per tali registrazioni possono utilizzare un dispositivo di input audio, quale un microfono incorporato, nel computer locale.

Configurare manualmente il reindirizzamento della registrazione audio

Per configurare manualmente il reindirizzamento della registrazione audio in un server Host sessione Desktop remoto, è necessario eseguire le operazioni seguenti:

  • Avviare il servizio Audio di Windows.

  • Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio.

Avviare il servizio Audio di Windows

Per avviare il servizio Audio Windows nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per avviare il servizio Audio di Windows

  1. Nel server Host sessione Desktop remoto aprire lo snap-in Servizi. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nel riquadro Servizi fare clic con il pulsante destro del mouse su Audio di Windows e quindi scegliere Proprietà.

  4. Nella casella Tipo di avvio nella scheda Generale selezionare Automatico e quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia.

  6. Fare clic su OK per chiudere la finestra di dialogo Audio di Windows - Proprietà.

  7. Verificare che nella colonna Stato relativa al servizio Audio di Windows sia visualizzato Avviato.

Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio

Per consentire il reindirizzamento della registrazione audio quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2, è necessario attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Configurare la composizione desktop in un server Host sessione Desktop remoto

La composizione desktop offre gli elementi di interfaccia utente tipici di Windows Aero, ad esempio finestre semitrasparenti, per le sessioni desktop remoto. Per impostazione predefinita, la composizione desktop non è consentita quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2.

Importante

Poiché per Windows Aero sono necessarie ulteriori risorse di sistema e di larghezza di banda, la configurazione della composizione desktop per sessioni desktop remoto può ridurre le prestazioni delle connessioni, in particolare in presenza di collegamenti lenti, e aumentare il carico del server Host sessione Desktop remoto.

La composizione desktop non è disponibile per le sessioni di RemoteApp. Per supportare le funzionalità di Windows Aero, il computer client deve inoltre disporre dell'hardware necessario.

Configurare manualmente la composizione desktop

Per configurare manualmente la composizione desktop in un server Host sessione Desktop remoto, è necessario eseguire le operazioni seguenti:

  • Installare la funzionalità Esperienza desktop.

  • Avviare il servizio Temi.

  • Attivare l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto.

  • Impostare l'intensità di colore massima su 32 bit per pixel.

Installare la funzionalità Esperienza desktop

Per informazioni sull'installazione di Esperienza desktop, vedere Installare Esperienza desktop in un server Host sessione Desktop remoto.

Avviare il servizio Temi

Per avviare il servizio Temi nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per avviare il servizio Temi

  1. Nel server Host sessione Desktop remoto aprire lo snap-in Servizi. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nel riquadro Servizi fare clic con il pulsante destro del mouse su Temi e quindi scegliere Proprietà.

  4. Nella casella Tipo di avvio nella scheda Generale selezionare Automatico e quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà - Temi.

  7. Verificare che nella colonna Stato relativa al servizio Temi sia visualizzato Avviato.

Attivare l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto

Per consentire la composizione desktop quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2, è necessario attivare l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Impostare l'intensità di colore massima su 32 bit per pixel

Per impostare l'intensità di colore massima su 32 bit per pixel nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per impostare l'intensità di colore massima su 32 bit per pixel

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. In Connessioni fare clic con il pulsante destro del mouse sulla connessione da configurare, ad esempio RDP-Tcp, e quindi scegliere Proprietà.

  4. Nella casella Limita intensità colore massima nella scheda Impostazioni client selezionare 32 bit per pixel.

  5. Fare clic su OK. Quando si apporta una modifica alle impostazioni dell'intensità del colore, questa non verrà applicata alle sessioni connesse al momento della modifica. Le modifiche diventeranno effettive alla successiva connessione dell'utente al server Host sessione Desktop remoto.

È inoltre possibile impostare l'intensità del colore massima applicando l'impostazione di Criteri di gruppo Limita intensità colore massima. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Impostazioni di Criteri di gruppo e configurazione di Esperienza client

Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, è possibile configurare automaticamente le funzionalità seguenti nella pagina Configura esperienza client dell'Aggiunta guidata ruoli:

  • Reindirizzamento riproduzione audio e video

  • Reindirizzamento registrazione audio

  • Composizione desktop

Server Manager verifica automaticamente se attualmente al computer sono applicate impostazioni di Criteri di gruppo che possono impedire la corretta configurazione delle funzionalità richieste. In caso affermativo, la relativa selezione risulterà visualizzata in grigio e non sarà possibile selezionare la casella di controllo associata nella pagina Configura esperienza client.

Di seguito è riportato un elenco delle impostazioni di Criteri di gruppo verificate da Server Manager:

  • Consenti reindirizzamento riproduzione audio e video

    Se l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video è disattivata, non sarà possibile selezionare la casella di controllo Reindirizzamento riproduzione audio e video nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse.

  • Consenti reindirizzamento registrazione audio

    Se l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio è disattivata, non sarà possibile selezionare la casella di controllo Reindirizzamento registrazione audio nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse.

  • Consenti composizione desktop per sessioni desktop remoto

    Se l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto è disattivata, non sarà possibile selezionare la casella di controllo Composizione desktop nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota.

  • Limita intensità colore massima

    Se l'impostazione di Criteri di gruppo Limita intensità colore massima è attivata e l'intensità di colore massima selezionata è inferiore a 32 bit per pixel, non sarà possibile selezionare la casella di controllo Composizione desktop nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota.

Queste impostazioni di Criteri di gruppo possono essere configurate utilizzando l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Gestire un server Host sessione Desktop remoto

In questa sezione sono incluse le procedure per la gestione di un server Host sessione Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Modificare le impostazioni di connessione remota

  • Attivare Single Sign-On del client di Connessione desktop remoto per Servizi Desktop remoto

  • Gestire i profili utente per Servizi Desktop remoto

  • Configurare i caratteri smussati per le sessioni remote

  • Monitorare un server Host sessione Desktop remoto con Gestione risorse di sistema Windows

  • Disinstallare il servizio ruolo Host sessione Desktop remoto


Modificare le impostazioni di connessione remota

È possibile eseguire la procedura seguente per modificare le impostazioni di connessione remota in un server Host sessione Desktop remoto.

Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema nel server Host sessione Desktop remoto è possibile modificare le impostazioni di connessione remota seguenti:

  • Requisito Autenticazione a livello di rete per le connessioni desktop remoto

  • Appartenenza al gruppo Utenti desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Per modificare le impostazioni di connessione remota

  1. Avviare lo strumento Sistema. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare control system e quindi fare clic su OK.

  2. In Attività fare clic su Impostazioni di connessione remota.

  3. Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema fare clic su una delle opzioni seguenti, in base all'ambiente:

    • Consenti connessioni da computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro)

    • Consenti connessioni solo dai computer che eseguono Desktop remoto con Autenticazione a livello di rete (più sicuro)

    Per ulteriori informazioni sulle due opzioni, fare clic sul collegamento Suggerimenti per la scelta nella scheda Connessione remota.

    Se nella scheda Connessione remota si seleziona Non consentire connessioni al computer, nessun utente potrà connettersi in remoto a questo computer, anche se è membro del gruppo Utenti desktop remoto.

  4. Fare clic su Seleziona utenti per aggiungere utenti e gruppi che devono connettersi al computer tramite Desktop remoto. Gli utenti e i gruppi aggiunti verranno inseriti nel gruppo Utenti desktop remoto.

    Nota

    I membri del gruppo Administrators locale possono connettersi anche se non sono presenti nell'elenco.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto

  • Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

  • Configurare il gruppo Utenti desktop remoto


Attivare Single Sign-On del client di Connessione desktop remoto per Servizi Desktop remoto

Single Sign-On è un metodo di autenticazione che consente agli utenti che dispongono di un account di dominio di eseguire un accesso a un computer cliente utilizzando una password e quindi di accedere ai server remoti senza dover reimmettere le credenziali.

Nota

Questo argomento riguarda esclusivamente l'autenticazione Single Sign-On da un client di Connessione Desktop remoto a un server Host sessione Desktop remoto. In Windows Server 2008 R2 è possibile abilitare Single Sign-On anche tra Accesso Web Desktop remoto e Host sessione Desktop remoto. Per ulteriori informazioni su Single Sign-On con Accesso Web Desktop remoto, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137334.

Per implementare la funzionalità Single Sign-On in Servizi Desktop remoto, è necessario soddisfare i requisiti seguenti:

  • È possibile utilizzare Single Sign-On solo per connessioni remote da un computer che esegue Windows 7, Microsoft Windows Vista o Windows XP con Service Pack 3 a un server Host sessione Desktop remoto che esegue Windows Server 2008 R2 o Windows Server 2008. È inoltre possibile utilizzare Single Sign-On per connessioni remote da un server in cui è in esecuzione Windows Server 2008 R2 o Windows Server 2008 a un altro server in cui è in esecuzione Windows Server 2008 R2 o Windows Server 2008.

  • Verificare che gli account utente utilizzati per accedere dispongano di diritti appropriati per l'accesso al server Host sessione Desktop remoto e al computer client.

  • Il computer client e il server Host sessione Desktop remoto devono appartenere allo stesso dominio.

Per configurare le impostazioni consigliate per il server Host sessione Desktop remoto, eseguire le operazioni seguenti:

  • Configurare l'autenticazione nel server Host sessione Desktop remoto.

  • Configurare il computer client per consentire l'utilizzo di credenziali predefinite per l'accesso ai server Host sessione Desktop remoto specificati.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per configurare l'autenticazione nel server Host sessione Desktop remoto

  1. Aprire Configurazione host sessione Desktop remoto. Per aprire Configurazione host sessione Desktop remoto, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sulla connessione appropriata, ad esempio RDP-Tcp, e quindi scegliere Proprietà.

  3. Nella scheda Generale della finestra di dialogo Proprietà verificare che il valore di Livello di sicurezza sia impostato su Negoziazione o SSL (TLS 1.0).

  4. Nella scheda Impostazioni di accesso verificare che la casella di controllo Richiedi sempre password sia deselezionata e quindi fare clic su OK.

Dopo aver configurato l'autenticazione nel server Host sessione Desktop remoto, è necessario consentire l'utilizzo delle credenziali predefinite nel server Host sessione Desktop remoto tramite Criteri di gruppo. Le impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e possono essere configurate tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per ulteriori informazioni sulla sicurezza e su Servizi Desktop remoto, vedere la pagina relativa a tale funzionalità nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=138055.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Gestire i profili utente per Servizi Desktop remoto

Un profilo utente descrive la configurazione per un utente specifico, incluse le impostazioni relative all'ambiente e alle preferenze dell'utente. Se non vengono pianificati e gestiti nell'ambiente di un server Host sessione Desktop remoto, i profili utente possono assumere dimensioni elevate e causare problemi, ad esempio tempi di accesso prolungati, al momento della connessione di un utente a un server Host sessione Desktop remoto. La gestione dei profili utente è inoltre importante quando gli utenti si connettono a diversi server Host sessione Desktop remoto o si connettono a server Host sessione Desktop remoto in posizioni remote.

È possibile specificare una home directory e un percorso profilo specifici di Servizi Desktop remoto per un utente che si connette a un server Host sessione Desktop remoto. Il profilo e la home directory specificati verranno utilizzati solo per le sessioni di Servizi Desktop remoto. È opportuno assegnare un profilo separato per le sessioni di Servizi Desktop remoto in quanto molte delle opzioni comuni archiviate nei profili, ad esempio screen saver ed effetti di animazione dei menu, non sono consigliabili quando si utilizza Servizi Desktop remoto.

È possibile configurare manualmente queste impostazioni nella scheda Profilo Servizi Desktop remoto della finestra delle proprietà di un account utente nello snap-in Utenti e gruppi locali o Utenti e computer di Active Directory.

Per configurare queste impostazioni, è inoltre possibile utilizzare le impostazioni di Criteri di gruppo seguenti:

  • Imposta la home directory utente di Servizi Desktop remoto

  • Imposta percorso per profili utente mobile di Servizi Desktop remoto

  • Usa profili obbligatori nel server Host sessione Desktop remoto

Le impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Profili e possono essere configurate tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Nota

L'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto o nella scheda Connessione remota.

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Configurare i caratteri smussati per le sessioni remote

Windows Server 2008 R2 supporta ClearType®, una tecnologia che consente di visualizzare i tipi di carattere in modo che risultino chiari e uniformi, in particolare quando si utilizza un monitor LCD.

Un server Host sessione Desktop remoto che esegue Windows Server 2008 R2 può offrire la funzionalità ClearType in una sessione remota quando un computer client si connette al server Host sessione Desktop remoto tramite Connessione Desktop remoto.

Nota

In Connessione desktop remoto la funzionalità ClearType viene indicata come anti-aliasing caratteri.

Tale funzionalità è disponibile se il computer client esegue uno dei sistemi operativi seguenti:

  • Windows 7

  • Microsoft Windows Vista

  • Windows Server 2003 con Service Pack 1 (SP1) e almeno Connessione desktop remoto 6.0

  • Windows XP con SP2 e almeno Connessione desktop remoto 6.0

Importante

L'utilizzo di caratteri smussati in una sessione remota comporta l'aumento della larghezza di banda utilizzata tra il computer client e il server Host sessione Desktop remoto.

Per rendere disponibili i caratteri smussati in una sessione remota

  1. Nel computer client aprire Connessione desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Connessione desktop remoto.

  2. Nella finestra di dialogo Connessione desktop remoto fare clic su Opzioni.

  3. Nella scheda Prestazioni selezionare la casella di controllo Anti-aliasing caratteri.

  4. Configurare eventuali altre impostazioni di connessione e quindi fare clic su Connetti.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Monitorare un server Host sessione Desktop remoto con Gestione risorse di sistema Windows

Gestione risorse di sistema Windows (WSRM) in Windows Server 2008 R2 consente di controllare in che modo le risorse di CPU e di memoria vengono allocate alle applicazioni, ai servizi e ai processi nel computer. Questo tipo di gestione delle risorse consente di migliorare le prestazioni del sistema e limitare le possibilità che applicazioni, servizi o processi si sottraggano a vicenda risorse di CPU o di memoria, riducendo le prestazioni del computer. La gestione delle risorse garantisce inoltre un'esperienza più coerente e prevedibile agli utenti di applicazioni e servizi in esecuzione nel computer.

È possibile utilizzare Gestione risorse di sistema Windows per gestire gli utenti o più applicazioni in un computer in cui è installato Servizi Desktop remoto.

Prima di installare e configurare Gestione risorse di sistema Windows, installare il servizio ruolo Host sessione Desktop remoto nel computer. Per installare Host sessione Desktop remoto, vedere Installare il servizio ruolo Host sessione Desktop remoto. Per installare Gestione risorse di sistema Windows, fare clic su Funzionalità in Server Manager.

Per ulteriori informazioni sull'installazione, la configurazione e l'utilizzo di Gestione risorse di sistema Windows, vedere la relativa Guida in Windows Server 2008 R2.

Due funzionalità di Gestione risorse di sistema Windows sono particolarmente interessanti per gli amministratori di server Host sessione Desktop remoto:

  • Criteri di allocazione risorse

  • Monitoraggio risorse

Criteri di allocazione risorse

In Gestione risorse di sistema Windows vengono utilizzati criteri di allocazione risorse per determinare in che modo le risorse del computer, ad esempio CPU e memoria, vengono allocate ai processi in esecuzione nel computer. I tre criteri di allocazione risorse progettati specificatamente per i computer che eseguono Servizi Desktop remoto sono i seguenti:

  • Equal_Per_User

  • Equal_Per_Session

  • Weighted_Remote_Sessions

Se si implementa il criterio Equal_Per_Session, ogni sessione utente, con i relativi processi associati, ottiene una quantità equivalente delle risorse di CPU nel computer.

Monitoraggio risorse

Prima e dopo aver implementato un criterio di allocazione risorse o aver apportato qualsiasi altra modifica di configurazione relativa a Gestione risorse di sistema Windows, è consigliabile raccogliere i dati sulle prestazioni del server Host sessione Desktop remoto. Per raccogliere e visualizzare i dati sull'utilizzo delle risorse hardware e l'attività dei servizi di sistema nel computer, è possibile utilizzare Monitoraggio risorse, disponibile nello snap-in Gestione risorse di sistema Windows.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Disinstallare il servizio ruolo Host sessione Desktop remoto

Utilizzare la procedura seguente per disinstallare, o rimuovere, il servizio ruolo Host sessione Desktop remoto dal server.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Importante

La rimozione del servizio ruolo Host sessione Desktop remoto dal server richiede il riavvio del computer.

Per disinstallare (rimuovere) il servizio ruolo Host sessione Desktop remoto

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro sinistro espandere Ruoli.

  3. Fare clic con il pulsante destro del mouse su Servizi Desktop remoto e quindi scegliere Rimuovi servizi ruolo.

  4. Nella pagina Selezione servizi ruolo deselezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

  5. Nella pagina Conferma selezioni per la rimozione fare clic su Rimuovi.

  6. Nella pagina Stato rimozione verrà indicato lo stato di avanzamento della rimozione.

  7. Nella pagina Risultati rimozione verrà richiesto di riavviare il server per completare il processo di rimozione. Fare clic su Chiudi e quindi su Sì nella finestra Rimozione servizi ruolo per riavviare il server.

  8. Se viene segnalato che altri programmi sono ancora in esecuzione, eseguire una delle operazioni seguenti:

    • Per chiudere i programmi manualmente e riavviare il server in un secondo momento, fare clic su Annulla.

    • Per chiudere i programmi automaticamente e riavviare il server, fare clic su Riavvia.

  9. Dopo aver riavviato il server e aver eseguito l'accesso al computer, verranno completati gli altri passaggi della rimozione. Quando viene visualizzata la pagina Risultati rimozione, verificare che la rimozione di Host sessione Desktop remoto sia stata eseguita correttamente.

    È inoltre possibile verificare che Host sessione Desktop remoto sia stato rimosso eseguendo le operazioni seguenti:

    1. Avviare Server Manager.

    2. In Riepilogo ruoli verificare che Servizi Desktop remoto non sia visualizzato come ruolo installato.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto