Hyper-V

Il ruolo Hyper-V consente di creare un ambiente di elaborazione server virtualizzato mediante una tecnologia che fa parte di Windows Server 2008. Questo tipo di ambiente risulta utile, poiché consente di creare e gestire macchine virtuali e quindi di eseguire più sistemi operativi in un unico computer fisico e isolare i sistemi operativi tra di loro. Di conseguenza, è possibile utilizzare un ambiente di elaborazione virtualizzato per migliorare le prestazioni delle risorse di elaborazione mediante l'ottimizzazione dell'utilizzo delle risorse hardware.

Per ulteriori informazioni su Hyper-V, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93752).

  • Panoramica di Hyper-V

  • Elenco di controllo: configurare le macchine virtuali per il consolidamento del server

  • Elenco di controllo: Configurare le macchine virtuali per la disponibilità elevata

  • Elenco di controllo: Configurare le macchine virtuali per test e sviluppo

  • Prerequisiti di installazione per Hyper-V

  • Configurare Hyper-V

  • Creare macchine virtuali

  • Creare dischi rigidi virtuali

  • Configurare le macchine virtuali

  • Installare un sistema operativo guest

  • Connettersi a una macchina virtuale

  • Gestire reti virtuali

  • Informazioni sulle istantanee di macchine virtuali

  • Risolvere i problemi relativi a Hyper-V

  • Risorse per Hyper-V

  • Interfaccia utente: Console di gestione di Hyper-V


Panoramica di Hyper-V

Hyper-V rende disponibili gli strumenti per la gestione di infrastrutture software e di base che è possibile utilizzare per creare e gestire un ambiente di elaborazione server virtualizzato. Questo ambiente può essere utilizzato per indirizzare diversi obiettivi aziendali destinati al miglioramento dell'efficienza e alla riduzione dei costi. Un ambiente server virtualizzato, ad esempio, consente di:

  • Ridurre i costi di funzionamento e manutenzione dei server fisici aumentando l'utilizzo dell'hardware. E' possibile ridurre la quantità di hardware necessaria per eseguire i carichi di lavoro del server.

  • Aumentare l'efficienza dello sviluppo e dei test riducendo il tempo impiegato per installare l'hardware e il software e riprodurre gli ambienti di prova.

  • Migliorare la disponibilità del server senza utilizzare lo stesso numero di computer fisici necessario in una configurazione di failover che utilizza solo computer fisici.

Per ulteriori informazioni su Hyper-V, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93752). Per ulteriori informazioni sulle nuove funzionalità della tecnologia Hyper-V di Windows Server 2008 R2, vedere http://go.microsoft.com/fwlink/?LinkId=142885.

Ulteriori riferimenti

  • Prerequisiti di installazione per Hyper-V

  • Creare macchine virtuali

  • Creare dischi rigidi virtuali

  • Configurare le macchine virtuali

  • Installare un sistema operativo guest

  • Risorse per Hyper-V


Elenco di controllo: configurare le macchine virtuali per il consolidamento del server

E' possibile migliorare l'efficienza dell'hardware del server e ridurne i costi di esecuzione e manutenzione consolidando più carichi di lavoro del server in un numero minore di sistemi fisici. Nella tabella seguente vengono indicate le attività di base necessarie per utilizzare Hyper-V per il consolidamento dei carichi di lavoro dei server.

Attività Descrizione

Identificare i carichi di lavoro che rappresentano i candidati ideali per la virtualizzazione.

È possibile utilizzare Microsoft Assessment and Planning Solution Accelerator, che consente di raccogliere i dati sulle prestazioni e di generare rapporti che identificano i candidati ideali per la virtualizzazione del server. Per ulteriori informazioni sullo strumento, vedere la pagina relativa a Microsoft Assessment and Planning Toolkit (http://go.microsoft.com/fwlink/?LinkID=111301).

Valutare i requisiti hardware in base al tipo e al numero di server che si desidera consolidare.

È necessario valutare i requisiti di elaborazione, di archiviazione e di rete per tutti i carichi di lavoro che verranno eseguiti in un server fisico allo scopo di determinare i requisiti hardware per il server fisico. Per ulteriori informazioni sui requisiti hardware e sulle configurazioni massime per Hyper-V, vedere http://go.microsoft.com/fwlink/?LinkID=129920.

Determinare l'edizione di Windows adatta ai propri piani di consolidamento.

La licenza per Windows Server 2008 include i diritti di utilizzo per ambienti virtualizzati. Il numero di istanze virtualizzate che è possibile eseguire in base ai termini del contratto di licenza varia a seconda dell'edizione. Per ulteriori informazioni, vedere la pagina contenente le informazioni sulle licenze nel sito Web Microsoft (http://go.microsoft.com/fwlink/?LinkID=111302.

Identificare lo strumento di gestione adatto in base alle esigenze dell'organizzazione.
  • Utilizzare la console di gestione di Hyper-V, ovvero lo snap-in di gestione fornito con il ruolo. È possibile utilizzare la console di gestione di Hyper-V per connettersi a un solo computer fisico alla volta. Per ulteriori informazioni sull'utilizzo della console di gestione di Hyper-V per le attività di configurazione, vedere i vari argomenti inclusi in questa Guida.

  • Utilizzare System Center Virtual Machine Manager per gestire consolidamenti su larga scala, ad esempio un centro dati virtualizzato. È possibile utilizzare Virtual Machine Manager per gestire più computer fisici contemporaneamente. Per ulteriori informazioni, vedere http://go.microsoft.com/fwlink/?LinkID=111303.

  • Creare una soluzione di gestione personalizzata utilizzando l'SDK di Hyper-V. Per informazioni sul provider WMI di Hyper-V, visitare il sito Web MSDN (http://go.microsoft.com/fwlink/?LinkID=108564).

Installare il ruolo Hyper-V nei server fisici che eseguiranno il ruolo.

Per istruzioni sull'installazione di Hyper-V, vedere la Guida alla pianificazione e distribuzione di Hyper-V (http://go.microsoft.com/fwlink/?LinkID=108560).

Creare le macchine virtuali o eseguirne la migrazione dai server fisici.

Per istruzioni sulla creazione di macchine virtuali, vedere Creare macchine virtuali.

Per ulteriori informazioni sull'utilizzo di System Center Virtual Machine Manager per la migrazione di server fisici, vedere http://go.microsoft.com/fwlink/?LinkID=111303.

Eseguire il test dei carichi di lavoro per verificare che funzionino come previsto.

Fare riferimento ai dati sulle prestazioni e agli eventuali altri criteri raccolti durante la valutazione dei server fisici per l'identificazione dei candidati per la virtualizzazione. Raccogliere dati analoghi per i carichi di lavoro virtualizzati e confrontarli con i dati originali per stabilire se le prestazioni sono o meno accettabili.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

Ulteriori riferimenti

  • Per ulteriori informazioni su Hyper-V, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93752).


Elenco di controllo: Configurare le macchine virtuali per la disponibilità elevata

In questo elenco di controllo vengono indicate le attività che è necessario eseguire per configurare le macchine virtuali per la disponibilità elevata. Per informazioni sugli strumenti che è possibile utilizzare per configurare la disponibilità elevata, vedere la Guida relativa ai cluster di failover. È possibile visualizzare il contenuto della Guida locale digitando il comando seguente al prompt dei comandi: hh cluadmin.chm. In alternativa, vedere la Guida relativa ai cluster di failover nella raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=143560).

Nota

Live Migration è una nuova funzionalità di Hyper-V disponibile in Windows Server 2008 R2 che rende possibile spostare una macchina virtuale a disponibilità elevata da un nodo a un altro mentre è in esecuzione, senza tempi di inattività. Per ulteriori informazioni sulla migrazione tramite Live Migration, vedere http://go.microsoft.com/fwlink/?LinkID=139667 ehttp://go.microsoft.com/fwlink/?LinkId=139664.

Attività Riferimenti

Analizzare i concetti relativi a Hyper-V e alle macchine virtuali nel contesto di un cluster.

Se si desidera utilizzare i volumi condivisi del cluster per le macchine virtuali, analizzare i concetti relativi ai volumi condivisi del cluster.

Vedere "Informazioni su Hyper-V e sulle macchine virtuali nel contesto di un cluster" nella Guida relativa ai cluster di failover.

Vedere "Informazioni sui volumi condivisi del cluster in un cluster di failover" nella Guida relativa ai cluster di failover.

Installare la funzionalità Clustering di failover e il ruolo Hyper-V in ogni server fisico. Per installare entrambe le tecnologie è possibile utilizzare Server Manager.

Per istruzioni sull'installazione della funzionalità Clustering di failover, vedere "Installare Clustering di failover" nella Guida relativa ai cluster di failover.

Per istruzioni sull'installazione di Hyper-V, vedere la Guida alla pianificazione e distribuzione di Hyper-V (http://go.microsoft.com/fwlink/?LinkID=108560).

Connettere le reti e i dispositivi di archiviazione che verranno utilizzati dal cluster.

Nella console di gestione di Hyper-V creare reti virtuali che potranno essere utilizzate con le macchine virtuali.

Importante

Utilizzare gli stessi nomi per le reti virtuali quando queste vengono create nei vari nodi. Quando viene eseguito il failover di una macchina virtuale da un nodo a un altro, il nome della rete virtuale deve corrispondere a quello per il quale è configurata la macchina virtuale.

Vedere "Preparare l'hardware prima della convalida di un cluster di failover" nella Guida relativa ai cluster di failover.

Gestire reti virtuali

Eseguire la Convalida guidata configurazione in tutti i server che si desidera inserire nel cluster per verificare che l'hardware e le impostazioni hardware dei server, della rete e dell'archiviazione siano compatibili con il clustering di failover. Se necessario, adeguare l'hardware o le impostazioni hardware e rieseguire la procedura guidata fino a quando non vengono superati tutti i test (condizione obbligatoria per poter usufruire dei servizi di supporto).

Importante

La convalida non consente di verificare la compatibilità delle funzionalità di virtualizzazione dei processori in ogni server.

Vedere "Convalidare un cluster di failover nuovo o esistente" nella Guida relativa ai cluster di failover.

Utilizzare la Creazione guidata cluster per creare il cluster di failover.

Vedere "Elenco di controllo: Creare un cluster di failover" nella Guida relativa ai cluster di failover.

Se i server del cluster sono connessi a una rete che non deve essere utilizzata per la comunicazione di rete nel cluster, ad esempio una rete destinata solo all'archiviazione iSCSI o al backup, configurare tale rete in modo che non sia consentita la comunicazione di cluster.

Vedere "Modificare le impostazioni di rete per un cluster di failover" nella Guida relativa ai cluster di failover.

Se si desidera utilizzare i volumi condivisi del cluster, attivare questa funzionalità se non è ancora stata attivata.

Vedere "Attivare i volumi condivisi del cluster in un cluster di failover" nella Guida relativa ai cluster di failover.

Utilizzare la Creazione guidata macchina virtuale per creare le macchine virtuali.

Nota

Verificare di creare la macchina virtuale in una nuova cartella e scegliere un percorso di archiviazione che sia accessibile a tutti i server del cluster.

Per le istruzioni, vedere Creare macchine virtuali. Per ulteriori informazioni sulla configurazione di macchine virtuali a disponibilità elevata, vedere Configurare una macchina virtuale per la disponibilità elevata. Per istruzioni dettagliate, vedere la Guida dettagliata relativa a Hyper-V: Hyper-V e funzionalità Clustering di failover (http://go.microsoft.com/fwlink/?LinkID=129063).

Utilizzare la Configurazione guidata disponibilità elevata per impostare ogni macchina virtuale per la disponibilità elevata.

Vedere "Configurare un servizio o un'applicazione per la disponibilità elevata" nella Guida relativa ai cluster di failover.

Riconfigurare l'azione di avvio automatico per la macchina virtuale in modo che non venga eseguita alcuna operazione all'avvio del computer fisico.

Pagina relativa alla configurazione di macchine virtuali (http://go.microsoft.com/fwlink/?LinkId=137807)

Eseguire il test di failover della macchina virtuale del cluster.

Vedere "Eseguire il test di failover di una macchina virtuale del cluster" nella Guida relativa ai cluster di failover.


Elenco di controllo: Configurare le macchine virtuali per test e sviluppo

Le macchine virtuali consentono di ricreare gli ambienti di elaborazione in modo più semplice e veloce rispetto all'utilizzo dei soli computer fisici. Nella tabella seguente vengono indicate le attività di base necessarie per configurare un ambiente di sviluppo e di prova.

Attività | Riferimento
Determinare i requisiti di rete, incluso l'isolamento della rete, dell'ambiente di prova. Creare reti virtuali che supportino tali requisiti. | Per informazioni sulla pianificazione di reti virtuali, vedere la pagina relativa alla configurazione di reti virtuali (http://go.microsoft.com/fwlink/?LinkID=131362). Per istruzioni sulla creazione o modifica di una rete virtuale, vedere Gestire reti virtuali.
Creare macchine virtuali per ricreare l'ambiente di elaborazione che si desidera provare. | Creare macchine virtuali
Installare il sistema operativo guest appropriato in ogni macchina virtuale. | Installare un sistema operativo guest
Se necessario, accedere alla macchina virtuale per interagire con il sistema operativo guest. | Connettersi a una macchina virtuale
Acquisire istantanee delle macchine virtuali prima e dopo avere apportato le modifiche che si desidera verificare o che potrebbe essere necessario ripristinare. | Per istruzioni sull'utilizzo di istantanee, vedere http://go.microsoft.com/fwlink/?LinkID=108561. Per informazioni sulla pianificazione e sulla gestione di istantanee, vedere Informazioni sulle istantanee di macchine virtuali.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • È possibile utilizzare le istantanee delle macchine virtuali per acquisire lo stato di una macchina virtuale mentre è in esecuzione. E' possibile effettuare più istantanee di una macchina virtuale e quindi ripristinarne uno degli stati precedenti applicando un'istantanea alla macchina. Questa operazione consente di semplificare la diagnosi delle cause di errore riducendo il numero di volte in cui è necessario ripetere un'attività o una sequenza. Utilizzare la console di gestione di Hyper-V o Virtual Machine Connection per acquisire le istantanee.

Ulteriori riferimenti

  • Per ulteriori informazioni su Hyper-V, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93752).


Prerequisiti di installazione per Hyper-V

Hyper-V richiede un hardware specifico. È possibile identificare i sistemi che supportano l'architettura x64 e Hyper-V eseguendo la ricerca di Hyper-V come qualifica aggiuntiva nel catalogo di Windows Server. Il catalogo di Windows Server è disponibile sul sito Web Microsoft (http://go.microsoft.com/fwlink/?LinkId=111228).

Per installare e utilizzare il ruolo Hyper-V, è necessario quanto segue:

  • Un processore basato su x64. Hyper-V è disponibile nelle versioni di Windows Server 2008 basate su x64, ovvero le versioni basate su x64 di Windows Server 2008 Standard, Windows Server 2008 Enterprise e Windows Server 2008 Datacenter.

  • Virtualizzazione via hardware. È disponibile nei processori che includono un'opzione di virtualizzazione, ovvero la tecnologia di virtualizzazione Intel (Intel VT) o la virtualizzazione AMD (AMD-V).

  • È necessario che la funzionalità Protezione esecuzione programmi applicata a livello di hardware sia disponibile e attivata. In particolare, è necessario attivare Intel XD Bit (eXecute Disable) o AMD NX Bit (No eXecute).

Ulteriori considerazioni

  • Le impostazioni per la virtualizzazione basata su hardware e Protezione esecuzione programmi applicata a livello di hardware sono disponibili nel BIOS. I nomi delle impostazioni potrebbero tuttavia essere diversi da quelli identificati in precedenza. Per sapere se un modello di processore specifico dispone del supporto per Hyper-V, rivolgersi al produttore del computer.

  • Se si modificano le impostazioni per la virtualizzazione basata su hardware o Protezione esecuzione programmi applicata a livello di hardware, potrebbe essere necessario spegnere e quindi riaccendere il computer. È possibile che le modifiche apportate alle impostazioni non vengano applicate al riavvio del computer.

Ulteriori riferimenti

  • Per ulteriori informazioni su Hyper-V, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93752).

  • Creare macchine virtuali

  • Creare dischi rigidi virtuali

  • Configurare le macchine virtuali

  • Installare un sistema operativo guest

  • Risorse per Hyper-V


Configurare Hyper-V

È possibile configurare il server che esegue Hyper-V modificando le impostazioni di Hyper-V. È possibile utilizzare queste impostazioni per specificare la posizione in cui vengono archiviati determinati file per impostazione predefinita ed effettuare il controllo delle interazioni, ad esempio combinazioni di tasti e credenziali di accesso.

Esistono due categorie di impostazioni di Hyper-V:

  • Impostazioni del server, che consentono di specificare il percorso predefinito di dischi rigidi virtuali e macchine virtuali.

  • Impostazioni dell'utente, che consentono di personalizzare le interazioni con Virtual Machine Connection e di visualizzare i messaggi e le pagine delle procedure guidate eventualmente nascosti in precedenza. Le impostazioni per Virtual Machine Connection includono la combinazione di tasti di rilascio del mouse e le combinazioni di tasti di Windows.

Per configurare le impostazioni di Hyper-V

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro Azioni fare clic su Impostazioni Hyper-V

  3. Nel riquadro di spostamento fare clic sull'impostazione che si desidera configurare.

  4. Fare clic su OK per salvare le modifiche e chiudere Impostazioni Hyper-V oppure fare clic su Applica per salvare le modifiche e configurare altre impostazioni.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

Ulteriori riferimenti

  • Creare macchine virtuali

  • Connettersi a una macchina virtuale


Creare macchine virtuali

La Creazione guidata macchina virtuale offre un modo semplice e flessibile per creare una macchina virtuale. La Creazione guidata nuova macchina virtuale è disponibile dalla console di gestione di Hyper-V.

Quando si utilizza questa procedure guidata, si hanno a disposizione due opzioni per creare una macchina virtuale:

  • È possibile utilizzare le impostazioni predefinite per creare una macchina virtuale senza visualizzare necessariamente tutte le pagine di configurazione della procedura guidata. Questo tipo di macchina virtuale viene configurato nel modo seguente:

    Nome

    Nuova macchina virtuale

    Percorso

    Percorso predefinito configurato per il server che esegue Hyper-V

    Memoria

    512 MB

    Connessione di rete

    Non connessa

    Disco rigido virtuale

    Disco rigido a espansione dinamica con capacità di archiviazione di 127 GB

    Opzioni di installazione

    Nessun supporto specificato

    Controller SCSI

    Nessun disco connesso a questo dispositivo. Per utilizzare questo dispositivo, è necessario che nel sistema operativo guest siano installati i servizi di integrazione. I servizi di integrazione sono inclusi in alcune delle versioni più recenti di Windows. Per ulteriori informazioni, vedere Installare un sistema operativo guest.

  • È possibile utilizzare le impostazioni specificate nella pagine di configurazione per creare una macchina virtuale personalizzata in base alle esigenze.

Nelle procedure seguenti vengono descritti entrambi i metodi.

Importante

Se si prevede di impostare una macchina virtuale per la disponibilità elevata, prima di creare la macchina virtuale vedere la sezione Configurare una macchina virtuale per la disponibilità elevata

Per creare una macchina virtuale predefinita

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro Azioni fare clic su Nuovo e quindi fare clic su Macchina virtuale.

  3. Nella pagina Prima di iniziare fare clic su Fine. In alternativa, se la pagina Impostazione nome e percorso è la prima pagina visualizzata, fare clic su Fine in tale pagina.
Per creare una macchina virtuale personalizzata

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro Azioni fare clic su Nuovo e quindi fare clic su Macchina virtuale.

  3. Procedere con la procedura guidata per specificare le impostazioni personalizzate che si desidera configurare. È possibile fare clic su Avanti per visualizzare ogni pagina della procedura guidata oppure è possibile fare clic sul nome di una pagina nel riquadro a sinistra per passare direttamente alla pagina specifica.

  4. Dopo aver completato la configurazione della macchina virtuale, fare clic su Fine.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • È possibile personalizzare le impostazioni nel numero di pagine desiderato della Creazione guidata macchina virtuale e quindi fare clic su Fine per completare il processo. Per le pagine non personalizzate prima del completamento della procedura guidata, verranno utilizzati i valori predefiniti.

  • Indipendentemente dal metodo utilizzato per creare una macchina virtuale, è possibile modificare la configurazione in un secondo momento cambiando le impostazioni della macchina virtuale. Per ulteriori informazioni, vedere Configurare le macchine virtuali.

  • Alcune configurazioni non possono essere eseguite mediante la Creazione guidata macchina virtuale in quanto vengono considerate configurazioni avanzate. Alcuni esempi includono il collegamento di dischi fisici a una macchina virtuale e la modifica delle impostazioni del processore. È possibile modificare le impostazioni della macchina virtuale per eseguire la configurazione avanzata. Per ulteriori informazioni, vedere Configurare le macchine virtuali.

Ulteriori riferimenti

  • Installare un sistema operativo guest

  • Creazione guidata macchina virtuale

  • Creazione guidata disco rigido virtuale


Creare dischi rigidi virtuali

La Creazione guidata disco rigido virtuale consente di creare con facilità un disco rigido virtuale. È possibile utilizzare questa procedura guidata per creare i tipi di dischi seguenti:

  • Disco rigido virtuale a dimensione fissa

  • Disco rigido virtuale a espansione dinamica

  • Disco rigido virtuale differenze

Molte delle opzioni che è possibile utilizzare per personalizzare il disco rigido virtuale variano a seconda del tipo di disco rigido virtuale creato. In tutti i casi, per il disco rigido virtuale è necessario specificare un nome e un percorso di archiviazione.

Importante

Non creare il disco rigido virtuale in una cartella contrassegnata per la crittografia. I dischi rigidi virtuali vengono archiviati come file con estensione vhd. Hyper-V non supporta l'utilizzo di supporti di archiviazione se il file con estensione vhd è stato crittografato mediante Crittografia file system. È tuttavia possibile utilizzare i file archiviati in un volume che utilizza Crittografia unità BitLocker di Windows. Per scaricare il white paper relativo a Hyper-V e Crittografia unità BitLocker di Windows Server 2008, vedere http://go.microsoft.com/fwlink/?LinkID=123534.

Per creare un disco rigido virtuale

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro azioni fare clic su Nuovo e quindi fare clic su Disco rigido.

  3. Procedere con la procedura guidata per personalizzare il disco rigido virtuale. È possibile fare clic su Avanti per visualizzare ogni pagina della procedura guidata oppure è possibile fare clic sul nome di una pagina nel riquadro a sinistra per passare direttamente alla pagina specifica.

  4. Dopo aver completato la configurazione del disco rigido virtuale, fare clic su Fine.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • I dischi rigidi virtuali vengono archiviati come file con estensione vhd. Ciò consente la portabilità di questi file, ma comporta un potenziale rischio per la sicurezza. È quindi consigliabile ridurre tale rischio adottando alcune precauzioni, ad esempio l'archiviazione dei file con estensione vhd in un percorso sicuro.

  • Il disco rigido virtuale viene creato quando si fa clic su Fine per completare la procedura guidata. A seconda delle opzioni scelte per il disco rigido virtuale, il processo potrebbe richiedere un tempo considerevole.

  • I dischi rigidi virtuali non possono essere archiviati in una cartella che utilizza la compressione NTFS.

  • È possibile apportare determinate modifiche a un disco rigido virtuale dopo averlo creato. È ad esempio possibile convertirlo da un tipo di disco rigido virtuale in un altro. Per apportare le modifiche, è possibile utilizzare la Modifica guidata disco rigido virtuale.

Ulteriori riferimenti

  • Installare un sistema operativo guest

  • Creazione guidata disco rigido virtuale


Configurare le macchine virtuali

Per utilizzare Hyper-V per eseguire carichi di lavoro del server in un ambiente virtualizzato, è necessario creare le macchine virtuali che eseguono i diversi sistemi operativi guest e applicazioni. Per creare le macchine virtuali, utilizzare la Creazione guidata macchina virtuale. Questa procedura guidata consente di creare una macchina virtuale con una configurazione scelta dall'utente per il nome, la memoria, la connessione di rete e l'archiviazione della macchina virtuale. La Creazione guidata nuova macchina virtuale è disponibile da Gestione Hyper-V.

Dopo aver creato una macchina virtuale, è possibile personalizzare la macchina virtuale mediante la configurazione delle relative impostazioni. Ad esempio, è possibile:

  • Aggiungere o rimuovere l'hardware virtuale, ad esempio un controller di archiviazione o una scheda di rete.

  • Aggiungere o rimuovere dischi rigidi virtuali.

  • Modificare l'ordine di avvio dei dispositivi del sistema BIOS.

È possibile modificare queste impostazioni e molte altre da Gestione Hyper-V.

Per configurare una macchina virtuale

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni.

  4. Nel riquadro di spostamento (riquadro a sinistra) fare clic sull'elemento che si desidera configurare.

  5. Eseguire una delle operazioni seguenti:

    • Per aggiungere un'altra istanza di un elemento, ad esempio un controller SCSI, selezionare l'elemento e fare clic su Aggiungi. Dopo l'aggiunta di alcuni elementi, ad esempio schede di rete, potrebbe essere necessario eseguire alcune attività di configurazione aggiuntive.

    • Per modificare un elemento, apportare le modifiche alla configurazione e fare clic su OK.

    • Per rimuovere un elemento, selezionarlo, se necessario, e quindi fare clic su Rimuovi.

  6. Per apportare ulteriori modifiche, fare clic sull'elemento successivo che si desidera modificare e ripetere il passaggio 5. Al termine della configurazione, fare clic su OK.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

Ulteriori riferimenti

  • Configurare memoria e processori

  • Configurare la rete

  • Configurare dischi e dispositivi di archiviazione

  • Configurare una macchina virtuale per la disponibilità elevata

  • Creazione guidata macchina virtuale

  • Creazione guidata disco rigido virtuale

  • Raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93752).


Configurare memoria e processori

La creazione di una macchina virtuale comporta la configurazione della memoria e del processore per fornire le risorse di elaborazione appropriate per il carico di lavoro che si intende eseguire sulla macchina virtuale. Il carico di lavoro è costituito dal sistema operativo guest e da tutti i servizi e le applicazioni che verranno eseguiti contemporaneamente sulla macchina virtuale.

Se è necessario modificare le risorse di elaborazione di una macchina virtuale, sarà possibile riconfigurare le risorse in base alle esigenze. Sarà inoltre possibile specificare i controlli delle risorse per automatizzare la modalità di allocazione delle risorse alle macchine virtuali.

Configurare la memoria o i processori per una macchina virtuale

Per eseguire il carico di lavoro, è necessario che a una macchina virtuale venga allocata la quantità di memoria necessaria. La memoria viene tuttavia utilizzata solo quando la macchina virtuale è in esecuzione o sospesa. Per ulteriori informazioni sull'allocazione della memoria, vedere la pagina relativa all'ottimizzazione delle prestazioni per i server di virtualizzazione nelle linee guida per l'ottimizzazione delle prestazioni per Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=135682).

Il numero di processori virtuali da configurare dipende dal sistema operativo guest. Per ulteriori informazioni sulla determinazione della quantità di memoria e dei processori appropriati per il sistema operativo guest che verrà eseguito sulla macchina virtuale, vedere la pagina relativa alle informazioni sulle machine virtuali e sui sistemi operativi guest (http://go.microsoft.com/fwlink/?LinkID=128037).

Hyper-V rende disponibili le impostazioni per la compatibilità del processore che consentono di utilizzare con facilità un sistema operativo meno recente e di eseguire con rapidità la migrazione tramite Live Migration di una macchina virtuale in un altro computer fisico con una versione del processore diversa. Per lo scenario di migrazione sono valide le considerazioni seguenti:

  • L'impostazione Esegui migrazione a un computer fisico con una versione diversa del processore assicura che la macchina virtuale utilizzerà solo le funzionalità del processore disponibili in tutte le versioni di un processore che supporta la virtualizzazione di uno stesso produttore. Non viene fornita la compatibilità tra processori di produttori diversi.

  • Questa impostazione è utile negli scenari di disponibilità elevata e di backup e ripristino, in quanto consente di spostare con facilità una macchina virtuale a disponibilità elevata in un altro nodo di un cluster o di ripristinare una configurazione hardware diversa per una macchina virtuale.

Nota

Se il computer fisico dispone di più processori e utilizza l'architettura NUMA (Non-Uniform Memory Architecture), è consigliabile non assegnare a una macchina virtuale un numero di processori o una quantità di memoria maggiori di quelli disponibili in un singolo nodo NUMA. Ad esempio, non assegnare 4 processori a una macchina virtuale se ogni nodo NUMA dispone solo di 2 processori. Per ulteriori informazioni sull'architettura del processore del computer fisico, vedere la documentazione fornita con il computer.

Per configurare la memoria o i processori per una macchina virtuale

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni. Nel riquadro di spostamento fare quindi clic sull'impostazione hardware appropriata come descritto nella procedura seguente.

  4. Per configurare la memoria, fare clic su Memoria. Nella pagina Memoria specificare la nuova quantità di memoria.

  5. Per configurare il processore, fare clic su Processore. Se il sistema operativo guest supporta più processori, specificare il numero di processori da assegnare alla macchina virtuale. Fare clic su OK.

Configurare l'allocazione delle risorse per una macchina virtuale

I controlli delle risorse consentono di controllare in modi diversi la modalità con cui Hyper-V alloca risorse alle macchine virtuali. Di seguito viene riportata una breve descrizione di ogni controllo: Per ulteriori informazioni sui controlli, vedere la sezione relativa a pesi e riserve nelle linee guida per l'ottimizzazione delle prestazioni per Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=135682).

  • Riserva della macchina virtuale. Specifica la percentuale delle risorse del processore disponibili per una machina virtuale riservata per la macchina virtuale. Questa impostazione assicura che la percentuale specificata sarà disponibile per la macchina virtuale. Questa impostazione può inoltre influire sul numero di macchine virtuali che è possibile eseguire contemporaneamente.

  • Limite della macchina virtuale. Specifica la percentuale massima delle risorse del processore disponibili per una machina virtuale che può essere utilizzata dalla macchina virtuale. Questa impostazione viene applicata indipendentemente dal fatto che altre macchine virtuali siano in esecuzione.

  • Peso relativo. Specifica la modalità con cui Hyper-V alloca risorse alla macchina virtuale quando più macchine virtuali sono in esecuzione e competono tra loro per le risorse.

Per configurare l'allocazione delle risorse per una macchina virtuale

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni.

  4. Nel riquadro di spostamento fare clic su Processore.

  5. In Controllo risorse specificare la quantità per ogni controllo che si desidera utilizzare. Fare clic su OK.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • Affinché sia possibile modificare le impostazioni relative alla memoria o al processore, è necessario che la macchina virtuale sia spenta.

Ulteriori riferimenti

  • Installare un sistema operativo guest

  • Risolvere i problemi relativi a Hyper-V


Configurare la rete

Per rendere disponibili le funzionalità di rete per una macchina virtuale, sono necessari gli stessi due componenti di base richiesti da un computer fisico, ovvero una scheda di rete e una rete disponibile. Al momento della creazione, la macchina virtuale viene configurata automaticamente con una scheda di rete. Se nel server che esegue Hyper-V sono disponibili una o più reti virtuali, sarà possibile connettere la scheda di rete a una rete disponibile in quel momento.

Hyper-V rende disponibili due tipi di schede di rete virtuali, ovvero una scheda di rete e una scheda di rete legacy:

  • Una scheda di rete richiede un driver della macchina virtuale per il corretto funzionamento, ma offre prestazioni migliori. Questo driver è incluso in alcune delle versioni più recenti di Windows. In tutti gli altri sistemi operativi supportati, per installare il driver della macchina virtuale è necessario installare i servizi di integrazione nel sistema operativo guest. Per le istruzioni, vedere Installare un sistema operativo guest. Per ulteriori informazioni sui sistemi operativi supportati e su quelli che richiedono l'installazione dei servizi di integrazione, vedere la pagina relativa alle informazioni sulle macchine virtuali e sui sistemi operativi guest (http://go.microsoft.com/fwlink/?LinkID=128037).

  • Per garantire il funzionamento di una scheda di rete legacy, non è necessario installare un driver della macchina virtuale. La scheda di rete legacy emula una scheda di rete fisica Multiport DEC 21140 10/100TX da 100 MB. Una scheda di rete legacy supporta inoltre le installazioni dalla rete poiché offre la possibilità di eseguire l'avvio con Pre-Execution Environment (avvio PXE). La scheda di rete legacy non è tuttavia supportata nella versione a 64 bit di Windows Server 2003.

Nota

A differenza della scheda di rete, per la scheda di rete legacy è necessaria l'elaborazione nel sistema operativo di gestione. È consigliabile utilizzare la scheda di rete legacy solo per eseguire un'installazione dalla rete o quando il sistema operativo guest non supporta la scheda di rete.

Dopo aver creato una macchina virtuale, è possibile configurare le funzionalità di rete per le macchine virtuali aggiungendo, rimuovendo e modificando le relative schede di rete in base alle esigenze. Ogni scheda di rete può essere connessa a una delle reti virtuali disponibili nel server che esegue Hyper-V.

Nota

È possibile utilizzare Gestione reti virtuali per aggiungere, rimuovere e modificare le reti virtuali. È inoltre possibile utilizzare Gestione reti virtuali per specificare un intervallo di indirizzi MAC (Media Access Control) da assegnare alle macchine virtuali.

Per aggiungere una scheda di rete

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni.

  4. Nel riquadro di spostamento fare clic su Installa hardware.

  5. Nella pagina Installa hardware scegliere una scheda di rete o una scheda di rete legacy. Per ulteriori informazioni su ogni tipo di scheda, vedere "Ulteriori considerazioni" più avanti.

  6. Fare clic su Aggiungi. Verrà visualizzata la pagina Scheda di rete o Scheda di rete legacy.

  7. In Rete selezionare la rete virtuale a cui si desidera connettersi.

  8. Se si desidera configurare un indirizzo MAC statico o un identificatore LAN virtuale, specificare i numeri che si desidera utilizzare.

  9. Fare clic su OK.
Per modificare o rimuovere una scheda di rete

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni.

  4. Nel riquadro di spostamento fare clic sul nome della scheda di rete.

  5. Nella pagina Scheda di rete o Scheda di rete legacy eseguire una delle operazioni seguenti:

    • Per modificare la configurazione, apportare le modifiche e quindi fare clic su Applica.

    • Per rimuovere la scheda di rete, fare clic su Rimuovi.

  6. Fare clic su OK.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • È possibile utilizzare Gestione reti virtuali per vincolare l'intervallo di indirizzi MAC dinamici. Ciò consente di evitare che si verifichino conflitti quando più computer fisici che eseguono Hyper-V utilizzano la stessa subnet e lo stesso indirizzo MAC è assegnato a più macchine virtuali nella subnet.

Ulteriori riferimenti

  • Gestire reti virtuali

  • Per ulteriori informazioni su Hyper-V, vedere la pagina relativa alla configurazione delle macchine virtuali (http://go.microsoft.com/fwlink/?LinkID=131362).


Configurare dischi e dispositivi di archiviazione

Una macchina virtuale può utilizzare tre tipi di supporti di archiviazione:

  • Dischi rigidi, sia dischi rigidi virtuali che dischi fisici

  • CD e DVD, sia dischi fisici che file di immagine (noti anche come file con estensione iso)

  • Dischi floppy virtuali

Per rendere disponibili più tipi di supporti e archivi per una macchina virtuale, è necessario configurare l'unità per la macchina virtuale aggiungendola o rimuovendola oppure modificando il supporto.

È possibile aggiungere o rimuovere dischi rigidi virtuali e dischi fisici collegati direttamente a una macchina virtuale anche quando la macchina virtuale è in esecuzione. È necessario che i dischi siano collegati al controller SCSI di una macchina virtuale e che i servizi di integrazione siano installati nel sistema operativo guest. Prima di rimuovere un disco, è consigliabile disconnettere il disco nel sistema operativo guest per evitare una possibile perdita di dati.

Nota

Per rendere disponibile un percorso per l'installazione del sistema operativo guest, è necessario che una macchina virtuale disponga almeno di un disco. È possibile aggiungere o rimuovere unità in base alle necessità. Quando si crea una macchina virtuale, viene aggiunta automaticamente una unità DVD.

Configurare dischi rigidi, CD e DVD

Per configurare dischi rigidi, CD e DVD per una macchina virtuale, è necessario modificare le impostazioni della macchina virtuale.

Importante

Il disco che funge da disco di sistema deve essere collegato a uno dei controller IDE. Se si collega il disco di sistema a un controller SCSI, la macchina virtuale non verrà avviata.

Per aggiungere un disco rigido a una macchina virtuale

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni.

  4. Nel riquadro di spostamento (riquadro a sinistra) fare clic sul controller al quale si desidera collegare il disco.

  5. Fare clic su Aggiungi.

  6. Nella pagina Unità disco rigido selezionare il percorso nel controller per il collegamento del disco.

  7. In Supporti eseguire una delle operazioni seguenti:

    • Specificare il percorso del file (con estensione vhd) del disco rigido virtuale.

    • Specificare un disco rigido fisico.

  8. Fare clic su OK.
Per modificare o rimuovere un'unità disco rigido o un'unità DVD

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni.

  4. Nel riquadro di spostamento (riquadro a sinistra) fare clic sull'unità disco rigido o sull'unità DVD.

  5. Nella pagina Unità disco rigido o Unità DVD eseguire una delle operazioni seguenti:

    • Per collegare l'unità a un supporto diverso, in Supporti selezionare il supporto appropriato.

    • Per rimuovere l'unità, fare clic su Rimuovi.

  6. Fare clic su OK.

Configurare l'unità a dischetti

Per rendere disponibile un'unità disco floppy virtuale per una macchina virtuale, è necessario collegare il file (con estensione vfd) dell'unità disco floppy virtuale all'unità a dischetti. L'unità a dischetti è sempre disponibile e non può essere rimossa.

Per configurare l'unità a dischetti

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali selezionare la macchina virtuale che si desidera configurare.

  3. Nel riquadro Azioni sotto il nome della macchina virtuale fare clic su Impostazioni.

  4. Nel riquadro di spostamento (riquadro sinistro) fare clic su Unità dischetto.

  5. In Supporti fare clic su File disco floppy virtuale (.vfd) e quindi digitare o selezionare il percorso del file con estensione vfd.

  6. Fare clic su OK.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • Hyper-V non supporta l'utilizzo di supporti di archiviazione se è stata eseguita la crittografia di file con estensione iso, vhd e vfd mediante Crittografia file system. È tuttavia possibile utilizzare i file archiviati in un volume che utilizza Crittografia unità BitLocker di Windows.

  • Non collegare un disco rigido virtuale a una macchina virtuale se il file con estensione vhd è archiviato in una cartella compressa. Le macchine virtuali non saranno in grado di accedere al disco rigido virtuale.

  • Non archiviare file con estensione vhd in cartelle condivise.

  • Solo una macchina virtuale alla volta può accedere a un'unità CD o DVD fisica.

  • Per consentire a una macchina virtuale di accedere a file con estensione iso in una cartella condivisa in un ambiente di dominio, è necessario configurare il server che esegue Hyper-V per la delega vincolata. Configurare l'account computer del server che esegue Hyper-V per la presentazione delle credenziali delegate per il tipo di servizio CIFS (Common Internet File System).

  • Prima di poterlo aggiungere a una macchina virtuale, è necessario che il disco sia offline. Per disconnettere un disco fisico, è possibile utilizzare Gestione disco.

Ulteriori riferimenti

  • Installare un sistema operativo guest

  • Creazione guidata disco rigido virtuale

  • Modifica guidata disco rigido virtuale


Configurare una macchina virtuale per la disponibilità elevata

Una macchina virtuale a disponibilità elevata richiede l'esecuzione di alcune configurazioni e attività specifiche. Alcune di queste configurazioni e attività devono essere eseguite prima che la macchina virtuale venga impostata per la disponibilità elevata, mentre altre devono essere eseguite successivamente. Prima di procedere all'impostazione una macchina virtuale per la disponibilità elevata, esaminare le informazioni seguenti per verificare che la macchina virtuale sia configurata correttamente.

Prima di impostare la macchina virtuale per la disponibilità elevata

Prima di impostare la macchina virtuale per la disponibilità elevata, è necessario esaminare e in alcuni casi modificare le impostazioni relative alla rete, alla sicurezza e all'archiviazione configurate nel proprio ambiente.

  • Rete. Tutti i nodi di uno stesso cluster devono utilizzare lo stesso nome per la rete virtuale che rende disponibile la connettività di rete esterna per le macchine virtuali. Ad esempio, se è stata creata una rete virtuale tramite l'Aggiunta guidata ruoli al momento dell'installazione del ruolo, alla rete virtuale viene assegnato un nome in base alla scheda di rete. Questo nome sarà diverso in ogni computer fisico. È necessario eliminare la rete virtuale e quindi ricrearla, utilizzando lo stesso nome in ogni computer fisico del cluster. Si noti inoltre che se una scheda di rete fisica utilizza impostazioni statiche, ad esempio un indirizzo IP statico, e IPv6 non è disattivato, le impostazioni statiche verranno eliminate quando si connette una rete virtuale alla scheda fisica. In tal caso, sarà necessario riconfigurare le impostazioni statiche.

  • Processore. Se i nodi del cluster utilizzano versioni di processore diverse, verificare di configurare la macchina virtuale per la compatibilità del processore. In questo modo sarà possibile eseguire il failover o la migrazione di una macchina virtuale senza che si verifichino i problemi causati da funzionalità di virtualizzazione diverse disponibili in versioni diverse del processore di uno stesso produttore. Non viene tuttavia fornita la compatibilità tra processori di produttori diversi.

  • Sicurezza. Per evitare che si verifichino problemi quando si tenta di amministrare macchine virtuali a disponibilità elevata, tutti i nodi del cluster devono utilizzare gli stessi criteri di autorizzazione. A tale scopo è possibile procedere in due modi:

    • Utilizzare un archivio autorizzazioni locale basato su XML in ogni nodo. Questo criterio deve essere configurato allo stesso modo in ogni archivio del cluster.

    • Utilizzare un archivio autorizzazioni posto in Servizi di dominio Active Directory.

  • Archiviazione. È necessario utilizzare un'archiviazione condivisa che sia supportata sia dalla funzionalità Clustering di failover sia da Hyper-V. Quando si crea la macchina virtuale, scegliere l'opzione che consente di archiviare la macchina virtuale in una nuova cartella e specificare il percorso dell'archiviazione condivisa. Per ulteriori informazioni sull'archiviazione cluster, vedere la pagina relativa ai cluster di failover (http://go.microsoft.com/fwlink/?LinkID=143559).

Nota

Affinché sia possibile impostarla per la disponibilità elevata, è necessario che la macchina virtuale sia spenta. Per impostare una macchina virtuale per la disponibilità elevata, eseguire la Configurazione guidata disponibilità elevata dallo snap-in Gestione cluster di failover e selezionare Macchina virtuale come servizio o applicazione da impostare per la disponibilità elevata.

Dopo avere impostato la macchina virtuale per la disponibilità elevata

Dopo avere impostato la macchina virtuale per la disponibilità elevata, eseguire le operazioni seguenti:

  • Installare il sistema operativo guest e i servizi di integrazione. Per le istruzioni, vedere Installare un sistema operativo guest.

  • Configurare la macchina virtuale in modo che non esegua alcuna azione tramite Hyper-V all'arresto del computer fisico mediante la modifica dell'impostazione Azione arresto automatico su Nessuna. Lo stato della macchina virtuale deve essere gestito tramite la funzionalità Clustering di failover. Per ulteriori informazioni sull'impostazione, vedere Impostazioni della macchina virtuale.

  • Se si utilizzano istantanee in una macchina virtuale del cluster, tutte le risorse associate a ogni istantanea dovranno essere archiviate nella stessa archiviazione condivisa della macchina virtuale.

  • Se si modifica la configurazione di una macchina virtuale, è consigliabile utilizzare lo snap-in Gestione cluster di failover per accedere alle impostazioni della macchina virtuale. In questo modo, il cluster verrà aggiornato automaticamente con le modifiche della configurazione. Se le modifiche alle impostazioni della macchina virtuale vengono apportate dallo snap-in Console di gestione di Hyper-V, dopo avere apportato le modifiche sarà tuttavia necessario aggiornare manualmente il cluster. Se la configurazione non viene aggiornata dopo avere apportato modifiche alle impostazioni di rete o di archiviazione, il failover successivo potrebbe anche riuscire, ma la macchina virtuale non sarà configurata correttamente.

Importante

La modifica dell'azione offline ha effetto sul comportamento della macchina virtuale in caso di failover. Se ad esempio si sceglie un'azione di arresto e si verifica un failover, verrà eseguito l'arresto della macchina virtuale anziché il failover in un altro nodo.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

Ulteriori riferimenti

  • Elenco di controllo: Configurare le macchine virtuali per la disponibilità elevata

  • Configurare le macchine virtuali


Installare un sistema operativo guest

Il sistema operativo guest è il sistema operativo che viene installato ed eseguito in una macchina virtuale. Prima di poter installare il sistema operativo guest, se non è stato specificato il percorso del supporto di installazione al momento della creazione della macchina virtuale, sarà necessario eseguire una delle operazioni seguenti:

  • Recuperare il supporto di installazione per il sistema operativo e configurare la macchina virtuale per l'utilizzo dell'unità CD/DVD per l'accesso al supporto di installazione. Per le istruzioni, vedere Configurare dischi e dispositivi di archiviazione.

  • Se si desidera eseguire un'installazione di rete, configurare la macchina virtuale per l'utilizzo di una scheda di rete legacy connessa a una rete virtuale esterna. Questo tipo di rete offre la connettività a una rete fisica mediante il routing del traffico attraverso una rete virtuale esterna a una scheda di rete fisica. Per ulteriori informazioni, vedere Configurare la rete.

Dopo avere configurato la macchina virtuale in modo appropriato, sarà possibile installare il sistema operativo guest.

Per installare il sistema operativo guest

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Connettersi alla macchina virtuale. Nella sezione Macchine virtuali del riquadro dei risultati eseguire una delle operazioni seguenti:

    • Fare clic con il pulsante destro del mouse sul nome della macchina virtuale e scegliere Connetti.

    • Selezionare il nome della macchina virtuale. Fare clic su Connetti nel riquadro Azioni.

  3. Verrà aperto lo strumento Virtual Machine Connection.

  4. Nella finestra di Virtual Machine Connection scegliere Avvia dal menu Azione.

  5. Verrà avviata la macchina virtuale, verrà eseguita la ricerca dei dispositivi di avvio e verrà caricato il pacchetto di installazione.

  6. Proseguire con l'installazione.

Nota

A seconda del sistema operativo che si sta installando, è possibile che il puntatore del mouse assuma la forma di un piccolo punto quando si sposta il cursore sull'immagine della finestra di installazione. In tal caso, fare clic in un punto qualsiasi nella finestra della macchina virtuale. Questa azione determina l'acquisizione del mouse in modo che l'input da tastiera o dal mouse venga inviato alla macchina virtuale. Per fare in modo che l'input venga inviato di nuovo al computer fisico, premere CTRL+ALT+FRECCIA SINISTRA e quindi spostare il puntatore del mouse all'esterno della finestra della macchina virtuale.

Hyper-V include un pacchetto software per i sistemi operativi guest supportati che migliora l'integrazione tra il computer fisico e la macchina virtuale. Questo pacchetto è noto come servizi di integrazione. Le versioni più recenti dei sistemi operativi Windows supportati includono i servizi di integrazione e non richiedono l'installazione dopo l'installazione del sistema operativo guest. Per ulteriori informazioni sui sistemi operativi supportati e su quelli che richiedono l'installazione dei servizi di integrazione, vedere le informazioni relative alla distribuzione di Hyper-V nella raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=128037).

Nota

Ai fini delle istruzioni seguenti, si presuppone che venga installato un sistema operativo per il quale il pacchetto software sia disponibile e l'installazione sia richiesta.

Per installare i servizi di integrazione

  1. Connettersi alla macchina virtuale. Nella sezione Macchine virtuali del riquadro dei risultati eseguire una delle operazioni seguenti:

    • Fare clic con il pulsante destro del mouse sul nome della macchina virtuale e scegliere Connetti.

    • Selezionare il nome della macchina virtuale. Fare clic su Connetti nel riquadro Azioni.

  2. Verrà aperto lo strumento Virtual Machine Connection.

  3. Dal menu Azione di Virtual Machine Connection scegliere Inserisci disco di installazione dei servizi di integrazione. Questa azione determina il caricamento del disco di installazione nell'unità DVD virtuale.

  4. A seconda del sistema operativo che si sta installando, potrebbe essere necessario avviare manualmente l'installazione. Fare clic in un punto qualsiasi nella finestra del sistema operativo guest e passare all'unità CD. Per avviare il pacchetto di installazione dall'unità CD, utilizzare il metodo appropriato per il sistema operativo guest.

  5. Al termine dell'installazione, tutti i servizi di integrazione saranno disponibili per l'uso.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • L'utilizzo di Virtual Machine Connection nell'ambito di una sessione di Servizi Desktop remoto non è supportato a meno che non siano installati i servizi di integrazione.

  • I servizi di integrazione per i sistemi operativi Linux supportati non sono inclusi in un'installazione di Hyper-V. Essi vengono distribuiti tramite il sito Web Microsoft Connect e identificati come componenti di integrazione Linux per Microsoft Hyper-V. Per ulteriori informazioni, vedere http://go.microsoft.com/fwlink/?LinkID=102024.

Ulteriori riferimenti

  • Configurare le macchine virtuali

  • Virtual Machine Connection


Connettersi a una macchina virtuale

Virtual Machine Connection è uno strumento che consente di connettersi a una macchina virtuale per installare il sistema operativo guest o interagire con esso in una macchina virtuale. Tramite Virtual Machine Connection è possibile eseguire alcune attività, incluse le seguenti:

  • Connettersi all'output video di una macchina virtuale

  • Controllare lo stato di una macchina virtuale

  • Acquisire istantanee di una macchina virtuale

  • Modificare le impostazioni di una macchina virtuale

Prima di iniziare

Virtual Machine Connection viene installato automaticamente quando si installa il ruolo Hyper-V in un'installazione completa di Windows Server 2008. In determinate versioni di Windows è possibile installarlo separatamente. Per ulteriori informazioni sull'installazione di Virtual Machine Connection, vedere http://go.microsoft.com/fwlink/?LinkId=143558

Per impostazione predefinita, Virtual Machine Connection utilizza le credenziali utilizzate per accedere alla sessione di Windows corrente anche per stabilire una sessione con una macchina virtuale in esecuzione. Se si desidera che Virtual Machine Connection utilizzi un insieme di credenziali diverso, sarà possibile configurare Hyper-V in modo che vengano richieste le credenziali. Per le istruzioni, vedere Configurare Hyper-V.

Connettersi a una macchina virtuale

Per connettersi a una macchina virtuale dalla console di gestione di Hyper-V

  1. Aprire la console di gestione di Hyper-V. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Console di gestione di Hyper-V.

  2. Nel riquadro dei risultati in Macchine virtuali fare clic con il pulsante destro del mouse sul nome della macchina virtuale e scegliere Connetti.

  3. Verrà aperto lo strumento Virtual Machine Connection.

Suggerimenti per l'utilizzo di Virtual Machine Connection

I suggerimenti seguenti possono essere utili per l'utilizzo di Virtual Machine Connection:

  • Quando i servizi di integrazione sono installati nel sistema operativo guest, è possibile spostare il puntatore del mouse senza problemi tra il sistema operativo in esecuzione nel computer fisico e il sistema operativo guest. I servizi di integrazione sono inclusi nelle versioni più recenti dei sistemi operativi Microsoft supportati. Per tutti gli altri sistemi operativi supportati, installare i servizi di integrazione nel sistema operativo guest. Per istruzioni sull'installazione dei servizi di integrazione, vedere Installare un sistema operativo guest. Per un elenco dei sistemi operativi guest per i quali sono disponibili i servizi di integrazione, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=128037).

  • Quando ci si connette a una macchina virtuale in esecuzione, il puntatore del mouse potrebbe venire visualizzato come un piccolo punto. Per inviare i clic del mouse o l'input da tastiera alla macchina virtuale, fare clic in un punto qualsiasi nella finestra della macchina virtuale. Per fare in modo che l'input venga inviato di nuovo al computer fisico, premere la combinazione di tasti di rilascio del mouse e quindi spostare il puntatore del mouse all'esterno della finestra della macchina virtuale. La combinazione di tasti di rilascio predefinita è CTRL+ALT+freccia SINISTRA, ma è possibile cambiarla modificando le impostazioni di Hyper-V.

  • Non è possibile premere CTRL+ALT+CANC sulla tastiera per inviare tale combinazione di tasti a una macchina virtuale. È possibile utilizzare il comando di menu. Dal menu Azione scegliere CTRL+ALT+CANC. In alternativa, premere CTRL+ALT+FINE.

  • È possibile passare dalla modalità a finestra alla modalità a schermo intero. Dal menu Visualizza scegliere Modalità schermo interno. Per passare di nuovo alla modalità a finestra, premere CTRL+ALT+INTER.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • Se un utente autorizzato è connesso a una macchina virtuale tramite Virtual Machine Connection e un altro utente autorizzato decide di utilizzare la console della stessa macchina virtuale, la sessione verrà assunta dal secondo utente e il primo utente perderà la sessione. Questo potrebbe rappresentare un rischio per la privacy e la sicurezza, in quanto il secondo utente sarà in grado di visualizzare il desktop, i documenti e le applicazioni del primo utente. Una sessione di macchina virtuale è disponibile per tutti gli utenti a cui è stato concesso il privilegio richiesto per l'operazione di lettura o di lettura e scrittura della console nei criteri di autorizzazione. Per impostazione predefinita, questo privilegio viene concesso a tutti gli amministratori. Per risolvere o evitare il problema, modificare i privilegi per limitare l'accesso in base alle esigenze.

Ulteriori riferimenti

  • Creare macchine virtuali

  • Installare un sistema operativo guest

  • Risolvere i problemi relativi a Hyper-V


Gestire reti virtuali

Nel server che esegue Hyper-V è possibile creare numerose reti virtuali per fornire una varietà di canali di comunicazione. Ad esempio, è possibile creare reti per offrire quanto segue:

  • Solo comunicazioni tra due macchine virtuali. Questo tipo di rete virtuale è detta rete privata.

  • Comunicazioni tra il server di virtualizzazione e le macchine virtuali. Questo tipo di rete virtuale è detta rete interna.

  • Comunicazioni tra una macchina virtuale e una rete fisica creando un'associazione a una schede di rete fisica nel server di virtualizzazione. Questo tipo di rete virtuale è detta rete esterna. In base alle procedure ottimali, è consigliabile dotare il computer fisico di più schede di rete fisiche. Utilizzare una scheda di rete fisica per fornire alle macchine virtuali una rete virtuale esterna, incluso l'accesso remoto alle macchine virtuali. Utilizzare un'altra scheda di rete per tutte le comunicazioni di rete con il sistema operativo di gestione, incluso l'accesso remoto al ruolo Hyper-V. Il sistema operativo di gestione esegue il ruolo Hyper-V.

Importante

Alcune modifiche apportate alla configurazione sovrascrivono le impostazioni statiche. Se ad esempio si connette una rete virtuale a una scheda di rete fisica che utilizza impostazioni statiche, ad esempio un indirizzo IP statico, la nuova connessione sovrascriverà tutte le impostazioni statiche relative a IPv6. Se si crea una rete esterna senza condividere la connessione di rete con il sistema operativo di gestione e quindi si riconfigura la rete esterna per consentire al sistema operativo di gestione di utilizzare la connessione, tale modifica sovrascriverà tutte le impostazioni statiche sulla schede di rete fisica. La connettività di rete potrebbe non essere più disponibile fino a quando non verranno applicate di nuovo le impostazioni statiche alla scheda di rete fisica.

È possibile utilizzare Gestione reti virtuali per aggiungere, rimuovere e modificare le reti virtuali. Gestione reti virtuali è disponibile dalla console di gestione di Hyper-V.

Per aggiungere una rete virtuale

  1. Aprire la console di gestione di Hyper-V.

  2. Scegliere Gestione reti virtuali dal menu Azioni.

  3. In Crea rete virtuale selezionare la rete che si desidera creare.

  4. Fare clic su Aggiungi. Verrà visualizzata la pagina Nuova rete virtuale.

  5. Digitare un nome per la nuova rete. Esaminare le altre proprietà e modificarle se necessario.

    Nota

    È possibile utilizzare il metodo di identificazione della LAN virtuale per isolare il traffico di rete. Questo tipo di configurazione deve tuttavia essere supportata dalla scheda di rete fisica. Per informazioni sulla configurazione dell'identificazione della LAN virtuale, vedere la pagina relativa alla configurazione di reti virtuali (http://go.microsoft.com/fwlink/?LinkID=131362).

  6. Fare clic su OK per salvare la rete virtuale e chiudere Gestione reti virtuali oppure fare clic su Applica per salvare la rete virtuale e continuare a utilizzare Gestione reti virtuali.
Per modificare una rete virtuale

  1. Aprire la console di gestione di Hyper-V.

  2. Scegliere Gestione reti virtuali dal menu Azioni.

  3. In Reti virtuali fare clic sul nome della rete che si desidera modificare.

  4. In Proprietà rete virtuale modificare la rete virtuale cambiando le proprietà appropriate.

  5. Fare clic su OK per salvare le modifiche e chiudere Gestione reti virtuali oppure fare clic su Applica per salvare le modifiche e continuare a utilizzare Gestione reti virtuali.
Per rimuovere una rete virtuale

  1. Aprire la console di gestione di Hyper-V.

  2. Scegliere Gestione reti virtuali dal menu Azioni.

  3. In Reti virtuali fare clic sul nome della rete che si desidera rimuovere.

  4. In Proprietà rete virtuale fare clic su Rimuovi.

  5. Fare clic su OK per salvare le modifiche e chiudere Gestione reti virtuali oppure fare clic su Applica per salvare le modifiche e continuare a utilizzare Gestione reti virtuali.

Ulteriori considerazioni

  • Per impostazione predefinita, per eseguire questa procedura è necessaria almeno l'appartenenza al gruppo Administrators locale o a un gruppo equivalente. Un amministratore può tuttavia utilizzare Gestione autorizzazioni per modificare i criteri di autorizzazione in modo che un utente o un gruppo di utenti possa completare questa procedura. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di Gestione autorizzazioni per la sicurezza di Hyper-V (http://go.microsoft.com/fwlink/?LinkId=142886).

  • Non è possibile connettere una rete virtuale a una scheda di rete wireless. Alle macchine virtuali non è pertanto possibile fornire funzionalità di rete wireless.

  • A una scheda di rete fisica specifica è possibile collegare solo una rete virtuale alla volta. Non è possibile collegare più reti virtuali alla stessa scheda di rete fisica.

Ulteriori riferimenti

  • Configurare la rete


Informazioni sulle istantanee di macchine virtuali

Le istantanee delle macchine virtuali sono istantanee basate su file relative allo stato, ai dati del disco e alla configurazione di una macchina virtuale in momento specifico. È possibile acquisire più istantanee di una macchina virtuale, anche mentre la macchina virtuale è in esecuzione. È quindi possibile ripristinare uno stato precedente della macchina virtuale applicando un'istantanea alla macchina virtuale.

Per acquisire un'istantanea, è possibile utilizzare la console di gestione di Hyper-V o Virtual Machine Connection. Tutte le altre attività che è possibile eseguire con le istantanee, ad esempio l'applicazione o l'eliminazione di un'istantanea oppure la visualizzazione di un elenco di tutte le istantanee per una macchina virtuale specifica, sono disponibili tramite la console di gestione di Hyper-V. È inoltre possibile esaminare o modificare i file con estensione avhd, nonché determinare a quale istantanea è associato un file con estensione avhd. Per istruzioni sull'utilizzo e sulla gestione delle istantanee delle macchine virtuali, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=143557).

Importante

Non modificare un disco rigido virtuale utilizzato da una macchina virtuale per le quali sono disponibili istantanee.

Considerazione sulle istantanee delle macchine virtuali

Le istantanee possono contribuire a migliorare l'efficienza di utilizzo in molto scenari in cui è necessario ricreare ambienti di elaborazione diversi e riprodurre condizioni diverse in tali ambienti. Alcuni esempi includono sviluppo e test di software, servizi di supporto tecnico e sviluppo di curriculum di formazione.

L'efficacia e la flessibilità che rendono estremamente utili le istantanee per determinati scenari possono tuttavia determinare conseguenze impreviste e potenzialmente gravi in scenari diversi. Tali conseguenze includono il rischio intrinseco di perdita dei dati in caso di gestione non appropriata delle istantanee. Se ad esempio si modifica un disco rigido virtuale connesso a una macchina virtuale per le quali sono disponibili istantanee, è possibile che si verifichi la perdita di dati.

Gli scenari appropriati per l'utilizzo di istantanee sono rappresentati dalle attività di sviluppo e test, incluso l'utilizzo di una macchina virtuale come server di gestione temporanea per il test di aggiornamenti e hotfix prima della loro distribuzione nei server di produzione. È consigliabile non utilizzare le istantanee nelle macchine virtuali che rendono disponibili servizi per i quali i tempi di risposta sono importanti, ad esempio i servizi Active Directory, oppure quando le prestazioni o la disponibilità di spazio di archiviazione sono fattori essenziali.

Prima di utilizzare le istantanee, è inoltre consigliabile considerare gli aspetti seguenti:

  • L'acquisizione di istantanee determina una riduzione delle prestazioni della macchina virtuale durante la creazione dell'istantanea. È consigliabile non utilizzare le istantanee nelle macchine virtuali che forniscono servizi in un ambiente di produzione.

  • Non è consigliabile utilizzare le istantanee nelle macchine virtuali configurate con dischi rigidi virtuali a dimensione fissa, in quanto non consentono di usufruire dei vantaggi in termini di prestazioni offerti dai dischi rigidi virtuali a dimensione fissa.

  • Per le istantanee è necessario disporre di uno spazio di archiviazione adeguato. Le istantanee vengono archiviate come file con estensione avhd nello stesso percorso nel disco rigido virtuale. L'acquisizione di più istantanee può determinare in tempi rapidi l'utilizzo di grandi quantità di spazio di archiviazione. Quando si utilizza la console di gestione Hyper-V per eliminare un'istantanea, l'istantanea viene rimossa dall'albero delle istantanee, ma il file con estensione avhd non viene rimosso fino a quando la macchina virtuale non viene spenta.

    Attenzione

    Non eliminare direttamente i file con estensione avhd dal percorso di archiviazione.

  • Le istantanee delle macchine virtuali sono diverse dalle istantanee create dal Servizio Copia Shadow del volume. Le istantanee delle macchine virtuali possono rappresentare uno strumento utile per creare backup temporanei di una macchina virtuale, ma non devono essere intese in sostituzione di una soluzione di backup permanente. Per ulteriori informazioni sul backup di macchine virtuali, vedere http://go.microsoft.com/fwlink/?LinkId=143125

Ulteriori riferimenti

  • Risolvere i problemi relativi a Hyper-V

  • Risorse per Hyper-V


Risolvere i problemi relativi a Hyper-V

In questo argomento vengono fornite informazioni sui problemi comuni che possono verificarsi durante l'utilizzo di Hyper-V. Per informazioni dettagliate sulla risoluzione dei problemi in base agli eventi di Hyper-V, vedere la pagina dedicata alla risoluzione dei problemi di Hyper-V nella raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=108562). Per cercare articoli su Hyper-V nella Knowledge Base, visitare il sito Web Guida e supporto tecnico all'indirizzo http://go.microsoft.com/fwlink/?LinkId=113139.

Problema riscontrato

Il ruolo Hyper-V è stato installato ed è possibile creare o importare una macchina virtuale, ma non è possibile avviare la macchina virtuale.

Causa: l'hypervisor non è in esecuzione. Nel registro eventi di sistema sarà incluso l'errore seguente: “Impossibile avviare la macchina virtuale perché l'hypervisor non è in esecuzione”.

Soluzione: per eseguire l'hypervisor, è necessario che il computer fisico soddisfi requisiti hardware specifici. Per le istruzioni, vedere Prerequisiti di installazione per Hyper-V. Se il computer non soddisfa i requisiti, non sarà possibile utilizzarlo per eseguire le macchine virtuali. Se il computer soddisfa i requisiti e l'hypervisor non viene eseguito, potrebbe essere necessario attivare le impostazioni per la virtualizzazione basata su hardware e per la protezione esecuzione programmi applicata a livello di hardware nel BIOS. Se si modificano queste impostazioni, sarà necessario spegnere e quindi riaccendere il computer. Il riavvio del computer non comporta l'applicazione delle modifiche apportate alle impostazioni.

Causa: il disco virtuale che funge da disco di sistema è collegato a un controller SCSI.

Soluzione: collegare il disco di sistema a un controller IDE. Per le istruzioni, vedere Configurare dischi e dispositivi di archiviazione.

Causa: la macchina virtuale è configurata per utilizzare un CD o DVD fisico come supporto di installazione e l'unità fisica è in uso.

Soluzione: l'accesso a un'unità CD o DVD fisica può essere eseguito solo da una macchina virtuale alla volta. Disconnettere l'unità CD o DVD dall'altra macchina virtuale e riprovare.

Non è possibile eseguire un'installazione di rete di un sistema operativo guest.

Causa: la macchina virtuale utilizza una scheda di rete anziché una scheda di rete legacy oppure la scheda di rete legacy non è connessa a una rete esterna appropriata.

Soluzione: verificare che la macchina virtuale sia configurata con una scheda di rete legacy connessa a una rete esterna che offre i servizi di installazione. Per istruzioni sulla configurazione delle schede di rete, vedere Configurare la rete.

Una macchina virtuale viene sospesa automaticamente.

Causa: una macchina virtuale viene sospesa automaticamente quando lo spazio sul volume in cui sono archiviati istantanee o dischi rigidi virtuali è esaurito. Lo stato della macchina virtuale verrà elencato come "sospeso-critico" nella console di gestione di Hyper-V.

Soluzione: creare spazio aggiuntivo nell'unità utilizzando la console di gestione di Hyper-V per applicare o eliminare le istantanee singolarmente. In alternativa, per eliminare tutte le istantanee, esportare la macchina virtuale senza esportare i dati della macchina virtuale e quindi importare la macchina virtuale.

Quando si tenta di creare o avviare una macchina virtuale, si riceve un messaggio di errore relativo a una sezione aperta mappata dall'utente, alla non disponibilità della risorsa o del dispositivo di rete specificato oppure alla terminazione dell'operazione di I/O a causa dell'uscita dal thread o della richiesta di un'applicazione.

Causa: il problema può dipendere dal software antivirus in esecuzione nel sistema operativo di gestione e si verifica quando il componente di ricerca dei virus in tempo reale è configurato per il monitoraggio dei file della macchina virtuale di Hyper-V.

Soluzione: escludere i file della macchina virtuale dalla ricerca dei virus in tempo reale. Per informazioni sui file specifici, vedere l'articolo 961804 della Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=143978).

Le macchine virtuali sono scomparse dalla console di gestione di Hyper-V.

Causa: il problema può dipendere dal software antivirus in esecuzione nel sistema operativo di gestione e si verifica quando il componente di ricerca dei virus in tempo reale è configurato per il monitoraggio dei file della macchina virtuale di Hyper-V.

Soluzione: escludere i file della macchina virtuale dalla ricerca dei virus in tempo reale. Per informazioni sui file specifici, vedere l'articolo 961804 della Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=143978).

Quando si utilizza Virtual Machine Connection, il puntatore del mouse assume la forma di un punto oppure rimane bloccato nella finestra della macchina virtuale.

Causa: i servizi di integrazione non sono installati nel sistema operativo guest.

Soluzione: se il sistema operativo guest è supportato, i servizi di integrazione saranno disponibili per tale sistema operativo. Installare i servizi di integrazione per migliorare l'integrazione del mouse. Per le istruzioni, vedere Installare un sistema operativo guest. Se il sistema operativo guest non è supportato, sarà possibile utilizzare una combinazione di tasti per spostare il mouse all'esterno della finestra della macchina virtuale. La combinazione di tasti predefinita è CTRL+ALT+FRECCIA SINISTRA.

Quando si tenta di controllare una macchina virtuale, non è possibile utilizzare il mouse. Si utilizza Connessione Desktop remoto per connettersi a un server che esegue Hyper-V.

Causa: quando si utilizza la console di gestione di Hyper-V per connettersi a una macchina virtuale, la connessione alla macchina virtuale viene fornita da Virtual Machine Connection. L'utilizzo di Virtual Machine Connection nell'ambito di una sessione di Connessione Desktop remoto non è tuttavia supportato fino a quando non si installano i servizi di integrazione. La mancanza di funzionalità del mouse corrisponde pertanto al comportamento previsto.

Soluzione: evitare di utilizzare Virtual Machine Connection nell'ambito di una sessione di Connessione Desktop remoto fino a quando non si installano i servizi di integrazione. A tale scopo è possibile procedere in più modi:

  • Installare i servizi di integrazione. Per le istruzioni, vedere Installare un sistema operativo guest.

  • Stabilire una sessione di desktop remoto direttamente con la macchina virtuale.

  • Accedere alla console del server che esegue Hyper-V e utilizzare Virtual Machine Connection per connettersi alla macchina virtuale.

  • In un computer client supportato installare gli strumenti di gestione Hyper-V per installare Virtual Machine Connection nel computer e stabilire una sessione di Virtual Machine Connection con la macchina virtuale. Per ulteriori informazioni, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=143558).

All'apertura di Gestione dispositivi nel sistema operativo guest, alcuni dispositivi vengono elencati come dispositivi sconosciuti.

Causa: Gestione dispositivi non riconosce i dispositivi ottimizzati per l'utilizzo nelle macchine virtuali ed eseguiti utilizzando Hyper-V fino a quando non si installano i servizi di integrazione. I dispositivi sconosciuti identificati in Gestione dispositivi variano a seconda del sistema operativo guest e possono includere i dispositivi seguenti: VMBus, miniport HID VMBus Microsoft , scheda di rete VMBus Microsoft e miniport storvsc.

Nota

Alcuni dispositivi ottimizzati non sono disponibili per determinati sistemi operativi guest. Un dispositivo non supportato in un sistema operativo guest non funzionerà. Non è possibile installare il driver di dispositivo manualmente nel tentativo di rendere funzionante il dispositivo. Per un elenco dei dispositivi disponibili in ogni sistema operativo guest supportato, vedere http://go.microsoft.com/fwlink/?LinkID=128037.

Soluzione: se il sistema operativo guest è supportato, i servizi di integrazione saranno disponibili per tale sistema operativo. Dopo avere installato i servizi di integrazione, i dispositivi disponibili per tale sistema operativo guest verranno riconosciuti in Gestione dispositivi. Per le istruzioni, vedere Installare un sistema operativo guest.

Si desidera monitorare le prestazioni di una macchina virtuale, ma le informazioni sul processore visualizzate in Gestione attività non includono le risorse del processore utilizzate dalla macchina virtuale.

Causa: in Gestione attività non vengono visualizzate le informazioni sulla CPU per le macchine virtuali.

Soluzione: per visualizzare le informazioni sull'utilizzo della CPU per le macchine virtuali in esecuzione in un server che esegue Hyper-V, utilizzare Monitoraggio affidabilità e Performance Monitor per visualizzare i dati dei contatori delle prestazioni di Hyper-V. Per aprire Monitoraggio affidabilità e Performance Monitor di Windows, fare clic sul pulsante Start, scegliere Esegui e quindi digitare perfmon.

I contatori delle prestazioni seguenti forniscono informazioni quando vengono visualizzati nel sistema operativo di gestione, ovvero il sistema operativo che esegue il ruolo Hyper-V:

  • % tempo di esecuzione guest processore logico hypervisor Hyper-V: Identifica la quantità di processore fisico utilizzata per eseguire le macchine virtuali. Questo contatore non identifica le singole macchine virtuali o la quantità utilizzata da ogni macchina virtuale.

  • % tempo di esecuzione guest processore virtuale hypervisor Hyper-V: Identifica la quantità di processore virtuale utilizzata da una macchina virtuale.

Nota

Non esiste una associazione diretta tra utilizzo del processore virtuale e utilizzo del processore logico, in quanto i processori virtuali possono essere pianificati per qualsiasi processore logico.


Risorse per Hyper-V

Nella Guida della console di gestione di Hyper-V sono disponibili le informazioni di base sull'utilizzo del ruolo Hyper-V che consente di creare e configurare macchine virtuali. Ulteriori informazioni su Hyper-V sono disponibili nel sito Web Microsoft agli indirizzi seguenti:

  • Per informazioni tecniche, vedere la raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=93752).

  • Per informazioni più dettagliate sulla risoluzione dei problemi, vedere http://go.microsoft.com/fwlink/?LinkID=108562.

  • Per informazioni sul provider WMI di Hyper-V, vedere http://go.microsoft.com/fwlink/?LinkID=108564.

  • Per cercare articoli su Hyper-V nella Knowledge Base, visitare il sito Web Guida e supporto tecnico Microsoft (http://go.microsoft.com/fwlink/?LinkId=113139).

  • Per ulteriori informazioni sui diversi prodotti di virtualizzazione offerti da Microsoft, vedere http://go.microsoft.com/fwlink/?LinkID=108563.

I collegamenti seguenti consentono di accedere a informazioni aggiuntive sulle opzioni e le tecnologie di Windows Server 2008 utili con Hyper-V:

  • Clustering di failover (http://go.microsoft.com/fwlink/?LinkID=92360)

  • Opzione di installazione Server Core (http://go.microsoft.com/fwlink/?LinkID=82146)

  • Servizi Desktop remoto (http://go.microsoft.com/fwlink/?LinkID=139526)


Interfaccia utente: Console di gestione di Hyper-V

In questa sezione vengono descritti gli argomenti seguenti:

  • Creazione guidata macchina virtuale

  • Creazione guidata disco rigido virtuale

  • Modifica guidata disco rigido virtuale

  • Virtual Machine Connection

  • Impostazioni della macchina virtuale

  • Gestione reti virtuali


Creazione guidata macchina virtuale

Pagina Dettagli

Prima di iniziare

È possibile creare una macchina virtuale senza che sia necessario completare la procedura guidata. Se si fa clic su Fine in questa pagina, verrà creata una macchina virtuale con una configurazione predefinita. In caso contrario, sarà possibile personalizzare una macchina virtuale utilizzando le pagine indicate di seguito.

Per ulteriori informazioni sulla configurazione predefinita, vedere Creare macchine virtuali.

Impostazione nome e percorso

È possibile specificare un nome e il percorso appropriati per l'ambiente specifico.

Importante

Se si prevede di includere in un cluster il disco rigido della macchina virtuale, scegliere l'opzione che consente di archiviare la macchina virtuale in una nuova cartella e specificare un percorso di archiviazione condivisa.

Assegnazione memoria

Specificare almeno una una quantità di memoria sufficiente per eseguire il sistema operativo guest e tutte le applicazioni che si desidera eseguire contemporaneamente.

Configurazione rete

Specificare la connessione di rete che si desidera utilizzare. L'opzione Non connessa è sempre disponibile. Se sono state creare reti virtuali, saranno disponibili altre connessioni. È possibile creare una o più reti virtuali quando si utilizza Server Manager per installare il ruolo ed è inoltre possibile creare reti virtuali in un secondo momento con Gestione reti virtuali. Per ulteriori informazioni, vedere Gestire reti virtuali.

Connessione disco rigido virtuale

Consente di creare l'archiviazione per la nuova macchina virtuale senza eseguire la Creazione guidata disco rigido virtuale. Può essere utile quando si desidera installare un sistema operativo guest in una macchina virtuale subito dopo averla creata. Alla macchina virtuale è inoltre possibile connettere un disco rigido virtuale esistente.

Opzioni di installazione

Se si desidera installare un sistema operativo guest subito dopo aver creato la macchina virtuale, sarà possibile specificare il percorso del supporto di installazione.

Completamento della Creazione guidata macchina virtuale

Visualizza i dettagli di configurazione selezionati per la macchina virtuale.

Ulteriori riferimenti

  • Impostazioni della macchina virtuale

  • Creazione guidata disco rigido virtuale

  • Modifica guidata disco rigido virtuale

  • Panoramica di Hyper-V


Creazione guidata disco rigido virtuale

Pagina Dettagli

Prima di iniziare

Illustra lo scopo della procedura guidata. È possibile creare un disco rigido virtuale senza che sia necessario completare la procedura guidata. Se si fa clic su Fine in questa pagina, verrà creato un disco rigido virtuale a espansione dinamica con una capacità di archiviazione di 127 GB.

Selezione tipo di disco
  • I dischi rigidi virtuali a espansione dinamica offrono la capacità di archiviazione necessaria per l'archiviazione dei dati. Le dimensioni del file con estensione vhd sono ridotte quando il disco viene creato e aumentano a mano a mano che i dati vengono aggiunti al disco. Le dimensioni del file con estensione vhd non vengono ridotte automaticamente quando i dati vengono eliminati dal disco rigido virtuale. È tuttavia possibile utilizzare Modifica guidata disco rigido virtuale per compattare il disco in modo da ridurre le dimensioni del file dopo l'eliminazione dei dati.

  • I dischi rigidi virtuali a dimensione fissa forniscono la capacità di archiviazione mediante un file con estensione vhd corrispondente alle dimensioni specificate per il disco rigido virtuale al momento della creazione del disco. Le dimensioni del file con estensione vhd restano fisse indipendentemente dalla quantità di dati archiviati. È tuttavia possibile utilizzare Modifica guidata disco rigido virtuale per aumentare le dimensioni del disco rigido virtuale, con conseguente aumento delle dimensioni del file con estensione vhd.

  • I dischi rigidi virtuali differenze offrono l'archiviazione che consente di apportare modifiche a un disco rigido virtuale padre senza modificare tale disco. Le dimensioni del file con estensione vhd per un disco differenze aumentano a mano a mano che le modifiche vengono archiviate nel disco.

Per ulteriori informazioni sulla modifica di dischi rigidi virtuali, vedere Modifica guidata disco rigido virtuale.

Impostazione nome e percorso

Specificare un nome e un percorso per il nuovo disco rigido virtuale. Se si prevede di aggiungere a un cluster la macchina virtuale che utilizzerà il disco rigido virtuale, specificare un percorso condiviso.

Importante

Non creare la macchina virtuale in una cartella contrassegnata per la crittografia. Hyper-V non supporta l'utilizzo di supporti di archiviazione se il file con estensione vhd è stato crittografato mediante Crittografia file system. È tuttavia possibile utilizzare i file archiviati in un volume che utilizza Crittografia unità BitLocker di Windows.

Configurazione disco

Le opzioni per la configurazione del disco variano a seconda del tipo di disco selezionato.

  • Per dischi rigidi virtuali a dimensione fissa e a espansione dinamica, è possibile specificare una dimensione o copiare il contenuto di un disco fisico disponibile.

  • Per un disco differenze, è necessario specificare il percorso del disco che si desidera utilizzare come disco rigido virtuale padre.

Completamento della Creazione guidata disco rigido virtuale

Visualizza i dettagli di configurazione selezionati per il disco rigido virtuale.

Ulteriori considerazioni

  • Il disco rigido virtuale viene creato quando si fa clic su Fine per completare la procedura guidata. A seconda delle opzioni scelte per il disco rigido virtuale, il processo potrebbe richiedere un tempo considerevole.

Ulteriori riferimenti

  • Creazione guidata macchina virtuale

  • Panoramica di Hyper-V


Modifica guidata disco rigido virtuale

È possibile utilizzare la Modifica guidata disco rigido virtuale per eseguire diverse azioni che determinano la modifica dei dischi rigidi virtuali. Le azioni disponibili variano seconda del tipo di disco selezionato. Nella tabella seguente vengono fornite informazioni su ogni azione.

Azione Descrizione

Compatta

Si applica ai dischi rigidi virtuali a espansione dinamica e ai dischi rigidi virtuali differenze. Riduce le dimensioni del file con estensione vhd rimuovendo lo spazio lasciato vuoto in seguito all'eliminazione dei dati dal disco rigido virtuale. Se il disco rigido virtuale non è formattato con il file system NTFS, lo spazio vuoto dovrà essere sovrascritto con degli zeri, in modo che l'azione di compattamento determini la riduzione delle dimensioni del file mediante la rimozione dei settori che contengono solo zeri.

Nota

Se il disco rigido virtuale non è formattato con il file system NTFS, sarà necessario predisporre il disco rigido virtuale per la compattazione utilizzando un'utilità per dischi non Microsoft che consenta di sostituire gli spazi vuoti con zeri.

Converti

Converte un disco rigido virtuale a espansione dinamica in un disco rigido virtuale a dimensione fissa o viceversa.

Espandi

Aumenta la capacità di archiviazione di un disco rigido virtuale a espansione dinamica o di un disco rigido virtuale a dimensione fissa.

Unisci

Si applica esclusivamente ai dischi differenze. Consente di combinare le modifiche archiviate in un disco differenze con il contenuto del disco padre. È possibile copiare il contenuto del disco padre e del disco differenze in un nuovo disco rigido virtuale lasciando inalterati entrambi i dischi di origine oppure applicare le modifiche al disco padre.

Riconnetti

Si applica esclusivamente ai dischi differenze. Se si seleziona un disco differenze ed è impossibile individuare il disco rigido virtuale padre, verrà visualizzata automaticamente questa pagina. Se i dischi fanno parte di una catena di dischi differenze, questa pagina verrà visualizzata nel caso non sia possibile individuare uno dei dischi della catena.

Ulteriori riferimenti

  • Creazione guidata disco rigido virtuale

  • Creazione guidata macchina virtuale


Virtual Machine Connection

Virtual Machine Connection è uno strumento che consente di connettersi alle macchine virtuali in esecuzione in un server locale o remoto. Per ulteriori informazioni, vedere Connettersi a una macchina virtuale.


Impostazioni della macchina virtuale

È possibile utilizzare Impostazioni macchina virtuale per modificare la configurazione di una macchina virtuale dopo averla creata. Per le istruzioni, vedere Configurare le macchine virtuali.

Alcune impostazioni non necessitano di spiegazione e non sono pertanto incluse in questo argomento. Nelle tabelle seguenti sono incluse le considerazioni sull'utilizzo o le informazioni aggiuntive relative alle impostazioni che potrebbero necessitare di spiegazione.

Impostazione hardware Descrizione

Memoria

Specificare una quantità di memoria sufficiente per eseguire il sistema operativo guest e tutte le applicazioni che verranno eseguite contemporaneamente nella macchina virtuale.

Processore virtuale

Se la macchina virtuale esegue Windows Server 2008 o Windows Server 2003 come sistema operativo guest, sarà possibile assegnare più processori virtuali.

Controlli risorse

Tramite queste impostazioni è possibile controllare la modalità di assegnazione delle risorse alle macchine virtuali eseguite contemporaneamente in un unico computer fisico. Per le istruzioni, vedere Configurare memoria e processori.

Compatibilità processore

L'impostazione Esegui migrazione a un computer fisico con una versione diversa del processore consente di spostare una macchina virtuale in esecuzione in un computer fisico con funzionalità del processore diverse senza che sia necessario riavviare la macchina virtuale. Quando questa impostazione è attivata, la macchina virtuale utilizza solo le funzionalità del processore disponibili in tutte le versioni di un processore che supporta la virtualizzazione di uno stesso produttore. Quando questa impostazione non viene utilizzata, Hyper-V rende disponibili alla macchina virtuale tutte le funzionalità di virtualizzazione offerte dal processore fisico.

COM numero

Una porta COM virtuale collegata a una named pipe viene in genere utilizzata con un debugger del kernel.

Nota

Non è possibile associare la porta COM virtuale a una porta COM fisica.

Unità floppy

Un'unità floppy rende possibile l'utilizzo di un disco floppy virtuale da parte di una macchina virtuale.

Nota

Non è possibile associare l'unità floppy virtuale all'unità floppy fisica.

Impostazione di gestione Descrizione

Percorso file snapshot

Questa impostazione consente di ignorare il percorso predefinito mediante la selezione di un percorso diverso per i file di configurazione e di archivio e memoria necessari per le istantanee. Il percorso predefinito corrisponde al percorso specificato per il server che esegue Hyper-V. Questa impostazione non modifica il percorso di archiviazione dei file (con estensione avhd) contenenti i dati delle istantanee.

Azione avvio automatico

Queste impostazioni consentono di specificare se eseguire il riavvio della macchina virtuale quando il computer fisico o il servizio Virtual Machine Management Hyper-V viene riavviato.

Nota

Se si prevede di impostare la macchina virtuale per la disponibilità elevata, non configurare la macchina virtuale per il riavvio automatico. Per ulteriori informazioni, vedere Configurare una macchina virtuale per la disponibilità elevata.

Azione arresto automatico

Queste impostazioni consentono di specificare lo stato su cui impostare la macchina virtuale quando il computer fisico viene arrestato.


Gestione reti virtuali

Gestione reti virtuali consente di creare e gestire reti virtuali. Per le istruzioni, vedere Gestire reti virtuali.

Nella tabella seguente vengono descritte le impostazioni disponibili per Gestione reti virtuali.

Impostazione Descrizione

Esterna

Crea una connessione a una scheda di rete fisica in modo che le macchine virtuali possano accedere a una rete fisica.

L'impostazione Consenti condivisione della scheda di rete da parte del sistema operativo di gestione determina se è possibile utilizzare la scheda di rete fisica per accedere al sistema operativo di gestione, ovvero il sistema operativo che esegue il ruolo Hyper-V. È possibile utilizzare questa opzione per isolare il sistema operativo di gestione dalle comunicazioni tra le macchine virtuali e gli altri computer in una rete fisica. Quando questa opzione è deselezionata non è tuttavia possibile connettersi da postazione remota al sistema operativo di gestione tramite la scheda di rete fisica.

Interna

Consente la comunicazione tra il sistema operativo di gestione e le macchine virtuali.

Privata

Consente la comunicazione solo tra due macchine virtuali.

Abilita identificazione LAN virtuale

Specifica un numero di identificazione che può essere utilizzato per isolare il traffico di rete dal sistema operativo di gestione. È necessario che la configurazione della rete LAN sia supportata dalla scheda di rete fisica. Per informazioni sulla configurazione dell'identificazione LAN virtuale, vedere le informazioni relative alla distribuzione di Hyper-V nella raccolta di documentazione tecnica di Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkID=131362).

Intervallo indirizzi MAC

Questa impostazione consente di specificare un intervallo di indirizzi da utilizzare nell'assegnazione di indirizzi MAC dinamici alle macchine virtuali. Ciò consente di evitare che si verifichino conflitti quando più computer fisici che eseguono Hyper-V utilizzano la stessa subnet e quando lo stesso indirizzo MAC è assegnato a più macchine virtuali che comunicano in tale subnet fisica. Gli indirizzi MAC dinamici vengono assegnati da Hyper-V in base a un intervallo predefinito uguale in ogni installazione di Hyper-V. È possibile utilizzare questa impostazione per suddividere l'intervallo predefinito in intervalli secondari e assegnare un intervallo secondario diverso a ogni computer fisico che esegue Hyper-V.

Ulteriori riferimenti

  • Configurare la rete

  • Interfaccia utente: Console di gestione di Hyper-V