Controllo WMI

  • Per informazioni sull'utilizzo di Controllo WMI, vedere Procedure di Controllo WMI.

  • Per ulteriori informazioni sul Controllo WMI, vedere Concetti di Controllo WMI.


Procedure di Controllo WMI

  • Eseguire il backup o ripristinare l'archivio WMI

  • Modificare le impostazioni degli script WMI

  • Autorizzare gli utenti WMI e impostare le autorizzazioni

  • Modificare le autorizzazioni o eliminare gli utenti autorizzati


Eseguire il backup o ripristinare l'archivio WMI

Per eseguire il backup o ripristinare l'archivio WMI

  1. Aprire la console Controllo WMI: fare clic su Start, scegliere Esegui, digitare wmimgmt.msc e quindi fare clic su OK.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Controllo WMI e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Backup/Ripristino.

  4. Scegliere Effettua backup o Ripristina.

Ulteriori considerazioni

  • Per eseguire questa procedura è necessario essere membri del gruppo Administrators nel computer locale oppure disporre della delega per l'autorità appropriata. Se il computer fa parte di un dominio, i membri del gruppo Domain Admins potrebbero essere in grado di eseguire la procedura. Per garantire un livello di sicurezza ottimale, è consigliabile inoltre utilizzare la funzione Esegui come.

  • È necessario eseguire l'accesso come amministratore del computer locale per salvare il file di backup nella cartella %Windir%\System32\Wbem\Repository. In caso contrario, è possibile salvarlo nella cartella Documenti per il profilo dell'account.

  • Quando si sceglie Effettua backup per eseguire manualmente il backup dell'archivio, è possibile eseguire il backup con il nome del file specificato e ripristinarlo in un secondo momento dal file salvato. Questo approccio risulta utile se si desidera salvare una configurazione di classi specifica. È inoltre possibile eseguire il comando Winmgmt al prompt dei comandi ed eseguire il ripristino dal file salvato. Per ulteriori informazioni sull'utilizzo del comando Winmgmt, fare clic su Start scegliere Esegui e digitare winmgmt /?


Modificare le impostazioni degli script WMI

Per modificare le impostazioni degli script WMI

  1. Aprire la console Controllo WMI: fare clic su Start, scegliere Esegui, digitare wmimgmt.msc e quindi fare clic su OK.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Controllo WMI e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Avanzate.

  4. In Spazio dei nomi predefinito per lo script fare clic su Modifica.

  5. Nella finestra di dialogo Selezione spazio dei nomi scegliere uno spazio dei nomi predefinito diverso come destinazione degli script.

Ulteriori considerazioni

  • Impostare lo spazio dei nomi di destinazione predefinito su quello che viene utilizzato più spesso negli script WMI. Se non viene identificato nessuno spazio dei nomi in uno script, verrà utilizzato quello predefinito.

  • Se il computer che si sta gestendo esegue Microsoft Windows NT 4.0, è possibile stabilire se gli script WMI possono essere eseguiti da una pagina ASP. Se si attiva questa opzione, la pagina ASP si connette ai Servizi Gestione Windows utilizzando l'identità del livello di processo di Internet Information Services, che potrebbe compromettere la sicurezza.

  • È possibile modificare il nome spazio dello script su un computer remoto o locale. Per accedere a un computer remoto, fare clic con il pulsante destro del mouse su Controllo WMI, scegliere Connetti a un altro computer, fare clic su Altro computer e digitare il nome del computer al quale si desidera connettersi. Se si sta utilizzando Controllo WMI dalla console Gestione computer, fare clic con il pulsante destro del mouse sul nodo Gestione computer per connettersi all'altro computer.

  • Per connettersi a un altro computer, è necessario accedere come membri del gruppo Administrators del computer remoto. Per ulteriori informazioni, vedere Connettersi a WMI su un computer remoto.


Autorizzare gli utenti WMI e impostare le autorizzazioni

Per autorizzare gli utenti WMI e impostare le autorizzazioni

  1. Aprire la console Controllo WMI: fare clic su Start, scegliere Esegui, digitare wmimgmt.msc e quindi fare clic su OK.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Controllo WMI e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Sicurezza.

  4. Scegliere lo spazio dei nomi per il quale si desidera dare l'accesso a un utente o a un gruppo e quindi fare clic su Sicurezza.

  5. Nella finestra di dialogo Sicurezza fare clic su Aggiungi.

  6. Nella finestra di dialogo Seleziona utenti, Computer o Gruppi, immettere il nome dell'oggetto, utente o gruppo, che si desidera aggiungere. Scegliere Controlla nomi per verificare l'immissione e quindi fare clic su OK. Potrebbe essere necessario modificare il percorso o fare clic sul pulsante Avanzate per trovare gli oggetti. Per ulteriori dettagli vedere la Guida della finestra di dialogo.

  7. Nella finestra di dialogo Sicurezza in Autorizzazioni scegliere le autorizzazioni da concedere o negare all'utente o gruppo nuovo:

Livello | Descrizione
Esegui metodi | Consente a un utente di eseguire i metodi della classe WMI.
Scrittura completa | Consente l'accesso completo in lettura, scrittura ed eliminazione di tutti gli oggetti, classi e istanze WMI, dinamici e statici.
Scrittura parziale | Consente l'accesso in scrittura agli oggetti WMI statici.
Scrittura provider | Consente l'accesso in scrittura a classi e istanze WMI dinamiche.
Abilita account | Consente l'accesso in scrittura agli oggetti WMI.
Abilita remoto | Consente l'accesso remoto allo spazio dei nomi.
Sicurezza lettura | Consente l'accesso in sola lettura alle informazioni sulla sicurezza.
Modifica sicurezza | Consente l'accesso in lettura e scrittura alle informazioni sulla sicurezza.

Ulteriori considerazioni

  • Per eseguire questa procedura sul computer locale, è necessario essere connessi come membri del gruppo Administrators locale.

  • Per eseguire questa procedura sul computer remoto, è necessario che l'account utilizzato per la connessione appartenga al gruppo Administrators di quel computer. Per accedere a un computer remoto, fare clic con il pulsante destro del mouse su Controllo WMI, scegliere Connetti a un altro computer, fare clic su Altro computer e digitare il nome del computer al quale si desidera connettersi. Se si sta utilizzando Controllo WMI dalla console Gestione computer, fare clic con il pulsante destro del mouse su Gestione computer per connettersi all'altro computer.

  • È possibile eliminare l'autorizzazione di un utente o di un gruppo per accedere ai Servizi WMI scegliendo l'utente o il gruppo e facendo clic su Rimuovi.

Ulteriori riferimenti

  • Gestire la sicurezza WMI

  • Modificare le autorizzazioni o eliminare gli utenti autorizzati


Modificare le autorizzazioni o eliminare gli utenti autorizzati

Per modificare le autorizzazioni o eliminare gli utenti autorizzati

  1. Aprire la console Controllo WMI: Fare clic su Start, scegliere Esegui, digitare wmimgmt.msc e quindi fare clic su OK.

  2. Nell'albero della console fare clic con il pulsante destro del mouse su Controllo WMI e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Sicurezza.

  4. Scegliere lo spazio dei nomi per il quale si desidera modificare le autorizzazioni di un utente o di un gruppo o eliminare un utente o un gruppo e quindi fare clic su Sicurezza.

  5. Nella finestra di dialogo Sicurezza in Nome scegliere l'utente o il gruppo che si desidera rimuovere o del quale si desiderano modificare le autorizzazioni.

  6. Eseguire una delle operazioni seguenti:

    • Per rimuovere un utente o un gruppo, fare clic su Rimuovi.

    • Per modificare le impostazioni di sicurezza, in Autorizzazioni modificare le autorizzazioni concesse o negate all'utente o al gruppo deselezionando o selezionando le caselle di controllo appropriate.

Ulteriori considerazioni

  • Per eseguire questa attività, è necessario essere amministratore o utilizzare un account di dominio che sia membro del gruppo Administrators sul computer che si sta gestendo.

  • La sicurezza WMI viene verificata soltanto quando un utente accede ai Servizi Gestione Windows. Tutte le modifiche apportate alle autorizzazioni di un utente mentre l'utente è connesso non hanno effetto fino al successivo accesso a WMI. Ad esempio, se l'accesso di un utente viene revocato, le modifiche non avranno effetto fino a quando l'utente non si disconnette dai Servizi Gestione Windows e tenta di accedere di nuovo.

  • È possibile modificare le autorizzazioni di un utente o di un gruppo su un computer remoto o locale. Per accedere a un computer remoto, fare clic con il pulsante destro del mouse su Controllo WMI, scegliere Connetti a un altro computer, fare clic su Altro computer e digitare il nome del computer al quale si desidera connettersi. Se si sta utilizzando Controllo WMI dalla console Gestione computer, fare clic con il pulsante destro del mouse sul nodo Gestione computer per connettersi all'altro computer.

Ulteriori riferimenti

  • Gestire la sicurezza WMI.

  • Autorizzare gli utenti WMI e impostare le autorizzazioni.


Concetti di Controllo WMI

  • Panoramica di Controllo WMI

  • Panoramica di WMI

  • Gestire la sicurezza WMI


Panoramica di Controllo WMI

Controllo WMI è uno strumento che consente di configurare le impostazioni WMI su un computer remoto o locale. Utilizzando Controllo WMI, è possibile eseguire le attività seguenti:

Eseguire il backup dell'archivio

È possibile configurare controllo WMI per eseguire il backup dell'archivio WMI in base a una pianificazione regolare o per eseguirlo ogni volta manualmente. L'archivio è il database di oggetti ai quali è possibile accedere tramite WMI. È inoltre possibile ripristinare una versione precedente dell'archivio.

Vedere Eseguire il backup o ripristinare l'archivio WMI

Modificare lo spazio dei nomi predefinito per gli script

È possibile modificare lo spazio dei nomi predefinito che viene assegnato negli script WMI.

Vedere Modificare le impostazioni degli script WMI

Autorizzare gli utenti o i gruppi e impostare i livelli di autorizzazione

È possibile autorizzare un utente o un gruppo per l'accesso a WMI. Per ogni utente o gruppo autorizzato, è possibile impostare il livello di autorizzazione per spazi dei nomi specifici.

Vedere:

  • Autorizzare gli utenti WMI e impostare le autorizzazioni

  • Modificare le autorizzazioni o eliminare gli utenti autorizzati

Ulteriori considerazioni

  • Per ulteriori informazioni su WMI, vedere Panoramica di WMI.

  • Per informazioni sull'utilizzo di interfaccia da riga di comando di WMI, visualizzare l'utilizzo della riga di comando di Windows Management Instrumentation Control Command-line (Wmic.exe) eseguendo wmic.exe -? al prompt dei comandi.


Panoramica di WMI

Strumentazione gestione Windows (WMI) è lo strumento principale di dati e funzionalità di gestione su computer locali e remoti che eseguono sistemi operativi Microsoft Windows. È possibile ottenere dati di gestione WMI direttamente mediante script e applicazioni o strumenti di gestione aziendale, ad esempio Microsoft Systems Management Server (SMS) e Microsoft Operations Manager (MOM). È possibile utilizzare script redatti in qualsiasi linguaggio di script che può essere utilizzato con Windows Script Host.

A partire da Windows Vista, le applicazioni o gli script che utilizzano il protocollo WS-Management possono ottenere i dati WMI tramite Gestione remota Windows.

WMI è l'implementazione Microsoft di WEBM, un progetto industriale per la definizione degli standard di accesso e la condivisione delle informazioni di gestione attraverso la rete aziendale. WMI è conforme a WBEM e offre supporto integrato per il modello Common Information Model (CIM), il modello di dati che descrive gli oggetti esistenti in un ambiente di gestione aziendale.

WMI include un archivio di oggetti conformi al modello CIM e il CIM Object Manager. Nell'archivio di oggetti sono contenute le definizioni degli oggetti che forniscono dati per hardware e software gestibili. Esempi di classi WMI sono le classi Win32, ad esempio Win32_Printer o Win32_ComputerSystem e StdRegProv, che fornisce dati del Registro di sistema.

CIM Object Manager gestisce la raccolta e la modifica degli oggetti nell'archivio e raccoglie le informazioni dai provider WMI. I provider WMI fungono da intermediari tra WMI e i componenti del sistema operativo, i driver, le applicazioni e altri sistemi. Diversi strumenti di gestione sistemi di Windows sono abilitati allo strumento WMI.

Ulteriori riferimenti

  • Per informazioni sull'utilizzo del Controllo WMI per configurare le impostazioni WMI e la sicurezza su un computer remoto o locale, vedere Panoramica di Controllo WMI.

  • Per informazioni sullo sviluppo di script e applicazioni che utilizzano i dati e le funzioni WMI, vedere Strumentazione gestione Windows.

  • Per informazioni sull'utilizzo dell'interfaccia da riga di comando di WMI, visualizzare l'utilizzo della riga di comando di Windows Management Instrumentation Control Command-line (Wmic.exe) eseguendo wmic.exe -? al prompt dei comandi.


Gestire la sicurezza WMI

Strumentazione gestione Windows (WMI) supporta una forma limitata di sicurezza che riconosce ogni utente prima che venga autorizzato a connettersi a WMI su un computer remoto o locale. Questa sicurezza è ai livelli più alti della sicurezza del sistema operativo. WMI non ignora né aggira la sicurezza fornita dal sistema operativo.

Per impostazione predefinita, solo l'account Administrator del computer locale ha il controllo completo dei Servizi WMI sul computer che viene gestito. I membri del gruppo Administrators hanno accesso ai computer remoti ma non possono accedere a tutti i dati. Tutti gli altri hanno autorizzazioni in lettura/scrittura/esecuzione soltanto sul proprio computer locale.

È possibile modificare le autorizzazioni aggiungendo un utente al gruppo Administrators sul computer gestito oppure autorizzando utenti o gruppi WMI e impostando il relativo livello di autorizzazione. L'accesso di basa sugli spazi dei nomi WMI.

La sicurezza viene verificata soltanto quando un utente si connette al Servizio WMI e a uno spazio dei nomi. Tutte le modifiche apportate alle autorizzazioni di un utente mentre l'utente è connesso non hanno effetto fino al successivo accesso al Servizio WMI. Ad esempio, se l'accesso di un utente viene revocato, le modifiche non avranno effetto fino a quando l'utente non si disconnette da WMI e tenta di accedere di nuovo al servizio.

Ulteriori considerazioni

  • Autorizzare gli utenti WMI e impostare le autorizzazioni

  • Modificare le autorizzazioni o eliminare gli utenti autorizzati