Server SMTP

Windows Server 2008
Server SMTP

Il server SMTP di Windows Server 2008 utilizza il protocollo SMTP (Simple Mail Transfer Protocol) standard di Internet per trasmettere e recapitare messaggi secondo le specifiche contenute nelle Request for Comments (RFC) 2821 e 2822. Esso include inoltre caratteristiche avanzate che potenziano le funzioni di recapito di base del protocollo. Sono altresì disponibili opzioni che consentono di controllare il routing e il recapito dei messaggi e che garantiscono comunicazioni protette.

Per informazioni su attività specifiche, vedere Procedure relative al server SMTP.

Per informazioni generiche sui concetti di base, vedere Concetti relativi al server SMTP.

Per informazioni sul monitoraggio delle prestazioni, vedere Manutenzione del server SMTP.

Per istruzioni sulla risoluzione dei problemi, vedere Risoluzione dei problemi del server SMTP.

Per informazioni sulle schede e le proprietà dell'interfaccia utente del server SMTP, vedere Riferimento.


Procedure relative al server SMTP

Procedure relative al server SMTP
Server SMTP >

In questa sezione sono contenute le istruzioni per la configurazione e la gestione del server SMTP di Windows Server 2008.

  • Installare il server SMTP

  • Utilizzare Microsoft Management Console

  • Avviare, interrompere o sospendere un server virtuale SMTP

  • Avviare, interrompere o sospendere il servizio SMTP

  • Configurare il server virtuale SMTP

  • Modificare l'impostazione di avvio predefinita

  • Creazione di server virtuali SMTP aggiuntivi

  • Configurare le connessioni

  • Abilitare la registrazione dei protocolli

  • Configurare un server virtuale per il clustering

  • Impostare le opzioni di protezione

  • Gestire i messaggi

  • Recapitare i messaggi

  • Creare o eliminare un dominio

  • Configurare domini locali

  • Configurare domini remoti

  • Configurare le connessioni a un server LDAP

  • Configurare un database conforme allo standard ODBC


Installare il server SMTP

Installare il server SMTP
Server SMTP > Procedure relative al server SMTP >

La funzionalità del server SMTP non viene installata per impostazione predefinita sui computer che eseguono Windows Server 2008. Per installarla è necessario utilizzare Gestione server.

Importante:
Quando si installa la funzionalità del server SMTP sui computer che eseguono Windows Server 2008, nel server virtuale SMTP predefinito è attivato solo l'Accesso anonimo. Per ulteriori informazioni, vedere Richiesta dell'autenticazione per le connessioni in ingresso.

Procedura

Per installare il server SMTP

  1. Durante l'installazione di Windows Server 2008 Standard operating system e Windows Server 2008 Enterprise operating system, verrà visualizzata la finestra Attività di configurazione iniziale. Per eseguire la procedura, è possibile utilizzare questo strumento. Tuttavia se è stata selezionata la casella Non visualizzare questa finestra all'accesso, è necessario utilizzare la finestra Gestione server.

    Per aprire manualmente Gestione server, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, quindi Gestione server.

  2. In Gestione server, scegliere Gestione server (nome server). Nel riquadro dei risultati, individuare la sezione Riepilogo funzionalità, quindi fare clic su Aggiungi funzionalità per aprire l'Aggiunta guidata funzionalità.

  3. Nella pagina Selezione delle funzionalità selezionare Server SMTP. Se viene visualizzata una finestra di dialogo con il messaggio Aggiungere funzionalità richieste per il server SMTP?, fare clic su Aggiungi funzionalità richieste. Quindi, fare clic su Avanti.

  4. Nella pagina Conferma opzioni installazione scegliere Installa. Durante l'installazione del server SMTP viene visualizzata la pagina Stato dell'installazione.

  5. Accertarsi che nella pagina Risultati installazione venga visualizzato il messaggio Installazione completata, quindi scegliere Chiudi.
Nota:
Il server SMTP viene gestito mediante Gestione Internet Information Services (IIS) 6.0 e tramite la configurazione delle proprietà dei server virtuali SMTP.


Utilizzare Microsoft Management Console

Utilizzare Microsoft Management Console
Server SMTP > Procedure relative al server SMTP >

Lo strumento di amministrazione della funzionalità del server SMTP è Gestione Internet Information Services (IIS) 6.0. Tale strumento viene implementato come parte di Microsoft Management Console (MMC). Consente di eseguire tutte le attività operative e richiede una connessione a una rete locale (LAN). Per le istruzioni sulle modalità di avvio di Microsoft Management Console, vedere Avviare Microsoft Management Console.

Per impostazione predefinita, questo strumento di amministrazione viene installato nel computer che esegue il server SMTP.

Per gestire il server SMTP tramite Microsoft Management Console da un computer remoto, è necessario disporre di un computer che esegue Windows Server 2008, aggiungere lo snap-in Gestione Internet Information Services (IIS) 6.0 a MMC e connettersi al computer che si desidera gestire.

Nota:
Per poter utilizzare il server SMTP, gli operatori devono disporre delle autorizzazioni appropriate. Per ulteriori informazioni, vedere Impostare le opzioni di protezione.


Avviare Microsoft Management Console

Avviare Microsoft Management Console
Server SMTP > Procedure relative al server SMTP > Utilizzare Microsoft Management Console >

È possibile gestire il server SMTP utilizzando lo snap-in Gestione Internet Information Services (IIS) 6.0 per Microsoft Management Console (MMC) dal computer in cui è in esecuzione la funzionalità.

Importante:
La funzionalità del server SMTP non viene installata per impostazione predefinita sui computer che eseguono Windows Server 2008. Per istruzioni sull'installazione del server SMTP, vedere Installare il server SMTP.
Nota:
Microsoft Management Console può essere utilizzato anche per amministrare il server virtuale SMTP (Simple Mail Transfer Protocol) da un computer remoto, purché questo sia connesso alla stessa rete locale (LAN) del server SMTP. Nel computer remoto deve essere tuttavia in esecuzione Windows Server 2008 ed è necessario aggiungere lo snap-in Gestione IIS 6.0 a MMC e connettersi al computer da gestire. Se si sceglie di amministrare SMTP da una postazione remota, assicurarsi che la connessione al server che esegue SMTP sia protetta e non possa essere intercettata.

Procedura

Per eseguire Gestione IIS 6.0 dal computer in cui è in esecuzione il server SMTP

  1. Fare clic su Start, scegliere Pannello di controllo, quindi Strumenti di amministrazione e infine Gestione Internet Information Services (IIS) 6.0.

  2. Nell'albero della console espandere Nome server. Il server virtuale che viene installato insieme al server SMTP è [Server virtuale SMTP #1].

Per visualizzare o modificare le proprietà di un server virtuale SMTP

  1. Selezionare il server virtuale SMTP che si desidera modificare.

  2. Scegliere Proprietà dal menu Azione.

  3. Fare clic sulla scheda che si desidera visualizzare o modificare.

  4. Modificare le opzioni desiderate.

    Per ulteriori informazioni sulle opzioni delle schede, vedere Accesso alle schede.


Avviare, interrompere o sospendere un server virtuale SMTP

Avviare, interrompere o sospendere un server virtuale SMTP
Server SMTP > Procedure relative al server SMTP >

Il server virtuale SMTP predefinito viene avviato con l'installazione del server SMTP e può essere sospeso, interrotto e riavviato da Microsoft Management Console.

Nota:
È anche possibile avviare, interrompere e sospendere l'intero servizio SMTP (Simple Mail Transfer Protocol). Per istruzioni, vedere Avviare, interrompere o sospendere il servizio SMTP. Se tuttavia si dispone di più server virtuali, l'interruzione del servizio SMTP avrà effetto su tutti i server virtuali SMTP in esecuzione nel computer. Quando il servizio SMTP viene interrotto, non è possibile utilizzare Microsoft Management Console per eseguire funzioni di amministrazione in alcun server virtuale SMTP.

È possibile interrompere e avviare il servizio SMTP manualmente. Tuttavia, mentre il servizio è in esecuzione, prestare attenzione quando lo si interrompe, sospende o riavvia per creare il minor numero possibile di problemi agli utenti.

Importante:
Assicurarsi che solo amministratori fidati e qualificati dispongano delle autorizzazioni necessarie per avviare o interrompere un server virtuale SMTP. Per ulteriori informazioni, vedere Impostare le opzioni di protezione.

In questa sezione viene illustrato come avviare, interrompere e sospendere i server virtuali SMTP con Microsoft Management Console. Nella sezione sono inclusi i seguenti argomenti:

  • Avvio di un server virtuale SMTP

  • Sospensione di un server virtuale SMTP

  • Interruzione di un server virtuale SMTP


Avvio di un server virtuale SMTP

Avvio di un server virtuale SMTP
Server SMTP > Procedure relative al server SMTP > Avviare, interrompere o sospendere un server virtuale SMTP >

Se l'impostazione di avvio predefinita è Manuale, sarà possibile utilizzare Microsoft Management Console per avviare un server virtuale SMTP (Simple Mail Transfer Protocol).

Procedura

Per avviare un server virtuale SMTP

  1. In Microsoft Management Console espandere la struttura ad albero del server virtuale SMTP.

    Per istruzioni su come avviare Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Fare clic sul server virtuale SMTP per selezionarlo.

  3. Scegliere Avvia dal menu Azione.


Sospensione di un server virtuale SMTP

Sospensione di un server virtuale SMTP
Server SMTP > Procedure relative al server SMTP > Avviare, interrompere o sospendere un server virtuale SMTP >

È possibile sospendere un server virtuale SMTP (Simple Mail Transfer Protocol) per apportare modifiche alla configurazione e per eseguire attività di manutenzione. Con la sospensione non vengono accettate nuove connessioni client, ma il server virtuale può continuare a elaborare le connessioni client esistenti e a recapitare i messaggi in coda.

Procedura

Per sospendere un server virtuale SMTP

  1. In Microsoft Management Console espandere la struttura ad albero del server virtuale SMTP.

    Per istruzioni su come avviare Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Selezionare il server virtuale SMTP.

  3. Scegliere Sospendi dal menu Azione.


Interruzione di un server virtuale SMTP

Interruzione di un server virtuale SMTP
Server SMTP > Procedure relative al server SMTP > Avviare, interrompere o sospendere un server virtuale SMTP >

È possibile interrompere un server virtuale SMTP (Simple Mail Transfer Protocol) per apportare modifiche alla configurazione ed eseguire attività di manutenzione.

Procedura

Per interrompere un server virtuale SMTP

  1. In Microsoft Management Console, espandere la struttura del server virtuale SMTP.

    Per le istruzioni sulle modalità di avvio di Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Selezionare il server virtuale SMTP.

  3. Scegliere Interrompi dal menu Azione.


Avviare, interrompere o sospendere il servizio SMTP

Avviare, interrompere o sospendere il servizio SMTP
Server SMTP > Procedure relative al server SMTP >

SMTP (Simple Mail Transfer Protocol) viene eseguito come servizio sui computer che eseguono Windows Server 2008. Per impostazione predefinita, il server SMTP viene avviato automaticamente una volta eseguita l'installazione. Per istruzioni sull'installazione del server SMTP, vedere Installare il server SMTP.

In un computer possono coesistere più server virtuali SMTP, ma vi può essere una sola istanza del servizio SMTP. Mentre è in esecuzione il servizio SMTP, è possibile avviare, interrompere o sospendere i singoli server virtuali in modo indipendente l'uno dall'altro. Per ulteriori informazioni, vedere Avviare, interrompere o sospendere un server virtuale SMTP.

Se si dispone di più server virtuali SMTP, è importante però ricordare che la sospensione o l'interruzione dell'intero servizio SMTP avrà impatto su tutti i server virtuali SMTP.

Quando il servizio SMTP viene avviato, vengono accettate nuove richieste di connessioni in ingresso. Quando viene interrotto, non vengono accettate nuove connessioni. Quando invece viene sospeso, i server virtuali SMTP in esecuzione non accettano più nuove connessioni, ma continuano a servire quelle già attive.

Importante:
Assicurarsi che solo amministratori fidati e qualificati abbiano le autorizzazioni necessarie per avviare o interrompere il servizio SMTP. Per ulteriori informazioni, vedere Impostare le opzioni di protezione.

Procedura

Per avviare, interrompere o sospendere il servizio SMTP utilizzando Strumenti di amministrazione

  1. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Servizi.

  2. Nell'albero della console scegliere Servizi (locale).

  3. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sulla voce corrispondente al servizio SMTP, quindi scegliere Avvia, Arresta o Sospendi.
Nota:
Quando si riavvia il servizio SMTP, tutti i server virtuali SMTP che erano in esecuzione al momento della chiusura del servizio verranno riavviati automaticamente. I server virtuali SMTP che non erano in funzione alla chiusura del servizio continueranno, invece, a rimanere inattivi anche dopo il riavvio del servizio SMTP.


Configurare il server virtuale SMTP

Configurare il server virtuale SMTP
Server SMTP > Procedure relative al server SMTP >

Le funzionalità che identificano un server virtuale SMTP (Simple Mail Transfer Protocol) sono due:

  • Nome visualizzato

  • Combinazione di indirizzo IP e porta TCP

Durante l'installazione, al server virtuale SMTP predefinito viene assegnato un nome visualizzato di Microsoft Management Console. È possibile mantenere tale nome [Server virtuale SMTP #1] o modificarlo attenendosi alla procedura descritta di seguito. È anche possibile selezionare l'indirizzo IP che sarà associato al server virtuale SMTP.

Procedura

Per identificare un server virtuale SMTP

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Rinomina dal menu Azione.

    Per istruzioni sulle modalità di avvio di Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Digitare un nuovo nome per il server virtuale se si desidera modificare quello predefinito.

    Nota:
    Non utilizzare caratteri estesi nel nome di un server virtuale SMTP.

  3. Selezionare il server virtuale SMTP, quindi scegliere Proprietà dal menu Azione.

  4. In Indirizzo IP selezionare l'indirizzo IP per il server virtuale. Il server virtuale SMTP può rispondere a richieste di connessione per tutti gli indirizzi IP configurati sul computer. Per impostare la porta TCP per ciascun indirizzo IP configurato per il server virtuale, scegliere Avanzate. La porta 25 è la porta TCP standard per SMTP ed è quella consigliata. Più server virtuali possono utilizzare la porta 25, purché siano associati a indirizzi IP diversi.
Nota:
Quando si modifica la configurazione di un server virtuale SMTP, si consiglia di utilizzare il comando Sospendi. Per istruzioni su come sospendere un server virtuale SMTP, vedere Sospensione di un server virtuale SMTP. Con la sospensione non vengono accettate nuove connessioni client, ma il servizio SMTP può continuare a elaborare le connessioni esistenti e a recapitare i messaggi in coda.


Modificare l'impostazione di avvio predefinita

Modificare l'impostazione di avvio predefinita
Server SMTP > Procedure relative al server SMTP >

È possibile utilizzare gli Strumenti di amministrazione per configurare lo stato predefinito del servizio SMTP all'avvio.

Procedura

Per modificare l'impostazione di avvio predefinita

  1. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Servizi.

  2. Nell'albero della console selezionare Servizi (computer locale).

  3. Nel riquadro dei risultati fare clic con il pulsante destro del mouse su SMTP (Simple Mail Transfer Protocol), quindi scegliere Proprietà.

  4. Nella sezione Tipo di avvio della scheda Generale selezionare Automatico (avvio ritardato), Automatico, Manuale o Disabilitato.


Creazione di server virtuali SMTP aggiuntivi

Creazione di server virtuali SMTP aggiuntivi
Server SMTP > Procedure relative al server SMTP >

Nella maggior parte dei casi è sufficiente un solo server virtuale SMTP (Simple Mail Transfer Protocol). Se tuttavia si ospitano più domini e si desidera ad esempio impostarne più di uno come dominio predefinito, è possibile creare più server virtuali SMTP. All'utente finale ciascun server virtuale SMTP appare come un server distinto con una combinazione univoca di indirizzo IP/porta TCP.

Quando si crea un server virtuale SMTP, viene richiesto di immettere il percorso relativo alla directory principale. Tale directory deve essere locale per il computer in cui è in esecuzione il servizio SMTP.

Nota:
Assicurarsi che solo amministratori fidati e qualificati dispongano delle autorizzazioni necessarie per creare un nuovo server virtuale SMTP. Per ulteriori informazioni, vedere Impostare le opzioni di protezione.

Procedura

Per creare un nuovo server virtuale SMTP utilizzando Microsoft Management Console

  1. Se il server virtuale SMTP utilizzerà un nuovo indirizzo IP, configurare l'indirizzo IP facendo clic sul pulsante Start, scegliendo Pannello di controllo e quindi Centro connessioni di rete e condivisione.

    Per ulteriori informazioni sul Centro connessioni di rete e condivisione, vedere la documentazione di Windows Server 2008.

  2. Dopo aver configurato l'indirizzo IP, selezionare un server virtuale SMTP esistente in Microsoft Management Console. Scegliere Nuovo dal menu Azione, quindi Server virtuale. Per istruzioni su come avviare Microsoft Management Console, vedere Avviare Microsoft Management Console.

  3. Seguire le istruzioni della Configurazione guidata del nuovo server virtuale SMTP. Assicurarsi di selezionare una combinazione di indirizzo IP/porta TCP non utilizzata da un altro server virtuale SMTP. La porta TCP consigliata è la porta 25, vale a dire la porta TCP standard per SMTP. Più server virtuali possono utilizzare la stessa porta TCP, purché siano configurati con indirizzi IP differenti.

  4. Se l'impostazione di avvio predefinita per il servizio SMTP è Automatico, il nuovo server virtuale SMTP si avvierà da solo. Se il server non si avvia, significa che è stata selezionata una combinazione di indirizzo IP/porta TCP già in uso.

  5. Configurare il nuovo server virtuale SMTP.


Configurare le connessioni

Configurare le connessioni
Server SMTP > Procedure relative al server SMTP >

Viene avviata una connessione ogni volta che un messaggio viene inviato o ricevuto da un server remoto.

Importante:
L'impostazione di limiti per le connessioni e l'imposizione di timeout di connessione possono ostacolare l'esecuzione di operazioni dannose, quali gli attacchi Denial of Service (DoS), sul server virtuale.
Nota:
La porta TCP utilizzata dal servizio SMTP per ricevere i messaggi in ingresso viene impostata quando si specifica il server virtuale SMTP (Simple Mail Transfer Protocol), durante la configurazione delle connessioni in ingresso. Per istruzioni sull'identificazione dei server virtuali SMTP, vedere Configurare il server virtuale SMTP.

Procedura

Per configurare le connessioni in ingresso

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Generale selezionare la casella di controllo Limita il numero di connessioni a e impostare le seguenti opzioni:

Opzione | Descrizione
Limita il numero di connessioni a | Quando la casella di controllo è selezionata, questa opzione consente di specificare il numero massimo di connessioni simultanee consentite per il recapito dei messaggi in ingresso. Il valore minimo è una connessione. Quando la casella di controllo non è selezionata, non viene imposto alcun limite. Per impostazione predefinita non è previsto alcun limite.
Timeout connessione (minuti) | Questa opzione consente di specificare quanto tempo deve trascorrere prima che una connessione inattiva venga interrotta. L'impostazione predefinita è 10 minuti.

Per configurare le connessioni in uscita

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Generale scegliere Connessioni esterne. Verrà visualizzata la finestra di dialogo Connessioni esterne.

  3. Nella sezione Connessioni esterne selezionare la casella di controllo e impostare le seguenti opzioni:

Opzione

Descrizione

Limita il numero di connessioni a

Quando la casella di controllo è selezionata, questa opzione consente di specificare il numero totale di connessioni in uscita verso tutti i domini remoti contemporaneamente esistenti. L'impostazione predefinita è 1000 connessioni. Il valore minimo è 1. Per impostazione predefinita non è previsto alcune limite.

Questa impostazione può essere utilizzata insieme all'opzione Limita numero di messaggi per connessione a della scheda Messaggi per migliorare le prestazioni del sistema. Per ulteriori informazioni e istruzioni sulla limitazione del numero di messaggi per connessione, vedere Limitazione del numero di messaggi per connessione.

Timeout (minuti)

Questa opzione consente di specificare quanto tempo deve trascorrere prima che una connessione inattiva venga interrotta. L'impostazione predefinita è 10 minuti.

Limita numero di connessioni per dominio a

Quando la casella di controllo è selezionata, questa opzione consente di specificare il numero massimo di connessioni consentite per un determinato dominio remoto. L'impostazione predefinita è 100 connessioni. Questo valore dovrà essere inferiore o uguale al valore impostato per l'opzione Limita il numero di connessioni a.

Porta TCP

Questa opzione consente di impostare la porta TCP utilizzata per le trasmissioni in uscita. La porta predefinita è la 25. L'impostazione della porta per le trasmissioni in uscita può essere uguale o diversa da quella delle trasmissioni in ingresso.

Per una panoramica dei processi coinvolti nell'invio dei messaggi, vedere Concetti relativi al server SMTP.


Abilitare la registrazione dei protocolli

Abilitare la registrazione dei protocolli
Server SMTP > Procedure relative al server SMTP >

I registri di protocollo tengono traccia dei comandi che il server virtuale SMTP (Simple Mail Transfer Protocol) riceve dai client SMTP tramite la rete. È possibile scegliere il formato di registro utilizzato dal servizio SMTP per la registrazione delle informazioni.

Quando si configura un file di registro, tenere presente che i formati e i nomi predefiniti sono uguali a quelli utilizzati da altri servizi di Internet Information Services (IIS). Se si utilizzano i nomi predefiniti, le transazioni di tutti i servizi verranno registrate nello stesso file. È invece possibile configurare un file distinto per ciascun servizio se si desidera avere registrazioni separate. Se per il file si specifica un percorso diverso da quello predefinito, assicurarsi che sia relativo a un'unità locale e non a una rete. Inoltre, dal momento che la registrazione viene condivisa con IIS, alcuni dei nomi non sono specifici di SMTP.

Importante:
Il controllo dell'attività del server con file di registro è un buon metodo per rilevare se utenti esterni non autorizzati stanno tentando di accedere al server virtuale o se utenti interni stanno tentando di accedere a risorse per le quali non dispongono di autorizzazioni appropriate. Per ulteriori informazioni sul controllo e sull'utilizzo del Visualizzatore eventi, vedere Events and Errors Message Center (informazioni in lingua inglese).

Per informazioni dettagliate sulla registrazione delle transazioni e i relativi formati, vedere Monitoraggio delle transazioni relative ai messaggi.

Procedura

Per abilitare la registrazione in formato testo ASCII

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Generale selezionare la casella di controllo Abilita registrazione.

  3. Selezionare un formato dall'elenco a discesa Formato registro attivo.

  4. Scegliere il pulsante Proprietà, quindi nella scheda Generale specificare la Nuova pianificazione registro.

    Selezionare Ogni ora, Ogni giorno, Ogni settimana oppure Ogni mese per creare un nuovo file di registro all'intervallo prescelto.

    Selezionare Dimensioni file illimitate per creare un unico file di registro.

    Selezionare Quando il file corrente raggiunge per specificare le dimensioni massime del file di registro e creare un nuovo file di registro quando il file corrente raggiunge tali dimensioni.

  5. Nella scheda Generale, in Directory file registro, specificare il percorso di memorizzazione dei file di registro.

  6. Se si è selezionato il formato di registro esteso W3C (World Wide Web Consortium), fare clic sulla scheda Avanzate, quindi selezionare le opzioni di registrazione estesa di cui si si desidera tenere traccia.

Per abilitare la registrazione in formato ODBC

  1. Configurare un database conforme allo standard ODBC. Per le istruzioni sulla configurazione di un database conforme allo standard ODBC, vedere Configurare un database conforme allo standard ODBC.

  2. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  3. Nella scheda Generale selezionare la casella di controllo Abilita registrazione.

  4. Selezionare Registrazione ODBC dall'elenco a discesa Formato registro attivo.

  5. Scegliere il pulsante Proprietà, quindi specificare la dimensione e il percorso del file di registro.


Configurare un server virtuale per il clustering

Configurare un server virtuale per il clustering
Server SMTP > Procedure relative al server SMTP >

Il clustering di failover è una funzionalità di Windows Server 2008 Enterprise operating system. Per ulteriori informazioni sull'installazione del clustering di failover, consultare la documentazione di Windows Server 2008 Enterprise.

Un cluster di server è un gruppo di computer indipendenti, noti come nodi, che interagiscono come se fossero un unico sistema per garantire ai client la disponibilità di risorse e applicazioni di importanza strategica. I cluster di server forniscono una disponibilità elevata. In un cluster di server SMTP (Simple Mail Transfer Protocol) ciò significa che se un server virtuale non funziona correttamente, il lavoro che quest'ultimo dovrebbe svolgere viene ridistribuito tra i restanti server virtuali, garantendo così la continuità del servizio di posta. Un altro vantaggio dei cluster di server è il failover delle risorse. Quando un server virtuale ha un problema, se ne attiva un altro che ne rileva automaticamente il carico di richieste.

Nel clustering un nodo è un sistema che dispone di un'installazione funzionante di Windows Server 2008 Enterprise e della funzionalità clustering di failover. Si consiglia di creare un nuovo server virtuale sul nodo per il clustering, invece di riconfigurare il server virtuale SMTP predefinito.

Per ulteriori informazioni sul clustering di failover e i cluster di server, vedere Guida e supporto tecnico. In tale documentazione sono contenute istruzioni dettagliate sulla configurazione e l'amministrazione dei cluster di server.

Procedura

Per configurare un server virtuale SMTP per il clustering

  1. Se necessario, modificare l'impostazione di avvio predefinita del servizio SMTP in Manuale. Per istruzioni su come modificare le impostazioni di avvio predefinite, vedere Modificare l'impostazione di avvio predefinita.

  2. Prima di creare un nuovo server virtuale, avviare Microsoft Management Console, quindi fare clic con il pulsante destro del mouse sul server virtuale SMTP predefinito e scegliere Proprietà. Per istruzioni sulle modalità di avvio di Microsoft Management Console, vedere Avviare Microsoft Management Console.

  3. Nella scheda Generale scegliere il pulsante Avanzate.

  4. Nella sezione Indirizzo IP fare clic su (Tutti non assegnati), quindi su Modifica.

  5. Nella finestra di dialogo Identificazione modificare l'impostazione predefinita (25) della porta TCP. È possibile specificare il numero di qualsiasi porta non assegnata. È importante cambiare il numero della porta per evitare conflitti con il nuovo server virtuale SMTP che verrà creato per il clustering. Digitare il nuovo numero di porta assicurandosi che sia univoco, quindi scegliere OK.

  6. Creare un nuovo server virtuale SMTP. Per istruzioni, vedere Creazione di server virtuali SMTP aggiuntivi. Una volta creato il server, sarà necessario avviarlo manualmente. Per il nuovo server virtuale assicurarsi di utilizzare la porta TCP predefinita, ovvero la porta 25.

    Importante:
    Quando si accede alla schermata Selezione della home directory della Configurazione guidata del nuovo server virtuale SMTP, specificare i percorsi relativi alle risorse condivise che verranno utilizzate per il clustering. Non specificare percorsi relativi a un disco rigido locale.

  7. Eseguire il comando di sincronizzazione IIS per sincronizzare tutte le informazioni IIS sul nodo con gli altri nodi del cluster di server. Al prompt dei comandi passare alla directory \Windows\System32\Inetsrv del nodo e digitare iissync nomeserver, dove nomeserver è un altro nodo del cluster di server. Per ulteriori informazioni sul comando di sincronizzazione IIS, consultare la documentazione di IIS.

  8. Una volta sincronizzati i nodi del cluster di server, potrebbe essere comunque necessario verificare i numeri della porta TCP del nuovo server virtuale SMTP oltre che del server virtuale predefinito. Più in particolare, quando si visualizza il nodo locale da altri nodi del cluster di server, assicurarsi che le impostazioni della porta TCP siano identiche a quelle specificate nel nodo locale. In tutti i nodi, il server virtuale SMTP predefinito non dovrebbe più puntare alla porta predefinita (25), mentre al nuovo server virtuale SMTP dovrebbe essere assegnata proprio quella porta. Le impostazioni devono essere le stesse su tutti i nodi perché il clustering funzioni correttamente.

  9. Avviare Gestione cluster di failover. Seguire le istruzioni visualizzate e associare un tipo di risorsa al nuovo server virtuale SMTP.

    Nota:
    Nella finestra di dialogo Parametri selezionare dal menu a discesa il nuovo server virtuale SMTP e non il server virtuale SMTP predefinito. Per ulteriori informazioni su Gestione cluster di failover, vedere Guida e supporto tecnico.


Impostare le opzioni di protezione

Impostare le opzioni di protezione
Server SMTP > Procedure relative al server SMTP >

In questa sezione vengono descritte le opzioni di protezione disponibili per il server virtuale SMTP:

  • Informazioni sulle impostazioni di protezione

  • Impostazione delle autorizzazioni di operatore

  • Richiesta dell'autenticazione per le connessioni in ingresso

  • Configurazione dell'autenticazione per i messaggi in uscita

  • Richiesta della crittografia TLS

  • Impostazione delle limitazioni per l'accesso IP al server

  • Impostazione o rimozione delle limitazioni per l'inoltro della posta da un server virtuale


Informazioni sulle impostazioni di protezione

Informazioni sulle impostazioni di protezione
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

È possibile scegliere il livello di protezione del server virtuale SMTP (Simple Mail Transfer Protocol) utilizzando le opzioni disponibili in due apposite schede. Le impostazioni effettuate in tali schede vengono applicate a tutti i domini del server virtuale.

Impostazioni di protezione

Scheda | Impostazioni
Protezione | Questa scheda consente di impostare gli account utente aventi le autorizzazioni di operatore per eseguire il servizio SMTP. Gli operatori possono configurare le proprietà del server virtuale SMTP.
Accesso | In questa scheda sono contenute le impostazioni per richiedere l'autorizzazione e l'utilizzo della crittografia TLS (Transport Layer Security) per tutte le connessioni in ingresso. È anche possibile concedere o negare l'accesso a determinati computer o reti.


Impostazione delle autorizzazioni di operatore

Impostazione delle autorizzazioni di operatore
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

È possibile impostare quali account utente possono avere le autorizzazioni di operatore per il server virtuale SMTP (Simple Mail Transfer Protocol). Dopo aver configurato gli account utente di Windows, è possibile concedere le autorizzazioni selezionando l'account desiderato da un elenco. Tali autorizzazioni possono essere revocate rimuovendo l'account dall'elenco di operatori del server virtuale.

Procedura

Per assegnare le autorizzazioni di operatore

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Protezione scegliere il pulsante Aggiungi. Verrà visualizzata la finestra di dialogo Seleziona utenti o gruppi.

  3. Digitare il nome di un account utente di Windows nella casella Immettere i nomi degli oggetti da selezionare, scegliere Controlla nomi, quindi OK. L'account selezionato verrà visualizzato nella casella Operatori.

È anche possibile rimuovere le autorizzazioni di operatore per gli account utente di Windows elencati nella casella Operatori.

Per rimuovere le autorizzazioni di operatore

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Protezione fare clic sull'operatore che si desidera rimuovere.

  3. Scegliere Rimuovi.


Richiesta dell'autenticazione per le connessioni in ingresso

Richiesta dell'autenticazione per le connessioni in ingresso
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

Sono disponibili tre metodi di autenticazione. È possibile sceglierne uno, due o tutti e tre. Per impostazione predefinita è abilitato solo l'accesso anonimo, in modo da impedire a chiunque di utilizzare il server virtuale SMTP (Simple Mail Transfer Protocol) per inoltrare la posta. Per ulteriori informazioni, vedere Impostazione o rimozione delle limitazioni per l'inoltro della posta da un server virtuale.

Le impostazioni predefinite per l'inoltro della posta sul server virtuale SMTP consentono di inoltrare la posta proveniente solo da utenti autenticati. Affinché gli utenti di un'organizzazione possano inviare posta tramite il server virtuale, gli utenti devono prima autenticarsi. Scegliendo uno dei metodi presenti nella finestra di dialogo Autenticazione, gli utenti dell'organizzazione saranno in grado di inviare messaggi, mentre gli utenti non autorizzati non potranno utilizzare il server virtuale per inoltrare la posta.

Opzione di autenticazione | Descrizione
Accesso anonimo | Non è necessario specificare un nome di account o una password.
Autenticazione di base | Il nome dell'account e la password vengono inviati come testo non crittografato. Specificare il dominio di Windows da aggiungere al nome dell'account per l'autenticazione. Per impedire un rilevamento non autorizzato di nomi utente e password durante la trasmissione, si consiglia di richiedere la crittografia TLS (Transport Layer Security) con l'autenticazione di base.
Autenticazione integrata di Windows | Utilizzando questa opzione vengono autenticati un nome di account e una password di Windows.

Procedura

Per disabilitare l'autenticazione per i messaggi in ingresso

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella sezione Controllo accesso della scheda Accesso scegliere il pulsante Autenticazione. Verrà visualizzata la finestra di dialogo Autenticazione.

  3. Selezionare la casella di controllo Accesso anonimo, quindi deselezionare le restanti caselle di controllo relative alle altre opzioni.

Per impostare l'autenticazione con testo non crittografato per i messaggi in ingresso

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella sezione Controllo accesso della scheda Accesso scegliere il pulsante Autenticazione. Verrà visualizzata la finestra di dialogo Autenticazione.

  3. Selezionare Autenticazione di base.

  4. Nella casella di testo Dominio predefinito digitare un nome di dominio di Windows. Tale dominio predefinito è diverso da quello del server virtuale SMTP.

Per utilizzare l'autenticazione integrata di Windows per autenticare i messaggi in ingresso

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella sezione Controllo accesso della scheda Accesso scegliere il pulsante Autenticazione. Verrà visualizzata la finestra di dialogo Autenticazione.

  3. Selezionare Autenticazione integrata di Windows.


Configurazione dell'autenticazione per i messaggi in uscita

Configurazione dell'autenticazione per i messaggi in uscita
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

È possibile configurare il server virtuale SMTP (Simple Mail Transfer Protocol) per la presentazione delle credenziali di autenticazione richieste da un server ricevente. Sono disponibili tre tipi di autenticazione: accesso anonimo, autenticazione di base (testo non crittografato) e Autenticazione integrata di Windows. L'accesso anonimo non richiede nome utente o password. Con l'opzione Autenticazione di base, il nome dell'account e la password del server a cui ci si connette vengono trasmessi come testo non crittografato. Con l'opzione Autenticazione integrata di Windows è necessario specificare un nome di account e una password di Windows.

L'opzione Protezione recapito esterno configurata per il server virtuale SMTP può essere ignorata per un determinato dominio remoto. Ciò consente di impostare il livello di autenticazione del server virtuale in modo che sia possibile gestire la maggior parte delle trasmissioni, pur consentendo delle eccezioni per singoli indirizzi. Nella tabella che segue sono riportati alcuni esempi di configurazione.

Nota:
Per ulteriori informazioni sulla crittografia dei messaggi in uscita, vedere Richiesta della crittografia TLS.

Trasmissioni SMTP | Opzione di autenticazione
Messaggi inviati in genere a più indirizzi. | Disattivare l'autenticazione per il server virtuale SMTP. Se i tentativi di recapito dei messaggi a uno spazio degli indirizzi non hanno esito positivo a causa dei requisiti di autenticazione, creare una voce di dominio remoto per lo spazio. Attivare quindi per il dominio remoto lo stesso livello di autenticazione richiesto dal server ricevente.
Messaggi inviati in genere a un indirizzo che richiede l'autenticazione. | Determinare quale livello di autenticazione è necessario per la connessione. Attivare quindi lo stesso livello di autenticazione per il server virtuale SMTP. Se in seguito si desidera inviare messaggi ad altri indirizzi, configurare dei domini remoti e impostare opzioni di autenticazione differenti. In questo caso, il nome account utilizzato sarà probabilmente quello che identifica il computer impostato come SmartHost.

Procedura

Per disattivare l'autenticazione per i messaggi in uscita

  1. Nella scheda Recapito scegliere il pulsante Protezione. Verrà visualizzata la finestra di dialogo Protezione recapito esterno.

  2. Scegliere Accesso anonimo.

  3. Deselezionare tutte le altre opzioni.

Per impostare l'autenticazione di base per i messaggi in uscita

  1. Nella scheda Recapito scegliere il pulsante Protezione. Verrà visualizzata la finestra di dialogo Protezione recapito esterno.

  2. Scegliere Autenticazione di base.

  3. Nelle caselle Nome utente e Password digitare il nome dell'account e la password che forniscono accesso al computer a cui ci si connette.
Importante:
Se l'autenticazione di base è l'unico metodo di autenticazione utilizzato, si consiglia di richiedere la crittografia TLS per impedire il rilevamento non autorizzato di nomi utente e password.

Per impostare l'Autenticazione integrata di Windows per i messaggi in uscita

  1. Nella scheda Recapito scegliere il pulsante Protezione. Verrà visualizzata la finestra di dialogo Protezione recapito esterno.

  2. Scegliere Autenticazione integrata di Windows.

  3. Nelle caselle Account e Password digitare il nome account e la password di Windows che forniscono accesso al computer a cui ci si connette.


Richiesta della crittografia TLS

Richiesta della crittografia TLS
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

È possibile impostare tutti i client in modo che venga utilizzata la crittografia TLS (Transport Layer Security), un protocollo di protezione generico simile a SSL (Secure Sockets Layer), per la connessione a un server virtuale SMTP (Simple Mail Transfer Protocol). Questa opzione consente di proteggere la connessione, ma non viene utilizzata per l'autenticazione.

Importante:
Quando si richiede l'autenticazione di base sui server virtuali, si consiglia di utilizzare anche la crittografia TLS. Senza crittografia, i nomi utente e le password possono essere intercettati facilmente.

Per utilizzare la crittografia TLS per il server virtuale SMTP, nell'archivio certificati attendibili deve essere presente un certificato valido per il computer Windows Server 2008 che esegue il server SMTP. Tale certificato deve essere rilasciato al nome di dominio completo (FQDN) per il computer. I certificati rilasciati a un indirizzo IP o a un nome host non possono essere utilizzati per fornire la crittografia TLS per le comunicazioni del server SMTP. Per impostazione predefinita, l'autorità di certificazione di Windows emette un certificato che utilizza la crittografia a 128 bit. I client che si connettono devono essere in grado supportare la crittografia a 128 bit, altrimenti i messaggi verranno restituiti al mittente con un rapporto di mancato recapito (NDR).

La procedura seguente consente di abilitare la crittografia TLS per tutte le sessioni client con il server virtuale SMTP e per tutte le sessioni con i server remoti.

Procedura

Per richiedere la crittografia TLS per tutte le comunicazioni con il server virtuale SMTP

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella casella di gruppo Comunicazione protetta della scheda Accesso selezionare la casella di controllo Richiedi crittografia TLS.
Nota:
Sono disponibili due opzioni TLS aggiuntive. Per utilizzare la crittografia TLS per tutte le connessioni in uscita, nella scheda Recapito fare clic su Protezione posta in uscita, quindi selezionare Crittografia TLS. Inoltre, se un server a cui ci si connette spesso richiede l'utilizzo di TLS per tutte le connessioni in ingresso, è possibile creare un dominio remoto. Fare clic su Protezione posta in uscita nella scheda Generale delle proprietà del dominio remoto, quindi selezionare Crittografia TLS.


Installazione di un certificato del server per la crittografia TLS

Installazione di un certificato del server per la crittografia TLS
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

In questo argomento viene descritto come installare un certificato del server per fornire la crittografia TLS (Transport Layer Security) per il Windows Server 2008 server SMTP. È possibile richiedere che tutti i client utilizzino la crittografia TLS per la connessione a un server virtuale SMTP (Simple Mail Transfer Protocol). TLS è un protocollo che fornisce riservatezza e protezione alle comunicazioni tra due applicazioni che comunicano su una rete. TLS crittografa le comunicazioni e consente ai client di autenticare i server e, in via facoltativa, viceversa. TLS rappresenta la versione più protetta del protocollo SSL (Secure Sockets Layer).

Per utilizzare la crittografia TLS per il server virtuale SMTP, nell'archivio certificati attendibili deve essere presente un certificato valido per il computer Windows Server 2008 che esegue il server SMTP. Tale certificato deve essere rilasciato al nome di dominio completo (FQDN) per il computer. I certificati rilasciati a un indirizzo IP o a un nome host non possono essere utilizzati per fornire la crittografia TLS per le comunicazioni del server SMTP. Per impostazione predefinita, l'autorità di certificazione di Windows (CA) emette un certificato che utilizza la crittografia a 128 bit. I client che si connettono devono essere in grado supportare la crittografia a 128 bit; in caso contrario, i messaggi verranno restituiti al mittente con un rapporto di mancato recapito (NDR).

Per installare un certificato del server, eseguire una delle procedure riportate di seguito. Se si dispone di una CA in linea come, ad esempio, una CA globale (enterprise) Windows Server 2008, il certificato verrà emesso immediatamente. Se si dispone di una CA non in linea come, ad esempio, una CA autonoma Windows Server 2008 o una CA di terze parti, è necessario richiedere il certificato, quindi installare il file del certificato. È possibile creare un certificato autofirmato per SMTP su transazioni TLS nel caso in cui il server con cui si sta comunicando non richieda la verifica della CA. Se è richiesta la verifica della CA, l'uso di un certificato autofirmato provocherà la mancata riuscita della negoziazione TLS.

Procedura

Per richiedere e installare un certificato del server allo scopo di fornire la crittografia TLS a tutte le comunicazioni fra server virtuali SMTP quando si dispone di una CA in linea

  1. Fare clic su Start, Esegui, quindi digitare MMC nel campo di testo Apri e premere INVIO. Viene visualizzata una Microsoft Management Console (MMC) predefinita.

  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.

  3. Dal menu Snap-in disponibili, scegliere Certificati, quindi fare clic su Aggiungi>. Nella finestra di dialogo Snap-in certificati, selezionare Account del computer, quindi scegliere Fine. Scegliere OK.

  4. Espandere Certificati (computer locale). Selezionare Personale. Fare clic con il pulsante destro del mouse, quindi selezionare Tutte le attività e Richiedi nuovo certificato. Viene avviata la procedura guidata di Registrazione certificato.

  5. Nella pagina Prima di iniziare, fare clic su Avanti.

  6. Nella pagina Richiedi certificati, selezionare la casella accanto a Computer. Fare clic sull'icona con le doppie virgolette acute a fianco a Dettagli, quindi selezionare Proprietà.

  7. Nella scheda Generale, digitare un nome descrittivo e una descrizione per il certificato.

  8. Nella sezione Nome soggetto della scheda Soggetto, selezionare Nome comune dal menu a discesa Tipo. Nel campo Valore, digitare il FQDN del server. Scegliere il pulsante Aggiungi>. Nella sezione Nome alternativo, selezionare DNS dal menu a discesa Tipo. Nel campo Valore, digitare il FQDN del server. Scegliere il pulsante Aggiungi>.

  9. Nella scheda Estensioni, fare clic sull'icona con le doppie virgolette acute a fianco a Utilizzo chiave esteso (criteri di applicazione). Accertarsi che sia selezionata l'opzione Autenticazione server.

  10. Nella scheda Autorità di certificazione, selezionare la CA che emetterà il certificato.

  11. Fare clic su OK per salvare le modifiche e chiudere la finestra Proprietà certificato.

  12. Nella finestra di dialogo Richiedi certificati, fare clic su Registrazione. Fare clic su Fine per chiudere la procedura guidata di Registrazione certificato.

Per richiedere e installare un certificato del server allo scopo di fornire la crittografia TLS a tutte le comunicazioni fra server virtuali SMTP quando si dispone di una CA non in linea

  1. Fare clic su Start, Strumenti di amministrazione, quindi aprire Gestione IIS 7.0 selezionando Gestione Internet Information Services (IIS).

  2. Selezionare il nodo server.

  3. Selezionare Certificati server nel riquadro Caratteristiche. Selezionare Apri funzionalità nel riquadro Azioni.

  4. Nel riquadro Azioni, selezionare Crea richiesta di certificato. Viene avviata la procedura guidata di Creazione richiesta.

  5. Completare tutti i campi nella pagina Proprietà nome distinto, quindi fare clic su Avanti.

  6. Nella pagina Proprietà provider servizio di crittografia, accertarsi che sia selezionato il provider del servizio di crittografia Microsoft RSA SChannel Cryptographic Service Provider e che il valore della Lunghezza in bit sia impostato su 1024. Scegliere Avanti.

  7. Nella pagina Nome file, individuare il percorso in cui si desidera salvare il file, quindi specificare un nome per il file. L'estensione del file sarà .txt. Fare clic su Fine.

  8. Inviare il file alla CA in uso. Una volta che l'amministratore avrà emesso il certificato, verrà inviato un file con estensione .cer.

  9. In Gestione IIS Manager, selezionare il nodo del server. Selezionare Certificati server nel riquadro Caratteristiche. Nel riquadro Azioni, selezionare Completa richiesta di certificato.

  10. Nella pagina Specifica risposta autorità di certificazione, digitare il percorso il nome del file *.cer oppure passare al percorso del file, selezionarlo e fare clic su Apri. Fare clic su OK per installare il certificato.

Per creare e installare un certificato del server autofirmato per fornire la crittografia TLS alle comunicazioni del server virtuale SMTP

  1. Fare clic su Start, Esegui, quindi digitare cmd nel campo di testo Apri e premere INVIO. Viene aperta una finestra della shell di comandi .

  2. Digitare il seguente comando e premere INVIO.

    Copia codice
    makecert -r -pe -n "CN=ServerName" -sky exchange -ss my -sr LocalMachine
    Nota:
    Per ulteriori informazioni sul programma makecert.exe, digitare makecert -? al prompt dei comandi per visualizzare le opzioni di base, oppure digitare makecert -! per visualizzare le opzioni estese..

Per verificare che il certificato sia installato correttamente e riconosciuto del server virtuale SMTP

  1. Fare clic su Start, Strumenti di amministrazione, quindi aprire Gestione IIS 6.0 selezionando Gestione Internet Information Services (IIS) 6.0.

  2. Selezionare un server virtuale SMTP, fare clic con il pulsante destro del mouse, quindi selezionare Proprietà.

  3. Nelle proprietà del server virtuale SMTP, selezionare la scheda Accesso. Se il certificato è installato correttamente, nella sezione Comunicazioni protette verrà visualizzato il messaggio Rilevato certificato TLS con scadenza: DD/MM/YYYY e la casella di controllo Richiedi crittografia TLS è disponibile.


Impostazione delle limitazioni per l'accesso IP al server

Impostazione delle limitazioni per l'accesso IP al server
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

È possibile concedere o negare a determinati indirizzi IP l'accesso al server virtuale SMTP (Simple Mail Transfer Protocol). Per impostazione predefinita, al server virtuale SMTP possono accedere tutti gli indirizzi IP. Per impostare restrizioni, specificare un singolo indirizzo IP, un gruppo di indirizzi tramite una subnet mask o un nome di dominio.

Procedura

Per impostare restrizioni di accesso per determinati indirizzi IP

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella sezione Controllo connessione della scheda Accesso scegliere il pulsante Connessione. Verrà visualizzata la finestra di dialogo Connessione.

  3. Selezionare il pulsante di opzione Solo i computer indicati nell'elenco o Tutti tranne quelli indicati nell'elenco.

  4. Per aggiungere un computer all'elenco, scegliere il pulsante Aggiungi. Verrà visualizzata la finestra di dialogo Computer.

    Per specificare un singolo indirizzo IP, scegliere Computer singolo e immettere un indirizzo IP.

    Per specificare un gruppo di indirizzi, scegliere Gruppo di computer e immettere un indirizzo subnet e la subnet mask.

    Per specificare un dominio, scegliere Dominio e immettere il nome del dominio. Scegliere OK.

  5. Per eliminare un computer dall'elenco, selezionarlo e scegliere Rimuovi.


Impostazione o rimozione delle limitazioni per l'inoltro della posta da un server virtuale

Impostazione o rimozione delle limitazioni per l'inoltro della posta da un server virtuale
Server SMTP > Procedure relative al server SMTP > Impostare le opzioni di protezione >

Per impostazione predefinita, il server SMTP impedisce ai computer di inoltrare la posta indesiderata tramite il server virtuale. Per attivare l'inoltro tramite il server virtuale SMTP (Simple Mail Transfer Protocol), nella scheda Accesso scegliere il pulsante Inoltro. Per impostazione predefinita, l'inoltro viene impedito a tutti i computer tranne a quelli che soddisfano i requisiti di autenticazione impostati nella finestra di dialogo Autenticazione, a cui si accede scegliendo il pulsante Autenticazione nella scheda Accesso.

È anche possibile consentire l'inoltro dei messaggi a un determinato dominio remoto. Per ulteriori informazioni, vedere Configurare domini remoti. L'impostazione del dominio ha la priorità sull'impostazione del server virtuale SMTP.

Nota:
Se il server virtuale è su Internet, non consentire l'inoltro della posta al fine di evitare la propagazione di messaggi indesiderati.

Procedura

Per rimuovere le limitazioni per l'inoltro della posta da un server virtuale

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella sezione Limitazioni inoltro della scheda Accesso scegliere il pulsante Inoltro. Verrà visualizzata la finestra di dialogo Limitazioni inoltro.

  3. Selezionare il pulsante di opzione Solo i computer indicati nell'elenco o Tutti tranne quelli indicati nell'elenco.

  4. Scegliere il pulsante Aggiungi per visualizzare la finestra di dialogo Computer e aggiungere le eccezioni all'opzione di accesso globale selezionata al passaggio 3.

Nella finestra di dialogo Limitazioni inoltro è possibile impostare le seguenti opzioni:

Opzione | Descrizione
Solo i computer indicati nell'elenco | Solo i computer elencati possono inoltrare i messaggi tramite il server virtuale SMTP. Questa è l'impostazione predefinita, insieme a Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sopra. Poiché in seguito a una nuova installazione di Windows Server 2008 l'elenco è vuoto, solo gli utenti autenticati possono inoltrare la posta per impostazione predefinita.
Tutti tranne quelli indicati nell'elenco | Tutti i computer possono inoltrare i messaggi tramite il server virtuale SMTP, tranne quelli presenti nell'elenco.
Aggiungi e Rimuovi | Questa opzione consente di aggiungere e rimuovere voci dall'elenco dei computer a cui è stata concessa o negata l'autorizzazione per l'inoltro dei messaggi.
Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sopra | Consente ai computer che soddisfano i requisiti di autenticazione impostati nella finestra di dialogo Autenticazione di inoltrare i messaggi al server virtuale SMTP. Questa è l'impostazione predefinita.


Gestire i messaggi

Gestire i messaggi
Server SMTP > Procedure relative al server SMTP >

In questa sezione viene spiegato come impostare limiti per la connessione in modo da ottimizzare le prestazioni, come impostare limiti per la dimensione dei messaggi e il numero dei destinatari e infine come gestire i messaggi non recapitabili. Nella sezione sono inclusi i seguenti argomenti:

  • Limitazione del numero di messaggi per connessione

  • Impostazione dei limiti per le dimensioni dei messaggi

  • Impostazione del numero massimo di destinatari

  • Memorizzazione dei rapporti NDR


Limitazione del numero di messaggi per connessione

Limitazione del numero di messaggi per connessione
Server SMTP > Procedure relative al server SMTP > Gestire i messaggi >

È possibile limitare il numero di messaggi inviati nel corso di un'unica connessione. Questa opzione permette di migliorare le prestazioni del sistema consentendo l'utilizzo di più connessioni per il recapito dei messaggi a un dominio remoto. Una volta raggiunto il limite impostato, viene aperta automaticamente una nuova connessione e la trasmissione continua finché tutti i messaggi non sono stati recapitati.

Se ad esempio si invia in genere un elevato numero di messaggi ad alcuni domini remoti, è possibile impostare l'opzione Limita numero di messaggi per connessione a su un valore relativamente basso, ad esempio 20. In questo modo, per inviare 100 messaggi in una sessione, il servizio SMTP attiva immediatamente una nuova connessione dopo l'invio dei primi 20 messaggi, quindi un'altra dopo i successivi 20 e così via. Per questo esempio, vi potrebbero essere fino a 5 connessioni simultanee per il recapito a un'unica destinazione dei messaggi in coda. Il processo sarà più rapido perché solo pochi messaggi vengono recapitati contemporaneamente, invece di un lungo flusso di messaggi in una sola connessione.

Per determinare un valore per il limite, controllare il contatore delle prestazioni Messaggi inviati al secondo per l'oggetto Server SMTP in Monitor di sistema. Il valore specificato per l'opzione Limita numero di messaggi per connessione a deve essere inferiore al valore indicato dal contatore delle prestazioni. Se il contatore indica 30 e si imposta 50 come numero massimo di messaggi, non verrà attivata alcuna connessione simultanea perché il server non può inviare più di 30 messaggi al secondo. In questo caso, i messaggi verranno tutti recapitati nell'ambito di un'unica connessione. Questa impostazione ha effetto solo sui messaggi in uscita. Può pertanto essere utilizzata per aumentare la velocità di output del server, ma non incide in alcun modo sulla velocità con cui gli altri server elaborano i messaggi in ingresso.

Procedura

Per limitare il numero di messaggi inviati in una connessione

  1. In Microsoft Management Console selezionare il server virtuale SMTP (Simple Mail Transfer Protocol) desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Messaggi selezionare la casella di controllo Limita numero di messaggi per connessione a, quindi digitare un valore. Il valore predefinito è 20.


Impostazione dei limiti per le dimensioni dei messaggi

Impostazione dei limiti per le dimensioni dei messaggi
Server SMTP > Procedure relative al server SMTP > Gestire i messaggi >

Le impostazioni per limitare la dimensione dei messaggi sono due.

  • Limita dimensione messaggi a Impostazione preferita per il limite dei messaggi per il server virtuale. Il servizio SMTP segnala tale valore come dimensione massima dei messaggi accettata dal server virtuale SMTP (Simple Mail Transfer Protocol). Se un client di posta invia un messaggio che supera tale limite, verrà visualizzato un errore. Se un server remoto supporta il comando EHLO, rileverà il valore impostato come dimensione massima al momento della connessione al server virtuale SMTP e non tenterà di recapitare un messaggio che superi tale limite. Invierà invece solo un rapporto di mancato recapito (NDR) al mittente. Un server remoto che non supporta EHLO tenterà di inviare un messaggio che supera il limite di dimensione, ma invierà comunque un rapporto di mancato recapito al mittente quando il messaggio non riesce a passare.

  • Limita dimensione sessione a Consente di definire la quantità massima di dati accettati durante l'intera connessione, ossia la somma di tutti i messaggi inviati durante la connessione, considerando solo il corpo del testo.

Procedura

Per impostare i limiti per le dimensioni dei messaggi

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Messaggi selezionare la casella di controllo Limita dimensione messaggi a (KB), quindi digitare un valore in kilobyte per indicare la dimensione massima di un messaggio. Il valore predefinito è 2.048 KB. Il valore minimo consentito è 1 KB.

  3. Nella scheda Messaggi selezionare la casella di controllo Limita dimensione sessione a (KB), quindi digitare un valore in kilobyte per indicare la dimensione massima di tutti i messaggi che è possibile inviare durante una determinata connessione. Questo valore sarà sempre superiore alla dimensione massima dei messaggi e dovrà essere impostato con attenzione, dal momento che l'Agente di trasferimento messaggi (MTA) potrebbe dover inoltrare il messaggio più volte. La dimensione predefinita è 10.240 KB. Tale valore dovrebbe essere pari o superiore al valore di Limita dimensione messaggi a (KB).


Impostazione del numero massimo di destinatari

Impostazione del numero massimo di destinatari
Server SMTP > Procedure relative al server SMTP > Gestire i messaggi >

È possibile impostare il numero massimo di destinatari per i singoli messaggi inviati durante una connessione. Il valore predefinito è 100, ossia il numero minimo specificato nella Request For Comments (RFC) 821. Molti client restituiscono i messaggi con un rapporto di mancato recapito (NDR) quando ricevono un messaggio di errore. Ciò indica che il numero massimo di destinatari è stato superato. In questo caso il servizio SMTP (Simple Mail Transfer Protocol) non restituisce i messaggi. Apre immediatamente una nuova connessione ed elabora i destinatari rimanenti. Se ad esempio il limite dei destinatari è impostato su 100 e il servizio riceve un messaggio con 105 destinatari, i primi 100 verranno recapitati in una connessione. Viene quindi aperta una nuova connessione e il messaggio viene elaborato per i cinque destinatari rimanenti.

Procedura

Per impostare il numero massimo di destinatari

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella casella Limita numero di destinatari per messaggio a della scheda Messaggi digitare il valore desiderato. Per non impostare alcun limite, deselezionare la casella di controllo.


Memorizzazione dei rapporti NDR

Memorizzazione dei rapporti NDR
Server SMTP > Procedure relative al server SMTP > Gestire i messaggi >

Quando un messaggio non è recapitabile, il servizio SMTP lo restituisce al mittente con un rapporto di mancato recapito (NDR, Non-Delivery Report). Se lo si desidera, è anche possibile specificare il percorso a cui devono essere inviate le copie dei rapporti di mancato recapito. Se il rapporto NDR non può essere recapitato al mittente, una copia del messaggio viene inserita nella directory della posta scartata (Badmail).

Tutti i rapporti di mancato recapito vengono sottoposti allo stesso processo di recapito degli altri messaggi, inclusi i tentativi di reinvio. Se il rapporto NDR raggiunge il limite di reinvio e non può essere recapitato al mittente, una copia del messaggio viene inserita nella directory della posta scartata (Badmail). I messaggi inseriti nella directory della posta scartata non possono essere recapitati né restituiti.

Procedura

Per impostare un percorso di archiviazione per i rapporti di mancato recapito

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Messaggi, in Invia una copia del rapporto sul mancato recapito a digitare l'indirizzo di posta elettronica della cassetta postale in cui si desidera archiviare le copie dei rapporti di mancato recapito. Può trattarsi di un qualsiasi indirizzo di posta elettronica SMTP valido ed è opzionale. Per disabilitare la funzionalità, deselezionare la casella di controllo.

  3. Nella casella Directory della posta scartata digitare la directory in cui si desidera archiviare i messaggi non recapitabili. Il percorso predefinito è directory principale:\inetpub\mailroot\Badmail. Scegliere il pulsante Sfoglia per selezionare una cartella diversa. È possibile impostare qualunque directory, purché si trovi nello stesso computer del servizio SMTP.


Recapitare i messaggi

Recapitare i messaggi
Server SMTP > Procedure relative al server SMTP >

Una volta aperta una connessione, quando il server di destinazione ha comunicato di essere pronto alla ricezione dei dati, è possibile trasmettere i messaggi da recapitare. In questa sezione vengono descritte le impostazioni che determinano in che modo avviene il recapito, incluse le opzioni di routing e il numero di tentativi. Nella sezione sono inclusi i seguenti argomenti:

  • Informazioni sulle opzioni per il recapito dei messaggi

  • Configurazione dei tentativi e dei relativi intervalli

  • Impostazione del numero massimo di hop

  • Impostazione del dominio di mascheramento

  • Impostazione di un nome di dominio completo

  • Configurazione di uno SmartHost

  • Abilitazione della ricerca DNS inversa


Informazioni sulle opzioni per il recapito dei messaggi

Informazioni sulle opzioni per il recapito dei messaggi
Server SMTP > Procedure relative al server SMTP > Recapitare i messaggi >

Utilizzare la scheda Recapito per impostare tutte le opzioni per il recapito e il routing. Le impostazioni possono essere raggruppate nelle seguenti categorie:

Opzioni di routing

Sono disponibili le seguenti opzioni di routing:

  • SmartHost Consente di impostare il server tramite il quale effettuare il routing di tutti i messaggi in uscita.

  • Numero massimo di passaggi (hop) Consente di impostare il numero massimo di server tramite i quali può essere effettuato il routing di un messaggio prima che quest'ultimo venga considerato non recapitabile.

  • Nome dominio completo Consente di impostare l'indirizzo da utilizzare nei record MX (Message Exchanger).

Opzioni di trasmissione

Sono disponibili le seguenti opzioni di trasmissione:

  • Intervallo tentativi Consente di impostare per quante volte, e con quale frequenza, deve essere rinviato un messaggio prima che questo venga considerato non recapitabile.

  • Notifica di ritardo Determina l'intervallo di attesa prima dell'invio di una notifica del ritardo al mittente del messaggio.

  • Timeout scadenza Determina l'intervallo durante il quale il servizio SMTP continuerà a tentare il recapito di un messaggio prima che questo venga considerato non recapitabile.

Opzioni di protezione

Sono disponibili le seguenti opzioni di protezione:

  • Protezione recapito esterno Consente di utilizzare l'autenticazione e la crittografia TLS (Transport Layer Security) per i messaggi in uscita.

  • Ricerca DNS al contrario Consente di verificare se il messaggio proviene realmente dal computer e dal dominio specificati nel campo From.

  • Dominio di mascheramento Consente di sostituire qualsiasi nome di dominio locale utilizzato nelle righe Mail From del protocollo con un nome di dominio diverso. Si tratta del nome con cui si desidera contrassegnare i messaggi in uscita.


Configurazione dei tentativi e dei relativi intervalli

Configurazione dei tentativi e dei relativi intervalli
Server SMTP > Procedure relative al server SMTP > Recapitare i messaggi >

Se un messaggio non può essere recapitato al primo tentativo, il servizio SMTP (Simple Mail Transfer Protocol) provvede a inviarlo nuovamente dalla directory della coda dopo un determinato intervallo di tempo. È infatti possibile impostare l'intervallo tra i tentativi di recapito. I tentativi di recapito proseguiranno a intervalli specificati dall'utente fino al raggiungimento del timeout di scadenza. Quando tale limite viene raggiunto, il messaggio viene restituito al mittente con un rapporto di mancato recapito (NDR), mentre una copia del messaggio e una copia del rapporto vengono memorizzate nel percorso indicato. Il rapporto di mancato recapito viene inserito nella directory della coda e segue lo stesso processo di recapito dei messaggi. Quando per il rapporto di mancato recapito viene raggiunto il numero massimo di tentativi, il rapporto viene inviato insieme al corrispondente messaggio alla directory della posta scartata.

Procedura

Per configurare le impostazioni per i tentativi di recapito e i relativi intervalli

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Fare clic sulla scheda Recapito.

  3. Nella casella Intervallo primo tentativo (min.) digitare un valore corrispondente all'intervallo di attesa dopo il quale tentare nuovamente di recapitare il messaggio. L'impostazione predefinita è 15 minuti.

  4. Nella casella Intervallo tra primo e secondo tentativo (min.) digitare un valore corrispondente all'intervallo di attesa dopo il quale tentare nuovamente di recapitare il messaggio. L'impostazione predefinita è 30 minuti, ossia 30 minuti dopo l'intervallo immesso in Intervallo primo tentativo (min.).

  5. Nella casella Intervallo tra secondo e terzo tentativo (min.) digitare un valore corrispondente all'intervallo di attesa dopo il quale tentare nuovamente di recapitare il messaggio. L'impostazione predefinita è 60 minuti, ossia 60 minuti dopo l'intervallo immesso in Intervallo tra primo e secondo tentativo (min.).

  6. Nella casella Intervallo tra tentativi successivi (min.) digitare un valore corrispondente all'intervallo di attesa tra tentativi di recapito successivi. L'impostazione predefinita è 240 minuti.

Notifica di ritardo

Poiché generalmente si verificano dei ritardi sulla rete, è possibile impostare un periodo di ritardo, scaduto il quale verrà inviata una notifica sullo stato del recapito (DSN, Delivery Status Notification) al mittente del messaggio. Se il messaggio non viene recapitato entro l'intervallo di timeout della notifica di ritardo, il mittente riceve un DSN di ritardo. Il valore minimo è 1 minuto, il valore predefinito è 12 ore, mentre il valore massimo è 9.999 giorni. Utilizzare l'elenco a discesa accanto al campo del valore per selezionare minuti, ore o giorni.

Timeout scadenza

Il timeout di scadenza specifica il periodo di tempo massimo in cui il servizio SMTP tenta di recapitare un messaggio. Se il messaggio non può essere recapitato prima che sia trascorso l'intervallo del timeout di scadenza, il mittente riceve un rapporto di mancato recapito (NDR). Il valore minimo è 1 minuto. L'impostazione predefinita è 2 giorni. Il valore massimo è 9.999 giorni. Utilizzare l'elenco a discesa accanto al campo del valore per selezionare minuti, ore o giorni.


Impostazione del numero massimo di hop

Impostazione del numero massimo di hop
Server SMTP > Procedure relative al server SMTP > Recapitare i messaggi >

Durante il processo di recapito di un messaggio, è possibile che il messaggio venga inoltrato a diversi server prima che raggiunga la destinazione finale. È possibile impostare il numero massimo di server tramite i quali possono transitare i messaggi. Tale impostazione è indicata come numero di hop.

Dopo aver effettuato questa impostazione, il server virtuale SMTP (Simple Mail Transfer Protocol) conta gli hop nelle righe Received dell'intestazione del messaggio. Quando il numero di campi Received supera le impostazioni relative al numero massimo di hop, il messaggio viene reinviato al mittente con un rapporto di mancato recapito (NDR).

Procedura

Per impostare il numero massimo di hop

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Recapito scegliere il pulsante Avanzate. Verrà visualizzata la finestra di dialogo Impostazioni avanzate recapito.

  3. In Numero massimo di passaggi (hop) specificare il numero di hop tra il server di origine e quello di destinazione. L'impostazione predefinita è di 15 hop.


Impostazione del dominio di mascheramento

Impostazione del dominio di mascheramento
Server SMTP > Procedure relative al server SMTP > Recapitare i messaggi >

Il dominio di mascheramento sostituisce qualsiasi nome di dominio locale utilizzato nel campo Mail From delle intestazioni dei messaggi del protocollo SMTP (Simple Mail Transfer Protocol). La sostituzione avviene solo nel primo hop.

Procedura

Per impostare il dominio di mascheramento

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Recapito scegliere il pulsante Avanzate. Verrà visualizzata la finestra di dialogo Impostazioni avanzate recapito.

  3. Nella casella Dominio di mascheramento digitare il nome di dominio che si desidera venga visualizzato nelle intestazioni dei messaggi al posto del nome di dominio effettivo.

Nota:
Di tutte le risposte a tali messaggi verrà effettuato il routing tramite il server virtuale SMTP che utilizza il dominio di mascheramento.


Impostazione di un nome di dominio completo

Impostazione di un nome di dominio completo
Server SMTP > Procedure relative al server SMTP > Recapitare i messaggi >

I domini di posta elettronica devono poter essere risolti mediante il sistema DSN (Domain Name System). I record DNS utilizzati per risolvere un dominio di posta elettronica sono due. Nella maggior parte dei casi viene impostato un record Mail Exchanger (MX) per associare un dominio di posta elettronica al nome di dominio completo (FQDN) di uno o più server virtuali SMTP (Simple Mail Transfer Protocol) che servono quel dominio. Ciascun server SMTP a cui fa riferimento il record MX deve avere un record di indirizzo (A). Tramite il record A viene effettuato il mapping di un determinato nome di dominio completo al relativo indirizzo IP.

È possibile impostare un solo record A per un dominio di posta elettronica. In questo scenario, tramite il record A viene effettuato il mapping del dominio agli indirizzi IP dei server virtuali SMTP o dei server che servono quel dominio. È comunque preferibile aggiungere un record MX perché consente a un amministratore SMTP di specificare un elenco ordinato di server da utilizzare per i client che inviano messaggi a quel determinato dominio di posta elettronica. Il servizio SMTP cerca sempre un record MX prima di cercare un record A, di conseguenza impostando dei record MX nel proprio server virtuale si possono migliorare le prestazioni. In alcuni casi il record A viene utilizzato anche per altri scopi, ad esempio per il protocollo HTTP, mentre il record MX viene utilizzato solo per i server SMTP. Il record MX consente a un server di gestire indirizzi del tipo http://esempio.com (i client HTTP utilizzano il record A) e a un altro server di gestire indirizzi del tipo prova@esempio.com (i client SMTP utilizzano il record MX).

Nell'ambito del servizio SMTP sono disponibili due opzioni per specificare un nome di dominio completo. È possibile utilizzare il nome specificato nella scheda Nome computer della finestra di dialogo Proprietà del sistema nel Pannello di controllo oppure è possibile specificare un nome di dominio completo univoco per il server virtuale SMTP che si sta configurando.

All'avvio, il nome impostato nella scheda Nome computer della finestra di dialogo Proprietà del sistema viene utilizzato automaticamente come nome di dominio completo del server virtuale SMTP. Se si modifica il nome manualmente o collegandosi a un dominio, il nuovo nome verrà utilizzato automaticamente come nome di dominio completo al riavvio del computer. Non è necessario eseguire alcuna operazione per aggiornare il nome di dominio completo del server virtuale.

Per ignorare l'utilizzo automatico dei nomi del computer e del dominio impostati nella scheda Nome computer, modificare il nome di dominio completo nella finestra di dialogo Impostazioni avanzate recapito, a cui è possibile accedere dalla scheda Recapito. Il servizio SMTP potrà quindi utilizzare tale nome invece di quello specificato nella scheda Nome computer.

Procedura

Per impostare un nome di dominio completo

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Recapito scegliere il pulsante Avanzate. Verrà visualizzata la finestra di dialogo Impostazioni avanzate recapito.

  3. Nella casella Nome di dominio completo digitare il nome di dominio completo.


Configurazione di uno SmartHost

Configurazione di uno SmartHost
Server SMTP > Procedure relative al server SMTP > Recapitare i messaggi >

È possibile effettuare il routing di tutti i messaggi in uscita diretti a domini remoti attraverso uno smart host, invece di utilizzare la risoluzione DNS per inviarli direttamente al dominio. Ciò consente di effettuare il routing dei messaggi attraverso una connessione più diretta o meno costosa di altre. Lo smart host è simile all'opzione di routing del dominio disponibile per i domini remoti. La differenza consiste nel fatto che, una volta designato uno smart host, per tutti i messaggi in uscita il routing viene effettuato verso tale server. Con un dominio di routing, vengono indirizzati a un server specifico solo i messaggi destinati al dominio remoto.

Importante:
Assicurarsi che lo smart host designato sia protetto e amministrato da un'autorità trusted, in particolare quando si inoltrano informazioni riservate.

Se si imposta uno smart host, è possibile designare anche un routing diverso per un dominio remoto. L'impostazione del dominio di routing sostituisce quella dello smart host.

Nota:
È possibile identificare lo smart host specificandone il nome di dominio completo (FQDN) o l'indirizzo IP. Se tuttavia si cambia l'indirizzo IP, sarà necessario modificarlo anche in tutti i server virtuali. Se si utilizza un indirizzo IP, racchiuderlo tra parentesi quadre ([ ]) per migliorare le prestazioni del sistema. Il servizio SMTP infatti cerca prima il nome di un server, quindi un indirizzo IP. Le parentesi identificano il valore come indirizzo IP, quindi la ricerca DNS viene ignorata.

Procedura

Per impostare uno smart host

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Recapito scegliere il pulsante Avanzate. Verrà visualizzata la finestra di dialogo Impostazioni avanzate recapito.

  3. Nella casella SmartHost digitare il nome di dominio completo (FQDN) o l'indirizzo IP del server smart host.

  4. Se si desidera che il servizio SMTP tenti di recapitare direttamente i messaggi remoti prima di inoltrarli al server smart host, selezionare la casella di controllo Tenta il recapito diretto prima di inviare allo SmartHost. In base all'impostazione predefinita tutti i messaggi remoti vengono inviati allo smart host e il recapito diretto non viene tentato.


Abilitazione della ricerca DNS inversa

Abilitazione della ricerca DNS inversa
Server SMTP > Procedure relative al server SMTP > Recapitare i messaggi >

Se si seleziona questa opzione, il servizio SMTP (Simple Mail Transfer Protocol) tenta di verificare che l'indirizzo IP del client corrisponda all'host/dominio presentato dal client nel comando EHLO/HELO. Se la ricerca DNS inversa ha esito positivo, l'intestazione RECEIVED rimane invariata. Se la verifica ha esito negativo, dopo l'indirizzo IP viene visualizzato il valore unverified nell'intestazione RECEIVED del messaggio. Se la ricerca DNS inversa ha esito negativo, viene visualizzato il valore RDNS failed nell'intestazione RECEIVED del messaggio.

Nota:
Poiché questa funzionalità verifica gli indirizzi di tutti i messaggi in ingresso, il suo utilizzo può avere effetti negativi sulle prestazioni del servizio SMTP. Deselezionare la casella di controllo per disabilitare la funzionalità.

Procedura

Per abilitare la ricerca DNS inversa

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Recapito scegliere il pulsante Avanzate. Verrà visualizzata la finestra di dialogo Impostazioni avanzate recapito.

  3. Selezionare la casella di controllo Esegui ricerca DNS al contrario sui messaggi in arrivo.


Creare o eliminare un dominio

Creare o eliminare un dominio
Server SMTP > Procedure relative al server SMTP >

I domini del server SMTP sono diversi dai domini DNS (Domain Name System) e da quelli di Windows. I domini configurati sui server virtuali SMTP vengono infatti utilizzati per organizzare i messaggi per il recapito.

In questa sezione vengono fornite informazioni generali sui domini e vengono descritte le procedure di base. Nella sezione sono inclusi i seguenti argomenti:

  • Informazioni sui domini

  • Creazione di un dominio

  • Eliminazione di un dominio

Per ulteriori informazioni, vedere i seguenti argomenti:

  • Per informazioni sui domini locali, vedere Configurare domini locali.

  • Per informazioni sui domini remoti, vedere Configurare domini remoti.


Informazioni sui domini

Informazioni sui domini
Server SMTP > Procedure relative al server SMTP > Creare o eliminare un dominio >

Il server virtuale SMTP (Simple Mail Transfer Protocol) dispone di almeno un dominio: il dominio locale predefinito. È comunque possibile aggiungere ulteriori domini e configurarli come locali o remoti, nonché eliminare qualsiasi dominio, tranne quello predefinito.

Domini locali

Un dominio locale è un dominio DNS (Domain Name System) servito dal server SMTP locale. Qualsiasi messaggio con un nome di dominio locale che arriva a un server SMTP deve essere recapitato localmente in una directory di destinazione o reinviato al mittente con un rapporto di mancato recapito (NDR). I domini locali vengono a volte indicati anche domini di servizio o domini supportati. Gli indirizzi di posta elettronica con nomi di dominio locale vengono spesso indicati come indirizzi locali.

Se il dominio è locale, è possibile designarlo come dominio predefinito o come dominio alias. Il dominio predefinito può essere uno solo e viene utilizzato per contrassegnare le intestazioni dei messaggi per cui non è stato specificato un dominio particolare. Un dominio alias è un alias del dominio predefinito. Se si aggiunge un dominio e lo si imposta come predefinito, il precedente dominio predefinito diventa un dominio alias.

Domini remoti

I domini non locali vengono indicati come remoti o non locali e gli indirizzi di posta elettronica con nomi di dominio remoto vengono indicati come indirizzi non locali. Il server SMTP ricerca i domini remoti nel DNS.

Se si desidera impostare requisiti di recapito univoci per un determinato dominio remoto, aggiungere il dominio e configurarlo di conseguenza. Ad esempio, è possibile aggiungere un dominio remoto e richiedere che il servizio SMTP utilizzi sempre la crittografia TLS (Transport Layer Security) per le sessioni con tale dominio oppure modificare il routing in modo che i messaggi inviati a un dominio remoto vengano reindirizzati a un altro dominio remoto. Per configurare i domini, utilizzare la finestra di dialogo delle Proprietà dei domini.


Creazione di un dominio

Creazione di un dominio
Server SMTP > Procedure relative al server SMTP > Creare o eliminare un dominio >

In Windows Server 2008 è possibile creare due tipi di domini: domini alias e domini remoti. I domini alias consentono di creare domini secondari che puntano al dominio predefinito e ne utilizzano le impostazioni, inclusa la directory di destinazione. Qualsiasi messaggio inviato a un dominio alias viene contrassegnato con il nome del dominio predefinito.

I domini remoti possono essere impostati per i domini a cui si inviano frequentemente messaggi. Per ciascun dominio remoto, è possibile impostare una route di recapito predeterminata e richiedere l'utilizzo della crittografia TLS (Transport Layer Security) in tutte le sessioni con tale dominio. Se inoltre si specifica un carattere jolly nel nome, tutti i domini inclusi nel dominio che si sta creando utilizzeranno le stesse impostazioni. Digitare un asterisco (*) come primo carattere, seguito da un punto (.). È possibile ad esempio utilizzare l'asterisco come carattere jolly nel seguente formato:

Copia codice
*.example.com

Procedura

Per creare un dominio alias in Microsoft Management Console

  1. In Microsoft Management Console espandere il server virtuale SMTP. Per istruzioni su come avviare Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Selezionare Domini.

  3. Scegliere Nuovo dal menu Azione, quindi fare clic su Dominio.

  4. Utilizzare la Configurazione guidata del dominio SMTP per configurare un dominio locale (alias).

Per creare un dominio remoto in Microsoft Management Console

  1. In Microsoft Management Console espandere il server virtuale SMTP.

  2. Selezionare Domini.

  3. Scegliere Nuovo dal menu Azione, quindi fare clic su Dominio.

  4. Utilizzare la Configurazione guidata del dominio SMTP per configurare un dominio remoto.

  5. Per designare un dominio di routing, impostare l'autenticazione per i messaggi in uscita o utilizzare la crittografia TLS, selezionare il dominio nel riquadro dei risultati, scegliere Proprietà dal menu Azione, quindi specificare le opzioni desiderate.


Eliminazione di un dominio

Eliminazione di un dominio
Server SMTP > Procedure relative al server SMTP > Creare o eliminare un dominio >

È possibile eliminare qualunque dominio aggiunto precedentemente. Non è invece possibile eliminare il dominio predefinito, a meno che non si aggiunga prima un dominio alias e non si imposti tale dominio come dominio predefinito.

Procedura

Per eliminare un dominio

  1. In Microsoft Management Console espandere il server virtuale SMTP (Simple Mail Transfer Protocol). Per istruzioni su come avviare Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Fare clic su Domini.

  3. Nel riquadro dei risultati selezionare il dominio che si desidera eliminare.

  4. Scegliere Elimina dal menu Azione.


Configurare domini locali

Configurare domini locali
Server SMTP > Procedure relative al server SMTP >

In questa sezione viene descritto come impostare le opzioni per i domini locali esistenti. Nella sezione sono inclusi i seguenti argomenti:

  • Impostazione di un dominio predefinito

  • Configurazione di un dominio alias

  • Impostazione di una directory di destinazione


Impostazione di un dominio predefinito

Impostazione di un dominio predefinito
Server SMTP > Procedure relative al server SMTP > Configurare domini locali >

Il dominio predefinito viene utilizzato per contrassegnare i messaggi provenienti da indirizzi privi di dominio. Un server virtuale SMTP (Simple Mail Transfer Protocol) può avere un solo dominio predefinito, che non può essere eliminato.

Per denominare un dominio predefinito, è possibile utilizzare il suffisso DNS primario assegnato al computer. Per impostazione predefinita, tale nome è lo stesso del dominio del servizio directory di Active Directory. Se il computer non fa parte di un dominio, è possibile specificare un suffisso DNS nella scheda DNS nelle proprietà Impostazioni avanzate TCP/IP della connessione LAN. Tale nome di dominio è utilizzato anche per tutti gli altri servizi. In alternativa è possibile specificare un dominio univoco come dominio predefinito solo per il server SMTP di Windows Server 2008.

All'avvio, il suffisso DNS configurato per il computer viene utilizzato automaticamente per il dominio predefinito. Se si modifica il suffisso DNS nella scheda DNS, il nuovo nome verrà utilizzato automaticamente per il dominio predefinito al successivo avvio del servizio SMTP. Non è richiesta alcuna azione dell'utente per aggiornare il dominio predefinito per il server virtuale SMTP.

Per ignorare l'utilizzo automatico del dominio di rete, rinominare il dominio predefinito. Sarà così possibile utilizzare per il server virtuale SMTP il nome designato invece del dominio di rete.

Procedura

Per rinominare il dominio predefinito

  1. Espandere il server virtuale SMTP, quindi selezionare Domini.

  2. Fare clic con il pulsante destro del mouse sul nome di un dominio nel riquadro dei risultati, quindi scegliere Rinomina.

  3. Immettere un nuovo nome per il dominio predefinito.


Configurazione di un dominio alias

Configurazione di un dominio alias
Server SMTP > Procedure relative al server SMTP > Configurare domini locali >

È possibile configurare dei domini alias che utilizzino le stesse impostazioni del dominio predefinito. I messaggi ricevuti dal server SMTP di Windows Server 2008 per il dominio alias vengono memorizzati nella directory di destinazione impostata per il dominio predefinito.

Procedura

Per configurare un dominio alias

  1. Espandere il server virtuale SMTP (Simple Mail Transfer Protocol), quindi fare clic con il pulsante destro del mouse su Domini.

  2. Scegliere Nuovo, quindi Dominio. Verrà avviata la Configurazione guidata del dominio SMTP.

  3. Durante l'esecuzione della Configurazione guidata del dominio SMTP selezionare il pulsante di opzione Alias, quindi scegliere Avanti.

  4. Digitare un nome per il dominio alias, quindi scegliere Fine.


Impostazione di una directory di destinazione

Impostazione di una directory di destinazione
Server SMTP > Procedure relative al server SMTP > Configurare domini locali >

Per il dominio predefinito è necessario impostare la directory di destinazione di tutti i messaggi in ingresso. Il server virtuale SMTP inserisce i messaggi per i domini alias nella directory di destinazione utilizzata per il dominio predefinito. Come directory di destinazione è possibile specificare una directory qualsiasi, purché esista già, si trovi nello stesso computer del server SMTP di Windows Server 2008 e non sia già stata impostata come directory di prelievo. Per impostazione predefinita, la directory di destinazione e quella di prelievo sono sottodirectory della directory principale configurata per il contenuto SMTP.

Importante:
Assicurarsi che la directory di destinazione sia in una posizione protetta e sia accessibile solo da amministratori fidati. In caso contrario, utenti non autorizzati potrebbero riuscire ad accedere ai messaggi presenti nella directory.

Procedura

Per impostare una directory di destinazione

  1. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sul dominio predefinito, quindi scegliere Proprietà.

  2. Nella casella di testo Directory di destinazione digitare la directory di destinazione di tutti i messaggi in ingresso. Il percorso predefinito è directory principale:\Inetpub\Mailroot\Drop. In alternativa scegliere il pulsante Sfoglia e selezionare la directory. Assicurarsi di aver selezionato la directory di destinazione e non quella di prelievo.


Configurare domini remoti

Configurare domini remoti
Server SMTP > Procedure relative al server SMTP >

È possibile impostare requisiti di recapito univoci per un dominio remoto specifico aggiungendo un dominio e configurandolo di conseguenza. È possibile ad esempio impostare una route di recapito predeterminata, selezionare il tipo di autenticazione e richiedere che venga utilizzata la crittografia TLS (Transport Layer Security) per tutte le connessioni a tale dominio. Se il dominio remoto non viene configurato in modo specifico, il server SMTP di Windows Server 2008 non effettuerà alcuna di queste operazioni quando recapiterà i messaggi al dominio. Completerà tuttavia una normale ricerca DNS (Domain Name System).

In questa sezione sono inclusi i seguenti argomenti:

  • Impostazione di un dominio di routing

  • Abilitazione della crittografia TLS per un dominio remoto

  • Configurazione dell'autenticazione per un dominio remoto

  • Configurazione delle trasmissioni ATRN per un dominio remoto


Impostazione di un dominio di routing

Impostazione di un dominio di routing
Server SMTP > Procedure relative al server SMTP > Configurare domini remoti >

È possibile specificare un percorso di recapito che potrebbe rivelarsi più veloce e meno costoso di un collegamento diretto. Digitare il nome di dominio completo (FQDN) o l'indirizzo IP del server tramite il quale si desidera effettuare il routing dei messaggi per questo dominio remoto. Se si immette un indirizzo IP, racchiuderlo tra parentesi quadre ([ ]) per migliorare le prestazioni del sistema. Questa impostazione ha la priorità sull'impostazione dello SmartHost effettuata nella scheda Recapito.

Procedura

Per designare un dominio di routing

  1. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, scegliere Nuovo, quindi Dominio.

  2. Utilizzare la Configurazione guidata del dominio SMTP per creare un dominio remoto. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sul nuovo dominio remoto, quindi scegliere Proprietà.

  3. Nella sezione Dominio di routing della scheda Generale selezionare il pulsante di opzione Inoltra tutta la posta a SmartHost, quindi digitare il nome di dominio completo o l'indirizzo IP del server tramite il quale si desidera effettuare il routing dei messaggi per questo dominio remoto.

    Nota:
    È possibile identificare lo SmartHost specificandone il nome di dominio completo (FQDN) o l'indirizzo IP. Se tuttavia si cambia l'indirizzo IP, sarà necessario modificarlo anche in tutti i server virtuali. Se si utilizza un indirizzo IP, racchiuderlo tra parentesi quadre ([ ]) per migliorare le prestazioni del sistema. Il servizio SMTP infatti cerca prima il nome di un server, quindi un indirizzo IP. Le parentesi identificano il valore come indirizzo IP, quindi la ricerca DNS viene ignorata.


Abilitazione della crittografia TLS per un dominio remoto

Abilitazione della crittografia TLS per un dominio remoto
Server SMTP > Procedure relative al server SMTP > Configurare domini remoti >

Se si sceglie di non utilizzare la crittografia TLS (Transport Layer Security) per il server virtuale SMTP (Simple Mail Transfer Protocol), ma si seleziona la casella di controllo Crittografia TLS per un particolare dominio remoto, il server SMTP di Windows Server 2008 utilizza la crittografia TLS quando effettua la connessione a quel dominio remoto. Le configurazioni del dominio sostituiscono sempre le configurazioni del server virtuale.

Procedura

Per abilitare la crittografia TLS per un dominio remoto

  1. Espandere il server virtuale SMTP, quindi scegliere Domini.

  2. Nel riquadro dei dettagli selezionare il dominio remoto che si desidera modificare. Scegliere Proprietà dal menu Azione.

  3. Nella scheda Generale scegliere Protezione per visualizzare la finestra di dialogo Protezione recapito esterno.

  4. Selezionare Autenticazione integrata di Windows.

  5. Digitare l'account e la password di Windows.

  6. Scegliere OK.

  7. Selezionare la casella di controllo Crittografia TLS, quindi scegliere OK.
Nota:
Se il dominio remoto non supporta la crittografia TLS, tutti i messaggi saranno restituiti al mittente con un rapporto di mancato recapito (NDR).


Configurazione dell'autenticazione per un dominio remoto

Configurazione dell'autenticazione per un dominio remoto
Server SMTP > Procedure relative al server SMTP > Configurare domini remoti >

È possibile configurare il server virtuale SMTP (Simple Mail Transfer Protocol) per la presentazione delle credenziali di autenticazione richieste dal dominio remoto. Sono disponibili due tipi di autenticazione: autenticazione di base (testo non crittografato) e Autenticazione integrata di Windows. Con l'opzione Autenticazione di base, il nome dell'account e la password del server a cui ci si connette vengono trasmessi come testo non crittografato. Con l'opzione Autenticazione integrata di Windows è necessario specificare un nome di account e una password di Windows. Per impostazione predefinita, è configurato l'accesso anonimo senza alcuna autenticazione.

Tale impostazione ha la priorità sull'impostazione dell'autenticazione del server virtuale SMTP effettuata nella scheda Accesso. Nella seguente tabella sono riportati due scenari di configurazione.

Trasmissioni del server virtuale SMTP | Opzione di autenticazione
Messaggi inviati di frequente a più indirizzi. | Abilitare l'accesso anonimo per il server virtuale SMTP. Se i tentativi di recapito dei messaggi a un indirizzo non hanno esito positivo a causa dei requisiti di autenticazione, aggiungere un dominio remoto per l'indirizzo. Abilitare quindi per il dominio lo stesso livello di autenticazione richiesto dal server.
Messaggi inviati di frequente a un indirizzo che richiede l'autenticazione. | Determinare quale livello di autenticazione è necessario per la connessione. Abilitare quindi lo stesso livello di autenticazione per il server virtuale SMTP. Se in seguito si desidera inviare messaggi ad altri indirizzi, configurare dei domini remoti e impostare opzioni di autenticazione differenti. In questo caso, il nome account utilizzato sarà probabilmente quello che identifica il computer impostato come smart host.

Procedura

Per disabilitare l'autenticazione per i messaggi in uscita inviati a un dominio remoto

  1. Espandere il server virtuale SMTP, quindi selezionare Domini.

  2. Nel riquadro dei risultati selezionare il dominio remoto che si desidera modificare. Scegliere Proprietà dal menu Azione.

  3. Nella scheda Generale scegliere Protezione per visualizzare la finestra di dialogo Protezione recapito esterno.

  4. Selezionare Accesso anonimo, quindi scegliere OK.

Per impostare l'autenticazione di base per i messaggi in uscita inviati a un dominio remoto

  1. Espandere il server virtuale SMTP, quindi selezionare Domini.

  2. Nel riquadro dei risultati selezionare il dominio remoto che si desidera modificare. Scegliere Proprietà dal menu Azione.

  3. Nella scheda Generale scegliere Protezione per visualizzare la finestra di dialogo Protezione recapito esterno.

  4. Scegliere Autenticazione di base.

  5. Digitare il nome utente e la password del computer a cui ci si connette.

  6. Scegliere OK.
Importante:
Se l'autenticazione di base è l'unico metodo di autenticazione utilizzato, si consiglia di richiedere la crittografia TLS per impedire il rilevamento non autorizzato di nomi utente e password.

Per impostare l'Autenticazione integrata di Windows per i messaggi in uscita

  1. Espandere il server virtuale SMTP, quindi selezionare Domini.

  2. Nel riquadro dei risultati selezionare il dominio remoto che si desidera modificare. Scegliere Proprietà dal menu Azione.

  3. Nella scheda Generale scegliere Protezione per visualizzare la finestra di dialogo Protezione recapito esterno.

  4. Scegliere Autenticazione integrata di Windows.

  5. Digitare il nome dell'account e la password di Windows.

  6. Scegliere OK.


Configurazione delle trasmissioni ATRN per un dominio remoto

Configurazione delle trasmissioni ATRN per un dominio remoto
Server SMTP > Procedure relative al server SMTP > Configurare domini remoti >

Il server SMTP di Windows Server 2008 può conservare la posta per i client che si connettono periodicamente per scaricare messaggi. In questo caso il client invia un comando ATRN. Il servizio SMTP (Simple Mail Transfer Protocol) inizia quindi a inviare messaggi al dominio ATRN. È possibile creare un dominio remoto per un indirizzo verso il quale il server virtuale accoda i messaggi e abilitare ATRN per il dominio.

Procedura

Per abilitare le trasmissioni ATRN per un dominio remoto

  1. Espandere il server virtuale SMTP, quindi scegliere Domini.

  2. Nel riquadro dei risultati selezionare il dominio remoto che si desidera modificare. Scegliere Proprietà dal menu Azione.

  3. Fare clic su Avanzate, quindi selezionare la casella di controllo Accoda messaggi per recapito remoto con trigger.

  4. Scegliere il pulsante Aggiungi o Rimuovi, a seconda delle necessità, per selezionare gli account utente di Windows che potranno utilizzare il comando ATRN nell'ambito del dominio.


Configurare le connessioni a un server LDAP

Configurare le connessioni a un server LDAP
Server SMTP > Procedure relative al server SMTP >

LDAP (Lightweight Directory Access Protocol) è un protocollo Internet che consente l'accesso alle informazioni delle directory da un server LDAP. Disponendo dell'autorizzazione per l'utilizzo di tale protocollo, è possibile esplorare, leggere ed effettuare ricerche negli elenchi delle directory del server LDAP.

Mediante la scheda Routing LDAP è possibile configurare il server SMTP di Windows Server 2008 in modo che per la risoluzione di mittenti e destinatari venga consultato un server LDAP. Ad esempio, è possibile utilizzare Active Directory come server LDAP e utilizzare Utenti e computer di Active Directory per creare una lista di distribuzione di gruppo espansa automaticamente sul server virtuale SMTP (Simple Mail Transfer Protocol).

In questa sezione viene spiegato come configurare il server virtuale SMTP come client LDAP in modo da poter accedere alle informazioni delle directory in un server LDAP. Nella sezione sono inclusi i seguenti argomenti:

  • Operazioni preliminari per la configurazione delle connessioni LDAP

  • Selezione di un tipo di schema

  • Impostazione del livello di autenticazione

  • Impostazione delle informazioni per il routing LDAP


Operazioni preliminari per la configurazione delle connessioni LDAP

Operazioni preliminari per la configurazione delle connessioni LDAP
Server SMTP > Procedure relative al server SMTP > Configurare le connessioni a un server LDAP >

Poiché alcune impostazioni della scheda Routing LDAP influiscono su altre, si consiglia di eseguire un'attenta pianificazione prima di configurare le connessioni LDAP (Lightweight Directory Access Protocol).

Procedura

Per configurare le connessioni LDAP

  1. Determinare il tipo di schema da utilizzare. Per ulteriori informazioni, vedereSelezione di un tipo di schema.

  2. Determinare il livello di autenticazione necessario per effettuare il binding della directory LDAP. Per ulteriori informazioni, vedere Impostazione del livello di autenticazione. Se il server LDAP a cui ci si connette non richiede l'autenticazione, non è necessario specificare l'account.

  3. Determinare se si deve specificare un contesto dei nomi. Ciò potrebbe essere necessario se gli account utente si trovano in un sottocontenitore all'interno della directory LDAP. Un contesto dei nomi può consentire alla directory LDAP di ottenere risultati più velocemente e, in alcuni casi, è necessario se il server LDAP contiene più contesti.


Selezione di un tipo di schema

Selezione di un tipo di schema
Server SMTP > Procedure relative al server SMTP > Configurare le connessioni a un server LDAP >

Nella tabella seguente vengono illustrati i tipi di schema disponibili nell'elenco a discesa Schema della scheda Routing LDAP.

Tipo di schema | Descrizione
Active Directory | Selezionare questa opzione per utilizzare il servizio directory di Active Directory come server LDAP (Lightweight Directory Access Protocol). Per gestire le cassette postali, utilizzare Utenti e computer di Active Directory.
Directory di appartenenza del server al sito | Utilizzare questa opzione se il servizio Microsoft LDAP è stato installato con Microsoft Commercial Internet System 2.0 Mail e lo si utilizza per gestire le cassette postali.
Servizio LDAP di Exchange | Selezionare questa opzione per utilizzare un server LDAP Microsoft Site Server 3.0 per la gestione delle cassette postali.


Impostazione del livello di autenticazione

Impostazione del livello di autenticazione
Server SMTP > Procedure relative al server SMTP > Configurare le connessioni a un server LDAP >

Nella tabella seguente vengono illustrati i quattro tipi di binding che determinano il livello di autenticazione utilizzato per le connessioni. L'opzione selezionata influisce sulle altre opzioni.

Tipo di binding | Descrizione
Anonimo | Non è richiesta alcuna autenticazione. Selezionare questa opzione quando il server non richiede l'account e la password.
Testo normale | Questa opzione consente di abilitare la trasmissione delle informazioni sull'account e delle password in formato non crittografato. Quando questa opzione è selezionata, è necessario specificare l'account e la password. Si consiglia di non trasmettere le password come testo normale, perché le informazioni non crittografate possono essere lette da utenti non autorizzati o malintenzionati.
Windows SSPI | Il client e il server negoziano quale sia il livello di autenticazione accettabile per entrambi e utilizzano il metodo disponibile più restrittivo. Quando si seleziona questa opzione, è necessario specificare l'account e la password.
Account del servizio | Vengono utilizzate le informazioni relative all'account dell'utente per il quale è in esecuzione il servizio SMTP. Per accedere a tali informazioni, scegliere Strumenti di amministrazione, quindi Servizi.


Impostazione delle informazioni per il routing LDAP

Impostazione delle informazioni per il routing LDAP
Server SMTP > Procedure relative al server SMTP > Configurare le connessioni a un server LDAP >

Se si abilita il routing LDAP (Lightweight Directory Access Protocol) per un server virtuale SMTP (Simple Mail Transfer Protocol), è possibile configurare il server virtuale SMTP affinché consulti una directory LDAP per risolvere mittenti e destinatari.

Procedura

Per impostare le informazioni per il routing LDAP

  1. In Microsoft Management Console selezionare le Proprietà relative al server virtuale SMTP che si desidera configurare. Per istruzioni su come avviare Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Fare clic sulla scheda Routing LDAP.

  3. Selezionare la casella di controllo Attiva routing LDAP.

  4. Impostare le opzioni come indicato nella tabella che segue.

Nella seguente tabella vengono descritte le opzioni disponibili:

Opzione Descrizione

Server

Digitare il nome del computer in cui è in esecuzione la directory LDAP (Lightweight Directory Access Protocol). Questo campo non è utilizzabile quando si utilizza il tipo di schema Servizio LDAP di Exchange, poiché il servizio rileva un server vicino e lo utilizza automaticamente.

Schema

Selezionare un tipo di schema. Per ulteriori informazioni, vedere Selezione di un tipo di schema.

Binding

Selezionare il metodo di autenticazione da utilizzare per il binding al server LDAP. Per ulteriori informazioni, vedere Impostazione del livello di autenticazione.

Con Testo normale le password vengono trasmesse come testo non crittografato. Per utilizzare il metodo di autenticazione più restrittivo per il server virtuale SMTP, selezionare Windows SSPI. Se non si desidera applicare alcun metodo di autenticazione, utilizzare l'impostazione predefinita Anonimo. Il tipo di binding relativo all'account del servizio utilizza le credenziali dell'account dell'utente che tenta di effettuare il binding al server LDAP.

Dominio

Digitare il dominio dell'account da utilizzare per il binding con la directory LDAP. Questa opzione si applica selezionando i tipi di binding Testo normale o Windows SSPI.

Nome utente

Digitare il nome distinto dell'account da utilizzare per il binding con la directory LDAP, ad esempio cn=utente1,ou=utenti,o=azienda. Questa opzione si applica selezionando i tipi di binding Testo normale o Windows SSPI.

Password

Digitare la password utilizzata per la registrazione al servizio di directory. Questa opzione si applica selezionando i tipi di binding Testo normale o Windows SSPI.

Base

Digitare il nome distinto di un contenitore del servizio di directory a cui si sta accedendo. Con questa impostazione viene specificato il punto da cui il servizio SMTP deve iniziare la ricerca nella directory LDAP. La ricerca inizia nel contenitore e, se necessario, prosegue nei sottocontenitori.


Configurare un database conforme allo standard ODBC

Configurare un database conforme allo standard ODBC
Server SMTP > Procedure relative al server SMTP >

Procedura

In questo argomento viene illustrato come configurare un database conforme allo standard ODBC (Open Database Connectivity).

Per configurare un database conforme allo standard ODBC

  1. Creare un database conforme allo standard ODBC utilizzando un programma di database quale Microsoft Access o Microsoft SQL Server.

  2. Creare nel database una tabella con i campi riportati di seguito.

    Nome campo Tipo di dati

    ClientHost

    varchar(255)

    Username

    varchar(255)

    LogTime

    datetime

    Service

    varchar(255)

    Machine

    varchar(255)

    ServerIP

    varchar(50)

    ProcessingTime

    integer

    BytesRecvd

    integer

    BytesSent

    integer

    ServiceStatus

    integer

    Win32Status

    integer

    Operation

    varchar(255)

    Target

    varchar(255)

    Parameters

    varchar(255)


Concetti relativi al server SMTP

Concetti relativi al server SMTP
Server SMTP >

Il recapito della posta è una funzionalità comune dei siti Internet. I messaggi Internet vengono in genere trasmessi e recapitati mediante il protocollo SMTP (Simple Mail Transfer Protocol). È possibile utilizzare il server SMTP di Windows Server 2008 per configurare l'hardware in uso per il recapito dei messaggi su una Intranet o su Internet.

Il server SMTP supporta le funzioni di recapito SMTP di base. Fornisce inoltre funzionalità che consentono di personalizzare la propria configurazione in base a requisiti di recapito e di protezione specifici.

In questa sezione vengono fornite informazioni generali sul server SMTP e vengono illustrati i seguenti argomenti:

  • Panoramica sul server SMTP

  • Funzionalità principali

  • Componenti

  • Panoramica sui processi


Panoramica sul server SMTP

Panoramica sul server SMTP
Server SMTP > Concetti relativi al server SMTP >

In questa sezione vengono fornite informazioni generali sulla configurazione del server SMTP di Windows Server 2008 e dei server virtuali SMTP. Nella sezione sono inclusi i seguenti argomenti:

  • Accesso alle schede

  • Miglioramento delle prestazioni del sistema


Accesso alle schede

Accesso alle schede
Server SMTP > Concetti relativi al server SMTP > Panoramica sul server SMTP >

Per configurare i server virtuali SMTP (Simple Mail Transfer Protocol) forniti dal server SMTP di Windows Server 2008, utilizzare le sei schede descritte nella tabella riportata di seguito.

Scheda | Descrizione
Generale | In questa scheda sono contenute le impostazioni che determinano in che modo il server virtuale si connette ad altri server SMTP per trasmettere e ricevere i messaggi. Può anche essere utilizzata per abilitare la registrazione.
Accesso | In questa scheda sono contenute le impostazioni per richiedere l'autenticazione e l'utilizzo dello standard TLS (Transport Layer Security), un tipo di crittografia SSL (Secure Sockets Layer) valido per tutti i protocolli, per tutte le connessioni in ingresso. È anche possibile concedere o negare l'accesso generale o per l'inoltro a determinati computer o reti.
Messaggi | In questa scheda è possibile configurare i limiti relativi ai messaggi e impostare come devono essere gestiti i messaggi non recapitabili.
Recapito | In questa scheda sono contenute le impostazioni che determinano in che modo il server recapita i messaggi, incluso il numero di messaggi per connessione, il routing, i tentativi di reinvio e il timeout di scadenza per il reinvio dei messaggi.
Routing LDAP | In questa scheda sono contenute le impostazioni per il protocollo LDAP (Lightweight Directory Access Protocol) che consentono l'accesso alle directory conformi alla struttura X.500.
Protezione | In questa scheda è possibile impostare gli account utente aventi le autorizzazioni di operatore per configurare il servizio SMTP.

Procedura

Per accedere alle schede del server virtuale SMTP da Microsoft Management Console

  1. Selezionare il server virtuale SMTP che si desidera configurare. Per istruzioni su come avviare Microsoft Management Console, vedere Avviare Microsoft Management Console.

  2. Scegliere Proprietà dal menu Azione.

  3. Fare clic sulla scheda che si desidera visualizzare.


Miglioramento delle prestazioni del sistema

Miglioramento delle prestazioni del sistema
Server SMTP > Concetti relativi al server SMTP > Panoramica sul server SMTP >

Alcune impostazioni di configurazione di un server virtuale SMTP (Simple Mail Transfer Protocol) possono influire sulle prestazioni del sistema. Per determinare come ottimizzare il sistema al fine di ridurre il tempo di elaborazione e ottimizzare le connessioni per il recapito dei messaggi, vedere i seguenti argomenti:

  • Limitazione del numero di messaggi per connessione

  • Configurazione di uno SmartHost

  • Abilitazione della ricerca DNS inversa


Funzionalità principali

Funzionalità principali
Server SMTP > Concetti relativi al server SMTP >

Il server SMTP di Windows Server 2008 presenta le funzionalità illustrate di seguito.

Supporto del protocollo standard di Internet

Il server SMTP supporta totalmente il protocollo SMTP (Simple Mail Transfer Protocol) ed è compatibile con i client di posta SMTP.

Scalabilità

È possibile configurare i server virtuali SMTP in modo da supportare più domini e centinaia di connessioni client nell'ambito di una configurazione con un unico server.

Amministrazione semplificata e integrazione con il sistema operativo Windows Server 2008

Il server SMTP utilizza Microsoft Management Console per l'amministrazione. I server virtuali SMTP vengono creati e configurati mediante Gestione Internet Information Services (IIS) 6.0. Gli amministratori possono utilizzare altre funzionalità di amministrazione di Windows Server 2008, tra cui il protocollo SNMP (Simple Network Management Protocol), i registri eventi e i registri delle transazioni per raccogliere i dati statistici sull'utilizzo, tenere traccia dei messaggi e delle transazioni o analizzare i criteri d'uso.

Protezione elevata

Il server SMTP supporta l'utilizzo dello standard TLS (Transport Layer Security) per la crittografia delle trasmissioni.

Destinazione e prelievo controllati della posta

Per il dominio predefinito il server SMTP inserisce tutti i messaggi in ingresso direttamente in una directory di destinazione e può pertanto essere utilizzato come ricevente di posta elettronica per altre applicazioni.

Oltre a connettersi a una porta TCP per l'invio di messaggi, le applicazioni possono utilizzare una directory di prelievo. Quando un messaggio formattato come file di testo viene copiato nella directory di prelievo, il server SMTP procede al recapito.


Componenti

Componenti
Server SMTP > Concetti relativi al server SMTP >

In questa sezione vengono descritti i componenti del server SMTP di Windows Server 2008, la relativa funzione e il modo in cui interagiscono. Nella sezione sono inclusi i seguenti argomenti:

  • Impostazioni di visualizzazione dei componenti in Microsoft Management Console

  • Relazione tra i componenti

  • Directory principale della posta (Mailroot) e directory predefinite


Impostazioni di visualizzazione dei componenti in Microsoft Management Console

Impostazioni di visualizzazione dei componenti in Microsoft Management Console
Server SMTP > Concetti relativi al server SMTP > Componenti >

Tutti i componenti di Internet Information Services (IIS) 6.0 configurati nel computer in uso vengono visualizzati in Microsoft Management Console. Il server SMTP di Windows Server 2008 è rappresentato da una serie di nodi del server virtuale SMTP nell'albero della console di Microsoft Management Console. Quando si seleziona un nodo, vengono visualizzate informazioni dettagliate nel riquadro dei risultati. Nella tabella che segue vengono descritti i nodi relativi al computer e al server virtuale SMTP.

Nodo | Icona | Descrizione
Computer | Icona del computer | Questo è il principale componente amministrativo di IIS. Visualizza informazioni su ciascun servizio IIS, inclusi lo stato operativo, l'indirizzo IP e la porta.
Server virtuale SMTP | Icona di recapito della posta elettronica | Questo è il principale componente amministrativo del server SMTP. Fornisce l'accesso alle schede per la configurazione del server virtuale SMTP.
Domini | Icona: due messaggi di posta elettronica recapitati | Questi sono i componenti organizzativi dei server virtuali SMTP. Il nodo consente di accedere alla finestra di dialogo delle Proprietà per la creazione e la configurazione dei domini e visualizza informazioni su tutti i domini configurati nel server virtuale.
Sessioni correnti | Raffigurazione di una testa di persona indicante lo stato della sessione | Fornisce informazioni di stato sull'utilizzo del server virtuale SMTP. Visualizza una schermata con l'utente, il percorso di origine e la durata della connessione per ciascuna sezione attiva.


Relazione tra i componenti

Relazione tra i componenti
Server SMTP > Concetti relativi al server SMTP > Componenti >

In Microsoft Management Console, il server virtuale SMTP viene utilizzato per gestire il server SMTP di Windows Server 2008. Ogni server virtuale comprende un dominio predefinito che viene utilizzato per contrassegnare i messaggi inviati da indirizzi senza dominio. Non è possibile eliminare il dominio predefinito. È tuttavia possibile creare un dominio alias. Tutti i domini alias utilizzano il dominio predefinito per contrassegnare i messaggi.

Per ulteriori informazioni sui domini, vedere Informazioni sui domini.


Directory principale della posta (Mailroot) e directory predefinite

Directory principale della posta (Mailroot) e directory predefinite
Server SMTP > Concetti relativi al server SMTP > Componenti >

Durante l'esecuzione del programma di installazione vengono create cinque sottodirectory predefinite nella directory principale della posta (Mailroot) per consentire l'elaborazione dei messaggi da parte del server SMTP di Windows Server 2008. Nella tabella che segue vengono illustrate quattro di queste directory. Nella directory SortTemp, creata anch'essa durante l'installazione, sono contenuti i file temporanei. Il percorso predefinito della directory Mailroot è directory radice:\Inetpub\Mailroot. È tuttavia possibile indicare un percorso diverso durante l'installazione. Di seguito è riportata la descrizione delle sottodirectory di Mailroot e del relativo contenuto.

Importante:
Assicurarsi che la directory Mailroot e le relative sottodirectory siano accessibili solo da amministratori fidati. Questa precauzione impedirà a utenti non autorizzati di accedere ai messaggi contenuti in queste directory.

Directory | Descrizione
Directory della posta scartata (Badmail) | In questa directory vengono memorizzati i messaggi non recapitabili che non possono essere restituiti al mittente.
Directory di destinazione (Drop) | In questa directory vengono riuniti i messaggi in ingresso relativi a tutti i domini ospitati nel computer. È possibile impostare come directory di destinazione qualsiasi directory, tranne quella già indicata come directory di prelievo (Pickup).
Directory di prelievo (Pickup) | In questa directory vengono elaborati i messaggi in uscita creati come file di testo e copiati nella directory. Non appena un messaggio Request for Comments (RFC) 2822 formattato correttamente viene copiato in questa directory, il servizio SMTP lo individua e procede al recapito.
Directory della coda (Queue) | In questa directory vengono conservati i messaggi da recapitare. Se un messaggio non può essere recapitato perché la linea è occupata o la connessione si è interrotta, viene inserito nella coda e inviato di nuovo a intervalli predeterminati.


Panoramica sui processi

Panoramica sui processi
Server SMTP > Concetti relativi al server SMTP >

Il server SMTP di Windows Server 2008 utilizza il protocollo SMTP (Simple Mail Transfer Protocol) per trasportare e recapitare i messaggi in conformità con le specifiche delle Request for Comments (RFC) 2821 e 2822. I messaggi vengono trasferiti tra server di posta remoti e la directory di destinazione del dominio predefinito. Il server SMTP è stato progettato per ottimizzare le connessioni in modo da elaborare il maggior numero possibile di messaggi al secondo.

In questa sezione viene illustrato il processo di trasmissione e recapito dei messaggi tramite il server SMTP. Nella sezione sono inclusi i seguenti argomenti:

  • Elaborazione dei messaggi

  • Recapito locale dei messaggi

  • Recapito remoto dei messaggi


Elaborazione dei messaggi

Elaborazione dei messaggi
Server SMTP > Concetti relativi al server SMTP > Panoramica sui processi >

Quando un messaggio viene copiato nella directory di prelievo o arriva tramite la porta TCP specificata viene inserito nella directory della coda. La porta TCP predefinita è la 25.

Se i destinatari sono locali, il messaggio verrà recapitato. Se i destinatari non sono locali, il messaggio verrà elaborato per il recapito remoto. Nella figura 1 viene mostrato il processo del flusso dei messaggi.

Importante:
Nella figura 1 è stata omessa la presenza consigliata di uno o più firewall tra Internet e il server SMTP.
Figura 1 Processo del flusso dei messaggi

Processo del flusso dei messaggi


Recapito locale dei messaggi

Recapito locale dei messaggi
Server SMTP > Concetti relativi al server SMTP > Panoramica sui processi >

Se un messaggio è destinato a un destinatario locale, verrà spostato dalla directory della coda alla directory di destinazione impostata per il dominio predefinito. Una volta che il messaggio è stato inserito nella directory di destinazione, il ciclo di recapito SMTP può ritenersi concluso. La directory di destinazione può essere impostata nella finestra di dialogo Dominio predefinito. Nella figura 1 viene mostrato il flusso del processo.

Importante:
Nella figura 1 è stata omessa la presenza consigliata di uno o più firewall tra Internet e il server SMTP.
Figura 1 Processo del flusso dei messaggi locale

Processo del flusso dei messaggi locale


Recapito remoto dei messaggi

Recapito remoto dei messaggi
Server SMTP > Concetti relativi al server SMTP > Panoramica sui processi >

Nella seguente tabella vengono descritti i processi utilizzati dal server SMTP di Windows Server 2008 per il recapito remoto dei messaggi. Vengono anche indicate le schede utilizzabili per la configurazione delle opzioni.

Processo Descrizione

Ordinare i messaggi e inserirli nella coda per il recapito.

I messaggi rimangono nella directory della coda. I destinatari dei diversi messaggi vengono ordinati in base al dominio in modo che il servizio SMTP possa inviarli in gruppo. Ciò consente al servizio SMTP di ottimizzare le connessioni recapitando più messaggi in un'unica sessione.

Determinare se il server ricevente è pronto per l'arrivo dei messaggi.

Il servizio SMTP tenta di connettersi al server di posta ricevente. Se il server non è pronto, il messaggio rimarrà nella coda e verrà eseguito un tentativo di recapito a intervalli prestabiliti finché non verrà raggiunto il limite massimo di tentativi previsto. Gli intervalli tra tentativi di recapito del messaggio possono essere impostati nella scheda Recapito.

Inviare il messaggio.

Una volta verificati i destinatari, il messaggio viene inviato. Dopo che il server ricevente accetta la trasmissione, il recapito da parte del servizio SMTP può ritenersi completato. Le opzioni di recapito vengono descritte di seguito.

  • Se è stata attivata la crittografia TLS (Transport Layer Security) per il recapito remoto, il servizio SMTP crittograferà tutti i messaggi in uscita. È inoltre possibile abilitare o disabilitare questa funzione per uno specifico dominio remoto. La crittografia TLS può essere impostata nella finestra di dialogo Protezione recapito esterno, a cui si accede scegliendo il pulsante Protezione nella scheda Recapito.

  • Tutti i messaggi diretti a domini remoti possono essere inviati a uno smart host, che provvederà successivamente a inviarli ai relativi destinatari. Lo smart host può essere impostato nella finestra di dialogo Impostazioni avanzate recapito, a cui si accede scegliendo il pulsante Avanzate nella scheda Recapito.

Per ulteriori informazioni su come utilizzare le schede per configurare i server virtuali SMTP, vedere Accesso alle schede.


Manutenzione del server SMTP

Manutenzione del server SMTP
Server SMTP >

In questa sezione viene illustrato come monitorare i vari processi in modo da poter analizzare la configurazione del server virtuale SMTP e da apportare eventuali modifiche per garantire un'elaborazione efficiente dei messaggi di posta. Viene inoltre descritto come sospendere e interrompere il servizio SMTP ai fini della manutenzione. Nella sezione sono inclusi i seguenti argomenti:

  • Panoramica sugli strumenti di monitoraggio

  • Monitoraggio dei processi di sistema

  • Monitoraggio delle prestazioni e della configurazione SMTP

  • Monitoraggio delle transazioni relative ai messaggi


Panoramica sugli strumenti di monitoraggio

Panoramica sugli strumenti di monitoraggio
Server SMTP > Manutenzione del server SMTP >

Sono disponibili numerosi strumenti per tenere traccia degli eventi e monitorare le prestazioni. È possibile utilizzare questi strumenti per risolvere eventuali problemi e determinare se è necessario apportare modifiche alla configurazione del sistema.

Importante:
Il controllo dell'attività del server con file di registro è un buon metodo per rilevare se utenti esterni non autorizzati stanno tentando di accedere al server virtuale SMTP (Simple Mail Transfer Protocol) o se utenti interni stanno tentando di accedere a risorse per le quali non dispongono di autorizzazioni appropriate. Per ulteriori informazioni su come controllare e utilizzare il Visualizzatore eventi, vedere Guida e supporto tecnico.

Registro eventi di Windows Server 2008

Questo registro consente di verificare se Windows Server 2008 funziona correttamente tenendo traccia di tutti gli eventi informativi, di avviso e di errore che richiedono l'attenzione dell'amministratore. Per impostazione predefinita, i registri disponibili sono tre: registro eventi di sistema, registro di protezione e registro applicazioni.

La registrazione di eventi predeterminati inizia automaticamente all'avvio di un computer che esegue Windows Server 2008. Per ciascun tipo di registro è possibile impostare la dimensione massima, per quanto tempo devono essere conservati i dati e se sovrascrivere automaticamente gli eventi quando il registro è pieno o cancellare manualmente le voci.

Monitoraggio affidabilità e Performance Monitor

Monitoraggio affidabilità e Performance Monitor verifica la capacità di risposta del servizio SMTP e indica se le prestazioni sono quelle previste. È possibile registrare le statistiche sui carichi di lavoro effettivi per qualsiasi componente del sistema si desideri controllare. È quindi possibile analizzare i dati per stabilire se è necessario apportare delle modifiche alla configurazione per garantire che i messaggi vengano elaborati in modo ottimale. A tale scopo, abilitare il monitoraggio e specificare gli elementi di cui tenere traccia.

Registro di protocollo

Il registro di protocollo consente di tenere traccia delle singole transazioni SMTP. È necessario prima abilitare la registrazione, quindi impostarne la frequenza e il formato.


Monitoraggio dei processi di sistema

Monitoraggio dei processi di sistema
Server SMTP > Manutenzione del server SMTP >

Il servizio SMTP scrive informazioni in due registri eventi di Windows Server 2008: registro eventi di sistema e registro eventi protezione. All'interno di ciascun registro, il servizio SMTP registra gli eventi informativi, di avviso e di errore.

Controllare con attenzione questi registri e archiviarli periodicamente per evitare che lo spazio disponibile si esaurisca. Per evitare di perdere informazioni, cancellare di tanto in tanto il contenuto dei registri in modo che il servizio SMTP possa continuare a scrivervi nuovi eventi.


Monitoraggio delle prestazioni e della configurazione SMTP

Monitoraggio delle prestazioni e della configurazione SMTP
Server SMTP > Manutenzione del server SMTP >

In questa sezione viene spiegato come utilizzare Monitoraggio affidabilità e Performance Monitor per verificare la struttura e le prestazioni del sistema. Nella sezione sono inclusi i seguenti argomenti:

  • Panoramica su Monitoraggio affidabilità e Performance Monitor

  • Monitoraggio delle prestazioni

  • Monitoraggio della capacità del sistema


Panoramica su Monitoraggio affidabilità e Performance Monitor

Panoramica su Monitoraggio affidabilità e Performance Monitor
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle prestazioni e della configurazione SMTP >

Dopo aver configurato il sistema, è possibile rivederne la struttura tenendo traccia delle prestazioni. Utilizzare Monitoraggio affidabilità e Performance Monitor per registrare le statistiche relative ai carichi di lavoro effettivi di qualunque oggetto del sistema si desideri monitorare, quindi analizzare i dati della registrazione per stabilire se è necessario apportare modifiche alla configurazione per garantire la massima efficienza nell'elaborazione dei messaggi.

È possibile personalizzare il processo di registrazione in base ai diversi tipi di informazioni da raccogliere. Scegliere pertanto gli oggetti di sistema che si desidera monitorare, quindi impostare i contatori per tenere traccia delle relative prestazioni. Per ottimizzare la registrazione e lasciare più tempo all'amministratore per rispondere agli eventi, è possibile impostare Monitoraggio affidabilità e Performance Monitor in modo che generi un avviso ogni volta che un contatore supera o scende al di sotto del valore specificato. Quando i dati saranno stati generati, è possibile esportarli in fogli di calcolo o database per ulteriori verifiche e analisi.

Le opzioni di monitoraggio consentono di:

  • Monitorare un singolo computer o diversi computer contemporaneamente.

  • Monitorare le prestazioni in tempo reale nella finestra del grafico oppure memorizzare i dati in registri per utilizzarli in un secondo tempo.

Per ulteriori informazioni sull'utilizzo di Monitoraggio affidabilità e Performance Monitor, consultare la documentazione di Windows Server 2008.


Monitoraggio delle prestazioni

Monitoraggio delle prestazioni
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle prestazioni e della configurazione SMTP >

È possibile monitorare l'elaborazione dei messaggi e le connessioni per il server SMTP di Windows Server 2008. Nella seguente tabella vengono descritti alcuni contatori delle prestazioni.

Contatore | Valori normali | Descrizione
Lunghezza coda locale | 0 | Questo contatore calcola il numero di messaggi contenuti nella coda locale. Se il valore è maggiore di 0, il server riceve più messaggi di quanti ne possa elaborare. Se il numero aumenta costantemente, determinare la causa del ritardo nell'elaborazione.
Lunghezza coda remota | 0 | Questo contatore calcola il numero di messaggi contenuti nella coda remota. Se il valore è maggiore di 0, il server riceve più messaggi di quanti ne possa elaborare. Se il numero aumenta costantemente, determinare la causa del ritardo nell'elaborazione.
Connessioni in ingresso correnti | Maggiore di 0 | Questo contatore calcola il numero di connessioni in ingresso correnti. Un valore pari a 0 per un periodo prolungato può indicare problemi di rete.


Monitoraggio della capacità del sistema

Monitoraggio della capacità del sistema
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle prestazioni e della configurazione SMTP >

È possibile confrontare l'utilizzo effettivo con le risorse disponibili per stabilire se nell'immediato futuro queste rischiano di diventare insufficienti. Per monitorare la capacità del server SMTP di Windows Server 2008, controllare sia le risorse fisiche sia il servizio SMTP. Una risorsa fisica raggiunge la sua capacità quando è occupata il 100% del tempo. Un servizio raggiunge la sua capacità quando le richieste di servizi iniziano a registrare dei ritardi.

Nella tabella che segue sono riportati gli oggetti da monitorare e i contatori da utilizzare.

Oggetto | Contatore | Valori normali | Descrizione
Disco logico | % Tempo disco | <70% | La percentuale di tempo in cui l'unità disco selezionata è occupata a servire richieste di lettura o scrittura. Se il valore supera continuamente il 70%, considerare la possibilità di aggiungere un altro server SMTP.
Sistema | % Tempo totale processore | <70% | La percentuale media di tempo in cui tutti i processori del sistema sono occupati a eseguire thread attivi. In un sistema multiprocessore in cui tutti i processori sono sempre occupati la percentuale media è pari al 100%. Se tutti i processori sono occupati al 50%, la percentuale media sarà pari al 50%. Se un quarto dei processori è occupato al 100%, la percentuale media sarà pari al 25%. La percentuale media è la frazione di tempo impiegata per eseguire operazioni utili. A ciascun processore è assegnato un thread inattivo del processo di inattività che consuma i cicli di processore non produttivo non utilizzati da altri thread.
Memoria | Byte disponibili | >10% della memoria totale | Indica la dimensione della memoria virtuale al momento disponibile negli elenchi Azzerata, Libera e Standby. La memoria azzerata e quella libera sono pronte per l'utilizzo, con la memoria Azzerata impostata su zero. La memoria Standby è la memoria rimossa da un processo working set, ma ancora disponibile. Si tratta di un conteggio relativo a un istante particolare e non di una media su un intervallo di tempo.


Monitoraggio delle transazioni relative ai messaggi

Monitoraggio delle transazioni relative ai messaggi
Server SMTP > Manutenzione del server SMTP >

In questa sezione viene descritto come utilizzare i registri delle transazioni per tenere traccia delle trasmissioni dei messaggi. Nella sezione sono inclusi i seguenti argomenti:

  • Panoramica sui registri di protocollo

  • Formati dei file di registro

  • Confronto tra i formati dei file di registro

  • Pianificazione dei registri di protocollo

  • Abilitazione della registrazione di protocollo


Panoramica sui registri di protocollo

Panoramica sui registri di protocollo
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi >

I registri di protocollo tengono traccia dei comandi che il server virtuale SMTP (Simple Mail Transfer Protocol) riceve dai client SMTP.

I formati disponibili sono quattro e in generale, tengono traccia delle stesse informazioni. Si differenziano però per il livello di dettaglio, il tipo di visualizzazione e il genere di analisi che consentono di effettuare. Al momento di scegliere un formato, decidere perciò quali elementi registrare, in che modo si desidera rivedere i dati raccolti e come si intende tenere traccia delle transazioni di altri servizi IIS (Internet Information Services). Per ulteriori informazioni, vedere Pianificazione dei registri di protocollo.

Il formato predefinito è il formato del file di registro esteso W3C (World Wide Web Consortium), ma è possibile sceglierne uno diverso. Per tre dei formati disponibili le transazioni vengono scritte in un file di testo ed è possibile impostare il periodo di registrazione e la dimensione massima del file. Quando viene raggiunta la dimensione massima, viene creato un nuovo file. Eseguire il backup e rimuovere i file meno recenti, in modo che lo spazio su disco non si esaurisca durante la scrittura nel file di registro delle transazioni corrente. È inoltre disponibile un quarto formato che consente di raccogliere i dati in un database conforme allo standard ODBC.

Nota:
I formati dei registri e i nomi dei file predefiniti sono quelli utilizzati da altri servizi IIS. Pianificare di quali informazioni si desidera tenere traccia per tutti i servizi, quanti file utilizzare e come impostare la dimensione dei file prima di scegliere un formato per un server virtuale SMTP. Per ulteriori informazioni, vedere Pianificazione dei registri di protocollo.


Formati dei file di registro

Formati dei file di registro
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi >

I formati disponibili per i registri delle transazioni sono quattro. Per descrizioni dettagliate dei formati ed esempi di ogni registro, vedere i seguenti argomenti:

  • Formato del file di registro Microsoft IIS

  • Formato del file di registro comune NCSA

  • Formato del file di registro esteso W3C

  • Registrazione ODBC

Per un confronto tra i formati di registro, vedere Confronto tra i formati dei file di registro.


Formato del file di registro Microsoft IIS

Formato del file di registro Microsoft IIS
Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi > Formati dei file di registro >

Di seguito viene descritto il formato del file di registro di Microsoft Internet Information Services (IIS):

  • Le informazioni vengono scritte in un file di testo ASCII delimitato da virgole.

  • I dati sono fissi: non è possibile personalizzare il registro.

  • Per ogni trasmissione vi sono più record.

Per un elenco completo delle voci, vedere Voci del file di registro di Microsoft IIS.

Esempio di formato del file di registro Microsoft IIS:

Copia codice
10.123.12.3,   Nwtraders.com,  8/18/06,  13:17:37,  SMTPSVC1, MAIL01,  10.200.200.1,  90, 42,  0,  250,  0,  MAIL FROM,  -,FROM:<someone@Nwtraders.com>,
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 0, 32, 0, 250, 0, RCPT TO, -, TO:<someone@example.com>,
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 270, 480, 101, 250, 0, DATA, -, 0019E3517201287MAIL01,
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 81, 4, 52, 0, 541, QUIT, -, MAIL01,


Voci del file di registro di Microsoft IIS

Voci del file di registro di Microsoft IIS
Monitoraggio delle transazioni relative ai messaggi > Formati dei file di registro > Formato del file di registro Microsoft IIS >

Di seguito è riportato un esempio del formato del file di registro di Microsoft Internet Information Services (IIS):

Copia codice
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<someone@Nwtraders.com>,

Nella seguente tabella sono illustrati i campi di una voce del file di registro di Microsoft IIS e un esempio di ciascuno di essi.

Campo | Esempio
Indirizzo IP del client | 10.123.12.3
Nome di dominio del client | Nwtraders.com
Data di connessione | 8/18/06
Ora di connessione | 13:17:37
Servizio IIS e numero del sito | SMTPSVC1
Nome computer del server | MAIL01
Indirizzo IP del server | 10.200.200.1
Tempo di elaborazione in millisecondi | 90
Byte ricevuti | 42
Byte inviati | 0
Codice di risposta del protocollo SMTP | 250
Stato o codice di errore Win32 | 0
Comando del protocollo SMTP | MAIL FROM
Campo facoltativo | -
Campo variabile, a seconda del comando del protocollo | FROM:<prova@Nwtraders.com>


Formato del file di registro comune NCSA

Formato del file di registro comune NCSA
Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi > Formati dei file di registro >

Di seguito viene descritto il formato del file di registro comune NCSA (National Center for Supercomputing Applications):

  • Le informazioni vengono scritte in un file di testo ASCII che utilizza il formato NCSA.

  • I dati sono fissi: non è possibile personalizzare il registro.

  • Per ogni trasmissione vi sono più record.

Per l'elenco completo delle voci, vedere Voci del formato del registro comune NSCA.

Di seguito è riportato un esempio del formato del file di registro comune NCSA:

Copia codice
10.3.5.1 -  Nwtraders.com  [18/Aug/2006:13:17:37 - 0800] "MAIL FROM -? FROM: someone HTTP/1.0"  250 0
10.3.5.1 - Nwtraders.com[18/Aug/2006:13:17:37 - 0800] "RCPT TO -? TO: someone@example.com HTTP/1.0" 250 0
10.3.5.1 - Nwtraders.com[18/Aug/2006:13:17:37 - 0800] "DATA -?000B72730441764MAIL01 HTTP/1.0" 250 97
10.3.5.1 - Nwtraders.com[18/Aug/2006:13:17:37 - 0800] "QUIT -?someone HTTP/1.0" 0 0


Voci del formato del registro comune NSCA

Voci del formato del registro comune NSCA
Monitoraggio delle transazioni relative ai messaggi > Formati dei file di registro > Formato del file di registro comune NCSA >

Di seguito è riportato un esempio del formato del file di registro comune NCSA (National Center for Supercomputing Applications):

Copia codice
10.3.5.1 - Nwtraders.com [18/Aug/2006:13:17:37 - 0800] "MAIL FROM -? FROM: someone HTTP/1.0" 250 0

Nella seguente tabella sono illustrati i campi in una voce del formato del registro comune NCSA e un esempio di ciascuno di essi.

Campo | Esempio
Indirizzo IP del client | 10.5.3.1
Nome di dominio del client | Nwtraders.com
Data e ora di connessione | [18/Aug/2006:13:17:37 - 0800]
Comando del protocollo SMTP e informazioni correlate | "MAIL FROM -? FROM: prova HTTP/1.0"
Codice di risposta del protocollo SMTP | 250
Byte inviati | 0


Formato del file di registro esteso W3C

Formato del file di registro esteso W3C
Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi > Formati dei file di registro >

In questa sezione viene illustrato il formato del file di registro esteso W3C (World Wide Web Consortium).

  • Il formato del file di registro esteso W3C è il formato di registro predefinito per il servizio SMTP di Windows Server 2008, oltre che per gli altri servizi di IIS (Internet Information Services).

  • I dati sono variabili ed è possibile scegliere di quali informazioni tenere traccia.

  • Questo formato consente di ottenere un registro di dimensione limitata.

  • Le informazioni vengono scritte in un file di testo ASCII.

  • Questo formato include alcune opzioni di campo applicabili solo ai servizi Web e FTP.

  • Per ogni trasmissione vi sono più voci.

Di seguito è riportato un esempio del formato del file di registro esteso W3C:

Copia codice
2006-08-18  13:17:37  10.3.5.1  Nwtraders.com  MAIL01,   10.200.200.1  MAIL FROM  -  -  250  -  357  0  90  -  -  -  -
2006-08-18 13:17:37 10.3.5.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 RCPT TO - +TO:+<someone@example.com> 250 0 0 33 0 - - -
2006-08-18 13:17:37 10.3.5.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 DATA - 001b60731171d87 250 0 101 1209 250 0 - - -
2006-08-18 13:17:37 10.3.5.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 QUIT - Nwtraders.com 0 3215 52 4 291 0 - - -


Voci del file di registro esteso W3C

Voci del file di registro esteso W3C
Monitoraggio delle transazioni relative ai messaggi > Formati dei file di registro > Formato del file di registro esteso W3C >

Le voci del file di registro esteso W3C (World Wide Web Consortium) sono le voci di registro predefinite per il server SMTP di Windows Server 2008 . Alcune si distinguono dalle voci Web e FTP (File Transfer Protocol). I campi che richiedono valori di testo non applicabili per il server SMTP vengono rappresentati da un trattino (-) o da uno zero (0) nel file di registro, mentre i campi che richiedono valori numerici vengono rappresentati da uno zero (0). Nella tabella seguente i campi in grassetto indicano le voci predefinite del file di registro.

Campo | Campo del registro | Descrizione
Data | date | Data di connessione
Ora | time | Ora di connessione
Indirizzo IP client | c-ip | Indirizzo IP del client che ha avuto accesso al server
Nome di dominio del client | cs-username | Client che ha avuto accesso al server
Nome servizio | s-sitename | Servizio IIS (Internet Information Services)
Nome server | s-computername | Server in cui è stata generata la voce di registro
Indirizzo IP server | s-ip | Indirizzo IP del server in cui è stata generata la voce di registro
Metodo | cs-method | Comando del protocollo SMTP (Simple Mail Transfer Protocol) inviato dal client
Origine URI | cs-uri-stem | Non applicabile per il servizio Microsoft SMTP
Query URI | cs-uri-query | Per il servizio Microsoft SMTP varia a seconda del comando del protocollo SMTP
Stato HTTP | sc-status | Codice di risposta del protocollo SMTP
Stato Win32 | sc-win32-status | Stato o codice di errore di Windows Server 2008; 0 indica la corretta esecuzione
Byte inviati | sc-bytes | Byte inviati dal server
Byte ricevuti | cs-bytes | Byte ricevuti dal server
Tempo impiegato | time-taken | Durata dell'operazione in millisecondi
Porta server | s-port | Non applicabile per il servizio SMTP
Agente utente | cs(User-Agent) | Non applicabile per il servizio SMTP
Cookie | cs(Cookie) | Non applicabile per il servizio SMTP
Provenienza | cs(Referrer) | Non applicabile per il servizio SMTP


Registrazione ODBC

Registrazione ODBC
Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi > Formati dei file di registro >

Nel seguente elenco viene descritta la registrazione ODBC (Open Database Connectivity).

  • Prima di utilizzare questo formato, è necessario configurare un database conforme allo standard ODBC.

  • Le informazioni vengono scritte in un database.

  • Per ogni trasmissione vi sono più record.

Nella tabella seguente sono riportati i campi e i tipi di dati per un file di registro delle transazioni ODBC.

Nome campo | Tipo di dati | Descrizione
ClientHost | varchar(255) | Indirizzo IP del client
Username | varchar(255) | Nome di dominio del client
LogTime | datetime | Data e ora di connessione
Service | varchar(255) | Servizio IIS (Internet Information Services)
Machine | varchar(255) | Nome del computer
ServerIP | varchar(50) | Indirizzo IP del server
ProcessingTime | integer | Tempo di elaborazione in millisecondi
BytesRecvd | integer | Byte ricevuti dal server
BytesSent | integer | Byte inviati dal server
ServiceStatus | integer | Codice di risposta del protocollo SMTP (Simple Mail Transfer Protocol)
Win32Status | integer | Codice di stato o di errore di Windows Server 2008 (0 indica la corretta esecuzione)
Operation | varchar(255) | Comando del protocollo SMTP
Target | varchar(255) | Destinatario
Parameters | varchar(255) | Nessuna descrizione disponibile


Confronto tra i formati dei file di registro

Confronto tra i formati dei file di registro
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi >

Gli esempi riportati di seguito mostrano come vengono registrati e visualizzati i dati delle transazioni dei messaggi nei formati disponibili:

  • Formato del file di registro Microsoft IIS

  • Formato del file di registro comune NCSA

  • Formato del file di registro esteso W3C

  • Registrazione OBDC

Le voci di registro per le trasmissioni SMTP (Simple Mail Transfer Protocol) in genere includono più record. Per ogni formato viene riportato un solo record in modo che le differenze tra i formati possano essere individuate più facilmente.

In questi esempi, Maria Cameron di Nwtraders.com invia un messaggio di posta elettronica a un collega il 18 agosto 2006 alle 13:17 circa.

Formato del file di registro Microsoft IIS

Copia codice
10.3.5.1, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<maria@Nwtraders.com>,

Formato del file di registro comune NCSA

Copia codice
10.3.5.1 - Nwtraders.com [18/Aug/2006:13:17:37 - 0800] "MAIL FROM -? FROM: maria HTTP/1.0 250 0

Formato del file di registro esteso W3C

Nell'esempio che segue sono riportate solo le impostazioni predefinite, ma è comunque possibile aggiungerne altre.

Copia codice
13:17:37 10.3.5.1 MAIL FROM - 250

Registrazione ODBC

Nel database sono inclusi i seguenti record:

  • Indirizzo IP del client

  • Nome di dominio del client

  • Data e ora di connessione

  • Servizio IIS

  • Nome computer del server

  • Indirizzo IP del server

  • Tempo di elaborazione in millisecondi

  • Byte ricevuti dal server

  • Byte inviati dal server

  • Codice di risposta del protocollo SMTP

  • Stato o codice di errore Win32

  • Comando del protocollo SMTP

  • Destinatario

  • Parametri


Pianificazione dei registri di protocollo

Pianificazione dei registri di protocollo
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi >

Leggere le informazioni riportate di seguito per decidere come utilizzare la registrazione per il server SMTP di Windows Server 2008 con altri servizi di IIS (Internet Information Services).

Utilizzo delle impostazioni predefinite

Se si utilizzano le impostazioni predefinite per tutti i servizi IIS, i registri delle transazioni verranno generati su base giornaliera per tutti i servizi, anche se in formato diverso. Il formato predefinito per i servizi Web e FTP è il formato di registro esteso W3C (World Wide Web Consortium). Le transazioni relative a questi servizi vengono combinate in un file utilizzando le opzioni predefinite solo per questo formato. Il formato predefinito per i server virtuali SMTP è il formato del file di registro Microsoft IIS. Le transazioni vengono registrate in un file separato.

Scelta del formato da utilizzare

I formati predefiniti per i servizi IIS sono diversi. Se si desidera combinare i record di tutti i servizi in un file, scegliere lo stesso formato per tutti i servizi. Quando si sceglie un formato, è anche necessario stabilire in che modo si desidera prendere visione dei dati. Tre dei quattro formati disponibili scrivono i record in file di testo ASCII delimitati da spazi o da virgole. Il quarto formato scrive i record in un database conforme allo standard ODBC.

Scelta della configurazione del file di registro

I fattori da considerare per la configurazione dei file di registro sono elencati nella seguente tabella.

Fattore | Descrizione
Frequenza di registrazione | Determinare se si desidera registrare i file su base giornaliera, settimanale o mensile.
Contenuto del file di registro | Determinare gli elementi da includere in un file di registro. Se si utilizzano i nomi file predefiniti per tutti i servizi IIS e lo stesso formato, i record delle transazioni possono essere combinati in un unico file di registro. Se si utilizza lo stesso formato per tutti i servizi e si desidera un file separato per i server virtuali SMTP, impostare un file separato per il registro delle transazioni.
Dimensione del file di registro | Determinare se si desidera che la dimensione del file sia illimitata oppure impostare una dimensione specifica.


Abilitazione della registrazione di protocollo

Abilitazione della registrazione di protocollo
Server SMTP > Manutenzione del server SMTP > Monitoraggio delle transazioni relative ai messaggi >

Utilizzare la scheda Generale per abilitare la registrazione di protocollo e selezionare il formato. Quando si configura il file di registro, tenere presente che i formati e i nomi dei file predefiniti sono quelli utilizzati da altri servizi IIS (Internet Information Services). Se si selezionano i nomi predefiniti, le transazioni di tutti i servizi verranno registrate nello stesso file. È invece possibile configurare un file distinto per ciascun servizio se si desidera avere registrazioni separate.

Se per il file si specifica un percorso diverso da quello predefinito, assicurarsi che sia relativo a un'unità locale e non a una rete.

Procedura

Per abilitare la registrazione in uno dei formati di testo ASCII

  1. In Microsoft Management Console selezionare il server virtuale SMTP desiderato, quindi scegliere Proprietà dal menu Azione.

  2. Nella scheda Generale selezionare la casella di controllo Attiva registro.

  3. Nell'elenco a discesa Formato registro attivo selezionare un formato del registro delle transazioni.

  4. Scegliere Proprietà, quindi impostare la dimensione e il percorso del file di registro.

  5. Se si è selezionato il formato esteso W3C (World Wide Web Consortium), fare clic sulla scheda Proprietà estese, quindi selezionare gli elementi di cui si desidera tenere traccia.

Per abilitare la registrazione in formato ODBC

  1. Configurare un database conforme allo standard ODBC. Per le istruzioni sulla configurazione di un database conforme allo standard ODBC (Open Database Connectivity), vedere Configurare un database conforme allo standard ODBC.

  2. Nella scheda Generale selezionare la casella di controllo Attiva registro.

  3. Nell'elenco a discesa Formato registro attivo selezionare Registrazione OBDC.

  4. Scegliere Proprietà, quindi impostare la dimensione e il percorso del file di registro.


Risoluzione dei problemi del server SMTP

Risoluzione dei problemi del server SMTP
Server SMTP >

In questa sezione vengono fornite informazioni sui problemi operativi più comuni con le relative soluzioni. Nella sezione sono inclusi i seguenti argomenti:

  • Suggerimenti generali per la risoluzione dei problemi

  • Recapito

  • Sistema

  • Risoluzione dei problemi del server SMTP


Suggerimenti generali per la risoluzione dei problemi

Suggerimenti generali per la risoluzione dei problemi
Server SMTP > Risoluzione dei problemi del server SMTP >

Monitorando le trasmissioni, è possibile apportare le modifiche necessarie alla configurazione ed evitare così eventuali problemi. Se dovessero comunque verificarsi degli errori, seguire i suggerimenti sotto riportati.

Verifiche regolari

È possibile configurare il sistema in modo che le trasmissioni siano verificate regolarmente e i colli di bottiglia vengano risolti prima che causino problemi.

Configurare una cassetta postale per la ricezione di rapporti di mancato recapito e messaggi non recapitabili

Non è possibile creare cassette postali nel server SMTP di Windows Server 2008. È tuttavia possibile specificare il nome e il percorso di una cassetta postale presente su un altro server per la ricezione delle copie dei rapporti di mancato recapito e dei messaggi non recapitabili. Creare ad esempio una cassetta postale in un client e denominarla Postmaster. Una volta impostata questa opzione, sarà possibile controllare continuamente i rapporti di mancato recapito e i messaggi non recapitabili e correggere tempestivamente i problemi di trasmissione. I messaggi non recapitabili hanno un'estensione bad.

Utilizzare i contatori delle prestazioni per stabilire il carico di lavoro del server e individuare eventuali colli di bottiglia

Monitoraggio affidabilità e Performance Monitor è uno strumento di grande utilità per tenere traccia delle informazioni sul flusso dei processi. Controllare con regolarità i dati dei contatori in modo da poter modificare le impostazioni della configurazione prima che si verifichino dei problemi. È possibile monitorare informazioni quali il numero dei messaggi in coda, il numero delle connessioni, il numero medio di tentativi e di destinatari, nonché il numero di byte inviati. Monitoraggio affidabilità e Performance Monitor è uno strumento di amministrazione di Windows Server 2008. Se i valori di un determinato contatore aumentano costantemente, accertarne la causa e apportare le modifiche necessarie.

Per ulteriori informazioni sull'utilizzo di Monitoraggio affidabilità e Performance Monitor, vedere Monitoraggio delle prestazioni e della configurazione SMTP.

Risoluzione dei problemi

Dopo che si è verificato un errore, procedere come segue per risalire alla causa e tentare di correggerlo.

Controllare gli eventi nel Visualizzatore eventi

I registri eventi di sistema, delle applicazioni e protezione consentono di registrare gli eventi del servizio SMTP e di altri processi del computer. Può perciò essere utile controllare gli eventi di tali registri per determinare la causa di un errore.

Controllare i file con estensione rtr nella directory della coda per stabilire perché i messaggi non vengono recapitati

I messaggi possono non essere recapitati perché un server remoto è inattivo e la coda si è riempita o per altre ragioni. Se si verifica tale problema, è possibile aprire i file transcript remoti (rtr) nella directory della coda per stabilire perché i messaggi non sono stati recapitati inizialmente e perché sono rimasti nella coda per essere nuovamente inviati.


Recapito

Recapito
Server SMTP > Risoluzione dei problemi del server SMTP >

I problemi di recapito sono in genere causati da mancanza di spazio su disco o da impostazioni dei percorsi errate. In questa sezione sono inclusi i seguenti argomenti:

  • I messaggi non vengono recapitati alla directory di destinazione

  • I messaggi non vengono recapitati a un determinato dominio remoto

  • Il routing dei messaggi remoti non avviene tramite lo SmartHost

  • È impostato un dominio di mascheramento, ma l'intestazione From non viene modificata


I messaggi non vengono recapitati alla directory di destinazione

I messaggi non vengono recapitati alla directory di destinazione
Server SMTP > Risoluzione dei problemi del server SMTP > Recapito >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | La directory o il disco è pieno.
Icona utensile: suggerimento per la risoluzione dei problemi | Svuotare la directory di destinazione e, se necessario, liberare ulteriore spazio sul disco.

Icona a forma di punto interrogativo: per ulteriori informazioni | Il percorso non è valido.
Icona utensile: suggerimento per la risoluzione dei problemi | Verificare il percorso della directory di destinazione nella finestra di dialogo delle Proprietà del dominio predefinito. La directory deve trovarsi su un'unità locale.


I messaggi non vengono recapitati a un determinato dominio remoto

I messaggi non vengono recapitati a un determinato dominio remoto
Server SMTP > Risoluzione dei problemi del server SMTP > Recapito >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | Il percorso del dominio di routing non è corretto e ciò genera l'errore "Host non raggiungibile".
Icona utensile: suggerimento per la risoluzione dei problemi | Verificare il percorso del dominio remoto nella scheda Generale della finestra di dialogo delle Proprietà del dominio.

Icona a forma di punto interrogativo: per ulteriori informazioni

Il server ricevente è inattivo o il messaggio non può essere recapitato per varie ragioni.
Icona utensile: suggerimento per la risoluzione dei problemi

Si prendano in considerazione le seguenti possibili cause:

  • Controllare i file con estensione rtr nella directory della coda per determinare la causa.

  • Controllare i contatori dei tentativi in Monitoraggio affidabilità e Performance Monitor.

  • Controllare il server ricevente.

Icona a forma di punto interrogativo: per ulteriori informazioni | Il nome non è corretto o l'indirizzo non è valido.
Icona utensile: suggerimento per la risoluzione dei problemi | Verificare il nome e il percorso.

Icona a forma di punto interrogativo: per ulteriori informazioni

Per le connessioni è richiesta la crittografia TLS (Transport Layer Security). Il certificato chiave non è valido oppure i livelli di crittografia non corrispondono.
Icona utensile: suggerimento per la risoluzione dei problemi

Si prendano in considerazione le seguenti possibili cause:

  • Controllare nelle impostazioni di Protezione recapito esterno nella finestra di dialogo delle Proprietà del dominio se l'utilizzo della crittografia TLS è stato ignorato per il dominio remoto.

  • Controllare il livello di crittografia TLS utilizzato dal certificato del servizio SMTP. Assicurarsi che corrisponda al livello richiesto dal server ricevente.


Il routing dei messaggi remoti non avviene tramite lo SmartHost

Il routing dei messaggi remoti non avviene tramite lo SmartHost
Server SMTP > Risoluzione dei problemi del server SMTP > Recapito >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | Per il dominio remoto è stato designato un dominio di routing che ha la priorità sull'impostazione dello smart host per il server virtuale SMTP.
Icona utensile: suggerimento per la risoluzione dei problemi | Modificare l'impostazione del dominio di routing. Non è possibile specificare come dominio di routing il dominio predefinito o un qualunque dominio alias.

Icona a forma di punto interrogativo: per ulteriori informazioni | Come smart host è stato impostato il dominio predefinito o un dominio alias. Non è possibile utilizzare un dominio locale per lo smart host.
Icona utensile: suggerimento per la risoluzione dei problemi | Modificare l'impostazione dello smart host nella finestra di dialogo Impostazioni avanzate recapito, a cui si accede scegliendo il pulsante Avanzate nella scheda Recapito.


È impostato un dominio di mascheramento, ma l'intestazione From non viene modificata

È impostato un dominio di mascheramento, ma l'intestazione From non viene modificata
Server SMTP > Risoluzione dei problemi del server SMTP > Recapito >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | Nell'intestazione From non compare il dominio di mascheramento.
Icona utensile: suggerimento per la risoluzione dei problemi | L'intestazione From viene modificata solo per il primo hop.


Sistema

Sistema
Server SMTP > Risoluzione dei problemi del server SMTP >

I problemi di recapito non risolti possono dare luogo a errori di sistema. In questa sezione è incluso il seguente argomento:

  • Memoria insufficiente


Memoria insufficiente

Memoria insufficiente
Server SMTP > Risoluzione dei problemi del server SMTP > Sistema >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni

I messaggi ricevuti non possono essere inviati in uscita per essere recapitati, ossia rimangono nella coda. Ciascun messaggio ricevuto viene assegnato in memoria come un oggetto di posta. Quando il messaggio viene inserito nella directory di destinazione, viene rimosso dalla memoria. Se i messaggi non possono essere recapitati e viene raggiunto il limite predefinito di 100.000 oggetti, il sistema genererà un errore di "Memoria insufficiente".
Icona utensile: suggerimento per la risoluzione dei problemi

Controllare i seguenti contatori delle prestazioni:

  • Lunghezza coda locale

  • Lunghezza coda remota

  • Lunghezza coda dei tentativi locale

  • Lunghezza coda dei tentativi remota

Se i primi due contatori indicano un valore pari a 0, significa che i messaggi vengono recapitati subito dopo la ricezione. Se il valore è più alto, significa che vi è un ritardo nel recapito.

Se le code dei tentativi hanno valori elevati, significa che i messaggi non possono essere recapitati. Aprire i file con estensione rtr per determinare la causa del problema.

Se ad esempio un server remoto è inattivo, il contatore Lunghezza coda dei tentativi remota potrebbe indicare un valore elevato e nei file con estensione rtr nella directory della coda potrebbe comparire un messaggio di errore "Host non trovato".


Risoluzione dei problemi del server SMTP

Risoluzione dei problemi del server SMTP
Server SMTP > Risoluzione dei problemi del server SMTP >

In questa sezione vengono descritti gli errori comuni alle operazioni del server SMTP di Windows Server 2008. Nella sezione sono inclusi i seguenti argomenti:

  • Il servizio SMTP si avvia, ma non il server virtuale SMTP

  • Lo snap-in SMTP non viene visualizzato in MMC

  • Nella directory della coda sono presenti file bad

  • Il client non riesce a connettersi


Il servizio SMTP si avvia, ma non il server virtuale SMTP

Il servizio SMTP si avvia, ma non il server virtuale SMTP
Server SMTP > Risoluzione dei problemi del server SMTP > Risoluzione dei problemi del server SMTP >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | Il server virtuale SMTP è stato interrotto in Microsoft Management Console e il servizio SMTP è stato interrotto e avviato dalla riga di comando.
Icona utensile: suggerimento per la risoluzione dei problemi | Riavviare il server virtuale SMTP in Microsoft Management Console. Per istruzioni su come riavviare il server virtuale SMTP in Microsoft Management Console, vedere Riavviare il server virtuale SMTP in MMC.


Riavviare il server virtuale SMTP in MMC

Riavviare il server virtuale SMTP in MMC
Risoluzione dei problemi del server SMTP > Risoluzione dei problemi del server SMTP > Il servizio SMTP si avvia, ma non il server virtuale SMTP >

In questa sezione viene spiegato come riavviare un server virtuale SMTP (Simple Mail Transfer Protocol) in Microsoft Management Console.

Procedura

Per riavviare il server virtuale SMTP in Microsoft Management Console

  1. Selezionare il server virtuale SMTP.

  2. Scegliere Avvia dal menu Azione.


Lo snap-in SMTP non viene visualizzato in MMC

Lo snap-in SMTP non viene visualizzato in MMC
Server SMTP > Risoluzione dei problemi del server SMTP > Risoluzione dei problemi del server SMTP >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | Microsoft Management Console è stato aperto dalla riga di comando.
Icona utensile: suggerimento per la risoluzione dei problemi | Aggiungere manualmente lo snap-in Internet Information Services (IIS) 6.0 con l'estensione del protocollo SMTP. Per istruzioni su come aggiungere manualmente lo snap-in e l'estensione, vedere Aggiungere lo snap-in SMTP manualmente.


Aggiungere lo snap-in SMTP manualmente

Aggiungere lo snap-in SMTP manualmente
Risoluzione dei problemi del server SMTP > Risoluzione dei problemi del server SMTP > Lo snap-in SMTP non viene visualizzato in MMC >

Procedura

In questo argomento viene descritto come aggiungere lo snap-in SMTP manualmente.

Per aggiungere lo snap-in SMTP manualmente

  1. Scegliere Aggiungi/Rimuovi snap-in dal menu Console.

  2. Nella casella Snap-in disponibili selezionare Internet Information Services (IIS) 6.0.

  3. Scegliere il pulsante Aggiungi.

  4. Dall'elenco Snap-in selezionati scegliere Internet Information Services (IIS) 6.0.

  5. Fare clic su Modifica estensioni.

  6. Selezionare Protocollo SMTP. Scegliere OK.

  7. Scegliere OK per chiudere la finestra di dialogo Aggiungi/Rimuovi snap-in.


Nella directory della coda sono presenti file bad

Nella directory della coda sono presenti file bad
Server SMTP > Risoluzione dei problemi del server SMTP > Risoluzione dei problemi del server SMTP >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | La directory della posta scartata (Badmail) è piena e i file con estensione bad rimangono nella directory della coda.
Icona utensile: suggerimento per la risoluzione dei problemi | Cancellare i messaggi dalla directory della posta scartata.


Il client non riesce a connettersi

Il client non riesce a connettersi
Server SMTP > Risoluzione dei problemi del server SMTP > Risoluzione dei problemi del server SMTP >

Tenere presenti i seguenti problemi con le cause e le soluzioni a essi associate.

Icona a forma di punto interrogativo: per ulteriori informazioni | Viene negato l'accesso a un client.
Icona utensile: suggerimento per la risoluzione dei problemi | Controllare le autorizzazioni di accesso al computer nella scheda Protezione.


Riferimento

Riferimento
Server SMTP >

Nelle sezioni seguenti vengono fornite informazioni sulle schede e sulle proprietà dell'interfaccia utente del server virtuale SMTP:

  • Scheda Generale

  • Scheda Accesso

  • Scheda Messaggi

  • Scheda Recapito

  • Scheda Routing LDAP

  • Scheda Protezione

  • Proprietà del dominio locale

  • Proprietà Dominio remoto


Scheda Generale

Scheda Generale
Server SMTP > Riferimento >

Utilizzare la scheda Generale per identificare l'indirizzo IP utilizzato dal server virtuale SMTP, configurare più identità per il server virtuale SMTP, impostare il limite e il timeout di connessione e abilitare la registrazione. Per impostazione predefinita, il server virtuale SMTP può rispondere alle richieste di connessione per tutti gli indirizzi IP configurati sul computer. Nella scheda Generale sono disponibili le seguenti opzioni.

Nome dominio completo

In questa proprietà di sola lettura viene visualizzato il nome di dominio completo (FQDN) assegnato al server virtuale SMTP. Per modificare il nome di dominio completo, selezionare la scheda Recapito e scegliere Avanzate.

Indirizzo IP

Per impostazione predefinita, il server virtuale SMTP può rispondere alle richieste di connessione per tutti gli indirizzi IP configurati sul computer. Per assegnare un indirizzo IP specifico al server virtuale SMTP, selezionare un indirizzo IP dall'elenco a discesa.

Avanzate

Selezionare questa opzione per assegnare più indirizzi IP al server virtuale SMTP o assegnare una porta TCP diversa dalla porta SMTP predefinita, ovvero la porta 25.

Limita il numero di connessioni a

Selezionare questa casella di controllo per limitare il numero massimo di connessioni simultanee in ingresso per il server virtuale SMTP, quindi digitare un valore. Il valore minimo è una connessione. Quando la casella di controllo non è selezionata, non viene imposto alcun limite. Si noti che l'impostazione di limiti per le connessioni può ostacolare l'esecuzione di operazioni dannose, quali gli attacchi Denial of Service (DoS), sul server virtuale.

Timeout connessione (minuti)

Questa impostazione consente di specificare per quanto tempo una singola connessione in ingresso può restare inattiva prima che si verifichi il timeout della connessione e che quest'ultima venga interrotta. Il valore predefinito è 10 minuti.

Attiva registro

La registrazione consente di tenere traccia dei comandi che il server virtuale SMTP riceve dai client SMTP in rete. Il controllo dell'attività del server con file di registro è un buon metodo per rilevare se utenti esterni non autorizzati stanno tentando di accedere al server virtuale o se utenti interni stanno tentando di accedere a risorse per le quali non dispongono di autorizzazioni appropriate. Selezionare la casella di controllo per abilitare la registrazione, quindi configurare le seguenti opzioni:

  • Formato registro attivo Selezionare un formato dall'elenco a discesa:

    • Formato file di registro Microsoft IIS Il file di registro viene registrato utilizzando un formato ASCII fisso.

    • Formato file di registro esteso W3C Questo è il formato predefinito del file di registro. Le informazioni vengono registrate in formato ASCII e possono essere personalizzate. Ciò consente di selezionare gli elementi di cui si desidera tenere traccia.

    • Formato file di registro comune NCSA Il file di registro viene registrato utilizzando un formato ASCII fisso.

    • Registrazione ODBC Questo formato utilizza un database conforme allo standard ODBC (Open Database Connectivity) per archiviare i dati registrati per un set fisso di campi dati.

  • Proprietà Utilizzare la finestra di dialogo Proprietà registrazione per configurare la nuova pianificazione di registro e la directory del file di registro.


Scheda Generale > Avanzate

Scheda Generale > Avanzate
Server SMTP > Riferimento > Scheda Generale >

Utilizzare la finestra di dialogo Avanzate per aggiungere, rimuovere o modificare gli indirizzi IP e i numeri di porta TCP relativi a questo server SMTP. Ciascun server virtuale viene identificato dalla relativa combinazione di indirizzo IP e porta TCP. È possibile definire indirizzi IP aggiuntivi a cui risponde questo server virtuale SMTP. Gli utenti possono connettersi al server virtuale SMTP utilizzando uno degli indirizzi IP definiti. Le seguenti opzioni della finestra di dialogo Avanzate consentono di configurare più identità per il server virtuale o modificare le identità esistenti.

Opzione | Descrizione
Indirizzo | Questa opzione consente di elencare tutti gli indirizzi IP assegnati al server virtuale SMTP, oltre alla porta TCP corrispondente a ciascun indirizzo. Gli utenti possono connettersi al server virtuale SMTP utilizzando uno degli indirizzi IP elencati.
Aggiungi | Scegliere Aggiungi per aprire la finestra di dialogo Identificazione, aggiungere un nuovo indirizzo IP e selezionare un numero di porta TCP su questo server virtuale SMTP.
Modifica | Selezionare una voce dalla tabella Indirizzo, quindi scegliere Modifica per aprire la finestra di dialogo Identificazione e modificare l'indirizzo IP, il numero della porta TCP o entrambi.
Rimuovi | Selezionare una voce dalla tabella Indirizzo, quindi scegliere Rimuovi per eliminare l'indirizzo IP selezionato.


Identificazione

Identificazione
Riferimento > Scheda Generale > Scheda Generale > Avanzate >

Utilizzare la finestra di dialogo Identificazione per specificare l'indirizzo IP e la porta TCP utilizzati per comunicare con il server virtuale SMTP. La porta 25 è la porta TCP standard del protocollo SMTP (Simple Mail Transfer Protocol) ed è la porta consigliata. Più server virtuali possono utilizzare la porta 25, purché siano associati a indirizzi IP diversi. Nella finestra di dialogo Identificazione è possibile configurare le seguenti opzioni:

Indirizzo IP

Utilizzare questa opzione per specificare gli indirizzi IP utilizzati dal server virtuale SMTP. Selezionare (Tutti non assegnati) per indicare che il server virtuale SMTP può utilizzare tutti gli indirizzi IP non assegnati ad altri server virtuali SMTP. Per selezionare un indirizzo IP specifico, selezionare dall'elenco a discesa un indirizzo IP definito sul computer in cui è in esecuzione il server SMTP di Windows Server 2008. Per configurare più indirizzi IP per un server, fare clic su Start, scegliere Pannello di controllo, quindi Centro connessioni di rete e condivisione.

Porta TCP

Digitare il numero della porta TCP utilizzata per la connessione al server virtuale SMTP. La porta predefinita è la 25. I server virtuali SMTP vengono identificati in base alla combinazione di indirizzo IP e numero di porta TCP. Pertanto più server virtuali SMTP possono utilizzare la stessa porta TCP, purché siano associati a indirizzi IP diversi. Se a un server virtuale SMTP si assegna una combinazione di indirizzo IP e numero porta TCP già in uso, tale server non verrà avviato. Affinché il nuovo numero di porta diventi effettivo, è necessario riavviare il computer.


Scheda Accesso

Scheda Accesso
Server SMTP > Riferimento >

Nella scheda Accesso è possibile configurare l'accesso del client al server virtuale SMTP e stabilire la protezione della trasmissione. Nella scheda Accesso sono disponibili le seguenti opzioni:

Controllo accesso

Questa opzione consente di selezionare uno o più metodi di autenticazione per il server virtuale SMTP. Fare clic su Autenticazione per aprire la finestra di dialogo Autenticazione e configurare le opzioni di autenticazione.

Comunicazione protetta

Selezionare la casella di controllo Richiedi crittografia TLS per abilitare la crittografia TLS (Transport Layer Security) per tutte le sessioni con questo server virtuale SMTP. Questa opzione è disponibile solo dopo che è stato emesso e installato un certificato del server per il nome di dominio completo (FQDN) per il computer.

Controllo connessione

Questa opzione consente di limitare l'accesso al server virtuale SMTP. Per impostazione predefinita, al server virtuale SMTP possono accedere tutti gli indirizzi IP. È possibile tuttavia concedere o negare l'accesso a specifici indirizzi IP, concedendo o negando allo stesso tempo l'accesso a un gruppo di dimensioni maggiori. A tale scopo, specificare un singolo indirizzo IP, un gruppo di indirizzi tramite una subnet mask o un nome di dominio. Per visualizzare le opzioni di limitazione dell'accesso, fare clic su Connessione.

Limitazioni inoltro

Il server SMTP di Windows Server 2008 impedisce ai computer di inoltrare posta indesiderata tramite il server virtuale. Per impostazione predefinita, l'inoltro viene impedito a tutti i computer tranne a quelli che soddisfano i requisiti di autenticazione. È possibile consentire l'accesso per l'inoltro al server virtuale per computer specifici, per un gruppo di indirizzi tramite una subnet mask o per un dominio. Fare clic su Inoltro per visualizzare le opzioni di limitazione dell'inoltro. È importante tenere presente che l'impostazione di accesso per l'inoltro al server virtuale SMTP può essere ignorata per un determinato dominio remoto.


Scheda Accesso > Autenticazione

Scheda Accesso > Autenticazione
Server SMTP > Riferimento > Scheda Accesso >

Utilizzare la finestra di dialogo Autenticazione per selezionare uno o più metodi di autenticazione per il server virtuale SMTP. Il server SMTP di Windows Server 2008 verifica l'identità dell'utente e concede l'accesso al server virtuale SMTP utilizzando il meccanismo di autenticazione configurato. Per impostazione predefinita è abilitato solo l'accesso anonimo. Sono disponibili le seguenti opzioni:

Accesso anonimo

Selezionare questa opzione per consentire l'accesso anonimo al server virtuale SMTP. Non è necessario specificare nome utente e password.

Autenticazione di base

Selezionare questa opzione per abilitare l'autenticazione di base (testo non crittografato). L'autenticazione di base trasmette la password con testo non crittografato. Per impedire un rilevamento non autorizzato di nomi utente e password durante la trasmissione, si consiglia di richiedere la crittografia TLS (Transport Layer Security) con l'autenticazione di base. Se si seleziona l'opzione Autenticazione di base, è possibile configurare anche le seguenti opzioni:

  • Richiedi crittografia TLS Selezionare questa casella di controllo per richiedere la crittografia TLS per le credenziali.

  • Dominio predefinito Digitare il nome di dominio utilizzato come dominio predefinito per l'autenticazione di base. Il nome di dominio verrà aggiunto al nome dell'account.

Autenticazione integrata di Windows

Selezionare questa opzione per abilitare la negoziazione tra client e server dell'interfaccia del provider supporto Protezione di Windows. Questa funzionalità di protezione consente alle aziende di fornire ai propri clienti servizi di accesso protetto. L'autenticazione integrata di Windows utilizza una tecnica di crittografia per l'autenticazione degli utenti e non richiede la trasmissione delle password effettive sulla rete.

Nota: per poter utilizzare l'Autenticazione integrata di Windows, il client di posta deve supportare tale metodo di autenticazione.


Scheda Accesso > Connessione

Scheda Accesso > Connessione
Server SMTP > Riferimento > Scheda Accesso >

Utilizzare le opzioni della finestra di dialogo Connessione per limitare l'accesso al server virtuale SMTP in base all'indirizzo IP o al nome di dominio del client. È possibile concedere l'accesso a tutti i computer con alcune eccezioni per computer specifici. Inoltre, se si nega l'accesso a tutti i computer, è comunque possibile concederlo a computer specifici. Nella finestra di dialogo Connessione sono disponibili le seguenti opzioni:

Specificare a quali computer consentire l'accesso a questo server virtuale

Selezionare una delle seguenti opzioni per controllare l'accesso a questo server virtuale:

  • Solo i computer indicati nell'elenco Selezionare questa opzione per negare l'accesso a tutte le connessioni tranne agli specifici indirizzi IP e domini aggiunti alla tabella Computer.

  • Tutti tranne quelli indicati nell'elenco Selezionare questa opzione per concedere l'accesso a tutte le connessioni tranne che agli indirizzi IP e ai domini specifici aggiunti alla tabella Computer.

Computer

Nella tabella Computer sono elencati gli indirizzi IP e i domini a cui è stato specificamente concesso o negato l'accesso. Nella colonna Accesso, accanto all'indirizzo IP o al dominio, è indicato se l'accesso è consentito o negato. Nella colonna Indirizzo IP (maschera) /Nome dominio vengono indicati gli indirizzi IP e i nomi di dominio a cui è stato specificamente concesso o negato l'accesso. Selezionare una delle seguenti opzioni per modificare la tabella Computer:

  • Aggiungi Scegliere Aggiungi per aprire la finestra di dialogo Computer e concedere o negare l'accesso a un indirizzo IP, un intervallo di indirizzi IP o un nome di dominio specifico.

  • Rimuovi Selezionare una voce relativa a un indirizzo IP o a un dominio nella tabella Computer, quindi scegliere Rimuovi per eliminarla.


Scheda Accesso > Limitazioni inoltro

Scheda Accesso > Limitazioni inoltro
Server SMTP > Riferimento > Scheda Accesso >

Utilizzare le opzioni della finestra di dialogo Limitazioni inoltro per limitare l'accesso all'inoltro tramite il server virtuale SMTP in base all'indirizzo IP o al nome di dominio del client. Per impostazione predefinita, solo gli utenti autenticati possono inoltrare la posta. È possibile concedere l'accesso all'inoltro a tutti i computer, con alcune eccezioni per computer specifici. Inoltre, se si nega l'accesso all'inoltro a tutti i computer, è comunque possibile concederlo a computer specifici.

L'inoltro non è consigliato se il server virtuale si trova su Internet. Se si abilita l'inoltro, il server virtuale potrebbe essere utilizzato per diffondere messaggi commerciali non richiesti o posta indesiderata.

Sono disponibili le seguenti opzioni:

Specificare quali computer sono autorizzati all'inoltro tramite il server virtuale

Selezionare una delle seguenti opzioni per controllare l'accesso all'inoltro tramite questo server virtuale:

  • Solo i computer indicati nell'elenco Selezionare questa opzione per negare l'accesso a tutte le connessioni tranne agli specifici indirizzi IP e domini aggiunti alla tabella Computer.

  • Tutti tranne quelli indicati nell'elenco Selezionare questa opzione per concedere l'accesso all'inoltro a tutte le connessioni tranne che agli indirizzi IP e ai domini specifici aggiunti alla tabella Computer.

Computer

Nella tabella Computer sono elencati gli indirizzi IP e i domini a cui è stato specificamente concesso o negato l'accesso all'inoltro. Nella colonna Accesso, accanto all'indirizzo IP o al dominio, è indicato se l'accesso è consentito o negato. Nella colonna Indirizzo IP (maschera) /Nome dominio vengono indicati gli indirizzi IP e i nomi di dominio a cui è stato specificamente concesso o negato l'accesso.

Selezionare una delle seguenti opzioni per modificare la tabella Computer:

  • Aggiungi Scegliere Aggiungi per aprire la finestra di dialogo Computer e concedere o negare l'accesso a un indirizzo IP, un intervallo di indirizzi IP o un nome di dominio specifico.

  • Rimuovi Selezionare una voce relativa a un indirizzo IP o a un dominio nella tabella Computer, quindi scegliere Rimuovi per eliminarla.

Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sopra

Questa casella di controllo è selezionata per impostazione predefinita. Questa opzione consente l'inoltro a chiunque sia autorizzato ad accedere al server virtuale utilizzando le proprie credenziali di autenticazione.


Finestra di dialogo Computer

Finestra di dialogo Computer
Server SMTP > Riferimento > Scheda Accesso >

La finestra di dialogo Computer consente di specificare gli indirizzi IP o i nomi di dominio ai quali si desidera concedere o negare l'accesso. È possibile specificare un singolo computer, un gruppo di computer o un nome di dominio. Nella finestra di dialogo Computer sono disponibili le seguenti opzioni.

Computer singolo

Selezionare questa opzione per concedere o negare l'accesso a un singolo computer. Se si seleziona questa impostazione, diventeranno disponibili le seguenti opzioni:

  • Indirizzo IP Immettere l'indirizzo IP di un singolo computer.

  • Ricerca DNS Se si conosce il nome del computer che si desidera aggiungere all'elenco, ma non si conosce l'indirizzo IP, fare clic su Ricerca DNS. Immettere il nome DNS del computer nella finestra visualizzata, quindi scegliere OK. Il server DNS risolverà il nome del computer in un indirizzo IP e il server SMTP popolerà automaticamente il campo Indirizzo IP.

Gruppo di computer

Selezionare questa opzione per concedere o negare l'accesso a tutti i computer di una subnet specifica. Se si seleziona questa opzione, è necessario immettere le seguenti informazioni:

  • Indirizzo subnet Immettere l'indirizzo IP di base per un gruppo di computer.

  • Subnet mask Immettere la subnet mask che definisce l'intervallo di indirizzi IP entro cui si estende l'indirizzo IP di base.

Ad esempio, se si specifica 192.168.1.0 come indirizzo di subnet e 255.255.255.0 come subnet mask, tutti i computer con un indirizzo IP compreso tra 192.168.1.1 e 192.168.1.254 vengono inclusi nel gruppo di computer.

Dominio

Selezionare questa opzione per concedere o negare l'accesso a tutti i computer di un dominio specifico. Se si seleziona questa opzione, è necessario immettere il nome del dominio nel campo Nome. Per limitare l'accesso in base al nome di dominio, è necessario eseguire una ricerca DNS al contrario su ciascuna connessione. Il sovraccarico di elaborazione aggiuntiva può influire sulle prestazioni generali del server SMTP.


Scheda Messaggi

Scheda Messaggi
Server SMTP > Riferimento >

Utilizzare le opzioni disponibili nella scheda Messaggi per configurare i limiti applicati alla dimensione dei messaggi, alla dimensione della sessione, al numero di messaggi per connessione e al numero di destinatari per messaggio. È inoltre possibile configurare le opzioni che consentono di controllare la gestione dei messaggi non recapitabili. Nella scheda Messaggi sono disponibili le seguenti opzioni:

Limita dimensione messaggi a (KB)

Selezionare questa casella di controllo per limitare la dimensione dei messaggi per questo server virtuale SMTP. Per consentire dimensioni massime illimitate, deselezionare la casella di controllo. Il server virtuale SMTP annuncerà tale valore come dimensione massima dei messaggi accettata dal server virtuale SMTP. Se un client di posta invia un messaggio che supera tale limite, verrà visualizzato un errore. Se un server remoto supporta il comando EHLO, rileverà il valore di Dimensione massima messaggio annunciato al momento della connessione al server virtuale SMTP e non tenterà nemmeno di recapitare un messaggio che superi tale limite. Il messaggio verrà invece restituito al mittente assieme a un rapporto di mancato recapito (NDR). Un server remoto che non supporta EHLO tenterà di inviare un messaggio che supera il limite di dimensione e invierà un rapporto di mancato recapito al mittente quando il messaggio non riesce a passare.

In Limita dimensione messaggi a (KB) digitare un valore in kilobyte per indicare la dimensione massima di un messaggio. Il valore predefinito è 2.048 KB. Il valore minimo consentito è 1 KB.

Limita dimensione sessione a (KB)

Selezionare questa casella di controllo per limitare la quantità massima di dati accettati durante l'intera connessione, ossia la somma di tutti i messaggi inviati durante la connessione, considerando solo il corpo del testo.

Digitare un valore maggiore di quello presente in Limita dimensione messaggi a (KB). Impostare questo valore con attenzione, dal momento che l'Agente di trasferimento messaggi (MTA) potrebbe dover inoltrare il messaggio più volte. La dimensione predefinita è 10.240 KB. Il valore minimo è uguale al valore assegnato al limite di dimensione del singolo messaggio.

Limita numero di messaggi per connessione a

Selezionare questa casella di controllo per limitare il numero di messaggi inviati nel corso di un'unica connessione. Il valore predefinito è 20. Questa funzionalità permette di migliorare le prestazioni del sistema consentendo l'utilizzo di più connessioni per il recapito dei messaggi a un dominio remoto. Una volta raggiunto il limite impostato, viene aperta automaticamente una nuova connessione e la trasmissione continua finché tutti i messaggi non sono stati recapitati. Per disabilitare questa funzionalità e non impostare alcun limite, deselezionare la casella di controllo.

Limita numero di destinatari per messaggio a

Selezionare questa casella di controllo per impostare il numero massimo di destinatari per un singolo messaggio. Il valore predefinito è 100, ossia il numero minimo richiesto specificato nella Request for Comments (RFC) 2821. Per disabilitare questa funzionalità e non impostare alcun limite, deselezionare la casella di controllo.

Quando ricevono un messaggio di errore, alcuni client restituiscono i messaggi al mittente con un rapporto di mancato recapito (NDR) indicante che il numero massimo di destinatari è stato superato. In questo caso, un server che esegue il server SMTP di Windows Server 2008 non restituisce i messaggi assieme al rapporto di mancato recapito, ma apre immediatamente una nuova connessione ed elabora i destinatari rimanenti. Se ad esempio il limite dei destinatari è impostato su 100 e il servizio riceve un messaggio con 105 destinatari, i primi 100 verranno recapitati in una connessione dopo la ricezione del messaggio di errore, quindi viene aperta una nuova connessione e il messaggio viene elaborato per i cinque destinatari rimanenti.

Invia una copia del rapporto di mancato recapito a

Quando un messaggio non è recapitabile, viene restituito al mittente con un rapporto di mancato recapito. È possibile specificare una cassetta postale SMTP a cui inviare le copie dei rapporti di mancato recapito. Specificare un indirizzo di posta elettronica per la cassetta postale.

Directory della posta scartata

Tutti i rapporti di mancato recapito vengono sottoposti allo stesso processo di recapito degli altri messaggi, inclusi i tentativi di reinvio. Se il rapporto raggiunge il limite di reinvio e non può essere recapitato al mittente, viene inserita una copia del rapporto stesso nella directory della posta scartata. I messaggi inseriti nella directory della posta scartata non possono essere recapitati né restituiti. Controllare periodicamente la directory per riconciliare i messaggi, poiché il riempimento della directory può incidere negativamente sulle prestazioni del server SMTP. Per impostazione predefinita, la directory della posta scartata è una sottocartella della directory principale della posta (Mailroot). Per selezionare un percorso alternativo per la directory della posta scartata, scegliere Sfoglia.


Scheda Recapito

Scheda Recapito
Server SMTP > Riferimento >

Dopo che è stata aperta una connessione e che il server ricevente ha confermato di essere pronto a ricevere i dati, i messaggi possono essere trasmessi per il recapito. Per impostare tutte le opzioni di recapito e routing, utilizzare la scheda Recapito della pagina Proprietà del server virtuale SMTP. Ciò include l'impostazione degli intervalli tra tentativi di recapito dei messaggi, la limitazione del numero di hop inviati ai server durante il recapito e l'identificazione di un nome di dominio di mascheramento da visualizzare nella riga From al posto del nome del dominio originale del mittente.

Nella scheda Recapito sono disponibili le seguenti opzioni:

In uscita

Utilizzare le impostazioni della sezione In uscita per configurare in che modo il server virtuale SMTP gestisce la posta ritardata. Sono disponibili le seguenti impostazioni:

  • Intervallo primo tentativo (min.) Determina i minuti di attesa trascorsi i quali il server virtuale SMTP tenta di inviare nuovamente il messaggio quando il primo tentativo di recapito non riesce. Il valore predefinito per questa impostazione è 15 minuti.

  • Intervallo tra primo e secondo tentativo (min.) Determina i minuti di attesa trascorsi i quali il server virtuale SMTP tenta di inviare nuovamente il messaggio quando il primo tentativo non riesce. Il valore predefinito per questa impostazione è 30 minuti.

  • Intervallo tra secondo e terzo tentativo (min.) Determina i minuti di attesa trascorsi i quali il server virtuale SMTP tenta di inviare nuovamente il messaggio quando il secondo tentativo non riesce. Il valore predefinito per questa impostazione è 60 minuti.

  • Intervallo tra tentativi successivi (min.) Determina i minuti di attesa trascorsi i quali il server virtuale SMTP tenta di inviare nuovamente il messaggio quando il terzo tentativo non riesce. I tentativi di recapito proseguono fino al raggiungimento del timeout di scadenza. Il valore predefinito per questa impostazione è 240 minuti.

  • Notifica di ritardo Determina l'intervallo di attesa dopo il tentativo originale di recapito della posta prima che il server virtuale SMTP invii al mittente la notifica del ritardato recapito del messaggio. Il valore predefinito per questa impostazione è 12 ore.

  • Timeout scadenza Determina l'intervallo durante il quale il server virtuale SMTP continuerà a tentare il recapito di un messaggio prima che questo scada e che venga inviato un rapporto di mancato recapito (NDR, Non-Delivery Report) al mittente del messaggio.

Locale

Utilizzare le impostazioni della casella di gruppo Locale per configurare la notifica di ritardo e il timeout di scadenza per il recapito della posta locale. Sono disponibili le seguenti opzioni:

  • Notifica di ritardo Determina l'intervallo di attesa dopo il tentativo originale di recapito della posta prima che il server virtuale SMTP invii al mittente la notifica del ritardato recapito del messaggio. Il valore predefinito per questa impostazione è 12 ore. Il valore minimo è 1 minuto, mentre il valore massimo è 9999 giorni. Utilizzare gli elenchi a discesa per impostare il valore su minuti, ore o giorni.

  • Timeout scadenza Determina l'intervallo durante il quale il server virtuale SMTP continuerà a tentare il recapito di un messaggio prima che questo scada e che venga inviato un rapporto di mancato recapito (NDR, Non-Delivery Report) al mittente del messaggio. Il valore predefinito per questa impostazione è 2 giorni. Il valore minimo è 1 minuto, mentre il valore massimo è 9999 giorni. Utilizzare gli elenchi a discesa per impostare il valore su minuti, ore o giorni.

Protezione recapito esterno

Scegliere Protezione per accedere alla finestra di dialogo Protezione recapito esterno e configurare il metodo di autenticazione e le credenziali utilizzate dal server virtuale SMTP per eseguire l'autenticazione su un server ricevente. È inoltre possibile richiedere la crittografia delle sessioni utilizzando il protocollo TLS (Transport Layer Security). Tali opzioni possono essere impostate per tutti i messaggi in uscita nella finestra di dialogo Protezione recapito esterno e ignorate per uno specifico dominio remoto nella scheda delle Proprietà del dominio. Ciò consente di impostare il livello di autenticazione e di crittografia del server virtuale SMTP in modo che sia possibile gestire la maggior parte delle trasmissioni, pur consentendo delle eccezioni per singoli indirizzi.

Connessioni esterne

Scegliere Connessioni esterne per configurare il server virtuale SMTP in modo da limitare il numero di connessioni esterne contemporanee.

Avanzate

Scegliere Avanzate per configurare le opzioni di recapito avanzate, incluso il numero massimo di hop, il dominio di mascheramento, il nome di dominio completo (FQDN, Fully Qualified Domain Name) e l'identità smart host.


Protezione posta in uscita

Protezione posta in uscita
Server SMTP > Riferimento > Scheda Recapito >

Utilizzare la finestra di dialogo Protezione posta in uscita per configurare il metodo di autenticazione e le credenziali utilizzate dal server virtuale SMTP per effettuare l'autenticazione a un server ricevente. Sono disponibili tre tipi di autenticazione:

  • Anonima

  • Di base (testo non crittografato)

  • Autenticazione integrata di Windows

L'accesso anonimo non richiede alcun tipo di autenticazione ed è l'impostazione predefinita. È possibile richiedere che le sessioni in uscita vengano sottoposte a crittografia TLS (Transport Layer Security). Tali opzioni possono essere impostate per tutti i messaggi in uscita nella finestra di dialogo Protezione recapito esterno e ignorate per uno specifico dominio remoto nella scheda delle Proprietà del dominio. Ciò consente di impostare il livello di autenticazione e di crittografia del server virtuale SMTP in modo che sia possibile gestire la maggior parte delle trasmissioni, pur consentendo delle eccezioni per singoli indirizzi.

Nella finestra di dialogo Protezione posta in uscita sono disponibili le seguenti opzioni.

Accesso anonimo

Utilizzare questa opzione per disabilitare l'autenticazione per le trasmissioni in uscita. Si tratta dell'opzione predefinita.

Autenticazione di base

Con l'opzione Autenticazione di base, il nome dell'account e la password del server a cui ci si connette vengono trasmessi come testo non crittografato. Questa impostazione deve corrispondere ai requisiti di autenticazione in ingresso del server ricevente. È necessario specificare nome utente e password. Scegliere Sfoglia per selezionare un utente.

Autenticazione integrata di Windows

Selezionare questa opzione per utilizzare l'Autenticazione integrata di Windows. Questa impostazione deve corrispondere ai requisiti di autenticazione in ingresso del server ricevente. È necessario specificare un account utente di Windows e una password. Scegliere Sfoglia per selezionare un account.

Crittografia TLS

Selezionare questa casella di controllo per applicare la crittografia TLS a tutti i messaggi in uscita.


Scheda Recapito > Connessioni esterne

Scheda Recapito > Connessioni esterne
Server SMTP > Riferimento > Scheda Recapito >

La finestra di dialogo Connessioni esterne consente di configurare le impostazioni per le connessioni in uscita su questo server virtuale SMTP. Nella finestra di dialogo Connessioni esterne sono disponibili le seguenti opzioni:

Limita il numero di connessioni a

Configurare questa impostazione per specificare il numero massimo di connessioni in uscita effettuate contemporaneamente a tutti i domini remoti. La casella di controllo è selezionata per impostazione predefinita e il limite predefinito è 1.000. Il valore minimo è di 1 connessione. Deselezionare questa casella di controllo per non impostare alcun limite al numero di connessioni in uscita.

Timeout (minuti)

Configurare questa impostazione per specificare i minuti di attesa di una risposta da parte del server ricevente al server virtuale SMTP prima della scadenza della connessione. Per impostazione predefinita, il valore di questa impostazione è di 10 minuti. Il server SMTP di Windows Server 2008 chiude la connessione se resta inattiva per il numero di minuti indicato.

Limita il numero di connessioni per dominio a

Configurare questa impostazione per specificare il numero massimo di connessioni in uscita effettuate contemporaneamente a un singolo dominio remoto. Il valore predefinito è 100. Questo valore dovrà essere inferiore o uguale al valore impostato per l'opzione Limita numero di connessioni a.

Porta TCP

Configurare questa impostazione per specificare la porta TCP utilizzata per le trasmissioni SMTP in uscita. La porta predefinita è la 25, vale a dire la porta TCP standard per SMTP.


Scheda Recapito > Impostazioni avanzate recapito

Scheda Recapito > Impostazioni avanzate recapito
Server SMTP > Riferimento > Scheda Recapito >

La finestra di dialogo Impostazioni avanzate recapito consente di impostare opzioni di routing sul server virtuale SMTP. Nella finestra di dialogo Impostazioni avanzate recapito sono disponibili le seguenti opzioni:

Numero massimo di passaggi (hop)

Quando un messaggio viene recapitato, può essere indirizzato a diversi server prima di raggiungere la destinazione finale. È possibile designare il numero massimo di server attraverso i quali può passare il messaggio. Tale impostazione viene definita numero di passaggi (hop).

Dopo aver effettuato questa impostazione, il server virtuale SMTP conta gli hop elencati nelle righe Received dell'intestazione del messaggio. Se il numero di campi Received supera l'impostazione relativa al numero massimo di hop, il messaggio viene restituito al mittente con un rapporto di mancato recapito (NDR). Per impostazione predefinita, il numero massimo di hop è 15.

Dominio di mascheramento

Il dominio di mascheramento sostituisce l'elenco dei nomi di dominio locale utilizzato nelle righe Mail From del protocollo SMTP.

Nome di dominio completo

Per identificare e verificare un computer in una rete TCP/IP, è possibile utilizzare due record:

  • Il record Mail Exchanger (MX)

  • Il record di indirizzo (A)

Il record MX identifica il nome dell'host e del dominio associati al server virtuale SMTP. Il record MX utilizza il nome di dominio completo (FQDN) per il nome di dominio. Il record A identifica l'indirizzo IP del computer. Se si utilizzano entrambi i record, la risoluzione del nome avviene più rapidamente.

Affinché il server SMTP di Windows Server 2008 elabori i record MX, è necessario designare un nome di dominio completo (FQDN). Il nome di dominio completo viene utilizzato dal DNS (Domain Name System) per identificare il server host di un dominio. La sintassi è host.dominio. Ad esempio, SocietàA.com può avere diversi server host, dei quali uno è denominato Server01. Il nome di dominio completo del server sarà Server01.SocietàA.com.

Per impostazione predefinita, il nome di dominio completo è il nome del dominio predefinito configurato per il server virtuale SMTP. Per ignorare l'impostazione relativa all'utilizzo automatico del dominio predefinito, modificare il nome di dominio completo nella scheda Recapito.

SmartHost

È possibile indirizzare tutti i messaggi in uscita diretti a domini remoti attraverso uno SmartHost, invece di inviarli direttamente al dominio. In questo modo i messaggi possono essere indirizzati attraverso una connessione che può essere più diretta o meno costosa di altre. Lo SmartHost è simile all'opzione di routing per i domini remoti. La differenza consiste nel fatto che, una volta designato uno SmartHost, tutti i messaggi in uscita vengono indirizzati a tale server. Con un dominio di routing, vengono indirizzati a un server specifico solo i messaggi destinati al dominio remoto.

Assicurarsi che lo SmartHost designato sia protetto e amministrato da un'autorità attendibile, in particolare quando si inoltrano informazioni riservate.

Se si imposta uno SmartHost, è possibile designare anche un routing diverso per un dominio remoto. L'impostazione del dominio di routing sostituisce quella dello SmartHost.

Digitare un nome di dominio completo o un indirizzo IP per identificare lo SmartHost. Se si utilizza un indirizzo IP, racchiuderlo tra parentesi quadre [ ] per migliorare le prestazioni del sistema. Il servizio SMTP cerca prima il nome di un server, quindi un indirizzo IP. Le parentesi identificano il valore come indirizzo IP, quindi la ricerca DNS viene ignorata.

Tenta il recapito diretto prima di inviare allo SmartHost

Selezionare questa opzione per tentare di recapitare i messaggi remoti direttamente prima di inoltrarli al server SmartHost. Per impostazione predefinita, tutti i messaggi remoti vengono inviati allo SmartHost e il recapito diretto non viene tentato.

Esegui ricerca DNS al contrario sui messaggi in arrivo

Se si seleziona questa opzione, il server SMTP tenta di verificare che l'indirizzo IP del client corrisponda all'host o al dominio presentato dal client nel comando EHLO/HELO. Se la ricerca DNS al contrario ha esito positivo, l'intestazione RECEIVED rimane invariata. Se la verifica ha esito negativo, nell'intestazione RECEIVED del messaggio dopo l'indirizzo IP viene visualizzato il valore "unverified". Se la ricerca DNS ha esito negativo, viene visualizzato il valore "RDNS failed" nell'intestazione RECEIVED del messaggio. Poiché questa funzionalità verifica gli indirizzi per tutti i messaggi in arrivo, il suo utilizzo può influire sulle prestazioni del server SMTP.


Scheda Routing LDAP

Scheda Routing LDAP
Server SMTP > Riferimento >

È possibile configurare un server virtuale SMTP in modo che consulti un server LDAP (Lightweight Directory Access Protocol) per risolvere mittenti e destinatari. È ad esempio possibile utilizzare il servizio directory di Active Directory come server LDAP e utilizzare lo strumento di amministrazione Utenti e computer di Active Directory per creare una lista di distribuzione di gruppo che viene espansa automaticamente sul server virtuale SMTP.

La scheda Routing LDAP consente di abilitare il routing LDAP e specificare l'identità e le proprietà del server dei servizi directory utilizzato per il server virtuale SMTP. I servizi directory archiviano le informazioni sui client di posta e le relative cassette postali. Il server virtuale SMTP utilizza il protocollo LDAP per comunicare con i servizi directory.

Per avviare il routing LDAP, selezionare la casella di controllo Attiva routing LDAP. È possibile quindi configurare i seguenti campi:

Server

Digitare il nome del computer in cui è in esecuzione la directory LDAP. Questo campo non è utilizzabile quando si utilizza il tipo di schema Servizio LDAP di Microsoft, poiché il servizio rileva un server vicino e lo utilizza automaticamente.

Schema

Selezionare il tipo di servizio directory da utilizzare. I tipi disponibili sono i seguenti:

  • Active Directory Selezionare questa opzione per utilizzare Active Directory come server LDAP. Per gestire le cassette postali, utilizzare Utenti e computer di Active Directory in Microsoft Management Console.

  • Directory di appartenenza del server al sito Selezionare questa opzione per utilizzare un server LDAP Microsoft Site Server 3.0 per la gestione delle cassette postali.

  • Servizio LDAP di Exchange Utilizzare questa opzione se il servizio LDAP di Exchange è stato installato con Microsoft Commercial Internet System 2.0 Mail e lo si utilizza per gestire le cassette postali.

Binding

Selezionare il tipo di binding. Il tipo di binding determina il livello di autenticazione del server virtuale SMTP utilizzato dal servizio directory. I tipi disponibili sono i seguenti:

  • Anonimo Il servizio directory non richiede l'invio del nome utente o della password. Questa è l'impostazione predefinita per i server virtuali SMTP creati.

  • Testo normale I valori relativi a Nome utente e Password vengono inviati al servizio directory come testo non crittografato. Questa è l'impostazione predefinita per il server virtuale SMTP predefinito.

  • Windows SSPI Il client e il server negoziano quale sia il livello di autenticazione accettabile per entrambi e utilizzano il metodo disponibile più restrittivo. Quando si seleziona questa opzione, è necessario specificare il nome utente e la password.

  • Account servizio Vengono utilizzate le credenziali dell'account utilizzato per l'esecuzione del servizio SMTP. Per accedere a tali informazioni, scegliere Strumenti di amministrazione, quindi Servizi.

Dominio

Digitare il dominio dell'account che si desidera utilizzare per il binding con la directory LDAP. Questa opzione si applica selezionando i tipi di binding Testo normale o Windows SSPI.

Nome utente

Digitare il nome distinto dell'account da utilizzare per il binding con la directory LDAP, ad esempio: cn=user1,ou=users,o=company.

Questa opzione si applica selezionando i tipi di binding Testo normale o Windows SSPI.

Password

Digitare la password utilizzata per la registrazione al servizio directory. Questa opzione si applica selezionando i tipi di binding Testo normale o Windows SSPI.

Base

Digitare il nome distinto di un contenitore del servizio directory a cui si sta accedendo. Con questa impostazione viene specificato il punto da cui il servizio SMTP deve iniziare la ricerca nella directory LDAP. La ricerca inizia nel contenitore specificato e, se necessario, prosegue nei sottocontenitori.

Ciò potrebbe essere necessario se gli account utente si trovano in un sottocontenitore all'interno della directory LDAP. La base può consentire alla directory LDAP di ottenere risultati più velocemente e, in alcuni casi, è necessaria se il server LDAP contiene più contesti dei nomi.


Scheda Protezione

Scheda Protezione
Server SMTP > Riferimento >

Utilizzare la scheda Protezione per designare gli account utente aventi le autorizzazioni di operatore per il server virtuale SMTP. Le autorizzazioni di accesso possono essere concesse a qualsiasi account esistente di Windows selezionandolo da un elenco. È possibile annullare le autorizzazioni rimuovendo l'account dall'elenco di operatori del server virtuale SMTP.

Nella scheda Protezione sono disponibili le seguenti opzioni:

Operatori

Viene visualizzato un elenco degli account utente e dei gruppi di protezione che dispongono delle autorizzazioni di operatore per il server virtuale SMTP. Gli operatori possono accedere al server virtuale SMTP e configurarlo.

Aggiungi

Scegliere Aggiungi per aprire la finestra Selezionare gli utenti e i gruppi, in cui è possibile selezionare gli account utente o i gruppi di protezione di Windows che si desidera impostare come operatori di questo server virtuale SMTP.

Rimuovi

Selezionare una voce dall'elenco Operatori, quindi scegliere Rimuovi per eliminare l'account dall'elenco di operatori del server virtuale SMTP.


Proprietà del dominio locale

Proprietà del dominio locale
Server SMTP > Riferimento >

Un dominio locale è un dominio DNS (Domain Name System) servito dal server virtuale SMTP locale. Qualsiasi messaggio in arrivo con un nome di dominio locale deve essere recapitato localmente nella directory di destinazione relativa al dominio predefinito o reinviato al mittente con un rapporto di mancato recapito (NDR). I domini locali vengono a volte indicati come domini di servizio o domini supportati. Gli indirizzi di posta elettronica con nomi di dominio locale vengono indicati come indirizzi locali.

Un dominio locale può essere configurato come dominio predefinito o come dominio alias. Il nome di dominio predefinito viene configurato quando viene creato il server virtuale SMTP. I domini alias vengono creati per fornire un'identità alternativa al dominio predefinito. Il dominio predefinito viene utilizzato per contrassegnare le intestazioni dei messaggi per cui non è stato specificato un dominio particolare. I messaggi ricevuti per il dominio alias vengono contrassegnati con le informazioni del dominio predefinito e inseriti nella directory di destinazione. Le proprietà di un dominio alias non sono configurabili. I domini alias utilizzano infatti la configurazione del dominio locale predefinito.

Nella pagina delle Proprietà del dominio locale predefinito è possibile impostare le opzioni riportate di seguito.

Directory di destinazione

Tutti i messaggi locali in arrivo vengono recapitati nella directory di destinazione impostata per il dominio predefinito. Non ci sono cassette postali.

Tutti i domini alias creati utilizzano la stessa directory di destinazione. Come directory di destinazione è possibile designare una directory qualsiasi, purché si trovi nella stessa unità del server SMTP di Windows Server 2008 e non sia già stata impostata come directory di prelievo. Per impostazione predefinita, la directory di destinazione è una sottodirectory della directory principale della posta (Mailroot). Per selezionare un percorso diverso, scegliere il pulsante Sfoglia.

Abilita quota della directory di destinazione

Se l'opzione Abilita quota della directory di destinazione è selezionata, il server SMTP riduce le dimensioni della directory di destinazione di 10 volte rispetto a quelle specificate nell'impostazione Limita dimensione messaggi a (KB) della scheda Messaggi.

Se tale limite viene superato, nel registro di protocollo verrà generata la voce "452 4.2.2 Mailbox Full" (cassetta postale piena).


Proprietà Dominio remoto

Proprietà Dominio remoto
Server SMTP > Riferimento >

Un dominio remoto è un dominio al di fuori della propria organizzazione al quale vengono inviati messaggi di posta elettronica. Se si desidera impostare requisiti di recapito univoci per un determinato dominio remoto, aggiungere il dominio e configurarlo di conseguenza. È possibile ad esempio impostare una route di recapito predeterminata, richiedere l'autenticazione e richiedere che venga utilizzata la crittografia TLS (Transport Layer Security) per tutte le connessioni a tale dominio. Se il dominio remoto non viene configurato in modo specifico, il server SMTP di Windows Server 2008 non effettuerà alcuna di queste operazioni quando recapiterà i messaggi al dominio. Completerà tuttavia una normale ricerca DNS.

Nel nome di un dominio remoto è possibile includere un asterisco (*) come primo carattere seguito da un punto (.). L'utilizzo del carattere jolly indica che tutti i domini inclusi nel dominio che si sta creando utilizzano le stesse impostazioni.

Per i domini remoti è possibile impostare le seguenti opzioni nella scheda Generale.

Consenti l'inoltro della posta in arrivo al dominio specificato

Per impostazione predefinita, il server SMTP impedisce ai computer di inoltrare la posta indesiderata al dominio remoto. Selezionare la casella di controllo Consenti l'inoltro della posta in arrivo al dominio specificato per ignorare l'impostazione relativa alle limitazioni di inoltro nella scheda Accesso.

Invia HELO invece di EHLO

ESMTP definisce un metodo di estensione del protocollo SMTP che consente a un server SMTP di informare un client SMTP sulle estensioni supportate. Un client SMTP che supporta ESMTP avvia una sessione SMTP emettendo il comando EHLO invece del comando HELO. Se la risposta ha esito positivo, viene generato un elenco di estensioni SMTP supportate dal server. Se il server non supporta ESMTP, viene generato un errore. Selezionare la casella di controllo Invia HELO invece di EHLO per comunicare solo con HELO quando si inviano messaggi al dominio remoto.

Protezione recapito esterno

È possibile ignorare le opzioni di autenticazione e crittografia TLS impostate nella scheda Recapito per un dominio remoto specifico. Ciò consente di impostare il livello di autenticazione del server virtuale SMTP per la maggior parte delle trasmissioni, pur consentendo delle eccezioni per singoli indirizzi gestiti da un determinato dominio remoto. Selezionare Protezione recapito esterno per impostare il livello di autenticazione per questo dominio remoto.

Dominio di routing

Per controllare le modalità di routing dei messaggi al dominio remoto, è possibile specificare una delle seguenti opzioni:

  • Utilizza DNS per effettuare il routing a questo dominio Selezionare questa opzione per utilizzare la risoluzione del nome DNS per individuare i server SMTP nel dominio remoto.

  • Inoltra tutta la posta a SmartHost Selezionare questa opzione per indicare che i messaggi inviati al dominio remoto vengono inoltrati a uno SmartHost. L'impostazione relativa allo SmartHost per un dominio remoto ha la priorità su quella relativa allo SmartHost del server virtuale specificata nella scheda Recapito. Digitare il nome di dominio completo o l'indirizzo IP del server tramite il quale si desidera effettuare il routing dei messaggi per questo dominio remoto.


Proprietà Dominio remoto > Avanzate

Proprietà Dominio remoto > Avanzate
Server SMTP > Riferimento > Proprietà Dominio remoto >

Nella scheda Avanzate della pagina delle proprietà del dominio remoto è possibile configurare le opzioni avanzate di recapito del messaggio per un dominio remoto.

Nella scheda Avanzate è possibile configurare le seguenti opzioni:

Accoda messaggi per recapito remoto con trigger

Selezionare questa casella di controllo per consentire al server SMTP di Windows Server 2008 di conservare la posta per i client che si connettono periodicamente per scaricare i messaggi. In questo caso il client invia un comando ATRN. Il servizio SMTP (Simple Mail Transfer Protocol) inizia quindi a inviare messaggi al dominio ATRN. È possibile creare un dominio remoto per un indirizzo per il quale il server virtuale accoda i messaggi, nonché abilitare ATRN per il dominio.

Account autorizzati a utilizzare ATRN

Con questa opzione è possibile ottenere un elenco degli account utente e dei gruppi autorizzati all'utilizzo di ATRN per questo dominio remoto. Scegliere Aggiungi o Rimuovi per concedere o negare l'autorizzazione ATRN agli utenti.

Aggiungi

Scegliere Aggiungi per aprire la finestra Selezionare gli utenti o i gruppi. Selezionare gli account utente o i gruppi di Windows a cui è stata concessa l'autorizzazione ATRN.

Rimuovi

Selezionare una voce dall'elenco Account autorizzati a utilizzare ATRN, quindi scegliere Rimuovi per eliminare l'account dall'elenco.