Gestione disco

In questa versione di Windows è possibile utilizzare Gestione disco per eseguire attività relative ai dischi, ad esempio la creazione e la formattazione di partizioni e volumi e l'assegnazione di lettere di unità. Per eseguire le attività di Gestione disco è inoltre possibile utilizzare il comando DiskPart, insieme ad altri strumenti da riga di comando.

  • Cenni preliminari su Gestione disco

  • Elenco di controllo: aggiungere un nuovo disco

  • Gestire dischi

  • Gestire volumi di base

  • Gestire volumi dinamici

  • Creare un volume con striping

  • Risolvere i problemi relativi a Gestione disco

  • Risorse su Gestione disco


Cenni preliminari su Gestione disco

Gestione disco è un'utilità di sistema per la gestione di dischi rigidi e di volumi e partizioni in essi contenuti. Con Gestione disco, è possibile inizializzare i dischi, creare volumi e formattare i volumi con file system FAT, FAT32 o NTFS. Gestione disco consente di eseguire la maggior parte delle attività relative ai dischi senza riavvio del sistema o interruzione per gli utenti. Per la maggior parte, le modifche alla configurazione diventano immediatamente effettive.

In questa versione di Windows, Gestione disco offre le stesse funzionalità eventualmente già note dalle versioni precedenti, nonché alcune nuove funzionalità aggiuntive:

  • Creazione delle partizioni semplificata. Facendo clic con il pulsante destro del mouse su un volume, si può scegliere se creare una partizione di base, con spanning o con striping direttamente dal menu.

  • Opzioni di conversione dei dischi. Quando si aggiungono più di quattro partizioni a un disco di base, viene richiesto di convertire il disco in dinamico o nello stile di partizione GPT (Tabella di partizione GUID, GUID Partition Table).

  • Possibilità di estendere e ridurre le partizioni. È possibile estendere e ridurre le partizioni direttamente dall'interfaccia Windows.

Risorse aggiuntive

  • Elenco di controllo: aggiungere un nuovo disco

  • Gestire dischi

  • Gestire volumi di base

  • Gestire volumi dinamici

  • Creare un volume con striping

  • Risolvere i problemi relativi a Gestione disco

  • Risorse su Gestione disco

  • Per informazioni più approfondite su Gestione disco, con concetti e procedure consigliate, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64097.


Elenco di controllo: aggiungere un nuovo disco

Attività | Informazioni di riferimento
Esaminare i concetti fondamentali. | Cenni preliminari su Gestione disco, http://go.microsoft.com/fwlink/?LinkId=64098
Verificare l'appartenenza al gruppo Backup Operators group o Administrators. | Cercare "account standard" e "account amministratore" in Guida e supporto tenico. Per informazioni sui gruppi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64099.
Aggiungere il nuovo disco. | http://go.microsoft.com/fwlink/?LinkId=64100
Creare partizioni o volumi. | http://go.microsoft.com/fwlink/?LinkId=64106; http://go.microsoft.com/fwlink/?LinkId=64107
Formattare i volumi del disco. | http://go.microsoft.com/fwlink/?LinkId=64101; http://go.microsoft.com/fwlink/?LinkId=64104; http://go.microsoft.com/fwlink/?LinkId=64105


Gestire dischi

In questa sezione sono incluse le attività di gestione dei dischi più comuni, ad esempio lo spostamento di dischi tra computer, la modifica dei dischi tra tipi di base e tipi dinamici e la modifica dello stile di partizione dei dischi.

Convertire i tipi di disco

Nonostante Gestione disco consenta di modificare i dischi utilizzando diversi tipi e stili di partizione, alcune operazioni sono irreversibili (a meno che non venga riformattata l'unità). È consigliabile considerare attentamente il tipo di disco e lo stile di partizione più appropriato per l'applicazione.

Per ulteriori considerazioni sull'utilizzo dei dischi di base e dei dischi dinamici, visitare i siti Web agli indirizzi http://go.microsoft.com/fwlink/?LinkId=64117 e http://go.microsoft.com/fwlink/?LinkId=64119.

Nella tabella seguente vengono illustrate le opzioni per la conversione dei dischi tra i diversi stili di partizione.

Tipo di disco | Conversione in MBR | Conversione in GPT | Conversione in dinamico
MBR (Record di avvio principale, Master Boot Record) | -- | Consentita (in assenza di volumi nel disco). | Consentita, ma il disco potrebbe risultare non avviabile. Vedere la nota.
GPT (Tabella di partizione GUID, GUID Partition Table) | Consentita (in assenza di volumi nel disco). | -- | Consentita, ma il disco potrebbe risultare non avviabile. Vedere la nota.
Nota

In uno scenario con avvio multiplo, se viene avviato un sistema operativo e si converte in disco dinamico un disco MBR di base contenente un sistema operativo alternativo, non sarà possibile avviare il sistema operativo alternativo.

Stato online e offline

In Gestione disco viene visualizzato lo stato online e offline dei dischi. In Microsoft Windows Vista per impostazione predefinita tutti i dischi appena individuati vengono connessi con accesso in lettura e scrittura. In Windows Server 2008 Enterprise e Windows Server 2008 Datacenter invece per impostazione predefinita i dischi appena individuati vengono connessi con accesso in lettura e in scrittura, a meno che non si trovino in un bus condiviso, ad esempio SCSI, iSCSI, Serial Attached SCSI o Fibre Channel. I dischi in un bus condiviso verranno disconnessi la prima volta che vengono individuati.

Se un disco è disconnesso, è necessario connetterlo per poterlo inizializzare o per creare volumi su di esso. Per connettere o disconnettere un disco, fare clic con il pulsante destro del mouse sul nome e quindi scegliere l'azione appropriata.

  • Inizializzare nuovi dischi

  • Spostare i dischi in un altro computer

  • Riattivare un disco dinamico mancante o offline

  • Modificare un disco di base in dinamico

  • Modificare un disco dinamico in disco di base

  • Modificare un disco MBR in disco GPT

  • Modificare un disco GPT in disco MBR

  • Rimuovere un disco dinamico mancante

  • Gestire i dischi in remoto

  • Gestire i dischi rigidi virtuali


Inizializzare nuovi dischi

È richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Per inizializzare nuovi dischi

  1. In Gestione disco fare clic con il pulsante destro del mouse sul disco che si desidera inizializzare e quindi scegliere Inizializza disco.

  2. Nella finestra di dialogo Inizializza disco selezionare i dischi da inizializzare. È possibile scegliere se utilizzare lo stile di partizione MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table).
Nota

Il disco verrà inizializzato come disco di base.

Ulteriori considerazioni

  • I nuovi dischi vengono visualizzati come Non inizializzato. Per poter utilizzare un disco, è innanzitutto necessario inizializzarlo. Se si avvia Gestione disco dopo l'aggiunta di un disco, verrà visualizzata l'Inizializzazione guidata disco che ne consente l'inizializzazione.


Spostare i dischi in un altro computer

In questa sezione vengono descritti i passaggi necessari per spostare i dischi in un altro computer e le considerazioni associate. Può rivelarsi utile stampare o annotare questa procedura prima di tentare lo spostamento di dischi da un computer a un altro.

Per eseguire la procedura seguente, è richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Verificare l'integrità dei volumi

Utilizzare Gestione disco per verificare che lo stato dei volumi dei dischi sia Integro. Se lo stato non è Integro, è consigliabile ripristinare i volumi prima di spostare i dischi.

Per verificare lo stato dei volumi, controllare la colonna Stato nella visualizzazione Elenco volumi o sotto le informazioni relative alla dimensione dei volumi e al file system in Visualizzazione grafica.

Disinstallare i dischi

Disinstallare i dischi che si desidera spostare mediante Gestione dispositivi.

Per disinstallare i dischi

  1. Aprire Gestione dispositivi in Gestione computer.

  2. Nell'elenco dei dispositivi fare doppio clic su Unità disco.

  3. Fare clic con il pulsante destro del mouse sui dischi che si desidera disinstallare e quindi scegliere Disinstalla.

  4. Nella finestra di dialogo Conferma rimozione dispositivo fare clic su OK.

Rimuovere dischi dinamici

Se i dischi che si desidera rimuovere sono dinamici, in Gestione disco fare clic con il pulsante destro del mouse sui dischi da rimuovere e quindi scegliere Rimuovi il disco.

Dopo la rimozione di dischi dinamici o lo spostamento di dischi di base, è possibile eseguirne la disconnessione fisica. In caso di dischi esterni, è ora possibile scollegarli dal computer. In caso di dischi interni, spegnere il computer e quindi rimuovere fisicamente i dischi.

Installare i dischi nel nuovo computer

In caso di dischi esterni, collegarli al computer. In caso di dischi interni, verificare che il computer sia spento e quindi installarvi fisicamente i dischi.

Avviare il computer contenente i dischi spostati e seguire le istruzioni della finestra di dialogo Trovato nuovo hardware.

Rilevare i nuovi dischi

Sul nuovo computer aprire Gestione disco. Scegliere Ripeti analisi dischi dal menu Azione. Fare clic con il pulsante destro del mouse su qualsiasi disco contrassegnato come Esterno e quindi scegliere Importa dischi esterni e seguire le istruzioni visualizzate.

Ulteriori considerazioni

  • Quando vengono spostati in un altro computer, ai volumi di base viene assegnata la successiva lettera di uniità disponibile in tale computer. I volumi dinamici mantengono la lettera di unità del computer precedente. Ai volumi dinamici che non disponevano di una lettera di unità nel computer precedente non viene assegnata una lettera di unità al momento dello spostamento in un altro computer. Se la lettera di unità è già in uso nel computer in cui viene spostato, al volume viene assegnata la successiva lettera di unità disponibile. Se un amministratore ha utilizzato il comando mountvol /n o diskpart automount per impedire l'aggiunta di nuovi volumi al sistema, i volumi spostati da un altro computer non verranno montati e non riceveranno una lettera di unità. Per utilizzare il volume, è necessario eseguire manualmente il montaggio del volume e l'assegnazione di una lettera di unità mediante Gestione disco o tramite i comandi DiskPart e mountvol.

  • In caso di spostamento di volumi con spanning, con striping, con mirroring o RAID-5, è consigliabile spostare tutti i dischi contenenti il volume congiuntamente. In caso contrario, i volumi non potranno essere portati online e non saranno accessibili se non per la relativa eliminazione.

  • È possibile spostare più dischi da computer diversi a un unico computer installando i dischi, aprendo Gestione disco, facendo clic con il pulsante destro del mouse su qualsiasi nuovo disco e scegliendo quindi Importa dischi esterni. Quando si importano più dischi da computer diversi, importare sempre tutti i dischi di un computer contemporaneamente. Se ad esempio si desidera spostare dischi da due computer, importare i dischi dal primo computer e quindi i dischi dal secondo computer.

  • In Gestione disco viene descritta la condizione dei volumi dei dischi prima dell'importazione. Esaminare attentamente tali informazioni. In caso di problemi, indicheranno l'impatto su ogni volume di tali dischi in seguito all'importazione dei dischi.

  • Se si sposta un discho GPT (Tabella di partizione GUID, GUID Partition Table) contenente il sistema operativo Windows in un computer basato su x86 o x64, è possibile accedere ai dati ma non eseguire l'avvio da tale sistema operativo.


Riattivare un disco dinamico mancante o offline

Un disco dinamico può risultare Mancante quando è danneggiato, spento o disconnesso.

Un disco dinamico può risultare Offline quando è danneggiato o non disponibile in modo intermittente. Un disco dinamico può inoltre diventare Offline se si tenta di importare un disco dinamico esterno e l'importazione ha esito negativo. In corrispondenza del disco dinamico Offline viene visualizzata un'icona di errore. Lo stato Mancante o Offline viene visualizzato soltanto per dischi dinamici.

Possono essere riattivati soltanto i dischi dinamici.

Per eseguire la procedura seguente, è richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Riattivare un disco dinamico mancante o offline

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per riattivare un disco dinamico tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sul disco contrassegnato come Mancante o Offline.

  2. Scegliere Riattiva disco specificato. Dopo la riattivazione, il disco verrà contrassegnato come Pronto.
Per riattivare un disco dinamico tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list disk. Annotare il numero del disco mancante o offline che si desidera portare online. I dischi mancanti presentano la numersazione M0, M1, M2 e così via, mentre ai dischi offline viene assegnata la numerazione 0, 1, 2 e così via.

  3. Al prompt DISKPART digitare select disk <disknumber>.

  4. Al prompt DISKPART digitare online.

Valore | Descrizione
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
select disk disknumber | Consente impostare lo stato attivo sul disco specificato. Il segnaposto disknumber rappresenta il numero del disco.
online | Consente di portare online un disco o un volume offline con lo stato attivo.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Modificare un disco di base in dinamico

Quando si modifica un disco di base in dinamico, è possibile creare volumi estesi su più dischi (volumi con spanning o con striping). I volumi dinamici possono essere utilizzati nella maggior parte delle situazioni, ma non in tutte.

I dischi di base supportano soltanto partizioni primarie, partizioni estese e unità logiche. I dischi di base sono supportati nei sistemi operativi da MS-DOS, mentre i dischi dinamici sono supportati nei sistemi operativi da Windows 2000.

È richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Attenzione

Non convertire in dischi dinamici i dischi che contengono più installazioni di Windows 2000, di Windows XP Professional o dei sistemi operativi della famiglia Windows Server 2003. È probabile che la seconda installazione non possa più essere avviata. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64134.

Nota

È consigliabile considerare attentamente le implicazioni della decisione di convertire un disco di base in dinamico. Per ulteriori informazioni su dischi di base e dinamici e sulla scelta del tipo da utilizzare, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64133.

Nota

Prima di convertire i dischi, chiudere tutti i programmi in esecuzione in tali dischi.

Modificare un disco di base in dinamico

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per modificare un disco di base in dinamico tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sul disco di base che si desidera convertire.

  2. Scegliere Converti in disco dinamico.

  3. Seguire le istruzioni visualizzate.

    Nota

    Se questa voce di menu non viene visualizzata, è possibile che si stia facendo clic con il pulsante destro del mouse su un volume, anziché su un disco, che il disco sia stato precedentemente convertito in dinamico o che il computer in uso sia un computer portatile. I dischi dinamici non sono supportati in computer portatili, dischi rimovibili, dischi rimovibili con interfacce USB (Universal Serial Bus) o IEEE 1394 (FireWire) o dischi connessi a bus SCSI condivisi. Non è inoltre possibile convertire in dischi dinamici i dischi di cluster connessi a bus Fibre Channel o SCSI condivisi. Il Servizio cluster supporta soltanto dischi di base.

    Attenzione

    Se si utilizza un disco di base come area di archiviazione per copie shadow e si intende convertire tale disco in dinamico, è importante prendere la precauzione seguente per evitare la perdita di dati. Se il disco è un volume non di avvio e costituisce un volume diverso rispetto a quello in cui risiedono i file originali, prima di convertire il disco contenente copie shadow in disco dinamico è innanzitutto necessario smontare e disconnettere il volume contenente i file originali. Tale volume deve essere riportato online entro 20 minuti. In caso contrario, i dati archiviati nelle copie shadow esistenti verranno persi. Se le copie shadow risiedono in un volume di avvio, è possibile convertire il disco in dinamico senza perdere le copie shadow. Il volume può essere smontato e disconnesso utilizzando il comando mountvol con l'opzione /p. È invece possibile montarlo e connetterlo mediante il comando mountvol o lo snap-in Gestione disco.

Ulteriori considerazioni

  • Per informazioni aggiuntive sulla conversione di dischi di base in dischi dinamici, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64136.

  • Dopo la conversione di un disco di base in dinamico, non è possibile modificare di nuovo i volumi dinamici in partizioni. È invece necessario eliminare tutti i volumi dinamici del disco e quindi utilizzare il comando Convert To Basic Disk. Se si desidera mantenere i dati, è innanzitutto necessario eseguirne il backup o lo spostamento in un altro volume.

  • Dopo la conversione, un disco dinamico non conterrà volumi di base (partizioni primarie o unità logiche).

  • Quando si converte un disco di base in dinamico, tutte le partizioni o le unità logiche esistenti nel disco di base diventano volumi semplici del disco dinamico.

  • Affinché la conversione abbia esito positivo, è necessario che i dischi MBR (Record di avvio principale, Master Boot Record) da convertire contenga almeno 1 MB di spazio per il database del disco dinamico.

Per modificare un disco di base in dinamico tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list disk. Annotare il numero del disco che si desidera convertire in dinamico.

  3. Al prompt DISKPART digitare select disk <disknumber>.

  4. Al prompt DISKPART digitare convert dynamic.

Valore | Descrizione
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
select disk | Consente di selezionare e attivare il disco specificato. Il segnaposto disknumber rappresenta il numero del disco.
convert dynamic | Consente di convertire un disco di base in dinamico. Tutte le partizioni esistenti nel disco diventano volumi semplici.
Attenzione

Se si utilizza un disco di base come area di archiviazione per copie shadow e si intende convertire tale disco in dinamico, è importante prendere la precauzione seguente per evitare la perdita di dati. Se il disco è un volume non di avvio e costituisce un volume diverso rispetto a quello in cui risiedono i file originali, prima di convertire il disco contenente copie shadow in disco dinamico è innanzitutto necessario smontare e disconnettere il volume contenente i file originali. Tale volume deve essere connesso entro 20 minuti. In caso contrario, i dati archiviati nelle copie shadow esistenti andranno persi. Se le copie shadow risiedono in un volume di avvio, è possibile convertire il disco in dinamico senza perdere le copie shadow. Il volume può essere smontato e disconnesso utilizzando il comando mountvol con l'opzione /p. È invece possibile montarlo e connetterlo mediante il comando mountvol o lo snap-in Gestione disco.

Ulteriori considerazioni

  • Per informazioni aggiuntive sulla conversione di dischi di base in dischi dinamici, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64136.

  • Dopo la conversione di un disco di base in dinamico, non è possibile modificare di nuovo i volumi dinamici in partizioni. È invece necessario eliminare tutti i volumi dinamici del disco e quindi utilizzare il comando Convert To Basic Disk. Se si desidera mantenere i dati, è innanzitutto necessario eseguirne il backup o lo spostamento in un altro volume.

  • Dopo la conversione, un disco dinamico non conterrà volumi di base (partizioni primarie o unità logiche).

  • Quando si converte un disco di base in dinamico, tutte le partizioni o le unità logiche esistenti nel disco di base diventano volumi semplici del disco dinamico.

  • Affinché la conversione abbia esito positivo, è necessario che i dischi MBR (Record di avvio principale, Master Boot Record) da convertire contengano almeno 1 MB di spazio per il database del disco dinamico.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Modificare un disco dinamico in disco di base

I dischi di base supportano soltanto partizioni primarie, partizioni estese e unità logiche. I dischi di base sono supportati nei sistemi operativi da MS-DOS, mentre i dischi dinamici sono supportati nei sistemi operativi da Windows 2000.

È richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Nota

È consigliabile considerare attentamente le implicazioni della decisione di convertire un disco dinamico in disco di base. Per ulteriori informazioni su dischi di base e dinamici e sulla scelta del tipo da utilizzare, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64133.

Nota

Prima di convertire i dischi, chiudere tutti i programmi in esecuzione in tali dischi.

Modificare un disco dinamico in disco di base

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per modificare un disco dinamico in disco di base tramite l'interfaccia Windows

  1. Eseguire il backup di tutti i volumi del disco che si desidera convertire da disco dinamico a disco di base.

  2. In Gestione disco fare clic con il pulsante destro del mouse su ogni volume del disco dinamico che si desidera convertire in disco di base e quindi scegliere Elimina volume per ogni volume del disco.

  3. Dopo aver eliminato tutti i volumi del disco, fare clic con il pulsante destro del mouse sul disco e quindi scegliere Converti in disco di base.

Ulteriori considerazioni

  • Per poter essere modificato in disco di base, il disco non deve contenere volumi o dati. Se si desidera mantenere i dati, eseguirne il backup o lo spostamento in un altro volume prima di convertire il disco in disco di base.

  • Dopo la modifica di un disco dinamico in disco di base, su tale disco possono essere create soltanto partizioni e unità logiche.

Per modificare un disco dinamico in disco di base tramite riga di comando

  1. Eseguire il backup di tutti i volumi del disco che si desidera convertire da dischi dinamici in dischi di base.

  2. Aprire un prompt dei comandi e digitare diskpart.

  3. Al prompt DISKPART digitare list disk. Annotare il numero del disco che si desidera convertire in disco di base.

  4. Al prompt DISKPART digitare select disk <disknumber>.

  5. Al prompt DISKPART digitare detail disk <disknumber>.

  6. Per ogni volume del disco, al prompt DISKPART digitare select volume= <volumenumber> e quindi digitare delete volume.

  7. Al prompt DISKPART digitare select disk <disknumber>. Specificare il numero del disco che si desidera convertire in un disco di base.

  8. Al prompt DISKPART digitare convert basic.

Valore | Descrizione
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
select disk disknumber | Consente di selezionare e attivare il disco specificato. Il segnaposto disknumber rappresenta il numero del disco.
detail disk disknumber | Consente di visualizzare le proprietà del disco selezionato e dei relativi volumi.
select volume disknumber | Consente di selezionare e attivare il volume specificato. Il segnaposto disknumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.
delete volume | Consente di eliminare il volume selezionato. Non è possibile eliminare il volume di sistema, il volume di avvio o qualsiasi volume contenente i dettagli di arresto anomalo del sistema (immagine della memoria) o il file di paging attivo.
convert basic | Consente di convertire un disco dinamico vuoto in un disco di base.

Ulteriori considerazioni

  • Per poter essere modificato in disco di base, il disco non deve contenere volumi o dati. Se si desidera mantenere i dati, eseguirne il backup o lo spostamento in un altro volume prima di convertire il disco in disco di base.

  • Dopo la modifica di un disco dinamico in disco di base, su tale disco possono essere create solo partizioni e unità logiche.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Modificare un disco MBR in disco GPT

I dischi MBR (Record di avvio principale, Master Boot Record) utilizzano la tabella di partizione BIOS standard. I dischi GPT (Tabella di partizione GUID, GUID Partition Table) utilizzano EFI (Extensible Firmware Interface). Un vantaggio offerto dai dischi GPT è rappresentato dal fatto che è possibile disporre di più di quattro partizioni in ogni disco. Lo stile GPT è inoltre necessario per dischi di dimensioni superiori a 2 TB.

È possibile modificare un disco passando dallo stile di partizione MBR a GPT a condizione che il disco non contenga partizioni o volumi.

Non è possibile utilizzare lo stile di partizione GPT in supporti rimovibili o dischi di cluster connessi a bus Fibre Channel o SCSI condivisi utilizzati dal Servizio cluster.

È richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Nota

Prima di convertire i dischi, chiudere tutti i programmi in esecuzione in tali dischi.

Modificare un disco MBR in disco GPT

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per modificare un disco MBR in disco GPT tramite l'interfaccia Windows

  1. Eseguire il backup o lo spostamento dei dati del disco MBR (Record di avvio principale, Master Boot Record) che si desidera convertire in un disco GPT (Tabella di partizione GUID, GUID Partition Table).

  2. Se il disco contiene partizioni o volumi, fare clic con il pulsante destro del mouse su qualsiasi volume del disco e quindi scegliere Elimina partizione o Elimina volume.

  3. Fare clic con il pulsante destro del mouse sul disco MBR che si desidera modificare in un disco GPT e quindi scegliere Converti in disco GPT.
Per modificare un disco MBR in disco GPT tramite riga di comando

  1. Eseguire il backup o lo spostamento dei dati del disco MBR (Record di avvio principale, Master Boot Record) che si desidera convertire in un disco GPT (Tabella di partizione GUID, GUID Partition Table).

  2. Aprire un prompt dei comandi e digitare diskpart. Se il disco non contiene partizioni o volumi passare al passaggio 6.

  3. Al prompt DISKPART digitare list volume. Annotare il numero del volume che si desidera eliminare.

  4. Al prompt DISKPART digitare select volume <volumenumber>.

  5. Al prompt DISKPART digitare delete volume.

  6. Al prompt DISKPART digitare list disk. Annotare il numero del disco che si desidera convertire in un disco GPT.

  7. Al prompt DISKPART digitare select disk <disknumber>.

  8. Al prompt DISKPART digitare convert gpt.
Importante

È possibile convertire in un disco GPT soltanto dischi MBR di base senza partizioni o volumi. Eseguire il backup dei dati e quindi eliminare tutte le partizioni o i volumi prima di convertire il disco.

Valore | Descrizione
list volume | Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.
select volume | Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.
delete volume | Consente di eliminare il volume selezionato. Non è possibile eliminare il volume di sistema, il volume di avvio o qualsiasi volume contenente i dettagli di arresto anomalo del sistema (immagine della memoria) o il file di paging attivo.
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
select disk disknumber | Consente di selezionare e attivare il disco specificato. Il segnaposto disknumber rappresenta il numero del disco.
convert gpt | Consente di convertire un disco di base vuoto con stile di partizione MBR in un disco di base con stile di partizione GPT.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Modificare un disco GPT in disco MBR

I dischi MBR (Record di avvio principale, Master Boot Record) utilizzano la tabella di partizione BIOS standard. I dischi GPT (Tabella di partizione GUID, GUID Partition Table) utilizzano EFI (Extensible Firmware Interface). I dischi MBR non supportano più di quattro partizioni in ogni disco. Il metodo di partizione MBR è sconsigliato per dischi di dimensioni superiori a 2 TB.

È possibile modificare un disco passando dallo stile di partizione GPT a MBR a condizione che il disco sia vuoto e non contenga volumi.

È richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Nota

Prima di convertire i dischi, chiudere tutti i programmi in esecuzione in tali dischi.

Modificare un disco GPT in disco MBR

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per modificare un disco GPT in disco MBR tramite l'interfaccia Windows

  1. Eseguire il backup o lo spostamento di tutti i volumi del disco GPT (Tabella di partizione GUID, GUID Partition Table) che si desidera convertire in un disco MBR (Record di avvio principale, Master Boot Record).

  2. Se il disco contiene partizioni o volumi, fare clic con il pulsante destro del mouse su qualsiasi volume del disco e quindi scegliere Elimina volume.

  3. Fare clic con il pulsante destro del mouse sul disco GPT che si desidera modificare in un disco MBR e quindi scegliere Converti in disco MBR.
Per modificare un disco GPT in disco MBR tramite riga di comando

  1. Eseguire il backup o lo spostamento di tutti i volumi del disco GPT (Tabella di partizione GUID, GUID Partition Table) che si desidera convertire in un disco MBR (Record di avvio principale, Master Boot Record).

  2. Aprire un prompt dei comandi e digitare diskpart. Se il disco non contiene partizioni o volumi passare al passaggio 6.

  3. Al prompt DISKPART digitare list volume. Annotare il numero del volume che si desidera eliminare.

  4. Al prompt DISKPART digitare select volume <volumenumber>.

  5. Al prompt DISKPART digitare delete volume.

  6. Al prompt DISKPART digitare list disk. Annotare il numero del disco che si desidera convertire in un disco GPT.

  7. Al prompt DISKPART digitare select disk <disknumber>.

  8. Al prompt DISKPART digitare convert mbr.

    Importante

    Il disco da convertire in un disco MBR deve essere vuoto. Eseguire il backup dei dati e quindi eliminare tutte le partizioni o i volumi prima di convertire il disco.

Valore | Descrizione
list volume | Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.
select volume | Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.
delete volume | Consente di eliminare il volume selezionato. Non è possibile eliminare il volume di sistema, il volume di avvio o qualsiasi volume contenente i dettagli di arresto anomalo del sistema (immagine della memoria) o il file di paging attivo.
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
select disk | Consente di selezionare e attivare il disco specificato. Il segnaposto disknumber rappresenta il numero del disco.
convert mbr | Consente di convertire un disco di base vuoto con stile di partizione GPT in un disco di base con stile di partizione MBR.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Rimuovere un disco dinamico mancante

Un disco dinamico può risultare Mancante quando è danneggiato, spento o disconnesso.

È richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Importante

Non eliminare i volumi da un disco dinamico mancante a meno che non si sia verificato che il disco non verrà acceso, riconnesso, riparato o ripristinato in altro modo nel computer. In caso contrario, non sarà possibile accedere a tali volumi in seguito al ripristino del disco.

Rimuovere un disco dinamico mancante

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per rimuovere un disco dinamico mancante tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse su ogni volume del disco dinamico contrassegnato come Mancante e quindi scegliere Elimina volume per rimuovere tutti i volumi del disco Mancante.

  2. Fare clic con il pulsante destro del mouse sul disco dinamico contrassegnato come Mancante e quindi scegliere Rimuovi il disco.
Per rimuovere un disco dinamico mancante tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list disk. Annotare il numero del disco che si desidera rimuovere dall'elenco dei dischi. I dischi mancanti presentano la numerazione M0, M1, M2 e così via.

  3. Al prompt DISKPART digitare select disk <disknumber>.

  4. Al prompt DISKPART digitare delete disk.

Valore | Descrizione
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
select disk disknumber | Consente di selezionare e attivare il disco specificato. Il segnaposto disknumber rappresenta il numero del disco.
delete disk | Consente di eliminare un disco dinamico mancante dall'elenco dei dischi.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Gestire i dischi in remoto

In questa sezione viene descritto come utilizzare Gestione disco in un computer per gestire i dischi in un altro computer.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Backup Operators o Administrators oppure a un gruppo equivalente.

Gestire i dischi in remoto

Per gestire i dischi in un computer remoto utilizzando Gestione disco nel computer locale, è necessario che il computer remoto supporti il Servizio dischi virtuali (VDS, Virtual Disk Service). In caso contrario, è possibile utilizzare Connessione desktop remoto per effettuare la connessione al computer e quindi eseguire Gestione disco direttamente nel computer remoto.

Per gestire i dischi in computer remoti che supportano il servizio VDS, è necessario configurare Windows Firewall sia nel computer locale in cui è in esecuzione Gestione disco sia nel computer remoto.

Nel computer locale configurare Windows Firewall in modo da attivare l'eccezione Gestione volumi remota.

Nota

L'eccezione Gestione volumi remota include le eccezioni per Vds.exe, Vdsldr.exe e per la porta TCP 135.

Sistema operativo del computer remoto Configurazione di Windows Firewall

Windows Server 2008, Windows Server 2008 con Service Pack 1 (SP1), Windows Server 2008 con SP2, Microsoft Windows Vista, Microsoft Windows Vista con SP1, Microsoft Windows Vista con SP2, Windows Server 2008 R2, Windows 7

Attivare l'eccezione Gestione volumi remota.

Microsoft Windows Vista

Attivare l'eccezione Gestione volumi remota.

Attivare l'eccezione Condivisione file e stampanti.

Windows Server 2003 con SP1

Attivare le eccezioni seguenti:

  • Porta TCP 135

  • Vds.exe

Nota

Le connessioni remote in gruppi di lavoro non sono supportate. Il computer locale e quello remoto devono trovarsi entrambi in un dominio.

Ulteriori riferimenti

  • Gestire dischi


Gestire i dischi rigidi virtuali

Il formato Disco rigido virtuale (VHD, Virtual Hard Disk) è una specifica pubblica relativa al formato delle immagini che consente di specificare un disco rigido virtuale incapsulato in un singolo file, in grado di ospitare file system nativi e supportare operazioni sui file e del disco standard. In genere, i file VHD sono utilizzati ad esempio con la funzionalità Hyper-V di Windows Server 2008 R2. Per ulteriori informazioni sui file VHD, vedere Ulteriori riferimenti.

È possibile utilizzare Gestione disco per creare, collegare e scollegare dischi rigidi virtuali.

Per eseguire queste procedure, è necessaria almeno l'appartenenza al gruppo Backup Operators o Administrators oppure a un gruppo equivalente.

Visualizzare i dischi rigidi virtuali in Gestione disco

In Gestione disco i dischi rigidi virtuali vengono visualizzati esattamente come i dischi fisici. Quando un disco rigido virtuale viene collegato, e quindi reso disponibile per l'utilizzo da parte del sistema, la relativa icona diventa blu. Se viene scollegato, e quindi reso non disponibile, l'icona appare nuovamente grigia.

Creare un file VHD

Per creare un file VHD

  1. Scegliere Crea file VHD dal menu Azione.

  2. Nella finestra di dialogo Crea e collega disco rigido virtuale specificare il percorso nel computer fisico in cui si desidera archiviare il file VHD e la dimensione di tale file.

  3. In Formato disco rigido virtuale selezionare A espansione dinamica o A dimensione fissa e quindi fare clic su OK.

Collegare e scollegare un file VHD

Per rendere disponibile per l'utilizzo un file VHD appena creato o esistente, scegliere Collega file VHD dal menu Azione e quindi specificare il percorso completo del file.

Per scollegare il file VHD e renderlo non disponibile, scegliere Scollega file VHD dal menu Azione oppure fare clic con il pulsante destro del mouse sul VHD nell'elenco dei volumi o nella visualizzazione grafica e quindi scegliere Scollega file VHD. Lo scollegamento di un file VHD non comporta l'eliminazione del file né dei dati in esso archiviati.

Ulteriori considerazioni

  • Il percorso che specifica la posizione del file VHD deve essere completo e non può trovarsi nella directory \Windows.

  • La dimensione minima di un VHD è 3 MB.

  • Un VHD può essere solo un disco di base.

  • Poiché un VHD viene inizializzato dopo essere stato creato, la creazione di file VHD fissi di grandi dimensioni potrebbe richiedere alcuni minuti.

Ulteriori riferimenti

  • Specifica relativa al formato delle immagini dei dischi rigidi virtuali (http://go.microsoft.com/fwlink/?LinkId=139201)

  • Glossario della guida per l'amministratore di Virtual Server 2005 (http://go.microsoft.com/fwlink/?LinkId=143882)


Gestire volumi di base

Un disco di base è un disco fisico che contiene partizioni primarie, partizioni estese o unità logiche. Partizioni e unità logiche dei dischi di base vengono denominate volumi di base. Su dischi di base è possibile creare soltanto volumi di base.

È possibile aggiungere più spazio a unità logiche e partizioni primarie esistenti estendendole nello spazio non allocato contiguo adiacente sullo stesso disco. Per estendere un volume di base, è necessario che il volume sia formattato con il file system NTFS. È possibile estendere un'unità logica all'interno dello spazio disponibile contiguo nella partizione estesa in cui è contenuta. In caso di estensione di un'unità logica oltre lo spazio disponibile nella partizione estesa, la partizione estesa viene espansa in modo da contenere l'unità logica, a condizione che la partizione estesa sia seguita da spazio non allocato contiguo.

  • Assegnare un percorso per cartella di punto di montaggio a un'unità

  • Estendere un volume di base

  • Ridurre un volume di base


Assegnare un percorso per cartella di punto di montaggio a un'unità

È possibile utilizzare Gestione disco per assegnare all'unità un percorso per cartella di punto di montaggio anziché una lettera di unità. I percorsi per cartelle di punti di montaggio sono disponibili solo per cartelle vuote in volumi NTFS di base o dinamici.

È richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Assegnare un percorso per cartella di punto di montaggio a un'unità

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per assegnare un percorso per cartella di punto di montaggio a un'unità tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sulla partizione o sul volume in cui si desidera assegnare il percorso per cartella di punto di montaggio e quindi scegliere Cambia lettera e percorso di unità.

  2. Eseguire una delle operazioni seguenti:

    • Per assegnare un percorso per cartella di punto di montaggio, fare clic su Aggiungi. Fare clic su Monta in questa cartella vuota NTFS e quindi digitare il percorso di una cartella vuota in un volume NTFS o fare clic su Sfoglia per individuarla.

    • Per rimuovere il percorso per cartella di punto di montaggio, selezionarlo e quindi fare clic su Rimuovi.

Ulteriori considerazioni

  • Se si amministra un computer locale o remoto, è possibile esplorare le cartelle NTFS in tale computer.

  • Quando si assegna un percorso per cartella di punto di montaggio a un'unità, utilizzare il Visualizzatore eventi per ricercare nel registro eventi di sistema eventuali errori o avvisi del Servizio cluster che indicano errori del punto di montaggio. Tali errori verranno inclusi nell'elenco con ClusSvc nella colonna Origine e Risorsa disco fisico nella colonna Categoria.

Per assegnare un percorso per cartella di punto di montaggio a un'unità tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list volume. Annotare il numero del volume di cui si desidera modificare l'assegnazione del percorso.

  3. Al prompt DISKPART digitare select volume <numerovolume>. Selezionare il volume semplice volumenumber a cui si desidera assegnare il percorso.

  4. Al prompt DISKPART digitare assign [mount=<percorso>].

Valore Descrizione

list volume

Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.

select volume

Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso per cartella di punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.

assign

Consente di assegnare una lettera di unità o un percorso per cartella di punto di montaggio al volume con lo stato attivo. Se non si specifica alcuna lettera di unità o alcun percorso per cartella di punto di montaggio, verrà assegnata la successiva lettera di unità disponibile. Se la lettera di unità o il percorso per cartella di punto di montaggio è già in uso, verrà generato un errore.

Utilizzando il comando assign è possibile cambiare la lettera di unità associata a un'unità rimovibile.

Non è possibile assegnare lettere di unità a volumi di avvio o a volumi contenenti il file di paging. Non può inoltre essere assegnata una lettera di unità a una partizione del produttore dell'hardware originale (OEM), a una partizione di sistema EFI o a qualsiasi partizione GPT diversa dalla partizione di dati di base.

mount=path

Consente di specificare una cartella NTFS vuota esistente in cui risiederà l'unità montata.

Ulteriori considerazioni

  • I percorsi per cartelle di punti di montaggio sono disponibili solo per cartelle vuote in volumi NTFS di base o dinamici.

  • Per modificare un percorso per cartella di punto di montaggio, rimuoverlo e creare un nuovo percorso per cartella utilizzando la nuova posizione. Il percorso per cartella di punto di montaggio non può essere modificato direttamente.

  • Quando si assegna un percorso per cartella di punto di montaggio a un'unità, utilizzare il Visualizzatore eventi per ricercare nel registro eventi di sistema eventuali errori o avvisi del Servizio cluster che indicano errori del percorso per cartella di punto di montaggio. Tali errori verranno inclusi nell'elenco con ClusSvc nella colonna Origine e Risorsa disco fisico nella colonna Categoria.

  • È inoltre possibile creare un'unità montata specificando il comando mountvol. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?linkid=64111.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Estendere un volume di base

È possibile aggiungere più spazio a unità logiche e partizioni primarie esistenti estendendole nello spazio non allocato adiacente sullo stesso disco. Per estendere un volume di base, è necessario che il volume sia non formattato oppure formattato con il file system NTFS. È possibile estendere un'unità logica all'interno dello spazio disponibile contiguo nella partizione estesa in cui è contenuta. In caso di estensione di un'unità logica oltre lo spazio disponibile nella partizione estesa, la partizione estesa viene espansa in modo da contenere l'unità logica.

Per unità logiche e volumi di avvio o di sistema, è possibile estendere il volume soltanto nello spazio continguo e solo se può essere eseguito l'aggiornamento del disco a disco dinamico. Per gli altri volumi, è possibile estendere il volume in spazio non contiguo, ma verrà richiesta la conversione del disco in dinamico.

Estendere un disco di base

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per estendere un volume di base tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sul volume di base che si desidera estendere.

  2. Scegliere Estendi volume.

  3. Seguire le istruzioni visualizzate.
Per estendere un volume di base tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list volume. Annotare il volume di base che si desidera estendere.

  3. Al prompt DISKPART digitare select volume <volumenumber>. Viene selezionato il volume di base volumenumber che si desidera estendere nello spazio vuoto contiguo sullo stesso disco.

  4. Al prompt DISKPART digitare extend [size=<size>]. Il volume selezionato viene esteso di size MB.

Valore Descrizione

list volume

Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.

select volume

Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.

extend

Consente di estendere il volume con lo stato attivo nello spazio non allocato contiguo. Per i volumi di base, lo spazio non allocato deve essere disponibile nello stesso disco della partizione con lo stato attivo e deve seguire quest'ultima, ovvero presentare un offset di settore più elevato di tale partizione. Un volume dinamico semplice o con spanning può essere esteso in qualsiasi spazio vuoto di qualsiasi disco dinamico. Mediante questo comando è possibile estendere un volume esistente nel nuovo spazio creato.

Se la partizione è stata precedentemente formattata con il file system NTFS, il file system viene esteso automaticamente in modo da occupare la partizione più grande. Non si verifica alcuna perdita di dati. Se la partizione è stata precedentemente formattata con un formato di file system diverso da NTFS, il comando ha esito negativo e non viene apportata alcuna modifica alla partizione.

Non è possibile estendere le partizioni di sistema o di avvio correnti.

size= size

Quantità di spazio, espressa in megabyte (MB), da aggiungere alla partizione corrente. Se non si specifica una dimensione, il disco verrà esteso in modo da occupare tutto lo spazio non allocato contiguo.

Ulteriori considerazioni

  • Per estendere un volume di base, è necessario che il volume non sia formattato con un file system oppure sia formattato con il file system NTFS.

  • Se il disco non contiene partizioni di avvio o di sistema, è possibile estendere il volume in altri dischi non di avvio o non di sistema, ma il disco verrà convertito in disco dinamico, se aggiornabile.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Ridurre un volume di base

È possibile diminuire lo spazio utilizzato da unità logiche e partizioni primarie esistenti riducendole nello spazio contiguo adiacente sullo stesso disco. Se ad esempio si individua l'esigenza di una partizione aggiuntiva ma non si dispone di dischi aggiuntivi, è possibile ridurre la partizione esistente dalla fine del volume in modo da creare nuovo spazio non allocato utilizzabile per una nuova partizione. L'operazione di riduzione può essere bloccata dalla presenza di determinati tipi di file. Per ulteriori informazioni, vedere Ulteriori considerazioni.

Quando si riduce una partizione, tutti i file ordinari vengono automaticamente rilocati sul disco in modo da creare il nuovo spazio non allocato. Per ridurre la partizione, non è necessario riformattare il disco.

Per eseguire queste procedure, è necessaria almeno l'appartenenza al gruppo Backup Operators o Administrators oppure a un gruppo equivalente.

Attenzione

Se la partizione non è elaborata, ovvero non dispone di file system, e contiene dati, ad esempio un file di database, la riduzione della partizione potrebbe determinare l'eliminazione dei dati.

Ridurre un volume di base

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per ridurre un volume di base tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sul volume di base che si desidera ridurre.

  2. Scegliere Riduci volume.

  3. Seguire le istruzioni visualizzate.

    Nota

    È possibile ridurre soltanto volumi di base che non dispongono di file system o utilizzano il file system NTFS.

Ulteriori considerazioni

  • Quando si riduce una partizione, determinati file (ad esempio il file di paging o l'area di archiviazione di copie shadow) non possono essere riallocati automaticamente e non è possibile diminuire lo spazio allocato oltre il punto in cui si trovano i file fissi. Se l'operazione di riduzione non riesce, controllare l'evento 259 nel registro applicazioni per identificare il file fisso. Se si conoscono il cluster o i cluster associati al file che impedisce l'operazione di riduzione, è inoltre possibile utilizzare il comando fsutil al prompt dei comandi. Digitare fsutil volume querycluster /? per informazioni sull'utilizzo. Quando si specifica il parametro querycluster, l'output del comando identificherà il file fisso che impedisce la corretta esecuzione dell'operazione di riduzione.

    In alcuni casi è possibile riallocare il file temporaneamente. Se, ad esempio, il file fisso è il file di paging, è possibile utilizzare il Pannello di controllo per spostarlo in un altro disco, ridurre il volume e quindi rispostare il file di paging nel disco.

  • Se il numero di cluster danneggiati rilevati dal nuovo mapping dinamico è eccessivo, non sarà possibile ridurre la partizione. In tal caso, è possibile spostare i dati e sostituire il disco.

    Non utilizzare una copia a livello di blocco per il trasferimento dei dati. In caso contrario, verrà copiata anche la tabella dei settori danneggiati e il nuovo disco considererà danneggiati tali settori anche se in realtà non presentano problemi.

  • È possibile ridurre partizioni primarie e unità logiche in partizioni non elaborate, ovvero senza file system, o partizioni con file system NTFS.

Per ridurre un volume di base tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list volume. Annotare il numero del volume semplice che si desidera ridurre.

  3. Al prompt DISKPART digitare select volume <volumenumber>. Viene selezionato il volume semplice volumenumber che si desidera ridurre.

  4. Al prompt DISKPART digitare shrink [desired=<desiredsize>] [minimum=<minimumsize>]. Il volume selezionato viene così ridotto a desiredsize MB, se possibile, o a minimumsize se il valore di desiredsize è troppo elevato.

Valore | Descrizione
list volume | Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.
select volume | Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.
shrink | Consente di ridurre il volume con lo stato attivo in modo da creare spazio non allocato. Non si verifica alcuna perdita di dati. Se la partizione include file fissi (ad esempio, il file di paging o l'area di archiviazione di copie shadow), il volume verrà ridotto fino al punto in cui si trovano i file fissi.
desired= desiredsize | Quantità di spazio, espressa in MB, da recuperare per la partizione corrente.
minimum=minimumsize | Quantità minima di spazio, espressa in MB, da recuperare per la partizione corrente. Se non si specifica una dimensione desiderata o minima, mediante il comando verrà recuperata la massima quantità di spazio possibile.

Ulteriori considerazioni

  • Quando si riduce una partizione, i file fissi (ad esempio il file di paging o l'area di archiviazione di copie shadow) non vengono riallocati automaticamente e non è possibile diminuire lo spazio allocato oltre il punto in cui si trovano i file fissi. Se è necessario ridurre ulteriormente la partizione, spostare il file di paging in un altro disco, eliminare le copie shadow archiviate, ridurre il volume e quindi spostare di nuovo il file di paging sul disco.

  • Se il numero di cluster danneggiati rilevati dal nuovo mapping dinamico è eccessivo, non sarà possibile ridurre la partizione. In tal caso, è possibile spostare i dati e sostituire il disco.

    Non utilizzare una copia a livello di blocco per il trasferimento dei dati. In caso contrario, verrà copiata anche la tabella dei settori danneggiati e il nuovo disco considererà danneggiati tali settori anche se in realtà non presentano problemi.

  • È possibile ridurre partizioni primarie e unità logiche in partizioni non elaborate, ovvero senza file system, o partizioni con file system NTFS.

Ulteriori riferimenti

  • Gestire volumi di base


Gestire volumi dinamici

  • Gestire volumi semplici

  • Gestire volumi con spanning


Gestire volumi semplici

Un volume semplice è un volume dinamico costituito da spazio su disco di un singolo disco dinamico. Un volume semplice può includere una singola regione di un disco o più regioni collegate dello stesso disco.

  • Creare un volume semplice

  • Creare un volume semplice

  • Ridurre un volume semplice o con spanning


Creare un volume semplice

Un volume semplice è un volume dinamico costituito da spazio su disco di un singolo disco dinamico. Un volume semplice può includere una singola regione di un disco o più regioni collegate dello stesso disco. I volumi semplici possono essere creati soltanto su dischi dinamici

e non sono a tolleranza di errore.

Per eseguire le operazioni seguenti, è richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Creare un volume semplice

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per creare un volume semplice tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sullo spazio non allocato del disco dinamico in cui si desidera creare il volume semplice e quindi scegliere Nuovo volume semplice.

  2. Nella Creazione guidata nuovo volume fare clic su Avanti e su Semplice e quindi seguire le istruzioni visualizzate.
Per creare un volume semplice tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list disk. Annotare il numero del disco in cui si desidera creare un volume semplice.

  3. Al prompt DISKPART digitare create volume simple [size=<size>] [disk=<disknumber>].

  4. Al prompt DISKPART digitare assign letter=<driveletter>.

Valore | Descrizione
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
create volume simple | Consente di creare un volume semplice. Al termine della creazione del volume, lo stato attivo passa automaticamente al nuovo volume.
size= size | Dimensione del volume in megabyte (MB). Se non si specifica alcuna dimensione, il nuovo volume occuperà lo spazio disponibile su disco residuo.
disk= disknumber | Disco dinamico in cui creare il volume. Se non si specifica alcun disco, verrà utilizzato il disco corrente.
assign letter=driveletter | Consente di assegnare una lettera di unità driveletter al volume con lo stato attivo. Se non si specifica alcuna lettera di unità o alcun punto di montaggio, verrà assegnata la successiva lettera di unità disponibile. Se la lettera di unità o il punto di montaggio è già in uso, verrà generato un errore.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Estendere un volume semplice o con spanning

Un volume con spanning è un volume dinamico costituito da spazio su disco in uno o più dischi fisici. Se non è un volume di sistema o di avvio, un volume semplice può essere esteso in dischi aggiuntivi. Estendendo un volume semplice in più dischi, si crea un volume con spanning.

È possibile estendere un volume solo in assenza di file system o in caso di formattazione mediante il file system NTFS. Non è possibile estendere volumi formattati con FAT o FAT32.

Per eseguire le operazioni seguenti, è richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Estendere un volume semplice o con spanning

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per estendere un volume semplice o con spanning tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sul volume semplice o con spanning che si desidera estendere.

  2. Scegliere Estendi volume.

  3. Seguire le istruzioni visualizzate.
Per estendere un volume semplice o con spanning tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list volume. Annotare il numero del volume semplice che si desidera estendere in un altro disco.

  3. Al prompt DISKPART digitare select volume <volumenumber>. Viene selezionato il volume semplice volumenumber che si desidera estendere in un altro disco.

  4. Al prompt DISKPART digitare list disk. Annotare il numero del disco in cui si desidera estendere il volume semplice.

  5. Al prompt DISKPART digitare extend [size=<size>] [disk=<disknumber>]. Il volume selezionato viene estenso nel disco disknumber, con estensione pari a size=size MB.

Valore Descrizione

list volume

Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.

select volume

Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.

list disk

Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.

extend

Consente di estendere il volume con lo stato attivo nello spazio non allocato contiguo. Per i volumi di base, lo spazio non allocato deve essere disponibile nello stesso disco della partizione con lo stato attivo e deve seguire quest'ultima, ovvero presentare un offset di settore più elevato di tale partizione. Un volume dinamico semplice o con spanning può essere esteso in qualsiasi spazio vuoto di qualsiasi disco dinamico. Mediante questo comando è possibile estendere un volume esistente nel nuovo spazio creato.

Se la partizione è stata precedentemente formattata con il file system NTFS, il file system viene esteso automaticamente in modo da occupare la partizione più grande. Non si verifica alcuna perdita di dati. Se la partizione è stata precedentemente formattata con un formato di file system diverso da NTFS, il comando ha esito negativo e non viene apportata alcuna modifica alla partizione.

Non è possibile estendere le partizioni di sistema o di avvio correnti.

disk= disknumber

Disco dinamico in cui estendere il volume. Sul disco viene allocata una quantità di spazio pari a size=size. Se non si specifica alcun disco, il volume verrà esteso nel disco corrente.

size= size

Quantità di spazio, espressa in megabyte (MB), da aggiungere alla partizione corrente. Se non si specifica una dimensione, il disco verrà esteso in modo da occupare tutto lo spazio non allocato contiguo.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Ridurre un volume semplice o con spanning

È possibile diminuire lo spazio utilizzato da volumi semplici o con spanning riducendoli nello spazio disponibile contiguo alla fine del volume. Se ad esempio si individua l'esigenza di una partizione aggiuntiva ma non si dispone di dischi aggiuntivi, è possibile ridurre la partizione esistente dalla fine del volume in modo da creare nuovo spazio non allocato utilizzabile per una nuova partizione.

Quando si riduce una partizione, tutti i file ordinari vengono automaticamente rilocati sul disco in modo da creare il nuovo spazio non allocato. Per ridurre la partizione, non è necessario riformattare il disco.

Per eseguire le operazioni seguenti, è richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Attenzione

Se la partizione non è formattata, ovvero non dispone di file system, e contiene dati, ad esempio un file di database, la riduzione della partizione può determinare l'eliminazione dei dati.

Ridurre un volume semplice o con spanning

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per ridurre un volume semplice o con spanning tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sul volume semplice o con spanning che si desidera ridurre.

  2. Scegliere Comprimi volume.

  3. Seguire le istruzioni visualizzate.

Ulteriori considerazioni

  • Quando si riduce una partizione, i file fissi (ad esempio il file di paging o l'area di archiviazione di copie shadow) non vengono riallocati automaticamente e non è possibile diminuire lo spazio allocato oltre il punto in cui si trovano i file fissi. Se è necessario ridurre ulteriormente la partizione, spostare il file di paging in un altro disco, eliminare le copie shadow archiviate, ridurre il volume e quindi spostare di nuovo il file di paging sul disco.

  • Se il numero di cluster danneggiati rilevati dal nuovo mapping dinamico è eccessivo, non sarà possibile ridurre la partizione. In tal caso, è possibile spostare i dati e sostituire il disco.

    Non utilizzare una copia a livello di blocco per il trasferimento dei dati. In caso contrario, verrà copiata anche la tabella dei settori danneggiati e il nuovo disco considererà danneggiati tali settori anche se in realtà non presentano problemi.

  • È possibile ridurre dischi dinamici con spanning e semplici, ma non di altro tipo.

Per ridurre un volume semplice o con spanning tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list volume. Annotare il numero del volume semplice che si desidera ridurre.

  3. Al prompt DISKPART digitare select volume <volumenumber>. Viene selezionato il volume semplice volumenumber che si desidera ridurre.

  4. Al prompt DISKPART digitare shrink [desired=<desiredsize>] [minimum=<minimumsize>]. Il volume selezionato viene così ridotto a desiredsize MB, se possibile, o a minimumsize se il valore di desiredsize è troppo elevato.

Valore | Descrizione
list volume | Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.
select volume | Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.
shrink | Consente di ridurre il volume con lo stato attivo in modo da creare spazio non allocato. Non si verifica alcuna perdita di dati. Se la partizione include file fissi (ad esempio, il file di paging o l'area di archiviazione di copie shadow), il volume verrà ridotto fino al punto in cui si trovano i file fissi.
desired= desiredsize | Quantità di spazio, espressa in megabyte (MB), da recuperare per la partizione corrente.
minimum= minimumsize | Quantità minima di spazio, espressa in megabyte (MB), da recuperare per la partizione corrente. Se non si specifica una dimensione desiderata o minima, mediante il comando verrà recuperata la massima quantità di spazio possibile.

Ulteriori considerazioni

  • Quando si riduce una partizione, i file fissi (ad esempio il file di paging o l'area di archiviazione di copie shadow) non vengono riallocati automaticamente e non è possibile diminuire lo spazio allocato oltre il punto in cui si trovano i file fissi. Se è necessario ridurre ulteriormente la partizione, spostare il file di paging in un altro disco, eliminare le copie shadow archiviate, ridurre il volume e quindi spostare di nuovo il file di paging sul disco.

  • Se il numero di cluster danneggiati rilevati dal nuovo mapping dinamico è eccessivo, non sarà possibile ridurre la partizione. In tal caso, è possibile spostare i dati e sostituire il disco.

    Non utilizzare una copia a livello di blocco per il trasferimento dei dati. In caso contrario, verrà copiata anche la tabella dei settori danneggiati e il nuovo disco considererà danneggiati tali settori anche se in realtà non presentano problemi.

  • È possibile ridurre dischi dinamici con spanning e semplici, ma non di altro tipo.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Gestire volumi con spanning

Un volume con spanning è un volume dinamico costituito da spazio su disco in uno o più dischi fisici. Se non è un volume di sistema o di avvio, un volume semplice può essere esteso in dischi aggiuntivi per creare un volume con spanning. In alternativa, è possibile creare un volume con spanning nello spazio non allocato di un disco dinamico.

  • Creare un volume con spanning

  • Estendere un volume semplice o con spanning

  • Ridurre un volume semplice o con spanning


Creare un volume con spanning

Un volume con spanning è un volume dinamico costituito da spazio su disco in uno o più dischi fisici. Se non è un volume di sistema o di avvio, un volume semplice può essere esteso in dischi aggiuntivi per creare un volume con spanning. In alternativa, è possibile creare un volume con spanning nello spazio non allocato di un disco dinamico.

Per creare un volume con spanning, è necessario disporre di almeno due dischi dinamici in aggiunta al disco di avvio. È possibile estendere un volume con spanning su un massimo di 32 dischi dinamici.

I volumi con spanning non sono a tolleranza di errore.

Per eseguire le operazioni seguenti, è richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Creare un volume con spanning

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per creare un volume con spanning tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sullo spazio non allocato di uno dei dischi dinamici in cui si desidera creare il volume con spanning.

  2. Scegliere Nuovo volume con spanning.

  3. Seguire le istruzioni visualizzate.
Per creare un volume con spanning tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list disk. Annotare il numero del disco in cui si desidera creare un volume semplice.

  3. Al prompt DISKPART digitare create volume simple [size=<size>] [disk=<disknumber>].

  4. Al prompt DISKPART digitare list volume. Annotare il numero del volume semplice che si desidera estendere in un altro disco.

  5. Al prompt DISKPART digitare select volume <volumenumber>. Selezionare il volume semplice volumenumber che si desidera estendere in un altro disco.

  6. Al prompt DISKPART digitare list disk. Annotare il numero del disco in cui si desidera estendere il volume semplice.

  7. Al prompt DISKPART digitare extend [size=<size>] [disk=<disknumber>]. Il volume selezionato viene estenso nel disco disknumber, con estensione pari a size=size MB.

Valore Descrizione

list disk

Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.

create volume simple

Consente di creare un volume semplice. Al termine della creazione del volume, lo stato attivo passa automaticamente al nuovo volume.

size= size

Dimensione del volume in megabyte (MB). Se non si specifica alcuna dimensione, il nuovo volume occuperà lo spazio disponibile su disco residuo.

disk= disknumber

Disco dinamico in cui creare il volume. Se non si specifica alcun disco, viene utilizzato il disco corrente.

list volume

Consente di visualizzare un elenco dei volumi di base e dinamici di tutti i dischi.

select volume

Consente di selezionare e attivare il volume specificato. Il segnaposto volumenumber rappresenta il numero del volume. Se non si specifica alcun volume, il comando select visualizzerà il volume corrente con lo stato attivo. È possibile specificare il volume per numero, lettera di unità o percorso del punto di montaggio. In un disco di base, la selezione di un volume assegna inoltre lo stato attivo alla partizione corrispondente.

extend

Consente di estendere il volume con lo stato attivo nello spazio non allocato contiguo. Per i volumi di base, lo spazio non allocato deve essere disponibile nello stesso disco della partizione con lo stato attivo e deve seguire quest'ultima, ovvero presentare un offset di settore più elevato di tale partizione. Un volume dinamico semplice o con spanning può essere esteso in qualsiasi spazio vuoto di qualsiasi disco dinamico. Mediante questo comando è possibile estendere un volume esistente nel nuovo spazio creato.

Se la partizione è stata precedentemente formattata con il file system NTFS, il file system viene esteso automaticamente in modo da occupare la partizione più grande. Non si verifica alcuna perdita di dati. Se la partizione è stata precedentemente formattata con un formato di file system diverso da NTFS, il comando ha esito negativo e non viene apportata alcuna modifica alla partizione.

Non è possibile estendere le partizioni di sistema o di avvio correnti.

disk= disknumber

Disco dinamico in cui estendere il volume. Sul disco viene allocata una quantità di spazio pari a size=size. Se non si specifica alcun disco, il volume viene esteso nel disco corrente.

size= size

Quantità di spazio, espressa in megabyte (MB), da aggiungere alla partizione corrente. Se non si specifica una dimensione, il disco verrà esteso in modo da occupare tutto lo spazio non allocato contiguo.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Creare un volume con striping

Un volume con striping è un volume dinamico che archivia i dati in set di stripe su due o più dischi fisici. I dati di un volume con striping sono allocati alternativamente e uniformemente tramite stripe su tali dischi. I volumi con striping consentono di ottenere le migliori prestazioni tra tutti i volumi disponibili in Windows, ma non offrono tolleranza di errore. Se si verifica un errore in un disco di un volume con striping, verranno persi tutti i dati nel volume.

I volumi con striping possono essere creati soltanto su dischi dinamici e non possono essere estesi. È possibile creare un volume con striping su un massimo di 32 dischi dinamici.

Per eseguire le operazioni seguenti, è richiesta almeno l'appartenenza al gruppo Backup Operators o Administrators.

Creare un volume con striping

  • Tramite l'interfaccia Windows

  • Tramite riga di comando
Per creare un volume con striping tramite l'interfaccia Windows

  1. In Gestione disco fare clic con il pulsante destro del mouse sullo spazio non allocato di uno dei dischi dinamici in cui si desidera creare il volume con striping e quindi scegliere Nuovo volume con striping.

  2. Seguire le istruzioni visualizzate.
Per creare un volume con striping tramite riga di comando

  1. Aprire un prompt dei comandi e digitare diskpart.

  2. Al prompt DISKPART digitare list disk. Annotare il numero del disco in cui si desidera creare un volume con striping.

  3. Al prompt DISKPART digitare create volume stripe [size=<size>] [disk=<disknumber>[,[<seconddisknumber>,…]].

Valore | Descrizione
list disk | Consente di visualizzare un elenco dei dischi e le relative informazioni, ad esempio la dimensione, la quantità di spazio disponibile, se si tratta di un disco di base o dinamico e lo stile di partizione utilizzato, ovvero MBR (Record di avvio principale, Master Boot Record) o GPT (Tabella di partizione GUID, GUID Partition Table). Il disco contrassegnato con un asterisco (*) ha lo stato attivo.
create volume stripe | Consente di creare un volume con striping sui dischi specificati. Al termine della creazione del volume, lo stato attivo passa automaticamente al nuovo volume.
size=size | Quantità di spazio su disco, espressa in megabyte (MB), che verrà occupata dal volume su ogni disco. Se non si specifica alcuna dimensione, il nuovo volume occuperà lo spazio disponibile residuo sul disco di minori dimensioni e un'uguale quantità di spazio su ogni disco successivo.
disk=disknumber | Dischi dinamici in cui creare il volume. Su ogni disco viene allocata una quantità di spazio pari a size=size.

Ulteriori riferimenti

  • Notazione di sintassi della riga di comando


Risolvere i problemi relativi a Gestione disco

In questa sezione vengono elencati alcuni problemi comuni riscontrabili durante l'utilizzo di Gestione disco.

Problema riscontrato

  • Le partizioni su dischi di base aggiunti al sistema non sono incluse nella visualizzazione Elenco volumi di Gestione disco.

  • Lo stato di un disco di base è Non inizializzato.

  • Lo stato di un disco di base o dinamico è Illeggibile.

  • Lo stato di un disco dinamico è Esterno.

  • Lo stato di un disco dinamico è Online (errori).

  • Lo stato di un disco dinamico è Offline o Mancante.

  • Lo stato di un volume di base o dinamico è Errore.

  • Lo stato di un volume di base o dinamico è Sconosciuto.

  • Lo stato di un volume dinamico è Dati incompleti.

  • È impossibile gestire volumi con striping mediante Gestione disco o DiskPart.

  • Lo stato di un volume dinamico è Integro (a rischio).

  • Gestione disco non riesce ad avviare Servizio Dischi virtuali.
Le partizioni su dischi di base aggiunti al sistema non sono incluse nella visualizzazione Elenco volumi di Gestione disco.

Causa: per impostazione predefinita, il montaggio dei volumi sui dischi di base aggiunti al sistema e l'assegnazione delle relative lettere di unità non vengono eseguiti automaticamente.

Quando vengono aggiunti al sistema, i dischi dinamici vengono visualizzati come Esterno. Per utilizzare i volumi, è necessario importare i dischi con stato Esterno e quindi portare i volumi online (stato Pronto).

I dispositivi di supporti rimovibili (ad esempio, unità Zip o Jaz) e i dischi ottici (ad esempio, CD-ROM o DVD-RAM) vengono sempre montati automaticamente dal sistema.

Soluzione: montare manualmente i volumi di base assegnando lettere di unità oppure creando punti di montaggio mediante Gestione disco o il comando DiskPart o mountvol.

Per ulteriori informazioni sul comando DiskPart o mountvol, visitare le pagine agli indirizzi seguenti:

  • http://go.microsoft.com/fwlink/?LinkId=64110

  • http://go.microsoft.com/fwlink/?LinkId=64111

Lo stato di un disco di base è Non inizializzato.

Causa: il disco non include una firma valida. Dopo l'installazione di un nuovo disco, affinché possano essere create partizioni sul disco è necessario che il sistema operativo crei una firma del disco, l'indicatore della fine di settore (denominato anche parola di firma), e un record di avvio principale o una tabella di partizione GUID. Quando si avvia Gestione disco per la prima volta dopo l'installazione di un nuovo disco, viene visualizzata una procedura guidata contenente un elenco dei nuovi dischi rilevati dal sistema operativo. Se si annulla la procedura guidata prima che venga scritta la firma del disco, lo stato del disco rimane Non inizializzato.

Soluzione: inizializzare il disco. Lo stato del disco viene brevemente modificato in Inizializzazione in corso e quindi in Pronto. Per istruzioni su come inizializzare un disco, vedere Inizializzare nuovi dischi.

Per ulteriori informazioni sugli stati dei dischi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64112.

Lo stato di un disco di base o dinamico è Illeggibile.

Causa: il disco di base o dinamico non è accessibile e potrebbe aver subito errori hardware, danneggiamenti o errori di I/O. La copia del disco del database di configurazione dei dischi del sistema potrebbe essere danneggiata. In corrispondenza dei dischi con stato Illeggibile viene visualizzata un'icona di errore.

Lo stato Illeggibile può inoltre essere visualizzato durante lo spin-up dei dischi o quando Gestione disco ripete l'analisi di tutti i dischi del sistema. In alcuni casi, in un disco illeggibile si è verificato un errore e il disco non è recuperabile. Per i dischi dinamici, lo stato Illeggibile è in genere determinato da un danneggiamento o errori di /O su parte del disco, anziché da un errore dell'intero disco.

Soluzione: ripetere l'analisi dei dischi o riavviare il computer per verificare se lo stato del disco viene modificato. Per istruzioni su come ripetere l'analisi dei dischi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64114.

Per ulteriori informazioni sugli stati dei dischi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64112.

Lo stato di un disco dinamico è Esterno.

Causa: lo stato Esterno si riscontra quando si sposta un disco dinamico nel computer locale da un altro computer che esegue Windows 2000, Windows XP Professional, Windows XP 64-Bit Edition o sistemi operativi Windows Server 2003. In corrispondenza dei dischi con stato Esterno viene visualizzata un'icona di avviso.

In alcuni casi, lo stato Esterno può essere visualizzato per un disco precedentemente connesso al sistema. Poiché i dati di configurazione per i dischi dinamici vengono archiviati in tutti i dischi dinamici, le informazioni relative ai dischi appartenenti al sistema vengono perse in caso di errore di tutti i dischi dinamici.

Soluzione: aggiungere il disco alla configurazione di sistema del computer in modo da poter accedere ai dati sul disco. Per aggiungere un disco alla configurazione di sistema del computer, importare il disco esterno facendo clic con il pulsante destro del mouse sul disco e scegliendo quindi Importa dischi esterni. Importando il disco, qualsiasi volume esistente sul disco esterno risulta visibile e accessibile.

Per ulteriori informazioni sugli stati dei dischi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64112.

Lo stato di un disco dinamico è Online (errori).

Causa: in una regione del disco dinamico sono presenti errori di I/O. In corrispondenza del disco dinamico con errori viene visualizzata un'icona di avviso.

Soluzione: se gli errori di I/O sono temporanei, riattivare il disco in modo da ripristinarne lo stato Pronto. Per istruzioni su come riportare il disco online, vedere Riattivare un disco dinamico mancante o offline.

Per ulteriori informazioni sugli stati dei dischi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64112.

Lo stato di un disco dinamico è Offline o Mancante.

Causa: un disco dinamico Offline potrebbe essere danneggiato o non disponibile in modo intermittente. In corrispondenza del disco dinamico offline viene visualizzata un'icona di errore.

Se lo stato del disco è Offline e il nome del disco viene modificato in Mancante, il disco era recentemente disponibile nel sistema ma non può più essere individuato o identificato. Il disco mancante potrebbe essere danneggiato, spento o disconnesso.

Soluzione:

Per riportare online un disco Offline e Mancante

Risolvere qualsiasi problema relativo al disco, al controller o al cavo e verificare che il disco fisico sia acceso, collegato e connesso al computer. Successivamente, utilizzare il comando Riattiva disco specificato per riportare il disco online. Per istruzioni su come riattivare i dischi mancanti o offline, vedere Riattivare un disco dinamico mancante o offline.

Se lo stato del disco rimane Offline e il nome del disco come Mancante e si determina che il problema del disco non può essere risolto, è possibile rimuovere il disco dal sistema facendo clic con il pulsante destro del mouse sul disco e scegliendo quindi Rimuovi il disco. Per poter rimuovere il disco, tuttavia, è innanzitutto necessario eliminare tutti i volumi o i mirror sul disco. È possibile salvare qualsiasi volume con mirroring sul disco rimuovendo il mirroring anziché l'intero volume. Poiché l'eliminazione di un volume determina la distruzione dei dati del volume, è consigliabile rimuovere un disco solo se si è assolutamente certi che il disco è definitivamente danneggiato e inutilizzabile.

Per riportare online un disco Offline denominato Disco # (anziché Mancante), eseguire una o più delle operazioni seguenti:

  • In Gestione disco fare clic con il pulsante destro del mouse sul disco e quindi scegliere Riattiva disco specificato per riportare il disco online. Se lo stato del disco rimane Offline, controllare i cavi e il controller del disco e verificare che il disco fisico sia integro. Risolvere gli eventuali problemi e provare a riattivare di nuovo il disco. Se la riattivazione del disco ha esito positivo, verrà automaticamente ripristinato lo stato Integro per qualsiasi volume sul disco.

  • Nel Visualizzatore eventi controllare nei registri eventi la presenza di eventuali errori relativi ai dischi, ad esempio relativo all'assenza di copie di configurazione valide. Se i registri eventi contengono tale tipo di errore, contattare il Servizio Supporto Tecnico Clienti Microsoft.

  • Provare a spostare il disco in un altro computer. Se è possibile ottenere lo stato Pronto del disco in un altro computer, il problema è probabilmente causato dalla configurazione del computer in cui il disco non risulta Pronto.

  • Provare a spostare il disco in un altro computer che dispone di dischi dinamici. Importare il disco in tale computer e quindi spostarlo di nuovo nel computer in cui non risultava Pronto.

Per ulteriori informazioni sugli stati dei dischi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64112.

Lo stato di un volume di base o dinamico è Errore.

Causa: il volume di base o dinamico non può essere avviato automaticamente oppure il disco o il file system è danneggiato. A meno che non sia possibile ripristinare il disco o il file system, lo stato Errore indica una perdita di dati.

Soluzione: in caso di volume di base con stato Errore, verificare che il disco fisico sottostante sia acceso, collegato e connesso al computer. Per i volumi di base non sono consentite altre azioni dell'utente.

In caso di volume dinamico con stato Errore, verificare che i dischi sottostanti siano online. In caso contrario, ripristinarne lo stato Pronto. Se questa operazione ha esito positivo, il volume viene riavviato automaticamente e ne viene ripristinato lo stato Integro. Per istruzioni su come portare un disco online, vedere Riattivare un disco dinamico mancante o offline.

In caso di ripristino dello stato Pronto del disco dinamico ma non dello stato Integro del volume dinamico, è possibile riattivare il volume manualmente. Per istruzioni su come riattivare un volume, vedere Riattivare un disco dinamico mancante o offline.

In caso di volume dinamico con mirroring o RAID-5 con dati obsoleti, il volume non verrà riavviato automaticamente portando il disco sottostante online. Se i dischi contenenti i dati correnti vengono disconnessi, è consigliabile portare online innanzitutto tali dischi, in modo da consentire la sincronizzazione dei dati. In alternativa, riavviare manualmente il volume con mirroring o RAID-5 e quindi eseguire lo strumento per il rilevamento degli errori o Chkdsk.exe.

Per istruzioni su come riattivare un volume, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64115.

Per ulteriori informazioni sugli stati dei volumi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64113.

Lo stato di un volume di base o dinamico è Sconosciuto.

Causa: lo stato Sconosciuto si riscontra quando il settore di avvio del volume è danneggiato (possibilmente a causa di un virus) e non è più possibile accedere ai dati del volume. Lo stato Sconosciuto si riscontra inoltre quando si installa un nuovo disco senza completare correttamente la procedura guidata per la creazione di una firma del disco.

Soluzione: inizializzare il disco. Per istruzioni su come inizializzare un disco, vedere Inizializzare nuovi dischi.

Per ulteriori informazioni sugli stati dei volumi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64113.

Lo stato di un volume dinamico è Dati incompleti.

Causa: si sono spostati alcuni dischi di un volume multidisco, ma non tutti. I dati del volume verranno distrutti a meno che non vengano spostati e importati i restanti dischi contenenti il volume.

Soluzione: spostare tutti i dischi da cui è costituito il volume multidisco nel computer e quindi eseguirne l'importazione. Per istruzioni su come spostare e importare i dischi, vedere Spostare i dischi in un altro computer.

Se il volume multidisco non è più necessario, è possibile importare il disco e crearvi nuovi volumi. Fare clic con il pulsante destro del mouse sul volume con stato Errore o Errore di ridondanza e quindi scegliere Elimina volume. Fare clic con il pulsante destro del mouse sul disco e quindi scegliere Nuovo volume.

Per ulteriori informazioni sugli stati dei volumi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64113.

Lo stato di un volume dinamico è Integro (a rischio).

Causa: questo stato indica che il volume dinamico è attualmente accessibile, ma sono stati rilevati errori di I/O nel disco dinamico sottostante. In caso di rilevamento di un errore di I/O in qualsiasi parte di un disco dinamico, per tutti i volumi del disco vengono visualizzati lo stato Integro (a rischio) e un'icona di avviso.

Quando lo stato del volume è Integro (a rischio), lo stato del disco sottostante corrisponde in genere a Pronto (errori).

Soluzione: ripristinare lo stato Pronto per il disco sottostante. Dopo il ripristino dello stato Pronto del disco, dovrebbe essere ripristinato lo stato Integro del volume. Se lo stato Integro (a rischio) persiste, il disco potrebbe essere danneggiato. Eseguire il backup dei dati e sostituire il disco appena possibile. Per istruzioni su come riportare il disco online, vedere Riattivare un disco dinamico mancante o offline.

Per ulteriori informazioni sugli stati dei volumi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64113.

È impossibile gestire volumi con striping mediante Gestione disco o DiskPart.

Causa: alcuni prodotti per la gestione dei dischi non Microsoft sostituiscono lo strumento Gestione dischi logici (LDM, Logical Disk Manager) Microsoft per la gestione avanzata dei dischi, disattivando Gestione dischi logici.

Soluzione: se il software per la gestione dei dischi non Microsoft in uso ha disattivato Gestione dischi logici, è necessario contattare il fornitore di tale software per ottenere supporto e assistenza nella risoluzione dei problemi relativi alla configurazione dei dischi.

Gestione disco non riesce ad avviare Servizio Dischi virtuali.

Causa: se un computer remoto non supporta Servizio Dischi virtuali (VDS) o non si riesce a stabilire una connessione al computer remoto perché è bloccato da Windows Firewall, è possibile che venga visualizzato questo errore.

Soluzione: se il computer remoto supporta VDS, è possibile configurare Windows Firewall in modo da consentire le connessioni VDS. Se invece il computer remoto non supporta VDS, è possibile utilizzare Connessione desktop remoto per effettuare la connessione e quindi eseguire Gestione disco direttamente sul computer remoto.

Per gestire i dischi in computer remoti che non supportano VDS, è necessario configurare Windows Firewall sia nel computer locale in cui è in esecuzione Gestione disco sia nel computer remoto.

Nel computer locale configurare Windows Firewall in modo da attivare l'eccezione Gestione volumi remota.

Nota

L'eccezione Gestione volumi remota include le eccezioni per Vds.exe, Vdsldr.exe e per la porta TCP 135.

Nella tabella seguente viene descritto come configurare Windows Firewall in diversi computer remoti in modo da consentire le connessioni da Gestione disco in esecuzione in un computer con Windows Server 2008, Microsoft Windows Vista o Microsoft Windows Vista con Service Pack 1 (SP 1).

Sistema operativo del computer remoto Configurazione di Windows Firewall

Windows Server 2008

Attivare l'eccezione Gestione volumi remota.

Microsoft Windows Vista

Attivare l'eccezione Gestione volumi remota.

Attivare l'eccezione Condivisione file e stampanti.

Microsoft Windows Vista con SP 1

Attivare l'eccezione Gestione volumi remota.

Windows Server 2003 con SP 1

Attivare le eccezioni seguenti:

  • porta TCP 135

  • Vds.exe

Nota

Le connessioni remote in gruppi di lavoro non sono supportate. Il computer locale e quello remoto devono trovarsi entrambi in un dominio.


Risorse su Gestione disco

  • Per informazioni più approfondite su Gestione disco, con concetti e procedure consigliate, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?linkid=64097.

  • Per informazioni sulle importanti considerazioni relative alla conversione tra dischi di base e dinamici, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64108.


Notazione di sintassi della riga di comando

Nella tabella seguente viene descritta la notazione utilizzata per indicare la sintassi della riga di comando.

Notazione | Descrizione
Testo senza parentesi quadre o graffe | Elementi da digitare come indicato
<Testo tra parentesi acute> | Segnaposto per il quale è necessario fornire un valore
[Testo tra parentesi quadre] | Elementi facoltativi
{Testo tra parentesi graffe} | Serie di elementi richiesti: effettuare una selezione
Barra verticale (|) | Separatore per elementi che si escludono a vicenda: effettuare una selezione
Puntini di sospensione (...) | Elementi che possono essere ripetuti


Ulteriori informazioni sulle impostazioni della cache in scrittura

Impostazioni della cache in scrittura

Quando si esegue la cache in scrittura in un dispositivo di archiviazione si utilizza memoria volatile ad alta velocità per raccogliere i comandi di scrittura inviati ai dispositivi di archiviazione e memorizzarli nella memoria cache finché i supporti di archiviazione più lenti, ovvero dischi fisici o memoria flash a basso costo, non saranno in grado di gestirli. La maggior parte dei dispositivi che utilizza la cache in scrittura richiede un'alimentazione continua.

Rimozione rapida

Questa opzione rappresenta in genere la scelta migliore per i dispositivi che con molta probabilità verranno rimossi dal sistema di frequente, ad esempio unità flash USB, schede SD, MMC, Compact Flash o schede di memoria simili e altri dispositivi di archiviazione collegati esternamente.

Quando si seleziona l'opzione Rimozione rapida, i comandi inviati al dispositivo vengono gestiti utilizzando un metodo denominato cache write-through. Con tale metodo il dispositivo agisce sui comandi di scrittura come se non fosse presente memoria cache. Sebbene la cache sia in grado di offrire un vantaggio minimo in termini di prestazioni, l'aspetto sicuramente più interessante è la gestione sicura dei dati grazie al trasferimento dei comandi al dispositivo di archiviazione principale. Il vantaggio più significativo è rappresentato dalla possibilità di rimuovere il dispositivo di archiviazione dal sistema rapidamente senza rischiare una perdita di dati. Se, ad esempio, un'unità flash viene accidentalmente estratta dalla rispettiva porta, la probabilità che i dati in essa scritti vadano persi è molto più bassa.

Prestazioni migliori

Questa opzione rappresenta in genere la scelta migliore per i dispositivi che devono garantire le prestazioni migliori possibili e che verranno rimossi solo raramente dal sistema. Se si sceglie questa opzione e il dispositivo viene disconnesso dal sistema prima che tutti i dati siano stati scritti al suo interno, ad esempio se si rimuove un'unità flash USB, i dati potrebbero andare persi.

Quando si seleziona l'opzione Prestazioni migliori, viene utilizzato un metodo denominato cache write-back. Con questo metodo il dispositivo di archiviazione può stabilire se l'utilizzo della cache ad alta velocità consentirà di risparmiare tempo durante la scrittura dei comandi. In caso affermativo, il dispositivo indicherà al computer che i dati sono stati archiviati correttamente anche se potrebbero non essere presenti nel dispositivo di archiviazione principale, ad esempio il disco o la memoria flash. Questo metodo consente di incrementare notevolmente la velocità effettiva delle operazioni di archiviazione che rappresentano spesso un enorme collo di bottiglia per le prestazioni generali del sistema. Se, tuttavia, si verifica un'interruzione di alimentazione del dispositivo, i dati ancora presenti nella cache e che si ritiene siano stati archiviati in modo sicuro potrebbero andare persi.

Scaricamento della cache

Per impostazione predefinita, in Windows viene eseguito lo scaricamento della cache. Il sistema pertanto indica periodicamente al dispositivo di archiviazione di trasferire tutti i dati in attesa nella cache nei supporti di archiviazione principali. Quando si seleziona Attiva cache in scrittura sul dispositivo, si disattivano questi comandi periodici per il trasferimento dei dati. Il supporto di queste funzionalità non è disponibile in tutti i dispositivi.

Se si desidera innanzitutto garantire un trasferimento dei dati ad alta velocità, è consigliabile abilitare entrambe le impostazioni: nella sezione Criteri di rimozione selezionare l'opzione Prestazioni migliori e nella sezione dei criteri della cache in scrittura selezionare Attiva cache in scrittura sul dispositivo se l'hardware del sistema e il dispositivo di archiviazione supportano queste funzionalità.

Come modificare l'impostazione della cache in scrittura per il dispositivo in uso

La maggior parte dei dispositivi di archiviazione orientati al consumer quali unità flash USB, schede di memoria SD o MMC o unità disco esterne del consumer non consente di modificare le impostazioni della cache del dispositivo. I dischi rigidi interni SATA o SAS (Serial-Attached SCSI) forniti con Windows in genere consentono la modifica delle impostazioni, sebbene questa possa essere garantita solo dal produttore del dispositivo. Per informazioni sulle funzionalità di memorizzazione nella cache disponibili in un determinato dispositivo e per stabilire quali impostazioni soddisfano meglio le proprie esigenze, consultare la documentazione fornita dal produttore.

Ulteriori informazioni per evitare perdite di dati

I sistemi con la cache in scrittura abilitata devono essere stabili e non soggetti a interruzioni dell'alimentazione in tutti i punti di passaggio tra l'applicazione e il dispositivo di archiviazione. Quando in un dispositivo collegato a un sistema viene utilizzata la cache in scrittura, gli algoritmi del dispositivo per la memorizzazione nella cache sono progettati supponendo che l'alimentazione sarà sempre disponibile per garantire il funzionamento della cache e lo spostamento dei dati all'interno e all'esterno della cache. Se il sistema o l'alimentazione presentano problemi noti di supporto dell'alimentazione, è consigliabile non utilizzare queste funzionalità.

È inoltre consigliabile rimuovere con cautela i dispositivi di archiviazione quali le unità flash USB, le schede di memoria SD, MMC o Compact Flash e le unità di archiviazione esterne. Quando si utilizza l'opzione Rimozione sicura i dati vengono protetti da Windows nella maggior parte dei casi. Poiché tuttavia è possibile che determinate unità o applicazioni non siano conformi al modello di Windows, potrebbe verificarsi una perdita di dati durante la rimozione di tali dispositivi. Se possibile, prima di rimuovere un dispositivo di archiviazione esterno dal sistema è consigliabile utilizzare l'applet Rimozione sicura.