Funzionalità disponibili in Windows Server 2008 R2

Le funzionalità sono programmi software disponibili in Windows Server® 2008 R2 che possono supportare o potenziare la funzionalità di uno o più ruoli, pur non facendone direttamente parte, oppure estendere la funzionalità dell'intero server, indipendentemente dai ruoli installati. La funzionalità Clustering di failover ad esempio potenzia la funzionalità di altri ruoli, quali Servizi file e Server DHCP, consentendone l'aggiunta ai cluster di server al fine di ottenere una maggiore ridondanza e prestazioni migliorate. Un'altra funzionalità, Client Telnet, consente di comunicare da postazione remota con un server Telnet tramite una connessione di rete, migliorando le possibilità di comunicazione del server nel suo complesso.

Funzionalità di Windows Server 2008 R2

Nell'elenco seguente vengono identificate le funzionalità che è possibile installare utilizzando l'Aggiunta guidata funzionalità di Server Manager, disponibile nell'ambito di Windows Server 2008 R2. È inoltre possibile installare il cmdlet Windows PowerShell utilizzando Add-WindowsFeature o l'utilità da riga di comando di Server Manager, ServerManagerCmd.exe. Per ulteriori informazioni su come installare o rimuovere funzionalità, vedere la Guida di Server Manager.

  • Panoramica di Servizio trasferimento intelligente in background (BITS)

  • Panoramica della biometria

  • Panoramica di Visualizzatore password di ripristino BitLocker per Active Directory

  • Panoramica di Crittografia unità BitLocker

  • Panoramica di BranchCache

  • Panoramica di Connection Manager Administration Kit

  • Panoramica di Esperienza desktop

  • Panoramica di DirectAccess

  • Panoramica di Gestione Criteri di gruppo

  • Panoramica dei cluster di failover

  • Panoramica di Servizi di input penna e riconoscimento grafia

  • Panoramica di Client di stampa Internet

  • Panoramica di Server iSNS

  • Panoramica di Monitor porta LPR (Line Printer Remote)

  • Panoramica di Accodamento messaggi

  • Panoramica di Multipath I/O

  • Panoramica di Funzionalità di .NET Framework 3.5.1

  • Panoramica di Bilanciamento carico di rete

  • Panoramica del protocollo PNRP (Peer Name Resolution Protocol)

  • Panoramica di Servizio audio/video Windows di qualità

  • Panoramica di Assistenza remota

  • Panoramica di RDC (Remote Differential Compression)

  • Panoramica di Strumenti di amministrazione remota del server

  • Panoramica di Proxy RPC su HTTP

  • Panoramica di Servizi per NFS (Network File System)

  • Panoramica del protocollo SMTP (Simple Mail Transfer Protocol)

  • Panoramica di Simple Network Management Protocol

  • Panoramica di Servizi TCP/IP semplificati

  • Panoramica del provider WMI per SNMP

  • Panoramica di Gestione archivi SAN

  • Panoramica di Subsystem for UNIX-based Applications

  • Panoramica di Server Telnet

  • Panoramica di Client Telnet

  • Panoramica del protocollo TFTP (Trivial File Transfer Protocol)

  • Panoramica di Database interno di Windows

  • Windows Internet Name Service (WINS) Overview

  • Panoramica di Windows PowerShell Integrated Scripting Environment

  • Panoramica del servizio Attivazione processo Windows

  • Panoramica di Estensione IIS di Gestione remota Windows

  • Panoramica di Windows Server Backup

  • Panoramica di Gestione risorse di sistema Windows

  • Panoramica di IFilter TIFF di Windows

  • Panoramica del servizio LAN wireless

  • Panoramica di XPS Viewer


Panoramica di Servizio trasferimento intelligente in background (BITS)

In BITS (Background Intelligent Transfer Service, Servizio trasferimento intelligente in background) sono disponibili due servizi ruolo: Compact Server ed Estensione del server IIS. Compact Server è un file server HTTP o HTTPS autonomo, mentre Estensione del server IIS è un plug-in di Internet Information Services (IIS) per il quale è necessario un server che esegue IIS.

Estensione del server IIS

Estensione del server IIS di BITS consente di configurare un server che esegue IIS in modo che i client BITS possano eseguire in background caricamenti ripristinabili di file nelle directory virtuali di IIS. Al completamento dell'operazione, il server BITS può notificare a un'applicazione Web l'avvenuto caricamento del file, consentendo all'applicazione di elaborarlo. L'applicazione Web può facoltativamente rispondere al client responsabile del caricamento.

Compact Server

Compact Server è un file server HTTP o HTTPS autonomo che consente alle applicazioni di ospitare file destinati al download da parte dei client BITS. Compact Server consente inoltre il trasferimento asincrono di un numero limitato di file di grandi dimensioni tra computer.

Risorse aggiuntive

  • Servizio trasferimento intelligente in background http://go.microsoft.com/fwlink/?LinkId=140888

  • Informazioni di riferimento per BITS http://go.microsoft.com/fwlink/?LinkId=140985


Panoramica della biometria

Per una maggiore praticità, Windows 7 consente agli amministratori e agli utenti di utilizzare dispositivi biometrici per impronte digitali per accedere ai computer, concedere privilegi di elevazione mediante Controllo dell'account utente ed eseguire attività di gestione di base dei dispositivi per impronte digitali. Gli amministratori possono gestire i dispositivi biometrici per impronte digitali in Criteri di gruppo, abilitando, limitando o bloccando il loro utilizzo.

Che cos'è la biometria?

Un numero crescente di computer, in particolare i computer portatili, integra un lettore di impronta digitale. I lettori di impronta digitale possono essere utilizzati per l'identificazione e l'autenticazione degli utenti in Windows. Finora non era disponibile un supporto standard per i dispositivi biometrici o per le applicazioni con funzionalità biometriche in Windows. I produttori di computer dovevano fornire gli strumenti software necessari al supporto dei dispositivi biometrici nei propri prodotti. Tale situazione rendeva più difficile l'utilizzo dei dispositivi biometrici per gli utenti e la gestione del loro utilizzo per gli amministratori.

Windows 7 include Windows Biometric Framework, che espone i lettori di impronta digitale e altri dispositivi biometrici alle applicazioni di livello superiore in modo uniforme e offre un'esperienza utente omogenea per l'individuazione e l'avvio delle applicazioni che utilizzano le impronte digitali. Tale risultato è raggiunto grazie alle funzionalità seguenti:

  • Un pannello di controllo Dispositivi biometrici, che consente agli utenti di controllare la disponibilità di dispositivi biometrici e la possibilità di utilizzarli per accedere a un computer locale o a un dominio.

  • Supporto in Gestione dispositivi per i driver dei dispositivi biometrici.

  • Supporto dei provider di credenziali per abilitare e configurare l'utilizzo dei dati biometrici per accedere a un computer locale ed eseguire l'elevazione tramite Controllo dell'account utente.

  • Impostazioni di Criteri di gruppo per abilitare, disabilitare o limitare l'utilizzo di dati biometrici per un computer locale o un dominio. Le impostazioni di Criteri di gruppo possono inoltre impedire l'installazione di driver di dispositivi biometrici o forzarne la disinstallazione.

  • Software driver di dispositivi biometrici disponibile da Windows Update.

Utenti interessati all'utilizzo di dispositivi biometrici

I dispositivi biometrici per impronte digitali sono uno strumento pratico per accedere al computer e concedere l'elevazione mediante Controllo dell'account utente.

Vantaggi delle nuove funzionalità biometriche

Le nuove funzionalità biometriche offrono un supporto coerente per l'implementazione delle applicazioni con funzionalità biometriche e per la gestione dei dispositivi biometrici per impronte digitali su computer autonomi o in una rete. Windows Biometric Framework facilita la configurazione e il controllo dei dispositivi biometrici in un computer locale o in un dominio da parte di utenti e amministratori.

Effetto delle modifiche sulla biometria

L'introduzione di Windows Biometric Framework consente l'integrazione dei dispositivi biometrici per impronte digitali in Windows. Offre un'esperienza utente omogenea per l'accesso a Windows e l'elevazione tramite Controllo dell'account utente. Implementa inoltre un insieme comune di punti di individuazione e integrazione che assicura un'esperienza utente più uniforme con vari dispositivi e applicazioni. Windows Biometric Framework include inoltre funzioni di gestione che consentono agli amministratori di controllare la distribuzione dei dispositivi biometrici per impronte digitali nell'azienda.


Panoramica di Visualizzatore password di ripristino BitLocker per Active Directory

Lo strumento Visualizzatore password di ripristino BitLocker per Active Directory è una funzionalità facoltativa inclusa in Strumenti di amministrazione remota del server che è possibile installare mediante l'Aggiunta guidata funzionalità del sistema di gestione Strumenti di amministrazione remota del server. Questo strumento consente di individuare e visualizzare le password di ripristino di BitLocker memorizzate in Servizi di dominio Active Directory. È possibile utilizzare questo strumento per recuperare i dati archiviati in un volume crittografato tramite BitLocker. Lo strumento Visualizzatore password di ripristino BitLocker per Active Directory è un'estensione dello snap-in Microsoft Management Console (MMC) Utenti e computer di Active Directory. Questo strumento consente di esaminare la finestra di dialogo Proprietà di un oggetto computer e visualizzare le password di ripristino di BitLocker corrispondenti. È inoltre possibile fare clic con il pulsante destro del mouse sul contenitore di un dominio e quindi cercare la password di ripristino di BitLocker in tutti i domini della foresta di Active Directory.

Requisiti di utilizzo

Le password di ripristino sono visualizzabili solo dall'amministratore di dominio o da un utente a cui l'amministratore di dominio ha delegato le autorizzazioni. Inoltre, per utilizzare lo strumento Visualizzatore password di ripristino BitLocker per Active Directory devono verificarsi le condizioni seguenti:

  • Il dominio deve essere configurato in modo da archiviare le informazioni per il ripristino di BitLocker.

  • I computer protetti da BitLocker devono far parte del dominio.

  • Nei computer deve essere attivata la Crittografia unità BitLocker.

Attività comuni

Nelle procedure seguenti vengono descritte le attività più comuni che è possibile eseguire utilizzando lo strumento Visualizzatore password di ripristino BitLocker per Active Directory.

Per visualizzare le password di ripristino per un computer

  1. In Utenti e Computer di Active Directory individuare il contenitore in cui si trova il computer e quindi fare clic su di esso.

  2. Fare clic con il pulsante destro del mouse sull'oggetto computer e quindi scegliere Proprietà.

  3. Nella finestra di dialogo Proprietà fare clic sulla scheda Ripristino BitLocker per visualizzare le password di ripristino di BitLocker associate al computer specifico.
Per copiare le password di ripristino per un computer

  1. Eseguire la procedura descritta in precedenza per visualizzare le password di ripristino di BitLocker.

  2. Nella scheda Ripristino BitLocker della finestra di dialogo Proprietà fare clic con il pulsante destro del mouse sulla password di ripristino di BitLocker che si desidera copiare e quindi scegliere Copia dettagli.

  3. Premere CTRL+V per incollare il testo copiati nella posizione di destinazione, ad esempio un file di testo o un foglio di calcolo.
Per individuare una password di ripristino

  1. In Utenti e computer di Active Directory fare clic con il pulsante destro del mouse sul contenitore del dominio e quindi scegliere Trova password di ripristino BitLocker.

  2. Nella finestra di dialogo Trova password di ripristino BitLocker digitare i primi otto caratteri della password di ripristino nella casella ID password (primi 8 caratteri) e quindi fare clic su Cerca.


Panoramica di Crittografia unità BitLocker

Crittografia unità BitLocker è una funzionalità di protezione dei dati disponibile in Windows Server 2008 R2 e in alcune edizioni di Windows 7. L'integrazione di BitLocker nel sistema operativo consente di eliminare i rischi di furto o esposizione dei dati in caso di smarrimento, furto o rimozione inappropriata delle autorizzazioni di un computer.

In caso di smarrimento o furto di un computer, i dati presenti sono esposti a rischi di accesso non autorizzato tramite l'esecuzione di uno strumento di attacco software direttamente in tale computer o il trasferimento del disco rigido in un computer diverso. BitLocker consente di limitare gli accessi non autorizzati ai dati grazie al miglioramento delle funzionalità di protezione di per i file e il sistema. Consente inoltre di rendere inaccessibili i dati in caso di rimozione delle autorizzazioni o riciclaggio di computer protetti da BitLocker.

BitLocker garantisce una protezione massima se utilizzato con un TPM (Trusted Platform Module) versione 1.2. Il TPM è un componente hardware installato in molti computer recenti dai produttori che interagisce con BitLocker al fine di proteggere i dati dell'utente e verificare che un computer non sia stato alterato mentre il sistema era in modalità offline.

Nei computer in cui non è presente un TPM versione 1.2 è comunque possibile utilizzare BitLocker per crittografare l'unità del sistema operativo Windows. Questa implementazione, tuttavia, richiede l'inserimento da parte dell'utente di una chiave di avvio USB per l'avvio del computer o la ripresa dalla modalità di ibernazione e non esegue la verifica dell'integrità del sistema preliminare all'avvio disponibile quando si utilizza BitLocker con un TPM.

Se utilizzata con il TPM, la crittografia BitLocker consente inoltre di bloccare il normale processo di avvio fino a quando l'utente non specifica un PIN o inserisce un dispositivo rimovibile, ad esempio un'unità memoria flash USB, contenente una chiave di avvio. Queste misure di sicurezza aggiuntive garantiscono l'autenticazione a più fattori e la certezza che il computer non verrà avviato o riattivato dalla modalità di ibernazione fino a quando non appaiono il PIN o la chiave di avvio corretta.

Verifica dell'integrità del sistema

BitLocker può utilizzare un TPM per verificare l'integrità dei componenti di avvio e dei dati configurazione di avvio. In questo modo l'unità crittografata risulta accessibile solo se tali componenti non sono stati alterati e l'unità crittografata si trova nel computer originale.

BitLocker assicura l'integrità del processo di avvio mediante le azioni seguenti:

  • Offrendo un metodo per controllare che l'integrità dei file di avvio non sia stata compromessa e verificare che tali file non siano stati sottoposti a modifiche dannose, come nel caso di virus del settore di avvio o rootkit.

  • Migliorando la protezione per limitare gli attacchi basati su software non in linea. Qualsiasi software alternativo che potrebbe avviare il sistema non ha accesso alle chiavi di decrittografia per l'unità del sistema operativo Windows.

  • Bloccando il sistema in caso di alterazione. In caso di alterazione di uno qualsiasi dei file monitorati, il sistema non verrà avviato. L'utente viene informato dell'alterazione in quando il sistema non si avvia come di norma. Quando si verifica un blocco del sistema, BitLocker consente di eseguire un semplice processo di ripristino.

Requisiti a livello hardware, firmware e software

Per utilizzare BitLocker, è necessario che il computer soddisfi determinati requisiti:

  • Affinché BitLocker possa utilizzare la verifica dell'integrità del sistema offerta da un TPM, è necessario che nel computer sia installato un TPM versione 1.2. In caso contrario, per attivare BitLocker sarà necessario salvare una chiave di avvio in un dispositivo rimovibile, ad esempio un'unità memoria flash USB.

  • In un computer con un TPM è inoltre necessario che sia installato un BIOS conforme alle specifiche del Trusted Computing Group (TCG). Il BIOS stabilisce una catena di certificati per l'avvio preliminare al sistema operativo e deve includere il supporto per Static Root of Trust Measurement in base alle specifiche del TCG. Un computer senza un TPM non richiede un BIOS conforme alle specifiche del TCG.

  • Il BIOS di sistema deve supportare, per computer con o senza TPM, la classe di dispositivi di archiviazione di massa USB, inclusa la lettura di piccoli file su un'unità memoria flash USB nell'ambiente preliminare al sistema operativo. Per ulteriori informazioni su USB, vedere le specifiche per l'archiviazione di massa USB Bulk-Only e UFI Command nel sito Web USB (http://go.microsoft.com/fwlink/?LinkId=83120).

  • Il disco rigido deve essere partizionato con almeno due unità:

    • L'unità del sistema operativo, o unità di avvio, contiene il sistema operativo e i relativi file di supporto e deve essere formattata con il file system NTFS.

    • L'unità di sistema contiene i file necessari per il caricamento di Windows dopo che il BIOS ha preparato l'hardware del sistema. BitLocker non è attivato in questa unità. Affinché BitLocker funzioni, è necessario che l'unità di sistema non sia crittografata, sia diversa dall'unità del sistema operativo e sia formattata con il file system NTFS. L'unità di sistema deve avere una dimensione minima di 1,5 gigabyte (GB).

Installazione e inizializzazione

BitLocker viene installato automaticamente insieme al sistema operativo, ma deve essere appositamente attivato utilizzando la procedura guidata per l'installazione di BitLocker, accessibile dal Pannello di controllo o tramite clic con il pulsante destro del mouse sull'unità in Esplora risorse.

Dopo l'installazione e la configurazione iniziale del sistema operativo, l'amministratore di sistema può inizializzare BitLocker in qualsiasi momento utilizzando questa procedura guidata. Il processo di inizializzazione prevede due passaggi:

  1. Nei computer con un TPM, inizializzare il TPM utilizzando l'Inizializzazione guidata TPM o l'elemento Crittografia unità BitLocker nel Pannello di controllo oppure eseguendo uno script appositamente progettato.

  2. Configurare BitLocker. Accedere dal Pannello di controllo alla procedura guidata per l'installazione di BitLocker, che consente di eseguire la configurazione in modo semplificato e visualizza opzioni di autenticazione avanzate.

Quando un amministratore locale inizializza BitLocker, deve anche creare una password di ripristino o una chiave di ripristino. In assenza di una chiave di ripristino o una password di ripristino, qualora si verifichi un problema con l'unità protetta da BitLocker, tutti i dati presenti nell'unità crittografata potrebbero risultare inaccessibili e non essere ripristinabili.

Nota

L'inizializzazione di BitLocker e del TPM deve essere eseguita da un membro del gruppo Administrators locale nel computer.

Per informazioni dettagliate sulla configurazione e la distribuzione di BitLocker, vedere la guida dettagliata relativa a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=140225).

Implementazione nell'organizzazione

BitLocker è in grado di utilizzare l'infrastruttura Servizi di dominio Active Directory esistente di un'organizzazione per archiviare chiavi di ripristino in remoto. BitLocker offre una procedura guidata per l'installazione e la gestione e assicura estendibilità e gestibilità tramite un'interfaccia Strumentazione gestione Windows (WMI) con supporto di scripting. BitLocker dispone inoltre di una console di ripristino, integrata nel processo di avvio, che consente all'utente o al personale di supporto tecnico di riaccedere a un computer bloccato.

Per ulteriori informazioni sulla creazione di script per BitLocker, vedere la pagina relativa a Win32_EncryptableVolume (http://go.microsoft.com/fwlink/?LinkId=85983).

Rimozione delle autorizzazioni e riciclaggio del computer

Molti personal computer oggi vengono riutilizzati da persone diverse dal proprietario o dall'utente iniziale del computer. Negli scenari relativi alle organizzazioni, i computer potrebbero essere ridistribuiti in altri reparti oppure potrebbero essere riciclati nell'ambito di un ciclo di aggiornamento dell'hardware dei computer standard.

I dati presenti in unità non crittografate potrebbero continuare a essere leggibili anche dopo la formattazione dell'unità. Le organizzazioni spesso ricorrono a più operazioni di sovrascrittura oppure alla distruzione fisica per limitare il rischio di esposizione dei dati in unità per cui è stata eseguita la rimozione delle autorizzazioni.

BitLocker può consentire di definire un semplice processo di rimozione delle autorizzazioni economicamente vantaggioso. Lasciando i dati crittografati da BitLocker e rimuovendo le chiavi, un'organizzazione può limitare in modo definitivo il rischio di esposizione di tali dati. Dopo la rimozione di tutte le chiavi di BitLocker, è pressoché impossibile accedere a dati crittografati con BitLocker perché sarebbe necessario violare la crittografia AES a 128 bit o 256 bit.

Considerazioni sulla sicurezza BitLocker

BitLocker non è in grado di proteggere un computer contro tutti i possibili attacchi. Se ad esempio utenti malintenzionati o programmi dannosi quali virus o rootkit hanno accesso al computer prima dello smarrimento o del furto, potrebbero essere in grado di introdurre punti di debolezza tramite cui accedere successivamente ai dati crittografati. Se si lascia nel computer la chiave di avvio USB o non si tengono segreti il PIN o la password di accesso a Windows, la protezione BitLocker può essere compromessa.

La modalità di autenticazione solo TPM è la più facile da distribuire, gestire e utilizzare. Potrebbe inoltre essere la più appropriata per computer in modalità automatica o che richiedono un riavvio in modalità automatica. La modalità solo TPM offre tuttavia un livello minimo di protezione dei dati. Se in alcune parti dell'organizzazione vengono archiviati dati altamente confidenziali su computer portatili, in tali computer è consigliabile distribuire BitLocker con l'autenticazione a più fattori.

Per ulteriori informazioni sulla sicurezza BitLocker, vedere la pagina relativa al toolkit di crittografia dei dati per computer portatili (http://go.microsoft.com/fwlink/?LinkId=85982).

Implementazione di BitLocker nei server

Per i server in ambienti condivisi o potenzialmente non sicuri, ad esempio all'interno di una succursale, è possibile utilizzare BitLocker per crittografare l'unità del sistema operativo e unità dati aggiuntive nello stesso server.

Per impostazione predefinita, BitLocker non viene installato con Windows Server 2008 R2. Per aggiungerlo, utilizzare la pagina Server Manager di Windows Server 2008 R2. Dopo aver installato BitLocker in un server, è necessario eseguire un riavvio. Utilizzando WMI è possibile attivare BitLocker in remoto.

BitLocker è supportato in server Extensible Firmware Interface (EFI) che utilizzano un'architettura del processore a 64 bit.

Nota

BitLocker non supporta le configurazioni cluster.

Gestione delle chiavi

Dopo aver crittografato e protetto l'unità con BitLocker, gli amministratori locali e di dominio possono utilizzare la pagina Gestione BitLocker dell'elemento Crittografia unità BitLocker nel Pannello di controllo per modificare la password di sblocco dell'unità, rimuovere la password dall'unità, aggiungere una smart card per lo sblocco dell'unità, salvare o stampare di nuovo la chiave di ripristino, sbloccare automaticamente l'unità, duplicare le chiavi e reimpostare il PIN.

Nota

È possibile controllare i tipi di chiavi utilizzabili in un computer tramite Criteri di gruppo. Per ulteriori informazioni sull'utilizzo di Criteri di gruppo con BitLocker, vedere la guida alla distribuzione di BitLocker (http://go.microsoft.com/fwlink/?LinkID=140286).

Disattivare temporaneamente la protezione BitLocker

Un amministratore potrebbe avere necessità di disattivare temporaneamente BitLocker in determinati scenari, ad esempio per:

  • Riavviare il computer per la manutenzione senza l'input dell'utente, ad esempio l'immissione di un PIN o l'inserimento di una chiave di avvio.

  • Aggiornare il BIOS.

  • Installare un componente hardware dotato di memoria di sola lettura facoltativa (ROM facoltativa).

  • Aggiornare componenti di avvio critici senza avviare il ripristino di BitLocker, Ad esempio:

    • Installare una versione diversa del sistema operativo o un altro sistema operativo, con una possibile modifica del record di avvio principale (MBR).

    • Ripartizionare il disco, con una possibile modifica della tabella di partizione.

    • Eseguire altre attività di sistema che comportano una modifica dei componenti di avvio convalidati dal TPM.

  • Aggiornare la scheda madre per sostituire o rimuovere il TPM senza avviare il ripristino di BitLocker.

  • Disattivare o cancellare il TPM senza avviare il ripristino di BitLocker.

  • Spostare un'unità protetta da BitLocker in un altro computer senza avviare il ripristino di BitLocker.

Questi scenari vengono definiti collettivamente come scenario di aggiornamento del computer. BitLocker può essere attivato o disattivato tramite l'elemento Crittografia unità BitLocker nel Pannello di controllo.

Per l'aggiornamento di un computer protetto da BitLocker, è necessario eseguire la procedura seguente:

  1. Disattivare temporaneamente BitLocker impostando la modalità di disabilitazione.

  2. Aggiornare il sistema o il BIOS.

  3. Riattivare BitLocker.

L'impostazione della modalità di disabilitazione di BitLocker consente di mantenere crittografata l'unità, mentre la chiave master dell'unità viene crittografata con una chiave simmetrica archiviata in forma non crittografata nel disco rigido. La disponibilità di questa chiave non crittografata disattiva la protezione dai dati offerta da BitLocker, ma consente di eseguire i successivi avvii del computer senza un ulteriore input dell'utente. Quando BitLocker viene riattivato, la chiave non crittografata viene rimossa dal disco e la protezione BitLocker viene riattivata. La chiave master dell'unità viene inoltre impostata e crittografata di nuovo.

Lo spostamento dell'unità crittografata, ovvero del disco fisico, in un altro computer protetto da BitLocker non richiede passaggi aggiuntivi. La chiave che protegge la chiave master dell'unità, infatti, è archiviata in forma non crittografata nel disco.

Attenzione

L'esposizione della chiave master dell'unità anche per un breve periodo di tempo comporta un rischio di protezione. Questo perché l'autore di un attacco potrebbe avere la possibilità di accedere alla chiave master dell'unità e alla chiave di crittografia dell'intera unità quando tali chiavi vengono esposte dalla chiave non crittografata.

Per informazioni dettagliate sulla disattivazione di BitLocker, vedere la guida dettagliata relativa a Crittografia unità BitLocker di Windows (http://go.microsoft.com/fwlink/?LinkID=140225).

Ripristino di sistema

Il processo di ripristino può essere avviato da una serie di scenari, ad esempio:

  • Lo spostamento dell'unità protetta da BitLocker in un nuovo computer.

  • L'installazione di una nuova scheda madre con un nuovo TPM.

  • La disattivazione o la cancellazione del TPM.

  • L'aggiornamento del BIOS.

  • L'aggiornamento della ROM facoltativa.

  • L'aggiornamento di componenti di avvio critici che causano un errore della convalida dell'integrità del sistema.

  • Lo smarrimento del PIN quando è attivata l'autenticazione con un PIN.

  • La perdita dell'unità memoria flash USB contenente la chiave di avvio quando è attivata l'autenticazione con una chiave di avvio.

Un amministratore può inoltre avviare il ripristino come meccanismo di controllo di accesso, ad esempio durante la ridistribuzione del computer. L'amministratore può decidere di bloccare un'unità crittografata e richiedere agli utenti di ottenere le informazioni di ripristino di BitLocker per lo sblocco dell'unità.

Configurazione del ripristino

Utilizzando i Criteri di gruppo, un amministratore IT può scegliere i metodi di ripristino da impostare come obbligatori, vietati o facoltativi per gli utenti che attivano BitLocker. La password di ripristino può essere archiviata in Servizi di dominio Active Directory e l'amministratore può impostare questa opzione come obbligatoria, vietata o facoltativa per ogni utente del computer. I dati di ripristino possono inoltre essere archiviati in un'unità memoria flash USB.

Password di ripristino

La password di ripristino è un numero generato in modo casuale e composto da 48 cifre che può essere creato durante la configurazione di BitLocker. Se nel computer viene attivata la modalità di ripristino, all'utente verrà chiesto di digitare questa password tramite i tasti funzione (da F0 a F9). La password di ripristino può essere gestita e copiata dopo l'attivazione di BitLocker. È possibile stampare o salvare la password di ripristino per uso futuro utilizzando la pagina Gestione BitLocker dell'elemento Crittografia unità BitLocker nel Pannello di controllo.

Un amministratore di dominio può configurare i Criteri di gruppo in modo da generare le password di ripristino automaticamente ed eseguirne il backup in Servizi di dominio Active Directory non appena viene attivato BitLocker. L'amministratore di dominio può inoltre scegliere di impedire a BitLocker di crittografare un'unità a meno che il computer non sia connesso alla rete e il backup in Servizi di dominio Active Directory della password di ripristino non abbia esito positivo.

Chiave di ripristino

La chiave di ripristino può essere creata e salvata in un'unità memoria flash USB durante la configurazione di BitLocker. Può inoltre essere gestita e copiata dopo l'attivazione di BitLocker. Se nel computer viene attivata la modalità di ripristino, all'utente verrà chiesto di inserire la chiave di ripristino nel computer.


Panoramica di BranchCache

I servizi necessari per le funzionalità client di BranchCache vengono installati automaticamente, così come il supporto server di BranchCache per il protocollo HTTP, la cache ospitata e le applicazioni diverse da file di rete.

Il supporto server di BranchCache per i file di rete è fornito dal servizio ruolo BranchCache per file di rete del ruolo server Servizi file.

Panoramica di BranchCache

BranchCache consente di ridurre l'utilizzo dei collegamenti WAN (Wide Area Network) di connessione tra le succursali e il data center o la sede centrale, garantendo una maggiore velocità di accesso al contenuto già scaricato all'interno delle succursali stesse.

Nei computer delle succursali viene attivata la memorizzazione nella cache dei file e del traffico HTTP dai server della Intranet in cui BranchCache è attivato. I computer di ogni succursale possono recuperare il contenuto dalla cache se dispongono dell'autorizzazione di accesso al contenuto e ricevono l'autorizzazione dal server di origine. Dopo aver ricevuto l'autorizzazione, i computer recuperano il contenuto della cache da un server cache ospitata presente nella succursale, se si utilizza la modalità cache ospitata, o da altri computer client, se si utilizza la modalità cache distribuita.

Ulteriori riferimenti

  • Guida alla distribuzione di BranchCache


Panoramica di Connection Manager Administration Kit

Connection Manager è uno strumento per connessioni di rete client che consente a un utente di connettersi a una rete remota, ad esempio un provider di servizi Internet (ISP, Internet Service Provider), o a una rete aziendale protetta da un server di rete privata virtuale (VPN, Virtual Private Network).

Connection Manager Administration Kit (CMAK) è uno strumento che può essere utilizzato per personalizzare la modalità di esecuzione delle connessioni remote per gli utenti in rete creando connessioni predefinite a reti e server remoti. Per creare e personalizzare una connessione per gli utenti, utilizzare la Configurazione guidata Microsoft Connection Manager Administration Kit.

È possibile utilizzare la Configurazione guidata Microsoft Connection Manager Administration Kit per personalizzare un profilo di connessione in modo da automatizzare molti aspetti di una connessione:

  • Informazioni di accesso per la rete remota.

  • Dettagli relativi alla connessione alla rete privata virtuale (VPN).

  • Informazioni relative alla configurazione del modem e al numero di telefono.

  • Tabelle di routing personalizzate.

  • Impostazioni proxy di Internet Explorer personalizzate.

  • Bitmap e icone personalizzate.

  • File della Guida personalizzato.

  • Azioni personalizzate per l'utilizzo di altri programmi già presenti nel sistema client o da includere con il programma di installazione del profilo di connessione.

La procedura guidata può essere utilizzata per personalizzare tutti gli aspetti del profilo di connessione desiderati. È possibile automatizzare praticamente tutto oppure fornire agli utenti molte opzioni in modo da garantire un'elevata flessibilità.

Installare Connection Manager Administration Kit

Per installare CMAK è possibile utilizzare l'Aggiunta guidata funzionalità in Server Manager. Sebbene Server Manager si apra per impostazione predefinita quando un membro del gruppo Administrators accede al computer, è possibile aprire Server Manager anche utilizzando i comandi del menu Start in Strumenti di amministrazione e aprendo Programmi nel Pannello di controllo.

Ulteriori riferimenti

Per ulteriori informazioni sull'installazione o l'utilizzo di CMAK, vedere la guida operativa di Connection Manager Administration Kit (http://go.microsoft.com/fwlink/?linkid=57535).


Panoramica di Esperienza desktop

La funzionalità Esperienza desktop consente di installare un'ampia gamma di funzionalità di Windows 7 su un server che esegue Windows Server 2008. Se si utilizza Windows Server 2008 come sistema operativo principale, può essere utile avere a disposizione alcune di queste funzionalità di Windows 7 per l'utilizzo quotidiano.

Che cosa include la funzionalità Esperienza desktop?

Esperienza desktop include i componenti e le funzionalità di Windows 7 seguenti:

  • Windows Media Player

  • Temi del desktop

  • Video per Windows (supporto AVI)

  • Windows SideShow

  • Windows Defender

  • Pulizia disco

  • Centro sincronizzazione

  • Registratore di suoni

  • Mappa caratteri

  • Strumento di cattura

Nota

L'installazione di Esperienza desktop non comporta l'attivazione automatica delle funzionalità installate. Dopo l'installazione, è necessario attivare manualmente le funzionalità che richiedono modifiche alla configurazione. Ad esempio, per utilizzare un tema del desktop, utilizzare lo snap-in Servizi per Microsoft Management Console per attivare e avviare il servizio Temi e quindi selezionare il tema.

Installare o disinstallare la funzionalità Esperienza desktop

È possibile installare o disinstallare Esperienza desktop tramite la procedura guidata di configurazione iniziale o tramite Server Manager.

Per installare Esperienza desktop utilizzando la procedura guidata di configurazione iniziale

  1. Nella sezione Personalizza server in uso fare clic su Aggiungi funzionalità.

  2. Selezionare la casella di controllo Esperienza desktop e quindi fare clic su Avanti.

  3. Fare clic su Installa per completare la procedura guidata.

Per installare Esperienza desktop utilizzando Server Manager

  1. Aprire Server Manager: fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Server Manager.

    Note
    • Per aprire Server Manager è inoltre possibile digitare il comando seguente al prompt dei comandi:
    • servermanager.msc

  2. Nella sezione Riepilogo funzionalità fare clic su Aggiungi funzionalità.

  3. Selezionare la casella di controllo Esperienza desktop e quindi fare clic su Avanti.

  4. Fare clic su Installa per completare la procedura guidata.

È possibile disinstallare Esperienza desktop in qualsiasi momento utilizzando uno dei metodi sopra descritti per avviare Aggiunta guidata funzionalità. Nella procedura guidata deselezionare la casella di controllo Esperienza desktop, fare clic su Avanti e quindi fare clic su Rimuovi per completare la procedura guidata.


Panoramica di DirectAccess

DirectAccess consente agli utenti remoti di accedere in modo sicuro alle condivisioni di file, ai siti Web e alle applicazioni di una rete interna senza connettersi a una rete privata virtuale (VPN). Una rete interna è anche definita rete privata o Intranet. DirectAccess stabilisce una connettività bidirezionale con una rete interna ogni volta che un computer in cui è attivato DirectAccess si connette a Internet, anche prima dell'accesso dell'utente. Gli utenti non devono preoccuparsi della connessione alla rete interna e gli amministratori IT possono gestire i computer remoti all'esterno dell'ufficio, anche quando i computer non sono connessi alla VPN.

È possibile utilizzare la console Gestione DirectAccess per configurare un'infrastruttura DirectAccess eseguendo le attività seguenti:

  • Specificare i computer client che possono utilizzare DirectAccess selezionando i gruppi di sicurezza a cui appartengono.

  • Configurare le schede di rete nel server DirectAccess che sono connesse alla rete interna e a Internet e i certificati che si desidera utilizzare per l'autenticazione.

  • Configurare il percorso di un sito Web interno in modo che i computer client DirectAccess possano determinare quando si trovano nella rete interna.

  • Configurare i nomi DNS (Domain Name Service) che devono essere risolti dai server DNS della rete interna.

  • Identificare i server di infrastruttura (server dei percorsi di rete, server DNS e server di gestione).

  • Identificare i server applicazioni per l'autenticazione facoltativa.

Per il monitoraggio di DirectAccess, utilizzare la console Gestione DirectAccess per determinare lo stato dei componenti di DirectAccess che sono in esecuzione nel server.

Ulteriori riferimenti

Informazioni sui componenti di DirectAccess

Informazioni sui modelli di distribuzione di DirectAccess

Per ulteriori informazioni, vedere la home page di DirectAccess nel sito Web Microsoft Technet all'indirizzo http://go.microsoft.com/fwlink/?LinkID=142598.


Panoramica di Gestione Criteri di gruppo

Gestione Criteri di gruppo include la console Gestione Criteri di gruppo, Microsoft Management Console che consente di gestire Criteri di gruppo in modo economicamente vantaggioso per l'azienda.

La console Gestione Criteri di gruppo semplifica la gestione di Criteri di gruppo basati su domini, consentendo la gestione, la modifica e la creazione di rapporti sugli aspetti chiave di Criteri di gruppo, e può essere considerata una risorsa unica per la gestione dei requisiti di Criteri di gruppo.

La console Gestione Criteri di gruppo include:

  • Un'interfaccia utente che aumenta la semplicità di utilizzo di Criteri di gruppo.

  • Il backup e il ripristino di oggetti Criteri di gruppo.

  • L'importazione/esportazione e il copia/incolla di oggetti Criteri di gruppo e filtri di Strumentazione gestione Windows (WMI).

  • La gestione semplificata della sicurezza relativa a Criteri di gruppo.

  • La creazione di rapporti HTML per le impostazioni degli oggetti Criteri di gruppo e i dati relativi al gruppo di criteri risultante.

  • La possibilità di includere commenti di testo negli oggetti Criteri di gruppo e nelle impostazioni dei criteri basate sul Registro di sistema.

  • Visualizzazioni filtrate delle impostazioni dei criteri basate sul Registro di sistema che utilizzano parole chiave all'interno del titolo, del testo della Guida o dei commenti delle impostazioni dei criteri.

  • Oggetti Criteri di gruppo Starter: insiemi portatili di impostazioni dei criteri basate sul Registro di sistema che rappresentano punti di partenza per gli oggetti Criteri di gruppo.

  • Preferenze: ventuno estensioni Criteri di gruppo aggiuntive che consentono di gestire mapping di unità, impostazioni del Registro di sistema, gruppi e utenti locali, servizi, file, cartelle e altro ancora senza necessità di conoscere linguaggi di script.


Panoramica dei cluster di failover

In questo argomento sono incluse le sezioni seguenti:

  • Disponibilità, scalabilità e tecnologie di clustering

  • Panoramica dei cluster di failover

Disponibilità, scalabilità e tecnologie di clustering

Windows Server® 2008 offre due tecnologie di clustering: cluster di failover e Bilanciamento carico di rete. I cluster di failover garantiscono principalmente un'alta disponibilità, mentre Bilanciamento carico di rete offre scalabilità aumentando allo stesso tempo la disponibilità dei servizi Web.

La scelta della tecnologia di clustering (cluster di failover o Bilanciamento carico di rete) più adatta dipende principalmente dal fatto che le applicazioni eseguite abbiano o meno uno stato in memoria di lunga durata:

  • I cluster di failover sono progettati per applicazioni con stato in memoria di lunga durata o stati di dati di grandi dimensioni e aggiornati di frequente. Tali applicazioni vengono denominate applicazioni con stato e includono applicazioni di database e messaggistica. I cluster di failover vengono in genere utilizzati da file server, server di stampa, server database e server di messaggistica.

  • Bilanciamento carico di rete è dedicato ad applicazioni che non hanno stato in memoria di lunga durata. Queste applicazioni vengono denominate applicazioni senza stato. Un'applicazione senza stato tratta ogni richiesta client come un'operazione indipendente e può pertanto bilanciare il carico di ogni richiesta in modo indipendente. Le applicazioni senza stato hanno spesso dati di sola lettura o dati che vengono modificati raramente. Bilanciamento carico di rete viene in genere utilizzato da server Web front-end, reti private virtuali, server FTP (File Transfer Protocol) e server proxy e firewall. I cluster di Bilanciamento carico di rete offrono inoltre il supporto per altri servizi e applicazioni TCP o UDP.

Panoramica dei cluster di failover

L'utilizzo di un cluster di failover consente di garantire agli utenti un accesso quasi continuo a risorse importanti basate sui server. Un cluster di failover è costituito da un insieme di computer indipendenti che interagiscono tra loro per aumentare la disponibilità di servizi e applicazioni. I server inclusi nel cluster (denominati nodi) sono connessi mediante cavi fisici e software. Se si verificano problemi in uno dei nodi, i servizi verranno forniti da un altro nodo. Tale processo è noto come failover.

È possibile utilizzare lo snap-in Gestione cluster di failover per creare e gestire cluster di failover, convalidarne le configurazioni ed eseguire la migrazione di alcune impostazioni delle risorse in un cluster che esegue Windows Server 2008 R2.

In Windows Server 2008 le modifiche ai cluster di failover, noti in precedenza come cluster di server, hanno lo scopo di semplificare la configurazione e la gestione dei cluster, in modo da potenziare la sicurezza e la stabilità, migliorare i servizi di rete e ottimizzare le modalità di comunicazione tra i cluster di failover e il sistema di archiviazione.

Che cosa sono i cluster di failover?

Un cluster di failover è costituito da un gruppo di server indipendenti che eseguono Windows Server 2008 e interagiscono tra loro per aumentare la disponibilità di servizi e applicazioni. Se in un computer del cluster si verifica un errore, le risorse vengono reindirizzate e il carico di lavoro viene ridistribuito su un altro computer del cluster. I cluster di failover consentono di garantire agli utenti un accesso quasi continuo a risorse importanti basate sui server.

Considerazioni relative ai requisiti hardware e software per i cluster di failover

Nota

È disponibile un insieme limitato di ruoli server per l'opzione di installazione di Server Core di Windows Server 2008 e per Windows Server 2008 per sistemi basati su Itanium.

Microsoft supporta una soluzione di cluster di failover solo se tutti i componenti hardware sono contrassegnati con il logo "Certified for Windows Server 2008 R2". È necessario inoltre che la configurazione completa, ovvero server, rete e memoria, superi tutti i test della Convalida guidata configurazione, inclusa nello snap-in Gestione cluster di failover.

Il software utilizzato per la gestione di un cluster di failover è costituito dallo snap-in Gestione cluster di failover, installato come parte della funzionalità di cluster di failover in Windows Server 2008 R2, mentre il servizio sottostante che supporta i cluster di failover è costituito dal Servizio cluster.

Installare la funzionalità di cluster di failover

Per installare le funzionalità, utilizzare Attività di configurazione iniziali o Server Manager. Per installare la funzionalità di cluster di failover:

  1. Nell'elenco delle attività fare clic su Aggiungi funzionalità.

  2. Nell'elenco delle funzionalità disponibili nella procedura guidata fare clic su Clustering di failover.

Gestire un cluster di failover

È possibile gestire le funzionalità e i ruoli del server con snap-in di MMC (Microsoft Management Console). Per aprire lo snap-in per i cluster di failover, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione cluster di failover.

Ulteriori riferimenti per il clustering di failover

Per ulteriori informazioni sui cluster di failover, è possibile visualizzare la Guida nel server in uso. A tale scopo, aprire lo snap-in relativo al cluster di failover come descritto nella sezione precedente e quindi premere F1..

Per ulteriori informazioni sui cluster di failover, vedere le risorse seguenti nel sito Web Microsoft:

  • Per un elenco di collegamenti a numerosi argomenti dedicati ai cluster di failover, vedere http://go.microsoft.com/fwlink/?LinkId=68633.

  • Per informazioni sulla progettazione e la distribuzione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137832.

  • Per informazioni sulle operazioni relative ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137835.

  • Per informazioni sulla risoluzione dei problemi relativi ai cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137836.


Panoramica di Servizi di input penna e riconoscimento grafia

Servizi di input penna e riconoscimento grafia include funzionalità di ruolo facoltative che offrono il supporto per input penna e il riconoscimento della grafia e delle espressioni matematiche. Per utilizzare la funzionalità Riconoscimento grafia è necessario che Supporto per input penna sia installato.

Per ulteriori informazioni sulla funzionalità Servizi di input penna e riconoscimento grafia, vedere la pagina relativa a Servizi di input penna e riconoscimento grafia.

Che cos'è Riconoscimento grafia?

Riconoscimento grafia consente agli utenti di avviare il Pannello input penna di Tablet PC (TIP), scrivere nella lingua desiderata e inserire il testo riconosciuto e convertito automaticamente in applicazioni quali Microsoft Outlook® o Word. Personalizzazione, una funzionalità di riconoscimento della grafia, consente progressivamente al componente di riconoscimento di interpretare il testo scritto dall'utente e lo stile grafico, migliorando nel tempo la grafia dell'utente.

Che cos'è Supporto per input penna?

La funzionalità Supporto per input penna include i componenti correlati a Tablet PC precedentemente inclusi in Desktop Experience Pack per Windows Server 2008, ad esempio il supporto per l'input utente mediante digitalizzatori a penna, mouse e dispositivi touch screen.


Panoramica di Client di stampa Internet

La funzionalità Client di stampa Internet consente agli utenti di utilizzare il protocollo IPP (Internet Printing Protocol) per connettersi alle stampanti attraverso la rete locale o Internet e di utilizzarle per la stampa. Per utilizzare Client di stampa Internet e il protocollo IPP per connettersi alla stampante condivisa è possibile utilizzare un Web browser, se nel server di stampa è installato il ruolo Stampa Internet.

Per utilizzare Client di stampa Internet per connettersi o stampare su un server di stampa tramite IPP, devono essere soddisfatte le condizioni seguenti:

  • Nel server di stampa devono essere installati il servizio ruolo Stampa Internet e il ruolo Server Web (IIS).

  • Il computer client deve essere in grado di raggiungere il server di stampa tramite una connessione locale, Wide Area Network (WAN) o Internet.

Nota

Se il computer client può accedere al server di stampa tramite una rete locale (LAN) o una connessione WAN, verrà stabilita automaticamente una connessione RPC (Remote Procedure Call) al server di stampa, che è più veloce di IPP. Se è possibile connettersi al server di stampa utilizzando una connessione RPC, non è necessario utilizzare Client di stampa Internet.

Ulteriori riferimenti

Per ulteriori informazioni su Client di stampa Internet, vedere le risorse seguenti nel sito Web Microsoft:

  • Come installare e utilizzare il client di stampa IP (http://go.microsoft.com/fwlink/?LinkId=143901).


Panoramica di Server iSNS

Server iSNS (Internet Storage Name Service)

Il protocollo iSNS (Internet Storage Name Service) viene utilizzato per l'interazione tra i server e i client iSNS. I client iSNS sono computer, noti anche come iniziatori, che tentano di individuare dispositivi di archiviazione, noti anche come destinazioni, su una rete Ethernet. iSNS consente di individuare, gestire e configurare automaticamente dispositivi iSCSI e Fibre Channel tramite gateway iFCP su una rete TCP/IP.

Nota

Server iSNS Microsoft supporta solo l'individuazione di dispositivi iSCSI e non di dispositivi Fibre Channel.

Server iSNS offre servizi di individuazione e gestione intelligenti paragonabili a quelli disponibili nelle reti Fibre Channel, consentendo a una rete IP commodity di funzionare con capacità simile a una rete di archiviazione (SAN). iSNS consente di integrare in modo più completo le reti IP e di gestire dispositivi iSCSI. Questo protocollo rappresenta pertanto un valore aggiunto in una rete di archiviazione dotata di dispositivi iSCSI.

Funzionalità di Server iSNS

  • Server iSNS è un archivio di nodi iSCSI attualmente attivi, nonché dei relativi portali, entità e così via.

  • I nodi possono essere iniziatori, destinazioni o nodi di gestione.

  • Gli iniziatori e le destinazioni in genere eseguono la registrazione nel server iSNS e gli iniziatori eseguono una query sul server iSNS per ottenere l'elenco delle destinazioni disponibili.

  • Un database dinamico dei dispositivi iSCSI e delle informazioni correlate attualmente disponibili nella rete: il database contribuisce alla funzionalità di individuazione delle destinazioni iSCSI per gli iniziatori iSCSI nella rete. Il database viene mantenuto in uno stato dinamico tramite le funzionalità di iSNS relative al periodo di registrazione e all'interrogazione sullo stato dell'entità. La funzionalità relativa al periodo di registrazione consente al server di annullare automaticamente la registrazione delle voci obsolete. La funzionalità relativa all'interrogazione sullo stato dell'entità fornisce al server una funzionalità simile al comando ping per determinare se i client registrati sono ancora presenti nella rete e consente al server di annullare automaticamente la registrazione dei client non più presenti.

  • Servizio di notifica di modifica dello stato: consente ai client registrati di ricevere notifiche relative alle modifiche apportate al database nel server iSNS. Consente ai client di mantenere un'immagine dinamica dei dispositivi iSCSI disponibili nella rete.

  • Servizio DD: consente a un amministratore di assegnare nodi e portali iSCSI in uno o più gruppi denominati oggetti DD. Gli oggetti DD offrono una funzionalità di suddivisione in zone tramite la quale un iniziatore iSCSI può solo individuare le destinazioni iSCSI che condividono con esso almeno un oggetto DD.

Vantaggi offerti da Server iSNS nelle reti di archiviazione iSCSI

  • Gestione centralizzata

  • Scalabilità in reti di archiviazione IP estese

  • Estendibilità

  • Notifica asincrona delle modifiche apportate nella rete di archiviazione iSCSI

  • Monitoraggio dello stato e della disponibilità dei client

  • Modalità di individuazione per iSCSI preferita di Microsoft

  • Requisito programma Designed for Windows Logo Program per HBA iSCSI

Componenti dell'architettura iSNS

Nella sezione seguente vengono descritti i componenti inclusi nel server iSNS.

Protocollo iSNSP (iSNS Protocol)

iSNSP (iSNS Protocol) è un protocollo semplice e flessibile che specifica la modalità di comunicazione tra client e server iSNS. È indicato per diverse piattaforme, inclusi switch e destinazioni, nonché per host server.

iSNSP è un protocollo basato sui messaggi le cui operazioni utilizzano nella maggior parte dei casi una richiesta e un messaggio di risposta corrispondente, che insieme formano una singola transazione.

Ogni messaggio del protocollo è costituito da un'intestazione seguita da un elenco di attributi. Un attributo di origine, ad esempio il nome iSCSI del nodo richiedente, in genere è seguito da uno o più attributi chiave ed eventualmente da uno o più attributi operativi. Per separare gli attributi operativi dall'attributo chiave viene utilizzato un attributo delimitatore.

  • Tutti gli attributi sono in formato TLV (Tag-Length-Value)

  • La lunghezza del valore di ogni attributo viene espressa con un multiplo di quattro

  • Tutti i campi sono in formato "big-endian" o byte di rete

Client iSNS

I client iSNS avviano le transazioni con i server iSNS utilizzando il protocollo iSNSP. I client sono processi co-residenti nel dispositivo di archiviazione che possono registrare le informazioni attributo dei dispositivi, scaricare informazioni su altri client registrati in un oggetto DD comune e ricevere una notifica asincrona di eventi che si verificano negli oggetti DD. Le stazioni di gestione sono un tipo speciale di client iSNS con accesso a tutti gli oggetti DD archiviati in iSNS.

Server iSNS

I server iSNS rispondono alle query e alle richieste del protocollo iSNS e avviano le notifiche di modifica dello stato del protocollo iSNS. Le informazioni autenticate correttamente inoltrate da una richiesta di registrazione vengono archiviate in un database iSNS.

Database iSNS

Il database iSNS è l'archivio informazioni dei server iSNS in cui vengono conservate le informazioni sugli attributi dei client iSNS. Un'implementazione di iSNS abilitata all'utilizzo di directory può archiviare attributi di client in un'infrastruttura di directory LDAP (Lightweight Directory Access Protocol).

iSCSI

iSCSI (Internet Small Computer System Interface) è un incapsulamento di SCSI per una nuova generazione di dispositivi di archiviazione interconnessi con TCP/IP (iSCSI).

Panoramica delle funzionalità di iSNS

I servizi forniti da iSNS sono i seguenti:

  • Servizio nomi per l'individuazione delle risorse di archiviazione

  • Servizi DD e di controllo degli accessi

  • Servizio di notifica di modifica dello stato

  • Mapping aperto di dispositivi Fibre Channel e iSCSI

Servizio di registrazione dei nomi

In iSNS è disponibile una funzionalità di registrazione che consente a tutte le entità di una rete di archiviazione di eseguire registrazioni e query sul database iSNS. Le destinazioni e gli iniziatori possono entrambi eseguire la registrazione nel database iSNS, nonché eseguire query relative a informazioni su altri iniziatori e destinazioni. In questo modo un iniziatore client può ad esempio ottenere informazioni su dispositivi di destinazione dal server iSNS. Questo servizio è basato su Fibre Channel Generic Services Name Server, descritto nei documenti Request for Comment (RFC) di Internet Engineering Task Force (IETF), con estensioni, utilizzato nel contesto di una rete IP.

Servizi DD e di controllo degli accessi

Il servizio DD consente di partizionare i nodi di archiviazione in gruppi gestibili per il controllo amministrativo e degli accessi. Consente all'amministratore di limitare il processo di accesso di ogni host al sottoinsieme più idoneo di destinazioni registrate in iSNS. In questo modo è possibile ridurre il numero di accessi iSCSI non necessari e limitare il tempo dedicato dagli host all'inizializzazione di relazioni di accesso man mano che aumenta la dimensione della rete di archiviazione. Per ottenere informazioni su altri nodi di archiviazione, i nodi di archiviazione devono essere contenuti in almeno un oggetto DD comune attivato. I dispositivi possono essere membri di più oggetti DD.

Il controllo degli accessi consente alle destinazioni di delegare il criterio di controllo degli accessi o di autorizzazione al server iSNS. In questo modo è possibile centralizzare la gestione dei dispositivi di archiviazione che utilizzano il server iSNS. Il nodo o il dispositivo di destinazione scarica da iSNS l'elenco degli iniziatori autorizzati. Ogni nodo o dispositivo è identificato in modo univoco da un nome iSCSI, indicato anche come iqn. Solo gli iniziatori che soddisfano l'identificazione e l'autorizzazione fornite da iSNS saranno autorizzati per l'accesso dal nodo di destinazione quando viene stabilita la sessione.

L'inserimento di portali di un'entità di rete in oggetti DD consente agli amministratori di indicare l'interfaccia portale IP preferita tramite la quale il traffico di archiviazione deve accedere a nodi di archiviazione specifici dell'entità di rete. Se non vengono inseriti portali di un'entità di rete in un oggetto DD, nelle query con ambito relativo all'oggetto DD verranno segnalati tutti i portali dell'entità di rete. Se invece in un oggetto DD viene inserito uno o più portali di un'entità di rete, nelle query con ambito relativo a tale oggetto DD verranno segnalati solo i portali inseriti in modo esplicito nell'oggetto DD.

Gli oggetti DD possono essere gestiti offline tramite un computer di gestione separato che utilizza il protocollo iSNSP o SNMP. Se utilizza la funzionalità di controllo degli accessi di iSNS, la destinazione delega la gestione del criterio di controllo degli accessi, ovvero l'elenco degli iniziatori autorizzati ad accedere alla destinazione, ai computer di gestione che controllano la configurazione del database iSNS.

Se autorizzata dall'amministratore, una destinazione può caricare il proprio elenco di controllo di accesso. A tale scopo, viene utilizzato il messaggio DDReg e viene elencato il nome iSCSI di ogni iniziatore da registrare nell'oggetto DD della destinazione.

Un'implementazione può ordinare dispositivi appena registrati non assegnati a un oggetto DD in un oggetto DD predefinito contenuto in un oggetto DDS predefinito il cui stato iniziale corrisponde al valore enabled. In questo modo saranno visibili agli altri dispositivi nell'oggetto DD predefinito. Altre implementazioni possono interpretare dispositivi appena registrati come appartenenti a nessun oggetto DD, rendendoli inaccessibili ai messaggi iSNSP con ambito relativo all'origine.

Il server iSNS utilizza l'attributo di origine di ogni messaggio iSNSP per determinare l'origine della richiesta e definire come ambito dell'operazione un insieme di oggetti DD. Solo i nodi di controllo ad esempio sono autorizzati a creare o eliminare gli oggetti DD.

Gli oggetti DD validi e attivi appartengono ad almeno un oggetto DDS attivo. Gli oggetti DD che non appartengono a un oggetto DDS attivato non sono abilitati. Il server iSNS mantiene lo stato di appartenenza agli oggetti DD per tutti i nodi di archiviazione, anche quelli di cui è stata annullata la registrazione. L'appartenenza agli oggetti DD è permanente indipendentemente dal fatto che un nodo di archiviazione sia attivamente registrato nel database iSNS.

Servizio di notifica di modifica dello stato

Il servizio di notifica di modifica dello stato consente al server iSNS di inviare notifiche su eventi di rete che hanno effetto sullo stato operativo dei nodi di archiviazione. Il client iSNS può eseguire la registrazione per le notifiche per conto dei propri nodi di archiviazione in modo da ricevere le notifiche di eventi rilevati dal server iSNS. Le notifiche di modifica dello stato segnalano ai client iSNS le modifiche apportate al database iSNS e non indicano necessariamente lo stato di connettività con i dispositivi di archiviazione peer della rete. La risposta di un dispositivo di archiviazione alla ricezione di una notifica di modifica dello stato è specifica dell'implementazione. Il criterio di risposta alle notifiche di modifica dello stato non rientra nell'ambito di questo modulo.

Esistono due tipi di registrazioni di notifica di modifica dello stato: registrazioni standard e registrazioni di gestione. Le registrazioni di gestione danno origine a notifiche di modifica dello stato di gestione, mentre le registrazioni standard danno origine a notifiche di modifica dello stato standard. Il tipo di registrazione e di messaggio di notifica di modifica dello stato sono indicati nel pacchetto di risposta di notifica di modifica dello stato, in genere una bitmap.

Una registrazione di notifica di modifica dello stato standard indica che viene utilizzato il servizio DD per controllare la distribuzione di messaggi di notifica di modifica dello stato. La ricezione di notifiche di modifica dello stato standard è limitata agli oggetti DD in cui si verifica l'evento che genera la notifica di modifica dello stato. Le notifiche di modifica dello stato standard non contengono informazioni sugli oggetti DD.

Una registrazione di notifica di modifica dello stato di gestione può essere richiesta solo dai nodi di controllo. Le notifiche di modifica dello stato di gestione risultanti dalle registrazioni di gestione non sono vincolate dal servizio DD. L'autorizzazione per la richiesta di registrazioni di notifiche di modifica dello stato di gestione può essere controllata dall'amministratore.

Un server iSNS deve essere implementato con risorse hardware e software sufficienti per supportare il numero previsto di client iSNS. Se tuttavia le risorse vengono esaurite inaspettatamente, il server iSNS potrebbe rifiutare il servizio di notifica di modifica dello stato restituendo un messaggio di evento che indica che la registrazione della notifica di modifica dello stato è stata rifiutata (codice di stato 17). Il rifiuto può verificarsi quando la dimensione della rete o il numero corrente di registrazioni di notifiche di modifica dello stato supera la soglia specifica di un'implementazione. Un client non autorizzato a eseguire la registrazione per le notifiche di modifica dello stato può monitorare le proprie sessioni direttamente con altri dispositivi di archiviazione.

Il meccanismo di notifica specifico in base al quale il server iSNS viene a conoscenza di eventi che generano notifiche di modifica dello stato è specifico dell'implementazione, ma può includere esempi come messaggi di notifica espliciti da un client iSNS al server iSNS o un interrupt hardware per un server iSNS ospitato in uno switch come risultato di un errore di collegamento.

Modello di utilizzo di iSNS

Di seguito viene riportata una descrizione di alto livello della modalità di utilizzo di iSNS in ogni tipo di dispositivo di una rete di archiviazione. Ogni tipo di dispositivo interagisce con il server iSNS come un client iSNS e deve eseguire la registrazione nel database iSNS per accedere ai servizi offerti da iSNS.

Iniziatore iSCSI

Un iniziatore iSCSI esegue query sul server iSNS per individuare i dispositivi di destinazione iSCSI. Può inoltre richiedere notifiche di modifica dello stato in modo da essere avvisato della presenza di nuove destinazioni nella rete dopo l'avvio e l'individuazione iniziali. Le notifiche di modifica dello stato possono inoltre informare l'iniziatore iSCSI di destinazioni che sono state rimosse o non sono più disponibili nella rete di archiviazione, in modo da consentire la chiusura normale di sessioni di archiviazione incomplete e la riallocazione di risorse allocate a destinazioni non esistenti.

Destinazione iSCSI

Una destinazione iSCSI viene individuata da iniziatori iSCSI tramite la registrazione nel server iSNS. Può inoltre eseguire la registrazione per notifiche di modifica dello stato in modo da individuare l'aggiunta o la rimozione di iniziatori e consentire l'allocazione delle risorse. Il dispositivo di destinazione iSCSI può infine eseguire la registrazione per messaggi di interrogazione sullo stato dell'entità, che consentono al server iSNS di monitorare la disponibilità del dispositivo di destinazione nella rete di archiviazione.

Stazione di gestione

Una stazione di gestione utilizza iSNS per monitorare i dispositivi di archiviazione e attivare o disattivare le sessioni di archiviazione configurando oggetti DD. Una stazione di gestione in genere interagisce con il server iSNS come nodo di controllo dotato di accesso a tutti i record del database iSNS e di privilegi per la modifica degli oggetti DD. Mediante la modifica di oggetti DD, la stazione di gestione controlla l'ambito dell'oggetto DD per i client iSNS che eseguono query sul server iSNS.

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Panoramica di Monitor porta LPR (Line Printer Remote)

Monitor porta LPR (Line Printer Remote) consente a un computer che esegue Microsoft Windows Vista, Windows 7, Windows Server 2008 o Windows Server 2008 R2 di stampare sul servizio Line Printer Daemon (LPD) in un server di stampa UNIX.

Nota

Non è necessario installare Monitor porta LPR per stampare su una stampante o su un server di stampa che utilizza il protocollo LPD, a meno che non si tratti di un server di stampa UNIX. Per stampare su una stampante o un server di stampa che utilizza il protocollo LPD mediante un computer che esegue Microsoft Windows Vista, Windows 7, Windows Server 2008 o Windows Server 2008 R2, è possibile utilizzare l'Installazione guidata stampante di rete e una porta stampante TCP/IP standard, che è più veloce di una porta LPR.

Dopo l'installazione di Monitor porta LPR, il tipo di porta LPR viene aggiunto automaticamente all'Installazione guidata stampante di rete. Per installare una stampante in una porta LPR, utilizzare i passaggi seguenti:

Installare una stampante in una porta LPR

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare doppio clic su Gestione stampa.

  2. Espandere Server di stampa e quindi fare clic con il pulsante destro del mouse sul server di stampa a cui si desidera aggiungere la stampante e scegliere Aggiungi stampante. Verrà visualizzata l'Installazione guidata stampante di rete.

  3. Fare clic su Creare una nuova porta e aggiungere una nuova stampante e quindi su Porta LPR.

  4. Utilizzare la finestra di dialogo Aggiungi stampante compatibile LPR per digitare l'indirizzo IP o il nome host del server di stampa UNIX che ospita la stampante condivisa, nonché il nome della coda di stampa.

  5. Fare clic su OK e quindi seguire le istruzioni dell'Installazione guidata stampante di rete per scegliere o installare i driver delle stampanti e condividere la stampante nella rete.

Ulteriori riferimenti

Per ulteriori informazioni su Monitor porta LPR (Line Printer Remote), vedere le risorse seguenti nel sito Web Microsoft:

  • Porte stampanti di rete (http://go.microsoft.com/fwlink/?LinkId=143902)


Panoramica di Accodamento messaggi

Accodamento messaggi, noto anche come MSMQ, è un'infrastruttura di messaggistica e uno strumento di sviluppo per la creazione di applicazioni distribuite di messaggistica per Microsoft Windows. Le applicazioni sviluppate per Accodamento messaggi inviano i messaggi alle code, ovvero percorsi di archiviazione temporanea, dalle quali i messaggi proseguono verso la destinazione finale quando le condizioni lo consentono. Tali applicazioni possono comunicare su reti eterogenee e consentono l'invio di messaggi tra computer che non sono temporaneamente in grado di connettersi tra di loro. Accodamento messaggi offre i vantaggi seguenti:

  • Recapito di messaggi garantito

  • Routing efficiente

  • Sicurezza migliorata

  • Supporto per l'invio di messaggi nell'ambito delle transazioni

  • Messaggistica basata su criteri di priorità

Le definizioni più ricorrenti di prodotti software dotati di queste funzionalità sono le seguenti:

  • Software di accodamento messaggi

  • Software di archiviazione e inoltro

  • Middleware orientato ai messaggi

Tramite Accodamento messaggi, gli utenti finali possono comunicare attraverso reti e computer anche disconnessi, indipendentemente dallo stato corrente della rete e dei computer. Gli amministratori di sistema possono utilizzare Accodamento Messaggi per gestire in modo efficiente reti grandi e complesse di computer e code di messaggi.

In questo argomento vengono descritte le funzionalità disponibili con Accodamento messaggi.

Server di Accodamento messaggi

Questa funzionalità è il componente di base di Accodamento messaggi e consente di eseguire le operazioni di base di Accodamento messaggi. Per ulteriori informazioni sulla funzionalità Server di Accodamento messaggi, vedere la pagina relativa ad Accodamento messaggi (http://go.microsoft.com/fwlink/?LinkId=93512).

Integrazione servizio directory

Questa funzionalità consente di pubblicare le proprietà della coda in Active Directory, di eseguire automaticamente l'autenticazione e la crittografia dei messaggi mediante i certificati registrati in Active Directory e di eseguire il routing dei messaggi attraverso i siti. Per ulteriori informazioni sulla funzionalità Integrazione servizio directory, vedere la pagina relativa a questa funzionalità (http://go.microsoft.com/fwlink/?LinkId=93513).

Trigger Accodamento messaggi

Questa funzionalità consente di richiamare un componente COM o un eseguibile in base i filtri definiti per i messaggi in ingresso in una coda specifica. Per ulteriori informazioni sulla funzionalità Trigger Accodamento messaggi, vedere la pagina relativa alla panoramica dei trigger (http://go.microsoft.com/fwlink/?LinkId=93514).

Supporto HTTP

Questa funzionalità consente di inviare e ricevere messaggi su HTTP. Per ulteriori informazioni sulla funzionalità Supporto HTTP, vedere la pagina relativa alla messaggistica Internet (http://go.microsoft.com/fwlink/?LinkId=93515).

Supporto multicast

Questa funzionalità consente di accodare e inviare messaggi multicast a un indirizzo IP multicast. Per ulteriori informazioni sulla funzionalità Supporto multicast, vedere la pagina relativa al multicast IP (http://go.microsoft.com/fwlink/?LinkId=93516).

Servizio di routing

Questa funzionalità consente di instradare i messaggi tra siti diversi e all'interno di uno stesso sito. Per ulteriori informazioni sulla funzionalità Servizio di routing, vedere la pagina relativa al routing di Accodamento messaggi (http://go.microsoft.com/fwlink/?LinkId=93517).

Proxy DCOM di Accodamento messaggi

Questa funzionalità consente all'API DCOM di MSMQ di connettersi a un server di Accodamento messaggi remoto.

Code secondarie

Questa funzionalità consente il raggruppamento logico dei messaggi in una coda senza creare un'altra coda fisica. Le code secondarie sono code locali create in modo implicito, ovvero partizioni logiche di una coda fisica. Le applicazioni possono utilizzare le code secondare per raggruppare i messaggi.

Spostare messaggi

È possibile spostare i messaggi in tre modi diversi:

  • Utilizzando la finestra di dialogo Sposta messaggio.

  • Eseguendo un'operazione di taglia e incolla.

  • Eseguendo un'operazione di trascinamento della selezione.

È possibile spostare messaggi tra code secondarie della stessa coda principale o da una coda principale alla propria coda secondaria. Non è possibile spostare messaggi dalla coda principale a una coda secondaria di una coda principale diversa o tra due code principali o tra due code secondarie di code principali diverse.

Il messaggio viene spostato nello stato in cui si trova dalla coda di origine alla coda di destinazione. Le proprietà del messaggio rimangono invariate ad eccezione del conteggio spostamenti.

Code di messaggi non recapitabili per applicazione

In Accodamento messaggi 4.0 sono state introdotte code di messaggi non recapitabili per applicazione in modo che ogni applicazione possa utilizzare la propria coda di messaggi non recapitabili. Un'applicazione può richiedere la propria coda di messaggi non recapitabili utilizzando la proprietà PROPID_M_DEADLETTER_QUEUE come parte del messaggio. Anziché alla coda dei messaggi non recapitabili relativi a transazioni di sistema, il messaggio viene inviato alla coda specificata nella proprietà PROPID_M_DEADLETTER_QUEUE.

È possibile impostare la proprietà PROPID_M_DEADLETTER_QUEUE per ogni percorso valido di una coda di transazione. È necessario che la coda di transazione sia locale rispetto a Gestione code che sposta il messaggio di riconoscimento negativo nella coda. Per la definizione di un percorso valido, vedere la pagina sui nomi dei percorsi della coda (http://go.microsoft.com/fwlink/?LinkId=69583).

Ricezione remota di transazione

La ricezione remota di transazione è un ricezione di transazione di un messaggio da una coda remota. Esistono scenari nei quali è necessaria una ricezione remota di transazione. Ad esempio, quando gli ordini di lavoro di una coda centrale remota devono essere elaborati da una farm di server applicazioni, la ricezione remota di transazione attiva l'elaborazione del messaggio in modo che il carico venga bilanciato sul server farm.

Possibilità di gestire un numero elevato di code di Accodamento messaggi

In Accodamento messaggi 5.0 è stata introdotta la nuova funzionalità seguente, rilasciata con Windows 7 e Windows Server 2008 R2:

Accodamento messaggi 5.0 consente di gestire un numero significativamente superiore di code rispetto ad Accodamento messaggi 4.0.. Benché in Accodamento messaggi 4.0 non sia previsto un limite specifico per il numero di code che è possibile creare, in presenza di diverse migliaia di code si verifica un rallentamento delle prestazioni. In modo particolare il rallentamento si verifica per l'avvio dei servizi di Accodamento messaggi 4.0 durante il caricamento di un considerevole numero di code in memoria a causa dell'algoritmo di ricerca delle code utilizzato. Con l'ottimizzazione dell'algoritmo di ricerca delle code utilizzato da Accodamento messaggi 5.0 all'avvio è possibile riscontrare un miglioramento significativo delle prestazioni all'avvio in presenza di un numero elevato di code ospitate nel sistema.

Ulteriori riferimenti

Funzionalità di Accodamento messaggi (http://go.microsoft.com/fwlink/?LinkId=93518)


Panoramica di Multipath I/O

Supporto di percorsi multipli per una maggiore disponibilità

In Windows Server® 2008 sono disponibili numerosi miglioramenti per la connessione di un computer che esegue un sistema operativo di tipo Windows Server a dispositivi di rete di archiviazione (SAN).

Tra i miglioramenti che garantiscono un'elevata disponibilità per la connessione di server basati su Windows a reti di archiviazione (SAN) è incluso il supporto Multipath I/O (MPIO) integrato. L'architettura Microsoft MPIO supporta una connettività SAN di tipo iSCSI, Fibre Channel e SAS (Serial Attached Storage) stabilendo più sessioni o connessioni all'array di archiviazione.

Le soluzioni a percorsi multipli utilizzano componenti con percorsi fisici ridondanti, ad esempio schede, cavi e switch, per creare percorsi logici tra il server e il dispositivo di archiviazione. Se si verifica un errore in uno o più di questi componenti, con conseguente errore del percorso, la logica dei percorsi multipli utilizza un percorso alternativo per l'I/O in modo che le applicazioni possano continuare ad accedere ai dati. Ogni scheda di interfaccia di rete, nel caso iSCSI, o HBA deve essere connessa utilizzando infrastrutture di switch ridondanti per garantire l'accesso continuo alle risorse di archiviazione in caso di errore di un componente dell'infrastruttura di archiviazione.

I tempi di failover variano in base al produttore del supporto di archiviazione e possono essere configurati utilizzando timer nel driver Microsoft iSCSI Software Initiator oppure modificando le impostazioni dei parametri del driver delle schede bus host Fibre Channel.

Le nuove funzionalità MPIO in Windows Server 2008 includono il modulo DSM (Device Specific Module), progettato per l'utilizzo con array di archiviazione che supportano il modello di controller con accesso simmetrico all'unità logica definito in SPC-3, nonché con array di archiviazione basati sul modello di controller Active/Active.

Funzionalità del modulo DSM incluso

In DSM Microsoft sono disponibili i criteri di bilanciamento del carico seguenti. Si noti che i criteri di bilanciamento del carico in genere dipendono dal modello di controller con accesso simmetrico all'unità logica o Active/Active di tipo true dell'array di archiviazione collegato ai computer basati su Windows.

  • Failover Non viene eseguito alcun bilanciamento del carico. L'applicazione specifica un percorso primario e un insieme di percorsi con stato standby. Il percorso primario viene utilizzato per elaborare le richieste dei dispositivi. Se si verifica un errore del percorso primario, viene utilizzato uno dei percorsi con stato standby. I percorsi con stato standby devono essere elencati in ordine di preferenza decrescente, ovvero con il percorso preferito elencato per primo.

  • Failback Il failback è la capacità di dedicare l'I/O a un percorso preferito funzionante. Se si verifica un errore del percorso preferito, l'I/O viene indirizzato a un percorso alternativo finché non viene ripristinato il funzionamento del percorso preferito. L'I/O passa automaticamente al percorso preferito dopo il ripristino del funzionamento.

  • Round robin DSM utilizza tutti i percorsi disponibili per l'I/O in un modo bilanciato di tipo round robin.

  • Round robin con sottoinsieme di percorsi L'applicazione specifica un insieme di percorsi da utilizzare in modo round robin e un insieme di percorsi con stato standby. DSM utilizza i percorsi di un pool primario di percorsi per elaborare le richieste finché è disponibile almeno uno dei percorsi. Utilizzerà un percorso con stato standby solo se si verificano errori in tutti i percorsi primari. I percorsi con stato standby devono essere elencati in ordine di preferenza decrescente, ovvero con il percorso preferito elencato per primo. Se uno o più percorsi primari diventano disponibili, DSM utilizzerà i percorsi primari secondo l'ordine di preferenza. Si prendano come esempio 4 percorsi, A, B, C e D: A, B e C elencati come percorsi primari e D come percorso con stato standby. DSM sceglierà un percorso A, B e C in modo round robin finché è disponibile almeno uno di essi.

    In caso di errore di tutti e tre i percorsi, DSM utilizzerà il percorso con stato standby D. Se diventa disponibile il percorso A, B o C, DSM smetterà di utilizzare D per passare ai percorsi disponibili tra A, B e C.

  • Lunghezza minima coda dinamica DSM instrada l'I/O al percorso con il numero minore di richieste in attesa.

  • Percorso ponderato L'applicazione assegna a ogni percorso un peso che indica la priorità relativa del percorso. Più il numero è alto, minore sarà la priorità. DSM sceglie il percorso con peso minore tra i percorsi disponibili.

DSM Microsoft mantiene le impostazioni di bilanciamento del carico anche dopo il riavvio del computer. Se non è stato impostato alcun criterio da un'applicazione di gestione, il criterio predefinito utilizzato da DSM sarà di tipo round robin se il controller di archiviazione segue il modello Active/Active di tipo true oppure sarà di tipo failover semplice se vengono utilizzati controller di archiviazione che supportano il modello con accesso simmetrico all'unità logica di SPC-3. Con il failover semplice è possibile utilizzare uno dei percorsi disponibili come percorso primario e i percorsi rimanenti come percorsi con stato standby.

Aggiungere e rimuovere il supporto MPIO

Per installare Multipath I/O in un computer con Windows Server 2008, eseguire i passaggi seguenti.

Per installare Multipath I/O

  1. Aprire Server Manager.

    Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nell'area Funzionalità fare clic su Aggiungi funzionalità.

  3. Nella pagina Selezione funzionalità dell'Aggiunta guidata funzionalità selezionare Multipath I/O e quindi fare clic su Avanti.

  4. Nella pagina Conferma selezioni per la rimozione fare clic su Rimuovi.

  5. Al termine della rimozione fare clic su Chiudi.

Per installare Multipath I/O in un computer tramite la riga di comando di Server Manager, eseguire i passaggi seguenti.

Per installare Multipath I/O tramite riga di comando

  1. Aprire una finestra Prompt dei comandi con privilegi elevati.

    Fare clic con il pulsante destro del mouse sull'oggetto Prompt dei comandi nel menu Start e quindi scegliere Esegui come amministratore.

  2. Digitare il comando seguente e quindi premere INVIO.

    ServerManagerCmd.exe -install Multipath-IO

  3. Al termine dell'installazione, è possibile verificare che Multipath I/O sia stato installato immettendo il comando seguente ed esaminando i risultati della query nella finestra di comando. Nell'elenco dei pacchetti installati deve essere presente Multipath I/O.

    ServerManagerCmd.exe -query

Rimuovere Multipath I/O

Per rimuovere Multipath I/O, eseguire i passaggi seguenti.

Per rimuovere Multipath I/O

  1. Aprire Server Manager.

    Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nell'area Funzionalità fare clic su Rimuovi funzionalità.

  3. Nella pagina Selezione funzionalità dell'Aggiunta guidata funzionalità selezionare Multipath I/O e quindi fare clic su Avanti.

  4. Nella pagina Conferma selezioni per l'installazione fare clic su Installa.

  5. Al termine dell'installazione fare clic su Chiudi.

Per rimuovere Multipath I/O tramite la riga di comando di Server Manager, eseguire i passaggi seguenti.

Per rimuovere Multipath I/O tramite riga di comando

  1. Aprire una finestra Prompt dei comandi con privilegi elevati.

    Fare clic con il pulsante destro del mouse sull'oggetto Prompt dei comandi nel menu Start e quindi scegliere Esegui come amministratore.

  2. Digitare il comando seguente e premere INVIO.

    ServerManagerCmd.exe -remove Multipath-IO

  3. Al termine della rimozione, è possibile verificare che Multipath I/O sia stato rimosso immettendo il comando seguente ed esaminando i risultati della query nella finestra di comando. Nell'elenco dei pacchetti installati non deve essere presente Multipath I/O.

    ServerManagerCmd.exe -query

Aprire e configurare Multipath I/O

Dopo l'installazione di Multipath I/O, è possibile aprire la finestra di dialogo Proprietà MPIO dal Pannello di controllo oppure facendo clic sul pulsante Start, scegliendo Strumenti di amministrazione e quindi MPIO.

Configurazione e installazione di DSM

È possibile configurare ulteriori connessioni tramite Microsoft MPIO utilizzando la finestra di dialogo Proprietà MPIO o l'interfaccia della riga di comando.

Aggiungere DSM di terze parti

Molti array di archiviazione conformi ad Active/Active e a SPC-3 interagiscono anche con il modulo DSM universale di MPIO. Alcuni produttori di array di archiviazione forniscono inoltre DSM propri per interagire con l'architettura Microsoft MPIO. Per installare i moduli DSM di terze parti è consigliabile utilizzare la scheda Installazione DSM della finestra di dialogo Proprietà MPIO.

La scheda Individua percorsi multipli consente di cercare dispositivi per i quali esistono percorsi multipli dell'array di archiviazione. Il campo ID hardware del dispositivo dovrebbe completarsi automaticamente dopo l'esecuzione del controllo.

Se non esistono percorsi multipli dell'array di archiviazione o il dispositivo di archiviazione non è connesso, è possibile aggiungere manualmente l'ID hardware del dispositivo specificando informazioni nella scheda Dispositivi MPIO.

Utilizzare lo strumento da riga di comando MPclaim

Multipath I/O può essere gestito tramite lo strumento da riga di comando MPclaim.

Nota

Nei computer che eseguono un'installazione Server Core di Windows Server 2008 è possibile configurare Multipath I/O esclusivamente tramite riga di comando.

Sintassi di MPclaim

mpclaim restart_option install_switch device_switch device_hwid

Parametri di MPclaim

Nella tabella seguente vengono descritti i parametri che è possibile utilizzare con il comando MPclaim per gestire Multipath I/O tramite riga di comando.

Parametro | Descrizione |
Restart_option | Opzione | Descrizione
-r | -r | Consente di riavviare automaticamente senza visualizzare la richiesta di conferma.
-n | -n | Consente di eliminare la richiesta di riavvio.
Install_switch | Opzione | Descrizione
-i | -i | Consente di installare MPIO e di aggiungere il supporto percorsi multipli per un dispositivo di archiviazione.
-u | -u | Consente di rimuovere MPIO e di sospendere il supporto di un dispositivo di archiviazione.
device_switch | Opzione | Descrizione
-d <device_hwid> | -d <device_hwid> | Consente di specificare i dispositivi per i quali si desidera attivare il supporto MPIO. Gli ID dei dispositivi sono separati da uno spazio.
-a | -a | Consente di applicare il supporto MPIO a tutti i dispositivi compatibili.
-c | -c | Consente di applicare il supporto MPIO solo ai dispositivi compatibili con SPC-3. Questo parametro è applicabile solo all'installazione. Se si rimuove MPIO utilizzando il parametro -u per install_switch, -c viene interpretato dal comando come -a.
device_hwid | device_hwid | ID dei dispositivi che devono essere supportati da MPIO, nel formato VendorProduct, in cui Vendor rappresenta il produttore o il nome del produttore e Product rappresenta il prodotto o il nome del modello. Se si specificano più ID, è necessario separarli con uno spazio. Questo parametro viene utilizzato solo con l'opzione di dispositivo -d.

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Panoramica di Funzionalità di .NET Framework 3.5.1

Funzionalità di .NET Framework 3.5.1 in Windows Server 2008

Microsoft .NET Framework 3.5.1 unisce la potenza delle API di .NET Framework 2.0 e 3.0 a nuove tecnologie per la creazione di applicazioni dotate di interfacce utente accattivanti che consentono di proteggere le informazioni riservate dei clienti, comunicare in modo semplice e sicuro, nonché modellare un'ampia gamma di processi aziendali.

Gli elementi di .NET Framework 3.5.1 vengono utilizzati dai ruoli server come Server applicazioni.

Elementi di Funzionalità di .NET Framework 3.5.1

Nella tabella seguente vengono descritti gli elementi che fanno parte di Funzionalità di .NET Framework 3.5.1.

Funzionalità Descrizione

Componenti di attivazione di Windows Communication Foundation

In Componenti di attivazione di Windows Communication Foundation (WCF) viene utilizzato il servizio Attivazione processo Windows per chiamare applicazioni in remoto attraverso una rete utilizzando protocolli come HTTP, Accodamento messaggi, TCP e named pipe. Componenti di attivazione di Windows Communication Foundation consente alle applicazioni di avviarsi e arrestarsi in modo dinamico in risposta a elementi di lavoro in ingresso, ottenendo così un hosting delle applicazioni più affidabile, gestibile ed efficiente.

  • Attivazione HTTP

Attivazione HTTP supporta l'attivazione dei processi tramite HTTP. Le applicazioni in cui viene utilizzata questa funzionalità possono avviarsi e arrestarsi in modo dinamico in risposta a elementi di lavoro trasmessi sulla rete tramite HTTP.

  • Attivazione non HTTP

Attivazione non HTTP supporta l'attivazione dei processi tramite Accodamento messaggi, TCP o named pipe. Le applicazioni in cui viene utilizzata questa funzionalità possono avviarsi e arrestarsi in modo dinamico in risposta a elementi di lavoro trasmessi sulla rete tramite Accodamento messaggi, TCP o named pipe.

Risorse aggiuntive per Funzionalità di .NET Framework 3.5.1

Per ulteriori informazioni sull'implementazione di Funzionalità di .NET Framework 3.5.1 nella propria organizzazione, vedere la pagina relativa a .NET Framework Developer Center (http://go.microsoft.com/fwlink/?LinkId=94265) in MSDN.

Vedere anche

  • Novità di .NET Framework versione 3.5 SP1


Panoramica di Bilanciamento carico di rete

In questo argomento sono incluse le sezioni seguenti:

  • Disponibilità, scalabilità e tecnologie di clustering

  • Panoramica di Bilanciamento carico di rete

Disponibilità, scalabilità e tecnologie di clustering

In Windows Server 2008 R2 sono disponibili due tecnologie di clustering, cluster di failover e Bilanciamento carico di rete. I cluster di failover garantiscono principalmente un'alta disponibilità, mentre Bilanciamento carico di rete offre scalabilità aumentando allo stesso tempo la disponibilità dei servizi Web.

La scelta della tecnologia di clustering (cluster di failover o Bilanciamento carico di rete) più adatta dipende principalmente dal fatto che le applicazioni eseguite abbiano o meno uno stato in memoria di lunga durata:

  • I cluster di failover sono progettati per applicazioni con stato in memoria di lunga durata o stati di dati di grandi dimensioni e aggiornati di frequente. Tali applicazioni vengono denominate applicazioni con stato e includono applicazioni di database e messaggistica. I cluster di failover vengono in genere utilizzati da file server, server di stampa, server database e server di messaggistica.

  • Bilanciamento carico di rete è dedicato ad applicazioni che non hanno stato in memoria di lunga durata. Queste applicazioni vengono denominate applicazioni senza stato. Un'applicazione senza stato tratta ogni richiesta client come un'operazione indipendente e può pertanto bilanciare il carico di ogni richiesta in modo indipendente. Le applicazioni senza stato hanno spesso dati di sola lettura o dati che vengono modificati raramente. Bilanciamento carico di rete viene in genere utilizzato da server Web front-end, reti private virtuali, server FTP (File Transfer Protocol) e server proxy e firewall. I cluster di Bilanciamento carico di rete offrono inoltre il supporto per altri servizi e applicazioni TCP o UDP.

Panoramica di Bilanciamento carico di rete

Il sevizio Bilanciamento carico di rete consente di migliorare la disponibilità e la scalabilità di applicazioni server Internet, ad esempio quelle utilizzate in server Web, FTP, firewall, proxy e di rete privata virtuale (VPN) e in altri server di importanza strategica.

Che cosa sono i cluster di Bilanciamento carico di rete?

Un singolo computer che esegue Windows può offrire un livello limitato di affidabilità del server e scalabilità delle prestazioni. Combinando invece le risorse di due o più computer che eseguono uno dei prodotti di Windows Server 2008 R2 in un unico cluster virtuale, Bilanciamento carico di rete può garantire i livelli di affidabilità e prestazioni necessari per i server Web e altri server di importanza strategica.

Ogni host esegue una copia separata delle applicazioni server desiderate, ad esempio applicazioni per server Web, FTP e Telnet. Le richieste client in ingresso vengono distribuite da Bilanciamento carico di rete tra gli host del cluster. Il peso del carico che deve essere gestito da ogni host può essere configurato in base alle esigenze. È inoltre possibile aggiungere host al cluster in modo dinamico per gestire un incremento del carico. Bilanciamento carico di rete può inoltre indirizzare tutto il traffico a un unico host designato, denominato host predefinito.

Bilanciamento carico di rete consente di associare a tutti i computer del cluster lo stesso insieme di indirizzi IP del cluster, mantenendo un insieme di indirizzi IP dedicati univoci per ogni host. Per le applicazioni con carico bilanciato, in caso di errore o disconnessione di un host il carico viene automaticamente ridistribuito tra i computer ancora operativi. In caso di disconnessione o errore imprevisto di un computer, le connessioni attive verso il server in cui si è verificato l'errore o che si è disconnesso vengono perse. Se invece un host viene disattivato intenzionalmente, è possibile utilizzare il comando drainstop per gestire tutte le connessioni attive prima di disconnettere il computer. In qualsiasi caso, quando è pronto, il computer offline può essere aggiunto nuovamente al cluster in modo trasparente e riottenere la propria parte del carico di lavoro, consentendo agli altri computer del cluster di gestire una minore quantità di traffico.

Considerazioni relative ai requisiti hardware e software per i cluster di Bilanciamento carico di rete

  • Bilanciamento carico di rete viene installato come un componente driver di rete standard di Windows.

  • L'attivazione e l'esecuzione di Bilanciamento carico di rete non richiedono modifiche hardware.

  • Gestione bilanciamento carico di rete consente di creare nuovi cluster di Bilanciamento carico di rete e di configurare e gestire cluster e tutti i relativi host da un unico computer locale o remoto.

  • Bilanciamento carico di rete consente ai client di accedere al cluster utilizzando un unico nome Internet logico e un indirizzo IP virtuale, denominato indirizzo IP del cluster, che mantiene i singoli nomi di ogni computer. Bilanciamento carico di rete supporta più indirizzi IP virtuali per server multihomed.

    Nota

    In caso di cluster virtuali, non è necessario che i server siano multihomed per disporre di più indirizzi IP virtuali.

  • Bilanciamento carico di rete può essere associato a più schede di rete. In questo modo è possibile configurare più cluster indipendenti in ogni host. Il supporto per più schede di rete è diverso rispetto ai cluster virtuali, poiché questi ultimi consentono di configurare più cluster in un'unica scheda di rete.

Installare la funzionalità Bilanciamento carico di rete

Per utilizzare Bilanciamento carico di rete, è necessario che nella scheda del computer in cui è installato sia presente solo il protocollo TCP/IP. Non aggiungere altri protocolli, ad esempio IPX, a questa scheda. Bilanciamento carico di rete può bilanciare il carico di qualsiasi applicazione o servizio che utilizza TCP/IP come protocollo di rete ed è associato a una porta TCP (Transmission Control Protocol) o UDP (User Datagram Protocol) specifica.

Per installare e configurare Bilanciamento carico di rete, è necessario utilizzare un account incluso nel gruppo Administrators in ogni host. Se durante l'installazione e la configurazione di ogni host non si utilizza un account del gruppo Administrators, verrà richiesto di specificare le credenziali di accesso di un account di questo tipo. Per impostare un account che verrà utilizzato per impostazione predefinita da Gestione bilanciamento carico di rete: in Gestione bilanciamento carico di rete scegliere Credenziali dal menu Opzioni. È consigliabile non utilizzare questo account per altri scopi.

Per installare Bilanciamento carico di rete, è possibile utilizzare Attività di configurazione iniziali o Server Manager. Per installare Bilanciamento carico di rete, nell'elenco delle attività fare clic su Aggiungi funzionalità e nell'elenco delle funzionalità nella procedura guidata fare clic su Bilanciamento carico di rete.

Gestire Bilanciamento carico di rete

È possibile gestire le funzionalità e i ruoli del server con snap-in di MMC (Microsoft Management Console). Per aprire lo snap-in Gestione bilanciamento carico di rete, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione bilanciamento carico di rete. Per aprire Gestione bilanciamento carico di rete, è inoltre possibile digitare Nlbmgr al prompt dei comandi.

Ulteriori riferimenti per Bilanciamento carico di rete

Per ulteriori informazioni su Bilanciamento carico di rete, è possibile visualizzare la Guida nel server in uso. A tale scopo, aprire Gestione bilanciamento carico di rete come descritto nella sezione precedente e quindi premere F1.

  • Per informazioni sulla distribuzione di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87253.

  • Per informazioni sulle operazioni di Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87254.

  • Per informazioni sulla risoluzione dei problemi relativi a Bilanciamento carico di rete, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=87255.


Panoramica del protocollo PNRP (Peer Name Resolution Protocol)

Il protocollo PNRP (Peer Name Resolution Protocol) viene utilizzato da Servizi di rete peer-to-peer Microsoft per risolvere i nomi per le comunicazioni peer.

I peer si basano sui sistemi di risoluzione dei nomi negli ambienti peer-to-peer per risolvere la presenza reciproca in rete, ad esempio indirizzi, protocolli e porte, a partire dai nomi o da altri tipi di identificatori. PNRP è un protocollo di registrazione e di risoluzione dei nomi sicuro, scalabile e dinamico sviluppato inizialmente per Windows XP e quindi aggiornato in Windows Vista e Windows Server 2008. Funziona in modo molto diverso rispetto ai sistemi di risoluzione tradizionali, offrendo nuove possibilità per le applicazioni.

Il protocollo PNRP è caratterizzato dalle proprietà seguenti:

  • È un protocollo distribuito che funziona senza server garantendo scalabilità e affidabilità.

  • Consente di pubblicare facilmente i nomi senza utilizzare applicazioni di terze parti.

  • Offre aggiornamenti in tempo reale per identificatori e indirizzi.

  • Non si limita esclusivamente all'identificazione dei computer.

  • Garantisce la pubblicazione dei nomi protetta, di tipo sicuro e non sicuro.

Per informazioni sulla risoluzione dei problemi di PNRP, vedere la pagina relativa al client Peer Name Resolution Protocol (PNRP) (http://go.microsoft.com/fwlink/?LinkId=143296).


Panoramica di Servizio audio/video Windows di qualità

Servizio audio/video Windows di qualità (qWave)

Servizio audio/video Windows di qualità (qWave) è una piattaforma di rete per applicazioni che utilizzano il flusso di dati audio/video (AV) in reti domestiche IP. Tale piattaforma migliora le prestazioni e l'affidabilità del flusso AV garantendo la qualità del servizio (QoS, Quality of Service) in rete per le applicazioni AV. Offre meccanismi per il controllo dell'ammissione, il monitoraggio e l'imposizione in fase di esecuzione, il feedback dell'applicazione e l'impostazione della priorità del traffico.

Nelle piattaforme Windows Server qWave offre solo servizi di velocità di flusso e impostazione delle priorità.

Per ulteriori informazioni su qWave, vedere TechCenter di Windows Server® 2008 (http://go.microsoft.com/fwlink/?LinkId=48541).


Panoramica di Assistenza remota

Informazioni su Assistenza remota

Gli utenti di computer, soprattutto se privi di esperienza tecnica, hanno spesso domande sull'utilizzo o problemi di configurazione che sono difficili da diagnosticare e risolvere telefonicamente dal personale del supporto tecnico. Con Assistenza remota è possibile risolvere questi problemi poiché consente al personale del supporto tecnico di visualizzare il desktop dell'utente in tempo reale. L'utente che richiede assistenza può dimostrare la natura del problema all'addetto del supporto tecnico. Il problema viene così comunicato in modo più rapido ed efficiente di quanto non sia possibile verbalmente o tramite posta elettronica. Se necessario, l'addetto del supporto tecnico può inoltre essere autorizzato dall'utente ad assumere un controllo interattivo condiviso del computer per mostrare come risolvere il problema. I vantaggi derivanti dall'utilizzo di Assistenza remota consistono in una più rapida risoluzione dei problemi, in un miglioramento del servizio di supporto tecnico e in una riduzione del costo totale di proprietà per il supporto per utenti finali in ambienti aziendali di grandi dimensioni.

Per ulteriori informazioni su Assistenza remota, vedere Assistenza remota di Windows: domande frequenti (http://go.microsoft.com/fwlink/?LinkId=143295) nel sito Web Microsoft.

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Panoramica di RDC (Remote Differential Compression)

La funzionalità RDC (Remote Differential Compression) è un insieme di API utilizzate dalle applicazioni per determinare se un insieme di file è stato modificato e, in caso affermativo, per rilevare quali parti dei file contengono le modifiche. RDC rileva eventuali inserimenti, rimozioni e ridisposizioni di dati nei file, consentendo a un'applicazione di replicare solo le parti modificate di un file. Questa funzionalità è utile per replicare file su una rete con larghezza di banda limitata, ad esempio una connessione WAN (Wide Area Network).

Per installare RDC aprire Server Manager e quindi utilizzare Aggiunta guidata funzionalità oppure digitare il comando seguente al prompt dei comandi elevato: Servermanagercmd -Install Rdc

Nota

Non è necessario installare la funzionalità RDC per utilizzarla con Replica DFS o con Servizi di dominio Active Directory.

Ulteriori riferimenti

  • RDC in MSDN (http://go.microsoft.com/fwlink/?LinkId=94399)

  • Domande frequenti su Replica DFS (http://go.microsoft.com/fwlink/?LinkId=93056)


Panoramica di Strumenti di amministrazione remota del server

Per facilitare la gestione remota del server, in Windows Server® 2008 R2 Microsoft ha incluso un pacchetto di strumenti di amministrazione remota.

È possibile installare il pacchetto Strumenti di amministrazione server remoto in computer con sistema operativo Windows Server 2008 R2 e utilizzare Strumenti di amministrazione server remoto per gestire computer che eseguono Windows Server 2008 R2, Windows Server 2008 oppure, per alcuni strumenti, Windows Server 2003.

Che cos'è il pacchetto Strumenti di amministrazione remota del server?

Il pacchetto Strumenti di amministrazione server remoto è una funzionalità disponibile in Windows Server 2008 R2 che consente la gestione remota di Windows Server 2008 R2, Windows Server 2008 e Windows Server 2003 da un computer che esegue Windows Server 2008 R2, consentendo l'apertura e l'esecuzione di strumenti di gestione e snap-in per gestire ruoli, ruoli server o funzionalità in un computer remoto.

Analogamente ad altri strumenti di gestione disponibili in Windows Server 2008 R2, Strumenti di amministrazione server remoto è sicuro per impostazione predefinita. La configurazione predefinita di Strumenti di amministrazione server remoto consente di aprire e attivare solo le porte e i servizi necessari per le operazioni di gestione remota.

Per ulteriori informazioni su ruoli, ruoli server e funzionalità in Windows Server 2008 R2, vedere l'argomento relativo a ruoli, servizi ruolo e funzionalità nella Guida di Server Manager.

Ruoli e funzionalità gestibili con Strumenti di amministrazione remota del server

In Windows Server 2008 R2 sono disponibili strumenti di gestione per i ruoli e le funzionalità seguenti.

Strumenti di amministrazione remota del server per i ruoli

Nota

È possibile che questo elenco di ruoli sia stato aggiornato in seguito alla pubblicazione del contenuto. Per verificare la presenza di aggiornamenti, vedere la pagina relativa al TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122006.

Ruolo di Strumenti di amministrazione server remoto Descrizione

Strumenti Servizi certificati Active Directory

Gli strumenti Servizi certificati Active Directory includono gli snap-in Autorità di certificazione, Modelli di certificato, Infrastruttura a chiave pubblica dell'organizzazione e Gestione risponditore online.

Servizi dei domini Active Directory (AD DS) e Strumenti Active Directory Lightweight Directory Services (AD LDS)

Servizi dei domini Active Directory include Utenti e computer di Active Directory, Domini e trust di Active Directory, Siti e servizi di Active Directory, Centro di amministrazione di Active Directory, Strumenti per Server per NIS, il provider e i cmdlet Windows PowerShell Active Directory e altri snap-in e strumenti da riga di comando per la gestione remota di Servizi dei domini Active Directory.

Gli strumenti Active Directory Lightweight Directory Services includono Siti e servizi di Active Directory, Modifica ADSI, Gestione schema e altri snap-in e strumenti da riga di comando per la gestione di Active Directory Lightweight Directory Services.

Strumenti Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD)

Gli strumenti Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD) includono lo snap-in Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD).

Strumenti server DHCP

Strumenti server DHCP include lo snap-in DHCP.

Strumenti server DNS

Strumenti server DNS include lo snap-in Gestore DNS e lo strumento da riga di comando dnscmd.exe.

Strumenti Server fax

Gli strumenti Server fax includono lo snap-in Gestione servizio fax.

Strumenti Servizi file

Gli strumenti Servizi file includono quanto segue:

  • Strumenti per File system distribuito (DFS) include lo snap-in Gestione DFS e gli strumenti da riga di comando dfsradmin.exe, dfsrdiag.exe, dfscmd.exe, dfsdiag.exe e dfsutil.exe.

  • Gli strumenti Gestione risorse file server includono lo snap-in Gestione risorse file server e gli strumenti da riga di comando filescrn.exe e storrept.exe.

  • Gli strumenti Servizi per NFS includono lo snap-in NFS e gli strumenti da riga di comando nfsadmin.exe, showmount.exe e rpcinfo.exe.

Strumenti di Hyper-V™

Strumenti di Hyper-V include lo snap-in Console di gestione di Hyper-V e altri strumenti per la gestione di Hyper-V.

Strumenti Servizi di accesso e criteri di rete

Strumenti per Servizi di accesso e criteri di rete include gli snap-in Routing e Accesso remoto e Autorità registrazione integrità.

Strumenti per Servizi di stampa e digitalizzazione

Strumenti per Servizi di stampa e digitalizzazione include lo snap-in Gestione stampa.

Strumenti per Servizi Desktop remoto

Strumenti per Servizi Desktop remoto include gli snap-in Gestione RemoteApp, Gestione Gateway Desktop remoto e Gestione licenze Desktop remoto.

  • Gestore connessione Desktop remoto include lo snap-in Gestione Connessione RemoteApp e desktop.

Strumenti Web Server (IIS)

Gli strumenti Web Server (IIS) includono gli snap-in Gestione Internet Information Services (IIS) 6.0 e Gestione IIS.

Strumenti Servizi di distribuzione Windows

Gli strumenti Servizi di distribuzione Windows includono lo snap-in Servizi di distribuzione Windows, lo strumento da riga di comando wdsutil.exe e l'estensione Installazione remota per lo snap-in Utenti e computer di Active Directory.

Strumenti di amministrazione remota del server per le funzionalità

Nota

È possibile che questo elenco di funzionalità sia stato aggiornato in seguito alla pubblicazione del contenuto. Per verificare la presenza di aggiornamenti, vedere la pagina relativa al TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122006.

Funzionalità Strumenti di amministrazione server remoto | Descrizione
Utilità di amministrazione di Crittografia unità BitLocker | Utilità di amministrazione di Crittografia unità BitLocker include lo script manage-bde.wsf e il Visualizzatore Password Ripristino BitLocker.
Strumenti Estensioni del server BITS | Gli strumenti Estensioni del server BITS includono gli snap-in Gestione Internet Information Services (IIS) 6.0 e Gestione IIS.
Strumenti Clustering di failover | Gli strumenti Clustering di failover includono lo snap-in Gestione cluster di failover e lo strumento da riga di comando cluster.exe.
Strumenti Bilanciamento carico di rete | Gli strumenti Bilanciamento carico di rete includono lo snap-in Gestione bilanciamento carico di rete e gli strumenti da riga di comando nlb.exe e wlbs.exe.
Strumenti Server SMTP | Gli strumenti Server SMTP includono lo snap-in Gestione Internet Information Services (IIS) 6.0.
Strumenti Server WINS | Gli strumenti Server WINS (Windows Internet Name Service) includono lo snap-in WINS.

Installare Strumenti di amministrazione remota del server

Nota

È necessario essere membro del gruppo Administrators del server in cui si desidera installare il pacchetto Strumenti di amministrazione server remoto oppure accedere al computer tramite l'account amministratore predefinito. Se si installa Strumenti di amministrazione server remoto mediante l'interfaccia da riga di comando, inoltre, è necessario aprire la finestra del prompt dei comandi con privilegi elevati.

È possibile installare Strumenti di amministrazione server remoto in uno dei modi seguenti.

  • Aggiunta guidata funzionalità. I comandi che consentono di aprire l'Aggiunta guidata funzionalità sono presenti in tre punti.

    • Server Manager. Server Manager viene aperto per impostazione predefinita quando si chiude la finestra Attività di configurazione iniziali oppure può essere aperto scegliendo Server Manager dal menu Strumenti di amministrazione.

    • Attività di configurazione iniziali. La finestra Attività di configurazione iniziali viene aperta per impostazione predefinita dopo l'avvio di un computer che esegue Windows Server 2008.

    • Pannello di controllo. Aprire il Pannello di controllo, quindi Programmi e funzionalità e fare clic su Attiva o disattiva le funzionalità Windows. Un comando nella home page di Server Manager consente di aprire l'Aggiunta guidata funzionalità.

  • Windows PowerShell. Per installare Strumenti di amministrazione server remoto tramite Windows PowerShell, vedere l'argomento relativo all'installazione del pacchetto Strumenti di amministrazione server remoto nella Guida di Strumenti di amministrazione server remoto. Il cmdlet Windows PowerShell impostato per Server Manager può essere utilizzato per installare o rimuovere Strumenti di amministrazione server remoto.

  • Riga di comando di Server Manager. Per installare Strumenti di amministrazione server remoto mediante la riga di comando di Server Manager, vedere l'argomento relativo all'installazione del pacchetto Strumenti di amministrazione server remoto nella Guida di Strumenti di amministrazione server remoto. A causa delle restrizioni di sicurezza imposte da Controllo dell'account utente, è necessario aprire il prompt dei comandi con privilegi elevati. A tale scopo, fare clic con il pulsante destro del mouse sull'eseguibile di Prompt dei comandi oppure sull'oggetto Prompt dei comandi nel menu Start e quindi scegliere Esegui come amministratore.

Nota

Quando si installano strumenti per ruoli, ruoli server e funzionalità specifici in Strumenti di amministrazione server remoto, viene installato esclusivamente un insieme di snap-in e strumenti per la gestione remota di tali ruoli, ruoli server e funzionalità installati in altri computer. L'installazione di Strumenti di amministrazione server remoto non implica l'installazione di ruoli o funzionalità nel computer locale.

Gestire con Strumenti di amministrazione remota del server

Per gestire ruoli, ruoli server o funzionalità in computer remoti mediante Strumenti di amministrazione server remoto, è necessario specificare nello snap-in o nello strumento di gestione il nome del computer in cui è installato il ruolo, servizio ruolo o funzionalità che si desidera gestire. In uno snap-in, in genere, è possibile specificare il computer remoto facendo clic sul comando Connetti a un altro computer nel riquadro Azioni o nel menu Azione.

Ulteriori informazioni

Per ulteriori informazioni su Strumenti di amministrazione server remoto, è possibile visualizzare la Guida nel server in uso. A tale scopo, cercare RSAT.chm e quindi fare doppio clic su di esso per aprirlo. RSAT.chm si trova in genere in %windir%\Help\mui\0409.

Per ulteriori informazioni su Strumenti di amministrazione server remoto e sulla gestione di ruoli, ruoli server e funzionalità mediante i relativi strumenti di amministrazione remota, visitare la pagina relativa al TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122006.


Panoramica di Proxy RPC su HTTP

Proxy RPC su HTTP

Per gli oggetti che ricevono chiamate di procedure remote (RPC, Remote Procedure Call) tramite HTTP (Hypertext Transfer Protocol) viene utilizzato Proxy RPC su HTTP. Il proxy consente ai client di individuare tali oggetti anche se questi ultimi vengono spostati da un server all'altro o si trovano in aree distinte della rete, in genere per motivi di protezione.

Risorse aggiuntive per Proxy RPC su HTTP

Per ulteriori informazioni su Proxy RPC su HTTP, visitare i siti Web seguenti:

  • Chiamate di procedure remote tramite Proxy RPC su HTTP (http://go.microsoft.com/fwlink/?LinkId=93826)

  • Server applicazioni (http://go.microsoft.com/fwlink/?LinkID=93880)


Panoramica di Servizi per NFS (Network File System)

Servizi per NFS rappresenta una soluzione di condivisione file per le organizzazioni che dispongono di ambienti misti Windows e UNIX. Con Servizi per NFS è possibile trasferire file tra computer che eseguono Windows Server 2008 e sistemi operativi UNIX mediante il protocollo NFS.

Per ulteriori informazioni su Servizi per NFS, vedere TechCenter di Windows Server (http://go.microsoft.com/fwlink/?LinkId=92798).

Nuove funzionalità introdotte in Windows Server 2008 R2

In Servizi per NFS sono stati apportati i miglioramenti seguenti tra Windows Server 2008 e Windows Server 2008 R2:

  • Supporto per netgroup. Servizi per NFS supporta i netgroup, che vengono utilizzati per creare gruppi di host denominati a livello di rete. I netgroup semplificano il controllo della connessione di utenti e gruppi e dell'accesso shell ai computer remoti e consentono agli amministratori di sistema di gestire più facilmente gli elenchi di controllo di accesso NFS.

  • Supporto per RPCSEC_GSS. Servizi per NFS offre il supporto nativo per RPCSEC_GSS, che consente alle applicazioni di utilizzare le funzionalità di sicurezza GSS-API.

    Nota

    Il supporto per RPCSEC_GSS include autenticazione e integrità. La privacy non è inclusa.

  • Utilizzo di WMI per la gestione di Server per NFS. WMI consente la gestione remota di NFS mediante l'abilitazione delle comunicazioni tra le applicazioni WBEM (Web-Based Enterprise Management) e i provider WMI nei computer locali o remoti per la gestione degli oggetti WMI.

  • Accesso utenti UNIX non mappati. Per le condivisioni NFS è ora disponibile un'opzione Utente UNIX non mappato. È possibile utilizzare i server Windows per archiviare dati NFS senza creare mapping di account da UNIX a Windows. Gli account utente mappati utilizzeranno ID di sicurezza (SID) di Windows standard, mentre gli utenti non mappati utilizzeranno SID NFS personalizzati.

Nota

Anche se non è disponibile la funzionalità server Mapping nomi utente per Windows Server 2008 R2, è comunque presente la funzionalità client Mapping nomi utente. Servizi per NFS è comunque in grado di recuperare i mapping dai server Mapping nomi utente legacy in uso.

Ulteriori riferimenti

Per ulteriori informazioni su Servizi per NFS, visitare il sito Web Microsoft seguente:

  • TechCenter per Windows Server (http://go.microsoft.com/fwlink/?LinkId=92798).


Panoramica del protocollo SMTP (Simple Mail Transfer Protocol)

Nel server SMTP di Windows Server® 2008 viene utilizzato il protocollo SMTP (Simple Mail Transfer Protocol) standard Internet per trasportare e recapitare messaggi secondo le specifiche contenute in Request for Comments (RFC) 2821 e 2822. In esso sono inclusi inoltre miglioramenti basati sulle funzionalità di recapito di base del protocollo. Diverse opzioni consentono di controllare il routing e il recapito dei messaggi, nonché di configurare comunicazioni più sicure.

Funzionalità del server SMTP

Nel server SMTP sono disponibili le funzionalità seguenti:

  • Supporto del protocollo IP standard Il server SMTP offre il supporto completo per SMTP ed è compatibile con i client di posta SMTP.

  • Scalabilità Con il server SMTP è possibile configurare server virtuali SMTP per il supporto di più domini e centinaia di connessioni client in una configurazione con un unico server.

  • Facilità di amministrazione e integrazione con il sistema operativo Windows Server 2008 Per l'amministrazione del server SMTP è utilizzata una Microsoft Management Console. I server virtuali SMTP vengono creati e configurati utilizzando Gestione Internet Information Services (IIS) 6.0. Gli amministratori possono utilizzare altre funzionalità di amministrazione di Windows Server 2008, inclusi il protocollo SNMP (Simple Network Management Protocol), i registri eventi e i registri delle transazioni per raccogliere le statistiche di utilizzo, tenere traccia dei messaggi e delle transazioni ed esaminare i criteri di utilizzo.

  • Sicurezza avanzata Il server SMTP supporta l'utilizzo del protocollo TLS (Transport Layer Security) per la crittografia delle trasmissioni.

  • Destinazione e prelievo diretti della posta Per il dominio predefinito, il server SMTP supporta l'inserimento di tutti i messaggi in ingresso direttamente in una directory di destinazione. In questo modo è possibile utilizzare il server SMTP come ricevitore di posta per altre applicazioni. Oltre a connettersi a una porta TCP per l'invio di messaggi, le applicazioni possono utilizzare una directory di prelievo. Dopo che un messaggio formattato come file di testo viene copiato nella directory di prelievo, il server SMTP lo recapita.

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Panoramica di Simple Network Management Protocol

SNMP (Simple Network Management Protocol) è uno standard di gestione delle reti largamente utilizzato per le reti TCP/IP.

Il protocollo SNMP offre un metodo di gestione degli host di rete, ad esempio computer server o workstation, router, bridge e hub, da un computer centrale che esegue il software di gestione della rete. SNMP offre servizi di gestione tramite l'utilizzo di un'architettura distribuita di agenti e sistemi di gestione.

Poiché la gestione di rete è fondamentale sia per il controllo che per la gestione delle risorse, il protocollo SNMP può essere utilizzato per le operazioni seguenti:

  • Configurare dispositivi remoti. Le informazioni di configurazione possono essere inviate a ogni host di rete dal sistema di gestione.

  • Monitorare le prestazioni di rete. È possibile registrare la velocità di elaborazione e la velocità effettiva della rete e raccogliere informazioni sulla corretta trasmissione dei dati.

  • Rilevare errori di rete o accessi non appropriati. È possibile configurare nei dispositivi di rete allarmi che vengono attivati quando si verificano determinati eventi. Quando un allarme viene attivato, il dispositivo inoltra un messaggio di evento al sistema di gestione. I tipi comuni di allarmi includono l'arresto o il riavvio di un dispositivo, il rilevamento di un errore di collegamento in un router e l'accesso non appropriato.

  • Controllare l'utilizzo della rete. È possibile monitorare sia l'utilizzo globale della rete, per identificare l'accesso di utenti o gruppi, che i tipi di utilizzo dei servizi e dei dispositivi di rete.

Servizio SNMP

Il servizio SNMP (Simple Network Management Protocol) è una funzionalità facoltativa che è possibile installare dopo la configurazione del protocollo TCP/IP.

Il servizio SNMP offre un agente SNMP che consente la gestione remota e centralizzata dei computer che eseguono:

  • Windows Vista®

  • Windows Server® 2008

  • Microsoft® Windows® XP

  • Microsoft Windows 2000

  • Sistemi operativi Windows Server 2003

L'agente SNMP consente inoltre la gestione dei servizi seguenti:

  • Servizio WINS per computer basati su Windows XP o sui sistemi operativi Windows Server 2003 e Microsoft Windows 2000

  • Servizio DHCP per computer basati su Windows XP o sistemi operativi Windows Server 2003 e Windows 2000

  • Internet Information Services per computer basati su Windows XP o sistemi operativi Windows Server 2003 e Windows 2000

  • LAN Manager

Per accedere alle informazioni dell'agente SNMP, è necessario disporre di almeno un'applicazione software sistema di gestione SNMP. Il servizio SNMP supporta, ma al momento non include, il software di gestione SNMP. Tale software deve essere in esecuzione nell'host che funge da sistema di gestione.


Panoramica di Servizi TCP/IP semplificati

Servizi TCP/IP semplificati offre il supporto per i servizi del protocollo TCP/IP facoltativi elencati nella tabella seguente.

Protocollo | Descrizione | RFC
Character Generator (CHARGEN) | Invia dati costituiti dall'insieme di 95 caratteri ASCII stampabili. È utile come strumento per il debug per verificare o risolvere i problemi relativi alle stampanti di linea. | 864
Daytime | Restituisce messaggi contenenti informazioni sul giorno della settimana, sul mese, sull'anno, sull'ora corrente in formato hh:mm:ss e sul fuso orario. In alcuni programmi viene utilizzato l'output di questo servizio per il debug o il monitoraggio di variazioni dell'ora dell'orologio di sistema o in un altro host. | 867
Discard | Elimina tutti i messaggi ricevuti sulla porta senza risposta o acknowledgment. Può funzionare come porta null per la ricezione e il routing di messaggi di prova TCP/IP durante l'installazione e la configurazione di rete o in alcuni casi può essere utilizzato dai programmi per l'eliminazione dei messaggi. | 863
Echo | Esegue l'echo dei dati dei messaggi ricevuti su questa porta del server. L'echo può essere utile come strumento di debug e di monitoraggio di rete. | 862
Quote of the Day (QUOTE) | Restituisce una citazione sotto forma di una o più righe di testo in un messaggio. Le citazioni vengono estratte in modo casuale dal file seguente: radice sistema\System32\Drivers\Etc\Quotes. Con Servizi TCP/IP semplificati viene installato un file di citazioni di esempio. Se il file non è disponibile, il servizio di citazioni ha esito negativo. | 865

Tutti questi servizi del protocollo sono classificati come standard Internet facoltativi e vengono definiti e descritti nel documento Request for Comments (RFC) specificato nella tabella. Per ulteriori informazioni su questi servizi del protocollo, vedere le specifiche RFC.

Importante

Non installare Servizi TCP/IP semplificati a meno che il computer non debba supportare in modo specifico comunicazioni con altri sistemi in cui vengono utilizzati questi servizi del protocollo.

Nota

Dopo aver installato Servizi TCP/IP semplificati, non è possibile attivare o disattivare i servizi separatamente.

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Panoramica del provider WMI per SNMP

La tecnologia Strumentazione gestione Windows (WMI) è l'implementazione Microsoft dell'iniziativa WBEM (Web-Based Enterprise Management) DMTF (Distributed Management Task Force) che consente di estendere il modello CIM (Common Information Model) in modo da rappresentare oggetti di gestione in ambienti di gestione basati su Windows. CIM (Common Information Model), anch'esso uno standard DMTF, è un modello di dati estendibile che consente di organizzare logicamente gli oggetti di gestione in modo coerente e unificato in un ambiente gestito.

WBEM è un'iniziativa e una tecnologia DMTF basata sul modello CIM che definisce gli standard per l'infrastruttura di gestione e consente di accedere in modo standardizzato alle informazioni da diversi sistemi di gestione hardware e software in un ambiente aziendale. Utilizzando gli standard WBEM, gli sviluppatori possono creare strumenti e tecnologie che consentono di ridurre la complessità e i costi della gestione aziendale. Tramite questi standard, WBEM contribuisce all'impegno dell'intero settore per ridurre il costo totale di proprietà. Per costo totale di proprietà si intende il costo amministrativo associato agli acquisti di hardware e software per computer, alla distribuzione e alla configurazione, agli aggiornamenti hardware e software, alla formazione, alla manutenzione e al supporto tecnico.

WBEM offre un punto di integrazione per l'accesso a dati provenienti da origini di gestione e completa ed estende strumentazione e protocolli di gestione esistenti, ad esempio Simple Network Management Protocol (SNMP), Desktop Management Interface (DMI) e Common Management Information Protocol (CMIP).

Tecnologia Strumentazione gestione Windows (WMI)

La tecnologia Strumentazione gestione Windows (WMI) è un'infrastruttura di gestione che supporta la sintassi del modello CIM, ovvero il formato MOF (Managed Object Format), e un'interfaccia di programmazione comune. La sintassi MOF definisce la struttura e il contenuto dello schema CIM in un formato leggibile dall'utente e dal computer. In Strumentazione gestione Windows (WMI) è disponibile un potente insieme di servizi, tra cui il recupero di informazioni basato su query e la notifica degli eventi Questi servizi e i dati di gestione sono accessibili tramite un'interfaccia di programmazione COM (Component Object Model). L'interfaccia di scripting di WMI offre inoltre il supporto per lo scripting.

La tecnologia WMI offre i vantaggi seguenti:

  • Accesso per il monitoraggio, la gestione e il controllo di oggetti gestiti tramite un insieme comune e unificato di interfacce, indipendentemente dal meccanismo di strumentazione sottostante. WMI è un meccanismo di accesso.

  • Modello uniforme di funzionamento, configurazione e stato del sistema operativo Windows.

  • Interfaccia API (Application Programming Interface) COM che offre un singolo punto di accesso per tutte le informazioni di gestione.

  • Interoperabilità con altri servizi di gestione Windows. Questo approccio consente di semplificare il processo di creazione di soluzioni di gestione integrate e ben progettate.

  • Architettura flessibile ed estendibile. Gli sviluppatori possono estendere il modello informativo in modo da supportare nuovi dispositivi e applicazioni scrivendo moduli di codice denominati provider WMI.

  • Estensioni del modello WDM (Windows Driver Model) per l'acquisizione di dati ed eventi di strumentazione da driver di dispositivo e componenti del lato kernel.

  • Potente architettura di eventi che consente di identificare, aggregare e confrontare le modifiche delle informazioni di gestione, nonché di associarle ad altre informazioni di gestione. Queste modifiche inoltre possono essere inoltrate ad applicazioni di gestione locali o remote.

  • Ricco linguaggio di query che consente di eseguire query dettagliate del modello informativo.

  • API configurabile tramite script che può essere utilizzata dagli sviluppatori per creare applicazioni di gestione. L'API di scripting supporta alcuni linguaggi, tra cui Microsoft Visual Basic; Visual Basic, Applications Edition (VBA); Visual Basic, Scripting Edition (VBScript) e il software di sviluppo Microsoft JScript. Oltre a VBScript e JScript, gli sviluppatori possono utilizzare qualsiasi implementazione di linguaggio di scripting che supporti le tecnologie di scripting Microsoft ActiveX con questa API, ad esempio un motore di scripting Perl. È inoltre possibile utilizzare Windows Script Host o Microsoft Internet Explorer per scrivere script con questa interfaccia. Windows Script Host, analogamente a Internet Explorer, funge da motore controller dei motori di script ActiveX e supporta gli script scritti in VBScript e JScript.

Panoramica dell'architettura WMI

L'architettura della tecnologia WMI è costituita dagli elementi seguenti:

  • Infrastruttura di gestione - Include CIM Object Manager, che offre alle applicazioni un accesso uniforme ai dati di gestione e un'area di archiviazione centrale per i dati di gestione denominata archivio di CIM Object Manager.

  • Provider WMI - Provider che funzionano da intermediari tra CIM Object Manager e gli oggetti gestiti. Utilizzando le API WMI, i provider forniscono a CIM Object Manager dati degli oggetti gestiti, gestiscono le richieste per conto di applicazioni di gestione e generano notifiche di eventi.

L'infrastruttura di gestione è costituita da CIM Object Manager e dall'archivio di CIM Object Manager. Le applicazioni dipendono da Object Manager per gestire l'interfaccia tra le applicazioni di gestione e i provider di dati. WMI facilita queste comunicazioni offrendo un'interfaccia di programmazione comune ai servizi di gestione Windows che utilizzano COM. Questa API COM offre servizi di notifica degli eventi e di elaborazione delle query e può essere utilizzata in alcuni ambienti di linguaggi di programmazione, ad esempio C e C++. L'archivio di CIM Object Manager include lo schema CIM e lo schema delle estensioni, nonché dettagli sui dati e sulle origini dati. CIM Object Manager utilizza i dati di schema contenuti in questo archivio per soddisfare le richieste relative agli oggetti gestiti effettuate dalle applicazioni di gestione.

Gli oggetti gestiti sono componenti aziendali fisici o logici basati sul modello CIM. Un oggetto gestito ad esempio può essere un componente hardware, come un cavo, o un componente software, come un'applicazione di database. Le applicazioni di gestione possono utilizzare CIM Object Manager per accedere agli oggetti gestiti.

Le applicazioni di gestione sono applicazioni o servizi di Windows che utilizzano o elaborano informazioni che originano da oggetti gestiti. Le applicazioni di gestione possono accedere alle informazioni sugli oggetti gestiti effettuando una richiesta a CIM Object Manager utilizzando uno dei metodi disponibili nell'API WMI.

I provider WMI sono server COM e DCOM (Distributed Component Object Model) standard che funzionano da mediatori tra gli oggetti gestiti e CIM Object Manager. Se riceve da un'applicazione di gestione una richiesta relativa a dati non disponibili nell'archivio di CIM Object Manager o a notifiche di eventi non supportate, CIM Object Manager inoltra la richiesta a un provider WMI. I provider forniscono dati e notifiche di eventi per gli oggetti gestiti specifici del proprio dominio.

Per implementare un provider, utilizzare uno dei tipi di server supportati seguenti:

• Servizi di Microsoft Windows 2008, locali o remoti.

• File eseguibili (con estensione exe) standard, locali o remoti.

• DLL (librerie di collegamento dinamico) in-process.

Si noti che i servizi di Windows 2008 locali o remoti e gli eseguibili standard sono tipi di server consigliati.

WMI viene fornito con provider predefiniti, ovvero provider standard, che forniscono dati provenienti da origini come il Registro di sistema. Tra i provider predefiniti sono inclusi i seguenti:

  • Provider di Active Directory - Funge da gateway per tutte le informazioni archiviate nel servizio Active Directory. Consente di accedere alle informazioni di WMI e Active Directory tramite una singola API.

  • Provider di Windows Installer - Consente di avere un controllo completo su Windows Installer e sull'installazione del software tramite WMI. Fornisce inoltre informazioni sulle applicazioni installate con Windows Installer.

  • Provider di contatori di prestazioni - Espone le informazioni dei contatori di prestazioni non elaborate utilizzate per calcolare i valori delle prestazioni visualizzati nello strumento Monitor di sistema. Tutti i contatori di prestazioni installati in un sistema saranno automaticamente visibili tramite questo provider.

  • Provider del Registro di sistema - Consente di creare, leggere e scrivere chiavi del Registro di sistema. Quando vengono modificate chiavi specifiche del Registro di sistema possono essere generati eventi WMI.

  • Provider SNMP - Funge da gateway per i sistemi e i dispositivi in cui viene utilizzato il protocollo SNMP (Simple Network Management Protocol) per la gestione. È possibile leggere e scrivere variabili oggetto MIB SNMP. Le trap SNMP possono essere mappate automaticamente a eventi WMI.

  • Provider del registro eventi - Consente di accedere ai dati e alle notifiche di eventi dal registro eventi di Windows Server 2008.

  • Provider Win32 - Fornisce informazioni sul sistema operativo, sul computer, sui dispositivi, sui file system e sulla sicurezza.

  • Provider WDM - Fornisce informazioni su driver Windows Driver Model di basso livello per dispositivi di input utente, dispositivi di archiviazione, interfacce di rete e porte di comunicazione.

  • Provider delle classi di viste - Consente di creare nuove classi aggregate a partire da classi esistenti. Le classi di origine possono essere filtrate in base solo alle informazioni di interesse, le informazioni di più classi possono essere combinate in una singola classe e i dati di più computer possono essere aggregati in una singola visualizzazione.

La tecnologia WMI supporta inoltre provider personalizzati di terze parti. I provider personalizzati possono essere utilizzati per soddisfare richieste correlate a oggetti gestiti specifici dell'ambiente. I provider in genere utilizzano il linguaggio MOF per definire e creare classi e utilizzano l'API WMI per accedere all'archivio di CIM Object Manager e rispondere alle richieste CIM Object Manager effettuate inizialmente dalle applicazioni.

Panoramica di Simple Network Management Protocol

Simple Network Management Protocol (SNMP) è uno standard di gestione delle reti che definisce una strategia per la gestione delle reti TCP/IP.

In SNMP viene utilizzata un'architettura distribuita che include gli elementi seguenti:

  • Più nodi gestiti, ognuno con un'entità SNMP denominata agente che consente di accedere in remoto alla strumentazione di gestione.

  • Almeno un'entità SNMP identificata come gestore che esegue applicazioni di gestione per il monitoraggio e il controllo di elementi gestiti. Gli elementi gestiti sono dispositivi quali host, router e così via che vengono monitorati e controllati tramite l'accesso alle relative informazioni di gestione.

  • Un protocollo di gestione, SNMP, utilizzato per il trasporto di informazioni di gestione tra le stazioni e gli agenti di gestione. Le informazioni di gestione fanno riferimento a un insieme di oggetti gestiti contenuti in un archivio di informazioni virtuale denominato Management Information Base (MIB).

Messaggi SNMP

Per comunicare le informazioni sugli host, i sistemi e gli agenti di gestione utilizzano i messaggi SNMP. Questi messaggi vengono inviati utilizzando il protocollo UDP (User Datagram Protocol) e vengono instradati tra il sistema di gestione e l'host tramite il protocollo IP.

Management Information Base (MIB) include le informazioni richieste dal sistema di gestione. L'archivio MIB di un computer collegato in rete può includere informazioni sulla configurazione e sulle prestazioni della scheda di interfaccia di rete, sullo spazio disponibile sul disco rigido, sulla versione dei driver e delle applicazioni e così via. È possibile scrivere e caricare MIB aggiuntivi per esporre i dati specificati per l'insieme, purché il sistema supporti la raccolta delle informazioni richieste.

Elaborare le richieste di informazioni

Quando un sistema di gestione richiede informazioni, viene eseguita la sequenza di operazioni seguente:

  1. Un sistema di gestione invia una richiesta a un agente utilizzando l'indirizzo IP dell'agente.

  2. L'agente forma un datagramma SNMP contenente un messaggio SNMP e il nome community a cui appartiene il sistema di gestione.

  3. L'agente SNMP riceve il datagramma e verifica il nome community. Se il nome community è valido, l'agente SNMP recupera i dati appropriati. Se invece il nome community non è valido, la richiesta viene rifiutata. Se l'agente è stato configurato per l'invio di una trap di autenticazione, viene inviato un messaggio trap.

  4. Il datagramma SNMP viene restituito al sistema di gestione con le informazioni richieste.

Messaggi

Vengono utilizzati i tipi di messaggi SNMP seguenti:

  • Get - Questo è un messaggio di richiesta. I sistemi di gestione SNMP utilizzano i messaggi Get per richiedere informazioni su una voce MIB in un agente SNMP.

  • Getnext - Tipo di messaggio di richiesta che può essere utilizzato per esplorare un intero albero di oggetti gestiti.

  • Getbulk - Tipo di richiesta che specifica che l'agente trasferisce tutti i dati possibili, entro i limiti delle dimensioni dei messaggi.

  • Set - Viene utilizzato per inviare e assegnare un valore MIB aggiornato a un agente.

  • Notify (o Trap) - Questo è un messaggio non richiesto inviato da un agente a un sistema di gestione SNMP quando viene rilevato che si è verificato un determinato tipo di evento localmente nell'host gestito.

Poiché gli eventi o le trap SNMP vengono inviate non richieste a una stazione di gestione che filtra gli eventi, viene creato traffico di rete. Con WMI gli eventi vengono filtrati localmente e solo quelli che soddisfano i criteri di filtro vengono inviati sulla rete, riducendo in questo modo la larghezza di banda necessaria per gli eventi di interesse.

Supporto per SNMP in WMI SDK

Il provider SNMP include i componenti seguenti:

  • Provider di classi, istanze ed eventi che integrano la modellazione e l'elaborazione delle informazioni SNMP in WMI. Questi provider SNMP mappano gli insiemi di valori oggetto ai valori proprietà di istanze di classi CIM.

  • Un compilatore di moduli di informazioni SNMP che compila le informazioni dello schema SNMP nativo nel formato utilizzato da CIM.

Provider SNMP

I provider SNMP restituiscono informazioni dinamiche. Per specificare rispetto a quale insieme di classi deve operare il provider di istanze, è possibile procedere in uno dei due modi seguenti:

  • In modo statico - Creando classi nello spazio dei nomi dell'archivio di oggetti CIM associato al dispositivo proxy.

  • In modo dinamico - Utilizzando il provider di classi SNMP, che restituisce l'insieme di classi contenute nello spazio dei nomi SMIR (SNMP Module Information Repository).

È inoltre possibile specificare se utilizzare o meno la correlazione per l'insieme di classi restituite dallo spazio dei nomi SMIR. Le classi correlate definiscono l'insieme di classi supportate da un agente SNMP al momento dell'enumerazione. L'enumerazione non correlata restituisce tutte le classi presenti nello spazio dei nomi SMIR, indipendentemente dal fatto che siano supportate dal dispositivo agente.

Di seguito vengono elencati i provider SNMP:

  • Provider di classi e di istanze SNMP, utilizzati dalle applicazioni per accedere ai dati che si riferiscono ai dispositivi SNMP e modificarli.

  • Provider di eventi SNMP, che generano eventi da trap e notifiche SNMP. Questi provider segnalano gli stessi tipi di eventi, ma in formati diversi: Incapsulato e Referente. Incapsulato indica che la classe di eventi dispone di proprietà semplici che descrivono le informazioni mappate direttamente dalle macro TRAP-TYPE e NOTIFICATION-TYPE, illustrate nella sezione seguente. Le classi di tipo Referente estraggono le informazioni presenti nelle macro in modo che le proprietà che condividono le stessa classe e la stessa istanza vengano presentate come oggetti incorporati. È così possibile eseguire l'estrazione di __RELPATH in modo che l'istanza univoca a cui è associata la trap possa essere recuperata dopo la ricezione dell'evento. Per scegliere un formato, gli utenti effettuano la registrazione per una classe particolare di eventi.

Mappare dati di dispositivo a classi CIM

I provider SNMP mappano i dati di dispositivo alle classi CIM nei modi seguenti:

  • Enumerando le definizioni delle classi SNMP. Per enumerare un insieme di definizioni di classi, le applicazioni possono chiamare IWbemServices::CreateClassEnum oppure IWbemServices::CreateClassEnumAsync.

    Gli oggetti MIB vengono mappati alle classi CIM SNMP tramite la macro OBJECT-TYPE. Gli eventi vengono mappati alle classi tramite le macro TRAP-TYPE e NOTIFICATION-TYPE.

    La macro OBJECT-TYPE viene utilizzata per descrivere le caratteristiche di base di un oggetto MIB. Nelle macro SNMPv1 TRAP-TYPE e SNMPv2C NOTIFICATION-TYPE sono descritte le caratteristiche di un evento SNMP.

  • Creando un'istanza delle definizioni delle classi SNMP. Per creare un'istanza di una definizione di classe, le applicazioni possono chiamare IWbemServices::GetObject oppure IWbemServices::GetObjectAsync.

  • Enumerando le istanze delle classi SNMP. Il provider di istanze SNMP soddisfa le richieste di enumerazione delle istanze associate alle classi che rappresentano MIB di dispositivi.

  • Creando un'istanza delle istanze delle classi SNMP. Il provider di istanze SNMP elabora le richieste di creazione di un'istanza delle istanze di classi che rappresentano oggetti MIB.

  • Recuperando le istanze delle classi SNMP. Per recuperare un'istanza specifica di una classe CIM SNMP, le applicazioni possono chiamare IWbemServices::GetObject oppure IWbemServices::GetObjectAsync.

SNMP e schema CIM

Lo schema utilizzato da SNMP per definire gli oggetti differisce da quello utilizzato nel modello CIM di WMI. Lo schema SNMPv1 e SNMPv2 è denominato SMI (Structure of Management Information) ed è inserito nel pacchetto nel formato di file MIB. Per definire gli oggetti, i file MIB utilizzano il linguaggio standard Abstract Syntax Notation 1 (ASN.1) e le definizioni delle macro utilizzate come modelli. Queste macro forniscono informazioni sull'oggetto, inclusi il nome, l'identificatore, la sintassi, la descrizione, i diritti di accesso e così via.

I provider SNMP WMI convertono le macro MIB seguenti:

  • OBJECT-TYPE - Descrive le caratteristiche di base di un oggetto, ad esempio il nome, la sintassi, i diritti di accesso di un oggetto e così via. Si riferisce a SNMPv1 e SNMPv2C.

  • TEXTUAL-CONVENTION - Assegna un nome e in alcuni casi un intervallo di valori a un tipo di dati esistente. Si riferisce solo a SNMPv2C.

  • TRAP-TYPE - Descrive i messaggi di eventi (trap). Si riferisce solo a SNMPv1.

  • NOTIFICATION-TYPE - Descrive i messaggi di eventi (notifiche). Si riferisce solo a SNMPv2C.

Il provider di classi SNMP enumera e crea un'istanza di un insieme di definizioni di classi rispetto a uno spazio dei nomi CIM. A tale scopo, utilizza un correlatore MIB e l'archivio SMIR (SNMP Module Information Repository), un database di schemi SNMP. Il provider di classi SNMP supporta modalità correlate e non correlate. Per designare una di queste modalità, impostare un valore contestuale (IWbemContext) correlato di tipo booleano e passarlo nel metodo IWbemServices. Il provider di classi SNMP supporta sia l'enumerazione di definizioni di classi che il recupero di una definizione di classe.

Il provider di istanze SNMP mappa oggetti MIB SNMP a istanze di classi.

Spazio dei nomi SNMP

Per definire una visualizzazione di un dispositivo di rete, viene utilizzato uno spazio dei nomi SNMP. Per creare uno spazio dei nomi SNMP, è possibile utilizzare l'applicazione WMI CIM Studio di WMI SDK, compilare un file MOF o utilizzare un'API WMI a livello di programmazione.

La classe di sistema Namespace viene utilizzata per rappresentare uno spazio dei nomi SNMP. Per generare un nuovo spazio dei nomi, creare un'istanza di questa classe. È necessario associare almeno un descrittore o qualificatore all'istanza della classe. I qualificatori contengono informazioni sul contesto specifiche dell'implementazione e trasportano le proprietà che definiscono il modo in cui i provider SNMP accedono a un agente SNMP.

Rappresentazione di dispositivi SNMP

I dispositivi SNMP sono rappresentati in WMI tramite uno spazio dei nomi proxy contenente un insieme di qualificatori di istanze. Questi qualificatori descrivono le caratteristiche del trasporto relative al dispositivo. In WMI viene utilizzato un file MOF, snmpreg.mof, per creare lo spazio dei nomi \\.\root\snmp\localhost. Questo è uno spazio dei nomi standard che rappresenta l'agente SNMP locale.

SNMPv2C

SNMPv2C è supportato nel contesto WMI. Lo scopo principale di SNMPv2C è quello di offrire un contesto di sicurezza superiore per SNMP. In questa versione viene utilizzata la funzionalità di autenticazione semplice e non sicura basata su password, conosciuta come funzionalità di community (disponibile in SNMPv1). In SMI di SNMPv2 vengono introdotti alcune integrazioni e alcuni miglioramenti per la sicurezza community, ad esempio l'utilizzo di stringhe di bit, indirizzi di rete e contatori nei tipi di dati specifici di SMI di SNMPv1. SMI di SNMPv2 inoltre specifica moduli di informazioni, che definiscono un gruppo di definizioni correlate. SNMPv2 infine definisce due nuove operazioni di protocollo: GetBulk e Inform.

Sicurezza

La sicurezza WMI convalida le informazioni di accesso di un utente sia per il computer locale che per l'accesso remoto. WMI concede a un utente convalidato una forma di accesso controllato all'intero archivio CIM. Nella versione corrente WMI non garantisce sicurezza per le risorse di sistema, ad esempio singole classi e istanze. Gli amministratori tuttavia possono utilizzare WMI per controllare le autorizzazioni globali per le operazioni relative allo schema, ad esempio limitando l'accesso di alcuni utenti alle operazioni di sola lettura. WMI inoltre supporta la sicurezza per ogni spazio dei nomi. Il provider SNMP inoltre offre il supporto per tutta la sicurezza basata su SNMP, inclusi i miglioramenti della sicurezza apportati in SNMPv2C.

Compilatore di moduli di informazioni SNMP

Il compilatore di moduli di informazioni SNMP viene utilizzato per compilare informazioni di gestione SNMP native definite in un archivio MIB in una definizione di schema CIM equivalente che può essere utilizzata con i provider SNMP. Lo schema CIM può esistere come output in un file MOF o essere caricato in un database di schemi SNMP, ovvero un archivio SMIR (SNMP Module Information Repository). Nel provider di classi dinamiche SNMP viene utilizzato l'archivio SMIR (SNMP Module Information Repository) per creare e recuperare istanze di definizioni di classi.

Il compilatore di moduli di informazioni SNMP viene eseguito in modalità riga di comando come file eseguibile utilizzando un modulo di informazioni SNMP come input e altri file aggiuntivi eventualmente necessari per risolvere riferimenti esterni. I moduli di informazioni SNMP sono insiemi di informazioni di gestione costituite in genere da una combinazione di moduli MIB e istruzioni AGENT-CAPABILITIES e MODULE-COMPLIANCE. Le istruzioni AGENT-CAPABILITIES descrivono la conformità di un agente all'insieme di moduli MIB supportati. Le istruzioni MODULE-COMPLIANCE descrivono le funzionalità di un agente relativamente alle definizioni di oggetti.

Il compilatore di moduli di informazioni SNMP inoltre offre le funzionalità seguenti:

  • Esegue operazioni di controllo nel modulo di informazioni. Controlla ad esempio la sintassi locale e i riferimenti esterni confrontandoli con le informazioni contenute nei moduli supplementari.

  • Rimuove tutti i dati precedentemente caricati dall'archivio SMIR o rimuove i dati caricati da un modulo di informazioni.

  • Restituisce il nome di modulo ASN.1 di un file specificato o i nomi di modulo ASN.1 di tutti i moduli importati in un file specificato.

  • Restituisce i nomi di modulo ASN.1 di tutti i moduli di informazioni SNMP attualmente caricati nell'archivio SMIR.

  • Esegue la risoluzione automatica dei moduli importati anziché richiedere agli utenti di specificare manualmente i moduli necessari.

  • Esegue una modalità di operazione con caricamento invisibile all'utente che non genera output, ma può essere utilizzata per caricare dati nell'archivio SMIR durante un'operazione di installazione.

Vedere anche

  • Panoramica di Simple Network Management Protocol


Panoramica di Gestione archivi SAN

È possibile utilizzare Gestione archivi SAN per creare e gestire numeri di unità logica (LUN, Logical Unit Number) in sottosistemi di archiviazione disco Fibre Channel e iSCSI che supportano il Servizio dischi virtuali (VDS).

A causa delle differenze a livello di hardware, protocolli e sicurezza, la configurazione e la gestione di LUN in ambienti Fibre Channel e iSCSI presentano alcune differenze. In questa sezione vengono illustrate tali differenze.

Gestire i LUN in un ambiente Fibre Channel

In un ambiente Fibre Channel i LUN creati in un sottosistema di archiviazione disco vengono assegnati direttamente a un server oppure a un cluster, che accede al LUN tramite una o più porte HBA (Scheda bus host, Host Bus Adapter) Fibre Channel. È sufficiente identificare il server o il cluster che eseguirà l'accesso al LUN e quindi selezionare le porte HBA sul server o sul cluster che verranno utilizzate per il traffico del LUN.

Quando viene identificato un server oppure un cluster, Gestione archivi SAN individua automaticamente le porte HBA Fibre Channel disponibili su tale server o cluster. È inoltre possibile aggiungere porte manualmente digitandone il nome universale (WWN, World Wide Name).

Gestire i LUN in un ambiente iSCSI

A differenza di un ambiente Fibre Channel, i LUN creati in un sottosistema di archiviazione disco iSCSI non vengono assegnati solo a un server o a un cluster, bensì vengono assegnati innanzitutto a entità logiche denominate destinazioni.

Le destinazioni vengono create per gestire le connessioni tra un dispositivo iSCSI e i server che vi devono accedere. Una destinazione definisce i portali (indirizzi IP) che possono essere utilizzati per la connessione al dispositivo iSCSI, nonché le eventuali impostazioni di sicurezza richieste dal dispositivo iSCSI per l'autenticazione dei server che richiedono l'accesso alle risorse.

Nota

Nella maggior parte dei casi è possibile creare e gestire direttamente le destinazioni. Alcuni sottosistemi di archiviazione iSCSI tuttavia supportano soltanto configurazioni delle destinazioni semplici, con creazione automatica delle destinazioni quando viene creato un LUN. Con le configurazioni delle destinazioni semplici inoltre non è possibile eliminare una destinazione o assegnarle manualmente LUN. I LUN vengono assegnati automaticamente quando vengono creati. Per questo tipo di sottosistema, è sufficiente identificare il server o il cluster che accederà al LUN. Il sottosistema iSCSI consentirà quindi l'accesso al LUN da tale server o cluster.

Per la connessione a una destinazione, un server della rete di archiviazione (SAN) utilizza un iniziatore iSCSI. Un iniziatore iSCSI è un'entità logica che consente al server di comunicare con la destinazione. L'iniziatore iSCSI esegue innanzitutto l'accesso alla destinazione e il server potrà avviare la lettura e la scrittura nei LUN assegnati a tale destinazione soltanto dopo la concessione dell'accesso. Ogni iniziatore iSCSI può disporre di una o più schede di rete tramite le quali viene stabilita la comunicazione.

Come negli ambienti Fibre Channel, è sufficiente identificare il server o il cluster che eseguirà l'accesso al LUN. Gestione archivi SAN individuerà quindi automaticamente gli iniziatori iSCSI su tale server o cluster ed elencherà tutte le schede disponibili per tali iniziatori. Dopo l'individuazione delle schede degli iniziatori iSCSI, è possibile selezionare quelle che verranno utilizzate per il traffico del LUN.

Per ulteriori informazioni su iSCSI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93543.


Panoramica di Subsystem for UNIX-based Applications

Subsystem for UNIX-based Applications (SUA) è un sottosistema per la compatibilità del codice sorgente che consente di compilare ed eseguire applicazioni personalizzate basate su UNIX nei computer che eseguono sistemi operativi Microsoft® Windows® di classe server. Con SUA è possibile assicurare la piena interoperabilità delle applicazioni basate su UNIX con Windows con minimi interventi o nessun intervento a livello di codice sorgente.

Subsystem for UNIX-based Applications fornisce un sistema operativo per i processi POSIX (Portable Operating System Interface). SUA, insieme al relativo pacchetto di utilità di supporto, quali shell e Visual Studio® 2005 debugger extension, disponibile per il download sul sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139521, offre un ambiente UNIX completo. Il pacchetto di download include un insieme completo di utilità di script e un SDK (Software Development Kit) progettato per supportare le funzionalità di sviluppo di SUA e per implementare un ambiente completo per lo sviluppo di applicazioni basate su UNIX.

SUA supporta inoltre nomi di file con distinzione tra maiuscole e minuscole, il controllo dei processi, strumenti di compilazione e l'utilizzo di oltre 300 comandi, utilità e script della shell UNIX. Poiché viene installato separatamente rispetto al kernel di Windows, il sottosistema offre funzionalità UNIX autentiche, senza emulazione.

Funzionalità incluse in Subsystem for UNIX-based Applications

Le funzionalità incluse in Subsystem for UNIX-based Applications sono:

  • Connettività di librerie di database (OCI/ODBC) SUA supporta la connettività con Oracle e SQL Server da applicazioni di database tramite l'interfaccia OCI (Oracle Call Interface) e lo standard ODBC (Open Database Connectivity).

  • Microsoft Visual Studio® Debugger Extension per il debug di applicazioni POSIX SUA include il supporto per il debug dei processi POSIX tramite l'ambiente di sviluppo integrato (IDE) di Visual Studio.

  • Utilità basate su ambienti SVR-5 e BSD UNIX Il pacchetto di download SUA supporta due diversi ambienti UNIX: SVR-5 e BSD.

  • Supporto di applicazioni a 64 bit Tramite un processo denominato esecuzione del thunk, SUA fornisce supporto non solo per applicazioni a 64 bit in esecuzione su un sistema operativo a 64 bit, ma anche supporto predefinito per i file binari a 32 bit in esecuzione su un sistema a 64 bit.

Per ulteriori informazioni e per scaricare le utilità di script e l'SDK, visitare il sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139521.

Installazione di Subsystem for UNIX-based Applications

Subsystem for UNIX-based Applications (SUA) è una funzionalità inclusa in Microsoft® Windows Server® 2008 R2 e Windows® 7.

Nota

Per eseguire o modificare script basati su UNIX e applicazioni personalizzate basate su UNIX, è necessario innanzitutto installare il pacchetto Utilità e SDK (Software Development Kit) per Subsystem for UNIX-based Applications. Tale pacchetto è disponibile per il download sul sito Web Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139521.

In Windows Server 2008 R2 è possibile installare SUA utilizzando l'Aggiunta guidata funzionalità in Server Manager. Sebbene Server Manager si apra per impostazione predefinita quando un membro del gruppo Administrators accede al computer, è possibile aprire Server Manager anche utilizzando i comandi del menu Start in Strumenti di amministrazione e aprendo Programmi in Pannello di controllo. Gli utenti di Windows Server 2008 R2 possono inoltre installare SUA tramite la riga di comando (ServerManagerCmd.exe) di Server Manager o l'insieme Server Manager di cmdlet Windows PowerShell. Per ulteriori informazioni sulla riga di comando di Server Manager o l'installazione di funzionalità mediante i cmdlet di Windows PowerShell, vedere la Guida di Server Manager, premendo F1 dalla console di Server Manager o aprendo il file della Guida nel percorso %windir%\Help\mui\0409\rmt.chm.

Nota

A causa delle restrizioni di sicurezza imposte dalla funzionalità Controllo dell'account utente in Windows Server 2008 R2 e Windows 7, per installare o rimuovere funzionalità nel computer tramite i cmdlet di Windows PowerShell o l'utilità da riga di comando Server Manager, è necessario eseguire Windows PowerShell o la sessione di prompt dei comandi come amministratore. A tale scopo, fare clic con il pulsante destro del mouse sul collegamento di Windows PowerShell o del prompt dei comandi e quindi scegliere Esegui come amministratore.

Per installare SUA in Windows 7, aprire il Pannello di controllo, scegliere Programmi e quindi fare clic su Attiva o disattiva le funzionalità di Windows.

Aprire Subsystem for UNIX-based Applications

Quando si installa il sottosistema utilizzando l'Aggiunta guidata funzionalità o l'opzione Attiva o disattiva le funzionalità di Windows, un oggetto SUA viene aggiunto al menu Start. Tale oggetto non è tuttavia un collegamento, non apre nessuna finestra SUA a differenza di altri collegamenti del menu Start. L'oggetto in questione è un contenitore di shell e utilità disponibili nel pacchetto di download SUA. Al termine dell'installazione del pacchetto di download, è possibile accedere a SUA aprendo e lavorando nelle shell di comando basate su UNIX, i cui collegamenti popolano l'oggetto SUA nel menu Start.


Panoramica di Server Telnet

Telnet è un protocollo e un'utilità standard Internet basato sulla RFC 854, che specifica un metodo per trasmettere e ricevere caratteri ASCII non crittografati su una rete. È possibile utilizzare un client Telnet eseguito in un computer per connettersi a una sessione basata su riga di comando per eseguire applicazioni. Sono supportate solo applicazioni e interfacce a carattere. Nell'ambiente Telnet non sono disponibili funzionalità grafiche.

I documenti RFC che definiscono Telnet sono disponibili nel sito Web Internet Engineering Task Force (http://go.microsoft.com/fwlink/?linkid=121). Nel sito Web fare clic su RFC Pages, digitare 854 nella casella di testo RFC number e quindi fare clic su Go.

Telnet è costituito da due componenti: Client Telnet e Server Telnet.

Server Telnet

Server Telnet ospita le sessioni remote dei client Telnet. Quando in un computer è in esecuzione Server Telnet, gli utenti possono connettersi al server con un client Telnet da un computer remoto. Server Telnet è implementato in Windows come servizio che può essere configurato in modo da essere sempre in esecuzione, anche quando nessun utente è connesso al server.

Quando un client Telnet si connette a un computer che esegue Server Telnet, viene chiesto all'utente remoto di immettere un nome utente e una password. La combinazione di nome utente e password deve essere una combinazione valida per Server Telnet. Server Telnet in Windows supporta due tipi di autenticazione: NTLM e l'autenticazione con password o senza crittografia.

Dopo aver eseguito la connessione, l'utente visualizza un prompt dei comandi che può essere utilizzato come se avesse avuto accesso localmente nella console del server. I comandi digitati al prompt dei comandi del client Telnet vengono inviati a Server Telnet e qui eseguiti, come se si fosse connessi in locale a una sessione del prompt dei comandi nel server. L'output dei comandi eseguiti viene inviato al client Telnet, dove viene visualizzato per l'utente.

Telnet non supporta applicazioni per cui è necessaria un'interfaccia utente grafica. Server Telnet e Client Telnet sono tuttavia in grado di decifrare sequenze di caratteri speciali che offrono un certo livello di formattazione e posizionamento del cursore nella finestra del client Telnet. Server Telnet e Client Telnet supportano l'emulazione di quattro tipi di terminali: ANSI, VT-100, VT-52 e VT-NT.

Installare Server Telnet

In Windows Server 2008 è possibile installare Server Telnet utilizzando l'Aggiunta guidata funzionalità di Server Manager. Sebbene Server Manager si apra per impostazione predefinita quando un membro del gruppo Administrators accede al computer, è possibile aprire Server Manager anche utilizzando i comandi del menu Start in Strumenti di amministrazione e aprendo Programmi nel Pannello di controllo. In Microsoft Windows Vista e versioni successive, per installare Server Telnet e Client Telnet aprire il Pannello di controllo, fare clic su Programmi e quindi su Attivazione o disattivazione delle funzionalità Windows.

Per ulteriori informazioni sull'installazione o l'utilizzo di Server Telnet, vedere la guida operativa Telnet (http://go.microsoft.com/fwlink/?linkid=86992) nel sito Web Microsoft.


Panoramica di Client Telnet

Telnet è un protocollo e un'utilità standard Internet basato sulla RFC 854, che specifica un metodo per trasmettere e ricevere caratteri ASCII non crittografati su una rete. È possibile utilizzare un client Telnet eseguito in un computer per connettersi a una sessione basata su riga di comando per eseguire applicazioni. Sono supportate solo applicazioni e interfacce a carattere. Nell'ambiente Telnet non sono disponibili funzionalità grafiche.

I documenti RFC che definiscono Telnet sono disponibili nel sito Web Internet Engineering Task Force (http://go.microsoft.com/fwlink/?linkid=121). Nel sito Web fare clic su RFC Pages, digitare 854 nella casella di testo RFC number e quindi fare clic su Go.

Telnet è costituito da due componenti: Client Telnet e Server Telnet.

Client Telnet

Client Telnet consente a un computer di connettersi a un server Telnet remoto ed eseguire le applicazioni su tale server. Dopo aver eseguito la connessione, l'utente visualizza un prompt dei comandi che può essere utilizzato come se avesse avuto accesso localmente nella console del server Telnet. I comandi digitati al prompt dei comandi del client Telnet vengono inviati a Server Telnet e qui eseguiti, come se si fosse connessi in locale a una sessione del prompt dei comandi nel server. L'output dei comandi eseguiti viene inviato al client Telnet, dove viene visualizzato per l'utente.

Telnet non supporta applicazioni per cui è necessaria un'interfaccia utente grafica. Server Telnet e Client Telnet sono tuttavia in grado di decifrare sequenze di caratteri speciali che offrono un certo livello di formattazione e posizionamento del cursore nella finestra del client Telnet. Server Telnet e Client Telnet supportano l'emulazione di quattro tipi di terminali: ANSI, VT-100, VT-52 e VT-NT.

Installare Client Telnet

In Windows Server 2008 è possibile installare Client Telnet utilizzando l'Aggiunta guidata funzionalità di Server Manager. Sebbene Server Manager si apra per impostazione predefinita quando un membro del gruppo Administrators accede al computer, è possibile aprire Server Manager anche utilizzando i comandi del menu Start in Strumenti di amministrazione e aprendo Programmi nel Pannello di controllo. In Microsoft Windows Vista e versioni successive, per installare Client Telnet e Server Telnet aprire il Pannello di controllo, fare clic su Programmi e quindi su Attivazione o disattivazione delle funzionalità Windows.

Per ulteriori informazioni sull'installazione o l'utilizzo di Client Telnet, vedere la guida operativa Telnet (http://go.microsoft.com/fwlink/?linkid=86992) nel sito Web Microsoft.


Panoramica del protocollo TFTP (Trivial File Transfer Protocol)

Protocollo TFTP (Trivial File Transfer Protocol)

Il client TFTP (Trivial File Transfer Protocol) consente di trasferire file utilizzando il protocollo TFTP tra un client TFTP e un server TFTP. Il protocollo TFTP viene implementato utilizzando il protocollo UDP (User Datagram Protocol) per l'invio e la ricezione di dati. Il protocollo TFTP implementa il proprio schema di affidabilità utilizzando UDP.

Poiché non supporta alcun meccanismo di autenticazione o crittografia, il protocollo TFTP può comportare un rischio di sicurezza. Non è consigliabile installare il client TFTP per sistemi con accesso a Internet.

Il client TFTP è un software facoltativo ed è obsoleto in Windows Vista® e nelle versioni più recenti del sistema operativo Windows. Per problemi di sicurezza analoghi, non viene più fornito un server TFTP da Microsoft.


Panoramica di Database interno di Windows

Database interno di Windows è un archivio dati relazionale che può essere utilizzato dalle applicazioni e dai servizi seguenti:

  • Servizi Microsoft Windows Rights Management di Active Directory (RMS di AD)

  • Windows Server Update Services

  • Gestione risorse di sistema Windows

Questi servizi e applicazioni condividono un'unica istanza dell'archivio dati.

Installare Database interno di Windows

Non è necessario in genere installare Database interno di Windows, poiché viene installato dalla prima applicazione o dal primo servizio che lo richiede.

Rimuovere Database interno di Windows

Poiché più applicazioni e servizi utilizzano la stessa istanza di Database interno di Windows, rimuovendo questi servizi e applicazioni non viene rimosso l'archivio dati. Se si rimuovono tutti i servizi e le applicazioni che utilizzano Database interno di Windows, è poi possibile rimuovere questo archivio utilizzando la Rimozione guidata funzionalità di Server Manager.

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Windows Internet Name Service (WINS) Overview

Windows Internet Name Service (WINS) è un servizio di registrazione e risoluzione dei nomi di computer che esegue il mapping dei nomi NetBIOS dei computer a indirizzi IP. La distribuzione di server WINS nella rete consente agli utenti finali di accedere alle risorse di rete utilizzandone il nome, anziché gli indirizzi IP più difficili da ricordare. I servizi software e gli altri servizi in esecuzione nei computer e negli altri dispositivi sono inoltre in grado di eseguire query sui nomi nel server WINS per risolvere i nomi in indirizzi IP.

Vantaggi offerti da un server WINS

WINS offre i vantaggi seguenti per l'amministrazione di una rete basata su TCP/IP:

  • Disponibilità di un database di mapping dinamico tra nomi e indirizzi che supporta la registrazione e la risoluzione dei nomi di computer.

  • Gestione centralizzata del database di mapping tra nomi e indirizzi e minore necessità di gestire i file Lmhosts.

  • Riduzione del traffico broadcast NetBIOS nelle subnet, grazie alla possibilità di permettere ai client di eseguire query nei server WINS per individuare direttamente i sistemi remoti.

  • Supporto dei client precedenti Microsoft® Windows® e basati su NetBIOS nella rete e possibilità per questi tipi di client di utilizzare elenchi di domini Windows remoti senza che sia necessaria la presenza di un controller di dominio locale in ogni subnet.

  • Supporto dei client DNS, ai quali è consentito individuare le risorse NetBIOS quando è implementata l'integrazione della ricerca WINS.

La risoluzione dei nomi per i client WINS è un'estensione dello stesso processo di risoluzione dei nomi utilizzato da tutti i client NetBIOS su TCP/IP (NetBT) Microsoft per risolvere le query sui nomi NetBIOS nella propria rete. Il metodo effettivo della risoluzione dei nomi è trasparente per l'utente.

Dopo avere eseguito la query tramite net use o un'applicazione NetBIOS simile, in Windows XP e Windows 2000 i client WINS eseguono la sequenza di operazioni illustrata di seguito per risolvere un nome:

  1. Stabiliscono se il nome contiene più di 15 caratteri o se contiene punti ("."). In caso affermativo, inviano una query al server DNS sul nome.

  2. Stabiliscono se il nome è archiviato nella cache dei nomi remota nel client.

  3. Contattano i server WINS configurati per tentare di risolvere il nome utilizzando WINS.

  4. Utilizzano broadcast IP locali per la subnet.

  5. Controllano un file Lmhosts se è abilitata l'opzione Abilita ricerca LMHOSTS nelle proprietà della connessione Protocollo Internet (TCP/IP).

  6. Controllano un file Hosts.

  7. Eseguono una query in un server DNS.

Componenti di un server WINS

WINS è costituito da due componenti principali, i server WINS e i client WINS. In alcune configurazioni vengono utilizzati i proxy WINS.

Server WINS

Il server WINS gestisce le richieste di registrazione dei nomi provenienti dai client WINS, registra i relativi nomi e indirizzi IP e risponde alle query sui nomi NetBIOS dei client restituendo l'indirizzo IP di un nome oggetto di query se tale nome è presente nel database del server.

È inoltre possibile configurare i server WINS in modo da replicare il contenuto dei relativi database (contenenti i mapping dei nomi di computer NetBIOS in indirizzi IP) su altri server WINS. Quando un client WINS, ad esempio una workstation, accede alla rete, il nome e l'indirizzo IP del client viene inviato in una richiesta di registrazione direttamente al relativo server primario WINS configurato. Il server che registra i client è definito come il proprietario dei record dei client nel database.

Database WINS

Nel database WINS sono archiviati i mapping tra nomi NetBIOS e indirizzi IP per la rete. Se per i server WINS si configurano partner di replica di Push nei quali viene spostato il contenuto del database, il contenuto del database nel server locale verrà replicato nel server del partner di replica. Se i partner di replica sono configurati come partner di Pull, i record del server WINS remoto vengono copiati nel database locale. Gli intervalli ai quali si verificano questi eventi di replica possono essere configurati utilizzando lo snap-in WINS di Microsoft Management Console (MMC), denominato anche console WINS.

La console WINS offre inoltre gli strumenti necessari per gestire e visualizzare il database del server WINS, nonché per eseguirne il backup e il ripristino. Eseguire il backup del database ogni volta che si crea un backup di altri file nel server WINS.

Client WINS

I client WINS eseguono un tentativo di registrazione dei relativi nomi su un server WINS quando accedono alla rete e in seguito inviano una query al server WINS per risolvere i nomi remoti in base alle necessità.

I client abilitati WINS sono computer configurabili per utilizzare direttamente un server WINS. La maggior parte dei client WINS in genere dispone di più nomi NetBIOS che devono essere registrati per poter essere utilizzati nella rete. Tramite questi nomi vengono pubblicati i diversi tipi di servizi di rete che ogni computer può utilizzare per comunicare in vari modi con gli altri computer della rete, ad esempio il servizio Messenger o Workstation.

Proxy WINS

Un proxy WINS è un computer client WINS configurato in modo da operare per conto di altri computer host che non possono utilizzare direttamente WINS. I proxy WINS semplificano la risoluzione delle query sui nomi NetBIOS per i computer che si trovano in reti TCP/IP con routing.

Per impostazione predefinita, la maggior parte dei computer che non può utilizzare WINS ricorre ai broadcast per risolvere le query sui nomi NetBIOS e registrare i relativi nomi NetBIOS nella rete. È possibile configurare un proxy WINS in modo che questo rimanga in ascolto per conto di questi computer ed esegua query in un server WINS per i nomi non risolti dai broadcast.

I proxy WINS sono utili o necessari solo nelle reti in cui sono presenti client NetBIOS solo broadcast (o nodo B). I client abilitati WINS sono comuni nella maggior parte delle reti e pertanto i proxy WINS non sono in genere necessari.

I proxy rimangono in ascolto delle funzioni del servizio dei nomi NetBIOS di nodo B (registrazione dei nomi, rilascio del nomi e query sui nomi) e possono rispondere per i nomi remoti e non utilizzati nella rete locale. I proxy comunicano direttamente con un server WINS per recuperare le informazioni necessarie per rispondere a questi broadcast locali.

I proxy WINS vengono utilizzati nei modi seguenti:

  • Quando un client nodo B effettua la registrazione del proprio nome, il proxy controlla il nome nel database del server WINS. Se il nome esiste nel database WINS, è possibile che il proxy invii una risposta di registrazione negativa al client nodo B che sta tentando di registrare il nome.

  • Quando un client nodo B rilascia il proprio nome, il proxy elimina il nome del client dalla relativa cache dei nomi remoti.

  • Quando un client nodo B invia una query sul nome, il proxy tenta di risolvere il nome utilizzando le informazioni disponibili a livello locale nella relativa cache dei nomi remoti o tramite le informazioni ottenute dal server WINS.

Gestione di un server WINS

Gli strumenti principali per la gestione dei server WINS sono la console WINS e i comandi Netsh per WINS.

Console WINS

La console WINS è uno snap-in di Microsoft Management Console (MMC).

Dopo avere installato un server WINS, è possibile utilizzare la console WINS o i comandi Netsh di WINS per eseguire le seguenti attività di amministrazione di base del server:

  1. Visualizzare e filtrare le registrazioni di nomi NetBIOS archiviate nel server WINS per i nomi dei client utilizzati nella rete.

  2. Aggiungere e configurare i partner di replica per il server WINS.

  3. Eseguire le attività correlate alla manutenzione nel database del server WINS, inclusi il backup, il ripristino, la compattazione e lo scavenging.

È inoltre possibile utilizzare la console WINS o i comandi Netsh di WINS per eseguire le attività di configurazione facoltative o avanzate riportate di seguito:

Visualizzare e modificare le proprietà WINS, ad esempio Intervallo di rinnovo e altri intervalli utilizzati durante la registrazione, il rinnovo e la verifica dei record dei nomi archiviati nel database del server.

  • Aggiungere e configurare i mapping WINS statici, se è necessario utilizzarli nella rete.

  • Eliminare o contrassegnare per la rimozione record WINS presenti in dati del server WINS che sono utilizzati in tutta la rete.

Comandi Netsh per WINS

È possibile digitare i comandi Netsh per WINS in una finestra del prompt dei comandi al prompt dei comandi netsh wins> oppure eseguire i comandi Netsh per WINS in file batch e altri script. Tutte le funzionalità disponibili nella console WINS sono disponibili anche al prompt dei comandi netsh wins>.


Panoramica di Windows PowerShell Integrated Scripting Environment

Windows PowerShell Integrated Scripting Environment (ISE) è un'applicazione host grafica per Windows PowerShell. Windows PowerShell ISE consente di eseguire comandi e di scrivere, modificare, eseguire e verificare script, nonché di eseguirne il debug, in un ambiente nel quale sono utilizzati i colori per la visualizzazione della sintassi ed è supportato il formato Unicode.

Windows PowerShell è una shell della riga di comando e un linguaggio di script basato su Microsoft .NET Framework. WPS è destinato soprattutto all'amministrazione di Windows. Grazie agli strumenti di facile utilizzo (i cosiddetti cmdlet) e al sistema di Guida integrato, è possibile iniziare a utilizzare WPS immediatamente. I cmdlet possono essere combinati in pipeline contenenti più comandi. È quindi possibile salvare le sequenze di comandi preferite all'interno di funzioni, per consentire l'esecuzione automatica di attività. Gli utenti più esperti possono utilizzare Windows PowerShell come piattaforma di sviluppo, ampliandola mediante l'aggiunta di funzioni, cmdlet e provider.

Windows PowerShell ISE è destinato agli utenti di ogni livello di esperienza. I principianti apprezzeranno i colori per la sintassi e la Guida sensibile al contesto. La modifica a più righe rende facile provare esempi copiati dalla Guida e da altre fonti. Gli utenti esperti apprezzeranno la disponibilità di più ambienti di esecuzione, il debugger incorporato e l'estendibilità del modello a oggetti di Windows PowerShell ISE.

Windows PowerShell 2.0 è una funzionalità di Windows Server 2008 R2. Windows PowerShell ISE è una funzionalità facoltativa. Per installarla, utilizzare Aggiunta guidata funzionalità.

Funzionalità di Windows PowerShell ISE

Le funzionalità di Windows PowerShell ISE includono:

  • Un riquadro dei comandi per l'esecuzione di comandi interattivi.

  • Un riquadro degli script per la scrittura, la modifica e l'esecuzione di script. È possibile eseguire l'intero script o solo alcune righe selezionate.

  • Un riquadro per l'output, che è possibile scorrere, in cui è visualizzata la trascrizione dei comandi del riquadro dei comandi e di quello degli script e i relativi risultati.

  • Fino a otto ambienti di esecuzione Windows PowerShell in un'unica finestra, ognuno con i riquadri dei comandi, degli script e dell'output. L'ambiente è suddiviso in schede e consente di eseguire più attività contemporaneamente.

  • La funzionalità di modifica multiriga del riquadro dei comandi consente di incollare più righe di codice, eseguirle e richiamarle come unità.

  • Un debugger integrato per il debug dei comandi, delle funzioni e degli script. È possibile impostare e rimuovere punti di interruzione, eseguire il codice un'istruzione alla volta, controllare i valori delle variabili e visualizzare una traccia dello stack di chiamata.

  • Grazie alle funzionalità personalizzabili, è possibile modificare i colori, il tipo di carattere e il layout.

  • Un modello a oggetti configurabile tramite script consente di personalizzare ed estendere ulteriormente Windows PowerShell ISE. È possibile aggiungere funzionalità, ad esempio voci di menu. È inoltre possibile accedere alla sessione, ai file e all'editor per creare funzionalità personalizzate.

  • I numeri di riga e colonna, le scelte rapide da tastiera, la Guida sensibile al contesto e il supporto per Unicode rendono Windows PowerShell ISE un ambiente efficiente e produttivo per l'utilizzo di Windows PowerShell. Windows PowerShell consente persino l'apertura di file mediante trascinamento della selezione.

Requisiti di Windows PowerShell ISE

È possibile eseguire Windows PowerShell ISE in Windows XP e versioni di Windows successive, ad eccezione delle installazioni Server Core di Windows Server.

Windows PowerShell ISE richiede Microsoft .NET Framework 3.5 con Service Pack 1. Se questa versione di Microsoft .NET Framework non è installata, viene installata da Server Manager durante l'installazione di Windows PowerShell ISE.

Per ulteriori informazioni su Windows PowerShell e Windows PowerShell ISE, vedere Windows PowerShell (http://go.microsoft.com/fwlink/?LinkID=107116).


Panoramica del servizio Attivazione processo Windows

Servizio Attivazione processo Windows

Il servizio Attivazione processo Windows consente di generalizzare il modello di processo di Internet Information Services (IIS), eliminando la dipendenza da HTTP. Tutte le funzionalità di IIS che in precedenza erano disponibili solo per le applicazioni HTTP ora sono disponibili per le applicazioni che ospitano i servizi WCF (Windows Communication Foundation) tramite protocolli non HTTP. In IIS 7.0 il servizio Attivazione processo Windows viene inoltre utilizzato per l'attivazione basata su messaggi su HTTP.

Condizioni per l'installazione e l'esecuzione del servizio Attivazione processo Windows

Dal punto di vista della protezione, è consigliabile eseguire il servizio Attivazione processo Windows solo se si dispone di .NET Framework 3.5.1 o di IIS 7.0.

IIS e .NET Framework 3.5.1 installano automaticamente il servizio Attivazione processo Windows a seconda delle esigenze. Non è consigliabile eseguire un'installazione autonoma del servizio Attivazione processo Windows.

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Panoramica di Estensione IIS di Gestione remota Windows

Estensione IIS di Gestione remota Windows è una nuova funzionalità di Windows Server® 2008 R2.

Che cos'è Estensione IIS di Gestione remota Windows?

Il modulo Estensione IIS di Gestione remota Windows offre un modello di hosting basato su Internet Information Services (IIS). È possibile attivare Estensione IIS di Gestione remota Windows a livello di sito Web o di directory virtuale. Il funzionamento si basa sull'intercettazione delle richieste in ingresso e il reindirizzamento di queste verso il sito Web o la directory virtuale associata.

Le richieste in ingresso vengono reindirizzate a un modulo di Gestione remota Windows che analizza il contenuto della richiesta per determinare il plug-in Gestione remota Windows corretto per la gestione della richiesta stessa. Per tutti i reindirizzamenti è consigliabile utilizzare SSL (Secure Socket Layer). È inoltre consigliabile che l'URI reindirizzato venga convalidato da tutte le applicazioni prima dell'avvio di una nuova sessione.

Per ulteriori informazioni su Estensione IIS di Gestione remota Windows, vedere la pagina relativa a Gestione remota Windows (http://go.microsoft.com/fwlink/?LinkId=136946).

Vedere anche

  • Funzionalità disponibili in Windows Server 2008 R2


Panoramica di Windows Server Backup

Windows Server Backup è costituito da uno snap-in Microsoft Management Console (MMC), da strumenti da riga di comando e da cmdlet Windows PowerShell che offrono una soluzione completa per le esigenze quotidiane di backup e ripristino. È possibile utilizzare Windows Server Backup per eseguire il backup di un intero server (tutti i volumi), di volumi selezionati, dello stato del sistema o di cartelle e file specifici e per creare un backup da utilizzare per il ripristino bare metal. È possibile ripristinare volumi, cartelle, file, determinate applicazioni e lo stato del sistema. In casi di emergenza, ad esempio un guasto del disco rigido, è inoltre possibile eseguire un ripristino bare metal. A tale scopo, è necessario utilizzare un backup del server completo o solo dei volumi contenenti i file del sistema operativo e Ambiente ripristino Windows, per ripristinare l'intero sistema nel vecchio sistema o in un nuovo disco rigido.

È possibile utilizzare Windows Server Backup per creare e gestire backup per il computer locale o un computer remoto. È inoltre possibile pianificare i backup in modo che vengano eseguiti automaticamente.

Windows Server Backup può essere utilizzato da chiunque necessiti di una soluzione di backup di base, piccole imprese o grandi aziende, ma è adatto anche per organizzazioni di dimensioni inferiori o per singoli individui non professionisti IT.

Considerazioni

  • Per utilizzare Windows Server Backup, è necessario essere membri del gruppo Administrators o Backup Operators.

  • Per alcune attività di backup o ripristino sono necessari due computer che eseguono la stessa versione di Windows Server 2008 o Windows Server 2008 R2, mentre altre sono effettuabili con computer che eseguono indifferentemente l'una o l'altra versione. Per ulteriori informazioni sulla compatibilità, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143709.

  • Per eseguire il ripristino dello stato del sistema o il ripristino completo del sistema, è necessario utilizzare backup eseguiti con la stessa versione di Windows che si desidera ripristinare. Non è ad esempio possibile utilizzare un backup eseguito con Windows Server 2008 per ripristinare lo stato del sistema di un computer che esegue Windows Server 2008 R2.

  • Il firewall può essere attivato. Se si gestiscono i backup di un altro computer mediante lo snap-in Windows Server Backup, è possibile che la connettività al computer remoto sia limitata e che per risolvere questo problema sia necessario modificare le regole del firewall. Se si utilizza il computer locale, questo problema non si verifica.

  • Windows Server Backup non supporta il backup o l'archiviazione di dati di volumi condivisi del cluster. È tuttavia possibile eseguire il backup di macchine virtuali utilizzando Windows Server Backup all'interno della macchina virtuale desiderata. Per ulteriori informazioni sulla gestione di cluster di failover, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=92360. Per ulteriori informazioni sulla gestione di Hyper-V, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=93752. Per ulteriori informazioni su Hyper-V e i volumi condivisi del cluster, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=139667.

  • Se per l'archiviazione di backup si utilizza un disco rigido virtuale e quest'ultimo si trova in un disco fisico contenente volumi di sistema o critici, il contenuto ripristinabile potrebbe essere limitato. I file di volumi virtuali, inoltre, vengono esclusi dal backup se sono online. Per ulteriori informazioni sull'utilizzo di dischi rigidi virtuali, visitare il sito Web all’indirizzo http://go.microsoft.com/fwlink/?LinkId=143712.

  • Se si utilizza la precedente funzionalità di backup (Ntbackup.exe) e si intende passare al nuovo snap-in Windows Server Backup, è possibile che si verifichino i problemi riportati di seguito e che sia necessario apportare le modifiche seguenti:

    • Le impostazioni per la creazione di backup non vengono aggiornate quando si esegue l'aggiornamento a Windows Server 2008. È necessario configurare nuovamente le impostazioni.

    • Non è possibile utilizzare Windows Server Backup per eseguire il backup di file e cartelle in volumi che richiedono oltre 2040 GB (o 2 TB). Se, tuttavia, le dimensioni dei dati sono inferiori a 2 TB è possibile eseguire il backup di file o cartelle. È ad esempio possibile eseguire il backup di 1,5 TB di dati da un volume da 3 TB. Se tuttavia si esegue un ripristino completo del server o del volume utilizzando questo backup, verrà ricreato un volume da 2 TB anziché un volume da 3 TB.

    • È possibile eseguire il backup solo di volumi NTFS di un disco collegato localmente. Per istruzioni sulla conversione di una partizione FAT in una partizione NTFS, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkID=70318.

    • Non è possibile archiviare i backup su nastro. In Windows Server 2008 sono tuttavia ancora supportati i driver di archiviazione su nastro. In Windows Server Backup è supportato il backup su dischi esterni e interni, supporti ottici e rimovibili, ad esempio DVD, e cartelle condivise remote.

    • Non è possibile utilizzare Windows Server Backup per ripristinare i backup creati con Ntbackup.exe. Una versione di Ntbackup.exe è tuttavia disponibile come download per Windows Server 2008 per gli utenti che desiderano ripristinare dati da backup creati con Ntbackup.exe. La versione scaricabile di Ntbackup.exe serve esclusivamente per il ripristino di backup per versioni precedenti di Windows e non può essere utilizzata per creare nuovi backup in Windows Server 2008. Per scaricare Ntbackup.exe, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=82917.

Nuove funzionalità

In Windows Server 2008 R2, Windows Server Backup include i miglioramenti seguenti:

  • Maggiore flessibilità nella scelta del contenuto di cui eseguire il backup. Windows Server Backup consente il backup di file selezionati anziché di interi volumi. È inoltre possibile escludere file in base al tipo e al percorso.

  • Gestione automatica del backup completo e incrementale. Non è più necessario gestire manualmente i backup completi e incrementali. Per impostazione predefinita, Windows Server Backup crea un backup incrementale con il comportamento di un backup completo. Viene creato un unico backup che consente di ripristinare qualsiasi elemento desiderato ma che occupa lo spazio di un backup incrementale. Inoltre, per l'eliminazione dei backup meno recenti allo scopo di liberare spazio su disco per i nuovi backup non è necessario l'intervento dell'utente. I backup meno recenti vengono eliminati automaticamente.

  • Opzioni più ampie per l'archiviazione del backup. È ora possibile archiviare backup creati tramite pianificazione in una cartella o in un volume condiviso remoto. Se si archiviano backup in una cartella condivisa remota, viene mantenuta solo una versione del backup. È inoltre possibile archiviare backup all'interno di dischi rigidi virtuali.

  • Miglioramento delle opzioni per il backup e il ripristino dello stato del sistema. È ora possibile utilizzare l'interfaccia utente dello snap-in Windows Server Backup per la creazione di backup utilizzabili per il ripristino dello stato del sistema. È inoltre ora possibile eseguire il backup dello stato del sistema e di altri dati presenti nel server mediante un unico backup. Questo tipo di backup dello stato del sistema è più rapido e richiede una quantità inferiore di spazio per più versioni, poiché per ogni versione utilizza copie shadow, analogamente al backup basato su volume, e non cartelle singole. Per ulteriori informazioni su come vengono archiviati i backup dello stato del sistema in Windows Server 2008 R2, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143713.

  • Supporto più ampio per la riga di comando e Windows PowerShell. Il comando Wbadmin e la documentazione relativa consentono di eseguire dalla riga di comando le stesse attività eseguite tramite lo snap-in. Per ulteriori informazioni, vedere le pagina di riferimento per i comandi (http://go.microsoft.com/fwlink/?LinkId=140216). È inoltre possibile automatizzare le attività di backup mediante script.

    Le modifiche apportate a questo comando equivalgono a quelle relative allo snap-in Windows Server Backup.

    Windows Server 2008 R2 contiene inoltre un insieme aggiornato di cmdlet Windows PowerShell per Windows Server Backup che consente di scrivere script Windows PowerShell per l'esecuzione di backup. Per ulteriori informazioni, vedere http://go.microsoft.com/fwlink/?LinkId=140217.

Sistemi operativi supportati

Windows Server Backup è disponibile in tutte le edizioni di Windows Server 2008 e Windows Server 2008 R2. Analogamente ad altri snap-in, tuttavia, lo snap-in Windows Server Backup non è disponibile per l'opzione di installazione Server Core di Windows Server 2008 R2. Per eseguire il backup di computer con un'installazione Server Core, è necessario utilizzare il comando Wbadmin o i cmdlet Windows PowerShell di Windows Server Backup oppure gestire i backup in remoto da un altro computer.

Risorse aggiuntive

  • Per ulteriori informazioni sul backup o il ripristino del server, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93012.


Guide e Strumenti di migrazione per Windows Server

La documentazione e gli strumenti per la migrazione semplificano la migrazione di ruoli server, impostazioni del sistema operativo e dati da un server esistente che esegue Windows Server® 2003, Windows Server 2008 o Windows Server 2008 R2 a un computer che esegue Windows Server 2008 R2.

Utilizzando le guide relative alla migrazione a cui è collegato questo argomento, e dove appropriato Strumenti di migrazione per Windows Server, per eseguire la migrazione dei ruoli, è possibile semplificare la distribuzione di nuovi server (inclusi quelli che utilizzano l'opzione di installazione dei soli componenti di base del server di Windows Server 2008 R2, o Server Core, e i server virtuali), ridurre il tempo di inattività dovuto alla migrazione, aumentare l'accuratezza del processo di migrazione e facilitare l'eliminazione dei conflitti che potrebbero verificarsi durante il processo di migrazione.

La maggior parte della documentazione e degli strumenti per la migrazione presentati nel portale dedicato alla migrazione a Windows Server supporta migrazioni tra architetture diverse (da piattaforme di elaborazione basate su x86 a piattaforme di elaborazione basate su x64), migrazioni tra ambienti fisici e virtuali e migrazioni tra installazioni complete e Server Core del sistema operativo Windows Server, se disponibili.

Guida alla migrazione a Windows Server 2008 R2

Guide dettagliate sulla migrazione per ruoli del server supportati, funzionalità, impostazioni del sistema operativo e dati sono disponibili nel TechCenter di Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkID=128554).

Strumenti di migrazione per Windows Server

Strumenti di migrazione per Windows Server è una funzionalità disponibile per l'installazione nei computer che eseguono Windows Server 2008 R2 utilizzando l'Aggiunta guidata funzionalità in Server Manager. Per rimuovere Strumenti di migrazione per Windows Server da Windows Server 2008 R2, è possibile utilizzare la Rimozione guidata funzionalità.

Per eseguire la migrazione di ruoli, funzionalità e altri dati utilizzando Strumenti di migrazione per Windows Server, è inoltre necessario distribuire Strumenti di migrazione per Windows Server nei server di origine dai quali si desidera eseguire la migrazione dei dati. Strumenti di migrazione per Windows Server viene distribuito nei server di origine creando una cartella di distribuzione in un computer che esegue Windows Server 2008 R2, quindi copiandola nei sistemi operativi dei computer di origine in cui è presente una versione precedente a Windows Server 2008 R2 indicati nella tabella in questo argomento.

È necessario essere membri del gruppo Administrators nel computer in cui si desidera installare, registrare o utilizzare Strumenti di migrazione per Windows Server. Inoltre, se si esegue Strumenti di migrazione per Windows Server in server che eseguono Windows Server 2008 o Windows Server 2008 R2, è necessario eseguire Strumenti di migrazione per Windows Server con diritti utente elevati. A tale scopo, fare clic su Start, scegliere Strumenti di amministrazione, fare clic con il pulsante destro del mouse su Strumenti di migrazione per Windows Server e quindi scegliere Esegui come amministratore.

Istruzioni complete su installazione, configurazione e rimozione di Strumenti di migrazione per Windows Server sono disponibili nella guida dettagliata relativa a installazione, accesso e rimozione di Strumenti di migrazione per Windows Server (http://go.microsoft.com/fwlink/?LinkId=134763) nel sito Web TechCenter di Windows Server 2008 R2.

Sistemi operativi supportati

Nella tabella seguente sono indicati i sistemi operativi per i quali è supportata la migrazione tramite Strumenti di migrazione per Windows Server.

Processore del server di origine | Sistemi operativi dei server di origine | Sistemi operativi dei server di destinazione | Processore di destinazione
Basato su x86 o su x64 | Windows Server 2003 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x86 o su x64 | Windows Server 2003 R2 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x86 o su x64 | Windows Server 2008 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x64 | Windows Server 2008 R2 | Windows Server 2008 R2 e Server Core | Basato su x64
Basato su x64 | Windows Server 2008 R2 Server Core | Windows Server 2008 R2 e Server Core | Basato su x64
Note
  • Per le edizioni Foundation, Standard, Enterprise e Datacenter di Windows Server è supportata sia l'opzione per l'installazione completa che quella per l'installazione Server Core, sia nei server di origine che di destinazione.
  • Sono supportate le migrazioni tra sistemi operativi fisici e sistemi operativi virtuali.
  • Non è supportata la migrazione da un server di origine a un server di destinazione che esegue un sistema operativo con una lingua dell'interfaccia utente (ovvero la lingua installata) diversa da quella del server di origine. Non è ad esempio possibile utilizzare Strumenti di migrazione per Windows Server per eseguire la migrazione di ruoli, impostazioni del sistema operativo o dati da un computer che esegue Windows Server 2008 con interfaccia utente del sistema in lingua francese a un computer che esegue Windows Server 2008 R2 con interfaccia utente del sistema in lingua tedesca.
  • La lingua dell'interfaccia utente del sistema è la lingua del pacchetto di installazione localizzato utilizzato per installare il sistema operativo Windows.
  • Per Windows Server 2003 e Windows Server 2008 sono supportate sia le migrazioni basate su x86 che quelle basate su x64. Tutte le edizioni di Windows Server 2008 R2 sono a 64 bit.
  • Non è possibile eseguire la migrazione dei ruoli nelle installazioni Server Core di Windows Server 2008 in quanto Windows Server 2008 Server Core non include .NET Framework.


Panoramica di Gestione risorse di sistema Windows

Con Gestione risorse di sistema Windows per il sistema operativo Windows Server® 2008 R2 è possibile gestire l'utilizzo del processore e della memoria del server mediante criteri delle risorse standard o personalizzati. La gestione delle risorse può garantire un'uguale disponibilità di tutti i servizi forniti da un singolo server oppure una costante disponibilità delle risorse per applicazioni, servizi o utenti ad alta priorità.

Gestione risorse di sistema Windows gestisce le risorse del processore solo quando il carico combinato del processore supera il 70%. Ciò significa che non limita attivamente le risorse utilizzabili da ogni utente quando il carico del processore è basso. In caso di conflitto per l'utilizzo delle risorse del processore, i criteri di allocazione risorse garantiscono una disponibilità minima delle risorse in base al profilo di gestione definito dall'utente.

Funzionalità di Gestione risorse di sistema Windows

Gestione risorse di sistema Windows consente di eseguire le operazioni seguenti:

  • Gestire risorse di sistema (processore e memoria) mediante criteri preconfigurati oppure creare criteri personalizzati che consentano di allocare le risorse per processo, utente, sessione di Servizi Desktop remoto o pool di applicazioni Internet Information Services (IIS).

  • Utilizzare regole di calendario per applicare criteri diversi in momenti diversi senza riconfigurazioni o interventi manuali.

  • Selezionare automaticamente criteri delle risorse in base a proprietà ed eventi del server, ad esempio eventi o condizioni relative ai cluster, oppure in base a modifiche della memoria fisica installata o del numero di processori.

  • Raccogliere dati sull'utilizzo delle risorse localmente o in un database SQL personalizzato. I dati sull'utilizzo delle risorse raccolti da più server possono essere consolidati in un unico computer che esegue Gestione risorse di sistema Windows.

  • Creare un gruppo di computer per migliorare l'organizzazione dei server desktop remoto che si desidera gestire. I criteri possono essere esportati o modificati in modo semplice per un intero gruppo di computer.

Vantaggi derivanti dalla gestione delle risorse

Poiché Windows Server 2008 R2 è progettato in modo da allocare il maggior numero di risorse possibile ad attività non correlate al sistema operativo, la gestione delle risorse non è in genere necessaria per un server con un singolo ruolo. Quando in un singolo server sono installati più servizi e applicazioni, questi ultimi non sono tuttavia in grado di riconoscere eventuali processi in conflitto. Un'applicazione o un servizio non gestito utilizza in genere tutte le risorse disponibili per completare un'attività. È pertanto importante utilizzare uno strumento quale Gestione risorse di sistema Windows per gestire le risorse di sistema in server multifunzione. L'utilizzo di Gestione risorse di sistema Windows offre due vantaggi principali:

  • È possibile eseguire più servizi in un singolo server poiché la disponibilità di ogni servizio può essere migliorata grazie alla gestione dinamica delle risorse.

  • Gli amministratori di sistema o gli utenti ad alta priorità possono accedere al sistema anche quando il carico delle risorse è massimo.

Modalità di gestione delle risorse

In Gestione risorse di sistema Windows sono disponibili cinque criteri di gestione risorse incorporati che possono essere utilizzati per implementare la gestione in modo rapido. È inoltre possibile creare criteri di gestione risorse personalizzati in base alle proprie esigenze.

Criteri di gestione risorse predefiniti

Per abilitare i criteri di gestione risorse predefiniti, selezionare il tipo di criterio da utilizzare. Non sono necessarie altre configurazioni.

Criterio Descrizione

Uguale per processo

Quando il sistema viene gestito in base al criterio di allocazione risorse Equal_Per_Process, ogni processo in esecuzione riceve lo stesso trattamento. Se ad esempio un server che esegue dieci processi raggiunge il 70% dell'utilizzo del processore, Gestione risorse di sistema Windows consentirà a ogni processo di utilizzare solo il 10% delle risorse del processore durante il conflitto. Si noti che le risorse non utilizzate dai processi con un basso utilizzo verranno allocate ad altri processi.

Uguale per utente

Quando il sistema viene gestito in base al criterio di allocazione risorse Equal_Per_User, i processi vengono raggruppati in base all'account utente da cui sono eseguiti e ogni gruppo di processi riceve lo stesso trattamento. Se ad esempio in un dato momento vi sono quattro utenti che eseguono processi nel server, a ogni utente verrà allocato il 25% delle risorse di sistema per il completamento di tali processi. Le risorse allocate saranno le stesse sia per un utente che esegue una singola applicazione che per un utente che esegue più applicazioni. Questo criterio risulta particolarmente utile per i server applicazioni.

Uguale per sessione

Quando il sistema viene gestito in base al criterio di allocazione risorse Equal_Per_Session, le risorse vengono allocate in modo uguale per ogni sessione connessa al sistema. Questo criterio è destinato all'utilizzo con server desktop remoti.

Uguale per pool di applicazioni di IIS

Quando il sistema viene gestito in base al criterio di allocazione risorse Equal_Per_IISAppPool, ogni pool di applicazioni IIS in esecuzione riceve lo stesso trattamento e le applicazioni non incluse in un pool di applicazioni IIS possono utilizzare solo le risorse non consumate dai pool di applicazioni IIS.

Sessioni remote ponderate

Quando il sistema viene gestito in base al criterio di allocazione risorse Weighted_Remote_Sessions, i processi vengono raggruppati secondo la priorità assegnata all'account utente. Se ad esempio vi sono tre utenti connessi in remoto, all'utente con priorità Premium verrà assegnato l'accesso con priorità più alta alla CPU, all'utente con priorità Standard verrà assegnato l'accesso con seconda priorità alla CPU e all'utente con priorità Di base verrà assegnato l'accesso con priorità più bassa alla CPU. Questo criterio è destinato all'utilizzo con server desktop remoti.

Nota

Quando Weighted_Remote_Sessions è impostato come criterio di gestione, la gestione del sistema viene delegata all'utilità di pianificazione di Windows Server 2008 R2 e Gestione risorse di sistema Windows si limita a definire il profilo del sistema. L'impostazione o la rimozione di Weighted_Remote_Sessions come criterio di gestione richiede un riavvio del computer imposto dal kernel.

Gestione personalizzata delle risorse

È possibile utilizzare metodi personalizzati di gestione delle risorse per identificare gli utenti delle risorse e allocare le risorse a tali utenti in base a criteri specifici.

Funzionalità Descrizione

Criteri di corrispondenza processo

Consentono di selezionare servizi o applicazioni da gestire in base alle regole dei criteri di allocazione risorse. È possibile selezionare le applicazioni o i servizi in base al nome di file o al comando oppure specificare utenti o gruppi. È ad esempio possibile creare un criterio di corrispondenza processo che applichi la gestione all'applicazione iexplore.exe quando viene eseguita dall'utente Administrator.

Criteri di allocazione risorse

Allocano risorse di memoria e processore ai processi specificati dai criteri di corrispondenza processo creati dall'utente.

Elenchi di esclusione

Escludono applicazioni, servizi, utenti o gruppi dalla gestione mediante Gestione risorse di sistema Windows.

Nota

In un criterio di allocazione risorse è inoltre possibile utilizzare la corrispondenza del percorso da riga di comando per escludere un'applicazione dalla gestione solo in base a tale criterio.

Pianificazione

Consente di utilizzare un'interfaccia di calendario per controllare eventi singoli o modifiche ricorrenti dell'allocazione delle risorse. È possibile attivare criteri di allocazione risorse diversi in momenti diversi del giorno, in giorni diversi della settimana oppure in base ad altri paradigmi di pianificazione.

Applicazione di criteri condizionali

Consentono di passare automaticamente da un criterio di allocazione risorse all'altro in seguito a determinati eventi di sistema, ad esempio l'installazione di nuova memoria o processori aggiuntivi, l'avvio o l'arresto di un nodo oppure la modifica della disponibilità di un gruppo di risorse in un cluster.

Ulteriori riferimenti

  • Per ulteriori informazioni su Gestione risorse di sistema Windows, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=90924.


Panoramica di IFilter TIFF di Windows

IFilter TIFF di Windows consente di cercare documenti TIFF (Tagged Image File Format) in base al contenuto del testo. IFilter TIFF di Windows supporta tutti i documenti TIFF conformi alle specifiche Adobe TIFF revisione 6.0, compresi i tipi di compressione più diffusi, ad esempio LZW, JPG, CCITT v4 e CCITT v6, oltre ai file non compressi.

Quando viene caricato, IFilter TIFF di Windows esegue l'elaborazione OCR (Optical Character Recognition) delle immagini TIFF e quindi fornisce il testo riconosciuto al programma chiamante per la generazione dell'indice di ricerca.

IFilter TIFF di Windows può essere utilizzato dal Servizio indicizzazione (per Desktop Search), Microsoft Office SharePoint Server 2007 o versioni successive, Microsoft SQL Server 2008 e Microsoft SQL Server 2005.

Considerazioni sui risultati delle ricerche

IFilter TIFF di Windows è progettato per i documenti basati su testo. La ricerca è quindi più efficace per i documenti che contengono testo chiaramente identificabile, ad esempio caratteri neri su sfondo bianco, e meno efficace per i documenti con contenuto misto, ad esempio caratteri artistici o testo all'interno di immagini. Inoltre, una scarsa qualità delle immagini e l'utilizzo di lingue diverse può influire negativamente sull'elaborazione OCR e quindi ridurre la qualità dei risultati delle ricerche.

Installare IFilter TIFF di Windows

Nota

La procedura seguente consente di eseguire l'installazione di IFilter TIFF di Windows ma non di attivare il Servizio indicizzazione. Per istruzioni sull'attivazione del Servizio indicizzazione in Windows Server 2008 R2, vedere la documentazione del Servizio indicizzazione. Se si utilizza IFilter TIFF di Windows con Microsoft SharePoint 2007 o versioni successive, Microsoft SQL Server 2008 o Microsoft SQL Server 2005, vedere la documentazione del prodotto per informazioni sulla distribuzione di IFilter TIFF di Windows.

Per installare IFilter TIFF di Windows in Windows 2008 R2

  1. Fare clic sul pulsante Start e quindi digitare Server Manager in Cerca programmi e file.

  2. In Programmi fare clic su Server Manager.

  3. Fare clic su Funzionalità e quindi su Aggiungi funzionalità.

  4. Selezionare IFilter TIFF di Windows e quindi fare clic su Avanti.

  5. Fare clic su Installa.


Panoramica del servizio LAN wireless

Il servizio LAN wireless è una funzionalità di questa versione di Windows Server® 2008 R2 e Windows Server® 2008 che è possibile utilizzare per attivare il servizio Configurazione automatica WLAN e configurarlo per l'avvio automatico. Dopo averlo attivato, il servizio Configurazione automatica WLAN selezionerà automaticamente la rete wireless alla quale verrà connesso automaticamente il computer e configurerà le impostazioni necessarie sulla schede di rete wireless. Sono incluse la selezione e la connessione automatica a una rete con preferenza superiore, se disponibile.

Servizio LAN wireless e servizio Configurazione automatica WLAN

Il servizio LAN wireless consente di configurare il servizio Configurazione automatica WLAN per l'avvio automatico, indipendentemente dalla presenza di schede wireless IEEE 802.11 nel computer. Quando è attivato, il servizio Configurazione automatica WLAN enumera ogni scheda di rete wireless nel computer, gestisce le connessioni wireless IEEE 802.11 e i profili delle connessioni wireless contenenti le impostazioni necessarie per configurare un client wireless per la connessione a una rete wireless. Il servizio Configurazione automatica WLAN consente di connettersi a una rete wireless esistente, modificare le impostazioni per la connessione alla rete wireless, configurare una connessione a una nuova rete wireless e specificare le reti wireless preferite. Consente inoltre di ricevere una notifica nel momento in cui sono disponibili nuove rete wireless. Quando si passa da una rete wireless all'altra, il servizio Configurazione automatica WLAN aggiorna dinamicamente le impostazioni della scheda di rete wireless per adattarle a quelle della nuova rete ed esegue un tentativo di connessione alla rete.

Se ci si sta connettendo a una rete wireless per la prima volta, il servizio Configurazione automatica WLAN configurerà le impostazioni di rete di base, se il servizio è attivato. Potrebbe tuttavia essere necessario configurare altre impostazioni, ad esempio il tipo di crittografia dei dati o la chiave di rete, nel caso in cui non vengano configurate automaticamente per l'account in uso tramite i Criteri reti wireless (IEEE 802.11) in Active Directory. Potrebbe inoltre essere necessario richiedere le autorizzazioni di account all'amministratore di rete.

Attivazione e avvio del servizio Configurazione automatica WLAN

È possibile attivare e avviare il servizio Configurazione automatica WLAN in modi diversi:

  • Aggiunta guidata funzionalità

    Consente di configurare il Servizio LAN wireless (WLAN) nell'Aggiunta guidata funzionalità di Windows Server 2008 R2 o Windows Server 2008.

  • Criteri reti wireless (IEEE 802.11)

    Consente di attivare l'impostazione Usa Servizio configurazione automatica WLAN di Windows per i client dei Criteri reti wireless (IEEE 802.11) di Windows Vista®. Nella scheda Generale delle proprietà dei Criteri reti wireless (IEEE 802.11) di Microsoft Windows Vista selezionare Usa Servizio configurazione automatica WLAN di Windows per i client.

    Questa impostazione consente agli amministratori di specificare che il servizio Configurazione automatica WLAN viene utilizzato per configurare e connettere i client wireless che eseguono Windows® 7, Microsoft Windows Vista, Windows Server 2008 R2 o Windows Server 2008 alla rete wireless.

  • Netsh WLAN set autoconfig

    Per eseguire i comandi Netsh WLAN nei computer che eseguono Windows Server 2008 R2 Windows Server 2008, è innanzitutto necessario installare il Servizio LAN wireless (WLAN).

    Utilizzare il comando netsh wlan set autoconfig con la sintassi seguente:

    set autoconfig enabled={yes|no} interface=InterfaceName

    È possibile utilizzare i comandi Netsh wlan per configurare il computer locale oppure per configurare più computer utilizzando uno script di accesso.

  • Snap-in Servizi di Microsoft Management Console

    Consente di passare al servizio Configurazione automatica WLAN per modificare le proprietà del servizio in base alle esigenze.

Differenze nei servizi wireless

In questa sezione vengono riepilogate le differenze tra il servizio di configurazione wireless nei computer che eseguono Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista e il servizio wireless nei computer che eseguono Windows Server 2003 e Windows XP:
Modifiche nel nome del servizio di configurazione automatica delle reti wireless

Windows Server 2003 e Windows XP | Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista
Nome del servizio di configurazione automatica delle reti wireless: Servizio Configurazione automatica reti senza fili | Nome del servizio di configurazione automatica delle reti wireless: Servizio Configurazione automatica WLAN (Wlansvc)

Dettagli sulla configurazione automatica delle reti wireless per reti wireless broadcast e non broadcast.

Nota

Nelle reti broadcast wireless il nome della rete wireless o l'identificatore del set di servizi (SSID) è incluso nei frame di beaconing inviati dal punto di accesso wireless. Nelle reti non broadcast il valore del frame di beaconing per il codice SSID è impostato su NULL.

Windows Server 2003 e Windows XP Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista

In Windows XP e Windows Server 2003 il servizio Configurazione automatica reti senza fili tenta di far corrispondere le reti wireless che stanno trasmettendo il proprio nome di rete con i profili delle reti wireless preferite configurate nel computer. Se non sono disponibili reti che corrispondono al profilo della rete wireless preferita, il servizio Configurazione automatica reti senza fili invierà richieste di probe per determinare se eventuali reti preferite nell'elenco ordinato siano reti non broadcast.

Il computer si connetterà pertanto alle reti broadcast prima che alle reti non broadcast, indipendentemente dal fatto che una rete non broadcast abbia un livello di priorità più alto nell'elenco delle reti preferite rispetto a una rete broadcast.

In aggiunta, i client wireless Windows XP e Windows Server 2003 annunciano i relativi elenchi di reti wireless preferite durante l'invio di richieste di probe.

In Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista è possibile configurare profili di configurazione di reti wireless come reti wireless broadcast o non broadcast.

Il servizio Configurazione automatica tenterà quindi di connettersi alle reti wireless in base al relativo livello di priorità nell'elenco delle reti preferite, indipendentemente dal fatto che siano reti broadcast o non broadcast.

Poiché le reti wireless sono esplicitamente contrassegnate come broadcast o non broadcast, i client wireless che eseguono Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista inviano richieste di probe solo per reti wireless non broadcast.

Modifiche al comportamento per reti wireless preferite non disponibili

Windows Server 2003 e Windows XP Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista

In Windows XP e Windows Server 2003 se non è possibile connettere una rete wireless preferita e il client wireless è configurato per impedire la connessione automatica alle reti wireless non incluse nell'elenco delle reti preferite (impostazione predefinita), il servizio di configurazione automatica delle reti wireless creerà un nome di rete wireless casuale e imposterà la scheda di rete wireless in modalità infrastruttura. La rete wireless non dispone tuttavia di una configurazione della sicurezza, rendendo in tal modo possibile a un utente malintenzionato di connettersi al client wireless utilizzando il nome di rete wireless casuale. Il nuovo aggiornamento del client wireless per Windows XP con Service Pack 2 modifica questo comportamento tramite la configurazione della scheda di rete wireless con un nome casuale e una configurazione della sicurezza costituita da una chiave di crittografia casuale a 128 bit e dal metodo di crittografia massima supportato dalla scheda di rete wireless. Questo nuovo comportamento consente di impedire la connessione al client wireless da parte di utenti malintenzionati utilizzando il nome di rete wireless casuale.

Per i computer che eseguono Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista in cui vengono utilizzati i driver wireless aggiornati progettati per Microsoft Windows Vista, il servizio Configurazione automatica WLAN wireless imposta la scheda di rete in una modalità di ascolto passiva per rimuovere la vulnerabilità che interessa i computer che eseguono Windows XP e Windows Server 2003. Mentre è attiva la modalità passiva, la scheda di rete wireless non invierà frame di richieste di probe per un nome di rete wireless casuale o qualsiasi altro nome. Gli utenti malintenzionati non hanno la possibilità di connettersi al client wireless.

Nota

La maggior parte dei driver di rete wireless è stata aggiornata per Microsoft Windows Vista. Se si utilizza un driver per scheda di rete wireless progettato per Windows XP in computer che eseguono Windows Server 2008 R2, Windows Server 2008, Windows 7 e Microsoft Windows Vista, tenere presente che il comportamento di questi computer corrisponde a quello dell'aggiornamento del client wireless per Windows XP con Service Pack 2, ovvero un nome di rete casuale con una configurazione della sicurezza.

Per ulteriori informazioni, vedere Accesso wireless autenticato 802.1X (http://go.microsoft.com/fwlink/?LinkID=93650).


Panoramica di XPS Viewer

Un documento XPS è un file salvato nel formato di file XML Paper Specification, o xps. È possibile creare documenti XPS (file con estensione XPS) utilizzando qualsiasi programma da cui è possibile stampare in Windows. È tuttavia possibile visualizzare documenti XPS solo utilizzando XPS Viewer, incluso in questa versione di Windows.

Che cos'è XPS Viewer?

Quando si fa clic su un documento XPS, questo viene aperto automaticamente in XPS Viewer. Per la visualizzazione e la gestione dei documenti XPS in XPS Viewer sono disponibili opzioni diverse, tra cui:

  • Salvataggio di una copia del documento XPS nel computer

  • Ricerca di una parola o di una frase all'interno del documento

  • Zoom avanti e zoom indietro per semplificare la lettura e la visualizzazione di testo e immagini

  • Firma digitale del documento XPS

  • Determinazione di quanto a lungo e a quali utenti sia concessa la visualizzazione del documento mediante l'applicazione di autorizzazioni per il documento

Per ulteriori informazioni sul formato dei documenti XPS, vedere la pagina relativa a XML Paper Specification (http://go.microsoft.com/fwlink/?LinkId=62045) nel sito Web Microsoft.

Utilizzare XPS Viewer

XPS Viewer è un programma utilizzabile per visualizzare documenti XPS ed eseguire ricerche, impostare autorizzazioni e applicare firme digitali nei documenti stessi. Per iniziare a utilizzare XPS Viewer, aprire un documento XPS. Nella tabella seguente vengono descritti i pulsanti delle barre degli strumenti disponibili in XPS Viewer.

Pulsanti delle barre degli strumenti di XPS Viewer

Pulsante Descrizione

File

Consente di aprire un documento XPS nel visualizzatore, salvare una copia di un documento o uscire dal visualizzatore. Consente inoltre di visualizzare informazioni sul documento, ad esempio l'autore o la data di creazione.

Autorizzazioni

Consente di impostare, modificare e visualizzare le autorizzazioni peri documenti. È inoltre possibile selezionare l'account da utilizzare per le autorizzazioni. Se l'utente è autore del documento, può impostare o modificare le autorizzazioni per il documento stesso. Se l'utente non è autore del documento, è necessario vedere le autorizzazioni disponibili per il documento.

Firme

Consente di utilizzare una firma digitale per il documento, richiedere firme da altri utenti e visualizzare le firme digitali già applicate al documento stesso.

Contenuti

Visualizza una struttura del documento nel riquadro dei contenuti.

Nota

Per alcuni documenti non sono disponibili strutture.

Stampa

Consente di stampare un documento XPS. Se per il documento sono impostate autorizzazioni, prima di tentare di stamparlo verificare di disporre delle autorizzazioni per la stampa.

Casella Trova

Consente di cercare una parola o una frase all'interno del documento. I risultati della ricerca vengono visualizzati nel riquadro dei contenuti.

Documenti XPS: domande frequenti

Di seguito vengono fornite le risposte ad alcune domande frequenti sui documenti XPS.

Che cos'è un documento XPS?

Un documento XPS (XML Paper Specification) è un documento in un formato che consente di visualizzare, salvare, condividere, firmare con firma digitale e proteggere il contenuto del documento stesso. Un documento XPS è analogo a un foglio di carta elettronico. Non è possibile modificare il contenuto di un foglio di carta dopo averlo stampato e non è possibile modificare il contenuto di un documento dopo che questo è stato salvato nel formato XPS. In questa versione di Windows, è possibile creare documenti XPS utilizzando qualsiasi programma da cui è possibile stampare. È tuttavia possibile visualizzare e firmare documenti XPS, nonché impostare le relative autorizzazioni, solo utilizzando XPS Viewer.

Come è possibile creare un documento XPS?

È possibile creare documenti XPS utilizzando qualsiasi programma da cui è possibile stampare, compreso l'intero sistema Microsoft Office. Per informazioni sulla creazione di documenti XPS in Microsoft Office, vedere la Guida di Microsoft Office e il sito Web Come fare a e cercare informazioni su come salvare un file in formato XPS.

Per creare un documento XPS in altri programmi, ad esempio Blocco note o WordPad

  1. Scegliere Stampa dal menu File.

  2. Nella finestra di dialogo Stampa selezionare Microsoft XPS Document Writer nell'elenco delle stampanti disponibili e quindi fare clic su Stampa.

  3. Nella finestra di dialogo Salva con nome assegnare un nome al documento XPS e quindi fare clic su Salva.

Come è possibile visualizzare un documento XPS?

È possibile creare un documento XPS in qualsiasi programma da cui è possibile stampare, ma è possibile visualizzare e firmare con firma digitale un documento XPS, nonché impostare le relative autorizzazioni, in XPS Viewer, incluso in Windows Server® 2008 R2.

Per visualizzare un documento XPS in XPS Viewer, fare doppio clic sul documento. Il visualizzatore verrà aperto automaticamente. Per ulteriori informazioni sulle barre degli strumenti e le funzionalità di XPS Viewer, vedere Utilizzare XPS Viewer.

Come è possibile verificare e proteggere un documento XPS?

Per verificare l'autenticità di un documento XPS è possibile utilizzare una firma digitale, mentre per proteggere il contenuto del documento è possibile impostare autorizzazioni.

La firma digitale ha due funzioni: garantisce che il documento XPS non è stato modificato dopo l'applicazione della firma e consente di verificare l'affidabilità dell'origine di un documento XPS di un altro autore prima di aprire il documento.

È inoltre possibile limitare le autorizzazioni per il documento XPS, per evitare che altri utenti possano visualizzare, copiare, stampare o firmare il documento con firma digitale senza l'autorizzazione dell'autore. È possibile impostare restrizioni di orario sulle autorizzazioni, concedere ad altri utenti il livello di autorizzazioni desiderato e assegnare a utenti diversi livelli di accesso diversi.