Guida di Gestione IIS (IIS 6.0)

Lo snap-in di MMC (Microsoft Management Console) Gestione IIS 6.0 è installato con IIS 7.0. È pertanto possibile gestire server Web IIS 6.0 da un server Web IIS 7.0. È inoltre necessario utilizzare Gestione IIS 6.0 per gestire siti FTP.

In questa sezione

Gestione di IIS 6.0 da Windows Vista

Configurazione di IIS per contenuti dinamici

Accesso a guide e risorse relative a IIS 6.0


Gestione di IIS 6.0 da Windows Vista

Quando si utilizza IIS 7, è comunque possibile gestire server Web remoti in cui è in esecuzione IIS 6.0 in Windows Server 2003. Lo snap-in di MCC Gestione IIS utilizzato in IIS 6.0 è disponibile in IIS 7. Per installare lo snap-in Gestione IIS, utilizzare la procedura seguente.

Procedura

Installare Gestione IIS

  1. Fare clic sul pulsante Start, quindi scegliere Pannello di controllo.

  2. Eseguire una delle operazioni seguenti:

    1. In Visualizzazione classica fare doppio clic su Installazione applicazioni.

    2. In visualizzazione Pagina iniziale Pannello di controllo fare clic su Aggiunta programma nella categoria Programmi.

  3. Nel riquadro sinistro della pagina Aggiunta programma fare clic su Opzioni avanzate, quindi su Funzionalità Windows.

  4. Nella finestra di dialogo Attiva o disattiva le funzionalità Windows espandere Server Web IISsuddiviso per componenti.

  5. Fare clic su Strumenti di gestione server Web, su Compatibilità gestione IIS 6, selezionare Console di gestione IIS 6, quindi scegliere OK.


Configurazione di IIS per contenuti dinamici

Quando lo si installa, IIS 6.0 è bloccato, ovvero è abilitata solo la gestione delle richieste di pagine Web statiche ed è installato solo il servizio Pubblicazione sul Web (servizio WWW). Per impostazione predefinita, funzionalità quali ASP, ASP.NET, eventi SSI (Server-Side Includes), Pubblicazioni WebDAV ed Estensioni del server di FrontPage® non funzionano a meno che non vengano abilitate. Se questa funzionalità non viene abilitata dopo l'installazione di IIS, verrà restituito un errore 404.

Nota

Se si installa il sistema di sviluppo Microsoft Visual Studio .NET 2003 con IIS 6.0 per ospitare applicazioni Web o servizi Web XML, è necessario abilitare ASP ed Estensioni del server di FrontPage.

È possibile configurare questi gestori di richieste, chiamati estensioni del servizio Web, impostando il nodo Estensioni servizio Web in Gestione IIS.

In questa sezione sono disponibili informazioni sui seguenti argomenti:

  • Abilitazione e disabilitazione dei contenuti dinamici in IIS 6.0: descrive come abilitare e disabilitare una singola estensione del servizio Web registrata nel nodo Estensioni servizio Web in Gestione IIS e inoltre come disabilitare contemporaneamente tutte le estensioni del servizio Web.

  • Aggiunta di un'estensione del servizio Web: descrive come registrare un'estensione del servizio Web in modo che venga visualizzata nel nodo Estensioni servizio Web in Gestione IIS.

  • Ridenominazione di un'estensione del servizio Web: descrive come rinominare un'estensione aggiunta all'elenco di estensioni del servizio Web in IIS.

  • Configurazione di un'applicazione per la chiamata di un'estensione del servizio Web: descrive come specificare le estensioni del servizio Web che possono essere chiamate da un'applicazione.


Abilitazione e disabilitazione dei contenuti dinamici in IIS 6.0

Se sono registrate nel nodo Estensioni servizio Web in Gestione IIS, le estensioni del servizio Web possono essere abilitate o disabilitate singolarmente. Se le funzionalità abilitate non sono più richieste, è possibile disabilitarle tramite il nodo Estensioni servizio Web in Gestione IIS.

Importante

Per eseguire la procedura o le procedure seguenti, è necessario appartenere al gruppo Administrators del computer locale. Per una sicurezza ottimale, accedere al computer tramite un account non appartenente al gruppo Administrators, quindi utilizzare il comando runas per eseguire Gestione IIS come amministratore. Al prompt dei comandi digitare runas /User:NomeAccount_amministrativo "mmc %systemroot%\system32\inetsrv\iis.msc".

Procedure

Per abilitare o disabilitare il contenuto dinamico

  1. In Gestione IIS espandere la struttura del computer locale, quindi fare clic su Estensioni servizio Web.

  2. Nel riquadro dei dettagli fare clic sull'estensione del servizio Web da abilitare o disabilitare.

  3. Eseguire una delle operazioni seguenti:

    • Per abilitare un'estensione del servizio Web disabilitata, fare clic su Consenti.

    • Per disabilitare un'estensione del servizio Web abilitata, fare clic su Non consentire.

    • Per visualizzare le proprietà di un'estensione del servizio Web, fare clic su Proprietà.

  4. Fare clic su OK.
Importante

Se si sceglie di consentire l'esecuzione di tutte le estensioni ISAPI o CGI sconosciute sul server Web, questo potrebbe diventare vulnerabile ai virus o ai worm che sfruttano tali tecnologie. È invece consigliabile selezionare solo le estensioni ISAPI o CGI che si ritiene necessario eseguire sul server Web.

È possibile disabilitare tutte le estensioni del servizio Web registrate nel computer locale mediante un'impostazione nel nodo Estensione servizio Web di Gestione IIS.

Per disabilitare tutte le estensioni del servizio Web

  1. In Gestione IIS espandere la struttura del computer locale, quindi fare clic su Estensioni servizio Web.

  2. Fare clic su Non consentire le estensioni del servizio Web. Viene visualizzato un messaggio di avviso.

  3. Per disabilitare tutte le estensioni, fare clic su Sì. Per annullare l'operazione, fare clic su No. Per visualizzare ulteriori informazioni, fare clic su ?.

  4. Se si fa clic su Sì, lo stato di ogni estensione del servizio Web viene disabilitato.


Aggiunta di un'estensione del servizio Web

Per consentire o negare l'utilizzo di un gestore di richieste HTTP non incluso nell'elenco delle estensioni del servizio Web, è innanzitutto necessario eseguirne la registrazione aggiungendolo a tale elenco.

Procedure

Per aggiungere una nuova estensione del servizio Web

  1. In Gestione IIS, espandere la struttura del computer e fare clic su Estensioni servizio Web.

  2. Nel riquadro dei dettagli fare clic su Aggiungi nuova estensione servizio Web.

  3. Nella casella Nome estensione digitare il nome della nuova estensione del servizio Web.

  4. Fare clic su Aggiungi.

  5. Nella casella Percorso del file digitare il percorso oppure fare clic su Sfoglia per individuare i file necessari per la nuova estensione del servizio Web, quindi fare clic su OK.

  6. Facoltativamente, selezionare la casella di controllo Imposta lo stato dell'estensione su Consentito per impostare automaticamente lo stato della nuova estensione del servizio Web su Consentito.

  7. Fare clic su OK.


Ridenominazione di un'estensione del servizio Web

È possibile rinominare un'estensione del servizio Web aggiunta a IIS. Le estensioni del servizio Web incluse in IIS non possono invece essere rinominate.

È possibile rinominare un'estensione del servizio Web utilizzando Gestione IIS oppure modificando direttamente il file MetaBase.xml. Con Gestione IIS, è innanzitutto necessario rimuovere l'estensione del servizio Web che si desidera rinominare e quindi aggiungerla utilizzando un nuovo nome. La ridenominazione di un'estensione del servizio Web mediante la modifica del file MetaBase.xml rappresenta un approccio più diretto. Di seguito vengono illustrati entrambi i metodi.

Importante

Per eseguire la procedura o le procedure seguenti, è necessario appartenere al gruppo Administrators del computer locale. Per una sicurezza ottimale, accedere al computer tramite un account non appartenente al gruppo Administrators, quindi utilizzare il comando runas per eseguire Gestione IIS come amministratore. Al prompt dei comandi digitare runas /User:NomeAccount_amministrativo "mmc %systemroot%\system32\inetsrv\iis.msc".

Procedure

Per rinominare un'estensione del servizio Web mediante Gestione IIS

  1. In Gestione IIS espandere la struttura del computer locale, quindi fare clic su Estensioni servizio Web.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sull'estensione del servizio Web che si desidera rinominare e quindi scegliere Elimina.

  3. Alla richiesta di conferma fare clic su Sì.

  4. Aggiungere l'estensione del servizio Web utilizzando il nuovo nome.
Per rinominare un'estensione del servizio Web mediante la modifica del file MetaBase.xml

  1. Assicurarsi che la funzionalità di modifica diretta della metabase sia abilitata.

  2. Aprire il file \Windows\System32\Inetsrv\MetaBase.xml con un editor di testo.

  3. Cercare il nome dell'estensione del servizio Web che si desidera rinominare e quindi modificare il nome.

  4. Salvare e chiudere il file MetaBase.xml.

  5. Per verificare la ridenominazione dell'estensione del servizio Web, in Gestione IIS fare clic con il pulsante destro del mouse sulla cartella Estensioni servizio Web e quindi scegliere Aggiorna.

    L'estensione del servizio Web verrà visualizzata con il nuovo nome nel riquadro dei dettagli.

Informazioni correlate

  • Per ulteriori informazioni sull'aggiunta di un'estensione del servizio Web, vedere Aggiunta di un'estensione del servizio Web.


Configurazione di un'applicazione per la chiamata di un'estensione del servizio Web

Per poter consentire a un'applicazione di chiamare un'estensione del servizio Web, è necessario configurare l'applicazione in modo appropriato. Un'estensione del servizio Web può accettare chiamate da più di un'applicazione.

Importante

Per eseguire la procedura o le procedure seguenti, è necessario appartenere al gruppo Administrators del computer locale. Per una sicurezza ottimale, accedere al computer tramite un account non appartenente al gruppo Administrators, quindi utilizzare il comando runas per eseguire Gestione IIS come amministratore. Al prompt dei comandi digitare runas /User:NomeAccount_amministrativo "mmc %systemroot%\system32\inetsrv\iis.msc".

Procedure

Per consentire a un'applicazione di chiamare un'estensione del servizio Web

  1. In Gestione IIS espandere la struttura del computer locale, quindi fare clic su Estensioni servizio Web.

  2. Fare clic su Consenti tutte le estensioni servizio Web per un'applicazione specifica.

  3. Dalla casella di riepilogo Applicazione selezionare il nome dell'applicazione. L'estensione del servizio Web che può essere chiamata dall'applicazione verrà visualizzata nella casella Estensioni da consentire.

  4. Fare clic su OK.


Accesso a guide e risorse relative a IIS 6.0

Le risorse seguenti consentono di ottenere ulteriori informazioni su IIS 6.0.

Panoramica tecnica su IIS 6.0

Questo documento include una panoramica tecnica di molte nuove funzionalità di IIS 6.0, ad esempio i pool di applicazioni e la modalità di isolamento processo di lavoro. Vengono inoltre descritti i miglioramenti di IIS 6.0 in materia di affidabilità, disponibilità, gestione, scalabilità e sicurezza di server Web. Per ulteriori informazioni, vedere IIS 6.0 Technical Overview (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Riepilogo delle modifiche al contenuto di IIS 6.0

In questo documento vengono elencate le modifiche apportate al contenuto della IIS 6.0 Deployment Guide, della IIS 6.0 Operations Guide e della IIS 6.0 Technical Reference dopo il relativo rilascio. Per ulteriori informazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Distribuzione di IIS 6.0

Informazioni contenenti istruzioni basate su attività e scenari che consentono di progettare una soluzione IIS 6.0 che risponda a esigenze specifiche. Tra gli scenari sono inclusi l'installazione di un nuovo server Web IIS 6.0, l'aggiornamento di un server Web esistente da una versione precedente di IIS e la migrazione di siti Web e applicazioni Apache o IIS esistenti in un nuovo server Web installato. Per ulteriori informazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Operazioni IIS 6.0

Informazioni su come eseguire attività di amministrazione comuni, configurare siti Web, amministrare server Web, configurare impostazioni relative a prestazioni e registrazione e risolvere i problemi relativi a IIS 6.0. Nel materiale di riferimento sono incluse descrizioni di proprietà della metabase, chiavi di registro, contatori di prestazioni ed eventi. Per ulteriori informazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Riferimento tecnico su IIS 6.0

Informazioni tecniche di riferimento estremamente dettagliate che consentono di eseguire e gestire in modo efficace un server in cui è in esecuzione IIS 6.0 e di risolverne i relativi problemi. Sono inclusi una descrizione completa dell'architettura di IIS 6.0 e informazioni pratiche e strumenti che consentono di eseguire le attività di amministrazione comuni. Per ulteriori informazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Area dedicata a IIS 6.0 del sito Web TechCenter

In questo sito Web sono disponibili collegamenti a numerose risorse e guide per la distribuzione, la gestione e il supporto di IIS. Per ulteriori informazioni, vedere l'area dedicata a IIS 6.0 del sito Web Microsoft Windows Server TechCenter.

UrlScan versione 2.5

Questo strumento di sicurezza limita i tipi di richieste HTTP elaborate da IIS. Tramite il blocco di richieste HTTP specifiche, UrlScan impedisce che il server venga raggiunto da richieste potenzialmente dannose. Per ulteriori informazioni, consultare la pagina relativa allo strumento di sicurezza UrlScan nel sito Web Microsoft Windows Server TechCenter.

Strumento di migrazione a IIS 6.0

Questo strumento da riga di comando consente di automatizzare diverse procedure necessarie per spostare un'applicazione Web da IIS 4.0, IIS 5.0 o IIS 6.0 in un'installazione pulita di IIS 6.0. Vengono trasferiti nel nuovo server IIS 6.0 i dati di configurazione, il contenuto dei siti Web e le impostazioni delle applicazioni. Per ulteriori informazioni, consultare la pagina relativa allo strumento di migrazione a IIS 6.0 nel sito Web Area download Microsoft.

IIS 6.0 Resource Kit Tools

Gli strumenti del Resource Kit di IIS 6.0 consentono di amministrare, proteggere e gestire IIS. Utilizzarli per eseguire ricerche in file di registro, distribuire certificati SSL (Secure Sockets Layer), utilizzare l'autenticazione del sito personalizzata, verificare le autorizzazioni, risolvere i problemi e altro ancora. Per ulteriori informazioni, vedere IIS 6.0 Resource Kit Tools (la pagina potrebbe essere in inglese) nell'Area download Microsoft.

IIS IT Pro Community su TechNet

Consente di comunicare con professionisti IT che utilizzano IIS. È possibile partecipare a gruppi di discussione, leggere le domande frequenti, entrare a far parte di un gruppo di utenti e ottenere la pianificazione aggiornata di trasmissioni webcast. Per ulteriori informazioni, vedere IIS Community Center (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

White paper

Distribuzione e configurazione di Internet Information Services (IIS) 6.0 con contenuto archiviato in remoto in server UNC e dispositivi NAS

In questo white paper viene illustrato come configurare e ottimizzare IIS 6.0 e un server remoto che funge da archivio centrale per file, applicazioni o altre risorse di rete rese disponibili a IIS tramite un percorso UNC (Universal Naming Convention). Per ulteriori informazioni, vedere Distribuzione e configurazione di Internet Information Services (IIS) 6.0 con contenuto archiviato in remoto in server UNC e dispositivi NAS (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Configurazione dell'isolamento delle applicazioni in Windows Server 2003 e Internet Information Services (IIS) 6.0

In questo white paper viene illustrato l'isolamento delle applicazioni in relazione ad applicazioni Web in esecuzione in server Web in cui è installato IIS 6.0 in modalità di isolamento processo di lavoro. Per ulteriori informazioni, vedere Configurazione dell'isolamento delle applicazioni in Windows Server 2003 e Internet Information Services (IIS) 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Download di IIS

La pagina Internet Information Services Downloads (la pagina potrebbe essere in inglese) offre collegamenti a strumenti e documenti che consentono di gestire e monitorare un server Web IIS 6.0.


IIS 6.0 F1: Guida dell'interfaccia utente di IIS 6.0

Il presente file fornisce una Guida sensibile al contesto per Internet Information Services (IIS) 6.0.

Per visualizzare la Guida, eseguire Gestione IIS, quindi fare clic su ? in qualunque pagina delle proprietà in IIS.

Argomenti correlati

Per visualizzare informazioni dettagliate su concetti e procedure relativi a IIS 6.0, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Connetti al computer

Questa finestra di dialogo consente di connettersi a un computer remoto digitando l'indirizzo IP, il nome del server se ci si trova nella stessa subnet, oppure il nome del dominio completo.

Per accedere come utente differente al computer di destinazione, digitare il nome utente e la password appropriati.

Nome del computer

Digitare il nome del computer a cui connettersi.

Sfoglia

Consente di cercare nella rete il nome del computer a cui connettersi.

Connetti come

Consente di connettersi a un altro computer utilizzando un nome specifico.

Argomenti correlati

Per ulteriori informazioni sull'amministrazione remota di IIS, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Backup o ripristino configurazione

Dopo aver stabilito la connessione al computer su cui si desidera eseguire il backup o il ripristino, utilizzare questa finestra di dialogo per salvare le impostazioni di configurazione per tutti i siti Web ed FTP, le directory e le directory virtuali e i file amministrati dal proprio computer. Innanzitutto è necessario connettersi al computer su cui si desidera eseguire il backup o il ripristino. La maggior parte delle impostazioni di configurazione viene memorizzata nella metabase, mentre altre sono memorizzate nel Registro di sistema. Questa utilità esegue il backup delle sole impostazioni di configurazione presenti nella metabase.

Backup precedenti

Nella casella di riepilogo Backup sono elencati tutti i backup della configurazione, i relativi numeri di versione e la data e l'ora di creazione. Quando si crea un file di backup, è necessario specificarne il nome.

Ripristino delle impostazioni di configurazione della metabase

Per ripristinare una configurazione precedente della metabase, scegliere una versione di backup, quindi fare clic su Ripristina. Tutti i servizi IIS verranno arrestati, le impostazioni di configurazione correnti verranno sovrascritte da quelle presenti nel file di backup, quindi verranno nuovamente avviati tutti i servizi IIS. La durata dell'operazione dipende dalle dimensioni della metabase.

Backup

Elenco di tutti i backup disponibili per il computer correntemente selezionato, che comprende il numero di versione (#) e la data e l'ora di creazione.

Crea backup

Per creare una versione di backup delle impostazioni di configurazione correnti della metabase, specificare un nome per il file di backup e fare clic.

Ripristina

Consente di sostituire le impostazioni di configurazione correnti della metabase con quelle della versione correntemente selezionata.

Elimina

Consente di eliminare il file di backup correntemente selezionato e rimuoverne il nome dall'elenco.

Argomenti correlati

Per ulteriori informazioni sul ruolo e la struttura della metabase e il ruolo del Registro di sistema, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Riavvio di IIS

Il riavvio o l'arresto di Internet Information Services (IIS), o il riavvio del server Web, sono operazioni critiche. Quando si riavviano i servizi Internet, tutte le sessioni connesse al server Web, incluse le sessioni Internet, FTP, SMTP e NNTP, vengono chiuse. Eventuali dati contenuti nelle applicazioni Web vengono perduti e tutti i siti Internet non sono più disponibili fino al riavvio dei servizi Internet. Per questo motivo, se possibile, è consigliabile evitare di riavviare o arrestare il server. IIS 6.0 include il riciclo del pool di applicazioni e altre funzionalità che forniscono soluzioni alternative al riavvio di IIS. Per un elenco delle funzionalità sviluppate per migliorare l'affidabilità di IIS ed evitarne il riavvio, vedere la sezione "Riavvio di IIS" nella Guida di IIS.

Nota

I servizi Internet includono i servizi Web, FTP, SMTP, NNTP e i servizi amministrativi IIS.

Scegliere l'operazione desiderata

Elenco di opzioni relative al riavvio di IIS; sono inoltre incluse una descrizione per ciascuna opzione e le possibili conseguenze.

Avvia i servizi Internet

Consente di avviare tutti i servizi Internet. Per modificare i servizi da avviare automaticamente, è possibile utilizzare il nodo Servizi dello snap-in Gestione computer. In caso di mancata risposta a tale comando da parte dei servizi Internet, riavviare il computer.

Interrompi i servizi Internet

Consente di interrompere tutti i servizi Internet. Tutte le sessioni connesse al server Web, inclusi i servizi FTP, SMTP e NNTP, vengono chiuse. Eventuali dati contenuti nelle applicazioni Web vengono perduti e tutti i siti Internet non sono più disponibili fino al riavvio dei servizi Internet. Alcune modifiche apportate a IIS richiedono l'arresto dei servizi Internet al fine di essere applicate, ad esempio quando si installa un nuovo componente COM o un filtro ISAPI.

Riavvia <computer locale>

Consente di riavviare il server. Il riavvio del server rappresenta un'operazione critica. Tutte le sessioni connesse al server Web, inclusi i servizi FTP, SMTP e NNTP, vengono chiuse. Eventuali dati contenuti nelle applicazioni Web vengono perduti e tutti i siti Internet sono disponibili solo dopo il riavvio del server e dei servizi Internet.

Riavvia i servizi Internet

Consente di interrompere e quindi riavviare tutti i servizi Internet. Tutte le sessioni connesse al server Web, inclusi i servizi FTP, SMTP e NNTP, vengono chiuse. Eventuali dati contenuti nelle applicazioni Web vengono perduti e tutti i siti Internet non sono più disponibili fino al riavvio dei servizi Internet.

Argomenti correlati

Per ulteriori informazioni sul riavvio di IIS, nonché per un elenco di funzionalità disponibili in IIS 6.0 che consentono di migliorare l'affidabilità e la disponibilità e pertanto ridurre l'esigenza di riavviare il server o il servizio Internet, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Internet Information Services

Le funzionalità riportate di seguito, quando abilitate, vengono applicate a tutti i servizi Internet. Affinché le modifiche abbiano effetto, è necessario riavviare i servizi Internet.

Abilita modifiche dirette della metabase

Questa funzionalità è nota anche come modifica diretta. Scegliere questa opzione per modificare i valori di proprietà della metabase mentre IIS è in esecuzione. Le modifiche vengono applicate immediatamente. Per apportare modifiche alla metabase, è possibile utilizzare strumenti standard per la modifica del testo, come Blocco note. Per abilitare e utilizzare questa funzionalità è necessario accedere come amministratore del computer su cui è in esecuzione IIS.

Nota

Per poter utilizzare la modifica diretta, è necessario che sia abilitata la funzionalità di cronologia della metabase. Per impostazione predefinita, questa funzionalità è abilitata.

Registrazione UTF-8

IIS 6.0 supporta la scrittura nei file registro per siti Web in formato UTF-8, oltre al formato ASCII o alla tabella codici locale. IIS 6.0 non supporta la registrazione UTF-8 per i siti FTP. Quando questa funzionalità è abilitata, tutti i siti Web sul server IIS utilizzeranno il formato UTF-8. Se non viene selezionato il formato UTF-8, la registrazione sarà effettuata nel set di caratteri della tabella codici locale.

Tipi MIME (livello globale)

I mapping MIME (Multipurpose Internet Mail Extensions) consentono di impostare i vari tipi di file trasferiti da IIS ai client. IIS trasferisce solo i file le cui estensioni sono registrate nell'elenco dei tipi MIME.

I tipi MIME possono essere definiti a livello globale per IIS. È inoltre possibile definire tipi MIME aggiuntivi a livello di sito Web, di directory e di directory virtuale di sito Web.

Nota

IIS 6.0 restituisce un errore (404.3) se una richiesta fa riferimento a un file la cui estensione non è inclusa nel mapping MIME o nel mapping di script. Per risolvere l'errore 404.3, è necessario aggiungere l'estensione di file richiesta al mapping MIME. fare clic su Tipi MIME nella finestra di dialogo per configurare i mapping MIME.

Tipi MIME

Consente di configurare i mapping MIME. Tramite questi mapping, è possibile impostare i vari tipi di file che il servizio Pubblicazione sul Web (servizio WWW) restituirà ai browser.

Argomenti correlati

Per ulteriori informazioni sui tipi MIME e la funzionalità di cronologia della metabase, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Messaggi di errore personalizzati

Questa scheda consente di personalizzare i messaggi di errore HTTP inviati ai client quando si verificano errori sul server Web. Gli amministratori possono utilizzare gli errori generici predefiniti HTTP 1.1 o file di errore personalizzati dettagliati forniti da IIS, oppure possono creare i propri file di errore personalizzati.

È possibile impostare questi valori globalmente per tutti i siti o separatamente all'interno di ciascun sito. IIS utilizza un modello di ereditarietà per queste impostazioni. Se si imposta o si modifica un'impostazione che è in conflitto con un'impostazione in un altro nodo della struttura gerarchica, verrà richiesto di specificare i nodi a cui applicare la nuova impostazione.

Modifica

Consente di modificare le proprietà del messaggio di errore personalizzato correntemente selezionato.

Impostazioni predefinite

Consente di configurare il messaggio di errore personalizzato correntemente selezionato in modo che utilizzi il messaggio di errore predefinito HTTP 1.1.

Nota

Per modificare le impostazioni per più errori contemporaneamente, selezionare gli errori HTTP tenendo premuto CTRL o MAIUSC.

Argomenti correlati

Per ulteriori informazioni sui messaggi di errore personalizzati, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Modifica proprietà errori personalizzati

Questa finestra consente di modificare i messaggi di errore personalizzati. Fare clic su un messaggio di errore personalizzato, quindi scegliere Modifica.

Per motivi di sicurezza e altri problemi relativi al sistema, alcuni errori non possono essere personalizzati in modo da puntare a un URL. L'errore 401;2 "Operazione non autorizzata: accesso non riuscito a causa della configurazione del server", ad esempio, non consente di associare un messaggio di errore personalizzato a un URL poiché, nel caso in cui esista una configurazione del server, potrebbe non essere possibile raggiungere l'URL contenente il file di errore personalizzato.

Tipo messaggio

Nella casella di riepilogo Tipo messaggio selezionare il tipo di messaggio, Predefinito, File o URL, che si desidera restituire al browser client.

Predefinito

Consente di restituire al browser client l'errore predefinito HTTP 1.1. L'opzione File consente di associare l'errore personalizzato a un file utilizzando un nome di file completo. L'opzione URL consente di associare l'errore personalizzato a un URL. Se il tipo di output è un URL, l'URL deve essere presente nel server locale. Scegliere OK per salvare le impostazioni.

File/URL

Individuare o digitare il percorso del file associato all'errore personalizzato.

Sfoglia

Consente di individuare la directory e il file.

Argomenti correlati

Per ulteriori informazioni sui messaggi di errore personalizzati, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Intestazioni HTTP

La scheda Intestazioni HTTP consente di impostare i valori che verranno restituiti al browser nell'intestazione delle pagine HTML. È inoltre possibile impostare le classificazioni del contenuto e definire i tipi MIME.

È possibile impostare questi valori globalmente per tutti i siti o separatamente all'interno di ciascun sito. Internet Information Services (IIS) utilizza un modello di ereditarietà per queste impostazioni. Se si imposta o si modifica un'impostazione che è in conflitto con un'impostazione in un altro nodo della struttura gerarchica, verrà richiesto di specificare i nodi a cui applicare la nuova impostazione.

Abilita scadenza contenuto

Selezionare la casella di controllo Abilita scadenza contenuto per includere informazioni relative alla scadenza per contenuti soggetti a scadenza, ad esempio offerte speciali o annunci di eventi. Il browser confronterà la data corrente con quella di scadenza per determinare se visualizzare una pagina memorizzata nella cache o richiedere una pagina aggiornata al server.

Immediata

Se si seleziona questa opzione, il contenuto scade immediatamente dopo essere stato visualizzato. Questa impostazione impone al browser di recuperare sempre il contenuto aggiornato dal server per le successive richieste.

Dopo

Questa opzione consente di impostare un periodo di tempo specifico alla cui scadenza il browser dovrà recuperare nuovamente il contenuto dal server per le successive richieste.

Scadenza

Scegliere questa opzione per impostare una data e un'ora specifiche alla cui scadenza il browser dovrà recuperare nuovamente il contenuto dal server per le successive richieste.

Intestazioni HTTP personalizzate

Consente di inviare un'intestazione HTTP personalizzata dal server Web al browser client. Le intestazioni personalizzate possono essere utilizzate per trasmettere dal server Web al browser client istruzioni non ancora supportate dalla specifica HTTP corrente, ad esempio intestazioni HTTP create dopo il rilascio di IIS. È possibile, ad esempio, utilizzare un'intestazione HTTP per consentire ai browser client, ma non ai server proxy, di memorizzare la pagina nella cache.

Aggiungi

Consente di aggiungere una nuova intestazione HTTP personalizzata.

Modifica

Consente di modificare le proprietà dell'intestazione HTTP personalizzata correntemente selezionata.

Rimuovi

Consente di rimuovere l'intestazione HTTP personalizzata correntemente selezionata.

Classificazioni del contenuto

Le restrizioni sul contenuto consentono di incorporare etichette descrittive nelle intestazioni HTTP delle pagine Web. Alcuni browser possono individuare tali classificazioni, consentendo agli utenti di identificare contenuto Web potenzialmente offensivo.

Modifica classificazioni

Consente di impostare i valori di classificazione del contenuto.

Tipi MIME (livello di sito, directory e directory virtuale)

I mapping MIME (Multipurpose Internet Mail Extensions) consentono di impostare i vari tipi di file trasferiti da IIS ai client. IIS trasferisce solo i file le cui estensioni sono registrate nell'elenco dei tipi MIME.

I tipi MIME possono essere definiti a livello globale per IIS. È inoltre possibile definire tipi MIME aggiuntivi a livello di sito Web, di directory e di directory virtuale di sito Web.

IIS utilizza un modello di ereditarietà per queste impostazioni. I tipi MIME definiti a livello globale vengono ereditati da tutti i siti Web, le directory e le directory virtuali di un sito Web. I tipi MIME definiti a livello di sito Web, di directory o directory virtuale di sito Web, sono utilizzati solo in quel determinato nodo. Se si imposta o modifica un tipo MIME che è in conflitto con un'impostazione in un altro nodo della struttura gerarchica, viene visualizzata la finestra di dialogo Proprietà ereditate ignorate, in cui è possibile specificare i nodi a cui applicare la nuova impostazione.

Nella casella di riepilogo Tipi MIME registrati (estensioni di file) sono elencati i tipi di file registrati installati nel computer in uso.

Nota

IIS 6.0 restituisce un errore (404.3) se una richiesta fa riferimento a un file la cui estensione non è inclusa nel mapping MIME o nel mapping di script. Per risolvere l'errore 404.3, è necessario aggiungere l'estensione di file richiesta al mapping MIME. Fare clic su Tipi MIME nella finestra di dialogo per configurare i mapping MIME.

Tipi MIME

Consente di configurare i mapping MIME. Tramite tali mapping è possibile impostare i diversi tipi di file restituiti ai browser dal servizio Web.

Nota

Quando si fa clic su un tipo MIME, i mapping MIME vengono elencati nella casella Tipi MIME.

Argomenti correlati

Per ulteriori informazioni sulla classificazione del contenuto e i tipi MIME, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Aggiunta/Modifica intestazioni HTTP personalizzate

Le intestazioni personalizzate vengono visualizzate nella scheda Intestazioni HTTP di una pagina delle proprietà nel formato Nome: Valore. Digitare il nome e il valore dell'intestazione HTTP personalizzata nelle caselle Nome intestazione personalizzata e Valore intestazione personalizzata.

Argomenti correlati

Per ulteriori informazioni sulla creazione di più siti Web utilizzando nomi di intestazione host, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Classificazioni del contenuto - Scheda Classificazioni

Questa scheda consente di configurare le funzionalità del server Web relative alla classificazione del contenuto per un sito Web, una directory o un file specifico.

Il sistema PICS (Platform for Internet Content Selection) del server Web utilizza un sistema di classificazione sviluppato da ICRA (Internet Content Rating Association) tramite il quale il contenuto viene valutato in base ai relativi livelli di violenza, nudo, sesso o linguaggio offensivo. Per ulteriori informazioni su ICRA, visitare il sito http://www.icra.org.

Abilita classificazioni per questo contenuto

Scegliere questa opzione per impostare nel sito Web i livelli di classificazione per ciascuna delle categorie elencate.

Categoria

Regolare il dispositivo di scorrimento Classificazione di ciascuna categoria sul livello appropriato in base al contenuto selezionato.

Indirizzo di posta elettronica dell'utente che ha impostato queste classificazioni per il contenuto selezionato

Nella casella di testo, digitare un indirizzo di posta elettronica per identificare l'utente che ha impostato le classificazioni per il contenuto selezionato.

Scadenza

Scegliere una data di scadenza per impostare la durata della classificazione. Dopo questa data, al contenuto non sarà associata alcuna classificazione.

Argomenti correlati

Per ulteriori informazioni sulla classificazione del contenuto, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Documenti

Questa scheda consente di definire la pagina Web predefinita del sito e di aggiungere un piè di pagina ai documenti del sito.

Abilita pagina contenuto predefinita

Quando si seleziona questa opzione, nel browser viene visualizzato il documento predefinito se nella richiesta del browser non è stato specificato un nome di documento. Il documento predefinito può essere la home page di una directory o una pagina d'indice contenente un elenco di directory di documenti del sito. È possibile che siano elencati più documenti in un ordine di ricerca dall'alto verso il basso. Tali file si trovano nella home directory del sito ed è possibile modificarne l'ordine utilizzando i pulsanti Sposta su e Sposta giù.

Selezionare la casella di controllo Abilita pagina contenuto predefinita per consentire al server Web di identificare un documento predefinito ogni volta che nella richiesta di un browser non è specificato un nome di documento.

Aggiungi

Consente di aggiungere altri documenti predefiniti che verranno visualizzati nell'ordine in cui compaiono nell'elenco. Il server, infatti, restituirà il primo documento trovato.

Rimuovi

Consente di rimuovere un documento predefinito dall'elenco senza eliminare il file.

Abilita piè di pagina documento

Selezionare la casella di controllo Abilita piè di pagina documento per configurare il server Web per l'aggiunta automatica di un piè di pagina a ogni documento restituito. Il file del piè di pagina non dovrebbe essere un documento HTML completo e deve includere solo i tag HTML necessari per formattare l'aspetto e la funzione del contenuto del piè di pagina.

Sfoglia

Consente di individuare e specificare il percorso completo e il nome del file del piè di pagina.

Argomenti correlati

Per ulteriori informazioni sui documenti predefiniti e l'aggiunta di un piè di pagina alle pagine Web, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Estensioni del server BITS

Il Servizio trasferimento intelligente in background (BITS, Background Intelligent Transfer Service), noto anche come servizio "a goccia", consente la gestione della coda e il trasferimento dei file in background. BITS regola le richieste dei file minimizzando l'utilizzo della larghezza di banda a vantaggio dell'utente finale. L'interazione di BITS con IIS migliora la qualità del servizio del server Web.

Consenti il trasferimento di dati in questa directory virtuale

Scegliere questa opzione per consentire il caricamento di dati dal client BITS nella directory virtuale. Se non viene selezionata, verrà negato l'accesso ai client BITS che tentano di effettuare un trasferimento. Tutte le autorizzazioni di script o di esecuzione relative a una directory virtuale abilitata al caricamento tramite BITS vengono disabilitate.

Usa impostazioni predefinite

Consente di utilizzare la configurazione predefinita per la directory virtuale. Se la directory è incorporata in un'altra directory virtuale che definisce una configurazione personalizzata, verrà utilizzata questa configurazione al posto di quella predefinita.

Personalizza impostazioni

Consente di utilizzare le informazioni di configurazione specificate in questa finestra delle proprietà. Non verrà utilizzata alcuna impostazione predefinita o ereditata.

Dimensione max file

Scegliere questa opzione per impostare la quantità massima di dati che è possibile trasferire in un singolo processo BITS. Se non viene selezionata, sarà possibile trasferire una quantità di dati illimitata.

Elimina processi incompleti dopo

Scegliere questa opzione per eliminare i processi di caricamento incompleti dopo il periodo di tempo specificato. Il timeout viene controllato ogni volta che si esegue l'elemento di lavoro MSTASK. Per configurare la frequenza con cui eseguire il controllo del timeout per questa directory virtuale, fare clic su Pianifica pulitura.

Abilita supporto server farm

Scegliere questa opzione per imporre a un client di riconnettersi utilizzando il nome specificato anziché quello utilizzato in precedenza. In questo modo, i client che caricano dati in un server farm possono continuare l'operazione nello stesso server con cui era iniziato il processo. Si consiglia di non effettuare il caricamento in Web farm se questa funzionalità non è stata abilitata e configurata.

Riconnetti all'indirizzo IP

Consente di specificare l'indirizzo IP pubblico da utilizzare per riconnettersi al server.

Utilizza indirizzo IP originario dopo

Dopo aver ricevuto un messaggio di errore, i client tenteranno ancora di riconnettersi al server utilizzando l'impostazione specificata in Riconnetti all'indirizzo IP fino allo scadere del timeout. Al termine del timeout specificato, i client torneranno a utilizzare il nome originale.

Consenti notifiche

Consente di abilitare le notifiche per la directory virtuale. Se questa opzione è selezionata, è necessario specificare anche le impostazioni Tipo notifica e URL notifica.

Tipo notifica

Consente di configurare il tipo di notifica da eseguire al termine del processo di caricamento.

  • Invia il nome file: il server invia il percorso del file caricato all'URL specificato nella casella URL notifica. Il server potrebbe restituire un file al client.

  • Invia i dati: il server invia l'intero file caricato all'URL specificato nella casella URL notifica come entità del metodo POST (Power-on Self Test). Al client verrà inviata l'entità di risposta.

URL notifica

Se il tipo di notifica è Invia i dati o Invia il nome file, questo URL indica il percorso in cui verrà inserito il file caricato. L'URL può essere assoluto o relativo. Se l'URL è relativo, verrà utilizzato come base l'URL della richiesta originale.

Pianifica pulitura

Consente di configurare la frequenza con la quale le estensioni BITS devono eseguire la scansione della directory virtuale per individuare eventuali file incompleti. Se viene rilevato un caricamento incompleto, il file verrà controllato in base al valore di timeout. Se nel periodo di timeout il caricamento del file non è avanzato, il processo verrà automaticamente annullato. Questa impostazione non è ereditaria e viene applicata solo a questa directory virtuale.

Esegui pulitura

Consente di avviare un controllo per individuare i processi di caricamento che non avanzano nel periodo di timeout. Per rimuovere tutti i file incompleti da questa directory virtuale, impostare il valore di timeout su 0 prima di eseguire la pulitura.


IIS 6.0 F1: Proprietà sito Web - Scheda Protezione directory

Questa scheda consente di impostare le funzionalità di sicurezza di IIS in modo da verificare l'identità degli utenti prima di autorizzare l'accesso a siti con restrizioni.

Controllo autenticazione e accesso

Questa impostazione consente di configurare il server Web in modo da verificare l'identità degli utenti prima di autorizzare l'accesso a siti con restrizioni. Prima che il server possa autenticare gli utenti, è tuttavia necessario creare account utente di Windows validi e configurare le autorizzazioni per i file e le directory NTFS degli account creati.

Modifica

Consente di configurare le funzionalità di autenticazione e accesso anonimo per il server Web.

Limitazioni sull'indirizzo IP e sul nome di dominio

Questa impostazione consente di concedere o negare a utenti, computer, gruppi di computer o domini specifici l'accesso al sito Web, alla directory o al file in base al nome di dominio o all'indirizzo IP.

Modifica

Consente di aggiungere impostazioni che limitano o negano a utenti, computer, gruppi di computer o domini specifici l'accesso al sito Web, alla directory o al file.

Comunicazioni protette

Per proteggere le comunicazioni tra il client e il server Web in Windows, vengono forniti certificati server e il mapping dei certificati. Per implementare la protezione delle comunicazioni, è possibile attivare il mapping del servizio directory Windows, che consente di utilizzare il mapping dei certificati client del servizio directory anziché il mapping uno a uno o molti a uno. Per abilitare questo servizio, è necessario che il server sia un membro del dominio Windows® Server 2003.

Abilita utilità di mapping servizio directory Windows

Selezionare questa opzione per utilizzare il mapping dei certificati client del servizio directory anziché il mapping uno a uno o molti a uno. Per abilitare questo servizio, è necessario che il server sia un membro del dominio Windows Server 2003. Questa opzione è disponibile solo quando si modificano le proprietà per tutti i siti Web.

Quando si modificano le proprietà per un sito Web specifico, sono disponibili le opzioni riportate di seguito.

Certificato server

Consente di avviare la Gestione guidata certificati server Web e ricevere un certificato server.

Visualizza certificato

Consente di visualizzare il certificato server per il sito Web, se ne esiste uno installato.

Modifica

Consente di abilitare le impostazioni di comunicazione, quali l'accettazione e il mapping dei certificati e l'elenco dei certificati attendibili.

Argomenti correlati

Per ulteriori informazioni sull'autenticazione utente in IIS, il controllo dell'accesso, i certificati in IIS e il mapping tra certificati client e account utente, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Metodi di autenticazione

Questa finestra di dialogo consente di configurare il server Web in modo da verificare l'identità degli utenti. Tramite l'autenticazione di singoli utenti o gruppi di utenti è possibile evitare che persone non autorizzate stabiliscano una connessione Web (HTTP) a siti con contenuti riservati. L'opzione Accesso anonimo consente agli utenti di stabilire una connessione anonima. L'utente accede a IIS con un account anonimo o guest. Per l'opzione Accesso con autenticazione sono attualmente disponibili quattro metodi:

  • Autenticazione integrata di Windows: utilizza uno scambio crittografico con il browser Web dell'utente per verificarne l'identità.

  • Autenticazione del digest: può essere utilizzato solo con account Active Directory® inviando tramite la rete un valore hash anziché una password non crittografata. Il metodo Autenticazione del digest può essere utilizzato anche in presenza di server proxy e altri firewall ed è disponibile per le directory WebDAV (Web Distributed Authoring and Versioning).

  • Autenticazione di base: trasmette password non crittografate tramite la rete.

Abilita accesso anonimo

Selezionare questa casella di controllo per stabilire una connessione anonima per gli utenti. IIS consentirà all'utente di accedere con un account anonimo o guest. Per impostazione predefinita, il server crea e utilizza l'account IUSR_nomecomputer.

Nome utente

È il nome utente per l'account utilizzato per l'accesso anonimo solo all'interno di Windows.

Password

È la password dell'account utente anonimo utilizzata solo all'interno di Windows. Gli utenti anonimi non devono specificare un nome utente e una password per effettuare l'accesso.

Sfoglia

Consente di cercare e scegliere il tipo di oggetto, quale l'utente, e la posizione, quale il computer in uso o un qualsiasi altro computer connesso in rete.

Accesso con autenticazione

Queste opzioni prevedono che gli utenti specifichino un nome utente e una password di Microsoft Windows validi per poter accedere alle informazioni presenti nel server.

Autenticazione integrata di Windows

Scegliere questa opzione per garantire che il nome utente e la password siano inviati attraverso la rete sotto forma di hash, fornendo così un sistema sicuro di autenticazione.

Nota

Se è attivo questo metodo di autenticazione, IIS utilizza l'autenticazione integrata di Windows solo quando l'accesso anonimo è disattivato e negato perché sono state impostate le autorizzazioni del file system di Windows, che richiedono agli utenti di fornire una password e un nome utente di Windows per potersi connettere a siti con restrizioni.

Autenticazione del digest per server di dominio Windows

Selezionare questa opzione per utilizzare Active Directory® e inviare tramite la rete un valore hash anziché una password non crittografata. Questo metodo è utile su server proxy e altri firewall. L'utilizzo dell'autenticazione del digest richiede la definizione di un'Area autenticazione.

Autenticazione di base (password non crittografata)

Scegliere questa opzione per inviare attraverso la rete una password non crittografata. L'autenticazione di base fa parte della specifica HTTP ed è supportata dalla maggior parte dei browser. Tuttavia, poiché il nome utente e la password non sono crittografati, questo metodo potrebbe comportare rischi in termini di sicurezza.

Dominio predefinito

Identifica il dominio di Windows utilizzato per il controllo dell'autenticazione dell'utente.

Seleziona

Per autenticare un utente o un gruppo, fare clic per visualizzare un elenco di tutti i domini a cui si è connessi.

Area autenticazione

Identifica il dominio o un altro controller di autenticazione del sistema operativo utilizzato per autenticare l'utente o il gruppo.

Seleziona

Consente di visualizzare un elenco di tutti i domini e le aree autenticazione a cui si è connessi.

Argomenti correlati


IIS 6.0 F1: Avviso relativo all'autenticazione di base

Questo avviso viene visualizzato quando si sceglie di utilizzare il metodo di autenticazione di base. Con l'autenticazione di base, il browser dell'utente trasmette i nomi utente e le password degli account di Windows attraverso la rete in testo non crittografato. Utenti malintenzionati possono quindi intercettare queste informazioni. È possibile utilizzare l'autenticazione di base e garantire comunque la protezione delle informazioni relative all'account utilizzando il protocollo SSL (Secure Sockets Layer). Per abilitare SSL, è necessario innanzitutto installare un certificato server.

Sì

Consente di implementare l'opzione di autenticazione selezionata e procedere con la configurazione della sicurezza.

No

Consente di annullare la selezione dell'opzione di autenticazione e tornare alla precedente finestra di dialogo.

Argomenti correlati

Per ulteriori informazioni sull'autenticazione utente, la crittografia e Secure Sockets Layer, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Avviso relativo all'autenticazione del digest

Il metodo di accesso con autenticazione Digest è disponibile solo per gli account di dominio nei server Microsoft® Windows® Server 2003 e richiede che gli account memorizzino le password utilizzando la crittografia reversibile. Internet Information Services (IIS) invia attraverso la rete un valore hash anziché la password, utilizzando server proxy e altri firewall.

Requisiti dell'autenticazione Digest

Prima di abilitare l'autenticazione Digest nel server su cui è in esecuzione IIS, verificare che vengano soddisfatti tutti i requisiti minimi indicati di seguito. La verifica dei requisiti dei controller di dominio può essere eseguita solo dagli amministratori del dominio. Contattare l'amministratore del dominio se non si è certi che il controller di dominio soddisfi i seguenti requisiti:

  • L'utente e il server in cui è in esecuzione IIS devono appartenere allo stesso dominio o essere ritenuti attendibili dallo stesso dominio.

  • Agli utenti deve essere assegnato un account utente di Windows valido, memorizzato in Active Directory® nel controller di dominio.

  • Nel dominio deve essere presente un controller di dominio Windows 2000 o versione successiva.

  • Il server IIS deve utilizzare un prodotto della famiglia Windows Server 2003 o versione successiva.

Sì

Consente di impostare il metodo di autenticazione in IIS su Autenticazione Digest.

No

Consente di interrompere l'operazione, tornare alla precedente finestra di dialogo ed effettuare un'altra selezione.

Argomenti correlati

Per ulteriori informazioni sull'autenticazione utente e l'autenticazione Digest, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Limitazioni sull'indirizzo IP e sul nome di dominio

Questa finestra di dialogo consente di concedere o negare agli utenti l'accesso a un sito Web, directory o file.

Nota

I computer che accedono al server tramite server proxy visualizzeranno lo stesso indirizzo IP del server proxy.

Limitazioni di accesso basate sull'indirizzo IP

consentito

Scegliere questa opzione per consentire l'accesso a tutti i computer.

Per aggiungere computer, gruppi di computer o domini a cui si desidera negare l'accesso, fare clic su Aggiungi, quindi immettere le informazioni richieste nella finestra di dialogo Nega accesso. I computer a cui è negato l'accesso verranno visualizzati nella casella di riepilogo ad eccezione dei seguenti.

negato

Scegliere questa opzione per negare l'accesso a tutti i computer.

Per aggiungere computer, gruppi di computer o domini a cui si desidera concedere l'accesso, fare clic su Aggiungi, quindi immettere le informazioni richieste nella finestra di dialogo Concedi accesso. I computer a cui è consentito l'accesso verranno visualizzati nella casella di riepilogo ad eccezione dei seguenti.

Aggiungi

Consente di definire un computer o un gruppo di computer a cui si desidera consentire o negare l'accesso.

Rimuovi

Consente di rimuovere l'elemento correntemente selezionato dall'elenco delle eccezioni.

Modifica

Consente di modificare le proprietà specifiche dell'elemento correntemente selezionato nell'elenco delle eccezioni.

Argomenti correlati

Per ulteriori informazioni sulla sicurezza, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Concedi accesso o Nega accesso

Queste due finestre di dialogo consentono di elencare i computer, i gruppi di computer o i domini a cui si desidera concedere o negare l'accesso alla risorsa.

Computer singolo

Consente di definire i diritti di accesso per un computer singolo.

Se si seleziona un singolo computer, sarà necessario conoscerne l'indirizzo IP.

Indirizzo IP

Digitare l'indirizzo IP (Internet Protocol) del computer.

Ricerca DNS

Consente di cercare l'indirizzo IP di un computer specifico utilizzando il nome di dominio, ad esempio www.contoso.com. Nella finestra di dialogo Ricerca DNS digitare il nome DNS del computer nella casella Digitare il nome DNS, quindi scegliere OK.

È possibile configurare IIS per eseguire una ricerca DNS ogni volta che viene richiesto l'accesso al sito, alla directory virtuale o al file. L'utilizzo della ricerca DNS ogni volta che viene fatta una richiesta può tuttavia influire sulle prestazioni del server.

Nota

Se viene visualizzato il messaggio di errore "Host non trovato", il nome del dominio specificato potrebbe non essere corretto oppure il computer a cui si fa riferimento potrebbe non essere disponibile nella rete.

Gruppi di computer

Consente di definire i diritti di accesso per un gruppo di computer in base all'ID rete e alla subnet mask.

Quando si concede o si nega l'accesso a gruppi di computer, verrà chiesto di identificarli tramite l'ID rete e la subnet mask. Una subnet mask, o maschera di indirizzo, è un indirizzo numerico di una subnet che include la rete. La maschera copre praticamente tutto tranne la parte significativa dell'indirizzo di rete. Contattare l'amministratore della rete per informazioni sulle reti TCP/IP, l'indirizzamento IP e l'utilizzo di subnet mask.

ID rete

Identifica l'indirizzo numerico della rete a cui appartiene il gruppo di computer.

Subnet mask

Identifica la mask indirizzo che sostituisce tutto tranne i numeri non significativi dell'ID rete, al fine di rendere univoco l'indirizzo subnet.

Argomenti correlati

Per ulteriori informazioni sulla sicurezza e l'autenticazione FTP, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Directory

Questa scheda consente di configurare la directory. È possibile configurare la posizione fisica impostando le autorizzazioni di accesso dell'utente, scegliendo se registrare le richieste per le risorse in questa posizione e se indicizzare un sito utilizzando Servizio indicizzazione. Per soddisfare la richiesta quando viene ricevuta, è necessario identificare e individuare le applicazioni e assegnare loro le autorizzazioni di esecuzione e la protezione appropriate.

Provenienza del contenuto della risorsa

Una directory nel proprio computer

Scegliere questa opzione per consentire agli utenti di accedere a una determinata directory sul computer per visualizzare o aggiornare il contenuto Web. È possibile controllare l'accesso al contenuto implementando un qualsiasi metodo di sicurezza di Windows.

Reindirizzamento a un URL

Consente di reindirizzare l'applicazione client, quale un browser, a un altro sito Web o a una directory virtuale. Quando questa opzione è selezionata, le opzioni relative al reindirizzamento vengono sostituite con quelle relative al percorso.

L'impostazione di percorsi locali o di rete consente di indirizzare la richiesta alla posizione fisica corretta. È possibile configurare ulteriormente la posizione fisica impostando le proprietà di accesso dell'utente e scegliendo se registrare le richieste per queste risorse e se indicizzare un sito utilizzando Servizio indicizzazione. Per soddisfare la richiesta nel momento in cui viene ricevuta, è necessario identificare e individuare le applicazioni e assegnare loro le autorizzazioni di esecuzione e la protezione appropriate.

Nota

Il Servizio di indicizzazione può essere attivato tramite Installazione applicazioni nel Pannello di controllo.

Percorso locale

Digitare o scegliere il percorso della directory in cui vengono memorizzati i file del sito Web predefinito. Per impostazione predefinita, questi file sono memorizzati nella directory systemdrive\inetpub\wwwroot per il sito Web predefinito.

Accesso origine script

Scegliere questa opzione per consentire agli utenti di accedere al codice sorgente se è impostata l'autorizzazione Accesso in lettura o Accesso in scrittura. Il codice sorgente include anche gli script di applicazioni ASP.

Lettura

Scegliere questa opzione per consentire agli utenti di leggere o scaricare file o directory e le rispettive proprietà.

Scrittura

Scegliere questa opzione per consentire agli utenti di caricare i file e le rispettive proprietà nella directory abilitata sul server oppure modificare il contenuto in un file abilitato per la scrittura. L'accesso in scrittura è consentito solo con i browser che supportano la funzionalità PUT dello standard del protocollo HTTP 1.1.

Esplorazione cartelle

Scegliere questa opzione per consentire agli utenti di visualizzare un elenco ipertestuale dei file e delle sottodirectory contenuti nella directory virtuale. Dato che l'elenco non include le directory virtuali, gli utenti ne devono conoscere l'alias. Se la funzionalità Esplorazione cartelle è disabilitata e l'utente non ha specificato un nome file, nel browser Web dell'utente verrà visualizzato il messaggio di errore "Accesso non autorizzato".

Registra visite

Consente di configurare IIS per registrare le visite alla directory in un file di registro. Le visite vengono registrate soltanto se per il sito Web è abilitata la registrazione.

Indicizza questa risorsa

Consente a Servizio indicizzazione Microsoft di includere la directory in un indice full-text del sito Web.

Nota: prima di impostare questa opzione, è necessario attivare il Servizio di indicizzazione tramite Installazione applicazioni nel Pannello di controllo.

Impostazioni applicazione:

Nome applicazione

Digitare il nome della directory radice in cui sono contenuti i file e le sottodirectory di un'applicazione.

Punto di partenza

Visualizza il nodo della metabase in cui è configurata l'applicazione.

Autorizzazioni di esecuzione

Mediante questa opzione si determina il livello di esecuzione del programma consentito per le risorse di questo sito.

  • Impostare le autorizzazioni su Nessuno per limitare l'accesso a file statici, quali file HTML o di immagine.

  • Impostare le autorizzazioni su Script per consentire l'esecuzione solo di script, non di file eseguibili.

  • Impostare le autorizzazioni su Script e file eseguibili per rimuovere tutte le restrizioni in modo che sia possibile accedere a tutti i tipi di file ed eseguirli.

Pool di applicazioni

Scegliere il pool di applicazioni associato alla home directory.

Sfoglia

Consente di individuare il percorso della directory.

Rimuovi

Consente di rimuovere l'applicazione dal sito Web lasciando intatta la directory virtuale.

Configurazione

Consente di configurare i mapping, le opzioni e le funzionalità di debug dell'applicazione.

Scaricamento

Consente di scaricare dalla memoria un'applicazione isolata o appartenente a un pool a cui nessun'altra applicazione fa riferimento.

Argomenti correlati

Per ulteriori informazioni sulla registrazione dell'attività di un sito e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Configurazione applicazioni - Scheda Mapping

Questa scheda consente di associare le estensioni dei nomi di file al programma o all'interprete che deve elaborare i file. Le applicazioni associate includono le applicazioni ASP (Active Server Pages), le applicazioni IDC (Internet Database Connector) e i file che utilizzano istruzioni di inclusione sul lato server. Quando ad esempio il server Web riceve una richiesta per una pagina con estensione asp, ricorre al mapping delle applicazioni per stabilire che per elaborare la pagina è necessario richiamare il file eseguibile asp.dll. È inoltre possibile utilizzare questa scheda per installare applicazioni ISAPI per il mapping di script jolly eseguite per ogni richiesta, indipendentemente dall'estensione del file.

Inserisci nella cache le estensioni ISAPI

Le DLL API di Internet Server (ISAPI) possono essere caricate e memorizzate nella cache in modo che le successive richieste possano essere elaborate senza dover chiamare nuovamente l'applicazione. La maggior parte delle applicazioni ISAPI, tra cui le pagine ASP, trae vantaggio dall'inserimento nella memoria cache. Si consiglia pertanto di deselezionare questa casella di controllo solo in circostanze particolari, ad esempio per eseguire il debug delle applicazioni ISAPI. Se una stessa applicazione ISAPI è stata caricata e memorizzata nella cache da più siti Web del server, l'applicazione verrà conservata in memoria anche quando questa opzione è deselezionata. Sarà necessario deselezionare l'opzione per tutti i siti Web che utilizzano l'applicazione ISAPI. Le applicazioni in esecuzione non vengono scaricate, ma le successive richieste non verranno inserite nella cache.

Estensioni applicazioni

È possibile sviluppare applicazioni Web utilizzando vari tipi di linguaggi di programmazione e per la creazione di script. Per individuare il programma ISAPI o CGI adeguato per l'elaborazione delle richieste ricevute, Internet Information Services (IIS) si basa sull'estensione dei file delle risorse del sito Web richieste. Se, ad esempio, viene richiesto un file con estensione asp, per l'elaborazione della richiesta nel server Web verrà richiamato il programma ASP (Asp.dll). La creazione di un'associazione tra un'estensione di file e un programma ISAPI o CGI è denominata mapping dell'applicazione. Per impostazione predefinita IIS supporta i mapping delle applicazioni comuni. È tuttavia possibile aggiungere o rimuovere i mapping relativi a tutte le applicazioni disponibili in un sito Web oppure a singole applicazioni.

Nella tabella Estensioni applicazioni sono incluse le estensioni di file associate ai file eseguibili e i percorsi dei file eseguibili. Se nella colonna Verbi viene visualizzato "TUTTI", all'applicazione verranno inviati tutti i verbi. Fare clic sui pulsanti Aggiungi, Modifica o Rimuovi per modificare i mapping delle applicazioni.

Importante

Nella colonna Esclusioni nella scheda Mapping applicazioni di IIS 4.0 è incluso un elenco di verbi. Questa colonna è stata sostituita dalla colonna Verbi, nella quale sono elencati i verbi HTTP eseguiti dall'applicazione.

Questa opzione consente di configurare il server Web per caricare e inserire nella cache le estensioni ISAPI in modo che le successive richieste possano essere elaborate senza dover chiamare nuovamente l'applicazione. La maggior parte delle applicazioni ISAPI, tra cui le pagine ASP, trae vantaggio dall'inserimento nella memoria cache.

Aggiungi

Consente di aggiungere un mapping di applicazione identificando l'estensione del nome di file, il percorso file eseguibile e i verbi HTTP.

Modifica

Consente di modificare un mapping di applicazione modificando l'estensione del nome di file, il percorso file eseguibile e i verbi HTTP.

Rimuovi

Consente di rimuovere un mapping di applicazione da IIS.

Mapping applicazioni jolly

Nella tabella sono elencate le applicazioni ISAPI che vengono eseguite prima che venga elaborato un file Web, indipendentemente dall'estensione del nome di file. Queste applicazioni ISAPI sono denominate mapping di script jolly. L'utilizzo dei mapping di script jolly è simile a quello dei filtri ISAPI, con l'eccezione che i mapping di script jolly possono essere installati sia su directory virtuali sia su siti Web, hanno accesso al corpo di una richiesta, non sono basati su eventi e l'API dell'estensione ISAPI ha maggiore funzionalità rispetto all'API del filtro ISAPI. Una directory virtuale eredita mapping di script jolly dalla directory virtuale padre o dal sito Web solo se non contiene mapping di script jolly propri.

Inserisci

Consente di aggiungere un mapping di script jolly che verrà eseguito a ogni richiesta a un file Web nel sito Web o nella directory virtuale.

Modifica

Consente di modificare il mapping di script jolly selezionato nella tabella Mapping applicazioni jolly.

Rimuovi

Consente di rimuovere il mapping di script jolly selezionato nella tabella Mapping applicazioni jolly.

Sposta su

Consente di spostare il mapping di script jolly selezionato in una posizione superiore nell'ordine di esecuzione nella tabella Mapping applicazioni jolly.

Sposta giù

Consente di spostare il mapping di script jolly selezionato in una posizione inferiore nell'ordine di esecuzione nella tabella Mapping applicazioni jolly.

Argomenti correlati

Per ulteriori informazioni sulla configurazione di applicazioni e i mapping di applicazioni jolly, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Aggiunta/Modifica mapping estensioni applicazioni (per Estensioni applicazioni)

Questa finestra di dialogo consente di aggiungere o modificare il mapping tra un'estensione di nome di file e il programma o l'interprete di elaborazione dei file. Eseguibile è il nome del file con estensione exe o dll che si desidera eseguire. Il file eseguibile deve essere presente nel disco rigido locale del server Web. Estensione è l'estensione di file associata all'applicazione. Se non si desidera che vengano passati tutti i verbi HTTP alle applicazioni tramite questi mapping, è possibile impostare restrizioni adeguate. Per impostazione predefinita, ad esempio, il file Asp.dll elabora le richieste utilizzando i verbi HTTP GET, HEAD e POST. Le richieste effettuate tramite il metodo TRACE sono gestite da IIS. Per attivare tutti i verbi, selezionare il pulsante di opzione Tutti i verbi. I vari nomi dei verbi o dei metodi devono essere separati da una virgola (,).

Eseguibile

Digitare il nome del file eseguibile (EXE o DLL). Il file eseguibile deve essere presente nel disco rigido locale del server Web.

Sfoglia

Consente di cercare nel disco rigido locale del server Web il file eseguibile (EXE o DLL).

Estensione

Digitare l'estensione di file associata all'applicazione.

Verbi

Consente di limitare il numero di verbi HTTP che possono essere associati a ciascuna estensione di applicazione.

Sono disponibili due opzioni:

  • Tutti i verbi.

  • Limite di. Questa opzione limita l'applicazione a uno o più verbi, a seconda del numero specificato.

Modulo script

Scegliere questa opzione se si desidera che l'applicazione venga eseguita in una directory senza autorizzazioni di esecuzione. Questa impostazione è utilizzata principalmente per applicazioni basate su script, quali ASP e IDC, per le quali è stato eseguito il mapping a un interprete. Per eseguire un'applicazione basata su mapping di script, è necessario selezionare Solo script o Script e file eseguibili nella casella di riepilogo Autorizzazioni di esecuzione nella scheda Directory relativa alla directory contenente l'applicazione.

  • Per consentire solo l'esecuzione di applicazioni basate su mapping di script, fare clic sull'opzione di accesso Solo script.

  • Per consentire l'esecuzione sia di applicazioni basate su mapping di script che di file eseguibili (con estensioni exe e dll), fare clic sull'opzione di accesso Script e file eseguibili.

Verifica esistenza del file

Questa opzione indica al server Web di verificare l'esistenza del file di script richiesto e accertarsi che l'utente richiedente abbia l'autorizzazione di accesso per tale file. Se lo script non esiste o l'utente non ha la necessaria autorizzazione, nel browser verrà visualizzato un apposito messaggio di avviso e il modulo di script non verrà richiamato. Questa opzione potrebbe risultare utile per i mapping di script a eseguibili diversi da CGI, quale l'interprete Perl, i quali non inviano una risposta CGI quando gli script non sono accessibili. Poiché uno script viene aperto due volte, prima dal server e quindi dal modulo di gestione di script, la scelta di questa opzione può comportare una riduzione delle prestazioni.

Argomenti correlati

Per ulteriori informazioni sulla configurazione delle applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Aggiunta/Modifica mapping estensioni applicazioni (per Mapping applicazioni jolly)

Questa finestra di dialogo consente di aggiungere o modificare applicazioni ISAPI per mapping di script jolly che verranno eseguite a ogni richiesta, indipendentemente dall'estensione del file. L'utilizzo dei mapping di script jolly è simile a quello dei filtri ISAPI, con l'eccezione che i mapping di script jolly possono essere installati sia su directory virtuali sia su siti Web, hanno accesso al corpo di una richiesta, non sono basati su eventi e l'API dell'estensione ISAPI ha maggiore funzionalità rispetto all'API del filtro ISAPI. Una directory virtuale eredita mapping di script jolly dalla directory virtuale o dal sito Web padre solo se non contiene mapping di script jolly propri.

Eseguibile

Digitare il nome del file eseguibile (EXE o DLL). Il file eseguibile deve essere presente nel disco rigido locale del server Web.

Sfoglia

Consente di cercare nel disco rigido locale del server Web l'applicazione ISAPI.

Verifica esistenza del file

Selezionare Verifica esistenza del file per indicare al server Web di verificare l'esistenza del file di script richiesto e accertarsi che l'utente richiedente disponga dell'autorizzazione di accesso per tale file. Se lo script non esiste o l'utente non ha la necessaria autorizzazione, nel browser verrà visualizzato un apposito messaggio di avviso e il modulo di script non verrà richiamato. Questa opzione potrebbe risultare utile per i mapping di script a eseguibili diversi da CGI, quale l'interprete Perl, i quali non inviano una risposta CGI quando gli script non sono accessibili. Poiché uno script viene aperto due volte, prima dal server e quindi dal modulo di gestione di script, la scelta di questa opzione può comportare una riduzione delle prestazioni.

Argomenti correlati

Per ulteriori informazioni sulla configurazione di applicazioni e i mapping di applicazioni jolly, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Configurazione applicazioni - Scheda Opzioni

Questa scheda consente di controllare la modalità di esecuzione delle pagine ASP all'interno dell'applicazione correntemente selezionata. Le applicazioni eseguite in Internet Information Services (IIS) possono essere configurate per ottenere maggiore efficienza abilitando lo stato e il timeout della sessione, il buffering, i percorsi principali, la lingua e il timeout di script ASP.

Nota

È possibile impostare le proprietà di configurazione delle applicazioni a livello di directory, di directory virtuale o di sito Web.

Abilita stato sessione

Scegliere questa opzione per abilitare lo stato della sessione.

Quando lo stato della sessione è abilitato, viene creata una sessione Active Server Pages (ASP) per ciascun utente che accede a un'applicazione ASP, in modo che l'utente possa essere identificato in tutte le pagine dell'applicazione. Quando invece lo stato della sessione è disabilitato, la sessione ASP non tiene traccia degli utenti e gli script ASP non possono memorizzare informazioni nell'oggetto Session né utilizzare l'evento Session_OnStart o Session_OnEnd. Se allo scadere dell'intervallo massimo previsto l'utente non ha richiesto o aggiornato una pagina di un'applicazione, la sessione verrà automaticamente terminata.

Timeout sessione

Impostare il periodo di timeout per tutte le sessioni inattive nel sistema.

Il timeout della sessione controlla la durata della sessione dell'utente o, più precisamente, controlla la durata dell'oggetto Session. Tramite uno script è possibile interrompere una sessione in modo esplicito utilizzando il metodo Session.Abandon. Lo stato della sessione può essere disabilitato per una singola pagina ASP tramite l'istruzione <%@ ENABLESESSIONSTATE = False %>, anche se per l'applicazione è abilitato.

Abilita buffer

Quando questa opzione è selezionata, l'output generato da una pagina ASP viene raccolto prima di essere inviato al browser. Quando la pagina viene visualizzata nel browser, il contenuto è interamente recuperato. La memorizzazione dell'output nel buffer consente di impostare le intestazioni HTTP in qualsiasi punto di uno script ASP.

Quando questa casella di controllo è deselezionata, l'output viene invece restituito al browser durante l'elaborazione della pagina, fornendo così un'immagine della stessa a mano a mano che si completa. È possibile ignorare questa opzione in uno script utilizzando il metodo Response.Buffer negli script ASP.

Abilita percorsi principali

Consente alle pagine ASP di utilizzare percorsi relativi per la directory padre della directory corrente (vale a dire percorsi che utilizzano la sintassi ..).

Quando questa opzione è selezionata, si consiglia di non concedere l'accesso in esecuzione alle directory padre per evitare che uno script esegua un programma non autorizzato in una di queste directory.

Linguaggio ASP predefinito

Consente di specificare il linguaggio di script principale per le pagine ASP, ovvero il linguaggio utilizzato per elaborare i comandi all'interno di delimitatori ASP (<% e %>).

ASP viene fornito con due moduli di script Microsoft® ActiveX®: Microsoft Visual Basic® Scripting Edition (VBScript) e Microsoft Jscript® (JScript). L'impostazione iniziale della casella Linguaggio ASP predefinito è VBScript. È tuttavia possibile impostare il nome di qualsiasi linguaggio per cui è disponibile un modulo di script ActiveX installato nel server. In questo caso è necessario specificare la parola chiave esatta richiesta dal modulo di script e indicata dal fornitore del modulo. È possibile ignorare il linguaggio predefinito in una singola pagina ASP utilizzando l'istruzione <%@ LANGUAGE %>.

Timeout script ASP

Consente di specificare la durata massima per l'esecuzione di uno script. Il periodo di timeout può essere impostato su un valore compreso tra 1 e 2147483647.

Se l'esecuzione dello script non viene ultimata entro il periodo di tempo specificato, lo script verrà interrotto da ASP e verrà scritto un evento nel registro eventi di Windows. È possibile ignorare questa opzione in una singola pagina ASP utilizzando il metodo Server.ScriptTimeout.

Abilita assembly side-by-side

Gli assembly side-by-side (SxS) consentono alle applicazioni ASP di specificare quale versione di una DLL di sistema o di un componente COM classico utilizzare, ad esempio MDAC, MFS, MSVCRT, MSXML e così via. Se, ad esempio, l'applicazione ASP si basa su MSXML versione 2.0, è possibile fare in modo che l'applicazione utilizzi comunque la versione 2.0 di MSXML anche dopo l'applicazione di Service Pack al server. Le eventuali nuove versioni di MSXML rimangono installate nel computer, ma l'applicazione continuerà a utilizzare la versione 2.0. Per configurare gli assembly SxS, è necessario conoscere il percorso della DLL e verificare che il file manifesto COM+ sia presente in ogni directory virtuale che richiede l'utilizzo della DLL.

Nota

Le DLL condivise devono supportare gli assembly SxS.

Nome file manifesto

Digitare il nome del file manifesto COM+. Il file manifesto COM+ è un file XML contenente informazioni sul percorso in cui è installata una DLL. La presenza del file manifesto non viene verificata da IIS.

Per visualizzare un estratto di un file manifesto, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Argomenti correlati

Per ulteriori informazioni su Active Server Pages e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Configurazione applicazioni - Scheda Debug

Questa scheda consente di impostare le opzioni di debug per pagine ASP che verranno eseguite nell'applicazione correntemente selezionata.

È possibile impostare due tipi di flag di debug che abilitano il debug degli script sul lato server e sul lato client. Per risolvere i problemi relativi agli script ASP mentre sono in fase di elaborazione, è possibile utilizzare Microsoft® Script Debugger. L'abilitazione del debug ASP sul lato server comporta l'esecuzione di pagine ASP in modalità a thread singolo. Per migliori prestazioni, si consiglia di non eseguire il debug ASP sul lato server o sul lato client in un ambiente di produzione.

È possibile controllare la frequenza e il tipo di messaggi di errore inviati al browser quando si verifica un errore negli script ASP. Internet Information Services (IIS) può essere configurato in modo da inviare al browser messaggi di errore dettagliati che contengono specifiche informazioni di debug, quali il nome del file, il messaggio di errore e il numero della riga, facilitando così l'analisi dell'output. È inoltre possibile configurare IIS in modo da inviare al browser un messaggio di errore predefinito quando un qualsiasi errore impedisce al server Web di elaborare una pagina ASP. Nel registro degli errori verrà inserito un messaggio di errore specifico. È inoltre possibile modificare il testo del messaggio di errore predefinito all'interno della casella di testo.

Abilita debug script ASP sul lato server

Consente al server Web di richiamare Microsoft Script Debugger durante l'elaborazione delle pagine ASP.

Abilita debug script ASP sul lato client

Consente al client di richiamare Microsoft Script Debugger durante l'elaborazione delle pagine ASP.

Invia al client messaggi d'errore dettagliati in formato ASP

Consente a IIS di inviare al browser specifiche informazioni di debug, quali il nome del file, il messaggio di errore e il numero di riga.

Invia al client il seguente messaggio d'errore in formato testo

Consente a IIS di inviare al browser un messaggio di errore predefinito quando un qualsiasi errore impedisce al server Web di elaborare una pagina ASP. È possibile utilizzare il messaggio di errore predefinito oppure modificarlo all'interno della casella di testo.

Argomenti correlati

Per ulteriori informazioni su Active Server Pages e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Configurazione applicazioni - Scheda Opzioni cache

Questa scheda consente di impostare le opzioni per la memorizzazione nella cache delle applicazioni. È possibile configurare Internet Information Services (IIS) affinché i file ASP non vengano inseriti nella cache sul client. A ogni richiesta, il browser client esegue una query sul server per trovare una pagina nuova o aggiornata. Questa operazione consente un risparmio di spazio sul disco del computer client, ma determina una riduzione delle prestazioni. La memorizzazione di file script ASP nella cache consente di ottimizzare le prestazioni poiché tali script non devono essere compilati a ogni chiamata.

Non inserire nella cache i file ASP

Se si sceglie questa opzione, i file ASP non verranno inseriti nella cache e, di conseguenza, a ogni successiva richiesta da parte del browser verrà inviata al server una nuova richiesta del file ASP.

Inserisci tutti i file ASP nella cache nella memoria

Consente di inserire nella cache sul computer in uso tutti i file ASP richiesti dal browser al server. Se si sceglie questa opzione, è consigliabile specificare una directory nella casella Directory cache su disco e impostare un limite per i moduli di script memorizzati nella cache nella casella Numero moduli di script nella cache.

Inserisci un numero limitato di file ASP nella cache nella memoria

Consente di inserire nella memoria cache un numero limitato di file ASP compilati (modelli). Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il numero di file che si desidera inserire nella cache. Dopo aver selezionato questa opzione, scegliere una delle opzioni seguenti per inserire nella cache sul disco tutti i file ASP rimanenti o solo un numero limitato.

Inserisci i file ASP rimanenti nella cache sul disco

Consente di inserire nella cache sul disco tutti i file ASP compilati rimanenti non memorizzati nella cache.

Inserisci un numero limitato di file ASP nella cache sul disco

Consente di inserire nella cache su disco un numero limitato di file ASP compilati non memorizzati nella cache.

Directory cache su disco

Digitare o scegliere la directory di destinazione in cui verranno inseriti i file ASP.

Sfoglia

Consente di individuare una directory sul computer in uso in cui memorizzare i file ASP disponibili nella cache.

Numero moduli di script nella cache

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il numero di moduli di gestione di script disponibili nella cache. I moduli di gestione di script, come Microsoft® Visual Basic® Scripting Edition (VBScript), richiedono memoria e accessibilità. Limitando il numero di moduli di gestione di script inseriti nella cache del computer, è possibile ottimizzare le prestazioni e l'utilizzo della memoria.

Argomenti correlati

Per ulteriori informazioni su Active Server Pages, la memorizzazione di pagine ASP nella cache e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Configurazione applicazioni - Scheda Opzioni processo

Questa scheda consente di modificare le impostazioni delle applicazioni che vengono eseguite in un unico processo. È possibile utilizzare questa scheda per modificare le impostazioni relative a due tipi di processi: il processo del server Web e i processi delle applicazioni isolate. Le opzioni impostate per il sito Web sono valide per tutte le applicazioni che vengono eseguite all'interno del processo del server Web. Le opzioni impostate per un'applicazione isolata sono valide solo per tale applicazione.

Scrivi nel registro eventi le richieste dei client non soddisfatte

Consente di configurare IIS in modo che il server Web scriva le richieste dei client non soddisfatte nel registro eventi di Windows.

Abilita l'individuazione delle eccezioni durante il debug

Consente di configurare IIS in modo che Active Server Pages (ASP) invii un messaggio di errore generale se non è possibile creare un'istanza di un oggetto fornito da un componente COM (una chiamata a Server.CreateObject). Quando questa opzione non è selezionata, ASP invia il messaggio di errore specifico del componente. Si consiglia di non scegliere questa opzione quando si esegue il debug di un componente. Al termine del debug, selezionare di nuovo l'opzione.

Timeout script CGI

Consente di impostare o modificare il valore di timeout, ossia l'intervallo di tempo assegnato a uno script CGI per l'esecuzione e la restituzione di un valore prima che l'operazione venga interrotta. È possibile impostare le proprietà di configurazione delle applicazioni a livello di directory, di directory virtuale o di sito Web.

Argomenti correlati

Per ulteriori informazioni su Active Server Pages e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Servizio

Questa scheda consente di abilitare la modalità di isolamento e la compressione HTTP di Internet Information Services (IIS) 5.0.

Modalità di isolamento

In IIS 6.0, la modalità di processo predefinita è la modalità di isolamento processo di lavoro. Per motivi di compatibilità con le versioni precedenti, è disponibile anche la modalità di isolamento IIS 5.0.

Esegui il servizio WWW in modalità di isolamento IIS 5.0

Consente di utilizzare la modalità di isolamento IIS 5.0 per applicazioni che violano le restrizioni della modalità di isolamento processo di lavoro, come le seguenti:

  • ISAPI multi-istanza: applicazioni ISAPI scritte per essere caricate da più processi ed eseguite contemporaneamente.

  • Processo di lavoro esterno: applicazioni scritte per inoltrare le richieste ad altri processi di lavoro. Questa operazione non è supportata nella modalità di isolamento processo di lavoro.

  • Stato sessione mantenuto in-process: applicazioni che mantengono lo stato della sessione in-process. Durante il riciclo del processo di lavoro, lo stato sessione potrebbe andare perso. Questo problema non riguarda le applicazioni ASP.NET che mantengono sempre uno stato out-of-process.

compressione HTTP

È possibile scegliere di comprimere i file prima che vengano inviati ai client abilitati per la compressione. Dopo che un file è stato richiesto, ne viene creata una copia compressa che viene memorizzata in una directory della cache e utilizzata in risposta alle successive richieste. I file vengono compressi soltanto dopo essere stati richiesti.

Questa opzione consente di eseguire le applicazioni IIS nella stessa modalità di isolamento processo di IIS 5.0.

Comprimi file applicazione

Scegliere questa opzione per comprimere i file applicazione prima che vengano inviati ai client abilitati per la compressione per essere inseriti nella cache.

Comprimi file statici

Scegliere questa opzione per comprimere solo i file statici prima che vengano inviati ai client abilitati per la compressione per essere inseriti nella cache.

Directory temporanea

Digitare o scegliere il percorso della directory in cui si desidera memorizzare i file compressi. Tale directory deve trovarsi in una partizione di file system NTFS nel disco rigido locale e non deve essere condivisa né contrassegnata per la compressione.

Sfoglia

Consente di individuare il percorso della directory.

Illimitate

Scegliere questa opzione per non imporre limiti alla dimensione della directory cache in cui si trovano i file compressi.

Limitate a

Scegliere questa opzione per imporre dei limiti alla dimensione della directory cache in cui si trovano i file compressi.

Nella casella adiacente digitare il numero massimo di megabyte a cui si desidera impostare la directory cache.

Argomenti correlati

Per ulteriori informazioni sulla modalità di isolamento IIS 5.0 e la compressione HTTP, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Sito Web

Questa scheda consente di impostare un nome semplice per il sito Web, configurare l'accesso al sito Web, impostare limiti di connessione, abilitare la registrazione e configurare il formato di registrazione del sito.

Identificazione sito Web

Per consentire ai browser di accedere al contenuto Web, è necessario definire sia un indirizzo IP che un numero di porta TCP.

Descrizione

Digitare un nome semplice per il sito Web. Questo nome verrà visualizzato nell'albero della console di Gestione IIS.

Indirizzo IP

Scegliere un indirizzo IP dalla casella di riepilogo o digitarne uno nuovo da utilizzare per accedere al sito. Se non si assegna un indirizzo IP specifico, il sito risponderà a tutti gli indirizzi IP assegnati al computer e non assegnati ad altri siti, impostando di fatto il sito corrente come sito Web predefinito. In questa casella vengono visualizzati solo gli indirizzi IP già configurati nel Pannello di controllo per l'utilizzo nel computer specifico. Per ulteriori informazioni, vedere la Guida di Windows Server 2003. Il nome descrittivo del sito è facoltativo.

Porta TCP

Specificare la porta TCP in cui il servizio Web è in esecuzione. Il numero di porta predefinito è 80. È possibile impostare la porta su un qualsiasi numero univoco, ma per evitare errori nelle richieste di connessione al server, è necessario che i client siano impostati per utilizzare il numero di porta corretto. Non è possibile lasciare questa casella vuota.

Porta SSL

Specificare la porta SSL da associare all'identità del sito Web. Il numero di porta SSL predefinito è 443. È tuttavia possibile assegnare alla porta SSL un qualsiasi numero univoco, ma per evitare errori nella connessione al server, è necessario che i client siano impostati per utilizzare il numero di porta corretto. È necessario specificare una porta SSL solo se si utilizza la crittografia SSL. In caso contrario, se la crittografia SSL non è attivata per il sito, la casella Porta SSL non sarà disponibile.

Avanzate

Consente di configurare l'indirizzo IP, il numero di porta TCP e il valore intestazione host che verranno utilizzati per accedere al sito.

Connessioni

È possibile impostare l'intervallo di tempo in secondi che deve trascorrere prima che il server chiuda la connessione di un utente inattivo. Questa impostazione assicura che tutte le connessioni vengano chiuse, anche quando il protocollo HTTP non riesce a chiuderle. La maggior parte dei browser chiede al server di tenere aperta la connessione tra una richiesta e l'altra. Questa funzionalità, nota con il nome di keep-alive HTTP, è una specifica HTTP che consente di aumentare notevolmente le prestazioni del server. In assenza di questa specifica, un browser deve stabilire numerose connessioni per visualizzare una pagina contenente più elementi, ad esempio immagini. Potrebbe essere necessario stabilire una connessione distinta per ogni elemento. Queste richieste e connessioni aggiuntive comportano un aumento dell'attività e dell'utilizzo delle risorse del server, con una conseguente riduzione delle prestazioni. Ulteriori richieste rendono il browser molto più lento e i tempi di risposta maggiori, soprattutto se la connessione è ad alta latenza. I keep-alive HTTP vengono abilitati per impostazione predefinita durante l'installazione.

Timeout connessione

Digitare un numero nella casella per impostare l'intervallo di tempo in secondi che deve trascorrere prima che il server interrompa la connessione di un utente inattivo. Questa impostazione assicura che tutte le connessioni vengano chiuse, anche quando il protocollo HTTP non riesce a chiuderle.

Abilitazione dei keep-alive HTTP

Scegliere questa opzione per consentire a un client di mantenere una connessione aperta con il server anziché dover riaprire la connessione a ogni nuova richiesta. La disattivazione dei keep-alive può comportare un degrado delle prestazioni del server. I keep-alive HTTP sono abilitati per impostazione predefinita.

Consenti registrazione attività

Scegliere questa opzione per abilitare le funzionalità di registrazione del sito Web tramite le quali è possibile registrare informazioni sulle attività degli utenti e creare file registro in vari formati.

Le informazioni vengono memorizzate in file ASCII o in un database compatibile con ODBC. La registrazione delle informazioni in IIS si pone un maggiore numero di finalità rispetto alle funzionalità di registrazione degli eventi o monitoraggio delle prestazioni disponibili in Microsoft ® Windows®. I registri possono includere informazioni quali gli utenti che hanno visitato il sito, le informazioni visualizzate e l'ultima data di accesso alle informazioni. Tramite i registri è possibile valutare il grado di popolarità del contenuto o identificare eventuali colli di bottiglia delle informazioni.

Formato registro attivo

Scegliere uno dei seguenti formati per i file registro.

  • Formato di file registro Microsoft IIS: formato ASCII fisso.

  • Formato di file registro comune NCSA: formato ASCII fisso.

  • Registrazione ODBC: formato fisso registrato in un database compatibile con il database specifico.

  • Formato di file registro W3C esteso: formato ASCII personalizzabile, selezionato per impostazione predefinita. Per utilizzare Conteggio processi, è necessario scegliere il formato di file registro esteso W3SVC.

Proprietà

Consente di configurare i criteri in base ai quali verrà creato il file registro, ad esempio, settimanalmente o in base alle dimensioni del file, oppure per configurare le proprietà per la registrazione ODBC o W3C estesa.

Argomenti correlati

Per ulteriori informazioni sulla denominazione dei siti Web, la crittografia di dati tramite SSL, i keep-alive HTTP e la registrazione dell'attività di un sito, vedere la documentazione in linea IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Identificazione avanzata sito Web

Questa finestra di dialogo consente di aggiungere al computer identità di sito Web o identità SSL.

Un'identità di sito Web è costituita da un indirizzo IP, una porta TCP e un nome intestazione host facoltativo, che associa un nome a un singolo indirizzo IP statico per ospitare più siti. Aggiungere il nome host nel sistema di risoluzione dei nomi, in genere DNS, in modo che quando una richiesta raggiunge il server, IIS utilizza il nome host per determinare il sito a cui i client hanno inviato la richiesta. Il nome host viene specificato nell'intestazione HTTP.

Un'identità SSL è costituita da un indirizzo IP e da un numero di porta SSL.

Identità multiple per questo sito Web

È possibile aggiungere, rimuovere o modificare le identità per il sito Web. Un'identità di sito Web è costituita da un indirizzo IP, una porta TCP e un nome intestazione host facoltativo. A ogni sito Web deve essere associata una combinazione univoca di caratteristiche identificative. Più siti Web possono pertanto condividere al massimo due delle tre caratteristiche identificative, ossia indirizzo IP, porta TCP e intestazione host; almeno una delle caratteristiche deve essere diversa. Poiché i certificati SSL includono il nome del dominio, i siti Web che utilizzano i certificati non possono condividere un indirizzo IP con altri siti Web.

Aggiungi

Consente di aggiungere un'identità di sito Web.

Rimuovi

Consente di rimuovere dall'elenco l'identità di sito Web correntemente selezionata.

Modifica

Consente di modificare l'identità di sito Web correntemente selezionata.

Identità SSL multiple per questo sito Web

È possibile aggiungere, rimuovere o modificare le identità SSL per il sito Web. Un'identità SSL è costituita da un indirizzo IP e da un numero di porta SSL. Specificare un'identità SSL solo se la crittografia SSL è abilitata. Se la crittografia SSL non è attivata nel sito, i pulsanti Aggiungi, Rimuovi e Modifica non saranno disponibili.

Aggiungi

Consente di aggiungere un'identità SSL per il sito Web, costituita da un indirizzo IP e un numero di porta SSL. Verrà visualizzata la finestra di dialogo Identificazione avanzata sito Web. Il numero di porta predefinito per SSL è 443. È possibile utilizzare un numero di porta diverso da quello predefinito, ma per evitare errori nelle richieste di connessione al server, è necessario che i client siano impostati per utilizzare il numero di porta corretto.

Rimuovi

Consente di rimuovere dal sito Web l'identità SSL correntemente selezionata.

Modifica

Consente di modificare l'identità SSL correntemente selezionata per il sito Web.

Argomenti correlati

Per ulteriori informazioni sulla denominazione dei siti Web e la crittografia di dati tramite SSL, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Aggiunta/Modifica identificazione sito Web

Questa finestra di dialogo consente di configurare l'identità del sito Web. L'identità del sito Web è costituita da un indirizzo IP, una porta TCP e un nome intestazione host facoltativo. Per poter visualizzare un indirizzo IP nella casella di riepilogo, è necessario associare l'indirizzo al computer. I nomi intestazione host devono essere registrati utilizzando il DNS (Domain Name System). Un server DNS associa il nome intestazione host registrato (nome di dominio) all'indirizzo IP del computer, consentendo alle richieste indirizzate al nome intestazione host di essere inoltrate al computer in uso.

Indirizzo IP

Dalla casella di riepilogo, scegliere un indirizzo IP che si desidera associare al sito Web. In questa casella vengono visualizzati solo gli indirizzi IP che sono stati configurati dal Pannello di controllo per l'utilizzo in questo computer. Se non si seleziona un indirizzo IP specifico, il sito Web risponderà a tutti gli indirizzi IP che sono assegnati al computer in uso ma non ad altri siti Web.

Porta TCP

Questa impostazione specifica la porta TCP su cui è in esecuzione il servizio Pubblicazione sul Web (servizio WWW). La porta predefinita è 80. È tuttavia possibile assegnare alla porta TCP un qualsiasi numero univoco, ma per evitare errori nelle richieste di connessione al server, è necessario che i client siano impostati per utilizzare il numero di porta corretto.

Valore intestazione host

È possibile assegnare più nomi host, noti anche come nomi di dominio, a un computer che utilizza un singolo indirizzo IP. Se il sito Web richiesto nell'intestazione host non è disponibile, il client riceverà il sito Web predefinito. I provider di servizi Internet (ISP) dovrebbero pertanto impostare come home page il sito Web predefinito anziché il sito di un cliente.

Argomenti correlati

Per ulteriori informazioni sulla denominazione dei siti Web e le modalità di utilizzo delle identità del sito Web per indirizzare le richieste del client al sito Web, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà registrazione - Scheda Generale

Questa scheda consente di specificare le modalità di creazione e salvataggio dei file registro. Nella casella Directory file registro viene visualizzato un nome di file, determinato dal formato del file di registro e dal criterio utilizzato per la creazione di nuovi file di registro.

Nuova pianificazione registro (comune a tutti i formati di registrazione)

Qualsiasi modifica apportata alla pianificazione registro diventa effettiva immediatamente dopo l'applicazione delle nuove impostazioni.

Ogni ora

Consente di creare file registro ogni ora.

Ogni giorno

Consente di creare file registro quotidianamente, a partire dal primo evento che si verifica dopo la mezzanotte.

Ogni settimana

Consente di creare file registro settimanalmente, a partire dal primo evento che si verifica dopo la mezzanotte di sabato.

Ogni mese

Consente di creare file registro mensilmente, a partire dal primo evento che si verifica dopo la mezzanotte dell'ultimo giorno del mese.

Nota

Per "mezzanotte" si intende la mezzanotte in base all'ora locale per tutti i formati di file registro, ad eccezione del formato W3C esteso. Per impostazione predefinita, per questo formato la mezzanotte viene determinata in base all'ora di Greenwich. È tuttavia possibile modificare questa impostazione affinché la mezzanotte venga calcolata in base all'ora locale anche per questo formato, selezionando l'opzione Usa ora locale per denominazione e aggiornamento file.

Dimensioni file illimitate

Consente di aggiungere continuamente dati allo stesso file registro a cui è possibile accedere solo dopo aver arrestato il server.

Quando il file corrente raggiunge

Consente di creare un nuovo file registro ogni volta che quello corrente raggiunge le dimensioni specificate. Digitare un numero nella casella o utilizzare le frecce Su e Giù per specificare la dimensione desiderata.

Usa ora locale per denominazione e aggiornamento file (specifica per il formato W3C)

Consente di definire l'ora di creazione e il formato di denominazione dei file registro W3C esteso per calcolare la mezzanotte in base all'ora locale anziché all'ora di Greenwich.

Directory file registro

Digitare o scegliere la directory in cui verranno salvati i file registro.

Sfoglia

Consente di individuare la directory in cui verranno salvati i file registro.

Argomenti correlati

Per ulteriori informazioni sulla registrazione dell'attività di un sito, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà registrazione - Scheda Avanzate

Questa scheda consente di personalizzare la registrazione W3C estesa scegliendo i campi, o elementi, da inserire nel registro. In alcuni casi, dopo il nome appare anche il nome del campo abbreviato. Per limitare le dimensioni del registro, omettere i campi non necessari.

Data

Consente di registrare la data in cui si è verificata l'attività.

Ora

Consente di registrare l'ora in cui si è verificata l'attività.

Proprietà estese

Indirizzo IP client

Consente di registrare l'indirizzo IP del client che ha avuto accesso al server.

Nome utente

Consente di registrare il nome dell'utente autenticato che ha avuto accesso al server. Sono esclusi gli utenti anonimi, che sono rappresentati da un trattino (-).

Nome servizio

Consente di registrare il servizio Internet e il numero di istanza a cui ha avuto accesso un client.

Nome server

Consente di registrare il nome del server in cui è stata generata la voce di registro.

Indirizzo IP server

Consente di registrare l'indirizzo IP del server in cui è stata generata la voce di registro.

Porta server

Consente di registrare il numero della porta a cui il client è connesso.

Metodo

Consente di registrare il tipo di azione che il client ha tentato di eseguire, ad esempio un comando GET.

Origine URI

Consente di registrare la risorsa a cui si è avuto accesso, ad esempio una pagina HTML, un programma CGI o uno script.

Query URI

Consente di registrare l'eventuale query che il client ha tentato di eseguire, vale a dire una o più stringhe di ricerca per cui il client ha cercato una corrispondenza.

Stato protocollo

Consente di registrare lo stato dell'azione, nei termini HTTP o FTP.

Stato secondario protocollo

Consente di registrare lo stato aggiuntivo dell'azione, nei termini HTTP. Per ulteriori informazioni sulla proprietà Stato secondario protocollo, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.

Stato Win32

Consente di registrare lo stato dell'azione nei termini utilizzati dal sistema operativo Microsoft® Windows®.

Byte inviati

Consente di registrare il numero di byte inviati dal server.

Byte ricevuti

Consente di registrare il numero di byte ricevuti dal server.

Tempo impiegato

Consente di registrare il tempo impiegato per eseguire l'operazione. Per tutti i formati di registro ad eccezione della registrazione delle attività ODBC, il tempo impiegato viene registrato in millisecondi, in base alla seguente suddivisione tecnica: il timestamp di richiesta cliente viene inizializzato quando HTTP.sys, ovvero il driver in modalità kernel, riceve il primo byte, prima che HTTP.sys avvii l'analisi della richiesta. Il timestamp di richiesta client viene terminato quando è stato completato l'ultimo invio in IIS. Il valore riportato nella casella Tempo impiegato non indica il tempo trascorso in rete. Si noti inoltre che la prima richiesta al sito mostra un tempo impiegato leggermente superiore a quello delle altre richieste simili o identiche perché HTTP.sys apre il file registro con la prima richiesta.

Versione protocollo

Consente di registrare la versione del protocollo (HTTP, FTP) utilizzata dal client. Nel caso del protocollo HTTP, la versione sarà HTTP 1.0 o HTTP 1.1.

Host

Consente di registrare il contenuto dell'intestazione host.

Agente utente

Consente di registrare il browser utilizzato dal client.

Cookie

Consente di registrare il contenuto di un eventuale cookie inviato o ricevuto.

Provenienza

Consente di registrare il sito precedente visitato dall'utente, in cui era disponibile un collegamento al sito corrente.

Argomenti correlati

Per ulteriori informazioni sulla registrazione in formato W3C esteso e la registrazione dell'attività di un sito, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà registrazione delle attività ODBC dei siti Web e FTP - Scheda Proprietà ODBC

Questa scheda consente di identificare l'origine dati, l'eventuale tabella in essa contenuta e il modo per accedervi, vale a dire il nome utente e la password. Un'origine dati può essere un qualsiasi file compatibile con ODBC, ad esempio un database o un file delimitato da virgole.

  • In questa scheda è possibile impostare le opzioni per la registrazione delle attività ODBC. Prima di iniziare, occorre effettuare le seguenti operazioni:

  • Utilizzare un programma di database compatibile con ODBC, quale Microsoft® Access o Microsoft SQL® Server, per creare un database.

  • Nel database creare una tabella con i campi specificati alla fine di questo argomento.

  • Creare un nome origine dati (DSN). Per ulteriori informazioni, vedere la Guida di Windows Server 2003.

  • Specificare il nome origine dati e il nome della tabella.

  • Se richiesti, specificare anche il nome utente e la password per accedere al database.

Nome origine dati ODBC (DSN)

Digitare il nome dell'origine dati a cui connettersi. Una volta creato, questo nome viene memorizzato in Amministratore origine dati ODBC, accessibile tramite Strumenti di amministrazione.

Tabella

Digitare il nome della tabella contenuta nell'origine dati ODBC sopra specificata.

Nome utente

Digitare l'alias dell'utente autorizzato ad accedere all'origine dati e alla tabella.

Password

Digitare la password associata al nome utente sopra specificato.

Argomenti correlati

Per ulteriori informazioni sulla registrazione delle attività ODBC e la registrazione dell'attività di un sito, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Prestazioni

Questa scheda consente di impostare le proprietà che influenzano l'utilizzo della larghezza di banda e il numero di connessioni Web del client. La configurazione della larghezza di banda in un determinato sito consente una migliore gestione del traffico consentito in quel sito. Limitando, ad esempio, la larghezza di banda e/o il numero di connessioni in un sito Web a bassa priorità, si consentirà ad altri siti con priorità più alta di gestire carichi di traffico maggiori. Le impostazioni sono specifiche del sito e possono essere modificate a seconda del traffico di rete e dell'utilizzo.

Limitazione larghezza di banda

Questa opzione, che consente di limitare la larghezza di banda nel sito Web, La limitazione della larghezza di banda si serve dell'Utilità di pianificazione pacchetti per gestire i tempi di invio dei pacchetti di dati. Quando si configura un sito per l'utilizzo della limitazione della larghezza di banda tramite Gestione IIS, l'Utilità di pianificazione pacchetti viene automaticamente installata e la limitazione della larghezza di banda viene automaticamente impostata su un minimo di 1024 byte al secondo. Se invece si utilizza un altro metodo, ad esempio Active Directory® Service Interfaces [ADSI] o Strumentazione gestione Windows [WMI], sarà necessario installare manualmente l'Utilità di pianificazione pacchetti per il corretto funzionamento della limitazione della larghezza di banda.

Limita la larghezza di banda disponibile per questo sito Web

Consente di abilitare la limitazione della larghezza di banda nel sito Web.

Larghezza di banda massima

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare la larghezza di banda massima in kilobyte al secondo per il sito Web.

Connessioni sito Web

È possibile configurare Internet Information Services (IIS) per consentire un numero illimitato di connessioni simultanee o per limitare il numero di connessioni consentite nel sito Web. Se il numero di connessioni tende a variare e si imposta un numero illimitato di connessioni, si evita la necessità di attività di amministrazione costanti; tuttavia, le prestazioni del sistema non saranno stabili, soprattutto se il numero di connessioni supera le possibilità delle risorse di sistema. La limitazione del sito a un numero specifico di connessioni consente invece una maggiore stabilità delle prestazioni. Le impostazioni sono specifiche del sito e possono essere modificate a seconda del traffico di rete e dell'utilizzo.

Illimitate

Consente di configurare il sito Web per gestire un numero illimitato di connessioni simultanee.

Limitate a

Consente di impostare un numero specifico di connessioni simultanee per il sito Web. Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il numero di connessioni.

Argomenti correlati

Per ulteriori informazioni sulle funzionalità di limitazione della larghezza di banda, la riduzione di connessioni simultanee a un sito Web e il ruolo della gestione delle prestazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Filtri ISAPI

Questa scheda consente di impostare le opzioni relative ai filtri ISAPI. Un filtro ISAPI è un programma che risponde agli eventi durante l'elaborazione di una richiesta HTTP. Nella tabella sono elencati lo stato di ciascun filtro, che può essere abilitato o disabilitato, il nome del file e la priorità per il caricamento in memoria. L'ordine di esecuzione dei filtri può essere modificato solo per i filtri con la stessa priorità.

Importante

Se è stato aggiunto o modificato un filtro a livello globale, sarà necessario riavviare Internet Information Services (IIS) per caricare il nuovo filtro. Se è stato aggiunto o modificato un filtro a livello di sito Web, il filtro non verrà caricato fino a quando non verrà fatta una richiesta al sito Web.

Aggiungi

Consente di aggiungere un filtro ISAPI esistente cercando il file eseguibile e specificando un nome semplice.

Rimuovi

Consente di rimuovere dall'elenco di filtri da caricare il filtro ISAPI correntemente selezionato.

Modifica

Consente di modificare le proprietà del filtro ISAPI correntemente selezionato.

Disabilita

Consente di impedire il caricamento del filtro ISAPI correntemente selezionato, senza rimuoverlo dall'elenco.

Sposta su

Consente di spostare il filtro correntemente selezionato in una posizione più alta nell'ordine di esecuzione.

Sposta giù

Consente di spostare il filtro correntemente selezionato in una posizione più bassa nell'ordine di esecuzione.

Argomenti correlati

Per ulteriori informazioni sui filtri ISAPI, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Aggiunta/Modifica proprietà filtro

Questa finestra di dialogo consente di stabilire le proprietà del filtro ISAPI. Un filtro ISAPI è un programma che risponde agli eventi durante l'elaborazione di una richiesta HTTP.

Nome filtro

Digitare un nome semplice per il filtro ISAPI. I nomi semplici spesso includono i numeri di versione per garantire che il filtro venga correttamente aggiornato con versioni successive.

Eseguibile

Digitare il percorso completo del programma eseguibile associato al filtro ISAPI.

Sfoglia

Consente di individuare il filtro ISAPI.

Argomenti correlati

Per ulteriori informazioni sui filtri ISAPI, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Aggiungi nuovo pool di applicazioni

Questa finestra di dialogo consente di aggiungere un nuovo pool di applicazioni. Un pool di applicazioni è un insieme di una o più applicazioni assegnate a uno o più processi di lavoro. Essendo i pool separati da meccanismi di isolamento, un'applicazione in un pool non è interessata da problemi che riguardano applicazioni in altri pool.

ID pool di applicazioni

Digitare il tag ID per il pool di applicazioni che si desidera creare.

Usa impostazioni predefinite per il nuovo pool di applicazioni

Per stabilire le impostazioni principali, fare clic con il pulsante destro del mouse sulla directory Pool di applicazioni nell'albero della console di Gestione IIS, quindi scegliere Proprietà. Tutte le impostazioni del pool di applicazioni stabilite a questo livello verranno considerate principali e verranno estese a tutti gli altri pool di applicazioni contenuti nella directory.

Usa pool di applicazioni esistente come modello

Questa opzione consente al pool che si desidera creare di ereditare le impostazioni di un pool di applicazioni esistente. Tali impostazioni verranno considerate come modello.

Nome pool di applicazioni

Specificare il nome descrittivo del pool di applicazioni esistente da utilizzare come modello per il pool che si desidera creare.

Argomenti correlati

Per ulteriori informazioni sui pool di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Pool di applicazioni - Scheda Riciclo

Questa scheda consente di gestire il riciclo dei processi di lavoro. Nella modalità di isolamento processo di lavoro, è possibile configurare IIS in modo da riavviare periodicamente i processi di lavoro in un pool di applicazioni, rendendo così possibile un'attenta gestione dei processi difettosi. In questo modo si assicura l'integrità delle applicazioni specificate in quei pool e il ripristino delle risorse del sistema.

Per riciclare un processo di lavoro difettoso, se ne si riduce la capacità di ricezione delle richieste fino a quando non vengono elaborate tutte le richieste rimanenti in coda. Per esaurire le richieste correnti, al processo viene assegnato un limite. Prima che si interrompa il processo di lavoro difettoso, viene avviato un processo di lavoro sostitutivo per lo stesso gruppo dello spazio dei nomi, impedendo così che si verifichino interruzioni del servizio. Il vecchio processo soddisfa le richieste in sospeso e si interrompe. Se ciò non avviene, verrà terminato forzatamente dopo un determinato periodo di tempo o un numero stabilito di richieste, in base a una pianificazione o anche dopo aver raggiunto il limite di utilizzo della memoria.

Ricicla i processi di lavoro (in minuti)

Consente di riciclare i processi di lavoro dopo un periodo specifico di inattività.

Ricicla i processi di lavoro (numero di richieste)

Consente di riciclare i processi di lavoro dopo un numero specifico di richieste.

Ricicla i processi di lavoro nei seguenti orari

Consente di utilizzare uno schema di pianificazione per interrompere un processo e avviarne uno sostitutivo.

Aggiungi

Consente di aggiungere un'ora del giorno ai criteri basati su pianificazione per il riciclo del processo di lavoro.

Rimuovi

Consente di rimuovere i criteri basati su pianificazione correntemente selezionati per il riciclo del processo di lavoro.

Modifica

Consente di modificare i criteri basati su pianificazione correntemente selezionati per il riciclo del processo di lavoro.

Ricicla il processo di lavoro in caso di consumo troppo elevato di memoria

Questa opzione consente di impostare dei limiti al consumo della memoria al fine di interrompere un processo e avviarne uno sostitutivo. Le impostazioni descritte di seguito consentono di definire le soglie per il riciclo basato sulla memoria quando la quantità di memoria virtuale o privata utilizzata da un processo di lavoro diventa troppo elevata in rapporto alla quantità di memoria totale del sistema. Il riciclo basato sulla memoria è adatto per ridurre la frammentazione dell'heap e ripristinare la memoria in applicazioni con perdite di memoria.

Quantità massima di memoria virtuale

Impostare il numero massimo di megabyte di memoria virtuale comune del sistema che dovrà essere utilizzata da un processo di lavoro prima di essere riciclato.

Un valore troppo elevato potrebbe causare una riduzione delle prestazioni del sistema. Utilizzare inizialmente il valore predefinito per poi ridurlo al minimo valore che consenta comunque buone prestazioni.

Quantità massima di memoria utilizzata

Impostare il numero massimo di megabyte di memoria fisica di sistema allocata privatamente che dovrà essere utilizzata da un processo di lavoro prima di essere riciclato.

Un valore troppo elevato potrebbe causare una riduzione delle prestazioni del sistema. Utilizzare inizialmente il valore predefinito per poi ridurlo al minimo valore che consenta comunque buone prestazioni.

Argomenti correlati

Per ulteriori informazioni sui processi di lavoro e il riciclo, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà pool di applicazioni - Scheda Prestazioni

Questa scheda consente di configurare il modo in cui Internet Information Services (IIS) arresta i processi di lavoro inattivi, il numero di richieste in attesa di elaborazione, il monitoraggio della CPU e il numero di processi in un Web garden.

Timeout di inattività

I limiti del timeout di inattività consentono di preservare le risorse di sistema terminando i processi di lavoro inutilizzati dopo un determinato periodo di tempo. Questo comportamento consente di ottimizzare le risorse in particolari computer quando il carico di elaborazione è pesante, quando determinate applicazioni sono sistematicamente in stato di inattività o quando non vi è spazio sufficiente per un nuovo processo.

Chiudi processi di lavoro dopo un periodo di inattività di (in minuti)

Consente di terminare qualsiasi processo di lavoro inattivo dopo un periodo specifico di inattività.

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il numero di minuti che deve trascorrere prima che un processo inattivo venga interrotto.

Limite coda richieste

Consente di configurare IIS per monitorare il numero di richieste per una determinata coda del pool di applicazioni prima di aggiungervi una nuova richiesta.

I limiti imposti alla lunghezza della coda del pool di applicazioni impediscono l'accodamento di un numero troppo elevato di richieste che potrebbe provocare un sovraccarico del sistema. Se aggiungendo una nuova richiesta alla coda si supera la capacità della coda stessa, il server rifiuterà la richiesta e restituirà al client un errore 503 non personalizzabile.

Numero massimo di richieste al kernel consentito per la coda

Consente di configurare IIS per utilizzare uno schema numerico che limiti le richieste HTTP in ingresso e per limitare la dimensione della coda delle richieste. Una volta raggiunto il limite, non vengono elaborate altre richieste e al client viene restituito un errore 503 non personalizzabile.

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il limite per il numero di richieste consentite nella coda.

Abilita monitoraggio CPU

Consente di configurare IIS in modo da utilizzare i conteggi CPU per monitorare e terminare i processi di lavoro che consumano quantità elevate di tempo CPU, superiori ai limiti specificati. Il monitoraggio della CPU è disponibile solo per pool di applicazioni e non per applicazioni CGI.

Massimo utilizzo CPU (percentuale)

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare la percentuale di utilizzo della CPU consentita a un processo di lavoro.

Aggiornamento numeri di utilizzo CPU (in minuti)

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare la frequenza di aggiornamento dei numeri di utilizzo della CPU perché siano impiegati per il monitoraggio della CPU.

Azione da eseguire in caso di utilizzo della CPU superiore al valore massimo

Dalla casella di riepilogo scegliere l'azione che si desidera venga eseguita quando la CPU supera il massimo valore di utilizzo specificato.

  • Se si seleziona Nessuna azione, quando l'utilizzo della CPU per un pool di applicazioni o per un gruppo di pool specifico raggiunge il limite impostato, verrà trascritto un errore nel Registro eventi.

  • Se si seleziona Chiusura, quando l'utilizzo della CPU per un pool di applicazioni specifico raggiunge il limite impostato, verrà avviata la chiusura di tutti i processi di lavoro nel pool di applicazioni. Ogni processo di lavoro verrà arrestato in base al numero di secondi impostato in Limite tempo di chiusura. Se i processi non si arrestano entro il periodo di tempo specificato, verranno terminati forzatamente da IIS. Il pool di applicazioni quindi si arresta e viene ripristinato in base al limite di tempo impostato in Intervallo ripristino CPU.

Web garden

Un Web garden è un pool di applicazioni che utilizza più processi di lavoro.

Numero massimo di processi di lavoro

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il numero massimo di processi di lavoro consentiti in un pool di applicazioni.

Argomenti correlati

Per ulteriori informazioni sulle funzionalità di timeout e CPU e i Web garden, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà pool di applicazioni - Scheda Integrità

Questa scheda consente di configurare il monitoraggio dell'integrità dei processi di lavoro. È possibile impostare dei limiti per la comunicazione con i processi di lavoro, specificare l'azione da eseguire in caso di errori di alcuni processi e impostare tempi di avvio e di chiusura.

Abilita esecuzione di ping

Consente di configurare Internet Information Services (IIS) per eseguire il ping di ciascun processo di lavoro in un pool di applicazioni nell'intervallo di tempo specificato, in modo da rilevare l'attività dei processi.

IIS controlla l'integrità dei processi di lavoro eseguendone periodicamente il ping per determinare i tempi di risposta. Un processo di lavoro che non risponde al comando ping verrà terminato e ne verrà creato uno sostitutivo.

Ping del processo di lavoro ogni (frequenza in secondi)

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare l'intervallo di tempo, in secondi, in cui verrà eseguito il ping dei processi di lavoro per rilevare l'attività.

Abilita protezione rapida da errori

Consente di configurare IIS per rimuovere dal servizio un pool di applicazioni e impostarlo in una modalità in cui il driver in modalità kernel restituisca immediatamente un errore "503 - Servizio non disponibile" di mancato funzionamento ogni volta che viene fatta una richiesta a quel pool di applicazioni.

La protezione rapida da errori protegge il servizio Internet da interruzioni di vasta portata rilevando e isolando pool di applicazioni i cui processi di lavoro generano errori.

Errori

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare un limite alle interruzioni di programma impreviste. Questo valore deve essere impostato insieme all'impostazione Periodo di tempo.

Periodo di tempo (in minuti)

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare un limite di tempo entro cui rilevare il numero di interruzioni di programma impreviste specificato. Questo valore deve essere impostato insieme all'impostazione Errori.

Limite tempo di avvio

Avvio del processo di lavoro entro (in secondi)

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il tempo di avvio in secondi del processo di lavoro.

Limite tempo di chiusura

Chiusura processo di lavoro entro (in secondi)

Digitare un numero nella casella o utilizzare le frecce Su e Giù per impostare il tempo di chiusura in secondi del processo di lavoro, se rilevato inattivo.

Argomenti correlati

Per ulteriori informazioni sulla protezione rapida da errori, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà pool di applicazioni - Scheda Identità

L'identità di un pool di applicazioni è il nome dell'account con cui viene eseguito il processo di lavoro di un pool di applicazioni. Per impostazione predefinita, i pool di applicazioni utilizzano l'account NetworkService, che dispone dei diritti utente minimi necessari per eseguire applicazioni Web. Questo account fornisce la più elevata sicurezza contro pirati informatici che potrebbero tentare di assumere il controllo del computer in cui viene eseguito il servizio Pubblicazione sul Web (servizio WWW). È possibile configurare i pool di applicazioni affinché vengano eseguiti utilizzando LocalSystem, un account che dispone di un maggior numero di diritti utente rispetto a NetworkService e che, di conseguenza, comporta un più elevato rischio di sicurezza.

Si supponga, ad esempio, che un provider di servizi Internet (ISP) desideri consentire ai clienti di caricare applicazioni CGI (Common Gateway Interface) e aggiungerle a un pool di applicazioni. L'esecuzione di applicazioni CGI in un pool di applicazioni distinto utilizzando l'account NetworkService, con i relativi diritti utente minimi, impedisce che queste applicazioni vengano utilizzate per assumere il controllo del server.

Predefinito

Scegliere dalla casella di riepilogo uno degli account di sicurezza predefiniti.

Configurabile

Consente di configurare la sicurezza del proprio pool di applicazioni specificandone l'identità con un nome utente e la password associata. Se si utilizza un account utente personalizzato, è necessario che tale account appartenga al gruppo IIS_WPG, altrimenti il pool di applicazioni non funzionerà.

Nome utente

Digitare l'alias dell'utente autorizzato ad accedere all'origine dati e alla tabella.

Password

Digitare la password associata al nome utente sopra specificato.

Sfoglia

Consente di visualizzare un elenco di account utente di Windows disponibili per questo server.

Nota

Nelle versioni precedenti di IIS i processi di lavoro vengono eseguiti con l'account LocalSystem. Il fatto che questo account abbia accesso a quasi tutte le risorse comporta gravi rischi di sicurezza. Al fine di ovviare a tali problemi, per impostazione predefinita in IIS 6.O i processi di lavoro vengono eseguiti utilizzando l'account NetworkService, incorporato di recente. IIS 6.0 consente anche di configurare l'account con cui vengono eseguiti i processi di lavoro.

Argomenti correlati

Per ulteriori informazioni sull'account NetworkService e l'account LocalSystem in IIS, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Aggiunta/Modifica identificazione SSL sito Web

Questa finestra di dialogo consente di configurare l'identità Secure Sockets Layer (SSL) per il sito Web. L'identità SSL del sito Web è costituita da un indirizzo IP e da un numero di porta SSL. Nella casella di riepilogo Indirizzo IP vengono visualizzati solo gli indirizzi IP che sono stati configurati per l'utilizzo nel computer in uso tramite il Pannello di controllo. È consentita una sola connessione SSL per ciascun indirizzo IP.

Indirizzo IP

Dalla casella di riepilogo scegliere l'indirizzo IP che si desidera associare alla connessione SSL al sito Web.

Porta SSL

Per specificare il numero di porta utilizzato per la crittografia SSL (Secure Sockets Layer), digitare il numero desiderato nella casella di testo Porta SSL. Il numero di porta predefinito per SSL è 443. È possibile assegnare alla porta un qualsiasi numero univoco, ma per evitare errori nelle richieste di connessione al server, è necessario che i client siano impostati per utilizzare il numero di porta corretto.

Argomenti correlati

Per ulteriori informazioni sulla crittografia di dati tramite SSL, la denominazione dei siti Web e le modalità di utilizzo delle identità del sito Web per indirizzare le richieste del client al sito Web, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Comunicazioni protette

Questa finestra di dialogo consente di configurare le impostazioni Secure Sockets Layer (SSL) per comunicazioni crittografate. Quando un browser che supporta comunicazioni protette si connette a un sito Web configurato per l'utilizzo di SSL con URL che iniziano con https://, i dati da trasferire vengono protetti. Un certificato client è un'identificazione digitale emessa da un'organizzazione di terze parti disponibile nell'elenco locale, denominata Autorità di certificazione. È possibile configurare il server Web in modo che accetti, richieda o rifiuti i certificati client come mezzo per stabilire una connessione con una directory o file specifico. Per gli utenti che tentano di accedere a un sito con certificati client è possibile eseguire il mapping, mentre per quelli privi di certificati sarà necessario ricorrere ad altri metodi di autenticazione. Il mapping dei certificati client consente di associare le informazioni contenute in un certificato client con le informazioni degli account utente di Windows. Un elenco di certificati attendibili (CTL, Certificate Trust List) include le Autorità di certificazione approvate per un particolare sito Web.

Richiedi un canale protetto (SSL)

Consente di configurare IIS affinché un browser possa connettersi al sito Web, alla directory o al file attraverso una comunicazione crittografata. Quando questa opzione è selezionata, tutti i dati trasmessi verso e dal sito Web vengono crittografati utilizzando un certificato.

Richiedi crittografia a 128 bit

Consente di configurare IIS affinché un browser possa connettersi al sito Web, alla directory o al file attraverso una comunicazione crittografata a 128 bit.

Ignora certificati dei client

Consente agli utenti di accedere al sito senza che venga richiesto loro di presentare un certificato client.

Accetta certificati dei client

Consente l'accesso a utenti con certificati client, senza richiedere il certificato. Per gli utenti con certificati client è possibile eseguire il mapping, mentre per quelli privi di certificati sarà necessario ricorrere ad altri metodi di autenticazione.

Richiedi certificati dei client

Consente la connessione solo agli utenti muniti di un certificato client valido. Agli utenti privi di certificato valido verrà negato l'accesso al sito. Prima di selezionare questa opzione per richiedere i certificati client, è necessario selezionare Richiedi un canale protetto (SSL).

Consenti il mapping dei certificati client

Consente di configurare il server per autenticare gli utenti che accedono con un certificato client valido.

Modifica

Consente di modificare un mapping dei certificati client o per crearlo, se non esiste uno. Un utente che accede al sito Web con un certificato disporrà delle stesse autorizzazioni dell'account utente a cui è associato il certificato.

Abilita utilità di mapping servizio directory Windows

Selezionare questa opzione per utilizzare il mapping dei certificati client del servizio directory anziché il mapping uno a uno o molti a uno. Per abilitare questo servizio, è necessario che il server sia un membro del dominio Windows Server 2003.

Abilita elenco certificati attendibili

Consente di modificare CTL esistenti o di crearne uno nuovo. Un CTL è un elenco delle Autorità di certificazione attendibili per un particolare sito Web e applicabili solo a livello di sito Web.

CTL corrente

Scegliere un CTL per il sito.

Nuovo

Consente di creare un nuovo CTL per il sito.

Modifica

Consente di modificare le impostazioni del CTL correntemente selezionato.

Argomenti correlati

Per ulteriori informazioni sui certificati e il relativo mapping, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Comunicazioni protette - Scheda Mapping 1 a 1

Questa scheda consente di modificare i mapping uno a uno. Con i mapping uno a uno, il server Web di accede a una copia in formato testo (ASCII) del certificato client dell'utente. Sul server Web viene eseguito il confronto della copia del certificato client disponibile con il certificato client inviato dal browser. Il mapping viene eseguito se il risultato del confronto indica che i due certificati sono identici. Se un client ottiene un altro certificato contenente le stesse informazioni utente, sarà necessario rieseguirne il mapping. Per associare più certificati a un singolo account, è necessario definire un mapping uno a uno per ogni certificato client.

Modifica mapping

Consente di modificare il mapping correntemente selezionato.

Aggiungi

Consente di associare un certificato client a un account utente di Windows.

Elimina

Consente di eliminare il mapping creato correntemente selezionato, ma non il certificato client.

Argomenti correlati

Per ulteriori informazioni sui certificati e il relativo mapping, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Comunicazioni protette - Scheda Mapping molti a uno

Questa scheda consente di modificare i mapping molti a uno. Con il mapping molti a uno vengono applicate regole jolly di corrispondenza per verificare se un certificato client contiene determinate informazioni, ad esempio il nome dell'autorità emittente o di un oggetto. Con questo tipo di mapping non viene eseguito il confronto con il certificato client effettivo, ma vengono accettati tutti i certificati client che soddisfano i criteri specificati. Se un client riceve un altro certificato contenente le stesse informazioni utente, il mapping esistente continuerà a funzionare correttamente. È possibile utilizzare l'intestazione Descrizione regola per elencare le regole di corrispondenza di un certificato oppure l'intestazione Account Windows con mapping per ordinarle in base all'account a cui sono associate. Per il mapping molti a uno l'esportazione di certificati non è necessaria.

Importante

Per garantire l'applicazione delle modifiche apportate alle regole di corrispondenza, chiudere e riavviare il sito Web.

Abilita regole jolly di corrispondenza per i certificati client

Consente di configurare IIS per abilitare regole di corrispondenza personalizzate che verificano se determinati campi dei certificati client corrispondono a criteri preimpostati.

Modifica regola

Consente di modificare la regola di corrispondenza correntemente selezionata.

Aggiungi

Consente di creare una regola personalizzata che consenta di verificare la presenza di informazioni specifiche nei campi di un certificato client prima di effettuare il mapping del certificato a un account utente di Windows.

Elimina

Consente di rimuovere la regola di corrispondenza correntemente selezionata. Per scegliere più mapping, tenere premuto CTRL mentre si selezionano singoli account oppure tenere premuto MAIUSC mentre si seleziona un intervallo di account.

Sposta su

Consente di spostare la regola correntemente selezionata in una posizione più alta nell'elenco delle regole di corrispondenza. Lo spostamento di una regola verso l'alto corrisponde all'assegnazione di una maggiore priorità.

Sposta giù

Consente di spostare una regola in una posizione più bassa nell'elenco delle regole di corrispondenza. Lo spostamento di una regola verso il basso corrisponde all'assegnazione di una minore priorità.

Nota

Se due regole definite per gli stessi criteri del certificato sono in conflitto, verrà utilizzata la regola con la priorità più alta, mentre l'altra verrà ignorata. È possibile ordinare le regole in base al nome facendo clic sull'intestazione Descrizione regola oppure in base all'account a cui sono associate facendo clic sull'intestazione Account Windows con mapping.

Argomenti correlati

Per ulteriori informazioni sui certificati e il relativo mapping, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Modifica regola jolly di mapping - Scheda Generale

La finestra di dialogo Modifica regola jolly di mapping e le relative schede consentono di creare regole personalizzate per eseguire il mapping tra certificati client e account utente di Windows. L'editor consente di verificare se determinati campi del certificato client corrispondono a criteri preimpostati. I certificati client possono contenere informazioni di identificazione, quali nomi di aziende, luoghi o indirizzi di posta elettronica, formattate in strutture di campi e campi secondari.

È possibile creare le regole in qualsiasi momento e abilitarle in un momento successivo.

Nella scheda Generale sono disponibili le seguenti opzioni:

Abilita questa regola jolly

Consente di configurare IIS per abilitare la regola jolly correntemente selezionata.

Descrizione

Digitare un commento facoltativo.

Argomenti correlati

Per ulteriori informazioni sui certificati e il relativo mapping, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Modifica regola jolly di mapping - Scheda Regole

Questa scheda consente di creare regole di corrispondenza per verificare se determinati campi del certificato client corrispondono a criteri preimpostati. Se un campo o un campo secondario corrisponde ai criteri, il certificato verrà associato a un account utente di Windows. Fare clic sull'intestazione di colonna Campo certificato, Campo secondario o Criteri di corrispondenza per ordinare l'elenco in base al relativo tipo di informazioni.

Modifica

Consente di modificare il campo del certificato correntemente selezionato e i relativi criteri di corrispondenza.

Nuovo

Consente di creare un nuovo campo del certificato e i relativi criteri di corrispondenza con la finestra di dialogo Modifica elemento regola.

Elimina

Consente di eliminare il campo del certificato correntemente selezionato e i relativi criteri di corrispondenza.

Argomenti correlati

Per ulteriori informazioni sui certificati e il relativo mapping, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Modifica elemento regola

Questa finestra di dialogo consente di creare o modificare gli elementi di una regola di corrispondenza. I certificati client possono contenere informazioni di identificazione, quali nomi di aziende, luoghi o indirizzi di posta elettronica, formattate in strutture di campi e campi secondari. Queste informazioni di identificazione possono essere utilizzate dal server Web per associare l'identità dell'utente a un account utente di Windows.

I nomi dei campi rappresentano le categorie di informazioni generali, quali Oggetto (Client) e Autorità emittente. Per ulteriori informazioni sui campi e i campi secondari di un certificato, consultare la documentazione relativa all'Autorità di certificazione emittente.

I nomi dei campi secondari rappresentano informazioni specifiche di ciascuna categoria generale Oggetto e Autorità emittente. Nell'elenco seguente vengono descritti i campi secondari di base contenuti in un certificato:

(O) Organizzazione

L'organizzazione o società di alto livello, preferibilmente registrata secondo le norme ISO.

(OU) Unità organizzativa

Un reparto all'interno di una società, ad esempio Marketing.

(CN) Nome comune

Il nome del dominio del server, ad esempio www.microsoft.com/italy/

(C) Paese

L'identificativo ISO di due caratteri del paese, ad esempio IT, US, UK e così via.

(S) Stato o provincia

Il nome completo, non abbreviato, della provincia, ad esempio Bologna o Milano, anziché MI o BO.

(L) Località

Il nome completo della città in cui ha sede la propria società, ad esempio Roma o Torino.

Sono supportate anche alcune categorie di campi secondari non standard, tra cui:

(I) Iniziali

Le iniziali del proprietario del certificato.

(GN) Nome specificato

Il nome del proprietario del certificato.

(T) Titolo

Il titolo del proprietario del certificato.

(Posta elettronica)

L'indirizzo di posta elettronica del proprietario del certificato.

Per informazioni aggiornate sui campi secondari, contattare un'autorità di certificazione.

Corrispondenza maiuscole/minuscole

Consente di configurare IIS per abilitare la distinzione tra maiuscole e minuscole nell'elemento della regola.

Campo certificato

Scegliere dalla casella di riepilogo un elemento del campo certificato di una regola di corrispondenza. Questo elemento deve essere scelto prima degli altri elementi nella finestra di dialogo.

Campo secondario

Scegliere dalla casella di riepilogo un elemento secondario del campo certificato di una regola di corrispondenza. Selezionare innanzitutto un elemento nella casella di riepilogo Campo certificato per visualizzare l'intero elenco di campi secondari validi.

Criterio

Specificare il criterio per la corrispondenza delle informazioni contenute nei campi e nei campi secondari. Se, ad esempio, il campo secondario è "O", come criterio si potrebbe specificare "Microsoft" per indicare a quale organizzazione deve corrispondere la regola di corrispondenza. È anche possibile utilizzare il carattere jolly (*) per specificare solo in parte il testo del criterio.

Argomenti correlati

Per ulteriori informazioni sui certificati e il relativo mapping, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Modifica regola jolly di mapping - Scheda Mapping

Questa scheda consente di specificare l'azione che deve essere eseguita quando un client Web invia un certificato che corrisponde ai criteri specificati nelle schede precedenti. È possibile rifiutare l'accesso al sito Web oppure eseguire il mapping tra l'identità dell'utente e un account utente specifico di Windows.

Accetta il certificato per l'autenticazione di accesso

Consente di configurare IIS per concedere l'accesso a risorse sul sito Web per qualsiasi certificato che corrisponde alle regole specificate.

Nega accesso

Consente di configurare IIS per negare l'accesso a risorse sul sito Web per qualsiasi certificato che corrisponde alle regole specificate.

Account

Digitare l'account utente di Windows da utilizzare come identità del client.

Sfoglia

Consente di visualizzare un elenco di account utente di Windows disponibili per questo server. Se durante l'esplorazione del sito Web si individua l'account che si desidera utilizzare come identità del client, sceglierlo dall'elenco. Il nome verrà visualizzato nella casella Account.

Password

Digitare la password dell'account utente di Windows visualizzato nella casella Account. Se si modifica la password in Windows, occorre modificarla anche in questa casella.

Applica

Consente di completare la creazione del mapping degli account dei certificati.

Argomenti correlati

Per ulteriori informazioni sui certificati e il relativo mapping, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda Home directory

Questa pagina delle proprietà consente di creare e gestire siti Web sul server IIS. Le impostazioni incluse in questa scheda sono simili a quelle disponibili nella scheda Home directory delle directory virtuali.

L'impostazione di percorsi locali o di rete consente di indirizzare la richiesta alla posizione fisica corretta. È possibile configurare ulteriormente la posizione fisica impostando i diritti di accesso dell'utente, scegliendo se registrare le richieste per queste risorse e se indicizzare un sito utilizzando Servizio indicizzazione. Per soddisfare la richiesta quando viene ricevuta, è necessario identificare e individuare le applicazioni e assegnare loro le autorizzazioni di esecuzione e la protezione appropriate.

Provenienza del contenuto della risorsa

Questa impostazione consente di definire il percorso della home directory del sito Web.

Una directory nel proprio computer

Scegliere questa opzione per consentire agli utenti di accedere a una determinata directory sul computer per visualizzare o aggiornare il contenuto Web. È possibile digitare il nome della directory nella casella di testo Percorso locale. È possibile controllare l'accesso al contenuto implementando un qualsiasi metodo di sicurezza di Windows.

Directory condivisa situata in un altro computer

Scegliere questa opzione per consentire agli utenti di visualizzare o aggiornare il contenuto Web in un altro computer con cui esiste una connessione attiva. Se si dispone di credenziali di amministrazione sul computer remoto, è possibile controllare l'accesso al contenuto implementando un qualsiasi metodo di sicurezza di Windows. Quando l'opzione è selezionata, è possibile immettere il nome del server e il nome della directory nella casella Directory di rete. Fare clic su Connetti come per immettere il nome utente e la password di rete.

Reindirizzamento a un URL

Consente di reindirizzare l'applicazione client, ad esempio un browser, a un altro sito Web o a una directory virtuale immettendo un URL nella casella Reindirizza a. Quando questa opzione è selezionata, le opzioni relative al reindirizzamento vengono sostituite con quelle relative al percorso.

Se si sceglie Directory situata in questo computer o Directory condivisa situata in un altro computer, saranno disponibili le seguenti opzioni:

Percorso locale

Quando il contenuto proviene da una directory situata in questo computer, nella casella viene visualizzato il percorso della directory in cui sono memorizzati i file del sito Web. Per impostazione predefinita, questi file vengono archiviati nella directory systemdrive\inetpub\wwwroot.

Sfoglia

Consente di individuare il percorso della directory.

Directory di rete

Quando il contenuto proviene da un altro computer sulla rete, nella casella viene visualizzato il nome del computer e il nome condivisione in cui si trova il contenuto.

Connetti come

Quando il contenuto proviene da un altro computer sulla rete, fare clic per fornire un nome utente e una password per accedere alla condivisione di rete.

Accesso origine script

Scegliere questa opzione per consentire agli utenti di accedere al codice sorgente se è impostata l'autorizzazione Accesso in lettura o Accesso in scrittura. Il codice sorgente include anche gli script di applicazioni ASP.

Lettura

Scegliere questa opzione per consentire agli utenti di leggere o scaricare file o directory e le rispettive proprietà.

Scrittura

Scegliere questa opzione per consentire agli utenti di caricare i file e le rispettive proprietà nella directory abilitata sul server oppure modificare il contenuto in un file abilitato per la scrittura. L'accesso in scrittura è consentito solo con un browser che supporta la funzionalità PUT dello standard del protocollo HTTP 1.1.

Esplorazione cartelle

Scegliere questa opzione per consentire agli utenti di visualizzare un elenco ipertestuale dei file e delle sottodirectory contenuti nella directory virtuale. Dato che l'elenco non include le directory virtuali, gli utenti ne devono conoscere l'alias. Se la funzionalità Esplorazione cartelle è disabilitata e l'utente non ha specificato un nome file, nel browser Web dell'utente verrà visualizzato il messaggio di errore "Accesso non autorizzato".

Registra visite

Consente di configurare IIS per registrare le visite alla directory in un file di registro. Le visite vengono registrate soltanto se per il sito Web è abilitata la registrazione.

Indicizza questa risorsa

Consente a Servizio indicizzazione Microsoft di includere la directory in un indice full-text del sito Web.

Nota

Prima di impostare questa opzione, è necessario abilitare il Servizio di indicizzazione tramite Installazione applicazioni nel Pannello di controllo.

Nome applicazione

Digitare il nome della directory radice in cui sono contenuti i file e le sottodirectory di un'applicazione.

Punto di partenza

Visualizza il nodo della metabase in cui è configurata l'applicazione.

Autorizzazioni di esecuzione

Mediante questa opzione si determina il livello di esecuzione del programma consentito per le risorse di questo sito.

  • Impostare le autorizzazioni su Nessuno per limitare l'accesso solo a file statici, quali file HTML o di immagine.

  • Impostare le autorizzazioni su Script per consentire l'esecuzione solo di script, non di file eseguibili.

  • Impostare le autorizzazioni su Script e file eseguibili per rimuovere tutte le restrizioni in modo che sia possibile accedere a tutti i tipi di file ed eseguirli.

Pool di applicazioni

Scegliere dalla casella di riepilogo il pool di applicazioni associato a questa home directory.

Rimuovi/Crea

Consente di rimuovere un'applicazione dal sito Web o crearne una lasciando intatta la directory virtuale.

Configurazione

Consente di configurare i mapping, le opzioni e le funzionalità di debug dell'applicazione.

Scaricamento

Consente di scaricare dalla memoria un'applicazione isolata o appartenente a un pool a cui nessun'altra applicazione fa riferimento.

Se si sceglie Reindirizzamento a un URL, saranno disponibili le seguenti opzioni:

Reindirizza a

Digitare un URL completo da cui verrà recuperato il contenuto.

URL sopra specificato

Scegliere questa opzione per reindirizzare una directory virtuale all'URL di destinazione senza l'aggiunta di altre parti dell'URL originale. È possibile reindirizzare un'intera directory virtuale a un file. Per reindirizzare, ad esempio, tutte le richieste per la directory virtuale /scripts al file Default.htm nella home directory, digitare /Default.htm nella casella Reindirizza a e selezionare questa opzione.

Sottodirectory dell'URL immesso

Scegliere questa opzione per reindirizzare una directory padre a una directory figlio. Per reindirizzare, ad esempio, la home directory, indicata dal carattere /, a una sottodirectory denominata /nuovahome, digitare /nuovahome nella casella Reindirizza a e selezionare questa opzione. Se l'opzione non è selezionata, il server Web continuerà a reindirizzare la directory superiore a se stessa.

Reindirizzamento permanente per la risorsa

Fare clic su questa opzione per inviare al client il messaggio "301 - Reindirizzamento permanente". I reindirizzamenti verranno considerati temporanei e il browser client riceverà il messaggio "302 - Reindirizzamento temporaneo". Alcuni browser possono interpretare il messaggio "301" come istruzione di modificare un URL in modo definitivo, ad esempio un segnalibro.

Argomenti correlati

Per ulteriori informazioni sulla home directory, le variabili e i caratteri jolly di reindirizzamento e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Credenziali di sicurezza directory di rete

Questa finestra di dialogo consente di stabilire delle credenziali di sicurezza per accedere alla condivisione di rete da cui verrà recuperato il contenuto.

Nota

Le caselle Nome utente e Password non saranno disponibili se l'opzione Utilizza sempre le credenziali autenticate dell'utente nel convalidare l'accesso alla directory di rete nella parte inferiore della finestra di dialogo è selezionata. Per stabilire un nome utente e una password per tutti gli utenti quando accedono a questa condivisione, deselezionare questa casella di controllo.

Nome utente

Digitare un nome utente. Questo nome verrà utilizzato per tutte le connessioni client alla condivisione remota.

Password

Digitare una password. Questa password verrà utilizzata per tutte le connessioni client alla condivisione remota.

Sfoglia

Consente di individuare il percorso della directory.

Utilizza sempre le credenziali autenticate dell'utente nel convalidare l'accesso alla directory di rete.

Quando questa opzione è selezionata, i tentativi di connessione alla condivisione remota vengono convalidati in funzione del nome e della password dell'utente connesso. Se questa opzione è deselezionata, tutte le connessioni client alla condivisione remota utilizzeranno il nome utente e la password specificati.

Argomenti correlati

Per ulteriori informazioni sulla sicurezza delle directory, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà directory virtuale del sito Web - Scheda Directory virtuale

Questa scheda consente di creare e gestire directory virtuali sul sito Web. Le directory virtuali sono puntatori a file e cartelle Web memorizzati nel computer e vengono utilizzati per la gestione del contenuto. La configurazione di directory virtuali è simile alla configurazione di siti Web.

L'impostazione di percorsi locali o di rete consente di indirizzare la richiesta alla posizione fisica corretta. È possibile configurare ulteriormente la posizione fisica impostando i diritti di accesso dell'utente, scegliendo se registrare le richieste per queste risorse e se indicizzare un sito utilizzando Servizio indicizzazione. Per soddisfare la richiesta quando viene ricevuta, è necessario identificare e individuare le applicazioni e assegnare loro le autorizzazioni di esecuzione e la protezione appropriate.

Provenienza del contenuto della risorsa

Mediante questa impostazione si definisce la provenienza del contenuto di questa directory virtuale.

Una directory nel proprio computer

Scegliere questa opzione per consentire agli utenti di accedere a una determinata directory sul computer per visualizzare o aggiornare il contenuto Web. È possibile digitare il nome della directory nella casella di testo Percorso locale. È possibile controllare l'accesso al contenuto implementando un qualsiasi metodo di sicurezza di Windows.

Directory condivisa situata in un altro computer

Scegliere questa opzione per consentire agli utenti di visualizzare o aggiornare il contenuto Web in un altro computer con cui esiste una connessione attiva. Se si dispone di credenziali di amministrazione sul computer remoto, è possibile controllare l'accesso al contenuto implementando un qualsiasi metodo di sicurezza di Windows. Quando l'opzione è selezionata, è possibile immettere il nome del server e il nome della directory nella casella Directory di rete. Fare clic su Connetti come per immettere il nome utente e la password di rete.

Reindirizzamento a un URL

Consente di reindirizzare l'applicazione client, quale un browser, a un altro sito Web o a una directory virtuale. Quando questa opzione è selezionata, le opzioni relative al reindirizzamento vengono sostituite con quelle relative al percorso.

Se si sceglie Directory situata in questo computer o Directory condivisa situata in un altro computer, saranno disponibili le seguenti opzioni:

Percorso locale

Quando il contenuto proviene da una directory situata in questo computer, nella casella viene visualizzato il percorso della directory in cui sono memorizzati i file del sito Web. Per impostazione predefinita, questi file vengono archiviati nella directory systemdrive\inetpub\wwwroot.

Sfoglia

Consente di individuare il percorso della directory.

Accesso origine script

Scegliere questa opzione per consentire agli utenti di accedere al codice sorgente se è impostata l'autorizzazione Accesso in lettura o Accesso in scrittura. Il codice sorgente include anche gli script di applicazioni ASP.

Lettura

Scegliere questa opzione per consentire agli utenti di leggere o scaricare file o directory e le rispettive proprietà.

Scrittura

Scegliere questa opzione per consentire agli utenti di caricare i file e le rispettive proprietà nella directory abilitata sul server oppure modificare il contenuto in un file abilitato per la scrittura. L'accesso in scrittura è consentito solo con un browser che supporta la funzionalità PUT dello standard del protocollo HTTP 1.1.

Esplorazione cartelle

Scegliere questa opzione per consentire agli utenti di visualizzare un elenco ipertestuale dei file e delle sottodirectory contenuti nella directory virtuale. Dato che l'elenco non include le directory virtuali, gli utenti ne devono conoscere l'alias. Se la funzionalità Esplorazione cartelle è disabilitata e l'utente non ha specificato un nome file, nel browser Web dell'utente verrà visualizzato il messaggio di errore "Accesso non autorizzato".

Registra visite

Consente di configurare IIS per registrare le visite alla directory in un file di registro. Le visite vengono registrate soltanto se per il sito Web è abilitata la registrazione.

Indicizza questa risorsa

Consente a Servizio indicizzazione Microsoft di includere la directory in un indice full-text del sito Web.

Nota

Prima di impostare questa opzione, è necessario abilitare il Servizio di indicizzazione tramite Installazione applicazioni nel Pannello di controllo.

Nome applicazione

Digitare il nome della directory radice in cui sono contenuti i file e le sottodirectory di un'applicazione.

Punto di partenza

Visualizza il nodo della metabase in cui è configurata l'applicazione.

Autorizzazioni di esecuzione

Mediante questa opzione si determina il livello di esecuzione del programma consentito per le risorse di questo sito.

  • Impostare le autorizzazioni su Nessuno per limitare l'accesso solo a file statici, quali file HTML o di immagine.

  • Impostare le autorizzazioni su Script per consentire l'esecuzione solo di script, non di file eseguibili.

  • Impostare le autorizzazioni su Script e file eseguibili per rimuovere tutte le restrizioni in modo che sia possibile accedere a tutti i tipi di file ed eseguirli.

Pool di applicazioni

Scegliere dalla casella di riepilogo il pool di applicazioni associato a questa home directory.

Rimuovi/Crea

Consente di rimuovere un'applicazione dal sito Web o crearne una lasciando intatta la directory virtuale.

Configurazione

Consente di configurare i mapping, le opzioni e le funzionalità di debug dell'applicazione.

Scaricamento

Consente di scaricare dalla memoria un'applicazione isolata o appartenente a un pool a cui nessun'altra applicazione fa riferimento.

Se si sceglie Reindirizzamento a un URL, saranno disponibili le seguenti opzioni:

Reindirizza a

Digitare un URL completo da cui verrà recuperato il contenuto.

URL sopra specificato

Scegliere questa opzione per reindirizzare una directory virtuale all'URL di destinazione senza l'aggiunta di altre parti dell'URL originale. È possibile reindirizzare un'intera directory virtuale a un file. Per reindirizzare, ad esempio, tutte le richieste per la directory virtuale /scripts al file Default.htm nella home directory, digitare /Default.htm nella casella Reindirizza a e selezionare questa opzione.

Sottodirectory dell'URL immesso

Scegliere questa opzione per reindirizzare una directory padre a una directory figlio. Per reindirizzare, ad esempio, la home directory, indicata dal carattere /, a una sottodirectory denominata /nuovahome, digitare /nuovahome nella casella Reindirizza a e selezionare questa opzione. Se l'opzione non è selezionata, il server Web continuerà a reindirizzare la directory superiore a se stessa.

Reindirizzamento permanente per la risorsa

Fare clic su questa opzione per inviare al client il messaggio "301 - Reindirizzamento permanente". I reindirizzamenti verranno considerati temporanei e il browser client riceverà il messaggio "302 - Reindirizzamento temporaneo". Alcuni browser possono interpretare il messaggio "301" come istruzione di modificare un URL in modo definitivo, ad esempio un segnalibro.

Argomenti correlati

Per ulteriori informazioni sulla registrazione dell'attività di un sito e la sicurezza delle directory, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà directory virtuale - Scheda Directory virtuale per file

Questa scheda consente di creare e gestire directory virtuali sul sito Web. Le directory virtuali sono puntatori a file e cartelle Web memorizzati nel computer e vengono utilizzati per la gestione del contenuto. La configurazione di directory virtuali è simile alla configurazione di siti Web. Il contenuto della directory virtuale può provenire da una o più delle seguenti origini:

Provenienza del contenuto della risorsa

Mediante questa impostazione si definisce la provenienza del contenuto di questa directory virtuale.

File selezionato

Consente di specificare il file predefinito inizialmente visualizzato nel client o eseguito nel server quando il browser invia una richiesta al sito. È possibile controllare l'accesso a questo file implementando un qualsiasi metodo di sicurezza di Windows.

Reindirizzamento a un URL

Consente di reindirizzare l'applicazione client, quale un browser, a un altro sito Web o a una directory virtuale. Quando questa opzione è selezionata, le opzioni relative al reindirizzamento vengono sostituite con quelle relative al percorso.

Percorso locale

Quando il contenuto proviene da una directory situata in questo computer, nella casella viene visualizzato il percorso della directory in cui sono memorizzati i file del sito Web. Per impostazione predefinita, questi file vengono archiviati nella directory systemdrive\inetpub\wwwroot.

Sfoglia

Consente di individuare il percorso della directory.

Accesso origine script

Scegliere questa opzione per consentire agli utenti di accedere al codice sorgente se è impostata l'autorizzazione Accesso in lettura o Accesso in scrittura. Il codice sorgente include anche gli script di applicazioni ASP.

Lettura

Scegliere questa opzione per consentire agli utenti di leggere o scaricare file o directory e le rispettive proprietà.

Scrittura

Scegliere questa opzione per consentire agli utenti di caricare i file e le rispettive proprietà nella directory abilitata sul server oppure modificare il contenuto in un file abilitato per la scrittura. L'accesso in scrittura è consentito solo con un browser che supporta la funzionalità PUT dello standard del protocollo HTTP 1.1.

Esplorazione cartelle

Scegliere questa opzione per consentire agli utenti di visualizzare un elenco ipertestuale dei file e delle sottodirectory contenuti nella directory virtuale. Dato che l'elenco non include le directory virtuali, gli utenti ne devono conoscere l'alias. Se la funzionalità Esplorazione cartelle è disabilitata e l'utente non ha specificato un nome file, nel browser Web dell'utente verrà visualizzato il messaggio di errore "Accesso non autorizzato".

Registra visite

Consente di configurare IIS per registrare le visite alla directory in un file di registro. Le visite vengono registrate soltanto se per il sito Web è abilitata la registrazione.

Argomenti correlati

Per ulteriori informazioni sulla registrazione dell'attività di un sito e le directory virtuali, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Nuova estensione servizio Web

Allo scopo di ridurre la vulnerabilità del proprio server Web alle intrusioni, IIS 6.0 fornisce solo contenuto statico dopo un'installazione predefinita. Le funzionalità a livello di programmazione fornite dalle applicazioni API di IIS (ISAPI) o Common Gateway Interfaces (CGI) devono essere abilitate manualmente da un amministratore di IIS. Le applicazioni ISAPI e CGI consentono di estendere le capacità delle pagine Web e per questo motivo vengono denominate estensioni del servizio Web. Per eseguire, ad esempio, Active Server Pages (ASP) con la versione corrente di IIS, è necessario abilitare ISAPI Asp.dll come nuova estensione del servizio Web.

Le opzioni disponibili in questa finestra di dialogo consentono di abilitare o disabilitare applicazioni ISAPI o CGI specifiche.

Nota

I filtri ISAPI non sono considerati come estensioni del servizio Web e non vengono abilitati attraverso questa finestra di dialogo.

Nota

Affinché sia possibile eseguire un'estensione del servizio Web, è necessario che l'applicazione ISAPI o CGI si trovi nella directory del contenuto nel server in cui è in esecuzione IIS, ad esempio UnitàLocale:\Inetpub\wwwroot nel caso di un'installazione predefinita.

Nome estensione

Digitare il nome descrittivo dell'applicazione ISAPI o CGI, ad esempio le estensioni del server di Microsoft® FrontPage®.

File richiesti

È un elenco di tutte le applicazioni ISAPI o CGI richieste per eseguire l'estensione del servizio Web. Le estensioni del server di FrontPage, ad esempio, sono costituite da cinque file che devono essere tutti abilitati per poter estendere le pagine Web.

Aggiungi

Consente di scegliere i file richiesti.

Rimuovi

Consente di rimuovere il file correntemente selezionato dall'elenco.

Imposta lo stato dell'estensione su Consentito

Consente di eseguire le estensioni del servizio Web sul server. Deselezionare questa opzione per impedire che le estensioni del servizio Web vengano eseguite sul server Web. Se, ad esempio, in questa finestra di dialogo si immettono informazioni relative a Nimda.dll e si imposta lo stato su Proibisci, lo stato predefinito quando l'opzione è deselezionata, si impedirà l'esecuzione di Nimda.dll sul server Web.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Uso di tutte le estensioni servizio Web per un'applicazione specifica

Questa finestra di dialogo consente di abilitare le estensioni del servizio Web per le proprie applicazioni. Se un'applicazione si arresta improvvisamente, utilizzare questa finestra di dialogo per confermare e abilitare tutte le estensioni del servizio Web per tale applicazione.

Applicazione

Scegliere il nome dell'applicazione dalla casella di riepilogo.

Estensioni da consentire

È un elenco di tutte le estensioni del servizio Web richieste per l'applicazione correntemente selezionata.

Nota

Scegliere OK per attivare l'elenco di estensioni del servizio Web consentite per l'applicazione selezionata.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà estensione servizio Web - Scheda Generale

Questa scheda consente di decidere se disabilitare un'estensione del servizio Web. Se non si consente l'estensione del servizio Web corrente, le applicazioni incluse nell'elenco Utilizzato da potrebbero smettere di funzionare correttamente, così come altre applicazioni non elencate nella finestra di dialogo. Internet Information Services (IIS) potrebbe infatti non rilevare altre dipendenze che impediscono la corretta esecuzione delle applicazioni.

Utilizzato da

È un elenco di applicazioni che utilizzano l'estensione del servizio Web specificata, indicata nella parte superiore della scheda.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà estensione server Web - Scheda File richiesti

Questa scheda consente di effettuare le operazioni riportate di seguito.

  • Visualizzare un elenco di file richiesti per l'estensione del servizio Web specificata.

  • Aggiungere o rimuovere file per l'estensione del servizio Web specificata.

  • Personalizzare la sicurezza per l'estensione del servizio Web specificata, consentendo o impedendo l'esecuzione di file.

File

È un elenco dei file richiesti e del relativo stato per l'estensione del servizio Web specificata.

Aggiungi

Consente di aggiungere un file richiesto all'elenco.

Rimuovi

Consente di rimuovere il file correntemente selezionato dall'elenco.

Consenti

Consente di eseguire il file correntemente selezionato sul server Web.

Proibisci

Consente di impedire l'esecuzione del file correntemente selezionato sul server Web.

Nota

Se tutti i file richiesti non hanno lo stesso stato, ad esempio un file ha lo stato Non consentito mentre gli altri file hanno lo stato Consentito, lo stato dell'estensione del servizio Web sarà Personalizzato.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Non consentire le estensioni del servizio Web

Se si impedisce l'esecuzione sul server Web a tutte le estensioni del servizio Web, le applicazioni perderanno parte della loro funzionalità o smetteranno del tutto di funzionare. Internet Information Services (IIS) potrà fornire solo contenuto statico. In caso di dubbi sul possibile impatto sulle applicazioni se non si consentono le estensioni del servizio Web, fare clic su ciascuna estensione del servizio Web e prendere nota delle applicazioni dipendenti incluse nell'elenco Utilizzato da nella scheda Generale.

Nota

IIS potrebbe non rilevare tutte le applicazioni la cui esecuzione dipende da specifiche estensioni del servizio Web. Se si impediscono tutte le estensioni dei servizio Web, anche altre applicazioni non elencate nella scheda Generale potrebbero smettere di funzionare.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Tutte le estensioni ISAPI sconosciute

Allo scopo di ridurre la vulnerabilità del proprio server Web alle intrusioni, IIS 6.0 fornisce solo contenuto statico dopo un'installazione predefinita. Le funzionalità a livello di programmazione fornite dalle applicazioni ISAPI o Common Gateway Interfaces (CGI) devono essere abilitate manualmente da un amministratore di IIS. Le applicazioni ISAPI e CGI consentono di estendere le capacità delle pagine Web e per questo motivo vengono denominate estensioni del servizio Web. Per eseguire, ad esempio, Active Server Pages (ASP) con la versione corrente di IIS, è necessario abilitare ISAPI Asp.dll come nuova estensione del servizio Web.

Importante

Se si sceglie di consentire l'esecuzione di tutte le applicazioni Application Program Interfaces di IIS (ISAPI) nel server Web, questo potrebbe diventare vulnerabile a virus o worm che sfruttano la tecnologia ISAPI. Utilizzare piuttosto il nodo Estensioni servizio Web in Gestione IIS per selezionare solo le applicazioni ISAPI a cui è consentita l'esecuzione nel server Web.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Tutte le estensioni CGI sconosciute

Allo scopo di ridurre la vulnerabilità del proprio server Web alle intrusioni, IIS 6.0 fornisce solo contenuto statico dopo un'installazione predefinita. Le funzionalità a livello di programmazione fornite dalle applicazioni ISAPI o Common Gateway Interfaces (CGI) devono essere abilitate manualmente da un amministratore di IIS. Le applicazioni ISAPI e CGI consentono di estendere le capacità delle pagine Web e per questo motivo vengono denominate estensioni del servizio Web. Per eseguire, ad esempio, Active Server Pages (ASP) con la versione corrente di IIS, è necessario abilitare ISAPI Asp.dll come nuova estensione del servizio Web.

Importante

Se si sceglie di consentire l'esecuzione di tutte le applicazioni Common Gateway Interfaces (CGI) nel server Web, questo potrebbe diventare vulnerabile a virus o worm che sfruttano la tecnologia CGI. Utilizzare piuttosto il nodo Estensioni servizio Web in Gestione IIS per selezionare solo le applicazioni CGI a cui è consentita l'esecuzione nel server Web.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Conferma disabilitazione delle estensioni

Internet Information Services (IIS) potrebbe non rilevare tutte le applicazioni che dipendono da questa estensione del servizio Web, pertanto se la si disabilita anche altre applicazioni non elencate potrebbero arrestarsi.

Argomenti correlati

Per ulteriori informazioni sulle estensioni del servizio Web e la configurazione di applicazioni, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà sito Web - Scheda File

Le opzioni di questa scheda consentono di determinare la provenienza del contenuto e le autorizzazioni dell'utente per questo file.

Provenienza del contenuto della risorsa

File selezionato

Scegliere questa opzione se tutto il contenuto si trova nel file correntemente selezionato.

Reindirizzamento a un URL

Consente di reindirizzare l'applicazione client, quale un browser, a un altro sito Web o a una directory virtuale. Quando questa opzione è selezionata, le opzioni relative al reindirizzamento vengono sostituite con quelle relative al percorso.

L'impostazione di percorsi locali o di rete consente di indirizzare la richiesta alla posizione fisica corretta. È possibile configurare ulteriormente la posizione fisica impostando le proprietà di accesso dell'utente, scegliendo se registrare le richieste per queste risorse e se indicizzare un sito utilizzando Servizio indicizzazione. Per soddisfare la richiesta quando viene ricevuta, è necessario identificare e individuare le applicazioni e assegnare loro le autorizzazioni di esecuzione e la protezione appropriate.

Nota

Il Servizio indicizzazione può essere attivato tramite Installazione applicazioni nel Pannello di controllo.

Se si fa clic su File designato, saranno disponibili le seguenti opzioni:

Accesso origine script

Scegliere questa opzione per consentire agli utenti di accedere al codice sorgente se è impostata l'autorizzazione Accesso in lettura o Accesso in scrittura.

Lettura

Consente agli utenti di leggere o scaricare il file.

Scrittura

Consente agli utenti di modificare il contenuto del file correntemente selezionato. Le operazioni di scrittura possono essere eseguite solo con un browser che supporta la funzionalità PUT dello standard del protocollo HTTP 1.1.

Registra visite

Consente di configurare IIS per registrare le visite al file correntemente selezionato in un file di registro. Le visite vengono registrate soltanto se per il sito Web è abilitata la registrazione.

Se si fa clic su File designato, saranno disponibili le seguenti opzioni:

Reindirizza a

Digitare l'URL di destinazione a cui verrà inviato il client.

URL sopra specificato

Scegliere questa opzione per reindirizzare le richieste a questa risorsa all'URL di destinazione senza aggiungere altre parti dell'URL originale.

Reindirizzamento permanente per la risorsa

Fare clic su questa opzione per inviare al client il messaggio "301 - Reindirizzamento permanente". Nella maggior parte dei casi, i reindirizzamenti verranno considerati temporanei e il browser client riceverà il messaggio "302 - Reindirizzamento temporaneo". Alcuni browser possono interpretare il messaggio "301" come istruzione di modificare un URL in modo definitivo, ad esempio un segnalibro.

Argomenti correlati

Per ulteriori informazioni sulla registrazione dell'attività di un sito e la configurazione di un sito Web, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Importa configurazione

Con Internet Information Services (IIS) 6.0, è possibile importare ed esportare la configurazione di siti FTP, pool di applicazioni Web e siti Web. Prima di importare un file di configurazione, è necessario esportare un file di configurazione da un sito FTP, un pool di applicazioni Web o un sito Web esistente. L'operazione di esportazione di un file di configurazione in Gestione IIS è denominata Salva la configurazione in un file. La configurazione esportata viene memorizzata in un file di configurazione XML della metabase. Dopo aver esportato il file di configurazione, è possibile importarlo in un'altra posizione sullo stesso server Web o in un altro.

L'esportazione e l'importazione di siti e pool di applicazioni come file di configurazione consente agli amministratori di effettuare velocemente la migrazione di siti e pool di applicazioni tra server. Inoltre, tramite questa funzione, gli amministratori sono in grado importare applicazioni Web quando lo sviluppatore ha memorizzato l'applicazione in un file di configurazione.

File

Digitare il percorso completo del file di configurazione.

Sfoglia

Consente di individuare il file di configurazione.

Leggi file

Consente di completare la casella di riepilogo Selezionare la configurazione da importare con tutte le configurazioni contenute nel file di configurazione selezionato.

Scegliere la configurazione da importare

Un file di configurazione XML della metabase può contenere varie configurazioni. Dopo avere selezionato Leggi file, questa casella di riepilogo verrà automaticamente completata con tutte le configurazioni contenute nel file di configurazione XML selezionato. Fare clic su una configurazione nell'elenco, quindi scegliere OK per importare la configurazione.

Argomenti correlati

Per ulteriori informazioni sui file di configurazione della metabase, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Salva la configurazione in un file

Con Internet Information Services (IIS) 6.0, è possibile importare ed esportare la configurazione di siti FTP, pool di applicazioni Web e siti Web. Quando si salva una configurazione in un file, tutte le configurazioni della proprietà della metabase per siti FTP, pool di applicazioni Web o siti Web correntemente selezionati vengono esportati in un file di configurazione XML della metabase. Dopo aver esportato il file di configurazione, è possibile importarlo in un'altra posizione sullo stesso server Web o in un altro. L'esportazione e l'importazione di siti e pool di applicazioni come file di configurazione consente agli amministratori di effettuare velocemente la migrazione di siti e pool di applicazioni tra server. Inoltre, tramite questa funzione, gli amministratori possono esportare applicazioni Web quando lo sviluppatore ha memorizzato l'applicazione in un file di configurazione.

L'operazione di esportazione di un file di configurazione in Gestione IIS è denominata Salva la configurazione in un file. Questa finestra di dialogo consente di memorizzare la configurazione esportata come un file di configurazione XML della metabase. Dopo aver esportato il file di configurazione, è possibile importarlo in un'altra posizione sullo stesso server Web o in un altro.

Nome file

Digitare un nome per il file di configurazione.

Percorso

Digitare il percorso completo in cui si desidera memorizzare il file di configurazione.

Sfoglia

Consente di individuare il percorso completo in cui si desidera memorizzare il file di configurazione.

Crittografa la configurazione utilizzando una password

Scegliere questa opzione per proteggere il file di configurazione con una password crittografata.

Password

Digitare la password.

Conferma password

Digitare di nuovo la password per confermare.

Argomenti correlati

Per ulteriori informazioni sui file di configurazione della metabase, vedere la documentazione in linea di IIS 6.0 (la pagina potrebbe essere in inglese) nel sito Web Microsoft Windows Server TechCenter.


IIS 6.0 F1: Proprietà ereditate ignorate

Se si modifica un'impostazione definita anche in uno o più nodi figlio, questi avranno un'impostazione differente e si potrà scegliere se far loro ereditare la nuova impostazione.

Se si desidera che i nodi figlio mantengano l'impostazione corrente, non selezionare alcun nodo, quindi scegliere OK.

Se si desidera che i nodi figlio utilizzino la nuova impostazione, selezionare i nodi che devono ereditare la nuova impostazione, quindi scegliere OK.