Iniziatore iSCSI Microsoft

L'iniziatore iSCSI Microsoft consente di connettere un host Windows a un array di archiviazione iSCSI mediante schede di interfaccia di rete (NIC) Ethernet. È possibile utilizzare l'iniziatore iSCSI Microsoft nell'infrastruttura di rete esistente per attivare reti SAN (Storage Area Network) basate su blocchi che forniscano funzionalità di destinazione iSCSI senza dover acquistare hardware aggiuntivo.

In questo file della Guida vengono illustrate le schede della finestra di dialogo Proprietà e altre schede comuni dell'interfaccia dell'iniziatore iSCSI Microsoft.

In questo file della Guida sono inclusi gli argomenti seguenti:

  • Proprietà di Destinazioni

  • Proprietà di Individuazione

  • Proprietà di Destinazioni preferite

  • Proprietà di Volumi e dispositivi

  • Proprietà di RADIUS

  • Proprietà di Configurazione

  • Impostazioni avanzate IPsec

  • Dettagli di Proprietà

  • Dispositivi - Destinazioni


Proprietà di Destinazioni

Utilizzare Connessione rapida per effettuare l'individuazione, l'accesso e per rendere il percorso di destinazione un percorso preferito. Digitare l'indirizzo IP o il nome Domain Name System (DNS) della destinazione e quindi fare clic su Connessione rapida. Al riavvio del sistema, viene automaticamente tentata la connessione alla destinazione Connessione rapida.

Nota

Affinché sia possibile visualizzare connessioni, sessioni e informazioni sui dispositivi nella scheda Destinazioni, è innanzitutto necessario individuare una destinazione tramite Connessione rapida o tramite la scheda Individuazione.

Importante

Per connessioni avanzate che utilizzano digest o che richiedono la sicurezza Challenge Handshake Authentication Protocol (CHAP), è necessario utilizzare la funzionalità Connetti. Connessione rapida non supporta l'accesso a dispositivi che supportano la sicurezza CHAP.

È possibile utilizzare Connetti quando una destinazione è visualizzata nell'elenco. In questo modo è possibile effettuare connessioni non permanenti e contrassegnare le connessioni per il supporto di opzioni a percorsi multipli, nonché opzioni avanzate aggiuntive.

Nota

La funzionalità Multipath I/O (MPIO) è disponibile esclusivamente nelle versioni server di Windows.

Le opzioni avanzate disponibili tramite Connetti includono opzioni di connessione quali l'indirizzo IP e la porta di destinazione da utilizzare, controlli di ridondanza ciclici (CRC, cyclic redundancy check) di digest dati e intestazione, informazioni di accesso CHAP e informazioni Internet Protocol Security (IPsec).

CHAP richiede che l'iniziatore disponga di un nome utente e di un segreto CHAP. Il nome utente CHAP viene in genere passato alla destinazione e quindi viene cercato il segreto CHAP di tale nome utente nella tabella privata relativa. Per impostazione predefinita, il servizio iniziatore iSCSI Microsoft utilizza il nome del nodo iniziatore come nome utente CHAP. È possibile impedire questa azione passando un nome utente CHAP alla richiesta di accesso. Il driver in modalità kernel dell'iniziatore iSCSI Microsoft limita il nome utente CHAP a 223 caratteri.

È possibile creare più sessioni con la stessa destinazione. Per creare una connessione aggiuntiva selezionare la destinazione in Destinazioni individuate e quindi fare clic su Connetti.

Nota

La presenza di più sessioni della stessa destinazione dipende dal fatto che la destinazione iSCSI consenta accessi a più sessioni e dagli eventuali limiti sul numero di connessioni già raggiunti.

Per disconnettere un'intera connessione, selezionare la destinazione in Destinazioni individuate e quindi fare clic su Disconnetti.

Poiché possono essere presenti più connessioni a una destinazione, è possibile fare clic su Proprietà per visualizzare le sessioni correnti e disconnettere singole sessioni.

È possibile fare clic su Dispositivi per visualizzare eventuali dispositivi associati alla connessione di destinazione.

Vedere anche

  • Iniziatore iSCSI Microsoft


Proprietà di Individuazione

Affinché sia possibile visualizzare connessioni, sessioni e informazioni sui dispositivi relative a una destinazione nella scheda Destinazioni, è necessario individuare tale destinazione.

Portali destinazione: è possibile individuare un dispositivo di destinazione iSCSI e quindi connettersi alla destinazione nella scheda Destinazioni.

Server iSNS: l'utilizzo di un server Internet Storage Name Service (iSNS) è analogo a quello di un server Domain Name System (DNS). Il computer client in cui è eseguito l'iniziatore iSCSI richiede che il server iSNS esegua una query per le destinazioni iSCSI accessibili al client. L'aggiunta di un server iSNS consente l'individuazione automatica delle destinazioni iSCSI accessibili al client. La rimozione del server iSNS impedirebbe l'individuazione automatica e renderebbe necessaria l'immissione manuale del nome di ogni destinazione iSCSI.

Nota

Affinché un client interagisca correttamente con un server iSNS, è necessario che sia attivata l'eccezione del firewall per il server iSNS. A tale scopo, viene consentito al servizio iSCSI di comunicare tramite Windows Firewall.

Vedere anche


Proprietà di Destinazioni preferite

Contrassegnando una destinazione come destinazione preferita, l'iniziatore iSCSI Microsoft configura gli iniziatori software e hardware in modo che tentino sempre di riconnettersi alla destinazione ogni volta che il computer viene riavviato. Le informazioni di accesso necessarie per connettersi alle destinazioni preferite, ad esempio i segreti Challenge-Handshake Authentication Protocol (CHAP), le informazioni sul portale, e così via vengono acquisite all'accesso e salvate dagli iniziatori software e hardware nella memoria non volatile. Gli iniziatori hardware possono avviare una riconnessione nella fase iniziale del processo di avvio mentre il driver in modalità kernel dell'iniziatore software Microsoft avvia una riconnessione nel momento in cui vengono caricati lo stack TCP/IP di Windows e il servizio iniziatore iSCSI Microsoft.

Vedere anche


Proprietà di Volumi e dispositivi

È possibile visualizzare un elenco dei volumi e dei dispositivi attualmente associati in modo permanente dall'iniziatore iSCSI Microsoft. Se un volume nell'elenco è attualmente montato, vengono visualizzati la lettera di unità e il punto di montaggio. Se un volume non è montato, l'interfaccia del dispositivo non viene visualizzata. Per ogni dispositivo, viene visualizzato il nome dell'interfaccia.

Nota

Se in un unico volume sono presenti più partizioni con lettere di unità, solo la prima lettera di unità verrà visualizzata nella pagina Proprietà di Volumi e dispositivi.

Vedere anche


Proprietà di RADIUS

Remote Authentication Dial-In User Service (RADIUS) è uno standard utilizzato per mantenere e gestire l'autenticazione e la convalida degli utenti. A differenza di Challenge Handshake Authentication Protocol (CHAP), RADIUS non esegue l'autenticazione tra peer, ma tra un server RADIUS e un client. Quando un utente (un iniziatore iSCSI) desidera effettuare l'autenticazione a un client (una destinazione iSCSI), il client invia al server RADIUS una richiesta di autenticazione. Il server RADIUS è responsabile dell'autenticazione del client. Anche le transazioni tra il client e il server RADIUS vengono autenticate tramite una chiave privata condivisa.

Per utilizzare questo livello di sicurezza, è necessario disporre di un server RADIUS in rete o distribuirne uno.

Vedere anche


Proprietà di Configurazione

L'host o il client iSCSI (anche denominato iniziatore iSCSI) è un sistema, ad esempio un server, che viene collegato a una rete IP e invia richieste e riceve risposte da una destinazione iSCSI. Ogni host iSCSI è identificato da un nome IQN (iSCSI Qualified Name) univoco analogo a un nome WWN Fibre Channel.

Il servizio iniziatore iSCSI Microsoft supporta l'utilizzo e la configurazione dei protocolli Challenge Handshake Authentication Protocol (CHAP) e Internet Protocol Security (IPsec) sia per l'iniziatore software iSCSI Microsoft sia per le schede bus host iSCSI (HBA, Host Bus Adapter). Tutte le schede HBA iSCSI supportate consentono l'utilizzo del protocollo CHAP, mentre alcune potrebbero non supportare IPsec.

Se si utilizza RADIUS, l'impostazione del segreto CHAP dell'iniziatore iSCSI non è necessaria quando si utilizza l'autenticazione CHAP reciproca.

Nota

Il segreto CHAP deve essere di lunghezza compresa tra 12 e 16 caratteri, a meno che non si utilizzi IPsec, nel qual caso sono sufficienti 8 caratteri.

Vedere anche


Impostazioni avanzate IPsec

Internet Protocol Security (IPsec) è un protocollo che offre autenticazione e crittografia dei dati a livello di pacchetto IP. Il protocollo Internet Key Exchange (IKE) viene utilizzato tra peer per consentire loro l'autenticazione reciproca e la negoziazione di meccanismi di autenticazione e crittografia dei pacchetti da utilizzare per la connessione. Poiché l'iniziatore iSCSI Microsoft utilizza lo stack TCP/IP di Windows, può utilizzare tutte le funzionalità disponibili in tale stack. Per l'autenticazione, sono inclusi certificati, Kerberos e chiavi già condivise. È possibile utilizzare Active Directory per distribuire i filtri IPsec ai computer dell'iniziatore iSCSI Microsoft. Sono inoltre supportati Triple DES (3DES) e Hash Message Authentication Code – Secure Hash Algorithm 1 (HMAC-SHA1) poiché si tratta di modalità tunnel e trasporto.

Poiché lo stack TCP/IP è integrato in una scheda bus host (HBA, Host Bus Adapter) iSCSI, la scheda HBA iSCSI dispone di una propria implementazione di IPsec e IKE, pertanto la funzionalità della scheda HBA iSCSI potrebbe variare. Supporta, come minimo, chiavi già condivise, 3DES e HMAC-SHA1. Il servizio iniziatore iSCSI Microsoft dispone di un'interfaccia Application Programming Interface (API) comune utilizzata per la configurazione di IPsec, sia per l'iniziatore iSCSI Microsoft sia per la scheda HBA iSCSI.

Vedere anche


Dettagli di Proprietà

Se la destinazione supporta più sessioni, è possibile creare una sessione aggiuntiva facendo clic su Aggiungi sessione.

Per disconnettere singole sessioni, selezionare la sessione nell'elenco e quindi fare clic su Disconnetti.

Per ulteriori informazioni sui dispositivi associati a una sessione, selezionare la sezione e quindi fare clic su Dispositivi.

In RFC iSCSI viene definito il supporto Sessione a più connessioni (MCS, Multiple Connections per Session) per consentire più connessioni TCP/IP dall'iniziatore alla destinazione per la stessa sessione iSCSI. Specifico del protocollo iSCSI. In questo modo si consente l'invio dell'I/O su qualsiasi connessione TCP/IP alla destinazione. In caso di errore durante una connessione, un'altra può continuare l'elaborazione di I/O senza interrompere l'applicazione. Non tutte le destinazioni iSCSI supportano MCS. Le destinazioni iSCSI che supportano MCS includono, in via esemplificativa, EMC Celerra, iStor e Network Appliance.

Vedere anche


Dispositivi - Destinazioni

In questa scheda sono disponibili informazioni sui dispositivi connessi e viene consentito l'accesso alla configurazione di Multipath I/O (MPIO). MPIO è disponibile esclusivamente nelle versioni server di Windows.

Mediante Microsoft Multipath I/O (MPIO), l'iniziatore iSCSI Microsoft può effettuare l'accesso alla stessa destinazione in più sessioni e aggregare i dispositivi duplicati in un unico dispositivo esposto a Windows. È possibile stabilire ogni sessione alla destinazione utilizzando diverse schede di interfaccia di rete (NIC), infrastrutture di rete e porte di destinazione. In caso di errore di una sessione, un'altra può continuare l'elaborazione di I/O senza interrompere l'applicazione. È necessario che la destinazione iSCSI supporti più sessioni alla stessa destinazione. Il supporto DSM (Device Specific Module) di Microsoft iSCSI MPIO consente l'utilizzo di un insieme di criteri di bilanciamento del carico che determinano il modo in cui l'I/O viene allocato tra le diverse sessioni.

In questa finestra di dialogo sono disponibili informazioni sui dischi attualmente connessi tramite l'iniziatore iSCSI, nonché un mapping tra il numero di disco e l'indirizzo. Nella finestra di dialogo Dispositivi è inoltre possibile configurare il tipo di utilizzo del percorso MPIO facendo clic su MPIO.

Vedere anche