Esplora archivi

Esplora archivi consente di visualizzare e gestire le infrastrutture Fibre Channel e iSCSI disponibili nella rete di archiviazione (SAN).

Un'infrastruttura è una topologia di rete in cui i dispositivi sono connessi gli uni agli altri tramite uno o più percorsi di dati a elevata efficienza. Nel caso delle infrastrutture Fibre Channel, la rete include uno o più commutatori Fibre Channel che consentono ai server e ai dispositivi di archiviazione di connettersi gli uni agli altri attraverso connessioni virtuali point-to-point. Nel caso delle infrastruttura iSCSI, la rete include uno o più server iSNS (Internet Storage Name Service) che offrono funzioni di individuazione e partizionamento delle risorse.

Esplora archivi consente di visualizzare informazioni dettagliate sui server connessi alla rete SAN e su componenti dell'infrastruttura quali schede bus host (HBA), commutatori Fibre Channel e iniziatori e destinazioni iSCSI.

In un'infrastruttura iSCSI è inoltre possibile eseguire varie attività amministrative, ad esempio accedere a destinazioni iSCSI, configurare la sicurezza iSCSI, aggiungere portali destinazione iSCSI, aggiungere server iSNS e gestire oggetti DD e oggetti DDS.

  • Gestire server

  • Gestire l'infrastruttura Fibre Channel

  • Gestire l'infrastruttura iSCSI

  • Eseguire la connessione a un computer remoto

  • Risolvere i problemi di Esplora archivi


Gestire server

Nel nodo Server dell'albero della console di Esplora archivi, è possibile visualizzare informazioni dettagliate su ogni scheda bus host (HBA) presente nei server connessi all'infrastruttura Fibre Channel. È inoltre possibile eseguire varie attività amministrative sugli iniziatori e sulle destinazioni iSCSI disponibili nell'infrastruttura iSCSI.

Nota

Esplora archivi può elencare e gestire risorse solo sui server che fanno parte di un dominio e che hanno un nome di dominio completo (FQDN) valido.

Importante

Per visualizzare e gestire server nella rete di archiviazione (SAN) è necessario attivare l'eccezione Strumentazione gestione Windows (WMI) su ogni server Windows Server 2008 o versione successiva che fa parte dell'infrastruttura Fibre Channel o iSCSI. È possibile attivare questa eccezione tramite Windows Firewall nel Pannello di controllo. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94683.

In questa sezione vengono descritti gli argomenti seguenti:

  • Visualizzare informazioni dettagliate sulla scheda bus host (HBA)

  • Configurare gli iniziatori iSCSI

  • Accedere a destinazioni iSCSI

  • Sicurezza iSCSI

  • Supporto per i percorsi multipli


Visualizzare informazioni dettagliate sulla scheda bus host (HBA)

È possibile utilizzare Esplora archivi per visualizzare informazioni dettagliate sulle schede bus host (HBA) Fibre Channel presenti sul server in uso o su altri server nella rete di archiviazione (SAN).

Le informazioni visualizzate comprendono:

  • Nome del server in cui: è installata la scheda HBA

  • Nome universale (WWN) della porta HBA

  • Nome universale (WWN) del nodo HBA

  • Versione firmware

  • Nome infrastruttura

  • Produttore della scheda HBA

  • Numero di serie della scheda HBA

  • Versioni dell'hardware, del driver e della memoria di sola lettura (ROM)

  • Codici identificativi del prodotto e del fornitore

  • Statistiche sulla porta HBA, quali i frame e i word trasmessi e ricevuti, il conteggio delle sincronizzazioni e delle perdite di segnale e il conteggio degli errori di collegamento

  • Zone di appartenenza della scheda HBA

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare informazioni dettagliate sulla scheda HBA

  1. In Server fare clic sulla scheda HBA per la quale si desidera visualizzare informazioni.

  2. Nel riquadro risultati verranno visualizzate alcune informazioni sulla scheda HBA. Per visualizzare informazioni più dettagliate fare clic su Proprietà nel riquadro Azioni.

Ulteriori considerazioni

  • Le informazioni visualizzate in Esplora archivi dipendono dal produttore hardware della scheda HBA. Esplora archivi potrebbe non essere in grado di visualizzare tutte le informazioni per alcune schede HBA.

Ulteriori riferimenti

  • Gestire server

  • Esplora archivi


Configurare gli iniziatori iSCSI

Esplora archivi consente di configurare gli iniziatori iSCSI utilizzati dai server nella rete di archiviazione (SAN).

Importante

Questa funzionalità consente di eseguire un sottoinsieme selezionato delle attività relative alla configurazione e all'amministrazione di iSCSI. È inoltre possibile eseguire queste e altre attività utilizzando l'iniziatore iSCSI Microsoft, incluso negli strumenti di amministrazione di Windows Server 2008 o versione successiva. Inoltre, i fornitori di soluzioni per l'archiviazione e per le reti offrono strumenti simili per l'esecuzione delle attività di configurazione e amministrazione di iSCSI. Per ulteriori informazioni su iSCSI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=102299.

I server che richiedono l'accesso alle risorse di archiviazione su un dispositivo iSCSI devono connettersi alla destinazione iSCSI alla quale le risorse sono state assegnate. Per la connessione a una destinazione, i server nella rete SAN utilizzano un iniziatore iSCSI.

Un iniziatore iSCSI è un'entità logica, ad esempio un programma o un servizio, che consente al server di comunicare con la destinazione. L'iniziatore iSCSI accede innanzitutto alla destinazione e richiede di avviare una sessione. La destinazione deve autorizzare la sessione e questa deve essere stabilita prima che il server possa accedere alle risorse di archiviazione.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare un iniziatore iSCSI

  1. In Server fare clic sull'iniziatore iSCSI che si desidera configurare.

  2. Per modificare il nome simbolico dell'iniziatore:

    1. Fare clic su Rinomina nel riquadro Azioni.

    2. Digitare un nuovo nome simbolico per l'iniziatore e fare clic su OK.

      Nota

      La modifica del nome simbolico di un iniziatore iSCSI può influire sull'accesso alle destinazioni iSCSI. Dopo la modifica del nome può essere necessario riconfigurare le destinazioni alle quali l'iniziatore ha accesso, in modo che riconoscano il nuovo nome.

  3. Per impostare un nuovo segreto CHAP (Challenge Handshake Authentication Protocol) da utilizzare per la connessione a una destinazione:

    1. Fare clic su Imposta segreto CHAP nel riquadro Azioni.

    2. Digitare il nuovo segreto CHAP e fare clic su OK.

      Nota

      Sarà inoltre necessario configurare con il nuovo segreto le destinazioni alle quali l'iniziatore farà accesso. In caso contrario, l'iniziatore non sarà in grado di accedere alle destinazioni.

  4. Per reimpostare il segreto CHAP, fare clic su Reimposta segreto CHAP nel riquadro Azioni.

  5. Per aggiungere un server iSNS (Internet Storage Name Service) per l'individuazione delle destinazioni, fare clic su Aggiungi server iSNS nel riquadro Azioni. Per ulteriori informazioni, vedere Aggiungere un server iSNS all'infrastruttura.

  6. Per aggiungere un portale destinazione:

    1. Fare clic su Aggiungi portale destinazione nel riquadro Azioni.

    2. Digitare l'indirizzo IP del portale destinazione.

    3. Se il portale destinazione utilizza un numero di socket diverso da quello predefinito (3260), digitare il numero di socket.

    4. Per scegliere le impostazioni di connessione fare clic su Connessione. Configurare i parametri di connessione che si desidera utilizzare, configurare i parametri CHAP necessari per la connessione al portale destinazione e fare clic su OK. Per ulteriori informazioni sul protocollo CHAP, vedere Sicurezza iSCSI.

    5. Per scegliere le impostazioni IPsec (Internet Protocol security) fare clic su IPSec. Configurare i parametri IPSec necessari per la connessione al portale destinazione e fare clic su OK. Per ulteriori informazioni su IPSec, vedere Sicurezza iSCSI.

    6. Per aggiungere il nuovo portale destinazione fare clic su OK.

Ulteriori considerazioni

  • I segreti CHAP più sicuri non sono parole o frasi, ma una sequenza casuale di caratteri.

Ulteriori riferimenti

  • Per ulteriori informazioni su iSCSI, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93543.

  • Gestire server


Accedere a destinazioni iSCSI

Esplora archivi consente di accedere a destinazioni nella rete di archiviazione (SAN) e scegliere le impostazioni di connessione per ogni sessione.

Importante

Questa funzionalità consente di eseguire un sottoinsieme selezionato delle attività relative alla configurazione e all'amministrazione di iSCSI. È inoltre possibile eseguire queste e altre attività utilizzando l'iniziatore iSCSI Microsoft, incluso negli strumenti di amministrazione di Windows Server 2008 o versione successiva. Inoltre, i fornitori di soluzioni per l'archiviazione e per le reti offrono strumenti simili per l'esecuzione delle attività di configurazione e amministrazione di iSCSI. Per ulteriori informazioni su iSCSI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=102299.

Le destinazioni vengono create per gestire le connessioni tra un dispositivo iSCSI e i server che vi devono accedere. Una destinazione definisce i portali (indirizzi IP) che possono essere utilizzati per la connessione al dispositivo iSCSI, nonché le eventuali impostazioni di sicurezza richieste dal dispositivo iSCSI per l'autenticazione dei server che richiedono l'accesso alle risorse.

I server che richiedono l'accesso alle risorse di archiviazione su un dispositivo iSCSI devono connettersi alla destinazione alla quale le risorse sono state assegnate. Per la connessione a una destinazione, i server nella rete SAN utilizzano un iniziatore iSCSI. Un iniziatore iSCSI è un'entità logica che consente al server di comunicare con la destinazione. L'iniziatore iSCSI accede innanzitutto alla destinazione e richiede di avviare una sessione. La destinazione deve autorizzare la sessione e questa deve essere stabilita prima che il server possa accedere alle risorse di archiviazione.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per accedere a una destinazione

  1. In Server selezionare la destinazione alla quale si desidera accedere.

  2. Fare clic su Accesso alla destinazione nel riquadro Azioni.

  3. Se si desidera che questa sessione di accesso venga ristabilita automaticamente dopo ogni riavvio, selezionare la casella di controllo Ripristina automaticamente la connessione all'avvio del sistema.

  4. Se si intende abilitare percorsi multipli da un server a questa destinazione, selezionare la casella di controllo Abilita percorsi multipli.

    Attenzione

    Se su un server che accederà a questa destinazione sono state abilitate due o più schede iniziatori iSCSI e il server non è configurato per utilizzare Multipath I/O, i dati potrebbero risultare danneggiati. Per ulteriori informazioni su Multipath I/O, vedere Supporto per i percorsi multipli.

  5. Per scegliere le impostazioni di connessione:

    1. Fare clic su Connessione.

    2. Nella finestra di dialogo Impostazioni di connessione dell'account di accesso selezionare il portale di destinazione al quale si desidera connettersi, la scheda locale e l'indirizzo IP di origine.

    3. Se si desidera proteggere l'integrità di ogni pacchetto di dati inviato in rete, selezionare la casella di controllo Digest dati o Digest intestazione (o entrambe). Quando si selezionano queste opzioni, i comandi vengono verificati e rifiutati in caso di errore.

    4. Se si desidera utilizzare l'autenticazione CHAP (Challenge Handshake Authentication Protocol) per la connessione alla destinazione, selezionare la casella di controllo Informazioni accesso CHAP.

    5. Scegliere i parametri CHAP necessari e fare clic su OK. Per ulteriori informazioni sul protocollo CHAP, vedere Sicurezza iSCSI.

      Importante

      Se si sceglie di utilizzare l'autenticazione RADIUS, è necessario configurare gli iniziatori e le destinazioni iSCSI nella rete SAN in modo che utilizzino questo tipo di sicurezza iSCSI. Questa configurazione non viene eseguita in Esplora archivi, ma negli strumenti di configurazione per iniziatori e destinazioni, ad esempio Iniziatore iSCSI nel Pannello di controllo.

  6. Per scegliere le impostazioni IPsec (Internet Protocol security):

    1. Fare clic su IPSec.

    2. Nella finestra di dialogo IPSec selezionare la casella di controllo Abilita le impostazioni IPSec.

    3. Scegliere i parametri IPSec che si desidera utilizzare e fare clic su OK. Per ulteriori informazioni su IPSec, vedere Sicurezza iSCSI.

  7. Per accedere alla destinazione utilizzando le impostazioni di connessione e le impostazioni IPsec selezionate, fare clic su OK.

Ulteriori considerazioni

  • Se non è possibile accedere a una destinazione, verificare che l'iniziatore iSCSI sul server sia configurato correttamente e che siano state scelte le impostazioni IPsec e di connessione corrette. Le impostazioni scelte in Esplora archivi per accedere a una destinazione devono corrispondere alle impostazioni richieste da tale destinazione.

  • Il livello di sicurezza che è possibile impostare per un sottosistema di archiviazione dipende dal produttore dell'hardware. Non tutti i sottosistemi supportano tutti i livelli di sicurezza iSCSI. È consigliabile contattare il produttore dell'hardware per verificare il livello di sicurezza supportato.

Ulteriori riferimenti

  • Per ulteriori informazioni su iSCSI, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93543.

  • Gestire server


Sicurezza iSCSI

È possibile utilizzare Esplora archivi per configurare le impostazioni di sicurezza iSCSI necessarie agli iniziatori nella rete di archiviazione (SAN) per la connessione a destinazioni e portali destinazione. Per iSCSI sono disponibili diversi livelli di sicurezza, tra i quali si dovranno scegliere quelli necessari per la destinazione o per il portale destinazione.

Importante

Questa funzionalità consente di eseguire un sottoinsieme selezionato delle attività relative alla configurazione e all'amministrazione di iSCSI. È inoltre possibile eseguire queste e altre attività utilizzando l'iniziatore iSCSI Microsoft, incluso negli strumenti di amministrazione di Windows Server 2008 o versione successiva. Inoltre, i fornitori di soluzioni per l'archiviazione e per le reti offrono strumenti simili per l'esecuzione delle attività di configurazione e amministrazione di iSCSI. Per ulteriori informazioni su iSCSI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=102299.

Esplora archivi supporta i seguenti livelli di sicurezza iSCSI:

  • Autenticazione CHAP

  • Autenticazione RADIUS

  • Autenticazione e crittografia IPSec

Autenticazione CHAP

Il livello base di sicurezza è costituito dal protocollo CHAP (Challenge Handshake Authentication Protocol), un protocollo che consente l'autenticazione del peer di una connessione ed è basato sulla condivisione di un segreto (una chiave di sicurezza analoga a una password) tra i peer.

Esistono due tipi di autenticazione CHAP:

  • One-way CHAP authentication. Con questo livello di sicurezza, soltanto la destinazione iSCSI esegue l'autenticazione dell'iniziatore. Il segreto viene impostato solo per la destinazione. Tutti gli iniziatori che desiderano accedervi devono utilizzare lo stesso segreto per avviare una sessione di accesso con la destinazione.

  • Mutual CHAP authentication. Con questo livello di sicurezza, la destinazione iSCSI e l'iniziatore eseguono l'autenticazione reciproca. Per ogni destinazione e ogni iniziatore della rete SAN viene impostato un segreto separato.

Attenzione

Tra iniziatori e destinazioni iSCSI utilizzare almeno l'autenticazione CHAP unidirezionale.

Autenticazione RADIUS

Il protocollo RADIUS (Remote Authentication Dial-In User Service) è uno standard utilizzato per la gestione dell'autenticazione e della convalida degli utenti. A differenza di CHAP, RADIUS non esegue l'autenticazione tra peer, ma tra un server RADIUS e un client. Quando un utente (un iniziatore iSCSI) desidera accedere alle risorse di un client (una destinazione iSCSI), il client invia al server RADIUS una richiesta di connessione utente. Il server RADIUS è responsabile dell'autenticazione dell'utente e della restituzione di tutte le informazioni di configurazione necessarie al client per fornire il servizio all'utente. Anche le transazioni tra il client e il server RADIUS vengono autenticate tramite un segreto condiviso.

Per utilizzare questo livello di sicurezza è necessario disporre di un server RADIUS in rete o distribuirne uno.

Autenticazione e crittografia IPSec

Il protocollo IPsec (Internet Protocol security) applica l'autenticazione e la crittografia dei dati a livello di pacchetto IP. IPSec può essere utilizzato in aggiunta all'autenticazione CHAP o RADIUS per implementare un ulteriore livello di sicurezza.

Quando si abilita IPSec, tutti i pacchetti IP inviati durante i trasferimenti dati vengono crittografati e autenticati. In tutti i portali IP viene impostata una chiave comune, in modo da consentire a tutti i peer di eseguire l'autenticazione reciproca e negoziare la crittografia dei pacchetti. Per ulteriori informazioni su IPsec, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?linkid=93520.

Ulteriori considerazioni

  • Il livello di sicurezza che è possibile impostare per un sottosistema di archiviazione dipende dal produttore dell'hardware. Non tutti i sottosistemi supportano tutti i livelli di sicurezza iSCSI. È consigliabile contattare il produttore dell'hardware per verificare il livello di sicurezza supportato.

  • I segreti CHAP più sicuri non sono parole o frasi, ma una sequenza casuale di caratteri.

Ulteriori riferimenti

  • Per ulteriori informazioni su iSCSI, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93543.

  • Accedere a destinazioni iSCSI

  • Configurare gli iniziatori iSCSI

  • Gestire server


Supporto per i percorsi multipli

I percorsi multipli aumentano la disponibilità delle risorse di archiviazione offrendo failover di percorso da un server o da un cluster a un sottosistema di archiviazione.

Multipath I/O (MPIO) è una funzionalità per il supporto dei percorsi multipli. È necessario installare MPIO sui server che devono accedere a una risorsa su un sottosistema di archiviazione attraverso più porte Fibre Channel o più schede iniziatori iSCSI. Per installare MPIO su un computer Windows Server 2008, eseguire la procedura seguente.

Attenzione

Per prevenire perdite di dati, accertarsi che il server supporti MPIO prima di abilitare più porte Fibre Channel o più schede iniziatori iSCSI per l'accesso all'archivio. Se il server non supporta MPIO o in caso di dubbi, attivare soltanto una porta Fibre Channel o una scheda iniziatore iSCSI nel server.

Attenzione

Se si intende abilitare l'accesso alle risorse su un sottosistema di archiviazione da un cluster, accertarsi che su ogni server del cluster sia stato installato Clustering di failover, al fine di evitare perdite di dati. Per ulteriori informazioni sull'installazione di Clustering di failover, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86168.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare MPIO

  1. Nell'albero della console di Server Manager fare clic sul nodo Funzionalità.

  2. Nel riquadro Funzionalità, in Riepilogo funzionalità, fare clic su Aggiungi funzionalità.

  3. Nell'Aggiunta guidata funzionalità selezionare la casella di controllo Multipath I/O e fare clic su Avanti.

  4. Eseguire i passaggi dell'Aggiunta guidata funzionalità.

Ulteriori riferimenti

  • Per ulteriori informazioni su MPIO, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81020.


Gestire l'infrastruttura Fibre Channel

Nel nodo Infrastruttura Fibre Channel dell'albero della console di Esplora archivi è possibile visualizzare informazioni dettagliate sui componenti dell'infrastruttura Fibre Channel, come le schede bus host (HBA) e i commutatori Fibre Channel. In base al tipo di commutatori Fibre Channel presenti nell'infrastruttura, è possibile inoltre utilizzare Esplora archivi per accedere facilmente ai portali di gestione di tali commutatori.

Nota

L'individuazione dei nodi Fibre Channel avviene in parte attraverso le query relative ai commutatori Fibre Channel nella rete di archiviazione (SAN). I comandi Fibre Channel supportati da un commutatore dipendono dal produttore hardware, dal modello del commutatore e dalla versione del relativo firmware. Un commutatore che non supporta i comandi inviati da Esplora archivi non verrà visualizzato e potrebbe non essere possibile visualizzare nemmeno alcuni server connessi a esso.

Importante

Per visualizzare e gestire l'infrastruttura Fibre Channel è necessario attivare l'eccezione Strumentazione gestione Windows (WMI) su ogni server Windows Server 2008 o versione successiva che fa parte dell'infrastruttura. È possibile attivare questa eccezione tramite Windows Firewall nel Pannello di controllo. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94683.

In questa sezione viene descritto l'argomento seguente:

  • Accedere ai portali di gestione di un commutatore Fibre Channel


Accedere ai portali di gestione di un commutatore Fibre Channel

È possibile utilizzare Esplora archivi per accedere ai portali di gestione di un commutatore Fibre Channel, oppure semplicemente visualizzare informazioni su tali portali, come gli indirizzi IP e i protocolli.

I portali di gestione che possono essere visualizzati o ai quali è possibile accedere tramite Esplora archivi comprendono:

  • Portali Telnet

  • Portali HTTP

  • Portali SNMP (Simple Network Management Protocol)

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per visualizzare o accedere ai portali di gestione di un commutatore Fibre Channel

  1. In Infrastruttura Fibre Channel fare clic sul commutatore Fibre Channel per il quale si desidera connettersi ai relativi portali di gestione o visualizzarli.

  2. Per accedere a un portale di gestione sul commutatore, fare clic sul commutatore con il pulsante destro del mouse e quindi scegliere il portale di gestione che si desidera utilizzare.

    Oppure

    Per visualizzare un elenco dei portali di gestione disponibili per il commutatore, fare clic su Proprietà nel riquadro Azioni.

Ulteriori considerazioni

  • Client Telnet non è installato per impostazione predefinita in Windows Server 2008. Se non è ancora stato installato, è possibile farlo tramite Server Manager facendo clic su Aggiungi funzionalità nel nodo Funzionalità.

  • I portali di gestione ai quali è possibile accedere o che possono essere visualizzati tramite Esplora archivi dipendono dal produttore hardware del commutatore Fibre Channel, dal modello del commutatore e dalla versione attuale del relativo firmware. Esplora archivi potrebbe non essere in grado di visualizzare o accedere a qualsiasi portale di gestione su alcuni commutatori Fibre Channel.

Ulteriori riferimenti

  • Gestire l'infrastruttura Fibre Channel


Gestire l'infrastruttura iSCSI

Nel nodo iSCSI Fabrics dell'albero della console di Esplora archivi sono visualizzate le informazioni rese disponibili da ogni server iSNS (Internet Storage Name Service) dell'infrastruttura iSCSI. È inoltre possibile creare e gestire oggetti DD e oggetti DDS per una migliore allocazione delle risorse di archiviazione iSCSI.

Importante

Questa funzionalità consente di eseguire un sottoinsieme selezionato delle attività relative alla configurazione e all'amministrazione di iSCSI e iSNS. È inoltre possibile eseguire queste e altre attività utilizzando l'iniziatore iSCSI Microsoft, incluso in Windows Server 2008 o versione successiva, e Microsoft iSNS Server, installabile da Server Manager. Inoltre, i fornitori di soluzioni per l'archiviazione e per le reti offrono strumenti simili per l'esecuzione delle attività di configurazione e amministrazione di iSCSI e iSNS. Per ulteriori informazioni su iSCSI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=102299.

Nota

L'individuazione dei nodi iSCSI avviene mediante query sui server iSNS nella rete di archiviazione (SAN). Se la rete SAN non contiene alcun server iSNS oppure se le destinazioni e gli iniziatori iSCSI non sono stati configurati per utilizzare un server iSNS per l'individuazione, non sarà possibile visualizzare le infrastrutture iSCSI dell'utente tramite Esplora archivi. Per ulteriori informazioni, vedere Aggiungere un server iSNS all'infrastruttura.

Importante

Per visualizzare e gestire l'infrastruttura iSCSI è necessario attivare l'eccezione Strumentazione gestione Windows (WMI) su ogni server Windows Server 2008 o versione successiva che fa parte dell'infrastruttura. È possibile attivare questa eccezione tramite Windows Firewall nel Pannello di controllo. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94683.

In questa sezione vengono descritti gli argomenti seguenti:

  • Aggiungere un server iSNS all'infrastruttura

  • Creare oggetti DD e DDS


Aggiungere un server iSNS all'infrastruttura

I server che eseguono Internet Storage Name Service (iSNS) forniscono servizi di individuazione dei dispositivi iSCSI in una rete di archiviazione (SAN). I server iSNS consentono ai client iSNS (come l'iniziatore iSCSI Microsoft) di registrarsi e di eseguire query per individuare altri client iSNS registrati, come le destinazioni iSCSI.

Esplora archivi utilizza le informazioni rese disponibili da ogni server iSNS nella rete SAN per elencare tutti gli iniziatori e le destinazioni iSCSI disponibili nella rete SAN sotto il nodo iSCSI Fabrics.

Importante

Questa funzionalità consente di eseguire un sottoinsieme selezionato delle attività relative alla configurazione e all'amministrazione di iSCSI e iSNS. È inoltre possibile eseguire queste e altre attività utilizzando l'iniziatore iSCSI Microsoft, incluso in Windows Server 2008 o versione successiva, e Microsoft iSNS Server, installabile da Server Manager. Inoltre, i fornitori di soluzioni per l'archiviazione e per le reti offrono strumenti simili per l'esecuzione delle attività di configurazione e amministrazione di iSCSI e iSNS. Per ulteriori informazioni su iSCSI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=102299.

Nota

L'individuazione dei nodi iSCSI avviene mediante query sui server iSNS nella rete SAN. Se la rete SAN non contiene alcun server iSNS oppure se le destinazioni e gli iniziatori iSCSI non sono stati configurati per utilizzare un server iSNS per l'individuazione, non sarà possibile visualizzare le infrastrutture iSCSI dell'utente tramite Esplora archivi.

Importante

Per visualizzare e gestire l'infrastruttura iSCSI è necessario attivare l'eccezione Strumentazione gestione Windows (WMI) su ogni server Windows Server 2008 o versione successiva che fa parte dell'infrastruttura, compresi tutti i server iSNS. È possibile attivare questa eccezione tramite Windows Firewall nel Pannello di controllo. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94683.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere un server iSNS all'infrastruttura

  1. In Server fare clic sull'iniziatore iSCSI al quale si desidera aggiungere un server iSNS.

  2. Fare clic su Aggiungi server iSNS nel riquadro Azioni.

  3. Digitare l'indirizzo IP del server iSNS e fare clic su OK.

  4. Fare clic con il pulsante destro del mouse sul nodo Esplora archivi (in alto nella console) e scegliere Aggiorna visualizzazione SAN.

Ulteriori considerazioni

  • Per aggiungere le informazioni del server iSNS è anche possibile utilizzare l'applicazione di gestione di ciascun iniziatore iSCSI. Se ad esempio si utilizza l'iniziatore iSCSI Microsoft, è possibile utilizzare Iniziatore iSCSI nel Pannello di controllo per aggiungere le informazioni del server iSNS (nella scheda Individuazione).

  • Se nella rete SAN non è presente un server iSNS, è necessario installarlo. Per l'installazione su un computer Windows Server 2008 è possibile utilizzare Server Manager, facendo clic su Aggiungi funzionalità nel nodo Funzionalità. Per l'installazione su un computer Windows 2000 o Windows Server 2003, è possibile scaricare e installare Server iSNS Microsoft 3.0 dall'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94670.

    Dopo aver installato uno o più server iSNS, configurare ogni destinazione e ogni iniziatore iSCSI nella rete SAN per utilizzare un server iSNS per l'individuazione. Questa configurazione viene effettuata tramite gli strumenti appositi per iniziatori e destinazioni, ad esempio Iniziatore iSCSI nel Pannello di controllo.

Ulteriori riferimenti

  • Gestire l'infrastruttura iSCSI


Creare oggetti DD e DDS

Esplora archivi consente di creare e gestire oggetti DD e DDS nell'infrastruttura iSCSI.

Importante

Questa funzionalità consente di eseguire un sottoinsieme selezionato delle attività relative alla configurazione e all'amministrazione di iSCSI e iSNS. È inoltre possibile eseguire queste e altre attività utilizzando l'iniziatore iSCSI Microsoft, incluso in Windows Server 2008 o versione successiva, e Microsoft iSNS Server, installabile da Server Manager. Inoltre, i fornitori di soluzioni per l'archiviazione e per le reti offrono strumenti simili per l'esecuzione delle attività di configurazione e amministrazione di iSCSI e iSNS. Per ulteriori informazioni su iSCSI, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=102299.

Gli oggetti DD in un'infrastruttura iSCSI, come le zone in un'infrastruttura Fibre Channel, consentono di partizionare le risorse di archiviazione nella rete SAN. Con la creazione e la gestione degli oggetti DD è possibile controllare le destinazioni iSCSI che ogni iniziatore iSCSI può vedere e alle quali può accedere.

Quando si crea un oggetto DD si raggruppano gli iniziatori e le destinazioni segnalati da ciascun server iSNS (Internet Storage Name Service) nella rete SAN. Gli oggetti DD possono essere ulteriormente partizionati in oggetti DDS. La loro funzione è simile a quella degli oggetti DD, con la differenza che ogni oggetto DDS corrisponde a un gruppo di oggetti DD e ogni DDS può essere abilitato o disabilitato. Un oggetto DD che non è membro di un oggetto DDS non può essere utilizzato per l'individuazione.

In breve, perché una destinazione iSCSI possa essere individuata da un iniziatore iSCSI, entrambi devono essere membri dello stesso oggetto DD, il quale deve essere membro di un oggetto DDS abilitato.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare un oggetto DD

  1. In iSCSI Fabrics fare clic sul server iSNS in cui si desidera creare un oggetto DD.

  2. Fare clic su Crea oggetto DD nel riquadro Azioni.

  3. Digitare un nome per l'oggetto DD e quindi fare clic su OK.

  4. Per aggiungere una destinazione o un iniziatore iSCSI all'oggetto DD:

    1. Trascinare la destinazione o l'iniziatore da Nodi registrati all'oggetto DD.

      Oppure

    2. Fare clic sull'oggetto DD e quindi su Aggiungi nuovo iniziatore o destinazione nel riquadro Azioni. Digitare il nome iSCSI dell'iniziatore o della destinazione e fare clic su OK.
Per creare un oggetto DDS e aggiungervi un oggetto DD

  1. In iSCSI Fabrics fare clic sul server iSNS in cui si desidera creare un oggetto DD.

  2. Fare clic su Crea oggetto DDS nel riquadro Azioni.

  3. Digitare un nome per l'oggetto DDS e quindi fare clic su OK.

  4. Per aggiungere un oggetto DD all'oggetto DDS, trascinare l'oggetto DD nell'oggetto DDS.

  5. Per abilitare il nuovo oggetto DDS, fare clic su Abilita nel riquadro Azioni.

Ulteriori considerazioni

  • Per utilizzare oggetti DD e oggetti DDS, è necessario innanzitutto aggiungere uno o più server iSNS all'infrastruttura iSCSI. Per ulteriori informazioni, vedere Aggiungere un server iSNS all'infrastruttura.

  • I nuovi oggetti DDS sono disabilitati per impostazione predefinita.

  • È possibile rimuovere una destinazione iSCSI da tutti gli oggetti DD e configurare manualmente un iniziatore iSCSI per l'accesso a tale destinazione. Questa operazione deve essere eseguita esternamente al contesto del server iSNS e degli oggetti DD, mediante gli strumenti di configurazione per l'iniziatore e per la destinazione, come Iniziatore iSCSI nel Pannello di controllo.

Ulteriori riferimenti

  • Gestire l'infrastruttura iSCSI


Eseguire la connessione a un computer remoto

Per visualizzare e gestire le infrastrutture Fibre Channel e iSCSI disponibili per un computer remoto, è possibile connettersi al computer da Esplora archivi.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per connettersi a un computer remoto da Esplora archivi

  1. Nell'albero della console fare clic con il pulsante destro del mouse su Esplora archivi e quindi scegliere Connetti a.

  2. Nella finestra di dialogo Connetti a digitare il nome del computer al quale si desidera connettersi.

  3. Fare clic su OK.

Ulteriori considerazioni

  • È necessario accedere al computer locale con un account di dominio che sia membro del gruppo Administrators nel computer remoto.

  • Il computer remoto deve eseguire Windows Server 2008 o versione successiva e deve essere membro dello stesso dominio del computer dal quale viene effettuata la connessione. Non è possibile connettersi a un computer remoto se entrambi i computer sono membri di un gruppo di lavoro che non fa parte dello stesso dominio.

  • Sul computer remoto deve essere attivata l'eccezione Strumentazione gestione Windows (WMI). È possibile attivare questa eccezione tramite Windows Firewall nel Pannello di controllo. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94683.

Ulteriori riferimenti


Risolvere i problemi di Esplora archivi

In questo argomento vengono elencati alcuni problemi comuni che possono verificarsi quando si utilizza Esplora archivi. Per ulteriori informazioni sulla risoluzione di problemi, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94678.

Problema riscontrato

  • Non è possibile visualizzare l'infrastruttura iSCSI dell'utente in iSCSI Fabrics.

  • Non è possibile visualizzare l'infrastruttura Fibre Channel dell'utente in Infrastruttura Fibre Channel.

  • Non è possibile connettersi a un computer remoto mediante Esplora archivi.
Non è possibile visualizzare l'infrastruttura iSCSI dell'utente in iSCSI Fabrics.
  • Causa Le possibile cause includono:

    • L'individuazione dei nodi iSCSI avviene mediante query sui server iSNS (Internet Storage Name Service) nella rete di archiviazione (SAN). Se la rete SAN non contiene alcun server iSNS oppure se le destinazioni e gli iniziatori iSCSI non sono stati configurati per utilizzare un server iSNS per l'individuazione, non sarà possibile visualizzare l'infrastruttura iSCSI dell'utente.

    • Restrizioni del firewall bloccano la comunicazione del server con altri server nella rete SAN.

    • I computer nella rete SAN non fanno parte di un dominio. Esplora archivi è in grado di individuare solo i computer con un nome di dominio completo.

  • Soluzione Le soluzioni includono:

    • Se nella rete SAN non è presente un server iSNS, è necessario innanzitutto installarlo. Per l'installazione su un computer Windows Server 2008 o versione successiva è possibile utilizzare Server Manager, facendo clic su Aggiungi funzionalità nel nodo Funzionalità. Per l'installazione su un computer Windows 2000 o Windows Server 2003, è possibile scaricare e installare Server iSNS Microsoft 3.0 dall'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=94670.

      Dopo aver installato uno o più server iSNS, configurare ogni destinazione e ogni iniziatore iSCSI nella rete SAN per utilizzare un server iSNS per l'individuazione. Questa configurazione viene effettuata tramite gli strumenti appositi per iniziatori e destinazioni, ad esempio Iniziatore iSCSI nel Pannello di controllo.

    • Attivare l'eccezione Strumentazione gestione Windows (WMI) in ogni server Windows Server 2008 o versione successiva che fa parte dell'infrastruttura. È possibile attivare questa eccezione tramite Windows Firewall nel Pannello di controllo. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94683.

    • Verificare che tutti i computer nella rete SAN facciano parte di un dominio e che abbiano un nome di dominio completo valido.

Non è possibile visualizzare l'infrastruttura Fibre Channel dell'utente in Infrastruttura Fibre Channel.
  • Causa Di seguito sono riportate le possibili cause:

    • L'individuazione dei nodi Fibre Channel avviene in parte attraverso le query relative ai commutatori Fibre Channel nella rete SAN. I comandi Fibre Channel supportati da un commutatore dipendono dal produttore hardware, dal modello del commutatore e dalla versione del relativo firmware. Un commutatore che non supporta i comandi inviati da Esplora archivi non verrà visualizzato e potrebbe non essere possibile visualizzare nemmeno alcuni server connessi a esso.

    • Restrizioni del firewall bloccano la comunicazione del server con altri server nella rete SAN.

    • I computer nella rete SAN non fanno parte di un dominio. Esplora archivi è in grado di individuare solo i computer con un nome di dominio completo.

  • Soluzione Le soluzioni includono:

    • Contattare il produttore del commutatore Fibre Channel e verificare che sia compatibile con Esplora archivi.

    • Attivare l'eccezione Strumentazione gestione Windows (WMI) in ogni server Windows Server 2008 o versione successiva che fa parte dell'infrastruttura. È possibile attivare questa eccezione tramite Windows Firewall nel Pannello di controllo. Per ulteriori informazioni, vedere la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94683.

    • Verificare che tutti i computer nella rete SAN facciano parte di un dominio e che abbiano un nome di dominio completo valido.

Non è possibile connettersi a un computer remoto mediante Esplora archivi.
  • Causa: nel computer remoto non è attivata l'eccezione Strumentazione gestione Windows (WMI), oppure l'utente non ha eseguito l'accesso utilizzando un account di dominio membro del gruppo Administrators sul computer remoto.

  • Soluzione: utilizzare Windows Firewall nel Pannello di controllo per attivare l'eccezione Strumentazione gestione Windows (WMI) nel computer remoto. Per ulteriori informazioni, visitare la pagina all'indirizzo http://go.microsoft.com/fwlink/?LinkID=94683.

    Accertarsi inoltre che l'account utilizzato per accedere al computer locale sia membro del gruppo Administrators nel computer remoto. Per ulteriori informazioni, vedere Eseguire la connessione a un computer remoto.

Ulteriori riferimenti