Gestione RemoteApp

Servizi Desktop remoto consente alle organizzazioni di offrire accesso a programmi Windows standard virtualmente da qualsiasi posizione, a qualunque dispositivo Windows, da Internet o da una rete Intranet. RemoteApp consente di fare in modo che i programmi a cui si accede in remoto tramite Servizi Desktop remoto vengano visualizzati come se venissero eseguiti nel computer locale dell'utente finale. Questi programmi vengono definiti Programmi RemoteApp.

Utilizzare Gestione RemoteApp per rendere i programmi installati in un server Host sessione Desktop remoto disponibili agli utenti come Programmi RemoteApp. Gestione RemoteApp viene automaticamente installato in un computer in cui è stato installato il servizio ruolo Host sessione Desktop remoto.

Sono inclusi gli argomenti seguenti:

  • Panoramica di RemoteApp

  • Elenco di controllo: configurare RemoteApp

  • Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp

  • Configurare programmi RemoteApp

  • Elenco di controllo: rendere i programmi RemoteApp disponibili da Internet

  • Accesso Web Desktop remoto

Per ulteriori informazioni su RemoteApp, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140439.


Panoramica di RemoteApp

Che cos'è RemoteApp?

RemoteApp consente di fare in modo che i programmi a cui si accede in remoto tramite Servizi Desktop remoto vengano visualizzati come se venissero eseguiti nel computer locale dell'utente finale. Questi programmi vengono definiti Programmi RemoteApp. Anziché essere presentato all'utente nel desktop del server Host sessione Desktop remoto, il Programma RemoteApp viene integrato nel desktop del client. Il Programma RemoteApp viene eseguito nella relativa finestra ridimensionabile, può essere trascinato tra più monitor ed è associato a una voce propria sulla barra delle applicazioni. Se un utente esegue più di un Programma RemoteApp nello stesso server Host sessione Desktop remoto, il Programma RemoteApp condividerà la stessa sessione di Servizi Desktop remoto.

Gli utenti possono accedere ai Programmi RemoteApp in diversi modi. Possono:

  1. Accedere a un collegamento al programma tramite Connessione RemoteApp e desktop utilizzando Accesso Web Desktop remoto.

  2. Fare doppio clic su un file Remote Desktop Protocol (con estensione rdp) creato e distribuito dall'amministratore.

  3. Fare doppio clic sull'icona del programma, presente sul desktop o nel menu Start, creato e distribuito dall'amministratore con un pacchetto Windows Installer (con estensione msi).

  4. Fare doppio clic su un file la cui estensione è associata a un Programma RemoteApp. Questa impostazione può essere configurata dall'amministratore con un pacchetto Windows Installer.

Gli utenti possono accedere a Connessione RemoteApp e desktop tramite il menu Start in un computer che esegue Windows® 7 o tramite il sito Web Accesso Web Desktop remoto. Per ulteriori informazioni su come rendere disponibili i Programmi RemoteApp tramite Connessione RemoteApp e desktop, vedere la Guida di Gestione connessione Desktop remoto in Windows Server 2008 R2. Per ulteriori informazioni su Connessione RemoteApp e desktop, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=143108).

I file con estensione rdp e i pacchetti di Windows Installer contengono impostazioni necessarie per eseguire Programmi RemoteApp. Dopo avere aperto un Programma RemoteApp nel computer locale, l'utente può interagire con il programma in esecuzione nel server Host sessione Desktop remoto come se fosse eseguito in locale.

Perché utilizzare RemoteApp?

RemoteApp può ridurre la complessità e l'overhead amministrativo in molte situazioni, incluse le seguenti:

  • Nelle succursali, in cui il supporto IT locale e la larghezza di banda di rete potrebbero risultare limitati.

  • Situazioni in cui gli utenti devono accedere a programmi in remoto.

  • Distribuzione di programmi line-of-business, in particolare di programmi line-of-business personalizzati.

  • Ambienti come aree di lavoro in spazi comuni, ad esempio in alberghi, in cui gli utenti non dispongono di computer assegnati.

  • Distribuzione di più versioni di un programma, in particolare se l'installazione di più versioni in locale provocherebbe conflitti.

Per ulteriori informazioni su RemoteApp, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140439.

Ulteriori riferimenti

  • Elenco di controllo: configurare RemoteApp

  • Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp

  • Configurare programmi RemoteApp

  • Elenco di controllo: rendere i programmi RemoteApp disponibili da Internet

  • Accesso Web Desktop remoto


Elenco di controllo: configurare RemoteApp

È possibile rendere i programmi presenti in un server Host sessione Desktop remoto disponibili agli utenti tramite RemoteApp. È possibile distribuire Programmi RemoteApp agli utenti utilizzando file con estensione rdp, pacchetti di Windows Installer o Accesso Web Desktop remoto per rendere i programmi disponibili tramite Connessione RemoteApp e desktop.

Nota

Questo elenco di controllo si applica a un ambiente in cui si utilizza un singolo server Host sessione Desktop remoto per ospitare Programmi RemoteApp.

Attività | Riferimento
Per poter rendere i Programmi RemoteApp disponibili agli utenti, è necessario completare alcuni prerequisiti di installazione. | Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp
Aggiungere programmi all'elenco Programmi RemoteApp. | Aggiungere programmi all'elenco Programmi RemoteApp
Assegnare utenti di dominio e gruppi di dominio a un Programma RemoteApp. | Assegnare utenti di dominio e gruppi di dominio a un programma RemoteApp
Configurare impostazioni di distribuzione globali. | Configurare impostazioni di distribuzione
Stabilire come distribuire i Programmi RemoteApp agli utenti. | Distribuire programmi RemoteApp agli utenti
Se si intende distribuire Programmi RemoteApp tramite Connessione RemoteApp e desktop, configurare Accesso Web Desktop remoto. | Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto
Se si intende distribuire Programmi RemoteApp tramite file con estensione rdp, creare i file con estensione rdp. | Creare un file con estensione rdp
Se si intende distribuire i Programmi RemoteApp tramite pacchetti di Windows Installer, creare i pacchetti di Windows Installer. | Creare un pacchetto di Windows Installer
Gestire l'elenco Programmi RemoteApp (facoltativo). | Gestire l'elenco Programmi RemoteApp

Ulteriori riferimenti

  • Panoramica di RemoteApp


Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp

Per poter configurare Programmi RemoteApp per l'utilizzo, è necessario completare alcuni prerequisiti di installazione. Negli argomenti seguenti viene illustrato come configurare il server per ospitare Programmi RemoteApp:

  • Installare il servizio ruolo Host sessione Desktop remoto

  • Installare programmi

  • Verificare le impostazioni di connessione remota


Installare il servizio ruolo Host sessione Desktop remoto

Gestione RemoteApp viene installato come parte del servizio ruolo Host sessione Desktop remoto.

Utilizzare la procedura seguente per installare il servizio ruolo Host sessione Desktop remoto.

Importante

Per installare il servizio ruolo Host sessione Desktop remoto, è necessario riavviare il computer.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare il servizio ruolo Host sessione Desktop remoto

  1. Nel computer in cui si desidera installare il servizio ruolo Host sessione Desktop remoto, aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Se il ruolo Servizi Desktop remoto non è già installato:

    1. In Riepilogo ruoli fare clic su Aggiungi ruoli.

    2. Nella pagina Prima di iniziare dell'Aggiunta guidata ruoli fare clic su Avanti.

    3. Nella pagina Selezione ruoli server selezionare la casella di controllo Servizi Desktop remoto e quindi fare clic su Avanti.

    4. Nella pagina Servizi Desktop remoto fare clic su Avanti.

    5. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

    Se il ruolo Servizi Desktop remoto è già installato:

    1. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    2. In Servizi ruolo fare clic su Aggiungi servizi ruolo.

    3. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

  3. Nella pagina Disinstallazione e reinstallazione di applicazioni per la compatibilità fare clic su Avanti.

  4. Nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto selezionare il metodo di autenticazione desiderato e quindi fare clic su Avanti.

  5. Nella pagina Impostazione modalità di gestione licenze selezionare la modalità gestione licenze appropriata per l'ambiente Servizi Desktop remoto e quindi fare clic su Avanti.

  6. Nella pagina Selezione dei gruppi di utenti autorizzati ad accedere all'host sessione Desktop remoto aggiungere gli utenti o i gruppi che si desidera aggiungere al gruppo Utenti desktop remoto e quindi fare clic su Avanti.

  7. Nella pagina Configura esperienza client selezionare l'esperienza client che si desidera implementare e quindi fare clic su Avanti.

  8. Nella pagina Conferma selezioni per l'installazione verificare che il servizio ruolo Host sessione Desktop remoto venga installato e quindi fare clic su Installa.

  9. Nella pagina Stato installazione verrà indicato lo stato di avanzamento dell'installazione.

  10. Nella pagina Risultati installazione verrà richiesto di riavviare il server per completare il processo di installazione. Fare clic su Chiudi e quindi su Sì per riavviare il server.

  11. Se viene segnalato che altri programmi sono ancora in esecuzione, eseguire una delle operazioni seguenti:

    • Per chiudere i programmi manualmente e riavviare il server in un secondo momento, fare clic su Annulla.

    • Per chiudere i programmi automaticamente e riavviare il server, fare clic su Riavvia.

  12. Dopo aver riavviato il server e aver eseguito l'accesso al computer con lo stesso account utente, verranno completati gli altri passaggi dell'installazione. Quando viene visualizzata la pagina Risultati installazione, verificare che l'installazione del servizio ruolo Host sessione Desktop remoto sia stata eseguita correttamente.

Ulteriori riferimenti

  • Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp


Installare programmi

Installare programmi nel server remoto dopo avere installato il servizio ruolo Host sessione Desktop remoto. È possibile installare un programma nel server Host sessione Desktop remoto allo stesso modo in cui il programma viene installato in un desktop locale. Verificare, tuttavia, di installare il programma per tutti gli utenti e che tutti i componenti del programma vengano installati in locale nel server Host sessione Desktop remoto.

Se sono presenti programmi con relazioni di correlazione o di dipendenza reciproca, è consigliabile installarli nello stesso server Host sessione Desktop remoto. È consigliabile, ad esempio, installare Microsoft Office come suite anziché installare singole applicazioni di Office in server Host sessione Desktop remoto distinti.

È consigliabile installare singoli programmi in server Host sessione Desktop remoto distinti nei casi seguenti:

  • Possono verificarsi problemi di compatibilità tra il programma e altri programmi.

  • Un singolo programma e il numero di utenti associati rischiano di esaurire la capacità del server.

Ulteriori riferimenti

  • Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp


Verificare le impostazioni di connessione remota

Per impostazione predefinita, le connessioni remote vengono attivate dopo l'installazione del servizio ruolo Host sessione Desktop remoto. È possibile utilizzare la procedura seguente per aggiungere utenti e gruppi che devono connettersi al server Host sessione Desktop remoto e per verificare o modificare le impostazioni di connessione remota.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per verificare le impostazioni di connessione remota

  1. Nel server Host sessione Desktop remoto avviare lo strumento Sistema. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare control system e quindi fare clic su OK.

  2. In Attività fare clic su Impostazioni di connessione remota.

  3. Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema fare clic su una delle opzioni seguenti, in base all'ambiente:

    • Consenti connessioni da computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro)

    • Consenti connessioni solo dai computer che eseguono Desktop remoto con Autenticazione a livello di rete (più sicuro)

    Per ulteriori informazioni sulle due opzioni, fare clic sul collegamento Suggerimenti per la scelta nella scheda Connessione remota.

  4. Per aggiungere gli utenti e i gruppi che devono connettersi al server Host sessione Desktop remoto utilizzando Desktop remoto, fare clic su Seleziona utenti e quindi su Aggiungi.

    Gli utenti e i gruppi aggiunti verranno inseriti nel gruppo Utenti desktop remoto.

    Nota

    I membri del gruppo Administrators locale possono connettersi anche se non sono presenti nell'elenco.

Ulteriori riferimenti

  • Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp


Configurare programmi RemoteApp

In questa sezione sono incluse le procedure per configurare Programmi RemoteApp nel server Host sessione Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Aggiungere programmi all'elenco Programmi RemoteApp

  • Assegnare utenti di dominio e gruppi di dominio a un programma RemoteApp

  • Configurare impostazioni di distribuzione

  • Creare un file con estensione rdp

  • Creare un pacchetto di Windows Installer

  • Distribuire programmi RemoteApp agli utenti

  • Gestire l'elenco Programmi RemoteApp

È inoltre possibile utilizzare il modulo Servizi Desktop remoto per Windows PowerShell per configurare alcune impostazioni di un Programma RemoteApp. Per ulteriori informazioni sull'utilizzo di Windows PowerShell con Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139898.

Ulteriori riferimenti

  • Configurare il server Host sessione Desktop remoto per ospitare programmi RemoteApp


Aggiungere programmi all'elenco Programmi RemoteApp

Per rendere un programma disponibile agli utenti in remoto tramite Gestione RemoteApp, è necessario aggiungerlo all'elenco Programmi RemoteApp.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere un programma all'elenco Programmi RemoteApp

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Fare clic su Aggiungi programmi RemoteApp nel riquadro Azioni.

  3. Nella pagina Aggiunta guidata programma RemoteApp fare clic su Avanti.

  4. Nella pagina Scelta dei programmi da aggiungere all'elenco dei programmi RemoteApp selezionare la casella di controllo accanto a ogni programma che si desidera aggiungere all'elenco Programmi RemoteApp. È possibile selezionare più programmi.

    Nota

    I programmi visualizzati nella pagina Scelta dei programmi da aggiungere all'elenco dei programmi RemoteApp sono quelli disponibili nel menu Start di tutti gli utenti nel server Host sessione Desktop remoto. Se il programma che si desidera aggiungere all'elenco Programmi RemoteApp non è in elenco, fare clic su Sfoglia e quindi specificare il percorso del file con estensione exe del programma.

  5. Per configurare le proprietà di un Programma RemoteApp, fare clic con il pulsante destro del mouse sul nome del programma e quindi scegliere Proprietà. È possibile configurare quanto segue:

    • Nome del programma che verrà visualizzato per gli utenti. Per modificare il nome, digitarne uno nuovo nella casella Nome programma RemoteApp.

    • Percorso del file eseguibile del programma. Per modificare il percorso, digitarne uno nuovo nella casella Percorso o fare clic su Sfoglia per individuare il file con estensione exe.

      Nota

      È possibile utilizzare variabili di ambiente di sistema nel nome percorso. È ad esempio possibile sostituire %windir% per il percorso esplicito della cartella Windows (ad esempio, C:\Windows). Non è possibile utilizzare variabili di ambiente per utente.

    • Alias del Programma RemoteApp. L'alias è un identificatore univoco del programma impostato in maniera predefinita sul nome file del programma, senza estensione. È consigliabile non modificare questo nome.

    • Se il programma è disponibile tramite Accesso Web Desktop remoto. Per impostazione predefinita, l'impostazione Programma RemoteApp disponibile tramite Accesso Web Desktop remoto è attivata. Per modificare l'impostazione, selezionare o deselezionare la casella di controllo.

    • Se sono consentiti o meno argomenti della riga di comando o se utilizzare sempre gli stessi argomenti della riga di comando.

    • Icona del programma che verrà utilizzata. Per modificare l'icona, fare clic su Cambia icona.

    • Utenti di dominio e gruppi di dominio che possono visualizzare l'icona del programma quando questo viene reso disponibile tramite Accesso Web Desktop remoto. Per specificare gli utenti di dominio e i gruppi di dominio, fare clic sulla scheda Assegnazione utente. Per ulteriori informazioni, vedere Assegnare utenti di dominio e gruppi di dominio a un programma RemoteApp.

  6. Dopo aver completato la configurazione delle proprietà dei programmi, fare clic su OK e quindi su Avanti.

  7. Nella pagina Revisione impostazioni esaminare le impostazioni e quindi fare clic su Fine.

    I programmi selezionati dovrebbero essere visualizzati nell'elenco Programmi RemoteApp.

Ulteriori riferimenti

  • Configurare programmi RemoteApp


Assegnare utenti di dominio e gruppi di dominio a un programma RemoteApp

È possibile specificare gli utenti di dominio e i gruppi di dominio autorizzati a visualizzare l'icona di un Programma RemoteApp quando il Programma RemoteApp viene reso disponibile tramite Accesso Web Desktop remoto. Per impostazione predefinita, tutti gli utenti di dominio autenticati saranno in grado di visualizzare l'icona di un Programma RemoteApp nel sito Web reso disponibile da Accesso Web Desktop remoto.

Importante
  • Per assegnare utenti a un Programma RemoteApp, il server Host sessione Desktop remoto in cui è configurato il Programma RemoteApp deve essere un membro di un dominio Active Directory.
  • Per eseguire il Programma RemoteApp, un utente deve essere un membro del gruppo Utenti desktop remoto nel server Host sessione Desktop remoto.

Utilizzare la procedura seguente per specificare gli utenti di dominio e i gruppi di dominio autorizzati a visualizzare l'icona di un Programma RemoteApp.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per assegnare utenti di dominio e gruppi di dominio a un programma RemoteApp

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nell'elenco Programmi RemoteApp fare clic sul programma a cui si desidera assegnare utenti di dominio e gruppi di dominio.

  3. Nel riquadro Azioni relativo al programma fare clic su Proprietà e quindi sulla scheda Assegnazione utente.

  4. Fare clic su Utenti o gruppi di dominio specificati e quindi su Aggiungi.

  5. Utilizzare la finestra di dialogo di selezione di utenti o gruppi per selezionare gli utenti di dominio e i gruppi di dominio da assegnare al Programma RemoteApp.

  6. Fare clic su OK per chiudere la finestra di dialogo di selezione di utenti o gruppi.

  7. Fare clic su OK per chiudere la finestra di dialogo Proprietà RemoteApp.

Ulteriori riferimenti

  • Aggiungere programmi all'elenco Programmi RemoteApp

  • Configurare programmi RemoteApp


Configurare impostazioni di distribuzione

È possibile configurare impostazioni di distribuzione valide per tutti i Programmi RemoteApp inclusi nell'elenco Programmi RemoteApp. Queste impostazioni si applicano a qualsiasi Programma RemoteApp reso disponibile tramite Accesso Web Desktop remoto. Tali impostazioni verranno inoltre utilizzate come impostazioni predefinite se si creano file con estensione rdp o pacchetti di Windows Installer da uno dei Programmi RemoteApp inclusi nell'elenco.

Nota

Qualsiasi modifica alle impostazioni di distribuzione apportata quando si utilizza Gestione RemoteApp per creare file con estensione rdp o pacchetti di Windows Installer sostituirà le impostazioni di distribuzione globali.

Le impostazioni di distribuzione globali includono le seguenti:

  • Impostazioni del server Host sessione Desktop remoto. Per ulteriori informazioni, vedere Configurare le impostazioni del server Host sessione Desktop remoto.

  • Impostazioni di Gateway Desktop remoto. Per ulteriori informazioni, vedere Configurare le impostazioni di Gateway Desktop remoto.

  • Impostazioni comuni RDP (Remote Desktop Protocol). Per ulteriori informazioni, vedere Configurare impostazioni RDP comuni.

  • Impostazioni personalizzate RDP. Per ulteriori informazioni, vedere Configurare impostazioni RDP personalizzate.

  • Impostazioni firma digitale. Per ulteriori informazioni, vedere Informazioni sulla firma digitale di programmi RemoteApp.

Ulteriori riferimenti

  • Configurare programmi RemoteApp


Configurare le impostazioni del server Host sessione Desktop remoto

Per definire il modo in cui gli utenti si connetteranno al server Host sessione Desktop remoto (o alla server farm Host sessione Desktop remoto) per accedere a Programmi RemoteApp, è possibile configurare le impostazioni di distribuzione del server Host sessione Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni del server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nel riquadro Azioni di Gestione RemoteApp fare clic su Impostazioni host sessione Desktop remoto. In alternativa, nel riquadro Generale fare clic su Cambia accanto a Impostazioni host sessione Desktop remoto.

  3. Nella scheda Host sessione Desktop remoto accettare o modificare il nome del server e il numero di porta Remote Desktop Protocol in Impostazioni di connessione.

  4. Per fornire un collegamento a una sessione desktop completa nel server Host sessione Desktop remoto tramite Accesso Web Desktop remoto, selezionare la casella di controllo Mostra in Accesso Web Desktop remoto una connessione desktop remoto a questo server Host sessione Desktop remoto in Accesso Desktop remoto.

    Nota

    Se si desidera consentire all'utente di utilizzare tutti i monitor client disponibili per la connessione a una sessione desktop completa nel server Host sessione Desktop remoto, in Tipo di installazione nella scheda Impostazioni comuni RDP selezionare la casella di controllo Usa tutti i monitor client durante la connessione a un desktop remoto.

  5. In Accesso ai programmi non elencati una delle opzioni seguenti:

    • Non consentire agli utenti di avviare i programmi non inclusi nell'elenco dopo la connessione iniziale (opzione consigliata)

      Per proteggersi da utenti malintenzionati o da un utente che avvia inavvertitamente un programma da un file con estensione rdp al momento della connessione iniziale, è consigliabile selezionare questa impostazione.

      Importante

      Questa impostazione non impedisce agli utenti di avviare in remoto programmi non elencati dopo essersi connessi al server Host sessione Desktop remoto utilizzando il Programma RemoteApp. Se, ad esempio, Microsoft Word è presente nell'elenco Programmi RemoteApp e un Web browser non lo è e un utente avvia una sessione di Word e quindi fa clic su un collegamento ipertestuale in un documento di Word, tale utente potrà avviare il Web browser.

    • Consenti agli utenti di avviare sia i programmi inclusi nell'elenco che quelli non inclusi dopo la connessione iniziale

      Attenzione

      Se si sceglie questa opzione, al momento della connessione iniziale, gli utenti possono avviare in remoto, da un file con estensione rdp, qualsiasi programma e non solo quelli inclusi nell'elenco Programmi RemoteApp. Per proteggersi da utenti malintenzionati o da un utente che avvia inavvertitamente un programma da un file con estensione rdp, è consigliabile non selezionare questa impostazione.

  6. Al termine fare clic su OK.

Ulteriori riferimenti

  • Configurare impostazioni di distribuzione


Configurare le impostazioni di Gateway Desktop remoto

Per definire se gli utenti si connetteranno al server Host sessione Desktop remoto attraverso un firewall tramite Gateway Desktop remoto, è possibile configurare le impostazioni di distribuzione di Gateway Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare le impostazioni di Gateway Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nel riquadro Azioni di Gestione RemoteApp fare clic su Impostazioni Gateway Desktop remoto. In alternativa, nel riquadro Generale fare clic su Cambia accanto a Impostazioni Gateway Desktop remoto.

  3. Nella scheda Gateway Desktop remoto configurare il comportamento desiderato per Gateway Desktop remoto. È possibile specificare se rilevare automaticamente le impostazioni del server Gateway Desktop remoto, utilizzare le impostazioni del server Gateway Desktop remoto specificate o non utilizzare un server Gateway Desktop remoto.

    Se si seleziona Rileva automaticamente impostazioni del server Gateway Desktop remoto, il client tenterà di utilizzare le impostazioni di Criteri di gruppo per determinare il comportamento delle connessioni client a Gateway Desktop remoto.

    Se si seleziona Usa le seguenti impostazioni del server Gateway Desktop remoto, eseguire le operazioni seguenti:

    1. Configurare il nome del server Gateway Desktop remoto e il metodo di accesso.

      Importante

      Il nome del server deve corrispondere a quello specificato nel certificato SSL (Secure Sockets Layer) per il server Gateway Desktop remoto.

    2. Se si desidera tentare di utilizzare le stesse credenziali utente per accedere sia a Gateway Desktop remoto sia al server Host sessione Desktop remoto, selezionare la casella di controllo Usa le stesse credenziali utente per Gateway Desktop remoto e per il server host sessione Desktop remoto. Tuttavia, gli utenti potrebbero continuare a ricevere due richieste di credenziali, se sono presenti credenziali in conflitto da una qualsiasi origine, quali ad esempio le impostazioni dei Criteri di gruppo, e se tali credenziali non funzionano. Potrebbero inoltre ricevere due richieste di credenziali, se per la connessione vengono utilizzate credenziali predefinite che non funzionano.

    3. Se si desidera che il computer client rilevi automaticamente i casi in cui Gateway Desktop remoto è necessario, selezionare la casella di controllo Ignora server Gateway Desktop remoto per indirizzi locali. Se si seleziona questa opzione, le prestazioni dei client verranno ottimizzate.

      Per utilizzare sempre un server Gateway Desktop remoto per le connessioni client, deselezionare la casella di controllo Ignora server Gateway Desktop remoto per indirizzi locali.

  4. Al termine fare clic su OK.

Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare impostazioni di distribuzione


Configurare impostazioni RDP comuni

È possibile specificare impostazioni RDP (Remote Desktop Protocol) comuni per le connessioni RemoteApp, ad esempio il reindirizzamento dispositivi e risorse, e alcune impostazioni di visualizzazione utente. Queste impostazioni verranno applicate quando un utente si connette a un Programma RemoteApp tramite Accesso Web Desktop remoto o quando si crea un file con estensione rdp o un pacchetto di Windows Installer da un Programma RemoteApp esistente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare impostazioni RDP comuni

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nel riquadro Generale di Gestione RemoteApp fare clic su Cambia accanto a Impostazioni RDP.

  3. In Dispositivi e risorse configurare quali dispositivi e risorse presenti sul computer client si desidera rendere disponibili nella sessione remota.

  4. In Tipo di installazione scegliere se consentire i caratteri smussati e l'intensità del colore desiderata.

    È inoltre possibile scegliere se verranno utilizzati tutti i monitor client disponibili per la connessione a un desktop remoto. Questa impostazione viene applicata solo se l'utente si connette a una sessione desktop completa nel server Host sessione Desktop remoto tramite Accesso Web Desktop remoto. Le connessioni a Programmi RemoteApp tentano sempre di utilizzare tutti i monitor client disponibili.

    Nota

    Per fornire un collegamento a una sessione desktop completa nel server Host sessione Desktop remoto tramite Accesso Web Desktop remoto, in Accesso desktop remoto nella scheda Host sessione Desktop remoto selezionare la casella di controllo Mostra in Accesso Web Desktop remoto una connessione desktop remoto a questo server Host sessione Desktop remoto.

  5. Al termine fare clic su Applica.

    Nota

    Per configurare ulteriori impostazioni RDP, come il reindirizzamento audio, fare clic sulla scheda Impostazioni personalizzate RDP. Per ulteriori informazioni, vedere Configurare impostazioni RDP personalizzate.

  6. Per chiudere la finestra di dialogo Impostazioni di distribuzione RemoteApp, fare clic su OK.
Nota

Se non si firmano digitalmente i file con estensione rdp o se vi si applica una firma digitale che i client non riconoscono (ad esempio un certificato di un'Autorità di certificazione privata), alcune impostazioni di reindirizzamento specificate in Gestione RemoteApp potrebbero essere ignorate dal client. Se si attivano, ad esempio, tutte le impostazioni di reindirizzamento della scheda Impostazioni comuni RDP e un utente si connette a un file con estensione rdp non firmato, le unità disco e i dispositivi Plug and Play supportati non verranno automaticamente reindirizzati. Tali dispositivi e risorse verranno reindirizzati solo se l'utente attiva le impostazioni di reindirizzamento pertinenti nella finestra di dialogo di avviso RemoteApp visualizzata quando si tenta di stabilire la connessione. Questo comportamento predefinito consente di ridurre potenziali vulnerabilità di sicurezza. Si noti che lo stesso comportamento si verifica se si attiva il reindirizzamento delle porte seriali nella scheda Impostazioni personalizzate RDP.

Per ulteriori informazioni sulle impostazioni RDP per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139899.

Ulteriori riferimenti

  • Configurare impostazioni di distribuzione

  • Informazioni sulla firma digitale di programmi RemoteApp


Configurare impostazioni RDP personalizzate

È possibile specificare impostazioni Remote Desktop Protocol (RDP) personalizzate per connessioni RemoteApp, ad esempio il reindirizzamento audio. Queste impostazioni verranno applicate quando un utente si connette a un Programma RemoteApp tramite Accesso Web Desktop remoto o quando si crea un file con estensione rdp o un pacchetto di Windows Installer da un programma RemoteApp esistente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare impostazioni RDP personalizzate

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nel riquadro Generale di Gestione RemoteApp fare clic su Cambia accanto a Impostazioni RDP.

  3. Nella scheda Impostazioni personalizzate RDP digitare o copiare nella casella Impostazioni personalizzate RDP le impostazioni RDP personalizzate che si desidera utilizzare.

    Nota

    Per impostazione predefinita, l'impostazione RDP per il livello di autenticazione viene aggiunta nella casella Impostazioni personalizzate RDP in Windows Server 2008 R2.

    Per copiare impostazioni da un file con estensione rdp, aprire il file in un editor di testo quale Blocco note e quindi copiare le impostazioni desiderate.

    Importante

    Non è possibile ignorare impostazioni disponibili nelle impostazioni di distribuzione globali in Gestione RemoteApp, incluse le impostazioni del server Gateway Desktop remoto e le impostazioni RDP comuni. In caso contrario, verrà richiesto di rimuovere queste impostazioni quando si fa clic su Applica.

    Per creare un file con estensione rdp da cui copiare le impostazioni, eseguire la procedura seguente:

    1. Aprire il client di Connessione Desktop remoto e quindi fare clic su Opzioni.

    2. Configurare le impostazioni desiderate, ad esempio il reindirizzamento audio.

    3. Al termine dell'operazione, nella scheda Generale fare clic su Salva con nome e quindi salvare il file con estensione rdp.

    4. Aprire il file con estensione rdp in Blocco note e quindi copiare le impostazioni desiderate nella casella Impostazioni personalizzate RDP nella scheda Impostazioni personalizzate RDP.

  4. Dopo aver completato l'aggiunta delle impostazioni desiderate, fare clic su Applica.

  5. Se viene visualizzata la finestra di dialogo Errore nelle impostazioni personalizzate RDP, eseguire le operazioni seguenti:

    1. Fare clic su Rimuovi per rimuovere automaticamente le impostazioni che non sono valide o non possono essere ignorate o fare clic su OK per rimuovere le impostazioni manualmente.

    2. Dopo aver rimosso le impostazioni, fare nuovamente clic su Applica.

  6. Per chiudere la finestra di dialogo Impostazioni di distribuzione RemoteApp, fare clic su OK.

Per ulteriori informazioni sulle impostazioni RDP per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139899.

Ulteriori riferimenti

  • Configurare impostazioni di distribuzione

  • Configurare impostazioni RDP comuni


Informazioni sulla firma digitale di programmi RemoteApp

È possibile utilizzare una firma digitale per firmare file con estensione rdp utilizzati per connessioni RemoteApp al server Host sessione Desktop remoto. Sono inclusi i file con estensione rdp utilizzati per le connessioni tramite Accesso Web Desktop remoto a Programmi RemoteApp e al desktop di un server Host sessione Desktop remoto.

Importante

Per connettersi a un Programma RemoteApp utilizzando un file con estensione rdp con firma digitale, il client deve eseguire almeno Connessione Desktop remoto 6.1. Il client di Connessione Desktop remoto 6.1 supporta Remote Desktop Protocol 6.1.

Se si utilizza un certificato digitale, la firma crittografata sul file di connessione fornisce informazioni verificabili sull'identità dell'autore. In questo modo, i client possono riconoscere l'organizzazione come origine del Programma RemoteApp o della connessione desktop remoto e adottare decisioni relative all'attendibilità più consapevoli nel determinare se avviare la connessione. Questo consente di proteggersi dall'uso di file con estensione rdp modificati da un utente malintenzionato.

È possibile firmare i file con estensione rdp utilizzati per connessioni RemoteApp utilizzando un certificato di tipo Autenticazione server [certificato SSL (Secure Sockets Layer)], un certificato di firma codice o un certificato di firma RDP (Remote Desktop Protocol). È possibile ottenere certificati SSL e di firma codice da autorità di certificazione pubbliche o da un'autorità di certificazione dell'organizzazione (enterprise) nella gerarchia dell'infrastruttura a chiave pubblica. Prima di poter utilizzare un certificato di firma RDP, è necessario configurare un'autorità di certificazione nell'organizzazione per rilasciare certificati di firma RDP.

Se si utilizza già un certificato SSL per le connessioni al server Host sessione Desktop remoto o a Gateway Desktop remoto, è possibile utilizzare lo stesso certificato per firmare file con estensione rdp. Se, tuttavia, gli utenti si connettono a Programmi RemoteApp da computer pubblici o di casa, è necessario utilizzare una delle opzioni seguenti:

  • Un certificato di un'autorità di certificazione pubblica che partecipa al programma Microsoft Root Certificate (http://go.microsoft.com/fwlink/?LinkID=59547).

  • Se si sta utilizzando un'autorità di certificazione dell'organizzazione (enterprise), il certificato rilasciato da tale autorità deve essere cofirmato da un'autorità di certificazione pubblica che partecipa al programma Microsoft Root Certificate.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare il certificato digitale da utilizzare

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nel riquadro Azioni di Gestione RemoteApp fare clic su Impostazioni firma digitale (oppure, nel riquadro Generale fare clic su Cambia accanto a Impostazioni firma digitale).

  3. Selezionare la casella di controllo Firma con un certificato digitale.

  4. Nella casella Dettagli certificato digitale fare clic su Cambia.

  5. Nella finestra di dialogo Selezione certificato selezionare il certificato che si desidera utilizzare e quindi fare clic su OK.

    Nota

    La finestra di dialogo Selezione certificato è popolata da certificati presenti nell'archivio certificati del computer locale o nel proprio archivio certificati personali. Il certificato che si desidera utilizzare deve trovarsi in uno di questi archivi.

Utilizzare le impostazioni di Criteri di gruppo per controllare il comportamento dei client quando si apre un file con estensione rdp e firma digitale

È possibile utilizzare Criteri di gruppo per configurare i client in modo da riconoscere sempre come trusted i Programmi RemoteApp di un determinato autore. È inoltre possibile configurare se i client bloccheranno i Programmi RemoteApp e le connessioni desktop remoto di origini esterne o sconosciute. Utilizzando queste impostazioni dei criteri, è possibile ridurre il numero e la complessità delle decisioni di sicurezza che riguardano gli utenti, riducendo anche la possibilità di azioni involontarie degli utenti che potrebbero causare vulnerabilità di sicurezza.

Di seguito vengono indicate le impostazioni di Criteri di gruppo pertinenti:

  • Specifica identificazioni personali SHA1 dei certificati che rappresentano gli autori di file rdp attendibili

  • Consenti esecuzione dei file rdp di autori validi e impostazioni rdp predefinite dell'utente

  • Consenti esecuzione di file rdp di autori sconosciuti

Queste impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Client di Connessione Desktop remoto e Configurazione utente\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Client di Connessione Desktop remoto.

Queste impostazioni di Criteri di gruppo possono essere configurate utilizzando l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare impostazioni di distribuzione


Creare un file con estensione rdp

È possibile utilizzare l'Aggiunta guidata programma RemoteApp per creare un file Remote Desktop Protocol (con estensione rdp) da qualsiasi programma presente nell'elenco Programmi RemoteApp. Per ulteriori informazioni sulla modalità di distribuzione dei file con estensione rdp agli utenti, vedere Distribuire programmi RemoteApp agli utenti.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare un file con estensione rdp

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nell'elenco Programmi RemoteApp fare clic sul programma per cui si desidera creare un file con estensione rdp. Per selezionare più programmi, fare clic sul nome di ogni programma tenendo premuto CTRL.

  3. Nel riquadro Azioni relativo al programma o ai programmi selezionati fare clic su Crea file con estensione rdp.

    Nota

    Se si sono selezionati più programmi, le impostazioni descritte nella restante parte di questa procedura verranno applicate a ognuno di essi. Verrà creato un file con estensione rdp separato per ogni programma.

  4. Nella pagina Aggiunta guidata programma RemoteApp fare clic su Avanti.

  5. Nella pagina Definizione impostazioni pacchetto eseguire le operazioni seguenti:

    1. Nella casella Immettere il percorso per il salvataggio dei pacchetti accettare il percorso predefinito o fare clic su Sfoglia per specificare un nuovo percorso in cui salvare il file con estensione rdp.

    2. Nell'area Impostazioni host sessione Desktop remoto fare clic su Cambia per modificare il nome del server o il numero di porta Remote Desktop Protocol (RDP). Al termine fare clic su OK.

    3. Nell'area Impostazioni Gateway Desktop remoto fare clic su Cambia per modificare o configurare l'utilizzo da parte dei client di un server Gateway Desktop remoto per la connessione al server Host sessione Desktop remoto di destinazione attraverso un firewall. Per ulteriori informazioni su queste impostazioni, vedere Configurare le impostazioni di Gateway Desktop remoto. Al termine, fare clic su OK.

    4. Per firmare digitalmente il file con estensione rdp, nell'area Impostazioni dei certificati fare clic su Cambia per selezionare o modificare il certificato. Per ulteriori informazioni, vedere Informazioni sulla firma digitale di programmi RemoteApp. Selezionare il certificato che si desidera utilizzare e quindi fare clic su OK.

  6. Al termine, fare clic su Avanti.

  7. Nella pagina Revisione impostazioni fare clic su Fine.

    Al termine della procedura guidata, la cartella in cui è stato salvato il file con estensione rdp si aprirà in una nuova finestra. È possibile confermare che il file con estensione rdp è stato creato.

Ulteriori riferimenti

  • Configurare programmi RemoteApp


Creare un pacchetto di Windows Installer

È possibile utilizzare l'Aggiunta guidata programma RemoteApp per creare un pacchetto di Microsoft Windows Installer (con estensione msi) da qualsiasi programma presente nell'elenco Programmi RemoteApp. Per ulteriori informazioni sulla modalità di distribuzione dei pacchetti Windows Installer agli utenti, vedere Distribuire programmi RemoteApp agli utenti.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per creare un pacchetto Windows Installer

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nell'elenco Programmi RemoteApp fare clic sul programma per cui si desidera creare un pacchetto Windows Installer. Per selezionare più programmi, fare clic sul nome di ogni programma tenendo premuto CTRL.

  3. Nel riquadro Azioni relativo al programma o ai programmi selezionati fare clic su Crea pacchetto Windows Installer.

    Nota

    Se si sono selezionati più programmi, le impostazioni descritte nella restante parte di questa procedura verranno applicate a ognuno di essi. Verrà creato un pacchetto Windows Installer separato per ogni programma.

  4. Nella pagina Aggiunta guidata programma RemoteApp fare clic su Avanti.

  5. Nella pagina Definizione impostazioni pacchetto eseguire le operazioni seguenti:

    1. Nella casella Immettere il percorso per il salvataggio dei pacchetti accettare il percorso predefinito o fare clic su Sfoglia per specificare un nuovo percorso in cui salvare il pacchetto Windows Installer.

    2. Nell'area Impostazioni host sessione Desktop remoto fare clic su Cambia per modificare il nome del server o il numero di porta Remote Desktop Protocol (RDP). Al termine fare clic su OK.

    3. Nell'area Impostazioni Gateway Desktop remoto fare clic su Cambia per modificare o configurare l'utilizzo da parte dei client di un server Gateway Desktop remoto per la connessione al server Host sessione Desktop remoto di destinazione attraverso un firewall. Per ulteriori informazioni su queste impostazioni, vedere Configurare le impostazioni di Gateway Desktop remoto. Al termine, fare clic su OK.

    4. Per firmare digitalmente il file, nell'area Impostazioni dei certificati fare clic su Cambia per selezionare o modificare il certificato. Per ulteriori informazioni, vedere Informazioni sulla firma digitale di programmi RemoteApp. Selezionare il certificato che si desidera utilizzare e quindi fare clic su OK.

  6. Al termine, fare clic su Avanti.

  7. Nella pagina Configurazione pacchetto di distribuzione eseguire le operazioni seguenti:

    1. Nell'area Icone collegamenti specificare dove verrà visualizzata l'icona del collegamento relativa al programma nei computer client.

    2. Nell'area Utilizzo estensioni client stabilire se utilizzare le estensioni di file client per il programma.

      Se si associano le estensioni di file nel computer client al Programma RemoteApp, anche tutte le estensioni di file gestite dal programma nel server Host sessione Desktop remoto verranno associate nel computer client al Programma RemoteApp. Si noti che agli utenti non verrà richiesto se Host sessione Desktop remoto deve utilizzare le estensioni di file per il programma.

      Per visualizzare le estensioni di file associate a un programma nel server Host sessione Desktop remoto, fare clic su Start, scegliere Pannello di controllo e quindi fare doppio clic su Programmi predefiniti. Fare clic su Associa un tipo di file o un protocollo a un programma per visualizzare le estensioni di file e il relativo programma associato predefinito.

      Attenzione

      Non installare pacchetti di Windows Installer creati con questa impostazione attivata nel server Host sessione Desktop remoto stesso. In caso contrario, i client che utilizzano il pacchetto di Windows Installer potrebbero non essere in grado di avviare il Programma RemoteApp associato.

  8. Dopo aver configurato le proprietà del pacchetto di distribuzione, fare clic su Avanti.

  9. Nella pagina Revisione impostazioni fare clic su Fine.

    Al termine della procedura guidata, la cartella in cui è stato salvato il pacchetto Windows Installer si aprirà in una nuova finestra. È possibile confermare che il pacchetto Windows Installer (con estensione msi) è stato creato.

Ulteriori riferimenti

  • Configurare programmi RemoteApp


Distribuire programmi RemoteApp agli utenti

È possibile distribuire Programmi RemoteApp agli utenti utilizzando metodi diversi. A seconda del metodo scelto, gli utenti potranno:

  • Accedere a un collegamento al programma tramite Connessione RemoteApp e desktop utilizzando Accesso Web Desktop remoto.

    Accesso Web Desktop remoto è un servizio ruolo Servizi Desktop remoto che consente di rendere i Programmi RemoteApp disponibili per gli utenti tramite Connessione RemoteApp e desktop. Per ulteriori informazioni, vedere Accesso Web Desktop remoto.

  • Fare doppio clic su un file con estensione rdp creato e distribuito dall'amministratore.

    È possibile creare un file Remote Desktop Protocol (con estensione rdp) per distribuire Programmi RemoteApp agli utenti. Per ulteriori informazioni, vedere Creare un file con estensione rdp. È possibile distribuire un file con estensione rdp nei computer client utilizzando il processo di distribuzione software esistente, ad esempio Microsoft Systems Management Server, o una condivisione file.

  • Fare doppio clic sull'icona del programma, presente sul desktop o nel menu Start, creato e distribuito dall'amministratore con un pacchetto Windows Installer.

    È possibile creare un pacchetto di Windows Installer (con estensione msi) per distribuire Programmi RemoteApp agli utenti. Per ulteriori informazioni, vedere Creare un pacchetto di Windows Installer. Per distribuire un pacchetto di Windows Installer in computer client, è possibile utilizzare il processo di distribuzione software esistente, ad esempio Microsoft Systems Management Server o Criteri di gruppo di Active Directory. È inoltre possibile rendere il pacchetto Windows Installer disponibile tramite una condivisione file.

  • Fare doppio clic su un file la cui l'estensione di file è associata a un programma RemoteApp.

    Se si distribuiscono Programmi RemoteApp tramite pacchetti di Windows Installer, è possibile definire se il server Host sessione Desktop remoto utilizzerà le estensioni di file del client per il Programma RemoteApp. Per ulteriori informazioni, vedere Creare un pacchetto di Windows Installer.

Importante

Per accedere ai Programmi RemoteApp, il computer client deve eseguire almeno Connessione Desktop remoto 6.0.

Ulteriori riferimenti

  • Configurare programmi RemoteApp


Gestire l'elenco Programmi RemoteApp

In Gestione RemoteApp è possibile apportare modifiche ai Programmi RemoteApp esistenti oppure rimuovere programmi dall'elenco Programmi RemoteApp. È inoltre possibile importare o esportare l'elenco dei Programmi RemoteApp e le impostazioni di distribuzione globali in o da un altro server Host sessione Desktop remoto.

  • Modificare o eliminare un programma RemoteApp

  • Esportare o importare una configurazione

Ulteriori riferimenti

  • Configurare programmi RemoteApp


Modificare o eliminare un programma RemoteApp

Dopo avere aggiunto programmi all'elenco Programmi RemoteApp, è possibile modificare le impostazioni di distribuzione per tutti i Programmi RemoteApp, modificare le proprietà di un singolo Programma RemoteApp o eliminare il Programma RemoteApp dall'elenco.

  • Per modificare le impostazioni di distribuzione per tutti i Programmi RemoteApp, nel riquadro Azioni di Gestione RemoteApp fare clic su Impostazioni host sessione Desktop remoto, Impostazioni Gateway Desktop remoto o Impostazioni firma digitale. In alternativa, è possibile fare clic su una delle opzioni Cambia nel riquadro Panoramica. È inoltre possibile modificare le impostazioni RDP dal riquadro Panoramica.

    Importante

    Se si apportano modifiche, queste non avranno effetto sui file con estensione rdp o i pacchetti di Windows Installer già creati utilizzando Gestione RemoteApp.

  • Per modificare le proprietà di un singolo Programma RemoteApp, fare clic sul programma nell'elenco Programmi RemoteApp e quindi fare clic su Proprietà nel riquadro Azioni relativo al programma.

    Nota

    Non è possibile modificare le proprietà di un file con estensione rdp o di un pacchetto di Windows Installer utilizzando Gestione RemoteApp. È invece necessario fare clic su Crea file con estensione rdp o Crea pacchetto Windows Installer nel riquadro Azioni, per creare un nuovo file con estensione rdp o un nuovo pacchetto Windows Installer con le proprietà desiderate.

  • Per specificare se il Programma RemoteApp sarà disponibile da Accesso Web Desktop remoto, fare clic sul nome del programma nell'elenco Programmi RemoteApp e quindi fare clic su Mostra in Accesso Web Desktop remoto o Nascondi in Accesso Web Desktop remoto nel riquadro Azioni.

  • Per eliminare un programma dall'elenco Programmi RemoteApp, fare clic sul Programma RemoteApp e quindi fare clic su Rimuovi nel riquadro Azioni relativo al programma. Fare clic su Sì per confermare l'eliminazione.

    Nota

    Quando si elimina un programma dall'elenco Programmi RemoteApp, tutti i file con estensione rdp o i pacchetti di Windows Installer creati dal Programma RemoteApp non verranno eliminati.

Ulteriori riferimenti

  • Gestire l'elenco Programmi RemoteApp

  • Configurare programmi RemoteApp


Esportare o importare una configurazione

È possibile copiare l'elenco dei Programmi RemoteApp e le impostazioni di distribuzione da un server Host sessione Desktop remoto a un altro server Host sessione Desktop remoto. Questa operazione può essere necessaria se si desidera configurare più server Host sessione Desktop remoto in modo identico per ospitare Programmi RemoteApp, ad esempio in una server farm Host sessione Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per esportare l'elenco Programmi RemoteApp e le impostazioni di distribuzione

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Fare clic su Esporta impostazioni RemoteApp nel riquadro Azioni.

  3. Selezionare una delle opzioni seguenti:

    • Esporta elenco Programmi RemoteApp e impostazioni in un altro server Host sessione Desktop remoto

      Se si seleziona questa opzione, immettere il nome del server Host sessione Desktop remoto in cui si desidera esportare le impostazioni nella casella Nome server Host sessione Desktop remoto. Perché l'operazione di esportazione abbia esito positivo, il server Host sessione Desktop remoto di origine deve disporre di accesso Strumentazione gestione Windows (WMI) al server Host sessione Desktop remoto di destinazione.

      Importante

      Quando si fa clic su OK, l'elenco Programmi RemoteApp e le impostazioni di distribuzione verranno automaticamente sovrascritti nel server Host sessione Desktop remoto di destinazione.

    • Esporta l'elenco di programmi RemoteApp e le impostazioni in un file

      Se si seleziona questa opzione, fare clic su OK. Nella finestra di dialogo Salva con nome specificare una posizione in cui salvare il file con estensione tspub e quindi fare clic su Salva.
Per importare l'elenco Programmi RemoteApp e le impostazioni di distribuzione

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Fare clic su Importa impostazioni RemoteApp nel riquadro Azioni.

  3. Selezionare una delle opzioni seguenti:

    • Importa elenco Programmi RemoteApp e impostazioni da un altro server Host sessione Desktop remoto

      Se si seleziona questa opzione, immettere il nome del server Host sessione Desktop remoto da cui si desidera importare le impostazioni nella casella Nome server Host sessione Desktop remoto e quindi fare clic su OK. Perché l'operazione di importazione abbia esito positivo, il server Host sessione Desktop remoto di origine deve disporre di accesso WMI al server Host sessione Desktop remoto di destinazione.

    • Importa l'elenco di programmi RemoteApp e le impostazioni da un file

      Se si seleziona questa opzione, fare clic su OK. Nella finestra di dialogo Apri individuare e fare clic sul file con estensione tspub che si desidera importare e quindi scegliere Apri.

Se si importa una configurazione e nel server Host sessione Desktop remoto di destinazione non è installato alcun programma nell'elenco Programmi RemoteApp o se il programma è installato in una cartella diversa, il programma verrà visualizzato nell'elenco Programmi RemoteApp. Tuttavia, il nome verrà visualizzato in testo barrato.

Nota

Verranno esportati o importati solo l'elenco Programmi RemoteApp e le impostazioni di distribuzione. Non verranno esportati o importati eventuali file con estensione rdp o pacchetti Windows Installer creati dai programmi. Sarà necessario creare nuovi file con estensione rdp o pacchetti di Windows Installer in ogni server Host sessione Desktop remoto, a meno che il server non sia un membro di una server farm Host sessione Desktop remoto. Se durante la creazione dei file con estensione rdp o dei pacchetti di Windows Installer è stato specificato un nome di farm e il server in cui si desidera copiare i file è un membro della stessa server farm Host sessione Desktop remoto, è possibile copiare manualmente i file.

Ulteriori riferimenti

  • Gestire l'elenco Programmi RemoteApp

  • Configurare programmi RemoteApp


Elenco di controllo: rendere i programmi RemoteApp disponibili da Internet

Utilizzando RemoteApp insieme a Gateway Desktop remoto, è possibile consentire agli utenti di connettersi da Internet a singoli programmi in un Host sessione Desktop remoto senza dover prima stabilire una connessione a una rete privata virtuale. A seconda del metodo di distribuzione scelto, gli utenti remoti possono connettersi a un programma aprendo un file con estensione rdp, facendo clic su un collegamento a un pacchetto di Windows Installer sul desktop o nel menu Start o accedendo a un Programma RemoteApp tramite Connessione RemoteApp e desktop utilizzando Accesso Web Desktop remoto.

In questo elenco di controllo viene illustrata la procedura necessaria per rendere i Programmi RemoteApp disponibili da Internet tramite Gateway Desktop remoto. In alternativa, se non si desidera distribuire Gateway Desktop remoto, è possibile rendere i Programmi RemoteApp disponibili tramite una soluzione di rete privata virtuale.

Importante

Per poter completare l'elenco di controllo, è necessario soddisfare i prerequisiti seguenti:

  • È necessario aver già distribuito Programmi RemoteApp nel server Host sessione Desktop remoto. Per ulteriori informazioni, vedere Elenco di controllo: configurare RemoteApp

  • Se si desidera rendere i Programmi RemoteApp disponibili da Internet tramite Accesso Web Desktop remoto, è necessario aver già distribuito Accesso Web Desktop remoto in un ambiente Intranet. Per ulteriori informazioni, vedere Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto.

Attività Riferimento

Analizzare le informazioni su Gateway Desktop remoto.

Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Distribuire e configurare Gateway Desktop remoto. Quando si configura Gateway Desktop remoto, assicurarsi di eseguire le operazioni seguenti:

  • Creare Criteri di autorizzazione connessioni Desktop remoto per definire l'elenco dei gruppi di utenti che possono connettersi ai server Host sessione Desktop remoto che ospitano i Programmi RemoteApp.

  • Creare Criteri di autorizzazione risorse Desktop remoto per consentire l'accesso ai server Host sessione Desktop remoto che ospitano i Programmi RemoteApp.

    Quando si creano criteri di autorizzazione connessioni Desktop remoto, aggiungere i gruppi di utenti definiti nei criteri di autorizzazione connessioni Desktop remoto. Creare inoltre un nuovo gruppo di computer gestito da Gateway Desktop remoto che contenga sia i nomi NetBIOS sia i nomi di dominio completo dei server Host sessione Desktop remoto o della server farm Host sessione Desktop remoto che ospitano i Programmi RemoteApp.

Per ulteriori informazioni, vedere la Guida di Gestione Gateway Desktop remoto in Windows Server 2008 R2.

Configurare le impostazioni di Gateway Desktop remoto in Gestione RemoteApp (nelle impostazioni di distribuzione globali o quando si crea un file con estensione rdp o un pacchetto di Windows Installer).

Configurare le impostazioni di Gateway Desktop remoto

Se si desidera utilizzare file con estensione rdp o pacchetti di Windows Installer esistenti per accedere ai Programmi RemoteApp in Internet, assicurarsi che i file siano stati creati con le impostazioni di Gateway Desktop remoto corrette. In caso contrario, sarà necessario creare nuovo file con le impostazioni corrette e quindi distribuirli agli utenti.
  • Creare un file con estensione rdp

  • Creare un pacchetto di Windows Installer

  • Distribuire programmi RemoteApp agli utenti

Se si desidera consentire l'accesso a Internet ai Programmi RemoteApp tramite Accesso Web Desktop remoto, configurare le impostazioni di autenticazione e del firewall.

Configurare il server Accesso Web Desktop remoto per consentire l'accesso da Internet

Ulteriori riferimenti

  • Configurare programmi RemoteApp


Accesso Web Desktop remoto

Accesso Web Desktop remoto, denominato in precedenza Accesso Web di Servizi terminal, consente agli utenti di accedere a Connessione RemoteApp e desktop tramite il menu Start in un computer che esegue Windows 7 o tramite un Web browser. Connessione RemoteApp e desktop offre agli utenti una visualizzazione personalizzata dei Programmi RemoteApp e dei desktop virtuali.

Accesso Web Desktop remoto, inoltre, include Connessione Web Desktop remoto, che consente agli utenti di connettersi in remoto al desktop di qualsiasi computer in cui dispongano di accesso Desktop remoto.

Sono inclusi gli argomenti seguenti:

  • Panoramica di Accesso Web Desktop remoto

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto

  • Attivare programmi RemoteApp per Accesso Web Desktop remoto

  • Installare il servizio ruolo Accesso Web Desktop remoto

  • Popolare il gruppo di sicurezza Computer Accesso Web di Servizi terminal

  • Configurare il server Accesso Web Desktop remoto per Connessione RemoteApp e desktop

  • Connettersi ad Accesso Web Desktop remoto

  • Configurare il server Accesso Web Desktop remoto per consentire l'accesso da Internet

  • Configurare il comportamento di Connessione Web Desktop remoto

Per ulteriori informazioni su Accesso Web Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140437.


Panoramica di Accesso Web Desktop remoto

Accesso Web Desktop remoto, denominato in precedenza Accesso Web di Servizi terminal, consente agli utenti di accedere a Connessione RemoteApp e desktop tramite il menu Start in un computer che esegue Windows 7 o tramite un Web browser. Connessione RemoteApp e desktop offre agli utenti una visualizzazione personalizzata dei Programmi RemoteApp e dei desktop virtuali.

Accesso Web Desktop remoto, inoltre, include Connessione Web Desktop remoto, che consente agli utenti di connettersi in remoto da un Web browser al desktop di qualsiasi computer in cui dispongano di accesso Desktop remoto.

Quando un utente avvia un Programma RemoteApp, viene avviata una sessione di Servizi Desktop remoto nel server Host sessione Desktop remoto che ospita il Programma RemoteApp. Se un utente si connette a un desktop virtuale, viene stabilita una connessione desktop remoto a una macchina virtuale in esecuzione in un server di Host di virtualizzazione Desktop remoto.

Per consentire agli utenti di accedere a Connessione RemoteApp e desktop, è necessario configurare Accesso Web Desktop remoto per specificare l'origine dei Programmi RemoteApp e dei desktop visualizzati agli utenti. È possibile configurare Accesso Web Desktop remoto per l'utilizzo di uno degli elementi seguenti:

  • Server Gestore connessione Desktop remoto

  • Origine RemoteApp

Un server Gestore connessione Desktop remoto consente agli utenti di accedere a desktop virtuali ospitati in server Host di virtualizzazione Desktop remoto e a Programmi RemoteApp ospitati in server Host sessione Desktop remoto. Per configurare il server Gestore connessione Desktop remoto, utilizzare lo strumento Gestione connessione Desktop remoto. Per ulteriori informazioni, vedere la Guida di Gestione connessione Desktop remoto in Windows Server 2008 R2. Per ulteriori informazioni su Connessione RemoteApp e desktop, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=143108).

Un'Origine RemoteApp è un singolo server Host sessione Desktop remoto o una farm di server Host sessione Desktop remoto configurati in modo identico in cui sono stati configurati Programmi RemoteApp. È possibile specificare più di un'Origine RemoteApp. Per configurare Programmi RemoteApp in un server Host sessione Desktop remoto, utilizzare Gestione RemoteApp. Per ulteriori informazioni, vedere Gestione RemoteApp.

Distribuire Accesso Web Desktop remoto

È necessario installare il servizio ruolo Accesso Web Desktop remoto nel server a cui si desidera che gli utenti si connettano sul Web per accedere a Programmi RemoteApp. Quando si installa Accesso Web Desktop remoto, viene installato anche Microsoft Internet Information Services (IIS) come componente necessario.

Dopo avere installato Accesso Web Desktop remoto, è necessario specificare se utilizzare un server Gestore connessione Desktop remoto o un'Origine RemoteApp come origine dei Programmi RemoteApp e dei desktop virtuali visualizzati agli utenti tramite Connessione RemoteApp e desktop. Per ulteriori informazioni, vedere Configurare il server Accesso Web Desktop remoto per Connessione RemoteApp e desktop.

Se si desidera che gli utenti accedano alla pagina Web da Internet, è possibile utilizzare Gateway Desktop remoto per consentire la protezione delle connessioni remote. Per ulteriori informazioni, vedere Elenco di controllo: rendere i programmi RemoteApp disponibili da Internet.

Per ulteriori informazioni su Accesso Web Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140437.

Ulteriori riferimenti

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto

  • Attivare programmi RemoteApp per Accesso Web Desktop remoto

  • Installare il servizio ruolo Accesso Web Desktop remoto

  • Popolare il gruppo di sicurezza Computer Accesso Web di Servizi terminal

  • Connettersi ad Accesso Web Desktop remoto

  • Configurare il server Accesso Web Desktop remoto per consentire l'accesso da Internet

  • Configurare il comportamento di Connessione Web Desktop remoto


Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto

In questo elenco di controllo vengono illustrati i passaggi necessari per configurare Accesso Web Desktop remoto, in modo da rendere disponibili i Programmi RemoteApp tramite Connessione RemoteApp e desktop.

Nota

Accesso Web Desktop remoto può inoltre essere configurato per consentire agli utenti l'accesso a desktop virtuali tramite Connessione RemoteApp e desktop. Per ulteriori informazioni, vedere la Guida di Gestione connessione Desktop remoto in Windows Server 2008 R2.

Attività | Riferimento
Configurare i Programmi RemoteApp in uno o più server Host sessione Desktop remoto nell'ambiente. | Configurare programmi RemoteApp
Attivare Programmi RemoteApp per Accesso Web Desktop remoto. | Attivare programmi RemoteApp per Accesso Web Desktop remoto
Installare il servizio ruolo Accesso Web Desktop remoto nel server a cui si desidera che gli utenti si connettano sul Web per accedere a Programmi RemoteApp. | Installare il servizio ruolo Accesso Web Desktop remoto
Aggiungere l'account computer del server Accesso Web Desktop remoto al gruppo Computer Accesso Web di Servizi terminal nel server Host sessione Desktop remoto. | Popolare il gruppo di sicurezza Computer Accesso Web di Servizi terminal
Specificare l'origine dei Programmi RemoteApp che sarà disponibile tramite Connessione RemoteApp e desktop. | Configurare il server Accesso Web Desktop remoto per Connessione RemoteApp e desktop

Dopo avere completato l'elenco di controllo, gli utenti potranno accedere al sito Web Accesso Web Desktop remoto da una rete Intranet. Per rendere il sito Web Accesso Web Desktop remoto disponibile da Internet, vedere Elenco di controllo: rendere i programmi RemoteApp disponibili da Internet.

Importante

Il sito Web Accesso Web Desktop remoto viene automaticamente configurato per l'utilizzo di Secure Sockets Layer (SSL) con un certificato autofirmato. Per impostazione predefinita, il certificato autofirmato non è un certificato attendibile e l'utilizzo di tali certificati è consigliabile solo a fini di testing e di valutazione. Per ulteriori informazioni sulla configurazione del sito Web Accesso Web Desktop remoto per l'utilizzo di un certificato attendibile, ad esempio un certificato rilasciato da un'Autorità di certificazione (CA) pubblica attendibile, vedere la pagina Web relativa alla sicurezza di Accesso Web Desktop remoto.

Ulteriori riferimenti

  • Panoramica di Accesso Web Desktop remoto


Attivare programmi RemoteApp per Accesso Web Desktop remoto

Per impostazione predefinita, un Programma RemoteApp viene attivato per Accesso Web Desktop remoto quando viene aggiunto all'elenco Programmi RemoteApp in un server Host sessione Desktop remoto.

Utilizzare la procedura seguente nel server Host sessione Desktop remoto in cui sono configurati i Programmi RemoteApp per determinare se un Programma RemoteApp è attivato per Accesso Web Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per determinare se un programma RemoteApp è attivato per Accesso Web Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Gestione RemoteApp. A tale scopo, fare clic sul pulsante Start, scegliereStrumenti di amministrazione, Servizi Desktop remoto e quindi Gestione RemoteApp.

  2. Nell'elenco Programmi RemoteApp verificare che sia visualizzato il valore Sì nella colonna Accesso Web Desktop remoto accanto al programma che si desidera rendere disponibile tramite Accesso Web Desktop remoto.

  3. Per definire se un Programma RemoteApp è disponibile tramite Accesso Web Desktop remoto, eseguire una delle operazioni seguenti:

    • Per attivare un Programma RemoteApp per Accesso Web Desktop remoto, fare clic sul nome del programma e quindi fare clic su Mostra in Accesso Web Desktop remoto nel riquadro Azioni.

    • Per disattivare un Programma RemoteApp per Accesso Web Desktop remoto, fare clic sul nome del programma e quindi fare clic su Nascondi in Accesso Web Desktop remoto nel riquadro Azioni.

I Programmi RemoteApp attivati per Accesso Web Desktop remoto verranno automaticamente resi disponibili tramite Connessione RemoteApp e desktop se Accesso Web Desktop remoto è configurato per l'utilizzo del server Host sessione Desktop remoto come origine per Connessione RemoteApp e desktop. Per ulteriori informazioni, vedere Configurare il server Accesso Web Desktop remoto per Connessione RemoteApp e desktop.

Ulteriori riferimenti

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto


Installare il servizio ruolo Accesso Web Desktop remoto

Installare il servizio ruolo Accesso Web Desktop remoto nel server a cui si desidera che gli utenti si connettano sul Web per accedere a Programmi RemoteApp. Quando si installa il servizio ruolo Accesso Web Desktop remoto, viene installato anche Microsoft Internet Information Services (IIS).

Il server in cui viene installato Accesso Web Desktop remoto funge da server Web e non deve necessariamente essere un server Host sessione Desktop remoto.

Utilizzare la procedura seguente per installare il servizio ruolo Accesso Web Desktop remoto.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per installare il servizio ruolo Accesso Web Desktop remoto

  1. Nel computer in cui si desidera installare il servizio ruolo Accesso Web Desktop remoto, aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Se il ruolo Servizi Desktop remoto non è già installato:

    1. In Riepilogo ruoli fare clic su Aggiungi ruoli.

    2. Sulla pagina Prima di iniziare fare clic su Avanti.

    3. Nella pagina Selezione ruoli server selezionare la casella di controllo Servizi Desktop remoto e quindi fare clic su Avanti.

    4. Esaminare la pagina Servizi Desktop remoto e quindi fare clic su Avanti.

    5. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Accesso Web Desktop remoto.

    Se il ruolo Servizi Desktop remoto è già installato:

    1. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    2. In Servizi ruolo fare clic su Aggiungi servizi ruolo.

    3. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Accesso Web Desktop remoto.

  3. Esaminare le informazioni sui servizi ruolo necessari e quindi fare clic su Aggiungi servizi ruolo necessari.

  4. Fare clic su Avanti.

  5. Esaminare la pagina Server Web (IIS) e quindi fare clic su Avanti.

  6. Sulla pagina Selezione servizi ruolo, in cui viene richiesto di selezionare i servizi ruolo che si desidera installare per IIS, fare clic su Avanti.

  7. Nella pagina Conferma selezioni per l'installazione fare clic su Installa.

  8. Nella pagina Stato installazione verrà indicato lo stato di avanzamento dell'installazione.

  9. Nella pagina Risultati installazione verificare che l'installazione sia stata completata e quindi fare clic su Chiudi.

Ulteriori riferimenti

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto


Popolare il gruppo di sicurezza Computer Accesso Web di Servizi terminal

Se il server Accesso Web Desktop remoto e il server Host sessione Desktop remoto che ospita i Programmi RemoteApp sono server distinti, è necessario aggiungere l'account computer del server Accesso Web Desktop remoto al gruppo di sicurezza Computer Accesso Web di Servizi terminal nel server Host sessione Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per aggiungere l'account computer del server Accesso Web Desktop remoto al gruppo di sicurezza

  1. Nel server Host sessione Desktop remoto fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione computer.

  2. Nel riquadro sinistro espandere Utenti e gruppi locali e quindi fare clic su Gruppi.

  3. Nel riquadro destro fare doppio clic su Computer Accesso Web di Servizi terminal.

  4. Nella finestra di dialogo delle proprietà di Computer Accesso Web di Servizi terminal fare clic su Aggiungi.

  5. Nella finestra di dialogo Selezione Utenti, Computer o Gruppi fare clic su Tipi di oggetto.

  6. Nella finestra di dialogo Tipi di oggetto selezionare la casella di controllo Computer e quindi fare clic su OK.

  7. Nella casella Immettere i nomi degli oggetti da selezionare specificare l'account computer del server Accesso Web Desktop remoto e quindi fare clic su OK.

  8. Fare clic su OK per chiudere la finestra di dialogo delle proprietà di Computer Accesso Web di Servizi terminal.

Ulteriori riferimenti

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto


Configurare il server Accesso Web Desktop remoto per Connessione RemoteApp e desktop

Per consentire agli utenti di accedere a Connessione RemoteApp e desktop, è necessario configurare Accesso Web Desktop remoto per specificare l'origine dei Programmi RemoteApp e dei desktop visualizzati agli utenti. È possibile configurare Accesso Web Desktop remoto per l'utilizzo di uno degli elementi seguenti:

  • Server Gestore connessione Desktop remoto

  • Origine RemoteApp

Un server Gestore connessione Desktop remoto consente agli utenti di accedere a desktop virtuali ospitati in server Host di virtualizzazione Desktop remoto e a Programmi RemoteApp ospitati in server Host sessione Desktop remoto. Per configurare il server Gestore connessione Desktop remoto, utilizzare lo strumento Gestione connessione Desktop remoto. Per ulteriori informazioni, vedere la Guida di Gestione connessione Desktop remoto in Windows Server 2008 R2. Per ulteriori informazioni su Connessione RemoteApp e desktop, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=143108).

Un'Origine RemoteApp è un singolo server Host sessione Desktop remoto o una farm di server Host sessione Desktop remoto configurati in modo identico in cui sono stati configurati Programmi RemoteApp. È possibile specificare più di un'Origine RemoteApp. Per configurare Programmi RemoteApp in un server Host sessione Desktop remoto, utilizzare Gestione RemoteApp. Per ulteriori informazioni, vedere Gestione RemoteApp.

Per completare questa procedura, è necessario accedere utilizzando l'account Administrator locale nel server Accesso Web Desktop remoto o un account membro del gruppo Administrators di Accesso Web di Servizi terminal nel server Accesso Web Desktop remoto. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare l'origine di Connessione RemoteApp e desktop

  1. Connettersi al sito Web Accesso Web Desktop remoto. A tale scopo, utilizzare una delle modalità seguenti:

    • Nel server Accesso Web Desktop remoto fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione di Accesso Web Desktop remoto.

    • Utilizzare Internet Explorer per connettersi al sito Web Accesso Web Desktop remoto. Per impostazione predefinita, il sito Web si trova all'indirizzo seguente, in cui server_name è il nome di dominio completo del server Accesso Web Desktop remoto:

      https://server_name/rdweb

  2. Accedere al sito utilizzando l'account Administrator locale nel server Accesso Web Desktop remoto o un account membro del gruppo Administrators di Accesso Web di Servizi terminal nel server Accesso Web Desktop remoto.

  3. Sulla barra del titolo fare clic su Configurazione.

    Nota

    Se si accede al sito Web Accesso Web Desktop remoto utilizzando l'opzione Configurazione di Accesso Web di Servizi terminal, verrà automaticamente aperta la pagina Configurazione.

  4. Selezionare Un server Gestore connessione Desktop remoto o Una o più origini RemoteApp.

    Se si seleziona Un server Gestore connessione Desktop remoto, nella casella Nome origine immettere il nome NetBIOS o il nome di dominio completo di Gestore connessione Desktop remoto.

    Se si seleziona Una o più origini RemoteApp, nella casella Nome origine immettere il nome NetBIOS o il nome di dominio completo dell'Origine RemoteApp. Se si utilizza una server farm Host sessione Desktop remoto come Origine RemoteApp, specificare il nome DNS della farm. Se si specifica più di un'Origine RemoteApp, separare ogni nome con un punto e virgola.

  5. Fare clic su OK per salvare le modifiche.

Se si è selezionato Una o più origini RemoteApp, è necessario specificare anche un nome di connessione e un ID connessione. Il nome della connessione verrà utilizzato per identificare la visualizzazione Connessione RemoteApp e desktop fornita dal server Accesso Web Desktop remoto all'utente. Per specificare il nome di connessione e l'ID connessione, nel server Accesso Web Desktop remoto aprire il file %windir%\Web\RDWeb\App_Data\RDWebAccess.config in un editor di testo, ad esempio Blocco note.

Se si è selezionato Un server Gestore connessione Desktop remoto, è necessario specificare il nome della connessione e l'ID connessione utilizzando lo strumento Gestione connessione Desktop remoto nel server Gestore connessione Desktop remoto. Per ulteriori informazioni, vedere la Guida di Gestione connessione Desktop remoto in Windows Server 2008 R2.

Ulteriori riferimenti

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto


Connettersi ad Accesso Web Desktop remoto

Per impostazione predefinita, è possibile accedere al sito Web Accesso Web Desktop remoto all'indirizzo seguente, dove server_name è il nome di dominio completo del server Web in cui è installato Accesso Web Desktop remoto:

https://server_name/rdweb

Se ci si connette al sito Web Accesso Web Desktop remoto da un computer pubblico, ad esempio il computer di un chiosco multimediale in un luogo pubblico o da un computer condiviso con altri utenti, fare clic su Computer pubblico o condiviso. Sarà necessario specificare il nome utente e la password ogni volta che si accede al sito Web Accesso Web Desktop remoto.

Se si utilizza un computer aziendale personale non condiviso con altri utenti, fare clic su Computer privato. Il nome utente verrà memorizzato e sarà necessario immettere solo la password ogni volta che si accede al sito Web Accesso Web Desktop remoto.

Nota

Per proteggere il sistema da accesso non autorizzato, le sessioni di Accesso Web Desktop remoto scadono automaticamente dopo un determinato periodo di inattività. Se la sessione di Accesso Web Desktop remoto scade, sarà necessario accedere di nuovo. I valori di timeout sono diversi, a seconda che si selezioni Computer pubblico o condiviso o Computer privato quando si accede al sito Web Accesso Web Desktop remoto. L'amministratore può configurare i valori di timeout predefiniti utilizzando lo strumento Gestione Internet Information Services (IIS).

Per accedere alle impostazioni di configurazione per il sito Web Accesso Web Desktop remoto, è necessario accedere al sito Web Accesso Web Desktop remoto utilizzando l'account Administrator locale nel server Accesso Web Desktop remoto o un account membro del gruppo Administrators di Accesso Web di Servizi terminal nel server Accesso Web Desktop remoto. Per accedere al sito Web, utilizzare uno dei metodi seguenti:

  • Digitare l'URL del sito Web Accesso Web Desktop remoto in un Web browser.

  • Nel server Accesso Web Desktop remoto fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione di Accesso Web Desktop remoto.

Nota

Tutti gli utenti autenticati possono accedere a Connessione RemoteApp e desktop tramite un server Accesso Web Desktop remoto. Per modificare questo comportamento, utilizzare Gestione Internet Information Services (IIS) per modificare le autorizzazioni per la directory virtuale RDWeb.

Per ulteriori informazioni sulla sicurezza di Accesso Web Desktop remoto, vedere la pagina Web relativa alla sicurezza di Accesso Web Desktop remoto.

Requisiti del computer client

Per utilizzare Accesso Web Desktop remoto, i computer client devono eseguire almeno Internet Explorer 6.0 e una versione di Connessione Desktop remoto che supporti almeno Remote Desktop Protocol (RDP) 6.1.

Per determinare la versione di Remote Desktop Protocol supportata da Connessione Desktop remoto, avviare Connessione Desktop remoto, fare clic sull'icona nell'angolo in alto a sinistra della finestra di dialogo Connessione Desktop remoto e quindi fare clic su Informazioni. La versione di Remote Desktop Protocol supportata da Connessione Desktop remoto sarà indicata nella finestra di dialogo Informazioni su Connessione desktop remoto.

Connessione Desktop remoto 6.1 supporta Remote Desktop Protocol 6.1 ed è incluso nei sistemi operativi seguenti:

  • Windows Server 2008

  • Microsoft Windows Vista con Service Pack 1 (SP1)

  • Windows XP con Service Pack 3 (SP3)

La versione di Connessione Desktop remoto inclusa in Windows 7 e Windows Server 2008 R2 supporta Remote Desktop Protocol 7.0. La versione di Connessione Desktop remoto utilizzata determina le funzionalità di Accesso Web Desktop remoto disponibili.

È inoltre necessario attivare il controllo Client ActiveX di Servizi Desktop remoto. Il controllo ActiveX è incluso in Connessione Desktop remoto 6.1 e nella versione di Connessione Desktop remoto disponibile in Windows 7 e Windows Server 2008 R2.

Per ulteriori informazioni sui requisiti del computer client per l'utilizzo di Accesso Web Desktop remoto, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=142240.

Ulteriori riferimenti

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto


Configurare il server Accesso Web Desktop remoto per consentire l'accesso da Internet

Per consentire agli utenti d accedere al server Accesso Web Desktop remoto da Internet, è possibile distribuire Gateway Desktop remoto. Una delle configurazioni consigliate consiste nel posizionare sia il server Gateway Desktop remoto sia il server Accesso Web Desktop remoto nella rete perimetrale, con i server Host sessione Desktop remoto che ospitano Programmi RemoteApp protetti dal firewall interno.

Per ulteriori informazioni su come distribuire Gateway Desktop remoto e come rendere disponibili i Programmi RemoteApp da Internet, vedere Elenco di controllo: rendere i programmi RemoteApp disponibili da Internet.

Dopo aver distribuito Programmi RemoteApp, Gateway Desktop remoto e Accesso Web Desktop remoto, è necessario configurare il firewall per consentire il traffico di Strumentazione gestione Windows (WMI) dal server Accesso Web Desktop remoto al server Host sessione Desktop remoto.

Verificare inoltre che il sito Web Accesso Web Desktop remoto sia configurato per l'utilizzo dell'autenticazione basata su form.

Nota

Per impostazione predefinita, l'autenticazione basata su form è attivata per il sito Web Accesso Web Desktop remoto.

Per verificare che l'autenticazione basata su form sia attivata

  1. Nel server Accesso Web Desktop remoto fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione Internet Information Services (IIS).

  2. Nel riquadro di sinistra di Gestione Internet Information Services (IIS) espandere il nome del server, Siti, Sito Web predefinito, RDWeb e quindi fare clic su Pagine.

  3. Nel riquadro centrale fare doppio clic su Autenticazione in IIS.

  4. Verificare che l'autenticazione basata su form sia impostata su Attivata. In caso contrario, fare clic con il pulsante destro del mouse su Autenticazione basata su form e quindi scegliere Attiva.

Per configurare il sito Web Accesso Web Desktop remoto per l'utilizzo dell'autenticazione di Windows anziché dell'autenticazione basata su form o per non utilizzare SSL, vedere la pagina Web relativa alla sicurezza di Accesso Web Desktop remoto.

Ulteriori riferimenti

  • Elenco di controllo: rendere disponibili i programmi RemoteApp tramite Accesso Web Desktop remoto


Configurare il comportamento di Connessione Web Desktop remoto

Connessione Web Desktop remoto consente a un utente di connettersi al desktop di un computer remoto dal sito Web Accesso Web Desktop remoto. Per connettersi a un computer remoto, devono essere soddisfatte le condizioni seguenti:

  • Il computer remoto deve essere configurato per accettare connessioni Desktop remoto.

  • L'utente deve essere membro del gruppo Utenti desktop remoto sul computer remoto.

Gli utenti possono accedere a Connessione Web Desktop remoto facendo clic sulla scheda Desktop remoto nella pagina Accesso Web Desktop remoto. Gli amministratori possono stabilire se la scheda Desktop remoto debba essere disponibile per gli utenti. È inoltre possibile configurare impostazioni quali il server Gateway Desktop remoto da utilizzare e le opzioni predefinite di reindirizzamento dispositivi e risorse.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per configurare il comportamento di Connessione Web desktop remoto

  1. Nel server Accesso Web Desktop remoto avviare Gestione Internet Information Services (IIS). A questo scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Gestione Internet Information Services (IIS).

  2. Nel riquadro di sinistra espandere il nome del server, espandere Siti, Sito Web predefinito, RDWeb e quindi fare clic su Pagine.

  3. Nel riquadro centrale fare doppio clic su Impostazioni applicazione in ASP.NET.

  4. Per modificare le impostazioni di Connessione Web desktop remoto, modificare i valori nel riquadro Impostazioni applicazione.

    • Per configurare un server Gateway Desktop remoto predefinito, fare doppio clic su DefaultTSGateway, immettere il nome di dominio completo del server nella casella Valore, ad esempio server1.contoso.com, e quindi fare clic su OK.

    • Per specificare il metodo di autenticazione di Gateway Desktop remoto, fare doppio clic su GatewayCredentialsSource, digitare il numero corrispondente al metodo di autenticazione desiderato nella casella Valore e quindi fare clic su OK. I valori possibili includono:

      0 = Richiedi password (autenticazione NTLM)

      1 = Smart card

      4 = Consenti selezione successiva

    • Per definire se la scheda Desktop remoto debba essere visualizzata nella pagina Web Accesso Web Desktop remoto, fare doppio clic su ShowDesktops. Nella casella Valore digitare true per visualizzare la scheda Desktop remoto o false per nasconderla. Al termine fare clic su OK.

    • Per configurare le impostazioni predefinite di reindirizzamento dispositivi e risorse, fare doppio clic sull'impostazione che si desidera modificare (xClipboard, xDriveRedirection, xPnPRedirection, xPortRedirection o xPrinterRedirection). Nella casella Valore digitare true per attivare l'impostazione di reindirizzamento per impostazione predefinita o false per disattivare l'impostazione di reindirizzamento per impostazione predefinita e quindi fare clic su OK.

  5. Al termine, chiudere Gestione IIS.

    Le modifiche avranno effetto immediato sul sito Web Accesso Web Desktop remoto. Se viene aperta la pagina Web, aggiornare la pagina per visualizzare le modifiche.
Nota

È inoltre possibile configurare queste impostazioni modificando direttamente il file %windir%\Web\RDWeb\Pages\Web.config in un editor di testo, ad esempio Blocco note.

Ulteriori riferimenti

  • Connettersi ad Accesso Web Desktop remoto