Servizi Desktop remoto

Il ruolo del server Servizi Desktop remoto in Windows Server® 2008 R2 include tecnologie che consentono agli utenti di accedere a programmi basati su Windows installati in un server Host sessione Desktop remoto oppure al desktop completo di Windows. Tramite Servizi Desktop remoto gli utenti possono accedere a un server Host sessione Desktop remoto da una rete aziendale o da Internet.


Panoramica di Servizi Desktop remoto

Che cos'è Servizi Desktop remoto?

Servizi Desktop remoto, in precedenza denominato Servizi terminal, è un ruolo del server di Windows Server® 2008 R2 che offre tecnologie che consentono agli utenti di accedere a programmi basati su Windows installati in un server Host sessione Desktop remoto oppure di accedere al desktop completo di Windows. Tramite Servizi Desktop remoto gli utenti possono accedere a un server Host sessione Desktop remoto da una rete aziendale o da Internet.

Servizi Desktop remoto consente di distribuire e gestire il software in modo efficiente in un ambiente aziendale. È possibile distribuire programmi in modo semplice da una posizione centrale. Poiché i programmi vengono installati nel server Host sessione Desktop remoto e non nel computer client, sono più semplici da aggiornare e gestire.

Quando un utente accede a un programma in un server Host sessione Desktop remoto, il programma viene eseguito nel server. Ogni utente visualizza solo la propria sessione individuale. Tale sessione viene gestita in modo trasparente dal sistema operativo server ed è indipendente da qualsiasi altra sessione client. È inoltre possibile configurare Servizi Desktop remoto per l'utilizzo di Hyper-V™ per assegnare macchine virtuali agli utenti oppure lasciare che sia Servizi Desktop remoto ad assegnare dinamicamente una macchina virtuale disponibile a un utente al momento della connessione.

Per ulteriori informazioni su Servizi Desktop remoto, vedere la pagina corrispondente nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Perché utilizzare Servizi Desktop remoto

Se si distribuisce un programma in un server Host sessione Desktop remoto anziché in ogni dispositivo, si ottengono numerosi vantaggi, tra cui i seguenti:

  • Distribuzione delle applicazioni. È possibile distribuire rapidamente programmi basati su Windows nei computer di un'organizzazione. Servizi Desktop remoto è particolarmente utile quando si dispone di programmi aggiornati di frequente, utilizzati raramente o difficili da gestire.

  • Consolidamento delle applicazioni. Poiché i programmi vengono installati ed eseguiti da un server Host sessione Desktop remoto, non è più necessario aggiornarli nei computer client. Ciò riduce inoltre la quantità di larghezza di banda di rete necessaria per accedere ai programmi.

  • Accesso remoto. Gli utenti possono accedere ai programmi in esecuzione in un server Host sessione Desktop remoto da dispositivi quali computer di casa, chioschi multimediali, hardware a basso consumo e sistemi operativi diversi da Windows.

  • Accesso dalle succursali. Servizi Desktop remoto garantisce migliori prestazioni dei programmi per i dipendenti di succursali che devono accedere ad archivi dati centralizzati. I programmi che richiedono un utilizzo intensivo di dati non dispongono in genere di protocolli client/server ottimizzati per connessioni a bassa velocità. I programmi di questo tipo offrono in genere prestazioni migliori se si utilizza una connessione di Servizi Desktop remoto anziché una normale Wide Area Network.

Servizi ruolo di Servizi Desktop remoto

Servizi Desktop remoto è un ruolo server che prevede diversi servizi ruolo. In Windows Server 2008 R2 Servizi Desktop remoto è costituito dai servizi ruolo seguenti:

  • Host sessione Desktop remoto. Host sessione Desktop remoto, denominato in precedenza Terminal Server, consente a un server di ospitare programmi basati su Windows o il desktop completo di Windows. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server.

  • Accesso Web Desktop remoto. Accesso Web Desktop remoto, denominato in precedenza Accesso Web di Servizi terminal, consente agli utenti di accedere a Connessione RemoteApp e desktop tramite il menu Start in un computer che esegue Windows 7 o tramite un Web browser. Connessione RemoteApp e desktop offre agli utenti una visualizzazione personalizzata dei Programmi RemoteApp e dei desktop virtuali.

  • Servizio licenze Desktop remoto. Servizio licenze Desktop remoto, denominato in precedenza Licenze Servizi terminal, consente di gestire le licenze CAL (Client Access License) Servizi Desktop remoto necessarie per ogni dispositivo o utente per la connessione a un server Host sessione Desktop remoto. Utilizzare Servizio licenze Desktop remoto per installare e rilasciare licenze CAL Servizi desktop remoto, nonché per tenere traccia della relativa disponibilità in un server licenze Desktop remoto.

  • Gateway Desktop remoto. Gateway Desktop remoto, denominato in precedenza Gateway di Servizi terminal, consente agli utenti remoti autorizzati di connettersi alle risorse di una rete aziendale interna da qualsiasi dispositivo connesso a Internet.

  • Gestore connessione Desktop remoto. Gestore connessione Desktop remoto, denominato in precedenza Broker di sessione di Servizi terminal, supporta il bilanciamento del carico delle sessioni e la riconnessione delle sessioni in una server farm Host sessione Desktop remoto con carico bilanciato. Gestore connessione Desktop remoto viene inoltre utilizzato per offrire agli utenti l'accesso a Programmi RemoteApp e a desktop virtuali tramite Connessione RemoteApp e desktop.

  • Host di virtualizzazione Desktop remoto. Host di virtualizzazione Desktop remoto si integra con Hyper-V per ospitare macchine virtuali e fornirle agli utenti come desktop virtuali. È possibile assegnare un desktop virtuale univoco a ogni utente dell'organizzazione oppure fornire agli utenti l'accesso condiviso a un pool di desktop virtuali.

Che cos'è Host sessione Desktop remoto?

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto utilizzando il client di Connessione Desktop remoto o Programmi RemoteApp.

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.

Che cos'è Accesso Web Desktop remoto?

Accesso Web Desktop remoto consente agli utenti di accedere a Connessione RemoteApp e desktop tramite il menu Start in un computer che esegue Windows 7 o tramite un Web browser. Connessione RemoteApp e desktop offre agli utenti una visualizzazione personalizzata dei Programmi RemoteApp e dei desktop virtuali.

Quando un utente avvia un Programma RemoteApp, viene avviata una sessione di Servizi Desktop remoto nel server Host sessione Desktop remoto che ospita il Programma RemoteApp. Se un utente si connette a un desktop virtuale, viene stabilita una connessione desktop remoto a una macchina virtuale in esecuzione in un server di Host di virtualizzazione Desktop remoto.

Per configurare i Programmi RemoteApp e i desktop virtuali che saranno disponibili tramite Connessione RemoteApp e desktop, è necessario installare il servizio ruolo Gestore connessione Desktop remoto in un computer che esegue Windows Server 2008 R2 e quindi utilizzare lo strumento Gestione connessione Desktop remoto.

È inoltre possibile utilizzare Accesso Web Desktop remoto se si desidera solo rendere disponibili agli utenti i Programmi RemoteApp in un server Host sessione Desktop remoto tramite un Web browser.

Per ulteriori informazioni su Accesso Web Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140437.

Che cos'è Servizio licenze Desktop remoto?

Servizio licenze Desktop remoto gestisce le licenze CAL Servizi Desktop remoto necessarie per ogni utente o dispositivo per la connessione a un server Host sessione Desktop remoto. Utilizzare Servizio licenze Desktop remoto per installare e rilasciare licenze CAL Servizi desktop remoto, nonché per tenere traccia della relativa disponibilità in un server licenze Desktop remoto.

Per poter utilizzare Servizi Desktop remoto, è necessario disporre di almeno un server licenze. Per distribuzioni di piccole dimensioni, è possibile installare il servizio ruolo Host sessione Desktop remoto e il servizio ruolo Servizio licenze Desktop remoto entrambi nello stesso computer. Per le distribuzioni di dimensioni maggiori, è consigliabile installare il servizio ruolo Servizio licenze Desktop remoto in un computer distinto rispetto al servizio ruolo Host sessione Desktop remoto.

Perché il server Host sessione Desktop remoto continui ad accettare connessioni dai client, è necessario configurare Servizio licenze Desktop remoto correttamente.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Che cos'è Gateway Desktop remoto?

Gateway Desktop remoto consente agli utenti remoti autorizzati di connettersi alle risorse di una rete aziendale interna da qualsiasi dispositivo connesso a Internet. Le risorse di rete possono essere server Host sessione Desktop remoto che eseguono Programmi RemoteApp (che ospitano applicazioni line-of-business), desktop virtuali oppure computer in cui è attivato Desktop remoto. Gateway Desktop remoto incapsula RDP su HTTPS per semplificare la formazione di una connessione sicura e crittografata tra utenti in Internet e le risorse di rete interne in cui vengono eseguite le applicazioni per la produttività.

Perché utilizzare Gateway Desktop remoto

Gateway Desktop remoto offre i vantaggi seguenti:

  • Gateway Desktop remoto consente agli utenti remoti di connettersi alle risorse di rete interne su Internet utilizzando una connessione crittografata, senza che sia necessario configurare connessioni a reti private virtuali (VPN).

  • Gateway Desktop remoto offre un modello di configurazione della sicurezza esaustivo che consente di controllare l'accesso a risorse di rete interne specifiche.

  • Gateway Desktop remoto consente agli utenti remoti di connettersi a risorse di rete interne protette da un firewall in reti private e tramite NAT (Network Address Translator).

  • Gestione Gateway Desktop remoto consente di configurare i criteri di autorizzazione per definire le condizioni che gli utenti remoti devono rispettare per connettersi alle risorse di rete interne.

  • Gestione Gateway Desktop remoto offre strumenti che semplificano il monitoraggio dello stato della connessione, l'integrità e gli eventi di Gateway Desktop remoto.

  • È possibile configurare i server Gateway Desktop remoto e i client di Servizi Desktop remoto per l'utilizzo di Protezione accesso alla rete per aumentare la sicurezza.

  • È possibile utilizzare un server Gateway Desktop remoto con Microsoft Internet Security and Acceleration (ISA) Server per migliorare ulteriormente la sicurezza.

Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Che cos'è Gestore connessione Desktop remoto?

Gestore connessione Desktop remoto tiene traccia delle sessioni utente in una server farm Host sessione Desktop remoto con carico bilanciato. Nel database di Gestore connessione Desktop remoto sono archiviate le informazioni relative allo stato delle sessioni, che includono gli ID di sessione, i nomi utente associati e il nome del server in cui è presente ogni sessione. Quando un utente con una sessione esistente si connette a un server Host sessione Desktop remoto nella farm con carico bilanciato, viene reindirizzato da Gestore connessione Desktop remoto al server Host sessione Desktop remoto in cui è in corso la sessione. Questo comportamento impedisce all'utente di essere connesso a un server diverso nella farm e di avviare una nuova sessione.

Se la funzionalità Bilanciamento del carico di Gestore connessione Desktop remoto è attivata, Gestore connessione Desktop remoto tiene inoltre traccia del numero di sessioni utente in ogni server Host sessione Desktop remoto nella farm e reindirizza al server con il numero minore di sessioni gli utenti che non dispongono di una sessione esistente. Questa funzionalità consente di distribuire in modo uniforme il carico di sessione tra server in una server farm Host sessione Desktop remoto con carico bilanciato.

Gestore connessione Desktop remoto viene inoltre utilizzato per fornire agli utenti l'accesso a Connessione RemoteApp e desktop. Connessione RemoteApp e desktop offre agli utenti una visualizzazione personalizzata dei Programmi RemoteApp e dei desktop virtuali. Gestore connessione Desktop remoto supporta il bilanciamento del carico e la riconnessione a sessioni esistenti nei desktop virtuali a cui si accede tramite Connessione RemoteApp e desktop.

Per configurare Connessione RemoteApp e desktop, utilizzare lo strumento Gestione connessione Desktop remoto nel server Gestore connessione Desktop remoto.

Per ulteriori informazioni su Gestore connessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140432.

Che cos'è Host di virtualizzazione Desktop remoto?

Host di virtualizzazione Desktop remoto si integra con Hyper-V per fornire macchine virtuali tramite Connessione RemoteApp e desktop. È possibile configurare Host di virtualizzazione Desktop remoto in modo che a ogni utente dell'organizzazione venga assegnato un desktop virtuale univoco oppure in modo che gli utenti vengano reindirizzati a un pool condiviso nel quale viene assegnato dinamicamente un desktop virtuale.

Host di virtualizzazione Desktop remoto richiede Gestore connessione Desktop remoto per determinare dove viene reindirizzato l'utente. Se a un utente viene assegnato un desktop virtuale personale, verrà reindirizzato da Gestore connessione Desktop remoto a questa macchina virtuale. Se la macchina virtuale non è attiva, Host di virtualizzazione Desktop remoto la attiverà e quindi connetterà l'utente al desktop virtuale personale. Se l'utente si connette a un pool condiviso di macchine virtuali, Gestore connessione Desktop remoto innanzitutto verificherà se dispone di una sessione disconnessa nel pool. In caso affermativo, l'utente verrà riconnesso a quel desktop virtuale. In caso negativo, all'utente verrà assegnato dinamicamente un desktop virtuale del pool.

Per ulteriori informazioni su Host di virtualizzazione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=140435).


Host sessione Desktop remoto

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto tramite Connessione Desktop remoto o RemoteApp.

Sono inclusi gli argomenti seguenti:

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

  • Elenco di controllo: configurare un server Host sessione Desktop remoto

  • Configurare un server Host sessione Desktop remoto

  • Gestire un server Host sessione Desktop remoto

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.


Panoramica di Host sessione Desktop remoto

Il ruolo server Servizi Desktop remoto in Windows Server 2008 R2 è costituito da diversi servizi ruolo, tra cui Host sessione Desktop remoto.

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto da una rete aziendale o da Internet utilizzando Connessione Desktop remoto o RemoteApp.

Per ulteriori informazioni su RemoteApp, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140439.

Quando un utente accede a un programma in un server Host sessione Desktop remoto, l'esecuzione del programma viene eseguita nel server. Ogni utente visualizza solo la propria sessione individuale. Tale sessione viene gestita in modo trasparente dal sistema operativo server ed è indipendente da qualsiasi altra sessione client.

Se si distribuisce un programma in un server Host sessione Desktop remoto anziché in ogni dispositivo, si ottengono numerosi vantaggi, tra cui i seguenti:

  • È possibile distribuire rapidamente programmi basati su Windows nei computer di un'organizzazione. Ciò è particolarmente utile quando si dispone di programmi aggiornati di frequente, utilizzati raramente o difficili da gestire.

  • Gli utenti possono accedere ai programmi in esecuzione in un server Host sessione Desktop remoto da dispositivi quali computer di casa, chioschi multimediali, componenti hardware che potrebbero non soddisfare i requisiti del sistema operativo o dell'applicazione e sistemi operativi diversi da Windows.

  • I dipendenti di succursali che devono accedere ad archivi dati centralizzati possono ottenere migliori prestazioni dei programmi accedendo a un programma in remoto in un Host sessione Desktop remoto. I programmi che richiedono un utilizzo intensivo di dati non dispongono in genere di protocolli client/server ottimizzati per connessioni a bassa velocità. I programmi di questo tipo offrono in genere prestazioni migliori se si utilizza una connessione di Servizi Desktop remoto anziché una normale Wide Area Network.

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.


Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto tramite Connessione Desktop remoto o RemoteApp.

In questo elenco di controllo sono incluse le attività che un amministratore deve eseguire prima di installare e configurare un server Host sessione Desktop remoto.

Nota

Non è consigliabile installare il servizio ruolo Host sessione Desktop remoto in un controller di dominio Active Directory®. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

Attività Riferimento

Determinare se è necessario un server Host sessione Desktop remoto.

Per consentire connessioni remote esclusivamente a scopo amministrativo, non è necessario installare un server Host sessione Desktop remoto.

Per ulteriori informazioni sulle connessioni remote per scopo amministrativo, vedere Utilizzare Desktop remoto.

Analizzare i requisiti relativi alle licenze per un server Host sessione Desktop remoto.

Ogni utente o dispositivo di elaborazione che si connette a un server Host sessione Desktop remoto deve disporre di una licenza CAL (Client Access License) Servizi Desktop remoto valida.

Un server Host sessione Desktop remoto che esegue Windows Server 2008 R2 deve essere configurato per l'utilizzo di almeno un server licenze che esegue Windows Server 2008 e in tale server devono essere installate licenze CAL Servizi Desktop remoto valide.

Per ulteriori informazioni sui requisiti di gestione delle licenze per Servizi Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Determinare i programmi che si desidera ospitare nel server Host sessione Desktop remoto.

È consigliabile installare il servizio ruolo Host sessione Desktop remoto nel computer prima di installare qualsiasi programma che si desidera rendere disponibile per gli utenti. Se si installa il servizio ruolo Host sessione Desktop remoto in un computer in cui sono già installati programmi, alcuni dei programmi esistenti potrebbero non funzionare correttamente in un ambiente multiutente. È possibile che tali problemi vengano risolti disinstallando e quindi reinstallando i programmi interessati.

Per ulteriori informazioni, vedere Installare programmi in un server Host sessione Desktop remoto.

Analizzare le informazioni relative a:

  • Requisiti hardware

  • Capacità e scalabilità

Vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138055.

Determinare se è necessario distribuire una server farm Host sessione Desktop remoto con carico bilanciato.

Per ulteriori informazioni su Gestore connessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140432.

Determinare la modalità gestione licenze Desktop remoto che verrà utilizzata dal server Host sessione Desktop remoto.

La modalità gestione licenze Desktop remoto configurata in un server Host sessione Desktop remoto deve corrispondere al tipo delle licenze CAL Servizi Desktop remoto disponibile nel server licenze Desktop remoto.

Per ulteriori informazioni, vedere Specificare la modalità di gestione licenze Desktop remoto.

Determinare il server licenze Desktop remoto a cui il server Host sessione Desktop remoto richiederà licenze CAL Servizi Desktop remoto.

Un server Host sessione Desktop remoto deve essere configurato per specificare un server licenze Desktop remoto a cui richiedere licenze CAL Servizi Desktop remoto per gli utenti o i dispositivi di elaborazione che si connettono al server Host sessione Desktop remoto.

Per ulteriori informazioni, vedere Specificare un server licenze per il server Host sessione Desktop remoto.

Determinare gli utenti autorizzati a connettersi in remoto al server Host sessione Desktop remoto.

Il gruppo Utenti desktop remoto in un server Host sessione Desktop remoto consente di concedere a utenti e gruppi l'autorizzazione necessaria per accedere in remoto al server Host sessione Desktop remoto.

Per ulteriori informazioni, vedere Configurare il gruppo Utenti desktop remoto.

Stabilire se è necessario distribuire un server Gateway Desktop remoto.

Per ulteriori informazioni su Gateway Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140433.

Determinare se per il server Host sessione Desktop remoto è necessario configurare l'impostazione Autenticazione a livello di rete.

È possibile migliorare la protezione del server Host sessione Desktop remoto consentendo l'autenticazione utente in una fase precedente del processo di connessione, ovvero quando un client si connette a un server Host sessione Desktop remoto. Questo metodo di autenticazione anticipata dell'utente viene definito Autenticazione a livello di rete.

Per ulteriori informazioni, vedere Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto.

Analizzare le informazioni su Windows Firewall.

L'installazione del ruolo Servizi Desktop remoto comporta la modifica della configurazione di Windows Firewall.

Per ulteriori informazioni, vedere Servizi Desktop remoto e Windows Firewall.


Utilizzare Desktop remoto

Per consentire connessioni remote esclusivamente a scopo amministrativo, non è necessario installare il servizio ruolo Host sessione Desktop remoto. Attivare invece la funzionalità Desktop remoto nel computer che si desidera amministrare in modo remoto.

Nota

Desktop remoto supporta solo due connessioni remote simultanee al computer. Per queste connessioni, non sono necessarie licenze CAL (Client Access License) Servizi Desktop remoto.

Per attivare Desktop remoto in un computer Windows Server 2008 R2, eseguire la procedura seguente.

Per eseguire questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel computer che si intende configurare.

Per attivare Desktop remoto

  1. Avviare lo strumento Sistema. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare control system e quindi fare clic su OK.

  2. In Attività fare clic su Impostazioni di connessione remota.

  3. Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema fare clic su una delle opzioni seguenti, in base all'ambiente:

    • Consenti connessioni da computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro)

    • Consenti connessioni solo dai computer che eseguono Desktop remoto con Autenticazione a livello di rete (più sicuro)

    Per ulteriori informazioni sulle due opzioni, fare clic sul collegamento Suggerimenti per la scelta nella scheda Connessione remota.

  4. Fare clic su Seleziona utenti per aggiungere utenti e gruppi che devono connettersi al computer tramite Desktop remoto. Gli utenti e i gruppi aggiunti verranno inseriti nel gruppo Utenti desktop remoto.

    Nota

    I membri del gruppo Administrators locale possono connettersi anche se non sono presenti nell'elenco.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

  • Configurare il gruppo Utenti desktop remoto

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Installare Host sessione Desktop remoto in un controller di dominio

Non è consigliabile installare il servizio ruolo Host sessione Desktop remoto in un controller di dominio Active Directory. Consentendo agli utenti di eseguire programmi in un controller di dominio, si potrebbero provocare rischi per la sicurezza e problemi relativi alle prestazioni.

Se il servizio ruolo Host sessione Desktop remoto viene installato in un controller di dominio, sarà necessario modificare le impostazioni di sicurezza del controller di dominio per consentire agli utenti di accedere in remoto al server. Questo accesso remoto è controllato dall'assegnazione dei diritti utente Consenti accesso tramite Servizi Desktop remoto, che è possibile configurare utilizzando Console Gestione Criteri di gruppo.

Per impostazione predefinita, in un controller di dominio il diritto utente Consenti accesso tramite Servizi Desktop remoto è concesso solo al gruppo Administrators. Per consentire l'accesso remoto al server Host sessione Desktop remoto agli utenti che non sono membri del gruppo Administrators, è necessario concedere il diritto utente Consenti accesso tramite Servizi Desktop remoto al gruppo Utenti desktop remoto.

Per ulteriori informazioni sull'utilizzo di Console Gestione Criteri di gruppo per configurare le assegnazioni dei diritti utente, vedere la Guida di Console Gestione Criteri di gruppo in Windows Server 2008 R2.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Ulteriori riferimenti

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Servizi Desktop remoto e Windows Firewall

In Windows Server 2008 e Windows Server 2008 R2 Windows Firewall è attivato per impostazione predefinita. Windows Firewall consente di controllare i programmi o le porte che è possibile utilizzare per la comunicazione tra il server Windows Server 2008 o Windows Server 2008 R2 e altri computer nella rete o in Internet. Per consentire a un programma o a una porta di comunicare attraverso Windows Firewall, è necessario attivare un'eccezione.

Se si attiva Desktop remoto, in Windows Firewall viene automaticamente attivata la relativa eccezione.

Quando è installato il servizio ruolo Host sessione Desktop remoto, in Windows Firewall vengono automaticamente attivate le eccezioni seguenti:

  • Desktop remoto

  • Servizi Desktop remoto

Se si installano altri servizi ruolo di Servizi Desktop remoto, in Windows Firewall verranno automaticamente attivate altre eccezioni. Quando ad esempio si installa il servizio ruolo Servizio licenze Desktop remoto, in Windows Firewall viene attivata l'eccezione Server licenze Desktop remoto.

Quando si disinstalla, o si rimuove, un servizio ruolo dal computer, in Windows Firewall viene automaticamente rimossa la relativa eccezione.

Importante

Quando il servizio ruolo Host sessione Desktop remoto viene disinstallato, ovvero rimosso, viene rimossa solo l'eccezione Servizi Desktop remoto, non l'eccezione Desktop remoto.

Per visualizzare le eccezioni di Windows Firewall, eseguire la procedura seguente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per visualizzare le eccezioni di Windows Firewall

  1. Fare clic sul pulsante Start e quindi scegliere Pannello di controllo.

  2. Fare clic su Sistema e sicurezza e quindi su Windows Firewall.

  3. Fare clic su Consenti programma o funzionalità con Windows Firewall.

  4. Se la casella di controllo associata al programma o alla porta nell'elenco è selezionata, l'eccezione di Windows Firewall per tale programma o porta è attivata.

    Alcuni programmi vengono visualizzati nell'elenco solo dopo l'installazione del servizio ruolo. L'eccezione Server licenze Desktop remoto viene ad esempio visualizzata nell'elenco solo quando il servizio ruolo Servizio licenze Desktop remoto è installato nel computer.

Per visualizzare informazioni più dettagliate sulle impostazioni di Windows Firewall, utilizzare lo snap-in Windows Firewall con sicurezza avanzata.

Per utilizzare Windows Firewall con sicurezza avanzata, eseguire la procedura seguente.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per utilizzare lo snap-in Windows Firewall con sicurezza avanzata

  1. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi fare clic su Windows Firewall con sicurezza avanzata.

  2. Per visualizzare informazioni dettagliate sulle impostazioni di Windows Firewall, fare clic su uno dei nodi seguenti nel riquadro di sinistra:

    • Regole connessioni in entrata

    • Regole connessioni in uscita

Per ulteriori informazioni sulla configurazione di Windows Firewall, vedere la Guida di Windows Firewall con sicurezza avanzata in Windows Server 2008 R2.

Per ulteriori informazioni sulle eccezioni di Windows Firewall specifiche di Servizi Desktop remoto, vedere la pagina relativa alla documentazione tecnica di Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?Linkid=138056.

Ulteriori riferimenti

  • Utilizzare Desktop remoto

  • Installare il servizio ruolo Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Elenco di controllo: configurare un server Host sessione Desktop remoto

Per server Host sessione Desktop remoto si intende il server che ospita programmi basati su Windows o il desktop completo di Windows per i client di Servizi Desktop remoto. Gli utenti possono connettersi a un server Host sessione Desktop remoto per eseguire programmi, salvare file e utilizzare le risorse di rete disponibili in tale server. Gli utenti possono accedere a un server Host sessione Desktop remoto tramite Connessione Desktop remoto o RemoteApp.

In questo elenco di controllo sono incluse le attività che gli amministratori devono eseguire per installare e configurare un server Host sessione Desktop remoto.

Tenere presente quanto segue:

  • L'installazione del servizio ruolo Host sessione Desktop remoto richiede il riavvio del computer.

  • Non è consigliabile installare il servizio ruolo Host sessione Desktop remoto in un controller di dominio Active Directory. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

  • È consigliabile installare il servizio ruolo Host sessione Desktop remoto nel computer prima di installare qualsiasi programma che si desidera rendere disponibile per gli utenti. Per ulteriori informazioni, vedere Installare programmi in un server Host sessione Desktop remoto.

Attività | Riferimento
Analizzare i prerequisiti per l'installazione del servizio ruolo Host sessione Desktop remoto. | Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto
Installare il servizio ruolo Host sessione Desktop remoto. | Installare il servizio ruolo Host sessione Desktop remoto
Configurare le impostazioni relative alle licenze nel server Host sessione Desktop remoto. | Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto
Configurare l'impostazione Autenticazione a livello di rete per il server Host sessione Desktop remoto. | Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto
Installare programmi nel server Host sessione Desktop remoto. | Installare programmi in un server Host sessione Desktop remoto
Configurare gli utenti autorizzati a connettersi in remoto al server Host sessione Desktop remoto. | Configurare il gruppo Utenti desktop remoto

Ulteriori riferimenti

  • Panoramica di Host sessione Desktop remoto


Configurare un server Host sessione Desktop remoto

In questa sezione sono incluse le procedure per la configurazione di un server Host sessione Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Installare il servizio ruolo Host sessione Desktop remoto

  • Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto

  • Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

  • Installare programmi in un server Host sessione Desktop remoto

  • Configurare il gruppo Utenti desktop remoto

  • Configurare l'esperienza client in un server Host sessione Desktop remoto

Ulteriori riferimenti

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

  • Elenco di controllo: configurare un server Host sessione Desktop remoto


Installare il servizio ruolo Host sessione Desktop remoto

In Windows Server 2008 R2 è possibile utilizzare Server Manager per installare il servizio ruolo Host sessione Desktop remoto. Per ulteriori informazioni su altri modi per installare il servizio ruolo Host sessione Desktop remoto, incluso l'utilizzo dello strumento da riga di comando servermanagercmd.exe, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?linkid=138055.

Per installare il servizio ruolo Host sessione Desktop remoto tramite Server Manager se Servizi Desktop remoto non è già installato nel server, eseguire la procedura seguente. Se Servizi Desktop remoto è già installato nel server, vedere Installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Importante

L'installazione del servizio ruolo Host sessione Desktop remoto richiede il ravvio del computer.

Per installare il servizio ruolo Host sessione Desktop remoto

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro sinistro fare clic con il pulsante destro del mouse su Ruoli e quindi scegliere Aggiungi ruoli.

  3. Nella pagina Prima di iniziare dell'Aggiunta guidata ruoli fare clic su Avanti.

  4. Nella pagina Selezione ruoli server selezionare la casella di controllo Servizi Desktop remoto in Ruoli.

    Nota

    Se Servizi Desktop remoto è già installato nel server, la casella di controllo Servizi Desktop remoto risulterà selezionata, in grigio e seguita dalla dicitura "(Installata)".

  5. Fare clic su Avanti.

  6. Nella pagina Servizi Desktop remoto fare clic su Avanti.

  7. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

    Nota

    Se si installa il servizio ruolo Host sessione Desktop remoto in un controller di dominio, verrà visualizzato un messaggio di avviso in quanto l'installazione del servizio ruolo Host sessione Desktop remoto in un controller di dominio non è consigliata. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

  8. Nella pagina Disinstallazione e reinstallazione di applicazioni per la compatibilità fare clic su Avanti.

  9. Nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto selezionare il metodo di autenticazione appropriato per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sui metodi di autenticazione, vedere Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto.

  10. Nella pagina Impostazione modalità di gestione licenze selezionare la modalità di gestione licenze appropriata per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sulle modalità di gestione licenze, vedere Specificare la modalità di gestione licenze Desktop remoto.

  11. Nella pagina Selezione dei gruppi di utenti autorizzati ad accedere al server Host sessione Desktop remoto aggiungere gli utenti o i gruppi di utenti a cui si desidera consentire la connessione remota al server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare il gruppo Utenti desktop remoto.

  12. Nella pagina Configura esperienza client selezionare le funzionalità che si desidera rendere disponibili ai client remoti connessi mediante il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare l'esperienza client in un server Host sessione Desktop remoto.

  13. Nella pagina Conferma selezioni per l'installazione verificare che il servizio ruolo Host sessione Desktop remoto venga installato e quindi fare clic su Installa.

  14. Nella pagina Stato installazione verrà indicato lo stato di avanzamento dell'installazione.

  15. Nella pagina Risultati installazione verrà richiesto di riavviare il server per completare il processo di installazione. Fare clic su Chiudi e quindi su Sì nella finestra Aggiunta servizi ruolo per riavviare il server.

  16. Se viene segnalato che altri programmi sono ancora in esecuzione, eseguire una delle operazioni seguenti:

    • Per chiudere i programmi manualmente e riavviare il server in un secondo momento, fare clic su Annulla.

    • Per chiudere i programmi automaticamente e riavviare il server, fare clic su Riavvia.

  17. Dopo aver riavviato il server e aver eseguito l'accesso al computer, verranno completati gli altri passaggi dell'installazione. Quando viene visualizzata la pagina Risultati installazione, verificare che l'installazione di Host sessione Desktop remoto sia stata eseguita correttamente.

    Per verificare che Host sessione Desktop remoto sia stato installato è inoltre possibile eseguire la procedura seguente:

    1. Avviare Server Manager.

    2. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    3. In Servizi di sistema verificare che lo stato di Servizi Desktop remoto sia In esecuzione.

    4. In Servizi ruolo verificare che lo stato di Host sessione Desktop remoto sia Installato.

Installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato

Per installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato nel server, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Importante

L'installazione del servizio ruolo Host sessione Desktop remoto richiede il ravvio del computer.

Per installare il servizio ruolo Host sessione Desktop remoto quando Servizi Desktop remoto è già installato

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro sinistro espandere Ruoli.

  3. Fare clic con il pulsante destro del mouse su Servizi Desktop remoto e quindi scegliere Aggiungi servizi ruolo.

  4. Nella pagina Selezione servizi ruolo selezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

    Nota

    Se si installa il servizio ruolo Host sessione Desktop remoto in un controller di dominio, verrà visualizzato un messaggio di avviso in quanto l'installazione del servio ruolo Host sessione Desktop remoto in un controllo di dominio non è consigliata. Per ulteriori informazioni, vedere Installare Host sessione Desktop remoto in un controller di dominio.

  5. Nella pagina Disinstallazione e reinstallazione di applicazioni per la compatibilità fare clic su Avanti.

  6. Nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto selezionare il metodo di autenticazione appropriato per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sui metodi di autenticazione, vedere Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto.

  7. Nella pagina Impostazione modalità di gestione licenze selezionare la modalità di gestione licenze appropriata per il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni sulle modalità di gestione licenze, vedere Specificare la modalità di gestione licenze Desktop remoto.

  8. Nella pagina Selezione dei gruppi di utenti autorizzati ad accedere al server Host sessione Desktop remoto aggiungere gli utenti o i gruppi di utenti a cui si desidera consentire la connessione remota al server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare il gruppo Utenti desktop remoto.

  9. Nella pagina Configura esperienza client selezionare le funzionalità che si desidera rendere disponibili ai client remoti connessi mediante il server Host sessione Desktop remoto e quindi fare clic su Avanti. Per ulteriori informazioni, vedere Configurare l'esperienza client in un server Host sessione Desktop remoto.

  10. Nella pagina Conferma selezioni per l'installazione verificare che il servizio ruolo Host sessione Desktop remoto venga installato e quindi fare clic su Installa.

  11. Nella pagina Stato installazione verrà indicato lo stato dell'installazione.

  12. Nella pagina Risultati installazione verrà richiesto di riavviare il server per completare il processo di installazione. Fare clic su Chiudi e quindi su Sì nella finestra Aggiunta servizi ruolo per riavviare il server.

  13. Se viene segnalato che altri programmi sono ancora in esecuzione, eseguire una delle operazioni seguenti:

    • Per chiudere manualmente i programmi e riavviare il server in un secondo momento, fare clic su Annulla.

    • Per chiudere automaticamente i programmi e riavviare il server, fare clic su Riavvia.

  14. Dopo aver riavviato il server ed eseguito l'accesso al computer, verranno completati gli altri passaggi dell'installazione. Quando viene visualizzata la pagina Risultati installazione, verificare che l'installazione di Host sessione Desktop remoto sia stata eseguita correttamente.

    Per verificare che Host sessione Desktop remoto sia stato installato è inoltre possibile eseguire la procedura seguente:

    1. Avviare Server Manager.

    2. In Riepilogo ruoli fare clic su Servizi Desktop remoto.

    3. In Servizi di sistema verificare che lo stato di Servizi Desktop remoto sia In esecuzione.

    4. In Servizi ruolo verificare che lo stato di Host sessione Desktop remoto sia Installato.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Panoramica di Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto

  • Elenco di controllo: configurare un server Host sessione Desktop remoto


Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto

Ogni utente o dispositivo di elaborazione che si connette a un server Host sessione Desktop remoto deve disporre di una licenza CAL (Client Access License) Servizi Desktop remoto valida rilasciata da un server licenze Desktop remoto.

Per garantire che un server Host sessione Desktop remoto possa contattare un server licenze Desktop remoto per richiedere licenze CAL Servizi Desktop remoto per i client, è necessario eseguire le operazioni seguenti nel server Host sessione Desktop remoto:

  • Specificare la modalità di gestione licenze Desktop remoto

  • Specificare un server licenze per il server Host sessione Desktop remoto

Per essere informati di eventuali problemi di configurazione della gestione licenze, utilizzare Diagnosi gestione licenze in Configurazione host sessione Desktop remoto. Per informazioni su Diagnosi gestione licenze, vedere l'argomento relativo all'identificazione di possibili problemi relativi alla gestione delle licenze per il server Host sessione Desktop remoto nella Guida di Configurazione host sessione Desktop remoto in Windows Server 2008 R2.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Elenco di controllo: prerequisiti per l'installazione di Host sessione Desktop remoto


Specificare la modalità di gestione licenze Desktop remoto

La modalità gestione licenze Desktop remoto determina il tipo di licenze CAL (Client Access License) Servizi Desktop remoto richiesto da un server Host sessione Desktop remoto a un server licenze per conto di un client che si connette al server Host sessione Desktop remoto.

Importante

La modalità gestione licenze Desktop remoto configurata in un server Host sessione Desktop remoto deve corrispondere al tipo delle licenze CAL Servizi Desktop remoto disponibile nel server licenze.

Esistono due tipi di licenze CAL Servizi Desktop remoto:

  • Licenza CAL Per dispositivo di Servizi Desktop remoto: consente a un dispositivo, utilizzato da qualsiasi utente, di connettersi a un server Host sessione Desktop remoto.

  • Licenza CAL Per utente di Servizi Desktop remoto: concede a un utente il diritto di accedere a server Host sessione Desktop remoto da un numero illimitato di dispositivi o computer client.

La modalità gestione licenze Desktop remoto per il server Host sessione Desktop remoto può essere impostata nei modi seguenti:

  • Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, nella pagina Impostazione modalità di gestione licenze nell'Aggiunta guidata ruoli.

    Nella pagina Impostazione modalità di gestione licenze è possibile selezionare Configura in seguito se durante l'installazione non si è certi se selezionare Per dispositivo o Per utente. Se si seleziona Configura in seguito, ogni volta che si accede al server Host sessione Desktop remoto nell'angolo in basso a destra del desktop verrà visualizzato un messaggio indicante che è necessario configurare la modalità gestione licenze per il server Host sessione Desktop remoto.

  • Configurando l'opzione Modalità di gestione licenze di Desktop remoto per il server Host sessione Desktop remoto tramite lo strumento Configurazione host sessione Desktop remoto.

    Se le impostazioni di Modalità di gestione licenze di Desktop remoto sono visualizzate in grigio e non possono essere selezionate, l'impostazione di Criteri di gruppo Imposta modalità gestione licenze Desktop remoto è stata attivata e applicata al server Host sessione Desktop remoto.

  • Applicando l'impostazione di Criteri di gruppo Imposta la modalità Licenze Desktop remoto.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Gestione licenze e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni su Servizio licenze Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140434.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto


Specificare un server licenze per il server Host sessione Desktop remoto

Un server Host sessione Desktop remoto deve essere in grado di contattare un server licenze Desktop remoto per richiedere licenze CAL (Client Access License) Servizi Desktop remoto per gli utenti o i dispositivi di elaborazione che si connettono al server Host sessione Desktop remoto.

In Windows Server 2008 R2 è necessario specificare un server licenze per l'utilizzo da parte del server Host sessione Desktop remoto. L'individuazione automatica del server licenze non è più supportata per un server Host sessione Desktop remoto che esegue Windows Server 2008 R2.

Eseguire la procedura seguente per specificare un server licenze per l'utilizzo da parte del server Host sessione Desktop remoto.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per specificare un server licenze per il server Host sessione Desktop remoto

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nella sezione Modifica impostazioni fare doppio clic su Server licenze Desktop remoto in Gestione licenze.

  4. Fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiungi server licenze selezionare un server licenze nell'elenco dei server di questo tipo noti e quindi fare clic su Aggiungi. Se il server licenze che si desidera aggiungere non è incluso nell'elenco, nella casella Nome o indirizzo IP del server licenze digitare il nome o l'indirizzo IP del server licenze da aggiungere e quindi fare clic su Aggiungi.

    È possibile aggiungere più server licenze per l'utilizzo da parte del server Host sessione Desktop remoto. Il server Host sessione Desktop remoto contatterà i server licenze nell'ordine in cui sono visualizzati nella casella Server licenze specificati.

  6. Fare clic su OK per chiudere la finestra di dialogo Aggiungi server licenze e quindi di nuovo su OK per salvare le modifiche relative alle impostazioni di gestione delle licenze.

È inoltre possibile specificare un server licenze per l'utilizzo da parte del server Host sessione Desktop remoto applicando l'impostazione di Criteri di gruppo Usa server licenze Desktop remoto specificati. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Gestione licenze e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sui server licenze configurati in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare impostazioni relative alle licenze in un server Host sessione Desktop remoto


Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

Autenticazione a livello di rete consente di migliorare la sicurezza di un server Host sessione Desktop remoto richiedendo che l'utente venga autenticato in un server Host sessione Desktop remoto prima della creazione di una sessione.

Autenticazione a livello di rete è un metodo di autenticazione che consente di completare l'autenticazione dell'utente prima che venga stabilita una connessione desktop remoto e che venga visualizzata la schermata di accesso. Si tratta di un metodo di autenticazione più sicuro che contribuisce a proteggere il computer remoto da utenti malintenzionati e software dannoso. Autenticazione a livello di rete offre i vantaggi seguenti:

  • Richiede un minore dispendio iniziale di risorse per il computer remoto. Il computer remoto utilizza una quantità limitata di risorse prima di eseguire l'autenticazione dell'utente, anziché avviare una connessione desktop remoto completa come accade nelle versioni precedenti.

  • Offre un migliore livello di sicurezza, riducendo il rischio di attacchi Denial of Service.

Per poter utilizzare Autenticazione a livello di rete, devono essere soddisfatti i requisiti seguenti:

  • Il computer client deve utilizzare almeno Connessione desktop remoto 6.0.

  • Il computer client deve utilizzare un sistema operativo, ad esempio Windows® 7 o Windows Vista®, che supporti il protocollo CredSSP (Credential Security Support Provider).

  • Il server Host sessione Desktop remoto deve utilizzare Windows Server 2008 R2 o Windows Server 2008.

È possibile configurare un server Host sessione Desktop remoto per supportare solo le connessioni da client che eseguono Autenticazione a livello di rete. È possibile configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto nei modi seguenti:

  • Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, nella pagina Impostazione del metodo di autenticazione per Host sessione Desktop remoto dell'Aggiunta guidata ruoli.

  • Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto.

    Se l'opzione Consenti connessioni dai computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro) non è selezionata né attivata, l'impostazione di Criteri di gruppo Richiedi autenticazione utente tramite Autenticazione a livello di rete per le connessioni remote è stata attivata e applicata al server Host sessione Desktop remoto.

    Per configurare l'impostazione Autenticazione a livello di rete tramite la scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto, vedere Modificare le impostazioni di connessione remota.

  • Nella scheda Generale della finestra di dialogo Proprietà di una connessione nello strumento Configurazione host sessione Desktop remoto, selezionando la casella di controllo Consenti connessioni solo da computer che eseguono Desktop remoto con Autenticazione a livello di rete.

    Se la casella di controllo Consenti connessioni solo da computer che eseguono Desktop remoto con Autenticazione a livello di rete è selezionata e visualizzata in grigio, l'impostazione di Criteri di gruppo Richiedi autenticazione utente per le connessioni remote tramite Autenticazione a livello di rete è stata attivata e applicata al server Host sessione Desktop remoto.

  • Applicando l'impostazione di Criteri di gruppo Richiedi autenticazione utente tramite Autenticazione a livello di rete per le connessioni remote.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto o nella scheda Connessione remota.

Per determinare se un computer esegue una versione di Connessione desktop remoto che supporta il metodo Autenticazione a livello di rete, avviare Connessione desktop remoto, fare clic sull'icona nell'angolo in alto a sinistra della finestra di dialogo Connessione desktop remoto e quindi fare clic su Informazioni su. Nella finestra di dialogo Informazioni su Connessione desktop remoto ricercare la frase Autenticazione a livello di rete supportata.

Per ulteriori informazioni su Autenticazione a livello di rete e Servizi Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=138055.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto

  • Installare il servizio ruolo Host sessione Desktop remoto


Installare programmi in un server Host sessione Desktop remoto

È consigliabile installare il servizio ruolo Host sessione Desktop remoto nel computer prima di installare qualsiasi programma che si desidera rendere disponibile per gli utenti. Se si installa il servizio ruolo Host sessione Desktop remoto in un computer in cui sono già installati programmi, alcuni dei programmi esistenti potrebbero non funzionare correttamente in un ambiente multiutente. È possibile che tali problemi vengano risolti disinstallando e quindi reinstallando i programmi interessati.

Per garantire la corretta installazione di un'applicazione e il relativo funzionamento in un ambiente multiutente, è necessario attivare una speciale modalità di installazione nel server Host sessione Desktop remoto prima di installare l'applicazione nel server Host sessione Desktop remoto. Questa speciale modalità di installazione fa sì che durante il processo di installazione vengano creati le voci del Registro di sistema e i file con estensione ini corretti necessari per supportare l'esecuzione dell'applicazione in un ambiente multiutente.

È possibile attivare questa speciale modalità di installazione in un server Host sessione Desktop remoto utilizzando uno dei metodi seguenti:

  • Strumento Installa applicazione nel server desktop remoto in Programmi nel Pannello di controllo. Questo strumento esegue una procedura guidata per semplificare l'installazione dell'applicazione.

  • Comando Change user /install al prompt dei comandi. Sarà necessario avviare manualmente l'installazione dell'applicazione.

Al termine dell'installazione dell'applicazione, è necessario attivare la modalità di esecuzione nel server Host sessione Desktop remoto prima che gli utenti remoti inizino a utilizzare l'applicazione. Tramite lo strumento Installa applicazione nel server desktop remoto la modalità di esecuzione verrà automaticamente attivata nel server Host sessione Desktop remoto al termine dell'esecuzione. Per attivare la modalità di esecuzione nel server Host sessione Desktop remoto dal prompt dei comandi, utilizzare il comando change user /execute.

Ulteriori considerazioni

  • Per la corretta esecuzione in un server Host sessione Desktop remoto, alcuni programmi potrebbero richiedere modifiche minime a livello di configurazione.

  • Se sono presenti programmi con relazioni di correlazione o di dipendenza reciproca, è consigliabile installarli nello stesso server Host sessione Desktop remoto. È consigliabile, ad esempio, installare Microsoft Office come famiglia di prodotti nello stesso server Host sessione Desktop remoto anziché installare singoli programmi di Office in server Host sessione Desktop remoto distinti.

  • È consigliabile installare singoli programmi in server Host sessione Desktop remoto distinti nei casi seguenti:

    • Possono verificarsi problemi di compatibilità tra il programma e altri programmi.

    • Un singolo programma e il numero di utenti associati rischiano di esaurire la capacità del server.

  • Per ulteriori informazioni sugli strumenti da riga di comando per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138135.

  • Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto


Configurare il gruppo Utenti desktop remoto

Il gruppo Utenti desktop remoto in un server Host sessione Desktop remoto consente di concedere a utenti e gruppi l'autorizzazione necessaria per connettersi in remoto al server Host sessione Desktop remoto.

È possibile aggiungere utenti e gruppi al gruppo Utenti desktop remoto tramite i metodi seguenti:

  • Snap-in Utenti e gruppi locali

  • Snap-in Utenti e computer di Active Directory se il server Host sessione Desktop remoto è installato in un controller di dominio

  • Nella scheda Connessione remota della finestra di dialogo Proprietà sistema in un server Host sessione Desktop remoto

Per aggiungere utenti e gruppi al gruppo Utenti desktop remoto tramite la scheda Connessione remota della finestra di dialogo Proprietà del sistema in un server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Per aggiungere utenti e gruppi al gruppo Utenti desktop remoto tramite la scheda Connessione remota

  1. Avviare lo strumento Sistema. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare control system e quindi fare clic su OK.

  2. In Attività fare clic su Impostazioni di connessione remota.

  3. Nella scheda Connessione remota nella finestra di dialogo Proprietà del sistema fare clic su Seleziona utenti. Aggiungere gli utenti o i gruppi che devono connettersi al server Host sessione Desktop remoto tramite Desktop remoto. Gli utenti e i gruppi aggiunti verranno inseriti nel gruppo Utenti desktop remoto.

    Nota

    I membri del gruppo Administrators locale possono connettersi anche se non sono presenti nell'elenco.

    Se nella scheda Connessione remota si seleziona Non consentire connessioni al computer, nessun utente potrà connettersi in remoto a questo computer, anche se è membro del gruppo Utenti desktop remoto.

Ulteriori riferimenti

  • Configurare un server Host sessione Desktop remoto


Configurare l'esperienza client in un server Host sessione Desktop remoto

È possibile configurare un server Host sessione Desktop remoto in modo che gli utenti che si connettono a una sessione desktop remoto possano utilizzare una funzionalità simile a quella disponibile in Windows 7.

Importante

Per poter garantire questa funzionalità, sono necessarie ulteriori risorse di sistema e di larghezza di banda, che possono influire sulla scalabilità del server Host sessione Desktop remoto.

Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, è possibile configurare automaticamente le funzionalità seguenti nella pagina Configura esperienza client dell'Aggiunta guidata ruoli:

  • Reindirizzamento riproduzione audio e video

  • Reindirizzamento registrazione audio

  • Composizione desktop

Se si configura il server Host sessione Desktop remoto in modo da consentire la riproduzione audio e video o la composizione desktop, nel server Host sessione Desktop remoto verrà installata la funzionalità Esperienza desktop. Per ulteriori informazioni su Esperienza desktop, vedere Funzionalità Esperienza desktop.

Per configurare manualmente tale funzionalità, vedere gli argomenti seguenti:

  • Configurare la riproduzione audio e video in un server Host sessione Desktop remoto

  • Configurare il reindirizzamento della registrazione audio in un server Host sessione Desktop remoto

  • Configurare la composizione desktop in un server Host sessione Desktop remoto


Funzionalità Esperienza desktop

La funzionalità Esperienza desktop consente di installare una vasta gamma di componenti e funzionalità offerti dal sistema operativo Windows 7 in un computer che esegue il sistema operativo Windows Server 2008 R2. Dopo avere installato Esperienza desktop, i componenti e le funzionalità di Windows 7, ad esempio Windows Media Player, verranno visualizzati in Tutti i programmi nel menu Start.

Nota

L'installazione di Esperienza desktop non comporta l'attivazione automatica dei relativi componenti o funzionalità. Dopo aver installato Esperienza desktop, sarà infatti necessario attivare o configurare manualmente le funzionalità o i componenti desiderati.

Per informazioni sull'installazione di Esperienza desktop, vedere Installare Esperienza desktop in un server Host sessione Desktop remoto.

Componenti e funzionalità di Esperienza desktop

Esperienza desktop include i componenti e le funzionalità di Windows 7 seguenti:

  • Calendario di Windows

  • Windows Mail

  • Windows Media Player

  • Temi del desktop

  • Video per Windows (supporto AVI)

  • Raccolta foto di Windows

  • Windows SideShow

  • Windows Defender

  • Pulizia disco

  • Centro sincronizzazione

  • Registratore di suoni

  • Mappa caratteri

  • Strumento di cattura

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Installare Esperienza desktop in un server Host sessione Desktop remoto

Quando un utente utilizza Connessione Desktop remoto per connettersi a un server Host sessione Desktop remoto, per impostazione predefinita viene riprodotto il desktop presente nel server Host sessione Desktop remoto nella sessione remota. Per conferire alla sessione remota lo stesso aspetto dell'esperienza desktop di Windows 7 locale dell'utente, installare la funzionalità Esperienza desktop in un server Host sessione Desktop remoto che esegue Windows Server 2008 R2.

Esperienza desktop consente di installare componenti e funzionalità di Windows 7, ad esempio Windows Media Player, Windows Defender e il Calendario di Windows. Per ulteriori informazioni su Esperienza desktop, vedere Funzionalità Esperienza desktop.

Installare Esperienza desktop

Per installare Esperienza desktop nel server, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Importante

L'installazione di Esperienza desktop richiede il riavvio del computer.

Per installare Esperienza desktop

  1. Aprire Gestione server. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Gestione server.

  2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità fare clic su Aggiungi funzionalità.

  3. Nella pagina Selezione funzionalità selezionare la casella di controllo Esperienza desktop.

  4. Verificare le informazioni relative alle funzionalità necessarie da installare con Esperienza desktop e quindi fare clic su Aggiungi funzionalità necessarie.

  5. Fare clic su Avanti.

  6. Nella pagina Conferma selezioni per l'installazione verificare che la funzionalità Esperienza desktop verrà installata e quindi fare clic su Installa.

  7. Nella pagina Stato installazione verrà indicato lo stato di avanzamento dell'installazione.

  8. Nella pagina Risultati installazione verrà richiesto di riavviare il server per completare il processo di installazione. Fare clic su Chiudi e quindi su Sì per riavviare il server.

  9. Dopo aver riavviato il server e aver eseguito l'accesso al computer con lo stesso account utente, verranno completati gli altri passaggi dell'installazione. Quando viene visualizzata la pagina Risultati installazione, verificare che l'installazione di Esperienza desktop sia stata eseguita correttamente e quindi fare clic su Chiudi.

    È inoltre possibile verificare che la funzionalità Esperienza desktop sia installata eseguendo la procedura seguente:

    1. Avviare Server Manager.

    2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità verificare che Esperienza desktop sia elencata come installata.

Dopo avere installato Esperienza desktop, i componenti e le funzionalità di Windows 7, ad esempio Windows Media Player, verranno visualizzati in Tutti i programmi nel menu Start.

Disinstallare (rimuovere) Esperienza desktop

Per disinstallare, ovvero rimuovere, Esperienza desktop dal server, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Importante

La rimozione di Esperienza desktop dal server richiede il riavvio del computer.

Per disinstallare (rimuovere) Esperienza desktop

  1. Aprire Gestione server. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Gestione server.

  2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità fare clic su Rimuovi funzionalità.

  3. Nella pagina Selezione delle funzionalità deselezionare la casella di controllo Esperienza desktop e quindi fare clic su Avanti.

  4. Nella pagina Conferma selezioni per la rimozione verificare che la funzionalità Esperienza desktop verrà rimossa e quindi fare clic su Rimuovi.

  5. Nella pagina Stato rimozione verrà indicato lo stato di avanzamento della rimozione.

  6. Nella pagina Risultati rimozione verrà richiesto di riavviare il server per completare il processo di rimozione. Fare clic su Chiudi e quindi su Sì per riavviare il server.

  7. Dopo aver riavviato il server e aver eseguito l'accesso al computer con lo stesso account utente, verranno completati gli altri passaggi della rimozione. Quando viene visualizzata la pagina Risultati rimozione, verificare che la rimozione di Esperienza desktop sia stata eseguita correttamente e quindi fare clic su Chiudi.

    È inoltre possibile verificare che la funzionalità Esperienza desktop sia stata rimossa eseguendo la procedura seguente:

    1. Avviare Server Manager.

    2. Nel riquadro sinistro fare clic su Funzionalità e quindi nella sezione Riepilogo funzionalità verificare che Esperienza desktop non sia più elencata come installata.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Configurare la riproduzione audio e video in un server Host sessione Desktop remoto

La riproduzione audio e video consente agli utenti di reindirizzare l'audio del computer remoto in una sessione remota, garantendo una migliore esperienza di riproduzione video nelle sessioni remote. Per impostazione predefinita, la riproduzione audio e video non è consentita quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2.

Nota

Gli utenti possono specificare dove riprodurre l'output audio del computer remoto configurando le impostazioni per l'audio remoto nella scheda Risorse locali di Connessione desktop remoto. La riproduzione video può essere configurata utilizzando l'impostazione videoplayback in un file Remote Desktop Protocol (con estensione rdp). La riproduzione video è attivata per impostazione predefinita.

Configurare manualmente la riproduzione audio e video

Per configurare manualmente la riproduzione audio e video in un server Host sessione Desktop remoto, è necessario eseguire le operazioni seguenti:

  • Installare la funzionalità Esperienza desktop.

  • Avviare il servizio Audio di Windows.

  • Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video.

  • Impostare l'intensità di colore massima su 32 bit per pixel.

Installare la funzionalità Esperienza desktop

Per informazioni sull'installazione di Esperienza desktop, vedere Installare Esperienza desktop in un server Host sessione Desktop remoto.

Avviare il servizio Audio di Windows

Per avviare il servizio Audio Windows nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per avviare il servizio Audio di Windows

  1. Nel server Host sessione Desktop remoto aprire lo snap-in Servizi. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nel riquadro Servizi fare clic con il pulsante destro del mouse su Audio di Windows e quindi scegliere Proprietà.

  4. Nella casella Tipo di avvio nella scheda Generale selezionare Automatico e quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà - Audio di Windows.

  7. Verificare che nella colonna Stato relativa al servizio Audio di Windows sia visualizzato Avviato.

Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video.

Per consentire la riproduzione audio e video quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2, è necessario attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video. L'impostazione Consenti reindirizzamento riproduzione audio e video è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Impostare l'intensità di colore massima su 32 bit per pixel

Per impostare l'intensità di colore massima su 32 bit per pixel nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per impostare l'intensità di colore massima su 32 bit per pixel

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. In Connessioni fare clic con il pulsante destro del mouse sulla connessione da configurare, ad esempio RDP-Tcp, e quindi scegliere Proprietà.

  4. Nella casella Limita intensità colore massima nella scheda Impostazioni client selezionare 32 bit per pixel.

  5. Fare clic su OK. Quando si apporta una modifica alle impostazioni dell'intensità del colore, questa non verrà applicata alle sessioni connesse al momento della modifica. Le modifiche diventeranno effettive alla successiva connessione dell'utente al server Host sessione Desktop remoto.

È inoltre possibile impostare l'intensità del colore massima applicando l'impostazione di Criteri di gruppo Limita intensità colore massima. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Configurare il reindirizzamento della registrazione audio in un server Host sessione Desktop remoto

Il reindirizzamento della registrazione audio consente agli utenti di effettuare registrazioni audio nel computer remoto in una sessione remota. Per impostazione predefinita, il reindirizzamento della registrazione audio non è consentito quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2.

Nota

Gli utenti possono specificare se registrare l'audio nel computer remoto configurando le impostazioni per l'audio remoto nella scheda Risorse locali di Connessione desktop remoto. Per tali registrazioni possono utilizzare un dispositivo di input audio, quale un microfono incorporato, nel computer locale.

Configurare manualmente il reindirizzamento della registrazione audio

Per configurare manualmente il reindirizzamento della registrazione audio in un server Host sessione Desktop remoto, è necessario eseguire le operazioni seguenti:

  • Avviare il servizio Audio di Windows.

  • Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio.

Avviare il servizio Audio di Windows

Per avviare il servizio Audio Windows nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per avviare il servizio Audio di Windows

  1. Nel server Host sessione Desktop remoto aprire lo snap-in Servizi. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nel riquadro Servizi fare clic con il pulsante destro del mouse su Audio di Windows e quindi scegliere Proprietà.

  4. Nella casella Tipo di avvio nella scheda Generale selezionare Automatico e quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia.

  6. Fare clic su OK per chiudere la finestra di dialogo Audio di Windows - Proprietà.

  7. Verificare che nella colonna Stato relativa al servizio Audio di Windows sia visualizzato Avviato.

Attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio

Per consentire il reindirizzamento della registrazione audio quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2, è necessario attivare l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Configurare la composizione desktop in un server Host sessione Desktop remoto

La composizione desktop offre gli elementi di interfaccia utente tipici di Windows Aero, ad esempio finestre semitrasparenti, per le sessioni desktop remoto. Per impostazione predefinita, la composizione desktop non è consentita quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2.

Importante

Poiché per Windows Aero sono necessarie ulteriori risorse di sistema e di larghezza di banda, la configurazione della composizione desktop per sessioni desktop remoto può ridurre le prestazioni delle connessioni, in particolare in presenza di collegamenti lenti, e aumentare il carico del server Host sessione Desktop remoto.

La composizione desktop non è disponibile per le sessioni di RemoteApp. Per supportare le funzionalità di Windows Aero, il computer client deve inoltre disporre dell'hardware necessario.

Configurare manualmente la composizione desktop

Per configurare manualmente la composizione desktop in un server Host sessione Desktop remoto, è necessario eseguire le operazioni seguenti:

  • Installare la funzionalità Esperienza desktop.

  • Avviare il servizio Temi.

  • Attivare l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto.

  • Impostare l'intensità di colore massima su 32 bit per pixel.

Installare la funzionalità Esperienza desktop

Per informazioni sull'installazione di Esperienza desktop, vedere Installare Esperienza desktop in un server Host sessione Desktop remoto.

Avviare il servizio Temi

Per avviare il servizio Temi nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per avviare il servizio Temi

  1. Nel server Host sessione Desktop remoto aprire lo snap-in Servizi. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. Nel riquadro Servizi fare clic con il pulsante destro del mouse su Temi e quindi scegliere Proprietà.

  4. Nella casella Tipo di avvio nella scheda Generale selezionare Automatico e quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà - Temi.

  7. Verificare che nella colonna Stato relativa al servizio Temi sia visualizzato Avviato.

Attivare l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto

Per consentire la composizione desktop quando ci si connette a un computer in cui è in esecuzione Windows Server 2008 R2, è necessario attivare l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Impostare l'intensità di colore massima su 32 bit per pixel

Per impostare l'intensità di colore massima su 32 bit per pixel nel server Host sessione Desktop remoto, eseguire la procedura seguente.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare. Per ulteriori informazioni sull'utilizzo degli account e delle appartenenze di gruppo appropriati, vedere http://go.microsoft.com/fwlink/?LinkId=83477 (la pagina potrebbe essere in inglese).

Per impostare l'intensità di colore massima su 32 bit per pixel

  1. Nel server Host sessione Desktop remoto aprire Configurazione host sessione Desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. Se viene visualizzata la finestra di dialogo Controllo account utente, confermare che l'azione visualizzata è quella desiderata e quindi fare clic su Sì.

  3. In Connessioni fare clic con il pulsante destro del mouse sulla connessione da configurare, ad esempio RDP-Tcp, e quindi scegliere Proprietà.

  4. Nella casella Limita intensità colore massima nella scheda Impostazioni client selezionare 32 bit per pixel.

  5. Fare clic su OK. Quando si apporta una modifica alle impostazioni dell'intensità del colore, questa non verrà applicata alle sessioni connesse al momento della modifica. Le modifiche diventeranno effettive alla successiva connessione dell'utente al server Host sessione Desktop remoto.

È inoltre possibile impostare l'intensità del colore massima applicando l'impostazione di Criteri di gruppo Limita intensità colore massima. Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota e può essere configurata tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo. Si noti che l'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Impostazioni di Criteri di gruppo e configurazione di Esperienza client

Durante l'installazione del servizio ruolo Host sessione Desktop remoto in Server Manager, è possibile configurare automaticamente le funzionalità seguenti nella pagina Configura esperienza client dell'Aggiunta guidata ruoli:

  • Reindirizzamento riproduzione audio e video

  • Reindirizzamento registrazione audio

  • Composizione desktop

Server Manager verifica automaticamente se attualmente al computer sono applicate impostazioni di Criteri di gruppo che possono impedire la corretta configurazione delle funzionalità richieste. In caso affermativo, la relativa selezione risulterà visualizzata in grigio e non sarà possibile selezionare la casella di controllo associata nella pagina Configura esperienza client.

Di seguito è riportato un elenco delle impostazioni di Criteri di gruppo verificate da Server Manager:

  • Consenti reindirizzamento riproduzione audio e video

    Se l'impostazione di Criteri di gruppo Consenti reindirizzamento riproduzione audio e video è disattivata, non sarà possibile selezionare la casella di controllo Reindirizzamento riproduzione audio e video nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse.

  • Consenti reindirizzamento registrazione audio

    Se l'impostazione di Criteri di gruppo Consenti reindirizzamento registrazione audio è disattivata, non sarà possibile selezionare la casella di controllo Reindirizzamento registrazione audio nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Reindirizzamento dispositivi e risorse.

  • Consenti composizione desktop per sessioni desktop remoto

    Se l'impostazione di Criteri di gruppo Consenti composizione desktop per sessioni desktop remoto è disattivata, non sarà possibile selezionare la casella di controllo Composizione desktop nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota.

  • Limita intensità colore massima

    Se l'impostazione di Criteri di gruppo Limita intensità colore massima è attivata e l'intensità di colore massima selezionata è inferiore a 32 bit per pixel, non sarà possibile selezionare la casella di controllo Composizione desktop nella pagina Configura esperienza client.

    Questa impostazione è disponibile in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Ambiente sessione remota.

Queste impostazioni di Criteri di gruppo possono essere configurate utilizzando l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Configurare l'esperienza client in un server Host sessione Desktop remoto


Gestire un server Host sessione Desktop remoto

In questa sezione sono incluse le procedure per la gestione di un server Host sessione Desktop remoto. Sono inclusi gli argomenti seguenti:

  • Modificare le impostazioni di connessione remota

  • Attivare Single Sign-On del client di Connessione desktop remoto per Servizi Desktop remoto

  • Gestire i profili utente per Servizi Desktop remoto

  • Configurare i caratteri smussati per le sessioni remote

  • Monitorare un server Host sessione Desktop remoto con Gestione risorse di sistema Windows

  • Disinstallare il servizio ruolo Host sessione Desktop remoto


Modificare le impostazioni di connessione remota

È possibile eseguire la procedura seguente per modificare le impostazioni di connessione remota in un server Host sessione Desktop remoto.

Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema nel server Host sessione Desktop remoto è possibile modificare le impostazioni di connessione remota seguenti:

  • Requisito Autenticazione a livello di rete per le connessioni desktop remoto

  • Appartenenza al gruppo Utenti desktop remoto

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Per modificare le impostazioni di connessione remota

  1. Avviare lo strumento Sistema. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare control system e quindi fare clic su OK.

  2. In Attività fare clic su Impostazioni di connessione remota.

  3. Nella scheda Connessione remota della finestra di dialogo Proprietà del sistema fare clic su una delle opzioni seguenti, in base all'ambiente:

    • Consenti connessioni da computer che eseguono qualsiasi versione di Desktop remoto (meno sicuro)

    • Consenti connessioni solo dai computer che eseguono Desktop remoto con Autenticazione a livello di rete (più sicuro)

    Per ulteriori informazioni sulle due opzioni, fare clic sul collegamento Suggerimenti per la scelta nella scheda Connessione remota.

    Se nella scheda Connessione remota si seleziona Non consentire connessioni al computer, nessun utente potrà connettersi in remoto a questo computer, anche se è membro del gruppo Utenti desktop remoto.

  4. Fare clic su Seleziona utenti per aggiungere utenti e gruppi che devono connettersi al computer tramite Desktop remoto. Gli utenti e i gruppi aggiunti verranno inseriti nel gruppo Utenti desktop remoto.

    Nota

    I membri del gruppo Administrators locale possono connettersi anche se non sono presenti nell'elenco.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto

  • Configurare l'impostazione Autenticazione a livello di rete per un server Host sessione Desktop remoto

  • Configurare il gruppo Utenti desktop remoto


Attivare Single Sign-On del client di Connessione desktop remoto per Servizi Desktop remoto

Single Sign-On è un metodo di autenticazione che consente agli utenti che dispongono di un account di dominio di eseguire un accesso a un computer cliente utilizzando una password e quindi di accedere ai server remoti senza dover reimmettere le credenziali.

Nota

Questo argomento riguarda esclusivamente l'autenticazione Single Sign-On da un client di Connessione Desktop remoto a un server Host sessione Desktop remoto. In Windows Server 2008 R2 è possibile abilitare Single Sign-On anche tra Accesso Web Desktop remoto e Host sessione Desktop remoto. Per ulteriori informazioni su Single Sign-On con Accesso Web Desktop remoto, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137334.

Per implementare la funzionalità Single Sign-On in Servizi Desktop remoto, è necessario soddisfare i requisiti seguenti:

  • È possibile utilizzare Single Sign-On solo per connessioni remote da un computer che esegue Windows 7, Microsoft Windows Vista o Windows XP con Service Pack 3 a un server Host sessione Desktop remoto che esegue Windows Server 2008 R2 o Windows Server 2008. È inoltre possibile utilizzare Single Sign-On per connessioni remote da un server in cui è in esecuzione Windows Server 2008 R2 o Windows Server 2008 a un altro server in cui è in esecuzione Windows Server 2008 R2 o Windows Server 2008.

  • Verificare che gli account utente utilizzati per accedere dispongano di diritti appropriati per l'accesso al server Host sessione Desktop remoto e al computer client.

  • Il computer client e il server Host sessione Desktop remoto devono appartenere allo stesso dominio.

Per configurare le impostazioni consigliate per il server Host sessione Desktop remoto, eseguire le operazioni seguenti:

  • Configurare l'autenticazione nel server Host sessione Desktop remoto.

  • Configurare il computer client per consentire l'utilizzo di credenziali predefinite per l'accesso ai server Host sessione Desktop remoto specificati.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per configurare l'autenticazione nel server Host sessione Desktop remoto

  1. Aprire Configurazione host sessione Desktop remoto. Per aprire Configurazione host sessione Desktop remoto, fare clic sul pulsante Start, scegliere Strumenti di amministrazione, Servizi Desktop remoto e quindi Configurazione host sessione Desktop remoto.

  2. In Connessioni fare clic con il pulsante destro del mouse sulla connessione appropriata, ad esempio RDP-Tcp, e quindi scegliere Proprietà.

  3. Nella scheda Generale della finestra di dialogo Proprietà verificare che il valore di Livello di sicurezza sia impostato su Negoziazione o SSL (TLS 1.0).

  4. Nella scheda Impostazioni di accesso verificare che la casella di controllo Richiedi sempre password sia deselezionata e quindi fare clic su OK.

Dopo aver configurato l'autenticazione nel server Host sessione Desktop remoto, è necessario consentire l'utilizzo delle credenziali predefinite nel server Host sessione Desktop remoto tramite Criteri di gruppo. Le impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Sicurezza e possono essere configurate tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Per ulteriori informazioni sulla sicurezza e su Servizi Desktop remoto, vedere la pagina relativa a tale funzionalità nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=138055.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Gestire i profili utente per Servizi Desktop remoto

Un profilo utente descrive la configurazione per un utente specifico, incluse le impostazioni relative all'ambiente e alle preferenze dell'utente. Se non vengono pianificati e gestiti nell'ambiente di un server Host sessione Desktop remoto, i profili utente possono assumere dimensioni elevate e causare problemi, ad esempio tempi di accesso prolungati, al momento della connessione di un utente a un server Host sessione Desktop remoto. La gestione dei profili utente è inoltre importante quando gli utenti si connettono a diversi server Host sessione Desktop remoto o si connettono a server Host sessione Desktop remoto in posizioni remote.

È possibile specificare una home directory e un percorso profilo specifici di Servizi Desktop remoto per un utente che si connette a un server Host sessione Desktop remoto. Il profilo e la home directory specificati verranno utilizzati solo per le sessioni di Servizi Desktop remoto. È opportuno assegnare un profilo separato per le sessioni di Servizi Desktop remoto in quanto molte delle opzioni comuni archiviate nei profili, ad esempio screen saver ed effetti di animazione dei menu, non sono consigliabili quando si utilizza Servizi Desktop remoto.

È possibile configurare manualmente queste impostazioni nella scheda Profilo Servizi Desktop remoto della finestra delle proprietà di un account utente nello snap-in Utenti e gruppi locali o Utenti e computer di Active Directory.

Per configurare queste impostazioni, è inoltre possibile utilizzare le impostazioni di Criteri di gruppo seguenti:

  • Imposta la home directory utente di Servizi Desktop remoto

  • Imposta percorso per profili utente mobile di Servizi Desktop remoto

  • Usa profili obbligatori nel server Host sessione Desktop remoto

Le impostazioni di Criteri di gruppo sono disponibili in Configurazione computer\Criteri\Modelli amministrativi\Componenti di Windows\Servizi Desktop remoto\Host sessione Desktop remoto\Profili e possono essere configurate tramite l'Editor Criteri di gruppo locali o Console Gestione Criteri di gruppo.

Nota

L'impostazione di Criteri di gruppo avrà la priorità sull'impostazione configurata in Configurazione host sessione Desktop remoto o nella scheda Connessione remota.

Per ulteriori informazioni su Host sessione Desktop remoto, vedere la pagina relativa a Servizi Desktop remoto nel sito Web TechCenter di Windows Server 2008 R2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=140438.

Per ulteriori informazioni sulle impostazioni di Criteri di gruppo per Servizi Desktop remoto, vedere la pagina relativa ai riferimenti tecnici per Servizi Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=138134.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Configurare i caratteri smussati per le sessioni remote

Windows Server 2008 R2 supporta ClearType®, una tecnologia che consente di visualizzare i tipi di carattere in modo che risultino chiari e uniformi, in particolare quando si utilizza un monitor LCD.

Un server Host sessione Desktop remoto che esegue Windows Server 2008 R2 può offrire la funzionalità ClearType in una sessione remota quando un computer client si connette al server Host sessione Desktop remoto tramite Connessione Desktop remoto.

Nota

In Connessione desktop remoto la funzionalità ClearType viene indicata come anti-aliasing caratteri.

Tale funzionalità è disponibile se il computer client esegue uno dei sistemi operativi seguenti:

  • Windows 7

  • Microsoft Windows Vista

  • Windows Server 2003 con Service Pack 1 (SP1) e almeno Connessione desktop remoto 6.0

  • Windows XP con SP2 e almeno Connessione desktop remoto 6.0

Importante

L'utilizzo di caratteri smussati in una sessione remota comporta l'aumento della larghezza di banda utilizzata tra il computer client e il server Host sessione Desktop remoto.

Per rendere disponibili i caratteri smussati in una sessione remota

  1. Nel computer client aprire Connessione desktop remoto. A tale scopo, fare clic sul pulsante Start, scegliere Tutti i programmi, Accessori e quindi Connessione desktop remoto.

  2. Nella finestra di dialogo Connessione desktop remoto fare clic su Opzioni.

  3. Nella scheda Prestazioni selezionare la casella di controllo Anti-aliasing caratteri.

  4. Configurare eventuali altre impostazioni di connessione e quindi fare clic su Connetti.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Monitorare un server Host sessione Desktop remoto con Gestione risorse di sistema Windows

Gestione risorse di sistema Windows (WSRM) in Windows Server 2008 R2 consente di controllare in che modo le risorse di CPU e di memoria vengono allocate alle applicazioni, ai servizi e ai processi nel computer. Questo tipo di gestione delle risorse consente di migliorare le prestazioni del sistema e limitare le possibilità che applicazioni, servizi o processi si sottraggano a vicenda risorse di CPU o di memoria, riducendo le prestazioni del computer. La gestione delle risorse garantisce inoltre un'esperienza più coerente e prevedibile agli utenti di applicazioni e servizi in esecuzione nel computer.

È possibile utilizzare Gestione risorse di sistema Windows per gestire gli utenti o più applicazioni in un computer in cui è installato Servizi Desktop remoto.

Prima di installare e configurare Gestione risorse di sistema Windows, installare il servizio ruolo Host sessione Desktop remoto nel computer. Per installare Host sessione Desktop remoto, vedere Installare il servizio ruolo Host sessione Desktop remoto. Per installare Gestione risorse di sistema Windows, fare clic su Funzionalità in Server Manager.

Per ulteriori informazioni sull'installazione, la configurazione e l'utilizzo di Gestione risorse di sistema Windows, vedere la relativa Guida in Windows Server 2008 R2.

Due funzionalità di Gestione risorse di sistema Windows sono particolarmente interessanti per gli amministratori di server Host sessione Desktop remoto:

  • Criteri di allocazione risorse

  • Monitoraggio risorse

Criteri di allocazione risorse

In Gestione risorse di sistema Windows vengono utilizzati criteri di allocazione risorse per determinare in che modo le risorse del computer, ad esempio CPU e memoria, vengono allocate ai processi in esecuzione nel computer. I tre criteri di allocazione risorse progettati specificatamente per i computer che eseguono Servizi Desktop remoto sono i seguenti:

  • Equal_Per_User

  • Equal_Per_Session

  • Weighted_Remote_Sessions

Se si implementa il criterio Equal_Per_Session, ogni sessione utente, con i relativi processi associati, ottiene una quantità equivalente delle risorse di CPU nel computer.

Monitoraggio risorse

Prima e dopo aver implementato un criterio di allocazione risorse o aver apportato qualsiasi altra modifica di configurazione relativa a Gestione risorse di sistema Windows, è consigliabile raccogliere i dati sulle prestazioni del server Host sessione Desktop remoto. Per raccogliere e visualizzare i dati sull'utilizzo delle risorse hardware e l'attività dei servizi di sistema nel computer, è possibile utilizzare Monitoraggio risorse, disponibile nello snap-in Gestione risorse di sistema Windows.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Disinstallare il servizio ruolo Host sessione Desktop remoto

Utilizzare la procedura seguente per disinstallare, o rimuovere, il servizio ruolo Host sessione Desktop remoto dal server.

Per completare questa procedura, è necessaria almeno l'appartenenza al gruppo Administrators locale oppure a un gruppo equivalente nel server Host sessione Desktop remoto che si intende configurare.

Importante

La rimozione del servizio ruolo Host sessione Desktop remoto dal server richiede il riavvio del computer.

Per disinstallare (rimuovere) il servizio ruolo Host sessione Desktop remoto

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Nel riquadro sinistro espandere Ruoli.

  3. Fare clic con il pulsante destro del mouse su Servizi Desktop remoto e quindi scegliere Rimuovi servizi ruolo.

  4. Nella pagina Selezione servizi ruolo deselezionare la casella di controllo Host sessione Desktop remoto e quindi fare clic su Avanti.

  5. Nella pagina Conferma selezioni per la rimozione fare clic su Rimuovi.

  6. Nella pagina Stato rimozione verrà indicato lo stato di avanzamento della rimozione.

  7. Nella pagina Risultati rimozione verrà richiesto di riavviare il server per completare il processo di rimozione. Fare clic su Chiudi e quindi su Sì nella finestra Rimozione servizi ruolo per riavviare il server.

  8. Se viene segnalato che altri programmi sono ancora in esecuzione, eseguire una delle operazioni seguenti:

    • Per chiudere i programmi manualmente e riavviare il server in un secondo momento, fare clic su Annulla.

    • Per chiudere i programmi automaticamente e riavviare il server, fare clic su Riavvia.

  9. Dopo aver riavviato il server e aver eseguito l'accesso al computer, verranno completati gli altri passaggi della rimozione. Quando viene visualizzata la pagina Risultati rimozione, verificare che la rimozione di Host sessione Desktop remoto sia stata eseguita correttamente.

    È inoltre possibile verificare che Host sessione Desktop remoto sia stato rimosso eseguendo le operazioni seguenti:

    1. Avviare Server Manager.

    2. In Riepilogo ruoli verificare che Servizi Desktop remoto non sia visualizzato come ruolo installato.

Ulteriori riferimenti

  • Gestire un server Host sessione Desktop remoto


Host di virtualizzazione Desktop remoto

In questa sezione vengono descritte procedure utili per la configurazione di Host di virtualizzazione Desktop remoto all'interno dell'organizzazione.

In questa sezione sono contenute le procedure seguenti:

  • Panoramica di Host di virtualizzazione Desktop remoto

  • Installare il servizio ruolo Host di virtualizzazione Desktop remoto


Panoramica di Host di virtualizzazione Desktop remoto

Host di virtualizzazione Desktop remoto è un servizio ruolo di Servizi Desktop remoto incluso in Windows Server 2008 R2. Host di virtualizzazione Desktop remoto si integra con Hyper-V per fornire macchine virtuali tramite Connessione RemoteApp e desktop. È possibile configurare Host di virtualizzazione Desktop remoto in modo che a ogni utente dell'organizzazione venga assegnata una macchina virtuale univoca o in modo che gli utenti vengano reindirizzati a un pool condiviso di macchine virtuali in cui viene assegnata dinamicamente una macchina virtuale.

Host di virtualizzazione Desktop remoto utilizza Gestore connessione Desktop remoto per determinare dove viene reindirizzato l'utente. Se a un utente viene assegnato e richiede un desktop virtuale personale, verrà reindirizzato da Gestore connessione Desktop remoto a questa macchina virtuale. Se la macchina virtuale non è attiva, Host di virtualizzazione Desktop remoto la attiverà e quindi connetterà l'utente. Se l'utente si connette a un pool condiviso di macchine virtuali, Gestore connessione Desktop remoto innanzitutto verificherà se dispone di una sessione disconnessa nel pool. In caso affermativo, l'utente verrà riconnesso a quella macchina virtuale. In caso negativo, all'utente verrà assegnata dinamicamente una macchina virtuale del pool, se disponibile.

Per ulteriori informazioni sull'installazione e sulla configurazione di Host di virtualizzazione Desktop remoto, vedere la Guida dettagliata relativa a Host di virtualizzazione Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137796.

Ulteriori riferimenti

  • Installare il servizio ruolo Host di virtualizzazione Desktop remoto


Installare il servizio ruolo Host di virtualizzazione Desktop remoto

Host di virtualizzazione Desktop remoto è un servizio ruolo di Servizi Desktop remoto disponibile in Windows Server 2008 R2. Host di virtualizzazione Desktop remoto è installabile tramite Server Manager. Quando è installato il servizio ruolo Host di virtualizzazione Desktop remoto, Server Manager verifica l'eventuale presenza di Hyper-V. Se Hyper-V non è installato, verrà installato automaticamente.

Importante

Il server di Host di virtualizzazione Desktop remoto deve soddisfare il requisito hardware per il ruolo server Hyper-V. Per ulteriori informazioni sui requisiti hardware di Hyper-V, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=129920.

L'appartenenza al gruppo locale Administrators o equivalente, è il minimo indispensabile per completare questa procedura.

Per installare il servizio ruolo Host di virtualizzazione Desktop remoto tramite Server Manager

  1. Aprire Server Manager. Per aprire Gestione server, fare clic su Start, scegliere Strumenti di amministrazione e quindi fare clic su Gestione server.

  2. Espandere Ruoli e quindi fare clic su Servizi Desktop remoto.

  3. In Servizi ruolo fare clic su Aggiungi servizi ruolo.

  4. Selezionare la casella di controllo Host di virtualizzazione Desktop remoto e quindi fare clic su Avanti. Se Hyper-V non è installato nel computer in uso, verrà installato automaticamente.

  5. Fare clic su Installa.

  6. Al termine dell'installazione, fare clic su Chiudi.

Per ulteriori informazioni sull'installazione e sulla configurazione del servizio ruolo Host di virtualizzazione Desktop remoto, vedere la Guida dettagliata relativa a Host di virtualizzazione Desktop remoto all'indirizzo http://go.microsoft.com/fwlink/?LinkId=137796.

Ulteriori riferimenti

  • Panoramica di Host di virtualizzazione Desktop remoto