Servizi di distribuzione Windows

È possibile utilizzare Servizi di distribuzione Windows per installare Windows in più computer in una rete anziché installare ogni sistema operativo direttamente da un CD o un DVD. Per utilizzare Servizi di distribuzione Windows, è consigliabile avere acquisito una certa familiarità con gli aspetti pratici relativi alle tecnologie di distribuzione di sistemi desktop e ai componenti di rete più comuni, inclusi Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS) e Servizi di dominio Active Directory.

Nota

La presente documentazione è un sottoinsieme della documentazione disponibile online all'indirizzo http://go.microsoft.com/fwlink/?LinkId=134776.

  • Panoramica di Servizi di distribuzione Windows

  • Configurare Servizi di distribuzione Windows

  • Gestire Servizi di distribuzione Windows

  • Risorse per Servizi di distribuzione Windows

  • Interfaccia utente: Servizi di distribuzione Windows


Panoramica di Servizi di distribuzione Windows

Servizi di distribuzione Windows è un ruolo server che consente di distribuire in modalità remota i sistemi operativi Windows. È possibile utilizzare tale ruolo per configurare nuovi computer eseguendo un'installazione basata su rete. Questo significa che non è necessario installare ogni sistema operativo direttamente da un CD o DVD. Per utilizzare Servizi di distribuzione Windows, è consigliabile avere acquisito una certa familiarità con gli aspetti pratici relativi alle tecnologie di distribuzione di sistemi desktop e ai componenti di rete più comuni, inclusi Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS) e Servizi di dominio Active Directory.

È possibile utilizzare la guida dettagliata su Servizi di distribuzione Windows (http://go.microsoft.com/fwlink/?LinkID=84628), in cui sono incluse istruzioni per l'installazione del ruolo, l'aggiunta di immagini, la configurazione del server e l'installazione di un'immagine. La guida include inoltre istruzioni per eseguire attività più avanzate, ad esempio il multicast delle immagini, la creazione di immagini e la configurazione di un'installazione automatica.

Nota

La presente documentazione è un sottoinsieme della documentazione disponibile online all'indirizzo http://go.microsoft.com/fwlink/?LinkId=134776.

Elenco di controllo per l'avvio rapido

Per iniziare rapidamente, completare la procedura seguente.

 | Attività | Riferimento
Casella di controllo | Configurare il server. | Configurare Servizi di distribuzione Windows
Casella di controllo | Aggiungere le immagini predefinite (Install.wim e Boot.wim) incluse nel DVD di installazione, nella cartella \Sources. | Aggiungere immagini di avvio e di installazione
Casella di controllo | Installare un sistema operativo. | Installare un sistema operativo

Strumenti per la gestione di Servizi di distribuzione Windows

Per gestire il server è possibile utilizzare due strumenti. Per le procedure relative alle attività comuni, vedere la pagina relativa all'esecuzione di attività comuni (http://go.microsoft.com/fwlink/?LinkId=143204).

  • Snap-in di MMC Servizi di distribuzione Windows . Snap-in di Microsoft Management Console (MMC) che consente di gestire in modo semplice immagini, computer e impostazioni comuni del server. Mediante lo snap-in di MMC è possibile eseguire quasi tutte le attività. Non è ad esempio possibile eseguire la pre-installazione di computer client o gestire immagini vhd. Si noti che lo snap-in non è disponibile quando viene installato solo il servizio ruolo Server di trasporto.

  • Strumento da riga di comando WDSUTIL. Strumento che consente di gestire la funzionalità completa del server. nonché di creare script di attività comuni, ovvero semplici file batch in grado di eseguire i comandi necessari perché i comandi non richiedono una sessione utente interattiva.

Vantaggi

Servizi di distribuzione Windows offre i vantaggi seguenti:

  • Consente l'installazione di rete dei sistemi operativi Windows, che, se paragonata alle installazioni manuali, riduce complessità e costi.

  • Supporta ambienti misti, inclusi Windows XP, Windows Server 2003, Windows 7 e Windows Server 2008 R2.

  • Utilizza tecnologie di installazione di Windows standard, inclusi Ambiente preinstallazione di Windows (Windows PE), file con estensione wim e installazione basata su immagine.

  • Trasmette i dati e le immagini utilizzando la funzionalità multicast.

  • Consente di creare immagini di un computer di riferimento utilizzando l'Acquisizione guidata immagine, che costituisce un'alternativa allo strumento ImageX. Per ulteriori informazioni, vedere la sezione relativa alla creazione di immagini di installazione personalizzate nella pagina sulla creazione di immagini (http://go.microsoft.com/fwlink/?LinkId=115311).

  • Consente di aggiungere pacchetti driver al server e configurarli in modo da distribuirli nei computer client insieme all'immagine di installazione. È inoltre possibile aggiungere pacchetti driver (ad esempio driver di scheda di rete, driver di archiviazione di massa e driver bus) alle immagini di avvio di Windows 7 e Windows Server 2008 R2. Per ulteriori informazioni, vedere Gestire pacchetti driver.

  • Consente di distribuire immagini del disco rigido virtuale, con estensione vhd, durante una distribuzione automatizzata. Per ulteriori informazioni, vedere Distribuire immagini del disco rigido virtuale.

Ulteriori riferimenti

  • Configurare Servizi di distribuzione Windows

  • Gestire Servizi di distribuzione Windows

  • Risorse per Servizi di distribuzione Windows


Elenco di controllo: creare un'immagine di installazione personalizzata

È possibile utilizzare Servizi di distribuzione Windows per personalizzare i sistemi operativi da distribuire, modificando le immagini e creandone di nuove da personalizzare in base alle esigenze aziendali. Standardizzando le applicazioni, i driver e le impostazioni di configurazione, è possibile migliorare la coerenza in tutta l'organizzazione. Per ulteriori informazioni, vedere la pagina sulla creazione di immagini (http://go.microsoft.com/fwlink/?LinkId=115311).

 | Passaggio | Riferimento
Casella di controllo | Aggiungere un'immagine di avvio al server. | Aggiungere immagini di avvio e di installazione
Casella di controllo | Creare un'immagine di acquisizione. | creare un'immagine di installazione personalizzata
Casella di controllo | Creare un'immagine di installazione personalizzata e aggiungerla al server. | creare un'immagine di installazione personalizzata
Casella di controllo | Modificare l'immagine (facoltativo). | Modificare le immagini di avvio e di installazione
Casella di controllo | Distribuire l'immagine di installazione personalizzata. | Installare un sistema operativo


Elenco di controllo: gestire computer conosciuti e sconosciuti

È possibile utilizzare Servizi di distribuzione Windows per collegare computer client a oggetti account computer in Servizi di dominio Active Directory. Questa operazione è denominata configurazione di client pre-installazione. I client pre-installazione sono anche chiamati “computer noti”. La configurazione di client pre-installazione consente di configurare le impostazioni dell'account per controllare l'installazione per ogni client. È possibile, ad esempio, configurare il programma di avvio di rete e il file di installazione automatica che vengono ricevuti dal client, oltre che il server dal quale il client scarica il programma di avvio di rete. Per i computer non pre-installazione (computer sconosciuti), è possibile abilitare il criterio di aggiunta automatica. Quando il criterio è abilitato, è necessaria l'approvazione amministrativa per poter installare un'immagine in un computer sconosciuto. Per ulteriori informazioni, vedere la pagina relativa alla configurazione di computer client pre-installazione (http://go.microsoft.com/fwlink/?LinkId=131987).

 | Passaggio | Riferimento
Casella di controllo | Configurare computer client pre-installazione in Servizi di dominio Active Directory. | Computer client pre-installazione
Casella di controllo | Configurare la risposta ai client sconosciuti. | Configurare il criterio di aggiunta automatica e Scheda Risposta PXE
Casella di controllo | Configurare le impostazioni di Servizi di dominio Active Directory per i client. | Scheda Servizi di dominio Active Directory
Nota

Per un elenco di procedure relative al criterio di aggiunta automatica e alla configurazione di client pre-installazione, vedere la pagina relativa alla gestione dei computer client (http://go.microsoft.com/fwlink/?LinkID=115265).


Elenco di controllo: gestire pacchetti driver

È possibile utilizzare Servizi di distribuzione Windows per aggiungere pacchetti driver al server e quindi distribuirli ai client durante un'installazione di rete. Dopo avere aggiunto i pacchetti driver al server, è possibile definire quali client riceveranno i driver utilizzando i gruppi di driver, nonché aggiungere i driver nelle immagini di avvio.

 | Passaggio | Riferimento
Casella di controllo | Ottenere e aggiungere pacchetti driver al server. | Estrarre e aggiungere pacchetti driver
Casella di controllo | Creare gruppi di driver. | Distribuire pacchetti driver
Casella di controllo | Configurare i pacchetti driver sul server. | Distribuire pacchetti driver
Casella di controllo | Modificare i pacchetti driver. | Attributi di driver e pacchetti
Casella di controllo | Aggiungere pacchetti driver a un'immagine di installazione. | Aggiungere pacchetti driver a un'immagine di avvio


Elenco di controllo: creare un'installazione automatica

Con Servizi di distribuzione Windows è possibile configurare l'intero processo di distribuzione in modo che venga eseguito senza l'intervento dell'utente. A tale scopo, è necessario automatizzare le schermate dell'interfaccia utente di Servizi di distribuzione Windows e le fasi successive dell'installazione, tra cui l'unione del computer a un dominio. È inoltre possibile automatizzare l'Acquisizione guidata immagine utilizzando un file WDSCapture.inf. Per ulteriori informazioni, vedere la pagina relativa all'esecuzione di un'installazione automatica (http://go.microsoft.com/fwlink/?LinkId=89226).

 | Passaggio | Riferimento
Casella di controllo | Creare un file di installazione automatica client Servizi di distribuzione Windows e impostarlo come predefinito da utilizzare per ogni architettura. | Configurare un'installazione automatica
Casella di controllo | Creare un file di installazione automatica immagine e associarlo a un'immagine. | Configurare un'installazione automatica
Casella di controllo | Creare un file di installazione automatica per l'Acquisizione guidata immagine e salvarlo all'interno dell'immagine. | Automatizzare l'Acquisizione guidata immagine (http://go.microsoft.com/fwlink/?LinkId=131989)


Configurare Servizi di distribuzione Windows

Dopo l'installazione di Servizi di distribuzione Windows, sarà necessario configurare il server. La configurazione del server dipende dai servizi ruolo installati.

In questa sezione vengono trattati gli argomenti seguenti:

  • Server di trasporto. È possibile installare solo il servizio ruolo Server di trasporto. Questo servizio ruolo offre un sottoinsieme delle funzionalità di Servizi di distribuzione Windows e può essere installato in ambienti in cui non sia presente Servizi di dominio Active Directory, DHCP o DNS. È possibile utilizzare il ruolo Server di trasporto per avviare in rete i computer in Ambiente preinstallazione di Windows (Windows PE), trasmettere dati (incluse le immagini dei sistemi operativi) tramite multicasting o per eseguire entrambe le operazioni.

  • Server di distribuzione. È possibile installare sia il servizio ruolo Server di distribuzione che Server di trasporto, che assicurano la funzionalità completa di Servizi di distribuzione Windows. Non è possibile installare solo Server di distribuzione senza Server di trasporto.

Ulteriori riferimenti

  • Servizi di distribuzione Windows


Server di trasporto

Durante l'installazione è possibile scegliere di installare solo il servizio ruolo Server di trasporto. Questo servizio ruolo offre un sottoinsieme delle funzionalità di Servizi di distribuzione Windows e può essere installato in ambienti in cui non sia presente Servizi di dominio Active Directory, DHCP o DNS. Server di trasporto contiene solo i componenti di rete principali di Servizi di distribuzione Windows.

È possibile utilizzare il ruolo Server di trasporto per avviare in rete i computer in Ambiente preinstallazione di Windows (Windows PE), trasmettere dati (incluse le immagini dei sistemi operativi) tramite multicasting o per eseguire entrambe le operazioni. Installare il ruolo Server di trasporto in scenari avanzati come parte di una soluzione di distribuzione personalizzata. Sebbene non sia necessario avere esperienza nello sviluppo di software per implementare questa soluzione, è consigliabile avere familiarità con l'utilizzo degli strumenti da riga di comando e con la scrittura di script.

Per informazioni sulla configurazione del ruolo Server di trasporto per avviare in rete i computer e/o per la trasmissione multicast dei dati, vedere la pagina relativa all'utilizzo del ruolo Server di trasporto (http://go.microsoft.com/fwlink/?LinkId=143905).


Server di distribuzione

Durante l'installazione, è possibile scegliere di installare sia il servizio ruolo Server di distribuzione che Server di trasporto, che assicurano la funzionalità completa di Servizi di distribuzione Windows. Sarà quindi possibile configurare e installare i sistemi operativi Windows da postazioni remote. Server di distribuzione dipende dai componenti principali di Server di trasporto (questo è il motivo per cui non è possibile installare solo Server di distribuzione senza Server di trasporto).

Nota

Per informazioni sulla configurazione del server, vedere la pagina relativa alla guida dettagliata a Servizi di distribuzione Windows (http://go.microsoft.com/fwlink/?LinkId=84628).

Installare Servizi di distribuzione Windows

È possibile installare Servizi di distribuzione Windows utilizzando la procedura guidata per le attività di configurazione iniziale, Server Manager o la riga di comando.

  • Per installare il ruolo tramite la procedura guidata, fare clic su Aggiungi ruoli nella schermata iniziale di Attività di configurazione iniziale. Fare clic su Avanti e quindi selezionare Servizi di distribuzione Windows.

  • Per installare il ruolo tramite Server Manager, fare clic su Aggiungi ruoli nel riquadro Riepilogo ruoli. Fare clic su Avanti e quindi selezionare Servizi di distribuzione Windows.

  • Per installare il ruolo tramite la riga di comando, eseguire ServerManagerCmd -install WDS.

Configuring Windows Deployment Services

Dopo l'installazione di Servizi di distribuzione Windows, sarà necessario configurare il server.

  • Per eseguire la configurazione tramite l'interfaccia di Windows

  • Per eseguire la configurazione tramite riga di comando

Per eseguire la configurazione tramite l'interfaccia di Windows

  1. Verificare di appartenere al gruppo Domain Admins.

  2. Fare clic sul pulsante Start, scegliere Strumenti di amministrazione e quindi Servizi di distribuzione Windows. Se nel nodo Server non è elencato alcun server, fare clic con il pulsante destro del mouse sul nodo Server e scegliere Aggiungi server per aggiungere il computer locale.

  3. Nel riquadro sinistro dello snap-in MMC Servizi di distribuzione Windows espandere il nodo Server.

  4. Fare clic con il pulsante destro del mouse sul server e quindi scegliere Configura server.

  5. Seguire le istruzioni della procedura guidata.

  6. Al termine della configurazione, verificare che la casella di controllo Aggiungi immagini al server ora sia selezionata e quindi fare clic su Fine.

  7. Seguire le istruzioni della procedura guidata per aggiungere almeno un'immagine di avvio e una di installazione. Per ulteriori informazioni, vedere Aggiungere immagini di avvio e di installazione.

  8. Se si desidera modificare le impostazioni del server, fare clic con il pulsante destro del mouse sul server nello snap-in MMC e scegliere Proprietà. Per un elenco delle attività di configurazione e per le istruzioni, vedere la pagina relativa alla gestione del server (http://go.microsoft.com/fwlink/?LinkId=143379).

Per eseguire la configurazione tramite riga di comando

  1. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Digitare il comando seguente, dove <path> è il percorso in cui si desidera salvare la cartella RemoteInstall. Questa cartella deve essere una partizione NTFS con dimensioni sufficienti a contenere tutte le future immagini e non deve corrispondere alla partizione di sistema.

    WDSUTIL /initialize-server /reminst:<path>

  3. Per impostare il criterio di risposta, eseguire il comando seguente. Se si imposta questo valore su Known, è necessario configurare un computer pre-installazione in Servizi di dominio Active Directory prima di ricevere la risposta dal server di Servizi di distribuzione Windows.

    WDSUTIL /Set-Server /AnswerClients:{all|known|none}

  4. Se si installa Servizi di distribuzione Windows in un computer in cui è installato il ruolo Server DHCP, eseguire il comando seguente. Per ulteriori informazioni sui motivi per cui è necessario configurare queste opzioni, vedere Scheda DHCP.

    WDSUTIL /Set-Server /UseDHCPPorts:no /DHCPoption60:yes

  5. Eseguire le configurazioni aggiuntive necessarie per l'ambiente. Per un elenco delle attività di configurazione aggiuntive e per le istruzioni, vedere la pagina relativa alla gestione del server (http://go.microsoft.com/fwlink/?LinkId=143379).

  6. Dopo la configurazione del server è necessario aggiungere le immagini, ovvero un'immagine di avvio (l'ambiente avviabile utilizzato per l'avvio iniziale del computer) e le immagini di installazione (le immagini effettive distribuite). Per istruzioni, vedere Aggiungere immagini di avvio e di installazione.

Ulteriori riferimenti

  • Panoramica di Servizi di distribuzione Windows

  • Configurare Servizi di distribuzione Windows

  • Gestire Servizi di distribuzione Windows

  • Risorse per Servizi di distribuzione Windows


Gestire Servizi di distribuzione Windows

In questa sezione sono contenute le informazioni sulla gestione di computer client, immagini e pacchetti driver.

In questa sezione vengono trattati gli argomenti seguenti:

  • Gestire i computer client

  • Gestire immagini

  • Gestire pacchetti driver


Gestire i computer client

È possibile utilizzare Servizi di distribuzione Windows per collegare computer client a oggetti account computer in Servizi di dominio Active Directory. Questa operazione è denominata configurazione di client pre-installazione. I client pre-installazione sono anche chiamati “computer noti”. Per i computer noti, è possibile configurare il criterio di aggiunta automatica per la richiesta dell'approvazione amministrativa prima che vengano autorizzati a eseguire l'avvio nel server per installare un sistema operativo. È inoltre possibile configurare un'installazione automatica per i client per automatizzare il client Servizi di distribuzione Windows e le fasi successive dell'installazione di Windows.

In questa sezione

  • Computer client pre-installazione

  • Configurare il criterio di aggiunta automatica

  • Installare un sistema operativo

  • Configurare un'installazione automatica


Computer client pre-installazione

È possibile utilizzare Servizi di distribuzione Windows per collegare computer fisici a oggetti account computer in Servizi di dominio Active Directory. Questa operazione è denominata configurazione di client pre-installazione. I client pre-installazione sono anche chiamati computer noti. La configurazione del client pre-installazione consente di configurare le proprietà per controllare l'installazione del client. È possibile, ad esempio, configurare il programma di avvio di rete e il file di installazione automatica che il client deve ricevere, oltre che il server dal quale il client deve scaricare il programma di avvio di rete. Per ulteriori informazioni, vedere http://go.microsoft.com/fwlink/?LinkId=131987. Per un elenco di procedure relative al criterio di aggiunta automatica e ai client pre-installazione, vedere la pagina relativa alla gestione dei computer client (http://go.microsoft.com/fwlink/?LinkID=115265).

È possibile creare un oggetto account computer e associarlo a un computer fisico utilizzando i metodi seguenti:

  • Mediante WDSUTIL. Mediante la riga di comando è possibile eseguire la pre-installazione di computer client prima che abbiano eseguito un tentativo di avvio di rete. Per istruzioni, vedere di seguito la seconda procedura. Si noti che non è possibile configurare computer pre-installazione utilizzando lo snap-in MMC Servizi di distribuzione Windows, ma è possibile impostare il Configurare il criterio di aggiunta automatica e approvare o rifiutare i computer in sospeso.

  • Mediante lo snap-in Utenti e computer di Active Directory. Mediante Servizi di dominio Active Directory è possibile eseguire la pre-installazione di computer client prima che abbiano eseguito un tentativo di avvio di rete. Per istruzioni, vedere di seguito la prima procedura.

  • Mediante l'attivazione del criterio di aggiunta automatica. Se si attiva questo criterio, quando si approva l'installazione di un client sconosciuto, l'installazione continua e in Servizi di dominio Active Directory viene creato un account computer per il client. Per ulteriori informazioni, vedere Configurare il criterio di aggiunta automatica.

  • Mediante l'utilizzo di Servizi di distribuzione Windows come parte dell'immagine di installazione. Per impostazione predefinita, ogni installazione di sistema operativo che utilizza Servizi di distribuzione Windows determina un computer client che appartiene a un dominio. È possibile disabilitare questa funzionalità tramite la scheda Client della pagina delle proprietà del server.

Per configurare computer client pre-installazione tramite l'interfaccia di Windows

  1. Nel server che esegue Utenti e computer di Active Directory aprire lo snap-in MMC Utenti e computer di Active Directory. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare dsa.msc e quindi fare clic su OK.

    Nota

    Per gestire il server in remoto, è possibile installare “Snap-in e strumenti da riga di comando di Servizi di dominio Active Directory” in Strumenti di amministrazione remota del server. A tale scopo, fare clic su Aggiungi funzionalità in Server Manager e installare la funzionalità dal percorso seguente: Strumenti di amministrazione remota del server>Strumenti di amministrazione remota>Strumenti per Servizi di dominio Active Directory e AD LDS>Strumenti di Servizi di dominio Active Directory>Snap-in e strumenti da riga di comando di Servizi di dominio Active Directory.

  2. Nell'albero della console fare clic con il pulsante destro del mouse sull'unità organizzativa in cui verrà incluso il nuovo computer client.

  3. Scegliere Nuovo e quindi Computer.

  4. Digitare il nome del computer client, fare clic su Avanti e quindi su Computer gestito.

  5. Nella casella di testo digitare l'indirizzo MAC (Media Access Control) del computer client preceduto da venti zeri o l'identificatore univoco globale (GUID) nel formato: {XXXXXXXX-XXXX-XXXX-XXX-XXXXXXXXXXXX}.

  6. Fare clic su Avanti e scegliere una delle opzioni seguenti per specificare quale server o quali server garantiranno il supporto per questo computer client:

    • Qualsiasi server di installazione remota

    • Il seguente server di installazione remota

  7. Fare clic su Avanti e quindi su Fine.

Per configurare computer client pre-installazione tramite la riga di comando

  1. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Digitare il comando seguente, dove <devicename> è il nome e <GUIDorMACAddress> è l'identificatore del nuovo computer. Se si utilizza l'indirizzo MAC con l'opzione /ID, è necessario che questo sia preceduto da venti zero (0).

    WDSUTIL /add-device /device:<devicename> /ID:<GUIDorMACAddress> <options>

    Ad esempio: WDSUTIL /Add-Device /Device:Computer1 /ID:{E8A3EFAC-201F-4E69-953F-B2DAA1E8B1B6} /ReferralServer:WDSServer1 /BootProgram:boot\x86\pxeboot.com /WDSClientUnattend:WDSClientUnattend\unattend.xml /User:Domain\MyUser/JoinRights:Full /BootImagePath:boot\x86\images\boot.wim /OU:"OU=MyOU,CN=Test,DC=Domain,DC=com"

Ulteriori riferimenti

  • Gestire Servizi di distribuzione Windows

  • Configurare il criterio di aggiunta automatica


Configurare il criterio di aggiunta automatica

Il criterio di aggiunta automatica specifica che è necessaria l'approvazione amministrativa prima che venga consentito di installare un sistema operativo in computer sconosciuti (computer pre-installazione non configurati in Servizi di dominio Active Directory). Se si abilita questo criterio, i client in attesa di approvazione vengono visualizzati nel nodo Periferiche in sospeso dello snap-in di MMC. Se si approva un computer in sospeso, l'avvio di tale computer continuerà a essere eseguito dalla rete e in Servizi di dominio Active Directory verrà creato un oggetto account computer per rappresentare il computer fisico. Ciò è utile in quanto consente di eseguire la configurazione dei computer pre-installazione senza conoscere previamente il GUID o l'indirizzo MAC del computer client. Se il computer viene rifiutato, l'avvio di rete verrà interrotto, il computer verrà avviato in base alla voce successiva nell'ordine di avvio e non verrà creato alcun account computer.

Se non si abilita il criterio di aggiunta automatica, Servizi di distribuzione Windows non creerà un account computer per i client sconosciuti al primo avvio PXE. Un account verrà tuttavia creato durante l'installazione se il server è configurato per l'aggiunta dei client al dominio. Per configurare questa impostazione, fare clic con il pulsante destro del mouse sul server e quindi scegliere Proprietà. Nella scheda Client visualizzare la sezione Aggiunta a un dominio.

Per ulteriori informazioni, vedere la pagina relativa alla configurazione di computer client pre-installazione (http://go.microsoft.com/fwlink/?LinkId=131987).

Per configurare il criterio di aggiunta automatica

  1. Fare clic con il pulsante destro del mouse sul server e scegliere Proprietà.

  2. Nella scheda Risposta PXE fare clic su Rispondi a tutti i computer client (conosciuti e sconosciuti) e quindi selezionare Richiedi approvazione dell'amministratore per i computer sconosciuti.

  3. Per modificare l'istruzione visualizzata ai computer client quando sono in sospeso, eseguire WDSUTIL /Set-Server /AutoAddPolicy /Message:<message>.

  4. Configurare le impostazioni per i client sconosciuti. Per un elenco di procedure, vedere la sezione sulla configurazione di impostazioni per computer pre-installazione nella pagina relativa alla gestione dei computer client (http://go.microsoft.com/fwlink/?LinkID=115265).

  5. Quando un computer sconosciuto viene avviato nel server, il computer verrà visualizzato nel nodo Periferiche in sospeso dello snap-in MMC. Per un elenco delle azioni che è possibile eseguire in questa fase, vedere la sezione sull'approvazione e il rifiuto di computer nella pagina relativa alla gestione dei computer client (http://go.microsoft.com/fwlink/?LinkID=115265).

Ulteriori riferimenti

  • Gestire Servizi di distribuzione Windows


Installare un sistema operativo

Quando si dispone di almeno un'immagine di avvio e un'immagine di installazione nel server, è possibile distribuire un'immagine di installazione. Per eseguire l'avvio PXE di un computer per installare un'immagine, eseguire la procedura in questa sezione.

Per installare un sistema operativo

  1. Configurare il BIOS del computer per attivare l'avvio PXE e quindi impostare l'ordine di avvio in modo che l'avvio del computer parta dalla rete.

  2. Riavviare il computer e quando richiesto premere F12 per inizializzare un avvio di rete.

  3. Se viene visualizzata una schermata di selezione dell'immagine di avvio, selezionare l'immagine di avvio appropriata. La schermata è disponibile solo se il server di Servizi di distribuzione Windows contiene due o più immagini di avvio. Per ulteriori informazioni, vedere Aggiungere immagini di avvio e di installazione.

  4. Nella prima schermata dell'interfaccia utente del client Servizi di distribuzione Windows selezionare le impostazioni locali e il metodo di input e fare clic su Avanti.

  5. Quando richiesto, immettere un nome utente e una password con credenziali sufficienti per installare immagini dal server di Servizi di distribuzione Windows.

  6. Seguire le istruzioni visualizzate dall'interfaccia utente del client Servizi di distribuzione Windows.

  7. Al termine dell'installazione dell'immagine, il computer verrà riavviato e Installazione di Windows proseguirà.

Ulteriori riferimenti

  • Gestire Servizi di distribuzione Windows


Configurare un'installazione automatica

Servizi di distribuzione Windows consente di automatizzare le schermate dell'interfaccia utente del client Servizi di distribuzione Windows e le fasi successive dell'installazione di Windows. Per automatizzare uno di questi processi o entrambi, si utilizzano i due file di installazione automatica seguenti:

  • File di installazione automatica client Servizi di distribuzione Windows. Per automatizzare le schermate dell'interfaccia utente del client Servizi di distribuzione Windows (ad esempio l'immissione delle credenziali, la scelta di un'immagine di installazione e la configurazione del disco), creare un file Unattend.xml e salvarlo nella cartella \WDSClientUnattend nel server di Servizi di distribuzione Windows. Per istruzioni, vedere Configurare l'installazione automatica per il client Servizi di distribuzione Windows.

  • File di installazione automatica immagine. Per automatizzare le fasi restanti dell'installazione (ad esempio, l'installazione offline, Sysprep specialize e l'installazione minima), è necessario creare un file di installazione automatica immagine e associarlo a un'immagine. Nella maggior parte dei casi, è necessario creare un altro file Unattend.xml. Per le immagini di Windows precedenti a Microsoft Windows Vista, è necessario utilizzare i file Sysprep.inf esistenti e salvare il file nella struttura $OEM$ dell'immagine. Per istruzioni, vedere Configurare l'installazione automatica di Windows.

È consigliabile utilizzare Windows System Image Manager, incluso in Windows Automated Installation Kit, per creare i file Unattend.xml. Per ulteriori informazioni, vedere la pagina relativa all'esecuzione di un'installazione automatica (http://go.microsoft.com/fwlink/?LinkId=89226).

Configurare l'installazione automatica per il client Servizi di distribuzione Windows

È possibile utilizzare le procedure seguenti per associare un file di installazione automatica client per un'intera architettura o per un computer pre-installazione specifico. L'assegnazione del file per un'intera architettura consente di avere impostazioni diverse per i clienti basati su x86 e x64. L'assegnazione a livello di client ignora l'impostazione dell'architettura.

Per associare un file di installazione automatica client per architettura tramite l'interfaccia di Windows

  1. Creare un file Unattend.xml. Per informazioni, vedere la pagina relativa ai file di installazione automatica di esempio all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122642.

  2. Copiare il file di installazione automatica client in RemoteInstall\WDSClientUnattend.

  3. Aprire lo snap-in MMC Servizi di distribuzione Windows, fare clic con il pulsante destro del mouse sul server contenente l'immagine a cui si desidera associare il file di installazione automatica e quindi scegliere Proprietà.

  4. Nella scheda Client selezionare Abilita installazione automatica, selezionare il file di installazione automatica appropriato e quindi fare clic su Apri.

  5. Fare clic su OK per chiudere la pagina Proprietà.

Per associare un file di installazione automatica client per architettura tramite la riga di comando

  1. Creare un file Unattend.xml. File di installazione automatica di esempio sono disponibili all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122642.

  2. Copiare il file di installazione automatica del client in RemoteInstall\WDSClientUnattend.

  3. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  4. Digitare il comando seguente (il percorso del file deve essere relativo dalla cartella RemoteInstall):

    WDSUTIL /Set-Server /WDSUnattend /Policy:enabled /File:wdsclientunattend\Unattend.xml /Architecture:{x86|ia64|x64}
    Nota

    Per le informazioni della Guida su WDSUTIL, digitare WDSUTIL /? al prompt dei comandi.

Per associare un file di installazione automatica client per computer tramite la riga di comando

  1. Creare un file Unattend.xml. File di installazione automatica di esempio sono disponibili all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122642.

  2. Copiare il file di installazione automatica in RemoteInstall\WDSClientUnattend.

  3. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  4. Digitare il comando seguente. Il percorso del file deve essere relativo dalla cartella RemoteInstall.

    WDSUTIL /Set-Device /Device:<computername> /ID:<GUID or MAC address> /WDSClientUnattend:wdsclientunattend\Unattend.xml

Configurare l'installazione automatica di Windows

Le fasi rimanenti del programma di installazione vengono automatizzate con un file di installazione automatica immagine, Unattend.xml o Sysprep.inf, a seconda del sistema operativo dell'immagine.

  • Unattend.xml. Per la maggior parte delle immagini (Windows Vista con SP1, Windows Server 2008, Windows 7 e Windows Server 2008 R2) creare un file Unattend.xml mediante Windows System Image Manager, salvarlo in una posizione nota e quindi associarlo a un'immagine eseguendo la procedura seguente.

  • Sysprep.inf. Per le immagini di Windows precedenti a Microsoft Windows Vista creare il file Sysprep.inf mediante Gestione guidata installazione e quindi salvarlo nella struttura $OEM$ dell'immagine, ad esempio D:\RemoteInstall\Images\Windows XP\winxpsp2\$OEM$\$1\sysprep\sysprep.inf. Quando si distribuirà l'immagine, il file Sysprep.inf verrà automaticamente individuato e utilizzato dal programma di installazione.

Per associare un file Unattend.xml a un'immagine tramite l'interfaccia di Windows

  1. Creare un file Unattend.xml. Per informazioni, vedere la pagina relativa ai file di installazione automatica di esempio all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122642.

  2. Nello snap-in MMC Servizi di distribuzione Windows fare clic per espandere il gruppo di immagini contenente l'immagine.

  3. Fare clic con il pulsante destro del mouse sull'immagine a cui si desidera associare il file di installazione automatica e quindi scegliere Proprietà.

  4. Nella scheda Generale selezionare Consenti installazione immagine in modalità automatica.

  5. Fare clic su Seleziona file, selezionare il file di installazione automatica e fare due volte clic su OK.

Per associare un file Unattend.xml a un'immagine tramite riga di comando

  1. Creare un file Unattend.xml e salvarlo in un percorso noto. Per informazioni, vedere la pagina relativa ai file di installazione automatica di esempio all'indirizzo http://go.microsoft.com/fwlink/?LinkId=122642.

  2. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  3. Digitare il comando seguente, dove <imagename> è il nome dell'immagine a cui associare il file di installazione automatica, <imagegroupname> è il nome del gruppo di immagini contenente l'immagine e <unattendfile> è il percorso e il nome del file di installazione automatica:

    WDSUTIL /Set-Image /Image:<imagename> /ImageType:install /ImageGroup:<imagegroupname> /UnattendFile:<unattendfile>

Ulteriori riferimenti

  • Per le informazioni della Guida su WDSUTIL, digitare WDSUTIL /? al prompt dei comandi o scaricare il file WDSUTILCommands.chm all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89381.

  • Gestire immagini


Gestire immagini

I tipi di immagini utilizzati in Servizi di distribuzione Windows sono le immagini di installazione e le immagini di avvio.

  • Immagine di installazione. Immagine del sistema operativo distribuita nel computer client. È possibile utilizzare l'immagine di installazione predefinita (Install.wim) inclusa nella directory \Sources nel DVD di Windows 7 o Windows Server 2008 R2. È inoltre possibile modificare le immagini predefinite o crearne di personalizzate.

  • Immagine di avvio. Immagine di Ambiente preinstallazione di Windows (Windows PE) utilizzata per avviare un client prima di installare l'immagine di installazione. Nella maggior parte dei casi, è consigliabile utilizzare l'immagine di avvio predefinita (Boot.wim) inclusa nella directory \Sources del DVD di installazione di Windows Server 2008 R2. Tranne che negli scenari avanzati, non sarà necessario modificare questo file a meno che non si desideri aggiungere driver all'immagine. Per informazioni, vedere Aggiungere pacchetti driver a un'immagine di avvio. Per installare un sistema operativo, avviare innanzitutto il computer nell'immagine di avvio, quindi selezionare l'immagine di installazione da installare.

    È inoltre possibile creare altri due tipi di immagini di avvio:

    • Immagine di acquisizione. Tipo di immagine di avvio utilizzata per avviare un computer client per acquisire il sistema operativo come file wim. È innanzitutto necessario creare un'immagine di acquisizione per creare un'immagine di installazione personalizzata.

    • Immagine di individuazione. Tipo di immagine di avvio che consente di installare un sistema operativo in un computer non abilitato per Pre-Boot Execution Environment (PXE). Quando si avvia un computer in un'immagine di individuazione, il client Servizi di distribuzione Windows individuerà un server Servizi di distribuzione Windows valido e sarà quindi possibile scegliere l'immagine di installazione che si desidera installare.

    Per ulteriori informazioni, vedere la pagina sulla creazione di immagini (http://go.microsoft.com/fwlink/?LinkId=115311).

In questa sezione

  • Aggiungere immagini di avvio e di installazione

  • creare un'immagine di installazione personalizzata

  • Creare un'immagine di individuazione

  • Modificare le immagini di avvio e di installazione

  • Attivare la trasmissione multicast di un'immagine

  • Convertire immagini RIPREP

  • Distribuire immagini del disco rigido virtuale


Aggiungere immagini di avvio e di installazione

È necessario aggiungere almeno un'immagine di avvio e un'immagine di installazione al server per poter avviare un computer client e installare un sistema operativo.

  • Aggiungere un'immagine di installazione

  • Aggiungere un'immagine di avvio

Aggiungere un'immagine di installazione

Le immagini di installazione sono immagini del sistema operativo distribuite nei computer client. È possibile utilizzare l'immagine di installazione predefinita (Install.wim) inclusa nella directory \Sources nel DVD di Windows 7 o Windows Server 2008 R2. È inoltre possibile creare e modificare le immagini tramite gli strumenti di Windows Automated Installation Kit (Windows AIK) disponibili all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139642.

Per aggiungere un'immagine di installazione

  1. Espandere il server a cui si desidera aggiungere l'immagine di installazione.

  2. Fare clic con il pulsante destro del mouse sul nodo Immagini di installazione e quindi scegliere Aggiungi immagine di installazione.

  3. Specificare un nome per il gruppo di immagini e quindi fare clic su Avanti.

  4. Selezionare l'immagine di installazione e fare clic su Apri. È possibile utilizzare l'immagine di installazione predefinita (Install.wim) inclusa nella directory \Sources nel DVD di Windows 7 o Windows Server 2008 R2.

  5. Per aggiungere un sottoinsieme di immagini incluse nel file Install.wim, deselezionare le caselle di controllo relative alle immagini che non si desidera aggiungere al server. È consigliabile aggiungere solo le immagini per cui si dispone di una licenza.

  6. Seguire le istruzioni della procedura guidata per aggiungere le immagini.

Nota

È inoltre possibile eseguire questa procedura dalla riga di comando eseguendo il comando seguente: WDSUTIL /Add-Image /ImageFile:"C:\MyFolder\Install.wim" /ImageType:Install

Aggiungere un'immagine di avvio

Le immagini di avvio sono le immagini di Ambiente preinstallazione di Windows (Windows PE) in cui si avvia un client prima di installare un'immagine di installazione. Nella maggior parte dei casi, è consigliabile utilizzare l'immagine di avvio predefinita (Boot.wim) inclusa nella directory \Sources del supporto di installazione di Windows Server 2008 R2. Tranne che negli scenari avanzati, non sarà necessario modificare questo file se non per aggiungere pacchetti driver. Per informazioni, vedere Aggiungere pacchetti driver a un'immagine di avvio. Per installare un sistema operativo, avviare innanzitutto il computer nell'immagine di avvio, quindi selezionare l'immagine di installazione da installare.

Un menu di avvio viene visualizzato quando si esegue l'avvio PXE di un computer ed esistono più immagini di avvio supportate nel server di Servizi di distribuzione Windows. Mediante le immagini di avvio di Ambiente preinstallazione di Windows è possibile eseguire numerose attività. Esistono infatti immagini di avvio che:

  • Avviano il programma per l'installazione di Windows.

  • Riformattano i dischi rigidi per il supporto di Crittografia unità BitLocker (mediante il file di installazione automatica) e quindi installano Windows.

  • Contengono Ambiente ripristino Windows da utilizzare quando l'avvio di un computer ha esito negativo.

  • Contengono Acquisizione guidata immagini per Servizi di distribuzione Windows che consente di creare un'immagine di installazione dal sistema operativo del computer client.

  • Includono un'immagine di Ambiente preinstallazione di Windows per gli amministratori che desiderano eseguire altre operazioni all'interno di Ambiente preinstallazione di Windows.

Nei computer basati su x64 è inoltre possibile eseguire immagini di avvio di Ambiente preinstallazione di Windows basate su x86 o x64. Per ogni attività si dispone pertanto di due immagini di avvio: una per x86 e una per x64. Nel menu di avvio dei computer basati su x86 verranno visualizzate solo le immagini di avvio x86 perché tali computer non supportano l'esecuzione di immagini di avvio x64.

Per aggiungere l'immagine di avvio predefinita inclusa nel DVD di installazione del prodotto

  1. Espandere il server a cui si desidera aggiungere l'immagine di avvio.

  2. Fare clic con il pulsante destro del mouse sul nodo Immagini d'avvio e quindi scegliere Aggiungi immagine d'avvio.

  3. Individuare e selezionare l'immagine di avvio predefinita (Boot.wim) inclusa nella directory \Sources nel DVD di Windows Server 2008 R2.

  4. Fare clic su Apri e quindi su Avanti.

  5. Seguire le istruzioni della procedura guidata per aggiungere l'immagine.
Nota

È inoltre possibile eseguire questa procedura dalla riga di comando eseguendo il comando seguente: WDSUTIL /Add-Image /ImageFile:"C:\MyFolder\Boot.wim" /ImageType:Boot

Per apportare ulteriori modifiche al menu di avvio, utilizzare Bcdedit.exe per modificare il file Default.bcd in RemoteInstall\boot\<architettura>. Per ulteriori informazioni, vedere la pagina relativa alla modifica dell'archivio dei dati di configurazione mediante lo strumento BCDEdit (http://go.microsoft.com/fwlink/?LinkId=115267).

Ulteriori considerazioni

  • Per eseguire questa procedura è necessario essere membri del gruppo Administrators nel computer locale oppure disporre della delega per i diritti utente appropriati.

Ulteriori riferimenti

  • Gestire immagini


creare un'immagine di installazione personalizzata

È possibile creare immagini di installazione personalizzate tramite Servizi di distribuzione Windows. A tale scopo, seguire le istruzioni di questa sezione per creare un'immagine di acquisizione, preparare un computer di riferimento utilizzando Sysprep e quindi acquisire il sistema operativo tramite l'Acquisizione guidata immagine. Si noti che, poiché le immagini di installazione precedenti a Windows Vista sono specifiche dell'Hardware Abstraction Layer (HAL), non è possibile distribuire un'immagine con un determinato tipo di HAL in un computer con un tipo di HAL diverso. Poiché le immagini Windows Vista, tuttavia, non sono specifiche del livello HAL, è necessaria una sola immagine per ogni architettura. Per ulteriori informazioni, vedere la pagina sulla creazione di immagini (http://go.microsoft.com/fwlink/?LinkId=115311).

  • Creare un'immagine di acquisizione

  • Creare un'immagine di installazione personalizzata

Creare un'immagine di acquisizione

Per creare un'immagine di installazione, è innanzitutto necessario creare un'immagine di acquisizione. Le immagini di acquisizione sono immagini di avvio in cui si avvia un computer client per acquisire il sistema operativo in un file con estensione wim. È inoltre possibile creare un supporto (un CD, un DVD, un'unità USB o un altro tipo di supporto) contenente un'immagine di acquisizione e quindi avviare un computer dal supporto. Queste immagini costituiscono un'alternativa all'utilità da riga di comando ImageX.exe. Tranne che negli scenari avanzati, è consigliabile creare un'immagine di acquisizione utilizzando il file Boot.wim disponibile nel DVD di Windows Server 2008 R2. È inoltre possibile utilizzare il file WinPE.wim disponibile in Windows Automated Installation Kit (Windows AIK) per creare un'immagine di acquisizione, con una dimensione leggermente inferiore a quella del file Boot.wim.

Per creare un'immagine di acquisizione

  1. Nello snap-in MMC Servizi di distribuzione Windows espandere il nodo Immagini d'avvio.

  2. Fare clic con il pulsante destro del mouse sull'immagine da utilizzare come immagine di acquisizione. Nella maggior parte dei casi, è possibile utilizzare il file Boot.wim del DVD.

  3. Scegliere Crea immagine di acquisizione.

  4. Immettere un nome, una descrizione e un percorso in cui salvare una copia locale del file. È necessario specificare un percorso in caso di problemi con la rete quando si distribuisce l'immagine di acquisizione.

  5. Seguire le istruzioni visualizzate nella procedura guidata e al termine fare clic su Fine.

  6. Fare clic con il pulsante destro del mouse sul nodo Immagine d'avvio.

  7. Scegliere Aggiungi immagine d'avvio.

  8. Selezionare la nuova immagine di acquisizione e quindi fare clic su Avanti.

  9. Seguire le istruzioni visualizzate nella procedura guidata.

  10. Dopo avere creato l'immagine di acquisizione, seguire le istruzioni della sezione successiva per avviare un computer nell'immagine di acquisizione e acquisire il sistema operativo.

Creare un'immagine di installazione personalizzata

Dopo la creazione di un'immagine di acquisizione, è necessario preparare un computer di riferimento e quindi creare l'immagine di installazione. Il computer di riferimento può essere un computer con un'installazione di Windows standard o un'installazione di Windows configurata per l'ambiente in uso. È innanzitutto necessario avviare un computer preparato con Sysprep nell'immagine di acquisizione. Tramite una procedura guidata sarà quindi possibile creare un'immagine di installazione del computer di riferimento e salvarla in un file con estensione wim. Al termine dell'operazione, sarà possibile distribuire il file con estensione wim in un computer. Si noti che nell'Acquisizione guidata immagine verranno visualizzate solo le unità che contengono i sistemi operativi preparati con Sysprep. Se non si esegue Sysprep sul computer prima di eseguire l'avvio nell'immagine, non verrà visualizzata alcuna unità per l'acquisizione.

Per creare un'immagine di installazione personalizzata

  1. Creare un computer di riferimento (installare il sistema operativo e le applicazioni e apportare le modifiche desiderate).

  2. Verificare che nel computer sia installata la versione corretta di Sysprep.exe.

  3. Al prompt dei comandi sul computer di riferimento passare a \Windows\System32\Sysprep o alla cartella contenente Sysprep.exe e Setupcl.exe.

  4. Eseguire sysprep /oobe /generalize /reboot. Se si preferisce, è inoltre possibile utilizzare l'interfaccia utente grafica di Sysprep facendo doppio clic su Sysprep.exe.

    Nota

    Nei computer che eseguono Windows XP o Windows Server 2003 eseguire sysprep -mini –reseal -reboot.

  5. Quando il computer viene riavviato, eseguire un avvio di rete nel computer premendo F12.

  6. Scegliere l'immagine di acquisizione creata nella procedura precedente dal menu di avvio e quindi fare clic su Avanti.

  7. Seguire le istruzioni dell'Acquisizione guidata immagine per denominare, salvare e caricare l'immagine nel server di Servizi di distribuzione Windows.

Dopo avere aggiunto l'immagine al server, è possibile eseguire un avvio PXE di un computer client per installare questa immagine. Per istruzioni, vedere Installare un sistema operativo.

Ulteriori riferimenti

  • Gestire immagini


Creare un'immagine di individuazione

Se si dispone di un computer non abilitato per PXE, è possibile creare un'immagine di individuazione e utilizzarla per installare un sistema operativo in tale computer. Quando si crea un'immagine di individuazione e la si salva in un supporto, ad esempio un CD, un DVD, un'unità USB o un altro tipo di supporto, è possibile avviare un computer in tale supporto. Quando si avvia un computer nell'immagine di individuazione, viene individuato un server di Servizi di distribuzione Windows che distribuisce l'immagine di installazione al computer. È possibile configurare le immagini di individuazione in modo che si indirizzino verso un server di Servizi di distribuzione Windows specifico. Ciò significa che, se sono presenti più server nell'ambiente in uso, è possibile creare un'immagine di individuazione per ogni computer, assegnandole un nome in base al nome del server. Dopo avere creato l'immagine di individuazione, creare il supporto contenente l'immagine. Per ulteriori informazioni, vedere la pagina sulla creazione di immagini all'indirizzo http://go.microsoft.com/fwlink/?LinkId=115311.

Per creare un'immagine di individuazione

  1. Nello snap-in MMC Servizi di distribuzione Windows fare clic sul nodo Immagini d'avvio.

  2. Nel riquadro destro fare clic con il pulsante destro del mouse sull'immagine da utilizzare come immagine di individuazione.

  3. Scegliere Crea immagine di individuazione.

  4. Nella prima schermata della procedura guidata digitare C:\boot.wim in Location and file name.

  5. Fare clic su Avanti e al termine dell'operazione fare clic su Fine.

Nota

Questa procedura può inoltre essere eseguita al prompt dei comandi mediante WDSUTIL /New-DiscoverImage /Image:<name> /Architecture:{x86|x64|ia64} /DestinationImage /FilePath:<path and name to new file>. Per specificare a quale server è connessa l'immagine di individuazione, aggiungere /WDSServer:<server name or IP>.

Per creare un supporto che contiene l'immagine di individuazione

  1. Scaricare e installare Windows Automated Installation Kit (Windows AIK) (http://go.microsoft.com/fwlink/?LinkId=139642).

  2. Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft Windows AIK e quindi Prompt dei comandi strumenti di distribuzione.

  3. Per creare un ambiente di creazione di Ambiente preinstallazione di Windows (Windows PE), digitare:

    CopyPE <architecture> C:\Winpe

  4. Per copiare l'immagine di individuazione creata nell'ambiente, digitare:

    Copy /y c:\boot.wim c:\Winpe\ISO\Sources

  5. Per tornare alla cartella PETools, digitare:

    Cd C:\Program Files\Windows AIK\Tools\PETools

  6. Per creare l'immagine di avvio con estensione iso, digitare:

    Oscdimg -n -bc:\winpe\ISO\boot\etfsboot.com c:\winpe\ISO c:\<imagename>.iso

  7. Utilizzare un'utilità per la creazione di CD o DVD per trasferire l'immagine con estensione iso sul supporto.

    Nota

    Se si utilizza il comando copia di Windows per copiare l'immagine sul supporto, non verrà creato un disco di avvio.

  8. Avviare il computer client nel supporto. A tale scopo, potrebbe essere necessario modificare l'ordine di avvio nel BIOS del client. Quando il client viene avviato nel supporto, il funzionamento sarà del tutto analogo all'avvio in rete.

Ulteriori riferimenti

  • Gestire immagini


Modificare le immagini di avvio e di installazione

Per modificare le immagini è possibile utilizzare gli strumenti disponibili in Windows Automated Installation Kit. I processi sono simili per le immagini di avvio e di installazione, ma gli insiemi di strumenti e la sintassi variano a seconda del tipo di immagine. Se è necessario solo aggiungere i driver a un'immagine, è possibile utilizzare Servizi di distribuzione Windows. Per aggiungere i driver alle immagini di installazione, è possibile aggiungerli al server e quindi definire in quali computer client installarli. Per ulteriori informazioni, vedere la pagina relativa alla gestione di pacchetti driver (http://go.microsoft.com/fwlink/?LinkId=143313).

Modificare le immagini di avvio

È possibile modificare le immagini di avvio tramite gli strumenti ImageX e Gestione e manutenzione immagini distribuzione di Windows AIK. Per ulteriori informazioni, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143437. È inoltre possibile utilizzare Servizi di distribuzione Windows per aggiungere pacchetti driver alle immagini di avvio. Per istruzioni, vedere Aggiungere pacchetti driver a un'immagine di avvio.

È inoltre possibile apportare ulteriori modifiche al menu di avvio, utilizzando lo strumento Bcdedit.exe per modificare il file Default.bcd in RemoteInstall\boot\<architettura>. Per ulteriori informazioni, vedere la pagina relativa alla modifica dell'archivio dei dati di configurazione mediante lo strumento BCDEdit (http://go.microsoft.com/fwlink/?LinkId=115267).

Per modificare un'immagine di avvio

  1. Disabilitare l’immagine che si desidera modificare. Se si utilizza lo snap-in Servizi di distribuzione Windows, fare clic con il pulsante destro del mouse sull'immagine e quindi scegliere Disabilita. Questo consentirà alle installazioni esistenti di continuare, ma i nuovi client non saranno in grado di installare l'immagine.

  2. Esportare l'immagine.

  3. Modificare l'immagine mediante gli strumenti inclusi in Windows Automated Installation Kit.

  4. Aggiungere l'immagine al server di Servizi di distribuzione Windows. Per eseguire questa operazione sono disponibili due modi:

    • Sostituire l'immagine esistente con la versione appena modificata, presupponendo che tutte le installazioni che utilizzano l'immagine esistente siano state completate (procedura consigliata). A tale scopo, fare clic con il pulsante destro del mouse sull'immagine e quindi scegliere Sostituisci immagine.

    • Aggiungere l'immagine come nuova immagine e rimuovere l'immagine precedente in un secondo momento.

Modificare le immagini di installazione

È possibile modificare le immagini di installazione utilizzando gli strumenti disponibili in Windows AIK. Per ulteriori informazioni, vedere gli argomenti seguenti in Waik.chm (http://go.microsoft.com/fwlink/?LinkId=139641):

  • Fase 5: Eseguire le attività di gestione e manutenzione dell'immagine Windows

  • Documentazione tecnica su Gestione e manutenzione immagini distribuzione

  • Aggiungere e rimuovere driver offline

  • Aggiungere e rimuovere Language Pack offline

Per modificare un'immagine di installazione

  1. Disabilitare l’immagine che si desidera modificare. Nello snap-in MMC Servizi di distribuzione Windows, fare clic con il pulsante destro del mouse sull'immagine e quindi scegliere Disabilita. Questo consentirà alle installazioni esistenti di continuare, ma i nuovi client non saranno in grado di enumerare l’immagine.

  2. Esportare l'immagine.

  3. Modificare l'immagine mediante gli strumenti inclusi in Windows Automated Installation Kit.

  4. Aggiungere l'immagine al server. Per eseguire questa operazione sono disponibili due modi:

    • Sostituire l'immagine esistente con la versione aggiornata, purché tutte le installazioni che utilizzano l'immagine esistente siano state completate (procedura consigliata). A tale scopo, fare clic con il pulsante destro del mouse sull'immagine e quindi scegliere Sostituisci immagine.

    • Aggiungere l’immagine come nuova immagine. Sarà in seguito possibile rimuovere la vecchia immagine, che non verrà enumerata in quanto era stata disabilitata.

Ulteriori riferimenti

  • Gestire immagini


Attivare la trasmissione multicast di un'immagine

In questo argomento sono contenute informazioni sull'implementazione delle trasmissioni multicast. Se è installato solo il servizio ruolo Server di trasporto, vedere Server di trasporto per informazioni relative al multicast con Server di trasporto. Quando si crea la trasmissione multicast, il contenuto viene trasferiro tramite la rete solo se i client richiedono i dati. Se nessun client è connesso, ovvero se la trasmissione è inattiva, i dati non vengono inviati in rete.

In questo argomento

  • Creare una trasmissione multicast per un'immagine di installazione

  • Creare una trasmissione multicast per un'immagine di avvio

Creare una trasmissione multicast per un'immagine di installazione

  • Creare una trasmissione

  • Configurare trasmissioni di immagini di installazione

  • Configurare i client in una trasmissione

Creare una trasmissione

Per eseguire questa attività, utilizzare la procedura seguente.

Per abilitare il multicast di un'immagine di installazione

  1. Prima di creare una trasmissione, è consigliabile impostare i criteri di trasferimento per il server. A tale scopo, fare clic con il pulsante destro del mouse sul server, scegliere Proprietà, fare clic sulla scheda Multicast e selezionare un'opzione in Impostazioni trasferimento. Queste impostazioni consentono di attivare le funzionalità seguenti:

    • Trasferimento di più flussi. La prima opzione in Impostazioni trasferimento utilizza un unico flusso per tutti i client multicast, indipendentemente dalla velocità dei client. Le due opzioni successive consentono di separare i client più lenti nel flusso multicast, consentendo in tal modo ai client più veloci di completare la distribuzione più rapidamente invece di essere rallentati dai client più lenti. Queste impostazioni sono disponibili solo per i client avviati in un'immagine di avvio da Windows 7 o Windows Server 2008 R2.

    • Disconnessione automatica. L'ultima opzione in Impostazioni trasferimento consente di interrompere automaticamente i client che scendono al di sotto di una velocità specificata. I client disconnessi continueranno a trasferire l'immagine tramite unicasting (Server Message Block). Queste impostazioni sono disponibili solo per i client che vengono avviati in un'immagine di avvio da Windows Vista con Service Pack 1, Windows Server 2008, Windows 7 o Windows Server 2008 R2.

  2. Per creare una trasmissione multicast per un'immagine di installazione, fare clic con il pulsante destro del mouse sul nodo Trasmissioni multicast o su un'immagine di installazione e scegliere Creazione trasmissione multicast. Eseguire i passaggi della procedura guidata per selezionare l'immagine e configurare la trasmissione. Esistono due tipi di trasmissione multicast:

    • Multicast automatico. Questa opzione indica che, non appena un client richiede l'immagine, la trasmissione multicast dell'immagine selezionata ha inizio. In seguito, se altri client richiedono la stessa immagine, vengono aggiunti alla trasmissione già avviata.

    • Multicast pianificato. Questa opzione imposta i criteri di avvio della trasmissione in base al numero di client che richiedono un'immagine e/o a un giorno e un'ora specifici. Oltre a questi criteri, è possibile avviare una trasmissione manualmente in qualsiasi momento facendo clic con il pulsante destro del mouse sulla trasmissione e scegliendo Avvia. Se non si selezionano i criteri di avvio per la trasmissione, sarà necessario avviarla manualmente.

Configurare le trasmissioni di un'immagine di installazione

Dopo aver creato una trasmissione, è possibile eseguire le operazioni seguenti:

  • Avviare la trasmissione. Se una trasmissione multicast pianificata dispone di almeno un client e non è ancora stata avviata, è possibile fare clic con il pulsante destro del mouse sulla trasmissione e scegliere Avvia.

  • Eliminare la trasmissione. Se si fa clic con il pulsante destro del mouse sulla trasmissione e si sceglie Elimina, la trasmissione multicast viene interrotta e per ogni installazione client viene ripristinata la modalità unicast. Le installazioni client non vengono eliminate o interrotte, ma non utilizzano la trasmissione multicast per completare l'installazione.

  • Disattivare la trasmissione. Se si fa clic con il pulsante destro del mouse sulla trasmissione e si sceglie Disattiva, l'installazione corrente dei client continuerà, ma alla trasmissione non verranno aggiunti nuovi client. Al termine dell'ultima installazione client corrente, la trasmissione verrà eliminata. Se non sono disponibili client quando si fa clic su questa opzione, la trasmissione verrà eliminata immediatamente.

  • Visualizzare le proprietà. Per visualizzare le proprietà di una trasmissione, fare clic con il pulsante destro del mouse su di essa e quindi scegliere Proprietà. Si noti che non è possibile modificare le proprietà di una trasmissione dopo la sua creazione. Per apportare una modifica dopo la creazione della trasmissione, è necessario eliminare la trasmissione e ricrearla.

  • Aggiornare i dati e le trasmissioni. Per aggiornare i dati, fare clic con il pulsante destro del mouse su una trasmissione e quindi scegliere Aggiorna, oppure premere F5.

Configurare i client in una trasmissione

Dopo aver creato la trasmissione, i computer client vengono aggiunti alla trasmissione selezionando l’immagine nel client Servizi di distribuzione Windows. I computer client possono inoltre essere aggiunti a una trasmissione tramite Wdsmcast.exe, uno strumento da riga di comando incluso in Windows Automated Installation Kit (Windows AIK). Se ci sono client in una trasmissione, è possibile:

  • Visualizzare i client e lo stato. Per visualizzare informazioni sui client connessi a una trasmissione, espandere il nodo Trasmissioni multicast e fare clic sulla trasmissione. I client verranno visualizzati nel riquadro destro.

  • Interrompere un'installazione client. Per interrompere definitivamente l'installazione, fare clic con il pulsante destro del mouse su un client e scegliere Disconnetti. È consigliabile utilizzare questa opzione con cautela poiché l’installazione non verrà eseguita correttamente e il computer potrebbe essere reso inutilizzabile.

  • Disconnettere un client da una trasmissione multicast. Per sospendere la trasmissione per un determinato client continuando a trasferire l'immagine in modalità unicast, fare clic con il pulsante destro del mouse sul client e quindi scegliere Ignora multicast.

Creare una trasmissione multicast per un'immagine di avvio

È possibile abilitare le trasmissioni multicast per le immagini di avvio per i computer che utilizzano Extensible Firmware Interface (EFI) tramite WDSUTIL. Di seguito sono indicati i comandi utilizzabili per creare, avviare e rimuovere una trasmissione. Come per le immagini di installazione, è possibile creare trasmissioni multicast automatiche o pianificate. Per informazioni sulla sintassi di questi comandi, vedere la pagina relativa a Wdsutil (http://go.microsoft.com/fwlink/?LinkId=143438).

  • Creare una trasmissione multicast.

    • Per creare una trasmissione multicast automatica per un'immagine di avvio, eseguire:

      WDSUTIL /New-MulticastTransmission /FriendlyName:"WDS Boot Transmission" /Image:"X64 Boot Image" /ImageType:Boot /Architecture:x64 /TransmissionType:AutoCast

    • Per creare una trasmissione multicast pianificata per un'immagine di avvio, eseguire:

      WDSUTIL /New-MulticastTransmission /FriendlyName:"Boot SchedCast Transmission" /Server:MyWDSServer /Image:"X64 Boot Image" /ImageType:Boot /Architecture:x64 /TransmissionType:ScheduledCast /Time:"2006/11/20:17:00" /Clients:10

  • Avviare una trasmissione multicast pianificata. Per avviare una trasmissione multicast pianificata creata in precedenza, eseguire:

    WDSUTIL /Start-MulticastTransmission /Server:MyWDSServer /Image:"X64 Boot Image" /ImageType:Boot /Architecture:x64 /Filename:boot.wim

  • Rimuovere una trasmissione. Per rimuovere una trasmissione, consentendo tuttavia il completamento di tutti i trasferimenti correnti, eseguire:

    WDSUTIL /Remove-MulticastTransmission /Image:"X64 Boot Image” /ImageType:Boot /Architecture:x64

Ulteriori riferimenti

  • Gestire immagini


Convertire immagini RIPREP

Se il server è stato aggiornato da Windows Server 2003, le immagini RIPREP (Remote Installation Preparation) saranno archiviate nel nodo Immagini legacy nello snap-in MMC Servizi di distribuzione Windows. Le immagini RISETUP (Remote Installation Setup) non sono supportate in Servizi di distribuzione Windows. Prima di distribuire le immagini RIPREP nei computer client, è necessario convertirle nel formato immagine Windows (file con estensione wim).

Per convertire un'immagine RIPREP nel formato WIM tramite l'interfaccia di Windows

  1. Salvare una copia di backup delle immagini RIPREP in un percorso temporaneo (nell'eventualità che il processo abbia esito negativo o che si desideri ripristinare le immagini originali).

  2. Fare clic per espandere il nodo Immagini legacy.

  3. Fare clic con il pulsante destro del mouse sull'immagine da convertire e quindi scegliere Converti immagine.

  4. Seguire le istruzioni della procedura guidata.

  5. Dopo aver convertito l'immagine, aggiungerla al gruppo di immagini appropriato.
Per convertire un'immagine in formato WIM tramite riga di comando

  1. Salvare una copia di backup delle immagini RIPREP in un percorso temporaneo (nell'eventualità che il processo abbia esito negativo o che si desideri ripristinare le immagini originali).

  2. Per convertire l'immagine, digitare il comando seguente:

    WDSUTIL /convert-riprepimage /filepath:<path to RIPREP image .sif file> /destinationimage /filepath:<path and name of .wim image>

    Con questo comando è inoltre possibile utilizzare i parametri seguenti:

    • Per assegnare alla nuova immagine con estensione wim un nome nei metadati, utilizzare /Name:<name>.

    • Per assegnare alla nuova immagine con estensione wim una descrizione nei metadati, utilizzare /Description:<description>.

    • Per convertire l'immagine RIPREP originale, anziché una copia, utilizzare /InPlace.

    • Per determinare il comportamento quando il file di immagine specificato in /DestinationImage esiste già, utilizzare /Overwrite:{Yes|No|Append}. Con Yes il file con estensione wim verrà sovrascritto, con No verrà generato un errore e con Append la nuova immagine verrà aggiunta al file wim esistente.

  3. Per aggiungere il file al server, digitare il comando seguente, dove <filepath> è il percorso completo del nuovo file con estensione wim:

    WDSUTIL /add-image /imagefile:<filepath> /imagetype:install

Ulteriori riferimenti

  • Per ulteriori informazioni sulla coesistenza di Servizi di distribuzione Windows con Servizi di installazione remota, vedere la pagina relativa alla gestione di un ambiente complesso (http://go.microsoft.com/fwlink/?LinkId=89227).

  • Per ulteriori informazioni sull'aggiornamento del server da Servizi di installazione remota, vedere la guida dettagliata a Servizi di distribuzione Windows (http://go.microsoft.com/fwlink/?LinkId=84628).

  • Gestire immagini


Distribuire immagini del disco rigido virtuale

È possibile distribuire immagini del disco rigido virtuale (con estensione vhd) di Windows Server 2008 R2 in un computer fisico (non virtuale) tramite Servizi di distribuzione Windows. Le immagini con estensione vhd, in genere, vengono distribuite allo stesso modo delle immagini con estensione wim. L'utilizzo di WDSUTIL nella riga di comando, tuttavia, è il solo metodo supportato per l'aggiunta e la configurazione delle immagini. La distribuzione, inoltre, deve fare parte di un'installazione automatica.

Per distribuire immagini con estensione vhd, seguire la procedura descritta alla pagina http://go.microsoft.com/fwlink/?LinkId=146973. In questa guida è illustrata la configurazione dell'installazione. Viene innanzitutto creato un gruppo di immagini al quale si aggiungono le immagini, quindi si creano due file di installazione automatica e si configura il server. A questo punto sarà possibile distribuire un'immagine con estensione vhd. È inoltre possibile configurare le immagini da distribuire tramite il multicast.

Prerequisiti per la distribuzione di immagini del disco rigido virtuale

Per distribuire immagini con estensione vhd, è necessario quanto segue:

  • Un server di Servizi di distribuzione Windows configurato. Per informazioni sull'installazione e sulla configurazione del server, vedere la guida dettagliata a Servizi di distribuzione Windows (http://go.microsoft.com/fwlink/?LinkId=84628).

  • Familiarità con WDSUTIL. Il solo modo per importare e configurare queste immagini è utilizzare lo strumento da riga di comando WDSUTIL. Per informazioni sui comandi citati nel presente argomento, eseguire WDSUTIL /?. È inoltre possibile scaricare le informazioni di riferimento per la riga di comando WDSUTIL all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89381.

  • Un'immagine con estensione vhd supportata. I soli sistemi operativi supportati sono Windows Server 2008 R2, Windows 7 Enterprise e Windows 7 Ultimate. Sono supportate immagini con estensione vhd fisse, dinamiche e differenze. Si noti, tuttavia, che un'immagine supportata cannot contenere:

    • Più sistemi operativi.

    • Più partizioni.

    • Applicazioni o dati (invece di un sistema operativo).

    • Un sistema operativo a 64 bit partizionato con una tabella di partizione GUID (GPT).

Informazioni aggiuntive

Per ulteriori informazioni sulle immagini con estensione vhd, vedere gli argomenti seguenti:

  • Domande frequenti: dischi rigidi virtuali in Windows 7 (http://go.microsoft.com/fwlink/?LinkId=147081)

  • Novità relative ai rigidi virtuali (http://go.microsoft.com/fwlink/?LinkId=147082)

  • Distribuire immagini del disco rigido virtuale (http://go.microsoft.com/fwlink/?LinkId=146973)


Gestire pacchetti driver

È possibile utilizzare Servizi di distribuzione Windows per aggiungere pacchetti driver al server e configurarli in modo da distribuirli nei computer client insieme all'immagine di installazione. È inoltre possibile aggiungere pacchetti driver (ad esempio driver di scheda di rete, driver di archiviazione di massa e driver bus) alle immagini di avvio di Windows 7 e Windows Server 2008 R2. Questo significa che non è necessario esportare l'immagine, utilizzare gli strumenti di Windows Automated Installation Kit per aggiungere pacchetti driver manualmente e quindi aggiungere l'immagine di avvio aggiornata. Per istruzioni dettagliate, vedere la pagina relativa alla gestione di pacchetti driver (http://go.microsoft.com/fwlink/?LinkId=143313).

In questa sezione

  • Estrarre e aggiungere pacchetti driver

  • Distribuire pacchetti driver

  • Aggiungere pacchetti driver a un'immagine di avvio

  • Risolvere i problemi relativi ai pacchetti con esito negativo


Estrarre e aggiungere pacchetti driver

Per aggiungere pacchetti driver al server, è innanzitutto necessario ottenerli dal produttore ed estrarli. I pacchetti non possono infatti essere in formato EXE o MSI. Questa operazione è necessaria perché Servizi di distribuzione Windows necessita del file con estensione inf che descrive il pacchetto. Per un elenco di siti Web di driver per l'hardware del produttore, vedere la pagina contenente l'elenco dei driver per la gestione degli aggiornamenti (http://go.microsoft.com/fwlink/?LinkId=143440).

In questo argomento

  • Individuare il file con estensione inf

  • Estrarre i pacchetti driver

  • Aggiungere i pacchetti driver al server

Individuare il file con estensione inf

Quando si aggiungono i pacchetti, è possibile puntare a una cartella contenente i pacchetti driver estratti o al file con estensione inf che descrive il pacchetto. Il file con estensione inf, in cui è incluso un elenco dei file che costituiscono il pacchetto con i relativi percorsi, è disponibile nel programma di installazione del driver. Il file con estensione inf si trova in genere sul supporto di installazione driver nella stessa cartella del programma di installazione o in una sottocartella.

Estrarre i pacchetti driver

Se i pacchetti sono in formato EXE o MSI, è necessario estrarli per aggiungerli al server.

Pacchetti driver non Microsoft

Per i pacchetti non Microsoft è consigliabile contattare il produttore del pacchetto driver per informazioni sull'estrazione, poiché ogni produttore progetta i driver in formati diversi. Di seguito vengono tuttavia fornite alcune indicazioni generali per estrarre i pacchetti driver.

Importante

I prodotti non Microsoft illustrati nel presente documento sono prodotti da società indipendenti da Microsoft. Microsoft esclude ogni garanzia implicita o di altro tipo riguardo alle prestazioni o all'affidabilità di questi prodotti.

  • Utilizzare un programma di compressione file per estrarre i file. Se i file dei driver si trovano in un unico file eseguibile, è possibile utilizzare uno strumento di compressione file, ad esempio WinZip o WinRAR, per estrarre il contenuto del pacchetto driver in una cartella.

  • Utilizzare la funzionalità delle cartelle compresse di Windows per estrarre i file. Se non si dispone del programma WinZip o WinRAR, è possibile estrarre i file utilizzando la funzionalità delle cartelle compresse di Windows. A tale scopo, modificare l'estensione di file da exe a zip. Utilizzare quindi Esplora risorse per copiare i file dalla cartella compressa.

  • Estrarre il contenuto del file con estensione cab. Se nel pacchetto driver non esiste alcun file con estensione inf, ma è presente uno o più file con estensione cab, è possibile estrarre il contenuto dei file cab. Questo metodo, tuttavia, ha in genere esito negativo. Questi tipi di pacchetti driver vengono solitamente creati tramite il programma InstallShield, che utilizza uno speciale formato con estensione cab a cui non è possibile accedere con strumenti quali WinZip o WinRAR.

  • Individuare i file nella cartella temporanea. Alcuni programmi di installazione di pacchetti driver, ad esempio quelli per le schede video, utilizzano un programma di installazione con estensione exe che richiederà un percorso in cui estrarre temporaneamente i file. In questi casi, è possibile specificare un percorso e visualizzare la cartella mentre il programma di installazione è in esecuzione. Anche se nel computer non è disponibile hardware compatibile e il programma di installazione si interrompe, è possibile copiare i file dalla cartella temporanea.

Pacchetti driver Microsoft

Se il pacchetto è stato ottenuto da Windows Update, utilizzare la procedura seguente per estrarlo.

Per estrarre un pacchetto driver da Windows Update

  1. Scaricare i pacchetti driver da Microsoft Update Catalog (http://go.microsoft.com/fwlink/?LinkID=66676).

  2. Estrarre il contenuto di ogni file con estensione cab in una directory nel computer utilizzando uno dei metodi seguenti:

    • Expand.exe. Per ulteriori informazioni su questo strumento da riga di comando, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143439.

    • Esplora risorse. A tale scopo, fare clic con il pulsante destro del mouse sul pacchetto e quindi scegliere Apri. Copiare quindi i file in un'altra cartella.

  3. Aggiungere i pacchetti driver al server Servizi di distribuzione Windows. Per istruzioni sulla gestione e la distribuzione dei pacchetti, vedere Distribuire pacchetti driver.

Aggiungere pacchetti driver al server

Dopo avere ottenuto ed estratto i pacchetti driver, è necessario aggiungerli al server. A tale scopo, fare clic con il pulsante destro del mouse sul nodo Driver, scegliere Aggiungi pacchetto driver e seguire le istruzioni della procedura guidata. Per istruzioni dettagliate sull'aggiunta e la distribuzione di pacchetti driver, vedere Distribuire pacchetti driver.

Ulteriori riferimenti

  • Gestire pacchetti driver


Distribuire pacchetti driver

È possibile utilizzare Servizi di distribuzione Windows per aggiungere pacchetti driver al server e configurarli in modo da distribuirli nei computer client insieme all'immagine di installazione. Si noti che questa funzionalità è disponibile solo quando si installano immagini dei sistemi operativi seguenti: Windows Vista con SP1, Windows Server 2008, Windows 7 e Windows Server 2008 R2. In questa sezione sono contenute tutte le istruzioni dettagliate necessarie per la configurazione della funzionalità, ma è necessario disporre di un server configurato prima di iniziare. Per istruzioni sulla configurazione del server, vedere la guida dettagliata a Servizi di distribuzione Windows (http://go.microsoft.com/fwlink/?LinkId=84628).

  • Terminologia utilizzata in questa sezione

  • Scegliere uno scenario

  • Prerequisiti

Terminologia utilizzata in questa sezione

Termine | Definizione
Gruppo di driver | Un gruppo di driver è un insieme di pacchetti driver. È possibile aggiungere filtri a un gruppo di driver per rendere disponibili i pacchetti del gruppo a un gruppo selezionato di computer client. In alternativa, se in un gruppo di driver non sono presenti filtri, i pacchetti saranno disponibili per tutti i client con hardware corrispondente. È possibile definire se i client che hanno accesso al gruppo di driver installano 1) tutti i pacchetti del gruppo oppure 2) solo i pacchetti corrispondenti all'hardware connesso al client o installato in esso, ovvero l'hardware Plug and Play.
Filtri | I filtri consentono di eseguire il mapping dei pacchetti di un gruppo di driver a determinati computer client. I filtri definiscono quali client hanno accesso ai pacchetti. Esistono due tipi di filtri: filtri basati sull'hardware del client (ad esempio, il produttore o il fornitore del BIOS) e filtri basati sugli attributi dell'immagine di installazione selezionata nel client (ad esempio, la versione o l'edizione dell'immagine). Per un elenco dei filtri, vedere Filtri del gruppo di driver.
Hardware Plug and Play | La funzionalità Plug and Play consente la configurazione automatica dell'hardware e dei dispositivi per i sistemi operativi Windows.

Scegliere uno scenario

È possibile configurare i pacchetti driver da distribuire ai client in tre modi. Nella tabella seguente viene descritto ciascun metodo e viene indicato quando è consigliabile utilizzarlo.

Scenario Descrizione Utilizzo

Scenario 1: distribuire pacchetti driver in base all'hardware Plug and Play del client

In questo scenario si rendono disponibili tutti i pacchetti per tutti i client, ovvero non si aggiungono filtri ai gruppi di driver, e si configurano i gruppi in modo da installare solo i pacchetti corrispondenti all'hardware sul computer.

Si tratta dello scenario più semplice da configurare e si consiglia alla maggior parte delle società di provare innanzitutto questo scenario. Se, tuttavia, si riscontrano problemi perché in un computer vengono installati contemporaneamente pacchetti non compatibili, ad esempio se non è possibile avviare alcuni computer o parte dell'hardware non funziona correttamente, sarà necessario aggiungere filtri ai gruppi di driver come definito nello scenario 2.

Scenario 2: distribuire pacchetti driver utilizzando i filtri per definire quali client hanno accesso a ogni gruppo di driver

In questo scenario si organizzano i pacchetti in gruppi di driver e quindi si esegue il mapping di ogni gruppo ai computer tramite i filtri. I filtri definiscono quali computer hanno accesso al gruppo di driver in base all'hardware del computer e/o agli attributi dell'immagine di installazione selezionata. È tuttavia possibile configurare i pacchetti da installare in base all'hardware Plug and Play, ma è possibile utilizzare i filtri per definire ulteriormente quali client avranno accesso ai pacchetti.

È consigliabile prendere in considerazione questo scenario se:

  • Lo scenario 1 provoca problemi di funzionamento dell'hardware in un computer.

  • Si dispone di un ambiente complesso che include computer con svariate configurazioni hardware e software.

  • È necessario installare pacchetti driver specifici in determinati computer, ad esempio computer con lingue o versioni diverse di un'immagine di installazione.

Scenario 3: distribuire tutti i pacchetti driver di un gruppo di driver ai client

In questo scenario si distribuiscono tutti i pacchetti driver di un gruppo di driver a un computer client, non solo quelli che corrispondono all'hardware Plug and Play nel client. Dopo l'installazione, quando si connette l'hardware al client, il driver del dispositivo verrà installato automaticamente.

Utilizzare questa opzione se si dispone di hardware disconnesso dal computer, ad esempio una stampante, e si desidera imporre l'installazione di tutti i pacchetti di un gruppo di driver nel client. È in genere consigliabile utilizzare questo scenario in combinazione con lo scenario 1 o 2.

Prerequisiti

Di seguito sono elencati i prerequisiti per tutti e tre gli scenari:

  • Un server di Servizi di distribuzione Windows configurato con gli elementi seguenti:

    • Un'immagine di avvio di Windows 7 o Windows Server 2008 R2 (da \Sources\Boot.wim sul DVD).

    • Immagini di installazione per Windows Vista SP1, Windows Server 2008, Windows 7 o Windows Server 2008 R2.

  • Pacchetti driver per l'hardware che si desidera distribuire. Si noti che questi pacchetti devono essere estratti, ovvero il pacchetto non può essere un file con estensione msi o exe.


Scenario 1: distribuire pacchetti driver in base all'hardware Plug and Play del client

In questo scenario si rendono disponibili tutti i pacchetti per tutti i client, ovvero non si aggiungono filtri ai gruppi di driver, e si configurano i gruppi in modo da installare solo i pacchetti corrispondenti all'hardware sul computer.

Importante

È consigliabile testare completamente questo scenario prima di implementarlo nell'organizzazione.

Problemi noti

  • A seconda dei pacchetti driver installati nel server e dell'hardware del client, dopo l'esecuzione di questa procedura potrebbe risultare impossibile avviare il computer. In questo caso, sarà necessario individuare i pacchetti driver che causano del problema e rimuoverli dal server oppure limitarli applicando dei filtri come descritto in Scenario 2: distribuire pacchetti driver utilizzando i filtri per definire quali client hanno accesso a ogni gruppo di driver.

Per aggiungere i pacchetti e configurare il server

  1. Aprire lo snap-in di MMC Servizi di distribuzione Windows. A tale scopo, fare clic sul pulsante Start, scegliere Strumenti di amministrazione e fare clic su Servizi di distribuzione Windows.

  2. Espandere il nodo Server e il nodo relativo al server di Servizi di distribuzione Windows.

  3. Fare clic con il pulsante destro del mouse sul nodo Driver e scegliere Aggiungi pacchetto driver.

  4. Seguire le istruzioni della procedura guidata per aggiungere i pacchetti driver. Quando viene chiesto a quale gruppo di driver aggiungere i pacchetti, fare clic su Seleziona gruppo di driver esistente e verificare che DriverGroup1 sia selezionato. Per impostazione predefinita, questo gruppo di driver è configurato nel modo seguente: 1) non dispone di filtri e pertanto tutti i client avranno accesso ai pacchetti di questo gruppo e 2) verranno installati solo i pacchetti corrispondenti all'hardware del client. Per visualizzare queste impostazioni, fare clic con il pulsante destro del mouse su DriverGroup1 e scegliere Proprietà.

  5. Nell'ultima pagina della procedura guidata non selezionare la casella di controllo per modificare i filtri per il gruppo e fare clic su Fine.

  6. Ripetere i passaggi da 3 a 5 fino ad aggiungere tutti i pacchetti driver a DriverGroup1.

    Nota

    Qualora si preferisse organizzare i pacchetti in gruppi di driver diversi, è possibile creare gruppi di driver durante l'aggiunta dei pacchetti. Per questo scenario non è tuttavia consigliabile aggiungere filtri.

    Dopo avere configurato il server, tutti i computer in cui viene installata un'immagine supportata, ovvero Windows Vista con SP1, Windows Server 2008, Windows 7 o Windows Server 2008 R2, avranno accesso a questo gruppo di driver. Nei computer verranno tuttavia installati solo i pacchetti corrispondenti all'hardware Plug and Play. Sarà quindi possibile installare un'immagine come descritto nella procedura successiva.
Per installare i pacchetti driver e un'immagine di installazione

  1. Verificare che tutto l'hardware per cui si desidera installare i pacchetti sia connesso ai computer client.

  2. Avviare un computer client e installare un'immagine.

  3. Al termine dell'installazione, nel computer client aprire Gestione dispositivi dal Pannello di controllo e verificare che siano stati installati i driver dei dispositivi per tutto l'hardware connesso.

Ulteriori riferimenti

  • Distribuire pacchetti driver

  • Filtri del gruppo di driver

  • Attributi di driver e pacchetti


Scenario 2: distribuire pacchetti driver utilizzando i filtri per definire quali client hanno accesso a ogni gruppo di driver

Scenario 2: distribuire pacchetti driver utilizzando i filtri per definire quali client hanno accesso a ogni gruppo di driver

Questo scenario non è semplice come lo scenario 1, in quanto sarà necessario testare la configurazione finché i filtri non risulteranno configurati in modo appropriato per l'ambiente. Potrebbe essere necessario creare più gruppi di driver con combinazioni di filtri diverse prima di trovare una configurazione adatta. In generale, la complessità della configurazione è direttamente proporzionale a quella dell'ambiente.

Problemi noti

  • Il valore del filtro deve corrispondere esattamente all'hardware client o alle specifiche dell'immagine di installazione. Per i filtri sono disponibili i due operatori Uguale a e Diverso da. Se pertanto nel valore specificato manca un carattere, ad esempio se si omette un punto, i filtri non filtreranno i client come desiderato. Per questo motivo, è consigliabile creare più filtri per tutti i casi possibili. Ad esempio, creare filtri per Fabrikam, Inc., Fabrikam e così via.

  • Quando si effettua una ricerca nei pacchetti tramite lo snap-in MMC per eseguire un'attività, ad esempio per eliminare un pacchetto, la finestra di dialogo potrebbe non rispondere per breve tempo se sul server sono presenti centinaia di pacchetti. In questi casi, è consigliabile continuare ad attendere perché il server sta elaborando la richiesta. Per questo motivo è consigliabile non aggiungere più di 2000 pacchetti driver per volta a un gruppo, sebbene non esista un limite.

Procedura per la distribuzione di pacchetti driver tramite filtri

Il primo passaggio di questo scenario consiste nella creazione di gruppi di driver dotati di filtri. I filtri definiscono quali computer debbano avere accesso ai pacchetti driver in tale gruppo. È possibile configurare i pacchetti da installare in base all'hardware del client (ad esempio, il produttore o il fornitore del BIOS) e agli attributi dell'immagine Windows selezionata durante l'installazione (ad esempio, la versione o l'edizione). È ad esempio possibile specificare che i soli i computer client ad avere accesso a un gruppo sono quelli 1) prodotti da Fabrikam, Inc. e che 2) selezionano un'immagine di Windows 7 durante l'installazione. Dopo avere configurato i gruppi di driver, vi si aggiungeranno i pacchetti e quindi sarà possibile avviare un computer e installare un sistema operativo.

Per creare gruppi di driver con filtri

  1. Aprire lo snap-in MMC Servizi di distribuzione Windows.

  2. Espandere il nodo Server e il nodo relativo al server di Servizi di distribuzione Windows.

  3. Fare clic con il pulsante destro del mouse su DriverGroup1 e scegliere Disabilita. È necessario disabilitare DriverGroup1 perché, non avendo filtri per impostazione predefinita, distribuirebbe tutti i pacchetti ai tutti i client.

  4. Fare clic con il pulsante destro del mouse sul nodo Driver e scegliere Aggiungi gruppo driver.

  5. Digitare un nome per il gruppo, fare clic su Avanti e seguire le istruzioni per aggiungere i filtri nel modo appropriato per l'organizzazione. Per un elenco dei filtri, vedere Filtri del gruppo di driver.

  6. Nella schermata Pacchetti da installare selezionare Installa solo i pacchetti driver specifici per la configurazione hardware del client.

  7. Fare clic su Avanti e quindi su Fine.

  8. Ripetere i passaggi da 3 a 6 finché non sono stati creati e configurati tutti i gruppi di driver desiderati.

Ora che i gruppi di driver sono stati configurati, è possibile aggiungervi i pacchetti driver come descritto nella procedura successiva.

Per aggiungere pacchetti driver ai gruppi di driver

  1. Per i pacchetti non ancora aggiunti al server, fare clic con il pulsante destro del mouse sul nodo Driver, scegliere Aggiungi pacchetto driver e seguire le istruzioni per aggiungere i pacchetti a uno dei gruppi creati nella procedura precedente.

  2. Per i pacchetti già presenti sul server, ma non nel gruppo corretto, fare clic con il pulsante destro del mouse sul gruppo di driver desiderato e scegliere Aggiungi pacchetti driver al gruppo.

  3. Utilizzare gli attributi di ricerca per eseguire una ricerca nei pacchetti sul server e quindi fare clic su Aggiungi per aggiungerli al gruppo.

    Nota

    Per aggiungere un pacchetto specifico a un gruppo, è inoltre possibile fare clic con il pulsante destro del mouse sul pacchetto e scegliere Aggiungi o rimuovi dai gruppi. Nella finestra di dialogo configurare i pacchetti driver utilizzando le frecce e quindi fare clic su Applica.

  4. Ripetere i passaggi da 1 a 3 fino ad aggiungere tutti i pacchetti desiderati, quindi fare clic su Chiudi.

  5. Se è necessario rimuovere un pacchetto specifico da un gruppo, selezionare il gruppo e fare clic con il pulsante destro del mouse sul pacchetto driver specifico nel riquadro destro. Sarà quindi possibile fare clic su Aggiungi o rimuovi dai gruppi per visualizzare un elenco di gruppi a cui è possibile aggiungerlo o da cui rimuoverlo. È inoltre possibile fare clic su Rimuovi dal gruppo per rimuoverlo immediatamente. Per eliminare il pacchetto dal server, fare clic con il pulsante destro del mouse sul pacchetto e scegliere Elimina.

Ora che i gruppi di driver sono stati configurati e i pacchetti aggiunti, è possibile avviare un client come descritto nella procedura seguente.

Per installare i pacchetti driver e un'immagine di installazione

  1. Verificare che tutto l'hardware per cui si desidera installare i pacchetti driver sia connesso ai computer client.

  2. Avviare un computer e installare un'immagine.

  3. Al termine dell'installazione, nel computer client aprire Gestione dispositivi dal Pannello di controllo e verificare che siano stati installati i driver dei dispositivi appropriati.

  • Distribuire pacchetti driver

  • Filtri del gruppo di driver

  • Attributi di driver e pacchetti


Scenario 3: distribuire tutti i pacchetti driver di un gruppo di driver ai client

Scenario 3: distribuire tutti i pacchetti driver di un gruppo di driver ai client

È possibile configurare qualsiasi gruppo di driver per la distribuzione ai client applicabili di all i pacchetti contenuti e non solo di quelli per cui l'hardware è connesso al client. Per configurare in questo modo un gruppo di driver, utilizzare la procedura seguente.

Importante

A seconda dei pacchetti driver installati nel server e dell'hardware del client, dopo l'esecuzione di questa procedura potrebbe risultare impossibile avviare il computer. In questo caso, sarà necessario individuare i pacchetti driver che causano del problema e rimuoverli dal server oppure limitarli applicando dei filtri come descritto nello scenario 2.

Per installare tutti i pacchetti nei client applicabili

  1. Aprire lo snap-in MMC Servizi di distribuzione Windows.

  2. Fare clic con il pulsante destro del mouse sul gruppo di driver e scegliere Proprietà.

  3. In Applicabilità selezionare Tutti i pacchetti driver nel gruppo nel menu a discesa.

  4. Avviare un computer client e installare un'immagine.

  5. Al termine dell'installazione, connettere l'hardware Plug and Play al computer client e verificare che Windows trovi il driver del dispositivo appropriato.

Ulteriori riferimenti

  • Distribuire pacchetti driver

  • Filtri del gruppo di driver

  • Attributi di driver e pacchetti


Aggiungere pacchetti driver a un'immagine di avvio

In questo argomento sono contenute informazioni sull'aggiunta di pacchetti driver a un'immagine di avvio, oltre a collegamenti a informazioni sulla visualizzazione dei driver in un'immagine. Per ulteriori informazioni, vedere la pagina relativa alla gestione di pacchetti driver (http://go.microsoft.com/fwlink/?LinkId=143313).

Aggiungere pacchetti driver alle immagini di installazione

È possibile utilizzare Servizi di distribuzione Windows per aggiungere pacchetti driver, ad esempio driver di scheda di rete, driver di archiviazione di massa e driver bus, alle immagini di avvio di Windows 7 e Windows Server 2008 R2. Questo significa che non è necessario esportare l'immagine, utilizzare gli strumenti di Windows Automated Installation Kit per aggiungere pacchetti driver manualmente e quindi aggiungere l'immagine di avvio aggiornata. È possibile aggiungere i pacchetti tramite la riga di comando o lo snap-in di MMC.

Per aggiungere pacchetti driver a un'immagine di avvio tramite l'interfaccia di Windows

  1. Aggiungere il pacchetto driver al server. Per ulteriori informazioni, vedere Estrarre e aggiungere pacchetti driver.

  2. Nello snap-in di MMC Servizi di distribuzione Windows espandere il nodo Immagini d'avvio.

  3. Fare clic con il pulsante destro del mouse sull'immagine a cui si desidera aggiungere il driver e scegliere Aggiungi pacchetti driver a immagine.

  4. Seguire le istruzioni della procedura guidata per cercare il pacchetto e quindi aggiungerlo all'immagine.

Nota

Se, quando si esegue questa procedura, è in corso il download dell'immagine che si sta aggiornando in un client, Servizi di distribuzione Windows verificherà che il client riceva una copia coerente del file.

Per aggiungere pacchetti driver a un'immagine di avvio tramite riga di comando

  1. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Aggiungere l'immagine utilizzando la sintassi seguente: WDSUTIL /Add-ImageDriverPackage [/Server:<Nome server>] /Image:<Nome immagine> /ImageType:Boot /Architecture:{x86 | ia64 | x64} [/Filename:<Nome file>] {/DriverPackage:<Nome pacchetto> | /PackageId:<ID>}

    Ad esempio:

    WDSUTIL /Add-ImageDriverPackage /Image:"WinPE Boot Image" /ImageType:Boot /Architecture:x86 /DriverPackage:”My Driver Package”

    oppure

    WDSUTIL /verbose /Add-ImageDriverPackage /Image:"WinPE Boot Image" /Server:MyWDSServer /ImageType:Boot /Architecture:x64 /PackageId:{4D36E972-E325-11CE-BFC1-08002BE10318}

Visualizzare i driver in un'immagine di avvio

Dopo avere aggiunto i pacchetti driver all'immagine di avvio, è possibile utilizzare la procedura seguente per visualizzare i driver attualmente presenti nell'immagine. Per ulteriori informazioni sulla modifica di un'immagine di avvio, vedere Modificare le immagini di avvio e di installazione.

Per visualizzare i pacchetti in un'immagine di avvio

  1. Esportare l'immagine. A tale scopo, fare clic con il pulsante destro del mouse sull'immagine, scegliere Esporta immagine, assegnare un nome al file e fare clic su Salva.

  2. Fare clic sul pulsante Start, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  3. Montare la seconda immagine dell'immagine di avvio in una directory locale con la sintassi seguente:

    Dism /Mount-Wim /WimFile:<percorso_del file_WIM> /index:<numero_indice_immagine> /MountDir:<percorso_directory_di_montaggio>

    Esempio: Dism /Mount-Wim /WimFile:C:\test\images\boot.wim /index:2 /MountDir:C:\test\offline

  4. Eseguire il comando dism /Get-Drivers per visualizzare tutti i pacchetti driver dell'immagine corrente. Ad esempio:

    dism /image:c:\test\offline /Get-Drivers

  5. Smontare l'immagine ed eseguire il commit delle modifiche. Ad esempio:

    DISM /Unmount-Wim /MountDir:C:\test\offline /commit

  6. Aggiungere l'immagine al server di Servizi di distribuzione Windows. Per eseguire questa operazione sono disponibili due modi:

    • Sostituire l'immagine esistente, purché tutte le installazioni che la utilizzano siano state completate (procedura consigliata). A tale scopo, fare clic con il pulsante destro del mouse sull'immagine e quindi scegliere Sostituisci immagine.

    • Aggiungere l'immagine come nuova immagine e rimuovere l'immagine precedente in un secondo momento.

Per ulteriori informazioni su Gestione e manutenzione immagini distribuzione (DISM.exe), vedere http://go.microsoft.com/fwlink/?LinkId=143441.

Ulteriori riferimenti

  • Gestire pacchetti driver


Risolvere i problemi relativi ai pacchetti con esito negativo

In questo argomento sono contenute informazioni sulle cause comuni degli errori che si verificano quando si tenta di aggiungere pacchetti driver a un server o a un'immagine di avvio.

Errori durante l'aggiunta di pacchetti a un server

Di seguito sono elencate le cause più comuni dell'esito negativo dell'aggiunta di pacchetti:

  • Pacchetto danneggiato o con file mancanti.

  • Problema di connettività di rete.

  • Pacchetto driver basato su x64 non firmato (i pacchetti driver basati su x64 devono essere firmati).

  • File con estensione inf non creato correttamente.

Se si stanno aggiungendo pacchetti driver tramite lo snap-in MMC, per visualizzare i dettagli sul pacchetto fare doppio clic su di esso nell'elenco dei pacchetti con esito negativo. Se si stanno aggiungendo pacchetti driver tramite WDSUTIL /Add-AllDriverPackages e non è possibile aggiungere uno o più pacchetti, nella console verrà visualizzato un elenco dei pacchetti con esito negativo. Per visualizzare un messaggio di errore più dettagliato per uno dei pacchetti, provare ad aggiungerlo singolarmente tramite WDSUTIL (ad esempio, WDSUTIL /verbose /Add-DriverPackage /InfFile:"C:\Temp\Display.inf").

Se non è possibile risolvere il problema, contattare il produttore del pacchetto per ottenerne uno nuovo e provare a eseguire nuovamente l'operazione.

Errori durante l'aggiunta di pacchetti a un'immagine di avvio

Di seguito sono elencate le cause più comuni dell'esito negativo dell'aggiunta di pacchetti:

  • Aggiunta di un pacchetto non corrispondente all'architettura dell'immagine.

  • Aggiunta di un pacchetto driver a un'immagine non supportata, ad esempio un'immagine di installazione.

  • Aggiunta di un pacchetto a un'immagine di avvio meno recente. È possibile aggiungere pacchetti solo a immagini di avvio basate su Windows 7 e Windows Server 2008 R2.

Ulteriori riferimenti

  • Gestire pacchetti driver


Risorse per Servizi di distribuzione Windows

La presente documentazione è un sottoinsieme della documentazione disponibile online all'indirizzo http://go.microsoft.com/fwlink/?LinkId=134776. È inoltre possibile scaricare la documentazione relativa a Servizi di distribuzione Windows (tra cui una guida dettagliata, una guida alla distribuzione e alla gestione, documentazione tecnica e informazioni di riferimento per la riga di comando WDSUTIL) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89381. Vedere inoltre le risorse online seguenti:

  • Guida dettagliata a Servizi di distribuzione Windows (http://go.microsoft.com/fwlink/?LinkId=84628)

  • Forum sulla distribuzione dell'installazione (http://go.microsoft.com/fwlink/?LinkId=87628)

  • Windows Automated Installation Kit (Windows AIK) (http://go.microsoft.com/fwlink/?LinkId=139642)

  • Documentazione relativa a Windows AIK (http://go.microsoft.com/fwlink/?LinkId=139641)


Interfaccia utente: Servizi di distribuzione Windows

In questa sezione sono contenute informazioni su alcune schermate dell'interfaccia utente di Servizi di distribuzione Windows.

  • Scheda Risposta PXE

  • Scheda Multicast

  • Scheda DHCP

  • Scheda Servizi di dominio Active Directory

  • Filtri del gruppo di driver

  • Attributi di driver e pacchetti


Scheda Risposta PXE

Le impostazioni disponibili nella scheda Risposta PXE determinano i client a cui Servizi di distribuzione Windows risponde, l'azione che viene eseguita in caso di risposta a un client sconosciuto e il tempo di attesa che deve trascorrere prima di rispondere a un client. Per visualizzare questa scheda, fare clic con il pulsante destro del mouse sul server nello snap-in MMC e quindi scegliere Proprietà.

Opzione Spiegazione

Criterio di risposta PXE

Le opzioni seguenti specificano la modalità di risposta del server di Servizi di distribuzione Windows alle richieste PXE (Pre-Boot Execution Environment) in arrivo dai computer client. Per ulteriori informazioni online, vedere la pagina relativa alla configurazione di computer client pre-installazione (http://go.microsoft.com/fwlink/?LinkId=131987).

  • Non rispondere ad alcun computer client. Questa opzione funzionerà solo se Servizi di distribuzione Windows e DHCP sono in esecuzione su server diversi, perché, anche se Servizi di distribuzione Windows non risponderà, DHCP lo farà. È possibile provare a risolvere questo problema disabilitando l'opzione DHCP 60 nella Scheda DHCP.

  • Rispondi solo a computer client conosciuti. Scegliere questa opzione se si dispone di client pre-installazione in Servizi di dominio Active Directory. Quando si seleziona questa opzione, i client non pre-installazione (sconosciuti) non saranno in grado di eseguire l'avvio PXE nel server di Servizi di distribuzione Windows.

  • Rispondi a tutti i computer client (conosciuti e sconosciuti). Scegliere questa opzione per consentire a tutti i client di eseguire l'avvio PXE nel server di Servizi di distribuzione Windows. La casella di controllo Richiedi approvazione dell'amministratore per i computer sconosciuti corrisponde al criterio di aggiunta automatica. Scegliere questa opzione se si desidera approvare nuovi client tramite il nodo Periferiche in sospeso nello snap-in MMC prima di consentire l'avvio PXE. Per ulteriori informazioni su questa opzione, vedere Configurare il criterio di aggiunta automatica.

Ritardo risposta PXE (in secondi)

Utilizzare questa impostazione per impostare la rapidità con cui il server risponde ai client in rete. Consente di impostare la quantità di tempo che il server PXE deve attendere prima di ricevere risposte da altri server PXE. Questa impostazione deve rimanere su zero (impostazione predefinita) a meno che non ci siano altri risponditori PXE in rete che hanno la precedenza o che la rete richieda un maggiore ritardo di risposta PXE.

Ulteriori riferimenti

  • Interfaccia utente: Servizi di distribuzione Windows

  • Computer client pre-installazione

  • Configurare il criterio di aggiunta automatica


Scheda Multicast

Nella scheda Multicast è possibile configurare l'indirizzo IP multicast e le impostazioni per il trasferimento di ogni trasmissione multicast. Per visualizzare questa scheda, fare clic con il pulsante destro del mouse sul server nello snap-in di MMC e quindi scegliere Proprietà. Per ulteriori informazioni sul multicast, vedere Attivare la trasmissione multicast di un'immagine.

Importante

Dopo aver configurato il server di Servizi di distribuzione Windows, se si modifica una di queste opzioni o il numero di porta RPC (eseguendo wdsutil /set-server /rpcport:<portnum>), sarà necessario riavviare Servizi di distribuzione Windows affinché le modifiche abbiano effetto. In caso contrario, il server utilizzerà i vecchi valori e potrebbe non rispondere ai client. Per riavviare il servizio, fare clic con il pulsante destro del mouse su Servizi di distribuzione Windows nello snap-in di MMC e scegliere Riavvia.

Opzione Spiegazione

Indirizzo IP multicast

Questa impostazione è applicabile solo se si stanno attivando trasmissioni multicast. È possibile scegliere una delle opzioni seguenti:

  • Ottieni indirizzo IP da DHCP. È possibile selezionare questa opzione solo se il server DHCP in uso la supporta. Se la si seleziona, l'indirizzo IP verrà ottenuto utilizzando Multicast Address Dynamic Client Allocation Protocol (MADCAP) (RFC 2730) per ogni spazio dei nomi. Per ulteriori informazioni, visitare la pagina relativa a Multicast Address Dynamic Client Allocation Protocol (http://go.microsoft.com/fwlink/?LinkId=81507). È possibile selezionare questa impostazione per facilitare la gestione, ad esempio quando si dispone di più server di Servizi di distribuzione Windows per gli stessi client.

    La selezione di questa impostazione equivale all'esecuzione di:

    WDSUTIL /Set-Server [/Server:<name>] /Transport /ObtainIPv4From:DHCP

  • Utilizza un indirizzo IP dell'intervallo seguente. Questa opzione specifica l'intervallo di indirizzi IP per l'utilizzo da parte del server di Servizi di distribuzione Windows. Quando si imposta questo intervallo, verificare che non si sovrapponga agli intervalli definiti per gli altri server. L'impostazione di questa opzione equivale all'esecuzione di:

    WDSUTIL /Set-Server [/Server:<name>] /Transport /ObtainIPv4From:Range /Start:x.x.x.x /End:y.y.y.y

Impostazioni di trasferimento

Queste impostazioni sono disponibili solo per i client avviati in un'immagine di avvio da Windows 7 o Windows Server 2008 R2. Consentono di attivare le funzionalità seguenti:

  • Trasferimento di un unico flusso. La prima impostazione utilizza un unico flusso multicast per tutti i client, indipendentemente dalla velocità dei client.

  • Trasferimento di più flussi. Le due impostazioni successive consentono di separare i client più lenti nel flusso multicast. Ciò consente ai client più veloci di completare le distribuzioni più rapidamente invece di essere rallentati dai client più lenti.

  • Disconnessione automatica. L'ultima opzione consente di interrompere automaticamente i client che scendono al di sotto di una velocità specificata. I client disconnessi continueranno a trasferire l'immagine tramite unicasting.

Ulteriori riferimenti

  • Interfaccia utente: Servizi di distribuzione Windows

  • Attivare la trasmissione multicast di un'immagine


Scheda DHCP

Il client di cui è in corso l'avvio e il server comunicano tramite pacchetti DHCP (Dynamic Host Control Protocol). Le impostazioni della scheda DHCP consentono di configurare le impostazioni DHCP del server. Per visualizzare questa scheda, fare clic con il pulsante destro del mouse sul server nello snap-in MMC e quindi scegliere Proprietà. Per ulteriori informazioni, vedere la pagina relativa alla configurazione DHCP (http://go.microsoft.com/fwlink/?LinkId=131988.

In questa scheda sono disponibili le impostazioni seguenti:

  • Non eseguire l'ascolto sulla porta 67. Selezionare questa casella di controllo se DHCP è in esecuzione sullo stesso server di Servizi di distribuzione Windows, ovvero questo server.

  • Configura opzione DHCP 60 per indicare che il server è anche un server PXE. Riguardo questa opzione si noti quanto segue:

    • Quando si seleziona questa opzione, ai client avviati dalla rete viene sempre notificato che il server PXE è disponibile, anche se il server non è funzionante o è stato arrestato.

    • Esistono alcuni scenari, in particolare quelli che richiedono l'esecuzione di un server DHCP, che non supportano l'aggiunta dell'opzione DHCP personalizzata 60 sullo stesso computer fisico del server di Servizi di distribuzione Windows. In questi casi, è possibile configurare il server per il binding alla porta UDP (User Datagram Protocol) 67 in modalità non esclusiva passando l'opzione SO_REUSEADDR. Per ulteriori informazioni, vedere la pagina relativa all'utilizzo di SO_REUSEADDR e di SO_EXCLUSIVEADDRUSE (http://go.microsoft.com/fwlink/?LinkId=82387).

Se DHCP è installato in un server che si trova in una subnet diversa, sarà necessario eseguire una delle operazioni seguenti: configurare le tabelle di helper IP (consigliato) o aggiungere le opzioni DHCP 66 e 67. Per ulteriori informazioni su queste impostazioni, vedere la pagina relativa alla gestione di programmi di avvio di rete (http://go.microsoft.com/fwlink/?LinkId=115304).

Ulteriori riferimenti

  • Interfaccia utente: Servizi di distribuzione Windows


Scheda Servizi di dominio Active Directory

È possibile utilizzare la scheda Servizi di dominio Active Directory per specificare il criterio di denominazione dei computer e il percorso in cui creare l'account computer. Le impostazioni di questa scheda verranno applicate quando sarà necessaria un'approvazione amministrativa per i computer sconosciuti, che è un'impostazione della Scheda Risposta PXE. Queste impostazioni pertanto non si applicano agli account computer pre-installazione configurati in Servizi di dominio Active Directory. Per visualizzare questa scheda, fare clic con il pulsante destro del mouse sul server nello snap-in MMC e quindi scegliere Proprietà. Per ulteriori informazioni online, vedere la pagina relativa alla configurazione dell'integrazione in Servizi di dominio Active Directory (http://go.microsoft.com/fwlink/?LinkId=143071).

Criterio di denominazione dei computer

Nella tabella seguente vengono illustrate le variabili che è possibile specificare per creare un nome personalizzato. Queste opzioni possono essere utilizzate separatamente o congiuntamente.

Variabile | Risultato
%First | Nome dell'utente. È possibile limitare la lunghezza del nome aggiungendo un valore numerico tra % e First. %5First, ad esempio, limiterà il nome a cinque caratteri.
%Last | Cognome dell'utente. È possibile limitare la lunghezza del cognome aggiungendo un valore numerico tra % e Last. %5Last, ad esempio, limiterà il cognome a cinque caratteri.
%Username | Nome utente. È possibile limitare la lunghezza del nome utente aggiungendo un valore numerico tra % e Username. %5Username, ad esempio, limiterà il nome utente a cinque caratteri.
%MAC | Indirizzo MAC (Media Access Control) per la scheda di rete.
%[0][n]# | Il nome del computer include un numero incrementale di n cifre. Per includere il riempimento con zeri nel numero incrementale, digitare uno zero come illustrato. Se si utilizza ad esempio %03#, verrà utilizzato un numero di tre cifre nell'intervallo compreso tra 001 e 999.

Esempi

  • Se si desidera limitare il nome del computer a tre caratteri del cognome dell'utente a cui viene aggiunto un numero incrementale di due cifre, digitare la stringa %3Last%02#. Il nome del computer per il quinto utente, il cui cognome è Smith, sarà Smi05.

  • Se si desidera che il nome del computer sia formato dalle prime tre lettere del nome seguite dalle prime tre lettere del cognome dell'utente a cui viene aggiunto un numero incrementale di tre cifre, digitare la stringa %3First%3Last%03#.

Si notino i seguenti problemi quando si imposta il criterio di denominazione dei client:

  • La lunghezza massima per il nome di un computer è di 15 caratteri. Il criterio predefinito consente tuttavia nomi di massimo 63 caratteri. Se viene generato un nome di lunghezza superiore a 15 caratteri, i caratteri che seguono i primi 15 verranno troncati e il computer non potrà essere aggiunto al dominio. È necessario specificare un criterio di denominazione che generi nomi di 15 o meno caratteri.

  • Il nome computer può contenere solo caratteri standard definiti nella specifica RFC 1123, relativa all'applicazione e al supporto dei requisiti per gli host Internet, nel modo seguente: lettere maiuscole (A-Z), lettere minuscole (a-z), numeri (0-9) e un trattino (-).

Percorso dell'account computer

In questa sezione è possibile specificare il percorso in cui si desidera creare tramite Servizi di distribuzione Windows gli account per i computer con un'approvazione amministrativa in sospeso. Se si desidera che nessun computer appartenga a un dominio dopo l'installazione, è possibile specificarlo nella scheda Client.

Ulteriori riferimenti

  • Interfaccia utente: Servizi di distribuzione Windows


Filtri del gruppo di driver

È possibile utilizzare i filtri per eseguire il mapping dei computer client ai pacchetti in un gruppo di driver. I filtri definiscono quali client installeranno i driver. È possibile, ad esempio, configurare i driver da installare in base all'hardware del client (ad esempio, produttore o fornitore del BIOS) e agli attributi dell'immagine Windows selezionata durante l'installazione (ad esempio, la versione o l'edizione). È inoltre possibile configurare i client in modo che installino o meno tutti i pacchetti in un gruppo di driver oppure solo i driver corrispondenti all'hardware installato nel client. Per istruzioni su come configurare questi filtri per la distribuzione dei pacchetti driver, vedere Distribuire pacchetti driver.

Nota

Un pacchetto può trovarsi in più gruppi di driver, ma deve trovarsi in almeno un gruppo per essere disponibile per i client.

Per creare un gruppo di driver, fare clic con il pulsante destro del mouse sul nodo Driver e scegliere Aggiungi gruppo driver. Per modificare i filtri per un gruppo di driver, fare clic con il pulsante destro del mouse sul gruppo e scegliere Modifica filtri per il gruppo.

Quando si aggiungono i filtri a un gruppo di driver, prendere nota della funzionalità seguente:

  • Il valore del filtro deve corrispondere esattamente all'hardware client o alle specifiche dell'immagine di installazione. Per i filtri sono disponibili i due operatori Uguale a e Diverso da. Se pertanto nel valore specificato manca un carattere, ad esempio se si omette un punto, i filtri non corrisponderanno ai client come desiderato. Per questo motivo, è consigliabile creare un valore di filtro per tutti i casi possibili. Ad esempio, creare valori di filtro per Fabrikam, Inc., Fabrikam e così via. Si noti che per il filtro non è rilevante la distinzione tra maiuscole e minuscole e gli spazi iniziali o finali vengono ignorati.

  • Se non si aggiunge alcun filtro, tutti i client avranno accesso ai driver del gruppo. Se si aggiungono uno o più filtri, i client devono soddisfare tutti i criteri dei filtri per accedere ai driver. Inoltre:

    • Se l'operatore di un filtro è impostato su Uguale a, il criterio del filtro verrà soddisfatto se il valore del client è uguale a uno o più valori dell'elenco.

      Esempio: Se si aggiunge Tipo chassis|Uguale a|Mini-tower, laptop, tutti i computer Mini-tower e laptop soddisferanno il criterio del filtro mentre i computer con altri tipi di chassis non soddisferanno tale criterio.

    • Se l'operatore di un filtro è impostato su Diverso da, il criterio del filtro verrà soddisfatto solo se il valore del client non è uguale ad alcuno dei valori dell'elenco. ovvero corrisponderanno solo i client con un valore diverso da tutti i valori del filtro.

      Esempio: Se si aggiunge UUID|Diverso da|<UUID 1>, <UUID 2>, tutti i client soddisferanno il criterio del filtro ad eccezione dei due computer specificati.

Per ulteriori esempi, vedere Esempi.

In questo argomento

  • Filtri per hardware client

  • Filtri per le immagini di installazione

  • Esempi

Filtri per hardware client

È possibile aggiungere filtri per hardware client a un gruppo di driver se si desidera che i client con un determinato hardware ricevano i driver di un gruppo. Si noti che i driver vengono filtrati automaticamente dall'architettura del client.

Tipo di filtro | Valori accettati | Descrizione ed esempi
Produttore | Stringa | Nome del produttore elencato nel BIOS. È possibile trovare queste informazioni nel computer client tramite lo strumento System Information (Msinfo32.exe). Per aprire questo strumento, fare clic su Start, scegliere Esegui, digitare msinfo32.exe e quindi fare clic su OK. Questo valore è elencato come Produttore sistema.
Fornitore BIOS | Stringa | Nome del fornitore del BIOS elencato nel BIOS. Per ottenere queste informazioni su un computer client, eseguire wmic bios get manufacturer al prompt dei comandi. La prima riga dell'output indica il nome dell'attributo. Utilizzare la seconda riga dell'output per il valore Fornitore Bios.
Versione BIOS | Stringa | Versione del BIOS definita dal produttore. Per ottenere queste informazioni su un computer client, eseguire wmic bios get smbiosbiosversion al prompt dei comandi. La prima riga dell'output indica il nome dell'attributo. Utilizzare la seconda riga dell'output per il valore Versione Bios.
Tipo chassis | Stringa | Contenitore fisico dei componenti di un computer. In genere il solo modo per identificare il tipo di chassis è quello di esaminarlo. È tuttavia possibile scrivere uno script tramite la classe Strumentazione gestione Windows (WMI) per determinare il tipo di chassis di un computer. Per ulteriori informazioni, vedere http://go.microsoft.com/fwlink/?LinkId=143449.
UUID | GUID con parentesi nel formato: {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} | GUID del computer elencato nel BIOS e visualizzato quando si esegue l'avvio PXE di un computer. È inoltre possibile scrivere uno script WMI per ottenere queste informazioni tramite il valore UUID (Universally Unique Identifier) della classe Win32_ComputerSystemProduct. Per ulteriori informazioni, vedere http://go.microsoft.com/fwlink/?LinkId=143450. Ad esempio: {E8A3EFAC-201F-4E69-953E-B2DAA1E8B1B6}.

Filtri per le immagini di installazione

È possibile aggiungere filtri per le immagini di installazione se si desidera che i client che selezionano immagini specifiche abbiano accesso a un gruppo di driver. I tipi di filtro seguenti derivano dai metadati del file di immagine con estensione wim.

Tipo di filtro Valori accettati Descrizione ed esempi

Versione sistema operativo

Numero

Versione del sistema operativo dell'immagine di installazione scelta dall'utente nel formato: VersionePrincipale.VersioneSecondaria.NumeroBuild.NumeroServicePack. Per Windows Vista con Service Pack 1 (SP1) e la versione iniziale di Windows Server 2008, specificare 6.0.6001.18000.

Per individuare questi valori per un'immagine

  1. Individuare l'immagine nello snap-in MMC Servizi di distribuzione Windows.

  2. Fare clic con il pulsante destro del mouse sull'immagine e scegliere Proprietà.

  3. Nella scheda Versione fare clic su Versione immagine e prendere nota del valore nella colonna di destra. Si noti che in questo valore manca la parte NumeroServicePack, ovvero il valore è nel formato VersionePrincipale.VersioneSecondaria.NumeroBuild.

  4. Per individuare il valore NumeroServicePack, fare clic su Livello Service Pack. Il valore è presente nella colonna destra.

  5. Per creare un filtro con il formato corretto, inserire il valore NumeroServicePack dopo VersionePrincipale.VersioneSecondaria.NumeroBuild. Se ad esempio è specificato 6.1.7025 e il numero di Service Pack è 2, specificare 6.1.7025.2 come valore per questo filtro.

Edizione sistema operativo

Stringa

Edizione dell'immagine scelta dall'utente. Ad esempio: BUSINESS oppure ULTIMATE. È possibile trovare Edizione sistema operativo utilizzando Gestione e manutenzione immagini distribuzione (DISM.exe).

Per visualizzare l'edizione del sistema operativo del computer

  1. Se il computer esegue Windows Vista con SP1 o la versione iniziale di Windows Server 2008, installare la versione più recente di Windows Automated Installation Kit (Windows AIK).

  2. Aprire un prompt dei comandi con privilegi elevati facendo clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliendo Esegui come amministratore.

  3. Eseguire Dism /online /Get-CurrentEdition.

Per visualizzare l'edizione del sistema operativo di un'immagine

  1. Esportare l'immagine in un nuovo file. A tale scopo, fare clic con il pulsante destro del mouse sullo snap-in MMC, scegliere Esporta, assegnare un nome al file e fare clic su Salva.

  2. Aprire un prompt dei comandi con privilegi elevati facendo clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliendo Esegui come amministratore.

  3. Montare l'immagine utilizzando la sintassi seguente:

    Dism /Mount-Wim /WimFile:<percorso_file_WIM> /index:<indice_immagine> /MountDir:<directory_di_montaggio_di_destinazione>

    Esempio: Dism /Mount-Wim /WimFile:C:\test\images\install.wim /index:1 /MountDir:C:\test\offline

  4. Per recuperare informazioni sull'edizione corrente, eseguire Dism /image:C:\test\offline /Get-CurrentEdition.

Lingua sistema operativo

Stringa in formato XX-XX

Lingua dell'immagine nel formato <lingua>-<PAESE>, dove <lingua> è il codice della lingua ISO 639 in caratteri minuscoli e <PAESE> è l'identificatore del paese ISO 3166-1 in caratteri maiuscoli. Le specifiche della lingua valide sono elencate nella colonna relativa al nome della lingua nella pagina di informazioni su NLS (National Language Support) (http://go.microsoft.com/fwlink/?LinkId=86010). Ad esempio, en-US, ar-SA e de-DE.

Esempi

Filtri Risultato

Filtri hardware:

  • Produttore | Uguale a | Fabrikam, Inc.

  • Tipo chassis | Diverso da | Laptop

Filtri per le immagini di installazione:

  • Versione sistema operativo | Uguale a | 6.0. 6001.18000

  • Edizione sistema operativo | Diverso da | Business

Applicabilità: Pacchetti driver compatibili con l'hardware client

I soli client ad avere accesso a questi driver sono i computer Fabrikam, Inc. che non sono portatili. Di tali computer, solo i client che selezionano un'immagine Windows Vista con SP1 che non sia Windows Vista Business avranno accesso a questi driver. L'impostazione di applicabilità indica che, per i client che hanno accesso al gruppo di driver, verranno installati solo i pacchetti compatibili con l'hardware del client.

Filtri hardware:

  • UUID | Uguale a | {E8A3EFAC-201F-4E69-953E-B2DAA1E8B1B6}

Filtri per le immagini di installazione:

  • Edizione sistema operativo | Diverso da | Ultimate

Applicabilità: Pacchetti driver compatibili con l'hardware client

Il solo client con accesso a questi driver è il client con lo UUID specificato e solo se tale client seleziona un'immagine diversa da un'immagine Windows Vista Ultimate. L'impostazione di applicabilità indica che, per i client che hanno accesso al gruppo di driver, verranno installati solo i pacchetti compatibili con l'hardware del client.

Filtri hardware: nessuno

Filtri per le immagini di installazione:

  • Versione sistema operativo | Uguale a| 6.0.6001.18000

  • Lingua | Diverso da | en-us

Applicabilità: Tutti i pacchetti del gruppo

Solo i client che selezionano un'immagine Windows Vista con SP1 non in lingua inglese (Stati Uniti) avranno accesso a questi driver. L'impostazione di applicabilità indica che, per i client che hanno accesso al gruppo di driver, verranno installati tutti i pacchetti driver di questo gruppo, anche quelli per cui il client non dispone di hardware.

Ulteriori riferimenti

  • Distribuire pacchetti driver

  • Attributi di driver e pacchetti


Attributi di driver e pacchetti

Dopo che i pacchetti driver sono stati aggiunti nel server, è possibile eliminarli, abilitarli o disabilitarli oppure aggiungerne una selezione a un gruppo di driver.

  • Per eliminare, abilitare o disabilitare i pacchetti driver, fare clic con il pulsante destro del mouse sul nodo Driver, quindi scegliere l'attività che si desidera eseguire.

  • Per aggiungere pacchetti a un gruppo, fare clic con il pulsante destro del mouse sul gruppo di driver e scegliere Aggiungi pacchetti driver al gruppo.

In questo argomento sono contenute informazioni sugli attributi in base ai quali è possibile eseguire la ricerca per eseguire queste attività. Per istruzioni su come configurare questi attributi per la distribuzione dei pacchetti driver, vedere Distribuire pacchetti driver.

  • Attributi dei pacchetti driver

  • Attributi dei file driver

Attributi dei pacchetti driver

Gli attributi seguenti si applicano all'intero pacchetto driver. Un pacchetto driver è costituito da un insieme di componenti software necessari affinché un dispositivo sia supportato da Windows, ad esempio i file dei driver, in genere con l'estensione di file sys, e i file di installazione. Per ulteriori informazioni sui pacchetti driver, visitare il sito Web all'indirizzo http://go.microsoft.com/fwlink/?LinkId=143447.

Tipo di attributo Valori accettati Descrizione ed esempi

ID pacchetto

GUID nel formato {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}

GUID generato in modo casuale quando un pacchetto driver viene aggiunto a un server Servizi di distribuzione Windows. Per trovare questo numero per un pacchetto, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto e quindi scegliere Proprietà. L'ID pacchetto è elencato nella scheda Generale. Ad esempio: {DD098D20-1850-4FC8-8E35-EA24A1BEFF5E}.

Nome pacchetto

Stringa

Nome del pacchetto nel server. Per impostazione predefinita, il nome è InfFilename [arch]. Per trovare questo valore, fare clic sul gruppo di driver che contiene il pacchetto o sul nodo Tutti i pacchetti, individuare il pacchetto driver e visualizzare la colonna Nome pacchetto.

Pacchetto abilitato

Sì|No

Specifica se il pacchetto è abilitato o meno nel server. I pacchetti disabilitati non sono disponibili per i client. Per visualizzare questo valore, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto e quindi scegliere Proprietà. Lo Stato è elencato nella scheda Generale.

Data aggiunta pacchetto

Data

Data in cui il pacchetto è stato aggiunto al server Servizi di distribuzione Windows. Per trovare questo valore, fare clic sul gruppo di driver che contiene il pacchetto o sul nodo Tutti i pacchetti, individuare il pacchetto driver e visualizzare la colonna Data aggiunta. Se si gestiscono server in fusi orari diversi, si noti che questa data corrisponde all'ora locale per il server e non all'ora UTC (Coordinated Universal Time).

Nome file INF pacchetto

Stringa

Nome del file con estensione inf associato al pacchetto driver. Per trovare questo valore, fare clic sul gruppo di driver che contiene il pacchetto o sul nodo Tutti i pacchetti, individuare il pacchetto driver e visualizzare la colonna Nome file. È necessario specificare il nome con l'estensione inf.

Classe pacchetto

Stringa o GUID

Nome o GUID di classe valido. Per un elenco di nomi o GUID di classe, vedere la pagina relativa alle classi di configurazione dei dispositivi fornite dal sistema (http://go.microsoft.com/fwlink/?LinkId=143448). Per trovare questo valore, fare clic sul gruppo di driver che contiene il pacchetto o sul nodo Tutti i pacchetti, individuare il pacchetto driver e visualizzare le colonne Nome classe e GUID classe. È possibile, ad esempio, specificare Net o {4D36E972-E325-11CE-BFC1-08002BE10318}.

Fornitore pacchetto

Stringa

Società che ha reso disponibile il pacchetto driver definita nel file con estensione inf del pacchetto. Per individuare questo valore, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto driver e quindi scegliere Proprietà. Il Fornitore è elencato nella scheda Generale. Ad esempio: SigmaTel oppure Microsoft.

Architettura

X86|x64|ia64

Architettura del pacchetto. Per trovare questo valore, fare clic sul gruppo di driver che contiene il pacchetto o sul nodo Tutti i pacchetti, individuare il pacchetto driver e visualizzare la colonna Architettura.

Impostazioni locali pacchetto

Stringa in formato XX-XX

Impostazioni locali del pacchetto. Sebbene di rado, alcuni file del pacchetto con estensione inf indicano che un pacchetto è valido solo per impostazioni locali specifiche. In questi casi, è possibile cercare le impostazioni locali utilizzando questo attributo. Per individuare questo valore, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto driver e quindi scegliere Proprietà. Le Impostazioni locali sono elencate nella scheda Generale.

La lingua è nel formato <lingua>-<PAESE>, dove <lingua> è il codice della lingua ISO 639 in caratteri minuscoli e <PAESE> è l'identificatore del paese ISO 3166-1 in caratteri maiuscoli. Le specifiche della lingua valide sono elencate nella colonna relativa al nome della lingua nella pagina di informazioni su NLS (National Language Support) (http://go.microsoft.com/fwlink/?LinkId=86010). Ad esempio, en-US, ar-SA e de-DE.

Pacchetto firmato

Sì|No

Specifica se il pacchetto driver dispone di un file delle firme. Si noti che Servizi di distribuzione Windows non determina se la firma è attendibile nel server Servizi di distribuzione Windows, ma solo se si tratta di un file delle firme valido. Per individuare questo valore, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto driver e quindi scegliere Proprietà. La Firma pacchetto è elencata nella scheda Generale.

Data pubblicazione pacchetto

Data

Data in cui il pacchetto è stato rilasciato dal produttore elencata nel file con estensione inf. Per trovare questo valore, fare clic sul gruppo di driver che contiene il pacchetto o sul nodo Tutti i pacchetti, individuare il pacchetto driver e visualizzare la colonna Data pacchetto.

Versione pacchetto

Stringa

Versione del pacchetto specificata nel file con estensione inf. Per trovare questo valore, fare clic sul gruppo di driver che contiene il pacchetto o sul nodo Tutti i pacchetti, individuare il pacchetto driver e visualizzare la colonna Versione. Ad esempio: 2.1.2.

Attributi dei file driver

Gli attributi seguenti, ad eccezione di Nome gruppo driver sono relativi ai singoli driver contenuti nei pacchetti driver. Per visualizzare un elenco dei driver, fare clic con il pulsante destro del mouse su un pacchetto driver, scegliere Proprietà e selezionare la scheda Driver.

Tipo di attributo Valori accettati Descrizione ed esempi

Descrizione driver

Stringa

Descrizione del driver contenuta nel file con estensione inf. Per visualizzare la descrizione di un driver, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto driver e quindi scegliere Proprietà. I driver e le descrizioni sono elencati nella scheda Driver.

Produttore driver

Stringa

Produttore del driver indicato nel file con estensione inf del pacchetto. Per visualizzare il produttore di un driver, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto driver e quindi scegliere Proprietà. I driver e i produttori sono elencati nella scheda Driver.

ID hardware driver

Stringa

Gli ID hardware driver, gli ID compatibili driver e gli ID esclusione driver sono stringhe di identificazione dei dispositivi definite dal fornitore utilizzate dal programma di installazione per associare un dispositivo a un file con estensione inf. Questi ID sono ID Plug and Play che fanno riferimento ai pacchetti driver. Se ad esempio un driver è valido per una scheda di rete specifica, l'ID dispositivo della scheda di rete sarà un ID hardware driver relativo al driver. Se il driver è generico e funziona in qualsiasi versione della scheda di rete, l'ID dispositivo corrispondente sarà elencato come ID compatibile driver. Se infine esiste una versione della scheda per cui questo driver non è valido, l'ID dispositivo per tale scheda sarà elencato come ID esclusione driver, anche se ciò accade di rado.

Per individuare questi valori, fare clic sul gruppo di driver che contiene il pacchetto (o sul nodo Tutti i pacchetti), fare clic con il pulsante destro del mouse sul pacchetto driver e quindi scegliere Proprietà. Gli ID sono elencati nella scheda Driver in ID Plug-and-Play. Gli ID hardware driver presentano un asterisco (*) davanti all'ID, gli ID compatibili driver presentano un segno più (+) davanti all'ID e gli ID esclusione driver presentano un segno meno (-).

ID compatibile driver

Stringa

Vedere “ID hardware driver”.

ID esclusione driver

Stringa

Vedere “ID hardware driver”.

Nome gruppo driver

Stringa

Nome del gruppo di driver nel server in cui si trova il pacchetto. È possibile utilizzare questo attributo per restringere la ricerca a uno o più gruppi di driver. Per visualizzare i gruppi in cui un pacchetto driver è contenuto, individuare il pacchetto nel nodo Tutti i pacchetti, fare clic con il pulsante destro del mouse sul pacchetto, scegliere Proprietà e quindi visualizzare la scheda Appartenenza a gruppi.

Ulteriori riferimenti

  • Distribuire pacchetti driver

  • Filtri del gruppo di driver