Windows Server Update Services

Windows Server® Update Services (WSUS) consente agli amministratori IT di distribuire gli ultimi aggiornamenti dei prodotti Microsoft ai computer che eseguono sistemi operativi Microsoft supportati. Per informazioni sui sistemi operativi supportati e su altri requisiti di sistema per Windows Server Update Services, vedere le note sulla versione di Windows Server Update Services.

Mediante Windows Server Update Services, gli amministratori possono gestire completamente la distribuzione di aggiornamenti rilasciati tramite Microsoft Update ai computer di rete. Windows Server Update Services offre un'infrastruttura di gestione costituita dai componenti seguenti:

  • Microsoft Update: sito Web Microsoft che distribuisce gli aggiornamenti di prodotti Microsoft.

  • Server Windows Server Update Services: componente installato in un server all'interno del firewall aziendale. Il server WSUS consente agli amministratori di gestire e distribuire gli aggiornamenti tramite la console di amministrazione di Windows Server Update Services, che può essere installata in tutti i computer basati su Windows inclusi nel dominio. Tale server può inoltre costituire l'origine degli aggiornamenti per altri server WSUS all'interno dell'organizzazione. Per ottenere le informazioni di aggiornamento disponibili, è necessario connettere almeno un server WSUS di rete a Microsoft Update. In base alla sicurezza e alla configurazione di rete, l'amministratore può determinare se è necessario connettere direttamente altri server a Microsoft Update.

  • Aggiornamenti automatici: componente incorporato nei sistemi operativi supportati che consente ai computer server e client di ricevere gli aggiornamenti da Microsoft Update o da un server WSUS.

Elenchi di controllo di Windows Server Update Services e argomenti introduttivi

Gli elenchi di controllo e gli argomenti seguenti rappresentano un'introduzione alla configurazione di Windows Server Update Services.

  • Elenco di controllo: ottenere la scalabilità verticale della rete di Windows Server Update Services

  • Elenco di controllo: ottenere gli aggiornamenti Microsoft

  • Elenco di controllo: garantire la distribuzione degli aggiornamenti all'organizzazione

  • Elenco di controllo: ricevere tempestivamente notifiche relative agli aggiornamenti

  • Elenco di controllo: distribuire gli aggiornamenti nell'ora più appropriata

  • Elenco di controllo: garantire la distribuzione degli aggiornamenti ai diversi gruppi di computer

  • Elenco di controllo: risolvere i problemi comuni del server WSUS

  • Progettare la rete di Windows Server Update Services

  • Configurare SSL per Windows Server Update Services

Ulteriori riferimenti

Per informazioni complete sull'installazione e sull'utilizzo di Windows Server Update Services, vedere le risorse seguenti:

Guida dettagliata all'installazione di Windows Server Update Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139836

Guida alla distribuzione di Windows Server Update Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139832

Guida operativa per WSUS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139838

Note sulla versione di Windows Server Update Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139840

Guida della console di amministrazione di Windows Server Update Services


Elenco di controllo: ottenere la scalabilità verticale della rete di Windows Server Update Services

È possibile configurare una gerarchia di server Windows Server Update Services (WSUS) per distribuire gli aggiornamenti negli uffici di diversi reparti, unità organizzative o aree geografiche. Il server WSUS di primo livello comunica direttamente con Microsoft Update, mentre i server WSUS downstream comunicano con il server upstream.

Progettare gerarchie di server WSUS

Passaggio Riferimento
Casella di controllo

Decidere come collegare i server WSUS. A tale scopo è possibile procedere in due modi:

Modalità autonoma: un server WSUS upstream condivide gli aggiornamenti con i relativi server downstream durante la sincronizzazione, ma non condivide le informazioni relative allo stato di approvazione degli aggiornamenti o ai gruppi di computer. È necessario amministrare separatamente i server WSUS downstream. I server autonomi possono inoltre sincronizzare gli aggiornamenti per un set di lingue corrispondente a un sottoinsieme del set sincronizzato dal relativo server upstream.

Modalità di replica: un server WSUS upstream condivide aggiornamenti, stato di approvazione e gruppi di computer con i relativi server downstream. I server di replica downstream ereditano le approvazioni degli aggiornamenti e non è possibile amministrarli separatamente dal relativo server WSUS upstream.

Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832

Casella di controllo

Se sono disponibili più server downstream, non configurarli in modo da sincronizzare gli aggiornamenti ed eseguire il rollup dei risultati nella stessa ora del giorno. I server downstream eseguono il rollup delle informazioni nel relativo server upstream subito dopo la sincronizzazione. Tale operazione può causare un traffico elevato nel server upstream ed errori di rollup. Per evitare che si verifichi questo problema, configurare server downstream diversi in modo che la sincronizzazione venga eseguita in ore diverse del giorno.

Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832

Casella di controllo

Quando si configura un server downstream, verificare che le lingue supportate per gli aggiornamenti corrispondano a quelle supportate nel relativo server upstream o a un sottoinsieme. Se in un server downstream si sceglie una lingua non supportata in un server upstream, non è possibile ottenere aggiornamenti in tale lingua.

Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832

Ulteriori riferimenti

Per istruzioni sull'installazione di Windows Server Update Services, vedere la relativa guida dettagliata all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139836.

Per informazioni sulla gestione di Windows Server Update Services, vedere la Guida operativa per WSUS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139838.

Vedere anche

  • Windows Server Update Services


Elenco di controllo: ottenere gli aggiornamenti Microsoft

Per configurare il server Windows Server Update Services (WSUS), specificare i prodotti, le classificazioni e le lingue per cui si desidera ricevere gli aggiornamenti, nonché i diversi gruppi di computer a cui è necessario distribuire gli aggiornamenti. È quindi possibile avviare la prima sincronizzazione in cui il server WSUS otterrà gli aggiornamenti specificati da Microsoft Update.

Configurare il server WSUS

 | Passaggio | Riferimento
Casella di controllo | Verificare che il server in cui si desidera installare Windows Server Update Services soddisfi i requisiti minimi di sistema. | Note sulla versione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139840
Casella di controllo | Se si dispone di un firewall o di un server proxy, verificare che Windows Server Update Services abbia accesso agli aggiornamenti su Internet prima di configurare il server WSUS. | Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832
Casella di controllo | Installare Windows Server Update Services ed eseguire la relativa Installazione guidata. | Guida dettagliata di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139836

Ulteriori riferimenti

Per informazioni sulla gestione di Windows Server Update Services, vedere la Guida operativa per WSUS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139838.

Vedere anche


Elenco di controllo: garantire la distribuzione degli aggiornamenti all'organizzazione

Se un aggiornamento viene installato innanzitutto in un ambiente di prova, è possibile valutarne l'impatto prima di decidere se implementarlo o meno nei sistemi di produzione. Questo approccio consente di evitare tempi di inattività imprevisti e la perdita di produttività.

Per testare gli aggiornamenti che si desidera distribuire in rete, configurare un ambiente di prova costituito da computer che utilizzano il software da aggiornare e le altre applicazioni utilizzate nell'ambiente di produzione. È possibile creare più gruppi di computer di prova che utilizzano configurazioni diverse analoghe a quelle dei computer presenti in reparti diversi dell'organizzazione. Se l'esito del test è positivo, sarà possibile distribuire gli aggiornamenti agli altri computer.

Configurare un ambiente di prova per gli aggiornamenti

 | Passaggio | Riferimento
Casella di controllo | Creare uno o più gruppi di computer personalizzati da utilizzare come ambiente di prova. | Guida dettagliata di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139836
Casella di controllo | Spostare alcuni computer rappresentativi nei gruppi di test. | Guida dettagliata di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139836

Ulteriori riferimenti

Per ulteriori informazioni sulla configurazione e sull'utilizzo di un ambiente di prova per gli aggiornamenti, vedere la guida alla distribuzione di Windows Server Update Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139832.

Vedere anche


Elenco di controllo: ricevere tempestivamente notifiche relative agli aggiornamenti

È possibile configurare il server Windows Server Update Services (WSUS) per inviare notifiche tramite posta elettronica relative a nuovi aggiornamenti e rapporti sullo stato della rete di Windows Server Update Services. Le notifiche vengono inviate quando il server WSUS sincronizza i nuovi aggiornamenti e i rapporti sullo stato possono essere aggiornati su base giornaliera o settimanale. Per selezionare gli utenti che riceveranno gli aggiornamenti tramite posta elettronica, è possibile aggiungerli al gruppo di account WSUS Administrators o al gruppo WSUS Reporters. È quindi possibile configurare il server WSUS per l'invio di notifiche agli utenti selezionati.

Configurare una notifica tramite posta elettronica

È possibile modificare le credenziali di autenticazione solo in un server WSUS, non da una console di amministrazione remota.

 | Passaggio | Riferimento
Casella di controllo | Configurare notifiche tramite posta elettronica relative a nuovi aggiornamenti e rapporti sullo stato della rete di Windows Server Update Services e del server WSUS. | Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832
Casella di controllo | Configurare il server di posta elettronica. | Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832

Ulteriori riferimenti

Per ulteriori informazioni sui rapporti di Windows Server Update Services, vedere la Guida operativa per WSUS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139838.

Vedere anche


Elenco di controllo: distribuire gli aggiornamenti nell'ora più appropriata

Per ridurre il traffico di rete e causare il minimo disagio per gli utenti è possibile pianificare gli aggiornamenti impostando Aggiornamenti automatici nei computer client affinché gli aggiornamenti vengano installati in un giorno e a un'ora specifici.

Pianificare gli aggiornamenti

 | Passaggio | Riferimento
Casella di controllo | Se questa operazione non è già stata eseguita, installare Windows Server Update Services ed eseguire la relativa Installazione guidata. | Guida dettagliata di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139836
Casella di controllo | Configurare gli aggiornamenti automatici. | Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832

Ulteriori riferimenti

Per ulteriori informazioni sulla procedura consigliata per la distribuzione degli aggiornamenti, vedere la Guida operativa per WSUS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139838.

Vedere anche


Elenco di controllo: garantire la distribuzione degli aggiornamenti ai diversi gruppi di computer

Windows Server Update Services (WSUS) consente di inviare gli aggiornamenti ai gruppi di computer client di destinazione, in modo che i computer specifici possano ricevere sempre gli aggiornamenti applicabili. È possibile creare gruppi di computer organizzati in gerarchie, ad esempio il gruppo Retribuzioni e il gruppo Contabilità fornitori sotto il gruppo Contabilità. Gli aggiornamenti approvati per un gruppo di livello superiore verranno distribuiti ai gruppi di livello inferiore.

È innanzitutto necessario configurare i computer client per contattare il server WSUS prima di assegnarli ai gruppi e gestirli da tale server. È possibile assegnare i computer ai gruppi di computer utilizzando uno dei due metodi denominati rispettivamente destinazione lato server e destinazione lato client. Con la destinazione lato server si spostano manualmente uno o più computer client alla volta in un gruppo di computer. Con la destinazione lato client si utilizzano i Criteri di gruppo o si modificano le impostazioni del Registro di sistema nei computer client per abilitare l'aggiunta automatica di tali computer ai gruppi di computer creati in precedenza.

Distribuzione di Windows Server Update Services mediante gruppi di computer

 | Passaggio | Riferimento
Casella di controllo | Configurare i computer client per contattare il server WSUS. | Guida dettagliata di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139836
Casella di controllo | Creare i gruppi di computer in Windows Server Update Services. | Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832
Casella di controllo | Assegnare i computer ai gruppi di computer. | Guida alla distribuzione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139832

Ulteriori riferimenti

Per ulteriori informazioni sulla gestione dei gruppi di computer WSUS, vedere la Guida operativa per WSUS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139838.

Vedere anche


Elenco di controllo: risolvere i problemi comuni del server WSUS

Se dopo l'installazione di Windows Server Update Services (WSUS) si verificano problemi nel server, è possibile risolverli utilizzando la Guida operativa per WSUS in cui sono disponibili informazioni dettagliate sulla risoluzione dei problemi comuni relativi ai computer client, degli errori di download e di installazione e dei problemi di altro tipo.

Se non si riesce a installare Windows Server Update Services, la causa consiste probabilmente in un problema di rete o nel fatto che sono stati soddisfatti i requisiti minimi di sistema e i prerequisiti hardware e software.

Risolvere i problemi relativi a Windows Server Update Services

 | Passaggio | Riferimento
Casella di controllo | Se viene visualizzato il messaggio "Impossibile trovare l'aggiornamento. Potrebbe essersi verificato un problema di connessione di rete." durante il tentativo di installazione di Windows Server Update Services, vedere le informazioni contenute nella guida per la risoluzione dei problemi di Centro connessioni di rete e condivisione. | Guida per la risoluzione dei problemi di Centro connessioni di rete e condivisione http://go.microsoft.com/fwlink/?LinkId=140135
Casella di controllo | Se durante il tentativo di installazione di Windows Server Update Services viene visualizzato un messaggio di errore diverso, è possibile che non siano stati soddisfatti tutti i requisiti minimi di sistema indicati nelle note sulla versione. | Note sulla versione di Windows Server Update Services http://go.microsoft.com/fwlink/?LinkId=139840
Casella di controllo | Se dopo l'installazione si verificano problemi in Windows Server Update Services, vedere la Guida operativa per WSUS. | Guida operativa per WSUS http://go.microsoft.com/fwlink/?LinkId=139838

Ulteriori riferimenti

Per ulteriori informazioni sulla configurazione e sull'utilizzo di WSUS, vedere la guida alla distribuzione di Windows Server Update Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139832.

Vedere anche


Progettare la rete di Windows Server Update Services

Il primo passaggio della distribuzione di Windows Server Update Services (WSUS) consiste nel progettare la configurazione del server, ovvero una configurazione semplice con un unico server o una configurazione complessa con più server WSUS. Tra gli elementi da tenere in considerazione sono inclusi la larghezza di banda della connessione (sia per connessioni Internet che per connessioni LAN o WAN), la configurazione di rete e i diversi requisiti relativi alla lingua.

Ulteriori riferimenti

Per istruzioni sull'installazione di Windows Server Update Services, vedere la relativa guida dettagliata all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139836.

Per informazioni sulla progettazione e sulla gestione della rete di Windows Server Update Services, vedere le risorse seguenti:

  • Guida alla distribuzione di Windows Server Update Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139832

  • Guida operativa per WSUS all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139838

Vedere anche


Configurare SSL per Windows Server Update Services

È possibile utilizzare il protocollo SSL (Secure Sockets Layer) per proteggere la distribuzione di Windows Server® Update Services (WSUS) in cui SSL viene utilizzato per consentire ai computer client e ai server WSUS downstream di autenticare il server WSUS, nonché per crittografare i metadati passati tra i computer client e i server WSUS downstream. Tenere presente che SSL viene utilizzato in Windows Server Update Services solo per i metadati, non per il contenuto. Consente inoltre a Microsoft Update di distribuire gli aggiornamenti.

Gli aggiornamenti sono costituiti da due tipi di componenti:

  • I metadati che descrivono l'aggiornamento

  • I file necessari per installare l'aggiornamento in un computer

Microsoft consente di ridurre il rischio che i file di aggiornamento vengano inviati attraverso un canale non crittografato inserendo una firma in ogni aggiornamento, per il quale viene inoltre calcolato e inviato un hash insieme ai metadati. Quando viene scaricato un aggiornamento, Windows Server Update Services verifica la firma digitale e l'hash. Se l'aggiornamento è stato modificato, non viene installato.

Per informazioni dettagliate sulla configurazione di SSL nel server WSUS e nel client WSUS, vedere la guida alla distribuzione di Windows Server Update Services all'indirizzo http://go.microsoft.com/fwlink/?LinkId=139832.

Limiti delle distribuzioni di Windows Server Update Services con SSL

Gli amministratori che pianificano l'implementazione delle distribuzioni di Windows Server Update Services con SSL devono tenere in considerazione due limiti:

  1. La protezione della distribuzione di Windows Server Update Services con SSL aumenta il carico di lavoro del server. È consigliabile pianificare una perdita di prestazioni del 10% a causa del costo aggiuntivo della crittografia di tutti i metadati inviati in rete.

  2. Se si utilizza un server SQL remoto, la connessione tra il server WSUS e il server che esegue il database non viene protetta mediante SSL. Se è necessario proteggere la connessione al database, tenere presenti le indicazioni seguenti:

    • Posizionare il database nel server WSUS (configurazione predefinita di Windows Server Update Services).

    • Posizionare il server remoto che esegue SQL e il server WSUS in una rete privata.

    • Distribuire IPsec in rete per proteggere il traffico di rete. Per ulteriori informazioni sulla distribuzione di IPsec nell'ambiente in uso, vedere la guida alla distribuzione di Windows Server http://go.microsoft.com/fwlink/?LinkId=45154.

Ulteriori riferimenti

La configurazione di un'Autorità di certificazione (CA), il binding di un certificato al sito Web Windows Server Update Services e il successivo bootstrap dei computer client per considerare attendibile il certificato in tale sito Web sono attività amministrative complesse. Le procedure dettagliate per ogni attività non rientrano nell'ambito di questo argomento. In merito sono tuttavia disponibili diversi articoli. Per ulteriori informazioni e istruzioni sull'installazione dei certificati e sulla configurazione dell'ambiente in uso, vedere le risorse seguenti:

  • Nella guida operativa per l'infrastruttura a chiave pubblica di Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=83159) sono disponibili indicazioni per consentire agli amministratori di configurare e utilizzare un'Autorità di certificazione di Windows.

  • Nell'articolo 299875 della Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=86176) sono disponibili istruzioni dettagliate per l'implementazione di SSL in IIS.

  • Nella pagina relativa alla registrazione automatica dei certificati in Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=17801) sono disponibili istruzioni relative alla registrazione automatica dei computer client che eseguono Windows XP in ambienti Windows Server 2003 Enterprise integrati con Active Directory.

  • Nella pagina relativa alla registrazione e gestione avanzate dei certificati (http://go.microsoft.com/fwlink/?LinkId=83160) sono disponibili indicazioni relative alla registrazione automatica dei computer client in altri ambienti.

Vedere anche